Grasshopper SDK

[image]

Send Feedback

This help-file contains information for those who wish to develop custom components, parameters and data-types for Grasshopper®.

Development

The first section (Development) in this help file contains vital facts, useful information and guidelines for custom component development. It outlines the architecture of the Grasshopper plugin, which libraries are essential for compilation and how to load and debug your custom components.

Examples

This section contains a number of examples of custom components, data types and parameters, as well as some generally useful tips and tricks.

Reference

The remaining sections are Reference sections which list all (useful) classes and functions in the GH_IO.dll and Grasshopper.dll libraries. GH_IO is required for (de)serialization, but it is unlikely you will be directly confronted with it if your primary goal is to develop custom Components.

Send comments on this topic to Grasshopper development

Copyright © 2009 Robert McNeel & Associates


GrasshopperLicense

[image]

Grasshopper SDK
GrasshopperLicense
Send Feedback

Grasshopper® License Agreement (Robert McNeel & Associates)

Monday August 24, 2009

  • Introduction
  • Definitions
  • Software License
  • Prohibited & Permitted Actions
  • All Rights Reserved
  • Warranty
  • Liability

——————————

License Agreement

Read carefully: Robert McNeel & Associates, ("RMA") licenses this software ("Grasshopper®") to you only upon the condition that you accept all of the terms contained in this software license agreement ("Agreement"). If you do not agree or do not wish to bind yourself or the entity you represent:

  • do not copy, upload, access or use Grasshopper
  • uninstall Grasshopper and delete all SDK documentation files from your computer
Copying, uploading, access or use of Grasshopper or any accompanying documentation or materials except as permitted by agreement is unauthorized and constitutes a material breach of this agreement and an infringement of the copyright and other intellectual property rights in such software and documentation. If you copy, upload, access or use all or any portion of Grasshopper or its user documentation without entering into this agreement or otherwise obtaining written permission of RMA, you are violating copyright and other intellectual property law. You may be liable to RMA for damages, and you may be subject to criminal penalties.

Section | Definitions
1.1 | "Access" means to use or benefit from using the functionality of Grasshopper.
1.2 | "RMA Materials" is the collective term for the Software, User Documentation and Excluded Materials.
1.3 | "Computer" means a single electronic device with one or more central processing units (CPUs) that accepts information in digital or similar form and manipulates the information for a specific result based on a sequence of instructions.
1.4 | "You" means you personally (i.e., the individual who reads and is prompted to accept this Agreement) if you acquire Grasshopper for yourself or the company or other legal entity for whom you acquire Grasshopper.
Section | Software License
2.1 | License Grant. RMA grants you a non-sublicensable, limited license to use copies of Grasshopper, within the scope of the License Parameters. RMA's license grant is conditioned on Your continuous compliance with all license limitations and restrictions described in this Agreement. If you violate any of these limitations or restrictions, the license grant will automatically and immediately expire. The license descriptions in this Section 2 (Software License) define the scope of rights that RMA grants to you. Any usage of Grasshopper outside the scope of the applicable license grant constitutes an infringement of RMA’s intellectual property rights as well as a material breach of this Agreement. No license is granted under the terms of this Agreement if you did not lawfully acquire the Software.
Section | Permitted & Prohibited Actions
3.1 | Permitted Actions
3.1.1 | Backup Copy. With respect to any version of Grasshopper, you may make unlimited backup copies of Grasshopper for backup purposes in the event that your primary copy of Grasshopper becomes inoperable.
3.1.2 | Installations. With respect to any version of Grasshopper, you may install unlimited copies of Grasshopper for usage purposes.
3.2 | Prohibited Actions. RMA does not permit any of the following actions and you acknowledge that such actions shall be prohibited:
3.2.1 | Reverse Engineering. You may not (and may not permit any third party to) reverse engineer, decompile, or disassemble Grasshopper.
3.2.2 | Transfers. You may not rent, loan, lease, sell, sublicense, or otherwise transfer all or any portion of Grasshopper, or any rights granted in this Agreement, to any other person without the prior written consent of RMA.
3.2.3 | Notices. You may not remove, alter, or obscure any proprietary notices, labels, or marks from the RMA Materials.
3.2.4 | Modifications. You may not modify or create derivative works based on the RMA Materials for any purpose.
3.2.5 | Circumvention. You may not utilize any equipment, device, software, or other means designed to circumvent or remove any form of copy protection used by RMA in connection with Grasshopper, or use Grasshopper together with any, authorization code, serial number, or other copy protection device not supplied by RMA directly or through an authorized distributor.
Section | All Rights Reserved
4.1 | Except as expressly provided otherwise in this Agreement, title, ownership and all rights and interest including, without limitation, patents, copyrights, trademarks, trade secrets and other intellectual property rights, in and to the RMA Materials and any authorized copies made by you remain with RMA. The structure, organization, and code of the RMA Materials are somewhat valuable trade secrets of RMA and you shall keep such trade secrets confidential. The Software and User Documentation are licensed, not given away for free.
Section | Limited Warranty & Disclaimers
5.1 | RMA makes and you receive no express warranties. Any statements or representations about the software and its functionality in the user documentation or any communication with you constitute technical information and not an express warranty or guarantee. In addition, RMA specifically disclaims any other warranty including, without limitation, the implied warranty of merchantability, fitness for a particular purpose and non-infringement. Without limiting the foregoing, RMA does not warrant that the operation of the software will be uninterrupted or error free.
Section | Limitations of Liability
6.1 | In no event shall RMA have any liability for any incidental, special, indirect, or consequential damages, loss of profits, revenue, data, or cost of cover. In addition, in no event shall the liability of rma for any damages arising out of or in connection with the software, user documentation or this agreement exceed the amount paid or payable by you for the software directly responsible for such damages. The limitations of liability in this section 6 shall apply to any damages, however caused and regardless of the theory of liability, whether derived from contract, tort (including, but not limited to, negligence), or otherwise, even if RMA has been advised of the possibility of such damages and regardless of whether the limited remedies available hereunder fail of their essential purpose.
6.2 | RMA shall have no responsibility or liability whatsoever arising from loss or theft of the software or the media on which the software is furnished to you. RMA shall not be obligated to replace any lost or stolen software or software media. You are solely responsible for safeguarding the software and the media on which the software is furnished.


Development

[image]

Grasshopper SDK
Development
Send Feedback

This section describes the architecture of the Grasshopper plugin. This includes the layout of namespaces and classes within the Grasshopper.dll, but also the hierarchy of referenced assemblies.


GHA Assembly Wizards

[image]

Grasshopper SDK
GHA Assembly Wizards
Send Feedback

Giulio Piacentino has written an excellent assembly wizard for GHA projects which is hosted on the Microsoft Visual Studio Gallery. This wizard requires Visual Studio 2010, but is a far superior way to create a GHA project than following the manual steps outlined below.


Assembly Hierarchy

[image]

Grasshopper SDK
Assembly Hierarchy
See Also Send Feedback

  • Rhino Plug-in Architecture
  • DotNET Component Library
  • Assembly References

This document explains the hierarchy of all assemblies involved with the Grasshopper® plug-in. This is important for component developers so they know which Assembly References they need to have in order to compile a Grasshopper Component Library. It also provides some background information which is useful when communicating with other developers.

Rhino Plug-in Architecture

Grasshopper is a DotNET plug-in for Rhinoceros® 4.0 SR7 and later. It was written using Microsoft® Visual Studio® 2008 Professional using both VB.NET and C# source compiled against the DotNET 2.0 Framework. It is recommended, though not required, that you target the same framework when developing Grasshopper Component Libraries.

Our aim is to keep Grasshopper dependencies as conservative as possible. However, it is possible that we will switch to a higher version number of Rhino or DotNET if this new version fixes crucial bugs or exposes useful functions.

In order to inter-operate with the Rhino C++ SDK, Grasshopper uses the RhinoCommon.dll wrapper SDK which is being developed for both Rhino5 and RhinoMac. Grasshopper uses a special build of this SDK in order to run on Rhino4.

DotNET Component Library

The Grasshopper project type is Class Library, meaning it cannot be run as a stand-alone application. Grasshopper.dll is loaded by a Rhino plugin called GrasshopperPlugin.rhp. This was done so we could provide support for Rhino4 and RhinoMac, without the need to resort to different builds of Grasshopper.dll.

Assembly References

As a Class Library, Grasshopper references namespaces in addition to RhinoCommon.dll, some of these are standard namespaces provided by the DotNET Framework, others are 3rd party assemblies and others still are written by McNeel developers but are shipped separately for technical reasons. Some of these assemblies need to be referenced by Component developers, while others can be safely ignored. The following table lists all assemblies referenced by Grasshopper.dll:

Assembly | Author | Purpose | Required
RhinoCommon.dll | Robert McNeel & Associates | Rhinoceros 5.0 DotNET SDK |
GH_IO.dll | Robert McNeel & Associates | Grasshopper Input/Output library required to read and write Grasshopper files. |
GH_Util.dll | Robert McNeel & Associates | Grasshopper utility library containing some peripheral algorithms. |
QWhale.*.dll 1 | Quantum Whale | Syntax highlighter functionality. |
System | Microsoft | Base DotNET Namespace. |
System.Drawing | Microsoft | DotNET namespace involved with drawing shapes and text. |
System.Windows.Forms | Microsoft | DotNET namespace involved with dialogs and controls. |
System.Collections.Generic | Microsoft | DotNET namespace containing useful list classes. |

1 The QWhale product contains a total of 5 dlls.

See Also

Other Resources

Project Setup (VB.NET)


Project Setup (VB.NET)

[image]

Grasshopper SDK
Project Setup (VB.NET)
See Also Send Feedback

Grasshopper Component Library Project Setup in VB.NET

Please note that we now have Assembly Wizards for Grasshopper and it is no longer necessary to manually create a GHA project in Visual Studio.

This topic outlines all the steps required to create a new project in VB.NET which will create a Grasshopper Component Library. If you are using VB.NET Express, some of these steps will differ since the Express version does not expose a UI for all these settings.

Creating a new Project

  1. Start Visual Studio and create a new project via the File menu.

  2. In the Project types tree, navigate towards the Visual Basic root node. Make sure the Target Framework is 3.5 and select the Class Library type:

  3. A new, empty project will now be created. Before this project becomes a valid Grasshopper Component Library, we have to add all the required Assembly References. Navigate towards your Project Properties (double click on "My Project" in the Solution Browser for example), open up the References tab and make sure the list includes the assemblies listed below.

    Careful! When adding Assembly Reference, the default Visual Studio behaviour is to tag them as CopyLocal=True. This is wrong. So very wrong. Set the Copy Local tag of GH_IO, Grasshopper and RhinoCommon to False before you press the Compile button for the first time.

    Note that the folder locations for RhinoCommon, Grasshopper and GH_IO will differ depending on installation.

    Assembly | Probable location
    GH_IO.dll | <Program Files>\Rhinoceros 4.0\Plug-ins\Grasshopper\
    Grasshopper.dll | <Program Files>\Rhinoceros 4.0\Plug-ins\Grasshopper\
    RhinoCommon.dll | <Program Files>\Rhinoceros 4.0\Plug-ins\Grasshopper\rh_common\

  4. By default, a Visual Studio project has two build 'flavours'; DEBUG and RELEASE. Debug builds are not optimized by the compiler so the instructions that eventually get executed are very similar to the source code. Release builds do get optimized, which usually results in a slightly better performance (and occasionally vastly superior performance), but it can be very confusing to try and debug a Release version.

    Debug and Release builds are written into different folders (usually ..\Bin\Debug\ and ..\Bin\Release\ ), which is a very useful feature when writing stand-alone application, but it is outright confusing when your application is loaded by another program. We advice that you alter the build folders so that both Debug and Release builds are stored in the same location. This way there can be no confusion about which build you are loading. If you have VB Express, then you will not be able to adjust the build locations through the Visual Studio interface. See this topic on how to solve this with Visual Studio Express.

    In Project Properties, go to the Compile tab, switch the Configuration filter to All Configurations and set the Build output path: to Bin\:

  5. When you override the default build folder destinations, both DEBUG and RELEASE flavours will end up in the same location. However, the file type of the compiled Class Library is still dll. Even though this is the correct file type for a Grasshopper Component Library, you must change the extension before Grasshopper will consider loading the library. You can automatically rename the compiled dll using a Post-Build Event. Once again, if you have VB Express you will not be able to add an event via the Visual Studio UI. See this topic on how to solve this with Visual Studio Express.

    On the Compile tab of the Project Properties you will find a button that provides access to the Build Events. Open up the Build Events dialog and add the following macro to the Post-build event command line:

    Copy "$(TargetPath)" "$(TargetDir)\$(ProjectName).gha"

    Erase "$(TargetPath)"

  6. You are now finished with the project setup for Grasshopper Component Libraries. When you compile your new project, the contents of the build folder should be:

See Also

Reference

Loading and debugging custom Component Libraries.


Project Setup (C#)

[image]

Grasshopper SDK
Project Setup (C#)
See Also Send Feedback

Grasshopper Component Library Project Setup in C#

Please note that we now have Assembly Wizards for Grasshopper and it is no longer necessary to manually create a GHA project in Visual Studio.

This topic outlines all the steps required to create a new project in C# which will create a Grasshopper Component Library. If you are using C# Express, some of these steps will differ since the Express version does not expose a UI for all these settings.

Creating a new Project

  1. Start Visual Studio and create a new project via the File menu.

  2. In the Project types tree, navigate towards the Visual C# root node. Make sure the Target Framework is 3.5 and select the Class Library type:

  3. A new, empty project will now be created. Before this project becomes a valid Grasshopper Component Library, we have to add all the required Assembly References. In your Solution Explorer pane, find the References node and make sure the list includes the assemblies listed below.

    Careful! When adding Assembly Reference, the default Visual Studio behaviour is to tag them as CopyLocal=True. This is wrong. So very wrong. Set the Copy Local tag of GH_IO, Grasshopper and RhinoCommon to False before you press the Compile button for the first time.

    Note that the folder locations for RhinoCommon, Grasshopper and GH_IO will differ depending on installation.

    Assembly | Probable location
    GH_IO.dll | <Program Files>\Rhinoceros 4.0\Plug-ins\Grasshopper\
    Grasshopper.dll | <Program Files>\Rhinoceros 4.0\Plug-ins\Grasshopper\
    RhinoCommon.dll | <Program Files>\Rhinoceros 4.0\Plug-ins\Grasshopper\rh_common\

  4. By default, a Visual Studio project has two build 'flavours'; DEBUG and RELEASE. Debug builds are not optimized by the compiler so the instructions that eventually get executed are very similar to the source code. Release builds do get optimized, which usually results in a slightly better performance (and occasionally vastly superior performance), but it can be very confusing to try and debug a Release version.

    Debug and Release builds are written into different folders (usually ..\Bin\Debug\ and ..\Bin\Release\ ), which is a very useful feature when writing stand-alone application, but it is outright confusing when your application is loaded by another program. We advice that you alter the build folders so that both Debug and Release builds are stored in the same location. This way there can be no confusion about which build you are loading. If you have VB Express, then you will not be able to adjust the build locations through the Visual Studio interface. See this topic on how to solve this with Visual Studio Express.

    In Project Properties, go to the Build tab, switch the Configuration filter to All Configurations and set the Output path: to bin\:

  5. When you override the default build folder destinations, both DEBUG and RELEASE flavours will end up in the same location. However, the file type of the compiled Class Library is still dll. Even though this is the correct file type for a Grasshopper Component Library, you must change the extension before Grasshopper will consider loading the library. You can automatically rename the compiled dll using a Post-Build Event. Once again, if you have C# Express you will not be able to add an event via the Visual Studio UI. See this topic on how to solve this with Visual Studio Express.

    On the Build Events tab of the Project Properties you will find a text field called Post-build event command line where you can enter the following macro:

    Copy "$(TargetPath)" "$(TargetDir)\$(ProjectName).gha"

    Erase "$(TargetPath)"

  6. You are now finished with the project setup for Grasshopper Component Libraries. When you compile your new project, the contents of the build folder should be:

See Also

Reference

Loading and debugging custom Component Libraries.


Project Setup (VS.Express)

[image]

Grasshopper SDK
Project Setup (VS.Express)
Send Feedback

Please note that we now have Assembly Wizards for Grasshopper and it is no longer necessary to manually create a GHA project in Visual Studio.

If you are using the Express version of Visual Studio, then you might not be able to apply all required settings through the VS User Interface. In this case you'll have to modify the project files manually to apply the settings.

If you are using Visual Studio Professional, you can safely ignore this page.

This document outlines how to manually modify csproj and vbproj files.

  • Override Configuration Folders
  • Add Post-Build Events
  • Set Debug Start Action

Override Configuration Folders

It is useful to override the Visual Studio default behaviour regarding build configuration output. By default, DEBUG and RELEASE configurations (or 'flavours') are outputted to unique folders. This can cause confusion during debugging.

In order to override the output folders, open the project file in a text editor. If you're using VB then the project file will have the *.vbproj extension. If you're using C# then the project file will have the *.csproj extension. Ideally you should use a text editor that understands xml-formatting, but Notepad will do.

Inside the project file, locate the property group that has to do with the Debug and Release configurations. They will probably be called:

CopyXML
<PropertyGroup Condition=" '$(Configuration)|$(Platform)' == 'Debug|AnyCPU' ">
<PropertyGroup Condition=" '$(Configuration)|$(Platform)' == 'Release|AnyCPU' ">
Inside these property groups you will find OutputPath nodes:
CopyXML
<OutputPath>bin\Debug\</OutputPath>
<OutputPath>bin\Release\</OutputPath>
 You'll have to change these to point to the same folder. We recommend:
CopyXML
<OutputPath>bin\</OutputPath>

Add Post-Build Events

It is vital to add a Post-Build event to a Grasshopper Component Library since Grasshopper will only consider *.gha files during plug-in loading. Since your project is a Class Library, it will automatically be compiled into a *.dll file.

In order to override the output folders, open the project file in a text editor. If you're using VB then the project file will have the *.vbproj extension. If you're using C# then the project file will have the *.csproj extension. Ideally you should use a text editor that understands xml-formatting, but Notepad will do.

By default, a project file (vbproj for VB.NET; csproj for C#) does not contain any Build Events, so you'll have to add the entire section in the project file Xml data. Navigate towards the bottom of the project file. Just before the closing </Project> tag, insert the following PropertyGroup:

CopyXML
<PropertyGroup>
  <PostBuildEvent>Copy "$(TargetPath)" "$(TargetDir)\$(ProjectName).gha"
                  Erase "$(TargetPath)"
  </PostBuildEvent>
</PropertyGroup>

Set Debug Start Action

It is not possible to directly debug a Grasshopper Component Library, since it must be loaded by Grasshopper, which in turn must be loaded by Rhinoceros. So, in order to debug a *.gha file you must first start Rhino. This is called a Debug Start Action and VS Express does not allow you to set one via its own UI.

TODO, Finish this topic...


Examples

[image]

Grasshopper SDK
Examples
Send Feedback

This section of the Grasshopper SDK Documentation features code examples for typical 3rd party development.

Components

My First Component (VB, C#)

Simple Mathematics (VB, C#)

Simple Geometry (VB, C#)

Advanced Geometry (VB, C#)

Reading and Writing Lists (VB, C#)

Reading and Writing Trees (VB, C#)

Custom Component Options (VB, C#)

Variable Parameters (VB, C#)

Custom Previews (VB, C#)

Parameters and Data

Simple Parameters (VB, C#)

Simple Data Types (VB, C#)

GUI

Extending the GUI (VB, C#)

Custom Attributes (VB, C#)


Simple Component (VB)

[image]

Grasshopper SDK
Simple Component (VB)
Send Feedback

  • Introduction
  • Grasshopper.Kernel.GH_Component
  • The Component Constructor
  • Component GUIDs
  • Parameter Registration
  • The Solver Routine

This article contains an exhaustive, step by step explanation of how to build your first component in VB.NET. It will skip over any complicated issues (such as mathematics, geometry and data handling) in order to reduce the totality of new concepts. You will however need to have a good understanding of basic OOP concepts such as classes, types and inheritance. If you do not understand these DotNET essentials, we recommend you start with some other reading material first.

Grasshopper.Kernel.GH_Component

All you need to do in order to define a new Component is to inherit from the GH_Component base class in Grasshopper. Assuming you've set up your project correctly, create a new, blank class in your project:

At this point a new file should be created (MyFirstComponent.vb) with the following content:

CopyVB.NET
Public Class MyFirstComponent

End Class
Since we'll be using primarily types from the Grasshopper.Kernel namespace. We'll import this namespace so that we have easy access to all types contained within it (unless otherwise specified, all further types discussed in this topic belong to Grasshopper.Kernel):
CopyVB.NET
Imports Grasshopper.Kernel
Public Class MyFirstComponent

End Class
 Now, we need to derive our MyFirstComponent class from the GH_Component base class defined inside Grasshopper. GH_Component takes care of almost all the complicated actions and mannerisms that constitute a Component. It will handle data conversion, GUI, menus, file Input/Output, Error trapping and much, much more. This allows us to focus only on the unique aspects of our Component. In order to derive from GH_Component, add the following line directly underneath the class declarator:
CopyVB.NET
Imports Grasshopper.Kernel
Public Class MyFirstComponent
  Inherits GH_Component

End Class
 As soon as you press Enter after finishing that line, Visual Studio will insert a bunch of empty properties and subroutines which we are required to fill out, but we'll deal with that in the next sections:
CopyVB.NET
Imports Grasshopper.Kernel
Public Class MyFirstComponent
  Inherits GH_Component

  Protected Overrides Sub RegisterInputParams(ByVal pManager As GH_Component.GH_InputParamManager)
    'Don't worry about this just yet!
  End Sub

  Protected Overrides Sub RegisterOutputParams(ByVal pManager As GH_Component.GH_OutputParamManager)
    'We'll get to it soon enough.
  End Sub

  Protected Overrides Sub SolveInstance(ByVal DA As IGH_DataAccess)
    'I know it all looks scary.
  End Sub

  Public Overrides ReadOnly Property ComponentGuid() As System.Guid
    Get
      'But we'll deal with it one item at a time.
    End Get
  End Property
End Class

The Component Constructor

As we've seen in the previous section, Visual Studio will populate the MyFirstComponent class with a collection of properties and subroutines that we need to implement. There is however another subroutine that requires our attention that is missing. This is the constructor. The constructor is a special subroutine inside each class which gets called when the class is instantiated (or "constructed"). This can happen only once (we feeble humans can only be born once as well after all) and it necessarily happens before anything else is allowed to happen. The GH_Component base class has a constructor which is not empty, so we have to call that constructor from within our constructor and supply it with all the information it needs. Let's play ball. Add the following code near the top of the MyFirstComponent class:

CopyVB.NET
Imports Grasshopper.Kernel
Public Class MyFirstComponent
  Inherits GH_Component

  Public Sub New()
    MyBase.New("MyFirst", "MFC", "My first component", "Extra", "Simple")
  End Sub

  ...
As you can see we need to supply a set of text constants, which are used to name and identify our component within the Grasshopper GUI. The text fields are:

Parameter | Purpose
name | The name of our component. The name is what appears on tooltips and Panel dropdowns.
abbreviation | The abbreviation of our component. The abbreviation is what is written on the component once it appears on the Canvas.
description | A description of our component. The description is used on tooltips to provide users with a more detailed idea about what this component is for.
category | The tab category for the component. The category equals the name of the Tab onto which the Component will appear. If a non-existing category is supplied, a new Tab will be added to the Grasshopper GUI.
subCategory | The panel category for the component. The sub-category equals the name of the Panel onto which the Component will appear. If a non-existing sub-category is supplied, a new Panel will be added to the Category Tab.

Component Guids

Every type of object inside a Grasshopper document must have a Guid associated with it. When a Grasshopper file (*.gh or *.ghx) is written these Guids are used as markers, so it becomes clear what portions of the file belong to which object. When the file is read back in, that marker is compared against the list of all cached components and if a match is found the appropriate component is asked to please go and deserialize itself. (You thought I was going to say something else didn't you?). When no matching component can be found it is assumed that whoever wrote the file had access to certain components that are not available locally, and that portion of the file is dutifully skipped.

So, long story short, we need to invent a Guid (Globally Unique IDentifier) that will positively and unerringly indicate this component. You can generate spanking new Guids using an Online Guid Generator or Microsofts popular guidgen.exe. Never re-use a Guid and never edit one by hand. Always generate a proper one using an official tool.

Once you have a new Guid standing by, modify the ComponentGuid property to return it:

CopyVB.NET
...
Public Overrides ReadOnly Property ComponentGuid() As System.Guid
  Get
    'Don't copy this GUID, make a new one
    Return New Guid("419c3a3a-cc48-4717-8cef-5f5647a5ecfc")
  End Get
End Property
...

Parameter Registration

Components have unique input and output parameters which are most often fixed. We are ignoring those rare cases where a component either has no inputs or no outputs, or where there is a variable number of parameters. There are two subroutines that allow you to define (or "register") these parameters. These routines are called from within the base class constructor and they are only called once. Let's have a look at the default implementation that Visual Studio generated again:

CopyVB.NET
...
Protected Overrides Sub RegisterInputParams(ByVal pManager As GH_Component.GH_InputParamManager)

End Sub

Protected Overrides Sub RegisterOutputParams(ByVal pManager As GH_Component.GH_OutputParamManager)

End Sub
...
Although it would technically be possible to manually register parameters, we highly recommend you use the methods on pManager. pManager has methods for adding all the basic parameter types and it often even allows you to specify default values:

In this example we'll only create two parameters (one input, one output) and they will both be of type String.

CopyVB.NET
...
Protected Overrides Sub RegisterInputParams(ByVal pManager As Grasshopper.Kernel.GH_Component.GH_InputParamManager)
  pManager.AddTextParameter("String", "S", "String to reverse")
End Sub

Protected Overrides Sub RegisterOutputParams(ByVal pManager As Grasshopper.Kernel.GH_Component.GH_OutputParamManager)
  pManager.AddTextParameter("Reverse", "R", "Reversed string")
End Sub
...
When we compile this project (assuming it has been setup correctly), the component will already be available on the Grasshopper tabs and it can be placed onto the canvas:

The Solver Routine

Our new component sure looks perky and expensive, but it doesn't do anything useful yet (am I the only one who's reminded of Paris Hilton?). We still need to write the contents of the SolveInstance subroutine, which is where all the action takes place. The SolveInstance() function is called upon whenever the component needs to handle input data. In this particular example, if we plug a list of twelve Strings into the [S] parameter, SolveInstance() will be called twelve times.

As you may already have guessed, the component we're writing will reverse a given textual string from [S] and output the result to [R]. Since we're operating on individual items of data (the default behaviour), all we need to do inside the SolveInstance() function is retrieve the current String from [S], reverse it and assign it to [R]. Now, String reversal is not a function that is directly available in the framework String type, so we need to actually do some thinking:

CopyVB.NET
...
Protected Overrides Sub SolveInstance(ByVal DA As Grasshopper.Kernel.IGH_DataAccess)
  'Declare a variable for the input String
  Dim data As String = Nothing

  'Use the DA object to retrieve the data inside the first input parameter.
  'If the retieval fails (for example if there is no data) we need to abort.
  If (Not DA.GetData(0, data)) Then Return

  'If the retrieved data is Nothing, we need to abort.
  'We're also going to abort on a zero-length String.
  If (data Is Nothing) Then Return
  If (data.Length = 0) Then Return

  'Convert the String to a character array.
  Dim chars As Char() = data.ToCharArray()

  'Reverse the array of character.
  Array.Reverse(chars)

  'Use the DA object to assign a new String to the first output parameter.
  DA.SetData(0, New String(chars))
End Sub
...


Simple Mathematics (VB)

[image]

Grasshopper SDK
Simple Mathematics (VB)
Send Feedback

  • Introduction
  • Input parameters
  • Output parameters
  • SolveInstance

This article contains a brief example of a component that deals with some simple mathematics and multiple input and output parameters. We'll discuss parameter order, legacy support for changing component layouts and default values for input parameters. We will not be dealing with any of the basics of component development. You should have read the My First Component topic before starting this one.

For this component we'll bundle the Sine, Cosine and Tangent trigonometry functions while allowing inputs to be specified in either Radians or Degrees. We'll need to define two input parameter (one of which will have a default value) and three output parameters.

Before you start with this topic, create a new class that derives from GH_Component, as outlined in the My First Component topic.

Input parameters

This component will require two input parameters, one of which has a default value. We'll need to register these parameters inside the RegisterInputParams subroutine:

CopyVB.NET
...
Protected Overrides Sub RegisterInputParams(ByVal pManager As GH_Component.GH_InputParamManager)
  pManager.AddNumberParameter("Angle", "A", "The angle to measure", GH_ParamAccess.item)
  pManager.AddBooleanParameter("Radians", "R", "Work in Radians", GH_ParamAccess.item, True) 'The default value is 'True'
End Sub
...
The first parameter is of type Number meaning it accepts floating point values. It has a name, abbreviation, description and access level defined. The second parameter is of type Boolean and it will accept True and False values. The pManager object allows us to specify a single default value for many parameter types. You must always assign the correct access level to every input and output parameter.

The order in which we register the parameters is also the order in which they'll appear on the component. We should not change the order (or the types, or the number) of the parameters once the Component has been released to the world. Every Grasshopper file that was saved with one of our components will expect to be deserialized by the exact same component layout. If you add an additional parameter to an component and someone tries to open a file which was saved while an older version of that component, it will fail to deserialize as the data in the file no longer matches the new layout. An exception will be thrown and Grasshopper will short circuit that particular instance. The entire component and all connections to it will be missing when the file is eventually displayed to the user.

If you must change the parameter layout of a component, you should create a completely new GH_Component class with a different ComponentGuid, while maintaining the old Component type for legacy file purposes. You can hide Components from the Grasshopper GUI by overriding the Exposure Property of the GH_Component class and changing the return value to GH_Exposure.hidden:

CopyVB.NET
Public Overrides ReadOnly Property Exposure() As Grasshopper.Kernel.GH_Exposure
  Get
    Return GH_Exposure.hidden
  End Get
End Property

Output parameters

Our component will also need three output parameters. Output parameters differ from input parameters in that they have much fewer options. Users cannot add expressions to them, there are no default values, they don't support persistent data. Outputs are always cleared when the component expires, and they are slowly filled out from within the SolveInstance() routine.

CopyVB.NET
...
Protected Overrides Sub RegisterOutputParams(ByVal pManager As GH_Component.GH_OutputParamManager)
  pManager.AddNumberParameter("Sin", "sin", "The sine of the Angle.", GH_ParamAccess.item)
  pManager.AddNumberParameter("Cos", "cos", "The cosine of the Angle.", GH_ParamAccess.item)
  pManager.AddNumberParameter("Tan", "tan", "The tangent of the Angle.", GH_ParamAccess.item)
End Sub
...

SolveInstance

The SolveInstance implementation for this component is hardly any more complicated than it was for My First Component. The only difference is that we now have more than one parameter on each side.

CopyVB.NET
...
Protected Overrides Sub SolveInstance(ByVal DA As Grasshopper.Kernel.IGH_DataAccess)
  'Declare variables to contain all inputs.
  'We can assign some initial values that are either sensible or indicative.
  Dim angle As Double = Double.NaN
  Dim radians As Boolean = False

  'Use the DA object to retrieve the data inside the input parameters.
  'If the retrieval fails (for example if there is no data) we need to abort.
  If (Not DA.GetData(0, angle)) Then Return
  If (Not DA.GetData(1, radians)) Then Return

  'If the angle value is not a valid number, we should abort.
  If (Not Rhino.RhinoMath.IsValidDouble(angle)) Then Return

  'If the user wants to work in degrees rather than radians,
  'we assume that angle is defined in degrees.
  'We need to convert it into Radians again.
  If (Not radians) Then
    angle = Rhino.RhinoMath.ToRadians(angle)
  End If

  'Now we are ready to assign the outputs via the DA object.
  'Since the Sin(), Cos() and Tan() never fail, we might as well
  'combine them with the assignment.
  DA.SetData(0, Math.Sin(angle))
  DA.SetData(1, Math.Cos(angle))
  DA.SetData(2, Math.Tan(angle))
End Sub
...


Simple Geometry (VB)

[image]

Grasshopper SDK
Simple Geometry (VB)
Send Feedback

  • Introduction
  • Input parameters
  • Output parameters
  • SolveInstance

This article shows how to use some of the simpler geometry types and classes in the RhinoCommon and Grasshopper SDK. We'll discuss how to deal with different access levels of input data and invalid Structs vs. invalid and null Classes. You should have read the My First Component and Simple Mathematics topics before starting this one.

This component will perform a simple Circle|Line Split operation. We'll retrieve a single Circle and a single Line input, make sure the data is valid, project the line onto the circle plane, determine whether or not the Split operation is valid and then output the two arcs on either side of the slicing line.

Before you start with this topic, create a new class that derives from GH_Component, as outlined in the My First Component topic.

Input parameters

This part of the component is very similar to the Simple Mathematics topic. Except this time there will be no default values.

CopyVB.NET
...
Protected Overrides Sub RegisterInputParams(ByVal pManager As GH_Component.GH_InputParamManager)
  pManager.AddCircleParameter("Circle", "C", "The circle to slice", GH_ParamAccess.item)
  pManager.AddLineParameter("Line", "L", "Slicing line", GH_ParamAccess.item)
End Sub
...
The first parameter is of type Param_Circle and the data it contains will consist solely of GH_Circle. GH_Circle is a class that wraps the Rhino.Geometry.Circle structure. It provides methods that allow Grasshopper to incorporate RhinoCommon circles into the default GUI. These methods include Archiving, Previewing, Baking and Casting (Converting) functions. However, when accessing data inside a Param_Circle parameter, you are not limited to the GH_Circle type, as we shall see.

The second parameter is of type Param_Line and it works very similar to the Param_Circle type discussed above.

Output parameters

Our component will output two arcs on success, or nulls on failure.

CopyVB.NET
...
Protected Overrides Sub RegisterOutputParams(ByVal pManager As GH_Component.GH_OutputParamManager)
  pManager.AddArcParameter("Arc A", "A", "First Split result.", GH_ParamAccess.item)
  pManager.AddArcParameter("Arc B", "B", "Second Split result.", GH_ParamAccess.item)
End Sub
...

SolveInstance

The SolveInstance() implementation for this component is responsible for the following steps:

  1. Declare placeholder variables for the input data.
  2. Retrieve input data.
  3. Test input data for validity.
  4. Project line segment onto circle plane.
  5. Test projected segment for validity.
  6. Solve intersections for circle and projected segment.
  7. Abort on insufficient intersections.
  8. Create the slice arcs.
  9. Assign arcs to the output parameters.

Item 2 and 9 however can be approached from different directions. First I'll show you the recommended approach and then we'll have a look at the alternatives:

CopyVB.NET
...
Protected Overrides Sub SolveInstance(ByVal DA As Grasshopper.Kernel.IGH_DataAccess)
  '1. Declare placeholder variables and assign initial invalid data.
  '   This way, if the input parameters fail to supply valid data, we know when to abort.
  Dim circle As Rhino.Geometry.Circle = Rhino.Geometry.Circle.Unset
  Dim line As Rhino.Geometry.Line = Rhino.Geometry.Line.Unset

  '2. Retrieve input data.
  If (Not DA.GetData(0, circle)) Then Return
  If (Not DA.GetData(1, line)) Then Return

  '3. Abort on invalid inputs.
  If (Not circle.IsValid) Then Return
  If (Not line.IsValid) Then Return

  '4. Project line segment onto circle plane.
  line.Transform(Rhino.Geometry.Transform.PlanarProjection(circle.Plane))

  '5. Test projected segment for validity.
  If (line.Length < Rhino.RhinoMath.ZeroTolerance) Then
    AddRuntimeMessage(GH_RuntimeMessageLevel.Error, "Line could not be projected onto the Circle plane")
    Return
  End If

  '6. Solve intersections and 7. Abort if there are less than two intersections.
  Dim t1 As Double
  Dim p1 As Rhino.Geometry.Point3d
  Dim t2 As Double
  Dim p2 As Rhino.Geometry.Point3d

  Select Case Rhino.Geometry.Intersect.Intersection.LineCircle(line, circle, t1, p1, t2, p2)
    Case Rhino.Geometry.Intersect.LineCircleIntersection.None
      AddRuntimeMessage(GH_RuntimeMessageLevel.Warning, "No intersections were found")
      Return
    Case Rhino.Geometry.Intersect.LineCircleIntersection.Single
      AddRuntimeMessage(GH_RuntimeMessageLevel.Warning, "Only a single intersection was found")
      Return
  End Select

  '8. Create slicing arcs.
  Dim ct As Double
  circle.ClosestParameterTo(p1, ct)

  Dim tan As Rhino.Geometry.Vector3d = circle.TangentAt(ct)

  '9. Assign output arcs.
  DA.SetData(0, New Rhino.Geometry.Arc(p1, tan, p2))
  DA.SetData(1, New Rhino.Geometry.Arc(p1, -tan, p2))
End Sub
...

As I mentioned before, the first input parameter is of type Param_Circle and it contains data of type GH_Circle. But when we're accessing the parameter via the DA.GetData(0, circle) method, we're using Rhino.Geometry.Circle instead of Grasshopper.Kernel.Types.GH_Circle. The DA.GetData() method is capable of converting data from the intrinsic parameter type into requested types, provided the conversion makes sense. GH_Circle to Rhino.Geometry.Circle is a perfectly valid conversion, GH_Circle to Rhino.Geometry.Transform would not be.

The Grasshopper Component SDK has been designed on the premise that the bulk of all Components that operate on data only care about the data itself, not how it is wrapped up inside the Grasshopper data structures. The conversion routines that translate GH_Circle data into Rhino.Geometry.Circle data (and obviously also GH_Number into System.Double, and GH_Colour into System.Drawing.Color etc.), have been highly optimised and should be used in almost all circumstances.

If however you feel the need to get access to the GH_Circle data directly, you can retrieve that instance in the same fashion:

CopyVB.NET
...
Dim circle As Grasshopper.Kernel.Data.GH_Circle = Nothing
If (Not DA.GetData(0, circle)) Then Return
...
Note that a single instance of GH_Circle may be shared among any number of parameters in Grasshopper, and thus changing one will change data everywhere. If you request Rhino.Geometry.Circle, System.Double or System.Drawing.Color instead of GH_Circle, GH_Number or GH_Colour you won't have to worry about this pitfall since you will always be given an object that has been disassociated from the (potentially shared) wrapper type.

Similarly, you are allowed to store output data in different formats as well. Instead of:

CopyVB.NET
DA.SetData(0, New Rhino.Geometry.Arc(p1, tan, p2))
you could also provide an instance of Grasshopper.Kernel.Types.GH_Arc:
CopyVB.NET
Dim gh_arc As New Grasshopper.Kernel.Types.GH_Arc(New Rhino.Geometry.Arc(p1, tan, p2))
DA.SetData(0, gh_arc)


Simple Data Types (VB)

[image]

Grasshopper SDK
Simple Data Types (VB)
Send Feedback

  • Introduction
  • The IGH_Goo interface
  • The GH_Goo abstract class
  • An Example Type
    • Constructors
    • Formatters
    • Serialization
    • Casting

This article discusses how Grasshopper deals with data items and types. It's a rather complicated topic as data is an integral part of the Grasshopper process and GUI. Grasshopper needs to be able to (de)serialize data, display data in tooltips, convert data to other types of data, prompt the user for persistent data, draw geometry preview data in viewports and bake geometric data. In this topic I'll only talk about non-geometric data, we'll get to previews and baking in a later topic.

Practically all native data types in Grasshopper are based either on a .NET Framework type or a RhinoCommon SDK type. For example System.Boolean, System.String, Rhino.Geometry.Point3d and Rhino.Geometry.Brep to name but a few. However the parameters in Grasshopper don't directly store Booleans, String, Points and Breps as these types can't handle themselves in the cauldron that is Grasshopper.

All data used in Grasshopper must implement the IGH_Goo interface. IGH_Goo defines the bare minimum of methods and properties for any kind of data before it is allowed to play ball.

The IGH_Goo interface

In this section I'll briefly discuss all the methods and properties that are defined in IGH_Goo. What they're for, who uses them at what time, etc, etc.

Method Purpose
CopyVB.NET
ReadOnly Property IsValid() As Boolean
         Not all data types are valid all the time, and this property allows you to teint the current instance of your data. When data is invalid it will often be ignored by components.
CopyVB.NET
ReadOnly Property TypeName() As String
         This property must return a human-readable name for your data type.
CopyVB.NET
ReadOnly Property TypeDescription() As String
         This property must return a human-readable description of your data type.
CopyVB.NET
Function Duplicate() As IGH_Goo
         This function must return an exact duplicate of the data item. Data is typically shared amongst multiple Grasshopper Parameters, so before data is changed, it first needs to copy itself. When data only contains ValueTypes and Primitives, making a copy of an instance is usually quite easy.
CopyVB.NET
Function ToString() As String
         This function is called whenever Grasshopper needs a human-readable version of your data. It is this function that populates the data panel in parameter tooltips. You don't need to create a String that is parsable, it only needs to be somewhat informative.
CopyVB.NET
Function EmitProxy() As IGH_GooProxy
         Data proxies are used in the Data Collection Manager. You can ignore this function (i.e. Return Nothing) without crippling your data type.
CopyVB.NET
Function CastTo(Of T)(ByRef target As T) As Boolean

Data Casting is a core feature of Grasshopper data. It basically allows data types defined in Grasshopper add-ons to become an integral part of Grasshopper. Lets assume that we have a component that operates on data type [A]. But instead of playing nice, we provide data of type [B]. Two conversion (casting) attempts will be made in order to change [B] into [A]. If [B] implements IGH_Goo, then it is asked if it knows how to convert itself into an instance of [A]. Failing that, if [A] implements IGH_Goo, it is asked whether or not it knows how to construct itself from an instance of [B].

The CastTo() function is responsible for step 1. The CastTo() method is a generic method, meaning the types on which it operates are not defined until the method is actually called. This allows the function to operate 'intelligently' on data types. It also unfortunately means you have to be 'intelligent' when implementing this function.

CopyVB.NET
Function CastFrom(ByVal source As Object) As Boolean

The CastFrom() method is responsible for step 2 of data casting. Some kind of data is provided as a source object and if the local Type knows how to 'read' the source data it can perform the conversion.

CopyVB.NET
Function ScriptVariable() As Object

When data is fed into a VB or C# script component, it is usually stripped of IGH_Goo specific data and methods. The ScriptVariable() method allows a data type to provide a stripped down version of itself for use in a Script component.

The GH_Goo abstract class

Although all data in Grasshopper must implement the IGH_Goo interface, it is not necessary to actually write a type from scratch. It is good practice to inherit from the abstract (MustInherit) class GH_Goo(Of T), as it takes care of some of the basic functionality. GH_Goo is a generic type (that's what the "(Of T)" bit means), where T is the actual type you're wrapping. GH_Goo(Of T) has several MustOverride methods and properties which must be implemented, but a lot of the other methods are already implemented with basic (though usually useless) functionality.

An Example Type

We'll now create a very simple Custom Type. This will introduce the basic concept of custom type development, without dealing with any of the baking and previewing logic yet. Our custom type will be a TriState flag, similar to boolean values but with an extra state called "Unknown". We'll represent these different states using integers:

Integer | TriState
Negative One | Unknown
Zero | False
Positive One | True

We'll start with the general class layout, then drill down into each individual function. Create a new public class called TriStateType and inherit from GH_Goo(Of Integer). Be sure to import the Grasshopper Kernel and Kernel.Types namespaces as we'll need them both:

CopyVB.NET
Imports Grasshopper.Kernel
Imports Grasshopper.Kernel.Types

Namespace MyTypes
  Public Class TriStateType
    Inherits GH_Goo(Of Integer)

  End Class
End Namespace

Constructors

Unless a constructor is defined, .NET classes always have a default constructor which initializes all the fields of the class to their default values. This constructor does not require any inputs and when you develop custom types it is a good idea to always provide a default constructor. If there is no default constructor, then class instances cannot be created automatically which thwarts certain algorithms in Grasshopper.

In addition to a default constructor I also find it useful to supply so called copy constructors which create a new instance of the Type class with a preset value.

CopyVB.NET
'' Default Constructor, sets the state to Unknown.
Public Sub New()
  Me.Value = -1
End Sub

'' Constructor with initial value
Public Sub New(ByVal tristateValue As Integer)
  Me.Value = tristateValue
End Sub

'' Copy Constructor
Public Sub New(ByVal tristateSource As TriStateType)
  Value = tristateSource.Value
End Sub

'' Duplication method (technically not a constructor)
Public Overrides Function Duplicate() As Kernel.Types.IGH_Goo
  Return New TriStateType(Me)
End Function

Incidentally, the Value property which we are using to assign integers to our local instance is provided by the GH_Goo(Of T) base class. GH_Goo(Of T) defines a protected field of type T called m_value and also a public accessor property called Value which gets or sets the m_value field.

In this particular case, it actually makes sense to override the default Value property implementation, as the number of sensible values we can assign (-1, 0 and +1) is a subset of the total number values available through the integer data type. It makes no sense to assign -62 for example. We could of course agree that all negative values indicate an "Unknown" state, but we should try to restrict ourselves to only three integer values:

CopyVB.NET
'' Override the Value property to strip non-sensical states.
Public Overrides Property Value() As Integer
  Get
    Return MyBase.Value
  End Get
  Set(ByVal value As Integer)
    If (value < -1) Then value = -1
    If (value > +1) Then value = +1
    MyBase.Value = value
  End Set
End Property

Formatters

Formatting data is primarily a User Interface task. Both the data type and the data state need to be presented in human-readable form every now and again. This mostly involves readonly properties as looking at data does not change its state:

CopyVB.NET
'' TriState instances are always valid
Public Overrides ReadOnly Property IsValid() As Boolean
  Get
    Return True
  End Get
End Property

'' Return a string with the name of this Type.
Public Overrides ReadOnly Property TypeName() As String
  Get
    Return "TriState"
  End Get
End Property

'' Return a string describing what this Type is about.
Public Overrides ReadOnly Property TypeDescription() As String
  Get
    Return "A TriState Value (True, False or Unknown)"
  End Get
End Property

'' Return a string representation of the state (value) of this instance.
Public Overrides Function ToString() As String
  If (Value = 0) Then Return "False"
  If (Value > 0) Then Return "True"
  Return "Unknown"
End Function

Serialization

Some data types can be stored as persistent data. Persistent data must be able to serialize and deserialize itself from a Grasshopper file. Most simple types support this feature (Booleans, Integers, Strings, Colours, Circles, Planes etc.), most complex geometry types cannot be stored as persistent data (Curves, Breps, Meshes). If possible, you should aim to provide robust (de)serialization for your data:

CopyVB.NET
'' Serialize this instance to a Grasshopper writer object.
Public Overrides Function Write(ByVal writer As GH_IO.Serialization.GH_IWriter) As Boolean
  writer.SetInt32("tri", Value)
  Return True
End Function

'' Deserialize this instance from a Grasshopper reader object.
Public Overrides Function Read(ByVal reader As GH_IO.Serialization.GH_IReader) As Boolean
  Value = reader.GetInt32("tri")
  Return True
End Function

Casting

There are three casting methods on IGH_Goo; the CastFrom() and CastTo() methods that facilitate conversions between different types of data and the ScriptVariable() method which creates a safe instance of this data to be used inside untrusted code (such as VB or C# Script components).

CopyVB.NET
'' Return the Integer we use to represent the TriState flag.
Public Overrides Function ScriptVariable() As Object
  Return Value
End Function

'' This function is called when Grasshopper needs to convert this
'' instance of TriStateType into some other type Q.
Public Overrides Function CastTo(Of Q)(ByRef target As Q) As Boolean
  'First, see if Q is similar to the Integer primitive.
  If (GetType(Q).IsAssignableFrom(GetType(Integer))) Then
    Dim ptr As Object = Value
    target = DirectCast(ptr, Q)
    Return True
  End If

  'Then, see if Q is similar to the GH_Integer type.
  If (GetType(Q).IsAssignableFrom(GetType(GH_Integer))) Then
    Dim int As Object = New GH_Integer(Value)
    target = DirectCast(int, Q)
    Return True
  End If

  'We could choose to also handle casts to Boolean, GH_Boolean,
  'Double and GH_Number, but this is left as an exercise for the reader.
  Return False
End Function

'' This function is called when Grasshopper needs to convert other data
'' into TriStateType.
Public Overrides Function CastFrom(ByVal source As Object) As Boolean
  'Abort immediately on bogus data.
  If (source Is Nothing) Then Return False

  'Use the Grasshopper Integer converter. By specifying GH_Conversion.Both
  'we will get both exact and fuzzy results. You should always try to use the
  'methods available through GH_Convert as they are extensive and consistent.
  Dim int As Integer
  If (GH_Convert.ToInt32(source, int, GH_Conversion.Both)) Then
    Value = int
    Return True
  End If

  'If the integer conversion failed, we can still try to parse Strings.
  'If possible, you should ensure that your data type can 'deserialize' itself
  'from the output of the ToString() method.
  Dim str As String = Nothing
  If (GH_Convert.ToString(source, str, GH_Conversion.Both)) Then
    Select Case str.ToUpperInvariant()
      Case "FALSE", "F", "NO", "N"
        Value = 0
        Return True
      Case "TRUE", "T", "YES", "Y"
        Value = +1
        Return True
      Case "UNKNOWN", "UNSET", "MAYBE", "DUNNO", "?"
        Value = -1
        Return True
    End Select
  End If

  'We've exhausted the possible conversions, it seems that source
  'cannot be converted into a TriStateType after all.
  Return False
End Function


Simple Parameters (VB)

[image]

Grasshopper SDK
Simple Parameters (VB)
Send Feedback

  • Introduction
  • Grasshopper.Kernel.IGH_Param
  • Types of Parameters
  • Data inside Parameters
  • A Custom Parameter Type
  • Collecting and Post-Processing Data

In this article we'll discuss parameters; what they are, what they're for, what they can and cannot do. Parameters are a vital part of Grasshopper (the other being components). However, unlike components, it is far less likely that you'll need to make your own parameters. Most components require only the native data types available inside Grasshopper. In those odd cases where you need to work with custom data, you'll also need to create custom parameters that store that data. In this topic, we'll create a parameter which can handle the TriStateType we discussed in the Simple Data Types topic.

Parameters are responsible for storing and distributing data. Components use them to collect existing data and output new data. Parameters can also be used to convert data from one type into another, even though on the atomic level the conversion is actually performed by the CastTo<(Of <<'(T>)>>) and CastFrom methods on IGH_Goo. Most objects in the Special subcategory on the Grasshopper toolbar are basically parameters with extended GUIs. Parameters can also be used by themselves to store constant data or to redirect data into multiple streams.

Grasshopper.Kernel.IGH_Param

All parameters in Grasshopper must implement the IGH_Param interface. IGH_Param defines the bare minimum of what a parameter must be able to do. There are some interfaces that extend on IGH_Param, and also some abstract classes that partially implement the interface. Note that IGH_Param already inherits from IGH_ActiveObject, so it comes with a lot of baggage.

IGH_Param is quite an extensive interface, it defines nearly thirty properties and methods, some of which are quite tricky to implement. It is highly recommended that you do not directly implement IGH_Param, but derive from the abstract GH_Param<(Of <(<'T>)>)> class instead. GH_Param(Of T) provides a basic implementation of IGH_Param and takes care of quite a lot of the nasty bits. Here's a list of things GH_Param(Of T) will happily do for you that you would otherwise have to do yourself:

  • It will create default Attributes in case the parameter is floating.
  • It will manage and synch the source and recipient lists.
  • It can parse network topology to figure out dependency relationships.
  • It will create, restore and clean proxy sources used during IO operations.
  • It knows how to disassociate itself from adjacent objects in a network.
  • It will provide getters and settings for typical parameter properties.
  • It knows how to apply DataMapping algorithms to local data.
  • It can handsomely format local data for display in tooltips.
  • It will maintain a GH_Structure(Of T) for local data storage.
  • It provides methods to cast data into the local type.
  • It will accurately measure the time it takes to collect and process data.
  • It knows how to collect and interweave data from multiple sources.
  • It will correctly populate parameter pop-up menus.
  • It will provide the correct StateTags for DataMapping settings.
  • It will (de)serialize all local properties.

In other words, do not implement IGH_Param but derive from GH_Param(Of T)!

Types of Parameters

As mentioned before, parameters can be encountered as component inputs or outputs, but also as free-floating objects. These are not different classes, but rather the same class behaving in different ways. Every instance of IGH_Param has a Kind readonly property which describes the context of that instance:

In the image above, we see all three valid parameter Kinds (Input, Output and Floating). The "bool" object is a floating parameter of type Param_Boolean. The "P" on the left side of the "Cull" component is an input parameter of that very same type.

The Text Panel is also a floating parameter which derives from GH_Param(Of GH_String). In a way it is very similar to the String parameter (not shown), except it overrides the display and GUI of the default GH_Param class. The "L" on the right of the "Cull" component is an output parameter of the Param_GenericObject type (just like the "L" input parameter).

From this image we can see how versatile parameters can be. Parameters can have wildly different front-ends, they can expose and hide input and output grips at will, they can be part of a larger component or stand by themselves. They can even override so much of the default functionality that they no longer appear to be parameters at all (like the cluster output attached to "L").

Data inside Parameters

All parameters have the capacity to store data, this is, after all, their primary function. When you derive from GH_Param<(Of <(<'T>)>)> there will be a protected member available within the class called m_data of type GH_Structure<(Of <(<'T>)>)>. Since GH_Structure(Of T) only accepts types of T that implement IGH_Goo, GH_Param(Of T) also only accepts types for T that implement IGH_Goo. This is why you cannot have a GH_Param(Of Integer) but must instead have GH_Param(Of GH_Integer).

Data stored inside the m_data field is destroyed whenever the parameter expires. Parameters can be expired via several different mechanisms, but the most common ones are:

  • One or more of the sources of a parameter expires.
  • The component that owns the parameter expires.
  • The user forces a complete solution recalculation (F5).
Because the data gets destroyed so readily, we call it Volatile Data. A lot of parameters in Grasshopper are also capable of storing Persistent Data, which is not destroyed whenever a solution runs. This allows parameters to define a collection of 'constant' values. The "Set One XXXX", "Set Multiple XXXX" and "Manage XXXX Collection" menu items in the parameter pop-up menu refer to persistent data.

When a parameter is not connected to any source parameters, the persistent data will be copied into the volatile data. If there is no persistent data, the parameter will remain empty and a runtime warning will be included to this effect.

GH_Param(Of T) however does not support persistent data. You can add your own mechanism for this (like Text Panel does) or you can choose to derive from more advanced classes like GH_PersistentParam<(Of <(<'T>)>)>. In this example, we'll derive from GH_PersistentParam(Of T) as we want to give users the ability to specify local data. GH_PersistentParam(Of T) requires we implement two additional methods that allow users to specify persistent data. These methods are called from the default popup menu when the "Set One XXXX" and "Set Multiple XXXX" items are clicked.

So let's start with deriving from GH_PersistentParam(Of T) and see where that takes us:

CopyVB.NET
Public Class TriStateParameter
  Inherits GH_PersistentParam(Of TriStateType)

  'We need to supply a constructor without arguments that calls the base class constructor.
  Public Sub New()
    'This is where we specify the name, description, tab and panel of this parameter.
    MyBase.New("TriState", "Tri", "Represents a collection of TriState values", "Params", "Primitive")
  End Sub

  Public Overrides ReadOnly Property ComponentGuid() As System.Guid
    Get
      'Always generate a new Guid, but never change it once you've released this parameter to the public.
      Return New Guid("{2FEEF1A2-A764-431d-8C78-9BF92C78BAE1}")
    End Get
  End Property

  Protected Overrides Function Prompt_Singular(ByRef value As TriStateType) As Kernel.GH_GetterResult
    'Todo, impement this function.
  End Function
  Protected Overrides Function Prompt_Plural(ByRef values As System.Collections.Generic.List(Of TriStateType)) As Kernel.GH_GetterResult
    'Todo, impement this function.
  End Function
End Class
That is essentially all there's to it. Though you should also provide an Icon and an Exposure for this object. The Prompt_Singular and Promt_Plural methods need to be implemented. In this case we'll use standard Rhino Command Line interface to prompt for persistent values:
CopyVB.NET
Protected Overrides Function Prompt_Singular(ByRef value As TriStateType) As Kernel.GH_GetterResult
  Dim go As New Rhino.Input.Custom.GetOption()
  go.SetCommandPrompt("TriState value")
  go.AcceptNothing(True)
  go.AddOption("True")
  go.AddOption("False")
  go.AddOption("Unknown")

  Select Case go.Get()
    Case Rhino.Input.GetResult.Option
      If (go.Option().EnglishName = "True") Then value = New TriStateType(1)
      If (go.Option().EnglishName = "False") Then value = New TriStateType(0)
      If (go.Option().EnglishName = "Unknown") Then value = New TriStateType(-1)
      Return GH_GetterResult.success

    Case Rhino.Input.GetResult.Nothing
      Return GH_GetterResult.accept

    Case Else
      Return GH_GetterResult.cancel
  End Select
End Function

Protected Overrides Function Prompt_Plural(ByRef values As List(Of TriStateType)) As Kernel.GH_GetterResult
  values = New List(Of TriStateType)

  Do
    Dim val As TriStateType = Nothing
    Select Case Prompt_Singular(val)
      Case GH_GetterResult.success
        values.Add(val)

      Case GH_GetterResult.accept
        Return GH_GetterResult.success

      Case GH_GetterResult.cancel
        values = Nothing
        Return GH_GetterResult.cancel
    End Select
  Loop
End Function


List Component (VB)

[image]

Grasshopper SDK
List Component (VB)
Send Feedback

  • Introduction
  • List Parameters
  • Solving Routine

So far the example components have all operated on individual data items. This is known as One-In-One-Out. But what if you want to operate on more than one item at a time; One-In-Many-Out, Many-In-One-Out or Many-In-Many-Out? This requires that input or output parameters have a non-standard Grasshopper.Kernel..::..GH_ParamAccess flag.

List Parameters

Input and Output parameters that are part of Grasshopper components have an access flag that affects how the component treats data stored in these parameters. Take for example the Polyline component. It creates a single polyline object from a collection of corner-points. This is a Many-In-One-Out kind of logic. The Divide component creates a whole bunch of division points from a single curve. This is an example of One-In-Many-Out. The Cull components remove certain items from lists, this is an example of Many-In-Many-Out.

Most often components treat their inputs and outputs as parameters that provide individual instances of data, rather than related collections of data. This is indicated by all parameters having an GH_ParamAccess..::..item access flag. You can however assign different access flags to parameters. Preferably this flag should be assigned only once, namely in the RegisterInputParams or RegisterOutputParams method overrides. It is legal to modify an access flag as long as a solution is not currently in progress, but it is not recommended.

In this tutorial, we'll be writing a component that removes (culls) the bottom-most N objects in a collection of geometric shapes. As inputs we'll need a collection of geometry and an integer indicating how many objects the user wants to remove, and as output we'll provide the same collection of geometry, but with the bottom-most objects missing. This is therefore a Many-In-Many-Out case.

The Component code (without the RegisterInputParams, RegisterOutputParams and SolveInstance methods) may look like this:

CopyVB.NET
Public Class Component_CullByElevation
  Inherits GH_Component

  Public Sub New()
    MyBase.New("Cull Elevation", "CullZ", "Cull objects by relative elevation", "Sets", "Sequence")
  End Sub

  Protected Overrides ReadOnly Property Icon() As System.Drawing.Bitmap
    Get
      Return My.Resources.TheIconNameForThisComponent
    End Get
  End Property
  Public Overrides ReadOnly Property Exposure() As Kernel.GH_Exposure
    Get
      Return GH_Exposure.primary Or GH_Exposure.obscure
    End Get
  End Property
  Public Overrides ReadOnly Property ComponentGuid() As System.Guid
    Get
      Return New Guid("{A8FF9CBA-0837-4cd6-9198-0D17325D3F8F}")
    End Get
  End Property

  '...further example code will come here...

End Class
We'll need to register the parameters as well, and we'll use the overloaded methods to immediately assign the correct parameter access flags.
CopyVB.NET
Protected Overrides Sub RegisterInputParams(ByVal pManager As Kernel.GH_Component.GH_InputParamManager)
  'list access is non-standard, so we need to specifically assign it.
  pManager.AddGeometryParameter("Geometry", "G", "Geometry to cull", GH_ParamAccess.list)
  pManager.AddIntegerParameter("Count", "C", "Number of objects to cull", GH_ParamAccess.item, 1)
End Sub
Protected Overrides Sub RegisterOutputParams(ByVal pManager As Kernel.GH_Component.GH_OutputParamManager)
  'Again, we need to specify list access as that is not default.
  pManager.AddGeometryParameter("Geometry", "G", "Culled geometry", GH_ParamAccess.list)
End Sub
 Input parameters rigorously enforce their access. You are only allowed to retrieve individual items from inputs that have the GH_ParamAccess..::..item flag set. Lists can only be retrieved when the access is set to GH_ParamAccess..::..list and data trees can only be gotten from a GH_ParamAccess..::..tree parameter. Failure to do so will result in an error message at runtime. Output parameter are more flexible, but this is only because output access was added only in Grasshopper 0.9.0001 and strict enforcement would result in SDK breakage with previous versions.

Solving Routine

The SolveInstance implementation is basically identical to previous examples, the only difference is the way the component interacts with the parameters.

CopyVB.NET
Protected Overrides Sub SolveInstance(ByVal DA As Kernel.IGH_DataAccess)
  'Declare a new List(Of T) to hold your data.
  'This list cannot be a null reference.
  Dim geometry As New List(Of IGH_GeometricGoo)
  Dim count As Int32 = 0

  'Retrieve the whole list using DA.GetDataList().
  If (Not DA.GetDataList(0, geometry)) Then Return
  If (Not DA.GetData(1, count)) Then Return

  'Validate inputs.
  If (count < 0) Then
    AddRuntimeMessage(GH_RuntimeMessageLevel.Error, "Count must be a positive integer")
    Return
  End If

  'The number of objects to cull is larger than or
  'equal to the total number of objects. I.e. cull them all.
  If (geometry.Count <= count) Then Return

  'Iteratively remove the lowest object from the list.
  For N As Int32 = 1 To count
    Dim lowestElevation As Double = Double.MaxValue
    Dim lowestIndex As Int32 = -1

    'Iterate over all remaining geometry and find the lowest one.
    For i As Int32 = 0 To geometry.Count - 1
      If (geometry(i) Is Nothing) Then Continue For
      Dim bbox As BoundingBox = geometry(i).Boundingbox
      If (Not bbox.IsValid) Then Continue For

      Dim localElevation As Double = bbox.Min.Z
      If (localElevation < lowestElevation) Then
        lowestElevation = localElevation
        lowestIndex = i
      End If
    Next

    'Delete the lowest object.
    If (lowestIndex >= 0) Then geometry.RemoveAt(lowestIndex)
  Next

  'Assign the remaining geometry using the DA.SetDataList() method.
  DA.SetDataList(0, geometry)
End Sub


Extending the GUI (VB)

[image]

Grasshopper SDK
Extending the GUI (VB)
Send Feedback

  • Introduction
  • Default Functionality and GUI
  • Menus
  • Interaction
  • Display

This article describes how to extend the default behaviour, functionality and graphical user interface (GUI) of Grasshopper document objects. We'll focus on components as you should be familiar with those from earlier topics, but the same logic also applies to Parameters and custom objects.

Default Functionality and GUI

When you derive a class from GH_Component or GH_Param<(Of <(<'T>)>)> you get a lot of functionality and GUI for free. It is quite important that all the objects in Grasshopper behave in a consistent and predictable fashion so you typically don't need to override this default behaviour. However there can be cases where changing the default Grasshopper GUI is the best solution. Overriding the GUI is not exactly a trivial task, there are a lot of different facets to this and I'll discuss the most important ones in this topic.

There are three common ways in which the default GUI can be altered:

  • Menus
  • Interaction
  • Display

Menus

It is possibe to insert items into the default pop-up menus of objects, or even to completely alter the menu layout. If your component for example can run in two different modes, you can choose to expose an additional GUI option instead of an input parameter. These modes can then be toggled via the component pop-up menu.

At the lowest level, pop-up menus are generated by the canvas when a right mouse button click is detected over a component or parameter. The menu by default contains no items and it is the responsibility of said component or parameter to populate the menu. The top-level method which is in charge of this is AppendMenuItems which is defined inside IGH_DocumentObject and thus propagates to all objects on the canvas.

The GH_DocumentObject abstract class does not create any menu items, so unless this function is overridden, there will be no popup menu for a certain object. However, it is unlikely you derive directly from GH_DocumentObject so this should not be a problem. GH_ActiveObject, which is the base class for all objects on the canvas that actually do something (Sketches and Scribbles don't "do" anything, hence they derive directly from GH_DocumentObject), does provide a default implementation of AppendMenuItems(). The default layout of popup menus is:

  • NickName

  • Preview

  • Enabled

  • Bake

  • Warnings

  • Errors

  • Help

Although if the object in question does not support previews or baking then those items will be missing from the final menu. When overridden, AppendMenuItems() allows you to completely replace the default menu:
CopyVB.NET
Public Overrides Function AppendMenuItems(ByVal menu As ToolStripDropDown) As Boolean
  Menu_AppendGenericMenuItem(menu, "First item")
  Menu_AppendGenericMenuItem(menu, "Second item")
  Menu_AppendGenericMenuItem(menu, "Third item")
  Menu_AppendSeparator(menu)
  Menu_AppendGenericMenuItem(menu, "Fourth item")
  Menu_AppendGenericMenuItem(menu, "Fifth item")
  Menu_AppendGenericMenuItem(menu, "Sixth item")

  'Return True, otherwise the menu won't be shown.
  Return True
End Function

If you want to insert additional items into the menu it would be very annoying if you had to recreate this default menu layout from scratch every single time. So eventhough you can override AppendMenuItems() it is recommended you instead override AppendAdditionalMenuItems() which allows you to insert custom menu items between Errors and Help without losing the standard functionality:

CopyVB.NET
Public Overrides Sub AppendAdditionalMenuItems(ByVal menu As ToolStripDropDown)
  MyBase.AppendAdditionalMenuItems(menu)

  Menu_AppendGenericMenuItem(menu, "First item")
  Menu_AppendGenericMenuItem(menu, "Second item")
  Menu_AppendGenericMenuItem(menu, "Third item")
  Menu_AppendSeparator(menu)
  Menu_AppendGenericMenuItem(menu, "Fourth item")
  Menu_AppendGenericMenuItem(menu, "Fifth item")
  Menu_AppendGenericMenuItem(menu, "Sixth item")
End Sub

GH_Param(Of T) for example derives from GH_ActiveObject and re-implements AppendAdditionalMenuItems() in order to supply the Wire Display, Disconnect, Reverse, Flatten and Graft menu items that are present in all parameters. GH_Component, likewise, derives from GH_ActiveObject and it re-implements AppendAdditionalMenuItems() in order to insert the Shortest List, Longest List, Cross Reference and the parameter submenus.

Long story short; if you wish to insert additional menu items then either re-implement AppendAdditionalMenuItems() if you derive from GH_Param(Of T) or re-implement AppendAdditionalComponentMenuItems() if you derive from GH_Component:

CopyVB.NET
'If you implement IGH_Param, then override this method. If you implement IGH_Component,
'then override AppendAdditionalComponentMenuItems instead.
Protected Overrides Sub AppendAdditionalMenuItems(ByVal menu As ToolstripDropDown)
  'Place a call to the base class to ensure the default parameter menu
  'is still there and operational.
  MyBase.AppendAdditinalMenuItems(menu)

  'Now insert your own custom menu items.
  Menu_AppendGenericMenuItem(menu, "My Custom Menu Item", Addressof Menu_MyCustomItemClicked)
End Sub

Private Sub Menu_MyCustomItemClicked(ByVal sender As Object, ByVal e As EventArgs)
  Rhino.RhinoApp.WriteLine("Alcohol doesn't affect me...")
End Sub
There's a lot of menu utility functions provided by GH_DocumentObject. They all start with "Menu_" and they'll make it much easier to insert formatted menu items. But of course nothing is stopping you from using typical System.Windows.Forms plumbing to extend the pop-up menu.

Interaction

You can also choose to handle specific mouse and keyboard events. You could for example choose to respond to a mouse double-click event on your component. Complicated objects such as Gradients and Graph Mappers handle all sorts of mouse events to provide grip-dragging functionality directly within the Grasshopper canvas. todo: finish this section

Display

Finally, it is possible to override the way an object displays itself on the canvas. These alterations can be minor, mere additions to the default display, or they can be radically different (as with the Gradient and Graph Mapper objects). For a detailed explanation regarding display overrides, see the Custom Attributes topic.


Custom Attributes (VB)

[image]

Grasshopper SDK
Custom Attributes (VB)
Send Feedback
  • Introduction
  • Grasshopper.Kernel.GH_Attributes
  • Layout
  • Render

This article contains a step-by-step walkthrough regarding custom object display. Objects on the Grasshopper canvas consist of two parts. The most important piece is the class that implements the IGH_DocumentObject interface. This interface provides the basic plumbing needed to make objects work within a Grasshopper node network. The interface part of objects however is handled separately. Every IGH_DocumentObject carries around an instance of a class that implements the IGH_Attributes interface (indeed, every IGH_DocumentObject knows how to create its own stand-alone attributes) and it is this class that takes care of display, mouse interactions, popup menus, tooltips and so forth.

In this article I'll explain how you can create your own attributes object. Since it's not possible to have an IGH_Attributes instance work on its own, we need an IGH_DocumentObject to tie it to. For this article we'll assume we have a custom simple parameter (i.e. without persistent data) that holds integers.

CopyVB.NET
Public Class MySimpleIntegerParameter
  Inherits GH_Param(Of Types.GH_Integer)

  Public Sub New()
    MyBase.New(New GH_InstanceDescription("Integer with stats", "Int(stats)", "Integer with basic statistics", "Params", "Primitive"))
  End Sub

  Public Overrides ReadOnly Property ComponentGuid() As System.Guid
    Get
      Return New Guid("{33D07726-8298-4104-9EBC-5398D8AD5420}")
    End Get
  End Property
End Class

What we'll do is create a special attributes object for this parameter which also displays the median and mean values of the collection of all integers. We want to put this information below the parameter name, but inside the parameter box. The first step here is to override the CreateAttributes() on MySimpleIntegerParameter and assign a new instance of our (yet to be written) attributes class:

CopyVB.NET
Public Overrides Sub CreateAttributes()
  m_attributes = New MySimpleIntegerParameterAttributes(Me)
End Sub
That's it, no more code is required inside the MySimpleIntegerParameter class. This part at least is simple. If you don't override the CreateAttributes() method, then an instance of GH_FloatingParamAttributes will be created instead. If your parameter is to be attached to a component as an input or output, then the component will assign an instance of GH_LinkedParamAttributes to the parameter and CreateAttributes() will never be called.

Grasshopper.Kernel.GH_Attributes

Although the IGH_Attributes interface is required for custom attributes, it is usually a good idea to derive from one of the abstract attribute classes already available. GH_Attributes<(Of <(<'T>)>)> is the most basic and obvious choice and it implements a large amount of methods with default behaviour, saving you a lot of time and effort:

CopyVB.NET
Public Class MySimpleIntegerParameterAttributes
  Inherits GH_Attributes(Of MySimpleIntegerParameter)

  Public Sub New(ByVal owner As MySimpleIntegerParameter)
    MyBase.New(owner)
  End Sub
End Class

This is enough so far to make it work, eventhough all the logic is still standard. We need to start overriding methods in MySimpleIntegerParameterAttributes to suit our needs. But first some basic information regarding the default behaviour.

GH_Attributes(Of T) assumes that the object that owns it is rectangular. This is true for most objects in Grasshopper, but there are some notable exceptions such as Pie-Graphs, Sketches and Scribbles. But this assumption (which holds true in our case) allows GH_Attributes(Of T) to supply basic functionality for a wide variety of methods.

All attributes have a property that defines the size of the object called Bounds. Basically everything that happens outside of the Bounds goes by unnoticed. Also, if the Bounds rectangle is not visible within the canvas area, Grasshopper might decide to not even bother calling any painting methods.

Because our parameter will be rectangular, we don't have to override any of the picking logic, as the default implementation of IsPickRegion, IsMenuRegion and IsTooltipRegion will already work.

Layout

We do however need to supply custom Layout logic. The width of our Attributes depends on both the length of the NickName of the MySimpleIntegerParameter that owns these attributes and on the length of the statistics information we want to include. The height of the parameter however is fixed, though larger than the standard height for parameters in Grasshopper.

In order to supply custom layout logic, we need to override the Layout method. In this case I measure the width of the NickName of the Owner object, and make sure the parameter is never narrower than 80 pixels:

CopyVB.NET
Protected Overrides Sub Layout()
  'Compute the width of the NickName of the owner (plus some extra padding),
  'then make sure we have at least 80 pixels.
  Dim width As Int32 = GH_FontServer.StringWidth(Owner.NickName, GH_FontServer.Standard)
  width = Math.Max(width + 10, 80)

  'The height of our object is always 60 pixels
  Dim height As Int32 = 60

  'Assign the width and height to the Bounds property.
  'Also, make sure the Bounds are anchored to the Pivot
  Bounds = New RectangleF(Pivot, New SizeF(width, height))
End Sub
The Pivot is a PointF structure that is changed when the object is dragged. It is therefore important that you always 'anchor' the layout of some attributes to the Pivot. If you fail to do so, your attributes will become undraggable.

There is a method you can override that will be called prior to the call to Layout which can be used to destroy any cached data you might have that's to do with display. But note that if you override ExpireLayout you must place a call to the base class method as well:

CopyVB.NET
Public Overrides Sub ExpireLayout()
  MyBase.ExpireLayout()

  'Destroy any data you have that becomes
  'invalid when the layout expires.
End Sub

Render

Now that we have handled the layout, we need to override the display of the parameter. There's two parts to doing so. You always have to override the Render method, as this is where the drawing takes place. Render is called a number of times as there are several 'layers' or 'channels' to a single Grasshopper canvas. At first, the background of the canvas is drawn. During this process attributes are not yet involved. Then there will be four channels where IGH_Attributes will be allowed to draw various shapes.

First the groups are drawn (as they are behind all other objects), but every GH_Attributes.Render() method will be called once for the Groups channel. Typically you should not draw anything in the Groups channel.

Next up is the Wires channel where all parameter connector wires are drawn. If your object has input parameters or is a parameter, it is your responsibility to draw all wires coming into your object. Wires going out the right side will be drawn by the recipient objects.

Next the actual components and parameters themselves are drawn inside the Objects channel. This is typically the most work, though there are lots of classes that take care of common tasks. The default visual style of components and parameter objects is the shiny rectangle with rounded corners. You can use the GH_Capsule type to draw these shapes with a minimum of fuss.

Ultimately there's an Overlay channel which is rarely used but it allows you to draw shapes that need to be on top of all other components and parameters. After this, there are still more channels to do with canvas widgets, but IGH_Attributes are not involved here.

Inside our implementation of the Render() method, we need to draw the wires coming into the MySimpleIntegerParameter, then the parameter capsule, while taking care to assign the correct colours (grey for normal, green for selected, dark for disabled, orange for warnings and red for errors). Finally we have to draw three lines of text on top of the capsule; the name of the owner, the median integer and the mean integer. The important types involved here are:

  • GH_Canvas
  • GH_Painter
  • GH_Palette
  • GH_RuntimeMessageLevel
  • GH_Capsule
  • GH_FontServer
CopyVB.NET
Protected Overrides Sub Render(ByVal canvas As GH_Canvas, ByVal graphics As Graphics, ByVal channel As GH_CanvasChannel)
  'Render all the wires that connect the Owner to all its Sources.
  If (channel = GH_CanvasChannel.Wires) Then
    RenderIncomingWires(canvas.Painter, Owner.Sources, Owner.WireDisplay)
    Return
  End If

  'Render the parameter capsule and any additional text on top of it.
  If (channel = GH_CanvasChannel.Objects) Then
    'Define the default palette.
    Dim palette As GH_Palette = GH_Palette.Normal

    'Adjust palette based on the Owner's worst case messaging level.
    Select Case Owner.RuntimeMessageLevel
      Case GH_RuntimeMessageLevel.Warning
        palette = GH_Palette.Warning

      Case GH_RuntimeMessageLevel.Error
        palette = GH_Palette.Error
    End Select

    'Create a new Capsule without text or icon.
    Dim capsule As GH_Capsule = GH_Capsule.CreateCapsule(Bounds, palette)

    'Render the capsule using the current Selection, Locked and Hidden states.
    'Integer parameters are always hidden since they cannot be drawn in the viewport.
    capsule.Render(graphics, Selected, Owner.Locked, True)

    'Always dispose of a GH_Capsule when you're done with it.
    capsule.Dispose()
    capsule = Nothing

    'Now it's time to draw the text on top of the capsule.
    'First we'll draw the Owner NickName using a standard font and a black brush.
    'We'll also align the NickName in the center of the Bounds.
    Dim format As New StringFormat()
    format.Alignment = StringAlignment.Center
    format.LineAlignment = StringAlignment.Center
    format.Trimming = StringTrimming.EllipsisCharacter

    'Our entire capsule is 60 pixels high, and we'll draw
    'three lines of text, each 20 pixels high.
    Dim textRectangle As RectangleF = Bounds
    textRectangle.Height = 20

    'Draw the NickName in a Standard Grasshopper font.
    graphics.DrawString(Owner.NickName, GH_FontServer.Standard, Brushes.Black, textRectangle, format)

    'Now we need to draw the median and mean information.
    'Adjust the formatting and the layout rectangle.
    format.Alignment = StringAlignment.Near
    textRectangle.Inflate(-5, 0)

    textRectangle.Y += 20
    graphics.DrawString(String.Format("Median: {0}", Owner.MedianValue), _
                        GH_FontServer.StandardItalic, Brushes.Black, _
                        textRectangle, format)

    textRectangle.Y += 20
    graphics.DrawString(String.Format("Mean: {0:0.00}", Owner.MeanValue), _
                        GH_FontServer.StandardItalic, Brushes.Black, _
                        textRectangle, format)

    'Always dispose of any GDI+ object that implement IDisposable.
    format.Dispose()
  End If
End Sub
 Note that in this case I assume that MySimpleIntegerParameter has two properties called MedianValue and MeanValue. I haven't written those, as they are not within the scope of this topic.

If you have cached display objects (for whatever reason I don't want to hear), a good place to ensure they are valid would be the PrepareForRender method. It is called once (and only once) just before any calls to Render(). You do not need to call the overridden method as it is empty by default.


Custom Component Options (VB)

[image]

Grasshopper SDK
Custom Component Options (VB)
Send Feedback

  • Introduction
  • Class Level variables
  • (De)serialization of custom data
  • Context menu changes

This article discusses how to add custom options to a component and have them included in *.gh/*.ghx (de)serialization. It skips over some portions of Component design which have already been handled in previous topics, so do not read this article before familiarizing yourself with the My First Component topic.

The component we'll create in this article will sort a list of numbers and have the custom option to convert those numbers to absolute values prior to sorting. However, rather than providing this option as a boolean input parameter, we'll allow people to set it via the Component context menu. We'll need to do four special things to achieve this, to wit:

  • Declare a class level variable/property.
  • Provide access to the variable from within the Component menu.
  • Include the variable in (de)serialization.
  • Record undo events when changing the value.

Before you start with this topic, create a new class that derives from GH_Component, as outlined in the My First Component topic.

This component will require one input parameter and one output parameter, both of type Number with list access:

CopyVB.NET
...
Protected Overrides Sub RegisterInputParams(ByVal pManager As GH_Component.GH_InputParamManager)
  pManager.AddNumberParameter("Values", "V", "Values to sort", GH_ParamAccess.list)
End Sub
Protected Overrides Sub RegisterOutputParams(ByVal pManager As Kernel.GH_Component.GH_OutputParamManager)
  pManager.AddNumberParameter("Values", "V", "Sorted values", GH_ParamAccess.list)
End Sub
...
Assuming for now we'll have a local property called Absolute() which gets a single boolean, we can also already write the SolveInstance() method:
CopyVB.NET
...
Protected Overrides Sub SolveInstance(ByVal DA As Kernel.IGH_DataAccess)
  Dim values As New List(Of Double)
  If (Not DA.GetDataList(0, values)) Then Return
  If (values.Count = 0) Then Return

  'Don't worry about where the Absolute property comes from, we'll get to it soon.
  If (Absolute) Then
    For i As Int32 = 0 To values.Count - 1
      values(i) = Math.Abs(values(i))
    Next
  End If

  values.Sort()
  DA.SetDataList(0, values)
End Sub
...

Class Level variables

The 'Absolute' option for this component applies to the entire object, but not to other instances of this component. Since it needs to survive (i.e. retain its value) for as long as the component lives, it has to be declared as a class level variable:

CopyVB.NET
...
Private m_absolute As Boolean = False
Public Property Absolute() As Boolean
  Get
    Return m_absolute
  End Get
  Set(ByVal value As Boolean)
    m_absolute = value
    If (m_absolute) Then
      Message = "Absolute"
    Else
      Message = "Standard"
    End If
  End Set
End Property
...
The m_absolute field is a private field (only accessible from within this component) and it is exposed publicly via the Absolute() property, which allows both getting and setting. Furthermore, whenever the m_absolute field is set, the Absolute() property ensures that the correct message is assigned. The Message field on GH_Component allows you to set a string which will be displayed underneath the component on the canvas. This is to signal to users that there's an option they can change which is not directly accessible via the input parameters. Note that the message is not set until the Absolute() property is accessed, so you should specifically place a call to Absolute = False (or True) in the constructor.

It is of course possible to add any number of custom fields to a component, but you can only attach a single message, if you have more than one field you want to make the user aware of, you'll need to get creative.

(De)serialization of custom data

When you add options or states to your component which need to be 'sticky', you'll also need to (de)serialize them correctly. (De)serialization is used when saving and opening files, when copying and pasting objects and during undo/redo actions. In this particular case, we only need to add a single boolean to the standard file archive. Serialization in Grasshopper happens using the GH_IO.dll methods and types, not via standard framework mechanisms such as the SerializableAttribute.

Override the Write and Read methods on GH_Component and be sure to always call the base implementation.

CopyVB.NET
...
Public Overrides Function Write(ByVal writer As GH_IO.Serialization.GH_IWriter) As Boolean
  'First add our own field.
  writer.SetBoolean("Absolute", Absolute)
  'Then call the base class implementation.
  Return MyBase.Write(writer)
End Function
Public Overrides Function Read(ByVal reader As GH_IO.Serialization.GH_IReader) As Boolean
  'First read our own field.
  Absolute = reader.GetBoolean("Absolute")
  'Then call the base class implementation.
  Return MyBase.Read(reader)
End Function
...

Context menu changes

We'll also need to add an additional menu item to the component context menu, then handle the click event for that item. Adding items to a context menu is best done via the AppendAdditionalComponentMenuItems method. It allows you to insert anu number of item in between the Bake and the Help items. The easiest way to add menu items is to use the Shared methods on GH_DocumentObject such as Menu_AppendItem or one of the overloads. In this case we also want to assign a tooltip text to the item which cannot be done from inside Menu_AppendItem().

CopyVB.NET
...
Protected Overrides Sub AppendAdditionalComponentMenuItems(ByVal menu As System.Windows.Forms.ToolStripDropDown)
  'Append the item to the menu, making sure it's always enabled and checked if Absolute is True.
  Dim item As ToolStripMenuItem = Menu_AppendItem(menu, "Absolute", AddressOf Menu_AbsoluteClicked, True, Absolute)
  'Specifically assign a tooltip text to the menu item.
  item.ToolTipText = "When checked, values are made absolute prior to sorting."
End Sub
...

When this menu item is clicked, the delegate assigned inside the Menu_AppendItem() method will be invoked. It is here that we must handle a click event. There are usually three steps involved in handling clicks; Record the current state as an undo event, change the state, trigger a new solution:

CopyVB.NET
...
Private Sub Menu_AbsoluteClicked(ByVal sender As Object, ByVal e As EventArgs)
  RecordUndoEvent("Absolute")
  Absolute = Not Absolute
  ExpireSolution(True)
End Sub
...
Since our Write() and Read() methods handle the (de)serialization of the Absolute field, we can use the default RecordUndoEvent method. It is possible to define your own undo records, but that is a topic for another day.


Simple Component (C#)

[image]

Grasshopper SDK
Simple Component (C#)
Send Feedback

  • Introduction
  • Grasshopper.Kernel.GH_Component
  • The Component Constructor
  • Component GUIDs
  • Parameter Registration
  • The Solver Routine

This article contains an exhaustive, step by step explanation of how to build your first component in C#. It will skip over any complicated issues (such as mathematics, geometry and data handling) in order to reduce the totality of new concepts. You will however need to have a good understanding of basic OOP concepts such as classes, types and inheritance. If you do not understand these DotNET essentials, we recommend you start with some other reading material first.

Grasshopper.Kernel.GH_Component

All you need to do in order to define a new component is to inherit from the GH_Component base class in Grasshopper. Assuming you've set up your project correctly, create a new, blank class in your project:

At this point a new file should be created (MyFirstComponent.cs) with the following content:

CopyC#
using System;
using System.Collections.Generic;
using System.Text;

namespace MyFirstProject
{
  public class MyFirstComponent
  {
  }
}
Since we'll be using primarily types from the Grasshopper.Kernel namespace. We'll import this namespace so that we have easy access to all types contained within it (unless otherwise specified, all further types discussed in this topic belong to Grasshopper.Kernel). We can also remove some unnecessary using statements while we're at it:
CopyC#
using System;
using Grasshopper.Kernel;

namespace MyFirstProject
{
  public class MyFirstComponent
  {
  }
}
 The idea is that this class will be loaded by Grasshopper whenever this component library is loaded, but in order for that to happen we must make sure that this class is 'visible' from outside this project. I.e., we need to make the accessor public:
CopyC#
using System;
using Grasshopper.Kernel;

namespace MyFirstProject
{
  // If a class is not public, it won't be visible
  // from where Grasshopper is sitting.
  public class MyFirstComponent
  {
  }
}
 Now, we need to derive our MyFirstComponent class from the GH_Component base class defined inside Grasshopper. GH_Component takes care of almost all the complicated actions and mannerisms that constitute a component. It will handle data conversion, GUI, menus, file Input/Output, Error trapping and much, much more. This allows us to focus only on the unique aspects of our component. In order to derive from GH_Component, add the following line directly underneath the class declarator:
CopyC#
using System;
using Grasshopper.Kernel;

namespace MyFirstProject
{
  public class MyFirstComponent : GH_Component
  {
  }
}
 Deriving (inheriting) from GH_Component requires you to implement a number of methods. Visual Studio can insert default implementations for all of these via the Implement Abstract Class menu option:

At this point you should see the following:

CopyC#
using System;
using Grasshopper.Kernel;

namespace MyFirstProject
{
  public class MyFirstComponent : GH_Component
  {
    protected override void RegisterInputParams(GH_Component.GH_InputParamManager pManager)
    {
      throw new NotImplementedException();
    }

    protected override void RegisterOutputParams(GH_Component.GH_OutputParamManager pManager)
    {
      throw new NotImplementedException();
    }

    protected override void SolveInstance(IGH_DataAccess DA)
    {
      throw new NotImplementedException();
    }

    public override Guid ComponentGuid
    {
      get { throw new NotImplementedException(); }
    }
  }
}

The Component Constructor

As we've seen in the previous section, Visual Studio will populate the MyFirstComponent class with a collection of properties and methods that we need to implement. There is however another method that requires our attention that is missing. This is the constructor. The constructor is a special method inside each class which gets called when the class is instantiated (or "constructed"). This can happen only once (we feeble humans can only be born once as well after all) and it necessarily happens before anything else is allowed to happen. The GH_Component base class has a constructor which is not empty, so we have to call that constructor from within our constructor and supply it with all the information it needs. Add the following code near the top of the MyFirstComponent class:

CopyC#
using System;
using Grasshopper.Kernel;

namespace MyFirstProject
{
  public class MyFirstComponent : GH_Component
  {
    public MyFirstComponent() : base("MyFirst", "MFC", "My first component", "Extra", "Simple")
    {
    }
  ...
As you can see we need to supply a set of text constants, which are used to name and identify our component within the Grasshopper GUI. The text fields are:

Parameter | Purpose
name | The name of our component. The name is what appears on tooltips and panel dropdowns.
abbreviation | The abbreviation of our component. The abbreviation is what is written on the component once it appears on the canvas.
description | A description of our component. The description is used on tooltips to provide users with a more detailed idea about what this component is for.
category | The tab category for the component. The category equals the name of the tab onto which the component will appear. If a non-existing category is supplied, a new Tab will be added to the Grasshopper GUI.
subCategory | The panel category for the component. The sub-category equals the name of the panel onto which the component will appear. If a non-existing sub-category is supplied, a new Panel will be added to the Category Tab.

Component Guids

Every type of object inside a Grasshopper document must have a ComponentGuid associated with it. When a Grasshopper file (*.gh or *.ghx) is written these Guids are used as markers, so it becomes clear what portions of the file belong to which object. When the file is read back in, that marker is compared against the list of all cached components and if a match is found the appropriate component is asked to deserialize itself from the appropriate file portion. When no matching component can be found it is assumed that whoever wrote the file had access to certain components that are not available locally, and that portion of the file is dutifully skipped.

So, long story short, we need to invent a Guid (Globally Unique IDentifier) that will positively and unerringly indicate this component. You can generate new Guids using an Online Guid Generator or Microsofts popular guidgen.exe. Never re-use a Guid and never edit one by hand. Always generate a proper one using an official tool.

Once you have a new Guid standing by, modify the ComponentGuid property to return it:

CopyC#
...
public override Guid ComponentGuid
{
  get { return new Guid("419c3a3a-cc48-4717-8cef-5f5647a5ecfc"); }
}
...

Parameter Registration

Components have unique input and output parameters which are most often fixed. We are ignoring those rare cases where a component either has no inputs or no outputs, or where there is a variable number of parameters. There are two methods that allow you to define (or "register") these parameters. These routines are called from within the base class constructor and they are only called once. Let's have a look at the default implementation that Visual Studio generated again:

CopyC#
...
protected override void RegisterInputParams(GH_Component.GH_InputParamManager pManager)
{
  throw new NotImplementedException();
}

protected override void RegisterOutputParams(GH_Component.GH_OutputParamManager pManager)
{
  throw new NotImplementedException();
}
...
Although it would technically be possible to manually register parameters, we highly recommend you use the methods on pManager. pManager has methods for adding all the basic parameter types and it often even allows you to specify default values:

In this example we'll only create two parameters (one input, one output) and they will both be of type String.

CopyC#
...
protected override void RegisterInputParams(GH_Component.GH_InputParamManager pManager)
{
  pManager.AddTextParameter("String", "S", "String to reverse", GH_ParamAccess.item);
}

protected override void RegisterOutputParams(GH_Component.GH_OutputParamManager pManager)
{
  pManager.AddTextParameter("Reverse", "R", "Reversed string", GH_ParamAccess.item);
}
...
When we compile this project (assuming it has been setup correctly), the component will already be available on the Grasshopper tabs and it can be placed onto the canvas:

The Solver Routine

Our new component sure looks perky and expensive, but it doesn't do anything yet. We still need to write the contents of the SolveInstance() subroutine, which is where all the action takes place. The SolveInstance() function is called upon whenever the component needs to handle input data. In this particular example, if we plug a list of twelve strings into the [S] parameter, SolveInstance() will be called twelve times.

As you may already have guessed, the component we're writing will reverse a given textual string from [S] and output the result to [R]. Since we're operating on individual items of data (the default behaviour), all we need to do inside the SolveInstance() function is retrieve the current String from [S], reverse it and assign it to [R]. Now, String reversal is not a function that is directly available in the framework String type, so we need to actually do some thinking:

CopyC#
...
protected override void SolveInstance(IGH_DataAccess DA)
{
  // Declare a variable for the input String
  string data = null;

  // Use the DA object to retrieve the data inside the first input parameter.
  // If the retieval fails (for example if there is no data) we need to abort.
  if (!DA.GetData(0, ref data)) { return; }

  // If the retrieved data is Nothing, we need to abort.
  // We're also going to abort on a zero-length String.
  if (data == null) { return; }
  if (data.Length == 0) { return; }

  // Convert the String to a character array.
  char[] chars = data.ToCharArray();

  // Reverse the array of character.
  System.Array.Reverse(chars);

  // Use the DA object to assign a new String to the first output parameter.
  DA.SetData(0, new string(chars));
}
...


Simple Mathematics (C#)

[image]

Grasshopper SDK
Simple Mathematics (C#)
Send Feedback

  • Introduction
  • Input parameters
  • Output parameters
  • SolveInstance

This article contains a brief example of a component that deals with some simple mathematics and multiple input and output parameters. We'll discuss parameter order, legacy support for changing component layouts and default values for input parameters. We will not be dealing with any of the basics of component development. You should have read the My First Component topic before starting this one.

For this component we'll bundle the Sine(), Cosine() and Tangent() trigonometry functions while allowing inputs to be specified in either Radians or Degrees. We'll need to define two input parameter (one of which will have a default value) and three output parameters.

Before you start with this topic, create a new class that derives from Grasshopper.Kernel.GH_Component, as outlined in the My First Component topic.

Input parameters

This component will require two input parameters, one of which has a default value. We'll need to register these parameters inside the RegisterInputParams() method:

CopyC#
...
protected override void RegisterInputParams(GH_Component.GH_InputParamManager pManager)
{
  pManager.AddNumberParameter("Angle", "A", "The angle to measure", GH_ParamAccess.item);
  pManager.AddBooleanParameter("Radians", "R", "Work in Radians", GH_ParamAccess.item, true); // The default value is 'true'
}
...
The first parameter is of type Double meaning it accepts floating point values. It only has a name, abbreviation, description and access level defined. The second parameter is of type bool and it will accept true and false values. The pManager object allows us to specify a single default value for many parameter types.

The order in which we register the parameters is also the order in which they'll appear on the component. We should not change the order (or the types, or the number) of the parameters once the component has been released to the world. Every Grasshopper file that was saved with one of our components will expect to be deserialized by the exact same component layout. If you add an additional parameter to an component and someone tries to open a file which was saved while an older version of that component, it will fail to deserialize as the data in the file no longer matches the new layout. An exception will be thrown and Grasshopper will short circuit that particular instance. The entire component and all connections to it will be missing when the file is eventually displayed to the user.

If you must change the parameter layout of a component, you should create a completely new GH_Component class with a different ComponentGuid, while maintaining the old component type for legacy file purposes. You can hide xomponents from the Grasshopper GUI by overriding the Exposure property of the GH_Component class and changing the return value to GH_Exposure.hidden:

CopyC#
public override Grasshopper.Kernel.GH_Exposure Exposure
{
  get { return GH_Exposure.hidden; }
}

Output parameters

Our component will also need three output parameters. Output parameters differ from input parameters in that they have much fewer options. Users cannot add expressions to them, there are no default values, they don't support persistent data. Outputs are always cleared when the component expires, and they are slowly filled out from within the SolveInstance() routine.

CopyC#
...
protected override void RegisterOutputParams(GH_Component.GH_OutputParamManager pManager)
{
  pManager.AddNumberParameter("Sin", "sin", "The sine of the Angle.", GH_ParamAccess.item);
  pManager.AddNumberParameter("Cos", "cos", "The cosine of the Angle.", GH_ParamAccess.item);
  pManager.AddNumberParameter("Tan", "tan", "The tangent of the Angle.", GH_ParamAccess.item);
}
...

SolveInstance

The SolveInstance() implementation for this component is hardly any more complicated than it was for My First Component. The only difference is that we now have more than one parameter on each side.

CopyC#
...
protected override void SolveInstance(IGH_DataAccess DA)
{
  // Declare variables to contain all inputs.
  // We can assign some initial values that are either sensible or indicative.
  double angle = double.NaN;
  bool radians = false;

  // Use the DA object to retrieve the data inside the input parameters.
  // If the retrieval fails (for example if there is no data) we need to abort.
  if (!DA.GetData(0, ref angle)) { return; }
  if (!DA.GetData(1, ref radians)) { return; }

  // If the angle value is not a valid number, we should abort.
  if (!Rhino.RhinoMath.IsValidDouble(angle)) { return; }

  // If the user wants to work in degrees rather than radians,
  // we assume that angle is defined in degrees.
  // We need to convert it into Radians again.
  if (!radians)
  {
    angle = Rhino.RhinoMath.ToRadians(angle);
  }

  // Now we are ready to assign the outputs via the DA object.
  // Since the Sin(), Cos() and Tan() never fail, we might as well
  // combine them with the assignment.
  DA.SetData(0, Math.Sin(angle));
  DA.SetData(1, Math.Cos(angle));
  DA.SetData(2, Math.Tan(angle));
}
...


Simple Geometry (C#)

[image]

Grasshopper SDK
Simple Geometry (C#)
Send Feedback

  • Introduction
  • Input parameters
  • Output parameters
  • SolveInstance

This article shows how to use some of the simpler geometry types and classes in the RhinoCommon and Grasshopper SDK. We'll discuss how to deal with different access levels of input data and invalid Structs vs. invalid and null Classes. You should have read the My First Component and Simple Mathematics topics before starting this one.

This component will perform a simple Circle|Line Split operation. We'll retrieve a single Circle and a single Line input, make sure the data is valid, project the line onto the circle plane, determine whether or not the Split operation is valid and then output the two arcs on either side of the slicing line.

Before you start with this topic, create a new class that derives from Grasshopper.Kernel.GH_Component, as outlined in the My First Component topic.

Input parameters

This part of the component is very similar to the Simple Mathematics topic. Except this time there will be no default values.

CopyC#
...
protected override void RegisterInputParams(GH_Component.GH_InputParamManager pManager)
{
  pManager.AddCircleParameter("Circle", "C", "The circle to slice", GH_ParamAccess.item);
  pManager.AddLineParameter("Line", "L", "Slicing line", GH_ParamAccess.item);
}
...
The first parameter is of type Param_Circle and the data it contains will consist solely of GH_Circle. GH_Circle is a class that wraps the Rhino.Geometry.Circle structure. It provides methods that allow Grasshopper to incorporate RhinoCommon circles into the default GUI. These methods include Archiving, Previewing, Baking and Casting (Converting) functions. However, when accessing data inside a Param_Circle parameter, you are not limited to the GH_Circle type, as we shall see.

The second parameter is of type Param_Line and it works very similar to the Param_Circle type discussed above.

Output parameters

Our component will output two arcs on success, or nulls on failure.

CopyC#
...
protected override void RegisterOutputParams(GH_Component.GH_OutputParamManager pManager)
{
  pManager.AddArcParameter("Arc A", "A", "First Split result.", GH_ParamAccess.item);
  pManager.AddArcParameter("Arc B", "B", "Second Split result.", GH_ParamAccess.item);
}
...

SolveInstance

The SolveInstance() implementation for this component is responsible for the following steps:

  1. Declare placeholder variables for the input data.
  2. Retrieve input data.
  3. Test input data for validity.
  4. Project line segment onto circle plane.
  5. Test projected segment for validity.
  6. Solve intersections for circle and projected segment.
  7. Abort on insufficient intersections.
  8. Create the slice arcs.
  9. Assign arcs to the output parameters.

Item 2 and 9 however can be approached from different directions. First I'll show you the recommended approach and then we'll have a look at the alternatives:

CopyC#
...
protected override void SolveInstance(IGH_DataAccess DA)
{
  // 1. Declare placeholder variables and assign initial invalid data.
  //    This way, if the input parameters fail to supply valid data, we know when to abort.
  Rhino.Geometry.Circle circle = Rhino.Geometry.Circle.Unset;
  Rhino.Geometry.Line line = Rhino.Geometry.Line.Unset;

  // 2. Retrieve input data.
  if (!DA.GetData(0, ref circle)) { return; }
  if (!DA.GetData(1, ref line)) { return; }

  // 3. Abort on invalid inputs.
  if (!circle.IsValid) { return; }
  if (!line.IsValid) { return; }

  // 4. Project line segment onto circle plane.
  line.Transform(Rhino.Geometry.Transform.PlanarProjection(circle.Plane));

  // 5. Test projected segment for validity.
  if (line.Length < Rhino.RhinoMath.ZeroTolerance)
  {
    AddRuntimeMessage(GH_RuntimeMessageLevel.Error, "Line could not be projected onto the Circle plane");
    return;
  }

  // 6. Solve intersections and 7. Abort if there are less than two intersections.
  double t1;
  double t2;
  Rhino.Geometry.Point3d p1;
  Rhino.Geometry.Point3d p2;

  switch (Rhino.Geometry.Intersect.Intersection.LineCircle(line, circle, out t1, out p1, out t2, out p2))
  {
    case Rhino.Geometry.Intersect.LineCircleIntersection.None:
      AddRuntimeMessage(GH_RuntimeMessageLevel.Warning, "No intersections were found");
      return;

    case Rhino.Geometry.Intersect.LineCircleIntersection.Single:
      AddRuntimeMessage(GH_RuntimeMessageLevel.Warning, "Only a single intersection was found");
      return;
  }

  // 8. Create slicing arcs.
  double ct;
  circle.ClosestParameterTo(p1, out ct);

  Rhino.Geometry.Vector3d tan = circle.TangentAt(ct);

  // 9. Assign output arcs.
  DA.SetData(0, new Rhino.Geometry.Arc(p1, tan, p2));
  DA.SetData(1, new Rhino.Geometry.Arc(p1, -tan, p2));
}
...

As I mentioned before, the first input parameter is of type Param_Circle and it contains data of type GH_Circle. But when we're accessing the parameter via the DA.GetData(0, circle) method, we're using Rhino.Geometry.Circle instead of GH_Circle. The DA.GetData() method is capable of converting data from the intrinsic parameter type into requested types, provided the conversion makes sense. GH_Circle to Rhino.Geometry.Circle is a perfectly valid conversion, GH_Circle to Rhino.Geometry.Transform would not be.

The Grasshopper Component SDK has been designed on the premise that the bulk of all components that operate on data only care about the data itself, not how it is wrapped up inside the Grasshopper data structures. The conversion routines that translate GH_Circle data into Rhino.Geometry.Circle data (and obviously also GH_Number into System.Double, and GH_Colour into System.Drawing.Color etc.), have been highly optimised and should be used in almost all circumstances.

If however you feel the need to get access to the GH_Circle data directly, you can retrieve that instance in the same fashion:

CopyC#
...
Grasshopper.Kernel.Data.GH_Circle circle = null;
if (!DA.GetData(0, circle)) { return; }
...
Note that a single instance of GH_Circle may be shared among any number of parameters in Grasshopper, and thus changing one will change data everywhere. If you request Rhino.Geometry.Circle, System.Double or System.Drawing.Color instead of GH_Circle, GH_Number or GH_Colour you won't have to worry about this pitfall since you will always be given an object that has been disassociated from the (potentially shared) wrapper type.

Similarly, you are allowed to store output data in different formats as well. Instead of:

CopyC#
DA.SetData(0, new Rhino.Geometry.Arc(p1, tan, p2));
you could also provide an instance of Grasshopper.Kernel.Types.GH_Arc:
CopyC#
Grasshopper.Kernel.Types.GH_Arc gh_arc = new Grasshopper.Kernel.Types.GH_Arc(new Rhino.Geometry.Arc(p1, tan, p2));
DA.SetData(0, gh_arc);


Simple Data Types (C#)

[image]

Grasshopper SDK
Simple Data Types (C#)
Send Feedback

  • Introduction
  • The IGH_Goo interface
  • The GH_Goo abstract class
  • An Example Type
    • Constructors
    • Formatters
    • Serialization
    • Casting

This article discusses how Grasshopper deals with data items and types. It's a rather complicated topic as data is an integral part of the Grasshopper process and GUI. Grasshopper needs to be able to (de)serialize data, display data in tooltips, convert data to other types of data, prompt the user for persistent data, draw geometry preview data in viewports and bake geometric data. In this topic I'll only talk about non-geometric data, we'll get to previews and baking in a later topic.

Practically all native data types in Grasshopper are based either on a .NET Framework type or a RhinoCommon SDK type. For example System.Boolean, System.String, Rhino.Geometry.Point3d and Rhino.Geometry.Brep to name but a few. However the parameters in Grasshopper don't directly store Booleans, String, Points and Breps as these types can't handle themselves in the cauldron that is Grasshopper.

All data used in Grasshopper must implement the IGH_Goo interface. IGH_Goo defines the bare minimum of methods and properties for any kind of data before it is allowed to play ball.

The IGH_Goo interface

In this section I'll briefly discuss all the methods and properties that are defined in IGH_Goo. What they're for, who uses them at what time, etc, etc.

Method Purpose
CopyC#
bool IsValid { get{} }
         Not all data types are valid all the time, and this property allows you to teint the current instance of your data. When data is invalid it will often be ignored by components.
CopyC#
string TypeName { get{} }
         This property must return a human-readable name for your data type.
CopyC#
string TypeDescription { get{} }
         This property must return a human-readable description of your data type.
CopyC#
IGH_Goo Duplicate()
         This function must return an exact duplicate of the data item. Data is typically shared amongst multiple Grasshopper parameters, so before data is changed, it first needs to copy itself. When data only contains ValueTypes and Primitives, making a copy of an instance is usually quite easy.
CopyC#
string ToString()
         This function is called whenever Grasshopper needs a human-readable version of your data. It is this function that populates the data panel in parameter tooltips. You don't need to create a String that is parsable, it only needs to be somewhat informative.
CopyC#
IGH_GooProxy EmitProxy()
         Data proxies are used in the Data Collection Manager. You can ignore this function (i.e. Return Nothing) without crippling your data type.
CopyC#
bool CastTo<T>(out T target)

Data Casting is a core feature of Grasshopper data. It basically allows data types defined in Grasshopper add-ons to become an integral part of Grasshopper. Lets assume that we have a Component that operates on data type [A]. But instead of playing nice, we provide data of type [B]. Two conversion (casting) attempts will be made in order to change [B] into [A]. If [B] implements IGH_Goo, then it is asked if it knows how to convert itself into an instance of [A]. Failing that, if [A] implements IGH_Goo, it is asked whether or not it knows how to construct itself from an instance of [B].

The CastTo() function is responsible for step 1. The CastTo() method is a generic method, meaning the types on which it operates are not defined until the method is actually called. This allows the function to operate 'intelligently' on data types. It also unfortunately means you have to be 'intelligent' when implementing this function.

CopyC#
bool CastFrom(object source)

The CastFrom() function is responsible for step 2 of data casting. Some kind of data is provided as a source object and if the local Type knows how to 'read' the source data it can perform the conversion.

CopyC#
object ScriptVariable()

When data is fed into a VB or C# script component, it is usually stripped of IGH_Goo specific data and methods. The ScriptVariable() method allows a data type to provide a stripped down version of itself for use in a Script component.

The GH_Goo abstract class

Although all data in Grasshopper must implement the IGH_Goo interface, it is not necessary to actually write a type from scratch. It is good practice to inherit from the abstract class GH_Goo<T>, as it takes care of some of the basic functionality. GH_Goo is a generic type (that's what the "<T>" bit means), where T is the actual type you're wrapping. GH_Goo<T> has several abstract methods and properties which must be implemented, but a lot of the other methods are already implemented with basic (though usually useless) functionality.

An Example Type

We'll now create a very simple custom type. This will introduce the basic concept of custom type development, without dealing with any of the baking and previewing logic yet. Our custom type will be a TriState flag, similar to boolean values but with an extra state called "Unknown". We'll represent these different states using integers:

Integer | TriState
Negative One | Unknown
Zero | False
Positive One | True

We'll start with the general class layout, then drill down into each individual function. Create a new public class called TriStateType and inherit from GH_Goo<Integer>. Be sure to import the Grasshopper Kernel and Kernel.Types namespaces as we'll need them both:

CopyC#
using Grasshopper.Kernel;
using Grasshopper.Kernel.Types;

namespace MyTypes
{
  public class TriStateType : GH_Goo<int>
  {

  }
}

Constructors

Unless a constructor is defined, .NET classes always have a default constructor which initializes all the fields of the class to their default values. This constructor does not require any inputs and when you develop custom types it is a good idea to always provide a default constructor. If there is no default constructor, then class instances cannot be created automatically which thwarts certain algorithms in Grasshopper.

In addition to a default constructor I also find it useful to supply so called copy constructors which create a new instance of the type class with a preset value.

CopyC#
// Default Constructor, sets the state to Unknown.
public TriStateType()
{
  this.Value = -1;
}

// Constructor with initial value
public TriStateType(int tristateValue)
{
  this.Value = tristateValue;
}

// Copy Constructor
public TriStateType(TriStateType tristateSource)
{
  this.Value = tristateSource.Value;
}

// Duplication method (technically not a constructor)
public override IGH_Goo Duplicate()
{
  return new TriStateType(this);
}

Incidentally, the Value property which we are using to assign integers to our local instance is provided by the GH_Goo<T> base class. GH_Goo<T> defines a protected field of type T called m_value and also a public accessor property called Value which gets or sets the m_value field.

In this particular case, it actually makes sense to override the default Value property implementation, as the number of sensible values we can assign (-1, 0 and +1) is a subset of the total number values available through the Integer data type. It makes no sense to assign -62 for example. We could of course agree that all negative values indicate an "Unknown" state, but we should try to restrict ourselves to only three integer values:

CopyC#
// Override the Value property to strip non-sensical states.
public override int Value
{
  get { return base.Value; }
  set
  {
    if (value < -1) { value = -1; }
    if (value > +1) { value = +1; }
    base.Value = value;
  }
}

Formatters

Formatting data is primarily a User Interface task. Both the data type and the data state need to be presented in human-readable form every now and again. This mostly involves readonly properties as looking at data does not change its state:

CopyC#
// TriState instances are always valid
public override bool IsValid
{
  get { return true; }
}

// Return a string with the name of this Type.
public override string TypeName
{
  get { return "TriState"; }
}

// Return a string describing what this Type is about.
public override string TypeDescription
{
  get { return "A TriState Value (True, False or Unknown)"; }
}

// Return a string representation of the state (value) of this instance.
public override string ToString()
{
  if (this.Value == 0) { return "False"; }
  if (this.Value > 0) { return "True"; }
  return "Unknown";
}

Serialization

Some data types can be stored as persistent data. Persistent data must be able to serialize and deserialize itself from a Grasshopper file. Most simple types support this feature (Booleans, Integers, Strings, Colours, Circles, Planes etc.), most complex geometry types cannot be stored as persistent data (Curves, Breps, Meshes). If possible, you should aim to provide robust (de)serialization for your data:

CopyC#
// Serialize this instance to a Grasshopper writer object.
public override bool Write(GH_IO.Serialization.GH_IWriter writer)
{
  writer.SetInt32("tri", this.Value);
  return true;
}

// Deserialize this instance from a Grasshopper reader object.
public override bool Read(GH_IO.Serialization.GH_IReader reader)
{
  this.Value = reader.GetInt32("tri");
  return true;
}

Casting

There are three casting methods on IGH_Goo; the CastFrom() and CastTo() methods that facilitate conversions between different types of data and the ScriptVariable() method which creates a safe instance of this data to be used inside untrusted code (such as VB or C# Script components).

CopyC#
// Return the Integer we use to represent the TriState flag.
public override object ScriptVariable()
{
  return this.Value;
}

// This function is called when Grasshopper needs to convert this
// instance of TriStateType into some other type Q.
public override bool CastTo<Q>(ref Q target)
{
  //First, see if Q is similar to the Integer primitive.
  if (typeof(Q).IsAssignableFrom(typeof(int)))
  {
    object ptr = this.Value;
    target = (Q)ptr;
    return true;
  }

  //Then, see if Q is similar to the GH_Integer type.
  if (typeof(Q).IsAssignableFrom(typeof(GH_Integer)))
  {
    object ptr = new GH_Integer(this.Value);
    target = (Q)ptr;
    return true;
  }

  //We could choose to also handle casts to Boolean, GH_Boolean,
  //Double and GH_Number, but this is left as an exercise for the reader.
  return false;
}

// This function is called when Grasshopper needs to convert other data
// into TriStateType.
public override bool CastFrom(object source)
{
  //Abort immediately on bogus data.
  if (source == null) { return false; }

  //Use the Grasshopper Integer converter. By specifying GH_Conversion.Both
  //we will get both exact and fuzzy results. You should always try to use the
  //methods available through GH_Convert as they are extensive and consistent.
  int val;
  if (GH_Convert.ToInt32(source, out val, GH_Conversion.Both))
  {
    this.Value = val;
    return true;
  }

  //If the integer conversion failed, we can still try to parse Strings.
  //If possible, you should ensure that your data type can 'deserialize' itself
  //from the output of the ToString() method.
  string str = null;
  if (GH_Convert.ToString(source, out str, GH_Conversion.Both))
  {
    switch (str.ToUpperInvariant())
    {
      case "FALSE":
      case "F":
      case "NO":
      case "N":
        this.Value = 0;
        return true;

      case "TRUE":
      case "T":
      case "YES":
      case "Y":
        this.Value = +1;
        return true;

      case "UNKNOWN":
      case "UNSET":
      case "MAYBE":
      case "DUNNO":
      case "?":
        this.Value = -1;
        return true;
    }
  }

  //We've exhausted the possible conversions, it seems that source
  //cannot be converted into a TriStateType after all.
  return false;
}


Simple Parameters (C#)

[image]

Grasshopper SDK
Simple Parameters (C#)
Send Feedback

  • Introduction
  • Grasshopper.Kernel.IGH_Param
  • Types of Parameters
  • Data inside Parameters
  • A Custom Parameter Type
  • Collecting and Post-Processing Data

In this article we'll discuss parameters; what they are, what they're for, what they can and cannot do. Parameters are a vital part of Grasshopper (the other being components). However, unlike components, it is far less likely that you'll need to make your own parameters. Most components require only the native data types available inside Grasshopper. In those odd cases where you need to work with custom data, you'll also need to create custom parameters that store that data. In this topic, we'll create a parameter which can handle the TriStateType we discussed in the Simple Data Types topic.

Parameters are responsible for storing and distributing data. Components use them to collect existing data and output new data. Parameters can also be used to convert data from one type into another, even though on the atomic level the conversion is actually performed by the CastTo<(Of <<'(T>)>>) and CastFrom methods on IGH_Goo. Most objects in the Special subcategory on the Grasshopper toolbar are basically parameters with extended GUIs. Parameters can also be used by themselves to store constant data or to redirect data into multiple streams.

Grasshopper.Kernel.IGH_Param

All parameters in Grasshopper must implement the IGH_Param interface. IGH_Param defines the bare minimum of what a parameter must be able to do. There are some interfaces that extend on IGH_Param, and also some abstract classes that partially implement the interface. Note that IGH_Param already inherits from IGH_ActiveObject, so it comes with a lot of baggage.

IGH_Param is quite an extensive interface, it defines nearly thirty properties and methods, some of which are quite tricky to implement. It is highly recommended that you do not directly implement IGH_Param, but derive from the abstract GH_Param<(Of <(<'T>)>)> class instead. GH_Param(Of T) provides a basic implementation of IGH_Param and takes care of quite a lot of the nasty bits. Here's a list of things GH_Param<T> will happily do for you that you would otherwise have to do yourself:

  • It will create default Attributes in case the parameter is floating.
  • It will manage and synch the source and recipient lists.
  • It can parse network topology to figure out dependency relationships.
  • It will create, restore and clean proxy sources used during IO operations.
  • It knows how to disassociate itself from adjacent objects in a network.
  • It will provide getters and settings for typical parameter properties.
  • It knows how to apply DataMapping algorithms to local data.
  • It can handsomely format local data for display in tooltips.
  • It will maintain a GH_Structure(Of T) for local data storage.
  • It provides methods to cast data into the local type.
  • It will accurately measure the time it takes to collect and process data.
  • It knows how to collect and interweave data from multiple sources.
  • It will correctly populate parameter pop-up menus.
  • It will provide the correct StateTags for DataMapping settings.
  • It will (de)serialize all local properties.

In other words, do not implement IGH_Param but derive from GH_Param<T>!

Types of Parameters

As mentioned before, parameters can be encountered as component inputs or outputs, but also as free-floating objects. These are not different classes, but rather the same class behaving in different ways. Every instance of IGH_Param has a Kind readonly property which describes the context of that instance:

In the image above, we see all three valid parameter Kinds (Input, Output and Floating). The "bool" object is a floating parameter of type Param_Boolean. The "P" on the left side of the "Cull" component is an input parameter of that very same type.

The Text Panel is also a floating parameter which derives from GH_Param(Of GH_String). In a way it is very similar to the String parameter (not shown), except it overrides the display and GUI of the default GH_Param class. The "L" on the right of the "Cull" component is an output parameter of the Param_GenericObject type (just like the "L" input parameter).

From this image we can see how versatile parameters can be. Parameters can have wildly different front-ends, they can expose and hide input and output grips at will, they can be part of a larger component or stand by themselves. They can even override so much of the default functionality that they no longer appear to be parameters at all (like the cluster output attached to "L").

Data inside Parameters

All parameters have the capacity to store data, this is, after all, their primary function. When you derive from GH_Param<(Of <(<'T>)>)> there will be a protected member available within the class called m_data of type GH_Structure<(Of <(<'T>)>)>. Since GH_Structure<T> only accepts types of T that implement IGH_Goo, GH_Param<T> also only accepts types for T that implement IGH_Goo. This is why you cannot have a GH_Param<int> but must instead have GH_Param<GH_Integer>.

Data stored inside the m_data field is destroyed whenever the parameter expires. Parameters can be expired via several different mechanisms, but the most common ones are:

  • One or more of the sources of a parameter expires.
  • The component that owns the parameter expires.
  • The user forces a complete solution recalculation (F5).
Because the data gets destroyed so readily, we call it Volatile Data. A lot of parameters in Grasshopper are also capable of storing Persistent Data, which is not destroyed whenever a solution runs. This allows parameters to define a collection of 'constant' values. The "Set One XXXX", "Set Multiple XXXX" and "Manage XXXX Collection" menu items in the parameter pop-up menu refer to persistent data.

When a parameter is not connected to any source parameters, the persistent data will be copied into the volatile data. If there is no persistent data, the parameter will remain empty and a runtime warning will be included to this effect.

GH_Param<T> however does not support persistent data. You can add your own mechanism for this (like Text Panel does) or you can choose to derive from more advanced classes like GH_PersistentParam<(Of <(<'T>)>)>. In this example, we'll derive from GH_PersistentParam<T> as we want to give users the ability to specify local data. GH_PersistentParam<T> requires we implement two additional methods that allow users to specify persistent data. These methods are called from the default popup menu when the "Set One XXXX" and "Set Multiple XXXX" items are clicked.

So let's start with deriving from GH_PersistentParam<T> and see where that takes us:

CopyC#
public class TriStateParameter : GH_PersistentParam<TriStateType>
{

  // We need to supply a constructor without arguments that calls the base class constructor.
  public TriStateParameter() :
    base("TriState", "Tri", "Represents a collection of TriState values", "Params", "Primitive") { }

  public override System.Guid ComponentGuid
  {
    // Always generate a new Guid, but never change it once
    // you've released this parameter to the public.
    get { return new Guid("{2FEEF1A2-A764-431d-8C78-9BF92C78BAE1}"); }
  }

  protected override Kernel.GH_GetterResult Prompt_Singular(ref TriStateType value)
  {
    // Todo, impement this function.
  }
  protected override Kernel.GH_GetterResult Prompt_Plural(ref List<TriStateType> values)
    // Todo, impement this function.
  }
}
That is essentially all there's to it. Though you should also provide an Icon and an Exposure for this object. The Prompt_Singular and Promt_Plural methods need to be implemented. In this case we'll use standard Rhino Command Line interface to prompt for persistent values:
CopyC#
protected override Kernel.GH_GetterResult Prompt_Singular(ref TriStateType value)
{
  Rhino.Input.Custom.GetOption() go = New Rhino.Input.Custom.GetOption();
  go.SetCommandPrompt("TriState value");
  go.AcceptNothing(true);
  go.AddOption("True");
  go.AddOption("False");
  go.AddOption("Unknown");

  switch (go.Get())
  {
    case Rhino.Input.GetResult.Option:
      if (go.Option().EnglishName == "True") { value = new TriStateType(1); }
      if (go.Option().EnglishName == "False") { value = new TriStateType(0); }
      if (go.Option().EnglishName == "Unknown") { value = new TriStateType(-1); }
      return GH_GetterResult.success;

    case Rhino.Input.GetResult.Nothing:
      return GH_GetterResult.accept;

    default:
      return GH_GetterResult.cancel;
  }
}

protected overrides Kernel.GH_GetterResult Prompt_Plural(ref List<TriStateType> values)
{
  values = new List<TriStateType>

  while (true)
  {
    TriStateType val = null;
    switch (Prompt_Singular(val))
      case GH_GetterResult.success:
        values.Add(val);
        break;

      case GH_GetterResult.accept:
        return GH_GetterResult.success;

      case GH_GetterResult.cancel:
        values = null;
        return GH_GetterResult.cancel;
    }
  }
}


List Component (C#)

[image]

Grasshopper SDK
List Component (C#)
Send Feedback

  • Introduction
  • List Parameters
  • Solving Routine

So far the example components have all operated on individual data items. This is known as One-In-One-Out. But what if you want to operate on more than one item at a time; One-In-Many-Out, Many-In-One-Out or Many-In-Many-Out? This requires that input or output parameters have a non-standard Grasshopper.Kernel..::..GH_ParamAccess flag.

List Parameters

Input and Output parameters that are part of Grasshopper components have an access flag that affects how the component treats data stored in these parameters. Take for example the Polyline component. It creates a single polyline object from a collection of corner-points. This is a Many-In-One-Out kind of logic. The Divide component creates a whole bunch of division points from a single curve. This is an example of One-In-Many-Out. The Cull components remove certain items from lists, this is an example of Many-In-Many-Out.

Most components treat their inputs and outputs as parameters that provide individual instances of data, rather than related collections of data. This is indicated by all parameters having an GH_ParamAccess..::..item access flag. You can however assign different access flags to parameters. Preferably this flag should be assigned only once, namely in the RegisterInputParams or RegisterOutputParams method overrides. It is legal to modify an access flag as long as a solution is not currently in progress, but it is not recommended.

In this tutorial, we'll be writing a component that removes (culls) the bottom-most N objects in a collection of geometric shapes. As inputs we'll need a collection of geometry and an integer indicating how many objects the user wants to remove, and as output we'll provide the same collection of geometry, but with the bottom-most objects missing. This is therefore a Many-In-Many-Out case.

The Component code (without the RegisterInputParams, RegisterOutputParams and SolveInstance methods) may look like this:

CopyC#
public class Component_CullByElevation : GH_Component
{
  public Component_CullByElevation()
    : base("Cull Elevation", "CullZ", "Cull objects by relative elevation", "Sets", "Sequence")
  { }

  public override Kernel.GH_Exposure Exposure
  {
    get { return GH_Exposure.primary | GH_Exposure.obscure; }
  }
  public override System.Guid ComponentGuid
  {
    get { return new Guid("{A8FF9CBA-0837-4cd6-9198-0D17325D3F8F}"); }
  }

  //...additional component code will go here..
}
We'll need to register the parameters as well, and we'll use the overloaded methods to immediately assign the correct parameter access flags.
CopyC#
protected override void RegisterInputParams(Kernel.GH_Component.GH_InputParamManager pManager)
{
  pManager.AddGeometryParameter("Geometry", "G", "Geometry to cull", GH_ParamAccess.list);
  pManager.AddIntegerParameter("Count", "C", "Number of objects to cull", GH_ParamAccess.item, 1);
}
protected override void RegisterOutputParams(Kernel.GH_Component.GH_OutputParamManager pManager)
{
  pManager.AddGeometryParameter("Geometry", "G", "Culled geometry", GH_ParamAccess.list);
}
 Input parameters rigorously enforce their access. You are only allowed to retrieve individual items from inputs that have the GH_ParamAccess..::..item flag set. Lists can only be retrieved when the access is set to GH_ParamAccess..::..list and data trees can only be gotten from a GH_ParamAccess..::..tree parameter. Failure to do so will result in an error message at runtime. Output parameter are more flexible, but this is only because output access was added only in Grasshopper 0.9.0001 and strict enforcement would result in SDK breakage with previous versions.

Solving Routine

The SolveInstance implementation is basically identical to previous examples, the only difference is the way the component interacts with the parameters.

CopyC#
protected override void SolveInstance(Kernel.IGH_DataAccess DA)
{
  //Declare a new List(Of T) to hold your data.
  //This list must exist and should probably be empty.
  List<IGH_GeometricGoo> geometry = new List<IGH_GeometricGoo>();
  Int32 count = 0;

  //Retrieve the whole list using Da.GetDataList().
  if ((!DA.GetDataList(0, geometry)))
    return;
  if ((!DA.GetData(1, count)))
    return;

  //Validate inputs.
  if ((count < 0))
  {
    AddRuntimeMessage(GH_RuntimeMessageLevel.Error, "Count must be a positive integer");
    return;
  }

  //The number of objects to cull is larger than or
  //equal to the total number of objects. I.e. cull them all.
  if ((geometry.Count <= count))
    return;

  //Iteratively remove the lowest object from the list.
  for (Int32 N = 1; N <= count; N++)
  {
    double lowestElevation = double.MaxValue;
    Int32 lowestIndex = -1;

    //Iterate over all remaining geometry and find the lowest one.
    for (Int32 i = 0; i <= geometry.Count - 1; i++)
    {
      if ((geometry[i] == null))
        continue;
      BoundingBox bbox = geometry[i].Boundingbox;
      if ((!bbox.IsValid))
        continue;

      double localElevation = bbox.Min.Z;
      if ((localElevation < lowestElevation))
      {
        lowestElevation = localElevation;
        lowestIndex = i;
      }
    }

    //Delete the lowest object.
    geometry.RemoveAt(lowestIndex);
  }

  //Assign the remaining geometry
  //(even if it is only a single item!)
  //using the DA.SetDataList() method.
  DA.SetDataList(0, geometry);
}


Extending the GUI (C#)

[image]

Grasshopper SDK
Extending the GUI (C#)
Send Feedback

  • Introduction
  • Default Functionality and GUI
  • Menus
  • Interaction
  • Display

This article describes how to extend the default behaviour, functionality and graphical user interface (GUI) of Grasshopper document objects. We'll focus on components as you should be familiar with those from earlier topics, but the same logic also applies to Parameters and custom objects.

Default Functionality and GUI

When you derive a class from GH_Component or GH_Param<(Of <(<'T>)>)> you get a lot of functionality and GUI for free. It is quite important that all the objects in Grasshopper behave in a consistent and predictable fashion so you typically don't need to override this default behaviour. However there can be cases where changing the default Grasshopper GUI is the best solution. Overriding the GUI is not exactly a trivial task, there are a lot of different facets to this and I'll discuss the most important ones in this topic.

There are three common ways in which the default GUI can be altered:

  • Menus
  • Interaction
  • Display

Menus

It is possibe to insert items into the default pop-up menus of objects, or even to completely alter the menu layout. If your component for example can run in two different modes, you can choose to expose an additional GUI option instead of an input parameter. These modes can then be toggled via the component pop-up menu.

At the lowest level, pop-up menus are generated by the canvas when a right mouse button click is detected over a component or parameter. The menu by default contains no items and it is the responsibility of said component or parameter to populate the menu. The top-level method which is in charge of this is AppendMenuItems which is defined inside IGH_DocumentObject and thus propagates to all objects on the canvas.

The GH_DocumentObject abstract class does not create any menu items, so unless this function is overridden, there will be no popup menu for a certain object. However, it is unlikely you derive directly from GH_DocumentObject so this should not be a problem. GH_ActiveObject, which is the base class for all objects on the canvas that actually do something (Sketches and Scribbles don't "do" anything, hence they derive directly from GH_DocumentObject), does provide a default implementation of AppendMenuItems(). The default layout of popup menus is:

  • NickName

  • Preview

  • Enabled

  • Bake

  • Warnings

  • Errors

  • Help

Although if the object in question does not support previews or baking then those items will be missing from the final menu. When overridden, AppendMenuItems() allows you to completely replace the default menu:
CopyVB.NET
public override bool AppendMenuItems(ToolStripDropDown menu)
{
  Menu_AppendGenericMenuItem(menu, "First item");
  Menu_AppendGenericMenuItem(menu, "Second item");
  Menu_AppendGenericMenuItem(menu, "Third item");
  Menu_AppendSeparator(menu);
  Menu_AppendGenericMenuItem(menu, "Fourth item");
  Menu_AppendGenericMenuItem(menu, "Fifth item");
  Menu_AppendGenericMenuItem(menu, "Sixth item");

  // Return true, otherwise the menu won't be shown.
  return true;
}

If you want to insert additional items into the menu it would be very annoying if you had to recreate this default menu layout from scratch every single time. So eventhough you can override AppendMenuItems() it is recommended you instead override AppendAdditionalMenuItems() which allows you to insert custom menu items between Errors and Help without losing the standard functionality:

CopyVB.NET
public override void AppendAdditionalMenuItems(ToolStripDropDown menu)
{
  base.AppendAdditionalMenuItems(menu);

  Menu_AppendGenericMenuItem(menu, "First item");
  Menu_AppendGenericMenuItem(menu, "Second item");
  Menu_AppendGenericMenuItem(menu, "Third item");
  Menu_AppendSeparator(menu);
  Menu_AppendGenericMenuItem(menu, "Fourth item");
  Menu_AppendGenericMenuItem(menu, "Fifth item");
  Menu_AppendGenericMenuItem(menu, "Sixth item");
}

GH_Param<T> for example derives from GH_ActiveObject and re-implements AppendAdditionalMenuItems() in order to supply the Wire Display, Disconnect, Reverse, Flatten and Graft menu items that are present in all parameters. GH_Component, likewise, derives from GH_ActiveObject and it re-implements AppendAdditionalMenuItems() in order to insert the Shortest List, Longest List, Cross Reference and the parameter submenus.

Long story short; if you wish to insert additional menu items then either re-implement AppendAdditionalMenuItems() if you derive from GH_Param<T> or re-implement AppendAdditionalComponentMenuItems() if you derive from GH_Component:

CopyVB.NET
// If you implement IGH_Param, then override this method. If you implement IGH_Component,
// then override AppendAdditionalComponentMenuItems instead.
protected override void AppendAdditionalMenuItems(ToolstripDropDown menu)
{
  // Place a call to the base class to ensure the default parameter menu
  // is still there and operational.
  base.AppendAdditinalMenuItems(menu);

  // Now insert your own custom menu items.
  Menu_AppendGenericMenuItem(menu, "My Custom Menu Item", Menu_MyCustomItemClicked);
}

private void Menu_MyCustomItemClicked(Object sender, EventArgs e)
{
  Rhino.RhinoApp.WriteLine("Alcohol doesn't affect me...");
}
There's a lot of menu utility functions provided by GH_DocumentObject. They all start with "Menu_" and they'll make it much easier to insert formatted menu items. But of course nothing is stopping you from using typical System.Windows.Forms plumbing to extend the pop-up menu.

Interaction

You can also choose to handle specific mouse and keyboard events. You could for example choose to respond to a mouse double-click event on your component. Complicated objects such as Gradients and Graph Mappers handle all sorts of mouse events to provide grip-dragging functionality directly within the Grasshopper canvas. todo: finish this section

Display

Finally, it is possible to override the way an object displays itself on the canvas. These alterations can be minor, mere additions to the default display, or they can be radically different (as with the Gradient and Graph Mapper objects). For a detailed explanation regarding display overrides, see the Custom Attributes topic.


Custom Attributes (C#)

[image]

Grasshopper SDK
Custom Attributes (C#)
Send Feedback
  • Introduction
  • Grasshopper.Kernel.GH_Attributes
  • Layout
  • Render

This article contains a step-by-step walkthrough regarding custom object display. Objects on the Grasshopper canvas consist of two parts. The most important piece is the class that implements the IGH_DocumentObject interface. This interface provides the basic plumbing needed to make objects work within a Grasshopper node network. The interface part of objects however is handled separately. Every IGH_DocumentObject carries around an instance of a class that implements the IGH_Attributes interface (indeed, every IGH_DocumentObject knows how to create its own stand-alone attributes) and it is this class that takes care of display, mouse interactions, popup menus, tooltips and so forth.

In this article I'll explain how you can create your own attributes object. Since it's not possible to have an IGH_Attributes instance work on its own, we need an IGH_DocumentObject to tie it to. For this article we'll assume we have a custom simple parameter (i.e. without persistent data) that holds integers.

CopyC#
public class MySimpleIntegerParameter : GH_Param<Types.GH_Integer>
{
  public MySimpleIntegerParameter() :
    base(new GH_InstanceDescription("Integer with stats", "Int(stats)",
                                    "Integer with basic statistics",
                                    "Params", "Primitive")) { }

  public override System.Guid ComponentGuid
  {
    get { return new Guid("{33D07726-8298-4104-9EBC-5398D8AD5421}"); }
  }
}

What we'll do is create a special attributes object for this parameter which also displays the median and mean values of the collection of all integers. We want to put this information below the parameter name, but inside the parameter box. The first step here is to override the CreateAttributes() on MySimpleIntegerParameter and assign a new instance of our (yet to be written) attributes class:

CopyC#
public override void CreateAttributes()
{
  m_attributes = new MySimpleIntegerParameterAttributes(Me);
}
That's it, no more code is required inside the MySimpleIntegerParameter class. This part at least is simple. If you don't override the CreateAttributes() method, then an instance of GH_FloatingParamAttributes will be created instead. If your parameter is to be attached to a component as an input or output, then the component will assign an instance of GH_LinkedParamAttributes to the parameter and CreateAttributes() will never be called.

Grasshopper.Kernel.GH_Attributes

Although the IGH_Attributes interface is required for custom attributes, it is usually a good idea to derive from one of the abstract attribute classes already available. GH_Attributes<(Of <(<'T>)>)> is the most basic and obvious choice and it implements a large amount of methods with default behaviour, saving you a lot of time and effort:

CopyC#
public class MySimpleIntegerParameterAttributes : GH_Attributes<MySimpleIntegerParameter>
{
  public MySimpleIntegerParameterAttributes(MySimpleIntegerParameter owner) : base(owner) { }
}

This is enough so far to make it work, eventhough all the logic is still standard. We need to start overriding methods in MySimpleIntegerParameterAttributes to suit our needs. But first some basic information regarding the default behaviour.

GH_Attributes<T> assumes that the object that owns it is rectangular. This is true for most objects in Grasshopper, but there are some notable exceptions such as Pie-Graphs, Sketches and Scribbles. But this assumption (which holds true in our case) allows GH_Attributes<T> to supply basic functionality for a wide variety of methods.

All attributes have a property that defines the size of the object called Bounds. Basically everything that happens outside of the Bounds goes by unnoticed. Also, if the Bounds rectangle is not visible within the canvas area, Grasshopper might decide to not even bother calling any painting methods.

Because our parameter will be rectangular, we don't have to override any of the picking logic, as the default implementation of IsPickRegion, IsMenuRegion and IsTooltipRegion will already work.

Layout

We do however need to supply custom Layout logic. The width of our attributes depends on both the length of the NickName of the MySimpleIntegerParameter that owns these attributes and on the length of the statistics information we want to include. The height of the parameter however is fixed, though larger than the standard height for parameters in Grasshopper.

In order to supply custom layout logic, we need to override the Layout method. In this case I measure the width of the NickName of the Owner object, and make sure the parameter is never narrower than 80 pixels:

CopyC#
protected override void Layout()
{
  // Compute the width of the NickName of the owner (plus some extra padding),
  // then make sure we have at least 80 pixels.
  int width = GH_FontServer.StringWidth(Owner.NickName, GH_FontServer.Standard);
  width = Math.Max(width + 10, 80);

  // The height of our object is always 60 pixels
  int height = 60;

  // Assign the width and height to the Bounds property.
  // Also, make sure the Bounds are anchored to the Pivot
  Bounds = new RectangleF(Pivot, new SizeF(width, height));
}
The Pivot is a PointF structure that is changed when the object is dragged. It is therefore important that you always 'anchor' the layout of some attributes to the Pivot. If you fail to do so, your attributes will become undraggable.

There is a method you can override that will be called prior to the call to Layout which can be used to destroy any cached data you might have that's to do with display. But note that if you override ExpireLayout you must place a call to the base class method as well:

CopyC#
publicoverride void ExpireLayout()
{
  base.ExpireLayout();

  // Destroy any data you have that becomes
  // invalid when the layout expires.
}

Render

Now that we have handled the Layout, we need to override the display of the parameter. There's two parts to doing so. You always have to override the Render method, as this is where the drawing takes place. Render is called a number of times as there are several 'layers' or 'channels' to a single Grasshopper canvas. At first, the background of the canvas is drawn. During this process attributes are not yet involved. Then there will be four channels where IGH_Attributes will be allowed to draw various shapes.

First the groups are drawn (as they are behind all other objects), but every GH_Attributes.Render() method will be called once for the Groups channel. Typically you should not draw anything in the Groups channel.

Next up is the Wires channel where all parameter connector wires are drawn. If your object has input parameters or is a parameter, it is your responsibility to draw all wires coming into your object. Wires going out the right side will be drawn by the recipient objects.

Next the actual Components and Parameters themselves are drawn inside the Objects channel. This is typically the most work, though there are lots of classes that take care of common tasks. The default visual style of Components and parameter objects is the shiny, rounded rectangle. You can use the GH_Capsule type to draw these shapes with a minimum of fuss.

Ultimately there's an Overlay channel which is rarely used but it allows you to draw shapes that need to be on top of all other components and parameters. After this, there are still more channels to do with canvas widgets, but IGH_Attributes are not involved here.

Inside our implementation of the Render() method, we need to draw the wires coming into the MySimpleIntegerParameter, then the parameter capsule, while taking care to assign the correct colours (grey for normal, green for selected, dark for disabled, orange for warnings and red for errors). Finally we have to draw three lines of text on top of the capsule; the name of the owner, the median integer and the mean integer. The important types involved here are:

  • GH_Canvas
  • GH_Painter
  • GH_Palette
  • GH_RuntimeMessageLevel
  • GH_Capsule
  • GH_FontServer
CopyC#
protected override void Render(GH_Canvas canvas, Graphics graphics, GH_CanvasChannel channel)
  // Render all the wires that connect the Owner to all its Sources.
  if (channel == GH_CanvasChannel.Wires)
  {
    RenderIncomingWires(canvas.Painter, Owner.Sources, Owner.WireDisplay);
    return;
  }

  // Render the parameter capsule and any additional text on top of it.
  if (channel == GH_CanvasChannel.Objects)
  {
    // Define the default palette.
    GH_Palette palette = GH_Palette.Normal;

    // Adjust palette based on the Owner's worst case messaging level.
    switch (Owner.RuntimeMessageLevel)
    {
      case GH_RuntimeMessageLevel.Warning:
        palette = GH_Palette.Warning;
        break;

      case GH_RuntimeMessageLevel.Error:
        palette = GH_Palette.Error;
        break;
     }

    // Create a new Capsule without text or icon.
    GH_Capsule capsule = GH_Capsule.CreateCapsule(Bounds, palette);

    // Render the capsule using the current Selection, Locked and Hidden states.
    // Integer parameters are always hidden since they cannot be drawn in the viewport.
    capsule.Render(graphics, Selected, Owner.Locked, true);

    // Always dispose of a GH_Capsule when you're done with it.
    capsule.Dispose();
    capsule = null;

    // Now it's time to draw the text on top of the capsule.
    // First we'll draw the Owner NickName using a standard font and a black brush.
    // We'll also align the NickName in the center of the Bounds.
    StringFormat format = New StringFormat();
    format.Alignment = StringAlignment.Center;
    format.LineAlignment = StringAlignment.Center;
    format.Trimming = StringTrimming.EllipsisCharacter;

    // Our entire capsule is 60 pixels high, and we'll draw
    // three lines of text, each 20 pixels high.
    RectangleF textRectangle = Bounds;
    textRectangle.Height = 20;

    // Draw the NickName in a Standard Grasshopper font.
    graphics.DrawString(Owner.NickName, GH_FontServer.Standard, Brushes.Black, textRectangle, format);

    // Now we need to draw the median and mean information.
    // Adjust the formatting and the layout rectangle.
    format.Alignment = StringAlignment.Near;
    textRectangle.Inflate(-5, 0);

    textRectangle.Y += 20;
    graphics.DrawString(String.Format("Median: {0}", Owner.MedianValue), _
                        GH_FontServer.StandardItalic, Brushes.Black, _
                        textRectangle, format);

    textRectangle.Y += 20;
    graphics.DrawString(String.Format("Mean: {0:0.00}", Owner.MeanValue), _
                        GH_FontServer.StandardItalic, Brushes.Black, _
                        textRectangle, format);

    // Always dispose of any GDI+ object that implement IDisposable.
    format.Dispose();
  }
}
 Note that in this case I assume that MySimpleIntegerParameter has two ReadOnly properties called MedianValue and MeanValue. I haven't written those, as they are not within the scope of this topic.

If you have cached display objects (for whatever reason I don't want to hear), a good place to ensure they are PrepareForRender method. It is called once (and only once) just before any calls to Render(). You do not need to call the overridden method as it is empty by default.


Custom Component Options (C#)

[image]

Grasshopper SDK
Custom Component Options (C#)
Send Feedback

  • Introduction
  • Class Level variables
  • (De)serialization of custom data
  • Context menu changes

This article discusses how to add custom options to a component and have them included in *.gh/*.ghx (de)serialization. It skips over some portions of Component design which have already been handled in previous topics, so do not read this article before familiarizing yourself with the My First Component topic.

The component we'll create in this article will sort a list of numbers and have the custom option to convert those numbers to absolute values prior to sorting. However, rather than providing this option as a boolean input parameter, we'll allow people to set it via the Component context menu. We'll need to do four special things to achieve this, to wit:

  • Declare a class level variable/property.
  • Provide access to the variable from within the Component menu.
  • Include the variable in (de)serialization.
  • Record undo events when changing the value.

Before you start with this topic, create a new class that derives from GH_Component, as outlined in the My First Component topic.

This component will require one input parameter and one output parameter, both of type Number with list access:

CopyC#
...
  protected override void RegisterInputParams(Kernel.GH_Component.GH_InputParamManager pManager)
  {
    pManager.AddNumberParameter("Values", "V", "Values to sort", GH_ParamAccess.list);
  }
  protected override void RegisterOutputParams(Kernel.GH_Component.GH_OutputParamManager pManager)
  {
    pManager.AddNumberParameter("Values", "V", "Sorted values", GH_ParamAccess.list);
  }
...
Assuming for now we'll have a local property called Absolute() which gets a single boolean, we can also already write the SolveInstance() method:
CopyC#
...
  protected override void SolveInstance(Kernel.IGH_DataAccess DA)
  {
    List<double> values = new List<double>();
    if ((!DA.GetDataList(0, values)))
      return;
    if ((values.Count == 0))
      return;

    // Don't worry about where the Absolute property comes from, we'll get to it soon.
    if ((Absolute))
    {
      for (Int32 i = 0; i < values.Count; i++)
      {
        values(i) = Math.Abs(values(i));
      }
    }

    values.Sort();
    DA.SetDataList(0, values);
  }
...

Class Level variables

The 'Absolute' option for this component applies to the entire object, but not to other instances of this component. Since it needs to survive (i.e. retain its value) for as long as the component lives, it has to be declared as a class level variable:

CopyC#
...
private bool m_absolute = false;
public bool Absolute
{
  get { return m_absolute; }
  set
  {
    m_absolute = value;
    if ((m_absolute))
    {
      Message = "Absolute";
    }
    else
    {
      Message = "Standard";
    }
  }
}
...
The m_absolute field is a private field (only accessible from within this component) and it is exposed publicly via the Absolute() property, which allows both getting and setting. Furthermore, whenever the m_absolute field is set, the Absolute() property ensures that the correct message is assigned. The Message field on GH_Component allows you to set a string which will be displayed underneath the component on the canvas. This is to signal to users that there's an option they can change which is not directly accessible via the input parameters. Note that the message is not set until the Absolute() property is accessed, so you should specifically place a call to Absolute = False (or True) in the constructor.

It is of course possible to add any number of custom fields to a component, but you can only attach a single message, if you have more than one field you want to make the user aware of, you'll need to get creative.

(De)serialization of custom data

When you add options or states to your component which need to be 'sticky', you'll also need to (de)serialize them correctly. (De)serialization is used when saving and opening files, when copying and pasting objects and during undo/redo actions. In this particular case, we only need to add a single boolean to the standard file archive. Serialization in Grasshopper happens using the GH_IO.dll methods and types, not via standard framework mechanisms such as the SerializableAttribute.

Override the Write and Read methods on GH_Component and be sure to always call the base implementation.

CopyC#
...
public override bool Write(GH_IO.Serialization.GH_IWriter writer)
{
  // First add our own field.
  writer.SetBoolean("Absolute", Absolute);
  // Then call the base class implementation.
  return base.Write(writer);
}
public override bool Read(GH_IO.Serialization.GH_IReader reader)
{
  // First read our own field.
  Absolute = reader.GetBoolean("Absolute");
  // Then call the base class implementation.
  return base.Read(reader);
}
...

Context menu changes

We'll also need to add an additional menu item to the component context menu, then handle the click event for that item. Adding items to a context menu is best done via the AppendAdditionalComponentMenuItems method. It allows you to insert anu number of item in between the Bake and the Help items. The easiest way to add menu items is to use the Shared methods on GH_DocumentObject such as Menu_AppendItem or one of the overloads. In this case we also want to assign a tooltip text to the item which cannot be done from inside Menu_AppendItem().

CopyC#
...
protected override void AppendAdditionalComponentMenuItems(System.Windows.Forms.ToolStripDropDown menu)
{
  // Append the item to the menu, making sure it's always enabled and checked if Absolute is True.
  ToolStripMenuItem item = Menu_AppendItem(menu, "Absolute", Menu_AbsoluteClicked, true, Absolute);
  // Specifically assign a tooltip text to the menu item.
  item.ToolTipText = "When checked, values are made absolute prior to sorting.";
}
...

When this menu item is clicked, the delegate assigned inside the Menu_AppendItem() method will be invoked. It is here that we must handle a click event. There are usually three steps involved in handling clicks; Record the current state as an undo event, change the state, trigger a new solution:

CopyC#
...
private void Menu_AbsoluteClicked(object sender, EventArgs e)
{
  RecordUndoEvent("Absolute");
  Absolute = !Absolute;
  ExpireSolution(true);
}
...
Since our Write() and Read() methods handle the (de)serialization of the Absolute field, we can use the default RecordUndoEvent method. It is possible to define your own undo records, but that is a topic for another day.


GH_IO Namespace

[image]

Grasshopper SDK
GH_IO Namespace
Send Feedback
Base namespace of the GH_IO.dll library. This library contains the classes and functions needed to read and write Grasshopper files. This library does not depend on Grasshopper.dll or Rhino_DotNET.dll, so it can be used by unrelated projects.

Interfaces

 | Interface | Description
Public interface | GH_ISerializable | Every object which needs to (de)serialize itself using GH_IO methodology must implement this interface.


GH_ISerializable Interface

[image]

Grasshopper SDK
GH_ISerializable Interface
Members See Also Send Feedback
Every object which needs to (de)serialize itself using GH_IO methodology must implement this interface.

Namespace: GH_IO
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public interface GH_ISerializable
Visual Basic
Public Interface GH_ISerializable

See Also

GH_ISerializable Members
GH_IO Namespace


GH_ISerializable Members

[image] [image]

Grasshopper SDK
GH_ISerializable Members
GH_ISerializable Interface Methods See Also Send Feedback

The GH_ISerializable type exposes the following members.

Methods

 | Name | Description
Public method | Read | This method is called whenever the instance is required to deserialize itself.
Public method | Write | This method is called whenever the instance is required to serialize itself.

See Also

GH_ISerializable Interface
GH_IO Namespace


GH_ISerializable Methods

[image] [image]

Grasshopper SDK
GH_ISerializable Methods
GH_ISerializable Interface See Also Send Feedback

The GH_ISerializable type exposes the following members.

Methods

 | Name | Description
Public method | Read | This method is called whenever the instance is required to deserialize itself.
Public method | Write | This method is called whenever the instance is required to serialize itself.

See Also

GH_ISerializable Interface
GH_IO Namespace


Read Method

[image]

Grasshopper SDK
GH_ISerializable..::..Read Method
GH_ISerializable Interface See Also Send Feedback
This method is called whenever the instance is required to deserialize itself.

Namespace: GH_IO
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool Read(
    GH_IReader reader
)
Visual Basic
Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader
Reader object to deserialize from.

Return Value

True on success, false on failure.

See Also

GH_ISerializable Interface
GH_IO Namespace


Write Method

[image]

Grasshopper SDK
GH_ISerializable..::..Write Method
GH_ISerializable Interface See Also Send Feedback
This method is called whenever the instance is required to serialize itself.

Namespace: GH_IO
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool Write(
    GH_IWriter writer
)
Visual Basic
Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter
Writer object to serialize with.

Return Value

True on success, false on failure.

See Also

GH_ISerializable Interface
GH_IO Namespace


GH_IO.Serialization Namespace

[image]

Grasshopper SDK
GH_IO.Serialization Namespace
Send Feedback
Namespace in GH_IO.dll that contains all the classes used during (de)serialization.

Classes

 | Class | Description
Public class | GH_Archive | This is the base archive class which takes care of all (de)serialization and messaging.
Public class | GH_Chunk | Full implementation of GH_IChunk, GH_IReader, GH_IWriter, GH_IBinarySupport and GH_IXmlSupport. Instances of this class are usually disguised as one of the interfaces it implements.
Public class | GH_Compression | Provides static methods for compression of byte-arrays.
Public class | GH_LooseChunk | A utility class for creating partial archives.
Public class | GH_Message | Represents an archive log message. Messages are collected during read/write operations.

Interfaces

 | Interface | Description
Public interface | GH_IBinarySupport | Interface which declares all methods required for objects that can be (de)serialized to and from a binary archive.
Public interface | GH_IChunk | Base interface for all Archive Chunks.
Public interface | GH_IReader | Provides access to a subset of GH_Chunk methods used for reading archives.
Public interface | GH_IWriter | Provides access to a subset of GH_Chunk methods used for writing archives.
Public interface | GH_IXmlSupport | Interface which declares all methods required for objects that can be (de)serialized to and from an Xml archive.

Enumerations

 | Enumeration | Description
Public enumeration | GH_Message_Type | Message type flag.


GH_Archive Class

[image]

Grasshopper SDK
GH_Archive Class
Members See Also Send Feedback
This is the base archive class which takes care of all (de)serialization and messaging.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public class GH_Archive
Visual Basic
Public Class GH_Archive

Inheritance Hierarchy

System..::..Object
GH_IO.Serialization..::..GH_Archive

See Also

GH_Archive Members
GH_IO.Serialization Namespace


GH_Archive Members

[image] [image]

Grasshopper SDK
GH_Archive Members
GH_Archive Class Constructors Methods Properties See Also Send Feedback

The GH_Archive type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Archive | Initializes a new instance of the GH_Archive class

Methods

 | Name | Description
Public method | AddMessage(GH_Message) | Add a new message to the record.
Public method | AddMessage(String, GH_Message_Type) | Add a new message to the record.
Public method | AppendObject | Appends a target object into the root node of this archive tree. If the root doesn't exist yet, it will be created. Existing objects at the root scope will not be affected.
Public method | ClearMessages | Remove all messages from the log.
Public method | CreateNewRoot | Discards the current data tree and instantiates a new root node. This root node contains some comments, a version value containing the current version of GH_IO.dll and a DateTime value containing the current date and time.
Public method | CreateTopLevelNode | Creates and returns a new root node for this archive in the form of a GH_IWriter instance. Typically you do not call this method. If you want to add an object to the archive, use AppendObject() instead.
Public method | Deserialize_Binary | Deserializes an array of bytes.
Public method | Deserialize_Xml | Deserializes an Xml string.
Public method | ExtractObject | Extract a target object from the data tree.
Public method | MessageCount()()()() | Gets the number of messages recorded since the most recent IO operation began.
Public method | MessageCount(Boolean, Boolean, Boolean) | Gets the number of messages recorded since the most recent IO operation began. Message count can be filtered by message type.
 | OpenFileDialog | Displays a standard OpenFileDialog with all the fields set to cater for Grasshopper files.
Public method | ReadFromFile | Reads a new archive tree from a file.
 | SaveFileDialog | Displays a standard SaveFileDialog with all the fields set to cater for Grasshopper files.
Public method | Serialize_Binary | Serializes the data tree into a Binary byte array.
Public method | Serialize_Xml | Serializes the data tree into an Xml string.
Public method | ShowMessageLog | Displays the message log viewer. You should typically only display the viewer if the WorstCaseMessageType equals GH_Message_Type.warning or GH_Message_Type.error
Public method | WriteToFile | Writes the current tree to a file.

Properties

 | Name | Description
Public property | FileName | Gets the filename (without extension) of the currently loaded data tree. If the path field has not been set, "unnamed" is returned.
Public property | GetRootNode | Gets the root node of this archive. Typically you do not need to modify the Root. Use functions like CreateTopLevelNode(), AppendObject() and ExtractObject() instead. If you modify the Root node, you may corrupt the archive.
 | GH_IO_Version | Gets the version number of the current GH_IO build.
 | GrasshopperBinaryExtension | Gets the file extension (including the dot) associated with Grasshopper® Binary data.
 | GrasshopperUserExtension | Gets the file extension (including the dot) associated with Grasshopper® User Object file.
 | GrasshopperXmlExtension | Gets the file extension (including the dot) associated with Grasshopper® XML data.
Public property | IsBinaryPath | Gets a value that indicates whether the Path field points to a Binary Grasshopper file.
Public property | IsPath | Gets a value that indicates whether or not the path field has been set.
Public property | IsXmlPath | Gets a value that indicates whether the Path field points to an Xml Grasshopper file.
Public property | Messages | Gets the internal list of messages.
Public property | Path | Gets the path to the file from which this archive was read and/or written to. If the archive hasn't been read or written yet, this field will be null.
Public property | WorstCaseMessageType | Gets the worst case message type. If the record contains at least 1 error, the worst case is GH_Message_Type.error. If the record contains no errors, but at least 1 warning, the worst case is GH_Message_Type.warning. If the record contains no messages or only infos, the worst case type is GH_Message_Type.info.

See Also

GH_Archive Class
GH_IO.Serialization Namespace


GH_Archive Constructor

[image]

Grasshopper SDK
GH_Archive Constructor
GH_Archive Class See Also Send Feedback
Initializes a new instance of the GH_Archive class

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Archive()
Visual Basic
Public Sub New

See Also

GH_Archive Class
GH_IO.Serialization Namespace


GH_Archive Methods

[image] [image]

Grasshopper SDK
GH_Archive Methods
GH_Archive Class See Also Send Feedback

The GH_Archive type exposes the following members.

Methods

 | Name | Description
Public method | AddMessage(GH_Message) | Add a new message to the record.
Public method | AddMessage(String, GH_Message_Type) | Add a new message to the record.
Public method | AppendObject | Appends a target object into the root node of this archive tree. If the root doesn't exist yet, it will be created. Existing objects at the root scope will not be affected.
Public method | ClearMessages | Remove all messages from the log.
Public method | CreateNewRoot | Discards the current data tree and instantiates a new root node. This root node contains some comments, a version value containing the current version of GH_IO.dll and a DateTime value containing the current date and time.
Public method | CreateTopLevelNode | Creates and returns a new root node for this archive in the form of a GH_IWriter instance. Typically you do not call this method. If you want to add an object to the archive, use AppendObject() instead.
Public method | Deserialize_Binary | Deserializes an array of bytes.
Public method | Deserialize_Xml | Deserializes an Xml string.
Public method | ExtractObject | Extract a target object from the data tree.
Public method | MessageCount()()()() | Gets the number of messages recorded since the most recent IO operation began.
Public method | MessageCount(Boolean, Boolean, Boolean) | Gets the number of messages recorded since the most recent IO operation began. Message count can be filtered by message type.
 | OpenFileDialog | Displays a standard OpenFileDialog with all the fields set to cater for Grasshopper files.
Public method | ReadFromFile | Reads a new archive tree from a file.
 | SaveFileDialog | Displays a standard SaveFileDialog with all the fields set to cater for Grasshopper files.
Public method | Serialize_Binary | Serializes the data tree into a Binary byte array.
Public method | Serialize_Xml | Serializes the data tree into an Xml string.
Public method | ShowMessageLog | Displays the message log viewer. You should typically only display the viewer if the WorstCaseMessageType equals GH_Message_Type.warning or GH_Message_Type.error
Public method | WriteToFile | Writes the current tree to a file.

See Also

GH_Archive Class
GH_IO.Serialization Namespace


AddMessage Method

[image] [image]

Grasshopper SDK
GH_Archive..::..AddMessage Method
GH_Archive Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddMessage(GH_Message) | Add a new message to the record.
Public method | AddMessage(String, GH_Message_Type) | Add a new message to the record.

See Also

GH_Archive Class
GH_Archive Members
GH_IO.Serialization Namespace


AddMessage Method (GH_Message)

[image]

Grasshopper SDK
GH_Archive..::..AddMessage Method (GH_Message)
GH_Archive Class See Also Send Feedback
Add a new message to the record.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void AddMessage(
    GH_Message message
)
Visual Basic
Public Sub AddMessage ( _
    message As GH_Message _
)

Parameters

message
Type: GH_IO.Serialization..::..GH_Message
Message to add

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the message is a null reference.

See Also

GH_Archive Class
AddMessage Overload
GH_IO.Serialization Namespace


AddMessage Method (String, GH_Message_Type)

[image]

Grasshopper SDK
GH_Archive..::..AddMessage Method (String, GH_Message_Type)
GH_Archive Class See Also Send Feedback
Add a new message to the record.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void AddMessage(
    string message_text,
    GH_Message_Type message_type
)
Visual Basic
Public Sub AddMessage ( _
    message_text As String, _
    message_type As GH_Message_Type _
)

Parameters

message_text
Type: System..::..String
Message text.
message_type
Type: GH_IO.Serialization..::..GH_Message_Type
Message type.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if message text is null or empty.

See Also

GH_Archive Class
AddMessage Overload
GH_IO.Serialization Namespace


AppendObject Method

[image]

Grasshopper SDK
GH_Archive..::..AppendObject Method
GH_Archive Class Example See Also Send Feedback
Appends a target object into the root node of this archive tree. If the root doesn't exist yet, it will be created. Existing objects at the root scope will not be affected.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool AppendObject(
    GH_ISerializable target,
    string target_name
)
Visual Basic
Public Function AppendObject ( _
    target As GH_ISerializable, _
    target_name As String _
) As Boolean

Parameters

target
Type: GH_IO..::..GH_ISerializable
Object to append. Cannot be null.
target_name
Type: System..::..String
Name of object to append, name must be unique.

Return Value

True on succes, false on failure.

Examples

This sample shows how to create a new archive and serialize a single top level object.
CopyC#
bool CreateFile(string file_name, GH_ISerializable target, string target_name)
{
  GH_Archive archive = new GH_Archive();
  archive.AppendObject(target, target_name);
  return archive.WriteToFile(file_name, true);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if target is a null reference.
System..::..ArgumentNullException | Thrown if the target_name is null or empty.

See Also

GH_Archive Class
GH_IO.Serialization Namespace


ClearMessages Method

[image]

Grasshopper SDK
GH_Archive..::..ClearMessages Method
GH_Archive Class See Also Send Feedback
Remove all messages from the log.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void ClearMessages()
Visual Basic
Public Sub ClearMessages

See Also

GH_Archive Class
GH_IO.Serialization Namespace


CreateNewRoot Method

[image]

Grasshopper SDK
GH_Archive..::..CreateNewRoot Method
GH_Archive Class See Also Send Feedback
Discards the current data tree and instantiates a new root node. This root node contains some comments, a version value containing the current version of GH_IO.dll and a DateTime value containing the current date and time.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void CreateNewRoot(
    bool forWriting
)
Visual Basic
Public Sub CreateNewRoot ( _
    forWriting As Boolean _
)

Parameters

forWriting
Type: System..::..Boolean
If true, all data fields are reset.

See Also

GH_Archive Class
GH_IO.Serialization Namespace


CreateTopLevelNode Method

[image]

Grasshopper SDK
GH_Archive..::..CreateTopLevelNode Method
GH_Archive Class See Also Send Feedback
Creates and returns a new root node for this archive in the form of a GH_IWriter instance. Typically you do not call this method. If you want to add an object to the archive, use AppendObject() instead.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_IWriter CreateTopLevelNode(
    string root_name
)
Visual Basic
Public Function CreateTopLevelNode ( _
    root_name As String _
) As GH_IWriter

Parameters

root_name
Type: System..::..String
Name of root object.

Return Value

The GH_IWriter incarnation of the GH_Chunk that represents the new Node.

See Also

GH_Archive Class
GH_IO.Serialization Namespace


Deserialize_Binary Method

[image]

Grasshopper SDK
GH_Archive..::..Deserialize_Binary Method
GH_Archive Class See Also Send Feedback
Deserializes an array of bytes.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool Deserialize_Binary(
    byte[] data
)
Visual Basic
Public Function Deserialize_Binary ( _
    data As Byte() _
) As Boolean

Parameters

data
Type: array< System..::..Byte >[]()[][]
Byte array to deserialize.

Return Value

True on success, false on failure.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if data is a null reference.

See Also

GH_Archive Class
GH_IO.Serialization Namespace


Deserialize_Xml Method

[image]

Grasshopper SDK
GH_Archive..::..Deserialize_Xml Method
GH_Archive Class See Also Send Feedback
Deserializes an Xml string.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool Deserialize_Xml(
    string xml_content
)
Visual Basic
Public Function Deserialize_Xml ( _
    xml_content As String _
) As Boolean

Parameters

xml_content
Type: System..::..String
Xml to deserialize.

Return Value

True on success, false on failure.

Exceptions

Exception | Condition
System.Xml..::..XmlException | Thrown if xml_content is not a valid Grasshopper Xml stream.

See Also

GH_Archive Class
GH_IO.Serialization Namespace


ExtractObject Method

[image]

Grasshopper SDK
GH_Archive..::..ExtractObject Method
GH_Archive Class See Also Send Feedback
Extract a target object from the data tree.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool ExtractObject(
    GH_ISerializable target,
    string target_name
)
Visual Basic
Public Function ExtractObject ( _
    target As GH_ISerializable, _
    target_name As String _
) As Boolean

Parameters

target
Type: GH_IO..::..GH_ISerializable
Object to extract. Cannot be null.
target_name
Type: System..::..String
Name of object to extract, name must identify an existing chunk.

Return Value

True on succes, false on failure.

Exceptions

Exception | Condition
System..::..MemberAccessException | Thrown if the Root node hasn't been instantiated yet.
System..::..ArgumentNullException | Thrown if target is a null reference.
System..::..ArgumentNullException | Thrown if the target_name is null or empty.
System..::..MemberAccessException | Thrown if the target_name cannot be resolved.

See Also

GH_Archive Class
GH_IO.Serialization Namespace


MessageCount Method

[image] [image]

Grasshopper SDK
GH_Archive..::..MessageCount Method
GH_Archive Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MessageCount()()()() | Gets the number of messages recorded since the most recent IO operation began.
Public method | MessageCount(Boolean, Boolean, Boolean) | Gets the number of messages recorded since the most recent IO operation began. Message count can be filtered by message type.

See Also

GH_Archive Class
GH_Archive Members
GH_IO.Serialization Namespace


MessageCount Method

[image]

Grasshopper SDK
GH_Archive..::..MessageCount Method
GH_Archive Class See Also Send Feedback
Gets the number of messages recorded since the most recent IO operation began.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public int MessageCount()
Visual Basic
Public Function MessageCount As Integer

Return Value

The number of recorded messages.

See Also

GH_Archive Class
MessageCount Overload
GH_IO.Serialization Namespace


MessageCount Method (Boolean, Boolean, Boolean)

[image]

Grasshopper SDK
GH_Archive..::..MessageCount Method (Boolean, Boolean, Boolean)
GH_Archive Class See Also Send Feedback
Gets the number of messages recorded since the most recent IO operation began. Message count can be filtered by message type.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public int MessageCount(
    bool includeInfo,
    bool includeWarnings,
    bool includeErrors
)
Visual Basic
Public Function MessageCount ( _
    includeInfo As Boolean, _
    includeWarnings As Boolean, _
    includeErrors As Boolean _
) As Integer

Parameters

includeInfo
Type: System..::..Boolean
If true, info messages will be included in the count.
includeWarnings
Type: System..::..Boolean
If true, warnings will be included in the count.
includeErrors
Type: System..::..Boolean
If true, errors will be included in the count.

Return Value

The number of recoded messages that pass the type filters.

See Also

GH_Archive Class
MessageCount Overload
GH_IO.Serialization Namespace


OpenFileDialog Method

[image]

Grasshopper SDK
GH_Archive..::..OpenFileDialog Method
GH_Archive Class See Also Send Feedback
Displays a standard OpenFileDialog with all the fields set to cater for Grasshopper files.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public static bool OpenFileDialog(
    string title,
    ref string file_path,
    List<string> additional_filters
)
Visual Basic
Public Shared Function OpenFileDialog ( _
    title As String, _
    ByRef file_path As String, _
    additional_filters As List(Of String) _
) As Boolean

Parameters

title
Type: System..::..String
Title of the dialog. If null, the default title will be used.
file_path
Type: System..::..String %
Path to file picked by user. If file_path represents a valid string, the dialog is set up to match.
additional_filters
Type: System.Collections.Generic..::..List <(Of <(<' String >)>)>
A list of additional file format filters or null. Filter strings must be in typical FileDialog.Filter syntax: "File Name (*.ext)|*.ext"

Return Value

True is user picked a path, False if user cancelled.

See Also

GH_Archive Class
GH_IO.Serialization Namespace


ReadFromFile Method

[image]

Grasshopper SDK
GH_Archive..::..ReadFromFile Method
GH_Archive Class See Also Send Feedback
Reads a new archive tree from a file.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool ReadFromFile(
    string file_name
)
Visual Basic
Public Function ReadFromFile ( _
    file_name As String _
) As Boolean

Parameters

file_name
Type: System..::..String
Path of file to parse.

Return Value

True on success, false on failure. If the read operation fails, all the member fields of this archive ought to be treated as invalid.

Exceptions

Exception | Condition
System.IO..::..FileNotFoundException | Thrown if the file doesn't exist.
System.IO..::..IOException | Thrown if the file_name doesn't represent a known file extension.

See Also

GH_Archive Class
GH_IO.Serialization Namespace


SaveFileDialog Method

[image]

Grasshopper SDK
GH_Archive..::..SaveFileDialog Method
GH_Archive Class See Also Send Feedback
Displays a standard SaveFileDialog with all the fields set to cater for Grasshopper files.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public static bool SaveFileDialog(
    string title,
    ref string file_path,
    List<string> additional_filters
)
Visual Basic
Public Shared Function SaveFileDialog ( _
    title As String, _
    ByRef file_path As String, _
    additional_filters As List(Of String) _
) As Boolean

Parameters

title
Type: System..::..String
Title of the dialog. If null, the default title will be used.
file_path
Type: System..::..String %
Path to file picked by user. If file_path represents a valid string, the dialog is set up to match.
additional_filters
Type: System.Collections.Generic..::..List <(Of <(<' String >)>)>
A list of additional file format filters or null. Filter strings must be in typical FileDialog.Filter syntax: "File Name (*.ext)|*.ext"

Return Value

True is user picked a new path, False if user cancelled.

See Also

GH_Archive Class
GH_IO.Serialization Namespace


Serialize_Binary Method

[image]

Grasshopper SDK
GH_Archive..::..Serialize_Binary Method
GH_Archive Class See Also Send Feedback
Serializes the data tree into a Binary byte array.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public byte[] Serialize_Binary()
Visual Basic
Public Function Serialize_Binary As Byte()

Return Value

A byte array containing the Binary stream.

Exceptions

Exception | Condition
System..::..MemberAccessException | Thrown if the root of the current archive hasn't been instantiated yet.

See Also

GH_Archive Class
GH_IO.Serialization Namespace


Serialize_Xml Method

[image]

Grasshopper SDK
GH_Archive..::..Serialize_Xml Method
GH_Archive Class See Also Send Feedback
Serializes the data tree into an Xml string.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public string Serialize_Xml()
Visual Basic
Public Function Serialize_Xml As String

Return Value

A string containing the Xml content.

Exceptions

Exception | Condition
System..::..MemberAccessException | Thrown if the root of the current archive hasn't been instantiated yet.

See Also

GH_Archive Class
GH_IO.Serialization Namespace


ShowMessageLog Method

[image]

Grasshopper SDK
GH_Archive..::..ShowMessageLog Method
GH_Archive Class See Also Send Feedback
Displays the message log viewer. You should typically only display the viewer if the WorstCaseMessageType equals GH_Message_Type.warning or GH_Message_Type.error

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public DialogResult ShowMessageLog()
Visual Basic
Public Function ShowMessageLog As DialogResult

Return Value

The closing flag for the displayed log form.

See Also

GH_Archive Class
GH_IO.Serialization Namespace


WriteToFile Method

[image]

Grasshopper SDK
GH_Archive..::..WriteToFile Method
GH_Archive Class See Also Send Feedback
Writes the current tree to a file.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool WriteToFile(
    string file_name,
    bool overwrite,
    bool remember_path
)
Visual Basic
Public Function WriteToFile ( _
    file_name As String, _
    overwrite As Boolean, _
    remember_path As Boolean _
) As Boolean

Parameters

file_name
Type: System..::..String
Path of file to write to. If the extension is not a recognized Grasshopper extension, an exception will be thrown.
overwrite
Type: System..::..Boolean
True to overwrite file at specified location.
remember_path
Type: System..::..Boolean
If True, the MRU path field will be updated to reflect the new path.

Return Value

True on succes, false if file already exists and overwrite is set to false.

Exceptions

Exception | Condition
System..::..MemberAccessException | Thrown if the root of the current archive hasn't been instantiated yet.
System..::..ArgumentNullException | Thrown if file_name is either null or empty.
System.IO..::..IOException | Thrown if the file_name doesn't represent a known file extension.

See Also

GH_Archive Class
GH_IO.Serialization Namespace


GH_Archive Properties

[image] [image]

Grasshopper SDK
GH_Archive Properties
GH_Archive Class See Also Send Feedback

The GH_Archive type exposes the following members.

Properties

 | Name | Description
Public property | FileName | Gets the filename (without extension) of the currently loaded data tree. If the path field has not been set, "unnamed" is returned.
Public property | GetRootNode | Gets the root node of this archive. Typically you do not need to modify the Root. Use functions like CreateTopLevelNode(), AppendObject() and ExtractObject() instead. If you modify the Root node, you may corrupt the archive.
 | GH_IO_Version | Gets the version number of the current GH_IO build.
 | GrasshopperBinaryExtension | Gets the file extension (including the dot) associated with Grasshopper® Binary data.
 | GrasshopperUserExtension | Gets the file extension (including the dot) associated with Grasshopper® User Object file.
 | GrasshopperXmlExtension | Gets the file extension (including the dot) associated with Grasshopper® XML data.
Public property | IsBinaryPath | Gets a value that indicates whether the Path field points to a Binary Grasshopper file.
Public property | IsPath | Gets a value that indicates whether or not the path field has been set.
Public property | IsXmlPath | Gets a value that indicates whether the Path field points to an Xml Grasshopper file.
Public property | Messages | Gets the internal list of messages.
Public property | Path | Gets the path to the file from which this archive was read and/or written to. If the archive hasn't been read or written yet, this field will be null.
Public property | WorstCaseMessageType | Gets the worst case message type. If the record contains at least 1 error, the worst case is GH_Message_Type.error. If the record contains no errors, but at least 1 warning, the worst case is GH_Message_Type.warning. If the record contains no messages or only infos, the worst case type is GH_Message_Type.info.

See Also

GH_Archive Class
GH_IO.Serialization Namespace


FileName Property

[image]

Grasshopper SDK
GH_Archive..::..FileName Property
GH_Archive Class See Also Send Feedback
Gets the filename (without extension) of the currently loaded data tree. If the path field has not been set, "unnamed" is returned.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public string FileName { get; }
Visual Basic
Public ReadOnly Property FileName As String
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Serialization.GH_Archive.FileName"]

See Also

GH_Archive Class
GH_IO.Serialization Namespace


GetRootNode Property

[image]

Grasshopper SDK
GH_Archive..::..GetRootNode Property
GH_Archive Class See Also Send Feedback
Gets the root node of this archive. Typically you do not need to modify the Root. Use functions like CreateTopLevelNode(), AppendObject() and ExtractObject() instead. If you modify the Root node, you may corrupt the archive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Chunk GetRootNode { get; }
Visual Basic
Public ReadOnly Property GetRootNode As GH_Chunk
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Serialization.GH_Archive.GetRootNode"]

See Also

GH_Archive Class
GH_IO.Serialization Namespace


GH_IO_Version Property

[image]

Grasshopper SDK
GH_Archive..::..GH_IO_Version Property
GH_Archive Class See Also Send Feedback
Gets the version number of the current GH_IO build.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public static GH_Version GH_IO_Version { get; }
Visual Basic
Public Shared ReadOnly Property GH_IO_Version As GH_Version
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Serialization.GH_Archive.GH_IO_Version"]

See Also

GH_Archive Class
GH_IO.Serialization Namespace


GrasshopperBinaryExtension Property

[image]

Grasshopper SDK
GH_Archive..::..GrasshopperBinaryExtension Property
GH_Archive Class See Also Send Feedback
Gets the file extension (including the dot) associated with Grasshopper® Binary data.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public static string GrasshopperBinaryExtension { get; }
Visual Basic
Public Shared ReadOnly Property GrasshopperBinaryExtension As String
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Serialization.GH_Archive.GrasshopperBinaryExtension"]

See Also

GH_Archive Class
GH_IO.Serialization Namespace


GrasshopperUserExtension Property

[image]

Grasshopper SDK
GH_Archive..::..GrasshopperUserExtension Property
GH_Archive Class See Also Send Feedback
Gets the file extension (including the dot) associated with Grasshopper® User Object file.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public static string GrasshopperUserExtension { get; }
Visual Basic
Public Shared ReadOnly Property GrasshopperUserExtension As String
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Serialization.GH_Archive.GrasshopperUserExtension"]

See Also

GH_Archive Class
GH_IO.Serialization Namespace


GrasshopperXmlExtension Property

[image]

Grasshopper SDK
GH_Archive..::..GrasshopperXmlExtension Property
GH_Archive Class See Also Send Feedback
Gets the file extension (including the dot) associated with Grasshopper® XML data.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public static string GrasshopperXmlExtension { get; }
Visual Basic
Public Shared ReadOnly Property GrasshopperXmlExtension As String
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Serialization.GH_Archive.GrasshopperXmlExtension"]

See Also

GH_Archive Class
GH_IO.Serialization Namespace


IsBinaryPath Property

[image]

Grasshopper SDK
GH_Archive..::..IsBinaryPath Property
GH_Archive Class See Also Send Feedback
Gets a value that indicates whether the Path field points to a Binary Grasshopper file.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool IsBinaryPath { get; }
Visual Basic
Public ReadOnly Property IsBinaryPath As Boolean
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Serialization.GH_Archive.IsBinaryPath"]

See Also

GH_Archive Class
GH_IO.Serialization Namespace


IsPath Property

[image]

Grasshopper SDK
GH_Archive..::..IsPath Property
GH_Archive Class See Also Send Feedback
Gets a value that indicates whether or not the path field has been set.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool IsPath { get; }
Visual Basic
Public ReadOnly Property IsPath As Boolean
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Serialization.GH_Archive.IsPath"]

See Also

GH_Archive Class
GH_IO.Serialization Namespace


IsXmlPath Property

[image]

Grasshopper SDK
GH_Archive..::..IsXmlPath Property
GH_Archive Class See Also Send Feedback
Gets a value that indicates whether the Path field points to an Xml Grasshopper file.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool IsXmlPath { get; }
Visual Basic
Public ReadOnly Property IsXmlPath As Boolean
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Serialization.GH_Archive.IsXmlPath"]

See Also

GH_Archive Class
GH_IO.Serialization Namespace


Messages Property

[image]

Grasshopper SDK
GH_Archive..::..Messages Property
GH_Archive Class See Also Send Feedback
Gets the internal list of messages.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public List<GH_Message> Messages { get; }
Visual Basic
Public ReadOnly Property Messages As List(Of GH_Message)
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Serialization.GH_Archive.Messages"]

See Also

GH_Archive Class
GH_IO.Serialization Namespace


Path Property

[image]

Grasshopper SDK
GH_Archive..::..Path Property
GH_Archive Class See Also Send Feedback
Gets the path to the file from which this archive was read and/or written to. If the archive hasn't been read or written yet, this field will be null.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public string Path { get; set; }
Visual Basic
Public Property Path As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:GH_IO.Serialization.GH_Archive.Path"]

See Also

GH_Archive Class
GH_IO.Serialization Namespace


WorstCaseMessageType Property

[image]

Grasshopper SDK
GH_Archive..::..WorstCaseMessageType Property
GH_Archive Class See Also Send Feedback
Gets the worst case message type. If the record contains at least 1 error, the worst case is GH_Message_Type.error. If the record contains no errors, but at least 1 warning, the worst case is GH_Message_Type.warning. If the record contains no messages or only infos, the worst case type is GH_Message_Type.info.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Message_Type WorstCaseMessageType { get; }
Visual Basic
Public ReadOnly Property WorstCaseMessageType As GH_Message_Type
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Serialization.GH_Archive.WorstCaseMessageType"]

See Also

GH_Archive Class
GH_IO.Serialization Namespace


GH_Chunk Class

[image]

Grasshopper SDK
GH_Chunk Class
Members See Also Send Feedback
Full implementation of GH_IChunk, GH_IReader, GH_IWriter, GH_IBinarySupport and GH_IXmlSupport. Instances of this class are usually disguised as one of the interfaces it implements.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public class GH_Chunk : GH_IWriter, GH_IReader,
    GH_IChunk, GH_IBinarySupport, GH_IXmlSupport
Visual Basic
Public Class GH_Chunk _
    Implements GH_IWriter, GH_IReader, GH_IChunk, GH_IBinarySupport,  _
    GH_IXmlSupport

Inheritance Hierarchy

System..::..Object
GH_IO.Serialization..::..GH_Chunk
GH_IO.Serialization..::..GH_LooseChunk

See Also

GH_Chunk Members
GH_IO.Serialization Namespace


GH_Chunk Members

[image] [image]

Grasshopper SDK
GH_Chunk Members
GH_Chunk Class Constructors Methods Fields Properties See Also Send Feedback

The GH_Chunk type exposes the following members.

Constructors

 | Name | Description
Protected method | GH_Chunk()()()() | Blank constructor. You typically do not need to create your own Chunks. The GH_Archive class will create top-level chunks and existing chunks can create child chunks.
Protected method | GH_Chunk(GH_Archive) | Constructor. You typically do not need to create your own Chunks. The GH_Archive class will create top-level chunks and existing chunks can create child chunks.
Protected method | GH_Chunk(GH_Archive, String) | Constructor. You typically do not need to create your own Chunks. The GH_Archive class will create top-level chunks and existing chunks can create child chunks.
Protected method | GH_Chunk(GH_Archive, String, Int32) | Constructor. You typically do not need to create your own Chunks. The GH_Archive class will create top-level chunks and existing chunks can create child chunks.

Methods

 | Name | Description
Public method | AddComment | Adds a text comment to this chunk. Comments are serialized only if the output flavour is a human readable format. Comments are never deserialized, they are purely for the benefit of the humans reading the file data.
Public method | AddMessage | Log a new message with the top-level archive. Messages are collected during read/write operations, and can be displayed to the user upon completion using GH_Archive.ShowMessageLog().
Public method | ChunkExists(String) | Checks whether a chunk with the specified name exists in the litter. Only chunks without index qualifiers are considered. Name comparisons are not case-sensitive.
Public method | ChunkExists(String, Int32) | Checks whether a chunk with the specified name and index exists in the litter. Only chunks with index qualifiers are considered. Name comparisons are not case-sensitive.
Public method | CreateChunk(String) | Create a new child chunk with the specified name and without an index qualifier. If another chunk already exists with similar properties, an exception will be thrown.
Public method | CreateChunk(String, Int32) | Create a new child chunk with the specified name and index qualifier. If another chunk already exists with similar properties, an exception will be thrown.
Public method | FindChunk(String) | Finds the first chunk in the litter that matches the given name. Only chunks without index qualifiers are considered.
Public method | FindChunk(String, Int32) | Finds the first chunk in the list that matches the given name and index. Only chunks with index qualifiers are considered.
Public method | FindItem(String) | Finds the first item that matches the given name. Only items without index qualifiers are considered. Name comparisons are not case-sensitive.
Public method | FindItem(String, Int32) | Finds the first item that matches the given name and index. Only items with index qualifiers are considered. Name comparisons are not case-sensitive.
Public method | GetBoolean(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetBoolean(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetBoundingBox(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetBoundingBox(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetByte(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetByte(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetByteArray(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetByteArray(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDate(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDate(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDecimal(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDecimal(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDouble(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDouble(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDoubleArray(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDoubleArray(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDrawingBitmap(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingBitmap(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDrawingColor(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingColor(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDrawingPoint(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingPoint(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDrawingPointF(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingPointF(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDrawingRectangle(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingRectangle(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDrawingRectangleF(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingRectangleF(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDrawingSize(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingSize(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDrawingSizeF(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingSizeF(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetGuid(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetGuid(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetInt32(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetInt32(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetInt64(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetInt64(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetInterval1D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetInterval1D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetInterval2D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetInterval2D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetLine(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetLine(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetPath(String, String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetPath(String, Int32, String) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetPlane(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetPlane(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetPoint2D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetPoint2D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetPoint3D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetPoint3D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetPoint4D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetPoint4D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetSingle(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetSingle(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetString(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetString(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetVersion(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetVersion(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
 | InstantiateRoot | Construct a new instance of GH_Chunk which acts as a Root node. If you must create a chunk from scratch, use this static method to create one.
Public method | ItemExists(String) | Gets the occupancy for a specific item name. Only items without index qualifiers are considered.
Public method | ItemExists(String, Int32) | Checks whether an item with the specified name and index exists. Only items with index qualifiers are considered. Name comparisons are not case-sensitive.
Public method | Read(BinaryReader) | Read this chunk and all child chunks from a binary stream.
Public method | Read(XmlNode) | Read this chunk and all child chunks from an Xml node.
Public method | RemoveChunk(String) | Remove the first chunk with a matching name. Only chunks without index qualifiers are considered. Name comparisons are not case-sensitive.
Public method | RemoveChunk(GH_IChunk) | Remove the specified chunk from the litter.
Public method | RemoveChunk(String, Int32) | Remove the first chunk with a matching name and index. Only chunks with index qualifiers are considered. Name comparisons are not case-sensitive.
Public method | RemoveItem(String) | Remove an unindexed item from this chunk.
Public method | RemoveItem(String, Int32) | Remove an indexed item from this chunk.
Public method | SetBoolean(String, Boolean) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetBoolean(String, Int32, Boolean) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetBoundingBox(String, GH_BoundingBox) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetBoundingBox(String, Int32, GH_BoundingBox) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetByte(String, Byte) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetByte(String, Int32, Byte) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetByteArray(String, array<Byte>[]()[][]) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetByteArray(String, Int32, array<Byte>[]()[][]) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDate(String, DateTime) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDate(String, Int32, DateTime) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDecimal(String, Decimal) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDecimal(String, Int32, Decimal) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDouble(String, Double) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDouble(String, Int32, Double) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDoubleArray(String, array<Double>[]()[][]) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDoubleArray(String, Int32, array<Double>[]()[][]) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDrawingBitmap(String, Bitmap) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingBitmap(String, Int32, Bitmap) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingColor(String, Color) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingColor(String, Int32, Color) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDrawingPoint(String, Point) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingPoint(String, Int32, Point) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDrawingPointF(String, PointF) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingPointF(String, Int32, PointF) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDrawingRectangle(String, Rectangle) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingRectangle(String, Int32, Rectangle) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDrawingRectangleF(String, RectangleF) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingRectangleF(String, Int32, RectangleF) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDrawingSize(String, Size) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingSize(String, Int32, Size) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDrawingSizeF(String, SizeF) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingSizeF(String, Int32, SizeF) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetGuid(String, Guid) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetGuid(String, Int32, Guid) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetInt32(String, Int32) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetInt32(String, Int32, Int32) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetInt64(String, Int64) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetInt64(String, Int32, Int64) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetInterval1D(String, GH_Interval1D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetInterval1D(String, Int32, GH_Interval1D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetInterval2D(String, GH_Interval2D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetInterval2D(String, Int32, GH_Interval2D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetLine(String, GH_Line) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetLine(String, Int32, GH_Line) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetPath(String, String, String) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetPath(String, Int32, String, String) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetPlane(String, GH_Plane) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetPlane(String, Int32, GH_Plane) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetPoint2D(String, GH_Point2D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetPoint2D(String, Int32, GH_Point2D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetPoint3D(String, GH_Point3D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetPoint3D(String, Int32, GH_Point3D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetPoint4D(String, GH_Point4D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetPoint4D(String, Int32, GH_Point4D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetSingle(String, Single) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetSingle(String, Int32, Single) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetString(String, String) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetString(String, Int32, String) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetVersion(String, GH_Version) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetVersion(String, Int32, GH_Version) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetVersion(String, Int32, Int32, Int32) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetVersion(String, Int32, Int32, Int32, Int32) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | TryGetBoolean(String, Boolean%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetBoolean(String, Int32, Boolean%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetBoundingBox(String, GH_BoundingBox%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetBoundingBox(String, Int32, GH_BoundingBox%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetByte(String, Byte%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetByte(String, Int32, Byte%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetDate(String, DateTime%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDate(String, Int32, DateTime%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetDecimal(String, Decimal%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDecimal(String, Int32, Decimal%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetDouble(String, Double%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDouble(String, Int32, Double%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetDrawingColor(String, Color%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingColor(String, Int32, Color%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetDrawingPoint(String, Point%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingPoint(String, Int32, Point%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetDrawingPointF(String, PointF%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingPointF(String, Int32, PointF%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetDrawingRectangle(String, Rectangle%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingRectangle(String, Int32, Rectangle%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetDrawingRectangleF(String, RectangleF%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingRectangleF(String, Int32, RectangleF%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetDrawingSize(String, Size%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingSize(String, Int32, Size%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetDrawingSizeF(String, SizeF%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingSizeF(String, Int32, SizeF%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetGuid(String, Guid%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetGuid(String, Int32, Guid%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetInt32(String, Int32%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetInt32(String, Int32, Int32%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetInt64(String, Int64%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetInt64(String, Int32, Int64%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetInterval1D(String, GH_Interval1D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetInterval1D(String, Int32, GH_Interval1D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetInterval2D(String, GH_Interval2D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetInterval2D(String, Int32, GH_Interval2D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetLine(String, GH_Line%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetLine(String, Int32, GH_Line%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetPlane(String, GH_Plane%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetPlane(String, Int32, GH_Plane%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetPoint2D(String, GH_Point2D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetPoint2D(String, Int32, GH_Point2D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetPoint3D(String, GH_Point3D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetPoint3D(String, Int32, GH_Point3D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetPoint4D(String, GH_Point4D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetPoint4D(String, Int32, GH_Point4D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetSingle(String, Single%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetSingle(String, Int32, Single%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetString(String, String%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetString(String, Int32, String%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetVersion(String, GH_Version%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetVersion(String, Int32, GH_Version%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | Write(BinaryWriter) | Write this chunk and all child chunks to a binary stream.
Public method | Write(XmlWriter) | Serialize this chunk into an Xml stream.

Fields

 | Name | Description
Protected field | m_archive | Pointer to the archive that owns the Root of the tree this chunk belongs to.
Protected field | m_chunks | List of sub-chunks contained within this chunk.
Protected field | m_comments | List of text comments. This list is automatically instantiated once the first comment is added.
Protected field | m_index | Index of this chunk. This field is set only once, during construction. A negative index indicates no index qualifier has been set.
Protected field | m_items | The list of nodes contained within this chunk.
Protected field | m_name | Name of this chunk. This field is set only once, during construction.
 | name_comp | Comparison flag to use when comparing names.

Properties

 | Name | Description
Public property | Archive | Gets a pointer to the archive that owns the Root of the tree this chunk belongs to.
Public property | ArchiveLocation | Gets a string representing the URI with which the archive is associated. The location may be a null string.
Public property | ChunkCount | Gets the number of child chunks contained in this chunk. The set of all child chunks is referred to as a 'litter'.
Public property | Chunks | Gets a pointer to the internal list of child chunks. Do not access this list unless you know what you are doing.
Public property | HasComments | Gets a value that indicates whether or not comments have been stored in this chunk.
Public property | HasIndex | Gets the index existence implication. The item is considered to have an index qualifier if the index value is larger than or equal to zero.
Public property | HasName | Gets the name validity of this item. The item is considered to have an invalid name if string.IsNullOrEmpty(name)
Public property | Index | Gets the index of this chunk. The index is set by the owner of this chunk. Indices smaller than zero imply no index has been set. The combination of name+index is always unique among a set of chunks in the same litter.
Public property | ItemCount | Gets the number of items contained in this chunk.
Public property | Items | Gets a pointer to the internal list of items. Do not access this list unless you know what you are doing.
Public property | Name | Gets the name of this chunk. The name is set by the owner of this chunk. Names must be at least 1 character long. The combination of name+index is always unique among a set of chunks in a single litter.

See Also

GH_Chunk Class
GH_IO.Serialization Namespace


GH_Chunk Constructor

[image] [image]

Grasshopper SDK
GH_Chunk Constructor
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GH_Chunk()()()() | Blank constructor. You typically do not need to create your own Chunks. The GH_Archive class will create top-level chunks and existing chunks can create child chunks.
Protected method | GH_Chunk(GH_Archive) | Constructor. You typically do not need to create your own Chunks. The GH_Archive class will create top-level chunks and existing chunks can create child chunks.
Protected method | GH_Chunk(GH_Archive, String) | Constructor. You typically do not need to create your own Chunks. The GH_Archive class will create top-level chunks and existing chunks can create child chunks.
Protected method | GH_Chunk(GH_Archive, String, Int32) | Constructor. You typically do not need to create your own Chunks. The GH_Archive class will create top-level chunks and existing chunks can create child chunks.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


GH_Chunk Constructor

[image]

Grasshopper SDK
GH_Chunk Constructor
GH_Chunk Class See Also Send Feedback
Blank constructor. You typically do not need to create your own Chunks. The GH_Archive class will create top-level chunks and existing chunks can create child chunks.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
protected GH_Chunk()
Visual Basic
Protected Sub New

See Also

GH_Chunk Class
GH_Chunk Overload
GH_IO.Serialization Namespace


GH_Chunk Constructor (GH_Archive)

[image]

Grasshopper SDK
GH_Chunk Constructor (GH_Archive)
GH_Chunk Class See Also Send Feedback
Constructor. You typically do not need to create your own Chunks. The GH_Archive class will create top-level chunks and existing chunks can create child chunks.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
protected GH_Chunk(
    GH_Archive chunk_archive
)
Visual Basic
Protected Sub New ( _
    chunk_archive As GH_Archive _
)

Parameters

chunk_archive
Type: GH_IO.Serialization..::..GH_Archive
Owner archive.

See Also

GH_Chunk Class
GH_Chunk Overload
GH_IO.Serialization Namespace


GH_Chunk Constructor (GH_Archive, String)

[image]

Grasshopper SDK
GH_Chunk Constructor (GH_Archive, String)
GH_Chunk Class See Also Send Feedback
Constructor. You typically do not need to create your own Chunks. The GH_Archive class will create top-level chunks and existing chunks can create child chunks.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
protected GH_Chunk(
    GH_Archive chunk_archive,
    string chunk_name
)
Visual Basic
Protected Sub New ( _
    chunk_archive As GH_Archive, _
    chunk_name As String _
)

Parameters

chunk_archive
Type: GH_IO.Serialization..::..GH_Archive
Owner archive.
chunk_name
Type: System..::..String
Name of this chunk.

See Also

GH_Chunk Class
GH_Chunk Overload
GH_IO.Serialization Namespace


GH_Chunk Constructor (GH_Archive, String, Int32)

[image]

Grasshopper SDK
GH_Chunk Constructor (GH_Archive, String, Int32)
GH_Chunk Class See Also Send Feedback
Constructor. You typically do not need to create your own Chunks. The GH_Archive class will create top-level chunks and existing chunks can create child chunks.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
protected GH_Chunk(
    GH_Archive chunk_archive,
    string chunk_name,
    int chunk_index
)
Visual Basic
Protected Sub New ( _
    chunk_archive As GH_Archive, _
    chunk_name As String, _
    chunk_index As Integer _
)

Parameters

chunk_archive
Type: GH_IO.Serialization..::..GH_Archive
Owner archive.
chunk_name
Type: System..::..String
Name of this chunk.
chunk_index
Type: System..::..Int32
Index of this chunk.

See Also

GH_Chunk Class
GH_Chunk Overload
GH_IO.Serialization Namespace


GH_Chunk Fields

[image] [image]

Grasshopper SDK
GH_Chunk Fields
GH_Chunk Class See Also Send Feedback

The GH_Chunk type exposes the following members.

Fields

 | Name | Description
Protected field | m_archive | Pointer to the archive that owns the Root of the tree this chunk belongs to.
Protected field | m_chunks | List of sub-chunks contained within this chunk.
Protected field | m_comments | List of text comments. This list is automatically instantiated once the first comment is added.
Protected field | m_index | Index of this chunk. This field is set only once, during construction. A negative index indicates no index qualifier has been set.
Protected field | m_items | The list of nodes contained within this chunk.
Protected field | m_name | Name of this chunk. This field is set only once, during construction.
 | name_comp | Comparison flag to use when comparing names.

See Also

GH_Chunk Class
GH_IO.Serialization Namespace


m_archive Field

[image]

Grasshopper SDK
GH_Chunk..::..m_archive Field
GH_Chunk Class See Also Send Feedback
Pointer to the archive that owns the Root of the tree this chunk belongs to.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
protected GH_Archive m_archive
Visual Basic
Protected m_archive As GH_Archive

See Also

GH_Chunk Class
GH_IO.Serialization Namespace


m_chunks Field

[image]

Grasshopper SDK
GH_Chunk..::..m_chunks Field
GH_Chunk Class See Also Send Feedback
List of sub-chunks contained within this chunk.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
protected List<GH_Chunk> m_chunks
Visual Basic
Protected m_chunks As List(Of GH_Chunk)

See Also

GH_Chunk Class
GH_IO.Serialization Namespace


m_comments Field

[image]

Grasshopper SDK
GH_Chunk..::..m_comments Field
GH_Chunk Class See Also Send Feedback
List of text comments. This list is automatically instantiated once the first comment is added.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
protected List<string> m_comments
Visual Basic
Protected m_comments As List(Of String)

See Also

GH_Chunk Class
GH_IO.Serialization Namespace


m_index Field

[image]

Grasshopper SDK
GH_Chunk..::..m_index Field
GH_Chunk Class See Also Send Feedback
Index of this chunk. This field is set only once, during construction. A negative index indicates no index qualifier has been set.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
protected int m_index
Visual Basic
Protected m_index As Integer

See Also

GH_Chunk Class
GH_IO.Serialization Namespace


m_items Field

[image]

Grasshopper SDK
GH_Chunk..::..m_items Field
GH_Chunk Class See Also Send Feedback
The list of nodes contained within this chunk.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
protected List<GH_Item> m_items
Visual Basic
Protected m_items As List(Of GH_Item)

See Also

GH_Chunk Class
GH_IO.Serialization Namespace


m_name Field

[image]

Grasshopper SDK
GH_Chunk..::..m_name Field
GH_Chunk Class See Also Send Feedback
Name of this chunk. This field is set only once, during construction.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
protected string m_name
Visual Basic
Protected m_name As String

See Also

GH_Chunk Class
GH_IO.Serialization Namespace


name_comp Field

[image]

Grasshopper SDK
GH_Chunk..::..name_comp Field
GH_Chunk Class See Also Send Feedback
Comparison flag to use when comparing names.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
protected static StringComparison name_comp
Visual Basic
Protected Shared name_comp As StringComparison

See Also

GH_Chunk Class
GH_IO.Serialization Namespace


GH_Chunk Methods

[image] [image]

Grasshopper SDK
GH_Chunk Methods
GH_Chunk Class See Also Send Feedback

The GH_Chunk type exposes the following members.

Methods

 | Name | Description
Public method | AddComment | Adds a text comment to this chunk. Comments are serialized only if the output flavour is a human readable format. Comments are never deserialized, they are purely for the benefit of the humans reading the file data.
Public method | AddMessage | Log a new message with the top-level archive. Messages are collected during read/write operations, and can be displayed to the user upon completion using GH_Archive.ShowMessageLog().
Public method | ChunkExists(String) | Checks whether a chunk with the specified name exists in the litter. Only chunks without index qualifiers are considered. Name comparisons are not case-sensitive.
Public method | ChunkExists(String, Int32) | Checks whether a chunk with the specified name and index exists in the litter. Only chunks with index qualifiers are considered. Name comparisons are not case-sensitive.
Public method | CreateChunk(String) | Create a new child chunk with the specified name and without an index qualifier. If another chunk already exists with similar properties, an exception will be thrown.
Public method | CreateChunk(String, Int32) | Create a new child chunk with the specified name and index qualifier. If another chunk already exists with similar properties, an exception will be thrown.
Public method | FindChunk(String) | Finds the first chunk in the litter that matches the given name. Only chunks without index qualifiers are considered.
Public method | FindChunk(String, Int32) | Finds the first chunk in the list that matches the given name and index. Only chunks with index qualifiers are considered.
Public method | FindItem(String) | Finds the first item that matches the given name. Only items without index qualifiers are considered. Name comparisons are not case-sensitive.
Public method | FindItem(String, Int32) | Finds the first item that matches the given name and index. Only items with index qualifiers are considered. Name comparisons are not case-sensitive.
Public method | GetBoolean(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetBoolean(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetBoundingBox(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetBoundingBox(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetByte(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetByte(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetByteArray(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetByteArray(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDate(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDate(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDecimal(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDecimal(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDouble(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDouble(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDoubleArray(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDoubleArray(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDrawingBitmap(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingBitmap(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDrawingColor(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingColor(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDrawingPoint(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingPoint(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDrawingPointF(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingPointF(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDrawingRectangle(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingRectangle(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDrawingRectangleF(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingRectangleF(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDrawingSize(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingSize(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDrawingSizeF(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingSizeF(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetGuid(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetGuid(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetInt32(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetInt32(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetInt64(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetInt64(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetInterval1D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetInterval1D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetInterval2D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetInterval2D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetLine(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetLine(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetPath(String, String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetPath(String, Int32, String) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetPlane(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetPlane(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetPoint2D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetPoint2D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetPoint3D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetPoint3D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetPoint4D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetPoint4D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetSingle(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetSingle(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetString(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetString(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetVersion(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetVersion(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
 | InstantiateRoot | Construct a new instance of GH_Chunk which acts as a Root node. If you must create a chunk from scratch, use this static method to create one.
Public method | ItemExists(String) | Gets the occupancy for a specific item name. Only items without index qualifiers are considered.
Public method | ItemExists(String, Int32) | Checks whether an item with the specified name and index exists. Only items with index qualifiers are considered. Name comparisons are not case-sensitive.
Public method | Read(BinaryReader) | Read this chunk and all child chunks from a binary stream.
Public method | Read(XmlNode) | Read this chunk and all child chunks from an Xml node.
Public method | RemoveChunk(String) | Remove the first chunk with a matching name. Only chunks without index qualifiers are considered. Name comparisons are not case-sensitive.
Public method | RemoveChunk(GH_IChunk) | Remove the specified chunk from the litter.
Public method | RemoveChunk(String, Int32) | Remove the first chunk with a matching name and index. Only chunks with index qualifiers are considered. Name comparisons are not case-sensitive.
Public method | RemoveItem(String) | Remove an unindexed item from this chunk.
Public method | RemoveItem(String, Int32) | Remove an indexed item from this chunk.
Public method | SetBoolean(String, Boolean) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetBoolean(String, Int32, Boolean) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetBoundingBox(String, GH_BoundingBox) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetBoundingBox(String, Int32, GH_BoundingBox) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetByte(String, Byte) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetByte(String, Int32, Byte) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetByteArray(String, array<Byte>[]()[][]) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetByteArray(String, Int32, array<Byte>[]()[][]) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDate(String, DateTime) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDate(String, Int32, DateTime) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDecimal(String, Decimal) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDecimal(String, Int32, Decimal) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDouble(String, Double) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDouble(String, Int32, Double) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDoubleArray(String, array<Double>[]()[][]) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDoubleArray(String, Int32, array<Double>[]()[][]) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDrawingBitmap(String, Bitmap) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingBitmap(String, Int32, Bitmap) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingColor(String, Color) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingColor(String, Int32, Color) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDrawingPoint(String, Point) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingPoint(String, Int32, Point) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDrawingPointF(String, PointF) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingPointF(String, Int32, PointF) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDrawingRectangle(String, Rectangle) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingRectangle(String, Int32, Rectangle) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDrawingRectangleF(String, RectangleF) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingRectangleF(String, Int32, RectangleF) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDrawingSize(String, Size) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingSize(String, Int32, Size) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDrawingSizeF(String, SizeF) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingSizeF(String, Int32, SizeF) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetGuid(String, Guid) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetGuid(String, Int32, Guid) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetInt32(String, Int32) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetInt32(String, Int32, Int32) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetInt64(String, Int64) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetInt64(String, Int32, Int64) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetInterval1D(String, GH_Interval1D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetInterval1D(String, Int32, GH_Interval1D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetInterval2D(String, GH_Interval2D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetInterval2D(String, Int32, GH_Interval2D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetLine(String, GH_Line) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetLine(String, Int32, GH_Line) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetPath(String, String, String) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetPath(String, Int32, String, String) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetPlane(String, GH_Plane) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetPlane(String, Int32, GH_Plane) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetPoint2D(String, GH_Point2D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetPoint2D(String, Int32, GH_Point2D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetPoint3D(String, GH_Point3D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetPoint3D(String, Int32, GH_Point3D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetPoint4D(String, GH_Point4D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetPoint4D(String, Int32, GH_Point4D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetSingle(String, Single) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetSingle(String, Int32, Single) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetString(String, String) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetString(String, Int32, String) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetVersion(String, GH_Version) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetVersion(String, Int32, GH_Version) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetVersion(String, Int32, Int32, Int32) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetVersion(String, Int32, Int32, Int32, Int32) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | TryGetBoolean(String, Boolean%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetBoolean(String, Int32, Boolean%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetBoundingBox(String, GH_BoundingBox%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetBoundingBox(String, Int32, GH_BoundingBox%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetByte(String, Byte%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetByte(String, Int32, Byte%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetDate(String, DateTime%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDate(String, Int32, DateTime%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetDecimal(String, Decimal%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDecimal(String, Int32, Decimal%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetDouble(String, Double%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDouble(String, Int32, Double%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetDrawingColor(String, Color%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingColor(String, Int32, Color%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetDrawingPoint(String, Point%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingPoint(String, Int32, Point%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetDrawingPointF(String, PointF%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingPointF(String, Int32, PointF%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetDrawingRectangle(String, Rectangle%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingRectangle(String, Int32, Rectangle%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetDrawingRectangleF(String, RectangleF%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingRectangleF(String, Int32, RectangleF%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetDrawingSize(String, Size%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingSize(String, Int32, Size%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetDrawingSizeF(String, SizeF%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingSizeF(String, Int32, SizeF%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetGuid(String, Guid%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetGuid(String, Int32, Guid%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetInt32(String, Int32%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetInt32(String, Int32, Int32%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetInt64(String, Int64%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetInt64(String, Int32, Int64%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetInterval1D(String, GH_Interval1D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetInterval1D(String, Int32, GH_Interval1D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetInterval2D(String, GH_Interval2D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetInterval2D(String, Int32, GH_Interval2D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetLine(String, GH_Line%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetLine(String, Int32, GH_Line%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetPlane(String, GH_Plane%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetPlane(String, Int32, GH_Plane%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetPoint2D(String, GH_Point2D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetPoint2D(String, Int32, GH_Point2D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetPoint3D(String, GH_Point3D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetPoint3D(String, Int32, GH_Point3D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetPoint4D(String, GH_Point4D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetPoint4D(String, Int32, GH_Point4D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetSingle(String, Single%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetSingle(String, Int32, Single%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetString(String, String%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetString(String, Int32, String%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetVersion(String, GH_Version%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetVersion(String, Int32, GH_Version%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | Write(BinaryWriter) | Write this chunk and all child chunks to a binary stream.
Public method | Write(XmlWriter) | Serialize this chunk into an Xml stream.

See Also

GH_Chunk Class
GH_IO.Serialization Namespace


AddComment Method

[image]

Grasshopper SDK
GH_Chunk..::..AddComment Method
GH_Chunk Class See Also Send Feedback
Adds a text comment to this chunk. Comments are serialized only if the output flavour is a human readable format. Comments are never deserialized, they are purely for the benefit of the humans reading the file data.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void AddComment(
    string comment_text
)
Visual Basic
Public Sub AddComment ( _
    comment_text As String _
)

Parameters

comment_text
Type: System..::..String
The content of the comment, text might be altered if it contains invalid characters for a chosen format flavour.

Implements

GH_IWriter..::..AddComment(String)

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the content text is either null or empty.

See Also

GH_Chunk Class
GH_IO.Serialization Namespace


AddMessage Method

[image]

Grasshopper SDK
GH_Chunk..::..AddMessage Method
GH_Chunk Class See Also Send Feedback
Log a new message with the top-level archive. Messages are collected during read/write operations, and can be displayed to the user upon completion using GH_Archive.ShowMessageLog().

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void AddMessage(
    string m,
    GH_Message_Type t
)
Visual Basic
Public Sub AddMessage ( _
    m As String, _
    t As GH_Message_Type _
)

Parameters

m
Type: System..::..String
Message text.
t
Type: GH_IO.Serialization..::..GH_Message_Type
Message type.

Implements

GH_IChunk..::..AddMessage(String, GH_Message_Type)

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if message text is null or empty.

See Also

GH_Chunk Class
GH_IO.Serialization Namespace


ChunkExists Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..ChunkExists Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ChunkExists(String) | Checks whether a chunk with the specified name exists in the litter. Only chunks without index qualifiers are considered. Name comparisons are not case-sensitive.
Public method | ChunkExists(String, Int32) | Checks whether a chunk with the specified name and index exists in the litter. Only chunks with index qualifiers are considered. Name comparisons are not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


ChunkExists Method (String)

[image]

Grasshopper SDK
GH_Chunk..::..ChunkExists Method (String)
GH_Chunk Class See Also Send Feedback
Checks whether a chunk with the specified name exists in the litter. Only chunks without index qualifiers are considered. Name comparisons are not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool ChunkExists(
    string name
)
Visual Basic
Public Function ChunkExists ( _
    name As String _
) As Boolean

Parameters

name
Type: System..::..String
Name of chunk to test for.

Return Value

True if a chunk with the specified name exists, otherwise false.

Implements

GH_IReader..::..ChunkExists(String)

See Also

GH_Chunk Class
ChunkExists Overload
GH_IO.Serialization Namespace


ChunkExists Method (String, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..ChunkExists Method (String, Int32)
GH_Chunk Class See Also Send Feedback
Checks whether a chunk with the specified name and index exists in the litter. Only chunks with index qualifiers are considered. Name comparisons are not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool ChunkExists(
    string name,
    int index
)
Visual Basic
Public Function ChunkExists ( _
    name As String, _
    index As Integer _
) As Boolean

Parameters

name
Type: System..::..String
Name of chunk to test for.
index
Type: System..::..Int32
Index of chunk to test for. If less than zero, ChunkExists(string name) is called instead.

Return Value

True if a chunk with the specified name and index exists, otherwise false.

Implements

GH_IReader..::..ChunkExists(String, Int32)

See Also

GH_Chunk Class
ChunkExists Overload
GH_IO.Serialization Namespace


CreateChunk Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..CreateChunk Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateChunk(String) | Create a new child chunk with the specified name and without an index qualifier. If another chunk already exists with similar properties, an exception will be thrown.
Public method | CreateChunk(String, Int32) | Create a new child chunk with the specified name and index qualifier. If another chunk already exists with similar properties, an exception will be thrown.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


CreateChunk Method (String)

[image]

Grasshopper SDK
GH_Chunk..::..CreateChunk Method (String)
GH_Chunk Class See Also Send Feedback
Create a new child chunk with the specified name and without an index qualifier. If another chunk already exists with similar properties, an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_IWriter CreateChunk(
    string chunk_name
)
Visual Basic
Public Function CreateChunk ( _
    chunk_name As String _
) As GH_IWriter

Parameters

chunk_name
Type: System..::..String
Name of new child.

Return Value

The newly created child chunk.

Implements

GH_IWriter..::..CreateChunk(String)

Exceptions

Exception | Condition
System..::..ArgumentException | Thrown if the name+index coordinte is already occupied by another chunk.

See Also

GH_Chunk Class
CreateChunk Overload
GH_IO.Serialization Namespace


CreateChunk Method (String, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..CreateChunk Method (String, Int32)
GH_Chunk Class See Also Send Feedback
Create a new child chunk with the specified name and index qualifier. If another chunk already exists with similar properties, an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_IWriter CreateChunk(
    string chunk_name,
    int chunk_index
)
Visual Basic
Public Function CreateChunk ( _
    chunk_name As String, _
    chunk_index As Integer _
) As GH_IWriter

Parameters

chunk_name
Type: System..::..String
Name of new child.
chunk_index
Type: System..::..Int32
Index of new child.

Return Value

The newly created child chunk.

Implements

GH_IWriter..::..CreateChunk(String, Int32)

Exceptions

Exception | Condition
System..::..ArgumentException | Thrown if the name+index coordinte is already occupied by another chunk.

See Also

GH_Chunk Class
CreateChunk Overload
GH_IO.Serialization Namespace


FindChunk Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..FindChunk Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindChunk(String) | Finds the first chunk in the litter that matches the given name. Only chunks without index qualifiers are considered.
Public method | FindChunk(String, Int32) | Finds the first chunk in the list that matches the given name and index. Only chunks with index qualifiers are considered.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


FindChunk Method (String)

[image]

Grasshopper SDK
GH_Chunk..::..FindChunk Method (String)
GH_Chunk Class See Also Send Feedback
Finds the first chunk in the litter that matches the given name. Only chunks without index qualifiers are considered.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_IReader FindChunk(
    string name
)
Visual Basic
Public Function FindChunk ( _
    name As String _
) As GH_IReader

Parameters

name
Type: System..::..String
Name of chunk to search for.

Return Value

The child chunk that matches the given name, or null of no matching chunk could be found.

Implements

GH_IReader..::..FindChunk(String)

See Also

GH_Chunk Class
FindChunk Overload
GH_IO.Serialization Namespace


FindChunk Method (String, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..FindChunk Method (String, Int32)
GH_Chunk Class See Also Send Feedback
Finds the first chunk in the list that matches the given name and index. Only chunks with index qualifiers are considered.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_IReader FindChunk(
    string name,
    int index
)
Visual Basic
Public Function FindChunk ( _
    name As String, _
    index As Integer _
) As GH_IReader

Parameters

name
Type: System..::..String
Name of chunk to search for.
index
Type: System..::..Int32
Index of chunk to search for. If less than zero, FindChunk(string chunk_name) is called instead.

Return Value

The child chunk that matches the given name and index, or null of no matching chunk could be found.

Implements

GH_IReader..::..FindChunk(String, Int32)

See Also

GH_Chunk Class
FindChunk Overload
GH_IO.Serialization Namespace


FindItem Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..FindItem Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindItem(String) | Finds the first item that matches the given name. Only items without index qualifiers are considered. Name comparisons are not case-sensitive.
Public method | FindItem(String, Int32) | Finds the first item that matches the given name and index. Only items with index qualifiers are considered. Name comparisons are not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


FindItem Method (String)

[image]

Grasshopper SDK
GH_Chunk..::..FindItem Method (String)
GH_Chunk Class See Also Send Feedback
Finds the first item that matches the given name. Only items without index qualifiers are considered. Name comparisons are not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item FindItem(
    string name
)
Visual Basic
Public Function FindItem ( _
    name As String _
) As GH_Item

Parameters

name
Type: System..::..String
Name of item to search for.

Return Value

The item that matches the given name, or null of no matching item could be found.

Implements

GH_IReader..::..FindItem(String)

See Also

GH_Chunk Class
FindItem Overload
GH_IO.Serialization Namespace


FindItem Method (String, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..FindItem Method (String, Int32)
GH_Chunk Class See Also Send Feedback
Finds the first item that matches the given name and index. Only items with index qualifiers are considered. Name comparisons are not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item FindItem(
    string name,
    int index
)
Visual Basic
Public Function FindItem ( _
    name As String, _
    index As Integer _
) As GH_Item

Parameters

name
Type: System..::..String
Name of item to search for.
index
Type: System..::..Int32
Index of item to search for. If less than zero, then FindItem(string name) is called instead.

Return Value

The item that matches the given name and index, or null of no matching item could be found.

Implements

GH_IReader..::..FindItem(String, Int32)

See Also

GH_Chunk Class
FindItem Overload
GH_IO.Serialization Namespace


GetBoolean Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..GetBoolean Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetBoolean(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetBoolean(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


GetBoolean Method (String)

[image]

Grasshopper SDK
GH_Chunk..::..GetBoolean Method (String)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool GetBoolean(
    string item_name
)
Visual Basic
Public Function GetBoolean ( _
    item_name As String _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetBoolean(String)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_Chunk Class
GetBoolean Overload
GH_IO.Serialization Namespace


GetBoolean Method (String, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..GetBoolean Method (String, Int32)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool GetBoolean(
    string item_name,
    int item_index
)
Visual Basic
Public Function GetBoolean ( _
    item_name As String, _
    item_index As Integer _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetBoolean(String, Int32)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_Chunk Class
GetBoolean Overload
GH_IO.Serialization Namespace


GetBoundingBox Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..GetBoundingBox Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetBoundingBox(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetBoundingBox(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


GetBoundingBox Method (String)

[image]

Grasshopper SDK
GH_Chunk..::..GetBoundingBox Method (String)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_BoundingBox GetBoundingBox(
    string item_name
)
Visual Basic
Public Function GetBoundingBox ( _
    item_name As String _
) As GH_BoundingBox

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetBoundingBox(String)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_Chunk Class
GetBoundingBox Overload
GH_IO.Serialization Namespace


GetBoundingBox Method (String, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..GetBoundingBox Method (String, Int32)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_BoundingBox GetBoundingBox(
    string item_name,
    int item_index
)
Visual Basic
Public Function GetBoundingBox ( _
    item_name As String, _
    item_index As Integer _
) As GH_BoundingBox

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetBoundingBox(String, Int32)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_Chunk Class
GetBoundingBox Overload
GH_IO.Serialization Namespace


GetByte Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..GetByte Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetByte(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetByte(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


GetByte Method (String)

[image]

Grasshopper SDK
GH_Chunk..::..GetByte Method (String)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public byte GetByte(
    string item_name
)
Visual Basic
Public Function GetByte ( _
    item_name As String _
) As Byte

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetByte(String)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_Chunk Class
GetByte Overload
GH_IO.Serialization Namespace


GetByte Method (String, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..GetByte Method (String, Int32)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public byte GetByte(
    string item_name,
    int item_index
)
Visual Basic
Public Function GetByte ( _
    item_name As String, _
    item_index As Integer _
) As Byte

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetByte(String, Int32)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_Chunk Class
GetByte Overload
GH_IO.Serialization Namespace


GetByteArray Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..GetByteArray Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetByteArray(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetByteArray(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


GetByteArray Method (String)

[image]

Grasshopper SDK
GH_Chunk..::..GetByteArray Method (String)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public byte[] GetByteArray(
    string item_name
)
Visual Basic
Public Function GetByteArray ( _
    item_name As String _
) As Byte()

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetByteArray(String)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_Chunk Class
GetByteArray Overload
GH_IO.Serialization Namespace


GetByteArray Method (String, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..GetByteArray Method (String, Int32)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public byte[] GetByteArray(
    string item_name,
    int item_index
)
Visual Basic
Public Function GetByteArray ( _
    item_name As String, _
    item_index As Integer _
) As Byte()

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetByteArray(String, Int32)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_Chunk Class
GetByteArray Overload
GH_IO.Serialization Namespace


GetDate Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..GetDate Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDate(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDate(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


GetDate Method (String)

[image]

Grasshopper SDK
GH_Chunk..::..GetDate Method (String)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public DateTime GetDate(
    string item_name
)
Visual Basic
Public Function GetDate ( _
    item_name As String _
) As DateTime

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetDate(String)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_Chunk Class
GetDate Overload
GH_IO.Serialization Namespace


GetDate Method (String, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..GetDate Method (String, Int32)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public DateTime GetDate(
    string item_name,
    int item_index
)
Visual Basic
Public Function GetDate ( _
    item_name As String, _
    item_index As Integer _
) As DateTime

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetDate(String, Int32)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_Chunk Class
GetDate Overload
GH_IO.Serialization Namespace


GetDecimal Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..GetDecimal Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDecimal(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDecimal(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


GetDecimal Method (String)

[image]

Grasshopper SDK
GH_Chunk..::..GetDecimal Method (String)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public decimal GetDecimal(
    string item_name
)
Visual Basic
Public Function GetDecimal ( _
    item_name As String _
) As Decimal

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetDecimal(String)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_Chunk Class
GetDecimal Overload
GH_IO.Serialization Namespace


GetDecimal Method (String, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..GetDecimal Method (String, Int32)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public decimal GetDecimal(
    string item_name,
    int item_index
)
Visual Basic
Public Function GetDecimal ( _
    item_name As String, _
    item_index As Integer _
) As Decimal

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetDecimal(String, Int32)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_Chunk Class
GetDecimal Overload
GH_IO.Serialization Namespace


GetDouble Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..GetDouble Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDouble(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDouble(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


GetDouble Method (String)

[image]

Grasshopper SDK
GH_Chunk..::..GetDouble Method (String)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public double GetDouble(
    string item_name
)
Visual Basic
Public Function GetDouble ( _
    item_name As String _
) As Double

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetDouble(String)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_Chunk Class
GetDouble Overload
GH_IO.Serialization Namespace


GetDouble Method (String, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..GetDouble Method (String, Int32)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public double GetDouble(
    string item_name,
    int item_index
)
Visual Basic
Public Function GetDouble ( _
    item_name As String, _
    item_index As Integer _
) As Double

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetDouble(String, Int32)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_Chunk Class
GetDouble Overload
GH_IO.Serialization Namespace


GetDoubleArray Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..GetDoubleArray Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDoubleArray(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDoubleArray(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


GetDoubleArray Method (String)

[image]

Grasshopper SDK
GH_Chunk..::..GetDoubleArray Method (String)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public double[] GetDoubleArray(
    string item_name
)
Visual Basic
Public Function GetDoubleArray ( _
    item_name As String _
) As Double()

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetDoubleArray(String)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_Chunk Class
GetDoubleArray Overload
GH_IO.Serialization Namespace


GetDoubleArray Method (String, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..GetDoubleArray Method (String, Int32)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public double[] GetDoubleArray(
    string item_name,
    int item_index
)
Visual Basic
Public Function GetDoubleArray ( _
    item_name As String, _
    item_index As Integer _
) As Double()

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetDoubleArray(String, Int32)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_Chunk Class
GetDoubleArray Overload
GH_IO.Serialization Namespace


GetDrawingBitmap Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..GetDrawingBitmap Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDrawingBitmap(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingBitmap(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


GetDrawingBitmap Method (String)

[image]

Grasshopper SDK
GH_Chunk..::..GetDrawingBitmap Method (String)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public Bitmap GetDrawingBitmap(
    string item_name
)
Visual Basic
Public Function GetDrawingBitmap ( _
    item_name As String _
) As Bitmap

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetDrawingBitmap(String)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_Chunk Class
GetDrawingBitmap Overload
GH_IO.Serialization Namespace


GetDrawingBitmap Method (String, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..GetDrawingBitmap Method (String, Int32)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public Bitmap GetDrawingBitmap(
    string item_name,
    int item_index
)
Visual Basic
Public Function GetDrawingBitmap ( _
    item_name As String, _
    item_index As Integer _
) As Bitmap

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetDrawingBitmap(String, Int32)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_Chunk Class
GetDrawingBitmap Overload
GH_IO.Serialization Namespace


GetDrawingColor Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..GetDrawingColor Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDrawingColor(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingColor(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


GetDrawingColor Method (String)

[image]

Grasshopper SDK
GH_Chunk..::..GetDrawingColor Method (String)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public Color GetDrawingColor(
    string item_name
)
Visual Basic
Public Function GetDrawingColor ( _
    item_name As String _
) As Color

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetDrawingColor(String)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_Chunk Class
GetDrawingColor Overload
GH_IO.Serialization Namespace


GetDrawingColor Method (String, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..GetDrawingColor Method (String, Int32)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public Color GetDrawingColor(
    string item_name,
    int item_index
)
Visual Basic
Public Function GetDrawingColor ( _
    item_name As String, _
    item_index As Integer _
) As Color

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetDrawingColor(String, Int32)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_Chunk Class
GetDrawingColor Overload
GH_IO.Serialization Namespace


GetDrawingPoint Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..GetDrawingPoint Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDrawingPoint(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingPoint(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


GetDrawingPoint Method (String)

[image]

Grasshopper SDK
GH_Chunk..::..GetDrawingPoint Method (String)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public Point GetDrawingPoint(
    string item_name
)
Visual Basic
Public Function GetDrawingPoint ( _
    item_name As String _
) As Point

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetDrawingPoint(String)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_Chunk Class
GetDrawingPoint Overload
GH_IO.Serialization Namespace


GetDrawingPoint Method (String, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..GetDrawingPoint Method (String, Int32)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public Point GetDrawingPoint(
    string item_name,
    int item_index
)
Visual Basic
Public Function GetDrawingPoint ( _
    item_name As String, _
    item_index As Integer _
) As Point

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetDrawingPoint(String, Int32)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_Chunk Class
GetDrawingPoint Overload
GH_IO.Serialization Namespace


GetDrawingPointF Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..GetDrawingPointF Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDrawingPointF(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingPointF(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


GetDrawingPointF Method (String)

[image]

Grasshopper SDK
GH_Chunk..::..GetDrawingPointF Method (String)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public PointF GetDrawingPointF(
    string item_name
)
Visual Basic
Public Function GetDrawingPointF ( _
    item_name As String _
) As PointF

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetDrawingPointF(String)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_Chunk Class
GetDrawingPointF Overload
GH_IO.Serialization Namespace


GetDrawingPointF Method (String, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..GetDrawingPointF Method (String, Int32)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public PointF GetDrawingPointF(
    string item_name,
    int item_index
)
Visual Basic
Public Function GetDrawingPointF ( _
    item_name As String, _
    item_index As Integer _
) As PointF

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetDrawingPointF(String, Int32)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_Chunk Class
GetDrawingPointF Overload
GH_IO.Serialization Namespace


GetDrawingRectangle Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..GetDrawingRectangle Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDrawingRectangle(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingRectangle(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


GetDrawingRectangle Method (String)

[image]

Grasshopper SDK
GH_Chunk..::..GetDrawingRectangle Method (String)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public Rectangle GetDrawingRectangle(
    string item_name
)
Visual Basic
Public Function GetDrawingRectangle ( _
    item_name As String _
) As Rectangle

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetDrawingRectangle(String)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_Chunk Class
GetDrawingRectangle Overload
GH_IO.Serialization Namespace


GetDrawingRectangle Method (String, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..GetDrawingRectangle Method (String, Int32)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public Rectangle GetDrawingRectangle(
    string item_name,
    int item_index
)
Visual Basic
Public Function GetDrawingRectangle ( _
    item_name As String, _
    item_index As Integer _
) As Rectangle

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetDrawingRectangle(String, Int32)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_Chunk Class
GetDrawingRectangle Overload
GH_IO.Serialization Namespace


GetDrawingRectangleF Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..GetDrawingRectangleF Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDrawingRectangleF(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingRectangleF(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


GetDrawingRectangleF Method (String)

[image]

Grasshopper SDK
GH_Chunk..::..GetDrawingRectangleF Method (String)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public RectangleF GetDrawingRectangleF(
    string item_name
)
Visual Basic
Public Function GetDrawingRectangleF ( _
    item_name As String _
) As RectangleF

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetDrawingRectangleF(String)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_Chunk Class
GetDrawingRectangleF Overload
GH_IO.Serialization Namespace


GetDrawingRectangleF Method (String, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..GetDrawingRectangleF Method (String, Int32)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public RectangleF GetDrawingRectangleF(
    string item_name,
    int item_index
)
Visual Basic
Public Function GetDrawingRectangleF ( _
    item_name As String, _
    item_index As Integer _
) As RectangleF

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetDrawingRectangleF(String, Int32)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_Chunk Class
GetDrawingRectangleF Overload
GH_IO.Serialization Namespace


GetDrawingSize Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..GetDrawingSize Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDrawingSize(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingSize(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


GetDrawingSize Method (String)

[image]

Grasshopper SDK
GH_Chunk..::..GetDrawingSize Method (String)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public Size GetDrawingSize(
    string item_name
)
Visual Basic
Public Function GetDrawingSize ( _
    item_name As String _
) As Size

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetDrawingSize(String)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_Chunk Class
GetDrawingSize Overload
GH_IO.Serialization Namespace


GetDrawingSize Method (String, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..GetDrawingSize Method (String, Int32)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public Size GetDrawingSize(
    string item_name,
    int item_index
)
Visual Basic
Public Function GetDrawingSize ( _
    item_name As String, _
    item_index As Integer _
) As Size

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetDrawingSize(String, Int32)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_Chunk Class
GetDrawingSize Overload
GH_IO.Serialization Namespace


GetDrawingSizeF Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..GetDrawingSizeF Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDrawingSizeF(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingSizeF(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


GetDrawingSizeF Method (String)

[image]

Grasshopper SDK
GH_Chunk..::..GetDrawingSizeF Method (String)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public SizeF GetDrawingSizeF(
    string item_name
)
Visual Basic
Public Function GetDrawingSizeF ( _
    item_name As String _
) As SizeF

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetDrawingSizeF(String)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_Chunk Class
GetDrawingSizeF Overload
GH_IO.Serialization Namespace


GetDrawingSizeF Method (String, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..GetDrawingSizeF Method (String, Int32)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public SizeF GetDrawingSizeF(
    string item_name,
    int item_index
)
Visual Basic
Public Function GetDrawingSizeF ( _
    item_name As String, _
    item_index As Integer _
) As SizeF

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetDrawingSizeF(String, Int32)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_Chunk Class
GetDrawingSizeF Overload
GH_IO.Serialization Namespace


GetGuid Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..GetGuid Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetGuid(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetGuid(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


GetGuid Method (String)

[image]

Grasshopper SDK
GH_Chunk..::..GetGuid Method (String)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public Guid GetGuid(
    string item_name
)
Visual Basic
Public Function GetGuid ( _
    item_name As String _
) As Guid

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetGuid(String)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_Chunk Class
GetGuid Overload
GH_IO.Serialization Namespace


GetGuid Method (String, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..GetGuid Method (String, Int32)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public Guid GetGuid(
    string item_name,
    int item_index
)
Visual Basic
Public Function GetGuid ( _
    item_name As String, _
    item_index As Integer _
) As Guid

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetGuid(String, Int32)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_Chunk Class
GetGuid Overload
GH_IO.Serialization Namespace


GetInt32 Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..GetInt32 Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetInt32(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetInt32(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


GetInt32 Method (String)

[image]

Grasshopper SDK
GH_Chunk..::..GetInt32 Method (String)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public int GetInt32(
    string item_name
)
Visual Basic
Public Function GetInt32 ( _
    item_name As String _
) As Integer

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetInt32(String)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_Chunk Class
GetInt32 Overload
GH_IO.Serialization Namespace


GetInt32 Method (String, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..GetInt32 Method (String, Int32)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public int GetInt32(
    string item_name,
    int item_index
)
Visual Basic
Public Function GetInt32 ( _
    item_name As String, _
    item_index As Integer _
) As Integer

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetInt32(String, Int32)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_Chunk Class
GetInt32 Overload
GH_IO.Serialization Namespace


GetInt64 Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..GetInt64 Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetInt64(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetInt64(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


GetInt64 Method (String)

[image]

Grasshopper SDK
GH_Chunk..::..GetInt64 Method (String)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public long GetInt64(
    string item_name
)
Visual Basic
Public Function GetInt64 ( _
    item_name As String _
) As Long

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetInt64(String)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_Chunk Class
GetInt64 Overload
GH_IO.Serialization Namespace


GetInt64 Method (String, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..GetInt64 Method (String, Int32)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public long GetInt64(
    string item_name,
    int item_index
)
Visual Basic
Public Function GetInt64 ( _
    item_name As String, _
    item_index As Integer _
) As Long

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetInt64(String, Int32)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_Chunk Class
GetInt64 Overload
GH_IO.Serialization Namespace


GetInterval1D Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..GetInterval1D Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetInterval1D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetInterval1D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


GetInterval1D Method (String)

[image]

Grasshopper SDK
GH_Chunk..::..GetInterval1D Method (String)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Interval1D GetInterval1D(
    string item_name
)
Visual Basic
Public Function GetInterval1D ( _
    item_name As String _
) As GH_Interval1D

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetInterval1D(String)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_Chunk Class
GetInterval1D Overload
GH_IO.Serialization Namespace


GetInterval1D Method (String, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..GetInterval1D Method (String, Int32)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Interval1D GetInterval1D(
    string item_name,
    int item_index
)
Visual Basic
Public Function GetInterval1D ( _
    item_name As String, _
    item_index As Integer _
) As GH_Interval1D

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetInterval1D(String, Int32)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_Chunk Class
GetInterval1D Overload
GH_IO.Serialization Namespace


GetInterval2D Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..GetInterval2D Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetInterval2D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetInterval2D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


GetInterval2D Method (String)

[image]

Grasshopper SDK
GH_Chunk..::..GetInterval2D Method (String)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Interval2D GetInterval2D(
    string item_name
)
Visual Basic
Public Function GetInterval2D ( _
    item_name As String _
) As GH_Interval2D

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetInterval2D(String)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_Chunk Class
GetInterval2D Overload
GH_IO.Serialization Namespace


GetInterval2D Method (String, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..GetInterval2D Method (String, Int32)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Interval2D GetInterval2D(
    string item_name,
    int item_index
)
Visual Basic
Public Function GetInterval2D ( _
    item_name As String, _
    item_index As Integer _
) As GH_Interval2D

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetInterval2D(String, Int32)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_Chunk Class
GetInterval2D Overload
GH_IO.Serialization Namespace


GetLine Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..GetLine Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetLine(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetLine(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


GetLine Method (String)

[image]

Grasshopper SDK
GH_Chunk..::..GetLine Method (String)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Line GetLine(
    string item_name
)
Visual Basic
Public Function GetLine ( _
    item_name As String _
) As GH_Line

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetLine(String)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_Chunk Class
GetLine Overload
GH_IO.Serialization Namespace


GetLine Method (String, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..GetLine Method (String, Int32)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Line GetLine(
    string item_name,
    int item_index
)
Visual Basic
Public Function GetLine ( _
    item_name As String, _
    item_index As Integer _
) As GH_Line

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetLine(String, Int32)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_Chunk Class
GetLine Overload
GH_IO.Serialization Namespace


GetPath Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..GetPath Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPath(String, String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetPath(String, Int32, String) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


GetPath Method (String, String)

[image]

Grasshopper SDK
GH_Chunk..::..GetPath Method (String, String)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public string[] GetPath(
    string item_name,
    string basePath
)
Visual Basic
Public Function GetPath ( _
    item_name As String, _
    basePath As String _
) As String()

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
basePath
Type: System..::..String
Base path for relative path resolution.

Return Value

An array of path strings. If the resolved relative path is different from the stored absolute path, two strings will be returned.

Implements

GH_IReader..::..GetPath(String, String)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_Chunk Class
GetPath Overload
GH_IO.Serialization Namespace


GetPath Method (String, Int32, String)

[image]

Grasshopper SDK
GH_Chunk..::..GetPath Method (String, Int32, String)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public string[] GetPath(
    string item_name,
    int item_index,
    string basePath
)
Visual Basic
Public Function GetPath ( _
    item_name As String, _
    item_index As Integer, _
    basePath As String _
) As String()

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
basePath
Type: System..::..String
Base path for relative path resolution.

Return Value

An array of path strings. If the resolved relative path is different from the stored absolute path, two strings will be returned.

Implements

GH_IReader..::..GetPath(String, Int32, String)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_Chunk Class
GetPath Overload
GH_IO.Serialization Namespace


GetPlane Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..GetPlane Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPlane(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetPlane(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


GetPlane Method (String)

[image]

Grasshopper SDK
GH_Chunk..::..GetPlane Method (String)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Plane GetPlane(
    string item_name
)
Visual Basic
Public Function GetPlane ( _
    item_name As String _
) As GH_Plane

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetPlane(String)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_Chunk Class
GetPlane Overload
GH_IO.Serialization Namespace


GetPlane Method (String, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..GetPlane Method (String, Int32)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Plane GetPlane(
    string item_name,
    int item_index
)
Visual Basic
Public Function GetPlane ( _
    item_name As String, _
    item_index As Integer _
) As GH_Plane

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetPlane(String, Int32)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_Chunk Class
GetPlane Overload
GH_IO.Serialization Namespace


GetPoint2D Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..GetPoint2D Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPoint2D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetPoint2D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


GetPoint2D Method (String)

[image]

Grasshopper SDK
GH_Chunk..::..GetPoint2D Method (String)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Point2D GetPoint2D(
    string item_name
)
Visual Basic
Public Function GetPoint2D ( _
    item_name As String _
) As GH_Point2D

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetPoint2D(String)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_Chunk Class
GetPoint2D Overload
GH_IO.Serialization Namespace


GetPoint2D Method (String, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..GetPoint2D Method (String, Int32)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Point2D GetPoint2D(
    string item_name,
    int item_index
)
Visual Basic
Public Function GetPoint2D ( _
    item_name As String, _
    item_index As Integer _
) As GH_Point2D

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetPoint2D(String, Int32)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_Chunk Class
GetPoint2D Overload
GH_IO.Serialization Namespace


GetPoint3D Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..GetPoint3D Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPoint3D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetPoint3D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


GetPoint3D Method (String)

[image]

Grasshopper SDK
GH_Chunk..::..GetPoint3D Method (String)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Point3D GetPoint3D(
    string item_name
)
Visual Basic
Public Function GetPoint3D ( _
    item_name As String _
) As GH_Point3D

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetPoint3D(String)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_Chunk Class
GetPoint3D Overload
GH_IO.Serialization Namespace


GetPoint3D Method (String, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..GetPoint3D Method (String, Int32)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Point3D GetPoint3D(
    string item_name,
    int item_index
)
Visual Basic
Public Function GetPoint3D ( _
    item_name As String, _
    item_index As Integer _
) As GH_Point3D

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetPoint3D(String, Int32)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_Chunk Class
GetPoint3D Overload
GH_IO.Serialization Namespace


GetPoint4D Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..GetPoint4D Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPoint4D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetPoint4D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


GetPoint4D Method (String)

[image]

Grasshopper SDK
GH_Chunk..::..GetPoint4D Method (String)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Point4D GetPoint4D(
    string item_name
)
Visual Basic
Public Function GetPoint4D ( _
    item_name As String _
) As GH_Point4D

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetPoint4D(String)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_Chunk Class
GetPoint4D Overload
GH_IO.Serialization Namespace


GetPoint4D Method (String, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..GetPoint4D Method (String, Int32)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Point4D GetPoint4D(
    string item_name,
    int item_index
)
Visual Basic
Public Function GetPoint4D ( _
    item_name As String, _
    item_index As Integer _
) As GH_Point4D

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetPoint4D(String, Int32)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_Chunk Class
GetPoint4D Overload
GH_IO.Serialization Namespace


GetSingle Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..GetSingle Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetSingle(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetSingle(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


GetSingle Method (String)

[image]

Grasshopper SDK
GH_Chunk..::..GetSingle Method (String)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public float GetSingle(
    string item_name
)
Visual Basic
Public Function GetSingle ( _
    item_name As String _
) As Single

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetSingle(String)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_Chunk Class
GetSingle Overload
GH_IO.Serialization Namespace


GetSingle Method (String, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..GetSingle Method (String, Int32)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public float GetSingle(
    string item_name,
    int item_index
)
Visual Basic
Public Function GetSingle ( _
    item_name As String, _
    item_index As Integer _
) As Single

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetSingle(String, Int32)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_Chunk Class
GetSingle Overload
GH_IO.Serialization Namespace


GetString Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..GetString Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetString(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetString(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


GetString Method (String)

[image]

Grasshopper SDK
GH_Chunk..::..GetString Method (String)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public string GetString(
    string item_name
)
Visual Basic
Public Function GetString ( _
    item_name As String _
) As String

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetString(String)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_Chunk Class
GetString Overload
GH_IO.Serialization Namespace


GetString Method (String, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..GetString Method (String, Int32)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public string GetString(
    string item_name,
    int item_index
)
Visual Basic
Public Function GetString ( _
    item_name As String, _
    item_index As Integer _
) As String

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetString(String, Int32)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_Chunk Class
GetString Overload
GH_IO.Serialization Namespace


GetVersion Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..GetVersion Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetVersion(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetVersion(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


GetVersion Method (String)

[image]

Grasshopper SDK
GH_Chunk..::..GetVersion Method (String)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Version GetVersion(
    string item_name
)
Visual Basic
Public Function GetVersion ( _
    item_name As String _
) As GH_Version

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetVersion(String)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_Chunk Class
GetVersion Overload
GH_IO.Serialization Namespace


GetVersion Method (String, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..GetVersion Method (String, Int32)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Version GetVersion(
    string item_name,
    int item_index
)
Visual Basic
Public Function GetVersion ( _
    item_name As String, _
    item_index As Integer _
) As GH_Version

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Implements

GH_IReader..::..GetVersion(String, Int32)

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_Chunk Class
GetVersion Overload
GH_IO.Serialization Namespace


InstantiateRoot Method

[image]

Grasshopper SDK
GH_Chunk..::..InstantiateRoot Method
GH_Chunk Class See Also Send Feedback
Construct a new instance of GH_Chunk which acts as a Root node. If you must create a chunk from scratch, use this static method to create one.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public static GH_Chunk InstantiateRoot(
    GH_Archive owner
)
Visual Basic
Public Shared Function InstantiateRoot ( _
    owner As GH_Archive _
) As GH_Chunk

Parameters

owner
Type: GH_IO.Serialization..::..GH_Archive
The archive which owns this chunk.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown when the owner is a null reference.

See Also

GH_Chunk Class
GH_IO.Serialization Namespace


ItemExists Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..ItemExists Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ItemExists(String) | Gets the occupancy for a specific item name. Only items without index qualifiers are considered.
Public method | ItemExists(String, Int32) | Checks whether an item with the specified name and index exists. Only items with index qualifiers are considered. Name comparisons are not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


ItemExists Method (String)

[image]

Grasshopper SDK
GH_Chunk..::..ItemExists Method (String)
GH_Chunk Class See Also Send Feedback
Gets the occupancy for a specific item name. Only items without index qualifiers are considered.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool ItemExists(
    string name
)
Visual Basic
Public Function ItemExists ( _
    name As String _
) As Boolean

Parameters

name
Type: System..::..String
Name of item to check for.

Return Value

True if an item with a similar name already exists, false if not.

Implements

GH_IReader..::..ItemExists(String)

See Also

GH_Chunk Class
ItemExists Overload
GH_IO.Serialization Namespace


ItemExists Method (String, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..ItemExists Method (String, Int32)
GH_Chunk Class See Also Send Feedback
Checks whether an item with the specified name and index exists. Only items with index qualifiers are considered. Name comparisons are not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool ItemExists(
    string name,
    int index
)
Visual Basic
Public Function ItemExists ( _
    name As String, _
    index As Integer _
) As Boolean

Parameters

name
Type: System..::..String
Name of item to test for.
index
Type: System..::..Int32
Index of item to test for. If index is less than zero, then ItemExists(string name) is called instead.

Return Value

True if an item with the specified name and index exists, otherwise false.

Implements

GH_IReader..::..ItemExists(String, Int32)

See Also

GH_Chunk Class
ItemExists Overload
GH_IO.Serialization Namespace


Read Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..Read Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Read(BinaryReader) | Read this chunk and all child chunks from a binary stream.
Public method | Read(XmlNode) | Read this chunk and all child chunks from an Xml node.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


Read Method (BinaryReader)

[image]

Grasshopper SDK
GH_Chunk..::..Read Method (BinaryReader)
GH_Chunk Class See Also Send Feedback
Read this chunk and all child chunks from a binary stream.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void Read(
    BinaryReader reader
)
Visual Basic
Public Sub Read ( _
    reader As BinaryReader _
)

Parameters

reader
Type: System.IO..::..BinaryReader
The Binary reader to use, cannot be null.

Implements

GH_IBinarySupport..::..Read(BinaryReader)

See Also

GH_Chunk Class
Read Overload
GH_IO.Serialization Namespace


Read Method (XmlNode)

[image]

Grasshopper SDK
GH_Chunk..::..Read Method (XmlNode)
GH_Chunk Class See Also Send Feedback
Read this chunk and all child chunks from an Xml node.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void Read(
    XmlNode node
)
Visual Basic
Public Sub Read ( _
    node As XmlNode _
)

Parameters

node
Type: System.Xml..::..XmlNode
The Xml node to deserialize from, cannot be null.

Implements

GH_IXmlSupport..::..Read(XmlNode)

See Also

GH_Chunk Class
Read Overload
GH_IO.Serialization Namespace


RemoveChunk Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..RemoveChunk Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveChunk(String) | Remove the first chunk with a matching name. Only chunks without index qualifiers are considered. Name comparisons are not case-sensitive.
Public method | RemoveChunk(GH_IChunk) | Remove the specified chunk from the litter.
Public method | RemoveChunk(String, Int32) | Remove the first chunk with a matching name and index. Only chunks with index qualifiers are considered. Name comparisons are not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


RemoveChunk Method (String)

[image]

Grasshopper SDK
GH_Chunk..::..RemoveChunk Method (String)
GH_Chunk Class See Also Send Feedback
Remove the first chunk with a matching name. Only chunks without index qualifiers are considered. Name comparisons are not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool RemoveChunk(
    string chunk_name
)
Visual Basic
Public Function RemoveChunk ( _
    chunk_name As String _
) As Boolean

Parameters

chunk_name
Type: System..::..String
Name of chunk to remove.

Return Value

True is chunk was removed, false if no matching chunk could be found.

Implements

GH_IWriter..::..RemoveChunk(String)

See Also

GH_Chunk Class
RemoveChunk Overload
GH_IO.Serialization Namespace


RemoveChunk Method (GH_IChunk)

[image]

Grasshopper SDK
GH_Chunk..::..RemoveChunk Method (GH_IChunk)
GH_Chunk Class See Also Send Feedback
Remove the specified chunk from the litter.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool RemoveChunk(
    GH_IChunk chunk
)
Visual Basic
Public Function RemoveChunk ( _
    chunk As GH_IChunk _
) As Boolean

Parameters

chunk
Type: GH_IO.Serialization..::..GH_IChunk
Chunk to remove.

Return Value

True is chunk was removed, false if chunk is not part of this litter.

Implements

GH_IWriter..::..RemoveChunk(GH_IChunk)

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if chunk is a null reference.

See Also

GH_Chunk Class
RemoveChunk Overload
GH_IO.Serialization Namespace


RemoveChunk Method (String, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..RemoveChunk Method (String, Int32)
GH_Chunk Class See Also Send Feedback
Remove the first chunk with a matching name and index. Only chunks with index qualifiers are considered. Name comparisons are not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool RemoveChunk(
    string chunk_name,
    int chunk_index
)
Visual Basic
Public Function RemoveChunk ( _
    chunk_name As String, _
    chunk_index As Integer _
) As Boolean

Parameters

chunk_name
Type: System..::..String
Name of chunk to remove.
chunk_index
Type: System..::..Int32
Index of chunk to remove.

Return Value

True is chunk was removed, false if no matching chunk could be found.

Implements

GH_IWriter..::..RemoveChunk(String, Int32)

See Also

GH_Chunk Class
RemoveChunk Overload
GH_IO.Serialization Namespace


RemoveItem Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..RemoveItem Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveItem(String) | Remove an unindexed item from this chunk.
Public method | RemoveItem(String, Int32) | Remove an indexed item from this chunk.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


RemoveItem Method (String)

[image]

Grasshopper SDK
GH_Chunk..::..RemoveItem Method (String)
GH_Chunk Class See Also Send Feedback
Remove an unindexed item from this chunk.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool RemoveItem(
    string itemName
)
Visual Basic
Public Function RemoveItem ( _
    itemName As String _
) As Boolean

Parameters

itemName
Type: System..::..String
Name of item.

Return Value

True on success, false on failure.

Implements

GH_IWriter..::..RemoveItem(String)

See Also

GH_Chunk Class
RemoveItem Overload
GH_IO.Serialization Namespace


RemoveItem Method (String, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..RemoveItem Method (String, Int32)
GH_Chunk Class See Also Send Feedback
Remove an indexed item from this chunk.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool RemoveItem(
    string itemName,
    int itemIndex
)
Visual Basic
Public Function RemoveItem ( _
    itemName As String, _
    itemIndex As Integer _
) As Boolean

Parameters

itemName
Type: System..::..String
Name of item.
itemIndex
Type: System..::..Int32
Index of item.

Return Value

True on success, false on failure.

Implements

GH_IWriter..::..RemoveItem(String, Int32)

See Also

GH_Chunk Class
RemoveItem Overload
GH_IO.Serialization Namespace


SetBoolean Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..SetBoolean Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBoolean(String, Boolean) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetBoolean(String, Int32, Boolean) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


SetBoolean Method (String, Boolean)

[image]

Grasshopper SDK
GH_Chunk..::..SetBoolean Method (String, Boolean)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetBoolean(
    string item_name,
    bool item_value
)
Visual Basic
Public Sub SetBoolean ( _
    item_name As String, _
    item_value As Boolean _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: System..::..Boolean
Value of item to add.

Implements

GH_IWriter..::..SetBoolean(String, Boolean)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_Chunk Class
SetBoolean Overload
GH_IO.Serialization Namespace


SetBoolean Method (String, Int32, Boolean)

[image]

Grasshopper SDK
GH_Chunk..::..SetBoolean Method (String, Int32, Boolean)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetBoolean(
    string item_name,
    int item_index,
    bool item_value
)
Visual Basic
Public Sub SetBoolean ( _
    item_name As String, _
    item_index As Integer, _
    item_value As Boolean _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: System..::..Boolean
Value of item to add.

Implements

GH_IWriter..::..SetBoolean(String, Int32, Boolean)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_Chunk Class
SetBoolean Overload
GH_IO.Serialization Namespace


SetBoundingBox Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..SetBoundingBox Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBoundingBox(String, GH_BoundingBox) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetBoundingBox(String, Int32, GH_BoundingBox) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


SetBoundingBox Method (String, GH_BoundingBox)

[image]

Grasshopper SDK
GH_Chunk..::..SetBoundingBox Method (String, GH_BoundingBox)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetBoundingBox(
    string item_name,
    GH_BoundingBox item_value
)
Visual Basic
Public Sub SetBoundingBox ( _
    item_name As String, _
    item_value As GH_BoundingBox _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: GH_IO.Types..::..GH_BoundingBox
Value of item to add.

Implements

GH_IWriter..::..SetBoundingBox(String, GH_BoundingBox)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_Chunk Class
SetBoundingBox Overload
GH_IO.Serialization Namespace


SetBoundingBox Method (String, Int32, GH_BoundingBox)

[image]

Grasshopper SDK
GH_Chunk..::..SetBoundingBox Method (String, Int32, GH_BoundingBox)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetBoundingBox(
    string item_name,
    int item_index,
    GH_BoundingBox item_value
)
Visual Basic
Public Sub SetBoundingBox ( _
    item_name As String, _
    item_index As Integer, _
    item_value As GH_BoundingBox _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: GH_IO.Types..::..GH_BoundingBox
Value of item to add.

Implements

GH_IWriter..::..SetBoundingBox(String, Int32, GH_BoundingBox)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_Chunk Class
SetBoundingBox Overload
GH_IO.Serialization Namespace


SetByte Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..SetByte Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetByte(String, Byte) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetByte(String, Int32, Byte) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


SetByte Method (String, Byte)

[image]

Grasshopper SDK
GH_Chunk..::..SetByte Method (String, Byte)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetByte(
    string item_name,
    byte item_value
)
Visual Basic
Public Sub SetByte ( _
    item_name As String, _
    item_value As Byte _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: System..::..Byte
Value of item to add.

Implements

GH_IWriter..::..SetByte(String, Byte)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_Chunk Class
SetByte Overload
GH_IO.Serialization Namespace


SetByte Method (String, Int32, Byte)

[image]

Grasshopper SDK
GH_Chunk..::..SetByte Method (String, Int32, Byte)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetByte(
    string item_name,
    int item_index,
    byte item_value
)
Visual Basic
Public Sub SetByte ( _
    item_name As String, _
    item_index As Integer, _
    item_value As Byte _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: System..::..Byte
Value of item to add.

Implements

GH_IWriter..::..SetByte(String, Int32, Byte)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_Chunk Class
SetByte Overload
GH_IO.Serialization Namespace


SetByteArray Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..SetByteArray Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetByteArray(String, array<Byte>[]()[][]) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetByteArray(String, Int32, array<Byte>[]()[][]) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


SetByteArray Method (String, Byte[])

[image]

Grasshopper SDK
GH_Chunk..::..SetByteArray Method (String, array<Byte>[]()[][])
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetByteArray(
    string item_name,
    byte[] item_value
)
Visual Basic
Public Sub SetByteArray ( _
    item_name As String, _
    item_value As Byte() _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: array< System..::..Byte >[]()[][]
Value of item to add.

Implements

GH_IWriter..::..SetByteArray(String, array<Byte>[]()[][])

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_Chunk Class
SetByteArray Overload
GH_IO.Serialization Namespace


SetByteArray Method (String, Int32, Byte[])

[image]

Grasshopper SDK
GH_Chunk..::..SetByteArray Method (String, Int32, array<Byte>[]()[][])
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetByteArray(
    string item_name,
    int item_index,
    byte[] item_value
)
Visual Basic
Public Sub SetByteArray ( _
    item_name As String, _
    item_index As Integer, _
    item_value As Byte() _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: array< System..::..Byte >[]()[][]
Value of item to add.

Implements

GH_IWriter..::..SetByteArray(String, Int32, array<Byte>[]()[][])

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_Chunk Class
SetByteArray Overload
GH_IO.Serialization Namespace


SetDate Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..SetDate Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDate(String, DateTime) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDate(String, Int32, DateTime) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


SetDate Method (String, DateTime)

[image]

Grasshopper SDK
GH_Chunk..::..SetDate Method (String, DateTime)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetDate(
    string item_name,
    DateTime item_value
)
Visual Basic
Public Sub SetDate ( _
    item_name As String, _
    item_value As DateTime _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: System..::..DateTime
Value of item to add.

Implements

GH_IWriter..::..SetDate(String, DateTime)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_Chunk Class
SetDate Overload
GH_IO.Serialization Namespace


SetDate Method (String, Int32, DateTime)

[image]

Grasshopper SDK
GH_Chunk..::..SetDate Method (String, Int32, DateTime)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetDate(
    string item_name,
    int item_index,
    DateTime item_value
)
Visual Basic
Public Sub SetDate ( _
    item_name As String, _
    item_index As Integer, _
    item_value As DateTime _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: System..::..DateTime
Value of item to add.

Implements

GH_IWriter..::..SetDate(String, Int32, DateTime)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_Chunk Class
SetDate Overload
GH_IO.Serialization Namespace


SetDecimal Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..SetDecimal Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDecimal(String, Decimal) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDecimal(String, Int32, Decimal) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


SetDecimal Method (String, Decimal)

[image]

Grasshopper SDK
GH_Chunk..::..SetDecimal Method (String, Decimal)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetDecimal(
    string item_name,
    decimal item_value
)
Visual Basic
Public Sub SetDecimal ( _
    item_name As String, _
    item_value As Decimal _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: System..::..Decimal
Value of item to add.

Implements

GH_IWriter..::..SetDecimal(String, Decimal)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_Chunk Class
SetDecimal Overload
GH_IO.Serialization Namespace


SetDecimal Method (String, Int32, Decimal)

[image]

Grasshopper SDK
GH_Chunk..::..SetDecimal Method (String, Int32, Decimal)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetDecimal(
    string item_name,
    int item_index,
    decimal item_value
)
Visual Basic
Public Sub SetDecimal ( _
    item_name As String, _
    item_index As Integer, _
    item_value As Decimal _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: System..::..Decimal
Value of item to add.

Implements

GH_IWriter..::..SetDecimal(String, Int32, Decimal)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_Chunk Class
SetDecimal Overload
GH_IO.Serialization Namespace


SetDouble Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..SetDouble Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDouble(String, Double) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDouble(String, Int32, Double) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


SetDouble Method (String, Double)

[image]

Grasshopper SDK
GH_Chunk..::..SetDouble Method (String, Double)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetDouble(
    string item_name,
    double item_value
)
Visual Basic
Public Sub SetDouble ( _
    item_name As String, _
    item_value As Double _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: System..::..Double
Value of item to add.

Implements

GH_IWriter..::..SetDouble(String, Double)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_Chunk Class
SetDouble Overload
GH_IO.Serialization Namespace


SetDouble Method (String, Int32, Double)

[image]

Grasshopper SDK
GH_Chunk..::..SetDouble Method (String, Int32, Double)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetDouble(
    string item_name,
    int item_index,
    double item_value
)
Visual Basic
Public Sub SetDouble ( _
    item_name As String, _
    item_index As Integer, _
    item_value As Double _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: System..::..Double
Value of item to add.

Implements

GH_IWriter..::..SetDouble(String, Int32, Double)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_Chunk Class
SetDouble Overload
GH_IO.Serialization Namespace


SetDoubleArray Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..SetDoubleArray Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDoubleArray(String, array<Double>[]()[][]) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDoubleArray(String, Int32, array<Double>[]()[][]) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


SetDoubleArray Method (String, Double[])

[image]

Grasshopper SDK
GH_Chunk..::..SetDoubleArray Method (String, array<Double>[]()[][])
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetDoubleArray(
    string item_name,
    double[] item_value
)
Visual Basic
Public Sub SetDoubleArray ( _
    item_name As String, _
    item_value As Double() _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: array< System..::..Double >[]()[][]
Value of item to add.

Implements

GH_IWriter..::..SetDoubleArray(String, array<Double>[]()[][])

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_Chunk Class
SetDoubleArray Overload
GH_IO.Serialization Namespace


SetDoubleArray Method (String, Int32, Double[])

[image]

Grasshopper SDK
GH_Chunk..::..SetDoubleArray Method (String, Int32, array<Double>[]()[][])
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetDoubleArray(
    string item_name,
    int item_index,
    double[] item_value
)
Visual Basic
Public Sub SetDoubleArray ( _
    item_name As String, _
    item_index As Integer, _
    item_value As Double() _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: array< System..::..Double >[]()[][]
Value of item to add.

Implements

GH_IWriter..::..SetDoubleArray(String, Int32, array<Double>[]()[][])

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_Chunk Class
SetDoubleArray Overload
GH_IO.Serialization Namespace


SetDrawingBitmap Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..SetDrawingBitmap Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDrawingBitmap(String, Bitmap) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingBitmap(String, Int32, Bitmap) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


SetDrawingBitmap Method (String, Bitmap)

[image]

Grasshopper SDK
GH_Chunk..::..SetDrawingBitmap Method (String, Bitmap)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetDrawingBitmap(
    string item_name,
    Bitmap item_value
)
Visual Basic
Public Sub SetDrawingBitmap ( _
    item_name As String, _
    item_value As Bitmap _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: System.Drawing..::..Bitmap
Value of item to add.

Implements

GH_IWriter..::..SetDrawingBitmap(String, Bitmap)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_Chunk Class
SetDrawingBitmap Overload
GH_IO.Serialization Namespace


SetDrawingBitmap Method (String, Int32, Bitmap)

[image]

Grasshopper SDK
GH_Chunk..::..SetDrawingBitmap Method (String, Int32, Bitmap)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetDrawingBitmap(
    string item_name,
    int item_index,
    Bitmap item_value
)
Visual Basic
Public Sub SetDrawingBitmap ( _
    item_name As String, _
    item_index As Integer, _
    item_value As Bitmap _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: System.Drawing..::..Bitmap
Value of item to add.

Implements

GH_IWriter..::..SetDrawingBitmap(String, Int32, Bitmap)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_Chunk Class
SetDrawingBitmap Overload
GH_IO.Serialization Namespace


SetDrawingColor Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..SetDrawingColor Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDrawingColor(String, Color) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingColor(String, Int32, Color) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


SetDrawingColor Method (String, Color)

[image]

Grasshopper SDK
GH_Chunk..::..SetDrawingColor Method (String, Color)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetDrawingColor(
    string item_name,
    Color item_value
)
Visual Basic
Public Sub SetDrawingColor ( _
    item_name As String, _
    item_value As Color _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: System.Drawing..::..Color
Value of item to add.

Implements

GH_IWriter..::..SetDrawingColor(String, Color)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_Chunk Class
SetDrawingColor Overload
GH_IO.Serialization Namespace


SetDrawingColor Method (String, Int32, Color)

[image]

Grasshopper SDK
GH_Chunk..::..SetDrawingColor Method (String, Int32, Color)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetDrawingColor(
    string item_name,
    int item_index,
    Color item_value
)
Visual Basic
Public Sub SetDrawingColor ( _
    item_name As String, _
    item_index As Integer, _
    item_value As Color _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: System.Drawing..::..Color
Value of item to add.

Implements

GH_IWriter..::..SetDrawingColor(String, Int32, Color)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_Chunk Class
SetDrawingColor Overload
GH_IO.Serialization Namespace


SetDrawingPoint Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..SetDrawingPoint Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDrawingPoint(String, Point) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingPoint(String, Int32, Point) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


SetDrawingPoint Method (String, Point)

[image]

Grasshopper SDK
GH_Chunk..::..SetDrawingPoint Method (String, Point)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetDrawingPoint(
    string item_name,
    Point item_value
)
Visual Basic
Public Sub SetDrawingPoint ( _
    item_name As String, _
    item_value As Point _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: System.Drawing..::..Point
Value of item to add.

Implements

GH_IWriter..::..SetDrawingPoint(String, Point)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_Chunk Class
SetDrawingPoint Overload
GH_IO.Serialization Namespace


SetDrawingPoint Method (String, Int32, Point)

[image]

Grasshopper SDK
GH_Chunk..::..SetDrawingPoint Method (String, Int32, Point)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetDrawingPoint(
    string item_name,
    int item_index,
    Point item_value
)
Visual Basic
Public Sub SetDrawingPoint ( _
    item_name As String, _
    item_index As Integer, _
    item_value As Point _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: System.Drawing..::..Point
Value of item to add.

Implements

GH_IWriter..::..SetDrawingPoint(String, Int32, Point)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_Chunk Class
SetDrawingPoint Overload
GH_IO.Serialization Namespace


SetDrawingPointF Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..SetDrawingPointF Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDrawingPointF(String, PointF) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingPointF(String, Int32, PointF) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


SetDrawingPointF Method (String, PointF)

[image]

Grasshopper SDK
GH_Chunk..::..SetDrawingPointF Method (String, PointF)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetDrawingPointF(
    string item_name,
    PointF item_value
)
Visual Basic
Public Sub SetDrawingPointF ( _
    item_name As String, _
    item_value As PointF _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: System.Drawing..::..PointF
Value of item to add.

Implements

GH_IWriter..::..SetDrawingPointF(String, PointF)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_Chunk Class
SetDrawingPointF Overload
GH_IO.Serialization Namespace


SetDrawingPointF Method (String, Int32, PointF)

[image]

Grasshopper SDK
GH_Chunk..::..SetDrawingPointF Method (String, Int32, PointF)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetDrawingPointF(
    string item_name,
    int item_index,
    PointF item_value
)
Visual Basic
Public Sub SetDrawingPointF ( _
    item_name As String, _
    item_index As Integer, _
    item_value As PointF _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: System.Drawing..::..PointF
Value of item to add.

Implements

GH_IWriter..::..SetDrawingPointF(String, Int32, PointF)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_Chunk Class
SetDrawingPointF Overload
GH_IO.Serialization Namespace


SetDrawingRectangle Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..SetDrawingRectangle Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDrawingRectangle(String, Rectangle) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingRectangle(String, Int32, Rectangle) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


SetDrawingRectangle Method (String, Rectangle)

[image]

Grasshopper SDK
GH_Chunk..::..SetDrawingRectangle Method (String, Rectangle)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetDrawingRectangle(
    string item_name,
    Rectangle item_value
)
Visual Basic
Public Sub SetDrawingRectangle ( _
    item_name As String, _
    item_value As Rectangle _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: System.Drawing..::..Rectangle
Value of item to add.

Implements

GH_IWriter..::..SetDrawingRectangle(String, Rectangle)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_Chunk Class
SetDrawingRectangle Overload
GH_IO.Serialization Namespace


SetDrawingRectangle Method (String, Int32, Rectangle)

[image]

Grasshopper SDK
GH_Chunk..::..SetDrawingRectangle Method (String, Int32, Rectangle)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetDrawingRectangle(
    string item_name,
    int item_index,
    Rectangle item_value
)
Visual Basic
Public Sub SetDrawingRectangle ( _
    item_name As String, _
    item_index As Integer, _
    item_value As Rectangle _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: System.Drawing..::..Rectangle
Value of item to add.

Implements

GH_IWriter..::..SetDrawingRectangle(String, Int32, Rectangle)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_Chunk Class
SetDrawingRectangle Overload
GH_IO.Serialization Namespace


SetDrawingRectangleF Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..SetDrawingRectangleF Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDrawingRectangleF(String, RectangleF) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingRectangleF(String, Int32, RectangleF) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


SetDrawingRectangleF Method (String, RectangleF)

[image]

Grasshopper SDK
GH_Chunk..::..SetDrawingRectangleF Method (String, RectangleF)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetDrawingRectangleF(
    string item_name,
    RectangleF item_value
)
Visual Basic
Public Sub SetDrawingRectangleF ( _
    item_name As String, _
    item_value As RectangleF _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: System.Drawing..::..RectangleF
Value of item to add.

Implements

GH_IWriter..::..SetDrawingRectangleF(String, RectangleF)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_Chunk Class
SetDrawingRectangleF Overload
GH_IO.Serialization Namespace


SetDrawingRectangleF Method (String, Int32, RectangleF)

[image]

Grasshopper SDK
GH_Chunk..::..SetDrawingRectangleF Method (String, Int32, RectangleF)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetDrawingRectangleF(
    string item_name,
    int item_index,
    RectangleF item_value
)
Visual Basic
Public Sub SetDrawingRectangleF ( _
    item_name As String, _
    item_index As Integer, _
    item_value As RectangleF _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: System.Drawing..::..RectangleF
Value of item to add.

Implements

GH_IWriter..::..SetDrawingRectangleF(String, Int32, RectangleF)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_Chunk Class
SetDrawingRectangleF Overload
GH_IO.Serialization Namespace


SetDrawingSize Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..SetDrawingSize Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDrawingSize(String, Size) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingSize(String, Int32, Size) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


SetDrawingSize Method (String, Size)

[image]

Grasshopper SDK
GH_Chunk..::..SetDrawingSize Method (String, Size)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetDrawingSize(
    string item_name,
    Size item_value
)
Visual Basic
Public Sub SetDrawingSize ( _
    item_name As String, _
    item_value As Size _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: System.Drawing..::..Size
Value of item to add.

Implements

GH_IWriter..::..SetDrawingSize(String, Size)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_Chunk Class
SetDrawingSize Overload
GH_IO.Serialization Namespace


SetDrawingSize Method (String, Int32, Size)

[image]

Grasshopper SDK
GH_Chunk..::..SetDrawingSize Method (String, Int32, Size)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetDrawingSize(
    string item_name,
    int item_index,
    Size item_value
)
Visual Basic
Public Sub SetDrawingSize ( _
    item_name As String, _
    item_index As Integer, _
    item_value As Size _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: System.Drawing..::..Size
Value of item to add.

Implements

GH_IWriter..::..SetDrawingSize(String, Int32, Size)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_Chunk Class
SetDrawingSize Overload
GH_IO.Serialization Namespace


SetDrawingSizeF Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..SetDrawingSizeF Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDrawingSizeF(String, SizeF) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingSizeF(String, Int32, SizeF) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


SetDrawingSizeF Method (String, SizeF)

[image]

Grasshopper SDK
GH_Chunk..::..SetDrawingSizeF Method (String, SizeF)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetDrawingSizeF(
    string item_name,
    SizeF item_value
)
Visual Basic
Public Sub SetDrawingSizeF ( _
    item_name As String, _
    item_value As SizeF _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: System.Drawing..::..SizeF
Value of item to add.

Implements

GH_IWriter..::..SetDrawingSizeF(String, SizeF)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_Chunk Class
SetDrawingSizeF Overload
GH_IO.Serialization Namespace


SetDrawingSizeF Method (String, Int32, SizeF)

[image]

Grasshopper SDK
GH_Chunk..::..SetDrawingSizeF Method (String, Int32, SizeF)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetDrawingSizeF(
    string item_name,
    int item_index,
    SizeF item_value
)
Visual Basic
Public Sub SetDrawingSizeF ( _
    item_name As String, _
    item_index As Integer, _
    item_value As SizeF _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: System.Drawing..::..SizeF
Value of item to add.

Implements

GH_IWriter..::..SetDrawingSizeF(String, Int32, SizeF)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_Chunk Class
SetDrawingSizeF Overload
GH_IO.Serialization Namespace


SetGuid Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..SetGuid Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetGuid(String, Guid) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetGuid(String, Int32, Guid) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


SetGuid Method (String, Guid)

[image]

Grasshopper SDK
GH_Chunk..::..SetGuid Method (String, Guid)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetGuid(
    string item_name,
    Guid item_value
)
Visual Basic
Public Sub SetGuid ( _
    item_name As String, _
    item_value As Guid _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: System..::..Guid
Value of item to add.

Implements

GH_IWriter..::..SetGuid(String, Guid)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_Chunk Class
SetGuid Overload
GH_IO.Serialization Namespace


SetGuid Method (String, Int32, Guid)

[image]

Grasshopper SDK
GH_Chunk..::..SetGuid Method (String, Int32, Guid)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetGuid(
    string item_name,
    int item_index,
    Guid item_value
)
Visual Basic
Public Sub SetGuid ( _
    item_name As String, _
    item_index As Integer, _
    item_value As Guid _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: System..::..Guid
Value of item to add.

Implements

GH_IWriter..::..SetGuid(String, Int32, Guid)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_Chunk Class
SetGuid Overload
GH_IO.Serialization Namespace


SetInt32 Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..SetInt32 Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetInt32(String, Int32) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetInt32(String, Int32, Int32) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


SetInt32 Method (String, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..SetInt32 Method (String, Int32)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetInt32(
    string item_name,
    int item_value
)
Visual Basic
Public Sub SetInt32 ( _
    item_name As String, _
    item_value As Integer _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: System..::..Int32
Value of item to add.

Implements

GH_IWriter..::..SetInt32(String, Int32)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_Chunk Class
SetInt32 Overload
GH_IO.Serialization Namespace


SetInt32 Method (String, Int32, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..SetInt32 Method (String, Int32, Int32)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetInt32(
    string item_name,
    int item_index,
    int item_value
)
Visual Basic
Public Sub SetInt32 ( _
    item_name As String, _
    item_index As Integer, _
    item_value As Integer _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: System..::..Int32
Value of item to add.

Implements

GH_IWriter..::..SetInt32(String, Int32, Int32)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_Chunk Class
SetInt32 Overload
GH_IO.Serialization Namespace


SetInt64 Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..SetInt64 Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetInt64(String, Int64) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetInt64(String, Int32, Int64) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


SetInt64 Method (String, Int64)

[image]

Grasshopper SDK
GH_Chunk..::..SetInt64 Method (String, Int64)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetInt64(
    string item_name,
    long item_value
)
Visual Basic
Public Sub SetInt64 ( _
    item_name As String, _
    item_value As Long _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: System..::..Int64
Value of item to add.

Implements

GH_IWriter..::..SetInt64(String, Int64)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_Chunk Class
SetInt64 Overload
GH_IO.Serialization Namespace


SetInt64 Method (String, Int32, Int64)

[image]

Grasshopper SDK
GH_Chunk..::..SetInt64 Method (String, Int32, Int64)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetInt64(
    string item_name,
    int item_index,
    long item_value
)
Visual Basic
Public Sub SetInt64 ( _
    item_name As String, _
    item_index As Integer, _
    item_value As Long _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: System..::..Int64
Value of item to add.

Implements

GH_IWriter..::..SetInt64(String, Int32, Int64)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_Chunk Class
SetInt64 Overload
GH_IO.Serialization Namespace


SetInterval1D Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..SetInterval1D Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetInterval1D(String, GH_Interval1D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetInterval1D(String, Int32, GH_Interval1D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


SetInterval1D Method (String, GH_Interval1D)

[image]

Grasshopper SDK
GH_Chunk..::..SetInterval1D Method (String, GH_Interval1D)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetInterval1D(
    string item_name,
    GH_Interval1D item_value
)
Visual Basic
Public Sub SetInterval1D ( _
    item_name As String, _
    item_value As GH_Interval1D _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: GH_IO.Types..::..GH_Interval1D
Value of item to add.

Implements

GH_IWriter..::..SetInterval1D(String, GH_Interval1D)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_Chunk Class
SetInterval1D Overload
GH_IO.Serialization Namespace


SetInterval1D Method (String, Int32, GH_Interval1D)

[image]

Grasshopper SDK
GH_Chunk..::..SetInterval1D Method (String, Int32, GH_Interval1D)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetInterval1D(
    string item_name,
    int item_index,
    GH_Interval1D item_value
)
Visual Basic
Public Sub SetInterval1D ( _
    item_name As String, _
    item_index As Integer, _
    item_value As GH_Interval1D _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: GH_IO.Types..::..GH_Interval1D
Value of item to add.

Implements

GH_IWriter..::..SetInterval1D(String, Int32, GH_Interval1D)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_Chunk Class
SetInterval1D Overload
GH_IO.Serialization Namespace


SetInterval2D Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..SetInterval2D Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetInterval2D(String, GH_Interval2D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetInterval2D(String, Int32, GH_Interval2D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


SetInterval2D Method (String, GH_Interval2D)

[image]

Grasshopper SDK
GH_Chunk..::..SetInterval2D Method (String, GH_Interval2D)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetInterval2D(
    string item_name,
    GH_Interval2D item_value
)
Visual Basic
Public Sub SetInterval2D ( _
    item_name As String, _
    item_value As GH_Interval2D _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: GH_IO.Types..::..GH_Interval2D
Value of item to add.

Implements

GH_IWriter..::..SetInterval2D(String, GH_Interval2D)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_Chunk Class
SetInterval2D Overload
GH_IO.Serialization Namespace


SetInterval2D Method (String, Int32, GH_Interval2D)

[image]

Grasshopper SDK
GH_Chunk..::..SetInterval2D Method (String, Int32, GH_Interval2D)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetInterval2D(
    string item_name,
    int item_index,
    GH_Interval2D item_value
)
Visual Basic
Public Sub SetInterval2D ( _
    item_name As String, _
    item_index As Integer, _
    item_value As GH_Interval2D _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: GH_IO.Types..::..GH_Interval2D
Value of item to add.

Implements

GH_IWriter..::..SetInterval2D(String, Int32, GH_Interval2D)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_Chunk Class
SetInterval2D Overload
GH_IO.Serialization Namespace


SetLine Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..SetLine Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetLine(String, GH_Line) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetLine(String, Int32, GH_Line) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


SetLine Method (String, GH_Line)

[image]

Grasshopper SDK
GH_Chunk..::..SetLine Method (String, GH_Line)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetLine(
    string item_name,
    GH_Line item_value
)
Visual Basic
Public Sub SetLine ( _
    item_name As String, _
    item_value As GH_Line _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: GH_IO.Types..::..GH_Line
Value of item to add.

Implements

GH_IWriter..::..SetLine(String, GH_Line)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_Chunk Class
SetLine Overload
GH_IO.Serialization Namespace


SetLine Method (String, Int32, GH_Line)

[image]

Grasshopper SDK
GH_Chunk..::..SetLine Method (String, Int32, GH_Line)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetLine(
    string item_name,
    int item_index,
    GH_Line item_value
)
Visual Basic
Public Sub SetLine ( _
    item_name As String, _
    item_index As Integer, _
    item_value As GH_Line _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: GH_IO.Types..::..GH_Line
Value of item to add.

Implements

GH_IWriter..::..SetLine(String, Int32, GH_Line)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_Chunk Class
SetLine Overload
GH_IO.Serialization Namespace


SetPath Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..SetPath Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetPath(String, String, String) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetPath(String, Int32, String, String) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


SetPath Method (String, String, String)

[image]

Grasshopper SDK
GH_Chunk..::..SetPath Method (String, String, String)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetPath(
    string item_name,
    string absolutePath,
    string basePath
)
Visual Basic
Public Sub SetPath ( _
    item_name As String, _
    absolutePath As String, _
    basePath As String _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
absolutePath
Type: System..::..String
Absolute path to store.
basePath
Type: System..::..String
Base path. This will be used to also store a relative path.

Implements

GH_IWriter..::..SetPath(String, String, String)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_Chunk Class
SetPath Overload
GH_IO.Serialization Namespace


SetPath Method (String, Int32, String, String)

[image]

Grasshopper SDK
GH_Chunk..::..SetPath Method (String, Int32, String, String)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetPath(
    string item_name,
    int item_index,
    string absolutePath,
    string basePath
)
Visual Basic
Public Sub SetPath ( _
    item_name As String, _
    item_index As Integer, _
    absolutePath As String, _
    basePath As String _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
absolutePath
Type: System..::..String
Absolute path to store.
basePath
Type: System..::..String
Base path. This will be used to also store a relative path.

Implements

GH_IWriter..::..SetPath(String, Int32, String, String)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_Chunk Class
SetPath Overload
GH_IO.Serialization Namespace


SetPlane Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..SetPlane Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetPlane(String, GH_Plane) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetPlane(String, Int32, GH_Plane) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


SetPlane Method (String, GH_Plane)

[image]

Grasshopper SDK
GH_Chunk..::..SetPlane Method (String, GH_Plane)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetPlane(
    string item_name,
    GH_Plane item_value
)
Visual Basic
Public Sub SetPlane ( _
    item_name As String, _
    item_value As GH_Plane _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: GH_IO.Types..::..GH_Plane
Value of item to add.

Implements

GH_IWriter..::..SetPlane(String, GH_Plane)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_Chunk Class
SetPlane Overload
GH_IO.Serialization Namespace


SetPlane Method (String, Int32, GH_Plane)

[image]

Grasshopper SDK
GH_Chunk..::..SetPlane Method (String, Int32, GH_Plane)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetPlane(
    string item_name,
    int item_index,
    GH_Plane item_value
)
Visual Basic
Public Sub SetPlane ( _
    item_name As String, _
    item_index As Integer, _
    item_value As GH_Plane _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: GH_IO.Types..::..GH_Plane
Value of item to add.

Implements

GH_IWriter..::..SetPlane(String, Int32, GH_Plane)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_Chunk Class
SetPlane Overload
GH_IO.Serialization Namespace


SetPoint2D Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..SetPoint2D Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetPoint2D(String, GH_Point2D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetPoint2D(String, Int32, GH_Point2D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


SetPoint2D Method (String, GH_Point2D)

[image]

Grasshopper SDK
GH_Chunk..::..SetPoint2D Method (String, GH_Point2D)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetPoint2D(
    string item_name,
    GH_Point2D item_value
)
Visual Basic
Public Sub SetPoint2D ( _
    item_name As String, _
    item_value As GH_Point2D _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: GH_IO.Types..::..GH_Point2D
Value of item to add.

Implements

GH_IWriter..::..SetPoint2D(String, GH_Point2D)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_Chunk Class
SetPoint2D Overload
GH_IO.Serialization Namespace


SetPoint2D Method (String, Int32, GH_Point2D)

[image]

Grasshopper SDK
GH_Chunk..::..SetPoint2D Method (String, Int32, GH_Point2D)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetPoint2D(
    string item_name,
    int item_index,
    GH_Point2D item_value
)
Visual Basic
Public Sub SetPoint2D ( _
    item_name As String, _
    item_index As Integer, _
    item_value As GH_Point2D _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: GH_IO.Types..::..GH_Point2D
Value of item to add.

Implements

GH_IWriter..::..SetPoint2D(String, Int32, GH_Point2D)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_Chunk Class
SetPoint2D Overload
GH_IO.Serialization Namespace


SetPoint3D Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..SetPoint3D Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetPoint3D(String, GH_Point3D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetPoint3D(String, Int32, GH_Point3D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


SetPoint3D Method (String, GH_Point3D)

[image]

Grasshopper SDK
GH_Chunk..::..SetPoint3D Method (String, GH_Point3D)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetPoint3D(
    string item_name,
    GH_Point3D item_value
)
Visual Basic
Public Sub SetPoint3D ( _
    item_name As String, _
    item_value As GH_Point3D _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: GH_IO.Types..::..GH_Point3D
Value of item to add.

Implements

GH_IWriter..::..SetPoint3D(String, GH_Point3D)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_Chunk Class
SetPoint3D Overload
GH_IO.Serialization Namespace


SetPoint3D Method (String, Int32, GH_Point3D)

[image]

Grasshopper SDK
GH_Chunk..::..SetPoint3D Method (String, Int32, GH_Point3D)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetPoint3D(
    string item_name,
    int item_index,
    GH_Point3D item_value
)
Visual Basic
Public Sub SetPoint3D ( _
    item_name As String, _
    item_index As Integer, _
    item_value As GH_Point3D _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: GH_IO.Types..::..GH_Point3D
Value of item to add.

Implements

GH_IWriter..::..SetPoint3D(String, Int32, GH_Point3D)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_Chunk Class
SetPoint3D Overload
GH_IO.Serialization Namespace


SetPoint4D Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..SetPoint4D Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetPoint4D(String, GH_Point4D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetPoint4D(String, Int32, GH_Point4D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


SetPoint4D Method (String, GH_Point4D)

[image]

Grasshopper SDK
GH_Chunk..::..SetPoint4D Method (String, GH_Point4D)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetPoint4D(
    string item_name,
    GH_Point4D item_value
)
Visual Basic
Public Sub SetPoint4D ( _
    item_name As String, _
    item_value As GH_Point4D _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: GH_IO.Types..::..GH_Point4D
Value of item to add.

Implements

GH_IWriter..::..SetPoint4D(String, GH_Point4D)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_Chunk Class
SetPoint4D Overload
GH_IO.Serialization Namespace


SetPoint4D Method (String, Int32, GH_Point4D)

[image]

Grasshopper SDK
GH_Chunk..::..SetPoint4D Method (String, Int32, GH_Point4D)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetPoint4D(
    string item_name,
    int item_index,
    GH_Point4D item_value
)
Visual Basic
Public Sub SetPoint4D ( _
    item_name As String, _
    item_index As Integer, _
    item_value As GH_Point4D _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: GH_IO.Types..::..GH_Point4D
Value of item to add.

Implements

GH_IWriter..::..SetPoint4D(String, Int32, GH_Point4D)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_Chunk Class
SetPoint4D Overload
GH_IO.Serialization Namespace


SetSingle Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..SetSingle Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetSingle(String, Single) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetSingle(String, Int32, Single) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


SetSingle Method (String, Single)

[image]

Grasshopper SDK
GH_Chunk..::..SetSingle Method (String, Single)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetSingle(
    string item_name,
    float item_value
)
Visual Basic
Public Sub SetSingle ( _
    item_name As String, _
    item_value As Single _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: System..::..Single
Value of item to add.

Implements

GH_IWriter..::..SetSingle(String, Single)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_Chunk Class
SetSingle Overload
GH_IO.Serialization Namespace


SetSingle Method (String, Int32, Single)

[image]

Grasshopper SDK
GH_Chunk..::..SetSingle Method (String, Int32, Single)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetSingle(
    string item_name,
    int item_index,
    float item_value
)
Visual Basic
Public Sub SetSingle ( _
    item_name As String, _
    item_index As Integer, _
    item_value As Single _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: System..::..Single
Value of item to add.

Implements

GH_IWriter..::..SetSingle(String, Int32, Single)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_Chunk Class
SetSingle Overload
GH_IO.Serialization Namespace


SetString Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..SetString Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetString(String, String) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetString(String, Int32, String) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


SetString Method (String, String)

[image]

Grasshopper SDK
GH_Chunk..::..SetString Method (String, String)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetString(
    string item_name,
    string item_value
)
Visual Basic
Public Sub SetString ( _
    item_name As String, _
    item_value As String _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: System..::..String
Value of item to add.

Implements

GH_IWriter..::..SetString(String, String)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_Chunk Class
SetString Overload
GH_IO.Serialization Namespace


SetString Method (String, Int32, String)

[image]

Grasshopper SDK
GH_Chunk..::..SetString Method (String, Int32, String)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetString(
    string item_name,
    int item_index,
    string item_value
)
Visual Basic
Public Sub SetString ( _
    item_name As String, _
    item_index As Integer, _
    item_value As String _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: System..::..String
Value of item to add.

Implements

GH_IWriter..::..SetString(String, Int32, String)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_Chunk Class
SetString Overload
GH_IO.Serialization Namespace


SetVersion Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..SetVersion Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetVersion(String, GH_Version) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetVersion(String, Int32, GH_Version) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetVersion(String, Int32, Int32, Int32) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetVersion(String, Int32, Int32, Int32, Int32) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


SetVersion Method (String, GH_Version)

[image]

Grasshopper SDK
GH_Chunk..::..SetVersion Method (String, GH_Version)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetVersion(
    string item_name,
    GH_Version item_value
)
Visual Basic
Public Sub SetVersion ( _
    item_name As String, _
    item_value As GH_Version _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: GH_IO.Types..::..GH_Version
Value of item to add.

Implements

GH_IWriter..::..SetVersion(String, GH_Version)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_Chunk Class
SetVersion Overload
GH_IO.Serialization Namespace


SetVersion Method (String, Int32, GH_Version)

[image]

Grasshopper SDK
GH_Chunk..::..SetVersion Method (String, Int32, GH_Version)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetVersion(
    string item_name,
    int item_index,
    GH_Version item_value
)
Visual Basic
Public Sub SetVersion ( _
    item_name As String, _
    item_index As Integer, _
    item_value As GH_Version _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: GH_IO.Types..::..GH_Version
Value of item to add.

Implements

GH_IWriter..::..SetVersion(String, Int32, GH_Version)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_Chunk Class
SetVersion Overload
GH_IO.Serialization Namespace


SetVersion Method (String, Int32, Int32, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..SetVersion Method (String, Int32, Int32, Int32)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetVersion(
    string item_name,
    int major,
    int minor,
    int revision
)
Visual Basic
Public Sub SetVersion ( _
    item_name As String, _
    major As Integer, _
    minor As Integer, _
    revision As Integer _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
major
Type: System..::..Int32
Major component of Version structure.
minor
Type: System..::..Int32
Minor component of Version structure.
revision
Type: System..::..Int32
Revision component of Version structure.

Implements

GH_IWriter..::..SetVersion(String, Int32, Int32, Int32)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_Chunk Class
SetVersion Overload
GH_IO.Serialization Namespace


SetVersion Method (String, Int32, Int32, Int32, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..SetVersion Method (String, Int32, Int32, Int32, Int32)
GH_Chunk Class See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetVersion(
    string item_name,
    int item_index,
    int major,
    int minor,
    int revision
)
Visual Basic
Public Sub SetVersion ( _
    item_name As String, _
    item_index As Integer, _
    major As Integer, _
    minor As Integer, _
    revision As Integer _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
major
Type: System..::..Int32
Major component of Version structure.
minor
Type: System..::..Int32
Minor component of Version structure.
revision
Type: System..::..Int32
Revision component of Version structure.

Implements

GH_IWriter..::..SetVersion(String, Int32, Int32, Int32, Int32)

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_Chunk Class
SetVersion Overload
GH_IO.Serialization Namespace


TryGetBoolean Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..TryGetBoolean Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetBoolean(String, Boolean%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetBoolean(String, Int32, Boolean%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


TryGetBoolean Method (String, Boolean)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetBoolean Method (String, Boolean%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetBoolean(
    string item_name,
    ref bool value
)
Visual Basic
Public Function TryGetBoolean ( _
    item_name As String, _
    ByRef value As Boolean _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: System..::..Boolean %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetBoolean(String, Boolean%)

See Also

GH_Chunk Class
TryGetBoolean Overload
GH_IO.Serialization Namespace


TryGetBoolean Method (String, Int32, Boolean)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetBoolean Method (String, Int32, Boolean%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetBoolean(
    string item_name,
    int item_index,
    ref bool value
)
Visual Basic
Public Function TryGetBoolean ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As Boolean _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: System..::..Boolean %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetBoolean(String, Int32, Boolean%)

See Also

GH_Chunk Class
TryGetBoolean Overload
GH_IO.Serialization Namespace


TryGetBoundingBox Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..TryGetBoundingBox Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetBoundingBox(String, GH_BoundingBox%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetBoundingBox(String, Int32, GH_BoundingBox%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


TryGetBoundingBox Method (String, GH_BoundingBox)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetBoundingBox Method (String, GH_BoundingBox%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetBoundingBox(
    string item_name,
    ref GH_BoundingBox value
)
Visual Basic
Public Function TryGetBoundingBox ( _
    item_name As String, _
    ByRef value As GH_BoundingBox _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: GH_IO.Types..::..GH_BoundingBox %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetBoundingBox(String, GH_BoundingBox%)

See Also

GH_Chunk Class
TryGetBoundingBox Overload
GH_IO.Serialization Namespace


TryGetBoundingBox Method (String, Int32, GH_BoundingBox)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetBoundingBox Method (String, Int32, GH_BoundingBox%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetBoundingBox(
    string item_name,
    int item_index,
    ref GH_BoundingBox value
)
Visual Basic
Public Function TryGetBoundingBox ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As GH_BoundingBox _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: GH_IO.Types..::..GH_BoundingBox %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetBoundingBox(String, Int32, GH_BoundingBox%)

See Also

GH_Chunk Class
TryGetBoundingBox Overload
GH_IO.Serialization Namespace


TryGetByte Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..TryGetByte Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetByte(String, Byte%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetByte(String, Int32, Byte%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


TryGetByte Method (String, Byte)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetByte Method (String, Byte%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetByte(
    string item_name,
    ref byte value
)
Visual Basic
Public Function TryGetByte ( _
    item_name As String, _
    ByRef value As Byte _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: System..::..Byte %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetByte(String, Byte%)

See Also

GH_Chunk Class
TryGetByte Overload
GH_IO.Serialization Namespace


TryGetByte Method (String, Int32, Byte)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetByte Method (String, Int32, Byte%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetByte(
    string item_name,
    int item_index,
    ref byte value
)
Visual Basic
Public Function TryGetByte ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As Byte _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: System..::..Byte %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetByte(String, Int32, Byte%)

See Also

GH_Chunk Class
TryGetByte Overload
GH_IO.Serialization Namespace


TryGetDate Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..TryGetDate Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetDate(String, DateTime%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDate(String, Int32, DateTime%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


TryGetDate Method (String, DateTime)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetDate Method (String, DateTime%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetDate(
    string item_name,
    ref DateTime value
)
Visual Basic
Public Function TryGetDate ( _
    item_name As String, _
    ByRef value As DateTime _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: System..::..DateTime %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetDate(String, DateTime%)

See Also

GH_Chunk Class
TryGetDate Overload
GH_IO.Serialization Namespace


TryGetDate Method (String, Int32, DateTime)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetDate Method (String, Int32, DateTime%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetDate(
    string item_name,
    int item_index,
    ref DateTime value
)
Visual Basic
Public Function TryGetDate ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As DateTime _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: System..::..DateTime %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetDate(String, Int32, DateTime%)

See Also

GH_Chunk Class
TryGetDate Overload
GH_IO.Serialization Namespace


TryGetDecimal Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..TryGetDecimal Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetDecimal(String, Decimal%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDecimal(String, Int32, Decimal%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


TryGetDecimal Method (String, Decimal)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetDecimal Method (String, Decimal%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetDecimal(
    string item_name,
    ref decimal value
)
Visual Basic
Public Function TryGetDecimal ( _
    item_name As String, _
    ByRef value As Decimal _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: System..::..Decimal %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetDecimal(String, Decimal%)

See Also

GH_Chunk Class
TryGetDecimal Overload
GH_IO.Serialization Namespace


TryGetDecimal Method (String, Int32, Decimal)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetDecimal Method (String, Int32, Decimal%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetDecimal(
    string item_name,
    int item_index,
    ref decimal value
)
Visual Basic
Public Function TryGetDecimal ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As Decimal _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: System..::..Decimal %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetDecimal(String, Int32, Decimal%)

See Also

GH_Chunk Class
TryGetDecimal Overload
GH_IO.Serialization Namespace


TryGetDouble Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..TryGetDouble Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetDouble(String, Double%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDouble(String, Int32, Double%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


TryGetDouble Method (String, Double)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetDouble Method (String, Double%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetDouble(
    string item_name,
    ref double value
)
Visual Basic
Public Function TryGetDouble ( _
    item_name As String, _
    ByRef value As Double _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: System..::..Double %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetDouble(String, Double%)

See Also

GH_Chunk Class
TryGetDouble Overload
GH_IO.Serialization Namespace


TryGetDouble Method (String, Int32, Double)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetDouble Method (String, Int32, Double%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetDouble(
    string item_name,
    int item_index,
    ref double value
)
Visual Basic
Public Function TryGetDouble ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As Double _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: System..::..Double %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetDouble(String, Int32, Double%)

See Also

GH_Chunk Class
TryGetDouble Overload
GH_IO.Serialization Namespace


TryGetDrawingColor Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..TryGetDrawingColor Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetDrawingColor(String, Color%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingColor(String, Int32, Color%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


TryGetDrawingColor Method (String, Color)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetDrawingColor Method (String, Color%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetDrawingColor(
    string item_name,
    ref Color value
)
Visual Basic
Public Function TryGetDrawingColor ( _
    item_name As String, _
    ByRef value As Color _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: System.Drawing..::..Color %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetDrawingColor(String, Color%)

See Also

GH_Chunk Class
TryGetDrawingColor Overload
GH_IO.Serialization Namespace


TryGetDrawingColor Method (String, Int32, Color)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetDrawingColor Method (String, Int32, Color%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetDrawingColor(
    string item_name,
    int item_index,
    ref Color value
)
Visual Basic
Public Function TryGetDrawingColor ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As Color _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: System.Drawing..::..Color %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetDrawingColor(String, Int32, Color%)

See Also

GH_Chunk Class
TryGetDrawingColor Overload
GH_IO.Serialization Namespace


TryGetDrawingPoint Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..TryGetDrawingPoint Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetDrawingPoint(String, Point%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingPoint(String, Int32, Point%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


TryGetDrawingPoint Method (String, Point)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetDrawingPoint Method (String, Point%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetDrawingPoint(
    string item_name,
    ref Point value
)
Visual Basic
Public Function TryGetDrawingPoint ( _
    item_name As String, _
    ByRef value As Point _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: System.Drawing..::..Point %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetDrawingPoint(String, Point%)

See Also

GH_Chunk Class
TryGetDrawingPoint Overload
GH_IO.Serialization Namespace


TryGetDrawingPoint Method (String, Int32, Point)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetDrawingPoint Method (String, Int32, Point%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetDrawingPoint(
    string item_name,
    int item_index,
    ref Point value
)
Visual Basic
Public Function TryGetDrawingPoint ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As Point _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: System.Drawing..::..Point %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetDrawingPoint(String, Int32, Point%)

See Also

GH_Chunk Class
TryGetDrawingPoint Overload
GH_IO.Serialization Namespace


TryGetDrawingPointF Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..TryGetDrawingPointF Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetDrawingPointF(String, PointF%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingPointF(String, Int32, PointF%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


TryGetDrawingPointF Method (String, PointF)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetDrawingPointF Method (String, PointF%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetDrawingPointF(
    string item_name,
    ref PointF value
)
Visual Basic
Public Function TryGetDrawingPointF ( _
    item_name As String, _
    ByRef value As PointF _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: System.Drawing..::..PointF %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetDrawingPointF(String, PointF%)

See Also

GH_Chunk Class
TryGetDrawingPointF Overload
GH_IO.Serialization Namespace


TryGetDrawingPointF Method (String, Int32, PointF)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetDrawingPointF Method (String, Int32, PointF%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetDrawingPointF(
    string item_name,
    int item_index,
    ref PointF value
)
Visual Basic
Public Function TryGetDrawingPointF ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As PointF _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: System.Drawing..::..PointF %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetDrawingPointF(String, Int32, PointF%)

See Also

GH_Chunk Class
TryGetDrawingPointF Overload
GH_IO.Serialization Namespace


TryGetDrawingRectangle Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..TryGetDrawingRectangle Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetDrawingRectangle(String, Rectangle%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingRectangle(String, Int32, Rectangle%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


TryGetDrawingRectangle Method (String, Rectangle)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetDrawingRectangle Method (String, Rectangle%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetDrawingRectangle(
    string item_name,
    ref Rectangle value
)
Visual Basic
Public Function TryGetDrawingRectangle ( _
    item_name As String, _
    ByRef value As Rectangle _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: System.Drawing..::..Rectangle %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetDrawingRectangle(String, Rectangle%)

See Also

GH_Chunk Class
TryGetDrawingRectangle Overload
GH_IO.Serialization Namespace


TryGetDrawingRectangle Method (String, Int32, Rectangle)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetDrawingRectangle Method (String, Int32, Rectangle%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetDrawingRectangle(
    string item_name,
    int item_index,
    ref Rectangle value
)
Visual Basic
Public Function TryGetDrawingRectangle ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As Rectangle _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: System.Drawing..::..Rectangle %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetDrawingRectangle(String, Int32, Rectangle%)

See Also

GH_Chunk Class
TryGetDrawingRectangle Overload
GH_IO.Serialization Namespace


TryGetDrawingRectangleF Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..TryGetDrawingRectangleF Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetDrawingRectangleF(String, RectangleF%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingRectangleF(String, Int32, RectangleF%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


TryGetDrawingRectangleF Method (String, RectangleF)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetDrawingRectangleF Method (String, RectangleF%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetDrawingRectangleF(
    string item_name,
    ref RectangleF value
)
Visual Basic
Public Function TryGetDrawingRectangleF ( _
    item_name As String, _
    ByRef value As RectangleF _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: System.Drawing..::..RectangleF %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetDrawingRectangleF(String, RectangleF%)

See Also

GH_Chunk Class
TryGetDrawingRectangleF Overload
GH_IO.Serialization Namespace


TryGetDrawingRectangleF Method (String, Int32, RectangleF)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetDrawingRectangleF Method (String, Int32, RectangleF%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetDrawingRectangleF(
    string item_name,
    int item_index,
    ref RectangleF value
)
Visual Basic
Public Function TryGetDrawingRectangleF ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As RectangleF _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: System.Drawing..::..RectangleF %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetDrawingRectangleF(String, Int32, RectangleF%)

See Also

GH_Chunk Class
TryGetDrawingRectangleF Overload
GH_IO.Serialization Namespace


TryGetDrawingSize Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..TryGetDrawingSize Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetDrawingSize(String, Size%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingSize(String, Int32, Size%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


TryGetDrawingSize Method (String, Size)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetDrawingSize Method (String, Size%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetDrawingSize(
    string item_name,
    ref Size value
)
Visual Basic
Public Function TryGetDrawingSize ( _
    item_name As String, _
    ByRef value As Size _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: System.Drawing..::..Size %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetDrawingSize(String, Size%)

See Also

GH_Chunk Class
TryGetDrawingSize Overload
GH_IO.Serialization Namespace


TryGetDrawingSize Method (String, Int32, Size)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetDrawingSize Method (String, Int32, Size%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetDrawingSize(
    string item_name,
    int item_index,
    ref Size value
)
Visual Basic
Public Function TryGetDrawingSize ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As Size _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: System.Drawing..::..Size %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetDrawingSize(String, Int32, Size%)

See Also

GH_Chunk Class
TryGetDrawingSize Overload
GH_IO.Serialization Namespace


TryGetDrawingSizeF Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..TryGetDrawingSizeF Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetDrawingSizeF(String, SizeF%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingSizeF(String, Int32, SizeF%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


TryGetDrawingSizeF Method (String, SizeF)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetDrawingSizeF Method (String, SizeF%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetDrawingSizeF(
    string item_name,
    ref SizeF value
)
Visual Basic
Public Function TryGetDrawingSizeF ( _
    item_name As String, _
    ByRef value As SizeF _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: System.Drawing..::..SizeF %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetDrawingSizeF(String, SizeF%)

See Also

GH_Chunk Class
TryGetDrawingSizeF Overload
GH_IO.Serialization Namespace


TryGetDrawingSizeF Method (String, Int32, SizeF)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetDrawingSizeF Method (String, Int32, SizeF%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetDrawingSizeF(
    string item_name,
    int item_index,
    ref SizeF value
)
Visual Basic
Public Function TryGetDrawingSizeF ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As SizeF _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: System.Drawing..::..SizeF %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetDrawingSizeF(String, Int32, SizeF%)

See Also

GH_Chunk Class
TryGetDrawingSizeF Overload
GH_IO.Serialization Namespace


TryGetGuid Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..TryGetGuid Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetGuid(String, Guid%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetGuid(String, Int32, Guid%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


TryGetGuid Method (String, Guid)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetGuid Method (String, Guid%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetGuid(
    string item_name,
    ref Guid value
)
Visual Basic
Public Function TryGetGuid ( _
    item_name As String, _
    ByRef value As Guid _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: System..::..Guid %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetGuid(String, Guid%)

See Also

GH_Chunk Class
TryGetGuid Overload
GH_IO.Serialization Namespace


TryGetGuid Method (String, Int32, Guid)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetGuid Method (String, Int32, Guid%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetGuid(
    string item_name,
    int item_index,
    ref Guid value
)
Visual Basic
Public Function TryGetGuid ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As Guid _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: System..::..Guid %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetGuid(String, Int32, Guid%)

See Also

GH_Chunk Class
TryGetGuid Overload
GH_IO.Serialization Namespace


TryGetInt32 Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..TryGetInt32 Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetInt32(String, Int32%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetInt32(String, Int32, Int32%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


TryGetInt32 Method (String, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetInt32 Method (String, Int32%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetInt32(
    string item_name,
    ref int value
)
Visual Basic
Public Function TryGetInt32 ( _
    item_name As String, _
    ByRef value As Integer _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: System..::..Int32 %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetInt32(String, Int32%)

See Also

GH_Chunk Class
TryGetInt32 Overload
GH_IO.Serialization Namespace


TryGetInt32 Method (String, Int32, Int32)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetInt32 Method (String, Int32, Int32%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetInt32(
    string item_name,
    int item_index,
    ref int value
)
Visual Basic
Public Function TryGetInt32 ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As Integer _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: System..::..Int32 %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetInt32(String, Int32, Int32%)

See Also

GH_Chunk Class
TryGetInt32 Overload
GH_IO.Serialization Namespace


TryGetInt64 Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..TryGetInt64 Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetInt64(String, Int64%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetInt64(String, Int32, Int64%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


TryGetInt64 Method (String, Int64)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetInt64 Method (String, Int64%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetInt64(
    string item_name,
    ref long value
)
Visual Basic
Public Function TryGetInt64 ( _
    item_name As String, _
    ByRef value As Long _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: System..::..Int64 %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetInt64(String, Int64%)

See Also

GH_Chunk Class
TryGetInt64 Overload
GH_IO.Serialization Namespace


TryGetInt64 Method (String, Int32, Int64)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetInt64 Method (String, Int32, Int64%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetInt64(
    string item_name,
    int item_index,
    ref long value
)
Visual Basic
Public Function TryGetInt64 ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As Long _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: System..::..Int64 %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetInt64(String, Int32, Int64%)

See Also

GH_Chunk Class
TryGetInt64 Overload
GH_IO.Serialization Namespace


TryGetInterval1D Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..TryGetInterval1D Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetInterval1D(String, GH_Interval1D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetInterval1D(String, Int32, GH_Interval1D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


TryGetInterval1D Method (String, GH_Interval1D)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetInterval1D Method (String, GH_Interval1D%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetInterval1D(
    string item_name,
    ref GH_Interval1D value
)
Visual Basic
Public Function TryGetInterval1D ( _
    item_name As String, _
    ByRef value As GH_Interval1D _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: GH_IO.Types..::..GH_Interval1D %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetInterval1D(String, GH_Interval1D%)

See Also

GH_Chunk Class
TryGetInterval1D Overload
GH_IO.Serialization Namespace


TryGetInterval1D Method (String, Int32, GH_Interval1D)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetInterval1D Method (String, Int32, GH_Interval1D%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetInterval1D(
    string item_name,
    int item_index,
    ref GH_Interval1D value
)
Visual Basic
Public Function TryGetInterval1D ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As GH_Interval1D _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: GH_IO.Types..::..GH_Interval1D %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetInterval1D(String, Int32, GH_Interval1D%)

See Also

GH_Chunk Class
TryGetInterval1D Overload
GH_IO.Serialization Namespace


TryGetInterval2D Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..TryGetInterval2D Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetInterval2D(String, GH_Interval2D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetInterval2D(String, Int32, GH_Interval2D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


TryGetInterval2D Method (String, GH_Interval2D)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetInterval2D Method (String, GH_Interval2D%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetInterval2D(
    string item_name,
    ref GH_Interval2D value
)
Visual Basic
Public Function TryGetInterval2D ( _
    item_name As String, _
    ByRef value As GH_Interval2D _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: GH_IO.Types..::..GH_Interval2D %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetInterval2D(String, GH_Interval2D%)

See Also

GH_Chunk Class
TryGetInterval2D Overload
GH_IO.Serialization Namespace


TryGetInterval2D Method (String, Int32, GH_Interval2D)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetInterval2D Method (String, Int32, GH_Interval2D%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetInterval2D(
    string item_name,
    int item_index,
    ref GH_Interval2D value
)
Visual Basic
Public Function TryGetInterval2D ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As GH_Interval2D _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: GH_IO.Types..::..GH_Interval2D %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetInterval2D(String, Int32, GH_Interval2D%)

See Also

GH_Chunk Class
TryGetInterval2D Overload
GH_IO.Serialization Namespace


TryGetLine Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..TryGetLine Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetLine(String, GH_Line%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetLine(String, Int32, GH_Line%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


TryGetLine Method (String, GH_Line)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetLine Method (String, GH_Line%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetLine(
    string item_name,
    ref GH_Line value
)
Visual Basic
Public Function TryGetLine ( _
    item_name As String, _
    ByRef value As GH_Line _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: GH_IO.Types..::..GH_Line %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetLine(String, GH_Line%)

See Also

GH_Chunk Class
TryGetLine Overload
GH_IO.Serialization Namespace


TryGetLine Method (String, Int32, GH_Line)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetLine Method (String, Int32, GH_Line%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetLine(
    string item_name,
    int item_index,
    ref GH_Line value
)
Visual Basic
Public Function TryGetLine ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As GH_Line _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: GH_IO.Types..::..GH_Line %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetLine(String, Int32, GH_Line%)

See Also

GH_Chunk Class
TryGetLine Overload
GH_IO.Serialization Namespace


TryGetPlane Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..TryGetPlane Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetPlane(String, GH_Plane%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetPlane(String, Int32, GH_Plane%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


TryGetPlane Method (String, GH_Plane)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetPlane Method (String, GH_Plane%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetPlane(
    string item_name,
    ref GH_Plane value
)
Visual Basic
Public Function TryGetPlane ( _
    item_name As String, _
    ByRef value As GH_Plane _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: GH_IO.Types..::..GH_Plane %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetPlane(String, GH_Plane%)

See Also

GH_Chunk Class
TryGetPlane Overload
GH_IO.Serialization Namespace


TryGetPlane Method (String, Int32, GH_Plane)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetPlane Method (String, Int32, GH_Plane%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetPlane(
    string item_name,
    int item_index,
    ref GH_Plane value
)
Visual Basic
Public Function TryGetPlane ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As GH_Plane _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: GH_IO.Types..::..GH_Plane %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetPlane(String, Int32, GH_Plane%)

See Also

GH_Chunk Class
TryGetPlane Overload
GH_IO.Serialization Namespace


TryGetPoint2D Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..TryGetPoint2D Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetPoint2D(String, GH_Point2D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetPoint2D(String, Int32, GH_Point2D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


TryGetPoint2D Method (String, GH_Point2D)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetPoint2D Method (String, GH_Point2D%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetPoint2D(
    string item_name,
    ref GH_Point2D value
)
Visual Basic
Public Function TryGetPoint2D ( _
    item_name As String, _
    ByRef value As GH_Point2D _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: GH_IO.Types..::..GH_Point2D %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetPoint2D(String, GH_Point2D%)

See Also

GH_Chunk Class
TryGetPoint2D Overload
GH_IO.Serialization Namespace


TryGetPoint2D Method (String, Int32, GH_Point2D)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetPoint2D Method (String, Int32, GH_Point2D%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetPoint2D(
    string item_name,
    int item_index,
    ref GH_Point2D value
)
Visual Basic
Public Function TryGetPoint2D ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As GH_Point2D _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: GH_IO.Types..::..GH_Point2D %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetPoint2D(String, Int32, GH_Point2D%)

See Also

GH_Chunk Class
TryGetPoint2D Overload
GH_IO.Serialization Namespace


TryGetPoint3D Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..TryGetPoint3D Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetPoint3D(String, GH_Point3D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetPoint3D(String, Int32, GH_Point3D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


TryGetPoint3D Method (String, GH_Point3D)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetPoint3D Method (String, GH_Point3D%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetPoint3D(
    string item_name,
    ref GH_Point3D value
)
Visual Basic
Public Function TryGetPoint3D ( _
    item_name As String, _
    ByRef value As GH_Point3D _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: GH_IO.Types..::..GH_Point3D %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetPoint3D(String, GH_Point3D%)

See Also

GH_Chunk Class
TryGetPoint3D Overload
GH_IO.Serialization Namespace


TryGetPoint3D Method (String, Int32, GH_Point3D)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetPoint3D Method (String, Int32, GH_Point3D%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetPoint3D(
    string item_name,
    int item_index,
    ref GH_Point3D value
)
Visual Basic
Public Function TryGetPoint3D ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As GH_Point3D _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: GH_IO.Types..::..GH_Point3D %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetPoint3D(String, Int32, GH_Point3D%)

See Also

GH_Chunk Class
TryGetPoint3D Overload
GH_IO.Serialization Namespace


TryGetPoint4D Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..TryGetPoint4D Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetPoint4D(String, GH_Point4D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetPoint4D(String, Int32, GH_Point4D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


TryGetPoint4D Method (String, GH_Point4D)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetPoint4D Method (String, GH_Point4D%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetPoint4D(
    string item_name,
    ref GH_Point4D value
)
Visual Basic
Public Function TryGetPoint4D ( _
    item_name As String, _
    ByRef value As GH_Point4D _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: GH_IO.Types..::..GH_Point4D %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetPoint4D(String, GH_Point4D%)

See Also

GH_Chunk Class
TryGetPoint4D Overload
GH_IO.Serialization Namespace


TryGetPoint4D Method (String, Int32, GH_Point4D)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetPoint4D Method (String, Int32, GH_Point4D%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetPoint4D(
    string item_name,
    int item_index,
    ref GH_Point4D value
)
Visual Basic
Public Function TryGetPoint4D ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As GH_Point4D _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: GH_IO.Types..::..GH_Point4D %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetPoint4D(String, Int32, GH_Point4D%)

See Also

GH_Chunk Class
TryGetPoint4D Overload
GH_IO.Serialization Namespace


TryGetSingle Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..TryGetSingle Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetSingle(String, Single%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetSingle(String, Int32, Single%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


TryGetSingle Method (String, Single)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetSingle Method (String, Single%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetSingle(
    string item_name,
    ref float value
)
Visual Basic
Public Function TryGetSingle ( _
    item_name As String, _
    ByRef value As Single _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: System..::..Single %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetSingle(String, Single%)

See Also

GH_Chunk Class
TryGetSingle Overload
GH_IO.Serialization Namespace


TryGetSingle Method (String, Int32, Single)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetSingle Method (String, Int32, Single%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetSingle(
    string item_name,
    int item_index,
    ref float value
)
Visual Basic
Public Function TryGetSingle ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As Single _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: System..::..Single %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetSingle(String, Int32, Single%)

See Also

GH_Chunk Class
TryGetSingle Overload
GH_IO.Serialization Namespace


TryGetString Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..TryGetString Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetString(String, String%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetString(String, Int32, String%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


TryGetString Method (String, String)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetString Method (String, String%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetString(
    string item_name,
    ref string value
)
Visual Basic
Public Function TryGetString ( _
    item_name As String, _
    ByRef value As String _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: System..::..String %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetString(String, String%)

See Also

GH_Chunk Class
TryGetString Overload
GH_IO.Serialization Namespace


TryGetString Method (String, Int32, String)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetString Method (String, Int32, String%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetString(
    string item_name,
    int item_index,
    ref string value
)
Visual Basic
Public Function TryGetString ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As String _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: System..::..String %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetString(String, Int32, String%)

See Also

GH_Chunk Class
TryGetString Overload
GH_IO.Serialization Namespace


TryGetVersion Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..TryGetVersion Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetVersion(String, GH_Version%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetVersion(String, Int32, GH_Version%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


TryGetVersion Method (String, GH_Version)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetVersion Method (String, GH_Version%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetVersion(
    string item_name,
    ref GH_Version value
)
Visual Basic
Public Function TryGetVersion ( _
    item_name As String, _
    ByRef value As GH_Version _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: GH_IO.Types..::..GH_Version %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetVersion(String, GH_Version%)

See Also

GH_Chunk Class
TryGetVersion Overload
GH_IO.Serialization Namespace


TryGetVersion Method (String, Int32, GH_Version)

[image]

Grasshopper SDK
GH_Chunk..::..TryGetVersion Method (String, Int32, GH_Version%)
GH_Chunk Class See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool TryGetVersion(
    string item_name,
    int item_index,
    ref GH_Version value
)
Visual Basic
Public Function TryGetVersion ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As GH_Version _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: GH_IO.Types..::..GH_Version %
Target of assignment.

Return Value

True if the value was set.

Implements

GH_IReader..::..TryGetVersion(String, Int32, GH_Version%)

See Also

GH_Chunk Class
TryGetVersion Overload
GH_IO.Serialization Namespace


Write Method

[image] [image]

Grasshopper SDK
GH_Chunk..::..Write Method
GH_Chunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Write(BinaryWriter) | Write this chunk and all child chunks to a binary stream.
Public method | Write(XmlWriter) | Serialize this chunk into an Xml stream.

See Also

GH_Chunk Class
GH_Chunk Members
GH_IO.Serialization Namespace


Write Method (BinaryWriter)

[image]

Grasshopper SDK
GH_Chunk..::..Write Method (BinaryWriter)
GH_Chunk Class See Also Send Feedback
Write this chunk and all child chunks to a binary stream.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void Write(
    BinaryWriter writer
)
Visual Basic
Public Sub Write ( _
    writer As BinaryWriter _
)

Parameters

writer
Type: System.IO..::..BinaryWriter
The Binary writer to use, cannot be null.

Implements

GH_IBinarySupport..::..Write(BinaryWriter)

Exceptions

Exception | Condition
System..::..MemberAccessException | Thrown if the name of this chunk is either null or empty.

See Also

GH_Chunk Class
Write Overload
GH_IO.Serialization Namespace


Write Method (XmlWriter)

[image]

Grasshopper SDK
GH_Chunk..::..Write Method (XmlWriter)
GH_Chunk Class See Also Send Feedback
Serialize this chunk into an Xml stream.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void Write(
    XmlWriter writer
)
Visual Basic
Public Sub Write ( _
    writer As XmlWriter _
)

Parameters

writer
Type: System.Xml..::..XmlWriter
Xml writer used for serialization.

Implements

GH_IXmlSupport..::..Write(XmlWriter)

Exceptions

Exception | Condition
System..::..MemberAccessException | Thrown if

See Also

GH_Chunk Class
Write Overload
GH_IO.Serialization Namespace


GH_Chunk Properties

[image] [image]

Grasshopper SDK
GH_Chunk Properties
GH_Chunk Class See Also Send Feedback

The GH_Chunk type exposes the following members.

Properties

 | Name | Description
Public property | Archive | Gets a pointer to the archive that owns the Root of the tree this chunk belongs to.
Public property | ArchiveLocation | Gets a string representing the URI with which the archive is associated. The location may be a null string.
Public property | ChunkCount | Gets the number of child chunks contained in this chunk. The set of all child chunks is referred to as a 'litter'.
Public property | Chunks | Gets a pointer to the internal list of child chunks. Do not access this list unless you know what you are doing.
Public property | HasComments | Gets a value that indicates whether or not comments have been stored in this chunk.
Public property | HasIndex | Gets the index existence implication. The item is considered to have an index qualifier if the index value is larger than or equal to zero.
Public property | HasName | Gets the name validity of this item. The item is considered to have an invalid name if string.IsNullOrEmpty(name)
Public property | Index | Gets the index of this chunk. The index is set by the owner of this chunk. Indices smaller than zero imply no index has been set. The combination of name+index is always unique among a set of chunks in the same litter.
Public property | ItemCount | Gets the number of items contained in this chunk.
Public property | Items | Gets a pointer to the internal list of items. Do not access this list unless you know what you are doing.
Public property | Name | Gets the name of this chunk. The name is set by the owner of this chunk. Names must be at least 1 character long. The combination of name+index is always unique among a set of chunks in a single litter.

See Also

GH_Chunk Class
GH_IO.Serialization Namespace


Archive Property

[image]

Grasshopper SDK
GH_Chunk..::..Archive Property
GH_Chunk Class See Also Send Feedback
Gets a pointer to the archive that owns the Root of the tree this chunk belongs to.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Archive Archive { get; }
Visual Basic
Public ReadOnly Property Archive As GH_Archive
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Serialization.GH_Chunk.Archive"]

Implements

GH_IChunk..::..Archive

See Also

GH_Chunk Class
GH_IO.Serialization Namespace


ArchiveLocation Property

[image]

Grasshopper SDK
GH_Chunk..::..ArchiveLocation Property
GH_Chunk Class See Also Send Feedback
Gets a string representing the URI with which the archive is associated. The location may be a null string.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public string ArchiveLocation { get; }
Visual Basic
Public ReadOnly Property ArchiveLocation As String
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Serialization.GH_Chunk.ArchiveLocation"]

Implements

GH_IChunk..::..ArchiveLocation

See Also

GH_Chunk Class
GH_IO.Serialization Namespace


ChunkCount Property

[image]

Grasshopper SDK
GH_Chunk..::..ChunkCount Property
GH_Chunk Class See Also Send Feedback
Gets the number of child chunks contained in this chunk. The set of all child chunks is referred to as a 'litter'.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public int ChunkCount { get; }
Visual Basic
Public ReadOnly Property ChunkCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Serialization.GH_Chunk.ChunkCount"]

Implements

GH_IChunk..::..ChunkCount

See Also

GH_Chunk Class
GH_IO.Serialization Namespace


Chunks Property

[image]

Grasshopper SDK
GH_Chunk..::..Chunks Property
GH_Chunk Class See Also Send Feedback
Gets a pointer to the internal list of child chunks. Do not access this list unless you know what you are doing.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public List<GH_IChunk> Chunks { get; }
Visual Basic
Public ReadOnly Property Chunks As List(Of GH_IChunk)
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Serialization.GH_Chunk.Chunks"]

Implements

GH_IChunk..::..Chunks

See Also

GH_Chunk Class
GH_IO.Serialization Namespace


HasComments Property

[image]

Grasshopper SDK
GH_Chunk..::..HasComments Property
GH_Chunk Class See Also Send Feedback
Gets a value that indicates whether or not comments have been stored in this chunk.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool HasComments { get; }
Visual Basic
Public ReadOnly Property HasComments As Boolean
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Serialization.GH_Chunk.HasComments"]

See Also

GH_Chunk Class
GH_IO.Serialization Namespace


HasIndex Property

[image]

Grasshopper SDK
GH_Chunk..::..HasIndex Property
GH_Chunk Class See Also Send Feedback
Gets the index existence implication. The item is considered to have an index qualifier if the index value is larger than or equal to zero.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool HasIndex { get; }
Visual Basic
Public ReadOnly Property HasIndex As Boolean
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Serialization.GH_Chunk.HasIndex"]

See Also

GH_Chunk Class
GH_IO.Serialization Namespace


HasName Property

[image]

Grasshopper SDK
GH_Chunk..::..HasName Property
GH_Chunk Class See Also Send Feedback
Gets the name validity of this item. The item is considered to have an invalid name if string.IsNullOrEmpty(name)

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool HasName { get; }
Visual Basic
Public ReadOnly Property HasName As Boolean
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Serialization.GH_Chunk.HasName"]

See Also

GH_Chunk Class
GH_IO.Serialization Namespace


Index Property

[image]

Grasshopper SDK
GH_Chunk..::..Index Property
GH_Chunk Class See Also Send Feedback
Gets the index of this chunk. The index is set by the owner of this chunk. Indices smaller than zero imply no index has been set. The combination of name+index is always unique among a set of chunks in the same litter.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public int Index { get; }
Visual Basic
Public ReadOnly Property Index As Integer
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Serialization.GH_Chunk.Index"]

Implements

GH_IChunk..::..Index

See Also

GH_Chunk Class
GH_IO.Serialization Namespace


ItemCount Property

[image]

Grasshopper SDK
GH_Chunk..::..ItemCount Property
GH_Chunk Class See Also Send Feedback
Gets the number of items contained in this chunk.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public int ItemCount { get; }
Visual Basic
Public ReadOnly Property ItemCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Serialization.GH_Chunk.ItemCount"]

Implements

GH_IChunk..::..ItemCount

See Also

GH_Chunk Class
GH_IO.Serialization Namespace


Items Property

[image]

Grasshopper SDK
GH_Chunk..::..Items Property
GH_Chunk Class See Also Send Feedback
Gets a pointer to the internal list of items. Do not access this list unless you know what you are doing.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public List<GH_Item> Items { get; }
Visual Basic
Public ReadOnly Property Items As List(Of GH_Item)
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Serialization.GH_Chunk.Items"]

Implements

GH_IChunk..::..Items

See Also

GH_Chunk Class
GH_IO.Serialization Namespace


Name Property

[image]

Grasshopper SDK
GH_Chunk..::..Name Property
GH_Chunk Class See Also Send Feedback
Gets the name of this chunk. The name is set by the owner of this chunk. Names must be at least 1 character long. The combination of name+index is always unique among a set of chunks in a single litter.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Serialization.GH_Chunk.Name"]

Implements

GH_IChunk..::..Name

See Also

GH_Chunk Class
GH_IO.Serialization Namespace


GH_Compression Class

[image]

Grasshopper SDK
GH_Compression Class
Members See Also Send Feedback
Provides static methods for compression of byte-arrays.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public sealed class GH_Compression
Visual Basic
Public NotInheritable Class GH_Compression

Inheritance Hierarchy

System..::..Object
GH_IO.Serialization..::..GH_Compression

See Also

GH_Compression Members
GH_IO.Serialization Namespace


GH_Compression Members

[image] [image]

Grasshopper SDK
GH_Compression Members
GH_Compression Class Methods See Also Send Feedback

The GH_Compression type exposes the following members.

Methods

Name | Description
Compress | Compress an array of bytes using the Deflate algorithm.
Decompress | Decompress an array of bytes using the Deflate algorithm.

See Also

GH_Compression Class
GH_IO.Serialization Namespace


GH_Compression Methods

[image] [image]

Grasshopper SDK
GH_Compression Methods
GH_Compression Class See Also Send Feedback

The GH_Compression type exposes the following members.

Methods

Name | Description
Compress | Compress an array of bytes using the Deflate algorithm.
Decompress | Decompress an array of bytes using the Deflate algorithm.

See Also

GH_Compression Class
GH_IO.Serialization Namespace


Compress Method

[image]

Grasshopper SDK
GH_Compression..::..Compress Method
GH_Compression Class See Also Send Feedback
Compress an array of bytes using the Deflate algorithm.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public static byte[] Compress(
    byte[] data
)
Visual Basic
Public Shared Function Compress ( _
    data As Byte() _
) As Byte()

Parameters

data
Type: array< System..::..Byte >[]()[][]
Byte array to compress.

Return Value

An array of compressed bytes.

See Also

GH_Compression Class
GH_IO.Serialization Namespace


Decompress Method

[image]

Grasshopper SDK
GH_Compression..::..Decompress Method
GH_Compression Class See Also Send Feedback
Decompress an array of bytes using the Deflate algorithm.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public static byte[] Decompress(
    byte[] compressedData
)
Visual Basic
Public Shared Function Decompress ( _
    compressedData As Byte() _
) As Byte()

Parameters

compressedData
Type: array< System..::..Byte >[]()[][]
Byte array to decompress.

Return Value

An array of decompressed bytes.

See Also

GH_Compression Class
GH_IO.Serialization Namespace


GH_IBinarySupport Interface

[image]

Grasshopper SDK
GH_IBinarySupport Interface
Members See Also Send Feedback
Interface which declares all methods required for objects that can be (de)serialized to and from a binary archive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public interface GH_IBinarySupport
Visual Basic
Public Interface GH_IBinarySupport

See Also

GH_IBinarySupport Members
GH_IO.Serialization Namespace


GH_IBinarySupport Members

[image] [image]

Grasshopper SDK
GH_IBinarySupport Members
GH_IBinarySupport Interface Methods See Also Send Feedback

The GH_IBinarySupport type exposes the following members.

Methods

 | Name | Description
Public method | Read | Called when an object is required to deserialize itself.
Public method | Write | Called when an object is required to serialize itself.

See Also

GH_IBinarySupport Interface
GH_IO.Serialization Namespace


GH_IBinarySupport Methods

[image] [image]

Grasshopper SDK
GH_IBinarySupport Methods
GH_IBinarySupport Interface See Also Send Feedback

The GH_IBinarySupport type exposes the following members.

Methods

 | Name | Description
Public method | Read | Called when an object is required to deserialize itself.
Public method | Write | Called when an object is required to serialize itself.

See Also

GH_IBinarySupport Interface
GH_IO.Serialization Namespace


Read Method

[image]

Grasshopper SDK
GH_IBinarySupport..::..Read Method
GH_IBinarySupport Interface See Also Send Feedback
Called when an object is required to deserialize itself.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void Read(
    BinaryReader reader
)
Visual Basic
Sub Read ( _
    reader As BinaryReader _
)

Parameters

reader
Type: System.IO..::..BinaryReader
Reader object to be used for deserialization.

See Also

GH_IBinarySupport Interface
GH_IO.Serialization Namespace


Write Method

[image]

Grasshopper SDK
GH_IBinarySupport..::..Write Method
GH_IBinarySupport Interface See Also Send Feedback
Called when an object is required to serialize itself.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void Write(
    BinaryWriter writer
)
Visual Basic
Sub Write ( _
    writer As BinaryWriter _
)

Parameters

writer
Type: System.IO..::..BinaryWriter
Writer object to be used for serialization.

See Also

GH_IBinarySupport Interface
GH_IO.Serialization Namespace


GH_IChunk Interface

[image]

Grasshopper SDK
GH_IChunk Interface
Members See Also Send Feedback
Base interface for all Archive Chunks.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public interface GH_IChunk : GH_IBinarySupport,
    GH_IXmlSupport
Visual Basic
Public Interface GH_IChunk _
    Inherits GH_IBinarySupport, GH_IXmlSupport

See Also

GH_IChunk Members
GH_IO.Serialization Namespace


GH_IChunk Members

[image] [image]

Grasshopper SDK
GH_IChunk Members
GH_IChunk Interface Methods Properties See Also Send Feedback

The GH_IChunk type exposes the following members.

Methods

 | Name | Description
Public method | AddMessage | Log a new message with the top-level archive. Messages are collected during read/write operations, and can be displayed to the user upon completion using GH_Archive.ShowMessageLog().
Public method | Read(BinaryReader) | Called when an object is required to deserialize itself. (Inherited from GH_IBinarySupport.)
Public method | Read(XmlNode) | Called when an object is required to deserialize itself. (Inherited from GH_IXmlSupport.)
Public method | Write(BinaryWriter) | Called when an object is required to serialize itself. (Inherited from GH_IBinarySupport.)
Public method | Write(XmlWriter) | Called when an object is required to serialize itself. (Inherited from GH_IXmlSupport.)

Properties

 | Name | Description
Public property | Archive | Gets a pointer to the archive that owns the Root of the tree this chunk belongs to.
Public property | ArchiveLocation | Gets a string representing the URI with which the archive is associated. The location may be a null string.
Public property | ChunkCount | Gets the number of child chunks contained in this chunk. The set of all child chunks is referred to as a 'litter'.
Public property | Chunks | Gets a pointer to the internal list of child chunks. Do not access this list unless you know what you are doing.
Public property | Index | Gets the index of this chunk. The index is set by the owner of this chunk. Indices smaller than zero imply no index has been set. The combination of name+index is always unique among a set of chunks in the same litter.
Public property | ItemCount | Gets the number of items contained in this chunk.
Public property | Items | Gets a pointer to the internal list of items. Do not access this list unless you know what you are doing.
Public property | Name | Gets the name of this chunk. The name is set by the owner of this chunk. Names must be at least 1 character long. The combination of name+index is always unique among a set of chunks in a single litter.

See Also

GH_IChunk Interface
GH_IO.Serialization Namespace


GH_IChunk Methods

[image] [image]

Grasshopper SDK
GH_IChunk Methods
GH_IChunk Interface See Also Send Feedback

The GH_IChunk type exposes the following members.

Methods

 | Name | Description
Public method | AddMessage | Log a new message with the top-level archive. Messages are collected during read/write operations, and can be displayed to the user upon completion using GH_Archive.ShowMessageLog().
Public method | Read(BinaryReader) | Called when an object is required to deserialize itself. (Inherited from GH_IBinarySupport.)
Public method | Read(XmlNode) | Called when an object is required to deserialize itself. (Inherited from GH_IXmlSupport.)
Public method | Write(BinaryWriter) | Called when an object is required to serialize itself. (Inherited from GH_IBinarySupport.)
Public method | Write(XmlWriter) | Called when an object is required to serialize itself. (Inherited from GH_IXmlSupport.)

See Also

GH_IChunk Interface
GH_IO.Serialization Namespace


AddMessage Method

[image]

Grasshopper SDK
GH_IChunk..::..AddMessage Method
GH_IChunk Interface See Also Send Feedback
Log a new message with the top-level archive. Messages are collected during read/write operations, and can be displayed to the user upon completion using GH_Archive.ShowMessageLog().

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void AddMessage(
    string m,
    GH_Message_Type t
)
Visual Basic
Sub AddMessage ( _
    m As String, _
    t As GH_Message_Type _
)

Parameters

m
Type: System..::..String
Message text.
t
Type: GH_IO.Serialization..::..GH_Message_Type
Message type.

See Also

GH_IChunk Interface
GH_IO.Serialization Namespace


Read Method

[image] [image]

Grasshopper SDK
GH_IChunk..::..Read Method
GH_IChunk Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | Read(BinaryReader) | Called when an object is required to deserialize itself. (Inherited from GH_IBinarySupport.)
Public method | Read(XmlNode) | Called when an object is required to deserialize itself. (Inherited from GH_IXmlSupport.)

See Also

GH_IChunk Interface
GH_IChunk Members
GH_IO.Serialization Namespace


Write Method

[image] [image]

Grasshopper SDK
GH_IChunk..::..Write Method
GH_IChunk Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | Write(BinaryWriter) | Called when an object is required to serialize itself. (Inherited from GH_IBinarySupport.)
Public method | Write(XmlWriter) | Called when an object is required to serialize itself. (Inherited from GH_IXmlSupport.)

See Also

GH_IChunk Interface
GH_IChunk Members
GH_IO.Serialization Namespace


GH_IChunk Properties

[image] [image]

Grasshopper SDK
GH_IChunk Properties
GH_IChunk Interface See Also Send Feedback

The GH_IChunk type exposes the following members.

Properties

 | Name | Description
Public property | Archive | Gets a pointer to the archive that owns the Root of the tree this chunk belongs to.
Public property | ArchiveLocation | Gets a string representing the URI with which the archive is associated. The location may be a null string.
Public property | ChunkCount | Gets the number of child chunks contained in this chunk. The set of all child chunks is referred to as a 'litter'.
Public property | Chunks | Gets a pointer to the internal list of child chunks. Do not access this list unless you know what you are doing.
Public property | Index | Gets the index of this chunk. The index is set by the owner of this chunk. Indices smaller than zero imply no index has been set. The combination of name+index is always unique among a set of chunks in the same litter.
Public property | ItemCount | Gets the number of items contained in this chunk.
Public property | Items | Gets a pointer to the internal list of items. Do not access this list unless you know what you are doing.
Public property | Name | Gets the name of this chunk. The name is set by the owner of this chunk. Names must be at least 1 character long. The combination of name+index is always unique among a set of chunks in a single litter.

See Also

GH_IChunk Interface
GH_IO.Serialization Namespace


Archive Property

[image]

Grasshopper SDK
GH_IChunk..::..Archive Property
GH_IChunk Interface See Also Send Feedback
Gets a pointer to the archive that owns the Root of the tree this chunk belongs to.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
GH_Archive Archive { get; }
Visual Basic
ReadOnly Property Archive As GH_Archive
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Serialization.GH_IChunk.Archive"]

See Also

GH_IChunk Interface
GH_IO.Serialization Namespace


ArchiveLocation Property

[image]

Grasshopper SDK
GH_IChunk..::..ArchiveLocation Property
GH_IChunk Interface See Also Send Feedback
Gets a string representing the URI with which the archive is associated. The location may be a null string.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
string ArchiveLocation { get; }
Visual Basic
ReadOnly Property ArchiveLocation As String
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Serialization.GH_IChunk.ArchiveLocation"]

See Also

GH_IChunk Interface
GH_IO.Serialization Namespace


ChunkCount Property

[image]

Grasshopper SDK
GH_IChunk..::..ChunkCount Property
GH_IChunk Interface See Also Send Feedback
Gets the number of child chunks contained in this chunk. The set of all child chunks is referred to as a 'litter'.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
int ChunkCount { get; }
Visual Basic
ReadOnly Property ChunkCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Serialization.GH_IChunk.ChunkCount"]

See Also

GH_IChunk Interface
GH_IO.Serialization Namespace


Chunks Property

[image]

Grasshopper SDK
GH_IChunk..::..Chunks Property
GH_IChunk Interface See Also Send Feedback
Gets a pointer to the internal list of child chunks. Do not access this list unless you know what you are doing.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
List<GH_IChunk> Chunks { get; }
Visual Basic
ReadOnly Property Chunks As List(Of GH_IChunk)
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Serialization.GH_IChunk.Chunks"]

See Also

GH_IChunk Interface
GH_IO.Serialization Namespace


Index Property

[image]

Grasshopper SDK
GH_IChunk..::..Index Property
GH_IChunk Interface See Also Send Feedback
Gets the index of this chunk. The index is set by the owner of this chunk. Indices smaller than zero imply no index has been set. The combination of name+index is always unique among a set of chunks in the same litter.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
int Index { get; }
Visual Basic
ReadOnly Property Index As Integer
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Serialization.GH_IChunk.Index"]

See Also

GH_IChunk Interface
GH_IO.Serialization Namespace


ItemCount Property

[image]

Grasshopper SDK
GH_IChunk..::..ItemCount Property
GH_IChunk Interface See Also Send Feedback
Gets the number of items contained in this chunk.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
int ItemCount { get; }
Visual Basic
ReadOnly Property ItemCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Serialization.GH_IChunk.ItemCount"]

See Also

GH_IChunk Interface
GH_IO.Serialization Namespace


Items Property

[image]

Grasshopper SDK
GH_IChunk..::..Items Property
GH_IChunk Interface See Also Send Feedback
Gets a pointer to the internal list of items. Do not access this list unless you know what you are doing.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
List<GH_Item> Items { get; }
Visual Basic
ReadOnly Property Items As List(Of GH_Item)
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Serialization.GH_IChunk.Items"]

See Also

GH_IChunk Interface
GH_IO.Serialization Namespace


Name Property

[image]

Grasshopper SDK
GH_IChunk..::..Name Property
GH_IChunk Interface See Also Send Feedback
Gets the name of this chunk. The name is set by the owner of this chunk. Names must be at least 1 character long. The combination of name+index is always unique among a set of chunks in a single litter.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
string Name { get; }
Visual Basic
ReadOnly Property Name As String
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Serialization.GH_IChunk.Name"]

See Also

GH_IChunk Interface
GH_IO.Serialization Namespace


GH_IReader Interface

[image]

Grasshopper SDK
GH_IReader Interface
Members See Also Send Feedback
Provides access to a subset of GH_Chunk methods used for reading archives.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public interface GH_IReader : GH_IChunk,
    GH_IBinarySupport, GH_IXmlSupport
Visual Basic
Public Interface GH_IReader _
    Inherits GH_IChunk, GH_IBinarySupport, GH_IXmlSupport

See Also

GH_IReader Members
GH_IO.Serialization Namespace


GH_IReader Members

[image] [image]

Grasshopper SDK
GH_IReader Members
GH_IReader Interface Methods Properties See Also Send Feedback

The GH_IReader type exposes the following members.

Methods

 | Name | Description
Public method | AddMessage | Log a new message with the top-level archive. Messages are collected during read/write operations, and can be displayed to the user upon completion using GH_Archive.ShowMessageLog(). (Inherited from GH_IChunk.)
Public method | ChunkExists(String) | Checks whether a chunk with the specified name exists in the litter. Only chunks without index qualifiers are considered. Name comparisons are not case-sensitive.
Public method | ChunkExists(String, Int32) | Checks whether a chunk with the specified name and index exists in the litter. Only chunks with index qualifiers are considered. Name comparisons are not case-sensitive.
Public method | FindChunk(String) | Finds the first chunk in the litter that matches the given name. Only chunks without index qualifiers are considered.
Public method | FindChunk(String, Int32) | Finds the first chunk in the list that matches the given name and index. Only chunks with index qualifiers are considered.
Public method | FindItem(String) | Finds the first item that matches the given name. Only items without index qualifiers are considered. Name comparisons are not case-sensitive.
Public method | FindItem(String, Int32) | Finds the first item that matches the given name and index. Only items with index qualifiers are considered. Name comparisons are not case-sensitive.
Public method | GetBoolean(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetBoolean(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetBoundingBox(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetBoundingBox(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetByte(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetByte(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetByteArray(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetByteArray(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDate(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDate(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDecimal(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDecimal(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDouble(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDouble(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDoubleArray(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDoubleArray(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDrawingBitmap(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingBitmap(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDrawingColor(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingColor(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDrawingPoint(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingPoint(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDrawingPointF(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingPointF(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDrawingRectangle(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingRectangle(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDrawingRectangleF(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingRectangleF(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDrawingSize(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingSize(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDrawingSizeF(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingSizeF(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetGuid(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetGuid(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetInt32(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetInt32(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetInt64(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetInt64(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetInterval1D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetInterval1D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetInterval2D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetInterval2D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetLine(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetLine(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetPath(String, String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetPath(String, Int32, String) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetPlane(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetPlane(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetPoint2D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetPoint2D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetPoint3D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetPoint3D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetPoint4D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetPoint4D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetSingle(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetSingle(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetString(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetString(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetVersion(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetVersion(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | ItemExists(String) | Checks whether an item with the specified name exists. Only items without index qualifiers are considered. Name comparisons are not case-sensitive.
Public method | ItemExists(String, Int32) | Checks whether an item with the specified name and index exists. Only items with index qualifiers are considered. Name comparisons are not case-sensitive.
Public method | Read(BinaryReader) | Called when an object is required to deserialize itself. (Inherited from GH_IBinarySupport.)
Public method | Read(XmlNode) | Called when an object is required to deserialize itself. (Inherited from GH_IXmlSupport.)
Public method | TryGetBoolean(String, Boolean%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetBoolean(String, Int32, Boolean%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetBoundingBox(String, GH_BoundingBox%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetBoundingBox(String, Int32, GH_BoundingBox%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetByte(String, Byte%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetByte(String, Int32, Byte%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetDate(String, DateTime%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDate(String, Int32, DateTime%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetDecimal(String, Decimal%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDecimal(String, Int32, Decimal%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetDouble(String, Double%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDouble(String, Int32, Double%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetDrawingColor(String, Color%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingColor(String, Int32, Color%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetDrawingPoint(String, Point%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingPoint(String, Int32, Point%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetDrawingPointF(String, PointF%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingPointF(String, Int32, PointF%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetDrawingRectangle(String, Rectangle%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingRectangle(String, Int32, Rectangle%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetDrawingRectangleF(String, RectangleF%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingRectangleF(String, Int32, RectangleF%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetDrawingSize(String, Size%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingSize(String, Int32, Size%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetDrawingSizeF(String, SizeF%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingSizeF(String, Int32, SizeF%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetGuid(String, Guid%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetGuid(String, Int32, Guid%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetInt32(String, Int32%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetInt32(String, Int32, Int32%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetInt64(String, Int64%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetInt64(String, Int32, Int64%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetInterval1D(String, GH_Interval1D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetInterval1D(String, Int32, GH_Interval1D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetInterval2D(String, GH_Interval2D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetInterval2D(String, Int32, GH_Interval2D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetLine(String, GH_Line%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetLine(String, Int32, GH_Line%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetPlane(String, GH_Plane%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetPlane(String, Int32, GH_Plane%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetPoint2D(String, GH_Point2D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetPoint2D(String, Int32, GH_Point2D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetPoint3D(String, GH_Point3D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetPoint3D(String, Int32, GH_Point3D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetPoint4D(String, GH_Point4D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetPoint4D(String, Int32, GH_Point4D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetSingle(String, Single%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetSingle(String, Int32, Single%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetString(String, String%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetString(String, Int32, String%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetVersion(String, GH_Version%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetVersion(String, Int32, GH_Version%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | Write(BinaryWriter) | Called when an object is required to serialize itself. (Inherited from GH_IBinarySupport.)
Public method | Write(XmlWriter) | Called when an object is required to serialize itself. (Inherited from GH_IXmlSupport.)

Properties

 | Name | Description
Public property | Archive | Gets a pointer to the archive that owns the Root of the tree this chunk belongs to. (Inherited from GH_IChunk.)
Public property | ArchiveLocation | Gets a string representing the URI with which the archive is associated. The location may be a null string. (Inherited from GH_IChunk.)
Public property | ChunkCount | Gets the number of child chunks contained in this chunk. The set of all child chunks is referred to as a 'litter'. (Inherited from GH_IChunk.)
Public property | Chunks | Gets a pointer to the internal list of child chunks. Do not access this list unless you know what you are doing. (Inherited from GH_IChunk.)
Public property | Index | Gets the index of this chunk. The index is set by the owner of this chunk. Indices smaller than zero imply no index has been set. The combination of name+index is always unique among a set of chunks in the same litter. (Inherited from GH_IChunk.)
Public property | ItemCount | Gets the number of items contained in this chunk. (Inherited from GH_IChunk.)
Public property | Items | Gets a pointer to the internal list of items. Do not access this list unless you know what you are doing. (Inherited from GH_IChunk.)
Public property | Name | Gets the name of this chunk. The name is set by the owner of this chunk. Names must be at least 1 character long. The combination of name+index is always unique among a set of chunks in a single litter. (Inherited from GH_IChunk.)

See Also

GH_IReader Interface
GH_IO.Serialization Namespace


GH_IReader Methods

[image] [image]

Grasshopper SDK
GH_IReader Methods
GH_IReader Interface See Also Send Feedback

The GH_IReader type exposes the following members.

Methods

 | Name | Description
Public method | AddMessage | Log a new message with the top-level archive. Messages are collected during read/write operations, and can be displayed to the user upon completion using GH_Archive.ShowMessageLog(). (Inherited from GH_IChunk.)
Public method | ChunkExists(String) | Checks whether a chunk with the specified name exists in the litter. Only chunks without index qualifiers are considered. Name comparisons are not case-sensitive.
Public method | ChunkExists(String, Int32) | Checks whether a chunk with the specified name and index exists in the litter. Only chunks with index qualifiers are considered. Name comparisons are not case-sensitive.
Public method | FindChunk(String) | Finds the first chunk in the litter that matches the given name. Only chunks without index qualifiers are considered.
Public method | FindChunk(String, Int32) | Finds the first chunk in the list that matches the given name and index. Only chunks with index qualifiers are considered.
Public method | FindItem(String) | Finds the first item that matches the given name. Only items without index qualifiers are considered. Name comparisons are not case-sensitive.
Public method | FindItem(String, Int32) | Finds the first item that matches the given name and index. Only items with index qualifiers are considered. Name comparisons are not case-sensitive.
Public method | GetBoolean(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetBoolean(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetBoundingBox(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetBoundingBox(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetByte(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetByte(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetByteArray(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetByteArray(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDate(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDate(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDecimal(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDecimal(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDouble(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDouble(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDoubleArray(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDoubleArray(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDrawingBitmap(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingBitmap(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDrawingColor(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingColor(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDrawingPoint(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingPoint(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDrawingPointF(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingPointF(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDrawingRectangle(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingRectangle(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDrawingRectangleF(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingRectangleF(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDrawingSize(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingSize(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetDrawingSizeF(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingSizeF(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetGuid(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetGuid(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetInt32(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetInt32(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetInt64(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetInt64(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetInterval1D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetInterval1D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetInterval2D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetInterval2D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetLine(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetLine(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetPath(String, String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetPath(String, Int32, String) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetPlane(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetPlane(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetPoint2D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetPoint2D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetPoint3D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetPoint3D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetPoint4D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetPoint4D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetSingle(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetSingle(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetString(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetString(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | GetVersion(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetVersion(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | ItemExists(String) | Checks whether an item with the specified name exists. Only items without index qualifiers are considered. Name comparisons are not case-sensitive.
Public method | ItemExists(String, Int32) | Checks whether an item with the specified name and index exists. Only items with index qualifiers are considered. Name comparisons are not case-sensitive.
Public method | Read(BinaryReader) | Called when an object is required to deserialize itself. (Inherited from GH_IBinarySupport.)
Public method | Read(XmlNode) | Called when an object is required to deserialize itself. (Inherited from GH_IXmlSupport.)
Public method | TryGetBoolean(String, Boolean%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetBoolean(String, Int32, Boolean%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetBoundingBox(String, GH_BoundingBox%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetBoundingBox(String, Int32, GH_BoundingBox%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetByte(String, Byte%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetByte(String, Int32, Byte%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetDate(String, DateTime%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDate(String, Int32, DateTime%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetDecimal(String, Decimal%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDecimal(String, Int32, Decimal%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetDouble(String, Double%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDouble(String, Int32, Double%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetDrawingColor(String, Color%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingColor(String, Int32, Color%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetDrawingPoint(String, Point%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingPoint(String, Int32, Point%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetDrawingPointF(String, PointF%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingPointF(String, Int32, PointF%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetDrawingRectangle(String, Rectangle%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingRectangle(String, Int32, Rectangle%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetDrawingRectangleF(String, RectangleF%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingRectangleF(String, Int32, RectangleF%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetDrawingSize(String, Size%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingSize(String, Int32, Size%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetDrawingSizeF(String, SizeF%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingSizeF(String, Int32, SizeF%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetGuid(String, Guid%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetGuid(String, Int32, Guid%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetInt32(String, Int32%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetInt32(String, Int32, Int32%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetInt64(String, Int64%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetInt64(String, Int32, Int64%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetInterval1D(String, GH_Interval1D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetInterval1D(String, Int32, GH_Interval1D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetInterval2D(String, GH_Interval2D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetInterval2D(String, Int32, GH_Interval2D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetLine(String, GH_Line%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetLine(String, Int32, GH_Line%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetPlane(String, GH_Plane%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetPlane(String, Int32, GH_Plane%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetPoint2D(String, GH_Point2D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetPoint2D(String, Int32, GH_Point2D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetPoint3D(String, GH_Point3D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetPoint3D(String, Int32, GH_Point3D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetPoint4D(String, GH_Point4D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetPoint4D(String, Int32, GH_Point4D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetSingle(String, Single%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetSingle(String, Int32, Single%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetString(String, String%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetString(String, Int32, String%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | TryGetVersion(String, GH_Version%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetVersion(String, Int32, GH_Version%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.
Public method | Write(BinaryWriter) | Called when an object is required to serialize itself. (Inherited from GH_IBinarySupport.)
Public method | Write(XmlWriter) | Called when an object is required to serialize itself. (Inherited from GH_IXmlSupport.)

See Also

GH_IReader Interface
GH_IO.Serialization Namespace


ChunkExists Method

[image] [image]

Grasshopper SDK
GH_IReader..::..ChunkExists Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | ChunkExists(String) | Checks whether a chunk with the specified name exists in the litter. Only chunks without index qualifiers are considered. Name comparisons are not case-sensitive.
Public method | ChunkExists(String, Int32) | Checks whether a chunk with the specified name and index exists in the litter. Only chunks with index qualifiers are considered. Name comparisons are not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


ChunkExists Method (String)

[image]

Grasshopper SDK
GH_IReader..::..ChunkExists Method (String)
GH_IReader Interface See Also Send Feedback
Checks whether a chunk with the specified name exists in the litter. Only chunks without index qualifiers are considered. Name comparisons are not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool ChunkExists(
    string name
)
Visual Basic
Function ChunkExists ( _
    name As String _
) As Boolean

Parameters

name
Type: System..::..String
Name of chunk to test for.

Return Value

True if a chunk with the specified name exists, otherwise false.

See Also

GH_IReader Interface
ChunkExists Overload
GH_IO.Serialization Namespace


ChunkExists Method (String, Int32)

[image]

Grasshopper SDK
GH_IReader..::..ChunkExists Method (String, Int32)
GH_IReader Interface See Also Send Feedback
Checks whether a chunk with the specified name and index exists in the litter. Only chunks with index qualifiers are considered. Name comparisons are not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool ChunkExists(
    string name,
    int index
)
Visual Basic
Function ChunkExists ( _
    name As String, _
    index As Integer _
) As Boolean

Parameters

name
Type: System..::..String
Name of chunk to test for.
index
Type: System..::..Int32
Index of chunk to test for. If less than zero, ChunkExists(string chunk_name) is called instead.

Return Value

True if a chunk with the specified name and index exists, otherwise false.

See Also

GH_IReader Interface
ChunkExists Overload
GH_IO.Serialization Namespace


FindChunk Method

[image] [image]

Grasshopper SDK
GH_IReader..::..FindChunk Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | FindChunk(String) | Finds the first chunk in the litter that matches the given name. Only chunks without index qualifiers are considered.
Public method | FindChunk(String, Int32) | Finds the first chunk in the list that matches the given name and index. Only chunks with index qualifiers are considered.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


FindChunk Method (String)

[image]

Grasshopper SDK
GH_IReader..::..FindChunk Method (String)
GH_IReader Interface See Also Send Feedback
Finds the first chunk in the litter that matches the given name. Only chunks without index qualifiers are considered.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
GH_IReader FindChunk(
    string name
)
Visual Basic
Function FindChunk ( _
    name As String _
) As GH_IReader

Parameters

name
Type: System..::..String
Name of chunk to search for.

Return Value

The child chunk that matches the given name, or null of no matching chunk could be found.

See Also

GH_IReader Interface
FindChunk Overload
GH_IO.Serialization Namespace


FindChunk Method (String, Int32)

[image]

Grasshopper SDK
GH_IReader..::..FindChunk Method (String, Int32)
GH_IReader Interface See Also Send Feedback
Finds the first chunk in the list that matches the given name and index. Only chunks with index qualifiers are considered.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
GH_IReader FindChunk(
    string name,
    int index
)
Visual Basic
Function FindChunk ( _
    name As String, _
    index As Integer _
) As GH_IReader

Parameters

name
Type: System..::..String
Name of chunk to search for.
index
Type: System..::..Int32
Index of chunk to search for. If less than zero, FindChunk(string chunk_name) is called instead.

Return Value

The child chunk that matches the given name and index, or null of no matching chunk could be found.

See Also

GH_IReader Interface
FindChunk Overload
GH_IO.Serialization Namespace


FindItem Method

[image] [image]

Grasshopper SDK
GH_IReader..::..FindItem Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | FindItem(String) | Finds the first item that matches the given name. Only items without index qualifiers are considered. Name comparisons are not case-sensitive.
Public method | FindItem(String, Int32) | Finds the first item that matches the given name and index. Only items with index qualifiers are considered. Name comparisons are not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


FindItem Method (String)

[image]

Grasshopper SDK
GH_IReader..::..FindItem Method (String)
GH_IReader Interface See Also Send Feedback
Finds the first item that matches the given name. Only items without index qualifiers are considered. Name comparisons are not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
GH_Item FindItem(
    string name
)
Visual Basic
Function FindItem ( _
    name As String _
) As GH_Item

Parameters

name
Type: System..::..String
Name of item to search for.

Return Value

The item that matches the given name, or null of no matching item could be found.

See Also

GH_IReader Interface
FindItem Overload
GH_IO.Serialization Namespace


FindItem Method (String, Int32)

[image]

Grasshopper SDK
GH_IReader..::..FindItem Method (String, Int32)
GH_IReader Interface See Also Send Feedback
Finds the first item that matches the given name and index. Only items with index qualifiers are considered. Name comparisons are not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
GH_Item FindItem(
    string name,
    int index
)
Visual Basic
Function FindItem ( _
    name As String, _
    index As Integer _
) As GH_Item

Parameters

name
Type: System..::..String
Name of item to search for.
index
Type: System..::..Int32
Index of item to search for. If less than zero, then FindItem(string name) is called instead.

Return Value

The item that matches the given name and index, or null of no matching item could be found.

See Also

GH_IReader Interface
FindItem Overload
GH_IO.Serialization Namespace


GetBoolean Method

[image] [image]

Grasshopper SDK
GH_IReader..::..GetBoolean Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetBoolean(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetBoolean(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


GetBoolean Method (String)

[image]

Grasshopper SDK
GH_IReader..::..GetBoolean Method (String)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool GetBoolean(
    string item_name
)
Visual Basic
Function GetBoolean ( _
    item_name As String _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_IReader Interface
GetBoolean Overload
GH_IO.Serialization Namespace


GetBoolean Method (String, Int32)

[image]

Grasshopper SDK
GH_IReader..::..GetBoolean Method (String, Int32)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool GetBoolean(
    string item_name,
    int item_index
)
Visual Basic
Function GetBoolean ( _
    item_name As String, _
    item_index As Integer _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_IReader Interface
GetBoolean Overload
GH_IO.Serialization Namespace


GetBoundingBox Method

[image] [image]

Grasshopper SDK
GH_IReader..::..GetBoundingBox Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetBoundingBox(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetBoundingBox(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


GetBoundingBox Method (String)

[image]

Grasshopper SDK
GH_IReader..::..GetBoundingBox Method (String)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
GH_BoundingBox GetBoundingBox(
    string item_name
)
Visual Basic
Function GetBoundingBox ( _
    item_name As String _
) As GH_BoundingBox

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_IReader Interface
GetBoundingBox Overload
GH_IO.Serialization Namespace


GetBoundingBox Method (String, Int32)

[image]

Grasshopper SDK
GH_IReader..::..GetBoundingBox Method (String, Int32)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
GH_BoundingBox GetBoundingBox(
    string item_name,
    int item_index
)
Visual Basic
Function GetBoundingBox ( _
    item_name As String, _
    item_index As Integer _
) As GH_BoundingBox

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_IReader Interface
GetBoundingBox Overload
GH_IO.Serialization Namespace


GetByte Method

[image] [image]

Grasshopper SDK
GH_IReader..::..GetByte Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetByte(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetByte(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


GetByte Method (String)

[image]

Grasshopper SDK
GH_IReader..::..GetByte Method (String)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
byte GetByte(
    string item_name
)
Visual Basic
Function GetByte ( _
    item_name As String _
) As Byte

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_IReader Interface
GetByte Overload
GH_IO.Serialization Namespace


GetByte Method (String, Int32)

[image]

Grasshopper SDK
GH_IReader..::..GetByte Method (String, Int32)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
byte GetByte(
    string item_name,
    int item_index
)
Visual Basic
Function GetByte ( _
    item_name As String, _
    item_index As Integer _
) As Byte

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_IReader Interface
GetByte Overload
GH_IO.Serialization Namespace


GetByteArray Method

[image] [image]

Grasshopper SDK
GH_IReader..::..GetByteArray Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetByteArray(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetByteArray(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


GetByteArray Method (String)

[image]

Grasshopper SDK
GH_IReader..::..GetByteArray Method (String)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
byte[] GetByteArray(
    string item_name
)
Visual Basic
Function GetByteArray ( _
    item_name As String _
) As Byte()

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_IReader Interface
GetByteArray Overload
GH_IO.Serialization Namespace


GetByteArray Method (String, Int32)

[image]

Grasshopper SDK
GH_IReader..::..GetByteArray Method (String, Int32)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
byte[] GetByteArray(
    string item_name,
    int item_index
)
Visual Basic
Function GetByteArray ( _
    item_name As String, _
    item_index As Integer _
) As Byte()

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_IReader Interface
GetByteArray Overload
GH_IO.Serialization Namespace


GetDate Method

[image] [image]

Grasshopper SDK
GH_IReader..::..GetDate Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDate(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDate(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


GetDate Method (String)

[image]

Grasshopper SDK
GH_IReader..::..GetDate Method (String)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
DateTime GetDate(
    string item_name
)
Visual Basic
Function GetDate ( _
    item_name As String _
) As DateTime

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_IReader Interface
GetDate Overload
GH_IO.Serialization Namespace


GetDate Method (String, Int32)

[image]

Grasshopper SDK
GH_IReader..::..GetDate Method (String, Int32)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
DateTime GetDate(
    string item_name,
    int item_index
)
Visual Basic
Function GetDate ( _
    item_name As String, _
    item_index As Integer _
) As DateTime

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_IReader Interface
GetDate Overload
GH_IO.Serialization Namespace


GetDecimal Method

[image] [image]

Grasshopper SDK
GH_IReader..::..GetDecimal Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDecimal(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDecimal(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


GetDecimal Method (String)

[image]

Grasshopper SDK
GH_IReader..::..GetDecimal Method (String)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
decimal GetDecimal(
    string item_name
)
Visual Basic
Function GetDecimal ( _
    item_name As String _
) As Decimal

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_IReader Interface
GetDecimal Overload
GH_IO.Serialization Namespace


GetDecimal Method (String, Int32)

[image]

Grasshopper SDK
GH_IReader..::..GetDecimal Method (String, Int32)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
decimal GetDecimal(
    string item_name,
    int item_index
)
Visual Basic
Function GetDecimal ( _
    item_name As String, _
    item_index As Integer _
) As Decimal

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_IReader Interface
GetDecimal Overload
GH_IO.Serialization Namespace


GetDouble Method

[image] [image]

Grasshopper SDK
GH_IReader..::..GetDouble Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDouble(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDouble(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


GetDouble Method (String)

[image]

Grasshopper SDK
GH_IReader..::..GetDouble Method (String)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
double GetDouble(
    string item_name
)
Visual Basic
Function GetDouble ( _
    item_name As String _
) As Double

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_IReader Interface
GetDouble Overload
GH_IO.Serialization Namespace


GetDouble Method (String, Int32)

[image]

Grasshopper SDK
GH_IReader..::..GetDouble Method (String, Int32)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
double GetDouble(
    string item_name,
    int item_index
)
Visual Basic
Function GetDouble ( _
    item_name As String, _
    item_index As Integer _
) As Double

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_IReader Interface
GetDouble Overload
GH_IO.Serialization Namespace


GetDoubleArray Method

[image] [image]

Grasshopper SDK
GH_IReader..::..GetDoubleArray Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDoubleArray(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDoubleArray(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


GetDoubleArray Method (String)

[image]

Grasshopper SDK
GH_IReader..::..GetDoubleArray Method (String)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
double[] GetDoubleArray(
    string item_name
)
Visual Basic
Function GetDoubleArray ( _
    item_name As String _
) As Double()

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_IReader Interface
GetDoubleArray Overload
GH_IO.Serialization Namespace


GetDoubleArray Method (String, Int32)

[image]

Grasshopper SDK
GH_IReader..::..GetDoubleArray Method (String, Int32)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
double[] GetDoubleArray(
    string item_name,
    int item_index
)
Visual Basic
Function GetDoubleArray ( _
    item_name As String, _
    item_index As Integer _
) As Double()

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_IReader Interface
GetDoubleArray Overload
GH_IO.Serialization Namespace


GetDrawingBitmap Method

[image] [image]

Grasshopper SDK
GH_IReader..::..GetDrawingBitmap Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDrawingBitmap(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingBitmap(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


GetDrawingBitmap Method (String)

[image]

Grasshopper SDK
GH_IReader..::..GetDrawingBitmap Method (String)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
Bitmap GetDrawingBitmap(
    string item_name
)
Visual Basic
Function GetDrawingBitmap ( _
    item_name As String _
) As Bitmap

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_IReader Interface
GetDrawingBitmap Overload
GH_IO.Serialization Namespace


GetDrawingBitmap Method (String, Int32)

[image]

Grasshopper SDK
GH_IReader..::..GetDrawingBitmap Method (String, Int32)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
Bitmap GetDrawingBitmap(
    string item_name,
    int item_index
)
Visual Basic
Function GetDrawingBitmap ( _
    item_name As String, _
    item_index As Integer _
) As Bitmap

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_IReader Interface
GetDrawingBitmap Overload
GH_IO.Serialization Namespace


GetDrawingColor Method

[image] [image]

Grasshopper SDK
GH_IReader..::..GetDrawingColor Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDrawingColor(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingColor(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


GetDrawingColor Method (String)

[image]

Grasshopper SDK
GH_IReader..::..GetDrawingColor Method (String)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
Color GetDrawingColor(
    string item_name
)
Visual Basic
Function GetDrawingColor ( _
    item_name As String _
) As Color

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_IReader Interface
GetDrawingColor Overload
GH_IO.Serialization Namespace


GetDrawingColor Method (String, Int32)

[image]

Grasshopper SDK
GH_IReader..::..GetDrawingColor Method (String, Int32)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
Color GetDrawingColor(
    string item_name,
    int item_index
)
Visual Basic
Function GetDrawingColor ( _
    item_name As String, _
    item_index As Integer _
) As Color

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_IReader Interface
GetDrawingColor Overload
GH_IO.Serialization Namespace


GetDrawingPoint Method

[image] [image]

Grasshopper SDK
GH_IReader..::..GetDrawingPoint Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDrawingPoint(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingPoint(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


GetDrawingPoint Method (String)

[image]

Grasshopper SDK
GH_IReader..::..GetDrawingPoint Method (String)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
Point GetDrawingPoint(
    string item_name
)
Visual Basic
Function GetDrawingPoint ( _
    item_name As String _
) As Point

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_IReader Interface
GetDrawingPoint Overload
GH_IO.Serialization Namespace


GetDrawingPoint Method (String, Int32)

[image]

Grasshopper SDK
GH_IReader..::..GetDrawingPoint Method (String, Int32)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
Point GetDrawingPoint(
    string item_name,
    int item_index
)
Visual Basic
Function GetDrawingPoint ( _
    item_name As String, _
    item_index As Integer _
) As Point

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_IReader Interface
GetDrawingPoint Overload
GH_IO.Serialization Namespace


GetDrawingPointF Method

[image] [image]

Grasshopper SDK
GH_IReader..::..GetDrawingPointF Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDrawingPointF(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingPointF(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


GetDrawingPointF Method (String)

[image]

Grasshopper SDK
GH_IReader..::..GetDrawingPointF Method (String)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
PointF GetDrawingPointF(
    string item_name
)
Visual Basic
Function GetDrawingPointF ( _
    item_name As String _
) As PointF

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_IReader Interface
GetDrawingPointF Overload
GH_IO.Serialization Namespace


GetDrawingPointF Method (String, Int32)

[image]

Grasshopper SDK
GH_IReader..::..GetDrawingPointF Method (String, Int32)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
PointF GetDrawingPointF(
    string item_name,
    int item_index
)
Visual Basic
Function GetDrawingPointF ( _
    item_name As String, _
    item_index As Integer _
) As PointF

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_IReader Interface
GetDrawingPointF Overload
GH_IO.Serialization Namespace


GetDrawingRectangle Method

[image] [image]

Grasshopper SDK
GH_IReader..::..GetDrawingRectangle Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDrawingRectangle(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingRectangle(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


GetDrawingRectangle Method (String)

[image]

Grasshopper SDK
GH_IReader..::..GetDrawingRectangle Method (String)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
Rectangle GetDrawingRectangle(
    string item_name
)
Visual Basic
Function GetDrawingRectangle ( _
    item_name As String _
) As Rectangle

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_IReader Interface
GetDrawingRectangle Overload
GH_IO.Serialization Namespace


GetDrawingRectangle Method (String, Int32)

[image]

Grasshopper SDK
GH_IReader..::..GetDrawingRectangle Method (String, Int32)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
Rectangle GetDrawingRectangle(
    string item_name,
    int item_index
)
Visual Basic
Function GetDrawingRectangle ( _
    item_name As String, _
    item_index As Integer _
) As Rectangle

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_IReader Interface
GetDrawingRectangle Overload
GH_IO.Serialization Namespace


GetDrawingRectangleF Method

[image] [image]

Grasshopper SDK
GH_IReader..::..GetDrawingRectangleF Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDrawingRectangleF(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingRectangleF(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


GetDrawingRectangleF Method (String)

[image]

Grasshopper SDK
GH_IReader..::..GetDrawingRectangleF Method (String)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
RectangleF GetDrawingRectangleF(
    string item_name
)
Visual Basic
Function GetDrawingRectangleF ( _
    item_name As String _
) As RectangleF

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_IReader Interface
GetDrawingRectangleF Overload
GH_IO.Serialization Namespace


GetDrawingRectangleF Method (String, Int32)

[image]

Grasshopper SDK
GH_IReader..::..GetDrawingRectangleF Method (String, Int32)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
RectangleF GetDrawingRectangleF(
    string item_name,
    int item_index
)
Visual Basic
Function GetDrawingRectangleF ( _
    item_name As String, _
    item_index As Integer _
) As RectangleF

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_IReader Interface
GetDrawingRectangleF Overload
GH_IO.Serialization Namespace


GetDrawingSize Method

[image] [image]

Grasshopper SDK
GH_IReader..::..GetDrawingSize Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDrawingSize(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingSize(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


GetDrawingSize Method (String)

[image]

Grasshopper SDK
GH_IReader..::..GetDrawingSize Method (String)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
Size GetDrawingSize(
    string item_name
)
Visual Basic
Function GetDrawingSize ( _
    item_name As String _
) As Size

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_IReader Interface
GetDrawingSize Overload
GH_IO.Serialization Namespace


GetDrawingSize Method (String, Int32)

[image]

Grasshopper SDK
GH_IReader..::..GetDrawingSize Method (String, Int32)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
Size GetDrawingSize(
    string item_name,
    int item_index
)
Visual Basic
Function GetDrawingSize ( _
    item_name As String, _
    item_index As Integer _
) As Size

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_IReader Interface
GetDrawingSize Overload
GH_IO.Serialization Namespace


GetDrawingSizeF Method

[image] [image]

Grasshopper SDK
GH_IReader..::..GetDrawingSizeF Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDrawingSizeF(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetDrawingSizeF(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


GetDrawingSizeF Method (String)

[image]

Grasshopper SDK
GH_IReader..::..GetDrawingSizeF Method (String)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
SizeF GetDrawingSizeF(
    string item_name
)
Visual Basic
Function GetDrawingSizeF ( _
    item_name As String _
) As SizeF

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_IReader Interface
GetDrawingSizeF Overload
GH_IO.Serialization Namespace


GetDrawingSizeF Method (String, Int32)

[image]

Grasshopper SDK
GH_IReader..::..GetDrawingSizeF Method (String, Int32)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
SizeF GetDrawingSizeF(
    string item_name,
    int item_index
)
Visual Basic
Function GetDrawingSizeF ( _
    item_name As String, _
    item_index As Integer _
) As SizeF

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_IReader Interface
GetDrawingSizeF Overload
GH_IO.Serialization Namespace


GetGuid Method

[image] [image]

Grasshopper SDK
GH_IReader..::..GetGuid Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetGuid(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetGuid(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


GetGuid Method (String)

[image]

Grasshopper SDK
GH_IReader..::..GetGuid Method (String)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
Guid GetGuid(
    string item_name
)
Visual Basic
Function GetGuid ( _
    item_name As String _
) As Guid

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_IReader Interface
GetGuid Overload
GH_IO.Serialization Namespace


GetGuid Method (String, Int32)

[image]

Grasshopper SDK
GH_IReader..::..GetGuid Method (String, Int32)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
Guid GetGuid(
    string item_name,
    int item_index
)
Visual Basic
Function GetGuid ( _
    item_name As String, _
    item_index As Integer _
) As Guid

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_IReader Interface
GetGuid Overload
GH_IO.Serialization Namespace


GetInt32 Method

[image] [image]

Grasshopper SDK
GH_IReader..::..GetInt32 Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetInt32(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetInt32(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


GetInt32 Method (String)

[image]

Grasshopper SDK
GH_IReader..::..GetInt32 Method (String)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
int GetInt32(
    string item_name
)
Visual Basic
Function GetInt32 ( _
    item_name As String _
) As Integer

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_IReader Interface
GetInt32 Overload
GH_IO.Serialization Namespace


GetInt32 Method (String, Int32)

[image]

Grasshopper SDK
GH_IReader..::..GetInt32 Method (String, Int32)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
int GetInt32(
    string item_name,
    int item_index
)
Visual Basic
Function GetInt32 ( _
    item_name As String, _
    item_index As Integer _
) As Integer

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_IReader Interface
GetInt32 Overload
GH_IO.Serialization Namespace


GetInt64 Method

[image] [image]

Grasshopper SDK
GH_IReader..::..GetInt64 Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetInt64(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetInt64(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


GetInt64 Method (String)

[image]

Grasshopper SDK
GH_IReader..::..GetInt64 Method (String)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
long GetInt64(
    string item_name
)
Visual Basic
Function GetInt64 ( _
    item_name As String _
) As Long

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_IReader Interface
GetInt64 Overload
GH_IO.Serialization Namespace


GetInt64 Method (String, Int32)

[image]

Grasshopper SDK
GH_IReader..::..GetInt64 Method (String, Int32)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
long GetInt64(
    string item_name,
    int item_index
)
Visual Basic
Function GetInt64 ( _
    item_name As String, _
    item_index As Integer _
) As Long

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_IReader Interface
GetInt64 Overload
GH_IO.Serialization Namespace


GetInterval1D Method

[image] [image]

Grasshopper SDK
GH_IReader..::..GetInterval1D Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetInterval1D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetInterval1D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


GetInterval1D Method (String)

[image]

Grasshopper SDK
GH_IReader..::..GetInterval1D Method (String)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
GH_Interval1D GetInterval1D(
    string item_name
)
Visual Basic
Function GetInterval1D ( _
    item_name As String _
) As GH_Interval1D

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_IReader Interface
GetInterval1D Overload
GH_IO.Serialization Namespace


GetInterval1D Method (String, Int32)

[image]

Grasshopper SDK
GH_IReader..::..GetInterval1D Method (String, Int32)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
GH_Interval1D GetInterval1D(
    string item_name,
    int item_index
)
Visual Basic
Function GetInterval1D ( _
    item_name As String, _
    item_index As Integer _
) As GH_Interval1D

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_IReader Interface
GetInterval1D Overload
GH_IO.Serialization Namespace


GetInterval2D Method

[image] [image]

Grasshopper SDK
GH_IReader..::..GetInterval2D Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetInterval2D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetInterval2D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


GetInterval2D Method (String)

[image]

Grasshopper SDK
GH_IReader..::..GetInterval2D Method (String)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
GH_Interval2D GetInterval2D(
    string item_name
)
Visual Basic
Function GetInterval2D ( _
    item_name As String _
) As GH_Interval2D

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_IReader Interface
GetInterval2D Overload
GH_IO.Serialization Namespace


GetInterval2D Method (String, Int32)

[image]

Grasshopper SDK
GH_IReader..::..GetInterval2D Method (String, Int32)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
GH_Interval2D GetInterval2D(
    string item_name,
    int item_index
)
Visual Basic
Function GetInterval2D ( _
    item_name As String, _
    item_index As Integer _
) As GH_Interval2D

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_IReader Interface
GetInterval2D Overload
GH_IO.Serialization Namespace


GetLine Method

[image] [image]

Grasshopper SDK
GH_IReader..::..GetLine Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetLine(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetLine(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


GetLine Method (String)

[image]

Grasshopper SDK
GH_IReader..::..GetLine Method (String)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
GH_Line GetLine(
    string item_name
)
Visual Basic
Function GetLine ( _
    item_name As String _
) As GH_Line

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_IReader Interface
GetLine Overload
GH_IO.Serialization Namespace


GetLine Method (String, Int32)

[image]

Grasshopper SDK
GH_IReader..::..GetLine Method (String, Int32)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
GH_Line GetLine(
    string item_name,
    int item_index
)
Visual Basic
Function GetLine ( _
    item_name As String, _
    item_index As Integer _
) As GH_Line

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_IReader Interface
GetLine Overload
GH_IO.Serialization Namespace


GetPath Method

[image] [image]

Grasshopper SDK
GH_IReader..::..GetPath Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPath(String, String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetPath(String, Int32, String) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


GetPath Method (String, String)

[image]

Grasshopper SDK
GH_IReader..::..GetPath Method (String, String)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
string[] GetPath(
    string item_name,
    string basePath
)
Visual Basic
Function GetPath ( _
    item_name As String, _
    basePath As String _
) As String()

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
basePath
Type: System..::..String
Base path for relative path resolution.

Return Value

An array of path strings. If the resolved relative path is different from the stored absolute path, two strings will be returned.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_IReader Interface
GetPath Overload
GH_IO.Serialization Namespace


GetPath Method (String, Int32, String)

[image]

Grasshopper SDK
GH_IReader..::..GetPath Method (String, Int32, String)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
string[] GetPath(
    string item_name,
    int item_index,
    string basePath
)
Visual Basic
Function GetPath ( _
    item_name As String, _
    item_index As Integer, _
    basePath As String _
) As String()

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
basePath
Type: System..::..String
Base path for relative path resolution.

Return Value

An array of path strings. If the resolved relative path is different from the stored absolute path, two strings will be returned.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_IReader Interface
GetPath Overload
GH_IO.Serialization Namespace


GetPlane Method

[image] [image]

Grasshopper SDK
GH_IReader..::..GetPlane Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPlane(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetPlane(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


GetPlane Method (String)

[image]

Grasshopper SDK
GH_IReader..::..GetPlane Method (String)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
GH_Plane GetPlane(
    string item_name
)
Visual Basic
Function GetPlane ( _
    item_name As String _
) As GH_Plane

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_IReader Interface
GetPlane Overload
GH_IO.Serialization Namespace


GetPlane Method (String, Int32)

[image]

Grasshopper SDK
GH_IReader..::..GetPlane Method (String, Int32)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
GH_Plane GetPlane(
    string item_name,
    int item_index
)
Visual Basic
Function GetPlane ( _
    item_name As String, _
    item_index As Integer _
) As GH_Plane

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_IReader Interface
GetPlane Overload
GH_IO.Serialization Namespace


GetPoint2D Method

[image] [image]

Grasshopper SDK
GH_IReader..::..GetPoint2D Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPoint2D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetPoint2D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


GetPoint2D Method (String)

[image]

Grasshopper SDK
GH_IReader..::..GetPoint2D Method (String)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
GH_Point2D GetPoint2D(
    string item_name
)
Visual Basic
Function GetPoint2D ( _
    item_name As String _
) As GH_Point2D

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_IReader Interface
GetPoint2D Overload
GH_IO.Serialization Namespace


GetPoint2D Method (String, Int32)

[image]

Grasshopper SDK
GH_IReader..::..GetPoint2D Method (String, Int32)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
GH_Point2D GetPoint2D(
    string item_name,
    int item_index
)
Visual Basic
Function GetPoint2D ( _
    item_name As String, _
    item_index As Integer _
) As GH_Point2D

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_IReader Interface
GetPoint2D Overload
GH_IO.Serialization Namespace


GetPoint3D Method

[image] [image]

Grasshopper SDK
GH_IReader..::..GetPoint3D Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPoint3D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetPoint3D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


GetPoint3D Method (String)

[image]

Grasshopper SDK
GH_IReader..::..GetPoint3D Method (String)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
GH_Point3D GetPoint3D(
    string item_name
)
Visual Basic
Function GetPoint3D ( _
    item_name As String _
) As GH_Point3D

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_IReader Interface
GetPoint3D Overload
GH_IO.Serialization Namespace


GetPoint3D Method (String, Int32)

[image]

Grasshopper SDK
GH_IReader..::..GetPoint3D Method (String, Int32)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
GH_Point3D GetPoint3D(
    string item_name,
    int item_index
)
Visual Basic
Function GetPoint3D ( _
    item_name As String, _
    item_index As Integer _
) As GH_Point3D

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_IReader Interface
GetPoint3D Overload
GH_IO.Serialization Namespace


GetPoint4D Method

[image] [image]

Grasshopper SDK
GH_IReader..::..GetPoint4D Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPoint4D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetPoint4D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


GetPoint4D Method (String)

[image]

Grasshopper SDK
GH_IReader..::..GetPoint4D Method (String)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
GH_Point4D GetPoint4D(
    string item_name
)
Visual Basic
Function GetPoint4D ( _
    item_name As String _
) As GH_Point4D

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_IReader Interface
GetPoint4D Overload
GH_IO.Serialization Namespace


GetPoint4D Method (String, Int32)

[image]

Grasshopper SDK
GH_IReader..::..GetPoint4D Method (String, Int32)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
GH_Point4D GetPoint4D(
    string item_name,
    int item_index
)
Visual Basic
Function GetPoint4D ( _
    item_name As String, _
    item_index As Integer _
) As GH_Point4D

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_IReader Interface
GetPoint4D Overload
GH_IO.Serialization Namespace


GetSingle Method

[image] [image]

Grasshopper SDK
GH_IReader..::..GetSingle Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetSingle(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetSingle(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


GetSingle Method (String)

[image]

Grasshopper SDK
GH_IReader..::..GetSingle Method (String)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
float GetSingle(
    string item_name
)
Visual Basic
Function GetSingle ( _
    item_name As String _
) As Single

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_IReader Interface
GetSingle Overload
GH_IO.Serialization Namespace


GetSingle Method (String, Int32)

[image]

Grasshopper SDK
GH_IReader..::..GetSingle Method (String, Int32)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
float GetSingle(
    string item_name,
    int item_index
)
Visual Basic
Function GetSingle ( _
    item_name As String, _
    item_index As Integer _
) As Single

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_IReader Interface
GetSingle Overload
GH_IO.Serialization Namespace


GetString Method

[image] [image]

Grasshopper SDK
GH_IReader..::..GetString Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetString(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetString(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


GetString Method (String)

[image]

Grasshopper SDK
GH_IReader..::..GetString Method (String)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
string GetString(
    string item_name
)
Visual Basic
Function GetString ( _
    item_name As String _
) As String

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_IReader Interface
GetString Overload
GH_IO.Serialization Namespace


GetString Method (String, Int32)

[image]

Grasshopper SDK
GH_IReader..::..GetString Method (String, Int32)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
string GetString(
    string item_name,
    int item_index
)
Visual Basic
Function GetString ( _
    item_name As String, _
    item_index As Integer _
) As String

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_IReader Interface
GetString Overload
GH_IO.Serialization Namespace


GetVersion Method

[image] [image]

Grasshopper SDK
GH_IReader..::..GetVersion Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetVersion(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | GetVersion(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


GetVersion Method (String)

[image]

Grasshopper SDK
GH_IReader..::..GetVersion Method (String)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
GH_Version GetVersion(
    string item_name
)
Visual Basic
Function GetVersion ( _
    item_name As String _
) As GH_Version

Parameters

item_name
Type: System..::..String
Name of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name does not exist.

See Also

GH_IReader Interface
GetVersion Overload
GH_IO.Serialization Namespace


GetVersion Method (String, Int32)

[image]

Grasshopper SDK
GH_IReader..::..GetVersion Method (String, Int32)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
GH_Version GetVersion(
    string item_name,
    int item_index
)
Visual Basic
Function GetVersion ( _
    item_name As String, _
    item_index As Integer _
) As GH_Version

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.

Return Value

The inner value of the item.

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.
System..::..NullReferenceException | Thrown if the item with the specified name and index does not exist.

See Also

GH_IReader Interface
GetVersion Overload
GH_IO.Serialization Namespace


ItemExists Method

[image] [image]

Grasshopper SDK
GH_IReader..::..ItemExists Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | ItemExists(String) | Checks whether an item with the specified name exists. Only items without index qualifiers are considered. Name comparisons are not case-sensitive.
Public method | ItemExists(String, Int32) | Checks whether an item with the specified name and index exists. Only items with index qualifiers are considered. Name comparisons are not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


ItemExists Method (String)

[image]

Grasshopper SDK
GH_IReader..::..ItemExists Method (String)
GH_IReader Interface See Also Send Feedback
Checks whether an item with the specified name exists. Only items without index qualifiers are considered. Name comparisons are not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool ItemExists(
    string name
)
Visual Basic
Function ItemExists ( _
    name As String _
) As Boolean

Parameters

name
Type: System..::..String
Name of item to test for.

Return Value

True if an item with the specified name exists, otherwise false.

See Also

GH_IReader Interface
ItemExists Overload
GH_IO.Serialization Namespace


ItemExists Method (String, Int32)

[image]

Grasshopper SDK
GH_IReader..::..ItemExists Method (String, Int32)
GH_IReader Interface See Also Send Feedback
Checks whether an item with the specified name and index exists. Only items with index qualifiers are considered. Name comparisons are not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool ItemExists(
    string name,
    int index
)
Visual Basic
Function ItemExists ( _
    name As String, _
    index As Integer _
) As Boolean

Parameters

name
Type: System..::..String
Name of item to test for.
index
Type: System..::..Int32
Index of item to test for. If index is less than zero, then ItemExists(string name) is called instead.

Return Value

True if an item with the specified name and index exists, otherwise false.

See Also

GH_IReader Interface
ItemExists Overload
GH_IO.Serialization Namespace


Read Method

[image] [image]

Grasshopper SDK
GH_IReader..::..Read Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | Read(BinaryReader) | Called when an object is required to deserialize itself. (Inherited from GH_IBinarySupport.)
Public method | Read(XmlNode) | Called when an object is required to deserialize itself. (Inherited from GH_IXmlSupport.)

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


TryGetBoolean Method

[image] [image]

Grasshopper SDK
GH_IReader..::..TryGetBoolean Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetBoolean(String, Boolean%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetBoolean(String, Int32, Boolean%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


TryGetBoolean Method (String, Boolean)

[image]

Grasshopper SDK
GH_IReader..::..TryGetBoolean Method (String, Boolean%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetBoolean(
    string item_name,
    ref bool value
)
Visual Basic
Function TryGetBoolean ( _
    item_name As String, _
    ByRef value As Boolean _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: System..::..Boolean %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetBoolean Overload
GH_IO.Serialization Namespace


TryGetBoolean Method (String, Int32, Boolean)

[image]

Grasshopper SDK
GH_IReader..::..TryGetBoolean Method (String, Int32, Boolean%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetBoolean(
    string item_name,
    int item_index,
    ref bool value
)
Visual Basic
Function TryGetBoolean ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As Boolean _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: System..::..Boolean %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetBoolean Overload
GH_IO.Serialization Namespace


TryGetBoundingBox Method

[image] [image]

Grasshopper SDK
GH_IReader..::..TryGetBoundingBox Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetBoundingBox(String, GH_BoundingBox%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetBoundingBox(String, Int32, GH_BoundingBox%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


TryGetBoundingBox Method (String, GH_BoundingBox)

[image]

Grasshopper SDK
GH_IReader..::..TryGetBoundingBox Method (String, GH_BoundingBox%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetBoundingBox(
    string item_name,
    ref GH_BoundingBox value
)
Visual Basic
Function TryGetBoundingBox ( _
    item_name As String, _
    ByRef value As GH_BoundingBox _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: GH_IO.Types..::..GH_BoundingBox %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetBoundingBox Overload
GH_IO.Serialization Namespace


TryGetBoundingBox Method (String, Int32, GH_BoundingBox)

[image]

Grasshopper SDK
GH_IReader..::..TryGetBoundingBox Method (String, Int32, GH_BoundingBox%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetBoundingBox(
    string item_name,
    int item_index,
    ref GH_BoundingBox value
)
Visual Basic
Function TryGetBoundingBox ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As GH_BoundingBox _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: GH_IO.Types..::..GH_BoundingBox %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetBoundingBox Overload
GH_IO.Serialization Namespace


TryGetByte Method

[image] [image]

Grasshopper SDK
GH_IReader..::..TryGetByte Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetByte(String, Byte%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetByte(String, Int32, Byte%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


TryGetByte Method (String, Byte)

[image]

Grasshopper SDK
GH_IReader..::..TryGetByte Method (String, Byte%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetByte(
    string item_name,
    ref byte value
)
Visual Basic
Function TryGetByte ( _
    item_name As String, _
    ByRef value As Byte _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: System..::..Byte %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetByte Overload
GH_IO.Serialization Namespace


TryGetByte Method (String, Int32, Byte)

[image]

Grasshopper SDK
GH_IReader..::..TryGetByte Method (String, Int32, Byte%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetByte(
    string item_name,
    int item_index,
    ref byte value
)
Visual Basic
Function TryGetByte ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As Byte _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: System..::..Byte %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetByte Overload
GH_IO.Serialization Namespace


TryGetDate Method

[image] [image]

Grasshopper SDK
GH_IReader..::..TryGetDate Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetDate(String, DateTime%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDate(String, Int32, DateTime%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


TryGetDate Method (String, DateTime)

[image]

Grasshopper SDK
GH_IReader..::..TryGetDate Method (String, DateTime%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetDate(
    string item_name,
    ref DateTime value
)
Visual Basic
Function TryGetDate ( _
    item_name As String, _
    ByRef value As DateTime _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: System..::..DateTime %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetDate Overload
GH_IO.Serialization Namespace


TryGetDate Method (String, Int32, DateTime)

[image]

Grasshopper SDK
GH_IReader..::..TryGetDate Method (String, Int32, DateTime%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetDate(
    string item_name,
    int item_index,
    ref DateTime value
)
Visual Basic
Function TryGetDate ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As DateTime _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: System..::..DateTime %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetDate Overload
GH_IO.Serialization Namespace


TryGetDecimal Method

[image] [image]

Grasshopper SDK
GH_IReader..::..TryGetDecimal Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetDecimal(String, Decimal%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDecimal(String, Int32, Decimal%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


TryGetDecimal Method (String, Decimal)

[image]

Grasshopper SDK
GH_IReader..::..TryGetDecimal Method (String, Decimal%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetDecimal(
    string item_name,
    ref decimal value
)
Visual Basic
Function TryGetDecimal ( _
    item_name As String, _
    ByRef value As Decimal _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: System..::..Decimal %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetDecimal Overload
GH_IO.Serialization Namespace


TryGetDecimal Method (String, Int32, Decimal)

[image]

Grasshopper SDK
GH_IReader..::..TryGetDecimal Method (String, Int32, Decimal%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetDecimal(
    string item_name,
    int item_index,
    ref decimal value
)
Visual Basic
Function TryGetDecimal ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As Decimal _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: System..::..Decimal %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetDecimal Overload
GH_IO.Serialization Namespace


TryGetDouble Method

[image] [image]

Grasshopper SDK
GH_IReader..::..TryGetDouble Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetDouble(String, Double%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDouble(String, Int32, Double%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


TryGetDouble Method (String, Double)

[image]

Grasshopper SDK
GH_IReader..::..TryGetDouble Method (String, Double%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetDouble(
    string item_name,
    ref double value
)
Visual Basic
Function TryGetDouble ( _
    item_name As String, _
    ByRef value As Double _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: System..::..Double %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetDouble Overload
GH_IO.Serialization Namespace


TryGetDouble Method (String, Int32, Double)

[image]

Grasshopper SDK
GH_IReader..::..TryGetDouble Method (String, Int32, Double%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetDouble(
    string item_name,
    int item_index,
    ref double value
)
Visual Basic
Function TryGetDouble ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As Double _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: System..::..Double %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetDouble Overload
GH_IO.Serialization Namespace


TryGetDrawingColor Method

[image] [image]

Grasshopper SDK
GH_IReader..::..TryGetDrawingColor Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetDrawingColor(String, Color%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingColor(String, Int32, Color%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


TryGetDrawingColor Method (String, Color)

[image]

Grasshopper SDK
GH_IReader..::..TryGetDrawingColor Method (String, Color%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetDrawingColor(
    string item_name,
    ref Color value
)
Visual Basic
Function TryGetDrawingColor ( _
    item_name As String, _
    ByRef value As Color _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: System.Drawing..::..Color %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetDrawingColor Overload
GH_IO.Serialization Namespace


TryGetDrawingColor Method (String, Int32, Color)

[image]

Grasshopper SDK
GH_IReader..::..TryGetDrawingColor Method (String, Int32, Color%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetDrawingColor(
    string item_name,
    int item_index,
    ref Color value
)
Visual Basic
Function TryGetDrawingColor ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As Color _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: System.Drawing..::..Color %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetDrawingColor Overload
GH_IO.Serialization Namespace


TryGetDrawingPoint Method

[image] [image]

Grasshopper SDK
GH_IReader..::..TryGetDrawingPoint Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetDrawingPoint(String, Point%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingPoint(String, Int32, Point%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


TryGetDrawingPoint Method (String, Point)

[image]

Grasshopper SDK
GH_IReader..::..TryGetDrawingPoint Method (String, Point%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetDrawingPoint(
    string item_name,
    ref Point value
)
Visual Basic
Function TryGetDrawingPoint ( _
    item_name As String, _
    ByRef value As Point _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: System.Drawing..::..Point %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetDrawingPoint Overload
GH_IO.Serialization Namespace


TryGetDrawingPoint Method (String, Int32, Point)

[image]

Grasshopper SDK
GH_IReader..::..TryGetDrawingPoint Method (String, Int32, Point%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetDrawingPoint(
    string item_name,
    int item_index,
    ref Point value
)
Visual Basic
Function TryGetDrawingPoint ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As Point _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: System.Drawing..::..Point %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetDrawingPoint Overload
GH_IO.Serialization Namespace


TryGetDrawingPointF Method

[image] [image]

Grasshopper SDK
GH_IReader..::..TryGetDrawingPointF Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetDrawingPointF(String, PointF%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingPointF(String, Int32, PointF%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


TryGetDrawingPointF Method (String, PointF)

[image]

Grasshopper SDK
GH_IReader..::..TryGetDrawingPointF Method (String, PointF%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetDrawingPointF(
    string item_name,
    ref PointF value
)
Visual Basic
Function TryGetDrawingPointF ( _
    item_name As String, _
    ByRef value As PointF _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: System.Drawing..::..PointF %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetDrawingPointF Overload
GH_IO.Serialization Namespace


TryGetDrawingPointF Method (String, Int32, PointF)

[image]

Grasshopper SDK
GH_IReader..::..TryGetDrawingPointF Method (String, Int32, PointF%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetDrawingPointF(
    string item_name,
    int item_index,
    ref PointF value
)
Visual Basic
Function TryGetDrawingPointF ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As PointF _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: System.Drawing..::..PointF %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetDrawingPointF Overload
GH_IO.Serialization Namespace


TryGetDrawingRectangle Method

[image] [image]

Grasshopper SDK
GH_IReader..::..TryGetDrawingRectangle Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetDrawingRectangle(String, Rectangle%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingRectangle(String, Int32, Rectangle%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


TryGetDrawingRectangle Method (String, Rectangle)

[image]

Grasshopper SDK
GH_IReader..::..TryGetDrawingRectangle Method (String, Rectangle%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetDrawingRectangle(
    string item_name,
    ref Rectangle value
)
Visual Basic
Function TryGetDrawingRectangle ( _
    item_name As String, _
    ByRef value As Rectangle _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: System.Drawing..::..Rectangle %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetDrawingRectangle Overload
GH_IO.Serialization Namespace


TryGetDrawingRectangle Method (String, Int32, Rectangle)

[image]

Grasshopper SDK
GH_IReader..::..TryGetDrawingRectangle Method (String, Int32, Rectangle%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetDrawingRectangle(
    string item_name,
    int item_index,
    ref Rectangle value
)
Visual Basic
Function TryGetDrawingRectangle ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As Rectangle _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: System.Drawing..::..Rectangle %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetDrawingRectangle Overload
GH_IO.Serialization Namespace


TryGetDrawingRectangleF Method

[image] [image]

Grasshopper SDK
GH_IReader..::..TryGetDrawingRectangleF Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetDrawingRectangleF(String, RectangleF%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingRectangleF(String, Int32, RectangleF%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


TryGetDrawingRectangleF Method (String, RectangleF)

[image]

Grasshopper SDK
GH_IReader..::..TryGetDrawingRectangleF Method (String, RectangleF%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetDrawingRectangleF(
    string item_name,
    ref RectangleF value
)
Visual Basic
Function TryGetDrawingRectangleF ( _
    item_name As String, _
    ByRef value As RectangleF _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: System.Drawing..::..RectangleF %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetDrawingRectangleF Overload
GH_IO.Serialization Namespace


TryGetDrawingRectangleF Method (String, Int32, RectangleF)

[image]

Grasshopper SDK
GH_IReader..::..TryGetDrawingRectangleF Method (String, Int32, RectangleF%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetDrawingRectangleF(
    string item_name,
    int item_index,
    ref RectangleF value
)
Visual Basic
Function TryGetDrawingRectangleF ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As RectangleF _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: System.Drawing..::..RectangleF %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetDrawingRectangleF Overload
GH_IO.Serialization Namespace


TryGetDrawingSize Method

[image] [image]

Grasshopper SDK
GH_IReader..::..TryGetDrawingSize Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetDrawingSize(String, Size%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingSize(String, Int32, Size%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


TryGetDrawingSize Method (String, Size)

[image]

Grasshopper SDK
GH_IReader..::..TryGetDrawingSize Method (String, Size%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetDrawingSize(
    string item_name,
    ref Size value
)
Visual Basic
Function TryGetDrawingSize ( _
    item_name As String, _
    ByRef value As Size _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: System.Drawing..::..Size %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetDrawingSize Overload
GH_IO.Serialization Namespace


TryGetDrawingSize Method (String, Int32, Size)

[image]

Grasshopper SDK
GH_IReader..::..TryGetDrawingSize Method (String, Int32, Size%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetDrawingSize(
    string item_name,
    int item_index,
    ref Size value
)
Visual Basic
Function TryGetDrawingSize ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As Size _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: System.Drawing..::..Size %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetDrawingSize Overload
GH_IO.Serialization Namespace


TryGetDrawingSizeF Method

[image] [image]

Grasshopper SDK
GH_IReader..::..TryGetDrawingSizeF Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetDrawingSizeF(String, SizeF%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetDrawingSizeF(String, Int32, SizeF%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


TryGetDrawingSizeF Method (String, SizeF)

[image]

Grasshopper SDK
GH_IReader..::..TryGetDrawingSizeF Method (String, SizeF%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetDrawingSizeF(
    string item_name,
    ref SizeF value
)
Visual Basic
Function TryGetDrawingSizeF ( _
    item_name As String, _
    ByRef value As SizeF _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: System.Drawing..::..SizeF %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetDrawingSizeF Overload
GH_IO.Serialization Namespace


TryGetDrawingSizeF Method (String, Int32, SizeF)

[image]

Grasshopper SDK
GH_IReader..::..TryGetDrawingSizeF Method (String, Int32, SizeF%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetDrawingSizeF(
    string item_name,
    int item_index,
    ref SizeF value
)
Visual Basic
Function TryGetDrawingSizeF ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As SizeF _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: System.Drawing..::..SizeF %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetDrawingSizeF Overload
GH_IO.Serialization Namespace


TryGetGuid Method

[image] [image]

Grasshopper SDK
GH_IReader..::..TryGetGuid Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetGuid(String, Guid%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetGuid(String, Int32, Guid%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


TryGetGuid Method (String, Guid)

[image]

Grasshopper SDK
GH_IReader..::..TryGetGuid Method (String, Guid%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetGuid(
    string item_name,
    ref Guid value
)
Visual Basic
Function TryGetGuid ( _
    item_name As String, _
    ByRef value As Guid _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: System..::..Guid %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetGuid Overload
GH_IO.Serialization Namespace


TryGetGuid Method (String, Int32, Guid)

[image]

Grasshopper SDK
GH_IReader..::..TryGetGuid Method (String, Int32, Guid%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetGuid(
    string item_name,
    int item_index,
    ref Guid value
)
Visual Basic
Function TryGetGuid ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As Guid _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: System..::..Guid %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetGuid Overload
GH_IO.Serialization Namespace


TryGetInt32 Method

[image] [image]

Grasshopper SDK
GH_IReader..::..TryGetInt32 Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetInt32(String, Int32%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetInt32(String, Int32, Int32%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


TryGetInt32 Method (String, Int32)

[image]

Grasshopper SDK
GH_IReader..::..TryGetInt32 Method (String, Int32%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetInt32(
    string item_name,
    ref int value
)
Visual Basic
Function TryGetInt32 ( _
    item_name As String, _
    ByRef value As Integer _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: System..::..Int32 %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetInt32 Overload
GH_IO.Serialization Namespace


TryGetInt32 Method (String, Int32, Int32)

[image]

Grasshopper SDK
GH_IReader..::..TryGetInt32 Method (String, Int32, Int32%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetInt32(
    string item_name,
    int item_index,
    ref int value
)
Visual Basic
Function TryGetInt32 ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As Integer _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: System..::..Int32 %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetInt32 Overload
GH_IO.Serialization Namespace


TryGetInt64 Method

[image] [image]

Grasshopper SDK
GH_IReader..::..TryGetInt64 Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetInt64(String, Int64%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetInt64(String, Int32, Int64%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


TryGetInt64 Method (String, Int64)

[image]

Grasshopper SDK
GH_IReader..::..TryGetInt64 Method (String, Int64%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetInt64(
    string item_name,
    ref long value
)
Visual Basic
Function TryGetInt64 ( _
    item_name As String, _
    ByRef value As Long _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: System..::..Int64 %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetInt64 Overload
GH_IO.Serialization Namespace


TryGetInt64 Method (String, Int32, Int64)

[image]

Grasshopper SDK
GH_IReader..::..TryGetInt64 Method (String, Int32, Int64%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetInt64(
    string item_name,
    int item_index,
    ref long value
)
Visual Basic
Function TryGetInt64 ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As Long _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: System..::..Int64 %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetInt64 Overload
GH_IO.Serialization Namespace


TryGetInterval1D Method

[image] [image]

Grasshopper SDK
GH_IReader..::..TryGetInterval1D Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetInterval1D(String, GH_Interval1D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetInterval1D(String, Int32, GH_Interval1D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


TryGetInterval1D Method (String, GH_Interval1D)

[image]

Grasshopper SDK
GH_IReader..::..TryGetInterval1D Method (String, GH_Interval1D%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetInterval1D(
    string item_name,
    ref GH_Interval1D value
)
Visual Basic
Function TryGetInterval1D ( _
    item_name As String, _
    ByRef value As GH_Interval1D _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: GH_IO.Types..::..GH_Interval1D %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetInterval1D Overload
GH_IO.Serialization Namespace


TryGetInterval1D Method (String, Int32, GH_Interval1D)

[image]

Grasshopper SDK
GH_IReader..::..TryGetInterval1D Method (String, Int32, GH_Interval1D%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetInterval1D(
    string item_name,
    int item_index,
    ref GH_Interval1D value
)
Visual Basic
Function TryGetInterval1D ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As GH_Interval1D _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: GH_IO.Types..::..GH_Interval1D %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetInterval1D Overload
GH_IO.Serialization Namespace


TryGetInterval2D Method

[image] [image]

Grasshopper SDK
GH_IReader..::..TryGetInterval2D Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetInterval2D(String, GH_Interval2D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetInterval2D(String, Int32, GH_Interval2D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


TryGetInterval2D Method (String, GH_Interval2D)

[image]

Grasshopper SDK
GH_IReader..::..TryGetInterval2D Method (String, GH_Interval2D%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetInterval2D(
    string item_name,
    ref GH_Interval2D value
)
Visual Basic
Function TryGetInterval2D ( _
    item_name As String, _
    ByRef value As GH_Interval2D _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: GH_IO.Types..::..GH_Interval2D %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetInterval2D Overload
GH_IO.Serialization Namespace


TryGetInterval2D Method (String, Int32, GH_Interval2D)

[image]

Grasshopper SDK
GH_IReader..::..TryGetInterval2D Method (String, Int32, GH_Interval2D%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetInterval2D(
    string item_name,
    int item_index,
    ref GH_Interval2D value
)
Visual Basic
Function TryGetInterval2D ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As GH_Interval2D _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: GH_IO.Types..::..GH_Interval2D %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetInterval2D Overload
GH_IO.Serialization Namespace


TryGetLine Method

[image] [image]

Grasshopper SDK
GH_IReader..::..TryGetLine Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetLine(String, GH_Line%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetLine(String, Int32, GH_Line%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


TryGetLine Method (String, GH_Line)

[image]

Grasshopper SDK
GH_IReader..::..TryGetLine Method (String, GH_Line%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetLine(
    string item_name,
    ref GH_Line value
)
Visual Basic
Function TryGetLine ( _
    item_name As String, _
    ByRef value As GH_Line _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: GH_IO.Types..::..GH_Line %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetLine Overload
GH_IO.Serialization Namespace


TryGetLine Method (String, Int32, GH_Line)

[image]

Grasshopper SDK
GH_IReader..::..TryGetLine Method (String, Int32, GH_Line%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetLine(
    string item_name,
    int item_index,
    ref GH_Line value
)
Visual Basic
Function TryGetLine ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As GH_Line _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: GH_IO.Types..::..GH_Line %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetLine Overload
GH_IO.Serialization Namespace


TryGetPlane Method

[image] [image]

Grasshopper SDK
GH_IReader..::..TryGetPlane Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetPlane(String, GH_Plane%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetPlane(String, Int32, GH_Plane%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


TryGetPlane Method (String, GH_Plane)

[image]

Grasshopper SDK
GH_IReader..::..TryGetPlane Method (String, GH_Plane%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetPlane(
    string item_name,
    ref GH_Plane value
)
Visual Basic
Function TryGetPlane ( _
    item_name As String, _
    ByRef value As GH_Plane _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: GH_IO.Types..::..GH_Plane %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetPlane Overload
GH_IO.Serialization Namespace


TryGetPlane Method (String, Int32, GH_Plane)

[image]

Grasshopper SDK
GH_IReader..::..TryGetPlane Method (String, Int32, GH_Plane%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetPlane(
    string item_name,
    int item_index,
    ref GH_Plane value
)
Visual Basic
Function TryGetPlane ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As GH_Plane _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: GH_IO.Types..::..GH_Plane %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetPlane Overload
GH_IO.Serialization Namespace


TryGetPoint2D Method

[image] [image]

Grasshopper SDK
GH_IReader..::..TryGetPoint2D Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetPoint2D(String, GH_Point2D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetPoint2D(String, Int32, GH_Point2D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


TryGetPoint2D Method (String, GH_Point2D)

[image]

Grasshopper SDK
GH_IReader..::..TryGetPoint2D Method (String, GH_Point2D%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetPoint2D(
    string item_name,
    ref GH_Point2D value
)
Visual Basic
Function TryGetPoint2D ( _
    item_name As String, _
    ByRef value As GH_Point2D _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: GH_IO.Types..::..GH_Point2D %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetPoint2D Overload
GH_IO.Serialization Namespace


TryGetPoint2D Method (String, Int32, GH_Point2D)

[image]

Grasshopper SDK
GH_IReader..::..TryGetPoint2D Method (String, Int32, GH_Point2D%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetPoint2D(
    string item_name,
    int item_index,
    ref GH_Point2D value
)
Visual Basic
Function TryGetPoint2D ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As GH_Point2D _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: GH_IO.Types..::..GH_Point2D %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetPoint2D Overload
GH_IO.Serialization Namespace


TryGetPoint3D Method

[image] [image]

Grasshopper SDK
GH_IReader..::..TryGetPoint3D Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetPoint3D(String, GH_Point3D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetPoint3D(String, Int32, GH_Point3D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


TryGetPoint3D Method (String, GH_Point3D)

[image]

Grasshopper SDK
GH_IReader..::..TryGetPoint3D Method (String, GH_Point3D%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetPoint3D(
    string item_name,
    ref GH_Point3D value
)
Visual Basic
Function TryGetPoint3D ( _
    item_name As String, _
    ByRef value As GH_Point3D _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: GH_IO.Types..::..GH_Point3D %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetPoint3D Overload
GH_IO.Serialization Namespace


TryGetPoint3D Method (String, Int32, GH_Point3D)

[image]

Grasshopper SDK
GH_IReader..::..TryGetPoint3D Method (String, Int32, GH_Point3D%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetPoint3D(
    string item_name,
    int item_index,
    ref GH_Point3D value
)
Visual Basic
Function TryGetPoint3D ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As GH_Point3D _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: GH_IO.Types..::..GH_Point3D %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetPoint3D Overload
GH_IO.Serialization Namespace


TryGetPoint4D Method

[image] [image]

Grasshopper SDK
GH_IReader..::..TryGetPoint4D Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetPoint4D(String, GH_Point4D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetPoint4D(String, Int32, GH_Point4D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


TryGetPoint4D Method (String, GH_Point4D)

[image]

Grasshopper SDK
GH_IReader..::..TryGetPoint4D Method (String, GH_Point4D%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetPoint4D(
    string item_name,
    ref GH_Point4D value
)
Visual Basic
Function TryGetPoint4D ( _
    item_name As String, _
    ByRef value As GH_Point4D _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: GH_IO.Types..::..GH_Point4D %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetPoint4D Overload
GH_IO.Serialization Namespace


TryGetPoint4D Method (String, Int32, GH_Point4D)

[image]

Grasshopper SDK
GH_IReader..::..TryGetPoint4D Method (String, Int32, GH_Point4D%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetPoint4D(
    string item_name,
    int item_index,
    ref GH_Point4D value
)
Visual Basic
Function TryGetPoint4D ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As GH_Point4D _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: GH_IO.Types..::..GH_Point4D %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetPoint4D Overload
GH_IO.Serialization Namespace


TryGetSingle Method

[image] [image]

Grasshopper SDK
GH_IReader..::..TryGetSingle Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetSingle(String, Single%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetSingle(String, Int32, Single%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


TryGetSingle Method (String, Single)

[image]

Grasshopper SDK
GH_IReader..::..TryGetSingle Method (String, Single%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetSingle(
    string item_name,
    ref float value
)
Visual Basic
Function TryGetSingle ( _
    item_name As String, _
    ByRef value As Single _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: System..::..Single %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetSingle Overload
GH_IO.Serialization Namespace


TryGetSingle Method (String, Int32, Single)

[image]

Grasshopper SDK
GH_IReader..::..TryGetSingle Method (String, Int32, Single%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetSingle(
    string item_name,
    int item_index,
    ref float value
)
Visual Basic
Function TryGetSingle ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As Single _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: System..::..Single %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetSingle Overload
GH_IO.Serialization Namespace


TryGetString Method

[image] [image]

Grasshopper SDK
GH_IReader..::..TryGetString Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetString(String, String%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetString(String, Int32, String%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


TryGetString Method (String, String)

[image]

Grasshopper SDK
GH_IReader..::..TryGetString Method (String, String%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetString(
    string item_name,
    ref string value
)
Visual Basic
Function TryGetString ( _
    item_name As String, _
    ByRef value As String _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: System..::..String %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetString Overload
GH_IO.Serialization Namespace


TryGetString Method (String, Int32, String)

[image]

Grasshopper SDK
GH_IReader..::..TryGetString Method (String, Int32, String%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetString(
    string item_name,
    int item_index,
    ref string value
)
Visual Basic
Function TryGetString ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As String _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: System..::..String %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetString Overload
GH_IO.Serialization Namespace


TryGetVersion Method

[image] [image]

Grasshopper SDK
GH_IReader..::..TryGetVersion Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetVersion(String, GH_Version%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive.
Public method | TryGetVersion(String, Int32, GH_Version%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


TryGetVersion Method (String, GH_Version)

[image]

Grasshopper SDK
GH_IReader..::..TryGetVersion Method (String, GH_Version%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetVersion(
    string item_name,
    ref GH_Version value
)
Visual Basic
Function TryGetVersion ( _
    item_name As String, _
    ByRef value As GH_Version _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
value
Type: GH_IO.Types..::..GH_Version %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetVersion Overload
GH_IO.Serialization Namespace


TryGetVersion Method (String, Int32, GH_Version)

[image]

Grasshopper SDK
GH_IReader..::..TryGetVersion Method (String, Int32, GH_Version%)
GH_IReader Interface See Also Send Feedback
Gets the value of the item with the specified name and index. Name comparison is not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool TryGetVersion(
    string item_name,
    int item_index,
    ref GH_Version value
)
Visual Basic
Function TryGetVersion ( _
    item_name As String, _
    item_index As Integer, _
    ByRef value As GH_Version _
) As Boolean

Parameters

item_name
Type: System..::..String
Name of item to retrieve.
item_index
Type: System..::..Int32
Index of item to retrieve.
value
Type: GH_IO.Types..::..GH_Version %
Target of assignment.

Return Value

True if the value was set.

See Also

GH_IReader Interface
TryGetVersion Overload
GH_IO.Serialization Namespace


Write Method

[image] [image]

Grasshopper SDK
GH_IReader..::..Write Method
GH_IReader Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | Write(BinaryWriter) | Called when an object is required to serialize itself. (Inherited from GH_IBinarySupport.)
Public method | Write(XmlWriter) | Called when an object is required to serialize itself. (Inherited from GH_IXmlSupport.)

See Also

GH_IReader Interface
GH_IReader Members
GH_IO.Serialization Namespace


GH_IReader Properties

[image] [image]

Grasshopper SDK
GH_IReader Properties
GH_IReader Interface See Also Send Feedback

The GH_IReader type exposes the following members.

Properties

 | Name | Description
Public property | Archive | Gets a pointer to the archive that owns the Root of the tree this chunk belongs to. (Inherited from GH_IChunk.)
Public property | ArchiveLocation | Gets a string representing the URI with which the archive is associated. The location may be a null string. (Inherited from GH_IChunk.)
Public property | ChunkCount | Gets the number of child chunks contained in this chunk. The set of all child chunks is referred to as a 'litter'. (Inherited from GH_IChunk.)
Public property | Chunks | Gets a pointer to the internal list of child chunks. Do not access this list unless you know what you are doing. (Inherited from GH_IChunk.)
Public property | Index | Gets the index of this chunk. The index is set by the owner of this chunk. Indices smaller than zero imply no index has been set. The combination of name+index is always unique among a set of chunks in the same litter. (Inherited from GH_IChunk.)
Public property | ItemCount | Gets the number of items contained in this chunk. (Inherited from GH_IChunk.)
Public property | Items | Gets a pointer to the internal list of items. Do not access this list unless you know what you are doing. (Inherited from GH_IChunk.)
Public property | Name | Gets the name of this chunk. The name is set by the owner of this chunk. Names must be at least 1 character long. The combination of name+index is always unique among a set of chunks in a single litter. (Inherited from GH_IChunk.)

See Also

GH_IReader Interface
GH_IO.Serialization Namespace


GH_IWriter Interface

[image]

Grasshopper SDK
GH_IWriter Interface
Members See Also Send Feedback
Provides access to a subset of GH_Chunk methods used for writing archives.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public interface GH_IWriter : GH_IChunk,
    GH_IBinarySupport, GH_IXmlSupport
Visual Basic
Public Interface GH_IWriter _
    Inherits GH_IChunk, GH_IBinarySupport, GH_IXmlSupport

See Also

GH_IWriter Members
GH_IO.Serialization Namespace


GH_IWriter Members

[image] [image]

Grasshopper SDK
GH_IWriter Members
GH_IWriter Interface Methods Properties See Also Send Feedback

The GH_IWriter type exposes the following members.

Methods

 | Name | Description
Public method | AddComment | Adds a text comment to this chunk. Comments are serialized only if the output flavour is a human readable format. Comments are never deserialized, they are purely for the benefit of the humans reading the file data.
Public method | AddMessage | Log a new message with the top-level archive. Messages are collected during read/write operations, and can be displayed to the user upon completion using GH_Archive.ShowMessageLog(). (Inherited from GH_IChunk.)
Public method | CreateChunk(String) | Create a new child chunk with the specified name but without an index qualifier. If another chunk already exists with similar properties, an exception will be thrown.
Public method | CreateChunk(String, Int32) | Create a new child chunk with the specified name and index qualifier. If another chunk already exists with similar properties, an exception will be thrown.
Public method | Read(BinaryReader) | Called when an object is required to deserialize itself. (Inherited from GH_IBinarySupport.)
Public method | Read(XmlNode) | Called when an object is required to deserialize itself. (Inherited from GH_IXmlSupport.)
Public method | RemoveChunk(String) | Remove the first chunk with a matching name. Only chunks without index qualifiers are considered. Name comparisons are not case-sensitive.
Public method | RemoveChunk(GH_IChunk) | Remove the specified chunk from the litter.
Public method | RemoveChunk(String, Int32) | Remove the first chunk with a matching name and index. Only chunks with index qualifiers are considered. Name comparisons are not case-sensitive.
Public method | RemoveItem(String) | Remove an unindexed item from this chunk.
Public method | RemoveItem(String, Int32) | Remove an indexed item from this chunk.
Public method | SetBoolean(String, Boolean) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetBoolean(String, Int32, Boolean) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetBoundingBox(String, GH_BoundingBox) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetBoundingBox(String, Int32, GH_BoundingBox) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetByte(String, Byte) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetByte(String, Int32, Byte) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetByteArray(String, array<Byte>[]()[][]) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetByteArray(String, Int32, array<Byte>[]()[][]) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDate(String, DateTime) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDate(String, Int32, DateTime) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDecimal(String, Decimal) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDecimal(String, Int32, Decimal) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDouble(String, Double) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDouble(String, Int32, Double) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDoubleArray(String, array<Double>[]()[][]) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDoubleArray(String, Int32, array<Double>[]()[][]) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDrawingBitmap(String, Bitmap) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingBitmap(String, Int32, Bitmap) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingColor(String, Color) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingColor(String, Int32, Color) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDrawingPoint(String, Point) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingPoint(String, Int32, Point) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDrawingPointF(String, PointF) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingPointF(String, Int32, PointF) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDrawingRectangle(String, Rectangle) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingRectangle(String, Int32, Rectangle) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDrawingRectangleF(String, RectangleF) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingRectangleF(String, Int32, RectangleF) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDrawingSize(String, Size) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingSize(String, Int32, Size) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDrawingSizeF(String, SizeF) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingSizeF(String, Int32, SizeF) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetGuid(String, Guid) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetGuid(String, Int32, Guid) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetInt32(String, Int32) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetInt32(String, Int32, Int32) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetInt64(String, Int64) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetInt64(String, Int32, Int64) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetInterval1D(String, GH_Interval1D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetInterval1D(String, Int32, GH_Interval1D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetInterval2D(String, GH_Interval2D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetInterval2D(String, Int32, GH_Interval2D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetLine(String, GH_Line) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetLine(String, Int32, GH_Line) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetPath(String, String, String) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetPath(String, Int32, String, String) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetPlane(String, GH_Plane) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetPlane(String, Int32, GH_Plane) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetPoint2D(String, GH_Point2D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetPoint2D(String, Int32, GH_Point2D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetPoint3D(String, GH_Point3D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetPoint3D(String, Int32, GH_Point3D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetPoint4D(String, GH_Point4D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetPoint4D(String, Int32, GH_Point4D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetSingle(String, Single) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetSingle(String, Int32, Single) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetString(String, String) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetString(String, Int32, String) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetVersion(String, GH_Version) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetVersion(String, Int32, GH_Version) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetVersion(String, Int32, Int32, Int32) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetVersion(String, Int32, Int32, Int32, Int32) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | Write(BinaryWriter) | Called when an object is required to serialize itself. (Inherited from GH_IBinarySupport.)
Public method | Write(XmlWriter) | Called when an object is required to serialize itself. (Inherited from GH_IXmlSupport.)

Properties

 | Name | Description
Public property | Archive | Gets a pointer to the archive that owns the Root of the tree this chunk belongs to. (Inherited from GH_IChunk.)
Public property | ArchiveLocation | Gets a string representing the URI with which the archive is associated. The location may be a null string. (Inherited from GH_IChunk.)
Public property | ChunkCount | Gets the number of child chunks contained in this chunk. The set of all child chunks is referred to as a 'litter'. (Inherited from GH_IChunk.)
Public property | Chunks | Gets a pointer to the internal list of child chunks. Do not access this list unless you know what you are doing. (Inherited from GH_IChunk.)
Public property | Index | Gets the index of this chunk. The index is set by the owner of this chunk. Indices smaller than zero imply no index has been set. The combination of name+index is always unique among a set of chunks in the same litter. (Inherited from GH_IChunk.)
Public property | ItemCount | Gets the number of items contained in this chunk. (Inherited from GH_IChunk.)
Public property | Items | Gets a pointer to the internal list of items. Do not access this list unless you know what you are doing. (Inherited from GH_IChunk.)
Public property | Name | Gets the name of this chunk. The name is set by the owner of this chunk. Names must be at least 1 character long. The combination of name+index is always unique among a set of chunks in a single litter. (Inherited from GH_IChunk.)

See Also

GH_IWriter Interface
GH_IO.Serialization Namespace


GH_IWriter Methods

[image] [image]

Grasshopper SDK
GH_IWriter Methods
GH_IWriter Interface See Also Send Feedback

The GH_IWriter type exposes the following members.

Methods

 | Name | Description
Public method | AddComment | Adds a text comment to this chunk. Comments are serialized only if the output flavour is a human readable format. Comments are never deserialized, they are purely for the benefit of the humans reading the file data.
Public method | AddMessage | Log a new message with the top-level archive. Messages are collected during read/write operations, and can be displayed to the user upon completion using GH_Archive.ShowMessageLog(). (Inherited from GH_IChunk.)
Public method | CreateChunk(String) | Create a new child chunk with the specified name but without an index qualifier. If another chunk already exists with similar properties, an exception will be thrown.
Public method | CreateChunk(String, Int32) | Create a new child chunk with the specified name and index qualifier. If another chunk already exists with similar properties, an exception will be thrown.
Public method | Read(BinaryReader) | Called when an object is required to deserialize itself. (Inherited from GH_IBinarySupport.)
Public method | Read(XmlNode) | Called when an object is required to deserialize itself. (Inherited from GH_IXmlSupport.)
Public method | RemoveChunk(String) | Remove the first chunk with a matching name. Only chunks without index qualifiers are considered. Name comparisons are not case-sensitive.
Public method | RemoveChunk(GH_IChunk) | Remove the specified chunk from the litter.
Public method | RemoveChunk(String, Int32) | Remove the first chunk with a matching name and index. Only chunks with index qualifiers are considered. Name comparisons are not case-sensitive.
Public method | RemoveItem(String) | Remove an unindexed item from this chunk.
Public method | RemoveItem(String, Int32) | Remove an indexed item from this chunk.
Public method | SetBoolean(String, Boolean) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetBoolean(String, Int32, Boolean) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetBoundingBox(String, GH_BoundingBox) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetBoundingBox(String, Int32, GH_BoundingBox) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetByte(String, Byte) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetByte(String, Int32, Byte) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetByteArray(String, array<Byte>[]()[][]) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetByteArray(String, Int32, array<Byte>[]()[][]) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDate(String, DateTime) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDate(String, Int32, DateTime) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDecimal(String, Decimal) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDecimal(String, Int32, Decimal) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDouble(String, Double) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDouble(String, Int32, Double) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDoubleArray(String, array<Double>[]()[][]) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDoubleArray(String, Int32, array<Double>[]()[][]) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDrawingBitmap(String, Bitmap) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingBitmap(String, Int32, Bitmap) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingColor(String, Color) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingColor(String, Int32, Color) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDrawingPoint(String, Point) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingPoint(String, Int32, Point) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDrawingPointF(String, PointF) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingPointF(String, Int32, PointF) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDrawingRectangle(String, Rectangle) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingRectangle(String, Int32, Rectangle) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDrawingRectangleF(String, RectangleF) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingRectangleF(String, Int32, RectangleF) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDrawingSize(String, Size) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingSize(String, Int32, Size) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetDrawingSizeF(String, SizeF) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingSizeF(String, Int32, SizeF) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetGuid(String, Guid) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetGuid(String, Int32, Guid) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetInt32(String, Int32) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetInt32(String, Int32, Int32) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetInt64(String, Int64) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetInt64(String, Int32, Int64) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetInterval1D(String, GH_Interval1D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetInterval1D(String, Int32, GH_Interval1D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetInterval2D(String, GH_Interval2D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetInterval2D(String, Int32, GH_Interval2D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetLine(String, GH_Line) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetLine(String, Int32, GH_Line) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetPath(String, String, String) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetPath(String, Int32, String, String) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetPlane(String, GH_Plane) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetPlane(String, Int32, GH_Plane) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetPoint2D(String, GH_Point2D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetPoint2D(String, Int32, GH_Point2D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetPoint3D(String, GH_Point3D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetPoint3D(String, Int32, GH_Point3D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetPoint4D(String, GH_Point4D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetPoint4D(String, Int32, GH_Point4D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetSingle(String, Single) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetSingle(String, Int32, Single) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetString(String, String) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetString(String, Int32, String) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetVersion(String, GH_Version) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetVersion(String, Int32, GH_Version) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetVersion(String, Int32, Int32, Int32) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetVersion(String, Int32, Int32, Int32, Int32) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | Write(BinaryWriter) | Called when an object is required to serialize itself. (Inherited from GH_IBinarySupport.)
Public method | Write(XmlWriter) | Called when an object is required to serialize itself. (Inherited from GH_IXmlSupport.)

See Also

GH_IWriter Interface
GH_IO.Serialization Namespace


AddComment Method

[image]

Grasshopper SDK
GH_IWriter..::..AddComment Method
GH_IWriter Interface See Also Send Feedback
Adds a text comment to this chunk. Comments are serialized only if the output flavour is a human readable format. Comments are never deserialized, they are purely for the benefit of the humans reading the file data.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void AddComment(
    string comment_text
)
Visual Basic
Sub AddComment ( _
    comment_text As String _
)

Parameters

comment_text
Type: System..::..String
The content of the comment, text might be altered if it contains invalid characters for a chosen format flavour.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the content text is either null or empty.

See Also

GH_IWriter Interface
GH_IO.Serialization Namespace


CreateChunk Method

[image] [image]

Grasshopper SDK
GH_IWriter..::..CreateChunk Method
GH_IWriter Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateChunk(String) | Create a new child chunk with the specified name but without an index qualifier. If another chunk already exists with similar properties, an exception will be thrown.
Public method | CreateChunk(String, Int32) | Create a new child chunk with the specified name and index qualifier. If another chunk already exists with similar properties, an exception will be thrown.

See Also

GH_IWriter Interface
GH_IWriter Members
GH_IO.Serialization Namespace


CreateChunk Method (String)

[image]

Grasshopper SDK
GH_IWriter..::..CreateChunk Method (String)
GH_IWriter Interface See Also Send Feedback
Create a new child chunk with the specified name but without an index qualifier. If another chunk already exists with similar properties, an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
GH_IWriter CreateChunk(
    string chunk_name
)
Visual Basic
Function CreateChunk ( _
    chunk_name As String _
) As GH_IWriter

Parameters

chunk_name
Type: System..::..String
Name of new child chunk.

Exceptions

Exception | Condition
System..::..ArgumentException | Thrown if the name coordinte is already occupied by another chunk.

See Also

GH_IWriter Interface
CreateChunk Overload
GH_IO.Serialization Namespace


CreateChunk Method (String, Int32)

[image]

Grasshopper SDK
GH_IWriter..::..CreateChunk Method (String, Int32)
GH_IWriter Interface See Also Send Feedback
Create a new child chunk with the specified name and index qualifier. If another chunk already exists with similar properties, an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
GH_IWriter CreateChunk(
    string chunk_name,
    int chunk_index
)
Visual Basic
Function CreateChunk ( _
    chunk_name As String, _
    chunk_index As Integer _
) As GH_IWriter

Parameters

chunk_name
Type: System..::..String
Name of new child.
chunk_index
Type: System..::..Int32
Index of new child.

Exceptions

Exception | Condition
System..::..ArgumentException | Thrown if the name+index coordinte is already occupied by another chunk.

See Also

GH_IWriter Interface
CreateChunk Overload
GH_IO.Serialization Namespace


Read Method

[image] [image]

Grasshopper SDK
GH_IWriter..::..Read Method
GH_IWriter Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | Read(BinaryReader) | Called when an object is required to deserialize itself. (Inherited from GH_IBinarySupport.)
Public method | Read(XmlNode) | Called when an object is required to deserialize itself. (Inherited from GH_IXmlSupport.)

See Also

GH_IWriter Interface
GH_IWriter Members
GH_IO.Serialization Namespace


RemoveChunk Method

[image] [image]

Grasshopper SDK
GH_IWriter..::..RemoveChunk Method
GH_IWriter Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveChunk(String) | Remove the first chunk with a matching name. Only chunks without index qualifiers are considered. Name comparisons are not case-sensitive.
Public method | RemoveChunk(GH_IChunk) | Remove the specified chunk from the litter.
Public method | RemoveChunk(String, Int32) | Remove the first chunk with a matching name and index. Only chunks with index qualifiers are considered. Name comparisons are not case-sensitive.

See Also

GH_IWriter Interface
GH_IWriter Members
GH_IO.Serialization Namespace


RemoveChunk Method (String)

[image]

Grasshopper SDK
GH_IWriter..::..RemoveChunk Method (String)
GH_IWriter Interface See Also Send Feedback
Remove the first chunk with a matching name. Only chunks without index qualifiers are considered. Name comparisons are not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool RemoveChunk(
    string chunk_name
)
Visual Basic
Function RemoveChunk ( _
    chunk_name As String _
) As Boolean

Parameters

chunk_name
Type: System..::..String
Name of chunk to remove.

Return Value

True is chunk was removed, false if no matching chunk could be found.

See Also

GH_IWriter Interface
RemoveChunk Overload
GH_IO.Serialization Namespace


RemoveChunk Method (GH_IChunk)

[image]

Grasshopper SDK
GH_IWriter..::..RemoveChunk Method (GH_IChunk)
GH_IWriter Interface See Also Send Feedback
Remove the specified chunk from the litter.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool RemoveChunk(
    GH_IChunk chunk
)
Visual Basic
Function RemoveChunk ( _
    chunk As GH_IChunk _
) As Boolean

Parameters

chunk
Type: GH_IO.Serialization..::..GH_IChunk
Chunk to remove.

Return Value

True is chunk was removed, false if chunk is not part of this litter.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if chunk is a null reference.

See Also

GH_IWriter Interface
RemoveChunk Overload
GH_IO.Serialization Namespace


RemoveChunk Method (String, Int32)

[image]

Grasshopper SDK
GH_IWriter..::..RemoveChunk Method (String, Int32)
GH_IWriter Interface See Also Send Feedback
Remove the first chunk with a matching name and index. Only chunks with index qualifiers are considered. Name comparisons are not case-sensitive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool RemoveChunk(
    string chunk_name,
    int chunk_index
)
Visual Basic
Function RemoveChunk ( _
    chunk_name As String, _
    chunk_index As Integer _
) As Boolean

Parameters

chunk_name
Type: System..::..String
Name of chunk to remove.
chunk_index
Type: System..::..Int32
Index of chunk to remove.

Return Value

True is chunk was removed, false if no matching chunk could be found.

See Also

GH_IWriter Interface
RemoveChunk Overload
GH_IO.Serialization Namespace


RemoveItem Method

[image] [image]

Grasshopper SDK
GH_IWriter..::..RemoveItem Method
GH_IWriter Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveItem(String) | Remove an unindexed item from this chunk.
Public method | RemoveItem(String, Int32) | Remove an indexed item from this chunk.

See Also

GH_IWriter Interface
GH_IWriter Members
GH_IO.Serialization Namespace


RemoveItem Method (String)

[image]

Grasshopper SDK
GH_IWriter..::..RemoveItem Method (String)
GH_IWriter Interface See Also Send Feedback
Remove an unindexed item from this chunk.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool RemoveItem(
    string itemName
)
Visual Basic
Function RemoveItem ( _
    itemName As String _
) As Boolean

Parameters

itemName
Type: System..::..String
Name of item.

Return Value

True on success, false on failure.

See Also

GH_IWriter Interface
RemoveItem Overload
GH_IO.Serialization Namespace


RemoveItem Method (String, Int32)

[image]

Grasshopper SDK
GH_IWriter..::..RemoveItem Method (String, Int32)
GH_IWriter Interface See Also Send Feedback
Remove an indexed item from this chunk.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
bool RemoveItem(
    string itemName,
    int itemIndex
)
Visual Basic
Function RemoveItem ( _
    itemName As String, _
    itemIndex As Integer _
) As Boolean

Parameters

itemName
Type: System..::..String
Name of item.
itemIndex
Type: System..::..Int32
Index of item.

Return Value

True on success, false on failure.

See Also

GH_IWriter Interface
RemoveItem Overload
GH_IO.Serialization Namespace


SetBoolean Method

[image] [image]

Grasshopper SDK
GH_IWriter..::..SetBoolean Method
GH_IWriter Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBoolean(String, Boolean) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetBoolean(String, Int32, Boolean) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_IWriter Interface
GH_IWriter Members
GH_IO.Serialization Namespace


SetBoolean Method (String, Boolean)

[image]

Grasshopper SDK
GH_IWriter..::..SetBoolean Method (String, Boolean)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetBoolean(
    string item_name,
    bool item_value
)
Visual Basic
Sub SetBoolean ( _
    item_name As String, _
    item_value As Boolean _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: System..::..Boolean
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_IWriter Interface
SetBoolean Overload
GH_IO.Serialization Namespace


SetBoolean Method (String, Int32, Boolean)

[image]

Grasshopper SDK
GH_IWriter..::..SetBoolean Method (String, Int32, Boolean)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetBoolean(
    string item_name,
    int item_index,
    bool item_value
)
Visual Basic
Sub SetBoolean ( _
    item_name As String, _
    item_index As Integer, _
    item_value As Boolean _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: System..::..Boolean
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_IWriter Interface
SetBoolean Overload
GH_IO.Serialization Namespace


SetBoundingBox Method

[image] [image]

Grasshopper SDK
GH_IWriter..::..SetBoundingBox Method
GH_IWriter Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBoundingBox(String, GH_BoundingBox) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetBoundingBox(String, Int32, GH_BoundingBox) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_IWriter Interface
GH_IWriter Members
GH_IO.Serialization Namespace


SetBoundingBox Method (String, GH_BoundingBox)

[image]

Grasshopper SDK
GH_IWriter..::..SetBoundingBox Method (String, GH_BoundingBox)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetBoundingBox(
    string item_name,
    GH_BoundingBox item_value
)
Visual Basic
Sub SetBoundingBox ( _
    item_name As String, _
    item_value As GH_BoundingBox _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: GH_IO.Types..::..GH_BoundingBox
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_IWriter Interface
SetBoundingBox Overload
GH_IO.Serialization Namespace


SetBoundingBox Method (String, Int32, GH_BoundingBox)

[image]

Grasshopper SDK
GH_IWriter..::..SetBoundingBox Method (String, Int32, GH_BoundingBox)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetBoundingBox(
    string item_name,
    int item_index,
    GH_BoundingBox item_value
)
Visual Basic
Sub SetBoundingBox ( _
    item_name As String, _
    item_index As Integer, _
    item_value As GH_BoundingBox _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: GH_IO.Types..::..GH_BoundingBox
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_IWriter Interface
SetBoundingBox Overload
GH_IO.Serialization Namespace


SetByte Method

[image] [image]

Grasshopper SDK
GH_IWriter..::..SetByte Method
GH_IWriter Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SetByte(String, Byte) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetByte(String, Int32, Byte) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_IWriter Interface
GH_IWriter Members
GH_IO.Serialization Namespace


SetByte Method (String, Byte)

[image]

Grasshopper SDK
GH_IWriter..::..SetByte Method (String, Byte)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetByte(
    string item_name,
    byte item_value
)
Visual Basic
Sub SetByte ( _
    item_name As String, _
    item_value As Byte _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: System..::..Byte
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_IWriter Interface
SetByte Overload
GH_IO.Serialization Namespace


SetByte Method (String, Int32, Byte)

[image]

Grasshopper SDK
GH_IWriter..::..SetByte Method (String, Int32, Byte)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetByte(
    string item_name,
    int item_index,
    byte item_value
)
Visual Basic
Sub SetByte ( _
    item_name As String, _
    item_index As Integer, _
    item_value As Byte _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: System..::..Byte
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_IWriter Interface
SetByte Overload
GH_IO.Serialization Namespace


SetByteArray Method

[image] [image]

Grasshopper SDK
GH_IWriter..::..SetByteArray Method
GH_IWriter Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SetByteArray(String, array<Byte>[]()[][]) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetByteArray(String, Int32, array<Byte>[]()[][]) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_IWriter Interface
GH_IWriter Members
GH_IO.Serialization Namespace


SetByteArray Method (String, Byte[])

[image]

Grasshopper SDK
GH_IWriter..::..SetByteArray Method (String, array<Byte>[]()[][])
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetByteArray(
    string item_name,
    byte[] item_value
)
Visual Basic
Sub SetByteArray ( _
    item_name As String, _
    item_value As Byte() _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: array< System..::..Byte >[]()[][]
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_IWriter Interface
SetByteArray Overload
GH_IO.Serialization Namespace


SetByteArray Method (String, Int32, Byte[])

[image]

Grasshopper SDK
GH_IWriter..::..SetByteArray Method (String, Int32, array<Byte>[]()[][])
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetByteArray(
    string item_name,
    int item_index,
    byte[] item_value
)
Visual Basic
Sub SetByteArray ( _
    item_name As String, _
    item_index As Integer, _
    item_value As Byte() _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: array< System..::..Byte >[]()[][]
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_IWriter Interface
SetByteArray Overload
GH_IO.Serialization Namespace


SetDate Method

[image] [image]

Grasshopper SDK
GH_IWriter..::..SetDate Method
GH_IWriter Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDate(String, DateTime) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDate(String, Int32, DateTime) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_IWriter Interface
GH_IWriter Members
GH_IO.Serialization Namespace


SetDate Method (String, DateTime)

[image]

Grasshopper SDK
GH_IWriter..::..SetDate Method (String, DateTime)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetDate(
    string item_name,
    DateTime item_value
)
Visual Basic
Sub SetDate ( _
    item_name As String, _
    item_value As DateTime _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: System..::..DateTime
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_IWriter Interface
SetDate Overload
GH_IO.Serialization Namespace


SetDate Method (String, Int32, DateTime)

[image]

Grasshopper SDK
GH_IWriter..::..SetDate Method (String, Int32, DateTime)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetDate(
    string item_name,
    int item_index,
    DateTime item_value
)
Visual Basic
Sub SetDate ( _
    item_name As String, _
    item_index As Integer, _
    item_value As DateTime _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: System..::..DateTime
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_IWriter Interface
SetDate Overload
GH_IO.Serialization Namespace


SetDecimal Method

[image] [image]

Grasshopper SDK
GH_IWriter..::..SetDecimal Method
GH_IWriter Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDecimal(String, Decimal) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDecimal(String, Int32, Decimal) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_IWriter Interface
GH_IWriter Members
GH_IO.Serialization Namespace


SetDecimal Method (String, Decimal)

[image]

Grasshopper SDK
GH_IWriter..::..SetDecimal Method (String, Decimal)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetDecimal(
    string item_name,
    decimal item_value
)
Visual Basic
Sub SetDecimal ( _
    item_name As String, _
    item_value As Decimal _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: System..::..Decimal
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_IWriter Interface
SetDecimal Overload
GH_IO.Serialization Namespace


SetDecimal Method (String, Int32, Decimal)

[image]

Grasshopper SDK
GH_IWriter..::..SetDecimal Method (String, Int32, Decimal)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetDecimal(
    string item_name,
    int item_index,
    decimal item_value
)
Visual Basic
Sub SetDecimal ( _
    item_name As String, _
    item_index As Integer, _
    item_value As Decimal _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: System..::..Decimal
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_IWriter Interface
SetDecimal Overload
GH_IO.Serialization Namespace


SetDouble Method

[image] [image]

Grasshopper SDK
GH_IWriter..::..SetDouble Method
GH_IWriter Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDouble(String, Double) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDouble(String, Int32, Double) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_IWriter Interface
GH_IWriter Members
GH_IO.Serialization Namespace


SetDouble Method (String, Double)

[image]

Grasshopper SDK
GH_IWriter..::..SetDouble Method (String, Double)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetDouble(
    string item_name,
    double item_value
)
Visual Basic
Sub SetDouble ( _
    item_name As String, _
    item_value As Double _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: System..::..Double
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_IWriter Interface
SetDouble Overload
GH_IO.Serialization Namespace


SetDouble Method (String, Int32, Double)

[image]

Grasshopper SDK
GH_IWriter..::..SetDouble Method (String, Int32, Double)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetDouble(
    string item_name,
    int item_index,
    double item_value
)
Visual Basic
Sub SetDouble ( _
    item_name As String, _
    item_index As Integer, _
    item_value As Double _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: System..::..Double
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_IWriter Interface
SetDouble Overload
GH_IO.Serialization Namespace


SetDoubleArray Method

[image] [image]

Grasshopper SDK
GH_IWriter..::..SetDoubleArray Method
GH_IWriter Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDoubleArray(String, array<Double>[]()[][]) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDoubleArray(String, Int32, array<Double>[]()[][]) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_IWriter Interface
GH_IWriter Members
GH_IO.Serialization Namespace


SetDoubleArray Method (String, Double[])

[image]

Grasshopper SDK
GH_IWriter..::..SetDoubleArray Method (String, array<Double>[]()[][])
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetDoubleArray(
    string item_name,
    double[] item_value
)
Visual Basic
Sub SetDoubleArray ( _
    item_name As String, _
    item_value As Double() _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: array< System..::..Double >[]()[][]
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_IWriter Interface
SetDoubleArray Overload
GH_IO.Serialization Namespace


SetDoubleArray Method (String, Int32, Double[])

[image]

Grasshopper SDK
GH_IWriter..::..SetDoubleArray Method (String, Int32, array<Double>[]()[][])
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetDoubleArray(
    string item_name,
    int item_index,
    double[] item_value
)
Visual Basic
Sub SetDoubleArray ( _
    item_name As String, _
    item_index As Integer, _
    item_value As Double() _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: array< System..::..Double >[]()[][]
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_IWriter Interface
SetDoubleArray Overload
GH_IO.Serialization Namespace


SetDrawingBitmap Method

[image] [image]

Grasshopper SDK
GH_IWriter..::..SetDrawingBitmap Method
GH_IWriter Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDrawingBitmap(String, Bitmap) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingBitmap(String, Int32, Bitmap) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.

See Also

GH_IWriter Interface
GH_IWriter Members
GH_IO.Serialization Namespace


SetDrawingBitmap Method (String, Bitmap)

[image]

Grasshopper SDK
GH_IWriter..::..SetDrawingBitmap Method (String, Bitmap)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetDrawingBitmap(
    string item_name,
    Bitmap item_value
)
Visual Basic
Sub SetDrawingBitmap ( _
    item_name As String, _
    item_value As Bitmap _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: System.Drawing..::..Bitmap
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_IWriter Interface
SetDrawingBitmap Overload
GH_IO.Serialization Namespace


SetDrawingBitmap Method (String, Int32, Bitmap)

[image]

Grasshopper SDK
GH_IWriter..::..SetDrawingBitmap Method (String, Int32, Bitmap)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetDrawingBitmap(
    string item_name,
    int item_index,
    Bitmap item_value
)
Visual Basic
Sub SetDrawingBitmap ( _
    item_name As String, _
    item_index As Integer, _
    item_value As Bitmap _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: System.Drawing..::..Bitmap
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_IWriter Interface
SetDrawingBitmap Overload
GH_IO.Serialization Namespace


SetDrawingColor Method

[image] [image]

Grasshopper SDK
GH_IWriter..::..SetDrawingColor Method
GH_IWriter Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDrawingColor(String, Color) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingColor(String, Int32, Color) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_IWriter Interface
GH_IWriter Members
GH_IO.Serialization Namespace


SetDrawingColor Method (String, Color)

[image]

Grasshopper SDK
GH_IWriter..::..SetDrawingColor Method (String, Color)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetDrawingColor(
    string item_name,
    Color item_value
)
Visual Basic
Sub SetDrawingColor ( _
    item_name As String, _
    item_value As Color _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: System.Drawing..::..Color
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_IWriter Interface
SetDrawingColor Overload
GH_IO.Serialization Namespace


SetDrawingColor Method (String, Int32, Color)

[image]

Grasshopper SDK
GH_IWriter..::..SetDrawingColor Method (String, Int32, Color)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetDrawingColor(
    string item_name,
    int item_index,
    Color item_value
)
Visual Basic
Sub SetDrawingColor ( _
    item_name As String, _
    item_index As Integer, _
    item_value As Color _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: System.Drawing..::..Color
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_IWriter Interface
SetDrawingColor Overload
GH_IO.Serialization Namespace


SetDrawingPoint Method

[image] [image]

Grasshopper SDK
GH_IWriter..::..SetDrawingPoint Method
GH_IWriter Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDrawingPoint(String, Point) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingPoint(String, Int32, Point) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_IWriter Interface
GH_IWriter Members
GH_IO.Serialization Namespace


SetDrawingPoint Method (String, Point)

[image]

Grasshopper SDK
GH_IWriter..::..SetDrawingPoint Method (String, Point)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetDrawingPoint(
    string item_name,
    Point item_value
)
Visual Basic
Sub SetDrawingPoint ( _
    item_name As String, _
    item_value As Point _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: System.Drawing..::..Point
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_IWriter Interface
SetDrawingPoint Overload
GH_IO.Serialization Namespace


SetDrawingPoint Method (String, Int32, Point)

[image]

Grasshopper SDK
GH_IWriter..::..SetDrawingPoint Method (String, Int32, Point)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetDrawingPoint(
    string item_name,
    int item_index,
    Point item_value
)
Visual Basic
Sub SetDrawingPoint ( _
    item_name As String, _
    item_index As Integer, _
    item_value As Point _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: System.Drawing..::..Point
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_IWriter Interface
SetDrawingPoint Overload
GH_IO.Serialization Namespace


SetDrawingPointF Method

[image] [image]

Grasshopper SDK
GH_IWriter..::..SetDrawingPointF Method
GH_IWriter Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDrawingPointF(String, PointF) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingPointF(String, Int32, PointF) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_IWriter Interface
GH_IWriter Members
GH_IO.Serialization Namespace


SetDrawingPointF Method (String, PointF)

[image]

Grasshopper SDK
GH_IWriter..::..SetDrawingPointF Method (String, PointF)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetDrawingPointF(
    string item_name,
    PointF item_value
)
Visual Basic
Sub SetDrawingPointF ( _
    item_name As String, _
    item_value As PointF _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: System.Drawing..::..PointF
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_IWriter Interface
SetDrawingPointF Overload
GH_IO.Serialization Namespace


SetDrawingPointF Method (String, Int32, PointF)

[image]

Grasshopper SDK
GH_IWriter..::..SetDrawingPointF Method (String, Int32, PointF)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetDrawingPointF(
    string item_name,
    int item_index,
    PointF item_value
)
Visual Basic
Sub SetDrawingPointF ( _
    item_name As String, _
    item_index As Integer, _
    item_value As PointF _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: System.Drawing..::..PointF
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_IWriter Interface
SetDrawingPointF Overload
GH_IO.Serialization Namespace


SetDrawingRectangle Method

[image] [image]

Grasshopper SDK
GH_IWriter..::..SetDrawingRectangle Method
GH_IWriter Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDrawingRectangle(String, Rectangle) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingRectangle(String, Int32, Rectangle) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_IWriter Interface
GH_IWriter Members
GH_IO.Serialization Namespace


SetDrawingRectangle Method (String, Rectangle)

[image]

Grasshopper SDK
GH_IWriter..::..SetDrawingRectangle Method (String, Rectangle)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetDrawingRectangle(
    string item_name,
    Rectangle item_value
)
Visual Basic
Sub SetDrawingRectangle ( _
    item_name As String, _
    item_value As Rectangle _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: System.Drawing..::..Rectangle
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_IWriter Interface
SetDrawingRectangle Overload
GH_IO.Serialization Namespace


SetDrawingRectangle Method (String, Int32, Rectangle)

[image]

Grasshopper SDK
GH_IWriter..::..SetDrawingRectangle Method (String, Int32, Rectangle)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetDrawingRectangle(
    string item_name,
    int item_index,
    Rectangle item_value
)
Visual Basic
Sub SetDrawingRectangle ( _
    item_name As String, _
    item_index As Integer, _
    item_value As Rectangle _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: System.Drawing..::..Rectangle
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_IWriter Interface
SetDrawingRectangle Overload
GH_IO.Serialization Namespace


SetDrawingRectangleF Method

[image] [image]

Grasshopper SDK
GH_IWriter..::..SetDrawingRectangleF Method
GH_IWriter Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDrawingRectangleF(String, RectangleF) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingRectangleF(String, Int32, RectangleF) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_IWriter Interface
GH_IWriter Members
GH_IO.Serialization Namespace


SetDrawingRectangleF Method (String, RectangleF)

[image]

Grasshopper SDK
GH_IWriter..::..SetDrawingRectangleF Method (String, RectangleF)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetDrawingRectangleF(
    string item_name,
    RectangleF item_value
)
Visual Basic
Sub SetDrawingRectangleF ( _
    item_name As String, _
    item_value As RectangleF _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: System.Drawing..::..RectangleF
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_IWriter Interface
SetDrawingRectangleF Overload
GH_IO.Serialization Namespace


SetDrawingRectangleF Method (String, Int32, RectangleF)

[image]

Grasshopper SDK
GH_IWriter..::..SetDrawingRectangleF Method (String, Int32, RectangleF)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetDrawingRectangleF(
    string item_name,
    int item_index,
    RectangleF item_value
)
Visual Basic
Sub SetDrawingRectangleF ( _
    item_name As String, _
    item_index As Integer, _
    item_value As RectangleF _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: System.Drawing..::..RectangleF
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_IWriter Interface
SetDrawingRectangleF Overload
GH_IO.Serialization Namespace


SetDrawingSize Method

[image] [image]

Grasshopper SDK
GH_IWriter..::..SetDrawingSize Method
GH_IWriter Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDrawingSize(String, Size) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingSize(String, Int32, Size) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_IWriter Interface
GH_IWriter Members
GH_IO.Serialization Namespace


SetDrawingSize Method (String, Size)

[image]

Grasshopper SDK
GH_IWriter..::..SetDrawingSize Method (String, Size)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetDrawingSize(
    string item_name,
    Size item_value
)
Visual Basic
Sub SetDrawingSize ( _
    item_name As String, _
    item_value As Size _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: System.Drawing..::..Size
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_IWriter Interface
SetDrawingSize Overload
GH_IO.Serialization Namespace


SetDrawingSize Method (String, Int32, Size)

[image]

Grasshopper SDK
GH_IWriter..::..SetDrawingSize Method (String, Int32, Size)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetDrawingSize(
    string item_name,
    int item_index,
    Size item_value
)
Visual Basic
Sub SetDrawingSize ( _
    item_name As String, _
    item_index As Integer, _
    item_value As Size _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: System.Drawing..::..Size
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_IWriter Interface
SetDrawingSize Overload
GH_IO.Serialization Namespace


SetDrawingSizeF Method

[image] [image]

Grasshopper SDK
GH_IWriter..::..SetDrawingSizeF Method
GH_IWriter Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDrawingSizeF(String, SizeF) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetDrawingSizeF(String, Int32, SizeF) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_IWriter Interface
GH_IWriter Members
GH_IO.Serialization Namespace


SetDrawingSizeF Method (String, SizeF)

[image]

Grasshopper SDK
GH_IWriter..::..SetDrawingSizeF Method (String, SizeF)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetDrawingSizeF(
    string item_name,
    SizeF item_value
)
Visual Basic
Sub SetDrawingSizeF ( _
    item_name As String, _
    item_value As SizeF _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: System.Drawing..::..SizeF
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_IWriter Interface
SetDrawingSizeF Overload
GH_IO.Serialization Namespace


SetDrawingSizeF Method (String, Int32, SizeF)

[image]

Grasshopper SDK
GH_IWriter..::..SetDrawingSizeF Method (String, Int32, SizeF)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetDrawingSizeF(
    string item_name,
    int item_index,
    SizeF item_value
)
Visual Basic
Sub SetDrawingSizeF ( _
    item_name As String, _
    item_index As Integer, _
    item_value As SizeF _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: System.Drawing..::..SizeF
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_IWriter Interface
SetDrawingSizeF Overload
GH_IO.Serialization Namespace


SetGuid Method

[image] [image]

Grasshopper SDK
GH_IWriter..::..SetGuid Method
GH_IWriter Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SetGuid(String, Guid) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetGuid(String, Int32, Guid) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_IWriter Interface
GH_IWriter Members
GH_IO.Serialization Namespace


SetGuid Method (String, Guid)

[image]

Grasshopper SDK
GH_IWriter..::..SetGuid Method (String, Guid)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetGuid(
    string item_name,
    Guid item_value
)
Visual Basic
Sub SetGuid ( _
    item_name As String, _
    item_value As Guid _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: System..::..Guid
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_IWriter Interface
SetGuid Overload
GH_IO.Serialization Namespace


SetGuid Method (String, Int32, Guid)

[image]

Grasshopper SDK
GH_IWriter..::..SetGuid Method (String, Int32, Guid)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetGuid(
    string item_name,
    int item_index,
    Guid item_value
)
Visual Basic
Sub SetGuid ( _
    item_name As String, _
    item_index As Integer, _
    item_value As Guid _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: System..::..Guid
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_IWriter Interface
SetGuid Overload
GH_IO.Serialization Namespace


SetInt32 Method

[image] [image]

Grasshopper SDK
GH_IWriter..::..SetInt32 Method
GH_IWriter Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SetInt32(String, Int32) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetInt32(String, Int32, Int32) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_IWriter Interface
GH_IWriter Members
GH_IO.Serialization Namespace


SetInt32 Method (String, Int32)

[image]

Grasshopper SDK
GH_IWriter..::..SetInt32 Method (String, Int32)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetInt32(
    string item_name,
    int item_value
)
Visual Basic
Sub SetInt32 ( _
    item_name As String, _
    item_value As Integer _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: System..::..Int32
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_IWriter Interface
SetInt32 Overload
GH_IO.Serialization Namespace


SetInt32 Method (String, Int32, Int32)

[image]

Grasshopper SDK
GH_IWriter..::..SetInt32 Method (String, Int32, Int32)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetInt32(
    string item_name,
    int item_index,
    int item_value
)
Visual Basic
Sub SetInt32 ( _
    item_name As String, _
    item_index As Integer, _
    item_value As Integer _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: System..::..Int32
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_IWriter Interface
SetInt32 Overload
GH_IO.Serialization Namespace


SetInt64 Method

[image] [image]

Grasshopper SDK
GH_IWriter..::..SetInt64 Method
GH_IWriter Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SetInt64(String, Int64) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetInt64(String, Int32, Int64) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_IWriter Interface
GH_IWriter Members
GH_IO.Serialization Namespace


SetInt64 Method (String, Int64)

[image]

Grasshopper SDK
GH_IWriter..::..SetInt64 Method (String, Int64)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetInt64(
    string item_name,
    long item_value
)
Visual Basic
Sub SetInt64 ( _
    item_name As String, _
    item_value As Long _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: System..::..Int64
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_IWriter Interface
SetInt64 Overload
GH_IO.Serialization Namespace


SetInt64 Method (String, Int32, Int64)

[image]

Grasshopper SDK
GH_IWriter..::..SetInt64 Method (String, Int32, Int64)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetInt64(
    string item_name,
    int item_index,
    long item_value
)
Visual Basic
Sub SetInt64 ( _
    item_name As String, _
    item_index As Integer, _
    item_value As Long _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: System..::..Int64
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_IWriter Interface
SetInt64 Overload
GH_IO.Serialization Namespace


SetInterval1D Method

[image] [image]

Grasshopper SDK
GH_IWriter..::..SetInterval1D Method
GH_IWriter Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SetInterval1D(String, GH_Interval1D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetInterval1D(String, Int32, GH_Interval1D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_IWriter Interface
GH_IWriter Members
GH_IO.Serialization Namespace


SetInterval1D Method (String, GH_Interval1D)

[image]

Grasshopper SDK
GH_IWriter..::..SetInterval1D Method (String, GH_Interval1D)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetInterval1D(
    string item_name,
    GH_Interval1D item_value
)
Visual Basic
Sub SetInterval1D ( _
    item_name As String, _
    item_value As GH_Interval1D _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: GH_IO.Types..::..GH_Interval1D
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_IWriter Interface
SetInterval1D Overload
GH_IO.Serialization Namespace


SetInterval1D Method (String, Int32, GH_Interval1D)

[image]

Grasshopper SDK
GH_IWriter..::..SetInterval1D Method (String, Int32, GH_Interval1D)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetInterval1D(
    string item_name,
    int item_index,
    GH_Interval1D item_value
)
Visual Basic
Sub SetInterval1D ( _
    item_name As String, _
    item_index As Integer, _
    item_value As GH_Interval1D _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: GH_IO.Types..::..GH_Interval1D
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_IWriter Interface
SetInterval1D Overload
GH_IO.Serialization Namespace


SetInterval2D Method

[image] [image]

Grasshopper SDK
GH_IWriter..::..SetInterval2D Method
GH_IWriter Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SetInterval2D(String, GH_Interval2D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetInterval2D(String, Int32, GH_Interval2D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_IWriter Interface
GH_IWriter Members
GH_IO.Serialization Namespace


SetInterval2D Method (String, GH_Interval2D)

[image]

Grasshopper SDK
GH_IWriter..::..SetInterval2D Method (String, GH_Interval2D)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetInterval2D(
    string item_name,
    GH_Interval2D item_value
)
Visual Basic
Sub SetInterval2D ( _
    item_name As String, _
    item_value As GH_Interval2D _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: GH_IO.Types..::..GH_Interval2D
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_IWriter Interface
SetInterval2D Overload
GH_IO.Serialization Namespace


SetInterval2D Method (String, Int32, GH_Interval2D)

[image]

Grasshopper SDK
GH_IWriter..::..SetInterval2D Method (String, Int32, GH_Interval2D)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetInterval2D(
    string item_name,
    int item_index,
    GH_Interval2D item_value
)
Visual Basic
Sub SetInterval2D ( _
    item_name As String, _
    item_index As Integer, _
    item_value As GH_Interval2D _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: GH_IO.Types..::..GH_Interval2D
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_IWriter Interface
SetInterval2D Overload
GH_IO.Serialization Namespace


SetLine Method

[image] [image]

Grasshopper SDK
GH_IWriter..::..SetLine Method
GH_IWriter Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SetLine(String, GH_Line) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetLine(String, Int32, GH_Line) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_IWriter Interface
GH_IWriter Members
GH_IO.Serialization Namespace


SetLine Method (String, GH_Line)

[image]

Grasshopper SDK
GH_IWriter..::..SetLine Method (String, GH_Line)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetLine(
    string item_name,
    GH_Line item_value
)
Visual Basic
Sub SetLine ( _
    item_name As String, _
    item_value As GH_Line _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: GH_IO.Types..::..GH_Line
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_IWriter Interface
SetLine Overload
GH_IO.Serialization Namespace


SetLine Method (String, Int32, GH_Line)

[image]

Grasshopper SDK
GH_IWriter..::..SetLine Method (String, Int32, GH_Line)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetLine(
    string item_name,
    int item_index,
    GH_Line item_value
)
Visual Basic
Sub SetLine ( _
    item_name As String, _
    item_index As Integer, _
    item_value As GH_Line _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: GH_IO.Types..::..GH_Line
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_IWriter Interface
SetLine Overload
GH_IO.Serialization Namespace


SetPath Method

[image] [image]

Grasshopper SDK
GH_IWriter..::..SetPath Method
GH_IWriter Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SetPath(String, String, String) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetPath(String, Int32, String, String) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_IWriter Interface
GH_IWriter Members
GH_IO.Serialization Namespace


SetPath Method (String, String, String)

[image]

Grasshopper SDK
GH_IWriter..::..SetPath Method (String, String, String)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetPath(
    string item_name,
    string absolutePath,
    string basePath
)
Visual Basic
Sub SetPath ( _
    item_name As String, _
    absolutePath As String, _
    basePath As String _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
absolutePath
Type: System..::..String
Absolute path to store.
basePath
Type: System..::..String
Base path. This will be used to also store a relative path.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_IWriter Interface
SetPath Overload
GH_IO.Serialization Namespace


SetPath Method (String, Int32, String, String)

[image]

Grasshopper SDK
GH_IWriter..::..SetPath Method (String, Int32, String, String)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetPath(
    string item_name,
    int item_index,
    string absolutePath,
    string basePath
)
Visual Basic
Sub SetPath ( _
    item_name As String, _
    item_index As Integer, _
    absolutePath As String, _
    basePath As String _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
absolutePath
Type: System..::..String
Absolute path to store.
basePath
Type: System..::..String
Base path. This will be used to also store a relative path.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_IWriter Interface
SetPath Overload
GH_IO.Serialization Namespace


SetPlane Method

[image] [image]

Grasshopper SDK
GH_IWriter..::..SetPlane Method
GH_IWriter Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SetPlane(String, GH_Plane) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetPlane(String, Int32, GH_Plane) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_IWriter Interface
GH_IWriter Members
GH_IO.Serialization Namespace


SetPlane Method (String, GH_Plane)

[image]

Grasshopper SDK
GH_IWriter..::..SetPlane Method (String, GH_Plane)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetPlane(
    string item_name,
    GH_Plane item_value
)
Visual Basic
Sub SetPlane ( _
    item_name As String, _
    item_value As GH_Plane _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: GH_IO.Types..::..GH_Plane
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_IWriter Interface
SetPlane Overload
GH_IO.Serialization Namespace


SetPlane Method (String, Int32, GH_Plane)

[image]

Grasshopper SDK
GH_IWriter..::..SetPlane Method (String, Int32, GH_Plane)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetPlane(
    string item_name,
    int item_index,
    GH_Plane item_value
)
Visual Basic
Sub SetPlane ( _
    item_name As String, _
    item_index As Integer, _
    item_value As GH_Plane _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: GH_IO.Types..::..GH_Plane
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_IWriter Interface
SetPlane Overload
GH_IO.Serialization Namespace


SetPoint2D Method

[image] [image]

Grasshopper SDK
GH_IWriter..::..SetPoint2D Method
GH_IWriter Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SetPoint2D(String, GH_Point2D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetPoint2D(String, Int32, GH_Point2D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_IWriter Interface
GH_IWriter Members
GH_IO.Serialization Namespace


SetPoint2D Method (String, GH_Point2D)

[image]

Grasshopper SDK
GH_IWriter..::..SetPoint2D Method (String, GH_Point2D)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetPoint2D(
    string item_name,
    GH_Point2D item_value
)
Visual Basic
Sub SetPoint2D ( _
    item_name As String, _
    item_value As GH_Point2D _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: GH_IO.Types..::..GH_Point2D
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_IWriter Interface
SetPoint2D Overload
GH_IO.Serialization Namespace


SetPoint2D Method (String, Int32, GH_Point2D)

[image]

Grasshopper SDK
GH_IWriter..::..SetPoint2D Method (String, Int32, GH_Point2D)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetPoint2D(
    string item_name,
    int item_index,
    GH_Point2D item_value
)
Visual Basic
Sub SetPoint2D ( _
    item_name As String, _
    item_index As Integer, _
    item_value As GH_Point2D _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: GH_IO.Types..::..GH_Point2D
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_IWriter Interface
SetPoint2D Overload
GH_IO.Serialization Namespace


SetPoint3D Method

[image] [image]

Grasshopper SDK
GH_IWriter..::..SetPoint3D Method
GH_IWriter Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SetPoint3D(String, GH_Point3D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetPoint3D(String, Int32, GH_Point3D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_IWriter Interface
GH_IWriter Members
GH_IO.Serialization Namespace


SetPoint3D Method (String, GH_Point3D)

[image]

Grasshopper SDK
GH_IWriter..::..SetPoint3D Method (String, GH_Point3D)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetPoint3D(
    string item_name,
    GH_Point3D item_value
)
Visual Basic
Sub SetPoint3D ( _
    item_name As String, _
    item_value As GH_Point3D _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: GH_IO.Types..::..GH_Point3D
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_IWriter Interface
SetPoint3D Overload
GH_IO.Serialization Namespace


SetPoint3D Method (String, Int32, GH_Point3D)

[image]

Grasshopper SDK
GH_IWriter..::..SetPoint3D Method (String, Int32, GH_Point3D)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetPoint3D(
    string item_name,
    int item_index,
    GH_Point3D item_value
)
Visual Basic
Sub SetPoint3D ( _
    item_name As String, _
    item_index As Integer, _
    item_value As GH_Point3D _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: GH_IO.Types..::..GH_Point3D
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_IWriter Interface
SetPoint3D Overload
GH_IO.Serialization Namespace


SetPoint4D Method

[image] [image]

Grasshopper SDK
GH_IWriter..::..SetPoint4D Method
GH_IWriter Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SetPoint4D(String, GH_Point4D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetPoint4D(String, Int32, GH_Point4D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_IWriter Interface
GH_IWriter Members
GH_IO.Serialization Namespace


SetPoint4D Method (String, GH_Point4D)

[image]

Grasshopper SDK
GH_IWriter..::..SetPoint4D Method (String, GH_Point4D)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetPoint4D(
    string item_name,
    GH_Point4D item_value
)
Visual Basic
Sub SetPoint4D ( _
    item_name As String, _
    item_value As GH_Point4D _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: GH_IO.Types..::..GH_Point4D
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_IWriter Interface
SetPoint4D Overload
GH_IO.Serialization Namespace


SetPoint4D Method (String, Int32, GH_Point4D)

[image]

Grasshopper SDK
GH_IWriter..::..SetPoint4D Method (String, Int32, GH_Point4D)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetPoint4D(
    string item_name,
    int item_index,
    GH_Point4D item_value
)
Visual Basic
Sub SetPoint4D ( _
    item_name As String, _
    item_index As Integer, _
    item_value As GH_Point4D _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: GH_IO.Types..::..GH_Point4D
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_IWriter Interface
SetPoint4D Overload
GH_IO.Serialization Namespace


SetSingle Method

[image] [image]

Grasshopper SDK
GH_IWriter..::..SetSingle Method
GH_IWriter Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SetSingle(String, Single) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetSingle(String, Int32, Single) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_IWriter Interface
GH_IWriter Members
GH_IO.Serialization Namespace


SetSingle Method (String, Single)

[image]

Grasshopper SDK
GH_IWriter..::..SetSingle Method (String, Single)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetSingle(
    string item_name,
    float item_value
)
Visual Basic
Sub SetSingle ( _
    item_name As String, _
    item_value As Single _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: System..::..Single
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_IWriter Interface
SetSingle Overload
GH_IO.Serialization Namespace


SetSingle Method (String, Int32, Single)

[image]

Grasshopper SDK
GH_IWriter..::..SetSingle Method (String, Int32, Single)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetSingle(
    string item_name,
    int item_index,
    float item_value
)
Visual Basic
Sub SetSingle ( _
    item_name As String, _
    item_index As Integer, _
    item_value As Single _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: System..::..Single
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_IWriter Interface
SetSingle Overload
GH_IO.Serialization Namespace


SetString Method

[image] [image]

Grasshopper SDK
GH_IWriter..::..SetString Method
GH_IWriter Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SetString(String, String) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetString(String, Int32, String) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_IWriter Interface
GH_IWriter Members
GH_IO.Serialization Namespace


SetString Method (String, String)

[image]

Grasshopper SDK
GH_IWriter..::..SetString Method (String, String)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetString(
    string item_name,
    string item_value
)
Visual Basic
Sub SetString ( _
    item_name As String, _
    item_value As String _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: System..::..String
Value of item to add. If a null String is supplied, a zero-length String will be serialized.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_IWriter Interface
SetString Overload
GH_IO.Serialization Namespace


SetString Method (String, Int32, String)

[image]

Grasshopper SDK
GH_IWriter..::..SetString Method (String, Int32, String)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetString(
    string item_name,
    int item_index,
    string item_value
)
Visual Basic
Sub SetString ( _
    item_name As String, _
    item_index As Integer, _
    item_value As String _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: System..::..String
Value of item to add. If a null String is supplied, a zero-length String will be serialized.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_IWriter Interface
SetString Overload
GH_IO.Serialization Namespace


SetVersion Method

[image] [image]

Grasshopper SDK
GH_IWriter..::..SetVersion Method
GH_IWriter Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SetVersion(String, GH_Version) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetVersion(String, Int32, GH_Version) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public method | SetVersion(String, Int32, Int32, Int32) | Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public method | SetVersion(String, Int32, Int32, Int32, Int32) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

See Also

GH_IWriter Interface
GH_IWriter Members
GH_IO.Serialization Namespace


SetVersion Method (String, GH_Version)

[image]

Grasshopper SDK
GH_IWriter..::..SetVersion Method (String, GH_Version)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetVersion(
    string item_name,
    GH_Version item_value
)
Visual Basic
Sub SetVersion ( _
    item_name As String, _
    item_value As GH_Version _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_value
Type: GH_IO.Types..::..GH_Version
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_IWriter Interface
SetVersion Overload
GH_IO.Serialization Namespace


SetVersion Method (String, Int32, GH_Version)

[image]

Grasshopper SDK
GH_IWriter..::..SetVersion Method (String, Int32, GH_Version)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetVersion(
    string item_name,
    int item_index,
    GH_Version item_value
)
Visual Basic
Sub SetVersion ( _
    item_name As String, _
    item_index As Integer, _
    item_value As GH_Version _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
item_value
Type: GH_IO.Types..::..GH_Version
Value of item to add.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_IWriter Interface
SetVersion Overload
GH_IO.Serialization Namespace


SetVersion Method (String, Int32, Int32, Int32)

[image]

Grasshopper SDK
GH_IWriter..::..SetVersion Method (String, Int32, Int32, Int32)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetVersion(
    string item_name,
    int major,
    int minor,
    int revision
)
Visual Basic
Sub SetVersion ( _
    item_name As String, _
    major As Integer, _
    minor As Integer, _
    revision As Integer _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
major
Type: System..::..Int32
Major component of version structure.
minor
Type: System..::..Int32
Minor component of version structure.
revision
Type: System..::..Int32
Revision component of version structure.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name already exists.

See Also

GH_IWriter Interface
SetVersion Overload
GH_IO.Serialization Namespace


SetVersion Method (String, Int32, Int32, Int32, Int32)

[image]

Grasshopper SDK
GH_IWriter..::..SetVersion Method (String, Int32, Int32, Int32, Int32)
GH_IWriter Interface See Also Send Feedback
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void SetVersion(
    string item_name,
    int item_index,
    int major,
    int minor,
    int revision
)
Visual Basic
Sub SetVersion ( _
    item_name As String, _
    item_index As Integer, _
    major As Integer, _
    minor As Integer, _
    revision As Integer _
)

Parameters

item_name
Type: System..::..String
Name of item to add.
item_index
Type: System..::..Int32
Index of item to add.
major
Type: System..::..Int32
Major component of version structure.
minor
Type: System..::..Int32
Minor component of version structure.
revision
Type: System..::..Int32
Revision component of version structure.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown if another item with the same name and index already exists.

See Also

GH_IWriter Interface
SetVersion Overload
GH_IO.Serialization Namespace


Write Method

[image] [image]

Grasshopper SDK
GH_IWriter..::..Write Method
GH_IWriter Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | Write(BinaryWriter) | Called when an object is required to serialize itself. (Inherited from GH_IBinarySupport.)
Public method | Write(XmlWriter) | Called when an object is required to serialize itself. (Inherited from GH_IXmlSupport.)

See Also

GH_IWriter Interface
GH_IWriter Members
GH_IO.Serialization Namespace


GH_IWriter Properties

[image] [image]

Grasshopper SDK
GH_IWriter Properties
GH_IWriter Interface See Also Send Feedback

The GH_IWriter type exposes the following members.

Properties

 | Name | Description
Public property | Archive | Gets a pointer to the archive that owns the Root of the tree this chunk belongs to. (Inherited from GH_IChunk.)
Public property | ArchiveLocation | Gets a string representing the URI with which the archive is associated. The location may be a null string. (Inherited from GH_IChunk.)
Public property | ChunkCount | Gets the number of child chunks contained in this chunk. The set of all child chunks is referred to as a 'litter'. (Inherited from GH_IChunk.)
Public property | Chunks | Gets a pointer to the internal list of child chunks. Do not access this list unless you know what you are doing. (Inherited from GH_IChunk.)
Public property | Index | Gets the index of this chunk. The index is set by the owner of this chunk. Indices smaller than zero imply no index has been set. The combination of name+index is always unique among a set of chunks in the same litter. (Inherited from GH_IChunk.)
Public property | ItemCount | Gets the number of items contained in this chunk. (Inherited from GH_IChunk.)
Public property | Items | Gets a pointer to the internal list of items. Do not access this list unless you know what you are doing. (Inherited from GH_IChunk.)
Public property | Name | Gets the name of this chunk. The name is set by the owner of this chunk. Names must be at least 1 character long. The combination of name+index is always unique among a set of chunks in a single litter. (Inherited from GH_IChunk.)

See Also

GH_IWriter Interface
GH_IO.Serialization Namespace


GH_IXmlSupport Interface

[image]

Grasshopper SDK
GH_IXmlSupport Interface
Members See Also Send Feedback
Interface which declares all methods required for objects that can be (de)serialized to and from an Xml archive.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public interface GH_IXmlSupport
Visual Basic
Public Interface GH_IXmlSupport

See Also

GH_IXmlSupport Members
GH_IO.Serialization Namespace


GH_IXmlSupport Members

[image] [image]

Grasshopper SDK
GH_IXmlSupport Members
GH_IXmlSupport Interface Methods See Also Send Feedback

The GH_IXmlSupport type exposes the following members.

Methods

 | Name | Description
Public method | Read | Called when an object is required to deserialize itself.
Public method | Write | Called when an object is required to serialize itself.

See Also

GH_IXmlSupport Interface
GH_IO.Serialization Namespace


GH_IXmlSupport Methods

[image] [image]

Grasshopper SDK
GH_IXmlSupport Methods
GH_IXmlSupport Interface See Also Send Feedback

The GH_IXmlSupport type exposes the following members.

Methods

 | Name | Description
Public method | Read | Called when an object is required to deserialize itself.
Public method | Write | Called when an object is required to serialize itself.

See Also

GH_IXmlSupport Interface
GH_IO.Serialization Namespace


Read Method

[image]

Grasshopper SDK
GH_IXmlSupport..::..Read Method
GH_IXmlSupport Interface See Also Send Feedback
Called when an object is required to deserialize itself.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void Read(
    XmlNode node
)
Visual Basic
Sub Read ( _
    node As XmlNode _
)

Parameters

node
Type: System.Xml..::..XmlNode
Node object to be used for deserialization.

See Also

GH_IXmlSupport Interface
GH_IO.Serialization Namespace


Write Method

[image]

Grasshopper SDK
GH_IXmlSupport..::..Write Method
GH_IXmlSupport Interface See Also Send Feedback
Called when an object is required to serialize itself.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
void Write(
    XmlWriter writer
)
Visual Basic
Sub Write ( _
    writer As XmlWriter _
)

Parameters

writer
Type: System.Xml..::..XmlWriter
Writer object to be used for serialization.

See Also

GH_IXmlSupport Interface
GH_IO.Serialization Namespace


GH_LooseChunk Class

[image]

Grasshopper SDK
GH_LooseChunk Class
Members See Also Send Feedback
A utility class for creating partial archives.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public class GH_LooseChunk : GH_Chunk
Visual Basic
Public Class GH_LooseChunk _
    Inherits GH_Chunk

Inheritance Hierarchy

System..::..Object
GH_IO.Serialization..::..GH_Chunk
GH_IO.Serialization..::..GH_LooseChunk

See Also

GH_LooseChunk Members
GH_IO.Serialization Namespace


GH_LooseChunk Members

[image] [image]

Grasshopper SDK
GH_LooseChunk Members
GH_LooseChunk Class Constructors Methods Fields Properties See Also Send Feedback

The GH_LooseChunk type exposes the following members.

Constructors

 | Name | Description
Public method | GH_LooseChunk | Create a new loose chunk. A loose chunk does not have an owner archive and thus cannot store runtime messages.

Methods

 | Name | Description
Public method | AddComment | Adds a text comment to this chunk. Comments are serialized only if the output flavour is a human readable format. Comments are never deserialized, they are purely for the benefit of the humans reading the file data. (Inherited from GH_Chunk.)
Public method | AddMessage | Log a new message with the top-level archive. Messages are collected during read/write operations, and can be displayed to the user upon completion using GH_Archive.ShowMessageLog(). (Inherited from GH_Chunk.)
Public method | ChunkExists(String) | Checks whether a chunk with the specified name exists in the litter. Only chunks without index qualifiers are considered. Name comparisons are not case-sensitive. (Inherited from GH_Chunk.)
Public method | ChunkExists(String, Int32) | Checks whether a chunk with the specified name and index exists in the litter. Only chunks with index qualifiers are considered. Name comparisons are not case-sensitive. (Inherited from GH_Chunk.)
Public method | CreateChunk(String) | Create a new child chunk with the specified name and without an index qualifier. If another chunk already exists with similar properties, an exception will be thrown. (Inherited from GH_Chunk.)
Public method | CreateChunk(String, Int32) | Create a new child chunk with the specified name and index qualifier. If another chunk already exists with similar properties, an exception will be thrown. (Inherited from GH_Chunk.)
Public method | Deserialize_Binary | Deserializes a byte array.
Public method | Deserialize_Xml | Deserializes an Xml string.
Public method | FindChunk(String) | Finds the first chunk in the litter that matches the given name. Only chunks without index qualifiers are considered. (Inherited from GH_Chunk.)
Public method | FindChunk(String, Int32) | Finds the first chunk in the list that matches the given name and index. Only chunks with index qualifiers are considered. (Inherited from GH_Chunk.)
Public method | FindItem(String) | Finds the first item that matches the given name. Only items without index qualifiers are considered. Name comparisons are not case-sensitive. (Inherited from GH_Chunk.)
Public method | FindItem(String, Int32) | Finds the first item that matches the given name and index. Only items with index qualifiers are considered. Name comparisons are not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetBoolean(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetBoolean(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetBoundingBox(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetBoundingBox(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetByte(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetByte(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetByteArray(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetByteArray(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDate(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDate(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDecimal(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDecimal(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDouble(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDouble(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDoubleArray(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDoubleArray(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDrawingBitmap(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDrawingBitmap(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDrawingColor(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDrawingColor(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDrawingPoint(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDrawingPoint(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDrawingPointF(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDrawingPointF(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDrawingRectangle(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDrawingRectangle(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDrawingRectangleF(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDrawingRectangleF(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDrawingSize(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDrawingSize(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDrawingSizeF(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDrawingSizeF(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetGuid(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetGuid(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetInt32(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetInt32(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetInt64(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetInt64(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetInterval1D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetInterval1D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetInterval2D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetInterval2D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetLine(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetLine(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetPath(String, String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetPath(String, Int32, String) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetPlane(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetPlane(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetPoint2D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetPoint2D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetPoint3D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetPoint3D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetPoint4D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetPoint4D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetSingle(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetSingle(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetString(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetString(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetVersion(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetVersion(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | ItemExists(String) | Gets the occupancy for a specific item name. Only items without index qualifiers are considered. (Inherited from GH_Chunk.)
Public method | ItemExists(String, Int32) | Checks whether an item with the specified name and index exists. Only items with index qualifiers are considered. Name comparisons are not case-sensitive. (Inherited from GH_Chunk.)
Public method | Read(BinaryReader) | Read this chunk and all child chunks from a binary stream. (Inherited from GH_Chunk.)
Public method | Read(XmlNode) | Read this chunk and all child chunks from an Xml node. (Inherited from GH_Chunk.)
Public method | RemoveChunk(String) | Remove the first chunk with a matching name. Only chunks without index qualifiers are considered. Name comparisons are not case-sensitive. (Inherited from GH_Chunk.)
Public method | RemoveChunk(GH_IChunk) | Remove the specified chunk from the litter. (Inherited from GH_Chunk.)
Public method | RemoveChunk(String, Int32) | Remove the first chunk with a matching name and index. Only chunks with index qualifiers are considered. Name comparisons are not case-sensitive. (Inherited from GH_Chunk.)
Public method | RemoveItem(String) | Remove an unindexed item from this chunk. (Inherited from GH_Chunk.)
Public method | RemoveItem(String, Int32) | Remove an indexed item from this chunk. (Inherited from GH_Chunk.)
Public method | Serialize_Binary | Serializes the data tree into a byte array.
Public method | Serialize_Xml | Serializes the data tree into an Xml string.
Public method | SetBoolean(String, Boolean) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetBoolean(String, Int32, Boolean) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetBoundingBox(String, GH_BoundingBox) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetBoundingBox(String, Int32, GH_BoundingBox) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetByte(String, Byte) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetByte(String, Int32, Byte) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetByteArray(String, array<Byte>[]()[][]) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetByteArray(String, Int32, array<Byte>[]()[][]) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDate(String, DateTime) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDate(String, Int32, DateTime) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDecimal(String, Decimal) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDecimal(String, Int32, Decimal) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDouble(String, Double) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDouble(String, Int32, Double) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDoubleArray(String, array<Double>[]()[][]) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDoubleArray(String, Int32, array<Double>[]()[][]) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDrawingBitmap(String, Bitmap) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDrawingBitmap(String, Int32, Bitmap) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDrawingColor(String, Color) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDrawingColor(String, Int32, Color) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDrawingPoint(String, Point) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDrawingPoint(String, Int32, Point) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDrawingPointF(String, PointF) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDrawingPointF(String, Int32, PointF) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDrawingRectangle(String, Rectangle) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDrawingRectangle(String, Int32, Rectangle) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDrawingRectangleF(String, RectangleF) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDrawingRectangleF(String, Int32, RectangleF) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDrawingSize(String, Size) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDrawingSize(String, Int32, Size) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDrawingSizeF(String, SizeF) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDrawingSizeF(String, Int32, SizeF) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetGuid(String, Guid) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetGuid(String, Int32, Guid) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetInt32(String, Int32) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetInt32(String, Int32, Int32) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetInt64(String, Int64) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetInt64(String, Int32, Int64) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetInterval1D(String, GH_Interval1D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetInterval1D(String, Int32, GH_Interval1D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetInterval2D(String, GH_Interval2D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetInterval2D(String, Int32, GH_Interval2D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetLine(String, GH_Line) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetLine(String, Int32, GH_Line) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetPath(String, String, String) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetPath(String, Int32, String, String) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetPlane(String, GH_Plane) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetPlane(String, Int32, GH_Plane) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetPoint2D(String, GH_Point2D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetPoint2D(String, Int32, GH_Point2D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetPoint3D(String, GH_Point3D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetPoint3D(String, Int32, GH_Point3D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetPoint4D(String, GH_Point4D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetPoint4D(String, Int32, GH_Point4D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetSingle(String, Single) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetSingle(String, Int32, Single) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetString(String, String) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetString(String, Int32, String) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetVersion(String, GH_Version) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetVersion(String, Int32, GH_Version) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetVersion(String, Int32, Int32, Int32) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetVersion(String, Int32, Int32, Int32, Int32) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | TryGetBoolean(String, Boolean%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetBoolean(String, Int32, Boolean%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetBoundingBox(String, GH_BoundingBox%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetBoundingBox(String, Int32, GH_BoundingBox%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetByte(String, Byte%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetByte(String, Int32, Byte%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDate(String, DateTime%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDate(String, Int32, DateTime%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDecimal(String, Decimal%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDecimal(String, Int32, Decimal%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDouble(String, Double%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDouble(String, Int32, Double%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDrawingColor(String, Color%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDrawingColor(String, Int32, Color%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDrawingPoint(String, Point%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDrawingPoint(String, Int32, Point%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDrawingPointF(String, PointF%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDrawingPointF(String, Int32, PointF%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDrawingRectangle(String, Rectangle%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDrawingRectangle(String, Int32, Rectangle%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDrawingRectangleF(String, RectangleF%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDrawingRectangleF(String, Int32, RectangleF%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDrawingSize(String, Size%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDrawingSize(String, Int32, Size%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDrawingSizeF(String, SizeF%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDrawingSizeF(String, Int32, SizeF%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetGuid(String, Guid%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetGuid(String, Int32, Guid%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetInt32(String, Int32%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetInt32(String, Int32, Int32%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetInt64(String, Int64%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetInt64(String, Int32, Int64%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetInterval1D(String, GH_Interval1D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetInterval1D(String, Int32, GH_Interval1D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetInterval2D(String, GH_Interval2D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetInterval2D(String, Int32, GH_Interval2D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetLine(String, GH_Line%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetLine(String, Int32, GH_Line%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetPlane(String, GH_Plane%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetPlane(String, Int32, GH_Plane%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetPoint2D(String, GH_Point2D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetPoint2D(String, Int32, GH_Point2D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetPoint3D(String, GH_Point3D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetPoint3D(String, Int32, GH_Point3D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetPoint4D(String, GH_Point4D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetPoint4D(String, Int32, GH_Point4D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetSingle(String, Single%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetSingle(String, Int32, Single%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetString(String, String%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetString(String, Int32, String%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetVersion(String, GH_Version%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetVersion(String, Int32, GH_Version%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | Write(BinaryWriter) | Write this chunk and all child chunks to a binary stream. (Inherited from GH_Chunk.)
Public method | Write(XmlWriter) | Serialize this chunk into an Xml stream. (Inherited from GH_Chunk.)

Fields

 | Name | Description
Protected field | m_archive | Pointer to the archive that owns the Root of the tree this chunk belongs to. (Inherited from GH_Chunk.)
Protected field | m_chunks | List of sub-chunks contained within this chunk. (Inherited from GH_Chunk.)
Protected field | m_comments | List of text comments. This list is automatically instantiated once the first comment is added. (Inherited from GH_Chunk.)
Protected field | m_index | Index of this chunk. This field is set only once, during construction. A negative index indicates no index qualifier has been set. (Inherited from GH_Chunk.)
Protected field | m_items | The list of nodes contained within this chunk. (Inherited from GH_Chunk.)
Protected field | m_name | Name of this chunk. This field is set only once, during construction. (Inherited from GH_Chunk.)

Properties

 | Name | Description
Public property | Archive | Gets a pointer to the archive that owns the Root of the tree this chunk belongs to. (Inherited from GH_Chunk.)
Public property | ArchiveLocation | Gets a string representing the URI with which the archive is associated. The location may be a null string. (Inherited from GH_Chunk.)
Public property | ChunkCount | Gets the number of child chunks contained in this chunk. The set of all child chunks is referred to as a 'litter'. (Inherited from GH_Chunk.)
Public property | Chunks | Gets a pointer to the internal list of child chunks. Do not access this list unless you know what you are doing. (Inherited from GH_Chunk.)
Public property | HasComments | Gets a value that indicates whether or not comments have been stored in this chunk. (Inherited from GH_Chunk.)
Public property | HasIndex | Gets the index existence implication. The item is considered to have an index qualifier if the index value is larger than or equal to zero. (Inherited from GH_Chunk.)
Public property | HasName | Gets the name validity of this item. The item is considered to have an invalid name if string.IsNullOrEmpty(name) (Inherited from GH_Chunk.)
Public property | Index | Gets the index of this chunk. The index is set by the owner of this chunk. Indices smaller than zero imply no index has been set. The combination of name+index is always unique among a set of chunks in the same litter. (Inherited from GH_Chunk.)
Public property | ItemCount | Gets the number of items contained in this chunk. (Inherited from GH_Chunk.)
Public property | Items | Gets a pointer to the internal list of items. Do not access this list unless you know what you are doing. (Inherited from GH_Chunk.)
Public property | Name | Gets the name of this chunk. The name is set by the owner of this chunk. Names must be at least 1 character long. The combination of name+index is always unique among a set of chunks in a single litter. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_IO.Serialization Namespace


GH_LooseChunk Constructor

[image]

Grasshopper SDK
GH_LooseChunk Constructor
GH_LooseChunk Class See Also Send Feedback
Create a new loose chunk. A loose chunk does not have an owner archive and thus cannot store runtime messages.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_LooseChunk(
    string chunk_name
)
Visual Basic
Public Sub New ( _
    chunk_name As String _
)

Parameters

chunk_name
Type: System..::..String
Name of this chunk.

See Also

GH_LooseChunk Class
GH_IO.Serialization Namespace


GH_LooseChunk Fields

[image] [image]

Grasshopper SDK
GH_LooseChunk Fields
GH_LooseChunk Class See Also Send Feedback

The GH_LooseChunk type exposes the following members.

Fields

 | Name | Description
Protected field | m_archive | Pointer to the archive that owns the Root of the tree this chunk belongs to. (Inherited from GH_Chunk.)
Protected field | m_chunks | List of sub-chunks contained within this chunk. (Inherited from GH_Chunk.)
Protected field | m_comments | List of text comments. This list is automatically instantiated once the first comment is added. (Inherited from GH_Chunk.)
Protected field | m_index | Index of this chunk. This field is set only once, during construction. A negative index indicates no index qualifier has been set. (Inherited from GH_Chunk.)
Protected field | m_items | The list of nodes contained within this chunk. (Inherited from GH_Chunk.)
Protected field | m_name | Name of this chunk. This field is set only once, during construction. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_IO.Serialization Namespace


GH_LooseChunk Methods

[image] [image]

Grasshopper SDK
GH_LooseChunk Methods
GH_LooseChunk Class See Also Send Feedback

The GH_LooseChunk type exposes the following members.

Methods

 | Name | Description
Public method | AddComment | Adds a text comment to this chunk. Comments are serialized only if the output flavour is a human readable format. Comments are never deserialized, they are purely for the benefit of the humans reading the file data. (Inherited from GH_Chunk.)
Public method | AddMessage | Log a new message with the top-level archive. Messages are collected during read/write operations, and can be displayed to the user upon completion using GH_Archive.ShowMessageLog(). (Inherited from GH_Chunk.)
Public method | ChunkExists(String) | Checks whether a chunk with the specified name exists in the litter. Only chunks without index qualifiers are considered. Name comparisons are not case-sensitive. (Inherited from GH_Chunk.)
Public method | ChunkExists(String, Int32) | Checks whether a chunk with the specified name and index exists in the litter. Only chunks with index qualifiers are considered. Name comparisons are not case-sensitive. (Inherited from GH_Chunk.)
Public method | CreateChunk(String) | Create a new child chunk with the specified name and without an index qualifier. If another chunk already exists with similar properties, an exception will be thrown. (Inherited from GH_Chunk.)
Public method | CreateChunk(String, Int32) | Create a new child chunk with the specified name and index qualifier. If another chunk already exists with similar properties, an exception will be thrown. (Inherited from GH_Chunk.)
Public method | Deserialize_Binary | Deserializes a byte array.
Public method | Deserialize_Xml | Deserializes an Xml string.
Public method | FindChunk(String) | Finds the first chunk in the litter that matches the given name. Only chunks without index qualifiers are considered. (Inherited from GH_Chunk.)
Public method | FindChunk(String, Int32) | Finds the first chunk in the list that matches the given name and index. Only chunks with index qualifiers are considered. (Inherited from GH_Chunk.)
Public method | FindItem(String) | Finds the first item that matches the given name. Only items without index qualifiers are considered. Name comparisons are not case-sensitive. (Inherited from GH_Chunk.)
Public method | FindItem(String, Int32) | Finds the first item that matches the given name and index. Only items with index qualifiers are considered. Name comparisons are not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetBoolean(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetBoolean(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetBoundingBox(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetBoundingBox(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetByte(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetByte(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetByteArray(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetByteArray(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDate(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDate(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDecimal(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDecimal(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDouble(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDouble(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDoubleArray(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDoubleArray(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDrawingBitmap(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDrawingBitmap(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDrawingColor(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDrawingColor(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDrawingPoint(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDrawingPoint(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDrawingPointF(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDrawingPointF(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDrawingRectangle(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDrawingRectangle(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDrawingRectangleF(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDrawingRectangleF(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDrawingSize(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDrawingSize(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDrawingSizeF(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDrawingSizeF(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetGuid(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetGuid(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetInt32(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetInt32(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetInt64(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetInt64(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetInterval1D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetInterval1D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetInterval2D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetInterval2D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetLine(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetLine(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetPath(String, String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetPath(String, Int32, String) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetPlane(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetPlane(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetPoint2D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetPoint2D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetPoint3D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetPoint3D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetPoint4D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetPoint4D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetSingle(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetSingle(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetString(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetString(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetVersion(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetVersion(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | ItemExists(String) | Gets the occupancy for a specific item name. Only items without index qualifiers are considered. (Inherited from GH_Chunk.)
Public method | ItemExists(String, Int32) | Checks whether an item with the specified name and index exists. Only items with index qualifiers are considered. Name comparisons are not case-sensitive. (Inherited from GH_Chunk.)
Public method | Read(BinaryReader) | Read this chunk and all child chunks from a binary stream. (Inherited from GH_Chunk.)
Public method | Read(XmlNode) | Read this chunk and all child chunks from an Xml node. (Inherited from GH_Chunk.)
Public method | RemoveChunk(String) | Remove the first chunk with a matching name. Only chunks without index qualifiers are considered. Name comparisons are not case-sensitive. (Inherited from GH_Chunk.)
Public method | RemoveChunk(GH_IChunk) | Remove the specified chunk from the litter. (Inherited from GH_Chunk.)
Public method | RemoveChunk(String, Int32) | Remove the first chunk with a matching name and index. Only chunks with index qualifiers are considered. Name comparisons are not case-sensitive. (Inherited from GH_Chunk.)
Public method | RemoveItem(String) | Remove an unindexed item from this chunk. (Inherited from GH_Chunk.)
Public method | RemoveItem(String, Int32) | Remove an indexed item from this chunk. (Inherited from GH_Chunk.)
Public method | Serialize_Binary | Serializes the data tree into a byte array.
Public method | Serialize_Xml | Serializes the data tree into an Xml string.
Public method | SetBoolean(String, Boolean) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetBoolean(String, Int32, Boolean) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetBoundingBox(String, GH_BoundingBox) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetBoundingBox(String, Int32, GH_BoundingBox) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetByte(String, Byte) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetByte(String, Int32, Byte) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetByteArray(String, array<Byte>[]()[][]) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetByteArray(String, Int32, array<Byte>[]()[][]) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDate(String, DateTime) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDate(String, Int32, DateTime) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDecimal(String, Decimal) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDecimal(String, Int32, Decimal) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDouble(String, Double) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDouble(String, Int32, Double) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDoubleArray(String, array<Double>[]()[][]) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDoubleArray(String, Int32, array<Double>[]()[][]) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDrawingBitmap(String, Bitmap) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDrawingBitmap(String, Int32, Bitmap) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDrawingColor(String, Color) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDrawingColor(String, Int32, Color) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDrawingPoint(String, Point) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDrawingPoint(String, Int32, Point) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDrawingPointF(String, PointF) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDrawingPointF(String, Int32, PointF) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDrawingRectangle(String, Rectangle) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDrawingRectangle(String, Int32, Rectangle) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDrawingRectangleF(String, RectangleF) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDrawingRectangleF(String, Int32, RectangleF) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDrawingSize(String, Size) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDrawingSize(String, Int32, Size) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDrawingSizeF(String, SizeF) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDrawingSizeF(String, Int32, SizeF) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetGuid(String, Guid) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetGuid(String, Int32, Guid) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetInt32(String, Int32) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetInt32(String, Int32, Int32) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetInt64(String, Int64) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetInt64(String, Int32, Int64) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetInterval1D(String, GH_Interval1D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetInterval1D(String, Int32, GH_Interval1D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetInterval2D(String, GH_Interval2D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetInterval2D(String, Int32, GH_Interval2D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetLine(String, GH_Line) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetLine(String, Int32, GH_Line) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetPath(String, String, String) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetPath(String, Int32, String, String) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetPlane(String, GH_Plane) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetPlane(String, Int32, GH_Plane) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetPoint2D(String, GH_Point2D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetPoint2D(String, Int32, GH_Point2D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetPoint3D(String, GH_Point3D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetPoint3D(String, Int32, GH_Point3D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetPoint4D(String, GH_Point4D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetPoint4D(String, Int32, GH_Point4D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetSingle(String, Single) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetSingle(String, Int32, Single) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetString(String, String) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetString(String, Int32, String) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetVersion(String, GH_Version) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetVersion(String, Int32, GH_Version) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetVersion(String, Int32, Int32, Int32) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetVersion(String, Int32, Int32, Int32, Int32) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | TryGetBoolean(String, Boolean%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetBoolean(String, Int32, Boolean%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetBoundingBox(String, GH_BoundingBox%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetBoundingBox(String, Int32, GH_BoundingBox%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetByte(String, Byte%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetByte(String, Int32, Byte%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDate(String, DateTime%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDate(String, Int32, DateTime%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDecimal(String, Decimal%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDecimal(String, Int32, Decimal%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDouble(String, Double%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDouble(String, Int32, Double%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDrawingColor(String, Color%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDrawingColor(String, Int32, Color%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDrawingPoint(String, Point%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDrawingPoint(String, Int32, Point%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDrawingPointF(String, PointF%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDrawingPointF(String, Int32, PointF%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDrawingRectangle(String, Rectangle%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDrawingRectangle(String, Int32, Rectangle%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDrawingRectangleF(String, RectangleF%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDrawingRectangleF(String, Int32, RectangleF%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDrawingSize(String, Size%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDrawingSize(String, Int32, Size%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDrawingSizeF(String, SizeF%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDrawingSizeF(String, Int32, SizeF%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetGuid(String, Guid%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetGuid(String, Int32, Guid%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetInt32(String, Int32%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetInt32(String, Int32, Int32%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetInt64(String, Int64%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetInt64(String, Int32, Int64%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetInterval1D(String, GH_Interval1D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetInterval1D(String, Int32, GH_Interval1D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetInterval2D(String, GH_Interval2D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetInterval2D(String, Int32, GH_Interval2D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetLine(String, GH_Line%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetLine(String, Int32, GH_Line%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetPlane(String, GH_Plane%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetPlane(String, Int32, GH_Plane%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetPoint2D(String, GH_Point2D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetPoint2D(String, Int32, GH_Point2D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetPoint3D(String, GH_Point3D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetPoint3D(String, Int32, GH_Point3D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetPoint4D(String, GH_Point4D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetPoint4D(String, Int32, GH_Point4D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetSingle(String, Single%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetSingle(String, Int32, Single%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetString(String, String%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetString(String, Int32, String%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetVersion(String, GH_Version%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetVersion(String, Int32, GH_Version%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | Write(BinaryWriter) | Write this chunk and all child chunks to a binary stream. (Inherited from GH_Chunk.)
Public method | Write(XmlWriter) | Serialize this chunk into an Xml stream. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_IO.Serialization Namespace


ChunkExists Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..ChunkExists Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ChunkExists(String) | Checks whether a chunk with the specified name exists in the litter. Only chunks without index qualifiers are considered. Name comparisons are not case-sensitive. (Inherited from GH_Chunk.)
Public method | ChunkExists(String, Int32) | Checks whether a chunk with the specified name and index exists in the litter. Only chunks with index qualifiers are considered. Name comparisons are not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


CreateChunk Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..CreateChunk Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateChunk(String) | Create a new child chunk with the specified name and without an index qualifier. If another chunk already exists with similar properties, an exception will be thrown. (Inherited from GH_Chunk.)
Public method | CreateChunk(String, Int32) | Create a new child chunk with the specified name and index qualifier. If another chunk already exists with similar properties, an exception will be thrown. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


Deserialize_Binary Method

[image]

Grasshopper SDK
GH_LooseChunk..::..Deserialize_Binary Method
GH_LooseChunk Class See Also Send Feedback
Deserializes a byte array.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void Deserialize_Binary(
    byte[] content
)
Visual Basic
Public Sub Deserialize_Binary ( _
    content As Byte() _
)

Parameters

content
Type: array< System..::..Byte >[]()[][]
Byte array to deserialize.

Return Value

True on success, false on failure.

See Also

GH_LooseChunk Class
GH_IO.Serialization Namespace


Deserialize_Xml Method

[image]

Grasshopper SDK
GH_LooseChunk..::..Deserialize_Xml Method
GH_LooseChunk Class See Also Send Feedback
Deserializes an Xml string.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void Deserialize_Xml(
    string xml_content
)
Visual Basic
Public Sub Deserialize_Xml ( _
    xml_content As String _
)

Parameters

xml_content
Type: System..::..String
Xml to deserialize.

Return Value

True on success, false on failure.

See Also

GH_LooseChunk Class
GH_IO.Serialization Namespace


FindChunk Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..FindChunk Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindChunk(String) | Finds the first chunk in the litter that matches the given name. Only chunks without index qualifiers are considered. (Inherited from GH_Chunk.)
Public method | FindChunk(String, Int32) | Finds the first chunk in the list that matches the given name and index. Only chunks with index qualifiers are considered. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


FindItem Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..FindItem Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindItem(String) | Finds the first item that matches the given name. Only items without index qualifiers are considered. Name comparisons are not case-sensitive. (Inherited from GH_Chunk.)
Public method | FindItem(String, Int32) | Finds the first item that matches the given name and index. Only items with index qualifiers are considered. Name comparisons are not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


GetBoolean Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..GetBoolean Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetBoolean(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetBoolean(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


GetBoundingBox Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..GetBoundingBox Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetBoundingBox(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetBoundingBox(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


GetByte Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..GetByte Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetByte(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetByte(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


GetByteArray Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..GetByteArray Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetByteArray(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetByteArray(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


GetDate Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..GetDate Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDate(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDate(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


GetDecimal Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..GetDecimal Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDecimal(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDecimal(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


GetDouble Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..GetDouble Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDouble(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDouble(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


GetDoubleArray Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..GetDoubleArray Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDoubleArray(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDoubleArray(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


GetDrawingBitmap Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..GetDrawingBitmap Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDrawingBitmap(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDrawingBitmap(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


GetDrawingColor Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..GetDrawingColor Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDrawingColor(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDrawingColor(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


GetDrawingPoint Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..GetDrawingPoint Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDrawingPoint(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDrawingPoint(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


GetDrawingPointF Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..GetDrawingPointF Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDrawingPointF(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDrawingPointF(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


GetDrawingRectangle Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..GetDrawingRectangle Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDrawingRectangle(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDrawingRectangle(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


GetDrawingRectangleF Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..GetDrawingRectangleF Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDrawingRectangleF(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDrawingRectangleF(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


GetDrawingSize Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..GetDrawingSize Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDrawingSize(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDrawingSize(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


GetDrawingSizeF Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..GetDrawingSizeF Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDrawingSizeF(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetDrawingSizeF(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


GetGuid Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..GetGuid Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetGuid(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetGuid(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


GetInt32 Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..GetInt32 Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetInt32(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetInt32(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


GetInt64 Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..GetInt64 Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetInt64(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetInt64(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


GetInterval1D Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..GetInterval1D Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetInterval1D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetInterval1D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


GetInterval2D Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..GetInterval2D Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetInterval2D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetInterval2D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


GetLine Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..GetLine Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetLine(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetLine(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


GetPath Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..GetPath Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPath(String, String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetPath(String, Int32, String) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


GetPlane Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..GetPlane Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPlane(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetPlane(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


GetPoint2D Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..GetPoint2D Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPoint2D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetPoint2D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


GetPoint3D Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..GetPoint3D Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPoint3D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetPoint3D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


GetPoint4D Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..GetPoint4D Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPoint4D(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetPoint4D(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


GetSingle Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..GetSingle Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetSingle(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetSingle(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


GetString Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..GetString Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetString(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetString(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


GetVersion Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..GetVersion Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetVersion(String) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | GetVersion(String, Int32) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


ItemExists Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..ItemExists Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ItemExists(String) | Gets the occupancy for a specific item name. Only items without index qualifiers are considered. (Inherited from GH_Chunk.)
Public method | ItemExists(String, Int32) | Checks whether an item with the specified name and index exists. Only items with index qualifiers are considered. Name comparisons are not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


Read Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..Read Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Read(BinaryReader) | Read this chunk and all child chunks from a binary stream. (Inherited from GH_Chunk.)
Public method | Read(XmlNode) | Read this chunk and all child chunks from an Xml node. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


RemoveChunk Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..RemoveChunk Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveChunk(String) | Remove the first chunk with a matching name. Only chunks without index qualifiers are considered. Name comparisons are not case-sensitive. (Inherited from GH_Chunk.)
Public method | RemoveChunk(GH_IChunk) | Remove the specified chunk from the litter. (Inherited from GH_Chunk.)
Public method | RemoveChunk(String, Int32) | Remove the first chunk with a matching name and index. Only chunks with index qualifiers are considered. Name comparisons are not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


RemoveItem Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..RemoveItem Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveItem(String) | Remove an unindexed item from this chunk. (Inherited from GH_Chunk.)
Public method | RemoveItem(String, Int32) | Remove an indexed item from this chunk. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


Serialize_Binary Method

[image]

Grasshopper SDK
GH_LooseChunk..::..Serialize_Binary Method
GH_LooseChunk Class Example See Also Send Feedback
Serializes the data tree into a byte array.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public byte[] Serialize_Binary()
Visual Basic
Public Function Serialize_Binary As Byte()

Return Value

An array of bytes representing the Loose chunk.

Examples

This sample shows how to create a new loose chunk and serialize some values.
CopyC#
public byte[] CreateBinary(string archive_name, string[] item_names, int[] item_values)
{
  GH_LooseChunk chunk = new GH_LooseChunk(archive_name);

  for (int i = 0; i < item_names.Length; i++)
  {
    chunk.SetInt32(item_names[i], i, item_values[i]);
  }

  return chunk.Serialize_Binary();
}

See Also

GH_LooseChunk Class
GH_IO.Serialization Namespace


Serialize_Xml Method

[image]

Grasshopper SDK
GH_LooseChunk..::..Serialize_Xml Method
GH_LooseChunk Class Example See Also Send Feedback
Serializes the data tree into an Xml string.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public string Serialize_Xml()
Visual Basic
Public Function Serialize_Xml As String

Return Value

A string containing the Xml content.

Examples

This sample shows how to create a new loose chunk and serialize some values.
CopyC#
public string CreateXML(string archive_name, string[] item_names, int[] item_values)
{
  GH_LooseChunk chunk = new GH_LooseChunk(archive_name);

  for (int i = 0; i < item_names.Length; i++)
  {
    chunk.SetInt32(item_names[i], i, item_values[i]);
  }

  return chunk.Serialize_Xml();
}

See Also

GH_LooseChunk Class
GH_IO.Serialization Namespace


SetBoolean Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..SetBoolean Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBoolean(String, Boolean) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetBoolean(String, Int32, Boolean) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


SetBoundingBox Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..SetBoundingBox Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBoundingBox(String, GH_BoundingBox) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetBoundingBox(String, Int32, GH_BoundingBox) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


SetByte Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..SetByte Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetByte(String, Byte) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetByte(String, Int32, Byte) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


SetByteArray Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..SetByteArray Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetByteArray(String, array<Byte>[]()[][]) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetByteArray(String, Int32, array<Byte>[]()[][]) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


SetDate Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..SetDate Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDate(String, DateTime) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDate(String, Int32, DateTime) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


SetDecimal Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..SetDecimal Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDecimal(String, Decimal) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDecimal(String, Int32, Decimal) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


SetDouble Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..SetDouble Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDouble(String, Double) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDouble(String, Int32, Double) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


SetDoubleArray Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..SetDoubleArray Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDoubleArray(String, array<Double>[]()[][]) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDoubleArray(String, Int32, array<Double>[]()[][]) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


SetDrawingBitmap Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..SetDrawingBitmap Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDrawingBitmap(String, Bitmap) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDrawingBitmap(String, Int32, Bitmap) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


SetDrawingColor Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..SetDrawingColor Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDrawingColor(String, Color) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDrawingColor(String, Int32, Color) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


SetDrawingPoint Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..SetDrawingPoint Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDrawingPoint(String, Point) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDrawingPoint(String, Int32, Point) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


SetDrawingPointF Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..SetDrawingPointF Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDrawingPointF(String, PointF) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDrawingPointF(String, Int32, PointF) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


SetDrawingRectangle Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..SetDrawingRectangle Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDrawingRectangle(String, Rectangle) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDrawingRectangle(String, Int32, Rectangle) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


SetDrawingRectangleF Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..SetDrawingRectangleF Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDrawingRectangleF(String, RectangleF) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDrawingRectangleF(String, Int32, RectangleF) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


SetDrawingSize Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..SetDrawingSize Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDrawingSize(String, Size) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDrawingSize(String, Int32, Size) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


SetDrawingSizeF Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..SetDrawingSizeF Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDrawingSizeF(String, SizeF) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetDrawingSizeF(String, Int32, SizeF) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


SetGuid Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..SetGuid Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetGuid(String, Guid) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetGuid(String, Int32, Guid) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


SetInt32 Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..SetInt32 Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetInt32(String, Int32) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetInt32(String, Int32, Int32) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


SetInt64 Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..SetInt64 Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetInt64(String, Int64) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetInt64(String, Int32, Int64) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


SetInterval1D Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..SetInterval1D Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetInterval1D(String, GH_Interval1D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetInterval1D(String, Int32, GH_Interval1D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


SetInterval2D Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..SetInterval2D Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetInterval2D(String, GH_Interval2D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetInterval2D(String, Int32, GH_Interval2D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


SetLine Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..SetLine Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetLine(String, GH_Line) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetLine(String, Int32, GH_Line) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


SetPath Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..SetPath Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetPath(String, String, String) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetPath(String, Int32, String, String) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


SetPlane Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..SetPlane Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetPlane(String, GH_Plane) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetPlane(String, Int32, GH_Plane) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


SetPoint2D Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..SetPoint2D Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetPoint2D(String, GH_Point2D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetPoint2D(String, Int32, GH_Point2D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


SetPoint3D Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..SetPoint3D Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetPoint3D(String, GH_Point3D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetPoint3D(String, Int32, GH_Point3D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


SetPoint4D Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..SetPoint4D Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetPoint4D(String, GH_Point4D) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetPoint4D(String, Int32, GH_Point4D) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


SetSingle Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..SetSingle Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetSingle(String, Single) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetSingle(String, Int32, Single) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


SetString Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..SetString Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetString(String, String) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetString(String, Int32, String) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


SetVersion Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..SetVersion Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetVersion(String, GH_Version) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetVersion(String, Int32, GH_Version) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetVersion(String, Int32, Int32, Int32) | Add a new data item to this chunk. The name must be unique or an exception will be thrown. (Inherited from GH_Chunk.)
Public method | SetVersion(String, Int32, Int32, Int32, Int32) | Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


TryGetBoolean Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..TryGetBoolean Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetBoolean(String, Boolean%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetBoolean(String, Int32, Boolean%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


TryGetBoundingBox Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..TryGetBoundingBox Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetBoundingBox(String, GH_BoundingBox%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetBoundingBox(String, Int32, GH_BoundingBox%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


TryGetByte Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..TryGetByte Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetByte(String, Byte%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetByte(String, Int32, Byte%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


TryGetDate Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..TryGetDate Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetDate(String, DateTime%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDate(String, Int32, DateTime%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


TryGetDecimal Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..TryGetDecimal Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetDecimal(String, Decimal%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDecimal(String, Int32, Decimal%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


TryGetDouble Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..TryGetDouble Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetDouble(String, Double%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDouble(String, Int32, Double%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


TryGetDrawingColor Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..TryGetDrawingColor Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetDrawingColor(String, Color%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDrawingColor(String, Int32, Color%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


TryGetDrawingPoint Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..TryGetDrawingPoint Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetDrawingPoint(String, Point%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDrawingPoint(String, Int32, Point%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


TryGetDrawingPointF Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..TryGetDrawingPointF Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetDrawingPointF(String, PointF%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDrawingPointF(String, Int32, PointF%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


TryGetDrawingRectangle Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..TryGetDrawingRectangle Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetDrawingRectangle(String, Rectangle%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDrawingRectangle(String, Int32, Rectangle%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


TryGetDrawingRectangleF Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..TryGetDrawingRectangleF Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetDrawingRectangleF(String, RectangleF%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDrawingRectangleF(String, Int32, RectangleF%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


TryGetDrawingSize Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..TryGetDrawingSize Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetDrawingSize(String, Size%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDrawingSize(String, Int32, Size%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


TryGetDrawingSizeF Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..TryGetDrawingSizeF Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetDrawingSizeF(String, SizeF%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetDrawingSizeF(String, Int32, SizeF%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


TryGetGuid Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..TryGetGuid Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetGuid(String, Guid%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetGuid(String, Int32, Guid%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


TryGetInt32 Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..TryGetInt32 Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetInt32(String, Int32%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetInt32(String, Int32, Int32%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


TryGetInt64 Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..TryGetInt64 Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetInt64(String, Int64%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetInt64(String, Int32, Int64%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


TryGetInterval1D Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..TryGetInterval1D Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetInterval1D(String, GH_Interval1D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetInterval1D(String, Int32, GH_Interval1D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


TryGetInterval2D Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..TryGetInterval2D Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetInterval2D(String, GH_Interval2D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetInterval2D(String, Int32, GH_Interval2D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


TryGetLine Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..TryGetLine Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetLine(String, GH_Line%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetLine(String, Int32, GH_Line%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


TryGetPlane Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..TryGetPlane Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetPlane(String, GH_Plane%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetPlane(String, Int32, GH_Plane%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


TryGetPoint2D Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..TryGetPoint2D Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetPoint2D(String, GH_Point2D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetPoint2D(String, Int32, GH_Point2D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


TryGetPoint3D Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..TryGetPoint3D Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetPoint3D(String, GH_Point3D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetPoint3D(String, Int32, GH_Point3D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


TryGetPoint4D Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..TryGetPoint4D Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetPoint4D(String, GH_Point4D%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetPoint4D(String, Int32, GH_Point4D%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


TryGetSingle Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..TryGetSingle Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetSingle(String, Single%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetSingle(String, Int32, Single%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


TryGetString Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..TryGetString Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetString(String, String%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetString(String, Int32, String%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


TryGetVersion Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..TryGetVersion Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TryGetVersion(String, GH_Version%) | Gets the value of the item with the specified name. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)
Public method | TryGetVersion(String, Int32, GH_Version%) | Gets the value of the item with the specified name and index. Name comparison is not case-sensitive. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


Write Method

[image] [image]

Grasshopper SDK
GH_LooseChunk..::..Write Method
GH_LooseChunk Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Write(BinaryWriter) | Write this chunk and all child chunks to a binary stream. (Inherited from GH_Chunk.)
Public method | Write(XmlWriter) | Serialize this chunk into an Xml stream. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_LooseChunk Members
GH_IO.Serialization Namespace


GH_LooseChunk Properties

[image] [image]

Grasshopper SDK
GH_LooseChunk Properties
GH_LooseChunk Class See Also Send Feedback

The GH_LooseChunk type exposes the following members.

Properties

 | Name | Description
Public property | Archive | Gets a pointer to the archive that owns the Root of the tree this chunk belongs to. (Inherited from GH_Chunk.)
Public property | ArchiveLocation | Gets a string representing the URI with which the archive is associated. The location may be a null string. (Inherited from GH_Chunk.)
Public property | ChunkCount | Gets the number of child chunks contained in this chunk. The set of all child chunks is referred to as a 'litter'. (Inherited from GH_Chunk.)
Public property | Chunks | Gets a pointer to the internal list of child chunks. Do not access this list unless you know what you are doing. (Inherited from GH_Chunk.)
Public property | HasComments | Gets a value that indicates whether or not comments have been stored in this chunk. (Inherited from GH_Chunk.)
Public property | HasIndex | Gets the index existence implication. The item is considered to have an index qualifier if the index value is larger than or equal to zero. (Inherited from GH_Chunk.)
Public property | HasName | Gets the name validity of this item. The item is considered to have an invalid name if string.IsNullOrEmpty(name) (Inherited from GH_Chunk.)
Public property | Index | Gets the index of this chunk. The index is set by the owner of this chunk. Indices smaller than zero imply no index has been set. The combination of name+index is always unique among a set of chunks in the same litter. (Inherited from GH_Chunk.)
Public property | ItemCount | Gets the number of items contained in this chunk. (Inherited from GH_Chunk.)
Public property | Items | Gets a pointer to the internal list of items. Do not access this list unless you know what you are doing. (Inherited from GH_Chunk.)
Public property | Name | Gets the name of this chunk. The name is set by the owner of this chunk. Names must be at least 1 character long. The combination of name+index is always unique among a set of chunks in a single litter. (Inherited from GH_Chunk.)

See Also

GH_LooseChunk Class
GH_IO.Serialization Namespace


GH_Message Class

[image]

Grasshopper SDK
GH_Message Class
Members See Also Send Feedback
Represents an archive log message. Messages are collected during read/write operations.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public class GH_Message
Visual Basic
Public Class GH_Message

Inheritance Hierarchy

System..::..Object
GH_IO.Serialization..::..GH_Message

See Also

GH_Message Members
GH_IO.Serialization Namespace


GH_Message Members

[image] [image]

Grasshopper SDK
GH_Message Members
GH_Message Class Constructors Properties See Also Send Feedback

The GH_Message type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Message()()()() | Fake constructor to avoid new instances being created by a PropertyGrid.
Public method | GH_Message(String) | Create a new message of type GH_Message_Type.info
Public method | GH_Message(String, GH_Message_Type) | Create a new message.

Properties

 | Name | Description
Public property | Message | Gets the text content of this message.
Public property | Type | Gets the type of this message.

See Also

GH_Message Class
GH_IO.Serialization Namespace


GH_Message Constructor

[image] [image]

Grasshopper SDK
GH_Message Constructor
GH_Message Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Message()()()() | Fake constructor to avoid new instances being created by a PropertyGrid.
Public method | GH_Message(String) | Create a new message of type GH_Message_Type.info
Public method | GH_Message(String, GH_Message_Type) | Create a new message.

See Also

GH_Message Class
GH_Message Members
GH_IO.Serialization Namespace


GH_Message Constructor

[image]

Grasshopper SDK
GH_Message Constructor
GH_Message Class See Also Send Feedback
Fake constructor to avoid new instances being created by a PropertyGrid.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Message()
Visual Basic
Public Sub New

See Also

GH_Message Class
GH_Message Overload
GH_IO.Serialization Namespace


GH_Message Constructor (String)

[image]

Grasshopper SDK
GH_Message Constructor (String)
GH_Message Class See Also Send Feedback
Create a new message of type GH_Message_Type.info

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Message(
    string message_content
)
Visual Basic
Public Sub New ( _
    message_content As String _
)

Parameters

message_content
Type: System..::..String
Text content of message.

See Also

GH_Message Class
GH_Message Overload
GH_IO.Serialization Namespace


GH_Message Constructor (String, GH_Message_Type)

[image]

Grasshopper SDK
GH_Message Constructor (String, GH_Message_Type)
GH_Message Class See Also Send Feedback
Create a new message.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Message(
    string message_content,
    GH_Message_Type message_type
)
Visual Basic
Public Sub New ( _
    message_content As String, _
    message_type As GH_Message_Type _
)

Parameters

message_content
Type: System..::..String
Text content of message.
message_type
Type: GH_IO.Serialization..::..GH_Message_Type
Type of message, GH_Message_Type.unset is not a valid type.

See Also

GH_Message Class
GH_Message Overload
GH_IO.Serialization Namespace


GH_Message Properties

[image] [image]

Grasshopper SDK
GH_Message Properties
GH_Message Class See Also Send Feedback

The GH_Message type exposes the following members.

Properties

 | Name | Description
Public property | Message | Gets the text content of this message.
Public property | Type | Gets the type of this message.

See Also

GH_Message Class
GH_IO.Serialization Namespace


Message Property

[image]

Grasshopper SDK
GH_Message..::..Message Property
GH_Message Class See Also Send Feedback
Gets the text content of this message.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public string Message { get; }
Visual Basic
Public ReadOnly Property Message As String
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Serialization.GH_Message.Message"]

See Also

GH_Message Class
GH_IO.Serialization Namespace


Type Property

[image]

Grasshopper SDK
GH_Message..::..Type Property
GH_Message Class See Also Send Feedback
Gets the type of this message.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Message_Type Type { get; }
Visual Basic
Public ReadOnly Property Type As GH_Message_Type
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Serialization.GH_Message.Type"]

See Also

GH_Message Class
GH_IO.Serialization Namespace


GH_Message_Type Enumeration

[image]

Grasshopper SDK
GH_Message_Type Enumeration
See Also Send Feedback
Message type flag.

Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public enum GH_Message_Type
Visual Basic
Public Enumeration GH_Message_Type

Members

Member name | Value | Description
info | 0 | Indicates a message represents information.
warning | 1 | Indicates the message represents a warning. Warnings are not severe enough to be regarded as IO errors.
error | 2 | Indicates the message represents an error. Errors mean (de)serialization failed (partially).

See Also

GH_IO.Serialization Namespace


GH_IO.Types Namespace

[image]

Grasshopper SDK
GH_IO.Types Namespace
Send Feedback
This namespace contains all the special data types that can occur in a Grasshopper document.

Classes

 | Class | Description
Public class | GH_Item | Represents a single data item in a chunk.

Structures

 | Structure | Description
Public structure | GH_BoundingBox | Represents a 3D bounding box, denoted by two points.
Public structure | GH_Interval1D | Represents two double precision floating point values.
Public structure | GH_Interval2D | Represents two double precision domains.
Public structure | GH_Line | Represents a 3D line segment, denoted by start and endpoints.
Public structure | GH_Plane | Represents a 3D plane system, defined by origin point and {X,Y} axis directions.
Public structure | GH_Point2D | Represents a 2D point coordinate with double precision floating point components.
Public structure | GH_Point3D | Represents a 3D point coordinate with double precision floating point components.
Public structure | GH_Point4D | Represents a 4D point coordinate with double precision floating point components.
Public structure | GH_Version | Basic version type. Contains Major, Minor and Revision fields.

Enumerations

 | Enumeration | Description
Public enumeration | GH_Types | Contains flags for all data types currently supported by GH_IO.dll


GH_BoundingBox Structure

[image]

Grasshopper SDK
GH_BoundingBox Structure
Members See Also Send Feedback
Represents a 3D bounding box, denoted by two points.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public struct GH_BoundingBox
Visual Basic
Public Structure GH_BoundingBox

See Also

GH_BoundingBox Members
GH_IO.Types Namespace


GH_BoundingBox Members

[image] [image]

Grasshopper SDK
GH_BoundingBox Members
GH_BoundingBox Structure Constructors Methods Fields See Also Send Feedback

The GH_BoundingBox type exposes the following members.

Constructors

 | Name | Description
Public method | GH_BoundingBox(GH_Point3D, GH_Point3D) | Constructor.
Public method | GH_BoundingBox(Double, Double, Double, Double, Double, Double) | Constructor.

Methods

 | Name | Description
Public method | ToString | Converts this structure to a human-readable string. (Overrides ValueType..::..ToString()()()().)

Fields

 | Name | Description
Public field | Max | Maximum corner of box.
Public field | Min | Minimum corner of box.

See Also

GH_BoundingBox Structure
GH_IO.Types Namespace


GH_BoundingBox Constructor

[image] [image]

Grasshopper SDK
GH_BoundingBox Constructor
GH_BoundingBox Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_BoundingBox(GH_Point3D, GH_Point3D) | Constructor.
Public method | GH_BoundingBox(Double, Double, Double, Double, Double, Double) | Constructor.

See Also

GH_BoundingBox Structure
GH_BoundingBox Members
GH_IO.Types Namespace


GH_BoundingBox Constructor (GH_Point3D, GH_Point3D)

[image]

Grasshopper SDK
GH_BoundingBox Constructor (GH_Point3D, GH_Point3D)
GH_BoundingBox Structure See Also Send Feedback
Constructor.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_BoundingBox(
    GH_Point3D nMin,
    GH_Point3D nMax
)
Visual Basic
Public Sub New ( _
    nMin As GH_Point3D, _
    nMax As GH_Point3D _
)

Parameters

nMin
Type: GH_IO.Types..::..GH_Point3D
Minimum corner of box.
nMax
Type: GH_IO.Types..::..GH_Point3D
Maximum corner of box.

See Also

GH_BoundingBox Structure
GH_BoundingBox Overload
GH_IO.Types Namespace


GH_BoundingBox Constructor (Double, Double, Double, Double, Double, Double)

[image]

Grasshopper SDK
GH_BoundingBox Constructor (Double, Double, Double, Double, Double, Double)
GH_BoundingBox Structure See Also Send Feedback
Constructor.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_BoundingBox(
    double Minx,
    double Miny,
    double Minz,
    double Maxx,
    double Maxy,
    double Maxz
)
Visual Basic
Public Sub New ( _
    Minx As Double, _
    Miny As Double, _
    Minz As Double, _
    Maxx As Double, _
    Maxy As Double, _
    Maxz As Double _
)

Parameters

Minx
Type: System..::..Double
X coordinate of minimum corner.
Miny
Type: System..::..Double
Y coordinate of minimum corner.
Minz
Type: System..::..Double
Z coordinate of minimum corner.
Maxx
Type: System..::..Double
X coordinate of maximum corner.
Maxy
Type: System..::..Double
Y coordinate of maximum corner.
Maxz
Type: System..::..Double
Z coordinate of maximum corner.

See Also

GH_BoundingBox Structure
GH_BoundingBox Overload
GH_IO.Types Namespace


GH_BoundingBox Fields

[image] [image]

Grasshopper SDK
GH_BoundingBox Fields
GH_BoundingBox Structure See Also Send Feedback

The GH_BoundingBox type exposes the following members.

Fields

 | Name | Description
Public field | Max | Maximum corner of box.
Public field | Min | Minimum corner of box.

See Also

GH_BoundingBox Structure
GH_IO.Types Namespace


Max Field

[image]

Grasshopper SDK
GH_BoundingBox..::..Max Field
GH_BoundingBox Structure See Also Send Feedback
Maximum corner of box.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Point3D Max
Visual Basic
Public Max As GH_Point3D

See Also

GH_BoundingBox Structure
GH_IO.Types Namespace


Min Field

[image]

Grasshopper SDK
GH_BoundingBox..::..Min Field
GH_BoundingBox Structure See Also Send Feedback
Minimum corner of box.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Point3D Min
Visual Basic
Public Min As GH_Point3D

See Also

GH_BoundingBox Structure
GH_IO.Types Namespace


GH_BoundingBox Methods

[image] [image]

Grasshopper SDK
GH_BoundingBox Methods
GH_BoundingBox Structure See Also Send Feedback

The GH_BoundingBox type exposes the following members.

Methods

 | Name | Description
Public method | ToString | Converts this structure to a human-readable string. (Overrides ValueType..::..ToString()()()().)

See Also

GH_BoundingBox Structure
GH_IO.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_BoundingBox..::..ToString Method
GH_BoundingBox Structure See Also Send Feedback
Converts this structure to a human-readable string.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A string representation of the box structure.

See Also

GH_BoundingBox Structure
GH_IO.Types Namespace


GH_Interval1D Structure

[image]

Grasshopper SDK
GH_Interval1D Structure
Members See Also Send Feedback
Represents two double precision floating point values.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public struct GH_Interval1D
Visual Basic
Public Structure GH_Interval1D

See Also

GH_Interval1D Members
GH_IO.Types Namespace


GH_Interval1D Members

[image] [image]

Grasshopper SDK
GH_Interval1D Members
GH_Interval1D Structure Constructors Methods Fields See Also Send Feedback

The GH_Interval1D type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Interval1D | Constructor.

Methods

 | Name | Description
Public method | ToString | Converts this structure to a human-readable string. (Overrides ValueType..::..ToString()()()().)

Fields

 | Name | Description
Public field | a | Start of interval.
Public field | b | End of interval.

See Also

GH_Interval1D Structure
GH_IO.Types Namespace


GH_Interval1D Constructor

[image]

Grasshopper SDK
GH_Interval1D Constructor
GH_Interval1D Structure See Also Send Feedback
Constructor.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Interval1D(
    double na,
    double nb
)
Visual Basic
Public Sub New ( _
    na As Double, _
    nb As Double _
)

Parameters

na
Type: System..::..Double
Start of interval.
nb
Type: System..::..Double
End of interval.

See Also

GH_Interval1D Structure
GH_IO.Types Namespace


GH_Interval1D Fields

[image] [image]

Grasshopper SDK
GH_Interval1D Fields
GH_Interval1D Structure See Also Send Feedback

The GH_Interval1D type exposes the following members.

Fields

 | Name | Description
Public field | a | Start of interval.
Public field | b | End of interval.

See Also

GH_Interval1D Structure
GH_IO.Types Namespace


a Field

[image]

Grasshopper SDK
GH_Interval1D..::..a Field
GH_Interval1D Structure See Also Send Feedback
Start of interval.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public double a
Visual Basic
Public a As Double

See Also

GH_Interval1D Structure
GH_IO.Types Namespace


b Field

[image]

Grasshopper SDK
GH_Interval1D..::..b Field
GH_Interval1D Structure See Also Send Feedback
End of interval.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public double b
Visual Basic
Public b As Double

See Also

GH_Interval1D Structure
GH_IO.Types Namespace


GH_Interval1D Methods

[image] [image]

Grasshopper SDK
GH_Interval1D Methods
GH_Interval1D Structure See Also Send Feedback

The GH_Interval1D type exposes the following members.

Methods

 | Name | Description
Public method | ToString | Converts this structure to a human-readable string. (Overrides ValueType..::..ToString()()()().)

See Also

GH_Interval1D Structure
GH_IO.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_Interval1D..::..ToString Method
GH_Interval1D Structure See Also Send Feedback
Converts this structure to a human-readable string.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A string representation of the Interval structure.

See Also

GH_Interval1D Structure
GH_IO.Types Namespace


GH_Interval2D Structure

[image]

Grasshopper SDK
GH_Interval2D Structure
Members See Also Send Feedback
Represents two double precision domains.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public struct GH_Interval2D
Visual Basic
Public Structure GH_Interval2D

See Also

GH_Interval2D Members
GH_IO.Types Namespace


GH_Interval2D Members

[image] [image]

Grasshopper SDK
GH_Interval2D Members
GH_Interval2D Structure Constructors Methods Fields See Also Send Feedback

The GH_Interval2D type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Interval2D(GH_Interval1D, GH_Interval1D) | Constructor.
Public method | GH_Interval2D(Double, Double, Double, Double) | Constructor.

Methods

 | Name | Description
Public method | ToString | Converts this structure to a human-readable string. (Overrides ValueType..::..ToString()()()().)

Fields

 | Name | Description
Public field | u | One dimensional component in U direction.
Public field | v | One dimensional component in V direction.

See Also

GH_Interval2D Structure
GH_IO.Types Namespace


GH_Interval2D Constructor

[image] [image]

Grasshopper SDK
GH_Interval2D Constructor
GH_Interval2D Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Interval2D(GH_Interval1D, GH_Interval1D) | Constructor.
Public method | GH_Interval2D(Double, Double, Double, Double) | Constructor.

See Also

GH_Interval2D Structure
GH_Interval2D Members
GH_IO.Types Namespace


GH_Interval2D Constructor (GH_Interval1D, GH_Interval1D)

[image]

Grasshopper SDK
GH_Interval2D Constructor (GH_Interval1D, GH_Interval1D)
GH_Interval2D Structure See Also Send Feedback
Constructor.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Interval2D(
    GH_Interval1D nu,
    GH_Interval1D nv
)
Visual Basic
Public Sub New ( _
    nu As GH_Interval1D, _
    nv As GH_Interval1D _
)

Parameters

nu
Type: GH_IO.Types..::..GH_Interval1D
Interval component in U direction.
nv
Type: GH_IO.Types..::..GH_Interval1D
Interval component in V direction.

See Also

GH_Interval2D Structure
GH_Interval2D Overload
GH_IO.Types Namespace


GH_Interval2D Constructor (Double, Double, Double, Double)

[image]

Grasshopper SDK
GH_Interval2D Constructor (Double, Double, Double, Double)
GH_Interval2D Structure See Also Send Feedback
Constructor.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Interval2D(
    double nu0,
    double nu1,
    double nv0,
    double nv1
)
Visual Basic
Public Sub New ( _
    nu0 As Double, _
    nu1 As Double, _
    nv0 As Double, _
    nv1 As Double _
)

Parameters

nu0
Type: System..::..Double
Start of interval component in U direction.
nu1
Type: System..::..Double
End of interval component in U direction.
nv0
Type: System..::..Double
Start of interval component in V direction.
nv1
Type: System..::..Double
End of interval component in V direction.

See Also

GH_Interval2D Structure
GH_Interval2D Overload
GH_IO.Types Namespace


GH_Interval2D Fields

[image] [image]

Grasshopper SDK
GH_Interval2D Fields
GH_Interval2D Structure See Also Send Feedback

The GH_Interval2D type exposes the following members.

Fields

 | Name | Description
Public field | u | One dimensional component in U direction.
Public field | v | One dimensional component in V direction.

See Also

GH_Interval2D Structure
GH_IO.Types Namespace


u Field

[image]

Grasshopper SDK
GH_Interval2D..::..u Field
GH_Interval2D Structure See Also Send Feedback
One dimensional component in U direction.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Interval1D u
Visual Basic
Public u As GH_Interval1D

See Also

GH_Interval2D Structure
GH_IO.Types Namespace


v Field

[image]

Grasshopper SDK
GH_Interval2D..::..v Field
GH_Interval2D Structure See Also Send Feedback
One dimensional component in V direction.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Interval1D v
Visual Basic
Public v As GH_Interval1D

See Also

GH_Interval2D Structure
GH_IO.Types Namespace


GH_Interval2D Methods

[image] [image]

Grasshopper SDK
GH_Interval2D Methods
GH_Interval2D Structure See Also Send Feedback

The GH_Interval2D type exposes the following members.

Methods

 | Name | Description
Public method | ToString | Converts this structure to a human-readable string. (Overrides ValueType..::..ToString()()()().)

See Also

GH_Interval2D Structure
GH_IO.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_Interval2D..::..ToString Method
GH_Interval2D Structure See Also Send Feedback
Converts this structure to a human-readable string.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A string representation of the two-dimensional Interval structure.

See Also

GH_Interval2D Structure
GH_IO.Types Namespace


GH_Item Class

[image]

Grasshopper SDK
GH_Item Class
Members See Also Send Feedback
Represents a single data item in a chunk.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public class GH_Item : GH_IBinarySupport, GH_IXmlSupport
Visual Basic
Public Class GH_Item _
    Implements GH_IBinarySupport, GH_IXmlSupport

Inheritance Hierarchy

System..::..Object
GH_IO.Types..::..GH_Item

See Also

GH_Item Members
GH_IO.Types Namespace


GH_Item Members

[image] [image]

Grasshopper SDK
GH_Item Members
GH_Item Class Constructors Methods Properties See Also Send Feedback

The GH_Item type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Item(String, GH_BoundingBox) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, GH_Interval1D) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, GH_Interval2D) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, GH_Line) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, GH_Plane) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, GH_Point2D) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, GH_Point3D) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, GH_Point4D) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, GH_Version) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, Boolean) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, Byte) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, array<Byte>[]()[][]) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, DateTime) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, Decimal) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, Double) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, array<Double>[]()[][]) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, Bitmap) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, Color) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, Point) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, PointF) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, Rectangle) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, RectangleF) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, Size) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, SizeF) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, Guid) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, Int32) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, Int64) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, Single) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, String) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, Int32, GH_BoundingBox) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, GH_Interval1D) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, GH_Interval2D) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, GH_Line) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, GH_Plane) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, GH_Point2D) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, GH_Point3D) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, GH_Point4D) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, GH_Version) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, Boolean) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, Byte) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, array<Byte>[]()[][]) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, DateTime) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, Decimal) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, Double) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, array<Double>[]()[][]) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, Bitmap) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, Color) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, Point) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, PointF) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, Rectangle) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, RectangleF) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, Size) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, SizeF) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, Guid) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, Int32) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, Int64) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, Single) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, String) | Construct a new instance of GH_Item with the specified name, index and value.

Methods

 | Name | Description
 | CreateFrom(BinaryReader) | Creates a new instance of GH_Item and sets the fields from a reader object.
 | CreateFrom(XmlNode) | Creates a new instance of GH_Item and sets the fields from an Xml node object.
Public method | Read(BinaryReader) | Deserialize this item from a binary stream.
Public method | Read(XmlNode) | Deserialize this item from an Xml node.
Public method | ToString | Converts the struct into a human readable format. (Overrides Object..::..ToString()()()().)
Public method | Write(BinaryWriter) | Serialize this item into a binary stream.
Public method | Write(XmlWriter) | Serialize this item into an Xml stream.

Properties

 | Name | Description
Public property | _bool | Returns the internal data of this item cast to a Boolean. If the data is not stored as a Boolean, a conversion exception might be thrown.
Public property | _boundingbox | Returns the internal data of this item cast to a BoundingBox. If the data is not stored as a BoundingBox, a conversion exception might be thrown.
Public property | _byte | Returns the internal data of this item cast to a Byte. If the data is not stored as a Byte, a conversion exception might be thrown.
Public property | _bytearray | Returns the internal data of this item cast to a Byte array. If the data is not stored as a Byte array, a conversion exception might be thrown.
Public property | _date | Returns the internal data of this item cast to a DateTime. If the data is not stored as a DateTime, a conversion exception might be thrown.
Public property | _decimal | Returns the internal data of this item cast to a Decimal. If the data is not stored as a Decimal, a conversion exception might be thrown.
Public property | _double | Returns the internal data of this item cast to a Double. If the data is not stored as a Double, a conversion exception might be thrown.
Public property | _doublearray | Returns the internal data of this item cast to a Byte array. If the data is not stored as a Byte array, a conversion exception might be thrown.
Public property | _drawing_bitmap | Returns the internal data of this item cast to a Bitmap. If the data is not stored as a Bitmap, a conversion exception might be thrown.
Public property | _drawing_color | Returns the internal data of this item cast to a Color. If the data is not stored as a Color, a conversion exception might be thrown.
Public property | _drawing_point | Returns the internal data of this item cast to a Point. If the data is not stored as a Point, a conversion exception might be thrown.
Public property | _drawing_pointf | Returns the internal data of this item cast to a PointF. If the data is not stored as a PointF, a conversion exception might be thrown.
Public property | _drawing_rectangle | Returns the internal data of this item cast to a Rectangle. If the data is not stored as a Rectangle, a conversion exception might be thrown.
Public property | _drawing_rectanglef | Returns the internal data of this item cast to a RectangleF. If the data is not stored as a RectangleF, a conversion exception might be thrown.
Public property | _drawing_size | Returns the internal data of this item cast to a Size. If the data is not stored as a Size, a conversion exception might be thrown.
Public property | _drawing_sizef | Returns the internal data of this item cast to a SizeF. If the data is not stored as a SizeF, a conversion exception might be thrown.
Public property | _guid | Returns the internal data of this item cast to a Guid. If the data is not stored as a Guid, a conversion exception might be thrown.
Public property | _int32 | Returns the internal data of this item cast to an Int32. If the data is not stored as an Int32, a conversion exception might be thrown.
Public property | _int64 | Returns the internal data of this item cast to an Int64. If the data is not stored as an Int64, a conversion exception might be thrown.
Public property | _interval1d | Returns the internal data of this item cast to an Interval1D. If the data is not stored as an Interval1D, a conversion exception might be thrown.
Public property | _interval2d | Returns the internal data of this item cast to an Interval2D. If the data is not stored as an Interval2D, a conversion exception might be thrown.
Public property | _line | Returns the internal data of this item cast to a Line. If the data is not stored as a Line, a conversion exception might be thrown.
Public property | _plane | Returns the internal data of this item cast to a Plane. If the data is not stored as a Plane, a conversion exception might be thrown.
Public property | _point2d | Returns the internal data of this item cast to a Point2D. If the data is not stored as a Point2D, a conversion exception might be thrown.
Public property | _point3d | Returns the internal data of this item cast to a Point3D. If the data is not stored as a Point3D, a conversion exception might be thrown.
Public property | _point4d | Returns the internal data of this item cast to a Point4D. If the data is not stored as a Point4D, a conversion exception might be thrown.
Public property | _single | Returns the internal data of this item cast to a Single. If the data is not stored as a Single, a conversion exception might be thrown.
Public property | _string | Returns the internal data of this item cast to a String. If the data is not stored as a String, a conversion exception might be thrown.
Public property | _version | Returns the internal data of this item cast to a Version. If the data is not stored as a Version, a conversion exception might be thrown.
Public property | HasIndex | Gets the index existence implication. The item is considered to have an index qualifier if the index value is larger than or equal to zero.
Public property | HasName | Gets the name validity of this item. The item is considered to have an invalid name if string.IsNullOrEmpty(name)
Public property | HasType | Gets the type set validity of this item. The item is considered to have a type if type != GH_Types.unset
Public property | Index | Gets or sets the index of an item. Typically, indices are set at construction and do not change. If you change indices after construction, you could corrupt an archive.
Public property | InternalData | Retrieves the internal data of this item. No type casting is performed.
Public property | Name | Gets or sets the name of this item. Typically, names are set at construction and do not change. If you change names after construction, you could corrupt an archive.
Public property | Type | Gets the type of this item. Type flags are set during construction and cannot be altered.

See Also

GH_Item Class
GH_IO.Types Namespace


GH_Item Constructor

[image] [image]

Grasshopper SDK
GH_Item Constructor
GH_Item Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Item(String, GH_BoundingBox) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, GH_Interval1D) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, GH_Interval2D) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, GH_Line) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, GH_Plane) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, GH_Point2D) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, GH_Point3D) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, GH_Point4D) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, GH_Version) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, Boolean) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, Byte) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, array<Byte>[]()[][]) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, DateTime) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, Decimal) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, Double) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, array<Double>[]()[][]) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, Bitmap) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, Color) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, Point) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, PointF) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, Rectangle) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, RectangleF) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, Size) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, SizeF) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, Guid) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, Int32) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, Int64) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, Single) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, String) | Construct a new instance of GH_Item with the specified name and value.
Public method | GH_Item(String, Int32, GH_BoundingBox) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, GH_Interval1D) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, GH_Interval2D) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, GH_Line) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, GH_Plane) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, GH_Point2D) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, GH_Point3D) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, GH_Point4D) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, GH_Version) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, Boolean) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, Byte) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, array<Byte>[]()[][]) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, DateTime) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, Decimal) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, Double) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, array<Double>[]()[][]) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, Bitmap) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, Color) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, Point) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, PointF) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, Rectangle) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, RectangleF) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, Size) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, SizeF) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, Guid) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, Int32) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, Int64) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, Single) | Construct a new instance of GH_Item with the specified name, index and value.
Public method | GH_Item(String, Int32, String) | Construct a new instance of GH_Item with the specified name, index and value.

See Also

GH_Item Class
GH_Item Members
GH_IO.Types Namespace


GH_Item Constructor (String, GH_BoundingBox)

[image]

Grasshopper SDK
GH_Item Constructor (String, GH_BoundingBox)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    GH_BoundingBox item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_data As GH_BoundingBox _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_data
Type: GH_IO.Types..::..GH_BoundingBox
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, GH_Interval1D)

[image]

Grasshopper SDK
GH_Item Constructor (String, GH_Interval1D)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    GH_Interval1D item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_data As GH_Interval1D _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_data
Type: GH_IO.Types..::..GH_Interval1D
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, GH_Interval2D)

[image]

Grasshopper SDK
GH_Item Constructor (String, GH_Interval2D)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    GH_Interval2D item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_data As GH_Interval2D _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_data
Type: GH_IO.Types..::..GH_Interval2D
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, GH_Line)

[image]

Grasshopper SDK
GH_Item Constructor (String, GH_Line)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    GH_Line item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_data As GH_Line _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_data
Type: GH_IO.Types..::..GH_Line
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, GH_Plane)

[image]

Grasshopper SDK
GH_Item Constructor (String, GH_Plane)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    GH_Plane item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_data As GH_Plane _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_data
Type: GH_IO.Types..::..GH_Plane
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, GH_Point2D)

[image]

Grasshopper SDK
GH_Item Constructor (String, GH_Point2D)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    GH_Point2D item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_data As GH_Point2D _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_data
Type: GH_IO.Types..::..GH_Point2D
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, GH_Point3D)

[image]

Grasshopper SDK
GH_Item Constructor (String, GH_Point3D)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    GH_Point3D item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_data As GH_Point3D _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_data
Type: GH_IO.Types..::..GH_Point3D
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, GH_Point4D)

[image]

Grasshopper SDK
GH_Item Constructor (String, GH_Point4D)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    GH_Point4D item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_data As GH_Point4D _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_data
Type: GH_IO.Types..::..GH_Point4D
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, GH_Version)

[image]

Grasshopper SDK
GH_Item Constructor (String, GH_Version)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    GH_Version item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_data As GH_Version _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_data
Type: GH_IO.Types..::..GH_Version
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Boolean)

[image]

Grasshopper SDK
GH_Item Constructor (String, Boolean)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    bool item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_data As Boolean _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_data
Type: System..::..Boolean
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Byte)

[image]

Grasshopper SDK
GH_Item Constructor (String, Byte)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    byte item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_data As Byte _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_data
Type: System..::..Byte
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Byte[])

[image]

Grasshopper SDK
GH_Item Constructor (String, array<Byte>[]()[][])
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    byte[] item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_data As Byte() _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_data
Type: array< System..::..Byte >[]()[][]
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, DateTime)

[image]

Grasshopper SDK
GH_Item Constructor (String, DateTime)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    DateTime item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_data As DateTime _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_data
Type: System..::..DateTime
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Decimal)

[image]

Grasshopper SDK
GH_Item Constructor (String, Decimal)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    decimal item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_data As Decimal _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_data
Type: System..::..Decimal
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Double)

[image]

Grasshopper SDK
GH_Item Constructor (String, Double)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    double item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_data As Double _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_data
Type: System..::..Double
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Double[])

[image]

Grasshopper SDK
GH_Item Constructor (String, array<Double>[]()[][])
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    double[] item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_data As Double() _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_data
Type: array< System..::..Double >[]()[][]
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Bitmap)

[image]

Grasshopper SDK
GH_Item Constructor (String, Bitmap)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    Bitmap item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_data As Bitmap _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_data
Type: System.Drawing..::..Bitmap
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Color)

[image]

Grasshopper SDK
GH_Item Constructor (String, Color)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    Color item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_data As Color _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_data
Type: System.Drawing..::..Color
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Point)

[image]

Grasshopper SDK
GH_Item Constructor (String, Point)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    Point item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_data As Point _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_data
Type: System.Drawing..::..Point
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, PointF)

[image]

Grasshopper SDK
GH_Item Constructor (String, PointF)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    PointF item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_data As PointF _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_data
Type: System.Drawing..::..PointF
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Rectangle)

[image]

Grasshopper SDK
GH_Item Constructor (String, Rectangle)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    Rectangle item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_data As Rectangle _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_data
Type: System.Drawing..::..Rectangle
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, RectangleF)

[image]

Grasshopper SDK
GH_Item Constructor (String, RectangleF)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    RectangleF item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_data As RectangleF _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_data
Type: System.Drawing..::..RectangleF
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Size)

[image]

Grasshopper SDK
GH_Item Constructor (String, Size)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    Size item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_data As Size _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_data
Type: System.Drawing..::..Size
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, SizeF)

[image]

Grasshopper SDK
GH_Item Constructor (String, SizeF)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    SizeF item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_data As SizeF _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_data
Type: System.Drawing..::..SizeF
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Guid)

[image]

Grasshopper SDK
GH_Item Constructor (String, Guid)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    Guid item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_data As Guid _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_data
Type: System..::..Guid
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Int32)

[image]

Grasshopper SDK
GH_Item Constructor (String, Int32)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    int item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_data As Integer _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_data
Type: System..::..Int32
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Int64)

[image]

Grasshopper SDK
GH_Item Constructor (String, Int64)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    long item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_data As Long _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_data
Type: System..::..Int64
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Single)

[image]

Grasshopper SDK
GH_Item Constructor (String, Single)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    float item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_data As Single _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_data
Type: System..::..Single
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, String)

[image]

Grasshopper SDK
GH_Item Constructor (String, String)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    string item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_data As String _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_data
Type: System..::..String
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Int32, GH_BoundingBox)

[image]

Grasshopper SDK
GH_Item Constructor (String, Int32, GH_BoundingBox)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name, index and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    int item_index,
    GH_BoundingBox item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_index As Integer, _
    item_data As GH_BoundingBox _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_index
Type: System..::..Int32
Index of new item. Any index less than zero will be clamped to -1.
item_data
Type: GH_IO.Types..::..GH_BoundingBox
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Int32, GH_Interval1D)

[image]

Grasshopper SDK
GH_Item Constructor (String, Int32, GH_Interval1D)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name, index and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    int item_index,
    GH_Interval1D item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_index As Integer, _
    item_data As GH_Interval1D _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_index
Type: System..::..Int32
Index of new item. Any index less than zero will be clamped to -1.
item_data
Type: GH_IO.Types..::..GH_Interval1D
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Int32, GH_Interval2D)

[image]

Grasshopper SDK
GH_Item Constructor (String, Int32, GH_Interval2D)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name, index and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    int item_index,
    GH_Interval2D item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_index As Integer, _
    item_data As GH_Interval2D _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_index
Type: System..::..Int32
Index of new item. Any index less than zero will be clamped to -1.
item_data
Type: GH_IO.Types..::..GH_Interval2D
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Int32, GH_Line)

[image]

Grasshopper SDK
GH_Item Constructor (String, Int32, GH_Line)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name, index and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    int item_index,
    GH_Line item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_index As Integer, _
    item_data As GH_Line _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_index
Type: System..::..Int32
Index of new item. Any index less than zero will be clamped to -1.
item_data
Type: GH_IO.Types..::..GH_Line
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Int32, GH_Plane)

[image]

Grasshopper SDK
GH_Item Constructor (String, Int32, GH_Plane)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name, index and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    int item_index,
    GH_Plane item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_index As Integer, _
    item_data As GH_Plane _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_index
Type: System..::..Int32
Index of new item. Any index less than zero will be clamped to -1.
item_data
Type: GH_IO.Types..::..GH_Plane
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Int32, GH_Point2D)

[image]

Grasshopper SDK
GH_Item Constructor (String, Int32, GH_Point2D)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name, index and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    int item_index,
    GH_Point2D item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_index As Integer, _
    item_data As GH_Point2D _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_index
Type: System..::..Int32
Index of new item. Any index less than zero will be clamped to -1.
item_data
Type: GH_IO.Types..::..GH_Point2D
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Int32, GH_Point3D)

[image]

Grasshopper SDK
GH_Item Constructor (String, Int32, GH_Point3D)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name, index and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    int item_index,
    GH_Point3D item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_index As Integer, _
    item_data As GH_Point3D _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_index
Type: System..::..Int32
Index of new item. Any index less than zero will be clamped to -1.
item_data
Type: GH_IO.Types..::..GH_Point3D
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Int32, GH_Point4D)

[image]

Grasshopper SDK
GH_Item Constructor (String, Int32, GH_Point4D)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name, index and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    int item_index,
    GH_Point4D item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_index As Integer, _
    item_data As GH_Point4D _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_index
Type: System..::..Int32
Index of new item. Any index less than zero will be clamped to -1.
item_data
Type: GH_IO.Types..::..GH_Point4D
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Int32, GH_Version)

[image]

Grasshopper SDK
GH_Item Constructor (String, Int32, GH_Version)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name, index and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    int item_index,
    GH_Version item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_index As Integer, _
    item_data As GH_Version _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_index
Type: System..::..Int32
Index of new item. Any index less than zero will be clamped to -1.
item_data
Type: GH_IO.Types..::..GH_Version
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Int32, Boolean)

[image]

Grasshopper SDK
GH_Item Constructor (String, Int32, Boolean)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name, index and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    int item_index,
    bool item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_index As Integer, _
    item_data As Boolean _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_index
Type: System..::..Int32
Index of new item. Any index less than zero will be clamped to -1.
item_data
Type: System..::..Boolean
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Int32, Byte)

[image]

Grasshopper SDK
GH_Item Constructor (String, Int32, Byte)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name, index and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    int item_index,
    byte item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_index As Integer, _
    item_data As Byte _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_index
Type: System..::..Int32
Index of new item. Any index less than zero will be clamped to -1.
item_data
Type: System..::..Byte
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Int32, Byte[])

[image]

Grasshopper SDK
GH_Item Constructor (String, Int32, array<Byte>[]()[][])
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name, index and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    int item_index,
    byte[] item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_index As Integer, _
    item_data As Byte() _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_index
Type: System..::..Int32
Index of new item. Any index less than zero will be clamped to -1.
item_data
Type: array< System..::..Byte >[]()[][]
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Int32, DateTime)

[image]

Grasshopper SDK
GH_Item Constructor (String, Int32, DateTime)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name, index and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    int item_index,
    DateTime item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_index As Integer, _
    item_data As DateTime _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_index
Type: System..::..Int32
Index of new item. Any index less than zero will be clamped to -1.
item_data
Type: System..::..DateTime
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Int32, Decimal)

[image]

Grasshopper SDK
GH_Item Constructor (String, Int32, Decimal)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name, index and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    int item_index,
    decimal item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_index As Integer, _
    item_data As Decimal _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_index
Type: System..::..Int32
Index of new item. Any index less than zero will be clamped to -1.
item_data
Type: System..::..Decimal
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Int32, Double)

[image]

Grasshopper SDK
GH_Item Constructor (String, Int32, Double)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name, index and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    int item_index,
    double item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_index As Integer, _
    item_data As Double _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_index
Type: System..::..Int32
Index of new item. Any index less than zero will be clamped to -1.
item_data
Type: System..::..Double
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Int32, Double[])

[image]

Grasshopper SDK
GH_Item Constructor (String, Int32, array<Double>[]()[][])
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name, index and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    int item_index,
    double[] item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_index As Integer, _
    item_data As Double() _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_index
Type: System..::..Int32
Index of new item. Any index less than zero will be clamped to -1.
item_data
Type: array< System..::..Double >[]()[][]
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Int32, Bitmap)

[image]

Grasshopper SDK
GH_Item Constructor (String, Int32, Bitmap)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name, index and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    int item_index,
    Bitmap item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_index As Integer, _
    item_data As Bitmap _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_index
Type: System..::..Int32
Index of new item. Any index less than zero will be clamped to -1.
item_data
Type: System.Drawing..::..Bitmap
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Int32, Color)

[image]

Grasshopper SDK
GH_Item Constructor (String, Int32, Color)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name, index and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    int item_index,
    Color item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_index As Integer, _
    item_data As Color _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_index
Type: System..::..Int32
Index of new item. Any index less than zero will be clamped to -1.
item_data
Type: System.Drawing..::..Color
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Int32, Point)

[image]

Grasshopper SDK
GH_Item Constructor (String, Int32, Point)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name, index and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    int item_index,
    Point item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_index As Integer, _
    item_data As Point _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_index
Type: System..::..Int32
Index of new item. Any index less than zero will be clamped to -1.
item_data
Type: System.Drawing..::..Point
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Int32, PointF)

[image]

Grasshopper SDK
GH_Item Constructor (String, Int32, PointF)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name, index and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    int item_index,
    PointF item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_index As Integer, _
    item_data As PointF _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_index
Type: System..::..Int32
Index of new item. Any index less than zero will be clamped to -1.
item_data
Type: System.Drawing..::..PointF
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Int32, Rectangle)

[image]

Grasshopper SDK
GH_Item Constructor (String, Int32, Rectangle)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name, index and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    int item_index,
    Rectangle item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_index As Integer, _
    item_data As Rectangle _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_index
Type: System..::..Int32
Index of new item. Any index less than zero will be clamped to -1.
item_data
Type: System.Drawing..::..Rectangle
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Int32, RectangleF)

[image]

Grasshopper SDK
GH_Item Constructor (String, Int32, RectangleF)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name, index and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    int item_index,
    RectangleF item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_index As Integer, _
    item_data As RectangleF _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_index
Type: System..::..Int32
Index of new item. Any index less than zero will be clamped to -1.
item_data
Type: System.Drawing..::..RectangleF
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Int32, Size)

[image]

Grasshopper SDK
GH_Item Constructor (String, Int32, Size)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name, index and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    int item_index,
    Size item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_index As Integer, _
    item_data As Size _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_index
Type: System..::..Int32
Index of new item. Any index less than zero will be clamped to -1.
item_data
Type: System.Drawing..::..Size
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Int32, SizeF)

[image]

Grasshopper SDK
GH_Item Constructor (String, Int32, SizeF)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name, index and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    int item_index,
    SizeF item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_index As Integer, _
    item_data As SizeF _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_index
Type: System..::..Int32
Index of new item. Any index less than zero will be clamped to -1.
item_data
Type: System.Drawing..::..SizeF
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Int32, Guid)

[image]

Grasshopper SDK
GH_Item Constructor (String, Int32, Guid)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name, index and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    int item_index,
    Guid item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_index As Integer, _
    item_data As Guid _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_index
Type: System..::..Int32
Index of new item. Any index less than zero will be clamped to -1.
item_data
Type: System..::..Guid
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Int32, Int32)

[image]

Grasshopper SDK
GH_Item Constructor (String, Int32, Int32)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name, index and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    int item_index,
    int item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_index As Integer, _
    item_data As Integer _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_index
Type: System..::..Int32
Index of new item. Any index less than zero will be clamped to -1.
item_data
Type: System..::..Int32
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Int32, Int64)

[image]

Grasshopper SDK
GH_Item Constructor (String, Int32, Int64)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name, index and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    int item_index,
    long item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_index As Integer, _
    item_data As Long _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_index
Type: System..::..Int32
Index of new item. Any index less than zero will be clamped to -1.
item_data
Type: System..::..Int64
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Int32, Single)

[image]

Grasshopper SDK
GH_Item Constructor (String, Int32, Single)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name, index and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    int item_index,
    float item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_index As Integer, _
    item_data As Single _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_index
Type: System..::..Int32
Index of new item. Any index less than zero will be clamped to -1.
item_data
Type: System..::..Single
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Constructor (String, Int32, String)

[image]

Grasshopper SDK
GH_Item Constructor (String, Int32, String)
GH_Item Class See Also Send Feedback
Construct a new instance of GH_Item with the specified name, index and value.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Item(
    string item_name,
    int item_index,
    string item_data
)
Visual Basic
Public Sub New ( _
    item_name As String, _
    item_index As Integer, _
    item_data As String _
)

Parameters

item_name
Type: System..::..String
Name of new item.
item_index
Type: System..::..Int32
Index of new item. Any index less than zero will be clamped to -1.
item_data
Type: System..::..String
Value of new item.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the specified name string is null or empty.

See Also

GH_Item Class
GH_Item Overload
GH_IO.Types Namespace


GH_Item Methods

[image] [image]

Grasshopper SDK
GH_Item Methods
GH_Item Class See Also Send Feedback

The GH_Item type exposes the following members.

Methods

 | Name | Description
 | CreateFrom(BinaryReader) | Creates a new instance of GH_Item and sets the fields from a reader object.
 | CreateFrom(XmlNode) | Creates a new instance of GH_Item and sets the fields from an Xml node object.
Public method | Read(BinaryReader) | Deserialize this item from a binary stream.
Public method | Read(XmlNode) | Deserialize this item from an Xml node.
Public method | ToString | Converts the struct into a human readable format. (Overrides Object..::..ToString()()()().)
Public method | Write(BinaryWriter) | Serialize this item into a binary stream.
Public method | Write(XmlWriter) | Serialize this item into an Xml stream.

See Also

GH_Item Class
GH_IO.Types Namespace


CreateFrom Method

[image] [image]

Grasshopper SDK
GH_Item..::..CreateFrom Method
GH_Item Class See Also Send Feedback

Overload List

Name | Description
CreateFrom(BinaryReader) | Creates a new instance of GH_Item and sets the fields from a reader object.
CreateFrom(XmlNode) | Creates a new instance of GH_Item and sets the fields from an Xml node object.

See Also

GH_Item Class
GH_Item Members
GH_IO.Types Namespace


CreateFrom Method (BinaryReader)

[image]

Grasshopper SDK
GH_Item..::..CreateFrom Method (BinaryReader)
GH_Item Class See Also Send Feedback
Creates a new instance of GH_Item and sets the fields from a reader object.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public static GH_Item CreateFrom(
    BinaryReader reader
)
Visual Basic
Public Shared Function CreateFrom ( _
    reader As BinaryReader _
) As GH_Item

Parameters

reader
Type: System.IO..::..BinaryReader
Reader object that defines the field data.

Return Value

The constructed and read item.

See Also

GH_Item Class
CreateFrom Overload
GH_IO.Types Namespace


CreateFrom Method (XmlNode)

[image]

Grasshopper SDK
GH_Item..::..CreateFrom Method (XmlNode)
GH_Item Class See Also Send Feedback
Creates a new instance of GH_Item and sets the fields from an Xml node object.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public static GH_Item CreateFrom(
    XmlNode node
)
Visual Basic
Public Shared Function CreateFrom ( _
    node As XmlNode _
) As GH_Item

Parameters

node
Type: System.Xml..::..XmlNode
Xml node object that defines the field data.

Return Value

The constructed and read item.

See Also

GH_Item Class
CreateFrom Overload
GH_IO.Types Namespace


Read Method

[image] [image]

Grasshopper SDK
GH_Item..::..Read Method
GH_Item Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Read(BinaryReader) | Deserialize this item from a binary stream.
Public method | Read(XmlNode) | Deserialize this item from an Xml node.

See Also

GH_Item Class
GH_Item Members
GH_IO.Types Namespace


Read Method (BinaryReader)

[image]

Grasshopper SDK
GH_Item..::..Read Method (BinaryReader)
GH_Item Class See Also Send Feedback
Deserialize this item from a binary stream.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void Read(
    BinaryReader reader
)
Visual Basic
Public Sub Read ( _
    reader As BinaryReader _
)

Parameters

reader
Type: System.IO..::..BinaryReader
Reader to deserialize with.

Implements

GH_IBinarySupport..::..Read(BinaryReader)

See Also

GH_Item Class
Read Overload
GH_IO.Types Namespace


Read Method (XmlNode)

[image]

Grasshopper SDK
GH_Item..::..Read Method (XmlNode)
GH_Item Class See Also Send Feedback
Deserialize this item from an Xml node.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void Read(
    XmlNode node
)
Visual Basic
Public Sub Read ( _
    node As XmlNode _
)

Parameters

node
Type: System.Xml..::..XmlNode
Xml node to serialize from.

Implements

GH_IXmlSupport..::..Read(XmlNode)

See Also

GH_Item Class
Read Overload
GH_IO.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_Item..::..ToString Method
GH_Item Class See Also Send Feedback
Converts the struct into a human readable format.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_Item Class
GH_IO.Types Namespace


Write Method

[image] [image]

Grasshopper SDK
GH_Item..::..Write Method
GH_Item Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Write(BinaryWriter) | Serialize this item into a binary stream.
Public method | Write(XmlWriter) | Serialize this item into an Xml stream.

See Also

GH_Item Class
GH_Item Members
GH_IO.Types Namespace


Write Method (BinaryWriter)

[image]

Grasshopper SDK
GH_Item..::..Write Method (BinaryWriter)
GH_Item Class See Also Send Feedback
Serialize this item into a binary stream.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void Write(
    BinaryWriter writer
)
Visual Basic
Public Sub Write ( _
    writer As BinaryWriter _
)

Parameters

writer
Type: System.IO..::..BinaryWriter
Writer to serialize with.

Implements

GH_IBinarySupport..::..Write(BinaryWriter)

Exceptions

Exception | Condition
System..::..MemberAccessException | Thrown if !HasName.
System..::..MemberAccessException | Thrown if !HasType.
System.IO..::..IOException | Thrown if the internal data could not be serialized.

See Also

GH_Item Class
Write Overload
GH_IO.Types Namespace


Write Method (XmlWriter)

[image]

Grasshopper SDK
GH_Item..::..Write Method (XmlWriter)
GH_Item Class See Also Send Feedback
Serialize this item into an Xml stream.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void Write(
    XmlWriter writer
)
Visual Basic
Public Sub Write ( _
    writer As XmlWriter _
)

Parameters

writer
Type: System.Xml..::..XmlWriter
Writer to serialize with.

Implements

GH_IXmlSupport..::..Write(XmlWriter)

Exceptions

Exception | Condition
System..::..MemberAccessException | Thrown if !HasName.
System..::..MemberAccessException | Thrown if !HasType.
System.IO..::..IOException | Thrown if the internal data could not be serialized.

See Also

GH_Item Class
Write Overload
GH_IO.Types Namespace


GH_Item Properties

[image] [image]

Grasshopper SDK
GH_Item Properties
GH_Item Class See Also Send Feedback

The GH_Item type exposes the following members.

Properties

 | Name | Description
Public property | _bool | Returns the internal data of this item cast to a Boolean. If the data is not stored as a Boolean, a conversion exception might be thrown.
Public property | _boundingbox | Returns the internal data of this item cast to a BoundingBox. If the data is not stored as a BoundingBox, a conversion exception might be thrown.
Public property | _byte | Returns the internal data of this item cast to a Byte. If the data is not stored as a Byte, a conversion exception might be thrown.
Public property | _bytearray | Returns the internal data of this item cast to a Byte array. If the data is not stored as a Byte array, a conversion exception might be thrown.
Public property | _date | Returns the internal data of this item cast to a DateTime. If the data is not stored as a DateTime, a conversion exception might be thrown.
Public property | _decimal | Returns the internal data of this item cast to a Decimal. If the data is not stored as a Decimal, a conversion exception might be thrown.
Public property | _double | Returns the internal data of this item cast to a Double. If the data is not stored as a Double, a conversion exception might be thrown.
Public property | _doublearray | Returns the internal data of this item cast to a Byte array. If the data is not stored as a Byte array, a conversion exception might be thrown.
Public property | _drawing_bitmap | Returns the internal data of this item cast to a Bitmap. If the data is not stored as a Bitmap, a conversion exception might be thrown.
Public property | _drawing_color | Returns the internal data of this item cast to a Color. If the data is not stored as a Color, a conversion exception might be thrown.
Public property | _drawing_point | Returns the internal data of this item cast to a Point. If the data is not stored as a Point, a conversion exception might be thrown.
Public property | _drawing_pointf | Returns the internal data of this item cast to a PointF. If the data is not stored as a PointF, a conversion exception might be thrown.
Public property | _drawing_rectangle | Returns the internal data of this item cast to a Rectangle. If the data is not stored as a Rectangle, a conversion exception might be thrown.
Public property | _drawing_rectanglef | Returns the internal data of this item cast to a RectangleF. If the data is not stored as a RectangleF, a conversion exception might be thrown.
Public property | _drawing_size | Returns the internal data of this item cast to a Size. If the data is not stored as a Size, a conversion exception might be thrown.
Public property | _drawing_sizef | Returns the internal data of this item cast to a SizeF. If the data is not stored as a SizeF, a conversion exception might be thrown.
Public property | _guid | Returns the internal data of this item cast to a Guid. If the data is not stored as a Guid, a conversion exception might be thrown.
Public property | _int32 | Returns the internal data of this item cast to an Int32. If the data is not stored as an Int32, a conversion exception might be thrown.
Public property | _int64 | Returns the internal data of this item cast to an Int64. If the data is not stored as an Int64, a conversion exception might be thrown.
Public property | _interval1d | Returns the internal data of this item cast to an Interval1D. If the data is not stored as an Interval1D, a conversion exception might be thrown.
Public property | _interval2d | Returns the internal data of this item cast to an Interval2D. If the data is not stored as an Interval2D, a conversion exception might be thrown.
Public property | _line | Returns the internal data of this item cast to a Line. If the data is not stored as a Line, a conversion exception might be thrown.
Public property | _plane | Returns the internal data of this item cast to a Plane. If the data is not stored as a Plane, a conversion exception might be thrown.
Public property | _point2d | Returns the internal data of this item cast to a Point2D. If the data is not stored as a Point2D, a conversion exception might be thrown.
Public property | _point3d | Returns the internal data of this item cast to a Point3D. If the data is not stored as a Point3D, a conversion exception might be thrown.
Public property | _point4d | Returns the internal data of this item cast to a Point4D. If the data is not stored as a Point4D, a conversion exception might be thrown.
Public property | _single | Returns the internal data of this item cast to a Single. If the data is not stored as a Single, a conversion exception might be thrown.
Public property | _string | Returns the internal data of this item cast to a String. If the data is not stored as a String, a conversion exception might be thrown.
Public property | _version | Returns the internal data of this item cast to a Version. If the data is not stored as a Version, a conversion exception might be thrown.
Public property | HasIndex | Gets the index existence implication. The item is considered to have an index qualifier if the index value is larger than or equal to zero.
Public property | HasName | Gets the name validity of this item. The item is considered to have an invalid name if string.IsNullOrEmpty(name)
Public property | HasType | Gets the type set validity of this item. The item is considered to have a type if type != GH_Types.unset
Public property | Index | Gets or sets the index of an item. Typically, indices are set at construction and do not change. If you change indices after construction, you could corrupt an archive.
Public property | InternalData | Retrieves the internal data of this item. No type casting is performed.
Public property | Name | Gets or sets the name of this item. Typically, names are set at construction and do not change. If you change names after construction, you could corrupt an archive.
Public property | Type | Gets the type of this item. Type flags are set during construction and cannot be altered.

See Also

GH_Item Class
GH_IO.Types Namespace


_bool Property

[image]

Grasshopper SDK
GH_Item..::.._bool Property
GH_Item Class See Also Send Feedback
Returns the internal data of this item cast to a Boolean. If the data is not stored as a Boolean, a conversion exception might be thrown.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool _bool { get; }
Visual Basic
Public ReadOnly Property _bool As Boolean
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Types.GH_Item._bool"]

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.

See Also

GH_Item Class
GH_IO.Types Namespace


_boundingbox Property

[image]

Grasshopper SDK
GH_Item..::.._boundingbox Property
GH_Item Class See Also Send Feedback
Returns the internal data of this item cast to a BoundingBox. If the data is not stored as a BoundingBox, a conversion exception might be thrown.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_BoundingBox _boundingbox { get; }
Visual Basic
Public ReadOnly Property _boundingbox As GH_BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Types.GH_Item._boundingbox"]

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.

See Also

GH_Item Class
GH_IO.Types Namespace


_byte Property

[image]

Grasshopper SDK
GH_Item..::.._byte Property
GH_Item Class See Also Send Feedback
Returns the internal data of this item cast to a Byte. If the data is not stored as a Byte, a conversion exception might be thrown.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public byte _byte { get; }
Visual Basic
Public ReadOnly Property _byte As Byte
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Types.GH_Item._byte"]

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.

See Also

GH_Item Class
GH_IO.Types Namespace


_bytearray Property

[image]

Grasshopper SDK
GH_Item..::.._bytearray Property
GH_Item Class See Also Send Feedback
Returns the internal data of this item cast to a Byte array. If the data is not stored as a Byte array, a conversion exception might be thrown.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public byte[] _bytearray { get; }
Visual Basic
Public ReadOnly Property _bytearray As Byte()
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Types.GH_Item._bytearray"]

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.

See Also

GH_Item Class
GH_IO.Types Namespace


_date Property

[image]

Grasshopper SDK
GH_Item..::.._date Property
GH_Item Class See Also Send Feedback
Returns the internal data of this item cast to a DateTime. If the data is not stored as a DateTime, a conversion exception might be thrown.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public DateTime _date { get; }
Visual Basic
Public ReadOnly Property _date As DateTime
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Types.GH_Item._date"]

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.

See Also

GH_Item Class
GH_IO.Types Namespace


_decimal Property

[image]

Grasshopper SDK
GH_Item..::.._decimal Property
GH_Item Class See Also Send Feedback
Returns the internal data of this item cast to a Decimal. If the data is not stored as a Decimal, a conversion exception might be thrown.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public decimal _decimal { get; }
Visual Basic
Public ReadOnly Property _decimal As Decimal
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Types.GH_Item._decimal"]

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.

See Also

GH_Item Class
GH_IO.Types Namespace


_double Property

[image]

Grasshopper SDK
GH_Item..::.._double Property
GH_Item Class See Also Send Feedback
Returns the internal data of this item cast to a Double. If the data is not stored as a Double, a conversion exception might be thrown.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public double _double { get; }
Visual Basic
Public ReadOnly Property _double As Double
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Types.GH_Item._double"]

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.

See Also

GH_Item Class
GH_IO.Types Namespace


_doublearray Property

[image]

Grasshopper SDK
GH_Item..::.._doublearray Property
GH_Item Class See Also Send Feedback
Returns the internal data of this item cast to a Byte array. If the data is not stored as a Byte array, a conversion exception might be thrown.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public double[] _doublearray { get; }
Visual Basic
Public ReadOnly Property _doublearray As Double()
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Types.GH_Item._doublearray"]

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.

See Also

GH_Item Class
GH_IO.Types Namespace


_drawing_bitmap Property

[image]

Grasshopper SDK
GH_Item..::.._drawing_bitmap Property
GH_Item Class See Also Send Feedback
Returns the internal data of this item cast to a Bitmap. If the data is not stored as a Bitmap, a conversion exception might be thrown.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public Bitmap _drawing_bitmap { get; }
Visual Basic
Public ReadOnly Property _drawing_bitmap As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Types.GH_Item._drawing_bitmap"]

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.

See Also

GH_Item Class
GH_IO.Types Namespace


_drawing_color Property

[image]

Grasshopper SDK
GH_Item..::.._drawing_color Property
GH_Item Class See Also Send Feedback
Returns the internal data of this item cast to a Color. If the data is not stored as a Color, a conversion exception might be thrown.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public Color _drawing_color { get; }
Visual Basic
Public ReadOnly Property _drawing_color As Color
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Types.GH_Item._drawing_color"]

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.

See Also

GH_Item Class
GH_IO.Types Namespace


_drawing_point Property

[image]

Grasshopper SDK
GH_Item..::.._drawing_point Property
GH_Item Class See Also Send Feedback
Returns the internal data of this item cast to a Point. If the data is not stored as a Point, a conversion exception might be thrown.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public Point _drawing_point { get; }
Visual Basic
Public ReadOnly Property _drawing_point As Point
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Types.GH_Item._drawing_point"]

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.

See Also

GH_Item Class
GH_IO.Types Namespace


_drawing_pointf Property

[image]

Grasshopper SDK
GH_Item..::.._drawing_pointf Property
GH_Item Class See Also Send Feedback
Returns the internal data of this item cast to a PointF. If the data is not stored as a PointF, a conversion exception might be thrown.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public PointF _drawing_pointf { get; }
Visual Basic
Public ReadOnly Property _drawing_pointf As PointF
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Types.GH_Item._drawing_pointf"]

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.

See Also

GH_Item Class
GH_IO.Types Namespace


_drawing_rectangle Property

[image]

Grasshopper SDK
GH_Item..::.._drawing_rectangle Property
GH_Item Class See Also Send Feedback
Returns the internal data of this item cast to a Rectangle. If the data is not stored as a Rectangle, a conversion exception might be thrown.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public Rectangle _drawing_rectangle { get; }
Visual Basic
Public ReadOnly Property _drawing_rectangle As Rectangle
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Types.GH_Item._drawing_rectangle"]

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.

See Also

GH_Item Class
GH_IO.Types Namespace


_drawing_rectanglef Property

[image]

Grasshopper SDK
GH_Item..::.._drawing_rectanglef Property
GH_Item Class See Also Send Feedback
Returns the internal data of this item cast to a RectangleF. If the data is not stored as a RectangleF, a conversion exception might be thrown.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public RectangleF _drawing_rectanglef { get; }
Visual Basic
Public ReadOnly Property _drawing_rectanglef As RectangleF
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Types.GH_Item._drawing_rectanglef"]

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.

See Also

GH_Item Class
GH_IO.Types Namespace


_drawing_size Property

[image]

Grasshopper SDK
GH_Item..::.._drawing_size Property
GH_Item Class See Also Send Feedback
Returns the internal data of this item cast to a Size. If the data is not stored as a Size, a conversion exception might be thrown.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public Size _drawing_size { get; }
Visual Basic
Public ReadOnly Property _drawing_size As Size
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Types.GH_Item._drawing_size"]

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.

See Also

GH_Item Class
GH_IO.Types Namespace


_drawing_sizef Property

[image]

Grasshopper SDK
GH_Item..::.._drawing_sizef Property
GH_Item Class See Also Send Feedback
Returns the internal data of this item cast to a SizeF. If the data is not stored as a SizeF, a conversion exception might be thrown.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public SizeF _drawing_sizef { get; }
Visual Basic
Public ReadOnly Property _drawing_sizef As SizeF
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Types.GH_Item._drawing_sizef"]

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.

See Also

GH_Item Class
GH_IO.Types Namespace


_guid Property

[image]

Grasshopper SDK
GH_Item..::.._guid Property
GH_Item Class See Also Send Feedback
Returns the internal data of this item cast to a Guid. If the data is not stored as a Guid, a conversion exception might be thrown.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public Guid _guid { get; }
Visual Basic
Public ReadOnly Property _guid As Guid
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Types.GH_Item._guid"]

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.

See Also

GH_Item Class
GH_IO.Types Namespace


_int32 Property

[image]

Grasshopper SDK
GH_Item..::.._int32 Property
GH_Item Class See Also Send Feedback
Returns the internal data of this item cast to an Int32. If the data is not stored as an Int32, a conversion exception might be thrown.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public int _int32 { get; }
Visual Basic
Public ReadOnly Property _int32 As Integer
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Types.GH_Item._int32"]

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.

See Also

GH_Item Class
GH_IO.Types Namespace


_int64 Property

[image]

Grasshopper SDK
GH_Item..::.._int64 Property
GH_Item Class See Also Send Feedback
Returns the internal data of this item cast to an Int64. If the data is not stored as an Int64, a conversion exception might be thrown.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public long _int64 { get; }
Visual Basic
Public ReadOnly Property _int64 As Long
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Types.GH_Item._int64"]

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.

See Also

GH_Item Class
GH_IO.Types Namespace


_interval1d Property

[image]

Grasshopper SDK
GH_Item..::.._interval1d Property
GH_Item Class See Also Send Feedback
Returns the internal data of this item cast to an Interval1D. If the data is not stored as an Interval1D, a conversion exception might be thrown.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Interval1D _interval1d { get; }
Visual Basic
Public ReadOnly Property _interval1d As GH_Interval1D
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Types.GH_Item._interval1d"]

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.

See Also

GH_Item Class
GH_IO.Types Namespace


_interval2d Property

[image]

Grasshopper SDK
GH_Item..::.._interval2d Property
GH_Item Class See Also Send Feedback
Returns the internal data of this item cast to an Interval2D. If the data is not stored as an Interval2D, a conversion exception might be thrown.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Interval2D _interval2d { get; }
Visual Basic
Public ReadOnly Property _interval2d As GH_Interval2D
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Types.GH_Item._interval2d"]

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.

See Also

GH_Item Class
GH_IO.Types Namespace


_line Property

[image]

Grasshopper SDK
GH_Item..::.._line Property
GH_Item Class See Also Send Feedback
Returns the internal data of this item cast to a Line. If the data is not stored as a Line, a conversion exception might be thrown.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Line _line { get; }
Visual Basic
Public ReadOnly Property _line As GH_Line
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Types.GH_Item._line"]

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.

See Also

GH_Item Class
GH_IO.Types Namespace


_plane Property

[image]

Grasshopper SDK
GH_Item..::.._plane Property
GH_Item Class See Also Send Feedback
Returns the internal data of this item cast to a Plane. If the data is not stored as a Plane, a conversion exception might be thrown.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Plane _plane { get; }
Visual Basic
Public ReadOnly Property _plane As GH_Plane
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Types.GH_Item._plane"]

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.

See Also

GH_Item Class
GH_IO.Types Namespace


_point2d Property

[image]

Grasshopper SDK
GH_Item..::.._point2d Property
GH_Item Class See Also Send Feedback
Returns the internal data of this item cast to a Point2D. If the data is not stored as a Point2D, a conversion exception might be thrown.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Point2D _point2d { get; }
Visual Basic
Public ReadOnly Property _point2d As GH_Point2D
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Types.GH_Item._point2d"]

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.

See Also

GH_Item Class
GH_IO.Types Namespace


_point3d Property

[image]

Grasshopper SDK
GH_Item..::.._point3d Property
GH_Item Class See Also Send Feedback
Returns the internal data of this item cast to a Point3D. If the data is not stored as a Point3D, a conversion exception might be thrown.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Point3D _point3d { get; }
Visual Basic
Public ReadOnly Property _point3d As GH_Point3D
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Types.GH_Item._point3d"]

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.

See Also

GH_Item Class
GH_IO.Types Namespace


_point4d Property

[image]

Grasshopper SDK
GH_Item..::.._point4d Property
GH_Item Class See Also Send Feedback
Returns the internal data of this item cast to a Point4D. If the data is not stored as a Point4D, a conversion exception might be thrown.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Point4D _point4d { get; }
Visual Basic
Public ReadOnly Property _point4d As GH_Point4D
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Types.GH_Item._point4d"]

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.

See Also

GH_Item Class
GH_IO.Types Namespace


_single Property

[image]

Grasshopper SDK
GH_Item..::.._single Property
GH_Item Class See Also Send Feedback
Returns the internal data of this item cast to a Single. If the data is not stored as a Single, a conversion exception might be thrown.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public float _single { get; }
Visual Basic
Public ReadOnly Property _single As Single
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Types.GH_Item._single"]

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.

See Also

GH_Item Class
GH_IO.Types Namespace


_string Property

[image]

Grasshopper SDK
GH_Item..::.._string Property
GH_Item Class See Also Send Feedback
Returns the internal data of this item cast to a String. If the data is not stored as a String, a conversion exception might be thrown.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public string _string { get; }
Visual Basic
Public ReadOnly Property _string As String
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Types.GH_Item._string"]

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.

See Also

GH_Item Class
GH_IO.Types Namespace


_version Property

[image]

Grasshopper SDK
GH_Item..::.._version Property
GH_Item Class See Also Send Feedback
Returns the internal data of this item cast to a Version. If the data is not stored as a Version, a conversion exception might be thrown.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Version _version { get; }
Visual Basic
Public ReadOnly Property _version As GH_Version
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Types.GH_Item._version"]

Exceptions

Exception | Condition
System..::..OverflowException | Thrown if the type conversion fails.
System..::..InvalidCastException | Thrown if the type conversion is invalid.

See Also

GH_Item Class
GH_IO.Types Namespace


HasIndex Property

[image]

Grasshopper SDK
GH_Item..::..HasIndex Property
GH_Item Class See Also Send Feedback
Gets the index existence implication. The item is considered to have an index qualifier if the index value is larger than or equal to zero.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool HasIndex { get; }
Visual Basic
Public ReadOnly Property HasIndex As Boolean
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Types.GH_Item.HasIndex"]

See Also

GH_Item Class
GH_IO.Types Namespace


HasName Property

[image]

Grasshopper SDK
GH_Item..::..HasName Property
GH_Item Class See Also Send Feedback
Gets the name validity of this item. The item is considered to have an invalid name if string.IsNullOrEmpty(name)

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool HasName { get; }
Visual Basic
Public ReadOnly Property HasName As Boolean
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Types.GH_Item.HasName"]

See Also

GH_Item Class
GH_IO.Types Namespace


HasType Property

[image]

Grasshopper SDK
GH_Item..::..HasType Property
GH_Item Class See Also Send Feedback
Gets the type set validity of this item. The item is considered to have a type if type != GH_Types.unset

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public bool HasType { get; }
Visual Basic
Public ReadOnly Property HasType As Boolean
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Types.GH_Item.HasType"]

See Also

GH_Item Class
GH_IO.Types Namespace


Index Property

[image]

Grasshopper SDK
GH_Item..::..Index Property
GH_Item Class See Also Send Feedback
Gets or sets the index of an item. Typically, indices are set at construction and do not change. If you change indices after construction, you could corrupt an archive.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public int Index { get; set; }
Visual Basic
Public Property Index As Integer
    Get
    Set

Field Value

Negative indices are clamped to -1.

See Also

GH_Item Class
GH_IO.Types Namespace


InternalData Property

[image]

Grasshopper SDK
GH_Item..::..InternalData Property
GH_Item Class See Also Send Feedback
Retrieves the internal data of this item. No type casting is performed.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public Object InternalData { get; }
Visual Basic
Public ReadOnly Property InternalData As Object
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Types.GH_Item.InternalData"]

See Also

GH_Item Class
GH_IO.Types Namespace


Name Property

[image]

Grasshopper SDK
GH_Item..::..Name Property
GH_Item Class See Also Send Feedback
Gets or sets the name of this item. Typically, names are set at construction and do not change. If you change names after construction, you could corrupt an archive.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:GH_IO.Types.GH_Item.Name"]

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if the new name is null or empty.

See Also

GH_Item Class
GH_IO.Types Namespace


Type Property

[image]

Grasshopper SDK
GH_Item..::..Type Property
GH_Item Class See Also Send Feedback
Gets the type of this item. Type flags are set during construction and cannot be altered.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Types Type { get; }
Visual Basic
Public ReadOnly Property Type As GH_Types
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.Types.GH_Item.Type"]

See Also

GH_Item Class
GH_IO.Types Namespace


GH_Line Structure

[image]

Grasshopper SDK
GH_Line Structure
Members See Also Send Feedback
Represents a 3D line segment, denoted by start and endpoints.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public struct GH_Line
Visual Basic
Public Structure GH_Line

See Also

GH_Line Members
GH_IO.Types Namespace


GH_Line Members

[image] [image]

Grasshopper SDK
GH_Line Members
GH_Line Structure Constructors Methods Fields See Also Send Feedback

The GH_Line type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Line(GH_Point3D, GH_Point3D) | Constructor.
Public method | GH_Line(Double, Double, Double, Double, Double, Double) | Constructor.

Methods

 | Name | Description
Public method | ToString | Converts this structure to a human-readable string. (Overrides ValueType..::..ToString()()()().)

Fields

 | Name | Description
Public field | A | Start of line.
Public field | B | End of line.

See Also

GH_Line Structure
GH_IO.Types Namespace


GH_Line Constructor

[image] [image]

Grasshopper SDK
GH_Line Constructor
GH_Line Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Line(GH_Point3D, GH_Point3D) | Constructor.
Public method | GH_Line(Double, Double, Double, Double, Double, Double) | Constructor.

See Also

GH_Line Structure
GH_Line Members
GH_IO.Types Namespace


GH_Line Constructor (GH_Point3D, GH_Point3D)

[image]

Grasshopper SDK
GH_Line Constructor (GH_Point3D, GH_Point3D)
GH_Line Structure See Also Send Feedback
Constructor.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Line(
    GH_Point3D nA,
    GH_Point3D nB
)
Visual Basic
Public Sub New ( _
    nA As GH_Point3D, _
    nB As GH_Point3D _
)

Parameters

nA
Type: GH_IO.Types..::..GH_Point3D
Start of line.
nB
Type: GH_IO.Types..::..GH_Point3D
End of line.

See Also

GH_Line Structure
GH_Line Overload
GH_IO.Types Namespace


GH_Line Constructor (Double, Double, Double, Double, Double, Double)

[image]

Grasshopper SDK
GH_Line Constructor (Double, Double, Double, Double, Double, Double)
GH_Line Structure See Also Send Feedback
Constructor.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Line(
    double Ax,
    double Ay,
    double Az,
    double Bx,
    double By,
    double Bz
)
Visual Basic
Public Sub New ( _
    Ax As Double, _
    Ay As Double, _
    Az As Double, _
    Bx As Double, _
    By As Double, _
    Bz As Double _
)

Parameters

Ax
Type: System..::..Double
X coordinate of start point.
Ay
Type: System..::..Double
Y coordinate of start point.
Az
Type: System..::..Double
Z coordinate of start point.
Bx
Type: System..::..Double
X coordinate of end point.
By
Type: System..::..Double
Y coordinate of end point.
Bz
Type: System..::..Double
Z coordinate of end point.

See Also

GH_Line Structure
GH_Line Overload
GH_IO.Types Namespace


GH_Line Fields

[image] [image]

Grasshopper SDK
GH_Line Fields
GH_Line Structure See Also Send Feedback

The GH_Line type exposes the following members.

Fields

 | Name | Description
Public field | A | Start of line.
Public field | B | End of line.

See Also

GH_Line Structure
GH_IO.Types Namespace


A Field

[image]

Grasshopper SDK
GH_Line..::..A Field
GH_Line Structure See Also Send Feedback
Start of line.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Point3D A
Visual Basic
Public A As GH_Point3D

See Also

GH_Line Structure
GH_IO.Types Namespace


B Field

[image]

Grasshopper SDK
GH_Line..::..B Field
GH_Line Structure See Also Send Feedback
End of line.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Point3D B
Visual Basic
Public B As GH_Point3D

See Also

GH_Line Structure
GH_IO.Types Namespace


GH_Line Methods

[image] [image]

Grasshopper SDK
GH_Line Methods
GH_Line Structure See Also Send Feedback

The GH_Line type exposes the following members.

Methods

 | Name | Description
Public method | ToString | Converts this structure to a human-readable string. (Overrides ValueType..::..ToString()()()().)

See Also

GH_Line Structure
GH_IO.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_Line..::..ToString Method
GH_Line Structure See Also Send Feedback
Converts this structure to a human-readable string.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A string representation of the line structure.

See Also

GH_Line Structure
GH_IO.Types Namespace


GH_Plane Structure

[image]

Grasshopper SDK
GH_Plane Structure
Members See Also Send Feedback
Represents a 3D plane system, defined by origin point and {X,Y} axis directions.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public struct GH_Plane
Visual Basic
Public Structure GH_Plane

See Also

GH_Plane Members
GH_IO.Types Namespace


GH_Plane Members

[image] [image]

Grasshopper SDK
GH_Plane Members
GH_Plane Structure Constructors Methods Fields See Also Send Feedback

The GH_Plane type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Plane(GH_Point3D, GH_Point3D, GH_Point3D) | Constructor.
Public method | GH_Plane(Double, Double, Double, Double, Double, Double, Double, Double, Double) | Constructor.

Methods

 | Name | Description
Public method | ToString | Converts this structure to a human-readable string. (Overrides ValueType..::..ToString()()()().)

Fields

 | Name | Description
Public field | Origin | Origin point of plane.
Public field | XAxis | X axis vector of plane.
Public field | YAxis | Y axis vector of plane.

See Also

GH_Plane Structure
GH_IO.Types Namespace


GH_Plane Constructor

[image] [image]

Grasshopper SDK
GH_Plane Constructor
GH_Plane Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Plane(GH_Point3D, GH_Point3D, GH_Point3D) | Constructor.
Public method | GH_Plane(Double, Double, Double, Double, Double, Double, Double, Double, Double) | Constructor.

See Also

GH_Plane Structure
GH_Plane Members
GH_IO.Types Namespace


GH_Plane Constructor (GH_Point3D, GH_Point3D, GH_Point3D)

[image]

Grasshopper SDK
GH_Plane Constructor (GH_Point3D, GH_Point3D, GH_Point3D)
GH_Plane Structure See Also Send Feedback
Constructor.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Plane(
    GH_Point3D nOrigin,
    GH_Point3D nXAxis,
    GH_Point3D nYAxis
)
Visual Basic
Public Sub New ( _
    nOrigin As GH_Point3D, _
    nXAxis As GH_Point3D, _
    nYAxis As GH_Point3D _
)

Parameters

nOrigin
Type: GH_IO.Types..::..GH_Point3D
Origin of plane.
nXAxis
Type: GH_IO.Types..::..GH_Point3D
X axis of plane.
nYAxis
Type: GH_IO.Types..::..GH_Point3D
Y axis of plane.

See Also

GH_Plane Structure
GH_Plane Overload
GH_IO.Types Namespace


GH_Plane Constructor (Double, Double, Double, Double, Double, Double, Double, Double, Double)

[image]

Grasshopper SDK
GH_Plane Constructor (Double, Double, Double, Double, Double, Double, Double, Double, Double)
GH_Plane Structure See Also Send Feedback
Constructor.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Plane(
    double Ox,
    double Oy,
    double Oz,
    double Xx,
    double Xy,
    double Xz,
    double Yx,
    double Yy,
    double Yz
)
Visual Basic
Public Sub New ( _
    Ox As Double, _
    Oy As Double, _
    Oz As Double, _
    Xx As Double, _
    Xy As Double, _
    Xz As Double, _
    Yx As Double, _
    Yy As Double, _
    Yz As Double _
)

Parameters

Ox
Type: System..::..Double
X coordinate of plane origin.
Oy
Type: System..::..Double
Y coordinate of plane origin.
Oz
Type: System..::..Double
Z coordinate of plane origin.
Xx
Type: System..::..Double
X component of plane x axis.
Xy
Type: System..::..Double
Y component of plane x axis.
Xz
Type: System..::..Double
Z component of plane x axis.
Yx
Type: System..::..Double
X component of plane y axis.
Yy
Type: System..::..Double
Y component of plane y axis.
Yz
Type: System..::..Double
Z component of plane y axis.

See Also

GH_Plane Structure
GH_Plane Overload
GH_IO.Types Namespace


GH_Plane Fields

[image] [image]

Grasshopper SDK
GH_Plane Fields
GH_Plane Structure See Also Send Feedback

The GH_Plane type exposes the following members.

Fields

 | Name | Description
Public field | Origin | Origin point of plane.
Public field | XAxis | X axis vector of plane.
Public field | YAxis | Y axis vector of plane.

See Also

GH_Plane Structure
GH_IO.Types Namespace


Origin Field

[image]

Grasshopper SDK
GH_Plane..::..Origin Field
GH_Plane Structure See Also Send Feedback
Origin point of plane.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Point3D Origin
Visual Basic
Public Origin As GH_Point3D

See Also

GH_Plane Structure
GH_IO.Types Namespace


XAxis Field

[image]

Grasshopper SDK
GH_Plane..::..XAxis Field
GH_Plane Structure See Also Send Feedback
X axis vector of plane.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Point3D XAxis
Visual Basic
Public XAxis As GH_Point3D

See Also

GH_Plane Structure
GH_IO.Types Namespace


YAxis Field

[image]

Grasshopper SDK
GH_Plane..::..YAxis Field
GH_Plane Structure See Also Send Feedback
Y axis vector of plane.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Point3D YAxis
Visual Basic
Public YAxis As GH_Point3D

See Also

GH_Plane Structure
GH_IO.Types Namespace


GH_Plane Methods

[image] [image]

Grasshopper SDK
GH_Plane Methods
GH_Plane Structure See Also Send Feedback

The GH_Plane type exposes the following members.

Methods

 | Name | Description
Public method | ToString | Converts this structure to a human-readable string. (Overrides ValueType..::..ToString()()()().)

See Also

GH_Plane Structure
GH_IO.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_Plane..::..ToString Method
GH_Plane Structure See Also Send Feedback
Converts this structure to a human-readable string.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A string representation of the plane structure.

See Also

GH_Plane Structure
GH_IO.Types Namespace


GH_Point2D Structure

[image]

Grasshopper SDK
GH_Point2D Structure
Members See Also Send Feedback
Represents a 2D point coordinate with double precision floating point components.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public struct GH_Point2D
Visual Basic
Public Structure GH_Point2D

See Also

GH_Point2D Members
GH_IO.Types Namespace


GH_Point2D Members

[image] [image]

Grasshopper SDK
GH_Point2D Members
GH_Point2D Structure Constructors Methods Fields See Also Send Feedback

The GH_Point2D type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Point2D | Constructor.

Methods

 | Name | Description
Public method | ToString | Converts this structure to a human-readable string. (Overrides ValueType..::..ToString()()()().)

Fields

 | Name | Description
Public field | x | X coordinate of point.
Public field | y | Y coordinate of point.

See Also

GH_Point2D Structure
GH_IO.Types Namespace


GH_Point2D Constructor

[image]

Grasshopper SDK
GH_Point2D Constructor
GH_Point2D Structure See Also Send Feedback
Constructor.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Point2D(
    double nx,
    double ny
)
Visual Basic
Public Sub New ( _
    nx As Double, _
    ny As Double _
)

Parameters

nx
Type: System..::..Double
X coordinate of point.
ny
Type: System..::..Double
Y coordinate of point.

See Also

GH_Point2D Structure
GH_IO.Types Namespace


GH_Point2D Fields

[image] [image]

Grasshopper SDK
GH_Point2D Fields
GH_Point2D Structure See Also Send Feedback

The GH_Point2D type exposes the following members.

Fields

 | Name | Description
Public field | x | X coordinate of point.
Public field | y | Y coordinate of point.

See Also

GH_Point2D Structure
GH_IO.Types Namespace


x Field

[image]

Grasshopper SDK
GH_Point2D..::..x Field
GH_Point2D Structure See Also Send Feedback
X coordinate of point.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public double x
Visual Basic
Public x As Double

See Also

GH_Point2D Structure
GH_IO.Types Namespace


y Field

[image]

Grasshopper SDK
GH_Point2D..::..y Field
GH_Point2D Structure See Also Send Feedback
Y coordinate of point.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public double y
Visual Basic
Public y As Double

See Also

GH_Point2D Structure
GH_IO.Types Namespace


GH_Point2D Methods

[image] [image]

Grasshopper SDK
GH_Point2D Methods
GH_Point2D Structure See Also Send Feedback

The GH_Point2D type exposes the following members.

Methods

 | Name | Description
Public method | ToString | Converts this structure to a human-readable string. (Overrides ValueType..::..ToString()()()().)

See Also

GH_Point2D Structure
GH_IO.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_Point2D..::..ToString Method
GH_Point2D Structure See Also Send Feedback
Converts this structure to a human-readable string.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A string representation of the two-dimenionsional point structure.

See Also

GH_Point2D Structure
GH_IO.Types Namespace


GH_Point3D Structure

[image]

Grasshopper SDK
GH_Point3D Structure
Members See Also Send Feedback
Represents a 3D point coordinate with double precision floating point components.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public struct GH_Point3D
Visual Basic
Public Structure GH_Point3D

See Also

GH_Point3D Members
GH_IO.Types Namespace


GH_Point3D Members

[image] [image]

Grasshopper SDK
GH_Point3D Members
GH_Point3D Structure Constructors Methods Fields See Also Send Feedback

The GH_Point3D type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Point3D | Constructor.

Methods

 | Name | Description
Public method | ToString | Converts this structure to a human-readable string. (Overrides ValueType..::..ToString()()()().)

Fields

 | Name | Description
Public field | x | X coordinate of point.
Public field | y | Y coordinate of point.
Public field | z | Z coordinate of point.

See Also

GH_Point3D Structure
GH_IO.Types Namespace


GH_Point3D Constructor

[image]

Grasshopper SDK
GH_Point3D Constructor
GH_Point3D Structure See Also Send Feedback
Constructor.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Point3D(
    double nx,
    double ny,
    double nz
)
Visual Basic
Public Sub New ( _
    nx As Double, _
    ny As Double, _
    nz As Double _
)

Parameters

nx
Type: System..::..Double
X coordinate of point.
ny
Type: System..::..Double
Y coordinate of point.
nz
Type: System..::..Double
Z coordinate of point.

See Also

GH_Point3D Structure
GH_IO.Types Namespace


GH_Point3D Fields

[image] [image]

Grasshopper SDK
GH_Point3D Fields
GH_Point3D Structure See Also Send Feedback

The GH_Point3D type exposes the following members.

Fields

 | Name | Description
Public field | x | X coordinate of point.
Public field | y | Y coordinate of point.
Public field | z | Z coordinate of point.

See Also

GH_Point3D Structure
GH_IO.Types Namespace


x Field

[image]

Grasshopper SDK
GH_Point3D..::..x Field
GH_Point3D Structure See Also Send Feedback
X coordinate of point.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public double x
Visual Basic
Public x As Double

See Also

GH_Point3D Structure
GH_IO.Types Namespace


y Field

[image]

Grasshopper SDK
GH_Point3D..::..y Field
GH_Point3D Structure See Also Send Feedback
Y coordinate of point.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public double y
Visual Basic
Public y As Double

See Also

GH_Point3D Structure
GH_IO.Types Namespace


z Field

[image]

Grasshopper SDK
GH_Point3D..::..z Field
GH_Point3D Structure See Also Send Feedback
Z coordinate of point.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public double z
Visual Basic
Public z As Double

See Also

GH_Point3D Structure
GH_IO.Types Namespace


GH_Point3D Methods

[image] [image]

Grasshopper SDK
GH_Point3D Methods
GH_Point3D Structure See Also Send Feedback

The GH_Point3D type exposes the following members.

Methods

 | Name | Description
Public method | ToString | Converts this structure to a human-readable string. (Overrides ValueType..::..ToString()()()().)

See Also

GH_Point3D Structure
GH_IO.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_Point3D..::..ToString Method
GH_Point3D Structure See Also Send Feedback
Converts this structure to a human-readable string.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A string representation of the three-dimenionsional point structure.

See Also

GH_Point3D Structure
GH_IO.Types Namespace


GH_Point4D Structure

[image]

Grasshopper SDK
GH_Point4D Structure
Members See Also Send Feedback
Represents a 4D point coordinate with double precision floating point components.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public struct GH_Point4D
Visual Basic
Public Structure GH_Point4D

See Also

GH_Point4D Members
GH_IO.Types Namespace


GH_Point4D Members

[image] [image]

Grasshopper SDK
GH_Point4D Members
GH_Point4D Structure Constructors Methods Fields See Also Send Feedback

The GH_Point4D type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Point4D | Constructor.

Methods

 | Name | Description
Public method | ToString | Converts this structure to a human-readable string. (Overrides ValueType..::..ToString()()()().)

Fields

 | Name | Description
Public field | w | W coordinate of point.
Public field | x | X coordinate of point.
Public field | y | Y coordinate of point.
Public field | z | Z coordinate of point.

See Also

GH_Point4D Structure
GH_IO.Types Namespace


GH_Point4D Constructor

[image]

Grasshopper SDK
GH_Point4D Constructor
GH_Point4D Structure See Also Send Feedback
Constructor.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Point4D(
    double nx,
    double ny,
    double nz,
    double nw
)
Visual Basic
Public Sub New ( _
    nx As Double, _
    ny As Double, _
    nz As Double, _
    nw As Double _
)

Parameters

nx
Type: System..::..Double
X coordinate of point.
ny
Type: System..::..Double
Y coordinate of point.
nz
Type: System..::..Double
Z coordinate of point.
nw
Type: System..::..Double
W coordinate of point.

See Also

GH_Point4D Structure
GH_IO.Types Namespace


GH_Point4D Fields

[image] [image]

Grasshopper SDK
GH_Point4D Fields
GH_Point4D Structure See Also Send Feedback

The GH_Point4D type exposes the following members.

Fields

 | Name | Description
Public field | w | W coordinate of point.
Public field | x | X coordinate of point.
Public field | y | Y coordinate of point.
Public field | z | Z coordinate of point.

See Also

GH_Point4D Structure
GH_IO.Types Namespace


w Field

[image]

Grasshopper SDK
GH_Point4D..::..w Field
GH_Point4D Structure See Also Send Feedback
W coordinate of point.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public double w
Visual Basic
Public w As Double

See Also

GH_Point4D Structure
GH_IO.Types Namespace


x Field

[image]

Grasshopper SDK
GH_Point4D..::..x Field
GH_Point4D Structure See Also Send Feedback
X coordinate of point.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public double x
Visual Basic
Public x As Double

See Also

GH_Point4D Structure
GH_IO.Types Namespace


y Field

[image]

Grasshopper SDK
GH_Point4D..::..y Field
GH_Point4D Structure See Also Send Feedback
Y coordinate of point.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public double y
Visual Basic
Public y As Double

See Also

GH_Point4D Structure
GH_IO.Types Namespace


z Field

[image]

Grasshopper SDK
GH_Point4D..::..z Field
GH_Point4D Structure See Also Send Feedback
Z coordinate of point.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public double z
Visual Basic
Public z As Double

See Also

GH_Point4D Structure
GH_IO.Types Namespace


GH_Point4D Methods

[image] [image]

Grasshopper SDK
GH_Point4D Methods
GH_Point4D Structure See Also Send Feedback

The GH_Point4D type exposes the following members.

Methods

 | Name | Description
Public method | ToString | Converts this structure to a human-readable string. (Overrides ValueType..::..ToString()()()().)

See Also

GH_Point4D Structure
GH_IO.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_Point4D..::..ToString Method
GH_Point4D Structure See Also Send Feedback
Converts this structure to a human-readable string.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A string representation of the four-dimenionsional point structure.

See Also

GH_Point4D Structure
GH_IO.Types Namespace


GH_Types Enumeration

[image]

Grasshopper SDK
GH_Types Enumeration
See Also Send Feedback
Contains flags for all data types currently supported by GH_IO.dll

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public enum GH_Types
Visual Basic
Public Enumeration GH_Types

Members

Member name | Value | Description
unset | 0 | Represents an unset type. GH_Items with this type will throw exceptions during serialization.
gh_bool | 1 | boolean
gh_byte | 2 | byte
gh_int32 | 3 | 32 bit integer
gh_int64 | 4 | 64 bit integer
gh_single | 5 | single precision floating point number
gh_double | 6 | double precision floating point number
gh_decimal | 7 | decimal number
gh_date | 8 | date time structure
gh_guid | 9 | 128 bit globally unique identifier
gh_string | 10 | unicode string
gh_bytearray | 20 | an array of bytes
gh_doublearray | 21 | an array of doubles
gh_drawing_point | 30 | gdi+ integer precision point
gh_drawing_pointf | 31 | gdi+ single precision point
gh_drawing_size | 32 | gdi+ integer precision size
gh_drawing_sizef | 33 | gdi+ single precision size
gh_drawing_rectangle | 34 | gdi+ integer precision rectangle
gh_drawing_rectanglef | 35 | gdi+ single precision rectangle
gh_drawing_color | 36 | gdi+ argb color
gh_drawing_bitmap | 37 | gdi+ bitmap (png format bytestream)
gh_point2d | 50 | double precision two-dimensional point
gh_point3d | 51 | double precision three-dimensional point
gh_point4d | 52 | double precision four-dimensional point
gh_interval1d | 60 | double precision one-dimensional numeric interval
gh_interval2d | 61 | double precision two-dimensional numeric interval
gh_line | 70 | double precision three-dimensional line segment
gh_boundingbox | 71 | double precision three-dimensional box volume
gh_plane | 72 | double precision three-dimensional plane construct
gh_version | 80 | version structure with major, minor and revision fields

See Also

GH_IO.Types Namespace


GH_Version Structure

[image]

Grasshopper SDK
GH_Version Structure
Members See Also Send Feedback
Basic version type. Contains Major, Minor and Revision fields.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public struct GH_Version
Visual Basic
Public Structure GH_Version

See Also

GH_Version Members
GH_IO.Types Namespace


GH_Version Members

[image] [image]

Grasshopper SDK
GH_Version Members
GH_Version Structure Constructors Methods Operators Fields See Also Send Feedback

The GH_Version type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Version(GH_Version) | Copy constructor. Duplicate an existing version structure.
Public method | GH_Version(Int32, Int32, Int32) | Default constructor. Create a new version from specified fields.

Methods

 | Name | Description
Public method | Equals | Performs value equality comparison. (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueType..::..GetHashCode()()()().)
Public method | ToString | Default formatter for Version data: M.m.RRRR Revision section is padded with zeroes until it is at least 4 digits long. (Overrides ValueType..::..ToString()()()().)

Operators

Name | Description
Equality | Compares two version structures for equality.
GreaterThan | Compares versions for larger than relationships.
GreaterThanOrEqual | Compares versions for larger than or equal to relationships.
Inequality | Compares two version structures for inequality.
LessThan | Compares versions for smaller than relationships.
LessThanOrEqual | Compares versions for smaller than or equal to relationships.

Fields

 | Name | Description
Public field | major | Major component of version structure.
Public field | minor | Minor component of version structure.
Public field | revision | Revision component of version structure.

See Also

GH_Version Structure
GH_IO.Types Namespace


GH_Version Constructor

[image] [image]

Grasshopper SDK
GH_Version Constructor
GH_Version Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Version(GH_Version) | Copy constructor. Duplicate an existing version structure.
Public method | GH_Version(Int32, Int32, Int32) | Default constructor. Create a new version from specified fields.

See Also

GH_Version Structure
GH_Version Members
GH_IO.Types Namespace


GH_Version Constructor (GH_Version)

[image]

Grasshopper SDK
GH_Version Constructor (GH_Version)
GH_Version Structure See Also Send Feedback
Copy constructor. Duplicate an existing version structure.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Version(
    GH_Version other
)
Visual Basic
Public Sub New ( _
    other As GH_Version _
)

Parameters

other
Type: GH_IO.Types..::..GH_Version
Version to duplicate.

See Also

GH_Version Structure
GH_Version Overload
GH_IO.Types Namespace


GH_Version Constructor (Int32, Int32, Int32)

[image]

Grasshopper SDK
GH_Version Constructor (Int32, Int32, Int32)
GH_Version Structure See Also Send Feedback
Default constructor. Create a new version from specified fields.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_Version(
    int v_major,
    int v_minor,
    int v_revision
)
Visual Basic
Public Sub New ( _
    v_major As Integer, _
    v_minor As Integer, _
    v_revision As Integer _
)

Parameters

v_major
Type: System..::..Int32
Major component of version.
v_minor
Type: System..::..Int32
Minor component of version.
v_revision
Type: System..::..Int32
Revision component of version.

See Also

GH_Version Structure
GH_Version Overload
GH_IO.Types Namespace


GH_Version Fields

[image] [image]

Grasshopper SDK
GH_Version Fields
GH_Version Structure See Also Send Feedback

The GH_Version type exposes the following members.

Fields

 | Name | Description
Public field | major | Major component of version structure.
Public field | minor | Minor component of version structure.
Public field | revision | Revision component of version structure.

See Also

GH_Version Structure
GH_IO.Types Namespace


major Field

[image]

Grasshopper SDK
GH_Version..::..major Field
GH_Version Structure See Also Send Feedback
Major component of version structure.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public int major
Visual Basic
Public major As Integer

See Also

GH_Version Structure
GH_IO.Types Namespace


minor Field

[image]

Grasshopper SDK
GH_Version..::..minor Field
GH_Version Structure See Also Send Feedback
Minor component of version structure.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public int minor
Visual Basic
Public minor As Integer

See Also

GH_Version Structure
GH_IO.Types Namespace


revision Field

[image]

Grasshopper SDK
GH_Version..::..revision Field
GH_Version Structure See Also Send Feedback
Revision component of version structure.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public int revision
Visual Basic
Public revision As Integer

See Also

GH_Version Structure
GH_IO.Types Namespace


GH_Version Methods

[image] [image]

Grasshopper SDK
GH_Version Methods
GH_Version Structure See Also Send Feedback

The GH_Version type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Performs value equality comparison. (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueType..::..GetHashCode()()()().)
Public method | ToString | Default formatter for Version data: M.m.RRRR Revision section is padded with zeroes until it is at least 4 digits long. (Overrides ValueType..::..ToString()()()().)

See Also

GH_Version Structure
GH_IO.Types Namespace


Equals Method

[image]

Grasshopper SDK
GH_Version..::..Equals Method
GH_Version Structure See Also Send Feedback
Performs value equality comparison.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
Object to compare with. If obj is a null reference or not a GH_Version instance, false is returned.

Return Value

True if obj is a GH_Version instance which is equal to this one.

See Also

GH_Version Structure
GH_IO.Types Namespace


GetHashCode Method

[image]

Grasshopper SDK
GH_Version..::..GetHashCode Method
GH_Version Structure See Also Send Feedback
Returns the hash code for this instance.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current version object.

See Also

GH_Version Structure
GH_IO.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_Version..::..ToString Method
GH_Version Structure See Also Send Feedback
Default formatter for Version data: M.m.RRRR Revision section is padded with zeroes until it is at least 4 digits long.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A string represtation of the Version structure.

See Also

GH_Version Structure
GH_IO.Types Namespace


GH_Version Operators

[image] [image]

Grasshopper SDK
GH_Version Operators
GH_Version Structure See Also Send Feedback

The GH_Version type exposes the following members.

Operators

Name | Description
Equality | Compares two version structures for equality.
GreaterThan | Compares versions for larger than relationships.
GreaterThanOrEqual | Compares versions for larger than or equal to relationships.
Inequality | Compares two version structures for inequality.
LessThan | Compares versions for smaller than relationships.
LessThanOrEqual | Compares versions for smaller than or equal to relationships.

See Also

GH_Version Structure
GH_IO.Types Namespace


Equality Operator

[image]

Grasshopper SDK
GH_Version..::..Equality Operator
GH_Version Structure See Also Send Feedback
Compares two version structures for equality.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public static bool operator ==(
    GH_Version A,
    GH_Version B
)
Visual Basic
Public Shared Operator = ( _
    A As GH_Version, _
    B As GH_Version _
) As Boolean

Parameters

A
Type: GH_IO.Types..::..GH_Version
Version to compare.
B
Type: GH_IO.Types..::..GH_Version
Version to compare with.

Return Value

True if all version fields in A and B are equal.

See Also

GH_Version Structure
GH_IO.Types Namespace


GreaterThan Operator

[image]

Grasshopper SDK
GH_Version..::..GreaterThan Operator
GH_Version Structure See Also Send Feedback
Compares versions for larger than relationships.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public static bool operator >(
    GH_Version A,
    GH_Version B
)
Visual Basic
Public Shared Operator > ( _
    A As GH_Version, _
    B As GH_Version _
) As Boolean

Parameters

A
Type: GH_IO.Types..::..GH_Version
Version to compare.
B
Type: GH_IO.Types..::..GH_Version
Version to compare with.

Return Value

True if A is newer than B.

See Also

GH_Version Structure
GH_IO.Types Namespace


GreaterThanOrEqual Operator

[image]

Grasshopper SDK
GH_Version..::..GreaterThanOrEqual Operator
GH_Version Structure See Also Send Feedback
Compares versions for larger than or equal to relationships.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public static bool operator >=(
    GH_Version A,
    GH_Version B
)
Visual Basic
Public Shared Operator >= ( _
    A As GH_Version, _
    B As GH_Version _
) As Boolean

Parameters

A
Type: GH_IO.Types..::..GH_Version
Version to compare.
B
Type: GH_IO.Types..::..GH_Version
Version to compare with.

Return Value

True if A is newer than or equal to B.

See Also

GH_Version Structure
GH_IO.Types Namespace


Inequality Operator

[image]

Grasshopper SDK
GH_Version..::..Inequality Operator
GH_Version Structure See Also Send Feedback
Compares two version structures for inequality.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public static bool operator !=(
    GH_Version A,
    GH_Version B
)
Visual Basic
Public Shared Operator <> ( _
    A As GH_Version, _
    B As GH_Version _
) As Boolean

Parameters

A
Type: GH_IO.Types..::..GH_Version
Version to compare.
B
Type: GH_IO.Types..::..GH_Version
Version to compare with.

Return Value

True if A is different from B.

See Also

GH_Version Structure
GH_IO.Types Namespace


LessThan Operator

[image]

Grasshopper SDK
GH_Version..::..LessThan Operator
GH_Version Structure See Also Send Feedback
Compares versions for smaller than relationships.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public static bool operator <(
    GH_Version A,
    GH_Version B
)
Visual Basic
Public Shared Operator < ( _
    A As GH_Version, _
    B As GH_Version _
) As Boolean

Parameters

A
Type: GH_IO.Types..::..GH_Version
Version to compare.
B
Type: GH_IO.Types..::..GH_Version
Version to compare with.

Return Value

True if A represents an older version than B.

See Also

GH_Version Structure
GH_IO.Types Namespace


LessThanOrEqual Operator

[image]

Grasshopper SDK
GH_Version..::..LessThanOrEqual Operator
GH_Version Structure See Also Send Feedback
Compares versions for smaller than or equal to relationships.

Namespace: GH_IO.Types
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public static bool operator <=(
    GH_Version A,
    GH_Version B
)
Visual Basic
Public Shared Operator <= ( _
    A As GH_Version, _
    B As GH_Version _
) As Boolean

Parameters

A
Type: GH_IO.Types..::..GH_Version
Version to compare.
B
Type: GH_IO.Types..::..GH_Version
Version to compare with.

Return Value

True if A is older than or equal to B.

See Also

GH_Version Structure
GH_IO.Types Namespace


GH_IO.UserInterface Namespace

[image]

Grasshopper SDK
GH_IO.UserInterface Namespace
Send Feedback
This namespace contains some utility functions for the GUI elements of the GH_IO.dll library.

Classes

 | Class | Description
Public class | GH_ArchiveMessageViewer | Viewer/Browser that displays a list of archive messages.
Public class | GH_DeveloperDetails | Constains a set of static fields and properties regarding developer contact details.


GH_ArchiveMessageViewer Class

[image]

Grasshopper SDK
GH_ArchiveMessageViewer Class
Members See Also Send Feedback
Viewer/Browser that displays a list of archive messages.

Namespace: GH_IO.UserInterface
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public class GH_ArchiveMessageViewer : Form
Visual Basic
Public Class GH_ArchiveMessageViewer _
    Inherits Form

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
GH_IO.UserInterface..::..GH_ArchiveMessageViewer

See Also

GH_ArchiveMessageViewer Members
GH_IO.UserInterface Namespace


GH_ArchiveMessageViewer Members

[image] [image]

Grasshopper SDK
GH_ArchiveMessageViewer Members
GH_ArchiveMessageViewer Class Constructors Methods See Also Send Feedback

The GH_ArchiveMessageViewer type exposes the following members.

Constructors

 | Name | Description
Public method | GH_ArchiveMessageViewer | Constructor.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides Form..::..Dispose(Boolean).)
Public method | SetArchive | Set a new archive. The messages in this archive will be displayed on the form.

See Also

GH_ArchiveMessageViewer Class
GH_IO.UserInterface Namespace


GH_ArchiveMessageViewer Constructor

[image]

Grasshopper SDK
GH_ArchiveMessageViewer Constructor
GH_ArchiveMessageViewer Class See Also Send Feedback
Constructor.

Namespace: GH_IO.UserInterface
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public GH_ArchiveMessageViewer()
Visual Basic
Public Sub New

See Also

GH_ArchiveMessageViewer Class
GH_IO.UserInterface Namespace


GH_ArchiveMessageViewer Methods

[image] [image]

Grasshopper SDK
GH_ArchiveMessageViewer Methods
GH_ArchiveMessageViewer Class See Also Send Feedback

The GH_ArchiveMessageViewer type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | Clean up any resources being used. (Overrides Form..::..Dispose(Boolean).)
Public method | SetArchive | Set a new archive. The messages in this archive will be displayed on the form.

See Also

GH_ArchiveMessageViewer Class
GH_IO.UserInterface Namespace


Dispose Method

[image]

Grasshopper SDK
GH_ArchiveMessageViewer..::..Dispose Method
GH_ArchiveMessageViewer Class See Also Send Feedback
Clean up any resources being used.

Namespace: GH_IO.UserInterface
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

GH_ArchiveMessageViewer Class
GH_IO.UserInterface Namespace


SetArchive Method

[image]

Grasshopper SDK
GH_ArchiveMessageViewer..::..SetArchive Method
GH_ArchiveMessageViewer Class See Also Send Feedback
Set a new archive. The messages in this archive will be displayed on the form.

Namespace: GH_IO.UserInterface
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public void SetArchive(
    GH_Archive nArchive
)
Visual Basic
Public Sub SetArchive ( _
    nArchive As GH_Archive _
)

Parameters

nArchive
Type: GH_IO.Serialization..::..GH_Archive

See Also

GH_ArchiveMessageViewer Class
GH_IO.UserInterface Namespace


GH_DeveloperDetails Class

[image]

Grasshopper SDK
GH_DeveloperDetails Class
Members See Also Send Feedback
Constains a set of static fields and properties regarding developer contact details.

Namespace: GH_IO.UserInterface
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public abstract class GH_DeveloperDetails
Visual Basic
Public MustInherit Class GH_DeveloperDetails

Inheritance Hierarchy

System..::..Object
GH_IO.UserInterface..::..GH_DeveloperDetails

See Also

GH_DeveloperDetails Members
GH_IO.UserInterface Namespace


GH_DeveloperDetails Members

[image] [image]

Grasshopper SDK
GH_DeveloperDetails Members
GH_DeveloperDetails Class Properties See Also Send Feedback

The GH_DeveloperDetails type exposes the following members.

Properties

Name | Description
DefaultDeveloperContact | Gets the default developer contact details.
DeveloperContact | Gets or sets the local developer contact info (e-mail). By default, the developer email is DefaultDeveloperContact; This email address is used in the Message Report viewer when sending a support e-mail.

See Also

GH_DeveloperDetails Class
GH_IO.UserInterface Namespace


GH_DeveloperDetails Properties

[image] [image]

Grasshopper SDK
GH_DeveloperDetails Properties
GH_DeveloperDetails Class See Also Send Feedback

The GH_DeveloperDetails type exposes the following members.

Properties

Name | Description
DefaultDeveloperContact | Gets the default developer contact details.
DeveloperContact | Gets or sets the local developer contact info (e-mail). By default, the developer email is DefaultDeveloperContact; This email address is used in the Message Report viewer when sending a support e-mail.

See Also

GH_DeveloperDetails Class
GH_IO.UserInterface Namespace


DefaultDeveloperContact Property

[image]

Grasshopper SDK
GH_DeveloperDetails..::..DefaultDeveloperContact Property
GH_DeveloperDetails Class See Also Send Feedback
Gets the default developer contact details.

Namespace: GH_IO.UserInterface
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public static string DefaultDeveloperContact { get; }
Visual Basic
Public Shared ReadOnly Property DefaultDeveloperContact As String
    Get

Field Value

[Missing <value> documentation for "P:GH_IO.UserInterface.GH_DeveloperDetails.DefaultDeveloperContact"]

See Also

GH_DeveloperDetails Class
GH_IO.UserInterface Namespace


DeveloperContact Property

[image]

Grasshopper SDK
GH_DeveloperDetails..::..DeveloperContact Property
GH_DeveloperDetails Class See Also Send Feedback
Gets or sets the local developer contact info (e-mail). By default, the developer email is DefaultDeveloperContact; This email address is used in the Message Report viewer when sending a support e-mail.

Namespace: GH_IO.UserInterface
Assembly: GH_IO (in GH_IO.dll) Version: 1.0.0.0 (0.9.52.0)

Syntax

C#
public static string DeveloperContact { get; set; }
Visual Basic
Public Shared Property DeveloperContact As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:GH_IO.UserInterface.GH_DeveloperDetails.DeveloperContact"]

See Also

GH_DeveloperDetails Class
GH_IO.UserInterface Namespace


Grasshopper Namespace

[image]

Grasshopper SDK
Grasshopper Namespace
Send Feedback
Top level namespace for the Grasshopper plug-in.

Classes

 | Class | Description
Public class | CentralSettings | Represents a collection of program wide settings and events for when those settings change. This should probably be the bottleneck for all program wide settings, but stuff is still littered about for now.
Public class | DataTree<(Of <(<'T>)>)> | Implements basic Grasshopper Data Tree functionality in an easy-to-use class. This class is used primarily in Scripting components. If you're using the Grasshopper SDK you should consider using the GH_Structure<(Of <(<'T>)>)> class instead.
Public class | Folders | Provides access to all standard Grasshopper file and folder locations.
Public class | Instances | Provides access to a bunch of global instances and variables.
Public class | Tracing | Class that provides useful static methods for debugging, tracing and messaging.
Public class | Utility | Class with useful static methods.
Public class | Versioning | Static class that provides information regarding the Grasshopper versioning.

Delegates

 | Delegate | Description
Public delegate | CentralSettings..::..AuthorAddressChangedEventHandler |
Public delegate | CentralSettings..::..AuthorCompanyChangedEventHandler |
Public delegate | CentralSettings..::..AuthorCopyrightChangedEventHandler |
Public delegate | CentralSettings..::..AuthorEMailChangedEventHandler |
Public delegate | CentralSettings..::..AuthorNameChangedEventHandler |
Public delegate | CentralSettings..::..AuthorPhoneChangedEventHandler |
Public delegate | CentralSettings..::..AuthorWebsiteChangedEventHandler |
Public delegate | CentralSettings..::..CanvasFancyWiresChangedEventHandler |
Public delegate | CentralSettings..::..CanvasFullNamesChangedEventHandler |
Public delegate | CentralSettings..::..CanvasObjectIconsChangedEventHandler |
Public delegate | CentralSettings..::..CanvasObsoleteTagsChangedEventHandler |
Public delegate | CentralSettings..::..CanvasRadialMenuChangedEventHandler |
Public delegate | CentralSettings..::..CanvasZuiZoomLevelChangedEventHandler |
Public delegate | CentralSettings..::..ComponentCascadeMenusChangedEventHandler |
Public delegate | CentralSettings..::..CreateSolutionUndoRecordChangedEventHandler |
Public delegate | CentralSettings..::..FormattingChangedEventHandler |
Public delegate | CentralSettings..::..LoadMechanismChangedEventHandler |
Public delegate | CentralSettings..::..LoadProtectionChangedEventHandler |
Public delegate | CentralSettings..::..PreviewBumpZBufferChangedEventHandler |
Public delegate | CentralSettings..::..PreviewMeshEdgesChangedEventHandler |
Public delegate | CentralSettings..::..PreviewPlaneRadiusChangedEventHandler |
Public delegate | CentralSettings..::..PreviewPointStyleChangedEventHandler |
Public delegate | CentralSettings..::..PruderyLevelChangedEventHandler |
Public delegate | CentralSettings..::..RibbonAllIconsChangedEventHandler |
Public delegate | CentralSettings..::..RibbonDrawTabIconsChangedEventHandler |
Public delegate | CentralSettings..::..RibbonSeparatorsChangedEventHandler |
Public delegate | CentralSettings..::..RibbonVisibleChangedEventHandler |
Public delegate | CentralSettings..::..TemplateFileChangedEventHandler |
Public delegate | CentralSettings..::..TooltipWiggleRadiusChangedEventHandler |
Public delegate | DataTree<(Of <(<'T>)>)>..::..DuplicateT | Duplication delegate used in the copy constructor. Implementation should never throw exceptions.


CentralSettings Class

[image]

Grasshopper SDK
CentralSettings Class
Members See Also Send Feedback
Represents a collection of program wide settings and events for when those settings change. This should probably be the bottleneck for all program wide settings, but stuff is still littered about for now.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class CentralSettings
Visual Basic
Public NotInheritable Class CentralSettings

Inheritance Hierarchy

System..::..Object
Grasshopper..::..CentralSettings

See Also

CentralSettings Members
Grasshopper Namespace


CentralSettings Members

[image] [image]

Grasshopper SDK
CentralSettings Members
CentralSettings Class Methods Properties Events See Also Send Feedback

The CentralSettings type exposes the following members.

Methods

Name | Description
GetLoadMechanism | Gets what load mechanism has been specified for a certain plugin.
IsLoadProtected | Gets whether a certain plugin is load protected.
SetLoadMechanism | Sets the user defined load mechanism for a certain plugin.
SetLoadProtected | Sets whether a certain plugin is load protected.

Properties

Name | Description
AuthorAddress | Gets or sets the default author address to be used for all data generated by this Grasshopper installation.
AuthorCompany | Gets or sets the default author company to be used for all data generated by this Grasshopper installation.
AuthorCopyright | Gets or sets the default author copyright to be used for all data generated by this Grasshopper installation.
AuthorCopyrightFormatted | Gets the authorCopyright message formatted to match the current date.
AuthorDetails | Gets a new GH_AuthorDetails instance populated with the current settings. Changing this instance does not affect the settings.
AuthorEMail | Gets or sets the default author e-mail to be used for all data generated by this Grasshopper installation.
AuthorName | Gets or sets the default author name to be used for all data generated by this Grasshopper installation.
AuthorPhone | Gets or sets the default author phone to be used for all data generated by this Grasshopper installation.
AuthorWebsite | Gets or sets the default author website to be used for all data generated by this Grasshopper installation.
CanvasFancyWires | Gets or sets whether or not fancy wires will be drawn. This is a global setting.
CanvasFullNames | Gets or sets the global default for verbose UI. When CanvasFullNames=True, parameter nicknames are set to their actual (long) names upon addition.
CanvasObjectIcons | Gets or sets the global default for icon display.
CanvasObsoleteTags | Gets or sets the global default for obsolete tags.
CanvasRadialMenu | Gets or sets the global default for whether the canvas should use Radial or olds-kool menus.
CanvasZuiZoomLevel | Gets or sets the global Zui zoom threshold.
ComponentCascadeMenus | Gets or sets whether Grasshopper document solutions are wrapped in undo records.
CreateSolutionUndoRecord | Gets or sets whether Grasshopper document solutions are wrapped in undo records.
FormatDecimalDigits | Gets or sets how many digits ought to be used for decimal formatted numbers.
FormatENotationDigits | Gets or sets how many digits ought to be used for scientific notation formatted numbers.
FormatENotationLowerLimit | Gets or sets at what power of ten decimal formatting of numbers switches to E notation for small numbers.
FormatENotationLowerThreshold | Gets at what actual threshold numeric formatting switches from decimal to E-Notation.
FormatENotationUpperLimit | Gets or sets at what power of ten decimal formatting of numbers switches to E notation for large numbers.
FormatENotationUpperThreshold | Gets at what actual threshold numeric formatting switches from decimal to E-Notation.
FormatMultiplesOfOne | Gets or sets whether floating point numbers close to whole integers should be special cased.
FormatMultiplesOfPi | Gets or sets whether multiples of 0.5*Pi ought to be special cased.
IsTemplateFile | Gets whether a template file has been defined and whether that file ectually exists.
PreviewBumpZBuffer | Gets or sets whether the Document preview bumps the Z-Buffer. Setting this value automatically causes a redraw of the Rhino viewports.
PreviewMeshEdges | Gets or sets the Mesh Wire display flag.
PreviewPlaneRadius | Gets or sets the global Plane radius.
PreviewPointStyle | Gets or sets the point style for Grasshopper preview points.
PruderyLevel | Gets or sets the Grasshopper UI prudery level.
RibbonDrawTabIcons | Gets or sets whether tab icons are drawn for the ribbon.
RibbonSeparators | Gets or sets whether there are separators between different exposures on the component Ribbon.
RibbonShowObscure | Gets or sets a value indicating whether components marked with DropDown exposure are drawn on the main toolbar anyway.
RibbonVisible | Gets or sets a value indicating whether components marked with DropDown exposure are drawn on the main toolbar anyway.
TemplateFile | Gets or sets the template file path. Use String.Empty or Nothing to disable the template file.
TooltipWiggleRadius | Gets or sets the wiggle radius (in pixels) which the mouse is allowed to move before the tooltip is nuked.

Events

Name | Description
AuthorAddressChanged | Raised whenever the AuthorAddress field is changed.
AuthorCompanyChanged | Raised whenever the AuthorCompany field is changed.
AuthorCopyrightChanged | Raised whenever the AuthorCopyright field is changed.
AuthorEMailChanged | Raised whenever the AuthorEMail field is changed.
AuthorNameChanged | Raised whenever the AuthorName field is changed.
AuthorPhoneChanged | Raised whenever the AuthorPhone field is changed.
AuthorWebsiteChanged | Raised whenever the AuthorWebsite field is changed.
CanvasFancyWiresChanged | Raised whenever the CanvasFancyWires setting changes.
CanvasFullNamesChanged | Raised whenever the CanvasFullNames setting changes.
CanvasObjectIconsChanged | Raised whenever the CanvasObjectIcons setting changes.
CanvasObsoleteTagsChanged | Raised whenever the CanvasObsoleteTags setting changes.
CanvasRadialMenuChanged | Raised whenever the CanvasRadialMenu setting changes.
CanvasZuiZoomLevelChanged | Raised whenever the CanvasZuiZoomLevel setting changes.
ComponentCascadeMenusChanged | Raised whenever the ComponentCascadeMenus setting changes.
CreateSolutionUndoRecordChanged | Raised whenever the CreateSolutionUndoRecord setting changes.
FormattingChanged | Raised whenever a formatting setting is changed.
LoadMechanismChanged | Raised whenever the load mechanism of a certain plugin changes.
LoadProtectionChanged | Raised whenever the load protection of a certain plugin changes.
PreviewBumpZBufferChanged | Raised whenever the PreviewBumpZBuffer setting changes.
PreviewMeshEdgesChanged | Raised whenever the PreviewMeshEdges setting changes.
PreviewPlaneRadiusChanged | Raised whenever the PreviewPlaneRadius setting changes.
PreviewPointStyleChanged | Raised whenever the PreviewPointStyle setting changes.
PruderyLevelChanged | Raised whenever the PruderyLevel setting changes.
RibbonAllIconsChanged | Raised whenever the RibbonAllIcons setting changes.
RibbonDrawTabIconsChanged | Raised whenever the RibbonDrawTabIcons setting changes.
RibbonSeparatorsChanged | Raised whenever the RibbonSeparators setting changes.
RibbonVisibleChanged | Raised whenever the RibbonVisible setting changes.
TemplateFileChanged | Raised whenever the TemplateFile property is changed.
TooltipWiggleRadiusChanged | Raised whenever the TooltipWiggleRadius setting changes.

See Also

CentralSettings Class
Grasshopper Namespace


CentralSettings Methods

[image] [image]

Grasshopper SDK
CentralSettings Methods
CentralSettings Class See Also Send Feedback

The CentralSettings type exposes the following members.

Methods

Name | Description
GetLoadMechanism | Gets what load mechanism has been specified for a certain plugin.
IsLoadProtected | Gets whether a certain plugin is load protected.
SetLoadMechanism | Sets the user defined load mechanism for a certain plugin.
SetLoadProtected | Sets whether a certain plugin is load protected.

See Also

CentralSettings Class
Grasshopper Namespace


GetLoadMechanism Method

[image]

Grasshopper SDK
CentralSettings..::..GetLoadMechanism Method
CentralSettings Class See Also Send Feedback
Gets what load mechanism has been specified for a certain plugin.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_LoadingDemand GetLoadMechanism(
    string pluginName
)
Visual Basic
Public Shared Function GetLoadMechanism ( _
    pluginName As String _
) As GH_LoadingDemand

Parameters

pluginName
Type: System..::..String
The name of the plugin file (without the extension).

Return Value

The user-defined load mechanism.

See Also

CentralSettings Class
Grasshopper Namespace


IsLoadProtected Method

[image]

Grasshopper SDK
CentralSettings..::..IsLoadProtected Method
CentralSettings Class See Also Send Feedback
Gets whether a certain plugin is load protected.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool IsLoadProtected(
    string pluginName
)
Visual Basic
Public Shared Function IsLoadProtected ( _
    pluginName As String _
) As Boolean

Parameters

pluginName
Type: System..::..String
The name of the plugin file (without the extension).

Return Value

True if the plugin is load protected, false if not.

See Also

CentralSettings Class
Grasshopper Namespace


SetLoadMechanism Method

[image]

Grasshopper SDK
CentralSettings..::..SetLoadMechanism Method
CentralSettings Class See Also Send Feedback
Sets the user defined load mechanism for a certain plugin.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void SetLoadMechanism(
    string pluginName,
    GH_LoadingDemand mechanism
)
Visual Basic
Public Shared Sub SetLoadMechanism ( _
    pluginName As String, _
    mechanism As GH_LoadingDemand _
)

Parameters

pluginName
Type: System..::..String
The name of the plugin file (without the extension).
mechanism
Type: Grasshopper.Kernel..::..GH_LoadingDemand
Load mechanism for this plugin.

See Also

CentralSettings Class
Grasshopper Namespace


SetLoadProtected Method

[image]

Grasshopper SDK
CentralSettings..::..SetLoadProtected Method
CentralSettings Class See Also Send Feedback
Sets whether a certain plugin is load protected.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void SetLoadProtected(
    string pluginName,
    bool loadProtect
)
Visual Basic
Public Shared Sub SetLoadProtected ( _
    pluginName As String, _
    loadProtect As Boolean _
)

Parameters

pluginName
Type: System..::..String
The name of the plugin file (without the extension).
loadProtect
Type: System..::..Boolean
Load protection flag for this plugin.

See Also

CentralSettings Class
Grasshopper Namespace


CentralSettings Properties

[image] [image]

Grasshopper SDK
CentralSettings Properties
CentralSettings Class See Also Send Feedback

The CentralSettings type exposes the following members.

Properties

Name | Description
AuthorAddress | Gets or sets the default author address to be used for all data generated by this Grasshopper installation.
AuthorCompany | Gets or sets the default author company to be used for all data generated by this Grasshopper installation.
AuthorCopyright | Gets or sets the default author copyright to be used for all data generated by this Grasshopper installation.
AuthorCopyrightFormatted | Gets the authorCopyright message formatted to match the current date.
AuthorDetails | Gets a new GH_AuthorDetails instance populated with the current settings. Changing this instance does not affect the settings.
AuthorEMail | Gets or sets the default author e-mail to be used for all data generated by this Grasshopper installation.
AuthorName | Gets or sets the default author name to be used for all data generated by this Grasshopper installation.
AuthorPhone | Gets or sets the default author phone to be used for all data generated by this Grasshopper installation.
AuthorWebsite | Gets or sets the default author website to be used for all data generated by this Grasshopper installation.
CanvasFancyWires | Gets or sets whether or not fancy wires will be drawn. This is a global setting.
CanvasFullNames | Gets or sets the global default for verbose UI. When CanvasFullNames=True, parameter nicknames are set to their actual (long) names upon addition.
CanvasObjectIcons | Gets or sets the global default for icon display.
CanvasObsoleteTags | Gets or sets the global default for obsolete tags.
CanvasRadialMenu | Gets or sets the global default for whether the canvas should use Radial or olds-kool menus.
CanvasZuiZoomLevel | Gets or sets the global Zui zoom threshold.
ComponentCascadeMenus | Gets or sets whether Grasshopper document solutions are wrapped in undo records.
CreateSolutionUndoRecord | Gets or sets whether Grasshopper document solutions are wrapped in undo records.
FormatDecimalDigits | Gets or sets how many digits ought to be used for decimal formatted numbers.
FormatENotationDigits | Gets or sets how many digits ought to be used for scientific notation formatted numbers.
FormatENotationLowerLimit | Gets or sets at what power of ten decimal formatting of numbers switches to E notation for small numbers.
FormatENotationLowerThreshold | Gets at what actual threshold numeric formatting switches from decimal to E-Notation.
FormatENotationUpperLimit | Gets or sets at what power of ten decimal formatting of numbers switches to E notation for large numbers.
FormatENotationUpperThreshold | Gets at what actual threshold numeric formatting switches from decimal to E-Notation.
FormatMultiplesOfOne | Gets or sets whether floating point numbers close to whole integers should be special cased.
FormatMultiplesOfPi | Gets or sets whether multiples of 0.5*Pi ought to be special cased.
IsTemplateFile | Gets whether a template file has been defined and whether that file ectually exists.
PreviewBumpZBuffer | Gets or sets whether the Document preview bumps the Z-Buffer. Setting this value automatically causes a redraw of the Rhino viewports.
PreviewMeshEdges | Gets or sets the Mesh Wire display flag.
PreviewPlaneRadius | Gets or sets the global Plane radius.
PreviewPointStyle | Gets or sets the point style for Grasshopper preview points.
PruderyLevel | Gets or sets the Grasshopper UI prudery level.
RibbonDrawTabIcons | Gets or sets whether tab icons are drawn for the ribbon.
RibbonSeparators | Gets or sets whether there are separators between different exposures on the component Ribbon.
RibbonShowObscure | Gets or sets a value indicating whether components marked with DropDown exposure are drawn on the main toolbar anyway.
RibbonVisible | Gets or sets a value indicating whether components marked with DropDown exposure are drawn on the main toolbar anyway.
TemplateFile | Gets or sets the template file path. Use String.Empty or Nothing to disable the template file.
TooltipWiggleRadius | Gets or sets the wiggle radius (in pixels) which the mouse is allowed to move before the tooltip is nuked.

See Also

CentralSettings Class
Grasshopper Namespace


AuthorAddress Property

[image]

Grasshopper SDK
CentralSettings..::..AuthorAddress Property
CentralSettings Class See Also Send Feedback
Gets or sets the default author address to be used for all data generated by this Grasshopper installation.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string AuthorAddress { get; set; }
Visual Basic
Public Shared Property AuthorAddress As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.CentralSettings.AuthorAddress"]

See Also

CentralSettings Class
Grasshopper Namespace


AuthorCompany Property

[image]

Grasshopper SDK
CentralSettings..::..AuthorCompany Property
CentralSettings Class See Also Send Feedback
Gets or sets the default author company to be used for all data generated by this Grasshopper installation.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string AuthorCompany { get; set; }
Visual Basic
Public Shared Property AuthorCompany As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.CentralSettings.AuthorCompany"]

See Also

CentralSettings Class
Grasshopper Namespace


AuthorCopyright Property

[image]

Grasshopper SDK
CentralSettings..::..AuthorCopyright Property
CentralSettings Class See Also Send Feedback
Gets or sets the default author copyright to be used for all data generated by this Grasshopper installation.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string AuthorCopyright { get; set; }
Visual Basic
Public Shared Property AuthorCopyright As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.CentralSettings.AuthorCopyright"]

See Also

CentralSettings Class
Grasshopper Namespace


AuthorCopyrightFormatted Property

[image]

Grasshopper SDK
CentralSettings..::..AuthorCopyrightFormatted Property
CentralSettings Class See Also Send Feedback
Gets the authorCopyright message formatted to match the current date.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string AuthorCopyrightFormatted { get; }
Visual Basic
Public Shared ReadOnly Property AuthorCopyrightFormatted As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.CentralSettings.AuthorCopyrightFormatted"]

See Also

CentralSettings Class
Grasshopper Namespace


AuthorDetails Property

[image]

Grasshopper SDK
CentralSettings..::..AuthorDetails Property
CentralSettings Class See Also Send Feedback
Gets a new GH_AuthorDetails instance populated with the current settings. Changing this instance does not affect the settings.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static IGH_Author AuthorDetails { get; }
Visual Basic
Public Shared ReadOnly Property AuthorDetails As IGH_Author
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.CentralSettings.AuthorDetails"]

See Also

CentralSettings Class
Grasshopper Namespace


AuthorEMail Property

[image]

Grasshopper SDK
CentralSettings..::..AuthorEMail Property
CentralSettings Class See Also Send Feedback
Gets or sets the default author e-mail to be used for all data generated by this Grasshopper installation.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string AuthorEMail { get; set; }
Visual Basic
Public Shared Property AuthorEMail As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.CentralSettings.AuthorEMail"]

See Also

CentralSettings Class
Grasshopper Namespace


AuthorName Property

[image]

Grasshopper SDK
CentralSettings..::..AuthorName Property
CentralSettings Class See Also Send Feedback
Gets or sets the default author name to be used for all data generated by this Grasshopper installation.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string AuthorName { get; set; }
Visual Basic
Public Shared Property AuthorName As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.CentralSettings.AuthorName"]

See Also

CentralSettings Class
Grasshopper Namespace


AuthorPhone Property

[image]

Grasshopper SDK
CentralSettings..::..AuthorPhone Property
CentralSettings Class See Also Send Feedback
Gets or sets the default author phone to be used for all data generated by this Grasshopper installation.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string AuthorPhone { get; set; }
Visual Basic
Public Shared Property AuthorPhone As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.CentralSettings.AuthorPhone"]

See Also

CentralSettings Class
Grasshopper Namespace


AuthorWebsite Property

[image]

Grasshopper SDK
CentralSettings..::..AuthorWebsite Property
CentralSettings Class See Also Send Feedback
Gets or sets the default author website to be used for all data generated by this Grasshopper installation.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string AuthorWebsite { get; set; }
Visual Basic
Public Shared Property AuthorWebsite As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.CentralSettings.AuthorWebsite"]

See Also

CentralSettings Class
Grasshopper Namespace


CanvasFancyWires Property

[image]

Grasshopper SDK
CentralSettings..::..CanvasFancyWires Property
CentralSettings Class See Also Send Feedback
Gets or sets whether or not fancy wires will be drawn. This is a global setting.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool CanvasFancyWires { get; set; }
Visual Basic
Public Shared Property CanvasFancyWires As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.CentralSettings.CanvasFancyWires"]

See Also

CentralSettings Class
Grasshopper Namespace


CanvasFullNames Property

[image]

Grasshopper SDK
CentralSettings..::..CanvasFullNames Property
CentralSettings Class See Also Send Feedback
Gets or sets the global default for verbose UI. When CanvasFullNames=True, parameter nicknames are set to their actual (long) names upon addition.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool CanvasFullNames { get; set; }
Visual Basic
Public Shared Property CanvasFullNames As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.CentralSettings.CanvasFullNames"]

See Also

CentralSettings Class
Grasshopper Namespace


CanvasObjectIcons Property

[image]

Grasshopper SDK
CentralSettings..::..CanvasObjectIcons Property
CentralSettings Class See Also Send Feedback
Gets or sets the global default for icon display.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool CanvasObjectIcons { get; set; }
Visual Basic
Public Shared Property CanvasObjectIcons As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.CentralSettings.CanvasObjectIcons"]

See Also

CentralSettings Class
Grasshopper Namespace


CanvasObsoleteTags Property

[image]

Grasshopper SDK
CentralSettings..::..CanvasObsoleteTags Property
CentralSettings Class See Also Send Feedback
Gets or sets the global default for obsolete tags.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool CanvasObsoleteTags { get; set; }
Visual Basic
Public Shared Property CanvasObsoleteTags As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.CentralSettings.CanvasObsoleteTags"]

See Also

CentralSettings Class
Grasshopper Namespace


CanvasRadialMenu Property

[image]

Grasshopper SDK
CentralSettings..::..CanvasRadialMenu Property
CentralSettings Class See Also Send Feedback
Gets or sets the global default for whether the canvas should use Radial or olds-kool menus.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool CanvasRadialMenu { get; set; }
Visual Basic
Public Shared Property CanvasRadialMenu As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.CentralSettings.CanvasRadialMenu"]

See Also

CentralSettings Class
Grasshopper Namespace


CanvasZuiZoomLevel Property

[image]

Grasshopper SDK
CentralSettings..::..CanvasZuiZoomLevel Property
CentralSettings Class See Also Send Feedback
Gets or sets the global Zui zoom threshold.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static float CanvasZuiZoomLevel { get; set; }
Visual Basic
Public Shared Property CanvasZuiZoomLevel As Single
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.CentralSettings.CanvasZuiZoomLevel"]

See Also

CentralSettings Class
Grasshopper Namespace


ComponentCascadeMenus Property

[image]

Grasshopper SDK
CentralSettings..::..ComponentCascadeMenus Property
CentralSettings Class See Also Send Feedback
Gets or sets whether Grasshopper document solutions are wrapped in undo records.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ComponentCascadeMenus { get; set; }
Visual Basic
Public Shared Property ComponentCascadeMenus As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.CentralSettings.ComponentCascadeMenus"]

See Also

CentralSettings Class
Grasshopper Namespace


CreateSolutionUndoRecord Property

[image]

Grasshopper SDK
CentralSettings..::..CreateSolutionUndoRecord Property
CentralSettings Class See Also Send Feedback
Gets or sets whether Grasshopper document solutions are wrapped in undo records.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool CreateSolutionUndoRecord { get; set; }
Visual Basic
Public Shared Property CreateSolutionUndoRecord As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.CentralSettings.CreateSolutionUndoRecord"]

See Also

CentralSettings Class
Grasshopper Namespace


FormatDecimalDigits Property

[image]

Grasshopper SDK
CentralSettings..::..FormatDecimalDigits Property
CentralSettings Class See Also Send Feedback
Gets or sets how many digits ought to be used for decimal formatted numbers.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static int FormatDecimalDigits { get; set; }
Visual Basic
Public Shared Property FormatDecimalDigits As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.CentralSettings.FormatDecimalDigits"]

See Also

CentralSettings Class
Grasshopper Namespace


FormatENotationDigits Property

[image]

Grasshopper SDK
CentralSettings..::..FormatENotationDigits Property
CentralSettings Class See Also Send Feedback
Gets or sets how many digits ought to be used for scientific notation formatted numbers.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static int FormatENotationDigits { get; set; }
Visual Basic
Public Shared Property FormatENotationDigits As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.CentralSettings.FormatENotationDigits"]

See Also

CentralSettings Class
Grasshopper Namespace


FormatENotationLowerLimit Property

[image]

Grasshopper SDK
CentralSettings..::..FormatENotationLowerLimit Property
CentralSettings Class See Also Send Feedback
Gets or sets at what power of ten decimal formatting of numbers switches to E notation for small numbers.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static int FormatENotationLowerLimit { get; set; }
Visual Basic
Public Shared Property FormatENotationLowerLimit As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.CentralSettings.FormatENotationLowerLimit"]

See Also

CentralSettings Class
Grasshopper Namespace


FormatENotationLowerThreshold Property

[image]

Grasshopper SDK
CentralSettings..::..FormatENotationLowerThreshold Property
CentralSettings Class See Also Send Feedback
Gets at what actual threshold numeric formatting switches from decimal to E-Notation.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static double FormatENotationLowerThreshold { get; }
Visual Basic
Public Shared ReadOnly Property FormatENotationLowerThreshold As Double
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.CentralSettings.FormatENotationLowerThreshold"]

See Also

CentralSettings Class
Grasshopper Namespace


FormatENotationUpperLimit Property

[image]

Grasshopper SDK
CentralSettings..::..FormatENotationUpperLimit Property
CentralSettings Class See Also Send Feedback
Gets or sets at what power of ten decimal formatting of numbers switches to E notation for large numbers.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static int FormatENotationUpperLimit { get; set; }
Visual Basic
Public Shared Property FormatENotationUpperLimit As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.CentralSettings.FormatENotationUpperLimit"]

See Also

CentralSettings Class
Grasshopper Namespace


FormatENotationUpperThreshold Property

[image]

Grasshopper SDK
CentralSettings..::..FormatENotationUpperThreshold Property
CentralSettings Class See Also Send Feedback
Gets at what actual threshold numeric formatting switches from decimal to E-Notation.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static double FormatENotationUpperThreshold { get; }
Visual Basic
Public Shared ReadOnly Property FormatENotationUpperThreshold As Double
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.CentralSettings.FormatENotationUpperThreshold"]

See Also

CentralSettings Class
Grasshopper Namespace


FormatMultiplesOfOne Property

[image]

Grasshopper SDK
CentralSettings..::..FormatMultiplesOfOne Property
CentralSettings Class See Also Send Feedback
Gets or sets whether floating point numbers close to whole integers should be special cased.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool FormatMultiplesOfOne { get; set; }
Visual Basic
Public Shared Property FormatMultiplesOfOne As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.CentralSettings.FormatMultiplesOfOne"]

See Also

CentralSettings Class
Grasshopper Namespace


FormatMultiplesOfPi Property

[image]

Grasshopper SDK
CentralSettings..::..FormatMultiplesOfPi Property
CentralSettings Class See Also Send Feedback
Gets or sets whether multiples of 0.5*Pi ought to be special cased.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool FormatMultiplesOfPi { get; set; }
Visual Basic
Public Shared Property FormatMultiplesOfPi As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.CentralSettings.FormatMultiplesOfPi"]

See Also

CentralSettings Class
Grasshopper Namespace


IsTemplateFile Property

[image]

Grasshopper SDK
CentralSettings..::..IsTemplateFile Property
CentralSettings Class See Also Send Feedback
Gets whether a template file has been defined and whether that file ectually exists.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool IsTemplateFile { get; }
Visual Basic
Public Shared ReadOnly Property IsTemplateFile As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.CentralSettings.IsTemplateFile"]

See Also

CentralSettings Class
Grasshopper Namespace


PreviewBumpZBuffer Property

[image]

Grasshopper SDK
CentralSettings..::..PreviewBumpZBuffer Property
CentralSettings Class See Also Send Feedback
Gets or sets whether the Document preview bumps the Z-Buffer. Setting this value automatically causes a redraw of the Rhino viewports.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool PreviewBumpZBuffer { get; set; }
Visual Basic
Public Shared Property PreviewBumpZBuffer As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.CentralSettings.PreviewBumpZBuffer"]

See Also

CentralSettings Class
Grasshopper Namespace


PreviewMeshEdges Property

[image]

Grasshopper SDK
CentralSettings..::..PreviewMeshEdges Property
CentralSettings Class See Also Send Feedback
Gets or sets the Mesh Wire display flag.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool PreviewMeshEdges { get; set; }
Visual Basic
Public Shared Property PreviewMeshEdges As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.CentralSettings.PreviewMeshEdges"]

See Also

CentralSettings Class
Grasshopper Namespace


PreviewPlaneRadius Property

[image]

Grasshopper SDK
CentralSettings..::..PreviewPlaneRadius Property
CentralSettings Class See Also Send Feedback
Gets or sets the global Plane radius.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static double PreviewPlaneRadius { get; set; }
Visual Basic
Public Shared Property PreviewPlaneRadius As Double
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.CentralSettings.PreviewPlaneRadius"]

See Also

CentralSettings Class
Grasshopper Namespace


PreviewPointStyle Property

[image]

Grasshopper SDK
CentralSettings..::..PreviewPointStyle Property
CentralSettings Class See Also Send Feedback
Gets or sets the point style for Grasshopper preview points.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static PointStyle PreviewPointStyle { get; set; }
Visual Basic
Public Shared Property PreviewPointStyle As PointStyle
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.CentralSettings.PreviewPointStyle"]

See Also

CentralSettings Class
Grasshopper Namespace


PruderyLevel Property

[image]

Grasshopper SDK
CentralSettings..::..PruderyLevel Property
CentralSettings Class See Also Send Feedback
Gets or sets the Grasshopper UI prudery level.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_PruderyFilter PruderyLevel { get; set; }
Visual Basic
Public Shared Property PruderyLevel As GH_PruderyFilter
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.CentralSettings.PruderyLevel"]

See Also

CentralSettings Class
Grasshopper Namespace


RibbonDrawTabIcons Property

[image]

Grasshopper SDK
CentralSettings..::..RibbonDrawTabIcons Property
CentralSettings Class See Also Send Feedback
Gets or sets whether tab icons are drawn for the ribbon.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool RibbonDrawTabIcons { get; set; }
Visual Basic
Public Shared Property RibbonDrawTabIcons As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.CentralSettings.RibbonDrawTabIcons"]

See Also

CentralSettings Class
Grasshopper Namespace


RibbonSeparators Property

[image]

Grasshopper SDK
CentralSettings..::..RibbonSeparators Property
CentralSettings Class See Also Send Feedback
Gets or sets whether there are separators between different exposures on the component Ribbon.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool RibbonSeparators { get; set; }
Visual Basic
Public Shared Property RibbonSeparators As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.CentralSettings.RibbonSeparators"]

See Also

CentralSettings Class
Grasshopper Namespace


RibbonShowObscure Property

[image]

Grasshopper SDK
CentralSettings..::..RibbonShowObscure Property
CentralSettings Class See Also Send Feedback
Gets or sets a value indicating whether components marked with DropDown exposure are drawn on the main toolbar anyway.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool RibbonShowObscure { get; set; }
Visual Basic
Public Shared Property RibbonShowObscure As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.CentralSettings.RibbonShowObscure"]

See Also

CentralSettings Class
Grasshopper Namespace


RibbonVisible Property

[image]

Grasshopper SDK
CentralSettings..::..RibbonVisible Property
CentralSettings Class See Also Send Feedback
Gets or sets a value indicating whether components marked with DropDown exposure are drawn on the main toolbar anyway.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool RibbonVisible { get; set; }
Visual Basic
Public Shared Property RibbonVisible As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.CentralSettings.RibbonVisible"]

See Also

CentralSettings Class
Grasshopper Namespace


TemplateFile Property

[image]

Grasshopper SDK
CentralSettings..::..TemplateFile Property
CentralSettings Class See Also Send Feedback
Gets or sets the template file path. Use String.Empty or Nothing to disable the template file.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string TemplateFile { get; set; }
Visual Basic
Public Shared Property TemplateFile As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.CentralSettings.TemplateFile"]

See Also

CentralSettings Class
Grasshopper Namespace


TooltipWiggleRadius Property

[image]

Grasshopper SDK
CentralSettings..::..TooltipWiggleRadius Property
CentralSettings Class See Also Send Feedback
Gets or sets the wiggle radius (in pixels) which the mouse is allowed to move before the tooltip is nuked.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static int TooltipWiggleRadius { get; set; }
Visual Basic
Public Shared Property TooltipWiggleRadius As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.CentralSettings.TooltipWiggleRadius"]

See Also

CentralSettings Class
Grasshopper Namespace


CentralSettings Events

[image] [image]

Grasshopper SDK
CentralSettings Events
CentralSettings Class See Also Send Feedback

The CentralSettings type exposes the following members.

Events

Name | Description
AuthorAddressChanged | Raised whenever the AuthorAddress field is changed.
AuthorCompanyChanged | Raised whenever the AuthorCompany field is changed.
AuthorCopyrightChanged | Raised whenever the AuthorCopyright field is changed.
AuthorEMailChanged | Raised whenever the AuthorEMail field is changed.
AuthorNameChanged | Raised whenever the AuthorName field is changed.
AuthorPhoneChanged | Raised whenever the AuthorPhone field is changed.
AuthorWebsiteChanged | Raised whenever the AuthorWebsite field is changed.
CanvasFancyWiresChanged | Raised whenever the CanvasFancyWires setting changes.
CanvasFullNamesChanged | Raised whenever the CanvasFullNames setting changes.
CanvasObjectIconsChanged | Raised whenever the CanvasObjectIcons setting changes.
CanvasObsoleteTagsChanged | Raised whenever the CanvasObsoleteTags setting changes.
CanvasRadialMenuChanged | Raised whenever the CanvasRadialMenu setting changes.
CanvasZuiZoomLevelChanged | Raised whenever the CanvasZuiZoomLevel setting changes.
ComponentCascadeMenusChanged | Raised whenever the ComponentCascadeMenus setting changes.
CreateSolutionUndoRecordChanged | Raised whenever the CreateSolutionUndoRecord setting changes.
FormattingChanged | Raised whenever a formatting setting is changed.
LoadMechanismChanged | Raised whenever the load mechanism of a certain plugin changes.
LoadProtectionChanged | Raised whenever the load protection of a certain plugin changes.
PreviewBumpZBufferChanged | Raised whenever the PreviewBumpZBuffer setting changes.
PreviewMeshEdgesChanged | Raised whenever the PreviewMeshEdges setting changes.
PreviewPlaneRadiusChanged | Raised whenever the PreviewPlaneRadius setting changes.
PreviewPointStyleChanged | Raised whenever the PreviewPointStyle setting changes.
PruderyLevelChanged | Raised whenever the PruderyLevel setting changes.
RibbonAllIconsChanged | Raised whenever the RibbonAllIcons setting changes.
RibbonDrawTabIconsChanged | Raised whenever the RibbonDrawTabIcons setting changes.
RibbonSeparatorsChanged | Raised whenever the RibbonSeparators setting changes.
RibbonVisibleChanged | Raised whenever the RibbonVisible setting changes.
TemplateFileChanged | Raised whenever the TemplateFile property is changed.
TooltipWiggleRadiusChanged | Raised whenever the TooltipWiggleRadius setting changes.

See Also

CentralSettings Class
Grasshopper Namespace


AuthorAddressChanged Event

[image]

Grasshopper SDK
CentralSettings..::..AuthorAddressChanged Event
CentralSettings Class See Also Send Feedback
Raised whenever the AuthorAddress field is changed.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event CentralSettings..::..AuthorAddressChangedEventHandler AuthorAddressChanged
Visual Basic
Public Shared Event AuthorAddressChanged As CentralSettings..::..AuthorAddressChangedEventHandler

See Also

CentralSettings Class
Grasshopper Namespace


AuthorCompanyChanged Event

[image]

Grasshopper SDK
CentralSettings..::..AuthorCompanyChanged Event
CentralSettings Class See Also Send Feedback
Raised whenever the AuthorCompany field is changed.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event CentralSettings..::..AuthorCompanyChangedEventHandler AuthorCompanyChanged
Visual Basic
Public Shared Event AuthorCompanyChanged As CentralSettings..::..AuthorCompanyChangedEventHandler

See Also

CentralSettings Class
Grasshopper Namespace


AuthorCopyrightChanged Event

[image]

Grasshopper SDK
CentralSettings..::..AuthorCopyrightChanged Event
CentralSettings Class See Also Send Feedback
Raised whenever the AuthorCopyright field is changed.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event CentralSettings..::..AuthorCopyrightChangedEventHandler AuthorCopyrightChanged
Visual Basic
Public Shared Event AuthorCopyrightChanged As CentralSettings..::..AuthorCopyrightChangedEventHandler

See Also

CentralSettings Class
Grasshopper Namespace


AuthorEMailChanged Event

[image]

Grasshopper SDK
CentralSettings..::..AuthorEMailChanged Event
CentralSettings Class See Also Send Feedback
Raised whenever the AuthorEMail field is changed.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event CentralSettings..::..AuthorEMailChangedEventHandler AuthorEMailChanged
Visual Basic
Public Shared Event AuthorEMailChanged As CentralSettings..::..AuthorEMailChangedEventHandler

See Also

CentralSettings Class
Grasshopper Namespace


AuthorNameChanged Event

[image]

Grasshopper SDK
CentralSettings..::..AuthorNameChanged Event
CentralSettings Class See Also Send Feedback
Raised whenever the AuthorName field is changed.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event CentralSettings..::..AuthorNameChangedEventHandler AuthorNameChanged
Visual Basic
Public Shared Event AuthorNameChanged As CentralSettings..::..AuthorNameChangedEventHandler

See Also

CentralSettings Class
Grasshopper Namespace


AuthorPhoneChanged Event

[image]

Grasshopper SDK
CentralSettings..::..AuthorPhoneChanged Event
CentralSettings Class See Also Send Feedback
Raised whenever the AuthorPhone field is changed.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event CentralSettings..::..AuthorPhoneChangedEventHandler AuthorPhoneChanged
Visual Basic
Public Shared Event AuthorPhoneChanged As CentralSettings..::..AuthorPhoneChangedEventHandler

See Also

CentralSettings Class
Grasshopper Namespace


AuthorWebsiteChanged Event

[image]

Grasshopper SDK
CentralSettings..::..AuthorWebsiteChanged Event
CentralSettings Class See Also Send Feedback
Raised whenever the AuthorWebsite field is changed.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event CentralSettings..::..AuthorWebsiteChangedEventHandler AuthorWebsiteChanged
Visual Basic
Public Shared Event AuthorWebsiteChanged As CentralSettings..::..AuthorWebsiteChangedEventHandler

See Also

CentralSettings Class
Grasshopper Namespace


CanvasFancyWiresChanged Event

[image]

Grasshopper SDK
CentralSettings..::..CanvasFancyWiresChanged Event
CentralSettings Class See Also Send Feedback
Raised whenever the CanvasFancyWires setting changes.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event CentralSettings..::..CanvasFancyWiresChangedEventHandler CanvasFancyWiresChanged
Visual Basic
Public Shared Event CanvasFancyWiresChanged As CentralSettings..::..CanvasFancyWiresChangedEventHandler

See Also

CentralSettings Class
Grasshopper Namespace


CanvasFullNamesChanged Event

[image]

Grasshopper SDK
CentralSettings..::..CanvasFullNamesChanged Event
CentralSettings Class See Also Send Feedback
Raised whenever the CanvasFullNames setting changes.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event CentralSettings..::..CanvasFullNamesChangedEventHandler CanvasFullNamesChanged
Visual Basic
Public Shared Event CanvasFullNamesChanged As CentralSettings..::..CanvasFullNamesChangedEventHandler

See Also

CentralSettings Class
Grasshopper Namespace


CanvasObjectIconsChanged Event

[image]

Grasshopper SDK
CentralSettings..::..CanvasObjectIconsChanged Event
CentralSettings Class See Also Send Feedback
Raised whenever the CanvasObjectIcons setting changes.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event CentralSettings..::..CanvasObjectIconsChangedEventHandler CanvasObjectIconsChanged
Visual Basic
Public Shared Event CanvasObjectIconsChanged As CentralSettings..::..CanvasObjectIconsChangedEventHandler

See Also

CentralSettings Class
Grasshopper Namespace


CanvasObsoleteTagsChanged Event

[image]

Grasshopper SDK
CentralSettings..::..CanvasObsoleteTagsChanged Event
CentralSettings Class See Also Send Feedback
Raised whenever the CanvasObsoleteTags setting changes.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event CentralSettings..::..CanvasObsoleteTagsChangedEventHandler CanvasObsoleteTagsChanged
Visual Basic
Public Shared Event CanvasObsoleteTagsChanged As CentralSettings..::..CanvasObsoleteTagsChangedEventHandler

See Also

CentralSettings Class
Grasshopper Namespace


CanvasRadialMenuChanged Event

[image]

Grasshopper SDK
CentralSettings..::..CanvasRadialMenuChanged Event
CentralSettings Class See Also Send Feedback
Raised whenever the CanvasRadialMenu setting changes.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event CentralSettings..::..CanvasRadialMenuChangedEventHandler CanvasRadialMenuChanged
Visual Basic
Public Shared Event CanvasRadialMenuChanged As CentralSettings..::..CanvasRadialMenuChangedEventHandler

See Also

CentralSettings Class
Grasshopper Namespace


CanvasZuiZoomLevelChanged Event

[image]

Grasshopper SDK
CentralSettings..::..CanvasZuiZoomLevelChanged Event
CentralSettings Class See Also Send Feedback
Raised whenever the CanvasZuiZoomLevel setting changes.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event CentralSettings..::..CanvasZuiZoomLevelChangedEventHandler CanvasZuiZoomLevelChanged
Visual Basic
Public Shared Event CanvasZuiZoomLevelChanged As CentralSettings..::..CanvasZuiZoomLevelChangedEventHandler

See Also

CentralSettings Class
Grasshopper Namespace


ComponentCascadeMenusChanged Event

[image]

Grasshopper SDK
CentralSettings..::..ComponentCascadeMenusChanged Event
CentralSettings Class See Also Send Feedback
Raised whenever the ComponentCascadeMenus setting changes.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event CentralSettings..::..ComponentCascadeMenusChangedEventHandler ComponentCascadeMenusChanged
Visual Basic
Public Shared Event ComponentCascadeMenusChanged As CentralSettings..::..ComponentCascadeMenusChangedEventHandler

See Also

CentralSettings Class
Grasshopper Namespace


CreateSolutionUndoRecordChanged Event

[image]

Grasshopper SDK
CentralSettings..::..CreateSolutionUndoRecordChanged Event
CentralSettings Class See Also Send Feedback
Raised whenever the CreateSolutionUndoRecord setting changes.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event CentralSettings..::..CreateSolutionUndoRecordChangedEventHandler CreateSolutionUndoRecordChanged
Visual Basic
Public Shared Event CreateSolutionUndoRecordChanged As CentralSettings..::..CreateSolutionUndoRecordChangedEventHandler

See Also

CentralSettings Class
Grasshopper Namespace


FormattingChanged Event

[image]

Grasshopper SDK
CentralSettings..::..FormattingChanged Event
CentralSettings Class See Also Send Feedback
Raised whenever a formatting setting is changed.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event CentralSettings..::..FormattingChangedEventHandler FormattingChanged
Visual Basic
Public Shared Event FormattingChanged As CentralSettings..::..FormattingChangedEventHandler

See Also

CentralSettings Class
Grasshopper Namespace


LoadMechanismChanged Event

[image]

Grasshopper SDK
CentralSettings..::..LoadMechanismChanged Event
CentralSettings Class See Also Send Feedback
Raised whenever the load mechanism of a certain plugin changes.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event CentralSettings..::..LoadMechanismChangedEventHandler LoadMechanismChanged
Visual Basic
Public Shared Event LoadMechanismChanged As CentralSettings..::..LoadMechanismChangedEventHandler

See Also

CentralSettings Class
Grasshopper Namespace


LoadProtectionChanged Event

[image]

Grasshopper SDK
CentralSettings..::..LoadProtectionChanged Event
CentralSettings Class See Also Send Feedback
Raised whenever the load protection of a certain plugin changes.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event CentralSettings..::..LoadProtectionChangedEventHandler LoadProtectionChanged
Visual Basic
Public Shared Event LoadProtectionChanged As CentralSettings..::..LoadProtectionChangedEventHandler

See Also

CentralSettings Class
Grasshopper Namespace


PreviewBumpZBufferChanged Event

[image]

Grasshopper SDK
CentralSettings..::..PreviewBumpZBufferChanged Event
CentralSettings Class See Also Send Feedback
Raised whenever the PreviewBumpZBuffer setting changes.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event CentralSettings..::..PreviewBumpZBufferChangedEventHandler PreviewBumpZBufferChanged
Visual Basic
Public Shared Event PreviewBumpZBufferChanged As CentralSettings..::..PreviewBumpZBufferChangedEventHandler

See Also

CentralSettings Class
Grasshopper Namespace


PreviewMeshEdgesChanged Event

[image]

Grasshopper SDK
CentralSettings..::..PreviewMeshEdgesChanged Event
CentralSettings Class See Also Send Feedback
Raised whenever the PreviewMeshEdges setting changes.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event CentralSettings..::..PreviewMeshEdgesChangedEventHandler PreviewMeshEdgesChanged
Visual Basic
Public Shared Event PreviewMeshEdgesChanged As CentralSettings..::..PreviewMeshEdgesChangedEventHandler

See Also

CentralSettings Class
Grasshopper Namespace


PreviewPlaneRadiusChanged Event

[image]

Grasshopper SDK
CentralSettings..::..PreviewPlaneRadiusChanged Event
CentralSettings Class See Also Send Feedback
Raised whenever the PreviewPlaneRadius setting changes.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event CentralSettings..::..PreviewPlaneRadiusChangedEventHandler PreviewPlaneRadiusChanged
Visual Basic
Public Shared Event PreviewPlaneRadiusChanged As CentralSettings..::..PreviewPlaneRadiusChangedEventHandler

See Also

CentralSettings Class
Grasshopper Namespace


PreviewPointStyleChanged Event

[image]

Grasshopper SDK
CentralSettings..::..PreviewPointStyleChanged Event
CentralSettings Class See Also Send Feedback
Raised whenever the PreviewPointStyle setting changes.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event CentralSettings..::..PreviewPointStyleChangedEventHandler PreviewPointStyleChanged
Visual Basic
Public Shared Event PreviewPointStyleChanged As CentralSettings..::..PreviewPointStyleChangedEventHandler

See Also

CentralSettings Class
Grasshopper Namespace


PruderyLevelChanged Event

[image]

Grasshopper SDK
CentralSettings..::..PruderyLevelChanged Event
CentralSettings Class See Also Send Feedback
Raised whenever the PruderyLevel setting changes.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event CentralSettings..::..PruderyLevelChangedEventHandler PruderyLevelChanged
Visual Basic
Public Shared Event PruderyLevelChanged As CentralSettings..::..PruderyLevelChangedEventHandler

See Also

CentralSettings Class
Grasshopper Namespace


RibbonAllIconsChanged Event

[image]

Grasshopper SDK
CentralSettings..::..RibbonAllIconsChanged Event
CentralSettings Class See Also Send Feedback
Raised whenever the RibbonAllIcons setting changes.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event CentralSettings..::..RibbonAllIconsChangedEventHandler RibbonAllIconsChanged
Visual Basic
Public Shared Event RibbonAllIconsChanged As CentralSettings..::..RibbonAllIconsChangedEventHandler

See Also

CentralSettings Class
Grasshopper Namespace


RibbonDrawTabIconsChanged Event

[image]

Grasshopper SDK
CentralSettings..::..RibbonDrawTabIconsChanged Event
CentralSettings Class See Also Send Feedback
Raised whenever the RibbonDrawTabIcons setting changes.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event CentralSettings..::..RibbonDrawTabIconsChangedEventHandler RibbonDrawTabIconsChanged
Visual Basic
Public Shared Event RibbonDrawTabIconsChanged As CentralSettings..::..RibbonDrawTabIconsChangedEventHandler

See Also

CentralSettings Class
Grasshopper Namespace


RibbonSeparatorsChanged Event

[image]

Grasshopper SDK
CentralSettings..::..RibbonSeparatorsChanged Event
CentralSettings Class See Also Send Feedback
Raised whenever the RibbonSeparators setting changes.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event CentralSettings..::..RibbonSeparatorsChangedEventHandler RibbonSeparatorsChanged
Visual Basic
Public Shared Event RibbonSeparatorsChanged As CentralSettings..::..RibbonSeparatorsChangedEventHandler

See Also

CentralSettings Class
Grasshopper Namespace


RibbonVisibleChanged Event

[image]

Grasshopper SDK
CentralSettings..::..RibbonVisibleChanged Event
CentralSettings Class See Also Send Feedback
Raised whenever the RibbonVisible setting changes.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event CentralSettings..::..RibbonVisibleChangedEventHandler RibbonVisibleChanged
Visual Basic
Public Shared Event RibbonVisibleChanged As CentralSettings..::..RibbonVisibleChangedEventHandler

See Also

CentralSettings Class
Grasshopper Namespace


TemplateFileChanged Event

[image]

Grasshopper SDK
CentralSettings..::..TemplateFileChanged Event
CentralSettings Class See Also Send Feedback
Raised whenever the TemplateFile property is changed.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event CentralSettings..::..TemplateFileChangedEventHandler TemplateFileChanged
Visual Basic
Public Shared Event TemplateFileChanged As CentralSettings..::..TemplateFileChangedEventHandler

See Also

CentralSettings Class
Grasshopper Namespace


TooltipWiggleRadiusChanged Event

[image]

Grasshopper SDK
CentralSettings..::..TooltipWiggleRadiusChanged Event
CentralSettings Class See Also Send Feedback
Raised whenever the TooltipWiggleRadius setting changes.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event CentralSettings..::..TooltipWiggleRadiusChangedEventHandler TooltipWiggleRadiusChanged
Visual Basic
Public Shared Event TooltipWiggleRadiusChanged As CentralSettings..::..TooltipWiggleRadiusChangedEventHandler

See Also

CentralSettings Class
Grasshopper Namespace


CentralSettings.AuthorAddressChangedEventHandler Delegate

[image]

Grasshopper SDK
CentralSettings..::..AuthorAddressChangedEventHandler Delegate
CentralSettings Class See Also Send Feedback

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void AuthorAddressChangedEventHandler()
Visual Basic
Public Delegate Sub AuthorAddressChangedEventHandler

See Also

Grasshopper Namespace


CentralSettings.AuthorCompanyChangedEventHandler Delegate

[image]

Grasshopper SDK
CentralSettings..::..AuthorCompanyChangedEventHandler Delegate
CentralSettings Class See Also Send Feedback

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void AuthorCompanyChangedEventHandler()
Visual Basic
Public Delegate Sub AuthorCompanyChangedEventHandler

See Also

Grasshopper Namespace


CentralSettings.AuthorCopyrightChangedEventHandler Delegate

[image]

Grasshopper SDK
CentralSettings..::..AuthorCopyrightChangedEventHandler Delegate
CentralSettings Class See Also Send Feedback

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void AuthorCopyrightChangedEventHandler()
Visual Basic
Public Delegate Sub AuthorCopyrightChangedEventHandler

See Also

Grasshopper Namespace


CentralSettings.AuthorEMailChangedEventHandler Delegate

[image]

Grasshopper SDK
CentralSettings..::..AuthorEMailChangedEventHandler Delegate
CentralSettings Class See Also Send Feedback

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void AuthorEMailChangedEventHandler()
Visual Basic
Public Delegate Sub AuthorEMailChangedEventHandler

See Also

Grasshopper Namespace


CentralSettings.AuthorNameChangedEventHandler Delegate

[image]

Grasshopper SDK
CentralSettings..::..AuthorNameChangedEventHandler Delegate
CentralSettings Class See Also Send Feedback

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void AuthorNameChangedEventHandler()
Visual Basic
Public Delegate Sub AuthorNameChangedEventHandler

See Also

Grasshopper Namespace


CentralSettings.AuthorPhoneChangedEventHandler Delegate

[image]

Grasshopper SDK
CentralSettings..::..AuthorPhoneChangedEventHandler Delegate
CentralSettings Class See Also Send Feedback

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void AuthorPhoneChangedEventHandler()
Visual Basic
Public Delegate Sub AuthorPhoneChangedEventHandler

See Also

Grasshopper Namespace


CentralSettings.AuthorWebsiteChangedEventHandler Delegate

[image]

Grasshopper SDK
CentralSettings..::..AuthorWebsiteChangedEventHandler Delegate
CentralSettings Class See Also Send Feedback

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void AuthorWebsiteChangedEventHandler()
Visual Basic
Public Delegate Sub AuthorWebsiteChangedEventHandler

See Also

Grasshopper Namespace


CentralSettings.CanvasFancyWiresChangedEventHandler Delegate

[image]

Grasshopper SDK
CentralSettings..::..CanvasFancyWiresChangedEventHandler Delegate
CentralSettings Class See Also Send Feedback

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void CanvasFancyWiresChangedEventHandler()
Visual Basic
Public Delegate Sub CanvasFancyWiresChangedEventHandler

See Also

Grasshopper Namespace


CentralSettings.CanvasFullNamesChangedEventHandler Delegate

[image]

Grasshopper SDK
CentralSettings..::..CanvasFullNamesChangedEventHandler Delegate
CentralSettings Class See Also Send Feedback

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void CanvasFullNamesChangedEventHandler()
Visual Basic
Public Delegate Sub CanvasFullNamesChangedEventHandler

See Also

Grasshopper Namespace


CentralSettings.CanvasObjectIconsChangedEventHandler Delegate

[image]

Grasshopper SDK
CentralSettings..::..CanvasObjectIconsChangedEventHandler Delegate
CentralSettings Class See Also Send Feedback

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void CanvasObjectIconsChangedEventHandler()
Visual Basic
Public Delegate Sub CanvasObjectIconsChangedEventHandler

See Also

Grasshopper Namespace


CentralSettings.CanvasObsoleteTagsChangedEventHandler Delegate

[image]

Grasshopper SDK
CentralSettings..::..CanvasObsoleteTagsChangedEventHandler Delegate
CentralSettings Class See Also Send Feedback

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void CanvasObsoleteTagsChangedEventHandler()
Visual Basic
Public Delegate Sub CanvasObsoleteTagsChangedEventHandler

See Also

Grasshopper Namespace


CentralSettings.CanvasRadialMenuChangedEventHandler Delegate

[image]

Grasshopper SDK
CentralSettings..::..CanvasRadialMenuChangedEventHandler Delegate
CentralSettings Class See Also Send Feedback

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void CanvasRadialMenuChangedEventHandler()
Visual Basic
Public Delegate Sub CanvasRadialMenuChangedEventHandler

See Also

Grasshopper Namespace


CentralSettings.CanvasZuiZoomLevelChangedEventHandler Delegate

[image]

Grasshopper SDK
CentralSettings..::..CanvasZuiZoomLevelChangedEventHandler Delegate
CentralSettings Class See Also Send Feedback

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void CanvasZuiZoomLevelChangedEventHandler()
Visual Basic
Public Delegate Sub CanvasZuiZoomLevelChangedEventHandler

See Also

Grasshopper Namespace


CentralSettings.ComponentCascadeMenusChangedEventHandler Delegate

[image]

Grasshopper SDK
CentralSettings..::..ComponentCascadeMenusChangedEventHandler Delegate
CentralSettings Class See Also Send Feedback

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void ComponentCascadeMenusChangedEventHandler()
Visual Basic
Public Delegate Sub ComponentCascadeMenusChangedEventHandler

See Also

Grasshopper Namespace


CentralSettings.CreateSolutionUndoRecordChangedEventHandler Delegate

[image]

Grasshopper SDK
CentralSettings..::..CreateSolutionUndoRecordChangedEventHandler Delegate
CentralSettings Class See Also Send Feedback

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void CreateSolutionUndoRecordChangedEventHandler()
Visual Basic
Public Delegate Sub CreateSolutionUndoRecordChangedEventHandler

See Also

Grasshopper Namespace


CentralSettings.FormattingChangedEventHandler Delegate

[image]

Grasshopper SDK
CentralSettings..::..FormattingChangedEventHandler Delegate
CentralSettings Class See Also Send Feedback

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void FormattingChangedEventHandler()
Visual Basic
Public Delegate Sub FormattingChangedEventHandler

See Also

Grasshopper Namespace


CentralSettings.LoadMechanismChangedEventHandler Delegate

[image]

Grasshopper SDK
CentralSettings..::..LoadMechanismChangedEventHandler Delegate
CentralSettings Class See Also Send Feedback

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void LoadMechanismChangedEventHandler(
    string pluginName
)
Visual Basic
Public Delegate Sub LoadMechanismChangedEventHandler ( _
    pluginName As String _
)

Parameters

pluginName
Type: System..::..String

See Also

Grasshopper Namespace


CentralSettings.LoadProtectionChangedEventHandler Delegate

[image]

Grasshopper SDK
CentralSettings..::..LoadProtectionChangedEventHandler Delegate
CentralSettings Class See Also Send Feedback

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void LoadProtectionChangedEventHandler(
    string pluginName
)
Visual Basic
Public Delegate Sub LoadProtectionChangedEventHandler ( _
    pluginName As String _
)

Parameters

pluginName
Type: System..::..String

See Also

Grasshopper Namespace


CentralSettings.PreviewBumpZBufferChangedEventHandler Delegate

[image]

Grasshopper SDK
CentralSettings..::..PreviewBumpZBufferChangedEventHandler Delegate
CentralSettings Class See Also Send Feedback

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void PreviewBumpZBufferChangedEventHandler()
Visual Basic
Public Delegate Sub PreviewBumpZBufferChangedEventHandler

See Also

Grasshopper Namespace


CentralSettings.PreviewMeshEdgesChangedEventHandler Delegate

[image]

Grasshopper SDK
CentralSettings..::..PreviewMeshEdgesChangedEventHandler Delegate
CentralSettings Class See Also Send Feedback

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void PreviewMeshEdgesChangedEventHandler()
Visual Basic
Public Delegate Sub PreviewMeshEdgesChangedEventHandler

See Also

Grasshopper Namespace


CentralSettings.PreviewPlaneRadiusChangedEventHandler Delegate

[image]

Grasshopper SDK
CentralSettings..::..PreviewPlaneRadiusChangedEventHandler Delegate
CentralSettings Class See Also Send Feedback

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void PreviewPlaneRadiusChangedEventHandler()
Visual Basic
Public Delegate Sub PreviewPlaneRadiusChangedEventHandler

See Also

Grasshopper Namespace


CentralSettings.PreviewPointStyleChangedEventHandler Delegate

[image]

Grasshopper SDK
CentralSettings..::..PreviewPointStyleChangedEventHandler Delegate
CentralSettings Class See Also Send Feedback

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void PreviewPointStyleChangedEventHandler()
Visual Basic
Public Delegate Sub PreviewPointStyleChangedEventHandler

See Also

Grasshopper Namespace


CentralSettings.PruderyLevelChangedEventHandler Delegate

[image]

Grasshopper SDK
CentralSettings..::..PruderyLevelChangedEventHandler Delegate
CentralSettings Class See Also Send Feedback

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void PruderyLevelChangedEventHandler()
Visual Basic
Public Delegate Sub PruderyLevelChangedEventHandler

See Also

Grasshopper Namespace


CentralSettings.RibbonAllIconsChangedEventHandler Delegate

[image]

Grasshopper SDK
CentralSettings..::..RibbonAllIconsChangedEventHandler Delegate
CentralSettings Class See Also Send Feedback

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void RibbonAllIconsChangedEventHandler()
Visual Basic
Public Delegate Sub RibbonAllIconsChangedEventHandler

See Also

Grasshopper Namespace


CentralSettings.RibbonDrawTabIconsChangedEventHandler Delegate

[image]

Grasshopper SDK
CentralSettings..::..RibbonDrawTabIconsChangedEventHandler Delegate
CentralSettings Class See Also Send Feedback

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void RibbonDrawTabIconsChangedEventHandler()
Visual Basic
Public Delegate Sub RibbonDrawTabIconsChangedEventHandler

See Also

Grasshopper Namespace


CentralSettings.RibbonSeparatorsChangedEventHandler Delegate

[image]

Grasshopper SDK
CentralSettings..::..RibbonSeparatorsChangedEventHandler Delegate
CentralSettings Class See Also Send Feedback

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void RibbonSeparatorsChangedEventHandler()
Visual Basic
Public Delegate Sub RibbonSeparatorsChangedEventHandler

See Also

Grasshopper Namespace


CentralSettings.RibbonVisibleChangedEventHandler Delegate

[image]

Grasshopper SDK
CentralSettings..::..RibbonVisibleChangedEventHandler Delegate
CentralSettings Class See Also Send Feedback

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void RibbonVisibleChangedEventHandler()
Visual Basic
Public Delegate Sub RibbonVisibleChangedEventHandler

See Also

Grasshopper Namespace


CentralSettings.TemplateFileChangedEventHandler Delegate

[image]

Grasshopper SDK
CentralSettings..::..TemplateFileChangedEventHandler Delegate
CentralSettings Class See Also Send Feedback

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void TemplateFileChangedEventHandler()
Visual Basic
Public Delegate Sub TemplateFileChangedEventHandler

See Also

Grasshopper Namespace


CentralSettings.TooltipWiggleRadiusChangedEventHandler Delegate

[image]

Grasshopper SDK
CentralSettings..::..TooltipWiggleRadiusChangedEventHandler Delegate
CentralSettings Class See Also Send Feedback

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void TooltipWiggleRadiusChangedEventHandler()
Visual Basic
Public Delegate Sub TooltipWiggleRadiusChangedEventHandler

See Also

Grasshopper Namespace


DataTree(T) Class

[image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)> Class
Members See Also Send Feedback
Implements basic Grasshopper Data Tree functionality in an easy-to-use class. This class is used primarily in Scripting components. If you're using the Grasshopper SDK you should consider using the GH_Structure<(Of <(<'T>)>)> class instead.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class DataTree<T> : IGH_DataTree
Visual Basic
Public Class DataTree(Of T) _
    Implements IGH_DataTree

Type Parameters

T
Data type of this class.

Inheritance Hierarchy

System..::..Object
Grasshopper..::..DataTree<(Of <(<'T>)>)>

See Also

DataTree<(Of <(<'T>)>)> Members
Grasshopper Namespace


DataTree(T) Members

[image] [image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)> Members
DataTree<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The DataTree<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | DataTree<(Of <(<'T>)>)>()()()() | Default constructor, create an empty data tree.
Public method | DataTree<(Of <(<'T>)>)>(DataTree<(Of <<'(T>)>>)) | Create a shallow duplicate of another data tree. This means it will create a new tree that contains the same items.
Public method | DataTree<(Of <(<'T>)>)>(IEnumerable<(Of <<'(T>)>>), GH_Path) | Create a tree with a single branch
Public method | DataTree<(Of <(<'T>)>)>(DataTree<(Of <<'(T>)>>), DataTree<(Of <<'(T>)>>)..::..DuplicateT) | Create a true duplicate of another data tree.

Methods

 | Name | Description
Public method | Add(T) | Add (append) a data item to the last branch in the tree. If no branches exist yet, a new one will be created with [path = {0}]
Public method | Add(T, GH_Path) | Add (append) a data item to the specified branch in the tree. If the branch doesn't exist yet, it will be created.
Public method | AddRange(IEnumerable<(Of <<'(T>)>>)) | Add (append) a list of data items to the last branch in the tree. If no branch exists yet, a new one will be created.
Public method | AddRange(IEnumerable<(Of <<'(T>)>>), GH_Path) | Add (append) a list of data items to the specified branch in the tree. If the branch doesn't exist yet, it will be created.
Public method | AllData | Collects all data in the tree in a single list. Does not alter the topology of this tree.
Public method | Branch(Int32) | Gets the list of data which belongs to the branch path at the given index.
Public method | Branch(array<Int32>[]()[][]) | Gets the list of data which belongs to a given Branch path.
Public method | Branch(GH_Path) | Gets the list of data which belongs to a given Branch path.
Public method | Clear | Clears the entire tree.
Public method | ClearData | Removes all data from all branches without affecting the tree topology.
Public method | EnsurePath(array<Int32>[]()[][]) | Create a new branch with the specified path if it doesn't already exists.
Public method | EnsurePath(GH_Path) | Create a new branch with the specified path if it doesn't already exists.
Public method | Flatten | Flattens the entire tree into a single path.
Public method | Graft(Boolean) | Graft all paths in this tree. "Grafting" means appending a new branch for every item in an existing branch.
Public method | Graft(GH_Path, Boolean) | Graft a single path in the tree. "Grafting" means appending a new branch for every item in an existing branch.
Public method | Insert | Insert a data item to the specified branch in the tree. If the branch doesn't exist yet, it will be created.
Public method | ItemExists | Test if the specified path + item index are defined inside the tree.
Public method | MergeTree | Merges two trees together. Data inside similar branches will be merged into single lists and unique paths will be appended. The other tree will not be altered, so beware that data is now shared among both trees.
Public method | Path | Gets the data path at the specified index.
Public method | PathExists(array<Int32>[]()[][]) | Test if the specified path is already defined inside the tree.
Public method | PathExists(GH_Path) | Test if the specified path is already defined inside the tree.
Public method | RemovePath(array<Int32>[]()[][]) | Removes a path and all associated data from the structure. If the path doesn't exist, nothing will happen.
Public method | RemovePath(GH_Path) | Removes a path and all associated data from the structure. If the path doesn't exist, nothing will happen.
Public method | RenumberPaths()()()() | Renumber all paths in this data tree, using a single incrementing path index.
Public method | RenumberPaths(String) | Renumber all paths in this data tree, using a single incrementing path index.
Public method | SimplifyPaths | Simplify the branches in this tree by removing all identical path entries. The length of the shortest path will be indicative of the similarity search depth. If this tree only contains a single branch, the branch wil be simplified to its last index.
Public method | ToString | Creates a brief description of the tree. (Overrides Object..::..ToString()()()().)
Public method | TrimExcess | Trims the excess allocated memory in all branches

Properties

 | Name | Description
Public property | BranchCount | Gets the number of branches defined in this tree.
Public property | Branches | Gets a list of all the data-arrays in this tree
Public property | DataCount | Gets the total number of data items (including nulls) stored in all branches.
Public property | Item | Gets or set the data item at the specified path and index.
Public property | Paths | Gets a list of all the branch paths in this tree.
Public property | TopologyDescription | Gets a description of the topology of the tree. Useful for debugging purposes.

See Also

DataTree<(Of <(<'T>)>)> Class
Grasshopper Namespace


DataTree(T) Constructor

[image] [image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)> Constructor
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DataTree<(Of <(<'T>)>)>()()()() | Default constructor, create an empty data tree.
Public method | DataTree<(Of <(<'T>)>)>(DataTree<(Of <<'(T>)>>)) | Create a shallow duplicate of another data tree. This means it will create a new tree that contains the same items.
Public method | DataTree<(Of <(<'T>)>)>(IEnumerable<(Of <<'(T>)>>), GH_Path) | Create a tree with a single branch
Public method | DataTree<(Of <(<'T>)>)>(DataTree<(Of <<'(T>)>>), DataTree<(Of <<'(T>)>>)..::..DuplicateT) | Create a true duplicate of another data tree.

See Also

DataTree<(Of <(<'T>)>)> Class
DataTree<(Of <(<'T>)>)> Members
Grasshopper Namespace


DataTree(T) Constructor

[image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)> Constructor
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback
Default constructor, create an empty data tree.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public DataTree()
Visual Basic
Public Sub New

See Also

DataTree<(Of <(<'T>)>)> Class
DataTree<(Of <(<'T>)>)> Overload
Grasshopper Namespace


DataTree(T) Constructor (DataTree(T))

[image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)> Constructor (DataTree<(Of <(<'T>)>)>)
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback
Create a shallow duplicate of another data tree. This means it will create a new tree that contains the same items.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public DataTree(
    DataTree<T> other
)
Visual Basic
Public Sub New ( _
    other As DataTree(Of T) _
)

Parameters

other
Type: Grasshopper..::..DataTree <(Of <(<' T >)>)>
Tree to duplicate

See Also

DataTree<(Of <(<'T>)>)> Class
DataTree<(Of <(<'T>)>)> Overload
Grasshopper Namespace


DataTree(T) Constructor (IEnumerable(T), GH_Path)

[image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)> Constructor (IEnumerable<(Of <(<'T>)>)>, GH_Path)
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback
Create a tree with a single branch

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public DataTree(
    IEnumerable<T> data,
    GH_Path root
)
Visual Basic
Public Sub New ( _
    data As IEnumerable(Of T), _
    root As GH_Path _
)

Parameters

data
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' T >)>)>
Data to append to the tree.
root
Type: Grasshopper.Kernel.Data..::..GH_Path
Branch path of first branch. If Null, the default path is used.

See Also

DataTree<(Of <(<'T>)>)> Class
DataTree<(Of <(<'T>)>)> Overload
Grasshopper Namespace


DataTree(T) Constructor (DataTree(T), DataTree(T).DuplicateT)

[image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)> Constructor (DataTree<(Of <(<'T>)>)>, DataTree<(Of <(<'T>)>)>..::..DuplicateT)
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback
Create a true duplicate of another data tree.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public DataTree(
    DataTree<T> other,
    DataTree<(Of <(<'T>)>)>..::..DuplicateT copyDelegate
)
Visual Basic
Public Sub New ( _
    other As DataTree(Of T), _
    copyDelegate As DataTree<(Of <(<'T>)>)>..::..DuplicateT _
)

Parameters

other
Type: Grasshopper..::..DataTree <(Of <(<' T >)>)>
Tree to duplicate
copyDelegate
Type: Grasshopper..::..DataTree<(Of <(<'T>)>)>..::..DuplicateT
Delegate function used to duplicate individual items.

See Also

DataTree<(Of <(<'T>)>)> Class
DataTree<(Of <(<'T>)>)> Overload
Grasshopper Namespace


DataTree(T) Methods

[image] [image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)> Methods
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback

The DataTree<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Add(T) | Add (append) a data item to the last branch in the tree. If no branches exist yet, a new one will be created with [path = {0}]
Public method | Add(T, GH_Path) | Add (append) a data item to the specified branch in the tree. If the branch doesn't exist yet, it will be created.
Public method | AddRange(IEnumerable<(Of <<'(T>)>>)) | Add (append) a list of data items to the last branch in the tree. If no branch exists yet, a new one will be created.
Public method | AddRange(IEnumerable<(Of <<'(T>)>>), GH_Path) | Add (append) a list of data items to the specified branch in the tree. If the branch doesn't exist yet, it will be created.
Public method | AllData | Collects all data in the tree in a single list. Does not alter the topology of this tree.
Public method | Branch(Int32) | Gets the list of data which belongs to the branch path at the given index.
Public method | Branch(array<Int32>[]()[][]) | Gets the list of data which belongs to a given Branch path.
Public method | Branch(GH_Path) | Gets the list of data which belongs to a given Branch path.
Public method | Clear | Clears the entire tree.
Public method | ClearData | Removes all data from all branches without affecting the tree topology.
Public method | EnsurePath(array<Int32>[]()[][]) | Create a new branch with the specified path if it doesn't already exists.
Public method | EnsurePath(GH_Path) | Create a new branch with the specified path if it doesn't already exists.
Public method | Flatten | Flattens the entire tree into a single path.
Public method | Graft(Boolean) | Graft all paths in this tree. "Grafting" means appending a new branch for every item in an existing branch.
Public method | Graft(GH_Path, Boolean) | Graft a single path in the tree. "Grafting" means appending a new branch for every item in an existing branch.
Public method | Insert | Insert a data item to the specified branch in the tree. If the branch doesn't exist yet, it will be created.
Public method | ItemExists | Test if the specified path + item index are defined inside the tree.
Public method | MergeTree | Merges two trees together. Data inside similar branches will be merged into single lists and unique paths will be appended. The other tree will not be altered, so beware that data is now shared among both trees.
Public method | Path | Gets the data path at the specified index.
Public method | PathExists(array<Int32>[]()[][]) | Test if the specified path is already defined inside the tree.
Public method | PathExists(GH_Path) | Test if the specified path is already defined inside the tree.
Public method | RemovePath(array<Int32>[]()[][]) | Removes a path and all associated data from the structure. If the path doesn't exist, nothing will happen.
Public method | RemovePath(GH_Path) | Removes a path and all associated data from the structure. If the path doesn't exist, nothing will happen.
Public method | RenumberPaths()()()() | Renumber all paths in this data tree, using a single incrementing path index.
Public method | RenumberPaths(String) | Renumber all paths in this data tree, using a single incrementing path index.
Public method | SimplifyPaths | Simplify the branches in this tree by removing all identical path entries. The length of the shortest path will be indicative of the similarity search depth. If this tree only contains a single branch, the branch wil be simplified to its last index.
Public method | ToString | Creates a brief description of the tree. (Overrides Object..::..ToString()()()().)
Public method | TrimExcess | Trims the excess allocated memory in all branches

See Also

DataTree<(Of <(<'T>)>)> Class
Grasshopper Namespace


Add Method

[image] [image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..Add Method
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(T) | Add (append) a data item to the last branch in the tree. If no branches exist yet, a new one will be created with [path = {0}]
Public method | Add(T, GH_Path) | Add (append) a data item to the specified branch in the tree. If the branch doesn't exist yet, it will be created.

See Also

DataTree<(Of <(<'T>)>)> Class
DataTree<(Of <(<'T>)>)> Members
Grasshopper Namespace


Add Method (T)

[image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..Add Method (T)
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback
Add (append) a data item to the last branch in the tree. If no branches exist yet, a new one will be created with [path = {0}]

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Add(
    T data
)
Visual Basic
Public Sub Add ( _
    data As T _
)

Parameters

data
Type: T
Data to append.

See Also

DataTree<(Of <(<'T>)>)> Class
Add Overload
Grasshopper Namespace


Add Method (T, GH_Path)

[image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..Add Method (T, GH_Path)
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback
Add (append) a data item to the specified branch in the tree. If the branch doesn't exist yet, it will be created.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Add(
    T data,
    GH_Path path
)
Visual Basic
Public Sub Add ( _
    data As T, _
    path As GH_Path _
)

Parameters

data
Type: T
Data to append.
path
Type: Grasshopper.Kernel.Data..::..GH_Path
Branch path to append to.

See Also

DataTree<(Of <(<'T>)>)> Class
Add Overload
Grasshopper Namespace


AddRange Method

[image] [image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..AddRange Method
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddRange(IEnumerable<(Of <<'(T>)>>)) | Add (append) a list of data items to the last branch in the tree. If no branch exists yet, a new one will be created.
Public method | AddRange(IEnumerable<(Of <<'(T>)>>), GH_Path) | Add (append) a list of data items to the specified branch in the tree. If the branch doesn't exist yet, it will be created.

See Also

DataTree<(Of <(<'T>)>)> Class
DataTree<(Of <(<'T>)>)> Members
Grasshopper Namespace


AddRange Method (IEnumerable(T))

[image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..AddRange Method (IEnumerable<(Of <(<'T>)>)>)
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback
Add (append) a list of data items to the last branch in the tree. If no branch exists yet, a new one will be created.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddRange(
    IEnumerable<T> data
)
Visual Basic
Public Sub AddRange ( _
    data As IEnumerable(Of T) _
)

Parameters

data
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' T >)>)>
Data to append

See Also

DataTree<(Of <(<'T>)>)> Class
AddRange Overload
Grasshopper Namespace


AddRange Method (IEnumerable(T), GH_Path)

[image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..AddRange Method (IEnumerable<(Of <(<'T>)>)>, GH_Path)
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback
Add (append) a list of data items to the specified branch in the tree. If the branch doesn't exist yet, it will be created.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddRange(
    IEnumerable<T> data,
    GH_Path path
)
Visual Basic
Public Sub AddRange ( _
    data As IEnumerable(Of T), _
    path As GH_Path _
)

Parameters

data
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' T >)>)>
Data to append.
path
Type: Grasshopper.Kernel.Data..::..GH_Path
Data path.

See Also

DataTree<(Of <(<'T>)>)> Class
AddRange Overload
Grasshopper Namespace


AllData Method

[image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..AllData Method
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback
Collects all data in the tree in a single list. Does not alter the topology of this tree.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<T> AllData()
Visual Basic
Public Function AllData As List(Of T)

Return Value

A linear list containing all data items in all branches.

See Also

DataTree<(Of <(<'T>)>)> Class
Grasshopper Namespace


Branch Method

[image] [image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..Branch Method
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Branch(Int32) | Gets the list of data which belongs to the branch path at the given index.
Public method | Branch(array<Int32>[]()[][]) | Gets the list of data which belongs to a given Branch path.
Public method | Branch(GH_Path) | Gets the list of data which belongs to a given Branch path.

See Also

DataTree<(Of <(<'T>)>)> Class
DataTree<(Of <(<'T>)>)> Members
Grasshopper Namespace


Branch Method (Int32)

[image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..Branch Method (Int32)
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the list of data which belongs to the branch path at the given index.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<T> Branch(
    int index
)
Visual Basic
Public Function Branch ( _
    index As Integer _
) As List(Of T)

Parameters

index
Type: System..::..Int32
Index of data to retrieve.

Exceptions

Exception | Condition
System..::..IndexOutOfRangeException | Thrown if the index does not represent a valid path.

See Also

DataTree<(Of <(<'T>)>)> Class
Branch Overload
Grasshopper Namespace


Branch Method (Int32[])

[image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..Branch Method (array<Int32>[]()[][])
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the list of data which belongs to a given Branch path.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<T> Branch(
    params int[] path
)
Visual Basic
Public Function Branch ( _
    ParamArray path As Integer() _
) As List(Of T)

Parameters

path
Type: array< System..::..Int32 >[]()[][]
Data path to retrieve.

See Also

DataTree<(Of <(<'T>)>)> Class
Branch Overload
Grasshopper Namespace


Branch Method (GH_Path)

[image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..Branch Method (GH_Path)
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the list of data which belongs to a given Branch path.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<T> Branch(
    GH_Path path
)
Visual Basic
Public Function Branch ( _
    path As GH_Path _
) As List(Of T)

Parameters

path
Type: Grasshopper.Kernel.Data..::..GH_Path
Data path to retrieve.

See Also

DataTree<(Of <(<'T>)>)> Class
Branch Overload
Grasshopper Namespace


Clear Method

[image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..Clear Method
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback
Clears the entire tree.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear

See Also

DataTree<(Of <(<'T>)>)> Class
Grasshopper Namespace


ClearData Method

[image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..ClearData Method
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback
Removes all data from all branches without affecting the tree topology.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ClearData()
Visual Basic
Public Sub ClearData

See Also

DataTree<(Of <(<'T>)>)> Class
Grasshopper Namespace


EnsurePath Method

[image] [image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..EnsurePath Method
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EnsurePath(array<Int32>[]()[][]) | Create a new branch with the specified path if it doesn't already exists.
Public method | EnsurePath(GH_Path) | Create a new branch with the specified path if it doesn't already exists.

See Also

DataTree<(Of <(<'T>)>)> Class
DataTree<(Of <(<'T>)>)> Members
Grasshopper Namespace


EnsurePath Method (Int32[])

[image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..EnsurePath Method (array<Int32>[]()[][])
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback
Create a new branch with the specified path if it doesn't already exists.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<T> EnsurePath(
    params int[] path
)
Visual Basic
Public Function EnsurePath ( _
    ParamArray path As Integer() _
) As List(Of T)

Parameters

path
Type: array< System..::..Int32 >[]()[][]
Path of the branch to ensure.

Return Value

The list that belongs to the specified path.

See Also

DataTree<(Of <(<'T>)>)> Class
EnsurePath Overload
Grasshopper Namespace


EnsurePath Method (GH_Path)

[image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..EnsurePath Method (GH_Path)
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback
Create a new branch with the specified path if it doesn't already exists.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<T> EnsurePath(
    GH_Path path
)
Visual Basic
Public Function EnsurePath ( _
    path As GH_Path _
) As List(Of T)

Parameters

path
Type: Grasshopper.Kernel.Data..::..GH_Path
Path of the branch to ensure.

Return Value

The list that belongs to the specified path.

See Also

DataTree<(Of <(<'T>)>)> Class
EnsurePath Overload
Grasshopper Namespace


Flatten Method

[image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..Flatten Method
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback
Flattens the entire tree into a single path.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Flatten(
    GH_Path flatten_path
)
Visual Basic
Public Sub Flatten ( _
    flatten_path As GH_Path _
)

Parameters

flatten_path
Type: Grasshopper.Kernel.Data..::..GH_Path
The path of the flattened data. If null, the path will be {0}

See Also

DataTree<(Of <(<'T>)>)> Class
Grasshopper Namespace


Graft Method

[image] [image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..Graft Method
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Graft(Boolean) | Graft all paths in this tree. "Grafting" means appending a new branch for every item in an existing branch.
Public method | Graft(GH_Path, Boolean) | Graft a single path in the tree. "Grafting" means appending a new branch for every item in an existing branch.

See Also

DataTree<(Of <(<'T>)>)> Class
DataTree<(Of <(<'T>)>)> Members
Grasshopper Namespace


Graft Method (Boolean)

[image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..Graft Method (Boolean)
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback
Graft all paths in this tree. "Grafting" means appending a new branch for every item in an existing branch.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Graft(
    bool skip_nulls
)
Visual Basic
Public Sub Graft ( _
    skip_nulls As Boolean _
)

Parameters

skip_nulls
Type: System..::..Boolean
If true, null items in the grafted path will not be included in the new tree.

See Also

DataTree<(Of <(<'T>)>)> Class
Graft Overload
Grasshopper Namespace


Graft Method (GH_Path, Boolean)

[image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..Graft Method (GH_Path, Boolean)
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback
Graft a single path in the tree. "Grafting" means appending a new branch for every item in an existing branch.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Graft(
    GH_Path path,
    bool skip_nulls
)
Visual Basic
Public Sub Graft ( _
    path As GH_Path, _
    skip_nulls As Boolean _
)

Parameters

path
Type: Grasshopper.Kernel.Data..::..GH_Path
Path to graft.
skip_nulls
Type: System..::..Boolean
If true, null items in the grafted path will not be included in the new tree.

See Also

DataTree<(Of <(<'T>)>)> Class
Graft Overload
Grasshopper Namespace


Insert Method

[image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..Insert Method
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback
Insert a data item to the specified branch in the tree. If the branch doesn't exist yet, it will be created.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Insert(
    T data,
    GH_Path path,
    int index
)
Visual Basic
Public Sub Insert ( _
    data As T, _
    path As GH_Path, _
    index As Integer _
)

Parameters

data
Type: T
Data to insert.
path
Type: Grasshopper.Kernel.Data..::..GH_Path
Branch path to insert into.
index
Type: System..::..Int32
Insertion index.

See Also

DataTree<(Of <(<'T>)>)> Class
Grasshopper Namespace


ItemExists Method

[image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..ItemExists Method
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback
Test if the specified path + item index are defined inside the tree.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool ItemExists(
    GH_Path path,
    int index
)
Visual Basic
Public Function ItemExists ( _
    path As GH_Path, _
    index As Integer _
) As Boolean

Parameters

path
Type: Grasshopper.Kernel.Data..::..GH_Path
Path to test for.
index
Type: System..::..Int32
Item index to test.

Return Value

True if the specified path exists and contains the specified index.

See Also

DataTree<(Of <(<'T>)>)> Class
Grasshopper Namespace


MergeTree Method

[image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..MergeTree Method
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback
Merges two trees together. Data inside similar branches will be merged into single lists and unique paths will be appended. The other tree will not be altered, so beware that data is now shared among both trees.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void MergeTree(
    DataTree<T> other
)
Visual Basic
Public Sub MergeTree ( _
    other As DataTree(Of T) _
)

Parameters

other
Type: Grasshopper..::..DataTree <(Of <(<' T >)>)>
Tree to merge with.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if other is a null reference.

See Also

DataTree<(Of <(<'T>)>)> Class
Grasshopper Namespace


Path Method

[image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..Path Method
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the data path at the specified index.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Path Path(
    int index
)
Visual Basic
Public Function Path ( _
    index As Integer _
) As GH_Path

Parameters

index
Type: System..::..Int32
Index of path to retrieve.

Exceptions

Exception | Condition
System..::..IndexOutOfRangeException | Thrown if the index does not represent a valid path.

See Also

DataTree<(Of <(<'T>)>)> Class
Grasshopper Namespace


PathExists Method

[image] [image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..PathExists Method
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PathExists(array<Int32>[]()[][]) | Test if the specified path is already defined inside the tree.
Public method | PathExists(GH_Path) | Test if the specified path is already defined inside the tree.

See Also

DataTree<(Of <(<'T>)>)> Class
DataTree<(Of <(<'T>)>)> Members
Grasshopper Namespace


PathExists Method (Int32[])

[image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..PathExists Method (array<Int32>[]()[][])
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback
Test if the specified path is already defined inside the tree.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool PathExists(
    params int[] path
)
Visual Basic
Public Function PathExists ( _
    ParamArray path As Integer() _
) As Boolean

Parameters

path
Type: array< System..::..Int32 >[]()[][]
The branch path to search for.

Return Value

True if the path already exists, false if it doesn't.

See Also

DataTree<(Of <(<'T>)>)> Class
PathExists Overload
Grasshopper Namespace


PathExists Method (GH_Path)

[image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..PathExists Method (GH_Path)
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback
Test if the specified path is already defined inside the tree.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool PathExists(
    GH_Path path
)
Visual Basic
Public Function PathExists ( _
    path As GH_Path _
) As Boolean

Parameters

path
Type: Grasshopper.Kernel.Data..::..GH_Path
The branch path to search for

Return Value

True if the path already exists, false if it doesn't.

See Also

DataTree<(Of <(<'T>)>)> Class
PathExists Overload
Grasshopper Namespace


RemovePath Method

[image] [image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..RemovePath Method
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemovePath(array<Int32>[]()[][]) | Removes a path and all associated data from the structure. If the path doesn't exist, nothing will happen.
Public method | RemovePath(GH_Path) | Removes a path and all associated data from the structure. If the path doesn't exist, nothing will happen.

See Also

DataTree<(Of <(<'T>)>)> Class
DataTree<(Of <(<'T>)>)> Members
Grasshopper Namespace


RemovePath Method (Int32[])

[image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..RemovePath Method (array<Int32>[]()[][])
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback
Removes a path and all associated data from the structure. If the path doesn't exist, nothing will happen.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RemovePath(
    params int[] path
)
Visual Basic
Public Sub RemovePath ( _
    ParamArray path As Integer() _
)

Parameters

path
Type: array< System..::..Int32 >[]()[][]
Path to remove.

See Also

DataTree<(Of <(<'T>)>)> Class
RemovePath Overload
Grasshopper Namespace


RemovePath Method (GH_Path)

[image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..RemovePath Method (GH_Path)
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback
Removes a path and all associated data from the structure. If the path doesn't exist, nothing will happen.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RemovePath(
    GH_Path path
)
Visual Basic
Public Sub RemovePath ( _
    path As GH_Path _
)

Parameters

path
Type: Grasshopper.Kernel.Data..::..GH_Path
Path to remove.

See Also

DataTree<(Of <(<'T>)>)> Class
RemovePath Overload
Grasshopper Namespace


RenumberPaths Method

[image] [image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..RenumberPaths Method
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RenumberPaths()()()() | Renumber all paths in this data tree, using a single incrementing path index.
Public method | RenumberPaths(String) | Renumber all paths in this data tree, using a single incrementing path index.

See Also

DataTree<(Of <(<'T>)>)> Class
DataTree<(Of <(<'T>)>)> Members
Grasshopper Namespace


RenumberPaths Method

[image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..RenumberPaths Method
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback
Renumber all paths in this data tree, using a single incrementing path index.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RenumberPaths()
Visual Basic
Public Sub RenumberPaths

See Also

DataTree<(Of <(<'T>)>)> Class
RenumberPaths Overload
Grasshopper Namespace


RenumberPaths Method (String)

[image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..RenumberPaths Method (String)
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback
Renumber all paths in this data tree, using a single incrementing path index.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RenumberPaths(
    string mask
)
Visual Basic
Public Sub RenumberPaths ( _
    mask As String _
)

Parameters

mask
Type: System..::..String
String formatting mask for paths. Use semi-colons for path index separators and "{i}" as a path index placeholder. Examples:

"{i}" -> {i}

"0;{i}" -> {0;i}

"{i};0;0" -> {i;0;0}

See Also

DataTree<(Of <(<'T>)>)> Class
RenumberPaths Overload
Grasshopper Namespace


SimplifyPaths Method

[image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..SimplifyPaths Method
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback
Simplify the branches in this tree by removing all identical path entries. The length of the shortest path will be indicative of the similarity search depth. If this tree only contains a single branch, the branch wil be simplified to its last index.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SimplifyPaths()
Visual Basic
Public Sub SimplifyPaths

See Also

DataTree<(Of <(<'T>)>)> Class
Grasshopper Namespace


ToString Method

[image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..ToString Method
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback
Creates a brief description of the tree.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String representing the current state of the data tree.

See Also

DataTree<(Of <(<'T>)>)> Class
Grasshopper Namespace


TrimExcess Method

[image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..TrimExcess Method
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback
Trims the excess allocated memory in all branches

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void TrimExcess()
Visual Basic
Public Sub TrimExcess

See Also

DataTree<(Of <(<'T>)>)> Class
Grasshopper Namespace


DataTree(T) Properties

[image] [image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)> Properties
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback

The DataTree<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | BranchCount | Gets the number of branches defined in this tree.
Public property | Branches | Gets a list of all the data-arrays in this tree
Public property | DataCount | Gets the total number of data items (including nulls) stored in all branches.
Public property | Item | Gets or set the data item at the specified path and index.
Public property | Paths | Gets a list of all the branch paths in this tree.
Public property | TopologyDescription | Gets a description of the topology of the tree. Useful for debugging purposes.

See Also

DataTree<(Of <(<'T>)>)> Class
Grasshopper Namespace


BranchCount Property

[image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..BranchCount Property
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the number of branches defined in this tree.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int BranchCount { get; }
Visual Basic
Public ReadOnly Property BranchCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.DataTree`1.BranchCount"]

See Also

DataTree<(Of <(<'T>)>)> Class
Grasshopper Namespace


Branches Property

[image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..Branches Property
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback
Gets a list of all the data-arrays in this tree

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IList<List<T>> Branches { get; }
Visual Basic
Public ReadOnly Property Branches As IList(Of List(Of T))
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.DataTree`1.Branches"]

See Also

DataTree<(Of <(<'T>)>)> Class
Grasshopper Namespace


DataCount Property

[image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..DataCount Property
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the total number of data items (including nulls) stored in all branches.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int DataCount { get; }
Visual Basic
Public ReadOnly Property DataCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.DataTree`1.DataCount"]

See Also

DataTree<(Of <(<'T>)>)> Class
Grasshopper Namespace


Item Property

[image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..Item Property
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback
Gets or set the data item at the specified path and index.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public T this[
    GH_Path path,
    int index
] { get; set; }
Visual Basic
Public Default Property Item ( _
    path As GH_Path, _
    index As Integer _
) As T
    Get
    Set

Parameters

path
Type: Grasshopper.Kernel.Data..::..GH_Path
Path of the data branch to retrieve. Path must be defined in the tree.
index
Type: System..::..Int32
Index of item to retrieve. Index must be defined in the branch.

Field Value

[Missing <value> documentation for "P:Grasshopper.DataTree`1.Item(Grasshopper.Kernel.Data.GH_Path,System.Int32)"]

Exceptions

Exception | Condition
System..::..NullReferenceException | Thrown if the path doesn't exist.
System..::..IndexOutOfRangeException | Thrown if the index does not exist within the path list.

See Also

DataTree<(Of <(<'T>)>)> Class
Grasshopper Namespace


Paths Property

[image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..Paths Property
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback
Gets a list of all the branch paths in this tree.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IList<GH_Path> Paths { get; }
Visual Basic
Public ReadOnly Property Paths As IList(Of GH_Path)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.DataTree`1.Paths"]

See Also

DataTree<(Of <(<'T>)>)> Class
Grasshopper Namespace


TopologyDescription Property

[image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..TopologyDescription Property
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback
Gets a description of the topology of the tree. Useful for debugging purposes.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string TopologyDescription { get; }
Visual Basic
Public ReadOnly Property TopologyDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.DataTree`1.TopologyDescription"]

See Also

DataTree<(Of <(<'T>)>)> Class
Grasshopper Namespace


DataTree(T).DuplicateT Delegate

[image]

Grasshopper SDK
DataTree<(Of <(<'T>)>)>..::..DuplicateT Delegate
DataTree<(Of <(<'T>)>)> Class See Also Send Feedback
Duplication delegate used in the copy constructor. Implementation should never throw exceptions.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate T DuplicateT(
    T original
)
Visual Basic
Public Delegate Function DuplicateT ( _
    original As T _
) As T

Parameters

original
Type: T
Data to copy (might be null)

Return Value

A duplicate of the original or null.

See Also

Grasshopper Namespace


Folders Class

[image]

Grasshopper SDK
Folders Class
Members See Also Send Feedback
Provides access to all standard Grasshopper file and folder locations.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class Folders
Visual Basic
Public NotInheritable Class Folders

Inheritance Hierarchy

System..::..Object
Grasshopper..::..Folders

See Also

Folders Members
Grasshopper Namespace


Folders Members

[image] [image]

Grasshopper SDK
Folders Members
Folders Class Methods Properties See Also Send Feedback

The Folders type exposes the following members.

Methods

Name | Description
ShowFolderInExplorer | Open a specific folder in Windows Explorer.

Properties

Name | Description
AppDataFolder | Gets the appdata folder for Grasshopper.
AssemblyFolders | Gets a list of all the directories from which GHA assemblies are loaded. Note: this is not the same as all folders from which GHA files were loaded at startup. This list includes the default Grasshopper folders, custom GHA folders and the locations provided by Rhino.Runtime.HostUtils.GetAssemblySearchPaths(). Folders which do not contain GHA files are omitted, as are duplicate entries.
AutoSaveFolder | Gets the directory in windows ApplicationData that contains the Grasshopper autosave files.
ClusterFolders | Gets a list of all the directories from which GHCLUSTER files are loaded. GHUSER files are loaded from subfolders as well.
CursorFolder | Gets the directory that contains the cursor files that ship with Grasshopper.
CustomAssemblyFolders | Gets or sets all custom assembly folders.
DefaultAssemblyFolder | Gets the standard directory in windows ApplicationData that contains 3rd party GHA files.
DefaultClusterFolder | Gets the standard directory in windows ApplicationData that contains GHCLUSTER files.
DefaultTemplateFolder | Gets the standard directory in windows ApplicationData that contains template files.
DefaultUserObjectFolder | Gets the standard directory in windows ApplicationData that contains GHUSER files.
Desktop | Gets the desktop directory of the current user profile.
IconFolder | Gets the directory that contains the icon files that ship with Grasshopper.
PluginFolder | Gets the directory that contains the Grasshopper.dll file.
SettingsFolder | Gets the folder into which all Grasshopper settings are stored. This folder might not exist until some settings are actually saved.
TemplateFolders | Gets a list of all the directories from which template files are loaded. Templates are not loaded from subfolders.
ToolsFolder | Obsolete. Gets the directory that contains the additional executables that ship with Grasshopper.
UserObjectFolders | Gets a list of all the directories from which GHUSER files are loaded. GHUSER files are loaded from subfolders as well.

See Also

Folders Class
Grasshopper Namespace


Folders Methods

[image] [image]

Grasshopper SDK
Folders Methods
Folders Class See Also Send Feedback

The Folders type exposes the following members.

Methods

Name | Description
ShowFolderInExplorer | Open a specific folder in Windows Explorer.

See Also

Folders Class
Grasshopper Namespace


ShowFolderInExplorer Method

[image]

Grasshopper SDK
Folders..::..ShowFolderInExplorer Method
Folders Class See Also Send Feedback
Open a specific folder in Windows Explorer.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void ShowFolderInExplorer(
    string folder
)
Visual Basic
Public Shared Sub ShowFolderInExplorer ( _
    folder As String _
)

Parameters

folder
Type: System..::..String

See Also

Folders Class
Grasshopper Namespace


Folders Properties

[image] [image]

Grasshopper SDK
Folders Properties
Folders Class See Also Send Feedback

The Folders type exposes the following members.

Properties

Name | Description
AppDataFolder | Gets the appdata folder for Grasshopper.
AssemblyFolders | Gets a list of all the directories from which GHA assemblies are loaded. Note: this is not the same as all folders from which GHA files were loaded at startup. This list includes the default Grasshopper folders, custom GHA folders and the locations provided by Rhino.Runtime.HostUtils.GetAssemblySearchPaths(). Folders which do not contain GHA files are omitted, as are duplicate entries.
AutoSaveFolder | Gets the directory in windows ApplicationData that contains the Grasshopper autosave files.
ClusterFolders | Gets a list of all the directories from which GHCLUSTER files are loaded. GHUSER files are loaded from subfolders as well.
CursorFolder | Gets the directory that contains the cursor files that ship with Grasshopper.
CustomAssemblyFolders | Gets or sets all custom assembly folders.
DefaultAssemblyFolder | Gets the standard directory in windows ApplicationData that contains 3rd party GHA files.
DefaultClusterFolder | Gets the standard directory in windows ApplicationData that contains GHCLUSTER files.
DefaultTemplateFolder | Gets the standard directory in windows ApplicationData that contains template files.
DefaultUserObjectFolder | Gets the standard directory in windows ApplicationData that contains GHUSER files.
Desktop | Gets the desktop directory of the current user profile.
IconFolder | Gets the directory that contains the icon files that ship with Grasshopper.
PluginFolder | Gets the directory that contains the Grasshopper.dll file.
SettingsFolder | Gets the folder into which all Grasshopper settings are stored. This folder might not exist until some settings are actually saved.
TemplateFolders | Gets a list of all the directories from which template files are loaded. Templates are not loaded from subfolders.
ToolsFolder | Obsolete. Gets the directory that contains the additional executables that ship with Grasshopper.
UserObjectFolders | Gets a list of all the directories from which GHUSER files are loaded. GHUSER files are loaded from subfolders as well.

See Also

Folders Class
Grasshopper Namespace


AppDataFolder Property

[image]

Grasshopper SDK
Folders..::..AppDataFolder Property
Folders Class See Also Send Feedback
Gets the appdata folder for Grasshopper.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string AppDataFolder { get; }
Visual Basic
Public Shared ReadOnly Property AppDataFolder As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Folders.AppDataFolder"]

See Also

Folders Class
Grasshopper Namespace


AssemblyFolders Property

[image]

Grasshopper SDK
Folders..::..AssemblyFolders Property
Folders Class See Also Send Feedback
Gets a list of all the directories from which GHA assemblies are loaded. Note: this is not the same as all folders from which GHA files were loaded at startup. This list includes the default Grasshopper folders, custom GHA folders and the locations provided by Rhino.Runtime.HostUtils.GetAssemblySearchPaths(). Folders which do not contain GHA files are omitted, as are duplicate entries.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static List<GH_AssemblyFolderInfo> AssemblyFolders { get; }
Visual Basic
Public Shared ReadOnly Property AssemblyFolders As List(Of GH_AssemblyFolderInfo)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Folders.AssemblyFolders"]

Return Value

A list of load target directories.

See Also

Folders Class
Grasshopper Namespace


AutoSaveFolder Property

[image]

Grasshopper SDK
Folders..::..AutoSaveFolder Property
Folders Class See Also Send Feedback
Gets the directory in windows ApplicationData that contains the Grasshopper autosave files.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string AutoSaveFolder { get; }
Visual Basic
Public Shared ReadOnly Property AutoSaveFolder As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Folders.AutoSaveFolder"]

Return Value

A directory path.

See Also

Folders Class
Grasshopper Namespace


ClusterFolders Property

[image]

Grasshopper SDK
Folders..::..ClusterFolders Property
Folders Class See Also Send Feedback
Gets a list of all the directories from which GHCLUSTER files are loaded. GHUSER files are loaded from subfolders as well.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static List<string> ClusterFolders { get; }
Visual Basic
Public Shared ReadOnly Property ClusterFolders As List(Of String)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Folders.ClusterFolders"]

Return Value

A list of load target directories.

See Also

Folders Class
Grasshopper Namespace


CursorFolder Property

[image]

Grasshopper SDK
Folders..::..CursorFolder Property
Folders Class See Also Send Feedback
Gets the directory that contains the cursor files that ship with Grasshopper.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string CursorFolder { get; }
Visual Basic
Public Shared ReadOnly Property CursorFolder As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Folders.CursorFolder"]

See Also

Folders Class
Grasshopper Namespace


CustomAssemblyFolders Property

[image]

Grasshopper SDK
Folders..::..CustomAssemblyFolders Property
Folders Class See Also Send Feedback
Gets or sets all custom assembly folders.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static List<string> CustomAssemblyFolders { get; set; }
Visual Basic
Public Shared Property CustomAssemblyFolders As List(Of String)
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Folders.CustomAssemblyFolders"]

See Also

Folders Class
Grasshopper Namespace


DefaultAssemblyFolder Property

[image]

Grasshopper SDK
Folders..::..DefaultAssemblyFolder Property
Folders Class See Also Send Feedback
Gets the standard directory in windows ApplicationData that contains 3rd party GHA files.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string DefaultAssemblyFolder { get; }
Visual Basic
Public Shared ReadOnly Property DefaultAssemblyFolder As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Folders.DefaultAssemblyFolder"]

Return Value

A directory path.

See Also

Folders Class
Grasshopper Namespace


DefaultClusterFolder Property

[image]

Grasshopper SDK
Folders..::..DefaultClusterFolder Property
Folders Class See Also Send Feedback
Gets the standard directory in windows ApplicationData that contains GHCLUSTER files.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string DefaultClusterFolder { get; }
Visual Basic
Public Shared ReadOnly Property DefaultClusterFolder As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Folders.DefaultClusterFolder"]

Return Value

A directory path.

See Also

Folders Class
Grasshopper Namespace


DefaultTemplateFolder Property

[image]

Grasshopper SDK
Folders..::..DefaultTemplateFolder Property
Folders Class See Also Send Feedback
Gets the standard directory in windows ApplicationData that contains template files.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string DefaultTemplateFolder { get; }
Visual Basic
Public Shared ReadOnly Property DefaultTemplateFolder As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Folders.DefaultTemplateFolder"]

Return Value

A directory path.

See Also

Folders Class
Grasshopper Namespace


DefaultUserObjectFolder Property

[image]

Grasshopper SDK
Folders..::..DefaultUserObjectFolder Property
Folders Class See Also Send Feedback
Gets the standard directory in windows ApplicationData that contains GHUSER files.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string DefaultUserObjectFolder { get; }
Visual Basic
Public Shared ReadOnly Property DefaultUserObjectFolder As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Folders.DefaultUserObjectFolder"]

Return Value

A directory path.

See Also

Folders Class
Grasshopper Namespace


Desktop Property

[image]

Grasshopper SDK
Folders..::..Desktop Property
Folders Class See Also Send Feedback
Gets the desktop directory of the current user profile.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string Desktop { get; }
Visual Basic
Public Shared ReadOnly Property Desktop As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Folders.Desktop"]

See Also

Folders Class
Grasshopper Namespace


IconFolder Property

[image]

Grasshopper SDK
Folders..::..IconFolder Property
Folders Class See Also Send Feedback
Gets the directory that contains the icon files that ship with Grasshopper.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string IconFolder { get; }
Visual Basic
Public Shared ReadOnly Property IconFolder As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Folders.IconFolder"]

See Also

Folders Class
Grasshopper Namespace


PluginFolder Property

[image]

Grasshopper SDK
Folders..::..PluginFolder Property
Folders Class See Also Send Feedback
Gets the directory that contains the Grasshopper.dll file.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string PluginFolder { get; }
Visual Basic
Public Shared ReadOnly Property PluginFolder As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Folders.PluginFolder"]

See Also

Folders Class
Grasshopper Namespace


SettingsFolder Property

[image]

Grasshopper SDK
Folders..::..SettingsFolder Property
Folders Class See Also Send Feedback
Gets the folder into which all Grasshopper settings are stored. This folder might not exist until some settings are actually saved.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string SettingsFolder { get; }
Visual Basic
Public Shared ReadOnly Property SettingsFolder As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Folders.SettingsFolder"]

See Also

Folders Class
Grasshopper Namespace


TemplateFolders Property

[image]

Grasshopper SDK
Folders..::..TemplateFolders Property
Folders Class See Also Send Feedback
Gets a list of all the directories from which template files are loaded. Templates are not loaded from subfolders.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static List<string> TemplateFolders { get; }
Visual Basic
Public Shared ReadOnly Property TemplateFolders As List(Of String)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Folders.TemplateFolders"]

Return Value

A list of load target directories.

See Also

Folders Class
Grasshopper Namespace


ToolsFolder Property

[image]

Grasshopper SDK
Folders..::..ToolsFolder Property
Folders Class See Also Send Feedback
Gets the directory that contains the additional executables that ship with Grasshopper.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
[ObsoleteAttribute("There no longer is a Tools folder, all tools are now directly in the PluginFolder")]
public static string ToolsFolder { get; }
Visual Basic
<ObsoleteAttribute("There no longer is a Tools folder, all tools are now directly in the PluginFolder")> _
Public Shared ReadOnly Property ToolsFolder As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Folders.ToolsFolder"]

See Also

Folders Class
Grasshopper Namespace


UserObjectFolders Property

[image]

Grasshopper SDK
Folders..::..UserObjectFolders Property
Folders Class See Also Send Feedback
Gets a list of all the directories from which GHUSER files are loaded. GHUSER files are loaded from subfolders as well.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static List<string> UserObjectFolders { get; }
Visual Basic
Public Shared ReadOnly Property UserObjectFolders As List(Of String)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Folders.UserObjectFolders"]

Return Value

A list of load target directories.

See Also

Folders Class
Grasshopper Namespace


Instances Class

[image]

Grasshopper SDK
Instances Class
Members See Also Send Feedback
Provides access to a bunch of global instances and variables.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class Instances
Visual Basic
Public NotInheritable Class Instances

Inheritance Hierarchy

System..::..Object
Grasshopper..::..Instances

See Also

Instances Members
Grasshopper Namespace


Instances Members

[image] [image]

Grasshopper SDK
Instances Members
Instances Class Methods Properties See Also Send Feedback

The Instances type exposes the following members.

Methods

Name | Description
DocumentEditorFadeIn | Calls the FadeIn() method on the DocumentEditor if it exists.
DocumentEditorFadeOut | Calls the FadeOut() method on the DocumentEditor if it exists.
EnforceInvariantCulture | If the Setting "EnforceInvariantCulture" is set to False, this function does nothing
InvalidateCanvas | Invalidates the currently active Grasshopper Canvas, causing a redraw sometime in the foreseeable future.
RedrawAll | Forces a redraw of both the active canvas and the Rhino viewports.
RedrawCanvas | Forces a redraw of the currently active Grasshopper Canvas.
UnloadAllObjects | Clears and unloads all cached objects. This function is called by the _GrasshopperUnloadPlugin command. Please don't use it.

Properties

Name | Description
ActiveCanvas | Gets the currently active Grasshopper canvas (if any)
AutoHideBanner | Gets or sets a value indicating whether the banner ought to be hidden automatically when loading completes.
AutoShowBanner | Gets or sets a value indicating whether or not the banner will be displayed during the ComponentServer Loading process.
ComponentServer | Gets the ComponentServer instance cached by the Instance Server. The ComponentServer will be instantiated the first time this property accessed. This is a rather involved process during which the Grasshopper Banner will be displayed.
CursorServer | Gets the CursorServer instance cached by the Instance Server. The CursorServer will be instantiated the first time this property is accessed.
DocumentAssociationServer | Gets the Document Association Server instance cached by the Instance Server. The Document Association Server will be instantiated the first time this property accessed.
DocumentEditor | Gets the DocumentEditor of Grasshopper.
DocumentServer | Gets the DocumentServer instance cached by the Instance Server. The DocumentServer will be instantiated the first time this property accessed.
IsComponentServer | Gets whether the Component server has been set.
IsCursorServer | Gets whether the Cursor server has been set.
IsDocumentAssociationServer | Gets whether the Document Association server has been set.
IsDocumentEditor | Gets whether the Document Editor has been set.
IsDocumentEditorOnTopOfViewports | Gets whether the Grasshopper document editor (or any of its child forms) is obscuring a significant part of the Rhino viewports.
IsDocumentServer | Gets whether the Document server has been set.
IsMarkovChain | Gets a value indicating whether or not the MarkovChain has already been initialized.
IsMruServer | Gets a value indicating whether or not the MRU server has been initialized.
MarkovChain | Gets the MarkovChain instance cached by the Instance Server. The Markov chain will be instantiated if it hasn't been already.
MruServer | Gets the MRU_Server instance cached by the Instance Server. The MRU_Server will be instantiated the first time this property accessed.
RcpDockBar | Gets the app-domain wide RCP dockbar instance.
RcpPanel | Gets the app-domain wide RCP panel instance. If it doesn't exist yet it will be created.
Settings | Represents the default settings database. Feel free to add your own settings to this database.

See Also

Instances Class
Grasshopper Namespace


Instances Methods

[image] [image]

Grasshopper SDK
Instances Methods
Instances Class See Also Send Feedback

The Instances type exposes the following members.

Methods

Name | Description
DocumentEditorFadeIn | Calls the FadeIn() method on the DocumentEditor if it exists.
DocumentEditorFadeOut | Calls the FadeOut() method on the DocumentEditor if it exists.
EnforceInvariantCulture | If the Setting "EnforceInvariantCulture" is set to False, this function does nothing
InvalidateCanvas | Invalidates the currently active Grasshopper Canvas, causing a redraw sometime in the foreseeable future.
RedrawAll | Forces a redraw of both the active canvas and the Rhino viewports.
RedrawCanvas | Forces a redraw of the currently active Grasshopper Canvas.
UnloadAllObjects | Clears and unloads all cached objects. This function is called by the _GrasshopperUnloadPlugin command. Please don't use it.

See Also

Instances Class
Grasshopper Namespace


DocumentEditorFadeIn Method

[image]

Grasshopper SDK
Instances..::..DocumentEditorFadeIn Method
Instances Class See Also Send Feedback
Calls the FadeIn() method on the DocumentEditor if it exists.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void DocumentEditorFadeIn()
Visual Basic
Public Shared Sub DocumentEditorFadeIn

See Also

Instances Class
Grasshopper Namespace


DocumentEditorFadeOut Method

[image]

Grasshopper SDK
Instances..::..DocumentEditorFadeOut Method
Instances Class See Also Send Feedback
Calls the FadeOut() method on the DocumentEditor if it exists.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void DocumentEditorFadeOut()
Visual Basic
Public Shared Sub DocumentEditorFadeOut

See Also

Instances Class
Grasshopper Namespace


EnforceInvariantCulture Method

[image]

Grasshopper SDK
Instances..::..EnforceInvariantCulture Method
Instances Class See Also Send Feedback
If the Setting "EnforceInvariantCulture" is set to False, this function does nothing

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void EnforceInvariantCulture()
Visual Basic
Public Shared Sub EnforceInvariantCulture

Remarks

See Also

Instances Class
Grasshopper Namespace


InvalidateCanvas Method

[image]

Grasshopper SDK
Instances..::..InvalidateCanvas Method
Instances Class See Also Send Feedback
Invalidates the currently active Grasshopper Canvas, causing a redraw sometime in the foreseeable future.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void InvalidateCanvas()
Visual Basic
Public Shared Sub InvalidateCanvas

See Also

Instances Class
Grasshopper Namespace


RedrawAll Method

[image]

Grasshopper SDK
Instances..::..RedrawAll Method
Instances Class See Also Send Feedback
Forces a redraw of both the active canvas and the Rhino viewports.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void RedrawAll()
Visual Basic
Public Shared Sub RedrawAll

See Also

Instances Class
Grasshopper Namespace


RedrawCanvas Method

[image]

Grasshopper SDK
Instances..::..RedrawCanvas Method
Instances Class See Also Send Feedback
Forces a redraw of the currently active Grasshopper Canvas.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void RedrawCanvas()
Visual Basic
Public Shared Sub RedrawCanvas

See Also

Instances Class
Grasshopper Namespace


UnloadAllObjects Method

[image]

Grasshopper SDK
Instances..::..UnloadAllObjects Method
Instances Class See Also Send Feedback
Clears and unloads all cached objects. This function is called by the _GrasshopperUnloadPlugin command. Please don't use it.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void UnloadAllObjects()
Visual Basic
Public Shared Sub UnloadAllObjects

See Also

Instances Class
Grasshopper Namespace


Instances Properties

[image] [image]

Grasshopper SDK
Instances Properties
Instances Class See Also Send Feedback

The Instances type exposes the following members.

Properties

Name | Description
ActiveCanvas | Gets the currently active Grasshopper canvas (if any)
AutoHideBanner | Gets or sets a value indicating whether the banner ought to be hidden automatically when loading completes.
AutoShowBanner | Gets or sets a value indicating whether or not the banner will be displayed during the ComponentServer Loading process.
ComponentServer | Gets the ComponentServer instance cached by the Instance Server. The ComponentServer will be instantiated the first time this property accessed. This is a rather involved process during which the Grasshopper Banner will be displayed.
CursorServer | Gets the CursorServer instance cached by the Instance Server. The CursorServer will be instantiated the first time this property is accessed.
DocumentAssociationServer | Gets the Document Association Server instance cached by the Instance Server. The Document Association Server will be instantiated the first time this property accessed.
DocumentEditor | Gets the DocumentEditor of Grasshopper.
DocumentServer | Gets the DocumentServer instance cached by the Instance Server. The DocumentServer will be instantiated the first time this property accessed.
IsComponentServer | Gets whether the Component server has been set.
IsCursorServer | Gets whether the Cursor server has been set.
IsDocumentAssociationServer | Gets whether the Document Association server has been set.
IsDocumentEditor | Gets whether the Document Editor has been set.
IsDocumentEditorOnTopOfViewports | Gets whether the Grasshopper document editor (or any of its child forms) is obscuring a significant part of the Rhino viewports.
IsDocumentServer | Gets whether the Document server has been set.
IsMarkovChain | Gets a value indicating whether or not the MarkovChain has already been initialized.
IsMruServer | Gets a value indicating whether or not the MRU server has been initialized.
MarkovChain | Gets the MarkovChain instance cached by the Instance Server. The Markov chain will be instantiated if it hasn't been already.
MruServer | Gets the MRU_Server instance cached by the Instance Server. The MRU_Server will be instantiated the first time this property accessed.
RcpDockBar | Gets the app-domain wide RCP dockbar instance.
RcpPanel | Gets the app-domain wide RCP panel instance. If it doesn't exist yet it will be created.
Settings | Represents the default settings database. Feel free to add your own settings to this database.

See Also

Instances Class
Grasshopper Namespace


ActiveCanvas Property

[image]

Grasshopper SDK
Instances..::..ActiveCanvas Property
Instances Class See Also Send Feedback
Gets the currently active Grasshopper canvas (if any)

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Canvas ActiveCanvas { get; }
Visual Basic
Public Shared ReadOnly Property ActiveCanvas As GH_Canvas
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Instances.ActiveCanvas"]

See Also

Instances Class
Grasshopper Namespace


AutoHideBanner Property

[image]

Grasshopper SDK
Instances..::..AutoHideBanner Property
Instances Class See Also Send Feedback
Gets or sets a value indicating whether the banner ought to be hidden automatically when loading completes.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool AutoHideBanner { get; set; }
Visual Basic
Public Shared Property AutoHideBanner As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Instances.AutoHideBanner"]

See Also

Instances Class
Grasshopper Namespace


AutoShowBanner Property

[image]

Grasshopper SDK
Instances..::..AutoShowBanner Property
Instances Class See Also Send Feedback
Gets or sets a value indicating whether or not the banner will be displayed during the ComponentServer Loading process.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool AutoShowBanner { get; set; }
Visual Basic
Public Shared Property AutoShowBanner As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Instances.AutoShowBanner"]

See Also

Instances Class
Grasshopper Namespace


ComponentServer Property

[image]

Grasshopper SDK
Instances..::..ComponentServer Property
Instances Class See Also Send Feedback
Gets the ComponentServer instance cached by the Instance Server. The ComponentServer will be instantiated the first time this property accessed. This is a rather involved process during which the Grasshopper Banner will be displayed.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_ComponentServer ComponentServer { get; }
Visual Basic
Public Shared ReadOnly Property ComponentServer As GH_ComponentServer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Instances.ComponentServer"]

See Also

Instances Class
Grasshopper Namespace


CursorServer Property

[image]

Grasshopper SDK
Instances..::..CursorServer Property
Instances Class See Also Send Feedback
Gets the CursorServer instance cached by the Instance Server. The CursorServer will be instantiated the first time this property is accessed.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_CursorServer CursorServer { get; }
Visual Basic
Public Shared ReadOnly Property CursorServer As GH_CursorServer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Instances.CursorServer"]

See Also

Instances Class
Grasshopper Namespace


DocumentAssociationServer Property

[image]

Grasshopper SDK
Instances..::..DocumentAssociationServer Property
Instances Class See Also Send Feedback
Gets the Document Association Server instance cached by the Instance Server. The Document Association Server will be instantiated the first time this property accessed.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_DocumentAssociations DocumentAssociationServer { get; }
Visual Basic
Public Shared ReadOnly Property DocumentAssociationServer As GH_DocumentAssociations
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Instances.DocumentAssociationServer"]

See Also

Instances Class
Grasshopper Namespace


DocumentEditor Property

[image]

Grasshopper SDK
Instances..::..DocumentEditor Property
Instances Class See Also Send Feedback
Gets the DocumentEditor of Grasshopper.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_DocumentEditor DocumentEditor { get; }
Visual Basic
Public Shared ReadOnly Property DocumentEditor As GH_DocumentEditor
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Instances.DocumentEditor"]

See Also

Instances Class
Grasshopper Namespace


DocumentServer Property

[image]

Grasshopper SDK
Instances..::..DocumentServer Property
Instances Class See Also Send Feedback
Gets the DocumentServer instance cached by the Instance Server. The DocumentServer will be instantiated the first time this property accessed.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_DocumentServer DocumentServer { get; }
Visual Basic
Public Shared ReadOnly Property DocumentServer As GH_DocumentServer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Instances.DocumentServer"]

See Also

Instances Class
Grasshopper Namespace


IsComponentServer Property

[image]

Grasshopper SDK
Instances..::..IsComponentServer Property
Instances Class See Also Send Feedback
Gets whether the Component server has been set.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool IsComponentServer { get; }
Visual Basic
Public Shared ReadOnly Property IsComponentServer As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Instances.IsComponentServer"]

See Also

Instances Class
Grasshopper Namespace


IsCursorServer Property

[image]

Grasshopper SDK
Instances..::..IsCursorServer Property
Instances Class See Also Send Feedback
Gets whether the Cursor server has been set.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool IsCursorServer { get; }
Visual Basic
Public Shared ReadOnly Property IsCursorServer As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Instances.IsCursorServer"]

See Also

Instances Class
Grasshopper Namespace


IsDocumentAssociationServer Property

[image]

Grasshopper SDK
Instances..::..IsDocumentAssociationServer Property
Instances Class See Also Send Feedback
Gets whether the Document Association server has been set.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool IsDocumentAssociationServer { get; }
Visual Basic
Public Shared ReadOnly Property IsDocumentAssociationServer As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Instances.IsDocumentAssociationServer"]

See Also

Instances Class
Grasshopper Namespace


IsDocumentEditor Property

[image]

Grasshopper SDK
Instances..::..IsDocumentEditor Property
Instances Class See Also Send Feedback
Gets whether the Document Editor has been set.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool IsDocumentEditor { get; }
Visual Basic
Public Shared ReadOnly Property IsDocumentEditor As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Instances.IsDocumentEditor"]

See Also

Instances Class
Grasshopper Namespace


IsDocumentEditorOnTopOfViewports Property

[image]

Grasshopper SDK
Instances..::..IsDocumentEditorOnTopOfViewports Property
Instances Class See Also Send Feedback
Gets whether the Grasshopper document editor (or any of its child forms) is obscuring a significant part of the Rhino viewports.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool IsDocumentEditorOnTopOfViewports { get; }
Visual Basic
Public Shared ReadOnly Property IsDocumentEditorOnTopOfViewports As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Instances.IsDocumentEditorOnTopOfViewports"]

See Also

Instances Class
Grasshopper Namespace


IsDocumentServer Property

[image]

Grasshopper SDK
Instances..::..IsDocumentServer Property
Instances Class See Also Send Feedback
Gets whether the Document server has been set.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool IsDocumentServer { get; }
Visual Basic
Public Shared ReadOnly Property IsDocumentServer As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Instances.IsDocumentServer"]

See Also

Instances Class
Grasshopper Namespace


IsMarkovChain Property

[image]

Grasshopper SDK
Instances..::..IsMarkovChain Property
Instances Class See Also Send Feedback
Gets a value indicating whether or not the MarkovChain has already been initialized.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool IsMarkovChain { get; }
Visual Basic
Public Shared ReadOnly Property IsMarkovChain As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Instances.IsMarkovChain"]

See Also

Instances Class
Grasshopper Namespace


IsMruServer Property

[image]

Grasshopper SDK
Instances..::..IsMruServer Property
Instances Class See Also Send Feedback
Gets a value indicating whether or not the MRU server has been initialized.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool IsMruServer { get; }
Visual Basic
Public Shared ReadOnly Property IsMruServer As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Instances.IsMruServer"]

See Also

Instances Class
Grasshopper Namespace


MarkovChain Property

[image]

Grasshopper SDK
Instances..::..MarkovChain Property
Instances Class See Also Send Feedback
Gets the MarkovChain instance cached by the Instance Server. The Markov chain will be instantiated if it hasn't been already.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_MarkovChain MarkovChain { get; }
Visual Basic
Public Shared ReadOnly Property MarkovChain As GH_MarkovChain
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Instances.MarkovChain"]

See Also

Instances Class
Grasshopper Namespace


MruServer Property

[image]

Grasshopper SDK
Instances..::..MruServer Property
Instances Class See Also Send Feedback
Gets the MRU_Server instance cached by the Instance Server. The MRU_Server will be instantiated the first time this property accessed.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_MRU_Server MruServer { get; }
Visual Basic
Public Shared ReadOnly Property MruServer As GH_MRU_Server
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Instances.MruServer"]

See Also

Instances Class
Grasshopper Namespace


RcpDockBar Property

[image]

Grasshopper SDK
Instances..::..RcpDockBar Property
Instances Class See Also Send Feedback
Gets the app-domain wide RCP dockbar instance.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Control RcpDockBar { get; }
Visual Basic
Public Shared ReadOnly Property RcpDockBar As GH_Control
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Instances.RcpDockBar"]

See Also

Instances Class
Grasshopper Namespace


RcpPanel Property

[image]

Grasshopper SDK
Instances..::..RcpPanel Property
Instances Class See Also Send Feedback
Gets the app-domain wide RCP panel instance. If it doesn't exist yet it will be created.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_FrontEnd RcpPanel { get; }
Visual Basic
Public Shared ReadOnly Property RcpPanel As GH_FrontEnd
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Instances.RcpPanel"]

See Also

Instances Class
Grasshopper Namespace


Settings Property

[image]

Grasshopper SDK
Instances..::..Settings Property
Instances Class See Also Send Feedback
Represents the default settings database. Feel free to add your own settings to this database.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_SettingsServer Settings { get; }
Visual Basic
Public Shared ReadOnly Property Settings As GH_SettingsServer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Instances.Settings"]

See Also

Instances Class
Grasshopper Namespace


Tracing Class

[image]

Grasshopper SDK
Tracing Class
Members See Also Send Feedback
Class that provides useful static methods for debugging, tracing and messaging.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class Tracing
Visual Basic
Public NotInheritable Class Tracing

Inheritance Hierarchy

System..::..Object
Grasshopper..::..Tracing

See Also

Tracing Members
Grasshopper Namespace


Tracing Members

[image] [image]

Grasshopper SDK
Tracing Members
Tracing Class Methods See Also Send Feedback

The Tracing type exposes the following members.

Methods

Name | Description
Assert(Guid) | Display a typical ASSERT dialog with stack information.
Assert(Guid, Exception) | Display a typical assert dialog with stack information.
Assert(Guid, String) | Display a typical assert dialog with stack information.
Assert(Guid, String, Exception) | Display a typical assert dialog with stack information.
Beep(Int32, Int32) | Sound a beep. This only works if Grasshopper.dll was compiled in Debug mode.
Beep(array<Int32>[]()[][], Int32) | Sound a beep. This only works if Grasshopper.dll was compiled in Debug mode.
Beep(Int32, Int32, UInt32) | Sound a beep. This only works if Grasshopper.dll was compiled in Debug mode.
DebugLogAddEntry | Add a message to the debug log. If the debug log doesn't exist yet, it will be created. This function will only work if the Grasshopper window exists. This method is threadsafe.
DebugLogBeginBlock | Start a new block in the debug data. You must end all your own blocks. This function will only work if the Grasshopper window exists. This method is threadsafe.
DebugLogEndBlock | Start a new block in the debug data. You must end all your own blocks. This function will only work if the Grasshopper window exists. This method is threadsafe.
Ping(String) | Display a permanent message on screen. This only works if the Ping constant is set, which it isn't.
Ping(String, Int32) | Display a permanent message on screen. This only works if the Ping constant is set, which it isn't.

See Also

Tracing Class
Grasshopper Namespace


Tracing Methods

[image] [image]

Grasshopper SDK
Tracing Methods
Tracing Class See Also Send Feedback

The Tracing type exposes the following members.

Methods

Name | Description
Assert(Guid) | Display a typical ASSERT dialog with stack information.
Assert(Guid, Exception) | Display a typical assert dialog with stack information.
Assert(Guid, String) | Display a typical assert dialog with stack information.
Assert(Guid, String, Exception) | Display a typical assert dialog with stack information.
Beep(Int32, Int32) | Sound a beep. This only works if Grasshopper.dll was compiled in Debug mode.
Beep(array<Int32>[]()[][], Int32) | Sound a beep. This only works if Grasshopper.dll was compiled in Debug mode.
Beep(Int32, Int32, UInt32) | Sound a beep. This only works if Grasshopper.dll was compiled in Debug mode.
DebugLogAddEntry | Add a message to the debug log. If the debug log doesn't exist yet, it will be created. This function will only work if the Grasshopper window exists. This method is threadsafe.
DebugLogBeginBlock | Start a new block in the debug data. You must end all your own blocks. This function will only work if the Grasshopper window exists. This method is threadsafe.
DebugLogEndBlock | Start a new block in the debug data. You must end all your own blocks. This function will only work if the Grasshopper window exists. This method is threadsafe.
Ping(String) | Display a permanent message on screen. This only works if the Ping constant is set, which it isn't.
Ping(String, Int32) | Display a permanent message on screen. This only works if the Ping constant is set, which it isn't.

See Also

Tracing Class
Grasshopper Namespace


Assert Method

[image] [image]

Grasshopper SDK
Tracing..::..Assert Method
Tracing Class See Also Send Feedback

Overload List

Name | Description
Assert(Guid) | Display a typical ASSERT dialog with stack information.
Assert(Guid, Exception) | Display a typical assert dialog with stack information.
Assert(Guid, String) | Display a typical assert dialog with stack information.
Assert(Guid, String, Exception) | Display a typical assert dialog with stack information.

See Also

Tracing Class
Tracing Members
Grasshopper Namespace


Assert Method (Guid)

[image]

Grasshopper SDK
Tracing..::..Assert Method (Guid)
Tracing Class See Also Send Feedback
Display a typical ASSERT dialog with stack information.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void Assert(
    Guid assert_id
)
Visual Basic
Public Shared Sub Assert ( _
    assert_id As Guid _
)

Parameters

assert_id
Type: System..::..Guid
ID of assert message. Every assert must have a unique ID so individual messages can be ignored.

See Also

Tracing Class
Assert Overload
Grasshopper Namespace


Assert Method (Guid, Exception)

[image]

Grasshopper SDK
Tracing..::..Assert Method (Guid, Exception)
Tracing Class See Also Send Feedback
Display a typical assert dialog with stack information.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void Assert(
    Guid assert_id,
    Exception exception
)
Visual Basic
Public Shared Sub Assert ( _
    assert_id As Guid, _
    exception As Exception _
)

Parameters

assert_id
Type: System..::..Guid
ID of assert message. Every assert must have a unique ID so individual messages can be ignored.
exception
Type: System..::..Exception
Exception object to harvest further information from.

See Also

Tracing Class
Assert Overload
Grasshopper Namespace


Assert Method (Guid, String)

[image]

Grasshopper SDK
Tracing..::..Assert Method (Guid, String)
Tracing Class See Also Send Feedback
Display a typical assert dialog with stack information.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void Assert(
    Guid assert_id,
    string message
)
Visual Basic
Public Shared Sub Assert ( _
    assert_id As Guid, _
    message As String _
)

Parameters

assert_id
Type: System..::..Guid
ID of assert message. Every assert must have a unique ID so individual messages can be ignored.
message
Type: System..::..String
The text to display as the assert message.

See Also

Tracing Class
Assert Overload
Grasshopper Namespace


Assert Method (Guid, String, Exception)

[image]

Grasshopper SDK
Tracing..::..Assert Method (Guid, String, Exception)
Tracing Class See Also Send Feedback
Display a typical assert dialog with stack information.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void Assert(
    Guid assert_id,
    string message,
    Exception exception
)
Visual Basic
Public Shared Sub Assert ( _
    assert_id As Guid, _
    message As String, _
    exception As Exception _
)

Parameters

assert_id
Type: System..::..Guid
ID of assert message. Every assert must have a unique ID so individual messages can be ignored.
message
Type: System..::..String
The text to display as the assert message.
exception
Type: System..::..Exception
Exception object to harvest further information from.

See Also

Tracing Class
Assert Overload
Grasshopper Namespace


Beep Method

[image] [image]

Grasshopper SDK
Tracing..::..Beep Method
Tracing Class See Also Send Feedback

Overload List

Name | Description
Beep(Int32, Int32) | Sound a beep. This only works if Grasshopper.dll was compiled in Debug mode.
Beep(array<Int32>[]()[][], Int32) | Sound a beep. This only works if Grasshopper.dll was compiled in Debug mode.
Beep(Int32, Int32, UInt32) | Sound a beep. This only works if Grasshopper.dll was compiled in Debug mode.

See Also

Tracing Class
Tracing Members
Grasshopper Namespace


Beep Method (Int32, Int32)

[image]

Grasshopper SDK
Tracing..::..Beep Method (Int32, Int32)
Tracing Class See Also Send Feedback
Sound a beep. This only works if Grasshopper.dll was compiled in Debug mode.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void Beep(
    int Frequency,
    int Duration
)
Visual Basic
Public Shared Sub Beep ( _
    Frequency As Integer, _
    Duration As Integer _
)

Parameters

Frequency
Type: System..::..Int32
Duration
Type: System..::..Int32

See Also

Tracing Class
Beep Overload
Grasshopper Namespace


Beep Method (Int32[], Int32)

[image]

Grasshopper SDK
Tracing..::..Beep Method (array<Int32>[]()[][], Int32)
Tracing Class See Also Send Feedback
Sound a beep. This only works if Grasshopper.dll was compiled in Debug mode.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void Beep(
    int[] Frequencies,
    int Duration
)
Visual Basic
Public Shared Sub Beep ( _
    Frequencies As Integer(), _
    Duration As Integer _
)

Parameters

Frequencies
Type: array< System..::..Int32 >[]()[][]
Duration
Type: System..::..Int32

See Also

Tracing Class
Beep Overload
Grasshopper Namespace


Beep Method (Int32, Int32, UInt32)

[image]

Grasshopper SDK
Tracing..::..Beep Method (Int32, Int32, UInt32)
Tracing Class See Also Send Feedback
Sound a beep. This only works if Grasshopper.dll was compiled in Debug mode.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void Beep(
    int Frequency,
    int Duration,
    uint Repeats
)
Visual Basic
Public Shared Sub Beep ( _
    Frequency As Integer, _
    Duration As Integer, _
    Repeats As UInteger _
)

Parameters

Frequency
Type: System..::..Int32
Duration
Type: System..::..Int32
Repeats
Type: System..::..UInt32

See Also

Tracing Class
Beep Overload
Grasshopper Namespace


DebugLogAddEntry Method

[image]

Grasshopper SDK
Tracing..::..DebugLogAddEntry Method
Tracing Class See Also Send Feedback
Add a message to the debug log. If the debug log doesn't exist yet, it will be created. This function will only work if the Grasshopper window exists. This method is threadsafe.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void DebugLogAddEntry(
    string message
)
Visual Basic
Public Shared Sub DebugLogAddEntry ( _
    message As String _
)

Parameters

message
Type: System..::..String
Message to post.

See Also

Tracing Class
Grasshopper Namespace


DebugLogBeginBlock Method

[image]

Grasshopper SDK
Tracing..::..DebugLogBeginBlock Method
Tracing Class See Also Send Feedback
Start a new block in the debug data. You must end all your own blocks. This function will only work if the Grasshopper window exists. This method is threadsafe.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void DebugLogBeginBlock(
    string name
)
Visual Basic
Public Shared Sub DebugLogBeginBlock ( _
    name As String _
)

Parameters

name
Type: System..::..String
Name of block

See Also

Tracing Class
Grasshopper Namespace


DebugLogEndBlock Method

[image]

Grasshopper SDK
Tracing..::..DebugLogEndBlock Method
Tracing Class See Also Send Feedback
Start a new block in the debug data. You must end all your own blocks. This function will only work if the Grasshopper window exists. This method is threadsafe.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void DebugLogEndBlock()
Visual Basic
Public Shared Sub DebugLogEndBlock

See Also

Tracing Class
Grasshopper Namespace


Ping Method

[image] [image]

Grasshopper SDK
Tracing..::..Ping Method
Tracing Class See Also Send Feedback

Overload List

Name | Description
Ping(String) | Display a permanent message on screen. This only works if the Ping constant is set, which it isn't.
Ping(String, Int32) | Display a permanent message on screen. This only works if the Ping constant is set, which it isn't.

See Also

Tracing Class
Tracing Members
Grasshopper Namespace


Ping Method (String)

[image]

Grasshopper SDK
Tracing..::..Ping Method (String)
Tracing Class See Also Send Feedback
Display a permanent message on screen. This only works if the Ping constant is set, which it isn't.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void Ping(
    string msg
)
Visual Basic
Public Shared Sub Ping ( _
    msg As String _
)

Parameters

msg
Type: System..::..String
Message to display.

See Also

Tracing Class
Ping Overload
Grasshopper Namespace


Ping Method (String, Int32)

[image]

Grasshopper SDK
Tracing..::..Ping Method (String, Int32)
Tracing Class See Also Send Feedback
Display a permanent message on screen. This only works if the Ping constant is set, which it isn't.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void Ping(
    string msg,
    int duration
)
Visual Basic
Public Shared Sub Ping ( _
    msg As String, _
    duration As Integer _
)

Parameters

msg
Type: System..::..String
Message to display.
duration
Type: System..::..Int32
Duration (in milliseconds) of message.

See Also

Tracing Class
Ping Overload
Grasshopper Namespace


Utility Class

[image]

Grasshopper SDK
Utility Class
Members See Also Send Feedback
Class with useful static methods.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class Utility
Visual Basic
Public NotInheritable Class Utility

Inheritance Hierarchy

System..::..Object
Grasshopper..::..Utility

See Also

Utility Members
Grasshopper Namespace


Utility Members

[image] [image]

Grasshopper SDK
Utility Members
Utility Class Methods See Also Send Feedback

The Utility type exposes the following members.

Methods

Name | Description
InvokeGetter | Call a getter property via its name.
InvokeGetterSafe | Call a getter property via its name. No exceptions are thrown.
InvokeMethod(Object, String) | Call a method via its name.
InvokeMethod(Object, String, array<Object>[]()[][]) | Call a method via its name.
InvokeMethodSafe(Object, String) | Call a method via its name. No exceptions are thrown.
InvokeMethodSafe(Object, String, array<Object>[]()[][]) | Call a method via its name. No exceptions are thrown.
InvokeSetter | Call a setter property via its name.
InvokeSetterSafe | Call a setter property via its name. No exceptions are thrown.
LikeOperator | Exposes the VB.NET Like operator as a static method.
TernaryIf<(Of <<'(T>)>>) | Type safe implementation of the IIf conditional statement.

See Also

Utility Class
Grasshopper Namespace


Utility Methods

[image] [image]

Grasshopper SDK
Utility Methods
Utility Class See Also Send Feedback

The Utility type exposes the following members.

Methods

Name | Description
InvokeGetter | Call a getter property via its name.
InvokeGetterSafe | Call a getter property via its name. No exceptions are thrown.
InvokeMethod(Object, String) | Call a method via its name.
InvokeMethod(Object, String, array<Object>[]()[][]) | Call a method via its name.
InvokeMethodSafe(Object, String) | Call a method via its name. No exceptions are thrown.
InvokeMethodSafe(Object, String, array<Object>[]()[][]) | Call a method via its name. No exceptions are thrown.
InvokeSetter | Call a setter property via its name.
InvokeSetterSafe | Call a setter property via its name. No exceptions are thrown.
LikeOperator | Exposes the VB.NET Like operator as a static method.
TernaryIf<(Of <<'(T>)>>) | Type safe implementation of the IIf conditional statement.

See Also

Utility Class
Grasshopper Namespace


InvokeGetter Method

[image]

Grasshopper SDK
Utility..::..InvokeGetter Method
Utility Class See Also Send Feedback
Call a getter property via its name.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Object InvokeGetter(
    Object target,
    string property
)
Visual Basic
Public Shared Function InvokeGetter ( _
    target As Object, _
    property As String _
) As Object

Parameters

target
Type: System..::..Object
Object to invoke on.
property
Type: System..::..String
Name of property to invoke.

Return Value

The return value of the method.

See Also

Utility Class
Grasshopper Namespace


InvokeGetterSafe Method

[image]

Grasshopper SDK
Utility..::..InvokeGetterSafe Method
Utility Class See Also Send Feedback
Call a getter property via its name. No exceptions are thrown.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Object InvokeGetterSafe(
    Object target,
    string property
)
Visual Basic
Public Shared Function InvokeGetterSafe ( _
    target As Object, _
    property As String _
) As Object

Parameters

target
Type: System..::..Object
Object to invoke on.
property
Type: System..::..String
Name of property to invoke.

Return Value

The return value of the method.

See Also

Utility Class
Grasshopper Namespace


InvokeMethod Method

[image] [image]

Grasshopper SDK
Utility..::..InvokeMethod Method
Utility Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(Object, String) | Call a method via its name.
InvokeMethod(Object, String, array<Object>[]()[][]) | Call a method via its name.

See Also

Utility Class
Utility Members
Grasshopper Namespace


InvokeMethod Method (Object, String)

[image]

Grasshopper SDK
Utility..::..InvokeMethod Method (Object, String)
Utility Class See Also Send Feedback
Call a method via its name.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Object InvokeMethod(
    Object target,
    string method
)
Visual Basic
Public Shared Function InvokeMethod ( _
    target As Object, _
    method As String _
) As Object

Parameters

target
Type: System..::..Object
Object to invoke on.
method
Type: System..::..String
Name of method to invoke.

Return Value

The return value of the method.

See Also

Utility Class
InvokeMethod Overload
Grasshopper Namespace


InvokeMethod Method (Object, String, Object[])

[image]

Grasshopper SDK
Utility..::..InvokeMethod Method (Object, String, array<Object>[]()[][])
Utility Class See Also Send Feedback
Call a method via its name.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Object InvokeMethod(
    Object target,
    string method,
    params Object[] params
)
Visual Basic
Public Shared Function InvokeMethod ( _
    target As Object, _
    method As String, _
    ParamArray params As Object() _
) As Object

Parameters

target
Type: System..::..Object
Object to invoke on.
method
Type: System..::..String
Name of method to invoke.
params
Type: array< System..::..Object >[]()[][]
Arguments for method.

Return Value

The return value of the method.

See Also

Utility Class
InvokeMethod Overload
Grasshopper Namespace


InvokeMethodSafe Method

[image] [image]

Grasshopper SDK
Utility..::..InvokeMethodSafe Method
Utility Class See Also Send Feedback

Overload List

Name | Description
InvokeMethodSafe(Object, String) | Call a method via its name. No exceptions are thrown.
InvokeMethodSafe(Object, String, array<Object>[]()[][]) | Call a method via its name. No exceptions are thrown.

See Also

Utility Class
Utility Members
Grasshopper Namespace


InvokeMethodSafe Method (Object, String)

[image]

Grasshopper SDK
Utility..::..InvokeMethodSafe Method (Object, String)
Utility Class See Also Send Feedback
Call a method via its name. No exceptions are thrown.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Object InvokeMethodSafe(
    Object target,
    string method
)
Visual Basic
Public Shared Function InvokeMethodSafe ( _
    target As Object, _
    method As String _
) As Object

Parameters

target
Type: System..::..Object
Object to invoke on.
method
Type: System..::..String
Name of method to invoke.

Return Value

The return value of the method.

See Also

Utility Class
InvokeMethodSafe Overload
Grasshopper Namespace


InvokeMethodSafe Method (Object, String, Object[])

[image]

Grasshopper SDK
Utility..::..InvokeMethodSafe Method (Object, String, array<Object>[]()[][])
Utility Class See Also Send Feedback
Call a method via its name. No exceptions are thrown.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Object InvokeMethodSafe(
    Object target,
    string method,
    params Object[] params
)
Visual Basic
Public Shared Function InvokeMethodSafe ( _
    target As Object, _
    method As String, _
    ParamArray params As Object() _
) As Object

Parameters

target
Type: System..::..Object
Object to invoke on.
method
Type: System..::..String
Name of method to invoke.
params
Type: array< System..::..Object >[]()[][]
Arguments for method.

Return Value

The return value of the method.

See Also

Utility Class
InvokeMethodSafe Overload
Grasshopper Namespace


InvokeSetter Method

[image]

Grasshopper SDK
Utility..::..InvokeSetter Method
Utility Class See Also Send Feedback
Call a setter property via its name.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void InvokeSetter(
    Object target,
    string property,
    Object value
)
Visual Basic
Public Shared Sub InvokeSetter ( _
    target As Object, _
    property As String, _
    value As Object _
)

Parameters

target
Type: System..::..Object
Object to invoke on.
property
Type: System..::..String
Name of property to invoke.
value
Type: System..::..Object

See Also

Utility Class
Grasshopper Namespace


InvokeSetterSafe Method

[image]

Grasshopper SDK
Utility..::..InvokeSetterSafe Method
Utility Class See Also Send Feedback
Call a setter property via its name. No exceptions are thrown.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void InvokeSetterSafe(
    Object target,
    string property,
    Object value
)
Visual Basic
Public Shared Sub InvokeSetterSafe ( _
    target As Object, _
    property As String, _
    value As Object _
)

Parameters

target
Type: System..::..Object
Object to invoke on.
property
Type: System..::..String
Name of property to invoke.
value
Type: System..::..Object

See Also

Utility Class
Grasshopper Namespace


LikeOperator Method

[image]

Grasshopper SDK
Utility..::..LikeOperator Method
Utility Class See Also Send Feedback
Exposes the VB.NET Like operator as a static method.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool LikeOperator(
    string text,
    string pattern
)
Visual Basic
Public Shared Function LikeOperator ( _
    text As String, _
    pattern As String _
) As Boolean

Parameters

text
Type: System..::..String
pattern
Type: System..::..String

See Also

Utility Class
Grasshopper Namespace


TernaryIf(T) Method

[image]

Grasshopper SDK
Utility..::..TernaryIf<(Of <(<'T>)>)> Method
Utility Class See Also Send Feedback
Type safe implementation of the IIf conditional statement.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static T TernaryIf<T>(
    bool condition,
    T A,
    T B
)
Visual Basic
Public Shared Function TernaryIf(Of T) ( _
    condition As Boolean, _
    A As T, _
    B As T _
) As T

Parameters

condition
Type: System..::..Boolean
If True, A is returned.
A
Type: T
Value to return when condition evaluates to true.
B
Type: T
Value to return when condition evaluates to false.

Type Parameters

T
Type of statement.

See Also

Utility Class
Grasshopper Namespace


Versioning Class

[image]

Grasshopper SDK
Versioning Class
Members See Also Send Feedback
Static class that provides information regarding the Grasshopper versioning.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class Versioning
Visual Basic
Public NotInheritable Class Versioning

Inheritance Hierarchy

System..::..Object
Grasshopper..::..Versioning

See Also

Versioning Members
Grasshopper Namespace


Versioning Members

[image] [image]

Grasshopper SDK
Versioning Members
Versioning Class Properties See Also Send Feedback

The Versioning type exposes the following members.

Properties

Name | Description
BuildDate | Gets the build date string. This is the visible release iteration tag. Typically the BuildDate is just the date (MMMM-dd, yyyy), but it may carry a prefix or suffix for special builds.
Version | Gets the version of the current build of Grasshopper.
VersionString | Gets the version of the current build of Grasshopper.

See Also

Versioning Class
Grasshopper Namespace


Versioning Properties

[image] [image]

Grasshopper SDK
Versioning Properties
Versioning Class See Also Send Feedback

The Versioning type exposes the following members.

Properties

Name | Description
BuildDate | Gets the build date string. This is the visible release iteration tag. Typically the BuildDate is just the date (MMMM-dd, yyyy), but it may carry a prefix or suffix for special builds.
Version | Gets the version of the current build of Grasshopper.
VersionString | Gets the version of the current build of Grasshopper.

See Also

Versioning Class
Grasshopper Namespace


BuildDate Property

[image]

Grasshopper SDK
Versioning..::..BuildDate Property
Versioning Class See Also Send Feedback
Gets the build date string. This is the visible release iteration tag. Typically the BuildDate is just the date (MMMM-dd, yyyy), but it may carry a prefix or suffix for special builds.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string BuildDate { get; }
Visual Basic
Public Shared ReadOnly Property BuildDate As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Versioning.BuildDate"]

See Also

Versioning Class
Grasshopper Namespace


Version Property

[image]

Grasshopper SDK
Versioning..::..Version Property
Versioning Class See Also Send Feedback
Gets the version of the current build of Grasshopper.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Version Version { get; }
Visual Basic
Public Shared ReadOnly Property Version As GH_Version
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Versioning.Version"]

See Also

Versioning Class
Grasshopper Namespace


VersionString Property

[image]

Grasshopper SDK
Versioning..::..VersionString Property
Versioning Class See Also Send Feedback
Gets the version of the current build of Grasshopper.

Namespace: Grasshopper
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string VersionString { get; }
Visual Basic
Public Shared ReadOnly Property VersionString As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Versioning.VersionString"]

See Also

Versioning Class
Grasshopper Namespace


Grasshopper.Documentation Namespace

[image]

Grasshopper SDK
Grasshopper.Documentation Namespace
Send Feedback

Classes

 | Class | Description
Public class | GH_ContentCollection | Represents an ordered collection of IGH_Content.
Public class | GH_Format | Represents a piece of formatted content.
Public class | GH_GlossaryItem | Represents a single glossary entry in the Grasshopper help.
Public class | GH_Link | Represents a link to another location in the Help or some external address.
Public class | GH_List | Represents a list of items in the Grasshopper help.
Public class | GH_Paragraph |
Public class | GH_Parser | Provides parsing methods for the Grasshopper Markdown flavour.
Public class | GH_RuntimeFile | Runtime representation of a Grasshopper help file. A GH_RuntimeFile is nothing more than a collection of keywords with associated content. This class does not interpret a file or check its validity, it merely figures out the different content section based on "Keyword:" entries.
Public class | GH_Text | Represents a single string.
Public class | GH_Topic | Represents a single topic in the Grasshopper help.

Interfaces

 | Interface | Description
Public interface | IGH_Content | All parts that make up documentation content must implement this interface.

Enumerations

 | Enumeration | Description
Public enumeration | GH_Audience | Enumerates the pre-defined target audiences used in the Grasshopper documentation.
Public enumeration | GH_Style | Enumerates possible formatting for documentation content.
Public enumeration | GH_Target | Enumerates the possible link targets in Grasshopper documentation.


GH_Audience Enumeration

[image]

Grasshopper SDK
GH_Audience Enumeration
See Also Send Feedback
Enumerates the pre-defined target audiences used in the Grasshopper documentation.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_Audience
Visual Basic
Public Enumeration GH_Audience

Members

Member name | Value | Description
Beginner | 0 |
Intermediate | 1 |
Expert | 2 |

See Also

Grasshopper.Documentation Namespace


GH_ContentCollection Class

[image]

Grasshopper SDK
GH_ContentCollection Class
Members See Also Send Feedback
Represents an ordered collection of IGH_Content.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_ContentCollection : IGH_Content
Visual Basic
Public Class GH_ContentCollection _
    Implements IGH_Content

Inheritance Hierarchy

System..::..Object
Grasshopper.Documentation..::..GH_ContentCollection

See Also

GH_ContentCollection Members
Grasshopper.Documentation Namespace


GH_ContentCollection Members

[image] [image]

Grasshopper SDK
GH_ContentCollection Members
GH_ContentCollection Class Constructors Methods Properties See Also Send Feedback

The GH_ContentCollection type exposes the following members.

Constructors

 | Name | Description
Public method | GH_ContentCollection | Initializes a new instance of the GH_ContentCollection class

Methods

 | Name | Description
Public method | ToString | (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Content |
Public property | Count |
Public property | Item |

See Also

GH_ContentCollection Class
Grasshopper.Documentation Namespace


GH_ContentCollection Constructor

[image]

Grasshopper SDK
GH_ContentCollection Constructor
GH_ContentCollection Class See Also Send Feedback
Initializes a new instance of the GH_ContentCollection class

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ContentCollection()
Visual Basic
Public Sub New

See Also

GH_ContentCollection Class
Grasshopper.Documentation Namespace


GH_ContentCollection Methods

[image] [image]

Grasshopper SDK
GH_ContentCollection Methods
GH_ContentCollection Class See Also Send Feedback

The GH_ContentCollection type exposes the following members.

Methods

 | Name | Description
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

GH_ContentCollection Class
Grasshopper.Documentation Namespace


ToString Method

[image]

Grasshopper SDK
GH_ContentCollection..::..ToString Method
GH_ContentCollection Class See Also Send Feedback

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_ContentCollection Class
Grasshopper.Documentation Namespace


GH_ContentCollection Properties

[image] [image]

Grasshopper SDK
GH_ContentCollection Properties
GH_ContentCollection Class See Also Send Feedback

The GH_ContentCollection type exposes the following members.

Properties

 | Name | Description
Public property | Content |
Public property | Count |
Public property | Item |

See Also

GH_ContentCollection Class
Grasshopper.Documentation Namespace


Content Property

[image]

Grasshopper SDK
GH_ContentCollection..::..Content Property
GH_ContentCollection Class See Also Send Feedback

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<IGH_Content> Content { get; }
Visual Basic
Public ReadOnly Property Content As List(Of IGH_Content)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Documentation.GH_ContentCollection.Content"]

See Also

GH_ContentCollection Class
Grasshopper.Documentation Namespace


Count Property

[image]

Grasshopper SDK
GH_ContentCollection..::..Count Property
GH_ContentCollection Class See Also Send Feedback

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Documentation.GH_ContentCollection.Count"]

See Also

GH_ContentCollection Class
Grasshopper.Documentation Namespace


Item Property

[image]

Grasshopper SDK
GH_ContentCollection..::..Item Property
GH_ContentCollection Class See Also Send Feedback

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_Content this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    index As Integer _
) As IGH_Content
    Get

Parameters

index
Type: System..::..Int32

Field Value

[Missing <value> documentation for "P:Grasshopper.Documentation.GH_ContentCollection.Item(System.Int32)"]

See Also

GH_ContentCollection Class
Grasshopper.Documentation Namespace


GH_Format Class

[image]

Grasshopper SDK
GH_Format Class
Members See Also Send Feedback
Represents a piece of formatted content.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Format : IGH_Content
Visual Basic
Public Class GH_Format _
    Implements IGH_Content

Inheritance Hierarchy

System..::..Object
Grasshopper.Documentation..::..GH_Format

See Also

GH_Format Members
Grasshopper.Documentation Namespace


GH_Format Members

[image] [image]

Grasshopper SDK
GH_Format Members
GH_Format Class Methods Properties See Also Send Feedback

The GH_Format type exposes the following members.

Methods

 | Name | Description
 | Create(String, GH_Style) |
 | Create(IGH_Content, GH_Style) |
Public method | ToString | (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Content |
Public property | Style |

See Also

GH_Format Class
Grasshopper.Documentation Namespace


GH_Format Methods

[image] [image]

Grasshopper SDK
GH_Format Methods
GH_Format Class See Also Send Feedback

The GH_Format type exposes the following members.

Methods

 | Name | Description
 | Create(String, GH_Style) |
 | Create(IGH_Content, GH_Style) |
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

GH_Format Class
Grasshopper.Documentation Namespace


Create Method

[image] [image]

Grasshopper SDK
GH_Format..::..Create Method
GH_Format Class See Also Send Feedback

Overload List

Name | Description
Create(String, GH_Style) |
Create(IGH_Content, GH_Style) |

See Also

GH_Format Class
GH_Format Members
Grasshopper.Documentation Namespace


Create Method (String, GH_Style)

[image]

Grasshopper SDK
GH_Format..::..Create Method (String, GH_Style)
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Format Create(
    string content,
    GH_Style style
)
Visual Basic
Public Shared Function Create ( _
    content As String, _
    style As GH_Style _
) As GH_Format

Parameters

content
Type: System..::..String
style
Type: Grasshopper.Documentation..::..GH_Style

See Also

GH_Format Class
Create Overload
Grasshopper.Documentation Namespace


Create Method (IGH_Content, GH_Style)

[image]

Grasshopper SDK
GH_Format..::..Create Method (IGH_Content, GH_Style)
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Format Create(
    IGH_Content content,
    GH_Style style
)
Visual Basic
Public Shared Function Create ( _
    content As IGH_Content, _
    style As GH_Style _
) As GH_Format

Parameters

content
Type: Grasshopper.Documentation..::..IGH_Content
style
Type: Grasshopper.Documentation..::..GH_Style

See Also

GH_Format Class
Create Overload
Grasshopper.Documentation Namespace


ToString Method

[image]

Grasshopper SDK
GH_Format..::..ToString Method
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_Format Class
Grasshopper.Documentation Namespace


GH_Format Properties

[image] [image]

Grasshopper SDK
GH_Format Properties
GH_Format Class See Also Send Feedback

The GH_Format type exposes the following members.

Properties

 | Name | Description
Public property | Content |
Public property | Style |

See Also

GH_Format Class
Grasshopper.Documentation Namespace


Content Property

[image]

Grasshopper SDK
GH_Format..::..Content Property
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_Content Content { get; }
Visual Basic
Public ReadOnly Property Content As IGH_Content
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Documentation.GH_Format.Content"]

See Also

GH_Format Class
Grasshopper.Documentation Namespace


Style Property

[image]

Grasshopper SDK
GH_Format..::..Style Property
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Style Style { get; }
Visual Basic
Public ReadOnly Property Style As GH_Style
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Documentation.GH_Format.Style"]

See Also

GH_Format Class
Grasshopper.Documentation Namespace


GH_GlossaryItem Class

[image]

Grasshopper SDK
GH_GlossaryItem Class
Members See Also Send Feedback
Represents a single glossary entry in the Grasshopper help.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_GlossaryItem
Visual Basic
Public Class GH_GlossaryItem

Inheritance Hierarchy

System..::..Object
Grasshopper.Documentation..::..GH_GlossaryItem

See Also

GH_GlossaryItem Members
Grasshopper.Documentation Namespace


GH_GlossaryItem Members

[image] [image]

Grasshopper SDK
GH_GlossaryItem Members
GH_GlossaryItem Class Methods Properties See Also Send Feedback

The GH_GlossaryItem type exposes the following members.

Methods

Name | Description
ParseFile | Parse a *.glossary file and return a glossary entry.

Properties

 | Name | Description
Public property | Author | Gets the author of this glossary entry. This field is optional and may not be defined.
Public property | Contact | Gets the contact information for the glossary entry author. This field is optional and may not be defined.
Public property | Descriptions | Gets the description (definition) for this glossary entry.
Public property | Path | Gets the source file for this glossary entry.
Public property | Pronunciation | Gets the pronunciation guide to the word. This field is optional and may not be defined.
Public property | Synonyms | Gets the synonyms for this glossary entry.
Public property | Word | Gets the word this glossary entry is about.

See Also

GH_GlossaryItem Class
Grasshopper.Documentation Namespace


GH_GlossaryItem Methods

[image] [image]

Grasshopper SDK
GH_GlossaryItem Methods
GH_GlossaryItem Class See Also Send Feedback

The GH_GlossaryItem type exposes the following members.

Methods

Name | Description
ParseFile | Parse a *.glossary file and return a glossary entry.

See Also

GH_GlossaryItem Class
Grasshopper.Documentation Namespace


ParseFile Method

[image]

Grasshopper SDK
GH_GlossaryItem..::..ParseFile Method
GH_GlossaryItem Class See Also Send Feedback
Parse a *.glossary file and return a glossary entry.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_GlossaryItem ParseFile(
    string path
)
Visual Basic
Public Shared Function ParseFile ( _
    path As String _
) As GH_GlossaryItem

Parameters

path
Type: System..::..String
File to parse.

Return Value

The glossary entry defined by the file. This function always returns a valid glossary or it throws an exception.

See Also

GH_GlossaryItem Class
Grasshopper.Documentation Namespace


GH_GlossaryItem Properties

[image] [image]

Grasshopper SDK
GH_GlossaryItem Properties
GH_GlossaryItem Class See Also Send Feedback

The GH_GlossaryItem type exposes the following members.

Properties

 | Name | Description
Public property | Author | Gets the author of this glossary entry. This field is optional and may not be defined.
Public property | Contact | Gets the contact information for the glossary entry author. This field is optional and may not be defined.
Public property | Descriptions | Gets the description (definition) for this glossary entry.
Public property | Path | Gets the source file for this glossary entry.
Public property | Pronunciation | Gets the pronunciation guide to the word. This field is optional and may not be defined.
Public property | Synonyms | Gets the synonyms for this glossary entry.
Public property | Word | Gets the word this glossary entry is about.

See Also

GH_GlossaryItem Class
Grasshopper.Documentation Namespace


Author Property

[image]

Grasshopper SDK
GH_GlossaryItem..::..Author Property
GH_GlossaryItem Class See Also Send Feedback
Gets the author of this glossary entry. This field is optional and may not be defined.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_Content Author { get; }
Visual Basic
Public ReadOnly Property Author As IGH_Content
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Documentation.GH_GlossaryItem.Author"]

See Also

GH_GlossaryItem Class
Grasshopper.Documentation Namespace


Contact Property

[image]

Grasshopper SDK
GH_GlossaryItem..::..Contact Property
GH_GlossaryItem Class See Also Send Feedback
Gets the contact information for the glossary entry author. This field is optional and may not be defined.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_Content Contact { get; }
Visual Basic
Public ReadOnly Property Contact As IGH_Content
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Documentation.GH_GlossaryItem.Contact"]

See Also

GH_GlossaryItem Class
Grasshopper.Documentation Namespace


Descriptions Property

[image]

Grasshopper SDK
GH_GlossaryItem..::..Descriptions Property
GH_GlossaryItem Class See Also Send Feedback
Gets the description (definition) for this glossary entry.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<IGH_Content> Descriptions { get; }
Visual Basic
Public ReadOnly Property Descriptions As List(Of IGH_Content)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Documentation.GH_GlossaryItem.Descriptions"]

See Also

GH_GlossaryItem Class
Grasshopper.Documentation Namespace


Path Property

[image]

Grasshopper SDK
GH_GlossaryItem..::..Path Property
GH_GlossaryItem Class See Also Send Feedback
Gets the source file for this glossary entry.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Path { get; }
Visual Basic
Public ReadOnly Property Path As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Documentation.GH_GlossaryItem.Path"]

See Also

GH_GlossaryItem Class
Grasshopper.Documentation Namespace


Pronunciation Property

[image]

Grasshopper SDK
GH_GlossaryItem..::..Pronunciation Property
GH_GlossaryItem Class See Also Send Feedback
Gets the pronunciation guide to the word. This field is optional and may not be defined.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_Content Pronunciation { get; }
Visual Basic
Public ReadOnly Property Pronunciation As IGH_Content
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Documentation.GH_GlossaryItem.Pronunciation"]

See Also

GH_GlossaryItem Class
Grasshopper.Documentation Namespace


Synonyms Property

[image]

Grasshopper SDK
GH_GlossaryItem..::..Synonyms Property
GH_GlossaryItem Class See Also Send Feedback
Gets the synonyms for this glossary entry.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public ReadOnlyCollection<string> Synonyms { get; }
Visual Basic
Public ReadOnly Property Synonyms As ReadOnlyCollection(Of String)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Documentation.GH_GlossaryItem.Synonyms"]

See Also

GH_GlossaryItem Class
Grasshopper.Documentation Namespace


Word Property

[image]

Grasshopper SDK
GH_GlossaryItem..::..Word Property
GH_GlossaryItem Class See Also Send Feedback
Gets the word this glossary entry is about.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Word { get; }
Visual Basic
Public ReadOnly Property Word As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Documentation.GH_GlossaryItem.Word"]

See Also

GH_GlossaryItem Class
Grasshopper.Documentation Namespace


GH_Link Class

[image]

Grasshopper SDK
GH_Link Class
Members See Also Send Feedback
Represents a link to another location in the Help or some external address.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Link : IGH_Content
Visual Basic
Public Class GH_Link _
    Implements IGH_Content

Inheritance Hierarchy

System..::..Object
Grasshopper.Documentation..::..GH_Link

See Also

GH_Link Members
Grasshopper.Documentation Namespace


GH_Link Members

[image] [image]

Grasshopper SDK
GH_Link Members
GH_Link Class Methods Properties See Also Send Feedback

The GH_Link type exposes the following members.

Methods

 | Name | Description
 | CreateExternalLink(String, String) |
 | CreateExternalLink(String, String, String) |
 | CreateGlossaryLink(String) |
 | CreateGlossaryLink(String, String) |
 | CreateSharedLink(String, String) |
 | CreateSharedLink(String, String, String) |
 | CreateTopicLink(String, String) |
 | CreateTopicLink(String, String, String) |
Public method | ToString | (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Destination | Gets the link target.
Public property | IsSharedLink | Gets whether this link is a shared link. A shared link should not have text but it should have a non-empty LinkId.
Public property | LinkId | Gets the link ID. The link ID is only used for shared links.
Public property | Target | Gets the link type.
Public property | Text | Gets the list text.
Public property | Tooltip | Gets the link tooltip text.

See Also

GH_Link Class
Grasshopper.Documentation Namespace


GH_Link Methods

[image] [image]

Grasshopper SDK
GH_Link Methods
GH_Link Class See Also Send Feedback

The GH_Link type exposes the following members.

Methods

 | Name | Description
 | CreateExternalLink(String, String) |
 | CreateExternalLink(String, String, String) |
 | CreateGlossaryLink(String) |
 | CreateGlossaryLink(String, String) |
 | CreateSharedLink(String, String) |
 | CreateSharedLink(String, String, String) |
 | CreateTopicLink(String, String) |
 | CreateTopicLink(String, String, String) |
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

GH_Link Class
Grasshopper.Documentation Namespace


CreateExternalLink Method

[image] [image]

Grasshopper SDK
GH_Link..::..CreateExternalLink Method
GH_Link Class See Also Send Feedback

Overload List

Name | Description
CreateExternalLink(String, String) |
CreateExternalLink(String, String, String) |

See Also

GH_Link Class
GH_Link Members
Grasshopper.Documentation Namespace


CreateExternalLink Method (String, String)

[image]

Grasshopper SDK
GH_Link..::..CreateExternalLink Method (String, String)
GH_Link Class See Also Send Feedback

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Link CreateExternalLink(
    string text,
    string url
)
Visual Basic
Public Shared Function CreateExternalLink ( _
    text As String, _
    url As String _
) As GH_Link

Parameters

text
Type: System..::..String
url
Type: System..::..String

See Also

GH_Link Class
CreateExternalLink Overload
Grasshopper.Documentation Namespace


CreateExternalLink Method (String, String, String)

[image]

Grasshopper SDK
GH_Link..::..CreateExternalLink Method (String, String, String)
GH_Link Class See Also Send Feedback

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Link CreateExternalLink(
    string text,
    string url,
    string tooltip
)
Visual Basic
Public Shared Function CreateExternalLink ( _
    text As String, _
    url As String, _
    tooltip As String _
) As GH_Link

Parameters

text
Type: System..::..String
url
Type: System..::..String
tooltip
Type: System..::..String

See Also

GH_Link Class
CreateExternalLink Overload
Grasshopper.Documentation Namespace


CreateGlossaryLink Method

[image] [image]

Grasshopper SDK
GH_Link..::..CreateGlossaryLink Method
GH_Link Class See Also Send Feedback

Overload List

Name | Description
CreateGlossaryLink(String) |
CreateGlossaryLink(String, String) |

See Also

GH_Link Class
GH_Link Members
Grasshopper.Documentation Namespace


CreateGlossaryLink Method (String)

[image]

Grasshopper SDK
GH_Link..::..CreateGlossaryLink Method (String)
GH_Link Class See Also Send Feedback

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Link CreateGlossaryLink(
    string text
)
Visual Basic
Public Shared Function CreateGlossaryLink ( _
    text As String _
) As GH_Link

Parameters

text
Type: System..::..String

See Also

GH_Link Class
CreateGlossaryLink Overload
Grasshopper.Documentation Namespace


CreateGlossaryLink Method (String, String)

[image]

Grasshopper SDK
GH_Link..::..CreateGlossaryLink Method (String, String)
GH_Link Class See Also Send Feedback

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Link CreateGlossaryLink(
    string text,
    string glossaryEntry
)
Visual Basic
Public Shared Function CreateGlossaryLink ( _
    text As String, _
    glossaryEntry As String _
) As GH_Link

Parameters

text
Type: System..::..String
glossaryEntry
Type: System..::..String

See Also

GH_Link Class
CreateGlossaryLink Overload
Grasshopper.Documentation Namespace


CreateSharedLink Method

[image] [image]

Grasshopper SDK
GH_Link..::..CreateSharedLink Method
GH_Link Class See Also Send Feedback

Overload List

Name | Description
CreateSharedLink(String, String) |
CreateSharedLink(String, String, String) |

See Also

GH_Link Class
GH_Link Members
Grasshopper.Documentation Namespace


CreateSharedLink Method (String, String)

[image]

Grasshopper SDK
GH_Link..::..CreateSharedLink Method (String, String)
GH_Link Class See Also Send Feedback

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Link CreateSharedLink(
    string linkId,
    string target
)
Visual Basic
Public Shared Function CreateSharedLink ( _
    linkId As String, _
    target As String _
) As GH_Link

Parameters

linkId
Type: System..::..String
target
Type: System..::..String

See Also

GH_Link Class
CreateSharedLink Overload
Grasshopper.Documentation Namespace


CreateSharedLink Method (String, String, String)

[image]

Grasshopper SDK
GH_Link..::..CreateSharedLink Method (String, String, String)
GH_Link Class See Also Send Feedback

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Link CreateSharedLink(
    string linkId,
    string target,
    string tooltip
)
Visual Basic
Public Shared Function CreateSharedLink ( _
    linkId As String, _
    target As String, _
    tooltip As String _
) As GH_Link

Parameters

linkId
Type: System..::..String
target
Type: System..::..String
tooltip
Type: System..::..String

See Also

GH_Link Class
CreateSharedLink Overload
Grasshopper.Documentation Namespace


CreateTopicLink Method

[image] [image]

Grasshopper SDK
GH_Link..::..CreateTopicLink Method
GH_Link Class See Also Send Feedback

Overload List

Name | Description
CreateTopicLink(String, String) |
CreateTopicLink(String, String, String) |

See Also

GH_Link Class
GH_Link Members
Grasshopper.Documentation Namespace


CreateTopicLink Method (String, String)

[image]

Grasshopper SDK
GH_Link..::..CreateTopicLink Method (String, String)
GH_Link Class See Also Send Feedback

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Link CreateTopicLink(
    string text,
    string topicName
)
Visual Basic
Public Shared Function CreateTopicLink ( _
    text As String, _
    topicName As String _
) As GH_Link

Parameters

text
Type: System..::..String
topicName
Type: System..::..String

See Also

GH_Link Class
CreateTopicLink Overload
Grasshopper.Documentation Namespace


CreateTopicLink Method (String, String, String)

[image]

Grasshopper SDK
GH_Link..::..CreateTopicLink Method (String, String, String)
GH_Link Class See Also Send Feedback

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Link CreateTopicLink(
    string text,
    string topicName,
    string tooltip
)
Visual Basic
Public Shared Function CreateTopicLink ( _
    text As String, _
    topicName As String, _
    tooltip As String _
) As GH_Link

Parameters

text
Type: System..::..String
topicName
Type: System..::..String
tooltip
Type: System..::..String

See Also

GH_Link Class
CreateTopicLink Overload
Grasshopper.Documentation Namespace


ToString Method

[image]

Grasshopper SDK
GH_Link..::..ToString Method
GH_Link Class See Also Send Feedback

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_Link Class
Grasshopper.Documentation Namespace


GH_Link Properties

[image] [image]

Grasshopper SDK
GH_Link Properties
GH_Link Class See Also Send Feedback

The GH_Link type exposes the following members.

Properties

 | Name | Description
Public property | Destination | Gets the link target.
Public property | IsSharedLink | Gets whether this link is a shared link. A shared link should not have text but it should have a non-empty LinkId.
Public property | LinkId | Gets the link ID. The link ID is only used for shared links.
Public property | Target | Gets the link type.
Public property | Text | Gets the list text.
Public property | Tooltip | Gets the link tooltip text.

See Also

GH_Link Class
Grasshopper.Documentation Namespace


Destination Property

[image]

Grasshopper SDK
GH_Link..::..Destination Property
GH_Link Class See Also Send Feedback
Gets the link target.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Destination { get; }
Visual Basic
Public ReadOnly Property Destination As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Documentation.GH_Link.Destination"]

See Also

GH_Link Class
Grasshopper.Documentation Namespace


IsSharedLink Property

[image]

Grasshopper SDK
GH_Link..::..IsSharedLink Property
GH_Link Class See Also Send Feedback
Gets whether this link is a shared link. A shared link should not have text but it should have a non-empty LinkId.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsSharedLink { get; }
Visual Basic
Public ReadOnly Property IsSharedLink As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Documentation.GH_Link.IsSharedLink"]

See Also

GH_Link Class
Grasshopper.Documentation Namespace


LinkId Property

[image]

Grasshopper SDK
GH_Link..::..LinkId Property
GH_Link Class See Also Send Feedback
Gets the link ID. The link ID is only used for shared links.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string LinkId { get; }
Visual Basic
Public ReadOnly Property LinkId As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Documentation.GH_Link.LinkId"]

See Also

GH_Link Class
Grasshopper.Documentation Namespace


Target Property

[image]

Grasshopper SDK
GH_Link..::..Target Property
GH_Link Class See Also Send Feedback
Gets the link type.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Target Target { get; }
Visual Basic
Public ReadOnly Property Target As GH_Target
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Documentation.GH_Link.Target"]

See Also

GH_Link Class
Grasshopper.Documentation Namespace


Text Property

[image]

Grasshopper SDK
GH_Link..::..Text Property
GH_Link Class See Also Send Feedback
Gets the list text.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_Content Text { get; }
Visual Basic
Public ReadOnly Property Text As IGH_Content
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Documentation.GH_Link.Text"]

See Also

GH_Link Class
Grasshopper.Documentation Namespace


Tooltip Property

[image]

Grasshopper SDK
GH_Link..::..Tooltip Property
GH_Link Class See Also Send Feedback
Gets the link tooltip text.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Tooltip { get; }
Visual Basic
Public ReadOnly Property Tooltip As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Documentation.GH_Link.Tooltip"]

See Also

GH_Link Class
Grasshopper.Documentation Namespace


GH_List Class

[image]

Grasshopper SDK
GH_List Class
Members See Also Send Feedback
Represents a list of items in the Grasshopper help.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_List : IGH_Content
Visual Basic
Public Class GH_List _
    Implements IGH_Content

Inheritance Hierarchy

System..::..Object
Grasshopper.Documentation..::..GH_List

See Also

GH_List Members
Grasshopper.Documentation Namespace


GH_List Members

[image] [image]

Grasshopper SDK
GH_List Members
GH_List Class Methods Properties See Also Send Feedback

The GH_List type exposes the following members.

Methods

 | Name | Description
 | Create(Boolean) |
 | Create(Boolean, IEnumerable<(Of <<'(IGH_Content>)>>)) |
Public method | ToString | (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Items |
Public property | Ordered |

See Also

GH_List Class
Grasshopper.Documentation Namespace


GH_List Methods

[image] [image]

Grasshopper SDK
GH_List Methods
GH_List Class See Also Send Feedback

The GH_List type exposes the following members.

Methods

 | Name | Description
 | Create(Boolean) |
 | Create(Boolean, IEnumerable<(Of <<'(IGH_Content>)>>)) |
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

GH_List Class
Grasshopper.Documentation Namespace


Create Method

[image] [image]

Grasshopper SDK
GH_List..::..Create Method
GH_List Class See Also Send Feedback

Overload List

Name | Description
Create(Boolean) |
Create(Boolean, IEnumerable<(Of <<'(IGH_Content>)>>)) |

See Also

GH_List Class
GH_List Members
Grasshopper.Documentation Namespace


Create Method (Boolean)

[image]

Grasshopper SDK
GH_List..::..Create Method (Boolean)
GH_List Class See Also Send Feedback

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_List Create(
    bool ordered
)
Visual Basic
Public Shared Function Create ( _
    ordered As Boolean _
) As GH_List

Parameters

ordered
Type: System..::..Boolean

See Also

GH_List Class
Create Overload
Grasshopper.Documentation Namespace


Create Method (Boolean, IEnumerable(IGH_Content))

[image]

Grasshopper SDK
GH_List..::..Create Method (Boolean, IEnumerable<(Of <(<'IGH_Content>)>)>)
GH_List Class See Also Send Feedback

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_List Create(
    bool ordered,
    IEnumerable<IGH_Content> items
)
Visual Basic
Public Shared Function Create ( _
    ordered As Boolean, _
    items As IEnumerable(Of IGH_Content) _
) As GH_List

Parameters

ordered
Type: System..::..Boolean
items
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' IGH_Content >)>)>

See Also

GH_List Class
Create Overload
Grasshopper.Documentation Namespace


ToString Method

[image]

Grasshopper SDK
GH_List..::..ToString Method
GH_List Class See Also Send Feedback

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_List Class
Grasshopper.Documentation Namespace


GH_List Properties

[image] [image]

Grasshopper SDK
GH_List Properties
GH_List Class See Also Send Feedback

The GH_List type exposes the following members.

Properties

 | Name | Description
Public property | Items |
Public property | Ordered |

See Also

GH_List Class
Grasshopper.Documentation Namespace


Items Property

[image]

Grasshopper SDK
GH_List..::..Items Property
GH_List Class See Also Send Feedback

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<IGH_Content> Items { get; }
Visual Basic
Public ReadOnly Property Items As List(Of IGH_Content)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Documentation.GH_List.Items"]

See Also

GH_List Class
Grasshopper.Documentation Namespace


Ordered Property

[image]

Grasshopper SDK
GH_List..::..Ordered Property
GH_List Class See Also Send Feedback

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Ordered { get; }
Visual Basic
Public ReadOnly Property Ordered As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Documentation.GH_List.Ordered"]

See Also

GH_List Class
Grasshopper.Documentation Namespace


GH_Paragraph Class

[image]

Grasshopper SDK
GH_Paragraph Class
Members See Also Send Feedback

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Paragraph : IGH_Content
Visual Basic
Public Class GH_Paragraph _
    Implements IGH_Content

Inheritance Hierarchy

System..::..Object
Grasshopper.Documentation..::..GH_Paragraph

See Also

GH_Paragraph Members
Grasshopper.Documentation Namespace


GH_Paragraph Members

[image] [image]

Grasshopper SDK
GH_Paragraph Members
GH_Paragraph Class Methods Properties See Also Send Feedback

The GH_Paragraph type exposes the following members.

Methods

 | Name | Description
 | Create(String) |
 | Create(array<String>[]()[][]) |
Public method | ToString | (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Content |

See Also

GH_Paragraph Class
Grasshopper.Documentation Namespace


GH_Paragraph Methods

[image] [image]

Grasshopper SDK
GH_Paragraph Methods
GH_Paragraph Class See Also Send Feedback

The GH_Paragraph type exposes the following members.

Methods

 | Name | Description
 | Create(String) |
 | Create(array<String>[]()[][]) |
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

GH_Paragraph Class
Grasshopper.Documentation Namespace


Create Method

[image] [image]

Grasshopper SDK
GH_Paragraph..::..Create Method
GH_Paragraph Class See Also Send Feedback

Overload List

Name | Description
Create(String) |
Create(array<String>[]()[][]) |

See Also

GH_Paragraph Class
GH_Paragraph Members
Grasshopper.Documentation Namespace


Create Method (String)

[image]

Grasshopper SDK
GH_Paragraph..::..Create Method (String)
GH_Paragraph Class See Also Send Feedback

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Paragraph Create(
    string content
)
Visual Basic
Public Shared Function Create ( _
    content As String _
) As GH_Paragraph

Parameters

content
Type: System..::..String

See Also

GH_Paragraph Class
Create Overload
Grasshopper.Documentation Namespace


Create Method (String[])

[image]

Grasshopper SDK
GH_Paragraph..::..Create Method (array<String>[]()[][])
GH_Paragraph Class See Also Send Feedback

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Paragraph Create(
    string[] content
)
Visual Basic
Public Shared Function Create ( _
    content As String() _
) As GH_Paragraph

Parameters

content
Type: array< System..::..String >[]()[][]

See Also

GH_Paragraph Class
Create Overload
Grasshopper.Documentation Namespace


ToString Method

[image]

Grasshopper SDK
GH_Paragraph..::..ToString Method
GH_Paragraph Class See Also Send Feedback

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_Paragraph Class
Grasshopper.Documentation Namespace


GH_Paragraph Properties

[image] [image]

Grasshopper SDK
GH_Paragraph Properties
GH_Paragraph Class See Also Send Feedback

The GH_Paragraph type exposes the following members.

Properties

 | Name | Description
Public property | Content |

See Also

GH_Paragraph Class
Grasshopper.Documentation Namespace


Content Property

[image]

Grasshopper SDK
GH_Paragraph..::..Content Property
GH_Paragraph Class See Also Send Feedback

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_Content Content { get; }
Visual Basic
Public ReadOnly Property Content As IGH_Content
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Documentation.GH_Paragraph.Content"]

See Also

GH_Paragraph Class
Grasshopper.Documentation Namespace


GH_Parser Class

[image]

Grasshopper SDK
GH_Parser Class
Members See Also Send Feedback
Provides parsing methods for the Grasshopper Markdown flavour.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Parser
Visual Basic
Public Class GH_Parser

Inheritance Hierarchy

System..::..Object
Grasshopper.Documentation..::..GH_Parser

See Also

GH_Parser Members
Grasshopper.Documentation Namespace


GH_Parser Members

[image] [image]

Grasshopper SDK
GH_Parser Members
GH_Parser Class Methods Properties See Also Send Feedback

The GH_Parser type exposes the following members.

Methods

Name | Description
IsChapterHeaderLine | Test whether a line represents a chapter header underline. Chapter header underlines contain at least 4 consecutive equals symbols preceded or followed by any amount of white space.
IsCommentLine | Test whether a line is a comment. Commented lines begin with double slashes (//) and are ignored during parsing.
IsLinkLine(String) | Test whether a line represents a referenced link target. Note; this is a quick check. The link might still be invalid, use the IsLinkLine overload to include validity checks.
IsLinkLine(String, String%, String%, String%) | Test whether a line represents a referenced link target.
IsListLine | Test whether a line contains a list item.
IsParagraphHeaderLine | Test whether a line represents a paragraph header underline. Paragraph header underlines contain at least 4 consecutive dashes preceded or followed by any amount of white space.
IsQuoteLine | Test whether a line is a block quote line. Block quotes start with a larger than symbol.
StringToFragment | Parse a block of text and return it as an interpreted IGH_Fragment.

Properties

Name | Description
Whitespace | Gets an array of characters that are considered to be whitespace. At the moment, this array contains the space char and the tab char, it does not contain feeds or breaks.

See Also

GH_Parser Class
Grasshopper.Documentation Namespace


GH_Parser Methods

[image] [image]

Grasshopper SDK
GH_Parser Methods
GH_Parser Class See Also Send Feedback

The GH_Parser type exposes the following members.

Methods

Name | Description
IsChapterHeaderLine | Test whether a line represents a chapter header underline. Chapter header underlines contain at least 4 consecutive equals symbols preceded or followed by any amount of white space.
IsCommentLine | Test whether a line is a comment. Commented lines begin with double slashes (//) and are ignored during parsing.
IsLinkLine(String) | Test whether a line represents a referenced link target. Note; this is a quick check. The link might still be invalid, use the IsLinkLine overload to include validity checks.
IsLinkLine(String, String%, String%, String%) | Test whether a line represents a referenced link target.
IsListLine | Test whether a line contains a list item.
IsParagraphHeaderLine | Test whether a line represents a paragraph header underline. Paragraph header underlines contain at least 4 consecutive dashes preceded or followed by any amount of white space.
IsQuoteLine | Test whether a line is a block quote line. Block quotes start with a larger than symbol.
StringToFragment | Parse a block of text and return it as an interpreted IGH_Fragment.

See Also

GH_Parser Class
Grasshopper.Documentation Namespace


IsChapterHeaderLine Method

[image]

Grasshopper SDK
GH_Parser..::..IsChapterHeaderLine Method
GH_Parser Class See Also Send Feedback
Test whether a line represents a chapter header underline. Chapter header underlines contain at least 4 consecutive equals symbols preceded or followed by any amount of white space.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool IsChapterHeaderLine(
    string line
)
Visual Basic
Public Shared Function IsChapterHeaderLine ( _
    line As String _
) As Boolean

Parameters

line
Type: System..::..String
Line to test.

Return Value

True if the line is considered to be a chapter header underline.

See Also

GH_Parser Class
Grasshopper.Documentation Namespace


IsCommentLine Method

[image]

Grasshopper SDK
GH_Parser..::..IsCommentLine Method
GH_Parser Class See Also Send Feedback
Test whether a line is a comment. Commented lines begin with double slashes (//) and are ignored during parsing.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool IsCommentLine(
    string line
)
Visual Basic
Public Shared Function IsCommentLine ( _
    line As String _
) As Boolean

Parameters

line
Type: System..::..String
Line to test. If you supply a multi-line string, death's too good for you.

Return Value

True if the line is a comment line.

See Also

GH_Parser Class
Grasshopper.Documentation Namespace


IsLinkLine Method

[image] [image]

Grasshopper SDK
GH_Parser..::..IsLinkLine Method
GH_Parser Class See Also Send Feedback

Overload List

Name | Description
IsLinkLine(String) | Test whether a line represents a referenced link target. Note; this is a quick check. The link might still be invalid, use the IsLinkLine overload to include validity checks.
IsLinkLine(String, String%, String%, String%) | Test whether a line represents a referenced link target.

See Also

GH_Parser Class
GH_Parser Members
Grasshopper.Documentation Namespace


IsLinkLine Method (String)

[image]

Grasshopper SDK
GH_Parser..::..IsLinkLine Method (String)
GH_Parser Class See Also Send Feedback
Test whether a line represents a referenced link target. Note; this is a quick check. The link might still be invalid, use the IsLinkLine overload to include validity checks.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool IsLinkLine(
    string line
)
Visual Basic
Public Shared Function IsLinkLine ( _
    line As String _
) As Boolean

Parameters

line
Type: System..::..String
Line to test.

Return Value

True if the line is a referenced link.

See Also

GH_Parser Class
IsLinkLine Overload
Grasshopper.Documentation Namespace


IsLinkLine Method (String, String, String, String)

[image]

Grasshopper SDK
GH_Parser..::..IsLinkLine Method (String, String%, String%, String%)
GH_Parser Class See Also Send Feedback
Test whether a line represents a referenced link target.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool IsLinkLine(
    string line,
    out string linkId,
    out string linkTarget,
    out string linkTooltip
)
Visual Basic
Public Shared Function IsLinkLine ( _
    line As String, _
    <OutAttribute> ByRef linkId As String, _
    <OutAttribute> ByRef linkTarget As String, _
    <OutAttribute> ByRef linkTooltip As String _
) As Boolean

Parameters

line
Type: System..::..String
Line to test.
linkId
Type: System..::..String %
linkTarget
Type: System..::..String %
linkTooltip
Type: System..::..String %

Return Value

True if the line is a referenced link.

See Also

GH_Parser Class
IsLinkLine Overload
Grasshopper.Documentation Namespace


IsListLine Method

[image]

Grasshopper SDK
GH_Parser..::..IsListLine Method
GH_Parser Class See Also Send Feedback
Test whether a line contains a list item.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool IsListLine(
    string line
)
Visual Basic
Public Shared Function IsListLine ( _
    line As String _
) As Boolean

Parameters

line
Type: System..::..String
Line to check.

Return Value

True if the line contains a list item.

See Also

GH_Parser Class
Grasshopper.Documentation Namespace


IsParagraphHeaderLine Method

[image]

Grasshopper SDK
GH_Parser..::..IsParagraphHeaderLine Method
GH_Parser Class See Also Send Feedback
Test whether a line represents a paragraph header underline. Paragraph header underlines contain at least 4 consecutive dashes preceded or followed by any amount of white space.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool IsParagraphHeaderLine(
    string line
)
Visual Basic
Public Shared Function IsParagraphHeaderLine ( _
    line As String _
) As Boolean

Parameters

line
Type: System..::..String
Line to test.

Return Value

True if the line is considered to be a paragraph header underline.

See Also

GH_Parser Class
Grasshopper.Documentation Namespace


IsQuoteLine Method

[image]

Grasshopper SDK
GH_Parser..::..IsQuoteLine Method
GH_Parser Class See Also Send Feedback
Test whether a line is a block quote line. Block quotes start with a larger than symbol.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool IsQuoteLine(
    string line
)
Visual Basic
Public Shared Function IsQuoteLine ( _
    line As String _
) As Boolean

Parameters

line
Type: System..::..String
Line to test.

Return Value

True if the line is a block quote.

See Also

GH_Parser Class
Grasshopper.Documentation Namespace


StringToFragment Method

[image]

Grasshopper SDK
GH_Parser..::..StringToFragment Method
GH_Parser Class See Also Send Feedback
Parse a block of text and return it as an interpreted IGH_Fragment.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static IGH_Content StringToFragment(
    string text
)
Visual Basic
Public Shared Function StringToFragment ( _
    text As String _
) As IGH_Content

Parameters

text
Type: System..::..String
Text to parse.

Return Value

Fragment representing the text.

See Also

GH_Parser Class
Grasshopper.Documentation Namespace


GH_Parser Properties

[image] [image]

Grasshopper SDK
GH_Parser Properties
GH_Parser Class See Also Send Feedback

The GH_Parser type exposes the following members.

Properties

Name | Description
Whitespace | Gets an array of characters that are considered to be whitespace. At the moment, this array contains the space char and the tab char, it does not contain feeds or breaks.

See Also

GH_Parser Class
Grasshopper.Documentation Namespace


Whitespace Property

[image]

Grasshopper SDK
GH_Parser..::..Whitespace Property
GH_Parser Class See Also Send Feedback
Gets an array of characters that are considered to be whitespace. At the moment, this array contains the space char and the tab char, it does not contain feeds or breaks.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static char[] Whitespace { get; }
Visual Basic
Public Shared ReadOnly Property Whitespace As Char()
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Documentation.GH_Parser.Whitespace"]

See Also

GH_Parser Class
Grasshopper.Documentation Namespace


GH_RuntimeFile Class

[image]

Grasshopper SDK
GH_RuntimeFile Class
Members See Also Send Feedback
Runtime representation of a Grasshopper help file. A GH_RuntimeFile is nothing more than a collection of keywords with associated content. This class does not interpret a file or check its validity, it merely figures out the different content section based on "Keyword:" entries.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_RuntimeFile
Visual Basic
Public Class GH_RuntimeFile

Inheritance Hierarchy

System..::..Object
Grasshopper.Documentation..::..GH_RuntimeFile

See Also

GH_RuntimeFile Members
Grasshopper.Documentation Namespace


GH_RuntimeFile Members

[image] [image]

Grasshopper SDK
GH_RuntimeFile Members
GH_RuntimeFile Class Methods Fields Properties See Also Send Feedback

The GH_RuntimeFile type exposes the following members.

Methods

 | Name | Description
Public method | ContainsKey | Test whether a certain key is present in the File.
 | IsTag | Tests whether a string is a predefined Grasshopper Help keyword.
 | IsTagLine | Tests whether a line of text starts with a Grasshopper Help keyword.
 | ParseFile | Parse a file and return the runtime representation of said file.

Fields

Name | Description
TagAuthor | String tag used to identify Author fields in documentation source files.
TagAutoLink | String tag used to signal whether automatic linking to a topic is allowed.
TagBeginner | String tag used t o identify Beginner Level Help Content in documentation source files.
TagCategory | String tag used to identify Category fields in documentation source files.
TagComponent | String tag used to identify Component IDs in documentation source files.
TagContact | String tag used to identify Author contact details in documentation source files.
TagDescription | String tag used t o identify Description fields in glossary source files.
TagErranyms | String tag used to identify Do Not Confuse collections in documentation source files.
TagExpert | String tag used t o identify Expert Level Help Content in documentation source files.
TagInclude | String tag used to signal whether inclusion of a topic is allowed.
TagIntermediate | String tag used t o identify Intermediate Level Help Content in documentation source files.
TagKeywords | String tag used to identify Keyword collections in documentation source files.
TagPronunciation | String tag used to identify Pronunciaion Guide fields (IPA) in glossary source files.
TagRhinoCommand | String tag used to identify Similar Rhino Commands in documentation source files.
TagSeeAlso | String tag used to identify See Also collections in documentation source files.
TagSynonyms | String tag used to identify Synonym collections in glossary source files.
TagTitle | String tag used to identify title fields in documentation source files.

Properties

 | Name | Description
Public property | Content | Gets the data associated with a certain key. For every time the key appears in the file, an array of content strings will be returned.
Public property | Keys | Gets a list of all the keys present in the File.
Public property | Path | Gets the path of this help file.
 | Tags | Gets a collection of all the pre-defined keywords. Use IsKeyword(string) if you want to know whether a string equals a keyword. It's both faster and more reliable than comparing against this collection.

See Also

GH_RuntimeFile Class
Grasshopper.Documentation Namespace


GH_RuntimeFile Fields

[image] [image]

Grasshopper SDK
GH_RuntimeFile Fields
GH_RuntimeFile Class See Also Send Feedback

The GH_RuntimeFile type exposes the following members.

Fields

Name | Description
TagAuthor | String tag used to identify Author fields in documentation source files.
TagAutoLink | String tag used to signal whether automatic linking to a topic is allowed.
TagBeginner | String tag used t o identify Beginner Level Help Content in documentation source files.
TagCategory | String tag used to identify Category fields in documentation source files.
TagComponent | String tag used to identify Component IDs in documentation source files.
TagContact | String tag used to identify Author contact details in documentation source files.
TagDescription | String tag used t o identify Description fields in glossary source files.
TagErranyms | String tag used to identify Do Not Confuse collections in documentation source files.
TagExpert | String tag used t o identify Expert Level Help Content in documentation source files.
TagInclude | String tag used to signal whether inclusion of a topic is allowed.
TagIntermediate | String tag used t o identify Intermediate Level Help Content in documentation source files.
TagKeywords | String tag used to identify Keyword collections in documentation source files.
TagPronunciation | String tag used to identify Pronunciaion Guide fields (IPA) in glossary source files.
TagRhinoCommand | String tag used to identify Similar Rhino Commands in documentation source files.
TagSeeAlso | String tag used to identify See Also collections in documentation source files.
TagSynonyms | String tag used to identify Synonym collections in glossary source files.
TagTitle | String tag used to identify title fields in documentation source files.

See Also

GH_RuntimeFile Class
Grasshopper.Documentation Namespace


TagAuthor Field

[image]

Grasshopper SDK
GH_RuntimeFile..::..TagAuthor Field
GH_RuntimeFile Class See Also Send Feedback
String tag used to identify Author fields in documentation source files.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const string TagAuthor
Visual Basic
Public Const TagAuthor As String

See Also

GH_RuntimeFile Class
Grasshopper.Documentation Namespace


TagAutoLink Field

[image]

Grasshopper SDK
GH_RuntimeFile..::..TagAutoLink Field
GH_RuntimeFile Class See Also Send Feedback
String tag used to signal whether automatic linking to a topic is allowed.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const string TagAutoLink
Visual Basic
Public Const TagAutoLink As String

See Also

GH_RuntimeFile Class
Grasshopper.Documentation Namespace


TagBeginner Field

[image]

Grasshopper SDK
GH_RuntimeFile..::..TagBeginner Field
GH_RuntimeFile Class See Also Send Feedback
String tag used t o identify Beginner Level Help Content in documentation source files.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const string TagBeginner
Visual Basic
Public Const TagBeginner As String

See Also

GH_RuntimeFile Class
Grasshopper.Documentation Namespace


TagCategory Field

[image]

Grasshopper SDK
GH_RuntimeFile..::..TagCategory Field
GH_RuntimeFile Class See Also Send Feedback
String tag used to identify Category fields in documentation source files.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const string TagCategory
Visual Basic
Public Const TagCategory As String

See Also

GH_RuntimeFile Class
Grasshopper.Documentation Namespace


TagComponent Field

[image]

Grasshopper SDK
GH_RuntimeFile..::..TagComponent Field
GH_RuntimeFile Class See Also Send Feedback
String tag used to identify Component IDs in documentation source files.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const string TagComponent
Visual Basic
Public Const TagComponent As String

See Also

GH_RuntimeFile Class
Grasshopper.Documentation Namespace


TagContact Field

[image]

Grasshopper SDK
GH_RuntimeFile..::..TagContact Field
GH_RuntimeFile Class See Also Send Feedback
String tag used to identify Author contact details in documentation source files.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const string TagContact
Visual Basic
Public Const TagContact As String

See Also

GH_RuntimeFile Class
Grasshopper.Documentation Namespace


TagDescription Field

[image]

Grasshopper SDK
GH_RuntimeFile..::..TagDescription Field
GH_RuntimeFile Class See Also Send Feedback
String tag used t o identify Description fields in glossary source files.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const string TagDescription
Visual Basic
Public Const TagDescription As String

See Also

GH_RuntimeFile Class
Grasshopper.Documentation Namespace


TagErranyms Field

[image]

Grasshopper SDK
GH_RuntimeFile..::..TagErranyms Field
GH_RuntimeFile Class See Also Send Feedback
String tag used to identify Do Not Confuse collections in documentation source files.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const string TagErranyms
Visual Basic
Public Const TagErranyms As String

See Also

GH_RuntimeFile Class
Grasshopper.Documentation Namespace


TagExpert Field

[image]

Grasshopper SDK
GH_RuntimeFile..::..TagExpert Field
GH_RuntimeFile Class See Also Send Feedback
String tag used t o identify Expert Level Help Content in documentation source files.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const string TagExpert
Visual Basic
Public Const TagExpert As String

See Also

GH_RuntimeFile Class
Grasshopper.Documentation Namespace


TagInclude Field

[image]

Grasshopper SDK
GH_RuntimeFile..::..TagInclude Field
GH_RuntimeFile Class See Also Send Feedback
String tag used to signal whether inclusion of a topic is allowed.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const string TagInclude
Visual Basic
Public Const TagInclude As String

See Also

GH_RuntimeFile Class
Grasshopper.Documentation Namespace


TagIntermediate Field

[image]

Grasshopper SDK
GH_RuntimeFile..::..TagIntermediate Field
GH_RuntimeFile Class See Also Send Feedback
String tag used t o identify Intermediate Level Help Content in documentation source files.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const string TagIntermediate
Visual Basic
Public Const TagIntermediate As String

See Also

GH_RuntimeFile Class
Grasshopper.Documentation Namespace


TagKeywords Field

[image]

Grasshopper SDK
GH_RuntimeFile..::..TagKeywords Field
GH_RuntimeFile Class See Also Send Feedback
String tag used to identify Keyword collections in documentation source files.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const string TagKeywords
Visual Basic
Public Const TagKeywords As String

See Also

GH_RuntimeFile Class
Grasshopper.Documentation Namespace


TagPronunciation Field

[image]

Grasshopper SDK
GH_RuntimeFile..::..TagPronunciation Field
GH_RuntimeFile Class See Also Send Feedback
String tag used to identify Pronunciaion Guide fields (IPA) in glossary source files.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const string TagPronunciation
Visual Basic
Public Const TagPronunciation As String

See Also

GH_RuntimeFile Class
Grasshopper.Documentation Namespace


TagRhinoCommand Field

[image]

Grasshopper SDK
GH_RuntimeFile..::..TagRhinoCommand Field
GH_RuntimeFile Class See Also Send Feedback
String tag used to identify Similar Rhino Commands in documentation source files.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const string TagRhinoCommand
Visual Basic
Public Const TagRhinoCommand As String

See Also

GH_RuntimeFile Class
Grasshopper.Documentation Namespace


TagSeeAlso Field

[image]

Grasshopper SDK
GH_RuntimeFile..::..TagSeeAlso Field
GH_RuntimeFile Class See Also Send Feedback
String tag used to identify See Also collections in documentation source files.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const string TagSeeAlso
Visual Basic
Public Const TagSeeAlso As String

See Also

GH_RuntimeFile Class
Grasshopper.Documentation Namespace


TagSynonyms Field

[image]

Grasshopper SDK
GH_RuntimeFile..::..TagSynonyms Field
GH_RuntimeFile Class See Also Send Feedback
String tag used to identify Synonym collections in glossary source files.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const string TagSynonyms
Visual Basic
Public Const TagSynonyms As String

See Also

GH_RuntimeFile Class
Grasshopper.Documentation Namespace


TagTitle Field

[image]

Grasshopper SDK
GH_RuntimeFile..::..TagTitle Field
GH_RuntimeFile Class See Also Send Feedback
String tag used to identify title fields in documentation source files.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const string TagTitle
Visual Basic
Public Const TagTitle As String

See Also

GH_RuntimeFile Class
Grasshopper.Documentation Namespace


GH_RuntimeFile Methods

[image] [image]

Grasshopper SDK
GH_RuntimeFile Methods
GH_RuntimeFile Class See Also Send Feedback

The GH_RuntimeFile type exposes the following members.

Methods

 | Name | Description
Public method | ContainsKey | Test whether a certain key is present in the File.
 | IsTag | Tests whether a string is a predefined Grasshopper Help keyword.
 | IsTagLine | Tests whether a line of text starts with a Grasshopper Help keyword.
 | ParseFile | Parse a file and return the runtime representation of said file.

See Also

GH_RuntimeFile Class
Grasshopper.Documentation Namespace


ContainsKey Method

[image]

Grasshopper SDK
GH_RuntimeFile..::..ContainsKey Method
GH_RuntimeFile Class See Also Send Feedback
Test whether a certain key is present in the File.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool ContainsKey(
    string key
)
Visual Basic
Public Function ContainsKey ( _
    key As String _
) As Boolean

Parameters

key
Type: System..::..String
Key to search for.

Return Value

True if the key is present in the file, false if not.

See Also

GH_RuntimeFile Class
Grasshopper.Documentation Namespace


IsTag Method

[image]

Grasshopper SDK
GH_RuntimeFile..::..IsTag Method
GH_RuntimeFile Class See Also Send Feedback
Tests whether a string is a predefined Grasshopper Help keyword.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool IsTag(
    string text
)
Visual Basic
Public Shared Function IsTag ( _
    text As String _
) As Boolean

Parameters

text
Type: System..::..String
String to test. Should contain no whitespace, but does not need to properly cased.

Return Value

True if text is a predefined keyword, false if not.

See Also

GH_RuntimeFile Class
Grasshopper.Documentation Namespace


IsTagLine Method

[image]

Grasshopper SDK
GH_RuntimeFile..::..IsTagLine Method
GH_RuntimeFile Class See Also Send Feedback
Tests whether a line of text starts with a Grasshopper Help keyword.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool IsTagLine(
    string line,
    out string keyword,
    out string remainder
)
Visual Basic
Public Shared Function IsTagLine ( _
    line As String, _
    <OutAttribute> ByRef keyword As String, _
    <OutAttribute> ByRef remainder As String _
) As Boolean

Parameters

line
Type: System..::..String
Line of text to test.
keyword
Type: System..::..String %
This is where the keyword is returned.
remainder
Type: System..::..String %
This is where the non-keyword part of the line is returned.

Return Value

True if the line starts with a keyword.

See Also

GH_RuntimeFile Class
Grasshopper.Documentation Namespace


ParseFile Method

[image]

Grasshopper SDK
GH_RuntimeFile..::..ParseFile Method
GH_RuntimeFile Class See Also Send Feedback
Parse a file and return the runtime representation of said file.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_RuntimeFile ParseFile(
    string path
)
Visual Basic
Public Shared Function ParseFile ( _
    path As String _
) As GH_RuntimeFile

Parameters

path
Type: System..::..String
Path to file.

Return Value

The runtime representation of the file on the disk.

See Also

GH_RuntimeFile Class
Grasshopper.Documentation Namespace


GH_RuntimeFile Properties

[image] [image]

Grasshopper SDK
GH_RuntimeFile Properties
GH_RuntimeFile Class See Also Send Feedback

The GH_RuntimeFile type exposes the following members.

Properties

 | Name | Description
Public property | Content | Gets the data associated with a certain key. For every time the key appears in the file, an array of content strings will be returned.
Public property | Keys | Gets a list of all the keys present in the File.
Public property | Path | Gets the path of this help file.
 | Tags | Gets a collection of all the pre-defined keywords. Use IsKeyword(string) if you want to know whether a string equals a keyword. It's both faster and more reliable than comparing against this collection.

See Also

GH_RuntimeFile Class
Grasshopper.Documentation Namespace


Content Property

[image]

Grasshopper SDK
GH_RuntimeFile..::..Content Property
GH_RuntimeFile Class See Also Send Feedback
Gets the data associated with a certain key. For every time the key appears in the file, an array of content strings will be returned.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<string[]> this[
    string key
] { get; }
Visual Basic
Public ReadOnly Default Property Content ( _
    key As String _
) As List(Of String())
    Get

Parameters

key
Type: System..::..String
Key to search for, key comparison is not case-sensitive.

Field Value

[Missing <value> documentation for "P:Grasshopper.Documentation.GH_RuntimeFile.Content(System.String)"]

See Also

GH_RuntimeFile Class
Grasshopper.Documentation Namespace


Keys Property

[image]

Grasshopper SDK
GH_RuntimeFile..::..Keys Property
GH_RuntimeFile Class See Also Send Feedback
Gets a list of all the keys present in the File.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<string> Keys { get; }
Visual Basic
Public ReadOnly Property Keys As List(Of String)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Documentation.GH_RuntimeFile.Keys"]

See Also

GH_RuntimeFile Class
Grasshopper.Documentation Namespace


Path Property

[image]

Grasshopper SDK
GH_RuntimeFile..::..Path Property
GH_RuntimeFile Class See Also Send Feedback
Gets the path of this help file.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Path { get; }
Visual Basic
Public ReadOnly Property Path As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Documentation.GH_RuntimeFile.Path"]

See Also

GH_RuntimeFile Class
Grasshopper.Documentation Namespace


Tags Property

[image]

Grasshopper SDK
GH_RuntimeFile..::..Tags Property
GH_RuntimeFile Class See Also Send Feedback
Gets a collection of all the pre-defined keywords. Use IsKeyword(string) if you want to know whether a string equals a keyword. It's both faster and more reliable than comparing against this collection.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static IEnumerable<string> Tags { get; }
Visual Basic
Public Shared ReadOnly Property Tags As IEnumerable(Of String)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Documentation.GH_RuntimeFile.Tags"]

See Also

GH_RuntimeFile Class
Grasshopper.Documentation Namespace


GH_Style Enumeration

[image]

Grasshopper SDK
GH_Style Enumeration
See Also Send Feedback
Enumerates possible formatting for documentation content.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_Style
Visual Basic
Public Enumeration GH_Style

Members

Member name | Value | Description
None | 0 |
WeakEmphasis | 1 |
StrongEmphasis | 2 |
Monospaced | 3 |
Boxed | 4 |
ChapterHeader | 5 |
ParagraphHeader | 6 |

See Also

Grasshopper.Documentation Namespace


GH_Target Enumeration

[image]

Grasshopper SDK
GH_Target Enumeration
See Also Send Feedback
Enumerates the possible link targets in Grasshopper documentation.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_Target
Visual Basic
Public Enumeration GH_Target

Members

Member name | Value | Description
Glossary | 0 | Specifies a link into the Glossary.
Topic | 1 | Specifies a link to another topic.
External | 2 | Specifies a link to some external web-page.

See Also

Grasshopper.Documentation Namespace


GH_Text Class

[image]

Grasshopper SDK
GH_Text Class
Members See Also Send Feedback
Represents a single string.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Text : IGH_Content
Visual Basic
Public Class GH_Text _
    Implements IGH_Content

Inheritance Hierarchy

System..::..Object
Grasshopper.Documentation..::..GH_Text

See Also

GH_Text Members
Grasshopper.Documentation Namespace


GH_Text Members

[image] [image]

Grasshopper SDK
GH_Text Members
GH_Text Class Methods Properties See Also Send Feedback

The GH_Text type exposes the following members.

Methods

 | Name | Description
 | Create | Create a new instance of GH_Text.
Public method | ToString | (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Text | Gets the text string.

See Also

GH_Text Class
Grasshopper.Documentation Namespace


GH_Text Methods

[image] [image]

Grasshopper SDK
GH_Text Methods
GH_Text Class See Also Send Feedback

The GH_Text type exposes the following members.

Methods

 | Name | Description
 | Create | Create a new instance of GH_Text.
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

GH_Text Class
Grasshopper.Documentation Namespace


Create Method

[image]

Grasshopper SDK
GH_Text..::..Create Method
GH_Text Class See Also Send Feedback
Create a new instance of GH_Text.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Text Create(
    string text
)
Visual Basic
Public Shared Function Create ( _
    text As String _
) As GH_Text

Parameters

text
Type: System..::..String
Text to wrap.

See Also

GH_Text Class
Grasshopper.Documentation Namespace


ToString Method

[image]

Grasshopper SDK
GH_Text..::..ToString Method
GH_Text Class See Also Send Feedback

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_Text Class
Grasshopper.Documentation Namespace


GH_Text Properties

[image] [image]

Grasshopper SDK
GH_Text Properties
GH_Text Class See Also Send Feedback

The GH_Text type exposes the following members.

Properties

 | Name | Description
Public property | Text | Gets the text string.

See Also

GH_Text Class
Grasshopper.Documentation Namespace


Text Property

[image]

Grasshopper SDK
GH_Text..::..Text Property
GH_Text Class See Also Send Feedback
Gets the text string.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Text { get; }
Visual Basic
Public ReadOnly Property Text As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Documentation.GH_Text.Text"]

See Also

GH_Text Class
Grasshopper.Documentation Namespace


GH_Topic Class

[image]

Grasshopper SDK
GH_Topic Class
Members See Also Send Feedback
Represents a single topic in the Grasshopper help.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Topic
Visual Basic
Public Class GH_Topic

Inheritance Hierarchy

System..::..Object
Grasshopper.Documentation..::..GH_Topic

See Also

GH_Topic Members
Grasshopper.Documentation Namespace


GH_Topic Members

[image] [image]

Grasshopper SDK
GH_Topic Members
GH_Topic Class Methods Properties See Also Send Feedback

The GH_Topic type exposes the following members.

Methods

Name | Description
ParseFile | Parse a *.topic file and return a topic entry.

Properties

 | Name | Description
Public property | Description |
Public property | SafeDescription |

See Also

GH_Topic Class
Grasshopper.Documentation Namespace


GH_Topic Methods

[image] [image]

Grasshopper SDK
GH_Topic Methods
GH_Topic Class See Also Send Feedback

The GH_Topic type exposes the following members.

Methods

Name | Description
ParseFile | Parse a *.topic file and return a topic entry.

See Also

GH_Topic Class
Grasshopper.Documentation Namespace


ParseFile Method

[image]

Grasshopper SDK
GH_Topic..::..ParseFile Method
GH_Topic Class See Also Send Feedback
Parse a *.topic file and return a topic entry.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Topic ParseFile(
    string path
)
Visual Basic
Public Shared Function ParseFile ( _
    path As String _
) As GH_Topic

Parameters

path
Type: System..::..String
File to parse.

Return Value

The topic defined by the file. This function always returns a valid topic or it throws an exception.

See Also

GH_Topic Class
Grasshopper.Documentation Namespace


GH_Topic Properties

[image] [image]

Grasshopper SDK
GH_Topic Properties
GH_Topic Class See Also Send Feedback

The GH_Topic type exposes the following members.

Properties

 | Name | Description
Public property | Description |
Public property | SafeDescription |

See Also

GH_Topic Class
Grasshopper.Documentation Namespace


Description Property

[image]

Grasshopper SDK
GH_Topic..::..Description Property
GH_Topic Class See Also Send Feedback

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ContentCollection this[
    GH_Audience level
] { get; }
Visual Basic
Public ReadOnly Property Description ( _
    level As GH_Audience _
) As GH_ContentCollection
    Get

Parameters

level
Type: Grasshopper.Documentation..::..GH_Audience

Field Value

[Missing <value> documentation for "P:Grasshopper.Documentation.GH_Topic.Description(Grasshopper.Documentation.GH_Audience)"]

See Also

GH_Topic Class
Grasshopper.Documentation Namespace


SafeDescription Property

[image]

Grasshopper SDK
GH_Topic..::..SafeDescription Property
GH_Topic Class See Also Send Feedback

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ContentCollection this[
    GH_Audience level
] { get; }
Visual Basic
Public ReadOnly Property SafeDescription ( _
    level As GH_Audience _
) As GH_ContentCollection
    Get

Parameters

level
Type: Grasshopper.Documentation..::..GH_Audience

Field Value

[Missing <value> documentation for "P:Grasshopper.Documentation.GH_Topic.SafeDescription(Grasshopper.Documentation.GH_Audience)"]

See Also

GH_Topic Class
Grasshopper.Documentation Namespace


IGH_Content Interface

[image]

Grasshopper SDK
IGH_Content Interface
See Also Send Feedback
All parts that make up documentation content must implement this interface.

Namespace: Grasshopper.Documentation
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_Content
Visual Basic
Public Interface IGH_Content

See Also

Grasshopper.Documentation Namespace


Grasshopper.GUI Namespace

[image]

Grasshopper SDK
Grasshopper.GUI Namespace
Send Feedback
Namespace for all things GUI. This namespace contains practically all the custom Form and Control classes used in Grasshopper, but it also contains many utility functions and classes. Note that many specific classes have been excluded from this helpfile as they are either very obtuse or overly specific.

Classes

 | Class | Description
Public class | GH_Animator | Provides static methods and constructors GH_Animator(Of T).
Public class | GH_Animator<(Of <(<'T>)>)> | Provides methods for animating values.
Public class | GH_BezierSolver | Class for evaluating four-point bezier curves as used in GDI+
Public class | GH_CanvasMouseEvent | Class used in Canvas UI events.
Public class | GH_CanvasObjectMouseDownEventArgs | Event arguments for the CanvasObjectMouseDown events.
Public class | GH_ColourPicker | Provides the standard Grasshopper Colour picker as a winforms Control.
Public class | GH_ColourSwatchEventArgs | Event arguments used in the GH_ColourSwatchControl.ColourChanged event.
Public class | GH_CursorServer | Class used to cache and set cursors.
Public class | GH_DebugLogForm |
Public class | GH_DigitScroller | Provides the standard Grasshopper Digit scroller as a winforms Control.
Public class | GH_DocumentEditor | The Grasshopper main window.
Public class | GH_DoubleBufferedPanel | Derives from Windows.Forms.Panel but overrides certain flags that improve on-screen rendering. Use panel if you want to have a custom drawn control that is under the control of the owner form.
Public class | GH_DragInfo | Contains data used for UI drag operations.
Public class | GH_ExternalFileConflictDialog |
Public class | GH_FadeAnimation | Utility class for animating fade ZUI events on the canvas.
Public class | GH_FontControl | Represents a control that offers both Font preview and Picking methods.
Public class | GH_FontList | Represents the installed Font collection. This control allows both navigation and selection of Font Families.
Public class | GH_FontPicker |
Public class | GH_FontScroller | Represents a panel with a scrolling collection of pangrams.
Public class | GH_FormShepard | A Form shepard is used to herde a bunch of floating forms. Important forms that potentially spout child forms might choose to implement one.
Public class | GH_GDI_Util | Contains some global function for filleting corners of GDI objects.
Public class | GH_GeometricFont | Exposes methods for drawing geometric characters.
Public class | GH_GraphicsUtil | Utility class with static (Shared) functions that help with colour, shape and text rendering.
Public class | GH_HorizontalSeparator | GUI elements for creating visual separations.
Public class | GH_IconLabel | A simple Icon with an icon overlay plus highlight rectangle.
Public class | GH_IconPicker | Provides a standard icon selection interface.
Public class | GH_LoadProtectDialog |
Public class | GH_MaterialPreviewControl | Offers a frontend for Grasshopper Material previews.
Public class | GH_MenuTextBox | Utility control for putting textboxes into menus.
Public class | GH_MouseTracker | Record mouse-movements over time.
Public class | GH_PanelEditorControl |
Public class | GH_QuickImageEditor |
Public class | GH_RotationalTuningData<(Of <(<'T>)>)> | Utility class for keeping track of rotational mouse events.
Public class | GH_SamplingSphere | Represents a coloured sphere that can be sampled at various rotations.
Public class | GH_SettingsCategory | Base implementation of IGH_SettingsCategory. Derive from this class and provide an empty constructor to play ball.
Public class | GH_Slider | Provides a standard Grasshopper slider as a winforms control.
Public class | GH_Slider_Obsolete | Obsolete. General purpose numeric slider.
Public class | GH_StandardIcons | Provides access to a set of standard icons.
Public class | GH_Tooltip | Implements a custom Tooltip class with advanced functionality. All methods and fields are Shared. There can never be more than one GH_Tooltip.
Public class | GH_TooltipComponent | This component provides Grasshopper tooltip functionality through a winforms Component.
Public class | GH_TooltipDisplayEventArgs | Event arguments used in the Tooltip Component.
Public class | GH_UnrecognizedObjectsForm |
Public class | GH_VerticalScrollBar | Scroll bar control with floating point accuracy.
Public class | GH_VerticalSeparator | GUI elements for creating visual separations.
Public class | GH_VoronoiWarningForm |
Public class | GH_WindowsControlUtil | Exposes some static (Shared) utility functions for setting text-rendering properties en masse.
Public class | GH_WindowsFormUtil | Exposes some static (Shared) utility functions for positioning custom windows.

Structures

 | Structure | Description
Public structure | GH_RotationalFrame | Represents a single frame in a rotational tuning history.
Public structure | GH_TrackerFrame | Represents a single frame in a mouse-tracker history. A frame represents all relevant mouse and keyboard data at a given time.

Interfaces

 | Interface | Description
Public interface | IGH_Embeddable | Implement this interface in your custom control if you want to be called before a menu commits or cancels.
Public interface | IGH_FileDropTarget | Implement this interface in your IGH_DocumentObject if you want to participate in Drag+Drop events.
Public interface | IGH_SettingCategory | Represents a single category in the Settings UI. Implement this interface or derive from GH_SettingsCategory to add a new Category to the Grasshopper Settings interface.
Public interface | IGH_SettingFrontend | Represents a single setting in the Settings UI. Implement this interface to participate in the Grasshopper Settings interface.
Public interface | IGH_Tooltip | Accessor interface for the Grasshopper Tooltip form.

Delegates

 | Delegate | Description
Public delegate | GH_Animator<(Of <(<'T>)>)>..::..Interpolate | Delegate for interpolating values.
Public delegate | GH_ColourPicker..::..ColourChangedEventHandler |
Public delegate | GH_DigitScroller..::..ValueChangedEventHandler |
Public delegate | GH_DocumentEditor..::..AggregateShortcutMenuItemsEventHandler |
Public delegate | GH_DocumentEditor..::..EditorFoldStateChangedEventHandler |
Public delegate | GH_FontScroller..::..PostPaint |
Public delegate | GH_MaterialPreviewControl..::..ColourChangedEventHandler |
Public delegate | GH_MaterialPreviewControl..::..MaterialImagePostPaintEventHandler |
Public delegate | GH_MaterialPreviewControl..::..SelectedChangedEventHandler |
Public delegate | GH_MenuTextBox..::..KeyDownEventHandler |
Public delegate | GH_MenuTextBox..::..TextChangedEventHandler |
Public delegate | GH_Slider..::..ValueChangedEventHandler |
Public delegate | GH_Slider_Obsolete..::..ValueChangedEventHandler |
Public delegate | GH_TooltipComponent..::..PopulateTooltipEventHandler |
Public delegate | GH_VerticalScrollBar..::..ScrollRatioChangedEventHandler |

Enumerations

 | Enumeration | Description
Public enumeration | GH_AnimationPhase | Enumerates the possible phases in which an animation can occur.
Public enumeration | GH_Constraint | Constraints used during UI dragging operations.
Public enumeration | GH_FadePhase | Enumerates the possible states of a ZUI fade animation.
Public enumeration | GH_Interpolation | Enumerates the possible animation progression types.
Public enumeration | GH_SeparatorDisplay | Enumerates all possible display modes for horizontal and vertical separators.
Public enumeration | GH_SliderInputMode | Enumerates all possible slider text input modes.


GH_AnimationPhase Enumeration

[image]

Grasshopper SDK
GH_AnimationPhase Enumeration
See Also Send Feedback
Enumerates the possible phases in which an animation can occur.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_AnimationPhase
Visual Basic
Public Enumeration GH_AnimationPhase

Members

Member name | Value | Description
Before | 0 | Animation hasn't started yet.
During | 1 | Animation currently in progress.
After | 2 | Animation has finished.

See Also

Grasshopper.GUI Namespace


GH_Animator Class

[image]

Grasshopper SDK
GH_Animator Class
Members See Also Send Feedback
Provides static methods and constructors GH_Animator(Of T).

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class GH_Animator
Visual Basic
Public NotInheritable Class GH_Animator

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI..::..GH_Animator

See Also

GH_Animator Members
Grasshopper.GUI Namespace


GH_Animator Members

[image] [image]

Grasshopper SDK
GH_Animator Members
GH_Animator Class Methods See Also Send Feedback

The GH_Animator type exposes the following members.

Methods

Name | Description
DecimalAnimator(Decimal, Decimal) |
DecimalAnimator(Decimal, Decimal, Int32) |
DecimalAnimator(Decimal, Decimal, DateTime, DateTime) |
DoubleAnimator(Double, Double) |
DoubleAnimator(Double, Double, Int32) |
DoubleAnimator(Double, Double, DateTime, DateTime) |
IntegerAnimator(Int32, Int32) |
IntegerAnimator(Int32, Int32, Int32) |
IntegerAnimator(Int32, Int32, DateTime, DateTime) |
InterpolateDecimal | Utility interpolation delegate for System.Decimal values.
InterpolateDouble | Utility interpolation delegate for System.Double values.
InterpolateInteger | Utility interpolation delegate for System.Int32 values.
InterpolatePoint | Utility interpolation delegate for System.Drawing.Point values.
InterpolatePointF | Utility interpolation delegate for System.Drawing.PointF values.
InterpolateRectangle | Utility interpolation delegate for System.Drawing.Rectangle values.
InterpolateRectangleF | Utility interpolation delegate for System.Drawing.RectangleF values.
InterpolateSingle | Utility interpolation delegate for System.Single values.
PointAnimator(Point, Point) |
PointAnimator(Point, Point, Int32) |
PointAnimator(Point, Point, DateTime, DateTime) |
PointFAnimator(PointF, PointF) |
PointFAnimator(PointF, PointF, Int32) |
PointFAnimator(PointF, PointF, DateTime, DateTime) |
RectangleAnimator(Rectangle, Rectangle) |
RectangleAnimator(Rectangle, Rectangle, Int32) |
RectangleAnimator(Rectangle, Rectangle, DateTime, DateTime) |
RectangleFAnimator(RectangleF, RectangleF) |
RectangleFAnimator(RectangleF, RectangleF, Int32) |
RectangleFAnimator(RectangleF, RectangleF, DateTime, DateTime) |
SingleAnimator(Single, Single) |
SingleAnimator(Single, Single, Int32) |
SingleAnimator(Single, Single, DateTime, DateTime) |

See Also

GH_Animator Class
Grasshopper.GUI Namespace


GH_Animator Methods

[image] [image]

Grasshopper SDK
GH_Animator Methods
GH_Animator Class See Also Send Feedback

The GH_Animator type exposes the following members.

Methods

Name | Description
DecimalAnimator(Decimal, Decimal) |
DecimalAnimator(Decimal, Decimal, Int32) |
DecimalAnimator(Decimal, Decimal, DateTime, DateTime) |
DoubleAnimator(Double, Double) |
DoubleAnimator(Double, Double, Int32) |
DoubleAnimator(Double, Double, DateTime, DateTime) |
IntegerAnimator(Int32, Int32) |
IntegerAnimator(Int32, Int32, Int32) |
IntegerAnimator(Int32, Int32, DateTime, DateTime) |
InterpolateDecimal | Utility interpolation delegate for System.Decimal values.
InterpolateDouble | Utility interpolation delegate for System.Double values.
InterpolateInteger | Utility interpolation delegate for System.Int32 values.
InterpolatePoint | Utility interpolation delegate for System.Drawing.Point values.
InterpolatePointF | Utility interpolation delegate for System.Drawing.PointF values.
InterpolateRectangle | Utility interpolation delegate for System.Drawing.Rectangle values.
InterpolateRectangleF | Utility interpolation delegate for System.Drawing.RectangleF values.
InterpolateSingle | Utility interpolation delegate for System.Single values.
PointAnimator(Point, Point) |
PointAnimator(Point, Point, Int32) |
PointAnimator(Point, Point, DateTime, DateTime) |
PointFAnimator(PointF, PointF) |
PointFAnimator(PointF, PointF, Int32) |
PointFAnimator(PointF, PointF, DateTime, DateTime) |
RectangleAnimator(Rectangle, Rectangle) |
RectangleAnimator(Rectangle, Rectangle, Int32) |
RectangleAnimator(Rectangle, Rectangle, DateTime, DateTime) |
RectangleFAnimator(RectangleF, RectangleF) |
RectangleFAnimator(RectangleF, RectangleF, Int32) |
RectangleFAnimator(RectangleF, RectangleF, DateTime, DateTime) |
SingleAnimator(Single, Single) |
SingleAnimator(Single, Single, Int32) |
SingleAnimator(Single, Single, DateTime, DateTime) |

See Also

GH_Animator Class
Grasshopper.GUI Namespace


DecimalAnimator Method

[image] [image]

Grasshopper SDK
GH_Animator..::..DecimalAnimator Method
GH_Animator Class See Also Send Feedback

Overload List

Name | Description
DecimalAnimator(Decimal, Decimal) |
DecimalAnimator(Decimal, Decimal, Int32) |
DecimalAnimator(Decimal, Decimal, DateTime, DateTime) |

See Also

GH_Animator Class
GH_Animator Members
Grasshopper.GUI Namespace


DecimalAnimator Method (Decimal, Decimal)

[image]

Grasshopper SDK
GH_Animator..::..DecimalAnimator Method (Decimal, Decimal)
GH_Animator Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Animator<decimal> DecimalAnimator(
    decimal A,
    decimal B
)
Visual Basic
Public Shared Function DecimalAnimator ( _
    A As Decimal, _
    B As Decimal _
) As GH_Animator(Of Decimal)

Parameters

A
Type: System..::..Decimal
B
Type: System..::..Decimal

See Also

GH_Animator Class
DecimalAnimator Overload
Grasshopper.GUI Namespace


DecimalAnimator Method (Decimal, Decimal, Int32)

[image]

Grasshopper SDK
GH_Animator..::..DecimalAnimator Method (Decimal, Decimal, Int32)
GH_Animator Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Animator<decimal> DecimalAnimator(
    decimal A,
    decimal B,
    int duration
)
Visual Basic
Public Shared Function DecimalAnimator ( _
    A As Decimal, _
    B As Decimal, _
    duration As Integer _
) As GH_Animator(Of Decimal)

Parameters

A
Type: System..::..Decimal
B
Type: System..::..Decimal
duration
Type: System..::..Int32

See Also

GH_Animator Class
DecimalAnimator Overload
Grasshopper.GUI Namespace


DecimalAnimator Method (Decimal, Decimal, DateTime, DateTime)

[image]

Grasshopper SDK
GH_Animator..::..DecimalAnimator Method (Decimal, Decimal, DateTime, DateTime)
GH_Animator Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Animator<decimal> DecimalAnimator(
    decimal A,
    decimal B,
    DateTime time0,
    DateTime time1
)
Visual Basic
Public Shared Function DecimalAnimator ( _
    A As Decimal, _
    B As Decimal, _
    time0 As DateTime, _
    time1 As DateTime _
) As GH_Animator(Of Decimal)

Parameters

A
Type: System..::..Decimal
B
Type: System..::..Decimal
time0
Type: System..::..DateTime
time1
Type: System..::..DateTime

See Also

GH_Animator Class
DecimalAnimator Overload
Grasshopper.GUI Namespace


DoubleAnimator Method

[image] [image]

Grasshopper SDK
GH_Animator..::..DoubleAnimator Method
GH_Animator Class See Also Send Feedback

Overload List

Name | Description
DoubleAnimator(Double, Double) |
DoubleAnimator(Double, Double, Int32) |
DoubleAnimator(Double, Double, DateTime, DateTime) |

See Also

GH_Animator Class
GH_Animator Members
Grasshopper.GUI Namespace


DoubleAnimator Method (Double, Double)

[image]

Grasshopper SDK
GH_Animator..::..DoubleAnimator Method (Double, Double)
GH_Animator Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Animator<double> DoubleAnimator(
    double A,
    double B
)
Visual Basic
Public Shared Function DoubleAnimator ( _
    A As Double, _
    B As Double _
) As GH_Animator(Of Double)

Parameters

A
Type: System..::..Double
B
Type: System..::..Double

See Also

GH_Animator Class
DoubleAnimator Overload
Grasshopper.GUI Namespace


DoubleAnimator Method (Double, Double, Int32)

[image]

Grasshopper SDK
GH_Animator..::..DoubleAnimator Method (Double, Double, Int32)
GH_Animator Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Animator<double> DoubleAnimator(
    double A,
    double B,
    int duration
)
Visual Basic
Public Shared Function DoubleAnimator ( _
    A As Double, _
    B As Double, _
    duration As Integer _
) As GH_Animator(Of Double)

Parameters

A
Type: System..::..Double
B
Type: System..::..Double
duration
Type: System..::..Int32

See Also

GH_Animator Class
DoubleAnimator Overload
Grasshopper.GUI Namespace


DoubleAnimator Method (Double, Double, DateTime, DateTime)

[image]

Grasshopper SDK
GH_Animator..::..DoubleAnimator Method (Double, Double, DateTime, DateTime)
GH_Animator Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Animator<double> DoubleAnimator(
    double A,
    double B,
    DateTime time0,
    DateTime time1
)
Visual Basic
Public Shared Function DoubleAnimator ( _
    A As Double, _
    B As Double, _
    time0 As DateTime, _
    time1 As DateTime _
) As GH_Animator(Of Double)

Parameters

A
Type: System..::..Double
B
Type: System..::..Double
time0
Type: System..::..DateTime
time1
Type: System..::..DateTime

See Also

GH_Animator Class
DoubleAnimator Overload
Grasshopper.GUI Namespace


IntegerAnimator Method

[image] [image]

Grasshopper SDK
GH_Animator..::..IntegerAnimator Method
GH_Animator Class See Also Send Feedback

Overload List

Name | Description
IntegerAnimator(Int32, Int32) |
IntegerAnimator(Int32, Int32, Int32) |
IntegerAnimator(Int32, Int32, DateTime, DateTime) |

See Also

GH_Animator Class
GH_Animator Members
Grasshopper.GUI Namespace


IntegerAnimator Method (Int32, Int32)

[image]

Grasshopper SDK
GH_Animator..::..IntegerAnimator Method (Int32, Int32)
GH_Animator Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Animator<int> IntegerAnimator(
    int A,
    int B
)
Visual Basic
Public Shared Function IntegerAnimator ( _
    A As Integer, _
    B As Integer _
) As GH_Animator(Of Integer)

Parameters

A
Type: System..::..Int32
B
Type: System..::..Int32

See Also

GH_Animator Class
IntegerAnimator Overload
Grasshopper.GUI Namespace


IntegerAnimator Method (Int32, Int32, Int32)

[image]

Grasshopper SDK
GH_Animator..::..IntegerAnimator Method (Int32, Int32, Int32)
GH_Animator Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Animator<int> IntegerAnimator(
    int A,
    int B,
    int duration
)
Visual Basic
Public Shared Function IntegerAnimator ( _
    A As Integer, _
    B As Integer, _
    duration As Integer _
) As GH_Animator(Of Integer)

Parameters

A
Type: System..::..Int32
B
Type: System..::..Int32
duration
Type: System..::..Int32

See Also

GH_Animator Class
IntegerAnimator Overload
Grasshopper.GUI Namespace


IntegerAnimator Method (Int32, Int32, DateTime, DateTime)

[image]

Grasshopper SDK
GH_Animator..::..IntegerAnimator Method (Int32, Int32, DateTime, DateTime)
GH_Animator Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Animator<int> IntegerAnimator(
    int A,
    int B,
    DateTime time0,
    DateTime time1
)
Visual Basic
Public Shared Function IntegerAnimator ( _
    A As Integer, _
    B As Integer, _
    time0 As DateTime, _
    time1 As DateTime _
) As GH_Animator(Of Integer)

Parameters

A
Type: System..::..Int32
B
Type: System..::..Int32
time0
Type: System..::..DateTime
time1
Type: System..::..DateTime

See Also

GH_Animator Class
IntegerAnimator Overload
Grasshopper.GUI Namespace


InterpolateDecimal Method

[image]

Grasshopper SDK
GH_Animator..::..InterpolateDecimal Method
GH_Animator Class See Also Send Feedback
Utility interpolation delegate for System.Decimal values.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static decimal InterpolateDecimal(
    decimal A,
    decimal B,
    double factor
)
Visual Basic
Public Shared Function InterpolateDecimal ( _
    A As Decimal, _
    B As Decimal, _
    factor As Double _
) As Decimal

Parameters

A
Type: System..::..Decimal
B
Type: System..::..Decimal
factor
Type: System..::..Double

See Also

GH_Animator Class
Grasshopper.GUI Namespace


InterpolateDouble Method

[image]

Grasshopper SDK
GH_Animator..::..InterpolateDouble Method
GH_Animator Class See Also Send Feedback
Utility interpolation delegate for System.Double values.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static double InterpolateDouble(
    double A,
    double B,
    double factor
)
Visual Basic
Public Shared Function InterpolateDouble ( _
    A As Double, _
    B As Double, _
    factor As Double _
) As Double

Parameters

A
Type: System..::..Double
B
Type: System..::..Double
factor
Type: System..::..Double

See Also

GH_Animator Class
Grasshopper.GUI Namespace


InterpolateInteger Method

[image]

Grasshopper SDK
GH_Animator..::..InterpolateInteger Method
GH_Animator Class See Also Send Feedback
Utility interpolation delegate for System.Int32 values.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static int InterpolateInteger(
    int A,
    int B,
    double factor
)
Visual Basic
Public Shared Function InterpolateInteger ( _
    A As Integer, _
    B As Integer, _
    factor As Double _
) As Integer

Parameters

A
Type: System..::..Int32
B
Type: System..::..Int32
factor
Type: System..::..Double

See Also

GH_Animator Class
Grasshopper.GUI Namespace


InterpolatePoint Method

[image]

Grasshopper SDK
GH_Animator..::..InterpolatePoint Method
GH_Animator Class See Also Send Feedback
Utility interpolation delegate for System.Drawing.Point values.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Point InterpolatePoint(
    Point A,
    Point B,
    double factor
)
Visual Basic
Public Shared Function InterpolatePoint ( _
    A As Point, _
    B As Point, _
    factor As Double _
) As Point

Parameters

A
Type: System.Drawing..::..Point
B
Type: System.Drawing..::..Point
factor
Type: System..::..Double

See Also

GH_Animator Class
Grasshopper.GUI Namespace


InterpolatePointF Method

[image]

Grasshopper SDK
GH_Animator..::..InterpolatePointF Method
GH_Animator Class See Also Send Feedback
Utility interpolation delegate for System.Drawing.PointF values.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static PointF InterpolatePointF(
    PointF A,
    PointF B,
    double factor
)
Visual Basic
Public Shared Function InterpolatePointF ( _
    A As PointF, _
    B As PointF, _
    factor As Double _
) As PointF

Parameters

A
Type: System.Drawing..::..PointF
B
Type: System.Drawing..::..PointF
factor
Type: System..::..Double

See Also

GH_Animator Class
Grasshopper.GUI Namespace


InterpolateRectangle Method

[image]

Grasshopper SDK
GH_Animator..::..InterpolateRectangle Method
GH_Animator Class See Also Send Feedback
Utility interpolation delegate for System.Drawing.Rectangle values.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Rectangle InterpolateRectangle(
    Rectangle A,
    Rectangle B,
    double factor
)
Visual Basic
Public Shared Function InterpolateRectangle ( _
    A As Rectangle, _
    B As Rectangle, _
    factor As Double _
) As Rectangle

Parameters

A
Type: System.Drawing..::..Rectangle
B
Type: System.Drawing..::..Rectangle
factor
Type: System..::..Double

See Also

GH_Animator Class
Grasshopper.GUI Namespace


InterpolateRectangleF Method

[image]

Grasshopper SDK
GH_Animator..::..InterpolateRectangleF Method
GH_Animator Class See Also Send Feedback
Utility interpolation delegate for System.Drawing.RectangleF values.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static RectangleF InterpolateRectangleF(
    RectangleF A,
    RectangleF B,
    double factor
)
Visual Basic
Public Shared Function InterpolateRectangleF ( _
    A As RectangleF, _
    B As RectangleF, _
    factor As Double _
) As RectangleF

Parameters

A
Type: System.Drawing..::..RectangleF
B
Type: System.Drawing..::..RectangleF
factor
Type: System..::..Double

See Also

GH_Animator Class
Grasshopper.GUI Namespace


InterpolateSingle Method

[image]

Grasshopper SDK
GH_Animator..::..InterpolateSingle Method
GH_Animator Class See Also Send Feedback
Utility interpolation delegate for System.Single values.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static float InterpolateSingle(
    float A,
    float B,
    double factor
)
Visual Basic
Public Shared Function InterpolateSingle ( _
    A As Single, _
    B As Single, _
    factor As Double _
) As Single

Parameters

A
Type: System..::..Single
B
Type: System..::..Single
factor
Type: System..::..Double

See Also

GH_Animator Class
Grasshopper.GUI Namespace


PointAnimator Method

[image] [image]

Grasshopper SDK
GH_Animator..::..PointAnimator Method
GH_Animator Class See Also Send Feedback

Overload List

Name | Description
PointAnimator(Point, Point) |
PointAnimator(Point, Point, Int32) |
PointAnimator(Point, Point, DateTime, DateTime) |

See Also

GH_Animator Class
GH_Animator Members
Grasshopper.GUI Namespace


PointAnimator Method (Point, Point)

[image]

Grasshopper SDK
GH_Animator..::..PointAnimator Method (Point, Point)
GH_Animator Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Animator<Point> PointAnimator(
    Point A,
    Point B
)
Visual Basic
Public Shared Function PointAnimator ( _
    A As Point, _
    B As Point _
) As GH_Animator(Of Point)

Parameters

A
Type: System.Drawing..::..Point
B
Type: System.Drawing..::..Point

See Also

GH_Animator Class
PointAnimator Overload
Grasshopper.GUI Namespace


PointAnimator Method (Point, Point, Int32)

[image]

Grasshopper SDK
GH_Animator..::..PointAnimator Method (Point, Point, Int32)
GH_Animator Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Animator<Point> PointAnimator(
    Point A,
    Point B,
    int duration
)
Visual Basic
Public Shared Function PointAnimator ( _
    A As Point, _
    B As Point, _
    duration As Integer _
) As GH_Animator(Of Point)

Parameters

A
Type: System.Drawing..::..Point
B
Type: System.Drawing..::..Point
duration
Type: System..::..Int32

See Also

GH_Animator Class
PointAnimator Overload
Grasshopper.GUI Namespace


PointAnimator Method (Point, Point, DateTime, DateTime)

[image]

Grasshopper SDK
GH_Animator..::..PointAnimator Method (Point, Point, DateTime, DateTime)
GH_Animator Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Animator<Point> PointAnimator(
    Point A,
    Point B,
    DateTime time0,
    DateTime time1
)
Visual Basic
Public Shared Function PointAnimator ( _
    A As Point, _
    B As Point, _
    time0 As DateTime, _
    time1 As DateTime _
) As GH_Animator(Of Point)

Parameters

A
Type: System.Drawing..::..Point
B
Type: System.Drawing..::..Point
time0
Type: System..::..DateTime
time1
Type: System..::..DateTime

See Also

GH_Animator Class
PointAnimator Overload
Grasshopper.GUI Namespace


PointFAnimator Method

[image] [image]

Grasshopper SDK
GH_Animator..::..PointFAnimator Method
GH_Animator Class See Also Send Feedback

Overload List

Name | Description
PointFAnimator(PointF, PointF) |
PointFAnimator(PointF, PointF, Int32) |
PointFAnimator(PointF, PointF, DateTime, DateTime) |

See Also

GH_Animator Class
GH_Animator Members
Grasshopper.GUI Namespace


PointFAnimator Method (PointF, PointF)

[image]

Grasshopper SDK
GH_Animator..::..PointFAnimator Method (PointF, PointF)
GH_Animator Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Animator<PointF> PointFAnimator(
    PointF A,
    PointF B
)
Visual Basic
Public Shared Function PointFAnimator ( _
    A As PointF, _
    B As PointF _
) As GH_Animator(Of PointF)

Parameters

A
Type: System.Drawing..::..PointF
B
Type: System.Drawing..::..PointF

See Also

GH_Animator Class
PointFAnimator Overload
Grasshopper.GUI Namespace


PointFAnimator Method (PointF, PointF, Int32)

[image]

Grasshopper SDK
GH_Animator..::..PointFAnimator Method (PointF, PointF, Int32)
GH_Animator Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Animator<PointF> PointFAnimator(
    PointF A,
    PointF B,
    int duration
)
Visual Basic
Public Shared Function PointFAnimator ( _
    A As PointF, _
    B As PointF, _
    duration As Integer _
) As GH_Animator(Of PointF)

Parameters

A
Type: System.Drawing..::..PointF
B
Type: System.Drawing..::..PointF
duration
Type: System..::..Int32

See Also

GH_Animator Class
PointFAnimator Overload
Grasshopper.GUI Namespace


PointFAnimator Method (PointF, PointF, DateTime, DateTime)

[image]

Grasshopper SDK
GH_Animator..::..PointFAnimator Method (PointF, PointF, DateTime, DateTime)
GH_Animator Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Animator<PointF> PointFAnimator(
    PointF A,
    PointF B,
    DateTime time0,
    DateTime time1
)
Visual Basic
Public Shared Function PointFAnimator ( _
    A As PointF, _
    B As PointF, _
    time0 As DateTime, _
    time1 As DateTime _
) As GH_Animator(Of PointF)

Parameters

A
Type: System.Drawing..::..PointF
B
Type: System.Drawing..::..PointF
time0
Type: System..::..DateTime
time1
Type: System..::..DateTime

See Also

GH_Animator Class
PointFAnimator Overload
Grasshopper.GUI Namespace


RectangleAnimator Method

[image] [image]

Grasshopper SDK
GH_Animator..::..RectangleAnimator Method
GH_Animator Class See Also Send Feedback

Overload List

Name | Description
RectangleAnimator(Rectangle, Rectangle) |
RectangleAnimator(Rectangle, Rectangle, Int32) |
RectangleAnimator(Rectangle, Rectangle, DateTime, DateTime) |

See Also

GH_Animator Class
GH_Animator Members
Grasshopper.GUI Namespace


RectangleAnimator Method (Rectangle, Rectangle)

[image]

Grasshopper SDK
GH_Animator..::..RectangleAnimator Method (Rectangle, Rectangle)
GH_Animator Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Animator<Rectangle> RectangleAnimator(
    Rectangle A,
    Rectangle B
)
Visual Basic
Public Shared Function RectangleAnimator ( _
    A As Rectangle, _
    B As Rectangle _
) As GH_Animator(Of Rectangle)

Parameters

A
Type: System.Drawing..::..Rectangle
B
Type: System.Drawing..::..Rectangle

See Also

GH_Animator Class
RectangleAnimator Overload
Grasshopper.GUI Namespace


RectangleAnimator Method (Rectangle, Rectangle, Int32)

[image]

Grasshopper SDK
GH_Animator..::..RectangleAnimator Method (Rectangle, Rectangle, Int32)
GH_Animator Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Animator<Rectangle> RectangleAnimator(
    Rectangle A,
    Rectangle B,
    int duration
)
Visual Basic
Public Shared Function RectangleAnimator ( _
    A As Rectangle, _
    B As Rectangle, _
    duration As Integer _
) As GH_Animator(Of Rectangle)

Parameters

A
Type: System.Drawing..::..Rectangle
B
Type: System.Drawing..::..Rectangle
duration
Type: System..::..Int32

See Also

GH_Animator Class
RectangleAnimator Overload
Grasshopper.GUI Namespace


RectangleAnimator Method (Rectangle, Rectangle, DateTime, DateTime)

[image]

Grasshopper SDK
GH_Animator..::..RectangleAnimator Method (Rectangle, Rectangle, DateTime, DateTime)
GH_Animator Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Animator<Rectangle> RectangleAnimator(
    Rectangle A,
    Rectangle B,
    DateTime time0,
    DateTime time1
)
Visual Basic
Public Shared Function RectangleAnimator ( _
    A As Rectangle, _
    B As Rectangle, _
    time0 As DateTime, _
    time1 As DateTime _
) As GH_Animator(Of Rectangle)

Parameters

A
Type: System.Drawing..::..Rectangle
B
Type: System.Drawing..::..Rectangle
time0
Type: System..::..DateTime
time1
Type: System..::..DateTime

See Also

GH_Animator Class
RectangleAnimator Overload
Grasshopper.GUI Namespace


RectangleFAnimator Method

[image] [image]

Grasshopper SDK
GH_Animator..::..RectangleFAnimator Method
GH_Animator Class See Also Send Feedback

Overload List

Name | Description
RectangleFAnimator(RectangleF, RectangleF) |
RectangleFAnimator(RectangleF, RectangleF, Int32) |
RectangleFAnimator(RectangleF, RectangleF, DateTime, DateTime) |

See Also

GH_Animator Class
GH_Animator Members
Grasshopper.GUI Namespace


RectangleFAnimator Method (RectangleF, RectangleF)

[image]

Grasshopper SDK
GH_Animator..::..RectangleFAnimator Method (RectangleF, RectangleF)
GH_Animator Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Animator<RectangleF> RectangleFAnimator(
    RectangleF A,
    RectangleF B
)
Visual Basic
Public Shared Function RectangleFAnimator ( _
    A As RectangleF, _
    B As RectangleF _
) As GH_Animator(Of RectangleF)

Parameters

A
Type: System.Drawing..::..RectangleF
B
Type: System.Drawing..::..RectangleF

See Also

GH_Animator Class
RectangleFAnimator Overload
Grasshopper.GUI Namespace


RectangleFAnimator Method (RectangleF, RectangleF, Int32)

[image]

Grasshopper SDK
GH_Animator..::..RectangleFAnimator Method (RectangleF, RectangleF, Int32)
GH_Animator Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Animator<RectangleF> RectangleFAnimator(
    RectangleF A,
    RectangleF B,
    int duration
)
Visual Basic
Public Shared Function RectangleFAnimator ( _
    A As RectangleF, _
    B As RectangleF, _
    duration As Integer _
) As GH_Animator(Of RectangleF)

Parameters

A
Type: System.Drawing..::..RectangleF
B
Type: System.Drawing..::..RectangleF
duration
Type: System..::..Int32

See Also

GH_Animator Class
RectangleFAnimator Overload
Grasshopper.GUI Namespace


RectangleFAnimator Method (RectangleF, RectangleF, DateTime, DateTime)

[image]

Grasshopper SDK
GH_Animator..::..RectangleFAnimator Method (RectangleF, RectangleF, DateTime, DateTime)
GH_Animator Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Animator<RectangleF> RectangleFAnimator(
    RectangleF A,
    RectangleF B,
    DateTime time0,
    DateTime time1
)
Visual Basic
Public Shared Function RectangleFAnimator ( _
    A As RectangleF, _
    B As RectangleF, _
    time0 As DateTime, _
    time1 As DateTime _
) As GH_Animator(Of RectangleF)

Parameters

A
Type: System.Drawing..::..RectangleF
B
Type: System.Drawing..::..RectangleF
time0
Type: System..::..DateTime
time1
Type: System..::..DateTime

See Also

GH_Animator Class
RectangleFAnimator Overload
Grasshopper.GUI Namespace


SingleAnimator Method

[image] [image]

Grasshopper SDK
GH_Animator..::..SingleAnimator Method
GH_Animator Class See Also Send Feedback

Overload List

Name | Description
SingleAnimator(Single, Single) |
SingleAnimator(Single, Single, Int32) |
SingleAnimator(Single, Single, DateTime, DateTime) |

See Also

GH_Animator Class
GH_Animator Members
Grasshopper.GUI Namespace


SingleAnimator Method (Single, Single)

[image]

Grasshopper SDK
GH_Animator..::..SingleAnimator Method (Single, Single)
GH_Animator Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Animator<float> SingleAnimator(
    float A,
    float B
)
Visual Basic
Public Shared Function SingleAnimator ( _
    A As Single, _
    B As Single _
) As GH_Animator(Of Single)

Parameters

A
Type: System..::..Single
B
Type: System..::..Single

See Also

GH_Animator Class
SingleAnimator Overload
Grasshopper.GUI Namespace


SingleAnimator Method (Single, Single, Int32)

[image]

Grasshopper SDK
GH_Animator..::..SingleAnimator Method (Single, Single, Int32)
GH_Animator Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Animator<float> SingleAnimator(
    float A,
    float B,
    int duration
)
Visual Basic
Public Shared Function SingleAnimator ( _
    A As Single, _
    B As Single, _
    duration As Integer _
) As GH_Animator(Of Single)

Parameters

A
Type: System..::..Single
B
Type: System..::..Single
duration
Type: System..::..Int32

See Also

GH_Animator Class
SingleAnimator Overload
Grasshopper.GUI Namespace


SingleAnimator Method (Single, Single, DateTime, DateTime)

[image]

Grasshopper SDK
GH_Animator..::..SingleAnimator Method (Single, Single, DateTime, DateTime)
GH_Animator Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Animator<float> SingleAnimator(
    float A,
    float B,
    DateTime time0,
    DateTime time1
)
Visual Basic
Public Shared Function SingleAnimator ( _
    A As Single, _
    B As Single, _
    time0 As DateTime, _
    time1 As DateTime _
) As GH_Animator(Of Single)

Parameters

A
Type: System..::..Single
B
Type: System..::..Single
time0
Type: System..::..DateTime
time1
Type: System..::..DateTime

See Also

GH_Animator Class
SingleAnimator Overload
Grasshopper.GUI Namespace


GH_Animator(T) Class

[image]

Grasshopper SDK
GH_Animator<(Of <(<'T>)>)> Class
Members See Also Send Feedback
Provides methods for animating values.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Animator<T>
Visual Basic
Public Class GH_Animator(Of T)

Type Parameters

T
Data type to animate.

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI..::..GH_Animator<(Of <(<'T>)>)>

See Also

GH_Animator<(Of <(<'T>)>)> Members
Grasshopper.GUI Namespace


GH_Animator(T) Members

[image] [image]

Grasshopper SDK
GH_Animator<(Of <(<'T>)>)> Members
GH_Animator<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The GH_Animator<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Animator<(Of <(<'T>)>)>(T, T, TimeSpan, GH_Animator<(Of <<'(T>)>>)..::..Interpolate) | Create a new instance of the generic animator.
Public method | GH_Animator<(Of <(<'T>)>)>(T, T, DateTime, DateTime, GH_Animator<(Of <<'(T>)>>)..::..Interpolate) | Create a new instance of the generic animator.

Methods

 | Name | Description
Public method | AdjustAnimation(T) | Adjust the animation.
Public method | AdjustAnimation(T, Int32) | Adjust the animation.
Public method | AdjustAnimation(T, DateTime, DateTime) | Adjust the animation.
Public method | CurrentValue | Gets the current animated value.

Properties

 | Name | Description
Public property | Interpolation | Gets or sets the interpolation mode. Changing the mode during an animation will result in discontinuous motion.
Public property | Phase | Gets the current animation phase.
Public property | ValueA | Gets or sets the start value of the animation. This value is set from within the constructor though you can change it at any time.
Public property | ValueB | Gets or sets the end value of the animation. This value is set from within the constructor though you can change it at any time.

See Also

GH_Animator<(Of <(<'T>)>)> Class
Grasshopper.GUI Namespace


GH_Animator(T) Constructor

[image] [image]

Grasshopper SDK
GH_Animator<(Of <(<'T>)>)> Constructor
GH_Animator<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Animator<(Of <(<'T>)>)>(T, T, TimeSpan, GH_Animator<(Of <<'(T>)>>)..::..Interpolate) | Create a new instance of the generic animator.
Public method | GH_Animator<(Of <(<'T>)>)>(T, T, DateTime, DateTime, GH_Animator<(Of <<'(T>)>>)..::..Interpolate) | Create a new instance of the generic animator.

See Also

GH_Animator<(Of <(<'T>)>)> Class
GH_Animator<(Of <(<'T>)>)> Members
Grasshopper.GUI Namespace


GH_Animator(T) Constructor (T, T, TimeSpan, GH_Animator(T).Interpolate)

[image]

Grasshopper SDK
GH_Animator<(Of <(<'T>)>)> Constructor (T, T, TimeSpan, GH_Animator<(Of <(<'T>)>)>..::..Interpolate)
GH_Animator<(Of <(<'T>)>)> Class See Also Send Feedback
Create a new instance of the generic animator.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Animator(
    T A,
    T B,
    TimeSpan duration,
    GH_Animator<(Of <(<'T>)>)>..::..Interpolate interpolator
)
Visual Basic
Public Sub New ( _
    A As T, _
    B As T, _
    duration As TimeSpan, _
    interpolator As GH_Animator<(Of <(<'T>)>)>..::..Interpolate _
)

Parameters

A
Type: T
Start value of animation.
B
Type: T
End value of animation.
duration
Type: System..::..TimeSpan
Duration of animation.
interpolator
Type: Grasshopper.GUI..::..GH_Animator<(Of <(<'T>)>)>..::..Interpolate
Interpolation delegate

See Also

GH_Animator<(Of <(<'T>)>)> Class
GH_Animator<(Of <(<'T>)>)> Overload
Grasshopper.GUI Namespace


GH_Animator(T) Constructor (T, T, DateTime, DateTime, GH_Animator(T).Interpolate)

[image]

Grasshopper SDK
GH_Animator<(Of <(<'T>)>)> Constructor (T, T, DateTime, DateTime, GH_Animator<(Of <(<'T>)>)>..::..Interpolate)
GH_Animator<(Of <(<'T>)>)> Class See Also Send Feedback
Create a new instance of the generic animator.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Animator(
    T A,
    T B,
    DateTime startTime,
    DateTime endTime,
    GH_Animator<(Of <(<'T>)>)>..::..Interpolate interpolator
)
Visual Basic
Public Sub New ( _
    A As T, _
    B As T, _
    startTime As DateTime, _
    endTime As DateTime, _
    interpolator As GH_Animator<(Of <(<'T>)>)>..::..Interpolate _
)

Parameters

A
Type: T
Start value of animation.
B
Type: T
End value of animation.
startTime
Type: System..::..DateTime
Start of animation, should be expressed in UTC time.
endTime
Type: System..::..DateTime
End of animation, should be expressed in UTC time.
interpolator
Type: Grasshopper.GUI..::..GH_Animator<(Of <(<'T>)>)>..::..Interpolate
Interpolation delegate.

See Also

GH_Animator<(Of <(<'T>)>)> Class
GH_Animator<(Of <(<'T>)>)> Overload
Grasshopper.GUI Namespace


GH_Animator(T) Methods

[image] [image]

Grasshopper SDK
GH_Animator<(Of <(<'T>)>)> Methods
GH_Animator<(Of <(<'T>)>)> Class See Also Send Feedback

The GH_Animator<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | AdjustAnimation(T) | Adjust the animation.
Public method | AdjustAnimation(T, Int32) | Adjust the animation.
Public method | AdjustAnimation(T, DateTime, DateTime) | Adjust the animation.
Public method | CurrentValue | Gets the current animated value.

See Also

GH_Animator<(Of <(<'T>)>)> Class
Grasshopper.GUI Namespace


AdjustAnimation Method

[image] [image]

Grasshopper SDK
GH_Animator<(Of <(<'T>)>)>..::..AdjustAnimation Method
GH_Animator<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AdjustAnimation(T) | Adjust the animation.
Public method | AdjustAnimation(T, Int32) | Adjust the animation.
Public method | AdjustAnimation(T, DateTime, DateTime) | Adjust the animation.

See Also

GH_Animator<(Of <(<'T>)>)> Class
GH_Animator<(Of <(<'T>)>)> Members
Grasshopper.GUI Namespace


AdjustAnimation Method (T)

[image]

Grasshopper SDK
GH_Animator<(Of <(<'T>)>)>..::..AdjustAnimation Method (T)
GH_Animator<(Of <(<'T>)>)> Class See Also Send Feedback
Adjust the animation.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AdjustAnimation(
    T newTarget
)
Visual Basic
Public Sub AdjustAnimation ( _
    newTarget As T _
)

Parameters

newTarget
Type: T
New B value.

See Also

GH_Animator<(Of <(<'T>)>)> Class
AdjustAnimation Overload
Grasshopper.GUI Namespace


AdjustAnimation Method (T, Int32)

[image]

Grasshopper SDK
GH_Animator<(Of <(<'T>)>)>..::..AdjustAnimation Method (T, Int32)
GH_Animator<(Of <(<'T>)>)> Class See Also Send Feedback
Adjust the animation.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AdjustAnimation(
    T newTarget,
    int duration
)
Visual Basic
Public Sub AdjustAnimation ( _
    newTarget As T, _
    duration As Integer _
)

Parameters

newTarget
Type: T
New B value.
duration
Type: System..::..Int32
Duration of adjusted animation in milliseconds.

See Also

GH_Animator<(Of <(<'T>)>)> Class
AdjustAnimation Overload
Grasshopper.GUI Namespace


AdjustAnimation Method (T, DateTime, DateTime)

[image]

Grasshopper SDK
GH_Animator<(Of <(<'T>)>)>..::..AdjustAnimation Method (T, DateTime, DateTime)
GH_Animator<(Of <(<'T>)>)> Class See Also Send Feedback
Adjust the animation.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AdjustAnimation(
    T newTarget,
    DateTime newStartTime,
    DateTime newEndTime
)
Visual Basic
Public Sub AdjustAnimation ( _
    newTarget As T, _
    newStartTime As DateTime, _
    newEndTime As DateTime _
)

Parameters

newTarget
Type: T
New B value.
newStartTime
Type: System..::..DateTime
newEndTime
Type: System..::..DateTime

See Also

GH_Animator<(Of <(<'T>)>)> Class
AdjustAnimation Overload
Grasshopper.GUI Namespace


CurrentValue Method

[image]

Grasshopper SDK
GH_Animator<(Of <(<'T>)>)>..::..CurrentValue Method
GH_Animator<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the current animated value.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public T CurrentValue()
Visual Basic
Public Function CurrentValue As T

See Also

GH_Animator<(Of <(<'T>)>)> Class
Grasshopper.GUI Namespace


GH_Animator(T) Properties

[image] [image]

Grasshopper SDK
GH_Animator<(Of <(<'T>)>)> Properties
GH_Animator<(Of <(<'T>)>)> Class See Also Send Feedback

The GH_Animator<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Interpolation | Gets or sets the interpolation mode. Changing the mode during an animation will result in discontinuous motion.
Public property | Phase | Gets the current animation phase.
Public property | ValueA | Gets or sets the start value of the animation. This value is set from within the constructor though you can change it at any time.
Public property | ValueB | Gets or sets the end value of the animation. This value is set from within the constructor though you can change it at any time.

See Also

GH_Animator<(Of <(<'T>)>)> Class
Grasshopper.GUI Namespace


Interpolation Property

[image]

Grasshopper SDK
GH_Animator<(Of <(<'T>)>)>..::..Interpolation Property
GH_Animator<(Of <(<'T>)>)> Class See Also Send Feedback
Gets or sets the interpolation mode. Changing the mode during an animation will result in discontinuous motion.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Interpolation Interpolation { get; set; }
Visual Basic
Public Property Interpolation As GH_Interpolation
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Animator`1.Interpolation"]

See Also

GH_Animator<(Of <(<'T>)>)> Class
Grasshopper.GUI Namespace


Phase Property

[image]

Grasshopper SDK
GH_Animator<(Of <(<'T>)>)>..::..Phase Property
GH_Animator<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the current animation phase.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_AnimationPhase Phase { get; }
Visual Basic
Public ReadOnly Property Phase As GH_AnimationPhase
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Animator`1.Phase"]

See Also

GH_Animator<(Of <(<'T>)>)> Class
Grasshopper.GUI Namespace


ValueA Property

[image]

Grasshopper SDK
GH_Animator<(Of <(<'T>)>)>..::..ValueA Property
GH_Animator<(Of <(<'T>)>)> Class See Also Send Feedback
Gets or sets the start value of the animation. This value is set from within the constructor though you can change it at any time.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public T ValueA { get; set; }
Visual Basic
Public Property ValueA As T
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Animator`1.ValueA"]

See Also

GH_Animator<(Of <(<'T>)>)> Class
Grasshopper.GUI Namespace


ValueB Property

[image]

Grasshopper SDK
GH_Animator<(Of <(<'T>)>)>..::..ValueB Property
GH_Animator<(Of <(<'T>)>)> Class See Also Send Feedback
Gets or sets the end value of the animation. This value is set from within the constructor though you can change it at any time.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public T ValueB { get; set; }
Visual Basic
Public Property ValueB As T
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Animator`1.ValueB"]

See Also

GH_Animator<(Of <(<'T>)>)> Class
Grasshopper.GUI Namespace


GH_Animator(T).Interpolate Delegate

[image]

Grasshopper SDK
GH_Animator<(Of <(<'T>)>)>..::..Interpolate Delegate
GH_Animator<(Of <(<'T>)>)> Class See Also Send Feedback
Delegate for interpolating values.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate T Interpolate(
    T A,
    T B,
    double factor
)
Visual Basic
Public Delegate Function Interpolate ( _
    A As T, _
    B As T, _
    factor As Double _
) As T

Parameters

A
Type: T
Start value.
B
Type: T
End value.
factor
Type: System..::..Double
Linear factor between A and B.

Return Value

The interpolated value.

See Also

Grasshopper.GUI Namespace


GH_BezierSolver Class

[image]

Grasshopper SDK
GH_BezierSolver Class
Members See Also Send Feedback
Class for evaluating four-point bezier curves as used in GDI+

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_BezierSolver
Visual Basic
Public Class GH_BezierSolver

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI..::..GH_BezierSolver

See Also

GH_BezierSolver Members
Grasshopper.GUI Namespace


GH_BezierSolver Members

[image] [image]

Grasshopper SDK
GH_BezierSolver Members
GH_BezierSolver Class Constructors Methods See Also Send Feedback

The GH_BezierSolver type exposes the following members.

Constructors

 | Name | Description
Public method | GH_BezierSolver | Initializes a new instance of the GH_BezierSolver class

Methods

Name | Description
AngleAt | Evaluate the tangent angle of a Bezier span.
PointAt | Evaluate a Bezier span.
TangentAt | Evaluate the tangent vector of a Bezier span.

See Also

GH_BezierSolver Class
Grasshopper.GUI Namespace


GH_BezierSolver Constructor

[image]

Grasshopper SDK
GH_BezierSolver Constructor
GH_BezierSolver Class See Also Send Feedback
Initializes a new instance of the GH_BezierSolver class

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_BezierSolver()
Visual Basic
Public Sub New

See Also

GH_BezierSolver Class
Grasshopper.GUI Namespace


GH_BezierSolver Methods

[image] [image]

Grasshopper SDK
GH_BezierSolver Methods
GH_BezierSolver Class See Also Send Feedback

The GH_BezierSolver type exposes the following members.

Methods

Name | Description
AngleAt | Evaluate the tangent angle of a Bezier span.
PointAt | Evaluate a Bezier span.
TangentAt | Evaluate the tangent vector of a Bezier span.

See Also

GH_BezierSolver Class
Grasshopper.GUI Namespace


AngleAt Method

[image]

Grasshopper SDK
GH_BezierSolver..::..AngleAt Method
GH_BezierSolver Class See Also Send Feedback
Evaluate the tangent angle of a Bezier span.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static float AngleAt(
    ref PointF P0,
    ref PointF P1,
    ref PointF P2,
    ref PointF P3,
    float t
)
Visual Basic
Public Shared Function AngleAt ( _
    ByRef P0 As PointF, _
    ByRef P1 As PointF, _
    ByRef P2 As PointF, _
    ByRef P3 As PointF, _
    t As Single _
) As Single

Parameters

P0
Type: System.Drawing..::..PointF %
Start point of bezier.
P1
Type: System.Drawing..::..PointF %
Point for start tangent.
P2
Type: System.Drawing..::..PointF %
Point for end tangent.
P3
Type: System.Drawing..::..PointF %
End point of bezier.
t
Type: System..::..Single
Unit parameter.

See Also

GH_BezierSolver Class
Grasshopper.GUI Namespace


PointAt Method

[image]

Grasshopper SDK
GH_BezierSolver..::..PointAt Method
GH_BezierSolver Class See Also Send Feedback
Evaluate a Bezier span.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static PointF PointAt(
    ref PointF P0,
    ref PointF P1,
    ref PointF P2,
    ref PointF P3,
    float t
)
Visual Basic
Public Shared Function PointAt ( _
    ByRef P0 As PointF, _
    ByRef P1 As PointF, _
    ByRef P2 As PointF, _
    ByRef P3 As PointF, _
    t As Single _
) As PointF

Parameters

P0
Type: System.Drawing..::..PointF %
Start point of bezier.
P1
Type: System.Drawing..::..PointF %
Point for start tangent.
P2
Type: System.Drawing..::..PointF %
Point for end tangent.
P3
Type: System.Drawing..::..PointF %
End point of bezier.
t
Type: System..::..Single
Unit parameter.

See Also

GH_BezierSolver Class
Grasshopper.GUI Namespace


TangentAt Method

[image]

Grasshopper SDK
GH_BezierSolver..::..TangentAt Method
GH_BezierSolver Class See Also Send Feedback
Evaluate the tangent vector of a Bezier span.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static SizeF TangentAt(
    ref PointF P0,
    ref PointF P1,
    ref PointF P2,
    ref PointF P3,
    float t
)
Visual Basic
Public Shared Function TangentAt ( _
    ByRef P0 As PointF, _
    ByRef P1 As PointF, _
    ByRef P2 As PointF, _
    ByRef P3 As PointF, _
    t As Single _
) As SizeF

Parameters

P0
Type: System.Drawing..::..PointF %
Start point of bezier.
P1
Type: System.Drawing..::..PointF %
Point for start tangent.
P2
Type: System.Drawing..::..PointF %
Point for end tangent.
P3
Type: System.Drawing..::..PointF %
End point of bezier.
t
Type: System..::..Single
Unit parameter.

See Also

GH_BezierSolver Class
Grasshopper.GUI Namespace


GH_CanvasMouseEvent Class

[image]

Grasshopper SDK
GH_CanvasMouseEvent Class
Members See Also Send Feedback
Class used in Canvas UI events.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_CanvasMouseEvent : EventArgs
Visual Basic
Public Class GH_CanvasMouseEvent _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Grasshopper.GUI..::..GH_CanvasMouseEvent

See Also

GH_CanvasMouseEvent Members
Grasshopper.GUI Namespace


GH_CanvasMouseEvent Members

[image] [image]

Grasshopper SDK
GH_CanvasMouseEvent Members
GH_CanvasMouseEvent Class Constructors Properties See Also Send Feedback

The GH_CanvasMouseEvent type exposes the following members.

Constructors

 | Name | Description
Public method | GH_CanvasMouseEvent()()()() | Blank constructor.
Public method | GH_CanvasMouseEvent(GH_Viewport, MouseEventArgs) | Constructor.
Public method | GH_CanvasMouseEvent(Point, PointF, MouseButtons, Int32, Int32) | Constructor.

Properties

 | Name | Description
Public property | Button | Gets which mouse button was pressed.
Public property | CanvasLocation | Gets the location of the cursor in canvas unit coordinates.
Public property | CanvasX | Gets the x-coordinate of the cursor location in canvas unit coordinates.
Public property | CanvasY | Gets the y-coordinate of the cursor location in canvas unit coordinates.
Public property | Clicks | Gets the number of times the mouse button was pressed and released.
Public property | ControlLocation | Gets the location of the cursor in control pixel coordinates.
Public property | ControlX | Gets the x-coordinate of the cursor location in control pixel coordinates.
Public property | ControlY | Gets the y-coordinate of the cursor location in control pixel coordinates.
Public property | Delta | Gets a signed count of the number of detents the mouse wheel has rotated. A detent is one notch of the mouse wheel.
Public property | WinFormsEventArgs | Downcast this data into a Windows.Forms.MouseEventArgs instance.

See Also

GH_CanvasMouseEvent Class
Grasshopper.GUI Namespace


GH_CanvasMouseEvent Constructor

[image] [image]

Grasshopper SDK
GH_CanvasMouseEvent Constructor
GH_CanvasMouseEvent Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_CanvasMouseEvent()()()() | Blank constructor.
Public method | GH_CanvasMouseEvent(GH_Viewport, MouseEventArgs) | Constructor.
Public method | GH_CanvasMouseEvent(Point, PointF, MouseButtons, Int32, Int32) | Constructor.

See Also

GH_CanvasMouseEvent Class
GH_CanvasMouseEvent Members
Grasshopper.GUI Namespace


GH_CanvasMouseEvent Constructor

[image]

Grasshopper SDK
GH_CanvasMouseEvent Constructor
GH_CanvasMouseEvent Class See Also Send Feedback
Blank constructor.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_CanvasMouseEvent()
Visual Basic
Public Sub New

See Also

GH_CanvasMouseEvent Class
GH_CanvasMouseEvent Overload
Grasshopper.GUI Namespace


GH_CanvasMouseEvent Constructor (GH_Viewport, MouseEventArgs)

[image]

Grasshopper SDK
GH_CanvasMouseEvent Constructor (GH_Viewport, MouseEventArgs)
GH_CanvasMouseEvent Class See Also Send Feedback
Constructor.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_CanvasMouseEvent(
    GH_Viewport vp,
    MouseEventArgs e_args
)
Visual Basic
Public Sub New ( _
    vp As GH_Viewport, _
    e_args As MouseEventArgs _
)

Parameters

vp
Type: Grasshopper.GUI.Canvas..::..GH_Viewport
The current canvas viewport state.
e_args
Type: System.Windows.Forms..::..MouseEventArgs
Original mouse event args.

See Also

GH_CanvasMouseEvent Class
GH_CanvasMouseEvent Overload
Grasshopper.GUI Namespace


GH_CanvasMouseEvent Constructor (Point, PointF, MouseButtons, Int32, Int32)

[image]

Grasshopper SDK
GH_CanvasMouseEvent Constructor (Point, PointF, MouseButtons, Int32, Int32)
GH_CanvasMouseEvent Class See Also Send Feedback
Constructor.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_CanvasMouseEvent(
    Point pt_control,
    PointF pt_canvas,
    MouseButtons mButton,
    int iClicks,
    int iDelta
)
Visual Basic
Public Sub New ( _
    pt_control As Point, _
    pt_canvas As PointF, _
    mButton As MouseButtons, _
    iClicks As Integer, _
    iDelta As Integer _
)

Parameters

pt_control
Type: System.Drawing..::..Point
Cursor location in control pixel coordinates.
pt_canvas
Type: System.Drawing..::..PointF
Cursor location in canvas unit coordinates.
mButton
Type: System.Windows.Forms..::..MouseButtons
Currently pressed mouse buttons.
iClicks
Type: System..::..Int32
Number of times the buttons were pressed and released.
iDelta
Type: System..::..Int32
A signed count of the number of detents the mouse wheel has rotated.

See Also

GH_CanvasMouseEvent Class
GH_CanvasMouseEvent Overload
Grasshopper.GUI Namespace


GH_CanvasMouseEvent Properties

[image] [image]

Grasshopper SDK
GH_CanvasMouseEvent Properties
GH_CanvasMouseEvent Class See Also Send Feedback

The GH_CanvasMouseEvent type exposes the following members.

Properties

 | Name | Description
Public property | Button | Gets which mouse button was pressed.
Public property | CanvasLocation | Gets the location of the cursor in canvas unit coordinates.
Public property | CanvasX | Gets the x-coordinate of the cursor location in canvas unit coordinates.
Public property | CanvasY | Gets the y-coordinate of the cursor location in canvas unit coordinates.
Public property | Clicks | Gets the number of times the mouse button was pressed and released.
Public property | ControlLocation | Gets the location of the cursor in control pixel coordinates.
Public property | ControlX | Gets the x-coordinate of the cursor location in control pixel coordinates.
Public property | ControlY | Gets the y-coordinate of the cursor location in control pixel coordinates.
Public property | Delta | Gets a signed count of the number of detents the mouse wheel has rotated. A detent is one notch of the mouse wheel.
Public property | WinFormsEventArgs | Downcast this data into a Windows.Forms.MouseEventArgs instance.

See Also

GH_CanvasMouseEvent Class
Grasshopper.GUI Namespace


Button Property

[image]

Grasshopper SDK
GH_CanvasMouseEvent..::..Button Property
GH_CanvasMouseEvent Class See Also Send Feedback
Gets which mouse button was pressed.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public MouseButtons Button { get; }
Visual Basic
Public ReadOnly Property Button As MouseButtons
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_CanvasMouseEvent.Button"]

See Also

GH_CanvasMouseEvent Class
Grasshopper.GUI Namespace


CanvasLocation Property

[image]

Grasshopper SDK
GH_CanvasMouseEvent..::..CanvasLocation Property
GH_CanvasMouseEvent Class See Also Send Feedback
Gets the location of the cursor in canvas unit coordinates.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public PointF CanvasLocation { get; }
Visual Basic
Public ReadOnly Property CanvasLocation As PointF
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_CanvasMouseEvent.CanvasLocation"]

See Also

GH_CanvasMouseEvent Class
Grasshopper.GUI Namespace


CanvasX Property

[image]

Grasshopper SDK
GH_CanvasMouseEvent..::..CanvasX Property
GH_CanvasMouseEvent Class See Also Send Feedback
Gets the x-coordinate of the cursor location in canvas unit coordinates.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public float CanvasX { get; }
Visual Basic
Public ReadOnly Property CanvasX As Single
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_CanvasMouseEvent.CanvasX"]

See Also

GH_CanvasMouseEvent Class
Grasshopper.GUI Namespace


CanvasY Property

[image]

Grasshopper SDK
GH_CanvasMouseEvent..::..CanvasY Property
GH_CanvasMouseEvent Class See Also Send Feedback
Gets the y-coordinate of the cursor location in canvas unit coordinates.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public float CanvasY { get; }
Visual Basic
Public ReadOnly Property CanvasY As Single
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_CanvasMouseEvent.CanvasY"]

See Also

GH_CanvasMouseEvent Class
Grasshopper.GUI Namespace


Clicks Property

[image]

Grasshopper SDK
GH_CanvasMouseEvent..::..Clicks Property
GH_CanvasMouseEvent Class See Also Send Feedback
Gets the number of times the mouse button was pressed and released.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int Clicks { get; }
Visual Basic
Public ReadOnly Property Clicks As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_CanvasMouseEvent.Clicks"]

See Also

GH_CanvasMouseEvent Class
Grasshopper.GUI Namespace


ControlLocation Property

[image]

Grasshopper SDK
GH_CanvasMouseEvent..::..ControlLocation Property
GH_CanvasMouseEvent Class See Also Send Feedback
Gets the location of the cursor in control pixel coordinates.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Point ControlLocation { get; }
Visual Basic
Public ReadOnly Property ControlLocation As Point
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_CanvasMouseEvent.ControlLocation"]

See Also

GH_CanvasMouseEvent Class
Grasshopper.GUI Namespace


ControlX Property

[image]

Grasshopper SDK
GH_CanvasMouseEvent..::..ControlX Property
GH_CanvasMouseEvent Class See Also Send Feedback
Gets the x-coordinate of the cursor location in control pixel coordinates.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int ControlX { get; }
Visual Basic
Public ReadOnly Property ControlX As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_CanvasMouseEvent.ControlX"]

See Also

GH_CanvasMouseEvent Class
Grasshopper.GUI Namespace


ControlY Property

[image]

Grasshopper SDK
GH_CanvasMouseEvent..::..ControlY Property
GH_CanvasMouseEvent Class See Also Send Feedback
Gets the y-coordinate of the cursor location in control pixel coordinates.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int ControlY { get; }
Visual Basic
Public ReadOnly Property ControlY As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_CanvasMouseEvent.ControlY"]

See Also

GH_CanvasMouseEvent Class
Grasshopper.GUI Namespace


Delta Property

[image]

Grasshopper SDK
GH_CanvasMouseEvent..::..Delta Property
GH_CanvasMouseEvent Class See Also Send Feedback
Gets a signed count of the number of detents the mouse wheel has rotated. A detent is one notch of the mouse wheel.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int Delta { get; }
Visual Basic
Public ReadOnly Property Delta As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_CanvasMouseEvent.Delta"]

See Also

GH_CanvasMouseEvent Class
Grasshopper.GUI Namespace


WinFormsEventArgs Property

[image]

Grasshopper SDK
GH_CanvasMouseEvent..::..WinFormsEventArgs Property
GH_CanvasMouseEvent Class See Also Send Feedback
Downcast this data into a Windows.Forms.MouseEventArgs instance.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public MouseEventArgs WinFormsEventArgs { get; }
Visual Basic
Public ReadOnly Property WinFormsEventArgs As MouseEventArgs
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_CanvasMouseEvent.WinFormsEventArgs"]

See Also

GH_CanvasMouseEvent Class
Grasshopper.GUI Namespace


GH_CanvasObjectMouseDownEventArgs Class

[image]

Grasshopper SDK
GH_CanvasObjectMouseDownEventArgs Class
Members See Also Send Feedback
Event arguments for the CanvasObjectMouseDown events.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_CanvasObjectMouseDownEventArgs : EventArgs
Visual Basic
Public Class GH_CanvasObjectMouseDownEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Grasshopper.GUI..::..GH_CanvasObjectMouseDownEventArgs

See Also

GH_CanvasObjectMouseDownEventArgs Members
Grasshopper.GUI Namespace


GH_CanvasObjectMouseDownEventArgs Members

[image] [image]

Grasshopper SDK
GH_CanvasObjectMouseDownEventArgs Members
GH_CanvasObjectMouseDownEventArgs Class Constructors Properties See Also Send Feedback

The GH_CanvasObjectMouseDownEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GH_CanvasObjectMouseDownEventArgs | Initializes a new instance of the GH_CanvasObjectMouseDownEventArgs class

Properties

 | Name | Description
Public property | Canvas |
Public property | Document |
Public property | Object |

See Also

GH_CanvasObjectMouseDownEventArgs Class
Grasshopper.GUI Namespace


GH_CanvasObjectMouseDownEventArgs Constructor

[image]

Grasshopper SDK
GH_CanvasObjectMouseDownEventArgs Constructor
GH_CanvasObjectMouseDownEventArgs Class See Also Send Feedback
Initializes a new instance of the GH_CanvasObjectMouseDownEventArgs class

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_CanvasObjectMouseDownEventArgs(
    GH_Canvas sender,
    GH_RelevantObjectData object
)
Visual Basic
Public Sub New ( _
    sender As GH_Canvas, _
    object As GH_RelevantObjectData _
)

Parameters

sender
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
object
Type: Grasshopper.Kernel..::..GH_RelevantObjectData

See Also

GH_CanvasObjectMouseDownEventArgs Class
Grasshopper.GUI Namespace


GH_CanvasObjectMouseDownEventArgs Properties

[image] [image]

Grasshopper SDK
GH_CanvasObjectMouseDownEventArgs Properties
GH_CanvasObjectMouseDownEventArgs Class See Also Send Feedback

The GH_CanvasObjectMouseDownEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Canvas |
Public property | Document |
Public property | Object |

See Also

GH_CanvasObjectMouseDownEventArgs Class
Grasshopper.GUI Namespace


Canvas Property

[image]

Grasshopper SDK
GH_CanvasObjectMouseDownEventArgs..::..Canvas Property
GH_CanvasObjectMouseDownEventArgs Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Canvas Canvas { get; }
Visual Basic
Public ReadOnly Property Canvas As GH_Canvas
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_CanvasObjectMouseDownEventArgs.Canvas"]

See Also

GH_CanvasObjectMouseDownEventArgs Class
Grasshopper.GUI Namespace


Document Property

[image]

Grasshopper SDK
GH_CanvasObjectMouseDownEventArgs..::..Document Property
GH_CanvasObjectMouseDownEventArgs Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Document Document { get; }
Visual Basic
Public ReadOnly Property Document As GH_Document
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_CanvasObjectMouseDownEventArgs.Document"]

See Also

GH_CanvasObjectMouseDownEventArgs Class
Grasshopper.GUI Namespace


Object Property

[image]

Grasshopper SDK
GH_CanvasObjectMouseDownEventArgs..::..Object Property
GH_CanvasObjectMouseDownEventArgs Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_RelevantObjectData Object { get; }
Visual Basic
Public ReadOnly Property Object As GH_RelevantObjectData
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_CanvasObjectMouseDownEventArgs.Object"]

See Also

GH_CanvasObjectMouseDownEventArgs Class
Grasshopper.GUI Namespace


GH_ColourPicker Class

[image]

Grasshopper SDK
GH_ColourPicker Class
Members See Also Send Feedback
Provides the standard Grasshopper Colour picker as a winforms Control.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_ColourPicker : UserControl,
    IGH_ToolstripItemKeyHandler
Visual Basic
Public Class GH_ColourPicker _
    Inherits UserControl _
    Implements IGH_ToolstripItemKeyHandler

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
Grasshopper.GUI..::..GH_ColourPicker

See Also

GH_ColourPicker Members
Grasshopper.GUI Namespace


GH_ColourPicker Members

[image] [image]

Grasshopper SDK
GH_ColourPicker Members
GH_ColourPicker Class Constructors Methods Properties Events See Also Send Feedback

The GH_ColourPicker type exposes the following members.

Constructors

 | Name | Description
Public method | GH_ColourPicker | Initializes a new instance of the GH_ColourPicker class

Methods

 | Name | Description
Protected method | Dispose | Releases the unmanaged resources used by the GH_ColourPicker and optionally releases the managed resources (Overrides ContainerControl..::..Dispose(Boolean).)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | (Overrides ScrollableControl..::..OnPaintBackground(PaintEventArgs).)

Properties

 | Name | Description
Public property | AllowNumericInput | Gets or sets whether this colour picker pops up a textbox on channel slider double clicks.
Public property | Colour | Gets or sets the colour currently specified in the picker.
Public property | DesiredHeight | Gets the ideal height for this control given the current width and UI settings.
Public property | ShowAlphaSlider | Gets or sets whether the alpha channel slider is included.
Public property | ShowChannelSliders | Gets or sets whether the channel sliders are included.
Public property | SliceRectangle | Gets the rectangle that outlines the colour cube slice.

Events

 | Name | Description
Public event | ColourChanged | Raised whenever the value of the slider is changed via GUI interaction.

See Also

GH_ColourPicker Class
Grasshopper.GUI Namespace


GH_ColourPicker Constructor

[image]

Grasshopper SDK
GH_ColourPicker Constructor
GH_ColourPicker Class See Also Send Feedback
Initializes a new instance of the GH_ColourPicker class

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ColourPicker()
Visual Basic
Public Sub New

See Also

GH_ColourPicker Class
Grasshopper.GUI Namespace


GH_ColourPicker Methods

[image] [image]

Grasshopper SDK
GH_ColourPicker Methods
GH_ColourPicker Class See Also Send Feedback

The GH_ColourPicker type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | (Overrides ContainerControl..::..Dispose(Boolean).)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | (Overrides ScrollableControl..::..OnPaintBackground(PaintEventArgs).)

See Also

GH_ColourPicker Class
Grasshopper.GUI Namespace


Dispose Method

[image]

Grasshopper SDK
GH_ColourPicker..::..Dispose Method
GH_ColourPicker Class See Also Send Feedback
Releases the unmanaged resources used by the GH_ColourPicker and optionally releases the managed resources

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

GH_ColourPicker Class
Grasshopper.GUI Namespace


OnPaint Method

[image]

Grasshopper SDK
GH_ColourPicker..::..OnPaint Method
GH_ColourPicker Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

GH_ColourPicker Class
Grasshopper.GUI Namespace


OnPaintBackground Method

[image]

Grasshopper SDK
GH_ColourPicker..::..OnPaintBackground Method
GH_ColourPicker Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void OnPaintBackground(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaintBackground ( _
    e As PaintEventArgs _
)

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

GH_ColourPicker Class
Grasshopper.GUI Namespace


GH_ColourPicker Properties

[image] [image]

Grasshopper SDK
GH_ColourPicker Properties
GH_ColourPicker Class See Also Send Feedback

The GH_ColourPicker type exposes the following members.

Properties

 | Name | Description
Public property | AllowNumericInput | Gets or sets whether this colour picker pops up a textbox on channel slider double clicks.
Public property | Colour | Gets or sets the colour currently specified in the picker.
Public property | DesiredHeight | Gets the ideal height for this control given the current width and UI settings.
Public property | ShowAlphaSlider | Gets or sets whether the alpha channel slider is included.
Public property | ShowChannelSliders | Gets or sets whether the channel sliders are included.
Public property | SliceRectangle | Gets the rectangle that outlines the colour cube slice.

See Also

GH_ColourPicker Class
Grasshopper.GUI Namespace


AllowNumericInput Property

[image]

Grasshopper SDK
GH_ColourPicker..::..AllowNumericInput Property
GH_ColourPicker Class See Also Send Feedback
Gets or sets whether this colour picker pops up a textbox on channel slider double clicks.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool AllowNumericInput { get; set; }
Visual Basic
Public Property AllowNumericInput As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_ColourPicker.AllowNumericInput"]

See Also

GH_ColourPicker Class
Grasshopper.GUI Namespace


Colour Property

[image]

Grasshopper SDK
GH_ColourPicker..::..Colour Property
GH_ColourPicker Class See Also Send Feedback
Gets or sets the colour currently specified in the picker.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color Colour { get; set; }
Visual Basic
Public Property Colour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_ColourPicker.Colour"]

See Also

GH_ColourPicker Class
Grasshopper.GUI Namespace


DesiredHeight Property

[image]

Grasshopper SDK
GH_ColourPicker..::..DesiredHeight Property
GH_ColourPicker Class See Also Send Feedback
Gets the ideal height for this control given the current width and UI settings.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int DesiredHeight { get; }
Visual Basic
Public ReadOnly Property DesiredHeight As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_ColourPicker.DesiredHeight"]

See Also

GH_ColourPicker Class
Grasshopper.GUI Namespace


ShowAlphaSlider Property

[image]

Grasshopper SDK
GH_ColourPicker..::..ShowAlphaSlider Property
GH_ColourPicker Class See Also Send Feedback
Gets or sets whether the alpha channel slider is included.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool ShowAlphaSlider { get; set; }
Visual Basic
Public Property ShowAlphaSlider As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_ColourPicker.ShowAlphaSlider"]

See Also

GH_ColourPicker Class
Grasshopper.GUI Namespace


ShowChannelSliders Property

[image]

Grasshopper SDK
GH_ColourPicker..::..ShowChannelSliders Property
GH_ColourPicker Class See Also Send Feedback
Gets or sets whether the channel sliders are included.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool ShowChannelSliders { get; set; }
Visual Basic
Public Property ShowChannelSliders As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_ColourPicker.ShowChannelSliders"]

See Also

GH_ColourPicker Class
Grasshopper.GUI Namespace


SliceRectangle Property

[image]

Grasshopper SDK
GH_ColourPicker..::..SliceRectangle Property
GH_ColourPicker Class See Also Send Feedback
Gets the rectangle that outlines the colour cube slice.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle SliceRectangle { get; }
Visual Basic
Public ReadOnly Property SliceRectangle As Rectangle
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_ColourPicker.SliceRectangle"]

See Also

GH_ColourPicker Class
Grasshopper.GUI Namespace


GH_ColourPicker Events

[image] [image]

Grasshopper SDK
GH_ColourPicker Events
GH_ColourPicker Class See Also Send Feedback

The GH_ColourPicker type exposes the following members.

Events

 | Name | Description
Public event | ColourChanged | Raised whenever the value of the slider is changed via GUI interaction.

See Also

GH_ColourPicker Class
Grasshopper.GUI Namespace


ColourChanged Event

[image]

Grasshopper SDK
GH_ColourPicker..::..ColourChanged Event
GH_ColourPicker Class See Also Send Feedback
Raised whenever the value of the slider is changed via GUI interaction.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_ColourPicker..::..ColourChangedEventHandler ColourChanged
Visual Basic
Public Event ColourChanged As GH_ColourPicker..::..ColourChangedEventHandler

See Also

GH_ColourPicker Class
Grasshopper.GUI Namespace


GH_ColourPicker.ColourChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_ColourPicker..::..ColourChangedEventHandler Delegate
GH_ColourPicker Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void ColourChangedEventHandler(
    Object sender,
    GH_ColourPickerEventArgs e
)
Visual Basic
Public Delegate Sub ColourChangedEventHandler ( _
    sender As Object, _
    e As GH_ColourPickerEventArgs _
)

Parameters

sender
Type: System..::..Object
e
Type: Grasshopper.GUI.Base..::..GH_ColourPickerEventArgs

See Also

Grasshopper.GUI Namespace


GH_ColourSwatchEventArgs Class

[image]

Grasshopper SDK
GH_ColourSwatchEventArgs Class
Members See Also Send Feedback
Event arguments used in the GH_ColourSwatchControl.ColourChanged event.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_ColourSwatchEventArgs : EventArgs
Visual Basic
Public Class GH_ColourSwatchEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Grasshopper.GUI..::..GH_ColourSwatchEventArgs

See Also

GH_ColourSwatchEventArgs Members
Grasshopper.GUI Namespace


GH_ColourSwatchEventArgs Members

[image] [image]

Grasshopper SDK
GH_ColourSwatchEventArgs Members
GH_ColourSwatchEventArgs Class Constructors Properties See Also Send Feedback

The GH_ColourSwatchEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GH_ColourSwatchEventArgs | Initializes a new instance of the GH_ColourSwatchEventArgs class

Properties

 | Name | Description
Public property | Colour |

See Also

GH_ColourSwatchEventArgs Class
Grasshopper.GUI Namespace


GH_ColourSwatchEventArgs Constructor

[image]

Grasshopper SDK
GH_ColourSwatchEventArgs Constructor
GH_ColourSwatchEventArgs Class See Also Send Feedback
Initializes a new instance of the GH_ColourSwatchEventArgs class

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ColourSwatchEventArgs(
    Color colour
)
Visual Basic
Public Sub New ( _
    colour As Color _
)

Parameters

colour
Type: System.Drawing..::..Color

See Also

GH_ColourSwatchEventArgs Class
Grasshopper.GUI Namespace


GH_ColourSwatchEventArgs Properties

[image] [image]

Grasshopper SDK
GH_ColourSwatchEventArgs Properties
GH_ColourSwatchEventArgs Class See Also Send Feedback

The GH_ColourSwatchEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Colour |

See Also

GH_ColourSwatchEventArgs Class
Grasshopper.GUI Namespace


Colour Property

[image]

Grasshopper SDK
GH_ColourSwatchEventArgs..::..Colour Property
GH_ColourSwatchEventArgs Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color Colour { get; }
Visual Basic
Public ReadOnly Property Colour As Color
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_ColourSwatchEventArgs.Colour"]

See Also

GH_ColourSwatchEventArgs Class
Grasshopper.GUI Namespace


GH_Constraint Enumeration

[image]

Grasshopper SDK
GH_Constraint Enumeration
See Also Send Feedback
Constraints used during UI dragging operations.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_Constraint
Visual Basic
Public Enumeration GH_Constraint

Members

Member name | Value | Description
None | 0 | No constraint is placed on drag direction.
Vertical | 1 | Dragging is constrainted to the vertical direction.
Horizontal | 2 | Dragging is constrainted to the horizontal direction.

See Also

Grasshopper.GUI Namespace


GH_CursorServer Class

[image]

Grasshopper SDK
GH_CursorServer Class
Members See Also Send Feedback
Class used to cache and set cursors.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class GH_CursorServer
Visual Basic
Public NotInheritable Class GH_CursorServer

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI..::..GH_CursorServer

See Also

GH_CursorServer Members
Grasshopper.GUI Namespace


GH_CursorServer Members

[image] [image]

Grasshopper SDK
GH_CursorServer Members
GH_CursorServer Class Methods Properties See Also Send Feedback

The GH_CursorServer type exposes the following members.

Methods

 | Name | Description
Public method | AttachCursor | Attach a cursor to a control.
Public method | Cursor | Gets a cursor from the cache.
Public method | IsCursor | Test for the existence of a cursor.
Public method | ReferenceCursors | Reference all the cursor files in a given directory.
Public method | ResetCursor | Reset the cursor of the given control to default.

Properties

 | Name | Description
Public property | Count | Gets the number of cached cursors.

See Also

GH_CursorServer Class
Grasshopper.GUI Namespace


GH_CursorServer Methods

[image] [image]

Grasshopper SDK
GH_CursorServer Methods
GH_CursorServer Class See Also Send Feedback

The GH_CursorServer type exposes the following members.

Methods

 | Name | Description
Public method | AttachCursor | Attach a cursor to a control.
Public method | Cursor | Gets a cursor from the cache.
Public method | IsCursor | Test for the existence of a cursor.
Public method | ReferenceCursors | Reference all the cursor files in a given directory.
Public method | ResetCursor | Reset the cursor of the given control to default.

See Also

GH_CursorServer Class
Grasshopper.GUI Namespace


AttachCursor Method

[image]

Grasshopper SDK
GH_CursorServer..::..AttachCursor Method
GH_CursorServer Class See Also Send Feedback
Attach a cursor to a control.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool AttachCursor(
    Control control,
    string name
)
Visual Basic
Public Function AttachCursor ( _
    control As Control, _
    name As String _
) As Boolean

Parameters

control
Type: System.Windows.Forms..::..Control
Control to assign cursor to.
name
Type: System..::..String
Name of cursor to assign. This is the filename of the original cursor file minus the extension.

Return Value

True if cursor was assigned, or false if no matching cursor could be found.

See Also

GH_CursorServer Class
Grasshopper.GUI Namespace


Cursor Method

[image]

Grasshopper SDK
GH_CursorServer..::..Cursor Method
GH_CursorServer Class See Also Send Feedback
Gets a cursor from the cache.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Cursor Cursor(
    string name
)
Visual Basic
Public Function Cursor ( _
    name As String _
) As Cursor

Parameters

name
Type: System..::..String
Name of cursor to retrieve.

Return Value

The cursor that is associated with the given name or null if not cursor could be matched.

See Also

GH_CursorServer Class
Grasshopper.GUI Namespace


IsCursor Method

[image]

Grasshopper SDK
GH_CursorServer..::..IsCursor Method
GH_CursorServer Class See Also Send Feedback
Test for the existence of a cursor.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsCursor(
    string name
)
Visual Basic
Public Function IsCursor ( _
    name As String _
) As Boolean

Parameters

name
Type: System..::..String
Cursor name to test for.

Return Value

True if the cursor is cached.

See Also

GH_CursorServer Class
Grasshopper.GUI Namespace


ReferenceCursors Method

[image]

Grasshopper SDK
GH_CursorServer..::..ReferenceCursors Method
GH_CursorServer Class See Also Send Feedback
Reference all the cursor files in a given directory.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int ReferenceCursors(
    string folder
)
Visual Basic
Public Function ReferenceCursors ( _
    folder As String _
) As Integer

Parameters

folder
Type: System..::..String
Directory to parse.

Return Value

The number of cursors referenced. Use the AttachCursor() method to assign a referenced cursor to a control.

See Also

GH_CursorServer Class
Grasshopper.GUI Namespace


ResetCursor Method

[image]

Grasshopper SDK
GH_CursorServer..::..ResetCursor Method
GH_CursorServer Class See Also Send Feedback
Reset the cursor of the given control to default.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool ResetCursor(
    Control control
)
Visual Basic
Public Function ResetCursor ( _
    control As Control _
) As Boolean

Parameters

control
Type: System.Windows.Forms..::..Control
Control to reset.

Return Value

True if control was successfully reset, false if iControl is a null reference.

See Also

GH_CursorServer Class
Grasshopper.GUI Namespace


GH_CursorServer Properties

[image] [image]

Grasshopper SDK
GH_CursorServer Properties
GH_CursorServer Class See Also Send Feedback

The GH_CursorServer type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of cached cursors.

See Also

GH_CursorServer Class
Grasshopper.GUI Namespace


Count Property

[image]

Grasshopper SDK
GH_CursorServer..::..Count Property
GH_CursorServer Class See Also Send Feedback
Gets the number of cached cursors.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_CursorServer.Count"]

See Also

GH_CursorServer Class
Grasshopper.GUI Namespace


GH_DebugLogForm Class

[image]

Grasshopper SDK
GH_DebugLogForm Class
Members See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_DebugLogForm : Form
Visual Basic
Public Class GH_DebugLogForm _
    Inherits Form

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
Grasshopper.GUI..::..GH_DebugLogForm

See Also

GH_DebugLogForm Members
Grasshopper.GUI Namespace


GH_DebugLogForm Members

[image] [image]

Grasshopper SDK
GH_DebugLogForm Members
GH_DebugLogForm Class Constructors Methods See Also Send Feedback

The GH_DebugLogForm type exposes the following members.

Constructors

 | Name | Description
Public method | GH_DebugLogForm | Initializes a new instance of the GH_DebugLogForm class

Methods

 | Name | Description
Protected method | Dispose | Releases the unmanaged resources used by the GH_DebugLogForm and optionally releases the managed resources (Overrides Form..::..Dispose(Boolean).)

See Also

GH_DebugLogForm Class
Grasshopper.GUI Namespace


GH_DebugLogForm Constructor

[image]

Grasshopper SDK
GH_DebugLogForm Constructor
GH_DebugLogForm Class See Also Send Feedback
Initializes a new instance of the GH_DebugLogForm class

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_DebugLogForm()
Visual Basic
Public Sub New

See Also

GH_DebugLogForm Class
Grasshopper.GUI Namespace


GH_DebugLogForm Methods

[image] [image]

Grasshopper SDK
GH_DebugLogForm Methods
GH_DebugLogForm Class See Also Send Feedback

The GH_DebugLogForm type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | (Overrides Form..::..Dispose(Boolean).)

See Also

GH_DebugLogForm Class
Grasshopper.GUI Namespace


Dispose Method

[image]

Grasshopper SDK
GH_DebugLogForm..::..Dispose Method
GH_DebugLogForm Class See Also Send Feedback
Releases the unmanaged resources used by the GH_DebugLogForm and optionally releases the managed resources

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

GH_DebugLogForm Class
Grasshopper.GUI Namespace


GH_DigitScroller Class

[image]

Grasshopper SDK
GH_DigitScroller Class
Members See Also Send Feedback
Provides the standard Grasshopper Digit scroller as a winforms Control.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_DigitScroller : GH_TextInputBaseControl
Visual Basic
Public Class GH_DigitScroller _
    Inherits GH_TextInputBaseControl

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
GH_TextInputBaseControl
Grasshopper.GUI..::..GH_DigitScroller

See Also

GH_DigitScroller Members
Grasshopper.GUI Namespace


GH_DigitScroller Members

[image] [image]

Grasshopper SDK
GH_DigitScroller Members
GH_DigitScroller Class Constructors Methods Properties Events See Also Send Feedback

The GH_DigitScroller type exposes the following members.

Constructors

 | Name | Description
Public method | GH_DigitScroller | Initializes a new instance of the GH_DigitScroller class

Methods

 | Name | Description
Protected method | Input_Assign | (Overrides GH_TextInputBaseControlInput_Assign(String).)
Protected method | Input_Parse | (Overrides GH_TextInputBaseControlInput_Parse(String).)
Protected method | Input_Supply | (Overrides GH_TextInputBaseControlInput_Supply()()()().)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | (Overrides ScrollableControl..::..OnPaintBackground(PaintEventArgs).)

Properties

 | Name | Description
Public property | AllowRadixDrag | Gets or sets whether the radix symbol can be dragged.
Public property | AllowTextInput | Gets or sets whether the control accepts text input override.
Public property | Amplify | Gets or sets whether vertical mouse movement ought to be amplified.
Public property | DecimalPlaces | Gets or sets the number of decimal places.
Public property | DigitAlign | Gets or sets the digit align mode
Public property | Digits | Gets or sets the number of digits displayed in the scroller.
Public property | DigitScroller | Gets the internal scroller object.
Public property | Epsilon | Gets the smallest possible change with the current settings.
Public property | MaximumValue | Gets or sets the upper bound of the scroll value.
Public property | MinimumValue | Gets or sets the lower bound of the scroll value.
Public property | Prefix | Gets or sets the prefix text
Public property | Presets | Gets the internal object that maintains numeric presets.
Public property | Radix | Gets or sets the radix point index.
Public property | Suffix | Gets or sets the prefix text
Public property | Value | Gets or sets the value of this scroller.

Events

 | Name | Description
Public event | ValueChanged |

See Also

GH_DigitScroller Class
Grasshopper.GUI Namespace


GH_DigitScroller Constructor

[image]

Grasshopper SDK
GH_DigitScroller Constructor
GH_DigitScroller Class See Also Send Feedback
Initializes a new instance of the GH_DigitScroller class

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_DigitScroller()
Visual Basic
Public Sub New

See Also

GH_DigitScroller Class
Grasshopper.GUI Namespace


GH_DigitScroller Methods

[image] [image]

Grasshopper SDK
GH_DigitScroller Methods
GH_DigitScroller Class See Also Send Feedback

The GH_DigitScroller type exposes the following members.

Methods

 | Name | Description
Protected method | Input_Assign | (Overrides GH_TextInputBaseControlInput_Assign(String).)
Protected method | Input_Parse | (Overrides GH_TextInputBaseControlInput_Parse(String).)
Protected method | Input_Supply | (Overrides GH_TextInputBaseControlInput_Supply()()()().)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | (Overrides ScrollableControl..::..OnPaintBackground(PaintEventArgs).)

See Also

GH_DigitScroller Class
Grasshopper.GUI Namespace


Input_Assign Method

[image]

Grasshopper SDK
GH_DigitScroller..::..Input_Assign Method
GH_DigitScroller Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Input_Assign(
    string text
)
Visual Basic
Protected Overrides Sub Input_Assign ( _
    text As String _
)

Parameters

text
Type: System..::..String

See Also

GH_DigitScroller Class
Grasshopper.GUI Namespace


Input_Parse Method

[image]

Grasshopper SDK
GH_DigitScroller..::..Input_Parse Method
GH_DigitScroller Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override bool Input_Parse(
    string text
)
Visual Basic
Protected Overrides Function Input_Parse ( _
    text As String _
) As Boolean

Parameters

text
Type: System..::..String

See Also

GH_DigitScroller Class
Grasshopper.GUI Namespace


Input_Supply Method

[image]

Grasshopper SDK
GH_DigitScroller..::..Input_Supply Method
GH_DigitScroller Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override string Input_Supply()
Visual Basic
Protected Overrides Function Input_Supply As String

See Also

GH_DigitScroller Class
Grasshopper.GUI Namespace


OnPaint Method

[image]

Grasshopper SDK
GH_DigitScroller..::..OnPaint Method
GH_DigitScroller Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

GH_DigitScroller Class
Grasshopper.GUI Namespace


OnPaintBackground Method

[image]

Grasshopper SDK
GH_DigitScroller..::..OnPaintBackground Method
GH_DigitScroller Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void OnPaintBackground(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaintBackground ( _
    e As PaintEventArgs _
)

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

GH_DigitScroller Class
Grasshopper.GUI Namespace


GH_DigitScroller Properties

[image] [image]

Grasshopper SDK
GH_DigitScroller Properties
GH_DigitScroller Class See Also Send Feedback

The GH_DigitScroller type exposes the following members.

Properties

 | Name | Description
Public property | AllowRadixDrag | Gets or sets whether the radix symbol can be dragged.
Public property | AllowTextInput | Gets or sets whether the control accepts text input override.
Public property | Amplify | Gets or sets whether vertical mouse movement ought to be amplified.
Public property | DecimalPlaces | Gets or sets the number of decimal places.
Public property | DigitAlign | Gets or sets the digit align mode
Public property | Digits | Gets or sets the number of digits displayed in the scroller.
Public property | DigitScroller | Gets the internal scroller object.
Public property | Epsilon | Gets the smallest possible change with the current settings.
Public property | MaximumValue | Gets or sets the upper bound of the scroll value.
Public property | MinimumValue | Gets or sets the lower bound of the scroll value.
Public property | Prefix | Gets or sets the prefix text
Public property | Presets | Gets the internal object that maintains numeric presets.
Public property | Radix | Gets or sets the radix point index.
Public property | Suffix | Gets or sets the prefix text
Public property | Value | Gets or sets the value of this scroller.

See Also

GH_DigitScroller Class
Grasshopper.GUI Namespace


AllowRadixDrag Property

[image]

Grasshopper SDK
GH_DigitScroller..::..AllowRadixDrag Property
GH_DigitScroller Class See Also Send Feedback
Gets or sets whether the radix symbol can be dragged.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool AllowRadixDrag { get; set; }
Visual Basic
Public Property AllowRadixDrag As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_DigitScroller.AllowRadixDrag"]

See Also

GH_DigitScroller Class
Grasshopper.GUI Namespace


AllowTextInput Property

[image]

Grasshopper SDK
GH_DigitScroller..::..AllowTextInput Property
GH_DigitScroller Class See Also Send Feedback
Gets or sets whether the control accepts text input override.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool AllowTextInput { get; set; }
Visual Basic
Public Property AllowTextInput As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_DigitScroller.AllowTextInput"]

See Also

GH_DigitScroller Class
Grasshopper.GUI Namespace


Amplify Property

[image]

Grasshopper SDK
GH_DigitScroller..::..Amplify Property
GH_DigitScroller Class See Also Send Feedback
Gets or sets whether vertical mouse movement ought to be amplified.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Amplify { get; set; }
Visual Basic
Public Property Amplify As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_DigitScroller.Amplify"]

See Also

GH_DigitScroller Class
Grasshopper.GUI Namespace


DecimalPlaces Property

[image]

Grasshopper SDK
GH_DigitScroller..::..DecimalPlaces Property
GH_DigitScroller Class See Also Send Feedback
Gets or sets the number of decimal places.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int DecimalPlaces { get; set; }
Visual Basic
Public Property DecimalPlaces As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_DigitScroller.DecimalPlaces"]

See Also

GH_DigitScroller Class
Grasshopper.GUI Namespace


DigitAlign Property

[image]

Grasshopper SDK
GH_DigitScroller..::..DigitAlign Property
GH_DigitScroller Class See Also Send Feedback
Gets or sets the digit align mode

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_DigitAlign DigitAlign { get; set; }
Visual Basic
Public Property DigitAlign As GH_DigitAlign
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_DigitScroller.DigitAlign"]

See Also

GH_DigitScroller Class
Grasshopper.GUI Namespace


Digits Property

[image]

Grasshopper SDK
GH_DigitScroller..::..Digits Property
GH_DigitScroller Class See Also Send Feedback
Gets or sets the number of digits displayed in the scroller.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int Digits { get; set; }
Visual Basic
Public Property Digits As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_DigitScroller.Digits"]

See Also

GH_DigitScroller Class
Grasshopper.GUI Namespace


DigitScroller Property

[image]

Grasshopper SDK
GH_DigitScroller..::..DigitScroller Property
GH_DigitScroller Class See Also Send Feedback
Gets the internal scroller object.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_DigitScrollerBase DigitScroller { get; }
Visual Basic
Public ReadOnly Property DigitScroller As GH_DigitScrollerBase
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_DigitScroller.DigitScroller"]

See Also

GH_DigitScroller Class
Grasshopper.GUI Namespace


Epsilon Property

[image]

Grasshopper SDK
GH_DigitScroller..::..Epsilon Property
GH_DigitScroller Class See Also Send Feedback
Gets the smallest possible change with the current settings.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public decimal Epsilon { get; }
Visual Basic
Public ReadOnly Property Epsilon As Decimal
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_DigitScroller.Epsilon"]

See Also

GH_DigitScroller Class
Grasshopper.GUI Namespace


MaximumValue Property

[image]

Grasshopper SDK
GH_DigitScroller..::..MaximumValue Property
GH_DigitScroller Class See Also Send Feedback
Gets or sets the upper bound of the scroll value.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public decimal MaximumValue { get; set; }
Visual Basic
Public Property MaximumValue As Decimal
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_DigitScroller.MaximumValue"]

See Also

GH_DigitScroller Class
Grasshopper.GUI Namespace


MinimumValue Property

[image]

Grasshopper SDK
GH_DigitScroller..::..MinimumValue Property
GH_DigitScroller Class See Also Send Feedback
Gets or sets the lower bound of the scroll value.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public decimal MinimumValue { get; set; }
Visual Basic
Public Property MinimumValue As Decimal
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_DigitScroller.MinimumValue"]

See Also

GH_DigitScroller Class
Grasshopper.GUI Namespace


Prefix Property

[image]

Grasshopper SDK
GH_DigitScroller..::..Prefix Property
GH_DigitScroller Class See Also Send Feedback
Gets or sets the prefix text

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Prefix { get; set; }
Visual Basic
Public Property Prefix As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_DigitScroller.Prefix"]

See Also

GH_DigitScroller Class
Grasshopper.GUI Namespace


Presets Property

[image]

Grasshopper SDK
GH_DigitScroller..::..Presets Property
GH_DigitScroller Class See Also Send Feedback
Gets the internal object that maintains numeric presets.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_NumberPresets Presets { get; }
Visual Basic
Public ReadOnly Property Presets As GH_NumberPresets
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_DigitScroller.Presets"]

See Also

GH_DigitScroller Class
Grasshopper.GUI Namespace


Radix Property

[image]

Grasshopper SDK
GH_DigitScroller..::..Radix Property
GH_DigitScroller Class See Also Send Feedback
Gets or sets the radix point index.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int Radix { get; set; }
Visual Basic
Public Property Radix As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_DigitScroller.Radix"]

See Also

GH_DigitScroller Class
Grasshopper.GUI Namespace


Suffix Property

[image]

Grasshopper SDK
GH_DigitScroller..::..Suffix Property
GH_DigitScroller Class See Also Send Feedback
Gets or sets the prefix text

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Suffix { get; set; }
Visual Basic
Public Property Suffix As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_DigitScroller.Suffix"]

See Also

GH_DigitScroller Class
Grasshopper.GUI Namespace


Value Property

[image]

Grasshopper SDK
GH_DigitScroller..::..Value Property
GH_DigitScroller Class See Also Send Feedback
Gets or sets the value of this scroller.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public decimal Value { get; set; }
Visual Basic
Public Property Value As Decimal
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_DigitScroller.Value"]

See Also

GH_DigitScroller Class
Grasshopper.GUI Namespace


GH_DigitScroller Events

[image] [image]

Grasshopper SDK
GH_DigitScroller Events
GH_DigitScroller Class See Also Send Feedback

The GH_DigitScroller type exposes the following members.

Events

 | Name | Description
Public event | ValueChanged |

See Also

GH_DigitScroller Class
Grasshopper.GUI Namespace


ValueChanged Event

[image]

Grasshopper SDK
GH_DigitScroller..::..ValueChanged Event
GH_DigitScroller Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_DigitScroller..::..ValueChangedEventHandler ValueChanged
Visual Basic
Public Event ValueChanged As GH_DigitScroller..::..ValueChangedEventHandler

See Also

GH_DigitScroller Class
Grasshopper.GUI Namespace


GH_DigitScroller.ValueChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_DigitScroller..::..ValueChangedEventHandler Delegate
GH_DigitScroller Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void ValueChangedEventHandler(
    Object sender,
    GH_DigitScrollerEventArgs e
)
Visual Basic
Public Delegate Sub ValueChangedEventHandler ( _
    sender As Object, _
    e As GH_DigitScrollerEventArgs _
)

Parameters

sender
Type: System..::..Object
e
Type: Grasshopper.GUI.Base..::..GH_DigitScrollerEventArgs

See Also

Grasshopper.GUI Namespace


GH_DocumentEditor Class

[image]

Grasshopper SDK
GH_DocumentEditor Class
Members See Also Send Feedback
The Grasshopper main window.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_DocumentEditor : Form
Visual Basic
Public Class GH_DocumentEditor _
    Inherits Form

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
Grasshopper.GUI..::..GH_DocumentEditor

See Also

GH_DocumentEditor Members
Grasshopper.GUI Namespace


GH_DocumentEditor Members

[image] [image]

Grasshopper SDK
GH_DocumentEditor Members
GH_DocumentEditor Class Constructors Methods Properties Events See Also Send Feedback

The GH_DocumentEditor type exposes the following members.

Constructors

 | Name | Description
Public method | GH_DocumentEditor | Initializes a new instance of the GH_DocumentEditor class

Methods

 | Name | Description
Public method | ClearStatusBar | Clear the Grasshopper status-bar.
Public method | CloseForReal | Really, really close the window.
Public method | CollapseForm | Collapses the form into the title bar area.
Public method | DisableUI | Disable all modifier UI.
Protected method | Dispose | Releases the unmanaged resources used by the GH_DocumentEditor and optionally releases the managed resources (Overrides Form..::..Dispose(Boolean).)
Public method | EnableUI | Enable all modifier UI.
Public method | ExpandForm | Expands the form if it is currenly collapsed.
Public method | FadeIn | Call this method if the prompt switches back to Grasshopper.
Public method | FadeOut | Call this method if the prompt switches to Rhino.
Public method | ScriptAccess_CloseAllDocuments | Closes all documents in the Document Queue.
Public method | ScriptAccess_CloseDocument | Closes the currently active document and loads the next available document into the canvas. Changes will not be saved.
Public method | ScriptAccess_IsDocument | Returns true if there is an active document.
Public method | ScriptAccess_IsDocumentModified | Gets the modified flag of the currently loaded document.
Public method | ScriptAccess_NewDocument | Creates a new document and loads it into the Canvas.
Public method | ScriptAccess_OpenDocument()()()() | Displays a command line interface for File Open... then loads that file into the Canvas.
Public method | ScriptAccess_OpenDocument(String) | Loads a specific file off the hard disk into the Canvas.
Public method | ScriptAccess_SaveDocument | Saves the document currently loaded in the Canvas. If the document hasn't been saved before then a Save... dialog box will be shown.
Public method | ScriptAccess_SaveDocumentAs()()()() | Saves the currently active document to disk.
Public method | ScriptAccess_SaveDocumentAs(String) | Saves the currently active document to disk.
Public method | SetStatusBarEvent | Set a new message on the Grasshopper status bar.
Public method | ToggleForm | Collapses the form if it's currently expanded or expands the form if it's currently collapsed.
Protected method | WndProc | WndProc is overridden in order to allow for title-bar double-click (un)folding. (Overrides Form..::..WndProc(Message%).)

Properties

 | Name | Description
Public property | Collapsed | Gets a value indicating whether or not the form is currently collapsed.
Public property | FormShepard | Gets the form shepard for this window. Register your modeless dialogs with this shepard if you want to be popular.

Events

 | Name | Description
 | AggregateShortcutMenuItems | This event is raised whenever a GH_DocumentEditor collects all shortcuttable menu items. If you added items to the menu and you want to be able to have custom shortcuts on these items, you must handle this event and insert your own items.
Public event | EditorFoldStateChanged | This event is raised whenever the main windows folds or unfolds.

See Also

GH_DocumentEditor Class
Grasshopper.GUI Namespace


GH_DocumentEditor Constructor

[image]

Grasshopper SDK
GH_DocumentEditor Constructor
GH_DocumentEditor Class See Also Send Feedback
Initializes a new instance of the GH_DocumentEditor class

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_DocumentEditor()
Visual Basic
Public Sub New

See Also

GH_DocumentEditor Class
Grasshopper.GUI Namespace


GH_DocumentEditor Methods

[image] [image]

Grasshopper SDK
GH_DocumentEditor Methods
GH_DocumentEditor Class See Also Send Feedback

The GH_DocumentEditor type exposes the following members.

Methods

 | Name | Description
Public method | ClearStatusBar | Clear the Grasshopper status-bar.
Public method | CloseForReal | Really, really close the window.
Public method | CollapseForm | Collapses the form into the title bar area.
Public method | DisableUI | Disable all modifier UI.
Protected method | Dispose | (Overrides Form..::..Dispose(Boolean).)
Public method | EnableUI | Enable all modifier UI.
Public method | ExpandForm | Expands the form if it is currenly collapsed.
Public method | FadeIn | Call this method if the prompt switches back to Grasshopper.
Public method | FadeOut | Call this method if the prompt switches to Rhino.
Public method | ScriptAccess_CloseAllDocuments | Closes all documents in the Document Queue.
Public method | ScriptAccess_CloseDocument | Closes the currently active document and loads the next available document into the canvas. Changes will not be saved.
Public method | ScriptAccess_IsDocument | Returns true if there is an active document.
Public method | ScriptAccess_IsDocumentModified | Gets the modified flag of the currently loaded document.
Public method | ScriptAccess_NewDocument | Creates a new document and loads it into the Canvas.
Public method | ScriptAccess_OpenDocument()()()() | Displays a command line interface for File Open... then loads that file into the Canvas.
Public method | ScriptAccess_OpenDocument(String) | Loads a specific file off the hard disk into the Canvas.
Public method | ScriptAccess_SaveDocument | Saves the document currently loaded in the Canvas. If the document hasn't been saved before then a Save... dialog box will be shown.
Public method | ScriptAccess_SaveDocumentAs()()()() | Saves the currently active document to disk.
Public method | ScriptAccess_SaveDocumentAs(String) | Saves the currently active document to disk.
Public method | SetStatusBarEvent | Set a new message on the Grasshopper status bar.
Public method | ToggleForm | Collapses the form if it's currently expanded or expands the form if it's currently collapsed.
Protected method | WndProc | WndProc is overridden in order to allow for title-bar double-click (un)folding. (Overrides Form..::..WndProc(Message%).)

See Also

GH_DocumentEditor Class
Grasshopper.GUI Namespace


ClearStatusBar Method

[image]

Grasshopper SDK
GH_DocumentEditor..::..ClearStatusBar Method
GH_DocumentEditor Class See Also Send Feedback
Clear the Grasshopper status-bar.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ClearStatusBar()
Visual Basic
Public Sub ClearStatusBar

See Also

GH_DocumentEditor Class
Grasshopper.GUI Namespace


CloseForReal Method

[image]

Grasshopper SDK
GH_DocumentEditor..::..CloseForReal Method
GH_DocumentEditor Class See Also Send Feedback
Really, really close the window.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void CloseForReal()
Visual Basic
Public Sub CloseForReal

See Also

GH_DocumentEditor Class
Grasshopper.GUI Namespace


CollapseForm Method

[image]

Grasshopper SDK
GH_DocumentEditor..::..CollapseForm Method
GH_DocumentEditor Class See Also Send Feedback
Collapses the form into the title bar area.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void CollapseForm()
Visual Basic
Public Sub CollapseForm

See Also

GH_DocumentEditor Class
Grasshopper.GUI Namespace


DisableUI Method

[image]

Grasshopper SDK
GH_DocumentEditor..::..DisableUI Method
GH_DocumentEditor Class See Also Send Feedback
Disable all modifier UI.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DisableUI()
Visual Basic
Public Sub DisableUI

See Also

GH_DocumentEditor Class
Grasshopper.GUI Namespace


Dispose Method

[image]

Grasshopper SDK
GH_DocumentEditor..::..Dispose Method
GH_DocumentEditor Class See Also Send Feedback
Releases the unmanaged resources used by the GH_DocumentEditor and optionally releases the managed resources

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

GH_DocumentEditor Class
Grasshopper.GUI Namespace


EnableUI Method

[image]

Grasshopper SDK
GH_DocumentEditor..::..EnableUI Method
GH_DocumentEditor Class See Also Send Feedback
Enable all modifier UI.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void EnableUI()
Visual Basic
Public Sub EnableUI

See Also

GH_DocumentEditor Class
Grasshopper.GUI Namespace


ExpandForm Method

[image]

Grasshopper SDK
GH_DocumentEditor..::..ExpandForm Method
GH_DocumentEditor Class See Also Send Feedback
Expands the form if it is currenly collapsed.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ExpandForm()
Visual Basic
Public Sub ExpandForm

See Also

GH_DocumentEditor Class
Grasshopper.GUI Namespace


FadeIn Method

[image]

Grasshopper SDK
GH_DocumentEditor..::..FadeIn Method
GH_DocumentEditor Class See Also Send Feedback
Call this method if the prompt switches back to Grasshopper.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void FadeIn()
Visual Basic
Public Sub FadeIn

See Also

GH_DocumentEditor Class
Grasshopper.GUI Namespace


FadeOut Method

[image]

Grasshopper SDK
GH_DocumentEditor..::..FadeOut Method
GH_DocumentEditor Class See Also Send Feedback
Call this method if the prompt switches to Rhino.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void FadeOut()
Visual Basic
Public Sub FadeOut

See Also

GH_DocumentEditor Class
Grasshopper.GUI Namespace


ScriptAccess_CloseAllDocuments Method

[image]

Grasshopper SDK
GH_DocumentEditor..::..ScriptAccess_CloseAllDocuments Method
GH_DocumentEditor Class See Also Send Feedback
Closes all documents in the Document Queue.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool ScriptAccess_CloseAllDocuments()
Visual Basic
Public Function ScriptAccess_CloseAllDocuments As Boolean

Return Value

True on success, false on failure.

See Also

GH_DocumentEditor Class
Grasshopper.GUI Namespace


ScriptAccess_CloseDocument Method

[image]

Grasshopper SDK
GH_DocumentEditor..::..ScriptAccess_CloseDocument Method
GH_DocumentEditor Class See Also Send Feedback
Closes the currently active document and loads the next available document into the canvas. Changes will not be saved.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool ScriptAccess_CloseDocument()
Visual Basic
Public Function ScriptAccess_CloseDocument As Boolean

Return Value

True on success, false on failure.

See Also

GH_DocumentEditor Class
Grasshopper.GUI Namespace


ScriptAccess_IsDocument Method

[image]

Grasshopper SDK
GH_DocumentEditor..::..ScriptAccess_IsDocument Method
GH_DocumentEditor Class See Also Send Feedback
Returns true if there is an active document.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool ScriptAccess_IsDocument()
Visual Basic
Public Function ScriptAccess_IsDocument As Boolean

See Also

GH_DocumentEditor Class
Grasshopper.GUI Namespace


ScriptAccess_IsDocumentModified Method

[image]

Grasshopper SDK
GH_DocumentEditor..::..ScriptAccess_IsDocumentModified Method
GH_DocumentEditor Class See Also Send Feedback
Gets the modified flag of the currently loaded document.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool ScriptAccess_IsDocumentModified()
Visual Basic
Public Function ScriptAccess_IsDocumentModified As Boolean

Return Value

True if the document has been modified, false if not or if there is no document.

See Also

GH_DocumentEditor Class
Grasshopper.GUI Namespace


ScriptAccess_NewDocument Method

[image]

Grasshopper SDK
GH_DocumentEditor..::..ScriptAccess_NewDocument Method
GH_DocumentEditor Class See Also Send Feedback
Creates a new document and loads it into the Canvas.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool ScriptAccess_NewDocument()
Visual Basic
Public Function ScriptAccess_NewDocument As Boolean

See Also

GH_DocumentEditor Class
Grasshopper.GUI Namespace


ScriptAccess_OpenDocument Method

[image] [image]

Grasshopper SDK
GH_DocumentEditor..::..ScriptAccess_OpenDocument Method
GH_DocumentEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScriptAccess_OpenDocument()()()() | Displays a command line interface for File Open... then loads that file into the Canvas.
Public method | ScriptAccess_OpenDocument(String) | Loads a specific file off the hard disk into the Canvas.

See Also

GH_DocumentEditor Class
GH_DocumentEditor Members
Grasshopper.GUI Namespace


ScriptAccess_OpenDocument Method

[image]

Grasshopper SDK
GH_DocumentEditor..::..ScriptAccess_OpenDocument Method
GH_DocumentEditor Class See Also Send Feedback
Displays a command line interface for File Open... then loads that file into the Canvas.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool ScriptAccess_OpenDocument()
Visual Basic
Public Function ScriptAccess_OpenDocument As Boolean

Return Value

True on success, false on failure.

See Also

GH_DocumentEditor Class
ScriptAccess_OpenDocument Overload
Grasshopper.GUI Namespace


ScriptAccess_OpenDocument Method (String)

[image]

Grasshopper SDK
GH_DocumentEditor..::..ScriptAccess_OpenDocument Method (String)
GH_DocumentEditor Class See Also Send Feedback
Loads a specific file off the hard disk into the Canvas.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool ScriptAccess_OpenDocument(
    string filename
)
Visual Basic
Public Function ScriptAccess_OpenDocument ( _
    filename As String _
) As Boolean

Parameters

filename
Type: System..::..String
File to load.

Return Value

True on success, false on failure.

See Also

GH_DocumentEditor Class
ScriptAccess_OpenDocument Overload
Grasshopper.GUI Namespace


ScriptAccess_SaveDocument Method

[image]

Grasshopper SDK
GH_DocumentEditor..::..ScriptAccess_SaveDocument Method
GH_DocumentEditor Class See Also Send Feedback
Saves the document currently loaded in the Canvas. If the document hasn't been saved before then a Save... dialog box will be shown.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool ScriptAccess_SaveDocument()
Visual Basic
Public Function ScriptAccess_SaveDocument As Boolean

Return Value

True on success, false on failure.

See Also

GH_DocumentEditor Class
Grasshopper.GUI Namespace


ScriptAccess_SaveDocumentAs Method

[image] [image]

Grasshopper SDK
GH_DocumentEditor..::..ScriptAccess_SaveDocumentAs Method
GH_DocumentEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScriptAccess_SaveDocumentAs()()()() | Saves the currently active document to disk.
Public method | ScriptAccess_SaveDocumentAs(String) | Saves the currently active document to disk.

See Also

GH_DocumentEditor Class
GH_DocumentEditor Members
Grasshopper.GUI Namespace


ScriptAccess_SaveDocumentAs Method

[image]

Grasshopper SDK
GH_DocumentEditor..::..ScriptAccess_SaveDocumentAs Method
GH_DocumentEditor Class See Also Send Feedback
Saves the currently active document to disk.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool ScriptAccess_SaveDocumentAs()
Visual Basic
Public Function ScriptAccess_SaveDocumentAs As Boolean

Return Value

True on success, false on failure.

See Also

GH_DocumentEditor Class
ScriptAccess_SaveDocumentAs Overload
Grasshopper.GUI Namespace


ScriptAccess_SaveDocumentAs Method (String)

[image]

Grasshopper SDK
GH_DocumentEditor..::..ScriptAccess_SaveDocumentAs Method (String)
GH_DocumentEditor Class See Also Send Feedback
Saves the currently active document to disk.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool ScriptAccess_SaveDocumentAs(
    string path
)
Visual Basic
Public Function ScriptAccess_SaveDocumentAs ( _
    path As String _
) As Boolean

Parameters

path
Type: System..::..String
Path of save destination.

Return Value

True on success, false on failure.

See Also

GH_DocumentEditor Class
ScriptAccess_SaveDocumentAs Overload
Grasshopper.GUI Namespace


SetStatusBarEvent Method

[image]

Grasshopper SDK
GH_DocumentEditor..::..SetStatusBarEvent Method
GH_DocumentEditor Class See Also Send Feedback
Set a new message on the Grasshopper status bar.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SetStatusBarEvent(
    GH_RuntimeMessage event
)
Visual Basic
Public Sub SetStatusBarEvent ( _
    event As GH_RuntimeMessage _
)

Parameters

event
Type: Grasshopper.Kernel..::..GH_RuntimeMessage
Message to set

See Also

GH_DocumentEditor Class
Grasshopper.GUI Namespace


ToggleForm Method

[image]

Grasshopper SDK
GH_DocumentEditor..::..ToggleForm Method
GH_DocumentEditor Class See Also Send Feedback
Collapses the form if it's currently expanded or expands the form if it's currently collapsed.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ToggleForm()
Visual Basic
Public Sub ToggleForm

See Also

GH_DocumentEditor Class
Grasshopper.GUI Namespace


WndProc Method

[image]

Grasshopper SDK
GH_DocumentEditor..::..WndProc Method
GH_DocumentEditor Class See Also Send Feedback
WndProc is overridden in order to allow for title-bar double-click (un)folding.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override sealed void WndProc(
    ref Message m
)
Visual Basic
Protected Overrides NotOverridable Sub WndProc ( _
    ByRef m As Message _
)

Parameters

m
Type: System.Windows.Forms..::..Message %
Proc message.

See Also

GH_DocumentEditor Class
Grasshopper.GUI Namespace


GH_DocumentEditor Properties

[image] [image]

Grasshopper SDK
GH_DocumentEditor Properties
GH_DocumentEditor Class See Also Send Feedback

The GH_DocumentEditor type exposes the following members.

Properties

 | Name | Description
Public property | Collapsed | Gets a value indicating whether or not the form is currently collapsed.
Public property | FormShepard | Gets the form shepard for this window. Register your modeless dialogs with this shepard if you want to be popular.

See Also

GH_DocumentEditor Class
Grasshopper.GUI Namespace


Collapsed Property

[image]

Grasshopper SDK
GH_DocumentEditor..::..Collapsed Property
GH_DocumentEditor Class See Also Send Feedback
Gets a value indicating whether or not the form is currently collapsed.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Collapsed { get; }
Visual Basic
Public ReadOnly Property Collapsed As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_DocumentEditor.Collapsed"]

See Also

GH_DocumentEditor Class
Grasshopper.GUI Namespace


FormShepard Property

[image]

Grasshopper SDK
GH_DocumentEditor..::..FormShepard Property
GH_DocumentEditor Class See Also Send Feedback
Gets the form shepard for this window. Register your modeless dialogs with this shepard if you want to be popular.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_FormShepard FormShepard { get; }
Visual Basic
Public ReadOnly Property FormShepard As GH_FormShepard
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_DocumentEditor.FormShepard"]

See Also

GH_DocumentEditor Class
Grasshopper.GUI Namespace


GH_DocumentEditor Events

[image] [image]

Grasshopper SDK
GH_DocumentEditor Events
GH_DocumentEditor Class See Also Send Feedback

The GH_DocumentEditor type exposes the following members.

Events

 | Name | Description
 | AggregateShortcutMenuItems | This event is raised whenever a GH_DocumentEditor collects all shortcuttable menu items. If you added items to the menu and you want to be able to have custom shortcuts on these items, you must handle this event and insert your own items.
Public event | EditorFoldStateChanged | This event is raised whenever the main windows folds or unfolds.

See Also

GH_DocumentEditor Class
Grasshopper.GUI Namespace


AggregateShortcutMenuItems Event

[image]

Grasshopper SDK
GH_DocumentEditor..::..AggregateShortcutMenuItems Event
GH_DocumentEditor Class See Also Send Feedback
This event is raised whenever a GH_DocumentEditor collects all shortcuttable menu items. If you added items to the menu and you want to be able to have custom shortcuts on these items, you must handle this event and insert your own items.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event GH_DocumentEditor..::..AggregateShortcutMenuItemsEventHandler AggregateShortcutMenuItems
Visual Basic
Public Shared Event AggregateShortcutMenuItems As GH_DocumentEditor..::..AggregateShortcutMenuItemsEventHandler

See Also

GH_DocumentEditor Class
Grasshopper.GUI Namespace


EditorFoldStateChanged Event

[image]

Grasshopper SDK
GH_DocumentEditor..::..EditorFoldStateChanged Event
GH_DocumentEditor Class See Also Send Feedback
This event is raised whenever the main windows folds or unfolds.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_DocumentEditor..::..EditorFoldStateChangedEventHandler EditorFoldStateChanged
Visual Basic
Public Event EditorFoldStateChanged As GH_DocumentEditor..::..EditorFoldStateChangedEventHandler

See Also

GH_DocumentEditor Class
Grasshopper.GUI Namespace


GH_DocumentEditor.AggregateShortcutMenuItemsEventHandler Delegate

[image]

Grasshopper SDK
GH_DocumentEditor..::..AggregateShortcutMenuItemsEventHandler Delegate
GH_DocumentEditor Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void AggregateShortcutMenuItemsEventHandler(
    Object sender,
    GH_MenuShortcutEventArgs e
)
Visual Basic
Public Delegate Sub AggregateShortcutMenuItemsEventHandler ( _
    sender As Object, _
    e As GH_MenuShortcutEventArgs _
)

Parameters

sender
Type: System..::..Object
e
Type: GH_MenuShortcutEventArgs

See Also

Grasshopper.GUI Namespace


GH_DocumentEditor.EditorFoldStateChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_DocumentEditor..::..EditorFoldStateChangedEventHandler Delegate
GH_DocumentEditor Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void EditorFoldStateChangedEventHandler(
    GH_DocumentEditor sender,
    EventArgs e
)
Visual Basic
Public Delegate Sub EditorFoldStateChangedEventHandler ( _
    sender As GH_DocumentEditor, _
    e As EventArgs _
)

Parameters

sender
Type: Grasshopper.GUI..::..GH_DocumentEditor
e
Type: System..::..EventArgs

See Also

Grasshopper.GUI Namespace


GH_DoubleBufferedPanel Class

[image]

Grasshopper SDK
GH_DoubleBufferedPanel Class
Members See Also Send Feedback
Derives from Windows.Forms.Panel but overrides certain flags that improve on-screen rendering. Use panel if you want to have a custom drawn control that is under the control of the owner form.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_DoubleBufferedPanel : Panel
Visual Basic
Public Class GH_DoubleBufferedPanel _
    Inherits Panel

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..Panel
Grasshopper.GUI..::..GH_DoubleBufferedPanel
Grasshopper.GUI..::..GH_FontList
Grasshopper.GUI..::..GH_FontScroller
Grasshopper.GUI..::..GH_HorizontalSeparator
Grasshopper.GUI..::..GH_VerticalScrollBar
Grasshopper.GUI..::..GH_VerticalSeparator

See Also

GH_DoubleBufferedPanel Members
Grasshopper.GUI Namespace


GH_DoubleBufferedPanel Members

[image] [image]

Grasshopper SDK
GH_DoubleBufferedPanel Members
GH_DoubleBufferedPanel Class Constructors See Also Send Feedback

The GH_DoubleBufferedPanel type exposes the following members.

Constructors

 | Name | Description
Public method | GH_DoubleBufferedPanel | Initializes a new instance of the GH_DoubleBufferedPanel class

See Also

GH_DoubleBufferedPanel Class
Grasshopper.GUI Namespace


GH_DoubleBufferedPanel Constructor

[image]

Grasshopper SDK
GH_DoubleBufferedPanel Constructor
GH_DoubleBufferedPanel Class See Also Send Feedback
Initializes a new instance of the GH_DoubleBufferedPanel class

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_DoubleBufferedPanel()
Visual Basic
Public Sub New

See Also

GH_DoubleBufferedPanel Class
Grasshopper.GUI Namespace


GH_DragInfo Class

[image]

Grasshopper SDK
GH_DragInfo Class
Members See Also Send Feedback
Contains data used for UI drag operations.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_DragInfo
Visual Basic
Public Class GH_DragInfo

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI..::..GH_DragInfo

See Also

GH_DragInfo Members
Grasshopper.GUI Namespace


GH_DragInfo Members

[image] [image]

Grasshopper SDK
GH_DragInfo Members
GH_DragInfo Class Constructors Methods Properties See Also Send Feedback

The GH_DragInfo type exposes the following members.

Constructors

 | Name | Description
Public method | GH_DragInfo | Create a new DragInfo instance.

Methods

 | Name | Description
Public method | Drag | Call this method to adjust the drag data. Results will be automatically constrained and limited.

Properties

 | Name | Description
Public property | Box_Drag | Gets the dimensions of the box as a result of the dragging op.
Public property | Box_Start | Gets the dimensions of the drag box prior to dragging.
Public property | Constraint | Gets or sets the directional constraint for the drag operation.
Public property | Point_Drag | Gets the cursor location at the current moment.
Public property | Point_Start | Gets the cursor location at the start of the drag.
Public property | Region | Gets or sets the drag limits. If the region is Rectangle.Empty then the region is ignored. For valid results the Region should be larger than the dimensions of the drag box.

See Also

GH_DragInfo Class
Grasshopper.GUI Namespace


GH_DragInfo Constructor

[image]

Grasshopper SDK
GH_DragInfo Constructor
GH_DragInfo Class See Also Send Feedback
Create a new DragInfo instance.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_DragInfo(
    Point drag_point,
    Rectangle initial_shape
)
Visual Basic
Public Sub New ( _
    drag_point As Point, _
    initial_shape As Rectangle _
)

Parameters

drag_point
Type: System.Drawing..::..Point
Start point of drag op.
initial_shape
Type: System.Drawing..::..Rectangle
Initial shape associated with drag op.

See Also

GH_DragInfo Class
Grasshopper.GUI Namespace


GH_DragInfo Methods

[image] [image]

Grasshopper SDK
GH_DragInfo Methods
GH_DragInfo Class See Also Send Feedback

The GH_DragInfo type exposes the following members.

Methods

 | Name | Description
Public method | Drag | Call this method to adjust the drag data. Results will be automatically constrained and limited.

See Also

GH_DragInfo Class
Grasshopper.GUI Namespace


Drag Method

[image]

Grasshopper SDK
GH_DragInfo..::..Drag Method
GH_DragInfo Class See Also Send Feedback
Call this method to adjust the drag data. Results will be automatically constrained and limited.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Drag(
    Point new_point
)
Visual Basic
Public Sub Drag ( _
    new_point As Point _
)

Parameters

new_point
Type: System.Drawing..::..Point
New location of cursor.

See Also

GH_DragInfo Class
Grasshopper.GUI Namespace


GH_DragInfo Properties

[image] [image]

Grasshopper SDK
GH_DragInfo Properties
GH_DragInfo Class See Also Send Feedback

The GH_DragInfo type exposes the following members.

Properties

 | Name | Description
Public property | Box_Drag | Gets the dimensions of the box as a result of the dragging op.
Public property | Box_Start | Gets the dimensions of the drag box prior to dragging.
Public property | Constraint | Gets or sets the directional constraint for the drag operation.
Public property | Point_Drag | Gets the cursor location at the current moment.
Public property | Point_Start | Gets the cursor location at the start of the drag.
Public property | Region | Gets or sets the drag limits. If the region is Rectangle.Empty then the region is ignored. For valid results the Region should be larger than the dimensions of the drag box.

See Also

GH_DragInfo Class
Grasshopper.GUI Namespace


Box_Drag Property

[image]

Grasshopper SDK
GH_DragInfo..::..Box_Drag Property
GH_DragInfo Class See Also Send Feedback
Gets the dimensions of the box as a result of the dragging op.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle Box_Drag { get; }
Visual Basic
Public ReadOnly Property Box_Drag As Rectangle
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_DragInfo.Box_Drag"]

See Also

GH_DragInfo Class
Grasshopper.GUI Namespace


Box_Start Property

[image]

Grasshopper SDK
GH_DragInfo..::..Box_Start Property
GH_DragInfo Class See Also Send Feedback
Gets the dimensions of the drag box prior to dragging.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle Box_Start { get; }
Visual Basic
Public ReadOnly Property Box_Start As Rectangle
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_DragInfo.Box_Start"]

See Also

GH_DragInfo Class
Grasshopper.GUI Namespace


Constraint Property

[image]

Grasshopper SDK
GH_DragInfo..::..Constraint Property
GH_DragInfo Class See Also Send Feedback
Gets or sets the directional constraint for the drag operation.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Constraint Constraint { get; set; }
Visual Basic
Public Property Constraint As GH_Constraint
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_DragInfo.Constraint"]

See Also

GH_DragInfo Class
Grasshopper.GUI Namespace


Point_Drag Property

[image]

Grasshopper SDK
GH_DragInfo..::..Point_Drag Property
GH_DragInfo Class See Also Send Feedback
Gets the cursor location at the current moment.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Point Point_Drag { get; }
Visual Basic
Public ReadOnly Property Point_Drag As Point
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_DragInfo.Point_Drag"]

See Also

GH_DragInfo Class
Grasshopper.GUI Namespace


Point_Start Property

[image]

Grasshopper SDK
GH_DragInfo..::..Point_Start Property
GH_DragInfo Class See Also Send Feedback
Gets the cursor location at the start of the drag.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Point Point_Start { get; }
Visual Basic
Public ReadOnly Property Point_Start As Point
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_DragInfo.Point_Start"]

See Also

GH_DragInfo Class
Grasshopper.GUI Namespace


Region Property

[image]

Grasshopper SDK
GH_DragInfo..::..Region Property
GH_DragInfo Class See Also Send Feedback
Gets or sets the drag limits. If the region is Rectangle.Empty then the region is ignored. For valid results the Region should be larger than the dimensions of the drag box.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle Region { get; set; }
Visual Basic
Public Property Region As Rectangle
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_DragInfo.Region"]

See Also

GH_DragInfo Class
Grasshopper.GUI Namespace


GH_ExternalFileConflictDialog Class

[image]

Grasshopper SDK
GH_ExternalFileConflictDialog Class
Members See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_ExternalFileConflictDialog : Form
Visual Basic
Public Class GH_ExternalFileConflictDialog _
    Inherits Form

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
Grasshopper.GUI..::..GH_ExternalFileConflictDialog

See Also

GH_ExternalFileConflictDialog Members
Grasshopper.GUI Namespace


GH_ExternalFileConflictDialog Members

[image] [image]

Grasshopper SDK
GH_ExternalFileConflictDialog Members
GH_ExternalFileConflictDialog Class Constructors Methods Properties See Also Send Feedback

The GH_ExternalFileConflictDialog type exposes the following members.

Constructors

 | Name | Description
Public method | GH_ExternalFileConflictDialog | Initializes a new instance of the GH_ExternalFileConflictDialog class

Methods

 | Name | Description
Protected method | Dispose | Releases the unmanaged resources used by the GH_ExternalFileConflictDialog and optionally releases the managed resources (Overrides Form..::..Dispose(Boolean).)

Properties

 | Name | Description
Public property | FilePathA |
Public property | FilePathB |
Public property | LoadFileCode |

See Also

GH_ExternalFileConflictDialog Class
Grasshopper.GUI Namespace


GH_ExternalFileConflictDialog Constructor

[image]

Grasshopper SDK
GH_ExternalFileConflictDialog Constructor
GH_ExternalFileConflictDialog Class See Also Send Feedback
Initializes a new instance of the GH_ExternalFileConflictDialog class

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ExternalFileConflictDialog()
Visual Basic
Public Sub New

See Also

GH_ExternalFileConflictDialog Class
Grasshopper.GUI Namespace


GH_ExternalFileConflictDialog Methods

[image] [image]

Grasshopper SDK
GH_ExternalFileConflictDialog Methods
GH_ExternalFileConflictDialog Class See Also Send Feedback

The GH_ExternalFileConflictDialog type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | (Overrides Form..::..Dispose(Boolean).)

See Also

GH_ExternalFileConflictDialog Class
Grasshopper.GUI Namespace


Dispose Method

[image]

Grasshopper SDK
GH_ExternalFileConflictDialog..::..Dispose Method
GH_ExternalFileConflictDialog Class See Also Send Feedback
Releases the unmanaged resources used by the GH_ExternalFileConflictDialog and optionally releases the managed resources

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

GH_ExternalFileConflictDialog Class
Grasshopper.GUI Namespace


GH_ExternalFileConflictDialog Properties

[image] [image]

Grasshopper SDK
GH_ExternalFileConflictDialog Properties
GH_ExternalFileConflictDialog Class See Also Send Feedback

The GH_ExternalFileConflictDialog type exposes the following members.

Properties

 | Name | Description
Public property | FilePathA |
Public property | FilePathB |
Public property | LoadFileCode |

See Also

GH_ExternalFileConflictDialog Class
Grasshopper.GUI Namespace


FilePathA Property

[image]

Grasshopper SDK
GH_ExternalFileConflictDialog..::..FilePathA Property
GH_ExternalFileConflictDialog Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string FilePathA { get; set; }
Visual Basic
Public Property FilePathA As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_ExternalFileConflictDialog.FilePathA"]

See Also

GH_ExternalFileConflictDialog Class
Grasshopper.GUI Namespace


FilePathB Property

[image]

Grasshopper SDK
GH_ExternalFileConflictDialog..::..FilePathB Property
GH_ExternalFileConflictDialog Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string FilePathB { get; set; }
Visual Basic
Public Property FilePathB As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_ExternalFileConflictDialog.FilePathB"]

See Also

GH_ExternalFileConflictDialog Class
Grasshopper.GUI Namespace


LoadFileCode Property

[image]

Grasshopper SDK
GH_ExternalFileConflictDialog..::..LoadFileCode Property
GH_ExternalFileConflictDialog Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int LoadFileCode { get; }
Visual Basic
Public ReadOnly Property LoadFileCode As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_ExternalFileConflictDialog.LoadFileCode"]

See Also

GH_ExternalFileConflictDialog Class
Grasshopper.GUI Namespace


GH_FadeAnimation Class

[image]

Grasshopper SDK
GH_FadeAnimation Class
Members See Also Send Feedback
Utility class for animating fade ZUI events on the canvas.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_FadeAnimation
Visual Basic
Public Class GH_FadeAnimation

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI..::..GH_FadeAnimation

See Also

GH_FadeAnimation Members
Grasshopper.GUI Namespace


GH_FadeAnimation Members

[image] [image]

Grasshopper SDK
GH_FadeAnimation Members
GH_FadeAnimation Class Constructors Methods Fields Properties See Also Send Feedback

The GH_FadeAnimation type exposes the following members.

Constructors

 | Name | Description
Public method | GH_FadeAnimation()()()() | Creates a new instance of the Animator class with default settings.
Public method | GH_FadeAnimation(Single) | Create a new instance of the Animator class with custom values for zoom threshold.
Public method | GH_FadeAnimation(Single, Int32) | Create a new instance of the Animator class with custom values for zoom threshold and duration.

Methods

 | Name | Description
Public method | Evaluate(GH_Canvas) | Reevaluate the fade animation parameters. You should call this method from within the Render method of your attributes. If an animation is currently in progress a redraw of the canvas will be scheduled, whether or not the attributes are actually visible on the canvas. You should therefore only call this method if your attributes are already drawing themselves.
Public method | Evaluate(GH_Canvas, Boolean) | Reevaluate the fade animation parameters. You should call this method from within the Render method of your attributes. If an animation is currently in progress a redraw of the canvas will be scheduled, whether or not the attributes are actually visible on the canvas. You should therefore only call this method if your attributes are already drawing themselves.
Public method | Evaluate(GH_Canvas, Single) | Reevaluate the fade animation parameters. You should call this method from within the Render method of your attributes. If an animation is currently in progress a redraw of the canvas will be scheduled, whether or not the attributes are actually visible on the canvas. You should therefore only call this method if your attributes are already drawing themselves.
Public method | Evaluate(GH_Canvas, Single, Boolean) | Reevaluate the fade animation parameters. You should call this method from within the Render method of your attributes. If an animation is currently in progress a redraw of the canvas will be scheduled, whether or not the attributes are actually visible on the canvas. You should therefore only call this method if your attributes are already drawing themselves.

Fields

Name | Description
Delay | Gets the number of milliseconds between redraws (25 milliseconds, resulting in ~40 fps)

Properties

 | Name | Description
Public property | Duration | Gets or sets the duration (in milliseconds) for ZUI animations. Negative durations are not allowed. The default is 350 milliseconds.
Public property | FadeAlpha | Gets the blend alpha byte for the current state. 0 means fully hidden, 255 means fully shown.
Public property | FadeFactor | Gets the blend factor for the current state. 0.0 means fully hidden, 1.0 means fully shown.
Public property | IsFinished | Gets a value indicating whether this animator has finished animating.
Public property | Phase | Gets the current animation phase.
Public property | Threshold | Gets or sets the threshold value for the fade animation trigger.
Public property | TriggerUpdate | Gets or sets whether this animator triggers canvas updates.

See Also

GH_FadeAnimation Class
Grasshopper.GUI Namespace


GH_FadeAnimation Constructor

[image] [image]

Grasshopper SDK
GH_FadeAnimation Constructor
GH_FadeAnimation Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_FadeAnimation()()()() | Creates a new instance of the Animator class with default settings.
Public method | GH_FadeAnimation(Single) | Create a new instance of the Animator class with custom values for zoom threshold.
Public method | GH_FadeAnimation(Single, Int32) | Create a new instance of the Animator class with custom values for zoom threshold and duration.

See Also

GH_FadeAnimation Class
GH_FadeAnimation Members
Grasshopper.GUI Namespace


GH_FadeAnimation Constructor

[image]

Grasshopper SDK
GH_FadeAnimation Constructor
GH_FadeAnimation Class See Also Send Feedback
Creates a new instance of the Animator class with default settings.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_FadeAnimation()
Visual Basic
Public Sub New

See Also

GH_FadeAnimation Class
GH_FadeAnimation Overload
Grasshopper.GUI Namespace


GH_FadeAnimation Constructor (Single)

[image]

Grasshopper SDK
GH_FadeAnimation Constructor (Single)
GH_FadeAnimation Class See Also Send Feedback
Create a new instance of the Animator class with custom values for zoom threshold.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_FadeAnimation(
    float threshold
)
Visual Basic
Public Sub New ( _
    threshold As Single _
)

Parameters

threshold
Type: System..::..Single
Zoom threshold at which the animation kicks in. The default is 2.0

See Also

GH_FadeAnimation Class
GH_FadeAnimation Overload
Grasshopper.GUI Namespace


GH_FadeAnimation Constructor (Single, Int32)

[image]

Grasshopper SDK
GH_FadeAnimation Constructor (Single, Int32)
GH_FadeAnimation Class See Also Send Feedback
Create a new instance of the Animator class with custom values for zoom threshold and duration.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_FadeAnimation(
    float threshold,
    int duration
)
Visual Basic
Public Sub New ( _
    threshold As Single, _
    duration As Integer _
)

Parameters

threshold
Type: System..::..Single
Zoom threshold at which the animation kicks in. The default is 2.0
duration
Type: System..::..Int32
The duration (in milliseconds) of the fade animation, the default is 350

See Also

GH_FadeAnimation Class
GH_FadeAnimation Overload
Grasshopper.GUI Namespace


GH_FadeAnimation Fields

[image] [image]

Grasshopper SDK
GH_FadeAnimation Fields
GH_FadeAnimation Class See Also Send Feedback

The GH_FadeAnimation type exposes the following members.

Fields

Name | Description
Delay | Gets the number of milliseconds between redraws (25 milliseconds, resulting in ~40 fps)

See Also

GH_FadeAnimation Class
Grasshopper.GUI Namespace


Delay Field

[image]

Grasshopper SDK
GH_FadeAnimation..::..Delay Field
GH_FadeAnimation Class See Also Send Feedback
Gets the number of milliseconds between redraws (25 milliseconds, resulting in ~40 fps)

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const int Delay
Visual Basic
Public Const Delay As Integer

See Also

GH_FadeAnimation Class
Grasshopper.GUI Namespace


GH_FadeAnimation Methods

[image] [image]

Grasshopper SDK
GH_FadeAnimation Methods
GH_FadeAnimation Class See Also Send Feedback

Methods

 | Name | Description
Public method | Evaluate(GH_Canvas) | Reevaluate the fade animation parameters. You should call this method from within the Render method of your attributes. If an animation is currently in progress a redraw of the canvas will be scheduled, whether or not the attributes are actually visible on the canvas. You should therefore only call this method if your attributes are already drawing themselves.
Public method | Evaluate(GH_Canvas, Boolean) | Reevaluate the fade animation parameters. You should call this method from within the Render method of your attributes. If an animation is currently in progress a redraw of the canvas will be scheduled, whether or not the attributes are actually visible on the canvas. You should therefore only call this method if your attributes are already drawing themselves.
Public method | Evaluate(GH_Canvas, Single) | Reevaluate the fade animation parameters. You should call this method from within the Render method of your attributes. If an animation is currently in progress a redraw of the canvas will be scheduled, whether or not the attributes are actually visible on the canvas. You should therefore only call this method if your attributes are already drawing themselves.
Public method | Evaluate(GH_Canvas, Single, Boolean) | Reevaluate the fade animation parameters. You should call this method from within the Render method of your attributes. If an animation is currently in progress a redraw of the canvas will be scheduled, whether or not the attributes are actually visible on the canvas. You should therefore only call this method if your attributes are already drawing themselves.

See Also

GH_FadeAnimation Class
Grasshopper.GUI Namespace


Evaluate Method

[image] [image]

Grasshopper SDK
GH_FadeAnimation..::..Evaluate Method
GH_FadeAnimation Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Evaluate(GH_Canvas) | Reevaluate the fade animation parameters. You should call this method from within the Render method of your attributes. If an animation is currently in progress a redraw of the canvas will be scheduled, whether or not the attributes are actually visible on the canvas. You should therefore only call this method if your attributes are already drawing themselves.
Public method | Evaluate(GH_Canvas, Boolean) | Reevaluate the fade animation parameters. You should call this method from within the Render method of your attributes. If an animation is currently in progress a redraw of the canvas will be scheduled, whether or not the attributes are actually visible on the canvas. You should therefore only call this method if your attributes are already drawing themselves.
Public method | Evaluate(GH_Canvas, Single) | Reevaluate the fade animation parameters. You should call this method from within the Render method of your attributes. If an animation is currently in progress a redraw of the canvas will be scheduled, whether or not the attributes are actually visible on the canvas. You should therefore only call this method if your attributes are already drawing themselves.
Public method | Evaluate(GH_Canvas, Single, Boolean) | Reevaluate the fade animation parameters. You should call this method from within the Render method of your attributes. If an animation is currently in progress a redraw of the canvas will be scheduled, whether or not the attributes are actually visible on the canvas. You should therefore only call this method if your attributes are already drawing themselves.

See Also

GH_FadeAnimation Class
GH_FadeAnimation Members
Grasshopper.GUI Namespace


Evaluate Method (GH_Canvas)

[image]

Grasshopper SDK
GH_FadeAnimation..::..Evaluate Method (GH_Canvas)
GH_FadeAnimation Class See Also Send Feedback
Reevaluate the fade animation parameters. You should call this method from within the Render method of your attributes. If an animation is currently in progress a redraw of the canvas will be scheduled, whether or not the attributes are actually visible on the canvas. You should therefore only call this method if your attributes are already drawing themselves.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Evaluate(
    GH_Canvas canvas
)
Visual Basic
Public Sub Evaluate ( _
    canvas As GH_Canvas _
)

Parameters

canvas
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
Canvas currently drawing in.

See Also

GH_FadeAnimation Class
Evaluate Overload
Grasshopper.GUI Namespace


Evaluate Method (GH_Canvas, Boolean)

[image]

Grasshopper SDK
GH_FadeAnimation..::..Evaluate Method (GH_Canvas, Boolean)
GH_FadeAnimation Class See Also Send Feedback
Reevaluate the fade animation parameters. You should call this method from within the Render method of your attributes. If an animation is currently in progress a redraw of the canvas will be scheduled, whether or not the attributes are actually visible on the canvas. You should therefore only call this method if your attributes are already drawing themselves.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Evaluate(
    GH_Canvas canvas,
    bool scheduleRedraw
)
Visual Basic
Public Sub Evaluate ( _
    canvas As GH_Canvas, _
    scheduleRedraw As Boolean _
)

Parameters

canvas
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
Canvas currently drawing in.
scheduleRedraw
Type: System..::..Boolean
If true and the animator is active, a redraw will be scheduled.

See Also

GH_FadeAnimation Class
Evaluate Overload
Grasshopper.GUI Namespace


Evaluate Method (GH_Canvas, Single)

[image]

Grasshopper SDK
GH_FadeAnimation..::..Evaluate Method (GH_Canvas, Single)
GH_FadeAnimation Class See Also Send Feedback
Reevaluate the fade animation parameters. You should call this method from within the Render method of your attributes. If an animation is currently in progress a redraw of the canvas will be scheduled, whether or not the attributes are actually visible on the canvas. You should therefore only call this method if your attributes are already drawing themselves.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Evaluate(
    GH_Canvas canvas,
    float value
)
Visual Basic
Public Sub Evaluate ( _
    canvas As GH_Canvas, _
    value As Single _
)

Parameters

canvas
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
Canvas currently drawing in.
value
Type: System..::..Single

See Also

GH_FadeAnimation Class
Evaluate Overload
Grasshopper.GUI Namespace


Evaluate Method (GH_Canvas, Single, Boolean)

[image]

Grasshopper SDK
GH_FadeAnimation..::..Evaluate Method (GH_Canvas, Single, Boolean)
GH_FadeAnimation Class See Also Send Feedback
Reevaluate the fade animation parameters. You should call this method from within the Render method of your attributes. If an animation is currently in progress a redraw of the canvas will be scheduled, whether or not the attributes are actually visible on the canvas. You should therefore only call this method if your attributes are already drawing themselves.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Evaluate(
    GH_Canvas canvas,
    float value,
    bool scheduleRedraw
)
Visual Basic
Public Sub Evaluate ( _
    canvas As GH_Canvas, _
    value As Single, _
    scheduleRedraw As Boolean _
)

Parameters

canvas
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
Canvas currently drawing in.
value
Type: System..::..Single
scheduleRedraw
Type: System..::..Boolean
If true and the animator is active, a redraw will be scheduled.

See Also

GH_FadeAnimation Class
Evaluate Overload
Grasshopper.GUI Namespace


GH_FadeAnimation Properties

[image] [image]

Grasshopper SDK
GH_FadeAnimation Properties
GH_FadeAnimation Class See Also Send Feedback

The GH_FadeAnimation type exposes the following members.

Properties

 | Name | Description
Public property | Duration | Gets or sets the duration (in milliseconds) for ZUI animations. Negative durations are not allowed. The default is 350 milliseconds.
Public property | FadeAlpha | Gets the blend alpha byte for the current state. 0 means fully hidden, 255 means fully shown.
Public property | FadeFactor | Gets the blend factor for the current state. 0.0 means fully hidden, 1.0 means fully shown.
Public property | IsFinished | Gets a value indicating whether this animator has finished animating.
Public property | Phase | Gets the current animation phase.
Public property | Threshold | Gets or sets the threshold value for the fade animation trigger.
Public property | TriggerUpdate | Gets or sets whether this animator triggers canvas updates.

See Also

GH_FadeAnimation Class
Grasshopper.GUI Namespace


Duration Property

[image]

Grasshopper SDK
GH_FadeAnimation..::..Duration Property
GH_FadeAnimation Class See Also Send Feedback
Gets or sets the duration (in milliseconds) for ZUI animations. Negative durations are not allowed. The default is 350 milliseconds.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int Duration { get; set; }
Visual Basic
Public Property Duration As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_FadeAnimation.Duration"]

See Also

GH_FadeAnimation Class
Grasshopper.GUI Namespace


FadeAlpha Property

[image]

Grasshopper SDK
GH_FadeAnimation..::..FadeAlpha Property
GH_FadeAnimation Class See Also Send Feedback
Gets the blend alpha byte for the current state. 0 means fully hidden, 255 means fully shown.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int FadeAlpha { get; }
Visual Basic
Public ReadOnly Property FadeAlpha As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_FadeAnimation.FadeAlpha"]

See Also

GH_FadeAnimation Class
Grasshopper.GUI Namespace


FadeFactor Property

[image]

Grasshopper SDK
GH_FadeAnimation..::..FadeFactor Property
GH_FadeAnimation Class See Also Send Feedback
Gets the blend factor for the current state. 0.0 means fully hidden, 1.0 means fully shown.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double FadeFactor { get; }
Visual Basic
Public ReadOnly Property FadeFactor As Double
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_FadeAnimation.FadeFactor"]

See Also

GH_FadeAnimation Class
Grasshopper.GUI Namespace


IsFinished Property

[image]

Grasshopper SDK
GH_FadeAnimation..::..IsFinished Property
GH_FadeAnimation Class See Also Send Feedback
Gets a value indicating whether this animator has finished animating.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsFinished { get; }
Visual Basic
Public ReadOnly Property IsFinished As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_FadeAnimation.IsFinished"]

See Also

GH_FadeAnimation Class
Grasshopper.GUI Namespace


Phase Property

[image]

Grasshopper SDK
GH_FadeAnimation..::..Phase Property
GH_FadeAnimation Class See Also Send Feedback
Gets the current animation phase.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_FadePhase Phase { get; }
Visual Basic
Public ReadOnly Property Phase As GH_FadePhase
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_FadeAnimation.Phase"]

See Also

GH_FadeAnimation Class
Grasshopper.GUI Namespace


Threshold Property

[image]

Grasshopper SDK
GH_FadeAnimation..::..Threshold Property
GH_FadeAnimation Class See Also Send Feedback
Gets or sets the threshold value for the fade animation trigger.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public float Threshold { get; set; }
Visual Basic
Public Property Threshold As Single
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_FadeAnimation.Threshold"]

See Also

GH_FadeAnimation Class
Grasshopper.GUI Namespace


TriggerUpdate Property

[image]

Grasshopper SDK
GH_FadeAnimation..::..TriggerUpdate Property
GH_FadeAnimation Class See Also Send Feedback
Gets or sets whether this animator triggers canvas updates.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool TriggerUpdate { get; set; }
Visual Basic
Public Property TriggerUpdate As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_FadeAnimation.TriggerUpdate"]

See Also

GH_FadeAnimation Class
Grasshopper.GUI Namespace


GH_FadePhase Enumeration

[image]

Grasshopper SDK
GH_FadePhase Enumeration
See Also Send Feedback
Enumerates the possible states of a ZUI fade animation.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_FadePhase
Visual Basic
Public Enumeration GH_FadePhase

Members

Member name | Value | Description
Hidden | 0 | Indicates the UI elements ought to be hidden.
Hiding | 1 | Indicates the UI elements are in the process of being hidden.
Shown | 2 | Indicates the UI elements ought to be shown.
Showing | 3 | Indicates the UI elements are in the process of being shown.

See Also

Grasshopper.GUI Namespace


GH_FontControl Class

[image]

Grasshopper SDK
GH_FontControl Class
Members See Also Send Feedback
Represents a control that offers both Font preview and Picking methods.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_FontControl : UserControl
Visual Basic
Public Class GH_FontControl _
    Inherits UserControl

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
Grasshopper.GUI..::..GH_FontControl

See Also

GH_FontControl Members
Grasshopper.GUI Namespace


GH_FontControl Members

[image] [image]

Grasshopper SDK
GH_FontControl Members
GH_FontControl Class Constructors Methods Properties See Also Send Feedback

The GH_FontControl type exposes the following members.

Constructors

 | Name | Description
Public method | GH_FontControl | Initializes a new instance of the GH_FontControl class

Methods

 | Name | Description
Protected method | Dispose | Releases the unmanaged resources used by the GH_FontControl and optionally releases the managed resources (Overrides ContainerControl..::..Dispose(Boolean).)

Properties

 | Name | Description
Public property | AllowFamilyOverride |
Public property | AllowSizeOverride |
Public property | AllowStyleOverride |

See Also

GH_FontControl Class
Grasshopper.GUI Namespace


GH_FontControl Constructor

[image]

Grasshopper SDK
GH_FontControl Constructor
GH_FontControl Class See Also Send Feedback
Initializes a new instance of the GH_FontControl class

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_FontControl()
Visual Basic
Public Sub New

See Also

GH_FontControl Class
Grasshopper.GUI Namespace


GH_FontControl Methods

[image] [image]

Grasshopper SDK
GH_FontControl Methods
GH_FontControl Class See Also Send Feedback

The GH_FontControl type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | (Overrides ContainerControl..::..Dispose(Boolean).)

See Also

GH_FontControl Class
Grasshopper.GUI Namespace


Dispose Method

[image]

Grasshopper SDK
GH_FontControl..::..Dispose Method
GH_FontControl Class See Also Send Feedback
Releases the unmanaged resources used by the GH_FontControl and optionally releases the managed resources

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

GH_FontControl Class
Grasshopper.GUI Namespace


GH_FontControl Properties

[image] [image]

Grasshopper SDK
GH_FontControl Properties
GH_FontControl Class See Also Send Feedback

The GH_FontControl type exposes the following members.

Properties

 | Name | Description
Public property | AllowFamilyOverride |
Public property | AllowSizeOverride |
Public property | AllowStyleOverride |

See Also

GH_FontControl Class
Grasshopper.GUI Namespace


AllowFamilyOverride Property

[image]

Grasshopper SDK
GH_FontControl..::..AllowFamilyOverride Property
GH_FontControl Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool AllowFamilyOverride { get; set; }
Visual Basic
Public Property AllowFamilyOverride As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_FontControl.AllowFamilyOverride"]

See Also

GH_FontControl Class
Grasshopper.GUI Namespace


AllowSizeOverride Property

[image]

Grasshopper SDK
GH_FontControl..::..AllowSizeOverride Property
GH_FontControl Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool AllowSizeOverride { get; set; }
Visual Basic
Public Property AllowSizeOverride As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_FontControl.AllowSizeOverride"]

See Also

GH_FontControl Class
Grasshopper.GUI Namespace


AllowStyleOverride Property

[image]

Grasshopper SDK
GH_FontControl..::..AllowStyleOverride Property
GH_FontControl Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool AllowStyleOverride { get; set; }
Visual Basic
Public Property AllowStyleOverride As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_FontControl.AllowStyleOverride"]

See Also

GH_FontControl Class
Grasshopper.GUI Namespace


GH_FontList Class

[image]

Grasshopper SDK
GH_FontList Class
Members See Also Send Feedback
Represents the installed Font collection. This control allows both navigation and selection of Font Families.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_FontList : GH_DoubleBufferedPanel
Visual Basic
Public Class GH_FontList _
    Inherits GH_DoubleBufferedPanel

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..Panel
Grasshopper.GUI..::..GH_DoubleBufferedPanel
Grasshopper.GUI..::..GH_FontList

See Also

GH_FontList Members
Grasshopper.GUI Namespace


GH_FontList Members

[image] [image]

Grasshopper SDK
GH_FontList Members
GH_FontList Class Constructors Methods Properties See Also Send Feedback

The GH_FontList type exposes the following members.

Constructors

 | Name | Description
Public method | GH_FontList | Initializes a new instance of the GH_FontList class

Methods

 | Name | Description
Public method | CreateFont | Create a font that best approximates the current settings.
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | (Overrides ScrollableControl..::..OnPaintBackground(PaintEventArgs).)
Public method | RecreateFontList |

Properties

 | Name | Description
Public property | DisplayText | Gets or sets the placeholder string.
Public property | Filter | Gets or sets the filter string. You must call RecreateFontList() before the new font list is created.
Public property | FontFamily | Gets or sets the selected font family.
Public property | FontSize | Gets or sets the font size.
Public property | FontStyle | Gets or sets the font style for all families.

See Also

GH_FontList Class
Grasshopper.GUI Namespace


GH_FontList Constructor

[image]

Grasshopper SDK
GH_FontList Constructor
GH_FontList Class See Also Send Feedback
Initializes a new instance of the GH_FontList class

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_FontList()
Visual Basic
Public Sub New

See Also

GH_FontList Class
Grasshopper.GUI Namespace


GH_FontList Methods

[image] [image]

Grasshopper SDK
GH_FontList Methods
GH_FontList Class See Also Send Feedback

The GH_FontList type exposes the following members.

Methods

 | Name | Description
Public method | CreateFont | Create a font that best approximates the current settings.
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | (Overrides ScrollableControl..::..OnPaintBackground(PaintEventArgs).)
Public method | RecreateFontList |

See Also

GH_FontList Class
Grasshopper.GUI Namespace


CreateFont Method

[image]

Grasshopper SDK
GH_FontList..::..CreateFont Method
GH_FontList Class See Also Send Feedback
Create a font that best approximates the current settings.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Font CreateFont()
Visual Basic
Public Function CreateFont As Font

See Also

GH_FontList Class
Grasshopper.GUI Namespace


OnPaint Method

[image]

Grasshopper SDK
GH_FontList..::..OnPaint Method
GH_FontList Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

GH_FontList Class
Grasshopper.GUI Namespace


OnPaintBackground Method

[image]

Grasshopper SDK
GH_FontList..::..OnPaintBackground Method
GH_FontList Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void OnPaintBackground(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaintBackground ( _
    e As PaintEventArgs _
)

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

GH_FontList Class
Grasshopper.GUI Namespace


RecreateFontList Method

[image]

Grasshopper SDK
GH_FontList..::..RecreateFontList Method
GH_FontList Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RecreateFontList()
Visual Basic
Public Sub RecreateFontList

See Also

GH_FontList Class
Grasshopper.GUI Namespace


GH_FontList Properties

[image] [image]

Grasshopper SDK
GH_FontList Properties
GH_FontList Class See Also Send Feedback

The GH_FontList type exposes the following members.

Properties

 | Name | Description
Public property | DisplayText | Gets or sets the placeholder string.
Public property | Filter | Gets or sets the filter string. You must call RecreateFontList() before the new font list is created.
Public property | FontFamily | Gets or sets the selected font family.
Public property | FontSize | Gets or sets the font size.
Public property | FontStyle | Gets or sets the font style for all families.

See Also

GH_FontList Class
Grasshopper.GUI Namespace


DisplayText Property

[image]

Grasshopper SDK
GH_FontList..::..DisplayText Property
GH_FontList Class See Also Send Feedback
Gets or sets the placeholder string.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string DisplayText { get; set; }
Visual Basic
Public Property DisplayText As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_FontList.DisplayText"]

See Also

GH_FontList Class
Grasshopper.GUI Namespace


Filter Property

[image]

Grasshopper SDK
GH_FontList..::..Filter Property
GH_FontList Class See Also Send Feedback
Gets or sets the filter string. You must call RecreateFontList() before the new font list is created.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Filter { get; set; }
Visual Basic
Public Property Filter As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_FontList.Filter"]

See Also

GH_FontList Class
Grasshopper.GUI Namespace


FontFamily Property

[image]

Grasshopper SDK
GH_FontList..::..FontFamily Property
GH_FontList Class See Also Send Feedback
Gets or sets the selected font family.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public FontFamily FontFamily { get; set; }
Visual Basic
Public Property FontFamily As FontFamily
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_FontList.FontFamily"]

See Also

GH_FontList Class
Grasshopper.GUI Namespace


FontSize Property

[image]

Grasshopper SDK
GH_FontList..::..FontSize Property
GH_FontList Class See Also Send Feedback
Gets or sets the font size.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public float FontSize { get; set; }
Visual Basic
Public Property FontSize As Single
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_FontList.FontSize"]

See Also

GH_FontList Class
Grasshopper.GUI Namespace


FontStyle Property

[image]

Grasshopper SDK
GH_FontList..::..FontStyle Property
GH_FontList Class See Also Send Feedback
Gets or sets the font style for all families.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public FontStyle FontStyle { get; set; }
Visual Basic
Public Property FontStyle As FontStyle
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_FontList.FontStyle"]

See Also

GH_FontList Class
Grasshopper.GUI Namespace


GH_FontPicker Class

[image]

Grasshopper SDK
GH_FontPicker Class
Members See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_FontPicker : UserControl
Visual Basic
Public Class GH_FontPicker _
    Inherits UserControl

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
Grasshopper.GUI..::..GH_FontPicker

See Also

GH_FontPicker Members
Grasshopper.GUI Namespace


GH_FontPicker Members

[image] [image]

Grasshopper SDK
GH_FontPicker Members
GH_FontPicker Class Constructors Methods Properties See Also Send Feedback

The GH_FontPicker type exposes the following members.

Constructors

 | Name | Description
Public method | GH_FontPicker | Initializes a new instance of the GH_FontPicker class

Methods

 | Name | Description
 | CreateFontPickerWindow | Create a new window containing a Font Picker object and OK, Cancel buttons. Picked fonts will be stored in the Tag field of the form.
Protected method | Dispose | Releases the unmanaged resources used by the GH_FontPicker and optionally releases the managed resources (Overrides ContainerControl..::..Dispose(Boolean).)
 | ShowFontPickerWindow(Font) | Display the fontpicker in a window.
 | ShowFontPickerWindow(Font, Form) | Display the fontpicker in a window.

Properties

 | Name | Description
Public property | SelectedFont |

See Also

GH_FontPicker Class
Grasshopper.GUI Namespace


GH_FontPicker Constructor

[image]

Grasshopper SDK
GH_FontPicker Constructor
GH_FontPicker Class See Also Send Feedback
Initializes a new instance of the GH_FontPicker class

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_FontPicker()
Visual Basic
Public Sub New

See Also

GH_FontPicker Class
Grasshopper.GUI Namespace


GH_FontPicker Methods

[image] [image]

Grasshopper SDK
GH_FontPicker Methods
GH_FontPicker Class See Also Send Feedback

The GH_FontPicker type exposes the following members.

Methods

 | Name | Description
 | CreateFontPickerWindow | Create a new window containing a Font Picker object and OK, Cancel buttons. Picked fonts will be stored in the Tag field of the form.
Protected method | Dispose | (Overrides ContainerControl..::..Dispose(Boolean).)
 | ShowFontPickerWindow(Font) | Display the fontpicker in a window.
 | ShowFontPickerWindow(Font, Form) | Display the fontpicker in a window.

See Also

GH_FontPicker Class
Grasshopper.GUI Namespace


CreateFontPickerWindow Method

[image]

Grasshopper SDK
GH_FontPicker..::..CreateFontPickerWindow Method
GH_FontPicker Class See Also Send Feedback
Create a new window containing a Font Picker object and OK, Cancel buttons. Picked fonts will be stored in the Tag field of the form.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Form CreateFontPickerWindow(
    Font defaultFont
)
Visual Basic
Public Shared Function CreateFontPickerWindow ( _
    defaultFont As Font _
) As Form

Parameters

defaultFont
Type: System.Drawing..::..Font

Return Value

A window with a font picker.

See Also

GH_FontPicker Class
Grasshopper.GUI Namespace


Dispose Method

[image]

Grasshopper SDK
GH_FontPicker..::..Dispose Method
GH_FontPicker Class See Also Send Feedback
Releases the unmanaged resources used by the GH_FontPicker and optionally releases the managed resources

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

GH_FontPicker Class
Grasshopper.GUI Namespace


ShowFontPickerWindow Method

[image] [image]

Grasshopper SDK
GH_FontPicker..::..ShowFontPickerWindow Method
GH_FontPicker Class See Also Send Feedback

Overload List

Name | Description
ShowFontPickerWindow(Font) | Display the fontpicker in a window.
ShowFontPickerWindow(Font, Form) | Display the fontpicker in a window.

See Also

GH_FontPicker Class
GH_FontPicker Members
Grasshopper.GUI Namespace


ShowFontPickerWindow Method (Font)

[image]

Grasshopper SDK
GH_FontPicker..::..ShowFontPickerWindow Method (Font)
GH_FontPicker Class See Also Send Feedback
Display the fontpicker in a window.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Font ShowFontPickerWindow(
    Font font
)
Visual Basic
Public Shared Function ShowFontPickerWindow ( _
    font As Font _
) As Font

Parameters

font
Type: System.Drawing..::..Font
Default font.

Return Value

A newly picked font.

See Also

GH_FontPicker Class
ShowFontPickerWindow Overload
Grasshopper.GUI Namespace


ShowFontPickerWindow Method (Font, Form)

[image]

Grasshopper SDK
GH_FontPicker..::..ShowFontPickerWindow Method (Font, Form)
GH_FontPicker Class See Also Send Feedback
Display the fontpicker in a window.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Font ShowFontPickerWindow(
    Font font,
    Form parent
)
Visual Basic
Public Shared Function ShowFontPickerWindow ( _
    font As Font, _
    parent As Form _
) As Font

Parameters

font
Type: System.Drawing..::..Font
Default font.
parent
Type: System.Windows.Forms..::..Form
Parent window.

Return Value

A newly picked font.

See Also

GH_FontPicker Class
ShowFontPickerWindow Overload
Grasshopper.GUI Namespace


GH_FontPicker Properties

[image] [image]

Grasshopper SDK
GH_FontPicker Properties
GH_FontPicker Class See Also Send Feedback

The GH_FontPicker type exposes the following members.

Properties

 | Name | Description
Public property | SelectedFont |

See Also

GH_FontPicker Class
Grasshopper.GUI Namespace


SelectedFont Property

[image]

Grasshopper SDK
GH_FontPicker..::..SelectedFont Property
GH_FontPicker Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Font SelectedFont { get; set; }
Visual Basic
Public Property SelectedFont As Font
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_FontPicker.SelectedFont"]

See Also

GH_FontPicker Class
Grasshopper.GUI Namespace


GH_FontScroller Class

[image]

Grasshopper SDK
GH_FontScroller Class
Members See Also Send Feedback
Represents a panel with a scrolling collection of pangrams.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_FontScroller : GH_DoubleBufferedPanel
Visual Basic
Public Class GH_FontScroller _
    Inherits GH_DoubleBufferedPanel

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..Panel
Grasshopper.GUI..::..GH_DoubleBufferedPanel
Grasshopper.GUI..::..GH_FontScroller

See Also

GH_FontScroller Members
Grasshopper.GUI Namespace


GH_FontScroller Members

[image] [image]

Grasshopper SDK
GH_FontScroller Members
GH_FontScroller Class Constructors Methods Properties See Also Send Feedback

The GH_FontScroller type exposes the following members.

Constructors

 | Name | Description
Public method | GH_FontScroller | Initializes a new instance of the GH_FontScroller class

Methods

 | Name | Description
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | (Overrides ScrollableControl..::..OnPaintBackground(PaintEventArgs).)

Properties

 | Name | Description
Public property | PostPaintDelegate |

See Also

GH_FontScroller Class
Grasshopper.GUI Namespace


GH_FontScroller Constructor

[image]

Grasshopper SDK
GH_FontScroller Constructor
GH_FontScroller Class See Also Send Feedback
Initializes a new instance of the GH_FontScroller class

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_FontScroller()
Visual Basic
Public Sub New

See Also

GH_FontScroller Class
Grasshopper.GUI Namespace


GH_FontScroller Methods

[image] [image]

Grasshopper SDK
GH_FontScroller Methods
GH_FontScroller Class See Also Send Feedback

The GH_FontScroller type exposes the following members.

Methods

 | Name | Description
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | (Overrides ScrollableControl..::..OnPaintBackground(PaintEventArgs).)

See Also

GH_FontScroller Class
Grasshopper.GUI Namespace


OnPaint Method

[image]

Grasshopper SDK
GH_FontScroller..::..OnPaint Method
GH_FontScroller Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

GH_FontScroller Class
Grasshopper.GUI Namespace


OnPaintBackground Method

[image]

Grasshopper SDK
GH_FontScroller..::..OnPaintBackground Method
GH_FontScroller Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void OnPaintBackground(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaintBackground ( _
    e As PaintEventArgs _
)

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

GH_FontScroller Class
Grasshopper.GUI Namespace


GH_FontScroller Properties

[image] [image]

Grasshopper SDK
GH_FontScroller Properties
GH_FontScroller Class See Also Send Feedback

The GH_FontScroller type exposes the following members.

Properties

 | Name | Description
Public property | PostPaintDelegate |

See Also

GH_FontScroller Class
Grasshopper.GUI Namespace


PostPaintDelegate Property

[image]

Grasshopper SDK
GH_FontScroller..::..PostPaintDelegate Property
GH_FontScroller Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_FontScroller..::..PostPaint PostPaintDelegate { get; set; }
Visual Basic
Public Property PostPaintDelegate As GH_FontScroller..::..PostPaint
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_FontScroller.PostPaintDelegate"]

See Also

GH_FontScroller Class
Grasshopper.GUI Namespace


GH_FontScroller.PostPaint Delegate

[image]

Grasshopper SDK
GH_FontScroller..::..PostPaint Delegate
GH_FontScroller Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void PostPaint(
    Graphics graphics
)
Visual Basic
Public Delegate Sub PostPaint ( _
    graphics As Graphics _
)

Parameters

graphics
Type: System.Drawing..::..Graphics

See Also

Grasshopper.GUI Namespace


GH_FormShepard Class

[image]

Grasshopper SDK
GH_FormShepard Class
Members See Also Send Feedback
A Form shepard is used to herde a bunch of floating forms. Important forms that potentially spout child forms might choose to implement one.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_FormShepard
Visual Basic
Public Class GH_FormShepard

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI..::..GH_FormShepard

See Also

GH_FormShepard Members
Grasshopper.GUI Namespace


GH_FormShepard Members

[image] [image]

Grasshopper SDK
GH_FormShepard Members
GH_FormShepard Class Constructors Methods Properties See Also Send Feedback

The GH_FormShepard type exposes the following members.

Constructors

 | Name | Description
Public method | GH_FormShepard | Create a new form shepard.

Methods

 | Name | Description
Public method | RegisterForm | Add a sheep form to the flock. This form will be affected by the location and size of the main form.
Public method | UnregisterForm | Remove a sheep from the flock.

Properties

 | Name | Description
Public property | Sheep |

See Also

GH_FormShepard Class
Grasshopper.GUI Namespace


GH_FormShepard Constructor

[image]

Grasshopper SDK
GH_FormShepard Constructor
GH_FormShepard Class See Also Send Feedback
Create a new form shepard.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_FormShepard(
    Form nOwner
)
Visual Basic
Public Sub New ( _
    nOwner As Form _
)

Parameters

nOwner
Type: System.Windows.Forms..::..Form
Owner form.

See Also

GH_FormShepard Class
Grasshopper.GUI Namespace


GH_FormShepard Methods

[image] [image]

Grasshopper SDK
GH_FormShepard Methods
GH_FormShepard Class See Also Send Feedback

The GH_FormShepard type exposes the following members.

Methods

 | Name | Description
Public method | RegisterForm | Add a sheep form to the flock. This form will be affected by the location and size of the main form.
Public method | UnregisterForm | Remove a sheep from the flock.

See Also

GH_FormShepard Class
Grasshopper.GUI Namespace


RegisterForm Method

[image]

Grasshopper SDK
GH_FormShepard..::..RegisterForm Method
GH_FormShepard Class See Also Send Feedback
Add a sheep form to the flock. This form will be affected by the location and size of the main form.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RegisterForm(
    Form dialog
)
Visual Basic
Public Sub RegisterForm ( _
    dialog As Form _
)

Parameters

dialog
Type: System.Windows.Forms..::..Form
Form to add.

See Also

GH_FormShepard Class
Grasshopper.GUI Namespace


UnregisterForm Method

[image]

Grasshopper SDK
GH_FormShepard..::..UnregisterForm Method
GH_FormShepard Class See Also Send Feedback
Remove a sheep from the flock.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void UnregisterForm(
    Form dialog
)
Visual Basic
Public Sub UnregisterForm ( _
    dialog As Form _
)

Parameters

dialog
Type: System.Windows.Forms..::..Form
Form to remove.

See Also

GH_FormShepard Class
Grasshopper.GUI Namespace


GH_FormShepard Properties

[image] [image]

Grasshopper SDK
GH_FormShepard Properties
GH_FormShepard Class See Also Send Feedback

The GH_FormShepard type exposes the following members.

Properties

 | Name | Description
Public property | Sheep |

See Also

GH_FormShepard Class
Grasshopper.GUI Namespace


Sheep Property

[image]

Grasshopper SDK
GH_FormShepard..::..Sheep Property
GH_FormShepard Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IEnumerable<Form> Sheep { get; }
Visual Basic
Public ReadOnly Property Sheep As IEnumerable(Of Form)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_FormShepard.Sheep"]

See Also

GH_FormShepard Class
Grasshopper.GUI Namespace


GH_GDI_Util Class

[image]

Grasshopper SDK
GH_GDI_Util Class
Members See Also Send Feedback
Contains some global function for filleting corners of GDI objects.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class GH_GDI_Util
Visual Basic
Public NotInheritable Class GH_GDI_Util

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI..::..GH_GDI_Util

See Also

GH_GDI_Util Members
Grasshopper.GUI Namespace


GH_GDI_Util Members

[image] [image]

Grasshopper SDK
GH_GDI_Util Members
GH_GDI_Util Class Methods See Also Send Feedback

The GH_GDI_Util type exposes the following members.

Methods

Name | Description
BoxUnion | Create the outline of a set of boxes.
FilletBoxOutline | Fillet all the corners of the combined outline of a set of rectangles.
FilletPolyline(array<Point>[]()[][], Int32) | Fillet all the corners of a freeform outline.
FilletPolyline(array<PointF>[]()[][], Single) | Fillet all the corners of a freeform outline.
FilletRectangle | Create a rectangle with filleted corners.
Freeform_Blob(IEnumerable<(Of <<'(RectangleF>)>>), Int32, Double) | Create a meta-ball outline for a set of rectangles.
Freeform_Blob(IEnumerable<(Of <<'(RectangleF>)>>), Int32, Double, FieldSolver, Double) | Create a meta-ball outline for a set of rectangles.
SimplifyBoxes | Create a simplified collection of Rectangles that describe the same union space as the supplied rectangles.

See Also

GH_GDI_Util Class
Grasshopper.GUI Namespace


GH_GDI_Util Methods

[image] [image]

Grasshopper SDK
GH_GDI_Util Methods
GH_GDI_Util Class See Also Send Feedback

The GH_GDI_Util type exposes the following members.

Methods

Name | Description
BoxUnion | Create the outline of a set of boxes.
FilletBoxOutline | Fillet all the corners of the combined outline of a set of rectangles.
FilletPolyline(array<Point>[]()[][], Int32) | Fillet all the corners of a freeform outline.
FilletPolyline(array<PointF>[]()[][], Single) | Fillet all the corners of a freeform outline.
FilletRectangle | Create a rectangle with filleted corners.
Freeform_Blob(IEnumerable<(Of <<'(RectangleF>)>>), Int32, Double) | Create a meta-ball outline for a set of rectangles.
Freeform_Blob(IEnumerable<(Of <<'(RectangleF>)>>), Int32, Double, FieldSolver, Double) | Create a meta-ball outline for a set of rectangles.
SimplifyBoxes | Create a simplified collection of Rectangles that describe the same union space as the supplied rectangles.

See Also

GH_GDI_Util Class
Grasshopper.GUI Namespace


BoxUnion Method

[image]

Grasshopper SDK
GH_GDI_Util..::..BoxUnion Method
GH_GDI_Util Class See Also Send Feedback
Create the outline of a set of boxes.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static List<Point[]> BoxUnion(
    IEnumerable<Rectangle> rectangles
)
Visual Basic
Public Shared Function BoxUnion ( _
    rectangles As IEnumerable(Of Rectangle) _
) As List(Of Point())

Parameters

rectangles
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Rectangle >)>)>
Boxes to union.

Return Value

A list of Point arrays, where each array describes the corners of each silhouette.

See Also

GH_GDI_Util Class
Grasshopper.GUI Namespace


FilletBoxOutline Method

[image]

Grasshopper SDK
GH_GDI_Util..::..FilletBoxOutline Method
GH_GDI_Util Class See Also Send Feedback
Fillet all the corners of the combined outline of a set of rectangles.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GraphicsPath FilletBoxOutline(
    IEnumerable<Rectangle> boxes,
    int radius
)
Visual Basic
Public Shared Function FilletBoxOutline ( _
    boxes As IEnumerable(Of Rectangle), _
    radius As Integer _
) As GraphicsPath

Parameters

boxes
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Rectangle >)>)>
Rectangles to outline.
radius
Type: System..::..Int32
Radius of corner fillets.

Return Value

GraphicsPath describing the filleted outline or null on failure.

See Also

GH_GDI_Util Class
Grasshopper.GUI Namespace


FilletPolyline Method

[image] [image]

Grasshopper SDK
GH_GDI_Util..::..FilletPolyline Method
GH_GDI_Util Class See Also Send Feedback

Overload List

Name | Description
FilletPolyline(array<Point>[]()[][], Int32) | Fillet all the corners of a freeform outline.
FilletPolyline(array<PointF>[]()[][], Single) | Fillet all the corners of a freeform outline.

See Also

GH_GDI_Util Class
GH_GDI_Util Members
Grasshopper.GUI Namespace


FilletPolyline Method (Point[], Int32)

[image]

Grasshopper SDK
GH_GDI_Util..::..FilletPolyline Method (array<Point>[]()[][], Int32)
GH_GDI_Util Class See Also Send Feedback
Fillet all the corners of a freeform outline.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GraphicsPath FilletPolyline(
    Point[] corners,
    int radius
)
Visual Basic
Public Shared Function FilletPolyline ( _
    corners As Point(), _
    radius As Integer _
) As GraphicsPath

Parameters

corners
Type: array< System.Drawing..::..Point >[]()[][]
A list of corner points.
radius
Type: System..::..Int32
Fillet to apply to all corners.

Return Value

A graphics path describing the filleted shape, or Nothing on failure.

See Also

GH_GDI_Util Class
FilletPolyline Overload
Grasshopper.GUI Namespace


FilletPolyline Method (PointF[], Single)

[image]

Grasshopper SDK
GH_GDI_Util..::..FilletPolyline Method (array<PointF>[]()[][], Single)
GH_GDI_Util Class See Also Send Feedback
Fillet all the corners of a freeform outline.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GraphicsPath FilletPolyline(
    PointF[] corners,
    float radius
)
Visual Basic
Public Shared Function FilletPolyline ( _
    corners As PointF(), _
    radius As Single _
) As GraphicsPath

Parameters

corners
Type: array< System.Drawing..::..PointF >[]()[][]
A list of corner points.
radius
Type: System..::..Single
Fillet to apply to all corners.

Return Value

A graphics path describing the filleted shape, or Nothing on failure.

See Also

GH_GDI_Util Class
FilletPolyline Overload
Grasshopper.GUI Namespace


FilletRectangle Method

[image]

Grasshopper SDK
GH_GDI_Util..::..FilletRectangle Method
GH_GDI_Util Class See Also Send Feedback
Create a rectangle with filleted corners.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GraphicsPath FilletRectangle(
    Rectangle box,
    int radius
)
Visual Basic
Public Shared Function FilletRectangle ( _
    box As Rectangle, _
    radius As Integer _
) As GraphicsPath

Parameters

box
Type: System.Drawing..::..Rectangle
Rectangle to fillet.
radius
Type: System..::..Int32
Fillet radius, radius will be limited if too large.

Return Value

GraphicsPath describing filletted rectangle.

See Also

GH_GDI_Util Class
Grasshopper.GUI Namespace


Freeform_Blob Method

[image] [image]

Grasshopper SDK
GH_GDI_Util..::..Freeform_Blob Method
GH_GDI_Util Class See Also Send Feedback

Overload List

Name | Description
Freeform_Blob(IEnumerable<(Of <<'(RectangleF>)>>), Int32, Double) | Create a meta-ball outline for a set of rectangles.
Freeform_Blob(IEnumerable<(Of <<'(RectangleF>)>>), Int32, Double, FieldSolver, Double) | Create a meta-ball outline for a set of rectangles.

See Also

GH_GDI_Util Class
GH_GDI_Util Members
Grasshopper.GUI Namespace


Freeform_Blob Method (IEnumerable(RectangleF), Int32, Double)

[image]

Grasshopper SDK
GH_GDI_Util..::..Freeform_Blob Method (IEnumerable<(Of <(<'RectangleF>)>)>, Int32, Double)
GH_GDI_Util Class See Also Send Feedback
Create a meta-ball outline for a set of rectangles.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GraphicsPath Freeform_Blob(
    IEnumerable<RectangleF> content,
    int padding,
    double accuracy
)
Visual Basic
Public Shared Function Freeform_Blob ( _
    content As IEnumerable(Of RectangleF), _
    padding As Integer, _
    accuracy As Double _
) As GraphicsPath

Parameters

content
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' RectangleF >)>)>
Rectangles to encompass.
padding
Type: System..::..Int32
Number of units to add to each box.
accuracy
Type: System..::..Double
Pixel accuracy for isosurface outlines. 3 is a good value for 1:1 UI.

Return Value

A graphics path describing all iso-surfaces.

See Also

GH_GDI_Util Class
Freeform_Blob Overload
Grasshopper.GUI Namespace


Freeform_Blob Method (IEnumerable(RectangleF), Int32, Double, ., Double)

[image]

Grasshopper SDK
GH_GDI_Util..::..Freeform_Blob Method (IEnumerable<(Of <(<'RectangleF>)>)>, Int32, Double, ..::.., Double)
GH_GDI_Util Class See Also Send Feedback
Create a meta-ball outline for a set of rectangles.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GraphicsPath Freeform_Blob(
    IEnumerable<RectangleF> content,
    int padding,
    double accuracy,
    FieldSolver solver,
    double section
)
Visual Basic
Public Shared Function Freeform_Blob ( _
    content As IEnumerable(Of RectangleF), _
    padding As Integer, _
    accuracy As Double, _
    solver As FieldSolver, _
    section As Double _
) As GraphicsPath

Parameters

content
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' RectangleF >)>)>
Rectangles to encompass.
padding
Type: System..::..Int32
Number of units to add to each box.
accuracy
Type: System..::..Double
Pixel accuracy for isosurface outlines. 3 is a good value for 1:1 UI.
solver
Type: FieldSolver
The falloff solver to use. GH_Util.MetaBall.GH_Context contains a bunch of predefined solvers.
section
Type: System..::..Double
Elevation of section plane.

Return Value

A graphics path describing all iso-surfaces

See Also

GH_GDI_Util Class
Freeform_Blob Overload
Grasshopper.GUI Namespace


SimplifyBoxes Method

[image]

Grasshopper SDK
GH_GDI_Util..::..SimplifyBoxes Method
GH_GDI_Util Class See Also Send Feedback
Create a simplified collection of Rectangles that describe the same union space as the supplied rectangles.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Rectangle[] SimplifyBoxes(
    IEnumerable<Rectangle> boxes
)
Visual Basic
Public Shared Function SimplifyBoxes ( _
    boxes As IEnumerable(Of Rectangle) _
) As Rectangle()

Parameters

boxes
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Rectangle >)>)>
Rectangles to simplify.

Return Value

An ordered collection of non-intersecting rectangles or null on failure.

See Also

GH_GDI_Util Class
Grasshopper.GUI Namespace


GH_GeometricFont Class

[image]

Grasshopper SDK
GH_GeometricFont Class
Members See Also Send Feedback
Exposes methods for drawing geometric characters.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class GH_GeometricFont
Visual Basic
Public NotInheritable Class GH_GeometricFont

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI..::..GH_GeometricFont

See Also

GH_GeometricFont Members
Grasshopper.GUI Namespace


GH_GeometricFont Members

[image] [image]

Grasshopper SDK
GH_GeometricFont Members
GH_GeometricFont Class Methods Properties See Also Send Feedback

The GH_GeometricFont type exposes the following members.

Methods

Name | Description
Draw0 | Draw the geometric character '0' at the specified location.
Draw1 | Draw the geometric character '1' at the specified location.
Draw2 | Draw the geometric character '2' at the specified location.
Draw3 | Draw the geometric character '3' at the specified location.
Draw4 | Draw the geometric character '4' at the specified location.
Draw5 | Draw the geometric character '5' at the specified location.
Draw6 | Draw the geometric character '6' at the specified location.
Draw7 | Draw the geometric character '7' at the specified location.
Draw8 | Draw the geometric character '8' at the specified location.
Draw9 | Draw the geometric character '9' at the specified location.
DrawBracketClose | Draw the geometric character '}' at the specified location.
DrawBracketOpen | Draw the geometric character '{' at the specified location.
DrawDash | Draw the geometric character '-' at the specified location.
DrawPath | Draw an entire path string at a specific location.
DrawSemiColon | Draw the geometric character ';' at the specified location.

Properties

Name | Description
Char0 | Gets the default geometry for '0'. Caller is responsible for disposing the path.
Char1 | Gets the default geometry for '1'. Caller is responsible for disposing the path.
Char2 | Gets the default geometry for '2'. Caller is responsible for disposing the path.
Char3 | Gets the default geometry for '3'. Caller is responsible for disposing the path.
Char4 | Gets the default geometry for '4'. Caller is responsible for disposing the path.
Char5 | Gets the default geometry for '5'. Caller is responsible for disposing the path.
Char6 | Gets the default geometry for '6'. Caller is responsible for disposing the path.
Char7 | Gets the default geometry for '7'. Caller is responsible for disposing the path.
Char8 | Gets the default geometry for '8'. Caller is responsible for disposing the path.
Char9 | Gets the default geometry for '9'. Caller is responsible for disposing the path.
CharBracketClose | Gets the default geometry for '}'. Caller is responsible for disposing the path.
CharBracketOpen | Gets the default geometry for '{'. Caller is responsible for disposing the path.
CharDash | Gets the default geometry for '-'. Caller is responsible for disposing the path.
CharSemiColon | Gets the default geometry for ';'. Caller is responsible for disposing the path.

See Also

GH_GeometricFont Class
Grasshopper.GUI Namespace


GH_GeometricFont Methods

[image] [image]

Grasshopper SDK
GH_GeometricFont Methods
GH_GeometricFont Class See Also Send Feedback

The GH_GeometricFont type exposes the following members.

Methods

Name | Description
Draw0 | Draw the geometric character '0' at the specified location.
Draw1 | Draw the geometric character '1' at the specified location.
Draw2 | Draw the geometric character '2' at the specified location.
Draw3 | Draw the geometric character '3' at the specified location.
Draw4 | Draw the geometric character '4' at the specified location.
Draw5 | Draw the geometric character '5' at the specified location.
Draw6 | Draw the geometric character '6' at the specified location.
Draw7 | Draw the geometric character '7' at the specified location.
Draw8 | Draw the geometric character '8' at the specified location.
Draw9 | Draw the geometric character '9' at the specified location.
DrawBracketClose | Draw the geometric character '}' at the specified location.
DrawBracketOpen | Draw the geometric character '{' at the specified location.
DrawDash | Draw the geometric character '-' at the specified location.
DrawPath | Draw an entire path string at a specific location.
DrawSemiColon | Draw the geometric character ';' at the specified location.

See Also

GH_GeometricFont Class
Grasshopper.GUI Namespace


Draw0 Method

[image]

Grasshopper SDK
GH_GeometricFont..::..Draw0 Method
GH_GeometricFont Class See Also Send Feedback
Draw the geometric character '0' at the specified location.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void Draw0(
    Graphics graphics,
    Color colour,
    PointF position
)
Visual Basic
Public Shared Sub Draw0 ( _
    graphics As Graphics, _
    colour As Color, _
    position As PointF _
)

Parameters

graphics
Type: System.Drawing..::..Graphics
Graphics object to draw with.
colour
Type: System.Drawing..::..Color
Colour of character.
position
Type: System.Drawing..::..PointF
Location of character.

See Also

GH_GeometricFont Class
Grasshopper.GUI Namespace


Draw1 Method

[image]

Grasshopper SDK
GH_GeometricFont..::..Draw1 Method
GH_GeometricFont Class See Also Send Feedback
Draw the geometric character '1' at the specified location.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void Draw1(
    Graphics graphics,
    Color colour,
    PointF position
)
Visual Basic
Public Shared Sub Draw1 ( _
    graphics As Graphics, _
    colour As Color, _
    position As PointF _
)

Parameters

graphics
Type: System.Drawing..::..Graphics
Graphics object to draw with.
colour
Type: System.Drawing..::..Color
Colour of character.
position
Type: System.Drawing..::..PointF
Location of character.

See Also

GH_GeometricFont Class
Grasshopper.GUI Namespace


Draw2 Method

[image]

Grasshopper SDK
GH_GeometricFont..::..Draw2 Method
GH_GeometricFont Class See Also Send Feedback
Draw the geometric character '2' at the specified location.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void Draw2(
    Graphics graphics,
    Color colour,
    PointF position
)
Visual Basic
Public Shared Sub Draw2 ( _
    graphics As Graphics, _
    colour As Color, _
    position As PointF _
)

Parameters

graphics
Type: System.Drawing..::..Graphics
Graphics object to draw with.
colour
Type: System.Drawing..::..Color
Colour of character.
position
Type: System.Drawing..::..PointF
Location of character.

See Also

GH_GeometricFont Class
Grasshopper.GUI Namespace


Draw3 Method

[image]

Grasshopper SDK
GH_GeometricFont..::..Draw3 Method
GH_GeometricFont Class See Also Send Feedback
Draw the geometric character '3' at the specified location.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void Draw3(
    Graphics graphics,
    Color colour,
    PointF position
)
Visual Basic
Public Shared Sub Draw3 ( _
    graphics As Graphics, _
    colour As Color, _
    position As PointF _
)

Parameters

graphics
Type: System.Drawing..::..Graphics
Graphics object to draw with.
colour
Type: System.Drawing..::..Color
Colour of character.
position
Type: System.Drawing..::..PointF
Location of character.

See Also

GH_GeometricFont Class
Grasshopper.GUI Namespace


Draw4 Method

[image]

Grasshopper SDK
GH_GeometricFont..::..Draw4 Method
GH_GeometricFont Class See Also Send Feedback
Draw the geometric character '4' at the specified location.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void Draw4(
    Graphics graphics,
    Color colour,
    PointF position
)
Visual Basic
Public Shared Sub Draw4 ( _
    graphics As Graphics, _
    colour As Color, _
    position As PointF _
)

Parameters

graphics
Type: System.Drawing..::..Graphics
Graphics object to draw with.
colour
Type: System.Drawing..::..Color
Colour of character.
position
Type: System.Drawing..::..PointF
Location of character.

See Also

GH_GeometricFont Class
Grasshopper.GUI Namespace


Draw5 Method

[image]

Grasshopper SDK
GH_GeometricFont..::..Draw5 Method
GH_GeometricFont Class See Also Send Feedback
Draw the geometric character '5' at the specified location.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void Draw5(
    Graphics graphics,
    Color colour,
    PointF position
)
Visual Basic
Public Shared Sub Draw5 ( _
    graphics As Graphics, _
    colour As Color, _
    position As PointF _
)

Parameters

graphics
Type: System.Drawing..::..Graphics
Graphics object to draw with.
colour
Type: System.Drawing..::..Color
Colour of character.
position
Type: System.Drawing..::..PointF
Location of character.

See Also

GH_GeometricFont Class
Grasshopper.GUI Namespace


Draw6 Method

[image]

Grasshopper SDK
GH_GeometricFont..::..Draw6 Method
GH_GeometricFont Class See Also Send Feedback
Draw the geometric character '6' at the specified location.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void Draw6(
    Graphics graphics,
    Color colour,
    PointF position
)
Visual Basic
Public Shared Sub Draw6 ( _
    graphics As Graphics, _
    colour As Color, _
    position As PointF _
)

Parameters

graphics
Type: System.Drawing..::..Graphics
Graphics object to draw with.
colour
Type: System.Drawing..::..Color
Colour of character.
position
Type: System.Drawing..::..PointF
Location of character.

See Also

GH_GeometricFont Class
Grasshopper.GUI Namespace


Draw7 Method

[image]

Grasshopper SDK
GH_GeometricFont..::..Draw7 Method
GH_GeometricFont Class See Also Send Feedback
Draw the geometric character '7' at the specified location.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void Draw7(
    Graphics graphics,
    Color colour,
    PointF position
)
Visual Basic
Public Shared Sub Draw7 ( _
    graphics As Graphics, _
    colour As Color, _
    position As PointF _
)

Parameters

graphics
Type: System.Drawing..::..Graphics
Graphics object to draw with.
colour
Type: System.Drawing..::..Color
Colour of character.
position
Type: System.Drawing..::..PointF
Location of character.

See Also

GH_GeometricFont Class
Grasshopper.GUI Namespace


Draw8 Method

[image]

Grasshopper SDK
GH_GeometricFont..::..Draw8 Method
GH_GeometricFont Class See Also Send Feedback
Draw the geometric character '8' at the specified location.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void Draw8(
    Graphics graphics,
    Color colour,
    PointF position
)
Visual Basic
Public Shared Sub Draw8 ( _
    graphics As Graphics, _
    colour As Color, _
    position As PointF _
)

Parameters

graphics
Type: System.Drawing..::..Graphics
Graphics object to draw with.
colour
Type: System.Drawing..::..Color
Colour of character.
position
Type: System.Drawing..::..PointF
Location of character.

See Also

GH_GeometricFont Class
Grasshopper.GUI Namespace


Draw9 Method

[image]

Grasshopper SDK
GH_GeometricFont..::..Draw9 Method
GH_GeometricFont Class See Also Send Feedback
Draw the geometric character '9' at the specified location.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void Draw9(
    Graphics graphics,
    Color colour,
    PointF position
)
Visual Basic
Public Shared Sub Draw9 ( _
    graphics As Graphics, _
    colour As Color, _
    position As PointF _
)

Parameters

graphics
Type: System.Drawing..::..Graphics
Graphics object to draw with.
colour
Type: System.Drawing..::..Color
Colour of character.
position
Type: System.Drawing..::..PointF
Location of character.

See Also

GH_GeometricFont Class
Grasshopper.GUI Namespace


DrawBracketClose Method

[image]

Grasshopper SDK
GH_GeometricFont..::..DrawBracketClose Method
GH_GeometricFont Class See Also Send Feedback
Draw the geometric character '}' at the specified location.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void DrawBracketClose(
    Graphics graphics,
    Color colour,
    PointF position
)
Visual Basic
Public Shared Sub DrawBracketClose ( _
    graphics As Graphics, _
    colour As Color, _
    position As PointF _
)

Parameters

graphics
Type: System.Drawing..::..Graphics
Graphics object to draw with.
colour
Type: System.Drawing..::..Color
Colour of character.
position
Type: System.Drawing..::..PointF
Location of character.

See Also

GH_GeometricFont Class
Grasshopper.GUI Namespace


DrawBracketOpen Method

[image]

Grasshopper SDK
GH_GeometricFont..::..DrawBracketOpen Method
GH_GeometricFont Class See Also Send Feedback
Draw the geometric character '{' at the specified location.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void DrawBracketOpen(
    Graphics graphics,
    Color colour,
    PointF position
)
Visual Basic
Public Shared Sub DrawBracketOpen ( _
    graphics As Graphics, _
    colour As Color, _
    position As PointF _
)

Parameters

graphics
Type: System.Drawing..::..Graphics
Graphics object to draw with.
colour
Type: System.Drawing..::..Color
Colour of character.
position
Type: System.Drawing..::..PointF
Location of character.

See Also

GH_GeometricFont Class
Grasshopper.GUI Namespace


DrawDash Method

[image]

Grasshopper SDK
GH_GeometricFont..::..DrawDash Method
GH_GeometricFont Class See Also Send Feedback
Draw the geometric character '-' at the specified location.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void DrawDash(
    Graphics graphics,
    Color colour,
    PointF position
)
Visual Basic
Public Shared Sub DrawDash ( _
    graphics As Graphics, _
    colour As Color, _
    position As PointF _
)

Parameters

graphics
Type: System.Drawing..::..Graphics
Graphics object to draw with.
colour
Type: System.Drawing..::..Color
Colour of character.
position
Type: System.Drawing..::..PointF
Location of character.

See Also

GH_GeometricFont Class
Grasshopper.GUI Namespace


DrawPath Method

[image]

Grasshopper SDK
GH_GeometricFont..::..DrawPath Method
GH_GeometricFont Class See Also Send Feedback
Draw an entire path string at a specific location.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void DrawPath(
    Graphics graphics,
    GH_Path path,
    Color colour,
    PointF position
)
Visual Basic
Public Shared Sub DrawPath ( _
    graphics As Graphics, _
    path As GH_Path, _
    colour As Color, _
    position As PointF _
)

Parameters

graphics
Type: System.Drawing..::..Graphics
Graphics object to draw with.
path
Type: Grasshopper.Kernel.Data..::..GH_Path
Path to draw.
colour
Type: System.Drawing..::..Color
Colour of path.
position
Type: System.Drawing..::..PointF
Location of opening bracket.

See Also

GH_GeometricFont Class
Grasshopper.GUI Namespace


DrawSemiColon Method

[image]

Grasshopper SDK
GH_GeometricFont..::..DrawSemiColon Method
GH_GeometricFont Class See Also Send Feedback
Draw the geometric character ';' at the specified location.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void DrawSemiColon(
    Graphics graphics,
    Color colour,
    PointF position
)
Visual Basic
Public Shared Sub DrawSemiColon ( _
    graphics As Graphics, _
    colour As Color, _
    position As PointF _
)

Parameters

graphics
Type: System.Drawing..::..Graphics
Graphics object to draw with.
colour
Type: System.Drawing..::..Color
Colour of character.
position
Type: System.Drawing..::..PointF
Location of character.

See Also

GH_GeometricFont Class
Grasshopper.GUI Namespace


GH_GeometricFont Properties

[image] [image]

Grasshopper SDK
GH_GeometricFont Properties
GH_GeometricFont Class See Also Send Feedback

The GH_GeometricFont type exposes the following members.

Properties

Name | Description
Char0 | Gets the default geometry for '0'. Caller is responsible for disposing the path.
Char1 | Gets the default geometry for '1'. Caller is responsible for disposing the path.
Char2 | Gets the default geometry for '2'. Caller is responsible for disposing the path.
Char3 | Gets the default geometry for '3'. Caller is responsible for disposing the path.
Char4 | Gets the default geometry for '4'. Caller is responsible for disposing the path.
Char5 | Gets the default geometry for '5'. Caller is responsible for disposing the path.
Char6 | Gets the default geometry for '6'. Caller is responsible for disposing the path.
Char7 | Gets the default geometry for '7'. Caller is responsible for disposing the path.
Char8 | Gets the default geometry for '8'. Caller is responsible for disposing the path.
Char9 | Gets the default geometry for '9'. Caller is responsible for disposing the path.
CharBracketClose | Gets the default geometry for '}'. Caller is responsible for disposing the path.
CharBracketOpen | Gets the default geometry for '{'. Caller is responsible for disposing the path.
CharDash | Gets the default geometry for '-'. Caller is responsible for disposing the path.
CharSemiColon | Gets the default geometry for ';'. Caller is responsible for disposing the path.

See Also

GH_GeometricFont Class
Grasshopper.GUI Namespace


Char0 Property

[image]

Grasshopper SDK
GH_GeometricFont..::..Char0 Property
GH_GeometricFont Class See Also Send Feedback
Gets the default geometry for '0'. Caller is responsible for disposing the path.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GraphicsPath Char0 { get; }
Visual Basic
Public Shared ReadOnly Property Char0 As GraphicsPath
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_GeometricFont.Char0"]

See Also

GH_GeometricFont Class
Grasshopper.GUI Namespace


Char1 Property

[image]

Grasshopper SDK
GH_GeometricFont..::..Char1 Property
GH_GeometricFont Class See Also Send Feedback
Gets the default geometry for '1'. Caller is responsible for disposing the path.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GraphicsPath Char1 { get; }
Visual Basic
Public Shared ReadOnly Property Char1 As GraphicsPath
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_GeometricFont.Char1"]

See Also

GH_GeometricFont Class
Grasshopper.GUI Namespace


Char2 Property

[image]

Grasshopper SDK
GH_GeometricFont..::..Char2 Property
GH_GeometricFont Class See Also Send Feedback
Gets the default geometry for '2'. Caller is responsible for disposing the path.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GraphicsPath Char2 { get; }
Visual Basic
Public Shared ReadOnly Property Char2 As GraphicsPath
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_GeometricFont.Char2"]

See Also

GH_GeometricFont Class
Grasshopper.GUI Namespace


Char3 Property

[image]

Grasshopper SDK
GH_GeometricFont..::..Char3 Property
GH_GeometricFont Class See Also Send Feedback
Gets the default geometry for '3'. Caller is responsible for disposing the path.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GraphicsPath Char3 { get; }
Visual Basic
Public Shared ReadOnly Property Char3 As GraphicsPath
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_GeometricFont.Char3"]

See Also

GH_GeometricFont Class
Grasshopper.GUI Namespace


Char4 Property

[image]

Grasshopper SDK
GH_GeometricFont..::..Char4 Property
GH_GeometricFont Class See Also Send Feedback
Gets the default geometry for '4'. Caller is responsible for disposing the path.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GraphicsPath Char4 { get; }
Visual Basic
Public Shared ReadOnly Property Char4 As GraphicsPath
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_GeometricFont.Char4"]

See Also

GH_GeometricFont Class
Grasshopper.GUI Namespace


Char5 Property

[image]

Grasshopper SDK
GH_GeometricFont..::..Char5 Property
GH_GeometricFont Class See Also Send Feedback
Gets the default geometry for '5'. Caller is responsible for disposing the path.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GraphicsPath Char5 { get; }
Visual Basic
Public Shared ReadOnly Property Char5 As GraphicsPath
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_GeometricFont.Char5"]

See Also

GH_GeometricFont Class
Grasshopper.GUI Namespace


Char6 Property

[image]

Grasshopper SDK
GH_GeometricFont..::..Char6 Property
GH_GeometricFont Class See Also Send Feedback
Gets the default geometry for '6'. Caller is responsible for disposing the path.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GraphicsPath Char6 { get; }
Visual Basic
Public Shared ReadOnly Property Char6 As GraphicsPath
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_GeometricFont.Char6"]

See Also

GH_GeometricFont Class
Grasshopper.GUI Namespace


Char7 Property

[image]

Grasshopper SDK
GH_GeometricFont..::..Char7 Property
GH_GeometricFont Class See Also Send Feedback
Gets the default geometry for '7'. Caller is responsible for disposing the path.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GraphicsPath Char7 { get; }
Visual Basic
Public Shared ReadOnly Property Char7 As GraphicsPath
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_GeometricFont.Char7"]

See Also

GH_GeometricFont Class
Grasshopper.GUI Namespace


Char8 Property

[image]

Grasshopper SDK
GH_GeometricFont..::..Char8 Property
GH_GeometricFont Class See Also Send Feedback
Gets the default geometry for '8'. Caller is responsible for disposing the path.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GraphicsPath Char8 { get; }
Visual Basic
Public Shared ReadOnly Property Char8 As GraphicsPath
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_GeometricFont.Char8"]

See Also

GH_GeometricFont Class
Grasshopper.GUI Namespace


Char9 Property

[image]

Grasshopper SDK
GH_GeometricFont..::..Char9 Property
GH_GeometricFont Class See Also Send Feedback
Gets the default geometry for '9'. Caller is responsible for disposing the path.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GraphicsPath Char9 { get; }
Visual Basic
Public Shared ReadOnly Property Char9 As GraphicsPath
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_GeometricFont.Char9"]

See Also

GH_GeometricFont Class
Grasshopper.GUI Namespace


CharBracketClose Property

[image]

Grasshopper SDK
GH_GeometricFont..::..CharBracketClose Property
GH_GeometricFont Class See Also Send Feedback
Gets the default geometry for '}'. Caller is responsible for disposing the path.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GraphicsPath CharBracketClose { get; }
Visual Basic
Public Shared ReadOnly Property CharBracketClose As GraphicsPath
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_GeometricFont.CharBracketClose"]

See Also

GH_GeometricFont Class
Grasshopper.GUI Namespace


CharBracketOpen Property

[image]

Grasshopper SDK
GH_GeometricFont..::..CharBracketOpen Property
GH_GeometricFont Class See Also Send Feedback
Gets the default geometry for '{'. Caller is responsible for disposing the path.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GraphicsPath CharBracketOpen { get; }
Visual Basic
Public Shared ReadOnly Property CharBracketOpen As GraphicsPath
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_GeometricFont.CharBracketOpen"]

See Also

GH_GeometricFont Class
Grasshopper.GUI Namespace


CharDash Property

[image]

Grasshopper SDK
GH_GeometricFont..::..CharDash Property
GH_GeometricFont Class See Also Send Feedback
Gets the default geometry for '-'. Caller is responsible for disposing the path.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GraphicsPath CharDash { get; }
Visual Basic
Public Shared ReadOnly Property CharDash As GraphicsPath
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_GeometricFont.CharDash"]

See Also

GH_GeometricFont Class
Grasshopper.GUI Namespace


CharSemiColon Property

[image]

Grasshopper SDK
GH_GeometricFont..::..CharSemiColon Property
GH_GeometricFont Class See Also Send Feedback
Gets the default geometry for ';'. Caller is responsible for disposing the path.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GraphicsPath CharSemiColon { get; }
Visual Basic
Public Shared ReadOnly Property CharSemiColon As GraphicsPath
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_GeometricFont.CharSemiColon"]

See Also

GH_GeometricFont Class
Grasshopper.GUI Namespace


GH_GraphicsUtil Class

[image]

Grasshopper SDK
GH_GraphicsUtil Class
Members See Also Send Feedback
Utility class with static (Shared) functions that help with colour, shape and text rendering.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class GH_GraphicsUtil
Visual Basic
Public NotInheritable Class GH_GraphicsUtil

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI..::..GH_GraphicsUtil

See Also

GH_GraphicsUtil Members
Grasshopper.GUI Namespace


GH_GraphicsUtil Members

[image] [image]

Grasshopper SDK
GH_GraphicsUtil Members
GH_GraphicsUtil Class Methods See Also Send Feedback

The GH_GraphicsUtil type exposes the following members.

Methods

Name | Description
AppendArc(Point3d, Point3d, Vector3d, GraphicsPath) | Append an arc segment to a GraphicsPath. If the arc cannot be solved, a linear segment is appended instead.
AppendArc(PointF, PointF, SizeF, GraphicsPath) | Append an arc segment to a GraphicsPath. If the arc cannot be solved, a linear segment is appended instead.
BlendColour(Color, Color) | Overlays two colours. The Alpha component of the top colour controls the blend.
BlendColour(Color, Color, Double) | Overlays two colours.
BlendInteger | Calculates a linear blend between two extremes. Although the inputs are unlimited integers, the output is an integer in the byte range (0-255).
BoxClosestArcPoint | Find the closest point on or in a box given a test point. Arc extension is implied.
BoxClosestPoint(Point, Rectangle) | Find the closest point on or in a box given a test point.
BoxClosestPoint(PointF, RectangleF) | Find the closest point on or in a box given a test point.
BoxFurthestPoint(Point, Rectangle) | Find the furthest point on or in a box given a test point.
BoxFurthestPoint(PointF, RectangleF) | Find the furthest point on or in a box given a test point.
BoxViewCone | Computes the graphicspath that represents the viewcone for a point and a rectangle. If the rectangle contains the point, null is returned.
ColourARGB(Double, Double, Double) | Create a colour from floating ARGB channels (0.0~1.0). Channels are clipped to valid ranges.
ColourARGB(Int32, Int32, Int32) | Create a colour from integer RGB channels. Channels are clipped to valid ranges.
ColourARGB(Int32, Int32, Int32, Int32) | Create a colour from integer ARGB channels. Channels are clipped to valid ranges.
CreateColourIcon | Create a colour swatch icon.
DentHorizontal(Graphics, Rectangle) | Draws a horizontal dent. A horizontal dent had dark lines along the top and bottom edges.
DentHorizontal(Graphics, Rectangle, Int32, Int32) | Draws a horizontal dent. A horizontal dent had dark lines along the top and bottom edges.
DentVertical(Graphics, Rectangle) | Draws a vertical dent. A vertical dent had dark lines along the left and right edges.
DentVertical(Graphics, Rectangle, Int32, Int32) | Draws a vertical dent. A vertical dent had dark lines along the left and right edges.
Distance | Compute the distance between two points.
DistanceS | Compute the squared distance between two points.
EtchFadingHorizontal | Draw an etched line with fading on the extremes.
EtchFadingVertical | Draw an etched line with fading on the extremes.
EtchHorizontal(Graphics, Single, Single, Single, Int32) | Draws an etched line segment.
EtchHorizontal(Graphics, Int32, Int32, Int32, Int32, Int32) | Draws an etched line segment.
EtchVertical(Graphics, Int32, Int32, Int32, Int32) | Draws an etched line segment.
EtchVertical(Graphics, Single, Single, Single, Int32) | Draws an etched line segment.
FadeColour | Fade a colour to transparency by linearly blending a parameter between extremes.
ForegroundColour | Calculates a suitable foreground color. If the background is lighter than 50%, the foreground will be darker, otherwise the foreground will be lighter.
Grid(Graphics, RectangleF, Int32) | Draw a default grid.
Grid(Graphics, RectangleF, Int32, Int32) | Draw a default grid.
Grid(Graphics, RectangleF, Int32, Int32, Color, Color) | Draw a grid.
HighlightBrush | Gets a new brush object that can be used to draw the content of hover and focus rectangles. Caller is responsible for disposing the brush.
HighlightPen | Gets a new pen object that can be used to draw the edges of hover and focus rectangles. Caller is responsible for disposing the pen.
InvertColour | Computes the inverted colour. Alpha remains the same.
IsPointInEllipse | Test whether a point is inside or outside an ellipse.
LimitInteger | Limits the given integer to the 0~255 range.
LimitIntegers | Limits RGB channels to the 0~255 range,
OffsetColour(Color, Int32) | Add a fixed value to all the channels in a colour.
OffsetColour(Color, Int32, Int32, Int32) | Add a fixed value to all the channels in a colour.
RenderBalloonTag(Graphics, String, PointF, RectangleF) | Draw a default balloon tag in a container.
RenderBalloonTag(Graphics, String, Font, PointF, RectangleF) | Draw a default balloon tag in a container with a Font override.
RenderBalloonTag(Graphics, String, Font, Color, Color, PointF, Boolean) | Draw a balloon tag in a container.
RenderBalloonTag(Graphics, String, Font, Color, Color, PointF, RectangleF) | Draw a balloon tag in a container.
RenderCenteredIcon(Graphics, RectangleF, Image) | Draw an icon centered in a frame. This code is not zoom-aware, but it will perform consistent rounding (to avoid pixel-jitter when moving the frame across the screen). Icon will not be clipped to the frame.
RenderCenteredIcon(Graphics, RectangleF, Image, Double) | Draw an icon centered in a frame. This code is not zoom-aware, but it will perform consistent rounding (to avoid pixel-jitter when moving the frame across the screen). Icon will not be clipped to the frame.
RenderCenteredText | Render a bit of text centered on a point.
RenderColourIcon | Render a colour icon into a graphics context. A colour icon contains a black outer and white inner edge.
RenderFadedImage(Graphics, Image, Rectangle, Double) | Render an icon into a rectangle with a specific fading factor.
RenderFadedImage(Graphics, Image, Rectangle, Int32) | Render an icon into a rectangle with a specific fading factor.
RenderHighlightBox(Graphics, Rectangle, Int32) | Render a typical blueish highlight rectangle
RenderHighlightBox(Graphics, Rectangle, Int32, Boolean, Boolean) | Render a typical blueish highlight rectangle
RenderHighlightBox(Graphics, Rectangle, Int32, Color, Color) | Render a typical blueish highlight rectangle
RenderObjectOverlay(Graphics, IGH_DocumentObject, RectangleF) | Render all overlay icons for a specific object. Overlays aren't drawn when the zoom is less than 80%
RenderObjectOverlay(Graphics, IGH_ObjectProxy, RectangleF) | Render all overlay icons for a specific object. Overlays aren't drawn when the zoom is less than 80%
RenderRoundBar | Render a cylinder shaped object with round caps.
RenderTag | Render a text tag into a Graphics surface.
RenderUnscaledIcon(Graphics, Image, Int32, Int32) | Draws an image file at 1:1 scale centered on the given coordinates.
RenderUnscaledIcon(Graphics, Image, Int32, Int32, Double) | Draws an image file at 1:1 scale centered on the given coordinates.
RenderVerticalString | Render vertical text (rotated 90 degrees counter-clockwise) within a rectangle.
RenderWarningIcon | Render a typical warning icon into a graphics context. A warning icon is an upright yellow triangle.
ScaleColour | Multiply the channels of a colour construct with a fixed factor.
ShadowHorizontal(Graphics, Int32, Int32, Int32, Int32, Boolean, Color) | Draws a horizontal shadow edge.
ShadowHorizontal(Graphics, Int32, Int32, Int32, Int32, Boolean, Int32) | Draws a horizontal shadow edge.
ShadowHorizontal(Graphics, Single, Single, Single, Single, Boolean, Int32) | Draws a horizontal shadow edge.
ShadowRectangle(Graphics, Rectangle, Int32, Color) | Draws shadow edges on the interior of a rectangle.
ShadowRectangle(Graphics, Rectangle, Int32, Int32) | Draws shadow edges on the interior of a rectangle.
ShadowVertical(Graphics, Int32, Int32, Int32, Int32, Boolean, Color) | Draws a vertical shadow edge.
ShadowVertical(Graphics, Int32, Int32, Int32, Int32, Boolean, Int32) | Draws a vertical shadow edge.
ShadowVertical(Graphics, Single, Single, Single, Single, Boolean, Int32) | Draws a vertical shadow edge.
SolveArc(Point3d, Point3d, Vector3d, RectangleF%, Single%, Single%) | Create a GDI circular arc definition from start-point, end-point and tangent direction.
SolveArc(PointF, PointF, SizeF, RectangleF%, Single%, Single%) | Create a GDI circular arc definition from start-point, end-point and tangent direction.
SolveArc(Double, Double, Double, Double, Double, Double, RectangleF%, Single%, Single%) | Create a GDI circular arc definition from start-point, end-point and tangent direction.
TransparencyMatrix(Double) | Create an image transparency matrix for a specific blending factor.
TransparencyMatrix(Int32) | Create an image transparency matrix for a specific blending factor.

See Also

GH_GraphicsUtil Class
Grasshopper.GUI Namespace


GH_GraphicsUtil Methods

[image] [image]

Grasshopper SDK
GH_GraphicsUtil Methods
GH_GraphicsUtil Class See Also Send Feedback

The GH_GraphicsUtil type exposes the following members.

Methods

Name | Description
AppendArc(Point3d, Point3d, Vector3d, GraphicsPath) | Append an arc segment to a GraphicsPath. If the arc cannot be solved, a linear segment is appended instead.
AppendArc(PointF, PointF, SizeF, GraphicsPath) | Append an arc segment to a GraphicsPath. If the arc cannot be solved, a linear segment is appended instead.
BlendColour(Color, Color) | Overlays two colours. The Alpha component of the top colour controls the blend.
BlendColour(Color, Color, Double) | Overlays two colours.
BlendInteger | Calculates a linear blend between two extremes. Although the inputs are unlimited integers, the output is an integer in the byte range (0-255).
BoxClosestArcPoint | Find the closest point on or in a box given a test point. Arc extension is implied.
BoxClosestPoint(Point, Rectangle) | Find the closest point on or in a box given a test point.
BoxClosestPoint(PointF, RectangleF) | Find the closest point on or in a box given a test point.
BoxFurthestPoint(Point, Rectangle) | Find the furthest point on or in a box given a test point.
BoxFurthestPoint(PointF, RectangleF) | Find the furthest point on or in a box given a test point.
BoxViewCone | Computes the graphicspath that represents the viewcone for a point and a rectangle. If the rectangle contains the point, null is returned.
ColourARGB(Double, Double, Double) | Create a colour from floating ARGB channels (0.0~1.0). Channels are clipped to valid ranges.
ColourARGB(Int32, Int32, Int32) | Create a colour from integer RGB channels. Channels are clipped to valid ranges.
ColourARGB(Int32, Int32, Int32, Int32) | Create a colour from integer ARGB channels. Channels are clipped to valid ranges.
CreateColourIcon | Create a colour swatch icon.
DentHorizontal(Graphics, Rectangle) | Draws a horizontal dent. A horizontal dent had dark lines along the top and bottom edges.
DentHorizontal(Graphics, Rectangle, Int32, Int32) | Draws a horizontal dent. A horizontal dent had dark lines along the top and bottom edges.
DentVertical(Graphics, Rectangle) | Draws a vertical dent. A vertical dent had dark lines along the left and right edges.
DentVertical(Graphics, Rectangle, Int32, Int32) | Draws a vertical dent. A vertical dent had dark lines along the left and right edges.
Distance | Compute the distance between two points.
DistanceS | Compute the squared distance between two points.
EtchFadingHorizontal | Draw an etched line with fading on the extremes.
EtchFadingVertical | Draw an etched line with fading on the extremes.
EtchHorizontal(Graphics, Single, Single, Single, Int32) | Draws an etched line segment.
EtchHorizontal(Graphics, Int32, Int32, Int32, Int32, Int32) | Draws an etched line segment.
EtchVertical(Graphics, Int32, Int32, Int32, Int32) | Draws an etched line segment.
EtchVertical(Graphics, Single, Single, Single, Int32) | Draws an etched line segment.
FadeColour | Fade a colour to transparency by linearly blending a parameter between extremes.
ForegroundColour | Calculates a suitable foreground color. If the background is lighter than 50%, the foreground will be darker, otherwise the foreground will be lighter.
Grid(Graphics, RectangleF, Int32) | Draw a default grid.
Grid(Graphics, RectangleF, Int32, Int32) | Draw a default grid.
Grid(Graphics, RectangleF, Int32, Int32, Color, Color) | Draw a grid.
HighlightBrush | Gets a new brush object that can be used to draw the content of hover and focus rectangles. Caller is responsible for disposing the brush.
HighlightPen | Gets a new pen object that can be used to draw the edges of hover and focus rectangles. Caller is responsible for disposing the pen.
InvertColour | Computes the inverted colour. Alpha remains the same.
IsPointInEllipse | Test whether a point is inside or outside an ellipse.
LimitInteger | Limits the given integer to the 0~255 range.
LimitIntegers | Limits RGB channels to the 0~255 range,
OffsetColour(Color, Int32) | Add a fixed value to all the channels in a colour.
OffsetColour(Color, Int32, Int32, Int32) | Add a fixed value to all the channels in a colour.
RenderBalloonTag(Graphics, String, PointF, RectangleF) | Draw a default balloon tag in a container.
RenderBalloonTag(Graphics, String, Font, PointF, RectangleF) | Draw a default balloon tag in a container with a Font override.
RenderBalloonTag(Graphics, String, Font, Color, Color, PointF, Boolean) | Draw a balloon tag in a container.
RenderBalloonTag(Graphics, String, Font, Color, Color, PointF, RectangleF) | Draw a balloon tag in a container.
RenderCenteredIcon(Graphics, RectangleF, Image) | Draw an icon centered in a frame. This code is not zoom-aware, but it will perform consistent rounding (to avoid pixel-jitter when moving the frame across the screen). Icon will not be clipped to the frame.
RenderCenteredIcon(Graphics, RectangleF, Image, Double) | Draw an icon centered in a frame. This code is not zoom-aware, but it will perform consistent rounding (to avoid pixel-jitter when moving the frame across the screen). Icon will not be clipped to the frame.
RenderCenteredText | Render a bit of text centered on a point.
RenderColourIcon | Render a colour icon into a graphics context. A colour icon contains a black outer and white inner edge.
RenderFadedImage(Graphics, Image, Rectangle, Double) | Render an icon into a rectangle with a specific fading factor.
RenderFadedImage(Graphics, Image, Rectangle, Int32) | Render an icon into a rectangle with a specific fading factor.
RenderHighlightBox(Graphics, Rectangle, Int32) | Render a typical blueish highlight rectangle
RenderHighlightBox(Graphics, Rectangle, Int32, Boolean, Boolean) | Render a typical blueish highlight rectangle
RenderHighlightBox(Graphics, Rectangle, Int32, Color, Color) | Render a typical blueish highlight rectangle
RenderObjectOverlay(Graphics, IGH_DocumentObject, RectangleF) | Render all overlay icons for a specific object. Overlays aren't drawn when the zoom is less than 80%
RenderObjectOverlay(Graphics, IGH_ObjectProxy, RectangleF) | Render all overlay icons for a specific object. Overlays aren't drawn when the zoom is less than 80%
RenderRoundBar | Render a cylinder shaped object with round caps.
RenderTag | Render a text tag into a Graphics surface.
RenderUnscaledIcon(Graphics, Image, Int32, Int32) | Draws an image file at 1:1 scale centered on the given coordinates.
RenderUnscaledIcon(Graphics, Image, Int32, Int32, Double) | Draws an image file at 1:1 scale centered on the given coordinates.
RenderVerticalString | Render vertical text (rotated 90 degrees counter-clockwise) within a rectangle.
RenderWarningIcon | Render a typical warning icon into a graphics context. A warning icon is an upright yellow triangle.
ScaleColour | Multiply the channels of a colour construct with a fixed factor.
ShadowHorizontal(Graphics, Int32, Int32, Int32, Int32, Boolean, Color) | Draws a horizontal shadow edge.
ShadowHorizontal(Graphics, Int32, Int32, Int32, Int32, Boolean, Int32) | Draws a horizontal shadow edge.
ShadowHorizontal(Graphics, Single, Single, Single, Single, Boolean, Int32) | Draws a horizontal shadow edge.
ShadowRectangle(Graphics, Rectangle, Int32, Color) | Draws shadow edges on the interior of a rectangle.
ShadowRectangle(Graphics, Rectangle, Int32, Int32) | Draws shadow edges on the interior of a rectangle.
ShadowVertical(Graphics, Int32, Int32, Int32, Int32, Boolean, Color) | Draws a vertical shadow edge.
ShadowVertical(Graphics, Int32, Int32, Int32, Int32, Boolean, Int32) | Draws a vertical shadow edge.
ShadowVertical(Graphics, Single, Single, Single, Single, Boolean, Int32) | Draws a vertical shadow edge.
SolveArc(Point3d, Point3d, Vector3d, RectangleF%, Single%, Single%) | Create a GDI circular arc definition from start-point, end-point and tangent direction.
SolveArc(PointF, PointF, SizeF, RectangleF%, Single%, Single%) | Create a GDI circular arc definition from start-point, end-point and tangent direction.
SolveArc(Double, Double, Double, Double, Double, Double, RectangleF%, Single%, Single%) | Create a GDI circular arc definition from start-point, end-point and tangent direction.
TransparencyMatrix(Double) | Create an image transparency matrix for a specific blending factor.
TransparencyMatrix(Int32) | Create an image transparency matrix for a specific blending factor.

See Also

GH_GraphicsUtil Class
Grasshopper.GUI Namespace


AppendArc Method

[image] [image]

Grasshopper SDK
GH_GraphicsUtil..::..AppendArc Method
GH_GraphicsUtil Class See Also Send Feedback

Overload List

Name | Description
AppendArc(Point3d, Point3d, Vector3d, GraphicsPath) | Append an arc segment to a GraphicsPath. If the arc cannot be solved, a linear segment is appended instead.
AppendArc(PointF, PointF, SizeF, GraphicsPath) | Append an arc segment to a GraphicsPath. If the arc cannot be solved, a linear segment is appended instead.

See Also

GH_GraphicsUtil Class
GH_GraphicsUtil Members
Grasshopper.GUI Namespace


AppendArc Method (, , , GraphicsPath)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..AppendArc Method (, , , GraphicsPath)
GH_GraphicsUtil Class See Also Send Feedback
Append an arc segment to a GraphicsPath. If the arc cannot be solved, a linear segment is appended instead.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void AppendArc(
    Point3d p0,
    Point3d p1,
    Vector3d dir,
    GraphicsPath path
)
Visual Basic
Public Shared Sub AppendArc ( _
    p0 As Point3d, _
    p1 As Point3d, _
    dir As Vector3d, _
    path As GraphicsPath _
)

Parameters

p0
Type: Point3d
Start point of arc.
p1
Type: Point3d
End point of arc.
dir
Type: Vector3d
Tangent direction at start of arc.
path
Type: System.Drawing.Drawing2D..::..GraphicsPath
Path to append to.

See Also

GH_GraphicsUtil Class
AppendArc Overload
Grasshopper.GUI Namespace


AppendArc Method (PointF, PointF, SizeF, GraphicsPath)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..AppendArc Method (PointF, PointF, SizeF, GraphicsPath)
GH_GraphicsUtil Class See Also Send Feedback
Append an arc segment to a GraphicsPath. If the arc cannot be solved, a linear segment is appended instead.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void AppendArc(
    PointF p0,
    PointF p1,
    SizeF dir,
    GraphicsPath path
)
Visual Basic
Public Shared Sub AppendArc ( _
    p0 As PointF, _
    p1 As PointF, _
    dir As SizeF, _
    path As GraphicsPath _
)

Parameters

p0
Type: System.Drawing..::..PointF
Start point of arc.
p1
Type: System.Drawing..::..PointF
End point of arc.
dir
Type: System.Drawing..::..SizeF
Tangent direction at start of arc.
path
Type: System.Drawing.Drawing2D..::..GraphicsPath
Path to append to.

See Also

GH_GraphicsUtil Class
AppendArc Overload
Grasshopper.GUI Namespace


BlendColour Method

[image] [image]

Grasshopper SDK
GH_GraphicsUtil..::..BlendColour Method
GH_GraphicsUtil Class See Also Send Feedback

Overload List

Name | Description
BlendColour(Color, Color) | Overlays two colours. The Alpha component of the top colour controls the blend.
BlendColour(Color, Color, Double) | Overlays two colours.

See Also

GH_GraphicsUtil Class
GH_GraphicsUtil Members
Grasshopper.GUI Namespace


BlendColour Method (Color, Color)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..BlendColour Method (Color, Color)
GH_GraphicsUtil Class See Also Send Feedback
Overlays two colours. The Alpha component of the top colour controls the blend.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Color BlendColour(
    Color bottom,
    Color top
)
Visual Basic
Public Shared Function BlendColour ( _
    bottom As Color, _
    top As Color _
) As Color

Parameters

bottom
Type: System.Drawing..::..Color
Base colour.
top
Type: System.Drawing..::..Color
Overlay colour.

Return Value

The blended colour. Alpha channels are added together.

See Also

GH_GraphicsUtil Class
BlendColour Overload
Grasshopper.GUI Namespace


BlendColour Method (Color, Color, Double)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..BlendColour Method (Color, Color, Double)
GH_GraphicsUtil Class See Also Send Feedback
Overlays two colours.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Color BlendColour(
    Color bottom,
    Color top,
    double factor
)
Visual Basic
Public Shared Function BlendColour ( _
    bottom As Color, _
    top As Color, _
    factor As Double _
) As Color

Parameters

bottom
Type: System.Drawing..::..Color
Base colour.
top
Type: System.Drawing..::..Color
Overlay colour.
factor
Type: System..::..Double
Blend factor. 0.0 means the return colour will be identical to the bottom colour, 1.0 means the return colour will be identical to the top colour.

Return Value

The blended colour.

See Also

GH_GraphicsUtil Class
BlendColour Overload
Grasshopper.GUI Namespace


BlendInteger Method

[image]

Grasshopper SDK
GH_GraphicsUtil..::..BlendInteger Method
GH_GraphicsUtil Class Example See Also Send Feedback
Calculates a linear blend between two extremes. Although the inputs are unlimited integers, the output is an integer in the byte range (0-255).

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static int BlendInteger(
    double t0,
    double t1,
    int a0,
    int a1,
    double t
)
Visual Basic
Public Shared Function BlendInteger ( _
    t0 As Double, _
    t1 As Double, _
    a0 As Integer, _
    a1 As Integer, _
    t As Double _
) As Integer

Parameters

t0
Type: System..::..Double
Value of first extreme.
t1
Type: System..::..Double
Value of second extreme.
a0
Type: System..::..Int32
Integer value at first extreme.
a1
Type: System..::..Int32
Integer value at second extreme.
t
Type: System..::..Double
Interpolation parameter.

Return Value

Interpolated value.

Examples

This function is useful when you need to link colour alpha amounts to zoom levels:
CopyVB.NET
Sub DrawZoomAwareCircle(ByVal G As Graphics, _
                        ByVal center As PointF, _
                        ByVal radius As Single, _
                        ByVal fill As Color)
  'Find the zoom level of the Graphics transform.
  Dim zoom As Single = G.Transform.Elements(0)

  'Abort if zoom less than 25%
  If (zoom < 0.25f) Then Return

  'Blend the alpha channel byte between 25% and 95% zoom.
  Dim alpha As Int32 = GH_GraphicsUtil.BlendByte(0.25, 0.95, 0, 255, zoom)
  G.FillEllipse(center.X - radius, center.Y - radius, _
                2.0f * radius, 2.0f * radius, _
                New SolidBrush(Color.FromARGB(alpha, fill)))
End Sub

See Also

GH_GraphicsUtil Class
Grasshopper.GUI Namespace


BoxClosestArcPoint Method

[image]

Grasshopper SDK
GH_GraphicsUtil..::..BoxClosestArcPoint Method
GH_GraphicsUtil Class See Also Send Feedback
Find the closest point on or in a box given a test point. Arc extension is implied.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static PointF BoxClosestArcPoint(
    PointF pt,
    RectangleF box
)
Visual Basic
Public Shared Function BoxClosestArcPoint ( _
    pt As PointF, _
    box As RectangleF _
) As PointF

Parameters

pt
Type: System.Drawing..::..PointF
Sample point.
box
Type: System.Drawing..::..RectangleF
Box to evaluate.

See Also

GH_GraphicsUtil Class
Grasshopper.GUI Namespace


BoxClosestPoint Method

[image] [image]

Grasshopper SDK
GH_GraphicsUtil..::..BoxClosestPoint Method
GH_GraphicsUtil Class See Also Send Feedback

Overload List

Name | Description
BoxClosestPoint(Point, Rectangle) | Find the closest point on or in a box given a test point.
BoxClosestPoint(PointF, RectangleF) | Find the closest point on or in a box given a test point.

See Also

GH_GraphicsUtil Class
GH_GraphicsUtil Members
Grasshopper.GUI Namespace


BoxClosestPoint Method (Point, Rectangle)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..BoxClosestPoint Method (Point, Rectangle)
GH_GraphicsUtil Class See Also Send Feedback
Find the closest point on or in a box given a test point.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Point BoxClosestPoint(
    Point pt,
    Rectangle box
)
Visual Basic
Public Shared Function BoxClosestPoint ( _
    pt As Point, _
    box As Rectangle _
) As Point

Parameters

pt
Type: System.Drawing..::..Point
Sample point.
box
Type: System.Drawing..::..Rectangle
Box to evaluate.

See Also

GH_GraphicsUtil Class
BoxClosestPoint Overload
Grasshopper.GUI Namespace


BoxClosestPoint Method (PointF, RectangleF)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..BoxClosestPoint Method (PointF, RectangleF)
GH_GraphicsUtil Class See Also Send Feedback
Find the closest point on or in a box given a test point.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static PointF BoxClosestPoint(
    PointF pt,
    RectangleF box
)
Visual Basic
Public Shared Function BoxClosestPoint ( _
    pt As PointF, _
    box As RectangleF _
) As PointF

Parameters

pt
Type: System.Drawing..::..PointF
Sample point.
box
Type: System.Drawing..::..RectangleF
Box to evaluate.

See Also

GH_GraphicsUtil Class
BoxClosestPoint Overload
Grasshopper.GUI Namespace


BoxFurthestPoint Method

[image] [image]

Grasshopper SDK
GH_GraphicsUtil..::..BoxFurthestPoint Method
GH_GraphicsUtil Class See Also Send Feedback

Overload List

Name | Description
BoxFurthestPoint(Point, Rectangle) | Find the furthest point on or in a box given a test point.
BoxFurthestPoint(PointF, RectangleF) | Find the furthest point on or in a box given a test point.

See Also

GH_GraphicsUtil Class
GH_GraphicsUtil Members
Grasshopper.GUI Namespace


BoxFurthestPoint Method (Point, Rectangle)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..BoxFurthestPoint Method (Point, Rectangle)
GH_GraphicsUtil Class See Also Send Feedback
Find the furthest point on or in a box given a test point.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Point BoxFurthestPoint(
    Point pt,
    Rectangle box
)
Visual Basic
Public Shared Function BoxFurthestPoint ( _
    pt As Point, _
    box As Rectangle _
) As Point

Parameters

pt
Type: System.Drawing..::..Point
Sample point.
box
Type: System.Drawing..::..Rectangle
Box to evaluate.

See Also

GH_GraphicsUtil Class
BoxFurthestPoint Overload
Grasshopper.GUI Namespace


BoxFurthestPoint Method (PointF, RectangleF)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..BoxFurthestPoint Method (PointF, RectangleF)
GH_GraphicsUtil Class See Also Send Feedback
Find the furthest point on or in a box given a test point.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static PointF BoxFurthestPoint(
    PointF pt,
    RectangleF box
)
Visual Basic
Public Shared Function BoxFurthestPoint ( _
    pt As PointF, _
    box As RectangleF _
) As PointF

Parameters

pt
Type: System.Drawing..::..PointF
Sample point.
box
Type: System.Drawing..::..RectangleF
Box to evaluate.

See Also

GH_GraphicsUtil Class
BoxFurthestPoint Overload
Grasshopper.GUI Namespace


BoxViewCone Method

[image]

Grasshopper SDK
GH_GraphicsUtil..::..BoxViewCone Method
GH_GraphicsUtil Class See Also Send Feedback
Computes the graphicspath that represents the viewcone for a point and a rectangle. If the rectangle contains the point, null is returned.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GraphicsPath BoxViewCone(
    PointF pt,
    RectangleF box
)
Visual Basic
Public Shared Function BoxViewCone ( _
    pt As PointF, _
    box As RectangleF _
) As GraphicsPath

Parameters

pt
Type: System.Drawing..::..PointF
box
Type: System.Drawing..::..RectangleF

See Also

GH_GraphicsUtil Class
Grasshopper.GUI Namespace


ColourARGB Method

[image] [image]

Grasshopper SDK
GH_GraphicsUtil..::..ColourARGB Method
GH_GraphicsUtil Class See Also Send Feedback

Overload List

Name | Description
ColourARGB(Double, Double, Double) | Create a colour from floating ARGB channels (0.0~1.0). Channels are clipped to valid ranges.
ColourARGB(Int32, Int32, Int32) | Create a colour from integer RGB channels. Channels are clipped to valid ranges.
ColourARGB(Int32, Int32, Int32, Int32) | Create a colour from integer ARGB channels. Channels are clipped to valid ranges.

See Also

GH_GraphicsUtil Class
GH_GraphicsUtil Members
Grasshopper.GUI Namespace


ColourARGB Method (Double, Double, Double)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..ColourARGB Method (Double, Double, Double)
GH_GraphicsUtil Class See Also Send Feedback
Create a colour from floating ARGB channels (0.0~1.0). Channels are clipped to valid ranges.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Color ColourARGB(
    double R,
    double G,
    double B
)
Visual Basic
Public Shared Function ColourARGB ( _
    R As Double, _
    G As Double, _
    B As Double _
) As Color

Parameters

R
Type: System..::..Double
G
Type: System..::..Double
B
Type: System..::..Double

Return Value

The colour implied by the RGB channel values.

See Also

GH_GraphicsUtil Class
ColourARGB Overload
Grasshopper.GUI Namespace


ColourARGB Method (Int32, Int32, Int32)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..ColourARGB Method (Int32, Int32, Int32)
GH_GraphicsUtil Class See Also Send Feedback
Create a colour from integer RGB channels. Channels are clipped to valid ranges.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Color ColourARGB(
    int R,
    int G,
    int B
)
Visual Basic
Public Shared Function ColourARGB ( _
    R As Integer, _
    G As Integer, _
    B As Integer _
) As Color

Parameters

R
Type: System..::..Int32
G
Type: System..::..Int32
B
Type: System..::..Int32

Return Value

Returns the colour as implied by the RGB channel values.

See Also

GH_GraphicsUtil Class
ColourARGB Overload
Grasshopper.GUI Namespace


ColourARGB Method (Int32, Int32, Int32, Int32)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..ColourARGB Method (Int32, Int32, Int32, Int32)
GH_GraphicsUtil Class See Also Send Feedback
Create a colour from integer ARGB channels. Channels are clipped to valid ranges.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Color ColourARGB(
    int A,
    int R,
    int G,
    int B
)
Visual Basic
Public Shared Function ColourARGB ( _
    A As Integer, _
    R As Integer, _
    G As Integer, _
    B As Integer _
) As Color

Parameters

A
Type: System..::..Int32
R
Type: System..::..Int32
G
Type: System..::..Int32
B
Type: System..::..Int32

Return Value

Returns the colour as implied by the ARGB channel values.

See Also

GH_GraphicsUtil Class
ColourARGB Overload
Grasshopper.GUI Namespace


CreateColourIcon Method

[image]

Grasshopper SDK
GH_GraphicsUtil..::..CreateColourIcon Method
GH_GraphicsUtil Class See Also Send Feedback
Create a colour swatch icon.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Bitmap CreateColourIcon(
    int width,
    int height,
    Color colour
)
Visual Basic
Public Shared Function CreateColourIcon ( _
    width As Integer, _
    height As Integer, _
    colour As Color _
) As Bitmap

Parameters

width
Type: System..::..Int32
Width of icon.
height
Type: System..::..Int32
Height of icon.
colour
Type: System.Drawing..::..Color
Colour for swatch, if colour contains an alpha component, you should draw an alpha-grid behind the icon.

Return Value

A bitmap with the requested icon colour.

See Also

GH_GraphicsUtil Class
Grasshopper.GUI Namespace


DentHorizontal Method

[image] [image]

Grasshopper SDK
GH_GraphicsUtil..::..DentHorizontal Method
GH_GraphicsUtil Class See Also Send Feedback

Overload List

Name | Description
DentHorizontal(Graphics, Rectangle) | Draws a horizontal dent. A horizontal dent had dark lines along the top and bottom edges.
DentHorizontal(Graphics, Rectangle, Int32, Int32) | Draws a horizontal dent. A horizontal dent had dark lines along the top and bottom edges.

See Also

GH_GraphicsUtil Class
GH_GraphicsUtil Members
Grasshopper.GUI Namespace


DentHorizontal Method (Graphics, Rectangle)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..DentHorizontal Method (Graphics, Rectangle)
GH_GraphicsUtil Class See Also Send Feedback
Draws a horizontal dent. A horizontal dent had dark lines along the top and bottom edges.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void DentHorizontal(
    Graphics G,
    Rectangle box
)
Visual Basic
Public Shared Sub DentHorizontal ( _
    G As Graphics, _
    box As Rectangle _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.
box
Type: System.Drawing..::..Rectangle
Dimensions of the dent.

See Also

GH_GraphicsUtil Class
DentHorizontal Overload
Grasshopper.GUI Namespace


DentHorizontal Method (Graphics, Rectangle, Int32, Int32)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..DentHorizontal Method (Graphics, Rectangle, Int32, Int32)
GH_GraphicsUtil Class See Also Send Feedback
Draws a horizontal dent. A horizontal dent had dark lines along the top and bottom edges.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void DentHorizontal(
    Graphics G,
    Rectangle box,
    int alphaEdge,
    int alphaFill
)
Visual Basic
Public Shared Sub DentHorizontal ( _
    G As Graphics, _
    box As Rectangle, _
    alphaEdge As Integer, _
    alphaFill As Integer _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.
box
Type: System.Drawing..::..Rectangle
Dimensions of the dent.
alphaEdge
Type: System..::..Int32
Transparency on the middle of the edges.
alphaFill
Type: System..::..Int32
Transparency on the middle of the fill.

See Also

GH_GraphicsUtil Class
DentHorizontal Overload
Grasshopper.GUI Namespace


DentVertical Method

[image] [image]

Grasshopper SDK
GH_GraphicsUtil..::..DentVertical Method
GH_GraphicsUtil Class See Also Send Feedback

Overload List

Name | Description
DentVertical(Graphics, Rectangle) | Draws a vertical dent. A vertical dent had dark lines along the left and right edges.
DentVertical(Graphics, Rectangle, Int32, Int32) | Draws a vertical dent. A vertical dent had dark lines along the left and right edges.

See Also

GH_GraphicsUtil Class
GH_GraphicsUtil Members
Grasshopper.GUI Namespace


DentVertical Method (Graphics, Rectangle)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..DentVertical Method (Graphics, Rectangle)
GH_GraphicsUtil Class See Also Send Feedback
Draws a vertical dent. A vertical dent had dark lines along the left and right edges.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void DentVertical(
    Graphics G,
    Rectangle box
)
Visual Basic
Public Shared Sub DentVertical ( _
    G As Graphics, _
    box As Rectangle _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.
box
Type: System.Drawing..::..Rectangle
Dimensions of the dent.

See Also

GH_GraphicsUtil Class
DentVertical Overload
Grasshopper.GUI Namespace


DentVertical Method (Graphics, Rectangle, Int32, Int32)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..DentVertical Method (Graphics, Rectangle, Int32, Int32)
GH_GraphicsUtil Class See Also Send Feedback
Draws a vertical dent. A vertical dent had dark lines along the left and right edges.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void DentVertical(
    Graphics G,
    Rectangle box,
    int alphaEdge,
    int alphaFill
)
Visual Basic
Public Shared Sub DentVertical ( _
    G As Graphics, _
    box As Rectangle, _
    alphaEdge As Integer, _
    alphaFill As Integer _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.
box
Type: System.Drawing..::..Rectangle
Dimensions of the dent.
alphaEdge
Type: System..::..Int32
Transparency on the middle of the edges.
alphaFill
Type: System..::..Int32
Transparency on the middle of the fill.

See Also

GH_GraphicsUtil Class
DentVertical Overload
Grasshopper.GUI Namespace


Distance Method

[image]

Grasshopper SDK
GH_GraphicsUtil..::..Distance Method
GH_GraphicsUtil Class See Also Send Feedback
Compute the distance between two points.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static float Distance(
    PointF A,
    PointF B
)
Visual Basic
Public Shared Function Distance ( _
    A As PointF, _
    B As PointF _
) As Single

Parameters

A
Type: System.Drawing..::..PointF
First point.
B
Type: System.Drawing..::..PointF
Second point.

See Also

GH_GraphicsUtil Class
Grasshopper.GUI Namespace


DistanceS Method

[image]

Grasshopper SDK
GH_GraphicsUtil..::..DistanceS Method
GH_GraphicsUtil Class See Also Send Feedback
Compute the squared distance between two points.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static float DistanceS(
    PointF A,
    PointF B
)
Visual Basic
Public Shared Function DistanceS ( _
    A As PointF, _
    B As PointF _
) As Single

Parameters

A
Type: System.Drawing..::..PointF
First point.
B
Type: System.Drawing..::..PointF
Second point.

See Also

GH_GraphicsUtil Class
Grasshopper.GUI Namespace


EtchFadingHorizontal Method

[image]

Grasshopper SDK
GH_GraphicsUtil..::..EtchFadingHorizontal Method
GH_GraphicsUtil Class See Also Send Feedback
Draw an etched line with fading on the extremes.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void EtchFadingHorizontal(
    Graphics G,
    int x0,
    int x1,
    int y,
    int alphaLight,
    int alphaDark
)
Visual Basic
Public Shared Sub EtchFadingHorizontal ( _
    G As Graphics, _
    x0 As Integer, _
    x1 As Integer, _
    y As Integer, _
    alphaLight As Integer, _
    alphaDark As Integer _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.
x0
Type: System..::..Int32
Left x coordinate of etch.
x1
Type: System..::..Int32
Right x coordinate of etch.
y
Type: System..::..Int32
Y coordinate of etch.
alphaLight
Type: System..::..Int32
Transparancy of bright etch line.
alphaDark
Type: System..::..Int32
Transparency of dark etch line.

See Also

GH_GraphicsUtil Class
Grasshopper.GUI Namespace


EtchFadingVertical Method

[image]

Grasshopper SDK
GH_GraphicsUtil..::..EtchFadingVertical Method
GH_GraphicsUtil Class See Also Send Feedback
Draw an etched line with fading on the extremes.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void EtchFadingVertical(
    Graphics G,
    int y0,
    int y1,
    int x,
    int alphaLight,
    int alphaDark
)
Visual Basic
Public Shared Sub EtchFadingVertical ( _
    G As Graphics, _
    y0 As Integer, _
    y1 As Integer, _
    x As Integer, _
    alphaLight As Integer, _
    alphaDark As Integer _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.
y0
Type: System..::..Int32
Top y coordinate of etch.
y1
Type: System..::..Int32
Bottom y coordinate of etch.
x
Type: System..::..Int32
X coordinate of etch.
alphaLight
Type: System..::..Int32
Transparancy of etch.
alphaDark
Type: System..::..Int32
Transparancy of etch.

See Also

GH_GraphicsUtil Class
Grasshopper.GUI Namespace


EtchHorizontal Method

[image] [image]

Grasshopper SDK
GH_GraphicsUtil..::..EtchHorizontal Method
GH_GraphicsUtil Class See Also Send Feedback

Overload List

Name | Description
EtchHorizontal(Graphics, Single, Single, Single, Int32) | Draws an etched line segment.
EtchHorizontal(Graphics, Int32, Int32, Int32, Int32, Int32) | Draws an etched line segment.

See Also

GH_GraphicsUtil Class
GH_GraphicsUtil Members
Grasshopper.GUI Namespace


EtchHorizontal Method (Graphics, Single, Single, Single, Int32)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..EtchHorizontal Method (Graphics, Single, Single, Single, Int32)
GH_GraphicsUtil Class See Also Send Feedback
Draws an etched line segment.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void EtchHorizontal(
    Graphics G,
    float x0,
    float x1,
    float y,
    int alpha
)
Visual Basic
Public Shared Sub EtchHorizontal ( _
    G As Graphics, _
    x0 As Single, _
    x1 As Single, _
    y As Single, _
    alpha As Integer _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.
x0
Type: System..::..Single
x component of start point.
x1
Type: System..::..Single
x component of end point.
y
Type: System..::..Single
y component of line segment.
alpha
Type: System..::..Int32
Alpha level of etched line.

See Also

GH_GraphicsUtil Class
EtchHorizontal Overload
Grasshopper.GUI Namespace


EtchHorizontal Method (Graphics, Int32, Int32, Int32, Int32, Int32)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..EtchHorizontal Method (Graphics, Int32, Int32, Int32, Int32, Int32)
GH_GraphicsUtil Class See Also Send Feedback
Draws an etched line segment.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void EtchHorizontal(
    Graphics G,
    int x0,
    int x1,
    int y,
    int alphaLight,
    int alphaDark
)
Visual Basic
Public Shared Sub EtchHorizontal ( _
    G As Graphics, _
    x0 As Integer, _
    x1 As Integer, _
    y As Integer, _
    alphaLight As Integer, _
    alphaDark As Integer _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.
x0
Type: System..::..Int32
x component of start point.
x1
Type: System..::..Int32
x component of end point.
y
Type: System..::..Int32
y component of line segment.
alphaLight
Type: System..::..Int32
Alpha level of etched lit line.
alphaDark
Type: System..::..Int32
Alpha level of etched shadow line.

See Also

GH_GraphicsUtil Class
EtchHorizontal Overload
Grasshopper.GUI Namespace


EtchVertical Method

[image] [image]

Grasshopper SDK
GH_GraphicsUtil..::..EtchVertical Method
GH_GraphicsUtil Class See Also Send Feedback

Overload List

Name | Description
EtchVertical(Graphics, Int32, Int32, Int32, Int32) | Draws an etched line segment.
EtchVertical(Graphics, Single, Single, Single, Int32) | Draws an etched line segment.

See Also

GH_GraphicsUtil Class
GH_GraphicsUtil Members
Grasshopper.GUI Namespace


EtchVertical Method (Graphics, Int32, Int32, Int32, Int32)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..EtchVertical Method (Graphics, Int32, Int32, Int32, Int32)
GH_GraphicsUtil Class See Also Send Feedback
Draws an etched line segment.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void EtchVertical(
    Graphics G,
    int x,
    int y0,
    int y1,
    int alpha
)
Visual Basic
Public Shared Sub EtchVertical ( _
    G As Graphics, _
    x As Integer, _
    y0 As Integer, _
    y1 As Integer, _
    alpha As Integer _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.
x
Type: System..::..Int32
x component of line segment.
y0
Type: System..::..Int32
x component of start point.
y1
Type: System..::..Int32
y component of end point.
alpha
Type: System..::..Int32
Alpha level of etched line.

See Also

GH_GraphicsUtil Class
EtchVertical Overload
Grasshopper.GUI Namespace


EtchVertical Method (Graphics, Single, Single, Single, Int32)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..EtchVertical Method (Graphics, Single, Single, Single, Int32)
GH_GraphicsUtil Class See Also Send Feedback
Draws an etched line segment.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void EtchVertical(
    Graphics G,
    float x,
    float y0,
    float y1,
    int alpha
)
Visual Basic
Public Shared Sub EtchVertical ( _
    G As Graphics, _
    x As Single, _
    y0 As Single, _
    y1 As Single, _
    alpha As Integer _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.
x
Type: System..::..Single
x component of line segment.
y0
Type: System..::..Single
x component of start point.
y1
Type: System..::..Single
y component of end point.
alpha
Type: System..::..Int32
Alpha level of etched line.

See Also

GH_GraphicsUtil Class
EtchVertical Overload
Grasshopper.GUI Namespace


FadeColour Method

[image]

Grasshopper SDK
GH_GraphicsUtil..::..FadeColour Method
GH_GraphicsUtil Class See Also Send Feedback
Fade a colour to transparency by linearly blending a parameter between extremes.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Color FadeColour(
    double t0,
    double t1,
    double t,
    Color col
)
Visual Basic
Public Shared Function FadeColour ( _
    t0 As Double, _
    t1 As Double, _
    t As Double, _
    col As Color _
) As Color

Parameters

t0
Type: System..::..Double
First extreme. (represents transparency)
t1
Type: System..::..Double
Second extreme. (represent unaltered colour)
t
Type: System..::..Double
Blending factor between t0 and t1.
col
Type: System.Drawing..::..Color
Colour to fade.

Return Value

The colour adjusted for blending.

See Also

GH_GraphicsUtil Class
Grasshopper.GUI Namespace


ForegroundColour Method

[image]

Grasshopper SDK
GH_GraphicsUtil..::..ForegroundColour Method
GH_GraphicsUtil Class See Also Send Feedback
Calculates a suitable foreground color. If the background is lighter than 50%, the foreground will be darker, otherwise the foreground will be lighter.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Color ForegroundColour(
    Color col,
    int Contrast
)
Visual Basic
Public Shared Function ForegroundColour ( _
    col As Color, _
    Contrast As Integer _
) As Color

Parameters

col
Type: System.Drawing..::..Color
Foreground colour that works well on the given background colour.
Contrast
Type: System..::..Int32
Contrast amount (in 0~255 range)

See Also

GH_GraphicsUtil Class
Grasshopper.GUI Namespace


Grid Method

[image] [image]

Grasshopper SDK
GH_GraphicsUtil..::..Grid Method
GH_GraphicsUtil Class See Also Send Feedback

Overload List

Name | Description
Grid(Graphics, RectangleF, Int32) | Draw a default grid.
Grid(Graphics, RectangleF, Int32, Int32) | Draw a default grid.
Grid(Graphics, RectangleF, Int32, Int32, Color, Color) | Draw a grid.

See Also

GH_GraphicsUtil Class
GH_GraphicsUtil Members
Grasshopper.GUI Namespace


Grid Method (Graphics, RectangleF, Int32)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..Grid Method (Graphics, RectangleF, Int32)
GH_GraphicsUtil Class See Also Send Feedback
Draw a default grid.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void Grid(
    Graphics G,
    RectangleF rec,
    int density
)
Visual Basic
Public Shared Sub Grid ( _
    G As Graphics, _
    rec As RectangleF, _
    density As Integer _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.
rec
Type: System.Drawing..::..RectangleF
Grid rectangle.
density
Type: System..::..Int32
Density in both directions.

See Also

GH_GraphicsUtil Class
Grid Overload
Grasshopper.GUI Namespace


Grid Method (Graphics, RectangleF, Int32, Int32)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..Grid Method (Graphics, RectangleF, Int32, Int32)
GH_GraphicsUtil Class See Also Send Feedback
Draw a default grid.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void Grid(
    Graphics G,
    RectangleF rec,
    int density_x,
    int density_y
)
Visual Basic
Public Shared Sub Grid ( _
    G As Graphics, _
    rec As RectangleF, _
    density_x As Integer, _
    density_y As Integer _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.
rec
Type: System.Drawing..::..RectangleF
Grid rectangle.
density_x
Type: System..::..Int32
Density in x direction.
density_y
Type: System..::..Int32
Density in y direction.

See Also

GH_GraphicsUtil Class
Grid Overload
Grasshopper.GUI Namespace


Grid Method (Graphics, RectangleF, Int32, Int32, Color, Color)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..Grid Method (Graphics, RectangleF, Int32, Int32, Color, Color)
GH_GraphicsUtil Class See Also Send Feedback
Draw a grid.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void Grid(
    Graphics G,
    RectangleF rec,
    int density_x,
    int density_y,
    Color color_bg,
    Color color_wire
)
Visual Basic
Public Shared Sub Grid ( _
    G As Graphics, _
    rec As RectangleF, _
    density_x As Integer, _
    density_y As Integer, _
    color_bg As Color, _
    color_wire As Color _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.
rec
Type: System.Drawing..::..RectangleF
Grid rectangle.
density_x
Type: System..::..Int32
Density in x direction.
density_y
Type: System..::..Int32
Density in y direction.
color_bg
Type: System.Drawing..::..Color
Background colour override, the default is 30/255 white.
color_wire
Type: System.Drawing..::..Color
Grid line colour override, the default is 40/255 black.

See Also

GH_GraphicsUtil Class
Grid Overload
Grasshopper.GUI Namespace


HighlightBrush Method

[image]

Grasshopper SDK
GH_GraphicsUtil..::..HighlightBrush Method
GH_GraphicsUtil Class See Also Send Feedback
Gets a new brush object that can be used to draw the content of hover and focus rectangles. Caller is responsible for disposing the brush.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Brush HighlightBrush()
Visual Basic
Public Shared Function HighlightBrush As Brush

See Also

GH_GraphicsUtil Class
Grasshopper.GUI Namespace


HighlightPen Method

[image]

Grasshopper SDK
GH_GraphicsUtil..::..HighlightPen Method
GH_GraphicsUtil Class See Also Send Feedback
Gets a new pen object that can be used to draw the edges of hover and focus rectangles. Caller is responsible for disposing the pen.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Pen HighlightPen()
Visual Basic
Public Shared Function HighlightPen As Pen

See Also

GH_GraphicsUtil Class
Grasshopper.GUI Namespace


InvertColour Method

[image]

Grasshopper SDK
GH_GraphicsUtil..::..InvertColour Method
GH_GraphicsUtil Class See Also Send Feedback
Computes the inverted colour. Alpha remains the same.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Color InvertColour(
    Color col
)
Visual Basic
Public Shared Function InvertColour ( _
    col As Color _
) As Color

Parameters

col
Type: System.Drawing..::..Color

Return Value

Colour where RGB channels are set to 255-C.

See Also

GH_GraphicsUtil Class
Grasshopper.GUI Namespace


IsPointInEllipse Method

[image]

Grasshopper SDK
GH_GraphicsUtil..::..IsPointInEllipse Method
GH_GraphicsUtil Class See Also Send Feedback
Test whether a point is inside or outside an ellipse.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool IsPointInEllipse(
    RectangleF ellipse,
    PointF point
)
Visual Basic
Public Shared Function IsPointInEllipse ( _
    ellipse As RectangleF, _
    point As PointF _
) As Boolean

Parameters

ellipse
Type: System.Drawing..::..RectangleF
Rectangle describing ellipse.
point
Type: System.Drawing..::..PointF
Point to test for inclusion.

Return Value

True if the point is in or on the ellipse.

See Also

GH_GraphicsUtil Class
Grasshopper.GUI Namespace


LimitInteger Method

[image]

Grasshopper SDK
GH_GraphicsUtil..::..LimitInteger Method
GH_GraphicsUtil Class See Also Send Feedback
Limits the given integer to the 0~255 range.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void LimitInteger(
    ref int channel
)
Visual Basic
Public Shared Sub LimitInteger ( _
    ByRef channel As Integer _
)

Parameters

channel
Type: System..::..Int32 %

See Also

GH_GraphicsUtil Class
Grasshopper.GUI Namespace


LimitIntegers Method

[image]

Grasshopper SDK
GH_GraphicsUtil..::..LimitIntegers Method
GH_GraphicsUtil Class See Also Send Feedback
Limits RGB channels to the 0~255 range,

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void LimitIntegers(
    ref int R,
    ref int G,
    ref int B
)
Visual Basic
Public Shared Sub LimitIntegers ( _
    ByRef R As Integer, _
    ByRef G As Integer, _
    ByRef B As Integer _
)

Parameters

R
Type: System..::..Int32 %
G
Type: System..::..Int32 %
B
Type: System..::..Int32 %

See Also

GH_GraphicsUtil Class
Grasshopper.GUI Namespace


OffsetColour Method

[image] [image]

Grasshopper SDK
GH_GraphicsUtil..::..OffsetColour Method
GH_GraphicsUtil Class See Also Send Feedback

Overload List

Name | Description
OffsetColour(Color, Int32) | Add a fixed value to all the channels in a colour.
OffsetColour(Color, Int32, Int32, Int32) | Add a fixed value to all the channels in a colour.

See Also

GH_GraphicsUtil Class
GH_GraphicsUtil Members
Grasshopper.GUI Namespace


OffsetColour Method (Color, Int32)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..OffsetColour Method (Color, Int32)
GH_GraphicsUtil Class See Also Send Feedback
Add a fixed value to all the channels in a colour.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Color OffsetColour(
    Color col,
    int shift
)
Visual Basic
Public Shared Function OffsetColour ( _
    col As Color, _
    shift As Integer _
) As Color

Parameters

col
Type: System.Drawing..::..Color
The colour to mutate.
shift
Type: System..::..Int32
Offset value (-255 ~ +255).

Return Value

The offsetted colour.

Remarks

The alpha channel of the colour is not offset.

See Also

GH_GraphicsUtil Class
OffsetColour Overload
Grasshopper.GUI Namespace


OffsetColour Method (Color, Int32, Int32, Int32)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..OffsetColour Method (Color, Int32, Int32, Int32)
GH_GraphicsUtil Class See Also Send Feedback
Add a fixed value to all the channels in a colour.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Color OffsetColour(
    Color col,
    int red_shift,
    int green_shift,
    int blue_shift
)
Visual Basic
Public Shared Function OffsetColour ( _
    col As Color, _
    red_shift As Integer, _
    green_shift As Integer, _
    blue_shift As Integer _
) As Color

Parameters

col
Type: System.Drawing..::..Color
The colour to mutate
red_shift
Type: System..::..Int32
Offset value for red channel (-255 ~ +255).
green_shift
Type: System..::..Int32
Offset value for green channel (-255 ~ +255).
blue_shift
Type: System..::..Int32
Offset value for blue channel (-255 ~ +255).

Return Value

The offsetted colour.

Remarks

The alpha channel of the colour is not offset.

See Also

GH_GraphicsUtil Class
OffsetColour Overload
Grasshopper.GUI Namespace


RenderBalloonTag Method

[image] [image]

Grasshopper SDK
GH_GraphicsUtil..::..RenderBalloonTag Method
GH_GraphicsUtil Class See Also Send Feedback

Overload List

Name | Description
RenderBalloonTag(Graphics, String, PointF, RectangleF) | Draw a default balloon tag in a container.
RenderBalloonTag(Graphics, String, Font, PointF, RectangleF) | Draw a default balloon tag in a container with a Font override.
RenderBalloonTag(Graphics, String, Font, Color, Color, PointF, Boolean) | Draw a balloon tag in a container.
RenderBalloonTag(Graphics, String, Font, Color, Color, PointF, RectangleF) | Draw a balloon tag in a container.

See Also

GH_GraphicsUtil Class
GH_GraphicsUtil Members
Grasshopper.GUI Namespace


RenderBalloonTag Method (Graphics, String, PointF, RectangleF)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..RenderBalloonTag Method (Graphics, String, PointF, RectangleF)
GH_GraphicsUtil Class See Also Send Feedback
Draw a default balloon tag in a container.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void RenderBalloonTag(
    Graphics G,
    string text,
    PointF tip,
    RectangleF container
)
Visual Basic
Public Shared Sub RenderBalloonTag ( _
    G As Graphics, _
    text As String, _
    tip As PointF, _
    container As RectangleF _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.
text
Type: System..::..String
Text of tag.
tip
Type: System.Drawing..::..PointF
Tip of balloon.
container
Type: System.Drawing..::..RectangleF
Container for balloon.

See Also

GH_GraphicsUtil Class
RenderBalloonTag Overload
Grasshopper.GUI Namespace


RenderBalloonTag Method (Graphics, String, Font, PointF, RectangleF)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..RenderBalloonTag Method (Graphics, String, Font, PointF, RectangleF)
GH_GraphicsUtil Class See Also Send Feedback
Draw a default balloon tag in a container with a Font override.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void RenderBalloonTag(
    Graphics G,
    string text,
    Font font,
    PointF tip,
    RectangleF container
)
Visual Basic
Public Shared Sub RenderBalloonTag ( _
    G As Graphics, _
    text As String, _
    font As Font, _
    tip As PointF, _
    container As RectangleF _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.
text
Type: System..::..String
Text of tag.
font
Type: System.Drawing..::..Font
Font of tag.
tip
Type: System.Drawing..::..PointF
Tip of balloon.
container
Type: System.Drawing..::..RectangleF
Container for balloon.

See Also

GH_GraphicsUtil Class
RenderBalloonTag Overload
Grasshopper.GUI Namespace


RenderBalloonTag Method (Graphics, String, Font, Color, Color, PointF, Boolean)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..RenderBalloonTag Method (Graphics, String, Font, Color, Color, PointF, Boolean)
GH_GraphicsUtil Class See Also Send Feedback
Draw a balloon tag in a container.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void RenderBalloonTag(
    Graphics G,
    string text,
    Font font,
    Color back_color,
    Color fore_color,
    PointF tip,
    bool upright
)
Visual Basic
Public Shared Sub RenderBalloonTag ( _
    G As Graphics, _
    text As String, _
    font As Font, _
    back_color As Color, _
    fore_color As Color, _
    tip As PointF, _
    upright As Boolean _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.
text
Type: System..::..String
Text of tag.
font
Type: System.Drawing..::..Font
Font of tag.
back_color
Type: System.Drawing..::..Color
Background colour of balloon.
fore_color
Type: System.Drawing..::..Color
Foreground colour of balloon edge and text.
tip
Type: System.Drawing..::..PointF
Tip of balloon.
upright
Type: System..::..Boolean
If true, the balloon will be above the tip point.

See Also

GH_GraphicsUtil Class
RenderBalloonTag Overload
Grasshopper.GUI Namespace


RenderBalloonTag Method (Graphics, String, Font, Color, Color, PointF, RectangleF)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..RenderBalloonTag Method (Graphics, String, Font, Color, Color, PointF, RectangleF)
GH_GraphicsUtil Class See Also Send Feedback
Draw a balloon tag in a container.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void RenderBalloonTag(
    Graphics G,
    string text,
    Font font,
    Color back_color,
    Color fore_color,
    PointF tip,
    RectangleF container
)
Visual Basic
Public Shared Sub RenderBalloonTag ( _
    G As Graphics, _
    text As String, _
    font As Font, _
    back_color As Color, _
    fore_color As Color, _
    tip As PointF, _
    container As RectangleF _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.
text
Type: System..::..String
Text of tag.
font
Type: System.Drawing..::..Font
Font of tag.
back_color
Type: System.Drawing..::..Color
Background colour of balloon.
fore_color
Type: System.Drawing..::..Color
Foreground colout of balloon edge and text.
tip
Type: System.Drawing..::..PointF
Tip of balloon (should be inside container).
container
Type: System.Drawing..::..RectangleF
Container for balloon.

See Also

GH_GraphicsUtil Class
RenderBalloonTag Overload
Grasshopper.GUI Namespace


RenderCenteredIcon Method

[image] [image]

Grasshopper SDK
GH_GraphicsUtil..::..RenderCenteredIcon Method
GH_GraphicsUtil Class See Also Send Feedback

Overload List

Name | Description
RenderCenteredIcon(Graphics, RectangleF, Image) | Draw an icon centered in a frame. This code is not zoom-aware, but it will perform consistent rounding (to avoid pixel-jitter when moving the frame across the screen). Icon will not be clipped to the frame.
RenderCenteredIcon(Graphics, RectangleF, Image, Double) | Draw an icon centered in a frame. This code is not zoom-aware, but it will perform consistent rounding (to avoid pixel-jitter when moving the frame across the screen). Icon will not be clipped to the frame.

See Also

GH_GraphicsUtil Class
GH_GraphicsUtil Members
Grasshopper.GUI Namespace


RenderCenteredIcon Method (Graphics, RectangleF, Image)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..RenderCenteredIcon Method (Graphics, RectangleF, Image)
GH_GraphicsUtil Class See Also Send Feedback
Draw an icon centered in a frame. This code is not zoom-aware, but it will perform consistent rounding (to avoid pixel-jitter when moving the frame across the screen). Icon will not be clipped to the frame.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void RenderCenteredIcon(
    Graphics G,
    RectangleF frame,
    Image icon
)
Visual Basic
Public Shared Sub RenderCenteredIcon ( _
    G As Graphics, _
    frame As RectangleF, _
    icon As Image _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to render with.
frame
Type: System.Drawing..::..RectangleF
Frame to center icon in.
icon
Type: System.Drawing..::..Image
Icon to render

See Also

GH_GraphicsUtil Class
RenderCenteredIcon Overload
Grasshopper.GUI Namespace


RenderCenteredIcon Method (Graphics, RectangleF, Image, Double)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..RenderCenteredIcon Method (Graphics, RectangleF, Image, Double)
GH_GraphicsUtil Class See Also Send Feedback
Draw an icon centered in a frame. This code is not zoom-aware, but it will perform consistent rounding (to avoid pixel-jitter when moving the frame across the screen). Icon will not be clipped to the frame.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void RenderCenteredIcon(
    Graphics G,
    RectangleF frame,
    Image icon,
    double alpha
)
Visual Basic
Public Shared Sub RenderCenteredIcon ( _
    G As Graphics, _
    frame As RectangleF, _
    icon As Image, _
    alpha As Double _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to render with.
frame
Type: System.Drawing..::..RectangleF
Frame to center icon in.
icon
Type: System.Drawing..::..Image
Icon to render
alpha
Type: System..::..Double
Transparency factor.

See Also

GH_GraphicsUtil Class
RenderCenteredIcon Overload
Grasshopper.GUI Namespace


RenderCenteredText Method

[image]

Grasshopper SDK
GH_GraphicsUtil..::..RenderCenteredText Method
GH_GraphicsUtil Class See Also Send Feedback
Render a bit of text centered on a point.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void RenderCenteredText(
    Graphics G,
    string text,
    Font font,
    Color color,
    PointF center
)
Visual Basic
Public Shared Sub RenderCenteredText ( _
    G As Graphics, _
    text As String, _
    font As Font, _
    color As Color, _
    center As PointF _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.
text
Type: System..::..String
Text to draw.
font
Type: System.Drawing..::..Font
Font to use.
color
Type: System.Drawing..::..Color
Text color.
center
Type: System.Drawing..::..PointF
Center point.

See Also

GH_GraphicsUtil Class
Grasshopper.GUI Namespace


RenderColourIcon Method

[image]

Grasshopper SDK
GH_GraphicsUtil..::..RenderColourIcon Method
GH_GraphicsUtil Class See Also Send Feedback
Render a colour icon into a graphics context. A colour icon contains a black outer and white inner edge.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void RenderColourIcon(
    Graphics G,
    Rectangle rec,
    Color colour
)
Visual Basic
Public Shared Sub RenderColourIcon ( _
    G As Graphics, _
    rec As Rectangle, _
    colour As Color _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.
rec
Type: System.Drawing..::..Rectangle
Rectangle describing icon dimensions.
colour
Type: System.Drawing..::..Color
Colour for icon.

See Also

GH_GraphicsUtil Class
Grasshopper.GUI Namespace


RenderFadedImage Method

[image] [image]

Grasshopper SDK
GH_GraphicsUtil..::..RenderFadedImage Method
GH_GraphicsUtil Class See Also Send Feedback

Overload List

Name | Description
RenderFadedImage(Graphics, Image, Rectangle, Double) | Render an icon into a rectangle with a specific fading factor.
RenderFadedImage(Graphics, Image, Rectangle, Int32) | Render an icon into a rectangle with a specific fading factor.

See Also

GH_GraphicsUtil Class
GH_GraphicsUtil Members
Grasshopper.GUI Namespace


RenderFadedImage Method (Graphics, Image, Rectangle, Double)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..RenderFadedImage Method (Graphics, Image, Rectangle, Double)
GH_GraphicsUtil Class See Also Send Feedback
Render an icon into a rectangle with a specific fading factor.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void RenderFadedImage(
    Graphics graphics,
    Image image,
    Rectangle destination,
    double fade
)
Visual Basic
Public Shared Sub RenderFadedImage ( _
    graphics As Graphics, _
    image As Image, _
    destination As Rectangle, _
    fade As Double _
)

Parameters

graphics
Type: System.Drawing..::..Graphics
Graphics object to draw with.
image
Type: System.Drawing..::..Image
Image to draw.
destination
Type: System.Drawing..::..Rectangle
Destination rectangle.
fade
Type: System..::..Double
Fading amount. 0.0=completely transparent, 1.0=original transparency.

See Also

GH_GraphicsUtil Class
RenderFadedImage Overload
Grasshopper.GUI Namespace


RenderFadedImage Method (Graphics, Image, Rectangle, Int32)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..RenderFadedImage Method (Graphics, Image, Rectangle, Int32)
GH_GraphicsUtil Class See Also Send Feedback
Render an icon into a rectangle with a specific fading factor.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void RenderFadedImage(
    Graphics graphics,
    Image image,
    Rectangle destination,
    int alpha
)
Visual Basic
Public Shared Sub RenderFadedImage ( _
    graphics As Graphics, _
    image As Image, _
    destination As Rectangle, _
    alpha As Integer _
)

Parameters

graphics
Type: System.Drawing..::..Graphics
Graphics object to draw with.
image
Type: System.Drawing..::..Image
Image to draw.
destination
Type: System.Drawing..::..Rectangle
Destination rectangle.
alpha
Type: System..::..Int32
Alpha value. 0=completely transparent, 255=original transparency.

See Also

GH_GraphicsUtil Class
RenderFadedImage Overload
Grasshopper.GUI Namespace


RenderHighlightBox Method

[image] [image]

Grasshopper SDK
GH_GraphicsUtil..::..RenderHighlightBox Method
GH_GraphicsUtil Class See Also Send Feedback

Overload List

Name | Description
RenderHighlightBox(Graphics, Rectangle, Int32) | Render a typical blueish highlight rectangle
RenderHighlightBox(Graphics, Rectangle, Int32, Boolean, Boolean) | Render a typical blueish highlight rectangle
RenderHighlightBox(Graphics, Rectangle, Int32, Color, Color) | Render a typical blueish highlight rectangle

See Also

GH_GraphicsUtil Class
GH_GraphicsUtil Members
Grasshopper.GUI Namespace


RenderHighlightBox Method (Graphics, Rectangle, Int32)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..RenderHighlightBox Method (Graphics, Rectangle, Int32)
GH_GraphicsUtil Class See Also Send Feedback
Render a typical blueish highlight rectangle

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void RenderHighlightBox(
    Graphics G,
    Rectangle box,
    int cornerRadius
)
Visual Basic
Public Shared Sub RenderHighlightBox ( _
    G As Graphics, _
    box As Rectangle, _
    cornerRadius As Integer _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to render with.
box
Type: System.Drawing..::..Rectangle
Dimensions of selection box.
cornerRadius
Type: System..::..Int32
Radius (in pixels) of box corners, use zero or less to render crisp rectangles.

See Also

GH_GraphicsUtil Class
RenderHighlightBox Overload
Grasshopper.GUI Namespace


RenderHighlightBox Method (Graphics, Rectangle, Int32, Boolean, Boolean)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..RenderHighlightBox Method (Graphics, Rectangle, Int32, Boolean, Boolean)
GH_GraphicsUtil Class See Also Send Feedback
Render a typical blueish highlight rectangle

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void RenderHighlightBox(
    Graphics G,
    Rectangle box,
    int cornerRadius,
    bool drawFill,
    bool drawEdge
)
Visual Basic
Public Shared Sub RenderHighlightBox ( _
    G As Graphics, _
    box As Rectangle, _
    cornerRadius As Integer, _
    drawFill As Boolean, _
    drawEdge As Boolean _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to render with.
box
Type: System.Drawing..::..Rectangle
Dimensions of selection box.
cornerRadius
Type: System..::..Int32
Radius (in pixels) of box corners, use zero or less to render crisp rectangles.
drawFill
Type: System..::..Boolean
If true, the box fill have a blue background.
drawEdge
Type: System..::..Boolean
If true, the box will have a blue edge.

See Also

GH_GraphicsUtil Class
RenderHighlightBox Overload
Grasshopper.GUI Namespace


RenderHighlightBox Method (Graphics, Rectangle, Int32, Color, Color)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..RenderHighlightBox Method (Graphics, Rectangle, Int32, Color, Color)
GH_GraphicsUtil Class See Also Send Feedback
Render a typical blueish highlight rectangle

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void RenderHighlightBox(
    Graphics G,
    Rectangle box,
    int cornerRadius,
    Color fill,
    Color edge
)
Visual Basic
Public Shared Sub RenderHighlightBox ( _
    G As Graphics, _
    box As Rectangle, _
    cornerRadius As Integer, _
    fill As Color, _
    edge As Color _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to render with.
box
Type: System.Drawing..::..Rectangle
Dimensions of selection box.
cornerRadius
Type: System..::..Int32
Radius (in pixels) of box corners, use zero or less to render crisp rectangles.
fill
Type: System.Drawing..::..Color
Fill colour
edge
Type: System.Drawing..::..Color
Edge colour

See Also

GH_GraphicsUtil Class
RenderHighlightBox Overload
Grasshopper.GUI Namespace


RenderObjectOverlay Method

[image] [image]

Grasshopper SDK
GH_GraphicsUtil..::..RenderObjectOverlay Method
GH_GraphicsUtil Class See Also Send Feedback

Overload List

Name | Description
RenderObjectOverlay(Graphics, IGH_DocumentObject, RectangleF) | Render all overlay icons for a specific object. Overlays aren't drawn when the zoom is less than 80%
RenderObjectOverlay(Graphics, IGH_ObjectProxy, RectangleF) | Render all overlay icons for a specific object. Overlays aren't drawn when the zoom is less than 80%

See Also

GH_GraphicsUtil Class
GH_GraphicsUtil Members
Grasshopper.GUI Namespace


RenderObjectOverlay Method (Graphics, IGH_DocumentObject, RectangleF)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..RenderObjectOverlay Method (Graphics, IGH_DocumentObject, RectangleF)
GH_GraphicsUtil Class See Also Send Feedback
Render all overlay icons for a specific object. Overlays aren't drawn when the zoom is less than 80%

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void RenderObjectOverlay(
    Graphics graphics,
    IGH_DocumentObject obj,
    RectangleF target
)
Visual Basic
Public Shared Sub RenderObjectOverlay ( _
    graphics As Graphics, _
    obj As IGH_DocumentObject, _
    target As RectangleF _
)

Parameters

graphics
Type: System.Drawing..::..Graphics
Graphics object to draw with.
obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject
Object to draw overlay for.
target
Type: System.Drawing..::..RectangleF
Destination area for overlay icons.

See Also

GH_GraphicsUtil Class
RenderObjectOverlay Overload
Grasshopper.GUI Namespace


RenderObjectOverlay Method (Graphics, IGH_ObjectProxy, RectangleF)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..RenderObjectOverlay Method (Graphics, IGH_ObjectProxy, RectangleF)
GH_GraphicsUtil Class See Also Send Feedback
Render all overlay icons for a specific object. Overlays aren't drawn when the zoom is less than 80%

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void RenderObjectOverlay(
    Graphics graphics,
    IGH_ObjectProxy obj,
    RectangleF target
)
Visual Basic
Public Shared Sub RenderObjectOverlay ( _
    graphics As Graphics, _
    obj As IGH_ObjectProxy, _
    target As RectangleF _
)

Parameters

graphics
Type: System.Drawing..::..Graphics
Graphics object to draw with.
obj
Type: Grasshopper.Kernel..::..IGH_ObjectProxy
Proxy to draw overlay for.
target
Type: System.Drawing..::..RectangleF
Destination area for overlay icons.

See Also

GH_GraphicsUtil Class
RenderObjectOverlay Overload
Grasshopper.GUI Namespace


RenderRoundBar Method

[image]

Grasshopper SDK
GH_GraphicsUtil..::..RenderRoundBar Method
GH_GraphicsUtil Class See Also Send Feedback
Render a cylinder shaped object with round caps.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void RenderRoundBar(
    Graphics graphics,
    RectangleF rec,
    Color colour
)
Visual Basic
Public Shared Sub RenderRoundBar ( _
    graphics As Graphics, _
    rec As RectangleF, _
    colour As Color _
)

Parameters

graphics
Type: System.Drawing..::..Graphics
Graphics object to draw with.
rec
Type: System.Drawing..::..RectangleF
Rectangle containing shape.
colour
Type: System.Drawing..::..Color
Fill colour of shape.

See Also

GH_GraphicsUtil Class
Grasshopper.GUI Namespace


RenderTag Method

[image]

Grasshopper SDK
GH_GraphicsUtil..::..RenderTag Method
GH_GraphicsUtil Class Example See Also Send Feedback
Render a text tag into a Graphics surface.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void RenderTag(
    Graphics G,
    string tag,
    Font font,
    Color back_color,
    Color fore_color,
    RectangleF frame,
    StringAlignment align_h,
    StringAlignment align_v
)
Visual Basic
Public Shared Sub RenderTag ( _
    G As Graphics, _
    tag As String, _
    font As Font, _
    back_color As Color, _
    fore_color As Color, _
    frame As RectangleF, _
    align_h As StringAlignment, _
    align_v As StringAlignment _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.
tag
Type: System..::..String
Text to draw.
font
Type: System.Drawing..::..Font
Font to use.
back_color
Type: System.Drawing..::..Color
Tag background colour.
fore_color
Type: System.Drawing..::..Color
Tag foreground colour.
frame
Type: System.Drawing..::..RectangleF
The frame into which the tags should be aligned.
align_h
Type: System.Drawing..::..StringAlignment
Horizontal alignment.
align_v
Type: System.Drawing..::..StringAlignment
Vertical alignment.

Examples

This example shows how to render the 8 corner and edge tags into a rectangle:
CopyVB.NET
Function RenderCornerAndEdgeTags(ByVal G As Graphics, ByVal frame As RectangleF)
  Dim font As New Font("Courier New", 8)
  Dim bg As Color = Color.White
  Dim fg As Color = Color.Black

  'Render the 4 corner tags
  RenderTag(G, "UL", font, bg, fg, frame, StringAlignment.Near, StringAlignment.Near)
  RenderTag(G, "UR", font, bg, fg, frame, StringAlignment.Far, StringAlignment.Near)
  RenderTag(G, "LR", font, bg, fg, frame, StringAlignment.Far, StringAlignment.Far)
  RenderTag(G, "LL", font, bg, fg, frame, StringAlignment.Near, StringAlignment.Far)

  'Render the 4 edge tags
  RenderTag(G, "T", font, bg, fg, frame, StringAlignment.Center, StringAlignment.Near)
  RenderTag(G, "R", font, bg, fg, frame, StringAlignment.Far, StringAlignment.Center)
  RenderTag(G, "B", font, bg, fg, frame, StringAlignment.Center, StringAlignment.Far)
  RenderTag(G, "L", font, bg, fg, frame, StringAlignment.Near, StringAlignment.Center)
End Function

See Also

GH_GraphicsUtil Class
Grasshopper.GUI Namespace


RenderUnscaledIcon Method

[image] [image]

Grasshopper SDK
GH_GraphicsUtil..::..RenderUnscaledIcon Method
GH_GraphicsUtil Class See Also Send Feedback

Overload List

Name | Description
RenderUnscaledIcon(Graphics, Image, Int32, Int32) | Draws an image file at 1:1 scale centered on the given coordinates.
RenderUnscaledIcon(Graphics, Image, Int32, Int32, Double) | Draws an image file at 1:1 scale centered on the given coordinates.

See Also

GH_GraphicsUtil Class
GH_GraphicsUtil Members
Grasshopper.GUI Namespace


RenderUnscaledIcon Method (Graphics, Image, Int32, Int32)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..RenderUnscaledIcon Method (Graphics, Image, Int32, Int32)
GH_GraphicsUtil Class See Also Send Feedback
Draws an image file at 1:1 scale centered on the given coordinates.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void RenderUnscaledIcon(
    Graphics G,
    Image icon,
    int cx,
    int cy
)
Visual Basic
Public Shared Sub RenderUnscaledIcon ( _
    G As Graphics, _
    icon As Image, _
    cx As Integer, _
    cy As Integer _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.
icon
Type: System.Drawing..::..Image
Image to draw.
cx
Type: System..::..Int32
X center of image in Graphics coordinate.
cy
Type: System..::..Int32
Y center of image in Graphics coordinate.

See Also

GH_GraphicsUtil Class
RenderUnscaledIcon Overload
Grasshopper.GUI Namespace


RenderUnscaledIcon Method (Graphics, Image, Int32, Int32, Double)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..RenderUnscaledIcon Method (Graphics, Image, Int32, Int32, Double)
GH_GraphicsUtil Class See Also Send Feedback
Draws an image file at 1:1 scale centered on the given coordinates.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void RenderUnscaledIcon(
    Graphics G,
    Image icon,
    int cx,
    int cy,
    double fade
)
Visual Basic
Public Shared Sub RenderUnscaledIcon ( _
    G As Graphics, _
    icon As Image, _
    cx As Integer, _
    cy As Integer, _
    fade As Double _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.
icon
Type: System.Drawing..::..Image
Image to draw.
cx
Type: System..::..Int32
X center of image in Graphics coordinate.
cy
Type: System..::..Int32
Y center of image in Graphics coordinate.
fade
Type: System..::..Double
Alpha fading factor.

See Also

GH_GraphicsUtil Class
RenderUnscaledIcon Overload
Grasshopper.GUI Namespace


RenderVerticalString Method

[image]

Grasshopper SDK
GH_GraphicsUtil..::..RenderVerticalString Method
GH_GraphicsUtil Class See Also Send Feedback
Render vertical text (rotated 90 degrees counter-clockwise) within a rectangle.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void RenderVerticalString(
    Graphics G,
    string text,
    Font font,
    Color colour,
    RectangleF rec,
    StringFormat format
)
Visual Basic
Public Shared Sub RenderVerticalString ( _
    G As Graphics, _
    text As String, _
    font As Font, _
    colour As Color, _
    rec As RectangleF, _
    format As StringFormat _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.
text
Type: System..::..String
Text to render.
font
Type: System.Drawing..::..Font
Font to render with.
colour
Type: System.Drawing..::..Color
Colour of text content.
rec
Type: System.Drawing..::..RectangleF
format
Type: System.Drawing..::..StringFormat
Formatting flags.

See Also

GH_GraphicsUtil Class
Grasshopper.GUI Namespace


RenderWarningIcon Method

[image]

Grasshopper SDK
GH_GraphicsUtil..::..RenderWarningIcon Method
GH_GraphicsUtil Class See Also Send Feedback
Render a typical warning icon into a graphics context. A warning icon is an upright yellow triangle.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void RenderWarningIcon(
    Graphics graphics,
    PointF center,
    float radius,
    int alpha
)
Visual Basic
Public Shared Sub RenderWarningIcon ( _
    graphics As Graphics, _
    center As PointF, _
    radius As Single, _
    alpha As Integer _
)

Parameters

graphics
Type: System.Drawing..::..Graphics
Graphics object to draw with.
center
Type: System.Drawing..::..PointF
Center of icon.
radius
Type: System..::..Single
Radius of icon.
alpha
Type: System..::..Int32
Transparency of icon.

See Also

GH_GraphicsUtil Class
Grasshopper.GUI Namespace


ScaleColour Method

[image]

Grasshopper SDK
GH_GraphicsUtil..::..ScaleColour Method
GH_GraphicsUtil Class See Also Send Feedback
Multiply the channels of a colour construct with a fixed factor.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Color ScaleColour(
    Color col,
    double factor
)
Visual Basic
Public Shared Function ScaleColour ( _
    col As Color, _
    factor As Double _
) As Color

Parameters

col
Type: System.Drawing..::..Color
The colour to mutate
factor
Type: System..::..Double
An adjustment factor.

Return Value

The scaled colour.

Remarks

The alpha channel of the colour is not mutated.

See Also

GH_GraphicsUtil Class
Grasshopper.GUI Namespace


ShadowHorizontal Method

[image] [image]

Grasshopper SDK
GH_GraphicsUtil..::..ShadowHorizontal Method
GH_GraphicsUtil Class See Also Send Feedback

Overload List

Name | Description
ShadowHorizontal(Graphics, Int32, Int32, Int32, Int32, Boolean, Color) | Draws a horizontal shadow edge.
ShadowHorizontal(Graphics, Int32, Int32, Int32, Int32, Boolean, Int32) | Draws a horizontal shadow edge.
ShadowHorizontal(Graphics, Single, Single, Single, Single, Boolean, Int32) | Draws a horizontal shadow edge.

See Also

GH_GraphicsUtil Class
GH_GraphicsUtil Members
Grasshopper.GUI Namespace


ShadowHorizontal Method (Graphics, Int32, Int32, Int32, Int32, Boolean, Color)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..ShadowHorizontal Method (Graphics, Int32, Int32, Int32, Int32, Boolean, Color)
GH_GraphicsUtil Class See Also Send Feedback
Draws a horizontal shadow edge.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void ShadowHorizontal(
    Graphics G,
    int x0,
    int x1,
    int y,
    int size,
    bool below,
    Color color
)
Visual Basic
Public Shared Sub ShadowHorizontal ( _
    G As Graphics, _
    x0 As Integer, _
    x1 As Integer, _
    y As Integer, _
    size As Integer, _
    below As Boolean, _
    color As Color _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.
x0
Type: System..::..Int32
Start of shadow edge.
x1
Type: System..::..Int32
End of shadow edge.
y
Type: System..::..Int32
Elevation of shadow edge.
size
Type: System..::..Int32
Length of cast shadow.
below
Type: System..::..Boolean
If true, shadow is drawn below elevation line.
color
Type: System.Drawing..::..Color
Colour at shadow edge.

See Also

GH_GraphicsUtil Class
ShadowHorizontal Overload
Grasshopper.GUI Namespace


ShadowHorizontal Method (Graphics, Int32, Int32, Int32, Int32, Boolean, Int32)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..ShadowHorizontal Method (Graphics, Int32, Int32, Int32, Int32, Boolean, Int32)
GH_GraphicsUtil Class See Also Send Feedback
Draws a horizontal shadow edge.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void ShadowHorizontal(
    Graphics G,
    int x0,
    int x1,
    int y,
    int size,
    bool below,
    int darkness
)
Visual Basic
Public Shared Sub ShadowHorizontal ( _
    G As Graphics, _
    x0 As Integer, _
    x1 As Integer, _
    y As Integer, _
    size As Integer, _
    below As Boolean, _
    darkness As Integer _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.
x0
Type: System..::..Int32
Start of shadow edge.
x1
Type: System..::..Int32
End of shadow edge.
y
Type: System..::..Int32
Elevation of shadow edge.
size
Type: System..::..Int32
Length of cast shadow.
below
Type: System..::..Boolean
If true, shadow is drawn below elevation line.
darkness
Type: System..::..Int32
Alpha component of darkness directly underneath the edge.

See Also

GH_GraphicsUtil Class
ShadowHorizontal Overload
Grasshopper.GUI Namespace


ShadowHorizontal Method (Graphics, Single, Single, Single, Single, Boolean, Int32)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..ShadowHorizontal Method (Graphics, Single, Single, Single, Single, Boolean, Int32)
GH_GraphicsUtil Class See Also Send Feedback
Draws a horizontal shadow edge.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void ShadowHorizontal(
    Graphics G,
    float x0,
    float x1,
    float y,
    float size,
    bool below,
    int darkness
)
Visual Basic
Public Shared Sub ShadowHorizontal ( _
    G As Graphics, _
    x0 As Single, _
    x1 As Single, _
    y As Single, _
    size As Single, _
    below As Boolean, _
    darkness As Integer _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.
x0
Type: System..::..Single
Start of shadow edge.
x1
Type: System..::..Single
End of shadow edge.
y
Type: System..::..Single
Elevation of shadow edge.
size
Type: System..::..Single
Length of cast shadow.
below
Type: System..::..Boolean
If true, shadow is drawn below elevation line.
darkness
Type: System..::..Int32
Alpha component of darkness directly underneath the edge.

See Also

GH_GraphicsUtil Class
ShadowHorizontal Overload
Grasshopper.GUI Namespace


ShadowRectangle Method

[image] [image]

Grasshopper SDK
GH_GraphicsUtil..::..ShadowRectangle Method
GH_GraphicsUtil Class See Also Send Feedback

Overload List

Name | Description
ShadowRectangle(Graphics, Rectangle, Int32, Color) | Draws shadow edges on the interior of a rectangle.
ShadowRectangle(Graphics, Rectangle, Int32, Int32) | Draws shadow edges on the interior of a rectangle.

See Also

GH_GraphicsUtil Class
GH_GraphicsUtil Members
Grasshopper.GUI Namespace


ShadowRectangle Method (Graphics, Rectangle, Int32, Color)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..ShadowRectangle Method (Graphics, Rectangle, Int32, Color)
GH_GraphicsUtil Class See Also Send Feedback
Draws shadow edges on the interior of a rectangle.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void ShadowRectangle(
    Graphics G,
    Rectangle rec,
    int size,
    Color color
)
Visual Basic
Public Shared Sub ShadowRectangle ( _
    G As Graphics, _
    rec As Rectangle, _
    size As Integer, _
    color As Color _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.
rec
Type: System.Drawing..::..Rectangle
Bounding rectangle.
size
Type: System..::..Int32
Length of cast shadow.
color
Type: System.Drawing..::..Color
Color at edge of shadow.

See Also

GH_GraphicsUtil Class
ShadowRectangle Overload
Grasshopper.GUI Namespace


ShadowRectangle Method (Graphics, Rectangle, Int32, Int32)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..ShadowRectangle Method (Graphics, Rectangle, Int32, Int32)
GH_GraphicsUtil Class See Also Send Feedback
Draws shadow edges on the interior of a rectangle.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void ShadowRectangle(
    Graphics G,
    Rectangle rec,
    int size,
    int darkness
)
Visual Basic
Public Shared Sub ShadowRectangle ( _
    G As Graphics, _
    rec As Rectangle, _
    size As Integer, _
    darkness As Integer _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.
rec
Type: System.Drawing..::..Rectangle
Bounding rectangle.
size
Type: System..::..Int32
Length of cast shadow.
darkness
Type: System..::..Int32
Alpha component of darkness directly underneath the edge.

See Also

GH_GraphicsUtil Class
ShadowRectangle Overload
Grasshopper.GUI Namespace


ShadowVertical Method

[image] [image]

Grasshopper SDK
GH_GraphicsUtil..::..ShadowVertical Method
GH_GraphicsUtil Class See Also Send Feedback

Overload List

Name | Description
ShadowVertical(Graphics, Int32, Int32, Int32, Int32, Boolean, Color) | Draws a vertical shadow edge.
ShadowVertical(Graphics, Int32, Int32, Int32, Int32, Boolean, Int32) | Draws a vertical shadow edge.
ShadowVertical(Graphics, Single, Single, Single, Single, Boolean, Int32) | Draws a vertical shadow edge.

See Also

GH_GraphicsUtil Class
GH_GraphicsUtil Members
Grasshopper.GUI Namespace


ShadowVertical Method (Graphics, Int32, Int32, Int32, Int32, Boolean, Color)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..ShadowVertical Method (Graphics, Int32, Int32, Int32, Int32, Boolean, Color)
GH_GraphicsUtil Class See Also Send Feedback
Draws a vertical shadow edge.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void ShadowVertical(
    Graphics G,
    int x,
    int y0,
    int y1,
    int size,
    bool right,
    Color color
)
Visual Basic
Public Shared Sub ShadowVertical ( _
    G As Graphics, _
    x As Integer, _
    y0 As Integer, _
    y1 As Integer, _
    size As Integer, _
    right As Boolean, _
    color As Color _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.
x
Type: System..::..Int32
Offset of shadow edge.
y0
Type: System..::..Int32
Start of shadow edge.
y1
Type: System..::..Int32
End of shadow edge.
size
Type: System..::..Int32
Length of cast shadow.
right
Type: System..::..Boolean
If true, shadow is drawn to the right of the elevated line.
color
Type: System.Drawing..::..Color
Color at shadow edge.

See Also

GH_GraphicsUtil Class
ShadowVertical Overload
Grasshopper.GUI Namespace


ShadowVertical Method (Graphics, Int32, Int32, Int32, Int32, Boolean, Int32)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..ShadowVertical Method (Graphics, Int32, Int32, Int32, Int32, Boolean, Int32)
GH_GraphicsUtil Class See Also Send Feedback
Draws a vertical shadow edge.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void ShadowVertical(
    Graphics G,
    int x,
    int y0,
    int y1,
    int size,
    bool right,
    int darkness
)
Visual Basic
Public Shared Sub ShadowVertical ( _
    G As Graphics, _
    x As Integer, _
    y0 As Integer, _
    y1 As Integer, _
    size As Integer, _
    right As Boolean, _
    darkness As Integer _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.
x
Type: System..::..Int32
Offset of shadow edge.
y0
Type: System..::..Int32
Start of shadow edge.
y1
Type: System..::..Int32
End of shadow edge.
size
Type: System..::..Int32
Length of cast shadow.
right
Type: System..::..Boolean
If true, shadow is drawn to the right of the elevated line.
darkness
Type: System..::..Int32
Alpha component of darkness directly underneath the edge.

See Also

GH_GraphicsUtil Class
ShadowVertical Overload
Grasshopper.GUI Namespace


ShadowVertical Method (Graphics, Single, Single, Single, Single, Boolean, Int32)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..ShadowVertical Method (Graphics, Single, Single, Single, Single, Boolean, Int32)
GH_GraphicsUtil Class See Also Send Feedback
Draws a vertical shadow edge.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void ShadowVertical(
    Graphics G,
    float x,
    float y0,
    float y1,
    float size,
    bool right,
    int darkness
)
Visual Basic
Public Shared Sub ShadowVertical ( _
    G As Graphics, _
    x As Single, _
    y0 As Single, _
    y1 As Single, _
    size As Single, _
    right As Boolean, _
    darkness As Integer _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.
x
Type: System..::..Single
Offset of shadow edge.
y0
Type: System..::..Single
Start of shadow edge.
y1
Type: System..::..Single
End of shadow edge.
size
Type: System..::..Single
Length of cast shadow.
right
Type: System..::..Boolean
If true, shadow is drawn to the right of the elevated line.
darkness
Type: System..::..Int32
Alpha component of darkness directly underneath the edge.

See Also

GH_GraphicsUtil Class
ShadowVertical Overload
Grasshopper.GUI Namespace


SolveArc Method

[image] [image]

Grasshopper SDK
GH_GraphicsUtil..::..SolveArc Method
GH_GraphicsUtil Class See Also Send Feedback

Overload List

Name | Description
SolveArc(Point3d, Point3d, Vector3d, RectangleF%, Single%, Single%) | Create a GDI circular arc definition from start-point, end-point and tangent direction.
SolveArc(PointF, PointF, SizeF, RectangleF%, Single%, Single%) | Create a GDI circular arc definition from start-point, end-point and tangent direction.
SolveArc(Double, Double, Double, Double, Double, Double, RectangleF%, Single%, Single%) | Create a GDI circular arc definition from start-point, end-point and tangent direction.

See Also

GH_GraphicsUtil Class
GH_GraphicsUtil Members
Grasshopper.GUI Namespace


SolveArc Method (, , , RectangleF, Single, Single)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..SolveArc Method (, , , RectangleF%, Single%, Single%)
GH_GraphicsUtil Class See Also Send Feedback
Create a GDI circular arc definition from start-point, end-point and tangent direction.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool SolveArc(
    Point3d p0,
    Point3d p1,
    Vector3d dir,
    ref RectangleF box,
    ref float angle,
    ref float sweep
)
Visual Basic
Public Shared Function SolveArc ( _
    p0 As Point3d, _
    p1 As Point3d, _
    dir As Vector3d, _
    ByRef box As RectangleF, _
    ByRef angle As Single, _
    ByRef sweep As Single _
) As Boolean

Parameters

p0
Type: Point3d
Start point of arc.
p1
Type: Point3d
End point of arc.
dir
Type: Vector3d
Tangent direction at start of arc.
box
Type: System.Drawing..::..RectangleF %
Bounding box of arc (out)
angle
Type: System..::..Single %
Start angle of arc (out)
sweep
Type: System..::..Single %
Sweep angle of arc (out)

Return Value

True on success, false on failure.

See Also

GH_GraphicsUtil Class
SolveArc Overload
Grasshopper.GUI Namespace


SolveArc Method (PointF, PointF, SizeF, RectangleF, Single, Single)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..SolveArc Method (PointF, PointF, SizeF, RectangleF%, Single%, Single%)
GH_GraphicsUtil Class See Also Send Feedback
Create a GDI circular arc definition from start-point, end-point and tangent direction.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool SolveArc(
    PointF p0,
    PointF p1,
    SizeF dir,
    ref RectangleF box,
    ref float angle,
    ref float sweep
)
Visual Basic
Public Shared Function SolveArc ( _
    p0 As PointF, _
    p1 As PointF, _
    dir As SizeF, _
    ByRef box As RectangleF, _
    ByRef angle As Single, _
    ByRef sweep As Single _
) As Boolean

Parameters

p0
Type: System.Drawing..::..PointF
Start point of arc.
p1
Type: System.Drawing..::..PointF
End point of arc.
dir
Type: System.Drawing..::..SizeF
Tangent direction at start of arc.
box
Type: System.Drawing..::..RectangleF %
Bounding box of arc (out)
angle
Type: System..::..Single %
Start angle of arc (out)
sweep
Type: System..::..Single %
Sweep angle of arc (out)

Return Value

True on success, false on failure.

See Also

GH_GraphicsUtil Class
SolveArc Overload
Grasshopper.GUI Namespace


SolveArc Method (Double, Double, Double, Double, Double, Double, RectangleF, Single, Single)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..SolveArc Method (Double, Double, Double, Double, Double, Double, RectangleF%, Single%, Single%)
GH_GraphicsUtil Class See Also Send Feedback
Create a GDI circular arc definition from start-point, end-point and tangent direction.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool SolveArc(
    double p0x,
    double p0y,
    double p1x,
    double p1y,
    double dx,
    double dy,
    ref RectangleF box,
    ref float angle,
    ref float sweep
)
Visual Basic
Public Shared Function SolveArc ( _
    p0x As Double, _
    p0y As Double, _
    p1x As Double, _
    p1y As Double, _
    dx As Double, _
    dy As Double, _
    ByRef box As RectangleF, _
    ByRef angle As Single, _
    ByRef sweep As Single _
) As Boolean

Parameters

p0x
Type: System..::..Double
p0y
Type: System..::..Double
p1x
Type: System..::..Double
p1y
Type: System..::..Double
dx
Type: System..::..Double
dy
Type: System..::..Double
box
Type: System.Drawing..::..RectangleF %
angle
Type: System..::..Single %
sweep
Type: System..::..Single %

See Also

GH_GraphicsUtil Class
SolveArc Overload
Grasshopper.GUI Namespace


TransparencyMatrix Method

[image] [image]

Grasshopper SDK
GH_GraphicsUtil..::..TransparencyMatrix Method
GH_GraphicsUtil Class See Also Send Feedback

Overload List

Name | Description
TransparencyMatrix(Double) | Create an image transparency matrix for a specific blending factor.
TransparencyMatrix(Int32) | Create an image transparency matrix for a specific blending factor.

See Also

GH_GraphicsUtil Class
GH_GraphicsUtil Members
Grasshopper.GUI Namespace


TransparencyMatrix Method (Double)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..TransparencyMatrix Method (Double)
GH_GraphicsUtil Class See Also Send Feedback
Create an image transparency matrix for a specific blending factor.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static ColorMatrix TransparencyMatrix(
    double fade
)
Visual Basic
Public Shared Function TransparencyMatrix ( _
    fade As Double _
) As ColorMatrix

Parameters

fade
Type: System..::..Double
Alpha fade amount. 0.0=complete transparency, 1.0=original transparency.

See Also

GH_GraphicsUtil Class
TransparencyMatrix Overload
Grasshopper.GUI Namespace


TransparencyMatrix Method (Int32)

[image]

Grasshopper SDK
GH_GraphicsUtil..::..TransparencyMatrix Method (Int32)
GH_GraphicsUtil Class See Also Send Feedback
Create an image transparency matrix for a specific blending factor.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static ColorMatrix TransparencyMatrix(
    int alpha
)
Visual Basic
Public Shared Function TransparencyMatrix ( _
    alpha As Integer _
) As ColorMatrix

Parameters

alpha
Type: System..::..Int32
Alpha level of color matrix.

See Also

GH_GraphicsUtil Class
TransparencyMatrix Overload
Grasshopper.GUI Namespace


GH_HorizontalSeparator Class

[image]

Grasshopper SDK
GH_HorizontalSeparator Class
Members See Also Send Feedback
GUI elements for creating visual separations.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_HorizontalSeparator : GH_DoubleBufferedPanel
Visual Basic
Public Class GH_HorizontalSeparator _
    Inherits GH_DoubleBufferedPanel

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..Panel
Grasshopper.GUI..::..GH_DoubleBufferedPanel
Grasshopper.GUI..::..GH_HorizontalSeparator

See Also

GH_HorizontalSeparator Members
Grasshopper.GUI Namespace


GH_HorizontalSeparator Members

[image] [image]

Grasshopper SDK
GH_HorizontalSeparator Members
GH_HorizontalSeparator Class Constructors Methods Properties See Also Send Feedback

The GH_HorizontalSeparator type exposes the following members.

Constructors

 | Name | Description
Public method | GH_HorizontalSeparator | Initializes a new instance of the GH_HorizontalSeparator class

Methods

 | Name | Description
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | (Overrides ScrollableControl..::..OnPaintBackground(PaintEventArgs).)

Properties

 | Name | Description
Public property | DisplayMode | Gets or sets the separator display mode.

See Also

GH_HorizontalSeparator Class
Grasshopper.GUI Namespace


GH_HorizontalSeparator Constructor

[image]

Grasshopper SDK
GH_HorizontalSeparator Constructor
GH_HorizontalSeparator Class See Also Send Feedback
Initializes a new instance of the GH_HorizontalSeparator class

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_HorizontalSeparator()
Visual Basic
Public Sub New

See Also

GH_HorizontalSeparator Class
Grasshopper.GUI Namespace


GH_HorizontalSeparator Methods

[image] [image]

Grasshopper SDK
GH_HorizontalSeparator Methods
GH_HorizontalSeparator Class See Also Send Feedback

The GH_HorizontalSeparator type exposes the following members.

Methods

 | Name | Description
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | (Overrides ScrollableControl..::..OnPaintBackground(PaintEventArgs).)

See Also

GH_HorizontalSeparator Class
Grasshopper.GUI Namespace


OnPaint Method

[image]

Grasshopper SDK
GH_HorizontalSeparator..::..OnPaint Method
GH_HorizontalSeparator Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

GH_HorizontalSeparator Class
Grasshopper.GUI Namespace


OnPaintBackground Method

[image]

Grasshopper SDK
GH_HorizontalSeparator..::..OnPaintBackground Method
GH_HorizontalSeparator Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void OnPaintBackground(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaintBackground ( _
    e As PaintEventArgs _
)

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

GH_HorizontalSeparator Class
Grasshopper.GUI Namespace


GH_HorizontalSeparator Properties

[image] [image]

Grasshopper SDK
GH_HorizontalSeparator Properties
GH_HorizontalSeparator Class See Also Send Feedback

The GH_HorizontalSeparator type exposes the following members.

Properties

 | Name | Description
Public property | DisplayMode | Gets or sets the separator display mode.

See Also

GH_HorizontalSeparator Class
Grasshopper.GUI Namespace


DisplayMode Property

[image]

Grasshopper SDK
GH_HorizontalSeparator..::..DisplayMode Property
GH_HorizontalSeparator Class See Also Send Feedback
Gets or sets the separator display mode.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_SeparatorDisplay DisplayMode { get; set; }
Visual Basic
Public Property DisplayMode As GH_SeparatorDisplay
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_HorizontalSeparator.DisplayMode"]

See Also

GH_HorizontalSeparator Class
Grasshopper.GUI Namespace


GH_IconLabel Class

[image]

Grasshopper SDK
GH_IconLabel Class
Members See Also Send Feedback
A simple Icon with an icon overlay plus highlight rectangle.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_IconLabel : Label
Visual Basic
Public Class GH_IconLabel _
    Inherits Label

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..Label
Grasshopper.GUI..::..GH_IconLabel

See Also

GH_IconLabel Members
Grasshopper.GUI Namespace


GH_IconLabel Members

[image] [image]

Grasshopper SDK
GH_IconLabel Members
GH_IconLabel Class Constructors Properties See Also Send Feedback

The GH_IconLabel type exposes the following members.

Constructors

 | Name | Description
Public method | GH_IconLabel | Initializes a new instance of the GH_IconLabel class

Properties

 | Name | Description
Public property | LabelIcon |

See Also

GH_IconLabel Class
Grasshopper.GUI Namespace


GH_IconLabel Constructor

[image]

Grasshopper SDK
GH_IconLabel Constructor
GH_IconLabel Class See Also Send Feedback
Initializes a new instance of the GH_IconLabel class

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_IconLabel()
Visual Basic
Public Sub New

See Also

GH_IconLabel Class
Grasshopper.GUI Namespace


GH_IconLabel Properties

[image] [image]

Grasshopper SDK
GH_IconLabel Properties
GH_IconLabel Class See Also Send Feedback

The GH_IconLabel type exposes the following members.

Properties

 | Name | Description
Public property | LabelIcon |

See Also

GH_IconLabel Class
Grasshopper.GUI Namespace


LabelIcon Property

[image]

Grasshopper SDK
GH_IconLabel..::..LabelIcon Property
GH_IconLabel Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Bitmap LabelIcon { get; set; }
Visual Basic
Public Property LabelIcon As Bitmap
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_IconLabel.LabelIcon"]

See Also

GH_IconLabel Class
Grasshopper.GUI Namespace


GH_IconPicker Class

[image]

Grasshopper SDK
GH_IconPicker Class
Members See Also Send Feedback
Provides a standard icon selection interface.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_IconPicker : UserControl
Visual Basic
Public Class GH_IconPicker _
    Inherits UserControl

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
Grasshopper.GUI..::..GH_IconPicker

See Also

GH_IconPicker Members
Grasshopper.GUI Namespace


GH_IconPicker Members

[image] [image]

Grasshopper SDK
GH_IconPicker Members
GH_IconPicker Class Constructors Methods Properties See Also Send Feedback

The GH_IconPicker type exposes the following members.

Constructors

 | Name | Description
Public method | GH_IconPicker | Initializes a new instance of the GH_IconPicker class

Methods

 | Name | Description
Protected method | Dispose | Releases the unmanaged resources used by the GH_IconPicker and optionally releases the managed resources (Overrides ContainerControl..::..Dispose(Boolean).)

Properties

 | Name | Description
Public property | Icon | Gets or sets the icon to be displayed in this picker.
Public property | IconChanged | Gets a value indicating whether or not the icon has been changed.

See Also

GH_IconPicker Class
Grasshopper.GUI Namespace


GH_IconPicker Constructor

[image]

Grasshopper SDK
GH_IconPicker Constructor
GH_IconPicker Class See Also Send Feedback
Initializes a new instance of the GH_IconPicker class

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_IconPicker()
Visual Basic
Public Sub New

See Also

GH_IconPicker Class
Grasshopper.GUI Namespace


GH_IconPicker Methods

[image] [image]

Grasshopper SDK
GH_IconPicker Methods
GH_IconPicker Class See Also Send Feedback

The GH_IconPicker type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | (Overrides ContainerControl..::..Dispose(Boolean).)

See Also

GH_IconPicker Class
Grasshopper.GUI Namespace


Dispose Method

[image]

Grasshopper SDK
GH_IconPicker..::..Dispose Method
GH_IconPicker Class See Also Send Feedback
Releases the unmanaged resources used by the GH_IconPicker and optionally releases the managed resources

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

GH_IconPicker Class
Grasshopper.GUI Namespace


GH_IconPicker Properties

[image] [image]

Grasshopper SDK
GH_IconPicker Properties
GH_IconPicker Class See Also Send Feedback

The GH_IconPicker type exposes the following members.

Properties

 | Name | Description
Public property | Icon | Gets or sets the icon to be displayed in this picker.
Public property | IconChanged | Gets a value indicating whether or not the icon has been changed.

See Also

GH_IconPicker Class
Grasshopper.GUI Namespace


Icon Property

[image]

Grasshopper SDK
GH_IconPicker..::..Icon Property
GH_IconPicker Class See Also Send Feedback
Gets or sets the icon to be displayed in this picker.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Bitmap Icon { get; set; }
Visual Basic
Public Property Icon As Bitmap
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_IconPicker.Icon"]

See Also

GH_IconPicker Class
Grasshopper.GUI Namespace


IconChanged Property

[image]

Grasshopper SDK
GH_IconPicker..::..IconChanged Property
GH_IconPicker Class See Also Send Feedback
Gets a value indicating whether or not the icon has been changed.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IconChanged { get; }
Visual Basic
Public ReadOnly Property IconChanged As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_IconPicker.IconChanged"]

See Also

GH_IconPicker Class
Grasshopper.GUI Namespace


GH_Interpolation Enumeration

[image]

Grasshopper SDK
GH_Interpolation Enumeration
See Also Send Feedback
Enumerates the possible animation progression types.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_Interpolation
Visual Basic
Public Enumeration GH_Interpolation

Members

Member name | Value | Description
None | 0 | No animation occurs.
NearestNeighbour | 1 | Animation interpolation is either equal to A or B, whichever is closest.
Linear | 2 | Linear interpolation between A and B.
EaseIn | 3 | Interpolation that has a derivative of zero at the start.
EaseOut | 4 | Inteprolation that has a derivative of zero at the end.
EaseInAndOut | 5 | Interpolation that has a derivative of zero at both ends.

See Also

Grasshopper.GUI Namespace


GH_LoadProtectDialog Class

[image]

Grasshopper SDK
GH_LoadProtectDialog Class
Members See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_LoadProtectDialog : Form
Visual Basic
Public Class GH_LoadProtectDialog _
    Inherits Form

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
Grasshopper.GUI..::..GH_LoadProtectDialog

See Also

GH_LoadProtectDialog Members
Grasshopper.GUI Namespace


GH_LoadProtectDialog Members

[image] [image]

Grasshopper SDK
GH_LoadProtectDialog Members
GH_LoadProtectDialog Class Constructors Methods See Also Send Feedback

The GH_LoadProtectDialog type exposes the following members.

Constructors

 | Name | Description
Public method | GH_LoadProtectDialog | Initializes a new instance of the GH_LoadProtectDialog class

Methods

 | Name | Description
Protected method | Dispose | Releases the unmanaged resources used by the GH_LoadProtectDialog and optionally releases the managed resources (Overrides Form..::..Dispose(Boolean).)
Public method | SetAssemblyName |

See Also

GH_LoadProtectDialog Class
Grasshopper.GUI Namespace


GH_LoadProtectDialog Constructor

[image]

Grasshopper SDK
GH_LoadProtectDialog Constructor
GH_LoadProtectDialog Class See Also Send Feedback
Initializes a new instance of the GH_LoadProtectDialog class

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_LoadProtectDialog()
Visual Basic
Public Sub New

See Also

GH_LoadProtectDialog Class
Grasshopper.GUI Namespace


GH_LoadProtectDialog Methods

[image] [image]

Grasshopper SDK
GH_LoadProtectDialog Methods
GH_LoadProtectDialog Class See Also Send Feedback

The GH_LoadProtectDialog type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | (Overrides Form..::..Dispose(Boolean).)
Public method | SetAssemblyName |

See Also

GH_LoadProtectDialog Class
Grasshopper.GUI Namespace


Dispose Method

[image]

Grasshopper SDK
GH_LoadProtectDialog..::..Dispose Method
GH_LoadProtectDialog Class See Also Send Feedback
Releases the unmanaged resources used by the GH_LoadProtectDialog and optionally releases the managed resources

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

GH_LoadProtectDialog Class
Grasshopper.GUI Namespace


SetAssemblyName Method

[image]

Grasshopper SDK
GH_LoadProtectDialog..::..SetAssemblyName Method
GH_LoadProtectDialog Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SetAssemblyName(
    string name
)
Visual Basic
Public Sub SetAssemblyName ( _
    name As String _
)

Parameters

name
Type: System..::..String

See Also

GH_LoadProtectDialog Class
Grasshopper.GUI Namespace


GH_MaterialPreviewControl Class

[image]

Grasshopper SDK
GH_MaterialPreviewControl Class
Members See Also Send Feedback
Offers a frontend for Grasshopper Material previews.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_MaterialPreviewControl : UserControl
Visual Basic
Public Class GH_MaterialPreviewControl _
    Inherits UserControl

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
Grasshopper.GUI..::..GH_MaterialPreviewControl

See Also

GH_MaterialPreviewControl Members
Grasshopper.GUI Namespace


GH_MaterialPreviewControl Members

[image] [image]

Grasshopper SDK
GH_MaterialPreviewControl Members
GH_MaterialPreviewControl Class Constructors Methods Properties Events See Also Send Feedback

The GH_MaterialPreviewControl type exposes the following members.

Constructors

 | Name | Description
Public method | GH_MaterialPreviewControl | Initializes a new instance of the GH_MaterialPreviewControl class

Methods

 | Name | Description
Protected method | Dispose | Releases the unmanaged resources used by the GH_MaterialPreviewControl and optionally releases the managed resources (Overrides ContainerControl..::..Dispose(Boolean).)

Properties

 | Name | Description
Public property | Colour | Gets or sets the colour of this preview.
Public property | Selected | Gets or sets the Selected state of this preview. Selected previews have thick borders drawn around them.
Public property | SelectOnClick | Gets or sets whether this control can be selected.

Events

 | Name | Description
Public event | ColourChanged |
Public event | MaterialImagePostPaint |
Public event | SelectedChanged |

See Also

GH_MaterialPreviewControl Class
Grasshopper.GUI Namespace


GH_MaterialPreviewControl Constructor

[image]

Grasshopper SDK
GH_MaterialPreviewControl Constructor
GH_MaterialPreviewControl Class See Also Send Feedback
Initializes a new instance of the GH_MaterialPreviewControl class

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_MaterialPreviewControl()
Visual Basic
Public Sub New

See Also

GH_MaterialPreviewControl Class
Grasshopper.GUI Namespace


GH_MaterialPreviewControl Methods

[image] [image]

Grasshopper SDK
GH_MaterialPreviewControl Methods
GH_MaterialPreviewControl Class See Also Send Feedback

The GH_MaterialPreviewControl type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | (Overrides ContainerControl..::..Dispose(Boolean).)

See Also

GH_MaterialPreviewControl Class
Grasshopper.GUI Namespace


Dispose Method

[image]

Grasshopper SDK
GH_MaterialPreviewControl..::..Dispose Method
GH_MaterialPreviewControl Class See Also Send Feedback
Releases the unmanaged resources used by the GH_MaterialPreviewControl and optionally releases the managed resources

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

GH_MaterialPreviewControl Class
Grasshopper.GUI Namespace


GH_MaterialPreviewControl Properties

[image] [image]

Grasshopper SDK
GH_MaterialPreviewControl Properties
GH_MaterialPreviewControl Class See Also Send Feedback

The GH_MaterialPreviewControl type exposes the following members.

Properties

 | Name | Description
Public property | Colour | Gets or sets the colour of this preview.
Public property | Selected | Gets or sets the Selected state of this preview. Selected previews have thick borders drawn around them.
Public property | SelectOnClick | Gets or sets whether this control can be selected.

See Also

GH_MaterialPreviewControl Class
Grasshopper.GUI Namespace


Colour Property

[image]

Grasshopper SDK
GH_MaterialPreviewControl..::..Colour Property
GH_MaterialPreviewControl Class See Also Send Feedback
Gets or sets the colour of this preview.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color Colour { get; set; }
Visual Basic
Public Property Colour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_MaterialPreviewControl.Colour"]

See Also

GH_MaterialPreviewControl Class
Grasshopper.GUI Namespace


Selected Property

[image]

Grasshopper SDK
GH_MaterialPreviewControl..::..Selected Property
GH_MaterialPreviewControl Class See Also Send Feedback
Gets or sets the Selected state of this preview. Selected previews have thick borders drawn around them.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Selected { get; set; }
Visual Basic
Public Property Selected As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_MaterialPreviewControl.Selected"]

See Also

GH_MaterialPreviewControl Class
Grasshopper.GUI Namespace


SelectOnClick Property

[image]

Grasshopper SDK
GH_MaterialPreviewControl..::..SelectOnClick Property
GH_MaterialPreviewControl Class See Also Send Feedback
Gets or sets whether this control can be selected.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool SelectOnClick { get; set; }
Visual Basic
Public Property SelectOnClick As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_MaterialPreviewControl.SelectOnClick"]

See Also

GH_MaterialPreviewControl Class
Grasshopper.GUI Namespace


GH_MaterialPreviewControl Events

[image] [image]

Grasshopper SDK
GH_MaterialPreviewControl Events
GH_MaterialPreviewControl Class See Also Send Feedback

The GH_MaterialPreviewControl type exposes the following members.

Events

 | Name | Description
Public event | ColourChanged |
Public event | MaterialImagePostPaint |
Public event | SelectedChanged |

See Also

GH_MaterialPreviewControl Class
Grasshopper.GUI Namespace


ColourChanged Event

[image]

Grasshopper SDK
GH_MaterialPreviewControl..::..ColourChanged Event
GH_MaterialPreviewControl Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_MaterialPreviewControl..::..ColourChangedEventHandler ColourChanged
Visual Basic
Public Event ColourChanged As GH_MaterialPreviewControl..::..ColourChangedEventHandler

See Also

GH_MaterialPreviewControl Class
Grasshopper.GUI Namespace


MaterialImagePostPaint Event

[image]

Grasshopper SDK
GH_MaterialPreviewControl..::..MaterialImagePostPaint Event
GH_MaterialPreviewControl Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_MaterialPreviewControl..::..MaterialImagePostPaintEventHandler MaterialImagePostPaint
Visual Basic
Public Event MaterialImagePostPaint As GH_MaterialPreviewControl..::..MaterialImagePostPaintEventHandler

See Also

GH_MaterialPreviewControl Class
Grasshopper.GUI Namespace


SelectedChanged Event

[image]

Grasshopper SDK
GH_MaterialPreviewControl..::..SelectedChanged Event
GH_MaterialPreviewControl Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_MaterialPreviewControl..::..SelectedChangedEventHandler SelectedChanged
Visual Basic
Public Event SelectedChanged As GH_MaterialPreviewControl..::..SelectedChangedEventHandler

See Also

GH_MaterialPreviewControl Class
Grasshopper.GUI Namespace


GH_MaterialPreviewControl.ColourChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_MaterialPreviewControl..::..ColourChangedEventHandler Delegate
GH_MaterialPreviewControl Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void ColourChangedEventHandler(
    Object sender,
    EventArgs e
)
Visual Basic
Public Delegate Sub ColourChangedEventHandler ( _
    sender As Object, _
    e As EventArgs _
)

Parameters

sender
Type: System..::..Object
e
Type: System..::..EventArgs

See Also

Grasshopper.GUI Namespace


GH_MaterialPreviewControl.MaterialImagePostPaintEventHandler Delegate

[image]

Grasshopper SDK
GH_MaterialPreviewControl..::..MaterialImagePostPaintEventHandler Delegate
GH_MaterialPreviewControl Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void MaterialImagePostPaintEventHandler(
    Bitmap image
)
Visual Basic
Public Delegate Sub MaterialImagePostPaintEventHandler ( _
    image As Bitmap _
)

Parameters

image
Type: System.Drawing..::..Bitmap

See Also

Grasshopper.GUI Namespace


GH_MaterialPreviewControl.SelectedChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_MaterialPreviewControl..::..SelectedChangedEventHandler Delegate
GH_MaterialPreviewControl Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void SelectedChangedEventHandler(
    Object sender,
    EventArgs e
)
Visual Basic
Public Delegate Sub SelectedChangedEventHandler ( _
    sender As Object, _
    e As EventArgs _
)

Parameters

sender
Type: System..::..Object
e
Type: System..::..EventArgs

See Also

Grasshopper.GUI Namespace


GH_MenuTextBox Class

[image]

Grasshopper SDK
GH_MenuTextBox Class
Members See Also Send Feedback
Utility control for putting textboxes into menus.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_MenuTextBox
Visual Basic
Public Class GH_MenuTextBox

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI..::..GH_MenuTextBox

See Also

GH_MenuTextBox Members
Grasshopper.GUI Namespace


GH_MenuTextBox Members

[image] [image]

Grasshopper SDK
GH_MenuTextBox Members
GH_MenuTextBox Class Constructors Methods Properties Events See Also Send Feedback

The GH_MenuTextBox type exposes the following members.

Constructors

 | Name | Description
Public method | GH_MenuTextBox | Constructor for TextBox collection.

Methods

 | Name | Description
Public method | CloseEntireMenuStructure | Call this function to close the ENTIRE menu structure.

Properties

 | Name | Description
Public property | OriginalText | Gets or sets the original text that was visible when the control was first displayed.
Public property | Text | Gets or sets the current text.
Public property | TextBoxItem | Gets the text box control embedded in the menu.
Public property | Width | Gets or sets the width of the control.

Events

 | Name | Description
Public event | KeyDown | Raised whenever a key is pressed.
Public event | TextChanged | Raised whenever the text in the textbox changes.

See Also

GH_MenuTextBox Class
Grasshopper.GUI Namespace


GH_MenuTextBox Constructor

[image]

Grasshopper SDK
GH_MenuTextBox Constructor
GH_MenuTextBox Class See Also Send Feedback
Constructor for TextBox collection.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_MenuTextBox(
    ToolStripDropDown nDropDown,
    string nText,
    bool bLockFocus
)
Visual Basic
Public Sub New ( _
    nDropDown As ToolStripDropDown, _
    nText As String, _
    bLockFocus As Boolean _
)

Parameters

nDropDown
Type: System.Windows.Forms..::..ToolStripDropDown
The menu dropdown into which to embed this textbox control.
nText
Type: System..::..String
The original text to be displayed in the textbox.
bLockFocus
Type: System..::..Boolean
If True, the control will disable the other menu items when it gets focus.

See Also

GH_MenuTextBox Class
Grasshopper.GUI Namespace


GH_MenuTextBox Methods

[image] [image]

Grasshopper SDK
GH_MenuTextBox Methods
GH_MenuTextBox Class See Also Send Feedback

The GH_MenuTextBox type exposes the following members.

Methods

 | Name | Description
Public method | CloseEntireMenuStructure | Call this function to close the ENTIRE menu structure.

See Also

GH_MenuTextBox Class
Grasshopper.GUI Namespace


CloseEntireMenuStructure Method

[image]

Grasshopper SDK
GH_MenuTextBox..::..CloseEntireMenuStructure Method
GH_MenuTextBox Class See Also Send Feedback
Call this function to close the ENTIRE menu structure.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void CloseEntireMenuStructure()
Visual Basic
Public Sub CloseEntireMenuStructure

See Also

GH_MenuTextBox Class
Grasshopper.GUI Namespace


GH_MenuTextBox Properties

[image] [image]

Grasshopper SDK
GH_MenuTextBox Properties
GH_MenuTextBox Class See Also Send Feedback

The GH_MenuTextBox type exposes the following members.

Properties

 | Name | Description
Public property | OriginalText | Gets or sets the original text that was visible when the control was first displayed.
Public property | Text | Gets or sets the current text.
Public property | TextBoxItem | Gets the text box control embedded in the menu.
Public property | Width | Gets or sets the width of the control.

See Also

GH_MenuTextBox Class
Grasshopper.GUI Namespace


OriginalText Property

[image]

Grasshopper SDK
GH_MenuTextBox..::..OriginalText Property
GH_MenuTextBox Class See Also Send Feedback
Gets or sets the original text that was visible when the control was first displayed.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string OriginalText { get; set; }
Visual Basic
Public Property OriginalText As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_MenuTextBox.OriginalText"]

See Also

GH_MenuTextBox Class
Grasshopper.GUI Namespace


Text Property

[image]

Grasshopper SDK
GH_MenuTextBox..::..Text Property
GH_MenuTextBox Class See Also Send Feedback
Gets or sets the current text.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_MenuTextBox.Text"]

See Also

GH_MenuTextBox Class
Grasshopper.GUI Namespace


TextBoxItem Property

[image]

Grasshopper SDK
GH_MenuTextBox..::..TextBoxItem Property
GH_MenuTextBox Class See Also Send Feedback
Gets the text box control embedded in the menu.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public ToolStripTextBox TextBoxItem { get; }
Visual Basic
Public ReadOnly Property TextBoxItem As ToolStripTextBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_MenuTextBox.TextBoxItem"]

See Also

GH_MenuTextBox Class
Grasshopper.GUI Namespace


Width Property

[image]

Grasshopper SDK
GH_MenuTextBox..::..Width Property
GH_MenuTextBox Class See Also Send Feedback
Gets or sets the width of the control.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int Width { get; set; }
Visual Basic
Public Property Width As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_MenuTextBox.Width"]

See Also

GH_MenuTextBox Class
Grasshopper.GUI Namespace


GH_MenuTextBox Events

[image] [image]

Grasshopper SDK
GH_MenuTextBox Events
GH_MenuTextBox Class See Also Send Feedback

The GH_MenuTextBox type exposes the following members.

Events

 | Name | Description
Public event | KeyDown | Raised whenever a key is pressed.
Public event | TextChanged | Raised whenever the text in the textbox changes.

See Also

GH_MenuTextBox Class
Grasshopper.GUI Namespace


KeyDown Event

[image]

Grasshopper SDK
GH_MenuTextBox..::..KeyDown Event
GH_MenuTextBox Class See Also Send Feedback
Raised whenever a key is pressed.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_MenuTextBox..::..KeyDownEventHandler KeyDown
Visual Basic
Public Event KeyDown As GH_MenuTextBox..::..KeyDownEventHandler

See Also

GH_MenuTextBox Class
Grasshopper.GUI Namespace


TextChanged Event

[image]

Grasshopper SDK
GH_MenuTextBox..::..TextChanged Event
GH_MenuTextBox Class See Also Send Feedback
Raised whenever the text in the textbox changes.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_MenuTextBox..::..TextChangedEventHandler TextChanged
Visual Basic
Public Event TextChanged As GH_MenuTextBox..::..TextChangedEventHandler

See Also

GH_MenuTextBox Class
Grasshopper.GUI Namespace


GH_MenuTextBox.KeyDownEventHandler Delegate

[image]

Grasshopper SDK
GH_MenuTextBox..::..KeyDownEventHandler Delegate
GH_MenuTextBox Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void KeyDownEventHandler(
    GH_MenuTextBox sender,
    KeyEventArgs e
)
Visual Basic
Public Delegate Sub KeyDownEventHandler ( _
    sender As GH_MenuTextBox, _
    e As KeyEventArgs _
)

Parameters

sender
Type: Grasshopper.GUI..::..GH_MenuTextBox
e
Type: System.Windows.Forms..::..KeyEventArgs

See Also

Grasshopper.GUI Namespace


GH_MenuTextBox.TextChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_MenuTextBox..::..TextChangedEventHandler Delegate
GH_MenuTextBox Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void TextChangedEventHandler(
    GH_MenuTextBox sender,
    string text
)
Visual Basic
Public Delegate Sub TextChangedEventHandler ( _
    sender As GH_MenuTextBox, _
    text As String _
)

Parameters

sender
Type: Grasshopper.GUI..::..GH_MenuTextBox
text
Type: System..::..String

See Also

Grasshopper.GUI Namespace


GH_MouseTracker Class

[image]

Grasshopper SDK
GH_MouseTracker Class
Members See Also Send Feedback
Record mouse-movements over time.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_MouseTracker
Visual Basic
Public Class GH_MouseTracker

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI..::..GH_MouseTracker

See Also

GH_MouseTracker Members
Grasshopper.GUI Namespace


GH_MouseTracker Members

[image] [image]

Grasshopper SDK
GH_MouseTracker Members
GH_MouseTracker Class Constructors Methods Properties See Also Send Feedback

The GH_MouseTracker type exposes the following members.

Constructors

 | Name | Description
Public method | GH_MouseTracker()()()() | Create a new mouse tracker.
Public method | GH_MouseTracker(Point) | Create a new mouse tracker.
Public method | GH_MouseTracker(Point, Object) | Create a new mouse tracker.

Methods

 | Name | Description
Public method | Deviation()()()() | Gets the maximum deviation of the recorded mouse path. The maximum deviation is the furthest distance the mouse has been from the first point in the history record.
Public method | Deviation(DateTime, DateTime) | Gets the maximum deviation of the recorded mouse path. The maximum deviation is the furthest distance the mouse has been from the first point in the history span. It does not measure the largest deviation between any two points in the time span, only the first and any subsequent point.
Public method | DropFrames(DateTime) | Drop all frames older than a given limit.
Public method | DropFrames(Double) | Find the youngest frame that deviates too much from the current locus and drop it and everything preceding it.
Public method | DropFrames(Double, Point) | Find the youngest frame that deviates too much from the given locus and drop it and everything preceding it.
Public method | LastFrameWithinDeviation | Starting from the youngest frame, finds the oldest frame that is still within a maximum deviation of the youngest frame.
Public method | Record(Point) | Record a new mouse event frame. If this frame is closer than [Accuracy]ms to the previously recorded frame, it is not included.
Public method | Record(Point, Object) | Record a new mouse event frame. If this frame is closer than [Accuracy]ms to the previously recorded frame, it is not included.
Public method | ToString | (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Duration | Gets the timespan that has passed between the oldest and youngest recorded frames. This is not the same as the time that has passed since recording began.
Public property | Frame | Gets the position (in control coordinates) of the frame at the given index.
Public property | FrameCount | Gets the number of recorded frames.
Public property | MaximumDuration | Gets or sets the maximum allowed duration of the entire record. When new frames are recorded, old frames that are more distant than MaximumDuration will be dropped. The default duration is 10 seconds.
Public property | MaximumFrameCount | Gets or sets the maximum number of frames to keep in history. If more frames are added, the oldest ones will be dropped. The default is 16,384 frames.
Public property | NewestFrame | Gets the most recent frame in recorded history.
Public property | OldestFrame | Gets the oldest frame in recorded history.
Public property | TemporalAccuracy | Gets or sets the maximum temporal accuracy. Frames that are closer together than the accuracy will not be recorded. The default accuracy equals 5ms.

See Also

GH_MouseTracker Class
Grasshopper.GUI Namespace


GH_MouseTracker Constructor

[image] [image]

Grasshopper SDK
GH_MouseTracker Constructor
GH_MouseTracker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_MouseTracker()()()() | Create a new mouse tracker.
Public method | GH_MouseTracker(Point) | Create a new mouse tracker.
Public method | GH_MouseTracker(Point, Object) | Create a new mouse tracker.

See Also

GH_MouseTracker Class
GH_MouseTracker Members
Grasshopper.GUI Namespace


GH_MouseTracker Constructor

[image]

Grasshopper SDK
GH_MouseTracker Constructor
GH_MouseTracker Class See Also Send Feedback
Create a new mouse tracker.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_MouseTracker()
Visual Basic
Public Sub New

See Also

GH_MouseTracker Class
GH_MouseTracker Overload
Grasshopper.GUI Namespace


GH_MouseTracker Constructor (Point)

[image]

Grasshopper SDK
GH_MouseTracker Constructor (Point)
GH_MouseTracker Class See Also Send Feedback
Create a new mouse tracker.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_MouseTracker(
    Point initialPosition
)
Visual Basic
Public Sub New ( _
    initialPosition As Point _
)

Parameters

initialPosition
Type: System.Drawing..::..Point
First point in tracker.

See Also

GH_MouseTracker Class
GH_MouseTracker Overload
Grasshopper.GUI Namespace


GH_MouseTracker Constructor (Point, Object)

[image]

Grasshopper SDK
GH_MouseTracker Constructor (Point, Object)
GH_MouseTracker Class See Also Send Feedback
Create a new mouse tracker.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_MouseTracker(
    Point initialPosition,
    Object tag
)
Visual Basic
Public Sub New ( _
    initialPosition As Point, _
    tag As Object _
)

Parameters

initialPosition
Type: System.Drawing..::..Point
First point in tracker.
tag
Type: System..::..Object
First tag in tracker.

See Also

GH_MouseTracker Class
GH_MouseTracker Overload
Grasshopper.GUI Namespace


GH_MouseTracker Methods

[image] [image]

Grasshopper SDK
GH_MouseTracker Methods
GH_MouseTracker Class See Also Send Feedback

The GH_MouseTracker type exposes the following members.

Methods

 | Name | Description
Public method | Deviation()()()() | Gets the maximum deviation of the recorded mouse path. The maximum deviation is the furthest distance the mouse has been from the first point in the history record.
Public method | Deviation(DateTime, DateTime) | Gets the maximum deviation of the recorded mouse path. The maximum deviation is the furthest distance the mouse has been from the first point in the history span. It does not measure the largest deviation between any two points in the time span, only the first and any subsequent point.
Public method | DropFrames(DateTime) | Drop all frames older than a given limit.
Public method | DropFrames(Double) | Find the youngest frame that deviates too much from the current locus and drop it and everything preceding it.
Public method | DropFrames(Double, Point) | Find the youngest frame that deviates too much from the given locus and drop it and everything preceding it.
Public method | LastFrameWithinDeviation | Starting from the youngest frame, finds the oldest frame that is still within a maximum deviation of the youngest frame.
Public method | Record(Point) | Record a new mouse event frame. If this frame is closer than [Accuracy]ms to the previously recorded frame, it is not included.
Public method | Record(Point, Object) | Record a new mouse event frame. If this frame is closer than [Accuracy]ms to the previously recorded frame, it is not included.
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

GH_MouseTracker Class
Grasshopper.GUI Namespace


Deviation Method

[image] [image]

Grasshopper SDK
GH_MouseTracker..::..Deviation Method
GH_MouseTracker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Deviation()()()() | Gets the maximum deviation of the recorded mouse path. The maximum deviation is the furthest distance the mouse has been from the first point in the history record.
Public method | Deviation(DateTime, DateTime) | Gets the maximum deviation of the recorded mouse path. The maximum deviation is the furthest distance the mouse has been from the first point in the history span. It does not measure the largest deviation between any two points in the time span, only the first and any subsequent point.

See Also

GH_MouseTracker Class
GH_MouseTracker Members
Grasshopper.GUI Namespace


Deviation Method

[image]

Grasshopper SDK
GH_MouseTracker..::..Deviation Method
GH_MouseTracker Class See Also Send Feedback
Gets the maximum deviation of the recorded mouse path. The maximum deviation is the furthest distance the mouse has been from the first point in the history record.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double Deviation()
Visual Basic
Public Function Deviation As Double

See Also

GH_MouseTracker Class
Deviation Overload
Grasshopper.GUI Namespace


Deviation Method (DateTime, DateTime)

[image]

Grasshopper SDK
GH_MouseTracker..::..Deviation Method (DateTime, DateTime)
GH_MouseTracker Class See Also Send Feedback
Gets the maximum deviation of the recorded mouse path. The maximum deviation is the furthest distance the mouse has been from the first point in the history span. It does not measure the largest deviation between any two points in the time span, only the first and any subsequent point.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double Deviation(
    DateTime t0,
    DateTime t1
)
Visual Basic
Public Function Deviation ( _
    t0 As DateTime, _
    t1 As DateTime _
) As Double

Parameters

t0
Type: System..::..DateTime
Represents the earliest time to include.
t1
Type: System..::..DateTime
Represents the latest time to include.

See Also

GH_MouseTracker Class
Deviation Overload
Grasshopper.GUI Namespace


DropFrames Method

[image] [image]

Grasshopper SDK
GH_MouseTracker..::..DropFrames Method
GH_MouseTracker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DropFrames(DateTime) | Drop all frames older than a given limit.
Public method | DropFrames(Double) | Find the youngest frame that deviates too much from the current locus and drop it and everything preceding it.
Public method | DropFrames(Double, Point) | Find the youngest frame that deviates too much from the given locus and drop it and everything preceding it.

See Also

GH_MouseTracker Class
GH_MouseTracker Members
Grasshopper.GUI Namespace


DropFrames Method (DateTime)

[image]

Grasshopper SDK
GH_MouseTracker..::..DropFrames Method (DateTime)
GH_MouseTracker Class See Also Send Feedback
Drop all frames older than a given limit.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DropFrames(
    DateTime timeLimit
)
Visual Basic
Public Sub DropFrames ( _
    timeLimit As DateTime _
)

Parameters

timeLimit
Type: System..::..DateTime
All frames older than the limit will be dropped.

See Also

GH_MouseTracker Class
DropFrames Overload
Grasshopper.GUI Namespace


DropFrames Method (Double)

[image]

Grasshopper SDK
GH_MouseTracker..::..DropFrames Method (Double)
GH_MouseTracker Class See Also Send Feedback
Find the youngest frame that deviates too much from the current locus and drop it and everything preceding it.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DropFrames(
    double deviation
)
Visual Basic
Public Sub DropFrames ( _
    deviation As Double _
)

Parameters

deviation
Type: System..::..Double
Local deviation.

See Also

GH_MouseTracker Class
DropFrames Overload
Grasshopper.GUI Namespace


DropFrames Method (Double, Point)

[image]

Grasshopper SDK
GH_MouseTracker..::..DropFrames Method (Double, Point)
GH_MouseTracker Class See Also Send Feedback
Find the youngest frame that deviates too much from the given locus and drop it and everything preceding it.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DropFrames(
    double deviation,
    Point anchor
)
Visual Basic
Public Sub DropFrames ( _
    deviation As Double, _
    anchor As Point _
)

Parameters

deviation
Type: System..::..Double
Local deviation.
anchor
Type: System.Drawing..::..Point

See Also

GH_MouseTracker Class
DropFrames Overload
Grasshopper.GUI Namespace


LastFrameWithinDeviation Method

[image]

Grasshopper SDK
GH_MouseTracker..::..LastFrameWithinDeviation Method
GH_MouseTracker Class See Also Send Feedback
Starting from the youngest frame, finds the oldest frame that is still within a maximum deviation of the youngest frame.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int LastFrameWithinDeviation(
    double deviation
)
Visual Basic
Public Function LastFrameWithinDeviation ( _
    deviation As Double _
) As Integer

Parameters

deviation
Type: System..::..Double
Maximum allowed deviation.

Return Value

The index of the oldest frame with a distance less than the deviation from the youngest frame, or -1 if no such frame could be found.

See Also

GH_MouseTracker Class
Grasshopper.GUI Namespace


Record Method

[image] [image]

Grasshopper SDK
GH_MouseTracker..::..Record Method
GH_MouseTracker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Record(Point) | Record a new mouse event frame. If this frame is closer than [Accuracy]ms to the previously recorded frame, it is not included.
Public method | Record(Point, Object) | Record a new mouse event frame. If this frame is closer than [Accuracy]ms to the previously recorded frame, it is not included.

See Also

GH_MouseTracker Class
GH_MouseTracker Members
Grasshopper.GUI Namespace


Record Method (Point)

[image]

Grasshopper SDK
GH_MouseTracker..::..Record Method (Point)
GH_MouseTracker Class See Also Send Feedback
Record a new mouse event frame. If this frame is closer than [Accuracy]ms to the previously recorded frame, it is not included.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Record(
    Point position
)
Visual Basic
Public Sub Record ( _
    position As Point _
)

Parameters

position
Type: System.Drawing..::..Point
Location of new frame.

See Also

GH_MouseTracker Class
Record Overload
Grasshopper.GUI Namespace


Record Method (Point, Object)

[image]

Grasshopper SDK
GH_MouseTracker..::..Record Method (Point, Object)
GH_MouseTracker Class See Also Send Feedback
Record a new mouse event frame. If this frame is closer than [Accuracy]ms to the previously recorded frame, it is not included.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Record(
    Point position,
    Object tag
)
Visual Basic
Public Sub Record ( _
    position As Point, _
    tag As Object _
)

Parameters

position
Type: System.Drawing..::..Point
Location of new frame.
tag
Type: System..::..Object

See Also

GH_MouseTracker Class
Record Overload
Grasshopper.GUI Namespace


ToString Method

[image]

Grasshopper SDK
GH_MouseTracker..::..ToString Method
GH_MouseTracker Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_MouseTracker Class
Grasshopper.GUI Namespace


GH_MouseTracker Properties

[image] [image]

Grasshopper SDK
GH_MouseTracker Properties
GH_MouseTracker Class See Also Send Feedback

The GH_MouseTracker type exposes the following members.

Properties

 | Name | Description
Public property | Duration | Gets the timespan that has passed between the oldest and youngest recorded frames. This is not the same as the time that has passed since recording began.
Public property | Frame | Gets the position (in control coordinates) of the frame at the given index.
Public property | FrameCount | Gets the number of recorded frames.
Public property | MaximumDuration | Gets or sets the maximum allowed duration of the entire record. When new frames are recorded, old frames that are more distant than MaximumDuration will be dropped. The default duration is 10 seconds.
Public property | MaximumFrameCount | Gets or sets the maximum number of frames to keep in history. If more frames are added, the oldest ones will be dropped. The default is 16,384 frames.
Public property | NewestFrame | Gets the most recent frame in recorded history.
Public property | OldestFrame | Gets the oldest frame in recorded history.
Public property | TemporalAccuracy | Gets or sets the maximum temporal accuracy. Frames that are closer together than the accuracy will not be recorded. The default accuracy equals 5ms.

See Also

GH_MouseTracker Class
Grasshopper.GUI Namespace


Duration Property

[image]

Grasshopper SDK
GH_MouseTracker..::..Duration Property
GH_MouseTracker Class See Also Send Feedback
Gets the timespan that has passed between the oldest and youngest recorded frames. This is not the same as the time that has passed since recording began.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public TimeSpan Duration { get; }
Visual Basic
Public ReadOnly Property Duration As TimeSpan
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_MouseTracker.Duration"]

See Also

GH_MouseTracker Class
Grasshopper.GUI Namespace


Frame Property

[image]

Grasshopper SDK
GH_MouseTracker..::..Frame Property
GH_MouseTracker Class See Also Send Feedback
Gets the position (in control coordinates) of the frame at the given index.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_TrackerFrame this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Frame ( _
    index As Integer _
) As GH_TrackerFrame
    Get

Parameters

index
Type: System..::..Int32

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_MouseTracker.Frame(System.Int32)"]

See Also

GH_MouseTracker Class
Grasshopper.GUI Namespace


FrameCount Property

[image]

Grasshopper SDK
GH_MouseTracker..::..FrameCount Property
GH_MouseTracker Class See Also Send Feedback
Gets the number of recorded frames.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int FrameCount { get; }
Visual Basic
Public ReadOnly Property FrameCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_MouseTracker.FrameCount"]

See Also

GH_MouseTracker Class
Grasshopper.GUI Namespace


MaximumDuration Property

[image]

Grasshopper SDK
GH_MouseTracker..::..MaximumDuration Property
GH_MouseTracker Class See Also Send Feedback
Gets or sets the maximum allowed duration of the entire record. When new frames are recorded, old frames that are more distant than MaximumDuration will be dropped. The default duration is 10 seconds.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public TimeSpan MaximumDuration { get; set; }
Visual Basic
Public Property MaximumDuration As TimeSpan
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_MouseTracker.MaximumDuration"]

See Also

GH_MouseTracker Class
Grasshopper.GUI Namespace


MaximumFrameCount Property

[image]

Grasshopper SDK
GH_MouseTracker..::..MaximumFrameCount Property
GH_MouseTracker Class See Also Send Feedback
Gets or sets the maximum number of frames to keep in history. If more frames are added, the oldest ones will be dropped. The default is 16,384 frames.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int MaximumFrameCount { get; set; }
Visual Basic
Public Property MaximumFrameCount As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_MouseTracker.MaximumFrameCount"]

See Also

GH_MouseTracker Class
Grasshopper.GUI Namespace


NewestFrame Property

[image]

Grasshopper SDK
GH_MouseTracker..::..NewestFrame Property
GH_MouseTracker Class See Also Send Feedback
Gets the most recent frame in recorded history.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_TrackerFrame NewestFrame { get; }
Visual Basic
Public ReadOnly Property NewestFrame As GH_TrackerFrame
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_MouseTracker.NewestFrame"]

See Also

GH_MouseTracker Class
Grasshopper.GUI Namespace


OldestFrame Property

[image]

Grasshopper SDK
GH_MouseTracker..::..OldestFrame Property
GH_MouseTracker Class See Also Send Feedback
Gets the oldest frame in recorded history.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_TrackerFrame OldestFrame { get; }
Visual Basic
Public ReadOnly Property OldestFrame As GH_TrackerFrame
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_MouseTracker.OldestFrame"]

See Also

GH_MouseTracker Class
Grasshopper.GUI Namespace


TemporalAccuracy Property

[image]

Grasshopper SDK
GH_MouseTracker..::..TemporalAccuracy Property
GH_MouseTracker Class See Also Send Feedback
Gets or sets the maximum temporal accuracy. Frames that are closer together than the accuracy will not be recorded. The default accuracy equals 5ms.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public TimeSpan TemporalAccuracy { get; set; }
Visual Basic
Public Property TemporalAccuracy As TimeSpan
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_MouseTracker.TemporalAccuracy"]

See Also

GH_MouseTracker Class
Grasshopper.GUI Namespace


GH_PanelEditorControl Class

[image]

Grasshopper SDK
GH_PanelEditorControl Class
Members See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_PanelEditorControl : UserControl
Visual Basic
Public Class GH_PanelEditorControl _
    Inherits UserControl

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
Grasshopper.GUI..::..GH_PanelEditorControl

See Also

GH_PanelEditorControl Members
Grasshopper.GUI Namespace


GH_PanelEditorControl Members

[image] [image]

Grasshopper SDK
GH_PanelEditorControl Members
GH_PanelEditorControl Class Constructors Methods Properties See Also Send Feedback

The GH_PanelEditorControl type exposes the following members.

Constructors

 | Name | Description
Public method | GH_PanelEditorControl | Initializes a new instance of the GH_PanelEditorControl class

Methods

 | Name | Description
Protected method | Dispose | Releases the unmanaged resources used by the GH_PanelEditorControl and optionally releases the managed resources (Overrides ContainerControl..::..Dispose(Boolean).)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | (Overrides ScrollableControl..::..OnPaintBackground(PaintEventArgs).)
Public method | PickNewFont |

Properties

 | Name | Description
Public property | PanelContent | Gets or sets the panel text on display.
Public property | PanelProperties | Gets or sets the panel properties on display.

See Also

GH_PanelEditorControl Class
Grasshopper.GUI Namespace


GH_PanelEditorControl Constructor

[image]

Grasshopper SDK
GH_PanelEditorControl Constructor
GH_PanelEditorControl Class See Also Send Feedback
Initializes a new instance of the GH_PanelEditorControl class

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PanelEditorControl()
Visual Basic
Public Sub New

See Also

GH_PanelEditorControl Class
Grasshopper.GUI Namespace


GH_PanelEditorControl Methods

[image] [image]

Grasshopper SDK
GH_PanelEditorControl Methods
GH_PanelEditorControl Class See Also Send Feedback

The GH_PanelEditorControl type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | (Overrides ContainerControl..::..Dispose(Boolean).)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | (Overrides ScrollableControl..::..OnPaintBackground(PaintEventArgs).)
Public method | PickNewFont |

See Also

GH_PanelEditorControl Class
Grasshopper.GUI Namespace


Dispose Method

[image]

Grasshopper SDK
GH_PanelEditorControl..::..Dispose Method
GH_PanelEditorControl Class See Also Send Feedback
Releases the unmanaged resources used by the GH_PanelEditorControl and optionally releases the managed resources

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

GH_PanelEditorControl Class
Grasshopper.GUI Namespace


OnPaint Method

[image]

Grasshopper SDK
GH_PanelEditorControl..::..OnPaint Method
GH_PanelEditorControl Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

GH_PanelEditorControl Class
Grasshopper.GUI Namespace


OnPaintBackground Method

[image]

Grasshopper SDK
GH_PanelEditorControl..::..OnPaintBackground Method
GH_PanelEditorControl Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void OnPaintBackground(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaintBackground ( _
    e As PaintEventArgs _
)

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

GH_PanelEditorControl Class
Grasshopper.GUI Namespace


PickNewFont Method

[image]

Grasshopper SDK
GH_PanelEditorControl..::..PickNewFont Method
GH_PanelEditorControl Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void PickNewFont()
Visual Basic
Public Sub PickNewFont

See Also

GH_PanelEditorControl Class
Grasshopper.GUI Namespace


GH_PanelEditorControl Properties

[image] [image]

Grasshopper SDK
GH_PanelEditorControl Properties
GH_PanelEditorControl Class See Also Send Feedback

The GH_PanelEditorControl type exposes the following members.

Properties

 | Name | Description
Public property | PanelContent | Gets or sets the panel text on display.
Public property | PanelProperties | Gets or sets the panel properties on display.

See Also

GH_PanelEditorControl Class
Grasshopper.GUI Namespace


PanelContent Property

[image]

Grasshopper SDK
GH_PanelEditorControl..::..PanelContent Property
GH_PanelEditorControl Class See Also Send Feedback
Gets or sets the panel text on display.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string PanelContent { get; set; }
Visual Basic
Public Property PanelContent As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_PanelEditorControl.PanelContent"]

See Also

GH_PanelEditorControl Class
Grasshopper.GUI Namespace


PanelProperties Property

[image]

Grasshopper SDK
GH_PanelEditorControl..::..PanelProperties Property
GH_PanelEditorControl Class See Also Send Feedback
Gets or sets the panel properties on display.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PanelProperties PanelProperties { get; set; }
Visual Basic
Public Property PanelProperties As GH_PanelProperties
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_PanelEditorControl.PanelProperties"]

See Also

GH_PanelEditorControl Class
Grasshopper.GUI Namespace


GH_QuickImageEditor Class

[image]

Grasshopper SDK
GH_QuickImageEditor Class
Members See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_QuickImageEditor : Form
Visual Basic
Public Class GH_QuickImageEditor _
    Inherits Form

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
Grasshopper.GUI..::..GH_QuickImageEditor

See Also

GH_QuickImageEditor Members
Grasshopper.GUI Namespace


GH_QuickImageEditor Members

[image] [image]

Grasshopper SDK
GH_QuickImageEditor Members
GH_QuickImageEditor Class Constructors Methods Properties See Also Send Feedback

The GH_QuickImageEditor type exposes the following members.

Constructors

 | Name | Description
Public method | GH_QuickImageEditor | Initializes a new instance of the GH_QuickImageEditor class

Methods

 | Name | Description
Protected method | Dispose | Releases the unmanaged resources used by the GH_QuickImageEditor and optionally releases the managed resources (Overrides Form..::..Dispose(Boolean).)

Properties

 | Name | Description
Public property | CanvasImage | Gets or sets the canvas image.
Public property | FrameCrop | Gets or sets the cropping rectangle.
Public property | FrameFocus | Gets or sets the rectangle of the focus frame.
Public property | FrameViewport | Gets or sets the rectangle of the viewport frame.
Public property | ViewportImage | Gets or sets the viewport image.
Public property | ViewportName | Gets or sets the viewport name to include. If the name string is null or empty, the active viewport is used.

See Also

GH_QuickImageEditor Class
Grasshopper.GUI Namespace


GH_QuickImageEditor Constructor

[image]

Grasshopper SDK
GH_QuickImageEditor Constructor
GH_QuickImageEditor Class See Also Send Feedback
Initializes a new instance of the GH_QuickImageEditor class

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_QuickImageEditor()
Visual Basic
Public Sub New

See Also

GH_QuickImageEditor Class
Grasshopper.GUI Namespace


GH_QuickImageEditor Methods

[image] [image]

Grasshopper SDK
GH_QuickImageEditor Methods
GH_QuickImageEditor Class See Also Send Feedback

The GH_QuickImageEditor type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | (Overrides Form..::..Dispose(Boolean).)

See Also

GH_QuickImageEditor Class
Grasshopper.GUI Namespace


Dispose Method

[image]

Grasshopper SDK
GH_QuickImageEditor..::..Dispose Method
GH_QuickImageEditor Class See Also Send Feedback
Releases the unmanaged resources used by the GH_QuickImageEditor and optionally releases the managed resources

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

GH_QuickImageEditor Class
Grasshopper.GUI Namespace


GH_QuickImageEditor Properties

[image] [image]

Grasshopper SDK
GH_QuickImageEditor Properties
GH_QuickImageEditor Class See Also Send Feedback

The GH_QuickImageEditor type exposes the following members.

Properties

 | Name | Description
Public property | CanvasImage | Gets or sets the canvas image.
Public property | FrameCrop | Gets or sets the cropping rectangle.
Public property | FrameFocus | Gets or sets the rectangle of the focus frame.
Public property | FrameViewport | Gets or sets the rectangle of the viewport frame.
Public property | ViewportImage | Gets or sets the viewport image.
Public property | ViewportName | Gets or sets the viewport name to include. If the name string is null or empty, the active viewport is used.

See Also

GH_QuickImageEditor Class
Grasshopper.GUI Namespace


CanvasImage Property

[image]

Grasshopper SDK
GH_QuickImageEditor..::..CanvasImage Property
GH_QuickImageEditor Class See Also Send Feedback
Gets or sets the canvas image.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Bitmap CanvasImage { get; set; }
Visual Basic
Public Property CanvasImage As Bitmap
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_QuickImageEditor.CanvasImage"]

See Also

GH_QuickImageEditor Class
Grasshopper.GUI Namespace


FrameCrop Property

[image]

Grasshopper SDK
GH_QuickImageEditor..::..FrameCrop Property
GH_QuickImageEditor Class See Also Send Feedback
Gets or sets the cropping rectangle.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle FrameCrop { get; set; }
Visual Basic
Public Property FrameCrop As Rectangle
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_QuickImageEditor.FrameCrop"]

See Also

GH_QuickImageEditor Class
Grasshopper.GUI Namespace


FrameFocus Property

[image]

Grasshopper SDK
GH_QuickImageEditor..::..FrameFocus Property
GH_QuickImageEditor Class See Also Send Feedback
Gets or sets the rectangle of the focus frame.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle3d FrameFocus { get; set; }
Visual Basic
Public Property FrameFocus As Rectangle3d
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_QuickImageEditor.FrameFocus"]

See Also

GH_QuickImageEditor Class
Grasshopper.GUI Namespace


FrameViewport Property

[image]

Grasshopper SDK
GH_QuickImageEditor..::..FrameViewport Property
GH_QuickImageEditor Class See Also Send Feedback
Gets or sets the rectangle of the viewport frame.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle3d FrameViewport { get; set; }
Visual Basic
Public Property FrameViewport As Rectangle3d
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_QuickImageEditor.FrameViewport"]

See Also

GH_QuickImageEditor Class
Grasshopper.GUI Namespace


ViewportImage Property

[image]

Grasshopper SDK
GH_QuickImageEditor..::..ViewportImage Property
GH_QuickImageEditor Class See Also Send Feedback
Gets or sets the viewport image.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Bitmap ViewportImage { get; set; }
Visual Basic
Public Property ViewportImage As Bitmap
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_QuickImageEditor.ViewportImage"]

See Also

GH_QuickImageEditor Class
Grasshopper.GUI Namespace


ViewportName Property

[image]

Grasshopper SDK
GH_QuickImageEditor..::..ViewportName Property
GH_QuickImageEditor Class See Also Send Feedback
Gets or sets the viewport name to include. If the name string is null or empty, the active viewport is used.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string ViewportName { get; set; }
Visual Basic
Public Property ViewportName As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_QuickImageEditor.ViewportName"]

See Also

GH_QuickImageEditor Class
Grasshopper.GUI Namespace


GH_RotationalFrame Structure

[image]

Grasshopper SDK
GH_RotationalFrame Structure
Members See Also Send Feedback
Represents a single frame in a rotational tuning history.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public struct GH_RotationalFrame
Visual Basic
Public Structure GH_RotationalFrame

Remarks

See Also

GH_RotationalFrame Members
Grasshopper.GUI Namespace


GH_RotationalFrame Members

[image] [image]

Grasshopper SDK
GH_RotationalFrame Members
GH_RotationalFrame Structure Properties See Also Send Feedback

The GH_RotationalFrame type exposes the following members.

Properties

 | Name | Description
Public property | Angle | Gets or sets the local angle of the rotation event.
Public property | Pivot | Gets or sets the pivot of the event.
Public property | Point | Gets or sets the location of the rotation event.
Public property | Time | Gets or sets the time when the event was recorded.

See Also

GH_RotationalFrame Structure
Grasshopper.GUI Namespace


GH_RotationalFrame Properties

[image] [image]

Grasshopper SDK
GH_RotationalFrame Properties
GH_RotationalFrame Structure See Also Send Feedback

The GH_RotationalFrame type exposes the following members.

Properties

 | Name | Description
Public property | Angle | Gets or sets the local angle of the rotation event.
Public property | Pivot | Gets or sets the pivot of the event.
Public property | Point | Gets or sets the location of the rotation event.
Public property | Time | Gets or sets the time when the event was recorded.

See Also

GH_RotationalFrame Structure
Grasshopper.GUI Namespace


Angle Property

[image]

Grasshopper SDK
GH_RotationalFrame..::..Angle Property
GH_RotationalFrame Structure See Also Send Feedback
Gets or sets the local angle of the rotation event.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double Angle { get; set; }
Visual Basic
Public Property Angle As Double
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_RotationalFrame.Angle"]

See Also

GH_RotationalFrame Structure
Grasshopper.GUI Namespace


Pivot Property

[image]

Grasshopper SDK
GH_RotationalFrame..::..Pivot Property
GH_RotationalFrame Structure See Also Send Feedback
Gets or sets the pivot of the event.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public PointF Pivot { get; set; }
Visual Basic
Public Property Pivot As PointF
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_RotationalFrame.Pivot"]

See Also

GH_RotationalFrame Structure
Grasshopper.GUI Namespace


Point Property

[image]

Grasshopper SDK
GH_RotationalFrame..::..Point Property
GH_RotationalFrame Structure See Also Send Feedback
Gets or sets the location of the rotation event.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public PointF Point { get; set; }
Visual Basic
Public Property Point As PointF
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_RotationalFrame.Point"]

See Also

GH_RotationalFrame Structure
Grasshopper.GUI Namespace


Time Property

[image]

Grasshopper SDK
GH_RotationalFrame..::..Time Property
GH_RotationalFrame Structure See Also Send Feedback
Gets or sets the time when the event was recorded.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public DateTime Time { get; set; }
Visual Basic
Public Property Time As DateTime
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_RotationalFrame.Time"]

See Also

GH_RotationalFrame Structure
Grasshopper.GUI Namespace


GH_RotationalTuningData(T) Class

[image]

Grasshopper SDK
GH_RotationalTuningData<(Of <(<'T>)>)> Class
Members See Also Send Feedback
Utility class for keeping track of rotational mouse events.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_RotationalTuningData<T>
Visual Basic
Public Class GH_RotationalTuningData(Of T)

Type Parameters

T
Basic type for initial conditions.

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI..::..GH_RotationalTuningData<(Of <(<'T>)>)>

See Also

GH_RotationalTuningData<(Of <(<'T>)>)> Members
Grasshopper.GUI Namespace


GH_RotationalTuningData(T) Members

[image] [image]

Grasshopper SDK
GH_RotationalTuningData<(Of <(<'T>)>)> Members
GH_RotationalTuningData<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The GH_RotationalTuningData<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | GH_RotationalTuningData<(Of <(<'T>)>)>(T, PointF) | Create a new instance of the rotational tuning data.
Public method | GH_RotationalTuningData<(Of <(<'T>)>)>(T, PointF, PointF) | Create a new instance of the rotational tuning data.

Methods

 | Name | Description
Public method | AddFrame | Grow the tuning track by one point and compute the angle.
Public method | TotalAngle | Compute the total angle from the first to the last frame.
Public method | TotalTurns | Compute the total number of full turns from the first to the last frame.

Properties

 | Name | Description
Public property | Frame | Gets the frame at the given index.
Public property | FrameCount | Gets the total number of recorded frames.
Public property | InitialValue | Gets the initial value.
Public property | Pivot | Gets or sets the rotational pivot. You only need to set this if the pivot changes.

See Also

GH_RotationalTuningData<(Of <(<'T>)>)> Class
Grasshopper.GUI Namespace


GH_RotationalTuningData(T) Constructor

[image] [image]

Grasshopper SDK
GH_RotationalTuningData<(Of <(<'T>)>)> Constructor
GH_RotationalTuningData<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_RotationalTuningData<(Of <(<'T>)>)>(T, PointF) | Create a new instance of the rotational tuning data.
Public method | GH_RotationalTuningData<(Of <(<'T>)>)>(T, PointF, PointF) | Create a new instance of the rotational tuning data.

See Also

GH_RotationalTuningData<(Of <(<'T>)>)> Class
GH_RotationalTuningData<(Of <(<'T>)>)> Members
Grasshopper.GUI Namespace


GH_RotationalTuningData(T) Constructor (T, PointF)

[image]

Grasshopper SDK
GH_RotationalTuningData<(Of <(<'T>)>)> Constructor (T, PointF)
GH_RotationalTuningData<(Of <(<'T>)>)> Class See Also Send Feedback
Create a new instance of the rotational tuning data.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_RotationalTuningData(
    T initialValue,
    PointF pivot
)
Visual Basic
Public Sub New ( _
    initialValue As T, _
    pivot As PointF _
)

Parameters

initialValue
Type: T
Initial value to store. Whatever you want it to be.
pivot
Type: System.Drawing..::..PointF
Center of rotation.

See Also

GH_RotationalTuningData<(Of <(<'T>)>)> Class
GH_RotationalTuningData<(Of <(<'T>)>)> Overload
Grasshopper.GUI Namespace


GH_RotationalTuningData(T) Constructor (T, PointF, PointF)

[image]

Grasshopper SDK
GH_RotationalTuningData<(Of <(<'T>)>)> Constructor (T, PointF, PointF)
GH_RotationalTuningData<(Of <(<'T>)>)> Class See Also Send Feedback
Create a new instance of the rotational tuning data.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_RotationalTuningData(
    T initialValue,
    PointF pivot,
    PointF initialPoint
)
Visual Basic
Public Sub New ( _
    initialValue As T, _
    pivot As PointF, _
    initialPoint As PointF _
)

Parameters

initialValue
Type: T
Initial value to store. Whatever you want it to be.
pivot
Type: System.Drawing..::..PointF
Center of rotation.
initialPoint
Type: System.Drawing..::..PointF
First point of track.

See Also

GH_RotationalTuningData<(Of <(<'T>)>)> Class
GH_RotationalTuningData<(Of <(<'T>)>)> Overload
Grasshopper.GUI Namespace


GH_RotationalTuningData(T) Methods

[image] [image]

Grasshopper SDK
GH_RotationalTuningData<(Of <(<'T>)>)> Methods
GH_RotationalTuningData<(Of <(<'T>)>)> Class See Also Send Feedback

The GH_RotationalTuningData<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | AddFrame | Grow the tuning track by one point and compute the angle.
Public method | TotalAngle | Compute the total angle from the first to the last frame.
Public method | TotalTurns | Compute the total number of full turns from the first to the last frame.

See Also

GH_RotationalTuningData<(Of <(<'T>)>)> Class
Grasshopper.GUI Namespace


AddFrame Method

[image]

Grasshopper SDK
GH_RotationalTuningData<(Of <(<'T>)>)>..::..AddFrame Method
GH_RotationalTuningData<(Of <(<'T>)>)> Class See Also Send Feedback
Grow the tuning track by one point and compute the angle.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddFrame(
    PointF point
)
Visual Basic
Public Sub AddFrame ( _
    point As PointF _
)

Parameters

point
Type: System.Drawing..::..PointF
Point (in canvas coordinates) to record.

See Also

GH_RotationalTuningData<(Of <(<'T>)>)> Class
Grasshopper.GUI Namespace


TotalAngle Method

[image]

Grasshopper SDK
GH_RotationalTuningData<(Of <(<'T>)>)>..::..TotalAngle Method
GH_RotationalTuningData<(Of <(<'T>)>)> Class See Also Send Feedback
Compute the total angle from the first to the last frame.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double TotalAngle()
Visual Basic
Public Function TotalAngle As Double

See Also

GH_RotationalTuningData<(Of <(<'T>)>)> Class
Grasshopper.GUI Namespace


TotalTurns Method

[image]

Grasshopper SDK
GH_RotationalTuningData<(Of <(<'T>)>)>..::..TotalTurns Method
GH_RotationalTuningData<(Of <(<'T>)>)> Class See Also Send Feedback
Compute the total number of full turns from the first to the last frame.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double TotalTurns()
Visual Basic
Public Function TotalTurns As Double

See Also

GH_RotationalTuningData<(Of <(<'T>)>)> Class
Grasshopper.GUI Namespace


GH_RotationalTuningData(T) Properties

[image] [image]

Grasshopper SDK
GH_RotationalTuningData<(Of <(<'T>)>)> Properties
GH_RotationalTuningData<(Of <(<'T>)>)> Class See Also Send Feedback

The GH_RotationalTuningData<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Frame | Gets the frame at the given index.
Public property | FrameCount | Gets the total number of recorded frames.
Public property | InitialValue | Gets the initial value.
Public property | Pivot | Gets or sets the rotational pivot. You only need to set this if the pivot changes.

See Also

GH_RotationalTuningData<(Of <(<'T>)>)> Class
Grasshopper.GUI Namespace


Frame Property

[image]

Grasshopper SDK
GH_RotationalTuningData<(Of <(<'T>)>)>..::..Frame Property
GH_RotationalTuningData<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the frame at the given index.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_RotationalFrame this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Frame ( _
    index As Integer _
) As GH_RotationalFrame
    Get

Parameters

index
Type: System..::..Int32
Index of frame.

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_RotationalTuningData`1.Frame(System.Int32)"]

See Also

GH_RotationalTuningData<(Of <(<'T>)>)> Class
Grasshopper.GUI Namespace


FrameCount Property

[image]

Grasshopper SDK
GH_RotationalTuningData<(Of <(<'T>)>)>..::..FrameCount Property
GH_RotationalTuningData<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the total number of recorded frames.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int FrameCount { get; }
Visual Basic
Public ReadOnly Property FrameCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_RotationalTuningData`1.FrameCount"]

See Also

GH_RotationalTuningData<(Of <(<'T>)>)> Class
Grasshopper.GUI Namespace


InitialValue Property

[image]

Grasshopper SDK
GH_RotationalTuningData<(Of <(<'T>)>)>..::..InitialValue Property
GH_RotationalTuningData<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the initial value.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public T InitialValue { get; }
Visual Basic
Public ReadOnly Property InitialValue As T
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_RotationalTuningData`1.InitialValue"]

See Also

GH_RotationalTuningData<(Of <(<'T>)>)> Class
Grasshopper.GUI Namespace


Pivot Property

[image]

Grasshopper SDK
GH_RotationalTuningData<(Of <(<'T>)>)>..::..Pivot Property
GH_RotationalTuningData<(Of <(<'T>)>)> Class See Also Send Feedback
Gets or sets the rotational pivot. You only need to set this if the pivot changes.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public PointF Pivot { get; set; }
Visual Basic
Public Property Pivot As PointF
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_RotationalTuningData`1.Pivot"]

See Also

GH_RotationalTuningData<(Of <(<'T>)>)> Class
Grasshopper.GUI Namespace


GH_SamplingSphere Class

[image]

Grasshopper SDK
GH_SamplingSphere Class
Members See Also Send Feedback
Represents a coloured sphere that can be sampled at various rotations.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_SamplingSphere
Visual Basic
Public Class GH_SamplingSphere

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI..::..GH_SamplingSphere

See Also

GH_SamplingSphere Members
Grasshopper.GUI Namespace


GH_SamplingSphere Members

[image] [image]

Grasshopper SDK
GH_SamplingSphere Members
GH_SamplingSphere Class Constructors Methods Properties See Also Send Feedback

The GH_SamplingSphere type exposes the following members.

Constructors

 | Name | Description
Public method | GH_SamplingSphere | Initializes a new instance of the GH_SamplingSphere class

Methods

 | Name | Description
Public method | SampleSphere(Sphere) | Sample the UV locations of a sphere. The sphere should be centered on the world origin.
Public method | SampleSphere(Sphere, GH_MemoryBitmap) | Sample a sphere with a UV texture and return a bitmap of sampled values.

Properties

 | Name | Description
Public property | SampleCount | Gets the total number of samples contained in this sampling grid.
Public property | Size | Gets the size of this sample grid.

See Also

GH_SamplingSphere Class
Grasshopper.GUI Namespace


GH_SamplingSphere Constructor

[image]

Grasshopper SDK
GH_SamplingSphere Constructor
GH_SamplingSphere Class See Also Send Feedback
Initializes a new instance of the GH_SamplingSphere class

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_SamplingSphere(
    int size
)
Visual Basic
Public Sub New ( _
    size As Integer _
)

Parameters

size
Type: System..::..Int32

See Also

GH_SamplingSphere Class
Grasshopper.GUI Namespace


GH_SamplingSphere Methods

[image] [image]

Grasshopper SDK
GH_SamplingSphere Methods
GH_SamplingSphere Class See Also Send Feedback

Methods

 | Name | Description
Public method | SampleSphere(Sphere) | Sample the UV locations of a sphere. The sphere should be centered on the world origin.
Public method | SampleSphere(Sphere, GH_MemoryBitmap) | Sample a sphere with a UV texture and return a bitmap of sampled values.

See Also

GH_SamplingSphere Class
Grasshopper.GUI Namespace


SampleSphere Method

[image] [image]

Grasshopper SDK
GH_SamplingSphere..::..SampleSphere Method
GH_SamplingSphere Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SampleSphere(Sphere) | Sample the UV locations of a sphere. The sphere should be centered on the world origin.
Public method | SampleSphere(Sphere, GH_MemoryBitmap) | Sample a sphere with a UV texture and return a bitmap of sampled values.

See Also

GH_SamplingSphere Class
GH_SamplingSphere Members
Grasshopper.GUI Namespace


SampleSphere Method ()

[image]

Grasshopper SDK
GH_SamplingSphere..::..SampleSphere Method ()
GH_SamplingSphere Class See Also Send Feedback
Sample the UV locations of a sphere. The sphere should be centered on the world origin.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Point2d[,] SampleSphere(
    Sphere sphere
)
Visual Basic
Public Function SampleSphere ( _
    sphere As Sphere _
) As Point2d(,)

Parameters

sphere
Type: Sphere
Sphere to sample.

Return Value

A two-dimensional array of Sphere UV locations, one for each sample point.

See Also

GH_SamplingSphere Class
SampleSphere Overload
Grasshopper.GUI Namespace


SampleSphere Method (, GH_MemoryBitmap)

[image]

Grasshopper SDK
GH_SamplingSphere..::..SampleSphere Method (, GH_MemoryBitmap)
GH_SamplingSphere Class See Also Send Feedback
Sample a sphere with a UV texture and return a bitmap of sampled values.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Bitmap SampleSphere(
    Sphere sphere,
    GH_MemoryBitmap texture
)
Visual Basic
Public Function SampleSphere ( _
    sphere As Sphere, _
    texture As GH_MemoryBitmap _
) As Bitmap

Parameters

sphere
Type: Sphere
Sphere to sample, it should be centered on the world origin.
texture
Type: Grasshopper.Kernel..::..GH_MemoryBitmap
Texture to sample, the texture will not be modified.

Return Value

A bitmap of Size x Size pixels.

See Also

GH_SamplingSphere Class
SampleSphere Overload
Grasshopper.GUI Namespace


GH_SamplingSphere Properties

[image] [image]

Grasshopper SDK
GH_SamplingSphere Properties
GH_SamplingSphere Class See Also Send Feedback

The GH_SamplingSphere type exposes the following members.

Properties

 | Name | Description
Public property | SampleCount | Gets the total number of samples contained in this sampling grid.
Public property | Size | Gets the size of this sample grid.

See Also

GH_SamplingSphere Class
Grasshopper.GUI Namespace


SampleCount Property

[image]

Grasshopper SDK
GH_SamplingSphere..::..SampleCount Property
GH_SamplingSphere Class See Also Send Feedback
Gets the total number of samples contained in this sampling grid.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int SampleCount { get; }
Visual Basic
Public ReadOnly Property SampleCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_SamplingSphere.SampleCount"]

See Also

GH_SamplingSphere Class
Grasshopper.GUI Namespace


Size Property

[image]

Grasshopper SDK
GH_SamplingSphere..::..Size Property
GH_SamplingSphere Class See Also Send Feedback
Gets the size of this sample grid.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int Size { get; }
Visual Basic
Public ReadOnly Property Size As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_SamplingSphere.Size"]

See Also

GH_SamplingSphere Class
Grasshopper.GUI Namespace


GH_SeparatorDisplay Enumeration

[image]

Grasshopper SDK
GH_SeparatorDisplay Enumeration
See Also Send Feedback
Enumerates all possible display modes for horizontal and vertical separators.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_SeparatorDisplay
Visual Basic
Public Enumeration GH_SeparatorDisplay

Members

Member name | Value | Description
None | 0 | No separator is drawn.
Etched | 1 | A double line etched separator is drawn.
EtchedFading | 2 | A double line etched separator with fading extremes is drawn.
Dashed | 3 | A single line dashed separator is drawn.

See Also

Grasshopper.GUI Namespace


GH_SettingsCategory Class

[image]

Grasshopper SDK
GH_SettingsCategory Class
Members See Also Send Feedback
Base implementation of IGH_SettingsCategory. Derive from this class and provide an empty constructor to play ball.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract class GH_SettingsCategory : IGH_SettingCategory
Visual Basic
Public MustInherit Class GH_SettingsCategory _
    Implements IGH_SettingCategory

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI..::..GH_SettingsCategory

See Also

GH_SettingsCategory Members
Grasshopper.GUI Namespace


GH_SettingsCategory Members

[image] [image]

Grasshopper SDK
GH_SettingsCategory Members
GH_SettingsCategory Class Constructors Properties See Also Send Feedback

The GH_SettingsCategory type exposes the following members.

Constructors

 | Name | Description
Protected method | GH_SettingsCategory(String, Bitmap) | Create a new top-level category.
Protected method | GH_SettingsCategory(String, String, Bitmap) | Create a new nested category.

Properties

 | Name | Description
Public property | Description |
Public property | Icon |
Public property | Name |
Public property | Parent |

See Also

GH_SettingsCategory Class
Grasshopper.GUI Namespace


GH_SettingsCategory Constructor

[image] [image]

Grasshopper SDK
GH_SettingsCategory Constructor
GH_SettingsCategory Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GH_SettingsCategory(String, Bitmap) | Create a new top-level category.
Protected method | GH_SettingsCategory(String, String, Bitmap) | Create a new nested category.

See Also

GH_SettingsCategory Class
GH_SettingsCategory Members
Grasshopper.GUI Namespace


GH_SettingsCategory Constructor (String, Bitmap)

[image]

Grasshopper SDK
GH_SettingsCategory Constructor (String, Bitmap)
GH_SettingsCategory Class See Also Send Feedback
Create a new top-level category.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_SettingsCategory(
    string name,
    Bitmap icon
)
Visual Basic
Protected Sub New ( _
    name As String, _
    icon As Bitmap _
)

Parameters

name
Type: System..::..String
Category name, keep it short.
icon
Type: System.Drawing..::..Bitmap
Category icon. If you supply an icon, it must be 48x48 pixels. If you supply a null instance, a generic Settings icon will be assigned.

See Also

GH_SettingsCategory Class
GH_SettingsCategory Overload
Grasshopper.GUI Namespace


GH_SettingsCategory Constructor (String, String, Bitmap)

[image]

Grasshopper SDK
GH_SettingsCategory Constructor (String, String, Bitmap)
GH_SettingsCategory Class See Also Send Feedback
Create a new nested category.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_SettingsCategory(
    string name,
    string parent,
    Bitmap icon
)
Visual Basic
Protected Sub New ( _
    name As String, _
    parent As String, _
    icon As Bitmap _
)

Parameters

name
Type: System..::..String
Category name, keep it short.
parent
Type: System..::..String
Name of parent category. If the parent category hasn't been defined, the category will be placed under a "Misc" category.
icon
Type: System.Drawing..::..Bitmap
Category icon. If you supply an icon, it must be 48x48 pixels. If you supply a null instance, a generic Settings icon will be assigned.

See Also

GH_SettingsCategory Class
GH_SettingsCategory Overload
Grasshopper.GUI Namespace


GH_SettingsCategory Properties

[image] [image]

Grasshopper SDK
GH_SettingsCategory Properties
GH_SettingsCategory Class See Also Send Feedback

The GH_SettingsCategory type exposes the following members.

Properties

 | Name | Description
Public property | Description |
Public property | Icon |
Public property | Name |
Public property | Parent |

See Also

GH_SettingsCategory Class
Grasshopper.GUI Namespace


Description Property

[image]

Grasshopper SDK
GH_SettingsCategory..::..Description Property
GH_SettingsCategory Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual string Description { get; }
Visual Basic
Public Overridable ReadOnly Property Description As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_SettingsCategory.Description"]

Implements

IGH_SettingCategory..::..Description

See Also

GH_SettingsCategory Class
Grasshopper.GUI Namespace


Icon Property

[image]

Grasshopper SDK
GH_SettingsCategory..::..Icon Property
GH_SettingsCategory Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Bitmap Icon { get; }
Visual Basic
Public ReadOnly Property Icon As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_SettingsCategory.Icon"]

Implements

IGH_SettingCategory..::..Icon

See Also

GH_SettingsCategory Class
Grasshopper.GUI Namespace


Name Property

[image]

Grasshopper SDK
GH_SettingsCategory..::..Name Property
GH_SettingsCategory Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_SettingsCategory.Name"]

Implements

IGH_SettingCategory..::..Name

See Also

GH_SettingsCategory Class
Grasshopper.GUI Namespace


Parent Property

[image]

Grasshopper SDK
GH_SettingsCategory..::..Parent Property
GH_SettingsCategory Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Parent { get; }
Visual Basic
Public ReadOnly Property Parent As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_SettingsCategory.Parent"]

Implements

IGH_SettingCategory..::..Parent

See Also

GH_SettingsCategory Class
Grasshopper.GUI Namespace


GH_Slider Class

[image]

Grasshopper SDK
GH_Slider Class
Members See Also Send Feedback
Provides a standard Grasshopper slider as a winforms control.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Slider : GH_TextInputBaseControl
Visual Basic
Public Class GH_Slider _
    Inherits GH_TextInputBaseControl

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
GH_TextInputBaseControl
Grasshopper.GUI..::..GH_Slider

See Also

GH_Slider Members
Grasshopper.GUI Namespace


GH_Slider Members

[image] [image]

Grasshopper SDK
GH_Slider Members
GH_Slider Class Constructors Methods Properties Events See Also Send Feedback

The GH_Slider type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Slider | Initializes a new instance of the GH_Slider class

Methods

 | Name | Description
Protected method | Input_Assign | (Overrides GH_TextInputBaseControlInput_Assign(String).)
Protected method | Input_Parse | (Overrides GH_TextInputBaseControlInput_Parse(String).)
Protected method | Input_Supply | (Overrides GH_TextInputBaseControlInput_Supply()()()().)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | (Overrides ScrollableControl..::..OnPaintBackground(PaintEventArgs).)

Properties

 | Name | Description
Public property | ControlEdgeColour | Gets or sets the EdgeColor for this slider control.
Public property | ControlShadowColour | Gets or sets the Shadow colour for this control.
Public property | DecimalPlaces | Gets or sets the number of decimal places allowed for Floating Point Sliders.
Public property | DrawControlBorder | Gets or sets whether the border of the slider should be drawn.
Public property | DrawControlShadows | Gets or sets whether the drop shadows of the slider should be drawn.
Public property | FormatMask | Gets or sets the string format mask to use for the display. Should contain at least one "{0}" element.
Public property | GripBottomColour | Gets or sets the fill colour for the bottom edge of the slider grip.
Public property | GripDisplay | Gets or sets how the slider grip (or thumb) is drawn.
Public property | GripEdgeColour | Gets or sets the edge colour for the slider grip.
Public property | GripTopColour | Gets or sets the fill colour for the top edge of the slider grip.
Public property | InternalSlider | Gets the internal slider.
Public property | Maximum | Gets or sets the upper numeric limit for the slider range.
Public property | Minimum | Gets or sets the lower numeric limit for the slider range.
Public property | RailBrightColour | Gets or sets the edge colour for the bright parts of the rail.
Public property | RailDarkColour | Gets or sets the edge colour for the dark parts of the rail.
Public property | RailDisplay | Gets or sets how the slider rail (or track) is drawn.
Public property | RailEmptyColour | Gets or sets the fill colour for the empty portion of the rail.
Public property | RailFullColour | Gets or sets the fill colour for the full portion of the rail.
Public property | ShadowSize | Gets or sets the size of the border shadow along all edges of the box.
Public property | TextColour | Gets or sets the fill colour for the slider text.
Public property | TickCount | Gets or sets the number of ticks.
Public property | TickDisplay | Gets or sets how the slider ticks are drawn.
Public property | TickFrequency | Gets or sets the frequency of large ticks vs small ticks.
Public property | Type | Gets or sets the numeric type of this slider.
Public property | Value | Gets or sets the numeric value for the slider range.

Events

 | Name | Description
Public event | ValueChanged | Raised whenever the value of the slider is changed via GUI interaction.

See Also

GH_Slider Class
Grasshopper.GUI Namespace


GH_Slider Constructor

[image]

Grasshopper SDK
GH_Slider Constructor
GH_Slider Class See Also Send Feedback
Initializes a new instance of the GH_Slider class

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Slider()
Visual Basic
Public Sub New

See Also

GH_Slider Class
Grasshopper.GUI Namespace


GH_Slider Methods

[image] [image]

Grasshopper SDK
GH_Slider Methods
GH_Slider Class See Also Send Feedback

The GH_Slider type exposes the following members.

Methods

 | Name | Description
Protected method | Input_Assign | (Overrides GH_TextInputBaseControlInput_Assign(String).)
Protected method | Input_Parse | (Overrides GH_TextInputBaseControlInput_Parse(String).)
Protected method | Input_Supply | (Overrides GH_TextInputBaseControlInput_Supply()()()().)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | (Overrides ScrollableControl..::..OnPaintBackground(PaintEventArgs).)

See Also

GH_Slider Class
Grasshopper.GUI Namespace


Input_Assign Method

[image]

Grasshopper SDK
GH_Slider..::..Input_Assign Method
GH_Slider Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Input_Assign(
    string text
)
Visual Basic
Protected Overrides Sub Input_Assign ( _
    text As String _
)

Parameters

text
Type: System..::..String

See Also

GH_Slider Class
Grasshopper.GUI Namespace


Input_Parse Method

[image]

Grasshopper SDK
GH_Slider..::..Input_Parse Method
GH_Slider Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override bool Input_Parse(
    string text
)
Visual Basic
Protected Overrides Function Input_Parse ( _
    text As String _
) As Boolean

Parameters

text
Type: System..::..String

See Also

GH_Slider Class
Grasshopper.GUI Namespace


Input_Supply Method

[image]

Grasshopper SDK
GH_Slider..::..Input_Supply Method
GH_Slider Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override string Input_Supply()
Visual Basic
Protected Overrides Function Input_Supply As String

See Also

GH_Slider Class
Grasshopper.GUI Namespace


OnPaint Method

[image]

Grasshopper SDK
GH_Slider..::..OnPaint Method
GH_Slider Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

GH_Slider Class
Grasshopper.GUI Namespace


OnPaintBackground Method

[image]

Grasshopper SDK
GH_Slider..::..OnPaintBackground Method
GH_Slider Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void OnPaintBackground(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaintBackground ( _
    e As PaintEventArgs _
)

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

GH_Slider Class
Grasshopper.GUI Namespace


GH_Slider Properties

[image] [image]

Grasshopper SDK
GH_Slider Properties
GH_Slider Class See Also Send Feedback

The GH_Slider type exposes the following members.

Properties

 | Name | Description
Public property | ControlEdgeColour | Gets or sets the EdgeColor for this slider control.
Public property | ControlShadowColour | Gets or sets the Shadow colour for this control.
Public property | DecimalPlaces | Gets or sets the number of decimal places allowed for Floating Point Sliders.
Public property | DrawControlBorder | Gets or sets whether the border of the slider should be drawn.
Public property | DrawControlShadows | Gets or sets whether the drop shadows of the slider should be drawn.
Public property | FormatMask | Gets or sets the string format mask to use for the display. Should contain at least one "{0}" element.
Public property | GripBottomColour | Gets or sets the fill colour for the bottom edge of the slider grip.
Public property | GripDisplay | Gets or sets how the slider grip (or thumb) is drawn.
Public property | GripEdgeColour | Gets or sets the edge colour for the slider grip.
Public property | GripTopColour | Gets or sets the fill colour for the top edge of the slider grip.
Public property | InternalSlider | Gets the internal slider.
Public property | Maximum | Gets or sets the upper numeric limit for the slider range.
Public property | Minimum | Gets or sets the lower numeric limit for the slider range.
Public property | RailBrightColour | Gets or sets the edge colour for the bright parts of the rail.
Public property | RailDarkColour | Gets or sets the edge colour for the dark parts of the rail.
Public property | RailDisplay | Gets or sets how the slider rail (or track) is drawn.
Public property | RailEmptyColour | Gets or sets the fill colour for the empty portion of the rail.
Public property | RailFullColour | Gets or sets the fill colour for the full portion of the rail.
Public property | ShadowSize | Gets or sets the size of the border shadow along all edges of the box.
Public property | TextColour | Gets or sets the fill colour for the slider text.
Public property | TickCount | Gets or sets the number of ticks.
Public property | TickDisplay | Gets or sets how the slider ticks are drawn.
Public property | TickFrequency | Gets or sets the frequency of large ticks vs small ticks.
Public property | Type | Gets or sets the numeric type of this slider.
Public property | Value | Gets or sets the numeric value for the slider range.

See Also

GH_Slider Class
Grasshopper.GUI Namespace


ControlEdgeColour Property

[image]

Grasshopper SDK
GH_Slider..::..ControlEdgeColour Property
GH_Slider Class See Also Send Feedback
Gets or sets the EdgeColor for this slider control.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color ControlEdgeColour { get; set; }
Visual Basic
Public Property ControlEdgeColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Slider.ControlEdgeColour"]

See Also

GH_Slider Class
Grasshopper.GUI Namespace


ControlShadowColour Property

[image]

Grasshopper SDK
GH_Slider..::..ControlShadowColour Property
GH_Slider Class See Also Send Feedback
Gets or sets the Shadow colour for this control.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color ControlShadowColour { get; set; }
Visual Basic
Public Property ControlShadowColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Slider.ControlShadowColour"]

See Also

GH_Slider Class
Grasshopper.GUI Namespace


DecimalPlaces Property

[image]

Grasshopper SDK
GH_Slider..::..DecimalPlaces Property
GH_Slider Class See Also Send Feedback
Gets or sets the number of decimal places allowed for Floating Point Sliders.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int DecimalPlaces { get; set; }
Visual Basic
Public Property DecimalPlaces As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Slider.DecimalPlaces"]

See Also

GH_Slider Class
Grasshopper.GUI Namespace


DrawControlBorder Property

[image]

Grasshopper SDK
GH_Slider..::..DrawControlBorder Property
GH_Slider Class See Also Send Feedback
Gets or sets whether the border of the slider should be drawn.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool DrawControlBorder { get; set; }
Visual Basic
Public Property DrawControlBorder As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Slider.DrawControlBorder"]

See Also

GH_Slider Class
Grasshopper.GUI Namespace


DrawControlShadows Property

[image]

Grasshopper SDK
GH_Slider..::..DrawControlShadows Property
GH_Slider Class See Also Send Feedback
Gets or sets whether the drop shadows of the slider should be drawn.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool DrawControlShadows { get; set; }
Visual Basic
Public Property DrawControlShadows As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Slider.DrawControlShadows"]

See Also

GH_Slider Class
Grasshopper.GUI Namespace


FormatMask Property

[image]

Grasshopper SDK
GH_Slider..::..FormatMask Property
GH_Slider Class See Also Send Feedback
Gets or sets the string format mask to use for the display. Should contain at least one "{0}" element.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string FormatMask { get; set; }
Visual Basic
Public Property FormatMask As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Slider.FormatMask"]

See Also

GH_Slider Class
Grasshopper.GUI Namespace


GripBottomColour Property

[image]

Grasshopper SDK
GH_Slider..::..GripBottomColour Property
GH_Slider Class See Also Send Feedback
Gets or sets the fill colour for the bottom edge of the slider grip.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color GripBottomColour { get; set; }
Visual Basic
Public Property GripBottomColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Slider.GripBottomColour"]

See Also

GH_Slider Class
Grasshopper.GUI Namespace


GripDisplay Property

[image]

Grasshopper SDK
GH_Slider..::..GripDisplay Property
GH_Slider Class See Also Send Feedback
Gets or sets how the slider grip (or thumb) is drawn.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_SliderGripDisplay GripDisplay { get; set; }
Visual Basic
Public Property GripDisplay As GH_SliderGripDisplay
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Slider.GripDisplay"]

See Also

GH_Slider Class
Grasshopper.GUI Namespace


GripEdgeColour Property

[image]

Grasshopper SDK
GH_Slider..::..GripEdgeColour Property
GH_Slider Class See Also Send Feedback
Gets or sets the edge colour for the slider grip.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color GripEdgeColour { get; set; }
Visual Basic
Public Property GripEdgeColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Slider.GripEdgeColour"]

See Also

GH_Slider Class
Grasshopper.GUI Namespace


GripTopColour Property

[image]

Grasshopper SDK
GH_Slider..::..GripTopColour Property
GH_Slider Class See Also Send Feedback
Gets or sets the fill colour for the top edge of the slider grip.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color GripTopColour { get; set; }
Visual Basic
Public Property GripTopColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Slider.GripTopColour"]

See Also

GH_Slider Class
Grasshopper.GUI Namespace


InternalSlider Property

[image]

Grasshopper SDK
GH_Slider..::..InternalSlider Property
GH_Slider Class See Also Send Feedback
Gets the internal slider.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_SliderBase InternalSlider { get; }
Visual Basic
Public ReadOnly Property InternalSlider As GH_SliderBase
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Slider.InternalSlider"]

See Also

GH_Slider Class
Grasshopper.GUI Namespace


Maximum Property

[image]

Grasshopper SDK
GH_Slider..::..Maximum Property
GH_Slider Class See Also Send Feedback
Gets or sets the upper numeric limit for the slider range.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public decimal Maximum { get; set; }
Visual Basic
Public Property Maximum As Decimal
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Slider.Maximum"]

See Also

GH_Slider Class
Grasshopper.GUI Namespace


Minimum Property

[image]

Grasshopper SDK
GH_Slider..::..Minimum Property
GH_Slider Class See Also Send Feedback
Gets or sets the lower numeric limit for the slider range.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public decimal Minimum { get; set; }
Visual Basic
Public Property Minimum As Decimal
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Slider.Minimum"]

See Also

GH_Slider Class
Grasshopper.GUI Namespace


RailBrightColour Property

[image]

Grasshopper SDK
GH_Slider..::..RailBrightColour Property
GH_Slider Class See Also Send Feedback
Gets or sets the edge colour for the bright parts of the rail.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color RailBrightColour { get; set; }
Visual Basic
Public Property RailBrightColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Slider.RailBrightColour"]

See Also

GH_Slider Class
Grasshopper.GUI Namespace


RailDarkColour Property

[image]

Grasshopper SDK
GH_Slider..::..RailDarkColour Property
GH_Slider Class See Also Send Feedback
Gets or sets the edge colour for the dark parts of the rail.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color RailDarkColour { get; set; }
Visual Basic
Public Property RailDarkColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Slider.RailDarkColour"]

See Also

GH_Slider Class
Grasshopper.GUI Namespace


RailDisplay Property

[image]

Grasshopper SDK
GH_Slider..::..RailDisplay Property
GH_Slider Class See Also Send Feedback
Gets or sets how the slider rail (or track) is drawn.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_SliderRailDisplay RailDisplay { get; set; }
Visual Basic
Public Property RailDisplay As GH_SliderRailDisplay
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Slider.RailDisplay"]

See Also

GH_Slider Class
Grasshopper.GUI Namespace


RailEmptyColour Property

[image]

Grasshopper SDK
GH_Slider..::..RailEmptyColour Property
GH_Slider Class See Also Send Feedback
Gets or sets the fill colour for the empty portion of the rail.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color RailEmptyColour { get; set; }
Visual Basic
Public Property RailEmptyColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Slider.RailEmptyColour"]

See Also

GH_Slider Class
Grasshopper.GUI Namespace


RailFullColour Property

[image]

Grasshopper SDK
GH_Slider..::..RailFullColour Property
GH_Slider Class See Also Send Feedback
Gets or sets the fill colour for the full portion of the rail.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color RailFullColour { get; set; }
Visual Basic
Public Property RailFullColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Slider.RailFullColour"]

See Also

GH_Slider Class
Grasshopper.GUI Namespace


ShadowSize Property

[image]

Grasshopper SDK
GH_Slider..::..ShadowSize Property
GH_Slider Class See Also Send Feedback
Gets or sets the size of the border shadow along all edges of the box.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Padding ShadowSize { get; set; }
Visual Basic
Public Property ShadowSize As Padding
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Slider.ShadowSize"]

See Also

GH_Slider Class
Grasshopper.GUI Namespace


TextColour Property

[image]

Grasshopper SDK
GH_Slider..::..TextColour Property
GH_Slider Class See Also Send Feedback
Gets or sets the fill colour for the slider text.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color TextColour { get; set; }
Visual Basic
Public Property TextColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Slider.TextColour"]

See Also

GH_Slider Class
Grasshopper.GUI Namespace


TickCount Property

[image]

Grasshopper SDK
GH_Slider..::..TickCount Property
GH_Slider Class See Also Send Feedback
Gets or sets the number of ticks.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int TickCount { get; set; }
Visual Basic
Public Property TickCount As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Slider.TickCount"]

See Also

GH_Slider Class
Grasshopper.GUI Namespace


TickDisplay Property

[image]

Grasshopper SDK
GH_Slider..::..TickDisplay Property
GH_Slider Class See Also Send Feedback
Gets or sets how the slider ticks are drawn.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_SliderTickDisplay TickDisplay { get; set; }
Visual Basic
Public Property TickDisplay As GH_SliderTickDisplay
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Slider.TickDisplay"]

See Also

GH_Slider Class
Grasshopper.GUI Namespace


TickFrequency Property

[image]

Grasshopper SDK
GH_Slider..::..TickFrequency Property
GH_Slider Class See Also Send Feedback
Gets or sets the frequency of large ticks vs small ticks.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int TickFrequency { get; set; }
Visual Basic
Public Property TickFrequency As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Slider.TickFrequency"]

See Also

GH_Slider Class
Grasshopper.GUI Namespace


Type Property

[image]

Grasshopper SDK
GH_Slider..::..Type Property
GH_Slider Class See Also Send Feedback
Gets or sets the numeric type of this slider.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_SliderAccuracy Type { get; set; }
Visual Basic
Public Property Type As GH_SliderAccuracy
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Slider.Type"]

See Also

GH_Slider Class
Grasshopper.GUI Namespace


Value Property

[image]

Grasshopper SDK
GH_Slider..::..Value Property
GH_Slider Class See Also Send Feedback
Gets or sets the numeric value for the slider range.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public decimal Value { get; set; }
Visual Basic
Public Property Value As Decimal
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Slider.Value"]

See Also

GH_Slider Class
Grasshopper.GUI Namespace


GH_Slider Events

[image] [image]

Grasshopper SDK
GH_Slider Events
GH_Slider Class See Also Send Feedback

The GH_Slider type exposes the following members.

Events

 | Name | Description
Public event | ValueChanged | Raised whenever the value of the slider is changed via GUI interaction.

See Also

GH_Slider Class
Grasshopper.GUI Namespace


ValueChanged Event

[image]

Grasshopper SDK
GH_Slider..::..ValueChanged Event
GH_Slider Class See Also Send Feedback
Raised whenever the value of the slider is changed via GUI interaction.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_Slider..::..ValueChangedEventHandler ValueChanged
Visual Basic
Public Event ValueChanged As GH_Slider..::..ValueChangedEventHandler

See Also

GH_Slider Class
Grasshopper.GUI Namespace


GH_Slider.ValueChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_Slider..::..ValueChangedEventHandler Delegate
GH_Slider Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void ValueChangedEventHandler(
    Object sender,
    GH_SliderEventArgs e
)
Visual Basic
Public Delegate Sub ValueChangedEventHandler ( _
    sender As Object, _
    e As GH_SliderEventArgs _
)

Parameters

sender
Type: System..::..Object
e
Type: Grasshopper.GUI.Base..::..GH_SliderEventArgs

See Also

Grasshopper.GUI Namespace


GH_Slider_Obsolete Class

[image]

Grasshopper SDK
GH_Slider_Obsolete Class
Members See Also Send Feedback
General purpose numeric slider.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
[ObsoleteAttribute("This control is obsolete, it has been replaced by GH_Slider")]
public class GH_Slider_Obsolete : UserControl
Visual Basic
<ObsoleteAttribute("This control is obsolete, it has been replaced by GH_Slider")> _
Public Class GH_Slider_Obsolete _
    Inherits UserControl

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
Grasshopper.GUI..::..GH_Slider_Obsolete

See Also

GH_Slider_Obsolete Members
Grasshopper.GUI Namespace


GH_Slider_Obsolete Members

[image] [image]

Grasshopper SDK
GH_Slider_Obsolete Members
GH_Slider_Obsolete Class Constructors Methods Properties Events See Also Send Feedback

The GH_Slider_Obsolete type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Slider_Obsolete | Initializes a new instance of the GH_Slider_Obsolete class

Methods

 | Name | Description
Protected method | Dispose | Releases the unmanaged resources used by the GH_Slider_Obsolete and optionally releases the managed resources (Overrides ContainerControl..::..Dispose(Boolean).)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | (Overrides ScrollableControl..::..OnPaintBackground(PaintEventArgs).)
Public method | OnValueChanged | Raise the ValueChanged event
 | SendMessage |

Properties

 | Name | Description
Public property | DisplayFormat | Gets or sets the display format fo the slider. This is the formatting that is applied prior to drawing. The default is {0} which results in a 1:1 display. Use this to append units or symbols.
Public property | DrawRail | Gets or sets a flag that control whether or not grip rails are drawn.
Public property | GripBackColor | Background colour of slider grip.
Public property | GripForeColor | Foreground colour of slider grip.
Public property | IsIntermediate | Gets the intermediate flag. If True, the user is currently dragging the slider.
Public property | Max | Gets or sets the maximum allowed value.
Public property | Min | Gets or sets the minimum allowed value.
Public property | NumericFormat | Gets or sets the numeric format for the slider. This is the formatting that is applied to the number. The default is #0.00 which results in a two digit rounding scheme.
Public property | TextInputMode | Gets or sets the Text input mode for this slider.
Public property | TickFrequency | Gets or sets the tick frequency of the slider.
Public property | Value | Gets or sets the current value.
Public property | ValueF | Gets or sets the current value in single-floating-point precision.

Events

 | Name | Description
Public event | ValueChanged | Raised whenever the value of the slider is changed via GUI interaction.

See Also

GH_Slider_Obsolete Class
Grasshopper.GUI Namespace


GH_Slider_Obsolete Constructor

[image]

Grasshopper SDK
GH_Slider_Obsolete Constructor
GH_Slider_Obsolete Class See Also Send Feedback
Initializes a new instance of the GH_Slider_Obsolete class

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Slider_Obsolete()
Visual Basic
Public Sub New

See Also

GH_Slider_Obsolete Class
Grasshopper.GUI Namespace


GH_Slider_Obsolete Methods

[image] [image]

Grasshopper SDK
GH_Slider_Obsolete Methods
GH_Slider_Obsolete Class See Also Send Feedback

The GH_Slider_Obsolete type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | (Overrides ContainerControl..::..Dispose(Boolean).)
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | (Overrides ScrollableControl..::..OnPaintBackground(PaintEventArgs).)
Public method | OnValueChanged | Raise the ValueChanged event
 | SendMessage |

See Also

GH_Slider_Obsolete Class
Grasshopper.GUI Namespace


Dispose Method

[image]

Grasshopper SDK
GH_Slider_Obsolete..::..Dispose Method
GH_Slider_Obsolete Class See Also Send Feedback
Releases the unmanaged resources used by the GH_Slider_Obsolete and optionally releases the managed resources

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

GH_Slider_Obsolete Class
Grasshopper.GUI Namespace


OnPaint Method

[image]

Grasshopper SDK
GH_Slider_Obsolete..::..OnPaint Method
GH_Slider_Obsolete Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

GH_Slider_Obsolete Class
Grasshopper.GUI Namespace


OnPaintBackground Method

[image]

Grasshopper SDK
GH_Slider_Obsolete..::..OnPaintBackground Method
GH_Slider_Obsolete Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void OnPaintBackground(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaintBackground ( _
    e As PaintEventArgs _
)

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

GH_Slider_Obsolete Class
Grasshopper.GUI Namespace


OnValueChanged Method

[image]

Grasshopper SDK
GH_Slider_Obsolete..::..OnValueChanged Method
GH_Slider_Obsolete Class See Also Send Feedback
Raise the ValueChanged event

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void OnValueChanged()
Visual Basic
Public Sub OnValueChanged

Remarks

See Also

GH_Slider_Obsolete Class
Grasshopper.GUI Namespace


SendMessage Method

[image]

Grasshopper SDK
GH_Slider_Obsolete..::..SendMessage Method
GH_Slider_Obsolete Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static IntPtr SendMessage(
    IntPtr hWnd,
    int msg,
    int wParam,
    IntPtr lParam
)
Visual Basic
Public Shared Function SendMessage ( _
    hWnd As IntPtr, _
    msg As Integer, _
    wParam As Integer, _
    lParam As IntPtr _
) As IntPtr

Parameters

hWnd
Type: System..::..IntPtr
msg
Type: System..::..Int32
wParam
Type: System..::..Int32
lParam
Type: System..::..IntPtr

See Also

GH_Slider_Obsolete Class
Grasshopper.GUI Namespace


GH_Slider_Obsolete Properties

[image] [image]

Grasshopper SDK
GH_Slider_Obsolete Properties
GH_Slider_Obsolete Class See Also Send Feedback

The GH_Slider_Obsolete type exposes the following members.

Properties

 | Name | Description
Public property | DisplayFormat | Gets or sets the display format fo the slider. This is the formatting that is applied prior to drawing. The default is {0} which results in a 1:1 display. Use this to append units or symbols.
Public property | DrawRail | Gets or sets a flag that control whether or not grip rails are drawn.
Public property | GripBackColor | Background colour of slider grip.
Public property | GripForeColor | Foreground colour of slider grip.
Public property | IsIntermediate | Gets the intermediate flag. If True, the user is currently dragging the slider.
Public property | Max | Gets or sets the maximum allowed value.
Public property | Min | Gets or sets the minimum allowed value.
Public property | NumericFormat | Gets or sets the numeric format for the slider. This is the formatting that is applied to the number. The default is #0.00 which results in a two digit rounding scheme.
Public property | TextInputMode | Gets or sets the Text input mode for this slider.
Public property | TickFrequency | Gets or sets the tick frequency of the slider.
Public property | Value | Gets or sets the current value.
Public property | ValueF | Gets or sets the current value in single-floating-point precision.

See Also

GH_Slider_Obsolete Class
Grasshopper.GUI Namespace


DisplayFormat Property

[image]

Grasshopper SDK
GH_Slider_Obsolete..::..DisplayFormat Property
GH_Slider_Obsolete Class See Also Send Feedback
Gets or sets the display format fo the slider. This is the formatting that is applied prior to drawing. The default is {0} which results in a 1:1 display. Use this to append units or symbols.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string DisplayFormat { get; set; }
Visual Basic
Public Property DisplayFormat As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Slider_Obsolete.DisplayFormat"]

Return Value

Remarks

See Also

GH_Slider_Obsolete Class
Grasshopper.GUI Namespace


DrawRail Property

[image]

Grasshopper SDK
GH_Slider_Obsolete..::..DrawRail Property
GH_Slider_Obsolete Class See Also Send Feedback
Gets or sets a flag that control whether or not grip rails are drawn.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool DrawRail { get; set; }
Visual Basic
Public Property DrawRail As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Slider_Obsolete.DrawRail"]

See Also

GH_Slider_Obsolete Class
Grasshopper.GUI Namespace


GripBackColor Property

[image]

Grasshopper SDK
GH_Slider_Obsolete..::..GripBackColor Property
GH_Slider_Obsolete Class See Also Send Feedback
Background colour of slider grip.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color GripBackColor { get; set; }
Visual Basic
Public Property GripBackColor As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Slider_Obsolete.GripBackColor"]

See Also

GH_Slider_Obsolete Class
Grasshopper.GUI Namespace


GripForeColor Property

[image]

Grasshopper SDK
GH_Slider_Obsolete..::..GripForeColor Property
GH_Slider_Obsolete Class See Also Send Feedback
Foreground colour of slider grip.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color GripForeColor { get; set; }
Visual Basic
Public Property GripForeColor As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Slider_Obsolete.GripForeColor"]

See Also

GH_Slider_Obsolete Class
Grasshopper.GUI Namespace


IsIntermediate Property

[image]

Grasshopper SDK
GH_Slider_Obsolete..::..IsIntermediate Property
GH_Slider_Obsolete Class See Also Send Feedback
Gets the intermediate flag. If True, the user is currently dragging the slider.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsIntermediate { get; }
Visual Basic
Public ReadOnly Property IsIntermediate As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Slider_Obsolete.IsIntermediate"]

See Also

GH_Slider_Obsolete Class
Grasshopper.GUI Namespace


Max Property

[image]

Grasshopper SDK
GH_Slider_Obsolete..::..Max Property
GH_Slider_Obsolete Class See Also Send Feedback
Gets or sets the maximum allowed value.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double Max { get; set; }
Visual Basic
Public Property Max As Double
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Slider_Obsolete.Max"]

See Also

GH_Slider_Obsolete Class
Grasshopper.GUI Namespace


Min Property

[image]

Grasshopper SDK
GH_Slider_Obsolete..::..Min Property
GH_Slider_Obsolete Class See Also Send Feedback
Gets or sets the minimum allowed value.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double Min { get; set; }
Visual Basic
Public Property Min As Double
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Slider_Obsolete.Min"]

See Also

GH_Slider_Obsolete Class
Grasshopper.GUI Namespace


NumericFormat Property

[image]

Grasshopper SDK
GH_Slider_Obsolete..::..NumericFormat Property
GH_Slider_Obsolete Class See Also Send Feedback
Gets or sets the numeric format for the slider. This is the formatting that is applied to the number. The default is #0.00 which results in a two digit rounding scheme.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string NumericFormat { get; set; }
Visual Basic
Public Property NumericFormat As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Slider_Obsolete.NumericFormat"]

See Also

GH_Slider_Obsolete Class
Grasshopper.GUI Namespace


TextInputMode Property

[image]

Grasshopper SDK
GH_Slider_Obsolete..::..TextInputMode Property
GH_Slider_Obsolete Class See Also Send Feedback
Gets or sets the Text input mode for this slider.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_SliderInputMode TextInputMode { get; set; }
Visual Basic
Public Property TextInputMode As GH_SliderInputMode
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Slider_Obsolete.TextInputMode"]

See Also

GH_Slider_Obsolete Class
Grasshopper.GUI Namespace


TickFrequency Property

[image]

Grasshopper SDK
GH_Slider_Obsolete..::..TickFrequency Property
GH_Slider_Obsolete Class See Also Send Feedback
Gets or sets the tick frequency of the slider.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int TickFrequency { get; set; }
Visual Basic
Public Property TickFrequency As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Slider_Obsolete.TickFrequency"]

See Also

GH_Slider_Obsolete Class
Grasshopper.GUI Namespace


Value Property

[image]

Grasshopper SDK
GH_Slider_Obsolete..::..Value Property
GH_Slider_Obsolete Class See Also Send Feedback
Gets or sets the current value.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double Value { get; set; }
Visual Basic
Public Property Value As Double
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Slider_Obsolete.Value"]

See Also

GH_Slider_Obsolete Class
Grasshopper.GUI Namespace


ValueF Property

[image]

Grasshopper SDK
GH_Slider_Obsolete..::..ValueF Property
GH_Slider_Obsolete Class See Also Send Feedback
Gets or sets the current value in single-floating-point precision.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public float ValueF { get; set; }
Visual Basic
Public Property ValueF As Single
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Slider_Obsolete.ValueF"]

See Also

GH_Slider_Obsolete Class
Grasshopper.GUI Namespace


GH_Slider_Obsolete Events

[image] [image]

Grasshopper SDK
GH_Slider_Obsolete Events
GH_Slider_Obsolete Class See Also Send Feedback

The GH_Slider_Obsolete type exposes the following members.

Events

 | Name | Description
Public event | ValueChanged | Raised whenever the value of the slider is changed via GUI interaction.

See Also

GH_Slider_Obsolete Class
Grasshopper.GUI Namespace


ValueChanged Event

[image]

Grasshopper SDK
GH_Slider_Obsolete..::..ValueChanged Event
GH_Slider_Obsolete Class See Also Send Feedback
Raised whenever the value of the slider is changed via GUI interaction.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_Slider_Obsolete..::..ValueChangedEventHandler ValueChanged
Visual Basic
Public Event ValueChanged As GH_Slider_Obsolete..::..ValueChangedEventHandler

See Also

GH_Slider_Obsolete Class
Grasshopper.GUI Namespace


GH_Slider_Obsolete.ValueChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_Slider_Obsolete..::..ValueChangedEventHandler Delegate
GH_Slider_Obsolete Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void ValueChangedEventHandler(
    GH_Slider_Obsolete sender,
    double nValue,
    bool bIntermediate
)
Visual Basic
Public Delegate Sub ValueChangedEventHandler ( _
    sender As GH_Slider_Obsolete, _
    nValue As Double, _
    bIntermediate As Boolean _
)

Parameters

sender
Type: Grasshopper.GUI..::..GH_Slider_Obsolete
nValue
Type: System..::..Double
bIntermediate
Type: System..::..Boolean

See Also

Grasshopper.GUI Namespace


GH_SliderInputMode Enumeration

[image]

Grasshopper SDK
GH_SliderInputMode Enumeration
See Also Send Feedback
Enumerates all possible slider text input modes.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_SliderInputMode
Visual Basic
Public Enumeration GH_SliderInputMode

Members

Member name | Value | Description
None | 0 | Text input mode is not available.
OnKeyDown | 1 | Text input mode will be available on keydown.
OnDoubleClick | 2 | Text input mode will be available upon double click.
All | 3 | All text input modes will be available.

See Also

Grasshopper.GUI Namespace


GH_StandardIcons Class

[image]

Grasshopper SDK
GH_StandardIcons Class
Members See Also Send Feedback
Provides access to a set of standard icons.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class GH_StandardIcons
Visual Basic
Public NotInheritable Class GH_StandardIcons

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI..::..GH_StandardIcons

See Also

GH_StandardIcons Members
Grasshopper.GUI Namespace


GH_StandardIcons Members

[image] [image]

Grasshopper SDK
GH_StandardIcons Members
GH_StandardIcons Class Properties See Also Send Feedback

The GH_StandardIcons type exposes the following members.

Properties

Name | Description
BlankObjectIcon_24x24 | Gets the base icon for objects; an empty white square.
BlankParameterIcon_24x24 | Gets the base icon for parameters; an empty black hexagon.
ClusterIcon_24x24 | Gets the icon used for clusters.
FileIconDll_32x32 | Gets the file icon used for Dll files.
FileIconExe_32x32 | Gets the file icon used for Exe files.
FileIconGH_32x36 | Gets the file icon used for Grasshopper Binary files.
FileIconGha_32x32 | Gets the file icon used for Gha files.
FileIconGHMissing_32x36 | Gets the file icon used for missing Grasshopper Binary files.
FileIconGHX_32x36 | Gets the file icon used for Grasshopper Xml files.
FileIconGHXMissing_32x36 | Gets the file icon used for missing Grasshopper Xml files.
FileIconRhp_32x32 | Gets the file icon used for Rhp files.
FlattenIcon_24x24 | Gets the trunk icon used to indicate flattening.
GraftIcon_24x24 | Gets the twig icon used to indicate grafting.
GroupIcon_24x24 | Gets the icon used for canvas groups.
UnknownObjectIcon_24x24 | Gets the icon used for objects that do not have their own icon and unknown objects.
UserObjectIcon_24x24 | Gets the icon used for user objects.

See Also

GH_StandardIcons Class
Grasshopper.GUI Namespace


GH_StandardIcons Properties

[image] [image]

Grasshopper SDK
GH_StandardIcons Properties
GH_StandardIcons Class See Also Send Feedback

The GH_StandardIcons type exposes the following members.

Properties

Name | Description
BlankObjectIcon_24x24 | Gets the base icon for objects; an empty white square.
BlankParameterIcon_24x24 | Gets the base icon for parameters; an empty black hexagon.
ClusterIcon_24x24 | Gets the icon used for clusters.
FileIconDll_32x32 | Gets the file icon used for Dll files.
FileIconExe_32x32 | Gets the file icon used for Exe files.
FileIconGH_32x36 | Gets the file icon used for Grasshopper Binary files.
FileIconGha_32x32 | Gets the file icon used for Gha files.
FileIconGHMissing_32x36 | Gets the file icon used for missing Grasshopper Binary files.
FileIconGHX_32x36 | Gets the file icon used for Grasshopper Xml files.
FileIconGHXMissing_32x36 | Gets the file icon used for missing Grasshopper Xml files.
FileIconRhp_32x32 | Gets the file icon used for Rhp files.
FlattenIcon_24x24 | Gets the trunk icon used to indicate flattening.
GraftIcon_24x24 | Gets the twig icon used to indicate grafting.
GroupIcon_24x24 | Gets the icon used for canvas groups.
UnknownObjectIcon_24x24 | Gets the icon used for objects that do not have their own icon and unknown objects.
UserObjectIcon_24x24 | Gets the icon used for user objects.

See Also

GH_StandardIcons Class
Grasshopper.GUI Namespace


BlankObjectIcon_24x24 Property

[image]

Grasshopper SDK
GH_StandardIcons..::..BlankObjectIcon_24x24 Property
GH_StandardIcons Class See Also Send Feedback
Gets the base icon for objects; an empty white square.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Bitmap BlankObjectIcon_24x24 { get; }
Visual Basic
Public Shared ReadOnly Property BlankObjectIcon_24x24 As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_StandardIcons.BlankObjectIcon_24x24"]

See Also

GH_StandardIcons Class
Grasshopper.GUI Namespace


BlankParameterIcon_24x24 Property

[image]

Grasshopper SDK
GH_StandardIcons..::..BlankParameterIcon_24x24 Property
GH_StandardIcons Class See Also Send Feedback
Gets the base icon for parameters; an empty black hexagon.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Bitmap BlankParameterIcon_24x24 { get; }
Visual Basic
Public Shared ReadOnly Property BlankParameterIcon_24x24 As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_StandardIcons.BlankParameterIcon_24x24"]

See Also

GH_StandardIcons Class
Grasshopper.GUI Namespace


ClusterIcon_24x24 Property

[image]

Grasshopper SDK
GH_StandardIcons..::..ClusterIcon_24x24 Property
GH_StandardIcons Class See Also Send Feedback
Gets the icon used for clusters.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Bitmap ClusterIcon_24x24 { get; }
Visual Basic
Public Shared ReadOnly Property ClusterIcon_24x24 As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_StandardIcons.ClusterIcon_24x24"]

See Also

GH_StandardIcons Class
Grasshopper.GUI Namespace


FileIconDll_32x32 Property

[image]

Grasshopper SDK
GH_StandardIcons..::..FileIconDll_32x32 Property
GH_StandardIcons Class See Also Send Feedback
Gets the file icon used for Dll files.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Bitmap FileIconDll_32x32 { get; }
Visual Basic
Public Shared ReadOnly Property FileIconDll_32x32 As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_StandardIcons.FileIconDll_32x32"]

See Also

GH_StandardIcons Class
Grasshopper.GUI Namespace


FileIconExe_32x32 Property

[image]

Grasshopper SDK
GH_StandardIcons..::..FileIconExe_32x32 Property
GH_StandardIcons Class See Also Send Feedback
Gets the file icon used for Exe files.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Bitmap FileIconExe_32x32 { get; }
Visual Basic
Public Shared ReadOnly Property FileIconExe_32x32 As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_StandardIcons.FileIconExe_32x32"]

See Also

GH_StandardIcons Class
Grasshopper.GUI Namespace


FileIconGH_32x36 Property

[image]

Grasshopper SDK
GH_StandardIcons..::..FileIconGH_32x36 Property
GH_StandardIcons Class See Also Send Feedback
Gets the file icon used for Grasshopper Binary files.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Bitmap FileIconGH_32x36 { get; }
Visual Basic
Public Shared ReadOnly Property FileIconGH_32x36 As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_StandardIcons.FileIconGH_32x36"]

See Also

GH_StandardIcons Class
Grasshopper.GUI Namespace


FileIconGha_32x32 Property

[image]

Grasshopper SDK
GH_StandardIcons..::..FileIconGha_32x32 Property
GH_StandardIcons Class See Also Send Feedback
Gets the file icon used for Gha files.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Bitmap FileIconGha_32x32 { get; }
Visual Basic
Public Shared ReadOnly Property FileIconGha_32x32 As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_StandardIcons.FileIconGha_32x32"]

See Also

GH_StandardIcons Class
Grasshopper.GUI Namespace


FileIconGHMissing_32x36 Property

[image]

Grasshopper SDK
GH_StandardIcons..::..FileIconGHMissing_32x36 Property
GH_StandardIcons Class See Also Send Feedback
Gets the file icon used for missing Grasshopper Binary files.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Bitmap FileIconGHMissing_32x36 { get; }
Visual Basic
Public Shared ReadOnly Property FileIconGHMissing_32x36 As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_StandardIcons.FileIconGHMissing_32x36"]

See Also

GH_StandardIcons Class
Grasshopper.GUI Namespace


FileIconGHX_32x36 Property

[image]

Grasshopper SDK
GH_StandardIcons..::..FileIconGHX_32x36 Property
GH_StandardIcons Class See Also Send Feedback
Gets the file icon used for Grasshopper Xml files.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Bitmap FileIconGHX_32x36 { get; }
Visual Basic
Public Shared ReadOnly Property FileIconGHX_32x36 As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_StandardIcons.FileIconGHX_32x36"]

See Also

GH_StandardIcons Class
Grasshopper.GUI Namespace


FileIconGHXMissing_32x36 Property

[image]

Grasshopper SDK
GH_StandardIcons..::..FileIconGHXMissing_32x36 Property
GH_StandardIcons Class See Also Send Feedback
Gets the file icon used for missing Grasshopper Xml files.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Bitmap FileIconGHXMissing_32x36 { get; }
Visual Basic
Public Shared ReadOnly Property FileIconGHXMissing_32x36 As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_StandardIcons.FileIconGHXMissing_32x36"]

See Also

GH_StandardIcons Class
Grasshopper.GUI Namespace


FileIconRhp_32x32 Property

[image]

Grasshopper SDK
GH_StandardIcons..::..FileIconRhp_32x32 Property
GH_StandardIcons Class See Also Send Feedback
Gets the file icon used for Rhp files.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Bitmap FileIconRhp_32x32 { get; }
Visual Basic
Public Shared ReadOnly Property FileIconRhp_32x32 As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_StandardIcons.FileIconRhp_32x32"]

See Also

GH_StandardIcons Class
Grasshopper.GUI Namespace


FlattenIcon_24x24 Property

[image]

Grasshopper SDK
GH_StandardIcons..::..FlattenIcon_24x24 Property
GH_StandardIcons Class See Also Send Feedback
Gets the trunk icon used to indicate flattening.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Bitmap FlattenIcon_24x24 { get; }
Visual Basic
Public Shared ReadOnly Property FlattenIcon_24x24 As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_StandardIcons.FlattenIcon_24x24"]

See Also

GH_StandardIcons Class
Grasshopper.GUI Namespace


GraftIcon_24x24 Property

[image]

Grasshopper SDK
GH_StandardIcons..::..GraftIcon_24x24 Property
GH_StandardIcons Class See Also Send Feedback
Gets the twig icon used to indicate grafting.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Bitmap GraftIcon_24x24 { get; }
Visual Basic
Public Shared ReadOnly Property GraftIcon_24x24 As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_StandardIcons.GraftIcon_24x24"]

See Also

GH_StandardIcons Class
Grasshopper.GUI Namespace


GroupIcon_24x24 Property

[image]

Grasshopper SDK
GH_StandardIcons..::..GroupIcon_24x24 Property
GH_StandardIcons Class See Also Send Feedback
Gets the icon used for canvas groups.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Bitmap GroupIcon_24x24 { get; }
Visual Basic
Public Shared ReadOnly Property GroupIcon_24x24 As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_StandardIcons.GroupIcon_24x24"]

See Also

GH_StandardIcons Class
Grasshopper.GUI Namespace


UnknownObjectIcon_24x24 Property

[image]

Grasshopper SDK
GH_StandardIcons..::..UnknownObjectIcon_24x24 Property
GH_StandardIcons Class See Also Send Feedback
Gets the icon used for objects that do not have their own icon and unknown objects.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Bitmap UnknownObjectIcon_24x24 { get; }
Visual Basic
Public Shared ReadOnly Property UnknownObjectIcon_24x24 As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_StandardIcons.UnknownObjectIcon_24x24"]

See Also

GH_StandardIcons Class
Grasshopper.GUI Namespace


UserObjectIcon_24x24 Property

[image]

Grasshopper SDK
GH_StandardIcons..::..UserObjectIcon_24x24 Property
GH_StandardIcons Class See Also Send Feedback
Gets the icon used for user objects.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Bitmap UserObjectIcon_24x24 { get; }
Visual Basic
Public Shared ReadOnly Property UserObjectIcon_24x24 As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_StandardIcons.UserObjectIcon_24x24"]

See Also

GH_StandardIcons Class
Grasshopper.GUI Namespace


GH_Tooltip Class

[image]

Grasshopper SDK
GH_Tooltip Class
Members See Also Send Feedback
Implements a custom Tooltip class with advanced functionality. All methods and fields are Shared. There can never be more than one GH_Tooltip.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class GH_Tooltip
Visual Basic
Public NotInheritable Class GH_Tooltip

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI..::..GH_Tooltip

See Also

GH_Tooltip Members
Grasshopper.GUI Namespace


GH_Tooltip Members

[image] [image]

Grasshopper SDK
GH_Tooltip Members
GH_Tooltip Class Methods Properties See Also Send Feedback

The GH_Tooltip type exposes the following members.

Methods

Name | Description
Adjust | Repositions the tooltip to match with new cursor positions.
AssignTooltipFields | Set all fields of the Tooltip. You'll still need to call Show() to display the tooltip.
Clear | Hides the tooltip and clears all references and caches.
IsOwner | Returns true if the test control matches the internal Owner control. Use this method to make sure you actually own this tooltip prior to clearing it.
IsTag | Returns True if the test object matches the internal Tag object
Layout | Layout the tooltip fields. Layout happens automatically if you use the AssigTooltipField method, if however you poke values directly in the tooltip form you must place a call to Layout() before showing the tooltip.
Show | Display the tooltip on screen.
TooltipDetailedInformation |

Properties

Name | Description
Tag | Gets or sets the tag object for the tooltip
TooltipForm | Gets the internal instance of GH_TooltipForm.

See Also

GH_Tooltip Class
Grasshopper.GUI Namespace


GH_Tooltip Methods

[image] [image]

Grasshopper SDK
GH_Tooltip Methods
GH_Tooltip Class See Also Send Feedback

The GH_Tooltip type exposes the following members.

Methods

Name | Description
Adjust | Repositions the tooltip to match with new cursor positions.
AssignTooltipFields | Set all fields of the Tooltip. You'll still need to call Show() to display the tooltip.
Clear | Hides the tooltip and clears all references and caches.
IsOwner | Returns true if the test control matches the internal Owner control. Use this method to make sure you actually own this tooltip prior to clearing it.
IsTag | Returns True if the test object matches the internal Tag object
Layout | Layout the tooltip fields. Layout happens automatically if you use the AssigTooltipField method, if however you poke values directly in the tooltip form you must place a call to Layout() before showing the tooltip.
Show | Display the tooltip on screen.
TooltipDetailedInformation |

See Also

GH_Tooltip Class
Grasshopper.GUI Namespace


Adjust Method

[image]

Grasshopper SDK
GH_Tooltip..::..Adjust Method
GH_Tooltip Class See Also Send Feedback
Repositions the tooltip to match with new cursor positions.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void Adjust()
Visual Basic
Public Shared Sub Adjust

See Also

GH_Tooltip Class
Grasshopper.GUI Namespace


AssignTooltipFields Method

[image]

Grasshopper SDK
GH_Tooltip..::..AssignTooltipFields Method
GH_Tooltip Class See Also Send Feedback
Set all fields of the Tooltip. You'll still need to call Show() to display the tooltip.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void AssignTooltipFields(
    string title,
    string text,
    string description,
    Image icon,
    Image diagram
)
Visual Basic
Public Shared Sub AssignTooltipFields ( _
    title As String, _
    text As String, _
    description As String, _
    icon As Image, _
    diagram As Image _
)

Parameters

title
Type: System..::..String
The Title text on the tooltip
text
Type: System..::..String
The text content of the tooltip
description
Type: System..::..String
The block text to be displayed in the sunken area of the tooltip.
icon
Type: System.Drawing..::..Image
The Icon to be displayed next to the Title.
diagram
Type: System.Drawing..::..Image
The image to be displayed in the sunken area.

See Also

GH_Tooltip Class
Grasshopper.GUI Namespace


Clear Method

[image]

Grasshopper SDK
GH_Tooltip..::..Clear Method
GH_Tooltip Class See Also Send Feedback
Hides the tooltip and clears all references and caches.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void Clear()
Visual Basic
Public Shared Sub Clear

See Also

GH_Tooltip Class
Grasshopper.GUI Namespace


IsOwner Method

[image]

Grasshopper SDK
GH_Tooltip..::..IsOwner Method
GH_Tooltip Class See Also Send Feedback
Returns true if the test control matches the internal Owner control. Use this method to make sure you actually own this tooltip prior to clearing it.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool IsOwner(
    Control test
)
Visual Basic
Public Shared Function IsOwner ( _
    test As Control _
) As Boolean

Parameters

test
Type: System.Windows.Forms..::..Control

Return Value

Remarks

See Also

GH_Tooltip Class
Grasshopper.GUI Namespace


IsTag Method

[image]

Grasshopper SDK
GH_Tooltip..::..IsTag Method
GH_Tooltip Class See Also Send Feedback
Returns True if the test object matches the internal Tag object

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool IsTag(
    Object test
)
Visual Basic
Public Shared Function IsTag ( _
    test As Object _
) As Boolean

Parameters

test
Type: System..::..Object

Return Value

Remarks

See Also

GH_Tooltip Class
Grasshopper.GUI Namespace


Layout Method

[image]

Grasshopper SDK
GH_Tooltip..::..Layout Method
GH_Tooltip Class See Also Send Feedback
Layout the tooltip fields. Layout happens automatically if you use the AssigTooltipField method, if however you poke values directly in the tooltip form you must place a call to Layout() before showing the tooltip.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void Layout()
Visual Basic
Public Shared Sub Layout

See Also

GH_Tooltip Class
Grasshopper.GUI Namespace


Show Method

[image]

Grasshopper SDK
GH_Tooltip..::..Show Method
GH_Tooltip Class See Also Send Feedback
Display the tooltip on screen.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void Show(
    Control owner
)
Visual Basic
Public Shared Sub Show ( _
    owner As Control _
)

Parameters

owner
Type: System.Windows.Forms..::..Control

See Also

GH_Tooltip Class
Grasshopper.GUI Namespace


TooltipDetailedInformation Method

[image]

Grasshopper SDK
GH_Tooltip..::..TooltipDetailedInformation Method
GH_Tooltip Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string TooltipDetailedInformation()
Visual Basic
Public Shared Function TooltipDetailedInformation As String

See Also

GH_Tooltip Class
Grasshopper.GUI Namespace


GH_Tooltip Properties

[image] [image]

Grasshopper SDK
GH_Tooltip Properties
GH_Tooltip Class See Also Send Feedback

The GH_Tooltip type exposes the following members.

Properties

Name | Description
Tag | Gets or sets the tag object for the tooltip
TooltipForm | Gets the internal instance of GH_TooltipForm.

See Also

GH_Tooltip Class
Grasshopper.GUI Namespace


Tag Property

[image]

Grasshopper SDK
GH_Tooltip..::..Tag Property
GH_Tooltip Class See Also Send Feedback
Gets or sets the tag object for the tooltip

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Object Tag { get; set; }
Visual Basic
Public Shared Property Tag As Object
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Tooltip.Tag"]

Return Value

Remarks

See Also

GH_Tooltip Class
Grasshopper.GUI Namespace


TooltipForm Property

[image]

Grasshopper SDK
GH_Tooltip..::..TooltipForm Property
GH_Tooltip Class See Also Send Feedback
Gets the internal instance of GH_TooltipForm.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_ToolTipForm TooltipForm { get; }
Visual Basic
Public Shared ReadOnly Property TooltipForm As GH_ToolTipForm
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_Tooltip.TooltipForm"]

See Also

GH_Tooltip Class
Grasshopper.GUI Namespace


GH_TooltipComponent Class

[image]

Grasshopper SDK
GH_TooltipComponent Class
Members See Also Send Feedback
This component provides Grasshopper tooltip functionality through a winforms Component.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class GH_TooltipComponent : Component
Visual Basic
Public NotInheritable Class GH_TooltipComponent _
    Inherits Component

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
Grasshopper.GUI..::..GH_TooltipComponent

See Also

GH_TooltipComponent Members
Grasshopper.GUI Namespace


GH_TooltipComponent Members

[image] [image]

Grasshopper SDK
GH_TooltipComponent Members
GH_TooltipComponent Class Constructors Methods Properties Events See Also Send Feedback

The GH_TooltipComponent type exposes the following members.

Constructors

 | Name | Description
Public method | GH_TooltipComponent | Initializes a new instance of the GH_TooltipComponent class

Methods

 | Name | Description
Public method | Hide |
Public method | IsTag | Test whether the current Tooltip tag matches the object.

Properties

 | Name | Description
Public property | Delay | Gets or sets the delay (in milliseconds) for this tooltip to appear.
Public property | Enabled | Gets or sets the Enabled flag.
Public property | Tag | Provides an easy way to store information on this Tooltip.
Public property | Target | Gets or sets the control this tooltip is tied to.

Events

 | Name | Description
Public event | PopulateTooltip | This event is raised just prior to the tooltip display.

See Also

GH_TooltipComponent Class
Grasshopper.GUI Namespace


GH_TooltipComponent Constructor

[image]

Grasshopper SDK
GH_TooltipComponent Constructor
GH_TooltipComponent Class See Also Send Feedback
Initializes a new instance of the GH_TooltipComponent class

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_TooltipComponent()
Visual Basic
Public Sub New

See Also

GH_TooltipComponent Class
Grasshopper.GUI Namespace


GH_TooltipComponent Methods

[image] [image]

Grasshopper SDK
GH_TooltipComponent Methods
GH_TooltipComponent Class See Also Send Feedback

The GH_TooltipComponent type exposes the following members.

Methods

 | Name | Description
Public method | Hide |
Public method | IsTag | Test whether the current Tooltip tag matches the object.

See Also

GH_TooltipComponent Class
Grasshopper.GUI Namespace


Hide Method

[image]

Grasshopper SDK
GH_TooltipComponent..::..Hide Method
GH_TooltipComponent Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Hide()
Visual Basic
Public Sub Hide

See Also

GH_TooltipComponent Class
Grasshopper.GUI Namespace


IsTag Method

[image]

Grasshopper SDK
GH_TooltipComponent..::..IsTag Method
GH_TooltipComponent Class See Also Send Feedback
Test whether the current Tooltip tag matches the object.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsTag(
    Object object
)
Visual Basic
Public Function IsTag ( _
    object As Object _
) As Boolean

Parameters

object
Type: System..::..Object
Object to test against tag.

Return Value

True if the Tag and object are the same.

See Also

GH_TooltipComponent Class
Grasshopper.GUI Namespace


GH_TooltipComponent Properties

[image] [image]

Grasshopper SDK
GH_TooltipComponent Properties
GH_TooltipComponent Class See Also Send Feedback

The GH_TooltipComponent type exposes the following members.

Properties

 | Name | Description
Public property | Delay | Gets or sets the delay (in milliseconds) for this tooltip to appear.
Public property | Enabled | Gets or sets the Enabled flag.
Public property | Tag | Provides an easy way to store information on this Tooltip.
Public property | Target | Gets or sets the control this tooltip is tied to.

See Also

GH_TooltipComponent Class
Grasshopper.GUI Namespace


Delay Property

[image]

Grasshopper SDK
GH_TooltipComponent..::..Delay Property
GH_TooltipComponent Class See Also Send Feedback
Gets or sets the delay (in milliseconds) for this tooltip to appear.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int Delay { get; set; }
Visual Basic
Public Property Delay As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_TooltipComponent.Delay"]

See Also

GH_TooltipComponent Class
Grasshopper.GUI Namespace


Enabled Property

[image]

Grasshopper SDK
GH_TooltipComponent..::..Enabled Property
GH_TooltipComponent Class See Also Send Feedback
Gets or sets the Enabled flag.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Enabled { get; set; }
Visual Basic
Public Property Enabled As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_TooltipComponent.Enabled"]

See Also

GH_TooltipComponent Class
Grasshopper.GUI Namespace


Tag Property

[image]

Grasshopper SDK
GH_TooltipComponent..::..Tag Property
GH_TooltipComponent Class See Also Send Feedback
Provides an easy way to store information on this Tooltip.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Object Tag { get; set; }
Visual Basic
Public Property Tag As Object
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_TooltipComponent.Tag"]

See Also

GH_TooltipComponent Class
Grasshopper.GUI Namespace


Target Property

[image]

Grasshopper SDK
GH_TooltipComponent..::..Target Property
GH_TooltipComponent Class See Also Send Feedback
Gets or sets the control this tooltip is tied to.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Control Target { get; set; }
Visual Basic
Public Property Target As Control
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_TooltipComponent.Target"]

See Also

GH_TooltipComponent Class
Grasshopper.GUI Namespace


GH_TooltipComponent Events

[image] [image]

Grasshopper SDK
GH_TooltipComponent Events
GH_TooltipComponent Class See Also Send Feedback

The GH_TooltipComponent type exposes the following members.

Events

 | Name | Description
Public event | PopulateTooltip | This event is raised just prior to the tooltip display.

See Also

GH_TooltipComponent Class
Grasshopper.GUI Namespace


PopulateTooltip Event

[image]

Grasshopper SDK
GH_TooltipComponent..::..PopulateTooltip Event
GH_TooltipComponent Class See Also Send Feedback
This event is raised just prior to the tooltip display.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_TooltipComponent..::..PopulateTooltipEventHandler PopulateTooltip
Visual Basic
Public Event PopulateTooltip As GH_TooltipComponent..::..PopulateTooltipEventHandler

See Also

GH_TooltipComponent Class
Grasshopper.GUI Namespace


GH_TooltipComponent.PopulateTooltipEventHandler Delegate

[image]

Grasshopper SDK
GH_TooltipComponent..::..PopulateTooltipEventHandler Delegate
GH_TooltipComponent Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void PopulateTooltipEventHandler(
    Object sender,
    GH_TooltipDisplayEventArgs e
)
Visual Basic
Public Delegate Sub PopulateTooltipEventHandler ( _
    sender As Object, _
    e As GH_TooltipDisplayEventArgs _
)

Parameters

sender
Type: System..::..Object
e
Type: Grasshopper.GUI..::..GH_TooltipDisplayEventArgs

See Also

Grasshopper.GUI Namespace


GH_TooltipDisplayEventArgs Class

[image]

Grasshopper SDK
GH_TooltipDisplayEventArgs Class
Members See Also Send Feedback
Event arguments used in the Tooltip Component.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class GH_TooltipDisplayEventArgs : EventArgs
Visual Basic
Public NotInheritable Class GH_TooltipDisplayEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Grasshopper.GUI..::..GH_TooltipDisplayEventArgs

See Also

GH_TooltipDisplayEventArgs Members
Grasshopper.GUI Namespace


GH_TooltipDisplayEventArgs Members

[image] [image]

Grasshopper SDK
GH_TooltipDisplayEventArgs Members
GH_TooltipDisplayEventArgs Class Properties See Also Send Feedback

The GH_TooltipDisplayEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Control | Gets the control for whom the tooltip is about to be displayed.
Public property | Description | Gets or sets the description of the tooltip. This field is optional.
Public property | Diagram | Gets or sets the image that is displayed in the details section of the tooltip. This field is optional, but when it is defined, the Description property is ignored.
Public property | Icon | Gets or sets the icon that is displayed in the upper left hand corner of the tooltip. This field is optional.
Public property | Point | Gets the point in control coordinates for the tooltip locus.
Public property | Region | Gets or sets the active region (in control coordinates) for this tooltip. Once a tooltip is shown inside the region, the tooltip will 'stick' to the mouse for as long as the mouse remains within this region. By default the region is set to Rectangle.Empty, which indicates that region tracking is not used for this tooltip.
Public property | Text | Gets or sets the text of the tooltip. If you do not set the Text property, you must set the Title property or the tooltip will not be shown.
Public property | Title | Gets or sets the title of the tooltip. If you do not set the Title property, you must set the Text property or the tooltip will not be shown.
Public property | Valid | Gets whether there is currently enough data to display a tooltip.

See Also

GH_TooltipDisplayEventArgs Class
Grasshopper.GUI Namespace


GH_TooltipDisplayEventArgs Properties

[image] [image]

Grasshopper SDK
GH_TooltipDisplayEventArgs Properties
GH_TooltipDisplayEventArgs Class See Also Send Feedback

The GH_TooltipDisplayEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Control | Gets the control for whom the tooltip is about to be displayed.
Public property | Description | Gets or sets the description of the tooltip. This field is optional.
Public property | Diagram | Gets or sets the image that is displayed in the details section of the tooltip. This field is optional, but when it is defined, the Description property is ignored.
Public property | Icon | Gets or sets the icon that is displayed in the upper left hand corner of the tooltip. This field is optional.
Public property | Point | Gets the point in control coordinates for the tooltip locus.
Public property | Region | Gets or sets the active region (in control coordinates) for this tooltip. Once a tooltip is shown inside the region, the tooltip will 'stick' to the mouse for as long as the mouse remains within this region. By default the region is set to Rectangle.Empty, which indicates that region tracking is not used for this tooltip.
Public property | Text | Gets or sets the text of the tooltip. If you do not set the Text property, you must set the Title property or the tooltip will not be shown.
Public property | Title | Gets or sets the title of the tooltip. If you do not set the Title property, you must set the Text property or the tooltip will not be shown.
Public property | Valid | Gets whether there is currently enough data to display a tooltip.

See Also

GH_TooltipDisplayEventArgs Class
Grasshopper.GUI Namespace


Control Property

[image]

Grasshopper SDK
GH_TooltipDisplayEventArgs..::..Control Property
GH_TooltipDisplayEventArgs Class See Also Send Feedback
Gets the control for whom the tooltip is about to be displayed.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Control Control { get; }
Visual Basic
Public ReadOnly Property Control As Control
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_TooltipDisplayEventArgs.Control"]

See Also

GH_TooltipDisplayEventArgs Class
Grasshopper.GUI Namespace


Description Property

[image]

Grasshopper SDK
GH_TooltipDisplayEventArgs..::..Description Property
GH_TooltipDisplayEventArgs Class See Also Send Feedback
Gets or sets the description of the tooltip. This field is optional.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_TooltipDisplayEventArgs.Description"]

See Also

GH_TooltipDisplayEventArgs Class
Grasshopper.GUI Namespace


Diagram Property

[image]

Grasshopper SDK
GH_TooltipDisplayEventArgs..::..Diagram Property
GH_TooltipDisplayEventArgs Class See Also Send Feedback
Gets or sets the image that is displayed in the details section of the tooltip. This field is optional, but when it is defined, the Description property is ignored.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Bitmap Diagram { get; set; }
Visual Basic
Public Property Diagram As Bitmap
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_TooltipDisplayEventArgs.Diagram"]

See Also

GH_TooltipDisplayEventArgs Class
Grasshopper.GUI Namespace


Icon Property

[image]

Grasshopper SDK
GH_TooltipDisplayEventArgs..::..Icon Property
GH_TooltipDisplayEventArgs Class See Also Send Feedback
Gets or sets the icon that is displayed in the upper left hand corner of the tooltip. This field is optional.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Bitmap Icon { get; set; }
Visual Basic
Public Property Icon As Bitmap
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_TooltipDisplayEventArgs.Icon"]

See Also

GH_TooltipDisplayEventArgs Class
Grasshopper.GUI Namespace


Point Property

[image]

Grasshopper SDK
GH_TooltipDisplayEventArgs..::..Point Property
GH_TooltipDisplayEventArgs Class See Also Send Feedback
Gets the point in control coordinates for the tooltip locus.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Point Point { get; }
Visual Basic
Public ReadOnly Property Point As Point
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_TooltipDisplayEventArgs.Point"]

See Also

GH_TooltipDisplayEventArgs Class
Grasshopper.GUI Namespace


Region Property

[image]

Grasshopper SDK
GH_TooltipDisplayEventArgs..::..Region Property
GH_TooltipDisplayEventArgs Class See Also Send Feedback
Gets or sets the active region (in control coordinates) for this tooltip. Once a tooltip is shown inside the region, the tooltip will 'stick' to the mouse for as long as the mouse remains within this region. By default the region is set to Rectangle.Empty, which indicates that region tracking is not used for this tooltip.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle Region { get; set; }
Visual Basic
Public Property Region As Rectangle
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_TooltipDisplayEventArgs.Region"]

See Also

GH_TooltipDisplayEventArgs Class
Grasshopper.GUI Namespace


Text Property

[image]

Grasshopper SDK
GH_TooltipDisplayEventArgs..::..Text Property
GH_TooltipDisplayEventArgs Class See Also Send Feedback
Gets or sets the text of the tooltip. If you do not set the Text property, you must set the Title property or the tooltip will not be shown.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_TooltipDisplayEventArgs.Text"]

See Also

GH_TooltipDisplayEventArgs Class
Grasshopper.GUI Namespace


Title Property

[image]

Grasshopper SDK
GH_TooltipDisplayEventArgs..::..Title Property
GH_TooltipDisplayEventArgs Class See Also Send Feedback
Gets or sets the title of the tooltip. If you do not set the Title property, you must set the Text property or the tooltip will not be shown.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Title { get; set; }
Visual Basic
Public Property Title As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_TooltipDisplayEventArgs.Title"]

See Also

GH_TooltipDisplayEventArgs Class
Grasshopper.GUI Namespace


Valid Property

[image]

Grasshopper SDK
GH_TooltipDisplayEventArgs..::..Valid Property
GH_TooltipDisplayEventArgs Class See Also Send Feedback
Gets whether there is currently enough data to display a tooltip.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Valid { get; }
Visual Basic
Public ReadOnly Property Valid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_TooltipDisplayEventArgs.Valid"]

See Also

GH_TooltipDisplayEventArgs Class
Grasshopper.GUI Namespace


GH_TrackerFrame Structure

[image]

Grasshopper SDK
GH_TrackerFrame Structure
Members See Also Send Feedback
Represents a single frame in a mouse-tracker history. A frame represents all relevant mouse and keyboard data at a given time.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public struct GH_TrackerFrame
Visual Basic
Public Structure GH_TrackerFrame

See Also

GH_TrackerFrame Members
Grasshopper.GUI Namespace


GH_TrackerFrame Members

[image] [image]

Grasshopper SDK
GH_TrackerFrame Members
GH_TrackerFrame Structure Constructors Fields See Also Send Feedback

The GH_TrackerFrame type exposes the following members.

Constructors

 | Name | Description
Public method | GH_TrackerFrame | Initializes a new instance of the GH_TrackerFrame class

Fields

 | Name | Description
Public field | Buttons | The state of the mouse buttons of the frame.
Public field | Keys | The state of the modifier keys (Contro, Shift and Alt) of the frame.
Public field | PositionControl | The position (in control coordinates) of the frame.
Public field | PositionScreen | The position (in screen coordinates) of the frame.
Public field | Tag | Optional Tag object (to be supplied by user).
Public field | Time | The time at which this frame was recorded.

See Also

GH_TrackerFrame Structure
Grasshopper.GUI Namespace


GH_TrackerFrame Constructor

[image]

Grasshopper SDK
GH_TrackerFrame Constructor
GH_TrackerFrame Structure See Also Send Feedback
Initializes a new instance of the GH_TrackerFrame class

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_TrackerFrame(
    Point position
)
Visual Basic
Public Sub New ( _
    position As Point _
)

Parameters

position
Type: System.Drawing..::..Point

See Also

GH_TrackerFrame Structure
Grasshopper.GUI Namespace


GH_TrackerFrame Fields

[image] [image]

Grasshopper SDK
GH_TrackerFrame Fields
GH_TrackerFrame Structure See Also Send Feedback

The GH_TrackerFrame type exposes the following members.

Fields

 | Name | Description
Public field | Buttons | The state of the mouse buttons of the frame.
Public field | Keys | The state of the modifier keys (Contro, Shift and Alt) of the frame.
Public field | PositionControl | The position (in control coordinates) of the frame.
Public field | PositionScreen | The position (in screen coordinates) of the frame.
Public field | Tag | Optional Tag object (to be supplied by user).
Public field | Time | The time at which this frame was recorded.

See Also

GH_TrackerFrame Structure
Grasshopper.GUI Namespace


Buttons Field

[image]

Grasshopper SDK
GH_TrackerFrame..::..Buttons Field
GH_TrackerFrame Structure See Also Send Feedback
The state of the mouse buttons of the frame.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public MouseButtons Buttons
Visual Basic
Public Buttons As MouseButtons

See Also

GH_TrackerFrame Structure
Grasshopper.GUI Namespace


Keys Field

[image]

Grasshopper SDK
GH_TrackerFrame..::..Keys Field
GH_TrackerFrame Structure See Also Send Feedback
The state of the modifier keys (Contro, Shift and Alt) of the frame.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Keys Keys
Visual Basic
Public Keys As Keys

See Also

GH_TrackerFrame Structure
Grasshopper.GUI Namespace


PositionControl Field

[image]

Grasshopper SDK
GH_TrackerFrame..::..PositionControl Field
GH_TrackerFrame Structure See Also Send Feedback
The position (in control coordinates) of the frame.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Point PositionControl
Visual Basic
Public PositionControl As Point

See Also

GH_TrackerFrame Structure
Grasshopper.GUI Namespace


PositionScreen Field

[image]

Grasshopper SDK
GH_TrackerFrame..::..PositionScreen Field
GH_TrackerFrame Structure See Also Send Feedback
The position (in screen coordinates) of the frame.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Point PositionScreen
Visual Basic
Public PositionScreen As Point

See Also

GH_TrackerFrame Structure
Grasshopper.GUI Namespace


Tag Field

[image]

Grasshopper SDK
GH_TrackerFrame..::..Tag Field
GH_TrackerFrame Structure See Also Send Feedback
Optional Tag object (to be supplied by user).

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Object Tag
Visual Basic
Public Tag As Object

See Also

GH_TrackerFrame Structure
Grasshopper.GUI Namespace


Time Field

[image]

Grasshopper SDK
GH_TrackerFrame..::..Time Field
GH_TrackerFrame Structure See Also Send Feedback
The time at which this frame was recorded.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public DateTime Time
Visual Basic
Public Time As DateTime

See Also

GH_TrackerFrame Structure
Grasshopper.GUI Namespace


GH_UnrecognizedObjectsForm Class

[image]

Grasshopper SDK
GH_UnrecognizedObjectsForm Class
Members See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_UnrecognizedObjectsForm : Form
Visual Basic
Public Class GH_UnrecognizedObjectsForm _
    Inherits Form

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
Grasshopper.GUI..::..GH_UnrecognizedObjectsForm

See Also

GH_UnrecognizedObjectsForm Members
Grasshopper.GUI Namespace


GH_UnrecognizedObjectsForm Members

[image] [image]

Grasshopper SDK
GH_UnrecognizedObjectsForm Members
GH_UnrecognizedObjectsForm Class Constructors Methods See Also Send Feedback

The GH_UnrecognizedObjectsForm type exposes the following members.

Constructors

 | Name | Description
Public method | GH_UnrecognizedObjectsForm | Initializes a new instance of the GH_UnrecognizedObjectsForm class

Methods

 | Name | Description
Protected method | Dispose | Releases the unmanaged resources used by the GH_UnrecognizedObjectsForm and optionally releases the managed resources (Overrides Form..::..Dispose(Boolean).)

See Also

GH_UnrecognizedObjectsForm Class
Grasshopper.GUI Namespace


GH_UnrecognizedObjectsForm Constructor

[image]

Grasshopper SDK
GH_UnrecognizedObjectsForm Constructor
GH_UnrecognizedObjectsForm Class See Also Send Feedback
Initializes a new instance of the GH_UnrecognizedObjectsForm class

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_UnrecognizedObjectsForm()
Visual Basic
Public Sub New

See Also

GH_UnrecognizedObjectsForm Class
Grasshopper.GUI Namespace


GH_UnrecognizedObjectsForm Methods

[image] [image]

Grasshopper SDK
GH_UnrecognizedObjectsForm Methods
GH_UnrecognizedObjectsForm Class See Also Send Feedback

The GH_UnrecognizedObjectsForm type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | (Overrides Form..::..Dispose(Boolean).)

See Also

GH_UnrecognizedObjectsForm Class
Grasshopper.GUI Namespace


Dispose Method

[image]

Grasshopper SDK
GH_UnrecognizedObjectsForm..::..Dispose Method
GH_UnrecognizedObjectsForm Class See Also Send Feedback
Releases the unmanaged resources used by the GH_UnrecognizedObjectsForm and optionally releases the managed resources

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

GH_UnrecognizedObjectsForm Class
Grasshopper.GUI Namespace


GH_VerticalScrollBar Class

[image]

Grasshopper SDK
GH_VerticalScrollBar Class
Members See Also Send Feedback
Scroll bar control with floating point accuracy.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_VerticalScrollBar : GH_DoubleBufferedPanel
Visual Basic
Public Class GH_VerticalScrollBar _
    Inherits GH_DoubleBufferedPanel

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..Panel
Grasshopper.GUI..::..GH_DoubleBufferedPanel
Grasshopper.GUI..::..GH_VerticalScrollBar

See Also

GH_VerticalScrollBar Members
Grasshopper.GUI Namespace


GH_VerticalScrollBar Members

[image] [image]

Grasshopper SDK
GH_VerticalScrollBar Members
GH_VerticalScrollBar Class Constructors Methods Properties Events See Also Send Feedback

The GH_VerticalScrollBar type exposes the following members.

Constructors

 | Name | Description
Public method | GH_VerticalScrollBar | Initializes a new instance of the GH_VerticalScrollBar class

Methods

 | Name | Description
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | (Overrides ScrollableControl..::..OnPaintBackground(PaintEventArgs).)

Properties

 | Name | Description
Public property | Grip | Gets the actual dimensions of the scroll bar grip.
Public property | GripRegion | Gets the grip region for this scroll bar. The Grip Region is the area in which the grip can be found. It is essentially the Client area minus the padding.
Public property | ImpliedVerticalOffset | Gets or sets the offset of the target region as implied by the scroll ratio. If you set this value, the ratio is reverse engineered.
Public property | ScreenHeight | Gets or sets the height of the screen area (the visible area)
Public property | TargetHeight | Gets or sets the height of the target area (the area being scrolled)
Public property | TargetRatio | Gets or sets the scroll ration. If the scroll ratio is changed, the OnScrollRatioChanged event will be raised.

Events

 | Name | Description
Public event | ScrollRatioChanged |

See Also

GH_VerticalScrollBar Class
Grasshopper.GUI Namespace


GH_VerticalScrollBar Constructor

[image]

Grasshopper SDK
GH_VerticalScrollBar Constructor
GH_VerticalScrollBar Class See Also Send Feedback
Initializes a new instance of the GH_VerticalScrollBar class

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_VerticalScrollBar()
Visual Basic
Public Sub New

See Also

GH_VerticalScrollBar Class
Grasshopper.GUI Namespace


GH_VerticalScrollBar Methods

[image] [image]

Grasshopper SDK
GH_VerticalScrollBar Methods
GH_VerticalScrollBar Class See Also Send Feedback

The GH_VerticalScrollBar type exposes the following members.

Methods

 | Name | Description
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | (Overrides ScrollableControl..::..OnPaintBackground(PaintEventArgs).)

See Also

GH_VerticalScrollBar Class
Grasshopper.GUI Namespace


OnPaint Method

[image]

Grasshopper SDK
GH_VerticalScrollBar..::..OnPaint Method
GH_VerticalScrollBar Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

GH_VerticalScrollBar Class
Grasshopper.GUI Namespace


OnPaintBackground Method

[image]

Grasshopper SDK
GH_VerticalScrollBar..::..OnPaintBackground Method
GH_VerticalScrollBar Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void OnPaintBackground(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaintBackground ( _
    e As PaintEventArgs _
)

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

GH_VerticalScrollBar Class
Grasshopper.GUI Namespace


GH_VerticalScrollBar Properties

[image] [image]

Grasshopper SDK
GH_VerticalScrollBar Properties
GH_VerticalScrollBar Class See Also Send Feedback

The GH_VerticalScrollBar type exposes the following members.

Properties

 | Name | Description
Public property | Grip | Gets the actual dimensions of the scroll bar grip.
Public property | GripRegion | Gets the grip region for this scroll bar. The Grip Region is the area in which the grip can be found. It is essentially the Client area minus the padding.
Public property | ImpliedVerticalOffset | Gets or sets the offset of the target region as implied by the scroll ratio. If you set this value, the ratio is reverse engineered.
Public property | ScreenHeight | Gets or sets the height of the screen area (the visible area)
Public property | TargetHeight | Gets or sets the height of the target area (the area being scrolled)
Public property | TargetRatio | Gets or sets the scroll ration. If the scroll ratio is changed, the OnScrollRatioChanged event will be raised.

See Also

GH_VerticalScrollBar Class
Grasshopper.GUI Namespace


Grip Property

[image]

Grasshopper SDK
GH_VerticalScrollBar..::..Grip Property
GH_VerticalScrollBar Class See Also Send Feedback
Gets the actual dimensions of the scroll bar grip.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle Grip { get; }
Visual Basic
Public ReadOnly Property Grip As Rectangle
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_VerticalScrollBar.Grip"]

See Also

GH_VerticalScrollBar Class
Grasshopper.GUI Namespace


GripRegion Property

[image]

Grasshopper SDK
GH_VerticalScrollBar..::..GripRegion Property
GH_VerticalScrollBar Class See Also Send Feedback
Gets the grip region for this scroll bar. The Grip Region is the area in which the grip can be found. It is essentially the Client area minus the padding.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle GripRegion { get; }
Visual Basic
Public ReadOnly Property GripRegion As Rectangle
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_VerticalScrollBar.GripRegion"]

See Also

GH_VerticalScrollBar Class
Grasshopper.GUI Namespace


ImpliedVerticalOffset Property

[image]

Grasshopper SDK
GH_VerticalScrollBar..::..ImpliedVerticalOffset Property
GH_VerticalScrollBar Class See Also Send Feedback
Gets or sets the offset of the target region as implied by the scroll ratio. If you set this value, the ratio is reverse engineered.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int ImpliedVerticalOffset { get; set; }
Visual Basic
Public Property ImpliedVerticalOffset As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_VerticalScrollBar.ImpliedVerticalOffset"]

See Also

GH_VerticalScrollBar Class
Grasshopper.GUI Namespace


ScreenHeight Property

[image]

Grasshopper SDK
GH_VerticalScrollBar..::..ScreenHeight Property
GH_VerticalScrollBar Class See Also Send Feedback
Gets or sets the height of the screen area (the visible area)

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int ScreenHeight { get; set; }
Visual Basic
Public Property ScreenHeight As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_VerticalScrollBar.ScreenHeight"]

See Also

GH_VerticalScrollBar Class
Grasshopper.GUI Namespace


TargetHeight Property

[image]

Grasshopper SDK
GH_VerticalScrollBar..::..TargetHeight Property
GH_VerticalScrollBar Class See Also Send Feedback
Gets or sets the height of the target area (the area being scrolled)

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int TargetHeight { get; set; }
Visual Basic
Public Property TargetHeight As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_VerticalScrollBar.TargetHeight"]

See Also

GH_VerticalScrollBar Class
Grasshopper.GUI Namespace


TargetRatio Property

[image]

Grasshopper SDK
GH_VerticalScrollBar..::..TargetRatio Property
GH_VerticalScrollBar Class See Also Send Feedback
Gets or sets the scroll ration. If the scroll ratio is changed, the OnScrollRatioChanged event will be raised.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double TargetRatio { get; set; }
Visual Basic
Public Property TargetRatio As Double
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.GH_VerticalScrollBar.TargetRatio"]

See Also

GH_VerticalScrollBar Class
Grasshopper.GUI Namespace


GH_VerticalScrollBar Events

[image] [image]

Grasshopper SDK
GH_VerticalScrollBar Events
GH_VerticalScrollBar Class See Also Send Feedback

The GH_VerticalScrollBar type exposes the following members.

Events

 | Name | Description
Public event | ScrollRatioChanged |

See Also

GH_VerticalScrollBar Class
Grasshopper.GUI Namespace


ScrollRatioChanged Event

[image]

Grasshopper SDK
GH_VerticalScrollBar..::..ScrollRatioChanged Event
GH_VerticalScrollBar Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_VerticalScrollBar..::..ScrollRatioChangedEventHandler ScrollRatioChanged
Visual Basic
Public Event ScrollRatioChanged As GH_VerticalScrollBar..::..ScrollRatioChangedEventHandler

See Also

GH_VerticalScrollBar Class
Grasshopper.GUI Namespace


GH_VerticalScrollBar.ScrollRatioChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_VerticalScrollBar..::..ScrollRatioChangedEventHandler Delegate
GH_VerticalScrollBar Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void ScrollRatioChangedEventHandler(
    GH_VerticalScrollBar sender,
    double ratio
)
Visual Basic
Public Delegate Sub ScrollRatioChangedEventHandler ( _
    sender As GH_VerticalScrollBar, _
    ratio As Double _
)

Parameters

sender
Type: Grasshopper.GUI..::..GH_VerticalScrollBar
ratio
Type: System..::..Double

See Also

Grasshopper.GUI Namespace


GH_VerticalSeparator Class

[image]

Grasshopper SDK
GH_VerticalSeparator Class
Members See Also Send Feedback
GUI elements for creating visual separations.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_VerticalSeparator : GH_DoubleBufferedPanel
Visual Basic
Public Class GH_VerticalSeparator _
    Inherits GH_DoubleBufferedPanel

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..Panel
Grasshopper.GUI..::..GH_DoubleBufferedPanel
Grasshopper.GUI..::..GH_VerticalSeparator

See Also

GH_VerticalSeparator Members
Grasshopper.GUI Namespace


GH_VerticalSeparator Members

[image] [image]

Grasshopper SDK
GH_VerticalSeparator Members
GH_VerticalSeparator Class Constructors Methods See Also Send Feedback

The GH_VerticalSeparator type exposes the following members.

Constructors

 | Name | Description
Public method | GH_VerticalSeparator | Initializes a new instance of the GH_VerticalSeparator class

Methods

 | Name | Description
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | (Overrides ScrollableControl..::..OnPaintBackground(PaintEventArgs).)

See Also

GH_VerticalSeparator Class
Grasshopper.GUI Namespace


GH_VerticalSeparator Constructor

[image]

Grasshopper SDK
GH_VerticalSeparator Constructor
GH_VerticalSeparator Class See Also Send Feedback
Initializes a new instance of the GH_VerticalSeparator class

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_VerticalSeparator()
Visual Basic
Public Sub New

See Also

GH_VerticalSeparator Class
Grasshopper.GUI Namespace


GH_VerticalSeparator Methods

[image] [image]

Grasshopper SDK
GH_VerticalSeparator Methods
GH_VerticalSeparator Class See Also Send Feedback

The GH_VerticalSeparator type exposes the following members.

Methods

 | Name | Description
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | (Overrides ScrollableControl..::..OnPaintBackground(PaintEventArgs).)

See Also

GH_VerticalSeparator Class
Grasshopper.GUI Namespace


OnPaint Method

[image]

Grasshopper SDK
GH_VerticalSeparator..::..OnPaint Method
GH_VerticalSeparator Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

GH_VerticalSeparator Class
Grasshopper.GUI Namespace


OnPaintBackground Method

[image]

Grasshopper SDK
GH_VerticalSeparator..::..OnPaintBackground Method
GH_VerticalSeparator Class See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void OnPaintBackground(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaintBackground ( _
    e As PaintEventArgs _
)

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

GH_VerticalSeparator Class
Grasshopper.GUI Namespace


GH_VoronoiWarningForm Class

[image]

Grasshopper SDK
GH_VoronoiWarningForm Class
Members See Also Send Feedback

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_VoronoiWarningForm : Form
Visual Basic
Public Class GH_VoronoiWarningForm _
    Inherits Form

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
Grasshopper.GUI..::..GH_VoronoiWarningForm

See Also

GH_VoronoiWarningForm Members
Grasshopper.GUI Namespace


GH_VoronoiWarningForm Members

[image] [image]

Grasshopper SDK
GH_VoronoiWarningForm Members
GH_VoronoiWarningForm Class Constructors Methods See Also Send Feedback

The GH_VoronoiWarningForm type exposes the following members.

Constructors

 | Name | Description
Public method | GH_VoronoiWarningForm | Initializes a new instance of the GH_VoronoiWarningForm class

Methods

 | Name | Description
Protected method | Dispose | Releases the unmanaged resources used by the GH_VoronoiWarningForm and optionally releases the managed resources (Overrides Form..::..Dispose(Boolean).)

See Also

GH_VoronoiWarningForm Class
Grasshopper.GUI Namespace


GH_VoronoiWarningForm Constructor

[image]

Grasshopper SDK
GH_VoronoiWarningForm Constructor
GH_VoronoiWarningForm Class See Also Send Feedback
Initializes a new instance of the GH_VoronoiWarningForm class

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_VoronoiWarningForm()
Visual Basic
Public Sub New

See Also

GH_VoronoiWarningForm Class
Grasshopper.GUI Namespace


GH_VoronoiWarningForm Methods

[image] [image]

Grasshopper SDK
GH_VoronoiWarningForm Methods
GH_VoronoiWarningForm Class See Also Send Feedback

The GH_VoronoiWarningForm type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | (Overrides Form..::..Dispose(Boolean).)

See Also

GH_VoronoiWarningForm Class
Grasshopper.GUI Namespace


Dispose Method

[image]

Grasshopper SDK
GH_VoronoiWarningForm..::..Dispose Method
GH_VoronoiWarningForm Class See Also Send Feedback
Releases the unmanaged resources used by the GH_VoronoiWarningForm and optionally releases the managed resources

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

GH_VoronoiWarningForm Class
Grasshopper.GUI Namespace


GH_WindowsControlUtil Class

[image]

Grasshopper SDK
GH_WindowsControlUtil Class
Members See Also Send Feedback
Exposes some static (Shared) utility functions for setting text-rendering properties en masse.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class GH_WindowsControlUtil
Visual Basic
Public NotInheritable Class GH_WindowsControlUtil

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI..::..GH_WindowsControlUtil

See Also

GH_WindowsControlUtil Members
Grasshopper.GUI Namespace


GH_WindowsControlUtil Members

[image] [image]

Grasshopper SDK
GH_WindowsControlUtil Members
GH_WindowsControlUtil Class Methods See Also Send Feedback

Methods

Name | Description
FixTextRenderingDefault(Control) | Sets the UseCompatibleTextRendering value to False on the control.
FixTextRenderingDefault(Control..::..ControlCollection) | Recursively sets the UseCompatibleTextRendering value to False on each control.

See Also

GH_WindowsControlUtil Class
Grasshopper.GUI Namespace


GH_WindowsControlUtil Methods

[image] [image]

Grasshopper SDK
GH_WindowsControlUtil Methods
GH_WindowsControlUtil Class See Also Send Feedback

Methods

Name | Description
FixTextRenderingDefault(Control) | Sets the UseCompatibleTextRendering value to False on the control.
FixTextRenderingDefault(Control..::..ControlCollection) | Recursively sets the UseCompatibleTextRendering value to False on each control.

See Also

GH_WindowsControlUtil Class
Grasshopper.GUI Namespace


FixTextRenderingDefault Method

[image] [image]

Grasshopper SDK
GH_WindowsControlUtil..::..FixTextRenderingDefault Method
GH_WindowsControlUtil Class See Also Send Feedback

Overload List

Name | Description
FixTextRenderingDefault(Control) | Sets the UseCompatibleTextRendering value to False on the control.
FixTextRenderingDefault(Control..::..ControlCollection) | Recursively sets the UseCompatibleTextRendering value to False on each control.

See Also

GH_WindowsControlUtil Class
GH_WindowsControlUtil Members
Grasshopper.GUI Namespace


FixTextRenderingDefault Method (Control)

[image]

Grasshopper SDK
GH_WindowsControlUtil..::..FixTextRenderingDefault Method (Control)
GH_WindowsControlUtil Class See Also Send Feedback
Sets the UseCompatibleTextRendering value to False on the control.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void FixTextRenderingDefault(
    Control control
)
Visual Basic
Public Shared Sub FixTextRenderingDefault ( _
    control As Control _
)

Parameters

control
Type: System.Windows.Forms..::..Control

See Also

GH_WindowsControlUtil Class
FixTextRenderingDefault Overload
Grasshopper.GUI Namespace


FixTextRenderingDefault Method (Control.ControlCollection)

[image]

Grasshopper SDK
GH_WindowsControlUtil..::..FixTextRenderingDefault Method (Control..::..ControlCollection)
GH_WindowsControlUtil Class Example See Also Send Feedback
Recursively sets the UseCompatibleTextRendering value to False on each control.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void FixTextRenderingDefault(
    Control..::..ControlCollection iControls
)
Visual Basic
Public Shared Sub FixTextRenderingDefault ( _
    iControls As Control..::..ControlCollection _
)

Parameters

iControls
Type: System.Windows.Forms..::..Control..::..ControlCollection

Examples

This example shows how to use this function to modify all the controls on a windows Form.
CopyVB.NET
Dim frm As New MyVerySpecialForm()
Grasshopper.GUI.GH_WindowsControlUtil.FixTextRenderingDefault(frm.Controls)

frm.Show()

See Also

GH_WindowsControlUtil Class
FixTextRenderingDefault Overload
Grasshopper.GUI Namespace


GH_WindowsFormUtil Class

[image]

Grasshopper SDK
GH_WindowsFormUtil Class
Members See Also Send Feedback
Exposes some static (Shared) utility functions for positioning custom windows.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class GH_WindowsFormUtil
Visual Basic
Public NotInheritable Class GH_WindowsFormUtil

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI..::..GH_WindowsFormUtil

See Also

GH_WindowsFormUtil Members
Grasshopper.GUI Namespace


GH_WindowsFormUtil Members

[image] [image]

Grasshopper SDK
GH_WindowsFormUtil Members
GH_WindowsFormUtil Class Methods See Also Send Feedback

The GH_WindowsFormUtil type exposes the following members.

Methods

Name | Description
CenterFormOnCursor | Positions a Form so that it is centered around the cursor
CenterFormOnEditor | Positions a Form so that it is centered on the active editor. If the editor doesn't exist or is hidden, the form will be centered on the screen instead.
CenterFormOnScreen | Positions a Form so that it is centered on the current screen. The current screen being defined as the screen containing the cursor.
CenterFormOnWindow | Positions a Form so that it is centered on the supplied window. If the window doesn't exist or is hidden, the form will be centered on the screen instead.

See Also

GH_WindowsFormUtil Class
Grasshopper.GUI Namespace


GH_WindowsFormUtil Methods

[image] [image]

Grasshopper SDK
GH_WindowsFormUtil Methods
GH_WindowsFormUtil Class See Also Send Feedback

The GH_WindowsFormUtil type exposes the following members.

Methods

Name | Description
CenterFormOnCursor | Positions a Form so that it is centered around the cursor
CenterFormOnEditor | Positions a Form so that it is centered on the active editor. If the editor doesn't exist or is hidden, the form will be centered on the screen instead.
CenterFormOnScreen | Positions a Form so that it is centered on the current screen. The current screen being defined as the screen containing the cursor.
CenterFormOnWindow | Positions a Form so that it is centered on the supplied window. If the window doesn't exist or is hidden, the form will be centered on the screen instead.

See Also

GH_WindowsFormUtil Class
Grasshopper.GUI Namespace


CenterFormOnCursor Method

[image]

Grasshopper SDK
GH_WindowsFormUtil..::..CenterFormOnCursor Method
GH_WindowsFormUtil Class See Also Send Feedback
Positions a Form so that it is centered around the cursor

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void CenterFormOnCursor(
    Form F,
    bool limitToScreen
)
Visual Basic
Public Shared Sub CenterFormOnCursor ( _
    F As Form, _
    limitToScreen As Boolean _
)

Parameters

F
Type: System.Windows.Forms..::..Form
The Form to adjust
limitToScreen
Type: System..::..Boolean
If True, the Form won't be allowed to extend beyond the limits of the screen containing the cursor.

See Also

GH_WindowsFormUtil Class
Grasshopper.GUI Namespace


CenterFormOnEditor Method

[image]

Grasshopper SDK
GH_WindowsFormUtil..::..CenterFormOnEditor Method
GH_WindowsFormUtil Class See Also Send Feedback
Positions a Form so that it is centered on the active editor. If the editor doesn't exist or is hidden, the form will be centered on the screen instead.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void CenterFormOnEditor(
    Form F,
    bool limitToScreen
)
Visual Basic
Public Shared Sub CenterFormOnEditor ( _
    F As Form, _
    limitToScreen As Boolean _
)

Parameters

F
Type: System.Windows.Forms..::..Form
The Form to adjust
limitToScreen
Type: System..::..Boolean
If True, the Form won't be allowed to extend beyond the limits of the screen containing the cursor.

See Also

GH_WindowsFormUtil Class
Grasshopper.GUI Namespace


CenterFormOnScreen Method

[image]

Grasshopper SDK
GH_WindowsFormUtil..::..CenterFormOnScreen Method
GH_WindowsFormUtil Class See Also Send Feedback
Positions a Form so that it is centered on the current screen. The current screen being defined as the screen containing the cursor.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void CenterFormOnScreen(
    Form F,
    bool limitToScreen
)
Visual Basic
Public Shared Sub CenterFormOnScreen ( _
    F As Form, _
    limitToScreen As Boolean _
)

Parameters

F
Type: System.Windows.Forms..::..Form
The Form to adjust
limitToScreen
Type: System..::..Boolean
If True, the Form won't be allowed to extend beyond the limits of the active screen.

See Also

GH_WindowsFormUtil Class
Grasshopper.GUI Namespace


CenterFormOnWindow Method

[image]

Grasshopper SDK
GH_WindowsFormUtil..::..CenterFormOnWindow Method
GH_WindowsFormUtil Class See Also Send Feedback
Positions a Form so that it is centered on the supplied window. If the window doesn't exist or is hidden, the form will be centered on the screen instead.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void CenterFormOnWindow(
    Form F,
    Form parentWindow,
    bool limitToScreen
)
Visual Basic
Public Shared Sub CenterFormOnWindow ( _
    F As Form, _
    parentWindow As Form, _
    limitToScreen As Boolean _
)

Parameters

F
Type: System.Windows.Forms..::..Form
The Form to adjust
parentWindow
Type: System.Windows.Forms..::..Form
limitToScreen
Type: System..::..Boolean
If True, the Form won't be allowed to extend beyond the limits of the screen containing the cursor.

See Also

GH_WindowsFormUtil Class
Grasshopper.GUI Namespace


IGH_Embeddable Interface

[image]

Grasshopper SDK
IGH_Embeddable Interface
Members See Also Send Feedback
Implement this interface in your custom control if you want to be called before a menu commits or cancels.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_Embeddable
Visual Basic
Public Interface IGH_Embeddable

See Also

IGH_Embeddable Members
Grasshopper.GUI Namespace


IGH_Embeddable Members

[image] [image]

Grasshopper SDK
IGH_Embeddable Members
IGH_Embeddable Interface Methods See Also Send Feedback

The IGH_Embeddable type exposes the following members.

Methods

 | Name | Description
Public method | PrepareForCancel | This will be called prior to a Cancel operation.
Public method | PrepareForCommit | This will be called prior to a Commit operation.

See Also

IGH_Embeddable Interface
Grasshopper.GUI Namespace


IGH_Embeddable Methods

[image] [image]

Grasshopper SDK
IGH_Embeddable Methods
IGH_Embeddable Interface See Also Send Feedback

The IGH_Embeddable type exposes the following members.

Methods

 | Name | Description
Public method | PrepareForCancel | This will be called prior to a Cancel operation.
Public method | PrepareForCommit | This will be called prior to a Commit operation.

See Also

IGH_Embeddable Interface
Grasshopper.GUI Namespace


PrepareForCancel Method

[image]

Grasshopper SDK
IGH_Embeddable..::..PrepareForCancel Method
IGH_Embeddable Interface See Also Send Feedback
This will be called prior to a Cancel operation.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void PrepareForCancel()
Visual Basic
Sub PrepareForCancel

See Also

IGH_Embeddable Interface
Grasshopper.GUI Namespace


PrepareForCommit Method

[image]

Grasshopper SDK
IGH_Embeddable..::..PrepareForCommit Method
IGH_Embeddable Interface See Also Send Feedback
This will be called prior to a Commit operation.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void PrepareForCommit()
Visual Basic
Sub PrepareForCommit

See Also

IGH_Embeddable Interface
Grasshopper.GUI Namespace


IGH_FileDropTarget Interface

[image]

Grasshopper SDK
IGH_FileDropTarget Interface
Members See Also Send Feedback
Implement this interface in your IGH_DocumentObject if you want to participate in Drag+Drop events.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_FileDropTarget
Visual Basic
Public Interface IGH_FileDropTarget

See Also

IGH_FileDropTarget Members
Grasshopper.GUI Namespace


IGH_FileDropTarget Members

[image] [image]

Grasshopper SDK
IGH_FileDropTarget Members
IGH_FileDropTarget Interface Methods See Also Send Feedback

The IGH_FileDropTarget type exposes the following members.

Methods

 | Name | Description
Public method | AcceptableFile | Gets a value indicating whether or not the path can be handled by the local object.
Public method | HandleDrop | Handle a file drop.

See Also

IGH_FileDropTarget Interface
Grasshopper.GUI Namespace


IGH_FileDropTarget Methods

[image] [image]

Grasshopper SDK
IGH_FileDropTarget Methods
IGH_FileDropTarget Interface See Also Send Feedback

The IGH_FileDropTarget type exposes the following members.

Methods

 | Name | Description
Public method | AcceptableFile | Gets a value indicating whether or not the path can be handled by the local object.
Public method | HandleDrop | Handle a file drop.

See Also

IGH_FileDropTarget Interface
Grasshopper.GUI Namespace


AcceptableFile Method

[image]

Grasshopper SDK
IGH_FileDropTarget..::..AcceptableFile Method
IGH_FileDropTarget Interface See Also Send Feedback
Gets a value indicating whether or not the path can be handled by the local object.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool AcceptableFile(
    string path
)
Visual Basic
Function AcceptableFile ( _
    path As String _
) As Boolean

Parameters

path
Type: System..::..String
Path to file in question.

Return Value

True if the file can be handled, false if otherwise.

See Also

IGH_FileDropTarget Interface
Grasshopper.GUI Namespace


HandleDrop Method

[image]

Grasshopper SDK
IGH_FileDropTarget..::..HandleDrop Method
IGH_FileDropTarget Interface See Also Send Feedback
Handle a file drop.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool HandleDrop(
    string path,
    PointF mouse_pt
)
Visual Basic
Function HandleDrop ( _
    path As String, _
    mouse_pt As PointF _
) As Boolean

Parameters

path
Type: System..::..String
Path of file to handle.
mouse_pt
Type: System.Drawing..::..PointF
Point at which the drop occured.

Return Value

True on success, false on failure.

See Also

IGH_FileDropTarget Interface
Grasshopper.GUI Namespace


IGH_SettingCategory Interface

[image]

Grasshopper SDK
IGH_SettingCategory Interface
Members See Also Send Feedback
Represents a single category in the Settings UI. Implement this interface or derive from GH_SettingsCategory to add a new Category to the Grasshopper Settings interface.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_SettingCategory
Visual Basic
Public Interface IGH_SettingCategory

See Also

IGH_SettingCategory Members
Grasshopper.GUI Namespace


IGH_SettingCategory Members

[image] [image]

Grasshopper SDK
IGH_SettingCategory Members
IGH_SettingCategory Interface Properties See Also Send Feedback

The IGH_SettingCategory type exposes the following members.

Properties

 | Name | Description
Public property | Description | Category description.
Public property | Icon | Category icon. Image should be 48x48 pixels.
Public property | Name | Category name (not case sensitive). Use dots to separate subcategories.
Public property | Parent | Gets the name of the parent category. If the category is supposed to be top-level, this property will return null or a String.Empty.

See Also

IGH_SettingCategory Interface
Grasshopper.GUI Namespace


IGH_SettingCategory Properties

[image] [image]

Grasshopper SDK
IGH_SettingCategory Properties
IGH_SettingCategory Interface See Also Send Feedback

The IGH_SettingCategory type exposes the following members.

Properties

 | Name | Description
Public property | Description | Category description.
Public property | Icon | Category icon. Image should be 48x48 pixels.
Public property | Name | Category name (not case sensitive). Use dots to separate subcategories.
Public property | Parent | Gets the name of the parent category. If the category is supposed to be top-level, this property will return null or a String.Empty.

See Also

IGH_SettingCategory Interface
Grasshopper.GUI Namespace


Description Property

[image]

Grasshopper SDK
IGH_SettingCategory..::..Description Property
IGH_SettingCategory Interface See Also Send Feedback
Category description.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string Description { get; }
Visual Basic
ReadOnly Property Description As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.IGH_SettingCategory.Description"]

See Also

IGH_SettingCategory Interface
Grasshopper.GUI Namespace


Icon Property

[image]

Grasshopper SDK
IGH_SettingCategory..::..Icon Property
IGH_SettingCategory Interface See Also Send Feedback
Category icon. Image should be 48x48 pixels.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
Bitmap Icon { get; }
Visual Basic
ReadOnly Property Icon As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.IGH_SettingCategory.Icon"]

See Also

IGH_SettingCategory Interface
Grasshopper.GUI Namespace


Name Property

[image]

Grasshopper SDK
IGH_SettingCategory..::..Name Property
IGH_SettingCategory Interface See Also Send Feedback
Category name (not case sensitive). Use dots to separate subcategories.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string Name { get; }
Visual Basic
ReadOnly Property Name As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.IGH_SettingCategory.Name"]

See Also

IGH_SettingCategory Interface
Grasshopper.GUI Namespace


Parent Property

[image]

Grasshopper SDK
IGH_SettingCategory..::..Parent Property
IGH_SettingCategory Interface See Also Send Feedback
Gets the name of the parent category. If the category is supposed to be top-level, this property will return null or a String.Empty.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string Parent { get; }
Visual Basic
ReadOnly Property Parent As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.IGH_SettingCategory.Parent"]

See Also

IGH_SettingCategory Interface
Grasshopper.GUI Namespace


IGH_SettingFrontend Interface

[image]

Grasshopper SDK
IGH_SettingFrontend Interface
Members See Also Send Feedback
Represents a single setting in the Settings UI. Implement this interface to participate in the Grasshopper Settings interface.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_SettingFrontend
Visual Basic
Public Interface IGH_SettingFrontend

See Also

IGH_SettingFrontend Members
Grasshopper.GUI Namespace


IGH_SettingFrontend Members

[image] [image]

Grasshopper SDK
IGH_SettingFrontend Members
IGH_SettingFrontend Interface Methods Properties See Also Send Feedback

The IGH_SettingFrontend type exposes the following members.

Methods

 | Name | Description
Public method | SettingsUI | Create the winforms UI portion for this setting.

Properties

 | Name | Description
Public property | Category | Category of this setting.
Public property | Keywords | Optional keywords for this setting.
Public property | Name | Name of this setting.

See Also

IGH_SettingFrontend Interface
Grasshopper.GUI Namespace


IGH_SettingFrontend Methods

[image] [image]

Grasshopper SDK
IGH_SettingFrontend Methods
IGH_SettingFrontend Interface See Also Send Feedback

The IGH_SettingFrontend type exposes the following members.

Methods

 | Name | Description
Public method | SettingsUI | Create the winforms UI portion for this setting.

See Also

IGH_SettingFrontend Interface
Grasshopper.GUI Namespace


SettingsUI Method

[image]

Grasshopper SDK
IGH_SettingFrontend..::..SettingsUI Method
IGH_SettingFrontend Interface See Also Send Feedback
Create the winforms UI portion for this setting.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
Control SettingsUI()
Visual Basic
Function SettingsUI As Control

See Also

IGH_SettingFrontend Interface
Grasshopper.GUI Namespace


IGH_SettingFrontend Properties

[image] [image]

Grasshopper SDK
IGH_SettingFrontend Properties
IGH_SettingFrontend Interface See Also Send Feedback

The IGH_SettingFrontend type exposes the following members.

Properties

 | Name | Description
Public property | Category | Category of this setting.
Public property | Keywords | Optional keywords for this setting.
Public property | Name | Name of this setting.

See Also

IGH_SettingFrontend Interface
Grasshopper.GUI Namespace


Category Property

[image]

Grasshopper SDK
IGH_SettingFrontend..::..Category Property
IGH_SettingFrontend Interface See Also Send Feedback
Category of this setting.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string Category { get; }
Visual Basic
ReadOnly Property Category As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.IGH_SettingFrontend.Category"]

See Also

IGH_SettingFrontend Interface
Grasshopper.GUI Namespace


Keywords Property

[image]

Grasshopper SDK
IGH_SettingFrontend..::..Keywords Property
IGH_SettingFrontend Interface See Also Send Feedback
Optional keywords for this setting.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
IEnumerable<string> Keywords { get; }
Visual Basic
ReadOnly Property Keywords As IEnumerable(Of String)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.IGH_SettingFrontend.Keywords"]

See Also

IGH_SettingFrontend Interface
Grasshopper.GUI Namespace


Name Property

[image]

Grasshopper SDK
IGH_SettingFrontend..::..Name Property
IGH_SettingFrontend Interface See Also Send Feedback
Name of this setting.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string Name { get; }
Visual Basic
ReadOnly Property Name As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.IGH_SettingFrontend.Name"]

See Also

IGH_SettingFrontend Interface
Grasshopper.GUI Namespace


IGH_Tooltip Interface

[image]

Grasshopper SDK
IGH_Tooltip Interface
Members See Also Send Feedback
Accessor interface for the Grasshopper Tooltip form.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_Tooltip
Visual Basic
Public Interface IGH_Tooltip

See Also

IGH_Tooltip Members
Grasshopper.GUI Namespace


IGH_Tooltip Members

[image] [image]

Grasshopper SDK
IGH_Tooltip Members
IGH_Tooltip Interface Properties See Also Send Feedback

The IGH_Tooltip type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets or sets the tooltip Description. The Description is optional and is displayed in the same area as the TooltipDiagram image.
Public property | Diagram | Sets the tooltip diagram image. The diagram image is optional and is displayed in the same area as the ToolTipDescription text.
Public property | Icon | Sets the Tooltip Icon image.
Public property | Palette | Gets or sets the tooltip colour palette.
Public property | Text | Gets or sets the tooltip Text.
Public property | Title | Gets or sets the tooltip Title.

See Also

IGH_Tooltip Interface
Grasshopper.GUI Namespace


IGH_Tooltip Properties

[image] [image]

Grasshopper SDK
IGH_Tooltip Properties
IGH_Tooltip Interface See Also Send Feedback

The IGH_Tooltip type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets or sets the tooltip Description. The Description is optional and is displayed in the same area as the TooltipDiagram image.
Public property | Diagram | Sets the tooltip diagram image. The diagram image is optional and is displayed in the same area as the ToolTipDescription text.
Public property | Icon | Sets the Tooltip Icon image.
Public property | Palette | Gets or sets the tooltip colour palette.
Public property | Text | Gets or sets the tooltip Text.
Public property | Title | Gets or sets the tooltip Title.

See Also

IGH_Tooltip Interface
Grasshopper.GUI Namespace


Description Property

[image]

Grasshopper SDK
IGH_Tooltip..::..Description Property
IGH_Tooltip Interface See Also Send Feedback
Gets or sets the tooltip Description. The Description is optional and is displayed in the same area as the TooltipDiagram image.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string Description { get; set; }
Visual Basic
Property Description As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.IGH_Tooltip.Description"]

See Also

IGH_Tooltip Interface
Grasshopper.GUI Namespace


Diagram Property

[image]

Grasshopper SDK
IGH_Tooltip..::..Diagram Property
IGH_Tooltip Interface See Also Send Feedback
Sets the tooltip diagram image. The diagram image is optional and is displayed in the same area as the ToolTipDescription text.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
Image Diagram { set; }
Visual Basic
WriteOnly Property Diagram As Image
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.IGH_Tooltip.Diagram"]

See Also

IGH_Tooltip Interface
Grasshopper.GUI Namespace


Icon Property

[image]

Grasshopper SDK
IGH_Tooltip..::..Icon Property
IGH_Tooltip Interface See Also Send Feedback
Sets the Tooltip Icon image.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
Image Icon { set; }
Visual Basic
WriteOnly Property Icon As Image
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.IGH_Tooltip.Icon"]

See Also

IGH_Tooltip Interface
Grasshopper.GUI Namespace


Palette Property

[image]

Grasshopper SDK
IGH_Tooltip..::..Palette Property
IGH_Tooltip Interface See Also Send Feedback
Gets or sets the tooltip colour palette.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
GH_TooltipPalette Palette { get; set; }
Visual Basic
Property Palette As GH_TooltipPalette
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.IGH_Tooltip.Palette"]

See Also

IGH_Tooltip Interface
Grasshopper.GUI Namespace


Text Property

[image]

Grasshopper SDK
IGH_Tooltip..::..Text Property
IGH_Tooltip Interface See Also Send Feedback
Gets or sets the tooltip Text.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string Text { get; set; }
Visual Basic
Property Text As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.IGH_Tooltip.Text"]

See Also

IGH_Tooltip Interface
Grasshopper.GUI Namespace


Title Property

[image]

Grasshopper SDK
IGH_Tooltip..::..Title Property
IGH_Tooltip Interface See Also Send Feedback
Gets or sets the tooltip Title.

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string Title { get; set; }
Visual Basic
Property Title As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.IGH_Tooltip.Title"]

See Also

IGH_Tooltip Interface
Grasshopper.GUI Namespace


Grasshopper.GUI.Base Namespace

[image]

Grasshopper SDK
Grasshopper.GUI.Base Namespace
Send Feedback
This namespace contains general purpose UI elements that have been divorced from winforms Control handles. This allows them to be rendered on screen as part of a larger constellation of UI elements. There are dedicated winforms control implementations of all the elements in this namespace in the Grasshopper.GUI namespace.

Classes

 | Class | Description
Public class | GH_ColourCube | Maintains a collection of graphical shapes and coordinates that specify important features of the Colour Space Cube graphics.
Public class | GH_ColourPickerBase | Provides Colour picker GUI not tied to a control-handle.
Public class | GH_ColourPickerEventArgs | Arguments passed via GH_SliderBase.ValueChanged events.
Public class | GH_ColourSphere |
Public class | GH_DigitNumber | Maintains and provides functionality for evaluating and modifying numbers as used in the GH_DigitScrollerBase control.
Public class | GH_DigitScrollerBase | Provides Numeric digit scrolling GUI not tied to a control-handle.
Public class | GH_DigitScrollerEventArgs | Arguments passed via GH_digitScrollerBase.ValueChanged events.
Public class | GH_ScrollBarVerticalBase | Provides basic vertical scroll bar logic.
Public class | GH_SliderBase | Provides Numeric slider GUI not tied to a control-handle.
Public class | GH_SliderEventArgs | Arguments passed via GH_SliderBase.ValueChanged events.
Public class | GH_TextBoxInputBase |

Delegates

 | Delegate | Description
Public delegate | GH_ColourPickerBase..::..ColorChangedEventHandler |
Public delegate | GH_ColourPickerBase..::..InvalidatedEventHandler |
Public delegate | GH_DigitScrollerBase..::..InvalidatedEventHandler |
Public delegate | GH_DigitScrollerBase..::..ValueChangedEventHandler |
Public delegate | GH_SliderBase..::..DrawSliderChannel | This delegate is used to intervene in the slider drawing process.
Public delegate | GH_SliderBase..::..TextInputHandler | Delegate used during Text Input handling.
Public delegate | GH_SliderBase..::..ValueChangedEventHandler |

Enumerations

 | Enumeration | Description
Public enumeration | GH_ColourSpace | Enumerates the different colour spaces supported by the GH_ColourPickerBase class.
Public enumeration | GH_DigitAlign | Enumerates the possible alignments for digits inside the GH_DigitScroller control.
Public enumeration | GH_DigitScrollerBase..::..GH_MouseAction | Enumerates the possible actions due to mouse-down mouse-move events.
Public enumeration | GH_SliderAccuracy | Enumerates the possible numeric slider accuracies.
Public enumeration | GH_SliderGripDisplay | Enumerates the possible slider grip displays.
Public enumeration | GH_SliderRailDisplay | Enumerates the possible slider rail displays.
Public enumeration | GH_SliderTickDisplay | Enumerates the possible slider tick displays.


GH_ColourCube Class

[image]

Grasshopper SDK
GH_ColourCube Class
Members See Also Send Feedback
Maintains a collection of graphical shapes and coordinates that specify important features of the Colour Space Cube graphics.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_ColourCube
Visual Basic
Public Class GH_ColourCube

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI.Base..::..GH_ColourCube

See Also

GH_ColourCube Members
Grasshopper.GUI.Base Namespace


GH_ColourCube Members

[image] [image]

Grasshopper SDK
GH_ColourCube Members
GH_ColourCube Class Constructors Methods Properties See Also Send Feedback

The GH_ColourCube type exposes the following members.

Constructors

 | Name | Description
Public method | GH_ColourCube | Create a new instance of this class.

Methods

 | Name | Description
Public method | Average(Color, Color) | Compute the average of two colours.
Public method | Average(Color, Color, Color, Color) | Compute the average of four colours.
Public method | Blend | Inteprolate between two colours.
Public method | ColorAtRail | Get the color at a position along the depth rail.
Public method | ColorAtSlice | Get the color at a position on the slice.
Public method | RenderAll | Call all render methods in the correct order.
Public method | RenderBackEdges | Render the edges of the back face creases.
Public method | RenderBackFaces | Render the fills of the backfaces.
Public method | RenderDropShadow | Render the drop shadow of the cube.
Public method | RenderEdgeShadows | Render the edge shadows of the cube due to GI.
Public method | RenderForeEdges | Render the edges of the fore face creases.
Public method | RenderGrip | Render the slice grip.
Public method | RenderPivot | Render the colour pivot on the current slice.
Public method | RenderSilhouetteEdges | Render the edges of the cube silhouettes.
Public method | RenderSlice | Render the square slice with colour gradients.
Public method | RenderSliceDropShadow | Render the drop shadow onto the slice.
Public method | RenderSliceEdgeShadows | Render the edge shadows of the slice due to GI.
Public method | RenderSliceSilhouetteEdges | Render the silhouette edges of the slice.

Properties

 | Name | Description
Public property | BackFace | Gets a graphics path describing the back face of the cube. Caller is responsible for disposing of this path instance.
Public property | BottomFace | Gets a graphics path describing the bottom face of the cube. Caller is responsible for disposing of this path instance.
Public property | C0 | Gets the first point in the corner point list.
Public property | C1 | Gets the second point in the corner point list.
Public property | C2 | Gets the third point in the corner point list.
Public property | C3 | Gets the fourth point in the corner point list.
Public property | C4 | Gets the fifth point in the corner point list.
Public property | C5 | Gets the sixth point in the corner point list.
Public property | C6 | Gets the seventh point in the corner point list.
Public property | C7 | Gets the eighth point in the corner point list.
Public property | Grip | Gets the rectangle that describes the slice grip.
Public property | LeftFace | Gets a graphics path describing the left face of the cube. Caller is responsible for disposing of this path instance.
Public property | Pivot | Gets the point that describes the center of the pivot on the slice.
Public property | S0 | Gets the first point in the shadow point list. This point is coincident with C0.
Public property | S1 | Gets the second point in the shadow point list. This is the corner of the drop-shadow on the bottom face.
Public property | S2 | Gets the third point in the shadow point list. This point is the kink of the drop-shadow on the edge connecting C2 and C3.
Public property | S3 | Gets the fourth point in the shadow point list. This point is coincident with C7.
Public property | S4 | Gets the fifth point in the shadow point list. This point is coincident with C4.
Public property | Shadow | Gets a graphics path describing the outline of the drop shadow. Caller is responsible for disposing of this path instance.
Public property | Silhouette | Gets a graphics path describing the silhouette of the cube. Caller is responsible for disposing of this path instance.
Public property | Slice | Gets the rectangle that describes the cutting slide through the current colour space.

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


GH_ColourCube Constructor

[image]

Grasshopper SDK
GH_ColourCube Constructor
GH_ColourCube Class See Also Send Feedback
Create a new instance of this class.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ColourCube(
    Rectangle box,
    GH_ColourSpace space,
    Point4d color
)
Visual Basic
Public Sub New ( _
    box As Rectangle, _
    space As GH_ColourSpace, _
    color As Point4d _
)

Parameters

box
Type: System.Drawing..::..Rectangle
Rectangle containing entire colour cube. Should be square.
space
Type: Grasshopper.GUI.Base..::..GH_ColourSpace
color
Type: Point4d

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


GH_ColourCube Methods

[image] [image]

Grasshopper SDK
GH_ColourCube Methods
GH_ColourCube Class See Also Send Feedback

The GH_ColourCube type exposes the following members.

Methods

 | Name | Description
Public method | Average(Color, Color) | Compute the average of two colours.
Public method | Average(Color, Color, Color, Color) | Compute the average of four colours.
Public method | Blend | Inteprolate between two colours.
Public method | ColorAtRail | Get the color at a position along the depth rail.
Public method | ColorAtSlice | Get the color at a position on the slice.
Public method | RenderAll | Call all render methods in the correct order.
Public method | RenderBackEdges | Render the edges of the back face creases.
Public method | RenderBackFaces | Render the fills of the backfaces.
Public method | RenderDropShadow | Render the drop shadow of the cube.
Public method | RenderEdgeShadows | Render the edge shadows of the cube due to GI.
Public method | RenderForeEdges | Render the edges of the fore face creases.
Public method | RenderGrip | Render the slice grip.
Public method | RenderPivot | Render the colour pivot on the current slice.
Public method | RenderSilhouetteEdges | Render the edges of the cube silhouettes.
Public method | RenderSlice | Render the square slice with colour gradients.
Public method | RenderSliceDropShadow | Render the drop shadow onto the slice.
Public method | RenderSliceEdgeShadows | Render the edge shadows of the slice due to GI.
Public method | RenderSliceSilhouetteEdges | Render the silhouette edges of the slice.

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


Average Method

[image] [image]

Grasshopper SDK
GH_ColourCube..::..Average Method
GH_ColourCube Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Average(Color, Color) | Compute the average of two colours.
Public method | Average(Color, Color, Color, Color) | Compute the average of four colours.

See Also

GH_ColourCube Class
GH_ColourCube Members
Grasshopper.GUI.Base Namespace


Average Method (Color, Color)

[image]

Grasshopper SDK
GH_ColourCube..::..Average Method (Color, Color)
GH_ColourCube Class See Also Send Feedback
Compute the average of two colours.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color Average(
    Color A,
    Color B
)
Visual Basic
Public Function Average ( _
    A As Color, _
    B As Color _
) As Color

Parameters

A
Type: System.Drawing..::..Color
First colour for average.
B
Type: System.Drawing..::..Color
Second colour for average.

Return Value

The average of A and B.

See Also

GH_ColourCube Class
Average Overload
Grasshopper.GUI.Base Namespace


Average Method (Color, Color, Color, Color)

[image]

Grasshopper SDK
GH_ColourCube..::..Average Method (Color, Color, Color, Color)
GH_ColourCube Class See Also Send Feedback
Compute the average of four colours.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color Average(
    Color A,
    Color B,
    Color C,
    Color D
)
Visual Basic
Public Function Average ( _
    A As Color, _
    B As Color, _
    C As Color, _
    D As Color _
) As Color

Parameters

A
Type: System.Drawing..::..Color
First colour for average.
B
Type: System.Drawing..::..Color
Second colour for average.
C
Type: System.Drawing..::..Color
Third colour for average.
D
Type: System.Drawing..::..Color
Fourth colour for average.

Return Value

The average of A, B, C and D.

See Also

GH_ColourCube Class
Average Overload
Grasshopper.GUI.Base Namespace


Blend Method

[image]

Grasshopper SDK
GH_ColourCube..::..Blend Method
GH_ColourCube Class See Also Send Feedback
Inteprolate between two colours.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color Blend(
    Color A,
    Color B,
    double t
)
Visual Basic
Public Function Blend ( _
    A As Color, _
    B As Color, _
    t As Double _
) As Color

Parameters

A
Type: System.Drawing..::..Color
First colour.
B
Type: System.Drawing..::..Color
Second colour.
t
Type: System..::..Double
Interpolation parameter.

Return Value

Interpolated colour.

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


ColorAtRail Method

[image]

Grasshopper SDK
GH_ColourCube..::..ColorAtRail Method
GH_ColourCube Class See Also Send Feedback
Get the color at a position along the depth rail.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Point4d ColorAtRail(
    PointF pt
)
Visual Basic
Public Function ColorAtRail ( _
    pt As PointF _
) As Point4d

Parameters

pt
Type: System.Drawing..::..PointF
Point along rail (will be projected into rail limits)

Return Value

Point4d structure representing the colour in the current space.

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


ColorAtSlice Method

[image]

Grasshopper SDK
GH_ColourCube..::..ColorAtSlice Method
GH_ColourCube Class See Also Send Feedback
Get the color at a position on the slice.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Point4d ColorAtSlice(
    PointF pt
)
Visual Basic
Public Function ColorAtSlice ( _
    pt As PointF _
) As Point4d

Parameters

pt
Type: System.Drawing..::..PointF
Point on slice (will be projected into slice limits)

Return Value

Point4d structure representing the colour in the current space.

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


RenderAll Method

[image]

Grasshopper SDK
GH_ColourCube..::..RenderAll Method
GH_ColourCube Class See Also Send Feedback
Call all render methods in the correct order.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RenderAll(
    Graphics G
)
Visual Basic
Public Sub RenderAll ( _
    G As Graphics _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


RenderBackEdges Method

[image]

Grasshopper SDK
GH_ColourCube..::..RenderBackEdges Method
GH_ColourCube Class See Also Send Feedback
Render the edges of the back face creases.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RenderBackEdges(
    Graphics G
)
Visual Basic
Public Sub RenderBackEdges ( _
    G As Graphics _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


RenderBackFaces Method

[image]

Grasshopper SDK
GH_ColourCube..::..RenderBackFaces Method
GH_ColourCube Class See Also Send Feedback
Render the fills of the backfaces.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RenderBackFaces(
    Graphics G
)
Visual Basic
Public Sub RenderBackFaces ( _
    G As Graphics _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


RenderDropShadow Method

[image]

Grasshopper SDK
GH_ColourCube..::..RenderDropShadow Method
GH_ColourCube Class See Also Send Feedback
Render the drop shadow of the cube.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RenderDropShadow(
    Graphics G
)
Visual Basic
Public Sub RenderDropShadow ( _
    G As Graphics _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


RenderEdgeShadows Method

[image]

Grasshopper SDK
GH_ColourCube..::..RenderEdgeShadows Method
GH_ColourCube Class See Also Send Feedback
Render the edge shadows of the cube due to GI.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RenderEdgeShadows(
    Graphics G
)
Visual Basic
Public Sub RenderEdgeShadows ( _
    G As Graphics _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


RenderForeEdges Method

[image]

Grasshopper SDK
GH_ColourCube..::..RenderForeEdges Method
GH_ColourCube Class See Also Send Feedback
Render the edges of the fore face creases.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RenderForeEdges(
    Graphics G
)
Visual Basic
Public Sub RenderForeEdges ( _
    G As Graphics _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


RenderGrip Method

[image]

Grasshopper SDK
GH_ColourCube..::..RenderGrip Method
GH_ColourCube Class See Also Send Feedback
Render the slice grip.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RenderGrip(
    Graphics G
)
Visual Basic
Public Sub RenderGrip ( _
    G As Graphics _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


RenderPivot Method

[image]

Grasshopper SDK
GH_ColourCube..::..RenderPivot Method
GH_ColourCube Class See Also Send Feedback
Render the colour pivot on the current slice.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RenderPivot(
    Graphics G
)
Visual Basic
Public Sub RenderPivot ( _
    G As Graphics _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


RenderSilhouetteEdges Method

[image]

Grasshopper SDK
GH_ColourCube..::..RenderSilhouetteEdges Method
GH_ColourCube Class See Also Send Feedback
Render the edges of the cube silhouettes.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RenderSilhouetteEdges(
    Graphics G
)
Visual Basic
Public Sub RenderSilhouetteEdges ( _
    G As Graphics _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


RenderSlice Method

[image]

Grasshopper SDK
GH_ColourCube..::..RenderSlice Method
GH_ColourCube Class See Also Send Feedback
Render the square slice with colour gradients.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RenderSlice(
    Graphics G
)
Visual Basic
Public Sub RenderSlice ( _
    G As Graphics _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


RenderSliceDropShadow Method

[image]

Grasshopper SDK
GH_ColourCube..::..RenderSliceDropShadow Method
GH_ColourCube Class See Also Send Feedback
Render the drop shadow onto the slice.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RenderSliceDropShadow(
    Graphics G
)
Visual Basic
Public Sub RenderSliceDropShadow ( _
    G As Graphics _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


RenderSliceEdgeShadows Method

[image]

Grasshopper SDK
GH_ColourCube..::..RenderSliceEdgeShadows Method
GH_ColourCube Class See Also Send Feedback
Render the edge shadows of the slice due to GI.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RenderSliceEdgeShadows(
    Graphics G
)
Visual Basic
Public Sub RenderSliceEdgeShadows ( _
    G As Graphics _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


RenderSliceSilhouetteEdges Method

[image]

Grasshopper SDK
GH_ColourCube..::..RenderSliceSilhouetteEdges Method
GH_ColourCube Class See Also Send Feedback
Render the silhouette edges of the slice.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RenderSliceSilhouetteEdges(
    Graphics G
)
Visual Basic
Public Sub RenderSliceSilhouetteEdges ( _
    G As Graphics _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


GH_ColourCube Properties

[image] [image]

Grasshopper SDK
GH_ColourCube Properties
GH_ColourCube Class See Also Send Feedback

The GH_ColourCube type exposes the following members.

Properties

 | Name | Description
Public property | BackFace | Gets a graphics path describing the back face of the cube. Caller is responsible for disposing of this path instance.
Public property | BottomFace | Gets a graphics path describing the bottom face of the cube. Caller is responsible for disposing of this path instance.
Public property | C0 | Gets the first point in the corner point list.
Public property | C1 | Gets the second point in the corner point list.
Public property | C2 | Gets the third point in the corner point list.
Public property | C3 | Gets the fourth point in the corner point list.
Public property | C4 | Gets the fifth point in the corner point list.
Public property | C5 | Gets the sixth point in the corner point list.
Public property | C6 | Gets the seventh point in the corner point list.
Public property | C7 | Gets the eighth point in the corner point list.
Public property | Grip | Gets the rectangle that describes the slice grip.
Public property | LeftFace | Gets a graphics path describing the left face of the cube. Caller is responsible for disposing of this path instance.
Public property | Pivot | Gets the point that describes the center of the pivot on the slice.
Public property | S0 | Gets the first point in the shadow point list. This point is coincident with C0.
Public property | S1 | Gets the second point in the shadow point list. This is the corner of the drop-shadow on the bottom face.
Public property | S2 | Gets the third point in the shadow point list. This point is the kink of the drop-shadow on the edge connecting C2 and C3.
Public property | S3 | Gets the fourth point in the shadow point list. This point is coincident with C7.
Public property | S4 | Gets the fifth point in the shadow point list. This point is coincident with C4.
Public property | Shadow | Gets a graphics path describing the outline of the drop shadow. Caller is responsible for disposing of this path instance.
Public property | Silhouette | Gets a graphics path describing the silhouette of the cube. Caller is responsible for disposing of this path instance.
Public property | Slice | Gets the rectangle that describes the cutting slide through the current colour space.

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


BackFace Property

[image]

Grasshopper SDK
GH_ColourCube..::..BackFace Property
GH_ColourCube Class See Also Send Feedback
Gets a graphics path describing the back face of the cube. Caller is responsible for disposing of this path instance.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GraphicsPath BackFace { get; }
Visual Basic
Public ReadOnly Property BackFace As GraphicsPath
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourCube.BackFace"]

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


BottomFace Property

[image]

Grasshopper SDK
GH_ColourCube..::..BottomFace Property
GH_ColourCube Class See Also Send Feedback
Gets a graphics path describing the bottom face of the cube. Caller is responsible for disposing of this path instance.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GraphicsPath BottomFace { get; }
Visual Basic
Public ReadOnly Property BottomFace As GraphicsPath
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourCube.BottomFace"]

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


C0 Property

[image]

Grasshopper SDK
GH_ColourCube..::..C0 Property
GH_ColourCube Class See Also Send Feedback
Gets the first point in the corner point list.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Point C0 { get; }
Visual Basic
Public ReadOnly Property C0 As Point
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourCube.C0"]

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


C1 Property

[image]

Grasshopper SDK
GH_ColourCube..::..C1 Property
GH_ColourCube Class See Also Send Feedback
Gets the second point in the corner point list.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Point C1 { get; }
Visual Basic
Public ReadOnly Property C1 As Point
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourCube.C1"]

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


C2 Property

[image]

Grasshopper SDK
GH_ColourCube..::..C2 Property
GH_ColourCube Class See Also Send Feedback
Gets the third point in the corner point list.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Point C2 { get; }
Visual Basic
Public ReadOnly Property C2 As Point
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourCube.C2"]

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


C3 Property

[image]

Grasshopper SDK
GH_ColourCube..::..C3 Property
GH_ColourCube Class See Also Send Feedback
Gets the fourth point in the corner point list.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Point C3 { get; }
Visual Basic
Public ReadOnly Property C3 As Point
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourCube.C3"]

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


C4 Property

[image]

Grasshopper SDK
GH_ColourCube..::..C4 Property
GH_ColourCube Class See Also Send Feedback
Gets the fifth point in the corner point list.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Point C4 { get; }
Visual Basic
Public ReadOnly Property C4 As Point
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourCube.C4"]

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


C5 Property

[image]

Grasshopper SDK
GH_ColourCube..::..C5 Property
GH_ColourCube Class See Also Send Feedback
Gets the sixth point in the corner point list.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Point C5 { get; }
Visual Basic
Public ReadOnly Property C5 As Point
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourCube.C5"]

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


C6 Property

[image]

Grasshopper SDK
GH_ColourCube..::..C6 Property
GH_ColourCube Class See Also Send Feedback
Gets the seventh point in the corner point list.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Point C6 { get; }
Visual Basic
Public ReadOnly Property C6 As Point
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourCube.C6"]

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


C7 Property

[image]

Grasshopper SDK
GH_ColourCube..::..C7 Property
GH_ColourCube Class See Also Send Feedback
Gets the eighth point in the corner point list.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Point C7 { get; }
Visual Basic
Public ReadOnly Property C7 As Point
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourCube.C7"]

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


Grip Property

[image]

Grasshopper SDK
GH_ColourCube..::..Grip Property
GH_ColourCube Class See Also Send Feedback
Gets the rectangle that describes the slice grip.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle Grip { get; }
Visual Basic
Public ReadOnly Property Grip As Rectangle
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourCube.Grip"]

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


LeftFace Property

[image]

Grasshopper SDK
GH_ColourCube..::..LeftFace Property
GH_ColourCube Class See Also Send Feedback
Gets a graphics path describing the left face of the cube. Caller is responsible for disposing of this path instance.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GraphicsPath LeftFace { get; }
Visual Basic
Public ReadOnly Property LeftFace As GraphicsPath
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourCube.LeftFace"]

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


Pivot Property

[image]

Grasshopper SDK
GH_ColourCube..::..Pivot Property
GH_ColourCube Class See Also Send Feedback
Gets the point that describes the center of the pivot on the slice.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Point Pivot { get; }
Visual Basic
Public ReadOnly Property Pivot As Point
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourCube.Pivot"]

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


S0 Property

[image]

Grasshopper SDK
GH_ColourCube..::..S0 Property
GH_ColourCube Class See Also Send Feedback
Gets the first point in the shadow point list. This point is coincident with C0.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Point S0 { get; }
Visual Basic
Public ReadOnly Property S0 As Point
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourCube.S0"]

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


S1 Property

[image]

Grasshopper SDK
GH_ColourCube..::..S1 Property
GH_ColourCube Class See Also Send Feedback
Gets the second point in the shadow point list. This is the corner of the drop-shadow on the bottom face.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Point S1 { get; }
Visual Basic
Public ReadOnly Property S1 As Point
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourCube.S1"]

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


S2 Property

[image]

Grasshopper SDK
GH_ColourCube..::..S2 Property
GH_ColourCube Class See Also Send Feedback
Gets the third point in the shadow point list. This point is the kink of the drop-shadow on the edge connecting C2 and C3.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Point S2 { get; }
Visual Basic
Public ReadOnly Property S2 As Point
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourCube.S2"]

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


S3 Property

[image]

Grasshopper SDK
GH_ColourCube..::..S3 Property
GH_ColourCube Class See Also Send Feedback
Gets the fourth point in the shadow point list. This point is coincident with C7.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Point S3 { get; }
Visual Basic
Public ReadOnly Property S3 As Point
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourCube.S3"]

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


S4 Property

[image]

Grasshopper SDK
GH_ColourCube..::..S4 Property
GH_ColourCube Class See Also Send Feedback
Gets the fifth point in the shadow point list. This point is coincident with C4.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Point S4 { get; }
Visual Basic
Public ReadOnly Property S4 As Point
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourCube.S4"]

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


Shadow Property

[image]

Grasshopper SDK
GH_ColourCube..::..Shadow Property
GH_ColourCube Class See Also Send Feedback
Gets a graphics path describing the outline of the drop shadow. Caller is responsible for disposing of this path instance.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GraphicsPath Shadow { get; }
Visual Basic
Public ReadOnly Property Shadow As GraphicsPath
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourCube.Shadow"]

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


Silhouette Property

[image]

Grasshopper SDK
GH_ColourCube..::..Silhouette Property
GH_ColourCube Class See Also Send Feedback
Gets a graphics path describing the silhouette of the cube. Caller is responsible for disposing of this path instance.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GraphicsPath Silhouette { get; }
Visual Basic
Public ReadOnly Property Silhouette As GraphicsPath
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourCube.Silhouette"]

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


Slice Property

[image]

Grasshopper SDK
GH_ColourCube..::..Slice Property
GH_ColourCube Class See Also Send Feedback
Gets the rectangle that describes the cutting slide through the current colour space.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle Slice { get; }
Visual Basic
Public ReadOnly Property Slice As Rectangle
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourCube.Slice"]

See Also

GH_ColourCube Class
Grasshopper.GUI.Base Namespace


GH_ColourPickerBase Class

[image]

Grasshopper SDK
GH_ColourPickerBase Class
Members See Also Send Feedback
Provides Colour picker GUI not tied to a control-handle.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_ColourPickerBase : IGH_ToolstripItemKeyHandler
Visual Basic
Public Class GH_ColourPickerBase _
    Implements IGH_ToolstripItemKeyHandler

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI.Base..::..GH_ColourPickerBase

See Also

GH_ColourPickerBase Members
Grasshopper.GUI.Base Namespace


GH_ColourPickerBase Members

[image] [image]

Grasshopper SDK
GH_ColourPickerBase Members
GH_ColourPickerBase Class Constructors Methods Fields Properties Events See Also Send Feedback

The GH_ColourPickerBase type exposes the following members.

Constructors

 | Name | Description
Public method | GH_ColourPickerBase | Create a new instance of the Colour Picker base control. This constructor assigns the default Colour space model and involves a call to the Grasshopper core settings server. You must call SetupColourPicker() prior to rendering this control on screen.

Methods

 | Name | Description
Public method | Invalidate | Raise the Invalidated event.
Public method | MouseClick | Respond to mouse-click events.
Public method | MouseDoubleClick | Respond to mouse-doubleclick events.
Public method | MouseDown | Respond to mouse-down events.
Public method | MouseMove | Respond to mouse-move events.
Public method | MouseUp | Respond to mouse-up events.
Public method | OnColorChanged | Raise the ColorChanged event.
Public method | Render | Render this slider into a Graphics context.
Public method | RespondToEnter |
Public method | RespondToEscape |
Public method | SetupColourPicker(Color, Point4d, GH_ColourSpace) | Setup all UI elements.
Public method | SetupColourPicker(Color, Color, GH_ColourSpace) | Setup all UI elements.

Fields

Name | Description
MinWidth |
SliderSize |
Spacing |
SwatchSize |

Properties

 | Name | Description
Public property | AutoSize | Gets or sets a value indicating whether the width and height of the Bounds are adjusted to fit the UI.
Public property | BackColour | Gets or sets the background colour of the picker.
Public property | BaseColour | Gets the original base colour for this picker. Use SetupColourPicker to assign this colour.
Public property | BaseColourBox | Gets the rectangle containing the base colour swatch.
Public property | Bounds | Gets or sets the Bounds for this control.
Public property | ChannelBox0 | Gets the rectangle containing the tag string for the first channel slider.
Public property | ChannelBox1 | Gets the rectangle containing the tag string for the second channel slider.
Public property | ChannelBox2 | Gets the rectangle containing the tag string for the third channel slider.
Public property | ChannelBox3 | Gets the rectangle containing the tag string for the fourth channel slider.
Public property | ColourCubeBox | Gets the rectangle that contains the colour space cube.
Public property | ColourSpace | Gets the Colour space mode used in this picker.
Public property | Cube | Gets the graphics object that describes the current colour cube.
Public property | DesiredHeight | Gets the ideal height for this colour picker given it's width and UI settings.
Public property | DrawAlphaSlider | Gets or sets whether or not the alpha slider is included in the UI.
Public property | DrawBackground | Gets or sets whether the background of the picker is drawn.
Public property | DrawChannelSliders | Gets or sets whether or not the three basic channel sliders are included in the UI.
Public property | DropperPreviewBox | Gets the rectangle in which the eye-dropped preview will be drawn.
Public property | Font | Gets or sets the Font used in this Colour Picker. Do not Dispose the Font returned by this property.
Public property | HSVSpaceBox | Gets the rectangle containing the base colour space.
Public property | IsTextInput | Gets whether any of the slider is currently displaying a text input box.
Public property | Padding | Gets or sets the Padding for this control.
Public property | PickColour | Gets the picked colour.
Public property | PickColourBox | Gets the rectangle containing the pick colour swatch.
Public property | RGBSpaceBox | Gets the rectangle containing the pick colour space.
Public property | SRCSpaceBox | Gets the rectangle containing the eye-dropper function.

Events

 | Name | Description
Public event | ColorChanged | Raised whenever the color of this picker is changed due to User-Interface methods.
Public event | Invalidated | Raised whenever a redraw is required.

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


GH_ColourPickerBase Constructor

[image]

Grasshopper SDK
GH_ColourPickerBase Constructor
GH_ColourPickerBase Class See Also Send Feedback
Create a new instance of the Colour Picker base control. This constructor assigns the default Colour space model and involves a call to the Grasshopper core settings server. You must call SetupColourPicker() prior to rendering this control on screen.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ColourPickerBase()
Visual Basic
Public Sub New

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


GH_ColourPickerBase Fields

[image] [image]

Grasshopper SDK
GH_ColourPickerBase Fields
GH_ColourPickerBase Class See Also Send Feedback

The GH_ColourPickerBase type exposes the following members.

Fields

Name | Description
MinWidth |
SliderSize |
Spacing |
SwatchSize |

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


MinWidth Field

[image]

Grasshopper SDK
GH_ColourPickerBase..::..MinWidth Field
GH_ColourPickerBase Class See Also Send Feedback

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const int MinWidth
Visual Basic
Public Const MinWidth As Integer

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


SliderSize Field

[image]

Grasshopper SDK
GH_ColourPickerBase..::..SliderSize Field
GH_ColourPickerBase Class See Also Send Feedback

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const int SliderSize
Visual Basic
Public Const SliderSize As Integer

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


Spacing Field

[image]

Grasshopper SDK
GH_ColourPickerBase..::..Spacing Field
GH_ColourPickerBase Class See Also Send Feedback

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const int Spacing
Visual Basic
Public Const Spacing As Integer

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


SwatchSize Field

[image]

Grasshopper SDK
GH_ColourPickerBase..::..SwatchSize Field
GH_ColourPickerBase Class See Also Send Feedback

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const int SwatchSize
Visual Basic
Public Const SwatchSize As Integer

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


GH_ColourPickerBase Methods

[image] [image]

Grasshopper SDK
GH_ColourPickerBase Methods
GH_ColourPickerBase Class See Also Send Feedback

The GH_ColourPickerBase type exposes the following members.

Methods

 | Name | Description
Public method | Invalidate | Raise the Invalidated event.
Public method | MouseClick | Respond to mouse-click events.
Public method | MouseDoubleClick | Respond to mouse-doubleclick events.
Public method | MouseDown | Respond to mouse-down events.
Public method | MouseMove | Respond to mouse-move events.
Public method | MouseUp | Respond to mouse-up events.
Public method | OnColorChanged | Raise the ColorChanged event.
Public method | Render | Render this slider into a Graphics context.
Public method | RespondToEnter |
Public method | RespondToEscape |
Public method | SetupColourPicker(Color, Point4d, GH_ColourSpace) | Setup all UI elements.
Public method | SetupColourPicker(Color, Color, GH_ColourSpace) | Setup all UI elements.

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


Invalidate Method

[image]

Grasshopper SDK
GH_ColourPickerBase..::..Invalidate Method
GH_ColourPickerBase Class See Also Send Feedback
Raise the Invalidated event.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Invalidate()
Visual Basic
Public Sub Invalidate

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


MouseClick Method

[image]

Grasshopper SDK
GH_ColourPickerBase..::..MouseClick Method
GH_ColourPickerBase Class See Also Send Feedback
Respond to mouse-click events.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool MouseClick(
    MouseEventArgs args,
    PointF pt
)
Visual Basic
Public Function MouseClick ( _
    args As MouseEventArgs, _
    pt As PointF _
) As Boolean

Parameters

args
Type: System.Windows.Forms..::..MouseEventArgs
Mouse Event arguments.
pt
Type: System.Drawing..::..PointF
Mouse cursor position in floating point accuracy.

Return Value

True if a Drag operation was terminated, false if the event went unnoticed.

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


MouseDoubleClick Method

[image]

Grasshopper SDK
GH_ColourPickerBase..::..MouseDoubleClick Method
GH_ColourPickerBase Class See Also Send Feedback
Respond to mouse-doubleclick events.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool MouseDoubleClick(
    MouseEventArgs args,
    PointF pt,
    Control owner,
    Matrix transform
)
Visual Basic
Public Function MouseDoubleClick ( _
    args As MouseEventArgs, _
    pt As PointF, _
    owner As Control, _
    transform As Matrix _
) As Boolean

Parameters

args
Type: System.Windows.Forms..::..MouseEventArgs
Mouse Event arguments.
pt
Type: System.Drawing..::..PointF
Mouse cursor position in floating point accuracy.
owner
Type: System.Windows.Forms..::..Control
Owner control for this colour-picker.
transform
Type: System.Drawing.Drawing2D..::..Matrix
Display Transformation matrix of colour-picker.

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


MouseDown Method

[image]

Grasshopper SDK
GH_ColourPickerBase..::..MouseDown Method
GH_ColourPickerBase Class See Also Send Feedback
Respond to mouse-down events.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool MouseDown(
    MouseEventArgs args,
    PointF pt
)
Visual Basic
Public Function MouseDown ( _
    args As MouseEventArgs, _
    pt As PointF _
) As Boolean

Parameters

args
Type: System.Windows.Forms..::..MouseEventArgs
Mouse Event arguments.
pt
Type: System.Drawing..::..PointF
Mouse cursor position in floating point accuracy.

Return Value

True if a Drag operation was started, false if the event went unnoticed.

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


MouseMove Method

[image]

Grasshopper SDK
GH_ColourPickerBase..::..MouseMove Method
GH_ColourPickerBase Class See Also Send Feedback
Respond to mouse-move events.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool MouseMove(
    MouseEventArgs args,
    PointF pt
)
Visual Basic
Public Function MouseMove ( _
    args As MouseEventArgs, _
    pt As PointF _
) As Boolean

Parameters

args
Type: System.Windows.Forms..::..MouseEventArgs
Mouse Event arguments.
pt
Type: System.Drawing..::..PointF
Mouse cursor position in floating point accuracy.

Return Value

True if a Drag operation was performed, false if the event went unnoticed.

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


MouseUp Method

[image]

Grasshopper SDK
GH_ColourPickerBase..::..MouseUp Method
GH_ColourPickerBase Class See Also Send Feedback
Respond to mouse-up events.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool MouseUp(
    MouseEventArgs args,
    PointF pt
)
Visual Basic
Public Function MouseUp ( _
    args As MouseEventArgs, _
    pt As PointF _
) As Boolean

Parameters

args
Type: System.Windows.Forms..::..MouseEventArgs
Mouse Event arguments.
pt
Type: System.Drawing..::..PointF
Mouse cursor position in floating point accuracy.

Return Value

True if a Drag operation was terminated, false if the event went unnoticed.

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


OnColorChanged Method

[image]

Grasshopper SDK
GH_ColourPickerBase..::..OnColorChanged Method
GH_ColourPickerBase Class See Also Send Feedback
Raise the ColorChanged event.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void OnColorChanged(
    bool intermediate
)
Visual Basic
Public Sub OnColorChanged ( _
    intermediate As Boolean _
)

Parameters

intermediate
Type: System..::..Boolean
Set the intermediate state of the event arguments.

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


Render Method

[image]

Grasshopper SDK
GH_ColourPickerBase..::..Render Method
GH_ColourPickerBase Class See Also Send Feedback
Render this slider into a Graphics context.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Render(
    Graphics G
)
Visual Basic
Public Sub Render ( _
    G As Graphics _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics to render with.

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


RespondToEnter Method

[image]

Grasshopper SDK
GH_ColourPickerBase..::..RespondToEnter Method
GH_ColourPickerBase Class See Also Send Feedback

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ToolstripItemKeyHandlerResult RespondToEnter()
Visual Basic
Public Function RespondToEnter As GH_ToolstripItemKeyHandlerResult

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


RespondToEscape Method

[image]

Grasshopper SDK
GH_ColourPickerBase..::..RespondToEscape Method
GH_ColourPickerBase Class See Also Send Feedback

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ToolstripItemKeyHandlerResult RespondToEscape()
Visual Basic
Public Function RespondToEscape As GH_ToolstripItemKeyHandlerResult

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


SetupColourPicker Method

[image] [image]

Grasshopper SDK
GH_ColourPickerBase..::..SetupColourPicker Method
GH_ColourPickerBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetupColourPicker(Color, Point4d, GH_ColourSpace) | Setup all UI elements.
Public method | SetupColourPicker(Color, Color, GH_ColourSpace) | Setup all UI elements.

See Also

GH_ColourPickerBase Class
GH_ColourPickerBase Members
Grasshopper.GUI.Base Namespace


SetupColourPicker Method (Color, , GH_ColourSpace)

[image]

Grasshopper SDK
GH_ColourPickerBase..::..SetupColourPicker Method (Color, , GH_ColourSpace)
GH_ColourPickerBase Class See Also Send Feedback
Setup all UI elements.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SetupColourPicker(
    Color col0,
    Point4d col1,
    GH_ColourSpace space
)
Visual Basic
Public Sub SetupColourPicker ( _
    col0 As Color, _
    col1 As Point4d, _
    space As GH_ColourSpace _
)

Parameters

col0
Type: System.Drawing..::..Color
Initial colour for this picker.
col1
Type: Point4d
Active colour for this picker.
space
Type: Grasshopper.GUI.Base..::..GH_ColourSpace
Colour space mode for this picker.

See Also

GH_ColourPickerBase Class
SetupColourPicker Overload
Grasshopper.GUI.Base Namespace


SetupColourPicker Method (Color, Color, GH_ColourSpace)

[image]

Grasshopper SDK
GH_ColourPickerBase..::..SetupColourPicker Method (Color, Color, GH_ColourSpace)
GH_ColourPickerBase Class See Also Send Feedback
Setup all UI elements.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SetupColourPicker(
    Color col0,
    Color col1,
    GH_ColourSpace space
)
Visual Basic
Public Sub SetupColourPicker ( _
    col0 As Color, _
    col1 As Color, _
    space As GH_ColourSpace _
)

Parameters

col0
Type: System.Drawing..::..Color
Initial colour for this picker.
col1
Type: System.Drawing..::..Color
Active colour for this picker.
space
Type: Grasshopper.GUI.Base..::..GH_ColourSpace
Colour space mode for this picker.

See Also

GH_ColourPickerBase Class
SetupColourPicker Overload
Grasshopper.GUI.Base Namespace


GH_ColourPickerBase Properties

[image] [image]

Grasshopper SDK
GH_ColourPickerBase Properties
GH_ColourPickerBase Class See Also Send Feedback

The GH_ColourPickerBase type exposes the following members.

Properties

 | Name | Description
Public property | AutoSize | Gets or sets a value indicating whether the width and height of the Bounds are adjusted to fit the UI.
Public property | BackColour | Gets or sets the background colour of the picker.
Public property | BaseColour | Gets the original base colour for this picker. Use SetupColourPicker to assign this colour.
Public property | BaseColourBox | Gets the rectangle containing the base colour swatch.
Public property | Bounds | Gets or sets the Bounds for this control.
Public property | ChannelBox0 | Gets the rectangle containing the tag string for the first channel slider.
Public property | ChannelBox1 | Gets the rectangle containing the tag string for the second channel slider.
Public property | ChannelBox2 | Gets the rectangle containing the tag string for the third channel slider.
Public property | ChannelBox3 | Gets the rectangle containing the tag string for the fourth channel slider.
Public property | ColourCubeBox | Gets the rectangle that contains the colour space cube.
Public property | ColourSpace | Gets the Colour space mode used in this picker.
Public property | Cube | Gets the graphics object that describes the current colour cube.
Public property | DesiredHeight | Gets the ideal height for this colour picker given it's width and UI settings.
Public property | DrawAlphaSlider | Gets or sets whether or not the alpha slider is included in the UI.
Public property | DrawBackground | Gets or sets whether the background of the picker is drawn.
Public property | DrawChannelSliders | Gets or sets whether or not the three basic channel sliders are included in the UI.
Public property | DropperPreviewBox | Gets the rectangle in which the eye-dropped preview will be drawn.
Public property | Font | Gets or sets the Font used in this Colour Picker. Do not Dispose the Font returned by this property.
Public property | HSVSpaceBox | Gets the rectangle containing the base colour space.
Public property | IsTextInput | Gets whether any of the slider is currently displaying a text input box.
Public property | Padding | Gets or sets the Padding for this control.
Public property | PickColour | Gets the picked colour.
Public property | PickColourBox | Gets the rectangle containing the pick colour swatch.
Public property | RGBSpaceBox | Gets the rectangle containing the pick colour space.
Public property | SRCSpaceBox | Gets the rectangle containing the eye-dropper function.

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


AutoSize Property

[image]

Grasshopper SDK
GH_ColourPickerBase..::..AutoSize Property
GH_ColourPickerBase Class See Also Send Feedback
Gets or sets a value indicating whether the width and height of the Bounds are adjusted to fit the UI.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool AutoSize { get; set; }
Visual Basic
Public Property AutoSize As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourPickerBase.AutoSize"]

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


BackColour Property

[image]

Grasshopper SDK
GH_ColourPickerBase..::..BackColour Property
GH_ColourPickerBase Class See Also Send Feedback
Gets or sets the background colour of the picker.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color BackColour { get; set; }
Visual Basic
Public Property BackColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourPickerBase.BackColour"]

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


BaseColour Property

[image]

Grasshopper SDK
GH_ColourPickerBase..::..BaseColour Property
GH_ColourPickerBase Class See Also Send Feedback
Gets the original base colour for this picker. Use SetupColourPicker to assign this colour.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color BaseColour { get; }
Visual Basic
Public ReadOnly Property BaseColour As Color
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourPickerBase.BaseColour"]

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


BaseColourBox Property

[image]

Grasshopper SDK
GH_ColourPickerBase..::..BaseColourBox Property
GH_ColourPickerBase Class See Also Send Feedback
Gets the rectangle containing the base colour swatch.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle BaseColourBox { get; }
Visual Basic
Public ReadOnly Property BaseColourBox As Rectangle
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourPickerBase.BaseColourBox"]

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


Bounds Property

[image]

Grasshopper SDK
GH_ColourPickerBase..::..Bounds Property
GH_ColourPickerBase Class See Also Send Feedback
Gets or sets the Bounds for this control.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle Bounds { get; set; }
Visual Basic
Public Property Bounds As Rectangle
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourPickerBase.Bounds"]

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


ChannelBox0 Property

[image]

Grasshopper SDK
GH_ColourPickerBase..::..ChannelBox0 Property
GH_ColourPickerBase Class See Also Send Feedback
Gets the rectangle containing the tag string for the first channel slider.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle ChannelBox0 { get; }
Visual Basic
Public ReadOnly Property ChannelBox0 As Rectangle
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourPickerBase.ChannelBox0"]

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


ChannelBox1 Property

[image]

Grasshopper SDK
GH_ColourPickerBase..::..ChannelBox1 Property
GH_ColourPickerBase Class See Also Send Feedback
Gets the rectangle containing the tag string for the second channel slider.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle ChannelBox1 { get; }
Visual Basic
Public ReadOnly Property ChannelBox1 As Rectangle
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourPickerBase.ChannelBox1"]

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


ChannelBox2 Property

[image]

Grasshopper SDK
GH_ColourPickerBase..::..ChannelBox2 Property
GH_ColourPickerBase Class See Also Send Feedback
Gets the rectangle containing the tag string for the third channel slider.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle ChannelBox2 { get; }
Visual Basic
Public ReadOnly Property ChannelBox2 As Rectangle
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourPickerBase.ChannelBox2"]

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


ChannelBox3 Property

[image]

Grasshopper SDK
GH_ColourPickerBase..::..ChannelBox3 Property
GH_ColourPickerBase Class See Also Send Feedback
Gets the rectangle containing the tag string for the fourth channel slider.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle ChannelBox3 { get; }
Visual Basic
Public ReadOnly Property ChannelBox3 As Rectangle
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourPickerBase.ChannelBox3"]

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


ColourCubeBox Property

[image]

Grasshopper SDK
GH_ColourPickerBase..::..ColourCubeBox Property
GH_ColourPickerBase Class See Also Send Feedback
Gets the rectangle that contains the colour space cube.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle ColourCubeBox { get; }
Visual Basic
Public ReadOnly Property ColourCubeBox As Rectangle
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourPickerBase.ColourCubeBox"]

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


ColourSpace Property

[image]

Grasshopper SDK
GH_ColourPickerBase..::..ColourSpace Property
GH_ColourPickerBase Class See Also Send Feedback
Gets the Colour space mode used in this picker.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ColourSpace ColourSpace { get; }
Visual Basic
Public ReadOnly Property ColourSpace As GH_ColourSpace
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourPickerBase.ColourSpace"]

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


Cube Property

[image]

Grasshopper SDK
GH_ColourPickerBase..::..Cube Property
GH_ColourPickerBase Class See Also Send Feedback
Gets the graphics object that describes the current colour cube.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ColourCube Cube { get; }
Visual Basic
Public ReadOnly Property Cube As GH_ColourCube
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourPickerBase.Cube"]

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


DesiredHeight Property

[image]

Grasshopper SDK
GH_ColourPickerBase..::..DesiredHeight Property
GH_ColourPickerBase Class See Also Send Feedback
Gets the ideal height for this colour picker given it's width and UI settings.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int DesiredHeight { get; }
Visual Basic
Public ReadOnly Property DesiredHeight As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourPickerBase.DesiredHeight"]

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


DrawAlphaSlider Property

[image]

Grasshopper SDK
GH_ColourPickerBase..::..DrawAlphaSlider Property
GH_ColourPickerBase Class See Also Send Feedback
Gets or sets whether or not the alpha slider is included in the UI.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool DrawAlphaSlider { get; set; }
Visual Basic
Public Property DrawAlphaSlider As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourPickerBase.DrawAlphaSlider"]

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


DrawBackground Property

[image]

Grasshopper SDK
GH_ColourPickerBase..::..DrawBackground Property
GH_ColourPickerBase Class See Also Send Feedback
Gets or sets whether the background of the picker is drawn.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool DrawBackground { get; set; }
Visual Basic
Public Property DrawBackground As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourPickerBase.DrawBackground"]

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


DrawChannelSliders Property

[image]

Grasshopper SDK
GH_ColourPickerBase..::..DrawChannelSliders Property
GH_ColourPickerBase Class See Also Send Feedback
Gets or sets whether or not the three basic channel sliders are included in the UI.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool DrawChannelSliders { get; set; }
Visual Basic
Public Property DrawChannelSliders As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourPickerBase.DrawChannelSliders"]

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


DropperPreviewBox Property

[image]

Grasshopper SDK
GH_ColourPickerBase..::..DropperPreviewBox Property
GH_ColourPickerBase Class See Also Send Feedback
Gets the rectangle in which the eye-dropped preview will be drawn.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle DropperPreviewBox { get; }
Visual Basic
Public ReadOnly Property DropperPreviewBox As Rectangle
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourPickerBase.DropperPreviewBox"]

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


Font Property

[image]

Grasshopper SDK
GH_ColourPickerBase..::..Font Property
GH_ColourPickerBase Class See Also Send Feedback
Gets or sets the Font used in this Colour Picker. Do not Dispose the Font returned by this property.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Font Font { get; set; }
Visual Basic
Public Property Font As Font
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourPickerBase.Font"]

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


HSVSpaceBox Property

[image]

Grasshopper SDK
GH_ColourPickerBase..::..HSVSpaceBox Property
GH_ColourPickerBase Class See Also Send Feedback
Gets the rectangle containing the base colour space.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle HSVSpaceBox { get; }
Visual Basic
Public ReadOnly Property HSVSpaceBox As Rectangle
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourPickerBase.HSVSpaceBox"]

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


IsTextInput Property

[image]

Grasshopper SDK
GH_ColourPickerBase..::..IsTextInput Property
GH_ColourPickerBase Class See Also Send Feedback
Gets whether any of the slider is currently displaying a text input box.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsTextInput { get; }
Visual Basic
Public ReadOnly Property IsTextInput As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourPickerBase.IsTextInput"]

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


Padding Property

[image]

Grasshopper SDK
GH_ColourPickerBase..::..Padding Property
GH_ColourPickerBase Class See Also Send Feedback
Gets or sets the Padding for this control.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Padding Padding { get; set; }
Visual Basic
Public Property Padding As Padding
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourPickerBase.Padding"]

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


PickColour Property

[image]

Grasshopper SDK
GH_ColourPickerBase..::..PickColour Property
GH_ColourPickerBase Class See Also Send Feedback
Gets the picked colour.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color PickColour { get; }
Visual Basic
Public ReadOnly Property PickColour As Color
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourPickerBase.PickColour"]

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


PickColourBox Property

[image]

Grasshopper SDK
GH_ColourPickerBase..::..PickColourBox Property
GH_ColourPickerBase Class See Also Send Feedback
Gets the rectangle containing the pick colour swatch.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle PickColourBox { get; }
Visual Basic
Public ReadOnly Property PickColourBox As Rectangle
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourPickerBase.PickColourBox"]

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


RGBSpaceBox Property

[image]

Grasshopper SDK
GH_ColourPickerBase..::..RGBSpaceBox Property
GH_ColourPickerBase Class See Also Send Feedback
Gets the rectangle containing the pick colour space.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle RGBSpaceBox { get; }
Visual Basic
Public ReadOnly Property RGBSpaceBox As Rectangle
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourPickerBase.RGBSpaceBox"]

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


SRCSpaceBox Property

[image]

Grasshopper SDK
GH_ColourPickerBase..::..SRCSpaceBox Property
GH_ColourPickerBase Class See Also Send Feedback
Gets the rectangle containing the eye-dropper function.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle SRCSpaceBox { get; }
Visual Basic
Public ReadOnly Property SRCSpaceBox As Rectangle
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourPickerBase.SRCSpaceBox"]

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


GH_ColourPickerBase Events

[image] [image]

Grasshopper SDK
GH_ColourPickerBase Events
GH_ColourPickerBase Class See Also Send Feedback

The GH_ColourPickerBase type exposes the following members.

Events

 | Name | Description
Public event | ColorChanged | Raised whenever the color of this picker is changed due to User-Interface methods.
Public event | Invalidated | Raised whenever a redraw is required.

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


ColorChanged Event

[image]

Grasshopper SDK
GH_ColourPickerBase..::..ColorChanged Event
GH_ColourPickerBase Class See Also Send Feedback
Raised whenever the color of this picker is changed due to User-Interface methods.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_ColourPickerBase..::..ColorChangedEventHandler ColorChanged
Visual Basic
Public Event ColorChanged As GH_ColourPickerBase..::..ColorChangedEventHandler

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


Invalidated Event

[image]

Grasshopper SDK
GH_ColourPickerBase..::..Invalidated Event
GH_ColourPickerBase Class See Also Send Feedback
Raised whenever a redraw is required.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_ColourPickerBase..::..InvalidatedEventHandler Invalidated
Visual Basic
Public Event Invalidated As GH_ColourPickerBase..::..InvalidatedEventHandler

See Also

GH_ColourPickerBase Class
Grasshopper.GUI.Base Namespace


GH_ColourPickerBase.ColorChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_ColourPickerBase..::..ColorChangedEventHandler Delegate
GH_ColourPickerBase Class See Also Send Feedback

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void ColorChangedEventHandler(
    Object sender,
    GH_ColourPickerEventArgs e
)
Visual Basic
Public Delegate Sub ColorChangedEventHandler ( _
    sender As Object, _
    e As GH_ColourPickerEventArgs _
)

Parameters

sender
Type: System..::..Object
e
Type: Grasshopper.GUI.Base..::..GH_ColourPickerEventArgs

See Also

Grasshopper.GUI.Base Namespace


GH_ColourPickerBase.InvalidatedEventHandler Delegate

[image]

Grasshopper SDK
GH_ColourPickerBase..::..InvalidatedEventHandler Delegate
GH_ColourPickerBase Class See Also Send Feedback

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void InvalidatedEventHandler(
    Object sender,
    EventArgs e
)
Visual Basic
Public Delegate Sub InvalidatedEventHandler ( _
    sender As Object, _
    e As EventArgs _
)

Parameters

sender
Type: System..::..Object
e
Type: System..::..EventArgs

See Also

Grasshopper.GUI.Base Namespace


GH_ColourPickerEventArgs Class

[image]

Grasshopper SDK
GH_ColourPickerEventArgs Class
Members See Also Send Feedback
Arguments passed via GH_SliderBase.ValueChanged events.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_ColourPickerEventArgs : EventArgs
Visual Basic
Public Class GH_ColourPickerEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Grasshopper.GUI.Base..::..GH_ColourPickerEventArgs

See Also

GH_ColourPickerEventArgs Members
Grasshopper.GUI.Base Namespace


GH_ColourPickerEventArgs Members

[image] [image]

Grasshopper SDK
GH_ColourPickerEventArgs Members
GH_ColourPickerEventArgs Class Properties See Also Send Feedback

The GH_ColourPickerEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Colour | Gets the new value of the colour picker. This value is cached, so even if the picker subsequently updates, this property remains constant.
Public property | ColourPicker | Gets the instance of the picker that raised the event.
Public property | Intermediate | Gets a value indicating whether the change was an intermediate one.
Public property | Original | Gets the original value of the colour picker. This value is cached, so even if the picker subsequently updates, this property remains constant.

See Also

GH_ColourPickerEventArgs Class
Grasshopper.GUI.Base Namespace


GH_ColourPickerEventArgs Properties

[image] [image]

Grasshopper SDK
GH_ColourPickerEventArgs Properties
GH_ColourPickerEventArgs Class See Also Send Feedback

The GH_ColourPickerEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Colour | Gets the new value of the colour picker. This value is cached, so even if the picker subsequently updates, this property remains constant.
Public property | ColourPicker | Gets the instance of the picker that raised the event.
Public property | Intermediate | Gets a value indicating whether the change was an intermediate one.
Public property | Original | Gets the original value of the colour picker. This value is cached, so even if the picker subsequently updates, this property remains constant.

See Also

GH_ColourPickerEventArgs Class
Grasshopper.GUI.Base Namespace


Colour Property

[image]

Grasshopper SDK
GH_ColourPickerEventArgs..::..Colour Property
GH_ColourPickerEventArgs Class See Also Send Feedback
Gets the new value of the colour picker. This value is cached, so even if the picker subsequently updates, this property remains constant.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color Colour { get; }
Visual Basic
Public ReadOnly Property Colour As Color
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourPickerEventArgs.Colour"]

See Also

GH_ColourPickerEventArgs Class
Grasshopper.GUI.Base Namespace


ColourPicker Property

[image]

Grasshopper SDK
GH_ColourPickerEventArgs..::..ColourPicker Property
GH_ColourPickerEventArgs Class See Also Send Feedback
Gets the instance of the picker that raised the event.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ColourPickerBase ColourPicker { get; }
Visual Basic
Public ReadOnly Property ColourPicker As GH_ColourPickerBase
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourPickerEventArgs.ColourPicker"]

See Also

GH_ColourPickerEventArgs Class
Grasshopper.GUI.Base Namespace


Intermediate Property

[image]

Grasshopper SDK
GH_ColourPickerEventArgs..::..Intermediate Property
GH_ColourPickerEventArgs Class See Also Send Feedback
Gets a value indicating whether the change was an intermediate one.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Intermediate { get; }
Visual Basic
Public ReadOnly Property Intermediate As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourPickerEventArgs.Intermediate"]

See Also

GH_ColourPickerEventArgs Class
Grasshopper.GUI.Base Namespace


Original Property

[image]

Grasshopper SDK
GH_ColourPickerEventArgs..::..Original Property
GH_ColourPickerEventArgs Class See Also Send Feedback
Gets the original value of the colour picker. This value is cached, so even if the picker subsequently updates, this property remains constant.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color Original { get; }
Visual Basic
Public ReadOnly Property Original As Color
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourPickerEventArgs.Original"]

See Also

GH_ColourPickerEventArgs Class
Grasshopper.GUI.Base Namespace


GH_ColourSpace Enumeration

[image]

Grasshopper SDK
GH_ColourSpace Enumeration
See Also Send Feedback
Enumerates the different colour spaces supported by the GH_ColourPickerBase class.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_ColourSpace
Visual Basic
Public Enumeration GH_ColourSpace

Members

Member name | Value | Description
None | 0 | Unset value. Do not use. Seriously. Stay away.
RGB | 1 | Colour picker operates in RGB mode.
HSV | 2 | Colour picker operates in HSV mode.

Remarks

See Also

Grasshopper.GUI.Base Namespace


GH_ColourSphere Class

[image]

Grasshopper SDK
GH_ColourSphere Class
Members See Also Send Feedback

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_ColourSphere
Visual Basic
Public Class GH_ColourSphere

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI.Base..::..GH_ColourSphere

See Also

GH_ColourSphere Members
Grasshopper.GUI.Base Namespace


GH_ColourSphere Members

[image] [image]

Grasshopper SDK
GH_ColourSphere Members
GH_ColourSphere Class Constructors Methods Properties See Also Send Feedback

The GH_ColourSphere type exposes the following members.

Constructors

 | Name | Description
Public method | GH_ColourSphere | Initializes a new instance of the GH_ColourSphere class

Methods

 | Name | Description
Public method | MouseDown |
Public method | MouseMove |
Public method | MouseUp |
Public method | RenderSphere |

Properties

 | Name | Description
Public property | Bounds | Gets or sets the Dimensions of this sphere.
Public property | Content | Gets the rectangle that contains the sphere.
Public property | Radius | Gets the radius of the sphere as dictated by the current size.

See Also

GH_ColourSphere Class
Grasshopper.GUI.Base Namespace


GH_ColourSphere Constructor

[image]

Grasshopper SDK
GH_ColourSphere Constructor
GH_ColourSphere Class See Also Send Feedback
Initializes a new instance of the GH_ColourSphere class

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ColourSphere(
    Rectangle bounds
)
Visual Basic
Public Sub New ( _
    bounds As Rectangle _
)

Parameters

bounds
Type: System.Drawing..::..Rectangle

See Also

GH_ColourSphere Class
Grasshopper.GUI.Base Namespace


GH_ColourSphere Methods

[image] [image]

Grasshopper SDK
GH_ColourSphere Methods
GH_ColourSphere Class See Also Send Feedback

The GH_ColourSphere type exposes the following members.

Methods

 | Name | Description
Public method | MouseDown |
Public method | MouseMove |
Public method | MouseUp |
Public method | RenderSphere |

See Also

GH_ColourSphere Class
Grasshopper.GUI.Base Namespace


MouseDown Method

[image]

Grasshopper SDK
GH_ColourSphere..::..MouseDown Method
GH_ColourSphere Class See Also Send Feedback

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool MouseDown(
    MouseEventArgs e
)
Visual Basic
Public Function MouseDown ( _
    e As MouseEventArgs _
) As Boolean

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

GH_ColourSphere Class
Grasshopper.GUI.Base Namespace


MouseMove Method

[image]

Grasshopper SDK
GH_ColourSphere..::..MouseMove Method
GH_ColourSphere Class See Also Send Feedback

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool MouseMove(
    MouseEventArgs e
)
Visual Basic
Public Function MouseMove ( _
    e As MouseEventArgs _
) As Boolean

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

GH_ColourSphere Class
Grasshopper.GUI.Base Namespace


MouseUp Method

[image]

Grasshopper SDK
GH_ColourSphere..::..MouseUp Method
GH_ColourSphere Class See Also Send Feedback

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool MouseUp(
    MouseEventArgs e
)
Visual Basic
Public Function MouseUp ( _
    e As MouseEventArgs _
) As Boolean

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs

See Also

GH_ColourSphere Class
Grasshopper.GUI.Base Namespace


RenderSphere Method

[image]

Grasshopper SDK
GH_ColourSphere..::..RenderSphere Method
GH_ColourSphere Class See Also Send Feedback

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RenderSphere(
    Graphics G
)
Visual Basic
Public Sub RenderSphere ( _
    G As Graphics _
)

Parameters

G
Type: System.Drawing..::..Graphics

See Also

GH_ColourSphere Class
Grasshopper.GUI.Base Namespace


GH_ColourSphere Properties

[image] [image]

Grasshopper SDK
GH_ColourSphere Properties
GH_ColourSphere Class See Also Send Feedback

The GH_ColourSphere type exposes the following members.

Properties

 | Name | Description
Public property | Bounds | Gets or sets the Dimensions of this sphere.
Public property | Content | Gets the rectangle that contains the sphere.
Public property | Radius | Gets the radius of the sphere as dictated by the current size.

See Also

GH_ColourSphere Class
Grasshopper.GUI.Base Namespace


Bounds Property

[image]

Grasshopper SDK
GH_ColourSphere..::..Bounds Property
GH_ColourSphere Class See Also Send Feedback
Gets or sets the Dimensions of this sphere.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle Bounds { get; set; }
Visual Basic
Public Property Bounds As Rectangle
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourSphere.Bounds"]

See Also

GH_ColourSphere Class
Grasshopper.GUI.Base Namespace


Content Property

[image]

Grasshopper SDK
GH_ColourSphere..::..Content Property
GH_ColourSphere Class See Also Send Feedback
Gets the rectangle that contains the sphere.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle Content { get; }
Visual Basic
Public ReadOnly Property Content As Rectangle
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourSphere.Content"]

See Also

GH_ColourSphere Class
Grasshopper.GUI.Base Namespace


Radius Property

[image]

Grasshopper SDK
GH_ColourSphere..::..Radius Property
GH_ColourSphere Class See Also Send Feedback
Gets the radius of the sphere as dictated by the current size.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public float Radius { get; }
Visual Basic
Public ReadOnly Property Radius As Single
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ColourSphere.Radius"]

See Also

GH_ColourSphere Class
Grasshopper.GUI.Base Namespace


GH_DigitAlign Enumeration

[image]

Grasshopper SDK
GH_DigitAlign Enumeration
See Also Send Feedback
Enumerates the possible alignments for digits inside the GH_DigitScroller control.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_DigitAlign
Visual Basic
Public Enumeration GH_DigitAlign

Members

Member name | Value | Description
Justify | 0 | Digits expand to fill out the entire free space.
Left | 1 | Digits are stacked against the left side of the control.
Center | 2 | Digits are stacked together in the center of the control.
Right | 3 | Digits are stacked against the right side of the control.

See Also

Grasshopper.GUI.Base Namespace


GH_DigitNumber Class

[image]

Grasshopper SDK
GH_DigitNumber Class
Members See Also Send Feedback
Maintains and provides functionality for evaluating and modifying numbers as used in the GH_DigitScrollerBase control.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_DigitNumber
Visual Basic
Public Class GH_DigitNumber

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI.Base..::..GH_DigitNumber

See Also

GH_DigitNumber Members
Grasshopper.GUI.Base Namespace


GH_DigitNumber Members

[image] [image]

Grasshopper SDK
GH_DigitNumber Members
GH_DigitNumber Class Constructors Methods Properties See Also Send Feedback

The GH_DigitNumber type exposes the following members.

Constructors

 | Name | Description
Public method | GH_DigitNumber(Int32) | Create a new GH_DigitNumber instance with the specified number of decimal places.
Public method | GH_DigitNumber(GH_DigitNumber) | Create an exact duplicate of another GH_DigitNumber instance.
Public method | GH_DigitNumber(Int32, Int32) | Create a new GH_DigitNumber instance with the specified number of decimal places and a given radix position.

Methods

 | Name | Description
Public method | AssignOffset | Assign an offset to a given digit and recursively adjust all leftwards offsets if needed.
Public method | LimitValue | Limits the value to the minimum and maximum domain.
Public method | Reset | Reset all parts to zero.
Public method | Round | Round the number by cancelling the offset in the proper direction.
Public method | ToString | (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | DigitCount | Gets or sets the amount of digits in this number.
Public property | Epsilon | Gets the smallest possible change.
Public property | IsPrimaryDigitSignificant | Gets whether the primary digit at the given index is significant.
Public property | IsSecondaryDigitSignificant | Gets whether the secondary digit at the given index is significant.
Public property | Maximum | Gets the maximum value allowed in this number.
Public property | Minimum | Gets the minimum value allowed in this number.
Public property | Offset | Gets the offset between the primary and secondary digits.
Public property | PrimaryDigits | Gets the internal list of primary digits. Do not modify this list.
Public property | PrimaryPositive | Gets or sets a value indicating whether the number is positive.
Public property | Radix | Gets or sets the radix point index. A negative radix index disables the radix point, zero is not a valid index.
Public property | RadixIndex | Gets the mapped radix.
Public property | SecondaryDigits | Gets the internal list of secondary digits. Do not modify this list.
Public property | SecondaryPositive | Gets a value indicating whether the secondary number is positive.
Public property | Value | Gets or sets the value of this number.

See Also

GH_DigitNumber Class
Grasshopper.GUI.Base Namespace


GH_DigitNumber Constructor

[image] [image]

Grasshopper SDK
GH_DigitNumber Constructor
GH_DigitNumber Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_DigitNumber(Int32) | Create a new GH_DigitNumber instance with the specified number of decimal places.
Public method | GH_DigitNumber(GH_DigitNumber) | Create an exact duplicate of another GH_DigitNumber instance.
Public method | GH_DigitNumber(Int32, Int32) | Create a new GH_DigitNumber instance with the specified number of decimal places and a given radix position.

See Also

GH_DigitNumber Class
GH_DigitNumber Members
Grasshopper.GUI.Base Namespace


GH_DigitNumber Constructor (Int32)

[image]

Grasshopper SDK
GH_DigitNumber Constructor (Int32)
GH_DigitNumber Class See Also Send Feedback
Create a new GH_DigitNumber instance with the specified number of decimal places.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_DigitNumber(
    int decimalPlaces
)
Visual Basic
Public Sub New ( _
    decimalPlaces As Integer _
)

Parameters

decimalPlaces
Type: System..::..Int32
Amount of decimal places.

See Also

GH_DigitNumber Class
GH_DigitNumber Overload
Grasshopper.GUI.Base Namespace


GH_DigitNumber Constructor (GH_DigitNumber)

[image]

Grasshopper SDK
GH_DigitNumber Constructor (GH_DigitNumber)
GH_DigitNumber Class See Also Send Feedback
Create an exact duplicate of another GH_DigitNumber instance.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_DigitNumber(
    GH_DigitNumber other
)
Visual Basic
Public Sub New ( _
    other As GH_DigitNumber _
)

Parameters

other
Type: Grasshopper.GUI.Base..::..GH_DigitNumber
Number to copy.

See Also

GH_DigitNumber Class
GH_DigitNumber Overload
Grasshopper.GUI.Base Namespace


GH_DigitNumber Constructor (Int32, Int32)

[image]

Grasshopper SDK
GH_DigitNumber Constructor (Int32, Int32)
GH_DigitNumber Class See Also Send Feedback
Create a new GH_DigitNumber instance with the specified number of decimal places and a given radix position.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_DigitNumber(
    int decimalPlaces,
    int radixPosition
)
Visual Basic
Public Sub New ( _
    decimalPlaces As Integer, _
    radixPosition As Integer _
)

Parameters

decimalPlaces
Type: System..::..Int32
Amount of decimal places
radixPosition
Type: System..::..Int32
Index of radix symbol, -1 to disable the radix altogether.

See Also

GH_DigitNumber Class
GH_DigitNumber Overload
Grasshopper.GUI.Base Namespace


GH_DigitNumber Methods

[image] [image]

Grasshopper SDK
GH_DigitNumber Methods
GH_DigitNumber Class See Also Send Feedback

The GH_DigitNumber type exposes the following members.

Methods

 | Name | Description
Public method | AssignOffset | Assign an offset to a given digit and recursively adjust all leftwards offsets if needed.
Public method | LimitValue | Limits the value to the minimum and maximum domain.
Public method | Reset | Reset all parts to zero.
Public method | Round | Round the number by cancelling the offset in the proper direction.
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

GH_DigitNumber Class
Grasshopper.GUI.Base Namespace


AssignOffset Method

[image]

Grasshopper SDK
GH_DigitNumber..::..AssignOffset Method
GH_DigitNumber Class See Also Send Feedback
Assign an offset to a given digit and recursively adjust all leftwards offsets if needed.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool AssignOffset(
    int index,
    decimal offset
)
Visual Basic
Public Function AssignOffset ( _
    index As Integer, _
    offset As Decimal _
) As Boolean

Parameters

index
Type: System..::..Int32
Index of digit to offset.
offset
Type: System..::..Decimal
New offset for digit.

Return Value

True on success, false on failure.

See Also

GH_DigitNumber Class
Grasshopper.GUI.Base Namespace


LimitValue Method

[image]

Grasshopper SDK
GH_DigitNumber..::..LimitValue Method
GH_DigitNumber Class See Also Send Feedback
Limits the value to the minimum and maximum domain.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void LimitValue()
Visual Basic
Public Sub LimitValue

See Also

GH_DigitNumber Class
Grasshopper.GUI.Base Namespace


Reset Method

[image]

Grasshopper SDK
GH_DigitNumber..::..Reset Method
GH_DigitNumber Class See Also Send Feedback
Reset all parts to zero.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset

See Also

GH_DigitNumber Class
Grasshopper.GUI.Base Namespace


Round Method

[image]

Grasshopper SDK
GH_DigitNumber..::..Round Method
GH_DigitNumber Class See Also Send Feedback
Round the number by cancelling the offset in the proper direction.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Round()
Visual Basic
Public Sub Round

See Also

GH_DigitNumber Class
Grasshopper.GUI.Base Namespace


ToString Method

[image]

Grasshopper SDK
GH_DigitNumber..::..ToString Method
GH_DigitNumber Class See Also Send Feedback

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_DigitNumber Class
Grasshopper.GUI.Base Namespace


GH_DigitNumber Properties

[image] [image]

Grasshopper SDK
GH_DigitNumber Properties
GH_DigitNumber Class See Also Send Feedback

The GH_DigitNumber type exposes the following members.

Properties

 | Name | Description
Public property | DigitCount | Gets or sets the amount of digits in this number.
Public property | Epsilon | Gets the smallest possible change.
Public property | IsPrimaryDigitSignificant | Gets whether the primary digit at the given index is significant.
Public property | IsSecondaryDigitSignificant | Gets whether the secondary digit at the given index is significant.
Public property | Maximum | Gets the maximum value allowed in this number.
Public property | Minimum | Gets the minimum value allowed in this number.
Public property | Offset | Gets the offset between the primary and secondary digits.
Public property | PrimaryDigits | Gets the internal list of primary digits. Do not modify this list.
Public property | PrimaryPositive | Gets or sets a value indicating whether the number is positive.
Public property | Radix | Gets or sets the radix point index. A negative radix index disables the radix point, zero is not a valid index.
Public property | RadixIndex | Gets the mapped radix.
Public property | SecondaryDigits | Gets the internal list of secondary digits. Do not modify this list.
Public property | SecondaryPositive | Gets a value indicating whether the secondary number is positive.
Public property | Value | Gets or sets the value of this number.

See Also

GH_DigitNumber Class
Grasshopper.GUI.Base Namespace


DigitCount Property

[image]

Grasshopper SDK
GH_DigitNumber..::..DigitCount Property
GH_DigitNumber Class See Also Send Feedback
Gets or sets the amount of digits in this number.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int DigitCount { get; }
Visual Basic
Public ReadOnly Property DigitCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitNumber.DigitCount"]

See Also

GH_DigitNumber Class
Grasshopper.GUI.Base Namespace


Epsilon Property

[image]

Grasshopper SDK
GH_DigitNumber..::..Epsilon Property
GH_DigitNumber Class See Also Send Feedback
Gets the smallest possible change.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public decimal Epsilon { get; }
Visual Basic
Public ReadOnly Property Epsilon As Decimal
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitNumber.Epsilon"]

See Also

GH_DigitNumber Class
Grasshopper.GUI.Base Namespace


IsPrimaryDigitSignificant Property

[image]

Grasshopper SDK
GH_DigitNumber..::..IsPrimaryDigitSignificant Property
GH_DigitNumber Class See Also Send Feedback
Gets whether the primary digit at the given index is significant.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property IsPrimaryDigitSignificant ( _
    index As Integer _
) As Boolean
    Get

Parameters

index
Type: System..::..Int32
Index of digit to test.

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitNumber.IsPrimaryDigitSignificant(System.Int32)"]

See Also

GH_DigitNumber Class
Grasshopper.GUI.Base Namespace


IsSecondaryDigitSignificant Property

[image]

Grasshopper SDK
GH_DigitNumber..::..IsSecondaryDigitSignificant Property
GH_DigitNumber Class See Also Send Feedback
Gets whether the secondary digit at the given index is significant.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property IsSecondaryDigitSignificant ( _
    index As Integer _
) As Boolean
    Get

Parameters

index
Type: System..::..Int32
Index of digit to test.

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitNumber.IsSecondaryDigitSignificant(System.Int32)"]

See Also

GH_DigitNumber Class
Grasshopper.GUI.Base Namespace


Maximum Property

[image]

Grasshopper SDK
GH_DigitNumber..::..Maximum Property
GH_DigitNumber Class See Also Send Feedback
Gets the maximum value allowed in this number.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public decimal Maximum { get; set; }
Visual Basic
Public Property Maximum As Decimal
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitNumber.Maximum"]

See Also

GH_DigitNumber Class
Grasshopper.GUI.Base Namespace


Minimum Property

[image]

Grasshopper SDK
GH_DigitNumber..::..Minimum Property
GH_DigitNumber Class See Also Send Feedback
Gets the minimum value allowed in this number.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public decimal Minimum { get; set; }
Visual Basic
Public Property Minimum As Decimal
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitNumber.Minimum"]

See Also

GH_DigitNumber Class
Grasshopper.GUI.Base Namespace


Offset Property

[image]

Grasshopper SDK
GH_DigitNumber..::..Offset Property
GH_DigitNumber Class See Also Send Feedback
Gets the offset between the primary and secondary digits.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public decimal Offset { get; }
Visual Basic
Public ReadOnly Property Offset As Decimal
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitNumber.Offset"]

See Also

GH_DigitNumber Class
Grasshopper.GUI.Base Namespace


PrimaryDigits Property

[image]

Grasshopper SDK
GH_DigitNumber..::..PrimaryDigits Property
GH_DigitNumber Class See Also Send Feedback
Gets the internal list of primary digits. Do not modify this list.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IList<int> PrimaryDigits { get; }
Visual Basic
Public ReadOnly Property PrimaryDigits As IList(Of Integer)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitNumber.PrimaryDigits"]

See Also

GH_DigitNumber Class
Grasshopper.GUI.Base Namespace


PrimaryPositive Property

[image]

Grasshopper SDK
GH_DigitNumber..::..PrimaryPositive Property
GH_DigitNumber Class See Also Send Feedback
Gets or sets a value indicating whether the number is positive.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool PrimaryPositive { get; set; }
Visual Basic
Public Property PrimaryPositive As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitNumber.PrimaryPositive"]

See Also

GH_DigitNumber Class
Grasshopper.GUI.Base Namespace


Radix Property

[image]

Grasshopper SDK
GH_DigitNumber..::..Radix Property
GH_DigitNumber Class See Also Send Feedback
Gets or sets the radix point index. A negative radix index disables the radix point, zero is not a valid index.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int Radix { get; set; }
Visual Basic
Public Property Radix As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitNumber.Radix"]

See Also

GH_DigitNumber Class
Grasshopper.GUI.Base Namespace


RadixIndex Property

[image]

Grasshopper SDK
GH_DigitNumber..::..RadixIndex Property
GH_DigitNumber Class See Also Send Feedback
Gets the mapped radix.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int RadixIndex { get; }
Visual Basic
Public ReadOnly Property RadixIndex As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitNumber.RadixIndex"]

See Also

GH_DigitNumber Class
Grasshopper.GUI.Base Namespace


SecondaryDigits Property

[image]

Grasshopper SDK
GH_DigitNumber..::..SecondaryDigits Property
GH_DigitNumber Class See Also Send Feedback
Gets the internal list of secondary digits. Do not modify this list.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IList<int> SecondaryDigits { get; }
Visual Basic
Public ReadOnly Property SecondaryDigits As IList(Of Integer)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitNumber.SecondaryDigits"]

See Also

GH_DigitNumber Class
Grasshopper.GUI.Base Namespace


SecondaryPositive Property

[image]

Grasshopper SDK
GH_DigitNumber..::..SecondaryPositive Property
GH_DigitNumber Class See Also Send Feedback
Gets a value indicating whether the secondary number is positive.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool SecondaryPositive { get; }
Visual Basic
Public ReadOnly Property SecondaryPositive As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitNumber.SecondaryPositive"]

See Also

GH_DigitNumber Class
Grasshopper.GUI.Base Namespace


Value Property

[image]

Grasshopper SDK
GH_DigitNumber..::..Value Property
GH_DigitNumber Class See Also Send Feedback
Gets or sets the value of this number.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public decimal Value { get; set; }
Visual Basic
Public Property Value As Decimal
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitNumber.Value"]

See Also

GH_DigitNumber Class
Grasshopper.GUI.Base Namespace


GH_DigitScrollerBase Class

[image]

Grasshopper SDK
GH_DigitScrollerBase Class
Members See Also Send Feedback
Provides Numeric digit scrolling GUI not tied to a control-handle.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_DigitScrollerBase : GH_TextBoxInputBase
Visual Basic
Public Class GH_DigitScrollerBase _
    Inherits GH_TextBoxInputBase

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI.Base..::..GH_TextBoxInputBase
Grasshopper.GUI.Base..::..GH_DigitScrollerBase

See Also

GH_DigitScrollerBase Members
Grasshopper.GUI.Base Namespace


GH_DigitScrollerBase Members

[image] [image]

Grasshopper SDK
GH_DigitScrollerBase Members
GH_DigitScrollerBase Class Constructors Methods Fields Properties Events See Also Send Feedback

The GH_DigitScrollerBase type exposes the following members.

Constructors

 | Name | Description
Public method | GH_DigitScrollerBase | Initializes a new instance of the GH_DigitScrollerBase class

Methods

 | Name | Description
Protected method | HandleTextInputAccepted | (Overrides GH_TextBoxInputBase..::..HandleTextInputAccepted(String).)
Public method | HideTextInputBox | Hides the text-input override form (if it is displayed). (Inherited from GH_TextBoxInputBase.)
Public method | MouseDown | Respond to mouse-down events.
Public method | MouseMove | Respond to mouse-move events.
Public method | MouseUp | Respond to mouse-up events.
Public method | OnInvalidated | Raise the Invalidated event.
Public method | OnValueChanged | Raise the ValueChanged event.
Public method | Render | Render all UI elements.
Public method | RespondToEnter | (Inherited from GH_TextBoxInputBase.)
Public method | RespondToEscape | (Inherited from GH_TextBoxInputBase.)
Public method | SetupScroller | Set the minimum, maximum and value fields simultaneously.
Public method | ShowTextInputBox(Control) |
Public method | ShowTextInputBox(Control, Boolean) |
Public method | ShowTextInputBox(Control, Boolean, Matrix) |
Public method | ShowTextInputBox(Control, String, Boolean) | Display a floating text-box on top of the owner control. (Inherited from GH_TextBoxInputBase.)
Public method | ShowTextInputBox(Control, String, Boolean, Boolean) | Display a floating text-box on top of the owner control. (Inherited from GH_TextBoxInputBase.)
Public method | ShowTextInputBox(Control, String, Boolean, Boolean, Matrix) | Display a floating text-box on top of the owner control. (Inherited from GH_TextBoxInputBase.)

Fields

Name | Description
DigitBoxWidth |
SymbolBoxWidth |

Properties

 | Name | Description
Public property | AllowRadixDrag | Gets or sets a value indicating whether the radix is allowed to be dragged around.
Public property | AllowTextInput | Gets or sets whether text input is allowed by double click.
Public property | AmplifyMotion | Gets or sets a value indicating whether vertical mouse drags should be amplified as the mouse moves further and further.
Public property | BackgroundGradient | Gets or sets the background Gradient. If the gradient is not null, it overrides the background colours.
Public property | BottomColour | Gets or sets the colour used along the bottom edge of the control.
Public property | Bounds | Gets or sets the Bounds for this scroller. (Overrides GH_TextBoxInputBase..::..Bounds.)
Public property | DecimalPlaces | Gets or sets the number of decimal places available in this scroller. Unlike Radix, this property maintains the decimal position of the value represented by this scroller.
Public property | DigitAlign | Gets or sets the digit align mode.
Public property | Digits | Gets or sets the number of digits available in this scroller.
Public property | DrawBackground | Gets or sets whether the background is drawn in this control.
Public property | DrawBorder | Gets or sets whether the border is drawn in this control.
Public property | DrawShadows | Gets or sets whether shadows are drawn in this control.
Public property | EdgeColour | Gets or sets the edge colour of the control.
Public property | Epsilon | Gets the smallest possible change in the value.
Public property | Font | Gets or sets the Font for this scroller. (Overrides GH_TextBoxInputBase..::..Font.)
Public property | IsTextInput | Gets whether the text input box is currently on screen. (Inherited from GH_TextBoxInputBase.)
Public property | MaximumValue | Gets or sets the upper bound of the scroll value.
Public property | MinimumValue | Gets or sets the lower bound of the scroll value.
Public property | Prefix | Gets or sets the prefix text to be displayed on the scroller.
Public property | PrefixBox | Gets the box containing the prefix string. If there is no prefix the PrefixBox will be Rectangle.Empty
Public property | Radix | Gets or sets the radix index of this scroller.
Public property | RadixBox | Gets the Radix box for this control, if there is no radix box, Rectangle.Empty will be returned.
Public property | RailColour | Gets or sets the colour used for the rail line.
Public property | RaiseEvents | Gets or sets whether this scroller raises the ValueChanged event.
Public property | ScrollBoxes | Gets all scroll boxes (from left to right) for this control, not including the radix box.
Public property | ShadowColour | Gets or sets the colour used for the shadows.
Public property | ShadowSize | Gets or sets the size of the drop shadow along all four edges.
Public property | SignBox | Gets the Sign box for this control.
Public property | Suffix | Gets or sets the suffix text to be displayed on the scroller.
Public property | SuffixBox | Gets the box containing the suffix string. If there is no suffix the PrefixBox will have zero width
Public property | TextColour | Gets or sets the colour used for the text inside the scrolls.
Public property | TopColour | Gets or sets the colour used along the top edge of the control.
Public property | Value | Gets or sets the value displayed in this scroller.

Events

 | Name | Description
Public event | Invalidated | Raised whenever the display of this scroller is changed, but not the value.
Public event | ValueChanged | Raised whenever the value of this scroller is changed due to User-Interface methods.

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


GH_DigitScrollerBase Constructor

[image]

Grasshopper SDK
GH_DigitScrollerBase Constructor
GH_DigitScrollerBase Class See Also Send Feedback
Initializes a new instance of the GH_DigitScrollerBase class

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_DigitScrollerBase()
Visual Basic
Public Sub New

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


GH_DigitScrollerBase Fields

[image] [image]

Grasshopper SDK
GH_DigitScrollerBase Fields
GH_DigitScrollerBase Class See Also Send Feedback

The GH_DigitScrollerBase type exposes the following members.

Fields

Name | Description
DigitBoxWidth |
SymbolBoxWidth |

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


DigitBoxWidth Field

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..DigitBoxWidth Field
GH_DigitScrollerBase Class See Also Send Feedback

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const int DigitBoxWidth
Visual Basic
Public Const DigitBoxWidth As Integer

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


SymbolBoxWidth Field

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..SymbolBoxWidth Field
GH_DigitScrollerBase Class See Also Send Feedback

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const int SymbolBoxWidth
Visual Basic
Public Const SymbolBoxWidth As Integer

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


GH_DigitScrollerBase Methods

[image] [image]

Grasshopper SDK
GH_DigitScrollerBase Methods
GH_DigitScrollerBase Class See Also Send Feedback

The GH_DigitScrollerBase type exposes the following members.

Methods

 | Name | Description
Protected method | HandleTextInputAccepted | (Overrides GH_TextBoxInputBase..::..HandleTextInputAccepted(String).)
Public method | HideTextInputBox | Hides the text-input override form (if it is displayed). (Inherited from GH_TextBoxInputBase.)
Public method | MouseDown | Respond to mouse-down events.
Public method | MouseMove | Respond to mouse-move events.
Public method | MouseUp | Respond to mouse-up events.
Public method | OnInvalidated | Raise the Invalidated event.
Public method | OnValueChanged | Raise the ValueChanged event.
Public method | Render | Render all UI elements.
Public method | RespondToEnter | (Inherited from GH_TextBoxInputBase.)
Public method | RespondToEscape | (Inherited from GH_TextBoxInputBase.)
Public method | SetupScroller | Set the minimum, maximum and value fields simultaneously.
Public method | ShowTextInputBox(Control) |
Public method | ShowTextInputBox(Control, Boolean) |
Public method | ShowTextInputBox(Control, Boolean, Matrix) |
Public method | ShowTextInputBox(Control, String, Boolean) | Display a floating text-box on top of the owner control. (Inherited from GH_TextBoxInputBase.)
Public method | ShowTextInputBox(Control, String, Boolean, Boolean) | Display a floating text-box on top of the owner control. (Inherited from GH_TextBoxInputBase.)
Public method | ShowTextInputBox(Control, String, Boolean, Boolean, Matrix) | Display a floating text-box on top of the owner control. (Inherited from GH_TextBoxInputBase.)

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


HandleTextInputAccepted Method

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..HandleTextInputAccepted Method
GH_DigitScrollerBase Class See Also Send Feedback

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void HandleTextInputAccepted(
    string text
)
Visual Basic
Protected Overrides Sub HandleTextInputAccepted ( _
    text As String _
)

Parameters

text
Type: System..::..String

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


MouseDown Method

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..MouseDown Method
GH_DigitScrollerBase Class See Also Send Feedback
Respond to mouse-down events.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_DigitScrollerBase..::..GH_MouseAction MouseDown(
    MouseEventArgs args,
    PointF pt
)
Visual Basic
Public Function MouseDown ( _
    args As MouseEventArgs, _
    pt As PointF _
) As GH_DigitScrollerBase..::..GH_MouseAction

Parameters

args
Type: System.Windows.Forms..::..MouseEventArgs
Mouse Event arguments.
pt
Type: System.Drawing..::..PointF
Mouse cursor position in floating point accuracy.

Return Value

True if a Drag operation was started, false if the event went unnoticed.

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


MouseMove Method

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..MouseMove Method
GH_DigitScrollerBase Class See Also Send Feedback
Respond to mouse-move events.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool MouseMove(
    MouseEventArgs args,
    PointF pt
)
Visual Basic
Public Function MouseMove ( _
    args As MouseEventArgs, _
    pt As PointF _
) As Boolean

Parameters

args
Type: System.Windows.Forms..::..MouseEventArgs
Mouse Event arguments.
pt
Type: System.Drawing..::..PointF
Mouse cursor position in floating point accuracy.

Return Value

True if a Drag operation was performed, false if the event went unnoticed.

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


MouseUp Method

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..MouseUp Method
GH_DigitScrollerBase Class See Also Send Feedback
Respond to mouse-up events.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool MouseUp(
    MouseEventArgs args,
    PointF pt
)
Visual Basic
Public Function MouseUp ( _
    args As MouseEventArgs, _
    pt As PointF _
) As Boolean

Parameters

args
Type: System.Windows.Forms..::..MouseEventArgs
Mouse Event arguments.
pt
Type: System.Drawing..::..PointF
Mouse cursor position in floating point accuracy.

Return Value

True if a Drag operation was terminated, false if the event went unnoticed.

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


OnInvalidated Method

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..OnInvalidated Method
GH_DigitScrollerBase Class See Also Send Feedback
Raise the Invalidated event.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void OnInvalidated()
Visual Basic
Public Sub OnInvalidated

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


OnValueChanged Method

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..OnValueChanged Method
GH_DigitScrollerBase Class See Also Send Feedback
Raise the ValueChanged event.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void OnValueChanged(
    bool intermediate
)
Visual Basic
Public Sub OnValueChanged ( _
    intermediate As Boolean _
)

Parameters

intermediate
Type: System..::..Boolean
Set the intermediate state of the event arguments.

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


Render Method

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..Render Method
GH_DigitScrollerBase Class See Also Send Feedback
Render all UI elements.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Render(
    Graphics G
)
Visual Basic
Public Sub Render ( _
    G As Graphics _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


SetupScroller Method

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..SetupScroller Method
GH_DigitScrollerBase Class See Also Send Feedback
Set the minimum, maximum and value fields simultaneously.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SetupScroller(
    decimal minimum,
    decimal maximum,
    decimal value
)
Visual Basic
Public Sub SetupScroller ( _
    minimum As Decimal, _
    maximum As Decimal, _
    value As Decimal _
)

Parameters

minimum
Type: System..::..Decimal
maximum
Type: System..::..Decimal
value
Type: System..::..Decimal

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


ShowTextInputBox Method

[image] [image]

Grasshopper SDK
GH_DigitScrollerBase..::..ShowTextInputBox Method
GH_DigitScrollerBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ShowTextInputBox(Control) |
Public method | ShowTextInputBox(Control, Boolean) |
Public method | ShowTextInputBox(Control, Boolean, Matrix) |
Public method | ShowTextInputBox(Control, String, Boolean) | Display a floating text-box on top of the owner control. (Inherited from GH_TextBoxInputBase.)
Public method | ShowTextInputBox(Control, String, Boolean, Boolean) | Display a floating text-box on top of the owner control. (Inherited from GH_TextBoxInputBase.)
Public method | ShowTextInputBox(Control, String, Boolean, Boolean, Matrix) | Display a floating text-box on top of the owner control. (Inherited from GH_TextBoxInputBase.)

See Also

GH_DigitScrollerBase Class
GH_DigitScrollerBase Members
Grasshopper.GUI.Base Namespace


ShowTextInputBox Method (Control)

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..ShowTextInputBox Method (Control)
GH_DigitScrollerBase Class See Also Send Feedback

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ShowTextInputBox(
    Control owner
)
Visual Basic
Public Sub ShowTextInputBox ( _
    owner As Control _
)

Parameters

owner
Type: System.Windows.Forms..::..Control

See Also

GH_DigitScrollerBase Class
ShowTextInputBox Overload
Grasshopper.GUI.Base Namespace


ShowTextInputBox Method (Control, Boolean)

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..ShowTextInputBox Method (Control, Boolean)
GH_DigitScrollerBase Class See Also Send Feedback

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ShowTextInputBox(
    Control owner,
    bool limitToBoundary
)
Visual Basic
Public Sub ShowTextInputBox ( _
    owner As Control, _
    limitToBoundary As Boolean _
)

Parameters

owner
Type: System.Windows.Forms..::..Control
limitToBoundary
Type: System..::..Boolean

See Also

GH_DigitScrollerBase Class
ShowTextInputBox Overload
Grasshopper.GUI.Base Namespace


ShowTextInputBox Method (Control, Boolean, Matrix)

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..ShowTextInputBox Method (Control, Boolean, Matrix)
GH_DigitScrollerBase Class See Also Send Feedback

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ShowTextInputBox(
    Control owner,
    bool limitToBoundary,
    Matrix transform
)
Visual Basic
Public Sub ShowTextInputBox ( _
    owner As Control, _
    limitToBoundary As Boolean, _
    transform As Matrix _
)

Parameters

owner
Type: System.Windows.Forms..::..Control
limitToBoundary
Type: System..::..Boolean
transform
Type: System.Drawing.Drawing2D..::..Matrix

See Also

GH_DigitScrollerBase Class
ShowTextInputBox Overload
Grasshopper.GUI.Base Namespace


GH_DigitScrollerBase Properties

[image] [image]

Grasshopper SDK
GH_DigitScrollerBase Properties
GH_DigitScrollerBase Class See Also Send Feedback

The GH_DigitScrollerBase type exposes the following members.

Properties

 | Name | Description
Public property | AllowRadixDrag | Gets or sets a value indicating whether the radix is allowed to be dragged around.
Public property | AllowTextInput | Gets or sets whether text input is allowed by double click.
Public property | AmplifyMotion | Gets or sets a value indicating whether vertical mouse drags should be amplified as the mouse moves further and further.
Public property | BackgroundGradient | Gets or sets the background Gradient. If the gradient is not null, it overrides the background colours.
Public property | BottomColour | Gets or sets the colour used along the bottom edge of the control.
Public property | Bounds | Gets or sets the Bounds for this scroller. (Overrides GH_TextBoxInputBase..::..Bounds.)
Public property | DecimalPlaces | Gets or sets the number of decimal places available in this scroller. Unlike Radix, this property maintains the decimal position of the value represented by this scroller.
Public property | DigitAlign | Gets or sets the digit align mode.
Public property | Digits | Gets or sets the number of digits available in this scroller.
Public property | DrawBackground | Gets or sets whether the background is drawn in this control.
Public property | DrawBorder | Gets or sets whether the border is drawn in this control.
Public property | DrawShadows | Gets or sets whether shadows are drawn in this control.
Public property | EdgeColour | Gets or sets the edge colour of the control.
Public property | Epsilon | Gets the smallest possible change in the value.
Public property | Font | Gets or sets the Font for this scroller. (Overrides GH_TextBoxInputBase..::..Font.)
Public property | IsTextInput | Gets whether the text input box is currently on screen. (Inherited from GH_TextBoxInputBase.)
Public property | MaximumValue | Gets or sets the upper bound of the scroll value.
Public property | MinimumValue | Gets or sets the lower bound of the scroll value.
Public property | Prefix | Gets or sets the prefix text to be displayed on the scroller.
Public property | PrefixBox | Gets the box containing the prefix string. If there is no prefix the PrefixBox will be Rectangle.Empty
Public property | Radix | Gets or sets the radix index of this scroller.
Public property | RadixBox | Gets the Radix box for this control, if there is no radix box, Rectangle.Empty will be returned.
Public property | RailColour | Gets or sets the colour used for the rail line.
Public property | RaiseEvents | Gets or sets whether this scroller raises the ValueChanged event.
Public property | ScrollBoxes | Gets all scroll boxes (from left to right) for this control, not including the radix box.
Public property | ShadowColour | Gets or sets the colour used for the shadows.
Public property | ShadowSize | Gets or sets the size of the drop shadow along all four edges.
Public property | SignBox | Gets the Sign box for this control.
Public property | Suffix | Gets or sets the suffix text to be displayed on the scroller.
Public property | SuffixBox | Gets the box containing the suffix string. If there is no suffix the PrefixBox will have zero width
Public property | TextColour | Gets or sets the colour used for the text inside the scrolls.
Public property | TopColour | Gets or sets the colour used along the top edge of the control.
Public property | Value | Gets or sets the value displayed in this scroller.

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


AllowRadixDrag Property

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..AllowRadixDrag Property
GH_DigitScrollerBase Class See Also Send Feedback
Gets or sets a value indicating whether the radix is allowed to be dragged around.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool AllowRadixDrag { get; set; }
Visual Basic
Public Property AllowRadixDrag As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitScrollerBase.AllowRadixDrag"]

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


AllowTextInput Property

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..AllowTextInput Property
GH_DigitScrollerBase Class See Also Send Feedback
Gets or sets whether text input is allowed by double click.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool AllowTextInput { get; set; }
Visual Basic
Public Property AllowTextInput As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitScrollerBase.AllowTextInput"]

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


AmplifyMotion Property

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..AmplifyMotion Property
GH_DigitScrollerBase Class See Also Send Feedback
Gets or sets a value indicating whether vertical mouse drags should be amplified as the mouse moves further and further.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool AmplifyMotion { get; set; }
Visual Basic
Public Property AmplifyMotion As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitScrollerBase.AmplifyMotion"]

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


BackgroundGradient Property

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..BackgroundGradient Property
GH_DigitScrollerBase Class See Also Send Feedback
Gets or sets the background Gradient. If the gradient is not null, it overrides the background colours.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Gradient BackgroundGradient { get; set; }
Visual Basic
Public Property BackgroundGradient As GH_Gradient
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitScrollerBase.BackgroundGradient"]

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


BottomColour Property

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..BottomColour Property
GH_DigitScrollerBase Class See Also Send Feedback
Gets or sets the colour used along the bottom edge of the control.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color BottomColour { get; set; }
Visual Basic
Public Property BottomColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitScrollerBase.BottomColour"]

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


Bounds Property

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..Bounds Property
GH_DigitScrollerBase Class See Also Send Feedback
Gets or sets the Bounds for this scroller.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override Rectangle Bounds { get; set; }
Visual Basic
Public Overrides Property Bounds As Rectangle
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitScrollerBase.Bounds"]

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


DecimalPlaces Property

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..DecimalPlaces Property
GH_DigitScrollerBase Class See Also Send Feedback
Gets or sets the number of decimal places available in this scroller. Unlike Radix, this property maintains the decimal position of the value represented by this scroller.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int DecimalPlaces { get; set; }
Visual Basic
Public Property DecimalPlaces As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitScrollerBase.DecimalPlaces"]

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


DigitAlign Property

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..DigitAlign Property
GH_DigitScrollerBase Class See Also Send Feedback
Gets or sets the digit align mode.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_DigitAlign DigitAlign { get; set; }
Visual Basic
Public Property DigitAlign As GH_DigitAlign
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitScrollerBase.DigitAlign"]

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


Digits Property

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..Digits Property
GH_DigitScrollerBase Class See Also Send Feedback
Gets or sets the number of digits available in this scroller.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int Digits { get; set; }
Visual Basic
Public Property Digits As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitScrollerBase.Digits"]

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


DrawBackground Property

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..DrawBackground Property
GH_DigitScrollerBase Class See Also Send Feedback
Gets or sets whether the background is drawn in this control.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool DrawBackground { get; set; }
Visual Basic
Public Property DrawBackground As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitScrollerBase.DrawBackground"]

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


DrawBorder Property

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..DrawBorder Property
GH_DigitScrollerBase Class See Also Send Feedback
Gets or sets whether the border is drawn in this control.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool DrawBorder { get; set; }
Visual Basic
Public Property DrawBorder As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitScrollerBase.DrawBorder"]

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


DrawShadows Property

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..DrawShadows Property
GH_DigitScrollerBase Class See Also Send Feedback
Gets or sets whether shadows are drawn in this control.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool DrawShadows { get; set; }
Visual Basic
Public Property DrawShadows As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitScrollerBase.DrawShadows"]

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


EdgeColour Property

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..EdgeColour Property
GH_DigitScrollerBase Class See Also Send Feedback
Gets or sets the edge colour of the control.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color EdgeColour { get; set; }
Visual Basic
Public Property EdgeColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitScrollerBase.EdgeColour"]

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


Epsilon Property

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..Epsilon Property
GH_DigitScrollerBase Class See Also Send Feedback
Gets the smallest possible change in the value.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public decimal Epsilon { get; }
Visual Basic
Public ReadOnly Property Epsilon As Decimal
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitScrollerBase.Epsilon"]

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


Font Property

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..Font Property
GH_DigitScrollerBase Class See Also Send Feedback
Gets or sets the Font for this scroller.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override Font Font { get; set; }
Visual Basic
Public Overrides Property Font As Font
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitScrollerBase.Font"]

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


MaximumValue Property

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..MaximumValue Property
GH_DigitScrollerBase Class See Also Send Feedback
Gets or sets the upper bound of the scroll value.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public decimal MaximumValue { get; set; }
Visual Basic
Public Property MaximumValue As Decimal
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitScrollerBase.MaximumValue"]

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


MinimumValue Property

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..MinimumValue Property
GH_DigitScrollerBase Class See Also Send Feedback
Gets or sets the lower bound of the scroll value.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public decimal MinimumValue { get; set; }
Visual Basic
Public Property MinimumValue As Decimal
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitScrollerBase.MinimumValue"]

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


Prefix Property

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..Prefix Property
GH_DigitScrollerBase Class See Also Send Feedback
Gets or sets the prefix text to be displayed on the scroller.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Prefix { get; set; }
Visual Basic
Public Property Prefix As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitScrollerBase.Prefix"]

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


PrefixBox Property

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..PrefixBox Property
GH_DigitScrollerBase Class See Also Send Feedback
Gets the box containing the prefix string. If there is no prefix the PrefixBox will be Rectangle.Empty

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle PrefixBox { get; }
Visual Basic
Public ReadOnly Property PrefixBox As Rectangle
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitScrollerBase.PrefixBox"]

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


Radix Property

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..Radix Property
GH_DigitScrollerBase Class See Also Send Feedback
Gets or sets the radix index of this scroller.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int Radix { get; set; }
Visual Basic
Public Property Radix As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitScrollerBase.Radix"]

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


RadixBox Property

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..RadixBox Property
GH_DigitScrollerBase Class See Also Send Feedback
Gets the Radix box for this control, if there is no radix box, Rectangle.Empty will be returned.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle RadixBox { get; }
Visual Basic
Public ReadOnly Property RadixBox As Rectangle
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitScrollerBase.RadixBox"]

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


RailColour Property

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..RailColour Property
GH_DigitScrollerBase Class See Also Send Feedback
Gets or sets the colour used for the rail line.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color RailColour { get; set; }
Visual Basic
Public Property RailColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitScrollerBase.RailColour"]

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


RaiseEvents Property

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..RaiseEvents Property
GH_DigitScrollerBase Class See Also Send Feedback
Gets or sets whether this scroller raises the ValueChanged event.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool RaiseEvents { get; set; }
Visual Basic
Public Property RaiseEvents As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitScrollerBase.RaiseEvents"]

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


ScrollBoxes Property

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..ScrollBoxes Property
GH_DigitScrollerBase Class See Also Send Feedback
Gets all scroll boxes (from left to right) for this control, not including the radix box.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<Rectangle> ScrollBoxes { get; }
Visual Basic
Public ReadOnly Property ScrollBoxes As List(Of Rectangle)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitScrollerBase.ScrollBoxes"]

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


ShadowColour Property

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..ShadowColour Property
GH_DigitScrollerBase Class See Also Send Feedback
Gets or sets the colour used for the shadows.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color ShadowColour { get; set; }
Visual Basic
Public Property ShadowColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitScrollerBase.ShadowColour"]

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


ShadowSize Property

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..ShadowSize Property
GH_DigitScrollerBase Class See Also Send Feedback
Gets or sets the size of the drop shadow along all four edges.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Padding ShadowSize { get; set; }
Visual Basic
Public Property ShadowSize As Padding
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitScrollerBase.ShadowSize"]

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


SignBox Property

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..SignBox Property
GH_DigitScrollerBase Class See Also Send Feedback
Gets the Sign box for this control.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle SignBox { get; }
Visual Basic
Public ReadOnly Property SignBox As Rectangle
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitScrollerBase.SignBox"]

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


Suffix Property

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..Suffix Property
GH_DigitScrollerBase Class See Also Send Feedback
Gets or sets the suffix text to be displayed on the scroller.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Suffix { get; set; }
Visual Basic
Public Property Suffix As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitScrollerBase.Suffix"]

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


SuffixBox Property

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..SuffixBox Property
GH_DigitScrollerBase Class See Also Send Feedback
Gets the box containing the suffix string. If there is no suffix the PrefixBox will have zero width

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle SuffixBox { get; }
Visual Basic
Public ReadOnly Property SuffixBox As Rectangle
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitScrollerBase.SuffixBox"]

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


TextColour Property

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..TextColour Property
GH_DigitScrollerBase Class See Also Send Feedback
Gets or sets the colour used for the text inside the scrolls.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color TextColour { get; set; }
Visual Basic
Public Property TextColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitScrollerBase.TextColour"]

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


TopColour Property

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..TopColour Property
GH_DigitScrollerBase Class See Also Send Feedback
Gets or sets the colour used along the top edge of the control.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color TopColour { get; set; }
Visual Basic
Public Property TopColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitScrollerBase.TopColour"]

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


Value Property

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..Value Property
GH_DigitScrollerBase Class See Also Send Feedback
Gets or sets the value displayed in this scroller.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public decimal Value { get; set; }
Visual Basic
Public Property Value As Decimal
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitScrollerBase.Value"]

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


GH_DigitScrollerBase Events

[image] [image]

Grasshopper SDK
GH_DigitScrollerBase Events
GH_DigitScrollerBase Class See Also Send Feedback

The GH_DigitScrollerBase type exposes the following members.

Events

 | Name | Description
Public event | Invalidated | Raised whenever the display of this scroller is changed, but not the value.
Public event | ValueChanged | Raised whenever the value of this scroller is changed due to User-Interface methods.

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


Invalidated Event

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..Invalidated Event
GH_DigitScrollerBase Class See Also Send Feedback
Raised whenever the display of this scroller is changed, but not the value.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_DigitScrollerBase..::..InvalidatedEventHandler Invalidated
Visual Basic
Public Event Invalidated As GH_DigitScrollerBase..::..InvalidatedEventHandler

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


ValueChanged Event

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..ValueChanged Event
GH_DigitScrollerBase Class See Also Send Feedback
Raised whenever the value of this scroller is changed due to User-Interface methods.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_DigitScrollerBase..::..ValueChangedEventHandler ValueChanged
Visual Basic
Public Event ValueChanged As GH_DigitScrollerBase..::..ValueChangedEventHandler

See Also

GH_DigitScrollerBase Class
Grasshopper.GUI.Base Namespace


GH_DigitScrollerBase.GH_MouseAction Enumeration

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..GH_MouseAction Enumeration
GH_DigitScrollerBase Class See Also Send Feedback
Enumerates the possible actions due to mouse-down mouse-move events.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_MouseAction
Visual Basic
Public Enumeration GH_MouseAction

Members

Member name | Value | Description
None | 0 | No specific action.
SignDown | 1 | Mouse down on sign symbol.
DigitDown | 2 | Mouse down on scrolling digit.
DigitDrag | 3 | Mouse move on scrolling digit.
RadixDown | 4 | Mouse down on radix point.
RadixDrag | 5 | Mouse move on radix point.

See Also

Grasshopper.GUI.Base Namespace


GH_DigitScrollerBase.InvalidatedEventHandler Delegate

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..InvalidatedEventHandler Delegate
GH_DigitScrollerBase Class See Also Send Feedback

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void InvalidatedEventHandler(
    Object sender,
    EventArgs e
)
Visual Basic
Public Delegate Sub InvalidatedEventHandler ( _
    sender As Object, _
    e As EventArgs _
)

Parameters

sender
Type: System..::..Object
e
Type: System..::..EventArgs

See Also

Grasshopper.GUI.Base Namespace


GH_DigitScrollerBase.ValueChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_DigitScrollerBase..::..ValueChangedEventHandler Delegate
GH_DigitScrollerBase Class See Also Send Feedback

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void ValueChangedEventHandler(
    Object sender,
    GH_DigitScrollerEventArgs e
)
Visual Basic
Public Delegate Sub ValueChangedEventHandler ( _
    sender As Object, _
    e As GH_DigitScrollerEventArgs _
)

Parameters

sender
Type: System..::..Object
e
Type: Grasshopper.GUI.Base..::..GH_DigitScrollerEventArgs

See Also

Grasshopper.GUI.Base Namespace


GH_DigitScrollerEventArgs Class

[image]

Grasshopper SDK
GH_DigitScrollerEventArgs Class
Members See Also Send Feedback
Arguments passed via GH_digitScrollerBase.ValueChanged events.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_DigitScrollerEventArgs : EventArgs
Visual Basic
Public Class GH_DigitScrollerEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Grasshopper.GUI.Base..::..GH_DigitScrollerEventArgs

See Also

GH_DigitScrollerEventArgs Members
Grasshopper.GUI.Base Namespace


GH_DigitScrollerEventArgs Members

[image] [image]

Grasshopper SDK
GH_DigitScrollerEventArgs Members
GH_DigitScrollerEventArgs Class Properties See Also Send Feedback

The GH_DigitScrollerEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Intermediate | Gets a value indicating whether the change was an intermediate one.
Public property | Scroller | Gets the instance of the scroller that raised the event.
Public property | Value | Gets the new value of the slider. This value is cached, so even if the slider subsequently updates, this property remains constant.

See Also

GH_DigitScrollerEventArgs Class
Grasshopper.GUI.Base Namespace


GH_DigitScrollerEventArgs Properties

[image] [image]

Grasshopper SDK
GH_DigitScrollerEventArgs Properties
GH_DigitScrollerEventArgs Class See Also Send Feedback

The GH_DigitScrollerEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Intermediate | Gets a value indicating whether the change was an intermediate one.
Public property | Scroller | Gets the instance of the scroller that raised the event.
Public property | Value | Gets the new value of the slider. This value is cached, so even if the slider subsequently updates, this property remains constant.

See Also

GH_DigitScrollerEventArgs Class
Grasshopper.GUI.Base Namespace


Intermediate Property

[image]

Grasshopper SDK
GH_DigitScrollerEventArgs..::..Intermediate Property
GH_DigitScrollerEventArgs Class See Also Send Feedback
Gets a value indicating whether the change was an intermediate one.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Intermediate { get; }
Visual Basic
Public ReadOnly Property Intermediate As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitScrollerEventArgs.Intermediate"]

See Also

GH_DigitScrollerEventArgs Class
Grasshopper.GUI.Base Namespace


Scroller Property

[image]

Grasshopper SDK
GH_DigitScrollerEventArgs..::..Scroller Property
GH_DigitScrollerEventArgs Class See Also Send Feedback
Gets the instance of the scroller that raised the event.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_DigitScrollerBase Scroller { get; }
Visual Basic
Public ReadOnly Property Scroller As GH_DigitScrollerBase
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitScrollerEventArgs.Scroller"]

See Also

GH_DigitScrollerEventArgs Class
Grasshopper.GUI.Base Namespace


Value Property

[image]

Grasshopper SDK
GH_DigitScrollerEventArgs..::..Value Property
GH_DigitScrollerEventArgs Class See Also Send Feedback
Gets the new value of the slider. This value is cached, so even if the slider subsequently updates, this property remains constant.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public decimal Value { get; }
Visual Basic
Public ReadOnly Property Value As Decimal
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_DigitScrollerEventArgs.Value"]

See Also

GH_DigitScrollerEventArgs Class
Grasshopper.GUI.Base Namespace


GH_ScrollBarVerticalBase Class

[image]

Grasshopper SDK
GH_ScrollBarVerticalBase Class
Members See Also Send Feedback
Provides basic vertical scroll bar logic.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_ScrollBarVerticalBase
Visual Basic
Public Class GH_ScrollBarVerticalBase

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI.Base..::..GH_ScrollBarVerticalBase

See Also

GH_ScrollBarVerticalBase Members
Grasshopper.GUI.Base Namespace


GH_ScrollBarVerticalBase Members

[image] [image]

Grasshopper SDK
GH_ScrollBarVerticalBase Members
GH_ScrollBarVerticalBase Class Constructors Methods Properties See Also Send Feedback

The GH_ScrollBarVerticalBase type exposes the following members.

Constructors

 | Name | Description
Public method | GH_ScrollBarVerticalBase | Initializes a new instance of the GH_ScrollBarVerticalBase class

Methods

 | Name | Description
Public method | BeginDrag | Start a new drag operation.
Public method | ContinueDrag | Continue a drag operation.
Public method | ScrollBar(Rectangle) | Compute the size and position of the scroll bar in the scroll rail.
Public method | ScrollBar(RectangleF) | Compute the size and position of the scroll bar in the scroll rail.

Properties

 | Name | Description
Public property | Content | Gets or sets the height of the content
Public property | ContentOffset | Gets the vertical offset (in pixels) of the scrolled content.
Public property | Display | Gets or sets the height of the display area.
Public property | Minimum | Gets or sets the minimum height of the scrollbar.
Public property | Offset | Gets the offset of the scroller.
Public property | OffsetNormalised | Gets or sets the normalised offset of the scroller.

See Also

GH_ScrollBarVerticalBase Class
Grasshopper.GUI.Base Namespace


GH_ScrollBarVerticalBase Constructor

[image]

Grasshopper SDK
GH_ScrollBarVerticalBase Constructor
GH_ScrollBarVerticalBase Class See Also Send Feedback
Initializes a new instance of the GH_ScrollBarVerticalBase class

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ScrollBarVerticalBase()
Visual Basic
Public Sub New

See Also

GH_ScrollBarVerticalBase Class
Grasshopper.GUI.Base Namespace


GH_ScrollBarVerticalBase Methods

[image] [image]

Grasshopper SDK
GH_ScrollBarVerticalBase Methods
GH_ScrollBarVerticalBase Class See Also Send Feedback

The GH_ScrollBarVerticalBase type exposes the following members.

Methods

 | Name | Description
Public method | BeginDrag | Start a new drag operation.
Public method | ContinueDrag | Continue a drag operation.
Public method | ScrollBar(Rectangle) | Compute the size and position of the scroll bar in the scroll rail.
Public method | ScrollBar(RectangleF) | Compute the size and position of the scroll bar in the scroll rail.

See Also

GH_ScrollBarVerticalBase Class
Grasshopper.GUI.Base Namespace


BeginDrag Method

[image]

Grasshopper SDK
GH_ScrollBarVerticalBase..::..BeginDrag Method
GH_ScrollBarVerticalBase Class See Also Send Feedback
Start a new drag operation.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void BeginDrag(
    RectangleF region,
    double start
)
Visual Basic
Public Sub BeginDrag ( _
    region As RectangleF, _
    start As Double _
)

Parameters

region
Type: System.Drawing..::..RectangleF
Scroll bar region (the rectangle in which the scroll bar is allowed to move).
start
Type: System..::..Double
Vertical offset of scroll drag.

See Also

GH_ScrollBarVerticalBase Class
Grasshopper.GUI.Base Namespace


ContinueDrag Method

[image]

Grasshopper SDK
GH_ScrollBarVerticalBase..::..ContinueDrag Method
GH_ScrollBarVerticalBase Class See Also Send Feedback
Continue a drag operation.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool ContinueDrag(
    double position
)
Visual Basic
Public Function ContinueDrag ( _
    position As Double _
) As Boolean

Parameters

position
Type: System..::..Double
New offset hint.

Return Value

True if the drag resulted in an offset change, false if not.

See Also

GH_ScrollBarVerticalBase Class
Grasshopper.GUI.Base Namespace


ScrollBar Method

[image] [image]

Grasshopper SDK
GH_ScrollBarVerticalBase..::..ScrollBar Method
GH_ScrollBarVerticalBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollBar(Rectangle) | Compute the size and position of the scroll bar in the scroll rail.
Public method | ScrollBar(RectangleF) | Compute the size and position of the scroll bar in the scroll rail.

See Also

GH_ScrollBarVerticalBase Class
GH_ScrollBarVerticalBase Members
Grasshopper.GUI.Base Namespace


ScrollBar Method (Rectangle)

[image]

Grasshopper SDK
GH_ScrollBarVerticalBase..::..ScrollBar Method (Rectangle)
GH_ScrollBarVerticalBase Class See Also Send Feedback
Compute the size and position of the scroll bar in the scroll rail.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle ScrollBar(
    Rectangle rail
)
Visual Basic
Public Function ScrollBar ( _
    rail As Rectangle _
) As Rectangle

Parameters

rail
Type: System.Drawing..::..Rectangle
Rail for scroll bar to move around in.

Return Value

A rectangle describing the location and extends of the scroll bar.

See Also

GH_ScrollBarVerticalBase Class
ScrollBar Overload
Grasshopper.GUI.Base Namespace


ScrollBar Method (RectangleF)

[image]

Grasshopper SDK
GH_ScrollBarVerticalBase..::..ScrollBar Method (RectangleF)
GH_ScrollBarVerticalBase Class See Also Send Feedback
Compute the size and position of the scroll bar in the scroll rail.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public RectangleF ScrollBar(
    RectangleF rail
)
Visual Basic
Public Function ScrollBar ( _
    rail As RectangleF _
) As RectangleF

Parameters

rail
Type: System.Drawing..::..RectangleF
Rail for scroll bar to move around in.

Return Value

A rectangle describing the location and extends of the scroll bar.

See Also

GH_ScrollBarVerticalBase Class
ScrollBar Overload
Grasshopper.GUI.Base Namespace


GH_ScrollBarVerticalBase Properties

[image] [image]

Grasshopper SDK
GH_ScrollBarVerticalBase Properties
GH_ScrollBarVerticalBase Class See Also Send Feedback

The GH_ScrollBarVerticalBase type exposes the following members.

Properties

 | Name | Description
Public property | Content | Gets or sets the height of the content
Public property | ContentOffset | Gets the vertical offset (in pixels) of the scrolled content.
Public property | Display | Gets or sets the height of the display area.
Public property | Minimum | Gets or sets the minimum height of the scrollbar.
Public property | Offset | Gets the offset of the scroller.
Public property | OffsetNormalised | Gets or sets the normalised offset of the scroller.

See Also

GH_ScrollBarVerticalBase Class
Grasshopper.GUI.Base Namespace


Content Property

[image]

Grasshopper SDK
GH_ScrollBarVerticalBase..::..Content Property
GH_ScrollBarVerticalBase Class See Also Send Feedback
Gets or sets the height of the content

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int Content { get; set; }
Visual Basic
Public Property Content As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ScrollBarVerticalBase.Content"]

See Also

GH_ScrollBarVerticalBase Class
Grasshopper.GUI.Base Namespace


ContentOffset Property

[image]

Grasshopper SDK
GH_ScrollBarVerticalBase..::..ContentOffset Property
GH_ScrollBarVerticalBase Class See Also Send Feedback
Gets the vertical offset (in pixels) of the scrolled content.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double ContentOffset { get; }
Visual Basic
Public ReadOnly Property ContentOffset As Double
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ScrollBarVerticalBase.ContentOffset"]

See Also

GH_ScrollBarVerticalBase Class
Grasshopper.GUI.Base Namespace


Display Property

[image]

Grasshopper SDK
GH_ScrollBarVerticalBase..::..Display Property
GH_ScrollBarVerticalBase Class See Also Send Feedback
Gets or sets the height of the display area.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int Display { get; set; }
Visual Basic
Public Property Display As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ScrollBarVerticalBase.Display"]

See Also

GH_ScrollBarVerticalBase Class
Grasshopper.GUI.Base Namespace


Minimum Property

[image]

Grasshopper SDK
GH_ScrollBarVerticalBase..::..Minimum Property
GH_ScrollBarVerticalBase Class See Also Send Feedback
Gets or sets the minimum height of the scrollbar.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int Minimum { get; set; }
Visual Basic
Public Property Minimum As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ScrollBarVerticalBase.Minimum"]

See Also

GH_ScrollBarVerticalBase Class
Grasshopper.GUI.Base Namespace


Offset Property

[image]

Grasshopper SDK
GH_ScrollBarVerticalBase..::..Offset Property
GH_ScrollBarVerticalBase Class See Also Send Feedback
Gets the offset of the scroller.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int Offset { get; }
Visual Basic
Public ReadOnly Property Offset As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ScrollBarVerticalBase.Offset"]

See Also

GH_ScrollBarVerticalBase Class
Grasshopper.GUI.Base Namespace


OffsetNormalised Property

[image]

Grasshopper SDK
GH_ScrollBarVerticalBase..::..OffsetNormalised Property
GH_ScrollBarVerticalBase Class See Also Send Feedback
Gets or sets the normalised offset of the scroller.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double OffsetNormalised { get; set; }
Visual Basic
Public Property OffsetNormalised As Double
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_ScrollBarVerticalBase.OffsetNormalised"]

See Also

GH_ScrollBarVerticalBase Class
Grasshopper.GUI.Base Namespace


GH_SliderAccuracy Enumeration

[image]

Grasshopper SDK
GH_SliderAccuracy Enumeration
See Also Send Feedback
Enumerates the possible numeric slider accuracies.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_SliderAccuracy
Visual Basic
Public Enumeration GH_SliderAccuracy

Members

Member name | Value | Description
Float | 0 | Slider supports floating point accuracy.
Integer | 1 | Slider supports integer accuracy.
Even | 2 | Slider only supports even integers.
Odd | 3 | Slider only supports odd integers.

See Also

Grasshopper.GUI.Base Namespace


GH_SliderBase Class

[image]

Grasshopper SDK
GH_SliderBase Class
Members See Also Send Feedback
Provides Numeric slider GUI not tied to a control-handle.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_SliderBase : GH_TextBoxInputBase
Visual Basic
Public Class GH_SliderBase _
    Inherits GH_TextBoxInputBase

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI.Base..::..GH_TextBoxInputBase
Grasshopper.GUI.Base..::..GH_SliderBase

See Also

GH_SliderBase Members
Grasshopper.GUI.Base Namespace


GH_SliderBase Members

[image] [image]

Grasshopper SDK
GH_SliderBase Members
GH_SliderBase Class Constructors Methods Properties Events See Also Send Feedback

The GH_SliderBase type exposes the following members.

Constructors

 | Name | Description
Public method | GH_SliderBase | Initializes a new instance of the GH_SliderBase class

Methods

 | Name | Description
Public method | FixDomain | Fix the limits of the slider. Limits will be rounded according to slider type and accuracy. Also, a minimum range for all types is ensured.
Public method | FixValue | Fix the value of the slider. The value will be rounded according to slider type and accuracy. Also, the value will be clipped to the limits. Before you call this function, ensure the limits are set up correctly.
Protected method | HandleTextInputAccepted | (Overrides GH_TextBoxInputBase..::..HandleTextInputAccepted(String).)
Public method | HideTextInputBox | Hides the text-input override form (if it is displayed). (Inherited from GH_TextBoxInputBase.)
Public method | KeyDown | Respond to a KeyDown event.
Public method | MouseDown | Respond to mouse-down events.
Public method | MouseMove | Respond to mouse-move events.
Public method | MouseUp | Respond to mouse-up events.
Public method | OnValueChanged | Raise the ValueChanged event.
 | ProcessNumber | Process a number using the given slider characteristics.
Public method | Render | Render this slider into a Graphics context.
Public method | RespondToEnter | (Inherited from GH_TextBoxInputBase.)
Public method | RespondToEscape | (Inherited from GH_TextBoxInputBase.)
Public method | ShowTextInputBox(Control) |
Public method | ShowTextInputBox(Control, Boolean) |
Public method | ShowTextInputBox(Control, Boolean, Matrix) |
Public method | ShowTextInputBox(Control, String, Boolean) | Display a floating text-box on top of the owner control. (Inherited from GH_TextBoxInputBase.)
Public method | ShowTextInputBox(Control, Boolean, Matrix, String) |
Public method | ShowTextInputBox(Control, String, Boolean, Boolean) | Display a floating text-box on top of the owner control. (Inherited from GH_TextBoxInputBase.)
Public method | ShowTextInputBox(Control, String, Boolean, Boolean, Matrix) | Display a floating text-box on top of the owner control. (Inherited from GH_TextBoxInputBase.)

Properties

 | Name | Description
Public property | Bounds | Gets or sets the bounds of the slider. (Overrides GH_TextBoxInputBase..::..Bounds.)
Public property | ControlBackColour | Gets or sets the BackColour for this slider control.
Public property | ControlEdgeColour | Gets or sets the EdgeColor for this slider control.
Public property | ControlShadowColour | Gets or sets the Shadow colour for this control.
Public property | DecimalPlaces | Gets or sets the number of decimal places allowed for floating point type sliders. Valid values between zero and 12.
Public property | DrawControlBackground | Gets or sets whether the background of the slider should be drawn.
Public property | DrawControlBorder | Gets or sets whether the border of the slider should be drawn.
Public property | DrawControlShadows | Gets or sets whether the drop shadows of the slider should be drawn.
Public property | Epsilon | Gets the smallest value change supported by the current slider properties.
Public property | Font | Gets or sets the font for this slider. (Overrides GH_TextBoxInputBase..::..Font.)
Public property | FormatMask | Gets or sets the string format mask to use for the display. Should contain at least one "{0}" element.
Public property | Grip | Gets the box of the current grip. If the slider value/limits are not set up correctly then this rectangle may well be outside of the bounds. If the limits are coincident, this will fail (divide by zero).
Public property | GripBottomColour | Gets or sets the fill colour for the bottom edge of the slider grip.
Public property | GripDisplay | Gets or sets how the slider grip (or thumb) is drawn.
Public property | GripEdgeColour | Gets or sets the edge colour for the slider grip.
Public property | GripText | Gets the text that will be drawn on the slider.
Public property | GripTextPure | Gets the text format of the number of this slider value.
Public property | GripTopColour | Gets or sets the fill colour for the top edge of the slider grip.
Public property | GripWidth | Gets an estimate of the maximum number of pixels taken up by the grip. This property depends on many different factors, though should remain constant when other properties are not changed. If the Font hasn't been specified, the default Windows.Forms.Control font is used.
Public property | IsTextInput | Gets whether the text input box is currently on screen. (Inherited from GH_TextBoxInputBase.)
Public property | Maximum | Gets or sets the upper limit of the slider.
Public property | Minimum | Gets or sets the lower limit of the slider.
Public property | NormalizedValue | Gets or sets the normalized value within the slider domain.
Public property | Padding | Gets or sets the padding around the slider border.
Public property | Rail | Gets the shape of the rail. The height of the rectangle will be zero, but the y-position will be rounded to integer precision.
Public property | RailBrightColour | Gets or sets the bright colour used to draw rails and ticks.
Public property | RailDarkColour | Gets or sets the dark colour used to draw rails and ticks.
Public property | RailDisplay | Gets or sets how the slider rail (or track) is drawn.
Public property | RailEmptyColour | Gets or sets the fill colour for the empty portion of the rail.
Public property | RailFullColour | Gets or sets the fill colour for the full portion of the rail.
Public property | RaiseEvents | Gets or sets a value indicating whether this slider raises the ValueChanged event.
Public property | RenderDelegate_Background | Gets or sets the delegate called after the background of the slider has been drawn.
Public property | RenderDelegate_Border | Gets or sets the delegate called after the border of the slider has been drawn.
Public property | RenderDelegate_Grip | Gets or sets the delegate called after the grip of the slider has been drawn.
Public property | RenderDelegate_Rail | Gets or sets the delegate called after the rail of the slider has been drawn.
Public property | RenderDelegate_Ticks | Gets or sets the delegate called after the ticks of the slider have been drawn.
Public property | ShadowSize | Gets or sets the size of the border shadow along all edges of the box.
Public property | TextColour | Gets or sets the fill colour for the slider text.
Public property | TextInputHandlerDelegate | Gets or sets the custom handler for text input. If you do not set a custom handler the default behaviour will be used.
Public property | TickCount | Gets or sets the number of ticks displayed.
Public property | TickDisplay | Gets or sets how the slider ticks are drawn.
Public property | TickFrequency | Gets or sets the frequency of large ticks vs small ticks.
Public property | Ticks | Gets a list of all the tick offset x positions.
Public property | Type | Gets or sets the accuracy type of the slider.
Public property | Value | Gets or sets the value of the slider.
Public property | ValueF | Gets or sets the value of the slider in single precision.

Events

 | Name | Description
Public event | ValueChanged | Raised whenever the value of this slider is changed due to User-Interface methods.

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


GH_SliderBase Constructor

[image]

Grasshopper SDK
GH_SliderBase Constructor
GH_SliderBase Class See Also Send Feedback
Initializes a new instance of the GH_SliderBase class

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_SliderBase()
Visual Basic
Public Sub New

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


GH_SliderBase Methods

[image] [image]

Grasshopper SDK
GH_SliderBase Methods
GH_SliderBase Class See Also Send Feedback

The GH_SliderBase type exposes the following members.

Methods

 | Name | Description
Public method | FixDomain | Fix the limits of the slider. Limits will be rounded according to slider type and accuracy. Also, a minimum range for all types is ensured.
Public method | FixValue | Fix the value of the slider. The value will be rounded according to slider type and accuracy. Also, the value will be clipped to the limits. Before you call this function, ensure the limits are set up correctly.
Protected method | HandleTextInputAccepted | (Overrides GH_TextBoxInputBase..::..HandleTextInputAccepted(String).)
Public method | HideTextInputBox | Hides the text-input override form (if it is displayed). (Inherited from GH_TextBoxInputBase.)
Public method | KeyDown | Respond to a KeyDown event.
Public method | MouseDown | Respond to mouse-down events.
Public method | MouseMove | Respond to mouse-move events.
Public method | MouseUp | Respond to mouse-up events.
Public method | OnValueChanged | Raise the ValueChanged event.
 | ProcessNumber | Process a number using the given slider characteristics.
Public method | Render | Render this slider into a Graphics context.
Public method | RespondToEnter | (Inherited from GH_TextBoxInputBase.)
Public method | RespondToEscape | (Inherited from GH_TextBoxInputBase.)
Public method | ShowTextInputBox(Control) |
Public method | ShowTextInputBox(Control, Boolean) |
Public method | ShowTextInputBox(Control, Boolean, Matrix) |
Public method | ShowTextInputBox(Control, String, Boolean) | Display a floating text-box on top of the owner control. (Inherited from GH_TextBoxInputBase.)
Public method | ShowTextInputBox(Control, Boolean, Matrix, String) |
Public method | ShowTextInputBox(Control, String, Boolean, Boolean) | Display a floating text-box on top of the owner control. (Inherited from GH_TextBoxInputBase.)
Public method | ShowTextInputBox(Control, String, Boolean, Boolean, Matrix) | Display a floating text-box on top of the owner control. (Inherited from GH_TextBoxInputBase.)

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


FixDomain Method

[image]

Grasshopper SDK
GH_SliderBase..::..FixDomain Method
GH_SliderBase Class See Also Send Feedback
Fix the limits of the slider. Limits will be rounded according to slider type and accuracy. Also, a minimum range for all types is ensured.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void FixDomain()
Visual Basic
Public Sub FixDomain

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


FixValue Method

[image]

Grasshopper SDK
GH_SliderBase..::..FixValue Method
GH_SliderBase Class See Also Send Feedback
Fix the value of the slider. The value will be rounded according to slider type and accuracy. Also, the value will be clipped to the limits. Before you call this function, ensure the limits are set up correctly.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void FixValue()
Visual Basic
Public Sub FixValue

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


HandleTextInputAccepted Method

[image]

Grasshopper SDK
GH_SliderBase..::..HandleTextInputAccepted Method
GH_SliderBase Class See Also Send Feedback

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void HandleTextInputAccepted(
    string text
)
Visual Basic
Protected Overrides Sub HandleTextInputAccepted ( _
    text As String _
)

Parameters

text
Type: System..::..String

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


KeyDown Method

[image]

Grasshopper SDK
GH_SliderBase..::..KeyDown Method
GH_SliderBase Class See Also Send Feedback
Respond to a KeyDown event.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool KeyDown(
    KeyEventArgs args
)
Visual Basic
Public Function KeyDown ( _
    args As KeyEventArgs _
) As Boolean

Parameters

args
Type: System.Windows.Forms..::..KeyEventArgs
KeyDown event arguments.

Return Value

True if something changed, false if not.

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


MouseDown Method

[image]

Grasshopper SDK
GH_SliderBase..::..MouseDown Method
GH_SliderBase Class See Also Send Feedback
Respond to mouse-down events.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool MouseDown(
    MouseEventArgs args,
    PointF pt
)
Visual Basic
Public Function MouseDown ( _
    args As MouseEventArgs, _
    pt As PointF _
) As Boolean

Parameters

args
Type: System.Windows.Forms..::..MouseEventArgs
Mouse Event arguments.
pt
Type: System.Drawing..::..PointF
Mouse cursor position in floating point accuracy.

Return Value

True if a Drag operation was started, false if the event went unnoticed.

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


MouseMove Method

[image]

Grasshopper SDK
GH_SliderBase..::..MouseMove Method
GH_SliderBase Class See Also Send Feedback
Respond to mouse-move events.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool MouseMove(
    MouseEventArgs args,
    PointF pt
)
Visual Basic
Public Function MouseMove ( _
    args As MouseEventArgs, _
    pt As PointF _
) As Boolean

Parameters

args
Type: System.Windows.Forms..::..MouseEventArgs
Mouse Event arguments.
pt
Type: System.Drawing..::..PointF
Mouse cursor position in floating point accuracy.

Return Value

True if a Drag operation was performed, false if the event went unnoticed.

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


MouseUp Method

[image]

Grasshopper SDK
GH_SliderBase..::..MouseUp Method
GH_SliderBase Class See Also Send Feedback
Respond to mouse-up events.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool MouseUp(
    MouseEventArgs args,
    PointF pt
)
Visual Basic
Public Function MouseUp ( _
    args As MouseEventArgs, _
    pt As PointF _
) As Boolean

Parameters

args
Type: System.Windows.Forms..::..MouseEventArgs
Mouse Event arguments.
pt
Type: System.Drawing..::..PointF
Mouse cursor position in floating point accuracy.

Return Value

True if a Drag operation was terminated, false if the event went unnoticed.

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


OnValueChanged Method

[image]

Grasshopper SDK
GH_SliderBase..::..OnValueChanged Method
GH_SliderBase Class See Also Send Feedback
Raise the ValueChanged event.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void OnValueChanged(
    bool intermediate
)
Visual Basic
Public Sub OnValueChanged ( _
    intermediate As Boolean _
)

Parameters

intermediate
Type: System..::..Boolean
Set the intermediate state of the event arguments.

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


ProcessNumber Method

[image]

Grasshopper SDK
GH_SliderBase..::..ProcessNumber Method
GH_SliderBase Class See Also Send Feedback
Process a number using the given slider characteristics.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static decimal ProcessNumber(
    decimal val,
    GH_SliderAccuracy accuracy,
    int digits
)
Visual Basic
Public Shared Function ProcessNumber ( _
    val As Decimal, _
    accuracy As GH_SliderAccuracy, _
    digits As Integer _
) As Decimal

Parameters

val
Type: System..::..Decimal
Number to process.
accuracy
Type: Grasshopper.GUI.Base..::..GH_SliderAccuracy
Slider rounding accuracy.
digits
Type: System..::..Int32
Number of digits to use for floating point rounding.

Return Value

Processed number.

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


Render Method

[image]

Grasshopper SDK
GH_SliderBase..::..Render Method
GH_SliderBase Class See Also Send Feedback
Render this slider into a Graphics context.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Render(
    Graphics G
)
Visual Basic
Public Sub Render ( _
    G As Graphics _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics to render with.

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


ShowTextInputBox Method

[image] [image]

Grasshopper SDK
GH_SliderBase..::..ShowTextInputBox Method
GH_SliderBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ShowTextInputBox(Control) |
Public method | ShowTextInputBox(Control, Boolean) |
Public method | ShowTextInputBox(Control, Boolean, Matrix) |
Public method | ShowTextInputBox(Control, String, Boolean) | Display a floating text-box on top of the owner control. (Inherited from GH_TextBoxInputBase.)
Public method | ShowTextInputBox(Control, Boolean, Matrix, String) |
Public method | ShowTextInputBox(Control, String, Boolean, Boolean) | Display a floating text-box on top of the owner control. (Inherited from GH_TextBoxInputBase.)
Public method | ShowTextInputBox(Control, String, Boolean, Boolean, Matrix) | Display a floating text-box on top of the owner control. (Inherited from GH_TextBoxInputBase.)

See Also

GH_SliderBase Class
GH_SliderBase Members
Grasshopper.GUI.Base Namespace


ShowTextInputBox Method (Control)

[image]

Grasshopper SDK
GH_SliderBase..::..ShowTextInputBox Method (Control)
GH_SliderBase Class See Also Send Feedback

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ShowTextInputBox(
    Control owner
)
Visual Basic
Public Sub ShowTextInputBox ( _
    owner As Control _
)

Parameters

owner
Type: System.Windows.Forms..::..Control

See Also

GH_SliderBase Class
ShowTextInputBox Overload
Grasshopper.GUI.Base Namespace


ShowTextInputBox Method (Control, Boolean)

[image]

Grasshopper SDK
GH_SliderBase..::..ShowTextInputBox Method (Control, Boolean)
GH_SliderBase Class See Also Send Feedback

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ShowTextInputBox(
    Control owner,
    bool limitToBoundary
)
Visual Basic
Public Sub ShowTextInputBox ( _
    owner As Control, _
    limitToBoundary As Boolean _
)

Parameters

owner
Type: System.Windows.Forms..::..Control
limitToBoundary
Type: System..::..Boolean

See Also

GH_SliderBase Class
ShowTextInputBox Overload
Grasshopper.GUI.Base Namespace


ShowTextInputBox Method (Control, Boolean, Matrix)

[image]

Grasshopper SDK
GH_SliderBase..::..ShowTextInputBox Method (Control, Boolean, Matrix)
GH_SliderBase Class See Also Send Feedback

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ShowTextInputBox(
    Control owner,
    bool limitToBoundary,
    Matrix transform
)
Visual Basic
Public Sub ShowTextInputBox ( _
    owner As Control, _
    limitToBoundary As Boolean, _
    transform As Matrix _
)

Parameters

owner
Type: System.Windows.Forms..::..Control
limitToBoundary
Type: System..::..Boolean
transform
Type: System.Drawing.Drawing2D..::..Matrix

See Also

GH_SliderBase Class
ShowTextInputBox Overload
Grasshopper.GUI.Base Namespace


ShowTextInputBox Method (Control, Boolean, Matrix, String)

[image]

Grasshopper SDK
GH_SliderBase..::..ShowTextInputBox Method (Control, Boolean, Matrix, String)
GH_SliderBase Class See Also Send Feedback

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ShowTextInputBox(
    Control owner,
    bool limitToBoundary,
    Matrix transform,
    string content
)
Visual Basic
Public Sub ShowTextInputBox ( _
    owner As Control, _
    limitToBoundary As Boolean, _
    transform As Matrix, _
    content As String _
)

Parameters

owner
Type: System.Windows.Forms..::..Control
limitToBoundary
Type: System..::..Boolean
transform
Type: System.Drawing.Drawing2D..::..Matrix
content
Type: System..::..String

See Also

GH_SliderBase Class
ShowTextInputBox Overload
Grasshopper.GUI.Base Namespace


GH_SliderBase Properties

[image] [image]

Grasshopper SDK
GH_SliderBase Properties
GH_SliderBase Class See Also Send Feedback

The GH_SliderBase type exposes the following members.

Properties

 | Name | Description
Public property | Bounds | Gets or sets the bounds of the slider. (Overrides GH_TextBoxInputBase..::..Bounds.)
Public property | ControlBackColour | Gets or sets the BackColour for this slider control.
Public property | ControlEdgeColour | Gets or sets the EdgeColor for this slider control.
Public property | ControlShadowColour | Gets or sets the Shadow colour for this control.
Public property | DecimalPlaces | Gets or sets the number of decimal places allowed for floating point type sliders. Valid values between zero and 12.
Public property | DrawControlBackground | Gets or sets whether the background of the slider should be drawn.
Public property | DrawControlBorder | Gets or sets whether the border of the slider should be drawn.
Public property | DrawControlShadows | Gets or sets whether the drop shadows of the slider should be drawn.
Public property | Epsilon | Gets the smallest value change supported by the current slider properties.
Public property | Font | Gets or sets the font for this slider. (Overrides GH_TextBoxInputBase..::..Font.)
Public property | FormatMask | Gets or sets the string format mask to use for the display. Should contain at least one "{0}" element.
Public property | Grip | Gets the box of the current grip. If the slider value/limits are not set up correctly then this rectangle may well be outside of the bounds. If the limits are coincident, this will fail (divide by zero).
Public property | GripBottomColour | Gets or sets the fill colour for the bottom edge of the slider grip.
Public property | GripDisplay | Gets or sets how the slider grip (or thumb) is drawn.
Public property | GripEdgeColour | Gets or sets the edge colour for the slider grip.
Public property | GripText | Gets the text that will be drawn on the slider.
Public property | GripTextPure | Gets the text format of the number of this slider value.
Public property | GripTopColour | Gets or sets the fill colour for the top edge of the slider grip.
Public property | GripWidth | Gets an estimate of the maximum number of pixels taken up by the grip. This property depends on many different factors, though should remain constant when other properties are not changed. If the Font hasn't been specified, the default Windows.Forms.Control font is used.
Public property | IsTextInput | Gets whether the text input box is currently on screen. (Inherited from GH_TextBoxInputBase.)
Public property | Maximum | Gets or sets the upper limit of the slider.
Public property | Minimum | Gets or sets the lower limit of the slider.
Public property | NormalizedValue | Gets or sets the normalized value within the slider domain.
Public property | Padding | Gets or sets the padding around the slider border.
Public property | Rail | Gets the shape of the rail. The height of the rectangle will be zero, but the y-position will be rounded to integer precision.
Public property | RailBrightColour | Gets or sets the bright colour used to draw rails and ticks.
Public property | RailDarkColour | Gets or sets the dark colour used to draw rails and ticks.
Public property | RailDisplay | Gets or sets how the slider rail (or track) is drawn.
Public property | RailEmptyColour | Gets or sets the fill colour for the empty portion of the rail.
Public property | RailFullColour | Gets or sets the fill colour for the full portion of the rail.
Public property | RaiseEvents | Gets or sets a value indicating whether this slider raises the ValueChanged event.
Public property | RenderDelegate_Background | Gets or sets the delegate called after the background of the slider has been drawn.
Public property | RenderDelegate_Border | Gets or sets the delegate called after the border of the slider has been drawn.
Public property | RenderDelegate_Grip | Gets or sets the delegate called after the grip of the slider has been drawn.
Public property | RenderDelegate_Rail | Gets or sets the delegate called after the rail of the slider has been drawn.
Public property | RenderDelegate_Ticks | Gets or sets the delegate called after the ticks of the slider have been drawn.
Public property | ShadowSize | Gets or sets the size of the border shadow along all edges of the box.
Public property | TextColour | Gets or sets the fill colour for the slider text.
Public property | TextInputHandlerDelegate | Gets or sets the custom handler for text input. If you do not set a custom handler the default behaviour will be used.
Public property | TickCount | Gets or sets the number of ticks displayed.
Public property | TickDisplay | Gets or sets how the slider ticks are drawn.
Public property | TickFrequency | Gets or sets the frequency of large ticks vs small ticks.
Public property | Ticks | Gets a list of all the tick offset x positions.
Public property | Type | Gets or sets the accuracy type of the slider.
Public property | Value | Gets or sets the value of the slider.
Public property | ValueF | Gets or sets the value of the slider in single precision.

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


Bounds Property

[image]

Grasshopper SDK
GH_SliderBase..::..Bounds Property
GH_SliderBase Class See Also Send Feedback
Gets or sets the bounds of the slider.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override Rectangle Bounds { get; set; }
Visual Basic
Public Overrides Property Bounds As Rectangle
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.Bounds"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


ControlBackColour Property

[image]

Grasshopper SDK
GH_SliderBase..::..ControlBackColour Property
GH_SliderBase Class See Also Send Feedback
Gets or sets the BackColour for this slider control.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color ControlBackColour { get; set; }
Visual Basic
Public Property ControlBackColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.ControlBackColour"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


ControlEdgeColour Property

[image]

Grasshopper SDK
GH_SliderBase..::..ControlEdgeColour Property
GH_SliderBase Class See Also Send Feedback
Gets or sets the EdgeColor for this slider control.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color ControlEdgeColour { get; set; }
Visual Basic
Public Property ControlEdgeColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.ControlEdgeColour"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


ControlShadowColour Property

[image]

Grasshopper SDK
GH_SliderBase..::..ControlShadowColour Property
GH_SliderBase Class See Also Send Feedback
Gets or sets the Shadow colour for this control.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color ControlShadowColour { get; set; }
Visual Basic
Public Property ControlShadowColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.ControlShadowColour"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


DecimalPlaces Property

[image]

Grasshopper SDK
GH_SliderBase..::..DecimalPlaces Property
GH_SliderBase Class See Also Send Feedback
Gets or sets the number of decimal places allowed for floating point type sliders. Valid values between zero and 12.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int DecimalPlaces { get; set; }
Visual Basic
Public Property DecimalPlaces As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.DecimalPlaces"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


DrawControlBackground Property

[image]

Grasshopper SDK
GH_SliderBase..::..DrawControlBackground Property
GH_SliderBase Class See Also Send Feedback
Gets or sets whether the background of the slider should be drawn.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool DrawControlBackground { get; set; }
Visual Basic
Public Property DrawControlBackground As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.DrawControlBackground"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


DrawControlBorder Property

[image]

Grasshopper SDK
GH_SliderBase..::..DrawControlBorder Property
GH_SliderBase Class See Also Send Feedback
Gets or sets whether the border of the slider should be drawn.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool DrawControlBorder { get; set; }
Visual Basic
Public Property DrawControlBorder As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.DrawControlBorder"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


DrawControlShadows Property

[image]

Grasshopper SDK
GH_SliderBase..::..DrawControlShadows Property
GH_SliderBase Class See Also Send Feedback
Gets or sets whether the drop shadows of the slider should be drawn.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool DrawControlShadows { get; set; }
Visual Basic
Public Property DrawControlShadows As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.DrawControlShadows"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


Epsilon Property

[image]

Grasshopper SDK
GH_SliderBase..::..Epsilon Property
GH_SliderBase Class See Also Send Feedback
Gets the smallest value change supported by the current slider properties.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public decimal Epsilon { get; }
Visual Basic
Public ReadOnly Property Epsilon As Decimal
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.Epsilon"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


Font Property

[image]

Grasshopper SDK
GH_SliderBase..::..Font Property
GH_SliderBase Class See Also Send Feedback
Gets or sets the font for this slider.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override Font Font { get; set; }
Visual Basic
Public Overrides Property Font As Font
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.Font"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


FormatMask Property

[image]

Grasshopper SDK
GH_SliderBase..::..FormatMask Property
GH_SliderBase Class See Also Send Feedback
Gets or sets the string format mask to use for the display. Should contain at least one "{0}" element.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string FormatMask { get; set; }
Visual Basic
Public Property FormatMask As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.FormatMask"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


Grip Property

[image]

Grasshopper SDK
GH_SliderBase..::..Grip Property
GH_SliderBase Class See Also Send Feedback
Gets the box of the current grip. If the slider value/limits are not set up correctly then this rectangle may well be outside of the bounds. If the limits are coincident, this will fail (divide by zero).

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public RectangleF Grip { get; }
Visual Basic
Public ReadOnly Property Grip As RectangleF
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.Grip"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


GripBottomColour Property

[image]

Grasshopper SDK
GH_SliderBase..::..GripBottomColour Property
GH_SliderBase Class See Also Send Feedback
Gets or sets the fill colour for the bottom edge of the slider grip.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color GripBottomColour { get; set; }
Visual Basic
Public Property GripBottomColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.GripBottomColour"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


GripDisplay Property

[image]

Grasshopper SDK
GH_SliderBase..::..GripDisplay Property
GH_SliderBase Class See Also Send Feedback
Gets or sets how the slider grip (or thumb) is drawn.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_SliderGripDisplay GripDisplay { get; set; }
Visual Basic
Public Property GripDisplay As GH_SliderGripDisplay
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.GripDisplay"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


GripEdgeColour Property

[image]

Grasshopper SDK
GH_SliderBase..::..GripEdgeColour Property
GH_SliderBase Class See Also Send Feedback
Gets or sets the edge colour for the slider grip.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color GripEdgeColour { get; set; }
Visual Basic
Public Property GripEdgeColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.GripEdgeColour"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


GripText Property

[image]

Grasshopper SDK
GH_SliderBase..::..GripText Property
GH_SliderBase Class See Also Send Feedback
Gets the text that will be drawn on the slider.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string GripText { get; }
Visual Basic
Public ReadOnly Property GripText As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.GripText"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


GripTextPure Property

[image]

Grasshopper SDK
GH_SliderBase..::..GripTextPure Property
GH_SliderBase Class See Also Send Feedback
Gets the text format of the number of this slider value.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string GripTextPure { get; }
Visual Basic
Public ReadOnly Property GripTextPure As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.GripTextPure"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


GripTopColour Property

[image]

Grasshopper SDK
GH_SliderBase..::..GripTopColour Property
GH_SliderBase Class See Also Send Feedback
Gets or sets the fill colour for the top edge of the slider grip.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color GripTopColour { get; set; }
Visual Basic
Public Property GripTopColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.GripTopColour"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


GripWidth Property

[image]

Grasshopper SDK
GH_SliderBase..::..GripWidth Property
GH_SliderBase Class See Also Send Feedback
Gets an estimate of the maximum number of pixels taken up by the grip. This property depends on many different factors, though should remain constant when other properties are not changed. If the Font hasn't been specified, the default Windows.Forms.Control font is used.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int GripWidth { get; }
Visual Basic
Public ReadOnly Property GripWidth As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.GripWidth"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


Maximum Property

[image]

Grasshopper SDK
GH_SliderBase..::..Maximum Property
GH_SliderBase Class See Also Send Feedback
Gets or sets the upper limit of the slider.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public decimal Maximum { get; set; }
Visual Basic
Public Property Maximum As Decimal
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.Maximum"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


Minimum Property

[image]

Grasshopper SDK
GH_SliderBase..::..Minimum Property
GH_SliderBase Class See Also Send Feedback
Gets or sets the lower limit of the slider.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public decimal Minimum { get; set; }
Visual Basic
Public Property Minimum As Decimal
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.Minimum"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


NormalizedValue Property

[image]

Grasshopper SDK
GH_SliderBase..::..NormalizedValue Property
GH_SliderBase Class See Also Send Feedback
Gets or sets the normalized value within the slider domain.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double NormalizedValue { get; set; }
Visual Basic
Public Property NormalizedValue As Double
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.NormalizedValue"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


Padding Property

[image]

Grasshopper SDK
GH_SliderBase..::..Padding Property
GH_SliderBase Class See Also Send Feedback
Gets or sets the padding around the slider border.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Padding Padding { get; set; }
Visual Basic
Public Property Padding As Padding
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.Padding"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


Rail Property

[image]

Grasshopper SDK
GH_SliderBase..::..Rail Property
GH_SliderBase Class See Also Send Feedback
Gets the shape of the rail. The height of the rectangle will be zero, but the y-position will be rounded to integer precision.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle Rail { get; }
Visual Basic
Public ReadOnly Property Rail As Rectangle
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.Rail"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


RailBrightColour Property

[image]

Grasshopper SDK
GH_SliderBase..::..RailBrightColour Property
GH_SliderBase Class See Also Send Feedback
Gets or sets the bright colour used to draw rails and ticks.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color RailBrightColour { get; set; }
Visual Basic
Public Property RailBrightColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.RailBrightColour"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


RailDarkColour Property

[image]

Grasshopper SDK
GH_SliderBase..::..RailDarkColour Property
GH_SliderBase Class See Also Send Feedback
Gets or sets the dark colour used to draw rails and ticks.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color RailDarkColour { get; set; }
Visual Basic
Public Property RailDarkColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.RailDarkColour"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


RailDisplay Property

[image]

Grasshopper SDK
GH_SliderBase..::..RailDisplay Property
GH_SliderBase Class See Also Send Feedback
Gets or sets how the slider rail (or track) is drawn.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_SliderRailDisplay RailDisplay { get; set; }
Visual Basic
Public Property RailDisplay As GH_SliderRailDisplay
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.RailDisplay"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


RailEmptyColour Property

[image]

Grasshopper SDK
GH_SliderBase..::..RailEmptyColour Property
GH_SliderBase Class See Also Send Feedback
Gets or sets the fill colour for the empty portion of the rail.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color RailEmptyColour { get; set; }
Visual Basic
Public Property RailEmptyColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.RailEmptyColour"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


RailFullColour Property

[image]

Grasshopper SDK
GH_SliderBase..::..RailFullColour Property
GH_SliderBase Class See Also Send Feedback
Gets or sets the fill colour for the full portion of the rail.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color RailFullColour { get; set; }
Visual Basic
Public Property RailFullColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.RailFullColour"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


RaiseEvents Property

[image]

Grasshopper SDK
GH_SliderBase..::..RaiseEvents Property
GH_SliderBase Class See Also Send Feedback
Gets or sets a value indicating whether this slider raises the ValueChanged event.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool RaiseEvents { get; set; }
Visual Basic
Public Property RaiseEvents As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.RaiseEvents"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


RenderDelegate_Background Property

[image]

Grasshopper SDK
GH_SliderBase..::..RenderDelegate_Background Property
GH_SliderBase Class See Also Send Feedback
Gets or sets the delegate called after the background of the slider has been drawn.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_SliderBase..::..DrawSliderChannel RenderDelegate_Background { get; set; }
Visual Basic
Public Property RenderDelegate_Background As GH_SliderBase..::..DrawSliderChannel
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.RenderDelegate_Background"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


RenderDelegate_Border Property

[image]

Grasshopper SDK
GH_SliderBase..::..RenderDelegate_Border Property
GH_SliderBase Class See Also Send Feedback
Gets or sets the delegate called after the border of the slider has been drawn.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_SliderBase..::..DrawSliderChannel RenderDelegate_Border { get; set; }
Visual Basic
Public Property RenderDelegate_Border As GH_SliderBase..::..DrawSliderChannel
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.RenderDelegate_Border"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


RenderDelegate_Grip Property

[image]

Grasshopper SDK
GH_SliderBase..::..RenderDelegate_Grip Property
GH_SliderBase Class See Also Send Feedback
Gets or sets the delegate called after the grip of the slider has been drawn.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_SliderBase..::..DrawSliderChannel RenderDelegate_Grip { get; set; }
Visual Basic
Public Property RenderDelegate_Grip As GH_SliderBase..::..DrawSliderChannel
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.RenderDelegate_Grip"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


RenderDelegate_Rail Property

[image]

Grasshopper SDK
GH_SliderBase..::..RenderDelegate_Rail Property
GH_SliderBase Class See Also Send Feedback
Gets or sets the delegate called after the rail of the slider has been drawn.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_SliderBase..::..DrawSliderChannel RenderDelegate_Rail { get; set; }
Visual Basic
Public Property RenderDelegate_Rail As GH_SliderBase..::..DrawSliderChannel
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.RenderDelegate_Rail"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


RenderDelegate_Ticks Property

[image]

Grasshopper SDK
GH_SliderBase..::..RenderDelegate_Ticks Property
GH_SliderBase Class See Also Send Feedback
Gets or sets the delegate called after the ticks of the slider have been drawn.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_SliderBase..::..DrawSliderChannel RenderDelegate_Ticks { get; set; }
Visual Basic
Public Property RenderDelegate_Ticks As GH_SliderBase..::..DrawSliderChannel
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.RenderDelegate_Ticks"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


ShadowSize Property

[image]

Grasshopper SDK
GH_SliderBase..::..ShadowSize Property
GH_SliderBase Class See Also Send Feedback
Gets or sets the size of the border shadow along all edges of the box.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Padding ShadowSize { get; set; }
Visual Basic
Public Property ShadowSize As Padding
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.ShadowSize"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


TextColour Property

[image]

Grasshopper SDK
GH_SliderBase..::..TextColour Property
GH_SliderBase Class See Also Send Feedback
Gets or sets the fill colour for the slider text.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color TextColour { get; set; }
Visual Basic
Public Property TextColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.TextColour"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


TextInputHandlerDelegate Property

[image]

Grasshopper SDK
GH_SliderBase..::..TextInputHandlerDelegate Property
GH_SliderBase Class See Also Send Feedback
Gets or sets the custom handler for text input. If you do not set a custom handler the default behaviour will be used.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_SliderBase..::..TextInputHandler TextInputHandlerDelegate { get; set; }
Visual Basic
Public Property TextInputHandlerDelegate As GH_SliderBase..::..TextInputHandler
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.TextInputHandlerDelegate"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


TickCount Property

[image]

Grasshopper SDK
GH_SliderBase..::..TickCount Property
GH_SliderBase Class See Also Send Feedback
Gets or sets the number of ticks displayed.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int TickCount { get; set; }
Visual Basic
Public Property TickCount As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.TickCount"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


TickDisplay Property

[image]

Grasshopper SDK
GH_SliderBase..::..TickDisplay Property
GH_SliderBase Class See Also Send Feedback
Gets or sets how the slider ticks are drawn.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_SliderTickDisplay TickDisplay { get; set; }
Visual Basic
Public Property TickDisplay As GH_SliderTickDisplay
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.TickDisplay"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


TickFrequency Property

[image]

Grasshopper SDK
GH_SliderBase..::..TickFrequency Property
GH_SliderBase Class See Also Send Feedback
Gets or sets the frequency of large ticks vs small ticks.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int TickFrequency { get; set; }
Visual Basic
Public Property TickFrequency As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.TickFrequency"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


Ticks Property

[image]

Grasshopper SDK
GH_SliderBase..::..Ticks Property
GH_SliderBase Class See Also Send Feedback
Gets a list of all the tick offset x positions.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<int> Ticks { get; }
Visual Basic
Public ReadOnly Property Ticks As List(Of Integer)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.Ticks"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


Type Property

[image]

Grasshopper SDK
GH_SliderBase..::..Type Property
GH_SliderBase Class See Also Send Feedback
Gets or sets the accuracy type of the slider.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_SliderAccuracy Type { get; set; }
Visual Basic
Public Property Type As GH_SliderAccuracy
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.Type"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


Value Property

[image]

Grasshopper SDK
GH_SliderBase..::..Value Property
GH_SliderBase Class See Also Send Feedback
Gets or sets the value of the slider.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public decimal Value { get; set; }
Visual Basic
Public Property Value As Decimal
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.Value"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


ValueF Property

[image]

Grasshopper SDK
GH_SliderBase..::..ValueF Property
GH_SliderBase Class See Also Send Feedback
Gets or sets the value of the slider in single precision.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public float ValueF { get; set; }
Visual Basic
Public Property ValueF As Single
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderBase.ValueF"]

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


GH_SliderBase Events

[image] [image]

Grasshopper SDK
GH_SliderBase Events
GH_SliderBase Class See Also Send Feedback

The GH_SliderBase type exposes the following members.

Events

 | Name | Description
Public event | ValueChanged | Raised whenever the value of this slider is changed due to User-Interface methods.

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


ValueChanged Event

[image]

Grasshopper SDK
GH_SliderBase..::..ValueChanged Event
GH_SliderBase Class See Also Send Feedback
Raised whenever the value of this slider is changed due to User-Interface methods.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_SliderBase..::..ValueChangedEventHandler ValueChanged
Visual Basic
Public Event ValueChanged As GH_SliderBase..::..ValueChangedEventHandler

See Also

GH_SliderBase Class
Grasshopper.GUI.Base Namespace


GH_SliderBase.DrawSliderChannel Delegate

[image]

Grasshopper SDK
GH_SliderBase..::..DrawSliderChannel Delegate
GH_SliderBase Class See Also Send Feedback
This delegate is used to intervene in the slider drawing process.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void DrawSliderChannel(
    GH_SliderBase slider,
    Graphics G
)
Visual Basic
Public Delegate Sub DrawSliderChannel ( _
    slider As GH_SliderBase, _
    G As Graphics _
)

Parameters

slider
Type: Grasshopper.GUI.Base..::..GH_SliderBase
Slider being drawn.
G
Type: System.Drawing..::..Graphics
Graphics object used for drawing.

See Also

Grasshopper.GUI.Base Namespace


GH_SliderBase.TextInputHandler Delegate

[image]

Grasshopper SDK
GH_SliderBase..::..TextInputHandler Delegate
GH_SliderBase Class See Also Send Feedback
Delegate used during Text Input handling.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void TextInputHandler(
    GH_SliderBase slider,
    string text
)
Visual Basic
Public Delegate Sub TextInputHandler ( _
    slider As GH_SliderBase, _
    text As String _
)

Parameters

slider
Type: Grasshopper.GUI.Base..::..GH_SliderBase
text
Type: System..::..String

See Also

Grasshopper.GUI.Base Namespace


GH_SliderBase.ValueChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_SliderBase..::..ValueChangedEventHandler Delegate
GH_SliderBase Class See Also Send Feedback

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void ValueChangedEventHandler(
    Object sender,
    GH_SliderEventArgs e
)
Visual Basic
Public Delegate Sub ValueChangedEventHandler ( _
    sender As Object, _
    e As GH_SliderEventArgs _
)

Parameters

sender
Type: System..::..Object
e
Type: Grasshopper.GUI.Base..::..GH_SliderEventArgs

See Also

Grasshopper.GUI.Base Namespace


GH_SliderEventArgs Class

[image]

Grasshopper SDK
GH_SliderEventArgs Class
Members See Also Send Feedback
Arguments passed via GH_SliderBase.ValueChanged events.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_SliderEventArgs : EventArgs
Visual Basic
Public Class GH_SliderEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Grasshopper.GUI.Base..::..GH_SliderEventArgs

See Also

GH_SliderEventArgs Members
Grasshopper.GUI.Base Namespace


GH_SliderEventArgs Members

[image] [image]

Grasshopper SDK
GH_SliderEventArgs Members
GH_SliderEventArgs Class Properties See Also Send Feedback

The GH_SliderEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Intermediate | Gets a value indicating whether the change was an intermediate one.
Public property | Slider | Gets the instance of the slider that raised the event.
Public property | Value | Gets the new value of the slider. This value is cached, so even if the slider subsequently updates, this property remains constant.

See Also

GH_SliderEventArgs Class
Grasshopper.GUI.Base Namespace


GH_SliderEventArgs Properties

[image] [image]

Grasshopper SDK
GH_SliderEventArgs Properties
GH_SliderEventArgs Class See Also Send Feedback

The GH_SliderEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Intermediate | Gets a value indicating whether the change was an intermediate one.
Public property | Slider | Gets the instance of the slider that raised the event.
Public property | Value | Gets the new value of the slider. This value is cached, so even if the slider subsequently updates, this property remains constant.

See Also

GH_SliderEventArgs Class
Grasshopper.GUI.Base Namespace


Intermediate Property

[image]

Grasshopper SDK
GH_SliderEventArgs..::..Intermediate Property
GH_SliderEventArgs Class See Also Send Feedback
Gets a value indicating whether the change was an intermediate one.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Intermediate { get; }
Visual Basic
Public ReadOnly Property Intermediate As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderEventArgs.Intermediate"]

See Also

GH_SliderEventArgs Class
Grasshopper.GUI.Base Namespace


Slider Property

[image]

Grasshopper SDK
GH_SliderEventArgs..::..Slider Property
GH_SliderEventArgs Class See Also Send Feedback
Gets the instance of the slider that raised the event.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_SliderBase Slider { get; }
Visual Basic
Public ReadOnly Property Slider As GH_SliderBase
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderEventArgs.Slider"]

See Also

GH_SliderEventArgs Class
Grasshopper.GUI.Base Namespace


Value Property

[image]

Grasshopper SDK
GH_SliderEventArgs..::..Value Property
GH_SliderEventArgs Class See Also Send Feedback
Gets the new value of the slider. This value is cached, so even if the slider subsequently updates, this property remains constant.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public decimal Value { get; }
Visual Basic
Public ReadOnly Property Value As Decimal
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_SliderEventArgs.Value"]

See Also

GH_SliderEventArgs Class
Grasshopper.GUI.Base Namespace


GH_SliderGripDisplay Enumeration

[image]

Grasshopper SDK
GH_SliderGripDisplay Enumeration
See Also Send Feedback
Enumerates the possible slider grip displays.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_SliderGripDisplay
Visual Basic
Public Enumeration GH_SliderGripDisplay

Members

Member name | Value | Description
None | 0 | No grip is drawn.
Numeric | 1 | A single box containing the slider value is drawn.
Shape | 2 | A constant shape grip is drawn (round for floating point, diamond for integers)
ShapeAndText | 3 | Same as Shape, but text with the slider value is drawn besides the grip.

See Also

Grasshopper.GUI.Base Namespace


GH_SliderRailDisplay Enumeration

[image]

Grasshopper SDK
GH_SliderRailDisplay Enumeration
See Also Send Feedback
Enumerates the possible slider rail displays.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_SliderRailDisplay
Visual Basic
Public Enumeration GH_SliderRailDisplay

Members

Member name | Value | Description
None | 0 | No rail is drawn.
Simple | 1 | A rail consisting of a single line is drawn.
Etched | 2 | A rail consisting of an etched line is drawn.
Filled | 3 | A thick rail with a filled out left portion is drawn.

See Also

Grasshopper.GUI.Base Namespace


GH_SliderTickDisplay Enumeration

[image]

Grasshopper SDK
GH_SliderTickDisplay Enumeration
See Also Send Feedback
Enumerates the possible slider tick displays.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_SliderTickDisplay
Visual Basic
Public Enumeration GH_SliderTickDisplay

Members

Member name | Value | Description
None | 0 | No slider ticks are drawn.
Simple | 1 | Slider ticks are drawn as single lines.
Etched | 2 | Slider ticks are drawn as etched lines.

See Also

Grasshopper.GUI.Base Namespace


GH_TextBoxInputBase Class

[image]

Grasshopper SDK
GH_TextBoxInputBase Class
Members See Also Send Feedback

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract class GH_TextBoxInputBase : IGH_ToolstripItemKeyHandler
Visual Basic
Public MustInherit Class GH_TextBoxInputBase _
    Implements IGH_ToolstripItemKeyHandler

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI.Base..::..GH_TextBoxInputBase
Grasshopper.GUI.Base..::..GH_DigitScrollerBase
Grasshopper.GUI.Base..::..GH_SliderBase

See Also

GH_TextBoxInputBase Members
Grasshopper.GUI.Base Namespace


GH_TextBoxInputBase Members

[image] [image]

Grasshopper SDK
GH_TextBoxInputBase Members
GH_TextBoxInputBase Class Constructors Methods Properties See Also Send Feedback

The GH_TextBoxInputBase type exposes the following members.

Constructors

 | Name | Description
Protected method | GH_TextBoxInputBase | Initializes a new instance of the GH_TextBoxInputBase class

Methods

 | Name | Description
Protected method | HandleTextInputAccepted |
Public method | HideTextInputBox | Hides the text-input override form (if it is displayed).
Public method | RespondToEnter |
Public method | RespondToEscape |
Public method | ShowTextInputBox(Control, String, Boolean) | Display a floating text-box on top of the owner control.
Public method | ShowTextInputBox(Control, String, Boolean, Boolean) | Display a floating text-box on top of the owner control.
Public method | ShowTextInputBox(Control, String, Boolean, Boolean, Matrix) | Display a floating text-box on top of the owner control.

Properties

 | Name | Description
Public property | Bounds | Gets or sets the Bounds of this control.
Public property | Font | Gets or sets the Font to use in this control.
Public property | IsTextInput | Gets whether the text input box is currently on screen.

See Also

GH_TextBoxInputBase Class
Grasshopper.GUI.Base Namespace


GH_TextBoxInputBase Constructor

[image]

Grasshopper SDK
GH_TextBoxInputBase Constructor
GH_TextBoxInputBase Class See Also Send Feedback
Initializes a new instance of the GH_TextBoxInputBase class

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_TextBoxInputBase()
Visual Basic
Protected Sub New

See Also

GH_TextBoxInputBase Class
Grasshopper.GUI.Base Namespace


GH_TextBoxInputBase Methods

[image] [image]

Grasshopper SDK
GH_TextBoxInputBase Methods
GH_TextBoxInputBase Class See Also Send Feedback

The GH_TextBoxInputBase type exposes the following members.

Methods

 | Name | Description
Protected method | HandleTextInputAccepted |
Public method | HideTextInputBox | Hides the text-input override form (if it is displayed).
Public method | RespondToEnter |
Public method | RespondToEscape |
Public method | ShowTextInputBox(Control, String, Boolean) | Display a floating text-box on top of the owner control.
Public method | ShowTextInputBox(Control, String, Boolean, Boolean) | Display a floating text-box on top of the owner control.
Public method | ShowTextInputBox(Control, String, Boolean, Boolean, Matrix) | Display a floating text-box on top of the owner control.

See Also

GH_TextBoxInputBase Class
Grasshopper.GUI.Base Namespace


HandleTextInputAccepted Method

[image]

Grasshopper SDK
GH_TextBoxInputBase..::..HandleTextInputAccepted Method
GH_TextBoxInputBase Class See Also Send Feedback

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected abstract void HandleTextInputAccepted(
    string text
)
Visual Basic
Protected MustOverride Sub HandleTextInputAccepted ( _
    text As String _
)

Parameters

text
Type: System..::..String

See Also

GH_TextBoxInputBase Class
Grasshopper.GUI.Base Namespace


HideTextInputBox Method

[image]

Grasshopper SDK
GH_TextBoxInputBase..::..HideTextInputBox Method
GH_TextBoxInputBase Class See Also Send Feedback
Hides the text-input override form (if it is displayed).

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void HideTextInputBox()
Visual Basic
Public Sub HideTextInputBox

See Also

GH_TextBoxInputBase Class
Grasshopper.GUI.Base Namespace


RespondToEnter Method

[image]

Grasshopper SDK
GH_TextBoxInputBase..::..RespondToEnter Method
GH_TextBoxInputBase Class See Also Send Feedback

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ToolstripItemKeyHandlerResult RespondToEnter()
Visual Basic
Public Function RespondToEnter As GH_ToolstripItemKeyHandlerResult

See Also

GH_TextBoxInputBase Class
Grasshopper.GUI.Base Namespace


RespondToEscape Method

[image]

Grasshopper SDK
GH_TextBoxInputBase..::..RespondToEscape Method
GH_TextBoxInputBase Class See Also Send Feedback

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ToolstripItemKeyHandlerResult RespondToEscape()
Visual Basic
Public Function RespondToEscape As GH_ToolstripItemKeyHandlerResult

See Also

GH_TextBoxInputBase Class
Grasshopper.GUI.Base Namespace


ShowTextInputBox Method

[image] [image]

Grasshopper SDK
GH_TextBoxInputBase..::..ShowTextInputBox Method
GH_TextBoxInputBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ShowTextInputBox(Control, String, Boolean) | Display a floating text-box on top of the owner control.
Public method | ShowTextInputBox(Control, String, Boolean, Boolean) | Display a floating text-box on top of the owner control.
Public method | ShowTextInputBox(Control, String, Boolean, Boolean, Matrix) | Display a floating text-box on top of the owner control.

See Also

GH_TextBoxInputBase Class
GH_TextBoxInputBase Members
Grasshopper.GUI.Base Namespace


ShowTextInputBox Method (Control, String, Boolean)

[image]

Grasshopper SDK
GH_TextBoxInputBase..::..ShowTextInputBox Method (Control, String, Boolean)
GH_TextBoxInputBase Class See Also Send Feedback
Display a floating text-box on top of the owner control.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ShowTextInputBox(
    Control owner,
    string content,
    bool selectContent
)
Visual Basic
Public Sub ShowTextInputBox ( _
    owner As Control, _
    content As String, _
    selectContent As Boolean _
)

Parameters

owner
Type: System.Windows.Forms..::..Control
Control that owns this slider. The coordinates of the Bounds rectangle must be specified in owner coordinates.
content
Type: System..::..String
selectContent
Type: System..::..Boolean

See Also

GH_TextBoxInputBase Class
ShowTextInputBox Overload
Grasshopper.GUI.Base Namespace


ShowTextInputBox Method (Control, String, Boolean, Boolean)

[image]

Grasshopper SDK
GH_TextBoxInputBase..::..ShowTextInputBox Method (Control, String, Boolean, Boolean)
GH_TextBoxInputBase Class See Also Send Feedback
Display a floating text-box on top of the owner control.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ShowTextInputBox(
    Control owner,
    string content,
    bool selectContent,
    bool limitToBoundary
)
Visual Basic
Public Sub ShowTextInputBox ( _
    owner As Control, _
    content As String, _
    selectContent As Boolean, _
    limitToBoundary As Boolean _
)

Parameters

owner
Type: System.Windows.Forms..::..Control
Control that owns this slider. The coordinates of the Bounds rectangle must be specified in owner coordinates.
content
Type: System..::..String
selectContent
Type: System..::..Boolean
limitToBoundary
Type: System..::..Boolean
If True, the pop up input box will be 'clipped' to the owner boundary. At least some part of the slider must be visible for this to work.

See Also

GH_TextBoxInputBase Class
ShowTextInputBox Overload
Grasshopper.GUI.Base Namespace


ShowTextInputBox Method (Control, String, Boolean, Boolean, Matrix)

[image]

Grasshopper SDK
GH_TextBoxInputBase..::..ShowTextInputBox Method (Control, String, Boolean, Boolean, Matrix)
GH_TextBoxInputBase Class See Also Send Feedback
Display a floating text-box on top of the owner control.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ShowTextInputBox(
    Control owner,
    string content,
    bool selectContent,
    bool limitToBoundary,
    Matrix transform
)
Visual Basic
Public Sub ShowTextInputBox ( _
    owner As Control, _
    content As String, _
    selectContent As Boolean, _
    limitToBoundary As Boolean, _
    transform As Matrix _
)

Parameters

owner
Type: System.Windows.Forms..::..Control
Control that owns this slider. The coordinates of the Bounds rectangle must be specified in owner coordinates.
content
Type: System..::..String
selectContent
Type: System..::..Boolean
limitToBoundary
Type: System..::..Boolean
If True, the pop up input box will be 'clipped' to the owner boundary. At least some part of the slider must be visible for this to work.
transform
Type: System.Drawing.Drawing2D..::..Matrix
Transformation matrix to apply to pop up UI.

See Also

GH_TextBoxInputBase Class
ShowTextInputBox Overload
Grasshopper.GUI.Base Namespace


GH_TextBoxInputBase Properties

[image] [image]

Grasshopper SDK
GH_TextBoxInputBase Properties
GH_TextBoxInputBase Class See Also Send Feedback

The GH_TextBoxInputBase type exposes the following members.

Properties

 | Name | Description
Public property | Bounds | Gets or sets the Bounds of this control.
Public property | Font | Gets or sets the Font to use in this control.
Public property | IsTextInput | Gets whether the text input box is currently on screen.

See Also

GH_TextBoxInputBase Class
Grasshopper.GUI.Base Namespace


Bounds Property

[image]

Grasshopper SDK
GH_TextBoxInputBase..::..Bounds Property
GH_TextBoxInputBase Class See Also Send Feedback
Gets or sets the Bounds of this control.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual Rectangle Bounds { get; set; }
Visual Basic
Public Overridable Property Bounds As Rectangle
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_TextBoxInputBase.Bounds"]

See Also

GH_TextBoxInputBase Class
Grasshopper.GUI.Base Namespace


Font Property

[image]

Grasshopper SDK
GH_TextBoxInputBase..::..Font Property
GH_TextBoxInputBase Class See Also Send Feedback
Gets or sets the Font to use in this control.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual Font Font { get; set; }
Visual Basic
Public Overridable Property Font As Font
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_TextBoxInputBase.Font"]

See Also

GH_TextBoxInputBase Class
Grasshopper.GUI.Base Namespace


IsTextInput Property

[image]

Grasshopper SDK
GH_TextBoxInputBase..::..IsTextInput Property
GH_TextBoxInputBase Class See Also Send Feedback
Gets whether the text input box is currently on screen.

Namespace: Grasshopper.GUI.Base
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsTextInput { get; }
Visual Basic
Public ReadOnly Property IsTextInput As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Base.GH_TextBoxInputBase.IsTextInput"]

See Also

GH_TextBoxInputBase Class
Grasshopper.GUI.Base Namespace


Grasshopper.GUI.Canvas Namespace

[image]

Grasshopper SDK
Grasshopper.GUI.Canvas Namespace
Send Feedback
This namespace contains all classes needed for the Grasshopper canvas display.

Classes

 | Class | Description
Public class | GH_Border | Represents a resizing border of a Grasshopper canvas object.
Public class | GH_Canvas | The GH_Canvas is the control that handles all mouse and paint events for a single loaded document.
Public class | GH_Canvas..::..GH_ImageSettings | Settings class for high-resolution image output.
Public class | GH_CanvasDocumentChangedEventArgs | These arguments are used in the DocumentChanged event on GH_Canvas.
Public class | GH_CanvasViewportChangedEventArgs | These arguments are used in the ViewportChanged event on GH_Canvas.
Public class | GH_CanvasWidgetListEventArgs | The event arguments are used in the WidgetListCreated event.
Public class | GH_Capsule | Class used to draw standard Grasshopper interface boxes.
Public class | GH_CapsuleRenderEngine | Provides basic Render methods for capsule display. You typically don't need this class, just use the Render() overloads on GH_Capsule directly.
Public class | GH_DocDiagramPainter | This class paints diagrammatic images of a collection of objects.
Public class | GH_NamedView | Named views are used both to store named views but also to allow smooth programmatic canvas navigation.
Public class | GH_Painter | This class performs most of the drawing operations required for Grasshopper Canvas controls.
Public class | GH_PaletteStyle | Contains all the colours for a single capsule palette.
Public class | GH_ResizeBorder |
Public class | GH_Skin | Provides static access to typical Palletes and other GUI colours.
Public class | GH_Viewport | Provides functionality for panning and zooming in a GH_Canvas environment.

Interfaces

 | Interface | Description
Public interface | IGH_ResponsiveObject | If you wish to participate in Canvas UI events, you must implement this interface.
Public interface | IGH_TooltipAwareObject | Implement this interface if you want your object to participate in Grasshopper Canvas tooltips.

Delegates

 | Delegate | Description
Public delegate | GH_Canvas..::..CanvasPaintBackgroundEventHandler |
Public delegate | GH_Canvas..::..CanvasPaintBeginEventHandler |
Public delegate | GH_Canvas..::..CanvasPaintEndEventHandler |
Public delegate | GH_Canvas..::..CanvasPostPaintGroupsEventHandler |
Public delegate | GH_Canvas..::..CanvasPostPaintObjectsEventHandler |
Public delegate | GH_Canvas..::..CanvasPostPaintOverlayEventHandler |
Public delegate | GH_Canvas..::..CanvasPostPaintWidgetsEventHandler |
Public delegate | GH_Canvas..::..CanvasPostPaintWiresEventHandler |
Public delegate | GH_Canvas..::..CanvasPrePaintGroupsEventHandler |
Public delegate | GH_Canvas..::..CanvasPrePaintObjectsEventHandler |
Public delegate | GH_Canvas..::..CanvasPrePaintOverlayEventHandler |
Public delegate | GH_Canvas..::..CanvasPrePaintWidgetsEventHandler |
Public delegate | GH_Canvas..::..CanvasPrePaintWiresEventHandler |
Public delegate | GH_Canvas..::..Document_ModifiedChangedEventHandler |
Public delegate | GH_Canvas..::..Document_ObjectsAddedEventHandler |
Public delegate | GH_Canvas..::..Document_ObjectsDeletedEventHandler |
Public delegate | GH_Canvas..::..Document_SettingsChangedEventHandler |
Public delegate | GH_Canvas..::..DocumentChangedEventHandler |
Public delegate | GH_Canvas..::..DocumentObjectMouseDownEventHandler |
Public delegate | GH_Canvas..::..DocumentObjectsDeletedEventHandler |
Public delegate | GH_Canvas..::..ModifiersChangedEventHandler |
Public delegate | GH_Canvas..::..NavigationSettingsChangedEventHandler |
Public delegate | GH_Canvas..::..ViewportChangedEventHandler |
Public delegate | GH_Canvas..::..WidgetListCreatedEventHandler |
Public delegate | GH_NamedView..::..SmoothFrameEventHandler |

Enumerations

 | Enumeration | Description
Public enumeration | GH_BorderTopology | Enumerates all possble border types.
Public enumeration | GH_CanvasChannel | Enumerates all the drawing channels that are handled inside the Grasshopper canvas.
Public enumeration | GH_CanvasMode | Enumerates all pre-defined Canvas modes.
Public enumeration | GH_CanvasNavigation | Enumerates all possible canvas navigations.
Public enumeration | GH_DragDropFileAction | Enumerates the possible actions for drag+drop loading ghx files.
Public enumeration | GH_NamedViewType | Types of named view anchor points.
Public enumeration | GH_ObjectResponse | Lists the possible responses an object can give when confronted with a UI event.
Public enumeration | GH_Orientation | Enumerates possible alignments.
Public enumeration | GH_Palette | Lists all possible Capsule Palette styles in Grasshopper.
Public enumeration | GH_Viewport..::..GH_DisplayMatrix | Enumerates the possible Display Transformation matrices.
Public enumeration | GH_WireDirection | Identifies a wire direction.
Public enumeration | GH_WireType | Enumerates the different kinds of connecting wires.


GH_Border Class

[image]

Grasshopper SDK
GH_Border Class
Members See Also Send Feedback
Represents a resizing border of a Grasshopper canvas object.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Border
Visual Basic
Public Class GH_Border

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI.Canvas..::..GH_Border
Grasshopper.GUI.Canvas..::..GH_ResizeBorder

See Also

GH_Border Members
Grasshopper.GUI.Canvas Namespace


GH_Border Members

[image] [image]

Grasshopper SDK
GH_Border Members
GH_Border Class Constructors Methods Properties See Also Send Feedback

The GH_Border type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Border | Create a new border.

Methods

 | Name | Description
Public method | Contains | Test a point for border inclusion.
 | CreateBorders(RectangleF, Int32) | Static (Shared) method for creating a set of borders.
 | CreateBorders(RectangleF, Padding) | Static (Shared) method for creating a set of borders.
 | CreateBorders(RectangleF, Int32, Int32) | Static (Shared) method for creating a set of borders.
 | CreateBorders(RectangleF, Int32, Int32, Int32, Int32) | Static (Shared) method for creating a set of borders.

Properties

 | Name | Description
Public property | Region | Gets the shape of the border.
Public property | Size_Cursor | Gets the cursor associated with this border.
Public property | Topology | Gets the type of border.

See Also

GH_Border Class
Grasshopper.GUI.Canvas Namespace


GH_Border Constructor

[image]

Grasshopper SDK
GH_Border Constructor
GH_Border Class See Also Send Feedback
Create a new border.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Border(
    RectangleF rectangle,
    GH_BorderTopology topology
)
Visual Basic
Public Sub New ( _
    rectangle As RectangleF, _
    topology As GH_BorderTopology _
)

Parameters

rectangle
Type: System.Drawing..::..RectangleF
Shape of border.
topology
Type: Grasshopper.GUI.Canvas..::..GH_BorderTopology
Border topology.

See Also

GH_Border Class
Grasshopper.GUI.Canvas Namespace


GH_Border Methods

[image] [image]

Grasshopper SDK
GH_Border Methods
GH_Border Class See Also Send Feedback

The GH_Border type exposes the following members.

Methods

 | Name | Description
Public method | Contains | Test a point for border inclusion.
 | CreateBorders(RectangleF, Int32) | Static (Shared) method for creating a set of borders.
 | CreateBorders(RectangleF, Padding) | Static (Shared) method for creating a set of borders.
 | CreateBorders(RectangleF, Int32, Int32) | Static (Shared) method for creating a set of borders.
 | CreateBorders(RectangleF, Int32, Int32, Int32, Int32) | Static (Shared) method for creating a set of borders.

See Also

GH_Border Class
Grasshopper.GUI.Canvas Namespace


Contains Method

[image]

Grasshopper SDK
GH_Border..::..Contains Method
GH_Border Class See Also Send Feedback
Test a point for border inclusion.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Contains(
    PointF pt
)
Visual Basic
Public Function Contains ( _
    pt As PointF _
) As Boolean

Parameters

pt
Type: System.Drawing..::..PointF
Point to test.

Return Value

True if pt is inside or on this border.

See Also

GH_Border Class
Grasshopper.GUI.Canvas Namespace


CreateBorders Method

[image] [image]

Grasshopper SDK
GH_Border..::..CreateBorders Method
GH_Border Class See Also Send Feedback

Overload List

Name | Description
CreateBorders(RectangleF, Int32) | Static (Shared) method for creating a set of borders.
CreateBorders(RectangleF, Padding) | Static (Shared) method for creating a set of borders.
CreateBorders(RectangleF, Int32, Int32) | Static (Shared) method for creating a set of borders.
CreateBorders(RectangleF, Int32, Int32, Int32, Int32) | Static (Shared) method for creating a set of borders.

See Also

GH_Border Class
GH_Border Members
Grasshopper.GUI.Canvas Namespace


CreateBorders Method (RectangleF, Int32)

[image]

Grasshopper SDK
GH_Border..::..CreateBorders Method (RectangleF, Int32)
GH_Border Class See Also Send Feedback
Static (Shared) method for creating a set of borders.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static List<GH_Border> CreateBorders(
    RectangleF box,
    int borderSize
)
Visual Basic
Public Shared Function CreateBorders ( _
    box As RectangleF, _
    borderSize As Integer _
) As List(Of GH_Border)

Parameters

box
Type: System.Drawing..::..RectangleF
Box for border creation.
borderSize
Type: System..::..Int32
The width of all borders.

Return Value

A list of borders.

See Also

GH_Border Class
CreateBorders Overload
Grasshopper.GUI.Canvas Namespace


CreateBorders Method (RectangleF, Padding)

[image]

Grasshopper SDK
GH_Border..::..CreateBorders Method (RectangleF, Padding)
GH_Border Class See Also Send Feedback
Static (Shared) method for creating a set of borders.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static List<GH_Border> CreateBorders(
    RectangleF box,
    Padding padding
)
Visual Basic
Public Shared Function CreateBorders ( _
    box As RectangleF, _
    padding As Padding _
) As List(Of GH_Border)

Parameters

box
Type: System.Drawing..::..RectangleF
Box for border creation.
padding
Type: System.Windows.Forms..::..Padding
The size of the borders along all four edges.

Return Value

A list of borders.

See Also

GH_Border Class
CreateBorders Overload
Grasshopper.GUI.Canvas Namespace


CreateBorders Method (RectangleF, Int32, Int32)

[image]

Grasshopper SDK
GH_Border..::..CreateBorders Method (RectangleF, Int32, Int32)
GH_Border Class See Also Send Feedback
Static (Shared) method for creating a set of borders.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static List<GH_Border> CreateBorders(
    RectangleF box,
    int borderWidth,
    int borderHeight
)
Visual Basic
Public Shared Function CreateBorders ( _
    box As RectangleF, _
    borderWidth As Integer, _
    borderHeight As Integer _
) As List(Of GH_Border)

Parameters

box
Type: System.Drawing..::..RectangleF
Box for border creation.
borderWidth
Type: System..::..Int32
The width of all vertical.
borderHeight
Type: System..::..Int32
The height of all horizontal borders.

Return Value

A list of borders.

See Also

GH_Border Class
CreateBorders Overload
Grasshopper.GUI.Canvas Namespace


CreateBorders Method (RectangleF, Int32, Int32, Int32, Int32)

[image]

Grasshopper SDK
GH_Border..::..CreateBorders Method (RectangleF, Int32, Int32, Int32, Int32)
GH_Border Class See Also Send Feedback
Static (Shared) method for creating a set of borders.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static List<GH_Border> CreateBorders(
    RectangleF box,
    int borderLeft,
    int borderRight,
    int borderTop,
    int borderBottom
)
Visual Basic
Public Shared Function CreateBorders ( _
    box As RectangleF, _
    borderLeft As Integer, _
    borderRight As Integer, _
    borderTop As Integer, _
    borderBottom As Integer _
) As List(Of GH_Border)

Parameters

box
Type: System.Drawing..::..RectangleF
Box for border creation.
borderLeft
Type: System..::..Int32
Width of the leftmost border.
borderRight
Type: System..::..Int32
Width of the rightmost border.
borderTop
Type: System..::..Int32
Width of the topmost border.
borderBottom
Type: System..::..Int32
Width of the bottommost border.

Return Value

A list of borders.

See Also

GH_Border Class
CreateBorders Overload
Grasshopper.GUI.Canvas Namespace


GH_Border Properties

[image] [image]

Grasshopper SDK
GH_Border Properties
GH_Border Class See Also Send Feedback

The GH_Border type exposes the following members.

Properties

 | Name | Description
Public property | Region | Gets the shape of the border.
Public property | Size_Cursor | Gets the cursor associated with this border.
Public property | Topology | Gets the type of border.

See Also

GH_Border Class
Grasshopper.GUI.Canvas Namespace


Region Property

[image]

Grasshopper SDK
GH_Border..::..Region Property
GH_Border Class See Also Send Feedback
Gets the shape of the border.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public RectangleF Region { get; }
Visual Basic
Public ReadOnly Property Region As RectangleF
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Border.Region"]

See Also

GH_Border Class
Grasshopper.GUI.Canvas Namespace


Size_Cursor Property

[image]

Grasshopper SDK
GH_Border..::..Size_Cursor Property
GH_Border Class See Also Send Feedback
Gets the cursor associated with this border.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Cursor Size_Cursor { get; }
Visual Basic
Public ReadOnly Property Size_Cursor As Cursor
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Border.Size_Cursor"]

See Also

GH_Border Class
Grasshopper.GUI.Canvas Namespace


Topology Property

[image]

Grasshopper SDK
GH_Border..::..Topology Property
GH_Border Class See Also Send Feedback
Gets the type of border.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_BorderTopology Topology { get; }
Visual Basic
Public ReadOnly Property Topology As GH_BorderTopology
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Border.Topology"]

See Also

GH_Border Class
Grasshopper.GUI.Canvas Namespace


GH_BorderTopology Enumeration

[image]

Grasshopper SDK
GH_BorderTopology Enumeration
See Also Send Feedback
Enumerates all possble border types.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_BorderTopology
Visual Basic
Public Enumeration GH_BorderTopology

Members

Member name | Value | Description
None | -2 | Unset value.
All | -1 | All possible types.
TopRight | 0 | Corner border in the top right area of the box.
TopLeft | 1 | Corner border in the top left area of the box.
BottomLeft | 2 | Corner border in the bottom left area of the box.
BottomRight | 3 | Corner border in the bottom right area of the box.
Top | 4 | Edge border along the top area of the box.
Left | 5 | Edge border along the left area of the box.
Bottom | 6 | Edge border along the bottom area of the box.
Right | 7 | Edge border along the right area of the box.

See Also

Grasshopper.GUI.Canvas Namespace


GH_Canvas Class

[image]

Grasshopper SDK
GH_Canvas Class
Members See Also Send Feedback
The GH_Canvas is the control that handles all mouse and paint events for a single loaded document.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Canvas : Control
Visual Basic
Public Class GH_Canvas _
    Inherits Control

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
Grasshopper.GUI.Canvas..::..GH_Canvas

See Also

GH_Canvas Members
Grasshopper.GUI.Canvas Namespace


GH_Canvas Members

[image] [image]

Grasshopper SDK
GH_Canvas Members
GH_Canvas Class Constructors Methods Fields Properties Events See Also Send Feedback

The GH_Canvas type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Canvas | Initializes a new instance of the GH_Canvas class

Methods

 | Name | Description
Public method | AddTagArtist | Add a Tag Artist instance to this canvas.
Public method | AutoSaveDocument |
Public method | CanvasOldSchoolMenu |
Public method | CenterPoint |
Public method | CreateMRUPanels | Create new MRU panels. This function only does something if there is no document loaded in the canvas.
Public method | CreatePreview | Render this canvas to a thumbnail preview.
Public method | DestroyMRUPanels | Destroy any MRU panels that might be in existence.
Protected method | Dispose | Releases the unmanaged resources used by the GH_Canvas and optionally releases the managed resources (Overrides Control..::..Dispose(Boolean).)
Public method | GenerateHiResImage | Generate a collection of hi-res images of the document.
Public method | GenerateHiResImageTile | Generate a single tile in a Hi-Res image export.
Public method | GetCanvasScreenBuffer | Get a bitmap that resembles the current state of the canvas.
Public method | GetGraphicsObject | Gets a graphics object for this control. You are not allowed to draw with this object, use it only for visibility testing and such. If you're inside a canvas update, use the Graphics() property instead. You must dispose of the Graphics object returned by this method or resources will be leaked.
Public method | HideMRUPanels | Hide all existing MRU panels by sliding them out of view.
Public method | InstantiateNewObject(Guid, PointF, Boolean) |
Public method | InstantiateNewObject(Guid, String, PointF, Boolean) |
Public method | InstantiateNewObject(IGH_DocumentObject, String, PointF, Boolean) |
Public method | Navigate | Perform a single navigation step.
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | (Overrides Control..::..OnPaintBackground(PaintEventArgs).)
Public method | OnViewportChanged | Ensure the canvas and document viewport data are synchronised and raises the ViewportChanged event.
Public method | ReevaluateMarkovSuggestions |
Public method | Regen | Obsolete.
Public method | RemoveAllTagArtists | Remove all IGH_TagArtists from this canvas. Do not use this method unless you want to screw over everyone else.
Public method | RemoveTagArtist(Guid) | Remove all IGH_TagArtists from this canvas that match a certain ID.
Public method | RemoveTagArtist(IGH_TagArtist) | Remove a specific tag artist from this canvas. If the instance occurs multiple times in the TagArtist list, all instances will be removed.
Public method | ScheduleRegen | Schedule a regen to occur after the specified number of milliseconds have elapsed. If a Regen is called in this time frame, the schedule will be cleared. Only a single schedule can be active at any time, so any call to ScheduleRegen will clear existing schedules.
Public method | SetSmartTextRenderingHint | When this method is called during a redraw, the TextRenderingHint of the associated graphics object will be set to either GH_CrispText or GH_SmoothText depending on zoom level.
Public method | ShowComponentSearchBox()()()() | Display the component Search dialog at the current mouse location. The dialog cannot be shown if ModifiersEnabled=False.
Public method | ShowComponentSearchBox(Point) | Display the component Search dialog at the given coordinate. The dialog cannot be shown if ModifiersEnabled=False.
Public method | ShowMRUPanels | Show any hidden MRU panels by sliding them back into view.
Public method | ShowNavigationPane | Displays the quick-navigation popup pane at the cursor.
Public method | ShowSearchDialog | Display the Find dialog. If a Find dialog is already active for this canvas, nothing will happen.
Public method | StartAutoPan | Start the auto-panning timer.
Public method | StopAutoPan | Stop the auto-panning timer.
Public method | UpdateDocumentPreview | Call this method to update the preview thumbnail for the currently loaded document. If no document is currently loaded, nothing will happen.

Fields

Name | Description
ScheduleInactive | Defines the delay used to indicate the absence of a schedule.
ThumbnailHeight |
ThumbnailWidth |

Properties

 | Name | Description
Public property | ActiveInteraction | Gets or sets the currently active interaction object.
Public property | ActiveObject | Gets or sets the currently active object.
Public property | ActiveWidget | Gets or sets the currently active widget.
Public property | CursorCanvasPosition | Gets the location of the cursor in Canvas coordinates.
Public property | CursorControlPosition | Gets the location of the cursor in Control coordinates.
 | DisplayVoronoiWarning | Gets or sets whether the Voronoi Over-dose warning message is displayed. This property is set once at Grasshopper startup to True.
Public property | Document | Gets or sets the document currently loaded in this canvas.
Public property | DrawingMode | Gets the current drawing mode for this canvas.
Public property | Graphics | Gets the graphics object with which this Canvas is redrawn. This object only exists during redraws, if you need the Graphics object for this canvas outside of updates, call GetGraphicsObject() instead.
Public property | IsActiveInteraction | Gets a value indicating whether or not there is an interaction object loaded in this canvas.
Public property | IsActiveObject | Gets a value indicating whether or not an object is currently activated.
Public property | IsActiveWidget | Gets a value indicating whether or not a widget is currently activated.
Public property | IsDocument | Gets a value indicating whether or not a document is currently loaded in this canvas.
Public property | MarkovSuggestions |
Public property | ModifiersEnabled | Gets or sets the modifiers enabled flag. When modifiers are disabled, only zooming and panning is still allowed.
 | NavigationPanDown | Gets or sets the special key for panning down.
 | NavigationPanLeft | Gets or sets the special key for panning left.
 | NavigationPanPixels | Gets or sets the number of pixels for each pan operation.
 | NavigationPanRight | Gets or sets the special key for panning right.
 | NavigationPanUp | Gets or sets the special key for panning up.
 | NavigationZoomFactor | Gets or sets the zoom factor for navigation zoom operations.
 | NavigationZoomIn | Gets or sets the special key for zooming in.
 | NavigationZoomOut | Gets or sets the special key for zooming in.
Public property | Painter | Gets the painter object that handles most of the drawing logic for this canvas.
Public property | Painting | Gets whether this canvas is currently busy painting itself.
Public property | TagArtistIDs | Gets all the TagArtist IDs in this Canvas.
 | ThumbnailSize | Gets the thumbnail size for documents.
Public property | TooltipDelay | Gets the delay (in milliseconds) required for a tooltip popup. This delay is a user setting stored under the Canvas:TooltipDelay field of the core settings.
Public property | ValidGraphics | Gets or sets the Valid Graphics flag. Even if the flag is set to true, though, the property may still return false if there is a problem with the internal graphics object.
Public property | Viewport | Gets the viewport that determines the panning and zooming for this canvas.
Public property | Widgets | Gets a list of all the widgets on this canvas.
 | ZoomFadeHigh | Gets the ZUI fade alpha value for the high zoom level threshold. This static field gets set on every Canvas paint start. The high threshold is typically used for ZUI elements that only appear when zoomed in.
 | ZoomFadeLow | Gets the ZUI fade alpha value for the low zoom level threshold. This static field gets set on every Canvas paint start. The low threshold is typically used for fading of icons and object names.
 | ZoomFadeMedium | Gets the ZUI fade alpha value for the medium zoom level threshold. This static field gets set on every Canvas paint start. The medium threshold is typically used for non-informative UI elements such as highlights.

Events

 | Name | Description
Public event | CanvasPaintBackground | Raised after the background has been drawn.
Public event | CanvasPaintBegin | Raised before a new paint operation starts. This event is always raised, even if the Canvas isn't visible.
Public event | CanvasPaintEnd | Raised after a paint operation completes. This event is always raised, even if the Canvas isn't visible.
Public event | CanvasPostPaintGroups | Raised after group drawing completes.
Public event | CanvasPostPaintObjects | Raised after object drawing completes.
Public event | CanvasPostPaintOverlay | Raised after object overlay drawing completes.
Public event | CanvasPostPaintWidgets | Raised after widgets are drawn. This is the final event in the Drawing pipeline.
Public event | CanvasPostPaintWires | Raised after wire drawing completes.
Public event | CanvasPrePaintGroups | Raised before group drawing starts.
Public event | CanvasPrePaintObjects | Raised before object drawing starts.
Public event | CanvasPrePaintOverlay | Raised before object overlay drawing starts.
Public event | CanvasPrePaintWidgets | Raised before Widgets are drawn.
Public event | CanvasPrePaintWires | Raised before wire drawing starts.
Public event | Document_ModifiedChanged |
Public event | Document_ObjectsAdded |
Public event | Document_ObjectsDeleted |
Public event | Document_SettingsChanged |
Public event | DocumentChanged | This event is raised whenever a different document is loaded into this canvas.
Public event | DocumentObjectMouseDown | This event is raised whenever the left mouse button is pressed while over a Document object.
Public event | DocumentObjectsDeleted | Obsolete.
Public event | ModifiersChanged | This event is raised whenever the ModifiersEnabled property changes.
 | NavigationSettingsChanged | Raised whenever any of the shared navigation properties changed.
Public event | ViewportChanged | This event is raised whenever the viewport properties are modified, for example when the pan or zoom values are affected.
 | WidgetListCreated | This event is raised once for every GH_Canvas object that is created anew. The event is Shared (static) because it is raised inside the constructor of a GH_Canvas object and therefor cannot be registered on an instance.

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


GH_Canvas Constructor

[image]

Grasshopper SDK
GH_Canvas Constructor
GH_Canvas Class See Also Send Feedback
Initializes a new instance of the GH_Canvas class

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Canvas()
Visual Basic
Public Sub New

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


GH_Canvas Fields

[image] [image]

Grasshopper SDK
GH_Canvas Fields
GH_Canvas Class See Also Send Feedback

The GH_Canvas type exposes the following members.

Fields

Name | Description
ScheduleInactive | Defines the delay used to indicate the absence of a schedule.
ThumbnailHeight |
ThumbnailWidth |

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


ScheduleInactive Field

[image]

Grasshopper SDK
GH_Canvas..::..ScheduleInactive Field
GH_Canvas Class See Also Send Feedback
Defines the delay used to indicate the absence of a schedule.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const int ScheduleInactive
Visual Basic
Public Const ScheduleInactive As Integer

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


ThumbnailHeight Field

[image]

Grasshopper SDK
GH_Canvas..::..ThumbnailHeight Field
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const int ThumbnailHeight
Visual Basic
Public Const ThumbnailHeight As Integer

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


ThumbnailWidth Field

[image]

Grasshopper SDK
GH_Canvas..::..ThumbnailWidth Field
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const int ThumbnailWidth
Visual Basic
Public Const ThumbnailWidth As Integer

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


GH_Canvas Methods

[image] [image]

Grasshopper SDK
GH_Canvas Methods
GH_Canvas Class See Also Send Feedback

The GH_Canvas type exposes the following members.

Methods

 | Name | Description
Public method | AddTagArtist | Add a Tag Artist instance to this canvas.
Public method | AutoSaveDocument |
Public method | CanvasOldSchoolMenu |
Public method | CenterPoint |
Public method | CreateMRUPanels | Create new MRU panels. This function only does something if there is no document loaded in the canvas.
Public method | CreatePreview | Render this canvas to a thumbnail preview.
Public method | DestroyMRUPanels | Destroy any MRU panels that might be in existence.
Protected method | Dispose | (Overrides Control..::..Dispose(Boolean).)
Public method | GenerateHiResImage | Generate a collection of hi-res images of the document.
Public method | GenerateHiResImageTile | Generate a single tile in a Hi-Res image export.
Public method | GetCanvasScreenBuffer | Get a bitmap that resembles the current state of the canvas.
Public method | GetGraphicsObject | Gets a graphics object for this control. You are not allowed to draw with this object, use it only for visibility testing and such. If you're inside a canvas update, use the Graphics() property instead. You must dispose of the Graphics object returned by this method or resources will be leaked.
Public method | HideMRUPanels | Hide all existing MRU panels by sliding them out of view.
Public method | InstantiateNewObject(Guid, PointF, Boolean) |
Public method | InstantiateNewObject(Guid, String, PointF, Boolean) |
Public method | InstantiateNewObject(IGH_DocumentObject, String, PointF, Boolean) |
Public method | Navigate | Perform a single navigation step.
Protected method | OnPaint | (Overrides Control..::..OnPaint(PaintEventArgs).)
Protected method | OnPaintBackground | (Overrides Control..::..OnPaintBackground(PaintEventArgs).)
Public method | OnViewportChanged | Ensure the canvas and document viewport data are synchronised and raises the ViewportChanged event.
Public method | ReevaluateMarkovSuggestions |
Public method | Regen | Obsolete.
Public method | RemoveAllTagArtists | Remove all IGH_TagArtists from this canvas. Do not use this method unless you want to screw over everyone else.
Public method | RemoveTagArtist(Guid) | Remove all IGH_TagArtists from this canvas that match a certain ID.
Public method | RemoveTagArtist(IGH_TagArtist) | Remove a specific tag artist from this canvas. If the instance occurs multiple times in the TagArtist list, all instances will be removed.
Public method | ScheduleRegen | Schedule a regen to occur after the specified number of milliseconds have elapsed. If a Regen is called in this time frame, the schedule will be cleared. Only a single schedule can be active at any time, so any call to ScheduleRegen will clear existing schedules.
Public method | SetSmartTextRenderingHint | When this method is called during a redraw, the TextRenderingHint of the associated graphics object will be set to either GH_CrispText or GH_SmoothText depending on zoom level.
Public method | ShowComponentSearchBox()()()() | Display the component Search dialog at the current mouse location. The dialog cannot be shown if ModifiersEnabled=False.
Public method | ShowComponentSearchBox(Point) | Display the component Search dialog at the given coordinate. The dialog cannot be shown if ModifiersEnabled=False.
Public method | ShowMRUPanels | Show any hidden MRU panels by sliding them back into view.
Public method | ShowNavigationPane | Displays the quick-navigation popup pane at the cursor.
Public method | ShowSearchDialog | Display the Find dialog. If a Find dialog is already active for this canvas, nothing will happen.
Public method | StartAutoPan | Start the auto-panning timer.
Public method | StopAutoPan | Stop the auto-panning timer.
Public method | UpdateDocumentPreview | Call this method to update the preview thumbnail for the currently loaded document. If no document is currently loaded, nothing will happen.

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


AddTagArtist Method

[image]

Grasshopper SDK
GH_Canvas..::..AddTagArtist Method
GH_Canvas Class See Also Send Feedback
Add a Tag Artist instance to this canvas.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddTagArtist(
    IGH_TagArtist artist
)
Visual Basic
Public Sub AddTagArtist ( _
    artist As IGH_TagArtist _
)

Parameters

artist
Type: Grasshopper.GUI.Canvas.TagArtists..::..IGH_TagArtist
Tag artist to add

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


AutoSaveDocument Method

[image]

Grasshopper SDK
GH_Canvas..::..AutoSaveDocument Method
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AutoSaveDocument(
    GH_AutoSaveTrigger trigger
)
Visual Basic
Public Sub AutoSaveDocument ( _
    trigger As GH_AutoSaveTrigger _
)

Parameters

trigger
Type: Grasshopper.Kernel..::..GH_AutoSaveTrigger

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


CanvasOldSchoolMenu Method

[image]

Grasshopper SDK
GH_Canvas..::..CanvasOldSchoolMenu Method
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public ToolStripDropDownMenu CanvasOldSchoolMenu()
Visual Basic
Public Function CanvasOldSchoolMenu As ToolStripDropDownMenu

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


CenterPoint Method

[image]

Grasshopper SDK
GH_Canvas..::..CenterPoint Method
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void CenterPoint(
    PointF pt,
    bool smooth
)
Visual Basic
Public Sub CenterPoint ( _
    pt As PointF, _
    smooth As Boolean _
)

Parameters

pt
Type: System.Drawing..::..PointF
smooth
Type: System..::..Boolean

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


CreateMRUPanels Method

[image]

Grasshopper SDK
GH_Canvas..::..CreateMRUPanels Method
GH_Canvas Class See Also Send Feedback
Create new MRU panels. This function only does something if there is no document loaded in the canvas.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void CreateMRUPanels()
Visual Basic
Public Sub CreateMRUPanels

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


CreatePreview Method

[image]

Grasshopper SDK
GH_Canvas..::..CreatePreview Method
GH_Canvas Class See Also Send Feedback
Render this canvas to a thumbnail preview.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Bitmap CreatePreview(
    Size size
)
Visual Basic
Public Function CreatePreview ( _
    size As Size _
) As Bitmap

Parameters

size
Type: System.Drawing..::..Size

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


DestroyMRUPanels Method

[image]

Grasshopper SDK
GH_Canvas..::..DestroyMRUPanels Method
GH_Canvas Class See Also Send Feedback
Destroy any MRU panels that might be in existence.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DestroyMRUPanels()
Visual Basic
Public Sub DestroyMRUPanels

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


Dispose Method

[image]

Grasshopper SDK
GH_Canvas..::..Dispose Method
GH_Canvas Class See Also Send Feedback
Releases the unmanaged resources used by the GH_Canvas and optionally releases the managed resources

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


GenerateHiResImage Method

[image]

Grasshopper SDK
GH_Canvas..::..GenerateHiResImage Method
GH_Canvas Class See Also Send Feedback
Generate a collection of hi-res images of the document.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<string> GenerateHiResImage(
    Rectangle rec,
    GH_Canvas..::..GH_ImageSettings settings,
    out Size totalSize
)
Visual Basic
Public Function GenerateHiResImage ( _
    rec As Rectangle, _
    settings As GH_Canvas..::..GH_ImageSettings, _
    <OutAttribute> ByRef totalSize As Size _
) As List(Of String)

Parameters

rec
Type: System.Drawing..::..Rectangle
BoundingBox rectangle of export.
settings
Type: Grasshopper.GUI.Canvas..::..GH_Canvas..::..GH_ImageSettings
Hi-res settings.
totalSize
Type: System.Drawing..::..Size %

Return Value

List of file paths that indicate the individual images.

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


GenerateHiResImageTile Method

[image]

Grasshopper SDK
GH_Canvas..::..GenerateHiResImageTile Method
GH_Canvas Class See Also Send Feedback
Generate a single tile in a Hi-Res image export.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Bitmap GenerateHiResImageTile(
    GH_Viewport vp,
    Color bg
)
Visual Basic
Public Function GenerateHiResImageTile ( _
    vp As GH_Viewport, _
    bg As Color _
) As Bitmap

Parameters

vp
Type: Grasshopper.GUI.Canvas..::..GH_Viewport
Viewport override
bg
Type: System.Drawing..::..Color
Background color override.

Return Value

A list of image tiles.

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


GetCanvasScreenBuffer Method

[image]

Grasshopper SDK
GH_Canvas..::..GetCanvasScreenBuffer Method
GH_Canvas Class See Also Send Feedback
Get a bitmap that resembles the current state of the canvas.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Bitmap GetCanvasScreenBuffer(
    GH_CanvasMode modeOverride
)
Visual Basic
Public Function GetCanvasScreenBuffer ( _
    modeOverride As GH_CanvasMode _
) As Bitmap

Parameters

modeOverride
Type: Grasshopper.GUI.Canvas..::..GH_CanvasMode
The mode to apply during the off-screen rendering.

Return Value

A Format24bppRgb bitmap similar to the current canvas display.

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


GetGraphicsObject Method

[image]

Grasshopper SDK
GH_Canvas..::..GetGraphicsObject Method
GH_Canvas Class See Also Send Feedback
Gets a graphics object for this control. You are not allowed to draw with this object, use it only for visibility testing and such. If you're inside a canvas update, use the Graphics() property instead. You must dispose of the Graphics object returned by this method or resources will be leaked.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Graphics GetGraphicsObject(
    bool setupDisplayTransform
)
Visual Basic
Public Function GetGraphicsObject ( _
    setupDisplayTransform As Boolean _
) As Graphics

Parameters

setupDisplayTransform
Type: System..::..Boolean
If true, the display transform will be added to the graphics object.

Return Value

A non-drawing Graphics object on success or null on failure..

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


HideMRUPanels Method

[image]

Grasshopper SDK
GH_Canvas..::..HideMRUPanels Method
GH_Canvas Class See Also Send Feedback
Hide all existing MRU panels by sliding them out of view.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void HideMRUPanels()
Visual Basic
Public Sub HideMRUPanels

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


InstantiateNewObject Method

[image] [image]

Grasshopper SDK
GH_Canvas..::..InstantiateNewObject Method
GH_Canvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InstantiateNewObject(Guid, PointF, Boolean) |
Public method | InstantiateNewObject(Guid, String, PointF, Boolean) |
Public method | InstantiateNewObject(IGH_DocumentObject, String, PointF, Boolean) |

See Also

GH_Canvas Class
GH_Canvas Members
Grasshopper.GUI.Canvas Namespace


InstantiateNewObject Method (Guid, PointF, Boolean)

[image]

Grasshopper SDK
GH_Canvas..::..InstantiateNewObject Method (Guid, PointF, Boolean)
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool InstantiateNewObject(
    Guid id,
    PointF at,
    bool update
)
Visual Basic
Public Function InstantiateNewObject ( _
    id As Guid, _
    at As PointF, _
    update As Boolean _
) As Boolean

Parameters

id
Type: System..::..Guid
at
Type: System.Drawing..::..PointF
update
Type: System..::..Boolean

See Also

GH_Canvas Class
InstantiateNewObject Overload
Grasshopper.GUI.Canvas Namespace


InstantiateNewObject Method (Guid, String, PointF, Boolean)

[image]

Grasshopper SDK
GH_Canvas..::..InstantiateNewObject Method (Guid, String, PointF, Boolean)
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool InstantiateNewObject(
    Guid id,
    string init_code,
    PointF at,
    bool update
)
Visual Basic
Public Function InstantiateNewObject ( _
    id As Guid, _
    init_code As String, _
    at As PointF, _
    update As Boolean _
) As Boolean

Parameters

id
Type: System..::..Guid
init_code
Type: System..::..String
at
Type: System.Drawing..::..PointF
update
Type: System..::..Boolean

See Also

GH_Canvas Class
InstantiateNewObject Overload
Grasshopper.GUI.Canvas Namespace


InstantiateNewObject Method (IGH_DocumentObject, String, PointF, Boolean)

[image]

Grasshopper SDK
GH_Canvas..::..InstantiateNewObject Method (IGH_DocumentObject, String, PointF, Boolean)
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool InstantiateNewObject(
    IGH_DocumentObject obj,
    string init_code,
    PointF at,
    bool update
)
Visual Basic
Public Function InstantiateNewObject ( _
    obj As IGH_DocumentObject, _
    init_code As String, _
    at As PointF, _
    update As Boolean _
) As Boolean

Parameters

obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject
init_code
Type: System..::..String
at
Type: System.Drawing..::..PointF
update
Type: System..::..Boolean

See Also

GH_Canvas Class
InstantiateNewObject Overload
Grasshopper.GUI.Canvas Namespace


Navigate Method

[image]

Grasshopper SDK
GH_Canvas..::..Navigate Method
GH_Canvas Class See Also Send Feedback
Perform a single navigation step.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Navigate(
    GH_CanvasNavigation navigation
)
Visual Basic
Public Sub Navigate ( _
    navigation As GH_CanvasNavigation _
)

Parameters

navigation
Type: Grasshopper.GUI.Canvas..::..GH_CanvasNavigation
Type of navigation step.

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


OnPaint Method

[image]

Grasshopper SDK
GH_Canvas..::..OnPaint Method
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaint ( _
    e As PaintEventArgs _
)

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


OnPaintBackground Method

[image]

Grasshopper SDK
GH_Canvas..::..OnPaintBackground Method
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void OnPaintBackground(
    PaintEventArgs e
)
Visual Basic
Protected Overrides Sub OnPaintBackground ( _
    e As PaintEventArgs _
)

Parameters

e
Type: System.Windows.Forms..::..PaintEventArgs

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


OnViewportChanged Method

[image]

Grasshopper SDK
GH_Canvas..::..OnViewportChanged Method
GH_Canvas Class See Also Send Feedback
Ensure the canvas and document viewport data are synchronised and raises the ViewportChanged event.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void OnViewportChanged()
Visual Basic
Public Sub OnViewportChanged

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


ReevaluateMarkovSuggestions Method

[image]

Grasshopper SDK
GH_Canvas..::..ReevaluateMarkovSuggestions Method
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ReevaluateMarkovSuggestions()
Visual Basic
Public Sub ReevaluateMarkovSuggestions

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


Regen Method

[image]

Grasshopper SDK
GH_Canvas..::..Regen Method
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
[ObsoleteAttribute("This method is obsolete, use Refresh() instead. Or better yet, use Invalidate().")]
public void Regen()
Visual Basic
<ObsoleteAttribute("This method is obsolete, use Refresh() instead. Or better yet, use Invalidate().")> _
Public Sub Regen

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


RemoveAllTagArtists Method

[image]

Grasshopper SDK
GH_Canvas..::..RemoveAllTagArtists Method
GH_Canvas Class See Also Send Feedback
Remove all IGH_TagArtists from this canvas. Do not use this method unless you want to screw over everyone else.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RemoveAllTagArtists()
Visual Basic
Public Sub RemoveAllTagArtists

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


RemoveTagArtist Method

[image] [image]

Grasshopper SDK
GH_Canvas..::..RemoveTagArtist Method
GH_Canvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveTagArtist(Guid) | Remove all IGH_TagArtists from this canvas that match a certain ID.
Public method | RemoveTagArtist(IGH_TagArtist) | Remove a specific tag artist from this canvas. If the instance occurs multiple times in the TagArtist list, all instances will be removed.

See Also

GH_Canvas Class
GH_Canvas Members
Grasshopper.GUI.Canvas Namespace


RemoveTagArtist Method (Guid)

[image]

Grasshopper SDK
GH_Canvas..::..RemoveTagArtist Method (Guid)
GH_Canvas Class See Also Send Feedback
Remove all IGH_TagArtists from this canvas that match a certain ID.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int RemoveTagArtist(
    Guid artistId
)
Visual Basic
Public Function RemoveTagArtist ( _
    artistId As Guid _
) As Integer

Parameters

artistId
Type: System..::..Guid
ID of IGH_TagArtists to remove.

Return Value

The number of IGH_TagArtist instances removed.

See Also

GH_Canvas Class
RemoveTagArtist Overload
Grasshopper.GUI.Canvas Namespace


RemoveTagArtist Method (IGH_TagArtist)

[image]

Grasshopper SDK
GH_Canvas..::..RemoveTagArtist Method (IGH_TagArtist)
GH_Canvas Class See Also Send Feedback
Remove a specific tag artist from this canvas. If the instance occurs multiple times in the TagArtist list, all instances will be removed.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int RemoveTagArtist(
    IGH_TagArtist artist
)
Visual Basic
Public Function RemoveTagArtist ( _
    artist As IGH_TagArtist _
) As Integer

Parameters

artist
Type: Grasshopper.GUI.Canvas.TagArtists..::..IGH_TagArtist
TagArtist to remove.

Return Value

The number of IGH_TagArtist instances removed.

See Also

GH_Canvas Class
RemoveTagArtist Overload
Grasshopper.GUI.Canvas Namespace


ScheduleRegen Method

[image]

Grasshopper SDK
GH_Canvas..::..ScheduleRegen Method
GH_Canvas Class See Also Send Feedback
Schedule a regen to occur after the specified number of milliseconds have elapsed. If a Regen is called in this time frame, the schedule will be cleared. Only a single schedule can be active at any time, so any call to ScheduleRegen will clear existing schedules.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ScheduleRegen(
    int delay
)
Visual Basic
Public Sub ScheduleRegen ( _
    delay As Integer _
)

Parameters

delay
Type: System..::..Int32
Number of milliseconds to wait until repainting the canvas. intervals equal to or less than zero will be ignored.

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


SetSmartTextRenderingHint Method

[image]

Grasshopper SDK
GH_Canvas..::..SetSmartTextRenderingHint Method
GH_Canvas Class See Also Send Feedback
When this method is called during a redraw, the TextRenderingHint of the associated graphics object will be set to either GH_CrispText or GH_SmoothText depending on zoom level.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SetSmartTextRenderingHint()
Visual Basic
Public Sub SetSmartTextRenderingHint

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


ShowComponentSearchBox Method

[image] [image]

Grasshopper SDK
GH_Canvas..::..ShowComponentSearchBox Method
GH_Canvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ShowComponentSearchBox()()()() | Display the component Search dialog at the current mouse location. The dialog cannot be shown if ModifiersEnabled=False.
Public method | ShowComponentSearchBox(Point) | Display the component Search dialog at the given coordinate. The dialog cannot be shown if ModifiersEnabled=False.

See Also

GH_Canvas Class
GH_Canvas Members
Grasshopper.GUI.Canvas Namespace


ShowComponentSearchBox Method

[image]

Grasshopper SDK
GH_Canvas..::..ShowComponentSearchBox Method
GH_Canvas Class See Also Send Feedback
Display the component Search dialog at the current mouse location. The dialog cannot be shown if ModifiersEnabled=False.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool ShowComponentSearchBox()
Visual Basic
Public Function ShowComponentSearchBox As Boolean

Return Value

True on success, false on failure.

See Also

GH_Canvas Class
ShowComponentSearchBox Overload
Grasshopper.GUI.Canvas Namespace


ShowComponentSearchBox Method (Point)

[image]

Grasshopper SDK
GH_Canvas..::..ShowComponentSearchBox Method (Point)
GH_Canvas Class See Also Send Feedback
Display the component Search dialog at the given coordinate. The dialog cannot be shown if ModifiersEnabled=False.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool ShowComponentSearchBox(
    Point at
)
Visual Basic
Public Function ShowComponentSearchBox ( _
    at As Point _
) As Boolean

Parameters

at
Type: System.Drawing..::..Point
Location (in screen space) for the center of the search box.

Return Value

True on success, false on failure.

See Also

GH_Canvas Class
ShowComponentSearchBox Overload
Grasshopper.GUI.Canvas Namespace


ShowMRUPanels Method

[image]

Grasshopper SDK
GH_Canvas..::..ShowMRUPanels Method
GH_Canvas Class See Also Send Feedback
Show any hidden MRU panels by sliding them back into view.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ShowMRUPanels()
Visual Basic
Public Sub ShowMRUPanels

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


ShowNavigationPane Method

[image]

Grasshopper SDK
GH_Canvas..::..ShowNavigationPane Method
GH_Canvas Class See Also Send Feedback
Displays the quick-navigation popup pane at the cursor.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ShowNavigationPane()
Visual Basic
Public Sub ShowNavigationPane

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


ShowSearchDialog Method

[image]

Grasshopper SDK
GH_Canvas..::..ShowSearchDialog Method
GH_Canvas Class See Also Send Feedback
Display the Find dialog. If a Find dialog is already active for this canvas, nothing will happen.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ShowSearchDialog(
    bool centerOnCursor
)
Visual Basic
Public Sub ShowSearchDialog ( _
    centerOnCursor As Boolean _
)

Parameters

centerOnCursor
Type: System..::..Boolean
If true, the dialog will be centered on the cursor, otherwise it will be put in the upper left corner of the canvas.

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


StartAutoPan Method

[image]

Grasshopper SDK
GH_Canvas..::..StartAutoPan Method
GH_Canvas Class See Also Send Feedback
Start the auto-panning timer.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void StartAutoPan()
Visual Basic
Public Sub StartAutoPan

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


StopAutoPan Method

[image]

Grasshopper SDK
GH_Canvas..::..StopAutoPan Method
GH_Canvas Class See Also Send Feedback
Stop the auto-panning timer.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void StopAutoPan()
Visual Basic
Public Sub StopAutoPan

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


UpdateDocumentPreview Method

[image]

Grasshopper SDK
GH_Canvas..::..UpdateDocumentPreview Method
GH_Canvas Class See Also Send Feedback
Call this method to update the preview thumbnail for the currently loaded document. If no document is currently loaded, nothing will happen.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void UpdateDocumentPreview()
Visual Basic
Public Sub UpdateDocumentPreview

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


GH_Canvas Properties

[image] [image]

Grasshopper SDK
GH_Canvas Properties
GH_Canvas Class See Also Send Feedback

The GH_Canvas type exposes the following members.

Properties

 | Name | Description
Public property | ActiveInteraction | Gets or sets the currently active interaction object.
Public property | ActiveObject | Gets or sets the currently active object.
Public property | ActiveWidget | Gets or sets the currently active widget.
Public property | CursorCanvasPosition | Gets the location of the cursor in Canvas coordinates.
Public property | CursorControlPosition | Gets the location of the cursor in Control coordinates.
 | DisplayVoronoiWarning | Gets or sets whether the Voronoi Over-dose warning message is displayed. This property is set once at Grasshopper startup to True.
Public property | Document | Gets or sets the document currently loaded in this canvas.
Public property | DrawingMode | Gets the current drawing mode for this canvas.
Public property | Graphics | Gets the graphics object with which this Canvas is redrawn. This object only exists during redraws, if you need the Graphics object for this canvas outside of updates, call GetGraphicsObject() instead.
Public property | IsActiveInteraction | Gets a value indicating whether or not there is an interaction object loaded in this canvas.
Public property | IsActiveObject | Gets a value indicating whether or not an object is currently activated.
Public property | IsActiveWidget | Gets a value indicating whether or not a widget is currently activated.
Public property | IsDocument | Gets a value indicating whether or not a document is currently loaded in this canvas.
Public property | MarkovSuggestions |
Public property | ModifiersEnabled | Gets or sets the modifiers enabled flag. When modifiers are disabled, only zooming and panning is still allowed.
 | NavigationPanDown | Gets or sets the special key for panning down.
 | NavigationPanLeft | Gets or sets the special key for panning left.
 | NavigationPanPixels | Gets or sets the number of pixels for each pan operation.
 | NavigationPanRight | Gets or sets the special key for panning right.
 | NavigationPanUp | Gets or sets the special key for panning up.
 | NavigationZoomFactor | Gets or sets the zoom factor for navigation zoom operations.
 | NavigationZoomIn | Gets or sets the special key for zooming in.
 | NavigationZoomOut | Gets or sets the special key for zooming in.
Public property | Painter | Gets the painter object that handles most of the drawing logic for this canvas.
Public property | Painting | Gets whether this canvas is currently busy painting itself.
Public property | TagArtistIDs | Gets all the TagArtist IDs in this Canvas.
 | ThumbnailSize | Gets the thumbnail size for documents.
Public property | TooltipDelay | Gets the delay (in milliseconds) required for a tooltip popup. This delay is a user setting stored under the Canvas:TooltipDelay field of the core settings.
Public property | ValidGraphics | Gets or sets the Valid Graphics flag. Even if the flag is set to true, though, the property may still return false if there is a problem with the internal graphics object.
Public property | Viewport | Gets the viewport that determines the panning and zooming for this canvas.
Public property | Widgets | Gets a list of all the widgets on this canvas.
 | ZoomFadeHigh | Gets the ZUI fade alpha value for the high zoom level threshold. This static field gets set on every Canvas paint start. The high threshold is typically used for ZUI elements that only appear when zoomed in.
 | ZoomFadeLow | Gets the ZUI fade alpha value for the low zoom level threshold. This static field gets set on every Canvas paint start. The low threshold is typically used for fading of icons and object names.
 | ZoomFadeMedium | Gets the ZUI fade alpha value for the medium zoom level threshold. This static field gets set on every Canvas paint start. The medium threshold is typically used for non-informative UI elements such as highlights.

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


ActiveInteraction Property

[image]

Grasshopper SDK
GH_Canvas..::..ActiveInteraction Property
GH_Canvas Class See Also Send Feedback
Gets or sets the currently active interaction object.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_MouseInteraction ActiveInteraction { get; set; }
Visual Basic
Public Property ActiveInteraction As IGH_MouseInteraction
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Canvas.ActiveInteraction"]

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


ActiveObject Property

[image]

Grasshopper SDK
GH_Canvas..::..ActiveObject Property
GH_Canvas Class See Also Send Feedback
Gets or sets the currently active object.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_DocumentObject ActiveObject { get; set; }
Visual Basic
Public Property ActiveObject As IGH_DocumentObject
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Canvas.ActiveObject"]

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


ActiveWidget Property

[image]

Grasshopper SDK
GH_Canvas..::..ActiveWidget Property
GH_Canvas Class See Also Send Feedback
Gets or sets the currently active widget.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_Widget ActiveWidget { get; set; }
Visual Basic
Public Property ActiveWidget As IGH_Widget
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Canvas.ActiveWidget"]

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


CursorCanvasPosition Property

[image]

Grasshopper SDK
GH_Canvas..::..CursorCanvasPosition Property
GH_Canvas Class See Also Send Feedback
Gets the location of the cursor in Canvas coordinates.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public PointF CursorCanvasPosition { get; }
Visual Basic
Public ReadOnly Property CursorCanvasPosition As PointF
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Canvas.CursorCanvasPosition"]

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


CursorControlPosition Property

[image]

Grasshopper SDK
GH_Canvas..::..CursorControlPosition Property
GH_Canvas Class See Also Send Feedback
Gets the location of the cursor in Control coordinates.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Point CursorControlPosition { get; }
Visual Basic
Public ReadOnly Property CursorControlPosition As Point
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Canvas.CursorControlPosition"]

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


DisplayVoronoiWarning Property

[image]

Grasshopper SDK
GH_Canvas..::..DisplayVoronoiWarning Property
GH_Canvas Class See Also Send Feedback
Gets or sets whether the Voronoi Over-dose warning message is displayed. This property is set once at Grasshopper startup to True.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool DisplayVoronoiWarning { get; set; }
Visual Basic
Public Shared Property DisplayVoronoiWarning As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Canvas.DisplayVoronoiWarning"]

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


Document Property

[image]

Grasshopper SDK
GH_Canvas..::..Document Property
GH_Canvas Class See Also Send Feedback
Gets or sets the document currently loaded in this canvas.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Document Document { get; set; }
Visual Basic
Public Property Document As GH_Document
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Canvas.Document"]

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


DrawingMode Property

[image]

Grasshopper SDK
GH_Canvas..::..DrawingMode Property
GH_Canvas Class See Also Send Feedback
Gets the current drawing mode for this canvas.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_CanvasMode DrawingMode { get; }
Visual Basic
Public ReadOnly Property DrawingMode As GH_CanvasMode
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Canvas.DrawingMode"]

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


Graphics Property

[image]

Grasshopper SDK
GH_Canvas..::..Graphics Property
GH_Canvas Class See Also Send Feedback
Gets the graphics object with which this Canvas is redrawn. This object only exists during redraws, if you need the Graphics object for this canvas outside of updates, call GetGraphicsObject() instead.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Graphics Graphics { get; }
Visual Basic
Public ReadOnly Property Graphics As Graphics
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Canvas.Graphics"]

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


IsActiveInteraction Property

[image]

Grasshopper SDK
GH_Canvas..::..IsActiveInteraction Property
GH_Canvas Class See Also Send Feedback
Gets a value indicating whether or not there is an interaction object loaded in this canvas.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsActiveInteraction { get; }
Visual Basic
Public ReadOnly Property IsActiveInteraction As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Canvas.IsActiveInteraction"]

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


IsActiveObject Property

[image]

Grasshopper SDK
GH_Canvas..::..IsActiveObject Property
GH_Canvas Class See Also Send Feedback
Gets a value indicating whether or not an object is currently activated.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsActiveObject { get; }
Visual Basic
Public ReadOnly Property IsActiveObject As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Canvas.IsActiveObject"]

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


IsActiveWidget Property

[image]

Grasshopper SDK
GH_Canvas..::..IsActiveWidget Property
GH_Canvas Class See Also Send Feedback
Gets a value indicating whether or not a widget is currently activated.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsActiveWidget { get; }
Visual Basic
Public ReadOnly Property IsActiveWidget As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Canvas.IsActiveWidget"]

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


IsDocument Property

[image]

Grasshopper SDK
GH_Canvas..::..IsDocument Property
GH_Canvas Class See Also Send Feedback
Gets a value indicating whether or not a document is currently loaded in this canvas.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsDocument { get; }
Visual Basic
Public ReadOnly Property IsDocument As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Canvas.IsDocument"]

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


MarkovSuggestions Property

[image]

Grasshopper SDK
GH_Canvas..::..MarkovSuggestions Property
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<IGH_ObjectProxy> MarkovSuggestions { get; }
Visual Basic
Public ReadOnly Property MarkovSuggestions As List(Of IGH_ObjectProxy)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Canvas.MarkovSuggestions"]

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


ModifiersEnabled Property

[image]

Grasshopper SDK
GH_Canvas..::..ModifiersEnabled Property
GH_Canvas Class See Also Send Feedback
Gets or sets the modifiers enabled flag. When modifiers are disabled, only zooming and panning is still allowed.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool ModifiersEnabled { get; set; }
Visual Basic
Public Property ModifiersEnabled As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Canvas.ModifiersEnabled"]

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


NavigationPanDown Property

[image]

Grasshopper SDK
GH_Canvas..::..NavigationPanDown Property
GH_Canvas Class See Also Send Feedback
Gets or sets the special key for panning down.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Keys NavigationPanDown { get; set; }
Visual Basic
Public Shared Property NavigationPanDown As Keys
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Canvas.NavigationPanDown"]

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


NavigationPanLeft Property

[image]

Grasshopper SDK
GH_Canvas..::..NavigationPanLeft Property
GH_Canvas Class See Also Send Feedback
Gets or sets the special key for panning left.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Keys NavigationPanLeft { get; set; }
Visual Basic
Public Shared Property NavigationPanLeft As Keys
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Canvas.NavigationPanLeft"]

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


NavigationPanPixels Property

[image]

Grasshopper SDK
GH_Canvas..::..NavigationPanPixels Property
GH_Canvas Class See Also Send Feedback
Gets or sets the number of pixels for each pan operation.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static int NavigationPanPixels { get; set; }
Visual Basic
Public Shared Property NavigationPanPixels As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Canvas.NavigationPanPixels"]

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


NavigationPanRight Property

[image]

Grasshopper SDK
GH_Canvas..::..NavigationPanRight Property
GH_Canvas Class See Also Send Feedback
Gets or sets the special key for panning right.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Keys NavigationPanRight { get; set; }
Visual Basic
Public Shared Property NavigationPanRight As Keys
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Canvas.NavigationPanRight"]

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


NavigationPanUp Property

[image]

Grasshopper SDK
GH_Canvas..::..NavigationPanUp Property
GH_Canvas Class See Also Send Feedback
Gets or sets the special key for panning up.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Keys NavigationPanUp { get; set; }
Visual Basic
Public Shared Property NavigationPanUp As Keys
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Canvas.NavigationPanUp"]

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


NavigationZoomFactor Property

[image]

Grasshopper SDK
GH_Canvas..::..NavigationZoomFactor Property
GH_Canvas Class See Also Send Feedback
Gets or sets the zoom factor for navigation zoom operations.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static double NavigationZoomFactor { get; set; }
Visual Basic
Public Shared Property NavigationZoomFactor As Double
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Canvas.NavigationZoomFactor"]

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


NavigationZoomIn Property

[image]

Grasshopper SDK
GH_Canvas..::..NavigationZoomIn Property
GH_Canvas Class See Also Send Feedback
Gets or sets the special key for zooming in.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Keys NavigationZoomIn { get; set; }
Visual Basic
Public Shared Property NavigationZoomIn As Keys
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Canvas.NavigationZoomIn"]

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


NavigationZoomOut Property

[image]

Grasshopper SDK
GH_Canvas..::..NavigationZoomOut Property
GH_Canvas Class See Also Send Feedback
Gets or sets the special key for zooming in.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Keys NavigationZoomOut { get; set; }
Visual Basic
Public Shared Property NavigationZoomOut As Keys
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Canvas.NavigationZoomOut"]

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


Painter Property

[image]

Grasshopper SDK
GH_Canvas..::..Painter Property
GH_Canvas Class See Also Send Feedback
Gets the painter object that handles most of the drawing logic for this canvas.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Painter Painter { get; }
Visual Basic
Public ReadOnly Property Painter As GH_Painter
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Canvas.Painter"]

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


Painting Property

[image]

Grasshopper SDK
GH_Canvas..::..Painting Property
GH_Canvas Class See Also Send Feedback
Gets whether this canvas is currently busy painting itself.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Painting { get; }
Visual Basic
Public ReadOnly Property Painting As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Canvas.Painting"]

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


TagArtistIDs Property

[image]

Grasshopper SDK
GH_Canvas..::..TagArtistIDs Property
GH_Canvas Class See Also Send Feedback
Gets all the TagArtist IDs in this Canvas.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<Guid> TagArtistIDs { get; }
Visual Basic
Public ReadOnly Property TagArtistIDs As List(Of Guid)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Canvas.TagArtistIDs"]

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


ThumbnailSize Property

[image]

Grasshopper SDK
GH_Canvas..::..ThumbnailSize Property
GH_Canvas Class See Also Send Feedback
Gets the thumbnail size for documents.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Size ThumbnailSize { get; }
Visual Basic
Public Shared ReadOnly Property ThumbnailSize As Size
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Canvas.ThumbnailSize"]

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


TooltipDelay Property

[image]

Grasshopper SDK
GH_Canvas..::..TooltipDelay Property
GH_Canvas Class See Also Send Feedback
Gets the delay (in milliseconds) required for a tooltip popup. This delay is a user setting stored under the Canvas:TooltipDelay field of the core settings.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int TooltipDelay { get; }
Visual Basic
Public ReadOnly Property TooltipDelay As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Canvas.TooltipDelay"]

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


ValidGraphics Property

[image]

Grasshopper SDK
GH_Canvas..::..ValidGraphics Property
GH_Canvas Class See Also Send Feedback
Gets or sets the Valid Graphics flag. Even if the flag is set to true, though, the property may still return false if there is a problem with the internal graphics object.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool ValidGraphics { get; set; }
Visual Basic
Public Property ValidGraphics As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Canvas.ValidGraphics"]

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


Viewport Property

[image]

Grasshopper SDK
GH_Canvas..::..Viewport Property
GH_Canvas Class See Also Send Feedback
Gets the viewport that determines the panning and zooming for this canvas.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Viewport Viewport { get; }
Visual Basic
Public ReadOnly Property Viewport As GH_Viewport
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Canvas.Viewport"]

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


Widgets Property

[image]

Grasshopper SDK
GH_Canvas..::..Widgets Property
GH_Canvas Class See Also Send Feedback
Gets a list of all the widgets on this canvas.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<IGH_Widget> Widgets { get; }
Visual Basic
Public ReadOnly Property Widgets As List(Of IGH_Widget)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Canvas.Widgets"]

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


ZoomFadeHigh Property

[image]

Grasshopper SDK
GH_Canvas..::..ZoomFadeHigh Property
GH_Canvas Class See Also Send Feedback
Gets the ZUI fade alpha value for the high zoom level threshold. This static field gets set on every Canvas paint start. The high threshold is typically used for ZUI elements that only appear when zoomed in.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static int ZoomFadeHigh { get; }
Visual Basic
Public Shared ReadOnly Property ZoomFadeHigh As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Canvas.ZoomFadeHigh"]

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


ZoomFadeLow Property

[image]

Grasshopper SDK
GH_Canvas..::..ZoomFadeLow Property
GH_Canvas Class See Also Send Feedback
Gets the ZUI fade alpha value for the low zoom level threshold. This static field gets set on every Canvas paint start. The low threshold is typically used for fading of icons and object names.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static int ZoomFadeLow { get; }
Visual Basic
Public Shared ReadOnly Property ZoomFadeLow As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Canvas.ZoomFadeLow"]

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


ZoomFadeMedium Property

[image]

Grasshopper SDK
GH_Canvas..::..ZoomFadeMedium Property
GH_Canvas Class See Also Send Feedback
Gets the ZUI fade alpha value for the medium zoom level threshold. This static field gets set on every Canvas paint start. The medium threshold is typically used for non-informative UI elements such as highlights.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static int ZoomFadeMedium { get; }
Visual Basic
Public Shared ReadOnly Property ZoomFadeMedium As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Canvas.ZoomFadeMedium"]

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


GH_Canvas Events

[image] [image]

Grasshopper SDK
GH_Canvas Events
GH_Canvas Class See Also Send Feedback

The GH_Canvas type exposes the following members.

Events

 | Name | Description
Public event | CanvasPaintBackground | Raised after the background has been drawn.
Public event | CanvasPaintBegin | Raised before a new paint operation starts. This event is always raised, even if the Canvas isn't visible.
Public event | CanvasPaintEnd | Raised after a paint operation completes. This event is always raised, even if the Canvas isn't visible.
Public event | CanvasPostPaintGroups | Raised after group drawing completes.
Public event | CanvasPostPaintObjects | Raised after object drawing completes.
Public event | CanvasPostPaintOverlay | Raised after object overlay drawing completes.
Public event | CanvasPostPaintWidgets | Raised after widgets are drawn. This is the final event in the Drawing pipeline.
Public event | CanvasPostPaintWires | Raised after wire drawing completes.
Public event | CanvasPrePaintGroups | Raised before group drawing starts.
Public event | CanvasPrePaintObjects | Raised before object drawing starts.
Public event | CanvasPrePaintOverlay | Raised before object overlay drawing starts.
Public event | CanvasPrePaintWidgets | Raised before Widgets are drawn.
Public event | CanvasPrePaintWires | Raised before wire drawing starts.
Public event | Document_ModifiedChanged |
Public event | Document_ObjectsAdded |
Public event | Document_ObjectsDeleted |
Public event | Document_SettingsChanged |
Public event | DocumentChanged | This event is raised whenever a different document is loaded into this canvas.
Public event | DocumentObjectMouseDown | This event is raised whenever the left mouse button is pressed while over a Document object.
Public event | DocumentObjectsDeleted | Obsolete.
Public event | ModifiersChanged | This event is raised whenever the ModifiersEnabled property changes.
 | NavigationSettingsChanged | Raised whenever any of the shared navigation properties changed.
Public event | ViewportChanged | This event is raised whenever the viewport properties are modified, for example when the pan or zoom values are affected.
 | WidgetListCreated | This event is raised once for every GH_Canvas object that is created anew. The event is Shared (static) because it is raised inside the constructor of a GH_Canvas object and therefor cannot be registered on an instance.

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


CanvasPaintBackground Event

[image]

Grasshopper SDK
GH_Canvas..::..CanvasPaintBackground Event
GH_Canvas Class See Also Send Feedback
Raised after the background has been drawn.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_Canvas..::..CanvasPaintBackgroundEventHandler CanvasPaintBackground
Visual Basic
Public Event CanvasPaintBackground As GH_Canvas..::..CanvasPaintBackgroundEventHandler

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


CanvasPaintBegin Event

[image]

Grasshopper SDK
GH_Canvas..::..CanvasPaintBegin Event
GH_Canvas Class See Also Send Feedback
Raised before a new paint operation starts. This event is always raised, even if the Canvas isn't visible.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_Canvas..::..CanvasPaintBeginEventHandler CanvasPaintBegin
Visual Basic
Public Event CanvasPaintBegin As GH_Canvas..::..CanvasPaintBeginEventHandler

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


CanvasPaintEnd Event

[image]

Grasshopper SDK
GH_Canvas..::..CanvasPaintEnd Event
GH_Canvas Class See Also Send Feedback
Raised after a paint operation completes. This event is always raised, even if the Canvas isn't visible.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_Canvas..::..CanvasPaintEndEventHandler CanvasPaintEnd
Visual Basic
Public Event CanvasPaintEnd As GH_Canvas..::..CanvasPaintEndEventHandler

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


CanvasPostPaintGroups Event

[image]

Grasshopper SDK
GH_Canvas..::..CanvasPostPaintGroups Event
GH_Canvas Class See Also Send Feedback
Raised after group drawing completes.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_Canvas..::..CanvasPostPaintGroupsEventHandler CanvasPostPaintGroups
Visual Basic
Public Event CanvasPostPaintGroups As GH_Canvas..::..CanvasPostPaintGroupsEventHandler

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


CanvasPostPaintObjects Event

[image]

Grasshopper SDK
GH_Canvas..::..CanvasPostPaintObjects Event
GH_Canvas Class See Also Send Feedback
Raised after object drawing completes.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_Canvas..::..CanvasPostPaintObjectsEventHandler CanvasPostPaintObjects
Visual Basic
Public Event CanvasPostPaintObjects As GH_Canvas..::..CanvasPostPaintObjectsEventHandler

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


CanvasPostPaintOverlay Event

[image]

Grasshopper SDK
GH_Canvas..::..CanvasPostPaintOverlay Event
GH_Canvas Class See Also Send Feedback
Raised after object overlay drawing completes.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_Canvas..::..CanvasPostPaintOverlayEventHandler CanvasPostPaintOverlay
Visual Basic
Public Event CanvasPostPaintOverlay As GH_Canvas..::..CanvasPostPaintOverlayEventHandler

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


CanvasPostPaintWidgets Event

[image]

Grasshopper SDK
GH_Canvas..::..CanvasPostPaintWidgets Event
GH_Canvas Class See Also Send Feedback
Raised after widgets are drawn. This is the final event in the Drawing pipeline.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_Canvas..::..CanvasPostPaintWidgetsEventHandler CanvasPostPaintWidgets
Visual Basic
Public Event CanvasPostPaintWidgets As GH_Canvas..::..CanvasPostPaintWidgetsEventHandler

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


CanvasPostPaintWires Event

[image]

Grasshopper SDK
GH_Canvas..::..CanvasPostPaintWires Event
GH_Canvas Class See Also Send Feedback
Raised after wire drawing completes.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_Canvas..::..CanvasPostPaintWiresEventHandler CanvasPostPaintWires
Visual Basic
Public Event CanvasPostPaintWires As GH_Canvas..::..CanvasPostPaintWiresEventHandler

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


CanvasPrePaintGroups Event

[image]

Grasshopper SDK
GH_Canvas..::..CanvasPrePaintGroups Event
GH_Canvas Class See Also Send Feedback
Raised before group drawing starts.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_Canvas..::..CanvasPrePaintGroupsEventHandler CanvasPrePaintGroups
Visual Basic
Public Event CanvasPrePaintGroups As GH_Canvas..::..CanvasPrePaintGroupsEventHandler

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


CanvasPrePaintObjects Event

[image]

Grasshopper SDK
GH_Canvas..::..CanvasPrePaintObjects Event
GH_Canvas Class See Also Send Feedback
Raised before object drawing starts.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_Canvas..::..CanvasPrePaintObjectsEventHandler CanvasPrePaintObjects
Visual Basic
Public Event CanvasPrePaintObjects As GH_Canvas..::..CanvasPrePaintObjectsEventHandler

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


CanvasPrePaintOverlay Event

[image]

Grasshopper SDK
GH_Canvas..::..CanvasPrePaintOverlay Event
GH_Canvas Class See Also Send Feedback
Raised before object overlay drawing starts.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_Canvas..::..CanvasPrePaintOverlayEventHandler CanvasPrePaintOverlay
Visual Basic
Public Event CanvasPrePaintOverlay As GH_Canvas..::..CanvasPrePaintOverlayEventHandler

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


CanvasPrePaintWidgets Event

[image]

Grasshopper SDK
GH_Canvas..::..CanvasPrePaintWidgets Event
GH_Canvas Class See Also Send Feedback
Raised before Widgets are drawn.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_Canvas..::..CanvasPrePaintWidgetsEventHandler CanvasPrePaintWidgets
Visual Basic
Public Event CanvasPrePaintWidgets As GH_Canvas..::..CanvasPrePaintWidgetsEventHandler

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


CanvasPrePaintWires Event

[image]

Grasshopper SDK
GH_Canvas..::..CanvasPrePaintWires Event
GH_Canvas Class See Also Send Feedback
Raised before wire drawing starts.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_Canvas..::..CanvasPrePaintWiresEventHandler CanvasPrePaintWires
Visual Basic
Public Event CanvasPrePaintWires As GH_Canvas..::..CanvasPrePaintWiresEventHandler

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


Document_ModifiedChanged Event

[image]

Grasshopper SDK
GH_Canvas..::..Document_ModifiedChanged Event
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_Canvas..::..Document_ModifiedChangedEventHandler Document_ModifiedChanged
Visual Basic
Public Event Document_ModifiedChanged As GH_Canvas..::..Document_ModifiedChangedEventHandler

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


Document_ObjectsAdded Event

[image]

Grasshopper SDK
GH_Canvas..::..Document_ObjectsAdded Event
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_Canvas..::..Document_ObjectsAddedEventHandler Document_ObjectsAdded
Visual Basic
Public Event Document_ObjectsAdded As GH_Canvas..::..Document_ObjectsAddedEventHandler

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


Document_ObjectsDeleted Event

[image]

Grasshopper SDK
GH_Canvas..::..Document_ObjectsDeleted Event
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_Canvas..::..Document_ObjectsDeletedEventHandler Document_ObjectsDeleted
Visual Basic
Public Event Document_ObjectsDeleted As GH_Canvas..::..Document_ObjectsDeletedEventHandler

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


Document_SettingsChanged Event

[image]

Grasshopper SDK
GH_Canvas..::..Document_SettingsChanged Event
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_Canvas..::..Document_SettingsChangedEventHandler Document_SettingsChanged
Visual Basic
Public Event Document_SettingsChanged As GH_Canvas..::..Document_SettingsChangedEventHandler

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


DocumentChanged Event

[image]

Grasshopper SDK
GH_Canvas..::..DocumentChanged Event
GH_Canvas Class See Also Send Feedback
This event is raised whenever a different document is loaded into this canvas.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_Canvas..::..DocumentChangedEventHandler DocumentChanged
Visual Basic
Public Event DocumentChanged As GH_Canvas..::..DocumentChangedEventHandler

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


DocumentObjectMouseDown Event

[image]

Grasshopper SDK
GH_Canvas..::..DocumentObjectMouseDown Event
GH_Canvas Class See Also Send Feedback
This event is raised whenever the left mouse button is pressed while over a Document object.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_Canvas..::..DocumentObjectMouseDownEventHandler DocumentObjectMouseDown
Visual Basic
Public Event DocumentObjectMouseDown As GH_Canvas..::..DocumentObjectMouseDownEventHandler

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


DocumentObjectsDeleted Event

[image]

Grasshopper SDK
GH_Canvas..::..DocumentObjectsDeleted Event
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
[ObsoleteAttribute("This event has been replaced by the Document_ObjectsDeleted event")]
public event GH_Canvas..::..DocumentObjectsDeletedEventHandler DocumentObjectsDeleted
Visual Basic
<ObsoleteAttribute("This event has been replaced by the Document_ObjectsDeleted event")> _
Public Event DocumentObjectsDeleted As GH_Canvas..::..DocumentObjectsDeletedEventHandler

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


ModifiersChanged Event

[image]

Grasshopper SDK
GH_Canvas..::..ModifiersChanged Event
GH_Canvas Class See Also Send Feedback
This event is raised whenever the ModifiersEnabled property changes.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_Canvas..::..ModifiersChangedEventHandler ModifiersChanged
Visual Basic
Public Event ModifiersChanged As GH_Canvas..::..ModifiersChangedEventHandler

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


NavigationSettingsChanged Event

[image]

Grasshopper SDK
GH_Canvas..::..NavigationSettingsChanged Event
GH_Canvas Class See Also Send Feedback
Raised whenever any of the shared navigation properties changed.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event GH_Canvas..::..NavigationSettingsChangedEventHandler NavigationSettingsChanged
Visual Basic
Public Shared Event NavigationSettingsChanged As GH_Canvas..::..NavigationSettingsChangedEventHandler

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


ViewportChanged Event

[image]

Grasshopper SDK
GH_Canvas..::..ViewportChanged Event
GH_Canvas Class See Also Send Feedback
This event is raised whenever the viewport properties are modified, for example when the pan or zoom values are affected.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_Canvas..::..ViewportChangedEventHandler ViewportChanged
Visual Basic
Public Event ViewportChanged As GH_Canvas..::..ViewportChangedEventHandler

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


WidgetListCreated Event

[image]

Grasshopper SDK
GH_Canvas..::..WidgetListCreated Event
GH_Canvas Class See Also Send Feedback
This event is raised once for every GH_Canvas object that is created anew. The event is Shared (static) because it is raised inside the constructor of a GH_Canvas object and therefor cannot be registered on an instance.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event GH_Canvas..::..WidgetListCreatedEventHandler WidgetListCreated
Visual Basic
Public Shared Event WidgetListCreated As GH_Canvas..::..WidgetListCreatedEventHandler

See Also

GH_Canvas Class
Grasshopper.GUI.Canvas Namespace


GH_Canvas.CanvasPaintBackgroundEventHandler Delegate

[image]

Grasshopper SDK
GH_Canvas..::..CanvasPaintBackgroundEventHandler Delegate
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void CanvasPaintBackgroundEventHandler(
    GH_Canvas sender
)
Visual Basic
Public Delegate Sub CanvasPaintBackgroundEventHandler ( _
    sender As GH_Canvas _
)

Parameters

sender
Type: Grasshopper.GUI.Canvas..::..GH_Canvas

See Also

Grasshopper.GUI.Canvas Namespace


GH_Canvas.CanvasPaintBeginEventHandler Delegate

[image]

Grasshopper SDK
GH_Canvas..::..CanvasPaintBeginEventHandler Delegate
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void CanvasPaintBeginEventHandler(
    GH_Canvas sender
)
Visual Basic
Public Delegate Sub CanvasPaintBeginEventHandler ( _
    sender As GH_Canvas _
)

Parameters

sender
Type: Grasshopper.GUI.Canvas..::..GH_Canvas

See Also

Grasshopper.GUI.Canvas Namespace


GH_Canvas.CanvasPaintEndEventHandler Delegate

[image]

Grasshopper SDK
GH_Canvas..::..CanvasPaintEndEventHandler Delegate
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void CanvasPaintEndEventHandler(
    GH_Canvas sender
)
Visual Basic
Public Delegate Sub CanvasPaintEndEventHandler ( _
    sender As GH_Canvas _
)

Parameters

sender
Type: Grasshopper.GUI.Canvas..::..GH_Canvas

See Also

Grasshopper.GUI.Canvas Namespace


GH_Canvas.CanvasPostPaintGroupsEventHandler Delegate

[image]

Grasshopper SDK
GH_Canvas..::..CanvasPostPaintGroupsEventHandler Delegate
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void CanvasPostPaintGroupsEventHandler(
    GH_Canvas sender
)
Visual Basic
Public Delegate Sub CanvasPostPaintGroupsEventHandler ( _
    sender As GH_Canvas _
)

Parameters

sender
Type: Grasshopper.GUI.Canvas..::..GH_Canvas

See Also

Grasshopper.GUI.Canvas Namespace


GH_Canvas.CanvasPostPaintObjectsEventHandler Delegate

[image]

Grasshopper SDK
GH_Canvas..::..CanvasPostPaintObjectsEventHandler Delegate
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void CanvasPostPaintObjectsEventHandler(
    GH_Canvas sender
)
Visual Basic
Public Delegate Sub CanvasPostPaintObjectsEventHandler ( _
    sender As GH_Canvas _
)

Parameters

sender
Type: Grasshopper.GUI.Canvas..::..GH_Canvas

See Also

Grasshopper.GUI.Canvas Namespace


GH_Canvas.CanvasPostPaintOverlayEventHandler Delegate

[image]

Grasshopper SDK
GH_Canvas..::..CanvasPostPaintOverlayEventHandler Delegate
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void CanvasPostPaintOverlayEventHandler(
    GH_Canvas sender
)
Visual Basic
Public Delegate Sub CanvasPostPaintOverlayEventHandler ( _
    sender As GH_Canvas _
)

Parameters

sender
Type: Grasshopper.GUI.Canvas..::..GH_Canvas

See Also

Grasshopper.GUI.Canvas Namespace


GH_Canvas.CanvasPostPaintWidgetsEventHandler Delegate

[image]

Grasshopper SDK
GH_Canvas..::..CanvasPostPaintWidgetsEventHandler Delegate
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void CanvasPostPaintWidgetsEventHandler(
    GH_Canvas sender
)
Visual Basic
Public Delegate Sub CanvasPostPaintWidgetsEventHandler ( _
    sender As GH_Canvas _
)

Parameters

sender
Type: Grasshopper.GUI.Canvas..::..GH_Canvas

See Also

Grasshopper.GUI.Canvas Namespace


GH_Canvas.CanvasPostPaintWiresEventHandler Delegate

[image]

Grasshopper SDK
GH_Canvas..::..CanvasPostPaintWiresEventHandler Delegate
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void CanvasPostPaintWiresEventHandler(
    GH_Canvas sender
)
Visual Basic
Public Delegate Sub CanvasPostPaintWiresEventHandler ( _
    sender As GH_Canvas _
)

Parameters

sender
Type: Grasshopper.GUI.Canvas..::..GH_Canvas

See Also

Grasshopper.GUI.Canvas Namespace


GH_Canvas.CanvasPrePaintGroupsEventHandler Delegate

[image]

Grasshopper SDK
GH_Canvas..::..CanvasPrePaintGroupsEventHandler Delegate
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void CanvasPrePaintGroupsEventHandler(
    GH_Canvas sender
)
Visual Basic
Public Delegate Sub CanvasPrePaintGroupsEventHandler ( _
    sender As GH_Canvas _
)

Parameters

sender
Type: Grasshopper.GUI.Canvas..::..GH_Canvas

See Also

Grasshopper.GUI.Canvas Namespace


GH_Canvas.CanvasPrePaintObjectsEventHandler Delegate

[image]

Grasshopper SDK
GH_Canvas..::..CanvasPrePaintObjectsEventHandler Delegate
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void CanvasPrePaintObjectsEventHandler(
    GH_Canvas sender
)
Visual Basic
Public Delegate Sub CanvasPrePaintObjectsEventHandler ( _
    sender As GH_Canvas _
)

Parameters

sender
Type: Grasshopper.GUI.Canvas..::..GH_Canvas

See Also

Grasshopper.GUI.Canvas Namespace


GH_Canvas.CanvasPrePaintOverlayEventHandler Delegate

[image]

Grasshopper SDK
GH_Canvas..::..CanvasPrePaintOverlayEventHandler Delegate
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void CanvasPrePaintOverlayEventHandler(
    GH_Canvas sender
)
Visual Basic
Public Delegate Sub CanvasPrePaintOverlayEventHandler ( _
    sender As GH_Canvas _
)

Parameters

sender
Type: Grasshopper.GUI.Canvas..::..GH_Canvas

See Also

Grasshopper.GUI.Canvas Namespace


GH_Canvas.CanvasPrePaintWidgetsEventHandler Delegate

[image]

Grasshopper SDK
GH_Canvas..::..CanvasPrePaintWidgetsEventHandler Delegate
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void CanvasPrePaintWidgetsEventHandler(
    GH_Canvas sender
)
Visual Basic
Public Delegate Sub CanvasPrePaintWidgetsEventHandler ( _
    sender As GH_Canvas _
)

Parameters

sender
Type: Grasshopper.GUI.Canvas..::..GH_Canvas

See Also

Grasshopper.GUI.Canvas Namespace


GH_Canvas.CanvasPrePaintWiresEventHandler Delegate

[image]

Grasshopper SDK
GH_Canvas..::..CanvasPrePaintWiresEventHandler Delegate
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void CanvasPrePaintWiresEventHandler(
    GH_Canvas sender
)
Visual Basic
Public Delegate Sub CanvasPrePaintWiresEventHandler ( _
    sender As GH_Canvas _
)

Parameters

sender
Type: Grasshopper.GUI.Canvas..::..GH_Canvas

See Also

Grasshopper.GUI.Canvas Namespace


GH_Canvas.Document_ModifiedChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_Canvas..::..Document_ModifiedChangedEventHandler Delegate
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void Document_ModifiedChangedEventHandler(
    GH_Document sender,
    GH_DocModifiedEventArgs e
)
Visual Basic
Public Delegate Sub Document_ModifiedChangedEventHandler ( _
    sender As GH_Document, _
    e As GH_DocModifiedEventArgs _
)

Parameters

sender
Type: Grasshopper.Kernel..::..GH_Document
e
Type: Grasshopper.Kernel..::..GH_DocModifiedEventArgs

See Also

Grasshopper.GUI.Canvas Namespace


GH_Canvas.Document_ObjectsAddedEventHandler Delegate

[image]

Grasshopper SDK
GH_Canvas..::..Document_ObjectsAddedEventHandler Delegate
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void Document_ObjectsAddedEventHandler(
    GH_Document sender,
    GH_DocObjectEventArgs e
)
Visual Basic
Public Delegate Sub Document_ObjectsAddedEventHandler ( _
    sender As GH_Document, _
    e As GH_DocObjectEventArgs _
)

Parameters

sender
Type: Grasshopper.Kernel..::..GH_Document
e
Type: Grasshopper.Kernel..::..GH_DocObjectEventArgs

See Also

Grasshopper.GUI.Canvas Namespace


GH_Canvas.Document_ObjectsDeletedEventHandler Delegate

[image]

Grasshopper SDK
GH_Canvas..::..Document_ObjectsDeletedEventHandler Delegate
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void Document_ObjectsDeletedEventHandler(
    GH_Document sender,
    GH_DocObjectEventArgs e
)
Visual Basic
Public Delegate Sub Document_ObjectsDeletedEventHandler ( _
    sender As GH_Document, _
    e As GH_DocObjectEventArgs _
)

Parameters

sender
Type: Grasshopper.Kernel..::..GH_Document
e
Type: Grasshopper.Kernel..::..GH_DocObjectEventArgs

See Also

Grasshopper.GUI.Canvas Namespace


GH_Canvas.Document_SettingsChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_Canvas..::..Document_SettingsChangedEventHandler Delegate
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void Document_SettingsChangedEventHandler(
    GH_Document sender,
    GH_DocSettingsEventArgs e
)
Visual Basic
Public Delegate Sub Document_SettingsChangedEventHandler ( _
    sender As GH_Document, _
    e As GH_DocSettingsEventArgs _
)

Parameters

sender
Type: Grasshopper.Kernel..::..GH_Document
e
Type: Grasshopper.Kernel..::..GH_DocSettingsEventArgs

See Also

Grasshopper.GUI.Canvas Namespace


GH_Canvas.DocumentChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_Canvas..::..DocumentChangedEventHandler Delegate
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void DocumentChangedEventHandler(
    GH_Canvas sender,
    GH_CanvasDocumentChangedEventArgs e
)
Visual Basic
Public Delegate Sub DocumentChangedEventHandler ( _
    sender As GH_Canvas, _
    e As GH_CanvasDocumentChangedEventArgs _
)

Parameters

sender
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
e
Type: Grasshopper.GUI.Canvas..::..GH_CanvasDocumentChangedEventArgs

See Also

Grasshopper.GUI.Canvas Namespace


GH_Canvas.DocumentObjectMouseDownEventHandler Delegate

[image]

Grasshopper SDK
GH_Canvas..::..DocumentObjectMouseDownEventHandler Delegate
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void DocumentObjectMouseDownEventHandler(
    Object sender,
    GH_CanvasObjectMouseDownEventArgs e
)
Visual Basic
Public Delegate Sub DocumentObjectMouseDownEventHandler ( _
    sender As Object, _
    e As GH_CanvasObjectMouseDownEventArgs _
)

Parameters

sender
Type: System..::..Object
e
Type: Grasshopper.GUI..::..GH_CanvasObjectMouseDownEventArgs

See Also

Grasshopper.GUI.Canvas Namespace


GH_Canvas.DocumentObjectsDeletedEventHandler Delegate

[image]

Grasshopper SDK
GH_Canvas..::..DocumentObjectsDeletedEventHandler Delegate
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void DocumentObjectsDeletedEventHandler(
    GH_Document sender,
    GH_DocObjectEventArgs e
)
Visual Basic
Public Delegate Sub DocumentObjectsDeletedEventHandler ( _
    sender As GH_Document, _
    e As GH_DocObjectEventArgs _
)

Parameters

sender
Type: Grasshopper.Kernel..::..GH_Document
e
Type: Grasshopper.Kernel..::..GH_DocObjectEventArgs

See Also

Grasshopper.GUI.Canvas Namespace


GH_Canvas.GH_ImageSettings Class

[image]

Grasshopper SDK
GH_Canvas..::..GH_ImageSettings Class
GH_Canvas Class Members See Also Send Feedback
Settings class for high-resolution image output.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_ImageSettings
Visual Basic
Public Class GH_ImageSettings

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI.Canvas..::..GH_Canvas..::..GH_ImageSettings

See Also

GH_Canvas..::..GH_ImageSettings Members
Grasshopper.GUI.Canvas Namespace


GH_Canvas.GH_ImageSettings Members

[image] [image]

Grasshopper SDK
GH_Canvas..::..GH_ImageSettings Members
GH_Canvas..::..GH_ImageSettings Class Constructors Properties See Also Send Feedback

The GH_Canvas is the control that handles all mouse and paint events for a single loaded document.

The GH_Canvas..::..GH_ImageSettings type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Canvas..::..GH_ImageSettings()()()() | Create a new instance of the GH_ImageSettings class with default values.
Public method | GH_Canvas..::..GH_ImageSettings(String) | Create a new instance of the GH_ImageSettings class.
Public method | GH_Canvas..::..GH_ImageSettings(String, String, String) | Create a new instance of the GH_ImageSettings class.

Properties

 | Name | Description
Public property | BackColour | Gets or sets the background colour to use for the high-resolution rendering.
Public property | Extension | Gets or sets the image extension of the target image.
Public property | FileName | Gets or sets the filename of the target image.
Public property | Folder | Gets or sets the folder in which the target image will be saved.
 | TileSize | Gets the default tile size for high-resolution export. This is a constant value.
Public property | Zoom | Gets or sets the zoom at which to export the high-resolution image.

See Also

GH_Canvas..::..GH_ImageSettings Class
Grasshopper.GUI.Canvas Namespace


GH_Canvas.GH_ImageSettings Constructor

[image] [image]

Grasshopper SDK
GH_Canvas..::..GH_ImageSettings Constructor
GH_Canvas..::..GH_ImageSettings Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Canvas..::..GH_ImageSettings()()()() | Create a new instance of the GH_ImageSettings class with default values.
Public method | GH_Canvas..::..GH_ImageSettings(String) | Create a new instance of the GH_ImageSettings class.
Public method | GH_Canvas..::..GH_ImageSettings(String, String, String) | Create a new instance of the GH_ImageSettings class.

See Also

GH_Canvas..::..GH_ImageSettings Class
GH_Canvas..::..GH_ImageSettings Members
Grasshopper.GUI.Canvas Namespace


GH_Canvas.GH_ImageSettings Constructor

[image]

Grasshopper SDK
GH_Canvas..::..GH_ImageSettings Constructor
GH_Canvas..::..GH_ImageSettings Class See Also Send Feedback
Create a new instance of the GH_ImageSettings class with default values.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ImageSettings()
Visual Basic
Public Sub New

See Also

GH_Canvas..::..GH_ImageSettings Class
GH_Canvas..::..GH_ImageSettings Overload
Grasshopper.GUI.Canvas Namespace


GH_Canvas.GH_ImageSettings Constructor (String)

[image]

Grasshopper SDK
GH_Canvas..::..GH_ImageSettings Constructor (String)
GH_Canvas..::..GH_ImageSettings Class See Also Send Feedback
Create a new instance of the GH_ImageSettings class.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ImageSettings(
    string filePath
)
Visual Basic
Public Sub New ( _
    filePath As String _
)

Parameters

filePath
Type: System..::..String
Target location for image.

See Also

GH_Canvas..::..GH_ImageSettings Class
GH_Canvas..::..GH_ImageSettings Overload
Grasshopper.GUI.Canvas Namespace


GH_Canvas.GH_ImageSettings Constructor (String, String, String)

[image]

Grasshopper SDK
GH_Canvas..::..GH_ImageSettings Constructor (String, String, String)
GH_Canvas..::..GH_ImageSettings Class See Also Send Feedback
Create a new instance of the GH_ImageSettings class.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ImageSettings(
    string folder,
    string filename,
    string extension
)
Visual Basic
Public Sub New ( _
    folder As String, _
    filename As String, _
    extension As String _
)

Parameters

folder
Type: System..::..String
Folder for target image.
filename
Type: System..::..String
File name of target image.
extension
Type: System..::..String
Image extension for target image.

See Also

GH_Canvas..::..GH_ImageSettings Class
GH_Canvas..::..GH_ImageSettings Overload
Grasshopper.GUI.Canvas Namespace


GH_Canvas.GH_ImageSettings Properties

[image] [image]

Grasshopper SDK
GH_Canvas..::..GH_ImageSettings Properties
GH_Canvas..::..GH_ImageSettings Class See Also Send Feedback

The GH_Canvas..::..GH_ImageSettings type exposes the following members.

Properties

 | Name | Description
Public property | BackColour | Gets or sets the background colour to use for the high-resolution rendering.
Public property | Extension | Gets or sets the image extension of the target image.
Public property | FileName | Gets or sets the filename of the target image.
Public property | Folder | Gets or sets the folder in which the target image will be saved.
 | TileSize | Gets the default tile size for high-resolution export. This is a constant value.
Public property | Zoom | Gets or sets the zoom at which to export the high-resolution image.

See Also

GH_Canvas..::..GH_ImageSettings Class
Grasshopper.GUI.Canvas Namespace


BackColour Property

[image]

Grasshopper SDK
GH_Canvas..::..GH_ImageSettings..::..BackColour Property
GH_Canvas..::..GH_ImageSettings Class See Also Send Feedback
Gets or sets the background colour to use for the high-resolution rendering.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color BackColour { get; set; }
Visual Basic
Public Property BackColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Canvas.GH_ImageSettings.BackColour"]

See Also

GH_Canvas..::..GH_ImageSettings Class
Grasshopper.GUI.Canvas Namespace


Extension Property

[image]

Grasshopper SDK
GH_Canvas..::..GH_ImageSettings..::..Extension Property
GH_Canvas..::..GH_ImageSettings Class See Also Send Feedback
Gets or sets the image extension of the target image.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Extension { get; set; }
Visual Basic
Public Property Extension As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Canvas.GH_ImageSettings.Extension"]

See Also

GH_Canvas..::..GH_ImageSettings Class
Grasshopper.GUI.Canvas Namespace


FileName Property

[image]

Grasshopper SDK
GH_Canvas..::..GH_ImageSettings..::..FileName Property
GH_Canvas..::..GH_ImageSettings Class See Also Send Feedback
Gets or sets the filename of the target image.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string FileName { get; set; }
Visual Basic
Public Property FileName As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Canvas.GH_ImageSettings.FileName"]

See Also

GH_Canvas..::..GH_ImageSettings Class
Grasshopper.GUI.Canvas Namespace


Folder Property

[image]

Grasshopper SDK
GH_Canvas..::..GH_ImageSettings..::..Folder Property
GH_Canvas..::..GH_ImageSettings Class See Also Send Feedback
Gets or sets the folder in which the target image will be saved.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Folder { get; set; }
Visual Basic
Public Property Folder As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Canvas.GH_ImageSettings.Folder"]

See Also

GH_Canvas..::..GH_ImageSettings Class
Grasshopper.GUI.Canvas Namespace


TileSize Property

[image]

Grasshopper SDK
GH_Canvas..::..GH_ImageSettings..::..TileSize Property
GH_Canvas..::..GH_ImageSettings Class See Also Send Feedback
Gets the default tile size for high-resolution export. This is a constant value.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Size TileSize { get; }
Visual Basic
Public Shared ReadOnly Property TileSize As Size
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Canvas.GH_ImageSettings.TileSize"]

See Also

GH_Canvas..::..GH_ImageSettings Class
Grasshopper.GUI.Canvas Namespace


Zoom Property

[image]

Grasshopper SDK
GH_Canvas..::..GH_ImageSettings..::..Zoom Property
GH_Canvas..::..GH_ImageSettings Class See Also Send Feedback
Gets or sets the zoom at which to export the high-resolution image.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public float Zoom { get; set; }
Visual Basic
Public Property Zoom As Single
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Canvas.GH_ImageSettings.Zoom"]

See Also

GH_Canvas..::..GH_ImageSettings Class
Grasshopper.GUI.Canvas Namespace


GH_Canvas.ModifiersChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_Canvas..::..ModifiersChangedEventHandler Delegate
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void ModifiersChangedEventHandler(
    Object sender,
    EventArgs e
)
Visual Basic
Public Delegate Sub ModifiersChangedEventHandler ( _
    sender As Object, _
    e As EventArgs _
)

Parameters

sender
Type: System..::..Object
e
Type: System..::..EventArgs

See Also

Grasshopper.GUI.Canvas Namespace


GH_Canvas.NavigationSettingsChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_Canvas..::..NavigationSettingsChangedEventHandler Delegate
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void NavigationSettingsChangedEventHandler()
Visual Basic
Public Delegate Sub NavigationSettingsChangedEventHandler

See Also

Grasshopper.GUI.Canvas Namespace


GH_Canvas.ViewportChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_Canvas..::..ViewportChangedEventHandler Delegate
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void ViewportChangedEventHandler(
    Object sender,
    GH_CanvasViewportChangedEventArgs e
)
Visual Basic
Public Delegate Sub ViewportChangedEventHandler ( _
    sender As Object, _
    e As GH_CanvasViewportChangedEventArgs _
)

Parameters

sender
Type: System..::..Object
e
Type: Grasshopper.GUI.Canvas..::..GH_CanvasViewportChangedEventArgs

See Also

Grasshopper.GUI.Canvas Namespace


GH_Canvas.WidgetListCreatedEventHandler Delegate

[image]

Grasshopper SDK
GH_Canvas..::..WidgetListCreatedEventHandler Delegate
GH_Canvas Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void WidgetListCreatedEventHandler(
    Object sender,
    GH_CanvasWidgetListEventArgs e
)
Visual Basic
Public Delegate Sub WidgetListCreatedEventHandler ( _
    sender As Object, _
    e As GH_CanvasWidgetListEventArgs _
)

Parameters

sender
Type: System..::..Object
e
Type: Grasshopper.GUI.Canvas..::..GH_CanvasWidgetListEventArgs

See Also

Grasshopper.GUI.Canvas Namespace


GH_CanvasChannel Enumeration

[image]

Grasshopper SDK
GH_CanvasChannel Enumeration
See Also Send Feedback
Enumerates all the drawing channels that are handled inside the Grasshopper canvas.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_CanvasChannel
Visual Basic
Public Enumeration GH_CanvasChannel

Members

Member name | Value | Description
First | 0 | First channel. At present, the first channel equals the Groups channel.
Groups | 0 | Channel for Group outlines and name tags.
Wires | 10 | Channel for connecting wires.
Objects | 20 | Channels for Document Objects (components, parameters, special objects)
Overlay | 30 | Channel for drawing overlay geometry.
Last | 30 | Last channel. At present, the last channel equals the Overlay channel.

See Also

Grasshopper.GUI.Canvas Namespace


GH_CanvasDocumentChangedEventArgs Class

[image]

Grasshopper SDK
GH_CanvasDocumentChangedEventArgs Class
Members See Also Send Feedback
These arguments are used in the DocumentChanged event on GH_Canvas.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_CanvasDocumentChangedEventArgs : EventArgs
Visual Basic
Public Class GH_CanvasDocumentChangedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Grasshopper.GUI.Canvas..::..GH_CanvasDocumentChangedEventArgs

See Also

GH_CanvasDocumentChangedEventArgs Members
Grasshopper.GUI.Canvas Namespace


GH_CanvasDocumentChangedEventArgs Members

[image] [image]

Grasshopper SDK
GH_CanvasDocumentChangedEventArgs Members
GH_CanvasDocumentChangedEventArgs Class Constructors Properties See Also Send Feedback

The GH_CanvasDocumentChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GH_CanvasDocumentChangedEventArgs | Initializes a new instance of the GH_CanvasDocumentChangedEventArgs class

Properties

 | Name | Description
Public property | NewDocument | Gets the document which has just been loaded into the canvas.
Public property | OldDocument | Gets the document which was previously loaded into the canvas.

See Also

GH_CanvasDocumentChangedEventArgs Class
Grasshopper.GUI.Canvas Namespace


GH_CanvasDocumentChangedEventArgs Constructor

[image]

Grasshopper SDK
GH_CanvasDocumentChangedEventArgs Constructor
GH_CanvasDocumentChangedEventArgs Class See Also Send Feedback
Initializes a new instance of the GH_CanvasDocumentChangedEventArgs class

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_CanvasDocumentChangedEventArgs(
    GH_Document newDoc,
    GH_Document oldDoc
)
Visual Basic
Public Sub New ( _
    newDoc As GH_Document, _
    oldDoc As GH_Document _
)

Parameters

newDoc
Type: Grasshopper.Kernel..::..GH_Document
oldDoc
Type: Grasshopper.Kernel..::..GH_Document

See Also

GH_CanvasDocumentChangedEventArgs Class
Grasshopper.GUI.Canvas Namespace


GH_CanvasDocumentChangedEventArgs Properties

[image] [image]

Grasshopper SDK
GH_CanvasDocumentChangedEventArgs Properties
GH_CanvasDocumentChangedEventArgs Class See Also Send Feedback

The GH_CanvasDocumentChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | NewDocument | Gets the document which has just been loaded into the canvas.
Public property | OldDocument | Gets the document which was previously loaded into the canvas.

See Also

GH_CanvasDocumentChangedEventArgs Class
Grasshopper.GUI.Canvas Namespace


NewDocument Property

[image]

Grasshopper SDK
GH_CanvasDocumentChangedEventArgs..::..NewDocument Property
GH_CanvasDocumentChangedEventArgs Class See Also Send Feedback
Gets the document which has just been loaded into the canvas.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Document NewDocument { get; }
Visual Basic
Public ReadOnly Property NewDocument As GH_Document
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_CanvasDocumentChangedEventArgs.NewDocument"]

See Also

GH_CanvasDocumentChangedEventArgs Class
Grasshopper.GUI.Canvas Namespace


OldDocument Property

[image]

Grasshopper SDK
GH_CanvasDocumentChangedEventArgs..::..OldDocument Property
GH_CanvasDocumentChangedEventArgs Class See Also Send Feedback
Gets the document which was previously loaded into the canvas.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Document OldDocument { get; }
Visual Basic
Public ReadOnly Property OldDocument As GH_Document
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_CanvasDocumentChangedEventArgs.OldDocument"]

See Also

GH_CanvasDocumentChangedEventArgs Class
Grasshopper.GUI.Canvas Namespace


GH_CanvasMode Enumeration

[image]

Grasshopper SDK
GH_CanvasMode Enumeration
See Also Send Feedback
Enumerates all pre-defined Canvas modes.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_CanvasMode
Visual Basic
Public Enumeration GH_CanvasMode

Members

Member name | Value | Description
Control | 0 | Indicates the canvas is currently drawing into the winforms control. This is the most common mode.
Thumbnail | 1 | Indicates the canvas is currently drawing itself to a thumbnail image.
Export | 2 | Indicates the canvas is currently drawing itself to an off-screen image. This typically happens during Hi-Res export operations.

See Also

Grasshopper.GUI.Canvas Namespace


GH_CanvasNavigation Enumeration

[image]

Grasshopper SDK
GH_CanvasNavigation Enumeration
See Also Send Feedback
Enumerates all possible canvas navigations.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_CanvasNavigation
Visual Basic
Public Enumeration GH_CanvasNavigation

Members

Member name | Value | Description
None | 0 |
PanLeft | 1 |
PanRight | 2 |
PanUp | 3 |
PanDown | 4 |
ZoomIn | 5 |
ZoomOut | 6 |

See Also

Grasshopper.GUI.Canvas Namespace


GH_CanvasViewportChangedEventArgs Class

[image]

Grasshopper SDK
GH_CanvasViewportChangedEventArgs Class
Members See Also Send Feedback
These arguments are used in the ViewportChanged event on GH_Canvas.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_CanvasViewportChangedEventArgs : EventArgs
Visual Basic
Public Class GH_CanvasViewportChangedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Grasshopper.GUI.Canvas..::..GH_CanvasViewportChangedEventArgs

See Also

GH_CanvasViewportChangedEventArgs Members
Grasshopper.GUI.Canvas Namespace


GH_CanvasViewportChangedEventArgs Members

[image] [image]

Grasshopper SDK
GH_CanvasViewportChangedEventArgs Members
GH_CanvasViewportChangedEventArgs Class Properties See Also Send Feedback

The GH_CanvasViewportChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Canvas | Gets the Canvas whose viewport was changed.
Public property | Viewport | Gets the new Viewport.

See Also

GH_CanvasViewportChangedEventArgs Class
Grasshopper.GUI.Canvas Namespace


GH_CanvasViewportChangedEventArgs Properties

[image] [image]

Grasshopper SDK
GH_CanvasViewportChangedEventArgs Properties
GH_CanvasViewportChangedEventArgs Class See Also Send Feedback

The GH_CanvasViewportChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Canvas | Gets the Canvas whose viewport was changed.
Public property | Viewport | Gets the new Viewport.

See Also

GH_CanvasViewportChangedEventArgs Class
Grasshopper.GUI.Canvas Namespace


Canvas Property

[image]

Grasshopper SDK
GH_CanvasViewportChangedEventArgs..::..Canvas Property
GH_CanvasViewportChangedEventArgs Class See Also Send Feedback
Gets the Canvas whose viewport was changed.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Canvas Canvas { get; }
Visual Basic
Public ReadOnly Property Canvas As GH_Canvas
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_CanvasViewportChangedEventArgs.Canvas"]

See Also

GH_CanvasViewportChangedEventArgs Class
Grasshopper.GUI.Canvas Namespace


Viewport Property

[image]

Grasshopper SDK
GH_CanvasViewportChangedEventArgs..::..Viewport Property
GH_CanvasViewportChangedEventArgs Class See Also Send Feedback
Gets the new Viewport.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Viewport Viewport { get; }
Visual Basic
Public ReadOnly Property Viewport As GH_Viewport
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_CanvasViewportChangedEventArgs.Viewport"]

See Also

GH_CanvasViewportChangedEventArgs Class
Grasshopper.GUI.Canvas Namespace


GH_CanvasWidgetListEventArgs Class

[image]

Grasshopper SDK
GH_CanvasWidgetListEventArgs Class
Members See Also Send Feedback
The event arguments are used in the WidgetListCreated event.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_CanvasWidgetListEventArgs : EventArgs
Visual Basic
Public Class GH_CanvasWidgetListEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Grasshopper.GUI.Canvas..::..GH_CanvasWidgetListEventArgs

See Also

GH_CanvasWidgetListEventArgs Members
Grasshopper.GUI.Canvas Namespace


GH_CanvasWidgetListEventArgs Members

[image] [image]

Grasshopper SDK
GH_CanvasWidgetListEventArgs Members
GH_CanvasWidgetListEventArgs Class Methods See Also Send Feedback

The GH_CanvasWidgetListEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | AddWidget | Append a widget to the canvas.

See Also

GH_CanvasWidgetListEventArgs Class
Grasshopper.GUI.Canvas Namespace


GH_CanvasWidgetListEventArgs Methods

[image] [image]

Grasshopper SDK
GH_CanvasWidgetListEventArgs Methods
GH_CanvasWidgetListEventArgs Class See Also Send Feedback

The GH_CanvasWidgetListEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | AddWidget | Append a widget to the canvas.

See Also

GH_CanvasWidgetListEventArgs Class
Grasshopper.GUI.Canvas Namespace


AddWidget Method

[image]

Grasshopper SDK
GH_CanvasWidgetListEventArgs..::..AddWidget Method
GH_CanvasWidgetListEventArgs Class See Also Send Feedback
Append a widget to the canvas.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddWidget(
    IGH_Widget widget
)
Visual Basic
Public Sub AddWidget ( _
    widget As IGH_Widget _
)

Parameters

widget
Type: IGH_Widget
Widget to append.

See Also

GH_CanvasWidgetListEventArgs Class
Grasshopper.GUI.Canvas Namespace


GH_Capsule Class

[image]

Grasshopper SDK
GH_Capsule Class
Members See Also Send Feedback
Class used to draw standard Grasshopper interface boxes.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Capsule : IDisposable
Visual Basic
Public Class GH_Capsule _
    Implements IDisposable

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI.Canvas..::..GH_Capsule

See Also

GH_Capsule Members
Grasshopper.GUI.Canvas Namespace


GH_Capsule Members

[image] [image]

Grasshopper SDK
GH_Capsule Members
GH_Capsule Class Methods Fields Properties See Also Send Feedback

The GH_Capsule type exposes the following members.

Methods

 | Name | Description
Public method | AddInputGrip(Point) | Add an input grip to this UI Box.
Public method | AddInputGrip(PointF) | Add an input grip to this UI Box.
Public method | AddInputGrip(Single) | Add an input grip to this UI Box. This is the recommended overload.
Public method | AddInputGrip(Single, Single) | Add an input grip to this UI Box.
Public method | AddOutputGrip(Point) | Add an output grip to this UI Box.
Public method | AddOutputGrip(PointF) | Add an output grip to this UI Box.
Public method | AddOutputGrip(Single) | Add an output grip to this UI Box. This is the recommended overload.
Public method | AddOutputGrip(Single, Single) | Add an output grip to this UI Box.
Public method | Contains | Test a point for capsule containment.
 | CreateCapsule(Rectangle, GH_Palette) | Create a new blank capsule with default radius and highlight dimensions.
 | CreateCapsule(RectangleF, GH_Palette) | Create a new blank capsule with default radius and highlight dimensions.
 | CreateCapsule(Rectangle, GH_Palette, Int32, Int32) | Create a new blank capsule.
 | CreateCapsule(Rectangle, GH_Palette, array<Int32>[]()[][], Int32) | Create a new blank capsule.
 | CreateCapsule(RectangleF, GH_Palette, Int32, Int32) | Create a new blank capsule.
 | CreateCapsule(RectangleF, GH_Palette, array<Int32>[]()[][], Int32) | Create a new blank capsule.
 | CreateTextCapsule(Rectangle, Rectangle, GH_Palette, String) | Create a new capsule with content text.
 | CreateTextCapsule(RectangleF, RectangleF, GH_Palette, String) | Create a new capsule with content text.
 | CreateTextCapsule(Rectangle, Rectangle, GH_Palette, String, Font) | Create a new capsule with content text.
 | CreateTextCapsule(RectangleF, RectangleF, GH_Palette, String, Font) | Create a new capsule with content text.
 | CreateTextCapsule(Rectangle, Rectangle, GH_Palette, String, Font, GH_Orientation) | Create a new capsule with content text.
 | CreateTextCapsule(Rectangle, Rectangle, GH_Palette, String, Int32, Int32) | Create a new capsule with content text.
 | CreateTextCapsule(Rectangle, Rectangle, GH_Palette, String, array<Int32>[]()[][], Int32) | Create a new capsule with content text.
 | CreateTextCapsule(RectangleF, RectangleF, GH_Palette, String, Font, GH_Orientation) | Create a new capsule with content text.
 | CreateTextCapsule(RectangleF, RectangleF, GH_Palette, String, Int32, Int32) | Create a new capsule with content text.
 | CreateTextCapsule(RectangleF, RectangleF, GH_Palette, String, array<Int32>[]()[][], Int32) | Create a new capsule with content text.
 | CreateTextCapsule(Rectangle, Rectangle, GH_Palette, String, Font, Int32, Int32) | Create a new capsule with content text.
 | CreateTextCapsule(Rectangle, Rectangle, GH_Palette, String, Font, array<Int32>[]()[][], Int32) | Create a new capsule with content text.
 | CreateTextCapsule(RectangleF, RectangleF, GH_Palette, String, Font, Int32, Int32) | Create a new capsule with content text.
 | CreateTextCapsule(RectangleF, RectangleF, GH_Palette, String, Font, array<Int32>[]()[][], Int32) | Create a new capsule with content text.
 | CreateTextCapsule(Rectangle, Rectangle, GH_Palette, String, Font, GH_Orientation, Int32, Int32) | Create a new capsule with content text.
 | CreateTextCapsule(Rectangle, Rectangle, GH_Palette, String, Font, GH_Orientation, array<Int32>[]()[][], Int32) | Create a new capsule with content text.
 | CreateTextCapsule(RectangleF, RectangleF, GH_Palette, String, Font, GH_Orientation, Int32, Int32) | Create a new capsule with content text.
 | CreateTextCapsule(RectangleF, RectangleF, GH_Palette, String, Font, GH_Orientation, array<Int32>[]()[][], Int32) | Create a new capsule with content text.
Public method | Dispose()()()() | Releases all resources used by the GH_Capsule
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the GH_Capsule and optionally releases the managed resources
Public method | Render(Graphics, GH_PaletteStyle) | Have this capsule draw itself onto a Graphics surface with a custom Style override.
Public method | Render(Graphics, Color) | Have this capsule draw itself onto a Graphics surface with a custom colour override.
Public method | Render(Graphics, Image, GH_PaletteStyle) | Have this capsule draw itself onto a Graphics surface with a custom Style override.
Public method | Render(Graphics, Image, Color) | Have this capsule draw itself onto a Graphics surface with a custom colour override.
Public method | Render(Graphics, Boolean, Boolean, Boolean) | Render the capsule onto a graphics context.
Public method | Render(Graphics, Image, Boolean, Boolean, Boolean) | Render the capsule onto a graphics context.
Public method | SetJaggedEdges | Assign left and right jagged edges.

Fields

Name | Description
DefaultHighlight | The default size (in pixel units) of the highlight bar.
DefaultRadius | The default radius (in pixel units) of the rounded corners.

Properties

 | Name | Description
Public property | Box | Gets the outline box for this Capsule.
Public property | Box_Content | Gets the content box for this Capsule. Text and icons are drawn inside this box.
Public property | Font | Gets or sets the Font to use for text rendering.
Public property | Highlight | Gets the highlight size for this Capsule. Zero or negative means there is no highlight.
Public property | HighlightShape | Gets the graphics path that describes the highlight bar shape of the capsule.
Public property | InputGrips | Gets the list of locally defined input grip locations.
Public property | JaggedLeft | Gets whether the left edge of this capsule is jagged.
Public property | JaggedRight | Gets whether the right edge of this capsule is jagged.
Public property | MaxRadius | Gets the largest radius defined for this capsule.
Public property | OutlineShape | Gets the graphics path that describes the outer edge of the capsule.
Public property | OutputGrips | Gets the list of locally defined output grip locations.
Public property | Palette | Gets or sets the palette for this Capsule.
Public property | Radius | Gets the radius of the rounded corners of this Capsule.
Public property | RenderEngine | Gets the RenderEngine associated with this capsule. You typically don't need to go this far, just use one of the Render() overloads on GH_Capsule directly.
Public property | Text | Gets or sets the text to render in the content box.
Public property | TextOrientation | Gets or sets the orientation of the text within the content box.

See Also

GH_Capsule Class
Grasshopper.GUI.Canvas Namespace


GH_Capsule Fields

[image] [image]

Grasshopper SDK
GH_Capsule Fields
GH_Capsule Class See Also Send Feedback

The GH_Capsule type exposes the following members.

Fields

Name | Description
DefaultHighlight | The default size (in pixel units) of the highlight bar.
DefaultRadius | The default radius (in pixel units) of the rounded corners.

See Also

GH_Capsule Class
Grasshopper.GUI.Canvas Namespace


DefaultHighlight Field

[image]

Grasshopper SDK
GH_Capsule..::..DefaultHighlight Field
GH_Capsule Class See Also Send Feedback
The default size (in pixel units) of the highlight bar.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const int DefaultHighlight
Visual Basic
Public Const DefaultHighlight As Integer

See Also

GH_Capsule Class
Grasshopper.GUI.Canvas Namespace


DefaultRadius Field

[image]

Grasshopper SDK
GH_Capsule..::..DefaultRadius Field
GH_Capsule Class See Also Send Feedback
The default radius (in pixel units) of the rounded corners.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const int DefaultRadius
Visual Basic
Public Const DefaultRadius As Integer

See Also

GH_Capsule Class
Grasshopper.GUI.Canvas Namespace


GH_Capsule Methods

[image] [image]

Grasshopper SDK
GH_Capsule Methods
GH_Capsule Class See Also Send Feedback

The GH_Capsule type exposes the following members.

Methods

 | Name | Description
Public method | AddInputGrip(Point) | Add an input grip to this UI Box.
Public method | AddInputGrip(PointF) | Add an input grip to this UI Box.
Public method | AddInputGrip(Single) | Add an input grip to this UI Box. This is the recommended overload.
Public method | AddInputGrip(Single, Single) | Add an input grip to this UI Box.
Public method | AddOutputGrip(Point) | Add an output grip to this UI Box.
Public method | AddOutputGrip(PointF) | Add an output grip to this UI Box.
Public method | AddOutputGrip(Single) | Add an output grip to this UI Box. This is the recommended overload.
Public method | AddOutputGrip(Single, Single) | Add an output grip to this UI Box.
Public method | Contains | Test a point for capsule containment.
 | CreateCapsule(Rectangle, GH_Palette) | Create a new blank capsule with default radius and highlight dimensions.
 | CreateCapsule(RectangleF, GH_Palette) | Create a new blank capsule with default radius and highlight dimensions.
 | CreateCapsule(Rectangle, GH_Palette, Int32, Int32) | Create a new blank capsule.
 | CreateCapsule(Rectangle, GH_Palette, array<Int32>[]()[][], Int32) | Create a new blank capsule.
 | CreateCapsule(RectangleF, GH_Palette, Int32, Int32) | Create a new blank capsule.
 | CreateCapsule(RectangleF, GH_Palette, array<Int32>[]()[][], Int32) | Create a new blank capsule.
 | CreateTextCapsule(Rectangle, Rectangle, GH_Palette, String) | Create a new capsule with content text.
 | CreateTextCapsule(RectangleF, RectangleF, GH_Palette, String) | Create a new capsule with content text.
 | CreateTextCapsule(Rectangle, Rectangle, GH_Palette, String, Font) | Create a new capsule with content text.
 | CreateTextCapsule(RectangleF, RectangleF, GH_Palette, String, Font) | Create a new capsule with content text.
 | CreateTextCapsule(Rectangle, Rectangle, GH_Palette, String, Font, GH_Orientation) | Create a new capsule with content text.
 | CreateTextCapsule(Rectangle, Rectangle, GH_Palette, String, Int32, Int32) | Create a new capsule with content text.
 | CreateTextCapsule(Rectangle, Rectangle, GH_Palette, String, array<Int32>[]()[][], Int32) | Create a new capsule with content text.
 | CreateTextCapsule(RectangleF, RectangleF, GH_Palette, String, Font, GH_Orientation) | Create a new capsule with content text.
 | CreateTextCapsule(RectangleF, RectangleF, GH_Palette, String, Int32, Int32) | Create a new capsule with content text.
 | CreateTextCapsule(RectangleF, RectangleF, GH_Palette, String, array<Int32>[]()[][], Int32) | Create a new capsule with content text.
 | CreateTextCapsule(Rectangle, Rectangle, GH_Palette, String, Font, Int32, Int32) | Create a new capsule with content text.
 | CreateTextCapsule(Rectangle, Rectangle, GH_Palette, String, Font, array<Int32>[]()[][], Int32) | Create a new capsule with content text.
 | CreateTextCapsule(RectangleF, RectangleF, GH_Palette, String, Font, Int32, Int32) | Create a new capsule with content text.
 | CreateTextCapsule(RectangleF, RectangleF, GH_Palette, String, Font, array<Int32>[]()[][], Int32) | Create a new capsule with content text.
 | CreateTextCapsule(Rectangle, Rectangle, GH_Palette, String, Font, GH_Orientation, Int32, Int32) | Create a new capsule with content text.
 | CreateTextCapsule(Rectangle, Rectangle, GH_Palette, String, Font, GH_Orientation, array<Int32>[]()[][], Int32) | Create a new capsule with content text.
 | CreateTextCapsule(RectangleF, RectangleF, GH_Palette, String, Font, GH_Orientation, Int32, Int32) | Create a new capsule with content text.
 | CreateTextCapsule(RectangleF, RectangleF, GH_Palette, String, Font, GH_Orientation, array<Int32>[]()[][], Int32) | Create a new capsule with content text.
Public method | Dispose()()()() |
Protected method | Dispose(Boolean) |
Public method | Render(Graphics, GH_PaletteStyle) | Have this capsule draw itself onto a Graphics surface with a custom Style override.
Public method | Render(Graphics, Color) | Have this capsule draw itself onto a Graphics surface with a custom colour override.
Public method | Render(Graphics, Image, GH_PaletteStyle) | Have this capsule draw itself onto a Graphics surface with a custom Style override.
Public method | Render(Graphics, Image, Color) | Have this capsule draw itself onto a Graphics surface with a custom colour override.
Public method | Render(Graphics, Boolean, Boolean, Boolean) | Render the capsule onto a graphics context.
Public method | Render(Graphics, Image, Boolean, Boolean, Boolean) | Render the capsule onto a graphics context.
Public method | SetJaggedEdges | Assign left and right jagged edges.

See Also

GH_Capsule Class
Grasshopper.GUI.Canvas Namespace


AddInputGrip Method

[image] [image]

Grasshopper SDK
GH_Capsule..::..AddInputGrip Method
GH_Capsule Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddInputGrip(Point) | Add an input grip to this UI Box.
Public method | AddInputGrip(PointF) | Add an input grip to this UI Box.
Public method | AddInputGrip(Single) | Add an input grip to this UI Box. This is the recommended overload.
Public method | AddInputGrip(Single, Single) | Add an input grip to this UI Box.

See Also

GH_Capsule Class
GH_Capsule Members
Grasshopper.GUI.Canvas Namespace


AddInputGrip Method (Point)

[image]

Grasshopper SDK
GH_Capsule..::..AddInputGrip Method (Point)
GH_Capsule Class See Also Send Feedback
Add an input grip to this UI Box.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddInputGrip(
    Point P
)
Visual Basic
Public Sub AddInputGrip ( _
    P As Point _
)

Parameters

P
Type: System.Drawing..::..Point
Coordinate of grip.

See Also

GH_Capsule Class
AddInputGrip Overload
Grasshopper.GUI.Canvas Namespace


AddInputGrip Method (PointF)

[image]

Grasshopper SDK
GH_Capsule..::..AddInputGrip Method (PointF)
GH_Capsule Class See Also Send Feedback
Add an input grip to this UI Box.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddInputGrip(
    PointF P
)
Visual Basic
Public Sub AddInputGrip ( _
    P As PointF _
)

Parameters

P
Type: System.Drawing..::..PointF
Coordinate of grip.

See Also

GH_Capsule Class
AddInputGrip Overload
Grasshopper.GUI.Canvas Namespace


AddInputGrip Method (Single)

[image]

Grasshopper SDK
GH_Capsule..::..AddInputGrip Method (Single)
GH_Capsule Class See Also Send Feedback
Add an input grip to this UI Box. This is the recommended overload.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddInputGrip(
    float Y
)
Visual Basic
Public Sub AddInputGrip ( _
    Y As Single _
)

Parameters

Y
Type: System..::..Single
Y coordinate of grip.

See Also

GH_Capsule Class
AddInputGrip Overload
Grasshopper.GUI.Canvas Namespace


AddInputGrip Method (Single, Single)

[image]

Grasshopper SDK
GH_Capsule..::..AddInputGrip Method (Single, Single)
GH_Capsule Class See Also Send Feedback
Add an input grip to this UI Box.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddInputGrip(
    float X,
    float Y
)
Visual Basic
Public Sub AddInputGrip ( _
    X As Single, _
    Y As Single _
)

Parameters

X
Type: System..::..Single
X coordinate of grip.
Y
Type: System..::..Single
Y coordinate of grip.

See Also

GH_Capsule Class
AddInputGrip Overload
Grasshopper.GUI.Canvas Namespace


AddOutputGrip Method

[image] [image]

Grasshopper SDK
GH_Capsule..::..AddOutputGrip Method
GH_Capsule Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddOutputGrip(Point) | Add an output grip to this UI Box.
Public method | AddOutputGrip(PointF) | Add an output grip to this UI Box.
Public method | AddOutputGrip(Single) | Add an output grip to this UI Box. This is the recommended overload.
Public method | AddOutputGrip(Single, Single) | Add an output grip to this UI Box.

See Also

GH_Capsule Class
GH_Capsule Members
Grasshopper.GUI.Canvas Namespace


AddOutputGrip Method (Point)

[image]

Grasshopper SDK
GH_Capsule..::..AddOutputGrip Method (Point)
GH_Capsule Class See Also Send Feedback
Add an output grip to this UI Box.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddOutputGrip(
    Point P
)
Visual Basic
Public Sub AddOutputGrip ( _
    P As Point _
)

Parameters

P
Type: System.Drawing..::..Point
Coordinate of grip.

See Also

GH_Capsule Class
AddOutputGrip Overload
Grasshopper.GUI.Canvas Namespace


AddOutputGrip Method (PointF)

[image]

Grasshopper SDK
GH_Capsule..::..AddOutputGrip Method (PointF)
GH_Capsule Class See Also Send Feedback
Add an output grip to this UI Box.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddOutputGrip(
    PointF P
)
Visual Basic
Public Sub AddOutputGrip ( _
    P As PointF _
)

Parameters

P
Type: System.Drawing..::..PointF
Coordinate of grip.

See Also

GH_Capsule Class
AddOutputGrip Overload
Grasshopper.GUI.Canvas Namespace


AddOutputGrip Method (Single)

[image]

Grasshopper SDK
GH_Capsule..::..AddOutputGrip Method (Single)
GH_Capsule Class See Also Send Feedback
Add an output grip to this UI Box. This is the recommended overload.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddOutputGrip(
    float Y
)
Visual Basic
Public Sub AddOutputGrip ( _
    Y As Single _
)

Parameters

Y
Type: System..::..Single
Y coordinate of grip.

See Also

GH_Capsule Class
AddOutputGrip Overload
Grasshopper.GUI.Canvas Namespace


AddOutputGrip Method (Single, Single)

[image]

Grasshopper SDK
GH_Capsule..::..AddOutputGrip Method (Single, Single)
GH_Capsule Class See Also Send Feedback
Add an output grip to this UI Box.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddOutputGrip(
    float X,
    float Y
)
Visual Basic
Public Sub AddOutputGrip ( _
    X As Single, _
    Y As Single _
)

Parameters

X
Type: System..::..Single
X coordinate of grip.
Y
Type: System..::..Single
Y coordinate of grip.

See Also

GH_Capsule Class
AddOutputGrip Overload
Grasshopper.GUI.Canvas Namespace


Contains Method

[image]

Grasshopper SDK
GH_Capsule..::..Contains Method
GH_Capsule Class See Also Send Feedback
Test a point for capsule containment.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Contains(
    PointF pt
)
Visual Basic
Public Function Contains ( _
    pt As PointF _
) As Boolean

Parameters

pt
Type: System.Drawing..::..PointF
Point to test.

Return Value

True if the point is on the interior of the capsule.

See Also

GH_Capsule Class
Grasshopper.GUI.Canvas Namespace


CreateCapsule Method

[image] [image]

Grasshopper SDK
GH_Capsule..::..CreateCapsule Method
GH_Capsule Class See Also Send Feedback

Overload List

Name | Description
CreateCapsule(Rectangle, GH_Palette) | Create a new blank capsule with default radius and highlight dimensions.
CreateCapsule(RectangleF, GH_Palette) | Create a new blank capsule with default radius and highlight dimensions.
CreateCapsule(Rectangle, GH_Palette, Int32, Int32) | Create a new blank capsule.
CreateCapsule(Rectangle, GH_Palette, array<Int32>[]()[][], Int32) | Create a new blank capsule.
CreateCapsule(RectangleF, GH_Palette, Int32, Int32) | Create a new blank capsule.
CreateCapsule(RectangleF, GH_Palette, array<Int32>[]()[][], Int32) | Create a new blank capsule.

See Also

GH_Capsule Class
GH_Capsule Members
Grasshopper.GUI.Canvas Namespace


CreateCapsule Method (Rectangle, GH_Palette)

[image]

Grasshopper SDK
GH_Capsule..::..CreateCapsule Method (Rectangle, GH_Palette)
GH_Capsule Class See Also Send Feedback
Create a new blank capsule with default radius and highlight dimensions.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Capsule CreateCapsule(
    Rectangle box,
    GH_Palette palette
)
Visual Basic
Public Shared Function CreateCapsule ( _
    box As Rectangle, _
    palette As GH_Palette _
) As GH_Capsule

Parameters

box
Type: System.Drawing..::..Rectangle
Box for capsule dimensions. The box will be grown until it is at least 3 pixels wide and high.
palette
Type: Grasshopper.GUI.Canvas..::..GH_Palette
Colour palette to apply.

Return Value

A new instance of GH_Capsule. Caller is responsible for disposing of the object.

See Also

GH_Capsule Class
CreateCapsule Overload
Grasshopper.GUI.Canvas Namespace


CreateCapsule Method (RectangleF, GH_Palette)

[image]

Grasshopper SDK
GH_Capsule..::..CreateCapsule Method (RectangleF, GH_Palette)
GH_Capsule Class See Also Send Feedback
Create a new blank capsule with default radius and highlight dimensions.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Capsule CreateCapsule(
    RectangleF box,
    GH_Palette palette
)
Visual Basic
Public Shared Function CreateCapsule ( _
    box As RectangleF, _
    palette As GH_Palette _
) As GH_Capsule

Parameters

box
Type: System.Drawing..::..RectangleF
Box for capsule dimensions. The box will be grown until it is at least 3 pixels wide and high.
palette
Type: Grasshopper.GUI.Canvas..::..GH_Palette
Colour palette to apply.

Return Value

A new instance of GH_Capsule. Caller is responsible for disposing of the object.

See Also

GH_Capsule Class
CreateCapsule Overload
Grasshopper.GUI.Canvas Namespace


CreateCapsule Method (Rectangle, GH_Palette, Int32, Int32)

[image]

Grasshopper SDK
GH_Capsule..::..CreateCapsule Method (Rectangle, GH_Palette, Int32, Int32)
GH_Capsule Class See Also Send Feedback
Create a new blank capsule.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Capsule CreateCapsule(
    Rectangle box,
    GH_Palette palette,
    int radius,
    int highlight
)
Visual Basic
Public Shared Function CreateCapsule ( _
    box As Rectangle, _
    palette As GH_Palette, _
    radius As Integer, _
    highlight As Integer _
) As GH_Capsule

Parameters

box
Type: System.Drawing..::..Rectangle
Box for capsule dimensions. The box will be grown until it is at least 3 pixels wide and high.
palette
Type: Grasshopper.GUI.Canvas..::..GH_Palette
Colour palette to apply.
radius
Type: System..::..Int32
Radius of rounded corners. A radius of zero or lower disables corner fillets.
highlight
Type: System..::..Int32
Height of the highlight bar. A value of zero or lower disables the highlight.

Return Value

A new instance of GH_Capsule. Caller is responsible for disposing of the object.

See Also

GH_Capsule Class
CreateCapsule Overload
Grasshopper.GUI.Canvas Namespace


CreateCapsule Method (Rectangle, GH_Palette, Int32[], Int32)

[image]

Grasshopper SDK
GH_Capsule..::..CreateCapsule Method (Rectangle, GH_Palette, array<Int32>[]()[][], Int32)
GH_Capsule Class See Also Send Feedback
Create a new blank capsule.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Capsule CreateCapsule(
    Rectangle box,
    GH_Palette palette,
    int[] radii,
    int highlight
)
Visual Basic
Public Shared Function CreateCapsule ( _
    box As Rectangle, _
    palette As GH_Palette, _
    radii As Integer(), _
    highlight As Integer _
) As GH_Capsule

Parameters

box
Type: System.Drawing..::..Rectangle
Box for capsule dimensions. The box will be grown until it is at least 3 pixels wide and high.
palette
Type: Grasshopper.GUI.Canvas..::..GH_Palette
Colour palette to apply.
radii
Type: array< System..::..Int32 >[]()[][]
Radii of rounded corners. This array must contain at least 4 integers. Radii are defined clockwise, starting at the upper left corner.
highlight
Type: System..::..Int32
Height of the highlight bar. A value of zero or lower disables the highlight.

Return Value

A new instance of GH_Capsule. Caller is responsible for disposing of the object.

See Also

GH_Capsule Class
CreateCapsule Overload
Grasshopper.GUI.Canvas Namespace


CreateCapsule Method (RectangleF, GH_Palette, Int32, Int32)

[image]

Grasshopper SDK
GH_Capsule..::..CreateCapsule Method (RectangleF, GH_Palette, Int32, Int32)
GH_Capsule Class See Also Send Feedback
Create a new blank capsule.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Capsule CreateCapsule(
    RectangleF box,
    GH_Palette palette,
    int radius,
    int highlight
)
Visual Basic
Public Shared Function CreateCapsule ( _
    box As RectangleF, _
    palette As GH_Palette, _
    radius As Integer, _
    highlight As Integer _
) As GH_Capsule

Parameters

box
Type: System.Drawing..::..RectangleF
Box for capsule dimensions. The box will be grown until it is at least 3 pixels wide and high.
palette
Type: Grasshopper.GUI.Canvas..::..GH_Palette
Colour palette to apply.
radius
Type: System..::..Int32
Radius of rounded corners. A radius of zero or lower disables corner fillets.
highlight
Type: System..::..Int32
Height of the highlight bar. A value of zero or lower disables the highlight.

Return Value

A new instance of GH_Capsule. Caller is responsible for disposing of the object.

See Also

GH_Capsule Class
CreateCapsule Overload
Grasshopper.GUI.Canvas Namespace


CreateCapsule Method (RectangleF, GH_Palette, Int32[], Int32)

[image]

Grasshopper SDK
GH_Capsule..::..CreateCapsule Method (RectangleF, GH_Palette, array<Int32>[]()[][], Int32)
GH_Capsule Class See Also Send Feedback
Create a new blank capsule.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Capsule CreateCapsule(
    RectangleF box,
    GH_Palette palette,
    int[] radii,
    int highlight
)
Visual Basic
Public Shared Function CreateCapsule ( _
    box As RectangleF, _
    palette As GH_Palette, _
    radii As Integer(), _
    highlight As Integer _
) As GH_Capsule

Parameters

box
Type: System.Drawing..::..RectangleF
Box for capsule dimensions. The box will be grown until it is at least 3 pixels wide and high.
palette
Type: Grasshopper.GUI.Canvas..::..GH_Palette
Colour palette to apply.
radii
Type: array< System..::..Int32 >[]()[][]
Radii of rounded corners. This array must contain at least 4 integers. Radii are defined clockwise, starting at the upper left corner.
highlight
Type: System..::..Int32
Height of the highlight bar. A value of zero or lower disables the highlight.

Return Value

A new instance of GH_Capsule. Caller is responsible for disposing of the object.

See Also

GH_Capsule Class
CreateCapsule Overload
Grasshopper.GUI.Canvas Namespace


CreateTextCapsule Method

[image] [image]

Grasshopper SDK
GH_Capsule..::..CreateTextCapsule Method
GH_Capsule Class See Also Send Feedback

Overload List

Name | Description
CreateTextCapsule(Rectangle, Rectangle, GH_Palette, String) | Create a new capsule with content text.
CreateTextCapsule(RectangleF, RectangleF, GH_Palette, String) | Create a new capsule with content text.
CreateTextCapsule(Rectangle, Rectangle, GH_Palette, String, Font) | Create a new capsule with content text.
CreateTextCapsule(RectangleF, RectangleF, GH_Palette, String, Font) | Create a new capsule with content text.
CreateTextCapsule(Rectangle, Rectangle, GH_Palette, String, Font, GH_Orientation) | Create a new capsule with content text.
CreateTextCapsule(Rectangle, Rectangle, GH_Palette, String, Int32, Int32) | Create a new capsule with content text.
CreateTextCapsule(Rectangle, Rectangle, GH_Palette, String, array<Int32>[]()[][], Int32) | Create a new capsule with content text.
CreateTextCapsule(RectangleF, RectangleF, GH_Palette, String, Font, GH_Orientation) | Create a new capsule with content text.
CreateTextCapsule(RectangleF, RectangleF, GH_Palette, String, Int32, Int32) | Create a new capsule with content text.
CreateTextCapsule(RectangleF, RectangleF, GH_Palette, String, array<Int32>[]()[][], Int32) | Create a new capsule with content text.
CreateTextCapsule(Rectangle, Rectangle, GH_Palette, String, Font, Int32, Int32) | Create a new capsule with content text.
CreateTextCapsule(Rectangle, Rectangle, GH_Palette, String, Font, array<Int32>[]()[][], Int32) | Create a new capsule with content text.
CreateTextCapsule(RectangleF, RectangleF, GH_Palette, String, Font, Int32, Int32) | Create a new capsule with content text.
CreateTextCapsule(RectangleF, RectangleF, GH_Palette, String, Font, array<Int32>[]()[][], Int32) | Create a new capsule with content text.
CreateTextCapsule(Rectangle, Rectangle, GH_Palette, String, Font, GH_Orientation, Int32, Int32) | Create a new capsule with content text.
CreateTextCapsule(Rectangle, Rectangle, GH_Palette, String, Font, GH_Orientation, array<Int32>[]()[][], Int32) | Create a new capsule with content text.
CreateTextCapsule(RectangleF, RectangleF, GH_Palette, String, Font, GH_Orientation, Int32, Int32) | Create a new capsule with content text.
CreateTextCapsule(RectangleF, RectangleF, GH_Palette, String, Font, GH_Orientation, array<Int32>[]()[][], Int32) | Create a new capsule with content text.

See Also

GH_Capsule Class
GH_Capsule Members
Grasshopper.GUI.Canvas Namespace


CreateTextCapsule Method (Rectangle, Rectangle, GH_Palette, String)

[image]

Grasshopper SDK
GH_Capsule..::..CreateTextCapsule Method (Rectangle, Rectangle, GH_Palette, String)
GH_Capsule Class See Also Send Feedback
Create a new capsule with content text.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Capsule CreateTextCapsule(
    Rectangle box,
    Rectangle textbox,
    GH_Palette palette,
    string text
)
Visual Basic
Public Shared Function CreateTextCapsule ( _
    box As Rectangle, _
    textbox As Rectangle, _
    palette As GH_Palette, _
    text As String _
) As GH_Capsule

Parameters

box
Type: System.Drawing..::..Rectangle
Box for capsule dimensions. The box will be grown until it is at least 3 pixels wide and high.
textbox
Type: System.Drawing..::..Rectangle
Box into which the text will be drawn.
palette
Type: Grasshopper.GUI.Canvas..::..GH_Palette
Colour palette to apply.
text
Type: System..::..String
Text to display inside the capsule.

Return Value

A new instance of GH_Capsule. Caller is responsible for disposing of the object.

See Also

GH_Capsule Class
CreateTextCapsule Overload
Grasshopper.GUI.Canvas Namespace


CreateTextCapsule Method (RectangleF, RectangleF, GH_Palette, String)

[image]

Grasshopper SDK
GH_Capsule..::..CreateTextCapsule Method (RectangleF, RectangleF, GH_Palette, String)
GH_Capsule Class See Also Send Feedback
Create a new capsule with content text.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Capsule CreateTextCapsule(
    RectangleF box,
    RectangleF textbox,
    GH_Palette palette,
    string text
)
Visual Basic
Public Shared Function CreateTextCapsule ( _
    box As RectangleF, _
    textbox As RectangleF, _
    palette As GH_Palette, _
    text As String _
) As GH_Capsule

Parameters

box
Type: System.Drawing..::..RectangleF
Box for capsule dimensions. The box will be grown until it is at least 3 pixels wide and high.
textbox
Type: System.Drawing..::..RectangleF
Box into which the text will be drawn.
palette
Type: Grasshopper.GUI.Canvas..::..GH_Palette
Colour palette to apply.
text
Type: System..::..String
Text to display inside the capsule.

Return Value

A new instance of GH_Capsule. Caller is responsible for disposing of the object.

See Also

GH_Capsule Class
CreateTextCapsule Overload
Grasshopper.GUI.Canvas Namespace


CreateTextCapsule Method (Rectangle, Rectangle, GH_Palette, String, Font)

[image]

Grasshopper SDK
GH_Capsule..::..CreateTextCapsule Method (Rectangle, Rectangle, GH_Palette, String, Font)
GH_Capsule Class See Also Send Feedback
Create a new capsule with content text.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Capsule CreateTextCapsule(
    Rectangle box,
    Rectangle textbox,
    GH_Palette palette,
    string text,
    Font font
)
Visual Basic
Public Shared Function CreateTextCapsule ( _
    box As Rectangle, _
    textbox As Rectangle, _
    palette As GH_Palette, _
    text As String, _
    font As Font _
) As GH_Capsule

Parameters

box
Type: System.Drawing..::..Rectangle
Box for capsule dimensions. The box will be grown until it is at least 3 pixels wide and high.
textbox
Type: System.Drawing..::..Rectangle
Box into which the text will be drawn.
palette
Type: Grasshopper.GUI.Canvas..::..GH_Palette
Colour palette to apply.
text
Type: System..::..String
Text to display inside the capsule.
font
Type: System.Drawing..::..Font
Font to draw text with.

Return Value

A new instance of GH_Capsule. Caller is responsible for disposing of the object.

See Also

GH_Capsule Class
CreateTextCapsule Overload
Grasshopper.GUI.Canvas Namespace


CreateTextCapsule Method (RectangleF, RectangleF, GH_Palette, String, Font)

[image]

Grasshopper SDK
GH_Capsule..::..CreateTextCapsule Method (RectangleF, RectangleF, GH_Palette, String, Font)
GH_Capsule Class See Also Send Feedback
Create a new capsule with content text.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Capsule CreateTextCapsule(
    RectangleF box,
    RectangleF textbox,
    GH_Palette palette,
    string text,
    Font font
)
Visual Basic
Public Shared Function CreateTextCapsule ( _
    box As RectangleF, _
    textbox As RectangleF, _
    palette As GH_Palette, _
    text As String, _
    font As Font _
) As GH_Capsule

Parameters

box
Type: System.Drawing..::..RectangleF
Box for capsule dimensions. The box will be grown until it is at least 3 pixels wide and high.
textbox
Type: System.Drawing..::..RectangleF
Box into which the text will be drawn.
palette
Type: Grasshopper.GUI.Canvas..::..GH_Palette
Colour palette to apply.
text
Type: System..::..String
Text to display inside the capsule.
font
Type: System.Drawing..::..Font
Font to draw text with.

Return Value

A new instance of GH_Capsule. Caller is responsible for disposing of the object.

See Also

GH_Capsule Class
CreateTextCapsule Overload
Grasshopper.GUI.Canvas Namespace


CreateTextCapsule Method (Rectangle, Rectangle, GH_Palette, String, Font, GH_Orientation)

[image]

Grasshopper SDK
GH_Capsule..::..CreateTextCapsule Method (Rectangle, Rectangle, GH_Palette, String, Font, GH_Orientation)
GH_Capsule Class See Also Send Feedback
Create a new capsule with content text.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Capsule CreateTextCapsule(
    Rectangle box,
    Rectangle textbox,
    GH_Palette palette,
    string text,
    Font font,
    GH_Orientation orientation
)
Visual Basic
Public Shared Function CreateTextCapsule ( _
    box As Rectangle, _
    textbox As Rectangle, _
    palette As GH_Palette, _
    text As String, _
    font As Font, _
    orientation As GH_Orientation _
) As GH_Capsule

Parameters

box
Type: System.Drawing..::..Rectangle
Box for capsule dimensions. The box will be grown until it is at least 3 pixels wide and high.
textbox
Type: System.Drawing..::..Rectangle
Box into which the text will be drawn.
palette
Type: Grasshopper.GUI.Canvas..::..GH_Palette
Colour palette to apply.
text
Type: System..::..String
Text to display inside the capsule.
font
Type: System.Drawing..::..Font
Font to draw text with.
orientation
Type: Grasshopper.GUI.Canvas..::..GH_Orientation
Orientation of text within box.

Return Value

A new instance of GH_Capsule. Caller is responsible for disposing of the object.

See Also

GH_Capsule Class
CreateTextCapsule Overload
Grasshopper.GUI.Canvas Namespace


CreateTextCapsule Method (Rectangle, Rectangle, GH_Palette, String, Int32, Int32)

[image]

Grasshopper SDK
GH_Capsule..::..CreateTextCapsule Method (Rectangle, Rectangle, GH_Palette, String, Int32, Int32)
GH_Capsule Class See Also Send Feedback
Create a new capsule with content text.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Capsule CreateTextCapsule(
    Rectangle box,
    Rectangle textbox,
    GH_Palette palette,
    string text,
    int radius,
    int highlight
)
Visual Basic
Public Shared Function CreateTextCapsule ( _
    box As Rectangle, _
    textbox As Rectangle, _
    palette As GH_Palette, _
    text As String, _
    radius As Integer, _
    highlight As Integer _
) As GH_Capsule

Parameters

box
Type: System.Drawing..::..Rectangle
Box for capsule dimensions. The box will be grown until it is at least 3 pixels wide and high.
textbox
Type: System.Drawing..::..Rectangle
Box into which the text will be drawn.
palette
Type: Grasshopper.GUI.Canvas..::..GH_Palette
Colour palette to apply.
text
Type: System..::..String
Text to display inside the capsule.
radius
Type: System..::..Int32
Radius of rounded corners. A radius of zero or lower disables corner fillets.
highlight
Type: System..::..Int32
Height of the highlight bar. A value of zero or lower disables the highlight.

Return Value

A new instance of GH_Capsule. Caller is responsible for disposing of the object.

See Also

GH_Capsule Class
CreateTextCapsule Overload
Grasshopper.GUI.Canvas Namespace


CreateTextCapsule Method (Rectangle, Rectangle, GH_Palette, String, Int32[], Int32)

[image]

Grasshopper SDK
GH_Capsule..::..CreateTextCapsule Method (Rectangle, Rectangle, GH_Palette, String, array<Int32>[]()[][], Int32)
GH_Capsule Class See Also Send Feedback
Create a new capsule with content text.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Capsule CreateTextCapsule(
    Rectangle box,
    Rectangle textbox,
    GH_Palette palette,
    string text,
    int[] radii,
    int highlight
)
Visual Basic
Public Shared Function CreateTextCapsule ( _
    box As Rectangle, _
    textbox As Rectangle, _
    palette As GH_Palette, _
    text As String, _
    radii As Integer(), _
    highlight As Integer _
) As GH_Capsule

Parameters

box
Type: System.Drawing..::..Rectangle
Box for capsule dimensions. The box will be grown until it is at least 3 pixels wide and high.
textbox
Type: System.Drawing..::..Rectangle
Box into which the text will be drawn.
palette
Type: Grasshopper.GUI.Canvas..::..GH_Palette
Colour palette to apply.
text
Type: System..::..String
Text to display inside the capsule.
radii
Type: array< System..::..Int32 >[]()[][]
Radii of rounded corners. This array must contain at least 4 integers. Radii are defined clockwise, starting at the upper left corner.
highlight
Type: System..::..Int32
Height of the highlight bar. A value of zero or lower disables the highlight.

Return Value

A new instance of GH_Capsule. Caller is responsible for disposing of the object.

See Also

GH_Capsule Class
CreateTextCapsule Overload
Grasshopper.GUI.Canvas Namespace


CreateTextCapsule Method (RectangleF, RectangleF, GH_Palette, String, Font, GH_Orientation)

[image]

Grasshopper SDK
GH_Capsule..::..CreateTextCapsule Method (RectangleF, RectangleF, GH_Palette, String, Font, GH_Orientation)
GH_Capsule Class See Also Send Feedback
Create a new capsule with content text.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Capsule CreateTextCapsule(
    RectangleF box,
    RectangleF textbox,
    GH_Palette palette,
    string text,
    Font font,
    GH_Orientation orientation
)
Visual Basic
Public Shared Function CreateTextCapsule ( _
    box As RectangleF, _
    textbox As RectangleF, _
    palette As GH_Palette, _
    text As String, _
    font As Font, _
    orientation As GH_Orientation _
) As GH_Capsule

Parameters

box
Type: System.Drawing..::..RectangleF
Box for capsule dimensions. The box will be grown until it is at least 3 pixels wide and high.
textbox
Type: System.Drawing..::..RectangleF
Box into which the text will be drawn.
palette
Type: Grasshopper.GUI.Canvas..::..GH_Palette
Colour palette to apply.
text
Type: System..::..String
Text to display inside the capsule.
font
Type: System.Drawing..::..Font
Font to draw text with.
orientation
Type: Grasshopper.GUI.Canvas..::..GH_Orientation
Orientation of text within box.

Return Value

A new instance of GH_Capsule. Caller is responsible for disposing of the object.

See Also

GH_Capsule Class
CreateTextCapsule Overload
Grasshopper.GUI.Canvas Namespace


CreateTextCapsule Method (RectangleF, RectangleF, GH_Palette, String, Int32, Int32)

[image]

Grasshopper SDK
GH_Capsule..::..CreateTextCapsule Method (RectangleF, RectangleF, GH_Palette, String, Int32, Int32)
GH_Capsule Class See Also Send Feedback
Create a new capsule with content text.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Capsule CreateTextCapsule(
    RectangleF box,
    RectangleF textbox,
    GH_Palette palette,
    string text,
    int radius,
    int highlight
)
Visual Basic
Public Shared Function CreateTextCapsule ( _
    box As RectangleF, _
    textbox As RectangleF, _
    palette As GH_Palette, _
    text As String, _
    radius As Integer, _
    highlight As Integer _
) As GH_Capsule

Parameters

box
Type: System.Drawing..::..RectangleF
Box for capsule dimensions. The box will be grown until it is at least 3 pixels wide and high.
textbox
Type: System.Drawing..::..RectangleF
Box into which the text will be drawn.
palette
Type: Grasshopper.GUI.Canvas..::..GH_Palette
Colour palette to apply.
text
Type: System..::..String
Text to display inside the capsule.
radius
Type: System..::..Int32
Radius of rounded corners. A radius of zero or lower disables corner fillets.
highlight
Type: System..::..Int32
Height of the highlight bar. A value of zero or lower disables the highlight.

Return Value

A new instance of GH_Capsule. Caller is responsible for disposing of the object.

See Also

GH_Capsule Class
CreateTextCapsule Overload
Grasshopper.GUI.Canvas Namespace


CreateTextCapsule Method (RectangleF, RectangleF, GH_Palette, String, Int32[], Int32)

[image]

Grasshopper SDK
GH_Capsule..::..CreateTextCapsule Method (RectangleF, RectangleF, GH_Palette, String, array<Int32>[]()[][], Int32)
GH_Capsule Class See Also Send Feedback
Create a new capsule with content text.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Capsule CreateTextCapsule(
    RectangleF box,
    RectangleF textbox,
    GH_Palette palette,
    string text,
    int[] radii,
    int highlight
)
Visual Basic
Public Shared Function CreateTextCapsule ( _
    box As RectangleF, _
    textbox As RectangleF, _
    palette As GH_Palette, _
    text As String, _
    radii As Integer(), _
    highlight As Integer _
) As GH_Capsule

Parameters

box
Type: System.Drawing..::..RectangleF
Box for capsule dimensions. The box will be grown until it is at least 3 pixels wide and high.
textbox
Type: System.Drawing..::..RectangleF
Box into which the text will be drawn.
palette
Type: Grasshopper.GUI.Canvas..::..GH_Palette
Colour palette to apply.
text
Type: System..::..String
Text to display inside the capsule.
radii
Type: array< System..::..Int32 >[]()[][]
Radii of rounded corners. This array must contain at least 4 integers. Radii are defined clockwise, starting at the upper left corner.
highlight
Type: System..::..Int32
Height of the highlight bar. A value of zero or lower disables the highlight.

Return Value

A new instance of GH_Capsule. Caller is responsible for disposing of the object.

See Also

GH_Capsule Class
CreateTextCapsule Overload
Grasshopper.GUI.Canvas Namespace


CreateTextCapsule Method (Rectangle, Rectangle, GH_Palette, String, Font, Int32, Int32)

[image]

Grasshopper SDK
GH_Capsule..::..CreateTextCapsule Method (Rectangle, Rectangle, GH_Palette, String, Font, Int32, Int32)
GH_Capsule Class See Also Send Feedback
Create a new capsule with content text.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Capsule CreateTextCapsule(
    Rectangle box,
    Rectangle textbox,
    GH_Palette palette,
    string text,
    Font font,
    int radius,
    int highlight
)
Visual Basic
Public Shared Function CreateTextCapsule ( _
    box As Rectangle, _
    textbox As Rectangle, _
    palette As GH_Palette, _
    text As String, _
    font As Font, _
    radius As Integer, _
    highlight As Integer _
) As GH_Capsule

Parameters

box
Type: System.Drawing..::..Rectangle
Box for capsule dimensions. The box will be grown until it is at least 3 pixels wide and high.
textbox
Type: System.Drawing..::..Rectangle
Box into which the text will be drawn.
palette
Type: Grasshopper.GUI.Canvas..::..GH_Palette
Colour palette to apply.
text
Type: System..::..String
Text to display inside the capsule.
font
Type: System.Drawing..::..Font
Font to draw text with.
radius
Type: System..::..Int32
Radius of rounded corners. A radius of zero or lower disables corner fillets.
highlight
Type: System..::..Int32
Height of the highlight bar. A value of zero or lower disables the highlight.

Return Value

A new instance of GH_Capsule. Caller is responsible for disposing of the object.

See Also

GH_Capsule Class
CreateTextCapsule Overload
Grasshopper.GUI.Canvas Namespace


CreateTextCapsule Method (Rectangle, Rectangle, GH_Palette, String, Font, Int32[], Int32)

[image]

Grasshopper SDK
GH_Capsule..::..CreateTextCapsule Method (Rectangle, Rectangle, GH_Palette, String, Font, array<Int32>[]()[][], Int32)
GH_Capsule Class See Also Send Feedback
Create a new capsule with content text.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Capsule CreateTextCapsule(
    Rectangle box,
    Rectangle textbox,
    GH_Palette palette,
    string text,
    Font font,
    int[] radii,
    int highlight
)
Visual Basic
Public Shared Function CreateTextCapsule ( _
    box As Rectangle, _
    textbox As Rectangle, _
    palette As GH_Palette, _
    text As String, _
    font As Font, _
    radii As Integer(), _
    highlight As Integer _
) As GH_Capsule

Parameters

box
Type: System.Drawing..::..Rectangle
Box for capsule dimensions. The box will be grown until it is at least 3 pixels wide and high.
textbox
Type: System.Drawing..::..Rectangle
Box into which the text will be drawn.
palette
Type: Grasshopper.GUI.Canvas..::..GH_Palette
Colour palette to apply.
text
Type: System..::..String
Text to display inside the capsule.
font
Type: System.Drawing..::..Font
Font to draw text with.
radii
Type: array< System..::..Int32 >[]()[][]
Radii of rounded corners. This array must contain at least 4 integers. Radii are defined clockwise, starting at the upper left corner.
highlight
Type: System..::..Int32
Height of the highlight bar. A value of zero or lower disables the highlight.

Return Value

A new instance of GH_Capsule. Caller is responsible for disposing of the object.

See Also

GH_Capsule Class
CreateTextCapsule Overload
Grasshopper.GUI.Canvas Namespace


CreateTextCapsule Method (RectangleF, RectangleF, GH_Palette, String, Font, Int32, Int32)

[image]

Grasshopper SDK
GH_Capsule..::..CreateTextCapsule Method (RectangleF, RectangleF, GH_Palette, String, Font, Int32, Int32)
GH_Capsule Class See Also Send Feedback
Create a new capsule with content text.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Capsule CreateTextCapsule(
    RectangleF box,
    RectangleF textbox,
    GH_Palette palette,
    string text,
    Font font,
    int radius,
    int highlight
)
Visual Basic
Public Shared Function CreateTextCapsule ( _
    box As RectangleF, _
    textbox As RectangleF, _
    palette As GH_Palette, _
    text As String, _
    font As Font, _
    radius As Integer, _
    highlight As Integer _
) As GH_Capsule

Parameters

box
Type: System.Drawing..::..RectangleF
Box for capsule dimensions. The box will be grown until it is at least 3 pixels wide and high.
textbox
Type: System.Drawing..::..RectangleF
Box into which the text will be drawn.
palette
Type: Grasshopper.GUI.Canvas..::..GH_Palette
Colour palette to apply.
text
Type: System..::..String
Text to display inside the capsule.
font
Type: System.Drawing..::..Font
Font to draw text with.
radius
Type: System..::..Int32
Radius of rounded corners. A radius of zero or lower disables corner fillets.
highlight
Type: System..::..Int32
Height of the highlight bar. A value of zero or lower disables the highlight.

Return Value

A new instance of GH_Capsule. Caller is responsible for disposing of the object.

See Also

GH_Capsule Class
CreateTextCapsule Overload
Grasshopper.GUI.Canvas Namespace


CreateTextCapsule Method (RectangleF, RectangleF, GH_Palette, String, Font, Int32[], Int32)

[image]

Grasshopper SDK
GH_Capsule..::..CreateTextCapsule Method (RectangleF, RectangleF, GH_Palette, String, Font, array<Int32>[]()[][], Int32)
GH_Capsule Class See Also Send Feedback
Create a new capsule with content text.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Capsule CreateTextCapsule(
    RectangleF box,
    RectangleF textbox,
    GH_Palette palette,
    string text,
    Font font,
    int[] radii,
    int highlight
)
Visual Basic
Public Shared Function CreateTextCapsule ( _
    box As RectangleF, _
    textbox As RectangleF, _
    palette As GH_Palette, _
    text As String, _
    font As Font, _
    radii As Integer(), _
    highlight As Integer _
) As GH_Capsule

Parameters

box
Type: System.Drawing..::..RectangleF
Box for capsule dimensions. The box will be grown until it is at least 3 pixels wide and high.
textbox
Type: System.Drawing..::..RectangleF
Box into which the text will be drawn.
palette
Type: Grasshopper.GUI.Canvas..::..GH_Palette
Colour palette to apply.
text
Type: System..::..String
Text to display inside the capsule.
font
Type: System.Drawing..::..Font
Font to draw text with.
radii
Type: array< System..::..Int32 >[]()[][]
Radii of rounded corners. This array must contain at least 4 integers. Radii are defined clockwise, starting at the upper left corner.
highlight
Type: System..::..Int32
Height of the highlight bar. A value of zero or lower disables the highlight.

Return Value

A new instance of GH_Capsule. Caller is responsible for disposing of the object.

See Also

GH_Capsule Class
CreateTextCapsule Overload
Grasshopper.GUI.Canvas Namespace


CreateTextCapsule Method (Rectangle, Rectangle, GH_Palette, String, Font, GH_Orientation, Int32, Int32)

[image]

Grasshopper SDK
GH_Capsule..::..CreateTextCapsule Method (Rectangle, Rectangle, GH_Palette, String, Font, GH_Orientation, Int32, Int32)
GH_Capsule Class See Also Send Feedback
Create a new capsule with content text.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Capsule CreateTextCapsule(
    Rectangle box,
    Rectangle textbox,
    GH_Palette palette,
    string text,
    Font font,
    GH_Orientation orientation,
    int radius,
    int highlight
)
Visual Basic
Public Shared Function CreateTextCapsule ( _
    box As Rectangle, _
    textbox As Rectangle, _
    palette As GH_Palette, _
    text As String, _
    font As Font, _
    orientation As GH_Orientation, _
    radius As Integer, _
    highlight As Integer _
) As GH_Capsule

Parameters

box
Type: System.Drawing..::..Rectangle
Box for capsule dimensions. The box will be grown until it is at least 3 pixels wide and high.
textbox
Type: System.Drawing..::..Rectangle
Box into which the text will be drawn.
palette
Type: Grasshopper.GUI.Canvas..::..GH_Palette
Colour palette to apply.
text
Type: System..::..String
Text to display inside the capsule.
font
Type: System.Drawing..::..Font
Font to draw text with.
orientation
Type: Grasshopper.GUI.Canvas..::..GH_Orientation
Orientation of text within box.
radius
Type: System..::..Int32
Radius of rounded corners. A radius of zero or lower disables corner fillets.
highlight
Type: System..::..Int32
Height of the highlight bar. A value of zero or lower disables the highlight.

Return Value

A new instance of GH_Capsule. Caller is responsible for disposing of the object.

See Also

GH_Capsule Class
CreateTextCapsule Overload
Grasshopper.GUI.Canvas Namespace


CreateTextCapsule Method (Rectangle, Rectangle, GH_Palette, String, Font, GH_Orientation, Int32[], Int32)

[image]

Grasshopper SDK
GH_Capsule..::..CreateTextCapsule Method (Rectangle, Rectangle, GH_Palette, String, Font, GH_Orientation, array<Int32>[]()[][], Int32)
GH_Capsule Class See Also Send Feedback
Create a new capsule with content text.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Capsule CreateTextCapsule(
    Rectangle box,
    Rectangle textbox,
    GH_Palette palette,
    string text,
    Font font,
    GH_Orientation orientation,
    int[] radii,
    int highlight
)
Visual Basic
Public Shared Function CreateTextCapsule ( _
    box As Rectangle, _
    textbox As Rectangle, _
    palette As GH_Palette, _
    text As String, _
    font As Font, _
    orientation As GH_Orientation, _
    radii As Integer(), _
    highlight As Integer _
) As GH_Capsule

Parameters

box
Type: System.Drawing..::..Rectangle
Box for capsule dimensions. The box will be grown until it is at least 3 pixels wide and high.
textbox
Type: System.Drawing..::..Rectangle
Box into which the text will be drawn.
palette
Type: Grasshopper.GUI.Canvas..::..GH_Palette
Colour palette to apply.
text
Type: System..::..String
Text to display inside the capsule.
font
Type: System.Drawing..::..Font
Font to draw text with.
orientation
Type: Grasshopper.GUI.Canvas..::..GH_Orientation
Orientation of text within box.
radii
Type: array< System..::..Int32 >[]()[][]
Radii of rounded corners. This array must contain at least 4 integers. Radii are defined clockwise, starting at the upper left corner.
highlight
Type: System..::..Int32
Height of the highlight bar. A value of zero or lower disables the highlight.

Return Value

A new instance of GH_Capsule. Caller is responsible for disposing of the object.

See Also

GH_Capsule Class
CreateTextCapsule Overload
Grasshopper.GUI.Canvas Namespace


CreateTextCapsule Method (RectangleF, RectangleF, GH_Palette, String, Font, GH_Orientation, Int32, Int32)

[image]

Grasshopper SDK
GH_Capsule..::..CreateTextCapsule Method (RectangleF, RectangleF, GH_Palette, String, Font, GH_Orientation, Int32, Int32)
GH_Capsule Class See Also Send Feedback
Create a new capsule with content text.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Capsule CreateTextCapsule(
    RectangleF box,
    RectangleF textbox,
    GH_Palette palette,
    string text,
    Font font,
    GH_Orientation orientation,
    int radius,
    int highlight
)
Visual Basic
Public Shared Function CreateTextCapsule ( _
    box As RectangleF, _
    textbox As RectangleF, _
    palette As GH_Palette, _
    text As String, _
    font As Font, _
    orientation As GH_Orientation, _
    radius As Integer, _
    highlight As Integer _
) As GH_Capsule

Parameters

box
Type: System.Drawing..::..RectangleF
Box for capsule dimensions. The box will be grown until it is at least 3 pixels wide and high.
textbox
Type: System.Drawing..::..RectangleF
Box into which the text will be drawn.
palette
Type: Grasshopper.GUI.Canvas..::..GH_Palette
Colour palette to apply.
text
Type: System..::..String
Text to display inside the capsule.
font
Type: System.Drawing..::..Font
Font to draw text with.
orientation
Type: Grasshopper.GUI.Canvas..::..GH_Orientation
Orientation of text within box.
radius
Type: System..::..Int32
Radius of rounded corners. A radius of zero or lower disables corner fillets.
highlight
Type: System..::..Int32
Height of the highlight bar. A value of zero or lower disables the highlight.

Return Value

A new instance of GH_Capsule. Caller is responsible for disposing of the object.

See Also

GH_Capsule Class
CreateTextCapsule Overload
Grasshopper.GUI.Canvas Namespace


CreateTextCapsule Method (RectangleF, RectangleF, GH_Palette, String, Font, GH_Orientation, Int32[], Int32)

[image]

Grasshopper SDK
GH_Capsule..::..CreateTextCapsule Method (RectangleF, RectangleF, GH_Palette, String, Font, GH_Orientation, array<Int32>[]()[][], Int32)
GH_Capsule Class See Also Send Feedback
Create a new capsule with content text.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Capsule CreateTextCapsule(
    RectangleF box,
    RectangleF textbox,
    GH_Palette palette,
    string text,
    Font font,
    GH_Orientation orientation,
    int[] radii,
    int highlight
)
Visual Basic
Public Shared Function CreateTextCapsule ( _
    box As RectangleF, _
    textbox As RectangleF, _
    palette As GH_Palette, _
    text As String, _
    font As Font, _
    orientation As GH_Orientation, _
    radii As Integer(), _
    highlight As Integer _
) As GH_Capsule

Parameters

box
Type: System.Drawing..::..RectangleF
Box for capsule dimensions. The box will be grown until it is at least 3 pixels wide and high.
textbox
Type: System.Drawing..::..RectangleF
Box into which the text will be drawn.
palette
Type: Grasshopper.GUI.Canvas..::..GH_Palette
Colour palette to apply.
text
Type: System..::..String
Text to display inside the capsule.
font
Type: System.Drawing..::..Font
Font to draw text with.
orientation
Type: Grasshopper.GUI.Canvas..::..GH_Orientation
Orientation of text within box.
radii
Type: array< System..::..Int32 >[]()[][]
Radii of rounded corners. This array must contain at least 4 integers. Radii are defined clockwise, starting at the upper left corner.
highlight
Type: System..::..Int32
Height of the highlight bar. A value of zero or lower disables the highlight.

Return Value

A new instance of GH_Capsule. Caller is responsible for disposing of the object.

See Also

GH_Capsule Class
CreateTextCapsule Overload
Grasshopper.GUI.Canvas Namespace


Dispose Method

[image] [image]

Grasshopper SDK
GH_Capsule..::..Dispose Method
GH_Capsule Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the GH_Capsule
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the GH_Capsule and optionally releases the managed resources

See Also

GH_Capsule Class
GH_Capsule Members
Grasshopper.GUI.Canvas Namespace


Dispose Method

[image]

Grasshopper SDK
GH_Capsule..::..Dispose Method
GH_Capsule Class See Also Send Feedback
Releases all resources used by the GH_Capsule

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose

Implements

IDisposable..::..Dispose()()()()

See Also

GH_Capsule Class
Dispose Overload
Grasshopper.GUI.Canvas Namespace


Dispose Method (Boolean)

[image]

Grasshopper SDK
GH_Capsule..::..Dispose Method (Boolean)
GH_Capsule Class See Also Send Feedback
Releases the unmanaged resources used by the GH_Capsule and optionally releases the managed resources

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected virtual void Dispose(
    bool disposing
)
Visual Basic
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

GH_Capsule Class
Dispose Overload
Grasshopper.GUI.Canvas Namespace


Render Method

[image] [image]

Grasshopper SDK
GH_Capsule..::..Render Method
GH_Capsule Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Render(Graphics, GH_PaletteStyle) | Have this capsule draw itself onto a Graphics surface with a custom Style override.
Public method | Render(Graphics, Color) | Have this capsule draw itself onto a Graphics surface with a custom colour override.
Public method | Render(Graphics, Image, GH_PaletteStyle) | Have this capsule draw itself onto a Graphics surface with a custom Style override.
Public method | Render(Graphics, Image, Color) | Have this capsule draw itself onto a Graphics surface with a custom colour override.
Public method | Render(Graphics, Boolean, Boolean, Boolean) | Render the capsule onto a graphics context.
Public method | Render(Graphics, Image, Boolean, Boolean, Boolean) | Render the capsule onto a graphics context.

See Also

GH_Capsule Class
GH_Capsule Members
Grasshopper.GUI.Canvas Namespace


Render Method (Graphics, GH_PaletteStyle)

[image]

Grasshopper SDK
GH_Capsule..::..Render Method (Graphics, GH_PaletteStyle)
GH_Capsule Class See Also Send Feedback
Have this capsule draw itself onto a Graphics surface with a custom Style override.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Render(
    Graphics G,
    GH_PaletteStyle style
)
Visual Basic
Public Sub Render ( _
    G As Graphics, _
    style As GH_PaletteStyle _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with. Zoom factor is implied by the G.Transform property.
style
Type: Grasshopper.GUI.Canvas..::..GH_PaletteStyle
Style to draw capsule with.

See Also

GH_Capsule Class
Render Overload
Grasshopper.GUI.Canvas Namespace


Render Method (Graphics, Color)

[image]

Grasshopper SDK
GH_Capsule..::..Render Method (Graphics, Color)
GH_Capsule Class See Also Send Feedback
Have this capsule draw itself onto a Graphics surface with a custom colour override.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Render(
    Graphics G,
    Color colour
)
Visual Basic
Public Sub Render ( _
    G As Graphics, _
    colour As Color _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with. Zoom factor is implied by the G.Transform property.
colour
Type: System.Drawing..::..Color
Base colour for the capsule. Other colours will be derived from the base colour. If you want full control over every colour involved, then use the overload that allows you to supply a custom Style instead.

See Also

GH_Capsule Class
Render Overload
Grasshopper.GUI.Canvas Namespace


Render Method (Graphics, Image, GH_PaletteStyle)

[image]

Grasshopper SDK
GH_Capsule..::..Render Method (Graphics, Image, GH_PaletteStyle)
GH_Capsule Class See Also Send Feedback
Have this capsule draw itself onto a Graphics surface with a custom Style override.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Render(
    Graphics G,
    Image icon,
    GH_PaletteStyle style
)
Visual Basic
Public Sub Render ( _
    G As Graphics, _
    icon As Image, _
    style As GH_PaletteStyle _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with. Zoom factor is implied by the G.Transform property.
icon
Type: System.Drawing..::..Image
Icon to render in center of content/bounding box.
style
Type: Grasshopper.GUI.Canvas..::..GH_PaletteStyle
Style to draw capsule with.

See Also

GH_Capsule Class
Render Overload
Grasshopper.GUI.Canvas Namespace


Render Method (Graphics, Image, Color)

[image]

Grasshopper SDK
GH_Capsule..::..Render Method (Graphics, Image, Color)
GH_Capsule Class See Also Send Feedback
Have this capsule draw itself onto a Graphics surface with a custom colour override.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Render(
    Graphics G,
    Image icon,
    Color colour
)
Visual Basic
Public Sub Render ( _
    G As Graphics, _
    icon As Image, _
    colour As Color _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with. Zoom factor is implied by the G.Transform property.
icon
Type: System.Drawing..::..Image
Icon to render in center of content/bounding box.
colour
Type: System.Drawing..::..Color
Base colour for the capsule. Other colours will be derived from the base colour. If you want full control over every colour involved, then use the overload that allows you to supply a custom Style instead.

See Also

GH_Capsule Class
Render Overload
Grasshopper.GUI.Canvas Namespace


Render Method (Graphics, Boolean, Boolean, Boolean)

[image]

Grasshopper SDK
GH_Capsule..::..Render Method (Graphics, Boolean, Boolean, Boolean)
GH_Capsule Class See Also Send Feedback
Render the capsule onto a graphics context.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Render(
    Graphics G,
    bool selected,
    bool locked,
    bool hidden
)
Visual Basic
Public Sub Render ( _
    G As Graphics, _
    selected As Boolean, _
    locked As Boolean, _
    hidden As Boolean _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with. Zoom factor is implied by the G.Transform property.
selected
Type: System..::..Boolean
If true, the capsule will be drawn with selected colours.
locked
Type: System..::..Boolean
If True, the capcule will be drawn in Locked style.
hidden
Type: System..::..Boolean
If True, the capsule will be drawn in Hidden style.

See Also

GH_Capsule Class
Render Overload
Grasshopper.GUI.Canvas Namespace


Render Method (Graphics, Image, Boolean, Boolean, Boolean)

[image]

Grasshopper SDK
GH_Capsule..::..Render Method (Graphics, Image, Boolean, Boolean, Boolean)
GH_Capsule Class See Also Send Feedback
Render the capsule onto a graphics context.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Render(
    Graphics G,
    Image icon,
    bool selected,
    bool locked,
    bool hidden
)
Visual Basic
Public Sub Render ( _
    G As Graphics, _
    icon As Image, _
    selected As Boolean, _
    locked As Boolean, _
    hidden As Boolean _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with. Zoom factor is implied by the G.Transform property.
icon
Type: System.Drawing..::..Image
Icon to render in center of content/bounding box.
selected
Type: System..::..Boolean
If true, the capsule will be drawn with selected colours.
locked
Type: System..::..Boolean
If True, the capcule will be drawn in Locked style.
hidden
Type: System..::..Boolean
If True, the capsule will be drawn in Hidden style.

See Also

GH_Capsule Class
Render Overload
Grasshopper.GUI.Canvas Namespace


SetJaggedEdges Method

[image]

Grasshopper SDK
GH_Capsule..::..SetJaggedEdges Method
GH_Capsule Class See Also Send Feedback
Assign left and right jagged edges.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SetJaggedEdges(
    bool left,
    bool right
)
Visual Basic
Public Sub SetJaggedEdges ( _
    left As Boolean, _
    right As Boolean _
)

Parameters

left
Type: System..::..Boolean
right
Type: System..::..Boolean

See Also

GH_Capsule Class
Grasshopper.GUI.Canvas Namespace


GH_Capsule Properties

[image] [image]

Grasshopper SDK
GH_Capsule Properties
GH_Capsule Class See Also Send Feedback

The GH_Capsule type exposes the following members.

Properties

 | Name | Description
Public property | Box | Gets the outline box for this Capsule.
Public property | Box_Content | Gets the content box for this Capsule. Text and icons are drawn inside this box.
Public property | Font | Gets or sets the Font to use for text rendering.
Public property | Highlight | Gets the highlight size for this Capsule. Zero or negative means there is no highlight.
Public property | HighlightShape | Gets the graphics path that describes the highlight bar shape of the capsule.
Public property | InputGrips | Gets the list of locally defined input grip locations.
Public property | JaggedLeft | Gets whether the left edge of this capsule is jagged.
Public property | JaggedRight | Gets whether the right edge of this capsule is jagged.
Public property | MaxRadius | Gets the largest radius defined for this capsule.
Public property | OutlineShape | Gets the graphics path that describes the outer edge of the capsule.
Public property | OutputGrips | Gets the list of locally defined output grip locations.
Public property | Palette | Gets or sets the palette for this Capsule.
Public property | Radius | Gets the radius of the rounded corners of this Capsule.
Public property | RenderEngine | Gets the RenderEngine associated with this capsule. You typically don't need to go this far, just use one of the Render() overloads on GH_Capsule directly.
Public property | Text | Gets or sets the text to render in the content box.
Public property | TextOrientation | Gets or sets the orientation of the text within the content box.

See Also

GH_Capsule Class
Grasshopper.GUI.Canvas Namespace


Box Property

[image]

Grasshopper SDK
GH_Capsule..::..Box Property
GH_Capsule Class See Also Send Feedback
Gets the outline box for this Capsule.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle Box { get; }
Visual Basic
Public ReadOnly Property Box As Rectangle
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Capsule.Box"]

See Also

GH_Capsule Class
Grasshopper.GUI.Canvas Namespace


Box_Content Property

[image]

Grasshopper SDK
GH_Capsule..::..Box_Content Property
GH_Capsule Class See Also Send Feedback
Gets the content box for this Capsule. Text and icons are drawn inside this box.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle Box_Content { get; }
Visual Basic
Public ReadOnly Property Box_Content As Rectangle
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Capsule.Box_Content"]

See Also

GH_Capsule Class
Grasshopper.GUI.Canvas Namespace


Font Property

[image]

Grasshopper SDK
GH_Capsule..::..Font Property
GH_Capsule Class See Also Send Feedback
Gets or sets the Font to use for text rendering.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Font Font { get; set; }
Visual Basic
Public Property Font As Font
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Capsule.Font"]

See Also

GH_Capsule Class
Grasshopper.GUI.Canvas Namespace


Highlight Property

[image]

Grasshopper SDK
GH_Capsule..::..Highlight Property
GH_Capsule Class See Also Send Feedback
Gets the highlight size for this Capsule. Zero or negative means there is no highlight.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int Highlight { get; }
Visual Basic
Public ReadOnly Property Highlight As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Capsule.Highlight"]

See Also

GH_Capsule Class
Grasshopper.GUI.Canvas Namespace


HighlightShape Property

[image]

Grasshopper SDK
GH_Capsule..::..HighlightShape Property
GH_Capsule Class See Also Send Feedback
Gets the graphics path that describes the highlight bar shape of the capsule.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GraphicsPath HighlightShape { get; }
Visual Basic
Public ReadOnly Property HighlightShape As GraphicsPath
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Capsule.HighlightShape"]

See Also

GH_Capsule Class
Grasshopper.GUI.Canvas Namespace


InputGrips Property

[image]

Grasshopper SDK
GH_Capsule..::..InputGrips Property
GH_Capsule Class See Also Send Feedback
Gets the list of locally defined input grip locations.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<Point> InputGrips { get; }
Visual Basic
Public ReadOnly Property InputGrips As List(Of Point)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Capsule.InputGrips"]

See Also

GH_Capsule Class
Grasshopper.GUI.Canvas Namespace


JaggedLeft Property

[image]

Grasshopper SDK
GH_Capsule..::..JaggedLeft Property
GH_Capsule Class See Also Send Feedback
Gets whether the left edge of this capsule is jagged.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool JaggedLeft { get; }
Visual Basic
Public ReadOnly Property JaggedLeft As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Capsule.JaggedLeft"]

See Also

GH_Capsule Class
Grasshopper.GUI.Canvas Namespace


JaggedRight Property

[image]

Grasshopper SDK
GH_Capsule..::..JaggedRight Property
GH_Capsule Class See Also Send Feedback
Gets whether the right edge of this capsule is jagged.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool JaggedRight { get; }
Visual Basic
Public ReadOnly Property JaggedRight As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Capsule.JaggedRight"]

See Also

GH_Capsule Class
Grasshopper.GUI.Canvas Namespace


MaxRadius Property

[image]

Grasshopper SDK
GH_Capsule..::..MaxRadius Property
GH_Capsule Class See Also Send Feedback
Gets the largest radius defined for this capsule.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int MaxRadius { get; }
Visual Basic
Public ReadOnly Property MaxRadius As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Capsule.MaxRadius"]

See Also

GH_Capsule Class
Grasshopper.GUI.Canvas Namespace


OutlineShape Property

[image]

Grasshopper SDK
GH_Capsule..::..OutlineShape Property
GH_Capsule Class See Also Send Feedback
Gets the graphics path that describes the outer edge of the capsule.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GraphicsPath OutlineShape { get; }
Visual Basic
Public ReadOnly Property OutlineShape As GraphicsPath
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Capsule.OutlineShape"]

See Also

GH_Capsule Class
Grasshopper.GUI.Canvas Namespace


OutputGrips Property

[image]

Grasshopper SDK
GH_Capsule..::..OutputGrips Property
GH_Capsule Class See Also Send Feedback
Gets the list of locally defined output grip locations.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<Point> OutputGrips { get; }
Visual Basic
Public ReadOnly Property OutputGrips As List(Of Point)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Capsule.OutputGrips"]

See Also

GH_Capsule Class
Grasshopper.GUI.Canvas Namespace


Palette Property

[image]

Grasshopper SDK
GH_Capsule..::..Palette Property
GH_Capsule Class See Also Send Feedback
Gets or sets the palette for this Capsule.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Palette Palette { get; set; }
Visual Basic
Public Property Palette As GH_Palette
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Capsule.Palette"]

See Also

GH_Capsule Class
Grasshopper.GUI.Canvas Namespace


Radius Property

[image]

Grasshopper SDK
GH_Capsule..::..Radius Property
GH_Capsule Class See Also Send Feedback
Gets the radius of the rounded corners of this Capsule.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property Radius ( _
    index As Integer _
) As Integer
    Get

Parameters

index
Type: System..::..Int32
Corner index.

0 = upper left

1 = upper right

2 = lower right

3 = lower left

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Capsule.Radius(System.Int32)"]

See Also

GH_Capsule Class
Grasshopper.GUI.Canvas Namespace


RenderEngine Property

[image]

Grasshopper SDK
GH_Capsule..::..RenderEngine Property
GH_Capsule Class See Also Send Feedback
Gets the RenderEngine associated with this capsule. You typically don't need to go this far, just use one of the Render() overloads on GH_Capsule directly.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_CapsuleRenderEngine RenderEngine { get; }
Visual Basic
Public ReadOnly Property RenderEngine As GH_CapsuleRenderEngine
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Capsule.RenderEngine"]

Remarks

Do not store pointers to the RenderEngine, always call this property anew.

See Also

GH_Capsule Class
Grasshopper.GUI.Canvas Namespace


Text Property

[image]

Grasshopper SDK
GH_Capsule..::..Text Property
GH_Capsule Class See Also Send Feedback
Gets or sets the text to render in the content box.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Capsule.Text"]

See Also

GH_Capsule Class
Grasshopper.GUI.Canvas Namespace


TextOrientation Property

[image]

Grasshopper SDK
GH_Capsule..::..TextOrientation Property
GH_Capsule Class See Also Send Feedback
Gets or sets the orientation of the text within the content box.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Orientation TextOrientation { get; set; }
Visual Basic
Public Property TextOrientation As GH_Orientation
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Capsule.TextOrientation"]

See Also

GH_Capsule Class
Grasshopper.GUI.Canvas Namespace


GH_CapsuleRenderEngine Class

[image]

Grasshopper SDK
GH_CapsuleRenderEngine Class
Members See Also Send Feedback
Provides basic Render methods for capsule display. You typically don't need this class, just use the Render() overloads on GH_Capsule directly.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_CapsuleRenderEngine
Visual Basic
Public Class GH_CapsuleRenderEngine

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI.Canvas..::..GH_CapsuleRenderEngine

See Also

GH_CapsuleRenderEngine Members
Grasshopper.GUI.Canvas Namespace


GH_CapsuleRenderEngine Members

[image] [image]

Grasshopper SDK
GH_CapsuleRenderEngine Members
GH_CapsuleRenderEngine Class Methods See Also Send Feedback

The GH_CapsuleRenderEngine type exposes the following members.

Methods

 | Name | Description
 | CreateHighlightBar(Rectangle, Int32, Int32) | Static (Shared in VB) method for creating Grasshopper Capsule highlight fills.
 | CreateHighlightBar(Rectangle, Int32, Int32, Int32) | Static (Shared in VB) method for creating Grasshopper Capsule highlight fills.
 | CreateHighlightBar(Rectangle, Int32, Int32, Boolean, Boolean) | Static (Shared in VB) method for creating Grasshopper Capsule highlight fills.
 | CreateHighlightBar(Rectangle, Int32, Int32, Int32, Boolean, Boolean) | Static (Shared in VB) method for creating Grasshopper Capsule highlight fills.
 | CreateJaggedRectangle | Static (Shared in VB) method for creating rectangles with rounded corners.
 | CreateRoundedRectangle(Rectangle, Int32) | Static (Shared in VB) method for creating rectangles with rounded corners.
 | CreateRoundedRectangle(RectangleF, Single) | Static (Shared in VB) method for creating rectangles with rounded corners.
 | CreateRoundedRectangle(Rectangle, Int32, Int32, Int32, Int32) | Static (Shared in VB) method for creating rectangles with rounded corners.
 | CreateRoundedRectangle(RectangleF, Single, Single, Single, Single) | Static (Shared in VB) method for creating rectangles with rounded corners.
 | GetImpliedPalette | Static (Shared in VB) method for solving which palette is the default given a specific object's properties. Default palettes are either GH_Palette.Normal, GH_Palette.Warning or GH_Palette.Error depending on the objects' runtime message level.
 | GetImpliedStyle(GH_Palette, IGH_Attributes) | Static (Shared in VB) method for solving which palette style is implied by the properties.
 | GetImpliedStyle(GH_Palette, Boolean, Boolean, Boolean) | Static (Shared in VB) method for solving which palette style is implied by the properties.
 | GetPaletteStyle(GH_Palette, IGH_Attributes) | Obsolete.
 | GetPaletteStyle(GH_Palette, Boolean, Boolean, Boolean) | Obsolete.
Public method | RenderAlphaFill | Render a standard transparancy background hatch. This is only needed when the capsule background colour is not fully opaque. This is usually the second stage in a capsule rendering, right after the Grips are drawn.
Public method | RenderBackground | Render a default capsule background fill. This is usually the third stage in a capsule rendering.
Public method | RenderBackground_Alternative | Render a custom capsule background fill. This is usually the third stage in a capsule rendering.
Public method | RenderGrips | Render all the grips associates with the capsule. Grips are not drawn if the zoom level is less than 50%. This is usually the first stage in a Capsule rendering.
Public method | RenderGrips_Alternative | Render all the grips associates with the capsule as semi-circles. This is needed if the capsule background is not fully opaque. Grips are not drawn if the zoom level is less than 50%. This is usually the first stage in a Capsule rendering.
Public method | RenderHighlight | Render a highlight bar. This is highly zoom-dependant. Highlight rendering is usually the fourth stage in a Capsule Rendering, after the background but prior to the edges.
Public method | RenderIcon(Graphics, Image, Int32, Int32) | Render an image icon centered into the box. If the content box has been defined the icon will be centered there, otherwise the outline box will be used.
Public method | RenderIcon(Graphics, Image, RectangleF, Int32, Int32) | Render an image icon centered into the box. If the content box has been defined the icon will be centered there, otherwise the outline box will be used.
 | RenderInputGrip | Static (Shared in VB) method to render a default input grip.
Public method | RenderMessage | Render a text message underneath the capsule.
Public method | RenderOutlines | Render default capsule outlines. If the zoom factor is less than 50% the inner outline is not drawn. This is usually the fifth stage in a Capsule rendering.
 | RenderOutputGrip | Static (Shared in VB) method to render a default output grip.
Public method | RenderText | Render the capsule text. This is usually the sixth and final stage in a capsule rendering.

See Also

GH_CapsuleRenderEngine Class
Grasshopper.GUI.Canvas Namespace


GH_CapsuleRenderEngine Methods

[image] [image]

Grasshopper SDK
GH_CapsuleRenderEngine Methods
GH_CapsuleRenderEngine Class See Also Send Feedback

The GH_CapsuleRenderEngine type exposes the following members.

Methods

 | Name | Description
 | CreateHighlightBar(Rectangle, Int32, Int32) | Static (Shared in VB) method for creating Grasshopper Capsule highlight fills.
 | CreateHighlightBar(Rectangle, Int32, Int32, Int32) | Static (Shared in VB) method for creating Grasshopper Capsule highlight fills.
 | CreateHighlightBar(Rectangle, Int32, Int32, Boolean, Boolean) | Static (Shared in VB) method for creating Grasshopper Capsule highlight fills.
 | CreateHighlightBar(Rectangle, Int32, Int32, Int32, Boolean, Boolean) | Static (Shared in VB) method for creating Grasshopper Capsule highlight fills.
 | CreateJaggedRectangle | Static (Shared in VB) method for creating rectangles with rounded corners.
 | CreateRoundedRectangle(Rectangle, Int32) | Static (Shared in VB) method for creating rectangles with rounded corners.
 | CreateRoundedRectangle(RectangleF, Single) | Static (Shared in VB) method for creating rectangles with rounded corners.
 | CreateRoundedRectangle(Rectangle, Int32, Int32, Int32, Int32) | Static (Shared in VB) method for creating rectangles with rounded corners.
 | CreateRoundedRectangle(RectangleF, Single, Single, Single, Single) | Static (Shared in VB) method for creating rectangles with rounded corners.
 | GetImpliedPalette | Static (Shared in VB) method for solving which palette is the default given a specific object's properties. Default palettes are either GH_Palette.Normal, GH_Palette.Warning or GH_Palette.Error depending on the objects' runtime message level.
 | GetImpliedStyle(GH_Palette, IGH_Attributes) | Static (Shared in VB) method for solving which palette style is implied by the properties.
 | GetImpliedStyle(GH_Palette, Boolean, Boolean, Boolean) | Static (Shared in VB) method for solving which palette style is implied by the properties.
 | GetPaletteStyle(GH_Palette, IGH_Attributes) | Obsolete.
 | GetPaletteStyle(GH_Palette, Boolean, Boolean, Boolean) | Obsolete.
Public method | RenderAlphaFill | Render a standard transparancy background hatch. This is only needed when the capsule background colour is not fully opaque. This is usually the second stage in a capsule rendering, right after the Grips are drawn.
Public method | RenderBackground | Render a default capsule background fill. This is usually the third stage in a capsule rendering.
Public method | RenderBackground_Alternative | Render a custom capsule background fill. This is usually the third stage in a capsule rendering.
Public method | RenderGrips | Render all the grips associates with the capsule. Grips are not drawn if the zoom level is less than 50%. This is usually the first stage in a Capsule rendering.
Public method | RenderGrips_Alternative | Render all the grips associates with the capsule as semi-circles. This is needed if the capsule background is not fully opaque. Grips are not drawn if the zoom level is less than 50%. This is usually the first stage in a Capsule rendering.
Public method | RenderHighlight | Render a highlight bar. This is highly zoom-dependant. Highlight rendering is usually the fourth stage in a Capsule Rendering, after the background but prior to the edges.
Public method | RenderIcon(Graphics, Image, Int32, Int32) | Render an image icon centered into the box. If the content box has been defined the icon will be centered there, otherwise the outline box will be used.
Public method | RenderIcon(Graphics, Image, RectangleF, Int32, Int32) | Render an image icon centered into the box. If the content box has been defined the icon will be centered there, otherwise the outline box will be used.
 | RenderInputGrip | Static (Shared in VB) method to render a default input grip.
Public method | RenderMessage | Render a text message underneath the capsule.
Public method | RenderOutlines | Render default capsule outlines. If the zoom factor is less than 50% the inner outline is not drawn. This is usually the fifth stage in a Capsule rendering.
 | RenderOutputGrip | Static (Shared in VB) method to render a default output grip.
Public method | RenderText | Render the capsule text. This is usually the sixth and final stage in a capsule rendering.

See Also

GH_CapsuleRenderEngine Class
Grasshopper.GUI.Canvas Namespace


CreateHighlightBar Method

[image] [image]

Grasshopper SDK
GH_CapsuleRenderEngine..::..CreateHighlightBar Method
GH_CapsuleRenderEngine Class See Also Send Feedback

Overload List

Name | Description
CreateHighlightBar(Rectangle, Int32, Int32) | Static (Shared in VB) method for creating Grasshopper Capsule highlight fills.
CreateHighlightBar(Rectangle, Int32, Int32, Int32) | Static (Shared in VB) method for creating Grasshopper Capsule highlight fills.
CreateHighlightBar(Rectangle, Int32, Int32, Boolean, Boolean) | Static (Shared in VB) method for creating Grasshopper Capsule highlight fills.
CreateHighlightBar(Rectangle, Int32, Int32, Int32, Boolean, Boolean) | Static (Shared in VB) method for creating Grasshopper Capsule highlight fills.

See Also

GH_CapsuleRenderEngine Class
GH_CapsuleRenderEngine Members
Grasshopper.GUI.Canvas Namespace


CreateHighlightBar Method (Rectangle, Int32, Int32)

[image]

Grasshopper SDK
GH_CapsuleRenderEngine..::..CreateHighlightBar Method (Rectangle, Int32, Int32)
GH_CapsuleRenderEngine Class See Also Send Feedback
Static (Shared in VB) method for creating Grasshopper Capsule highlight fills.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GraphicsPath CreateHighlightBar(
    Rectangle rec,
    int radius,
    int size
)
Visual Basic
Public Shared Function CreateHighlightBar ( _
    rec As Rectangle, _
    radius As Integer, _
    size As Integer _
) As GraphicsPath

Parameters

rec
Type: System.Drawing..::..Rectangle
Rectangle for entire fill.
radius
Type: System..::..Int32
Corner radius.
size
Type: System..::..Int32
Highlight fill height.

Return Value

Graphics path that describes the highlight fill shape.

See Also

GH_CapsuleRenderEngine Class
CreateHighlightBar Overload
Grasshopper.GUI.Canvas Namespace


CreateHighlightBar Method (Rectangle, Int32, Int32, Int32)

[image]

Grasshopper SDK
GH_CapsuleRenderEngine..::..CreateHighlightBar Method (Rectangle, Int32, Int32, Int32)
GH_CapsuleRenderEngine Class See Also Send Feedback
Static (Shared in VB) method for creating Grasshopper Capsule highlight fills.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GraphicsPath CreateHighlightBar(
    Rectangle rec,
    int R0,
    int R1,
    int size
)
Visual Basic
Public Shared Function CreateHighlightBar ( _
    rec As Rectangle, _
    R0 As Integer, _
    R1 As Integer, _
    size As Integer _
) As GraphicsPath

Parameters

rec
Type: System.Drawing..::..Rectangle
Rectangle for entire fill.
R0
Type: System..::..Int32
Radius of upper left corner.
R1
Type: System..::..Int32
Radius of upper right corner.
size
Type: System..::..Int32
Highlight fill height.

Return Value

Graphics path that describes the highlight fill shape.

See Also

GH_CapsuleRenderEngine Class
CreateHighlightBar Overload
Grasshopper.GUI.Canvas Namespace


CreateHighlightBar Method (Rectangle, Int32, Int32, Boolean, Boolean)

[image]

Grasshopper SDK
GH_CapsuleRenderEngine..::..CreateHighlightBar Method (Rectangle, Int32, Int32, Boolean, Boolean)
GH_CapsuleRenderEngine Class See Also Send Feedback
Static (Shared in VB) method for creating Grasshopper Capsule highlight fills.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GraphicsPath CreateHighlightBar(
    Rectangle rec,
    int radius,
    int size,
    bool jaggedLeft,
    bool jaggedRight
)
Visual Basic
Public Shared Function CreateHighlightBar ( _
    rec As Rectangle, _
    radius As Integer, _
    size As Integer, _
    jaggedLeft As Boolean, _
    jaggedRight As Boolean _
) As GraphicsPath

Parameters

rec
Type: System.Drawing..::..Rectangle
Rectangle for entire fill.
radius
Type: System..::..Int32
Corner radius.
size
Type: System..::..Int32
Highlight fill height.
jaggedLeft
Type: System..::..Boolean
jaggedRight
Type: System..::..Boolean

Return Value

Graphics path that describes the highlight fill shape.

See Also

GH_CapsuleRenderEngine Class
CreateHighlightBar Overload
Grasshopper.GUI.Canvas Namespace


CreateHighlightBar Method (Rectangle, Int32, Int32, Int32, Boolean, Boolean)

[image]

Grasshopper SDK
GH_CapsuleRenderEngine..::..CreateHighlightBar Method (Rectangle, Int32, Int32, Int32, Boolean, Boolean)
GH_CapsuleRenderEngine Class See Also Send Feedback
Static (Shared in VB) method for creating Grasshopper Capsule highlight fills.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GraphicsPath CreateHighlightBar(
    Rectangle rec,
    int R0,
    int R1,
    int size,
    bool jaggedLeft,
    bool jaggedRight
)
Visual Basic
Public Shared Function CreateHighlightBar ( _
    rec As Rectangle, _
    R0 As Integer, _
    R1 As Integer, _
    size As Integer, _
    jaggedLeft As Boolean, _
    jaggedRight As Boolean _
) As GraphicsPath

Parameters

rec
Type: System.Drawing..::..Rectangle
Rectangle for entire fill.
R0
Type: System..::..Int32
Radius of upper left corner.
R1
Type: System..::..Int32
Radius of upper right corner.
size
Type: System..::..Int32
Highlight fill height.
jaggedLeft
Type: System..::..Boolean
jaggedRight
Type: System..::..Boolean

Return Value

Graphics path that describes the highlight fill shape.

See Also

GH_CapsuleRenderEngine Class
CreateHighlightBar Overload
Grasshopper.GUI.Canvas Namespace


CreateJaggedRectangle Method

[image]

Grasshopper SDK
GH_CapsuleRenderEngine..::..CreateJaggedRectangle Method
GH_CapsuleRenderEngine Class See Also Send Feedback
Static (Shared in VB) method for creating rectangles with rounded corners.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GraphicsPath CreateJaggedRectangle(
    RectangleF rec,
    float R0,
    float R1,
    float R2,
    float R3,
    bool jaggedLeft,
    bool jaggedRight
)
Visual Basic
Public Shared Function CreateJaggedRectangle ( _
    rec As RectangleF, _
    R0 As Single, _
    R1 As Single, _
    R2 As Single, _
    R3 As Single, _
    jaggedLeft As Boolean, _
    jaggedRight As Boolean _
) As GraphicsPath

Parameters

rec
Type: System.Drawing..::..RectangleF
Rectangle to fillet. Rectangles smaller than 3 pixels wide/high will be grown.
R0
Type: System..::..Single
Radius of upper left corner. Zero or negative values omit fillets.
R1
Type: System..::..Single
Radius of upper right corner. Zero or negative values omit fillets.
R2
Type: System..::..Single
Radius of lower right corner. Zero or negative values omit fillets.
R3
Type: System..::..Single
Radius of lower left corner. Zero or negative values omit fillets.
jaggedLeft
Type: System..::..Boolean
If true, the left edge of the rectangle will be jagged and R0 and R3 will be ignored.
jaggedRight
Type: System..::..Boolean
If true, the right edge of the rectangle will be jagged and R1 and R2 will be ignored.

Return Value

Graphics path that describes the rounded rectangle.

See Also

GH_CapsuleRenderEngine Class
Grasshopper.GUI.Canvas Namespace


CreateRoundedRectangle Method

[image] [image]

Grasshopper SDK
GH_CapsuleRenderEngine..::..CreateRoundedRectangle Method
GH_CapsuleRenderEngine Class See Also Send Feedback

Overload List

Name | Description
CreateRoundedRectangle(Rectangle, Int32) | Static (Shared in VB) method for creating rectangles with rounded corners.
CreateRoundedRectangle(RectangleF, Single) | Static (Shared in VB) method for creating rectangles with rounded corners.
CreateRoundedRectangle(Rectangle, Int32, Int32, Int32, Int32) | Static (Shared in VB) method for creating rectangles with rounded corners.
CreateRoundedRectangle(RectangleF, Single, Single, Single, Single) | Static (Shared in VB) method for creating rectangles with rounded corners.

See Also

GH_CapsuleRenderEngine Class
GH_CapsuleRenderEngine Members
Grasshopper.GUI.Canvas Namespace


CreateRoundedRectangle Method (Rectangle, Int32)

[image]

Grasshopper SDK
GH_CapsuleRenderEngine..::..CreateRoundedRectangle Method (Rectangle, Int32)
GH_CapsuleRenderEngine Class See Also Send Feedback
Static (Shared in VB) method for creating rectangles with rounded corners.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GraphicsPath CreateRoundedRectangle(
    Rectangle rec,
    int radius
)
Visual Basic
Public Shared Function CreateRoundedRectangle ( _
    rec As Rectangle, _
    radius As Integer _
) As GraphicsPath

Parameters

rec
Type: System.Drawing..::..Rectangle
Rectangle to fillet. Rectangles smaller than 3 pixels wide/high will be grown.
radius
Type: System..::..Int32
Radius of corner fillets.

Return Value

Graphics path that describes the rounded rectangle.

See Also

GH_CapsuleRenderEngine Class
CreateRoundedRectangle Overload
Grasshopper.GUI.Canvas Namespace


CreateRoundedRectangle Method (RectangleF, Single)

[image]

Grasshopper SDK
GH_CapsuleRenderEngine..::..CreateRoundedRectangle Method (RectangleF, Single)
GH_CapsuleRenderEngine Class See Also Send Feedback
Static (Shared in VB) method for creating rectangles with rounded corners.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GraphicsPath CreateRoundedRectangle(
    RectangleF rec,
    float radius
)
Visual Basic
Public Shared Function CreateRoundedRectangle ( _
    rec As RectangleF, _
    radius As Single _
) As GraphicsPath

Parameters

rec
Type: System.Drawing..::..RectangleF
Rectangle to fillet. Rectangles smaller than 3 pixels wide/high will be grown.
radius
Type: System..::..Single
Radius of corner fillets.

Return Value

Graphics path that describes the rounded rectangle.

See Also

GH_CapsuleRenderEngine Class
CreateRoundedRectangle Overload
Grasshopper.GUI.Canvas Namespace


CreateRoundedRectangle Method (Rectangle, Int32, Int32, Int32, Int32)

[image]

Grasshopper SDK
GH_CapsuleRenderEngine..::..CreateRoundedRectangle Method (Rectangle, Int32, Int32, Int32, Int32)
GH_CapsuleRenderEngine Class See Also Send Feedback
Static (Shared in VB) method for creating rectangles with rounded corners.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GraphicsPath CreateRoundedRectangle(
    Rectangle rec,
    int R0,
    int R1,
    int R2,
    int R3
)
Visual Basic
Public Shared Function CreateRoundedRectangle ( _
    rec As Rectangle, _
    R0 As Integer, _
    R1 As Integer, _
    R2 As Integer, _
    R3 As Integer _
) As GraphicsPath

Parameters

rec
Type: System.Drawing..::..Rectangle
Rectangle to fillet. Rectangles smaller than 3 pixels wide/high will be grown.
R0
Type: System..::..Int32
Radius of upper left corner. Zero or negative values omit fillets.
R1
Type: System..::..Int32
Radius of upper right corner. Zero or negative values omit fillets.
R2
Type: System..::..Int32
Radius of lower right corner. Zero or negative values omit fillets.
R3
Type: System..::..Int32
Radius of lower left corner. Zero or negative values omit fillets.

Return Value

Graphics path that describes the rounded rectangle.

See Also

GH_CapsuleRenderEngine Class
CreateRoundedRectangle Overload
Grasshopper.GUI.Canvas Namespace


CreateRoundedRectangle Method (RectangleF, Single, Single, Single, Single)

[image]

Grasshopper SDK
GH_CapsuleRenderEngine..::..CreateRoundedRectangle Method (RectangleF, Single, Single, Single, Single)
GH_CapsuleRenderEngine Class See Also Send Feedback
Static (Shared in VB) method for creating rectangles with rounded corners.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GraphicsPath CreateRoundedRectangle(
    RectangleF rec,
    float R0,
    float R1,
    float R2,
    float R3
)
Visual Basic
Public Shared Function CreateRoundedRectangle ( _
    rec As RectangleF, _
    R0 As Single, _
    R1 As Single, _
    R2 As Single, _
    R3 As Single _
) As GraphicsPath

Parameters

rec
Type: System.Drawing..::..RectangleF
Rectangle to fillet. Rectangles smaller than 3 pixels wide/high will be grown.
R0
Type: System..::..Single
Radius of upper left corner. Zero or negative values omit fillets.
R1
Type: System..::..Single
Radius of upper right corner. Zero or negative values omit fillets.
R2
Type: System..::..Single
Radius of lower right corner. Zero or negative values omit fillets.
R3
Type: System..::..Single
Radius of lower left corner. Zero or negative values omit fillets.

Return Value

Graphics path that describes the rounded rectangle.

See Also

GH_CapsuleRenderEngine Class
CreateRoundedRectangle Overload
Grasshopper.GUI.Canvas Namespace


GetImpliedPalette Method

[image]

Grasshopper SDK
GH_CapsuleRenderEngine..::..GetImpliedPalette Method
GH_CapsuleRenderEngine Class See Also Send Feedback
Static (Shared in VB) method for solving which palette is the default given a specific object's properties. Default palettes are either GH_Palette.Normal, GH_Palette.Warning or GH_Palette.Error depending on the objects' runtime message level.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Palette GetImpliedPalette(
    IGH_ActiveObject obj
)
Visual Basic
Public Shared Function GetImpliedPalette ( _
    obj As IGH_ActiveObject _
) As GH_Palette

Parameters

obj
Type: Grasshopper.Kernel..::..IGH_ActiveObject
Object to evaluate.

Return Value

The default palette.

See Also

GH_CapsuleRenderEngine Class
Grasshopper.GUI.Canvas Namespace


GetImpliedStyle Method

[image] [image]

Grasshopper SDK
GH_CapsuleRenderEngine..::..GetImpliedStyle Method
GH_CapsuleRenderEngine Class See Also Send Feedback

Overload List

Name | Description
GetImpliedStyle(GH_Palette, IGH_Attributes) | Static (Shared in VB) method for solving which palette style is implied by the properties.
GetImpliedStyle(GH_Palette, Boolean, Boolean, Boolean) | Static (Shared in VB) method for solving which palette style is implied by the properties.

See Also

GH_CapsuleRenderEngine Class
GH_CapsuleRenderEngine Members
Grasshopper.GUI.Canvas Namespace


GetImpliedStyle Method (GH_Palette, IGH_Attributes)

[image]

Grasshopper SDK
GH_CapsuleRenderEngine..::..GetImpliedStyle Method (GH_Palette, IGH_Attributes)
GH_CapsuleRenderEngine Class See Also Send Feedback
Static (Shared in VB) method for solving which palette style is implied by the properties.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_PaletteStyle GetImpliedStyle(
    GH_Palette palette,
    IGH_Attributes attributes
)
Visual Basic
Public Shared Function GetImpliedStyle ( _
    palette As GH_Palette, _
    attributes As IGH_Attributes _
) As GH_PaletteStyle

Parameters

palette
Type: Grasshopper.GUI.Canvas..::..GH_Palette
Palette hint.
attributes
Type: Grasshopper.Kernel..::..IGH_Attributes
Attributes to parse for style details.

See Also

GH_CapsuleRenderEngine Class
GetImpliedStyle Overload
Grasshopper.GUI.Canvas Namespace


GetImpliedStyle Method (GH_Palette, Boolean, Boolean, Boolean)

[image]

Grasshopper SDK
GH_CapsuleRenderEngine..::..GetImpliedStyle Method (GH_Palette, Boolean, Boolean, Boolean)
GH_CapsuleRenderEngine Class See Also Send Feedback
Static (Shared in VB) method for solving which palette style is implied by the properties.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_PaletteStyle GetImpliedStyle(
    GH_Palette palette,
    bool selected,
    bool locked,
    bool hidden
)
Visual Basic
Public Shared Function GetImpliedStyle ( _
    palette As GH_Palette, _
    selected As Boolean, _
    locked As Boolean, _
    hidden As Boolean _
) As GH_PaletteStyle

Parameters

palette
Type: Grasshopper.GUI.Canvas..::..GH_Palette
Palette hint.
selected
Type: System..::..Boolean
Specifies whether the selected flavour of a palette needs to be returned.
locked
Type: System..::..Boolean
If True, the returned palette style is always Locked.
hidden
Type: System..::..Boolean
If True, the returned palette style is always Hidden.

See Also

GH_CapsuleRenderEngine Class
GetImpliedStyle Overload
Grasshopper.GUI.Canvas Namespace


GetPaletteStyle Method

[image] [image]

Grasshopper SDK
GH_CapsuleRenderEngine..::..GetPaletteStyle Method
GH_CapsuleRenderEngine Class See Also Send Feedback

Overload List

Name | Description
GetPaletteStyle(GH_Palette, IGH_Attributes) | Obsolete.
GetPaletteStyle(GH_Palette, Boolean, Boolean, Boolean) | Obsolete.

See Also

GH_CapsuleRenderEngine Class
GH_CapsuleRenderEngine Members
Grasshopper.GUI.Canvas Namespace


GetPaletteStyle Method (GH_Palette, IGH_Attributes)

[image]

Grasshopper SDK
GH_CapsuleRenderEngine..::..GetPaletteStyle Method (GH_Palette, IGH_Attributes)
GH_CapsuleRenderEngine Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
[ObsoleteAttribute("this method has been replaced by GetImpliedStyle")]
public static GH_PaletteStyle GetPaletteStyle(
    GH_Palette palette,
    IGH_Attributes attributes
)
Visual Basic
<ObsoleteAttribute("this method has been replaced by GetImpliedStyle")> _
Public Shared Function GetPaletteStyle ( _
    palette As GH_Palette, _
    attributes As IGH_Attributes _
) As GH_PaletteStyle

Parameters

palette
Type: Grasshopper.GUI.Canvas..::..GH_Palette
attributes
Type: Grasshopper.Kernel..::..IGH_Attributes

See Also

GH_CapsuleRenderEngine Class
GetPaletteStyle Overload
Grasshopper.GUI.Canvas Namespace


GetPaletteStyle Method (GH_Palette, Boolean, Boolean, Boolean)

[image]

Grasshopper SDK
GH_CapsuleRenderEngine..::..GetPaletteStyle Method (GH_Palette, Boolean, Boolean, Boolean)
GH_CapsuleRenderEngine Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
[ObsoleteAttribute("this method has been replaced by GetImpliedStyle")]
public static GH_PaletteStyle GetPaletteStyle(
    GH_Palette palette,
    bool selected,
    bool locked,
    bool hidden
)
Visual Basic
<ObsoleteAttribute("this method has been replaced by GetImpliedStyle")> _
Public Shared Function GetPaletteStyle ( _
    palette As GH_Palette, _
    selected As Boolean, _
    locked As Boolean, _
    hidden As Boolean _
) As GH_PaletteStyle

Parameters

palette
Type: Grasshopper.GUI.Canvas..::..GH_Palette
selected
Type: System..::..Boolean
locked
Type: System..::..Boolean
hidden
Type: System..::..Boolean

See Also

GH_CapsuleRenderEngine Class
GetPaletteStyle Overload
Grasshopper.GUI.Canvas Namespace


RenderAlphaFill Method

[image]

Grasshopper SDK
GH_CapsuleRenderEngine..::..RenderAlphaFill Method
GH_CapsuleRenderEngine Class See Also Send Feedback
Render a standard transparancy background hatch. This is only needed when the capsule background colour is not fully opaque. This is usually the second stage in a capsule rendering, right after the Grips are drawn.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RenderAlphaFill(
    Graphics G
)
Visual Basic
Public Sub RenderAlphaFill ( _
    G As Graphics _
)

Parameters

G
Type: System.Drawing..::..Graphics

See Also

GH_CapsuleRenderEngine Class
Grasshopper.GUI.Canvas Namespace


RenderBackground Method

[image]

Grasshopper SDK
GH_CapsuleRenderEngine..::..RenderBackground Method
GH_CapsuleRenderEngine Class See Also Send Feedback
Render a default capsule background fill. This is usually the third stage in a capsule rendering.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RenderBackground(
    Graphics G,
    float zoom,
    GH_PaletteStyle style
)
Visual Basic
Public Sub RenderBackground ( _
    G As Graphics, _
    zoom As Single, _
    style As GH_PaletteStyle _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.
zoom
Type: System..::..Single
Zoom of graphics object.
style
Type: Grasshopper.GUI.Canvas..::..GH_PaletteStyle
Final style to draw with.

See Also

GH_CapsuleRenderEngine Class
Grasshopper.GUI.Canvas Namespace


RenderBackground_Alternative Method

[image]

Grasshopper SDK
GH_CapsuleRenderEngine..::..RenderBackground_Alternative Method
GH_CapsuleRenderEngine Class See Also Send Feedback
Render a custom capsule background fill. This is usually the third stage in a capsule rendering.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RenderBackground_Alternative(
    Graphics G,
    Color colourOverride,
    bool drawAlphaGrid
)
Visual Basic
Public Sub RenderBackground_Alternative ( _
    G As Graphics, _
    colourOverride As Color, _
    drawAlphaGrid As Boolean _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.
colourOverride
Type: System.Drawing..::..Color
Custom background colour.
drawAlphaGrid
Type: System..::..Boolean
If true, and the background colour is not opaque, an alpha grid will be drawn as well.

See Also

GH_CapsuleRenderEngine Class
Grasshopper.GUI.Canvas Namespace


RenderGrips Method

[image]

Grasshopper SDK
GH_CapsuleRenderEngine..::..RenderGrips Method
GH_CapsuleRenderEngine Class See Also Send Feedback
Render all the grips associates with the capsule. Grips are not drawn if the zoom level is less than 50%. This is usually the first stage in a Capsule rendering.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RenderGrips(
    Graphics G
)
Visual Basic
Public Sub RenderGrips ( _
    G As Graphics _
)

Parameters

G
Type: System.Drawing..::..Graphics

See Also

GH_CapsuleRenderEngine Class
Grasshopper.GUI.Canvas Namespace


RenderGrips_Alternative Method

[image]

Grasshopper SDK
GH_CapsuleRenderEngine..::..RenderGrips_Alternative Method
GH_CapsuleRenderEngine Class See Also Send Feedback
Render all the grips associates with the capsule as semi-circles. This is needed if the capsule background is not fully opaque. Grips are not drawn if the zoom level is less than 50%. This is usually the first stage in a Capsule rendering.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RenderGrips_Alternative(
    Graphics G
)
Visual Basic
Public Sub RenderGrips_Alternative ( _
    G As Graphics _
)

Parameters

G
Type: System.Drawing..::..Graphics

See Also

GH_CapsuleRenderEngine Class
Grasshopper.GUI.Canvas Namespace


RenderHighlight Method

[image]

Grasshopper SDK
GH_CapsuleRenderEngine..::..RenderHighlight Method
GH_CapsuleRenderEngine Class See Also Send Feedback
Render a highlight bar. This is highly zoom-dependant. Highlight rendering is usually the fourth stage in a Capsule Rendering, after the background but prior to the edges.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RenderHighlight(
    Graphics G
)
Visual Basic
Public Sub RenderHighlight ( _
    G As Graphics _
)

Parameters

G
Type: System.Drawing..::..Graphics

See Also

GH_CapsuleRenderEngine Class
Grasshopper.GUI.Canvas Namespace


RenderIcon Method

[image] [image]

Grasshopper SDK
GH_CapsuleRenderEngine..::..RenderIcon Method
GH_CapsuleRenderEngine Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RenderIcon(Graphics, Image, Int32, Int32) | Render an image icon centered into the box. If the content box has been defined the icon will be centered there, otherwise the outline box will be used.
Public method | RenderIcon(Graphics, Image, RectangleF, Int32, Int32) | Render an image icon centered into the box. If the content box has been defined the icon will be centered there, otherwise the outline box will be used.

See Also

GH_CapsuleRenderEngine Class
GH_CapsuleRenderEngine Members
Grasshopper.GUI.Canvas Namespace


RenderIcon Method (Graphics, Image, Int32, Int32)

[image]

Grasshopper SDK
GH_CapsuleRenderEngine..::..RenderIcon Method (Graphics, Image, Int32, Int32)
GH_CapsuleRenderEngine Class See Also Send Feedback
Render an image icon centered into the box. If the content box has been defined the icon will be centered there, otherwise the outline box will be used.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RenderIcon(
    Graphics G,
    Image icon,
    int offsetX,
    int offsetY
)
Visual Basic
Public Sub RenderIcon ( _
    G As Graphics, _
    icon As Image, _
    offsetX As Integer, _
    offsetY As Integer _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics surface to draw onto.
icon
Type: System.Drawing..::..Image
Icon to draw.
offsetX
Type: System..::..Int32
Additional x-offset (in original pixel units).
offsetY
Type: System..::..Int32
Additional y-offset (in original pixel units).

See Also

GH_CapsuleRenderEngine Class
RenderIcon Overload
Grasshopper.GUI.Canvas Namespace


RenderIcon Method (Graphics, Image, RectangleF, Int32, Int32)

[image]

Grasshopper SDK
GH_CapsuleRenderEngine..::..RenderIcon Method (Graphics, Image, RectangleF, Int32, Int32)
GH_CapsuleRenderEngine Class See Also Send Feedback
Render an image icon centered into the box. If the content box has been defined the icon will be centered there, otherwise the outline box will be used.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RenderIcon(
    Graphics G,
    Image icon,
    RectangleF box,
    int offsetX,
    int offsetY
)
Visual Basic
Public Sub RenderIcon ( _
    G As Graphics, _
    icon As Image, _
    box As RectangleF, _
    offsetX As Integer, _
    offsetY As Integer _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics surface to draw onto.
icon
Type: System.Drawing..::..Image
Icon to draw.
box
Type: System.Drawing..::..RectangleF
Box override.
offsetX
Type: System..::..Int32
Additional x-offset (in original pixel units).
offsetY
Type: System..::..Int32
Additional y-offset (in original pixel units).

See Also

GH_CapsuleRenderEngine Class
RenderIcon Overload
Grasshopper.GUI.Canvas Namespace


RenderInputGrip Method

[image]

Grasshopper SDK
GH_CapsuleRenderEngine..::..RenderInputGrip Method
GH_CapsuleRenderEngine Class See Also Send Feedback
Static (Shared in VB) method to render a default input grip.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void RenderInputGrip(
    Graphics G,
    float zoom,
    PointF loc,
    bool full
)
Visual Basic
Public Shared Sub RenderInputGrip ( _
    G As Graphics, _
    zoom As Single, _
    loc As PointF, _
    full As Boolean _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics objects to draw with.
zoom
Type: System..::..Single
Zoom level of graphics surface.
loc
Type: System.Drawing..::..PointF
Location of grip.
full
Type: System..::..Boolean
If true, a complete circular grip will be draw. If false, a semi-circular grip will be drawn.

See Also

GH_CapsuleRenderEngine Class
Grasshopper.GUI.Canvas Namespace


RenderMessage Method

[image]

Grasshopper SDK
GH_CapsuleRenderEngine..::..RenderMessage Method
GH_CapsuleRenderEngine Class See Also Send Feedback
Render a text message underneath the capsule.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RenderMessage(
    Graphics G,
    string message,
    GH_PaletteStyle style
)
Visual Basic
Public Sub RenderMessage ( _
    G As Graphics, _
    message As String, _
    style As GH_PaletteStyle _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.
message
Type: System..::..String
Message to draw.
style
Type: Grasshopper.GUI.Canvas..::..GH_PaletteStyle
Style to use.

See Also

GH_CapsuleRenderEngine Class
Grasshopper.GUI.Canvas Namespace


RenderOutlines Method

[image]

Grasshopper SDK
GH_CapsuleRenderEngine..::..RenderOutlines Method
GH_CapsuleRenderEngine Class See Also Send Feedback
Render default capsule outlines. If the zoom factor is less than 50% the inner outline is not drawn. This is usually the fifth stage in a Capsule rendering.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RenderOutlines(
    Graphics G,
    float zoom,
    GH_PaletteStyle style
)
Visual Basic
Public Sub RenderOutlines ( _
    G As Graphics, _
    zoom As Single, _
    style As GH_PaletteStyle _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.
zoom
Type: System..::..Single
Zoom level of graphics object.
style
Type: Grasshopper.GUI.Canvas..::..GH_PaletteStyle
Palette style that defines edge properties.

See Also

GH_CapsuleRenderEngine Class
Grasshopper.GUI.Canvas Namespace


RenderOutputGrip Method

[image]

Grasshopper SDK
GH_CapsuleRenderEngine..::..RenderOutputGrip Method
GH_CapsuleRenderEngine Class See Also Send Feedback
Static (Shared in VB) method to render a default output grip.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void RenderOutputGrip(
    Graphics G,
    float zoom,
    PointF loc,
    bool full
)
Visual Basic
Public Shared Sub RenderOutputGrip ( _
    G As Graphics, _
    zoom As Single, _
    loc As PointF, _
    full As Boolean _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics objects to draw with.
zoom
Type: System..::..Single
Zoom level of graphics surface.
loc
Type: System.Drawing..::..PointF
Location of grip.
full
Type: System..::..Boolean
If true, a complete circular grip will be draw. If false, a semi-circular grip will be drawn.

See Also

GH_CapsuleRenderEngine Class
Grasshopper.GUI.Canvas Namespace


RenderText Method

[image]

Grasshopper SDK
GH_CapsuleRenderEngine..::..RenderText Method
GH_CapsuleRenderEngine Class See Also Send Feedback
Render the capsule text. This is usually the sixth and final stage in a capsule rendering.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RenderText(
    Graphics G,
    Color colour
)
Visual Basic
Public Sub RenderText ( _
    G As Graphics, _
    colour As Color _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.
colour
Type: System.Drawing..::..Color
Colour of text.

See Also

GH_CapsuleRenderEngine Class
Grasshopper.GUI.Canvas Namespace


GH_DocDiagramPainter Class

[image]

Grasshopper SDK
GH_DocDiagramPainter Class
Members See Also Send Feedback
This class paints diagrammatic images of a collection of objects.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_DocDiagramPainter
Visual Basic
Public Class GH_DocDiagramPainter

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI.Canvas..::..GH_DocDiagramPainter

See Also

GH_DocDiagramPainter Members
Grasshopper.GUI.Canvas Namespace


GH_DocDiagramPainter Members

[image] [image]

Grasshopper SDK
GH_DocDiagramPainter Members
GH_DocDiagramPainter Class Constructors Methods Properties See Also Send Feedback

The GH_DocDiagramPainter type exposes the following members.

Constructors

 | Name | Description
Public method | GH_DocDiagramPainter | Initializes a new instance of the GH_DocDiagramPainter class

Methods

 | Name | Description
Public method | MapPoint(Point) |
Public method | MapPoint(PointF) |
Public method | MapRectangle |
Public method | MapX(Int32) |
Public method | MapX(Single) |
Public method | MapY(Int32) |
Public method | MapY(Single) |
Public method | PaintDiagram(IEnumerable<(Of <<'(IGH_DocumentObject>)>>), Int32, Int32) | Paint a diagram of a document.
Public method | PaintDiagram(IEnumerable<(Of <<'(IGH_DocumentObject>)>>), Int32, Int32, Int32) | Paint a diagram of a document.
Public method | UnmapPoint |
Public method | UnmapRectangle |
Public method | UnmapX |
Public method | UnmapY |

Properties

 | Name | Description
Public property | BoundingBox | Gets the 2D domain of the diagram in canvas coordinates.
Public property | DrawingBox | Gets the 2D domain of the diagram in image coordinates.
Public property | IgnoreSelectedStates | Gets or sets the Ignore Selected State flag. When set to True, selected objects are not drawn in a different colour.
Public property | Image | Gets the diagram image (only available after a call to PaintDiagram().
Public property | Size | Gets the width and height (in pixels) of this diagram image.
Public property | Zoom | Gets the zoom factor for this diagram.

See Also

GH_DocDiagramPainter Class
Grasshopper.GUI.Canvas Namespace


GH_DocDiagramPainter Constructor

[image]

Grasshopper SDK
GH_DocDiagramPainter Constructor
GH_DocDiagramPainter Class See Also Send Feedback
Initializes a new instance of the GH_DocDiagramPainter class

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_DocDiagramPainter()
Visual Basic
Public Sub New

See Also

GH_DocDiagramPainter Class
Grasshopper.GUI.Canvas Namespace


GH_DocDiagramPainter Methods

[image] [image]

Grasshopper SDK
GH_DocDiagramPainter Methods
GH_DocDiagramPainter Class See Also Send Feedback

The GH_DocDiagramPainter type exposes the following members.

Methods

 | Name | Description
Public method | MapPoint(Point) |
Public method | MapPoint(PointF) |
Public method | MapRectangle |
Public method | MapX(Int32) |
Public method | MapX(Single) |
Public method | MapY(Int32) |
Public method | MapY(Single) |
Public method | PaintDiagram(IEnumerable<(Of <<'(IGH_DocumentObject>)>>), Int32, Int32) | Paint a diagram of a document.
Public method | PaintDiagram(IEnumerable<(Of <<'(IGH_DocumentObject>)>>), Int32, Int32, Int32) | Paint a diagram of a document.
Public method | UnmapPoint |
Public method | UnmapRectangle |
Public method | UnmapX |
Public method | UnmapY |

See Also

GH_DocDiagramPainter Class
Grasshopper.GUI.Canvas Namespace


MapPoint Method

[image] [image]

Grasshopper SDK
GH_DocDiagramPainter..::..MapPoint Method
GH_DocDiagramPainter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MapPoint(Point) |
Public method | MapPoint(PointF) |

See Also

GH_DocDiagramPainter Class
GH_DocDiagramPainter Members
Grasshopper.GUI.Canvas Namespace


MapPoint Method (Point)

[image]

Grasshopper SDK
GH_DocDiagramPainter..::..MapPoint Method (Point)
GH_DocDiagramPainter Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Point MapPoint(
    Point pt
)
Visual Basic
Public Function MapPoint ( _
    pt As Point _
) As Point

Parameters

pt
Type: System.Drawing..::..Point

See Also

GH_DocDiagramPainter Class
MapPoint Overload
Grasshopper.GUI.Canvas Namespace


MapPoint Method (PointF)

[image]

Grasshopper SDK
GH_DocDiagramPainter..::..MapPoint Method (PointF)
GH_DocDiagramPainter Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public PointF MapPoint(
    PointF pt
)
Visual Basic
Public Function MapPoint ( _
    pt As PointF _
) As PointF

Parameters

pt
Type: System.Drawing..::..PointF

See Also

GH_DocDiagramPainter Class
MapPoint Overload
Grasshopper.GUI.Canvas Namespace


MapRectangle Method

[image]

Grasshopper SDK
GH_DocDiagramPainter..::..MapRectangle Method
GH_DocDiagramPainter Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle MapRectangle(
    Rectangle rec
)
Visual Basic
Public Function MapRectangle ( _
    rec As Rectangle _
) As Rectangle

Parameters

rec
Type: System.Drawing..::..Rectangle

See Also

GH_DocDiagramPainter Class
Grasshopper.GUI.Canvas Namespace


MapX Method

[image] [image]

Grasshopper SDK
GH_DocDiagramPainter..::..MapX Method
GH_DocDiagramPainter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MapX(Int32) |
Public method | MapX(Single) |

See Also

GH_DocDiagramPainter Class
GH_DocDiagramPainter Members
Grasshopper.GUI.Canvas Namespace


MapX Method (Int32)

[image]

Grasshopper SDK
GH_DocDiagramPainter..::..MapX Method (Int32)
GH_DocDiagramPainter Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int MapX(
    int x
)
Visual Basic
Public Function MapX ( _
    x As Integer _
) As Integer

Parameters

x
Type: System..::..Int32

See Also

GH_DocDiagramPainter Class
MapX Overload
Grasshopper.GUI.Canvas Namespace


MapX Method (Single)

[image]

Grasshopper SDK
GH_DocDiagramPainter..::..MapX Method (Single)
GH_DocDiagramPainter Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public float MapX(
    float x
)
Visual Basic
Public Function MapX ( _
    x As Single _
) As Single

Parameters

x
Type: System..::..Single

See Also

GH_DocDiagramPainter Class
MapX Overload
Grasshopper.GUI.Canvas Namespace


MapY Method

[image] [image]

Grasshopper SDK
GH_DocDiagramPainter..::..MapY Method
GH_DocDiagramPainter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MapY(Int32) |
Public method | MapY(Single) |

See Also

GH_DocDiagramPainter Class
GH_DocDiagramPainter Members
Grasshopper.GUI.Canvas Namespace


MapY Method (Int32)

[image]

Grasshopper SDK
GH_DocDiagramPainter..::..MapY Method (Int32)
GH_DocDiagramPainter Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int MapY(
    int y
)
Visual Basic
Public Function MapY ( _
    y As Integer _
) As Integer

Parameters

y
Type: System..::..Int32

See Also

GH_DocDiagramPainter Class
MapY Overload
Grasshopper.GUI.Canvas Namespace


MapY Method (Single)

[image]

Grasshopper SDK
GH_DocDiagramPainter..::..MapY Method (Single)
GH_DocDiagramPainter Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public float MapY(
    float y
)
Visual Basic
Public Function MapY ( _
    y As Single _
) As Single

Parameters

y
Type: System..::..Single

See Also

GH_DocDiagramPainter Class
MapY Overload
Grasshopper.GUI.Canvas Namespace


PaintDiagram Method

[image] [image]

Grasshopper SDK
GH_DocDiagramPainter..::..PaintDiagram Method
GH_DocDiagramPainter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PaintDiagram(IEnumerable<(Of <<'(IGH_DocumentObject>)>>), Int32, Int32) | Paint a diagram of a document.
Public method | PaintDiagram(IEnumerable<(Of <<'(IGH_DocumentObject>)>>), Int32, Int32, Int32) | Paint a diagram of a document.

See Also

GH_DocDiagramPainter Class
GH_DocDiagramPainter Members
Grasshopper.GUI.Canvas Namespace


PaintDiagram Method (IEnumerable(IGH_DocumentObject), Int32, Int32)

[image]

Grasshopper SDK
GH_DocDiagramPainter..::..PaintDiagram Method (IEnumerable<(Of <(<'IGH_DocumentObject>)>)>, Int32, Int32)
GH_DocDiagramPainter Class See Also Send Feedback
Paint a diagram of a document.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool PaintDiagram(
    IEnumerable<IGH_DocumentObject> objs,
    int approx_size,
    int inflate
)
Visual Basic
Public Function PaintDiagram ( _
    objs As IEnumerable(Of IGH_DocumentObject), _
    approx_size As Integer, _
    inflate As Integer _
) As Boolean

Parameters

objs
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' IGH_DocumentObject >)>)>
Objects to paint.
approx_size
Type: System..::..Int32
Approximate size along each side.
inflate
Type: System..::..Int32
Padding around the objects.

Return Value

True on success, false on failure.

See Also

GH_DocDiagramPainter Class
PaintDiagram Overload
Grasshopper.GUI.Canvas Namespace


PaintDiagram Method (IEnumerable(IGH_DocumentObject), Int32, Int32, Int32)

[image]

Grasshopper SDK
GH_DocDiagramPainter..::..PaintDiagram Method (IEnumerable<(Of <(<'IGH_DocumentObject>)>)>, Int32, Int32, Int32)
GH_DocDiagramPainter Class See Also Send Feedback
Paint a diagram of a document.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool PaintDiagram(
    IEnumerable<IGH_DocumentObject> objs,
    int mapWidth,
    int mapHeight,
    int inflate
)
Visual Basic
Public Function PaintDiagram ( _
    objs As IEnumerable(Of IGH_DocumentObject), _
    mapWidth As Integer, _
    mapHeight As Integer, _
    inflate As Integer _
) As Boolean

Parameters

objs
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' IGH_DocumentObject >)>)>
Objects to paint.
mapWidth
Type: System..::..Int32
Width (in pixels) of diagram.
mapHeight
Type: System..::..Int32
Height (in pixels) of diagram.
inflate
Type: System..::..Int32
Padding around the objects.

Return Value

True on success, false on failure.

See Also

GH_DocDiagramPainter Class
PaintDiagram Overload
Grasshopper.GUI.Canvas Namespace


UnmapPoint Method

[image]

Grasshopper SDK
GH_DocDiagramPainter..::..UnmapPoint Method
GH_DocDiagramPainter Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Point UnmapPoint(
    Point pt
)
Visual Basic
Public Function UnmapPoint ( _
    pt As Point _
) As Point

Parameters

pt
Type: System.Drawing..::..Point

See Also

GH_DocDiagramPainter Class
Grasshopper.GUI.Canvas Namespace


UnmapRectangle Method

[image]

Grasshopper SDK
GH_DocDiagramPainter..::..UnmapRectangle Method
GH_DocDiagramPainter Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle UnmapRectangle(
    Rectangle rec
)
Visual Basic
Public Function UnmapRectangle ( _
    rec As Rectangle _
) As Rectangle

Parameters

rec
Type: System.Drawing..::..Rectangle

See Also

GH_DocDiagramPainter Class
Grasshopper.GUI.Canvas Namespace


UnmapX Method

[image]

Grasshopper SDK
GH_DocDiagramPainter..::..UnmapX Method
GH_DocDiagramPainter Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int UnmapX(
    int x
)
Visual Basic
Public Function UnmapX ( _
    x As Integer _
) As Integer

Parameters

x
Type: System..::..Int32

See Also

GH_DocDiagramPainter Class
Grasshopper.GUI.Canvas Namespace


UnmapY Method

[image]

Grasshopper SDK
GH_DocDiagramPainter..::..UnmapY Method
GH_DocDiagramPainter Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int UnmapY(
    int y
)
Visual Basic
Public Function UnmapY ( _
    y As Integer _
) As Integer

Parameters

y
Type: System..::..Int32

See Also

GH_DocDiagramPainter Class
Grasshopper.GUI.Canvas Namespace


GH_DocDiagramPainter Properties

[image] [image]

Grasshopper SDK
GH_DocDiagramPainter Properties
GH_DocDiagramPainter Class See Also Send Feedback

The GH_DocDiagramPainter type exposes the following members.

Properties

 | Name | Description
Public property | BoundingBox | Gets the 2D domain of the diagram in canvas coordinates.
Public property | DrawingBox | Gets the 2D domain of the diagram in image coordinates.
Public property | IgnoreSelectedStates | Gets or sets the Ignore Selected State flag. When set to True, selected objects are not drawn in a different colour.
Public property | Image | Gets the diagram image (only available after a call to PaintDiagram().
Public property | Size | Gets the width and height (in pixels) of this diagram image.
Public property | Zoom | Gets the zoom factor for this diagram.

See Also

GH_DocDiagramPainter Class
Grasshopper.GUI.Canvas Namespace


BoundingBox Property

[image]

Grasshopper SDK
GH_DocDiagramPainter..::..BoundingBox Property
GH_DocDiagramPainter Class See Also Send Feedback
Gets the 2D domain of the diagram in canvas coordinates.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public RectangleF BoundingBox { get; }
Visual Basic
Public ReadOnly Property BoundingBox As RectangleF
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_DocDiagramPainter.BoundingBox"]

See Also

GH_DocDiagramPainter Class
Grasshopper.GUI.Canvas Namespace


DrawingBox Property

[image]

Grasshopper SDK
GH_DocDiagramPainter..::..DrawingBox Property
GH_DocDiagramPainter Class See Also Send Feedback
Gets the 2D domain of the diagram in image coordinates.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle DrawingBox { get; }
Visual Basic
Public ReadOnly Property DrawingBox As Rectangle
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_DocDiagramPainter.DrawingBox"]

See Also

GH_DocDiagramPainter Class
Grasshopper.GUI.Canvas Namespace


IgnoreSelectedStates Property

[image]

Grasshopper SDK
GH_DocDiagramPainter..::..IgnoreSelectedStates Property
GH_DocDiagramPainter Class See Also Send Feedback
Gets or sets the Ignore Selected State flag. When set to True, selected objects are not drawn in a different colour.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IgnoreSelectedStates { get; set; }
Visual Basic
Public Property IgnoreSelectedStates As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_DocDiagramPainter.IgnoreSelectedStates"]

See Also

GH_DocDiagramPainter Class
Grasshopper.GUI.Canvas Namespace


Image Property

[image]

Grasshopper SDK
GH_DocDiagramPainter..::..Image Property
GH_DocDiagramPainter Class See Also Send Feedback
Gets the diagram image (only available after a call to PaintDiagram().

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Bitmap Image { get; }
Visual Basic
Public ReadOnly Property Image As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_DocDiagramPainter.Image"]

See Also

GH_DocDiagramPainter Class
Grasshopper.GUI.Canvas Namespace


Size Property

[image]

Grasshopper SDK
GH_DocDiagramPainter..::..Size Property
GH_DocDiagramPainter Class See Also Send Feedback
Gets the width and height (in pixels) of this diagram image.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Size Size { get; }
Visual Basic
Public ReadOnly Property Size As Size
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_DocDiagramPainter.Size"]

See Also

GH_DocDiagramPainter Class
Grasshopper.GUI.Canvas Namespace


Zoom Property

[image]

Grasshopper SDK
GH_DocDiagramPainter..::..Zoom Property
GH_DocDiagramPainter Class See Also Send Feedback
Gets the zoom factor for this diagram.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public float Zoom { get; }
Visual Basic
Public ReadOnly Property Zoom As Single
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_DocDiagramPainter.Zoom"]

See Also

GH_DocDiagramPainter Class
Grasshopper.GUI.Canvas Namespace


GH_DragDropFileAction Enumeration

[image]

Grasshopper SDK
GH_DragDropFileAction Enumeration
See Also Send Feedback
Enumerates the possible actions for drag+drop loading ghx files.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_DragDropFileAction
Visual Basic
Public Enumeration GH_DragDropFileAction

Members

Member name | Value | Description
None | 0 | Indicates no action is defined.
Open | 1 | Open the file(s) as a new document.
Examine | 2 | Examine the file(s) using GHViewer.exe
Insert | 3 | Insert the file(s) into the current document.
Group | 4 | Insert the file(s) into the current document as separate groups.
Cluster | 5 | Insert the file(s) into the current document as clusters.

See Also

Grasshopper.GUI.Canvas Namespace


GH_NamedView Class

[image]

Grasshopper SDK
GH_NamedView Class
Members See Also Send Feedback
Named views are used both to store named views but also to allow smooth programmatic canvas navigation.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_NamedView : GH_ISerializable
Visual Basic
Public Class GH_NamedView _
    Implements GH_ISerializable

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI.Canvas..::..GH_NamedView

See Also

GH_NamedView Members
Grasshopper.GUI.Canvas Namespace


GH_NamedView Members

[image] [image]

Grasshopper SDK
GH_NamedView Members
GH_NamedView Class Constructors Methods Properties Events See Also Send Feedback

The GH_NamedView type exposes the following members.

Constructors

 | Name | Description
Public method | GH_NamedView()()()() | Create a default named view.
Public method | GH_NamedView(Rectangle, RectangleF) | Create a new view useful for box-fit transitions.
Public method | GH_NamedView(GH_Viewport, Point, PointF) | Create a new view useful for point match transitions.
Public method | GH_NamedView(GH_Viewport, Rectangle, PointF) | Create a new view useful for point inclusion transitions.
Public method | GH_NamedView(String, PointF, Single, GH_NamedViewType) | Create a new named view.

Methods

 | Name | Description
Public method | LoadFromViewport | Create a named view from a viewport.
Public method | Read |
Public method | SetToViewport(GH_Canvas) | Set the named view to the canvas viewport and redraw the canvas.
Public method | SetToViewport(GH_Viewport) | Set the named view to a viewport.
Public method | SetToViewport(GH_Canvas, Int32) | Animates a view transition.
Public method | Write |

Properties

 | Name | Description
Public property | Name | Gets or sets the name of the view.
Public property | Point | Gets or sets the anchor point of the named view.
Public property | Type | Gets or sets a value indicating whether the anchor point represents the target or the center.
Public property | Zoom | Gets or sets the zoom factor of the named view.

Events

 | Name | Description
Public event | SmoothFrame | This event is raised during smooth animations.

See Also

GH_NamedView Class
Grasshopper.GUI.Canvas Namespace


GH_NamedView Constructor

[image] [image]

Grasshopper SDK
GH_NamedView Constructor
GH_NamedView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_NamedView()()()() | Create a default named view.
Public method | GH_NamedView(Rectangle, RectangleF) | Create a new view useful for box-fit transitions.
Public method | GH_NamedView(GH_Viewport, Point, PointF) | Create a new view useful for point match transitions.
Public method | GH_NamedView(GH_Viewport, Rectangle, PointF) | Create a new view useful for point inclusion transitions.
Public method | GH_NamedView(String, PointF, Single, GH_NamedViewType) | Create a new named view.

See Also

GH_NamedView Class
GH_NamedView Members
Grasshopper.GUI.Canvas Namespace


GH_NamedView Constructor

[image]

Grasshopper SDK
GH_NamedView Constructor
GH_NamedView Class See Also Send Feedback
Create a default named view.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_NamedView()
Visual Basic
Public Sub New

See Also

GH_NamedView Class
GH_NamedView Overload
Grasshopper.GUI.Canvas Namespace


GH_NamedView Constructor (Rectangle, RectangleF)

[image]

Grasshopper SDK
GH_NamedView Constructor (Rectangle, RectangleF)
GH_NamedView Class See Also Send Feedback
Create a new view useful for box-fit transitions.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_NamedView(
    Rectangle view_box,
    RectangleF target_box
)
Visual Basic
Public Sub New ( _
    view_box As Rectangle, _
    target_box As RectangleF _
)

Parameters

view_box
Type: System.Drawing..::..Rectangle
The dimensions of the area into which we want to display something in control coordinates. For example, the Visible area in a Viewport.
target_box
Type: System.Drawing..::..RectangleF
The dimensions of the area we want to display in viewport coordinates. For example, the bounding box of some objects.

See Also

GH_NamedView Class
GH_NamedView Overload
Grasshopper.GUI.Canvas Namespace


GH_NamedView Constructor (GH_Viewport, Point, PointF)

[image]

Grasshopper SDK
GH_NamedView Constructor (GH_Viewport, Point, PointF)
GH_NamedView Class See Also Send Feedback
Create a new view useful for point match transitions.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_NamedView(
    GH_Viewport view,
    Point point,
    PointF target
)
Visual Basic
Public Sub New ( _
    view As GH_Viewport, _
    point As Point, _
    target As PointF _
)

Parameters

view
Type: Grasshopper.GUI.Canvas..::..GH_Viewport
Viewport this transition is supposed to work in.
point
Type: System.Drawing..::..Point
Point in control coordinates that is supposed to be matched.
target
Type: System.Drawing..::..PointF
Point in canvas coordinates that will be matched.

See Also

GH_NamedView Class
GH_NamedView Overload
Grasshopper.GUI.Canvas Namespace


GH_NamedView Constructor (GH_Viewport, Rectangle, PointF)

[image]

Grasshopper SDK
GH_NamedView Constructor (GH_Viewport, Rectangle, PointF)
GH_NamedView Class See Also Send Feedback
Create a new view useful for point inclusion transitions.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_NamedView(
    GH_Viewport view,
    Rectangle region,
    PointF target
)
Visual Basic
Public Sub New ( _
    view As GH_Viewport, _
    region As Rectangle, _
    target As PointF _
)

Parameters

view
Type: Grasshopper.GUI.Canvas..::..GH_Viewport
Viewport this transition is supposed to work in.
region
Type: System.Drawing..::..Rectangle
Region into which the target is supposed to be visible in control coordinates. For example, the contents of the viewport.
target
Type: System.Drawing..::..PointF
Point to ensure.

See Also

GH_NamedView Class
GH_NamedView Overload
Grasshopper.GUI.Canvas Namespace


GH_NamedView Constructor (String, PointF, Single, GH_NamedViewType)

[image]

Grasshopper SDK
GH_NamedView Constructor (String, PointF, Single, GH_NamedViewType)
GH_NamedView Class See Also Send Feedback
Create a new named view.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_NamedView(
    string view_name,
    PointF view_point,
    float view_zoom,
    GH_NamedViewType view_type
)
Visual Basic
Public Sub New ( _
    view_name As String, _
    view_point As PointF, _
    view_zoom As Single, _
    view_type As GH_NamedViewType _
)

Parameters

view_name
Type: System..::..String
Name of view.
view_point
Type: System.Drawing..::..PointF
Anchor point of named view.
view_zoom
Type: System..::..Single
Zoom factor of named view.
view_type
Type: Grasshopper.GUI.Canvas..::..GH_NamedViewType
The type of named view.

See Also

GH_NamedView Class
GH_NamedView Overload
Grasshopper.GUI.Canvas Namespace


GH_NamedView Methods

[image] [image]

Grasshopper SDK
GH_NamedView Methods
GH_NamedView Class See Also Send Feedback

The GH_NamedView type exposes the following members.

Methods

 | Name | Description
Public method | LoadFromViewport | Create a named view from a viewport.
Public method | Read |
Public method | SetToViewport(GH_Canvas) | Set the named view to the canvas viewport and redraw the canvas.
Public method | SetToViewport(GH_Viewport) | Set the named view to a viewport.
Public method | SetToViewport(GH_Canvas, Int32) | Animates a view transition.
Public method | Write |

See Also

GH_NamedView Class
Grasshopper.GUI.Canvas Namespace


LoadFromViewport Method

[image]

Grasshopper SDK
GH_NamedView..::..LoadFromViewport Method
GH_NamedView Class See Also Send Feedback
Create a named view from a viewport.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void LoadFromViewport(
    GH_Viewport vp,
    GH_NamedViewType view_type
)
Visual Basic
Public Sub LoadFromViewport ( _
    vp As GH_Viewport, _
    view_type As GH_NamedViewType _
)

Parameters

vp
Type: Grasshopper.GUI.Canvas..::..GH_Viewport
Viewport to mimic.
view_type
Type: Grasshopper.GUI.Canvas..::..GH_NamedViewType
Type of named view to create.

See Also

GH_NamedView Class
Grasshopper.GUI.Canvas Namespace


Read Method

[image]

Grasshopper SDK
GH_NamedView..::..Read Method
GH_NamedView Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Read(
    GH_IReader reader
)
Visual Basic
Public Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

Implements

GH_ISerializable..::..Read(GH_IReader)

See Also

GH_NamedView Class
Grasshopper.GUI.Canvas Namespace


SetToViewport Method

[image] [image]

Grasshopper SDK
GH_NamedView..::..SetToViewport Method
GH_NamedView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetToViewport(GH_Canvas) | Set the named view to the canvas viewport and redraw the canvas.
Public method | SetToViewport(GH_Viewport) | Set the named view to a viewport.
Public method | SetToViewport(GH_Canvas, Int32) | Animates a view transition.

See Also

GH_NamedView Class
GH_NamedView Members
Grasshopper.GUI.Canvas Namespace


SetToViewport Method (GH_Canvas)

[image]

Grasshopper SDK
GH_NamedView..::..SetToViewport Method (GH_Canvas)
GH_NamedView Class See Also Send Feedback
Set the named view to the canvas viewport and redraw the canvas.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SetToViewport(
    GH_Canvas cv
)
Visual Basic
Public Sub SetToViewport ( _
    cv As GH_Canvas _
)

Parameters

cv
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
Canvas to set

See Also

GH_NamedView Class
SetToViewport Overload
Grasshopper.GUI.Canvas Namespace


SetToViewport Method (GH_Viewport)

[image]

Grasshopper SDK
GH_NamedView..::..SetToViewport Method (GH_Viewport)
GH_NamedView Class See Also Send Feedback
Set the named view to a viewport.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SetToViewport(
    GH_Viewport vp
)
Visual Basic
Public Sub SetToViewport ( _
    vp As GH_Viewport _
)

Parameters

vp
Type: Grasshopper.GUI.Canvas..::..GH_Viewport
Viewport to set.

See Also

GH_NamedView Class
SetToViewport Overload
Grasshopper.GUI.Canvas Namespace


SetToViewport Method (GH_Canvas, Int32)

[image]

Grasshopper SDK
GH_NamedView..::..SetToViewport Method (GH_Canvas, Int32)
GH_NamedView Class See Also Send Feedback
Animates a view transition.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SetToViewport(
    GH_Canvas cv,
    int length
)
Visual Basic
Public Sub SetToViewport ( _
    cv As GH_Canvas, _
    length As Integer _
)

Parameters

cv
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
Canvas to apply the transition to.
length
Type: System..::..Int32
Length (in milliseconds) of the transition.

See Also

GH_NamedView Class
SetToViewport Overload
Grasshopper.GUI.Canvas Namespace


Write Method

[image]

Grasshopper SDK
GH_NamedView..::..Write Method
GH_NamedView Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Write(
    GH_IWriter writer
)
Visual Basic
Public Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

Implements

GH_ISerializable..::..Write(GH_IWriter)

See Also

GH_NamedView Class
Grasshopper.GUI.Canvas Namespace


GH_NamedView Properties

[image] [image]

Grasshopper SDK
GH_NamedView Properties
GH_NamedView Class See Also Send Feedback

The GH_NamedView type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets or sets the name of the view.
Public property | Point | Gets or sets the anchor point of the named view.
Public property | Type | Gets or sets a value indicating whether the anchor point represents the target or the center.
Public property | Zoom | Gets or sets the zoom factor of the named view.

See Also

GH_NamedView Class
Grasshopper.GUI.Canvas Namespace


Name Property

[image]

Grasshopper SDK
GH_NamedView..::..Name Property
GH_NamedView Class See Also Send Feedback
Gets or sets the name of the view.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_NamedView.Name"]

See Also

GH_NamedView Class
Grasshopper.GUI.Canvas Namespace


Point Property

[image]

Grasshopper SDK
GH_NamedView..::..Point Property
GH_NamedView Class See Also Send Feedback
Gets or sets the anchor point of the named view.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public PointF Point { get; set; }
Visual Basic
Public Property Point As PointF
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_NamedView.Point"]

See Also

GH_NamedView Class
Grasshopper.GUI.Canvas Namespace


Type Property

[image]

Grasshopper SDK
GH_NamedView..::..Type Property
GH_NamedView Class See Also Send Feedback
Gets or sets a value indicating whether the anchor point represents the target or the center.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_NamedViewType Type { get; set; }
Visual Basic
Public Property Type As GH_NamedViewType
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_NamedView.Type"]

See Also

GH_NamedView Class
Grasshopper.GUI.Canvas Namespace


Zoom Property

[image]

Grasshopper SDK
GH_NamedView..::..Zoom Property
GH_NamedView Class See Also Send Feedback
Gets or sets the zoom factor of the named view.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public float Zoom { get; set; }
Visual Basic
Public Property Zoom As Single
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_NamedView.Zoom"]

See Also

GH_NamedView Class
Grasshopper.GUI.Canvas Namespace


GH_NamedView Events

[image] [image]

Grasshopper SDK
GH_NamedView Events
GH_NamedView Class See Also Send Feedback

The GH_NamedView type exposes the following members.

Events

 | Name | Description
Public event | SmoothFrame | This event is raised during smooth animations.

See Also

GH_NamedView Class
Grasshopper.GUI.Canvas Namespace


SmoothFrame Event

[image]

Grasshopper SDK
GH_NamedView..::..SmoothFrame Event
GH_NamedView Class See Also Send Feedback
This event is raised during smooth animations.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_NamedView..::..SmoothFrameEventHandler SmoothFrame
Visual Basic
Public Event SmoothFrame As GH_NamedView..::..SmoothFrameEventHandler

See Also

GH_NamedView Class
Grasshopper.GUI.Canvas Namespace


GH_NamedView.SmoothFrameEventHandler Delegate

[image]

Grasshopper SDK
GH_NamedView..::..SmoothFrameEventHandler Delegate
GH_NamedView Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void SmoothFrameEventHandler(
    GH_NamedView sender,
    GH_Canvas canvas
)
Visual Basic
Public Delegate Sub SmoothFrameEventHandler ( _
    sender As GH_NamedView, _
    canvas As GH_Canvas _
)

Parameters

sender
Type: Grasshopper.GUI.Canvas..::..GH_NamedView
canvas
Type: Grasshopper.GUI.Canvas..::..GH_Canvas

See Also

Grasshopper.GUI.Canvas Namespace


GH_NamedViewType Enumeration

[image]

Grasshopper SDK
GH_NamedViewType Enumeration
See Also Send Feedback
Types of named view anchor points.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_NamedViewType
Visual Basic
Public Enumeration GH_NamedViewType

Members

Member name | Value | Description
target | 0 | Anchor represents the location of the target (the canvas origin).
center | 1 | Anchor represents the point that is supposed to end up in the middle of the canvas.

See Also

Grasshopper.GUI.Canvas Namespace


GH_ObjectResponse Enumeration

[image]

Grasshopper SDK
GH_ObjectResponse Enumeration
See Also Send Feedback
Lists the possible responses an object can give when confronted with a UI event.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_ObjectResponse
Visual Basic
Public Enumeration GH_ObjectResponse

Members

Member name | Value | Description
Ignore | 0 | Event was ignored.
Capture | 1 | Event caused the object to become active.
Release | 2 | Object was active, but event caused object to become inactive.
Handled | 3 | Something happened, but no capture is needed.

See Also

Grasshopper.GUI.Canvas Namespace


GH_Orientation Enumeration

[image]

Grasshopper SDK
GH_Orientation Enumeration
See Also Send Feedback
Enumerates possible alignments.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_Orientation
Visual Basic
Public Enumeration GH_Orientation

Members

Member name | Value | Description
horizontal_center | 0 | Text is drawn horizontally, centered in the middle of the context.
horizontal_near | 1 | Text is drawn horizontally, aligned near to the context edge.
horizontal_far | 2 | Text is drawn horizontally, aligned far from the context edge.
vertical_center | 10 | Text is drawn vertically, centered in the middle of the context.
vertical_near | 11 | Text is drawn vertically, aligned near to the context edge.
vertical_far | 12 | Text is drawn vertically, aligned far from the context edge.

See Also

Grasshopper.GUI.Canvas Namespace


GH_Painter Class

[image]

Grasshopper SDK
GH_Painter Class
Members See Also Send Feedback
This class performs most of the drawing operations required for Grasshopper Canvas controls.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Painter
Visual Basic
Public Class GH_Painter

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI.Canvas..::..GH_Painter

See Also

GH_Painter Members
Grasshopper.GUI.Canvas Namespace


GH_Painter Members

[image] [image]

Grasshopper SDK
GH_Painter Members
GH_Painter Class Constructors Methods See Also Send Feedback

The GH_Painter type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Painter | Constructor.

Methods

 | Name | Description
 | ConnectionPath |
Public method | ConnectionVisible | Test whether a wire ought to be drawn at all.
 | DetermineWireType | Utility method for determining wire display types.
Public method | DrawBackground |
Public method | DrawConnection |
Public method | DrawMiddleGround |
Public method | DrawNoDocumentMessage |
Public method | DrawNULLBuffer |
Public method | DrawPivots |
Public method | DrawRecipientLinks(GH_Document) |
Protected method | DrawRecipientLinks(IGH_Param) |
Public method | DrawStateFlags |
Public method | GenerateWirePen_Fill |

See Also

GH_Painter Class
Grasshopper.GUI.Canvas Namespace


GH_Painter Constructor

[image]

Grasshopper SDK
GH_Painter Constructor
GH_Painter Class See Also Send Feedback
Constructor.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Painter(
    GH_Canvas owner
)
Visual Basic
Public Sub New ( _
    owner As GH_Canvas _
)

Parameters

owner
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
Canvas that owns this painter object.

See Also

GH_Painter Class
Grasshopper.GUI.Canvas Namespace


GH_Painter Methods

[image] [image]

Grasshopper SDK
GH_Painter Methods
GH_Painter Class See Also Send Feedback

The GH_Painter type exposes the following members.

Methods

 | Name | Description
 | ConnectionPath |
Public method | ConnectionVisible | Test whether a wire ought to be drawn at all.
 | DetermineWireType | Utility method for determining wire display types.
Public method | DrawBackground |
Public method | DrawConnection |
Public method | DrawMiddleGround |
Public method | DrawNoDocumentMessage |
Public method | DrawNULLBuffer |
Public method | DrawPivots |
Public method | DrawRecipientLinks(GH_Document) |
Protected method | DrawRecipientLinks(IGH_Param) |
Public method | DrawStateFlags |
Public method | GenerateWirePen_Fill |

See Also

GH_Painter Class
Grasshopper.GUI.Canvas Namespace


ConnectionPath Method

[image]

Grasshopper SDK
GH_Painter..::..ConnectionPath Method
GH_Painter Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GraphicsPath ConnectionPath(
    PointF A,
    PointF B,
    GH_WireDirection ADir,
    GH_WireDirection BDir
)
Visual Basic
Public Shared Function ConnectionPath ( _
    A As PointF, _
    B As PointF, _
    ADir As GH_WireDirection, _
    BDir As GH_WireDirection _
) As GraphicsPath

Parameters

A
Type: System.Drawing..::..PointF
B
Type: System.Drawing..::..PointF
ADir
Type: Grasshopper.GUI.Canvas..::..GH_WireDirection
BDir
Type: Grasshopper.GUI.Canvas..::..GH_WireDirection

See Also

GH_Painter Class
Grasshopper.GUI.Canvas Namespace


ConnectionVisible Method

[image]

Grasshopper SDK
GH_Painter..::..ConnectionVisible Method
GH_Painter Class See Also Send Feedback
Test whether a wire ought to be drawn at all.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool ConnectionVisible(
    PointF a,
    PointF b
)
Visual Basic
Public Function ConnectionVisible ( _
    a As PointF, _
    b As PointF _
) As Boolean

Parameters

a
Type: System.Drawing..::..PointF
Start point of wire.
b
Type: System.Drawing..::..PointF
End point of wire.

Return Value

True if the wire is visible and ought to be drawn.

See Also

GH_Painter Class
Grasshopper.GUI.Canvas Namespace


DetermineWireType Method

[image]

Grasshopper SDK
GH_Painter..::..DetermineWireType Method
GH_Painter Class See Also Send Feedback
Utility method for determining wire display types.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_WireType DetermineWireType(
    IGH_Structure target
)
Visual Basic
Public Shared Function DetermineWireType ( _
    target As IGH_Structure _
) As GH_WireType

Parameters

target
Type: Grasshopper.Kernel.Data..::..IGH_Structure
Pointer to transfer data.

See Also

GH_Painter Class
Grasshopper.GUI.Canvas Namespace


DrawBackground Method

[image]

Grasshopper SDK
GH_Painter..::..DrawBackground Method
GH_Painter Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DrawBackground(
    GH_Viewport viewport
)
Visual Basic
Public Sub DrawBackground ( _
    viewport As GH_Viewport _
)

Parameters

viewport
Type: Grasshopper.GUI.Canvas..::..GH_Viewport

See Also

GH_Painter Class
Grasshopper.GUI.Canvas Namespace


DrawConnection Method

[image]

Grasshopper SDK
GH_Painter..::..DrawConnection Method
GH_Painter Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DrawConnection(
    PointF a,
    PointF b,
    GH_WireDirection adir,
    GH_WireDirection bdir,
    bool asel,
    bool bsel,
    GH_WireType type
)
Visual Basic
Public Sub DrawConnection ( _
    a As PointF, _
    b As PointF, _
    adir As GH_WireDirection, _
    bdir As GH_WireDirection, _
    asel As Boolean, _
    bsel As Boolean, _
    type As GH_WireType _
)

Parameters

a
Type: System.Drawing..::..PointF
b
Type: System.Drawing..::..PointF
adir
Type: Grasshopper.GUI.Canvas..::..GH_WireDirection
bdir
Type: Grasshopper.GUI.Canvas..::..GH_WireDirection
asel
Type: System..::..Boolean
bsel
Type: System..::..Boolean
type
Type: Grasshopper.GUI.Canvas..::..GH_WireType

See Also

GH_Painter Class
Grasshopper.GUI.Canvas Namespace


DrawMiddleGround Method

[image]

Grasshopper SDK
GH_Painter..::..DrawMiddleGround Method
GH_Painter Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DrawMiddleGround(
    GH_Document doc,
    GH_CanvasChannel channel
)
Visual Basic
Public Sub DrawMiddleGround ( _
    doc As GH_Document, _
    channel As GH_CanvasChannel _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document
channel
Type: Grasshopper.GUI.Canvas..::..GH_CanvasChannel

See Also

GH_Painter Class
Grasshopper.GUI.Canvas Namespace


DrawNoDocumentMessage Method

[image]

Grasshopper SDK
GH_Painter..::..DrawNoDocumentMessage Method
GH_Painter Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DrawNoDocumentMessage()
Visual Basic
Public Sub DrawNoDocumentMessage

See Also

GH_Painter Class
Grasshopper.GUI.Canvas Namespace


DrawNULLBuffer Method

[image]

Grasshopper SDK
GH_Painter..::..DrawNULLBuffer Method
GH_Painter Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DrawNULLBuffer()
Visual Basic
Public Sub DrawNULLBuffer

See Also

GH_Painter Class
Grasshopper.GUI.Canvas Namespace


DrawPivots Method

[image]

Grasshopper SDK
GH_Painter..::..DrawPivots Method
GH_Painter Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DrawPivots(
    GH_Document doc
)
Visual Basic
Public Sub DrawPivots ( _
    doc As GH_Document _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document

See Also

GH_Painter Class
Grasshopper.GUI.Canvas Namespace


DrawRecipientLinks Method

[image] [image]

Grasshopper SDK
GH_Painter..::..DrawRecipientLinks Method
GH_Painter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawRecipientLinks(GH_Document) |
Protected method | DrawRecipientLinks(IGH_Param) |

See Also

GH_Painter Class
GH_Painter Members
Grasshopper.GUI.Canvas Namespace


DrawRecipientLinks Method (GH_Document)

[image]

Grasshopper SDK
GH_Painter..::..DrawRecipientLinks Method (GH_Document)
GH_Painter Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DrawRecipientLinks(
    GH_Document doc
)
Visual Basic
Public Sub DrawRecipientLinks ( _
    doc As GH_Document _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document

See Also

GH_Painter Class
DrawRecipientLinks Overload
Grasshopper.GUI.Canvas Namespace


DrawRecipientLinks Method (IGH_Param)

[image]

Grasshopper SDK
GH_Painter..::..DrawRecipientLinks Method (IGH_Param)
GH_Painter Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected void DrawRecipientLinks(
    IGH_Param param
)
Visual Basic
Protected Sub DrawRecipientLinks ( _
    param As IGH_Param _
)

Parameters

param
Type: Grasshopper.Kernel..::..IGH_Param

See Also

GH_Painter Class
DrawRecipientLinks Overload
Grasshopper.GUI.Canvas Namespace


DrawStateFlags Method

[image]

Grasshopper SDK
GH_Painter..::..DrawStateFlags Method
GH_Painter Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DrawStateFlags(
    GH_Document doc
)
Visual Basic
Public Sub DrawStateFlags ( _
    doc As GH_Document _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document

See Also

GH_Painter Class
Grasshopper.GUI.Canvas Namespace


GenerateWirePen_Fill Method

[image]

Grasshopper SDK
GH_Painter..::..GenerateWirePen_Fill Method
GH_Painter Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Brush GenerateWirePen_Fill(
    PointF a,
    PointF b,
    bool asel,
    bool bsel,
    bool empty
)
Visual Basic
Public Function GenerateWirePen_Fill ( _
    a As PointF, _
    b As PointF, _
    asel As Boolean, _
    bsel As Boolean, _
    empty As Boolean _
) As Brush

Parameters

a
Type: System.Drawing..::..PointF
b
Type: System.Drawing..::..PointF
asel
Type: System..::..Boolean
bsel
Type: System..::..Boolean
empty
Type: System..::..Boolean

See Also

GH_Painter Class
Grasshopper.GUI.Canvas Namespace


GH_Palette Enumeration

[image]

Grasshopper SDK
GH_Palette Enumeration
See Also Send Feedback
Lists all possible Capsule Palette styles in Grasshopper.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_Palette
Visual Basic
Public Enumeration GH_Palette

Members

Member name | Value | Description
Normal | 0 |
Hidden | 1 |
Locked | 2 |
Warning | 3 |
Error | 4 |
White | 5 |
Grey | 6 |
Black | 7 |
Brown | 8 |
Pink | 9 |
Blue | 10 |
Transparent | 11 |

See Also

Grasshopper.GUI.Canvas Namespace


GH_PaletteStyle Class

[image]

Grasshopper SDK
GH_PaletteStyle Class
Members See Also Send Feedback
Contains all the colours for a single capsule palette.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_PaletteStyle
Visual Basic
Public Class GH_PaletteStyle

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI.Canvas..::..GH_PaletteStyle

See Also

GH_PaletteStyle Members
Grasshopper.GUI.Canvas Namespace


GH_PaletteStyle Members

[image] [image]

Grasshopper SDK
GH_PaletteStyle Members
GH_PaletteStyle Class Constructors Methods Fields Properties See Also Send Feedback

The GH_PaletteStyle type exposes the following members.

Constructors

 | Name | Description
Public method | GH_PaletteStyle(Color) | Construct a new GH_Box_Palette_Colours instance with a single base colour.
Public method | GH_PaletteStyle(Color, Color) | Construct a new GH_Box_Palette_Colours instance.
Public method | GH_PaletteStyle(Color, Color, Color) | Construct a new GH_Box_Palette_Colours instance.

Methods

 | Name | Description
Public method | CreateBrush | Create a fill brush. At low zoom levels the brush will be solid colour, at medium to high zoom levels the brush will have a gradient.

Fields

 | Name | Description
Public field | m_edge | Obsolete.
Public field | m_fill | Obsolete.
Public field | m_text | Obsolete.

Properties

 | Name | Description
Public property | Edge | Gets or sets the edge of this style.
Public property | Fill | Gets or sets the fill of this style.
Public property | Text | Gets or sets the text of this style.

See Also

GH_PaletteStyle Class
Grasshopper.GUI.Canvas Namespace


GH_PaletteStyle Constructor

[image] [image]

Grasshopper SDK
GH_PaletteStyle Constructor
GH_PaletteStyle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_PaletteStyle(Color) | Construct a new GH_Box_Palette_Colours instance with a single base colour.
Public method | GH_PaletteStyle(Color, Color) | Construct a new GH_Box_Palette_Colours instance.
Public method | GH_PaletteStyle(Color, Color, Color) | Construct a new GH_Box_Palette_Colours instance.

See Also

GH_PaletteStyle Class
GH_PaletteStyle Members
Grasshopper.GUI.Canvas Namespace


GH_PaletteStyle Constructor (Color)

[image]

Grasshopper SDK
GH_PaletteStyle Constructor (Color)
GH_PaletteStyle Class See Also Send Feedback
Construct a new GH_Box_Palette_Colours instance with a single base colour.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PaletteStyle(
    Color fill
)
Visual Basic
Public Sub New ( _
    fill As Color _
)

Parameters

fill
Type: System.Drawing..::..Color
Colour to use for background fills. All other colours are computed based on this colour.

See Also

GH_PaletteStyle Class
GH_PaletteStyle Overload
Grasshopper.GUI.Canvas Namespace


GH_PaletteStyle Constructor (Color, Color)

[image]

Grasshopper SDK
GH_PaletteStyle Constructor (Color, Color)
GH_PaletteStyle Class See Also Send Feedback
Construct a new GH_Box_Palette_Colours instance.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PaletteStyle(
    Color fill,
    Color edge
)
Visual Basic
Public Sub New ( _
    fill As Color, _
    edge As Color _
)

Parameters

fill
Type: System.Drawing..::..Color
Colour to use for background fills.
edge
Type: System.Drawing..::..Color
Colour to use for edges.

See Also

GH_PaletteStyle Class
GH_PaletteStyle Overload
Grasshopper.GUI.Canvas Namespace


GH_PaletteStyle Constructor (Color, Color, Color)

[image]

Grasshopper SDK
GH_PaletteStyle Constructor (Color, Color, Color)
GH_PaletteStyle Class See Also Send Feedback
Construct a new GH_Box_Palette_Colours instance.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PaletteStyle(
    Color fill,
    Color edge,
    Color text
)
Visual Basic
Public Sub New ( _
    fill As Color, _
    edge As Color, _
    text As Color _
)

Parameters

fill
Type: System.Drawing..::..Color
Colour to use for background fills.
edge
Type: System.Drawing..::..Color
Colour to use for edges.
text
Type: System.Drawing..::..Color
Colour to use for text objects.

See Also

GH_PaletteStyle Class
GH_PaletteStyle Overload
Grasshopper.GUI.Canvas Namespace


GH_PaletteStyle Fields

[image] [image]

Grasshopper SDK
GH_PaletteStyle Fields
GH_PaletteStyle Class See Also Send Feedback

The GH_PaletteStyle type exposes the following members.

Fields

 | Name | Description
Public field | m_edge | Obsolete.
Public field | m_fill | Obsolete.
Public field | m_text | Obsolete.

See Also

GH_PaletteStyle Class
Grasshopper.GUI.Canvas Namespace


m_edge Field

[image]

Grasshopper SDK
GH_PaletteStyle..::..m_edge Field
GH_PaletteStyle Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
[ObsoleteAttribute("This field has been replaced with the Edge property")]
public Color m_edge
Visual Basic
<ObsoleteAttribute("This field has been replaced with the Edge property")> _
Public m_edge As Color

See Also

GH_PaletteStyle Class
Grasshopper.GUI.Canvas Namespace


m_fill Field

[image]

Grasshopper SDK
GH_PaletteStyle..::..m_fill Field
GH_PaletteStyle Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
[ObsoleteAttribute("This field has been replaced with the Fill property")]
public Color m_fill
Visual Basic
<ObsoleteAttribute("This field has been replaced with the Fill property")> _
Public m_fill As Color

See Also

GH_PaletteStyle Class
Grasshopper.GUI.Canvas Namespace


m_text Field

[image]

Grasshopper SDK
GH_PaletteStyle..::..m_text Field
GH_PaletteStyle Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
[ObsoleteAttribute("This field has been replaced with the Text property")]
public Color m_text
Visual Basic
<ObsoleteAttribute("This field has been replaced with the Text property")> _
Public m_text As Color

See Also

GH_PaletteStyle Class
Grasshopper.GUI.Canvas Namespace


GH_PaletteStyle Methods

[image] [image]

Grasshopper SDK
GH_PaletteStyle Methods
GH_PaletteStyle Class See Also Send Feedback

The GH_PaletteStyle type exposes the following members.

Methods

 | Name | Description
Public method | CreateBrush | Create a fill brush. At low zoom levels the brush will be solid colour, at medium to high zoom levels the brush will have a gradient.

See Also

GH_PaletteStyle Class
Grasshopper.GUI.Canvas Namespace


CreateBrush Method

[image]

Grasshopper SDK
GH_PaletteStyle..::..CreateBrush Method
GH_PaletteStyle Class See Also Send Feedback
Create a fill brush. At low zoom levels the brush will be solid colour, at medium to high zoom levels the brush will have a gradient.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual Brush CreateBrush(
    RectangleF rec,
    float zoom
)
Visual Basic
Public Overridable Function CreateBrush ( _
    rec As RectangleF, _
    zoom As Single _
) As Brush

Parameters

rec
Type: System.Drawing..::..RectangleF
Target rectangle of fill brush.
zoom
Type: System..::..Single
Zoom level of target graphics surface.

Return Value

A brush object that can be used to fill a custom area.

See Also

GH_PaletteStyle Class
Grasshopper.GUI.Canvas Namespace


GH_PaletteStyle Properties

[image] [image]

Grasshopper SDK
GH_PaletteStyle Properties
GH_PaletteStyle Class See Also Send Feedback

The GH_PaletteStyle type exposes the following members.

Properties

 | Name | Description
Public property | Edge | Gets or sets the edge of this style.
Public property | Fill | Gets or sets the fill of this style.
Public property | Text | Gets or sets the text of this style.

See Also

GH_PaletteStyle Class
Grasshopper.GUI.Canvas Namespace


Edge Property

[image]

Grasshopper SDK
GH_PaletteStyle..::..Edge Property
GH_PaletteStyle Class See Also Send Feedback
Gets or sets the edge of this style.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color Edge { get; set; }
Visual Basic
Public Property Edge As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_PaletteStyle.Edge"]

See Also

GH_PaletteStyle Class
Grasshopper.GUI.Canvas Namespace


Fill Property

[image]

Grasshopper SDK
GH_PaletteStyle..::..Fill Property
GH_PaletteStyle Class See Also Send Feedback
Gets or sets the fill of this style.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color Fill { get; set; }
Visual Basic
Public Property Fill As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_PaletteStyle.Fill"]

See Also

GH_PaletteStyle Class
Grasshopper.GUI.Canvas Namespace


Text Property

[image]

Grasshopper SDK
GH_PaletteStyle..::..Text Property
GH_PaletteStyle Class See Also Send Feedback
Gets or sets the text of this style.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color Text { get; set; }
Visual Basic
Public Property Text As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_PaletteStyle.Text"]

See Also

GH_PaletteStyle Class
Grasshopper.GUI.Canvas Namespace


GH_ResizeBorder Class

[image]

Grasshopper SDK
GH_ResizeBorder Class
Members See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_ResizeBorder : GH_Border
Visual Basic
Public Class GH_ResizeBorder _
    Inherits GH_Border

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI.Canvas..::..GH_Border
Grasshopper.GUI.Canvas..::..GH_ResizeBorder

See Also

GH_ResizeBorder Members
Grasshopper.GUI.Canvas Namespace


GH_ResizeBorder Members

[image] [image]

Grasshopper SDK
GH_ResizeBorder Members
GH_ResizeBorder Class Constructors Methods Properties See Also Send Feedback

The GH_ResizeBorder type exposes the following members.

Constructors

 | Name | Description
Public method | GH_ResizeBorder(GH_Border) | Create a new instance of the GH_ResizeBorder class.
Public method | GH_ResizeBorder(RectangleF, GH_BorderTopology) | Create a new instance of the GH_ResizeBorder class.

Methods

 | Name | Description
Public method | Contains | Test a point for border inclusion. (Inherited from GH_Border.)
Public method | Setup(IGH_Attributes, PointF) | Set up a new sizing operation.
Public method | Setup(RectangleF, PointF, PointF) | Set up a new sizing operation.
Public method | Setup(IGH_Attributes, PointF, SizeF) | Set up a new sizing operation.
Public method | Setup(RectangleF, PointF, PointF, SizeF) | Set up a new sizing operation.
Public method | Setup(IGH_Attributes, PointF, SizeF, SizeF) | Set up a new sizing operation.
Public method | Setup(RectangleF, PointF, PointF, SizeF, SizeF) | Set up a new sizing operation.
Public method | Solve | Solve a resizing step.

Properties

 | Name | Description
Public property | Anchor | Gets or sets the anchor point for sizing operations. This point is determined automatically when you call Setup(), however you can alter it afterwards if you want.
Public property | Region | Gets the shape of the border. (Inherited from GH_Border.)
Public property | Size_Cursor | Gets the cursor associated with this border. (Inherited from GH_Border.)
Public property | Topology | Gets the type of border. (Inherited from GH_Border.)

See Also

GH_ResizeBorder Class
Grasshopper.GUI.Canvas Namespace


GH_ResizeBorder Constructor

[image] [image]

Grasshopper SDK
GH_ResizeBorder Constructor
GH_ResizeBorder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_ResizeBorder(GH_Border) | Create a new instance of the GH_ResizeBorder class.
Public method | GH_ResizeBorder(RectangleF, GH_BorderTopology) | Create a new instance of the GH_ResizeBorder class.

See Also

GH_ResizeBorder Class
GH_ResizeBorder Members
Grasshopper.GUI.Canvas Namespace


GH_ResizeBorder Constructor (GH_Border)

[image]

Grasshopper SDK
GH_ResizeBorder Constructor (GH_Border)
GH_ResizeBorder Class See Also Send Feedback
Create a new instance of the GH_ResizeBorder class.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ResizeBorder(
    GH_Border borders
)
Visual Basic
Public Sub New ( _
    borders As GH_Border _
)

Parameters

borders
Type: Grasshopper.GUI.Canvas..::..GH_Border
Border to mimic.

See Also

GH_ResizeBorder Class
GH_ResizeBorder Overload
Grasshopper.GUI.Canvas Namespace


GH_ResizeBorder Constructor (RectangleF, GH_BorderTopology)

[image]

Grasshopper SDK
GH_ResizeBorder Constructor (RectangleF, GH_BorderTopology)
GH_ResizeBorder Class See Also Send Feedback
Create a new instance of the GH_ResizeBorder class.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ResizeBorder(
    RectangleF region,
    GH_BorderTopology topology
)
Visual Basic
Public Sub New ( _
    region As RectangleF, _
    topology As GH_BorderTopology _
)

Parameters

region
Type: System.Drawing..::..RectangleF
Base rectangle for borders.
topology
Type: Grasshopper.GUI.Canvas..::..GH_BorderTopology
Border topology.

See Also

GH_ResizeBorder Class
GH_ResizeBorder Overload
Grasshopper.GUI.Canvas Namespace


GH_ResizeBorder Methods

[image] [image]

Grasshopper SDK
GH_ResizeBorder Methods
GH_ResizeBorder Class See Also Send Feedback

The GH_ResizeBorder type exposes the following members.

Methods

 | Name | Description
Public method | Contains | Test a point for border inclusion. (Inherited from GH_Border.)
Public method | Setup(IGH_Attributes, PointF) | Set up a new sizing operation.
Public method | Setup(RectangleF, PointF, PointF) | Set up a new sizing operation.
Public method | Setup(IGH_Attributes, PointF, SizeF) | Set up a new sizing operation.
Public method | Setup(RectangleF, PointF, PointF, SizeF) | Set up a new sizing operation.
Public method | Setup(IGH_Attributes, PointF, SizeF, SizeF) | Set up a new sizing operation.
Public method | Setup(RectangleF, PointF, PointF, SizeF, SizeF) | Set up a new sizing operation.
Public method | Solve | Solve a resizing step.

See Also

GH_ResizeBorder Class
Grasshopper.GUI.Canvas Namespace


Setup Method

[image] [image]

Grasshopper SDK
GH_ResizeBorder..::..Setup Method
GH_ResizeBorder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Setup(IGH_Attributes, PointF) | Set up a new sizing operation.
Public method | Setup(RectangleF, PointF, PointF) | Set up a new sizing operation.
Public method | Setup(IGH_Attributes, PointF, SizeF) | Set up a new sizing operation.
Public method | Setup(RectangleF, PointF, PointF, SizeF) | Set up a new sizing operation.
Public method | Setup(IGH_Attributes, PointF, SizeF, SizeF) | Set up a new sizing operation.
Public method | Setup(RectangleF, PointF, PointF, SizeF, SizeF) | Set up a new sizing operation.

See Also

GH_ResizeBorder Class
GH_ResizeBorder Members
Grasshopper.GUI.Canvas Namespace


Setup Method (IGH_Attributes, PointF)

[image]

Grasshopper SDK
GH_ResizeBorder..::..Setup Method (IGH_Attributes, PointF)
GH_ResizeBorder Class See Also Send Feedback
Set up a new sizing operation.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Setup(
    IGH_Attributes att,
    PointF MouseCursor
)
Visual Basic
Public Sub Setup ( _
    att As IGH_Attributes, _
    MouseCursor As PointF _
)

Parameters

att
Type: Grasshopper.Kernel..::..IGH_Attributes
Attributes of shape to resize.
MouseCursor
Type: System.Drawing..::..PointF
Location of cursor in shape space coordinates.

See Also

GH_ResizeBorder Class
Setup Overload
Grasshopper.GUI.Canvas Namespace


Setup Method (RectangleF, PointF, PointF)

[image]

Grasshopper SDK
GH_ResizeBorder..::..Setup Method (RectangleF, PointF, PointF)
GH_ResizeBorder Class See Also Send Feedback
Set up a new sizing operation.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Setup(
    RectangleF ShapeRegion,
    PointF ShapePivot,
    PointF MouseCursor
)
Visual Basic
Public Sub Setup ( _
    ShapeRegion As RectangleF, _
    ShapePivot As PointF, _
    MouseCursor As PointF _
)

Parameters

ShapeRegion
Type: System.Drawing..::..RectangleF
Shape of the object to resize.
ShapePivot
Type: System.Drawing..::..PointF
Pivot of the object to resize.
MouseCursor
Type: System.Drawing..::..PointF
Location of cursor in shape space coordinates.

See Also

GH_ResizeBorder Class
Setup Overload
Grasshopper.GUI.Canvas Namespace


Setup Method (IGH_Attributes, PointF, SizeF)

[image]

Grasshopper SDK
GH_ResizeBorder..::..Setup Method (IGH_Attributes, PointF, SizeF)
GH_ResizeBorder Class See Also Send Feedback
Set up a new sizing operation.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Setup(
    IGH_Attributes att,
    PointF MouseCursor,
    SizeF MinSize
)
Visual Basic
Public Sub Setup ( _
    att As IGH_Attributes, _
    MouseCursor As PointF, _
    MinSize As SizeF _
)

Parameters

att
Type: Grasshopper.Kernel..::..IGH_Attributes
Attributes of shape to resize.
MouseCursor
Type: System.Drawing..::..PointF
Location of cursor in shape space coordinates.
MinSize
Type: System.Drawing..::..SizeF
Minimum allowed size for shape.

See Also

GH_ResizeBorder Class
Setup Overload
Grasshopper.GUI.Canvas Namespace


Setup Method (RectangleF, PointF, PointF, SizeF)

[image]

Grasshopper SDK
GH_ResizeBorder..::..Setup Method (RectangleF, PointF, PointF, SizeF)
GH_ResizeBorder Class See Also Send Feedback
Set up a new sizing operation.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Setup(
    RectangleF ShapeRegion,
    PointF ShapePivot,
    PointF MouseCursor,
    SizeF MinSize
)
Visual Basic
Public Sub Setup ( _
    ShapeRegion As RectangleF, _
    ShapePivot As PointF, _
    MouseCursor As PointF, _
    MinSize As SizeF _
)

Parameters

ShapeRegion
Type: System.Drawing..::..RectangleF
Shape of the object to resize.
ShapePivot
Type: System.Drawing..::..PointF
Pivot of the object to resize.
MouseCursor
Type: System.Drawing..::..PointF
Location of cursor in shape space coordinates.
MinSize
Type: System.Drawing..::..SizeF
Minimum allowed size for shape.

See Also

GH_ResizeBorder Class
Setup Overload
Grasshopper.GUI.Canvas Namespace


Setup Method (IGH_Attributes, PointF, SizeF, SizeF)

[image]

Grasshopper SDK
GH_ResizeBorder..::..Setup Method (IGH_Attributes, PointF, SizeF, SizeF)
GH_ResizeBorder Class See Also Send Feedback
Set up a new sizing operation.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Setup(
    IGH_Attributes att,
    PointF MouseCursor,
    SizeF MinSize,
    SizeF MaxSize
)
Visual Basic
Public Sub Setup ( _
    att As IGH_Attributes, _
    MouseCursor As PointF, _
    MinSize As SizeF, _
    MaxSize As SizeF _
)

Parameters

att
Type: Grasshopper.Kernel..::..IGH_Attributes
Attributes of shape to resize.
MouseCursor
Type: System.Drawing..::..PointF
Location of cursor in shape space coordinates.
MinSize
Type: System.Drawing..::..SizeF
Minimum allowed size for shape.
MaxSize
Type: System.Drawing..::..SizeF
Maximum allowed size for shape.

See Also

GH_ResizeBorder Class
Setup Overload
Grasshopper.GUI.Canvas Namespace


Setup Method (RectangleF, PointF, PointF, SizeF, SizeF)

[image]

Grasshopper SDK
GH_ResizeBorder..::..Setup Method (RectangleF, PointF, PointF, SizeF, SizeF)
GH_ResizeBorder Class See Also Send Feedback
Set up a new sizing operation.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Setup(
    RectangleF ShapeRegion,
    PointF ShapePivot,
    PointF MouseCursor,
    SizeF MinSize,
    SizeF MaxSize
)
Visual Basic
Public Sub Setup ( _
    ShapeRegion As RectangleF, _
    ShapePivot As PointF, _
    MouseCursor As PointF, _
    MinSize As SizeF, _
    MaxSize As SizeF _
)

Parameters

ShapeRegion
Type: System.Drawing..::..RectangleF
Shape of the object to resize.
ShapePivot
Type: System.Drawing..::..PointF
Pivot of the object to resize.
MouseCursor
Type: System.Drawing..::..PointF
Location of cursor in shape space coordinates.
MinSize
Type: System.Drawing..::..SizeF
Minimum allowed size for shape.
MaxSize
Type: System.Drawing..::..SizeF
Maximum allowed size for shape.

See Also

GH_ResizeBorder Class
Setup Overload
Grasshopper.GUI.Canvas Namespace


Solve Method

[image]

Grasshopper SDK
GH_ResizeBorder..::..Solve Method
GH_ResizeBorder Class See Also Send Feedback
Solve a resizing step.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Solve(
    PointF nCursor,
    out RectangleF new_shape,
    out PointF new_pivot
)
Visual Basic
Public Sub Solve ( _
    nCursor As PointF, _
    <OutAttribute> ByRef new_shape As RectangleF, _
    <OutAttribute> ByRef new_pivot As PointF _
)

Parameters

nCursor
Type: System.Drawing..::..PointF
The new cursor location.
new_shape
Type: System.Drawing..::..RectangleF %
The resized shape bounding box.
new_pivot
Type: System.Drawing..::..PointF %
The adjusted shape pivot.

See Also

GH_ResizeBorder Class
Grasshopper.GUI.Canvas Namespace


GH_ResizeBorder Properties

[image] [image]

Grasshopper SDK
GH_ResizeBorder Properties
GH_ResizeBorder Class See Also Send Feedback

The GH_ResizeBorder type exposes the following members.

Properties

 | Name | Description
Public property | Anchor | Gets or sets the anchor point for sizing operations. This point is determined automatically when you call Setup(), however you can alter it afterwards if you want.
Public property | Region | Gets the shape of the border. (Inherited from GH_Border.)
Public property | Size_Cursor | Gets the cursor associated with this border. (Inherited from GH_Border.)
Public property | Topology | Gets the type of border. (Inherited from GH_Border.)

See Also

GH_ResizeBorder Class
Grasshopper.GUI.Canvas Namespace


Anchor Property

[image]

Grasshopper SDK
GH_ResizeBorder..::..Anchor Property
GH_ResizeBorder Class See Also Send Feedback
Gets or sets the anchor point for sizing operations. This point is determined automatically when you call Setup(), however you can alter it afterwards if you want.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public PointF Anchor { get; set; }
Visual Basic
Public Property Anchor As PointF
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_ResizeBorder.Anchor"]

See Also

GH_ResizeBorder Class
Grasshopper.GUI.Canvas Namespace


GH_Skin Class

[image]

Grasshopper SDK
GH_Skin Class
Members See Also Send Feedback
Provides static access to typical Palletes and other GUI colours.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class GH_Skin
Visual Basic
Public NotInheritable Class GH_Skin

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI.Canvas..::..GH_Skin

See Also

GH_Skin Members
Grasshopper.GUI.Canvas Namespace


GH_Skin Members

[image] [image]

Grasshopper SDK
GH_Skin Members
GH_Skin Class Methods Fields See Also Send Feedback

The GH_Skin type exposes the following members.

Methods

Name | Description
DefaultPalette | Obsolete. Get the default palette as implied by the object state. Locked and Hidden flags are ignored.
LoadSkin | Instantiate all palette and gui defaults. This function reads the colour values out of grasshopper_gui.xml settings database if it exists.
SaveSkin | Store all palette and gui defaults. This function writes the colour values out to grasshopper_gui.xml settings database.

Fields

Name | Description
canvas_back | Specifies canvas background colour.
canvas_edge | Specifies canvas edge colour.
canvas_grid | Specifies canvas grid colour.
canvas_grid_col | Specifies the interval of the canvas grid columns.
canvas_grid_row | Specifies the interval of the canvas grid rows.
canvas_mono | Canvas monochromatic flag. If True, the canvas background is a solid colour.
canvas_mono_color | If canvas_mono is set to true, this colour specified the solid background fill for the canvas.
canvas_shade | Specifies the colour of the canvas drop shadow.
canvas_shade_size | Specifies the size of the canvas drop shadow.
group_back | Specifies the default fill colour for Group objects.
palette_black_selected | Black palette, selected.
palette_black_standard | Black palette, unselected.
palette_blue_selected | Blue palette, selected.
palette_blue_standard | Blue palette, unselected.
palette_brown_selected | Brown palette, selected.
palette_brown_standard | Brown palette, unselected.
palette_error_selected | Errors, selected palette. Default background for parameters and components that carry errors.
palette_error_standard | Errors, unselected palette. Default background for parameters and components that carry errors.
palette_grey_selected | Grey palette, selected.
palette_grey_standard | Grey palette, unselected.
palette_hidden_selected | Hidden, selected palette. Default background for hidden (preview=off) parameters and components.
palette_hidden_standard | Hidden, unselected palette. Default background for hidden (preview=off) parameters and components.
palette_locked_selected | Locked, selected palette. Default background for locked parameters and components.
palette_locked_standard | Locked, unselected palette. Default background for locked parameters and components.
palette_normal_selected | Normal, selected palette. Default background for parameters and components.
palette_normal_standard | Normal, unselected palette. Default background for parameters and components.
palette_pink_selected | Pink palette, selected.
palette_pink_standard | Pink palette, unselected.
palette_trans_selected | Transparent palette, selected.
palette_trans_standard | Transparent palette, unselected.
palette_warning_selected | Warnings, selected palette. Default background for parameters and components that carry warnings.
palette_warning_standard | Warnings, unselected palette. Default background for parameters and components that carry warnings.
palette_white_selected | White palette, selected.
palette_white_standard | White palette, unselected.
panel_back | Specifies the default fill colour for Panel objects.
wire_default | Specifies the default wire colour.
wire_empty | Specifies the colour for empty (null) wires.
wire_selected_a | Specifies the colour for wires at the selected end.
wire_selected_b | Specifies the colour for wires at the unselected end.
zui_edge | Specifies the default edge colour for ZUI elements.
zui_edge_highlight | Specifies the default edge colour for highlighted ZUI elements.
zui_fill | Specifies the default fill colour for ZUI elements.
zui_fill_highlight | Specifies the default fill colour for highlighted ZUI elements.

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


GH_Skin Fields

[image] [image]

Grasshopper SDK
GH_Skin Fields
GH_Skin Class See Also Send Feedback

The GH_Skin type exposes the following members.

Fields

Name | Description
canvas_back | Specifies canvas background colour.
canvas_edge | Specifies canvas edge colour.
canvas_grid | Specifies canvas grid colour.
canvas_grid_col | Specifies the interval of the canvas grid columns.
canvas_grid_row | Specifies the interval of the canvas grid rows.
canvas_mono | Canvas monochromatic flag. If True, the canvas background is a solid colour.
canvas_mono_color | If canvas_mono is set to true, this colour specified the solid background fill for the canvas.
canvas_shade | Specifies the colour of the canvas drop shadow.
canvas_shade_size | Specifies the size of the canvas drop shadow.
group_back | Specifies the default fill colour for Group objects.
palette_black_selected | Black palette, selected.
palette_black_standard | Black palette, unselected.
palette_blue_selected | Blue palette, selected.
palette_blue_standard | Blue palette, unselected.
palette_brown_selected | Brown palette, selected.
palette_brown_standard | Brown palette, unselected.
palette_error_selected | Errors, selected palette. Default background for parameters and components that carry errors.
palette_error_standard | Errors, unselected palette. Default background for parameters and components that carry errors.
palette_grey_selected | Grey palette, selected.
palette_grey_standard | Grey palette, unselected.
palette_hidden_selected | Hidden, selected palette. Default background for hidden (preview=off) parameters and components.
palette_hidden_standard | Hidden, unselected palette. Default background for hidden (preview=off) parameters and components.
palette_locked_selected | Locked, selected palette. Default background for locked parameters and components.
palette_locked_standard | Locked, unselected palette. Default background for locked parameters and components.
palette_normal_selected | Normal, selected palette. Default background for parameters and components.
palette_normal_standard | Normal, unselected palette. Default background for parameters and components.
palette_pink_selected | Pink palette, selected.
palette_pink_standard | Pink palette, unselected.
palette_trans_selected | Transparent palette, selected.
palette_trans_standard | Transparent palette, unselected.
palette_warning_selected | Warnings, selected palette. Default background for parameters and components that carry warnings.
palette_warning_standard | Warnings, unselected palette. Default background for parameters and components that carry warnings.
palette_white_selected | White palette, selected.
palette_white_standard | White palette, unselected.
panel_back | Specifies the default fill colour for Panel objects.
wire_default | Specifies the default wire colour.
wire_empty | Specifies the colour for empty (null) wires.
wire_selected_a | Specifies the colour for wires at the selected end.
wire_selected_b | Specifies the colour for wires at the unselected end.
zui_edge | Specifies the default edge colour for ZUI elements.
zui_edge_highlight | Specifies the default edge colour for highlighted ZUI elements.
zui_fill | Specifies the default fill colour for ZUI elements.
zui_fill_highlight | Specifies the default fill colour for highlighted ZUI elements.

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


canvas_back Field

[image]

Grasshopper SDK
GH_Skin..::..canvas_back Field
GH_Skin Class See Also Send Feedback
Specifies canvas background colour.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Color canvas_back
Visual Basic
Public Shared canvas_back As Color

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


canvas_edge Field

[image]

Grasshopper SDK
GH_Skin..::..canvas_edge Field
GH_Skin Class See Also Send Feedback
Specifies canvas edge colour.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Color canvas_edge
Visual Basic
Public Shared canvas_edge As Color

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


canvas_grid Field

[image]

Grasshopper SDK
GH_Skin..::..canvas_grid Field
GH_Skin Class See Also Send Feedback
Specifies canvas grid colour.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Color canvas_grid
Visual Basic
Public Shared canvas_grid As Color

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


canvas_grid_col Field

[image]

Grasshopper SDK
GH_Skin..::..canvas_grid_col Field
GH_Skin Class See Also Send Feedback
Specifies the interval of the canvas grid columns.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static int canvas_grid_col
Visual Basic
Public Shared canvas_grid_col As Integer

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


canvas_grid_row Field

[image]

Grasshopper SDK
GH_Skin..::..canvas_grid_row Field
GH_Skin Class See Also Send Feedback
Specifies the interval of the canvas grid rows.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static int canvas_grid_row
Visual Basic
Public Shared canvas_grid_row As Integer

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


canvas_mono Field

[image]

Grasshopper SDK
GH_Skin..::..canvas_mono Field
GH_Skin Class See Also Send Feedback
Canvas monochromatic flag. If True, the canvas background is a solid colour.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool canvas_mono
Visual Basic
Public Shared canvas_mono As Boolean

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


canvas_mono_color Field

[image]

Grasshopper SDK
GH_Skin..::..canvas_mono_color Field
GH_Skin Class See Also Send Feedback
If canvas_mono is set to true, this colour specified the solid background fill for the canvas.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Color canvas_mono_color
Visual Basic
Public Shared canvas_mono_color As Color

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


canvas_shade Field

[image]

Grasshopper SDK
GH_Skin..::..canvas_shade Field
GH_Skin Class See Also Send Feedback
Specifies the colour of the canvas drop shadow.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Color canvas_shade
Visual Basic
Public Shared canvas_shade As Color

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


canvas_shade_size Field

[image]

Grasshopper SDK
GH_Skin..::..canvas_shade_size Field
GH_Skin Class See Also Send Feedback
Specifies the size of the canvas drop shadow.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static int canvas_shade_size
Visual Basic
Public Shared canvas_shade_size As Integer

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


group_back Field

[image]

Grasshopper SDK
GH_Skin..::..group_back Field
GH_Skin Class See Also Send Feedback
Specifies the default fill colour for Group objects.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Color group_back
Visual Basic
Public Shared group_back As Color

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


palette_black_selected Field

[image]

Grasshopper SDK
GH_Skin..::..palette_black_selected Field
GH_Skin Class See Also Send Feedback
Black palette, selected.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_PaletteStyle palette_black_selected
Visual Basic
Public Shared palette_black_selected As GH_PaletteStyle

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


palette_black_standard Field

[image]

Grasshopper SDK
GH_Skin..::..palette_black_standard Field
GH_Skin Class See Also Send Feedback
Black palette, unselected.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_PaletteStyle palette_black_standard
Visual Basic
Public Shared palette_black_standard As GH_PaletteStyle

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


palette_blue_selected Field

[image]

Grasshopper SDK
GH_Skin..::..palette_blue_selected Field
GH_Skin Class See Also Send Feedback
Blue palette, selected.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_PaletteStyle palette_blue_selected
Visual Basic
Public Shared palette_blue_selected As GH_PaletteStyle

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


palette_blue_standard Field

[image]

Grasshopper SDK
GH_Skin..::..palette_blue_standard Field
GH_Skin Class See Also Send Feedback
Blue palette, unselected.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_PaletteStyle palette_blue_standard
Visual Basic
Public Shared palette_blue_standard As GH_PaletteStyle

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


palette_brown_selected Field

[image]

Grasshopper SDK
GH_Skin..::..palette_brown_selected Field
GH_Skin Class See Also Send Feedback
Brown palette, selected.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_PaletteStyle palette_brown_selected
Visual Basic
Public Shared palette_brown_selected As GH_PaletteStyle

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


palette_brown_standard Field

[image]

Grasshopper SDK
GH_Skin..::..palette_brown_standard Field
GH_Skin Class See Also Send Feedback
Brown palette, unselected.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_PaletteStyle palette_brown_standard
Visual Basic
Public Shared palette_brown_standard As GH_PaletteStyle

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


palette_error_selected Field

[image]

Grasshopper SDK
GH_Skin..::..palette_error_selected Field
GH_Skin Class See Also Send Feedback
Errors, selected palette. Default background for parameters and components that carry errors.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_PaletteStyle palette_error_selected
Visual Basic
Public Shared palette_error_selected As GH_PaletteStyle

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


palette_error_standard Field

[image]

Grasshopper SDK
GH_Skin..::..palette_error_standard Field
GH_Skin Class See Also Send Feedback
Errors, unselected palette. Default background for parameters and components that carry errors.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_PaletteStyle palette_error_standard
Visual Basic
Public Shared palette_error_standard As GH_PaletteStyle

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


palette_grey_selected Field

[image]

Grasshopper SDK
GH_Skin..::..palette_grey_selected Field
GH_Skin Class See Also Send Feedback
Grey palette, selected.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_PaletteStyle palette_grey_selected
Visual Basic
Public Shared palette_grey_selected As GH_PaletteStyle

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


palette_grey_standard Field

[image]

Grasshopper SDK
GH_Skin..::..palette_grey_standard Field
GH_Skin Class See Also Send Feedback
Grey palette, unselected.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_PaletteStyle palette_grey_standard
Visual Basic
Public Shared palette_grey_standard As GH_PaletteStyle

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


palette_hidden_selected Field

[image]

Grasshopper SDK
GH_Skin..::..palette_hidden_selected Field
GH_Skin Class See Also Send Feedback
Hidden, selected palette. Default background for hidden (preview=off) parameters and components.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_PaletteStyle palette_hidden_selected
Visual Basic
Public Shared palette_hidden_selected As GH_PaletteStyle

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


palette_hidden_standard Field

[image]

Grasshopper SDK
GH_Skin..::..palette_hidden_standard Field
GH_Skin Class See Also Send Feedback
Hidden, unselected palette. Default background for hidden (preview=off) parameters and components.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_PaletteStyle palette_hidden_standard
Visual Basic
Public Shared palette_hidden_standard As GH_PaletteStyle

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


palette_locked_selected Field

[image]

Grasshopper SDK
GH_Skin..::..palette_locked_selected Field
GH_Skin Class See Also Send Feedback
Locked, selected palette. Default background for locked parameters and components.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_PaletteStyle palette_locked_selected
Visual Basic
Public Shared palette_locked_selected As GH_PaletteStyle

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


palette_locked_standard Field

[image]

Grasshopper SDK
GH_Skin..::..palette_locked_standard Field
GH_Skin Class See Also Send Feedback
Locked, unselected palette. Default background for locked parameters and components.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_PaletteStyle palette_locked_standard
Visual Basic
Public Shared palette_locked_standard As GH_PaletteStyle

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


palette_normal_selected Field

[image]

Grasshopper SDK
GH_Skin..::..palette_normal_selected Field
GH_Skin Class See Also Send Feedback
Normal, selected palette. Default background for parameters and components.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_PaletteStyle palette_normal_selected
Visual Basic
Public Shared palette_normal_selected As GH_PaletteStyle

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


palette_normal_standard Field

[image]

Grasshopper SDK
GH_Skin..::..palette_normal_standard Field
GH_Skin Class See Also Send Feedback
Normal, unselected palette. Default background for parameters and components.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_PaletteStyle palette_normal_standard
Visual Basic
Public Shared palette_normal_standard As GH_PaletteStyle

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


palette_pink_selected Field

[image]

Grasshopper SDK
GH_Skin..::..palette_pink_selected Field
GH_Skin Class See Also Send Feedback
Pink palette, selected.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_PaletteStyle palette_pink_selected
Visual Basic
Public Shared palette_pink_selected As GH_PaletteStyle

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


palette_pink_standard Field

[image]

Grasshopper SDK
GH_Skin..::..palette_pink_standard Field
GH_Skin Class See Also Send Feedback
Pink palette, unselected.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_PaletteStyle palette_pink_standard
Visual Basic
Public Shared palette_pink_standard As GH_PaletteStyle

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


palette_trans_selected Field

[image]

Grasshopper SDK
GH_Skin..::..palette_trans_selected Field
GH_Skin Class See Also Send Feedback
Transparent palette, selected.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_PaletteStyle palette_trans_selected
Visual Basic
Public Shared palette_trans_selected As GH_PaletteStyle

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


palette_trans_standard Field

[image]

Grasshopper SDK
GH_Skin..::..palette_trans_standard Field
GH_Skin Class See Also Send Feedback
Transparent palette, unselected.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_PaletteStyle palette_trans_standard
Visual Basic
Public Shared palette_trans_standard As GH_PaletteStyle

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


palette_warning_selected Field

[image]

Grasshopper SDK
GH_Skin..::..palette_warning_selected Field
GH_Skin Class See Also Send Feedback
Warnings, selected palette. Default background for parameters and components that carry warnings.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_PaletteStyle palette_warning_selected
Visual Basic
Public Shared palette_warning_selected As GH_PaletteStyle

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


palette_warning_standard Field

[image]

Grasshopper SDK
GH_Skin..::..palette_warning_standard Field
GH_Skin Class See Also Send Feedback
Warnings, unselected palette. Default background for parameters and components that carry warnings.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_PaletteStyle palette_warning_standard
Visual Basic
Public Shared palette_warning_standard As GH_PaletteStyle

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


palette_white_selected Field

[image]

Grasshopper SDK
GH_Skin..::..palette_white_selected Field
GH_Skin Class See Also Send Feedback
White palette, selected.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_PaletteStyle palette_white_selected
Visual Basic
Public Shared palette_white_selected As GH_PaletteStyle

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


palette_white_standard Field

[image]

Grasshopper SDK
GH_Skin..::..palette_white_standard Field
GH_Skin Class See Also Send Feedback
White palette, unselected.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_PaletteStyle palette_white_standard
Visual Basic
Public Shared palette_white_standard As GH_PaletteStyle

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


panel_back Field

[image]

Grasshopper SDK
GH_Skin..::..panel_back Field
GH_Skin Class See Also Send Feedback
Specifies the default fill colour for Panel objects.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Color panel_back
Visual Basic
Public Shared panel_back As Color

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


wire_default Field

[image]

Grasshopper SDK
GH_Skin..::..wire_default Field
GH_Skin Class See Also Send Feedback
Specifies the default wire colour.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Color wire_default
Visual Basic
Public Shared wire_default As Color

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


wire_empty Field

[image]

Grasshopper SDK
GH_Skin..::..wire_empty Field
GH_Skin Class See Also Send Feedback
Specifies the colour for empty (null) wires.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Color wire_empty
Visual Basic
Public Shared wire_empty As Color

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


wire_selected_a Field

[image]

Grasshopper SDK
GH_Skin..::..wire_selected_a Field
GH_Skin Class See Also Send Feedback
Specifies the colour for wires at the selected end.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Color wire_selected_a
Visual Basic
Public Shared wire_selected_a As Color

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


wire_selected_b Field

[image]

Grasshopper SDK
GH_Skin..::..wire_selected_b Field
GH_Skin Class See Also Send Feedback
Specifies the colour for wires at the unselected end.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Color wire_selected_b
Visual Basic
Public Shared wire_selected_b As Color

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


zui_edge Field

[image]

Grasshopper SDK
GH_Skin..::..zui_edge Field
GH_Skin Class See Also Send Feedback
Specifies the default edge colour for ZUI elements.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Color zui_edge
Visual Basic
Public Shared zui_edge As Color

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


zui_edge_highlight Field

[image]

Grasshopper SDK
GH_Skin..::..zui_edge_highlight Field
GH_Skin Class See Also Send Feedback
Specifies the default edge colour for highlighted ZUI elements.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Color zui_edge_highlight
Visual Basic
Public Shared zui_edge_highlight As Color

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


zui_fill Field

[image]

Grasshopper SDK
GH_Skin..::..zui_fill Field
GH_Skin Class See Also Send Feedback
Specifies the default fill colour for ZUI elements.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Color zui_fill
Visual Basic
Public Shared zui_fill As Color

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


zui_fill_highlight Field

[image]

Grasshopper SDK
GH_Skin..::..zui_fill_highlight Field
GH_Skin Class See Also Send Feedback
Specifies the default fill colour for highlighted ZUI elements.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Color zui_fill_highlight
Visual Basic
Public Shared zui_fill_highlight As Color

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


GH_Skin Methods

[image] [image]

Grasshopper SDK
GH_Skin Methods
GH_Skin Class See Also Send Feedback

The GH_Skin type exposes the following members.

Methods

Name | Description
DefaultPalette | Obsolete. Get the default palette as implied by the object state. Locked and Hidden flags are ignored.
LoadSkin | Instantiate all palette and gui defaults. This function reads the colour values out of grasshopper_gui.xml settings database if it exists.
SaveSkin | Store all palette and gui defaults. This function writes the colour values out to grasshopper_gui.xml settings database.

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


DefaultPalette Method

[image]

Grasshopper SDK
GH_Skin..::..DefaultPalette Method
GH_Skin Class See Also Send Feedback
Get the default palette as implied by the object state. Locked and Hidden flags are ignored.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
[ObsoleteAttribute("This method is now available on GH_CapsuleRenderEngine")]
public static GH_Palette DefaultPalette(
    IGH_ActiveObject obj
)
Visual Basic
<ObsoleteAttribute("This method is now available on GH_CapsuleRenderEngine")> _
Public Shared Function DefaultPalette ( _
    obj As IGH_ActiveObject _
) As GH_Palette

Parameters

obj
Type: Grasshopper.Kernel..::..IGH_ActiveObject

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


LoadSkin Method

[image]

Grasshopper SDK
GH_Skin..::..LoadSkin Method
GH_Skin Class See Also Send Feedback
Instantiate all palette and gui defaults. This function reads the colour values out of grasshopper_gui.xml settings database if it exists.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void LoadSkin()
Visual Basic
Public Shared Sub LoadSkin

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


SaveSkin Method

[image]

Grasshopper SDK
GH_Skin..::..SaveSkin Method
GH_Skin Class See Also Send Feedback
Store all palette and gui defaults. This function writes the colour values out to grasshopper_gui.xml settings database.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void SaveSkin()
Visual Basic
Public Shared Sub SaveSkin

See Also

GH_Skin Class
Grasshopper.GUI.Canvas Namespace


GH_Viewport Class

[image]

Grasshopper SDK
GH_Viewport Class
Members See Also Send Feedback
Provides functionality for panning and zooming in a GH_Canvas environment.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class GH_Viewport
Visual Basic
Public NotInheritable Class GH_Viewport

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI.Canvas..::..GH_Viewport

See Also

GH_Viewport Members
Grasshopper.GUI.Canvas Namespace


GH_Viewport Members

[image] [image]

Grasshopper SDK
GH_Viewport Members
GH_Viewport Class Constructors Methods Fields Properties See Also Send Feedback

The GH_Viewport type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Viewport()()()() | Initializes a new instance of the GH_Viewport class
Public method | GH_Viewport(Point) | Initializes a new instance of the GH_Viewport class
Public method | GH_Viewport(GH_Viewport) | Initializes a new instance of the GH_Viewport class
Public method | GH_Viewport(Point, Single) | Initializes a new instance of the GH_Viewport class

Methods

 | Name | Description
Public method | ApplyProjection | Apply the current display transformation to a Graphics object.
Public method | ComputeProjection | Forces a recomputation of all cached data.
Public method | DollyZoom | Advanced interface function for mouse 'dolly' zooming.
Public method | Duplicate |
Public method | Focus(Point) | Look at a specific point.
Public method | Focus(PointF) | Look at a specific point.
Public method | Focus(IGH_Attributes) | Look at a specific object.
Public method | Focus(List<(Of <<'(IGH_Attributes>)>>)) | Look at a set of specific objects.
Public method | IsVisible(PointF%, Single) | Test visibility of a point.
Public method | IsVisible(RectangleF%, Single) | Test visibility of a rectangle.
Public method | LimitUnit | Utility function for calculating pixel dimensions in a zoom-aware environment. The desired value is put through the zoom projection and if the resulting size (as displayed on the screen) exceeds the visual limits it is clipped. This function can be used for example to make sure that a certain penwidth never exceeds visual limits (i.e. it doesn't get too thin or too thick on the screen).
Public method | Project | Transform a point from canvas into control coordinate space.
Public method | ProjectPoint | Project a point from canvas coordinates into control coordinates.
Public method | ProjectRectangle | Project a rectangle from canvas coordinates into control coordinates.
Public method | ProjectX | Project a value along constant X from canvas coordinates into control coordinates.
Public method | ProjectY | Project a value along constant Y from canvas coordinates into control coordinates.
Public method | Set |
Public method | SolveUnit | Utility function for calculating graphics dimensions in a zoom-aware environment. This function can be used for example to compute the linewidth of a pen which always needs to appear as 3 pixels thick on the screen regardless of zoom values.
Public method | Unproject | Transform a point from control into canvas coordinate space.
Public method | UnprojectPoint | Project a point from control coordinates into canvas coordinates.
Public method | UnprojectRectangle | Project a rectangle from control coordinates into canvas coordinates.
Public method | UnprojectX | Project a value along constant X from control coordinates into canvas coordinates.
Public method | UnprojectY | Project a value along constant Y from control coordinates into canvas coordinates.
Public method | XFormMatrix | Gets the display transformation cached by this viewport.

Fields

Name | Description
ZoomMaximum |
ZoomMinimum |

Properties

 | Name | Description
Public property | ControlMidPoint | Gets the point in the exact center of the viewport in control coordinates.
Public property | Diagonal | Gets the length of the diagonal of the viewport in canvas coordinates.
Public property | Height | Gets or sets the height of the viewport. Typically this is tied to the dimensions of the canvas. Height is not allowed to go below 5 pixels.
Public property | MidPoint | Gets or sets the canvas coordinate that is directly underneath the center of the viewport.
Public property | ScreenPort | Gets the dimensions of the viewport in control coordinates.
Public property | Size | Gets or sets the size of the viewport. The size is typically tied to the dimensions of the Canvas.
Public property | Target | Gets or sets the location of the target pixel. The target represents where the canvas origin is drawn.
Public property | TargetRatio | Gets or sets the target ratio with respect to the viewport dimensions. This is a useful tool to prevent weird view changes during a canvas resize.
Public property | Tx | Gets or sets the x-component of the target pixel. The target represents where the canvas origin is drawn.
Public property | Ty | Gets or sets the y-component of the target pixel. The target represents where the canvas origin is drawn.
Public property | VisibleRegion | Gets the rectangle in canvas coordinates that is visible in the control.
Public property | Width | Gets or sets the width of the viewport. Typically this is tied to the dimensions of the canvas. Width is not allowed to go below 5 pixels.
Public property | Zoom | Gets or sets the Zoom factor of the viewport. Please assign only sensible values.
Public property | Zoom[([( Boolean])]) | Sets the zoom of the viewport with a view anchor.
Public property | ZoomInverse | Gets the inverse of the zoom.

See Also

GH_Viewport Class
Grasshopper.GUI.Canvas Namespace


GH_Viewport Constructor

[image] [image]

Grasshopper SDK
GH_Viewport Constructor
GH_Viewport Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Viewport()()()() | Initializes a new instance of the GH_Viewport class
Public method | GH_Viewport(Point) | Initializes a new instance of the GH_Viewport class
Public method | GH_Viewport(GH_Viewport) | Initializes a new instance of the GH_Viewport class
Public method | GH_Viewport(Point, Single) | Initializes a new instance of the GH_Viewport class

See Also

GH_Viewport Class
GH_Viewport Members
Grasshopper.GUI.Canvas Namespace


GH_Viewport Constructor

[image]

Grasshopper SDK
GH_Viewport Constructor
GH_Viewport Class See Also Send Feedback
Initializes a new instance of the GH_Viewport class

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Viewport()
Visual Basic
Public Sub New

See Also

GH_Viewport Class
GH_Viewport Overload
Grasshopper.GUI.Canvas Namespace


GH_Viewport Constructor (Point)

[image]

Grasshopper SDK
GH_Viewport Constructor (Point)
GH_Viewport Class See Also Send Feedback
Initializes a new instance of the GH_Viewport class

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Viewport(
    Point target
)
Visual Basic
Public Sub New ( _
    target As Point _
)

Parameters

target
Type: System.Drawing..::..Point

See Also

GH_Viewport Class
GH_Viewport Overload
Grasshopper.GUI.Canvas Namespace


GH_Viewport Constructor (GH_Viewport)

[image]

Grasshopper SDK
GH_Viewport Constructor (GH_Viewport)
GH_Viewport Class See Also Send Feedback
Initializes a new instance of the GH_Viewport class

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Viewport(
    GH_Viewport viewport
)
Visual Basic
Public Sub New ( _
    viewport As GH_Viewport _
)

Parameters

viewport
Type: Grasshopper.GUI.Canvas..::..GH_Viewport

See Also

GH_Viewport Class
GH_Viewport Overload
Grasshopper.GUI.Canvas Namespace


GH_Viewport Constructor (Point, Single)

[image]

Grasshopper SDK
GH_Viewport Constructor (Point, Single)
GH_Viewport Class See Also Send Feedback
Initializes a new instance of the GH_Viewport class

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Viewport(
    Point target,
    float zoom
)
Visual Basic
Public Sub New ( _
    target As Point, _
    zoom As Single _
)

Parameters

target
Type: System.Drawing..::..Point
zoom
Type: System..::..Single

See Also

GH_Viewport Class
GH_Viewport Overload
Grasshopper.GUI.Canvas Namespace


GH_Viewport Fields

[image] [image]

Grasshopper SDK
GH_Viewport Fields
GH_Viewport Class See Also Send Feedback

The GH_Viewport type exposes the following members.

Fields

Name | Description
ZoomMaximum |
ZoomMinimum |

See Also

GH_Viewport Class
Grasshopper.GUI.Canvas Namespace


ZoomMaximum Field

[image]

Grasshopper SDK
GH_Viewport..::..ZoomMaximum Field
GH_Viewport Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const float ZoomMaximum
Visual Basic
Public Const ZoomMaximum As Single

See Also

GH_Viewport Class
Grasshopper.GUI.Canvas Namespace


ZoomMinimum Field

[image]

Grasshopper SDK
GH_Viewport..::..ZoomMinimum Field
GH_Viewport Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const float ZoomMinimum
Visual Basic
Public Const ZoomMinimum As Single

See Also

GH_Viewport Class
Grasshopper.GUI.Canvas Namespace


GH_Viewport Methods

[image] [image]

Grasshopper SDK
GH_Viewport Methods
GH_Viewport Class See Also Send Feedback

The GH_Viewport type exposes the following members.

Methods

 | Name | Description
Public method | ApplyProjection | Apply the current display transformation to a Graphics object.
Public method | ComputeProjection | Forces a recomputation of all cached data.
Public method | DollyZoom | Advanced interface function for mouse 'dolly' zooming.
Public method | Duplicate |
Public method | Focus(Point) | Look at a specific point.
Public method | Focus(PointF) | Look at a specific point.
Public method | Focus(IGH_Attributes) | Look at a specific object.
Public method | Focus(List<(Of <<'(IGH_Attributes>)>>)) | Look at a set of specific objects.
Public method | IsVisible(PointF%, Single) | Test visibility of a point.
Public method | IsVisible(RectangleF%, Single) | Test visibility of a rectangle.
Public method | LimitUnit | Utility function for calculating pixel dimensions in a zoom-aware environment. The desired value is put through the zoom projection and if the resulting size (as displayed on the screen) exceeds the visual limits it is clipped. This function can be used for example to make sure that a certain penwidth never exceeds visual limits (i.e. it doesn't get too thin or too thick on the screen).
Public method | Project | Transform a point from canvas into control coordinate space.
Public method | ProjectPoint | Project a point from canvas coordinates into control coordinates.
Public method | ProjectRectangle | Project a rectangle from canvas coordinates into control coordinates.
Public method | ProjectX | Project a value along constant X from canvas coordinates into control coordinates.
Public method | ProjectY | Project a value along constant Y from canvas coordinates into control coordinates.
Public method | Set |
Public method | SolveUnit | Utility function for calculating graphics dimensions in a zoom-aware environment. This function can be used for example to compute the linewidth of a pen which always needs to appear as 3 pixels thick on the screen regardless of zoom values.
Public method | Unproject | Transform a point from control into canvas coordinate space.
Public method | UnprojectPoint | Project a point from control coordinates into canvas coordinates.
Public method | UnprojectRectangle | Project a rectangle from control coordinates into canvas coordinates.
Public method | UnprojectX | Project a value along constant X from control coordinates into canvas coordinates.
Public method | UnprojectY | Project a value along constant Y from control coordinates into canvas coordinates.
Public method | XFormMatrix | Gets the display transformation cached by this viewport.

See Also

GH_Viewport Class
Grasshopper.GUI.Canvas Namespace


ApplyProjection Method

[image]

Grasshopper SDK
GH_Viewport..::..ApplyProjection Method
GH_Viewport Class See Also Send Feedback
Apply the current display transformation to a Graphics object.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ApplyProjection(
    Graphics G
)
Visual Basic
Public Sub ApplyProjection ( _
    G As Graphics _
)

Parameters

G
Type: System.Drawing..::..Graphics

See Also

GH_Viewport Class
Grasshopper.GUI.Canvas Namespace


ComputeProjection Method

[image]

Grasshopper SDK
GH_Viewport..::..ComputeProjection Method
GH_Viewport Class See Also Send Feedback
Forces a recomputation of all cached data.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ComputeProjection()
Visual Basic
Public Sub ComputeProjection

See Also

GH_Viewport Class
Grasshopper.GUI.Canvas Namespace


DollyZoom Method

[image]

Grasshopper SDK
GH_Viewport..::..DollyZoom Method
GH_Viewport Class See Also Send Feedback
Advanced interface function for mouse 'dolly' zooming.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool DollyZoom(
    GH_CanvasMouseEvent e
)
Visual Basic
Public Function DollyZoom ( _
    e As GH_CanvasMouseEvent _
) As Boolean

Parameters

e
Type: Grasshopper.GUI..::..GH_CanvasMouseEvent
Event arguments.

Return Value

True if a change to the viewport was made, otherwise false.

See Also

GH_Viewport Class
Grasshopper.GUI.Canvas Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_Viewport..::..Duplicate Method
GH_Viewport Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Viewport Duplicate()
Visual Basic
Public Function Duplicate As GH_Viewport

See Also

GH_Viewport Class
Grasshopper.GUI.Canvas Namespace


Focus Method

[image] [image]

Grasshopper SDK
GH_Viewport..::..Focus Method
GH_Viewport Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Focus(Point) | Look at a specific point.
Public method | Focus(PointF) | Look at a specific point.
Public method | Focus(IGH_Attributes) | Look at a specific object.
Public method | Focus(List<(Of <<'(IGH_Attributes>)>>)) | Look at a set of specific objects.

See Also

GH_Viewport Class
GH_Viewport Members
Grasshopper.GUI.Canvas Namespace


Focus Method (Point)

[image]

Grasshopper SDK
GH_Viewport..::..Focus Method (Point)
GH_Viewport Class See Also Send Feedback
Look at a specific point.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Focus(
    Point pt
)
Visual Basic
Public Sub Focus ( _
    pt As Point _
)

Parameters

pt
Type: System.Drawing..::..Point
Point to focus on.

See Also

GH_Viewport Class
Focus Overload
Grasshopper.GUI.Canvas Namespace


Focus Method (PointF)

[image]

Grasshopper SDK
GH_Viewport..::..Focus Method (PointF)
GH_Viewport Class See Also Send Feedback
Look at a specific point.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Focus(
    PointF pt
)
Visual Basic
Public Sub Focus ( _
    pt As PointF _
)

Parameters

pt
Type: System.Drawing..::..PointF
Point to focus on.

See Also

GH_Viewport Class
Focus Overload
Grasshopper.GUI.Canvas Namespace


Focus Method (IGH_Attributes)

[image]

Grasshopper SDK
GH_Viewport..::..Focus Method (IGH_Attributes)
GH_Viewport Class See Also Send Feedback
Look at a specific object.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Focus(
    IGH_Attributes attribute
)
Visual Basic
Public Sub Focus ( _
    attribute As IGH_Attributes _
)

Parameters

attribute
Type: Grasshopper.Kernel..::..IGH_Attributes
Object attribute to focus on.

See Also

GH_Viewport Class
Focus Overload
Grasshopper.GUI.Canvas Namespace


Focus Method (List(IGH_Attributes))

[image]

Grasshopper SDK
GH_Viewport..::..Focus Method (List<(Of <(<'IGH_Attributes>)>)>)
GH_Viewport Class See Also Send Feedback
Look at a set of specific objects.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Focus(
    List<IGH_Attributes> attributes
)
Visual Basic
Public Sub Focus ( _
    attributes As List(Of IGH_Attributes) _
)

Parameters

attributes
Type: System.Collections.Generic..::..List <(Of <(<' IGH_Attributes >)>)>
Object attributes to focus on.

See Also

GH_Viewport Class
Focus Overload
Grasshopper.GUI.Canvas Namespace


IsVisible Method

[image] [image]

Grasshopper SDK
GH_Viewport..::..IsVisible Method
GH_Viewport Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsVisible(PointF%, Single) | Test visibility of a point.
Public method | IsVisible(RectangleF%, Single) | Test visibility of a rectangle.

See Also

GH_Viewport Class
GH_Viewport Members
Grasshopper.GUI.Canvas Namespace


IsVisible Method (PointF, Single)

[image]

Grasshopper SDK
GH_Viewport..::..IsVisible Method (PointF%, Single)
GH_Viewport Class See Also Send Feedback
Test visibility of a point.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsVisible(
    ref PointF pt,
    float margin
)
Visual Basic
Public Function IsVisible ( _
    ByRef pt As PointF, _
    margin As Single _
) As Boolean

Parameters

pt
Type: System.Drawing..::..PointF %
Point in canvas coordinates.
margin
Type: System..::..Single
Fuzzy area around point to test.

Return Value

True if the point is visible in the control upon projection.

See Also

GH_Viewport Class
IsVisible Overload
Grasshopper.GUI.Canvas Namespace


IsVisible Method (RectangleF, Single)

[image]

Grasshopper SDK
GH_Viewport..::..IsVisible Method (RectangleF%, Single)
GH_Viewport Class See Also Send Feedback
Test visibility of a rectangle.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsVisible(
    ref RectangleF rec,
    float margin
)
Visual Basic
Public Function IsVisible ( _
    ByRef rec As RectangleF, _
    margin As Single _
) As Boolean

Parameters

rec
Type: System.Drawing..::..RectangleF %
Rectangle in canvas coordinates.
margin
Type: System..::..Single
Fuzzy area around rectangle to test.

Return Value

True if the rectangle is visible in the control upon projection.

See Also

GH_Viewport Class
IsVisible Overload
Grasshopper.GUI.Canvas Namespace


LimitUnit Method

[image]

Grasshopper SDK
GH_Viewport..::..LimitUnit Method
GH_Viewport Class See Also Send Feedback
Utility function for calculating pixel dimensions in a zoom-aware environment. The desired value is put through the zoom projection and if the resulting size (as displayed on the screen) exceeds the visual limits it is clipped. This function can be used for example to make sure that a certain penwidth never exceeds visual limits (i.e. it doesn't get too thin or too thick on the screen).

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public float LimitUnit(
    float guide_value,
    float no_less_than,
    float no_more_than
)
Visual Basic
Public Function LimitUnit ( _
    guide_value As Single, _
    no_less_than As Single, _
    no_more_than As Single _
) As Single

Parameters

guide_value
Type: System..::..Single
Initial value.
no_less_than
Type: System..::..Single
Minimum allowed visible size on screen.
no_more_than
Type: System..::..Single
Maximum allowed visible size on screen.

See Also

GH_Viewport Class
Grasshopper.GUI.Canvas Namespace


Project Method

[image]

Grasshopper SDK
GH_Viewport..::..Project Method
GH_Viewport Class See Also Send Feedback
Transform a point from canvas into control coordinate space.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Project(
    ref PointF pt
)
Visual Basic
Public Sub Project ( _
    ByRef pt As PointF _
)

Parameters

pt
Type: System.Drawing..::..PointF %
Point to transform.

See Also

GH_Viewport Class
Grasshopper.GUI.Canvas Namespace


ProjectPoint Method

[image]

Grasshopper SDK
GH_Viewport..::..ProjectPoint Method
GH_Viewport Class See Also Send Feedback
Project a point from canvas coordinates into control coordinates.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public PointF ProjectPoint(
    PointF pt
)
Visual Basic
Public Function ProjectPoint ( _
    pt As PointF _
) As PointF

Parameters

pt
Type: System.Drawing..::..PointF
The point in canvas coordinates.

Return Value

The associated point in control pixel coordinates.

See Also

GH_Viewport Class
Grasshopper.GUI.Canvas Namespace


ProjectRectangle Method

[image]

Grasshopper SDK
GH_Viewport..::..ProjectRectangle Method
GH_Viewport Class See Also Send Feedback
Project a rectangle from canvas coordinates into control coordinates.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public RectangleF ProjectRectangle(
    RectangleF rec
)
Visual Basic
Public Function ProjectRectangle ( _
    rec As RectangleF _
) As RectangleF

Parameters

rec
Type: System.Drawing..::..RectangleF
The rectangle in canvas coordinates.

Return Value

The associated rectangle in control pixel coordinates.

See Also

GH_Viewport Class
Grasshopper.GUI.Canvas Namespace


ProjectX Method

[image]

Grasshopper SDK
GH_Viewport..::..ProjectX Method
GH_Viewport Class See Also Send Feedback
Project a value along constant X from canvas coordinates into control coordinates.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public float ProjectX(
    float x
)
Visual Basic
Public Function ProjectX ( _
    x As Single _
) As Single

Parameters

x
Type: System..::..Single
The constant X value in canvas coordinates.

Return Value

The associated X value in control pixel coordinates.

See Also

GH_Viewport Class
Grasshopper.GUI.Canvas Namespace


ProjectY Method

[image]

Grasshopper SDK
GH_Viewport..::..ProjectY Method
GH_Viewport Class See Also Send Feedback
Project a value along constant Y from canvas coordinates into control coordinates.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public float ProjectY(
    float y
)
Visual Basic
Public Function ProjectY ( _
    y As Single _
) As Single

Parameters

y
Type: System..::..Single
The constant Y value in canvas coordinates.

Return Value

The associated Y value in control pixel coordinates.

See Also

GH_Viewport Class
Grasshopper.GUI.Canvas Namespace


Set Method

[image]

Grasshopper SDK
GH_Viewport..::..Set Method
GH_Viewport Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Set(
    GH_Viewport other
)
Visual Basic
Public Sub Set ( _
    other As GH_Viewport _
)

Parameters

other
Type: Grasshopper.GUI.Canvas..::..GH_Viewport

See Also

GH_Viewport Class
Grasshopper.GUI.Canvas Namespace


SolveUnit Method

[image]

Grasshopper SDK
GH_Viewport..::..SolveUnit Method
GH_Viewport Class See Also Send Feedback
Utility function for calculating graphics dimensions in a zoom-aware environment. This function can be used for example to compute the linewidth of a pen which always needs to appear as 3 pixels thick on the screen regardless of zoom values.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public float SolveUnit(
    float desired,
    float no_less_than,
    float no_more_than
)
Visual Basic
Public Function SolveUnit ( _
    desired As Single, _
    no_less_than As Single, _
    no_more_than As Single _
) As Single

Parameters

desired
Type: System..::..Single
Desired value in pixel units.
no_less_than
Type: System..::..Single
Minimum allowed size in graphics coordinates.
no_more_than
Type: System..::..Single
Maximum allowed size in graphics coordinates.

See Also

GH_Viewport Class
Grasshopper.GUI.Canvas Namespace


Unproject Method

[image]

Grasshopper SDK
GH_Viewport..::..Unproject Method
GH_Viewport Class See Also Send Feedback
Transform a point from control into canvas coordinate space.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Unproject(
    ref PointF pt
)
Visual Basic
Public Sub Unproject ( _
    ByRef pt As PointF _
)

Parameters

pt
Type: System.Drawing..::..PointF %
Point to transform.

See Also

GH_Viewport Class
Grasshopper.GUI.Canvas Namespace


UnprojectPoint Method

[image]

Grasshopper SDK
GH_Viewport..::..UnprojectPoint Method
GH_Viewport Class See Also Send Feedback
Project a point from control coordinates into canvas coordinates.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public PointF UnprojectPoint(
    PointF pt
)
Visual Basic
Public Function UnprojectPoint ( _
    pt As PointF _
) As PointF

Parameters

pt
Type: System.Drawing..::..PointF
The point in control coordinates.

Return Value

The associated point in canvas coordinates.

See Also

GH_Viewport Class
Grasshopper.GUI.Canvas Namespace


UnprojectRectangle Method

[image]

Grasshopper SDK
GH_Viewport..::..UnprojectRectangle Method
GH_Viewport Class See Also Send Feedback
Project a rectangle from control coordinates into canvas coordinates.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public RectangleF UnprojectRectangle(
    RectangleF rec
)
Visual Basic
Public Function UnprojectRectangle ( _
    rec As RectangleF _
) As RectangleF

Parameters

rec
Type: System.Drawing..::..RectangleF
The rectangle in control coordinates.

Return Value

The associated rectangle in canvas coordinates.

See Also

GH_Viewport Class
Grasshopper.GUI.Canvas Namespace


UnprojectX Method

[image]

Grasshopper SDK
GH_Viewport..::..UnprojectX Method
GH_Viewport Class See Also Send Feedback
Project a value along constant X from control coordinates into canvas coordinates.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public float UnprojectX(
    float x
)
Visual Basic
Public Function UnprojectX ( _
    x As Single _
) As Single

Parameters

x
Type: System..::..Single
The constant X value in control coordinates.

Return Value

The associated X value in canvas coordinates.

See Also

GH_Viewport Class
Grasshopper.GUI.Canvas Namespace


UnprojectY Method

[image]

Grasshopper SDK
GH_Viewport..::..UnprojectY Method
GH_Viewport Class See Also Send Feedback
Project a value along constant Y from control coordinates into canvas coordinates.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public float UnprojectY(
    float y
)
Visual Basic
Public Function UnprojectY ( _
    y As Single _
) As Single

Parameters

y
Type: System..::..Single
The constant Y value in control coordinates.

Return Value

The associated Y value in canvas coordinates.

See Also

GH_Viewport Class
Grasshopper.GUI.Canvas Namespace


XFormMatrix Method

[image]

Grasshopper SDK
GH_Viewport..::..XFormMatrix Method
GH_Viewport Class See Also Send Feedback
Gets the display transformation cached by this viewport.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Matrix XFormMatrix(
    GH_Viewport..::..GH_DisplayMatrix projection
)
Visual Basic
Public Function XFormMatrix ( _
    projection As GH_Viewport..::..GH_DisplayMatrix _
) As Matrix

Parameters

projection
Type: Grasshopper.GUI.Canvas..::..GH_Viewport..::..GH_DisplayMatrix

See Also

GH_Viewport Class
Grasshopper.GUI.Canvas Namespace


GH_Viewport Properties

[image] [image]

Grasshopper SDK
GH_Viewport Properties
GH_Viewport Class See Also Send Feedback

The GH_Viewport type exposes the following members.

Properties

 | Name | Description
Public property | ControlMidPoint | Gets the point in the exact center of the viewport in control coordinates.
Public property | Diagonal | Gets the length of the diagonal of the viewport in canvas coordinates.
Public property | Height | Gets or sets the height of the viewport. Typically this is tied to the dimensions of the canvas. Height is not allowed to go below 5 pixels.
Public property | MidPoint | Gets or sets the canvas coordinate that is directly underneath the center of the viewport.
Public property | ScreenPort | Gets the dimensions of the viewport in control coordinates.
Public property | Size | Gets or sets the size of the viewport. The size is typically tied to the dimensions of the Canvas.
Public property | Target | Gets or sets the location of the target pixel. The target represents where the canvas origin is drawn.
Public property | TargetRatio | Gets or sets the target ratio with respect to the viewport dimensions. This is a useful tool to prevent weird view changes during a canvas resize.
Public property | Tx | Gets or sets the x-component of the target pixel. The target represents where the canvas origin is drawn.
Public property | Ty | Gets or sets the y-component of the target pixel. The target represents where the canvas origin is drawn.
Public property | VisibleRegion | Gets the rectangle in canvas coordinates that is visible in the control.
Public property | Width | Gets or sets the width of the viewport. Typically this is tied to the dimensions of the canvas. Width is not allowed to go below 5 pixels.
Public property | Zoom | Gets or sets the Zoom factor of the viewport. Please assign only sensible values.
Public property | Zoom[([( Boolean])]) | Sets the zoom of the viewport with a view anchor.
Public property | ZoomInverse | Gets the inverse of the zoom.

See Also

GH_Viewport Class
Grasshopper.GUI.Canvas Namespace


ControlMidPoint Property

[image]

Grasshopper SDK
GH_Viewport..::..ControlMidPoint Property
GH_Viewport Class See Also Send Feedback
Gets the point in the exact center of the viewport in control coordinates.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public PointF ControlMidPoint { get; }
Visual Basic
Public ReadOnly Property ControlMidPoint As PointF
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Viewport.ControlMidPoint"]

See Also

GH_Viewport Class
Grasshopper.GUI.Canvas Namespace


Diagonal Property

[image]

Grasshopper SDK
GH_Viewport..::..Diagonal Property
GH_Viewport Class See Also Send Feedback
Gets the length of the diagonal of the viewport in canvas coordinates.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public float Diagonal { get; }
Visual Basic
Public ReadOnly Property Diagonal As Single
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Viewport.Diagonal"]

See Also

GH_Viewport Class
Grasshopper.GUI.Canvas Namespace


Height Property

[image]

Grasshopper SDK
GH_Viewport..::..Height Property
GH_Viewport Class See Also Send Feedback
Gets or sets the height of the viewport. Typically this is tied to the dimensions of the canvas. Height is not allowed to go below 5 pixels.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int Height { get; set; }
Visual Basic
Public Property Height As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Viewport.Height"]

See Also

GH_Viewport Class
Grasshopper.GUI.Canvas Namespace


MidPoint Property

[image]

Grasshopper SDK
GH_Viewport..::..MidPoint Property
GH_Viewport Class See Also Send Feedback
Gets or sets the canvas coordinate that is directly underneath the center of the viewport.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public PointF MidPoint { get; set; }
Visual Basic
Public Property MidPoint As PointF
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Viewport.MidPoint"]

See Also

GH_Viewport Class
Grasshopper.GUI.Canvas Namespace


ScreenPort Property

[image]

Grasshopper SDK
GH_Viewport..::..ScreenPort Property
GH_Viewport Class See Also Send Feedback
Gets the dimensions of the viewport in control coordinates.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle ScreenPort { get; }
Visual Basic
Public ReadOnly Property ScreenPort As Rectangle
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Viewport.ScreenPort"]

See Also

GH_Viewport Class
Grasshopper.GUI.Canvas Namespace


Size Property

[image]

Grasshopper SDK
GH_Viewport..::..Size Property
GH_Viewport Class See Also Send Feedback
Gets or sets the size of the viewport. The size is typically tied to the dimensions of the Canvas.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Size Size { get; set; }
Visual Basic
Public Property Size As Size
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Viewport.Size"]

See Also

GH_Viewport Class
Grasshopper.GUI.Canvas Namespace


Target Property

[image]

Grasshopper SDK
GH_Viewport..::..Target Property
GH_Viewport Class See Also Send Feedback
Gets or sets the location of the target pixel. The target represents where the canvas origin is drawn.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Point Target { get; set; }
Visual Basic
Public Property Target As Point
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Viewport.Target"]

See Also

GH_Viewport Class
Grasshopper.GUI.Canvas Namespace


TargetRatio Property

[image]

Grasshopper SDK
GH_Viewport..::..TargetRatio Property
GH_Viewport Class See Also Send Feedback
Gets or sets the target ratio with respect to the viewport dimensions. This is a useful tool to prevent weird view changes during a canvas resize.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public SizeF TargetRatio { get; set; }
Visual Basic
Public Property TargetRatio As SizeF
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Viewport.TargetRatio"]

See Also

GH_Viewport Class
Grasshopper.GUI.Canvas Namespace


Tx Property

[image]

Grasshopper SDK
GH_Viewport..::..Tx Property
GH_Viewport Class See Also Send Feedback
Gets or sets the x-component of the target pixel. The target represents where the canvas origin is drawn.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int Tx { get; set; }
Visual Basic
Public Property Tx As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Viewport.Tx"]

See Also

GH_Viewport Class
Grasshopper.GUI.Canvas Namespace


Ty Property

[image]

Grasshopper SDK
GH_Viewport..::..Ty Property
GH_Viewport Class See Also Send Feedback
Gets or sets the y-component of the target pixel. The target represents where the canvas origin is drawn.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int Ty { get; set; }
Visual Basic
Public Property Ty As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Viewport.Ty"]

See Also

GH_Viewport Class
Grasshopper.GUI.Canvas Namespace


VisibleRegion Property

[image]

Grasshopper SDK
GH_Viewport..::..VisibleRegion Property
GH_Viewport Class See Also Send Feedback
Gets the rectangle in canvas coordinates that is visible in the control.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public RectangleF VisibleRegion { get; }
Visual Basic
Public ReadOnly Property VisibleRegion As RectangleF
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Viewport.VisibleRegion"]

See Also

GH_Viewport Class
Grasshopper.GUI.Canvas Namespace


Width Property

[image]

Grasshopper SDK
GH_Viewport..::..Width Property
GH_Viewport Class See Also Send Feedback
Gets or sets the width of the viewport. Typically this is tied to the dimensions of the canvas. Width is not allowed to go below 5 pixels.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int Width { get; set; }
Visual Basic
Public Property Width As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Viewport.Width"]

See Also

GH_Viewport Class
Grasshopper.GUI.Canvas Namespace


Zoom Property

[image] [image]

Grasshopper SDK
GH_Viewport..::..Zoom Property
GH_Viewport Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Zoom | Gets or sets the Zoom factor of the viewport. Please assign only sensible values.
Public property | Zoom[([( Boolean])]) | Sets the zoom of the viewport with a view anchor.

See Also

GH_Viewport Class
GH_Viewport Members
Grasshopper.GUI.Canvas Namespace


Zoom Property

[image]

Grasshopper SDK
GH_Viewport..::..Zoom Property
GH_Viewport Class See Also Send Feedback
Gets or sets the Zoom factor of the viewport. Please assign only sensible values.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public float Zoom { get; set; }
Visual Basic
Public Property Zoom As Single
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Viewport.Zoom"]

See Also

GH_Viewport Class
Zoom Overload
Grasshopper.GUI.Canvas Namespace


Zoom Property (Boolean)

[image]

Grasshopper SDK
GH_Viewport..::..Zoom Property (Boolean)
GH_Viewport Class See Also Send Feedback
Sets the zoom of the viewport with a view anchor.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public float this[
    bool adjustTarget
] { set; }
Visual Basic
Public WriteOnly Property Zoom ( _
    adjustTarget As Boolean _
) As Single
    Set

Parameters

adjustTarget
Type: System..::..Boolean
If true, the target will be adjusted so that the center point remains the same.

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Viewport.Zoom(System.Boolean)"]

See Also

GH_Viewport Class
Zoom Overload
Grasshopper.GUI.Canvas Namespace


ZoomInverse Property

[image]

Grasshopper SDK
GH_Viewport..::..ZoomInverse Property
GH_Viewport Class See Also Send Feedback
Gets the inverse of the zoom.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public float ZoomInverse { get; }
Visual Basic
Public ReadOnly Property ZoomInverse As Single
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.GH_Viewport.ZoomInverse"]

See Also

GH_Viewport Class
Grasshopper.GUI.Canvas Namespace


GH_Viewport.GH_DisplayMatrix Enumeration

[image]

Grasshopper SDK
GH_Viewport..::..GH_DisplayMatrix Enumeration
GH_Viewport Class See Also Send Feedback
Enumerates the possible Display Transformation matrices.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_DisplayMatrix
Visual Basic
Public Enumeration GH_DisplayMatrix

Members

Member name | Value | Description
CanvasToControl | 0 |
ControlToCanvas | 1 |

See Also

Grasshopper.GUI.Canvas Namespace


GH_WireDirection Enumeration

[image]

Grasshopper SDK
GH_WireDirection Enumeration
See Also Send Feedback
Identifies a wire direction.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_WireDirection
Visual Basic
Public Enumeration GH_WireDirection

Members

Member name | Value | Description
left | 0 |
right | 1 |

See Also

Grasshopper.GUI.Canvas Namespace


GH_WireType Enumeration

[image]

Grasshopper SDK
GH_WireType Enumeration
See Also Send Feedback
Enumerates the different kinds of connecting wires.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_WireType
Visual Basic
Public Enumeration GH_WireType

Members

Member name | Value | Description
dynamic | 0 | Dynamic indicates the wire is in the process of being made.
wireless | 1 | Wireless connector. Will be drawn dotted when either end is selected.
generic | 2 | Generic connector wire. Can't go wrong with generic.
faint | 3 | Similar to generic, but less pronounced.
null | 4 | Wire with null data transfer.
item | 5 | Wire with a single data transfer.
list | 6 | Wire with a single list transfer.
tree | 7 | Wire with multiple list transfer.

See Also

Grasshopper.GUI.Canvas Namespace


IGH_ResponsiveObject Interface

[image]

Grasshopper SDK
IGH_ResponsiveObject Interface
Members See Also Send Feedback
If you wish to participate in Canvas UI events, you must implement this interface.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_ResponsiveObject
Visual Basic
Public Interface IGH_ResponsiveObject

See Also

IGH_ResponsiveObject Members
Grasshopper.GUI.Canvas Namespace


IGH_ResponsiveObject Members

[image] [image]

Grasshopper SDK
IGH_ResponsiveObject Members
IGH_ResponsiveObject Interface Methods See Also Send Feedback

The IGH_ResponsiveObject type exposes the following members.

Methods

 | Name | Description
Public method | RespondToKeyDown |
Public method | RespondToKeyUp |
Public method | RespondToMouseDoubleClick | This function will be called whenever the left button is double-clicked over the canvas. If you are active, you will be the only object who gets called.
Public method | RespondToMouseDown | This function will be called whenever a mouse button is pressed over the canvas. If you are active, you will be the only object who gets called. If you are inactive, you might get called if nobody on top of you decides to become active.
Public method | RespondToMouseMove | This function will be called when the mouse moves across the canvas. If you are active, you will be the only object who gets called. If you are inactive, you might get called if nobody on top of you decides to become active.
Public method | RespondToMouseUp | This function will be called whenever a mouse button is released over the canvas. If you are active, you will be the only object who gets called. If you are inactive, you will not be called at all for MouseUp events.

See Also

IGH_ResponsiveObject Interface
Grasshopper.GUI.Canvas Namespace


IGH_ResponsiveObject Methods

[image] [image]

Grasshopper SDK
IGH_ResponsiveObject Methods
IGH_ResponsiveObject Interface See Also Send Feedback

The IGH_ResponsiveObject type exposes the following members.

Methods

 | Name | Description
Public method | RespondToKeyDown |
Public method | RespondToKeyUp |
Public method | RespondToMouseDoubleClick | This function will be called whenever the left button is double-clicked over the canvas. If you are active, you will be the only object who gets called.
Public method | RespondToMouseDown | This function will be called whenever a mouse button is pressed over the canvas. If you are active, you will be the only object who gets called. If you are inactive, you might get called if nobody on top of you decides to become active.
Public method | RespondToMouseMove | This function will be called when the mouse moves across the canvas. If you are active, you will be the only object who gets called. If you are inactive, you might get called if nobody on top of you decides to become active.
Public method | RespondToMouseUp | This function will be called whenever a mouse button is released over the canvas. If you are active, you will be the only object who gets called. If you are inactive, you will not be called at all for MouseUp events.

See Also

IGH_ResponsiveObject Interface
Grasshopper.GUI.Canvas Namespace


RespondToKeyDown Method

[image]

Grasshopper SDK
IGH_ResponsiveObject..::..RespondToKeyDown Method
IGH_ResponsiveObject Interface See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
GH_ObjectResponse RespondToKeyDown(
    GH_Canvas sender,
    KeyEventArgs e
)
Visual Basic
Function RespondToKeyDown ( _
    sender As GH_Canvas, _
    e As KeyEventArgs _
) As GH_ObjectResponse

Parameters

sender
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
e
Type: System.Windows.Forms..::..KeyEventArgs

See Also

IGH_ResponsiveObject Interface
Grasshopper.GUI.Canvas Namespace


RespondToKeyUp Method

[image]

Grasshopper SDK
IGH_ResponsiveObject..::..RespondToKeyUp Method
IGH_ResponsiveObject Interface See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
GH_ObjectResponse RespondToKeyUp(
    GH_Canvas sender,
    KeyEventArgs e
)
Visual Basic
Function RespondToKeyUp ( _
    sender As GH_Canvas, _
    e As KeyEventArgs _
) As GH_ObjectResponse

Parameters

sender
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
e
Type: System.Windows.Forms..::..KeyEventArgs

See Also

IGH_ResponsiveObject Interface
Grasshopper.GUI.Canvas Namespace


RespondToMouseDoubleClick Method

[image]

Grasshopper SDK
IGH_ResponsiveObject..::..RespondToMouseDoubleClick Method
IGH_ResponsiveObject Interface See Also Send Feedback
This function will be called whenever the left button is double-clicked over the canvas. If you are active, you will be the only object who gets called.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
GH_ObjectResponse RespondToMouseDoubleClick(
    GH_Canvas sender,
    GH_CanvasMouseEvent e
)
Visual Basic
Function RespondToMouseDoubleClick ( _
    sender As GH_Canvas, _
    e As GH_CanvasMouseEvent _
) As GH_ObjectResponse

Parameters

sender
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
Base canvas.
e
Type: Grasshopper.GUI..::..GH_CanvasMouseEvent
Mouse event arguments.

Return Value

All Response flags are valid.

See Also

IGH_ResponsiveObject Interface
Grasshopper.GUI.Canvas Namespace


RespondToMouseDown Method

[image]

Grasshopper SDK
IGH_ResponsiveObject..::..RespondToMouseDown Method
IGH_ResponsiveObject Interface See Also Send Feedback
This function will be called whenever a mouse button is pressed over the canvas. If you are active, you will be the only object who gets called. If you are inactive, you might get called if nobody on top of you decides to become active.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
GH_ObjectResponse RespondToMouseDown(
    GH_Canvas sender,
    GH_CanvasMouseEvent e
)
Visual Basic
Function RespondToMouseDown ( _
    sender As GH_Canvas, _
    e As GH_CanvasMouseEvent _
) As GH_ObjectResponse

Parameters

sender
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
Base canvas.
e
Type: Grasshopper.GUI..::..GH_CanvasMouseEvent
Mouse event arguments.

Return Value

All Response flags are valid.

See Also

IGH_ResponsiveObject Interface
Grasshopper.GUI.Canvas Namespace


RespondToMouseMove Method

[image]

Grasshopper SDK
IGH_ResponsiveObject..::..RespondToMouseMove Method
IGH_ResponsiveObject Interface See Also Send Feedback
This function will be called when the mouse moves across the canvas. If you are active, you will be the only object who gets called. If you are inactive, you might get called if nobody on top of you decides to become active.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
GH_ObjectResponse RespondToMouseMove(
    GH_Canvas sender,
    GH_CanvasMouseEvent e
)
Visual Basic
Function RespondToMouseMove ( _
    sender As GH_Canvas, _
    e As GH_CanvasMouseEvent _
) As GH_ObjectResponse

Parameters

sender
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
Base canvas.
e
Type: Grasshopper.GUI..::..GH_CanvasMouseEvent
Mouse event arguments.

Return Value

All Response flags are valid.

See Also

IGH_ResponsiveObject Interface
Grasshopper.GUI.Canvas Namespace


RespondToMouseUp Method

[image]

Grasshopper SDK
IGH_ResponsiveObject..::..RespondToMouseUp Method
IGH_ResponsiveObject Interface See Also Send Feedback
This function will be called whenever a mouse button is released over the canvas. If you are active, you will be the only object who gets called. If you are inactive, you will not be called at all for MouseUp events.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
GH_ObjectResponse RespondToMouseUp(
    GH_Canvas sender,
    GH_CanvasMouseEvent e
)
Visual Basic
Function RespondToMouseUp ( _
    sender As GH_Canvas, _
    e As GH_CanvasMouseEvent _
) As GH_ObjectResponse

Parameters

sender
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
Base canvas.
e
Type: Grasshopper.GUI..::..GH_CanvasMouseEvent
Mouse event arguments.

Return Value

All Response flags are valid.

See Also

IGH_ResponsiveObject Interface
Grasshopper.GUI.Canvas Namespace


IGH_TooltipAwareObject Interface

[image]

Grasshopper SDK
IGH_TooltipAwareObject Interface
Members See Also Send Feedback
Implement this interface if you want your object to participate in Grasshopper Canvas tooltips.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_TooltipAwareObject
Visual Basic
Public Interface IGH_TooltipAwareObject

See Also

IGH_TooltipAwareObject Members
Grasshopper.GUI.Canvas Namespace


IGH_TooltipAwareObject Members

[image] [image]

Grasshopper SDK
IGH_TooltipAwareObject Members
IGH_TooltipAwareObject Interface Methods Properties See Also Send Feedback

The IGH_TooltipAwareObject type exposes the following members.

Methods

 | Name | Description
Public method | IsTooltipRegion | Determine whether the specified pixel should result in a tooltip when the cursor hovers over it.
Public method | SetupTooltip | This function is called when a tooltip it about to be displayed.

Properties

 | Name | Description
Public property | TooltipEnabled | Gets the tooltip enabled value. If False, no further tooltip functions will be called.

See Also

IGH_TooltipAwareObject Interface
Grasshopper.GUI.Canvas Namespace


IGH_TooltipAwareObject Methods

[image] [image]

Grasshopper SDK
IGH_TooltipAwareObject Methods
IGH_TooltipAwareObject Interface See Also Send Feedback

The IGH_TooltipAwareObject type exposes the following members.

Methods

 | Name | Description
Public method | IsTooltipRegion | Determine whether the specified pixel should result in a tooltip when the cursor hovers over it.
Public method | SetupTooltip | This function is called when a tooltip it about to be displayed.

See Also

IGH_TooltipAwareObject Interface
Grasshopper.GUI.Canvas Namespace


IsTooltipRegion Method

[image]

Grasshopper SDK
IGH_TooltipAwareObject..::..IsTooltipRegion Method
IGH_TooltipAwareObject Interface See Also Send Feedback
Determine whether the specified pixel should result in a tooltip when the cursor hovers over it.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool IsTooltipRegion(
    PointF canvasPoint
)
Visual Basic
Function IsTooltipRegion ( _
    canvasPoint As PointF _
) As Boolean

Parameters

canvasPoint
Type: System.Drawing..::..PointF
Point in Canvas coordinates.

See Also

IGH_TooltipAwareObject Interface
Grasshopper.GUI.Canvas Namespace


SetupTooltip Method

[image]

Grasshopper SDK
IGH_TooltipAwareObject..::..SetupTooltip Method
IGH_TooltipAwareObject Interface See Also Send Feedback
This function is called when a tooltip it about to be displayed.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void SetupTooltip(
    PointF canvasPoint,
    GH_TooltipDisplayEventArgs e
)
Visual Basic
Sub SetupTooltip ( _
    canvasPoint As PointF, _
    e As GH_TooltipDisplayEventArgs _
)

Parameters

canvasPoint
Type: System.Drawing..::..PointF
The pixel coordinate on the canvas of the cursor.
e
Type: Grasshopper.GUI..::..GH_TooltipDisplayEventArgs
Tooltip display arguments.

See Also

IGH_TooltipAwareObject Interface
Grasshopper.GUI.Canvas Namespace


IGH_TooltipAwareObject Properties

[image] [image]

Grasshopper SDK
IGH_TooltipAwareObject Properties
IGH_TooltipAwareObject Interface See Also Send Feedback

The IGH_TooltipAwareObject type exposes the following members.

Properties

 | Name | Description
Public property | TooltipEnabled | Gets the tooltip enabled value. If False, no further tooltip functions will be called.

See Also

IGH_TooltipAwareObject Interface
Grasshopper.GUI.Canvas Namespace


TooltipEnabled Property

[image]

Grasshopper SDK
IGH_TooltipAwareObject..::..TooltipEnabled Property
IGH_TooltipAwareObject Interface See Also Send Feedback
Gets the tooltip enabled value. If False, no further tooltip functions will be called.

Namespace: Grasshopper.GUI.Canvas
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool TooltipEnabled { get; }
Visual Basic
ReadOnly Property TooltipEnabled As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.IGH_TooltipAwareObject.TooltipEnabled"]

See Also

IGH_TooltipAwareObject Interface
Grasshopper.GUI.Canvas Namespace


Grasshopper.GUI.Canvas.TagArtists Namespace

[image]

Grasshopper SDK
Grasshopper.GUI.Canvas.TagArtists Namespace
Send Feedback
This namespace contains all types associated with canvas paint event hooks.

Classes

 | Class | Description
Public class | GH_TagArtist | Provides a basic implementation of the IGH_TagArtist interface.
Public class | GH_TagArtist_WirePainter | IGH_TagArtist implementation for drawing individual wires.

Interfaces

 | Interface | Description
Public interface | IGH_TagArtist | Defines the interface for TagArtist objects. TagArtists can be used to paint additional stuff onto a GH_Canvas.


GH_TagArtist Class

[image]

Grasshopper SDK
GH_TagArtist Class
Members See Also Send Feedback
Provides a basic implementation of the IGH_TagArtist interface.

Namespace: Grasshopper.GUI.Canvas.TagArtists
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract class GH_TagArtist : IGH_TagArtist
Visual Basic
Public MustInherit Class GH_TagArtist _
    Implements IGH_TagArtist

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI.Canvas.TagArtists..::..GH_TagArtist
Grasshopper.GUI.Canvas.TagArtists..::..GH_TagArtist_WirePainter

See Also

GH_TagArtist Members
Grasshopper.GUI.Canvas.TagArtists Namespace


GH_TagArtist Members

[image] [image]

Grasshopper SDK
GH_TagArtist Members
GH_TagArtist Class Constructors Methods Properties See Also Send Feedback

The GH_TagArtist type exposes the following members.

Constructors

 | Name | Description
Protected method | GH_TagArtist | Initializes a new instance of the GH_TagArtist class

Methods

 | Name | Description
Public method | Paint | This method is called whenever a Canvas channel is painted

Properties

 | Name | Description
Public property | ID | Gets the ID of this TagArtist object.

See Also

GH_TagArtist Class
Grasshopper.GUI.Canvas.TagArtists Namespace


GH_TagArtist Constructor

[image]

Grasshopper SDK
GH_TagArtist Constructor
GH_TagArtist Class See Also Send Feedback
Initializes a new instance of the GH_TagArtist class

Namespace: Grasshopper.GUI.Canvas.TagArtists
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_TagArtist(
    Guid id
)
Visual Basic
Protected Sub New ( _
    id As Guid _
)

Parameters

id
Type: System..::..Guid

See Also

GH_TagArtist Class
Grasshopper.GUI.Canvas.TagArtists Namespace


GH_TagArtist Methods

[image] [image]

Grasshopper SDK
GH_TagArtist Methods
GH_TagArtist Class See Also Send Feedback

The GH_TagArtist type exposes the following members.

Methods

 | Name | Description
Public method | Paint | This method is called whenever a Canvas channel is painted

See Also

GH_TagArtist Class
Grasshopper.GUI.Canvas.TagArtists Namespace


Paint Method

[image]

Grasshopper SDK
GH_TagArtist..::..Paint Method
GH_TagArtist Class See Also Send Feedback
This method is called whenever a Canvas channel is painted

Namespace: Grasshopper.GUI.Canvas.TagArtists
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract void Paint(
    GH_Canvas canvas,
    GH_CanvasChannel channel
)
Visual Basic
Public MustOverride Sub Paint ( _
    canvas As GH_Canvas, _
    channel As GH_CanvasChannel _
)

Parameters

canvas
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
Canvas that is currently painting.
channel
Type: Grasshopper.GUI.Canvas..::..GH_CanvasChannel
Channel that is currently being painted.

Implements

IGH_TagArtist..::..Paint(GH_Canvas, GH_CanvasChannel)

See Also

GH_TagArtist Class
Grasshopper.GUI.Canvas.TagArtists Namespace


GH_TagArtist Properties

[image] [image]

Grasshopper SDK
GH_TagArtist Properties
GH_TagArtist Class See Also Send Feedback

The GH_TagArtist type exposes the following members.

Properties

 | Name | Description
Public property | ID | Gets the ID of this TagArtist object.

See Also

GH_TagArtist Class
Grasshopper.GUI.Canvas.TagArtists Namespace


ID Property

[image]

Grasshopper SDK
GH_TagArtist..::..ID Property
GH_TagArtist Class See Also Send Feedback
Gets the ID of this TagArtist object.

Namespace: Grasshopper.GUI.Canvas.TagArtists
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid ID { get; }
Visual Basic
Public ReadOnly Property ID As Guid
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.TagArtists.GH_TagArtist.ID"]

Implements

IGH_TagArtist..::..ID

See Also

GH_TagArtist Class
Grasshopper.GUI.Canvas.TagArtists Namespace


GH_TagArtist_WirePainter Class

[image]

Grasshopper SDK
GH_TagArtist_WirePainter Class
Members See Also Send Feedback
IGH_TagArtist implementation for drawing individual wires.

Namespace: Grasshopper.GUI.Canvas.TagArtists
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_TagArtist_WirePainter : GH_TagArtist
Visual Basic
Public Class GH_TagArtist_WirePainter _
    Inherits GH_TagArtist

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI.Canvas.TagArtists..::..GH_TagArtist
Grasshopper.GUI.Canvas.TagArtists..::..GH_TagArtist_WirePainter

See Also

GH_TagArtist_WirePainter Members
Grasshopper.GUI.Canvas.TagArtists Namespace


GH_TagArtist_WirePainter Members

[image] [image]

Grasshopper SDK
GH_TagArtist_WirePainter Members
GH_TagArtist_WirePainter Class Constructors Methods Properties See Also Send Feedback

The GH_TagArtist_WirePainter type exposes the following members.

Constructors

 | Name | Description
Public method | GH_TagArtist_WirePainter | Initializes a new instance of the GH_TagArtist_WirePainter class

Methods

 | Name | Description
Public method | Paint | (Overrides GH_TagArtist..::..Paint(GH_Canvas, GH_CanvasChannel).)

Properties

 | Name | Description
Public property | ID | Gets the ID of this TagArtist object. (Inherited from GH_TagArtist.)
 | WirePainter_ID |

See Also

GH_TagArtist_WirePainter Class
Grasshopper.GUI.Canvas.TagArtists Namespace


GH_TagArtist_WirePainter Constructor

[image]

Grasshopper SDK
GH_TagArtist_WirePainter Constructor
GH_TagArtist_WirePainter Class See Also Send Feedback
Initializes a new instance of the GH_TagArtist_WirePainter class

Namespace: Grasshopper.GUI.Canvas.TagArtists
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_TagArtist_WirePainter(
    IGH_Param source,
    IGH_Param target,
    Color colour,
    int width
)
Visual Basic
Public Sub New ( _
    source As IGH_Param, _
    target As IGH_Param, _
    colour As Color, _
    width As Integer _
)

Parameters

source
Type: Grasshopper.Kernel..::..IGH_Param
target
Type: Grasshopper.Kernel..::..IGH_Param
colour
Type: System.Drawing..::..Color
width
Type: System..::..Int32

See Also

GH_TagArtist_WirePainter Class
Grasshopper.GUI.Canvas.TagArtists Namespace


GH_TagArtist_WirePainter Methods

[image] [image]

Grasshopper SDK
GH_TagArtist_WirePainter Methods
GH_TagArtist_WirePainter Class See Also Send Feedback

The GH_TagArtist_WirePainter type exposes the following members.

Methods

 | Name | Description
Public method | Paint | (Overrides GH_TagArtist..::..Paint(GH_Canvas, GH_CanvasChannel).)

See Also

GH_TagArtist_WirePainter Class
Grasshopper.GUI.Canvas.TagArtists Namespace


Paint Method

[image]

Grasshopper SDK
GH_TagArtist_WirePainter..::..Paint Method
GH_TagArtist_WirePainter Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas.TagArtists
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void Paint(
    GH_Canvas canvas,
    GH_CanvasChannel channel
)
Visual Basic
Public Overrides Sub Paint ( _
    canvas As GH_Canvas, _
    channel As GH_CanvasChannel _
)

Parameters

canvas
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
channel
Type: Grasshopper.GUI.Canvas..::..GH_CanvasChannel

See Also

GH_TagArtist_WirePainter Class
Grasshopper.GUI.Canvas.TagArtists Namespace


GH_TagArtist_WirePainter Properties

[image] [image]

Grasshopper SDK
GH_TagArtist_WirePainter Properties
GH_TagArtist_WirePainter Class See Also Send Feedback

The GH_TagArtist_WirePainter type exposes the following members.

Properties

 | Name | Description
Public property | ID | Gets the ID of this TagArtist object. (Inherited from GH_TagArtist.)
 | WirePainter_ID |

See Also

GH_TagArtist_WirePainter Class
Grasshopper.GUI.Canvas.TagArtists Namespace


WirePainter_ID Property

[image]

Grasshopper SDK
GH_TagArtist_WirePainter..::..WirePainter_ID Property
GH_TagArtist_WirePainter Class See Also Send Feedback

Namespace: Grasshopper.GUI.Canvas.TagArtists
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid WirePainter_ID { get; }
Visual Basic
Public Shared ReadOnly Property WirePainter_ID As Guid
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.TagArtists.GH_TagArtist_WirePainter.WirePainter_ID"]

See Also

GH_TagArtist_WirePainter Class
Grasshopper.GUI.Canvas.TagArtists Namespace


IGH_TagArtist Interface

[image]

Grasshopper SDK
IGH_TagArtist Interface
Members See Also Send Feedback
Defines the interface for TagArtist objects. TagArtists can be used to paint additional stuff onto a GH_Canvas.

Namespace: Grasshopper.GUI.Canvas.TagArtists
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_TagArtist
Visual Basic
Public Interface IGH_TagArtist

See Also

IGH_TagArtist Members
Grasshopper.GUI.Canvas.TagArtists Namespace


IGH_TagArtist Members

[image] [image]

Grasshopper SDK
IGH_TagArtist Members
IGH_TagArtist Interface Methods Properties See Also Send Feedback

The IGH_TagArtist type exposes the following members.

Methods

 | Name | Description
Public method | Paint | This method is called whenever a Canvas channel is painted

Properties

 | Name | Description
Public property | ID | Gets the ID of this Tag Artist object.

See Also

IGH_TagArtist Interface
Grasshopper.GUI.Canvas.TagArtists Namespace


IGH_TagArtist Methods

[image] [image]

Grasshopper SDK
IGH_TagArtist Methods
IGH_TagArtist Interface See Also Send Feedback

The IGH_TagArtist type exposes the following members.

Methods

 | Name | Description
Public method | Paint | This method is called whenever a Canvas channel is painted

See Also

IGH_TagArtist Interface
Grasshopper.GUI.Canvas.TagArtists Namespace


Paint Method

[image]

Grasshopper SDK
IGH_TagArtist..::..Paint Method
IGH_TagArtist Interface See Also Send Feedback
This method is called whenever a Canvas channel is painted

Namespace: Grasshopper.GUI.Canvas.TagArtists
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void Paint(
    GH_Canvas canvas,
    GH_CanvasChannel channel
)
Visual Basic
Sub Paint ( _
    canvas As GH_Canvas, _
    channel As GH_CanvasChannel _
)

Parameters

canvas
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
Canvas that is currently painting.
channel
Type: Grasshopper.GUI.Canvas..::..GH_CanvasChannel
Channel that is currently being painted.

See Also

IGH_TagArtist Interface
Grasshopper.GUI.Canvas.TagArtists Namespace


IGH_TagArtist Properties

[image] [image]

Grasshopper SDK
IGH_TagArtist Properties
IGH_TagArtist Interface See Also Send Feedback

The IGH_TagArtist type exposes the following members.

Properties

 | Name | Description
Public property | ID | Gets the ID of this Tag Artist object.

See Also

IGH_TagArtist Interface
Grasshopper.GUI.Canvas.TagArtists Namespace


ID Property

[image]

Grasshopper SDK
IGH_TagArtist..::..ID Property
IGH_TagArtist Interface See Also Send Feedback
Gets the ID of this Tag Artist object.

Namespace: Grasshopper.GUI.Canvas.TagArtists
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
Guid ID { get; }
Visual Basic
ReadOnly Property ID As Guid
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Canvas.TagArtists.IGH_TagArtist.ID"]

See Also

IGH_TagArtist Interface
Grasshopper.GUI.Canvas.TagArtists Namespace


Grasshopper.GUI.Gradient Namespace

[image]

Grasshopper SDK
Grasshopper.GUI.Gradient Namespace
Send Feedback

Classes

 | Class | Description
Public class | GH_Gradient | Represents a colour gradient defined by a succession of grips.
Public class | GH_GradientChangedEventArgs | Arguments for te GradientChanged event.
Public class | GH_Grip | Represents a grip in a gradient. A grip defines both where and how the colour of a gradient changes.

Delegates

 | Delegate | Description
Public delegate | GH_Gradient..::..GradientChangedEventHandler |
Public delegate | GH_Gradient..::..SelectionChangedEventHandler |

Enumerations

 | Enumeration | Description
Public enumeration | GH_GripSide | Enumerates the possible types of colour-in/colour-out behaviours of Gradient Grips.
Public enumeration | GH_GripType | Enumerates the possible grip types.


GH_Gradient Class

[image]

Grasshopper SDK
GH_Gradient Class
Members See Also Send Feedback
Represents a colour gradient defined by a succession of grips.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Gradient : GH_ISerializable
Visual Basic
Public Class GH_Gradient _
    Implements GH_ISerializable

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI.Gradient..::..GH_Gradient

See Also

GH_Gradient Members
Grasshopper.GUI.Gradient Namespace


GH_Gradient Members

[image] [image]

Grasshopper SDK
GH_Gradient Members
GH_Gradient Class Constructors Methods Properties Events See Also Send Feedback

The GH_Gradient type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Gradient()()()() | Initializes a new instance of the GH_Gradient class
Public method | GH_Gradient(GH_Gradient) | Create a duplicate of another gradient.
Public method | GH_Gradient(IEnumerable<(Of <<'(Double>)>>), IEnumerable<(Of <<'(Color>)>>)) | Create a new gradient from grips and colours.

Methods

 | Name | Description
Public method | AddGrip(Double) | Add a new grip to the gradient. The colour of the grip will be picked so that there is no difference to the gradient, though this is not actually possible when the interpolation mode is not linear.
Public method | AddGrip(GH_Grip) | Add a new grip to the gradient. This method does not raise the GradientChanged event, so you need to do that yourself by calling OnGradientChanged().
Public method | AddGrip(Double, Color) | Add a new single-colour grip.
Public method | AddGrip(Double, Color, Color) | Add a new bi-colour grip.
Public method | ColourAt | Evaluate the colour at a specific parameter.
 | DeleteGripRegion | Gets the Delete Grip region rectangle based on a gradient destination rectangle.
Public method | DisplayGradientEditor |
Public method | DisplayGripColourPicker |
 | EarthlyBrown |
 | Forest |
 | GreyScale |
 | Heat |
Public method | MouseDown | Begin grip drag operation.
Public method | MouseDragAbort | Abort grip drag.
Public method | MouseMove | Continue grip dragging operation.
Public method | MouseUp | Terminate grip drag.
Public method | NearestGrip(Double) | Find the nearest grip to a parameter.
Public method | NearestGrip(Double, GH_GripSide) | Find the nearest grip to a parameter.
Public method | NearestGrip(RectangleF, PointF, Double) | Find the nearest grip in screen coordinates.
 | NewGripRegion | Gets the new Grip region rectangle based on a gradient destination rectangle.
Public method | NormalizeGrips | Normalize all grips. This will scale all grip parameters so that the full gradient extend equals 0~1.
Public method | OnGradientChanged | Raise the GradientChanged event.
Public method | OnGradientChangedIntermediate | Raise the GradientChanged event.
Public method | OnSelectionChanged | Raise the SelectionChanged event.
Public method | Read |
Public method | RemoveGrip(Int32) | Remove the grip at the specified index.
Public method | RemoveGrip(GH_Grip) | Remove the specified grip.
Public method | Render_Background |
Public method | Render_Gradient |
Public method | Render_Grips |
 | SoGay |
 | Spectrum |
 | Traffic |
Public method | Write |
 | Zebra |

Properties

 | Name | Description
Public property | Grip | Gets or sets the grip at the given index.
Public property | GripCount | Gets the number of grips in this gradient.
Public property | Linear | Gets or sets whether the colours are interpolated linearly between grips.
Public property | Locked | Gets or sets whether this gradient is locked. A locked gradient cannot be modified by the user.
Public property | SelectedGrip | Gets or sets the selected grip.

Events

 | Name | Description
Public event | GradientChanged |
Public event | SelectionChanged |

See Also

GH_Gradient Class
Grasshopper.GUI.Gradient Namespace


GH_Gradient Constructor

[image] [image]

Grasshopper SDK
GH_Gradient Constructor
GH_Gradient Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Gradient()()()() | Initializes a new instance of the GH_Gradient class
Public method | GH_Gradient(GH_Gradient) | Create a duplicate of another gradient.
Public method | GH_Gradient(IEnumerable<(Of <<'(Double>)>>), IEnumerable<(Of <<'(Color>)>>)) | Create a new gradient from grips and colours.

See Also

GH_Gradient Class
GH_Gradient Members
Grasshopper.GUI.Gradient Namespace


GH_Gradient Constructor

[image]

Grasshopper SDK
GH_Gradient Constructor
GH_Gradient Class See Also Send Feedback
Initializes a new instance of the GH_Gradient class

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Gradient()
Visual Basic
Public Sub New

See Also

GH_Gradient Class
GH_Gradient Overload
Grasshopper.GUI.Gradient Namespace


GH_Gradient Constructor (GH_Gradient)

[image]

Grasshopper SDK
GH_Gradient Constructor (GH_Gradient)
GH_Gradient Class See Also Send Feedback
Create a duplicate of another gradient.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Gradient(
    GH_Gradient other
)
Visual Basic
Public Sub New ( _
    other As GH_Gradient _
)

Parameters

other
Type: Grasshopper.GUI.Gradient..::..GH_Gradient
Gradient to duplicate.

See Also

GH_Gradient Class
GH_Gradient Overload
Grasshopper.GUI.Gradient Namespace


GH_Gradient Constructor (IEnumerable(Double), IEnumerable(Color))

[image]

Grasshopper SDK
GH_Gradient Constructor (IEnumerable<(Of <(<'Double>)>)>, IEnumerable<(Of <(<'Color>)>)>)
GH_Gradient Class See Also Send Feedback
Create a new gradient from grips and colours.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Gradient(
    IEnumerable<double> parameters,
    IEnumerable<Color> colours
)
Visual Basic
Public Sub New ( _
    parameters As IEnumerable(Of Double), _
    colours As IEnumerable(Of Color) _
)

Parameters

parameters
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Double >)>)>
Grip locations.
colours
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Color >)>)>
Colours for each grip.

See Also

GH_Gradient Class
GH_Gradient Overload
Grasshopper.GUI.Gradient Namespace


GH_Gradient Methods

[image] [image]

Grasshopper SDK
GH_Gradient Methods
GH_Gradient Class See Also Send Feedback

The GH_Gradient type exposes the following members.

Methods

 | Name | Description
Public method | AddGrip(Double) | Add a new grip to the gradient. The colour of the grip will be picked so that there is no difference to the gradient, though this is not actually possible when the interpolation mode is not linear.
Public method | AddGrip(GH_Grip) | Add a new grip to the gradient. This method does not raise the GradientChanged event, so you need to do that yourself by calling OnGradientChanged().
Public method | AddGrip(Double, Color) | Add a new single-colour grip.
Public method | AddGrip(Double, Color, Color) | Add a new bi-colour grip.
Public method | ColourAt | Evaluate the colour at a specific parameter.
 | DeleteGripRegion | Gets the Delete Grip region rectangle based on a gradient destination rectangle.
Public method | DisplayGradientEditor |
Public method | DisplayGripColourPicker |
 | EarthlyBrown |
 | Forest |
 | GreyScale |
 | Heat |
Public method | MouseDown | Begin grip drag operation.
Public method | MouseDragAbort | Abort grip drag.
Public method | MouseMove | Continue grip dragging operation.
Public method | MouseUp | Terminate grip drag.
Public method | NearestGrip(Double) | Find the nearest grip to a parameter.
Public method | NearestGrip(Double, GH_GripSide) | Find the nearest grip to a parameter.
Public method | NearestGrip(RectangleF, PointF, Double) | Find the nearest grip in screen coordinates.
 | NewGripRegion | Gets the new Grip region rectangle based on a gradient destination rectangle.
Public method | NormalizeGrips | Normalize all grips. This will scale all grip parameters so that the full gradient extend equals 0~1.
Public method | OnGradientChanged | Raise the GradientChanged event.
Public method | OnGradientChangedIntermediate | Raise the GradientChanged event.
Public method | OnSelectionChanged | Raise the SelectionChanged event.
Public method | Read |
Public method | RemoveGrip(Int32) | Remove the grip at the specified index.
Public method | RemoveGrip(GH_Grip) | Remove the specified grip.
Public method | Render_Background |
Public method | Render_Gradient |
Public method | Render_Grips |
 | SoGay |
 | Spectrum |
 | Traffic |
Public method | Write |
 | Zebra |

See Also

GH_Gradient Class
Grasshopper.GUI.Gradient Namespace


AddGrip Method

[image] [image]

Grasshopper SDK
GH_Gradient..::..AddGrip Method
GH_Gradient Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddGrip(Double) | Add a new grip to the gradient. The colour of the grip will be picked so that there is no difference to the gradient, though this is not actually possible when the interpolation mode is not linear.
Public method | AddGrip(GH_Grip) | Add a new grip to the gradient. This method does not raise the GradientChanged event, so you need to do that yourself by calling OnGradientChanged().
Public method | AddGrip(Double, Color) | Add a new single-colour grip.
Public method | AddGrip(Double, Color, Color) | Add a new bi-colour grip.

See Also

GH_Gradient Class
GH_Gradient Members
Grasshopper.GUI.Gradient Namespace


AddGrip Method (Double)

[image]

Grasshopper SDK
GH_Gradient..::..AddGrip Method (Double)
GH_Gradient Class See Also Send Feedback
Add a new grip to the gradient. The colour of the grip will be picked so that there is no difference to the gradient, though this is not actually possible when the interpolation mode is not linear.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Grip AddGrip(
    double t
)
Visual Basic
Public Function AddGrip ( _
    t As Double _
) As GH_Grip

Parameters

t
Type: System..::..Double
Grip parameter.

See Also

GH_Gradient Class
AddGrip Overload
Grasshopper.GUI.Gradient Namespace


AddGrip Method (GH_Grip)

[image]

Grasshopper SDK
GH_Gradient..::..AddGrip Method (GH_Grip)
GH_Gradient Class See Also Send Feedback
Add a new grip to the gradient. This method does not raise the GradientChanged event, so you need to do that yourself by calling OnGradientChanged().

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddGrip(
    GH_Grip grip
)
Visual Basic
Public Sub AddGrip ( _
    grip As GH_Grip _
)

Parameters

grip
Type: Grasshopper.GUI.Gradient..::..GH_Grip
Grip to add.

See Also

GH_Gradient Class
AddGrip Overload
Grasshopper.GUI.Gradient Namespace


AddGrip Method (Double, Color)

[image]

Grasshopper SDK
GH_Gradient..::..AddGrip Method (Double, Color)
GH_Gradient Class See Also Send Feedback
Add a new single-colour grip.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Grip AddGrip(
    double t,
    Color c
)
Visual Basic
Public Function AddGrip ( _
    t As Double, _
    c As Color _
) As GH_Grip

Parameters

t
Type: System..::..Double
Parameter for grip.
c
Type: System.Drawing..::..Color
Colour of grip.

See Also

GH_Gradient Class
AddGrip Overload
Grasshopper.GUI.Gradient Namespace


AddGrip Method (Double, Color, Color)

[image]

Grasshopper SDK
GH_Gradient..::..AddGrip Method (Double, Color, Color)
GH_Gradient Class See Also Send Feedback
Add a new bi-colour grip.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Grip AddGrip(
    double t,
    Color c0,
    Color c1
)
Visual Basic
Public Function AddGrip ( _
    t As Double, _
    c0 As Color, _
    c1 As Color _
) As GH_Grip

Parameters

t
Type: System..::..Double
Parameter for grip.
c0
Type: System.Drawing..::..Color
Left colour of grip.
c1
Type: System.Drawing..::..Color
Right colour of grip.

See Also

GH_Gradient Class
AddGrip Overload
Grasshopper.GUI.Gradient Namespace


ColourAt Method

[image]

Grasshopper SDK
GH_Gradient..::..ColourAt Method
GH_Gradient Class See Also Send Feedback
Evaluate the colour at a specific parameter.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color ColourAt(
    double t
)
Visual Basic
Public Function ColourAt ( _
    t As Double _
) As Color

Parameters

t
Type: System..::..Double
Parameter to evaluate.

Return Value

The colour at the given parameter.

See Also

GH_Gradient Class
Grasshopper.GUI.Gradient Namespace


DeleteGripRegion Method

[image]

Grasshopper SDK
GH_Gradient..::..DeleteGripRegion Method
GH_Gradient Class See Also Send Feedback
Gets the Delete Grip region rectangle based on a gradient destination rectangle.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static RectangleF DeleteGripRegion(
    RectangleF destination
)
Visual Basic
Public Shared Function DeleteGripRegion ( _
    destination As RectangleF _
) As RectangleF

Parameters

destination
Type: System.Drawing..::..RectangleF
Gradient destination rectangle.

See Also

GH_Gradient Class
Grasshopper.GUI.Gradient Namespace


DisplayGradientEditor Method

[image]

Grasshopper SDK
GH_Gradient..::..DisplayGradientEditor Method
GH_Gradient Class See Also Send Feedback

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DisplayGradientEditor()
Visual Basic
Public Sub DisplayGradientEditor

See Also

GH_Gradient Class
Grasshopper.GUI.Gradient Namespace


DisplayGripColourPicker Method

[image]

Grasshopper SDK
GH_Gradient..::..DisplayGripColourPicker Method
GH_Gradient Class See Also Send Feedback

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DisplayGripColourPicker(
    GH_Grip grip
)
Visual Basic
Public Sub DisplayGripColourPicker ( _
    grip As GH_Grip _
)

Parameters

grip
Type: Grasshopper.GUI.Gradient..::..GH_Grip

See Also

GH_Gradient Class
Grasshopper.GUI.Gradient Namespace


EarthlyBrown Method

[image]

Grasshopper SDK
GH_Gradient..::..EarthlyBrown Method
GH_Gradient Class See Also Send Feedback

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Gradient EarthlyBrown()
Visual Basic
Public Shared Function EarthlyBrown As GH_Gradient

See Also

GH_Gradient Class
Grasshopper.GUI.Gradient Namespace


Forest Method

[image]

Grasshopper SDK
GH_Gradient..::..Forest Method
GH_Gradient Class See Also Send Feedback

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Gradient Forest()
Visual Basic
Public Shared Function Forest As GH_Gradient

See Also

GH_Gradient Class
Grasshopper.GUI.Gradient Namespace


GreyScale Method

[image]

Grasshopper SDK
GH_Gradient..::..GreyScale Method
GH_Gradient Class See Also Send Feedback

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Gradient GreyScale()
Visual Basic
Public Shared Function GreyScale As GH_Gradient

See Also

GH_Gradient Class
Grasshopper.GUI.Gradient Namespace


Heat Method

[image]

Grasshopper SDK
GH_Gradient..::..Heat Method
GH_Gradient Class See Also Send Feedback

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Gradient Heat()
Visual Basic
Public Shared Function Heat As GH_Gradient

See Also

GH_Gradient Class
Grasshopper.GUI.Gradient Namespace


MouseDown Method

[image]

Grasshopper SDK
GH_Gradient..::..MouseDown Method
GH_Gradient Class See Also Send Feedback
Begin grip drag operation.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool MouseDown(
    RectangleF dest,
    PointF pt
)
Visual Basic
Public Function MouseDown ( _
    dest As RectangleF, _
    pt As PointF _
) As Boolean

Parameters

dest
Type: System.Drawing..::..RectangleF
Destination rectangle of the gradient.
pt
Type: System.Drawing..::..PointF
Mouse position in destination coordinates.

Return Value

True if a grip drag was started, false otherwise.

See Also

GH_Gradient Class
Grasshopper.GUI.Gradient Namespace


MouseDragAbort Method

[image]

Grasshopper SDK
GH_Gradient..::..MouseDragAbort Method
GH_Gradient Class See Also Send Feedback
Abort grip drag.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool MouseDragAbort()
Visual Basic
Public Function MouseDragAbort As Boolean

See Also

GH_Gradient Class
Grasshopper.GUI.Gradient Namespace


MouseMove Method

[image]

Grasshopper SDK
GH_Gradient..::..MouseMove Method
GH_Gradient Class See Also Send Feedback
Continue grip dragging operation.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool MouseMove(
    RectangleF dest,
    PointF pt
)
Visual Basic
Public Function MouseMove ( _
    dest As RectangleF, _
    pt As PointF _
) As Boolean

Parameters

dest
Type: System.Drawing..::..RectangleF
Destination rectangle of gradient.
pt
Type: System.Drawing..::..PointF
Mouse position in destination coordinates.

Return Value

True if a grip position was changed, false otherwise. Redraws are only required on TRUE.

See Also

GH_Gradient Class
Grasshopper.GUI.Gradient Namespace


MouseUp Method

[image]

Grasshopper SDK
GH_Gradient..::..MouseUp Method
GH_Gradient Class See Also Send Feedback
Terminate grip drag.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool MouseUp(
    RectangleF dest,
    PointF pt
)
Visual Basic
Public Function MouseUp ( _
    dest As RectangleF, _
    pt As PointF _
) As Boolean

Parameters

dest
Type: System.Drawing..::..RectangleF
Destination rectangle of gradient
pt
Type: System.Drawing..::..PointF
Mouse location in destination coordinates

See Also

GH_Gradient Class
Grasshopper.GUI.Gradient Namespace


NearestGrip Method

[image] [image]

Grasshopper SDK
GH_Gradient..::..NearestGrip Method
GH_Gradient Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NearestGrip(Double) | Find the nearest grip to a parameter.
Public method | NearestGrip(Double, GH_GripSide) | Find the nearest grip to a parameter.
Public method | NearestGrip(RectangleF, PointF, Double) | Find the nearest grip in screen coordinates.

See Also

GH_Gradient Class
GH_Gradient Members
Grasshopper.GUI.Gradient Namespace


NearestGrip Method (Double)

[image]

Grasshopper SDK
GH_Gradient..::..NearestGrip Method (Double)
GH_Gradient Class See Also Send Feedback
Find the nearest grip to a parameter.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int NearestGrip(
    double t
)
Visual Basic
Public Function NearestGrip ( _
    t As Double _
) As Integer

Parameters

t
Type: System..::..Double
Parameter to search from.

Return Value

The grip nearest to the parameter.

See Also

GH_Gradient Class
NearestGrip Overload
Grasshopper.GUI.Gradient Namespace


NearestGrip Method (Double, GH_GripSide)

[image]

Grasshopper SDK
GH_Gradient..::..NearestGrip Method (Double, GH_GripSide)
GH_Gradient Class See Also Send Feedback
Find the nearest grip to a parameter.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int NearestGrip(
    double t,
    GH_GripSide side
)
Visual Basic
Public Function NearestGrip ( _
    t As Double, _
    side As GH_GripSide _
) As Integer

Parameters

t
Type: System..::..Double
Parameter to search from.
side
Type: Grasshopper.GUI.Gradient..::..GH_GripSide
Side to search.

Return Value

The grip nearest to the parameter.

See Also

GH_Gradient Class
NearestGrip Overload
Grasshopper.GUI.Gradient Namespace


NearestGrip Method (RectangleF, PointF, Double)

[image]

Grasshopper SDK
GH_Gradient..::..NearestGrip Method (RectangleF, PointF, Double)
GH_Gradient Class See Also Send Feedback
Find the nearest grip in screen coordinates.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int NearestGrip(
    RectangleF dest,
    PointF pt,
    double maxRadius
)
Visual Basic
Public Function NearestGrip ( _
    dest As RectangleF, _
    pt As PointF, _
    maxRadius As Double _
) As Integer

Parameters

dest
Type: System.Drawing..::..RectangleF
Retangle that contains the entire gradient.
pt
Type: System.Drawing..::..PointF
Point to search from.
maxRadius
Type: System..::..Double
Maximum distance between point and grip.

Return Value

The grip closest to the point.

See Also

GH_Gradient Class
NearestGrip Overload
Grasshopper.GUI.Gradient Namespace


NewGripRegion Method

[image]

Grasshopper SDK
GH_Gradient..::..NewGripRegion Method
GH_Gradient Class See Also Send Feedback
Gets the new Grip region rectangle based on a gradient destination rectangle.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static RectangleF NewGripRegion(
    RectangleF destination
)
Visual Basic
Public Shared Function NewGripRegion ( _
    destination As RectangleF _
) As RectangleF

Parameters

destination
Type: System.Drawing..::..RectangleF
Gradient destination rectangle.

See Also

GH_Gradient Class
Grasshopper.GUI.Gradient Namespace


NormalizeGrips Method

[image]

Grasshopper SDK
GH_Gradient..::..NormalizeGrips Method
GH_Gradient Class See Also Send Feedback
Normalize all grips. This will scale all grip parameters so that the full gradient extend equals 0~1.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void NormalizeGrips()
Visual Basic
Public Sub NormalizeGrips

See Also

GH_Gradient Class
Grasshopper.GUI.Gradient Namespace


OnGradientChanged Method

[image]

Grasshopper SDK
GH_Gradient..::..OnGradientChanged Method
GH_Gradient Class See Also Send Feedback
Raise the GradientChanged event.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void OnGradientChanged()
Visual Basic
Public Sub OnGradientChanged

See Also

GH_Gradient Class
Grasshopper.GUI.Gradient Namespace


OnGradientChangedIntermediate Method

[image]

Grasshopper SDK
GH_Gradient..::..OnGradientChangedIntermediate Method
GH_Gradient Class See Also Send Feedback
Raise the GradientChanged event.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void OnGradientChangedIntermediate()
Visual Basic
Public Sub OnGradientChangedIntermediate

See Also

GH_Gradient Class
Grasshopper.GUI.Gradient Namespace


OnSelectionChanged Method

[image]

Grasshopper SDK
GH_Gradient..::..OnSelectionChanged Method
GH_Gradient Class See Also Send Feedback
Raise the SelectionChanged event.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void OnSelectionChanged()
Visual Basic
Public Sub OnSelectionChanged

See Also

GH_Gradient Class
Grasshopper.GUI.Gradient Namespace


Read Method

[image]

Grasshopper SDK
GH_Gradient..::..Read Method
GH_Gradient Class See Also Send Feedback

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Read(
    GH_IReader reader
)
Visual Basic
Public Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

Implements

GH_ISerializable..::..Read(GH_IReader)

See Also

GH_Gradient Class
Grasshopper.GUI.Gradient Namespace


RemoveGrip Method

[image] [image]

Grasshopper SDK
GH_Gradient..::..RemoveGrip Method
GH_Gradient Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveGrip(Int32) | Remove the grip at the specified index.
Public method | RemoveGrip(GH_Grip) | Remove the specified grip.

See Also

GH_Gradient Class
GH_Gradient Members
Grasshopper.GUI.Gradient Namespace


RemoveGrip Method (Int32)

[image]

Grasshopper SDK
GH_Gradient..::..RemoveGrip Method (Int32)
GH_Gradient Class See Also Send Feedback
Remove the grip at the specified index.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RemoveGrip(
    int index
)
Visual Basic
Public Sub RemoveGrip ( _
    index As Integer _
)

Parameters

index
Type: System..::..Int32
Index of grip to remove.

See Also

GH_Gradient Class
RemoveGrip Overload
Grasshopper.GUI.Gradient Namespace


RemoveGrip Method (GH_Grip)

[image]

Grasshopper SDK
GH_Gradient..::..RemoveGrip Method (GH_Grip)
GH_Gradient Class See Also Send Feedback
Remove the specified grip.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RemoveGrip(
    GH_Grip grip
)
Visual Basic
Public Sub RemoveGrip ( _
    grip As GH_Grip _
)

Parameters

grip
Type: Grasshopper.GUI.Gradient..::..GH_Grip
Grip to remove.

See Also

GH_Gradient Class
RemoveGrip Overload
Grasshopper.GUI.Gradient Namespace


Render_Background Method

[image]

Grasshopper SDK
GH_Gradient..::..Render_Background Method
GH_Gradient Class See Also Send Feedback

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Render_Background(
    Graphics g,
    RectangleF dest
)
Visual Basic
Public Sub Render_Background ( _
    g As Graphics, _
    dest As RectangleF _
)

Parameters

g
Type: System.Drawing..::..Graphics
dest
Type: System.Drawing..::..RectangleF

See Also

GH_Gradient Class
Grasshopper.GUI.Gradient Namespace


Render_Gradient Method

[image]

Grasshopper SDK
GH_Gradient..::..Render_Gradient Method
GH_Gradient Class See Also Send Feedback

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Render_Gradient(
    Graphics g,
    RectangleF dest
)
Visual Basic
Public Sub Render_Gradient ( _
    g As Graphics, _
    dest As RectangleF _
)

Parameters

g
Type: System.Drawing..::..Graphics
dest
Type: System.Drawing..::..RectangleF

See Also

GH_Gradient Class
Grasshopper.GUI.Gradient Namespace


Render_Grips Method

[image]

Grasshopper SDK
GH_Gradient..::..Render_Grips Method
GH_Gradient Class See Also Send Feedback

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Render_Grips(
    Graphics g,
    RectangleF dest
)
Visual Basic
Public Sub Render_Grips ( _
    g As Graphics, _
    dest As RectangleF _
)

Parameters

g
Type: System.Drawing..::..Graphics
dest
Type: System.Drawing..::..RectangleF

See Also

GH_Gradient Class
Grasshopper.GUI.Gradient Namespace


SoGay Method

[image]

Grasshopper SDK
GH_Gradient..::..SoGay Method
GH_Gradient Class See Also Send Feedback

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Gradient SoGay()
Visual Basic
Public Shared Function SoGay As GH_Gradient

See Also

GH_Gradient Class
Grasshopper.GUI.Gradient Namespace


Spectrum Method

[image]

Grasshopper SDK
GH_Gradient..::..Spectrum Method
GH_Gradient Class See Also Send Feedback

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Gradient Spectrum()
Visual Basic
Public Shared Function Spectrum As GH_Gradient

See Also

GH_Gradient Class
Grasshopper.GUI.Gradient Namespace


Traffic Method

[image]

Grasshopper SDK
GH_Gradient..::..Traffic Method
GH_Gradient Class See Also Send Feedback

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Gradient Traffic()
Visual Basic
Public Shared Function Traffic As GH_Gradient

See Also

GH_Gradient Class
Grasshopper.GUI.Gradient Namespace


Write Method

[image]

Grasshopper SDK
GH_Gradient..::..Write Method
GH_Gradient Class See Also Send Feedback

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Write(
    GH_IWriter writer
)
Visual Basic
Public Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

Implements

GH_ISerializable..::..Write(GH_IWriter)

See Also

GH_Gradient Class
Grasshopper.GUI.Gradient Namespace


Zebra Method

[image]

Grasshopper SDK
GH_Gradient..::..Zebra Method
GH_Gradient Class See Also Send Feedback

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Gradient Zebra()
Visual Basic
Public Shared Function Zebra As GH_Gradient

See Also

GH_Gradient Class
Grasshopper.GUI.Gradient Namespace


GH_Gradient Properties

[image] [image]

Grasshopper SDK
GH_Gradient Properties
GH_Gradient Class See Also Send Feedback

The GH_Gradient type exposes the following members.

Properties

 | Name | Description
Public property | Grip | Gets or sets the grip at the given index.
Public property | GripCount | Gets the number of grips in this gradient.
Public property | Linear | Gets or sets whether the colours are interpolated linearly between grips.
Public property | Locked | Gets or sets whether this gradient is locked. A locked gradient cannot be modified by the user.
Public property | SelectedGrip | Gets or sets the selected grip.

See Also

GH_Gradient Class
Grasshopper.GUI.Gradient Namespace


Grip Property

[image]

Grasshopper SDK
GH_Gradient..::..Grip Property
GH_Gradient Class See Also Send Feedback
Gets or sets the grip at the given index.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Grip this[
    int index
] { get; set; }
Visual Basic
Public Default Property Grip ( _
    index As Integer _
) As GH_Grip
    Get
    Set

Parameters

index
Type: System..::..Int32
Index of grip to retrieve.

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Gradient.GH_Gradient.Grip(System.Int32)"]

Return Value

The grip at the given index.

See Also

GH_Gradient Class
Grasshopper.GUI.Gradient Namespace


GripCount Property

[image]

Grasshopper SDK
GH_Gradient..::..GripCount Property
GH_Gradient Class See Also Send Feedback
Gets the number of grips in this gradient.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int GripCount { get; }
Visual Basic
Public ReadOnly Property GripCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Gradient.GH_Gradient.GripCount"]

See Also

GH_Gradient Class
Grasshopper.GUI.Gradient Namespace


Linear Property

[image]

Grasshopper SDK
GH_Gradient..::..Linear Property
GH_Gradient Class See Also Send Feedback
Gets or sets whether the colours are interpolated linearly between grips.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Linear { get; set; }
Visual Basic
Public Property Linear As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Gradient.GH_Gradient.Linear"]

See Also

GH_Gradient Class
Grasshopper.GUI.Gradient Namespace


Locked Property

[image]

Grasshopper SDK
GH_Gradient..::..Locked Property
GH_Gradient Class See Also Send Feedback
Gets or sets whether this gradient is locked. A locked gradient cannot be modified by the user.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Locked { get; set; }
Visual Basic
Public Property Locked As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Gradient.GH_Gradient.Locked"]

See Also

GH_Gradient Class
Grasshopper.GUI.Gradient Namespace


SelectedGrip Property

[image]

Grasshopper SDK
GH_Gradient..::..SelectedGrip Property
GH_Gradient Class See Also Send Feedback
Gets or sets the selected grip.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Grip SelectedGrip { get; set; }
Visual Basic
Public Property SelectedGrip As GH_Grip
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Gradient.GH_Gradient.SelectedGrip"]

See Also

GH_Gradient Class
Grasshopper.GUI.Gradient Namespace


GH_Gradient Events

[image] [image]

Grasshopper SDK
GH_Gradient Events
GH_Gradient Class See Also Send Feedback

The GH_Gradient type exposes the following members.

Events

 | Name | Description
Public event | GradientChanged |
Public event | SelectionChanged |

See Also

GH_Gradient Class
Grasshopper.GUI.Gradient Namespace


GradientChanged Event

[image]

Grasshopper SDK
GH_Gradient..::..GradientChanged Event
GH_Gradient Class See Also Send Feedback

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_Gradient..::..GradientChangedEventHandler GradientChanged
Visual Basic
Public Event GradientChanged As GH_Gradient..::..GradientChangedEventHandler

See Also

GH_Gradient Class
Grasshopper.GUI.Gradient Namespace


SelectionChanged Event

[image]

Grasshopper SDK
GH_Gradient..::..SelectionChanged Event
GH_Gradient Class See Also Send Feedback

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_Gradient..::..SelectionChangedEventHandler SelectionChanged
Visual Basic
Public Event SelectionChanged As GH_Gradient..::..SelectionChangedEventHandler

See Also

GH_Gradient Class
Grasshopper.GUI.Gradient Namespace


GH_Gradient.GradientChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_Gradient..::..GradientChangedEventHandler Delegate
GH_Gradient Class See Also Send Feedback

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void GradientChangedEventHandler(
    Object sender,
    GH_GradientChangedEventArgs e
)
Visual Basic
Public Delegate Sub GradientChangedEventHandler ( _
    sender As Object, _
    e As GH_GradientChangedEventArgs _
)

Parameters

sender
Type: System..::..Object
e
Type: Grasshopper.GUI.Gradient..::..GH_GradientChangedEventArgs

See Also

Grasshopper.GUI.Gradient Namespace


GH_Gradient.SelectionChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_Gradient..::..SelectionChangedEventHandler Delegate
GH_Gradient Class See Also Send Feedback

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void SelectionChangedEventHandler(
    Object sender,
    GH_GradientChangedEventArgs e
)
Visual Basic
Public Delegate Sub SelectionChangedEventHandler ( _
    sender As Object, _
    e As GH_GradientChangedEventArgs _
)

Parameters

sender
Type: System..::..Object
e
Type: Grasshopper.GUI.Gradient..::..GH_GradientChangedEventArgs

See Also

Grasshopper.GUI.Gradient Namespace


GH_GradientChangedEventArgs Class

[image]

Grasshopper SDK
GH_GradientChangedEventArgs Class
Members See Also Send Feedback
Arguments for te GradientChanged event.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_GradientChangedEventArgs : EventArgs
Visual Basic
Public Class GH_GradientChangedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Grasshopper.GUI.Gradient..::..GH_GradientChangedEventArgs

See Also

GH_GradientChangedEventArgs Members
Grasshopper.GUI.Gradient Namespace


GH_GradientChangedEventArgs Members

[image] [image]

Grasshopper SDK
GH_GradientChangedEventArgs Members
GH_GradientChangedEventArgs Class Constructors Properties See Also Send Feedback

The GH_GradientChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GH_GradientChangedEventArgs | Initializes a new instance of the GH_GradientChangedEventArgs class

Properties

 | Name | Description
Public property | Gradient | Gets the gradient that raised this event.
Public property | Intermediate | Gets whether this event is intermediate. I.e. whether it will be followed by another, similar event.

See Also

GH_GradientChangedEventArgs Class
Grasshopper.GUI.Gradient Namespace


GH_GradientChangedEventArgs Constructor

[image]

Grasshopper SDK
GH_GradientChangedEventArgs Constructor
GH_GradientChangedEventArgs Class See Also Send Feedback
Initializes a new instance of the GH_GradientChangedEventArgs class

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_GradientChangedEventArgs(
    GH_Gradient gradient,
    bool intermediate
)
Visual Basic
Public Sub New ( _
    gradient As GH_Gradient, _
    intermediate As Boolean _
)

Parameters

gradient
Type: Grasshopper.GUI.Gradient..::..GH_Gradient
intermediate
Type: System..::..Boolean

See Also

GH_GradientChangedEventArgs Class
Grasshopper.GUI.Gradient Namespace


GH_GradientChangedEventArgs Properties

[image] [image]

Grasshopper SDK
GH_GradientChangedEventArgs Properties
GH_GradientChangedEventArgs Class See Also Send Feedback

The GH_GradientChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Gradient | Gets the gradient that raised this event.
Public property | Intermediate | Gets whether this event is intermediate. I.e. whether it will be followed by another, similar event.

See Also

GH_GradientChangedEventArgs Class
Grasshopper.GUI.Gradient Namespace


Gradient Property

[image]

Grasshopper SDK
GH_GradientChangedEventArgs..::..Gradient Property
GH_GradientChangedEventArgs Class See Also Send Feedback
Gets the gradient that raised this event.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Gradient Gradient { get; }
Visual Basic
Public ReadOnly Property Gradient As GH_Gradient
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Gradient.GH_GradientChangedEventArgs.Gradient"]

See Also

GH_GradientChangedEventArgs Class
Grasshopper.GUI.Gradient Namespace


Intermediate Property

[image]

Grasshopper SDK
GH_GradientChangedEventArgs..::..Intermediate Property
GH_GradientChangedEventArgs Class See Also Send Feedback
Gets whether this event is intermediate. I.e. whether it will be followed by another, similar event.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Intermediate { get; }
Visual Basic
Public ReadOnly Property Intermediate As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Gradient.GH_GradientChangedEventArgs.Intermediate"]

See Also

GH_GradientChangedEventArgs Class
Grasshopper.GUI.Gradient Namespace


GH_Grip Class

[image]

Grasshopper SDK
GH_Grip Class
Members See Also Send Feedback
Represents a grip in a gradient. A grip defines both where and how the colour of a gradient changes.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Grip : IComparable<GH_Grip>,
    GH_ISerializable
Visual Basic
Public Class GH_Grip _
    Implements IComparable(Of GH_Grip), GH_ISerializable

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI.Gradient..::..GH_Grip

See Also

GH_Grip Members
Grasshopper.GUI.Gradient Namespace


GH_Grip Members

[image] [image]

Grasshopper SDK
GH_Grip Members
GH_Grip Class Constructors Methods Properties See Also Send Feedback

The GH_Grip type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Grip()()()() | Initializes a new instance of the GH_Grip class
Public method | GH_Grip(GH_Grip) | Initializes a new instance of the GH_Grip class
Public method | GH_Grip(Double, Color) | Initializes a new instance of the GH_Grip class
Public method | GH_Grip(Double, Color, Color) | Initializes a new instance of the GH_Grip class

Methods

 | Name | Description
 | Blend |
Public method | CompareTo |
Public method | MutateId | Create a new grip ID.
Public method | Read |
Public method | Write |

Properties

 | Name | Description
Public property | ColourLeft | Gets the colour to the left of this grip.
Public property | ColourRight | Gets the colour to the right of this grip.
Public property | GripId | Gets the Grip ID.
Public property | IsValid | Gets whether this grip is valid. A valid grip must have a non-empty Id and a non-NaN parameter.
Public property | Parameter | Gets or sets the numeric parameter of the grip.
Public property | Selected | Gets or sets whether this grip is selected. Selection state is not (de)serialized.
Public property | Type | Gets whether the colour across this grip is smooth.

See Also

GH_Grip Class
Grasshopper.GUI.Gradient Namespace


GH_Grip Constructor

[image] [image]

Grasshopper SDK
GH_Grip Constructor
GH_Grip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Grip()()()() | Initializes a new instance of the GH_Grip class
Public method | GH_Grip(GH_Grip) | Initializes a new instance of the GH_Grip class
Public method | GH_Grip(Double, Color) | Initializes a new instance of the GH_Grip class
Public method | GH_Grip(Double, Color, Color) | Initializes a new instance of the GH_Grip class

See Also

GH_Grip Class
GH_Grip Members
Grasshopper.GUI.Gradient Namespace


GH_Grip Constructor

[image]

Grasshopper SDK
GH_Grip Constructor
GH_Grip Class See Also Send Feedback
Initializes a new instance of the GH_Grip class

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Grip()
Visual Basic
Public Sub New

See Also

GH_Grip Class
GH_Grip Overload
Grasshopper.GUI.Gradient Namespace


GH_Grip Constructor (GH_Grip)

[image]

Grasshopper SDK
GH_Grip Constructor (GH_Grip)
GH_Grip Class See Also Send Feedback
Initializes a new instance of the GH_Grip class

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Grip(
    GH_Grip other
)
Visual Basic
Public Sub New ( _
    other As GH_Grip _
)

Parameters

other
Type: Grasshopper.GUI.Gradient..::..GH_Grip

See Also

GH_Grip Class
GH_Grip Overload
Grasshopper.GUI.Gradient Namespace


GH_Grip Constructor (Double, Color)

[image]

Grasshopper SDK
GH_Grip Constructor (Double, Color)
GH_Grip Class See Also Send Feedback
Initializes a new instance of the GH_Grip class

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Grip(
    double parameter,
    Color colour
)
Visual Basic
Public Sub New ( _
    parameter As Double, _
    colour As Color _
)

Parameters

parameter
Type: System..::..Double
colour
Type: System.Drawing..::..Color

See Also

GH_Grip Class
GH_Grip Overload
Grasshopper.GUI.Gradient Namespace


GH_Grip Constructor (Double, Color, Color)

[image]

Grasshopper SDK
GH_Grip Constructor (Double, Color, Color)
GH_Grip Class See Also Send Feedback
Initializes a new instance of the GH_Grip class

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Grip(
    double parameter,
    Color colourLeft,
    Color colourRight
)
Visual Basic
Public Sub New ( _
    parameter As Double, _
    colourLeft As Color, _
    colourRight As Color _
)

Parameters

parameter
Type: System..::..Double
colourLeft
Type: System.Drawing..::..Color
colourRight
Type: System.Drawing..::..Color

See Also

GH_Grip Class
GH_Grip Overload
Grasshopper.GUI.Gradient Namespace


GH_Grip Methods

[image] [image]

Grasshopper SDK
GH_Grip Methods
GH_Grip Class See Also Send Feedback

The GH_Grip type exposes the following members.

Methods

 | Name | Description
 | Blend |
Public method | CompareTo |
Public method | MutateId | Create a new grip ID.
Public method | Read |
Public method | Write |

See Also

GH_Grip Class
Grasshopper.GUI.Gradient Namespace


Blend Method

[image]

Grasshopper SDK
GH_Grip..::..Blend Method
GH_Grip Class See Also Send Feedback

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Color Blend(
    Color A,
    Color B,
    double t
)
Visual Basic
Public Shared Function Blend ( _
    A As Color, _
    B As Color, _
    t As Double _
) As Color

Parameters

A
Type: System.Drawing..::..Color
B
Type: System.Drawing..::..Color
t
Type: System..::..Double

See Also

GH_Grip Class
Grasshopper.GUI.Gradient Namespace


CompareTo Method

[image]

Grasshopper SDK
GH_Grip..::..CompareTo Method
GH_Grip Class See Also Send Feedback

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int CompareTo(
    GH_Grip other
)
Visual Basic
Public Function CompareTo ( _
    other As GH_Grip _
) As Integer

Parameters

other
Type: Grasshopper.GUI.Gradient..::..GH_Grip

Implements

IComparable<(Of <(<'T>)>)>..::..CompareTo(T)

See Also

GH_Grip Class
Grasshopper.GUI.Gradient Namespace


MutateId Method

[image]

Grasshopper SDK
GH_Grip..::..MutateId Method
GH_Grip Class See Also Send Feedback
Create a new grip ID.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void MutateId()
Visual Basic
Public Sub MutateId

See Also

GH_Grip Class
Grasshopper.GUI.Gradient Namespace


Read Method

[image]

Grasshopper SDK
GH_Grip..::..Read Method
GH_Grip Class See Also Send Feedback

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Read(
    GH_IReader reader
)
Visual Basic
Public Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

Implements

GH_ISerializable..::..Read(GH_IReader)

See Also

GH_Grip Class
Grasshopper.GUI.Gradient Namespace


Write Method

[image]

Grasshopper SDK
GH_Grip..::..Write Method
GH_Grip Class See Also Send Feedback

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Write(
    GH_IWriter writer
)
Visual Basic
Public Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

Implements

GH_ISerializable..::..Write(GH_IWriter)

See Also

GH_Grip Class
Grasshopper.GUI.Gradient Namespace


GH_Grip Properties

[image] [image]

Grasshopper SDK
GH_Grip Properties
GH_Grip Class See Also Send Feedback

The GH_Grip type exposes the following members.

Properties

 | Name | Description
Public property | ColourLeft | Gets the colour to the left of this grip.
Public property | ColourRight | Gets the colour to the right of this grip.
Public property | GripId | Gets the Grip ID.
Public property | IsValid | Gets whether this grip is valid. A valid grip must have a non-empty Id and a non-NaN parameter.
Public property | Parameter | Gets or sets the numeric parameter of the grip.
Public property | Selected | Gets or sets whether this grip is selected. Selection state is not (de)serialized.
Public property | Type | Gets whether the colour across this grip is smooth.

See Also

GH_Grip Class
Grasshopper.GUI.Gradient Namespace


ColourLeft Property

[image]

Grasshopper SDK
GH_Grip..::..ColourLeft Property
GH_Grip Class See Also Send Feedback
Gets the colour to the left of this grip.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color ColourLeft { get; set; }
Visual Basic
Public Property ColourLeft As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Gradient.GH_Grip.ColourLeft"]

See Also

GH_Grip Class
Grasshopper.GUI.Gradient Namespace


ColourRight Property

[image]

Grasshopper SDK
GH_Grip..::..ColourRight Property
GH_Grip Class See Also Send Feedback
Gets the colour to the right of this grip.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color ColourRight { get; set; }
Visual Basic
Public Property ColourRight As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Gradient.GH_Grip.ColourRight"]

See Also

GH_Grip Class
Grasshopper.GUI.Gradient Namespace


GripId Property

[image]

Grasshopper SDK
GH_Grip..::..GripId Property
GH_Grip Class See Also Send Feedback
Gets the Grip ID.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid GripId { get; }
Visual Basic
Public ReadOnly Property GripId As Guid
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Gradient.GH_Grip.GripId"]

See Also

GH_Grip Class
Grasshopper.GUI.Gradient Namespace


IsValid Property

[image]

Grasshopper SDK
GH_Grip..::..IsValid Property
GH_Grip Class See Also Send Feedback
Gets whether this grip is valid. A valid grip must have a non-empty Id and a non-NaN parameter.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsValid { get; }
Visual Basic
Public ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Gradient.GH_Grip.IsValid"]

See Also

GH_Grip Class
Grasshopper.GUI.Gradient Namespace


Parameter Property

[image]

Grasshopper SDK
GH_Grip..::..Parameter Property
GH_Grip Class See Also Send Feedback
Gets or sets the numeric parameter of the grip.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double Parameter { get; set; }
Visual Basic
Public Property Parameter As Double
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Gradient.GH_Grip.Parameter"]

See Also

GH_Grip Class
Grasshopper.GUI.Gradient Namespace


Selected Property

[image]

Grasshopper SDK
GH_Grip..::..Selected Property
GH_Grip Class See Also Send Feedback
Gets or sets whether this grip is selected. Selection state is not (de)serialized.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Selected { get; set; }
Visual Basic
Public Property Selected As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Gradient.GH_Grip.Selected"]

See Also

GH_Grip Class
Grasshopper.GUI.Gradient Namespace


Type Property

[image]

Grasshopper SDK
GH_Grip..::..Type Property
GH_Grip Class See Also Send Feedback
Gets whether the colour across this grip is smooth.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_GripType Type { get; }
Visual Basic
Public ReadOnly Property Type As GH_GripType
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Gradient.GH_Grip.Type"]

See Also

GH_Grip Class
Grasshopper.GUI.Gradient Namespace


GH_GripSide Enumeration

[image]

Grasshopper SDK
GH_GripSide Enumeration
See Also Send Feedback
Enumerates the possible types of colour-in/colour-out behaviours of Gradient Grips.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_GripSide
Visual Basic
Public Enumeration GH_GripSide

Members

Member name | Value | Description
Both | 0 |
Left | 1 |
Right | 2 |

See Also

Grasshopper.GUI.Gradient Namespace


GH_GripType Enumeration

[image]

Grasshopper SDK
GH_GripType Enumeration
See Also Send Feedback
Enumerates the possible grip types.

Namespace: Grasshopper.GUI.Gradient
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_GripType
Visual Basic
Public Enumeration GH_GripType

Members

Member name | Value | Description
Continuous | 0 | Grip has the same colour coming in and going out.
Discontinuous | 1 | Grip has a different colour coming in and going out.

See Also

Grasshopper.GUI.Gradient Namespace


Grasshopper.GUI.Theme Namespace

[image]

Grasshopper SDK
Grasshopper.GUI.Theme Namespace
Send Feedback

Classes

 | Class | Description
Public class | GH_BackgroundSettings |
Public class | GH_ObjectSettings |
Public class | GH_PageSettings |
Public class | GH_PaletteSettings |
Public class | GH_Theme |
Public class | GH_WireSettings |

Enumerations

 | Enumeration | Description
Public enumeration | GH_BackgroundStyle | Enumerates the pre-defined canvas background themes.


GH_BackgroundSettings Class

[image]

Grasshopper SDK
GH_BackgroundSettings Class
Members See Also Send Feedback

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_BackgroundSettings
Visual Basic
Public Class GH_BackgroundSettings

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI.Theme..::..GH_BackgroundSettings

See Also

GH_BackgroundSettings Members
Grasshopper.GUI.Theme Namespace


GH_BackgroundSettings Members

[image] [image]

Grasshopper SDK
GH_BackgroundSettings Members
GH_BackgroundSettings Class Properties See Also Send Feedback

The GH_BackgroundSettings type exposes the following members.

Properties

 | Name | Description
Public property | Colour1 | First background colour. Depending on the background style, this colour is used in different ways.
Public property | Colour2 | Second background colour. Depending on the background style, this colour is used in different ways.
Public property | Hatch | Background hatch brush style. This property is only used if BackgroundStyle is set to GH_ThemeBackgroundStyle.Hatch.
Public property | Style | Canvas monochromatic flag. If True, the canvas background is a solid colour.

See Also

GH_BackgroundSettings Class
Grasshopper.GUI.Theme Namespace


GH_BackgroundSettings Properties

[image] [image]

Grasshopper SDK
GH_BackgroundSettings Properties
GH_BackgroundSettings Class See Also Send Feedback

The GH_BackgroundSettings type exposes the following members.

Properties

 | Name | Description
Public property | Colour1 | First background colour. Depending on the background style, this colour is used in different ways.
Public property | Colour2 | Second background colour. Depending on the background style, this colour is used in different ways.
Public property | Hatch | Background hatch brush style. This property is only used if BackgroundStyle is set to GH_ThemeBackgroundStyle.Hatch.
Public property | Style | Canvas monochromatic flag. If True, the canvas background is a solid colour.

See Also

GH_BackgroundSettings Class
Grasshopper.GUI.Theme Namespace


Colour1 Property

[image]

Grasshopper SDK
GH_BackgroundSettings..::..Colour1 Property
GH_BackgroundSettings Class See Also Send Feedback
First background colour. Depending on the background style, this colour is used in different ways.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color Colour1 { get; set; }
Visual Basic
Public Property Colour1 As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Theme.GH_BackgroundSettings.Colour1"]

See Also

GH_BackgroundSettings Class
Grasshopper.GUI.Theme Namespace


Colour2 Property

[image]

Grasshopper SDK
GH_BackgroundSettings..::..Colour2 Property
GH_BackgroundSettings Class See Also Send Feedback
Second background colour. Depending on the background style, this colour is used in different ways.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color Colour2 { get; set; }
Visual Basic
Public Property Colour2 As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Theme.GH_BackgroundSettings.Colour2"]

See Also

GH_BackgroundSettings Class
Grasshopper.GUI.Theme Namespace


Hatch Property

[image]

Grasshopper SDK
GH_BackgroundSettings..::..Hatch Property
GH_BackgroundSettings Class See Also Send Feedback
Background hatch brush style. This property is only used if BackgroundStyle is set to GH_ThemeBackgroundStyle.Hatch.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public HatchStyle Hatch { get; set; }
Visual Basic
Public Property Hatch As HatchStyle
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Theme.GH_BackgroundSettings.Hatch"]

See Also

GH_BackgroundSettings Class
Grasshopper.GUI.Theme Namespace


Style Property

[image]

Grasshopper SDK
GH_BackgroundSettings..::..Style Property
GH_BackgroundSettings Class See Also Send Feedback
Canvas monochromatic flag. If True, the canvas background is a solid colour.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_BackgroundStyle Style { get; set; }
Visual Basic
Public Property Style As GH_BackgroundStyle
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Theme.GH_BackgroundSettings.Style"]

See Also

GH_BackgroundSettings Class
Grasshopper.GUI.Theme Namespace


GH_BackgroundStyle Enumeration

[image]

Grasshopper SDK
GH_BackgroundStyle Enumeration
See Also Send Feedback
Enumerates the pre-defined canvas background themes.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_BackgroundStyle
Visual Basic
Public Enumeration GH_BackgroundStyle

Members

Member name | Value | Description
Solid | 0 | Canvas background will be a single, solid colour.
Hatch | 1 | Canvas background will be a GDI hatch brush.
GradientLeftRight | 10 | Canvas background will be a linear horizontal gradient.
GradientTopBottom | 11 | Canvas background will be a linear vertical gradient.

See Also

Grasshopper.GUI.Theme Namespace


GH_ObjectSettings Class

[image]

Grasshopper SDK
GH_ObjectSettings Class
Members See Also Send Feedback

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_ObjectSettings
Visual Basic
Public Class GH_ObjectSettings

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI.Theme..::..GH_ObjectSettings

See Also

GH_ObjectSettings Members
Grasshopper.GUI.Theme Namespace


GH_ObjectSettings Members

[image] [image]

Grasshopper SDK
GH_ObjectSettings Members
GH_ObjectSettings Class Properties See Also Send Feedback

The GH_ObjectSettings type exposes the following members.

Properties

 | Name | Description
Public property | GroupColour | Gets or sets the default fill colour for group objects.
Public property | PanelColour | Gets or sets the default fill colour for panel objects.
Public property | ZuiEdgeColour | Gets or sets the edge colour for ZUI elements.
Public property | ZuiFillColour | Gets or sets the fill colour for ZUI elements.

See Also

GH_ObjectSettings Class
Grasshopper.GUI.Theme Namespace


GH_ObjectSettings Properties

[image] [image]

Grasshopper SDK
GH_ObjectSettings Properties
GH_ObjectSettings Class See Also Send Feedback

The GH_ObjectSettings type exposes the following members.

Properties

 | Name | Description
Public property | GroupColour | Gets or sets the default fill colour for group objects.
Public property | PanelColour | Gets or sets the default fill colour for panel objects.
Public property | ZuiEdgeColour | Gets or sets the edge colour for ZUI elements.
Public property | ZuiFillColour | Gets or sets the fill colour for ZUI elements.

See Also

GH_ObjectSettings Class
Grasshopper.GUI.Theme Namespace


GroupColour Property

[image]

Grasshopper SDK
GH_ObjectSettings..::..GroupColour Property
GH_ObjectSettings Class See Also Send Feedback
Gets or sets the default fill colour for group objects.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color GroupColour { get; set; }
Visual Basic
Public Property GroupColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Theme.GH_ObjectSettings.GroupColour"]

See Also

GH_ObjectSettings Class
Grasshopper.GUI.Theme Namespace


PanelColour Property

[image]

Grasshopper SDK
GH_ObjectSettings..::..PanelColour Property
GH_ObjectSettings Class See Also Send Feedback
Gets or sets the default fill colour for panel objects.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color PanelColour { get; set; }
Visual Basic
Public Property PanelColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Theme.GH_ObjectSettings.PanelColour"]

See Also

GH_ObjectSettings Class
Grasshopper.GUI.Theme Namespace


ZuiEdgeColour Property

[image]

Grasshopper SDK
GH_ObjectSettings..::..ZuiEdgeColour Property
GH_ObjectSettings Class See Also Send Feedback
Gets or sets the edge colour for ZUI elements.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color ZuiEdgeColour { get; set; }
Visual Basic
Public Property ZuiEdgeColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Theme.GH_ObjectSettings.ZuiEdgeColour"]

See Also

GH_ObjectSettings Class
Grasshopper.GUI.Theme Namespace


ZuiFillColour Property

[image]

Grasshopper SDK
GH_ObjectSettings..::..ZuiFillColour Property
GH_ObjectSettings Class See Also Send Feedback
Gets or sets the fill colour for ZUI elements.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color ZuiFillColour { get; set; }
Visual Basic
Public Property ZuiFillColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Theme.GH_ObjectSettings.ZuiFillColour"]

See Also

GH_ObjectSettings Class
Grasshopper.GUI.Theme Namespace


GH_PageSettings Class

[image]

Grasshopper SDK
GH_PageSettings Class
Members See Also Send Feedback

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_PageSettings
Visual Basic
Public Class GH_PageSettings

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI.Theme..::..GH_PageSettings

See Also

GH_PageSettings Members
Grasshopper.GUI.Theme Namespace


GH_PageSettings Members

[image] [image]

Grasshopper SDK
GH_PageSettings Members
GH_PageSettings Class Properties See Also Send Feedback

The GH_PageSettings type exposes the following members.

Properties

 | Name | Description
Public property | DrawGrid | Gets or sets whether the grid ought to be drawn.
Public property | DrawPage | Gets or sets whether the page ought to be drawn.
Public property | DrawShadow | Gets or sets whether the page shadow ought to be drawn. If the page is not drawn, neither is the page shadow, irregardless of this property.
Public property | EdgeColour | Gets or sets the page edge colour to be used.
Public property | FillColour | Gets or sets the page fill colour to be used.
Public property | GridColour | Gets or sets the page grid colour to be used.
Public property | GridHeight | Gets or sets the height of a page grid cell.
Public property | GridPattern | Gets or sets the dash pattern to apply to grid lines. Leave null or empty for a solid line.
Public property | GridWidth | Gets or sets the width of a page grid cell.
Public property | ShadowColour | Gets or set the page shadow colour to be used.
Public property | ShadowSize | Gets or sets the size of the page shadow.

See Also

GH_PageSettings Class
Grasshopper.GUI.Theme Namespace


GH_PageSettings Properties

[image] [image]

Grasshopper SDK
GH_PageSettings Properties
GH_PageSettings Class See Also Send Feedback

The GH_PageSettings type exposes the following members.

Properties

 | Name | Description
Public property | DrawGrid | Gets or sets whether the grid ought to be drawn.
Public property | DrawPage | Gets or sets whether the page ought to be drawn.
Public property | DrawShadow | Gets or sets whether the page shadow ought to be drawn. If the page is not drawn, neither is the page shadow, irregardless of this property.
Public property | EdgeColour | Gets or sets the page edge colour to be used.
Public property | FillColour | Gets or sets the page fill colour to be used.
Public property | GridColour | Gets or sets the page grid colour to be used.
Public property | GridHeight | Gets or sets the height of a page grid cell.
Public property | GridPattern | Gets or sets the dash pattern to apply to grid lines. Leave null or empty for a solid line.
Public property | GridWidth | Gets or sets the width of a page grid cell.
Public property | ShadowColour | Gets or set the page shadow colour to be used.
Public property | ShadowSize | Gets or sets the size of the page shadow.

See Also

GH_PageSettings Class
Grasshopper.GUI.Theme Namespace


DrawGrid Property

[image]

Grasshopper SDK
GH_PageSettings..::..DrawGrid Property
GH_PageSettings Class See Also Send Feedback
Gets or sets whether the grid ought to be drawn.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool DrawGrid { get; set; }
Visual Basic
Public Property DrawGrid As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Theme.GH_PageSettings.DrawGrid"]

See Also

GH_PageSettings Class
Grasshopper.GUI.Theme Namespace


DrawPage Property

[image]

Grasshopper SDK
GH_PageSettings..::..DrawPage Property
GH_PageSettings Class See Also Send Feedback
Gets or sets whether the page ought to be drawn.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool DrawPage { get; set; }
Visual Basic
Public Property DrawPage As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Theme.GH_PageSettings.DrawPage"]

See Also

GH_PageSettings Class
Grasshopper.GUI.Theme Namespace


DrawShadow Property

[image]

Grasshopper SDK
GH_PageSettings..::..DrawShadow Property
GH_PageSettings Class See Also Send Feedback
Gets or sets whether the page shadow ought to be drawn. If the page is not drawn, neither is the page shadow, irregardless of this property.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool DrawShadow { get; set; }
Visual Basic
Public Property DrawShadow As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Theme.GH_PageSettings.DrawShadow"]

See Also

GH_PageSettings Class
Grasshopper.GUI.Theme Namespace


EdgeColour Property

[image]

Grasshopper SDK
GH_PageSettings..::..EdgeColour Property
GH_PageSettings Class See Also Send Feedback
Gets or sets the page edge colour to be used.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color EdgeColour { get; set; }
Visual Basic
Public Property EdgeColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Theme.GH_PageSettings.EdgeColour"]

See Also

GH_PageSettings Class
Grasshopper.GUI.Theme Namespace


FillColour Property

[image]

Grasshopper SDK
GH_PageSettings..::..FillColour Property
GH_PageSettings Class See Also Send Feedback
Gets or sets the page fill colour to be used.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color FillColour { get; set; }
Visual Basic
Public Property FillColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Theme.GH_PageSettings.FillColour"]

See Also

GH_PageSettings Class
Grasshopper.GUI.Theme Namespace


GridColour Property

[image]

Grasshopper SDK
GH_PageSettings..::..GridColour Property
GH_PageSettings Class See Also Send Feedback
Gets or sets the page grid colour to be used.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color GridColour { get; set; }
Visual Basic
Public Property GridColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Theme.GH_PageSettings.GridColour"]

See Also

GH_PageSettings Class
Grasshopper.GUI.Theme Namespace


GridHeight Property

[image]

Grasshopper SDK
GH_PageSettings..::..GridHeight Property
GH_PageSettings Class See Also Send Feedback
Gets or sets the height of a page grid cell.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int GridHeight { get; set; }
Visual Basic
Public Property GridHeight As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Theme.GH_PageSettings.GridHeight"]

See Also

GH_PageSettings Class
Grasshopper.GUI.Theme Namespace


GridPattern Property

[image]

Grasshopper SDK
GH_PageSettings..::..GridPattern Property
GH_PageSettings Class See Also Send Feedback
Gets or sets the dash pattern to apply to grid lines. Leave null or empty for a solid line.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public float[] GridPattern { get; set; }
Visual Basic
Public Property GridPattern As Single()
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Theme.GH_PageSettings.GridPattern"]

See Also

GH_PageSettings Class
Grasshopper.GUI.Theme Namespace


GridWidth Property

[image]

Grasshopper SDK
GH_PageSettings..::..GridWidth Property
GH_PageSettings Class See Also Send Feedback
Gets or sets the width of a page grid cell.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int GridWidth { get; set; }
Visual Basic
Public Property GridWidth As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Theme.GH_PageSettings.GridWidth"]

See Also

GH_PageSettings Class
Grasshopper.GUI.Theme Namespace


ShadowColour Property

[image]

Grasshopper SDK
GH_PageSettings..::..ShadowColour Property
GH_PageSettings Class See Also Send Feedback
Gets or set the page shadow colour to be used.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color ShadowColour { get; set; }
Visual Basic
Public Property ShadowColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Theme.GH_PageSettings.ShadowColour"]

See Also

GH_PageSettings Class
Grasshopper.GUI.Theme Namespace


ShadowSize Property

[image]

Grasshopper SDK
GH_PageSettings..::..ShadowSize Property
GH_PageSettings Class See Also Send Feedback
Gets or sets the size of the page shadow.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int ShadowSize { get; set; }
Visual Basic
Public Property ShadowSize As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Theme.GH_PageSettings.ShadowSize"]

See Also

GH_PageSettings Class
Grasshopper.GUI.Theme Namespace


GH_PaletteSettings Class

[image]

Grasshopper SDK
GH_PaletteSettings Class
Members See Also Send Feedback

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_PaletteSettings
Visual Basic
Public Class GH_PaletteSettings

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI.Theme..::..GH_PaletteSettings

See Also

GH_PaletteSettings Members
Grasshopper.GUI.Theme Namespace


GH_PaletteSettings Members

[image] [image]

Grasshopper SDK
GH_PaletteSettings Members
GH_PaletteSettings Class Properties See Also Send Feedback

The GH_PaletteSettings type exposes the following members.

Properties

 | Name | Description
Public property | ErrorSelected | Gets or sets the palette style for selected Error palettes.
Public property | ErrorStandard | Gets or sets the palette style for unselected Error palettes.
Public property | HiddenSelected | Gets or sets the palette style for selected Hidden palettes.
Public property | HiddenStandard | Gets or sets the palette style for unselected Hidden palettes.
Public property | LockedSelected | Gets or sets the palette style for selected Locked palettes.
Public property | LockedStandard | Gets or sets the palette style for unselected Locked palettes.
Public property | NormalSelected | Gets or sets the palette style for selected Normal palettes.
Public property | NormalStandard | Gets or sets the palette style for unselected Normal palettes.
Public property | WarningSelected | Gets or sets the palette style for selected Warning palettes.
Public property | WarningStandard | Gets or sets the palette style for unselected Warning palettes.

See Also

GH_PaletteSettings Class
Grasshopper.GUI.Theme Namespace


GH_PaletteSettings Properties

[image] [image]

Grasshopper SDK
GH_PaletteSettings Properties
GH_PaletteSettings Class See Also Send Feedback

The GH_PaletteSettings type exposes the following members.

Properties

 | Name | Description
Public property | ErrorSelected | Gets or sets the palette style for selected Error palettes.
Public property | ErrorStandard | Gets or sets the palette style for unselected Error palettes.
Public property | HiddenSelected | Gets or sets the palette style for selected Hidden palettes.
Public property | HiddenStandard | Gets or sets the palette style for unselected Hidden palettes.
Public property | LockedSelected | Gets or sets the palette style for selected Locked palettes.
Public property | LockedStandard | Gets or sets the palette style for unselected Locked palettes.
Public property | NormalSelected | Gets or sets the palette style for selected Normal palettes.
Public property | NormalStandard | Gets or sets the palette style for unselected Normal palettes.
Public property | WarningSelected | Gets or sets the palette style for selected Warning palettes.
Public property | WarningStandard | Gets or sets the palette style for unselected Warning palettes.

See Also

GH_PaletteSettings Class
Grasshopper.GUI.Theme Namespace


ErrorSelected Property

[image]

Grasshopper SDK
GH_PaletteSettings..::..ErrorSelected Property
GH_PaletteSettings Class See Also Send Feedback
Gets or sets the palette style for selected Error palettes.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PaletteStyle ErrorSelected { get; set; }
Visual Basic
Public Property ErrorSelected As GH_PaletteStyle
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Theme.GH_PaletteSettings.ErrorSelected"]

See Also

GH_PaletteSettings Class
Grasshopper.GUI.Theme Namespace


ErrorStandard Property

[image]

Grasshopper SDK
GH_PaletteSettings..::..ErrorStandard Property
GH_PaletteSettings Class See Also Send Feedback
Gets or sets the palette style for unselected Error palettes.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PaletteStyle ErrorStandard { get; set; }
Visual Basic
Public Property ErrorStandard As GH_PaletteStyle
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Theme.GH_PaletteSettings.ErrorStandard"]

See Also

GH_PaletteSettings Class
Grasshopper.GUI.Theme Namespace


HiddenSelected Property

[image]

Grasshopper SDK
GH_PaletteSettings..::..HiddenSelected Property
GH_PaletteSettings Class See Also Send Feedback
Gets or sets the palette style for selected Hidden palettes.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PaletteStyle HiddenSelected { get; set; }
Visual Basic
Public Property HiddenSelected As GH_PaletteStyle
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Theme.GH_PaletteSettings.HiddenSelected"]

See Also

GH_PaletteSettings Class
Grasshopper.GUI.Theme Namespace


HiddenStandard Property

[image]

Grasshopper SDK
GH_PaletteSettings..::..HiddenStandard Property
GH_PaletteSettings Class See Also Send Feedback
Gets or sets the palette style for unselected Hidden palettes.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PaletteStyle HiddenStandard { get; set; }
Visual Basic
Public Property HiddenStandard As GH_PaletteStyle
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Theme.GH_PaletteSettings.HiddenStandard"]

See Also

GH_PaletteSettings Class
Grasshopper.GUI.Theme Namespace


LockedSelected Property

[image]

Grasshopper SDK
GH_PaletteSettings..::..LockedSelected Property
GH_PaletteSettings Class See Also Send Feedback
Gets or sets the palette style for selected Locked palettes.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PaletteStyle LockedSelected { get; set; }
Visual Basic
Public Property LockedSelected As GH_PaletteStyle
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Theme.GH_PaletteSettings.LockedSelected"]

See Also

GH_PaletteSettings Class
Grasshopper.GUI.Theme Namespace


LockedStandard Property

[image]

Grasshopper SDK
GH_PaletteSettings..::..LockedStandard Property
GH_PaletteSettings Class See Also Send Feedback
Gets or sets the palette style for unselected Locked palettes.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PaletteStyle LockedStandard { get; set; }
Visual Basic
Public Property LockedStandard As GH_PaletteStyle
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Theme.GH_PaletteSettings.LockedStandard"]

See Also

GH_PaletteSettings Class
Grasshopper.GUI.Theme Namespace


NormalSelected Property

[image]

Grasshopper SDK
GH_PaletteSettings..::..NormalSelected Property
GH_PaletteSettings Class See Also Send Feedback
Gets or sets the palette style for selected Normal palettes.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PaletteStyle NormalSelected { get; set; }
Visual Basic
Public Property NormalSelected As GH_PaletteStyle
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Theme.GH_PaletteSettings.NormalSelected"]

See Also

GH_PaletteSettings Class
Grasshopper.GUI.Theme Namespace


NormalStandard Property

[image]

Grasshopper SDK
GH_PaletteSettings..::..NormalStandard Property
GH_PaletteSettings Class See Also Send Feedback
Gets or sets the palette style for unselected Normal palettes.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PaletteStyle NormalStandard { get; set; }
Visual Basic
Public Property NormalStandard As GH_PaletteStyle
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Theme.GH_PaletteSettings.NormalStandard"]

See Also

GH_PaletteSettings Class
Grasshopper.GUI.Theme Namespace


WarningSelected Property

[image]

Grasshopper SDK
GH_PaletteSettings..::..WarningSelected Property
GH_PaletteSettings Class See Also Send Feedback
Gets or sets the palette style for selected Warning palettes.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PaletteStyle WarningSelected { get; set; }
Visual Basic
Public Property WarningSelected As GH_PaletteStyle
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Theme.GH_PaletteSettings.WarningSelected"]

See Also

GH_PaletteSettings Class
Grasshopper.GUI.Theme Namespace


WarningStandard Property

[image]

Grasshopper SDK
GH_PaletteSettings..::..WarningStandard Property
GH_PaletteSettings Class See Also Send Feedback
Gets or sets the palette style for unselected Warning palettes.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PaletteStyle WarningStandard { get; set; }
Visual Basic
Public Property WarningStandard As GH_PaletteStyle
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Theme.GH_PaletteSettings.WarningStandard"]

See Also

GH_PaletteSettings Class
Grasshopper.GUI.Theme Namespace


GH_Theme Class

[image]

Grasshopper SDK
GH_Theme Class
Members See Also Send Feedback

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Theme : GH_ISerializable
Visual Basic
Public Class GH_Theme _
    Implements GH_ISerializable

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI.Theme..::..GH_Theme

See Also

GH_Theme Members
Grasshopper.GUI.Theme Namespace


GH_Theme Members

[image] [image]

Grasshopper SDK
GH_Theme Members
GH_Theme Class Constructors Methods Properties See Also Send Feedback

The GH_Theme type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Theme()()()() | Create a new default theme.
Public method | GH_Theme(GH_Theme) | Make a duplicate of another theme.

Methods

 | Name | Description
Public method | LoadTheme | Instantiate all palette and gui defaults. This function reads the colour values out of grasshopper_gui.xml settings database if it exists.
Public method | Read |
Public method | SaveTheme | Store all palette and gui defaults. This function writes the colour values out to grasshopper_gui.xml settings database.
Public method | Write |

Properties

 | Name | Description
Public property | BackGround | Gets the theme background settings.
 | DefaultTheme |
Public property | Objects | Gets the theme objects and ZUI settings.
Public property | Page | Gets the theme page and grid settings.
Public property | Palettes | Gets the theme palette settings.
Public property | Wires | Gets the theme wire settings.

See Also

GH_Theme Class
Grasshopper.GUI.Theme Namespace


GH_Theme Constructor

[image] [image]

Grasshopper SDK
GH_Theme Constructor
GH_Theme Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Theme()()()() | Create a new default theme.
Public method | GH_Theme(GH_Theme) | Make a duplicate of another theme.

See Also

GH_Theme Class
GH_Theme Members
Grasshopper.GUI.Theme Namespace


GH_Theme Constructor

[image]

Grasshopper SDK
GH_Theme Constructor
GH_Theme Class See Also Send Feedback
Create a new default theme.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Theme()
Visual Basic
Public Sub New

See Also

GH_Theme Class
GH_Theme Overload
Grasshopper.GUI.Theme Namespace


GH_Theme Constructor (GH_Theme)

[image]

Grasshopper SDK
GH_Theme Constructor (GH_Theme)
GH_Theme Class See Also Send Feedback
Make a duplicate of another theme.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Theme(
    GH_Theme other
)
Visual Basic
Public Sub New ( _
    other As GH_Theme _
)

Parameters

other
Type: Grasshopper.GUI.Theme..::..GH_Theme
Theme to copy.

See Also

GH_Theme Class
GH_Theme Overload
Grasshopper.GUI.Theme Namespace


GH_Theme Methods

[image] [image]

Grasshopper SDK
GH_Theme Methods
GH_Theme Class See Also Send Feedback

The GH_Theme type exposes the following members.

Methods

 | Name | Description
Public method | LoadTheme | Instantiate all palette and gui defaults. This function reads the colour values out of grasshopper_gui.xml settings database if it exists.
Public method | Read |
Public method | SaveTheme | Store all palette and gui defaults. This function writes the colour values out to grasshopper_gui.xml settings database.
Public method | Write |

See Also

GH_Theme Class
Grasshopper.GUI.Theme Namespace


LoadTheme Method

[image]

Grasshopper SDK
GH_Theme..::..LoadTheme Method
GH_Theme Class See Also Send Feedback
Instantiate all palette and gui defaults. This function reads the colour values out of grasshopper_gui.xml settings database if it exists.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void LoadTheme()
Visual Basic
Public Sub LoadTheme

See Also

GH_Theme Class
Grasshopper.GUI.Theme Namespace


Read Method

[image]

Grasshopper SDK
GH_Theme..::..Read Method
GH_Theme Class See Also Send Feedback

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Read(
    GH_IReader reader
)
Visual Basic
Public Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

Implements

GH_ISerializable..::..Read(GH_IReader)

See Also

GH_Theme Class
Grasshopper.GUI.Theme Namespace


SaveTheme Method

[image]

Grasshopper SDK
GH_Theme..::..SaveTheme Method
GH_Theme Class See Also Send Feedback
Store all palette and gui defaults. This function writes the colour values out to grasshopper_gui.xml settings database.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SaveTheme()
Visual Basic
Public Sub SaveTheme

See Also

GH_Theme Class
Grasshopper.GUI.Theme Namespace


Write Method

[image]

Grasshopper SDK
GH_Theme..::..Write Method
GH_Theme Class See Also Send Feedback

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Write(
    GH_IWriter writer
)
Visual Basic
Public Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

Implements

GH_ISerializable..::..Write(GH_IWriter)

See Also

GH_Theme Class
Grasshopper.GUI.Theme Namespace


GH_Theme Properties

[image] [image]

Grasshopper SDK
GH_Theme Properties
GH_Theme Class See Also Send Feedback

The GH_Theme type exposes the following members.

Properties

 | Name | Description
Public property | BackGround | Gets the theme background settings.
 | DefaultTheme |
Public property | Objects | Gets the theme objects and ZUI settings.
Public property | Page | Gets the theme page and grid settings.
Public property | Palettes | Gets the theme palette settings.
Public property | Wires | Gets the theme wire settings.

See Also

GH_Theme Class
Grasshopper.GUI.Theme Namespace


BackGround Property

[image]

Grasshopper SDK
GH_Theme..::..BackGround Property
GH_Theme Class See Also Send Feedback
Gets the theme background settings.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_BackgroundSettings BackGround { get; }
Visual Basic
Public ReadOnly Property BackGround As GH_BackgroundSettings
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Theme.GH_Theme.BackGround"]

See Also

GH_Theme Class
Grasshopper.GUI.Theme Namespace


DefaultTheme Property

[image]

Grasshopper SDK
GH_Theme..::..DefaultTheme Property
GH_Theme Class See Also Send Feedback

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Theme DefaultTheme { get; }
Visual Basic
Public Shared ReadOnly Property DefaultTheme As GH_Theme
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Theme.GH_Theme.DefaultTheme"]

See Also

GH_Theme Class
Grasshopper.GUI.Theme Namespace


Objects Property

[image]

Grasshopper SDK
GH_Theme..::..Objects Property
GH_Theme Class See Also Send Feedback
Gets the theme objects and ZUI settings.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ObjectSettings Objects { get; }
Visual Basic
Public ReadOnly Property Objects As GH_ObjectSettings
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Theme.GH_Theme.Objects"]

See Also

GH_Theme Class
Grasshopper.GUI.Theme Namespace


Page Property

[image]

Grasshopper SDK
GH_Theme..::..Page Property
GH_Theme Class See Also Send Feedback
Gets the theme page and grid settings.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PageSettings Page { get; }
Visual Basic
Public ReadOnly Property Page As GH_PageSettings
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Theme.GH_Theme.Page"]

See Also

GH_Theme Class
Grasshopper.GUI.Theme Namespace


Palettes Property

[image]

Grasshopper SDK
GH_Theme..::..Palettes Property
GH_Theme Class See Also Send Feedback
Gets the theme palette settings.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PaletteSettings Palettes { get; }
Visual Basic
Public ReadOnly Property Palettes As GH_PaletteSettings
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Theme.GH_Theme.Palettes"]

See Also

GH_Theme Class
Grasshopper.GUI.Theme Namespace


Wires Property

[image]

Grasshopper SDK
GH_Theme..::..Wires Property
GH_Theme Class See Also Send Feedback
Gets the theme wire settings.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_WireSettings Wires { get; }
Visual Basic
Public ReadOnly Property Wires As GH_WireSettings
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Theme.GH_Theme.Wires"]

See Also

GH_Theme Class
Grasshopper.GUI.Theme Namespace


GH_WireSettings Class

[image]

Grasshopper SDK
GH_WireSettings Class
Members See Also Send Feedback

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_WireSettings
Visual Basic
Public Class GH_WireSettings

Inheritance Hierarchy

System..::..Object
Grasshopper.GUI.Theme..::..GH_WireSettings

See Also

GH_WireSettings Members
Grasshopper.GUI.Theme Namespace


GH_WireSettings Members

[image] [image]

Grasshopper SDK
GH_WireSettings Members
GH_WireSettings Class Properties See Also Send Feedback

The GH_WireSettings type exposes the following members.

Properties

 | Name | Description
Public property | DefaultColour | Gets or sets the colour to use for standard wires.
Public property | EmptyColour | Gets or sets the colour to use for empty wires.
Public property | SelectedColour0 | Gets or sets the colour of a wire at the selected extreme.
Public property | SelectedColour1 | Gets or sets the colour of a wire at the unselected extreme.

See Also

GH_WireSettings Class
Grasshopper.GUI.Theme Namespace


GH_WireSettings Properties

[image] [image]

Grasshopper SDK
GH_WireSettings Properties
GH_WireSettings Class See Also Send Feedback

The GH_WireSettings type exposes the following members.

Properties

 | Name | Description
Public property | DefaultColour | Gets or sets the colour to use for standard wires.
Public property | EmptyColour | Gets or sets the colour to use for empty wires.
Public property | SelectedColour0 | Gets or sets the colour of a wire at the selected extreme.
Public property | SelectedColour1 | Gets or sets the colour of a wire at the unselected extreme.

See Also

GH_WireSettings Class
Grasshopper.GUI.Theme Namespace


DefaultColour Property

[image]

Grasshopper SDK
GH_WireSettings..::..DefaultColour Property
GH_WireSettings Class See Also Send Feedback
Gets or sets the colour to use for standard wires.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color DefaultColour { get; set; }
Visual Basic
Public Property DefaultColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Theme.GH_WireSettings.DefaultColour"]

See Also

GH_WireSettings Class
Grasshopper.GUI.Theme Namespace


EmptyColour Property

[image]

Grasshopper SDK
GH_WireSettings..::..EmptyColour Property
GH_WireSettings Class See Also Send Feedback
Gets or sets the colour to use for empty wires.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color EmptyColour { get; set; }
Visual Basic
Public Property EmptyColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Theme.GH_WireSettings.EmptyColour"]

See Also

GH_WireSettings Class
Grasshopper.GUI.Theme Namespace


SelectedColour0 Property

[image]

Grasshopper SDK
GH_WireSettings..::..SelectedColour0 Property
GH_WireSettings Class See Also Send Feedback
Gets or sets the colour of a wire at the selected extreme.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color SelectedColour0 { get; set; }
Visual Basic
Public Property SelectedColour0 As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Theme.GH_WireSettings.SelectedColour0"]

See Also

GH_WireSettings Class
Grasshopper.GUI.Theme Namespace


SelectedColour1 Property

[image]

Grasshopper SDK
GH_WireSettings..::..SelectedColour1 Property
GH_WireSettings Class See Also Send Feedback
Gets or sets the colour of a wire at the unselected extreme.

Namespace: Grasshopper.GUI.Theme
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color SelectedColour1 { get; set; }
Visual Basic
Public Property SelectedColour1 As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.GUI.Theme.GH_WireSettings.SelectedColour1"]

See Also

GH_WireSettings Class
Grasshopper.GUI.Theme Namespace


Grasshopper.Kernel Namespace

[image]

Grasshopper SDK
Grasshopper.Kernel Namespace
Send Feedback
The Kernel namespace contains all the classes that make up the logical backbone of the plug-in.

Classes

 | Class | Description
Public class | GH_ActiveObject | Basic implementation of IGH_ActiveObject interface. Derive from this class rather than implementing IGH_ActiveObject to make your life easier.
Public class | GH_Alias | Represents a single alias|target combo.
Public class | GH_AssemblyInfo | Implement this interface once (and once only) in a GHA project if you wish to add additional information about your library to Grasshopper. Note you must supply an empty constructor.
Public class | GH_AssemblyInfoStub | Provides basic properties for a GHA assembly that does not expose a type that derives from GH_AssemblyInfo. This type is created automatically when a GH_AssemblyInfo type is not found in an assembly.
Public class | GH_AssemblyPriority | Derive from this class if you wish to perform additional steps before any of your components are loaded. Any class in your project which inherits from GH_AssemblyPriority and which has an empty constructor will be instantiated prior to any GH_Component or IGH_DocumentObject classes.
Public class | GH_Attributes<(Of <(<'T>)>)> | Derive from this class rather than implementing IGH_Attributes from scratch.
Public class | GH_AttributesChangedEventArgs | Event arguments passed during AttributesChanged events.
Public class | GH_Author | Maintains author information such as name, company, copyright, address etc.
Public class | GH_AutoSaveSettings | Provides access to all AutoSave event flags.
Public class | GH_Component | Inherit from this class if you wish to create a custom component. Note that you must provide a public, empty constructor which calls the base class constructor.
Protected class | GH_Component..::..GH_InputParamManager | This class is used during Component construction to add input parameters.
Protected class | GH_Component..::..GH_OutputParamManager | This class is used during Component construction to add output parameters.
Public class | GH_ComponentParamServer | Wraps all members and functions needed for GH_Component to manage its input and output parameters.
Public class | GH_ComponentServer | Maintains proxies for all components, parameters and other object types as defined in all grasshopper assemblies.
Public class | GH_ConnectivityDiagram | Represents a complete connectivity diagram (topology) of a GH_Document. A connectivity diagram is basically an undirected network of all the wires in a document.
Public class | GH_ConnectivityDisparity | Maintains two connectivity diagrams, one of which is a subset of the other.
Public class | GH_ConnectivityNode | Represents a single node in a Grasshopper connectivity diagram. A single node represents a single IGH_Param instance.
Public class | GH_Convert | Provides static converters for different data types inside Grasshopper. This class both has specific and generic converters.
Public class | GH_CustomEventServer | RhinoCommon only event server.
Public class | GH_DebugDescriptionWriter | Writer object used to create debug logs.
Public class | GH_DisplayExpiredEventArgs | Arguments for display events.
Public class | GH_DocContextEventArgs | These arguments are passed along with SettingsChanged events on GH_Document.
Public class | GH_DocEnabledEventArgs | These arguments are passed along with SettingsChanged events on GH_Document.
Public class | GH_DocFilePathEventArgs | These arguments are passed along with FilePathChanged events on GH_Document.
Public class | GH_DocModifiedEventArgs | These arguments are passed along with ModifiedChanged events on GH_Document.
Public class | GH_DocObjectEventArgs | These arguments are passed along with ObjectsAdded and ObjectsRemoved events on GH_Document.
Public class | GH_DocSettingsEventArgs | These arguments are passed along with SettingsChanged events on GH_Document.
Public class | GH_Document | Represents a single Grasshopper document.
Public class | GH_Document..::..GH_UndoUtil | This class is emitted by the Undo property of a GH_Document instance.
Public class | GH_DocumentAssociations |
Public class | GH_DocumentEventServer | RhinoCommon only event server.
Public class | GH_DocumentIO | Provides basic IO operations for GH_Documents.
Public class | GH_DocumentObject | Standard implementation of IGH_DocumentObject.
Public class | GH_DocumentServer | Manages and maintains a collection of GH_Documents.
Public class | GH_DocumentTree | Represents a hierarchical tree of documents that are subsidiary to one another.
Public class | GH_DocumentTreeNode | Represents a single node in a document tree.
Public class | GH_DocUndoEventArgs | These arguments are passed along with UndoStateChanged events on GH_Document.
Public class | GH_ExternalFile | Represents information about external files to be loaded.
Public class | GH_FileSystemEventServer | Provides a easy-to-use way to keep tabs on files.
Public class | GH_FileWatcher | Provides easy mechanisms to monitor changes to the local File System.
Public class | GH_FontServer | Maintains a collection of standard fonts and mays to measure them.
Public class | GH_Format | Provides standard Grasshopper formatting functions.
Public class | GH_GHALoadingEventArgs | Event arguments used in the GH_GHALoaded event on GH_ComponentServer.
Public class | GH_GHXHarvester | Provides static methods for harvesting data from GHX and GH files.
Public class | GH_InstanceDescription | Base implementation of IGH_InstanceDescription. Consider deriving from this class rather than implementing IGH_InstanceDescription from scratch.
Public class | GH_LineParser | Provides basic functionality for the custom ReadFile component script parsing.
Public class | GH_ListUtil | Provides utilities for dealing with list of Data from input parameters.
Public class | GH_LoadingAttribute | Assembly loading behaviour attribute.
Public class | GH_MemoryBitmap | Utility class for ultra-fast bitmap sampling and filters.
Public class | GH_ObjectChangedEventArgs | Event arguments passed during ObjectChanged events.
Public class | GH_Param<(Of <(<'T>)>)> | Base implementation of IGH_Param. Derive from this class rather than implementing IGH_Param from scratch. If your parameter can store persistent data, derive from GH_PersistentParam(Of T) instead.
Public class | GH_ParamServerEventArgs | Arguments used in events for the GH_ComponentParamServer type.
Public class | GH_PersistentGeometryParam<(Of <(<'T>)>)> | Derives from GH_PersistentParam(Of T), but adds some useful functions for dealing with geometric data types.
Public class | GH_PersistentParam<(Of <(<'T>)>)> | Implementation of GH_Param(Of T) that supports persistent data.
Public class | GH_PingDocumentEventArgs | Event arguments passed during PingDocument events.
Public class | GH_PreviewArgs | This class is passed to Objects that implement IGH_PreviewObject during drawing operations.
Public class | GH_PreviewExpiredEventArgs | Arguments for preview events.
Public class | GH_PreviewMeshArgs | This class is passed to objects that implement IGH_PreviewData during mesh drawing operations.
Public class | GH_PreviewUtil | This class exposes functionality that makes it easy to draw temporary geometry in Rhino viewports.
Public class | GH_PreviewWireArgs | This class is passed to objects that implement IGH_PreviewData during wire drawing operations.
Public class | GH_RelevantObjectData | Contains information about relevant objects at a specific canvas location.
Public class | GH_RuntimeMessage | Contains all fields that together define a RuntimeMessage. Runtime Messages are created and recorded by document objects during Grasshopper solutions.
Public class | GH_SettingsServer | A single instance of this class is maintained at module level under the accessor "Settings".
Public class | GH_SolutionEventArgs | Event arguments used for Document Solution events.
Public class | GH_SolutionExpiredEventArgs | Arguments for solution events.
Public class | GH_State | Represents a single recorded document state. A state contains values for an arbitrary set of objects inside the document.
Public class | GH_StateServer | Maintains all the recorded states for this document.
Public class | GH_StateTag | Abstract implementation of the IGH_StateTag interface. Derive from this class rather than implementing IGH_StateTag.
Public class | GH_StateTagList | Maintains a collection of IGH_StateTag objects.
Public class | GH_TypeLib | Utility module that caches a number of oft-used types and type-ids for quick access. Do not change any of the values in this module or you'll wreck casting and conversion logic.
Public class | GH_UpgradeUtil | Exposes several utility functions for migrating parameters and wires between components useful while upgrading components.
Public class | GH_UserObject | Represents a custom user object. A User Object is an existing IGH_DocumentObject with overridden icon, instance description and exposure.
Public class | GH_ValueProxy<(Of <(<'T>)>)> | Represents the abstract base implementation of the IGH_ValueProxy interface.
Public class | GH_VarParamEventArgs | Arguments used in Variable Parameter events.
Public class | GH_ZuiAction | Basic implementation of IGH_ZuiAction.

Structures

 | Structure | Description
Public structure | GH_AssemblyFolderInfo | Represents a folder from which GHA files are loaded.
Public structure | GH_SolutionSpan | Represents the time interval for a GH_Document solution.

Interfaces

 | Interface | Description
Public interface | GH_ComponentParamServer..::..IGH_SyncObject | Synch object for tracking long term changes to the parameter server.
Public interface | IGH_ActiveObject | Base interface for all objects on the canvas that participate in solutions
Public interface | IGH_Attributes | Base interface for all Attributes. Attributes are the visual portion of GH_DocumentObjects. They handle display, mouse events, layout, context menus etc. etc. You should consider inheriting from GH_Attributes or some other abstract class instead of implementing this interface from scratch.
Public interface | IGH_Author | Provides of collection of basic author details.
Public interface | IGH_BakeAwareData | Implement this interface in your IGH_Goo data type if you want to be included in baking operations.
Public interface | IGH_BakeAwareObject | Implement this interface on your IGH_ActiveObject if you want to participate in the Bake GUI.
Public interface | IGH_Component | Base interface for all GH_Component types. Do not implement this interface from scratch, inherit from GH_Component instead.
Public interface | IGH_DataAccess | Provides access to component parameters, in order to retrieve and assign data during solutions.
Public interface | IGH_DebugDescription | Implement this interface to participate in Debug Logging.
Public interface | IGH_DocumentObject | Base interface for objects that want to play on the Canvas. Do not implement this interface from scratch. Either inherit from GH_DocumentObject or one of the other partially finished types such as GH_ActiveObject, GH_Param(Of T) or GH_Component.
Public interface | IGH_DocumentOwner | Implement this interface if you want to be the owner assigned to a document in the Grasshopper documentserver.
Public interface | IGH_EventConsumer | Implement this interface if you want to inter-operate with a GH_EventServer.
Public interface | IGH_InitCodeAware | Implement this interface in your IGH_DocumentObject class if you want to handle initialization codes from Canvas Search boxes.
Public interface | IGH_InstanceDescription | Base interface for all objects that participate in the Grasshopper GUI.
Public interface | IGH_InstanceGuidDependent | Implement this interface in your IGH_DocumentObject class if you want to be informed when the InstanceGuids of objects in the document are mutated.
Public interface | IGH_ObjectProxy | Provides proxy data for all Grasshopper components and parameters.
Public interface | IGH_Param | Base interface for all Parameter types in Grasshopper. Do not implement this interface from scratch, derive from GH_Param or GH_PersistentParam instead.
Public interface | IGH_PreviewArgs | Preview display arguments for IGH_PreviewObjects.
Public interface | IGH_PreviewData | All IGH_Goo types that wish to participate in Viewport redraws must implement this interface.
Public interface | IGH_PreviewMeshData | Implement this interface if your data deals with preview meshes.
Public interface | IGH_PreviewObject | All IGH_DocumentObjects that wish to participate in Viewport redraws must implement this interface.
Public interface | IGH_RCP_Aware | Implement this interface if you want to become part of the RemoteControlPanel.
Public interface | IGH_StateAwareObject | Implement this interface if you want to be included in state saving/loading.
Public interface | IGH_StateTag | A StateTag is a visual feedback mechanism that reflects a certain local setting of an Object.
Public interface | IGH_UpgradeObject | Create a class with an empty constructor that implements this interface if you want to provide an upgrade mechanism.
Public interface | IGH_UserPromptAware | Implement this interface in your IGH_Param if you want to allow users to set data either through the menu or by double clicking.
Public interface | IGH_ValueProxy |
Public interface | IGH_VariableParameterComponent | Implement this interface in your component if you want to enable variable parameter UI.
Public interface | IGH_VarParamComponent | This interface is obsolete, please use the IGH_VariableParameterComponent interface instead.
Public interface | IGH_ZuiAction | Represents a single action which is only visible on screen above a certain zoom level.

Delegates

 | Delegate | Description
Public delegate | GH_AutoSaveSettings..::..AutoSaveFileFormatChangedEventHandler |
Public delegate | GH_AutoSaveSettings..::..EnableAutoSaveChangedEventHandler |
Public delegate | GH_AutoSaveSettings..::..SaveOnDataFlatteningChangedEventHandler |
Public delegate | GH_AutoSaveSettings..::..SaveOnDocumentUnloadChangedEventHandler |
Public delegate | GH_AutoSaveSettings..::..SaveOnObjectAddedChangedEventHandler |
Public delegate | GH_AutoSaveSettings..::..SaveOnObjectChangeChangedEventHandler |
Public delegate | GH_AutoSaveSettings..::..SaveOnObjectRemovedChangedEventHandler |
Public delegate | GH_AutoSaveSettings..::..SaveOnWireEventChangedEventHandler |
Public delegate | GH_ComponentParamServer..::..ParameterChangedEventHandler |
Public delegate | GH_ComponentParamServer..::..ParameterNickNameChangedEventHandler |
Public delegate | GH_ComponentParamServer..::..ParameterSourcesChangedEventHandler |
Public delegate | GH_ComponentServer..::..GHAFileLoadedEventHandler |
Public delegate | GH_Document..::..ContextChangedEventHandler |
Public delegate | GH_Document..::..DefaultPreviewColourChangedEventHandler |
Public delegate | GH_Document..::..DefaultSelectedPreviewColourChangedEventHandler |
Public delegate | GH_Document..::..EnabledChangedEventHandler |
Public delegate | GH_Document..::..EnableSolutionsChangedEventHandler |
Public delegate | GH_Document..::..FilePathChangedEventHandler |
Public delegate | GH_Document..::..GH_ActiveObjectFilter |
Public delegate | GH_Document..::..GH_ScheduleDelegate | Callback signature for Scheduled Solutions.
Public delegate | GH_Document..::..ModifiedChangedEventHandler |
Public delegate | GH_Document..::..ObjectsAddedEventHandler |
Public delegate | GH_Document..::..ObjectsDeletedEventHandler |
Public delegate | GH_Document..::..SettingsChangedEventHandler |
Public delegate | GH_Document..::..SolutionEndEventHandler |
Public delegate | GH_Document..::..SolutionStartEventHandler |
Public delegate | GH_Document..::..UndoStateChangedEventHandler |
Public delegate | GH_DocumentObject..::..ColourEventHandler |
Public delegate | GH_DocumentServer..::..DocumentAddedEventHandler |
Public delegate | GH_DocumentServer..::..DocumentRemovedEventHandler |
Public delegate | GH_FileSystemEventServer..::..FileEvent | This delegate is called when changes to a certain file occur.
Public delegate | GH_FileWatcher..::..FileChanged | Delegate method for file change callbacks.
Public delegate | GH_FileWatcher..::..FileChangedSimple | Delegate method for file change callbacks.
Public delegate | GH_FontServer..::..ConsoleFamilyChangedEventHandler |
Public delegate | GH_FontServer..::..ScriptFamilyChangedEventHandler |
Public delegate | GH_FontServer..::..StandardFamilyChangedEventHandler |
Protected delegate | GH_StateTag..::..DrawCallback | Drawing delegate.
Public delegate | IGH_DocumentObject..::..AttributesChangedEventHandler |
Public delegate | IGH_DocumentObject..::..DisplayExpiredEventHandler |
Public delegate | IGH_DocumentObject..::..ObjectChangedEventHandler |
Public delegate | IGH_DocumentObject..::..PingDocumentEventHandler |
Public delegate | IGH_DocumentObject..::..PreviewExpiredEventHandler |
Public delegate | IGH_DocumentObject..::..SolutionExpiredEventHandler |

Enumerations

 | Enumeration | Description
Public enumeration | GH_Arrange | Enumerates possible types of object arrangement.
Public enumeration | GH_AutoSaveTrigger | Different types of events that can cause an AutoSave.
Public enumeration | GH_BitmapChannel | Lists all possible channels for 24 and 32 bit bitmaps.
Public enumeration | GH_ClipboardType | Enumerates all possible clipboards for GH_DocumentIO operations.
Public enumeration | GH_Conversion | Level flag for conversion algorithms.
Public enumeration | GH_DataComparison | Enumerates all possible Data Matching algorithms for Components.
Public enumeration | GH_DataMapping | Enumerates all parameter data mapping types.
Public enumeration | GH_DocumentContext | Enumerates all possible (de)activation contexts for documents.
Public enumeration | GH_DocumentRank | Enumerates all possible document rankings.
Public enumeration | GH_DocumentSettings | Enumerates all possible types of settings for a GH_Document.
Public enumeration | GH_Exposure | Lists the different kinds of GUI exposure an object can have.
Public enumeration | GH_ExternalFileType | Enumerates the possible external files that Grasshopper is interested in.
Public enumeration | GH_FileWatcherEvents | Enumerates all possible file watcher events. These can be combined.
Public enumeration | GH_Filter | Enumerates all object Search filters.
Public enumeration | GH_GetterResult | Enumerates typical getter results.
Public enumeration | GH_GuidConflictSolution | Contains a list of all possible Assembly GUID conflict solutions
Public enumeration | GH_IconDisplayMode | Lists all display modes that individual objects can have.
Public enumeration | GH_LibraryLicense | Enumerates the possible library types for GHA assemblies.
Public enumeration | GH_LineParserAction | Enumerates the possible actions a line parser can invoke.
Public enumeration | GH_LoadingDemand | Enumerates all assembly loading behaviour demands.
Public enumeration | GH_LoadingInstruction | Enumerates all external GHA loading process instructions.
Public enumeration | GH_LoadingMechanism | Enumerates all assembly loading mechanisms.
Public enumeration | GH_MatchLevel | All possible string matching schemes.
Public enumeration | GH_MatchWeight | Weighting factors of string matches.
Public enumeration | GH_ObjectEventType | Represents common changes which can cause the ObjectChanged event to be raised.
Public enumeration | GH_ObjectSpecies | Contains all object species.
Public enumeration | GH_ObjectType | Enumerates all types of object that can be referenced by a GH_ObjectProxy instance.
Public enumeration | GH_ParamAccess | Enumerates the types of access that parameters support.
Public enumeration | GH_ParamData | Enumerates the possible states of being for data inside a parameter.
Public enumeration | GH_ParameterSide | Enumerates possible sides for variable parameters.
Public enumeration | GH_ParamHashFields | Enumerates all accepted fields for hashing parameter data.
Public enumeration | GH_ParamKind | Enumerates the different guises of parameter
Public enumeration | GH_ParamWireDisplay | Enumerates the possible wire display types for parameters.
Public enumeration | GH_PickBox | Represents the different ways in which picking rectangles can behave.
Public enumeration | GH_PluginFolderType | Enumerates the possible folder types for GH_AssemblyFolderInfo
Public enumeration | GH_PreviewFilter | Lists all possible Grasshopper preview filters.
Public enumeration | GH_PreviewMesh | Enumerates possible meshing parameters for documents.
Public enumeration | GH_PreviewMode | Lists all possible Grasshopper preview modes.
Public enumeration | GH_PrincipalState | Enumerates the different possible states in which the masterness of a parameter can occur.
Public enumeration | GH_ProcessStep | Enumerates all possible solution states in which the document can be.
Public enumeration | GH_ProfilerMode | Lists all profiler modes.
Public enumeration | GH_RelevantObjectFilter | Enumerates the possible filters to use in relevant object searches.
Public enumeration | GH_RuntimeMessageLevel | Indicates the severity of a runtime message.
Public enumeration | GH_SelectionState | Enumerates the possible effects of a specific selection operation.
Public enumeration | GH_SelectionTopology | Enumerates the possible selection topologies.
Public enumeration | GH_SettingsType | Lists all the data types available in the GH_SettingsServer class.
Public enumeration | GH_SolutionMode | Enumerates all solution modes.
Public enumeration | GH_SolutionPhase | The Phase flags are used to track object states during solutions.
Public enumeration | GH_StateTagLayoutDirection | Enumerates the possible layout directions for parameter state tags.
Public enumeration | GH_TimeKind | Enumerates the possible kinds that a System.DateTime value can imply.
Public enumeration | GH_UndoOperation | Enumerates all possible types of undo operation.
Public enumeration | GH_VarParamSide | Enumerates possible sides for variable parameters.


GH_ActiveObject Class

[image]

Grasshopper SDK
GH_ActiveObject Class
Members See Also Send Feedback
Basic implementation of IGH_ActiveObject interface. Derive from this class rather than implementing IGH_ActiveObject to make your life easier.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract class GH_ActiveObject : GH_DocumentObject,
    IGH_ActiveObject
Visual Basic
Public MustInherit Class GH_ActiveObject _
    Inherits GH_DocumentObject _
    Implements IGH_ActiveObject

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_InstanceDescription
Grasshopper.Kernel..::..GH_DocumentObject
Grasshopper.Kernel..::..GH_ActiveObject
Grasshopper.Kernel..::..GH_Component
Grasshopper.Kernel..::..GH_Param<(Of <(<'T>)>)>

See Also

GH_ActiveObject Members
Grasshopper.Kernel Namespace


GH_ActiveObject Members

[image] [image]

Grasshopper SDK
GH_ActiveObject Members
GH_ActiveObject Class Constructors Methods Fields Properties Events See Also Send Feedback

The GH_ActiveObject type exposes the following members.

Constructors

 | Name | Description
Protected method | GH_ActiveObject(IGH_InstanceDescription) | Initializes a new instance of the GH_ActiveObject class
Protected method | GH_ActiveObject(String, String, String, String, String) | Initializes a new instance of the GH_ActiveObject class

Methods

 | Name | Description
Public method | AddedToDocument | This method will be called when an object is added to a document. Override this method if you want to handle such events. (Inherited from GH_DocumentObject.)
Public method | AddRuntimeMessage | Add a new message to this object. Valid message type flags are Warning and Error. If the Message string is empty or zero-length no message is added.
Public method | AppendAdditionalMenuItems | Override this function if you want to add additional items to the object context menu. Default items already included in the menu toolstrip are: 1. Name 2. Preview 3. Warnings 4. Errors 5. [additional items will be inserted here] 6. Help
Public method | AppendMenuItems | This function is called when a context menu is about to be displayed. Override it to set custom items. GH_ActiveObject will already populate the menu with default items, if you merely wish to insert object-specific menu item, consider overriding AppendAdditionalMenuItems instead. (Overrides GH_DocumentObject..::..AppendMenuItems(ToolStripDropDown).)
Public method | ClearData | This function is called whenever the object needs to clear all solution data. Override this function if you need to perform custom clensing.
Public method | ClearRuntimeMessages | Destroy all warning and error lists
Public method | CollectData | This function is called whenever the object is required to collect all data. Either from Persistent records, from source params or whatever.
Public method | ComputeData | This function is called whenever the object is required to generate new data.
Public method | CopyFrom | Copy all fields (except the instance ID) from another instance description. (Inherited from GH_InstanceDescription.)
Public method | CreateAttributes | This function creates the stand-alone attributes for this object. If you wish to supply your own Attributes, you must override this function. (Inherited from GH_DocumentObject.)
Public method | DependsOn | Returns a boolean indicating whether or not the current object somehow inherits from the PotenialSource object
Protected method | DestroyIconCache | Call this method to erase the existing icon cache. You must call this if you want to change the display icon of an object. (Inherited from GH_DocumentObject.)
Public method | DocumentContextChanged | This method will be called when the document that owns this object moves into a different context. (Inherited from GH_DocumentObject.)
Protected method | ExpireDownStreamObjects | This function is called whenever the solution for this object expires. Override this function if objects depend on you.
Public method | ExpirePreview | Call this function when you suspect that the preview has expired for this object. This will cause the display cache to be eradicated. (Inherited from GH_DocumentObject.)
Public method | ExpireSolution | Informs the document that owns this object that the solution has expired. The current object will be set to BLANK as a result. This method is recursive, it will also expire any and all objects which depend on this object. If you want a less destructive expiration, consider using ClearData(). If this object is already Blank, you should consider not expiring it. (Overrides GH_DocumentObject..::..ExpireSolution(Boolean).)
Protected method | GetValue(String, Boolean) | Get a boolean value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Double) | Get a double value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Color) | Get a color value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Int32) | Get an integer value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, String) | Get a string value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | HtmlHelp_Source | Return a String which contains HTML formatted source for the help topic. If you want to pass a URL that points to a remote page, then prefix the URL with a GOTO: tag, like so: GOTO:http://www.YourWebAddressHere.com (Inherited from GH_DocumentObject.)
Public method | IsolateObject | Destroy all connections to other objects. (Inherited from GH_DocumentObject.)
Protected method | Menu_AppendBakeItem | Append the default Bake menu item.
Protected method | Menu_AppendEnableItem | Append the default Enable/Disable menu item.
Protected method | Menu_AppendObjectHelp | Appends the default object Help menu item. (Inherited from GH_DocumentObject.)
Protected method | Menu_AppendObjectName | Appends the old-fashioned object name menu item. If you also want the Display mode toggle then use Menu_AppendObjectNameEx() (Inherited from GH_DocumentObject.)
Protected method | Menu_AppendObjectNameEx | Appends the default object name + display mode menu item. (Inherited from GH_DocumentObject.)
Protected method | Menu_AppendPreviewItem | Append the default Show/Hide preview menu item.
Protected method | Menu_AppendRuntimeMessages | Append the default warnings and errors menu items.
Protected method | Menu_AppendWarningsAndErrors | Obsolete. This method is obsolete and has been replaced with Menu_AppendRuntimeMessages().
Public method | MovedBetweenDocuments | This method will be called when an object is moved from one document to another. Override this method if you want to handle such events. (Inherited from GH_DocumentObject.)
Public method | NewInstanceGuid()()()() | Generate a new random instance GUID (Inherited from GH_InstanceDescription.)
Public method | NewInstanceGuid(Guid) | Set the instance ID to be a specific GUID. This is very dangerous, only use this function if you're 6"4' and your first name is David. (Inherited from GH_InstanceDescription.)
Public method | OnAttributesChanged | Raises the AttributesChanged event on the toplevel object. (Inherited from GH_DocumentObject.)
Public method | OnDisplayExpired | Raises the DisplayExpired event on the toplevel object. (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(String) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectChangedEventArgs) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(String, Object) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType, Object) | (Inherited from GH_DocumentObject.)
Public method | OnPingDocument | Raise the PingDocument Event on the toplevel object and try to find the document which owns this object. (Inherited from GH_DocumentObject.)
Public method | OnPreviewExpired | Raises the PreviewExpired event on the toplevel object. (Inherited from GH_DocumentObject.)
Public method | OnSolutionExpired | Raises the SolutionExpired event on the toplevel object. You probably want to call ExpireSolution() instead of this method directly. (Inherited from GH_DocumentObject.)
Public method | Read | (Overrides GH_DocumentObject..::..Read(GH_IReader).)
Public method | ReadFull | GH_InstanceDescription does not by default serialize all fields. Use this function to read all fields from the archive. This method is compatible with the default Write()/Read() operations. (Inherited from GH_InstanceDescription.)
Public method | RecordUndoEvent(String) | Record a generic object change undo event. (Inherited from GH_DocumentObject.)
Public method | RecordUndoEvent(GH_UndoRecord) | Record an entire undo record. (Inherited from GH_DocumentObject.)
Public method | RecordUndoEvent(String, IGH_UndoAction) | Record a specific object change undo event. (Inherited from GH_DocumentObject.)
Public method | RegisterRemoteIDs | Override this function if you want object changes in the Rhino document to trigger a new solution.
Public method | RemovedFromDocument | This method will be called when an object is removed from a document. Override this method if you want to handle such events. (Inherited from GH_DocumentObject.)
Public method | RuntimeMessages | Gets the list of cached runtime messages that were recorded during solver-time processes.
Public method | SDKCompliancy | Test whether this object is compliant with a given Rhino version.
Public method | SetIconOverride | Set a new custom icon override for this object. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Boolean) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Double) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Color) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Int32) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, String) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave()()()() | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(Guid) | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger, Guid) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from GH_DocumentObject.)
Protected method | ValuesChanged | Override this method if you want to respond to changes to the value table. The base implementation is empty, so you don't have to call it. (Inherited from GH_DocumentObject.)
Public method | Write | (Overrides GH_DocumentObject..::..Write(GH_IWriter).)
Public method | WriteFull | GH_InstanceDescription does not by default serialize all fields. Use this function to write all fields to the archive. This method is compatible with the default Write()/Read() operations. (Inherited from GH_InstanceDescription.)

Fields

 | Name | Description
Protected field | m_attributes | (Inherited from GH_DocumentObject.)

Properties

 | Name | Description
Public property | Attributes | Gets or sets the attributes that are associated with this object. Only set custom attributes if you know what you are doing. (Inherited from GH_DocumentObject.)
Public property | Category | Gets or sets the Category in which this object belongs. If HasCategory() returns false, this field has no meaning. (Inherited from GH_InstanceDescription.)
Public property | ComponentGuid | Returns a consistent ID for this object type. Every object must supply a unique and unchanging ID that is used to identify objects of the same type. (Inherited from GH_DocumentObject.)
Public property | Description | Gets or sets the description of the object. This field typically remains fixed during the lifetime of an object. (Inherited from GH_InstanceDescription.)
Public property | Exposure | Gets the exposure of this object in the Graphical User Interface. The default is to expose everywhere. (Inherited from GH_DocumentObject.)
Public property | HasCategory | Gets whether or not the Category field has been set. (Inherited from GH_InstanceDescription.)
Public property | HasSubCategory | Gets whether or not the SubCategory field has been set. (Inherited from GH_InstanceDescription.)
Protected property | Icon | Override this function to supply a custom icon (24x24 pixels). The result of this property is cached, so don't worry if icon retrieval is not very fast. (Inherited from GH_DocumentObject.)
Public property | Icon_24x24 | The icon associated with this object. (Inherited from GH_DocumentObject.)
Public property | Icon_24x24_Locked | The greyscale icon of this object. (Inherited from GH_DocumentObject.)
Public property | IconCapableUI | By default the NickName menu item supports the Icon Mode override toggle. If your UI is not capable of displaying icons, then override this property and return False.
Public property | IconDisplayMode | Gets the current display mode of the object. (Inherited from GH_DocumentObject.)
Public property | InstanceDescription | Gets a description of the current state of the object. This field is usually the same as the Description() field, but it might be variable when overridden. (Inherited from GH_InstanceDescription.)
Public property | InstanceGuid | Gets the ID of this runtime instance. (Inherited from GH_InstanceDescription.)
Public property | IsDataProvider | Returns a boolean indicating whether or not the current object can seed data.
Public property | Keywords | Gets a list of additional keywords that describe the object. Typically this list is empty but you can override this property to aid in object searches. (Inherited from GH_InstanceDescription.)
Public property | Locked | Gets or sets the enabled flag of this object. Disabled objects are ignored during solutions.
Public property | MutableNickName | Gets or sets a value that enables Nick name changes through the menu. The default is TRUE.
Public property | Name | Gets or sets the name of the object. This field typically remains fixed during the lifetime of an object. (Inherited from GH_InstanceDescription.)
Public property | NickName | Gets or sets the nickname of the object. This field can be changed by the user. (Inherited from GH_InstanceDescription.)
Public property | Obsolete | Gets whether this object is obsolete. Default implementation returns true if the class name contains the string "OBSOLETE" or if this class has been decorated with the ObsoleteAttribute. You are free to override this if you want, but I suggest adding the ObsoleteAttribute instead. (Inherited from GH_DocumentObject.)
Public property | Phase | Gets or sets the solution phase this object is currenly in.
Public property | ProcessorTime | Gets the most recent processor time profiler value.
Public property | RuntimeMessageLevel | Returns the worst case flag for the current object If the object contains at least 1 error, the result is Error. If the object contains at least 1 warning, the result is Warning. If the object contains at least 1 message, the result is Remark. If the object contains no errors, no warnings and no messages, the result is Blank.
Public property | SubCategory | Gets or sets the SubCategory in which this object belongs. If HasSubCategory() returns false, this field has no meaning. (Inherited from GH_InstanceDescription.)

Events

 | Name | Description
Public event | AttributesChanged | Raised whenever the number or kind of attributes changes. This event is handled by GH_Documents who subsequently wipe their attribute caches. (Inherited from GH_DocumentObject.)
Public event | DisplayExpired | Raised whenever the display (on the Canvas) of a certain object becomes invalid. (Inherited from GH_DocumentObject.)
Public event | ObjectChanged | (Inherited from GH_DocumentObject.)
Public event | PingDocument | Raised whenever an object needs to know which GH_Document it belongs to. (Inherited from GH_DocumentObject.)
Public event | PreviewExpired | Raised whenever the display (in the Rhino viewports) of a certain object becomes invalid. (Inherited from GH_DocumentObject.)
Public event | SolutionExpired | Raised whenever the solution of a certain object becomes invalid. (Inherited from GH_DocumentObject.)

See Also

GH_ActiveObject Class
Grasshopper.Kernel Namespace


GH_ActiveObject Constructor

[image] [image]

Grasshopper SDK
GH_ActiveObject Constructor
GH_ActiveObject Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GH_ActiveObject(IGH_InstanceDescription) | Initializes a new instance of the GH_ActiveObject class
Protected method | GH_ActiveObject(String, String, String, String, String) | Initializes a new instance of the GH_ActiveObject class

See Also

GH_ActiveObject Class
GH_ActiveObject Members
Grasshopper.Kernel Namespace


GH_ActiveObject Constructor (IGH_InstanceDescription)

[image]

Grasshopper SDK
GH_ActiveObject Constructor (IGH_InstanceDescription)
GH_ActiveObject Class See Also Send Feedback
Initializes a new instance of the GH_ActiveObject class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_ActiveObject(
    IGH_InstanceDescription Tag
)
Visual Basic
Protected Sub New ( _
    Tag As IGH_InstanceDescription _
)

Parameters

Tag
Type: Grasshopper.Kernel..::..IGH_InstanceDescription

See Also

GH_ActiveObject Class
GH_ActiveObject Overload
Grasshopper.Kernel Namespace


GH_ActiveObject Constructor (String, String, String, String, String)

[image]

Grasshopper SDK
GH_ActiveObject Constructor (String, String, String, String, String)
GH_ActiveObject Class See Also Send Feedback
Initializes a new instance of the GH_ActiveObject class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_ActiveObject(
    string sName,
    string sAbbreviation,
    string sDescription,
    string sCategory,
    string sSubCategory
)
Visual Basic
Protected Sub New ( _
    sName As String, _
    sAbbreviation As String, _
    sDescription As String, _
    sCategory As String, _
    sSubCategory As String _
)

Parameters

sName
Type: System..::..String
sAbbreviation
Type: System..::..String
sDescription
Type: System..::..String
sCategory
Type: System..::..String
sSubCategory
Type: System..::..String

See Also

GH_ActiveObject Class
GH_ActiveObject Overload
Grasshopper.Kernel Namespace


GH_ActiveObject Fields

[image] [image]

Grasshopper SDK
GH_ActiveObject Fields
GH_ActiveObject Class See Also Send Feedback

The GH_ActiveObject type exposes the following members.

Fields

 | Name | Description
Protected field | m_attributes | (Inherited from GH_DocumentObject.)

See Also

GH_ActiveObject Class
Grasshopper.Kernel Namespace


GH_ActiveObject Methods

[image] [image]

Grasshopper SDK
GH_ActiveObject Methods
GH_ActiveObject Class See Also Send Feedback

The GH_ActiveObject type exposes the following members.

Methods

 | Name | Description
Public method | AddedToDocument | This method will be called when an object is added to a document. Override this method if you want to handle such events. (Inherited from GH_DocumentObject.)
Public method | AddRuntimeMessage | Add a new message to this object. Valid message type flags are Warning and Error. If the Message string is empty or zero-length no message is added.
Public method | AppendAdditionalMenuItems | Override this function if you want to add additional items to the object context menu. Default items already included in the menu toolstrip are: 1. Name 2. Preview 3. Warnings 4. Errors 5. [additional items will be inserted here] 6. Help
Public method | AppendMenuItems | This function is called when a context menu is about to be displayed. Override it to set custom items. GH_ActiveObject will already populate the menu with default items, if you merely wish to insert object-specific menu item, consider overriding AppendAdditionalMenuItems instead. (Overrides GH_DocumentObject..::..AppendMenuItems(ToolStripDropDown).)
Public method | ClearData | This function is called whenever the object needs to clear all solution data. Override this function if you need to perform custom clensing.
Public method | ClearRuntimeMessages | Destroy all warning and error lists
Public method | CollectData | This function is called whenever the object is required to collect all data. Either from Persistent records, from source params or whatever.
Public method | ComputeData | This function is called whenever the object is required to generate new data.
Public method | CopyFrom | Copy all fields (except the instance ID) from another instance description. (Inherited from GH_InstanceDescription.)
Public method | CreateAttributes | This function creates the stand-alone attributes for this object. If you wish to supply your own Attributes, you must override this function. (Inherited from GH_DocumentObject.)
Public method | DependsOn | Returns a boolean indicating whether or not the current object somehow inherits from the PotenialSource object
Protected method | DestroyIconCache | Call this method to erase the existing icon cache. You must call this if you want to change the display icon of an object. (Inherited from GH_DocumentObject.)
Public method | DocumentContextChanged | This method will be called when the document that owns this object moves into a different context. (Inherited from GH_DocumentObject.)
Protected method | ExpireDownStreamObjects | This function is called whenever the solution for this object expires. Override this function if objects depend on you.
Public method | ExpirePreview | Call this function when you suspect that the preview has expired for this object. This will cause the display cache to be eradicated. (Inherited from GH_DocumentObject.)
Public method | ExpireSolution | Informs the document that owns this object that the solution has expired. The current object will be set to BLANK as a result. This method is recursive, it will also expire any and all objects which depend on this object. If you want a less destructive expiration, consider using ClearData(). If this object is already Blank, you should consider not expiring it. (Overrides GH_DocumentObject..::..ExpireSolution(Boolean).)
Protected method | GetValue(String, Boolean) | Get a boolean value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Double) | Get a double value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Color) | Get a color value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Int32) | Get an integer value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, String) | Get a string value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | HtmlHelp_Source | Return a String which contains HTML formatted source for the help topic. If you want to pass a URL that points to a remote page, then prefix the URL with a GOTO: tag, like so: GOTO:http://www.YourWebAddressHere.com (Inherited from GH_DocumentObject.)
Public method | IsolateObject | Destroy all connections to other objects. (Inherited from GH_DocumentObject.)
Protected method | Menu_AppendBakeItem | Append the default Bake menu item.
Protected method | Menu_AppendEnableItem | Append the default Enable/Disable menu item.
Protected method | Menu_AppendObjectHelp | Appends the default object Help menu item. (Inherited from GH_DocumentObject.)
Protected method | Menu_AppendObjectName | Appends the old-fashioned object name menu item. If you also want the Display mode toggle then use Menu_AppendObjectNameEx() (Inherited from GH_DocumentObject.)
Protected method | Menu_AppendObjectNameEx | Appends the default object name + display mode menu item. (Inherited from GH_DocumentObject.)
Protected method | Menu_AppendPreviewItem | Append the default Show/Hide preview menu item.
Protected method | Menu_AppendRuntimeMessages | Append the default warnings and errors menu items.
Protected method | Menu_AppendWarningsAndErrors | Obsolete. This method is obsolete and has been replaced with Menu_AppendRuntimeMessages().
Public method | MovedBetweenDocuments | This method will be called when an object is moved from one document to another. Override this method if you want to handle such events. (Inherited from GH_DocumentObject.)
Public method | NewInstanceGuid()()()() | Generate a new random instance GUID (Inherited from GH_InstanceDescription.)
Public method | NewInstanceGuid(Guid) | Set the instance ID to be a specific GUID. This is very dangerous, only use this function if you're 6"4' and your first name is David. (Inherited from GH_InstanceDescription.)
Public method | OnAttributesChanged | Raises the AttributesChanged event on the toplevel object. (Inherited from GH_DocumentObject.)
Public method | OnDisplayExpired | Raises the DisplayExpired event on the toplevel object. (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(String) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectChangedEventArgs) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(String, Object) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType, Object) | (Inherited from GH_DocumentObject.)
Public method | OnPingDocument | Raise the PingDocument Event on the toplevel object and try to find the document which owns this object. (Inherited from GH_DocumentObject.)
Public method | OnPreviewExpired | Raises the PreviewExpired event on the toplevel object. (Inherited from GH_DocumentObject.)
Public method | OnSolutionExpired | Raises the SolutionExpired event on the toplevel object. You probably want to call ExpireSolution() instead of this method directly. (Inherited from GH_DocumentObject.)
Public method | Read | (Overrides GH_DocumentObject..::..Read(GH_IReader).)
Public method | ReadFull | GH_InstanceDescription does not by default serialize all fields. Use this function to read all fields from the archive. This method is compatible with the default Write()/Read() operations. (Inherited from GH_InstanceDescription.)
Public method | RecordUndoEvent(String) | Record a generic object change undo event. (Inherited from GH_DocumentObject.)
Public method | RecordUndoEvent(GH_UndoRecord) | Record an entire undo record. (Inherited from GH_DocumentObject.)
Public method | RecordUndoEvent(String, IGH_UndoAction) | Record a specific object change undo event. (Inherited from GH_DocumentObject.)
Public method | RegisterRemoteIDs | Override this function if you want object changes in the Rhino document to trigger a new solution.
Public method | RemovedFromDocument | This method will be called when an object is removed from a document. Override this method if you want to handle such events. (Inherited from GH_DocumentObject.)
Public method | RuntimeMessages | Gets the list of cached runtime messages that were recorded during solver-time processes.
Public method | SDKCompliancy | Test whether this object is compliant with a given Rhino version.
Public method | SetIconOverride | Set a new custom icon override for this object. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Boolean) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Double) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Color) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Int32) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, String) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave()()()() | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(Guid) | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger, Guid) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from GH_DocumentObject.)
Protected method | ValuesChanged | Override this method if you want to respond to changes to the value table. The base implementation is empty, so you don't have to call it. (Inherited from GH_DocumentObject.)
Public method | Write | (Overrides GH_DocumentObject..::..Write(GH_IWriter).)
Public method | WriteFull | GH_InstanceDescription does not by default serialize all fields. Use this function to write all fields to the archive. This method is compatible with the default Write()/Read() operations. (Inherited from GH_InstanceDescription.)

See Also

GH_ActiveObject Class
Grasshopper.Kernel Namespace


AddRuntimeMessage Method

[image]

Grasshopper SDK
GH_ActiveObject..::..AddRuntimeMessage Method
GH_ActiveObject Class See Also Send Feedback
Add a new message to this object. Valid message type flags are Warning and Error. If the Message string is empty or zero-length no message is added.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual void AddRuntimeMessage(
    GH_RuntimeMessageLevel level,
    string text
)
Visual Basic
Public Overridable Sub AddRuntimeMessage ( _
    level As GH_RuntimeMessageLevel, _
    text As String _
)

Parameters

level
Type: Grasshopper.Kernel..::..GH_RuntimeMessageLevel
Type of message. Only Warnings and Errors are recorded.
text
Type: System..::..String
Content of message.

Implements

IGH_ActiveObject..::..AddRuntimeMessage(GH_RuntimeMessageLevel, String)

See Also

GH_ActiveObject Class
Grasshopper.Kernel Namespace


AppendAdditionalMenuItems Method

[image]

Grasshopper SDK
GH_ActiveObject..::..AppendAdditionalMenuItems Method
GH_ActiveObject Class See Also Send Feedback
Override this function if you want to add additional items to the object context menu. Default items already included in the menu toolstrip are:

1. Name

2. Preview

3. Warnings

4. Errors

5. [additional items will be inserted here]

6. Help

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual void AppendAdditionalMenuItems(
    ToolStripDropDown menu
)
Visual Basic
Public Overridable Sub AppendAdditionalMenuItems ( _
    menu As ToolStripDropDown _
)

Parameters

menu
Type: System.Windows.Forms..::..ToolStripDropDown

See Also

GH_ActiveObject Class
Grasshopper.Kernel Namespace


AppendMenuItems Method

[image]

Grasshopper SDK
GH_ActiveObject..::..AppendMenuItems Method
GH_ActiveObject Class See Also Send Feedback
This function is called when a context menu is about to be displayed. Override it to set custom items. GH_ActiveObject will already populate the menu with default items, if you merely wish to insert object-specific menu item, consider overriding AppendAdditionalMenuItems instead.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool AppendMenuItems(
    ToolStripDropDown menu
)
Visual Basic
Public Overrides Function AppendMenuItems ( _
    menu As ToolStripDropDown _
) As Boolean

Parameters

menu
Type: System.Windows.Forms..::..ToolStripDropDown
Menu object to populate.

Return Value

If true, the menu will be displayed, if false the menu will be supressed.

See Also

GH_ActiveObject Class
Grasshopper.Kernel Namespace


ClearData Method

[image]

Grasshopper SDK
GH_ActiveObject..::..ClearData Method
GH_ActiveObject Class See Also Send Feedback
This function is called whenever the object needs to clear all solution data. Override this function if you need to perform custom clensing.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual void ClearData()
Visual Basic
Public Overridable Sub ClearData

Implements

IGH_ActiveObject..::..ClearData()()()()

See Also

GH_ActiveObject Class
Grasshopper.Kernel Namespace


ClearRuntimeMessages Method

[image]

Grasshopper SDK
GH_ActiveObject..::..ClearRuntimeMessages Method
GH_ActiveObject Class See Also Send Feedback
Destroy all warning and error lists

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual void ClearRuntimeMessages()
Visual Basic
Public Overridable Sub ClearRuntimeMessages

Implements

IGH_ActiveObject..::..ClearRuntimeMessages()()()()

See Also

GH_ActiveObject Class
Grasshopper.Kernel Namespace


CollectData Method

[image]

Grasshopper SDK
GH_ActiveObject..::..CollectData Method
GH_ActiveObject Class See Also Send Feedback
This function is called whenever the object is required to collect all data. Either from Persistent records, from source params or whatever.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual void CollectData()
Visual Basic
Public Overridable Sub CollectData

Implements

IGH_ActiveObject..::..CollectData()()()()

See Also

GH_ActiveObject Class
Grasshopper.Kernel Namespace


ComputeData Method

[image]

Grasshopper SDK
GH_ActiveObject..::..ComputeData Method
GH_ActiveObject Class See Also Send Feedback
This function is called whenever the object is required to generate new data.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual void ComputeData()
Visual Basic
Public Overridable Sub ComputeData

Implements

IGH_ActiveObject..::..ComputeData()()()()

See Also

GH_ActiveObject Class
Grasshopper.Kernel Namespace


DependsOn Method

[image]

Grasshopper SDK
GH_ActiveObject..::..DependsOn Method
GH_ActiveObject Class See Also Send Feedback
Returns a boolean indicating whether or not the current object somehow inherits from the PotenialSource object

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract bool DependsOn(
    IGH_ActiveObject PotentialSource
)
Visual Basic
Public MustOverride Function DependsOn ( _
    PotentialSource As IGH_ActiveObject _
) As Boolean

Parameters

PotentialSource
Type: Grasshopper.Kernel..::..IGH_ActiveObject

Return Value

Implements

IGH_ActiveObject..::..DependsOn(IGH_ActiveObject)

See Also

GH_ActiveObject Class
Grasshopper.Kernel Namespace


ExpireDownStreamObjects Method

[image]

Grasshopper SDK
GH_ActiveObject..::..ExpireDownStreamObjects Method
GH_ActiveObject Class See Also Send Feedback
This function is called whenever the solution for this object expires. Override this function if objects depend on you.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected virtual void ExpireDownStreamObjects()
Visual Basic
Protected Overridable Sub ExpireDownStreamObjects

See Also

GH_ActiveObject Class
Grasshopper.Kernel Namespace


ExpireSolution Method

[image]

Grasshopper SDK
GH_ActiveObject..::..ExpireSolution Method
GH_ActiveObject Class See Also Send Feedback
Informs the document that owns this object that the solution has expired. The current object will be set to BLANK as a result. This method is recursive, it will also expire any and all objects which depend on this object. If you want a less destructive expiration, consider using ClearData(). If this object is already Blank, you should consider not expiring it.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void ExpireSolution(
    bool recompute
)
Visual Basic
Public Overrides Sub ExpireSolution ( _
    recompute As Boolean _
)

Parameters

recompute
Type: System..::..Boolean
If True, the document will be instructed to solve the new state.

See Also

GH_ActiveObject Class
Grasshopper.Kernel Namespace


GetValue Method

[image] [image]

Grasshopper SDK
GH_ActiveObject..::..GetValue Method
GH_ActiveObject Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetValue(String, Boolean) | Get a boolean value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Double) | Get a double value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Color) | Get a color value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Int32) | Get an integer value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, String) | Get a string value from the component value table. (Inherited from GH_DocumentObject.)

See Also

GH_ActiveObject Class
GH_ActiveObject Members
Grasshopper.Kernel Namespace


Menu_AppendBakeItem Method

[image]

Grasshopper SDK
GH_ActiveObject..::..Menu_AppendBakeItem Method
GH_ActiveObject Class See Also Send Feedback
Append the default Bake menu item.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected void Menu_AppendBakeItem(
    ToolStripDropDown menu
)
Visual Basic
Protected Sub Menu_AppendBakeItem ( _
    menu As ToolStripDropDown _
)

Parameters

menu
Type: System.Windows.Forms..::..ToolStripDropDown

See Also

GH_ActiveObject Class
Grasshopper.Kernel Namespace


Menu_AppendEnableItem Method

[image]

Grasshopper SDK
GH_ActiveObject..::..Menu_AppendEnableItem Method
GH_ActiveObject Class See Also Send Feedback
Append the default Enable/Disable menu item.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected void Menu_AppendEnableItem(
    ToolStripDropDown menu
)
Visual Basic
Protected Sub Menu_AppendEnableItem ( _
    menu As ToolStripDropDown _
)

Parameters

menu
Type: System.Windows.Forms..::..ToolStripDropDown

See Also

GH_ActiveObject Class
Grasshopper.Kernel Namespace


Menu_AppendPreviewItem Method

[image]

Grasshopper SDK
GH_ActiveObject..::..Menu_AppendPreviewItem Method
GH_ActiveObject Class See Also Send Feedback
Append the default Show/Hide preview menu item.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected void Menu_AppendPreviewItem(
    ToolStripDropDown menu
)
Visual Basic
Protected Sub Menu_AppendPreviewItem ( _
    menu As ToolStripDropDown _
)

Parameters

menu
Type: System.Windows.Forms..::..ToolStripDropDown

See Also

GH_ActiveObject Class
Grasshopper.Kernel Namespace


Menu_AppendRuntimeMessages Method

[image]

Grasshopper SDK
GH_ActiveObject..::..Menu_AppendRuntimeMessages Method
GH_ActiveObject Class See Also Send Feedback
Append the default warnings and errors menu items.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected void Menu_AppendRuntimeMessages(
    ToolStripDropDown menu
)
Visual Basic
Protected Sub Menu_AppendRuntimeMessages ( _
    menu As ToolStripDropDown _
)

Parameters

menu
Type: System.Windows.Forms..::..ToolStripDropDown

See Also

GH_ActiveObject Class
Grasshopper.Kernel Namespace


Menu_AppendWarningsAndErrors Method

[image]

Grasshopper SDK
GH_ActiveObject..::..Menu_AppendWarningsAndErrors Method
GH_ActiveObject Class See Also Send Feedback
This method is obsolete and has been replaced with Menu_AppendRuntimeMessages().

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
[ObsoleteAttribute("This method has been replaced by Menu_AppendRuntimeMessages()")]
protected void Menu_AppendWarningsAndErrors(
    ToolStripDropDown menu
)
Visual Basic
<ObsoleteAttribute("This method has been replaced by Menu_AppendRuntimeMessages()")> _
Protected Sub Menu_AppendWarningsAndErrors ( _
    menu As ToolStripDropDown _
)

Parameters

menu
Type: System.Windows.Forms..::..ToolStripDropDown

See Also

GH_ActiveObject Class
Grasshopper.Kernel Namespace


NewInstanceGuid Method

[image] [image]

Grasshopper SDK
GH_ActiveObject..::..NewInstanceGuid Method
GH_ActiveObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NewInstanceGuid()()()() | Generate a new random instance GUID (Inherited from GH_InstanceDescription.)
Public method | NewInstanceGuid(Guid) | Set the instance ID to be a specific GUID. This is very dangerous, only use this function if you're 6"4' and your first name is David. (Inherited from GH_InstanceDescription.)

See Also

GH_ActiveObject Class
GH_ActiveObject Members
Grasshopper.Kernel Namespace


OnObjectChanged Method

[image] [image]

Grasshopper SDK
GH_ActiveObject..::..OnObjectChanged Method
GH_ActiveObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OnObjectChanged(String) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectChangedEventArgs) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(String, Object) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType, Object) | (Inherited from GH_DocumentObject.)

See Also

GH_ActiveObject Class
GH_ActiveObject Members
Grasshopper.Kernel Namespace


Read Method

[image]

Grasshopper SDK
GH_ActiveObject..::..Read Method
GH_ActiveObject Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

See Also

GH_ActiveObject Class
Grasshopper.Kernel Namespace


RecordUndoEvent Method

[image] [image]

Grasshopper SDK
GH_ActiveObject..::..RecordUndoEvent Method
GH_ActiveObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RecordUndoEvent(String) | Record a generic object change undo event. (Inherited from GH_DocumentObject.)
Public method | RecordUndoEvent(GH_UndoRecord) | Record an entire undo record. (Inherited from GH_DocumentObject.)
Public method | RecordUndoEvent(String, IGH_UndoAction) | Record a specific object change undo event. (Inherited from GH_DocumentObject.)

See Also

GH_ActiveObject Class
GH_ActiveObject Members
Grasshopper.Kernel Namespace


RegisterRemoteIDs Method

[image]

Grasshopper SDK
GH_ActiveObject..::..RegisterRemoteIDs Method
GH_ActiveObject Class See Also Send Feedback
Override this function if you want object changes in the Rhino document to trigger a new solution.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual void RegisterRemoteIDs(
    GH_GuidTable id_list
)
Visual Basic
Public Overridable Sub RegisterRemoteIDs ( _
    id_list As GH_GuidTable _
)

Parameters

id_list
Type: GH_GuidTable
The object ID database Grasshopper is responsive to.

Implements

IGH_ActiveObject..::..RegisterRemoteIDs(GH_GuidTable)

See Also

GH_ActiveObject Class
Grasshopper.Kernel Namespace


RuntimeMessages Method

[image]

Grasshopper SDK
GH_ActiveObject..::..RuntimeMessages Method
GH_ActiveObject Class See Also Send Feedback
Gets the list of cached runtime messages that were recorded during solver-time processes.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual IList<string> RuntimeMessages(
    GH_RuntimeMessageLevel level
)
Visual Basic
Public Overridable Function RuntimeMessages ( _
    level As GH_RuntimeMessageLevel _
) As IList(Of String)

Parameters

level
Type: Grasshopper.Kernel..::..GH_RuntimeMessageLevel
Runtime message type to retrieve.

Return Value

A list of runtime message strings.

Implements

IGH_ActiveObject..::..RuntimeMessages(GH_RuntimeMessageLevel)

See Also

GH_ActiveObject Class
Grasshopper.Kernel Namespace


SDKCompliancy Method

[image]

Grasshopper SDK
GH_ActiveObject..::..SDKCompliancy Method
GH_ActiveObject Class See Also Send Feedback
Test whether this object is compliant with a given Rhino version.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool SDKCompliancy(
    int exeVersion,
    int exeServiceRelease
)
Visual Basic
Public Overridable Function SDKCompliancy ( _
    exeVersion As Integer, _
    exeServiceRelease As Integer _
) As Boolean

Parameters

exeVersion
Type: System..::..Int32
Rhino major release (4, 5, ...).
exeServiceRelease
Type: System..::..Int32
Rhino minor (service) release.

Return Value

True if this object is compliant with the given Rhino release.

Implements

IGH_ActiveObject..::..SDKCompliancy(Int32, Int32)

See Also

GH_ActiveObject Class
Grasshopper.Kernel Namespace


SetValue Method

[image] [image]

Grasshopper SDK
GH_ActiveObject..::..SetValue Method
GH_ActiveObject Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SetValue(String, Boolean) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Double) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Color) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Int32) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, String) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)

See Also

GH_ActiveObject Class
GH_ActiveObject Members
Grasshopper.Kernel Namespace


TriggerAutoSave Method

[image] [image]

Grasshopper SDK
GH_ActiveObject..::..TriggerAutoSave Method
GH_ActiveObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TriggerAutoSave()()()() | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(Guid) | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger, Guid) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from GH_DocumentObject.)

See Also

GH_ActiveObject Class
GH_ActiveObject Members
Grasshopper.Kernel Namespace


Write Method

[image]

Grasshopper SDK
GH_ActiveObject..::..Write Method
GH_ActiveObject Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overrides Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

See Also

GH_ActiveObject Class
Grasshopper.Kernel Namespace


GH_ActiveObject Properties

[image] [image]

Grasshopper SDK
GH_ActiveObject Properties
GH_ActiveObject Class See Also Send Feedback

The GH_ActiveObject type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Gets or sets the attributes that are associated with this object. Only set custom attributes if you know what you are doing. (Inherited from GH_DocumentObject.)
Public property | Category | Gets or sets the Category in which this object belongs. If HasCategory() returns false, this field has no meaning. (Inherited from GH_InstanceDescription.)
Public property | ComponentGuid | Returns a consistent ID for this object type. Every object must supply a unique and unchanging ID that is used to identify objects of the same type. (Inherited from GH_DocumentObject.)
Public property | Description | Gets or sets the description of the object. This field typically remains fixed during the lifetime of an object. (Inherited from GH_InstanceDescription.)
Public property | Exposure | Gets the exposure of this object in the Graphical User Interface. The default is to expose everywhere. (Inherited from GH_DocumentObject.)
Public property | HasCategory | Gets whether or not the Category field has been set. (Inherited from GH_InstanceDescription.)
Public property | HasSubCategory | Gets whether or not the SubCategory field has been set. (Inherited from GH_InstanceDescription.)
Protected property | Icon | Override this function to supply a custom icon (24x24 pixels). The result of this property is cached, so don't worry if icon retrieval is not very fast. (Inherited from GH_DocumentObject.)
Public property | Icon_24x24 | The icon associated with this object. (Inherited from GH_DocumentObject.)
Public property | Icon_24x24_Locked | The greyscale icon of this object. (Inherited from GH_DocumentObject.)
Public property | IconCapableUI | By default the NickName menu item supports the Icon Mode override toggle. If your UI is not capable of displaying icons, then override this property and return False.
Public property | IconDisplayMode | Gets the current display mode of the object. (Inherited from GH_DocumentObject.)
Public property | InstanceDescription | Gets a description of the current state of the object. This field is usually the same as the Description() field, but it might be variable when overridden. (Inherited from GH_InstanceDescription.)
Public property | InstanceGuid | Gets the ID of this runtime instance. (Inherited from GH_InstanceDescription.)
Public property | IsDataProvider | Returns a boolean indicating whether or not the current object can seed data.
Public property | Keywords | Gets a list of additional keywords that describe the object. Typically this list is empty but you can override this property to aid in object searches. (Inherited from GH_InstanceDescription.)
Public property | Locked | Gets or sets the enabled flag of this object. Disabled objects are ignored during solutions.
Public property | MutableNickName | Gets or sets a value that enables Nick name changes through the menu. The default is TRUE.
Public property | Name | Gets or sets the name of the object. This field typically remains fixed during the lifetime of an object. (Inherited from GH_InstanceDescription.)
Public property | NickName | Gets or sets the nickname of the object. This field can be changed by the user. (Inherited from GH_InstanceDescription.)
Public property | Obsolete | Gets whether this object is obsolete. Default implementation returns true if the class name contains the string "OBSOLETE" or if this class has been decorated with the ObsoleteAttribute. You are free to override this if you want, but I suggest adding the ObsoleteAttribute instead. (Inherited from GH_DocumentObject.)
Public property | Phase | Gets or sets the solution phase this object is currenly in.
Public property | ProcessorTime | Gets the most recent processor time profiler value.
Public property | RuntimeMessageLevel | Returns the worst case flag for the current object If the object contains at least 1 error, the result is Error. If the object contains at least 1 warning, the result is Warning. If the object contains at least 1 message, the result is Remark. If the object contains no errors, no warnings and no messages, the result is Blank.
Public property | SubCategory | Gets or sets the SubCategory in which this object belongs. If HasSubCategory() returns false, this field has no meaning. (Inherited from GH_InstanceDescription.)

See Also

GH_ActiveObject Class
Grasshopper.Kernel Namespace


IconCapableUI Property

[image]

Grasshopper SDK
GH_ActiveObject..::..IconCapableUI Property
GH_ActiveObject Class See Also Send Feedback
By default the NickName menu item supports the Icon Mode override toggle. If your UI is not capable of displaying icons, then override this property and return False.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool IconCapableUI { get; }
Visual Basic
Public Overridable ReadOnly Property IconCapableUI As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ActiveObject.IconCapableUI"]

See Also

GH_ActiveObject Class
Grasshopper.Kernel Namespace


IsDataProvider Property

[image]

Grasshopper SDK
GH_ActiveObject..::..IsDataProvider Property
GH_ActiveObject Class See Also Send Feedback
Returns a boolean indicating whether or not the current object can seed data.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract bool IsDataProvider { get; }
Visual Basic
Public MustOverride ReadOnly Property IsDataProvider As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ActiveObject.IsDataProvider"]

Implements

IGH_ActiveObject..::..IsDataProvider

See Also

GH_ActiveObject Class
Grasshopper.Kernel Namespace


Locked Property

[image]

Grasshopper SDK
GH_ActiveObject..::..Locked Property
GH_ActiveObject Class See Also Send Feedback
Gets or sets the enabled flag of this object. Disabled objects are ignored during solutions.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool Locked { get; set; }
Visual Basic
Public Overridable Property Locked As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ActiveObject.Locked"]

Implements

IGH_ActiveObject..::..Locked

See Also

GH_ActiveObject Class
Grasshopper.Kernel Namespace


MutableNickName Property

[image]

Grasshopper SDK
GH_ActiveObject..::..MutableNickName Property
GH_ActiveObject Class See Also Send Feedback
Gets or sets a value that enables Nick name changes through the menu. The default is TRUE.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool MutableNickName { get; set; }
Visual Basic
Public Property MutableNickName As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ActiveObject.MutableNickName"]

Implements

IGH_ActiveObject..::..MutableNickName

See Also

GH_ActiveObject Class
Grasshopper.Kernel Namespace


Phase Property

[image]

Grasshopper SDK
GH_ActiveObject..::..Phase Property
GH_ActiveObject Class See Also Send Feedback
Gets or sets the solution phase this object is currenly in.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_SolutionPhase Phase { get; set; }
Visual Basic
Public Property Phase As GH_SolutionPhase
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ActiveObject.Phase"]

Implements

IGH_ActiveObject..::..Phase

See Also

GH_ActiveObject Class
Grasshopper.Kernel Namespace


ProcessorTime Property

[image]

Grasshopper SDK
GH_ActiveObject..::..ProcessorTime Property
GH_ActiveObject Class See Also Send Feedback
Gets the most recent processor time profiler value.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual TimeSpan ProcessorTime { get; }
Visual Basic
Public Overridable ReadOnly Property ProcessorTime As TimeSpan
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ActiveObject.ProcessorTime"]

Implements

IGH_ActiveObject..::..ProcessorTime

See Also

GH_ActiveObject Class
Grasshopper.Kernel Namespace


RuntimeMessageLevel Property

[image]

Grasshopper SDK
GH_ActiveObject..::..RuntimeMessageLevel Property
GH_ActiveObject Class See Also Send Feedback
Returns the worst case flag for the current object

If the object contains at least 1 error, the result is Error.

If the object contains at least 1 warning, the result is Warning.

If the object contains at least 1 message, the result is Remark.

If the object contains no errors, no warnings and no messages, the result is Blank.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual GH_RuntimeMessageLevel RuntimeMessageLevel { get; }
Visual Basic
Public Overridable ReadOnly Property RuntimeMessageLevel As GH_RuntimeMessageLevel
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ActiveObject.RuntimeMessageLevel"]

Implements

IGH_ActiveObject..::..RuntimeMessageLevel

See Also

GH_ActiveObject Class
Grasshopper.Kernel Namespace


GH_ActiveObject Events

[image] [image]

Grasshopper SDK
GH_ActiveObject Events
GH_ActiveObject Class See Also Send Feedback

The GH_ActiveObject type exposes the following members.

Events

 | Name | Description
Public event | AttributesChanged | Raised whenever the number or kind of attributes changes. This event is handled by GH_Documents who subsequently wipe their attribute caches. (Inherited from GH_DocumentObject.)
Public event | DisplayExpired | Raised whenever the display (on the Canvas) of a certain object becomes invalid. (Inherited from GH_DocumentObject.)
Public event | ObjectChanged | (Inherited from GH_DocumentObject.)
Public event | PingDocument | Raised whenever an object needs to know which GH_Document it belongs to. (Inherited from GH_DocumentObject.)
Public event | PreviewExpired | Raised whenever the display (in the Rhino viewports) of a certain object becomes invalid. (Inherited from GH_DocumentObject.)
Public event | SolutionExpired | Raised whenever the solution of a certain object becomes invalid. (Inherited from GH_DocumentObject.)

See Also

GH_ActiveObject Class
Grasshopper.Kernel Namespace


GH_Alias Class

[image]

Grasshopper SDK
GH_Alias Class
Members See Also Send Feedback
Represents a single alias|target combo.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Alias : IComparable<GH_Alias>
Visual Basic
Public Class GH_Alias _
    Implements IComparable(Of GH_Alias)

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_Alias

See Also

GH_Alias Members
Grasshopper.Kernel Namespace


GH_Alias Members

[image] [image]

Grasshopper SDK
GH_Alias Members
GH_Alias Class Constructors Methods Properties See Also Send Feedback

The GH_Alias type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Alias()()()() | Initializes a new instance of the GH_Alias class
Public method | GH_Alias(GH_Alias) | Initializes a new instance of the GH_Alias class
Public method | GH_Alias(String, Guid) | Initializes a new instance of the GH_Alias class

Methods

 | Name | Description
 | AliasToString |
Public method | CompareTo |
 | StringToAlias |

Properties

 | Name | Description
Public property | Alias | Gets or sets the alias string.
Public property | Target | Gets or sets the alias target.

See Also

GH_Alias Class
Grasshopper.Kernel Namespace


GH_Alias Constructor

[image] [image]

Grasshopper SDK
GH_Alias Constructor
GH_Alias Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Alias()()()() | Initializes a new instance of the GH_Alias class
Public method | GH_Alias(GH_Alias) | Initializes a new instance of the GH_Alias class
Public method | GH_Alias(String, Guid) | Initializes a new instance of the GH_Alias class

See Also

GH_Alias Class
GH_Alias Members
Grasshopper.Kernel Namespace


GH_Alias Constructor

[image]

Grasshopper SDK
GH_Alias Constructor
GH_Alias Class See Also Send Feedback
Initializes a new instance of the GH_Alias class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Alias()
Visual Basic
Public Sub New

See Also

GH_Alias Class
GH_Alias Overload
Grasshopper.Kernel Namespace


GH_Alias Constructor (GH_Alias)

[image]

Grasshopper SDK
GH_Alias Constructor (GH_Alias)
GH_Alias Class See Also Send Feedback
Initializes a new instance of the GH_Alias class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Alias(
    GH_Alias other
)
Visual Basic
Public Sub New ( _
    other As GH_Alias _
)

Parameters

other
Type: Grasshopper.Kernel..::..GH_Alias

See Also

GH_Alias Class
GH_Alias Overload
Grasshopper.Kernel Namespace


GH_Alias Constructor (String, Guid)

[image]

Grasshopper SDK
GH_Alias Constructor (String, Guid)
GH_Alias Class See Also Send Feedback
Initializes a new instance of the GH_Alias class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Alias(
    string alias,
    Guid target
)
Visual Basic
Public Sub New ( _
    alias As String, _
    target As Guid _
)

Parameters

alias
Type: System..::..String
target
Type: System..::..Guid

See Also

GH_Alias Class
GH_Alias Overload
Grasshopper.Kernel Namespace


GH_Alias Methods

[image] [image]

Grasshopper SDK
GH_Alias Methods
GH_Alias Class See Also Send Feedback

The GH_Alias type exposes the following members.

Methods

 | Name | Description
 | AliasToString |
Public method | CompareTo |
 | StringToAlias |

See Also

GH_Alias Class
Grasshopper.Kernel Namespace


AliasToString Method

[image]

Grasshopper SDK
GH_Alias..::..AliasToString Method
GH_Alias Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string AliasToString(
    IEnumerable<string> aliases
)
Visual Basic
Public Shared Function AliasToString ( _
    aliases As IEnumerable(Of String) _
) As String

Parameters

aliases
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' String >)>)>

See Also

GH_Alias Class
Grasshopper.Kernel Namespace


CompareTo Method

[image]

Grasshopper SDK
GH_Alias..::..CompareTo Method
GH_Alias Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int CompareTo(
    GH_Alias other
)
Visual Basic
Public Function CompareTo ( _
    other As GH_Alias _
) As Integer

Parameters

other
Type: Grasshopper.Kernel..::..GH_Alias

Implements

IComparable<(Of <(<'T>)>)>..::..CompareTo(T)

See Also

GH_Alias Class
Grasshopper.Kernel Namespace


StringToAlias Method

[image]

Grasshopper SDK
GH_Alias..::..StringToAlias Method
GH_Alias Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string[] StringToAlias(
    string text
)
Visual Basic
Public Shared Function StringToAlias ( _
    text As String _
) As String()

Parameters

text
Type: System..::..String

See Also

GH_Alias Class
Grasshopper.Kernel Namespace


GH_Alias Properties

[image] [image]

Grasshopper SDK
GH_Alias Properties
GH_Alias Class See Also Send Feedback

The GH_Alias type exposes the following members.

Properties

 | Name | Description
Public property | Alias | Gets or sets the alias string.
Public property | Target | Gets or sets the alias target.

See Also

GH_Alias Class
Grasshopper.Kernel Namespace


Alias Property

[image]

Grasshopper SDK
GH_Alias..::..Alias Property
GH_Alias Class See Also Send Feedback
Gets or sets the alias string.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Alias { get; set; }
Visual Basic
Public Property Alias As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Alias.Alias"]

See Also

GH_Alias Class
Grasshopper.Kernel Namespace


Target Property

[image]

Grasshopper SDK
GH_Alias..::..Target Property
GH_Alias Class See Also Send Feedback
Gets or sets the alias target.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid Target { get; set; }
Visual Basic
Public Property Target As Guid
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Alias.Target"]

See Also

GH_Alias Class
Grasshopper.Kernel Namespace


GH_Arrange Enumeration

[image]

Grasshopper SDK
GH_Arrange Enumeration
See Also Send Feedback
Enumerates possible types of object arrangement.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_Arrange
Visual Basic
Public Enumeration GH_Arrange

Members

Member name | Value | Description
MoveToFront | 0 | Put the objects on the top of the stack.
MoveForwards | 1 | Objects are inserted above the first occluding object.
MoveToBack | 2 | Put the objects on the bottom of the stack.
MoveBackwards | 3 | Objects are inserted below the first occluded object.

See Also

Grasshopper.Kernel Namespace


GH_AssemblyFolderInfo Structure

[image]

Grasshopper SDK
GH_AssemblyFolderInfo Structure
Members See Also Send Feedback
Represents a folder from which GHA files are loaded.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public struct GH_AssemblyFolderInfo
Visual Basic
Public Structure GH_AssemblyFolderInfo

See Also

GH_AssemblyFolderInfo Members
Grasshopper.Kernel Namespace


GH_AssemblyFolderInfo Members

[image] [image]

Grasshopper SDK
GH_AssemblyFolderInfo Members
GH_AssemblyFolderInfo Structure Constructors Methods Fields Properties See Also Send Feedback

The GH_AssemblyFolderInfo type exposes the following members.

Constructors

 | Name | Description
Public method | GH_AssemblyFolderInfo | Initializes a new instance of the GH_AssemblyFolderInfo class

Methods

 | Name | Description
Public method | ToString | (Overrides ValueType..::..ToString()()()().)

Fields

 | Name | Description
Public field | Folder | The actual full path to the folder.
Public field | Type | Identifies the type of assembly folder.

Properties

 | Name | Description
Public property | SearchOption | Gets the search option to use when looking for GHA files in this folder.

See Also

GH_AssemblyFolderInfo Structure
Grasshopper.Kernel Namespace


GH_AssemblyFolderInfo Constructor

[image]

Grasshopper SDK
GH_AssemblyFolderInfo Constructor
GH_AssemblyFolderInfo Structure See Also Send Feedback
Initializes a new instance of the GH_AssemblyFolderInfo class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_AssemblyFolderInfo(
    string folder,
    GH_PluginFolderType type
)
Visual Basic
Public Sub New ( _
    folder As String, _
    type As GH_PluginFolderType _
)

Parameters

folder
Type: System..::..String
type
Type: Grasshopper.Kernel..::..GH_PluginFolderType

See Also

GH_AssemblyFolderInfo Structure
Grasshopper.Kernel Namespace


GH_AssemblyFolderInfo Fields

[image] [image]

Grasshopper SDK
GH_AssemblyFolderInfo Fields
GH_AssemblyFolderInfo Structure See Also Send Feedback

The GH_AssemblyFolderInfo type exposes the following members.

Fields

 | Name | Description
Public field | Folder | The actual full path to the folder.
Public field | Type | Identifies the type of assembly folder.

See Also

GH_AssemblyFolderInfo Structure
Grasshopper.Kernel Namespace


Folder Field

[image]

Grasshopper SDK
GH_AssemblyFolderInfo..::..Folder Field
GH_AssemblyFolderInfo Structure See Also Send Feedback
The actual full path to the folder.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Folder
Visual Basic
Public Folder As String

See Also

GH_AssemblyFolderInfo Structure
Grasshopper.Kernel Namespace


Type Field

[image]

Grasshopper SDK
GH_AssemblyFolderInfo..::..Type Field
GH_AssemblyFolderInfo Structure See Also Send Feedback
Identifies the type of assembly folder.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PluginFolderType Type
Visual Basic
Public Type As GH_PluginFolderType

See Also

GH_AssemblyFolderInfo Structure
Grasshopper.Kernel Namespace


GH_AssemblyFolderInfo Methods

[image] [image]

Grasshopper SDK
GH_AssemblyFolderInfo Methods
GH_AssemblyFolderInfo Structure See Also Send Feedback

The GH_AssemblyFolderInfo type exposes the following members.

Methods

 | Name | Description
Public method | ToString | (Overrides ValueType..::..ToString()()()().)

See Also

GH_AssemblyFolderInfo Structure
Grasshopper.Kernel Namespace


ToString Method

[image]

Grasshopper SDK
GH_AssemblyFolderInfo..::..ToString Method
GH_AssemblyFolderInfo Structure See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_AssemblyFolderInfo Structure
Grasshopper.Kernel Namespace


GH_AssemblyFolderInfo Properties

[image] [image]

Grasshopper SDK
GH_AssemblyFolderInfo Properties
GH_AssemblyFolderInfo Structure See Also Send Feedback

The GH_AssemblyFolderInfo type exposes the following members.

Properties

 | Name | Description
Public property | SearchOption | Gets the search option to use when looking for GHA files in this folder.

See Also

GH_AssemblyFolderInfo Structure
Grasshopper.Kernel Namespace


SearchOption Property

[image]

Grasshopper SDK
GH_AssemblyFolderInfo..::..SearchOption Property
GH_AssemblyFolderInfo Structure See Also Send Feedback
Gets the search option to use when looking for GHA files in this folder.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public SearchOption SearchOption { get; }
Visual Basic
Public ReadOnly Property SearchOption As SearchOption
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_AssemblyFolderInfo.SearchOption"]

See Also

GH_AssemblyFolderInfo Structure
Grasshopper.Kernel Namespace


GH_AssemblyInfo Class

[image]

Grasshopper SDK
GH_AssemblyInfo Class
Members See Also Send Feedback
Implement this interface once (and once only) in a GHA project if you wish to add additional information about your library to Grasshopper. Note you must supply an empty constructor.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract class GH_AssemblyInfo
Visual Basic
Public MustInherit Class GH_AssemblyInfo

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_AssemblyInfo
Grasshopper.Kernel..::..GH_AssemblyInfoStub

See Also

GH_AssemblyInfo Members
Grasshopper.Kernel Namespace


GH_AssemblyInfo Members

[image] [image]

Grasshopper SDK
GH_AssemblyInfo Members
GH_AssemblyInfo Class Constructors Properties See Also Send Feedback

The GH_AssemblyInfo type exposes the following members.

Constructors

 | Name | Description
Protected method | GH_AssemblyInfo | Initializes a new instance of the GH_AssemblyInfo class

Properties

 | Name | Description
Public property | Assembly | Gets the actual assembly that this info object describes.
Public property | AssemblyDescription | Obsolete.
Public property | AssemblyIcon | Obsolete.
Public property | AssemblyLicense | Obsolete.
Public property | AssemblyName | Obsolete.
Public property | AssemblyVersion | Obsolete.
Public property | AuthorContact | Gets the contact information for the author. This can be email, phone, fax, address or all of the above. Return null if you do not wish to associate contact details with this assembly.
Public property | AuthorName | Gets the name of the individual/company/organisation that is responsible for this assembly. Return null if you do not wish to associate an author with this assembly.
Public property | Description | Gets the human readable description of this assembly. Return null if you do not wish to associate a description with this assembly.
Public property | Icon | Gets a 24x24 icon that represents this assembly. Return null if you do not wish to associate an icon with this assembly.
Public property | Id | Gets the Id of this assembly. By default the Id is a hash of the name.
Public property | IsCoreLibrary | Gets whether this library is a Grasshopper core library. Core libraries are installed along with Grasshopper and thus should always be available anywhere.
Public property | License | Gets the license type for this assembly.
Public property | LoadingMechanism | Gets the mechanism used to load this assembly.
Public property | Location | Gets the location this assembly was loaded from.
Public property | Name | Gets the human readable name of this assembly. Return null if you do not wish to associate a name with this assembly.
Public property | Version | Gets the version code for this assembly.

See Also

GH_AssemblyInfo Class
Grasshopper.Kernel Namespace


GH_AssemblyInfo Constructor

[image]

Grasshopper SDK
GH_AssemblyInfo Constructor
GH_AssemblyInfo Class See Also Send Feedback
Initializes a new instance of the GH_AssemblyInfo class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_AssemblyInfo()
Visual Basic
Protected Sub New

See Also

GH_AssemblyInfo Class
Grasshopper.Kernel Namespace


GH_AssemblyInfo Properties

[image] [image]

Grasshopper SDK
GH_AssemblyInfo Properties
GH_AssemblyInfo Class See Also Send Feedback

The GH_AssemblyInfo type exposes the following members.

Properties

 | Name | Description
Public property | Assembly | Gets the actual assembly that this info object describes.
Public property | AssemblyDescription | Obsolete.
Public property | AssemblyIcon | Obsolete.
Public property | AssemblyLicense | Obsolete.
Public property | AssemblyName | Obsolete.
Public property | AssemblyVersion | Obsolete.
Public property | AuthorContact | Gets the contact information for the author. This can be email, phone, fax, address or all of the above. Return null if you do not wish to associate contact details with this assembly.
Public property | AuthorName | Gets the name of the individual/company/organisation that is responsible for this assembly. Return null if you do not wish to associate an author with this assembly.
Public property | Description | Gets the human readable description of this assembly. Return null if you do not wish to associate a description with this assembly.
Public property | Icon | Gets a 24x24 icon that represents this assembly. Return null if you do not wish to associate an icon with this assembly.
Public property | Id | Gets the Id of this assembly. By default the Id is a hash of the name.
Public property | IsCoreLibrary | Gets whether this library is a Grasshopper core library. Core libraries are installed along with Grasshopper and thus should always be available anywhere.
Public property | License | Gets the license type for this assembly.
Public property | LoadingMechanism | Gets the mechanism used to load this assembly.
Public property | Location | Gets the location this assembly was loaded from.
Public property | Name | Gets the human readable name of this assembly. Return null if you do not wish to associate a name with this assembly.
Public property | Version | Gets the version code for this assembly.

See Also

GH_AssemblyInfo Class
Grasshopper.Kernel Namespace


Assembly Property

[image]

Grasshopper SDK
GH_AssemblyInfo..::..Assembly Property
GH_AssemblyInfo Class See Also Send Feedback
Gets the actual assembly that this info object describes.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Assembly Assembly { get; }
Visual Basic
Public ReadOnly Property Assembly As Assembly
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_AssemblyInfo.Assembly"]

See Also

GH_AssemblyInfo Class
Grasshopper.Kernel Namespace


AssemblyDescription Property

[image]

Grasshopper SDK
GH_AssemblyInfo..::..AssemblyDescription Property
GH_AssemblyInfo Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
[ObsoleteAttribute("This property has been replaced by the Icon property")]
public virtual string AssemblyDescription { get; }
Visual Basic
<ObsoleteAttribute("This property has been replaced by the Icon property")> _
Public Overridable ReadOnly Property AssemblyDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_AssemblyInfo.AssemblyDescription"]

See Also

GH_AssemblyInfo Class
Grasshopper.Kernel Namespace


AssemblyIcon Property

[image]

Grasshopper SDK
GH_AssemblyInfo..::..AssemblyIcon Property
GH_AssemblyInfo Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
[ObsoleteAttribute("This property has been replaced by the Icon property")]
public virtual Bitmap AssemblyIcon { get; }
Visual Basic
<ObsoleteAttribute("This property has been replaced by the Icon property")> _
Public Overridable ReadOnly Property AssemblyIcon As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_AssemblyInfo.AssemblyIcon"]

See Also

GH_AssemblyInfo Class
Grasshopper.Kernel Namespace


AssemblyLicense Property

[image]

Grasshopper SDK
GH_AssemblyInfo..::..AssemblyLicense Property
GH_AssemblyInfo Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
[ObsoleteAttribute("This property has been replaced by the Icon property")]
public virtual GH_LibraryLicense AssemblyLicense { get; }
Visual Basic
<ObsoleteAttribute("This property has been replaced by the Icon property")> _
Public Overridable ReadOnly Property AssemblyLicense As GH_LibraryLicense
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_AssemblyInfo.AssemblyLicense"]

See Also

GH_AssemblyInfo Class
Grasshopper.Kernel Namespace


AssemblyName Property

[image]

Grasshopper SDK
GH_AssemblyInfo..::..AssemblyName Property
GH_AssemblyInfo Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
[ObsoleteAttribute("This property has been replaced by the Name property")]
public virtual string AssemblyName { get; }
Visual Basic
<ObsoleteAttribute("This property has been replaced by the Name property")> _
Public Overridable ReadOnly Property AssemblyName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_AssemblyInfo.AssemblyName"]

See Also

GH_AssemblyInfo Class
Grasshopper.Kernel Namespace


AssemblyVersion Property

[image]

Grasshopper SDK
GH_AssemblyInfo..::..AssemblyVersion Property
GH_AssemblyInfo Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
[ObsoleteAttribute("This property has been replaced by the Version property")]
public virtual string AssemblyVersion { get; }
Visual Basic
<ObsoleteAttribute("This property has been replaced by the Version property")> _
Public Overridable ReadOnly Property AssemblyVersion As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_AssemblyInfo.AssemblyVersion"]

See Also

GH_AssemblyInfo Class
Grasshopper.Kernel Namespace


AuthorContact Property

[image]

Grasshopper SDK
GH_AssemblyInfo..::..AuthorContact Property
GH_AssemblyInfo Class See Also Send Feedback
Gets the contact information for the author. This can be email, phone, fax, address or all of the above. Return null if you do not wish to associate contact details with this assembly.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual string AuthorContact { get; }
Visual Basic
Public Overridable ReadOnly Property AuthorContact As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_AssemblyInfo.AuthorContact"]

See Also

GH_AssemblyInfo Class
Grasshopper.Kernel Namespace


AuthorName Property

[image]

Grasshopper SDK
GH_AssemblyInfo..::..AuthorName Property
GH_AssemblyInfo Class See Also Send Feedback
Gets the name of the individual/company/organisation that is responsible for this assembly. Return null if you do not wish to associate an author with this assembly.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual string AuthorName { get; }
Visual Basic
Public Overridable ReadOnly Property AuthorName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_AssemblyInfo.AuthorName"]

See Also

GH_AssemblyInfo Class
Grasshopper.Kernel Namespace


Description Property

[image]

Grasshopper SDK
GH_AssemblyInfo..::..Description Property
GH_AssemblyInfo Class See Also Send Feedback
Gets the human readable description of this assembly. Return null if you do not wish to associate a description with this assembly.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual string Description { get; }
Visual Basic
Public Overridable ReadOnly Property Description As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_AssemblyInfo.Description"]

See Also

GH_AssemblyInfo Class
Grasshopper.Kernel Namespace


Icon Property

[image]

Grasshopper SDK
GH_AssemblyInfo..::..Icon Property
GH_AssemblyInfo Class See Also Send Feedback
Gets a 24x24 icon that represents this assembly. Return null if you do not wish to associate an icon with this assembly.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual Bitmap Icon { get; }
Visual Basic
Public Overridable ReadOnly Property Icon As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_AssemblyInfo.Icon"]

See Also

GH_AssemblyInfo Class
Grasshopper.Kernel Namespace


Id Property

[image]

Grasshopper SDK
GH_AssemblyInfo..::..Id Property
GH_AssemblyInfo Class See Also Send Feedback
Gets the Id of this assembly. By default the Id is a hash of the name.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual Guid Id { get; }
Visual Basic
Public Overridable ReadOnly Property Id As Guid
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_AssemblyInfo.Id"]

See Also

GH_AssemblyInfo Class
Grasshopper.Kernel Namespace


IsCoreLibrary Property

[image]

Grasshopper SDK
GH_AssemblyInfo..::..IsCoreLibrary Property
GH_AssemblyInfo Class See Also Send Feedback
Gets whether this library is a Grasshopper core library. Core libraries are installed along with Grasshopper and thus should always be available anywhere.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsCoreLibrary { get; }
Visual Basic
Public ReadOnly Property IsCoreLibrary As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_AssemblyInfo.IsCoreLibrary"]

See Also

GH_AssemblyInfo Class
Grasshopper.Kernel Namespace


License Property

[image]

Grasshopper SDK
GH_AssemblyInfo..::..License Property
GH_AssemblyInfo Class See Also Send Feedback
Gets the license type for this assembly.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual GH_LibraryLicense License { get; }
Visual Basic
Public Overridable ReadOnly Property License As GH_LibraryLicense
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_AssemblyInfo.License"]

See Also

GH_AssemblyInfo Class
Grasshopper.Kernel Namespace


LoadingMechanism Property

[image]

Grasshopper SDK
GH_AssemblyInfo..::..LoadingMechanism Property
GH_AssemblyInfo Class See Also Send Feedback
Gets the mechanism used to load this assembly.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_LoadingMechanism LoadingMechanism { get; }
Visual Basic
Public ReadOnly Property LoadingMechanism As GH_LoadingMechanism
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_AssemblyInfo.LoadingMechanism"]

See Also

GH_AssemblyInfo Class
Grasshopper.Kernel Namespace


Location Property

[image]

Grasshopper SDK
GH_AssemblyInfo..::..Location Property
GH_AssemblyInfo Class See Also Send Feedback
Gets the location this assembly was loaded from.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Location { get; }
Visual Basic
Public ReadOnly Property Location As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_AssemblyInfo.Location"]

See Also

GH_AssemblyInfo Class
Grasshopper.Kernel Namespace


Name Property

[image]

Grasshopper SDK
GH_AssemblyInfo..::..Name Property
GH_AssemblyInfo Class See Also Send Feedback
Gets the human readable name of this assembly. Return null if you do not wish to associate a name with this assembly.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual string Name { get; }
Visual Basic
Public Overridable ReadOnly Property Name As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_AssemblyInfo.Name"]

See Also

GH_AssemblyInfo Class
Grasshopper.Kernel Namespace


Version Property

[image]

Grasshopper SDK
GH_AssemblyInfo..::..Version Property
GH_AssemblyInfo Class See Also Send Feedback
Gets the version code for this assembly.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual string Version { get; }
Visual Basic
Public Overridable ReadOnly Property Version As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_AssemblyInfo.Version"]

See Also

GH_AssemblyInfo Class
Grasshopper.Kernel Namespace


GH_AssemblyInfoStub Class

[image]

Grasshopper SDK
GH_AssemblyInfoStub Class
Members See Also Send Feedback
Provides basic properties for a GHA assembly that does not expose a type that derives from GH_AssemblyInfo. This type is created automatically when a GH_AssemblyInfo type is not found in an assembly.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class GH_AssemblyInfoStub : GH_AssemblyInfo
Visual Basic
Public NotInheritable Class GH_AssemblyInfoStub _
    Inherits GH_AssemblyInfo

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_AssemblyInfo
Grasshopper.Kernel..::..GH_AssemblyInfoStub

See Also

GH_AssemblyInfoStub Members
Grasshopper.Kernel Namespace


GH_AssemblyInfoStub Members

[image] [image]

Grasshopper SDK
GH_AssemblyInfoStub Members
GH_AssemblyInfoStub Class Constructors Properties See Also Send Feedback

The GH_AssemblyInfoStub type exposes the following members.

Constructors

 | Name | Description
Public method | GH_AssemblyInfoStub | Initializes a new instance of the GH_AssemblyInfoStub class

Properties

 | Name | Description
Public property | Assembly | Gets the actual assembly that this info object describes. (Inherited from GH_AssemblyInfo.)
Public property | AssemblyDescription | Obsolete. (Inherited from GH_AssemblyInfo.)
Public property | AssemblyIcon | Obsolete. (Inherited from GH_AssemblyInfo.)
Public property | AssemblyLicense | Obsolete. (Inherited from GH_AssemblyInfo.)
Public property | AssemblyName | (Overrides GH_AssemblyInfo..::..AssemblyName.)
Public property | AssemblyVersion | (Overrides GH_AssemblyInfo..::..AssemblyVersion.)
Public property | AuthorContact | Gets the contact information for the author. This can be email, phone, fax, address or all of the above. Return null if you do not wish to associate contact details with this assembly. (Inherited from GH_AssemblyInfo.)
Public property | AuthorName | Gets the name of the individual/company/organisation that is responsible for this assembly. Return null if you do not wish to associate an author with this assembly. (Inherited from GH_AssemblyInfo.)
Public property | Description | Gets the human readable description of this assembly. Return null if you do not wish to associate a description with this assembly. (Inherited from GH_AssemblyInfo.)
Public property | Icon | Gets a 24x24 icon that represents this assembly. Return null if you do not wish to associate an icon with this assembly. (Inherited from GH_AssemblyInfo.)
Public property | Id | Gets the Id of this assembly. By default the Id is a hash of the name. (Inherited from GH_AssemblyInfo.)
Public property | IsCoreLibrary | Gets whether this library is a Grasshopper core library. Core libraries are installed along with Grasshopper and thus should always be available anywhere. (Inherited from GH_AssemblyInfo.)
Public property | License | Gets the license type for this assembly. (Inherited from GH_AssemblyInfo.)
Public property | LoadingMechanism | Gets the mechanism used to load this assembly. (Inherited from GH_AssemblyInfo.)
Public property | Location | Gets the location this assembly was loaded from. (Inherited from GH_AssemblyInfo.)
Public property | Name | Gets the human readable name of this assembly. Return null if you do not wish to associate a name with this assembly. (Inherited from GH_AssemblyInfo.)
Public property | Version | Gets the version code for this assembly. (Inherited from GH_AssemblyInfo.)

See Also

GH_AssemblyInfoStub Class
Grasshopper.Kernel Namespace


GH_AssemblyInfoStub Constructor

[image]

Grasshopper SDK
GH_AssemblyInfoStub Constructor
GH_AssemblyInfoStub Class See Also Send Feedback
Initializes a new instance of the GH_AssemblyInfoStub class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_AssemblyInfoStub(
    Assembly assembly
)
Visual Basic
Public Sub New ( _
    assembly As Assembly _
)

Parameters

assembly
Type: System.Reflection..::..Assembly

See Also

GH_AssemblyInfoStub Class
Grasshopper.Kernel Namespace


GH_AssemblyInfoStub Properties

[image] [image]

Grasshopper SDK
GH_AssemblyInfoStub Properties
GH_AssemblyInfoStub Class See Also Send Feedback

The GH_AssemblyInfoStub type exposes the following members.

Properties

 | Name | Description
Public property | Assembly | Gets the actual assembly that this info object describes. (Inherited from GH_AssemblyInfo.)
Public property | AssemblyDescription | Obsolete. (Inherited from GH_AssemblyInfo.)
Public property | AssemblyIcon | Obsolete. (Inherited from GH_AssemblyInfo.)
Public property | AssemblyLicense | Obsolete. (Inherited from GH_AssemblyInfo.)
Public property | AssemblyName | (Overrides GH_AssemblyInfo..::..AssemblyName.)
Public property | AssemblyVersion | (Overrides GH_AssemblyInfo..::..AssemblyVersion.)
Public property | AuthorContact | Gets the contact information for the author. This can be email, phone, fax, address or all of the above. Return null if you do not wish to associate contact details with this assembly. (Inherited from GH_AssemblyInfo.)
Public property | AuthorName | Gets the name of the individual/company/organisation that is responsible for this assembly. Return null if you do not wish to associate an author with this assembly. (Inherited from GH_AssemblyInfo.)
Public property | Description | Gets the human readable description of this assembly. Return null if you do not wish to associate a description with this assembly. (Inherited from GH_AssemblyInfo.)
Public property | Icon | Gets a 24x24 icon that represents this assembly. Return null if you do not wish to associate an icon with this assembly. (Inherited from GH_AssemblyInfo.)
Public property | Id | Gets the Id of this assembly. By default the Id is a hash of the name. (Inherited from GH_AssemblyInfo.)
Public property | IsCoreLibrary | Gets whether this library is a Grasshopper core library. Core libraries are installed along with Grasshopper and thus should always be available anywhere. (Inherited from GH_AssemblyInfo.)
Public property | License | Gets the license type for this assembly. (Inherited from GH_AssemblyInfo.)
Public property | LoadingMechanism | Gets the mechanism used to load this assembly. (Inherited from GH_AssemblyInfo.)
Public property | Location | Gets the location this assembly was loaded from. (Inherited from GH_AssemblyInfo.)
Public property | Name | Gets the human readable name of this assembly. Return null if you do not wish to associate a name with this assembly. (Inherited from GH_AssemblyInfo.)
Public property | Version | Gets the version code for this assembly. (Inherited from GH_AssemblyInfo.)

See Also

GH_AssemblyInfoStub Class
Grasshopper.Kernel Namespace


AssemblyName Property

[image]

Grasshopper SDK
GH_AssemblyInfoStub..::..AssemblyName Property
GH_AssemblyInfoStub Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string AssemblyName { get; }
Visual Basic
Public Overrides ReadOnly Property AssemblyName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_AssemblyInfoStub.AssemblyName"]

See Also

GH_AssemblyInfoStub Class
Grasshopper.Kernel Namespace


AssemblyVersion Property

[image]

Grasshopper SDK
GH_AssemblyInfoStub..::..AssemblyVersion Property
GH_AssemblyInfoStub Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string AssemblyVersion { get; }
Visual Basic
Public Overrides ReadOnly Property AssemblyVersion As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_AssemblyInfoStub.AssemblyVersion"]

See Also

GH_AssemblyInfoStub Class
Grasshopper.Kernel Namespace


GH_AssemblyPriority Class

[image]

Grasshopper SDK
GH_AssemblyPriority Class
Members See Also Send Feedback
Derive from this class if you wish to perform additional steps before any of your components are loaded. Any class in your project which inherits from GH_AssemblyPriority and which has an empty constructor will be instantiated prior to any GH_Component or IGH_DocumentObject classes.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract class GH_AssemblyPriority
Visual Basic
Public MustInherit Class GH_AssemblyPriority

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_AssemblyPriority

See Also

GH_AssemblyPriority Members
Grasshopper.Kernel Namespace


GH_AssemblyPriority Members

[image] [image]

Grasshopper SDK
GH_AssemblyPriority Members
GH_AssemblyPriority Class Constructors Methods See Also Send Feedback

The GH_AssemblyPriority type exposes the following members.

Constructors

 | Name | Description
Protected method | GH_AssemblyPriority | Initializes a new instance of the GH_AssemblyPriority class

Methods

 | Name | Description
Public method | PriorityLoad | This method will be called exactly once before any of the Components in your project are loaded.

See Also

GH_AssemblyPriority Class
Grasshopper.Kernel Namespace


GH_AssemblyPriority Constructor

[image]

Grasshopper SDK
GH_AssemblyPriority Constructor
GH_AssemblyPriority Class See Also Send Feedback
Initializes a new instance of the GH_AssemblyPriority class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_AssemblyPriority()
Visual Basic
Protected Sub New

See Also

GH_AssemblyPriority Class
Grasshopper.Kernel Namespace


GH_AssemblyPriority Methods

[image] [image]

Grasshopper SDK
GH_AssemblyPriority Methods
GH_AssemblyPriority Class See Also Send Feedback

The GH_AssemblyPriority type exposes the following members.

Methods

 | Name | Description
Public method | PriorityLoad | This method will be called exactly once before any of the Components in your project are loaded.

See Also

GH_AssemblyPriority Class
Grasshopper.Kernel Namespace


PriorityLoad Method

[image]

Grasshopper SDK
GH_AssemblyPriority..::..PriorityLoad Method
GH_AssemblyPriority Class See Also Send Feedback
This method will be called exactly once before any of the Components in your project are loaded.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract GH_LoadingInstruction PriorityLoad()
Visual Basic
Public MustOverride Function PriorityLoad As GH_LoadingInstruction

Return Value

Loading instruction. If you wish to abort the loading of your project, then return GH_LoadingInstruction.Abort.

See Also

GH_AssemblyPriority Class
Grasshopper.Kernel Namespace


GH_Attributes(T) Class

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)> Class
Members See Also Send Feedback
Derive from this class rather than implementing IGH_Attributes from scratch.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract class GH_Attributes<T> : IGH_Attributes
where T : IGH_DocumentObject
Visual Basic
Public MustInherit Class GH_Attributes(Of T As IGH_DocumentObject) _
    Implements IGH_Attributes

Type Parameters

T
Type of the objects that owns these attributes.

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_Attributes<(Of <(<'T>)>)>
Grasshopper.Kernel.Attributes..::..GH_ComponentAttributes
Grasshopper.Kernel.Attributes..::..GH_FloatingParamAttributes
Grasshopper.Kernel.Attributes..::..GH_LinkedParamAttributes
Grasshopper.Kernel.Attributes..::..GH_ResizableAttributes<(Of <(<'T>)>)>

See Also

GH_Attributes<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


GH_Attributes(T) Members

[image] [image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)> Members
GH_Attributes<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The GH_Attributes<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Protected method | GH_Attributes<(Of <(<'T>)>)> | Construct a new instance of this class.

Methods

 | Name | Description
Public method | AppendToAttributeTree | Recursively append these attributes and all child attributes to the attribute list.
Public method | ExpireLayout | Expires the entire layout of the attributes. When overridden, implementer must place a call to the base class ExpireLayout().
Public method | InvalidateCanvas | If the mouse location should cause a canvas invalidation then return true. You only need to override this function if you draw objects that are dependant on cursor positions outside the bounds of the attributes.
 | IsIconMode | Utility function for determining Icon display modes. If the supplied mode is ::application, then it will be adjusted to match the current app settings.
Public method | IsMenuRegion | Determines whether a point is available for context menu popups. By default, IsMenuRegion calls IsPickRegion(PointF).
Public method | IsPickRegion(PointF) | Determines whether a point is within the pickable region for this object. By default, any point inside the Bounds is treated as pickable.
Public method | IsPickRegion(RectangleF, GH_PickBox) | Determines whether a rectangle is a valid pick region for this object. By default, the picking rectangle is intersected with the Bounds rectangle.
Public method | IsTooltipRegion | Determines whether a point is available for tooltip popups. By default, IsMenuRegion calls IsTooltipRegion(PointF).
Protected method | Layout | Perform dedicated layout logic specific to this particular DocumentObject. This method is called from PerformLayout if the existing layout is stale.
Public method | NewInstanceGuid()()()() | Generate a new instance GUID for the owner object.
Public method | NewInstanceGuid(Guid) | Generate a new instance GUID for the owner object. Do not use this overload unless you're > 1.95m and called David.
Public method | PerformLayout | Recompute the layout for these attributes. This function is automatically called during Drawing operations, so you typically don't have to.
Protected method | PrepareForRender | This method will always be called exactly once prior to Render(). This would be a good place to make sure all the necessary GUI data is up and running.
Public method | Read |
Protected method | Render | Override this function to supply custom Render logic.
Protected method | RenderIncomingWires(GH_Painter, IEnumerable<(Of <<'(IGH_Param>)>>), GH_ParamWireDisplay) | Utility function for derived classes. This method draws all the wires going into the left side of the attributes.
Protected method | RenderIncomingWires(GH_Painter, IEnumerable<(Of <<'(IGH_Param>)>>), IEnumerable<(Of <<'(Pen>)>>)) | Utility function for derived classes. This method draws all the wires going into the left side of the attributes.
Public method | RenderToCanvas | Render these attributes into a Canvas control. This function places calls to PrepareForRender() and Render(), you should override those.
Public method | RespondToKeyDown |
Public method | RespondToKeyUp |
Public method | RespondToMouseDoubleClick |
Public method | RespondToMouseDown |
Public method | RespondToMouseMove |
Public method | RespondToMouseUp |
Public method | SetupTooltip | Populates the Grasshopper tooltip with all relevant data. If this function returns True, it is assumed that all possible fields have been filled out and the tooltip is ready for display.
Public method | Write |

Properties

 | Name | Description
Public property | AllowMessageBalloon | Gets a value indicating whether these attributes allow warning and error balloons to be drawn on top of them.
Public property | Bounds | Gets the rectangle that contains the active content of the attributes. Typically the Contents determine the active area for menus, tooltips etc. Attributes are not supposed to draw objects beyond the Bounds.
Public property | DocObject | Gets the owner object of these attributes.
Public property | GetTopLevel | Gets the top-level attributes of the attribute stack these attributes belong to.
Public property | HasInputGrip | Gets a value indicating whether or not these attributes have an input grip.
Public property | HasOutputGrip | Gets a value indicating whether or not these attributes have an output grip.
Public property | InputGrip | Gets the input grip location for these attributes. If HasInputGrip equals False, this point is meaningless.
Public property | InstanceGuid | Gets the instance ID of the document object that owns these attributes.
Public property | IsTopLevel | Gets whether these attributes are top_level (i.e. no Parent attributes)
Public property | OutputGrip | Gets the output grip location for these attributes. If HasOutputGrip equals False, this point is meaningless.
Public property | Owner | Gets the type-safe owner object of these attributes. This property is identical to the DocObject property.
Public property | Parent | Gets or sets the parent attributes. Top level attributes do not have parents.
Public property | PathName | Get a description of the location of these attributes within the local attribute stack.
Public property | Pivot | Gets or sets the pivot for these attributes. The pivot controls the general placement of the attributes. If you want to move the attributes, change the pivot location.
Public property | Selected | Gets or sets the selected state of the top-level attributes.
Public property | TooltipEnabled | Gets the tooltip enabled value. If False, no further tooltip functions will be called.

See Also

GH_Attributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


GH_Attributes(T) Constructor

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)> Constructor
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback
Construct a new instance of this class.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Attributes(
    T owner
)
Visual Basic
Protected Sub New ( _
    owner As T _
)

Parameters

owner
Type: T
Owner object associated with these attributes.

See Also

GH_Attributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


GH_Attributes(T) Methods

[image] [image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)> Methods
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback

The GH_Attributes<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | AppendToAttributeTree | Recursively append these attributes and all child attributes to the attribute list.
Public method | ExpireLayout | Expires the entire layout of the attributes. When overridden, implementer must place a call to the base class ExpireLayout().
Public method | InvalidateCanvas | If the mouse location should cause a canvas invalidation then return true. You only need to override this function if you draw objects that are dependant on cursor positions outside the bounds of the attributes.
 | IsIconMode | Utility function for determining Icon display modes. If the supplied mode is ::application, then it will be adjusted to match the current app settings.
Public method | IsMenuRegion | Determines whether a point is available for context menu popups. By default, IsMenuRegion calls IsPickRegion(PointF).
Public method | IsPickRegion(PointF) | Determines whether a point is within the pickable region for this object. By default, any point inside the Bounds is treated as pickable.
Public method | IsPickRegion(RectangleF, GH_PickBox) | Determines whether a rectangle is a valid pick region for this object. By default, the picking rectangle is intersected with the Bounds rectangle.
Public method | IsTooltipRegion | Determines whether a point is available for tooltip popups. By default, IsMenuRegion calls IsTooltipRegion(PointF).
Protected method | Layout | Perform dedicated layout logic specific to this particular DocumentObject. This method is called from PerformLayout if the existing layout is stale.
Public method | NewInstanceGuid()()()() | Generate a new instance GUID for the owner object.
Public method | NewInstanceGuid(Guid) | Generate a new instance GUID for the owner object. Do not use this overload unless you're > 1.95m and called David.
Public method | PerformLayout | Recompute the layout for these attributes. This function is automatically called during Drawing operations, so you typically don't have to.
Protected method | PrepareForRender | This method will always be called exactly once prior to Render(). This would be a good place to make sure all the necessary GUI data is up and running.
Public method | Read |
Protected method | Render | Override this function to supply custom Render logic.
Protected method | RenderIncomingWires(GH_Painter, IEnumerable<(Of <<'(IGH_Param>)>>), GH_ParamWireDisplay) | Utility function for derived classes. This method draws all the wires going into the left side of the attributes.
Protected method | RenderIncomingWires(GH_Painter, IEnumerable<(Of <<'(IGH_Param>)>>), IEnumerable<(Of <<'(Pen>)>>)) | Utility function for derived classes. This method draws all the wires going into the left side of the attributes.
Public method | RenderToCanvas | Render these attributes into a Canvas control. This function places calls to PrepareForRender() and Render(), you should override those.
Public method | RespondToKeyDown |
Public method | RespondToKeyUp |
Public method | RespondToMouseDoubleClick |
Public method | RespondToMouseDown |
Public method | RespondToMouseMove |
Public method | RespondToMouseUp |
Public method | SetupTooltip | Populates the Grasshopper tooltip with all relevant data. If this function returns True, it is assumed that all possible fields have been filled out and the tooltip is ready for display.
Public method | Write |

See Also

GH_Attributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


AppendToAttributeTree Method

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..AppendToAttributeTree Method
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback
Recursively append these attributes and all child attributes to the attribute list.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual void AppendToAttributeTree(
    List<IGH_Attributes> attributes
)
Visual Basic
Public Overridable Sub AppendToAttributeTree ( _
    attributes As List(Of IGH_Attributes) _
)

Parameters

attributes
Type: System.Collections.Generic..::..List <(Of <(<' IGH_Attributes >)>)>
List to append to.

Implements

IGH_Attributes..::..AppendToAttributeTree(List<(Of <<'(IGH_Attributes>)>>))

See Also

GH_Attributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


ExpireLayout Method

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..ExpireLayout Method
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback
Expires the entire layout of the attributes. When overridden, implementer must place a call to the base class ExpireLayout().

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual void ExpireLayout()
Visual Basic
Public Overridable Sub ExpireLayout

Implements

IGH_Attributes..::..ExpireLayout()()()()

See Also

GH_Attributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


InvalidateCanvas Method

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..InvalidateCanvas Method
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback
If the mouse location should cause a canvas invalidation then return true. You only need to override this function if you draw objects that are dependant on cursor positions outside the bounds of the attributes.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool InvalidateCanvas(
    GH_Canvas canvas,
    GH_CanvasMouseEvent e
)
Visual Basic
Public Overridable Function InvalidateCanvas ( _
    canvas As GH_Canvas, _
    e As GH_CanvasMouseEvent _
) As Boolean

Parameters

canvas
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
Canvas to potentially invalidate.
e
Type: Grasshopper.GUI..::..GH_CanvasMouseEvent
Event arguments for canvas mousemove.

Return Value

True if the canvas ought to be invalidated.

Implements

IGH_Attributes..::..InvalidateCanvas(GH_Canvas, GH_CanvasMouseEvent)

See Also

GH_Attributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


IsIconMode Method

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..IsIconMode Method
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback
Utility function for determining Icon display modes. If the supplied mode is ::application, then it will be adjusted to match the current app settings.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected static bool IsIconMode(
    GH_IconDisplayMode mode
)
Visual Basic
Protected Shared Function IsIconMode ( _
    mode As GH_IconDisplayMode _
) As Boolean

Parameters

mode
Type: Grasshopper.Kernel..::..GH_IconDisplayMode

See Also

GH_Attributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


IsMenuRegion Method

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..IsMenuRegion Method
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback
Determines whether a point is available for context menu popups. By default, IsMenuRegion calls IsPickRegion(PointF).

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool IsMenuRegion(
    PointF point
)
Visual Basic
Public Overridable Function IsMenuRegion ( _
    point As PointF _
) As Boolean

Parameters

point
Type: System.Drawing..::..PointF
Point location to test.

Implements

IGH_Attributes..::..IsMenuRegion(PointF)

See Also

GH_Attributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


IsPickRegion Method

[image] [image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..IsPickRegion Method
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsPickRegion(PointF) | Determines whether a point is within the pickable region for this object. By default, any point inside the Bounds is treated as pickable.
Public method | IsPickRegion(RectangleF, GH_PickBox) | Determines whether a rectangle is a valid pick region for this object. By default, the picking rectangle is intersected with the Bounds rectangle.

See Also

GH_Attributes<(Of <(<'T>)>)> Class
GH_Attributes<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


IsPickRegion Method (PointF)

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..IsPickRegion Method (PointF)
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback
Determines whether a point is within the pickable region for this object. By default, any point inside the Bounds is treated as pickable.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool IsPickRegion(
    PointF point
)
Visual Basic
Public Overridable Function IsPickRegion ( _
    point As PointF _
) As Boolean

Parameters

point
Type: System.Drawing..::..PointF
Point location to test.

Implements

IGH_Attributes..::..IsPickRegion(PointF)

See Also

GH_Attributes<(Of <(<'T>)>)> Class
IsPickRegion Overload
Grasshopper.Kernel Namespace


IsPickRegion Method (RectangleF, GH_PickBox)

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..IsPickRegion Method (RectangleF, GH_PickBox)
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback
Determines whether a rectangle is a valid pick region for this object. By default, the picking rectangle is intersected with the Bounds rectangle.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool IsPickRegion(
    RectangleF box,
    GH_PickBox method
)
Visual Basic
Public Overridable Function IsPickRegion ( _
    box As RectangleF, _
    method As GH_PickBox _
) As Boolean

Parameters

box
Type: System.Drawing..::..RectangleF
Selection box.
method
Type: Grasshopper.Kernel..::..GH_PickBox
Selection method.

Implements

IGH_Attributes..::..IsPickRegion(RectangleF, GH_PickBox)

See Also

GH_Attributes<(Of <(<'T>)>)> Class
IsPickRegion Overload
Grasshopper.Kernel Namespace


IsTooltipRegion Method

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..IsTooltipRegion Method
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback
Determines whether a point is available for tooltip popups. By default, IsMenuRegion calls IsTooltipRegion(PointF).

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool IsTooltipRegion(
    PointF point
)
Visual Basic
Public Overridable Function IsTooltipRegion ( _
    point As PointF _
) As Boolean

Parameters

point
Type: System.Drawing..::..PointF
Point location to test.

Implements

IGH_TooltipAwareObject..::..IsTooltipRegion(PointF)

See Also

GH_Attributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Layout Method

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..Layout Method
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback
Perform dedicated layout logic specific to this particular DocumentObject. This method is called from PerformLayout if the existing layout is stale.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected virtual void Layout()
Visual Basic
Protected Overridable Sub Layout

See Also

GH_Attributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


NewInstanceGuid Method

[image] [image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..NewInstanceGuid Method
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NewInstanceGuid()()()() | Generate a new instance GUID for the owner object.
Public method | NewInstanceGuid(Guid) | Generate a new instance GUID for the owner object. Do not use this overload unless you're > 1.95m and called David.

See Also

GH_Attributes<(Of <(<'T>)>)> Class
GH_Attributes<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


NewInstanceGuid Method

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..NewInstanceGuid Method
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback
Generate a new instance GUID for the owner object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void NewInstanceGuid()
Visual Basic
Public Sub NewInstanceGuid

Implements

IGH_Attributes..::..NewInstanceGuid()()()()

See Also

GH_Attributes<(Of <(<'T>)>)> Class
NewInstanceGuid Overload
Grasshopper.Kernel Namespace


NewInstanceGuid Method (Guid)

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..NewInstanceGuid Method (Guid)
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback
Generate a new instance GUID for the owner object. Do not use this overload unless you're > 1.95m and called David.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void NewInstanceGuid(
    Guid newId
)
Visual Basic
Public Sub NewInstanceGuid ( _
    newId As Guid _
)

Parameters

newId
Type: System..::..Guid

Implements

IGH_Attributes..::..NewInstanceGuid(Guid)

See Also

GH_Attributes<(Of <(<'T>)>)> Class
NewInstanceGuid Overload
Grasshopper.Kernel Namespace


PerformLayout Method

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..PerformLayout Method
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback
Recompute the layout for these attributes. This function is automatically called during Drawing operations, so you typically don't have to.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void PerformLayout()
Visual Basic
Public Sub PerformLayout

Implements

IGH_Attributes..::..PerformLayout()()()()

See Also

GH_Attributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


PrepareForRender Method

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..PrepareForRender Method
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback
This method will always be called exactly once prior to Render(). This would be a good place to make sure all the necessary GUI data is up and running.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected virtual void PrepareForRender(
    GH_Canvas canvas
)
Visual Basic
Protected Overridable Sub PrepareForRender ( _
    canvas As GH_Canvas _
)

Parameters

canvas
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
Canvas that is about to render these attributes.

See Also

GH_Attributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Read Method

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..Read Method
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool Read(
    GH_IReader reader
)
Visual Basic
Public Overridable Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

Implements

GH_ISerializable..::..Read(GH_IReader)

See Also

GH_Attributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Render Method

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..Render Method
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback
Override this function to supply custom Render logic.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected virtual void Render(
    GH_Canvas canvas,
    Graphics graphics,
    GH_CanvasChannel channel
)
Visual Basic
Protected Overridable Sub Render ( _
    canvas As GH_Canvas, _
    graphics As Graphics, _
    channel As GH_CanvasChannel _
)

Parameters

canvas
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
Canvas in which these attributes are to be drawn.
graphics
Type: System.Drawing..::..Graphics
Graphics object to draw with.
channel
Type: Grasshopper.GUI.Canvas..::..GH_CanvasChannel
Current drawing channel.

See Also

GH_Attributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


RenderIncomingWires Method

[image] [image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..RenderIncomingWires Method
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RenderIncomingWires(GH_Painter, IEnumerable<(Of <<'(IGH_Param>)>>), GH_ParamWireDisplay) | Utility function for derived classes. This method draws all the wires going into the left side of the attributes.
Protected method | RenderIncomingWires(GH_Painter, IEnumerable<(Of <<'(IGH_Param>)>>), IEnumerable<(Of <<'(Pen>)>>)) | Utility function for derived classes. This method draws all the wires going into the left side of the attributes.

See Also

GH_Attributes<(Of <(<'T>)>)> Class
GH_Attributes<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


RenderIncomingWires Method (GH_Painter, IEnumerable(IGH_Param), GH_ParamWireDisplay)

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..RenderIncomingWires Method (GH_Painter, IEnumerable<(Of <(<'IGH_Param>)>)>, GH_ParamWireDisplay)
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback
Utility function for derived classes. This method draws all the wires going into the left side of the attributes.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected void RenderIncomingWires(
    GH_Painter painter,
    IEnumerable<IGH_Param> sources,
    GH_ParamWireDisplay style
)
Visual Basic
Protected Sub RenderIncomingWires ( _
    painter As GH_Painter, _
    sources As IEnumerable(Of IGH_Param), _
    style As GH_ParamWireDisplay _
)

Parameters

painter
Type: Grasshopper.GUI.Canvas..::..GH_Painter
The graphics object to paint with
sources
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' IGH_Param >)>)>
A list of sources that will be connected with the input grip of this attribute
style
Type: Grasshopper.Kernel..::..GH_ParamWireDisplay
Style for wire display.

See Also

GH_Attributes<(Of <(<'T>)>)> Class
RenderIncomingWires Overload
Grasshopper.Kernel Namespace


RenderIncomingWires Method (GH_Painter, IEnumerable(IGH_Param), IEnumerable(Pen))

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..RenderIncomingWires Method (GH_Painter, IEnumerable<(Of <(<'IGH_Param>)>)>, IEnumerable<(Of <(<'Pen>)>)>)
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback
Utility function for derived classes. This method draws all the wires going into the left side of the attributes.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected void RenderIncomingWires(
    GH_Painter painter,
    IEnumerable<IGH_Param> sources,
    IEnumerable<Pen> styles
)
Visual Basic
Protected Sub RenderIncomingWires ( _
    painter As GH_Painter, _
    sources As IEnumerable(Of IGH_Param), _
    styles As IEnumerable(Of Pen) _
)

Parameters

painter
Type: Grasshopper.GUI.Canvas..::..GH_Painter
The graphics object to paint with
sources
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' IGH_Param >)>)>
A list of sources that will be connected with the input grip of this attribute
styles
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Pen >)>)>
A collection of pen objects to use for each source. If a pen is null, the default wire style will be used instead.

See Also

GH_Attributes<(Of <(<'T>)>)> Class
RenderIncomingWires Overload
Grasshopper.Kernel Namespace


RenderToCanvas Method

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..RenderToCanvas Method
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback
Render these attributes into a Canvas control. This function places calls to PrepareForRender() and Render(), you should override those.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RenderToCanvas(
    GH_Canvas canvas,
    GH_CanvasChannel channel
)
Visual Basic
Public Sub RenderToCanvas ( _
    canvas As GH_Canvas, _
    channel As GH_CanvasChannel _
)

Parameters

canvas
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
Canvas to draw on.
channel
Type: Grasshopper.GUI.Canvas..::..GH_CanvasChannel
Current drawing channel.

Implements

IGH_Attributes..::..RenderToCanvas(GH_Canvas, GH_CanvasChannel)

See Also

GH_Attributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


RespondToKeyDown Method

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..RespondToKeyDown Method
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual GH_ObjectResponse RespondToKeyDown(
    GH_Canvas sender,
    KeyEventArgs e
)
Visual Basic
Public Overridable Function RespondToKeyDown ( _
    sender As GH_Canvas, _
    e As KeyEventArgs _
) As GH_ObjectResponse

Parameters

sender
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
e
Type: System.Windows.Forms..::..KeyEventArgs

Implements

IGH_ResponsiveObject..::..RespondToKeyDown(GH_Canvas, KeyEventArgs)

See Also

GH_Attributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


RespondToKeyUp Method

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..RespondToKeyUp Method
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual GH_ObjectResponse RespondToKeyUp(
    GH_Canvas sender,
    KeyEventArgs e
)
Visual Basic
Public Overridable Function RespondToKeyUp ( _
    sender As GH_Canvas, _
    e As KeyEventArgs _
) As GH_ObjectResponse

Parameters

sender
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
e
Type: System.Windows.Forms..::..KeyEventArgs

Implements

IGH_ResponsiveObject..::..RespondToKeyUp(GH_Canvas, KeyEventArgs)

See Also

GH_Attributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


RespondToMouseDoubleClick Method

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..RespondToMouseDoubleClick Method
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual GH_ObjectResponse RespondToMouseDoubleClick(
    GH_Canvas sender,
    GH_CanvasMouseEvent e
)
Visual Basic
Public Overridable Function RespondToMouseDoubleClick ( _
    sender As GH_Canvas, _
    e As GH_CanvasMouseEvent _
) As GH_ObjectResponse

Parameters

sender
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
e
Type: Grasshopper.GUI..::..GH_CanvasMouseEvent

Implements

IGH_ResponsiveObject..::..RespondToMouseDoubleClick(GH_Canvas, GH_CanvasMouseEvent)

See Also

GH_Attributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


RespondToMouseDown Method

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..RespondToMouseDown Method
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual GH_ObjectResponse RespondToMouseDown(
    GH_Canvas sender,
    GH_CanvasMouseEvent e
)
Visual Basic
Public Overridable Function RespondToMouseDown ( _
    sender As GH_Canvas, _
    e As GH_CanvasMouseEvent _
) As GH_ObjectResponse

Parameters

sender
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
e
Type: Grasshopper.GUI..::..GH_CanvasMouseEvent

Implements

IGH_ResponsiveObject..::..RespondToMouseDown(GH_Canvas, GH_CanvasMouseEvent)

See Also

GH_Attributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


RespondToMouseMove Method

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..RespondToMouseMove Method
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual GH_ObjectResponse RespondToMouseMove(
    GH_Canvas sender,
    GH_CanvasMouseEvent e
)
Visual Basic
Public Overridable Function RespondToMouseMove ( _
    sender As GH_Canvas, _
    e As GH_CanvasMouseEvent _
) As GH_ObjectResponse

Parameters

sender
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
e
Type: Grasshopper.GUI..::..GH_CanvasMouseEvent

Implements

IGH_ResponsiveObject..::..RespondToMouseMove(GH_Canvas, GH_CanvasMouseEvent)

See Also

GH_Attributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


RespondToMouseUp Method

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..RespondToMouseUp Method
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual GH_ObjectResponse RespondToMouseUp(
    GH_Canvas sender,
    GH_CanvasMouseEvent e
)
Visual Basic
Public Overridable Function RespondToMouseUp ( _
    sender As GH_Canvas, _
    e As GH_CanvasMouseEvent _
) As GH_ObjectResponse

Parameters

sender
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
e
Type: Grasshopper.GUI..::..GH_CanvasMouseEvent

Implements

IGH_ResponsiveObject..::..RespondToMouseUp(GH_Canvas, GH_CanvasMouseEvent)

See Also

GH_Attributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


SetupTooltip Method

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..SetupTooltip Method
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback
Populates the Grasshopper tooltip with all relevant data. If this function returns True, it is assumed that all possible fields have been filled out and the tooltip is ready for display.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual void SetupTooltip(
    PointF point,
    GH_TooltipDisplayEventArgs e
)
Visual Basic
Public Overridable Sub SetupTooltip ( _
    point As PointF, _
    e As GH_TooltipDisplayEventArgs _
)

Parameters

point
Type: System.Drawing..::..PointF
The pixel coordinate on the canvas of the cursor.
e
Type: Grasshopper.GUI..::..GH_TooltipDisplayEventArgs
Tooltip event arguments.

Implements

IGH_TooltipAwareObject..::..SetupTooltip(PointF, GH_TooltipDisplayEventArgs)

See Also

GH_Attributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Write Method

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..Write Method
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overridable Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

Implements

GH_ISerializable..::..Write(GH_IWriter)

See Also

GH_Attributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


GH_Attributes(T) Properties

[image] [image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)> Properties
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback

The GH_Attributes<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | AllowMessageBalloon | Gets a value indicating whether these attributes allow warning and error balloons to be drawn on top of them.
Public property | Bounds | Gets the rectangle that contains the active content of the attributes. Typically the Contents determine the active area for menus, tooltips etc. Attributes are not supposed to draw objects beyond the Bounds.
Public property | DocObject | Gets the owner object of these attributes.
Public property | GetTopLevel | Gets the top-level attributes of the attribute stack these attributes belong to.
Public property | HasInputGrip | Gets a value indicating whether or not these attributes have an input grip.
Public property | HasOutputGrip | Gets a value indicating whether or not these attributes have an output grip.
Public property | InputGrip | Gets the input grip location for these attributes. If HasInputGrip equals False, this point is meaningless.
Public property | InstanceGuid | Gets the instance ID of the document object that owns these attributes.
Public property | IsTopLevel | Gets whether these attributes are top_level (i.e. no Parent attributes)
Public property | OutputGrip | Gets the output grip location for these attributes. If HasOutputGrip equals False, this point is meaningless.
Public property | Owner | Gets the type-safe owner object of these attributes. This property is identical to the DocObject property.
Public property | Parent | Gets or sets the parent attributes. Top level attributes do not have parents.
Public property | PathName | Get a description of the location of these attributes within the local attribute stack.
Public property | Pivot | Gets or sets the pivot for these attributes. The pivot controls the general placement of the attributes. If you want to move the attributes, change the pivot location.
Public property | Selected | Gets or sets the selected state of the top-level attributes.
Public property | TooltipEnabled | Gets the tooltip enabled value. If False, no further tooltip functions will be called.

See Also

GH_Attributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


AllowMessageBalloon Property

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..AllowMessageBalloon Property
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback
Gets a value indicating whether these attributes allow warning and error balloons to be drawn on top of them.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool AllowMessageBalloon { get; }
Visual Basic
Public Overridable ReadOnly Property AllowMessageBalloon As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Attributes`1.AllowMessageBalloon"]

Implements

IGH_Attributes..::..AllowMessageBalloon

See Also

GH_Attributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Bounds Property

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..Bounds Property
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the rectangle that contains the active content of the attributes. Typically the Contents determine the active area for menus, tooltips etc. Attributes are not supposed to draw objects beyond the Bounds.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual RectangleF Bounds { get; set; }
Visual Basic
Public Overridable Property Bounds As RectangleF
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Attributes`1.Bounds"]

Implements

IGH_Attributes..::..Bounds

See Also

GH_Attributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


DocObject Property

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..DocObject Property
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the owner object of these attributes.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_DocumentObject DocObject { get; }
Visual Basic
Public ReadOnly Property DocObject As IGH_DocumentObject
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Attributes`1.DocObject"]

Implements

IGH_Attributes..::..DocObject

See Also

GH_Attributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


GetTopLevel Property

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..GetTopLevel Property
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the top-level attributes of the attribute stack these attributes belong to.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_Attributes GetTopLevel { get; }
Visual Basic
Public ReadOnly Property GetTopLevel As IGH_Attributes
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Attributes`1.GetTopLevel"]

Implements

IGH_Attributes..::..GetTopLevel

See Also

GH_Attributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


HasInputGrip Property

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..HasInputGrip Property
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback
Gets a value indicating whether or not these attributes have an input grip.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool HasInputGrip { get; }
Visual Basic
Public Overridable ReadOnly Property HasInputGrip As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Attributes`1.HasInputGrip"]

Implements

IGH_Attributes..::..HasInputGrip

See Also

GH_Attributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


HasOutputGrip Property

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..HasOutputGrip Property
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback
Gets a value indicating whether or not these attributes have an output grip.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool HasOutputGrip { get; }
Visual Basic
Public Overridable ReadOnly Property HasOutputGrip As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Attributes`1.HasOutputGrip"]

Implements

IGH_Attributes..::..HasOutputGrip

See Also

GH_Attributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


InputGrip Property

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..InputGrip Property
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the input grip location for these attributes. If HasInputGrip equals False, this point is meaningless.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual PointF InputGrip { get; }
Visual Basic
Public Overridable ReadOnly Property InputGrip As PointF
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Attributes`1.InputGrip"]

Implements

IGH_Attributes..::..InputGrip

See Also

GH_Attributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


InstanceGuid Property

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..InstanceGuid Property
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the instance ID of the document object that owns these attributes.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid InstanceGuid { get; }
Visual Basic
Public ReadOnly Property InstanceGuid As Guid
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Attributes`1.InstanceGuid"]

Implements

IGH_Attributes..::..InstanceGuid

See Also

GH_Attributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


IsTopLevel Property

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..IsTopLevel Property
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback
Gets whether these attributes are top_level (i.e. no Parent attributes)

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsTopLevel { get; }
Visual Basic
Public ReadOnly Property IsTopLevel As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Attributes`1.IsTopLevel"]

Implements

IGH_Attributes..::..IsTopLevel

See Also

GH_Attributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


OutputGrip Property

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..OutputGrip Property
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the output grip location for these attributes. If HasOutputGrip equals False, this point is meaningless.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual PointF OutputGrip { get; }
Visual Basic
Public Overridable ReadOnly Property OutputGrip As PointF
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Attributes`1.OutputGrip"]

Implements

IGH_Attributes..::..OutputGrip

See Also

GH_Attributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Owner Property

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..Owner Property
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the type-safe owner object of these attributes. This property is identical to the DocObject property.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public T Owner { get; }
Visual Basic
Public ReadOnly Property Owner As T
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Attributes`1.Owner"]

See Also

GH_Attributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Parent Property

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..Parent Property
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback
Gets or sets the parent attributes. Top level attributes do not have parents.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_Attributes Parent { get; set; }
Visual Basic
Public Property Parent As IGH_Attributes
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Attributes`1.Parent"]

Implements

IGH_Attributes..::..Parent

See Also

GH_Attributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


PathName Property

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..PathName Property
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback
Get a description of the location of these attributes within the local attribute stack.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual string PathName { get; }
Visual Basic
Public Overridable ReadOnly Property PathName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Attributes`1.PathName"]

Implements

IGH_Attributes..::..PathName

See Also

GH_Attributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Pivot Property

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..Pivot Property
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback
Gets or sets the pivot for these attributes. The pivot controls the general placement of the attributes. If you want to move the attributes, change the pivot location.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual PointF Pivot { get; set; }
Visual Basic
Public Overridable Property Pivot As PointF
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Attributes`1.Pivot"]

Implements

IGH_Attributes..::..Pivot

See Also

GH_Attributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Selected Property

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..Selected Property
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback
Gets or sets the selected state of the top-level attributes.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool Selected { get; set; }
Visual Basic
Public Overridable Property Selected As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Attributes`1.Selected"]

Implements

IGH_Attributes..::..Selected

See Also

GH_Attributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


TooltipEnabled Property

[image]

Grasshopper SDK
GH_Attributes<(Of <(<'T>)>)>..::..TooltipEnabled Property
GH_Attributes<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the tooltip enabled value. If False, no further tooltip functions will be called.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool TooltipEnabled { get; }
Visual Basic
Public Overridable ReadOnly Property TooltipEnabled As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Attributes`1.TooltipEnabled"]

Implements

IGH_TooltipAwareObject..::..TooltipEnabled

See Also

GH_Attributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


GH_AttributesChangedEventArgs Class

[image]

Grasshopper SDK
GH_AttributesChangedEventArgs Class
Members See Also Send Feedback
Event arguments passed during AttributesChanged events.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_AttributesChangedEventArgs : EventArgs
Visual Basic
Public Class GH_AttributesChangedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Grasshopper.Kernel..::..GH_AttributesChangedEventArgs

See Also

GH_AttributesChangedEventArgs Members
Grasshopper.Kernel Namespace


GH_AttributesChangedEventArgs Members

[image] [image]

Grasshopper SDK
GH_AttributesChangedEventArgs Members
GH_AttributesChangedEventArgs Class Constructors See Also Send Feedback

The GH_AttributesChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GH_AttributesChangedEventArgs | Initializes a new instance of the GH_AttributesChangedEventArgs class

See Also

GH_AttributesChangedEventArgs Class
Grasshopper.Kernel Namespace


GH_AttributesChangedEventArgs Constructor

[image]

Grasshopper SDK
GH_AttributesChangedEventArgs Constructor
GH_AttributesChangedEventArgs Class See Also Send Feedback
Initializes a new instance of the GH_AttributesChangedEventArgs class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_AttributesChangedEventArgs()
Visual Basic
Public Sub New

See Also

GH_AttributesChangedEventArgs Class
Grasshopper.Kernel Namespace


GH_Author Class

[image]

Grasshopper SDK
GH_Author Class
Members See Also Send Feedback
Maintains author information such as name, company, copyright, address etc.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Author : GH_ISerializable, IGH_Author
Visual Basic
Public Class GH_Author _
    Implements GH_ISerializable, IGH_Author

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_Author

See Also

GH_Author Members
Grasshopper.Kernel Namespace


GH_Author Members

[image] [image]

Grasshopper SDK
GH_Author Members
GH_Author Class Constructors Methods Properties See Also Send Feedback

The GH_Author type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Author()()()() | Initializes a new instance of the GH_Author class
Public method | GH_Author(IGH_Author) | Initializes a new instance of the GH_Author class

Methods

 | Name | Description
Public method | Clear | Erase all fields.
Public method | Read |
Public method | Write |

Properties

 | Name | Description
Public property | Address |
Public property | AddressReadonly |
Public property | Company |
Public property | CompanyReadonly |
Public property | Copyright |
Public property | CopyrightReadonly |
Public property | EMail |
Public property | EMailReadonly |
Public property | IsEmpty | Gets whether any of the fields have been assigned.
Public property | Name |
Public property | NameReadonly |
Public property | Phone |
Public property | PhoneReadonly |
Public property | Website |
Public property | WebsiteReadonly |

See Also

GH_Author Class
Grasshopper.Kernel Namespace


GH_Author Constructor

[image] [image]

Grasshopper SDK
GH_Author Constructor
GH_Author Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Author()()()() | Initializes a new instance of the GH_Author class
Public method | GH_Author(IGH_Author) | Initializes a new instance of the GH_Author class

See Also

GH_Author Class
GH_Author Members
Grasshopper.Kernel Namespace


GH_Author Constructor

[image]

Grasshopper SDK
GH_Author Constructor
GH_Author Class See Also Send Feedback
Initializes a new instance of the GH_Author class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Author()
Visual Basic
Public Sub New

See Also

GH_Author Class
GH_Author Overload
Grasshopper.Kernel Namespace


GH_Author Constructor (IGH_Author)

[image]

Grasshopper SDK
GH_Author Constructor (IGH_Author)
GH_Author Class See Also Send Feedback
Initializes a new instance of the GH_Author class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Author(
    IGH_Author other
)
Visual Basic
Public Sub New ( _
    other As IGH_Author _
)

Parameters

other
Type: Grasshopper.Kernel..::..IGH_Author

See Also

GH_Author Class
GH_Author Overload
Grasshopper.Kernel Namespace


GH_Author Methods

[image] [image]

Grasshopper SDK
GH_Author Methods
GH_Author Class See Also Send Feedback

The GH_Author type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Erase all fields.
Public method | Read |
Public method | Write |

See Also

GH_Author Class
Grasshopper.Kernel Namespace


Clear Method

[image]

Grasshopper SDK
GH_Author..::..Clear Method
GH_Author Class See Also Send Feedback
Erase all fields.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear

See Also

GH_Author Class
Grasshopper.Kernel Namespace


Read Method

[image]

Grasshopper SDK
GH_Author..::..Read Method
GH_Author Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Read(
    GH_IReader reader
)
Visual Basic
Public Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

Implements

GH_ISerializable..::..Read(GH_IReader)

See Also

GH_Author Class
Grasshopper.Kernel Namespace


Write Method

[image]

Grasshopper SDK
GH_Author..::..Write Method
GH_Author Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Write(
    GH_IWriter writer
)
Visual Basic
Public Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

Implements

GH_ISerializable..::..Write(GH_IWriter)

See Also

GH_Author Class
Grasshopper.Kernel Namespace


GH_Author Properties

[image] [image]

Grasshopper SDK
GH_Author Properties
GH_Author Class See Also Send Feedback

The GH_Author type exposes the following members.

Properties

 | Name | Description
Public property | Address |
Public property | AddressReadonly |
Public property | Company |
Public property | CompanyReadonly |
Public property | Copyright |
Public property | CopyrightReadonly |
Public property | EMail |
Public property | EMailReadonly |
Public property | IsEmpty | Gets whether any of the fields have been assigned.
Public property | Name |
Public property | NameReadonly |
Public property | Phone |
Public property | PhoneReadonly |
Public property | Website |
Public property | WebsiteReadonly |

See Also

GH_Author Class
Grasshopper.Kernel Namespace


Address Property

[image]

Grasshopper SDK
GH_Author..::..Address Property
GH_Author Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Address { get; set; }
Visual Basic
Public Property Address As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Author.Address"]

See Also

GH_Author Class
Grasshopper.Kernel Namespace


AddressReadonly Property

[image]

Grasshopper SDK
GH_Author..::..AddressReadonly Property
GH_Author Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string AddressReadonly { get; }
Visual Basic
Public ReadOnly Property AddressReadonly As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Author.AddressReadonly"]

Implements

IGH_Author..::..Address

See Also

GH_Author Class
Grasshopper.Kernel Namespace


Company Property

[image]

Grasshopper SDK
GH_Author..::..Company Property
GH_Author Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Company { get; set; }
Visual Basic
Public Property Company As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Author.Company"]

See Also

GH_Author Class
Grasshopper.Kernel Namespace


CompanyReadonly Property

[image]

Grasshopper SDK
GH_Author..::..CompanyReadonly Property
GH_Author Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string CompanyReadonly { get; }
Visual Basic
Public ReadOnly Property CompanyReadonly As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Author.CompanyReadonly"]

Implements

IGH_Author..::..Company

See Also

GH_Author Class
Grasshopper.Kernel Namespace


Copyright Property

[image]

Grasshopper SDK
GH_Author..::..Copyright Property
GH_Author Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Copyright { get; set; }
Visual Basic
Public Property Copyright As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Author.Copyright"]

See Also

GH_Author Class
Grasshopper.Kernel Namespace


CopyrightReadonly Property

[image]

Grasshopper SDK
GH_Author..::..CopyrightReadonly Property
GH_Author Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string CopyrightReadonly { get; }
Visual Basic
Public ReadOnly Property CopyrightReadonly As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Author.CopyrightReadonly"]

Implements

IGH_Author..::..Copyright

See Also

GH_Author Class
Grasshopper.Kernel Namespace


EMail Property

[image]

Grasshopper SDK
GH_Author..::..EMail Property
GH_Author Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string EMail { get; set; }
Visual Basic
Public Property EMail As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Author.EMail"]

See Also

GH_Author Class
Grasshopper.Kernel Namespace


EMailReadonly Property

[image]

Grasshopper SDK
GH_Author..::..EMailReadonly Property
GH_Author Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string EMailReadonly { get; }
Visual Basic
Public ReadOnly Property EMailReadonly As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Author.EMailReadonly"]

Implements

IGH_Author..::..Email

See Also

GH_Author Class
Grasshopper.Kernel Namespace


IsEmpty Property

[image]

Grasshopper SDK
GH_Author..::..IsEmpty Property
GH_Author Class See Also Send Feedback
Gets whether any of the fields have been assigned.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Author.IsEmpty"]

Implements

IGH_Author..::..IsEmpty

See Also

GH_Author Class
Grasshopper.Kernel Namespace


Name Property

[image]

Grasshopper SDK
GH_Author..::..Name Property
GH_Author Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Author.Name"]

See Also

GH_Author Class
Grasshopper.Kernel Namespace


NameReadonly Property

[image]

Grasshopper SDK
GH_Author..::..NameReadonly Property
GH_Author Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string NameReadonly { get; }
Visual Basic
Public ReadOnly Property NameReadonly As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Author.NameReadonly"]

Implements

IGH_Author..::..Name

See Also

GH_Author Class
Grasshopper.Kernel Namespace


Phone Property

[image]

Grasshopper SDK
GH_Author..::..Phone Property
GH_Author Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Phone { get; set; }
Visual Basic
Public Property Phone As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Author.Phone"]

See Also

GH_Author Class
Grasshopper.Kernel Namespace


PhoneReadonly Property

[image]

Grasshopper SDK
GH_Author..::..PhoneReadonly Property
GH_Author Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string PhoneReadonly { get; }
Visual Basic
Public ReadOnly Property PhoneReadonly As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Author.PhoneReadonly"]

Implements

IGH_Author..::..Phone

See Also

GH_Author Class
Grasshopper.Kernel Namespace


Website Property

[image]

Grasshopper SDK
GH_Author..::..Website Property
GH_Author Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Website { get; set; }
Visual Basic
Public Property Website As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Author.Website"]

See Also

GH_Author Class
Grasshopper.Kernel Namespace


WebsiteReadonly Property

[image]

Grasshopper SDK
GH_Author..::..WebsiteReadonly Property
GH_Author Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string WebsiteReadonly { get; }
Visual Basic
Public ReadOnly Property WebsiteReadonly As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Author.WebsiteReadonly"]

Implements

IGH_Author..::..Website

See Also

GH_Author Class
Grasshopper.Kernel Namespace


GH_AutoSaveSettings Class

[image]

Grasshopper SDK
GH_AutoSaveSettings Class
Members See Also Send Feedback
Provides access to all AutoSave event flags.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class GH_AutoSaveSettings
Visual Basic
Public NotInheritable Class GH_AutoSaveSettings

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_AutoSaveSettings

See Also

GH_AutoSaveSettings Members
Grasshopper.Kernel Namespace


GH_AutoSaveSettings Members

[image] [image]

Grasshopper SDK
GH_AutoSaveSettings Members
GH_AutoSaveSettings Class Constructors Methods Properties Events See Also Send Feedback

The GH_AutoSaveSettings type exposes the following members.

Constructors

 | Name | Description
Public method | GH_AutoSaveSettings | Initializes a new instance of the GH_AutoSaveSettings class

Methods

Name | Description
PerformAutosave | Tests a given trigger to see if it allows an autosave operation.

Properties

Name | Description
EnableAutoSave |
SaveOnDataFlattening |
SaveOnDocumentUnload |
SaveOnObjectAdded |
SaveOnObjectChange |
SaveOnObjectRemoved |
SaveOnWireEvent |

Events

Name | Description
AutoSaveFileFormatChanged |
EnableAutoSaveChanged |
SaveOnDataFlatteningChanged |
SaveOnDocumentUnloadChanged |
SaveOnObjectAddedChanged |
SaveOnObjectChangeChanged |
SaveOnObjectRemovedChanged |
SaveOnWireEventChanged |

See Also

GH_AutoSaveSettings Class
Grasshopper.Kernel Namespace


GH_AutoSaveSettings Constructor

[image]

Grasshopper SDK
GH_AutoSaveSettings Constructor
GH_AutoSaveSettings Class See Also Send Feedback
Initializes a new instance of the GH_AutoSaveSettings class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_AutoSaveSettings()
Visual Basic
Public Sub New

See Also

GH_AutoSaveSettings Class
Grasshopper.Kernel Namespace


GH_AutoSaveSettings Methods

[image] [image]

Grasshopper SDK
GH_AutoSaveSettings Methods
GH_AutoSaveSettings Class See Also Send Feedback

The GH_AutoSaveSettings type exposes the following members.

Methods

Name | Description
PerformAutosave | Tests a given trigger to see if it allows an autosave operation.

See Also

GH_AutoSaveSettings Class
Grasshopper.Kernel Namespace


PerformAutosave Method

[image]

Grasshopper SDK
GH_AutoSaveSettings..::..PerformAutosave Method
GH_AutoSaveSettings Class See Also Send Feedback
Tests a given trigger to see if it allows an autosave operation.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool PerformAutosave(
    GH_AutoSaveTrigger trigger
)
Visual Basic
Public Shared Function PerformAutosave ( _
    trigger As GH_AutoSaveTrigger _
) As Boolean

Parameters

trigger
Type: Grasshopper.Kernel..::..GH_AutoSaveTrigger
Trigger to filter.

Return Value

True if the trigger ought to start an AutoSave op.

See Also

GH_AutoSaveSettings Class
Grasshopper.Kernel Namespace


GH_AutoSaveSettings Properties

[image] [image]

Grasshopper SDK
GH_AutoSaveSettings Properties
GH_AutoSaveSettings Class See Also Send Feedback

The GH_AutoSaveSettings type exposes the following members.

Properties

Name | Description
EnableAutoSave |
SaveOnDataFlattening |
SaveOnDocumentUnload |
SaveOnObjectAdded |
SaveOnObjectChange |
SaveOnObjectRemoved |
SaveOnWireEvent |

See Also

GH_AutoSaveSettings Class
Grasshopper.Kernel Namespace


EnableAutoSave Property

[image]

Grasshopper SDK
GH_AutoSaveSettings..::..EnableAutoSave Property
GH_AutoSaveSettings Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool EnableAutoSave { get; set; }
Visual Basic
Public Shared Property EnableAutoSave As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_AutoSaveSettings.EnableAutoSave"]

See Also

GH_AutoSaveSettings Class
Grasshopper.Kernel Namespace


SaveOnDataFlattening Property

[image]

Grasshopper SDK
GH_AutoSaveSettings..::..SaveOnDataFlattening Property
GH_AutoSaveSettings Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool SaveOnDataFlattening { get; set; }
Visual Basic
Public Shared Property SaveOnDataFlattening As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_AutoSaveSettings.SaveOnDataFlattening"]

See Also

GH_AutoSaveSettings Class
Grasshopper.Kernel Namespace


SaveOnDocumentUnload Property

[image]

Grasshopper SDK
GH_AutoSaveSettings..::..SaveOnDocumentUnload Property
GH_AutoSaveSettings Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool SaveOnDocumentUnload { get; set; }
Visual Basic
Public Shared Property SaveOnDocumentUnload As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_AutoSaveSettings.SaveOnDocumentUnload"]

See Also

GH_AutoSaveSettings Class
Grasshopper.Kernel Namespace


SaveOnObjectAdded Property

[image]

Grasshopper SDK
GH_AutoSaveSettings..::..SaveOnObjectAdded Property
GH_AutoSaveSettings Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool SaveOnObjectAdded { get; set; }
Visual Basic
Public Shared Property SaveOnObjectAdded As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_AutoSaveSettings.SaveOnObjectAdded"]

See Also

GH_AutoSaveSettings Class
Grasshopper.Kernel Namespace


SaveOnObjectChange Property

[image]

Grasshopper SDK
GH_AutoSaveSettings..::..SaveOnObjectChange Property
GH_AutoSaveSettings Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool SaveOnObjectChange { get; set; }
Visual Basic
Public Shared Property SaveOnObjectChange As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_AutoSaveSettings.SaveOnObjectChange"]

See Also

GH_AutoSaveSettings Class
Grasshopper.Kernel Namespace


SaveOnObjectRemoved Property

[image]

Grasshopper SDK
GH_AutoSaveSettings..::..SaveOnObjectRemoved Property
GH_AutoSaveSettings Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool SaveOnObjectRemoved { get; set; }
Visual Basic
Public Shared Property SaveOnObjectRemoved As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_AutoSaveSettings.SaveOnObjectRemoved"]

See Also

GH_AutoSaveSettings Class
Grasshopper.Kernel Namespace


SaveOnWireEvent Property

[image]

Grasshopper SDK
GH_AutoSaveSettings..::..SaveOnWireEvent Property
GH_AutoSaveSettings Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool SaveOnWireEvent { get; set; }
Visual Basic
Public Shared Property SaveOnWireEvent As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_AutoSaveSettings.SaveOnWireEvent"]

See Also

GH_AutoSaveSettings Class
Grasshopper.Kernel Namespace


GH_AutoSaveSettings Events

[image] [image]

Grasshopper SDK
GH_AutoSaveSettings Events
GH_AutoSaveSettings Class See Also Send Feedback

The GH_AutoSaveSettings type exposes the following members.

Events

Name | Description
AutoSaveFileFormatChanged |
EnableAutoSaveChanged |
SaveOnDataFlatteningChanged |
SaveOnDocumentUnloadChanged |
SaveOnObjectAddedChanged |
SaveOnObjectChangeChanged |
SaveOnObjectRemovedChanged |
SaveOnWireEventChanged |

See Also

GH_AutoSaveSettings Class
Grasshopper.Kernel Namespace


AutoSaveFileFormatChanged Event

[image]

Grasshopper SDK
GH_AutoSaveSettings..::..AutoSaveFileFormatChanged Event
GH_AutoSaveSettings Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event GH_AutoSaveSettings..::..AutoSaveFileFormatChangedEventHandler AutoSaveFileFormatChanged
Visual Basic
Public Shared Event AutoSaveFileFormatChanged As GH_AutoSaveSettings..::..AutoSaveFileFormatChangedEventHandler

See Also

GH_AutoSaveSettings Class
Grasshopper.Kernel Namespace


EnableAutoSaveChanged Event

[image]

Grasshopper SDK
GH_AutoSaveSettings..::..EnableAutoSaveChanged Event
GH_AutoSaveSettings Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event GH_AutoSaveSettings..::..EnableAutoSaveChangedEventHandler EnableAutoSaveChanged
Visual Basic
Public Shared Event EnableAutoSaveChanged As GH_AutoSaveSettings..::..EnableAutoSaveChangedEventHandler

See Also

GH_AutoSaveSettings Class
Grasshopper.Kernel Namespace


SaveOnDataFlatteningChanged Event

[image]

Grasshopper SDK
GH_AutoSaveSettings..::..SaveOnDataFlatteningChanged Event
GH_AutoSaveSettings Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event GH_AutoSaveSettings..::..SaveOnDataFlatteningChangedEventHandler SaveOnDataFlatteningChanged
Visual Basic
Public Shared Event SaveOnDataFlatteningChanged As GH_AutoSaveSettings..::..SaveOnDataFlatteningChangedEventHandler

See Also

GH_AutoSaveSettings Class
Grasshopper.Kernel Namespace


SaveOnDocumentUnloadChanged Event

[image]

Grasshopper SDK
GH_AutoSaveSettings..::..SaveOnDocumentUnloadChanged Event
GH_AutoSaveSettings Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event GH_AutoSaveSettings..::..SaveOnDocumentUnloadChangedEventHandler SaveOnDocumentUnloadChanged
Visual Basic
Public Shared Event SaveOnDocumentUnloadChanged As GH_AutoSaveSettings..::..SaveOnDocumentUnloadChangedEventHandler

See Also

GH_AutoSaveSettings Class
Grasshopper.Kernel Namespace


SaveOnObjectAddedChanged Event

[image]

Grasshopper SDK
GH_AutoSaveSettings..::..SaveOnObjectAddedChanged Event
GH_AutoSaveSettings Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event GH_AutoSaveSettings..::..SaveOnObjectAddedChangedEventHandler SaveOnObjectAddedChanged
Visual Basic
Public Shared Event SaveOnObjectAddedChanged As GH_AutoSaveSettings..::..SaveOnObjectAddedChangedEventHandler

See Also

GH_AutoSaveSettings Class
Grasshopper.Kernel Namespace


SaveOnObjectChangeChanged Event

[image]

Grasshopper SDK
GH_AutoSaveSettings..::..SaveOnObjectChangeChanged Event
GH_AutoSaveSettings Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event GH_AutoSaveSettings..::..SaveOnObjectChangeChangedEventHandler SaveOnObjectChangeChanged
Visual Basic
Public Shared Event SaveOnObjectChangeChanged As GH_AutoSaveSettings..::..SaveOnObjectChangeChangedEventHandler

See Also

GH_AutoSaveSettings Class
Grasshopper.Kernel Namespace


SaveOnObjectRemovedChanged Event

[image]

Grasshopper SDK
GH_AutoSaveSettings..::..SaveOnObjectRemovedChanged Event
GH_AutoSaveSettings Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event GH_AutoSaveSettings..::..SaveOnObjectRemovedChangedEventHandler SaveOnObjectRemovedChanged
Visual Basic
Public Shared Event SaveOnObjectRemovedChanged As GH_AutoSaveSettings..::..SaveOnObjectRemovedChangedEventHandler

See Also

GH_AutoSaveSettings Class
Grasshopper.Kernel Namespace


SaveOnWireEventChanged Event

[image]

Grasshopper SDK
GH_AutoSaveSettings..::..SaveOnWireEventChanged Event
GH_AutoSaveSettings Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event GH_AutoSaveSettings..::..SaveOnWireEventChangedEventHandler SaveOnWireEventChanged
Visual Basic
Public Shared Event SaveOnWireEventChanged As GH_AutoSaveSettings..::..SaveOnWireEventChangedEventHandler

See Also

GH_AutoSaveSettings Class
Grasshopper.Kernel Namespace


GH_AutoSaveSettings.AutoSaveFileFormatChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_AutoSaveSettings..::..AutoSaveFileFormatChangedEventHandler Delegate
GH_AutoSaveSettings Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void AutoSaveFileFormatChangedEventHandler()
Visual Basic
Public Delegate Sub AutoSaveFileFormatChangedEventHandler

See Also

Grasshopper.Kernel Namespace


GH_AutoSaveSettings.EnableAutoSaveChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_AutoSaveSettings..::..EnableAutoSaveChangedEventHandler Delegate
GH_AutoSaveSettings Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void EnableAutoSaveChangedEventHandler()
Visual Basic
Public Delegate Sub EnableAutoSaveChangedEventHandler

See Also

Grasshopper.Kernel Namespace


GH_AutoSaveSettings.SaveOnDataFlatteningChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_AutoSaveSettings..::..SaveOnDataFlatteningChangedEventHandler Delegate
GH_AutoSaveSettings Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void SaveOnDataFlatteningChangedEventHandler()
Visual Basic
Public Delegate Sub SaveOnDataFlatteningChangedEventHandler

See Also

Grasshopper.Kernel Namespace


GH_AutoSaveSettings.SaveOnDocumentUnloadChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_AutoSaveSettings..::..SaveOnDocumentUnloadChangedEventHandler Delegate
GH_AutoSaveSettings Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void SaveOnDocumentUnloadChangedEventHandler()
Visual Basic
Public Delegate Sub SaveOnDocumentUnloadChangedEventHandler

See Also

Grasshopper.Kernel Namespace


GH_AutoSaveSettings.SaveOnObjectAddedChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_AutoSaveSettings..::..SaveOnObjectAddedChangedEventHandler Delegate
GH_AutoSaveSettings Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void SaveOnObjectAddedChangedEventHandler()
Visual Basic
Public Delegate Sub SaveOnObjectAddedChangedEventHandler

See Also

Grasshopper.Kernel Namespace


GH_AutoSaveSettings.SaveOnObjectChangeChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_AutoSaveSettings..::..SaveOnObjectChangeChangedEventHandler Delegate
GH_AutoSaveSettings Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void SaveOnObjectChangeChangedEventHandler()
Visual Basic
Public Delegate Sub SaveOnObjectChangeChangedEventHandler

See Also

Grasshopper.Kernel Namespace


GH_AutoSaveSettings.SaveOnObjectRemovedChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_AutoSaveSettings..::..SaveOnObjectRemovedChangedEventHandler Delegate
GH_AutoSaveSettings Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void SaveOnObjectRemovedChangedEventHandler()
Visual Basic
Public Delegate Sub SaveOnObjectRemovedChangedEventHandler

See Also

Grasshopper.Kernel Namespace


GH_AutoSaveSettings.SaveOnWireEventChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_AutoSaveSettings..::..SaveOnWireEventChangedEventHandler Delegate
GH_AutoSaveSettings Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void SaveOnWireEventChangedEventHandler()
Visual Basic
Public Delegate Sub SaveOnWireEventChangedEventHandler

See Also

Grasshopper.Kernel Namespace


GH_AutoSaveTrigger Enumeration

[image]

Grasshopper SDK
GH_AutoSaveTrigger Enumeration
See Also Send Feedback
Different types of events that can cause an AutoSave.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_AutoSaveTrigger
Visual Basic
Public Enumeration GH_AutoSaveTrigger

Members

Member name | Value | Description
undefined | 0 | Generic autosave trigger, this flag is not filtered.
doc_unload | 1 | Autosave was triggered by a document being unloaded from a Canvas Context.
object_added | 2 | Autosave was triggered by the addition of an object to the document.
object_removed | 3 | Autosave was triggered by the removal of an object from the document.
wire_event | 4 | Autosave was triggered by a change in connector wires.
data_matching_event | 5 | Autosave was triggered by a change to Data Matching settings.
data_modification_event | 6 | Autosave was triggered by a change to Data modifier settings.
object_generic | 7 | Autosave was triggered by a non-trivial change to object data or settings.

See Also

Grasshopper.Kernel Namespace


GH_BitmapChannel Enumeration

[image]

Grasshopper SDK
GH_BitmapChannel Enumeration
See Also Send Feedback
Lists all possible channels for 24 and 32 bit bitmaps.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
[FlagsAttribute]
public enum GH_BitmapChannel
Visual Basic
<FlagsAttribute> _
Public Enumeration GH_BitmapChannel

Members

Member name | Value | Description
A | 1 | Alpha channel, not all bitmaps support this.
R | 2 | Red channel.
G | 4 | Green channel.
B | 8 | Blue channel.
RGB | 14 | Red, Green and Blue channel mashup.
ARGB | 15 | Alpha, Red, Green and Blue channel mashup.

See Also

Grasshopper.Kernel Namespace


GH_ClipboardType Enumeration

[image]

Grasshopper SDK
GH_ClipboardType Enumeration
See Also Send Feedback
Enumerates all possible clipboards for GH_DocumentIO operations.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_ClipboardType
Visual Basic
Public Enumeration GH_ClipboardType

Members

Member name | Value | Description
System | 0 | Identifies the Operating System clipboard shared amongst all applications.
Local | 1 | Identifies the DocumentIO clipboard which is only accessible from within a single instance of GH_DocumentIO.
Global | 2 | Identifies the DocumentIO clipboard which is accessible from all instances of GH_DocumentIO in this AppDomain.

See Also

Grasshopper.Kernel Namespace


GH_Component Class

[image]

Grasshopper SDK
GH_Component Class
Members See Also Send Feedback
Inherit from this class if you wish to create a custom component. Note that you must provide a public, empty constructor which calls the base class constructor.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract class GH_Component : GH_ActiveObject,
    IGH_Component
Visual Basic
Public MustInherit Class GH_Component _
    Inherits GH_ActiveObject _
    Implements IGH_Component

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_InstanceDescription
Grasshopper.Kernel..::..GH_DocumentObject
Grasshopper.Kernel..::..GH_ActiveObject
Grasshopper.Kernel..::..GH_Component

See Also

GH_Component Members
Grasshopper.Kernel Namespace


GH_Component Members

[image] [image]

Grasshopper SDK
GH_Component Members
GH_Component Class Methods Fields Properties Events See Also Send Feedback

The GH_Component type exposes the following members.

Methods

 | Name | Description
Public method | AddedToDocument | Overrides the AddedToDocument method and delegates the call to all parameters. (Overrides GH_DocumentObject..::..AddedToDocument(GH_Document).)
Public method | AddRuntimeMessage | Add a new message to this object. Valid message type flags are Warning and Error. If the Message string is empty or zero-length no message is added. (Inherited from GH_ActiveObject.)
Protected method | AfterSolveInstance | Override this method if you want to be called after the last call to SolveInstance.
Protected method | AppendAdditionalComponentMenuItems | Override this function if you want to insert some custom menu items in your derived Component class. Items will be added between List Matching items and parameter menus.
Public method | AppendAdditionalMenuItems | Adds typical component type items to the context menu: 1. Data comparison types 2. Custom (overridden) items 3. Nested input parameter context menu items 4. Nested output parameter context menu items (Overrides GH_ActiveObject..::..AppendAdditionalMenuItems(ToolStripDropDown).)
Public method | AppendMenuItems | This function is called when a context menu is about to be displayed. Override it to set custom items. GH_ActiveObject will already populate the menu with default items, if you merely wish to insert object-specific menu item, consider overriding AppendAdditionalMenuItems instead. (Inherited from GH_ActiveObject.)
Protected method | AssignInitCodeToInputParameter | Utility function for parsing and assigning init codes. This only works for standard parameter types.
Public method | BakeGeometry(RhinoDoc, List<(Of <<'(Guid>)>>)) |
Public method | BakeGeometry(RhinoDoc, ObjectAttributes, List<(Of <<'(Guid>)>>)) |
Protected method | BeforeSolveInstance | Override this method if you want to be called before the first call to SolveInstance.
Public method | ClearData | Clear the data inside this component and all output parameters. (Overrides GH_ActiveObject..::..ClearData()()()().)
Public method | ClearRuntimeMessages | Clears all runtime messages in me and my parameters (Overrides GH_ActiveObject..::..ClearRuntimeMessages()()()().)
Public method | CollectData | Calls CollectData on all input parameters and makes sure the Component and all associated parameters are left in a valid state. (Overrides GH_ActiveObject..::..CollectData()()()().)
Public method | ComputeData | Compute all data and fill out all output parameters. (Overrides GH_ActiveObject..::..ComputeData()()()().)
Public method | CopyFrom | Copy all fields (except the instance ID) from another instance description. (Inherited from GH_InstanceDescription.)
Public method | CreateAttributes | Create new attributes. (Overrides GH_DocumentObject..::..CreateAttributes()()()().)
Public method | DependsOn | Returns True is any one of my input parameters depends on the source. (Overrides GH_ActiveObject..::..DependsOn(IGH_ActiveObject).)
Protected method | DestroyIconCache | Call this method to erase the existing icon cache. You must call this if you want to change the display icon of an object. (Inherited from GH_DocumentObject.)
 | DocumentAngleTolerance | Gets the Angle tolerance (in radians) for the currently active Rhino document.
Public method | DocumentContextChanged | Overrides the DocumentContextChanged method and delegates the call to all parameters. (Overrides GH_DocumentObject..::..DocumentContextChanged(GH_Document, GH_DocumentContext).)
 | DocumentTolerance | Gets the Absolute tolerance for the currently active Rhino document.
Public method | DrawViewportMeshes | Draw preview meshes for this component and all associated parameters.
Public method | DrawViewportWires | Draw preview wires for this component and all associated parameters.
Protected method | ExpireDownStreamObjects | Expire all objects that depend on any of the output parameters. (Overrides GH_ActiveObject..::..ExpireDownStreamObjects()()()().)
Public method | ExpirePreview | Call this function when you suspect that the preview has expired for this object. This will cause the display cache to be eradicated. (Inherited from GH_DocumentObject.)
Public method | ExpireSolution | Informs the document that owns this object that the solution has expired. The current object will be set to BLANK as a result. This method is recursive, it will also expire any and all objects which depend on this object. If you want a less destructive expiration, consider using ClearData(). If this object is already Blank, you should consider not expiring it. (Inherited from GH_ActiveObject.)
Protected method | GenerateDefaultHTML | Creates the default component help topic, including all parameter lists.
Protected method | GenerateParameterHelp()()()() | Create an HTML string that lists names and descriptions for input and output parameters.
Protected method | GenerateParameterHelp(IGH_Param) | Generate HTML string for a single parameter.
Protected method | GetValue(String, Boolean) | Get a boolean value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Double) | Get a double value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Color) | Get a color value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Int32) | Get an integer value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, String) | Get a string value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | HtmlHelp_Source | Return a String which contains HTML formatted source for the help topic. If you want to pass a URL that points to a remote page, then prefix the URL with a GOTO: tag, like so: GOTO:http://www.YourWebAddressHere.com (Overrides GH_DocumentObject..::..HtmlHelp_Source()()()().)
Public method | IsolateObject | Sever the connections of all input and output parameters. (Overrides GH_DocumentObject..::..IsolateObject()()()().)
Protected method | Menu_AppendBakeItem | Append the default Bake menu item. (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendEnableItem | Append the default Enable/Disable menu item. (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendObjectHelp | Appends the default object Help menu item. (Inherited from GH_DocumentObject.)
Protected method | Menu_AppendObjectName | Appends the old-fashioned object name menu item. If you also want the Display mode toggle then use Menu_AppendObjectNameEx() (Inherited from GH_DocumentObject.)
Protected method | Menu_AppendObjectNameEx | Appends the default object name + display mode menu item. (Inherited from GH_DocumentObject.)
Protected method | Menu_AppendPreviewItem | Append the default Show/Hide preview menu item. (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendRuntimeMessages | Append the default warnings and errors menu items. (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendWarningsAndErrors | Obsolete. This method is obsolete and has been replaced with Menu_AppendRuntimeMessages(). (Inherited from GH_ActiveObject.)
Public method | MovedBetweenDocuments | Overrides the MovedBetweenDocuments method and delegates the call to all parameters. (Overrides GH_DocumentObject..::..MovedBetweenDocuments(GH_Document, GH_Document).)
Public method | NewInstanceGuid()()()() | Generate a new random instance GUID (Inherited from GH_InstanceDescription.)
Public method | NewInstanceGuid(Guid) | Set the instance ID to be a specific GUID. This is very dangerous, only use this function if you're 6"4' and your first name is David. (Inherited from GH_InstanceDescription.)
Public method | OnAttributesChanged | Raises the AttributesChanged event on the toplevel object. (Inherited from GH_DocumentObject.)
Public method | OnDisplayExpired | Raises the DisplayExpired event on the toplevel object. (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(String) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectChangedEventArgs) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(String, Object) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType, Object) | (Inherited from GH_DocumentObject.)
Public method | OnPingDocument | Raise the PingDocument Event on the toplevel object and try to find the document which owns this object. (Inherited from GH_DocumentObject.)
Public method | OnPreviewExpired | Raises the PreviewExpired event on the toplevel object. (Inherited from GH_DocumentObject.)
Public method | OnSolutionExpired | Raises the SolutionExpired event on the toplevel object. You probably want to call ExpireSolution() instead of this method directly. (Inherited from GH_DocumentObject.)
Protected method | PostConstructor | The PostConstructor is called from within each constructor. DO NOT OVERRIDE THIS unless you know what you are doing.
Public method | Read | Read all required data for deserialization from an IO archive. (Overrides GH_ActiveObject..::..Read(GH_IReader).)
Public method | ReadFull | GH_InstanceDescription does not by default serialize all fields. Use this function to read all fields from the archive. This method is compatible with the default Write()/Read() operations. (Inherited from GH_InstanceDescription.)
Public method | RecordUndoEvent(String) | Record a generic object change undo event. (Inherited from GH_DocumentObject.)
Public method | RecordUndoEvent(GH_UndoRecord) | Record an entire undo record. (Inherited from GH_DocumentObject.)
Public method | RecordUndoEvent(String, IGH_UndoAction) | Record a specific object change undo event. (Inherited from GH_DocumentObject.)
Protected method | RegisterInputParams | Declare all your input parameters here.
Protected method | RegisterOutputParams | Declare all your output parameters here.
Public method | RegisterRemoteIDs | Registers all my input parameters with the UUID_LookUpTable (Overrides GH_ActiveObject..::..RegisterRemoteIDs(GH_GuidTable).)
Public method | RemovedFromDocument | Overrides the RemovedFromDocument method and delegates the call to all parameters. (Overrides GH_DocumentObject..::..RemovedFromDocument(GH_Document).)
Public method | RuntimeMessages | Gets the list of cached runtime messages that were recorded during solver-time processes. For components, the set of runtime messages also includes input and output parameters. (Overrides GH_ActiveObject..::..RuntimeMessages(GH_RuntimeMessageLevel).)
Public method | SDKCompliancy | Test whether this object is compliant with a given Rhino version. (Inherited from GH_ActiveObject.)
Public method | SetIconOverride | Set a new custom icon override for this object. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Boolean) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Double) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Color) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Int32) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, String) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SolveInstance | This function will be called (successively) from within the ComputeData method of this component.
Public method | TriggerAutoSave()()()() | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(Guid) | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger, Guid) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from GH_DocumentObject.)
Protected method | ValuesChanged | Override this method if you want to respond to changes to the value table. The base implementation is empty, so you don't have to call it. (Inherited from GH_DocumentObject.)
Public method | Write | Write all required data for deserialization to an IO archive. (Overrides GH_ActiveObject..::..Write(GH_IWriter).)
Public method | WriteFull | GH_InstanceDescription does not by default serialize all fields. Use this function to write all fields to the archive. This method is compatible with the default Write()/Read() operations. (Inherited from GH_InstanceDescription.)

Fields

 | Name | Description
Protected field | m_attributes | (Inherited from GH_DocumentObject.)

Properties

 | Name | Description
Public property | Attributes | Gets or sets the attributes that are associated with this object. Only set custom attributes if you know what you are doing. (Inherited from GH_DocumentObject.)
Public property | Category | Gets or sets the Category in which this object belongs. If HasCategory() returns false, this field has no meaning. (Inherited from GH_InstanceDescription.)
Public property | ClippingBox | Gets the clipping box for all preview geometry drawn by this component and all associated parameters.
Public property | ComponentGuid | Returns a consistent ID for this object type. Every object must supply a unique and unchanging ID that is used to identify objects of the same type. (Inherited from GH_DocumentObject.)
Public property | DataComparison | Obsolete. Gets or sets the data matching algorithm for this component
Public property | Description | Gets or sets the description of the object. This field typically remains fixed during the lifetime of an object. (Inherited from GH_InstanceDescription.)
Public property | Exposure | Gets the exposure of this object in the Graphical User Interface. The default is to expose everywhere. (Inherited from GH_DocumentObject.)
Public property | HasCategory | Gets whether or not the Category field has been set. (Inherited from GH_InstanceDescription.)
Public property | HasSubCategory | Gets whether or not the SubCategory field has been set. (Inherited from GH_InstanceDescription.)
Protected property | HelpDescription | Override this method if you want the help topic content to be more than the Component description.
Public property | Hidden | Gets or sets the hidden flag for this component. Does not affect Hidden flags on parameters associated with this component.
Protected property | Icon | Override this function to supply a custom icon (24x24 pixels). The result of this property is cached, so don't worry if icon retrieval is not very fast. (Inherited from GH_DocumentObject.)
Public property | Icon_24x24 | The icon associated with this object. (Inherited from GH_DocumentObject.)
Public property | Icon_24x24_Locked | The greyscale icon of this object. (Inherited from GH_DocumentObject.)
Public property | IconCapableUI | By default the NickName menu item supports the Icon Mode override toggle. If your UI is not capable of displaying icons, then override this property and return False. (Inherited from GH_ActiveObject.)
Public property | IconDisplayMode | Gets the current display mode of the object. (Inherited from GH_DocumentObject.)
Public property | InConstructor | Gets the constructor flag for this instance. If InConstructor = True, it means the component is still registering parameters and the layout is not yet complete.
Public property | InstanceDescription | (Overrides GH_InstanceDescription..::..InstanceDescription.)
Public property | InstanceGuid | Gets the ID of this runtime instance. (Inherited from GH_InstanceDescription.)
Public property | IsBakeCapable |
Public property | IsDataProvider | Components are never Data providers. Only the output parameters can be considered to be providers. (Overrides GH_ActiveObject..::..IsDataProvider.)
Public property | IsPreviewCapable | If a single parameter is PreviewCapable, so is the component. Override this property if you need special Preview flags.
Public property | IsValidPrincipalParameterIndex | Gets whether the MasterParameterIndex property identifies a valid parameter.
Public property | Keywords | Gets a list of additional keywords that describe the object. Typically this list is empty but you can override this property to aid in object searches. (Inherited from GH_InstanceDescription.)
Public property | Locked | Gets or sets the Locked state for this Component. This also sets locked states for all input and output parameters. (Overrides GH_ActiveObject..::..Locked.)
Public property | Message | Gets or sets a custom message to be displayed underneath the component. This message is not serialized and should be assigned on every solution anew.
Public property | MutableNickName | Gets or sets a value that enables Nick name changes through the menu. The default is TRUE. (Inherited from GH_ActiveObject.)
Public property | Name | Gets or sets the name of the object. This field typically remains fixed during the lifetime of an object. (Inherited from GH_InstanceDescription.)
Public property | NickName | Gets or sets the nickname of the object. This field can be changed by the user. (Inherited from GH_InstanceDescription.)
Public property | Obsolete | Gets whether this object is obsolete. Default implementation returns true if the class name contains the string "OBSOLETE" or if this class has been decorated with the ObsoleteAttribute. You are free to override this if you want, but I suggest adding the ObsoleteAttribute instead. (Inherited from GH_DocumentObject.)
Public property | Params | Gets the parameter manager object for this component.
Public property | Phase | Gets or sets the solution phase this object is currenly in. (Inherited from GH_ActiveObject.)
Public property | PrincipalParameterIndex | Gets or sets the principal parameter index override. Negative indices or indices larger than or equal to the input parameter count will be ignored and regular principal parameter detection will kick in.
Public property | ProcessorTime | Gets the total processor time (profiler) spend by this component and all input parameters. (Overrides GH_ActiveObject..::..ProcessorTime.)
Public property | RuntimeMessageLevel | Returns the worst case runtime warning level of me and all my parameters (Overrides GH_ActiveObject..::..RuntimeMessageLevel.)
Public property | SubCategory | Gets or sets the SubCategory in which this object belongs. If HasSubCategory() returns false, this field has no meaning. (Inherited from GH_InstanceDescription.)

Events

 | Name | Description
Public event | AttributesChanged | Raised whenever the number or kind of attributes changes. This event is handled by GH_Documents who subsequently wipe their attribute caches. (Inherited from GH_DocumentObject.)
Public event | DisplayExpired | Raised whenever the display (on the Canvas) of a certain object becomes invalid. (Inherited from GH_DocumentObject.)
Public event | ObjectChanged | (Inherited from GH_DocumentObject.)
Public event | PingDocument | Raised whenever an object needs to know which GH_Document it belongs to. (Inherited from GH_DocumentObject.)
Public event | PreviewExpired | Raised whenever the display (in the Rhino viewports) of a certain object becomes invalid. (Inherited from GH_DocumentObject.)
Public event | SolutionExpired | Raised whenever the solution of a certain object becomes invalid. (Inherited from GH_DocumentObject.)

See Also

GH_Component Class
Grasshopper.Kernel Namespace


GH_Component Fields

[image] [image]

Grasshopper SDK
GH_Component Fields
GH_Component Class See Also Send Feedback

The GH_Component type exposes the following members.

Fields

 | Name | Description
Protected field | m_attributes | (Inherited from GH_DocumentObject.)

See Also

GH_Component Class
Grasshopper.Kernel Namespace


GH_Component Methods

[image] [image]

Grasshopper SDK
GH_Component Methods
GH_Component Class See Also Send Feedback

The GH_Component type exposes the following members.

Methods

 | Name | Description
Public method | AddedToDocument | Overrides the AddedToDocument method and delegates the call to all parameters. (Overrides GH_DocumentObject..::..AddedToDocument(GH_Document).)
Public method | AddRuntimeMessage | Add a new message to this object. Valid message type flags are Warning and Error. If the Message string is empty or zero-length no message is added. (Inherited from GH_ActiveObject.)
Protected method | AfterSolveInstance | Override this method if you want to be called after the last call to SolveInstance.
Protected method | AppendAdditionalComponentMenuItems | Override this function if you want to insert some custom menu items in your derived Component class. Items will be added between List Matching items and parameter menus.
Public method | AppendAdditionalMenuItems | Adds typical component type items to the context menu: 1. Data comparison types 2. Custom (overridden) items 3. Nested input parameter context menu items 4. Nested output parameter context menu items (Overrides GH_ActiveObject..::..AppendAdditionalMenuItems(ToolStripDropDown).)
Public method | AppendMenuItems | This function is called when a context menu is about to be displayed. Override it to set custom items. GH_ActiveObject will already populate the menu with default items, if you merely wish to insert object-specific menu item, consider overriding AppendAdditionalMenuItems instead. (Inherited from GH_ActiveObject.)
Protected method | AssignInitCodeToInputParameter | Utility function for parsing and assigning init codes. This only works for standard parameter types.
Public method | BakeGeometry(RhinoDoc, List<(Of <<'(Guid>)>>)) |
Public method | BakeGeometry(RhinoDoc, ObjectAttributes, List<(Of <<'(Guid>)>>)) |
Protected method | BeforeSolveInstance | Override this method if you want to be called before the first call to SolveInstance.
Public method | ClearData | Clear the data inside this component and all output parameters. (Overrides GH_ActiveObject..::..ClearData()()()().)
Public method | ClearRuntimeMessages | Clears all runtime messages in me and my parameters (Overrides GH_ActiveObject..::..ClearRuntimeMessages()()()().)
Public method | CollectData | Calls CollectData on all input parameters and makes sure the Component and all associated parameters are left in a valid state. (Overrides GH_ActiveObject..::..CollectData()()()().)
Public method | ComputeData | Compute all data and fill out all output parameters. (Overrides GH_ActiveObject..::..ComputeData()()()().)
Public method | CopyFrom | Copy all fields (except the instance ID) from another instance description. (Inherited from GH_InstanceDescription.)
Public method | CreateAttributes | Create new attributes. (Overrides GH_DocumentObject..::..CreateAttributes()()()().)
Public method | DependsOn | Returns True is any one of my input parameters depends on the source. (Overrides GH_ActiveObject..::..DependsOn(IGH_ActiveObject).)
Protected method | DestroyIconCache | Call this method to erase the existing icon cache. You must call this if you want to change the display icon of an object. (Inherited from GH_DocumentObject.)
 | DocumentAngleTolerance | Gets the Angle tolerance (in radians) for the currently active Rhino document.
Public method | DocumentContextChanged | Overrides the DocumentContextChanged method and delegates the call to all parameters. (Overrides GH_DocumentObject..::..DocumentContextChanged(GH_Document, GH_DocumentContext).)
 | DocumentTolerance | Gets the Absolute tolerance for the currently active Rhino document.
Public method | DrawViewportMeshes | Draw preview meshes for this component and all associated parameters.
Public method | DrawViewportWires | Draw preview wires for this component and all associated parameters.
Protected method | ExpireDownStreamObjects | Expire all objects that depend on any of the output parameters. (Overrides GH_ActiveObject..::..ExpireDownStreamObjects()()()().)
Public method | ExpirePreview | Call this function when you suspect that the preview has expired for this object. This will cause the display cache to be eradicated. (Inherited from GH_DocumentObject.)
Public method | ExpireSolution | Informs the document that owns this object that the solution has expired. The current object will be set to BLANK as a result. This method is recursive, it will also expire any and all objects which depend on this object. If you want a less destructive expiration, consider using ClearData(). If this object is already Blank, you should consider not expiring it. (Inherited from GH_ActiveObject.)
Protected method | GenerateDefaultHTML | Creates the default component help topic, including all parameter lists.
Protected method | GenerateParameterHelp()()()() | Create an HTML string that lists names and descriptions for input and output parameters.
Protected method | GenerateParameterHelp(IGH_Param) | Generate HTML string for a single parameter.
Protected method | GetValue(String, Boolean) | Get a boolean value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Double) | Get a double value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Color) | Get a color value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Int32) | Get an integer value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, String) | Get a string value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | HtmlHelp_Source | Return a String which contains HTML formatted source for the help topic. If you want to pass a URL that points to a remote page, then prefix the URL with a GOTO: tag, like so: GOTO:http://www.YourWebAddressHere.com (Overrides GH_DocumentObject..::..HtmlHelp_Source()()()().)
Public method | IsolateObject | Sever the connections of all input and output parameters. (Overrides GH_DocumentObject..::..IsolateObject()()()().)
Protected method | Menu_AppendBakeItem | Append the default Bake menu item. (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendEnableItem | Append the default Enable/Disable menu item. (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendObjectHelp | Appends the default object Help menu item. (Inherited from GH_DocumentObject.)
Protected method | Menu_AppendObjectName | Appends the old-fashioned object name menu item. If you also want the Display mode toggle then use Menu_AppendObjectNameEx() (Inherited from GH_DocumentObject.)
Protected method | Menu_AppendObjectNameEx | Appends the default object name + display mode menu item. (Inherited from GH_DocumentObject.)
Protected method | Menu_AppendPreviewItem | Append the default Show/Hide preview menu item. (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendRuntimeMessages | Append the default warnings and errors menu items. (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendWarningsAndErrors | Obsolete. This method is obsolete and has been replaced with Menu_AppendRuntimeMessages(). (Inherited from GH_ActiveObject.)
Public method | MovedBetweenDocuments | Overrides the MovedBetweenDocuments method and delegates the call to all parameters. (Overrides GH_DocumentObject..::..MovedBetweenDocuments(GH_Document, GH_Document).)
Public method | NewInstanceGuid()()()() | Generate a new random instance GUID (Inherited from GH_InstanceDescription.)
Public method | NewInstanceGuid(Guid) | Set the instance ID to be a specific GUID. This is very dangerous, only use this function if you're 6"4' and your first name is David. (Inherited from GH_InstanceDescription.)
Public method | OnAttributesChanged | Raises the AttributesChanged event on the toplevel object. (Inherited from GH_DocumentObject.)
Public method | OnDisplayExpired | Raises the DisplayExpired event on the toplevel object. (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(String) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectChangedEventArgs) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(String, Object) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType, Object) | (Inherited from GH_DocumentObject.)
Public method | OnPingDocument | Raise the PingDocument Event on the toplevel object and try to find the document which owns this object. (Inherited from GH_DocumentObject.)
Public method | OnPreviewExpired | Raises the PreviewExpired event on the toplevel object. (Inherited from GH_DocumentObject.)
Public method | OnSolutionExpired | Raises the SolutionExpired event on the toplevel object. You probably want to call ExpireSolution() instead of this method directly. (Inherited from GH_DocumentObject.)
Protected method | PostConstructor | The PostConstructor is called from within each constructor. DO NOT OVERRIDE THIS unless you know what you are doing.
Public method | Read | Read all required data for deserialization from an IO archive. (Overrides GH_ActiveObject..::..Read(GH_IReader).)
Public method | ReadFull | GH_InstanceDescription does not by default serialize all fields. Use this function to read all fields from the archive. This method is compatible with the default Write()/Read() operations. (Inherited from GH_InstanceDescription.)
Public method | RecordUndoEvent(String) | Record a generic object change undo event. (Inherited from GH_DocumentObject.)
Public method | RecordUndoEvent(GH_UndoRecord) | Record an entire undo record. (Inherited from GH_DocumentObject.)
Public method | RecordUndoEvent(String, IGH_UndoAction) | Record a specific object change undo event. (Inherited from GH_DocumentObject.)
Protected method | RegisterInputParams | Declare all your input parameters here.
Protected method | RegisterOutputParams | Declare all your output parameters here.
Public method | RegisterRemoteIDs | Registers all my input parameters with the UUID_LookUpTable (Overrides GH_ActiveObject..::..RegisterRemoteIDs(GH_GuidTable).)
Public method | RemovedFromDocument | Overrides the RemovedFromDocument method and delegates the call to all parameters. (Overrides GH_DocumentObject..::..RemovedFromDocument(GH_Document).)
Public method | RuntimeMessages | Gets the list of cached runtime messages that were recorded during solver-time processes. For components, the set of runtime messages also includes input and output parameters. (Overrides GH_ActiveObject..::..RuntimeMessages(GH_RuntimeMessageLevel).)
Public method | SDKCompliancy | Test whether this object is compliant with a given Rhino version. (Inherited from GH_ActiveObject.)
Public method | SetIconOverride | Set a new custom icon override for this object. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Boolean) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Double) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Color) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Int32) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, String) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SolveInstance | This function will be called (successively) from within the ComputeData method of this component.
Public method | TriggerAutoSave()()()() | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(Guid) | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger, Guid) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from GH_DocumentObject.)
Protected method | ValuesChanged | Override this method if you want to respond to changes to the value table. The base implementation is empty, so you don't have to call it. (Inherited from GH_DocumentObject.)
Public method | Write | Write all required data for deserialization to an IO archive. (Overrides GH_ActiveObject..::..Write(GH_IWriter).)
Public method | WriteFull | GH_InstanceDescription does not by default serialize all fields. Use this function to write all fields to the archive. This method is compatible with the default Write()/Read() operations. (Inherited from GH_InstanceDescription.)

See Also

GH_Component Class
Grasshopper.Kernel Namespace


AddedToDocument Method

[image]

Grasshopper SDK
GH_Component..::..AddedToDocument Method
GH_Component Class See Also Send Feedback
Overrides the AddedToDocument method and delegates the call to all parameters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void AddedToDocument(
    GH_Document document
)
Visual Basic
Public Overrides Sub AddedToDocument ( _
    document As GH_Document _
)

Parameters

document
Type: Grasshopper.Kernel..::..GH_Document
Document that now owns this object.

See Also

GH_Component Class
Grasshopper.Kernel Namespace


AfterSolveInstance Method

[image]

Grasshopper SDK
GH_Component..::..AfterSolveInstance Method
GH_Component Class See Also Send Feedback
Override this method if you want to be called after the last call to SolveInstance.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected virtual void AfterSolveInstance()
Visual Basic
Protected Overridable Sub AfterSolveInstance

See Also

GH_Component Class
Grasshopper.Kernel Namespace


AppendAdditionalComponentMenuItems Method

[image]

Grasshopper SDK
GH_Component..::..AppendAdditionalComponentMenuItems Method
GH_Component Class See Also Send Feedback
Override this function if you want to insert some custom menu items in your derived Component class. Items will be added between List Matching items and parameter menus.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected virtual void AppendAdditionalComponentMenuItems(
    ToolStripDropDown menu
)
Visual Basic
Protected Overridable Sub AppendAdditionalComponentMenuItems ( _
    menu As ToolStripDropDown _
)

Parameters

menu
Type: System.Windows.Forms..::..ToolStripDropDown

See Also

GH_Component Class
Grasshopper.Kernel Namespace


AppendAdditionalMenuItems Method

[image]

Grasshopper SDK
GH_Component..::..AppendAdditionalMenuItems Method
GH_Component Class See Also Send Feedback
Adds typical component type items to the context menu: 1. Data comparison types 2. Custom (overridden) items 3. Nested input parameter context menu items 4. Nested output parameter context menu items

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void AppendAdditionalMenuItems(
    ToolStripDropDown menu
)
Visual Basic
Public Overrides Sub AppendAdditionalMenuItems ( _
    menu As ToolStripDropDown _
)

Parameters

menu
Type: System.Windows.Forms..::..ToolStripDropDown

See Also

GH_Component Class
Grasshopper.Kernel Namespace


AssignInitCodeToInputParameter Method

[image]

Grasshopper SDK
GH_Component..::..AssignInitCodeToInputParameter Method
GH_Component Class See Also Send Feedback
Utility function for parsing and assigning init codes. This only works for standard parameter types.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected bool AssignInitCodeToInputParameter(
    int paramIndex,
    string code
)
Visual Basic
Protected Function AssignInitCodeToInputParameter ( _
    paramIndex As Integer, _
    code As String _
) As Boolean

Parameters

paramIndex
Type: System..::..Int32
Index of input parameter to assign.
code
Type: System..::..String
Code to parse and assign.

Return Value

True if the code was assigned, false if otherwise.

See Also

GH_Component Class
Grasshopper.Kernel Namespace


BakeGeometry Method

[image] [image]

Grasshopper SDK
GH_Component..::..BakeGeometry Method
GH_Component Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BakeGeometry(RhinoDoc, List<(Of <<'(Guid>)>>)) |
Public method | BakeGeometry(RhinoDoc, ObjectAttributes, List<(Of <<'(Guid>)>>)) |

See Also

GH_Component Class
GH_Component Members
Grasshopper.Kernel Namespace


BakeGeometry Method (, List(Guid))

[image]

Grasshopper SDK
GH_Component..::..BakeGeometry Method (, List<(Of <(<'Guid>)>)>)
GH_Component Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual void BakeGeometry(
    RhinoDoc doc,
    List<Guid> obj_ids
)
Visual Basic
Public Overridable Sub BakeGeometry ( _
    doc As RhinoDoc, _
    obj_ids As List(Of Guid) _
)

Parameters

doc
Type: RhinoDoc
obj_ids
Type: System.Collections.Generic..::..List <(Of <(<' Guid >)>)>

Implements

IGH_BakeAwareObject..::..BakeGeometry(RhinoDoc, List<(Of <<'(Guid>)>>))

See Also

GH_Component Class
BakeGeometry Overload
Grasshopper.Kernel Namespace


BakeGeometry Method (, , List(Guid))

[image]

Grasshopper SDK
GH_Component..::..BakeGeometry Method (, , List<(Of <(<'Guid>)>)>)
GH_Component Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual void BakeGeometry(
    RhinoDoc doc,
    ObjectAttributes att,
    List<Guid> obj_ids
)
Visual Basic
Public Overridable Sub BakeGeometry ( _
    doc As RhinoDoc, _
    att As ObjectAttributes, _
    obj_ids As List(Of Guid) _
)

Parameters

doc
Type: RhinoDoc
att
Type: ObjectAttributes
obj_ids
Type: System.Collections.Generic..::..List <(Of <(<' Guid >)>)>

Implements

IGH_BakeAwareObject..::..BakeGeometry(RhinoDoc, ObjectAttributes, List<(Of <<'(Guid>)>>))

See Also

GH_Component Class
BakeGeometry Overload
Grasshopper.Kernel Namespace


BeforeSolveInstance Method

[image]

Grasshopper SDK
GH_Component..::..BeforeSolveInstance Method
GH_Component Class See Also Send Feedback
Override this method if you want to be called before the first call to SolveInstance.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected virtual void BeforeSolveInstance()
Visual Basic
Protected Overridable Sub BeforeSolveInstance

See Also

GH_Component Class
Grasshopper.Kernel Namespace


ClearData Method

[image]

Grasshopper SDK
GH_Component..::..ClearData Method
GH_Component Class See Also Send Feedback
Clear the data inside this component and all output parameters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void ClearData()
Visual Basic
Public Overrides Sub ClearData

See Also

GH_Component Class
Grasshopper.Kernel Namespace


ClearRuntimeMessages Method

[image]

Grasshopper SDK
GH_Component..::..ClearRuntimeMessages Method
GH_Component Class See Also Send Feedback
Clears all runtime messages in me and my parameters

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override sealed void ClearRuntimeMessages()
Visual Basic
Public Overrides NotOverridable Sub ClearRuntimeMessages

See Also

GH_Component Class
Grasshopper.Kernel Namespace


CollectData Method

[image]

Grasshopper SDK
GH_Component..::..CollectData Method
GH_Component Class See Also Send Feedback
Calls CollectData on all input parameters and makes sure the Component and all associated parameters are left in a valid state.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void CollectData()
Visual Basic
Public Overrides Sub CollectData

See Also

GH_Component Class
Grasshopper.Kernel Namespace


ComputeData Method

[image]

Grasshopper SDK
GH_Component..::..ComputeData Method
GH_Component Class See Also Send Feedback
Compute all data and fill out all output parameters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void ComputeData()
Visual Basic
Public Overrides Sub ComputeData

See Also

GH_Component Class
Grasshopper.Kernel Namespace


CreateAttributes Method

[image]

Grasshopper SDK
GH_Component..::..CreateAttributes Method
GH_Component Class See Also Send Feedback
Create new attributes.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void CreateAttributes()
Visual Basic
Public Overrides Sub CreateAttributes

Remarks

Typically you do not have to override this.

See Also

GH_Component Class
Grasshopper.Kernel Namespace


DependsOn Method

[image]

Grasshopper SDK
GH_Component..::..DependsOn Method
GH_Component Class See Also Send Feedback
Returns True is any one of my input parameters depends on the source.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override sealed bool DependsOn(
    IGH_ActiveObject potentialSource
)
Visual Basic
Public Overrides NotOverridable Function DependsOn ( _
    potentialSource As IGH_ActiveObject _
) As Boolean

Parameters

potentialSource
Type: Grasshopper.Kernel..::..IGH_ActiveObject
Source to test for dependency.

See Also

GH_Component Class
Grasshopper.Kernel Namespace


DocumentAngleTolerance Method

[image]

Grasshopper SDK
GH_Component..::..DocumentAngleTolerance Method
GH_Component Class See Also Send Feedback
Gets the Angle tolerance (in radians) for the currently active Rhino document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected static double DocumentAngleTolerance()
Visual Basic
Protected Shared Function DocumentAngleTolerance As Double

See Also

GH_Component Class
Grasshopper.Kernel Namespace


DocumentContextChanged Method

[image]

Grasshopper SDK
GH_Component..::..DocumentContextChanged Method
GH_Component Class See Also Send Feedback
Overrides the DocumentContextChanged method and delegates the call to all parameters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void DocumentContextChanged(
    GH_Document document,
    GH_DocumentContext context
)
Visual Basic
Public Overrides Sub DocumentContextChanged ( _
    document As GH_Document, _
    context As GH_DocumentContext _
)

Parameters

document
Type: Grasshopper.Kernel..::..GH_Document
Document that owns this object.
context
Type: Grasshopper.Kernel..::..GH_DocumentContext
The reason for this event.

See Also

GH_Component Class
Grasshopper.Kernel Namespace


DocumentTolerance Method

[image]

Grasshopper SDK
GH_Component..::..DocumentTolerance Method
GH_Component Class See Also Send Feedback
Gets the Absolute tolerance for the currently active Rhino document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected static double DocumentTolerance()
Visual Basic
Protected Shared Function DocumentTolerance As Double

See Also

GH_Component Class
Grasshopper.Kernel Namespace


DrawViewportMeshes Method

[image]

Grasshopper SDK
GH_Component..::..DrawViewportMeshes Method
GH_Component Class See Also Send Feedback
Draw preview meshes for this component and all associated parameters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual void DrawViewportMeshes(
    IGH_PreviewArgs args
)
Visual Basic
Public Overridable Sub DrawViewportMeshes ( _
    args As IGH_PreviewArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..IGH_PreviewArgs
Display data used during preview drawing.

Implements

IGH_PreviewObject..::..DrawViewportMeshes(IGH_PreviewArgs)

See Also

GH_Component Class
Grasshopper.Kernel Namespace


DrawViewportWires Method

[image]

Grasshopper SDK
GH_Component..::..DrawViewportWires Method
GH_Component Class See Also Send Feedback
Draw preview wires for this component and all associated parameters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual void DrawViewportWires(
    IGH_PreviewArgs args
)
Visual Basic
Public Overridable Sub DrawViewportWires ( _
    args As IGH_PreviewArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..IGH_PreviewArgs
Display data used during preview drawing.

Implements

IGH_PreviewObject..::..DrawViewportWires(IGH_PreviewArgs)

See Also

GH_Component Class
Grasshopper.Kernel Namespace


ExpireDownStreamObjects Method

[image]

Grasshopper SDK
GH_Component..::..ExpireDownStreamObjects Method
GH_Component Class See Also Send Feedback
Expire all objects that depend on any of the output parameters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void ExpireDownStreamObjects()
Visual Basic
Protected Overrides Sub ExpireDownStreamObjects

See Also

GH_Component Class
Grasshopper.Kernel Namespace


GenerateDefaultHTML Method

[image]

Grasshopper SDK
GH_Component..::..GenerateDefaultHTML Method
GH_Component Class See Also Send Feedback
Creates the default component help topic, including all parameter lists.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_HtmlFormatter GenerateDefaultHTML()
Visual Basic
Protected Function GenerateDefaultHTML As GH_HtmlFormatter

Remarks

This formatter does not include the this-is-an-autogenerated-topic message

See Also

GH_Component Class
Grasshopper.Kernel Namespace


GenerateParameterHelp Method

[image] [image]

Grasshopper SDK
GH_Component..::..GenerateParameterHelp Method
GH_Component Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GenerateParameterHelp()()()() | Create an HTML string that lists names and descriptions for input and output parameters.
Protected method | GenerateParameterHelp(IGH_Param) | Generate HTML string for a single parameter.

See Also

GH_Component Class
GH_Component Members
Grasshopper.Kernel Namespace


GenerateParameterHelp Method

[image]

Grasshopper SDK
GH_Component..::..GenerateParameterHelp Method
GH_Component Class See Also Send Feedback
Create an HTML string that lists names and descriptions for input and output parameters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected string GenerateParameterHelp()
Visual Basic
Protected Function GenerateParameterHelp As String

See Also

GH_Component Class
GenerateParameterHelp Overload
Grasshopper.Kernel Namespace


GenerateParameterHelp Method (IGH_Param)

[image]

Grasshopper SDK
GH_Component..::..GenerateParameterHelp Method (IGH_Param)
GH_Component Class See Also Send Feedback
Generate HTML string for a single parameter.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected string GenerateParameterHelp(
    IGH_Param param
)
Visual Basic
Protected Function GenerateParameterHelp ( _
    param As IGH_Param _
) As String

Parameters

param
Type: Grasshopper.Kernel..::..IGH_Param

See Also

GH_Component Class
GenerateParameterHelp Overload
Grasshopper.Kernel Namespace


GetValue Method

[image] [image]

Grasshopper SDK
GH_Component..::..GetValue Method
GH_Component Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetValue(String, Boolean) | Get a boolean value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Double) | Get a double value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Color) | Get a color value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Int32) | Get an integer value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, String) | Get a string value from the component value table. (Inherited from GH_DocumentObject.)

See Also

GH_Component Class
GH_Component Members
Grasshopper.Kernel Namespace


HtmlHelp_Source Method

[image]

Grasshopper SDK
GH_Component..::..HtmlHelp_Source Method
GH_Component Class See Also Send Feedback
Return a String which contains HTML formatted source for the help topic. If you want to pass a URL that points to a remote page, then prefix the URL with a GOTO: tag, like so: GOTO:http://www.YourWebAddressHere.com

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected internal override string HtmlHelp_Source()
Visual Basic
Protected Friend Overrides Function HtmlHelp_Source As String

Return Value

The HTML default help topic for this component including all parameters

Remarks

You can use the GUI.GH_HtmlFormatter class to generate an HTML page which conforms to Grasshopper Help standards

See Also

GH_Component Class
Grasshopper.Kernel Namespace


IsolateObject Method

[image]

Grasshopper SDK
GH_Component..::..IsolateObject Method
GH_Component Class See Also Send Feedback
Sever the connections of all input and output parameters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void IsolateObject()
Visual Basic
Public Overrides Sub IsolateObject

See Also

GH_Component Class
Grasshopper.Kernel Namespace


MovedBetweenDocuments Method

[image]

Grasshopper SDK
GH_Component..::..MovedBetweenDocuments Method
GH_Component Class See Also Send Feedback
Overrides the MovedBetweenDocuments method and delegates the call to all parameters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void MovedBetweenDocuments(
    GH_Document oldDocument,
    GH_Document newDocument
)
Visual Basic
Public Overrides Sub MovedBetweenDocuments ( _
    oldDocument As GH_Document, _
    newDocument As GH_Document _
)

Parameters

oldDocument
Type: Grasshopper.Kernel..::..GH_Document
Document that used to own this object.
newDocument
Type: Grasshopper.Kernel..::..GH_Document
Document that now owns ths object.

See Also

GH_Component Class
Grasshopper.Kernel Namespace


NewInstanceGuid Method

[image] [image]

Grasshopper SDK
GH_Component..::..NewInstanceGuid Method
GH_Component Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NewInstanceGuid()()()() | Generate a new random instance GUID (Inherited from GH_InstanceDescription.)
Public method | NewInstanceGuid(Guid) | Set the instance ID to be a specific GUID. This is very dangerous, only use this function if you're 6"4' and your first name is David. (Inherited from GH_InstanceDescription.)

See Also

GH_Component Class
GH_Component Members
Grasshopper.Kernel Namespace


OnObjectChanged Method

[image] [image]

Grasshopper SDK
GH_Component..::..OnObjectChanged Method
GH_Component Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OnObjectChanged(String) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectChangedEventArgs) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(String, Object) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType, Object) | (Inherited from GH_DocumentObject.)

See Also

GH_Component Class
GH_Component Members
Grasshopper.Kernel Namespace


PostConstructor Method

[image]

Grasshopper SDK
GH_Component..::..PostConstructor Method
GH_Component Class See Also Send Feedback
The PostConstructor is called from within each constructor. DO NOT OVERRIDE THIS unless you know what you are doing.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected virtual void PostConstructor()
Visual Basic
Protected Overridable Sub PostConstructor

See Also

GH_Component Class
Grasshopper.Kernel Namespace


Read Method

[image]

Grasshopper SDK
GH_Component..::..Read Method
GH_Component Class See Also Send Feedback
Read all required data for deserialization from an IO archive.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader
Object to read with.

Return Value

True on success, false on failure.

See Also

GH_Component Class
Grasshopper.Kernel Namespace


RecordUndoEvent Method

[image] [image]

Grasshopper SDK
GH_Component..::..RecordUndoEvent Method
GH_Component Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RecordUndoEvent(String) | Record a generic object change undo event. (Inherited from GH_DocumentObject.)
Public method | RecordUndoEvent(GH_UndoRecord) | Record an entire undo record. (Inherited from GH_DocumentObject.)
Public method | RecordUndoEvent(String, IGH_UndoAction) | Record a specific object change undo event. (Inherited from GH_DocumentObject.)

See Also

GH_Component Class
GH_Component Members
Grasshopper.Kernel Namespace


RegisterInputParams Method

[image]

Grasshopper SDK
GH_Component..::..RegisterInputParams Method
GH_Component Class See Also Send Feedback
Declare all your input parameters here.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected abstract void RegisterInputParams(
    GH_Component..::..GH_InputParamManager pManager
)
Visual Basic
Protected MustOverride Sub RegisterInputParams ( _
    pManager As GH_Component..::..GH_InputParamManager _
)

Parameters

pManager
Type: Grasshopper.Kernel..::..GH_Component..::..GH_InputParamManager
Use the pManager to register new parameters. pManager is never null.

See Also

GH_Component Class
Grasshopper.Kernel Namespace


RegisterOutputParams Method

[image]

Grasshopper SDK
GH_Component..::..RegisterOutputParams Method
GH_Component Class See Also Send Feedback
Declare all your output parameters here.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected abstract void RegisterOutputParams(
    GH_Component..::..GH_OutputParamManager pManager
)
Visual Basic
Protected MustOverride Sub RegisterOutputParams ( _
    pManager As GH_Component..::..GH_OutputParamManager _
)

Parameters

pManager
Type: Grasshopper.Kernel..::..GH_Component..::..GH_OutputParamManager
Use the pManager to register new parameters. pManager is never null.

See Also

GH_Component Class
Grasshopper.Kernel Namespace


RegisterRemoteIDs Method

[image]

Grasshopper SDK
GH_Component..::..RegisterRemoteIDs Method
GH_Component Class See Also Send Feedback
Registers all my input parameters with the UUID_LookUpTable

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void RegisterRemoteIDs(
    GH_GuidTable table
)
Visual Basic
Public Overrides Sub RegisterRemoteIDs ( _
    table As GH_GuidTable _
)

Parameters

table
Type: GH_GuidTable

See Also

GH_Component Class
Grasshopper.Kernel Namespace


RemovedFromDocument Method

[image]

Grasshopper SDK
GH_Component..::..RemovedFromDocument Method
GH_Component Class See Also Send Feedback
Overrides the RemovedFromDocument method and delegates the call to all parameters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void RemovedFromDocument(
    GH_Document document
)
Visual Basic
Public Overrides Sub RemovedFromDocument ( _
    document As GH_Document _
)

Parameters

document
Type: Grasshopper.Kernel..::..GH_Document
Document that now no longer owns this object.

See Also

GH_Component Class
Grasshopper.Kernel Namespace


RuntimeMessages Method

[image]

Grasshopper SDK
GH_Component..::..RuntimeMessages Method
GH_Component Class See Also Send Feedback
Gets the list of cached runtime messages that were recorded during solver-time processes. For components, the set of runtime messages also includes input and output parameters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IList<string> RuntimeMessages(
    GH_RuntimeMessageLevel level
)
Visual Basic
Public Overrides Function RuntimeMessages ( _
    level As GH_RuntimeMessageLevel _
) As IList(Of String)

Parameters

level
Type: Grasshopper.Kernel..::..GH_RuntimeMessageLevel
Runtime message type to retrieve.

Return Value

A list of runtime message strings.

See Also

GH_Component Class
Grasshopper.Kernel Namespace


SetValue Method

[image] [image]

Grasshopper SDK
GH_Component..::..SetValue Method
GH_Component Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SetValue(String, Boolean) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Double) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Color) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Int32) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, String) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)

See Also

GH_Component Class
GH_Component Members
Grasshopper.Kernel Namespace


SolveInstance Method

[image]

Grasshopper SDK
GH_Component..::..SolveInstance Method
GH_Component Class See Also Send Feedback
This function will be called (successively) from within the ComputeData method of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected abstract void SolveInstance(
    IGH_DataAccess DA
)
Visual Basic
Protected MustOverride Sub SolveInstance ( _
    DA As IGH_DataAccess _
)

Parameters

DA
Type: Grasshopper.Kernel..::..IGH_DataAccess
Data Access object. Use this object to retrieve data from input parameters and assign data to output parameters.

See Also

GH_Component Class
Grasshopper.Kernel Namespace


TriggerAutoSave Method

[image] [image]

Grasshopper SDK
GH_Component..::..TriggerAutoSave Method
GH_Component Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TriggerAutoSave()()()() | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(Guid) | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger, Guid) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from GH_DocumentObject.)

See Also

GH_Component Class
GH_Component Members
Grasshopper.Kernel Namespace


Write Method

[image]

Grasshopper SDK
GH_Component..::..Write Method
GH_Component Class See Also Send Feedback
Write all required data for deserialization to an IO archive.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overrides Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter
Object to write with.

Return Value

True on success, false on failure.

See Also

GH_Component Class
Grasshopper.Kernel Namespace


GH_Component Properties

[image] [image]

Grasshopper SDK
GH_Component Properties
GH_Component Class See Also Send Feedback

The GH_Component type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Gets or sets the attributes that are associated with this object. Only set custom attributes if you know what you are doing. (Inherited from GH_DocumentObject.)
Public property | Category | Gets or sets the Category in which this object belongs. If HasCategory() returns false, this field has no meaning. (Inherited from GH_InstanceDescription.)
Public property | ClippingBox | Gets the clipping box for all preview geometry drawn by this component and all associated parameters.
Public property | ComponentGuid | Returns a consistent ID for this object type. Every object must supply a unique and unchanging ID that is used to identify objects of the same type. (Inherited from GH_DocumentObject.)
Public property | DataComparison | Obsolete. Gets or sets the data matching algorithm for this component
Public property | Description | Gets or sets the description of the object. This field typically remains fixed during the lifetime of an object. (Inherited from GH_InstanceDescription.)
Public property | Exposure | Gets the exposure of this object in the Graphical User Interface. The default is to expose everywhere. (Inherited from GH_DocumentObject.)
Public property | HasCategory | Gets whether or not the Category field has been set. (Inherited from GH_InstanceDescription.)
Public property | HasSubCategory | Gets whether or not the SubCategory field has been set. (Inherited from GH_InstanceDescription.)
Protected property | HelpDescription | Override this method if you want the help topic content to be more than the Component description.
Public property | Hidden | Gets or sets the hidden flag for this component. Does not affect Hidden flags on parameters associated with this component.
Protected property | Icon | Override this function to supply a custom icon (24x24 pixels). The result of this property is cached, so don't worry if icon retrieval is not very fast. (Inherited from GH_DocumentObject.)
Public property | Icon_24x24 | The icon associated with this object. (Inherited from GH_DocumentObject.)
Public property | Icon_24x24_Locked | The greyscale icon of this object. (Inherited from GH_DocumentObject.)
Public property | IconCapableUI | By default the NickName menu item supports the Icon Mode override toggle. If your UI is not capable of displaying icons, then override this property and return False. (Inherited from GH_ActiveObject.)
Public property | IconDisplayMode | Gets the current display mode of the object. (Inherited from GH_DocumentObject.)
Public property | InConstructor | Gets the constructor flag for this instance. If InConstructor = True, it means the component is still registering parameters and the layout is not yet complete.
Public property | InstanceDescription | (Overrides GH_InstanceDescription..::..InstanceDescription.)
Public property | InstanceGuid | Gets the ID of this runtime instance. (Inherited from GH_InstanceDescription.)
Public property | IsBakeCapable |
Public property | IsDataProvider | Components are never Data providers. Only the output parameters can be considered to be providers. (Overrides GH_ActiveObject..::..IsDataProvider.)
Public property | IsPreviewCapable | If a single parameter is PreviewCapable, so is the component. Override this property if you need special Preview flags.
Public property | IsValidPrincipalParameterIndex | Gets whether the MasterParameterIndex property identifies a valid parameter.
Public property | Keywords | Gets a list of additional keywords that describe the object. Typically this list is empty but you can override this property to aid in object searches. (Inherited from GH_InstanceDescription.)
Public property | Locked | Gets or sets the Locked state for this Component. This also sets locked states for all input and output parameters. (Overrides GH_ActiveObject..::..Locked.)
Public property | Message | Gets or sets a custom message to be displayed underneath the component. This message is not serialized and should be assigned on every solution anew.
Public property | MutableNickName | Gets or sets a value that enables Nick name changes through the menu. The default is TRUE. (Inherited from GH_ActiveObject.)
Public property | Name | Gets or sets the name of the object. This field typically remains fixed during the lifetime of an object. (Inherited from GH_InstanceDescription.)
Public property | NickName | Gets or sets the nickname of the object. This field can be changed by the user. (Inherited from GH_InstanceDescription.)
Public property | Obsolete | Gets whether this object is obsolete. Default implementation returns true if the class name contains the string "OBSOLETE" or if this class has been decorated with the ObsoleteAttribute. You are free to override this if you want, but I suggest adding the ObsoleteAttribute instead. (Inherited from GH_DocumentObject.)
Public property | Params | Gets the parameter manager object for this component.
Public property | Phase | Gets or sets the solution phase this object is currenly in. (Inherited from GH_ActiveObject.)
Public property | PrincipalParameterIndex | Gets or sets the principal parameter index override. Negative indices or indices larger than or equal to the input parameter count will be ignored and regular principal parameter detection will kick in.
Public property | ProcessorTime | Gets the total processor time (profiler) spend by this component and all input parameters. (Overrides GH_ActiveObject..::..ProcessorTime.)
Public property | RuntimeMessageLevel | Returns the worst case runtime warning level of me and all my parameters (Overrides GH_ActiveObject..::..RuntimeMessageLevel.)
Public property | SubCategory | Gets or sets the SubCategory in which this object belongs. If HasSubCategory() returns false, this field has no meaning. (Inherited from GH_InstanceDescription.)

See Also

GH_Component Class
Grasshopper.Kernel Namespace


ClippingBox Property

[image]

Grasshopper SDK
GH_Component..::..ClippingBox Property
GH_Component Class See Also Send Feedback
Gets the clipping box for all preview geometry drawn by this component and all associated parameters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual BoundingBox ClippingBox { get; }
Visual Basic
Public Overridable ReadOnly Property ClippingBox As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Component.ClippingBox"]

Implements

IGH_PreviewObject..::..ClippingBox

See Also

GH_Component Class
Grasshopper.Kernel Namespace


DataComparison Property

[image]

Grasshopper SDK
GH_Component..::..DataComparison Property
GH_Component Class See Also Send Feedback
Gets or sets the data matching algorithm for this component

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
[ObsoleteAttribute("This property is obsolete and will be phased out in future versions")]
public GH_DataComparison DataComparison { get; set; }
Visual Basic
<ObsoleteAttribute("This property is obsolete and will be phased out in future versions")> _
Public Property DataComparison As GH_DataComparison
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Component.DataComparison"]

Implements

IGH_Component..::..DataComparison

See Also

GH_Component Class
Grasshopper.Kernel Namespace


HelpDescription Property

[image]

Grasshopper SDK
GH_Component..::..HelpDescription Property
GH_Component Class See Also Send Feedback
Override this method if you want the help topic content to be more than the Component description.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected virtual string HelpDescription { get; }
Visual Basic
Protected Overridable ReadOnly Property HelpDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Component.HelpDescription"]

See Also

GH_Component Class
Grasshopper.Kernel Namespace


Hidden Property

[image]

Grasshopper SDK
GH_Component..::..Hidden Property
GH_Component Class See Also Send Feedback
Gets or sets the hidden flag for this component. Does not affect Hidden flags on parameters associated with this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Hidden { get; set; }
Visual Basic
Public Property Hidden As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Component.Hidden"]

Implements

IGH_PreviewObject..::..Hidden

See Also

GH_Component Class
Grasshopper.Kernel Namespace


InConstructor Property

[image]

Grasshopper SDK
GH_Component..::..InConstructor Property
GH_Component Class See Also Send Feedback
Gets the constructor flag for this instance. If InConstructor = True, it means the component is still registering parameters and the layout is not yet complete.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool InConstructor { get; }
Visual Basic
Public ReadOnly Property InConstructor As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Component.InConstructor"]

Implements

IGH_Component..::..InConstructor

See Also

GH_Component Class
Grasshopper.Kernel Namespace


InstanceDescription Property

[image]

Grasshopper SDK
GH_Component..::..InstanceDescription Property
GH_Component Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string InstanceDescription { get; }
Visual Basic
Public Overrides ReadOnly Property InstanceDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Component.InstanceDescription"]

See Also

GH_Component Class
Grasshopper.Kernel Namespace


IsBakeCapable Property

[image]

Grasshopper SDK
GH_Component..::..IsBakeCapable Property
GH_Component Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool IsBakeCapable { get; }
Visual Basic
Public Overridable ReadOnly Property IsBakeCapable As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Component.IsBakeCapable"]

Implements

IGH_BakeAwareObject..::..IsBakeCapable

See Also

GH_Component Class
Grasshopper.Kernel Namespace


IsDataProvider Property

[image]

Grasshopper SDK
GH_Component..::..IsDataProvider Property
GH_Component Class See Also Send Feedback
Components are never Data providers. Only the output parameters can be considered to be providers.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override sealed bool IsDataProvider { get; }
Visual Basic
Public Overrides NotOverridable ReadOnly Property IsDataProvider As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Component.IsDataProvider"]

See Also

GH_Component Class
Grasshopper.Kernel Namespace


IsPreviewCapable Property

[image]

Grasshopper SDK
GH_Component..::..IsPreviewCapable Property
GH_Component Class See Also Send Feedback
If a single parameter is PreviewCapable, so is the component. Override this property if you need special Preview flags.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool IsPreviewCapable { get; }
Visual Basic
Public Overridable ReadOnly Property IsPreviewCapable As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Component.IsPreviewCapable"]

Implements

IGH_PreviewObject..::..IsPreviewCapable

See Also

GH_Component Class
Grasshopper.Kernel Namespace


IsValidPrincipalParameterIndex Property

[image]

Grasshopper SDK
GH_Component..::..IsValidPrincipalParameterIndex Property
GH_Component Class See Also Send Feedback
Gets whether the MasterParameterIndex property identifies a valid parameter.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsValidPrincipalParameterIndex { get; }
Visual Basic
Public ReadOnly Property IsValidPrincipalParameterIndex As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Component.IsValidPrincipalParameterIndex"]

Implements

IGH_Component..::..IsValidMasterParameterIndex

See Also

GH_Component Class
Grasshopper.Kernel Namespace


Locked Property

[image]

Grasshopper SDK
GH_Component..::..Locked Property
GH_Component Class See Also Send Feedback
Gets or sets the Locked state for this Component. This also sets locked states for all input and output parameters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Locked { get; set; }
Visual Basic
Public Overrides Property Locked As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Component.Locked"]

See Also

GH_Component Class
Grasshopper.Kernel Namespace


Message Property

[image]

Grasshopper SDK
GH_Component..::..Message Property
GH_Component Class See Also Send Feedback
Gets or sets a custom message to be displayed underneath the component. This message is not serialized and should be assigned on every solution anew.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Message { get; set; }
Visual Basic
Public Property Message As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Component.Message"]

Implements

IGH_Component..::..Message

See Also

GH_Component Class
Grasshopper.Kernel Namespace


Params Property

[image]

Grasshopper SDK
GH_Component..::..Params Property
GH_Component Class See Also Send Feedback
Gets the parameter manager object for this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ComponentParamServer Params { get; }
Visual Basic
Public ReadOnly Property Params As GH_ComponentParamServer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Component.Params"]

Implements

IGH_Component..::..Params

See Also

GH_Component Class
Grasshopper.Kernel Namespace


PrincipalParameterIndex Property

[image]

Grasshopper SDK
GH_Component..::..PrincipalParameterIndex Property
GH_Component Class See Also Send Feedback
Gets or sets the principal parameter index override. Negative indices or indices larger than or equal to the input parameter count will be ignored and regular principal parameter detection will kick in.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int PrincipalParameterIndex { get; set; }
Visual Basic
Public Property PrincipalParameterIndex As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Component.PrincipalParameterIndex"]

Implements

IGH_Component..::..MasterParameterIndex

See Also

GH_Component Class
Grasshopper.Kernel Namespace


ProcessorTime Property

[image]

Grasshopper SDK
GH_Component..::..ProcessorTime Property
GH_Component Class See Also Send Feedback
Gets the total processor time (profiler) spend by this component and all input parameters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override TimeSpan ProcessorTime { get; }
Visual Basic
Public Overrides ReadOnly Property ProcessorTime As TimeSpan
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Component.ProcessorTime"]

See Also

GH_Component Class
Grasshopper.Kernel Namespace


RuntimeMessageLevel Property

[image]

Grasshopper SDK
GH_Component..::..RuntimeMessageLevel Property
GH_Component Class See Also Send Feedback
Returns the worst case runtime warning level of me and all my parameters

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override sealed GH_RuntimeMessageLevel RuntimeMessageLevel { get; }
Visual Basic
Public Overrides NotOverridable ReadOnly Property RuntimeMessageLevel As GH_RuntimeMessageLevel
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Component.RuntimeMessageLevel"]

See Also

GH_Component Class
Grasshopper.Kernel Namespace


GH_Component Events

[image] [image]

Grasshopper SDK
GH_Component Events
GH_Component Class See Also Send Feedback

The GH_Component type exposes the following members.

Events

 | Name | Description
Public event | AttributesChanged | Raised whenever the number or kind of attributes changes. This event is handled by GH_Documents who subsequently wipe their attribute caches. (Inherited from GH_DocumentObject.)
Public event | DisplayExpired | Raised whenever the display (on the Canvas) of a certain object becomes invalid. (Inherited from GH_DocumentObject.)
Public event | ObjectChanged | (Inherited from GH_DocumentObject.)
Public event | PingDocument | Raised whenever an object needs to know which GH_Document it belongs to. (Inherited from GH_DocumentObject.)
Public event | PreviewExpired | Raised whenever the display (in the Rhino viewports) of a certain object becomes invalid. (Inherited from GH_DocumentObject.)
Public event | SolutionExpired | Raised whenever the solution of a certain object becomes invalid. (Inherited from GH_DocumentObject.)

See Also

GH_Component Class
Grasshopper.Kernel Namespace


GH_Component.GH_InputParamManager Class

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager Class
GH_Component Class Members See Also Send Feedback
This class is used during Component construction to add input parameters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected class GH_InputParamManager : GH_ParamManager
Visual Basic
Protected Class GH_InputParamManager _
    Inherits GH_ParamManager

Inheritance Hierarchy

System..::..Object
GH_ParamManager
Grasshopper.Kernel..::..GH_Component..::..GH_InputParamManager

See Also

GH_Component..::..GH_InputParamManager Members
Grasshopper.Kernel Namespace


GH_Component.GH_InputParamManager Members

[image] [image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager Members
GH_Component..::..GH_InputParamManager Class Methods Properties See Also Send Feedback

Inherit from this class if you wish to create a custom component. Note that you must provide a public, empty constructor which calls the base class constructor.

The GH_Component..::..GH_InputParamManager type exposes the following members.

Methods

 | Name | Description
Public method | AddAngleParameter(String, String, String, GH_ParamAccess) | Add a floating point Number parameter to the input list of this component. The parameter will be aware that it is representing angles.
Public method | AddAngleParameter(String, String, String, GH_ParamAccess, IEnumerable<(Of <<'(Double>)>>)) | Add a floating point Number parameter to the input list of this component. The parameter will be aware that it is representing angles.
Public method | AddAngleParameter(String, String, String, GH_ParamAccess, Double) | Add a floating point Number parameter to the input list of this component. The parameter will be aware that it is representing angles.
Public method | AddArcParameter(String, String, String, GH_ParamAccess) | Add a 3D Arc parameter to the input list of this component.
Public method | AddArcParameter(String, String, String, GH_ParamAccess, Arc) | Add a 3D Arc parameter to the input list of this component.
Public method | AddBooleanParameter(String, String, String, GH_ParamAccess) | Add a Boolean parameter to the input list of this component.
Public method | AddBooleanParameter(String, String, String, GH_ParamAccess, Boolean) | Add a Boolean parameter to the input list of this component.
Public method | AddBooleanParameter(String, String, String, GH_ParamAccess, IEnumerable<(Of <<'(Boolean>)>>)) | Add a Boolean parameter to the input list of this component.
Public method | AddBoxParameter(String, String, String, GH_ParamAccess) | Add a 3D Box parameter to the input list of this component.
Public method | AddBoxParameter(String, String, String, GH_ParamAccess, Box) | Add a 3D Box parameter to the input list of this component.
Public method | AddBrepParameter | Add a 3D Brep parameter to the input list of this component. Brep parameters can handle both trimmed and untrimmed single or multi-faced Breps.
Public method | AddCircleParameter(String, String, String, GH_ParamAccess) | Add a 3D Circle parameter to the input list of this component.
Public method | AddCircleParameter(String, String, String, GH_ParamAccess, Circle) | Add a 3D Circle parameter to the input list of this component.
Public method | AddColourParameter(String, String, String, GH_ParamAccess) | Add an ARGB Colour parameter to the input list of this component.
Public method | AddColourParameter(String, String, String, GH_ParamAccess, IEnumerable<(Of <<'(Color>)>>)) | Add an ARGB Colour parameter to the input list of this component.
Public method | AddColourParameter(String, String, String, GH_ParamAccess, Color) | Add an ARGB Colour parameter to the input list of this component.
Public method | AddComplexNumberParameter(String, String, String, GH_ParamAccess) | Add a Complex Number parameter to the input list of this component.
Public method | AddComplexNumberParameter(String, String, String, GH_ParamAccess, GH_ComplexNumber) | Add a Complex Number parameter to the input list of this component.
Public method | AddCultureParameter(String, String, String, GH_ParamAccess) | Add a Cultue parameter to the input list of this component.
Public method | AddCultureParameter(String, String, String, GH_ParamAccess, CultureInfo) | Add a Culture parameter to the input list of this component.
Public method | AddCurveParameter | Add a 3D Curve parameter to the input list of this component. Curve parameters can handle all curve types (Lines, Polylines, Circles, Arcs, NurbsCurves etc.)
Public method | AddFieldParameter | Add a Field parameter to the input list of this component.
Public method | AddGenericParameter | Add a Generic parameter to the input list of this component. Generic parameters can handle all types of data.
Public method | AddGeometryParameter | Add a generic 3D Geometry parameter to the input list of this component. Geometry parameters can handle all types that represent actual shapes.
Public method | AddGroupParameter | Add a Transform Group parameter to the input list of this component. Groups are collections of geometry that are transformed as one, they are not the same as Rhino groups.
Public method | AddIntegerParameter(String, String, String, GH_ParamAccess) | Add a Integer parameter to the input list of this component.
Public method | AddIntegerParameter(String, String, String, GH_ParamAccess, IEnumerable<(Of <<'(Int32>)>>)) | Add a Integer parameter to the input list of this component.
Public method | AddIntegerParameter(String, String, String, GH_ParamAccess, Int32) | Add a Integer parameter to the input list of this component.
Public method | AddInterval2DParameter | Add an Interval2D (i.e. uv domain) parameter to the input list of this component.
Public method | AddIntervalParameter(String, String, String, GH_ParamAccess) | Add an Interval (i.e. numeric domain) parameter to the input list of this component.
Public method | AddIntervalParameter(String, String, String, GH_ParamAccess, Interval) | Add an Interval (i.e. numeric domain) parameter to the input list of this component.
Public method | AddIntervalParameter(String, String, String, GH_ParamAccess, IEnumerable<(Of <<'(Interval>)>>)) | Add an Interval (i.e. numeric domain) parameter to the input list of this component.
Public method | AddLineParameter(String, String, String, GH_ParamAccess) | Add a 3D Line parameter to the input list of this component.
Public method | AddLineParameter(String, String, String, GH_ParamAccess, Line) | Add a 3D Line parameter to the input list of this component.
Public method | AddMatrixParameter | Add a Matrix parameter to the input list of this component.
Public method | AddMeshFaceParameter | Add a topological MeshFace parameter to the input list of this component.
Public method | AddMeshParameter | Add a 3D Mesh parameter to the input list of this component.
Public method | AddNumberParameter(String, String, String, GH_ParamAccess) | Add a floating point Number parameter to the input list of this component.
Public method | AddNumberParameter(String, String, String, GH_ParamAccess, IEnumerable<(Of <<'(Double>)>>)) | Add a floating point Number parameter to the input list of this component.
Public method | AddNumberParameter(String, String, String, GH_ParamAccess, Double) | Add a floating point Number parameter to the input list of this component.
Public method | AddParameter(IGH_Param) | Generic parameter addition. If you cannot use one of the utility methods provided by this class, you can register a customized parameter using this method.
Public method | AddParameter(IGH_Param, String, String, String, GH_ParamAccess) | Generic parameter addition. If you cannot use one of the utility methods provided by this class, you can register a customized parameter using this method.
Public method | AddPathParameter | Add a Data Path parameter to the input list of this component.
Public method | AddPlaneParameter(String, String, String, GH_ParamAccess) | Add a 3D Plane parameter to the input list of this component.
Public method | AddPlaneParameter(String, String, String, GH_ParamAccess, Plane) | Add a 3D Plane parameter to the input list of this component.
Public method | AddPointParameter(String, String, String, GH_ParamAccess) | Add a 3D Point parameter to the input list of this component.
Public method | AddPointParameter(String, String, String, GH_ParamAccess, Point3d) | Register a new 3D point param with a single default coordinate.
Public method | AddPointParameter(String, String, String, GH_ParamAccess, IEnumerable<(Of <<'(Point3d>)>>)) | Register a new 3D point param with multiple default coordinates.
Public method | AddRectangleParameter(String, String, String, GH_ParamAccess) | Add a 3D Rectangle parameter to the input list of this component.
Public method | AddRectangleParameter(String, String, String, GH_ParamAccess, Rectangle3d) | Add a 3D Rectangle parameter to the input list of this component.
Public method | AddScriptVariableParameter | Add a Script Variable parameter to the input list of this component. Script variable parameters are used almost exclusively in VB/C#/Python components so you probably don't want this one.
Public method | AddSurfaceParameter | Add a 3D Surface parameter to the input list of this component. Surface parameters can handle both trimmed and untrimmed single-faced Breps.
Public method | AddTextParameter(String, String, String, GH_ParamAccess) | Add a Text parameter to the input list of this component.
Public method | AddTextParameter(String, String, String, GH_ParamAccess, IEnumerable<(Of <<'(String>)>>)) | Add a Text parameter to the input list of this component.
Public method | AddTextParameter(String, String, String, GH_ParamAccess, String) | Add a Text parameter to the input list of this component.
Public method | AddTimeParameter(String, String, String, GH_ParamAccess) | Add a Time parameter to the input list of this component.
Public method | AddTimeParameter(String, String, String, GH_ParamAccess, DateTime) | Add a Time parameter to the input list of this component.
Public method | AddTransformParameter | Add a Transformation parameter to the input list of this component.
Public method | AddVectorParameter(String, String, String, GH_ParamAccess) | Add a 3D Vector parameter to the input list of this component.
Public method | AddVectorParameter(String, String, String, GH_ParamAccess, Vector3d) | Add a 3D Vector parameter to the input list of this component.
Public method | HideParameter | Hide a specific input parameter. If the parameter at the given index implements IGH_PreviewObject then the Hidden flag will be set to True. Otherwise, nothing will happen. (Overrides GH_ParamManagerHideParameter(Int32).)

Properties

 | Name | Description
Public property | Param | Gets the input parameter at the given index. (Overrides GH_ParamManagerParam(Int32).)
Public property | ParamCount | Returns the number of input parameters already part of this component. (Overrides GH_ParamManagerParamCount()()()().)

See Also

GH_Component..::..GH_InputParamManager Class
Grasshopper.Kernel Namespace


GH_Component.GH_InputParamManager Methods

[image] [image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager Methods
GH_Component..::..GH_InputParamManager Class See Also Send Feedback

The GH_Component..::..GH_InputParamManager type exposes the following members.

Methods

 | Name | Description
Public method | AddAngleParameter(String, String, String, GH_ParamAccess) | Add a floating point Number parameter to the input list of this component. The parameter will be aware that it is representing angles.
Public method | AddAngleParameter(String, String, String, GH_ParamAccess, IEnumerable<(Of <<'(Double>)>>)) | Add a floating point Number parameter to the input list of this component. The parameter will be aware that it is representing angles.
Public method | AddAngleParameter(String, String, String, GH_ParamAccess, Double) | Add a floating point Number parameter to the input list of this component. The parameter will be aware that it is representing angles.
Public method | AddArcParameter(String, String, String, GH_ParamAccess) | Add a 3D Arc parameter to the input list of this component.
Public method | AddArcParameter(String, String, String, GH_ParamAccess, Arc) | Add a 3D Arc parameter to the input list of this component.
Public method | AddBooleanParameter(String, String, String, GH_ParamAccess) | Add a Boolean parameter to the input list of this component.
Public method | AddBooleanParameter(String, String, String, GH_ParamAccess, Boolean) | Add a Boolean parameter to the input list of this component.
Public method | AddBooleanParameter(String, String, String, GH_ParamAccess, IEnumerable<(Of <<'(Boolean>)>>)) | Add a Boolean parameter to the input list of this component.
Public method | AddBoxParameter(String, String, String, GH_ParamAccess) | Add a 3D Box parameter to the input list of this component.
Public method | AddBoxParameter(String, String, String, GH_ParamAccess, Box) | Add a 3D Box parameter to the input list of this component.
Public method | AddBrepParameter | Add a 3D Brep parameter to the input list of this component. Brep parameters can handle both trimmed and untrimmed single or multi-faced Breps.
Public method | AddCircleParameter(String, String, String, GH_ParamAccess) | Add a 3D Circle parameter to the input list of this component.
Public method | AddCircleParameter(String, String, String, GH_ParamAccess, Circle) | Add a 3D Circle parameter to the input list of this component.
Public method | AddColourParameter(String, String, String, GH_ParamAccess) | Add an ARGB Colour parameter to the input list of this component.
Public method | AddColourParameter(String, String, String, GH_ParamAccess, IEnumerable<(Of <<'(Color>)>>)) | Add an ARGB Colour parameter to the input list of this component.
Public method | AddColourParameter(String, String, String, GH_ParamAccess, Color) | Add an ARGB Colour parameter to the input list of this component.
Public method | AddComplexNumberParameter(String, String, String, GH_ParamAccess) | Add a Complex Number parameter to the input list of this component.
Public method | AddComplexNumberParameter(String, String, String, GH_ParamAccess, GH_ComplexNumber) | Add a Complex Number parameter to the input list of this component.
Public method | AddCultureParameter(String, String, String, GH_ParamAccess) | Add a Cultue parameter to the input list of this component.
Public method | AddCultureParameter(String, String, String, GH_ParamAccess, CultureInfo) | Add a Culture parameter to the input list of this component.
Public method | AddCurveParameter | Add a 3D Curve parameter to the input list of this component. Curve parameters can handle all curve types (Lines, Polylines, Circles, Arcs, NurbsCurves etc.)
Public method | AddFieldParameter | Add a Field parameter to the input list of this component.
Public method | AddGenericParameter | Add a Generic parameter to the input list of this component. Generic parameters can handle all types of data.
Public method | AddGeometryParameter | Add a generic 3D Geometry parameter to the input list of this component. Geometry parameters can handle all types that represent actual shapes.
Public method | AddGroupParameter | Add a Transform Group parameter to the input list of this component. Groups are collections of geometry that are transformed as one, they are not the same as Rhino groups.
Public method | AddIntegerParameter(String, String, String, GH_ParamAccess) | Add a Integer parameter to the input list of this component.
Public method | AddIntegerParameter(String, String, String, GH_ParamAccess, IEnumerable<(Of <<'(Int32>)>>)) | Add a Integer parameter to the input list of this component.
Public method | AddIntegerParameter(String, String, String, GH_ParamAccess, Int32) | Add a Integer parameter to the input list of this component.
Public method | AddInterval2DParameter | Add an Interval2D (i.e. uv domain) parameter to the input list of this component.
Public method | AddIntervalParameter(String, String, String, GH_ParamAccess) | Add an Interval (i.e. numeric domain) parameter to the input list of this component.
Public method | AddIntervalParameter(String, String, String, GH_ParamAccess, Interval) | Add an Interval (i.e. numeric domain) parameter to the input list of this component.
Public method | AddIntervalParameter(String, String, String, GH_ParamAccess, IEnumerable<(Of <<'(Interval>)>>)) | Add an Interval (i.e. numeric domain) parameter to the input list of this component.
Public method | AddLineParameter(String, String, String, GH_ParamAccess) | Add a 3D Line parameter to the input list of this component.
Public method | AddLineParameter(String, String, String, GH_ParamAccess, Line) | Add a 3D Line parameter to the input list of this component.
Public method | AddMatrixParameter | Add a Matrix parameter to the input list of this component.
Public method | AddMeshFaceParameter | Add a topological MeshFace parameter to the input list of this component.
Public method | AddMeshParameter | Add a 3D Mesh parameter to the input list of this component.
Public method | AddNumberParameter(String, String, String, GH_ParamAccess) | Add a floating point Number parameter to the input list of this component.
Public method | AddNumberParameter(String, String, String, GH_ParamAccess, IEnumerable<(Of <<'(Double>)>>)) | Add a floating point Number parameter to the input list of this component.
Public method | AddNumberParameter(String, String, String, GH_ParamAccess, Double) | Add a floating point Number parameter to the input list of this component.
Public method | AddParameter(IGH_Param) | Generic parameter addition. If you cannot use one of the utility methods provided by this class, you can register a customized parameter using this method.
Public method | AddParameter(IGH_Param, String, String, String, GH_ParamAccess) | Generic parameter addition. If you cannot use one of the utility methods provided by this class, you can register a customized parameter using this method.
Public method | AddPathParameter | Add a Data Path parameter to the input list of this component.
Public method | AddPlaneParameter(String, String, String, GH_ParamAccess) | Add a 3D Plane parameter to the input list of this component.
Public method | AddPlaneParameter(String, String, String, GH_ParamAccess, Plane) | Add a 3D Plane parameter to the input list of this component.
Public method | AddPointParameter(String, String, String, GH_ParamAccess) | Add a 3D Point parameter to the input list of this component.
Public method | AddPointParameter(String, String, String, GH_ParamAccess, Point3d) | Register a new 3D point param with a single default coordinate.
Public method | AddPointParameter(String, String, String, GH_ParamAccess, IEnumerable<(Of <<'(Point3d>)>>)) | Register a new 3D point param with multiple default coordinates.
Public method | AddRectangleParameter(String, String, String, GH_ParamAccess) | Add a 3D Rectangle parameter to the input list of this component.
Public method | AddRectangleParameter(String, String, String, GH_ParamAccess, Rectangle3d) | Add a 3D Rectangle parameter to the input list of this component.
Public method | AddScriptVariableParameter | Add a Script Variable parameter to the input list of this component. Script variable parameters are used almost exclusively in VB/C#/Python components so you probably don't want this one.
Public method | AddSurfaceParameter | Add a 3D Surface parameter to the input list of this component. Surface parameters can handle both trimmed and untrimmed single-faced Breps.
Public method | AddTextParameter(String, String, String, GH_ParamAccess) | Add a Text parameter to the input list of this component.
Public method | AddTextParameter(String, String, String, GH_ParamAccess, IEnumerable<(Of <<'(String>)>>)) | Add a Text parameter to the input list of this component.
Public method | AddTextParameter(String, String, String, GH_ParamAccess, String) | Add a Text parameter to the input list of this component.
Public method | AddTimeParameter(String, String, String, GH_ParamAccess) | Add a Time parameter to the input list of this component.
Public method | AddTimeParameter(String, String, String, GH_ParamAccess, DateTime) | Add a Time parameter to the input list of this component.
Public method | AddTransformParameter | Add a Transformation parameter to the input list of this component.
Public method | AddVectorParameter(String, String, String, GH_ParamAccess) | Add a 3D Vector parameter to the input list of this component.
Public method | AddVectorParameter(String, String, String, GH_ParamAccess, Vector3d) | Add a 3D Vector parameter to the input list of this component.
Public method | HideParameter | Hide a specific input parameter. If the parameter at the given index implements IGH_PreviewObject then the Hidden flag will be set to True. Otherwise, nothing will happen. (Overrides GH_ParamManagerHideParameter(Int32).)

See Also

GH_Component..::..GH_InputParamManager Class
Grasshopper.Kernel Namespace


AddAngleParameter Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddAngleParameter Method
GH_Component..::..GH_InputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddAngleParameter(String, String, String, GH_ParamAccess) | Add a floating point Number parameter to the input list of this component. The parameter will be aware that it is representing angles.
Public method | AddAngleParameter(String, String, String, GH_ParamAccess, IEnumerable<(Of <<'(Double>)>>)) | Add a floating point Number parameter to the input list of this component. The parameter will be aware that it is representing angles.
Public method | AddAngleParameter(String, String, String, GH_ParamAccess, Double) | Add a floating point Number parameter to the input list of this component. The parameter will be aware that it is representing angles.

See Also

GH_Component..::..GH_InputParamManager Class
GH_Component..::..GH_InputParamManager Members
Grasshopper.Kernel Namespace


AddAngleParameter Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddAngleParameter Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a floating point Number parameter to the input list of this component. The parameter will be aware that it is representing angles.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddAngleParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddAngleParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.

See Also

GH_Component..::..GH_InputParamManager Class
AddAngleParameter Overload
Grasshopper.Kernel Namespace


AddAngleParameter Method (String, String, String, GH_ParamAccess, IEnumerable(Double))

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddAngleParameter Method (String, String, String, GH_ParamAccess, IEnumerable<(Of <(<'Double>)>)>)
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a floating point Number parameter to the input list of this component. The parameter will be aware that it is representing angles.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddAngleParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access,
    IEnumerable<double> default
)
Visual Basic
Public Function AddAngleParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess, _
    default As IEnumerable(Of Double) _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.
default
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Double >)>)>
A collection of default values to store in the parameter Persistent Data.

See Also

GH_Component..::..GH_InputParamManager Class
AddAngleParameter Overload
Grasshopper.Kernel Namespace


AddAngleParameter Method (String, String, String, GH_ParamAccess, Double)

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddAngleParameter Method (String, String, String, GH_ParamAccess, Double)
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a floating point Number parameter to the input list of this component. The parameter will be aware that it is representing angles.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddAngleParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access,
    double default
)
Visual Basic
Public Function AddAngleParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess, _
    default As Double _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.
default
Type: System..::..Double
A default value to store in the parameter Persistent Data.

See Also

GH_Component..::..GH_InputParamManager Class
AddAngleParameter Overload
Grasshopper.Kernel Namespace


AddArcParameter Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddArcParameter Method
GH_Component..::..GH_InputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddArcParameter(String, String, String, GH_ParamAccess) | Add a 3D Arc parameter to the input list of this component.
Public method | AddArcParameter(String, String, String, GH_ParamAccess, Arc) | Add a 3D Arc parameter to the input list of this component.

See Also

GH_Component..::..GH_InputParamManager Class
GH_Component..::..GH_InputParamManager Members
Grasshopper.Kernel Namespace


AddArcParameter Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddArcParameter Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a 3D Arc parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddArcParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddArcParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.

See Also

GH_Component..::..GH_InputParamManager Class
AddArcParameter Overload
Grasshopper.Kernel Namespace


AddArcParameter Method (String, String, String, GH_ParamAccess, )

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddArcParameter Method (String, String, String, GH_ParamAccess, )
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a 3D Arc parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddArcParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access,
    Arc default
)
Visual Basic
Public Function AddArcParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess, _
    default As Arc _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.
default
Type: Arc
A default value to store in the parameter Persistent Data.

See Also

GH_Component..::..GH_InputParamManager Class
AddArcParameter Overload
Grasshopper.Kernel Namespace


AddBooleanParameter Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddBooleanParameter Method
GH_Component..::..GH_InputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddBooleanParameter(String, String, String, GH_ParamAccess) | Add a Boolean parameter to the input list of this component.
Public method | AddBooleanParameter(String, String, String, GH_ParamAccess, Boolean) | Add a Boolean parameter to the input list of this component.
Public method | AddBooleanParameter(String, String, String, GH_ParamAccess, IEnumerable<(Of <<'(Boolean>)>>)) | Add a Boolean parameter to the input list of this component.

See Also

GH_Component..::..GH_InputParamManager Class
GH_Component..::..GH_InputParamManager Members
Grasshopper.Kernel Namespace


AddBooleanParameter Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddBooleanParameter Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a Boolean parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddBooleanParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddBooleanParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.

See Also

GH_Component..::..GH_InputParamManager Class
AddBooleanParameter Overload
Grasshopper.Kernel Namespace


AddBooleanParameter Method (String, String, String, GH_ParamAccess, Boolean)

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddBooleanParameter Method (String, String, String, GH_ParamAccess, Boolean)
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a Boolean parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddBooleanParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access,
    bool default
)
Visual Basic
Public Function AddBooleanParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess, _
    default As Boolean _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.
default
Type: System..::..Boolean
A default value to store in the parameter Persistent Data.

See Also

GH_Component..::..GH_InputParamManager Class
AddBooleanParameter Overload
Grasshopper.Kernel Namespace


AddBooleanParameter Method (String, String, String, GH_ParamAccess, IEnumerable(Boolean))

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddBooleanParameter Method (String, String, String, GH_ParamAccess, IEnumerable<(Of <(<'Boolean>)>)>)
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a Boolean parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddBooleanParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access,
    IEnumerable<bool> default
)
Visual Basic
Public Function AddBooleanParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess, _
    default As IEnumerable(Of Boolean) _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.
default
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Boolean >)>)>
A collection of default values to store in the parameter Persistent Data.

See Also

GH_Component..::..GH_InputParamManager Class
AddBooleanParameter Overload
Grasshopper.Kernel Namespace


AddBoxParameter Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddBoxParameter Method
GH_Component..::..GH_InputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddBoxParameter(String, String, String, GH_ParamAccess) | Add a 3D Box parameter to the input list of this component.
Public method | AddBoxParameter(String, String, String, GH_ParamAccess, Box) | Add a 3D Box parameter to the input list of this component.

See Also

GH_Component..::..GH_InputParamManager Class
GH_Component..::..GH_InputParamManager Members
Grasshopper.Kernel Namespace


AddBoxParameter Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddBoxParameter Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a 3D Box parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddBoxParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddBoxParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.

See Also

GH_Component..::..GH_InputParamManager Class
AddBoxParameter Overload
Grasshopper.Kernel Namespace


AddBoxParameter Method (String, String, String, GH_ParamAccess, )

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddBoxParameter Method (String, String, String, GH_ParamAccess, )
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a 3D Box parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddBoxParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access,
    Box default
)
Visual Basic
Public Function AddBoxParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess, _
    default As Box _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.
default
Type: Box
A default value to store in the parameter Persistent Data.

See Also

GH_Component..::..GH_InputParamManager Class
AddBoxParameter Overload
Grasshopper.Kernel Namespace


AddBrepParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddBrepParameter Method
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a 3D Brep parameter to the input list of this component. Brep parameters can handle both trimmed and untrimmed single or multi-faced Breps.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddBrepParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddBrepParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.

See Also

GH_Component..::..GH_InputParamManager Class
Grasshopper.Kernel Namespace


AddCircleParameter Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddCircleParameter Method
GH_Component..::..GH_InputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddCircleParameter(String, String, String, GH_ParamAccess) | Add a 3D Circle parameter to the input list of this component.
Public method | AddCircleParameter(String, String, String, GH_ParamAccess, Circle) | Add a 3D Circle parameter to the input list of this component.

See Also

GH_Component..::..GH_InputParamManager Class
GH_Component..::..GH_InputParamManager Members
Grasshopper.Kernel Namespace


AddCircleParameter Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddCircleParameter Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a 3D Circle parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddCircleParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddCircleParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.

See Also

GH_Component..::..GH_InputParamManager Class
AddCircleParameter Overload
Grasshopper.Kernel Namespace


AddCircleParameter Method (String, String, String, GH_ParamAccess, )

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddCircleParameter Method (String, String, String, GH_ParamAccess, )
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a 3D Circle parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddCircleParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access,
    Circle default
)
Visual Basic
Public Function AddCircleParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess, _
    default As Circle _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.
default
Type: Circle
A default value to store in the parameter Persistent Data.

See Also

GH_Component..::..GH_InputParamManager Class
AddCircleParameter Overload
Grasshopper.Kernel Namespace


AddColourParameter Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddColourParameter Method
GH_Component..::..GH_InputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddColourParameter(String, String, String, GH_ParamAccess) | Add an ARGB Colour parameter to the input list of this component.
Public method | AddColourParameter(String, String, String, GH_ParamAccess, IEnumerable<(Of <<'(Color>)>>)) | Add an ARGB Colour parameter to the input list of this component.
Public method | AddColourParameter(String, String, String, GH_ParamAccess, Color) | Add an ARGB Colour parameter to the input list of this component.

See Also

GH_Component..::..GH_InputParamManager Class
GH_Component..::..GH_InputParamManager Members
Grasshopper.Kernel Namespace


AddColourParameter Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddColourParameter Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add an ARGB Colour parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddColourParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddColourParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.

See Also

GH_Component..::..GH_InputParamManager Class
AddColourParameter Overload
Grasshopper.Kernel Namespace


AddColourParameter Method (String, String, String, GH_ParamAccess, IEnumerable(Color))

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddColourParameter Method (String, String, String, GH_ParamAccess, IEnumerable<(Of <(<'Color>)>)>)
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add an ARGB Colour parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddColourParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access,
    IEnumerable<Color> default
)
Visual Basic
Public Function AddColourParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess, _
    default As IEnumerable(Of Color) _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.
default
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Color >)>)>
A collection of default values to store in the parameter Persistent Data.

See Also

GH_Component..::..GH_InputParamManager Class
AddColourParameter Overload
Grasshopper.Kernel Namespace


AddColourParameter Method (String, String, String, GH_ParamAccess, Color)

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddColourParameter Method (String, String, String, GH_ParamAccess, Color)
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add an ARGB Colour parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddColourParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access,
    Color default
)
Visual Basic
Public Function AddColourParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess, _
    default As Color _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.
default
Type: System.Drawing..::..Color
A default value to store in the parameter Persistent Data.

See Also

GH_Component..::..GH_InputParamManager Class
AddColourParameter Overload
Grasshopper.Kernel Namespace


AddComplexNumberParameter Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddComplexNumberParameter Method
GH_Component..::..GH_InputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddComplexNumberParameter(String, String, String, GH_ParamAccess) | Add a Complex Number parameter to the input list of this component.
Public method | AddComplexNumberParameter(String, String, String, GH_ParamAccess, GH_ComplexNumber) | Add a Complex Number parameter to the input list of this component.

See Also

GH_Component..::..GH_InputParamManager Class
GH_Component..::..GH_InputParamManager Members
Grasshopper.Kernel Namespace


AddComplexNumberParameter Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddComplexNumberParameter Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a Complex Number parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddComplexNumberParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddComplexNumberParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.

See Also

GH_Component..::..GH_InputParamManager Class
AddComplexNumberParameter Overload
Grasshopper.Kernel Namespace


AddComplexNumberParameter Method (String, String, String, GH_ParamAccess, GH_ComplexNumber)

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddComplexNumberParameter Method (String, String, String, GH_ParamAccess, GH_ComplexNumber)
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a Complex Number parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddComplexNumberParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access,
    GH_ComplexNumber default
)
Visual Basic
Public Function AddComplexNumberParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess, _
    default As GH_ComplexNumber _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.
default
Type: Grasshopper.Kernel.Types..::..GH_ComplexNumber
A default value to store in the parameter Persistent Data.

See Also

GH_Component..::..GH_InputParamManager Class
AddComplexNumberParameter Overload
Grasshopper.Kernel Namespace


AddCultureParameter Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddCultureParameter Method
GH_Component..::..GH_InputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddCultureParameter(String, String, String, GH_ParamAccess) | Add a Cultue parameter to the input list of this component.
Public method | AddCultureParameter(String, String, String, GH_ParamAccess, CultureInfo) | Add a Culture parameter to the input list of this component.

See Also

GH_Component..::..GH_InputParamManager Class
GH_Component..::..GH_InputParamManager Members
Grasshopper.Kernel Namespace


AddCultureParameter Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddCultureParameter Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a Cultue parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddCultureParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddCultureParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.

See Also

GH_Component..::..GH_InputParamManager Class
AddCultureParameter Overload
Grasshopper.Kernel Namespace


AddCultureParameter Method (String, String, String, GH_ParamAccess, CultureInfo)

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddCultureParameter Method (String, String, String, GH_ParamAccess, CultureInfo)
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a Culture parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddCultureParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access,
    CultureInfo default
)
Visual Basic
Public Function AddCultureParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess, _
    default As CultureInfo _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.
default
Type: System.Globalization..::..CultureInfo
A default value to store in the parameter Persistent Data.

See Also

GH_Component..::..GH_InputParamManager Class
AddCultureParameter Overload
Grasshopper.Kernel Namespace


AddCurveParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddCurveParameter Method
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a 3D Curve parameter to the input list of this component. Curve parameters can handle all curve types (Lines, Polylines, Circles, Arcs, NurbsCurves etc.)

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddCurveParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddCurveParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.

See Also

GH_Component..::..GH_InputParamManager Class
Grasshopper.Kernel Namespace


AddFieldParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddFieldParameter Method
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a Field parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddFieldParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddFieldParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.

See Also

GH_Component..::..GH_InputParamManager Class
Grasshopper.Kernel Namespace


AddGenericParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddGenericParameter Method
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a Generic parameter to the input list of this component. Generic parameters can handle all types of data.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddGenericParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddGenericParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.

See Also

GH_Component..::..GH_InputParamManager Class
Grasshopper.Kernel Namespace


AddGeometryParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddGeometryParameter Method
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a generic 3D Geometry parameter to the input list of this component. Geometry parameters can handle all types that represent actual shapes.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddGeometryParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddGeometryParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.

See Also

GH_Component..::..GH_InputParamManager Class
Grasshopper.Kernel Namespace


AddGroupParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddGroupParameter Method
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a Transform Group parameter to the input list of this component. Groups are collections of geometry that are transformed as one, they are not the same as Rhino groups.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddGroupParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddGroupParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.

See Also

GH_Component..::..GH_InputParamManager Class
Grasshopper.Kernel Namespace


AddIntegerParameter Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddIntegerParameter Method
GH_Component..::..GH_InputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddIntegerParameter(String, String, String, GH_ParamAccess) | Add a Integer parameter to the input list of this component.
Public method | AddIntegerParameter(String, String, String, GH_ParamAccess, IEnumerable<(Of <<'(Int32>)>>)) | Add a Integer parameter to the input list of this component.
Public method | AddIntegerParameter(String, String, String, GH_ParamAccess, Int32) | Add a Integer parameter to the input list of this component.

See Also

GH_Component..::..GH_InputParamManager Class
GH_Component..::..GH_InputParamManager Members
Grasshopper.Kernel Namespace


AddIntegerParameter Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddIntegerParameter Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a Integer parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddIntegerParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddIntegerParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.

See Also

GH_Component..::..GH_InputParamManager Class
AddIntegerParameter Overload
Grasshopper.Kernel Namespace


AddIntegerParameter Method (String, String, String, GH_ParamAccess, IEnumerable(Int32))

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddIntegerParameter Method (String, String, String, GH_ParamAccess, IEnumerable<(Of <(<'Int32>)>)>)
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a Integer parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddIntegerParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access,
    IEnumerable<int> default
)
Visual Basic
Public Function AddIntegerParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess, _
    default As IEnumerable(Of Integer) _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.
default
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Int32 >)>)>
A collection of default values to store in the parameter Persistent Data.

See Also

GH_Component..::..GH_InputParamManager Class
AddIntegerParameter Overload
Grasshopper.Kernel Namespace


AddIntegerParameter Method (String, String, String, GH_ParamAccess, Int32)

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddIntegerParameter Method (String, String, String, GH_ParamAccess, Int32)
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a Integer parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddIntegerParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access,
    int default
)
Visual Basic
Public Function AddIntegerParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess, _
    default As Integer _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.
default
Type: System..::..Int32
A default value to store in the parameter Persistent Data.

See Also

GH_Component..::..GH_InputParamManager Class
AddIntegerParameter Overload
Grasshopper.Kernel Namespace


AddInterval2DParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddInterval2DParameter Method
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add an Interval2D (i.e. uv domain) parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddInterval2DParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddInterval2DParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.

See Also

GH_Component..::..GH_InputParamManager Class
Grasshopper.Kernel Namespace


AddIntervalParameter Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddIntervalParameter Method
GH_Component..::..GH_InputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddIntervalParameter(String, String, String, GH_ParamAccess) | Add an Interval (i.e. numeric domain) parameter to the input list of this component.
Public method | AddIntervalParameter(String, String, String, GH_ParamAccess, Interval) | Add an Interval (i.e. numeric domain) parameter to the input list of this component.
Public method | AddIntervalParameter(String, String, String, GH_ParamAccess, IEnumerable<(Of <<'(Interval>)>>)) | Add an Interval (i.e. numeric domain) parameter to the input list of this component.

See Also

GH_Component..::..GH_InputParamManager Class
GH_Component..::..GH_InputParamManager Members
Grasshopper.Kernel Namespace


AddIntervalParameter Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddIntervalParameter Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add an Interval (i.e. numeric domain) parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddIntervalParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddIntervalParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.

See Also

GH_Component..::..GH_InputParamManager Class
AddIntervalParameter Overload
Grasshopper.Kernel Namespace


AddIntervalParameter Method (String, String, String, GH_ParamAccess, )

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddIntervalParameter Method (String, String, String, GH_ParamAccess, )
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add an Interval (i.e. numeric domain) parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddIntervalParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access,
    Interval default
)
Visual Basic
Public Function AddIntervalParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess, _
    default As Interval _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.
default
Type: Interval
A default value to store in the parameter Persistent Data.

See Also

GH_Component..::..GH_InputParamManager Class
AddIntervalParameter Overload
Grasshopper.Kernel Namespace


AddIntervalParameter Method (String, String, String, GH_ParamAccess, IEnumerable())

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddIntervalParameter Method (String, String, String, GH_ParamAccess, IEnumerable<(Of <(<'>)>)>)
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add an Interval (i.e. numeric domain) parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddIntervalParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access,
    IEnumerable<Interval> default
)
Visual Basic
Public Function AddIntervalParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess, _
    default As IEnumerable(Of Interval) _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.
default
Type: System.Collections.Generic..::..IEnumerable <(Of <(<'Interval>)>)>
A collection of default values to store in the parameter Persistent Data.

See Also

GH_Component..::..GH_InputParamManager Class
AddIntervalParameter Overload
Grasshopper.Kernel Namespace


AddLineParameter Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddLineParameter Method
GH_Component..::..GH_InputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddLineParameter(String, String, String, GH_ParamAccess) | Add a 3D Line parameter to the input list of this component.
Public method | AddLineParameter(String, String, String, GH_ParamAccess, Line) | Add a 3D Line parameter to the input list of this component.

See Also

GH_Component..::..GH_InputParamManager Class
GH_Component..::..GH_InputParamManager Members
Grasshopper.Kernel Namespace


AddLineParameter Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddLineParameter Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a 3D Line parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddLineParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddLineParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.

See Also

GH_Component..::..GH_InputParamManager Class
AddLineParameter Overload
Grasshopper.Kernel Namespace


AddLineParameter Method (String, String, String, GH_ParamAccess, )

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddLineParameter Method (String, String, String, GH_ParamAccess, )
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a 3D Line parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddLineParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access,
    Line default
)
Visual Basic
Public Function AddLineParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess, _
    default As Line _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.
default
Type: Line
A default value to store in the parameter Persistent Data.

See Also

GH_Component..::..GH_InputParamManager Class
AddLineParameter Overload
Grasshopper.Kernel Namespace


AddMatrixParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddMatrixParameter Method
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a Matrix parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddMatrixParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddMatrixParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.

See Also

GH_Component..::..GH_InputParamManager Class
Grasshopper.Kernel Namespace


AddMeshFaceParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddMeshFaceParameter Method
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a topological MeshFace parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddMeshFaceParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddMeshFaceParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.

See Also

GH_Component..::..GH_InputParamManager Class
Grasshopper.Kernel Namespace


AddMeshParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddMeshParameter Method
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a 3D Mesh parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddMeshParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddMeshParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.

See Also

GH_Component..::..GH_InputParamManager Class
Grasshopper.Kernel Namespace


AddNumberParameter Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddNumberParameter Method
GH_Component..::..GH_InputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddNumberParameter(String, String, String, GH_ParamAccess) | Add a floating point Number parameter to the input list of this component.
Public method | AddNumberParameter(String, String, String, GH_ParamAccess, IEnumerable<(Of <<'(Double>)>>)) | Add a floating point Number parameter to the input list of this component.
Public method | AddNumberParameter(String, String, String, GH_ParamAccess, Double) | Add a floating point Number parameter to the input list of this component.

See Also

GH_Component..::..GH_InputParamManager Class
GH_Component..::..GH_InputParamManager Members
Grasshopper.Kernel Namespace


AddNumberParameter Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddNumberParameter Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a floating point Number parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddNumberParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddNumberParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.

See Also

GH_Component..::..GH_InputParamManager Class
AddNumberParameter Overload
Grasshopper.Kernel Namespace


AddNumberParameter Method (String, String, String, GH_ParamAccess, IEnumerable(Double))

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddNumberParameter Method (String, String, String, GH_ParamAccess, IEnumerable<(Of <(<'Double>)>)>)
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a floating point Number parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddNumberParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access,
    IEnumerable<double> default
)
Visual Basic
Public Function AddNumberParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess, _
    default As IEnumerable(Of Double) _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.
default
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Double >)>)>
A collection of default values to store in the parameter Persistent Data.

See Also

GH_Component..::..GH_InputParamManager Class
AddNumberParameter Overload
Grasshopper.Kernel Namespace


AddNumberParameter Method (String, String, String, GH_ParamAccess, Double)

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddNumberParameter Method (String, String, String, GH_ParamAccess, Double)
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a floating point Number parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddNumberParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access,
    double default
)
Visual Basic
Public Function AddNumberParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess, _
    default As Double _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.
default
Type: System..::..Double
A default value to store in the parameter Persistent Data.

See Also

GH_Component..::..GH_InputParamManager Class
AddNumberParameter Overload
Grasshopper.Kernel Namespace


AddParameter Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddParameter Method
GH_Component..::..GH_InputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddParameter(IGH_Param) | Generic parameter addition. If you cannot use one of the utility methods provided by this class, you can register a customized parameter using this method.
Public method | AddParameter(IGH_Param, String, String, String, GH_ParamAccess) | Generic parameter addition. If you cannot use one of the utility methods provided by this class, you can register a customized parameter using this method.

See Also

GH_Component..::..GH_InputParamManager Class
GH_Component..::..GH_InputParamManager Members
Grasshopper.Kernel Namespace


AddParameter Method (IGH_Param)

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddParameter Method (IGH_Param)
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Generic parameter addition. If you cannot use one of the utility methods provided by this class, you can register a customized parameter using this method.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddParameter(
    IGH_Param param
)
Visual Basic
Public Function AddParameter ( _
    param As IGH_Param _
) As Integer

Parameters

param
Type: Grasshopper.Kernel..::..IGH_Param
The parameter to add.

Return Value

Index of the newly added parameter.

See Also

GH_Component..::..GH_InputParamManager Class
AddParameter Overload
Grasshopper.Kernel Namespace


AddParameter Method (IGH_Param, String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddParameter Method (IGH_Param, String, String, String, GH_ParamAccess)
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Generic parameter addition. If you cannot use one of the utility methods provided by this class, you can register a customized parameter using this method.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddParameter(
    IGH_Param param,
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddParameter ( _
    param As IGH_Param, _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

param
Type: Grasshopper.Kernel..::..IGH_Param
The parameter to add.
name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.

Return Value

Index of the newly added parameter.

See Also

GH_Component..::..GH_InputParamManager Class
AddParameter Overload
Grasshopper.Kernel Namespace


AddPathParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddPathParameter Method
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a Data Path parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddPathParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddPathParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.

See Also

GH_Component..::..GH_InputParamManager Class
Grasshopper.Kernel Namespace


AddPlaneParameter Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddPlaneParameter Method
GH_Component..::..GH_InputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddPlaneParameter(String, String, String, GH_ParamAccess) | Add a 3D Plane parameter to the input list of this component.
Public method | AddPlaneParameter(String, String, String, GH_ParamAccess, Plane) | Add a 3D Plane parameter to the input list of this component.

See Also

GH_Component..::..GH_InputParamManager Class
GH_Component..::..GH_InputParamManager Members
Grasshopper.Kernel Namespace


AddPlaneParameter Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddPlaneParameter Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a 3D Plane parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddPlaneParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddPlaneParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.

See Also

GH_Component..::..GH_InputParamManager Class
AddPlaneParameter Overload
Grasshopper.Kernel Namespace


AddPlaneParameter Method (String, String, String, GH_ParamAccess, )

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddPlaneParameter Method (String, String, String, GH_ParamAccess, )
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a 3D Plane parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddPlaneParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access,
    Plane default
)
Visual Basic
Public Function AddPlaneParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess, _
    default As Plane _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.
default
Type: Plane
A default value to store in the parameter Persistent Data.

See Also

GH_Component..::..GH_InputParamManager Class
AddPlaneParameter Overload
Grasshopper.Kernel Namespace


AddPointParameter Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddPointParameter Method
GH_Component..::..GH_InputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddPointParameter(String, String, String, GH_ParamAccess) | Add a 3D Point parameter to the input list of this component.
Public method | AddPointParameter(String, String, String, GH_ParamAccess, Point3d) | Register a new 3D point param with a single default coordinate.
Public method | AddPointParameter(String, String, String, GH_ParamAccess, IEnumerable<(Of <<'(Point3d>)>>)) | Register a new 3D point param with multiple default coordinates.

See Also

GH_Component..::..GH_InputParamManager Class
GH_Component..::..GH_InputParamManager Members
Grasshopper.Kernel Namespace


AddPointParameter Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddPointParameter Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a 3D Point parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddPointParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddPointParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.

See Also

GH_Component..::..GH_InputParamManager Class
AddPointParameter Overload
Grasshopper.Kernel Namespace


AddPointParameter Method (String, String, String, GH_ParamAccess, )

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddPointParameter Method (String, String, String, GH_ParamAccess, )
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Register a new 3D point param with a single default coordinate.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddPointParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access,
    Point3d default
)
Visual Basic
Public Function AddPointParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess, _
    default As Point3d _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.
default
Type: Point3d
A default value to store in the parameter Persistent Data.

See Also

GH_Component..::..GH_InputParamManager Class
AddPointParameter Overload
Grasshopper.Kernel Namespace


AddPointParameter Method (String, String, String, GH_ParamAccess, IEnumerable())

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddPointParameter Method (String, String, String, GH_ParamAccess, IEnumerable<(Of <(<'>)>)>)
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Register a new 3D point param with multiple default coordinates.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddPointParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access,
    IEnumerable<Point3d> default
)
Visual Basic
Public Function AddPointParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess, _
    default As IEnumerable(Of Point3d) _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.
default
Type: System.Collections.Generic..::..IEnumerable <(Of <(<'Point3d>)>)>
A collection of default values to store in the parameter Persistent Data.

See Also

GH_Component..::..GH_InputParamManager Class
AddPointParameter Overload
Grasshopper.Kernel Namespace


AddRectangleParameter Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddRectangleParameter Method
GH_Component..::..GH_InputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddRectangleParameter(String, String, String, GH_ParamAccess) | Add a 3D Rectangle parameter to the input list of this component.
Public method | AddRectangleParameter(String, String, String, GH_ParamAccess, Rectangle3d) | Add a 3D Rectangle parameter to the input list of this component.

See Also

GH_Component..::..GH_InputParamManager Class
GH_Component..::..GH_InputParamManager Members
Grasshopper.Kernel Namespace


AddRectangleParameter Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddRectangleParameter Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a 3D Rectangle parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddRectangleParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddRectangleParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.

See Also

GH_Component..::..GH_InputParamManager Class
AddRectangleParameter Overload
Grasshopper.Kernel Namespace


AddRectangleParameter Method (String, String, String, GH_ParamAccess, )

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddRectangleParameter Method (String, String, String, GH_ParamAccess, )
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a 3D Rectangle parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddRectangleParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access,
    Rectangle3d default
)
Visual Basic
Public Function AddRectangleParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess, _
    default As Rectangle3d _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.
default
Type: Rectangle3d
A default value to store in the parameter Persistent Data.

See Also

GH_Component..::..GH_InputParamManager Class
AddRectangleParameter Overload
Grasshopper.Kernel Namespace


AddScriptVariableParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddScriptVariableParameter Method
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a Script Variable parameter to the input list of this component. Script variable parameters are used almost exclusively in VB/C#/Python components so you probably don't want this one.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddScriptVariableParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddScriptVariableParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.

See Also

GH_Component..::..GH_InputParamManager Class
Grasshopper.Kernel Namespace


AddSurfaceParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddSurfaceParameter Method
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a 3D Surface parameter to the input list of this component. Surface parameters can handle both trimmed and untrimmed single-faced Breps.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddSurfaceParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddSurfaceParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.

See Also

GH_Component..::..GH_InputParamManager Class
Grasshopper.Kernel Namespace


AddTextParameter Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddTextParameter Method
GH_Component..::..GH_InputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddTextParameter(String, String, String, GH_ParamAccess) | Add a Text parameter to the input list of this component.
Public method | AddTextParameter(String, String, String, GH_ParamAccess, IEnumerable<(Of <<'(String>)>>)) | Add a Text parameter to the input list of this component.
Public method | AddTextParameter(String, String, String, GH_ParamAccess, String) | Add a Text parameter to the input list of this component.

See Also

GH_Component..::..GH_InputParamManager Class
GH_Component..::..GH_InputParamManager Members
Grasshopper.Kernel Namespace


AddTextParameter Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddTextParameter Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a Text parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddTextParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddTextParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.

See Also

GH_Component..::..GH_InputParamManager Class
AddTextParameter Overload
Grasshopper.Kernel Namespace


AddTextParameter Method (String, String, String, GH_ParamAccess, IEnumerable(String))

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddTextParameter Method (String, String, String, GH_ParamAccess, IEnumerable<(Of <(<'String>)>)>)
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a Text parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddTextParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access,
    IEnumerable<string> default
)
Visual Basic
Public Function AddTextParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess, _
    default As IEnumerable(Of String) _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.
default
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' String >)>)>
A collection of default values to store in the parameter Persistent Data.

See Also

GH_Component..::..GH_InputParamManager Class
AddTextParameter Overload
Grasshopper.Kernel Namespace


AddTextParameter Method (String, String, String, GH_ParamAccess, String)

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddTextParameter Method (String, String, String, GH_ParamAccess, String)
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a Text parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddTextParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access,
    string default
)
Visual Basic
Public Function AddTextParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess, _
    default As String _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.
default
Type: System..::..String
A default value to store in the parameter Persistent Data.

See Also

GH_Component..::..GH_InputParamManager Class
AddTextParameter Overload
Grasshopper.Kernel Namespace


AddTimeParameter Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddTimeParameter Method
GH_Component..::..GH_InputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddTimeParameter(String, String, String, GH_ParamAccess) | Add a Time parameter to the input list of this component.
Public method | AddTimeParameter(String, String, String, GH_ParamAccess, DateTime) | Add a Time parameter to the input list of this component.

See Also

GH_Component..::..GH_InputParamManager Class
GH_Component..::..GH_InputParamManager Members
Grasshopper.Kernel Namespace


AddTimeParameter Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddTimeParameter Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a Time parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddTimeParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddTimeParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.

See Also

GH_Component..::..GH_InputParamManager Class
AddTimeParameter Overload
Grasshopper.Kernel Namespace


AddTimeParameter Method (String, String, String, GH_ParamAccess, DateTime)

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddTimeParameter Method (String, String, String, GH_ParamAccess, DateTime)
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a Time parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddTimeParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access,
    DateTime default
)
Visual Basic
Public Function AddTimeParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess, _
    default As DateTime _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.
default
Type: System..::..DateTime
A default value to store in the parameter Persistent Data.

See Also

GH_Component..::..GH_InputParamManager Class
AddTimeParameter Overload
Grasshopper.Kernel Namespace


AddTransformParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddTransformParameter Method
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a Transformation parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddTransformParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddTransformParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.

See Also

GH_Component..::..GH_InputParamManager Class
Grasshopper.Kernel Namespace


AddVectorParameter Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddVectorParameter Method
GH_Component..::..GH_InputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddVectorParameter(String, String, String, GH_ParamAccess) | Add a 3D Vector parameter to the input list of this component.
Public method | AddVectorParameter(String, String, String, GH_ParamAccess, Vector3d) | Add a 3D Vector parameter to the input list of this component.

See Also

GH_Component..::..GH_InputParamManager Class
GH_Component..::..GH_InputParamManager Members
Grasshopper.Kernel Namespace


AddVectorParameter Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddVectorParameter Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a 3D Vector parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddVectorParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddVectorParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.

See Also

GH_Component..::..GH_InputParamManager Class
AddVectorParameter Overload
Grasshopper.Kernel Namespace


AddVectorParameter Method (String, String, String, GH_ParamAccess, )

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..AddVectorParameter Method (String, String, String, GH_ParamAccess, )
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Add a 3D Vector parameter to the input list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddVectorParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access,
    Vector3d default
)
Visual Basic
Public Function AddVectorParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess, _
    default As Vector3d _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use GetData(), GetDataList() or GetDataTree() respectively.
default
Type: Vector3d
A default value to store in the parameter Persistent Data.

See Also

GH_Component..::..GH_InputParamManager Class
AddVectorParameter Overload
Grasshopper.Kernel Namespace


HideParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..HideParameter Method
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Hide a specific input parameter. If the parameter at the given index implements IGH_PreviewObject then the Hidden flag will be set to True. Otherwise, nothing will happen.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void HideParameter(
    int index
)
Visual Basic
Public Overrides Sub HideParameter ( _
    index As Integer _
)

Parameters

index
Type: System..::..Int32
Index of parameter to hide.

See Also

GH_Component..::..GH_InputParamManager Class
Grasshopper.Kernel Namespace


GH_Component.GH_InputParamManager Properties

[image] [image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager Properties
GH_Component..::..GH_InputParamManager Class See Also Send Feedback

The GH_Component..::..GH_InputParamManager type exposes the following members.

Properties

 | Name | Description
Public property | Param | Gets the input parameter at the given index. (Overrides GH_ParamManagerParam(Int32).)
Public property | ParamCount | Returns the number of input parameters already part of this component. (Overrides GH_ParamManagerParamCount()()()().)

See Also

GH_Component..::..GH_InputParamManager Class
Grasshopper.Kernel Namespace


Param Property

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..Param Property
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Gets the input parameter at the given index.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_Param this[
    int index
] { get; }
Visual Basic
Public Overrides ReadOnly Default Property Param ( _
    index As Integer _
) As IGH_Param
    Get

Parameters

index
Type: System..::..Int32

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Component.GH_InputParamManager.Param(System.Int32)"]

See Also

GH_Component..::..GH_InputParamManager Class
Grasshopper.Kernel Namespace


ParamCount Property

[image]

Grasshopper SDK
GH_Component..::..GH_InputParamManager..::..ParamCount Property
GH_Component..::..GH_InputParamManager Class See Also Send Feedback
Returns the number of input parameters already part of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override int ParamCount { get; }
Visual Basic
Public Overrides ReadOnly Property ParamCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Component.GH_InputParamManager.ParamCount"]

See Also

GH_Component..::..GH_InputParamManager Class
Grasshopper.Kernel Namespace


GH_Component.GH_OutputParamManager Class

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager Class
GH_Component Class Members See Also Send Feedback
This class is used during Component construction to add output parameters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected class GH_OutputParamManager : GH_ParamManager
Visual Basic
Protected Class GH_OutputParamManager _
    Inherits GH_ParamManager

Inheritance Hierarchy

System..::..Object
GH_ParamManager
Grasshopper.Kernel..::..GH_Component..::..GH_OutputParamManager

See Also

GH_Component..::..GH_OutputParamManager Members
Grasshopper.Kernel Namespace


GH_Component.GH_OutputParamManager Members

[image] [image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager Members
GH_Component..::..GH_OutputParamManager Class Methods Properties See Also Send Feedback

Inherit from this class if you wish to create a custom component. Note that you must provide a public, empty constructor which calls the base class constructor.

The GH_Component..::..GH_OutputParamManager type exposes the following members.

Methods

 | Name | Description
Public method | AddArcParameter | Add a 3D Arc parameter to the output list of this component.
Public method | AddBooleanParameter | Add a Boolean parameter to the output list of this component.
Public method | AddBoxParameter | Add a 3D Box parameter to the output list of this component.
Public method | AddBrepParameter | Add a Brep parameter to the output list of this component. Brep parameters can handle both trimmed and untrimmed single or multi-faced Breps.
Public method | AddCircleParameter | Add a 3D Circle parameter to the output list of this component.
Public method | AddColourParameter | Add a ARGB Colour parameter to the output list of this component.
Public method | AddComplexNumberParameter | Add a Complex Number parameter to the output list of this component.
Public method | AddCultureParameter | Add a Culture parameter to the output list of this component.
Public method | AddCurveParameter | Add a Curve parameter to the output list of this component. Curve parameters can handle all curve types (Lines, Polylines, Circles, Arcs, NurbsCurves etc.)
Public method | AddFieldParameter | Add a Field parameter to the output list of this component.
Public method | AddGenericParameter | Add a Generic parameter to the output list of this component. Generic parameters can handle all types of data.
Public method | AddGeometryParameter | Add a Geometry parameter to the output list of this component. Geometry parameters can handle all types that represent actual shapes.
Public method | AddGroupParameter | Add a Transform Group parameter to the output list of this component. Groups are collections of geometry that are transformed as one, they are not the same as Rhino groups.
Public method | AddIntegerParameter | Add a Integer parameter to the output list of this component.
Public method | AddInterval2DParameter | Add a Interval2D (i.e. uv domain) parameter to the output list of this component.
Public method | AddIntervalParameter | Add a Interval (i.e. numeric domain) parameter to the output list of this component.
Public method | AddLineParameter | Add a 3D Line parameter to the output list of this component.
Public method | AddMatrixParameter | Add a Matrix parameter to the output list of this component.
Public method | AddMeshFaceParameter | Add a topological MeshFace parameter to the output list of this component.
Public method | AddMeshParameter | Add a Mesh parameter to the output list of this component.
Public method | AddNumberParameter | Add a floating point Number parameter to the output list of this component.
Public method | AddParameter(IGH_Param) | Generic parameter addition. If you cannot use one of the utility methods provided by this class, you can register a customized parameter using this method.
Public method | AddParameter(IGH_Param, String, String, String, GH_ParamAccess) | Generic parameter addition. If you cannot use one of the utility methods provided by this class, you can register a customized parameter using this method.
Public method | AddPathParameter | Add a Data Path parameter to the output list of this component.
Public method | AddPlaneParameter | Add a 3D Plane parameter to the output list of this component.
Public method | AddPointParameter | Add a 3D Point parameter to the output list of this component.
Public method | AddRectangleParameter | Add a 3D Rectangle parameter to the output list of this component.
Public method | AddSurfaceParameter | Add a Surface parameter to the output list of this component. Surface parameters can handle both trimmed and untrimmed single-faced Breps.
Public method | AddTextParameter | Add a Text parameter to the output list of this component.
Public method | AddTimeParameter | Add a Time parameter to the output list of this component.
Public method | AddTransformParameter | Add a Transformation parameter to the output list of this component.
Public method | AddVectorParameter | Add a 3D Vector parameter to the output list of this component.
Public method | HideParameter | Hide a specific output parameter. If the parameter at the given index implement IGH_PreviewObject then the Hidden flag will be set to True. Otherwise, nothing will happen. (Overrides GH_ParamManagerHideParameter(Int32).)
Public method | Register_2DIntervalParam(String, String, String) | Register a new two-dimensional OnInterval parameter
Public method | Register_2DIntervalParam(String, String, String, GH_ParamAccess) | Register a new two-dimensional OnInterval parameter
Public method | Register_ArcParam(String, String, String) | Register a new 3D arc parameter
Public method | Register_ArcParam(String, String, String, GH_ParamAccess) | Register a new 3D arc parameter
Public method | Register_BooleanParam(String, String, String) | Register a new Boolean primitive parameter
Public method | Register_BooleanParam(String, String, String, GH_ParamAccess) | Register a new Boolean primitive parameter
Public method | Register_BoxParam(String, String, String) | Register a new 3D box parameter
Public method | Register_BoxParam(String, String, String, GH_ParamAccess) | Register a new 3D box parameter
Public method | Register_BRepParam(String, String, String) | Register a new 3D Brep parameter
Public method | Register_BRepParam(String, String, String, GH_ParamAccess) | Register a new 3D Brep parameter
Public method | Register_CircleParam(String, String, String) | Register a new 3D circle parameter
Public method | Register_CircleParam(String, String, String, GH_ParamAccess) | Register a new 3D circle parameter
Public method | Register_ColourParam(String, String, String) | Register a new Colour primitive parameter
Public method | Register_ColourParam(String, String, String, GH_ParamAccess) | Register a new Colour primitive parameter
Public method | Register_ComplexParam(String, String, String) | Register a new Complex primitive parameter
Public method | Register_ComplexParam(String, String, String, GH_ParamAccess) | Register a new Complex primitive parameter
Public method | Register_CurveParam(String, String, String) | Register a new 3D curve parameter
Public method | Register_CurveParam(String, String, String, GH_ParamAccess) | Register a new 3D curve parameter
Public method | Register_DoubleParam(String, String, String) | Register a new Double primitive parameter
Public method | Register_DoubleParam(String, String, String, GH_ParamAccess) | Register a new Double primitive parameter
Public method | Register_FieldParam(String, String, String) | Register a new field parameter
Public method | Register_FieldParam(String, String, String, GH_ParamAccess) | Register a new field parameter
Public method | Register_GenericParam(String, String, String) | Register a new Generic (Object) parameter
Public method | Register_GenericParam(String, String, String, GH_ParamAccess) | Register a new Generic (Object) parameter
Public method | Register_GeometryParam(String, String, String) | Register a new 3D geometry parameter
Public method | Register_GeometryParam(String, String, String, GH_ParamAccess) | Register a new 3D geometry parameter
Public method | Register_GroupParam(String, String, String) | Register a new geometric group parameter
Public method | Register_GroupParam(String, String, String, GH_ParamAccess) | Register a new geometric group parameter
Public method | Register_IntegerParam(String, String, String) | Register a new Integer primitive parameter
Public method | Register_IntegerParam(String, String, String, GH_ParamAccess) | Register a new Integer primitive parameter
Public method | Register_IntervalParam(String, String, String) | Register a new Interval parameter
Public method | Register_IntervalParam(String, String, String, GH_ParamAccess) | Register a new Interval parameter
Public method | Register_LineParam(String, String, String) | Register a new 3D line parameter
Public method | Register_LineParam(String, String, String, GH_ParamAccess) | Register a new 3D line parameter
Public method | Register_MatrixParam(String, String, String) | Register a new matrix parameter
Public method | Register_MatrixParam(String, String, String, GH_ParamAccess) | Register a new matrix parameter
Public method | Register_MeshFaceParam(String, String, String) | Register a new 3D Mesh face parameter
Public method | Register_MeshFaceParam(String, String, String, GH_ParamAccess) | Register a new 3D Mesh face parameter
Public method | Register_MeshParam(String, String, String) | Register a new 3D Mesh parameter
Public method | Register_MeshParam(String, String, String, GH_ParamAccess) | Register a new 3D Mesh parameter
Public method | Register_PathParam(String, String, String) | Register a new Data Structure path parameter
Public method | Register_PathParam(String, String, String, GH_ParamAccess) | Register a new Data Structure path parameter
Public method | Register_PlaneParam(String, String, String) | Register a new 3D plane parameter
Public method | Register_PlaneParam(String, String, String, GH_ParamAccess) | Register a new 3D plane parameter
Public method | Register_PointParam(String, String, String) | Register a new 3D point parameter
Public method | Register_PointParam(String, String, String, GH_ParamAccess) | Register a new 3D point parameter
Public method | Register_RectangleParam(String, String, String) | Register a new 3D rectangle parameter
Public method | Register_RectangleParam(String, String, String, GH_ParamAccess) | Register a new 3D rectangle parameter
Public method | Register_StringParam(String, String, String) | Register a new String primitive parameter
Public method | Register_StringParam(String, String, String, GH_ParamAccess) | Register a new String primitive parameter
Public method | Register_SurfaceParam(String, String, String) | Register a new 3D surface parameter
Public method | Register_SurfaceParam(String, String, String, GH_ParamAccess) | Register a new 3D surface parameter
Public method | Register_TransformParam(String, String, String) | Register a new Transform parameter
Public method | Register_TransformParam(String, String, String, GH_ParamAccess) | Register a new Transform parameter
Public method | Register_VectorParam(String, String, String) | Register a new 3D vector parameter
Public method | Register_VectorParam(String, String, String, GH_ParamAccess) | Register a new 3D vector parameter
Public method | RegisterParam(IGH_Param) | Generic parameter registration. This class provides methods to register standard parameters, but if you have a special type you're in charge of setting it all up yourself.
Public method | RegisterParam(IGH_Param, GH_ParamAccess) | Generic parameter registration. This class provides methods to register standard parameters, but if you have a special type you're in charge of setting it all up yourself.
Public method | RegisterParam(IGH_Param, String, String, String) | Generic parameter registration. This class provides methods to register standard parameters, but if you have a special type you're in charge of setting it all up yourself.
Public method | RegisterParam(IGH_Param, String, String, String, GH_ParamAccess) | Generic parameter registration. This class provides methods to register standard parameters, but if you have a special type you're in charge of setting it all up yourself.

Properties

 | Name | Description
Public property | Param | Gets the output parameter at the given index. (Overrides GH_ParamManagerParam(Int32).)
Public property | ParamCount | Returns the number of output parameters already part of this component. (Overrides GH_ParamManagerParamCount()()()().)

See Also

GH_Component..::..GH_OutputParamManager Class
Grasshopper.Kernel Namespace


GH_Component.GH_OutputParamManager Methods

[image] [image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager Methods
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback

The GH_Component..::..GH_OutputParamManager type exposes the following members.

Methods

 | Name | Description
Public method | AddArcParameter | Add a 3D Arc parameter to the output list of this component.
Public method | AddBooleanParameter | Add a Boolean parameter to the output list of this component.
Public method | AddBoxParameter | Add a 3D Box parameter to the output list of this component.
Public method | AddBrepParameter | Add a Brep parameter to the output list of this component. Brep parameters can handle both trimmed and untrimmed single or multi-faced Breps.
Public method | AddCircleParameter | Add a 3D Circle parameter to the output list of this component.
Public method | AddColourParameter | Add a ARGB Colour parameter to the output list of this component.
Public method | AddComplexNumberParameter | Add a Complex Number parameter to the output list of this component.
Public method | AddCultureParameter | Add a Culture parameter to the output list of this component.
Public method | AddCurveParameter | Add a Curve parameter to the output list of this component. Curve parameters can handle all curve types (Lines, Polylines, Circles, Arcs, NurbsCurves etc.)
Public method | AddFieldParameter | Add a Field parameter to the output list of this component.
Public method | AddGenericParameter | Add a Generic parameter to the output list of this component. Generic parameters can handle all types of data.
Public method | AddGeometryParameter | Add a Geometry parameter to the output list of this component. Geometry parameters can handle all types that represent actual shapes.
Public method | AddGroupParameter | Add a Transform Group parameter to the output list of this component. Groups are collections of geometry that are transformed as one, they are not the same as Rhino groups.
Public method | AddIntegerParameter | Add a Integer parameter to the output list of this component.
Public method | AddInterval2DParameter | Add a Interval2D (i.e. uv domain) parameter to the output list of this component.
Public method | AddIntervalParameter | Add a Interval (i.e. numeric domain) parameter to the output list of this component.
Public method | AddLineParameter | Add a 3D Line parameter to the output list of this component.
Public method | AddMatrixParameter | Add a Matrix parameter to the output list of this component.
Public method | AddMeshFaceParameter | Add a topological MeshFace parameter to the output list of this component.
Public method | AddMeshParameter | Add a Mesh parameter to the output list of this component.
Public method | AddNumberParameter | Add a floating point Number parameter to the output list of this component.
Public method | AddParameter(IGH_Param) | Generic parameter addition. If you cannot use one of the utility methods provided by this class, you can register a customized parameter using this method.
Public method | AddParameter(IGH_Param, String, String, String, GH_ParamAccess) | Generic parameter addition. If you cannot use one of the utility methods provided by this class, you can register a customized parameter using this method.
Public method | AddPathParameter | Add a Data Path parameter to the output list of this component.
Public method | AddPlaneParameter | Add a 3D Plane parameter to the output list of this component.
Public method | AddPointParameter | Add a 3D Point parameter to the output list of this component.
Public method | AddRectangleParameter | Add a 3D Rectangle parameter to the output list of this component.
Public method | AddSurfaceParameter | Add a Surface parameter to the output list of this component. Surface parameters can handle both trimmed and untrimmed single-faced Breps.
Public method | AddTextParameter | Add a Text parameter to the output list of this component.
Public method | AddTimeParameter | Add a Time parameter to the output list of this component.
Public method | AddTransformParameter | Add a Transformation parameter to the output list of this component.
Public method | AddVectorParameter | Add a 3D Vector parameter to the output list of this component.
Public method | HideParameter | Hide a specific output parameter. If the parameter at the given index implement IGH_PreviewObject then the Hidden flag will be set to True. Otherwise, nothing will happen. (Overrides GH_ParamManagerHideParameter(Int32).)
Public method | Register_2DIntervalParam(String, String, String) | Register a new two-dimensional OnInterval parameter
Public method | Register_2DIntervalParam(String, String, String, GH_ParamAccess) | Register a new two-dimensional OnInterval parameter
Public method | Register_ArcParam(String, String, String) | Register a new 3D arc parameter
Public method | Register_ArcParam(String, String, String, GH_ParamAccess) | Register a new 3D arc parameter
Public method | Register_BooleanParam(String, String, String) | Register a new Boolean primitive parameter
Public method | Register_BooleanParam(String, String, String, GH_ParamAccess) | Register a new Boolean primitive parameter
Public method | Register_BoxParam(String, String, String) | Register a new 3D box parameter
Public method | Register_BoxParam(String, String, String, GH_ParamAccess) | Register a new 3D box parameter
Public method | Register_BRepParam(String, String, String) | Register a new 3D Brep parameter
Public method | Register_BRepParam(String, String, String, GH_ParamAccess) | Register a new 3D Brep parameter
Public method | Register_CircleParam(String, String, String) | Register a new 3D circle parameter
Public method | Register_CircleParam(String, String, String, GH_ParamAccess) | Register a new 3D circle parameter
Public method | Register_ColourParam(String, String, String) | Register a new Colour primitive parameter
Public method | Register_ColourParam(String, String, String, GH_ParamAccess) | Register a new Colour primitive parameter
Public method | Register_ComplexParam(String, String, String) | Register a new Complex primitive parameter
Public method | Register_ComplexParam(String, String, String, GH_ParamAccess) | Register a new Complex primitive parameter
Public method | Register_CurveParam(String, String, String) | Register a new 3D curve parameter
Public method | Register_CurveParam(String, String, String, GH_ParamAccess) | Register a new 3D curve parameter
Public method | Register_DoubleParam(String, String, String) | Register a new Double primitive parameter
Public method | Register_DoubleParam(String, String, String, GH_ParamAccess) | Register a new Double primitive parameter
Public method | Register_FieldParam(String, String, String) | Register a new field parameter
Public method | Register_FieldParam(String, String, String, GH_ParamAccess) | Register a new field parameter
Public method | Register_GenericParam(String, String, String) | Register a new Generic (Object) parameter
Public method | Register_GenericParam(String, String, String, GH_ParamAccess) | Register a new Generic (Object) parameter
Public method | Register_GeometryParam(String, String, String) | Register a new 3D geometry parameter
Public method | Register_GeometryParam(String, String, String, GH_ParamAccess) | Register a new 3D geometry parameter
Public method | Register_GroupParam(String, String, String) | Register a new geometric group parameter
Public method | Register_GroupParam(String, String, String, GH_ParamAccess) | Register a new geometric group parameter
Public method | Register_IntegerParam(String, String, String) | Register a new Integer primitive parameter
Public method | Register_IntegerParam(String, String, String, GH_ParamAccess) | Register a new Integer primitive parameter
Public method | Register_IntervalParam(String, String, String) | Register a new Interval parameter
Public method | Register_IntervalParam(String, String, String, GH_ParamAccess) | Register a new Interval parameter
Public method | Register_LineParam(String, String, String) | Register a new 3D line parameter
Public method | Register_LineParam(String, String, String, GH_ParamAccess) | Register a new 3D line parameter
Public method | Register_MatrixParam(String, String, String) | Register a new matrix parameter
Public method | Register_MatrixParam(String, String, String, GH_ParamAccess) | Register a new matrix parameter
Public method | Register_MeshFaceParam(String, String, String) | Register a new 3D Mesh face parameter
Public method | Register_MeshFaceParam(String, String, String, GH_ParamAccess) | Register a new 3D Mesh face parameter
Public method | Register_MeshParam(String, String, String) | Register a new 3D Mesh parameter
Public method | Register_MeshParam(String, String, String, GH_ParamAccess) | Register a new 3D Mesh parameter
Public method | Register_PathParam(String, String, String) | Register a new Data Structure path parameter
Public method | Register_PathParam(String, String, String, GH_ParamAccess) | Register a new Data Structure path parameter
Public method | Register_PlaneParam(String, String, String) | Register a new 3D plane parameter
Public method | Register_PlaneParam(String, String, String, GH_ParamAccess) | Register a new 3D plane parameter
Public method | Register_PointParam(String, String, String) | Register a new 3D point parameter
Public method | Register_PointParam(String, String, String, GH_ParamAccess) | Register a new 3D point parameter
Public method | Register_RectangleParam(String, String, String) | Register a new 3D rectangle parameter
Public method | Register_RectangleParam(String, String, String, GH_ParamAccess) | Register a new 3D rectangle parameter
Public method | Register_StringParam(String, String, String) | Register a new String primitive parameter
Public method | Register_StringParam(String, String, String, GH_ParamAccess) | Register a new String primitive parameter
Public method | Register_SurfaceParam(String, String, String) | Register a new 3D surface parameter
Public method | Register_SurfaceParam(String, String, String, GH_ParamAccess) | Register a new 3D surface parameter
Public method | Register_TransformParam(String, String, String) | Register a new Transform parameter
Public method | Register_TransformParam(String, String, String, GH_ParamAccess) | Register a new Transform parameter
Public method | Register_VectorParam(String, String, String) | Register a new 3D vector parameter
Public method | Register_VectorParam(String, String, String, GH_ParamAccess) | Register a new 3D vector parameter
Public method | RegisterParam(IGH_Param) | Generic parameter registration. This class provides methods to register standard parameters, but if you have a special type you're in charge of setting it all up yourself.
Public method | RegisterParam(IGH_Param, GH_ParamAccess) | Generic parameter registration. This class provides methods to register standard parameters, but if you have a special type you're in charge of setting it all up yourself.
Public method | RegisterParam(IGH_Param, String, String, String) | Generic parameter registration. This class provides methods to register standard parameters, but if you have a special type you're in charge of setting it all up yourself.
Public method | RegisterParam(IGH_Param, String, String, String, GH_ParamAccess) | Generic parameter registration. This class provides methods to register standard parameters, but if you have a special type you're in charge of setting it all up yourself.

See Also

GH_Component..::..GH_OutputParamManager Class
Grasshopper.Kernel Namespace


AddArcParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..AddArcParameter Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Add a 3D Arc parameter to the output list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddArcParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddArcParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use SetData(), SetDataList() or SetDataTree() respectively.

See Also

GH_Component..::..GH_OutputParamManager Class
Grasshopper.Kernel Namespace


AddBooleanParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..AddBooleanParameter Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Add a Boolean parameter to the output list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddBooleanParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddBooleanParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use SetData(), SetDataList() or SetDataTree() respectively.

See Also

GH_Component..::..GH_OutputParamManager Class
Grasshopper.Kernel Namespace


AddBoxParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..AddBoxParameter Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Add a 3D Box parameter to the output list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddBoxParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddBoxParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use SetData(), SetDataList() or SetDataTree() respectively.

See Also

GH_Component..::..GH_OutputParamManager Class
Grasshopper.Kernel Namespace


AddBrepParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..AddBrepParameter Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Add a Brep parameter to the output list of this component. Brep parameters can handle both trimmed and untrimmed single or multi-faced Breps.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddBrepParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddBrepParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use SetData(), SetDataList() or SetDataTree() respectively.

See Also

GH_Component..::..GH_OutputParamManager Class
Grasshopper.Kernel Namespace


AddCircleParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..AddCircleParameter Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Add a 3D Circle parameter to the output list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddCircleParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddCircleParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use SetData(), SetDataList() or SetDataTree() respectively.

See Also

GH_Component..::..GH_OutputParamManager Class
Grasshopper.Kernel Namespace


AddColourParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..AddColourParameter Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Add a ARGB Colour parameter to the output list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddColourParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddColourParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use SetData(), SetDataList() or SetDataTree() respectively.

See Also

GH_Component..::..GH_OutputParamManager Class
Grasshopper.Kernel Namespace


AddComplexNumberParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..AddComplexNumberParameter Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Add a Complex Number parameter to the output list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddComplexNumberParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddComplexNumberParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use SetData(), SetDataList() or SetDataTree() respectively.

See Also

GH_Component..::..GH_OutputParamManager Class
Grasshopper.Kernel Namespace


AddCultureParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..AddCultureParameter Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Add a Culture parameter to the output list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddCultureParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddCultureParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use SetData(), SetDataList() or SetDataTree() respectively.

See Also

GH_Component..::..GH_OutputParamManager Class
Grasshopper.Kernel Namespace


AddCurveParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..AddCurveParameter Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Add a Curve parameter to the output list of this component. Curve parameters can handle all curve types (Lines, Polylines, Circles, Arcs, NurbsCurves etc.)

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddCurveParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddCurveParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use SetData(), SetDataList() or SetDataTree() respectively.

See Also

GH_Component..::..GH_OutputParamManager Class
Grasshopper.Kernel Namespace


AddFieldParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..AddFieldParameter Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Add a Field parameter to the output list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddFieldParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddFieldParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use SetData(), SetDataList() or SetDataTree() respectively.

See Also

GH_Component..::..GH_OutputParamManager Class
Grasshopper.Kernel Namespace


AddGenericParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..AddGenericParameter Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Add a Generic parameter to the output list of this component. Generic parameters can handle all types of data.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddGenericParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddGenericParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use SetData(), SetDataList() or SetDataTree() respectively.

See Also

GH_Component..::..GH_OutputParamManager Class
Grasshopper.Kernel Namespace


AddGeometryParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..AddGeometryParameter Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Add a Geometry parameter to the output list of this component. Geometry parameters can handle all types that represent actual shapes.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddGeometryParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddGeometryParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use SetData(), SetDataList() or SetDataTree() respectively.

See Also

GH_Component..::..GH_OutputParamManager Class
Grasshopper.Kernel Namespace


AddGroupParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..AddGroupParameter Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Add a Transform Group parameter to the output list of this component. Groups are collections of geometry that are transformed as one, they are not the same as Rhino groups.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddGroupParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddGroupParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use SetData(), SetDataList() or SetDataTree() respectively.

See Also

GH_Component..::..GH_OutputParamManager Class
Grasshopper.Kernel Namespace


AddIntegerParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..AddIntegerParameter Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Add a Integer parameter to the output list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddIntegerParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddIntegerParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use SetData(), SetDataList() or SetDataTree() respectively.

See Also

GH_Component..::..GH_OutputParamManager Class
Grasshopper.Kernel Namespace


AddInterval2DParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..AddInterval2DParameter Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Add a Interval2D (i.e. uv domain) parameter to the output list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddInterval2DParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddInterval2DParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use SetData(), SetDataList() or SetDataTree() respectively.

See Also

GH_Component..::..GH_OutputParamManager Class
Grasshopper.Kernel Namespace


AddIntervalParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..AddIntervalParameter Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Add a Interval (i.e. numeric domain) parameter to the output list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddIntervalParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddIntervalParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use SetData(), SetDataList() or SetDataTree() respectively.

See Also

GH_Component..::..GH_OutputParamManager Class
Grasshopper.Kernel Namespace


AddLineParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..AddLineParameter Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Add a 3D Line parameter to the output list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddLineParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddLineParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use SetData(), SetDataList() or SetDataTree() respectively.

See Also

GH_Component..::..GH_OutputParamManager Class
Grasshopper.Kernel Namespace


AddMatrixParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..AddMatrixParameter Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Add a Matrix parameter to the output list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddMatrixParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddMatrixParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use SetData(), SetDataList() or SetDataTree() respectively.

See Also

GH_Component..::..GH_OutputParamManager Class
Grasshopper.Kernel Namespace


AddMeshFaceParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..AddMeshFaceParameter Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Add a topological MeshFace parameter to the output list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddMeshFaceParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddMeshFaceParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use SetData(), SetDataList() or SetDataTree() respectively.

See Also

GH_Component..::..GH_OutputParamManager Class
Grasshopper.Kernel Namespace


AddMeshParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..AddMeshParameter Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Add a Mesh parameter to the output list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddMeshParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddMeshParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use SetData(), SetDataList() or SetDataTree() respectively.

See Also

GH_Component..::..GH_OutputParamManager Class
Grasshopper.Kernel Namespace


AddNumberParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..AddNumberParameter Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Add a floating point Number parameter to the output list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddNumberParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddNumberParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use SetData(), SetDataList() or SetDataTree() respectively.

See Also

GH_Component..::..GH_OutputParamManager Class
Grasshopper.Kernel Namespace


AddParameter Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..AddParameter Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddParameter(IGH_Param) | Generic parameter addition. If you cannot use one of the utility methods provided by this class, you can register a customized parameter using this method.
Public method | AddParameter(IGH_Param, String, String, String, GH_ParamAccess) | Generic parameter addition. If you cannot use one of the utility methods provided by this class, you can register a customized parameter using this method.

See Also

GH_Component..::..GH_OutputParamManager Class
GH_Component..::..GH_OutputParamManager Members
Grasshopper.Kernel Namespace


AddParameter Method (IGH_Param)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..AddParameter Method (IGH_Param)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Generic parameter addition. If you cannot use one of the utility methods provided by this class, you can register a customized parameter using this method.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddParameter(
    IGH_Param param
)
Visual Basic
Public Function AddParameter ( _
    param As IGH_Param _
) As Integer

Parameters

param
Type: Grasshopper.Kernel..::..IGH_Param
The parameter to add.

Return Value

Index of the newly added parameter.

See Also

GH_Component..::..GH_OutputParamManager Class
AddParameter Overload
Grasshopper.Kernel Namespace


AddParameter Method (IGH_Param, String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..AddParameter Method (IGH_Param, String, String, String, GH_ParamAccess)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Generic parameter addition. If you cannot use one of the utility methods provided by this class, you can register a customized parameter using this method.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddParameter(
    IGH_Param param,
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddParameter ( _
    param As IGH_Param, _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

param
Type: Grasshopper.Kernel..::..IGH_Param
The parameter to add.
name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use SetData(), SetDataList() or SetDataTree() respectively.

Return Value

Index of the newly added parameter.

See Also

GH_Component..::..GH_OutputParamManager Class
AddParameter Overload
Grasshopper.Kernel Namespace


AddPathParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..AddPathParameter Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Add a Data Path parameter to the output list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddPathParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddPathParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use SetData(), SetDataList() or SetDataTree() respectively.

See Also

GH_Component..::..GH_OutputParamManager Class
Grasshopper.Kernel Namespace


AddPlaneParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..AddPlaneParameter Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Add a 3D Plane parameter to the output list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddPlaneParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddPlaneParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use SetData(), SetDataList() or SetDataTree() respectively.

See Also

GH_Component..::..GH_OutputParamManager Class
Grasshopper.Kernel Namespace


AddPointParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..AddPointParameter Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Add a 3D Point parameter to the output list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddPointParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddPointParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use SetData(), SetDataList() or SetDataTree() respectively.

See Also

GH_Component..::..GH_OutputParamManager Class
Grasshopper.Kernel Namespace


AddRectangleParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..AddRectangleParameter Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Add a 3D Rectangle parameter to the output list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddRectangleParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddRectangleParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use SetData(), SetDataList() or SetDataTree() respectively.

See Also

GH_Component..::..GH_OutputParamManager Class
Grasshopper.Kernel Namespace


AddSurfaceParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..AddSurfaceParameter Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Add a Surface parameter to the output list of this component. Surface parameters can handle both trimmed and untrimmed single-faced Breps.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddSurfaceParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddSurfaceParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use SetData(), SetDataList() or SetDataTree() respectively.

See Also

GH_Component..::..GH_OutputParamManager Class
Grasshopper.Kernel Namespace


AddTextParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..AddTextParameter Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Add a Text parameter to the output list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddTextParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddTextParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use SetData(), SetDataList() or SetDataTree() respectively.

See Also

GH_Component..::..GH_OutputParamManager Class
Grasshopper.Kernel Namespace


AddTimeParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..AddTimeParameter Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Add a Time parameter to the output list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddTimeParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddTimeParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use SetData(), SetDataList() or SetDataTree() respectively.

See Also

GH_Component..::..GH_OutputParamManager Class
Grasshopper.Kernel Namespace


AddTransformParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..AddTransformParameter Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Add a Transformation parameter to the output list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddTransformParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddTransformParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use SetData(), SetDataList() or SetDataTree() respectively.

See Also

GH_Component..::..GH_OutputParamManager Class
Grasshopper.Kernel Namespace


AddVectorParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..AddVectorParameter Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Add a 3D Vector parameter to the output list of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AddVectorParameter(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Function AddVectorParameter ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
) As Integer

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear, single sentences are best.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access type. You must provide a correct access code in order to use SetData(), SetDataList() or SetDataTree() respectively.

See Also

GH_Component..::..GH_OutputParamManager Class
Grasshopper.Kernel Namespace


HideParameter Method

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..HideParameter Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Hide a specific output parameter. If the parameter at the given index implement IGH_PreviewObject then the Hidden flag will be set to True. Otherwise, nothing will happen.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void HideParameter(
    int index
)
Visual Basic
Public Overrides Sub HideParameter ( _
    index As Integer _
)

Parameters

index
Type: System..::..Int32
Index of parameter to hide.

See Also

GH_Component..::..GH_OutputParamManager Class
Grasshopper.Kernel Namespace


Register_2DIntervalParam Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_2DIntervalParam Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Register_2DIntervalParam(String, String, String) | Register a new two-dimensional OnInterval parameter
Public method | Register_2DIntervalParam(String, String, String, GH_ParamAccess) | Register a new two-dimensional OnInterval parameter

See Also

GH_Component..::..GH_OutputParamManager Class
GH_Component..::..GH_OutputParamManager Members
Grasshopper.Kernel Namespace


Register_2DIntervalParam Method (String, String, String)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_2DIntervalParam Method (String, String, String)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new two-dimensional OnInterval parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_2DIntervalParam(
    string name,
    string nickname,
    string description
)
Visual Basic
Public Sub Register_2DIntervalParam ( _
    name As String, _
    nickname As String, _
    description As String _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.

Remarks

See Also

GH_Component..::..GH_OutputParamManager Class
Register_2DIntervalParam Overload
Grasshopper.Kernel Namespace


Register_2DIntervalParam Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_2DIntervalParam Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new two-dimensional OnInterval parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_2DIntervalParam(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Sub Register_2DIntervalParam ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access, you should set this field if you intend to output lists here.

See Also

GH_Component..::..GH_OutputParamManager Class
Register_2DIntervalParam Overload
Grasshopper.Kernel Namespace


Register_ArcParam Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_ArcParam Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Register_ArcParam(String, String, String) | Register a new 3D arc parameter
Public method | Register_ArcParam(String, String, String, GH_ParamAccess) | Register a new 3D arc parameter

See Also

GH_Component..::..GH_OutputParamManager Class
GH_Component..::..GH_OutputParamManager Members
Grasshopper.Kernel Namespace


Register_ArcParam Method (String, String, String)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_ArcParam Method (String, String, String)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new 3D arc parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_ArcParam(
    string name,
    string nickname,
    string description
)
Visual Basic
Public Sub Register_ArcParam ( _
    name As String, _
    nickname As String, _
    description As String _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.

Remarks

See Also

GH_Component..::..GH_OutputParamManager Class
Register_ArcParam Overload
Grasshopper.Kernel Namespace


Register_ArcParam Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_ArcParam Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new 3D arc parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_ArcParam(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Sub Register_ArcParam ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access, you should set this field if you intend to output lists here.

See Also

GH_Component..::..GH_OutputParamManager Class
Register_ArcParam Overload
Grasshopper.Kernel Namespace


Register_BooleanParam Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_BooleanParam Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Register_BooleanParam(String, String, String) | Register a new Boolean primitive parameter
Public method | Register_BooleanParam(String, String, String, GH_ParamAccess) | Register a new Boolean primitive parameter

See Also

GH_Component..::..GH_OutputParamManager Class
GH_Component..::..GH_OutputParamManager Members
Grasshopper.Kernel Namespace


Register_BooleanParam Method (String, String, String)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_BooleanParam Method (String, String, String)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new Boolean primitive parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_BooleanParam(
    string name,
    string nickname,
    string description
)
Visual Basic
Public Sub Register_BooleanParam ( _
    name As String, _
    nickname As String, _
    description As String _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.

Remarks

See Also

GH_Component..::..GH_OutputParamManager Class
Register_BooleanParam Overload
Grasshopper.Kernel Namespace


Register_BooleanParam Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_BooleanParam Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new Boolean primitive parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_BooleanParam(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Sub Register_BooleanParam ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access, you should set this field if you intend to output lists here.

See Also

GH_Component..::..GH_OutputParamManager Class
Register_BooleanParam Overload
Grasshopper.Kernel Namespace


Register_BoxParam Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_BoxParam Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Register_BoxParam(String, String, String) | Register a new 3D box parameter
Public method | Register_BoxParam(String, String, String, GH_ParamAccess) | Register a new 3D box parameter

See Also

GH_Component..::..GH_OutputParamManager Class
GH_Component..::..GH_OutputParamManager Members
Grasshopper.Kernel Namespace


Register_BoxParam Method (String, String, String)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_BoxParam Method (String, String, String)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new 3D box parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_BoxParam(
    string name,
    string nickname,
    string description
)
Visual Basic
Public Sub Register_BoxParam ( _
    name As String, _
    nickname As String, _
    description As String _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.

Remarks

See Also

GH_Component..::..GH_OutputParamManager Class
Register_BoxParam Overload
Grasshopper.Kernel Namespace


Register_BoxParam Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_BoxParam Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new 3D box parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_BoxParam(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Sub Register_BoxParam ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access, you should set this field if you intend to output lists here.

See Also

GH_Component..::..GH_OutputParamManager Class
Register_BoxParam Overload
Grasshopper.Kernel Namespace


Register_BRepParam Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_BRepParam Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Register_BRepParam(String, String, String) | Register a new 3D Brep parameter
Public method | Register_BRepParam(String, String, String, GH_ParamAccess) | Register a new 3D Brep parameter

See Also

GH_Component..::..GH_OutputParamManager Class
GH_Component..::..GH_OutputParamManager Members
Grasshopper.Kernel Namespace


Register_BRepParam Method (String, String, String)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_BRepParam Method (String, String, String)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new 3D Brep parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_BRepParam(
    string name,
    string nickname,
    string description
)
Visual Basic
Public Sub Register_BRepParam ( _
    name As String, _
    nickname As String, _
    description As String _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.

Remarks

See Also

GH_Component..::..GH_OutputParamManager Class
Register_BRepParam Overload
Grasshopper.Kernel Namespace


Register_BRepParam Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_BRepParam Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new 3D Brep parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_BRepParam(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Sub Register_BRepParam ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access, you should set this field if you intend to output lists here.

See Also

GH_Component..::..GH_OutputParamManager Class
Register_BRepParam Overload
Grasshopper.Kernel Namespace


Register_CircleParam Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_CircleParam Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Register_CircleParam(String, String, String) | Register a new 3D circle parameter
Public method | Register_CircleParam(String, String, String, GH_ParamAccess) | Register a new 3D circle parameter

See Also

GH_Component..::..GH_OutputParamManager Class
GH_Component..::..GH_OutputParamManager Members
Grasshopper.Kernel Namespace


Register_CircleParam Method (String, String, String)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_CircleParam Method (String, String, String)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new 3D circle parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_CircleParam(
    string name,
    string nickname,
    string description
)
Visual Basic
Public Sub Register_CircleParam ( _
    name As String, _
    nickname As String, _
    description As String _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.

Remarks

See Also

GH_Component..::..GH_OutputParamManager Class
Register_CircleParam Overload
Grasshopper.Kernel Namespace


Register_CircleParam Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_CircleParam Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new 3D circle parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_CircleParam(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Sub Register_CircleParam ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access, you should set this field if you intend to output lists here.

See Also

GH_Component..::..GH_OutputParamManager Class
Register_CircleParam Overload
Grasshopper.Kernel Namespace


Register_ColourParam Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_ColourParam Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Register_ColourParam(String, String, String) | Register a new Colour primitive parameter
Public method | Register_ColourParam(String, String, String, GH_ParamAccess) | Register a new Colour primitive parameter

See Also

GH_Component..::..GH_OutputParamManager Class
GH_Component..::..GH_OutputParamManager Members
Grasshopper.Kernel Namespace


Register_ColourParam Method (String, String, String)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_ColourParam Method (String, String, String)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new Colour primitive parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_ColourParam(
    string name,
    string nickname,
    string description
)
Visual Basic
Public Sub Register_ColourParam ( _
    name As String, _
    nickname As String, _
    description As String _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.

Remarks

See Also

GH_Component..::..GH_OutputParamManager Class
Register_ColourParam Overload
Grasshopper.Kernel Namespace


Register_ColourParam Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_ColourParam Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new Colour primitive parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_ColourParam(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Sub Register_ColourParam ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access, you should set this field if you intend to output lists here.

See Also

GH_Component..::..GH_OutputParamManager Class
Register_ColourParam Overload
Grasshopper.Kernel Namespace


Register_ComplexParam Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_ComplexParam Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Register_ComplexParam(String, String, String) | Register a new Complex primitive parameter
Public method | Register_ComplexParam(String, String, String, GH_ParamAccess) | Register a new Complex primitive parameter

See Also

GH_Component..::..GH_OutputParamManager Class
GH_Component..::..GH_OutputParamManager Members
Grasshopper.Kernel Namespace


Register_ComplexParam Method (String, String, String)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_ComplexParam Method (String, String, String)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new Complex primitive parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_ComplexParam(
    string name,
    string nickname,
    string description
)
Visual Basic
Public Sub Register_ComplexParam ( _
    name As String, _
    nickname As String, _
    description As String _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.

Remarks

See Also

GH_Component..::..GH_OutputParamManager Class
Register_ComplexParam Overload
Grasshopper.Kernel Namespace


Register_ComplexParam Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_ComplexParam Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new Complex primitive parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_ComplexParam(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Sub Register_ComplexParam ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access, you should set this field if you intend to output lists here.

See Also

GH_Component..::..GH_OutputParamManager Class
Register_ComplexParam Overload
Grasshopper.Kernel Namespace


Register_CurveParam Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_CurveParam Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Register_CurveParam(String, String, String) | Register a new 3D curve parameter
Public method | Register_CurveParam(String, String, String, GH_ParamAccess) | Register a new 3D curve parameter

See Also

GH_Component..::..GH_OutputParamManager Class
GH_Component..::..GH_OutputParamManager Members
Grasshopper.Kernel Namespace


Register_CurveParam Method (String, String, String)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_CurveParam Method (String, String, String)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new 3D curve parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_CurveParam(
    string name,
    string nickname,
    string description
)
Visual Basic
Public Sub Register_CurveParam ( _
    name As String, _
    nickname As String, _
    description As String _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.

Remarks

See Also

GH_Component..::..GH_OutputParamManager Class
Register_CurveParam Overload
Grasshopper.Kernel Namespace


Register_CurveParam Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_CurveParam Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new 3D curve parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_CurveParam(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Sub Register_CurveParam ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access, you should set this field if you intend to output lists here.

See Also

GH_Component..::..GH_OutputParamManager Class
Register_CurveParam Overload
Grasshopper.Kernel Namespace


Register_DoubleParam Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_DoubleParam Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Register_DoubleParam(String, String, String) | Register a new Double primitive parameter
Public method | Register_DoubleParam(String, String, String, GH_ParamAccess) | Register a new Double primitive parameter

See Also

GH_Component..::..GH_OutputParamManager Class
GH_Component..::..GH_OutputParamManager Members
Grasshopper.Kernel Namespace


Register_DoubleParam Method (String, String, String)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_DoubleParam Method (String, String, String)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new Double primitive parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_DoubleParam(
    string name,
    string nickname,
    string description
)
Visual Basic
Public Sub Register_DoubleParam ( _
    name As String, _
    nickname As String, _
    description As String _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.

Remarks

See Also

GH_Component..::..GH_OutputParamManager Class
Register_DoubleParam Overload
Grasshopper.Kernel Namespace


Register_DoubleParam Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_DoubleParam Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new Double primitive parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_DoubleParam(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Sub Register_DoubleParam ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access, you should set this field if you intend to output lists here.

See Also

GH_Component..::..GH_OutputParamManager Class
Register_DoubleParam Overload
Grasshopper.Kernel Namespace


Register_FieldParam Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_FieldParam Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Register_FieldParam(String, String, String) | Register a new field parameter
Public method | Register_FieldParam(String, String, String, GH_ParamAccess) | Register a new field parameter

See Also

GH_Component..::..GH_OutputParamManager Class
GH_Component..::..GH_OutputParamManager Members
Grasshopper.Kernel Namespace


Register_FieldParam Method (String, String, String)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_FieldParam Method (String, String, String)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new field parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_FieldParam(
    string name,
    string nickname,
    string description
)
Visual Basic
Public Sub Register_FieldParam ( _
    name As String, _
    nickname As String, _
    description As String _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.

Remarks

See Also

GH_Component..::..GH_OutputParamManager Class
Register_FieldParam Overload
Grasshopper.Kernel Namespace


Register_FieldParam Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_FieldParam Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new field parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_FieldParam(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Sub Register_FieldParam ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access, you should set this field if you intend to output lists here.

See Also

GH_Component..::..GH_OutputParamManager Class
Register_FieldParam Overload
Grasshopper.Kernel Namespace


Register_GenericParam Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_GenericParam Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Register_GenericParam(String, String, String) | Register a new Generic (Object) parameter
Public method | Register_GenericParam(String, String, String, GH_ParamAccess) | Register a new Generic (Object) parameter

See Also

GH_Component..::..GH_OutputParamManager Class
GH_Component..::..GH_OutputParamManager Members
Grasshopper.Kernel Namespace


Register_GenericParam Method (String, String, String)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_GenericParam Method (String, String, String)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new Generic (Object) parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_GenericParam(
    string name,
    string nickname,
    string description
)
Visual Basic
Public Sub Register_GenericParam ( _
    name As String, _
    nickname As String, _
    description As String _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.

Remarks

See Also

GH_Component..::..GH_OutputParamManager Class
Register_GenericParam Overload
Grasshopper.Kernel Namespace


Register_GenericParam Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_GenericParam Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new Generic (Object) parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_GenericParam(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Sub Register_GenericParam ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access, you should set this field if you intend to output lists here.

See Also

GH_Component..::..GH_OutputParamManager Class
Register_GenericParam Overload
Grasshopper.Kernel Namespace


Register_GeometryParam Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_GeometryParam Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Register_GeometryParam(String, String, String) | Register a new 3D geometry parameter
Public method | Register_GeometryParam(String, String, String, GH_ParamAccess) | Register a new 3D geometry parameter

See Also

GH_Component..::..GH_OutputParamManager Class
GH_Component..::..GH_OutputParamManager Members
Grasshopper.Kernel Namespace


Register_GeometryParam Method (String, String, String)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_GeometryParam Method (String, String, String)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new 3D geometry parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_GeometryParam(
    string name,
    string nickname,
    string description
)
Visual Basic
Public Sub Register_GeometryParam ( _
    name As String, _
    nickname As String, _
    description As String _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.

Remarks

See Also

GH_Component..::..GH_OutputParamManager Class
Register_GeometryParam Overload
Grasshopper.Kernel Namespace


Register_GeometryParam Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_GeometryParam Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new 3D geometry parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_GeometryParam(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Sub Register_GeometryParam ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access, you should set this field if you intend to output lists here.

See Also

GH_Component..::..GH_OutputParamManager Class
Register_GeometryParam Overload
Grasshopper.Kernel Namespace


Register_GroupParam Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_GroupParam Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Register_GroupParam(String, String, String) | Register a new geometric group parameter
Public method | Register_GroupParam(String, String, String, GH_ParamAccess) | Register a new geometric group parameter

See Also

GH_Component..::..GH_OutputParamManager Class
GH_Component..::..GH_OutputParamManager Members
Grasshopper.Kernel Namespace


Register_GroupParam Method (String, String, String)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_GroupParam Method (String, String, String)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new geometric group parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_GroupParam(
    string name,
    string nickname,
    string description
)
Visual Basic
Public Sub Register_GroupParam ( _
    name As String, _
    nickname As String, _
    description As String _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.

Remarks

See Also

GH_Component..::..GH_OutputParamManager Class
Register_GroupParam Overload
Grasshopper.Kernel Namespace


Register_GroupParam Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_GroupParam Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new geometric group parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_GroupParam(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Sub Register_GroupParam ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access, you should set this field if you intend to output lists here.

See Also

GH_Component..::..GH_OutputParamManager Class
Register_GroupParam Overload
Grasshopper.Kernel Namespace


Register_IntegerParam Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_IntegerParam Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Register_IntegerParam(String, String, String) | Register a new Integer primitive parameter
Public method | Register_IntegerParam(String, String, String, GH_ParamAccess) | Register a new Integer primitive parameter

See Also

GH_Component..::..GH_OutputParamManager Class
GH_Component..::..GH_OutputParamManager Members
Grasshopper.Kernel Namespace


Register_IntegerParam Method (String, String, String)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_IntegerParam Method (String, String, String)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new Integer primitive parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_IntegerParam(
    string name,
    string nickname,
    string description
)
Visual Basic
Public Sub Register_IntegerParam ( _
    name As String, _
    nickname As String, _
    description As String _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.

Remarks

See Also

GH_Component..::..GH_OutputParamManager Class
Register_IntegerParam Overload
Grasshopper.Kernel Namespace


Register_IntegerParam Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_IntegerParam Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new Integer primitive parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_IntegerParam(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Sub Register_IntegerParam ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access, you should set this field if you intend to output lists here.

See Also

GH_Component..::..GH_OutputParamManager Class
Register_IntegerParam Overload
Grasshopper.Kernel Namespace


Register_IntervalParam Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_IntervalParam Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Register_IntervalParam(String, String, String) | Register a new Interval parameter
Public method | Register_IntervalParam(String, String, String, GH_ParamAccess) | Register a new Interval parameter

See Also

GH_Component..::..GH_OutputParamManager Class
GH_Component..::..GH_OutputParamManager Members
Grasshopper.Kernel Namespace


Register_IntervalParam Method (String, String, String)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_IntervalParam Method (String, String, String)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new Interval parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_IntervalParam(
    string name,
    string nickname,
    string description
)
Visual Basic
Public Sub Register_IntervalParam ( _
    name As String, _
    nickname As String, _
    description As String _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.

Remarks

See Also

GH_Component..::..GH_OutputParamManager Class
Register_IntervalParam Overload
Grasshopper.Kernel Namespace


Register_IntervalParam Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_IntervalParam Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new Interval parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_IntervalParam(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Sub Register_IntervalParam ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access, you should set this field if you intend to output lists here.

See Also

GH_Component..::..GH_OutputParamManager Class
Register_IntervalParam Overload
Grasshopper.Kernel Namespace


Register_LineParam Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_LineParam Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Register_LineParam(String, String, String) | Register a new 3D line parameter
Public method | Register_LineParam(String, String, String, GH_ParamAccess) | Register a new 3D line parameter

See Also

GH_Component..::..GH_OutputParamManager Class
GH_Component..::..GH_OutputParamManager Members
Grasshopper.Kernel Namespace


Register_LineParam Method (String, String, String)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_LineParam Method (String, String, String)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new 3D line parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_LineParam(
    string name,
    string nickname,
    string description
)
Visual Basic
Public Sub Register_LineParam ( _
    name As String, _
    nickname As String, _
    description As String _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.

Remarks

See Also

GH_Component..::..GH_OutputParamManager Class
Register_LineParam Overload
Grasshopper.Kernel Namespace


Register_LineParam Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_LineParam Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new 3D line parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_LineParam(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Sub Register_LineParam ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access, you should set this field if you intend to output lists here.

See Also

GH_Component..::..GH_OutputParamManager Class
Register_LineParam Overload
Grasshopper.Kernel Namespace


Register_MatrixParam Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_MatrixParam Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Register_MatrixParam(String, String, String) | Register a new matrix parameter
Public method | Register_MatrixParam(String, String, String, GH_ParamAccess) | Register a new matrix parameter

See Also

GH_Component..::..GH_OutputParamManager Class
GH_Component..::..GH_OutputParamManager Members
Grasshopper.Kernel Namespace


Register_MatrixParam Method (String, String, String)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_MatrixParam Method (String, String, String)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new matrix parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_MatrixParam(
    string name,
    string nickname,
    string description
)
Visual Basic
Public Sub Register_MatrixParam ( _
    name As String, _
    nickname As String, _
    description As String _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.

Remarks

See Also

GH_Component..::..GH_OutputParamManager Class
Register_MatrixParam Overload
Grasshopper.Kernel Namespace


Register_MatrixParam Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_MatrixParam Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new matrix parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_MatrixParam(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Sub Register_MatrixParam ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access, you should set this field if you intend to output lists here.

See Also

GH_Component..::..GH_OutputParamManager Class
Register_MatrixParam Overload
Grasshopper.Kernel Namespace


Register_MeshFaceParam Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_MeshFaceParam Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Register_MeshFaceParam(String, String, String) | Register a new 3D Mesh face parameter
Public method | Register_MeshFaceParam(String, String, String, GH_ParamAccess) | Register a new 3D Mesh face parameter

See Also

GH_Component..::..GH_OutputParamManager Class
GH_Component..::..GH_OutputParamManager Members
Grasshopper.Kernel Namespace


Register_MeshFaceParam Method (String, String, String)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_MeshFaceParam Method (String, String, String)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new 3D Mesh face parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_MeshFaceParam(
    string name,
    string nickname,
    string description
)
Visual Basic
Public Sub Register_MeshFaceParam ( _
    name As String, _
    nickname As String, _
    description As String _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.

Remarks

See Also

GH_Component..::..GH_OutputParamManager Class
Register_MeshFaceParam Overload
Grasshopper.Kernel Namespace


Register_MeshFaceParam Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_MeshFaceParam Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new 3D Mesh face parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_MeshFaceParam(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Sub Register_MeshFaceParam ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access, you should set this field if you intend to output lists here.

See Also

GH_Component..::..GH_OutputParamManager Class
Register_MeshFaceParam Overload
Grasshopper.Kernel Namespace


Register_MeshParam Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_MeshParam Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Register_MeshParam(String, String, String) | Register a new 3D Mesh parameter
Public method | Register_MeshParam(String, String, String, GH_ParamAccess) | Register a new 3D Mesh parameter

See Also

GH_Component..::..GH_OutputParamManager Class
GH_Component..::..GH_OutputParamManager Members
Grasshopper.Kernel Namespace


Register_MeshParam Method (String, String, String)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_MeshParam Method (String, String, String)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new 3D Mesh parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_MeshParam(
    string name,
    string nickname,
    string description
)
Visual Basic
Public Sub Register_MeshParam ( _
    name As String, _
    nickname As String, _
    description As String _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.

Remarks

See Also

GH_Component..::..GH_OutputParamManager Class
Register_MeshParam Overload
Grasshopper.Kernel Namespace


Register_MeshParam Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_MeshParam Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new 3D Mesh parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_MeshParam(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Sub Register_MeshParam ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access, you should set this field if you intend to output lists here.

See Also

GH_Component..::..GH_OutputParamManager Class
Register_MeshParam Overload
Grasshopper.Kernel Namespace


Register_PathParam Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_PathParam Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Register_PathParam(String, String, String) | Register a new Data Structure path parameter
Public method | Register_PathParam(String, String, String, GH_ParamAccess) | Register a new Data Structure path parameter

See Also

GH_Component..::..GH_OutputParamManager Class
GH_Component..::..GH_OutputParamManager Members
Grasshopper.Kernel Namespace


Register_PathParam Method (String, String, String)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_PathParam Method (String, String, String)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new Data Structure path parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_PathParam(
    string name,
    string nickname,
    string description
)
Visual Basic
Public Sub Register_PathParam ( _
    name As String, _
    nickname As String, _
    description As String _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.

Remarks

See Also

GH_Component..::..GH_OutputParamManager Class
Register_PathParam Overload
Grasshopper.Kernel Namespace


Register_PathParam Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_PathParam Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new Data Structure path parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_PathParam(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Sub Register_PathParam ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access, you should set this field if you intend to output lists here.

See Also

GH_Component..::..GH_OutputParamManager Class
Register_PathParam Overload
Grasshopper.Kernel Namespace


Register_PlaneParam Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_PlaneParam Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Register_PlaneParam(String, String, String) | Register a new 3D plane parameter
Public method | Register_PlaneParam(String, String, String, GH_ParamAccess) | Register a new 3D plane parameter

See Also

GH_Component..::..GH_OutputParamManager Class
GH_Component..::..GH_OutputParamManager Members
Grasshopper.Kernel Namespace


Register_PlaneParam Method (String, String, String)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_PlaneParam Method (String, String, String)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new 3D plane parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_PlaneParam(
    string name,
    string nickname,
    string description
)
Visual Basic
Public Sub Register_PlaneParam ( _
    name As String, _
    nickname As String, _
    description As String _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.

Remarks

See Also

GH_Component..::..GH_OutputParamManager Class
Register_PlaneParam Overload
Grasshopper.Kernel Namespace


Register_PlaneParam Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_PlaneParam Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new 3D plane parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_PlaneParam(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Sub Register_PlaneParam ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access, you should set this field if you intend to output lists here.

See Also

GH_Component..::..GH_OutputParamManager Class
Register_PlaneParam Overload
Grasshopper.Kernel Namespace


Register_PointParam Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_PointParam Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Register_PointParam(String, String, String) | Register a new 3D point parameter
Public method | Register_PointParam(String, String, String, GH_ParamAccess) | Register a new 3D point parameter

See Also

GH_Component..::..GH_OutputParamManager Class
GH_Component..::..GH_OutputParamManager Members
Grasshopper.Kernel Namespace


Register_PointParam Method (String, String, String)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_PointParam Method (String, String, String)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new 3D point parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_PointParam(
    string name,
    string nickname,
    string description
)
Visual Basic
Public Sub Register_PointParam ( _
    name As String, _
    nickname As String, _
    description As String _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.

Remarks

See Also

GH_Component..::..GH_OutputParamManager Class
Register_PointParam Overload
Grasshopper.Kernel Namespace


Register_PointParam Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_PointParam Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new 3D point parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_PointParam(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Sub Register_PointParam ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access, you should set this field if you intend to output lists here.

See Also

GH_Component..::..GH_OutputParamManager Class
Register_PointParam Overload
Grasshopper.Kernel Namespace


Register_RectangleParam Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_RectangleParam Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Register_RectangleParam(String, String, String) | Register a new 3D rectangle parameter
Public method | Register_RectangleParam(String, String, String, GH_ParamAccess) | Register a new 3D rectangle parameter

See Also

GH_Component..::..GH_OutputParamManager Class
GH_Component..::..GH_OutputParamManager Members
Grasshopper.Kernel Namespace


Register_RectangleParam Method (String, String, String)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_RectangleParam Method (String, String, String)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new 3D rectangle parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_RectangleParam(
    string name,
    string nickname,
    string description
)
Visual Basic
Public Sub Register_RectangleParam ( _
    name As String, _
    nickname As String, _
    description As String _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.

Remarks

See Also

GH_Component..::..GH_OutputParamManager Class
Register_RectangleParam Overload
Grasshopper.Kernel Namespace


Register_RectangleParam Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_RectangleParam Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new 3D rectangle parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_RectangleParam(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Sub Register_RectangleParam ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access, you should set this field if you intend to output lists here.

See Also

GH_Component..::..GH_OutputParamManager Class
Register_RectangleParam Overload
Grasshopper.Kernel Namespace


Register_StringParam Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_StringParam Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Register_StringParam(String, String, String) | Register a new String primitive parameter
Public method | Register_StringParam(String, String, String, GH_ParamAccess) | Register a new String primitive parameter

See Also

GH_Component..::..GH_OutputParamManager Class
GH_Component..::..GH_OutputParamManager Members
Grasshopper.Kernel Namespace


Register_StringParam Method (String, String, String)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_StringParam Method (String, String, String)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new String primitive parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_StringParam(
    string name,
    string nickname,
    string description
)
Visual Basic
Public Sub Register_StringParam ( _
    name As String, _
    nickname As String, _
    description As String _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.

Remarks

See Also

GH_Component..::..GH_OutputParamManager Class
Register_StringParam Overload
Grasshopper.Kernel Namespace


Register_StringParam Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_StringParam Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new String primitive parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_StringParam(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Sub Register_StringParam ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access, you should set this field if you intend to output lists here.

See Also

GH_Component..::..GH_OutputParamManager Class
Register_StringParam Overload
Grasshopper.Kernel Namespace


Register_SurfaceParam Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_SurfaceParam Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Register_SurfaceParam(String, String, String) | Register a new 3D surface parameter
Public method | Register_SurfaceParam(String, String, String, GH_ParamAccess) | Register a new 3D surface parameter

See Also

GH_Component..::..GH_OutputParamManager Class
GH_Component..::..GH_OutputParamManager Members
Grasshopper.Kernel Namespace


Register_SurfaceParam Method (String, String, String)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_SurfaceParam Method (String, String, String)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new 3D surface parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_SurfaceParam(
    string name,
    string nickname,
    string description
)
Visual Basic
Public Sub Register_SurfaceParam ( _
    name As String, _
    nickname As String, _
    description As String _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.

Remarks

See Also

GH_Component..::..GH_OutputParamManager Class
Register_SurfaceParam Overload
Grasshopper.Kernel Namespace


Register_SurfaceParam Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_SurfaceParam Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new 3D surface parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_SurfaceParam(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Sub Register_SurfaceParam ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access, you should set this field if you intend to output lists here.

See Also

GH_Component..::..GH_OutputParamManager Class
Register_SurfaceParam Overload
Grasshopper.Kernel Namespace


Register_TransformParam Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_TransformParam Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Register_TransformParam(String, String, String) | Register a new Transform parameter
Public method | Register_TransformParam(String, String, String, GH_ParamAccess) | Register a new Transform parameter

See Also

GH_Component..::..GH_OutputParamManager Class
GH_Component..::..GH_OutputParamManager Members
Grasshopper.Kernel Namespace


Register_TransformParam Method (String, String, String)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_TransformParam Method (String, String, String)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new Transform parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_TransformParam(
    string name,
    string nickname,
    string description
)
Visual Basic
Public Sub Register_TransformParam ( _
    name As String, _
    nickname As String, _
    description As String _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.

See Also

GH_Component..::..GH_OutputParamManager Class
Register_TransformParam Overload
Grasshopper.Kernel Namespace


Register_TransformParam Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_TransformParam Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new Transform parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_TransformParam(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Sub Register_TransformParam ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access, you should set this field if you intend to output lists here.

See Also

GH_Component..::..GH_OutputParamManager Class
Register_TransformParam Overload
Grasshopper.Kernel Namespace


Register_VectorParam Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_VectorParam Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Register_VectorParam(String, String, String) | Register a new 3D vector parameter
Public method | Register_VectorParam(String, String, String, GH_ParamAccess) | Register a new 3D vector parameter

See Also

GH_Component..::..GH_OutputParamManager Class
GH_Component..::..GH_OutputParamManager Members
Grasshopper.Kernel Namespace


Register_VectorParam Method (String, String, String)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_VectorParam Method (String, String, String)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new 3D vector parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_VectorParam(
    string name,
    string nickname,
    string description
)
Visual Basic
Public Sub Register_VectorParam ( _
    name As String, _
    nickname As String, _
    description As String _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.

Remarks

See Also

GH_Component..::..GH_OutputParamManager Class
Register_VectorParam Overload
Grasshopper.Kernel Namespace


Register_VectorParam Method (String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Register_VectorParam Method (String, String, String, GH_ParamAccess)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Register a new 3D vector parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Register_VectorParam(
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Sub Register_VectorParam ( _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
)

Parameters

name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access, you should set this field if you intend to output lists here.

See Also

GH_Component..::..GH_OutputParamManager Class
Register_VectorParam Overload
Grasshopper.Kernel Namespace


RegisterParam Method

[image] [image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..RegisterParam Method
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RegisterParam(IGH_Param) | Generic parameter registration. This class provides methods to register standard parameters, but if you have a special type you're in charge of setting it all up yourself.
Public method | RegisterParam(IGH_Param, GH_ParamAccess) | Generic parameter registration. This class provides methods to register standard parameters, but if you have a special type you're in charge of setting it all up yourself.
Public method | RegisterParam(IGH_Param, String, String, String) | Generic parameter registration. This class provides methods to register standard parameters, but if you have a special type you're in charge of setting it all up yourself.
Public method | RegisterParam(IGH_Param, String, String, String, GH_ParamAccess) | Generic parameter registration. This class provides methods to register standard parameters, but if you have a special type you're in charge of setting it all up yourself.

See Also

GH_Component..::..GH_OutputParamManager Class
GH_Component..::..GH_OutputParamManager Members
Grasshopper.Kernel Namespace


RegisterParam Method (IGH_Param)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..RegisterParam Method (IGH_Param)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Generic parameter registration. This class provides methods to register standard parameters, but if you have a special type you're in charge of setting it all up yourself.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RegisterParam(
    IGH_Param param
)
Visual Basic
Public Sub RegisterParam ( _
    param As IGH_Param _
)

Parameters

param
Type: Grasshopper.Kernel..::..IGH_Param
The parameter to add

See Also

GH_Component..::..GH_OutputParamManager Class
RegisterParam Overload
Grasshopper.Kernel Namespace


RegisterParam Method (IGH_Param, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..RegisterParam Method (IGH_Param, GH_ParamAccess)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Generic parameter registration. This class provides methods to register standard parameters, but if you have a special type you're in charge of setting it all up yourself.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RegisterParam(
    IGH_Param param,
    GH_ParamAccess access
)
Visual Basic
Public Sub RegisterParam ( _
    param As IGH_Param, _
    access As GH_ParamAccess _
)

Parameters

param
Type: Grasshopper.Kernel..::..IGH_Param
The parameter to add.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access, you should set this field if you intend to output lists here.

See Also

GH_Component..::..GH_OutputParamManager Class
RegisterParam Overload
Grasshopper.Kernel Namespace


RegisterParam Method (IGH_Param, String, String, String)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..RegisterParam Method (IGH_Param, String, String, String)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Generic parameter registration. This class provides methods to register standard parameters, but if you have a special type you're in charge of setting it all up yourself.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RegisterParam(
    IGH_Param param,
    string name,
    string nickname,
    string description
)
Visual Basic
Public Sub RegisterParam ( _
    param As IGH_Param, _
    name As String, _
    nickname As String, _
    description As String _
)

Parameters

param
Type: Grasshopper.Kernel..::..IGH_Param
The parameter to add
name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.

Remarks

See Also

GH_Component..::..GH_OutputParamManager Class
RegisterParam Overload
Grasshopper.Kernel Namespace


RegisterParam Method (IGH_Param, String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..RegisterParam Method (IGH_Param, String, String, String, GH_ParamAccess)
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Generic parameter registration. This class provides methods to register standard parameters, but if you have a special type you're in charge of setting it all up yourself.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RegisterParam(
    IGH_Param param,
    string name,
    string nickname,
    string description,
    GH_ParamAccess access
)
Visual Basic
Public Sub RegisterParam ( _
    param As IGH_Param, _
    name As String, _
    nickname As String, _
    description As String, _
    access As GH_ParamAccess _
)

Parameters

param
Type: Grasshopper.Kernel..::..IGH_Param
The parameter to add
name
Type: System..::..String
The name of the parameter. Keep it short, single words are best.
nickname
Type: System..::..String
The nickname of the parameter. Keep it short, single characters are best.
description
Type: System..::..String
The description of the parameter. Be succinct but clear.
access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Parameter access, you should set this field if you intend to output lists here.

See Also

GH_Component..::..GH_OutputParamManager Class
RegisterParam Overload
Grasshopper.Kernel Namespace


GH_Component.GH_OutputParamManager Properties

[image] [image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager Properties
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback

The GH_Component..::..GH_OutputParamManager type exposes the following members.

Properties

 | Name | Description
Public property | Param | Gets the output parameter at the given index. (Overrides GH_ParamManagerParam(Int32).)
Public property | ParamCount | Returns the number of output parameters already part of this component. (Overrides GH_ParamManagerParamCount()()()().)

See Also

GH_Component..::..GH_OutputParamManager Class
Grasshopper.Kernel Namespace


Param Property

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..Param Property
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Gets the output parameter at the given index.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_Param this[
    int index
] { get; }
Visual Basic
Public Overrides ReadOnly Default Property Param ( _
    index As Integer _
) As IGH_Param
    Get

Parameters

index
Type: System..::..Int32

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Component.GH_OutputParamManager.Param(System.Int32)"]

See Also

GH_Component..::..GH_OutputParamManager Class
Grasshopper.Kernel Namespace


ParamCount Property

[image]

Grasshopper SDK
GH_Component..::..GH_OutputParamManager..::..ParamCount Property
GH_Component..::..GH_OutputParamManager Class See Also Send Feedback
Returns the number of output parameters already part of this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override int ParamCount { get; }
Visual Basic
Public Overrides ReadOnly Property ParamCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Component.GH_OutputParamManager.ParamCount"]

See Also

GH_Component..::..GH_OutputParamManager Class
Grasshopper.Kernel Namespace


GH_ComponentParamServer Class

[image]

Grasshopper SDK
GH_ComponentParamServer Class
Members See Also Send Feedback
Wraps all members and functions needed for GH_Component to manage its input and output parameters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_ComponentParamServer : GH_ISerializable,
    IEnumerable<IGH_Param>
Visual Basic
Public Class GH_ComponentParamServer _
    Implements GH_ISerializable, IEnumerable(Of IGH_Param)

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_ComponentParamServer

See Also

GH_ComponentParamServer Members
Grasshopper.Kernel Namespace


GH_ComponentParamServer Members

[image] [image]

Grasshopper SDK
GH_ComponentParamServer Members
GH_ComponentParamServer Class Methods Properties Events See Also Send Feedback

The GH_ComponentParamServer type exposes the following members.

Methods

 | Name | Description
Public method | AccessCount | Returns the total number of input parameters that match the access mask.
Public method | Clear()()()() | Removes all input and output parameters.
Public method | Clear(Boolean) | Removes all input and output parameters.
 | CreateDuplicate | Attempts to duplicate a parameter. Attributes will be ignored. Warning! The duplicate will have the same ID as the original!
Public method | EmitSyncObject | Create a synch object that stores a shallow representation of this server. Cache this object if you're planning to make sweeping changes to this param-server. Then, once you are finished call the Sync() function to perform cleanup of removed parameters. This is a utility function and you can choose to perform cleanup yourself.
Public method | Find | Find the parameter that has the given InstanceGuid.
Public method | GetEnumerator | Gets a customized enumerator which iterates over all (both input and output) parameters.
Public method | GetHashCode()()()() | (Overrides Object..::..GetHashCode()()()().)
Public method | GetHashCode(GH_ParamHashFields) | Creates a SHA1 hash from the parameter data.
Public method | IndexOfInputParam(Guid) | Finds the index of the input parameter that matches the specified search mask.
Public method | IndexOfInputParam(String) | Finds the index of the input parameter that matches the specified search mask.
Public method | IndexOfOutputParam(Guid) | Finds the index of the output parameter that matches the specified search mask.
Public method | IndexOfOutputParam(String) | Finds the index of the output parameter that matches the specified search mask.
 | InventUniqueNickname(String, IEnumerable<(Of <<'(IGH_Param>)>>)) | Create a new, unique parameter name.
 | InventUniqueNickname(String, IEnumerable<(Of <<'(String>)>>)) | Create a new, unique parameter name.
Public method | IsInputParam | Returns True if this parameter is an input child of the component
Public method | IsOutputParam | Returns True if this parameter is an output child of the component
Public method | IsParam | Returns True if this parameter is a child of the component
Public method | OnParametersChanged | Call this function when you change input/output parameter lists or types. This function will wipe all caches that are potentially invalid. PerformLayout on the component attributes will be called.
Public method | Read | Read all parameter data from an IO archive.
Public method | RegisterInputParam(IGH_Param) | Add a parameter to the end of the input list.
Public method | RegisterInputParam(IGH_Param, Int32) | Add a parameter at the specific index of the input list.
Public method | RegisterOutputParam(IGH_Param) | Add a parameter to the end of the output list.
Public method | RegisterOutputParam(IGH_Param, Int32) | Add a parameter at the specific index of the output list.
Public method | RepairParamAssociations | Makes sure all parameter attributes are a-ok. If you stick to regular functions, you shouldn't have to call this.
Public method | RepairProxyParams | Attempt to fix all proxy params. Returns false if a single one fails.
Public method | SortInput(array<Double>[]()[][]) | Sort the input parameter order based on a numeric key array.
Public method | SortInput(array<Int32>[]()[][]) | Sort the input parameter order based on a numeric key array.
Public method | SortInput(array<Single>[]()[][]) | Sort the input parameter order based on a numeric key array.
Public method | SortOutput(array<Double>[]()[][]) | Sort the input parameter order based on a numeric key array.
Public method | SortOutput(array<Int32>[]()[][]) | Sort the output parameter order based on a numeric key array.
Public method | SortOutput(array<Single>[]()[][]) | Sort the output parameter order based on a numeric key array.
Public method | Sync(Object) | Sync changes from a prerecorded state. All param references in the sync object which are no longer present in the current server will be properly deleted. The sync object will be reset in the process, so you can only call this function with a specific Sync object once.
Public method | Sync(GH_ComponentParamServer..::..IGH_SyncObject) | Sync changes from a prerecorded state. All param references in the sync object which are no longer present in the current server will be properly deleted. The sync object will be reset in the process, so you can only call this function with a specific Sync object once.
Public method | Sync(GH_ComponentParamServer..::..IGH_SyncObject, Int32%) | Sync changes from a prerecorded state. All param references in the sync object which are no longer present in the current server will be properly deleted. The sync object will be reset in the process, so you can only call this function with a specific Sync object once.
Public method | UnregisterInputParameter(IGH_Param) | Removes the specified parameter from this component.
Public method | UnregisterInputParameter(IGH_Param, Boolean) | Removes the specified parameter from this component.
Public method | UnregisterOutputParameter(IGH_Param) | Removes the specified parameter from this component.
Public method | UnregisterOutputParameter(IGH_Param, Boolean) | Removes the specified parameter from this component.
Public method | UnregisterParameter(IGH_Param) | Removes the specified parameter from this component.
Public method | UnregisterParameter(IGH_Param, Boolean) | Removes the specified parameter from this component.
Public method | Write | Write all parameter data to an IO archive.
 | WriteParamHashData | Write parameter data to a binary writer.

Properties

 | Name | Description
Public property | Input | Gets or sets the input list of parameters. Do not insert or remove parameters from this list, use the dedicated functions instead.
Public property | InputWidth | Gets the width of the largest input parameter.
Public property | OnlyTreeAndListParameters | Returns True if every input parameter is either a list or a tree parameter.
Public property | OnlyTreeParameters | Returns True if every input parameter is a tree parameter.
Public property | Output | Gets or sets the output list of parameters. Do not insert or remove parameters from this list, use the dedicated functions instead.
Public property | OutputWidth | Gets the width of the largest output parameter.
Public property | Owner | Gets the owner component of this instance

Events

 | Name | Description
Public event | ParameterChanged | Raised whenever there is a change to any parameter. If you only care about NickName or Source changes, handle the ParameterNickNameChanged or ParameterSourcesChanged events instead.
Public event | ParameterNickNameChanged | Raised whenever a parameter nickname change is accepted.
Public event | ParameterSourcesChanged | Raised whenever the source list of an input parameter is changed.

See Also

GH_ComponentParamServer Class
Grasshopper.Kernel Namespace


GH_ComponentParamServer Methods

[image] [image]

Grasshopper SDK
GH_ComponentParamServer Methods
GH_ComponentParamServer Class See Also Send Feedback

The GH_ComponentParamServer type exposes the following members.

Methods

 | Name | Description
Public method | AccessCount | Returns the total number of input parameters that match the access mask.
Public method | Clear()()()() | Removes all input and output parameters.
Public method | Clear(Boolean) | Removes all input and output parameters.
 | CreateDuplicate | Attempts to duplicate a parameter. Attributes will be ignored. Warning! The duplicate will have the same ID as the original!
Public method | EmitSyncObject | Create a synch object that stores a shallow representation of this server. Cache this object if you're planning to make sweeping changes to this param-server. Then, once you are finished call the Sync() function to perform cleanup of removed parameters. This is a utility function and you can choose to perform cleanup yourself.
Public method | Find | Find the parameter that has the given InstanceGuid.
Public method | GetEnumerator | Gets a customized enumerator which iterates over all (both input and output) parameters.
Public method | GetHashCode()()()() | (Overrides Object..::..GetHashCode()()()().)
Public method | GetHashCode(GH_ParamHashFields) | Creates a SHA1 hash from the parameter data.
Public method | IndexOfInputParam(Guid) | Finds the index of the input parameter that matches the specified search mask.
Public method | IndexOfInputParam(String) | Finds the index of the input parameter that matches the specified search mask.
Public method | IndexOfOutputParam(Guid) | Finds the index of the output parameter that matches the specified search mask.
Public method | IndexOfOutputParam(String) | Finds the index of the output parameter that matches the specified search mask.
 | InventUniqueNickname(String, IEnumerable<(Of <<'(IGH_Param>)>>)) | Create a new, unique parameter name.
 | InventUniqueNickname(String, IEnumerable<(Of <<'(String>)>>)) | Create a new, unique parameter name.
Public method | IsInputParam | Returns True if this parameter is an input child of the component
Public method | IsOutputParam | Returns True if this parameter is an output child of the component
Public method | IsParam | Returns True if this parameter is a child of the component
Public method | OnParametersChanged | Call this function when you change input/output parameter lists or types. This function will wipe all caches that are potentially invalid. PerformLayout on the component attributes will be called.
Public method | Read | Read all parameter data from an IO archive.
Public method | RegisterInputParam(IGH_Param) | Add a parameter to the end of the input list.
Public method | RegisterInputParam(IGH_Param, Int32) | Add a parameter at the specific index of the input list.
Public method | RegisterOutputParam(IGH_Param) | Add a parameter to the end of the output list.
Public method | RegisterOutputParam(IGH_Param, Int32) | Add a parameter at the specific index of the output list.
Public method | RepairParamAssociations | Makes sure all parameter attributes are a-ok. If you stick to regular functions, you shouldn't have to call this.
Public method | RepairProxyParams | Attempt to fix all proxy params. Returns false if a single one fails.
Public method | SortInput(array<Double>[]()[][]) | Sort the input parameter order based on a numeric key array.
Public method | SortInput(array<Int32>[]()[][]) | Sort the input parameter order based on a numeric key array.
Public method | SortInput(array<Single>[]()[][]) | Sort the input parameter order based on a numeric key array.
Public method | SortOutput(array<Double>[]()[][]) | Sort the input parameter order based on a numeric key array.
Public method | SortOutput(array<Int32>[]()[][]) | Sort the output parameter order based on a numeric key array.
Public method | SortOutput(array<Single>[]()[][]) | Sort the output parameter order based on a numeric key array.
Public method | Sync(Object) | Sync changes from a prerecorded state. All param references in the sync object which are no longer present in the current server will be properly deleted. The sync object will be reset in the process, so you can only call this function with a specific Sync object once.
Public method | Sync(GH_ComponentParamServer..::..IGH_SyncObject) | Sync changes from a prerecorded state. All param references in the sync object which are no longer present in the current server will be properly deleted. The sync object will be reset in the process, so you can only call this function with a specific Sync object once.
Public method | Sync(GH_ComponentParamServer..::..IGH_SyncObject, Int32%) | Sync changes from a prerecorded state. All param references in the sync object which are no longer present in the current server will be properly deleted. The sync object will be reset in the process, so you can only call this function with a specific Sync object once.
Public method | UnregisterInputParameter(IGH_Param) | Removes the specified parameter from this component.
Public method | UnregisterInputParameter(IGH_Param, Boolean) | Removes the specified parameter from this component.
Public method | UnregisterOutputParameter(IGH_Param) | Removes the specified parameter from this component.
Public method | UnregisterOutputParameter(IGH_Param, Boolean) | Removes the specified parameter from this component.
Public method | UnregisterParameter(IGH_Param) | Removes the specified parameter from this component.
Public method | UnregisterParameter(IGH_Param, Boolean) | Removes the specified parameter from this component.
Public method | Write | Write all parameter data to an IO archive.
 | WriteParamHashData | Write parameter data to a binary writer.

See Also

GH_ComponentParamServer Class
Grasshopper.Kernel Namespace


AccessCount Method

[image]

Grasshopper SDK
GH_ComponentParamServer..::..AccessCount Method
GH_ComponentParamServer Class See Also Send Feedback
Returns the total number of input parameters that match the access mask.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AccessCount(
    GH_ParamAccess access
)
Visual Basic
Public Function AccessCount ( _
    access As GH_ParamAccess _
) As Integer

Parameters

access
Type: Grasshopper.Kernel..::..GH_ParamAccess
Access flag mask.

See Also

GH_ComponentParamServer Class
Grasshopper.Kernel Namespace


Clear Method

[image] [image]

Grasshopper SDK
GH_ComponentParamServer..::..Clear Method
GH_ComponentParamServer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clear()()()() | Removes all input and output parameters.
Public method | Clear(Boolean) | Removes all input and output parameters.

See Also

GH_ComponentParamServer Class
GH_ComponentParamServer Members
Grasshopper.Kernel Namespace


Clear Method

[image]

Grasshopper SDK
GH_ComponentParamServer..::..Clear Method
GH_ComponentParamServer Class See Also Send Feedback
Removes all input and output parameters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear

See Also

GH_ComponentParamServer Class
Clear Overload
Grasshopper.Kernel Namespace


Clear Method (Boolean)

[image]

Grasshopper SDK
GH_ComponentParamServer..::..Clear Method (Boolean)
GH_ComponentParamServer Class See Also Send Feedback
Removes all input and output parameters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Clear(
    bool isolate
)
Visual Basic
Public Sub Clear ( _
    isolate As Boolean _
)

Parameters

isolate
Type: System..::..Boolean
If true, parameters that are removed will be isolated from sources and recipients.

See Also

GH_ComponentParamServer Class
Clear Overload
Grasshopper.Kernel Namespace


CreateDuplicate Method

[image]

Grasshopper SDK
GH_ComponentParamServer..::..CreateDuplicate Method
GH_ComponentParamServer Class See Also Send Feedback
Attempts to duplicate a parameter. Attributes will be ignored. Warning! The duplicate will have the same ID as the original!

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static IGH_Param CreateDuplicate(
    IGH_Param original
)
Visual Basic
Public Shared Function CreateDuplicate ( _
    original As IGH_Param _
) As IGH_Param

Parameters

original
Type: Grasshopper.Kernel..::..IGH_Param
Parameter to duplicate.

Return Value

A dupicate of the original or null on failure.

See Also

GH_ComponentParamServer Class
Grasshopper.Kernel Namespace


EmitSyncObject Method

[image]

Grasshopper SDK
GH_ComponentParamServer..::..EmitSyncObject Method
GH_ComponentParamServer Class See Also Send Feedback
Create a synch object that stores a shallow representation of this server. Cache this object if you're planning to make sweeping changes to this param-server. Then, once you are finished call the Sync() function to perform cleanup of removed parameters. This is a utility function and you can choose to perform cleanup yourself.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ComponentParamServer..::..IGH_SyncObject EmitSyncObject()
Visual Basic
Public Function EmitSyncObject As GH_ComponentParamServer..::..IGH_SyncObject

See Also

GH_ComponentParamServer Class
Grasshopper.Kernel Namespace


Find Method

[image]

Grasshopper SDK
GH_ComponentParamServer..::..Find Method
GH_ComponentParamServer Class See Also Send Feedback
Find the parameter that has the given InstanceGuid.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_Param Find(
    Guid id
)
Visual Basic
Public Function Find ( _
    id As Guid _
) As IGH_Param

Parameters

id
Type: System..::..Guid
InstanceID to search for.

Return Value

The parameter with the matching ID or null on failure.

See Also

GH_ComponentParamServer Class
Grasshopper.Kernel Namespace


GetEnumerator Method

[image]

Grasshopper SDK
GH_ComponentParamServer..::..GetEnumerator Method
GH_ComponentParamServer Class See Also Send Feedback
Gets a customized enumerator which iterates over all (both input and output) parameters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IEnumerator<IGH_Param> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of IGH_Param)

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

GH_ComponentParamServer Class
Grasshopper.Kernel Namespace


GetHashCode Method

[image] [image]

Grasshopper SDK
GH_ComponentParamServer..::..GetHashCode Method
GH_ComponentParamServer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetHashCode()()()() | (Overrides Object..::..GetHashCode()()()().)
Public method | GetHashCode(GH_ParamHashFields) | Creates a SHA1 hash from the parameter data.

See Also

GH_ComponentParamServer Class
GH_ComponentParamServer Members
Grasshopper.Kernel Namespace


GetHashCode Method

[image]

Grasshopper SDK
GH_ComponentParamServer..::..GetHashCode Method
GH_ComponentParamServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

See Also

GH_ComponentParamServer Class
GetHashCode Overload
Grasshopper.Kernel Namespace


GetHashCode Method (GH_ParamHashFields)

[image]

Grasshopper SDK
GH_ComponentParamServer..::..GetHashCode Method (GH_ParamHashFields)
GH_ComponentParamServer Class See Also Send Feedback
Creates a SHA1 hash from the parameter data.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid GetHashCode(
    GH_ParamHashFields fields
)
Visual Basic
Public Function GetHashCode ( _
    fields As GH_ParamHashFields _
) As Guid

Parameters

fields
Type: Grasshopper.Kernel..::..GH_ParamHashFields
Fields to include.

Return Value

A Guid representing a SHA hash of the parameter fields.

See Also

GH_ComponentParamServer Class
GetHashCode Overload
Grasshopper.Kernel Namespace


IndexOfInputParam Method

[image] [image]

Grasshopper SDK
GH_ComponentParamServer..::..IndexOfInputParam Method
GH_ComponentParamServer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOfInputParam(Guid) | Finds the index of the input parameter that matches the specified search mask.
Public method | IndexOfInputParam(String) | Finds the index of the input parameter that matches the specified search mask.

See Also

GH_ComponentParamServer Class
GH_ComponentParamServer Members
Grasshopper.Kernel Namespace


IndexOfInputParam Method (Guid)

[image]

Grasshopper SDK
GH_ComponentParamServer..::..IndexOfInputParam Method (Guid)
GH_ComponentParamServer Class See Also Send Feedback
Finds the index of the input parameter that matches the specified search mask.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int IndexOfInputParam(
    Guid id
)
Visual Basic
Public Function IndexOfInputParam ( _
    id As Guid _
) As Integer

Parameters

id
Type: System..::..Guid
ID to search for

Return Value

The index of the parameter, or -1 if no parameter was found to match

See Also

GH_ComponentParamServer Class
IndexOfInputParam Overload
Grasshopper.Kernel Namespace


IndexOfInputParam Method (String)

[image]

Grasshopper SDK
GH_ComponentParamServer..::..IndexOfInputParam Method (String)
GH_ComponentParamServer Class See Also Send Feedback
Finds the index of the input parameter that matches the specified search mask.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int IndexOfInputParam(
    string name
)
Visual Basic
Public Function IndexOfInputParam ( _
    name As String _
) As Integer

Parameters

name
Type: System..::..String
Name to search for.

Return Value

The index of the parameter, or -1 if no parameter was found to match

See Also

GH_ComponentParamServer Class
IndexOfInputParam Overload
Grasshopper.Kernel Namespace


IndexOfOutputParam Method

[image] [image]

Grasshopper SDK
GH_ComponentParamServer..::..IndexOfOutputParam Method
GH_ComponentParamServer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOfOutputParam(Guid) | Finds the index of the output parameter that matches the specified search mask.
Public method | IndexOfOutputParam(String) | Finds the index of the output parameter that matches the specified search mask.

See Also

GH_ComponentParamServer Class
GH_ComponentParamServer Members
Grasshopper.Kernel Namespace


IndexOfOutputParam Method (Guid)

[image]

Grasshopper SDK
GH_ComponentParamServer..::..IndexOfOutputParam Method (Guid)
GH_ComponentParamServer Class See Also Send Feedback
Finds the index of the output parameter that matches the specified search mask.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int IndexOfOutputParam(
    Guid id
)
Visual Basic
Public Function IndexOfOutputParam ( _
    id As Guid _
) As Integer

Parameters

id
Type: System..::..Guid
ID to search for.

Return Value

The index of the parameter, or -1 if no parameter was found to match

See Also

GH_ComponentParamServer Class
IndexOfOutputParam Overload
Grasshopper.Kernel Namespace


IndexOfOutputParam Method (String)

[image]

Grasshopper SDK
GH_ComponentParamServer..::..IndexOfOutputParam Method (String)
GH_ComponentParamServer Class See Also Send Feedback
Finds the index of the output parameter that matches the specified search mask.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int IndexOfOutputParam(
    string name
)
Visual Basic
Public Function IndexOfOutputParam ( _
    name As String _
) As Integer

Parameters

name
Type: System..::..String
Name to search for.

Return Value

The index of the parameter, or -1 if no parameter was found to match

See Also

GH_ComponentParamServer Class
IndexOfOutputParam Overload
Grasshopper.Kernel Namespace


InventUniqueNickname Method

[image] [image]

Grasshopper SDK
GH_ComponentParamServer..::..InventUniqueNickname Method
GH_ComponentParamServer Class See Also Send Feedback

Overload List

Name | Description
InventUniqueNickname(String, IEnumerable<(Of <<'(IGH_Param>)>>)) | Create a new, unique parameter name.
InventUniqueNickname(String, IEnumerable<(Of <<'(String>)>>)) | Create a new, unique parameter name.

See Also

GH_ComponentParamServer Class
GH_ComponentParamServer Members
Grasshopper.Kernel Namespace


InventUniqueNickname Method (String, IEnumerable(IGH_Param))

[image]

Grasshopper SDK
GH_ComponentParamServer..::..InventUniqueNickname Method (String, IEnumerable<(Of <(<'IGH_Param>)>)>)
GH_ComponentParamServer Class See Also Send Feedback
Create a new, unique parameter name.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string InventUniqueNickname(
    string allowedChars,
    IEnumerable<IGH_Param> existingNames
)
Visual Basic
Public Shared Function InventUniqueNickname ( _
    allowedChars As String, _
    existingNames As IEnumerable(Of IGH_Param) _
) As String

Parameters

allowedChars
Type: System..::..String
Allowed character set for naming logic.
existingNames
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' IGH_Param >)>)>
A collection of parameter names to avoid.

Return Value

The first name combination that doesn't occur in the existingNames collection.

See Also

GH_ComponentParamServer Class
InventUniqueNickname Overload
Grasshopper.Kernel Namespace


InventUniqueNickname Method (String, IEnumerable(String))

[image]

Grasshopper SDK
GH_ComponentParamServer..::..InventUniqueNickname Method (String, IEnumerable<(Of <(<'String>)>)>)
GH_ComponentParamServer Class See Also Send Feedback
Create a new, unique parameter name.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string InventUniqueNickname(
    string allowedChars,
    IEnumerable<string> existingNames
)
Visual Basic
Public Shared Function InventUniqueNickname ( _
    allowedChars As String, _
    existingNames As IEnumerable(Of String) _
) As String

Parameters

allowedChars
Type: System..::..String
Allowed character set for naming logic.
existingNames
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' String >)>)>
A collection of parameter names to avoid.

Return Value

The first name combination that doesn't occur in the existingNames collection.

See Also

GH_ComponentParamServer Class
InventUniqueNickname Overload
Grasshopper.Kernel Namespace


IsInputParam Method

[image]

Grasshopper SDK
GH_ComponentParamServer..::..IsInputParam Method
GH_ComponentParamServer Class See Also Send Feedback
Returns True if this parameter is an input child of the component

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsInputParam(
    IGH_Param param
)
Visual Basic
Public Function IsInputParam ( _
    param As IGH_Param _
) As Boolean

Parameters

param
Type: Grasshopper.Kernel..::..IGH_Param
Parameter to test.

See Also

GH_ComponentParamServer Class
Grasshopper.Kernel Namespace


IsOutputParam Method

[image]

Grasshopper SDK
GH_ComponentParamServer..::..IsOutputParam Method
GH_ComponentParamServer Class See Also Send Feedback
Returns True if this parameter is an output child of the component

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsOutputParam(
    IGH_Param param
)
Visual Basic
Public Function IsOutputParam ( _
    param As IGH_Param _
) As Boolean

Parameters

param
Type: Grasshopper.Kernel..::..IGH_Param
Parameter to test.

See Also

GH_ComponentParamServer Class
Grasshopper.Kernel Namespace


IsParam Method

[image]

Grasshopper SDK
GH_ComponentParamServer..::..IsParam Method
GH_ComponentParamServer Class See Also Send Feedback
Returns True if this parameter is a child of the component

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsParam(
    IGH_Param param
)
Visual Basic
Public Function IsParam ( _
    param As IGH_Param _
) As Boolean

Parameters

param
Type: Grasshopper.Kernel..::..IGH_Param
Parameter to test.

See Also

GH_ComponentParamServer Class
Grasshopper.Kernel Namespace


OnParametersChanged Method

[image]

Grasshopper SDK
GH_ComponentParamServer..::..OnParametersChanged Method
GH_ComponentParamServer Class See Also Send Feedback
Call this function when you change input/output parameter lists or types. This function will wipe all caches that are potentially invalid. PerformLayout on the component attributes will be called.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void OnParametersChanged()
Visual Basic
Public Sub OnParametersChanged

See Also

GH_ComponentParamServer Class
Grasshopper.Kernel Namespace


Read Method

[image]

Grasshopper SDK
GH_ComponentParamServer..::..Read Method
GH_ComponentParamServer Class See Also Send Feedback
Read all parameter data from an IO archive.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Read(
    GH_IReader reader
)
Visual Basic
Public Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader
Object to read with.

Return Value

True on success, false on failure.

Implements

GH_ISerializable..::..Read(GH_IReader)

See Also

GH_ComponentParamServer Class
Grasshopper.Kernel Namespace


RegisterInputParam Method

[image] [image]

Grasshopper SDK
GH_ComponentParamServer..::..RegisterInputParam Method
GH_ComponentParamServer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RegisterInputParam(IGH_Param) | Add a parameter to the end of the input list.
Public method | RegisterInputParam(IGH_Param, Int32) | Add a parameter at the specific index of the input list.

See Also

GH_ComponentParamServer Class
GH_ComponentParamServer Members
Grasshopper.Kernel Namespace


RegisterInputParam Method (IGH_Param)

[image]

Grasshopper SDK
GH_ComponentParamServer..::..RegisterInputParam Method (IGH_Param)
GH_ComponentParamServer Class See Also Send Feedback
Add a parameter to the end of the input list.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool RegisterInputParam(
    IGH_Param new_param
)
Visual Basic
Public Function RegisterInputParam ( _
    new_param As IGH_Param _
) As Boolean

Parameters

new_param
Type: Grasshopper.Kernel..::..IGH_Param

See Also

GH_ComponentParamServer Class
RegisterInputParam Overload
Grasshopper.Kernel Namespace


RegisterInputParam Method (IGH_Param, Int32)

[image]

Grasshopper SDK
GH_ComponentParamServer..::..RegisterInputParam Method (IGH_Param, Int32)
GH_ComponentParamServer Class See Also Send Feedback
Add a parameter at the specific index of the input list.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool RegisterInputParam(
    IGH_Param new_param,
    int at_index
)
Visual Basic
Public Function RegisterInputParam ( _
    new_param As IGH_Param, _
    at_index As Integer _
) As Boolean

Parameters

new_param
Type: Grasshopper.Kernel..::..IGH_Param
at_index
Type: System..::..Int32

See Also

GH_ComponentParamServer Class
RegisterInputParam Overload
Grasshopper.Kernel Namespace


RegisterOutputParam Method

[image] [image]

Grasshopper SDK
GH_ComponentParamServer..::..RegisterOutputParam Method
GH_ComponentParamServer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RegisterOutputParam(IGH_Param) | Add a parameter to the end of the output list.
Public method | RegisterOutputParam(IGH_Param, Int32) | Add a parameter at the specific index of the output list.

See Also

GH_ComponentParamServer Class
GH_ComponentParamServer Members
Grasshopper.Kernel Namespace


RegisterOutputParam Method (IGH_Param)

[image]

Grasshopper SDK
GH_ComponentParamServer..::..RegisterOutputParam Method (IGH_Param)
GH_ComponentParamServer Class See Also Send Feedback
Add a parameter to the end of the output list.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool RegisterOutputParam(
    IGH_Param new_param
)
Visual Basic
Public Function RegisterOutputParam ( _
    new_param As IGH_Param _
) As Boolean

Parameters

new_param
Type: Grasshopper.Kernel..::..IGH_Param

See Also

GH_ComponentParamServer Class
RegisterOutputParam Overload
Grasshopper.Kernel Namespace


RegisterOutputParam Method (IGH_Param, Int32)

[image]

Grasshopper SDK
GH_ComponentParamServer..::..RegisterOutputParam Method (IGH_Param, Int32)
GH_ComponentParamServer Class See Also Send Feedback
Add a parameter at the specific index of the output list.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool RegisterOutputParam(
    IGH_Param new_param,
    int at_index
)
Visual Basic
Public Function RegisterOutputParam ( _
    new_param As IGH_Param, _
    at_index As Integer _
) As Boolean

Parameters

new_param
Type: Grasshopper.Kernel..::..IGH_Param
at_index
Type: System..::..Int32

See Also

GH_ComponentParamServer Class
RegisterOutputParam Overload
Grasshopper.Kernel Namespace


RepairParamAssociations Method

[image]

Grasshopper SDK
GH_ComponentParamServer..::..RepairParamAssociations Method
GH_ComponentParamServer Class See Also Send Feedback
Makes sure all parameter attributes are a-ok. If you stick to regular functions, you shouldn't have to call this.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RepairParamAssociations()
Visual Basic
Public Sub RepairParamAssociations

See Also

GH_ComponentParamServer Class
Grasshopper.Kernel Namespace


RepairProxyParams Method

[image]

Grasshopper SDK
GH_ComponentParamServer..::..RepairProxyParams Method
GH_ComponentParamServer Class See Also Send Feedback
Attempt to fix all proxy params. Returns false if a single one fails.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool RepairProxyParams(
    GH_Document document
)
Visual Basic
Public Function RepairProxyParams ( _
    document As GH_Document _
) As Boolean

Parameters

document
Type: Grasshopper.Kernel..::..GH_Document
Document that contains potential proxy targets.

See Also

GH_ComponentParamServer Class
Grasshopper.Kernel Namespace


SortInput Method

[image] [image]

Grasshopper SDK
GH_ComponentParamServer..::..SortInput Method
GH_ComponentParamServer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SortInput(array<Double>[]()[][]) | Sort the input parameter order based on a numeric key array.
Public method | SortInput(array<Int32>[]()[][]) | Sort the input parameter order based on a numeric key array.
Public method | SortInput(array<Single>[]()[][]) | Sort the input parameter order based on a numeric key array.

See Also

GH_ComponentParamServer Class
GH_ComponentParamServer Members
Grasshopper.Kernel Namespace


SortInput Method (Double[])

[image]

Grasshopper SDK
GH_ComponentParamServer..::..SortInput Method (array<Double>[]()[][])
GH_ComponentParamServer Class See Also Send Feedback
Sort the input parameter order based on a numeric key array.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SortInput(
    double[] keys
)
Visual Basic
Public Sub SortInput ( _
    keys As Double() _
)

Parameters

keys
Type: array< System..::..Double >[]()[][]
Array of double precision numbers to function as sorting keys.

See Also

GH_ComponentParamServer Class
SortInput Overload
Grasshopper.Kernel Namespace


SortInput Method (Int32[])

[image]

Grasshopper SDK
GH_ComponentParamServer..::..SortInput Method (array<Int32>[]()[][])
GH_ComponentParamServer Class See Also Send Feedback
Sort the input parameter order based on a numeric key array.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SortInput(
    int[] keys
)
Visual Basic
Public Sub SortInput ( _
    keys As Integer() _
)

Parameters

keys
Type: array< System..::..Int32 >[]()[][]
Array of integer precision numbers to function as sorting keys.

See Also

GH_ComponentParamServer Class
SortInput Overload
Grasshopper.Kernel Namespace


SortInput Method (Single[])

[image]

Grasshopper SDK
GH_ComponentParamServer..::..SortInput Method (array<Single>[]()[][])
GH_ComponentParamServer Class See Also Send Feedback
Sort the input parameter order based on a numeric key array.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SortInput(
    float[] keys
)
Visual Basic
Public Sub SortInput ( _
    keys As Single() _
)

Parameters

keys
Type: array< System..::..Single >[]()[][]
Array of single precision numbers to function as sorting keys.

See Also

GH_ComponentParamServer Class
SortInput Overload
Grasshopper.Kernel Namespace


SortOutput Method

[image] [image]

Grasshopper SDK
GH_ComponentParamServer..::..SortOutput Method
GH_ComponentParamServer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SortOutput(array<Double>[]()[][]) | Sort the input parameter order based on a numeric key array.
Public method | SortOutput(array<Int32>[]()[][]) | Sort the output parameter order based on a numeric key array.
Public method | SortOutput(array<Single>[]()[][]) | Sort the output parameter order based on a numeric key array.

See Also

GH_ComponentParamServer Class
GH_ComponentParamServer Members
Grasshopper.Kernel Namespace


SortOutput Method (Double[])

[image]

Grasshopper SDK
GH_ComponentParamServer..::..SortOutput Method (array<Double>[]()[][])
GH_ComponentParamServer Class See Also Send Feedback
Sort the input parameter order based on a numeric key array.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SortOutput(
    double[] keys
)
Visual Basic
Public Sub SortOutput ( _
    keys As Double() _
)

Parameters

keys
Type: array< System..::..Double >[]()[][]
Array of double precision numbers to function as sorting keys.

See Also

GH_ComponentParamServer Class
SortOutput Overload
Grasshopper.Kernel Namespace


SortOutput Method (Int32[])

[image]

Grasshopper SDK
GH_ComponentParamServer..::..SortOutput Method (array<Int32>[]()[][])
GH_ComponentParamServer Class See Also Send Feedback
Sort the output parameter order based on a numeric key array.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SortOutput(
    int[] keys
)
Visual Basic
Public Sub SortOutput ( _
    keys As Integer() _
)

Parameters

keys
Type: array< System..::..Int32 >[]()[][]
Array of integer precision numbers to function as sorting keys.

See Also

GH_ComponentParamServer Class
SortOutput Overload
Grasshopper.Kernel Namespace


SortOutput Method (Single[])

[image]

Grasshopper SDK
GH_ComponentParamServer..::..SortOutput Method (array<Single>[]()[][])
GH_ComponentParamServer Class See Also Send Feedback
Sort the output parameter order based on a numeric key array.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SortOutput(
    float[] keys
)
Visual Basic
Public Sub SortOutput ( _
    keys As Single() _
)

Parameters

keys
Type: array< System..::..Single >[]()[][]
Array of single precision numbers to function as sorting keys.

See Also

GH_ComponentParamServer Class
SortOutput Overload
Grasshopper.Kernel Namespace


Sync Method

[image] [image]

Grasshopper SDK
GH_ComponentParamServer..::..Sync Method
GH_ComponentParamServer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sync(Object) | Sync changes from a prerecorded state. All param references in the sync object which are no longer present in the current server will be properly deleted. The sync object will be reset in the process, so you can only call this function with a specific Sync object once.
Public method | Sync(GH_ComponentParamServer..::..IGH_SyncObject) | Sync changes from a prerecorded state. All param references in the sync object which are no longer present in the current server will be properly deleted. The sync object will be reset in the process, so you can only call this function with a specific Sync object once.
Public method | Sync(GH_ComponentParamServer..::..IGH_SyncObject, Int32%) | Sync changes from a prerecorded state. All param references in the sync object which are no longer present in the current server will be properly deleted. The sync object will be reset in the process, so you can only call this function with a specific Sync object once.

See Also

GH_ComponentParamServer Class
GH_ComponentParamServer Members
Grasshopper.Kernel Namespace


Sync Method (Object)

[image]

Grasshopper SDK
GH_ComponentParamServer..::..Sync Method (Object)
GH_ComponentParamServer Class See Also Send Feedback
Sync changes from a prerecorded state. All param references in the sync object which are no longer present in the current server will be properly deleted. The sync object will be reset in the process, so you can only call this function with a specific Sync object once.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Sync(
    Object sync_data
)
Visual Basic
Public Sub Sync ( _
    sync_data As Object _
)

Parameters

sync_data
Type: System..::..Object
Sync object. Should be obtained by calling EmitSyncObject()

See Also

GH_ComponentParamServer Class
Sync Overload
Grasshopper.Kernel Namespace


Sync Method (GH_ComponentParamServer.IGH_SyncObject)

[image]

Grasshopper SDK
GH_ComponentParamServer..::..Sync Method (GH_ComponentParamServer..::..IGH_SyncObject)
GH_ComponentParamServer Class See Also Send Feedback
Sync changes from a prerecorded state. All param references in the sync object which are no longer present in the current server will be properly deleted. The sync object will be reset in the process, so you can only call this function with a specific Sync object once.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Sync(
    GH_ComponentParamServer..::..IGH_SyncObject sync_data
)
Visual Basic
Public Sub Sync ( _
    sync_data As GH_ComponentParamServer..::..IGH_SyncObject _
)

Parameters

sync_data
Type: Grasshopper.Kernel..::..GH_ComponentParamServer..::..IGH_SyncObject
Sync object. Should be obtained by calling EmitSyncObject()

See Also

GH_ComponentParamServer Class
Sync Overload
Grasshopper.Kernel Namespace


Sync Method (GH_ComponentParamServer.IGH_SyncObject, Int32)

[image]

Grasshopper SDK
GH_ComponentParamServer..::..Sync Method (GH_ComponentParamServer..::..IGH_SyncObject, Int32%)
GH_ComponentParamServer Class See Also Send Feedback
Sync changes from a prerecorded state. All param references in the sync object which are no longer present in the current server will be properly deleted. The sync object will be reset in the process, so you can only call this function with a specific Sync object once.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Sync(
    GH_ComponentParamServer..::..IGH_SyncObject sync_data,
    out int cleanup_count
)
Visual Basic
Public Sub Sync ( _
    sync_data As GH_ComponentParamServer..::..IGH_SyncObject, _
    <OutAttribute> ByRef cleanup_count As Integer _
)

Parameters

sync_data
Type: Grasshopper.Kernel..::..GH_ComponentParamServer..::..IGH_SyncObject
Sync object. Should be obtained by calling EmitSyncObject()
cleanup_count
Type: System..::..Int32 %
Number of parameters that were cleaned up.

See Also

GH_ComponentParamServer Class
Sync Overload
Grasshopper.Kernel Namespace


UnregisterInputParameter Method

[image] [image]

Grasshopper SDK
GH_ComponentParamServer..::..UnregisterInputParameter Method
GH_ComponentParamServer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UnregisterInputParameter(IGH_Param) | Removes the specified parameter from this component.
Public method | UnregisterInputParameter(IGH_Param, Boolean) | Removes the specified parameter from this component.

See Also

GH_ComponentParamServer Class
GH_ComponentParamServer Members
Grasshopper.Kernel Namespace


UnregisterInputParameter Method (IGH_Param)

[image]

Grasshopper SDK
GH_ComponentParamServer..::..UnregisterInputParameter Method (IGH_Param)
GH_ComponentParamServer Class See Also Send Feedback
Removes the specified parameter from this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool UnregisterInputParameter(
    IGH_Param param
)
Visual Basic
Public Function UnregisterInputParameter ( _
    param As IGH_Param _
) As Boolean

Parameters

param
Type: Grasshopper.Kernel..::..IGH_Param
Parameter to remove

See Also

GH_ComponentParamServer Class
UnregisterInputParameter Overload
Grasshopper.Kernel Namespace


UnregisterInputParameter Method (IGH_Param, Boolean)

[image]

Grasshopper SDK
GH_ComponentParamServer..::..UnregisterInputParameter Method (IGH_Param, Boolean)
GH_ComponentParamServer Class See Also Send Feedback
Removes the specified parameter from this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool UnregisterInputParameter(
    IGH_Param param,
    bool isolate
)
Visual Basic
Public Function UnregisterInputParameter ( _
    param As IGH_Param, _
    isolate As Boolean _
) As Boolean

Parameters

param
Type: Grasshopper.Kernel..::..IGH_Param
Parameter to remove
isolate
Type: System..::..Boolean
If true, parameters that are removed will be isolated from sources and recipients.

See Also

GH_ComponentParamServer Class
UnregisterInputParameter Overload
Grasshopper.Kernel Namespace


UnregisterOutputParameter Method

[image] [image]

Grasshopper SDK
GH_ComponentParamServer..::..UnregisterOutputParameter Method
GH_ComponentParamServer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UnregisterOutputParameter(IGH_Param) | Removes the specified parameter from this component.
Public method | UnregisterOutputParameter(IGH_Param, Boolean) | Removes the specified parameter from this component.

See Also

GH_ComponentParamServer Class
GH_ComponentParamServer Members
Grasshopper.Kernel Namespace


UnregisterOutputParameter Method (IGH_Param)

[image]

Grasshopper SDK
GH_ComponentParamServer..::..UnregisterOutputParameter Method (IGH_Param)
GH_ComponentParamServer Class See Also Send Feedback
Removes the specified parameter from this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool UnregisterOutputParameter(
    IGH_Param param
)
Visual Basic
Public Function UnregisterOutputParameter ( _
    param As IGH_Param _
) As Boolean

Parameters

param
Type: Grasshopper.Kernel..::..IGH_Param
Parameter to remove

See Also

GH_ComponentParamServer Class
UnregisterOutputParameter Overload
Grasshopper.Kernel Namespace


UnregisterOutputParameter Method (IGH_Param, Boolean)

[image]

Grasshopper SDK
GH_ComponentParamServer..::..UnregisterOutputParameter Method (IGH_Param, Boolean)
GH_ComponentParamServer Class See Also Send Feedback
Removes the specified parameter from this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool UnregisterOutputParameter(
    IGH_Param param,
    bool isolate
)
Visual Basic
Public Function UnregisterOutputParameter ( _
    param As IGH_Param, _
    isolate As Boolean _
) As Boolean

Parameters

param
Type: Grasshopper.Kernel..::..IGH_Param
Parameter to remove
isolate
Type: System..::..Boolean
If true, parameters that are removed will be isolated from sources and recipients.

See Also

GH_ComponentParamServer Class
UnregisterOutputParameter Overload
Grasshopper.Kernel Namespace


UnregisterParameter Method

[image] [image]

Grasshopper SDK
GH_ComponentParamServer..::..UnregisterParameter Method
GH_ComponentParamServer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UnregisterParameter(IGH_Param) | Removes the specified parameter from this component.
Public method | UnregisterParameter(IGH_Param, Boolean) | Removes the specified parameter from this component.

See Also

GH_ComponentParamServer Class
GH_ComponentParamServer Members
Grasshopper.Kernel Namespace


UnregisterParameter Method (IGH_Param)

[image]

Grasshopper SDK
GH_ComponentParamServer..::..UnregisterParameter Method (IGH_Param)
GH_ComponentParamServer Class See Also Send Feedback
Removes the specified parameter from this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool UnregisterParameter(
    IGH_Param param
)
Visual Basic
Public Function UnregisterParameter ( _
    param As IGH_Param _
) As Boolean

Parameters

param
Type: Grasshopper.Kernel..::..IGH_Param
Parameter to remove

See Also

GH_ComponentParamServer Class
UnregisterParameter Overload
Grasshopper.Kernel Namespace


UnregisterParameter Method (IGH_Param, Boolean)

[image]

Grasshopper SDK
GH_ComponentParamServer..::..UnregisterParameter Method (IGH_Param, Boolean)
GH_ComponentParamServer Class See Also Send Feedback
Removes the specified parameter from this component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool UnregisterParameter(
    IGH_Param param,
    bool isolate
)
Visual Basic
Public Function UnregisterParameter ( _
    param As IGH_Param, _
    isolate As Boolean _
) As Boolean

Parameters

param
Type: Grasshopper.Kernel..::..IGH_Param
Parameter to remove
isolate
Type: System..::..Boolean
If true, parameters that are removed will be isolated from sources and recipients.

See Also

GH_ComponentParamServer Class
UnregisterParameter Overload
Grasshopper.Kernel Namespace


Write Method

[image]

Grasshopper SDK
GH_ComponentParamServer..::..Write Method
GH_ComponentParamServer Class See Also Send Feedback
Write all parameter data to an IO archive.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Write(
    GH_IWriter writer
)
Visual Basic
Public Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter
Object to write with.

Return Value

True on success, false on failure.

Implements

GH_ISerializable..::..Write(GH_IWriter)

See Also

GH_ComponentParamServer Class
Grasshopper.Kernel Namespace


WriteParamHashData Method

[image]

Grasshopper SDK
GH_ComponentParamServer..::..WriteParamHashData Method
GH_ComponentParamServer Class See Also Send Feedback
Write parameter data to a binary writer.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void WriteParamHashData(
    BinaryWriter writer,
    IGH_Param param,
    GH_ParamHashFields fields
)
Visual Basic
Public Shared Sub WriteParamHashData ( _
    writer As BinaryWriter, _
    param As IGH_Param, _
    fields As GH_ParamHashFields _
)

Parameters

writer
Type: System.IO..::..BinaryWriter
Writer to write with.
param
Type: Grasshopper.Kernel..::..IGH_Param
Parameter to serialize.
fields
Type: Grasshopper.Kernel..::..GH_ParamHashFields
Fields of parameter to serialize.

Remarks

This is useful for hashing purposes, there is no way to deserialize data written with this method.

See Also

GH_ComponentParamServer Class
Grasshopper.Kernel Namespace


GH_ComponentParamServer Properties

[image] [image]

Grasshopper SDK
GH_ComponentParamServer Properties
GH_ComponentParamServer Class See Also Send Feedback

The GH_ComponentParamServer type exposes the following members.

Properties

 | Name | Description
Public property | Input | Gets or sets the input list of parameters. Do not insert or remove parameters from this list, use the dedicated functions instead.
Public property | InputWidth | Gets the width of the largest input parameter.
Public property | OnlyTreeAndListParameters | Returns True if every input parameter is either a list or a tree parameter.
Public property | OnlyTreeParameters | Returns True if every input parameter is a tree parameter.
Public property | Output | Gets or sets the output list of parameters. Do not insert or remove parameters from this list, use the dedicated functions instead.
Public property | OutputWidth | Gets the width of the largest output parameter.
Public property | Owner | Gets the owner component of this instance

See Also

GH_ComponentParamServer Class
Grasshopper.Kernel Namespace


Input Property

[image]

Grasshopper SDK
GH_ComponentParamServer..::..Input Property
GH_ComponentParamServer Class See Also Send Feedback
Gets or sets the input list of parameters. Do not insert or remove parameters from this list, use the dedicated functions instead.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<IGH_Param> Input { get; }
Visual Basic
Public ReadOnly Property Input As List(Of IGH_Param)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ComponentParamServer.Input"]

See Also

GH_ComponentParamServer Class
Grasshopper.Kernel Namespace


InputWidth Property

[image]

Grasshopper SDK
GH_ComponentParamServer..::..InputWidth Property
GH_ComponentParamServer Class See Also Send Feedback
Gets the width of the largest input parameter.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public float InputWidth { get; }
Visual Basic
Public ReadOnly Property InputWidth As Single
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ComponentParamServer.InputWidth"]

See Also

GH_ComponentParamServer Class
Grasshopper.Kernel Namespace


OnlyTreeAndListParameters Property

[image]

Grasshopper SDK
GH_ComponentParamServer..::..OnlyTreeAndListParameters Property
GH_ComponentParamServer Class See Also Send Feedback
Returns True if every input parameter is either a list or a tree parameter.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool OnlyTreeAndListParameters { get; }
Visual Basic
Public ReadOnly Property OnlyTreeAndListParameters As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ComponentParamServer.OnlyTreeAndListParameters"]

See Also

GH_ComponentParamServer Class
Grasshopper.Kernel Namespace


OnlyTreeParameters Property

[image]

Grasshopper SDK
GH_ComponentParamServer..::..OnlyTreeParameters Property
GH_ComponentParamServer Class See Also Send Feedback
Returns True if every input parameter is a tree parameter.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool OnlyTreeParameters { get; }
Visual Basic
Public ReadOnly Property OnlyTreeParameters As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ComponentParamServer.OnlyTreeParameters"]

See Also

GH_ComponentParamServer Class
Grasshopper.Kernel Namespace


Output Property

[image]

Grasshopper SDK
GH_ComponentParamServer..::..Output Property
GH_ComponentParamServer Class See Also Send Feedback
Gets or sets the output list of parameters. Do not insert or remove parameters from this list, use the dedicated functions instead.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<IGH_Param> Output { get; }
Visual Basic
Public ReadOnly Property Output As List(Of IGH_Param)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ComponentParamServer.Output"]

See Also

GH_ComponentParamServer Class
Grasshopper.Kernel Namespace


OutputWidth Property

[image]

Grasshopper SDK
GH_ComponentParamServer..::..OutputWidth Property
GH_ComponentParamServer Class See Also Send Feedback
Gets the width of the largest output parameter.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public float OutputWidth { get; }
Visual Basic
Public ReadOnly Property OutputWidth As Single
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ComponentParamServer.OutputWidth"]

See Also

GH_ComponentParamServer Class
Grasshopper.Kernel Namespace


Owner Property

[image]

Grasshopper SDK
GH_ComponentParamServer..::..Owner Property
GH_ComponentParamServer Class See Also Send Feedback
Gets the owner component of this instance

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_Component Owner { get; }
Visual Basic
Public ReadOnly Property Owner As IGH_Component
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ComponentParamServer.Owner"]

See Also

GH_ComponentParamServer Class
Grasshopper.Kernel Namespace


GH_ComponentParamServer Events

[image] [image]

Grasshopper SDK
GH_ComponentParamServer Events
GH_ComponentParamServer Class See Also Send Feedback

The GH_ComponentParamServer type exposes the following members.

Events

 | Name | Description
Public event | ParameterChanged | Raised whenever there is a change to any parameter. If you only care about NickName or Source changes, handle the ParameterNickNameChanged or ParameterSourcesChanged events instead.
Public event | ParameterNickNameChanged | Raised whenever a parameter nickname change is accepted.
Public event | ParameterSourcesChanged | Raised whenever the source list of an input parameter is changed.

See Also

GH_ComponentParamServer Class
Grasshopper.Kernel Namespace


ParameterChanged Event

[image]

Grasshopper SDK
GH_ComponentParamServer..::..ParameterChanged Event
GH_ComponentParamServer Class See Also Send Feedback
Raised whenever there is a change to any parameter. If you only care about NickName or Source changes, handle the ParameterNickNameChanged or ParameterSourcesChanged events instead.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_ComponentParamServer..::..ParameterChangedEventHandler ParameterChanged
Visual Basic
Public Event ParameterChanged As GH_ComponentParamServer..::..ParameterChangedEventHandler

See Also

GH_ComponentParamServer Class
Grasshopper.Kernel Namespace


ParameterNickNameChanged Event

[image]

Grasshopper SDK
GH_ComponentParamServer..::..ParameterNickNameChanged Event
GH_ComponentParamServer Class See Also Send Feedback
Raised whenever a parameter nickname change is accepted.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_ComponentParamServer..::..ParameterNickNameChangedEventHandler ParameterNickNameChanged
Visual Basic
Public Event ParameterNickNameChanged As GH_ComponentParamServer..::..ParameterNickNameChangedEventHandler

See Also

GH_ComponentParamServer Class
Grasshopper.Kernel Namespace


ParameterSourcesChanged Event

[image]

Grasshopper SDK
GH_ComponentParamServer..::..ParameterSourcesChanged Event
GH_ComponentParamServer Class See Also Send Feedback
Raised whenever the source list of an input parameter is changed.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_ComponentParamServer..::..ParameterSourcesChangedEventHandler ParameterSourcesChanged
Visual Basic
Public Event ParameterSourcesChanged As GH_ComponentParamServer..::..ParameterSourcesChangedEventHandler

See Also

GH_ComponentParamServer Class
Grasshopper.Kernel Namespace


GH_ComponentParamServer.IGH_SyncObject Interface

[image]

Grasshopper SDK
GH_ComponentParamServer..::..IGH_SyncObject Interface
GH_ComponentParamServer Class See Also Send Feedback
Synch object for tracking long term changes to the parameter server.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_SyncObject
Visual Basic
Public Interface IGH_SyncObject

See Also

Grasshopper.Kernel Namespace


GH_ComponentParamServer.ParameterChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_ComponentParamServer..::..ParameterChangedEventHandler Delegate
GH_ComponentParamServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void ParameterChangedEventHandler(
    Object sender,
    GH_ParamServerEventArgs e
)
Visual Basic
Public Delegate Sub ParameterChangedEventHandler ( _
    sender As Object, _
    e As GH_ParamServerEventArgs _
)

Parameters

sender
Type: System..::..Object
e
Type: Grasshopper.Kernel..::..GH_ParamServerEventArgs

See Also

Grasshopper.Kernel Namespace


GH_ComponentParamServer.ParameterNickNameChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_ComponentParamServer..::..ParameterNickNameChangedEventHandler Delegate
GH_ComponentParamServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void ParameterNickNameChangedEventHandler(
    Object sender,
    GH_ParamServerEventArgs e
)
Visual Basic
Public Delegate Sub ParameterNickNameChangedEventHandler ( _
    sender As Object, _
    e As GH_ParamServerEventArgs _
)

Parameters

sender
Type: System..::..Object
e
Type: Grasshopper.Kernel..::..GH_ParamServerEventArgs

See Also

Grasshopper.Kernel Namespace


GH_ComponentParamServer.ParameterSourcesChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_ComponentParamServer..::..ParameterSourcesChangedEventHandler Delegate
GH_ComponentParamServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void ParameterSourcesChangedEventHandler(
    Object sender,
    GH_ParamServerEventArgs e
)
Visual Basic
Public Delegate Sub ParameterSourcesChangedEventHandler ( _
    sender As Object, _
    e As GH_ParamServerEventArgs _
)

Parameters

sender
Type: System..::..Object
e
Type: Grasshopper.Kernel..::..GH_ParamServerEventArgs

See Also

Grasshopper.Kernel Namespace


GH_ComponentServer Class

[image]

Grasshopper SDK
GH_ComponentServer Class
Members See Also Send Feedback
Maintains proxies for all components, parameters and other object types as defined in all grasshopper assemblies.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class GH_ComponentServer
Visual Basic
Public NotInheritable Class GH_ComponentServer

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_ComponentServer

See Also

GH_ComponentServer Members
Grasshopper.Kernel Namespace


GH_ComponentServer Members

[image] [image]

Grasshopper SDK
GH_ComponentServer Members
GH_ComponentServer Class Constructors Methods Properties Events See Also Send Feedback

The GH_ComponentServer type exposes the following members.

Constructors

 | Name | Description
Public method | GH_ComponentServer | Initializes a new instance of the GH_ComponentServer class

Methods

 | Name | Description
Public method | AddAlias | Add an alias to a target.
Public method | AddCategoryIcon | Add an icon for a tab category. 16x16 images are required.
Public method | AddCategoryShortName | Add an abbreviation for a tab category. 2~4 letter abbreviations are best.
Public method | AddCategorySymbolName | Add a single char category description.
Public method | AliasTargets | Get all the target Component IDs for a given alias.
Public method | Clear | Clear all caches.
Public method | ClearStaleUserObjects | Remove all user objects that no longer point to existing files.
 | CompareProxies | Compare two object proxies. Names and exposures are taken into account.
 | CopyFileToRoamingFolder | Copy a GHA or GHUSER file into the appropriate Roaming Application Data folder. Of the file is already in the top-level roaming folder it will not be copied.
Public method | DestroyLoadingUI | Destroy the loading UI (the banner and the progress bar).
Public method | EmitGraph | Create a new instance of the IGH_Graph that matches the id. If no proxy can be matched to the id, a null reference will be returned.
Public method | EmitObject | Create a new instance of the IGH_DocumentObject that matches the id. If no proxy can be matched to the id, a null reference will be returned.
Public method | EmitObjectIcon | Get the icon that is associated with the given Object ID.
Public method | EmitObjectProxy | Get the proxy that is associated with the given Object ID.
 | ExternalFiles | Get lists of all the external files (GHA, GHUSER and GHCLUSTER) that will be loaded by Grasshopper. Note: this does not equal the files that may already have been loaded, just the files that we'll attempt to load if we were asked to load all plugins now. The list contains no duplicate file paths, but it may contain identical files which won't be filtered until actual loading.
Public method | FindAssembly | Gets the assembly that corresponds to the given library ID.
Public method | FindAssemblyByObject(Guid) | Gets the assembly that corresponds to the given library ID.
Public method | FindAssemblyByObject(IGH_DocumentObject) | Gets the assembly that corresponds to the given library ID.
Public method | FindObjects(Guid) | Find all the objects that are part of a certain library.
Public method | FindObjects(array<String>[]()[][], Int32) | Searches the list of cached object proxies for objects that might be implied by a search term.
Public method | FindUpgrader | Find the upgrader that can convert from the given target.
Public method | GetAlias | Gets the alias display string for a given object.
Public method | GetCategoryIcon | Get the icon for a specific category. If the icon hasn't been defined, this method will return the default icon.
Public method | GetCategoryShortName | Get the abbreviation (short name) for a specific category. If the short name hasn't been defined, this method will return the full name instead.
Public method | GetCategorySymbolName | Get the single char representation for a specific category. If the char hasn't been defined, this method will return the first char of the full name instead.
Public method | IsGraphCached | Tests the graph cache for an existing graph type ID.
Public method | IsObjectCached | Tests the caches for an existing object type ID.
Public method | IsUpgrader | Checks to see if at least one upgrader is defined for a collection of objects.
Public method | LoadAliases | Load the Alias table from the settings directory. Only use this function if you suspect the alias table settings file has changed due to some external process.
Public method | LoadExternalFiles | Attempt to parse all external files. This includes GHA libraries, GHUSER objects and GHCLUSTER files.
 | NewUserObject | Create a new UserObject and write it to the Grasshopper User Object folder.
Public method | RemoveCachedGraph | Remove a cache entry from the graph cache. This cannot be undone.
Public method | RemoveCachedObject(Guid) | Remove a cache entry from the object cache. This cannot be undone.
Public method | RemoveCachedObject(String) | Remove the user object (if any) that loads itself from a specified *.ghuser file.
Public method | SaveAliases | Save the alias table to the settings directory. Use this function if you change the alias table while ignoring usual channels.
Public method | SetAlias | Sets the aliases for a given target.
 | UpdateRibbonUI | Forces an update of the Ribbon control on the Grasshopper main form.

Properties

 | Name | Description
Public property | Aliases | Gets a list of all the defined aliases.
 | AllAddOns | Obsolete. Gets a list of all the gha and ghuser files that will be loaded as Grasshopper add-ons.
Public property | CompleteRibbonLayout | Gets the default component layout featuring all non-hidden components and parameters.
Public property | DiscardedProxies | Returns the total number of IGH_DocumentObjects that were discarded during assembly parsing. This includes both skipped and replaced proxies.
Public property | GraphProxies | Returns a list of all cached GH_GraphProxy instances.
Public property | Libraries | Returns a list of Assembly Info objects describing all loaded assemblies.
Public property | LoadingExceptions | Gets a list of all the exceptions that were recorded during the most recent loading sequence.
Public property | ObjectProxies | Returns a list of all cached GH_ObjectProxy instances.
Public property | ObjectProxyNames | Returns a specialized string collection of all component names.
Public property | TypeHints | Gets a list of all IGH_TypeHint types in all loaded assemblies.
Public property | Upgraders | Gets a list of all the upgraders that have been cached.

Events

 | Name | Description
Public event | GHAFileLoaded | Raised whenever a GHA file has been successfully loaded.

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


GH_ComponentServer Constructor

[image]

Grasshopper SDK
GH_ComponentServer Constructor
GH_ComponentServer Class See Also Send Feedback
Initializes a new instance of the GH_ComponentServer class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ComponentServer()
Visual Basic
Public Sub New

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


GH_ComponentServer Methods

[image] [image]

Grasshopper SDK
GH_ComponentServer Methods
GH_ComponentServer Class See Also Send Feedback

The GH_ComponentServer type exposes the following members.

Methods

 | Name | Description
Public method | AddAlias | Add an alias to a target.
Public method | AddCategoryIcon | Add an icon for a tab category. 16x16 images are required.
Public method | AddCategoryShortName | Add an abbreviation for a tab category. 2~4 letter abbreviations are best.
Public method | AddCategorySymbolName | Add a single char category description.
Public method | AliasTargets | Get all the target Component IDs for a given alias.
Public method | Clear | Clear all caches.
Public method | ClearStaleUserObjects | Remove all user objects that no longer point to existing files.
 | CompareProxies | Compare two object proxies. Names and exposures are taken into account.
 | CopyFileToRoamingFolder | Copy a GHA or GHUSER file into the appropriate Roaming Application Data folder. Of the file is already in the top-level roaming folder it will not be copied.
Public method | DestroyLoadingUI | Destroy the loading UI (the banner and the progress bar).
Public method | EmitGraph | Create a new instance of the IGH_Graph that matches the id. If no proxy can be matched to the id, a null reference will be returned.
Public method | EmitObject | Create a new instance of the IGH_DocumentObject that matches the id. If no proxy can be matched to the id, a null reference will be returned.
Public method | EmitObjectIcon | Get the icon that is associated with the given Object ID.
Public method | EmitObjectProxy | Get the proxy that is associated with the given Object ID.
 | ExternalFiles | Get lists of all the external files (GHA, GHUSER and GHCLUSTER) that will be loaded by Grasshopper. Note: this does not equal the files that may already have been loaded, just the files that we'll attempt to load if we were asked to load all plugins now. The list contains no duplicate file paths, but it may contain identical files which won't be filtered until actual loading.
Public method | FindAssembly | Gets the assembly that corresponds to the given library ID.
Public method | FindAssemblyByObject(Guid) | Gets the assembly that corresponds to the given library ID.
Public method | FindAssemblyByObject(IGH_DocumentObject) | Gets the assembly that corresponds to the given library ID.
Public method | FindObjects(Guid) | Find all the objects that are part of a certain library.
Public method | FindObjects(array<String>[]()[][], Int32) | Searches the list of cached object proxies for objects that might be implied by a search term.
Public method | FindUpgrader | Find the upgrader that can convert from the given target.
Public method | GetAlias | Gets the alias display string for a given object.
Public method | GetCategoryIcon | Get the icon for a specific category. If the icon hasn't been defined, this method will return the default icon.
Public method | GetCategoryShortName | Get the abbreviation (short name) for a specific category. If the short name hasn't been defined, this method will return the full name instead.
Public method | GetCategorySymbolName | Get the single char representation for a specific category. If the char hasn't been defined, this method will return the first char of the full name instead.
Public method | IsGraphCached | Tests the graph cache for an existing graph type ID.
Public method | IsObjectCached | Tests the caches for an existing object type ID.
Public method | IsUpgrader | Checks to see if at least one upgrader is defined for a collection of objects.
Public method | LoadAliases | Load the Alias table from the settings directory. Only use this function if you suspect the alias table settings file has changed due to some external process.
Public method | LoadExternalFiles | Attempt to parse all external files. This includes GHA libraries, GHUSER objects and GHCLUSTER files.
 | NewUserObject | Create a new UserObject and write it to the Grasshopper User Object folder.
Public method | RemoveCachedGraph | Remove a cache entry from the graph cache. This cannot be undone.
Public method | RemoveCachedObject(Guid) | Remove a cache entry from the object cache. This cannot be undone.
Public method | RemoveCachedObject(String) | Remove the user object (if any) that loads itself from a specified *.ghuser file.
Public method | SaveAliases | Save the alias table to the settings directory. Use this function if you change the alias table while ignoring usual channels.
Public method | SetAlias | Sets the aliases for a given target.
 | UpdateRibbonUI | Forces an update of the Ribbon control on the Grasshopper main form.

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


AddAlias Method

[image]

Grasshopper SDK
GH_ComponentServer..::..AddAlias Method
GH_ComponentServer Class See Also Send Feedback
Add an alias to a target.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddAlias(
    string alias,
    Guid target
)
Visual Basic
Public Sub AddAlias ( _
    alias As String, _
    target As Guid _
)

Parameters

alias
Type: System..::..String
Alias to add. If the alias string contains spaces or commas, those will be used to harvest partial aliases.
target
Type: System..::..Guid
Component ID of object that is targeted by the alias.

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


AddCategoryIcon Method

[image]

Grasshopper SDK
GH_ComponentServer..::..AddCategoryIcon Method
GH_ComponentServer Class See Also Send Feedback
Add an icon for a tab category. 16x16 images are required.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddCategoryIcon(
    string fullCategoryName,
    Bitmap icon
)
Visual Basic
Public Sub AddCategoryIcon ( _
    fullCategoryName As String, _
    icon As Bitmap _
)

Parameters

fullCategoryName
Type: System..::..String
The full name of the category.
icon
Type: System.Drawing..::..Bitmap
the icon to display on the tab (has to be a 16x16 image).

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


AddCategoryShortName Method

[image]

Grasshopper SDK
GH_ComponentServer..::..AddCategoryShortName Method
GH_ComponentServer Class See Also Send Feedback
Add an abbreviation for a tab category. 2~4 letter abbreviations are best.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddCategoryShortName(
    string fullCategoryName,
    string categoryAbbreviation
)
Visual Basic
Public Sub AddCategoryShortName ( _
    fullCategoryName As String, _
    categoryAbbreviation As String _
)

Parameters

fullCategoryName
Type: System..::..String
The full name of the category.
categoryAbbreviation
Type: System..::..String
The abbreviation to display on the tab.

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


AddCategorySymbolName Method

[image]

Grasshopper SDK
GH_ComponentServer..::..AddCategorySymbolName Method
GH_ComponentServer Class See Also Send Feedback
Add a single char category description.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddCategorySymbolName(
    string fullCategoryName,
    char symbol
)
Visual Basic
Public Sub AddCategorySymbolName ( _
    fullCategoryName As String, _
    symbol As Char _
)

Parameters

fullCategoryName
Type: System..::..String
The full name of the category.
symbol
Type: System..::..Char
The single char representing the category.

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


AliasTargets Method

[image]

Grasshopper SDK
GH_ComponentServer..::..AliasTargets Method
GH_ComponentServer Class See Also Send Feedback
Get all the target Component IDs for a given alias.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<Guid> AliasTargets(
    string alias
)
Visual Basic
Public Function AliasTargets ( _
    alias As String _
) As List(Of Guid)

Parameters

alias
Type: System..::..String
Alias to search for.

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


Clear Method

[image]

Grasshopper SDK
GH_ComponentServer..::..Clear Method
GH_ComponentServer Class See Also Send Feedback
Clear all caches.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


ClearStaleUserObjects Method

[image]

Grasshopper SDK
GH_ComponentServer..::..ClearStaleUserObjects Method
GH_ComponentServer Class See Also Send Feedback
Remove all user objects that no longer point to existing files.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ClearStaleUserObjects()
Visual Basic
Public Sub ClearStaleUserObjects

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


CompareProxies Method

[image]

Grasshopper SDK
GH_ComponentServer..::..CompareProxies Method
GH_ComponentServer Class See Also Send Feedback
Compare two object proxies. Names and exposures are taken into account.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static int CompareProxies(
    IGH_ObjectProxy A,
    IGH_ObjectProxy B
)
Visual Basic
Public Shared Function CompareProxies ( _
    A As IGH_ObjectProxy, _
    B As IGH_ObjectProxy _
) As Integer

Parameters

A
Type: Grasshopper.Kernel..::..IGH_ObjectProxy
First proxy to compare.
B
Type: Grasshopper.Kernel..::..IGH_ObjectProxy
Second proxy to compare.

Return Value

-1 if A is valued lower than B, 0 if A and B are considered equal, +1 if A is valued higher than B.

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


CopyFileToRoamingFolder Method

[image]

Grasshopper SDK
GH_ComponentServer..::..CopyFileToRoamingFolder Method
GH_ComponentServer Class See Also Send Feedback
Copy a GHA or GHUSER file into the appropriate Roaming Application Data folder. Of the file is already in the top-level roaming folder it will not be copied.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string CopyFileToRoamingFolder(
    string filepath,
    bool moveOriginalToBin
)
Visual Basic
Public Shared Function CopyFileToRoamingFolder ( _
    filepath As String, _
    moveOriginalToBin As Boolean _
) As String

Parameters

filepath
Type: System..::..String
The file to copy.
moveOriginalToBin
Type: System..::..Boolean
If true, the original file will be placed in the recycle bin upon a successful copy.

Return Value

The path of the copied file.

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


DestroyLoadingUI Method

[image]

Grasshopper SDK
GH_ComponentServer..::..DestroyLoadingUI Method
GH_ComponentServer Class See Also Send Feedback
Destroy the loading UI (the banner and the progress bar).

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DestroyLoadingUI()
Visual Basic
Public Sub DestroyLoadingUI

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


EmitGraph Method

[image]

Grasshopper SDK
GH_ComponentServer..::..EmitGraph Method
GH_ComponentServer Class See Also Send Feedback
Create a new instance of the IGH_Graph that matches the id. If no proxy can be matched to the id, a null reference will be returned.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_Graph EmitGraph(
    Guid id
)
Visual Basic
Public Function EmitGraph ( _
    id As Guid _
) As IGH_Graph

Parameters

id
Type: System..::..Guid
The graph type id to instantiate

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


EmitObject Method

[image]

Grasshopper SDK
GH_ComponentServer..::..EmitObject Method
GH_ComponentServer Class See Also Send Feedback
Create a new instance of the IGH_DocumentObject that matches the id. If no proxy can be matched to the id, a null reference will be returned.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_DocumentObject EmitObject(
    Guid id
)
Visual Basic
Public Function EmitObject ( _
    id As Guid _
) As IGH_DocumentObject

Parameters

id
Type: System..::..Guid
The component type id to instantiate

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


EmitObjectIcon Method

[image]

Grasshopper SDK
GH_ComponentServer..::..EmitObjectIcon Method
GH_ComponentServer Class See Also Send Feedback
Get the icon that is associated with the given Object ID.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Bitmap EmitObjectIcon(
    Guid id
)
Visual Basic
Public Function EmitObjectIcon ( _
    id As Guid _
) As Bitmap

Parameters

id
Type: System..::..Guid
ID to search for.

Return Value

Icon of object or null if object is not defined or if object does not have an icon.

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


EmitObjectProxy Method

[image]

Grasshopper SDK
GH_ComponentServer..::..EmitObjectProxy Method
GH_ComponentServer Class See Also Send Feedback
Get the proxy that is associated with the given Object ID.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_ObjectProxy EmitObjectProxy(
    Guid id
)
Visual Basic
Public Function EmitObjectProxy ( _
    id As Guid _
) As IGH_ObjectProxy

Parameters

id
Type: System..::..Guid
ID to search for.

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


ExternalFiles Method

[image]

Grasshopper SDK
GH_ComponentServer..::..ExternalFiles Method
GH_ComponentServer Class See Also Send Feedback
Get lists of all the external files (GHA, GHUSER and GHCLUSTER) that will be loaded by Grasshopper. Note: this does not equal the files that may already have been loaded, just the files that we'll attempt to load if we were asked to load all plugins now. The list contains no duplicate file paths, but it may contain identical files which won't be filtered until actual loading.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static List<GH_ExternalFile> ExternalFiles(
    bool testGrasshopperCollisions,
    bool testExternalCollisions
)
Visual Basic
Public Shared Function ExternalFiles ( _
    testGrasshopperCollisions As Boolean, _
    testExternalCollisions As Boolean _
) As List(Of GH_ExternalFile)

Parameters

testGrasshopperCollisions
Type: System..::..Boolean
If true, invalid duplicates of Grasshopper.dll will be tested for and warned about.
testExternalCollisions
Type: System..::..Boolean
If true, duplicates of GHA, GHUSER and GHCLUSTER files will be tested for and warned about.

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


FindAssembly Method

[image]

Grasshopper SDK
GH_ComponentServer..::..FindAssembly Method
GH_ComponentServer Class See Also Send Feedback
Gets the assembly that corresponds to the given library ID.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_AssemblyInfo FindAssembly(
    Guid libraryId
)
Visual Basic
Public Function FindAssembly ( _
    libraryId As Guid _
) As GH_AssemblyInfo

Parameters

libraryId
Type: System..::..Guid
Library ID to search for.

Return Value

The library info, or null if the ID is not registered.

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


FindAssemblyByObject Method

[image] [image]

Grasshopper SDK
GH_ComponentServer..::..FindAssemblyByObject Method
GH_ComponentServer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindAssemblyByObject(Guid) | Gets the assembly that corresponds to the given library ID.
Public method | FindAssemblyByObject(IGH_DocumentObject) | Gets the assembly that corresponds to the given library ID.

See Also

GH_ComponentServer Class
GH_ComponentServer Members
Grasshopper.Kernel Namespace


FindAssemblyByObject Method (Guid)

[image]

Grasshopper SDK
GH_ComponentServer..::..FindAssemblyByObject Method (Guid)
GH_ComponentServer Class See Also Send Feedback
Gets the assembly that corresponds to the given library ID.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_AssemblyInfo FindAssemblyByObject(
    Guid objectId
)
Visual Basic
Public Function FindAssemblyByObject ( _
    objectId As Guid _
) As GH_AssemblyInfo

Parameters

objectId
Type: System..::..Guid
The object ComponentGuid.

Return Value

The library info, or null if the ID is not registered.

See Also

GH_ComponentServer Class
FindAssemblyByObject Overload
Grasshopper.Kernel Namespace


FindAssemblyByObject Method (IGH_DocumentObject)

[image]

Grasshopper SDK
GH_ComponentServer..::..FindAssemblyByObject Method (IGH_DocumentObject)
GH_ComponentServer Class See Also Send Feedback
Gets the assembly that corresponds to the given library ID.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_AssemblyInfo FindAssemblyByObject(
    IGH_DocumentObject object
)
Visual Basic
Public Function FindAssemblyByObject ( _
    object As IGH_DocumentObject _
) As GH_AssemblyInfo

Parameters

object
Type: Grasshopper.Kernel..::..IGH_DocumentObject
Object.

Return Value

The library info, or null if the ID is not registered.

See Also

GH_ComponentServer Class
FindAssemblyByObject Overload
Grasshopper.Kernel Namespace


FindObjects Method

[image] [image]

Grasshopper SDK
GH_ComponentServer..::..FindObjects Method
GH_ComponentServer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindObjects(Guid) | Find all the objects that are part of a certain library.
Public method | FindObjects(array<String>[]()[][], Int32) | Searches the list of cached object proxies for objects that might be implied by a search term.

See Also

GH_ComponentServer Class
GH_ComponentServer Members
Grasshopper.Kernel Namespace


FindObjects Method (Guid)

[image]

Grasshopper SDK
GH_ComponentServer..::..FindObjects Method (Guid)
GH_ComponentServer Class See Also Send Feedback
Find all the objects that are part of a certain library.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<IGH_ObjectProxy> FindObjects(
    Guid libraryID
)
Visual Basic
Public Function FindObjects ( _
    libraryID As Guid _
) As List(Of IGH_ObjectProxy)

Parameters

libraryID
Type: System..::..Guid
ID of library to search for.

Return Value

A list of all the objects that are defined in the specified library.

See Also

GH_ComponentServer Class
FindObjects Overload
Grasshopper.Kernel Namespace


FindObjects Method (String[], Int32)

[image]

Grasshopper SDK
GH_ComponentServer..::..FindObjects Method (array<String>[]()[][], Int32)
GH_ComponentServer Class See Also Send Feedback
Searches the list of cached object proxies for objects that might be implied by a search term.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IList<IGH_ObjectProxy> FindObjects(
    string[] terms,
    int max_hits
)
Visual Basic
Public Function FindObjects ( _
    terms As String(), _
    max_hits As Integer _
) As IList(Of IGH_ObjectProxy)

Parameters

terms
Type: array< System..::..String >[]()[][]
Search terms to use.
max_hits
Type: System..::..Int32
Maximum number of allowed hits.

Return Value

A sorted list of search results.

See Also

GH_ComponentServer Class
FindObjects Overload
Grasshopper.Kernel Namespace


FindUpgrader Method

[image]

Grasshopper SDK
GH_ComponentServer..::..FindUpgrader Method
GH_ComponentServer Class See Also Send Feedback
Find the upgrader that can convert from the given target.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_UpgradeObject FindUpgrader(
    Guid target
)
Visual Basic
Public Function FindUpgrader ( _
    target As Guid _
) As IGH_UpgradeObject

Parameters

target
Type: System..::..Guid
ComponentID of object to upgrade.

Return Value

Matching upgrader or null if no upgrader is defined.

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


GetAlias Method

[image]

Grasshopper SDK
GH_ComponentServer..::..GetAlias Method
GH_ComponentServer Class See Also Send Feedback
Gets the alias display string for a given object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string GetAlias(
    Guid target
)
Visual Basic
Public Function GetAlias ( _
    target As Guid _
) As String

Parameters

target
Type: System..::..Guid
Object id to retrieve aliases for.

Return Value

A parsable display string of aliases.

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


GetCategoryIcon Method

[image]

Grasshopper SDK
GH_ComponentServer..::..GetCategoryIcon Method
GH_ComponentServer Class See Also Send Feedback
Get the icon for a specific category. If the icon hasn't been defined, this method will return the default icon.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Bitmap GetCategoryIcon(
    string fullName
)
Visual Basic
Public Function GetCategoryIcon ( _
    fullName As String _
) As Bitmap

Parameters

fullName
Type: System..::..String
Full name of category.

Return Value

The category icon.

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


GetCategoryShortName Method

[image]

Grasshopper SDK
GH_ComponentServer..::..GetCategoryShortName Method
GH_ComponentServer Class See Also Send Feedback
Get the abbreviation (short name) for a specific category. If the short name hasn't been defined, this method will return the full name instead.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string GetCategoryShortName(
    string fullName
)
Visual Basic
Public Function GetCategoryShortName ( _
    fullName As String _
) As String

Parameters

fullName
Type: System..::..String
Full name of category.

Return Value

The abbreviated name or the full name.

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


GetCategorySymbolName Method

[image]

Grasshopper SDK
GH_ComponentServer..::..GetCategorySymbolName Method
GH_ComponentServer Class See Also Send Feedback
Get the single char representation for a specific category. If the char hasn't been defined, this method will return the first char of the full name instead.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string GetCategorySymbolName(
    string fullName
)
Visual Basic
Public Function GetCategorySymbolName ( _
    fullName As String _
) As String

Parameters

fullName
Type: System..::..String
Full name of category.

Return Value

The category char.

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


IsGraphCached Method

[image]

Grasshopper SDK
GH_ComponentServer..::..IsGraphCached Method
GH_ComponentServer Class See Also Send Feedback
Tests the graph cache for an existing graph type ID.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsGraphCached(
    Guid id
)
Visual Basic
Public Function IsGraphCached ( _
    id As Guid _
) As Boolean

Parameters

id
Type: System..::..Guid
The ID to test for.

Return Value

True if the ID is cached, false if it aint.

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


IsObjectCached Method

[image]

Grasshopper SDK
GH_ComponentServer..::..IsObjectCached Method
GH_ComponentServer Class See Also Send Feedback
Tests the caches for an existing object type ID.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsObjectCached(
    Guid id
)
Visual Basic
Public Function IsObjectCached ( _
    id As Guid _
) As Boolean

Parameters

id
Type: System..::..Guid
The ID to test for.

Return Value

True if the ID is cached, false if it aint.

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


IsUpgrader Method

[image]

Grasshopper SDK
GH_ComponentServer..::..IsUpgrader Method
GH_ComponentServer Class See Also Send Feedback
Checks to see if at least one upgrader is defined for a collection of objects.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsUpgrader(
    IEnumerable<IGH_DocumentObject> objs
)
Visual Basic
Public Function IsUpgrader ( _
    objs As IEnumerable(Of IGH_DocumentObject) _
) As Boolean

Parameters

objs
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' IGH_DocumentObject >)>)>

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


LoadAliases Method

[image]

Grasshopper SDK
GH_ComponentServer..::..LoadAliases Method
GH_ComponentServer Class See Also Send Feedback
Load the Alias table from the settings directory. Only use this function if you suspect the alias table settings file has changed due to some external process.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void LoadAliases()
Visual Basic
Public Sub LoadAliases

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


LoadExternalFiles Method

[image]

Grasshopper SDK
GH_ComponentServer..::..LoadExternalFiles Method
GH_ComponentServer Class See Also Send Feedback
Attempt to parse all external files. This includes GHA libraries, GHUSER objects and GHCLUSTER files.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool LoadExternalFiles()
Visual Basic
Public Function LoadExternalFiles As Boolean

Return Value

True on success, false on failure.

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


NewUserObject Method

[image]

Grasshopper SDK
GH_ComponentServer..::..NewUserObject Method
GH_ComponentServer Class See Also Send Feedback
Create a new UserObject and write it to the Grasshopper User Object folder.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool NewUserObject(
    IGH_DocumentObject obj
)
Visual Basic
Public Shared Function NewUserObject ( _
    obj As IGH_DocumentObject _
) As Boolean

Parameters

obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject
Object to write.

Return Value

True on success, false on failure.

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


RemoveCachedGraph Method

[image]

Grasshopper SDK
GH_ComponentServer..::..RemoveCachedGraph Method
GH_ComponentServer Class See Also Send Feedback
Remove a cache entry from the graph cache. This cannot be undone.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool RemoveCachedGraph(
    Guid id
)
Visual Basic
Public Function RemoveCachedGraph ( _
    id As Guid _
) As Boolean

Parameters

id
Type: System..::..Guid
The id to remove.

Return Value

True on success, false on failure.

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


RemoveCachedObject Method

[image] [image]

Grasshopper SDK
GH_ComponentServer..::..RemoveCachedObject Method
GH_ComponentServer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveCachedObject(Guid) | Remove a cache entry from the object cache. This cannot be undone.
Public method | RemoveCachedObject(String) | Remove the user object (if any) that loads itself from a specified *.ghuser file.

See Also

GH_ComponentServer Class
GH_ComponentServer Members
Grasshopper.Kernel Namespace


RemoveCachedObject Method (Guid)

[image]

Grasshopper SDK
GH_ComponentServer..::..RemoveCachedObject Method (Guid)
GH_ComponentServer Class See Also Send Feedback
Remove a cache entry from the object cache. This cannot be undone.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool RemoveCachedObject(
    Guid id
)
Visual Basic
Public Function RemoveCachedObject ( _
    id As Guid _
) As Boolean

Parameters

id
Type: System..::..Guid
The id to remove.

Return Value

True on success, false on failure.

See Also

GH_ComponentServer Class
RemoveCachedObject Overload
Grasshopper.Kernel Namespace


RemoveCachedObject Method (String)

[image]

Grasshopper SDK
GH_ComponentServer..::..RemoveCachedObject Method (String)
GH_ComponentServer Class See Also Send Feedback
Remove the user object (if any) that loads itself from a specified *.ghuser file.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool RemoveCachedObject(
    string userObjectFilePath
)
Visual Basic
Public Function RemoveCachedObject ( _
    userObjectFilePath As String _
) As Boolean

Parameters

userObjectFilePath
Type: System..::..String
File name path of user object proxy.

Return Value

True if an object proxy was removed, false if not.

See Also

GH_ComponentServer Class
RemoveCachedObject Overload
Grasshopper.Kernel Namespace


SaveAliases Method

[image]

Grasshopper SDK
GH_ComponentServer..::..SaveAliases Method
GH_ComponentServer Class See Also Send Feedback
Save the alias table to the settings directory. Use this function if you change the alias table while ignoring usual channels.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SaveAliases()
Visual Basic
Public Sub SaveAliases

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


SetAlias Method

[image]

Grasshopper SDK
GH_ComponentServer..::..SetAlias Method
GH_ComponentServer Class See Also Send Feedback
Sets the aliases for a given target.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SetAlias(
    string alias,
    Guid target
)
Visual Basic
Public Sub SetAlias ( _
    alias As String, _
    target As Guid _
)

Parameters

alias
Type: System..::..String
Alias to add. If the alias string contains spaces or commas, those will be used to harvest partial aliases. Use a zero-length alias to remove all aliases to the target.
target
Type: System..::..Guid
Component ID of object that is targeted by the alias.

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


UpdateRibbonUI Method

[image]

Grasshopper SDK
GH_ComponentServer..::..UpdateRibbonUI Method
GH_ComponentServer Class See Also Send Feedback
Forces an update of the Ribbon control on the Grasshopper main form.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void UpdateRibbonUI()
Visual Basic
Public Shared Sub UpdateRibbonUI

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


GH_ComponentServer Properties

[image] [image]

Grasshopper SDK
GH_ComponentServer Properties
GH_ComponentServer Class See Also Send Feedback

The GH_ComponentServer type exposes the following members.

Properties

 | Name | Description
Public property | Aliases | Gets a list of all the defined aliases.
 | AllAddOns | Obsolete. Gets a list of all the gha and ghuser files that will be loaded as Grasshopper add-ons.
Public property | CompleteRibbonLayout | Gets the default component layout featuring all non-hidden components and parameters.
Public property | DiscardedProxies | Returns the total number of IGH_DocumentObjects that were discarded during assembly parsing. This includes both skipped and replaced proxies.
Public property | GraphProxies | Returns a list of all cached GH_GraphProxy instances.
Public property | Libraries | Returns a list of Assembly Info objects describing all loaded assemblies.
Public property | LoadingExceptions | Gets a list of all the exceptions that were recorded during the most recent loading sequence.
Public property | ObjectProxies | Returns a list of all cached GH_ObjectProxy instances.
Public property | ObjectProxyNames | Returns a specialized string collection of all component names.
Public property | TypeHints | Gets a list of all IGH_TypeHint types in all loaded assemblies.
Public property | Upgraders | Gets a list of all the upgraders that have been cached.

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


Aliases Property

[image]

Grasshopper SDK
GH_ComponentServer..::..Aliases Property
GH_ComponentServer Class See Also Send Feedback
Gets a list of all the defined aliases.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<string> Aliases { get; }
Visual Basic
Public ReadOnly Property Aliases As List(Of String)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ComponentServer.Aliases"]

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


AllAddOns Property

[image]

Grasshopper SDK
GH_ComponentServer..::..AllAddOns Property
GH_ComponentServer Class See Also Send Feedback
Gets a list of all the gha and ghuser files that will be loaded as Grasshopper add-ons.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
[ObsoleteAttribute("This property has been replaced by the ExternalFiles() Shared method")]
public static List<string> AllAddOns { get; }
Visual Basic
<ObsoleteAttribute("This property has been replaced by the ExternalFiles() Shared method")> _
Public Shared ReadOnly Property AllAddOns As List(Of String)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ComponentServer.AllAddOns"]

Return Value

A list of target file paths.

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


CompleteRibbonLayout Property

[image]

Grasshopper SDK
GH_ComponentServer..::..CompleteRibbonLayout Property
GH_ComponentServer Class See Also Send Feedback
Gets the default component layout featuring all non-hidden components and parameters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Layout CompleteRibbonLayout { get; }
Visual Basic
Public ReadOnly Property CompleteRibbonLayout As GH_Layout
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ComponentServer.CompleteRibbonLayout"]

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


DiscardedProxies Property

[image]

Grasshopper SDK
GH_ComponentServer..::..DiscardedProxies Property
GH_ComponentServer Class See Also Send Feedback
Returns the total number of IGH_DocumentObjects that were discarded during assembly parsing. This includes both skipped and replaced proxies.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int DiscardedProxies { get; }
Visual Basic
Public ReadOnly Property DiscardedProxies As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ComponentServer.DiscardedProxies"]

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


GraphProxies Property

[image]

Grasshopper SDK
GH_ComponentServer..::..GraphProxies Property
GH_ComponentServer Class See Also Send Feedback
Returns a list of all cached GH_GraphProxy instances.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IList<GH_GraphProxy> GraphProxies { get; }
Visual Basic
Public ReadOnly Property GraphProxies As IList(Of GH_GraphProxy)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ComponentServer.GraphProxies"]

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


Libraries Property

[image]

Grasshopper SDK
GH_ComponentServer..::..Libraries Property
GH_ComponentServer Class See Also Send Feedback
Returns a list of Assembly Info objects describing all loaded assemblies.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public ReadOnlyCollection<GH_AssemblyInfo> Libraries { get; }
Visual Basic
Public ReadOnly Property Libraries As ReadOnlyCollection(Of GH_AssemblyInfo)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ComponentServer.Libraries"]

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


LoadingExceptions Property

[image]

Grasshopper SDK
GH_ComponentServer..::..LoadingExceptions Property
GH_ComponentServer Class See Also Send Feedback
Gets a list of all the exceptions that were recorded during the most recent loading sequence.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<GH_LoadingException> LoadingExceptions { get; }
Visual Basic
Public ReadOnly Property LoadingExceptions As List(Of GH_LoadingException)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ComponentServer.LoadingExceptions"]

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


ObjectProxies Property

[image]

Grasshopper SDK
GH_ComponentServer..::..ObjectProxies Property
GH_ComponentServer Class See Also Send Feedback
Returns a list of all cached GH_ObjectProxy instances.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IList<IGH_ObjectProxy> ObjectProxies { get; }
Visual Basic
Public ReadOnly Property ObjectProxies As IList(Of IGH_ObjectProxy)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ComponentServer.ObjectProxies"]

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


ObjectProxyNames Property

[image]

Grasshopper SDK
GH_ComponentServer..::..ObjectProxyNames Property
GH_ComponentServer Class See Also Send Feedback
Returns a specialized string collection of all component names.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public AutoCompleteStringCollection ObjectProxyNames { get; }
Visual Basic
Public ReadOnly Property ObjectProxyNames As AutoCompleteStringCollection
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ComponentServer.ObjectProxyNames"]

Remarks

This property is used for autocompletion in textboxes.

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


TypeHints Property

[image]

Grasshopper SDK
GH_ComponentServer..::..TypeHints Property
GH_ComponentServer Class See Also Send Feedback
Gets a list of all IGH_TypeHint types in all loaded assemblies.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IList<Type> TypeHints { get; }
Visual Basic
Public ReadOnly Property TypeHints As IList(Of Type)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ComponentServer.TypeHints"]

Return Value

A list of System.Type containing all classes that implement IGH_TypeHint.

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


Upgraders Property

[image]

Grasshopper SDK
GH_ComponentServer..::..Upgraders Property
GH_ComponentServer Class See Also Send Feedback
Gets a list of all the upgraders that have been cached.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IList<IGH_UpgradeObject> Upgraders { get; }
Visual Basic
Public ReadOnly Property Upgraders As IList(Of IGH_UpgradeObject)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ComponentServer.Upgraders"]

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


GH_ComponentServer Events

[image] [image]

Grasshopper SDK
GH_ComponentServer Events
GH_ComponentServer Class See Also Send Feedback

The GH_ComponentServer type exposes the following members.

Events

 | Name | Description
Public event | GHAFileLoaded | Raised whenever a GHA file has been successfully loaded.

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


GHAFileLoaded Event

[image]

Grasshopper SDK
GH_ComponentServer..::..GHAFileLoaded Event
GH_ComponentServer Class See Also Send Feedback
Raised whenever a GHA file has been successfully loaded.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_ComponentServer..::..GHAFileLoadedEventHandler GHAFileLoaded
Visual Basic
Public Event GHAFileLoaded As GH_ComponentServer..::..GHAFileLoadedEventHandler

See Also

GH_ComponentServer Class
Grasshopper.Kernel Namespace


GH_ComponentServer.GHAFileLoadedEventHandler Delegate

[image]

Grasshopper SDK
GH_ComponentServer..::..GHAFileLoadedEventHandler Delegate
GH_ComponentServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void GHAFileLoadedEventHandler(
    Object sender,
    GH_GHALoadingEventArgs e
)
Visual Basic
Public Delegate Sub GHAFileLoadedEventHandler ( _
    sender As Object, _
    e As GH_GHALoadingEventArgs _
)

Parameters

sender
Type: System..::..Object
e
Type: Grasshopper.Kernel..::..GH_GHALoadingEventArgs

See Also

Grasshopper.Kernel Namespace


GH_ConnectivityDiagram Class

[image]

Grasshopper SDK
GH_ConnectivityDiagram Class
Members See Also Send Feedback
Represents a complete connectivity diagram (topology) of a GH_Document. A connectivity diagram is basically an undirected network of all the wires in a document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_ConnectivityDiagram
Visual Basic
Public Class GH_ConnectivityDiagram

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_ConnectivityDiagram

See Also

GH_ConnectivityDiagram Members
Grasshopper.Kernel Namespace


GH_ConnectivityDiagram Members

[image] [image]

Grasshopper SDK
GH_ConnectivityDiagram Members
GH_ConnectivityDiagram Class Constructors Methods Properties See Also Send Feedback

The GH_ConnectivityDiagram type exposes the following members.

Constructors

 | Name | Description
Public method | GH_ConnectivityDiagram(GH_ConnectivityDiagram) | Create a duplicate of another Connectivity Diagram.
Public method | GH_ConnectivityDiagram(GH_Document) | Create a new Connectivity Diagram from a GH_Document.

Methods

 | Name | Description
Public method | ContainsID | Test the diagram for a given Node ID.
Public method | GetAllInputs | Get all the Nodes that are part of the specified node input.
Public method | GetAllOutputs | Get all the Nodes that are part of the specified node output.

Properties

 | Name | Description
Public property | Node | Get the connectivity node with the specified ID.
Public property | NodeCount | Gets the number of connectivity nodes in this diagram.
Public property | Nodes | Gets a proxy for all the Nodes in this diagram.

See Also

GH_ConnectivityDiagram Class
Grasshopper.Kernel Namespace


GH_ConnectivityDiagram Constructor

[image] [image]

Grasshopper SDK
GH_ConnectivityDiagram Constructor
GH_ConnectivityDiagram Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_ConnectivityDiagram(GH_ConnectivityDiagram) | Create a duplicate of another Connectivity Diagram.
Public method | GH_ConnectivityDiagram(GH_Document) | Create a new Connectivity Diagram from a GH_Document.

See Also

GH_ConnectivityDiagram Class
GH_ConnectivityDiagram Members
Grasshopper.Kernel Namespace


GH_ConnectivityDiagram Constructor (GH_ConnectivityDiagram)

[image]

Grasshopper SDK
GH_ConnectivityDiagram Constructor (GH_ConnectivityDiagram)
GH_ConnectivityDiagram Class See Also Send Feedback
Create a duplicate of another Connectivity Diagram.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ConnectivityDiagram(
    GH_ConnectivityDiagram other
)
Visual Basic
Public Sub New ( _
    other As GH_ConnectivityDiagram _
)

Parameters

other
Type: Grasshopper.Kernel..::..GH_ConnectivityDiagram
Diagram to copy.

See Also

GH_ConnectivityDiagram Class
GH_ConnectivityDiagram Overload
Grasshopper.Kernel Namespace


GH_ConnectivityDiagram Constructor (GH_Document)

[image]

Grasshopper SDK
GH_ConnectivityDiagram Constructor (GH_Document)
GH_ConnectivityDiagram Class See Also Send Feedback
Create a new Connectivity Diagram from a GH_Document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ConnectivityDiagram(
    GH_Document doc
)
Visual Basic
Public Sub New ( _
    doc As GH_Document _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document
Document to examine.

See Also

GH_ConnectivityDiagram Class
GH_ConnectivityDiagram Overload
Grasshopper.Kernel Namespace


GH_ConnectivityDiagram Methods

[image] [image]

Grasshopper SDK
GH_ConnectivityDiagram Methods
GH_ConnectivityDiagram Class See Also Send Feedback

The GH_ConnectivityDiagram type exposes the following members.

Methods

 | Name | Description
Public method | ContainsID | Test the diagram for a given Node ID.
Public method | GetAllInputs | Get all the Nodes that are part of the specified node input.
Public method | GetAllOutputs | Get all the Nodes that are part of the specified node output.

See Also

GH_ConnectivityDiagram Class
Grasshopper.Kernel Namespace


ContainsID Method

[image]

Grasshopper SDK
GH_ConnectivityDiagram..::..ContainsID Method
GH_ConnectivityDiagram Class See Also Send Feedback
Test the diagram for a given Node ID.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool ContainsID(
    Guid id
)
Visual Basic
Public Function ContainsID ( _
    id As Guid _
) As Boolean

Parameters

id
Type: System..::..Guid
ID to search for.

Return Value

True if the ID is part of this diagram, false if otherwise.

See Also

GH_ConnectivityDiagram Class
Grasshopper.Kernel Namespace


GetAllInputs Method

[image]

Grasshopper SDK
GH_ConnectivityDiagram..::..GetAllInputs Method
GH_ConnectivityDiagram Class See Also Send Feedback
Get all the Nodes that are part of the specified node input.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<Guid> GetAllInputs(
    Guid id
)
Visual Basic
Public Function GetAllInputs ( _
    id As Guid _
) As List(Of Guid)

Parameters

id
Type: System..::..Guid
ID of node to query.

Return Value

A list of input nodes.

See Also

GH_ConnectivityDiagram Class
Grasshopper.Kernel Namespace


GetAllOutputs Method

[image]

Grasshopper SDK
GH_ConnectivityDiagram..::..GetAllOutputs Method
GH_ConnectivityDiagram Class See Also Send Feedback
Get all the Nodes that are part of the specified node output.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<Guid> GetAllOutputs(
    Guid id
)
Visual Basic
Public Function GetAllOutputs ( _
    id As Guid _
) As List(Of Guid)

Parameters

id
Type: System..::..Guid
ID of node to query.

Return Value

A list of output nodes.

See Also

GH_ConnectivityDiagram Class
Grasshopper.Kernel Namespace


GH_ConnectivityDiagram Properties

[image] [image]

Grasshopper SDK
GH_ConnectivityDiagram Properties
GH_ConnectivityDiagram Class See Also Send Feedback

The GH_ConnectivityDiagram type exposes the following members.

Properties

 | Name | Description
Public property | Node | Get the connectivity node with the specified ID.
Public property | NodeCount | Gets the number of connectivity nodes in this diagram.
Public property | Nodes | Gets a proxy for all the Nodes in this diagram.

See Also

GH_ConnectivityDiagram Class
Grasshopper.Kernel Namespace


Node Property

[image]

Grasshopper SDK
GH_ConnectivityDiagram..::..Node Property
GH_ConnectivityDiagram Class See Also Send Feedback
Get the connectivity node with the specified ID.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ConnectivityNode this[
    Guid id
] { get; }
Visual Basic
Public ReadOnly Default Property Node ( _
    id As Guid _
) As GH_ConnectivityNode
    Get

Parameters

id
Type: System..::..Guid
ID of node to search for.

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ConnectivityDiagram.Node(System.Guid)"]

Return Value

The node on success or null on failure.

See Also

GH_ConnectivityDiagram Class
Grasshopper.Kernel Namespace


NodeCount Property

[image]

Grasshopper SDK
GH_ConnectivityDiagram..::..NodeCount Property
GH_ConnectivityDiagram Class See Also Send Feedback
Gets the number of connectivity nodes in this diagram.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int NodeCount { get; }
Visual Basic
Public ReadOnly Property NodeCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ConnectivityDiagram.NodeCount"]

See Also

GH_ConnectivityDiagram Class
Grasshopper.Kernel Namespace


Nodes Property

[image]

Grasshopper SDK
GH_ConnectivityDiagram..::..Nodes Property
GH_ConnectivityDiagram Class See Also Send Feedback
Gets a proxy for all the Nodes in this diagram.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public ReadOnlyCollection<Guid> Nodes { get; }
Visual Basic
Public ReadOnly Property Nodes As ReadOnlyCollection(Of Guid)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ConnectivityDiagram.Nodes"]

See Also

GH_ConnectivityDiagram Class
Grasshopper.Kernel Namespace


GH_ConnectivityDisparity Class

[image]

Grasshopper SDK
GH_ConnectivityDisparity Class
Members See Also Send Feedback
Maintains two connectivity diagrams, one of which is a subset of the other.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_ConnectivityDisparity
Visual Basic
Public Class GH_ConnectivityDisparity

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_ConnectivityDisparity

See Also

GH_ConnectivityDisparity Members
Grasshopper.Kernel Namespace


GH_ConnectivityDisparity Members

[image] [image]

Grasshopper SDK
GH_ConnectivityDisparity Members
GH_ConnectivityDisparity Class Constructors Methods Properties See Also Send Feedback

The GH_ConnectivityDisparity type exposes the following members.

Constructors

 | Name | Description
Public method | GH_ConnectivityDisparity | Create a new instance of the Connectivity Disparity utility class.

Methods

 | Name | Description
Public method | ExternalInputs | Find all external sources for a given id in the subset.
Public method | ExternalOutputs | Find all external recipients for a given id in the subset.
Public method | InternalInputs | Find all internal sources for a given id in the subset.
Public method | InternalOutputs | Find all external recipients for a given id in the subset.

Properties

 | Name | Description
Public property | SubNodes | Gets a proxy for all the Nodes in the Subset diagram.
Public property | SubSet | Gets a pointer to the subset diagram stored in this disparity class.
Public property | TopNodes | Gets a proxy for all the Nodes in the Top Level diagram.
Public property | TopSet | Gets a pointer to the complete diagram stored in this disparity class.

See Also

GH_ConnectivityDisparity Class
Grasshopper.Kernel Namespace


GH_ConnectivityDisparity Constructor

[image]

Grasshopper SDK
GH_ConnectivityDisparity Constructor
GH_ConnectivityDisparity Class See Also Send Feedback
Create a new instance of the Connectivity Disparity utility class.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ConnectivityDisparity(
    GH_ConnectivityDiagram topset,
    GH_ConnectivityDiagram subset
)
Visual Basic
Public Sub New ( _
    topset As GH_ConnectivityDiagram, _
    subset As GH_ConnectivityDiagram _
)

Parameters

topset
Type: Grasshopper.Kernel..::..GH_ConnectivityDiagram
Overarching connectivity diagram.
subset
Type: Grasshopper.Kernel..::..GH_ConnectivityDiagram
Partial connectivity diagram.

See Also

GH_ConnectivityDisparity Class
Grasshopper.Kernel Namespace


GH_ConnectivityDisparity Methods

[image] [image]

Grasshopper SDK
GH_ConnectivityDisparity Methods
GH_ConnectivityDisparity Class See Also Send Feedback

The GH_ConnectivityDisparity type exposes the following members.

Methods

 | Name | Description
Public method | ExternalInputs | Find all external sources for a given id in the subset.
Public method | ExternalOutputs | Find all external recipients for a given id in the subset.
Public method | InternalInputs | Find all internal sources for a given id in the subset.
Public method | InternalOutputs | Find all external recipients for a given id in the subset.

See Also

GH_ConnectivityDisparity Class
Grasshopper.Kernel Namespace


ExternalInputs Method

[image]

Grasshopper SDK
GH_ConnectivityDisparity..::..ExternalInputs Method
GH_ConnectivityDisparity Class See Also Send Feedback
Find all external sources for a given id in the subset.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<Guid> ExternalInputs(
    Guid id
)
Visual Basic
Public Function ExternalInputs ( _
    id As Guid _
) As List(Of Guid)

Parameters

id
Type: System..::..Guid
ID of parameter.

Return Value

A list containing all sources that are not present in the subset topology.

See Also

GH_ConnectivityDisparity Class
Grasshopper.Kernel Namespace


ExternalOutputs Method

[image]

Grasshopper SDK
GH_ConnectivityDisparity..::..ExternalOutputs Method
GH_ConnectivityDisparity Class See Also Send Feedback
Find all external recipients for a given id in the subset.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<Guid> ExternalOutputs(
    Guid id
)
Visual Basic
Public Function ExternalOutputs ( _
    id As Guid _
) As List(Of Guid)

Parameters

id
Type: System..::..Guid
ID of parameter.

Return Value

A list containing all recipients that are not present in the subset topology.

See Also

GH_ConnectivityDisparity Class
Grasshopper.Kernel Namespace


InternalInputs Method

[image]

Grasshopper SDK
GH_ConnectivityDisparity..::..InternalInputs Method
GH_ConnectivityDisparity Class See Also Send Feedback
Find all internal sources for a given id in the subset.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<Guid> InternalInputs(
    Guid id
)
Visual Basic
Public Function InternalInputs ( _
    id As Guid _
) As List(Of Guid)

Parameters

id
Type: System..::..Guid
ID of parameter.

Return Value

A list containing all sources that are present in the subset topology.

See Also

GH_ConnectivityDisparity Class
Grasshopper.Kernel Namespace


InternalOutputs Method

[image]

Grasshopper SDK
GH_ConnectivityDisparity..::..InternalOutputs Method
GH_ConnectivityDisparity Class See Also Send Feedback
Find all external recipients for a given id in the subset.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<Guid> InternalOutputs(
    Guid id
)
Visual Basic
Public Function InternalOutputs ( _
    id As Guid _
) As List(Of Guid)

Parameters

id
Type: System..::..Guid
ID of parameter.

Return Value

A list containing all recipients that are present in the subset topology.

See Also

GH_ConnectivityDisparity Class
Grasshopper.Kernel Namespace


GH_ConnectivityDisparity Properties

[image] [image]

Grasshopper SDK
GH_ConnectivityDisparity Properties
GH_ConnectivityDisparity Class See Also Send Feedback

The GH_ConnectivityDisparity type exposes the following members.

Properties

 | Name | Description
Public property | SubNodes | Gets a proxy for all the Nodes in the Subset diagram.
Public property | SubSet | Gets a pointer to the subset diagram stored in this disparity class.
Public property | TopNodes | Gets a proxy for all the Nodes in the Top Level diagram.
Public property | TopSet | Gets a pointer to the complete diagram stored in this disparity class.

See Also

GH_ConnectivityDisparity Class
Grasshopper.Kernel Namespace


SubNodes Property

[image]

Grasshopper SDK
GH_ConnectivityDisparity..::..SubNodes Property
GH_ConnectivityDisparity Class See Also Send Feedback
Gets a proxy for all the Nodes in the Subset diagram.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public ReadOnlyCollection<Guid> SubNodes { get; }
Visual Basic
Public ReadOnly Property SubNodes As ReadOnlyCollection(Of Guid)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ConnectivityDisparity.SubNodes"]

See Also

GH_ConnectivityDisparity Class
Grasshopper.Kernel Namespace


SubSet Property

[image]

Grasshopper SDK
GH_ConnectivityDisparity..::..SubSet Property
GH_ConnectivityDisparity Class See Also Send Feedback
Gets a pointer to the subset diagram stored in this disparity class.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ConnectivityDiagram SubSet { get; }
Visual Basic
Public ReadOnly Property SubSet As GH_ConnectivityDiagram
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ConnectivityDisparity.SubSet"]

See Also

GH_ConnectivityDisparity Class
Grasshopper.Kernel Namespace


TopNodes Property

[image]

Grasshopper SDK
GH_ConnectivityDisparity..::..TopNodes Property
GH_ConnectivityDisparity Class See Also Send Feedback
Gets a proxy for all the Nodes in the Top Level diagram.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public ReadOnlyCollection<Guid> TopNodes { get; }
Visual Basic
Public ReadOnly Property TopNodes As ReadOnlyCollection(Of Guid)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ConnectivityDisparity.TopNodes"]

See Also

GH_ConnectivityDisparity Class
Grasshopper.Kernel Namespace


TopSet Property

[image]

Grasshopper SDK
GH_ConnectivityDisparity..::..TopSet Property
GH_ConnectivityDisparity Class See Also Send Feedback
Gets a pointer to the complete diagram stored in this disparity class.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ConnectivityDiagram TopSet { get; }
Visual Basic
Public ReadOnly Property TopSet As GH_ConnectivityDiagram
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ConnectivityDisparity.TopSet"]

See Also

GH_ConnectivityDisparity Class
Grasshopper.Kernel Namespace


GH_ConnectivityNode Class

[image]

Grasshopper SDK
GH_ConnectivityNode Class
Members See Also Send Feedback
Represents a single node in a Grasshopper connectivity diagram. A single node represents a single IGH_Param instance.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_ConnectivityNode
Visual Basic
Public Class GH_ConnectivityNode

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_ConnectivityNode

See Also

GH_ConnectivityNode Members
Grasshopper.Kernel Namespace


GH_ConnectivityNode Members

[image] [image]

Grasshopper SDK
GH_ConnectivityNode Members
GH_ConnectivityNode Class Constructors Properties See Also Send Feedback

The GH_ConnectivityNode type exposes the following members.

Constructors

 | Name | Description
Public method | GH_ConnectivityNode | Initializes a new instance of the GH_ConnectivityNode class

Properties

 | Name | Description
Public property | NodeID | Gets the InstanceID of the Parameter that this node represents.
Public property | NodeIn | Gets the list of IDs that are connected to the input of this node.
Public property | NodeOut | Gets the list of IDs that are connected to the input of this node.

See Also

GH_ConnectivityNode Class
Grasshopper.Kernel Namespace


GH_ConnectivityNode Constructor

[image]

Grasshopper SDK
GH_ConnectivityNode Constructor
GH_ConnectivityNode Class See Also Send Feedback
Initializes a new instance of the GH_ConnectivityNode class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ConnectivityNode(
    GH_ConnectivityNode other
)
Visual Basic
Public Sub New ( _
    other As GH_ConnectivityNode _
)

Parameters

other
Type: Grasshopper.Kernel..::..GH_ConnectivityNode

See Also

GH_ConnectivityNode Class
Grasshopper.Kernel Namespace


GH_ConnectivityNode Properties

[image] [image]

Grasshopper SDK
GH_ConnectivityNode Properties
GH_ConnectivityNode Class See Also Send Feedback

The GH_ConnectivityNode type exposes the following members.

Properties

 | Name | Description
Public property | NodeID | Gets the InstanceID of the Parameter that this node represents.
Public property | NodeIn | Gets the list of IDs that are connected to the input of this node.
Public property | NodeOut | Gets the list of IDs that are connected to the input of this node.

See Also

GH_ConnectivityNode Class
Grasshopper.Kernel Namespace


NodeID Property

[image]

Grasshopper SDK
GH_ConnectivityNode..::..NodeID Property
GH_ConnectivityNode Class See Also Send Feedback
Gets the InstanceID of the Parameter that this node represents.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid NodeID { get; }
Visual Basic
Public ReadOnly Property NodeID As Guid
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ConnectivityNode.NodeID"]

See Also

GH_ConnectivityNode Class
Grasshopper.Kernel Namespace


NodeIn Property

[image]

Grasshopper SDK
GH_ConnectivityNode..::..NodeIn Property
GH_ConnectivityNode Class See Also Send Feedback
Gets the list of IDs that are connected to the input of this node.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public ReadOnlyCollection<Guid> NodeIn { get; }
Visual Basic
Public ReadOnly Property NodeIn As ReadOnlyCollection(Of Guid)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ConnectivityNode.NodeIn"]

See Also

GH_ConnectivityNode Class
Grasshopper.Kernel Namespace


NodeOut Property

[image]

Grasshopper SDK
GH_ConnectivityNode..::..NodeOut Property
GH_ConnectivityNode Class See Also Send Feedback
Gets the list of IDs that are connected to the input of this node.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public ReadOnlyCollection<Guid> NodeOut { get; }
Visual Basic
Public ReadOnly Property NodeOut As ReadOnlyCollection(Of Guid)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ConnectivityNode.NodeOut"]

See Also

GH_ConnectivityNode Class
Grasshopper.Kernel Namespace


GH_Conversion Enumeration

[image]

Grasshopper SDK
GH_Conversion Enumeration
See Also Send Feedback
Level flag for conversion algorithms.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_Conversion
Visual Basic
Public Enumeration GH_Conversion

Members

Member name | Value | Description
Primary | 0 | Primary conversions only entail direct casts from identical or similar data types.
Secondary | 1 | Secondary conversions entail all implied conversions with the exception of direct casts.
Both | 2 | Indicates both Primary and Secondary

See Also

Grasshopper.Kernel Namespace


GH_Convert Class

[image]

Grasshopper SDK
GH_Convert Class
Members See Also Send Feedback
Provides static converters for different data types inside Grasshopper. This class both has specific and generic converters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class GH_Convert
Visual Basic
Public NotInheritable Class GH_Convert

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_Convert

See Also

GH_Convert Members
Grasshopper.Kernel Namespace


GH_Convert Members

[image] [image]

Grasshopper SDK
GH_Convert Members
GH_Convert Class Methods Fields Properties See Also Send Feedback

The GH_Convert type exposes the following members.

Methods

Name | Description
BackSolveExpression | Try and backsolve an expression
ByteArrayToCommonObject<(Of <<'(T>)>>) | Convert an OpenNurbs compliant compressed byte array into a RhinoCommon object.
CombineDateAndTime | Combine a pure date and a pure time.
CommonObjectToByteArray | Convert a RhinoCommon object into a compressed byte-array using safe Rhino 4.0 OpenNurbs serialization.
CreatePureDate | Convert a datetime structure into a pure date, i.e. remove the time portion. As per convention, this leaves 1 tick into the day in question intact.
CreatePureTime(DateTime) | Convert a datetime structure into a pure time, i.e. remove the date portion. As per convention, this means setting the year, month and day to 1.
CreatePureTime(Int32, Int32, Int32) | Create a pure time instance. If the total number of hours, minutes and seconds exceeds a full year then it is not possible to create a pure time and the largest possible pure time will be returned instead.
FileToHash | Create a hash of a file.
FindRhinoObjectByNameAndType | Search the current Rhino document for an object with a given name of a given type.
GetBrepFromDocument | Harvest a brep object from a Rhino document.
GetCurveFromDocument | Harvest a curve object from a Rhino document.
GetMeshFromDocument | Harvest a mesh object from a Rhino document.
GetPointFromDocument | Harvest a point object from a Rhino document.
GetSurfaceFromDocument | Harvest a surface object from a Rhino document.
GetTimeKind(DateTime) | Gets the kind of time implied by a System.DateTime value.
GetTimeKind(DateTime, DateTime) | Gets the kind of time implied by two System.DateTime values.
IsPureDate | Tests whether a DateTime instance represents a pure date (i.e. that the time portion is undefined). Pure dates are a Grasshopper convention, basically a pure date is 1 tick past midnight.
IsPureTime | Tests whether a DateTime instance represents a pure time (i.e. that the date portion is undefined). Pure times are a Grasshopper convention, basically a pure time is 2 ticks past any second.
ObjRefToGeometry | Convert a Rhino Object Reference into Grasshopper IGH_GeometricGoo.
ParseExpression | Attempts to parse an expression.
StringToDate | Convert a string representing a date into an actual date. If a pure date is possible it will be returned. If the input is a pure time this method will fail, you need to use StringToTime instead.
StringToGuid | Create a Guid based on SHA256 hashing of a string.
StringToTime | Convert a string representing a time into an pure time. Allowed separators of hour, minute and second portions are colons, semi-colons, points and commas. Grasshopper itself uses colons when formatting times. A PM or AM symbol is allowed provided it does not border on any alphabetical characters. A time can be prefixed by a "X day[s] + " string which defines the total number of 24-hour periods to include.
ToArc | Convert data into Rhino.Geometry.Arc.
ToArc_Primary | Performs a direct cast from OnArc or GH_Arc. Data is not quaranteed to be duplicated.
ToArc_Secondary | Attempts to convert other data types into an OnArc. Data is not quaranteed to be duplicated.
ToBoolean | Convert data into Booleans.
ToBoolean_Primary | Performs a direct cast from boolean or GH_Boolean.
ToBoolean_Secondary | Performs indirect casts from other data types into booleans.
ToBoundingBox_Primary | Performs a direct cast from OnBoundingBox. Data is not quaranteed to be duplicated.
ToBox_Primary | Performs a direct cast from Box. Data is not quaranteed to be duplicated.
ToBrep | Convert data into Rhino.Geometry.Brep.
ToBrep_Primary | Performs a direct cast from OnBrep or GH_Brep. Data is not quaranteed to be duplicated.
ToBrep_Secondary | Attempts to convert other data types into an OnBrep. Data is not quaranteed to be duplicated.
ToCircle | Convert data into Rhino.Geometry.Circle.
ToCircle_Primary | Performs a direct cast from OnCircle or GH_Circle. Data is not quaranteed to be duplicated.
ToCircle_Secondary | Attempts to convert other data types into an OnCircle. Data is not quaranteed to be duplicated.
ToColor | Convert data into Colors.
ToColor_Primary | Performs a direct cast from Drawing.Color, GH_Color and OnColor.
ToColor_Secondary | Performs indirect casts from other data types into Colors.
ToComplex | Convert data into Complex.
ToComplex_Primary | Performs a direct cast from Complex or GH_ComplexNumber
ToComplex_Secondary | Performs indirect casts from other data types into Complex.
ToCoordinates |
ToCulture | Convert data into Colors.
ToCulture_Primary | Performs a direct cast from System.Globalization.CultureInfo and GH_Culture.
ToCulture_Secondary | Performs indirect casts from other data types into CultureInfo.
ToCurve | Convert data into Rhino.Geometry.Curve.
ToCurve_Primary | Performs a direct cast from OnCurve or GH_Curve. Data is not quaranteed to be duplicated.
ToCurve_Secondary | Attempts to convert other data types into an IOnCurve. Data is not quaranteed to be duplicated.
ToDate | Convert data into Dates.
ToDate_Primary | Performs a direct cast from DateTime or GH_DateTime.
ToDate_Secondary | Performs indirect casts from other data types into DateTime constructs.
ToDouble | Convert data into Doubles.
ToDouble_Primary | Performs a direct cast from Double or GH_Number.
ToDouble_Secondary | Performs indirect casts from other data types into Doubles.
ToGeometricGoo | Converts an object into GeometricGoo. Does not duplicate the data if a lossless conversion is possible.
ToGeometryBase | Attempt to convert an object into a Rhino.Geometry.GeometryBase instance.
ToGHArc | Convert data into GH_Arcs.
ToGHArc_Primary | Converts similar data into a GH_Arc instance. Data is not quaranteed to be duplicated.
ToGHArc_Secondary | Converts similar data into a GH_Arc instance. Data is not quaranteed to be duplicated.
ToGHBoolean | Convert data into GH_Boolean.
ToGHBoolean_Primary | Converts similar data into a GH_Boolean instance. Data is not quaranteed to be duplicated.
ToGHBoolean_Secondary | Converts similar data into a GH_Boolean instance. Data is not quaranteed to be duplicated.
ToGHBox | Convert data into GH_Boxes.
ToGHBox_Primary | Converts similar data into a GH_Box instance. Data is not quaranteed to be duplicated.
ToGHBox_Secondary | Converts similar data into a GH_Box instance. Data is not quaranteed to be duplicated.
ToGHBrep | Convert data into GH_Breps.
ToGHBrep_Primary | Converts similar data into a GH_Brep instance. Data is not quaranteed to be duplicated.
ToGHBrep_Secondary | Converts similar data into a GH_Brep instance. Data is not quaranteed to be duplicated.
ToGHCircle | Convert data into GH_Circles.
ToGHCircle_Primary | Converts similar data into a GH_Circle instance. Data is not quaranteed to be duplicated.
ToGHCircle_Secondary | Converts similar data into a GH_Circle instance. Data is not quaranteed to be duplicated.
ToGHColour | Convert data into GH_Colour.
ToGHColour_Primary | Converts similar data into a GH_Colour instance. Data is not quaranteed to be duplicated.
ToGHColour_Secondary | Converts similar data into a GH_Colour instance. Data is not quaranteed to be duplicated.
ToGHComplexNumber | Convert data into GH_ComplexNumber.
ToGHComplexNumber_Primary | Converts similar data into a GH_ComplexNumber instance. Data is not quaranteed to be duplicated.
ToGHComplexNumber_Secondary | Converts similar data into a GH_ComplexNumber instance. Data is not quaranteed to be duplicated.
ToGHCurve | Convert data into GH_Curves.
ToGHCurve_Primary | Converts similar data into a GH_Curve instance. Data is not quaranteed to be duplicated.
ToGHCurve_Secondary | Converts similar data into a GH_Curve instance. Data is not quaranteed to be duplicated.
ToGHGuid | Convert data into GH_Guid.
ToGHGuid_Primary | Converts similar data into a GH_Guid instance. Data is not quaranteed to be duplicated.
ToGHGuid_Secondary | Converts similar data into a GH_Guid instance. Data is not quaranteed to be duplicated.
ToGHInteger | Convert data into GH_Integer.
ToGHInteger_Primary | Converts similar data into a GH_Integer instance. Data is not quaranteed to be duplicated.
ToGHInteger_Secondary | Converts similar data into a GH_Integer instance. Data is not quaranteed to be duplicated.
ToGHInterval | Convert data into GH_Intervals.
ToGHInterval_Primary | Converts similar data into a GH_Interval instance. Data is not quaranteed to be duplicated.
ToGHInterval_Secondary | Converts similar data into a GH_Interval instance. Data is not quaranteed to be duplicated.
ToGHInterval2D | Convert data into GH_Interval2Ds.
ToGHInterval2D_Primary | Converts similar data into a GH_Interval2D instance. Data is not quaranteed to be duplicated.
ToGHInterval2D_Secondary | Converts similar data into a GH_Interval2D instance. Data is not quaranteed to be duplicated.
ToGHLine | Convert data into GH_Lines.
ToGHLine_Primary | Converts similar data into a GH_Line instance. Data is not quaranteed to be duplicated.
ToGHLine_Secondary | Converts similar data into a GH_Line instance. Data is not quaranteed to be duplicated.
ToGHMatrix | Convert data into ToGHMatrix.
ToGHMatrix_Primary | Converts similar data into a GH_Matrix instance. Data is not quaranteed to be duplicated.
ToGHMatrix_Secondary | Converts similar data into a GH_Matrix instance. Data is not quaranteed to be duplicated.
ToGHMesh | Convert data into GH_Meshs.
ToGHMesh_Primary | Converts similar data into a GH_Mesh instance. Data is not quaranteed to be duplicated.
ToGHMesh_Secondary | Converts similar data into a GH_Mesh instance. Data is not quaranteed to be duplicated.
ToGHMeshFace | Convert data into GH_MeshFaces.
ToGHMeshFace_Primary | Converts similar data into a GH_MeshFace instance. Data is not quaranteed to be duplicated.
ToGHMeshFace_Secondary | Converts similar data into a GH_MeshFace instance. Data is not quaranteed to be duplicated.
ToGHNumber | Convert data into GH_Number.
ToGHNumber_Primary | Converts similar data into a GH_Number instance. Data is not quaranteed to be duplicated.
ToGHNumber_Secondary | Converts similar data into a GH_Number instance. Data is not quaranteed to be duplicated.
ToGHPlane | Convert data into GH_Planes.
ToGHPlane_Primary | Converts similar data into a GH_Plane instance. Data is not quaranteed to be duplicated.
ToGHPlane_Secondary | Converts similar data into a GH_Plane instance. Data is not quaranteed to be duplicated.
ToGHPoint | Convert data into GH_Points.
ToGHPoint_Primary | Converts similar data into a GH_Point instance. Data is not quaranteed to be duplicated.
ToGHPoint_Secondary | Converts similar data into a GH_Point instance. Data is not quaranteed to be duplicated.
ToGHRectangle | Convert data into GH_Rectangles.
ToGHRectangle_Primary | Converts similar data into a GH_Rectangle instance. Data is not quaranteed to be duplicated.
ToGHRectangle_Secondary | Converts similar data into a GH_Rectangle instance. Data is not quaranteed to be duplicated.
ToGHString | Convert data into GH_String.
ToGHString_Primary | Converts similar data into a GH_String instance. Data is not quaranteed to be duplicated.
ToGHString_Secondary | Converts similar data into a GH_String instance. Data is not quaranteed to be duplicated.
ToGHSurface | Convert data into GH_Surfaces.
ToGHSurface_Primary | Converts similar data into a GH_Surface instance. Data is not quaranteed to be duplicated.
ToGHSurface_Secondary | Converts similar data into a GH_Surface instance. Data is not quaranteed to be duplicated.
ToGHTime | Convert data into GH_Time.
ToGHTime_Primary | Converts similar data into a GH_Time instance. Data is not quaranteed to be duplicated.
ToGHTime_Secondary | Converts similar data into a GH_Time instance. Data is not quaranteed to be duplicated.
ToGHVector | Convert data into GH_Vectors.
ToGHVector_Primary | Converts similar data into a GH_Vector instance. Data is not quaranteed to be duplicated.
ToGHVector_Secondary | Converts similar data into a GH_Vector instance. Data is not quaranteed to be duplicated.
ToGoo | Converts an object into Goo. Does not duplicate the data if a lossless conversion is possible.
ToGUID | Convert data into Guids.
ToGUID_Primary | Performs a direct cast from Guid, GH_Guid, String and GH_String.
ToGUID_Secondary | Performs indirect casts from other data types into Guids.
ToInt32 | Convert data into Int32s.
ToInt32_Primary | Performs a direct cast from Int32 or GH_Integer.
ToInt32_Secondary | Performs indirect casts from other data types into Integers.
ToInterval | Convert data into Rhino.Geometry.Interval.
ToInterval_Primary | Performs a direct cast from OnInterval or GH_Interval.
ToInterval_Secondary | Attempts to convert other data types into an Interval. Data is not quaranteed to be duplicated.
ToLine | Convert data into Rhino.Geometry.Line.
ToLine_Primary | Performs a direct cast from OnLine or GH_Line. Data is not quaranteed to be duplicated.
ToLine_Secondary | Attempts to convert other data types into an OnLine. Data is not quaranteed to be duplicated.
ToMatrix | Convert data into Rhino.Geometry.Matrix.
ToMatrix_Primary | Performs a direct cast from Matrix or GH_Matrix.
ToMatrix_Secondary | Attempts to convert other data types into a Matrix. Data is not quaranteed to be duplicated.
ToMesh | Convert data into Rhino.Geometry.Mesh.
ToMesh_Primary | Performs a direct cast from OnMesh or GH_Mesh. Data is not quaranteed to be duplicated.
ToMesh_Secondary | Attempts to convert other data types into an OnMesh. Data is not quaranteed to be duplicated.
ToNextPowerOfTen | Round a number upwards to the nearest power of ten.
ToPlane | Convert data into Rhino.Geometry.Plane.
ToPlane_Primary | Performs a direct cast from OnPlane or GH_Plane. Data is not quaranteed to be duplicated.
ToPlane_Secondary | Attempts to convert other data types into an OnPlane. Data is not quaranteed to be duplicated.
ToPlural | Apply english rules to convert a noun into its plural form. This algorithm is not water-tight as it will not handle any irregular cases.
ToPoint | Convert a floating point GDI point structure to an integer rounded point.
ToPoint3d | Convert data into Rhino.Geometry.Point3d.
ToPoint3d_Primary | Performs a direct cast from On3dPoint or GH_Point. Data is not quaranteed to be duplicated.
ToPoint3d_Secondary | Attempts to convert other data types into an Point. Data is not quaranteed to be duplicated.
ToPointF | Convert a Rhino SDK point structure to a GDI point structure.
ToPrevPowerOfTen | Round a number downwards to the nearest power of ten.
ToRectangle | Convert a floating point GDI rectangle structure to an integer rounded rectangle. Use this method for any and all GUI conversions as the specific rounding scheme used here avoids pixel jitter.
ToRectangle3d | Convert data into Rhino.Geometry.Line.
ToRectangle3d_Primary | Performs a direct cast from Rectangle3d or GH_Rectangle. Data is not quaranteed to be duplicated.
ToRectangle3d_Secondary | Attempts to convert other data types into a Rectangle3d. Data is not quaranteed to be duplicated.
ToRelativePath | Obsolete. Create a relative path from two absolute paths.
ToSHA_Hash(array<Byte>[]()[][]) | Create a SHA hash. The hash algorithm is only guaranteed to yield the same results from within a unique application domain.
ToSHA_Hash(Stream) | Create a SHA hash. The hash algorithm is only guaranteed to yield the same results from within a unique application domain.
ToSize | Convert a floating point GDI size structure to an integer rounded size.
ToString | Convert data into Colors.
ToString_Primary | Performs a direct cast from String and GH_String.
ToString_Secondary | Creates a String representation of an object by calling the ToString() function.
ToSurface | Convert data into Rhino.Geometry.Surface.
ToSurface_Primary | Performs a direct cast from OnSurface or GH_Surface. Data is not quaranteed to be duplicated. If data is of type GH_Surface, then trim curves are ignored.
ToSurface_Secondary | Attempts to convert other data types into an IOnSurface. Data is not quaranteed to be duplicated.
ToUVInterval | Convert data into Grasshopper.Kernel.Types.UVInterval.
ToUVInterval_Primary | Performs a direct cast from UVInterval or GH_Interval2D.
ToUVInterval_Secondary | Attempts to convert other data types into a UVInterval. Data is not quaranteed to be duplicated.
ToVariableName | Extract the implied variable name from a compound string. A string is considered compound if it contains a parenthesis pair with at least one character within the brackets.
ToVariant | Convert an object to a Grasshopper Expression Variant if possible.
ToVector3d | Convert data into Rhino.Geometry.Vector3d.
ToVector3d_Primary | Performs a direct cast from On3dVector or GH_Vector. Data is not quaranteed to be duplicated.
ToVector3d_Secondary | Attempts to convert other data types into a Vector. Data is not quaranteed to be duplicated.

Fields

Name | Description
PureDateTicks | Represents the total number of ticks past midnight that (by Grasshopper convention) identifies a pure date.
PureTimeTicks | Represents the total number of ticks past a whole second that (by Grasshopper convention) identifies a pure time.

Properties

Name | Description
CultureTable | Gets the cached culture table. Do not modify this dictionary unless you know what you are doing.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


GH_Convert Fields

[image] [image]

Grasshopper SDK
GH_Convert Fields
GH_Convert Class See Also Send Feedback

The GH_Convert type exposes the following members.

Fields

Name | Description
PureDateTicks | Represents the total number of ticks past midnight that (by Grasshopper convention) identifies a pure date.
PureTimeTicks | Represents the total number of ticks past a whole second that (by Grasshopper convention) identifies a pure time.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


PureDateTicks Field

[image]

Grasshopper SDK
GH_Convert..::..PureDateTicks Field
GH_Convert Class See Also Send Feedback
Represents the total number of ticks past midnight that (by Grasshopper convention) identifies a pure date.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const long PureDateTicks
Visual Basic
Public Const PureDateTicks As Long

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


PureTimeTicks Field

[image]

Grasshopper SDK
GH_Convert..::..PureTimeTicks Field
GH_Convert Class See Also Send Feedback
Represents the total number of ticks past a whole second that (by Grasshopper convention) identifies a pure time.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const long PureTimeTicks
Visual Basic
Public Const PureTimeTicks As Long

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


GH_Convert Methods

[image] [image]

Grasshopper SDK
GH_Convert Methods
GH_Convert Class See Also Send Feedback

The GH_Convert type exposes the following members.

Methods

Name | Description
BackSolveExpression | Try and backsolve an expression
ByteArrayToCommonObject<(Of <<'(T>)>>) | Convert an OpenNurbs compliant compressed byte array into a RhinoCommon object.
CombineDateAndTime | Combine a pure date and a pure time.
CommonObjectToByteArray | Convert a RhinoCommon object into a compressed byte-array using safe Rhino 4.0 OpenNurbs serialization.
CreatePureDate | Convert a datetime structure into a pure date, i.e. remove the time portion. As per convention, this leaves 1 tick into the day in question intact.
CreatePureTime(DateTime) | Convert a datetime structure into a pure time, i.e. remove the date portion. As per convention, this means setting the year, month and day to 1.
CreatePureTime(Int32, Int32, Int32) | Create a pure time instance. If the total number of hours, minutes and seconds exceeds a full year then it is not possible to create a pure time and the largest possible pure time will be returned instead.
FileToHash | Create a hash of a file.
FindRhinoObjectByNameAndType | Search the current Rhino document for an object with a given name of a given type.
GetBrepFromDocument | Harvest a brep object from a Rhino document.
GetCurveFromDocument | Harvest a curve object from a Rhino document.
GetMeshFromDocument | Harvest a mesh object from a Rhino document.
GetPointFromDocument | Harvest a point object from a Rhino document.
GetSurfaceFromDocument | Harvest a surface object from a Rhino document.
GetTimeKind(DateTime) | Gets the kind of time implied by a System.DateTime value.
GetTimeKind(DateTime, DateTime) | Gets the kind of time implied by two System.DateTime values.
IsPureDate | Tests whether a DateTime instance represents a pure date (i.e. that the time portion is undefined). Pure dates are a Grasshopper convention, basically a pure date is 1 tick past midnight.
IsPureTime | Tests whether a DateTime instance represents a pure time (i.e. that the date portion is undefined). Pure times are a Grasshopper convention, basically a pure time is 2 ticks past any second.
ObjRefToGeometry | Convert a Rhino Object Reference into Grasshopper IGH_GeometricGoo.
ParseExpression | Attempts to parse an expression.
StringToDate | Convert a string representing a date into an actual date. If a pure date is possible it will be returned. If the input is a pure time this method will fail, you need to use StringToTime instead.
StringToGuid | Create a Guid based on SHA256 hashing of a string.
StringToTime | Convert a string representing a time into an pure time. Allowed separators of hour, minute and second portions are colons, semi-colons, points and commas. Grasshopper itself uses colons when formatting times. A PM or AM symbol is allowed provided it does not border on any alphabetical characters. A time can be prefixed by a "X day[s] + " string which defines the total number of 24-hour periods to include.
ToArc | Convert data into Rhino.Geometry.Arc.
ToArc_Primary | Performs a direct cast from OnArc or GH_Arc. Data is not quaranteed to be duplicated.
ToArc_Secondary | Attempts to convert other data types into an OnArc. Data is not quaranteed to be duplicated.
ToBoolean | Convert data into Booleans.
ToBoolean_Primary | Performs a direct cast from boolean or GH_Boolean.
ToBoolean_Secondary | Performs indirect casts from other data types into booleans.
ToBoundingBox_Primary | Performs a direct cast from OnBoundingBox. Data is not quaranteed to be duplicated.
ToBox_Primary | Performs a direct cast from Box. Data is not quaranteed to be duplicated.
ToBrep | Convert data into Rhino.Geometry.Brep.
ToBrep_Primary | Performs a direct cast from OnBrep or GH_Brep. Data is not quaranteed to be duplicated.
ToBrep_Secondary | Attempts to convert other data types into an OnBrep. Data is not quaranteed to be duplicated.
ToCircle | Convert data into Rhino.Geometry.Circle.
ToCircle_Primary | Performs a direct cast from OnCircle or GH_Circle. Data is not quaranteed to be duplicated.
ToCircle_Secondary | Attempts to convert other data types into an OnCircle. Data is not quaranteed to be duplicated.
ToColor | Convert data into Colors.
ToColor_Primary | Performs a direct cast from Drawing.Color, GH_Color and OnColor.
ToColor_Secondary | Performs indirect casts from other data types into Colors.
ToComplex | Convert data into Complex.
ToComplex_Primary | Performs a direct cast from Complex or GH_ComplexNumber
ToComplex_Secondary | Performs indirect casts from other data types into Complex.
ToCoordinates |
ToCulture | Convert data into Colors.
ToCulture_Primary | Performs a direct cast from System.Globalization.CultureInfo and GH_Culture.
ToCulture_Secondary | Performs indirect casts from other data types into CultureInfo.
ToCurve | Convert data into Rhino.Geometry.Curve.
ToCurve_Primary | Performs a direct cast from OnCurve or GH_Curve. Data is not quaranteed to be duplicated.
ToCurve_Secondary | Attempts to convert other data types into an IOnCurve. Data is not quaranteed to be duplicated.
ToDate | Convert data into Dates.
ToDate_Primary | Performs a direct cast from DateTime or GH_DateTime.
ToDate_Secondary | Performs indirect casts from other data types into DateTime constructs.
ToDouble | Convert data into Doubles.
ToDouble_Primary | Performs a direct cast from Double or GH_Number.
ToDouble_Secondary | Performs indirect casts from other data types into Doubles.
ToGeometricGoo | Converts an object into GeometricGoo. Does not duplicate the data if a lossless conversion is possible.
ToGeometryBase | Attempt to convert an object into a Rhino.Geometry.GeometryBase instance.
ToGHArc | Convert data into GH_Arcs.
ToGHArc_Primary | Converts similar data into a GH_Arc instance. Data is not quaranteed to be duplicated.
ToGHArc_Secondary | Converts similar data into a GH_Arc instance. Data is not quaranteed to be duplicated.
ToGHBoolean | Convert data into GH_Boolean.
ToGHBoolean_Primary | Converts similar data into a GH_Boolean instance. Data is not quaranteed to be duplicated.
ToGHBoolean_Secondary | Converts similar data into a GH_Boolean instance. Data is not quaranteed to be duplicated.
ToGHBox | Convert data into GH_Boxes.
ToGHBox_Primary | Converts similar data into a GH_Box instance. Data is not quaranteed to be duplicated.
ToGHBox_Secondary | Converts similar data into a GH_Box instance. Data is not quaranteed to be duplicated.
ToGHBrep | Convert data into GH_Breps.
ToGHBrep_Primary | Converts similar data into a GH_Brep instance. Data is not quaranteed to be duplicated.
ToGHBrep_Secondary | Converts similar data into a GH_Brep instance. Data is not quaranteed to be duplicated.
ToGHCircle | Convert data into GH_Circles.
ToGHCircle_Primary | Converts similar data into a GH_Circle instance. Data is not quaranteed to be duplicated.
ToGHCircle_Secondary | Converts similar data into a GH_Circle instance. Data is not quaranteed to be duplicated.
ToGHColour | Convert data into GH_Colour.
ToGHColour_Primary | Converts similar data into a GH_Colour instance. Data is not quaranteed to be duplicated.
ToGHColour_Secondary | Converts similar data into a GH_Colour instance. Data is not quaranteed to be duplicated.
ToGHComplexNumber | Convert data into GH_ComplexNumber.
ToGHComplexNumber_Primary | Converts similar data into a GH_ComplexNumber instance. Data is not quaranteed to be duplicated.
ToGHComplexNumber_Secondary | Converts similar data into a GH_ComplexNumber instance. Data is not quaranteed to be duplicated.
ToGHCurve | Convert data into GH_Curves.
ToGHCurve_Primary | Converts similar data into a GH_Curve instance. Data is not quaranteed to be duplicated.
ToGHCurve_Secondary | Converts similar data into a GH_Curve instance. Data is not quaranteed to be duplicated.
ToGHGuid | Convert data into GH_Guid.
ToGHGuid_Primary | Converts similar data into a GH_Guid instance. Data is not quaranteed to be duplicated.
ToGHGuid_Secondary | Converts similar data into a GH_Guid instance. Data is not quaranteed to be duplicated.
ToGHInteger | Convert data into GH_Integer.
ToGHInteger_Primary | Converts similar data into a GH_Integer instance. Data is not quaranteed to be duplicated.
ToGHInteger_Secondary | Converts similar data into a GH_Integer instance. Data is not quaranteed to be duplicated.
ToGHInterval | Convert data into GH_Intervals.
ToGHInterval_Primary | Converts similar data into a GH_Interval instance. Data is not quaranteed to be duplicated.
ToGHInterval_Secondary | Converts similar data into a GH_Interval instance. Data is not quaranteed to be duplicated.
ToGHInterval2D | Convert data into GH_Interval2Ds.
ToGHInterval2D_Primary | Converts similar data into a GH_Interval2D instance. Data is not quaranteed to be duplicated.
ToGHInterval2D_Secondary | Converts similar data into a GH_Interval2D instance. Data is not quaranteed to be duplicated.
ToGHLine | Convert data into GH_Lines.
ToGHLine_Primary | Converts similar data into a GH_Line instance. Data is not quaranteed to be duplicated.
ToGHLine_Secondary | Converts similar data into a GH_Line instance. Data is not quaranteed to be duplicated.
ToGHMatrix | Convert data into ToGHMatrix.
ToGHMatrix_Primary | Converts similar data into a GH_Matrix instance. Data is not quaranteed to be duplicated.
ToGHMatrix_Secondary | Converts similar data into a GH_Matrix instance. Data is not quaranteed to be duplicated.
ToGHMesh | Convert data into GH_Meshs.
ToGHMesh_Primary | Converts similar data into a GH_Mesh instance. Data is not quaranteed to be duplicated.
ToGHMesh_Secondary | Converts similar data into a GH_Mesh instance. Data is not quaranteed to be duplicated.
ToGHMeshFace | Convert data into GH_MeshFaces.
ToGHMeshFace_Primary | Converts similar data into a GH_MeshFace instance. Data is not quaranteed to be duplicated.
ToGHMeshFace_Secondary | Converts similar data into a GH_MeshFace instance. Data is not quaranteed to be duplicated.
ToGHNumber | Convert data into GH_Number.
ToGHNumber_Primary | Converts similar data into a GH_Number instance. Data is not quaranteed to be duplicated.
ToGHNumber_Secondary | Converts similar data into a GH_Number instance. Data is not quaranteed to be duplicated.
ToGHPlane | Convert data into GH_Planes.
ToGHPlane_Primary | Converts similar data into a GH_Plane instance. Data is not quaranteed to be duplicated.
ToGHPlane_Secondary | Converts similar data into a GH_Plane instance. Data is not quaranteed to be duplicated.
ToGHPoint | Convert data into GH_Points.
ToGHPoint_Primary | Converts similar data into a GH_Point instance. Data is not quaranteed to be duplicated.
ToGHPoint_Secondary | Converts similar data into a GH_Point instance. Data is not quaranteed to be duplicated.
ToGHRectangle | Convert data into GH_Rectangles.
ToGHRectangle_Primary | Converts similar data into a GH_Rectangle instance. Data is not quaranteed to be duplicated.
ToGHRectangle_Secondary | Converts similar data into a GH_Rectangle instance. Data is not quaranteed to be duplicated.
ToGHString | Convert data into GH_String.
ToGHString_Primary | Converts similar data into a GH_String instance. Data is not quaranteed to be duplicated.
ToGHString_Secondary | Converts similar data into a GH_String instance. Data is not quaranteed to be duplicated.
ToGHSurface | Convert data into GH_Surfaces.
ToGHSurface_Primary | Converts similar data into a GH_Surface instance. Data is not quaranteed to be duplicated.
ToGHSurface_Secondary | Converts similar data into a GH_Surface instance. Data is not quaranteed to be duplicated.
ToGHTime | Convert data into GH_Time.
ToGHTime_Primary | Converts similar data into a GH_Time instance. Data is not quaranteed to be duplicated.
ToGHTime_Secondary | Converts similar data into a GH_Time instance. Data is not quaranteed to be duplicated.
ToGHVector | Convert data into GH_Vectors.
ToGHVector_Primary | Converts similar data into a GH_Vector instance. Data is not quaranteed to be duplicated.
ToGHVector_Secondary | Converts similar data into a GH_Vector instance. Data is not quaranteed to be duplicated.
ToGoo | Converts an object into Goo. Does not duplicate the data if a lossless conversion is possible.
ToGUID | Convert data into Guids.
ToGUID_Primary | Performs a direct cast from Guid, GH_Guid, String and GH_String.
ToGUID_Secondary | Performs indirect casts from other data types into Guids.
ToInt32 | Convert data into Int32s.
ToInt32_Primary | Performs a direct cast from Int32 or GH_Integer.
ToInt32_Secondary | Performs indirect casts from other data types into Integers.
ToInterval | Convert data into Rhino.Geometry.Interval.
ToInterval_Primary | Performs a direct cast from OnInterval or GH_Interval.
ToInterval_Secondary | Attempts to convert other data types into an Interval. Data is not quaranteed to be duplicated.
ToLine | Convert data into Rhino.Geometry.Line.
ToLine_Primary | Performs a direct cast from OnLine or GH_Line. Data is not quaranteed to be duplicated.
ToLine_Secondary | Attempts to convert other data types into an OnLine. Data is not quaranteed to be duplicated.
ToMatrix | Convert data into Rhino.Geometry.Matrix.
ToMatrix_Primary | Performs a direct cast from Matrix or GH_Matrix.
ToMatrix_Secondary | Attempts to convert other data types into a Matrix. Data is not quaranteed to be duplicated.
ToMesh | Convert data into Rhino.Geometry.Mesh.
ToMesh_Primary | Performs a direct cast from OnMesh or GH_Mesh. Data is not quaranteed to be duplicated.
ToMesh_Secondary | Attempts to convert other data types into an OnMesh. Data is not quaranteed to be duplicated.
ToNextPowerOfTen | Round a number upwards to the nearest power of ten.
ToPlane | Convert data into Rhino.Geometry.Plane.
ToPlane_Primary | Performs a direct cast from OnPlane or GH_Plane. Data is not quaranteed to be duplicated.
ToPlane_Secondary | Attempts to convert other data types into an OnPlane. Data is not quaranteed to be duplicated.
ToPlural | Apply english rules to convert a noun into its plural form. This algorithm is not water-tight as it will not handle any irregular cases.
ToPoint | Convert a floating point GDI point structure to an integer rounded point.
ToPoint3d | Convert data into Rhino.Geometry.Point3d.
ToPoint3d_Primary | Performs a direct cast from On3dPoint or GH_Point. Data is not quaranteed to be duplicated.
ToPoint3d_Secondary | Attempts to convert other data types into an Point. Data is not quaranteed to be duplicated.
ToPointF | Convert a Rhino SDK point structure to a GDI point structure.
ToPrevPowerOfTen | Round a number downwards to the nearest power of ten.
ToRectangle | Convert a floating point GDI rectangle structure to an integer rounded rectangle. Use this method for any and all GUI conversions as the specific rounding scheme used here avoids pixel jitter.
ToRectangle3d | Convert data into Rhino.Geometry.Line.
ToRectangle3d_Primary | Performs a direct cast from Rectangle3d or GH_Rectangle. Data is not quaranteed to be duplicated.
ToRectangle3d_Secondary | Attempts to convert other data types into a Rectangle3d. Data is not quaranteed to be duplicated.
ToRelativePath | Obsolete. Create a relative path from two absolute paths.
ToSHA_Hash(array<Byte>[]()[][]) | Create a SHA hash. The hash algorithm is only guaranteed to yield the same results from within a unique application domain.
ToSHA_Hash(Stream) | Create a SHA hash. The hash algorithm is only guaranteed to yield the same results from within a unique application domain.
ToSize | Convert a floating point GDI size structure to an integer rounded size.
ToString | Convert data into Colors.
ToString_Primary | Performs a direct cast from String and GH_String.
ToString_Secondary | Creates a String representation of an object by calling the ToString() function.
ToSurface | Convert data into Rhino.Geometry.Surface.
ToSurface_Primary | Performs a direct cast from OnSurface or GH_Surface. Data is not quaranteed to be duplicated. If data is of type GH_Surface, then trim curves are ignored.
ToSurface_Secondary | Attempts to convert other data types into an IOnSurface. Data is not quaranteed to be duplicated.
ToUVInterval | Convert data into Grasshopper.Kernel.Types.UVInterval.
ToUVInterval_Primary | Performs a direct cast from UVInterval or GH_Interval2D.
ToUVInterval_Secondary | Attempts to convert other data types into a UVInterval. Data is not quaranteed to be duplicated.
ToVariableName | Extract the implied variable name from a compound string. A string is considered compound if it contains a parenthesis pair with at least one character within the brackets.
ToVariant | Convert an object to a Grasshopper Expression Variant if possible.
ToVector3d | Convert data into Rhino.Geometry.Vector3d.
ToVector3d_Primary | Performs a direct cast from On3dVector or GH_Vector. Data is not quaranteed to be duplicated.
ToVector3d_Secondary | Attempts to convert other data types into a Vector. Data is not quaranteed to be duplicated.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


BackSolveExpression Method

[image]

Grasshopper SDK
GH_Convert..::..BackSolveExpression Method
GH_Convert Class See Also Send Feedback
Try and backsolve an expression

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool BackSolveExpression(
    string exp,
    string variable,
    double target,
    double minimum,
    double maximum,
    int steps,
    out double t,
    out double v
)
Visual Basic
Public Shared Function BackSolveExpression ( _
    exp As String, _
    variable As String, _
    target As Double, _
    minimum As Double, _
    maximum As Double, _
    steps As Integer, _
    <OutAttribute> ByRef t As Double, _
    <OutAttribute> ByRef v As Double _
) As Boolean

Parameters

exp
Type: System..::..String
Expression to back solve.
variable
Type: System..::..String
Name of input variable.
target
Type: System..::..Double
Result to look for.
minimum
Type: System..::..Double
Lowest input to try.
maximum
Type: System..::..Double
Highest input to try.
steps
Type: System..::..Int32
Number of steps per iteration.
t
Type: System..::..Double %
Value for variable that closest approximates the target value.
v
Type: System..::..Double %
Value of expression for the best approximation.

Return Value

True on success, false on failure..

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ByteArrayToCommonObject(T) Method

[image]

Grasshopper SDK
GH_Convert..::..ByteArrayToCommonObject<(Of <(<'T>)>)> Method
GH_Convert Class See Also Send Feedback
Convert an OpenNurbs compliant compressed byte array into a RhinoCommon object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static T ByteArrayToCommonObject<T>(
    byte[] data
)
where T : CommonObject
Visual Basic
Public Shared Function ByteArrayToCommonObject(Of T As CommonObject) ( _
    data As Byte() _
) As T

Parameters

data
Type: array< System..::..Byte >[]()[][]
Byte array to de-serialize.

Type Parameters

T

Return Value

A RhinoCommon object instance or null on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


CombineDateAndTime Method

[image]

Grasshopper SDK
GH_Convert..::..CombineDateAndTime Method
GH_Convert Class See Also Send Feedback
Combine a pure date and a pure time.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static DateTime CombineDateAndTime(
    DateTime date,
    DateTime time
)
Visual Basic
Public Shared Function CombineDateAndTime ( _
    date As DateTime, _
    time As DateTime _
) As DateTime

Parameters

date
Type: System..::..DateTime
Must be a pure date instance.
time
Type: System..::..DateTime
Must be a pute time instance.

Return Value

A combined date and time.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


CommonObjectToByteArray Method

[image]

Grasshopper SDK
GH_Convert..::..CommonObjectToByteArray Method
GH_Convert Class See Also Send Feedback
Convert a RhinoCommon object into a compressed byte-array using safe Rhino 4.0 OpenNurbs serialization.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static byte[] CommonObjectToByteArray(
    CommonObject data
)
Visual Basic
Public Shared Function CommonObjectToByteArray ( _
    data As CommonObject _
) As Byte()

Parameters

data
Type: CommonObject
Object to serialize.

Return Value

A byte array representing the object or null on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


CreatePureDate Method

[image]

Grasshopper SDK
GH_Convert..::..CreatePureDate Method
GH_Convert Class See Also Send Feedback
Convert a datetime structure into a pure date, i.e. remove the time portion. As per convention, this leaves 1 tick into the day in question intact.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static DateTime CreatePureDate(
    DateTime date
)
Visual Basic
Public Shared Function CreatePureDate ( _
    date As DateTime _
) As DateTime

Parameters

date
Type: System..::..DateTime

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


CreatePureTime Method

[image] [image]

Grasshopper SDK
GH_Convert..::..CreatePureTime Method
GH_Convert Class See Also Send Feedback

Overload List

Name | Description
CreatePureTime(DateTime) | Convert a datetime structure into a pure time, i.e. remove the date portion. As per convention, this means setting the year, month and day to 1.
CreatePureTime(Int32, Int32, Int32) | Create a pure time instance. If the total number of hours, minutes and seconds exceeds a full year then it is not possible to create a pure time and the largest possible pure time will be returned instead.

See Also

GH_Convert Class
GH_Convert Members
Grasshopper.Kernel Namespace


CreatePureTime Method (DateTime)

[image]

Grasshopper SDK
GH_Convert..::..CreatePureTime Method (DateTime)
GH_Convert Class See Also Send Feedback
Convert a datetime structure into a pure time, i.e. remove the date portion. As per convention, this means setting the year, month and day to 1.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static DateTime CreatePureTime(
    DateTime date
)
Visual Basic
Public Shared Function CreatePureTime ( _
    date As DateTime _
) As DateTime

Parameters

date
Type: System..::..DateTime

See Also

GH_Convert Class
CreatePureTime Overload
Grasshopper.Kernel Namespace


CreatePureTime Method (Int32, Int32, Int32)

[image]

Grasshopper SDK
GH_Convert..::..CreatePureTime Method (Int32, Int32, Int32)
GH_Convert Class See Also Send Feedback
Create a pure time instance. If the total number of hours, minutes and seconds exceeds a full year then it is not possible to create a pure time and the largest possible pure time will be returned instead.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static DateTime CreatePureTime(
    int hours,
    int minutes,
    int seconds
)
Visual Basic
Public Shared Function CreatePureTime ( _
    hours As Integer, _
    minutes As Integer, _
    seconds As Integer _
) As DateTime

Parameters

hours
Type: System..::..Int32
minutes
Type: System..::..Int32
seconds
Type: System..::..Int32

See Also

GH_Convert Class
CreatePureTime Overload
Grasshopper.Kernel Namespace


FileToHash Method

[image]

Grasshopper SDK
GH_Convert..::..FileToHash Method
GH_Convert Class See Also Send Feedback
Create a hash of a file.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid FileToHash(
    string path
)
Visual Basic
Public Shared Function FileToHash ( _
    path As String _
) As Guid

Parameters

path
Type: System..::..String
File to hash.

Return Value

A hash of the file contents. File name and attributes are not taken into consideration.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


FindRhinoObjectByNameAndType Method

[image]

Grasshopper SDK
GH_Convert..::..FindRhinoObjectByNameAndType Method
GH_Convert Class See Also Send Feedback
Search the current Rhino document for an object with a given name of a given type.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static RhinoObject FindRhinoObjectByNameAndType(
    string name,
    ObjectType type
)
Visual Basic
Public Shared Function FindRhinoObjectByNameAndType ( _
    name As String, _
    type As ObjectType _
) As RhinoObject

Parameters

name
Type: System..::..String
Name of object.
type
Type: ObjectType
Geometry type of object.

Return Value

An object that matches the name + type filter or null if no object could be found.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


GetBrepFromDocument Method

[image]

Grasshopper SDK
GH_Convert..::..GetBrepFromDocument Method
GH_Convert Class See Also Send Feedback
Harvest a brep object from a Rhino document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool GetBrepFromDocument(
    RhinoDoc doc,
    Guid id,
    out Brep brp
)
Visual Basic
Public Shared Function GetBrepFromDocument ( _
    doc As RhinoDoc, _
    id As Guid, _
    <OutAttribute> ByRef brp As Brep _
) As Boolean

Parameters

doc
Type: RhinoDoc
Document to search.
id
Type: System..::..Guid
ID of brep object.
brp
Type: Brep%
Brep result.

Return Value

True on success, false on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


GetCurveFromDocument Method

[image]

Grasshopper SDK
GH_Convert..::..GetCurveFromDocument Method
GH_Convert Class See Also Send Feedback
Harvest a curve object from a Rhino document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool GetCurveFromDocument(
    RhinoDoc doc,
    Guid id,
    out Curve crv
)
Visual Basic
Public Shared Function GetCurveFromDocument ( _
    doc As RhinoDoc, _
    id As Guid, _
    <OutAttribute> ByRef crv As Curve _
) As Boolean

Parameters

doc
Type: RhinoDoc
Document to search.
id
Type: System..::..Guid
ID of curve object.
crv
Type: Curve%
Curve result.

Return Value

True on success, false on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


GetMeshFromDocument Method

[image]

Grasshopper SDK
GH_Convert..::..GetMeshFromDocument Method
GH_Convert Class See Also Send Feedback
Harvest a mesh object from a Rhino document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool GetMeshFromDocument(
    RhinoDoc doc,
    Guid id,
    out Mesh msh
)
Visual Basic
Public Shared Function GetMeshFromDocument ( _
    doc As RhinoDoc, _
    id As Guid, _
    <OutAttribute> ByRef msh As Mesh _
) As Boolean

Parameters

doc
Type: RhinoDoc
Document to search.
id
Type: System..::..Guid
ID of mesh object.
msh
Type: Mesh%
Mesh result.

Return Value

True on success, false on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


GetPointFromDocument Method

[image]

Grasshopper SDK
GH_Convert..::..GetPointFromDocument Method
GH_Convert Class See Also Send Feedback
Harvest a point object from a Rhino document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool GetPointFromDocument(
    RhinoDoc doc,
    Guid id,
    out Point3d pt
)
Visual Basic
Public Shared Function GetPointFromDocument ( _
    doc As RhinoDoc, _
    id As Guid, _
    <OutAttribute> ByRef pt As Point3d _
) As Boolean

Parameters

doc
Type: RhinoDoc
Document to search.
id
Type: System..::..Guid
ID of point object.
pt
Type: Point3d%
Point result.

Return Value

True on success, false on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


GetSurfaceFromDocument Method

[image]

Grasshopper SDK
GH_Convert..::..GetSurfaceFromDocument Method
GH_Convert Class See Also Send Feedback
Harvest a surface object from a Rhino document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool GetSurfaceFromDocument(
    RhinoDoc doc,
    Guid id,
    out Surface srf
)
Visual Basic
Public Shared Function GetSurfaceFromDocument ( _
    doc As RhinoDoc, _
    id As Guid, _
    <OutAttribute> ByRef srf As Surface _
) As Boolean

Parameters

doc
Type: RhinoDoc
Document to search.
id
Type: System..::..Guid
ID of surface object.
srf
Type: Surface%
Surface result.

Return Value

True on success, false on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


GetTimeKind Method

[image] [image]

Grasshopper SDK
GH_Convert..::..GetTimeKind Method
GH_Convert Class See Also Send Feedback

Overload List

Name | Description
GetTimeKind(DateTime) | Gets the kind of time implied by a System.DateTime value.
GetTimeKind(DateTime, DateTime) | Gets the kind of time implied by two System.DateTime values.

See Also

GH_Convert Class
GH_Convert Members
Grasshopper.Kernel Namespace


GetTimeKind Method (DateTime)

[image]

Grasshopper SDK
GH_Convert..::..GetTimeKind Method (DateTime)
GH_Convert Class See Also Send Feedback
Gets the kind of time implied by a System.DateTime value.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_TimeKind GetTimeKind(
    DateTime time
)
Visual Basic
Public Shared Function GetTimeKind ( _
    time As DateTime _
) As GH_TimeKind

Parameters

time
Type: System..::..DateTime
Time to evaluate.

Return Value

GH_TimeKind.PureTime, GH_TimeKind.PureDate or GH_TimeKind.DateAndTime.

See Also

GH_Convert Class
GetTimeKind Overload
Grasshopper.Kernel Namespace


GetTimeKind Method (DateTime, DateTime)

[image]

Grasshopper SDK
GH_Convert..::..GetTimeKind Method (DateTime, DateTime)
GH_Convert Class See Also Send Feedback
Gets the kind of time implied by two System.DateTime values.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_TimeKind GetTimeKind(
    DateTime A,
    DateTime B
)
Visual Basic
Public Shared Function GetTimeKind ( _
    A As DateTime, _
    B As DateTime _
) As GH_TimeKind

Parameters

A
Type: System..::..DateTime
First time to evaluate.
B
Type: System..::..DateTime
Second time to evaluate.

Return Value

GH_TimeKind.PureTime, GH_TimeKind.PureDate or GH_TimeKind.DateAndTime if both kinds are the same. GH_TimeKind.DateAndTime is one is a pure date and the other a DateAndTime value. GH_TimeKind.Mixed is one is a pure time and the other one is not.

See Also

GH_Convert Class
GetTimeKind Overload
Grasshopper.Kernel Namespace


IsPureDate Method

[image]

Grasshopper SDK
GH_Convert..::..IsPureDate Method
GH_Convert Class See Also Send Feedback
Tests whether a DateTime instance represents a pure date (i.e. that the time portion is undefined). Pure dates are a Grasshopper convention, basically a pure date is 1 tick past midnight.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool IsPureDate(
    DateTime potentialDate
)
Visual Basic
Public Shared Function IsPureDate ( _
    potentialDate As DateTime _
) As Boolean

Parameters

potentialDate
Type: System..::..DateTime
Date to test.

Return Value

True if the date is considered pure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


IsPureTime Method

[image]

Grasshopper SDK
GH_Convert..::..IsPureTime Method
GH_Convert Class See Also Send Feedback
Tests whether a DateTime instance represents a pure time (i.e. that the date portion is undefined). Pure times are a Grasshopper convention, basically a pure time is 2 ticks past any second.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool IsPureTime(
    DateTime potentialTime
)
Visual Basic
Public Shared Function IsPureTime ( _
    potentialTime As DateTime _
) As Boolean

Parameters

potentialTime
Type: System..::..DateTime
Date to test.

Return Value

True if the time is considered undefined.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ObjRefToGeometry Method

[image]

Grasshopper SDK
GH_Convert..::..ObjRefToGeometry Method
GH_Convert Class See Also Send Feedback
Convert a Rhino Object Reference into Grasshopper IGH_GeometricGoo.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static IGH_GeometricGoo ObjRefToGeometry(
    ObjRef in
)
Visual Basic
Public Shared Function ObjRefToGeometry ( _
    in As ObjRef _
) As IGH_GeometricGoo

Parameters

in
Type: ObjRef
Object reference to convert.

Return Value

An instance that implements IGH_GeometricGoo on success or false on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ParseExpression Method

[image]

Grasshopper SDK
GH_Convert..::..ParseExpression Method
GH_Convert Class See Also Send Feedback
Attempts to parse an expression.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Variant ParseExpression(
    string exp,
    bool recursive
)
Visual Basic
Public Shared Function ParseExpression ( _
    exp As String, _
    recursive As Boolean _
) As GH_Variant

Parameters

exp
Type: System..::..String
Expression to parse.
recursive
Type: System..::..Boolean
If True, and the result of the expression is a String, the result is parsed again until the result is no longer a String or until the expression fails.

Return Value

The result of the (recursive) expression.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


StringToDate Method

[image]

Grasshopper SDK
GH_Convert..::..StringToDate Method
GH_Convert Class See Also Send Feedback
Convert a string representing a date into an actual date. If a pure date is possible it will be returned. If the input is a pure time this method will fail, you need to use StringToTime instead.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool StringToDate(
    string text,
    ref DateTime date
)
Visual Basic
Public Shared Function StringToDate ( _
    text As String, _
    ByRef date As DateTime _
) As Boolean

Parameters

text
Type: System..::..String
String to parse.
date
Type: System..::..DateTime %
If the string could be parsed, the pure date will be returned here.

Return Value

True if string was successfully parsed, false if not.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


StringToGuid Method

[image]

Grasshopper SDK
GH_Convert..::..StringToGuid Method
GH_Convert Class See Also Send Feedback
Create a Guid based on SHA256 hashing of a string.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid StringToGuid(
    string text
)
Visual Basic
Public Shared Function StringToGuid ( _
    text As String _
) As Guid

Parameters

text
Type: System..::..String
Text to hash.

Return Value

A guid representing the string.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


StringToTime Method

[image]

Grasshopper SDK
GH_Convert..::..StringToTime Method
GH_Convert Class See Also Send Feedback
Convert a string representing a time into an pure time. Allowed separators of hour, minute and second portions are colons, semi-colons, points and commas. Grasshopper itself uses colons when formatting times. A PM or AM symbol is allowed provided it does not border on any alphabetical characters. A time can be prefixed by a "X day[s] + " string which defines the total number of 24-hour periods to include.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool StringToTime(
    string text,
    ref DateTime time
)
Visual Basic
Public Shared Function StringToTime ( _
    text As String, _
    ByRef time As DateTime _
) As Boolean

Parameters

text
Type: System..::..String
String to parse.
time
Type: System..::..DateTime %
If the string could be parsed, the pure time will be returned here.

Return Value

True if string was successfully parsed, false if not.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToArc Method

[image]

Grasshopper SDK
GH_Convert..::..ToArc Method
GH_Convert Class See Also Send Feedback
Convert data into Rhino.Geometry.Arc.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToArc(
    Object data,
    ref Arc rc,
    GH_Conversion conversion_level
)
Visual Basic
Public Shared Function ToArc ( _
    data As Object, _
    ByRef rc As Arc, _
    conversion_level As GH_Conversion _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Arc%
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToArc_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToArc_Primary Method
GH_Convert Class See Also Send Feedback
Performs a direct cast from OnArc or GH_Arc. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToArc_Primary(
    Object data,
    ref Arc rc
)
Visual Basic
Public Shared Function ToArc_Primary ( _
    data As Object, _
    ByRef rc As Arc _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Arc%

Return Value

An OnArc instance if successful, or Nothing on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToArc_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToArc_Secondary Method
GH_Convert Class See Also Send Feedback
Attempts to convert other data types into an OnArc. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToArc_Secondary(
    Object data,
    ref Arc rc
)
Visual Basic
Public Shared Function ToArc_Secondary ( _
    data As Object, _
    ByRef rc As Arc _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Arc%

Return Value

An OnArc instance if successful, or Nothing on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToBoolean Method

[image]

Grasshopper SDK
GH_Convert..::..ToBoolean Method
GH_Convert Class See Also Send Feedback
Convert data into Booleans.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToBoolean(
    Object data,
    out bool destination,
    GH_Conversion conversion_level
)
Visual Basic
Public Shared Function ToBoolean ( _
    data As Object, _
    <OutAttribute> ByRef destination As Boolean, _
    conversion_level As GH_Conversion _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
destination
Type: System..::..Boolean %
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToBoolean_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToBoolean_Primary Method
GH_Convert Class See Also Send Feedback
Performs a direct cast from boolean or GH_Boolean.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToBoolean_Primary(
    Object data,
    ref bool destination
)
Visual Basic
Public Shared Function ToBoolean_Primary ( _
    data As Object, _
    ByRef destination As Boolean _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert.
destination
Type: System..::..Boolean %
Target for value assignment.

Return Value

True on success, false on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToBoolean_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToBoolean_Secondary Method
GH_Convert Class See Also Send Feedback
Performs indirect casts from other data types into booleans.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToBoolean_Secondary(
    Object data,
    ref bool destination
)
Visual Basic
Public Shared Function ToBoolean_Secondary ( _
    data As Object, _
    ByRef destination As Boolean _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert.
destination
Type: System..::..Boolean %
Target for value assignment.

Return Value

True on success, false on failure.

Remarks

This converted relies on ToInt32_Secondary()

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToBoundingBox_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToBoundingBox_Primary Method
GH_Convert Class See Also Send Feedback
Performs a direct cast from OnBoundingBox. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToBoundingBox_Primary(
    Object data,
    ref BoundingBox rc
)
Visual Basic
Public Shared Function ToBoundingBox_Primary ( _
    data As Object, _
    ByRef rc As BoundingBox _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: BoundingBox%

Return Value

An OnBoundingBox instance if successful, or Nothing on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToBox_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToBox_Primary Method
GH_Convert Class See Also Send Feedback
Performs a direct cast from Box. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToBox_Primary(
    Object data,
    ref Box rc
)
Visual Basic
Public Shared Function ToBox_Primary ( _
    data As Object, _
    ByRef rc As Box _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Box%

Return Value

An OnBoundingBox instance if successful, or Nothing on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToBrep Method

[image]

Grasshopper SDK
GH_Convert..::..ToBrep Method
GH_Convert Class See Also Send Feedback
Convert data into Rhino.Geometry.Brep.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToBrep(
    Object data,
    ref Brep rc,
    GH_Conversion conversion_level
)
Visual Basic
Public Shared Function ToBrep ( _
    data As Object, _
    ByRef rc As Brep, _
    conversion_level As GH_Conversion _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Brep%
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToBrep_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToBrep_Primary Method
GH_Convert Class See Also Send Feedback
Performs a direct cast from OnBrep or GH_Brep. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToBrep_Primary(
    Object data,
    ref Brep rc
)
Visual Basic
Public Shared Function ToBrep_Primary ( _
    data As Object, _
    ByRef rc As Brep _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Brep%

Return Value

An OnBrep instance if successful, or Nothing on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToBrep_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToBrep_Secondary Method
GH_Convert Class See Also Send Feedback
Attempts to convert other data types into an OnBrep. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToBrep_Secondary(
    Object data,
    ref Brep rc
)
Visual Basic
Public Shared Function ToBrep_Secondary ( _
    data As Object, _
    ByRef rc As Brep _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Brep%

Return Value

An OnBrep instance if successful, or Nothing on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToCircle Method

[image]

Grasshopper SDK
GH_Convert..::..ToCircle Method
GH_Convert Class See Also Send Feedback
Convert data into Rhino.Geometry.Circle.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToCircle(
    Object data,
    ref Circle rc,
    GH_Conversion conversion_level
)
Visual Basic
Public Shared Function ToCircle ( _
    data As Object, _
    ByRef rc As Circle, _
    conversion_level As GH_Conversion _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Circle%
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToCircle_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToCircle_Primary Method
GH_Convert Class See Also Send Feedback
Performs a direct cast from OnCircle or GH_Circle. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToCircle_Primary(
    Object data,
    ref Circle rc
)
Visual Basic
Public Shared Function ToCircle_Primary ( _
    data As Object, _
    ByRef rc As Circle _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Circle%

Return Value

An OnCircle instance if successful, or Nothing on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToCircle_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToCircle_Secondary Method
GH_Convert Class See Also Send Feedback
Attempts to convert other data types into an OnCircle. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToCircle_Secondary(
    Object data,
    ref Circle rc
)
Visual Basic
Public Shared Function ToCircle_Secondary ( _
    data As Object, _
    ByRef rc As Circle _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Circle%

Return Value

An OnCircle instance if successful, or Nothing on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToColor Method

[image]

Grasshopper SDK
GH_Convert..::..ToColor Method
GH_Convert Class See Also Send Feedback
Convert data into Colors.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToColor(
    Object data,
    out Color destination,
    GH_Conversion conversion_level
)
Visual Basic
Public Shared Function ToColor ( _
    data As Object, _
    <OutAttribute> ByRef destination As Color, _
    conversion_level As GH_Conversion _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
destination
Type: System.Drawing..::..Color %
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToColor_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToColor_Primary Method
GH_Convert Class See Also Send Feedback
Performs a direct cast from Drawing.Color, GH_Color and OnColor.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToColor_Primary(
    Object data,
    ref Color destination
)
Visual Basic
Public Shared Function ToColor_Primary ( _
    data As Object, _
    ByRef destination As Color _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert.
destination
Type: System.Drawing..::..Color %
Target for value assignment.

Return Value

True on success, false on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToColor_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToColor_Secondary Method
GH_Convert Class See Also Send Feedback
Performs indirect casts from other data types into Colors.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToColor_Secondary(
    Object data,
    ref Color destination
)
Visual Basic
Public Shared Function ToColor_Secondary ( _
    data As Object, _
    ByRef destination As Color _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert.
destination
Type: System.Drawing..::..Color %
Target for value assignment.

Return Value

True on success, false on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToComplex Method

[image]

Grasshopper SDK
GH_Convert..::..ToComplex Method
GH_Convert Class See Also Send Feedback
Convert data into Complex.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToComplex(
    Object data,
    out Complex destination,
    GH_Conversion conversion_level
)
Visual Basic
Public Shared Function ToComplex ( _
    data As Object, _
    <OutAttribute> ByRef destination As Complex, _
    conversion_level As GH_Conversion _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
destination
Type: Grasshopper.Kernel.Types..::..Complex %
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToComplex_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToComplex_Primary Method
GH_Convert Class See Also Send Feedback
Performs a direct cast from Complex or GH_ComplexNumber

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToComplex_Primary(
    Object data,
    ref Complex destination
)
Visual Basic
Public Shared Function ToComplex_Primary ( _
    data As Object, _
    ByRef destination As Complex _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert.
destination
Type: Grasshopper.Kernel.Types..::..Complex %
Target for value assignment.

Return Value

True on success, false on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToComplex_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToComplex_Secondary Method
GH_Convert Class See Also Send Feedback
Performs indirect casts from other data types into Complex.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToComplex_Secondary(
    Object data,
    ref Complex destination
)
Visual Basic
Public Shared Function ToComplex_Secondary ( _
    data As Object, _
    ByRef destination As Complex _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert.
destination
Type: Grasshopper.Kernel.Types..::..Complex %
Target for value assignment.

Return Value

True on success, false on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToCoordinates Method

[image]

Grasshopper SDK
GH_Convert..::..ToCoordinates Method
GH_Convert Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToCoordinates(
    Object data,
    ref double x,
    ref double y,
    ref double z,
    ref double w
)
Visual Basic
Public Shared Function ToCoordinates ( _
    data As Object, _
    ByRef x As Double, _
    ByRef y As Double, _
    ByRef z As Double, _
    ByRef w As Double _
) As Boolean

Parameters

data
Type: System..::..Object
x
Type: System..::..Double %
y
Type: System..::..Double %
z
Type: System..::..Double %
w
Type: System..::..Double %

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToCulture Method

[image]

Grasshopper SDK
GH_Convert..::..ToCulture Method
GH_Convert Class See Also Send Feedback
Convert data into Colors.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToCulture(
    Object data,
    out CultureInfo destination,
    GH_Conversion conversion_level
)
Visual Basic
Public Shared Function ToCulture ( _
    data As Object, _
    <OutAttribute> ByRef destination As CultureInfo, _
    conversion_level As GH_Conversion _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert.
destination
Type: System.Globalization..::..CultureInfo %
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToCulture_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToCulture_Primary Method
GH_Convert Class See Also Send Feedback
Performs a direct cast from System.Globalization.CultureInfo and GH_Culture.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToCulture_Primary(
    Object data,
    ref CultureInfo destination
)
Visual Basic
Public Shared Function ToCulture_Primary ( _
    data As Object, _
    ByRef destination As CultureInfo _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert.
destination
Type: System.Globalization..::..CultureInfo %
Target for value assignment.

Return Value

True on success, false on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToCulture_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToCulture_Secondary Method
GH_Convert Class See Also Send Feedback
Performs indirect casts from other data types into CultureInfo.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToCulture_Secondary(
    Object data,
    ref CultureInfo destination
)
Visual Basic
Public Shared Function ToCulture_Secondary ( _
    data As Object, _
    ByRef destination As CultureInfo _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert.
destination
Type: System.Globalization..::..CultureInfo %
Target for value assignment.

Return Value

True on success, false on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToCurve Method

[image]

Grasshopper SDK
GH_Convert..::..ToCurve Method
GH_Convert Class See Also Send Feedback
Convert data into Rhino.Geometry.Curve.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToCurve(
    Object data,
    ref Curve rc,
    GH_Conversion conversion_level
)
Visual Basic
Public Shared Function ToCurve ( _
    data As Object, _
    ByRef rc As Curve, _
    conversion_level As GH_Conversion _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Curve%
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToCurve_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToCurve_Primary Method
GH_Convert Class See Also Send Feedback
Performs a direct cast from OnCurve or GH_Curve. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToCurve_Primary(
    Object data,
    ref Curve rc
)
Visual Basic
Public Shared Function ToCurve_Primary ( _
    data As Object, _
    ByRef rc As Curve _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Curve%

Return Value

An OnCurve instance if successful, or Nothing on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToCurve_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToCurve_Secondary Method
GH_Convert Class See Also Send Feedback
Attempts to convert other data types into an IOnCurve. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToCurve_Secondary(
    Object data,
    ref Curve rc
)
Visual Basic
Public Shared Function ToCurve_Secondary ( _
    data As Object, _
    ByRef rc As Curve _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert.
rc
Type: Curve%

Return Value

True on success, false on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToDate Method

[image]

Grasshopper SDK
GH_Convert..::..ToDate Method
GH_Convert Class See Also Send Feedback
Convert data into Dates.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToDate(
    Object data,
    out DateTime destination,
    GH_Conversion conversion_level
)
Visual Basic
Public Shared Function ToDate ( _
    data As Object, _
    <OutAttribute> ByRef destination As DateTime, _
    conversion_level As GH_Conversion _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
destination
Type: System..::..DateTime %
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToDate_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToDate_Primary Method
GH_Convert Class See Also Send Feedback
Performs a direct cast from DateTime or GH_DateTime.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToDate_Primary(
    Object data,
    ref DateTime destination
)
Visual Basic
Public Shared Function ToDate_Primary ( _
    data As Object, _
    ByRef destination As DateTime _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert.
destination
Type: System..::..DateTime %
Target for value assignment.

Return Value

True on success, false on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToDate_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToDate_Secondary Method
GH_Convert Class See Also Send Feedback
Performs indirect casts from other data types into DateTime constructs.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToDate_Secondary(
    Object data,
    ref DateTime destination
)
Visual Basic
Public Shared Function ToDate_Secondary ( _
    data As Object, _
    ByRef destination As DateTime _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert.
destination
Type: System..::..DateTime %
Target for value assignment.

Return Value

True on success, false on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToDouble Method

[image]

Grasshopper SDK
GH_Convert..::..ToDouble Method
GH_Convert Class See Also Send Feedback
Convert data into Doubles.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToDouble(
    Object data,
    out double destination,
    GH_Conversion conversion_level
)
Visual Basic
Public Shared Function ToDouble ( _
    data As Object, _
    <OutAttribute> ByRef destination As Double, _
    conversion_level As GH_Conversion _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
destination
Type: System..::..Double %
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToDouble_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToDouble_Primary Method
GH_Convert Class See Also Send Feedback
Performs a direct cast from Double or GH_Number.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToDouble_Primary(
    Object data,
    ref double destination
)
Visual Basic
Public Shared Function ToDouble_Primary ( _
    data As Object, _
    ByRef destination As Double _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert.
destination
Type: System..::..Double %
Target for value assignment.

Return Value

True on success, false on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToDouble_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToDouble_Secondary Method
GH_Convert Class See Also Send Feedback
Performs indirect casts from other data types into Doubles.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToDouble_Secondary(
    Object data,
    ref double destination
)
Visual Basic
Public Shared Function ToDouble_Secondary ( _
    data As Object, _
    ByRef destination As Double _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert.
destination
Type: System..::..Double %
Target for value assignment.

Return Value

True on success, false on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGeometricGoo Method

[image]

Grasshopper SDK
GH_Convert..::..ToGeometricGoo Method
GH_Convert Class See Also Send Feedback
Converts an object into GeometricGoo. Does not duplicate the data if a lossless conversion is possible.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static IGH_GeometricGoo ToGeometricGoo(
    Object data
)
Visual Basic
Public Shared Function ToGeometricGoo ( _
    data As Object _
) As IGH_GeometricGoo

Parameters

data
Type: System..::..Object
Data to convert.

Return Value

An instance that implements IGH_GeometricGoo on success or null on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGeometryBase Method

[image]

Grasshopper SDK
GH_Convert..::..ToGeometryBase Method
GH_Convert Class See Also Send Feedback
Attempt to convert an object into a Rhino.Geometry.GeometryBase instance.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GeometryBase ToGeometryBase(
    Object data
)
Visual Basic
Public Shared Function ToGeometryBase ( _
    data As Object _
) As GeometryBase

Parameters

data
Type: System..::..Object
Data to convert.

Return Value

A GeometryBase instance on success or null on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHArc Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHArc Method
GH_Convert Class See Also Send Feedback
Convert data into GH_Arcs.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHArc(
    Object data,
    GH_Conversion conversion_level,
    ref GH_Arc target
)
Visual Basic
Public Shared Function ToGHArc ( _
    data As Object, _
    conversion_level As GH_Conversion, _
    ByRef target As GH_Arc _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.
target
Type: Grasshopper.Kernel.Types..::..GH_Arc %
Destination of conversion. If Null, a new instance will be created.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHArc_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHArc_Primary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Arc instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHArc_Primary(
    Object data,
    ref GH_Arc target
)
Visual Basic
Public Shared Function ToGHArc_Primary ( _
    data As Object, _
    ByRef target As GH_Arc _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Arc %
Target instance. If null, a new GH_Arc will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHArc_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHArc_Secondary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Arc instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHArc_Secondary(
    Object data,
    ref GH_Arc target
)
Visual Basic
Public Shared Function ToGHArc_Secondary ( _
    data As Object, _
    ByRef target As GH_Arc _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Arc %
Target instance. If null, a new GH_Arc will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHBoolean Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHBoolean Method
GH_Convert Class See Also Send Feedback
Convert data into GH_Boolean.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHBoolean(
    Object data,
    GH_Conversion conversion_level,
    ref GH_Boolean target
)
Visual Basic
Public Shared Function ToGHBoolean ( _
    data As Object, _
    conversion_level As GH_Conversion, _
    ByRef target As GH_Boolean _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.
target
Type: Grasshopper.Kernel.Types..::..GH_Boolean %
Destination of conversion. If Null, a new instance will be created.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHBoolean_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHBoolean_Primary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Boolean instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHBoolean_Primary(
    Object data,
    ref GH_Boolean target
)
Visual Basic
Public Shared Function ToGHBoolean_Primary ( _
    data As Object, _
    ByRef target As GH_Boolean _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Boolean %
Target instance. If null, a new GH_Boolean will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHBoolean_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHBoolean_Secondary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Boolean instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHBoolean_Secondary(
    Object data,
    ref GH_Boolean target
)
Visual Basic
Public Shared Function ToGHBoolean_Secondary ( _
    data As Object, _
    ByRef target As GH_Boolean _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Boolean %
Target instance. If null, a new GH_Boolean will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHBox Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHBox Method
GH_Convert Class See Also Send Feedback
Convert data into GH_Boxes.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHBox(
    Object data,
    GH_Conversion conversion_level,
    ref GH_Box target
)
Visual Basic
Public Shared Function ToGHBox ( _
    data As Object, _
    conversion_level As GH_Conversion, _
    ByRef target As GH_Box _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.
target
Type: Grasshopper.Kernel.Types..::..GH_Box %
Destination of conversion. If Null, a new instance will be created.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHBox_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHBox_Primary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Box instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHBox_Primary(
    Object data,
    ref GH_Box target
)
Visual Basic
Public Shared Function ToGHBox_Primary ( _
    data As Object, _
    ByRef target As GH_Box _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Box %
Target instance. If null, a new GH_Box will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHBox_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHBox_Secondary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Box instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHBox_Secondary(
    Object data,
    ref GH_Box target
)
Visual Basic
Public Shared Function ToGHBox_Secondary ( _
    data As Object, _
    ByRef target As GH_Box _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Box %
Target instance. If null, a new GH_Box will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHBrep Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHBrep Method
GH_Convert Class See Also Send Feedback
Convert data into GH_Breps.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHBrep(
    Object data,
    GH_Conversion conversion_level,
    ref GH_Brep target
)
Visual Basic
Public Shared Function ToGHBrep ( _
    data As Object, _
    conversion_level As GH_Conversion, _
    ByRef target As GH_Brep _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.
target
Type: Grasshopper.Kernel.Types..::..GH_Brep %
Destination of conversion. If Null, a new instance will be created.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHBrep_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHBrep_Primary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Brep instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHBrep_Primary(
    Object data,
    ref GH_Brep target
)
Visual Basic
Public Shared Function ToGHBrep_Primary ( _
    data As Object, _
    ByRef target As GH_Brep _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Brep %
Target instance. If null, a new GH_Brep will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHBrep_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHBrep_Secondary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Brep instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHBrep_Secondary(
    Object data,
    ref GH_Brep target
)
Visual Basic
Public Shared Function ToGHBrep_Secondary ( _
    data As Object, _
    ByRef target As GH_Brep _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Brep %
Target instance. If null, a new GH_Brep will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHCircle Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHCircle Method
GH_Convert Class See Also Send Feedback
Convert data into GH_Circles.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHCircle(
    Object data,
    GH_Conversion conversion_level,
    ref GH_Circle target
)
Visual Basic
Public Shared Function ToGHCircle ( _
    data As Object, _
    conversion_level As GH_Conversion, _
    ByRef target As GH_Circle _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.
target
Type: Grasshopper.Kernel.Types..::..GH_Circle %
Destination of conversion. If Null, a new instance will be created.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHCircle_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHCircle_Primary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Circle instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHCircle_Primary(
    Object data,
    ref GH_Circle target
)
Visual Basic
Public Shared Function ToGHCircle_Primary ( _
    data As Object, _
    ByRef target As GH_Circle _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Circle %
Target instance. If null, a new GH_Circle will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHCircle_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHCircle_Secondary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Circle instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHCircle_Secondary(
    Object data,
    ref GH_Circle target
)
Visual Basic
Public Shared Function ToGHCircle_Secondary ( _
    data As Object, _
    ByRef target As GH_Circle _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Circle %
Target instance. If null, a new GH_Circle will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHColour Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHColour Method
GH_Convert Class See Also Send Feedback
Convert data into GH_Colour.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHColour(
    Object data,
    GH_Conversion conversion_level,
    ref GH_Colour target
)
Visual Basic
Public Shared Function ToGHColour ( _
    data As Object, _
    conversion_level As GH_Conversion, _
    ByRef target As GH_Colour _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.
target
Type: Grasshopper.Kernel.Types..::..GH_Colour %
Destination of conversion. If Null, a new instance will be created.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHColour_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHColour_Primary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Colour instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHColour_Primary(
    Object data,
    ref GH_Colour target
)
Visual Basic
Public Shared Function ToGHColour_Primary ( _
    data As Object, _
    ByRef target As GH_Colour _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Colour %
Target instance. If null, a new GH_Colour will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHColour_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHColour_Secondary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Colour instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHColour_Secondary(
    Object data,
    ref GH_Colour target
)
Visual Basic
Public Shared Function ToGHColour_Secondary ( _
    data As Object, _
    ByRef target As GH_Colour _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Colour %
Target instance. If null, a new GH_Colour will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHComplexNumber Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHComplexNumber Method
GH_Convert Class See Also Send Feedback
Convert data into GH_ComplexNumber.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHComplexNumber(
    Object data,
    GH_Conversion conversion_level,
    ref GH_ComplexNumber target
)
Visual Basic
Public Shared Function ToGHComplexNumber ( _
    data As Object, _
    conversion_level As GH_Conversion, _
    ByRef target As GH_ComplexNumber _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.
target
Type: Grasshopper.Kernel.Types..::..GH_ComplexNumber %
Destination of conversion. If Null, a new instance will be created.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHComplexNumber_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHComplexNumber_Primary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_ComplexNumber instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHComplexNumber_Primary(
    Object data,
    ref GH_ComplexNumber target
)
Visual Basic
Public Shared Function ToGHComplexNumber_Primary ( _
    data As Object, _
    ByRef target As GH_ComplexNumber _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_ComplexNumber %
Target instance. If null, a new GH_ComplexNumber will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHComplexNumber_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHComplexNumber_Secondary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_ComplexNumber instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHComplexNumber_Secondary(
    Object data,
    ref GH_ComplexNumber target
)
Visual Basic
Public Shared Function ToGHComplexNumber_Secondary ( _
    data As Object, _
    ByRef target As GH_ComplexNumber _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_ComplexNumber %
Target instance. If null, a new GH_ComplexNumber will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHCurve Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHCurve Method
GH_Convert Class See Also Send Feedback
Convert data into GH_Curves.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHCurve(
    Object data,
    GH_Conversion conversion_level,
    ref GH_Curve target
)
Visual Basic
Public Shared Function ToGHCurve ( _
    data As Object, _
    conversion_level As GH_Conversion, _
    ByRef target As GH_Curve _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.
target
Type: Grasshopper.Kernel.Types..::..GH_Curve %
Destination of conversion. If Null, a new instance will be created.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHCurve_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHCurve_Primary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Curve instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHCurve_Primary(
    Object data,
    ref GH_Curve target
)
Visual Basic
Public Shared Function ToGHCurve_Primary ( _
    data As Object, _
    ByRef target As GH_Curve _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Curve %
Target instance. If null, a new GH_Line will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHCurve_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHCurve_Secondary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Curve instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHCurve_Secondary(
    Object data,
    ref GH_Curve target
)
Visual Basic
Public Shared Function ToGHCurve_Secondary ( _
    data As Object, _
    ByRef target As GH_Curve _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Curve %
Target instance. If null, a new GH_Line will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHGuid Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHGuid Method
GH_Convert Class See Also Send Feedback
Convert data into GH_Guid.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHGuid(
    Object data,
    GH_Conversion conversion_level,
    ref GH_Guid target
)
Visual Basic
Public Shared Function ToGHGuid ( _
    data As Object, _
    conversion_level As GH_Conversion, _
    ByRef target As GH_Guid _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.
target
Type: Grasshopper.Kernel.Types..::..GH_Guid %
Destination of conversion. If Null, a new instance will be created.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHGuid_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHGuid_Primary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Guid instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHGuid_Primary(
    Object data,
    ref GH_Guid target
)
Visual Basic
Public Shared Function ToGHGuid_Primary ( _
    data As Object, _
    ByRef target As GH_Guid _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Guid %
Target instance. If null, a new GH_Guid will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHGuid_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHGuid_Secondary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Guid instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHGuid_Secondary(
    Object data,
    ref GH_Guid target
)
Visual Basic
Public Shared Function ToGHGuid_Secondary ( _
    data As Object, _
    ByRef target As GH_Guid _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Guid %
Target instance. If null, a new GH_Guid will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHInteger Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHInteger Method
GH_Convert Class See Also Send Feedback
Convert data into GH_Integer.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHInteger(
    Object data,
    GH_Conversion conversion_level,
    ref GH_Integer target
)
Visual Basic
Public Shared Function ToGHInteger ( _
    data As Object, _
    conversion_level As GH_Conversion, _
    ByRef target As GH_Integer _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.
target
Type: Grasshopper.Kernel.Types..::..GH_Integer %
Destination of conversion. If Null, a new instance will be created.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHInteger_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHInteger_Primary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Integer instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHInteger_Primary(
    Object data,
    ref GH_Integer target
)
Visual Basic
Public Shared Function ToGHInteger_Primary ( _
    data As Object, _
    ByRef target As GH_Integer _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Integer %
Target instance. If null, a new GH_Integer will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHInteger_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHInteger_Secondary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Integer instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHInteger_Secondary(
    Object data,
    ref GH_Integer target
)
Visual Basic
Public Shared Function ToGHInteger_Secondary ( _
    data As Object, _
    ByRef target As GH_Integer _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Integer %
Target instance. If null, a new GH_Integer will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHInterval Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHInterval Method
GH_Convert Class See Also Send Feedback
Convert data into GH_Intervals.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHInterval(
    Object data,
    GH_Conversion conversion_level,
    ref GH_Interval target
)
Visual Basic
Public Shared Function ToGHInterval ( _
    data As Object, _
    conversion_level As GH_Conversion, _
    ByRef target As GH_Interval _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.
target
Type: Grasshopper.Kernel.Types..::..GH_Interval %
Destination of conversion. If Null, a new instance will be created.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHInterval_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHInterval_Primary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Interval instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHInterval_Primary(
    Object data,
    ref GH_Interval target
)
Visual Basic
Public Shared Function ToGHInterval_Primary ( _
    data As Object, _
    ByRef target As GH_Interval _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Interval %
Target instance. If null, a new GH_Interval will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHInterval_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHInterval_Secondary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Interval instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHInterval_Secondary(
    Object data,
    ref GH_Interval target
)
Visual Basic
Public Shared Function ToGHInterval_Secondary ( _
    data As Object, _
    ByRef target As GH_Interval _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Interval %
Target instance. If null, a new GH_Interval will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHInterval2D Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHInterval2D Method
GH_Convert Class See Also Send Feedback
Convert data into GH_Interval2Ds.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHInterval2D(
    Object data,
    GH_Conversion conversion_level,
    ref GH_Interval2D target
)
Visual Basic
Public Shared Function ToGHInterval2D ( _
    data As Object, _
    conversion_level As GH_Conversion, _
    ByRef target As GH_Interval2D _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.
target
Type: Grasshopper.Kernel.Types..::..GH_Interval2D %
Destination of conversion. If Null, a new instance will be created.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHInterval2D_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHInterval2D_Primary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Interval2D instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHInterval2D_Primary(
    Object data,
    ref GH_Interval2D target
)
Visual Basic
Public Shared Function ToGHInterval2D_Primary ( _
    data As Object, _
    ByRef target As GH_Interval2D _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Interval2D %
Target instance. If null, a new GH_Interval2D will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHInterval2D_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHInterval2D_Secondary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Interval2D instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHInterval2D_Secondary(
    Object data,
    ref GH_Interval2D target
)
Visual Basic
Public Shared Function ToGHInterval2D_Secondary ( _
    data As Object, _
    ByRef target As GH_Interval2D _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Interval2D %
Target instance. If null, a new GH_Interval2D will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHLine Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHLine Method
GH_Convert Class See Also Send Feedback
Convert data into GH_Lines.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHLine(
    Object data,
    GH_Conversion conversion_level,
    ref GH_Line target
)
Visual Basic
Public Shared Function ToGHLine ( _
    data As Object, _
    conversion_level As GH_Conversion, _
    ByRef target As GH_Line _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.
target
Type: Grasshopper.Kernel.Types..::..GH_Line %
Destination of conversion. If Null, a new instance will be created.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHLine_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHLine_Primary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Line instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHLine_Primary(
    Object data,
    ref GH_Line target
)
Visual Basic
Public Shared Function ToGHLine_Primary ( _
    data As Object, _
    ByRef target As GH_Line _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Line %
Target instance. If null, a new GH_Line will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHLine_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHLine_Secondary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Line instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHLine_Secondary(
    Object data,
    ref GH_Line target
)
Visual Basic
Public Shared Function ToGHLine_Secondary ( _
    data As Object, _
    ByRef target As GH_Line _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Line %
Target instance. If null, a new GH_Line will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHMatrix Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHMatrix Method
GH_Convert Class See Also Send Feedback
Convert data into ToGHMatrix.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHMatrix(
    Object data,
    GH_Conversion conversion_level,
    ref GH_Matrix target
)
Visual Basic
Public Shared Function ToGHMatrix ( _
    data As Object, _
    conversion_level As GH_Conversion, _
    ByRef target As GH_Matrix _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.
target
Type: Grasshopper.Kernel.Types..::..GH_Matrix %
Destination of conversion. If Null, a new instance will be created.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHMatrix_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHMatrix_Primary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Matrix instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHMatrix_Primary(
    Object data,
    ref GH_Matrix target
)
Visual Basic
Public Shared Function ToGHMatrix_Primary ( _
    data As Object, _
    ByRef target As GH_Matrix _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Matrix %
Target instance. If null, a new GH_Matrix will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHMatrix_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHMatrix_Secondary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Matrix instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHMatrix_Secondary(
    Object data,
    ref GH_Matrix target
)
Visual Basic
Public Shared Function ToGHMatrix_Secondary ( _
    data As Object, _
    ByRef target As GH_Matrix _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Matrix %
Target instance. If null, a new GH_Matrix will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHMesh Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHMesh Method
GH_Convert Class See Also Send Feedback
Convert data into GH_Meshs.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHMesh(
    Object data,
    GH_Conversion conversion_level,
    ref GH_Mesh target
)
Visual Basic
Public Shared Function ToGHMesh ( _
    data As Object, _
    conversion_level As GH_Conversion, _
    ByRef target As GH_Mesh _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.
target
Type: Grasshopper.Kernel.Types..::..GH_Mesh %
Destination of conversion. If Null, a new instance will be created.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHMesh_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHMesh_Primary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Mesh instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHMesh_Primary(
    Object data,
    ref GH_Mesh target
)
Visual Basic
Public Shared Function ToGHMesh_Primary ( _
    data As Object, _
    ByRef target As GH_Mesh _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Mesh %
Target instance. If null, a new GH_Mesh will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHMesh_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHMesh_Secondary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Mesh instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHMesh_Secondary(
    Object data,
    ref GH_Mesh target
)
Visual Basic
Public Shared Function ToGHMesh_Secondary ( _
    data As Object, _
    ByRef target As GH_Mesh _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Mesh %
Target instance. If null, a new GH_Mesh will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHMeshFace Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHMeshFace Method
GH_Convert Class See Also Send Feedback
Convert data into GH_MeshFaces.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHMeshFace(
    Object data,
    GH_Conversion conversion_level,
    ref GH_MeshFace target
)
Visual Basic
Public Shared Function ToGHMeshFace ( _
    data As Object, _
    conversion_level As GH_Conversion, _
    ByRef target As GH_MeshFace _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.
target
Type: Grasshopper.Kernel.Types..::..GH_MeshFace %
Destination of conversion. If Null, a new instance will be created.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHMeshFace_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHMeshFace_Primary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_MeshFace instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHMeshFace_Primary(
    Object data,
    ref GH_MeshFace target
)
Visual Basic
Public Shared Function ToGHMeshFace_Primary ( _
    data As Object, _
    ByRef target As GH_MeshFace _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_MeshFace %
Target instance. If null, a new GH_MeshFace will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHMeshFace_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHMeshFace_Secondary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_MeshFace instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHMeshFace_Secondary(
    Object data,
    ref GH_MeshFace target
)
Visual Basic
Public Shared Function ToGHMeshFace_Secondary ( _
    data As Object, _
    ByRef target As GH_MeshFace _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_MeshFace %
Target instance. If null, a new GH_MeshFace will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHNumber Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHNumber Method
GH_Convert Class See Also Send Feedback
Convert data into GH_Number.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHNumber(
    Object data,
    GH_Conversion conversion_level,
    ref GH_Number target
)
Visual Basic
Public Shared Function ToGHNumber ( _
    data As Object, _
    conversion_level As GH_Conversion, _
    ByRef target As GH_Number _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.
target
Type: Grasshopper.Kernel.Types..::..GH_Number %
Destination of conversion. If Null, a new instance will be created.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHNumber_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHNumber_Primary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Number instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHNumber_Primary(
    Object data,
    ref GH_Number target
)
Visual Basic
Public Shared Function ToGHNumber_Primary ( _
    data As Object, _
    ByRef target As GH_Number _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Number %
Target instance. If null, a new GH_Number will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHNumber_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHNumber_Secondary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Number instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHNumber_Secondary(
    Object data,
    ref GH_Number target
)
Visual Basic
Public Shared Function ToGHNumber_Secondary ( _
    data As Object, _
    ByRef target As GH_Number _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Number %
Target instance. If null, a new GH_Number will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHPlane Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHPlane Method
GH_Convert Class See Also Send Feedback
Convert data into GH_Planes.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHPlane(
    Object data,
    GH_Conversion conversion_level,
    ref GH_Plane target
)
Visual Basic
Public Shared Function ToGHPlane ( _
    data As Object, _
    conversion_level As GH_Conversion, _
    ByRef target As GH_Plane _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.
target
Type: Grasshopper.Kernel.Types..::..GH_Plane %
Destination of conversion. If Null, a new instance will be created.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHPlane_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHPlane_Primary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Plane instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHPlane_Primary(
    Object data,
    ref GH_Plane target
)
Visual Basic
Public Shared Function ToGHPlane_Primary ( _
    data As Object, _
    ByRef target As GH_Plane _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Plane %
Target instance. If null, a new GH_Plane will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHPlane_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHPlane_Secondary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Plane instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHPlane_Secondary(
    Object data,
    ref GH_Plane target
)
Visual Basic
Public Shared Function ToGHPlane_Secondary ( _
    data As Object, _
    ByRef target As GH_Plane _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Plane %
Target instance. If null, a new GH_Plane will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHPoint Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHPoint Method
GH_Convert Class See Also Send Feedback
Convert data into GH_Points.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHPoint(
    Object data,
    GH_Conversion conversion_level,
    ref GH_Point target
)
Visual Basic
Public Shared Function ToGHPoint ( _
    data As Object, _
    conversion_level As GH_Conversion, _
    ByRef target As GH_Point _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.
target
Type: Grasshopper.Kernel.Types..::..GH_Point %
Destination of conversion. If Null, a new instance will be created.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHPoint_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHPoint_Primary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Point instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHPoint_Primary(
    Object data,
    ref GH_Point target
)
Visual Basic
Public Shared Function ToGHPoint_Primary ( _
    data As Object, _
    ByRef target As GH_Point _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Point %
Target instance. If null, a new GH_Point will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHPoint_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHPoint_Secondary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Point instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHPoint_Secondary(
    Object data,
    ref GH_Point target
)
Visual Basic
Public Shared Function ToGHPoint_Secondary ( _
    data As Object, _
    ByRef target As GH_Point _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Point %
Target instance. If null, a new GH_Point will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHRectangle Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHRectangle Method
GH_Convert Class See Also Send Feedback
Convert data into GH_Rectangles.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHRectangle(
    Object data,
    GH_Conversion conversion_level,
    ref GH_Rectangle target
)
Visual Basic
Public Shared Function ToGHRectangle ( _
    data As Object, _
    conversion_level As GH_Conversion, _
    ByRef target As GH_Rectangle _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.
target
Type: Grasshopper.Kernel.Types..::..GH_Rectangle %
Destination of conversion. If Null, a new instance will be created.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHRectangle_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHRectangle_Primary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Rectangle instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHRectangle_Primary(
    Object data,
    ref GH_Rectangle target
)
Visual Basic
Public Shared Function ToGHRectangle_Primary ( _
    data As Object, _
    ByRef target As GH_Rectangle _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Rectangle %
Target instance. If null, a new GH_Rectangle will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHRectangle_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHRectangle_Secondary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Rectangle instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHRectangle_Secondary(
    Object data,
    ref GH_Rectangle target
)
Visual Basic
Public Shared Function ToGHRectangle_Secondary ( _
    data As Object, _
    ByRef target As GH_Rectangle _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Rectangle %
Target instance. If null, a new GH_Rectangle will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHString Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHString Method
GH_Convert Class See Also Send Feedback
Convert data into GH_String.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHString(
    Object data,
    GH_Conversion conversion_level,
    ref GH_String target
)
Visual Basic
Public Shared Function ToGHString ( _
    data As Object, _
    conversion_level As GH_Conversion, _
    ByRef target As GH_String _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.
target
Type: Grasshopper.Kernel.Types..::..GH_String %
Destination of conversion. If Null, a new instance will be created.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHString_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHString_Primary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_String instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHString_Primary(
    Object data,
    ref GH_String target
)
Visual Basic
Public Shared Function ToGHString_Primary ( _
    data As Object, _
    ByRef target As GH_String _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_String %
Target instance. If null, a new GH_String will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHString_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHString_Secondary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_String instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHString_Secondary(
    Object data,
    ref GH_String target
)
Visual Basic
Public Shared Function ToGHString_Secondary ( _
    data As Object, _
    ByRef target As GH_String _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_String %
Target instance. If null, a new GH_String will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHSurface Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHSurface Method
GH_Convert Class See Also Send Feedback
Convert data into GH_Surfaces.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHSurface(
    Object data,
    GH_Conversion conversion_level,
    ref GH_Surface target
)
Visual Basic
Public Shared Function ToGHSurface ( _
    data As Object, _
    conversion_level As GH_Conversion, _
    ByRef target As GH_Surface _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.
target
Type: Grasshopper.Kernel.Types..::..GH_Surface %
Destination of conversion. If Null, a new instance will be created.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHSurface_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHSurface_Primary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Surface instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHSurface_Primary(
    Object data,
    ref GH_Surface target
)
Visual Basic
Public Shared Function ToGHSurface_Primary ( _
    data As Object, _
    ByRef target As GH_Surface _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Surface %
Target instance. If null, a new GH_Surface will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHSurface_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHSurface_Secondary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Surface instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHSurface_Secondary(
    Object data,
    ref GH_Surface target
)
Visual Basic
Public Shared Function ToGHSurface_Secondary ( _
    data As Object, _
    ByRef target As GH_Surface _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Surface %
Target instance. If null, a new GH_Surface will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHTime Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHTime Method
GH_Convert Class See Also Send Feedback
Convert data into GH_Time.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHTime(
    Object data,
    GH_Conversion conversion_level,
    ref GH_Time target
)
Visual Basic
Public Shared Function ToGHTime ( _
    data As Object, _
    conversion_level As GH_Conversion, _
    ByRef target As GH_Time _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.
target
Type: Grasshopper.Kernel.Types..::..GH_Time %
Destination of conversion. If Null, a new instance will be created.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHTime_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHTime_Primary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Time instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHTime_Primary(
    Object data,
    ref GH_Time target
)
Visual Basic
Public Shared Function ToGHTime_Primary ( _
    data As Object, _
    ByRef target As GH_Time _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Time %
Target instance. If null, a new GH_Time will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHTime_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHTime_Secondary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Time instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHTime_Secondary(
    Object data,
    ref GH_Time target
)
Visual Basic
Public Shared Function ToGHTime_Secondary ( _
    data As Object, _
    ByRef target As GH_Time _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Time %
Target instance. If null, a new GH_Time will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHVector Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHVector Method
GH_Convert Class See Also Send Feedback
Convert data into GH_Vectors.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHVector(
    Object data,
    GH_Conversion conversion_level,
    ref GH_Vector target
)
Visual Basic
Public Shared Function ToGHVector ( _
    data As Object, _
    conversion_level As GH_Conversion, _
    ByRef target As GH_Vector _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.
target
Type: Grasshopper.Kernel.Types..::..GH_Vector %
Destination of conversion. If Null, a new instance will be created.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHVector_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHVector_Primary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Vector instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHVector_Primary(
    Object data,
    ref GH_Vector target
)
Visual Basic
Public Shared Function ToGHVector_Primary ( _
    data As Object, _
    ByRef target As GH_Vector _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Vector %
Target instance. If null, a new GH_Vector will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGHVector_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGHVector_Secondary Method
GH_Convert Class See Also Send Feedback
Converts similar data into a GH_Vector instance. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGHVector_Secondary(
    Object data,
    ref GH_Vector target
)
Visual Basic
Public Shared Function ToGHVector_Secondary ( _
    data As Object, _
    ByRef target As GH_Vector _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
target
Type: Grasshopper.Kernel.Types..::..GH_Vector %
Target instance. If null, a new GH_Vector will be constructed. If not null, the instance values will be set.

Return Value

True on success, False on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGoo Method

[image]

Grasshopper SDK
GH_Convert..::..ToGoo Method
GH_Convert Class See Also Send Feedback
Converts an object into Goo. Does not duplicate the data if a lossless conversion is possible.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static IGH_Goo ToGoo(
    Object data
)
Visual Basic
Public Shared Function ToGoo ( _
    data As Object _
) As IGH_Goo

Parameters

data
Type: System..::..Object
Data to convert.

Return Value

IGH_Goo instance. If Data is not a null reference this function ALWAYS returns a GOO instance.

Remarks

This function calls a whole sh*tload of other conversion functions. IT IS SLOW.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGUID Method

[image]

Grasshopper SDK
GH_Convert..::..ToGUID Method
GH_Convert Class See Also Send Feedback
Convert data into Guids.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGUID(
    Object data,
    out Guid destination,
    GH_Conversion conversion_level
)
Visual Basic
Public Shared Function ToGUID ( _
    data As Object, _
    <OutAttribute> ByRef destination As Guid, _
    conversion_level As GH_Conversion _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
destination
Type: System..::..Guid %
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGUID_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGUID_Primary Method
GH_Convert Class See Also Send Feedback
Performs a direct cast from Guid, GH_Guid, String and GH_String.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGUID_Primary(
    Object data,
    ref Guid destination
)
Visual Basic
Public Shared Function ToGUID_Primary ( _
    data As Object, _
    ByRef destination As Guid _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert.
destination
Type: System..::..Guid %
Target for value assignment.

Return Value

True on success, false on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToGUID_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToGUID_Secondary Method
GH_Convert Class See Also Send Feedback
Performs indirect casts from other data types into Guids.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToGUID_Secondary(
    Object data,
    ref Guid destination
)
Visual Basic
Public Shared Function ToGUID_Secondary ( _
    data As Object, _
    ByRef destination As Guid _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert.
destination
Type: System..::..Guid %
Target for value assignment.

Return Value

True on success, false on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToInt32 Method

[image]

Grasshopper SDK
GH_Convert..::..ToInt32 Method
GH_Convert Class See Also Send Feedback
Convert data into Int32s.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToInt32(
    Object data,
    out int destination,
    GH_Conversion conversion_level
)
Visual Basic
Public Shared Function ToInt32 ( _
    data As Object, _
    <OutAttribute> ByRef destination As Integer, _
    conversion_level As GH_Conversion _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
destination
Type: System..::..Int32 %
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToInt32_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToInt32_Primary Method
GH_Convert Class See Also Send Feedback
Performs a direct cast from Int32 or GH_Integer.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToInt32_Primary(
    Object data,
    ref int destination
)
Visual Basic
Public Shared Function ToInt32_Primary ( _
    data As Object, _
    ByRef destination As Integer _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert.
destination
Type: System..::..Int32 %
Target for value assignment.

Return Value

True on success, false on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToInt32_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToInt32_Secondary Method
GH_Convert Class See Also Send Feedback
Performs indirect casts from other data types into Integers.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToInt32_Secondary(
    Object data,
    ref int destination
)
Visual Basic
Public Shared Function ToInt32_Secondary ( _
    data As Object, _
    ByRef destination As Integer _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert.
destination
Type: System..::..Int32 %
Target for value assignment.

Return Value

True on success, false on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToInterval Method

[image]

Grasshopper SDK
GH_Convert..::..ToInterval Method
GH_Convert Class See Also Send Feedback
Convert data into Rhino.Geometry.Interval.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToInterval(
    Object data,
    ref Interval rc,
    GH_Conversion conversion_level
)
Visual Basic
Public Shared Function ToInterval ( _
    data As Object, _
    ByRef rc As Interval, _
    conversion_level As GH_Conversion _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Interval%
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToInterval_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToInterval_Primary Method
GH_Convert Class See Also Send Feedback
Performs a direct cast from OnInterval or GH_Interval.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToInterval_Primary(
    Object data,
    ref Interval rc
)
Visual Basic
Public Shared Function ToInterval_Primary ( _
    data As Object, _
    ByRef rc As Interval _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Interval%
[out] Interval cast.

Return Value

True on success, false on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToInterval_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToInterval_Secondary Method
GH_Convert Class See Also Send Feedback
Attempts to convert other data types into an Interval. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToInterval_Secondary(
    Object data,
    ref Interval rc
)
Visual Basic
Public Shared Function ToInterval_Secondary ( _
    data As Object, _
    ByRef rc As Interval _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Interval%
[out] Interval cast.

Return Value

True on success, false on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToLine Method

[image]

Grasshopper SDK
GH_Convert..::..ToLine Method
GH_Convert Class See Also Send Feedback
Convert data into Rhino.Geometry.Line.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToLine(
    Object data,
    ref Line rc,
    GH_Conversion conversion_level
)
Visual Basic
Public Shared Function ToLine ( _
    data As Object, _
    ByRef rc As Line, _
    conversion_level As GH_Conversion _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Line%
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToLine_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToLine_Primary Method
GH_Convert Class See Also Send Feedback
Performs a direct cast from OnLine or GH_Line. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToLine_Primary(
    Object data,
    ref Line rc
)
Visual Basic
Public Shared Function ToLine_Primary ( _
    data As Object, _
    ByRef rc As Line _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Line%

Return Value

An OnLine instance if successful, or Nothing on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToLine_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToLine_Secondary Method
GH_Convert Class See Also Send Feedback
Attempts to convert other data types into an OnLine. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToLine_Secondary(
    Object data,
    ref Line rc
)
Visual Basic
Public Shared Function ToLine_Secondary ( _
    data As Object, _
    ByRef rc As Line _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Line%

Return Value

An OnLine instance if successful, or Nothing on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToMatrix Method

[image]

Grasshopper SDK
GH_Convert..::..ToMatrix Method
GH_Convert Class See Also Send Feedback
Convert data into Rhino.Geometry.Matrix.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToMatrix(
    Object data,
    ref Matrix rc,
    GH_Conversion conversion_level
)
Visual Basic
Public Shared Function ToMatrix ( _
    data As Object, _
    ByRef rc As Matrix, _
    conversion_level As GH_Conversion _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Matrix%
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToMatrix_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToMatrix_Primary Method
GH_Convert Class See Also Send Feedback
Performs a direct cast from Matrix or GH_Matrix.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToMatrix_Primary(
    Object data,
    ref Matrix rc
)
Visual Basic
Public Shared Function ToMatrix_Primary ( _
    data As Object, _
    ByRef rc As Matrix _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Matrix%
[out] Matrix cast.

Return Value

True on success, false on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToMatrix_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToMatrix_Secondary Method
GH_Convert Class See Also Send Feedback
Attempts to convert other data types into a Matrix. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToMatrix_Secondary(
    Object data,
    ref Matrix rc
)
Visual Basic
Public Shared Function ToMatrix_Secondary ( _
    data As Object, _
    ByRef rc As Matrix _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Matrix%
[out] Matrix cast.

Return Value

True on success, false on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToMesh Method

[image]

Grasshopper SDK
GH_Convert..::..ToMesh Method
GH_Convert Class See Also Send Feedback
Convert data into Rhino.Geometry.Mesh.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToMesh(
    Object data,
    ref Mesh rc,
    GH_Conversion conversion_level
)
Visual Basic
Public Shared Function ToMesh ( _
    data As Object, _
    ByRef rc As Mesh, _
    conversion_level As GH_Conversion _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Mesh%
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToMesh_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToMesh_Primary Method
GH_Convert Class See Also Send Feedback
Performs a direct cast from OnMesh or GH_Mesh. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToMesh_Primary(
    Object data,
    ref Mesh rc
)
Visual Basic
Public Shared Function ToMesh_Primary ( _
    data As Object, _
    ByRef rc As Mesh _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Mesh%

Return Value

An OnMesh instance if successful, or Nothing on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToMesh_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToMesh_Secondary Method
GH_Convert Class See Also Send Feedback
Attempts to convert other data types into an OnMesh. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToMesh_Secondary(
    Object data,
    ref Mesh rc
)
Visual Basic
Public Shared Function ToMesh_Secondary ( _
    data As Object, _
    ByRef rc As Mesh _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Mesh%

Return Value

An OnMesh instance if successful, or Nothing on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToNextPowerOfTen Method

[image]

Grasshopper SDK
GH_Convert..::..ToNextPowerOfTen Method
GH_Convert Class See Also Send Feedback
Round a number upwards to the nearest power of ten.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static double ToNextPowerOfTen(
    double num
)
Visual Basic
Public Shared Function ToNextPowerOfTen ( _
    num As Double _
) As Double

Parameters

num
Type: System..::..Double
Number to round.

Return Value

The power of ten equal to or higher than num.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToPlane Method

[image]

Grasshopper SDK
GH_Convert..::..ToPlane Method
GH_Convert Class See Also Send Feedback
Convert data into Rhino.Geometry.Plane.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToPlane(
    Object data,
    ref Plane rc,
    GH_Conversion conversion_level
)
Visual Basic
Public Shared Function ToPlane ( _
    data As Object, _
    ByRef rc As Plane, _
    conversion_level As GH_Conversion _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Plane%
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToPlane_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToPlane_Primary Method
GH_Convert Class See Also Send Feedback
Performs a direct cast from OnPlane or GH_Plane. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToPlane_Primary(
    Object data,
    ref Plane rc
)
Visual Basic
Public Shared Function ToPlane_Primary ( _
    data As Object, _
    ByRef rc As Plane _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Plane%

Return Value

An OnPlane instance if successful, or Nothing on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToPlane_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToPlane_Secondary Method
GH_Convert Class See Also Send Feedback
Attempts to convert other data types into an OnPlane. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToPlane_Secondary(
    Object data,
    ref Plane rc
)
Visual Basic
Public Shared Function ToPlane_Secondary ( _
    data As Object, _
    ByRef rc As Plane _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Plane%

Return Value

An OnPlane instance if successful, or Nothing on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToPlural Method

[image]

Grasshopper SDK
GH_Convert..::..ToPlural Method
GH_Convert Class See Also Send Feedback
Apply english rules to convert a noun into its plural form. This algorithm is not water-tight as it will not handle any irregular cases.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string ToPlural(
    string singular
)
Visual Basic
Public Shared Function ToPlural ( _
    singular As String _
) As String

Parameters

singular
Type: System..::..String
Singular form of noun.

Return Value

Plural form of noun.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToPoint Method

[image]

Grasshopper SDK
GH_Convert..::..ToPoint Method
GH_Convert Class See Also Send Feedback
Convert a floating point GDI point structure to an integer rounded point.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Point ToPoint(
    PointF in
)
Visual Basic
Public Shared Function ToPoint ( _
    in As PointF _
) As Point

Parameters

in
Type: System.Drawing..::..PointF
PointF to convert.

Return Value

Integer accuracy point.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToPoint3d Method

[image]

Grasshopper SDK
GH_Convert..::..ToPoint3d Method
GH_Convert Class See Also Send Feedback
Convert data into Rhino.Geometry.Point3d.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToPoint3d(
    Object data,
    ref Point3d rc,
    GH_Conversion conversion_level
)
Visual Basic
Public Shared Function ToPoint3d ( _
    data As Object, _
    ByRef rc As Point3d, _
    conversion_level As GH_Conversion _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Point3d%
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToPoint3d_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToPoint3d_Primary Method
GH_Convert Class See Also Send Feedback
Performs a direct cast from On3dPoint or GH_Point. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToPoint3d_Primary(
    Object data,
    ref Point3d rc
)
Visual Basic
Public Shared Function ToPoint3d_Primary ( _
    data As Object, _
    ByRef rc As Point3d _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Point3d%

Return Value

An On3dPoint instance if successful, or Nothing on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToPoint3d_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToPoint3d_Secondary Method
GH_Convert Class See Also Send Feedback
Attempts to convert other data types into an Point. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToPoint3d_Secondary(
    Object data,
    ref Point3d rc
)
Visual Basic
Public Shared Function ToPoint3d_Secondary ( _
    data As Object, _
    ByRef rc As Point3d _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Point3d%
[out] Point cast.

Return Value

True on success, false on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToPointF Method

[image]

Grasshopper SDK
GH_Convert..::..ToPointF Method
GH_Convert Class See Also Send Feedback
Convert a Rhino SDK point structure to a GDI point structure.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static PointF ToPointF(
    Point3d in
)
Visual Basic
Public Shared Function ToPointF ( _
    in As Point3d _
) As PointF

Parameters

in
Type: Point3d
Point3d to convert.

Return Value

Floating point accuracy GDI point.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToPrevPowerOfTen Method

[image]

Grasshopper SDK
GH_Convert..::..ToPrevPowerOfTen Method
GH_Convert Class See Also Send Feedback
Round a number downwards to the nearest power of ten.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static double ToPrevPowerOfTen(
    double num
)
Visual Basic
Public Shared Function ToPrevPowerOfTen ( _
    num As Double _
) As Double

Parameters

num
Type: System..::..Double
Number to round.

Return Value

The power of ten equal to or less than num.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToRectangle Method

[image]

Grasshopper SDK
GH_Convert..::..ToRectangle Method
GH_Convert Class See Also Send Feedback
Convert a floating point GDI rectangle structure to an integer rounded rectangle. Use this method for any and all GUI conversions as the specific rounding scheme used here avoids pixel jitter.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Rectangle ToRectangle(
    RectangleF in
)
Visual Basic
Public Shared Function ToRectangle ( _
    in As RectangleF _
) As Rectangle

Parameters

in
Type: System.Drawing..::..RectangleF
RectangleF to convert.

Return Value

Integer accuracy rectangle.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToRectangle3d Method

[image]

Grasshopper SDK
GH_Convert..::..ToRectangle3d Method
GH_Convert Class See Also Send Feedback
Convert data into Rhino.Geometry.Line.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToRectangle3d(
    Object data,
    ref Rectangle3d rc,
    GH_Conversion conversion_level
)
Visual Basic
Public Shared Function ToRectangle3d ( _
    data As Object, _
    ByRef rc As Rectangle3d, _
    conversion_level As GH_Conversion _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Rectangle3d%
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToRectangle3d_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToRectangle3d_Primary Method
GH_Convert Class See Also Send Feedback
Performs a direct cast from Rectangle3d or GH_Rectangle. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToRectangle3d_Primary(
    Object data,
    ref Rectangle3d rc
)
Visual Basic
Public Shared Function ToRectangle3d_Primary ( _
    data As Object, _
    ByRef rc As Rectangle3d _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Rectangle3d%

Return Value

A Rectangle3d instance if successful, or Nothing on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToRectangle3d_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToRectangle3d_Secondary Method
GH_Convert Class See Also Send Feedback
Attempts to convert other data types into a Rectangle3d. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToRectangle3d_Secondary(
    Object data,
    ref Rectangle3d rc
)
Visual Basic
Public Shared Function ToRectangle3d_Secondary ( _
    data As Object, _
    ByRef rc As Rectangle3d _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Rectangle3d%

Return Value

A Rectangle3d instance if successful, or Nothing on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToRelativePath Method

[image]

Grasshopper SDK
GH_Convert..::..ToRelativePath Method
GH_Convert Class See Also Send Feedback
Create a relative path from two absolute paths.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
[ObsoleteAttribute("Do not use this method, it is lame")]
public static string ToRelativePath(
    string anchor_path,
    string target_path
)
Visual Basic
<ObsoleteAttribute("Do not use this method, it is lame")> _
Public Shared Function ToRelativePath ( _
    anchor_path As String, _
    target_path As String _
) As String

Parameters

anchor_path
Type: System..::..String
Anchor path, the relative path result will be based on this location. Must be absolute.
target_path
Type: System..::..String
Target path, this is the path that will be converted. Must be absolute and must have the same root as the Anchor.

Return Value

The relative path on success or null on failure.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if anchor_path is a null reference.
System..::..ArgumentNullException | Thrown if target_path is a null reference.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToSHA_Hash Method

[image] [image]

Grasshopper SDK
GH_Convert..::..ToSHA_Hash Method
GH_Convert Class See Also Send Feedback

Overload List

Name | Description
ToSHA_Hash(array<Byte>[]()[][]) | Create a SHA hash. The hash algorithm is only guaranteed to yield the same results from within a unique application domain.
ToSHA_Hash(Stream) | Create a SHA hash. The hash algorithm is only guaranteed to yield the same results from within a unique application domain.

See Also

GH_Convert Class
GH_Convert Members
Grasshopper.Kernel Namespace


ToSHA_Hash Method (Byte[])

[image]

Grasshopper SDK
GH_Convert..::..ToSHA_Hash Method (array<Byte>[]()[][])
GH_Convert Class See Also Send Feedback
Create a SHA hash. The hash algorithm is only guaranteed to yield the same results from within a unique application domain.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid ToSHA_Hash(
    byte[] data
)
Visual Basic
Public Shared Function ToSHA_Hash ( _
    data As Byte() _
) As Guid

Parameters

data
Type: array< System..::..Byte >[]()[][]
Data to hash.

Return Value

A guid representing the (partial) SHA hash.

See Also

GH_Convert Class
ToSHA_Hash Overload
Grasshopper.Kernel Namespace


ToSHA_Hash Method (Stream)

[image]

Grasshopper SDK
GH_Convert..::..ToSHA_Hash Method (Stream)
GH_Convert Class See Also Send Feedback
Create a SHA hash. The hash algorithm is only guaranteed to yield the same results from within a unique application domain.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid ToSHA_Hash(
    Stream data
)
Visual Basic
Public Shared Function ToSHA_Hash ( _
    data As Stream _
) As Guid

Parameters

data
Type: System.IO..::..Stream
Data to hash.

Return Value

A guid representing the (partial) SHA hash.

See Also

GH_Convert Class
ToSHA_Hash Overload
Grasshopper.Kernel Namespace


ToSize Method

[image]

Grasshopper SDK
GH_Convert..::..ToSize Method
GH_Convert Class See Also Send Feedback
Convert a floating point GDI size structure to an integer rounded size.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Size ToSize(
    SizeF in
)
Visual Basic
Public Shared Function ToSize ( _
    in As SizeF _
) As Size

Parameters

in
Type: System.Drawing..::..SizeF
SizeF to convert.

Return Value

Integer accuracy size.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToString Method

[image]

Grasshopper SDK
GH_Convert..::..ToString Method
GH_Convert Class See Also Send Feedback
Convert data into Colors.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToString(
    Object data,
    out string destination,
    GH_Conversion conversion_level
)
Visual Basic
Public Shared Function ToString ( _
    data As Object, _
    <OutAttribute> ByRef destination As String, _
    conversion_level As GH_Conversion _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
destination
Type: System..::..String %
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToString_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToString_Primary Method
GH_Convert Class See Also Send Feedback
Performs a direct cast from String and GH_String.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToString_Primary(
    Object data,
    ref string destination
)
Visual Basic
Public Shared Function ToString_Primary ( _
    data As Object, _
    ByRef destination As String _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert.
destination
Type: System..::..String %
Target for value assignment.

Return Value

True on success, false on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToString_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToString_Secondary Method
GH_Convert Class See Also Send Feedback
Creates a String representation of an object by calling the ToString() function.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToString_Secondary(
    Object data,
    ref string destination
)
Visual Basic
Public Shared Function ToString_Secondary ( _
    data As Object, _
    ByRef destination As String _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert.
destination
Type: System..::..String %
Target for value assignment.

Return Value

True on success, false on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToSurface Method

[image]

Grasshopper SDK
GH_Convert..::..ToSurface Method
GH_Convert Class See Also Send Feedback
Convert data into Rhino.Geometry.Surface.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToSurface(
    Object data,
    ref Surface rc,
    GH_Conversion conversion_level
)
Visual Basic
Public Shared Function ToSurface ( _
    data As Object, _
    ByRef rc As Surface, _
    conversion_level As GH_Conversion _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Surface%
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToSurface_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToSurface_Primary Method
GH_Convert Class See Also Send Feedback
Performs a direct cast from OnSurface or GH_Surface. Data is not quaranteed to be duplicated. If data is of type GH_Surface, then trim curves are ignored.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToSurface_Primary(
    Object data,
    ref Surface rc
)
Visual Basic
Public Shared Function ToSurface_Primary ( _
    data As Object, _
    ByRef rc As Surface _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Surface%

Return Value

An OnSurface instance if successful, or Nothing on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToSurface_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToSurface_Secondary Method
GH_Convert Class See Also Send Feedback
Attempts to convert other data types into an IOnSurface. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToSurface_Secondary(
    Object data,
    ref Surface rc
)
Visual Basic
Public Shared Function ToSurface_Secondary ( _
    data As Object, _
    ByRef rc As Surface _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Surface%

Return Value

An IOnSurface instance if successful, or Nothing on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToUVInterval Method

[image]

Grasshopper SDK
GH_Convert..::..ToUVInterval Method
GH_Convert Class See Also Send Feedback
Convert data into Grasshopper.Kernel.Types.UVInterval.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToUVInterval(
    Object data,
    ref UVInterval rc,
    GH_Conversion conversion_level
)
Visual Basic
Public Shared Function ToUVInterval ( _
    data As Object, _
    ByRef rc As UVInterval, _
    conversion_level As GH_Conversion _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Grasshopper.Kernel.Types..::..UVInterval %
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToUVInterval_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToUVInterval_Primary Method
GH_Convert Class See Also Send Feedback
Performs a direct cast from UVInterval or GH_Interval2D.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToUVInterval_Primary(
    Object data,
    ref UVInterval rc
)
Visual Basic
Public Shared Function ToUVInterval_Primary ( _
    data As Object, _
    ByRef rc As UVInterval _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Grasshopper.Kernel.Types..::..UVInterval %
[out] Interval cast.

Return Value

True on success, false on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToUVInterval_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToUVInterval_Secondary Method
GH_Convert Class See Also Send Feedback
Attempts to convert other data types into a UVInterval. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToUVInterval_Secondary(
    Object data,
    ref UVInterval rc
)
Visual Basic
Public Shared Function ToUVInterval_Secondary ( _
    data As Object, _
    ByRef rc As UVInterval _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Grasshopper.Kernel.Types..::..UVInterval %
[out] Interval cast.

Return Value

True on success, false on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToVariableName Method

[image]

Grasshopper SDK
GH_Convert..::..ToVariableName Method
GH_Convert Class See Also Send Feedback
Extract the implied variable name from a compound string. A string is considered compound if it contains a parenthesis pair with at least one character within the brackets.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string ToVariableName(
    string compound
)
Visual Basic
Public Shared Function ToVariableName ( _
    compound As String _
) As String

Parameters

compound
Type: System..::..String
String to parse.

Return Value

The variable name as extracted or the original compound if no name was implied.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToVariant Method

[image]

Grasshopper SDK
GH_Convert..::..ToVariant Method
GH_Convert Class See Also Send Feedback
Convert an object to a Grasshopper Expression Variant if possible.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Variant ToVariant(
    Object value
)
Visual Basic
Public Shared Function ToVariant ( _
    value As Object _
) As GH_Variant

Parameters

value
Type: System..::..Object
Data to convert.

Return Value

An expression variant that matches the input best or a VAR_Null instance.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToVector3d Method

[image]

Grasshopper SDK
GH_Convert..::..ToVector3d Method
GH_Convert Class See Also Send Feedback
Convert data into Rhino.Geometry.Vector3d.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToVector3d(
    Object data,
    ref Vector3d rc,
    GH_Conversion conversion_level
)
Visual Basic
Public Shared Function ToVector3d ( _
    data As Object, _
    ByRef rc As Vector3d, _
    conversion_level As GH_Conversion _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Vector3d%
conversion_level
Type: Grasshopper.Kernel..::..GH_Conversion
Level of conversion.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToVector3d_Primary Method

[image]

Grasshopper SDK
GH_Convert..::..ToVector3d_Primary Method
GH_Convert Class See Also Send Feedback
Performs a direct cast from On3dVector or GH_Vector. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToVector3d_Primary(
    Object data,
    ref Vector3d rc
)
Visual Basic
Public Shared Function ToVector3d_Primary ( _
    data As Object, _
    ByRef rc As Vector3d _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Vector3d%

Return Value

An On3dVector instance if successful, or Nothing on failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


ToVector3d_Secondary Method

[image]

Grasshopper SDK
GH_Convert..::..ToVector3d_Secondary Method
GH_Convert Class See Also Send Feedback
Attempts to convert other data types into a Vector. Data is not quaranteed to be duplicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool ToVector3d_Secondary(
    Object data,
    ref Vector3d rc
)
Visual Basic
Public Shared Function ToVector3d_Secondary ( _
    data As Object, _
    ByRef rc As Vector3d _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert
rc
Type: Vector3d%
[out] Vector cast.

Return Value

True on success, false o failure.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


GH_Convert Properties

[image] [image]

Grasshopper SDK
GH_Convert Properties
GH_Convert Class See Also Send Feedback

The GH_Convert type exposes the following members.

Properties

Name | Description
CultureTable | Gets the cached culture table. Do not modify this dictionary unless you know what you are doing.

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


CultureTable Property

[image]

Grasshopper SDK
GH_Convert..::..CultureTable Property
GH_Convert Class See Also Send Feedback
Gets the cached culture table. Do not modify this dictionary unless you know what you are doing.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static SortedDictionary<CultureInfo, List<string>> CultureTable { get; }
Visual Basic
Public Shared ReadOnly Property CultureTable As SortedDictionary(Of CultureInfo, List(Of String))
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Convert.CultureTable"]

See Also

GH_Convert Class
Grasshopper.Kernel Namespace


GH_CustomEventServer Class

[image]

Grasshopper SDK
GH_CustomEventServer Class
Members See Also Send Feedback
RhinoCommon only event server.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_CustomEventServer
Visual Basic
Public Class GH_CustomEventServer

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_CustomEventServer

See Also

GH_CustomEventServer Members
Grasshopper.Kernel Namespace


GH_CustomEventServer Members

[image] [image]

Grasshopper SDK
GH_CustomEventServer Members
GH_CustomEventServer Class Constructors Properties See Also Send Feedback

The GH_CustomEventServer type exposes the following members.

Constructors

 | Name | Description
Public method | GH_CustomEventServer | Create and register a new event server.

Properties

 | Name | Description
Public property | Enabled | Gets or sets the enabled state flag for this event watcher.
Public property | GuidTable | Gets direct access to the internal guid table. The table contains pairs of object Ids and runtime serial numbers.
Public property | GuidTableCount | Gets the number of stored ids in the Guid Table.

See Also

GH_CustomEventServer Class
Grasshopper.Kernel Namespace


GH_CustomEventServer Constructor

[image]

Grasshopper SDK
GH_CustomEventServer Constructor
GH_CustomEventServer Class See Also Send Feedback
Create and register a new event server.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_CustomEventServer(
    IGH_EventConsumer consumer
)
Visual Basic
Public Sub New ( _
    consumer As IGH_EventConsumer _
)

Parameters

consumer
Type: Grasshopper.Kernel..::..IGH_EventConsumer
Consumer object that owns this event server.

See Also

GH_CustomEventServer Class
Grasshopper.Kernel Namespace


GH_CustomEventServer Properties

[image] [image]

Grasshopper SDK
GH_CustomEventServer Properties
GH_CustomEventServer Class See Also Send Feedback

The GH_CustomEventServer type exposes the following members.

Properties

 | Name | Description
Public property | Enabled | Gets or sets the enabled state flag for this event watcher.
Public property | GuidTable | Gets direct access to the internal guid table. The table contains pairs of object Ids and runtime serial numbers.
Public property | GuidTableCount | Gets the number of stored ids in the Guid Table.

See Also

GH_CustomEventServer Class
Grasshopper.Kernel Namespace


Enabled Property

[image]

Grasshopper SDK
GH_CustomEventServer..::..Enabled Property
GH_CustomEventServer Class See Also Send Feedback
Gets or sets the enabled state flag for this event watcher.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Enabled { get; set; }
Visual Basic
Public Property Enabled As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_CustomEventServer.Enabled"]

Return Value

Remarks

See Also

GH_CustomEventServer Class
Grasshopper.Kernel Namespace


GuidTable Property

[image]

Grasshopper SDK
GH_CustomEventServer..::..GuidTable Property
GH_CustomEventServer Class See Also Send Feedback
Gets direct access to the internal guid table. The table contains pairs of object Ids and runtime serial numbers.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public SortedDictionary<Guid, uint> GuidTable { get; }
Visual Basic
Public ReadOnly Property GuidTable As SortedDictionary(Of Guid, UInteger)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_CustomEventServer.GuidTable"]

See Also

GH_CustomEventServer Class
Grasshopper.Kernel Namespace


GuidTableCount Property

[image]

Grasshopper SDK
GH_CustomEventServer..::..GuidTableCount Property
GH_CustomEventServer Class See Also Send Feedback
Gets the number of stored ids in the Guid Table.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int GuidTableCount { get; }
Visual Basic
Public ReadOnly Property GuidTableCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_CustomEventServer.GuidTableCount"]

See Also

GH_CustomEventServer Class
Grasshopper.Kernel Namespace


GH_DataComparison Enumeration

[image]

Grasshopper SDK
GH_DataComparison Enumeration
See Also Send Feedback
Enumerates all possible Data Matching algorithms for Components.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_DataComparison
Visual Basic
Public Enumeration GH_DataComparison

Members

Member name | Value | Description
ShortestList | 0 | Matches data in all lists until the shortest list runs dry. This flag will omit data entries if lists have a different length
LongestList | 1 | Matches data in all lists until the longest list runs dry. This is the default behaviour
CrossReference | 2 | Matches data in all lists in all possible combinations. Careful, since this might results in stupendous amounts of data

See Also

Grasshopper.Kernel Namespace


GH_DataMapping Enumeration

[image]

Grasshopper SDK
GH_DataMapping Enumeration
See Also Send Feedback
Enumerates all parameter data mapping types.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_DataMapping
Visual Basic
Public Enumeration GH_DataMapping

Members

Member name | Value | Description
None | 0 | Data is not mapped.
Flatten | 1 | Data is flattened inside this parameter.
Graft | 2 | Data is grafted inside this parameter.

See Also

Grasshopper.Kernel Namespace


GH_DebugDescriptionWriter Class

[image]

Grasshopper SDK
GH_DebugDescriptionWriter Class
Members See Also Send Feedback
Writer object used to create debug logs.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_DebugDescriptionWriter
Visual Basic
Public Class GH_DebugDescriptionWriter

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_DebugDescriptionWriter

See Also

GH_DebugDescriptionWriter Members
Grasshopper.Kernel Namespace


GH_DebugDescriptionWriter Members

[image] [image]

Grasshopper SDK
GH_DebugDescriptionWriter Members
GH_DebugDescriptionWriter Class Constructors Methods Properties See Also Send Feedback

The GH_DebugDescriptionWriter type exposes the following members.

Constructors

 | Name | Description
Public method | GH_DebugDescriptionWriter | Initializes a new instance of the GH_DebugDescriptionWriter class

Methods

 | Name | Description
Public method | CloseBlock | Close the current block and decrease the depth by 1.
Public method | CreateBlock | Begin a new block. This will increase the depth by 1. You must call CloseBlock() if you call this function.
Public method | CreateLog | Get a single string that represents the entire log so far.
Public method | WriteLine()()()() | Write a new blank line to the log.
Public method | WriteLine(String) | Write a new line to the log.
Public method | WriteLine(String, array<Object>[]()[][]) | Write a new formatted line to the log.
Public method | WriteLogToFile | Write the log to a text file.

Properties

 | Name | Description
Public property | Depth | Gets the depth of the current writer. Depth is represented by whitespace in front of each line.

See Also

GH_DebugDescriptionWriter Class
Grasshopper.Kernel Namespace


GH_DebugDescriptionWriter Constructor

[image]

Grasshopper SDK
GH_DebugDescriptionWriter Constructor
GH_DebugDescriptionWriter Class See Also Send Feedback
Initializes a new instance of the GH_DebugDescriptionWriter class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_DebugDescriptionWriter()
Visual Basic
Public Sub New

See Also

GH_DebugDescriptionWriter Class
Grasshopper.Kernel Namespace


GH_DebugDescriptionWriter Methods

[image] [image]

Grasshopper SDK
GH_DebugDescriptionWriter Methods
GH_DebugDescriptionWriter Class See Also Send Feedback

The GH_DebugDescriptionWriter type exposes the following members.

Methods

 | Name | Description
Public method | CloseBlock | Close the current block and decrease the depth by 1.
Public method | CreateBlock | Begin a new block. This will increase the depth by 1. You must call CloseBlock() if you call this function.
Public method | CreateLog | Get a single string that represents the entire log so far.
Public method | WriteLine()()()() | Write a new blank line to the log.
Public method | WriteLine(String) | Write a new line to the log.
Public method | WriteLine(String, array<Object>[]()[][]) | Write a new formatted line to the log.
Public method | WriteLogToFile | Write the log to a text file.

See Also

GH_DebugDescriptionWriter Class
Grasshopper.Kernel Namespace


CloseBlock Method

[image]

Grasshopper SDK
GH_DebugDescriptionWriter..::..CloseBlock Method
GH_DebugDescriptionWriter Class See Also Send Feedback
Close the current block and decrease the depth by 1.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void CloseBlock()
Visual Basic
Public Sub CloseBlock

See Also

GH_DebugDescriptionWriter Class
Grasshopper.Kernel Namespace


CreateBlock Method

[image]

Grasshopper SDK
GH_DebugDescriptionWriter..::..CreateBlock Method
GH_DebugDescriptionWriter Class See Also Send Feedback
Begin a new block. This will increase the depth by 1. You must call CloseBlock() if you call this function.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void CreateBlock(
    string name
)
Visual Basic
Public Sub CreateBlock ( _
    name As String _
)

Parameters

name
Type: System..::..String

See Also

GH_DebugDescriptionWriter Class
Grasshopper.Kernel Namespace


CreateLog Method

[image]

Grasshopper SDK
GH_DebugDescriptionWriter..::..CreateLog Method
GH_DebugDescriptionWriter Class See Also Send Feedback
Get a single string that represents the entire log so far.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string CreateLog()
Visual Basic
Public Function CreateLog As String

See Also

GH_DebugDescriptionWriter Class
Grasshopper.Kernel Namespace


WriteLine Method

[image] [image]

Grasshopper SDK
GH_DebugDescriptionWriter..::..WriteLine Method
GH_DebugDescriptionWriter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WriteLine()()()() | Write a new blank line to the log.
Public method | WriteLine(String) | Write a new line to the log.
Public method | WriteLine(String, array<Object>[]()[][]) | Write a new formatted line to the log.

See Also

GH_DebugDescriptionWriter Class
GH_DebugDescriptionWriter Members
Grasshopper.Kernel Namespace


WriteLine Method

[image]

Grasshopper SDK
GH_DebugDescriptionWriter..::..WriteLine Method
GH_DebugDescriptionWriter Class See Also Send Feedback
Write a new blank line to the log.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void WriteLine()
Visual Basic
Public Sub WriteLine

See Also

GH_DebugDescriptionWriter Class
WriteLine Overload
Grasshopper.Kernel Namespace


WriteLine Method (String)

[image]

Grasshopper SDK
GH_DebugDescriptionWriter..::..WriteLine Method (String)
GH_DebugDescriptionWriter Class See Also Send Feedback
Write a new line to the log.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void WriteLine(
    string line
)
Visual Basic
Public Sub WriteLine ( _
    line As String _
)

Parameters

line
Type: System..::..String
Line to write.

See Also

GH_DebugDescriptionWriter Class
WriteLine Overload
Grasshopper.Kernel Namespace


WriteLine Method (String, Object[])

[image]

Grasshopper SDK
GH_DebugDescriptionWriter..::..WriteLine Method (String, array<Object>[]()[][])
GH_DebugDescriptionWriter Class See Also Send Feedback
Write a new formatted line to the log.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void WriteLine(
    string line,
    params Object[] args
)
Visual Basic
Public Sub WriteLine ( _
    line As String, _
    ParamArray args As Object() _
)

Parameters

line
Type: System..::..String
Line to write with formatting tags.
args
Type: array< System..::..Object >[]()[][]
Data to format.

See Also

GH_DebugDescriptionWriter Class
WriteLine Overload
Grasshopper.Kernel Namespace


WriteLogToFile Method

[image]

Grasshopper SDK
GH_DebugDescriptionWriter..::..WriteLogToFile Method
GH_DebugDescriptionWriter Class See Also Send Feedback
Write the log to a text file.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool WriteLogToFile(
    string path
)
Visual Basic
Public Function WriteLogToFile ( _
    path As String _
) As Boolean

Parameters

path
Type: System..::..String
Path of file to write to.

Return Value

True on success, false on failure.

See Also

GH_DebugDescriptionWriter Class
Grasshopper.Kernel Namespace


GH_DebugDescriptionWriter Properties

[image] [image]

Grasshopper SDK
GH_DebugDescriptionWriter Properties
GH_DebugDescriptionWriter Class See Also Send Feedback

The GH_DebugDescriptionWriter type exposes the following members.

Properties

 | Name | Description
Public property | Depth | Gets the depth of the current writer. Depth is represented by whitespace in front of each line.

See Also

GH_DebugDescriptionWriter Class
Grasshopper.Kernel Namespace


Depth Property

[image]

Grasshopper SDK
GH_DebugDescriptionWriter..::..Depth Property
GH_DebugDescriptionWriter Class See Also Send Feedback
Gets the depth of the current writer. Depth is represented by whitespace in front of each line.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int Depth { get; }
Visual Basic
Public ReadOnly Property Depth As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DebugDescriptionWriter.Depth"]

See Also

GH_DebugDescriptionWriter Class
Grasshopper.Kernel Namespace


GH_DisplayExpiredEventArgs Class

[image]

Grasshopper SDK
GH_DisplayExpiredEventArgs Class
Members See Also Send Feedback
Arguments for display events.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_DisplayExpiredEventArgs : EventArgs
Visual Basic
Public Class GH_DisplayExpiredEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Grasshopper.Kernel..::..GH_DisplayExpiredEventArgs

See Also

GH_DisplayExpiredEventArgs Members
Grasshopper.Kernel Namespace


GH_DisplayExpiredEventArgs Members

[image] [image]

Grasshopper SDK
GH_DisplayExpiredEventArgs Members
GH_DisplayExpiredEventArgs Class Constructors Fields Properties See Also Send Feedback

The GH_DisplayExpiredEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GH_DisplayExpiredEventArgs | Initializes a new instance of the GH_DisplayExpiredEventArgs class

Fields

 | Name | Description
Protected field | m_redraw |

Properties

 | Name | Description
Public property | ForceRedraw |

See Also

GH_DisplayExpiredEventArgs Class
Grasshopper.Kernel Namespace


GH_DisplayExpiredEventArgs Constructor

[image]

Grasshopper SDK
GH_DisplayExpiredEventArgs Constructor
GH_DisplayExpiredEventArgs Class See Also Send Feedback
Initializes a new instance of the GH_DisplayExpiredEventArgs class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_DisplayExpiredEventArgs(
    bool eForceRedraw
)
Visual Basic
Public Sub New ( _
    eForceRedraw As Boolean _
)

Parameters

eForceRedraw
Type: System..::..Boolean

See Also

GH_DisplayExpiredEventArgs Class
Grasshopper.Kernel Namespace


GH_DisplayExpiredEventArgs Fields

[image] [image]

Grasshopper SDK
GH_DisplayExpiredEventArgs Fields
GH_DisplayExpiredEventArgs Class See Also Send Feedback

The GH_DisplayExpiredEventArgs type exposes the following members.

Fields

 | Name | Description
Protected field | m_redraw |

See Also

GH_DisplayExpiredEventArgs Class
Grasshopper.Kernel Namespace


m_redraw Field

[image]

Grasshopper SDK
GH_DisplayExpiredEventArgs..::..m_redraw Field
GH_DisplayExpiredEventArgs Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected bool m_redraw
Visual Basic
Protected m_redraw As Boolean

See Also

GH_DisplayExpiredEventArgs Class
Grasshopper.Kernel Namespace


GH_DisplayExpiredEventArgs Properties

[image] [image]

Grasshopper SDK
GH_DisplayExpiredEventArgs Properties
GH_DisplayExpiredEventArgs Class See Also Send Feedback

The GH_DisplayExpiredEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ForceRedraw |

See Also

GH_DisplayExpiredEventArgs Class
Grasshopper.Kernel Namespace


ForceRedraw Property

[image]

Grasshopper SDK
GH_DisplayExpiredEventArgs..::..ForceRedraw Property
GH_DisplayExpiredEventArgs Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool ForceRedraw { get; }
Visual Basic
Public ReadOnly Property ForceRedraw As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DisplayExpiredEventArgs.ForceRedraw"]

See Also

GH_DisplayExpiredEventArgs Class
Grasshopper.Kernel Namespace


GH_DocContextEventArgs Class

[image]

Grasshopper SDK
GH_DocContextEventArgs Class
Members See Also Send Feedback
These arguments are passed along with SettingsChanged events on GH_Document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_DocContextEventArgs : EventArgs
Visual Basic
Public Class GH_DocContextEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Grasshopper.Kernel..::..GH_DocContextEventArgs

See Also

GH_DocContextEventArgs Members
Grasshopper.Kernel Namespace


GH_DocContextEventArgs Members

[image] [image]

Grasshopper SDK
GH_DocContextEventArgs Members
GH_DocContextEventArgs Class Properties See Also Send Feedback

The GH_DocContextEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Context | Gets the value of the document context flag at the time the event was raised, it may have been changed in between by other event handlers.
Public property | Document | Gets the document that raised the event.

See Also

GH_DocContextEventArgs Class
Grasshopper.Kernel Namespace


GH_DocContextEventArgs Properties

[image] [image]

Grasshopper SDK
GH_DocContextEventArgs Properties
GH_DocContextEventArgs Class See Also Send Feedback

The GH_DocContextEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Context | Gets the value of the document context flag at the time the event was raised, it may have been changed in between by other event handlers.
Public property | Document | Gets the document that raised the event.

See Also

GH_DocContextEventArgs Class
Grasshopper.Kernel Namespace


Context Property

[image]

Grasshopper SDK
GH_DocContextEventArgs..::..Context Property
GH_DocContextEventArgs Class See Also Send Feedback
Gets the value of the document context flag at the time the event was raised, it may have been changed in between by other event handlers.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_DocumentContext Context { get; }
Visual Basic
Public ReadOnly Property Context As GH_DocumentContext
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DocContextEventArgs.Context"]

See Also

GH_DocContextEventArgs Class
Grasshopper.Kernel Namespace


Document Property

[image]

Grasshopper SDK
GH_DocContextEventArgs..::..Document Property
GH_DocContextEventArgs Class See Also Send Feedback
Gets the document that raised the event.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Document Document { get; }
Visual Basic
Public ReadOnly Property Document As GH_Document
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DocContextEventArgs.Document"]

See Also

GH_DocContextEventArgs Class
Grasshopper.Kernel Namespace


GH_DocEnabledEventArgs Class

[image]

Grasshopper SDK
GH_DocEnabledEventArgs Class
Members See Also Send Feedback
These arguments are passed along with SettingsChanged events on GH_Document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_DocEnabledEventArgs : EventArgs
Visual Basic
Public Class GH_DocEnabledEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Grasshopper.Kernel..::..GH_DocEnabledEventArgs

See Also

GH_DocEnabledEventArgs Members
Grasshopper.Kernel Namespace


GH_DocEnabledEventArgs Members

[image] [image]

Grasshopper SDK
GH_DocEnabledEventArgs Members
GH_DocEnabledEventArgs Class Properties See Also Send Feedback

The GH_DocEnabledEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Document | Gets the document that raised the event.
Public property | Enabled | Gets the value of the document Enabled flag at the time the event was raised, it may have been changed in between by other event handlers.

See Also

GH_DocEnabledEventArgs Class
Grasshopper.Kernel Namespace


GH_DocEnabledEventArgs Properties

[image] [image]

Grasshopper SDK
GH_DocEnabledEventArgs Properties
GH_DocEnabledEventArgs Class See Also Send Feedback

The GH_DocEnabledEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Document | Gets the document that raised the event.
Public property | Enabled | Gets the value of the document Enabled flag at the time the event was raised, it may have been changed in between by other event handlers.

See Also

GH_DocEnabledEventArgs Class
Grasshopper.Kernel Namespace


Document Property

[image]

Grasshopper SDK
GH_DocEnabledEventArgs..::..Document Property
GH_DocEnabledEventArgs Class See Also Send Feedback
Gets the document that raised the event.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Document Document { get; }
Visual Basic
Public ReadOnly Property Document As GH_Document
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DocEnabledEventArgs.Document"]

See Also

GH_DocEnabledEventArgs Class
Grasshopper.Kernel Namespace


Enabled Property

[image]

Grasshopper SDK
GH_DocEnabledEventArgs..::..Enabled Property
GH_DocEnabledEventArgs Class See Also Send Feedback
Gets the value of the document Enabled flag at the time the event was raised, it may have been changed in between by other event handlers.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Enabled { get; }
Visual Basic
Public ReadOnly Property Enabled As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DocEnabledEventArgs.Enabled"]

See Also

GH_DocEnabledEventArgs Class
Grasshopper.Kernel Namespace


GH_DocFilePathEventArgs Class

[image]

Grasshopper SDK
GH_DocFilePathEventArgs Class
Members See Also Send Feedback
These arguments are passed along with FilePathChanged events on GH_Document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_DocFilePathEventArgs : EventArgs
Visual Basic
Public Class GH_DocFilePathEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Grasshopper.Kernel..::..GH_DocFilePathEventArgs

See Also

GH_DocFilePathEventArgs Members
Grasshopper.Kernel Namespace


GH_DocFilePathEventArgs Members

[image] [image]

Grasshopper SDK
GH_DocFilePathEventArgs Members
GH_DocFilePathEventArgs Class Constructors Properties See Also Send Feedback

The GH_DocFilePathEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GH_DocFilePathEventArgs | Create a new instance of the GH_DocFilePathEventArgs class.

Properties

 | Name | Description
Public property | Document | Gets the document that raised this event.
Public property | NewFilePath | Gets the new filepath, the one currently assigned to this document.
Public property | OldFilePath | Gets the old filepath, prior to the change that triggered this event.

See Also

GH_DocFilePathEventArgs Class
Grasshopper.Kernel Namespace


GH_DocFilePathEventArgs Constructor

[image]

Grasshopper SDK
GH_DocFilePathEventArgs Constructor
GH_DocFilePathEventArgs Class See Also Send Feedback
Create a new instance of the GH_DocFilePathEventArgs class.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_DocFilePathEventArgs(
    GH_Document document,
    string oldPath,
    string newPath
)
Visual Basic
Public Sub New ( _
    document As GH_Document, _
    oldPath As String, _
    newPath As String _
)

Parameters

document
Type: Grasshopper.Kernel..::..GH_Document
oldPath
Type: System..::..String
newPath
Type: System..::..String

See Also

GH_DocFilePathEventArgs Class
Grasshopper.Kernel Namespace


GH_DocFilePathEventArgs Properties

[image] [image]

Grasshopper SDK
GH_DocFilePathEventArgs Properties
GH_DocFilePathEventArgs Class See Also Send Feedback

The GH_DocFilePathEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Document | Gets the document that raised this event.
Public property | NewFilePath | Gets the new filepath, the one currently assigned to this document.
Public property | OldFilePath | Gets the old filepath, prior to the change that triggered this event.

See Also

GH_DocFilePathEventArgs Class
Grasshopper.Kernel Namespace


Document Property

[image]

Grasshopper SDK
GH_DocFilePathEventArgs..::..Document Property
GH_DocFilePathEventArgs Class See Also Send Feedback
Gets the document that raised this event.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Document Document { get; }
Visual Basic
Public ReadOnly Property Document As GH_Document
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DocFilePathEventArgs.Document"]

See Also

GH_DocFilePathEventArgs Class
Grasshopper.Kernel Namespace


NewFilePath Property

[image]

Grasshopper SDK
GH_DocFilePathEventArgs..::..NewFilePath Property
GH_DocFilePathEventArgs Class See Also Send Feedback
Gets the new filepath, the one currently assigned to this document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string NewFilePath { get; }
Visual Basic
Public ReadOnly Property NewFilePath As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DocFilePathEventArgs.NewFilePath"]

See Also

GH_DocFilePathEventArgs Class
Grasshopper.Kernel Namespace


OldFilePath Property

[image]

Grasshopper SDK
GH_DocFilePathEventArgs..::..OldFilePath Property
GH_DocFilePathEventArgs Class See Also Send Feedback
Gets the old filepath, prior to the change that triggered this event.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string OldFilePath { get; }
Visual Basic
Public ReadOnly Property OldFilePath As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DocFilePathEventArgs.OldFilePath"]

See Also

GH_DocFilePathEventArgs Class
Grasshopper.Kernel Namespace


GH_DocModifiedEventArgs Class

[image]

Grasshopper SDK
GH_DocModifiedEventArgs Class
Members See Also Send Feedback
These arguments are passed along with ModifiedChanged events on GH_Document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_DocModifiedEventArgs : EventArgs
Visual Basic
Public Class GH_DocModifiedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Grasshopper.Kernel..::..GH_DocModifiedEventArgs

See Also

GH_DocModifiedEventArgs Members
Grasshopper.Kernel Namespace


GH_DocModifiedEventArgs Members

[image] [image]

Grasshopper SDK
GH_DocModifiedEventArgs Members
GH_DocModifiedEventArgs Class Properties See Also Send Feedback

The GH_DocModifiedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Document | Gets the document that raised the event.
Public property | Modified | Gets the value of the document Modified flag at the time the event was raised, it may have been changed in between by other event handlers.

See Also

GH_DocModifiedEventArgs Class
Grasshopper.Kernel Namespace


GH_DocModifiedEventArgs Properties

[image] [image]

Grasshopper SDK
GH_DocModifiedEventArgs Properties
GH_DocModifiedEventArgs Class See Also Send Feedback

The GH_DocModifiedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Document | Gets the document that raised the event.
Public property | Modified | Gets the value of the document Modified flag at the time the event was raised, it may have been changed in between by other event handlers.

See Also

GH_DocModifiedEventArgs Class
Grasshopper.Kernel Namespace


Document Property

[image]

Grasshopper SDK
GH_DocModifiedEventArgs..::..Document Property
GH_DocModifiedEventArgs Class See Also Send Feedback
Gets the document that raised the event.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Document Document { get; }
Visual Basic
Public ReadOnly Property Document As GH_Document
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DocModifiedEventArgs.Document"]

See Also

GH_DocModifiedEventArgs Class
Grasshopper.Kernel Namespace


Modified Property

[image]

Grasshopper SDK
GH_DocModifiedEventArgs..::..Modified Property
GH_DocModifiedEventArgs Class See Also Send Feedback
Gets the value of the document Modified flag at the time the event was raised, it may have been changed in between by other event handlers.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Modified { get; }
Visual Basic
Public ReadOnly Property Modified As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DocModifiedEventArgs.Modified"]

See Also

GH_DocModifiedEventArgs Class
Grasshopper.Kernel Namespace


GH_DocObjectEventArgs Class

[image]

Grasshopper SDK
GH_DocObjectEventArgs Class
Members See Also Send Feedback
These arguments are passed along with ObjectsAdded and ObjectsRemoved events on GH_Document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_DocObjectEventArgs : EventArgs
Visual Basic
Public Class GH_DocObjectEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Grasshopper.Kernel..::..GH_DocObjectEventArgs

See Also

GH_DocObjectEventArgs Members
Grasshopper.Kernel Namespace


GH_DocObjectEventArgs Members

[image] [image]

Grasshopper SDK
GH_DocObjectEventArgs Members
GH_DocObjectEventArgs Class Properties See Also Send Feedback

The GH_DocObjectEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Gets all the attributes that are associated with all objects in the event.
Public property | Document | Gets the document that raised the event.
Public property | Object | Gets the object to which this event pertains.
Public property | ObjectCount | Gets the number of objects in this event.
Public property | Objects | Gets a readonly list of the objects to which this event pertains.

See Also

GH_DocObjectEventArgs Class
Grasshopper.Kernel Namespace


GH_DocObjectEventArgs Properties

[image] [image]

Grasshopper SDK
GH_DocObjectEventArgs Properties
GH_DocObjectEventArgs Class See Also Send Feedback

The GH_DocObjectEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Gets all the attributes that are associated with all objects in the event.
Public property | Document | Gets the document that raised the event.
Public property | Object | Gets the object to which this event pertains.
Public property | ObjectCount | Gets the number of objects in this event.
Public property | Objects | Gets a readonly list of the objects to which this event pertains.

See Also

GH_DocObjectEventArgs Class
Grasshopper.Kernel Namespace


Attributes Property

[image]

Grasshopper SDK
GH_DocObjectEventArgs..::..Attributes Property
GH_DocObjectEventArgs Class See Also Send Feedback
Gets all the attributes that are associated with all objects in the event.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<IGH_Attributes> Attributes { get; }
Visual Basic
Public ReadOnly Property Attributes As List(Of IGH_Attributes)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DocObjectEventArgs.Attributes"]

See Also

GH_DocObjectEventArgs Class
Grasshopper.Kernel Namespace


Document Property

[image]

Grasshopper SDK
GH_DocObjectEventArgs..::..Document Property
GH_DocObjectEventArgs Class See Also Send Feedback
Gets the document that raised the event.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Document Document { get; }
Visual Basic
Public ReadOnly Property Document As GH_Document
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DocObjectEventArgs.Document"]

See Also

GH_DocObjectEventArgs Class
Grasshopper.Kernel Namespace


Object Property

[image]

Grasshopper SDK
GH_DocObjectEventArgs..::..Object Property
GH_DocObjectEventArgs Class See Also Send Feedback
Gets the object to which this event pertains.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_DocumentObject this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Object ( _
    index As Integer _
) As IGH_DocumentObject
    Get

Parameters

index
Type: System..::..Int32

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DocObjectEventArgs.Object(System.Int32)"]

See Also

GH_DocObjectEventArgs Class
Grasshopper.Kernel Namespace


ObjectCount Property

[image]

Grasshopper SDK
GH_DocObjectEventArgs..::..ObjectCount Property
GH_DocObjectEventArgs Class See Also Send Feedback
Gets the number of objects in this event.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int ObjectCount { get; }
Visual Basic
Public ReadOnly Property ObjectCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DocObjectEventArgs.ObjectCount"]

See Also

GH_DocObjectEventArgs Class
Grasshopper.Kernel Namespace


Objects Property

[image]

Grasshopper SDK
GH_DocObjectEventArgs..::..Objects Property
GH_DocObjectEventArgs Class See Also Send Feedback
Gets a readonly list of the objects to which this event pertains.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public ReadOnlyCollection<IGH_DocumentObject> Objects { get; }
Visual Basic
Public ReadOnly Property Objects As ReadOnlyCollection(Of IGH_DocumentObject)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DocObjectEventArgs.Objects"]

See Also

GH_DocObjectEventArgs Class
Grasshopper.Kernel Namespace


GH_DocSettingsEventArgs Class

[image]

Grasshopper SDK
GH_DocSettingsEventArgs Class
Members See Also Send Feedback
These arguments are passed along with SettingsChanged events on GH_Document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_DocSettingsEventArgs : EventArgs
Visual Basic
Public Class GH_DocSettingsEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Grasshopper.Kernel..::..GH_DocSettingsEventArgs

See Also

GH_DocSettingsEventArgs Members
Grasshopper.Kernel Namespace


GH_DocSettingsEventArgs Members

[image] [image]

Grasshopper SDK
GH_DocSettingsEventArgs Members
GH_DocSettingsEventArgs Class Properties See Also Send Feedback

The GH_DocSettingsEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Document | Gets the document that raised the event.
Public property | Kind | Gets the type of setting that was changed.

See Also

GH_DocSettingsEventArgs Class
Grasshopper.Kernel Namespace


GH_DocSettingsEventArgs Properties

[image] [image]

Grasshopper SDK
GH_DocSettingsEventArgs Properties
GH_DocSettingsEventArgs Class See Also Send Feedback

The GH_DocSettingsEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Document | Gets the document that raised the event.
Public property | Kind | Gets the type of setting that was changed.

See Also

GH_DocSettingsEventArgs Class
Grasshopper.Kernel Namespace


Document Property

[image]

Grasshopper SDK
GH_DocSettingsEventArgs..::..Document Property
GH_DocSettingsEventArgs Class See Also Send Feedback
Gets the document that raised the event.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Document Document { get; }
Visual Basic
Public ReadOnly Property Document As GH_Document
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DocSettingsEventArgs.Document"]

See Also

GH_DocSettingsEventArgs Class
Grasshopper.Kernel Namespace


Kind Property

[image]

Grasshopper SDK
GH_DocSettingsEventArgs..::..Kind Property
GH_DocSettingsEventArgs Class See Also Send Feedback
Gets the type of setting that was changed.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_DocumentSettings Kind { get; }
Visual Basic
Public ReadOnly Property Kind As GH_DocumentSettings
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DocSettingsEventArgs.Kind"]

See Also

GH_DocSettingsEventArgs Class
Grasshopper.Kernel Namespace


GH_Document Class

[image]

Grasshopper SDK
GH_Document Class
Members See Also Send Feedback
Represents a single Grasshopper document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class GH_Document : GH_ISerializable,
    IDisposable, IComparable<GH_Document>, IGH_DebugDescription
Visual Basic
Public NotInheritable Class GH_Document _
    Implements GH_ISerializable, IDisposable, IComparable(Of GH_Document),  _
    IGH_DebugDescription

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_Document

See Also

GH_Document Members
Grasshopper.Kernel Namespace


GH_Document Members

[image] [image]

Grasshopper SDK
GH_Document Members
GH_Document Class Constructors Methods Fields Properties Events See Also Send Feedback

The GH_Document type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Document | Constructor for GH_Document. Makes sure all important members are initialized.

Methods

 | Name | Description
Public method | ActiveObjects | Returns all normal objects in the document that implement the IGH_ActiveObject interface
Public method | AddObject | Add a new object to the document. If the object is already contained, nothing will happen
Public method | AlignObjects(GH_Align, GH_Distribute) | Perform alignment and distribution logic on all selected objects.
Public method | AlignObjects(GH_Align, GH_Distribute, List<(Of <<'(IGH_DocumentObject>)>>)) | Perform alignment and distribution logic on a set of objects.
Public method | AppendToDebugLog | Useful for creating textual representations of this document for debugging purposes.
Public method | ArrangeObject | Rearrange the stack order of the object.
Public method | ArrangeObjects | Rearrange the stack order of a collection of objects.
Public method | AssociateWithRhinoDocument | Associate this GH_Document with the currently active Rhino document. This only works if both the 3dm and the ghx file have been saved at least once.
Public method | AutoSave(GH_AutoSaveTrigger) | Creates a new autosave file on the disk. The previous autosave file (assuming it exists) will be temporarily renamed and eventually deleted entirely. Note: AutoSave is only possible on Documents that have TopLevel Rank and a valid FilePath.
Public method | AutoSave(GH_AutoSaveTrigger, Guid) | Creates a new autosave file on the disk. The previous autosave file (assuming it exists) will be temporarily renamed and eventually deleted entirely. Note: AutoSave is only possible on Documents that have TopLevel Rank and a valid FilePath.
 | AutoSaveFileName | Computes the autosave filename for a full grasshopper filepath.
Public method | BoundingBox | Returns the boundingbox of all the normal attributes. If the document contains no normal attributes an Empty RectangleF structure is returned.
Public method | BringSelectionToTop | Move the selection set to the top of the visible stack
Public method | ClearIgnoreList | Clears the Object Exception Ignore List.
Public method | ClearReferenceTable | Destroys the Referenced object table in the Rhino event watcher. You must call this function if you either add or remove a reference to a Rhino object.
Public method | CloseAllSubsidiaries | Iterate over all subsidiary documents and close them all without saving.
Public method | ClusterInputHooks | Gets a sorted list of all the cluster input hooks.
Public method | ClusterInstanceCount | Counts the number of instances of a specific cluster document ID.
Public method | ClusterOutputHooks | Gets a sorted list of all the cluster output hooks.
Public method | CompareTo | Compare two documents. This function does not compare document content.
Public method | ConstructDocumentTree | Create a hierarchical document tree of ownership with this document as the root.
Public method | ContainsClusterHooks | Tests whether this document contains at least one cluster hook.
Public method | ConvertFullNamesToNickNames | Convert all nicknames to original nicknames if they are equal to the default full name. There will be no undo record associated with this operation.
Public method | ConvertNickNamesToFullNames | Convert all nicknames to full names, if they are equal to the default nickname. There will be no undo record associated with this operation.
Public method | CreateAutomaticClusterHooks | Add an input hook for every non-optional input parameter with no persistent data and no sources. Then add an output hook for every floating parameter without recipients, and for every first component output parameter where the parent component has no recipients.
Public method | CreateCompleteProxy | Create a complete RCP_Proxy instance for the entire document.
Public method | CreateConnectivityDiagram | Gets the connectivity diagram for the current state of this document.
Public method | CreateExpressionParser | Create a new Expression Solver preloaded with the constants defined in this document.
Public method | DefineConstant | Add a new constant to the document. Constants are not case-sensitive, when you define a constant with an existing name, the old one will be replaced. Note: constants are as of yet unused. Eventually they are supposed to become accessible to all expressions running inside a document.
Public method | DeselectAll | Deselect all top-level attributes.
Public method | DestroyAttributeCache | Destroys the Attribute cache. Call this function whenever you do something which might affect attributes.
Public method | DestroyAutoSaveFiles | Destroys all autosave files and backup files that are associated with this document. Only call this function when you are certain that the document has been properly saved and no changes have occured since.
Public method | DestroyObjectTable | Erase the Object fast lookup table. You must call this whenever you add or remove objects to or from the document while circumventing the regular channels.
Public method | DestroyPreviewMeshes | Attempts to destroy all the preview meshes in this document. It might not work for all objects, but this is still your best bet.
Public method | DestroyProxySources | Remove all remaining proxy sources from the document.
Public method | DisabledObjects | Returns all disabled objects in the document
Public method | Dispose | When you discard documents you must call Dispose or the Viewport Display event handlers will not be disconnected.
 | DuplicateDocument | Attempt to duplicate a document.
Public method | EnabledObjects | Returns all enabled objects in the document
Public method | ExpandSelection | Grow or shift the selection set based on source and recipient links
Public method | ExpirePreview | Expires the preview caches of the conduit.
Public method | ExpireSolution | Expire the entire solution. This will blank all objects.
 | FilterActive | Filter a list of objects.
 | FilterDisabled | Filter a list of objects.
 | FilterEnabled | Filter a list of objects.
 | FilterInactive | Filter a list of objects.
Public method | FilterObjects(GH_Filter, GH_Filter, GH_Filter) | Returns all objects in the document that pass the filter specification
 | FilterObjects(List<(Of <<'(IGH_DocumentObject>)>>), GH_Filter, GH_Filter, GH_Filter) | Filter a list of objects using several filters at once
 | FilterSelected | Filter a list of objects.
 | FilterUnselected | Filter a list of objects.
Public method | FindAllDownstreamObjects(IGH_ActiveObject) | Find all objects that depend in some way on the Source.
Public method | FindAllDownstreamObjects(List<(Of <<'(IGH_ActiveObject>)>>)) | Find all objects that depend in some way on the Source collection
Public method | FindAllDownstreamObjects(IGH_ActiveObject, GH_Document..::..GH_ActiveObjectFilter) | Find all objects that depend in some way on the Source.
Public method | FindAllDownstreamObjects(List<(Of <<'(IGH_ActiveObject>)>>), GH_Document..::..GH_ActiveObjectFilter) | Find all objects that depend in some way on the Source collection
Public method | FindAttribute(Guid) | Find the object that matches the ID
Public method | FindAttribute(PointF, Boolean) | Search for attributes that contain a certain point. The attribute balloon boxes are also taken into account.
Public method | FindAttributeByGrip(PointF, Boolean, Int32) | Search for attributes that contain grips near the search locus
Public method | FindAttributeByGrip(PointF, Boolean, Boolean, Boolean, Int32) | Search for attributes that contain grips near the search locus
Public method | FindClusters(Guid) | Find all the clusters that have a matching ID.
Public method | FindClusters(String) | Find all the clusters that have a matching filepath.
Public method | FindComponent(Point) | Search for components that contain the locus
Public method | FindComponent(Guid) | Search for components using an ID filter
Public method | FindFloatingParameter | Search for floating parameters that contain the locus
Public method | FindInputParameter | Search for input (upstream) parameters that contain the locus
Public method | FindObject(PointF, Single) | Find the topmost object that is closest to the point
Public method | FindObject(Guid, Boolean) | Find the object that matches the ID.
Public method | FindObject<(Of <<'(T>)>>)(Guid, Boolean) | Find the object that matches the ID.
Public method | FindObjects | Find the objects in the document that match the search term. Top level object names and nicknames are searched, as well as descriptions. Some objects are special cased to allow for more targeted searches. Data descriptions are not searched.
Public method | FindOutputParameter | Search for output (downstream) parameters that contain the locus
Public method | FindParameter | Search for parameters using an ID filter
Public method | GetAllInstanceIDs | Get a sorted list of all the IGH_DocumentObject instance IDs in this document.
Public method | InactiveObjects | Returns all objects in the document that don't implement the IGH_ActiveObject interface
Public method | InvertSelection | Invert the selected state of all top-level attributes.
 | IsEscapeKeyDown | Gets whether the escape key was pressed since the last time this function was called. Though in reality the actual escape state is checked no more than once every 50 milliseconds or so, which should be sufficient for a smooth user experience.
Public method | MergeDocument(GH_Document) | Hoist all objects from another document into this one.
Public method | MergeDocument(GH_Document, Boolean) | Hoist all objects from another document into this one.
Public method | MergeDocument(GH_Document, Boolean, Boolean) | Hoist all objects from another document into this one.
Public method | Modified | Sets the modified flag of this document.
Public method | MutateAllIds | Change all the instance UUIDs of all objects in the document. Be sure to resolve all proxy sources before mutating IDs. This function will ensure all groups are updated appropriately.
Public method | NewSolution(Boolean) | Start a new solution.
Public method | NewSolution(Boolean, GH_SolutionMode) | Start a new solution.
 | NonBlankFilter | This delegate can be used in the FindAllDownstreamObjects(...) methods. Only includes objects that are non-blank and non-failed.
 | NullFilter | This delegate can be used in the FindAllDownstreamObjects(...) methods. Includes all objects.
Public method | OnContextChanged | Raise the ContextChanged event.
Public method | OnEnabledChanged | Raise the EnabledChanged event.
Public method | OnFilePathChanged | Raise the FilePathChanged event.
Public method | OnModifiedChanged | Raise the ModifiedChanged event
Public method | OnObjectAdded | Raise the ObjectsAdded event.
Public method | OnObjectDeleted | Raise the ObjectsDeleted event.
Public method | OnObjectsAdded | Raise the ObjectsAdded event.
Public method | OnObjectsDeleted | Raise the ObjectsDeleted event.
Public method | OnSettingsChanged | Raise the SettingsChanged event.
Public method | OnUndoStateChanged | Raise the UndoStateChanged event.
Public method | PreviewCurrentMeshParameters | Gets the currently relevant meshing parameters (do not modify the instance as it may be shared).
Public method | Read | Standard archiving function. Will deserialize the entire document.
Public method | Redo | Perform the first redo event.
Public method | RelevantObjectAtPoint(PointF) | Find the most relevant object at a given canvas location. The most relevant object might be a regular Object (Component or Parameter), it might be an attribute grip, an attribute balloon, a wire or a group.
Public method | RelevantObjectAtPoint(PointF, GH_RelevantObjectFilter) | Find the most relevant object at a given canvas location. The most relevant object might be a regular Object (Component or Parameter), it might be an attribute grip, an attribute balloon, a wire or a group.
Public method | RemoveObject(IGH_Attributes, Boolean) | Remove the top-level object in the attribute tree from the document. This method does not add an Undo event, that is the responsibility of the caller.
Public method | RemoveObject(IGH_DocumentObject, Boolean) | Remove the object from the document. This removal is the precursor to object deletion. Do not call this function if you intend to transfer the object to another GH_Document. This method does not add an Undo event, that is the responsibility of the caller.
Public method | RemoveObjects | Remove the specified objects from the document. This removal is the precursor to object deletion. Do not call this function if you intend to transfer the objects to another GH_Document. This method does not add an Undo event, that is the responsibility of the caller.
Public method | RemoveSelection | Delete all the objects in the selection set. This method does not record an Undo event, that is the responsibility of the caller.
Public method | RepairProxySources | Attempts to resolve all proxy sources in the document.
Public method | ReplaceProxySources | Replace all remaining proxy sources in the document with UnresolvedProxy Objects.
Public method | RequestAbortSolution | Set the requestabort flag. The solution will be aborted whenever the current active object is completed. It is also possible that active objects themselves implement an abortion mechanism, in which case abortion might occur even sooner.
Public method | ScheduleSolution(Int32) | Schedule a new solution after a specified time interval. The schedule is erased if another solution is triggered before the schedule is executed. Tight schedules override loose schedules. If this method is called during a solution, the schedule will be started after the current solution completes.
Public method | ScheduleSolution(Int32, GH_Document..::..GH_ScheduleDelegate) | Schedule a new solution after a specified time interval. The schedule is erased if another solution is triggered before the schedule is executed. Tight schedules override loose schedules. If this method is called during a solution, the schedule will be started after the current solution completes.
Public method | Select(GH_RelevantObjectData) | Default pick selection behaviour. (looks at current Shift + Control modifier states to determine addition/removal)
Public method | Select(GH_RelevantObjectData, Boolean, Boolean) | Default pick selection behaviour
Public method | SelectAll | Select all top-level attributes.
Public method | SelectedObjects | Returns all selected objects in the document
Public method | SetEnabledFlags(Boolean) | Set the enabled flags of all selected objects to true or false
Public method | SetEnabledFlags(List<(Of <<'(IGH_DocumentObject>)>>), Boolean) | Set the enabled flags of all specified objects to true or false
Public method | SetPreviewFlags(Boolean) | Set the preview flags of all selected objects to true or false
Public method | SetPreviewFlags(List<(Of <<'(IGH_DocumentObject>)>>), Boolean) | Set the preview flags of all specified objects to true or false
Public method | ShowPreviewSettings | Display the Preview settings dialog.
Public method | SolutionProgress | Returns the progress of the current solution.
Public method | ToggleEnabledFlags()()()() | Toggle the enabled flags of all selected objects
Public method | ToggleEnabledFlags(List<(Of <<'(IGH_DocumentObject>)>>)) | Toggle the enabled flags of all specified objects
Public method | TogglePreviewFlags()()()() | Toggle the preview flags of all selected objects
Public method | TogglePreviewFlags(List<(Of <<'(IGH_DocumentObject>)>>)) | Toggle the preview flags of all specified objects
Public method | ToString | A document serializes itself using the filename of the current path. This is useful for sorting purposes and ListBoxes. (Overrides Object..::..ToString()()()().)
Public method | TranslateObjects | Offset objects by a certain distance in X and Y
Public method | Undo | Perform the first undo event.
Public method | UnselectedObjects | Returns all unselected objects in the document
Public method | UpdateAllSubsidiaries | Iterate over all subsidiary documents and update them with their respective owners. If a subsidiary hasn't been modified, it will not be updated and it will not be counted.
Public method | Write(GH_IWriter) | Standard archiving function. Will serialize the entire document.
Public method | Write(GH_IWriter, IList<(Of <<'(IGH_DocumentObject>)>>)) | Special function that allows writing of a custom object list. This function is used when partial documents need to be serialized such as when exporting or during clipboard operations.

Fields

Name | Description
ScheduleInactive | Defined the delay used to indicate the absence of a schedule.
ScheduleRecursive | Defines the delay used to indicate the schedule should be immedate and recursive.

Properties

 | Name | Description
Public property | AbortRequested | Gets the abortrequested flag state.
Public property | AttributeCount | Returns the total number of attributes in the document. Both Normal and Hidden ones
Public property | Attributes | Returns a list of all the attributes in this document. This includes attributes for nested objects such as input or output parameters.
Public property | Author | Gets the author details associated with this document.
Public property | ConstantServer | Gets the dictionary of constants defined in this document.
Public property | Context | Gets or sets the context for this document. Note that the context is not a state so much as an action. Therefore it is not particularly useful to read the context after the fact, rather, context is mostly intended to be a setter, not a getter. When you set the context, all top-level document objects will be informed and the ContextChanged event will be raised.
 | DefaultPreviewColour | Gets or sets the default preview colour for normal objects.
 | DefaultSelectedPreviewColour | Gets or sets the default preview colour for normal objects.
Public property | DisplayName | Gets the display name for this document. The display name is highly context sensitive and is only supposed to give the user a good idea of which document this is and whether it has been modified.
Public property | DocumentID | Gets the document Id. The Id is assigned at construction and never changed. Note: clusters may choose to modify the Id of their internal documents.
Public property | Enabled | Gets or sets the enabled state for this document. Enabled documents respond to events and display their previews in the Rhino viewport.
 | EnableSolutions | Gets or sets a global variable that indicates whether solutions are allowed to be recomputed. When this flag is off, the solver will be disabled and the event watchers should be silent.
Public property | EventServer | Gets the event server that belongs to this document. The Event server may be in an inactive state, but it is never null.
Public property | FilePath | Gets or sets the file path of this document. If the file path is not set Nothing is returned.
Public property | IgnoredCount | Returns the total numbers of components currently in the Object Exception Ignore List.
Public property | IsFilePathDefined | Returns True if the filename flag of this document has been set
Public property | IsModified | Gets or sets the modified flag. If the new value differs from the old value, the ModifiedChanged() event is raised.
Public property | ModifiedSubsidiaries | Gets the number of modified subsidiary documents.
Public property | Nested | Gets or sets whether this document is nested. A nested document is always part of some other document and is therefore unknown to the DocumentServer and the Canvas.
Public property | ObjectCount | Returns the total number of top-level objects in the document.
Public property | Objects | Returns a list of all normal, top-level objects.
Public property | ObjectSpan | Gets the total timespan for all objects.
Public property | Owner | Gets or sets the owner of this document. A document is typically owned when it is subsidiary to some object, such as a cluster.
Public property | PreviewColour | Gets or sets the colour of unselected preview geometry.
Public property | PreviewColourSelected | Gets or sets the colour of selected preview geometry.
Public property | PreviewCustomMeshParameters | Gets or sets the Custom Meshing Parameters for this document, these are only used when PreviewMeshType = GH_PreviewMesh.Custom
Public property | PreviewFilter | Gets or set the preview filter.
Public property | PreviewMeshType | Gets or sets the preview mesh type for this document.
Public property | PreviewMode | Gets or sets the preview display mode and makes sure the conduit instance of this class is set to match.
Public property | Profiler | Gets or sets the profiler mode used in this document.
Public property | Properties | The properties of this document
Public property | RaiseEvents | If RaiseEvents is set to false, all the On....() methods of this document will stop raising events.
Public property | RemotePanelProxy | Gets or sets the Remote Control Panel proxy description for this document.
Public property | RuntimeID | Gets the runtime ID of this document. RuntimeID is assigned once and never changed. It is also not deserialized so every document will always have a unique ID when loaded.
Public property | ScheduleDelay | Gets the delay for the next scheduled solution. If there is no solution scheduled the delay will be negative.
Public property | SelectedCount | Gets the number of selected objects
Public property | SelectionTopology | Gets the selection topology of the document.
Public property | SolutionDepth | Gets the number of nested solutions currently running. If no solutions are running, the depth should be zero. If one solution is runnnig, the depth should be one. Higher depths are only possible if a new solution was scheduled from within an existing solution with delay=0ms.
Public property | SolutionHistory | Gets a list of the last 1000 solution timespans, from oldest to youngest.
Public property | SolutionSpan | Gets the timespan for the most recent solution.
Public property | SolutionState | Gets the state of this document.
Public property | StateServer | Gets the list of stored states in this document
Public property | Thumbnail | Gets or sets the thumbnail bitmap for this document.
Public property | UndoServer | Gets the UndoServer instance that belongs to this document.
Public property | UndoUtil | Gets a temporary undo utility instance that allows you to easily create standard undo events.

Events

 | Name | Description
Public event | ContextChanged | The context for this document was changed.
 | DefaultPreviewColourChanged | This even is raised whenever the global default for Normal preview colour is changed.
 | DefaultSelectedPreviewColourChanged | This even is raised whenever the global default for Selected preview colour is changed.
Public event | EnabledChanged | The Enabled state was changed on this document.
 | EnableSolutionsChanged | Raised whenever the Shared EnabledSolutions property is changed.
Public event | FilePathChanged | Raised whenever the FilePath of the document is modified.
Public event | ModifiedChanged | The modified flag on the document was changed.
Public event | ObjectsAdded | Raised after a collection of objects was added to the document.
Public event | ObjectsDeleted | Raised after a collection of objects was removed from the document. At this point, the objects still exist, but they no longer belong to this document.
Public event | SettingsChanged | Some settings of the document were changed.
Public event | SolutionEnd | This event is raised whenever a new solution request has been handled. Even if the document is locked.
Public event | SolutionStart | This event is raised whenever a new solution is requested. Even if the document is locked.
Public event | UndoStateChanged | Raised whenever there is a change to the document undo/redo stack.

See Also

GH_Document Class
Grasshopper.Kernel Namespace


GH_Document Constructor

[image]

Grasshopper SDK
GH_Document Constructor
GH_Document Class See Also Send Feedback
Constructor for GH_Document. Makes sure all important members are initialized.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Document()
Visual Basic
Public Sub New

See Also

GH_Document Class
Grasshopper.Kernel Namespace


GH_Document Fields

[image] [image]

Grasshopper SDK
GH_Document Fields
GH_Document Class See Also Send Feedback

The GH_Document type exposes the following members.

Fields

Name | Description
ScheduleInactive | Defined the delay used to indicate the absence of a schedule.
ScheduleRecursive | Defines the delay used to indicate the schedule should be immedate and recursive.

See Also

GH_Document Class
Grasshopper.Kernel Namespace


ScheduleInactive Field

[image]

Grasshopper SDK
GH_Document..::..ScheduleInactive Field
GH_Document Class See Also Send Feedback
Defined the delay used to indicate the absence of a schedule.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const int ScheduleInactive
Visual Basic
Public Const ScheduleInactive As Integer

See Also

GH_Document Class
Grasshopper.Kernel Namespace


ScheduleRecursive Field

[image]

Grasshopper SDK
GH_Document..::..ScheduleRecursive Field
GH_Document Class See Also Send Feedback
Defines the delay used to indicate the schedule should be immedate and recursive.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const int ScheduleRecursive
Visual Basic
Public Const ScheduleRecursive As Integer

See Also

GH_Document Class
Grasshopper.Kernel Namespace


GH_Document Methods

[image] [image]

Grasshopper SDK
GH_Document Methods
GH_Document Class See Also Send Feedback

The GH_Document type exposes the following members.

Methods

 | Name | Description
Public method | ActiveObjects | Returns all normal objects in the document that implement the IGH_ActiveObject interface
Public method | AddObject | Add a new object to the document. If the object is already contained, nothing will happen
Public method | AlignObjects(GH_Align, GH_Distribute) | Perform alignment and distribution logic on all selected objects.
Public method | AlignObjects(GH_Align, GH_Distribute, List<(Of <<'(IGH_DocumentObject>)>>)) | Perform alignment and distribution logic on a set of objects.
Public method | AppendToDebugLog | Useful for creating textual representations of this document for debugging purposes.
Public method | ArrangeObject | Rearrange the stack order of the object.
Public method | ArrangeObjects | Rearrange the stack order of a collection of objects.
Public method | AssociateWithRhinoDocument | Associate this GH_Document with the currently active Rhino document. This only works if both the 3dm and the ghx file have been saved at least once.
Public method | AutoSave(GH_AutoSaveTrigger) | Creates a new autosave file on the disk. The previous autosave file (assuming it exists) will be temporarily renamed and eventually deleted entirely. Note: AutoSave is only possible on Documents that have TopLevel Rank and a valid FilePath.
Public method | AutoSave(GH_AutoSaveTrigger, Guid) | Creates a new autosave file on the disk. The previous autosave file (assuming it exists) will be temporarily renamed and eventually deleted entirely. Note: AutoSave is only possible on Documents that have TopLevel Rank and a valid FilePath.
 | AutoSaveFileName | Computes the autosave filename for a full grasshopper filepath.
Public method | BoundingBox | Returns the boundingbox of all the normal attributes. If the document contains no normal attributes an Empty RectangleF structure is returned.
Public method | BringSelectionToTop | Move the selection set to the top of the visible stack
Public method | ClearIgnoreList | Clears the Object Exception Ignore List.
Public method | ClearReferenceTable | Destroys the Referenced object table in the Rhino event watcher. You must call this function if you either add or remove a reference to a Rhino object.
Public method | CloseAllSubsidiaries | Iterate over all subsidiary documents and close them all without saving.
Public method | ClusterInputHooks | Gets a sorted list of all the cluster input hooks.
Public method | ClusterInstanceCount | Counts the number of instances of a specific cluster document ID.
Public method | ClusterOutputHooks | Gets a sorted list of all the cluster output hooks.
Public method | CompareTo | Compare two documents. This function does not compare document content.
Public method | ConstructDocumentTree | Create a hierarchical document tree of ownership with this document as the root.
Public method | ContainsClusterHooks | Tests whether this document contains at least one cluster hook.
Public method | ConvertFullNamesToNickNames | Convert all nicknames to original nicknames if they are equal to the default full name. There will be no undo record associated with this operation.
Public method | ConvertNickNamesToFullNames | Convert all nicknames to full names, if they are equal to the default nickname. There will be no undo record associated with this operation.
Public method | CreateAutomaticClusterHooks | Add an input hook for every non-optional input parameter with no persistent data and no sources. Then add an output hook for every floating parameter without recipients, and for every first component output parameter where the parent component has no recipients.
Public method | CreateCompleteProxy | Create a complete RCP_Proxy instance for the entire document.
Public method | CreateConnectivityDiagram | Gets the connectivity diagram for the current state of this document.
Public method | CreateExpressionParser | Create a new Expression Solver preloaded with the constants defined in this document.
Public method | DefineConstant | Add a new constant to the document. Constants are not case-sensitive, when you define a constant with an existing name, the old one will be replaced. Note: constants are as of yet unused. Eventually they are supposed to become accessible to all expressions running inside a document.
Public method | DeselectAll | Deselect all top-level attributes.
Public method | DestroyAttributeCache | Destroys the Attribute cache. Call this function whenever you do something which might affect attributes.
Public method | DestroyAutoSaveFiles | Destroys all autosave files and backup files that are associated with this document. Only call this function when you are certain that the document has been properly saved and no changes have occured since.
Public method | DestroyObjectTable | Erase the Object fast lookup table. You must call this whenever you add or remove objects to or from the document while circumventing the regular channels.
Public method | DestroyPreviewMeshes | Attempts to destroy all the preview meshes in this document. It might not work for all objects, but this is still your best bet.
Public method | DestroyProxySources | Remove all remaining proxy sources from the document.
Public method | DisabledObjects | Returns all disabled objects in the document
Public method | Dispose | When you discard documents you must call Dispose or the Viewport Display event handlers will not be disconnected.
 | DuplicateDocument | Attempt to duplicate a document.
Public method | EnabledObjects | Returns all enabled objects in the document
Public method | ExpandSelection | Grow or shift the selection set based on source and recipient links
Public method | ExpirePreview | Expires the preview caches of the conduit.
Public method | ExpireSolution | Expire the entire solution. This will blank all objects.
 | FilterActive | Filter a list of objects.
 | FilterDisabled | Filter a list of objects.
 | FilterEnabled | Filter a list of objects.
 | FilterInactive | Filter a list of objects.
Public method | FilterObjects(GH_Filter, GH_Filter, GH_Filter) | Returns all objects in the document that pass the filter specification
 | FilterObjects(List<(Of <<'(IGH_DocumentObject>)>>), GH_Filter, GH_Filter, GH_Filter) | Filter a list of objects using several filters at once
 | FilterSelected | Filter a list of objects.
 | FilterUnselected | Filter a list of objects.
Public method | FindAllDownstreamObjects(IGH_ActiveObject) | Find all objects that depend in some way on the Source.
Public method | FindAllDownstreamObjects(List<(Of <<'(IGH_ActiveObject>)>>)) | Find all objects that depend in some way on the Source collection
Public method | FindAllDownstreamObjects(IGH_ActiveObject, GH_Document..::..GH_ActiveObjectFilter) | Find all objects that depend in some way on the Source.
Public method | FindAllDownstreamObjects(List<(Of <<'(IGH_ActiveObject>)>>), GH_Document..::..GH_ActiveObjectFilter) | Find all objects that depend in some way on the Source collection
Public method | FindAttribute(Guid) | Find the object that matches the ID
Public method | FindAttribute(PointF, Boolean) | Search for attributes that contain a certain point. The attribute balloon boxes are also taken into account.
Public method | FindAttributeByGrip(PointF, Boolean, Int32) | Search for attributes that contain grips near the search locus
Public method | FindAttributeByGrip(PointF, Boolean, Boolean, Boolean, Int32) | Search for attributes that contain grips near the search locus
Public method | FindClusters(Guid) | Find all the clusters that have a matching ID.
Public method | FindClusters(String) | Find all the clusters that have a matching filepath.
Public method | FindComponent(Point) | Search for components that contain the locus
Public method | FindComponent(Guid) | Search for components using an ID filter
Public method | FindFloatingParameter | Search for floating parameters that contain the locus
Public method | FindInputParameter | Search for input (upstream) parameters that contain the locus
Public method | FindObject(PointF, Single) | Find the topmost object that is closest to the point
Public method | FindObject(Guid, Boolean) | Find the object that matches the ID.
Public method | FindObject<(Of <<'(T>)>>)(Guid, Boolean) | Find the object that matches the ID.
Public method | FindObjects | Find the objects in the document that match the search term. Top level object names and nicknames are searched, as well as descriptions. Some objects are special cased to allow for more targeted searches. Data descriptions are not searched.
Public method | FindOutputParameter | Search for output (downstream) parameters that contain the locus
Public method | FindParameter | Search for parameters using an ID filter
Public method | GetAllInstanceIDs | Get a sorted list of all the IGH_DocumentObject instance IDs in this document.
Public method | InactiveObjects | Returns all objects in the document that don't implement the IGH_ActiveObject interface
Public method | InvertSelection | Invert the selected state of all top-level attributes.
 | IsEscapeKeyDown | Gets whether the escape key was pressed since the last time this function was called. Though in reality the actual escape state is checked no more than once every 50 milliseconds or so, which should be sufficient for a smooth user experience.
Public method | MergeDocument(GH_Document) | Hoist all objects from another document into this one.
Public method | MergeDocument(GH_Document, Boolean) | Hoist all objects from another document into this one.
Public method | MergeDocument(GH_Document, Boolean, Boolean) | Hoist all objects from another document into this one.
Public method | Modified | Sets the modified flag of this document.
Public method | MutateAllIds | Change all the instance UUIDs of all objects in the document. Be sure to resolve all proxy sources before mutating IDs. This function will ensure all groups are updated appropriately.
Public method | NewSolution(Boolean) | Start a new solution.
Public method | NewSolution(Boolean, GH_SolutionMode) | Start a new solution.
 | NonBlankFilter | This delegate can be used in the FindAllDownstreamObjects(...) methods. Only includes objects that are non-blank and non-failed.
 | NullFilter | This delegate can be used in the FindAllDownstreamObjects(...) methods. Includes all objects.
Public method | OnContextChanged | Raise the ContextChanged event.
Public method | OnEnabledChanged | Raise the EnabledChanged event.
Public method | OnFilePathChanged | Raise the FilePathChanged event.
Public method | OnModifiedChanged | Raise the ModifiedChanged event
Public method | OnObjectAdded | Raise the ObjectsAdded event.
Public method | OnObjectDeleted | Raise the ObjectsDeleted event.
Public method | OnObjectsAdded | Raise the ObjectsAdded event.
Public method | OnObjectsDeleted | Raise the ObjectsDeleted event.
Public method | OnSettingsChanged | Raise the SettingsChanged event.
Public method | OnUndoStateChanged | Raise the UndoStateChanged event.
Public method | PreviewCurrentMeshParameters | Gets the currently relevant meshing parameters (do not modify the instance as it may be shared).
Public method | Read | Standard archiving function. Will deserialize the entire document.
Public method | Redo | Perform the first redo event.
Public method | RelevantObjectAtPoint(PointF) | Find the most relevant object at a given canvas location. The most relevant object might be a regular Object (Component or Parameter), it might be an attribute grip, an attribute balloon, a wire or a group.
Public method | RelevantObjectAtPoint(PointF, GH_RelevantObjectFilter) | Find the most relevant object at a given canvas location. The most relevant object might be a regular Object (Component or Parameter), it might be an attribute grip, an attribute balloon, a wire or a group.
Public method | RemoveObject(IGH_Attributes, Boolean) | Remove the top-level object in the attribute tree from the document. This method does not add an Undo event, that is the responsibility of the caller.
Public method | RemoveObject(IGH_DocumentObject, Boolean) | Remove the object from the document. This removal is the precursor to object deletion. Do not call this function if you intend to transfer the object to another GH_Document. This method does not add an Undo event, that is the responsibility of the caller.
Public method | RemoveObjects | Remove the specified objects from the document. This removal is the precursor to object deletion. Do not call this function if you intend to transfer the objects to another GH_Document. This method does not add an Undo event, that is the responsibility of the caller.
Public method | RemoveSelection | Delete all the objects in the selection set. This method does not record an Undo event, that is the responsibility of the caller.
Public method | RepairProxySources | Attempts to resolve all proxy sources in the document.
Public method | ReplaceProxySources | Replace all remaining proxy sources in the document with UnresolvedProxy Objects.
Public method | RequestAbortSolution | Set the requestabort flag. The solution will be aborted whenever the current active object is completed. It is also possible that active objects themselves implement an abortion mechanism, in which case abortion might occur even sooner.
Public method | ScheduleSolution(Int32) | Schedule a new solution after a specified time interval. The schedule is erased if another solution is triggered before the schedule is executed. Tight schedules override loose schedules. If this method is called during a solution, the schedule will be started after the current solution completes.
Public method | ScheduleSolution(Int32, GH_Document..::..GH_ScheduleDelegate) | Schedule a new solution after a specified time interval. The schedule is erased if another solution is triggered before the schedule is executed. Tight schedules override loose schedules. If this method is called during a solution, the schedule will be started after the current solution completes.
Public method | Select(GH_RelevantObjectData) | Default pick selection behaviour. (looks at current Shift + Control modifier states to determine addition/removal)
Public method | Select(GH_RelevantObjectData, Boolean, Boolean) | Default pick selection behaviour
Public method | SelectAll | Select all top-level attributes.
Public method | SelectedObjects | Returns all selected objects in the document
Public method | SetEnabledFlags(Boolean) | Set the enabled flags of all selected objects to true or false
Public method | SetEnabledFlags(List<(Of <<'(IGH_DocumentObject>)>>), Boolean) | Set the enabled flags of all specified objects to true or false
Public method | SetPreviewFlags(Boolean) | Set the preview flags of all selected objects to true or false
Public method | SetPreviewFlags(List<(Of <<'(IGH_DocumentObject>)>>), Boolean) | Set the preview flags of all specified objects to true or false
Public method | ShowPreviewSettings | Display the Preview settings dialog.
Public method | SolutionProgress | Returns the progress of the current solution.
Public method | ToggleEnabledFlags()()()() | Toggle the enabled flags of all selected objects
Public method | ToggleEnabledFlags(List<(Of <<'(IGH_DocumentObject>)>>)) | Toggle the enabled flags of all specified objects
Public method | TogglePreviewFlags()()()() | Toggle the preview flags of all selected objects
Public method | TogglePreviewFlags(List<(Of <<'(IGH_DocumentObject>)>>)) | Toggle the preview flags of all specified objects
Public method | ToString | A document serializes itself using the filename of the current path. This is useful for sorting purposes and ListBoxes. (Overrides Object..::..ToString()()()().)
Public method | TranslateObjects | Offset objects by a certain distance in X and Y
Public method | Undo | Perform the first undo event.
Public method | UnselectedObjects | Returns all unselected objects in the document
Public method | UpdateAllSubsidiaries | Iterate over all subsidiary documents and update them with their respective owners. If a subsidiary hasn't been modified, it will not be updated and it will not be counted.
Public method | Write(GH_IWriter) | Standard archiving function. Will serialize the entire document.
Public method | Write(GH_IWriter, IList<(Of <<'(IGH_DocumentObject>)>>)) | Special function that allows writing of a custom object list. This function is used when partial documents need to be serialized such as when exporting or during clipboard operations.

See Also

GH_Document Class
Grasshopper.Kernel Namespace


ActiveObjects Method

[image]

Grasshopper SDK
GH_Document..::..ActiveObjects Method
GH_Document Class See Also Send Feedback
Returns all normal objects in the document that implement the IGH_ActiveObject interface

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<IGH_ActiveObject> ActiveObjects()
Visual Basic
Public Function ActiveObjects As List(Of IGH_ActiveObject)

Return Value

See Also

GH_Document Class
Grasshopper.Kernel Namespace


AddObject Method

[image]

Grasshopper SDK
GH_Document..::..AddObject Method
GH_Document Class See Also Send Feedback
Add a new object to the document. If the object is already contained, nothing will happen

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool AddObject(
    IGH_DocumentObject docObject,
    bool update,
    int index
)
Visual Basic
Public Function AddObject ( _
    docObject As IGH_DocumentObject, _
    update As Boolean, _
    index As Integer _
) As Boolean

Parameters

docObject
Type: Grasshopper.Kernel..::..IGH_DocumentObject
The object to add.
update
Type: System..::..Boolean
If True, a new solution will be triggered afterwards, regardless of event response settings.
index
Type: System..::..Int32
Index at which object will be inserted.

See Also

GH_Document Class
Grasshopper.Kernel Namespace


AlignObjects Method

[image] [image]

Grasshopper SDK
GH_Document..::..AlignObjects Method
GH_Document Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AlignObjects(GH_Align, GH_Distribute) | Perform alignment and distribution logic on all selected objects.
Public method | AlignObjects(GH_Align, GH_Distribute, List<(Of <<'(IGH_DocumentObject>)>>)) | Perform alignment and distribution logic on a set of objects.

See Also

GH_Document Class
GH_Document Members
Grasshopper.Kernel Namespace


AlignObjects Method (, )

[image]

Grasshopper SDK
GH_Document..::..AlignObjects Method (, )
GH_Document Class See Also Send Feedback
Perform alignment and distribution logic on all selected objects.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AlignObjects(
    GH_Align align,
    GH_Distribute distribute
)
Visual Basic
Public Sub AlignObjects ( _
    align As GH_Align, _
    distribute As GH_Distribute _
)

Parameters

align
Type: GH_Align
distribute
Type: GH_Distribute

See Also

GH_Document Class
AlignObjects Overload
Grasshopper.Kernel Namespace


AlignObjects Method (, , List(IGH_DocumentObject))

[image]

Grasshopper SDK
GH_Document..::..AlignObjects Method (, , List<(Of <(<'IGH_DocumentObject>)>)>)
GH_Document Class See Also Send Feedback
Perform alignment and distribution logic on a set of objects.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AlignObjects(
    GH_Align align,
    GH_Distribute distribute,
    List<IGH_DocumentObject> objs
)
Visual Basic
Public Sub AlignObjects ( _
    align As GH_Align, _
    distribute As GH_Distribute, _
    objs As List(Of IGH_DocumentObject) _
)

Parameters

align
Type: GH_Align
distribute
Type: GH_Distribute
objs
Type: System.Collections.Generic..::..List <(Of <(<' IGH_DocumentObject >)>)>

See Also

GH_Document Class
AlignObjects Overload
Grasshopper.Kernel Namespace


AppendToDebugLog Method

[image]

Grasshopper SDK
GH_Document..::..AppendToDebugLog Method
GH_Document Class See Also Send Feedback
Useful for creating textual representations of this document for debugging purposes.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AppendToDebugLog(
    GH_DebugDescriptionWriter writer
)
Visual Basic
Public Sub AppendToDebugLog ( _
    writer As GH_DebugDescriptionWriter _
)

Parameters

writer
Type: Grasshopper.Kernel..::..GH_DebugDescriptionWriter

Implements

IGH_DebugDescription..::..AppendToDebugLog(GH_DebugDescriptionWriter)

See Also

GH_Document Class
Grasshopper.Kernel Namespace


ArrangeObject Method

[image]

Grasshopper SDK
GH_Document..::..ArrangeObject Method
GH_Document Class See Also Send Feedback
Rearrange the stack order of the object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool ArrangeObject(
    IGH_DocumentObject obj,
    GH_Arrange motion
)
Visual Basic
Public Function ArrangeObject ( _
    obj As IGH_DocumentObject, _
    motion As GH_Arrange _
) As Boolean

Parameters

obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject
Object to move.
motion
Type: Grasshopper.Kernel..::..GH_Arrange
Direction to move in.

See Also

GH_Document Class
Grasshopper.Kernel Namespace


ArrangeObjects Method

[image]

Grasshopper SDK
GH_Document..::..ArrangeObjects Method
GH_Document Class See Also Send Feedback
Rearrange the stack order of a collection of objects.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool ArrangeObjects(
    IEnumerable<IGH_DocumentObject> objs,
    GH_Arrange motion
)
Visual Basic
Public Function ArrangeObjects ( _
    objs As IEnumerable(Of IGH_DocumentObject), _
    motion As GH_Arrange _
) As Boolean

Parameters

objs
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' IGH_DocumentObject >)>)>
Objects to move.
motion
Type: Grasshopper.Kernel..::..GH_Arrange
Direction to move in.

See Also

GH_Document Class
Grasshopper.Kernel Namespace


AssociateWithRhinoDocument Method

[image]

Grasshopper SDK
GH_Document..::..AssociateWithRhinoDocument Method
GH_Document Class See Also Send Feedback
Associate this GH_Document with the currently active Rhino document. This only works if both the 3dm and the ghx file have been saved at least once.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AssociateWithRhinoDocument()
Visual Basic
Public Sub AssociateWithRhinoDocument

See Also

GH_Document Class
Grasshopper.Kernel Namespace


AutoSave Method

[image] [image]

Grasshopper SDK
GH_Document..::..AutoSave Method
GH_Document Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AutoSave(GH_AutoSaveTrigger) | Creates a new autosave file on the disk. The previous autosave file (assuming it exists) will be temporarily renamed and eventually deleted entirely. Note: AutoSave is only possible on Documents that have TopLevel Rank and a valid FilePath.
Public method | AutoSave(GH_AutoSaveTrigger, Guid) | Creates a new autosave file on the disk. The previous autosave file (assuming it exists) will be temporarily renamed and eventually deleted entirely. Note: AutoSave is only possible on Documents that have TopLevel Rank and a valid FilePath.

See Also

GH_Document Class
GH_Document Members
Grasshopper.Kernel Namespace


AutoSave Method (GH_AutoSaveTrigger)

[image]

Grasshopper SDK
GH_Document..::..AutoSave Method (GH_AutoSaveTrigger)
GH_Document Class See Also Send Feedback
Creates a new autosave file on the disk. The previous autosave file (assuming it exists) will be temporarily renamed and eventually deleted entirely. Note: AutoSave is only possible on Documents that have TopLevel Rank and a valid FilePath.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool AutoSave(
    GH_AutoSaveTrigger trigger
)
Visual Basic
Public Function AutoSave ( _
    trigger As GH_AutoSaveTrigger _
) As Boolean

Parameters

trigger
Type: Grasshopper.Kernel..::..GH_AutoSaveTrigger
Reason for autosave. User can choose to ignore certain autosave reasons.

See Also

GH_Document Class
AutoSave Overload
Grasshopper.Kernel Namespace


AutoSave Method (GH_AutoSaveTrigger, Guid)

[image]

Grasshopper SDK
GH_Document..::..AutoSave Method (GH_AutoSaveTrigger, Guid)
GH_Document Class See Also Send Feedback
Creates a new autosave file on the disk. The previous autosave file (assuming it exists) will be temporarily renamed and eventually deleted entirely. Note: AutoSave is only possible on Documents that have TopLevel Rank and a valid FilePath.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool AutoSave(
    GH_AutoSaveTrigger trigger,
    Guid id
)
Visual Basic
Public Function AutoSave ( _
    trigger As GH_AutoSaveTrigger, _
    id As Guid _
) As Boolean

Parameters

trigger
Type: Grasshopper.Kernel..::..GH_AutoSaveTrigger
Reason for autosave. User can choose to ignore certain autosave reasons.
id
Type: System..::..Guid
Guid of autosave operation, consecutive calls to autosave with the same Guid will be ignored.

See Also

GH_Document Class
AutoSave Overload
Grasshopper.Kernel Namespace


AutoSaveFileName Method

[image]

Grasshopper SDK
GH_Document..::..AutoSaveFileName Method
GH_Document Class See Also Send Feedback
Computes the autosave filename for a full grasshopper filepath.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string AutoSaveFileName(
    string filename
)
Visual Basic
Public Shared Function AutoSaveFileName ( _
    filename As String _
) As String

Parameters

filename
Type: System..::..String
Full path of Grasshopper file, including directories and extension.

Return Value

The autosave filename (but not including the autosave directory).

See Also

GH_Document Class
Grasshopper.Kernel Namespace


BoundingBox Method

[image]

Grasshopper SDK
GH_Document..::..BoundingBox Method
GH_Document Class See Also Send Feedback
Returns the boundingbox of all the normal attributes. If the document contains no normal attributes an Empty RectangleF structure is returned.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public RectangleF BoundingBox(
    bool limitToSelection
)
Visual Basic
Public Function BoundingBox ( _
    limitToSelection As Boolean _
) As RectangleF

Parameters

limitToSelection
Type: System..::..Boolean
If true, only selected attributes are included in the boundingbox computation.

Return Value

The boundingbox of the requested objects or RectangleF.Empty if no objects could be found.

See Also

GH_Document Class
Grasshopper.Kernel Namespace


BringSelectionToTop Method

[image]

Grasshopper SDK
GH_Document..::..BringSelectionToTop Method
GH_Document Class See Also Send Feedback
Move the selection set to the top of the visible stack

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void BringSelectionToTop()
Visual Basic
Public Sub BringSelectionToTop

See Also

GH_Document Class
Grasshopper.Kernel Namespace


ClearIgnoreList Method

[image]

Grasshopper SDK
GH_Document..::..ClearIgnoreList Method
GH_Document Class See Also Send Feedback
Clears the Object Exception Ignore List.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ClearIgnoreList()
Visual Basic
Public Sub ClearIgnoreList

See Also

GH_Document Class
Grasshopper.Kernel Namespace


ClearReferenceTable Method

[image]

Grasshopper SDK
GH_Document..::..ClearReferenceTable Method
GH_Document Class See Also Send Feedback
Destroys the Referenced object table in the Rhino event watcher. You must call this function if you either add or remove a reference to a Rhino object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ClearReferenceTable()
Visual Basic
Public Sub ClearReferenceTable

See Also

GH_Document Class
Grasshopper.Kernel Namespace


CloseAllSubsidiaries Method

[image]

Grasshopper SDK
GH_Document..::..CloseAllSubsidiaries Method
GH_Document Class See Also Send Feedback
Iterate over all subsidiary documents and close them all without saving.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int CloseAllSubsidiaries()
Visual Basic
Public Function CloseAllSubsidiaries As Integer

Return Value

The number of subsidiary documents that was closed.

See Also

GH_Document Class
Grasshopper.Kernel Namespace


ClusterInputHooks Method

[image]

Grasshopper SDK
GH_Document..::..ClusterInputHooks Method
GH_Document Class See Also Send Feedback
Gets a sorted list of all the cluster input hooks.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ClusterInputHook[] ClusterInputHooks()
Visual Basic
Public Function ClusterInputHooks As GH_ClusterInputHook()

Return Value

A list of hooks in the proper order (from top to bottom, left to right).

See Also

GH_Document Class
Grasshopper.Kernel Namespace


ClusterInstanceCount Method

[image]

Grasshopper SDK
GH_Document..::..ClusterInstanceCount Method
GH_Document Class See Also Send Feedback
Counts the number of instances of a specific cluster document ID.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int ClusterInstanceCount(
    Guid id
)
Visual Basic
Public Function ClusterInstanceCount ( _
    id As Guid _
) As Integer

Parameters

id
Type: System..::..Guid
The cluster document id to search for.

Return Value

The number of instances of a specific cluster.

See Also

GH_Document Class
Grasshopper.Kernel Namespace


ClusterOutputHooks Method

[image]

Grasshopper SDK
GH_Document..::..ClusterOutputHooks Method
GH_Document Class See Also Send Feedback
Gets a sorted list of all the cluster output hooks.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ClusterOutputHook[] ClusterOutputHooks()
Visual Basic
Public Function ClusterOutputHooks As GH_ClusterOutputHook()

Return Value

A list of hooks in the proper order (from top to bottom, left to right).

See Also

GH_Document Class
Grasshopper.Kernel Namespace


CompareTo Method

[image]

Grasshopper SDK
GH_Document..::..CompareTo Method
GH_Document Class See Also Send Feedback
Compare two documents. This function does not compare document content.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int CompareTo(
    GH_Document other
)
Visual Basic
Public Function CompareTo ( _
    other As GH_Document _
) As Integer

Parameters

other
Type: Grasshopper.Kernel..::..GH_Document
Document to compare to.

Return Value

Comparison key.

Implements

IComparable<(Of <(<'T>)>)>..::..CompareTo(T)

See Also

GH_Document Class
Grasshopper.Kernel Namespace


ConstructDocumentTree Method

[image]

Grasshopper SDK
GH_Document..::..ConstructDocumentTree Method
GH_Document Class See Also Send Feedback
Create a hierarchical document tree of ownership with this document as the root.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_DocumentTree ConstructDocumentTree()
Visual Basic
Public Function ConstructDocumentTree As GH_DocumentTree

Return Value

A tree of all documents owned directly or indirectly by this document.

See Also

GH_Document Class
Grasshopper.Kernel Namespace


ContainsClusterHooks Method

[image]

Grasshopper SDK
GH_Document..::..ContainsClusterHooks Method
GH_Document Class See Also Send Feedback
Tests whether this document contains at least one cluster hook.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool ContainsClusterHooks()
Visual Basic
Public Function ContainsClusterHooks As Boolean

See Also

GH_Document Class
Grasshopper.Kernel Namespace


ConvertFullNamesToNickNames Method

[image]

Grasshopper SDK
GH_Document..::..ConvertFullNamesToNickNames Method
GH_Document Class See Also Send Feedback
Convert all nicknames to original nicknames if they are equal to the default full name. There will be no undo record associated with this operation.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ConvertFullNamesToNickNames()
Visual Basic
Public Sub ConvertFullNamesToNickNames

See Also

GH_Document Class
Grasshopper.Kernel Namespace


ConvertNickNamesToFullNames Method

[image]

Grasshopper SDK
GH_Document..::..ConvertNickNamesToFullNames Method
GH_Document Class See Also Send Feedback
Convert all nicknames to full names, if they are equal to the default nickname. There will be no undo record associated with this operation.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ConvertNickNamesToFullNames()
Visual Basic
Public Sub ConvertNickNamesToFullNames

See Also

GH_Document Class
Grasshopper.Kernel Namespace


CreateAutomaticClusterHooks Method

[image]

Grasshopper SDK
GH_Document..::..CreateAutomaticClusterHooks Method
GH_Document Class See Also Send Feedback
Add an input hook for every non-optional input parameter with no persistent data and no sources. Then add an output hook for every floating parameter without recipients, and for every first component output parameter where the parent component has no recipients.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void CreateAutomaticClusterHooks()
Visual Basic
Public Sub CreateAutomaticClusterHooks

Remarks

See Also

GH_Document Class
Grasshopper.Kernel Namespace


CreateCompleteProxy Method

[image]

Grasshopper SDK
GH_Document..::..CreateCompleteProxy Method
GH_Document Class See Also Send Feedback
Create a complete RCP_Proxy instance for the entire document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_RcpProxy CreateCompleteProxy(
    bool bIncludeCustomObjects,
    bool bIncludeFloatingParams
)
Visual Basic
Public Function CreateCompleteProxy ( _
    bIncludeCustomObjects As Boolean, _
    bIncludeFloatingParams As Boolean _
) As GH_RcpProxy

Parameters

bIncludeCustomObjects
Type: System..::..Boolean
If True, custom objects will be included.
bIncludeFloatingParams
Type: System..::..Boolean
If True, floating parameters will be included.

See Also

GH_Document Class
Grasshopper.Kernel Namespace


CreateConnectivityDiagram Method

[image]

Grasshopper SDK
GH_Document..::..CreateConnectivityDiagram Method
GH_Document Class See Also Send Feedback
Gets the connectivity diagram for the current state of this document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ConnectivityDiagram CreateConnectivityDiagram()
Visual Basic
Public Function CreateConnectivityDiagram As GH_ConnectivityDiagram

Return Value

The connectivity diagram of the current state. Once objects/wires are added or removed the diagram will not update and you must request a new one.

See Also

GH_Document Class
Grasshopper.Kernel Namespace


CreateExpressionParser Method

[image]

Grasshopper SDK
GH_Document..::..CreateExpressionParser Method
GH_Document Class See Also Send Feedback
Create a new Expression Solver preloaded with the constants defined in this document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ExpressionParser CreateExpressionParser()
Visual Basic
Public Function CreateExpressionParser As GH_ExpressionParser

See Also

GH_Document Class
Grasshopper.Kernel Namespace


DefineConstant Method

[image]

Grasshopper SDK
GH_Document..::..DefineConstant Method
GH_Document Class See Also Send Feedback
Add a new constant to the document. Constants are not case-sensitive, when you define a constant with an existing name, the old one will be replaced. Note: constants are as of yet unused. Eventually they are supposed to become accessible to all expressions running inside a document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DefineConstant(
    string name,
    GH_Variant value
)
Visual Basic
Public Sub DefineConstant ( _
    name As String, _
    value As GH_Variant _
)

Parameters

name
Type: System..::..String
Name of constant.
value
Type: Grasshopper.Kernel.Expressions..::..GH_Variant
Value of constant.

See Also

GH_Document Class
Grasshopper.Kernel Namespace


DeselectAll Method

[image]

Grasshopper SDK
GH_Document..::..DeselectAll Method
GH_Document Class See Also Send Feedback
Deselect all top-level attributes.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DeselectAll()
Visual Basic
Public Sub DeselectAll

See Also

GH_Document Class
Grasshopper.Kernel Namespace


DestroyAttributeCache Method

[image]

Grasshopper SDK
GH_Document..::..DestroyAttributeCache Method
GH_Document Class See Also Send Feedback
Destroys the Attribute cache. Call this function whenever you do something which might affect attributes.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DestroyAttributeCache()
Visual Basic
Public Sub DestroyAttributeCache

See Also

GH_Document Class
Grasshopper.Kernel Namespace


DestroyAutoSaveFiles Method

[image]

Grasshopper SDK
GH_Document..::..DestroyAutoSaveFiles Method
GH_Document Class See Also Send Feedback
Destroys all autosave files and backup files that are associated with this document. Only call this function when you are certain that the document has been properly saved and no changes have occured since.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DestroyAutoSaveFiles()
Visual Basic
Public Sub DestroyAutoSaveFiles

See Also

GH_Document Class
Grasshopper.Kernel Namespace


DestroyObjectTable Method

[image]

Grasshopper SDK
GH_Document..::..DestroyObjectTable Method
GH_Document Class See Also Send Feedback
Erase the Object fast lookup table. You must call this whenever you add or remove objects to or from the document while circumventing the regular channels.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DestroyObjectTable()
Visual Basic
Public Sub DestroyObjectTable

See Also

GH_Document Class
Grasshopper.Kernel Namespace


DestroyPreviewMeshes Method

[image]

Grasshopper SDK
GH_Document..::..DestroyPreviewMeshes Method
GH_Document Class See Also Send Feedback
Attempts to destroy all the preview meshes in this document. It might not work for all objects, but this is still your best bet.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DestroyPreviewMeshes()
Visual Basic
Public Sub DestroyPreviewMeshes

See Also

GH_Document Class
Grasshopper.Kernel Namespace


DestroyProxySources Method

[image]

Grasshopper SDK
GH_Document..::..DestroyProxySources Method
GH_Document Class See Also Send Feedback
Remove all remaining proxy sources from the document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DestroyProxySources()
Visual Basic
Public Sub DestroyProxySources

See Also

GH_Document Class
Grasshopper.Kernel Namespace


DisabledObjects Method

[image]

Grasshopper SDK
GH_Document..::..DisabledObjects Method
GH_Document Class See Also Send Feedback
Returns all disabled objects in the document

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<IGH_DocumentObject> DisabledObjects()
Visual Basic
Public Function DisabledObjects As List(Of IGH_DocumentObject)

Return Value

See Also

GH_Document Class
Grasshopper.Kernel Namespace


Dispose Method

[image]

Grasshopper SDK
GH_Document..::..Dispose Method
GH_Document Class See Also Send Feedback
When you discard documents you must call Dispose or the Viewport Display event handlers will not be disconnected.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose

Implements

IDisposable..::..Dispose()()()()

See Also

GH_Document Class
Grasshopper.Kernel Namespace


DuplicateDocument Method

[image]

Grasshopper SDK
GH_Document..::..DuplicateDocument Method
GH_Document Class See Also Send Feedback
Attempt to duplicate a document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_Document DuplicateDocument(
    GH_Document doc
)
Visual Basic
Public Shared Function DuplicateDocument ( _
    doc As GH_Document _
) As GH_Document

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document
Document to copy.

Return Value

A document similar to the input on success, or nothing on failure.

See Also

GH_Document Class
Grasshopper.Kernel Namespace


EnabledObjects Method

[image]

Grasshopper SDK
GH_Document..::..EnabledObjects Method
GH_Document Class See Also Send Feedback
Returns all enabled objects in the document

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<IGH_DocumentObject> EnabledObjects()
Visual Basic
Public Function EnabledObjects As List(Of IGH_DocumentObject)

Return Value

See Also

GH_Document Class
Grasshopper.Kernel Namespace


ExpandSelection Method

[image]

Grasshopper SDK
GH_Document..::..ExpandSelection Method
GH_Document Class See Also Send Feedback
Grow or shift the selection set based on source and recipient links

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ExpandSelection(
    bool Upstream,
    bool Downstream,
    bool GrowSelection
)
Visual Basic
Public Sub ExpandSelection ( _
    Upstream As Boolean, _
    Downstream As Boolean, _
    GrowSelection As Boolean _
)

Parameters

Upstream
Type: System..::..Boolean
If True, the selection will grow/shift upstream
Downstream
Type: System..::..Boolean
If True, the selection will grow/shift downstream
GrowSelection
Type: System..::..Boolean
If True, the current selection set is retained. If False, the current selection set is discarded

See Also

GH_Document Class
Grasshopper.Kernel Namespace


ExpirePreview Method

[image]

Grasshopper SDK
GH_Document..::..ExpirePreview Method
GH_Document Class See Also Send Feedback
Expires the preview caches of the conduit.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ExpirePreview(
    bool redraw
)
Visual Basic
Public Sub ExpirePreview ( _
    redraw As Boolean _
)

Parameters

redraw
Type: System..::..Boolean

See Also

GH_Document Class
Grasshopper.Kernel Namespace


ExpireSolution Method

[image]

Grasshopper SDK
GH_Document..::..ExpireSolution Method
GH_Document Class See Also Send Feedback
Expire the entire solution. This will blank all objects.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ExpireSolution()
Visual Basic
Public Sub ExpireSolution

See Also

GH_Document Class
Grasshopper.Kernel Namespace


FilterActive Method

[image]

Grasshopper SDK
GH_Document..::..FilterActive Method
GH_Document Class See Also Send Feedback
Filter a list of objects.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static List<IGH_ActiveObject> FilterActive(
    List<IGH_DocumentObject> in
)
Visual Basic
Public Shared Function FilterActive ( _
    in As List(Of IGH_DocumentObject) _
) As List(Of IGH_ActiveObject)

Parameters

in
Type: System.Collections.Generic..::..List <(Of <(<' IGH_DocumentObject >)>)>
The object list to filter

Return Value

A list containing only the objects that implement the IGH_ActiveObject interface

Remarks

See Also

GH_Document Class
Grasshopper.Kernel Namespace


FilterDisabled Method

[image]

Grasshopper SDK
GH_Document..::..FilterDisabled Method
GH_Document Class See Also Send Feedback
Filter a list of objects.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static List<IGH_DocumentObject> FilterDisabled(
    List<IGH_DocumentObject> in
)
Visual Basic
Public Shared Function FilterDisabled ( _
    in As List(Of IGH_DocumentObject) _
) As List(Of IGH_DocumentObject)

Parameters

in
Type: System.Collections.Generic..::..List <(Of <(<' IGH_DocumentObject >)>)>
The object list to filter

Return Value

A list containing only the disabled objects

Remarks

See Also

GH_Document Class
Grasshopper.Kernel Namespace


FilterEnabled Method

[image]

Grasshopper SDK
GH_Document..::..FilterEnabled Method
GH_Document Class See Also Send Feedback
Filter a list of objects.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static List<IGH_DocumentObject> FilterEnabled(
    List<IGH_DocumentObject> in
)
Visual Basic
Public Shared Function FilterEnabled ( _
    in As List(Of IGH_DocumentObject) _
) As List(Of IGH_DocumentObject)

Parameters

in
Type: System.Collections.Generic..::..List <(Of <(<' IGH_DocumentObject >)>)>
The object list to filter

Return Value

A list containing only the enabled objects

Remarks

See Also

GH_Document Class
Grasshopper.Kernel Namespace


FilterInactive Method

[image]

Grasshopper SDK
GH_Document..::..FilterInactive Method
GH_Document Class See Also Send Feedback
Filter a list of objects.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static List<IGH_ActiveObject> FilterInactive(
    List<IGH_DocumentObject> in
)
Visual Basic
Public Shared Function FilterInactive ( _
    in As List(Of IGH_DocumentObject) _
) As List(Of IGH_ActiveObject)

Parameters

in
Type: System.Collections.Generic..::..List <(Of <(<' IGH_DocumentObject >)>)>
The object list to filter

Return Value

A list containing only the objects that don't implement the IGH_ActiveObject interface

Remarks

See Also

GH_Document Class
Grasshopper.Kernel Namespace


FilterObjects Method

[image] [image]

Grasshopper SDK
GH_Document..::..FilterObjects Method
GH_Document Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FilterObjects(GH_Filter, GH_Filter, GH_Filter) | Returns all objects in the document that pass the filter specification
 | FilterObjects(List<(Of <<'(IGH_DocumentObject>)>>), GH_Filter, GH_Filter, GH_Filter) | Filter a list of objects using several filters at once

See Also

GH_Document Class
GH_Document Members
Grasshopper.Kernel Namespace


FilterObjects Method (GH_Filter, GH_Filter, GH_Filter)

[image]

Grasshopper SDK
GH_Document..::..FilterObjects Method (GH_Filter, GH_Filter, GH_Filter)
GH_Document Class See Also Send Feedback
Returns all objects in the document that pass the filter specification

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<IGH_DocumentObject> FilterObjects(
    GH_Filter selectedObjects,
    GH_Filter enabledObjects,
    GH_Filter activeObjects
)
Visual Basic
Public Function FilterObjects ( _
    selectedObjects As GH_Filter, _
    enabledObjects As GH_Filter, _
    activeObjects As GH_Filter _
) As List(Of IGH_DocumentObject)

Parameters

selectedObjects
Type: Grasshopper.Kernel..::..GH_Filter
enabledObjects
Type: Grasshopper.Kernel..::..GH_Filter
activeObjects
Type: Grasshopper.Kernel..::..GH_Filter

See Also

GH_Document Class
FilterObjects Overload
Grasshopper.Kernel Namespace


FilterObjects Method (List(IGH_DocumentObject), GH_Filter, GH_Filter, GH_Filter)

[image]

Grasshopper SDK
GH_Document..::..FilterObjects Method (List<(Of <(<'IGH_DocumentObject>)>)>, GH_Filter, GH_Filter, GH_Filter)
GH_Document Class See Also Send Feedback
Filter a list of objects using several filters at once

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static List<IGH_DocumentObject> FilterObjects(
    List<IGH_DocumentObject> in,
    GH_Filter bSelectedObjects,
    GH_Filter bEnabledObjects,
    GH_Filter bActiveObjects
)
Visual Basic
Public Shared Function FilterObjects ( _
    in As List(Of IGH_DocumentObject), _
    bSelectedObjects As GH_Filter, _
    bEnabledObjects As GH_Filter, _
    bActiveObjects As GH_Filter _
) As List(Of IGH_DocumentObject)

Parameters

in
Type: System.Collections.Generic..::..List <(Of <(<' IGH_DocumentObject >)>)>
The set to filter
bSelectedObjects
Type: Grasshopper.Kernel..::..GH_Filter
Filter (non)selected objects only
bEnabledObjects
Type: Grasshopper.Kernel..::..GH_Filter
Filter (non)enabled objects only
bActiveObjects
Type: Grasshopper.Kernel..::..GH_Filter
Filter (non)active objects only

Return Value

A list with all objects that pass all filters

See Also

GH_Document Class
FilterObjects Overload
Grasshopper.Kernel Namespace


FilterSelected Method

[image]

Grasshopper SDK
GH_Document..::..FilterSelected Method
GH_Document Class See Also Send Feedback
Filter a list of objects.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static List<IGH_DocumentObject> FilterSelected(
    List<IGH_DocumentObject> in
)
Visual Basic
Public Shared Function FilterSelected ( _
    in As List(Of IGH_DocumentObject) _
) As List(Of IGH_DocumentObject)

Parameters

in
Type: System.Collections.Generic..::..List <(Of <(<' IGH_DocumentObject >)>)>
The object list to filter

Return Value

A list containing only the selected objects

Remarks

See Also

GH_Document Class
Grasshopper.Kernel Namespace


FilterUnselected Method

[image]

Grasshopper SDK
GH_Document..::..FilterUnselected Method
GH_Document Class See Also Send Feedback
Filter a list of objects.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static List<IGH_DocumentObject> FilterUnselected(
    List<IGH_DocumentObject> in
)
Visual Basic
Public Shared Function FilterUnselected ( _
    in As List(Of IGH_DocumentObject) _
) As List(Of IGH_DocumentObject)

Parameters

in
Type: System.Collections.Generic..::..List <(Of <(<' IGH_DocumentObject >)>)>
The object list to filter

Return Value

A list containing only the unselected objects

Remarks

See Also

GH_Document Class
Grasshopper.Kernel Namespace


FindAllDownstreamObjects Method

[image] [image]

Grasshopper SDK
GH_Document..::..FindAllDownstreamObjects Method
GH_Document Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindAllDownstreamObjects(IGH_ActiveObject) | Find all objects that depend in some way on the Source.
Public method | FindAllDownstreamObjects(List<(Of <<'(IGH_ActiveObject>)>>)) | Find all objects that depend in some way on the Source collection
Public method | FindAllDownstreamObjects(IGH_ActiveObject, GH_Document..::..GH_ActiveObjectFilter) | Find all objects that depend in some way on the Source.
Public method | FindAllDownstreamObjects(List<(Of <<'(IGH_ActiveObject>)>>), GH_Document..::..GH_ActiveObjectFilter) | Find all objects that depend in some way on the Source collection

See Also

GH_Document Class
GH_Document Members
Grasshopper.Kernel Namespace


FindAllDownstreamObjects Method (IGH_ActiveObject)

[image]

Grasshopper SDK
GH_Document..::..FindAllDownstreamObjects Method (IGH_ActiveObject)
GH_Document Class See Also Send Feedback
Find all objects that depend in some way on the Source.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<IGH_ActiveObject> FindAllDownstreamObjects(
    IGH_ActiveObject from
)
Visual Basic
Public Function FindAllDownstreamObjects ( _
    from As IGH_ActiveObject _
) As List(Of IGH_ActiveObject)

Parameters

from
Type: Grasshopper.Kernel..::..IGH_ActiveObject
Object to start searching from.

See Also

GH_Document Class
FindAllDownstreamObjects Overload
Grasshopper.Kernel Namespace


FindAllDownstreamObjects Method (List(IGH_ActiveObject))

[image]

Grasshopper SDK
GH_Document..::..FindAllDownstreamObjects Method (List<(Of <(<'IGH_ActiveObject>)>)>)
GH_Document Class See Also Send Feedback
Find all objects that depend in some way on the Source collection

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<IGH_ActiveObject> FindAllDownstreamObjects(
    List<IGH_ActiveObject> from
)
Visual Basic
Public Function FindAllDownstreamObjects ( _
    from As List(Of IGH_ActiveObject) _
) As List(Of IGH_ActiveObject)

Parameters

from
Type: System.Collections.Generic..::..List <(Of <(<' IGH_ActiveObject >)>)>
Objects to start searching from.

See Also

GH_Document Class
FindAllDownstreamObjects Overload
Grasshopper.Kernel Namespace


FindAllDownstreamObjects Method (IGH_ActiveObject, GH_Document.GH_ActiveObjectFilter)

[image]

Grasshopper SDK
GH_Document..::..FindAllDownstreamObjects Method (IGH_ActiveObject, GH_Document..::..GH_ActiveObjectFilter)
GH_Document Class See Also Send Feedback
Find all objects that depend in some way on the Source.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<IGH_ActiveObject> FindAllDownstreamObjects(
    IGH_ActiveObject from,
    GH_Document..::..GH_ActiveObjectFilter filter
)
Visual Basic
Public Function FindAllDownstreamObjects ( _
    from As IGH_ActiveObject, _
    filter As GH_Document..::..GH_ActiveObjectFilter _
) As List(Of IGH_ActiveObject)

Parameters

from
Type: Grasshopper.Kernel..::..IGH_ActiveObject
Object to start searching from.
filter
Type: Grasshopper.Kernel..::..GH_Document..::..GH_ActiveObjectFilter
The inclusion delegate

See Also

GH_Document Class
FindAllDownstreamObjects Overload
Grasshopper.Kernel Namespace


FindAllDownstreamObjects Method (List(IGH_ActiveObject), GH_Document.GH_ActiveObjectFilter)

[image]

Grasshopper SDK
GH_Document..::..FindAllDownstreamObjects Method (List<(Of <(<'IGH_ActiveObject>)>)>, GH_Document..::..GH_ActiveObjectFilter)
GH_Document Class See Also Send Feedback
Find all objects that depend in some way on the Source collection

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<IGH_ActiveObject> FindAllDownstreamObjects(
    List<IGH_ActiveObject> from,
    GH_Document..::..GH_ActiveObjectFilter filter
)
Visual Basic
Public Function FindAllDownstreamObjects ( _
    from As List(Of IGH_ActiveObject), _
    filter As GH_Document..::..GH_ActiveObjectFilter _
) As List(Of IGH_ActiveObject)

Parameters

from
Type: System.Collections.Generic..::..List <(Of <(<' IGH_ActiveObject >)>)>
Objects to start searching from.
filter
Type: Grasshopper.Kernel..::..GH_Document..::..GH_ActiveObjectFilter
The inclusion delegate

See Also

GH_Document Class
FindAllDownstreamObjects Overload
Grasshopper.Kernel Namespace


FindAttribute Method

[image] [image]

Grasshopper SDK
GH_Document..::..FindAttribute Method
GH_Document Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindAttribute(Guid) | Find the object that matches the ID
Public method | FindAttribute(PointF, Boolean) | Search for attributes that contain a certain point. The attribute balloon boxes are also taken into account.

See Also

GH_Document Class
GH_Document Members
Grasshopper.Kernel Namespace


FindAttribute Method (Guid)

[image]

Grasshopper SDK
GH_Document..::..FindAttribute Method (Guid)
GH_Document Class See Also Send Feedback
Find the object that matches the ID

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_Attributes FindAttribute(
    Guid id
)
Visual Basic
Public Function FindAttribute ( _
    id As Guid _
) As IGH_Attributes

Parameters

id
Type: System..::..Guid
the ID to search for

See Also

GH_Document Class
FindAttribute Overload
Grasshopper.Kernel Namespace


FindAttribute Method (PointF, Boolean)

[image]

Grasshopper SDK
GH_Document..::..FindAttribute Method (PointF, Boolean)
GH_Document Class See Also Send Feedback
Search for attributes that contain a certain point. The attribute balloon boxes are also taken into account.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_Attributes FindAttribute(
    PointF pt,
    bool topLevelOnly
)
Visual Basic
Public Function FindAttribute ( _
    pt As PointF, _
    topLevelOnly As Boolean _
) As IGH_Attributes

Parameters

pt
Type: System.Drawing..::..PointF
The point in Canvas coordinates
topLevelOnly
Type: System..::..Boolean
If true, child attributes will be skipped.

See Also

GH_Document Class
FindAttribute Overload
Grasshopper.Kernel Namespace


FindAttributeByGrip Method

[image] [image]

Grasshopper SDK
GH_Document..::..FindAttributeByGrip Method
GH_Document Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindAttributeByGrip(PointF, Boolean, Int32) | Search for attributes that contain grips near the search locus
Public method | FindAttributeByGrip(PointF, Boolean, Boolean, Boolean, Int32) | Search for attributes that contain grips near the search locus

See Also

GH_Document Class
GH_Document Members
Grasshopper.Kernel Namespace


FindAttributeByGrip Method (PointF, Boolean, Int32)

[image]

Grasshopper SDK
GH_Document..::..FindAttributeByGrip Method (PointF, Boolean, Int32)
GH_Document Class See Also Send Feedback
Search for attributes that contain grips near the search locus

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_Attributes FindAttributeByGrip(
    PointF pt,
    bool bLimitToOutside,
    int SearchRadius
)
Visual Basic
Public Function FindAttributeByGrip ( _
    pt As PointF, _
    bLimitToOutside As Boolean, _
    SearchRadius As Integer _
) As IGH_Attributes

Parameters

pt
Type: System.Drawing..::..PointF
Pixel for search start
bLimitToOutside
Type: System..::..Boolean
If true, grips are ignored if the pt is on the 'inside' side.
SearchRadius
Type: System..::..Int32
Radius of search

See Also

GH_Document Class
FindAttributeByGrip Overload
Grasshopper.Kernel Namespace


FindAttributeByGrip Method (PointF, Boolean, Boolean, Boolean, Int32)

[image]

Grasshopper SDK
GH_Document..::..FindAttributeByGrip Method (PointF, Boolean, Boolean, Boolean, Int32)
GH_Document Class See Also Send Feedback
Search for attributes that contain grips near the search locus

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_Attributes FindAttributeByGrip(
    PointF pt,
    bool bLimitToOutside,
    bool bIncludeInputs,
    bool bIncludeOutputs,
    int SearchRadius
)
Visual Basic
Public Function FindAttributeByGrip ( _
    pt As PointF, _
    bLimitToOutside As Boolean, _
    bIncludeInputs As Boolean, _
    bIncludeOutputs As Boolean, _
    SearchRadius As Integer _
) As IGH_Attributes

Parameters

pt
Type: System.Drawing..::..PointF
Pixel for search start
bLimitToOutside
Type: System..::..Boolean
If true, grips are ignored if the pt is on the 'inside' side.
bIncludeInputs
Type: System..::..Boolean
bIncludeOutputs
Type: System..::..Boolean
SearchRadius
Type: System..::..Int32
Radius of search

See Also

GH_Document Class
FindAttributeByGrip Overload
Grasshopper.Kernel Namespace


FindClusters Method

[image] [image]

Grasshopper SDK
GH_Document..::..FindClusters Method
GH_Document Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindClusters(Guid) | Find all the clusters that have a matching ID.
Public method | FindClusters(String) | Find all the clusters that have a matching filepath.

See Also

GH_Document Class
GH_Document Members
Grasshopper.Kernel Namespace


FindClusters Method (Guid)

[image]

Grasshopper SDK
GH_Document..::..FindClusters Method (Guid)
GH_Document Class See Also Send Feedback
Find all the clusters that have a matching ID.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<GH_Cluster> FindClusters(
    Guid id
)
Visual Basic
Public Function FindClusters ( _
    id As Guid _
) As List(Of GH_Cluster)

Parameters

id
Type: System..::..Guid
Cluster DocumentID to search for.

Return Value

A list of all the clusters that match the ID.

See Also

GH_Document Class
FindClusters Overload
Grasshopper.Kernel Namespace


FindClusters Method (String)

[image]

Grasshopper SDK
GH_Document..::..FindClusters Method (String)
GH_Document Class See Also Send Feedback
Find all the clusters that have a matching filepath.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<GH_Cluster> FindClusters(
    string filepath
)
Visual Basic
Public Function FindClusters ( _
    filepath As String _
) As List(Of GH_Cluster)

Parameters

filepath
Type: System..::..String
Cluster FilePath to search for.

Return Value

A list of all the clusters that match the filepath.

See Also

GH_Document Class
FindClusters Overload
Grasshopper.Kernel Namespace


FindComponent Method

[image] [image]

Grasshopper SDK
GH_Document..::..FindComponent Method
GH_Document Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindComponent(Point) | Search for components that contain the locus
Public method | FindComponent(Guid) | Search for components using an ID filter

See Also

GH_Document Class
GH_Document Members
Grasshopper.Kernel Namespace


FindComponent Method (Point)

[image]

Grasshopper SDK
GH_Document..::..FindComponent Method (Point)
GH_Document Class See Also Send Feedback
Search for components that contain the locus

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_Component FindComponent(
    Point pt
)
Visual Basic
Public Function FindComponent ( _
    pt As Point _
) As IGH_Component

Parameters

pt
Type: System.Drawing..::..Point
The point to search for

See Also

GH_Document Class
FindComponent Overload
Grasshopper.Kernel Namespace


FindComponent Method (Guid)

[image]

Grasshopper SDK
GH_Document..::..FindComponent Method (Guid)
GH_Document Class See Also Send Feedback
Search for components using an ID filter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_Component FindComponent(
    Guid id
)
Visual Basic
Public Function FindComponent ( _
    id As Guid _
) As IGH_Component

Parameters

id
Type: System..::..Guid
ID to search for

Return Value

The component with the ID, or Null if no component could be found

Remarks

See Also

GH_Document Class
FindComponent Overload
Grasshopper.Kernel Namespace


FindFloatingParameter Method

[image]

Grasshopper SDK
GH_Document..::..FindFloatingParameter Method
GH_Document Class See Also Send Feedback
Search for floating parameters that contain the locus

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_Param FindFloatingParameter(
    Point pt
)
Visual Basic
Public Function FindFloatingParameter ( _
    pt As Point _
) As IGH_Param

Parameters

pt
Type: System.Drawing..::..Point
Point for search start

See Also

GH_Document Class
Grasshopper.Kernel Namespace


FindInputParameter Method

[image]

Grasshopper SDK
GH_Document..::..FindInputParameter Method
GH_Document Class See Also Send Feedback
Search for input (upstream) parameters that contain the locus

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_Param FindInputParameter(
    Point pt
)
Visual Basic
Public Function FindInputParameter ( _
    pt As Point _
) As IGH_Param

Parameters

pt
Type: System.Drawing..::..Point
Point for search start

See Also

GH_Document Class
Grasshopper.Kernel Namespace


FindObject Method

[image] [image]

Grasshopper SDK
GH_Document..::..FindObject Method
GH_Document Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindObject(PointF, Single) | Find the topmost object that is closest to the point
Public method | FindObject(Guid, Boolean) | Find the object that matches the ID.
Public method | FindObject<(Of <<'(T>)>>)(Guid, Boolean) | Find the object that matches the ID.

See Also

GH_Document Class
GH_Document Members
Grasshopper.Kernel Namespace


FindObject Method (PointF, Single)

[image]

Grasshopper SDK
GH_Document..::..FindObject Method (PointF, Single)
GH_Document Class See Also Send Feedback
Find the topmost object that is closest to the point

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_DocumentObject FindObject(
    PointF pt,
    float radius
)
Visual Basic
Public Function FindObject ( _
    pt As PointF, _
    radius As Single _
) As IGH_DocumentObject

Parameters

pt
Type: System.Drawing..::..PointF
Canvas coordinates for object lookup
radius
Type: System..::..Single
Radius, (in canvas units) for search.

See Also

GH_Document Class
FindObject Overload
Grasshopper.Kernel Namespace


FindObject Method (Guid, Boolean)

[image]

Grasshopper SDK
GH_Document..::..FindObject Method (Guid, Boolean)
GH_Document Class See Also Send Feedback
Find the object that matches the ID.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_DocumentObject FindObject(
    Guid id,
    bool topLevelOnly
)
Visual Basic
Public Function FindObject ( _
    id As Guid, _
    topLevelOnly As Boolean _
) As IGH_DocumentObject

Parameters

id
Type: System..::..Guid
The ID to search for.
topLevelOnly
Type: System..::..Boolean
If True, only top-level objects are included. If False, the entire object attribute tree is recursed

See Also

GH_Document Class
FindObject Overload
Grasshopper.Kernel Namespace


FindObject(T) Method (Guid, Boolean)

[image]

Grasshopper SDK
GH_Document..::..FindObject<(Of <(<'T>)>)> Method (Guid, Boolean)
GH_Document Class See Also Send Feedback
Find the object that matches the ID.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public T FindObject<T>(
    Guid id,
    bool topLevelOnly
)
where T : IGH_DocumentObject
Visual Basic
Public Function FindObject(Of T As IGH_DocumentObject) ( _
    id As Guid, _
    topLevelOnly As Boolean _
) As T

Parameters

id
Type: System..::..Guid
The ID to search for.
topLevelOnly
Type: System..::..Boolean
If True, only top-level objects are included. If False, the entire object attribute tree is recursed

Type Parameters

T
Object type constraint.

See Also

GH_Document Class
FindObject Overload
Grasshopper.Kernel Namespace


FindObjects Method

[image]

Grasshopper SDK
GH_Document..::..FindObjects Method
GH_Document Class See Also Send Feedback
Find the objects in the document that match the search term. Top level object names and nicknames are searched, as well as descriptions. Some objects are special cased to allow for more targeted searches. Data descriptions are not searched.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<IGH_DocumentObject> FindObjects(
    List<string> keys,
    int maxCount
)
Visual Basic
Public Function FindObjects ( _
    keys As List(Of String), _
    maxCount As Integer _
) As List(Of IGH_DocumentObject)

Parameters

keys
Type: System.Collections.Generic..::..List <(Of <(<' String >)>)>
maxCount
Type: System..::..Int32

See Also

GH_Document Class
Grasshopper.Kernel Namespace


FindOutputParameter Method

[image]

Grasshopper SDK
GH_Document..::..FindOutputParameter Method
GH_Document Class See Also Send Feedback
Search for output (downstream) parameters that contain the locus

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_Param FindOutputParameter(
    Point pt
)
Visual Basic
Public Function FindOutputParameter ( _
    pt As Point _
) As IGH_Param

Parameters

pt
Type: System.Drawing..::..Point
Point for search start

See Also

GH_Document Class
Grasshopper.Kernel Namespace


FindParameter Method

[image]

Grasshopper SDK
GH_Document..::..FindParameter Method
GH_Document Class See Also Send Feedback
Search for parameters using an ID filter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_Param FindParameter(
    Guid id
)
Visual Basic
Public Function FindParameter ( _
    id As Guid _
) As IGH_Param

Parameters

id
Type: System..::..Guid
ID to search for

Return Value

The parameter with the ID, or Null if no parameter could be found

Remarks

See Also

GH_Document Class
Grasshopper.Kernel Namespace


GetAllInstanceIDs Method

[image]

Grasshopper SDK
GH_Document..::..GetAllInstanceIDs Method
GH_Document Class See Also Send Feedback
Get a sorted list of all the IGH_DocumentObject instance IDs in this document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public SortedList<Guid, int> GetAllInstanceIDs(
    bool topLevelOnly
)
Visual Basic
Public Function GetAllInstanceIDs ( _
    topLevelOnly As Boolean _
) As SortedList(Of Guid, Integer)

Parameters

topLevelOnly
Type: System..::..Boolean
If true, only top level objects are considered.

Return Value

A sorted fictionary of IDs and Integers. The integers represent the indices of the top-level objects that contained the ids. Since the object list inside a GH_Document is not static, these indices will not remain valid.

See Also

GH_Document Class
Grasshopper.Kernel Namespace


InactiveObjects Method

[image]

Grasshopper SDK
GH_Document..::..InactiveObjects Method
GH_Document Class See Also Send Feedback
Returns all objects in the document that don't implement the IGH_ActiveObject interface

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<IGH_ActiveObject> InactiveObjects()
Visual Basic
Public Function InactiveObjects As List(Of IGH_ActiveObject)

Return Value

See Also

GH_Document Class
Grasshopper.Kernel Namespace


InvertSelection Method

[image]

Grasshopper SDK
GH_Document..::..InvertSelection Method
GH_Document Class See Also Send Feedback
Invert the selected state of all top-level attributes.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void InvertSelection()
Visual Basic
Public Sub InvertSelection

See Also

GH_Document Class
Grasshopper.Kernel Namespace


IsEscapeKeyDown Method

[image]

Grasshopper SDK
GH_Document..::..IsEscapeKeyDown Method
GH_Document Class See Also Send Feedback
Gets whether the escape key was pressed since the last time this function was called. Though in reality the actual escape state is checked no more than once every 50 milliseconds or so, which should be sufficient for a smooth user experience.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool IsEscapeKeyDown()
Visual Basic
Public Shared Function IsEscapeKeyDown As Boolean

Return Value

True if escape was/is pressed, false if otherwise.

Remarks

If GetAsyncKeyState is called by some other application, it will mess with the value returned here, as GetAsyncKeyState is a system wide static method.

See Also

GH_Document Class
Grasshopper.Kernel Namespace


MergeDocument Method

[image] [image]

Grasshopper SDK
GH_Document..::..MergeDocument Method
GH_Document Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MergeDocument(GH_Document) | Hoist all objects from another document into this one.
Public method | MergeDocument(GH_Document, Boolean) | Hoist all objects from another document into this one.
Public method | MergeDocument(GH_Document, Boolean, Boolean) | Hoist all objects from another document into this one.

See Also

GH_Document Class
GH_Document Members
Grasshopper.Kernel Namespace


MergeDocument Method (GH_Document)

[image]

Grasshopper SDK
GH_Document..::..MergeDocument Method (GH_Document)
GH_Document Class See Also Send Feedback
Hoist all objects from another document into this one.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool MergeDocument(
    GH_Document other
)
Visual Basic
Public Function MergeDocument ( _
    other As GH_Document _
) As Boolean

Parameters

other
Type: Grasshopper.Kernel..::..GH_Document
The other document. Cannot be Null or

Remarks

The objects will be moved, not copied. The other document ends up being empty since objects can only belong to one document at a time.

See Also

GH_Document Class
MergeDocument Overload
Grasshopper.Kernel Namespace


MergeDocument Method (GH_Document, Boolean)

[image]

Grasshopper SDK
GH_Document..::..MergeDocument Method (GH_Document, Boolean)
GH_Document Class See Also Send Feedback
Hoist all objects from another document into this one.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool MergeDocument(
    GH_Document other,
    bool resolveProxies
)
Visual Basic
Public Function MergeDocument ( _
    other As GH_Document, _
    resolveProxies As Boolean _
) As Boolean

Parameters

other
Type: Grasshopper.Kernel..::..GH_Document
The other document. Cannot be Null or
resolveProxies
Type: System..::..Boolean
If True, an attempt is made to repair proxy sources after insertion.

Remarks

The objects will be moved, not copied. The other document ends up being empty since objects can only belong to one document at a time.

See Also

GH_Document Class
MergeDocument Overload
Grasshopper.Kernel Namespace


MergeDocument Method (GH_Document, Boolean, Boolean)

[image]

Grasshopper SDK
GH_Document..::..MergeDocument Method (GH_Document, Boolean, Boolean)
GH_Document Class See Also Send Feedback
Hoist all objects from another document into this one.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool MergeDocument(
    GH_Document other,
    bool resolveProxies,
    bool removeProxies
)
Visual Basic
Public Function MergeDocument ( _
    other As GH_Document, _
    resolveProxies As Boolean, _
    removeProxies As Boolean _
) As Boolean

Parameters

other
Type: Grasshopper.Kernel..::..GH_Document
The other document. Cannot be null.
resolveProxies
Type: System..::..Boolean
If True, an attempt is made to repair proxy sources after insertion.
removeProxies
Type: System..::..Boolean
If True, all remaining proxies will be deleted.

Remarks

The objects will be moved, not copied. The other document ends up being empty since objects can only belong to one document at a time.

See Also

GH_Document Class
MergeDocument Overload
Grasshopper.Kernel Namespace


Modified Method

[image]

Grasshopper SDK
GH_Document..::..Modified Method
GH_Document Class See Also Send Feedback
Sets the modified flag of this document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Modified()
Visual Basic
Public Sub Modified

See Also

GH_Document Class
Grasshopper.Kernel Namespace


MutateAllIds Method

[image]

Grasshopper SDK
GH_Document..::..MutateAllIds Method
GH_Document Class See Also Send Feedback
Change all the instance UUIDs of all objects in the document. Be sure to resolve all proxy sources before mutating IDs. This function will ensure all groups are updated appropriately.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void MutateAllIds()
Visual Basic
Public Sub MutateAllIds

See Also

GH_Document Class
Grasshopper.Kernel Namespace


NewSolution Method

[image] [image]

Grasshopper SDK
GH_Document..::..NewSolution Method
GH_Document Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NewSolution(Boolean) | Start a new solution.
Public method | NewSolution(Boolean, GH_SolutionMode) | Start a new solution.

See Also

GH_Document Class
GH_Document Members
Grasshopper.Kernel Namespace


NewSolution Method (Boolean)

[image]

Grasshopper SDK
GH_Document..::..NewSolution Method (Boolean)
GH_Document Class See Also Send Feedback
Start a new solution.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void NewSolution(
    bool expireAllObjects
)
Visual Basic
Public Sub NewSolution ( _
    expireAllObjects As Boolean _
)

Parameters

expireAllObjects
Type: System..::..Boolean
If True, all objects will be recalculated. If False, only already expired objects will be recalculated.

See Also

GH_Document Class
NewSolution Overload
Grasshopper.Kernel Namespace


NewSolution Method (Boolean, GH_SolutionMode)

[image]

Grasshopper SDK
GH_Document..::..NewSolution Method (Boolean, GH_SolutionMode)
GH_Document Class See Also Send Feedback
Start a new solution.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void NewSolution(
    bool expireAllObjects,
    GH_SolutionMode mode
)
Visual Basic
Public Sub NewSolution ( _
    expireAllObjects As Boolean, _
    mode As GH_SolutionMode _
)

Parameters

expireAllObjects
Type: System..::..Boolean
If True, all objects will be recalculated. If False, only already expired objects will be recalculated.
mode
Type: Grasshopper.Kernel..::..GH_SolutionMode
Solution mode. Only use CommandLine or Silent if your solution runs in the background.

See Also

GH_Document Class
NewSolution Overload
Grasshopper.Kernel Namespace


NonBlankFilter Method

[image]

Grasshopper SDK
GH_Document..::..NonBlankFilter Method
GH_Document Class See Also Send Feedback
This delegate can be used in the FindAllDownstreamObjects(...) methods. Only includes objects that are non-blank and non-failed.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool NonBlankFilter(
    IGH_ActiveObject iObj
)
Visual Basic
Public Shared Function NonBlankFilter ( _
    iObj As IGH_ActiveObject _
) As Boolean

Parameters

iObj
Type: Grasshopper.Kernel..::..IGH_ActiveObject

See Also

GH_Document Class
Grasshopper.Kernel Namespace


NullFilter Method

[image]

Grasshopper SDK
GH_Document..::..NullFilter Method
GH_Document Class See Also Send Feedback
This delegate can be used in the FindAllDownstreamObjects(...) methods. Includes all objects.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool NullFilter(
    IGH_ActiveObject iObj
)
Visual Basic
Public Shared Function NullFilter ( _
    iObj As IGH_ActiveObject _
) As Boolean

Parameters

iObj
Type: Grasshopper.Kernel..::..IGH_ActiveObject

See Also

GH_Document Class
Grasshopper.Kernel Namespace


OnContextChanged Method

[image]

Grasshopper SDK
GH_Document..::..OnContextChanged Method
GH_Document Class See Also Send Feedback
Raise the ContextChanged event.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void OnContextChanged()
Visual Basic
Public Sub OnContextChanged

See Also

GH_Document Class
Grasshopper.Kernel Namespace


OnEnabledChanged Method

[image]

Grasshopper SDK
GH_Document..::..OnEnabledChanged Method
GH_Document Class See Also Send Feedback
Raise the EnabledChanged event.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void OnEnabledChanged()
Visual Basic
Public Sub OnEnabledChanged

See Also

GH_Document Class
Grasshopper.Kernel Namespace


OnFilePathChanged Method

[image]

Grasshopper SDK
GH_Document..::..OnFilePathChanged Method
GH_Document Class See Also Send Feedback
Raise the FilePathChanged event.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void OnFilePathChanged(
    string old,
    string new
)
Visual Basic
Public Sub OnFilePathChanged ( _
    old As String, _
    new As String _
)

Parameters

old
Type: System..::..String
Old filepath.
new
Type: System..::..String
New filepath.

See Also

GH_Document Class
Grasshopper.Kernel Namespace


OnModifiedChanged Method

[image]

Grasshopper SDK
GH_Document..::..OnModifiedChanged Method
GH_Document Class See Also Send Feedback
Raise the ModifiedChanged event

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void OnModifiedChanged()
Visual Basic
Public Sub OnModifiedChanged

Remarks

See Also

GH_Document Class
Grasshopper.Kernel Namespace


OnObjectAdded Method

[image]

Grasshopper SDK
GH_Document..::..OnObjectAdded Method
GH_Document Class See Also Send Feedback
Raise the ObjectsAdded event.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void OnObjectAdded(
    IGH_DocumentObject doc_object
)
Visual Basic
Public Sub OnObjectAdded ( _
    doc_object As IGH_DocumentObject _
)

Parameters

doc_object
Type: Grasshopper.Kernel..::..IGH_DocumentObject
Object that was added.

See Also

GH_Document Class
Grasshopper.Kernel Namespace


OnObjectDeleted Method

[image]

Grasshopper SDK
GH_Document..::..OnObjectDeleted Method
GH_Document Class See Also Send Feedback
Raise the ObjectsDeleted event.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void OnObjectDeleted(
    IGH_DocumentObject doc_object
)
Visual Basic
Public Sub OnObjectDeleted ( _
    doc_object As IGH_DocumentObject _
)

Parameters

doc_object
Type: Grasshopper.Kernel..::..IGH_DocumentObject
Object that was deleted.

See Also

GH_Document Class
Grasshopper.Kernel Namespace


OnObjectsAdded Method

[image]

Grasshopper SDK
GH_Document..::..OnObjectsAdded Method
GH_Document Class See Also Send Feedback
Raise the ObjectsAdded event.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void OnObjectsAdded(
    IEnumerable<IGH_DocumentObject> doc_objects
)
Visual Basic
Public Sub OnObjectsAdded ( _
    doc_objects As IEnumerable(Of IGH_DocumentObject) _
)

Parameters

doc_objects
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' IGH_DocumentObject >)>)>
Objects that were added.

See Also

GH_Document Class
Grasshopper.Kernel Namespace


OnObjectsDeleted Method

[image]

Grasshopper SDK
GH_Document..::..OnObjectsDeleted Method
GH_Document Class See Also Send Feedback
Raise the ObjectsDeleted event.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void OnObjectsDeleted(
    IEnumerable<IGH_DocumentObject> doc_objects
)
Visual Basic
Public Sub OnObjectsDeleted ( _
    doc_objects As IEnumerable(Of IGH_DocumentObject) _
)

Parameters

doc_objects
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' IGH_DocumentObject >)>)>
Objects that were deleted.

See Also

GH_Document Class
Grasshopper.Kernel Namespace


OnSettingsChanged Method

[image]

Grasshopper SDK
GH_Document..::..OnSettingsChanged Method
GH_Document Class See Also Send Feedback
Raise the SettingsChanged event.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void OnSettingsChanged(
    GH_DocumentSettings kind
)
Visual Basic
Public Sub OnSettingsChanged ( _
    kind As GH_DocumentSettings _
)

Parameters

kind
Type: Grasshopper.Kernel..::..GH_DocumentSettings

See Also

GH_Document Class
Grasshopper.Kernel Namespace


OnUndoStateChanged Method

[image]

Grasshopper SDK
GH_Document..::..OnUndoStateChanged Method
GH_Document Class See Also Send Feedback
Raise the UndoStateChanged event.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void OnUndoStateChanged(
    GH_UndoOperation op,
    GH_UndoRecord rec
)
Visual Basic
Public Sub OnUndoStateChanged ( _
    op As GH_UndoOperation, _
    rec As GH_UndoRecord _
)

Parameters

op
Type: Grasshopper.Kernel..::..GH_UndoOperation
Type of undo operation to provide with the Event arguments.
rec
Type: Grasshopper.Kernel.Undo..::..GH_UndoRecord
Record to provide in the Event arguments.

See Also

GH_Document Class
Grasshopper.Kernel Namespace


PreviewCurrentMeshParameters Method

[image]

Grasshopper SDK
GH_Document..::..PreviewCurrentMeshParameters Method
GH_Document Class See Also Send Feedback
Gets the currently relevant meshing parameters (do not modify the instance as it may be shared).

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public MeshingParameters PreviewCurrentMeshParameters()
Visual Basic
Public Function PreviewCurrentMeshParameters As MeshingParameters

See Also

GH_Document Class
Grasshopper.Kernel Namespace


Read Method

[image]

Grasshopper SDK
GH_Document..::..Read Method
GH_Document Class See Also Send Feedback
Standard archiving function. Will deserialize the entire document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Read(
    GH_IReader reader
)
Visual Basic
Public Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

Implements

GH_ISerializable..::..Read(GH_IReader)

See Also

GH_Document Class
Grasshopper.Kernel Namespace


Redo Method

[image]

Grasshopper SDK
GH_Document..::..Redo Method
GH_Document Class See Also Send Feedback
Perform the first redo event.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Redo()
Visual Basic
Public Function Redo As Boolean

Return Value

True on success, false on no redo event or invalid redo event.

See Also

GH_Document Class
Grasshopper.Kernel Namespace


RelevantObjectAtPoint Method

[image] [image]

Grasshopper SDK
GH_Document..::..RelevantObjectAtPoint Method
GH_Document Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RelevantObjectAtPoint(PointF) | Find the most relevant object at a given canvas location. The most relevant object might be a regular Object (Component or Parameter), it might be an attribute grip, an attribute balloon, a wire or a group.
Public method | RelevantObjectAtPoint(PointF, GH_RelevantObjectFilter) | Find the most relevant object at a given canvas location. The most relevant object might be a regular Object (Component or Parameter), it might be an attribute grip, an attribute balloon, a wire or a group.

See Also

GH_Document Class
GH_Document Members
Grasshopper.Kernel Namespace


RelevantObjectAtPoint Method (PointF)

[image]

Grasshopper SDK
GH_Document..::..RelevantObjectAtPoint Method (PointF)
GH_Document Class See Also Send Feedback
Find the most relevant object at a given canvas location. The most relevant object might be a regular Object (Component or Parameter), it might be an attribute grip, an attribute balloon, a wire or a group.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_RelevantObjectData RelevantObjectAtPoint(
    PointF pt
)
Visual Basic
Public Function RelevantObjectAtPoint ( _
    pt As PointF _
) As GH_RelevantObjectData

Parameters

pt
Type: System.Drawing..::..PointF
The point to test.

Return Value

Information about the most relevant object or Null if no relevant object could be found at the given point.

See Also

GH_Document Class
RelevantObjectAtPoint Overload
Grasshopper.Kernel Namespace


RelevantObjectAtPoint Method (PointF, GH_RelevantObjectFilter)

[image]

Grasshopper SDK
GH_Document..::..RelevantObjectAtPoint Method (PointF, GH_RelevantObjectFilter)
GH_Document Class See Also Send Feedback
Find the most relevant object at a given canvas location. The most relevant object might be a regular Object (Component or Parameter), it might be an attribute grip, an attribute balloon, a wire or a group.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_RelevantObjectData RelevantObjectAtPoint(
    PointF pt,
    GH_RelevantObjectFilter searchFilter
)
Visual Basic
Public Function RelevantObjectAtPoint ( _
    pt As PointF, _
    searchFilter As GH_RelevantObjectFilter _
) As GH_RelevantObjectData

Parameters

pt
Type: System.Drawing..::..PointF
The point to test.
searchFilter
Type: Grasshopper.Kernel..::..GH_RelevantObjectFilter

Return Value

Information about the most relevant object or Null if no relevant object could be found at the given point.

See Also

GH_Document Class
RelevantObjectAtPoint Overload
Grasshopper.Kernel Namespace


RemoveObject Method

[image] [image]

Grasshopper SDK
GH_Document..::..RemoveObject Method
GH_Document Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveObject(IGH_Attributes, Boolean) | Remove the top-level object in the attribute tree from the document. This method does not add an Undo event, that is the responsibility of the caller.
Public method | RemoveObject(IGH_DocumentObject, Boolean) | Remove the object from the document. This removal is the precursor to object deletion. Do not call this function if you intend to transfer the object to another GH_Document. This method does not add an Undo event, that is the responsibility of the caller.

See Also

GH_Document Class
GH_Document Members
Grasshopper.Kernel Namespace


RemoveObject Method (IGH_Attributes, Boolean)

[image]

Grasshopper SDK
GH_Document..::..RemoveObject Method (IGH_Attributes, Boolean)
GH_Document Class See Also Send Feedback
Remove the top-level object in the attribute tree from the document. This method does not add an Undo event, that is the responsibility of the caller.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool RemoveObject(
    IGH_Attributes attribute,
    bool update
)
Visual Basic
Public Function RemoveObject ( _
    attribute As IGH_Attributes, _
    update As Boolean _
) As Boolean

Parameters

attribute
Type: Grasshopper.Kernel..::..IGH_Attributes
update
Type: System..::..Boolean

See Also

GH_Document Class
RemoveObject Overload
Grasshopper.Kernel Namespace


RemoveObject Method (IGH_DocumentObject, Boolean)

[image]

Grasshopper SDK
GH_Document..::..RemoveObject Method (IGH_DocumentObject, Boolean)
GH_Document Class See Also Send Feedback
Remove the object from the document. This removal is the precursor to object deletion. Do not call this function if you intend to transfer the object to another GH_Document. This method does not add an Undo event, that is the responsibility of the caller.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool RemoveObject(
    IGH_DocumentObject docObject,
    bool update
)
Visual Basic
Public Function RemoveObject ( _
    docObject As IGH_DocumentObject, _
    update As Boolean _
) As Boolean

Parameters

docObject
Type: Grasshopper.Kernel..::..IGH_DocumentObject
Object to remove.
update
Type: System..::..Boolean

See Also

GH_Document Class
RemoveObject Overload
Grasshopper.Kernel Namespace


RemoveObjects Method

[image]

Grasshopper SDK
GH_Document..::..RemoveObjects Method
GH_Document Class See Also Send Feedback
Remove the specified objects from the document. This removal is the precursor to object deletion. Do not call this function if you intend to transfer the objects to another GH_Document. This method does not add an Undo event, that is the responsibility of the caller.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int RemoveObjects(
    IEnumerable<IGH_DocumentObject> objectList,
    bool update
)
Visual Basic
Public Function RemoveObjects ( _
    objectList As IEnumerable(Of IGH_DocumentObject), _
    update As Boolean _
) As Integer

Parameters

objectList
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' IGH_DocumentObject >)>)>
Objects to remove from this document.
update
Type: System..::..Boolean
If True, the solution will be recomputed.

Return Value

The number of objects actually deleted.

See Also

GH_Document Class
Grasshopper.Kernel Namespace


RemoveSelection Method

[image]

Grasshopper SDK
GH_Document..::..RemoveSelection Method
GH_Document Class See Also Send Feedback
Delete all the objects in the selection set. This method does not record an Undo event, that is the responsibility of the caller.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RemoveSelection(
    bool update
)
Visual Basic
Public Sub RemoveSelection ( _
    update As Boolean _
)

Parameters

update
Type: System..::..Boolean
If True, the solution will be recomputed.

See Also

GH_Document Class
Grasshopper.Kernel Namespace


RepairProxySources Method

[image]

Grasshopper SDK
GH_Document..::..RepairProxySources Method
GH_Document Class See Also Send Feedback
Attempts to resolve all proxy sources in the document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool RepairProxySources()
Visual Basic
Public Function RepairProxySources As Boolean

Return Value

False if one or more proxies could not be resolved

See Also

GH_Document Class
Grasshopper.Kernel Namespace


ReplaceProxySources Method

[image]

Grasshopper SDK
GH_Document..::..ReplaceProxySources Method
GH_Document Class See Also Send Feedback
Replace all remaining proxy sources in the document with UnresolvedProxy Objects.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ReplaceProxySources()
Visual Basic
Public Sub ReplaceProxySources

See Also

GH_Document Class
Grasshopper.Kernel Namespace


RequestAbortSolution Method

[image]

Grasshopper SDK
GH_Document..::..RequestAbortSolution Method
GH_Document Class See Also Send Feedback
Set the requestabort flag. The solution will be aborted whenever the current active object is completed. It is also possible that active objects themselves implement an abortion mechanism, in which case abortion might occur even sooner.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RequestAbortSolution()
Visual Basic
Public Sub RequestAbortSolution

See Also

GH_Document Class
Grasshopper.Kernel Namespace


ScheduleSolution Method

[image] [image]

Grasshopper SDK
GH_Document..::..ScheduleSolution Method
GH_Document Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScheduleSolution(Int32) | Schedule a new solution after a specified time interval. The schedule is erased if another solution is triggered before the schedule is executed. Tight schedules override loose schedules. If this method is called during a solution, the schedule will be started after the current solution completes.
Public method | ScheduleSolution(Int32, GH_Document..::..GH_ScheduleDelegate) | Schedule a new solution after a specified time interval. The schedule is erased if another solution is triggered before the schedule is executed. Tight schedules override loose schedules. If this method is called during a solution, the schedule will be started after the current solution completes.

See Also

GH_Document Class
GH_Document Members
Grasshopper.Kernel Namespace


ScheduleSolution Method (Int32)

[image]

Grasshopper SDK
GH_Document..::..ScheduleSolution Method (Int32)
GH_Document Class See Also Send Feedback
Schedule a new solution after a specified time interval. The schedule is erased if another solution is triggered before the schedule is executed. Tight schedules override loose schedules. If this method is called during a solution, the schedule will be started after the current solution completes.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ScheduleSolution(
    int delay
)
Visual Basic
Public Sub ScheduleSolution ( _
    delay As Integer _
)

Parameters

delay
Type: System..::..Int32
The delay (in milliseconds) between the completion of this solution and the start of the scheduled solution. If the delay is 1ms or more, a timer will be used to trigger a new solution sometime in the future. If a delay of 0ms is used, then the next solution will run recursively within the current solution. You should not use a delay of zero milliseconds too often as it will cause the Rhino process to run out of stack-space. The SolutionDepth property can be used to see how deeply recursive the solution currently is.

See Also

GH_Document Class
ScheduleSolution Overload
Grasshopper.Kernel Namespace


ScheduleSolution Method (Int32, GH_Document.GH_ScheduleDelegate)

[image]

Grasshopper SDK
GH_Document..::..ScheduleSolution Method (Int32, GH_Document..::..GH_ScheduleDelegate)
GH_Document Class See Also Send Feedback
Schedule a new solution after a specified time interval. The schedule is erased if another solution is triggered before the schedule is executed. Tight schedules override loose schedules. If this method is called during a solution, the schedule will be started after the current solution completes.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ScheduleSolution(
    int delay,
    GH_Document..::..GH_ScheduleDelegate callback
)
Visual Basic
Public Sub ScheduleSolution ( _
    delay As Integer, _
    callback As GH_Document..::..GH_ScheduleDelegate _
)

Parameters

delay
Type: System..::..Int32
The delay (in milliseconds) between the completion of this solution and the start of the scheduled solution. If the delay is 1ms or more, a timer will be used to trigger a new solution sometime in the future. If a delay of 0ms is used, then the next solution will run recursively within the current solution. You should not use a delay of zero milliseconds too often as it will cause the Rhino process to run out of stack-space. The SolutionDepth property can be used to see how deeply recursive the solution currently is.
callback
Type: Grasshopper.Kernel..::..GH_Document..::..GH_ScheduleDelegate
If not null, the callback will be called before the scheduled solution is triggered.

See Also

GH_Document Class
ScheduleSolution Overload
Grasshopper.Kernel Namespace


Select Method

[image] [image]

Grasshopper SDK
GH_Document..::..Select Method
GH_Document Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select(GH_RelevantObjectData) | Default pick selection behaviour. (looks at current Shift + Control modifier states to determine addition/removal)
Public method | Select(GH_RelevantObjectData, Boolean, Boolean) | Default pick selection behaviour

See Also

GH_Document Class
GH_Document Members
Grasshopper.Kernel Namespace


Select Method (GH_RelevantObjectData)

[image]

Grasshopper SDK
GH_Document..::..Select Method (GH_RelevantObjectData)
GH_Document Class See Also Send Feedback
Default pick selection behaviour. (looks at current Shift + Control modifier states to determine addition/removal)

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_SelectionState Select(
    GH_RelevantObjectData obj_dat
)
Visual Basic
Public Function Select ( _
    obj_dat As GH_RelevantObjectData _
) As GH_SelectionState

Parameters

obj_dat
Type: Grasshopper.Kernel..::..GH_RelevantObjectData
Information regarding the object to be selected.

See Also

GH_Document Class
Select Overload
Grasshopper.Kernel Namespace


Select Method (GH_RelevantObjectData, Boolean, Boolean)

[image]

Grasshopper SDK
GH_Document..::..Select Method (GH_RelevantObjectData, Boolean, Boolean)
GH_Document Class See Also Send Feedback
Default pick selection behaviour

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_SelectionState Select(
    GH_RelevantObjectData obj_dat,
    bool bAdd,
    bool bRemove
)
Visual Basic
Public Function Select ( _
    obj_dat As GH_RelevantObjectData, _
    bAdd As Boolean, _
    bRemove As Boolean _
) As GH_SelectionState

Parameters

obj_dat
Type: Grasshopper.Kernel..::..GH_RelevantObjectData
Information regarding the object to be selected.
bAdd
Type: System..::..Boolean
If True, it will add the topmost unselected object that contains pt to the selection set. If False, the selection set will be cleared when an unselected object is picked
bRemove
Type: System..::..Boolean
If True, it will remove the topmost selected object that contains pt from the selection set.

See Also

GH_Document Class
Select Overload
Grasshopper.Kernel Namespace


SelectAll Method

[image]

Grasshopper SDK
GH_Document..::..SelectAll Method
GH_Document Class See Also Send Feedback
Select all top-level attributes.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SelectAll()
Visual Basic
Public Sub SelectAll

See Also

GH_Document Class
Grasshopper.Kernel Namespace


SelectedObjects Method

[image]

Grasshopper SDK
GH_Document..::..SelectedObjects Method
GH_Document Class See Also Send Feedback
Returns all selected objects in the document

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<IGH_DocumentObject> SelectedObjects()
Visual Basic
Public Function SelectedObjects As List(Of IGH_DocumentObject)

Return Value

See Also

GH_Document Class
Grasshopper.Kernel Namespace


SetEnabledFlags Method

[image] [image]

Grasshopper SDK
GH_Document..::..SetEnabledFlags Method
GH_Document Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetEnabledFlags(Boolean) | Set the enabled flags of all selected objects to true or false
Public method | SetEnabledFlags(List<(Of <<'(IGH_DocumentObject>)>>), Boolean) | Set the enabled flags of all specified objects to true or false

See Also

GH_Document Class
GH_Document Members
Grasshopper.Kernel Namespace


SetEnabledFlags Method (Boolean)

[image]

Grasshopper SDK
GH_Document..::..SetEnabledFlags Method (Boolean)
GH_Document Class See Also Send Feedback
Set the enabled flags of all selected objects to true or false

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SetEnabledFlags(
    bool bEnable
)
Visual Basic
Public Sub SetEnabledFlags ( _
    bEnable As Boolean _
)

Parameters

bEnable
Type: System..::..Boolean

See Also

GH_Document Class
SetEnabledFlags Overload
Grasshopper.Kernel Namespace


SetEnabledFlags Method (List(IGH_DocumentObject), Boolean)

[image]

Grasshopper SDK
GH_Document..::..SetEnabledFlags Method (List<(Of <(<'IGH_DocumentObject>)>)>, Boolean)
GH_Document Class See Also Send Feedback
Set the enabled flags of all specified objects to true or false

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SetEnabledFlags(
    List<IGH_DocumentObject> objects,
    bool bEnable
)
Visual Basic
Public Sub SetEnabledFlags ( _
    objects As List(Of IGH_DocumentObject), _
    bEnable As Boolean _
)

Parameters

objects
Type: System.Collections.Generic..::..List <(Of <(<' IGH_DocumentObject >)>)>
bEnable
Type: System..::..Boolean

See Also

GH_Document Class
SetEnabledFlags Overload
Grasshopper.Kernel Namespace


SetPreviewFlags Method

[image] [image]

Grasshopper SDK
GH_Document..::..SetPreviewFlags Method
GH_Document Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetPreviewFlags(Boolean) | Set the preview flags of all selected objects to true or false
Public method | SetPreviewFlags(List<(Of <<'(IGH_DocumentObject>)>>), Boolean) | Set the preview flags of all specified objects to true or false

See Also

GH_Document Class
GH_Document Members
Grasshopper.Kernel Namespace


SetPreviewFlags Method (Boolean)

[image]

Grasshopper SDK
GH_Document..::..SetPreviewFlags Method (Boolean)
GH_Document Class See Also Send Feedback
Set the preview flags of all selected objects to true or false

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SetPreviewFlags(
    bool bPreview
)
Visual Basic
Public Sub SetPreviewFlags ( _
    bPreview As Boolean _
)

Parameters

bPreview
Type: System..::..Boolean

See Also

GH_Document Class
SetPreviewFlags Overload
Grasshopper.Kernel Namespace


SetPreviewFlags Method (List(IGH_DocumentObject), Boolean)

[image]

Grasshopper SDK
GH_Document..::..SetPreviewFlags Method (List<(Of <(<'IGH_DocumentObject>)>)>, Boolean)
GH_Document Class See Also Send Feedback
Set the preview flags of all specified objects to true or false

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SetPreviewFlags(
    List<IGH_DocumentObject> objects,
    bool bPreview
)
Visual Basic
Public Sub SetPreviewFlags ( _
    objects As List(Of IGH_DocumentObject), _
    bPreview As Boolean _
)

Parameters

objects
Type: System.Collections.Generic..::..List <(Of <(<' IGH_DocumentObject >)>)>
bPreview
Type: System..::..Boolean

See Also

GH_Document Class
SetPreviewFlags Overload
Grasshopper.Kernel Namespace


ShowPreviewSettings Method

[image]

Grasshopper SDK
GH_Document..::..ShowPreviewSettings Method
GH_Document Class See Also Send Feedback
Display the Preview settings dialog.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ShowPreviewSettings()
Visual Basic
Public Sub ShowPreviewSettings

See Also

GH_Document Class
Grasshopper.Kernel Namespace


SolutionProgress Method

[image]

Grasshopper SDK
GH_Document..::..SolutionProgress Method
GH_Document Class See Also Send Feedback
Returns the progress of the current solution.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int SolutionProgress(
    out int objectIndex,
    out int maximumIndex
)
Visual Basic
Public Function SolutionProgress ( _
    <OutAttribute> ByRef objectIndex As Integer, _
    <OutAttribute> ByRef maximumIndex As Integer _
) As Integer

Parameters

objectIndex
Type: System..::..Int32 %
The index of the object currently being solved.
maximumIndex
Type: System..::..Int32 %
The highest index.

Return Value

Percentage of solution as a number between 1 and 99 inclusive.

See Also

GH_Document Class
Grasshopper.Kernel Namespace


ToggleEnabledFlags Method

[image] [image]

Grasshopper SDK
GH_Document..::..ToggleEnabledFlags Method
GH_Document Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToggleEnabledFlags()()()() | Toggle the enabled flags of all selected objects
Public method | ToggleEnabledFlags(List<(Of <<'(IGH_DocumentObject>)>>)) | Toggle the enabled flags of all specified objects

See Also

GH_Document Class
GH_Document Members
Grasshopper.Kernel Namespace


ToggleEnabledFlags Method

[image]

Grasshopper SDK
GH_Document..::..ToggleEnabledFlags Method
GH_Document Class See Also Send Feedback
Toggle the enabled flags of all selected objects

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ToggleEnabledFlags()
Visual Basic
Public Sub ToggleEnabledFlags

See Also

GH_Document Class
ToggleEnabledFlags Overload
Grasshopper.Kernel Namespace


ToggleEnabledFlags Method (List(IGH_DocumentObject))

[image]

Grasshopper SDK
GH_Document..::..ToggleEnabledFlags Method (List<(Of <(<'IGH_DocumentObject>)>)>)
GH_Document Class See Also Send Feedback
Toggle the enabled flags of all specified objects

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ToggleEnabledFlags(
    List<IGH_DocumentObject> objects
)
Visual Basic
Public Sub ToggleEnabledFlags ( _
    objects As List(Of IGH_DocumentObject) _
)

Parameters

objects
Type: System.Collections.Generic..::..List <(Of <(<' IGH_DocumentObject >)>)>

See Also

GH_Document Class
ToggleEnabledFlags Overload
Grasshopper.Kernel Namespace


TogglePreviewFlags Method

[image] [image]

Grasshopper SDK
GH_Document..::..TogglePreviewFlags Method
GH_Document Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TogglePreviewFlags()()()() | Toggle the preview flags of all selected objects
Public method | TogglePreviewFlags(List<(Of <<'(IGH_DocumentObject>)>>)) | Toggle the preview flags of all specified objects

See Also

GH_Document Class
GH_Document Members
Grasshopper.Kernel Namespace


TogglePreviewFlags Method

[image]

Grasshopper SDK
GH_Document..::..TogglePreviewFlags Method
GH_Document Class See Also Send Feedback
Toggle the preview flags of all selected objects

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void TogglePreviewFlags()
Visual Basic
Public Sub TogglePreviewFlags

See Also

GH_Document Class
TogglePreviewFlags Overload
Grasshopper.Kernel Namespace


TogglePreviewFlags Method (List(IGH_DocumentObject))

[image]

Grasshopper SDK
GH_Document..::..TogglePreviewFlags Method (List<(Of <(<'IGH_DocumentObject>)>)>)
GH_Document Class See Also Send Feedback
Toggle the preview flags of all specified objects

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void TogglePreviewFlags(
    List<IGH_DocumentObject> objects
)
Visual Basic
Public Sub TogglePreviewFlags ( _
    objects As List(Of IGH_DocumentObject) _
)

Parameters

objects
Type: System.Collections.Generic..::..List <(Of <(<' IGH_DocumentObject >)>)>

See Also

GH_Document Class
TogglePreviewFlags Overload
Grasshopper.Kernel Namespace


ToString Method

[image]

Grasshopper SDK
GH_Document..::..ToString Method
GH_Document Class See Also Send Feedback
A document serializes itself using the filename of the current path. This is useful for sorting purposes and ListBoxes.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_Document Class
Grasshopper.Kernel Namespace


TranslateObjects Method

[image]

Grasshopper SDK
GH_Document..::..TranslateObjects Method
GH_Document Class See Also Send Feedback
Offset objects by a certain distance in X and Y

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void TranslateObjects(
    Size trXForm,
    bool bLimitToSelection
)
Visual Basic
Public Sub TranslateObjects ( _
    trXForm As Size, _
    bLimitToSelection As Boolean _
)

Parameters

trXForm
Type: System.Drawing..::..Size
Translation vector
bLimitToSelection
Type: System..::..Boolean
If True, only selected objects are affected

See Also

GH_Document Class
Grasshopper.Kernel Namespace


Undo Method

[image]

Grasshopper SDK
GH_Document..::..Undo Method
GH_Document Class See Also Send Feedback
Perform the first undo event.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Undo()
Visual Basic
Public Function Undo As Boolean

Return Value

True on success, false on no undo event or invalid undo event.

See Also

GH_Document Class
Grasshopper.Kernel Namespace


UnselectedObjects Method

[image]

Grasshopper SDK
GH_Document..::..UnselectedObjects Method
GH_Document Class See Also Send Feedback
Returns all unselected objects in the document

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<IGH_DocumentObject> UnselectedObjects()
Visual Basic
Public Function UnselectedObjects As List(Of IGH_DocumentObject)

Return Value

See Also

GH_Document Class
Grasshopper.Kernel Namespace


UpdateAllSubsidiaries Method

[image]

Grasshopper SDK
GH_Document..::..UpdateAllSubsidiaries Method
GH_Document Class See Also Send Feedback
Iterate over all subsidiary documents and update them with their respective owners. If a subsidiary hasn't been modified, it will not be updated and it will not be counted.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int UpdateAllSubsidiaries()
Visual Basic
Public Function UpdateAllSubsidiaries As Integer

Return Value

The number of subsidiary documents updated.

See Also

GH_Document Class
Grasshopper.Kernel Namespace


Write Method

[image] [image]

Grasshopper SDK
GH_Document..::..Write Method
GH_Document Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Write(GH_IWriter) | Standard archiving function. Will serialize the entire document.
Public method | Write(GH_IWriter, IList<(Of <<'(IGH_DocumentObject>)>>)) | Special function that allows writing of a custom object list. This function is used when partial documents need to be serialized such as when exporting or during clipboard operations.

See Also

GH_Document Class
GH_Document Members
Grasshopper.Kernel Namespace


Write Method (GH_IWriter)

[image]

Grasshopper SDK
GH_Document..::..Write Method (GH_IWriter)
GH_Document Class See Also Send Feedback
Standard archiving function. Will serialize the entire document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Write(
    GH_IWriter writer
)
Visual Basic
Public Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

Implements

GH_ISerializable..::..Write(GH_IWriter)

See Also

GH_Document Class
Write Overload
Grasshopper.Kernel Namespace


Write Method (GH_IWriter, IList(IGH_DocumentObject))

[image]

Grasshopper SDK
GH_Document..::..Write Method (GH_IWriter, IList<(Of <(<'IGH_DocumentObject>)>)>)
GH_Document Class See Also Send Feedback
Special function that allows writing of a custom object list. This function is used when partial documents need to be serialized such as when exporting or during clipboard operations.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Write(
    GH_IWriter writer,
    IList<IGH_DocumentObject> objList
)
Visual Basic
Public Function Write ( _
    writer As GH_IWriter, _
    objList As IList(Of IGH_DocumentObject) _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter
Writer to serialize with.
objList
Type: System.Collections.Generic..::..IList <(Of <(<' IGH_DocumentObject >)>)>
Object list override

See Also

GH_Document Class
Write Overload
Grasshopper.Kernel Namespace


GH_Document Properties

[image] [image]

Grasshopper SDK
GH_Document Properties
GH_Document Class See Also Send Feedback

The GH_Document type exposes the following members.

Properties

 | Name | Description
Public property | AbortRequested | Gets the abortrequested flag state.
Public property | AttributeCount | Returns the total number of attributes in the document. Both Normal and Hidden ones
Public property | Attributes | Returns a list of all the attributes in this document. This includes attributes for nested objects such as input or output parameters.
Public property | Author | Gets the author details associated with this document.
Public property | ConstantServer | Gets the dictionary of constants defined in this document.
Public property | Context | Gets or sets the context for this document. Note that the context is not a state so much as an action. Therefore it is not particularly useful to read the context after the fact, rather, context is mostly intended to be a setter, not a getter. When you set the context, all top-level document objects will be informed and the ContextChanged event will be raised.
 | DefaultPreviewColour | Gets or sets the default preview colour for normal objects.
 | DefaultSelectedPreviewColour | Gets or sets the default preview colour for normal objects.
Public property | DisplayName | Gets the display name for this document. The display name is highly context sensitive and is only supposed to give the user a good idea of which document this is and whether it has been modified.
Public property | DocumentID | Gets the document Id. The Id is assigned at construction and never changed. Note: clusters may choose to modify the Id of their internal documents.
Public property | Enabled | Gets or sets the enabled state for this document. Enabled documents respond to events and display their previews in the Rhino viewport.
 | EnableSolutions | Gets or sets a global variable that indicates whether solutions are allowed to be recomputed. When this flag is off, the solver will be disabled and the event watchers should be silent.
Public property | EventServer | Gets the event server that belongs to this document. The Event server may be in an inactive state, but it is never null.
Public property | FilePath | Gets or sets the file path of this document. If the file path is not set Nothing is returned.
Public property | IgnoredCount | Returns the total numbers of components currently in the Object Exception Ignore List.
Public property | IsFilePathDefined | Returns True if the filename flag of this document has been set
Public property | IsModified | Gets or sets the modified flag. If the new value differs from the old value, the ModifiedChanged() event is raised.
Public property | ModifiedSubsidiaries | Gets the number of modified subsidiary documents.
Public property | Nested | Gets or sets whether this document is nested. A nested document is always part of some other document and is therefore unknown to the DocumentServer and the Canvas.
Public property | ObjectCount | Returns the total number of top-level objects in the document.
Public property | Objects | Returns a list of all normal, top-level objects.
Public property | ObjectSpan | Gets the total timespan for all objects.
Public property | Owner | Gets or sets the owner of this document. A document is typically owned when it is subsidiary to some object, such as a cluster.
Public property | PreviewColour | Gets or sets the colour of unselected preview geometry.
Public property | PreviewColourSelected | Gets or sets the colour of selected preview geometry.
Public property | PreviewCustomMeshParameters | Gets or sets the Custom Meshing Parameters for this document, these are only used when PreviewMeshType = GH_PreviewMesh.Custom
Public property | PreviewFilter | Gets or set the preview filter.
Public property | PreviewMeshType | Gets or sets the preview mesh type for this document.
Public property | PreviewMode | Gets or sets the preview display mode and makes sure the conduit instance of this class is set to match.
Public property | Profiler | Gets or sets the profiler mode used in this document.
Public property | Properties | The properties of this document
Public property | RaiseEvents | If RaiseEvents is set to false, all the On....() methods of this document will stop raising events.
Public property | RemotePanelProxy | Gets or sets the Remote Control Panel proxy description for this document.
Public property | RuntimeID | Gets the runtime ID of this document. RuntimeID is assigned once and never changed. It is also not deserialized so every document will always have a unique ID when loaded.
Public property | ScheduleDelay | Gets the delay for the next scheduled solution. If there is no solution scheduled the delay will be negative.
Public property | SelectedCount | Gets the number of selected objects
Public property | SelectionTopology | Gets the selection topology of the document.
Public property | SolutionDepth | Gets the number of nested solutions currently running. If no solutions are running, the depth should be zero. If one solution is runnnig, the depth should be one. Higher depths are only possible if a new solution was scheduled from within an existing solution with delay=0ms.
Public property | SolutionHistory | Gets a list of the last 1000 solution timespans, from oldest to youngest.
Public property | SolutionSpan | Gets the timespan for the most recent solution.
Public property | SolutionState | Gets the state of this document.
Public property | StateServer | Gets the list of stored states in this document
Public property | Thumbnail | Gets or sets the thumbnail bitmap for this document.
Public property | UndoServer | Gets the UndoServer instance that belongs to this document.
Public property | UndoUtil | Gets a temporary undo utility instance that allows you to easily create standard undo events.

See Also

GH_Document Class
Grasshopper.Kernel Namespace


AbortRequested Property

[image]

Grasshopper SDK
GH_Document..::..AbortRequested Property
GH_Document Class See Also Send Feedback
Gets the abortrequested flag state.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool AbortRequested { get; }
Visual Basic
Public ReadOnly Property AbortRequested As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.AbortRequested"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


AttributeCount Property

[image]

Grasshopper SDK
GH_Document..::..AttributeCount Property
GH_Document Class See Also Send Feedback
Returns the total number of attributes in the document. Both Normal and Hidden ones

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int AttributeCount { get; }
Visual Basic
Public ReadOnly Property AttributeCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.AttributeCount"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


Attributes Property

[image]

Grasshopper SDK
GH_Document..::..Attributes Property
GH_Document Class See Also Send Feedback
Returns a list of all the attributes in this document. This includes attributes for nested objects such as input or output parameters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IList<IGH_Attributes> Attributes { get; }
Visual Basic
Public ReadOnly Property Attributes As IList(Of IGH_Attributes)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.Attributes"]

Remarks

If the attribute cache is empty, it will be rebuild. Hence, this could be quite an expensive call to make.

See Also

GH_Document Class
Grasshopper.Kernel Namespace


Author Property

[image]

Grasshopper SDK
GH_Document..::..Author Property
GH_Document Class See Also Send Feedback
Gets the author details associated with this document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_Author Author { get; }
Visual Basic
Public ReadOnly Property Author As IGH_Author
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.Author"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


ConstantServer Property

[image]

Grasshopper SDK
GH_Document..::..ConstantServer Property
GH_Document Class See Also Send Feedback
Gets the dictionary of constants defined in this document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public SortedDictionary<string, GH_Variant> ConstantServer { get; }
Visual Basic
Public ReadOnly Property ConstantServer As SortedDictionary(Of String, GH_Variant)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.ConstantServer"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


Context Property

[image]

Grasshopper SDK
GH_Document..::..Context Property
GH_Document Class See Also Send Feedback
Gets or sets the context for this document. Note that the context is not a state so much as an action. Therefore it is not particularly useful to read the context after the fact, rather, context is mostly intended to be a setter, not a getter. When you set the context, all top-level document objects will be informed and the ContextChanged event will be raised.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_DocumentContext Context { get; set; }
Visual Basic
Public Property Context As GH_DocumentContext
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.Context"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


DefaultPreviewColour Property

[image]

Grasshopper SDK
GH_Document..::..DefaultPreviewColour Property
GH_Document Class See Also Send Feedback
Gets or sets the default preview colour for normal objects.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Color DefaultPreviewColour { get; set; }
Visual Basic
Public Shared Property DefaultPreviewColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.DefaultPreviewColour"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


DefaultSelectedPreviewColour Property

[image]

Grasshopper SDK
GH_Document..::..DefaultSelectedPreviewColour Property
GH_Document Class See Also Send Feedback
Gets or sets the default preview colour for normal objects.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Color DefaultSelectedPreviewColour { get; set; }
Visual Basic
Public Shared Property DefaultSelectedPreviewColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.DefaultSelectedPreviewColour"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


DisplayName Property

[image]

Grasshopper SDK
GH_Document..::..DisplayName Property
GH_Document Class See Also Send Feedback
Gets the display name for this document. The display name is highly context sensitive and is only supposed to give the user a good idea of which document this is and whether it has been modified.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string DisplayName { get; }
Visual Basic
Public ReadOnly Property DisplayName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.DisplayName"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


DocumentID Property

[image]

Grasshopper SDK
GH_Document..::..DocumentID Property
GH_Document Class See Also Send Feedback
Gets the document Id. The Id is assigned at construction and never changed. Note: clusters may choose to modify the Id of their internal documents.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid DocumentID { get; }
Visual Basic
Public ReadOnly Property DocumentID As Guid
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.DocumentID"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


Enabled Property

[image]

Grasshopper SDK
GH_Document..::..Enabled Property
GH_Document Class See Also Send Feedback
Gets or sets the enabled state for this document. Enabled documents respond to events and display their previews in the Rhino viewport.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Enabled { get; set; }
Visual Basic
Public Property Enabled As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.Enabled"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


EnableSolutions Property

[image]

Grasshopper SDK
GH_Document..::..EnableSolutions Property
GH_Document Class See Also Send Feedback
Gets or sets a global variable that indicates whether solutions are allowed to be recomputed. When this flag is off, the solver will be disabled and the event watchers should be silent.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool EnableSolutions { get; set; }
Visual Basic
Public Shared Property EnableSolutions As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.EnableSolutions"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


EventServer Property

[image]

Grasshopper SDK
GH_Document..::..EventServer Property
GH_Document Class See Also Send Feedback
Gets the event server that belongs to this document. The Event server may be in an inactive state, but it is never null.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_DocumentEventServer EventServer { get; }
Visual Basic
Public ReadOnly Property EventServer As GH_DocumentEventServer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.EventServer"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


FilePath Property

[image]

Grasshopper SDK
GH_Document..::..FilePath Property
GH_Document Class See Also Send Feedback
Gets or sets the file path of this document. If the file path is not set Nothing is returned.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string FilePath { get; set; }
Visual Basic
Public Property FilePath As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.FilePath"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


IgnoredCount Property

[image]

Grasshopper SDK
GH_Document..::..IgnoredCount Property
GH_Document Class See Also Send Feedback
Returns the total numbers of components currently in the Object Exception Ignore List.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int IgnoredCount { get; }
Visual Basic
Public ReadOnly Property IgnoredCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.IgnoredCount"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


IsFilePathDefined Property

[image]

Grasshopper SDK
GH_Document..::..IsFilePathDefined Property
GH_Document Class See Also Send Feedback
Returns True if the filename flag of this document has been set

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsFilePathDefined { get; }
Visual Basic
Public ReadOnly Property IsFilePathDefined As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.IsFilePathDefined"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


IsModified Property

[image]

Grasshopper SDK
GH_Document..::..IsModified Property
GH_Document Class See Also Send Feedback
Gets or sets the modified flag. If the new value differs from the old value, the ModifiedChanged() event is raised.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsModified { get; set; }
Visual Basic
Public Property IsModified As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.IsModified"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


ModifiedSubsidiaries Property

[image]

Grasshopper SDK
GH_Document..::..ModifiedSubsidiaries Property
GH_Document Class See Also Send Feedback
Gets the number of modified subsidiary documents.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int ModifiedSubsidiaries { get; }
Visual Basic
Public ReadOnly Property ModifiedSubsidiaries As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.ModifiedSubsidiaries"]

Return Value

The number of modified subsidiary documents.

See Also

GH_Document Class
Grasshopper.Kernel Namespace


Nested Property

[image]

Grasshopper SDK
GH_Document..::..Nested Property
GH_Document Class See Also Send Feedback
Gets or sets whether this document is nested. A nested document is always part of some other document and is therefore unknown to the DocumentServer and the Canvas.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Nested { get; set; }
Visual Basic
Public Property Nested As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.Nested"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


ObjectCount Property

[image]

Grasshopper SDK
GH_Document..::..ObjectCount Property
GH_Document Class See Also Send Feedback
Returns the total number of top-level objects in the document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int ObjectCount { get; }
Visual Basic
Public ReadOnly Property ObjectCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.ObjectCount"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


Objects Property

[image]

Grasshopper SDK
GH_Document..::..Objects Property
GH_Document Class See Also Send Feedback
Returns a list of all normal, top-level objects.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IList<IGH_DocumentObject> Objects { get; }
Visual Basic
Public ReadOnly Property Objects As IList(Of IGH_DocumentObject)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.Objects"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


ObjectSpan Property

[image]

Grasshopper SDK
GH_Document..::..ObjectSpan Property
GH_Document Class See Also Send Feedback
Gets the total timespan for all objects.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public TimeSpan ObjectSpan { get; }
Visual Basic
Public ReadOnly Property ObjectSpan As TimeSpan
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.ObjectSpan"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


Owner Property

[image]

Grasshopper SDK
GH_Document..::..Owner Property
GH_Document Class See Also Send Feedback
Gets or sets the owner of this document. A document is typically owned when it is subsidiary to some object, such as a cluster.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_DocumentOwner Owner { get; set; }
Visual Basic
Public Property Owner As IGH_DocumentOwner
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.Owner"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


PreviewColour Property

[image]

Grasshopper SDK
GH_Document..::..PreviewColour Property
GH_Document Class See Also Send Feedback
Gets or sets the colour of unselected preview geometry.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color PreviewColour { get; set; }
Visual Basic
Public Property PreviewColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.PreviewColour"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


PreviewColourSelected Property

[image]

Grasshopper SDK
GH_Document..::..PreviewColourSelected Property
GH_Document Class See Also Send Feedback
Gets or sets the colour of selected preview geometry.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color PreviewColourSelected { get; set; }
Visual Basic
Public Property PreviewColourSelected As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.PreviewColourSelected"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


PreviewCustomMeshParameters Property

[image]

Grasshopper SDK
GH_Document..::..PreviewCustomMeshParameters Property
GH_Document Class See Also Send Feedback
Gets or sets the Custom Meshing Parameters for this document, these are only used when PreviewMeshType = GH_PreviewMesh.Custom

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public MeshingParameters PreviewCustomMeshParameters { get; set; }
Visual Basic
Public Property PreviewCustomMeshParameters As MeshingParameters
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.PreviewCustomMeshParameters"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


PreviewFilter Property

[image]

Grasshopper SDK
GH_Document..::..PreviewFilter Property
GH_Document Class See Also Send Feedback
Gets or set the preview filter.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PreviewFilter PreviewFilter { get; set; }
Visual Basic
Public Property PreviewFilter As GH_PreviewFilter
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.PreviewFilter"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


PreviewMeshType Property

[image]

Grasshopper SDK
GH_Document..::..PreviewMeshType Property
GH_Document Class See Also Send Feedback
Gets or sets the preview mesh type for this document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PreviewMesh PreviewMeshType { get; set; }
Visual Basic
Public Property PreviewMeshType As GH_PreviewMesh
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.PreviewMeshType"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


PreviewMode Property

[image]

Grasshopper SDK
GH_Document..::..PreviewMode Property
GH_Document Class See Also Send Feedback
Gets or sets the preview display mode and makes sure the conduit instance of this class is set to match.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PreviewMode PreviewMode { get; set; }
Visual Basic
Public Property PreviewMode As GH_PreviewMode
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.PreviewMode"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


Profiler Property

[image]

Grasshopper SDK
GH_Document..::..Profiler Property
GH_Document Class See Also Send Feedback
Gets or sets the profiler mode used in this document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ProfilerMode Profiler { get; set; }
Visual Basic
Public Property Profiler As GH_ProfilerMode
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.Profiler"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


Properties Property

[image]

Grasshopper SDK
GH_Document..::..Properties Property
GH_Document Class See Also Send Feedback
The properties of this document

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_DocumentProperties Properties { get; }
Visual Basic
Public ReadOnly Property Properties As GH_DocumentProperties
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.Properties"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


RaiseEvents Property

[image]

Grasshopper SDK
GH_Document..::..RaiseEvents Property
GH_Document Class See Also Send Feedback
If RaiseEvents is set to false, all the On....() methods of this document will stop raising events.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool RaiseEvents { get; set; }
Visual Basic
Public Property RaiseEvents As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.RaiseEvents"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


RemotePanelProxy Property

[image]

Grasshopper SDK
GH_Document..::..RemotePanelProxy Property
GH_Document Class See Also Send Feedback
Gets or sets the Remote Control Panel proxy description for this document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_RcpProxy RemotePanelProxy { get; set; }
Visual Basic
Public Property RemotePanelProxy As GH_RcpProxy
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.RemotePanelProxy"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


RuntimeID Property

[image]

Grasshopper SDK
GH_Document..::..RuntimeID Property
GH_Document Class See Also Send Feedback
Gets the runtime ID of this document. RuntimeID is assigned once and never changed. It is also not deserialized so every document will always have a unique ID when loaded.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public ulong RuntimeID { get; }
Visual Basic
Public ReadOnly Property RuntimeID As ULong
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.RuntimeID"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


ScheduleDelay Property

[image]

Grasshopper SDK
GH_Document..::..ScheduleDelay Property
GH_Document Class See Also Send Feedback
Gets the delay for the next scheduled solution. If there is no solution scheduled the delay will be negative.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int ScheduleDelay { get; }
Visual Basic
Public ReadOnly Property ScheduleDelay As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.ScheduleDelay"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


SelectedCount Property

[image]

Grasshopper SDK
GH_Document..::..SelectedCount Property
GH_Document Class See Also Send Feedback
Gets the number of selected objects

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int SelectedCount { get; }
Visual Basic
Public ReadOnly Property SelectedCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.SelectedCount"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


SelectionTopology Property

[image]

Grasshopper SDK
GH_Document..::..SelectionTopology Property
GH_Document Class See Also Send Feedback
Gets the selection topology of the document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_SelectionTopology SelectionTopology { get; }
Visual Basic
Public ReadOnly Property SelectionTopology As GH_SelectionTopology
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.SelectionTopology"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


SolutionDepth Property

[image]

Grasshopper SDK
GH_Document..::..SolutionDepth Property
GH_Document Class See Also Send Feedback
Gets the number of nested solutions currently running. If no solutions are running, the depth should be zero. If one solution is runnnig, the depth should be one. Higher depths are only possible if a new solution was scheduled from within an existing solution with delay=0ms.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int SolutionDepth { get; }
Visual Basic
Public ReadOnly Property SolutionDepth As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.SolutionDepth"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


SolutionHistory Property

[image]

Grasshopper SDK
GH_Document..::..SolutionHistory Property
GH_Document Class See Also Send Feedback
Gets a list of the last 1000 solution timespans, from oldest to youngest.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<GH_SolutionSpan> SolutionHistory { get; }
Visual Basic
Public ReadOnly Property SolutionHistory As List(Of GH_SolutionSpan)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.SolutionHistory"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


SolutionSpan Property

[image]

Grasshopper SDK
GH_Document..::..SolutionSpan Property
GH_Document Class See Also Send Feedback
Gets the timespan for the most recent solution.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public TimeSpan SolutionSpan { get; }
Visual Basic
Public ReadOnly Property SolutionSpan As TimeSpan
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.SolutionSpan"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


SolutionState Property

[image]

Grasshopper SDK
GH_Document..::..SolutionState Property
GH_Document Class See Also Send Feedback
Gets the state of this document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ProcessStep SolutionState { get; }
Visual Basic
Public ReadOnly Property SolutionState As GH_ProcessStep
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.SolutionState"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


StateServer Property

[image]

Grasshopper SDK
GH_Document..::..StateServer Property
GH_Document Class See Also Send Feedback
Gets the list of stored states in this document

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_StateServer StateServer { get; }
Visual Basic
Public ReadOnly Property StateServer As GH_StateServer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.StateServer"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


Thumbnail Property

[image]

Grasshopper SDK
GH_Document..::..Thumbnail Property
GH_Document Class See Also Send Feedback
Gets or sets the thumbnail bitmap for this document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Bitmap Thumbnail { get; set; }
Visual Basic
Public Property Thumbnail As Bitmap
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.Thumbnail"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


UndoServer Property

[image]

Grasshopper SDK
GH_Document..::..UndoServer Property
GH_Document Class See Also Send Feedback
Gets the UndoServer instance that belongs to this document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_UndoServer UndoServer { get; }
Visual Basic
Public ReadOnly Property UndoServer As GH_UndoServer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.UndoServer"]

See Also

GH_Document Class
Grasshopper.Kernel Namespace


UndoUtil Property

[image]

Grasshopper SDK
GH_Document..::..UndoUtil Property
GH_Document Class See Also Send Feedback
Gets a temporary undo utility instance that allows you to easily create standard undo events.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Document..::..GH_UndoUtil UndoUtil { get; }
Visual Basic
Public ReadOnly Property UndoUtil As GH_Document..::..GH_UndoUtil
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Document.UndoUtil"]

Return Value

A new instance of GH_UndoUtil set up to work with this document. Do not hang on to this object, ask for a new one every time you need it.

See Also

GH_Document Class
Grasshopper.Kernel Namespace


GH_Document Events

[image] [image]

Grasshopper SDK
GH_Document Events
GH_Document Class See Also Send Feedback

The GH_Document type exposes the following members.

Events

 | Name | Description
Public event | ContextChanged | The context for this document was changed.
 | DefaultPreviewColourChanged | This even is raised whenever the global default for Normal preview colour is changed.
 | DefaultSelectedPreviewColourChanged | This even is raised whenever the global default for Selected preview colour is changed.
Public event | EnabledChanged | The Enabled state was changed on this document.
 | EnableSolutionsChanged | Raised whenever the Shared EnabledSolutions property is changed.
Public event | FilePathChanged | Raised whenever the FilePath of the document is modified.
Public event | ModifiedChanged | The modified flag on the document was changed.
Public event | ObjectsAdded | Raised after a collection of objects was added to the document.
Public event | ObjectsDeleted | Raised after a collection of objects was removed from the document. At this point, the objects still exist, but they no longer belong to this document.
Public event | SettingsChanged | Some settings of the document were changed.
Public event | SolutionEnd | This event is raised whenever a new solution request has been handled. Even if the document is locked.
Public event | SolutionStart | This event is raised whenever a new solution is requested. Even if the document is locked.
Public event | UndoStateChanged | Raised whenever there is a change to the document undo/redo stack.

See Also

GH_Document Class
Grasshopper.Kernel Namespace


ContextChanged Event

[image]

Grasshopper SDK
GH_Document..::..ContextChanged Event
GH_Document Class See Also Send Feedback
The context for this document was changed.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_Document..::..ContextChangedEventHandler ContextChanged
Visual Basic
Public Event ContextChanged As GH_Document..::..ContextChangedEventHandler

See Also

GH_Document Class
Grasshopper.Kernel Namespace


DefaultPreviewColourChanged Event

[image]

Grasshopper SDK
GH_Document..::..DefaultPreviewColourChanged Event
GH_Document Class See Also Send Feedback
This even is raised whenever the global default for Normal preview colour is changed.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event GH_Document..::..DefaultPreviewColourChangedEventHandler DefaultPreviewColourChanged
Visual Basic
Public Shared Event DefaultPreviewColourChanged As GH_Document..::..DefaultPreviewColourChangedEventHandler

See Also

GH_Document Class
Grasshopper.Kernel Namespace


DefaultSelectedPreviewColourChanged Event

[image]

Grasshopper SDK
GH_Document..::..DefaultSelectedPreviewColourChanged Event
GH_Document Class See Also Send Feedback
This even is raised whenever the global default for Selected preview colour is changed.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event GH_Document..::..DefaultSelectedPreviewColourChangedEventHandler DefaultSelectedPreviewColourChanged
Visual Basic
Public Shared Event DefaultSelectedPreviewColourChanged As GH_Document..::..DefaultSelectedPreviewColourChangedEventHandler

See Also

GH_Document Class
Grasshopper.Kernel Namespace


EnabledChanged Event

[image]

Grasshopper SDK
GH_Document..::..EnabledChanged Event
GH_Document Class See Also Send Feedback
The Enabled state was changed on this document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_Document..::..EnabledChangedEventHandler EnabledChanged
Visual Basic
Public Event EnabledChanged As GH_Document..::..EnabledChangedEventHandler

See Also

GH_Document Class
Grasshopper.Kernel Namespace


EnableSolutionsChanged Event

[image]

Grasshopper SDK
GH_Document..::..EnableSolutionsChanged Event
GH_Document Class See Also Send Feedback
Raised whenever the Shared EnabledSolutions property is changed.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event GH_Document..::..EnableSolutionsChangedEventHandler EnableSolutionsChanged
Visual Basic
Public Shared Event EnableSolutionsChanged As GH_Document..::..EnableSolutionsChangedEventHandler

See Also

GH_Document Class
Grasshopper.Kernel Namespace


FilePathChanged Event

[image]

Grasshopper SDK
GH_Document..::..FilePathChanged Event
GH_Document Class See Also Send Feedback
Raised whenever the FilePath of the document is modified.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_Document..::..FilePathChangedEventHandler FilePathChanged
Visual Basic
Public Event FilePathChanged As GH_Document..::..FilePathChangedEventHandler

See Also

GH_Document Class
Grasshopper.Kernel Namespace


ModifiedChanged Event

[image]

Grasshopper SDK
GH_Document..::..ModifiedChanged Event
GH_Document Class See Also Send Feedback
The modified flag on the document was changed.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_Document..::..ModifiedChangedEventHandler ModifiedChanged
Visual Basic
Public Event ModifiedChanged As GH_Document..::..ModifiedChangedEventHandler

See Also

GH_Document Class
Grasshopper.Kernel Namespace


ObjectsAdded Event

[image]

Grasshopper SDK
GH_Document..::..ObjectsAdded Event
GH_Document Class See Also Send Feedback
Raised after a collection of objects was added to the document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_Document..::..ObjectsAddedEventHandler ObjectsAdded
Visual Basic
Public Event ObjectsAdded As GH_Document..::..ObjectsAddedEventHandler

See Also

GH_Document Class
Grasshopper.Kernel Namespace


ObjectsDeleted Event

[image]

Grasshopper SDK
GH_Document..::..ObjectsDeleted Event
GH_Document Class See Also Send Feedback
Raised after a collection of objects was removed from the document. At this point, the objects still exist, but they no longer belong to this document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_Document..::..ObjectsDeletedEventHandler ObjectsDeleted
Visual Basic
Public Event ObjectsDeleted As GH_Document..::..ObjectsDeletedEventHandler

See Also

GH_Document Class
Grasshopper.Kernel Namespace


SettingsChanged Event

[image]

Grasshopper SDK
GH_Document..::..SettingsChanged Event
GH_Document Class See Also Send Feedback
Some settings of the document were changed.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_Document..::..SettingsChangedEventHandler SettingsChanged
Visual Basic
Public Event SettingsChanged As GH_Document..::..SettingsChangedEventHandler

See Also

GH_Document Class
Grasshopper.Kernel Namespace


SolutionEnd Event

[image]

Grasshopper SDK
GH_Document..::..SolutionEnd Event
GH_Document Class See Also Send Feedback
This event is raised whenever a new solution request has been handled. Even if the document is locked.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_Document..::..SolutionEndEventHandler SolutionEnd
Visual Basic
Public Event SolutionEnd As GH_Document..::..SolutionEndEventHandler

See Also

GH_Document Class
Grasshopper.Kernel Namespace


SolutionStart Event

[image]

Grasshopper SDK
GH_Document..::..SolutionStart Event
GH_Document Class See Also Send Feedback
This event is raised whenever a new solution is requested. Even if the document is locked.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_Document..::..SolutionStartEventHandler SolutionStart
Visual Basic
Public Event SolutionStart As GH_Document..::..SolutionStartEventHandler

See Also

GH_Document Class
Grasshopper.Kernel Namespace


UndoStateChanged Event

[image]

Grasshopper SDK
GH_Document..::..UndoStateChanged Event
GH_Document Class See Also Send Feedback
Raised whenever there is a change to the document undo/redo stack.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_Document..::..UndoStateChangedEventHandler UndoStateChanged
Visual Basic
Public Event UndoStateChanged As GH_Document..::..UndoStateChangedEventHandler

See Also

GH_Document Class
Grasshopper.Kernel Namespace


GH_Document.ContextChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_Document..::..ContextChangedEventHandler Delegate
GH_Document Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void ContextChangedEventHandler(
    Object sender,
    GH_DocContextEventArgs e
)
Visual Basic
Public Delegate Sub ContextChangedEventHandler ( _
    sender As Object, _
    e As GH_DocContextEventArgs _
)

Parameters

sender
Type: System..::..Object
e
Type: Grasshopper.Kernel..::..GH_DocContextEventArgs

See Also

Grasshopper.Kernel Namespace


GH_Document.DefaultPreviewColourChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_Document..::..DefaultPreviewColourChangedEventHandler Delegate
GH_Document Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void DefaultPreviewColourChangedEventHandler(
    Color colour
)
Visual Basic
Public Delegate Sub DefaultPreviewColourChangedEventHandler ( _
    colour As Color _
)

Parameters

colour
Type: System.Drawing..::..Color

See Also

Grasshopper.Kernel Namespace


GH_Document.DefaultSelectedPreviewColourChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_Document..::..DefaultSelectedPreviewColourChangedEventHandler Delegate
GH_Document Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void DefaultSelectedPreviewColourChangedEventHandler(
    Color colour
)
Visual Basic
Public Delegate Sub DefaultSelectedPreviewColourChangedEventHandler ( _
    colour As Color _
)

Parameters

colour
Type: System.Drawing..::..Color

See Also

Grasshopper.Kernel Namespace


GH_Document.EnabledChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_Document..::..EnabledChangedEventHandler Delegate
GH_Document Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void EnabledChangedEventHandler(
    Object sender,
    GH_DocEnabledEventArgs e
)
Visual Basic
Public Delegate Sub EnabledChangedEventHandler ( _
    sender As Object, _
    e As GH_DocEnabledEventArgs _
)

Parameters

sender
Type: System..::..Object
e
Type: Grasshopper.Kernel..::..GH_DocEnabledEventArgs

See Also

Grasshopper.Kernel Namespace


GH_Document.EnableSolutionsChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_Document..::..EnableSolutionsChangedEventHandler Delegate
GH_Document Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void EnableSolutionsChangedEventHandler(
    bool state
)
Visual Basic
Public Delegate Sub EnableSolutionsChangedEventHandler ( _
    state As Boolean _
)

Parameters

state
Type: System..::..Boolean

See Also

Grasshopper.Kernel Namespace


GH_Document.FilePathChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_Document..::..FilePathChangedEventHandler Delegate
GH_Document Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void FilePathChangedEventHandler(
    Object sender,
    GH_DocFilePathEventArgs e
)
Visual Basic
Public Delegate Sub FilePathChangedEventHandler ( _
    sender As Object, _
    e As GH_DocFilePathEventArgs _
)

Parameters

sender
Type: System..::..Object
e
Type: Grasshopper.Kernel..::..GH_DocFilePathEventArgs

See Also

Grasshopper.Kernel Namespace


GH_Document.GH_ActiveObjectFilter Delegate

[image]

Grasshopper SDK
GH_Document..::..GH_ActiveObjectFilter Delegate
GH_Document Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate bool GH_ActiveObjectFilter(
    IGH_ActiveObject iObj
)
Visual Basic
Public Delegate Function GH_ActiveObjectFilter ( _
    iObj As IGH_ActiveObject _
) As Boolean

Parameters

iObj
Type: Grasshopper.Kernel..::..IGH_ActiveObject

See Also

Grasshopper.Kernel Namespace


GH_Document.GH_ScheduleDelegate Delegate

[image]

Grasshopper SDK
GH_Document..::..GH_ScheduleDelegate Delegate
GH_Document Class See Also Send Feedback
Callback signature for Scheduled Solutions.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void GH_ScheduleDelegate(
    GH_Document doc
)
Visual Basic
Public Delegate Sub GH_ScheduleDelegate ( _
    doc As GH_Document _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document
Document that was scheduled.

See Also

Grasshopper.Kernel Namespace


GH_Document.GH_UndoUtil Class

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil Class
GH_Document Class Members See Also Send Feedback
This class is emitted by the Undo property of a GH_Document instance.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class GH_UndoUtil
Visual Basic
Public NotInheritable Class GH_UndoUtil

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_Document..::..GH_UndoUtil

See Also

GH_Document..::..GH_UndoUtil Members
Grasshopper.Kernel Namespace


GH_Document.GH_UndoUtil Members

[image] [image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil Members
GH_Document..::..GH_UndoUtil Class Methods See Also Send Feedback

Represents a single Grasshopper document.

The GH_Document..::..GH_UndoUtil type exposes the following members.

Methods

 | Name | Description
Public method | CreateAddObjectEvent(String, IGH_DocumentObject) | Create a new undo record for a single object addition.
Public method | CreateAddObjectEvent(String, IEnumerable<(Of <<'(IGH_DocumentObject>)>>)) | Create a new undo record for a bunch of object additions.
Public method | CreateAddStateEvent | Create a new undo record for a single solution state addition.
Public method | CreateEnabledEvent | Create a new undo record for an object enabled change. This function must be called before the enabled flag is changed.
Public method | CreateGenericObjectEvent | Create a new undo record for a generic, single object change.
Public method | CreateLayoutEvent(String, IGH_DocumentObject) | Create a new undo record for a single object layout change. This function must be called before the layout is changed.
Public method | CreateLayoutEvent(String, IEnumerable<(Of <<'(IGH_DocumentObject>)>>)) | Create a new undo record for a bunch of object layout changes. This function must be called before the layouts are changed.
Public method | CreateNickNameEvent | Create a new undo record for an object nickname change. This function must be called before the nickname is changed.
Public method | CreatePersistentDataEvent<(Of <<'(T>)>>) | Create a new undo record for a single object persistent data change.
Public method | CreatePivotEvent(String, IGH_DocumentObject) | Create a new undo record for a single pivot change. This function must be called before the pivot is changed.
Public method | CreatePivotEvent(String, IEnumerable<(Of <<'(IGH_DocumentObject>)>>)) | Create a new undo record for a bunch of pivot changes. This function must be called before the pivots are changed.
Public method | CreatePreviewEvent | Create a new undo record for an object preview change. This function must be called before the preview is changed.
Public method | CreateRemoveObjectEvent(String, IGH_DocumentObject) | Create a new undo record for a single object removal.
Public method | CreateRemoveObjectEvent(String, IEnumerable<(Of <<'(IGH_DocumentObject>)>>)) | Create a new undo record for a bunch of object removals.
Public method | CreateRemoveStateEvent | Create a new undo record for a single solution state removal.
Public method | CreateReplaceStateEvent | Create a new undo record for a single solution state addition.
Public method | CreateWireEvent(String, IGH_Param) | Create a new undo record for a set of Connector wire changes. This function must be called before the wires are changed.
Public method | CreateWireEvent(String, IEnumerable<(Of <<'(IGH_Param>)>>)) | Create a new undo record for a set of Connector wire changes. This function must be called before the wires are changed.
Public method | RecordAddObjectEvent(String, IGH_DocumentObject) | Create and Record a new ObjectAdded undo record.
Public method | RecordAddObjectEvent(String, IEnumerable<(Of <<'(IGH_DocumentObject>)>>)) | Create and Record a new ObjectAdded undo record.
Public method | RecordAddStateEvent | Create and Record a new CreateAddStateEvent undo record.
Public method | RecordEnabledEvent | Create and Record a new EnabledChanged undo record.
Public method | RecordEvent(GH_UndoRecord) | Add a new record to the undo stack of the owner document.
Public method | RecordEvent(String, IGH_UndoAction) | Add a new record to the undo stack of the owner document.
Public method | RecordEvent(String, array<IGH_UndoAction>[]()[][]) | Add a new record to the undo stack of the owner document.
Public method | RecordEvent(String, IEnumerable<(Of <<'(IGH_UndoAction>)>>)) | Add a new record to the undo stack of the owner document.
Public method | RecordGenericObjectEvent | Create and Record a new ObjectChanged undo record.
Public method | RecordLayoutEvent(String, IGH_DocumentObject) | Create and Record a new LayoutChanged undo record.
Public method | RecordLayoutEvent(String, IEnumerable<(Of <<'(IGH_DocumentObject>)>>)) | Create and Record a new LayoutChanged undo record.
Public method | RecordNickNameEvent | Create and Record a new NickNameChanged undo record.
Public method | RecordPersistentDataEvent<(Of <<'(T>)>>) | Create and Record a new PersistentDataChanged undo record.
Public method | RecordPivotEvent(String, IGH_DocumentObject) | Create and Record a new PivotChanged undo record.
Public method | RecordPivotEvent(String, IEnumerable<(Of <<'(IGH_DocumentObject>)>>)) | Create and Record a new PivotChanged undo record.
Public method | RecordPreviewEvent | Create and Record a new PreviewChanged undo record.
Public method | RecordRemoveObjectEvent(String, IGH_DocumentObject) | Create and Record a new ObjectRemoved undo record.
Public method | RecordRemoveObjectEvent(String, IEnumerable<(Of <<'(IGH_DocumentObject>)>>)) | Create and Record a new ObjectRemoved undo record.
Public method | RecordRemoveStateEvent | Create and Record a new CreateRemoveStateEvent undo record.
Public method | RecordReplaceStateEvent | Create and Record a new CreateReplaceStateEvent undo record.
Public method | RecordWireEvent(String, IGH_Param) | Create and Record a new WiresChanged undo record.
Public method | RecordWireEvent(String, IEnumerable<(Of <<'(IGH_Param>)>>)) | Create and Record a new WiresChanged undo record.

See Also

GH_Document..::..GH_UndoUtil Class
Grasshopper.Kernel Namespace


GH_Document.GH_UndoUtil Methods

[image] [image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil Methods
GH_Document..::..GH_UndoUtil Class See Also Send Feedback

The GH_Document..::..GH_UndoUtil type exposes the following members.

Methods

 | Name | Description
Public method | CreateAddObjectEvent(String, IGH_DocumentObject) | Create a new undo record for a single object addition.
Public method | CreateAddObjectEvent(String, IEnumerable<(Of <<'(IGH_DocumentObject>)>>)) | Create a new undo record for a bunch of object additions.
Public method | CreateAddStateEvent | Create a new undo record for a single solution state addition.
Public method | CreateEnabledEvent | Create a new undo record for an object enabled change. This function must be called before the enabled flag is changed.
Public method | CreateGenericObjectEvent | Create a new undo record for a generic, single object change.
Public method | CreateLayoutEvent(String, IGH_DocumentObject) | Create a new undo record for a single object layout change. This function must be called before the layout is changed.
Public method | CreateLayoutEvent(String, IEnumerable<(Of <<'(IGH_DocumentObject>)>>)) | Create a new undo record for a bunch of object layout changes. This function must be called before the layouts are changed.
Public method | CreateNickNameEvent | Create a new undo record for an object nickname change. This function must be called before the nickname is changed.
Public method | CreatePersistentDataEvent<(Of <<'(T>)>>) | Create a new undo record for a single object persistent data change.
Public method | CreatePivotEvent(String, IGH_DocumentObject) | Create a new undo record for a single pivot change. This function must be called before the pivot is changed.
Public method | CreatePivotEvent(String, IEnumerable<(Of <<'(IGH_DocumentObject>)>>)) | Create a new undo record for a bunch of pivot changes. This function must be called before the pivots are changed.
Public method | CreatePreviewEvent | Create a new undo record for an object preview change. This function must be called before the preview is changed.
Public method | CreateRemoveObjectEvent(String, IGH_DocumentObject) | Create a new undo record for a single object removal.
Public method | CreateRemoveObjectEvent(String, IEnumerable<(Of <<'(IGH_DocumentObject>)>>)) | Create a new undo record for a bunch of object removals.
Public method | CreateRemoveStateEvent | Create a new undo record for a single solution state removal.
Public method | CreateReplaceStateEvent | Create a new undo record for a single solution state addition.
Public method | CreateWireEvent(String, IGH_Param) | Create a new undo record for a set of Connector wire changes. This function must be called before the wires are changed.
Public method | CreateWireEvent(String, IEnumerable<(Of <<'(IGH_Param>)>>)) | Create a new undo record for a set of Connector wire changes. This function must be called before the wires are changed.
Public method | RecordAddObjectEvent(String, IGH_DocumentObject) | Create and Record a new ObjectAdded undo record.
Public method | RecordAddObjectEvent(String, IEnumerable<(Of <<'(IGH_DocumentObject>)>>)) | Create and Record a new ObjectAdded undo record.
Public method | RecordAddStateEvent | Create and Record a new CreateAddStateEvent undo record.
Public method | RecordEnabledEvent | Create and Record a new EnabledChanged undo record.
Public method | RecordEvent(GH_UndoRecord) | Add a new record to the undo stack of the owner document.
Public method | RecordEvent(String, IGH_UndoAction) | Add a new record to the undo stack of the owner document.
Public method | RecordEvent(String, array<IGH_UndoAction>[]()[][]) | Add a new record to the undo stack of the owner document.
Public method | RecordEvent(String, IEnumerable<(Of <<'(IGH_UndoAction>)>>)) | Add a new record to the undo stack of the owner document.
Public method | RecordGenericObjectEvent | Create and Record a new ObjectChanged undo record.
Public method | RecordLayoutEvent(String, IGH_DocumentObject) | Create and Record a new LayoutChanged undo record.
Public method | RecordLayoutEvent(String, IEnumerable<(Of <<'(IGH_DocumentObject>)>>)) | Create and Record a new LayoutChanged undo record.
Public method | RecordNickNameEvent | Create and Record a new NickNameChanged undo record.
Public method | RecordPersistentDataEvent<(Of <<'(T>)>>) | Create and Record a new PersistentDataChanged undo record.
Public method | RecordPivotEvent(String, IGH_DocumentObject) | Create and Record a new PivotChanged undo record.
Public method | RecordPivotEvent(String, IEnumerable<(Of <<'(IGH_DocumentObject>)>>)) | Create and Record a new PivotChanged undo record.
Public method | RecordPreviewEvent | Create and Record a new PreviewChanged undo record.
Public method | RecordRemoveObjectEvent(String, IGH_DocumentObject) | Create and Record a new ObjectRemoved undo record.
Public method | RecordRemoveObjectEvent(String, IEnumerable<(Of <<'(IGH_DocumentObject>)>>)) | Create and Record a new ObjectRemoved undo record.
Public method | RecordRemoveStateEvent | Create and Record a new CreateRemoveStateEvent undo record.
Public method | RecordReplaceStateEvent | Create and Record a new CreateReplaceStateEvent undo record.
Public method | RecordWireEvent(String, IGH_Param) | Create and Record a new WiresChanged undo record.
Public method | RecordWireEvent(String, IEnumerable<(Of <<'(IGH_Param>)>>)) | Create and Record a new WiresChanged undo record.

See Also

GH_Document..::..GH_UndoUtil Class
Grasshopper.Kernel Namespace


CreateAddObjectEvent Method

[image] [image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..CreateAddObjectEvent Method
GH_Document..::..GH_UndoUtil Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateAddObjectEvent(String, IGH_DocumentObject) | Create a new undo record for a single object addition.
Public method | CreateAddObjectEvent(String, IEnumerable<(Of <<'(IGH_DocumentObject>)>>)) | Create a new undo record for a bunch of object additions.

See Also

GH_Document..::..GH_UndoUtil Class
GH_Document..::..GH_UndoUtil Members
Grasshopper.Kernel Namespace


CreateAddObjectEvent Method (String, IGH_DocumentObject)

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..CreateAddObjectEvent Method (String, IGH_DocumentObject)
GH_Document..::..GH_UndoUtil Class See Also Send Feedback
Create a new undo record for a single object addition.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_UndoRecord CreateAddObjectEvent(
    string name,
    IGH_DocumentObject obj
)
Visual Basic
Public Function CreateAddObjectEvent ( _
    name As String, _
    obj As IGH_DocumentObject _
) As GH_UndoRecord

Parameters

name
Type: System..::..String
Name of undo record.
obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject
Object to be added.

Return Value

A newly created undo record.

See Also

GH_Document..::..GH_UndoUtil Class
CreateAddObjectEvent Overload
Grasshopper.Kernel Namespace


CreateAddObjectEvent Method (String, IEnumerable(IGH_DocumentObject))

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..CreateAddObjectEvent Method (String, IEnumerable<(Of <(<'IGH_DocumentObject>)>)>)
GH_Document..::..GH_UndoUtil Class See Also Send Feedback
Create a new undo record for a bunch of object additions.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_UndoRecord CreateAddObjectEvent(
    string name,
    IEnumerable<IGH_DocumentObject> objs
)
Visual Basic
Public Function CreateAddObjectEvent ( _
    name As String, _
    objs As IEnumerable(Of IGH_DocumentObject) _
) As GH_UndoRecord

Parameters

name
Type: System..::..String
Name of undo record.
objs
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' IGH_DocumentObject >)>)>
Objects to be added.

Return Value

A newly created undo record.

See Also

GH_Document..::..GH_UndoUtil Class
CreateAddObjectEvent Overload
Grasshopper.Kernel Namespace


CreateAddStateEvent Method

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..CreateAddStateEvent Method
GH_Document..::..GH_UndoUtil Class See Also Send Feedback
Create a new undo record for a single solution state addition.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_UndoRecord CreateAddStateEvent(
    string name,
    int stateIndex,
    GH_State state
)
Visual Basic
Public Function CreateAddStateEvent ( _
    name As String, _
    stateIndex As Integer, _
    state As GH_State _
) As GH_UndoRecord

Parameters

name
Type: System..::..String
Name of undo record.
stateIndex
Type: System..::..Int32
Index of state.
state
Type: Grasshopper.Kernel..::..GH_State
Solution state.

Return Value

A newly created undo record.

See Also

GH_Document..::..GH_UndoUtil Class
Grasshopper.Kernel Namespace


CreateEnabledEvent Method

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..CreateEnabledEvent Method
GH_Document..::..GH_UndoUtil Class See Also Send Feedback
Create a new undo record for an object enabled change. This function must be called before the enabled flag is changed.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_UndoRecord CreateEnabledEvent(
    string name,
    IGH_ActiveObject obj
)
Visual Basic
Public Function CreateEnabledEvent ( _
    name As String, _
    obj As IGH_ActiveObject _
) As GH_UndoRecord

Parameters

name
Type: System..::..String
Name of undo record.
obj
Type: Grasshopper.Kernel..::..IGH_ActiveObject
Target object for undo record.

Return Value

A newly created undo record.

See Also

GH_Document..::..GH_UndoUtil Class
Grasshopper.Kernel Namespace


CreateGenericObjectEvent Method

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..CreateGenericObjectEvent Method
GH_Document..::..GH_UndoUtil Class See Also Send Feedback
Create a new undo record for a generic, single object change.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_UndoRecord CreateGenericObjectEvent(
    string name,
    IGH_DocumentObject obj
)
Visual Basic
Public Function CreateGenericObjectEvent ( _
    name As String, _
    obj As IGH_DocumentObject _
) As GH_UndoRecord

Parameters

name
Type: System..::..String
Name of undo record.
obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject
Object to be recorded.

Return Value

A newly created undo record.

See Also

GH_Document..::..GH_UndoUtil Class
Grasshopper.Kernel Namespace


CreateLayoutEvent Method

[image] [image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..CreateLayoutEvent Method
GH_Document..::..GH_UndoUtil Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateLayoutEvent(String, IGH_DocumentObject) | Create a new undo record for a single object layout change. This function must be called before the layout is changed.
Public method | CreateLayoutEvent(String, IEnumerable<(Of <<'(IGH_DocumentObject>)>>)) | Create a new undo record for a bunch of object layout changes. This function must be called before the layouts are changed.

See Also

GH_Document..::..GH_UndoUtil Class
GH_Document..::..GH_UndoUtil Members
Grasshopper.Kernel Namespace


CreateLayoutEvent Method (String, IGH_DocumentObject)

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..CreateLayoutEvent Method (String, IGH_DocumentObject)
GH_Document..::..GH_UndoUtil Class See Also Send Feedback
Create a new undo record for a single object layout change. This function must be called before the layout is changed.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_UndoRecord CreateLayoutEvent(
    string name,
    IGH_DocumentObject obj
)
Visual Basic
Public Function CreateLayoutEvent ( _
    name As String, _
    obj As IGH_DocumentObject _
) As GH_UndoRecord

Parameters

name
Type: System..::..String
Name of undo record.
obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject
Target object for undo record.

Return Value

A newly created undo record.

See Also

GH_Document..::..GH_UndoUtil Class
CreateLayoutEvent Overload
Grasshopper.Kernel Namespace


CreateLayoutEvent Method (String, IEnumerable(IGH_DocumentObject))

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..CreateLayoutEvent Method (String, IEnumerable<(Of <(<'IGH_DocumentObject>)>)>)
GH_Document..::..GH_UndoUtil Class See Also Send Feedback
Create a new undo record for a bunch of object layout changes. This function must be called before the layouts are changed.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_UndoRecord CreateLayoutEvent(
    string name,
    IEnumerable<IGH_DocumentObject> objs
)
Visual Basic
Public Function CreateLayoutEvent ( _
    name As String, _
    objs As IEnumerable(Of IGH_DocumentObject) _
) As GH_UndoRecord

Parameters

name
Type: System..::..String
Name of undo record.
objs
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' IGH_DocumentObject >)>)>
Target objects for undo record.

Return Value

A newly created undo record.

See Also

GH_Document..::..GH_UndoUtil Class
CreateLayoutEvent Overload
Grasshopper.Kernel Namespace


CreateNickNameEvent Method

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..CreateNickNameEvent Method
GH_Document..::..GH_UndoUtil Class See Also Send Feedback
Create a new undo record for an object nickname change. This function must be called before the nickname is changed.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_UndoRecord CreateNickNameEvent(
    string name,
    IGH_DocumentObject obj
)
Visual Basic
Public Function CreateNickNameEvent ( _
    name As String, _
    obj As IGH_DocumentObject _
) As GH_UndoRecord

Parameters

name
Type: System..::..String
Name of undo record.
obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject
Target object for undo record.

Return Value

A newly created undo record.

See Also

GH_Document..::..GH_UndoUtil Class
Grasshopper.Kernel Namespace


CreatePersistentDataEvent(T) Method

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..CreatePersistentDataEvent<(Of <(<'T>)>)> Method
GH_Document..::..GH_UndoUtil Class See Also Send Feedback
Create a new undo record for a single object persistent data change.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_UndoRecord CreatePersistentDataEvent<T>(
    string name,
    GH_PersistentParam<T> obj
)
where T : class, IGH_Goo
Visual Basic
Public Function CreatePersistentDataEvent(Of T As {Class, IGH_Goo}) ( _
    name As String, _
    obj As GH_PersistentParam(Of T) _
) As GH_UndoRecord

Parameters

name
Type: System..::..String
Name of undo record.
obj
Type: Grasshopper.Kernel..::..GH_PersistentParam <(Of <(<'T>)>)>
Object to be recorded.

Type Parameters

T

Return Value

A newly created undo record.

See Also

GH_Document..::..GH_UndoUtil Class
Grasshopper.Kernel Namespace


CreatePivotEvent Method

[image] [image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..CreatePivotEvent Method
GH_Document..::..GH_UndoUtil Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreatePivotEvent(String, IGH_DocumentObject) | Create a new undo record for a single pivot change. This function must be called before the pivot is changed.
Public method | CreatePivotEvent(String, IEnumerable<(Of <<'(IGH_DocumentObject>)>>)) | Create a new undo record for a bunch of pivot changes. This function must be called before the pivots are changed.

See Also

GH_Document..::..GH_UndoUtil Class
GH_Document..::..GH_UndoUtil Members
Grasshopper.Kernel Namespace


CreatePivotEvent Method (String, IGH_DocumentObject)

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..CreatePivotEvent Method (String, IGH_DocumentObject)
GH_Document..::..GH_UndoUtil Class See Also Send Feedback
Create a new undo record for a single pivot change. This function must be called before the pivot is changed.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_UndoRecord CreatePivotEvent(
    string name,
    IGH_DocumentObject obj
)
Visual Basic
Public Function CreatePivotEvent ( _
    name As String, _
    obj As IGH_DocumentObject _
) As GH_UndoRecord

Parameters

name
Type: System..::..String
Name of undo record.
obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject
Target object for undo record.

Return Value

A newly created undo record.

See Also

GH_Document..::..GH_UndoUtil Class
CreatePivotEvent Overload
Grasshopper.Kernel Namespace


CreatePivotEvent Method (String, IEnumerable(IGH_DocumentObject))

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..CreatePivotEvent Method (String, IEnumerable<(Of <(<'IGH_DocumentObject>)>)>)
GH_Document..::..GH_UndoUtil Class See Also Send Feedback
Create a new undo record for a bunch of pivot changes. This function must be called before the pivots are changed.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_UndoRecord CreatePivotEvent(
    string name,
    IEnumerable<IGH_DocumentObject> objs
)
Visual Basic
Public Function CreatePivotEvent ( _
    name As String, _
    objs As IEnumerable(Of IGH_DocumentObject) _
) As GH_UndoRecord

Parameters

name
Type: System..::..String
Name of undo record.
objs
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' IGH_DocumentObject >)>)>
Target objects for undo record.

Return Value

A newly created undo record.

See Also

GH_Document..::..GH_UndoUtil Class
CreatePivotEvent Overload
Grasshopper.Kernel Namespace


CreatePreviewEvent Method

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..CreatePreviewEvent Method
GH_Document..::..GH_UndoUtil Class See Also Send Feedback
Create a new undo record for an object preview change. This function must be called before the preview is changed.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_UndoRecord CreatePreviewEvent(
    string name,
    IGH_ActiveObject obj
)
Visual Basic
Public Function CreatePreviewEvent ( _
    name As String, _
    obj As IGH_ActiveObject _
) As GH_UndoRecord

Parameters

name
Type: System..::..String
Name of undo record.
obj
Type: Grasshopper.Kernel..::..IGH_ActiveObject
Target object for undo record.

Return Value

A newly created undo record.

See Also

GH_Document..::..GH_UndoUtil Class
Grasshopper.Kernel Namespace


CreateRemoveObjectEvent Method

[image] [image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..CreateRemoveObjectEvent Method
GH_Document..::..GH_UndoUtil Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateRemoveObjectEvent(String, IGH_DocumentObject) | Create a new undo record for a single object removal.
Public method | CreateRemoveObjectEvent(String, IEnumerable<(Of <<'(IGH_DocumentObject>)>>)) | Create a new undo record for a bunch of object removals.

See Also

GH_Document..::..GH_UndoUtil Class
GH_Document..::..GH_UndoUtil Members
Grasshopper.Kernel Namespace


CreateRemoveObjectEvent Method (String, IGH_DocumentObject)

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..CreateRemoveObjectEvent Method (String, IGH_DocumentObject)
GH_Document..::..GH_UndoUtil Class See Also Send Feedback
Create a new undo record for a single object removal.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_UndoRecord CreateRemoveObjectEvent(
    string name,
    IGH_DocumentObject obj
)
Visual Basic
Public Function CreateRemoveObjectEvent ( _
    name As String, _
    obj As IGH_DocumentObject _
) As GH_UndoRecord

Parameters

name
Type: System..::..String
Name of undo record.
obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject
Object to be removed.

Return Value

A newly created undo record.

See Also

GH_Document..::..GH_UndoUtil Class
CreateRemoveObjectEvent Overload
Grasshopper.Kernel Namespace


CreateRemoveObjectEvent Method (String, IEnumerable(IGH_DocumentObject))

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..CreateRemoveObjectEvent Method (String, IEnumerable<(Of <(<'IGH_DocumentObject>)>)>)
GH_Document..::..GH_UndoUtil Class See Also Send Feedback
Create a new undo record for a bunch of object removals.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_UndoRecord CreateRemoveObjectEvent(
    string name,
    IEnumerable<IGH_DocumentObject> objs
)
Visual Basic
Public Function CreateRemoveObjectEvent ( _
    name As String, _
    objs As IEnumerable(Of IGH_DocumentObject) _
) As GH_UndoRecord

Parameters

name
Type: System..::..String
Name of undo record.
objs
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' IGH_DocumentObject >)>)>
Objects to be removed.

Return Value

A newly created undo record.

See Also

GH_Document..::..GH_UndoUtil Class
CreateRemoveObjectEvent Overload
Grasshopper.Kernel Namespace


CreateRemoveStateEvent Method

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..CreateRemoveStateEvent Method
GH_Document..::..GH_UndoUtil Class See Also Send Feedback
Create a new undo record for a single solution state removal.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_UndoRecord CreateRemoveStateEvent(
    string name,
    int stateIndex,
    GH_State state
)
Visual Basic
Public Function CreateRemoveStateEvent ( _
    name As String, _
    stateIndex As Integer, _
    state As GH_State _
) As GH_UndoRecord

Parameters

name
Type: System..::..String
Name of undo record.
stateIndex
Type: System..::..Int32
Index of state.
state
Type: Grasshopper.Kernel..::..GH_State
Solution state.

Return Value

A newly created undo record.

See Also

GH_Document..::..GH_UndoUtil Class
Grasshopper.Kernel Namespace


CreateReplaceStateEvent Method

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..CreateReplaceStateEvent Method
GH_Document..::..GH_UndoUtil Class See Also Send Feedback
Create a new undo record for a single solution state addition.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_UndoRecord CreateReplaceStateEvent(
    string name,
    int stateIndex,
    GH_State oldState,
    GH_State newState
)
Visual Basic
Public Function CreateReplaceStateEvent ( _
    name As String, _
    stateIndex As Integer, _
    oldState As GH_State, _
    newState As GH_State _
) As GH_UndoRecord

Parameters

name
Type: System..::..String
Name of undo record.
stateIndex
Type: System..::..Int32
Index of state.
oldState
Type: Grasshopper.Kernel..::..GH_State
Solution state to remove.
newState
Type: Grasshopper.Kernel..::..GH_State
Solution state to insert.

Return Value

A newly created undo record.

See Also

GH_Document..::..GH_UndoUtil Class
Grasshopper.Kernel Namespace


CreateWireEvent Method

[image] [image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..CreateWireEvent Method
GH_Document..::..GH_UndoUtil Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateWireEvent(String, IGH_Param) | Create a new undo record for a set of Connector wire changes. This function must be called before the wires are changed.
Public method | CreateWireEvent(String, IEnumerable<(Of <<'(IGH_Param>)>>)) | Create a new undo record for a set of Connector wire changes. This function must be called before the wires are changed.

See Also

GH_Document..::..GH_UndoUtil Class
GH_Document..::..GH_UndoUtil Members
Grasshopper.Kernel Namespace


CreateWireEvent Method (String, IGH_Param)

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..CreateWireEvent Method (String, IGH_Param)
GH_Document..::..GH_UndoUtil Class See Also Send Feedback
Create a new undo record for a set of Connector wire changes. This function must be called before the wires are changed.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_UndoRecord CreateWireEvent(
    string name,
    IGH_Param param
)
Visual Basic
Public Function CreateWireEvent ( _
    name As String, _
    param As IGH_Param _
) As GH_UndoRecord

Parameters

name
Type: System..::..String
Name of undo record.
param
Type: Grasshopper.Kernel..::..IGH_Param
Target object for undo record.

Return Value

A newly created undo record.

See Also

GH_Document..::..GH_UndoUtil Class
CreateWireEvent Overload
Grasshopper.Kernel Namespace


CreateWireEvent Method (String, IEnumerable(IGH_Param))

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..CreateWireEvent Method (String, IEnumerable<(Of <(<'IGH_Param>)>)>)
GH_Document..::..GH_UndoUtil Class See Also Send Feedback
Create a new undo record for a set of Connector wire changes. This function must be called before the wires are changed.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_UndoRecord CreateWireEvent(
    string name,
    IEnumerable<IGH_Param> params
)
Visual Basic
Public Function CreateWireEvent ( _
    name As String, _
    params As IEnumerable(Of IGH_Param) _
) As GH_UndoRecord

Parameters

name
Type: System..::..String
Name of undo record.
params
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' IGH_Param >)>)>
Target parameters for undo record.

Return Value

A newly created undo record.

See Also

GH_Document..::..GH_UndoUtil Class
CreateWireEvent Overload
Grasshopper.Kernel Namespace


RecordAddObjectEvent Method

[image] [image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..RecordAddObjectEvent Method
GH_Document..::..GH_UndoUtil Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RecordAddObjectEvent(String, IGH_DocumentObject) | Create and Record a new ObjectAdded undo record.
Public method | RecordAddObjectEvent(String, IEnumerable<(Of <<'(IGH_DocumentObject>)>>)) | Create and Record a new ObjectAdded undo record.

See Also

GH_Document..::..GH_UndoUtil Class
GH_Document..::..GH_UndoUtil Members
Grasshopper.Kernel Namespace


RecordAddObjectEvent Method (String, IGH_DocumentObject)

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..RecordAddObjectEvent Method (String, IGH_DocumentObject)
GH_Document..::..GH_UndoUtil Class See Also Send Feedback
Create and Record a new ObjectAdded undo record.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid RecordAddObjectEvent(
    string name,
    IGH_DocumentObject obj
)
Visual Basic
Public Function RecordAddObjectEvent ( _
    name As String, _
    obj As IGH_DocumentObject _
) As Guid

Parameters

name
Type: System..::..String
Name of undo record.
obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject
Target object for undo record.

Return Value

The ID of the newly added undo record or Guid.Empty on failure.

See Also

GH_Document..::..GH_UndoUtil Class
RecordAddObjectEvent Overload
Grasshopper.Kernel Namespace


RecordAddObjectEvent Method (String, IEnumerable(IGH_DocumentObject))

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..RecordAddObjectEvent Method (String, IEnumerable<(Of <(<'IGH_DocumentObject>)>)>)
GH_Document..::..GH_UndoUtil Class See Also Send Feedback
Create and Record a new ObjectAdded undo record.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid RecordAddObjectEvent(
    string name,
    IEnumerable<IGH_DocumentObject> objs
)
Visual Basic
Public Function RecordAddObjectEvent ( _
    name As String, _
    objs As IEnumerable(Of IGH_DocumentObject) _
) As Guid

Parameters

name
Type: System..::..String
Name of undo record.
objs
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' IGH_DocumentObject >)>)>
Target objects for undo record.

Return Value

The ID of the newly added undo record or Guid.Empty on failure.

See Also

GH_Document..::..GH_UndoUtil Class
RecordAddObjectEvent Overload
Grasshopper.Kernel Namespace


RecordAddStateEvent Method

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..RecordAddStateEvent Method
GH_Document..::..GH_UndoUtil Class See Also Send Feedback
Create and Record a new CreateAddStateEvent undo record.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid RecordAddStateEvent(
    string name,
    int stateIndex,
    GH_State state
)
Visual Basic
Public Function RecordAddStateEvent ( _
    name As String, _
    stateIndex As Integer, _
    state As GH_State _
) As Guid

Parameters

name
Type: System..::..String
Name of undo record.
stateIndex
Type: System..::..Int32
Index of state.
state
Type: Grasshopper.Kernel..::..GH_State
Solution state.

Return Value

The ID of the newly added undo record or Guid.Empty on failure.

See Also

GH_Document..::..GH_UndoUtil Class
Grasshopper.Kernel Namespace


RecordEnabledEvent Method

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..RecordEnabledEvent Method
GH_Document..::..GH_UndoUtil Class See Also Send Feedback
Create and Record a new EnabledChanged undo record.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid RecordEnabledEvent(
    string name,
    IGH_ActiveObject obj
)
Visual Basic
Public Function RecordEnabledEvent ( _
    name As String, _
    obj As IGH_ActiveObject _
) As Guid

Parameters

name
Type: System..::..String
Name of undo record.
obj
Type: Grasshopper.Kernel..::..IGH_ActiveObject
Target object for undo record.

Return Value

The ID of the newly added undo record or Guid.Empty on failure.

See Also

GH_Document..::..GH_UndoUtil Class
Grasshopper.Kernel Namespace


RecordEvent Method

[image] [image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..RecordEvent Method
GH_Document..::..GH_UndoUtil Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RecordEvent(GH_UndoRecord) | Add a new record to the undo stack of the owner document.
Public method | RecordEvent(String, IGH_UndoAction) | Add a new record to the undo stack of the owner document.
Public method | RecordEvent(String, array<IGH_UndoAction>[]()[][]) | Add a new record to the undo stack of the owner document.
Public method | RecordEvent(String, IEnumerable<(Of <<'(IGH_UndoAction>)>>)) | Add a new record to the undo stack of the owner document.

See Also

GH_Document..::..GH_UndoUtil Class
GH_Document..::..GH_UndoUtil Members
Grasshopper.Kernel Namespace


RecordEvent Method (GH_UndoRecord)

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..RecordEvent Method (GH_UndoRecord)
GH_Document..::..GH_UndoUtil Class See Also Send Feedback
Add a new record to the undo stack of the owner document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid RecordEvent(
    GH_UndoRecord record
)
Visual Basic
Public Function RecordEvent ( _
    record As GH_UndoRecord _
) As Guid

Parameters

record
Type: Grasshopper.Kernel.Undo..::..GH_UndoRecord
Undo record to add.

Return Value

The ID of the newly added undo record or Guid.Empty on failure.

See Also

GH_Document..::..GH_UndoUtil Class
RecordEvent Overload
Grasshopper.Kernel Namespace


RecordEvent Method (String, IGH_UndoAction)

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..RecordEvent Method (String, IGH_UndoAction)
GH_Document..::..GH_UndoUtil Class See Also Send Feedback
Add a new record to the undo stack of the owner document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid RecordEvent(
    string name,
    IGH_UndoAction action
)
Visual Basic
Public Function RecordEvent ( _
    name As String, _
    action As IGH_UndoAction _
) As Guid

Parameters

name
Type: System..::..String
Name of undo record.
action
Type: Grasshopper.Kernel.Undo..::..IGH_UndoAction
Undo action.

Return Value

The ID of the newly added undo record or Guid.Empty on failure.

See Also

GH_Document..::..GH_UndoUtil Class
RecordEvent Overload
Grasshopper.Kernel Namespace


RecordEvent Method (String, IGH_UndoAction[])

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..RecordEvent Method (String, array<IGH_UndoAction>[]()[][])
GH_Document..::..GH_UndoUtil Class See Also Send Feedback
Add a new record to the undo stack of the owner document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid RecordEvent(
    string name,
    params IGH_UndoAction[] actions
)
Visual Basic
Public Function RecordEvent ( _
    name As String, _
    ParamArray actions As IGH_UndoAction() _
) As Guid

Parameters

name
Type: System..::..String
Name of undo record.
actions
Type: array< Grasshopper.Kernel.Undo..::..IGH_UndoAction >[]()[][]
Undo actions.

Return Value

The ID of the newly added undo record or Guid.Empty on failure.

See Also

GH_Document..::..GH_UndoUtil Class
RecordEvent Overload
Grasshopper.Kernel Namespace


RecordEvent Method (String, IEnumerable(IGH_UndoAction))

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..RecordEvent Method (String, IEnumerable<(Of <(<'IGH_UndoAction>)>)>)
GH_Document..::..GH_UndoUtil Class See Also Send Feedback
Add a new record to the undo stack of the owner document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid RecordEvent(
    string name,
    IEnumerable<IGH_UndoAction> actions
)
Visual Basic
Public Function RecordEvent ( _
    name As String, _
    actions As IEnumerable(Of IGH_UndoAction) _
) As Guid

Parameters

name
Type: System..::..String
Name of undo record.
actions
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' IGH_UndoAction >)>)>
Undo actions.

Return Value

The ID of the newly added undo record or Guid.Empty on failure.

See Also

GH_Document..::..GH_UndoUtil Class
RecordEvent Overload
Grasshopper.Kernel Namespace


RecordGenericObjectEvent Method

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..RecordGenericObjectEvent Method
GH_Document..::..GH_UndoUtil Class See Also Send Feedback
Create and Record a new ObjectChanged undo record.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid RecordGenericObjectEvent(
    string name,
    IGH_DocumentObject obj
)
Visual Basic
Public Function RecordGenericObjectEvent ( _
    name As String, _
    obj As IGH_DocumentObject _
) As Guid

Parameters

name
Type: System..::..String
Name of undo record.
obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject
Target object for undo record.

Return Value

The ID of the newly added undo record or Guid.Empty on failure.

See Also

GH_Document..::..GH_UndoUtil Class
Grasshopper.Kernel Namespace


RecordLayoutEvent Method

[image] [image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..RecordLayoutEvent Method
GH_Document..::..GH_UndoUtil Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RecordLayoutEvent(String, IGH_DocumentObject) | Create and Record a new LayoutChanged undo record.
Public method | RecordLayoutEvent(String, IEnumerable<(Of <<'(IGH_DocumentObject>)>>)) | Create and Record a new LayoutChanged undo record.

See Also

GH_Document..::..GH_UndoUtil Class
GH_Document..::..GH_UndoUtil Members
Grasshopper.Kernel Namespace


RecordLayoutEvent Method (String, IGH_DocumentObject)

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..RecordLayoutEvent Method (String, IGH_DocumentObject)
GH_Document..::..GH_UndoUtil Class See Also Send Feedback
Create and Record a new LayoutChanged undo record.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid RecordLayoutEvent(
    string name,
    IGH_DocumentObject obj
)
Visual Basic
Public Function RecordLayoutEvent ( _
    name As String, _
    obj As IGH_DocumentObject _
) As Guid

Parameters

name
Type: System..::..String
Name of undo record.
obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject
Target object for undo record.

Return Value

The ID of the newly added undo record or Guid.Empty on failure.

See Also

GH_Document..::..GH_UndoUtil Class
RecordLayoutEvent Overload
Grasshopper.Kernel Namespace


RecordLayoutEvent Method (String, IEnumerable(IGH_DocumentObject))

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..RecordLayoutEvent Method (String, IEnumerable<(Of <(<'IGH_DocumentObject>)>)>)
GH_Document..::..GH_UndoUtil Class See Also Send Feedback
Create and Record a new LayoutChanged undo record.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid RecordLayoutEvent(
    string name,
    IEnumerable<IGH_DocumentObject> objs
)
Visual Basic
Public Function RecordLayoutEvent ( _
    name As String, _
    objs As IEnumerable(Of IGH_DocumentObject) _
) As Guid

Parameters

name
Type: System..::..String
Name of undo record.
objs
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' IGH_DocumentObject >)>)>
Target objects for undo record.

Return Value

The ID of the newly added undo record or Guid.Empty on failure.

See Also

GH_Document..::..GH_UndoUtil Class
RecordLayoutEvent Overload
Grasshopper.Kernel Namespace


RecordNickNameEvent Method

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..RecordNickNameEvent Method
GH_Document..::..GH_UndoUtil Class See Also Send Feedback
Create and Record a new NickNameChanged undo record.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid RecordNickNameEvent(
    string name,
    IGH_DocumentObject obj
)
Visual Basic
Public Function RecordNickNameEvent ( _
    name As String, _
    obj As IGH_DocumentObject _
) As Guid

Parameters

name
Type: System..::..String
Name of undo record.
obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject
Target object for undo record.

Return Value

The ID of the newly added undo record or Guid.Empty on failure.

See Also

GH_Document..::..GH_UndoUtil Class
Grasshopper.Kernel Namespace


RecordPersistentDataEvent(T) Method

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..RecordPersistentDataEvent<(Of <(<'T>)>)> Method
GH_Document..::..GH_UndoUtil Class See Also Send Feedback
Create and Record a new PersistentDataChanged undo record.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid RecordPersistentDataEvent<T>(
    string name,
    GH_PersistentParam<T> obj
)
where T : class, IGH_Goo
Visual Basic
Public Function RecordPersistentDataEvent(Of T As {Class, IGH_Goo}) ( _
    name As String, _
    obj As GH_PersistentParam(Of T) _
) As Guid

Parameters

name
Type: System..::..String
Name of undo record.
obj
Type: Grasshopper.Kernel..::..GH_PersistentParam <(Of <(<'T>)>)>
Target object for undo record.

Type Parameters

T

Return Value

The ID of the newly added undo record or Guid.Empty on failure.

See Also

GH_Document..::..GH_UndoUtil Class
Grasshopper.Kernel Namespace


RecordPivotEvent Method

[image] [image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..RecordPivotEvent Method
GH_Document..::..GH_UndoUtil Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RecordPivotEvent(String, IGH_DocumentObject) | Create and Record a new PivotChanged undo record.
Public method | RecordPivotEvent(String, IEnumerable<(Of <<'(IGH_DocumentObject>)>>)) | Create and Record a new PivotChanged undo record.

See Also

GH_Document..::..GH_UndoUtil Class
GH_Document..::..GH_UndoUtil Members
Grasshopper.Kernel Namespace


RecordPivotEvent Method (String, IGH_DocumentObject)

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..RecordPivotEvent Method (String, IGH_DocumentObject)
GH_Document..::..GH_UndoUtil Class See Also Send Feedback
Create and Record a new PivotChanged undo record.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid RecordPivotEvent(
    string name,
    IGH_DocumentObject obj
)
Visual Basic
Public Function RecordPivotEvent ( _
    name As String, _
    obj As IGH_DocumentObject _
) As Guid

Parameters

name
Type: System..::..String
Name of undo record.
obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject
Target object for undo record.

Return Value

The ID of the newly added undo record or Guid.Empty on failure.

See Also

GH_Document..::..GH_UndoUtil Class
RecordPivotEvent Overload
Grasshopper.Kernel Namespace


RecordPivotEvent Method (String, IEnumerable(IGH_DocumentObject))

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..RecordPivotEvent Method (String, IEnumerable<(Of <(<'IGH_DocumentObject>)>)>)
GH_Document..::..GH_UndoUtil Class See Also Send Feedback
Create and Record a new PivotChanged undo record.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid RecordPivotEvent(
    string name,
    IEnumerable<IGH_DocumentObject> objs
)
Visual Basic
Public Function RecordPivotEvent ( _
    name As String, _
    objs As IEnumerable(Of IGH_DocumentObject) _
) As Guid

Parameters

name
Type: System..::..String
Name of undo record.
objs
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' IGH_DocumentObject >)>)>
Target objects for undo record.

Return Value

The ID of the newly added undo record or Guid.Empty on failure.

See Also

GH_Document..::..GH_UndoUtil Class
RecordPivotEvent Overload
Grasshopper.Kernel Namespace


RecordPreviewEvent Method

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..RecordPreviewEvent Method
GH_Document..::..GH_UndoUtil Class See Also Send Feedback
Create and Record a new PreviewChanged undo record.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid RecordPreviewEvent(
    string name,
    IGH_ActiveObject obj
)
Visual Basic
Public Function RecordPreviewEvent ( _
    name As String, _
    obj As IGH_ActiveObject _
) As Guid

Parameters

name
Type: System..::..String
Name of undo record.
obj
Type: Grasshopper.Kernel..::..IGH_ActiveObject
Target object for undo record.

Return Value

The ID of the newly added undo record or Guid.Empty on failure.

See Also

GH_Document..::..GH_UndoUtil Class
Grasshopper.Kernel Namespace


RecordRemoveObjectEvent Method

[image] [image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..RecordRemoveObjectEvent Method
GH_Document..::..GH_UndoUtil Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RecordRemoveObjectEvent(String, IGH_DocumentObject) | Create and Record a new ObjectRemoved undo record.
Public method | RecordRemoveObjectEvent(String, IEnumerable<(Of <<'(IGH_DocumentObject>)>>)) | Create and Record a new ObjectRemoved undo record.

See Also

GH_Document..::..GH_UndoUtil Class
GH_Document..::..GH_UndoUtil Members
Grasshopper.Kernel Namespace


RecordRemoveObjectEvent Method (String, IGH_DocumentObject)

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..RecordRemoveObjectEvent Method (String, IGH_DocumentObject)
GH_Document..::..GH_UndoUtil Class See Also Send Feedback
Create and Record a new ObjectRemoved undo record.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid RecordRemoveObjectEvent(
    string name,
    IGH_DocumentObject obj
)
Visual Basic
Public Function RecordRemoveObjectEvent ( _
    name As String, _
    obj As IGH_DocumentObject _
) As Guid

Parameters

name
Type: System..::..String
Name of undo record.
obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject
Target object for undo record.

Return Value

The ID of the newly added undo record or Guid.Empty on failure.

See Also

GH_Document..::..GH_UndoUtil Class
RecordRemoveObjectEvent Overload
Grasshopper.Kernel Namespace


RecordRemoveObjectEvent Method (String, IEnumerable(IGH_DocumentObject))

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..RecordRemoveObjectEvent Method (String, IEnumerable<(Of <(<'IGH_DocumentObject>)>)>)
GH_Document..::..GH_UndoUtil Class See Also Send Feedback
Create and Record a new ObjectRemoved undo record.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid RecordRemoveObjectEvent(
    string name,
    IEnumerable<IGH_DocumentObject> objs
)
Visual Basic
Public Function RecordRemoveObjectEvent ( _
    name As String, _
    objs As IEnumerable(Of IGH_DocumentObject) _
) As Guid

Parameters

name
Type: System..::..String
Name of undo record.
objs
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' IGH_DocumentObject >)>)>
Target objects for undo record.

Return Value

The ID of the newly added undo record or Guid.Empty on failure.

See Also

GH_Document..::..GH_UndoUtil Class
RecordRemoveObjectEvent Overload
Grasshopper.Kernel Namespace


RecordRemoveStateEvent Method

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..RecordRemoveStateEvent Method
GH_Document..::..GH_UndoUtil Class See Also Send Feedback
Create and Record a new CreateRemoveStateEvent undo record.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid RecordRemoveStateEvent(
    string name,
    int stateIndex,
    GH_State state
)
Visual Basic
Public Function RecordRemoveStateEvent ( _
    name As String, _
    stateIndex As Integer, _
    state As GH_State _
) As Guid

Parameters

name
Type: System..::..String
Name of undo record.
stateIndex
Type: System..::..Int32
Index of state.
state
Type: Grasshopper.Kernel..::..GH_State
Solution state.

Return Value

The ID of the newly added undo record or Guid.Empty on failure.

See Also

GH_Document..::..GH_UndoUtil Class
Grasshopper.Kernel Namespace


RecordReplaceStateEvent Method

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..RecordReplaceStateEvent Method
GH_Document..::..GH_UndoUtil Class See Also Send Feedback
Create and Record a new CreateReplaceStateEvent undo record.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid RecordReplaceStateEvent(
    string name,
    int stateIndex,
    GH_State oldState,
    GH_State newState
)
Visual Basic
Public Function RecordReplaceStateEvent ( _
    name As String, _
    stateIndex As Integer, _
    oldState As GH_State, _
    newState As GH_State _
) As Guid

Parameters

name
Type: System..::..String
Name of undo record.
stateIndex
Type: System..::..Int32
Index of state.
oldState
Type: Grasshopper.Kernel..::..GH_State
Solution state to remove.
newState
Type: Grasshopper.Kernel..::..GH_State
Solution state to insert.

Return Value

The ID of the newly added undo record or Guid.Empty on failure.

See Also

GH_Document..::..GH_UndoUtil Class
Grasshopper.Kernel Namespace


RecordWireEvent Method

[image] [image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..RecordWireEvent Method
GH_Document..::..GH_UndoUtil Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RecordWireEvent(String, IGH_Param) | Create and Record a new WiresChanged undo record.
Public method | RecordWireEvent(String, IEnumerable<(Of <<'(IGH_Param>)>>)) | Create and Record a new WiresChanged undo record.

See Also

GH_Document..::..GH_UndoUtil Class
GH_Document..::..GH_UndoUtil Members
Grasshopper.Kernel Namespace


RecordWireEvent Method (String, IGH_Param)

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..RecordWireEvent Method (String, IGH_Param)
GH_Document..::..GH_UndoUtil Class See Also Send Feedback
Create and Record a new WiresChanged undo record.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid RecordWireEvent(
    string name,
    IGH_Param param
)
Visual Basic
Public Function RecordWireEvent ( _
    name As String, _
    param As IGH_Param _
) As Guid

Parameters

name
Type: System..::..String
Name of undo record.
param
Type: Grasshopper.Kernel..::..IGH_Param
Target parameter for undo record.

Return Value

The ID of the newly added undo record or Guid.Empty on failure.

See Also

GH_Document..::..GH_UndoUtil Class
RecordWireEvent Overload
Grasshopper.Kernel Namespace


RecordWireEvent Method (String, IEnumerable(IGH_Param))

[image]

Grasshopper SDK
GH_Document..::..GH_UndoUtil..::..RecordWireEvent Method (String, IEnumerable<(Of <(<'IGH_Param>)>)>)
GH_Document..::..GH_UndoUtil Class See Also Send Feedback
Create and Record a new WiresChanged undo record.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid RecordWireEvent(
    string name,
    IEnumerable<IGH_Param> params
)
Visual Basic
Public Function RecordWireEvent ( _
    name As String, _
    params As IEnumerable(Of IGH_Param) _
) As Guid

Parameters

name
Type: System..::..String
Name of undo record.
params
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' IGH_Param >)>)>
Target parameters for undo record.

Return Value

The ID of the newly added undo record or Guid.Empty on failure.

See Also

GH_Document..::..GH_UndoUtil Class
RecordWireEvent Overload
Grasshopper.Kernel Namespace


GH_Document.ModifiedChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_Document..::..ModifiedChangedEventHandler Delegate
GH_Document Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void ModifiedChangedEventHandler(
    Object sender,
    GH_DocModifiedEventArgs e
)
Visual Basic
Public Delegate Sub ModifiedChangedEventHandler ( _
    sender As Object, _
    e As GH_DocModifiedEventArgs _
)

Parameters

sender
Type: System..::..Object
e
Type: Grasshopper.Kernel..::..GH_DocModifiedEventArgs

See Also

Grasshopper.Kernel Namespace


GH_Document.ObjectsAddedEventHandler Delegate

[image]

Grasshopper SDK
GH_Document..::..ObjectsAddedEventHandler Delegate
GH_Document Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void ObjectsAddedEventHandler(
    Object sender,
    GH_DocObjectEventArgs e
)
Visual Basic
Public Delegate Sub ObjectsAddedEventHandler ( _
    sender As Object, _
    e As GH_DocObjectEventArgs _
)

Parameters

sender
Type: System..::..Object
e
Type: Grasshopper.Kernel..::..GH_DocObjectEventArgs

See Also

Grasshopper.Kernel Namespace


GH_Document.ObjectsDeletedEventHandler Delegate

[image]

Grasshopper SDK
GH_Document..::..ObjectsDeletedEventHandler Delegate
GH_Document Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void ObjectsDeletedEventHandler(
    Object sender,
    GH_DocObjectEventArgs e
)
Visual Basic
Public Delegate Sub ObjectsDeletedEventHandler ( _
    sender As Object, _
    e As GH_DocObjectEventArgs _
)

Parameters

sender
Type: System..::..Object
e
Type: Grasshopper.Kernel..::..GH_DocObjectEventArgs

See Also

Grasshopper.Kernel Namespace


GH_Document.SettingsChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_Document..::..SettingsChangedEventHandler Delegate
GH_Document Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void SettingsChangedEventHandler(
    Object sender,
    GH_DocSettingsEventArgs e
)
Visual Basic
Public Delegate Sub SettingsChangedEventHandler ( _
    sender As Object, _
    e As GH_DocSettingsEventArgs _
)

Parameters

sender
Type: System..::..Object
e
Type: Grasshopper.Kernel..::..GH_DocSettingsEventArgs

See Also

Grasshopper.Kernel Namespace


GH_Document.SolutionEndEventHandler Delegate

[image]

Grasshopper SDK
GH_Document..::..SolutionEndEventHandler Delegate
GH_Document Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void SolutionEndEventHandler(
    Object sender,
    GH_SolutionEventArgs e
)
Visual Basic
Public Delegate Sub SolutionEndEventHandler ( _
    sender As Object, _
    e As GH_SolutionEventArgs _
)

Parameters

sender
Type: System..::..Object
e
Type: Grasshopper.Kernel..::..GH_SolutionEventArgs

See Also

Grasshopper.Kernel Namespace


GH_Document.SolutionStartEventHandler Delegate

[image]

Grasshopper SDK
GH_Document..::..SolutionStartEventHandler Delegate
GH_Document Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void SolutionStartEventHandler(
    Object sender,
    GH_SolutionEventArgs e
)
Visual Basic
Public Delegate Sub SolutionStartEventHandler ( _
    sender As Object, _
    e As GH_SolutionEventArgs _
)

Parameters

sender
Type: System..::..Object
e
Type: Grasshopper.Kernel..::..GH_SolutionEventArgs

See Also

Grasshopper.Kernel Namespace


GH_Document.UndoStateChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_Document..::..UndoStateChangedEventHandler Delegate
GH_Document Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void UndoStateChangedEventHandler(
    Object sender,
    GH_DocUndoEventArgs e
)
Visual Basic
Public Delegate Sub UndoStateChangedEventHandler ( _
    sender As Object, _
    e As GH_DocUndoEventArgs _
)

Parameters

sender
Type: System..::..Object
e
Type: Grasshopper.Kernel..::..GH_DocUndoEventArgs

See Also

Grasshopper.Kernel Namespace


GH_DocumentAssociations Class

[image]

Grasshopper SDK
GH_DocumentAssociations Class
Members See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_DocumentAssociations
Visual Basic
Public Class GH_DocumentAssociations

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_DocumentAssociations

See Also

GH_DocumentAssociations Members
Grasshopper.Kernel Namespace


GH_DocumentAssociations Members

[image] [image]

Grasshopper SDK
GH_DocumentAssociations Members
GH_DocumentAssociations Class Constructors Methods See Also Send Feedback

The GH_DocumentAssociations type exposes the following members.

Constructors

 | Name | Description
Public method | GH_DocumentAssociations | Initializes a new instance of the GH_DocumentAssociations class

Methods

 | Name | Description
Public method | Associate | Add an association between a Rhino and a Grasshopper file. If a similar association already exists, it will be overwritten. This function reads and writes to the disk, it is SLOW. Only call it when you KNOW something changed.
Public method | GetGrasshopperAssociations | Find all the Grasshopper ghx files that have been associated with a given Rhino file.
Public method | GetRhinoAssociations | Find all the Rhino 3dm files that have been associated with a given Grasshopper file.

See Also

GH_DocumentAssociations Class
Grasshopper.Kernel Namespace


GH_DocumentAssociations Constructor

[image]

Grasshopper SDK
GH_DocumentAssociations Constructor
GH_DocumentAssociations Class See Also Send Feedback
Initializes a new instance of the GH_DocumentAssociations class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_DocumentAssociations()
Visual Basic
Public Sub New

See Also

GH_DocumentAssociations Class
Grasshopper.Kernel Namespace


GH_DocumentAssociations Methods

[image] [image]

Grasshopper SDK
GH_DocumentAssociations Methods
GH_DocumentAssociations Class See Also Send Feedback

The GH_DocumentAssociations type exposes the following members.

Methods

 | Name | Description
Public method | Associate | Add an association between a Rhino and a Grasshopper file. If a similar association already exists, it will be overwritten. This function reads and writes to the disk, it is SLOW. Only call it when you KNOW something changed.
Public method | GetGrasshopperAssociations | Find all the Grasshopper ghx files that have been associated with a given Rhino file.
Public method | GetRhinoAssociations | Find all the Rhino 3dm files that have been associated with a given Grasshopper file.

See Also

GH_DocumentAssociations Class
Grasshopper.Kernel Namespace


Associate Method

[image]

Grasshopper SDK
GH_DocumentAssociations..::..Associate Method
GH_DocumentAssociations Class See Also Send Feedback
Add an association between a Rhino and a Grasshopper file. If a similar association already exists, it will be overwritten. This function reads and writes to the disk, it is SLOW. Only call it when you KNOW something changed.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Associate(
    string rhinoFile,
    string grasshopperFile
)
Visual Basic
Public Sub Associate ( _
    rhinoFile As String, _
    grasshopperFile As String _
)

Parameters

rhinoFile
Type: System..::..String
Path to Rhino 3dm file.
grasshopperFile
Type: System..::..String
Path to Grasshopper ghx or gh file.

See Also

GH_DocumentAssociations Class
Grasshopper.Kernel Namespace


GetGrasshopperAssociations Method

[image]

Grasshopper SDK
GH_DocumentAssociations..::..GetGrasshopperAssociations Method
GH_DocumentAssociations Class See Also Send Feedback
Find all the Grasshopper ghx files that have been associated with a given Rhino file.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<string> GetGrasshopperAssociations(
    string rhinoFile
)
Visual Basic
Public Function GetGrasshopperAssociations ( _
    rhinoFile As String _
) As List(Of String)

Parameters

rhinoFile
Type: System..::..String
Rhino file path.

Return Value

A list of files, ordered chronologically (most recent association first)

See Also

GH_DocumentAssociations Class
Grasshopper.Kernel Namespace


GetRhinoAssociations Method

[image]

Grasshopper SDK
GH_DocumentAssociations..::..GetRhinoAssociations Method
GH_DocumentAssociations Class See Also Send Feedback
Find all the Rhino 3dm files that have been associated with a given Grasshopper file.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<string> GetRhinoAssociations(
    string grasshopperFile
)
Visual Basic
Public Function GetRhinoAssociations ( _
    grasshopperFile As String _
) As List(Of String)

Parameters

grasshopperFile
Type: System..::..String
Grasshopper file path.

Return Value

A list of files, ordered chronologically (most recent association first)

See Also

GH_DocumentAssociations Class
Grasshopper.Kernel Namespace


GH_DocumentContext Enumeration

[image]

Grasshopper SDK
GH_DocumentContext Enumeration
See Also Send Feedback
Enumerates all possible (de)activation contexts for documents.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_DocumentContext
Visual Basic
Public Enumeration GH_DocumentContext

Members

Member name | Value | Description
Unknown | 0 | Specifies unknown context. This should never be used.
None | 1 | Specifies unset state. This is only used for documents that have never been in a context.
Open | 2 | Indicates the document was created anew from a file.
Close | 3 | Indicates the document has been unloaded from memory.
Loaded | 4 | Indicates the document has been loaded into the Canvas.
Unloaded | 5 | Indicates the document has been unloaded from the Canvas.
Lock | 6 | Indicates the document has been locked. This is only possible for nested documents.
Unlock | 7 | Indicates the document has been unlocked. This is only possible for nested documents.

See Also

Grasshopper.Kernel Namespace


GH_DocumentEventServer Class

[image]

Grasshopper SDK
GH_DocumentEventServer Class
Members See Also Send Feedback
RhinoCommon only event server.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_DocumentEventServer : IGH_DebugDescription
Visual Basic
Public Class GH_DocumentEventServer _
    Implements IGH_DebugDescription

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_DocumentEventServer

See Also

GH_DocumentEventServer Members
Grasshopper.Kernel Namespace


GH_DocumentEventServer Members

[image] [image]

Grasshopper SDK
GH_DocumentEventServer Members
GH_DocumentEventServer Class Constructors Methods Properties See Also Send Feedback

The GH_DocumentEventServer type exposes the following members.

Constructors

 | Name | Description
Public method | GH_DocumentEventServer | Create and register a new event server.

Methods

 | Name | Description
Public method | AppendToDebugLog |
Public method | ClearGuidTable | Clear the entire ID table.
Public method | CreateGuidTable | Create the entire ID table from scratch.
Public method | EnsureGuidTable | Create the entire ID table if it doesn't exist yet.

Properties

 | Name | Description
Public property | Enabled | Gets or sets the enabled state flag for this event watcher.
Public property | GuidTableRefCount | Gets the number of stored ids in the Guid Table.

See Also

GH_DocumentEventServer Class
Grasshopper.Kernel Namespace


GH_DocumentEventServer Constructor

[image]

Grasshopper SDK
GH_DocumentEventServer Constructor
GH_DocumentEventServer Class See Also Send Feedback
Create and register a new event server.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_DocumentEventServer(
    GH_Document document
)
Visual Basic
Public Sub New ( _
    document As GH_Document _
)

Parameters

document
Type: Grasshopper.Kernel..::..GH_Document
Document that owns this event server.

See Also

GH_DocumentEventServer Class
Grasshopper.Kernel Namespace


GH_DocumentEventServer Methods

[image] [image]

Grasshopper SDK
GH_DocumentEventServer Methods
GH_DocumentEventServer Class See Also Send Feedback

The GH_DocumentEventServer type exposes the following members.

Methods

 | Name | Description
Public method | AppendToDebugLog |
Public method | ClearGuidTable | Clear the entire ID table.
Public method | CreateGuidTable | Create the entire ID table from scratch.
Public method | EnsureGuidTable | Create the entire ID table if it doesn't exist yet.

See Also

GH_DocumentEventServer Class
Grasshopper.Kernel Namespace


AppendToDebugLog Method

[image]

Grasshopper SDK
GH_DocumentEventServer..::..AppendToDebugLog Method
GH_DocumentEventServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AppendToDebugLog(
    GH_DebugDescriptionWriter writer
)
Visual Basic
Public Sub AppendToDebugLog ( _
    writer As GH_DebugDescriptionWriter _
)

Parameters

writer
Type: Grasshopper.Kernel..::..GH_DebugDescriptionWriter

Implements

IGH_DebugDescription..::..AppendToDebugLog(GH_DebugDescriptionWriter)

See Also

GH_DocumentEventServer Class
Grasshopper.Kernel Namespace


ClearGuidTable Method

[image]

Grasshopper SDK
GH_DocumentEventServer..::..ClearGuidTable Method
GH_DocumentEventServer Class See Also Send Feedback
Clear the entire ID table.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ClearGuidTable()
Visual Basic
Public Sub ClearGuidTable

See Also

GH_DocumentEventServer Class
Grasshopper.Kernel Namespace


CreateGuidTable Method

[image]

Grasshopper SDK
GH_DocumentEventServer..::..CreateGuidTable Method
GH_DocumentEventServer Class See Also Send Feedback
Create the entire ID table from scratch.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void CreateGuidTable()
Visual Basic
Public Sub CreateGuidTable

See Also

GH_DocumentEventServer Class
Grasshopper.Kernel Namespace


EnsureGuidTable Method

[image]

Grasshopper SDK
GH_DocumentEventServer..::..EnsureGuidTable Method
GH_DocumentEventServer Class See Also Send Feedback
Create the entire ID table if it doesn't exist yet.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void EnsureGuidTable()
Visual Basic
Public Sub EnsureGuidTable

See Also

GH_DocumentEventServer Class
Grasshopper.Kernel Namespace


GH_DocumentEventServer Properties

[image] [image]

Grasshopper SDK
GH_DocumentEventServer Properties
GH_DocumentEventServer Class See Also Send Feedback

The GH_DocumentEventServer type exposes the following members.

Properties

 | Name | Description
Public property | Enabled | Gets or sets the enabled state flag for this event watcher.
Public property | GuidTableRefCount | Gets the number of stored ids in the Guid Table.

See Also

GH_DocumentEventServer Class
Grasshopper.Kernel Namespace


Enabled Property

[image]

Grasshopper SDK
GH_DocumentEventServer..::..Enabled Property
GH_DocumentEventServer Class See Also Send Feedback
Gets or sets the enabled state flag for this event watcher.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Enabled { get; set; }
Visual Basic
Public Property Enabled As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DocumentEventServer.Enabled"]

Return Value

Remarks

See Also

GH_DocumentEventServer Class
Grasshopper.Kernel Namespace


GuidTableRefCount Property

[image]

Grasshopper SDK
GH_DocumentEventServer..::..GuidTableRefCount Property
GH_DocumentEventServer Class See Also Send Feedback
Gets the number of stored ids in the Guid Table.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int GuidTableRefCount { get; }
Visual Basic
Public ReadOnly Property GuidTableRefCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DocumentEventServer.GuidTableRefCount"]

See Also

GH_DocumentEventServer Class
Grasshopper.Kernel Namespace


GH_DocumentIO Class

[image]

Grasshopper SDK
GH_DocumentIO Class
Members See Also Send Feedback
Provides basic IO operations for GH_Documents.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class GH_DocumentIO
Visual Basic
Public NotInheritable Class GH_DocumentIO

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_DocumentIO

See Also

GH_DocumentIO Members
Grasshopper.Kernel Namespace


GH_DocumentIO Members

[image] [image]

Grasshopper SDK
GH_DocumentIO Members
GH_DocumentIO Class Constructors Methods Properties See Also Send Feedback

The GH_DocumentIO type exposes the following members.

Constructors

 | Name | Description
Public method | GH_DocumentIO()()()() | Create a new instance of GH_DocumentIO without an internal document.
Public method | GH_DocumentIO(GH_Document) | Create a new instance of GH_DocumentIO with an internal document.

Methods

 | Name | Description
Public method | ClearClipboard | Clear the Clipboard Text content. This function wipes both the Text and UnicodeText clipboard fields.
Public method | Copy(GH_ClipboardType) | Copy the internal document into the clipboard.
Public method | Copy(GH_ClipboardType, Boolean) | Copy the internal document into the clipboard.
Public method | Copy(GH_ClipboardType, IEnumerable<(Of <<'(Guid>)>>)) | Copy the specified objects in the internal document into the clipboard.
 | GetDocumentThumbnail | Try and extract the preview image of a document. Not all gh/ghx files contain a thumbnail so this function may return null. The document itself is not loaded and rendered, so the thumbnail really has to be part of the file already.
Public method | Open()()()() | Perform a default Open operation and store the result as the internal document.
Public method | Open(String) | Open the file at the given location.
Public method | OpenDocumentDialog | Display the Open GH/GHX dialog.
Public method | Paste | Deserialize a Grasshopper document from the clipboard. On success, the internal document of this GH_DocumentIO instance will be set.
Public method | Save | Perform a default Save operation on the internal document.
Public method | SaveAs | Perform a default Save As operation on the internal document.
Public method | SaveAsCopyDocumentDialog | Display the Save As Copy GH/GHX dialog.
Public method | SaveAsDocumentDialog | Display the Save As GH/GHX dialog.
Public method | SaveBackup | Save a time-stamped copy of the current file.
Public method | SaveDocumentDialog | Display the Save GH/GHX dialog.
 | SubsidiaryDocumentSavePrompt(GH_Document) | Display a 'stuff has changed do you want to save' message box with Yes/No/Cancel options.
 | SubsidiaryDocumentSavePrompt(String, Boolean, Int32) | Display a 'stuff has changed do you want to save' message box with Yes/No/Cancel options.

Properties

 | Name | Description
Public property | Document | Gets or sets the internal document.
Public property | IsDocument | Gets a value indicating whether or not this instance of GH_DocumentIO contains an internal document.

See Also

GH_DocumentIO Class
Grasshopper.Kernel Namespace


GH_DocumentIO Constructor

[image] [image]

Grasshopper SDK
GH_DocumentIO Constructor
GH_DocumentIO Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_DocumentIO()()()() | Create a new instance of GH_DocumentIO without an internal document.
Public method | GH_DocumentIO(GH_Document) | Create a new instance of GH_DocumentIO with an internal document.

See Also

GH_DocumentIO Class
GH_DocumentIO Members
Grasshopper.Kernel Namespace


GH_DocumentIO Constructor

[image]

Grasshopper SDK
GH_DocumentIO Constructor
GH_DocumentIO Class See Also Send Feedback
Create a new instance of GH_DocumentIO without an internal document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_DocumentIO()
Visual Basic
Public Sub New

See Also

GH_DocumentIO Class
GH_DocumentIO Overload
Grasshopper.Kernel Namespace


GH_DocumentIO Constructor (GH_Document)

[image]

Grasshopper SDK
GH_DocumentIO Constructor (GH_Document)
GH_DocumentIO Class See Also Send Feedback
Create a new instance of GH_DocumentIO with an internal document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_DocumentIO(
    GH_Document internal_doc
)
Visual Basic
Public Sub New ( _
    internal_doc As GH_Document _
)

Parameters

internal_doc
Type: Grasshopper.Kernel..::..GH_Document
Document to internalise.

See Also

GH_DocumentIO Class
GH_DocumentIO Overload
Grasshopper.Kernel Namespace


GH_DocumentIO Methods

[image] [image]

Grasshopper SDK
GH_DocumentIO Methods
GH_DocumentIO Class See Also Send Feedback

The GH_DocumentIO type exposes the following members.

Methods

 | Name | Description
Public method | ClearClipboard | Clear the Clipboard Text content. This function wipes both the Text and UnicodeText clipboard fields.
Public method | Copy(GH_ClipboardType) | Copy the internal document into the clipboard.
Public method | Copy(GH_ClipboardType, Boolean) | Copy the internal document into the clipboard.
Public method | Copy(GH_ClipboardType, IEnumerable<(Of <<'(Guid>)>>)) | Copy the specified objects in the internal document into the clipboard.
 | GetDocumentThumbnail | Try and extract the preview image of a document. Not all gh/ghx files contain a thumbnail so this function may return null. The document itself is not loaded and rendered, so the thumbnail really has to be part of the file already.
Public method | Open()()()() | Perform a default Open operation and store the result as the internal document.
Public method | Open(String) | Open the file at the given location.
Public method | OpenDocumentDialog | Display the Open GH/GHX dialog.
Public method | Paste | Deserialize a Grasshopper document from the clipboard. On success, the internal document of this GH_DocumentIO instance will be set.
Public method | Save | Perform a default Save operation on the internal document.
Public method | SaveAs | Perform a default Save As operation on the internal document.
Public method | SaveAsCopyDocumentDialog | Display the Save As Copy GH/GHX dialog.
Public method | SaveAsDocumentDialog | Display the Save As GH/GHX dialog.
Public method | SaveBackup | Save a time-stamped copy of the current file.
Public method | SaveDocumentDialog | Display the Save GH/GHX dialog.
 | SubsidiaryDocumentSavePrompt(GH_Document) | Display a 'stuff has changed do you want to save' message box with Yes/No/Cancel options.
 | SubsidiaryDocumentSavePrompt(String, Boolean, Int32) | Display a 'stuff has changed do you want to save' message box with Yes/No/Cancel options.

See Also

GH_DocumentIO Class
Grasshopper.Kernel Namespace


ClearClipboard Method

[image]

Grasshopper SDK
GH_DocumentIO..::..ClearClipboard Method
GH_DocumentIO Class See Also Send Feedback
Clear the Clipboard Text content. This function wipes both the Text and UnicodeText clipboard fields.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ClearClipboard(
    GH_ClipboardType clipboard
)
Visual Basic
Public Sub ClearClipboard ( _
    clipboard As GH_ClipboardType _
)

Parameters

clipboard
Type: Grasshopper.Kernel..::..GH_ClipboardType

See Also

GH_DocumentIO Class
Grasshopper.Kernel Namespace


Copy Method

[image] [image]

Grasshopper SDK
GH_DocumentIO..::..Copy Method
GH_DocumentIO Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Copy(GH_ClipboardType) | Copy the internal document into the clipboard.
Public method | Copy(GH_ClipboardType, Boolean) | Copy the internal document into the clipboard.
Public method | Copy(GH_ClipboardType, IEnumerable<(Of <<'(Guid>)>>)) | Copy the specified objects in the internal document into the clipboard.

See Also

GH_DocumentIO Class
GH_DocumentIO Members
Grasshopper.Kernel Namespace


Copy Method (GH_ClipboardType)

[image]

Grasshopper SDK
GH_DocumentIO..::..Copy Method (GH_ClipboardType)
GH_DocumentIO Class See Also Send Feedback
Copy the internal document into the clipboard.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Copy(
    GH_ClipboardType clipboard
)
Visual Basic
Public Function Copy ( _
    clipboard As GH_ClipboardType _
) As Boolean

Parameters

clipboard
Type: Grasshopper.Kernel..::..GH_ClipboardType
Specifies the clipboard type to use.

See Also

GH_DocumentIO Class
Copy Overload
Grasshopper.Kernel Namespace


Copy Method (GH_ClipboardType, Boolean)

[image]

Grasshopper SDK
GH_DocumentIO..::..Copy Method (GH_ClipboardType, Boolean)
GH_DocumentIO Class See Also Send Feedback
Copy the internal document into the clipboard.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Copy(
    GH_ClipboardType clipboard,
    bool limitToSelection
)
Visual Basic
Public Function Copy ( _
    clipboard As GH_ClipboardType, _
    limitToSelection As Boolean _
) As Boolean

Parameters

clipboard
Type: Grasshopper.Kernel..::..GH_ClipboardType
Specifies the clipboard type to use.
limitToSelection
Type: System..::..Boolean
If true, only the selected objects will be copied.

Return Value

True on success, false on failure.

See Also

GH_DocumentIO Class
Copy Overload
Grasshopper.Kernel Namespace


Copy Method (GH_ClipboardType, IEnumerable(Guid))

[image]

Grasshopper SDK
GH_DocumentIO..::..Copy Method (GH_ClipboardType, IEnumerable<(Of <(<'Guid>)>)>)
GH_DocumentIO Class See Also Send Feedback
Copy the specified objects in the internal document into the clipboard.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Copy(
    GH_ClipboardType clipboard,
    IEnumerable<Guid> guids
)
Visual Basic
Public Function Copy ( _
    clipboard As GH_ClipboardType, _
    guids As IEnumerable(Of Guid) _
) As Boolean

Parameters

clipboard
Type: Grasshopper.Kernel..::..GH_ClipboardType
Specifies the clipboard type to use.
guids
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Guid >)>)>
List of object ids to copy.

Return Value

True on success, false on failure.

See Also

GH_DocumentIO Class
Copy Overload
Grasshopper.Kernel Namespace


GetDocumentThumbnail Method

[image]

Grasshopper SDK
GH_DocumentIO..::..GetDocumentThumbnail Method
GH_DocumentIO Class See Also Send Feedback
Try and extract the preview image of a document. Not all gh/ghx files contain a thumbnail so this function may return null. The document itself is not loaded and rendered, so the thumbnail really has to be part of the file already.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Bitmap GetDocumentThumbnail(
    string filePath
)
Visual Basic
Public Shared Function GetDocumentThumbnail ( _
    filePath As String _
) As Bitmap

Parameters

filePath
Type: System..::..String
Filepath to examine.

Return Value

A preview bitmap on success or null on failure. Caller is responsible for disposing of the image.

See Also

GH_DocumentIO Class
Grasshopper.Kernel Namespace


Open Method

[image] [image]

Grasshopper SDK
GH_DocumentIO..::..Open Method
GH_DocumentIO Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Open()()()() | Perform a default Open operation and store the result as the internal document.
Public method | Open(String) | Open the file at the given location.

See Also

GH_DocumentIO Class
GH_DocumentIO Members
Grasshopper.Kernel Namespace


Open Method

[image]

Grasshopper SDK
GH_DocumentIO..::..Open Method
GH_DocumentIO Class See Also Send Feedback
Perform a default Open operation and store the result as the internal document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Open()
Visual Basic
Public Function Open As Boolean

Return Value

True on success, false on failure.

See Also

GH_DocumentIO Class
Open Overload
Grasshopper.Kernel Namespace


Open Method (String)

[image]

Grasshopper SDK
GH_DocumentIO..::..Open Method (String)
GH_DocumentIO Class See Also Send Feedback
Open the file at the given location.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Open(
    string filePath
)
Visual Basic
Public Function Open ( _
    filePath As String _
) As Boolean

Parameters

filePath
Type: System..::..String
Path of Grasshopper file to open.

Return Value

True on success, false on failure.

See Also

GH_DocumentIO Class
Open Overload
Grasshopper.Kernel Namespace


OpenDocumentDialog Method

[image]

Grasshopper SDK
GH_DocumentIO..::..OpenDocumentDialog Method
GH_DocumentIO Class See Also Send Feedback
Display the Open GH/GHX dialog.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string OpenDocumentDialog(
    string path,
    string title
)
Visual Basic
Public Function OpenDocumentDialog ( _
    path As String, _
    title As String _
) As String

Parameters

path
Type: System..::..String
Optional default path.
title
Type: System..::..String
Title of dialog.

Return Value

FileName specified via the Open dialog or null if the dialog was cancelled.

See Also

GH_DocumentIO Class
Grasshopper.Kernel Namespace


Paste Method

[image]

Grasshopper SDK
GH_DocumentIO..::..Paste Method
GH_DocumentIO Class See Also Send Feedback
Deserialize a Grasshopper document from the clipboard. On success, the internal document of this GH_DocumentIO instance will be set.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Paste(
    GH_ClipboardType clipboard
)
Visual Basic
Public Function Paste ( _
    clipboard As GH_ClipboardType _
) As Boolean

Parameters

clipboard
Type: Grasshopper.Kernel..::..GH_ClipboardType
Specifies the clipboard type to use.

Return Value

True on success, false on failure.

See Also

GH_DocumentIO Class
Grasshopper.Kernel Namespace


Save Method

[image]

Grasshopper SDK
GH_DocumentIO..::..Save Method
GH_DocumentIO Class See Also Send Feedback
Perform a default Save operation on the internal document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Save()
Visual Basic
Public Function Save As Boolean

Return Value

True on success, false on failure.

See Also

GH_DocumentIO Class
Grasshopper.Kernel Namespace


SaveAs Method

[image]

Grasshopper SDK
GH_DocumentIO..::..SaveAs Method
GH_DocumentIO Class See Also Send Feedback
Perform a default Save As operation on the internal document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool SaveAs()
Visual Basic
Public Function SaveAs As Boolean

Return Value

True on success, false on failure.

See Also

GH_DocumentIO Class
Grasshopper.Kernel Namespace


SaveAsCopyDocumentDialog Method

[image]

Grasshopper SDK
GH_DocumentIO..::..SaveAsCopyDocumentDialog Method
GH_DocumentIO Class See Also Send Feedback
Display the Save As Copy GH/GHX dialog.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string SaveAsCopyDocumentDialog(
    string path
)
Visual Basic
Public Function SaveAsCopyDocumentDialog ( _
    path As String _
) As String

Parameters

path
Type: System..::..String
Optional default path.

Return Value

FileName specified via the Save As Copy dialog or null if the dialog was cancelled.

See Also

GH_DocumentIO Class
Grasshopper.Kernel Namespace


SaveAsDocumentDialog Method

[image]

Grasshopper SDK
GH_DocumentIO..::..SaveAsDocumentDialog Method
GH_DocumentIO Class See Also Send Feedback
Display the Save As GH/GHX dialog.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string SaveAsDocumentDialog(
    string path
)
Visual Basic
Public Function SaveAsDocumentDialog ( _
    path As String _
) As String

Parameters

path
Type: System..::..String
Optional default path.

Return Value

FileName specified via the Save As dialog or null if the dialog was cancelled.

See Also

GH_DocumentIO Class
Grasshopper.Kernel Namespace


SaveBackup Method

[image]

Grasshopper SDK
GH_DocumentIO..::..SaveBackup Method
GH_DocumentIO Class See Also Send Feedback
Save a time-stamped copy of the current file.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool SaveBackup()
Visual Basic
Public Function SaveBackup As Boolean

Return Value

True on success, false on failure.

See Also

GH_DocumentIO Class
Grasshopper.Kernel Namespace


SaveDocumentDialog Method

[image]

Grasshopper SDK
GH_DocumentIO..::..SaveDocumentDialog Method
GH_DocumentIO Class See Also Send Feedback
Display the Save GH/GHX dialog.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string SaveDocumentDialog(
    string path,
    string title
)
Visual Basic
Public Function SaveDocumentDialog ( _
    path As String, _
    title As String _
) As String

Parameters

path
Type: System..::..String
Optional default path.
title
Type: System..::..String
Title of dialog.

Return Value

FileName specified via the Save dialog or null if the dialog was cancelled.

See Also

GH_DocumentIO Class
Grasshopper.Kernel Namespace


SubsidiaryDocumentSavePrompt Method

[image] [image]

Grasshopper SDK
GH_DocumentIO..::..SubsidiaryDocumentSavePrompt Method
GH_DocumentIO Class See Also Send Feedback

Overload List

Name | Description
SubsidiaryDocumentSavePrompt(GH_Document) | Display a 'stuff has changed do you want to save' message box with Yes/No/Cancel options.
SubsidiaryDocumentSavePrompt(String, Boolean, Int32) | Display a 'stuff has changed do you want to save' message box with Yes/No/Cancel options.

See Also

GH_DocumentIO Class
GH_DocumentIO Members
Grasshopper.Kernel Namespace


SubsidiaryDocumentSavePrompt Method (GH_Document)

[image]

Grasshopper SDK
GH_DocumentIO..::..SubsidiaryDocumentSavePrompt Method (GH_Document)
GH_DocumentIO Class See Also Send Feedback
Display a 'stuff has changed do you want to save' message box with Yes/No/Cancel options.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static DialogResult SubsidiaryDocumentSavePrompt(
    GH_Document document
)
Visual Basic
Public Shared Function SubsidiaryDocumentSavePrompt ( _
    document As GH_Document _
) As DialogResult

Parameters

document
Type: Grasshopper.Kernel..::..GH_Document
Top level document.

Return Value

Yes, No, Cancel or None state.

See Also

GH_DocumentIO Class
SubsidiaryDocumentSavePrompt Overload
Grasshopper.Kernel Namespace


SubsidiaryDocumentSavePrompt Method (String, Boolean, Int32)

[image]

Grasshopper SDK
GH_DocumentIO..::..SubsidiaryDocumentSavePrompt Method (String, Boolean, Int32)
GH_DocumentIO Class See Also Send Feedback
Display a 'stuff has changed do you want to save' message box with Yes/No/Cancel options.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static DialogResult SubsidiaryDocumentSavePrompt(
    string documentName,
    bool modified,
    int modifiedSubsidiaries
)
Visual Basic
Public Shared Function SubsidiaryDocumentSavePrompt ( _
    documentName As String, _
    modified As Boolean, _
    modifiedSubsidiaries As Integer _
) As DialogResult

Parameters

documentName
Type: System..::..String
Name of top level document.
modified
Type: System..::..Boolean
Boolean indicating whether top-level document is modified.
modifiedSubsidiaries
Type: System..::..Int32
Number of modified subsidiary documents.

Return Value

Yes, No, Cancel or None state.

See Also

GH_DocumentIO Class
SubsidiaryDocumentSavePrompt Overload
Grasshopper.Kernel Namespace


GH_DocumentIO Properties

[image] [image]

Grasshopper SDK
GH_DocumentIO Properties
GH_DocumentIO Class See Also Send Feedback

The GH_DocumentIO type exposes the following members.

Properties

 | Name | Description
Public property | Document | Gets or sets the internal document.
Public property | IsDocument | Gets a value indicating whether or not this instance of GH_DocumentIO contains an internal document.

See Also

GH_DocumentIO Class
Grasshopper.Kernel Namespace


Document Property

[image]

Grasshopper SDK
GH_DocumentIO..::..Document Property
GH_DocumentIO Class See Also Send Feedback
Gets or sets the internal document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Document Document { get; set; }
Visual Basic
Public Property Document As GH_Document
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DocumentIO.Document"]

See Also

GH_DocumentIO Class
Grasshopper.Kernel Namespace


IsDocument Property

[image]

Grasshopper SDK
GH_DocumentIO..::..IsDocument Property
GH_DocumentIO Class See Also Send Feedback
Gets a value indicating whether or not this instance of GH_DocumentIO contains an internal document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsDocument { get; }
Visual Basic
Public ReadOnly Property IsDocument As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DocumentIO.IsDocument"]

See Also

GH_DocumentIO Class
Grasshopper.Kernel Namespace


GH_DocumentObject Class

[image]

Grasshopper SDK
GH_DocumentObject Class
Members See Also Send Feedback
Standard implementation of IGH_DocumentObject.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract class GH_DocumentObject : GH_InstanceDescription,
    IGH_DocumentObject
Visual Basic
Public MustInherit Class GH_DocumentObject _
    Inherits GH_InstanceDescription _
    Implements IGH_DocumentObject

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_InstanceDescription
Grasshopper.Kernel..::..GH_DocumentObject
Grasshopper.Kernel..::..GH_ActiveObject

See Also

GH_DocumentObject Members
Grasshopper.Kernel Namespace


GH_DocumentObject Members

[image] [image]

Grasshopper SDK
GH_DocumentObject Members
GH_DocumentObject Class Constructors Methods Fields Properties Events See Also Send Feedback

The GH_DocumentObject type exposes the following members.

Constructors

 | Name | Description
Protected method | GH_DocumentObject(IGH_InstanceDescription) | Initializes a new instance of the GH_DocumentObject class
Protected method | GH_DocumentObject(String, String, String, String) | Initializes a new instance of the GH_DocumentObject class
Protected method | GH_DocumentObject(String, String, String, String, String) | Initializes a new instance of the GH_DocumentObject class

Methods

 | Name | Description
Public method | AddedToDocument | This method will be called when an object is added to a document. Override this method if you want to handle such events.
Public method | AppendMenuItems | This function is called when a context menu is about to be displayed. Override it to set custom items.
Public method | CopyFrom | Copy all fields (except the instance ID) from another instance description. (Inherited from GH_InstanceDescription.)
Public method | CreateAttributes | This function creates the stand-alone attributes for this object. If you wish to supply your own Attributes, you must override this function.
Protected method | DestroyIconCache | Call this method to erase the existing icon cache. You must call this if you want to change the display icon of an object.
Public method | DocumentContextChanged | This method will be called when the document that owns this object moves into a different context.
Public method | ExpirePreview | Call this function when you suspect that the preview has expired for this object. This will cause the display cache to be eradicated.
Public method | ExpireSolution | Call this function whenever you do something which expires the current solution. This will make sure all caches are erased, all downstream objects are expired and that the event is raised. The default implementation merely places a call to OnSolutionExpired(), override this function in derived classes to make sure you clear local data caches and expire downstream objects.
Protected method | GetValue(String, Boolean) | Get a boolean value from the component value table.
Protected method | GetValue(String, Double) | Get a double value from the component value table.
Protected method | GetValue(String, Color) | Get a color value from the component value table.
Protected method | GetValue(String, Int32) | Get an integer value from the component value table.
Protected method | GetValue(String, String) | Get a string value from the component value table.
Protected method | HtmlHelp_Source | Return a String which contains HTML formatted source for the help topic. If you want to pass a URL that points to a remote page, then prefix the URL with a GOTO: tag, like so: GOTO:http://www.YourWebAddressHere.com
Public method | IsolateObject | Destroy all connections to other objects.
 | Menu_AppendColourPicker | Add a colour picker to a menu.
 | Menu_AppendCustomItem(ToolStripDropDown, Control) | Utility function for inserting exotic controls into dropdown menus.
 | Menu_AppendCustomItem(ToolStripDropDown, Control, KeyDownEventHandler) | Utility function for inserting exotic controls into dropdown menus.
 | Menu_AppendCustomItem(ToolStripDropDown, Control, KeyDownEventHandler, Boolean, Int32, Boolean) | Utility function for inserting exotic controls into dropdown menus.
 | Menu_AppendDigitScrollerItem | Utility function for inserting a digit scroller into menus.
 | Menu_AppendGenericMenuItem | Obsolete. This method is obsolete.
 | Menu_AppendItem(ToolStrip, String) | Utility function for appending generic menu items.
 | Menu_AppendItem(ToolStrip, String, EventHandler) | Utility function for appending generic menu items.
 | Menu_AppendItem(ToolStrip, String, EventHandler, Boolean) | Utility function for appending generic menu items.
 | Menu_AppendItem(ToolStrip, String, EventHandler, Image) | Utility function for appending generic menu items.
 | Menu_AppendItem(ToolStrip, String, EventHandler, Boolean, Boolean) | Utility function for appending generic menu items.
 | Menu_AppendItem(ToolStrip, String, EventHandler, Image, Object) | Utility function for appending generic menu items.
 | Menu_AppendItem(ToolStrip, String, EventHandler, Image, Boolean, Boolean) | Utility function for appending generic menu items.
Protected method | Menu_AppendObjectHelp | Appends the default object Help menu item.
Protected method | Menu_AppendObjectName | Appends the old-fashioned object name menu item. If you also want the Display mode toggle then use Menu_AppendObjectNameEx()
Protected method | Menu_AppendObjectNameEx | Appends the default object name + display mode menu item.
 | Menu_AppendSeparator | Utility function for appending separators to a menu dropdown. If the dropdown is empty or if it already has a separator at the bottom, nothing will happen.
 | Menu_AppendTextItem(ToolStripDropDown, String, GH_MenuTextBox..::..KeyDownEventHandler, GH_MenuTextBox..::..TextChangedEventHandler, Boolean) | Utility function for inserting text boxes into menus.
 | Menu_AppendTextItem(ToolStripDropDown, String, GH_MenuTextBox..::..KeyDownEventHandler, GH_MenuTextBox..::..TextChangedEventHandler, Boolean, Int32, Boolean) | Utility function for inserting text boxes into menus.
 | Menu_MoveItem(ToolStripItem, array<String>[]()[][]) | Utility function for moving menu items.
 | Menu_MoveItem(ToolStripItem, Boolean, array<String>[]()[][]) | Utility function for moving menu items.
Public method | MovedBetweenDocuments | This method will be called when an object is moved from one document to another. Override this method if you want to handle such events.
Public method | NewInstanceGuid()()()() | Generate a new random instance GUID (Inherited from GH_InstanceDescription.)
Public method | NewInstanceGuid(Guid) | Set the instance ID to be a specific GUID. This is very dangerous, only use this function if you're 6"4' and your first name is David. (Inherited from GH_InstanceDescription.)
Public method | OnAttributesChanged | Raises the AttributesChanged event on the toplevel object.
Public method | OnDisplayExpired | Raises the DisplayExpired event on the toplevel object.
Public method | OnObjectChanged(String) |
Public method | OnObjectChanged(GH_ObjectChangedEventArgs) |
Public method | OnObjectChanged(GH_ObjectEventType) |
Public method | OnObjectChanged(String, Object) |
Public method | OnObjectChanged(GH_ObjectEventType, Object) |
Public method | OnPingDocument | Raise the PingDocument Event on the toplevel object and try to find the document which owns this object.
Public method | OnPreviewExpired | Raises the PreviewExpired event on the toplevel object.
Public method | OnSolutionExpired | Raises the SolutionExpired event on the toplevel object. You probably want to call ExpireSolution() instead of this method directly.
Public method | Read | (Overrides GH_InstanceDescription..::..Read(GH_IReader).)
Public method | ReadFull | GH_InstanceDescription does not by default serialize all fields. Use this function to read all fields from the archive. This method is compatible with the default Write()/Read() operations. (Inherited from GH_InstanceDescription.)
Public method | RecordUndoEvent(String) | Record a generic object change undo event.
Public method | RecordUndoEvent(GH_UndoRecord) | Record an entire undo record.
Public method | RecordUndoEvent(String, IGH_UndoAction) | Record a specific object change undo event.
Public method | RemovedFromDocument | This method will be called when an object is removed from a document. Override this method if you want to handle such events.
Public method | SetIconOverride | Set a new custom icon override for this object.
Protected method | SetValue(String, Boolean) | Set a named value. This value will be serialized with the component.
Protected method | SetValue(String, Double) | Set a named value. This value will be serialized with the component.
Protected method | SetValue(String, Color) | Set a named value. This value will be serialized with the component.
Protected method | SetValue(String, Int32) | Set a named value. This value will be serialized with the component.
Protected method | SetValue(String, String) | Set a named value. This value will be serialized with the component.
Public method | TriggerAutoSave()()()() | Triggers the AutoSave function on the owner document with the object_changed flag.
Public method | TriggerAutoSave(Guid) | Triggers the AutoSave function on the owner document with the object_changed flag.
Public method | TriggerAutoSave(GH_AutoSaveTrigger) | Triggers the AutoSave function on the owner document with a custom flag.
Public method | TriggerAutoSave(GH_AutoSaveTrigger, Guid) | Triggers the AutoSave function on the owner document with a custom flag.
Protected method | ValuesChanged | Override this method if you want to respond to changes to the value table. The base implementation is empty, so you don't have to call it.
Public method | Write | (Overrides GH_InstanceDescription..::..Write(GH_IWriter).)
Public method | WriteFull | GH_InstanceDescription does not by default serialize all fields. Use this function to write all fields to the archive. This method is compatible with the default Write()/Read() operations. (Inherited from GH_InstanceDescription.)

Fields

 | Name | Description
Protected field | m_attributes |

Properties

 | Name | Description
Public property | Attributes | Gets or sets the attributes that are associated with this object. Only set custom attributes if you know what you are doing.
Public property | Category | Gets or sets the Category in which this object belongs. If HasCategory() returns false, this field has no meaning. (Inherited from GH_InstanceDescription.)
Public property | ComponentGuid | Returns a consistent ID for this object type. Every object must supply a unique and unchanging ID that is used to identify objects of the same type.
Public property | Description | Gets or sets the description of the object. This field typically remains fixed during the lifetime of an object. (Inherited from GH_InstanceDescription.)
Public property | Exposure | Gets the exposure of this object in the Graphical User Interface. The default is to expose everywhere.
Public property | HasCategory | Gets whether or not the Category field has been set. (Inherited from GH_InstanceDescription.)
Public property | HasSubCategory | Gets whether or not the SubCategory field has been set. (Inherited from GH_InstanceDescription.)
Protected property | Icon | Override this function to supply a custom icon (24x24 pixels). The result of this property is cached, so don't worry if icon retrieval is not very fast.
Public property | Icon_24x24 | The icon associated with this object.
Public property | Icon_24x24_Locked | The greyscale icon of this object.
Public property | IconDisplayMode | Gets the current display mode of the object.
Public property | InstanceDescription | Gets a description of the current state of the object. This field is usually the same as the Description() field, but it might be variable when overridden. (Inherited from GH_InstanceDescription.)
Public property | InstanceGuid | Gets the ID of this runtime instance. (Inherited from GH_InstanceDescription.)
Public property | Keywords | Gets a list of additional keywords that describe the object. Typically this list is empty but you can override this property to aid in object searches. (Inherited from GH_InstanceDescription.)
Public property | Name | Gets or sets the name of the object. This field typically remains fixed during the lifetime of an object. (Inherited from GH_InstanceDescription.)
Public property | NickName | Gets or sets the nickname of the object. This field can be changed by the user. (Inherited from GH_InstanceDescription.)
Public property | Obsolete | Gets whether this object is obsolete. Default implementation returns true if the class name contains the string "OBSOLETE" or if this class has been decorated with the ObsoleteAttribute. You are free to override this if you want, but I suggest adding the ObsoleteAttribute instead.
Public property | SubCategory | Gets or sets the SubCategory in which this object belongs. If HasSubCategory() returns false, this field has no meaning. (Inherited from GH_InstanceDescription.)

Events

 | Name | Description
Public event | AttributesChanged | Raised whenever the number or kind of attributes changes. This event is handled by GH_Documents who subsequently wipe their attribute caches.
Public event | DisplayExpired | Raised whenever the display (on the Canvas) of a certain object becomes invalid.
Public event | ObjectChanged |
Public event | PingDocument | Raised whenever an object needs to know which GH_Document it belongs to.
Public event | PreviewExpired | Raised whenever the display (in the Rhino viewports) of a certain object becomes invalid.
Public event | SolutionExpired | Raised whenever the solution of a certain object becomes invalid.

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


GH_DocumentObject Constructor

[image] [image]

Grasshopper SDK
GH_DocumentObject Constructor
GH_DocumentObject Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GH_DocumentObject(IGH_InstanceDescription) | Initializes a new instance of the GH_DocumentObject class
Protected method | GH_DocumentObject(String, String, String, String) | Initializes a new instance of the GH_DocumentObject class
Protected method | GH_DocumentObject(String, String, String, String, String) | Initializes a new instance of the GH_DocumentObject class

See Also

GH_DocumentObject Class
GH_DocumentObject Members
Grasshopper.Kernel Namespace


GH_DocumentObject Constructor (IGH_InstanceDescription)

[image]

Grasshopper SDK
GH_DocumentObject Constructor (IGH_InstanceDescription)
GH_DocumentObject Class See Also Send Feedback
Initializes a new instance of the GH_DocumentObject class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_DocumentObject(
    IGH_InstanceDescription tag
)
Visual Basic
Protected Sub New ( _
    tag As IGH_InstanceDescription _
)

Parameters

tag
Type: Grasshopper.Kernel..::..IGH_InstanceDescription

See Also

GH_DocumentObject Class
GH_DocumentObject Overload
Grasshopper.Kernel Namespace


GH_DocumentObject Constructor (String, String, String, String)

[image]

Grasshopper SDK
GH_DocumentObject Constructor (String, String, String, String)
GH_DocumentObject Class See Also Send Feedback
Initializes a new instance of the GH_DocumentObject class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_DocumentObject(
    string name,
    string nickname,
    string description,
    string category
)
Visual Basic
Protected Sub New ( _
    name As String, _
    nickname As String, _
    description As String, _
    category As String _
)

Parameters

name
Type: System..::..String
nickname
Type: System..::..String
description
Type: System..::..String
category
Type: System..::..String

See Also

GH_DocumentObject Class
GH_DocumentObject Overload
Grasshopper.Kernel Namespace


GH_DocumentObject Constructor (String, String, String, String, String)

[image]

Grasshopper SDK
GH_DocumentObject Constructor (String, String, String, String, String)
GH_DocumentObject Class See Also Send Feedback
Initializes a new instance of the GH_DocumentObject class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_DocumentObject(
    string name,
    string nickName,
    string description,
    string category,
    string subCategory
)
Visual Basic
Protected Sub New ( _
    name As String, _
    nickName As String, _
    description As String, _
    category As String, _
    subCategory As String _
)

Parameters

name
Type: System..::..String
nickName
Type: System..::..String
description
Type: System..::..String
category
Type: System..::..String
subCategory
Type: System..::..String

See Also

GH_DocumentObject Class
GH_DocumentObject Overload
Grasshopper.Kernel Namespace


GH_DocumentObject Fields

[image] [image]

Grasshopper SDK
GH_DocumentObject Fields
GH_DocumentObject Class See Also Send Feedback

The GH_DocumentObject type exposes the following members.

Fields

 | Name | Description
Protected field | m_attributes |

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


m_attributes Field

[image]

Grasshopper SDK
GH_DocumentObject..::..m_attributes Field
GH_DocumentObject Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected IGH_Attributes m_attributes
Visual Basic
Protected m_attributes As IGH_Attributes

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


GH_DocumentObject Methods

[image] [image]

Grasshopper SDK
GH_DocumentObject Methods
GH_DocumentObject Class See Also Send Feedback

The GH_DocumentObject type exposes the following members.

Methods

 | Name | Description
Public method | AddedToDocument | This method will be called when an object is added to a document. Override this method if you want to handle such events.
Public method | AppendMenuItems | This function is called when a context menu is about to be displayed. Override it to set custom items.
Public method | CopyFrom | Copy all fields (except the instance ID) from another instance description. (Inherited from GH_InstanceDescription.)
Public method | CreateAttributes | This function creates the stand-alone attributes for this object. If you wish to supply your own Attributes, you must override this function.
Protected method | DestroyIconCache | Call this method to erase the existing icon cache. You must call this if you want to change the display icon of an object.
Public method | DocumentContextChanged | This method will be called when the document that owns this object moves into a different context.
Public method | ExpirePreview | Call this function when you suspect that the preview has expired for this object. This will cause the display cache to be eradicated.
Public method | ExpireSolution | Call this function whenever you do something which expires the current solution. This will make sure all caches are erased, all downstream objects are expired and that the event is raised. The default implementation merely places a call to OnSolutionExpired(), override this function in derived classes to make sure you clear local data caches and expire downstream objects.
Protected method | GetValue(String, Boolean) | Get a boolean value from the component value table.
Protected method | GetValue(String, Double) | Get a double value from the component value table.
Protected method | GetValue(String, Color) | Get a color value from the component value table.
Protected method | GetValue(String, Int32) | Get an integer value from the component value table.
Protected method | GetValue(String, String) | Get a string value from the component value table.
Protected method | HtmlHelp_Source | Return a String which contains HTML formatted source for the help topic. If you want to pass a URL that points to a remote page, then prefix the URL with a GOTO: tag, like so: GOTO:http://www.YourWebAddressHere.com
Public method | IsolateObject | Destroy all connections to other objects.
 | Menu_AppendColourPicker | Add a colour picker to a menu.
 | Menu_AppendCustomItem(ToolStripDropDown, Control) | Utility function for inserting exotic controls into dropdown menus.
 | Menu_AppendCustomItem(ToolStripDropDown, Control, KeyDownEventHandler) | Utility function for inserting exotic controls into dropdown menus.
 | Menu_AppendCustomItem(ToolStripDropDown, Control, KeyDownEventHandler, Boolean, Int32, Boolean) | Utility function for inserting exotic controls into dropdown menus.
 | Menu_AppendDigitScrollerItem | Utility function for inserting a digit scroller into menus.
 | Menu_AppendGenericMenuItem | Obsolete. This method is obsolete.
 | Menu_AppendItem(ToolStrip, String) | Utility function for appending generic menu items.
 | Menu_AppendItem(ToolStrip, String, EventHandler) | Utility function for appending generic menu items.
 | Menu_AppendItem(ToolStrip, String, EventHandler, Boolean) | Utility function for appending generic menu items.
 | Menu_AppendItem(ToolStrip, String, EventHandler, Image) | Utility function for appending generic menu items.
 | Menu_AppendItem(ToolStrip, String, EventHandler, Boolean, Boolean) | Utility function for appending generic menu items.
 | Menu_AppendItem(ToolStrip, String, EventHandler, Image, Object) | Utility function for appending generic menu items.
 | Menu_AppendItem(ToolStrip, String, EventHandler, Image, Boolean, Boolean) | Utility function for appending generic menu items.
Protected method | Menu_AppendObjectHelp | Appends the default object Help menu item.
Protected method | Menu_AppendObjectName | Appends the old-fashioned object name menu item. If you also want the Display mode toggle then use Menu_AppendObjectNameEx()
Protected method | Menu_AppendObjectNameEx | Appends the default object name + display mode menu item.
 | Menu_AppendSeparator | Utility function for appending separators to a menu dropdown. If the dropdown is empty or if it already has a separator at the bottom, nothing will happen.
 | Menu_AppendTextItem(ToolStripDropDown, String, GH_MenuTextBox..::..KeyDownEventHandler, GH_MenuTextBox..::..TextChangedEventHandler, Boolean) | Utility function for inserting text boxes into menus.
 | Menu_AppendTextItem(ToolStripDropDown, String, GH_MenuTextBox..::..KeyDownEventHandler, GH_MenuTextBox..::..TextChangedEventHandler, Boolean, Int32, Boolean) | Utility function for inserting text boxes into menus.
 | Menu_MoveItem(ToolStripItem, array<String>[]()[][]) | Utility function for moving menu items.
 | Menu_MoveItem(ToolStripItem, Boolean, array<String>[]()[][]) | Utility function for moving menu items.
Public method | MovedBetweenDocuments | This method will be called when an object is moved from one document to another. Override this method if you want to handle such events.
Public method | NewInstanceGuid()()()() | Generate a new random instance GUID (Inherited from GH_InstanceDescription.)
Public method | NewInstanceGuid(Guid) | Set the instance ID to be a specific GUID. This is very dangerous, only use this function if you're 6"4' and your first name is David. (Inherited from GH_InstanceDescription.)
Public method | OnAttributesChanged | Raises the AttributesChanged event on the toplevel object.
Public method | OnDisplayExpired | Raises the DisplayExpired event on the toplevel object.
Public method | OnObjectChanged(String) |
Public method | OnObjectChanged(GH_ObjectChangedEventArgs) |
Public method | OnObjectChanged(GH_ObjectEventType) |
Public method | OnObjectChanged(String, Object) |
Public method | OnObjectChanged(GH_ObjectEventType, Object) |
Public method | OnPingDocument | Raise the PingDocument Event on the toplevel object and try to find the document which owns this object.
Public method | OnPreviewExpired | Raises the PreviewExpired event on the toplevel object.
Public method | OnSolutionExpired | Raises the SolutionExpired event on the toplevel object. You probably want to call ExpireSolution() instead of this method directly.
Public method | Read | (Overrides GH_InstanceDescription..::..Read(GH_IReader).)
Public method | ReadFull | GH_InstanceDescription does not by default serialize all fields. Use this function to read all fields from the archive. This method is compatible with the default Write()/Read() operations. (Inherited from GH_InstanceDescription.)
Public method | RecordUndoEvent(String) | Record a generic object change undo event.
Public method | RecordUndoEvent(GH_UndoRecord) | Record an entire undo record.
Public method | RecordUndoEvent(String, IGH_UndoAction) | Record a specific object change undo event.
Public method | RemovedFromDocument | This method will be called when an object is removed from a document. Override this method if you want to handle such events.
Public method | SetIconOverride | Set a new custom icon override for this object.
Protected method | SetValue(String, Boolean) | Set a named value. This value will be serialized with the component.
Protected method | SetValue(String, Double) | Set a named value. This value will be serialized with the component.
Protected method | SetValue(String, Color) | Set a named value. This value will be serialized with the component.
Protected method | SetValue(String, Int32) | Set a named value. This value will be serialized with the component.
Protected method | SetValue(String, String) | Set a named value. This value will be serialized with the component.
Public method | TriggerAutoSave()()()() | Triggers the AutoSave function on the owner document with the object_changed flag.
Public method | TriggerAutoSave(Guid) | Triggers the AutoSave function on the owner document with the object_changed flag.
Public method | TriggerAutoSave(GH_AutoSaveTrigger) | Triggers the AutoSave function on the owner document with a custom flag.
Public method | TriggerAutoSave(GH_AutoSaveTrigger, Guid) | Triggers the AutoSave function on the owner document with a custom flag.
Protected method | ValuesChanged | Override this method if you want to respond to changes to the value table. The base implementation is empty, so you don't have to call it.
Public method | Write | (Overrides GH_InstanceDescription..::..Write(GH_IWriter).)
Public method | WriteFull | GH_InstanceDescription does not by default serialize all fields. Use this function to write all fields to the archive. This method is compatible with the default Write()/Read() operations. (Inherited from GH_InstanceDescription.)

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


AddedToDocument Method

[image]

Grasshopper SDK
GH_DocumentObject..::..AddedToDocument Method
GH_DocumentObject Class See Also Send Feedback
This method will be called when an object is added to a document. Override this method if you want to handle such events.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual void AddedToDocument(
    GH_Document document
)
Visual Basic
Public Overridable Sub AddedToDocument ( _
    document As GH_Document _
)

Parameters

document
Type: Grasshopper.Kernel..::..GH_Document
Document that now owns this object.

Implements

IGH_DocumentObject..::..AddedToDocument(GH_Document)

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


AppendMenuItems Method

[image]

Grasshopper SDK
GH_DocumentObject..::..AppendMenuItems Method
GH_DocumentObject Class See Also Send Feedback
This function is called when a context menu is about to be displayed. Override it to set custom items.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool AppendMenuItems(
    ToolStripDropDown menu
)
Visual Basic
Public Overridable Function AppendMenuItems ( _
    menu As ToolStripDropDown _
) As Boolean

Parameters

menu
Type: System.Windows.Forms..::..ToolStripDropDown
Menu object to populate.

Return Value

If true, the menu will be displayed, if false the menu will be supressed.

Implements

IGH_DocumentObject..::..AppendMenuItems(ToolStripDropDown)

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


CreateAttributes Method

[image]

Grasshopper SDK
GH_DocumentObject..::..CreateAttributes Method
GH_DocumentObject Class See Also Send Feedback
This function creates the stand-alone attributes for this object. If you wish to supply your own Attributes, you must override this function.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract void CreateAttributes()
Visual Basic
Public MustOverride Sub CreateAttributes

Implements

IGH_DocumentObject..::..CreateAttributes()()()()

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


DestroyIconCache Method

[image]

Grasshopper SDK
GH_DocumentObject..::..DestroyIconCache Method
GH_DocumentObject Class See Also Send Feedback
Call this method to erase the existing icon cache. You must call this if you want to change the display icon of an object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected void DestroyIconCache()
Visual Basic
Protected Sub DestroyIconCache

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


DocumentContextChanged Method

[image]

Grasshopper SDK
GH_DocumentObject..::..DocumentContextChanged Method
GH_DocumentObject Class See Also Send Feedback
This method will be called when the document that owns this object moves into a different context.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual void DocumentContextChanged(
    GH_Document document,
    GH_DocumentContext context
)
Visual Basic
Public Overridable Sub DocumentContextChanged ( _
    document As GH_Document, _
    context As GH_DocumentContext _
)

Parameters

document
Type: Grasshopper.Kernel..::..GH_Document
Document that owns this object.
context
Type: Grasshopper.Kernel..::..GH_DocumentContext
The reason for this event.

Implements

IGH_DocumentObject..::..DocumentContextChanged(GH_Document, GH_DocumentContext)

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


ExpirePreview Method

[image]

Grasshopper SDK
GH_DocumentObject..::..ExpirePreview Method
GH_DocumentObject Class See Also Send Feedback
Call this function when you suspect that the preview has expired for this object. This will cause the display cache to be eradicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual void ExpirePreview(
    bool redraw
)
Visual Basic
Public Overridable Sub ExpirePreview ( _
    redraw As Boolean _
)

Parameters

redraw
Type: System..::..Boolean

Implements

IGH_DocumentObject..::..ExpirePreview(Boolean)

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


ExpireSolution Method

[image]

Grasshopper SDK
GH_DocumentObject..::..ExpireSolution Method
GH_DocumentObject Class See Also Send Feedback
Call this function whenever you do something which expires the current solution. This will make sure all caches are erased, all downstream objects are expired and that the event is raised. The default implementation merely places a call to OnSolutionExpired(), override this function in derived classes to make sure you clear local data caches and expire downstream objects.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual void ExpireSolution(
    bool recompute
)
Visual Basic
Public Overridable Sub ExpireSolution ( _
    recompute As Boolean _
)

Parameters

recompute
Type: System..::..Boolean
If True, the solution will be recomputed straight away.

Implements

IGH_DocumentObject..::..ExpireSolution(Boolean)

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


GetValue Method

[image] [image]

Grasshopper SDK
GH_DocumentObject..::..GetValue Method
GH_DocumentObject Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetValue(String, Boolean) | Get a boolean value from the component value table.
Protected method | GetValue(String, Double) | Get a double value from the component value table.
Protected method | GetValue(String, Color) | Get a color value from the component value table.
Protected method | GetValue(String, Int32) | Get an integer value from the component value table.
Protected method | GetValue(String, String) | Get a string value from the component value table.

See Also

GH_DocumentObject Class
GH_DocumentObject Members
Grasshopper.Kernel Namespace


GetValue Method (String, Boolean)

[image]

Grasshopper SDK
GH_DocumentObject..::..GetValue Method (String, Boolean)
GH_DocumentObject Class See Also Send Feedback
Get a boolean value from the component value table.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected bool GetValue(
    string name,
    bool default
)
Visual Basic
Protected Function GetValue ( _
    name As String, _
    default As Boolean _
) As Boolean

Parameters

name
Type: System..::..String
Name of boolean to retrieve.
default
Type: System..::..Boolean
Default value to return in case of missing named value.

Return Value

The boolean value with the given name of the default value.

See Also

GH_DocumentObject Class
GetValue Overload
Grasshopper.Kernel Namespace


GetValue Method (String, Double)

[image]

Grasshopper SDK
GH_DocumentObject..::..GetValue Method (String, Double)
GH_DocumentObject Class See Also Send Feedback
Get a double value from the component value table.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected double GetValue(
    string name,
    double default
)
Visual Basic
Protected Function GetValue ( _
    name As String, _
    default As Double _
) As Double

Parameters

name
Type: System..::..String
Name of double to retrieve.
default
Type: System..::..Double
Default value to return in case of missing named value.

Return Value

The double value with the given name of the default value.

See Also

GH_DocumentObject Class
GetValue Overload
Grasshopper.Kernel Namespace


GetValue Method (String, Color)

[image]

Grasshopper SDK
GH_DocumentObject..::..GetValue Method (String, Color)
GH_DocumentObject Class See Also Send Feedback
Get a color value from the component value table.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected Color GetValue(
    string name,
    Color default
)
Visual Basic
Protected Function GetValue ( _
    name As String, _
    default As Color _
) As Color

Parameters

name
Type: System..::..String
Name of color to retrieve.
default
Type: System.Drawing..::..Color
Default value to return in case of missing named value.

Return Value

The color value with the given name of the default value.

See Also

GH_DocumentObject Class
GetValue Overload
Grasshopper.Kernel Namespace


GetValue Method (String, Int32)

[image]

Grasshopper SDK
GH_DocumentObject..::..GetValue Method (String, Int32)
GH_DocumentObject Class See Also Send Feedback
Get an integer value from the component value table.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected int GetValue(
    string name,
    int default
)
Visual Basic
Protected Function GetValue ( _
    name As String, _
    default As Integer _
) As Integer

Parameters

name
Type: System..::..String
Name of integer to retrieve.
default
Type: System..::..Int32
Default value to return in case of missing named value.

Return Value

The integer value with the given name of the default value.

See Also

GH_DocumentObject Class
GetValue Overload
Grasshopper.Kernel Namespace


GetValue Method (String, String)

[image]

Grasshopper SDK
GH_DocumentObject..::..GetValue Method (String, String)
GH_DocumentObject Class See Also Send Feedback
Get a string value from the component value table.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected string GetValue(
    string name,
    string default
)
Visual Basic
Protected Function GetValue ( _
    name As String, _
    default As String _
) As String

Parameters

name
Type: System..::..String
Name of string to retrieve.
default
Type: System..::..String
Default value to return in case of missing named value.

Return Value

The string value with the given name of the default value.

See Also

GH_DocumentObject Class
GetValue Overload
Grasshopper.Kernel Namespace


HtmlHelp_Source Method

[image]

Grasshopper SDK
GH_DocumentObject..::..HtmlHelp_Source Method
GH_DocumentObject Class See Also Send Feedback
Return a String which contains HTML formatted source for the help topic. If you want to pass a URL that points to a remote page, then prefix the URL with a GOTO: tag, like so: GOTO:http://www.YourWebAddressHere.com

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected internal virtual string HtmlHelp_Source()
Visual Basic
Protected Friend Overridable Function HtmlHelp_Source As String

Remarks

You can use the GUI.GH_HtmlFormatter class to generate an HTML page which conforms to Grasshopper Help standards

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


IsolateObject Method

[image]

Grasshopper SDK
GH_DocumentObject..::..IsolateObject Method
GH_DocumentObject Class See Also Send Feedback
Destroy all connections to other objects.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual void IsolateObject()
Visual Basic
Public Overridable Sub IsolateObject

Implements

IGH_DocumentObject..::..IsolateObject()()()()

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


Menu_AppendColourPicker Method

[image]

Grasshopper SDK
GH_DocumentObject..::..Menu_AppendColourPicker Method
GH_DocumentObject Class See Also Send Feedback
Add a colour picker to a menu.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_ColourPicker Menu_AppendColourPicker(
    ToolStripDropDown menu,
    Color colour,
    GH_DocumentObject..::..ColourEventHandler colourChanged
)
Visual Basic
Public Shared Function Menu_AppendColourPicker ( _
    menu As ToolStripDropDown, _
    colour As Color, _
    colourChanged As GH_DocumentObject..::..ColourEventHandler _
) As GH_ColourPicker

Parameters

menu
Type: System.Windows.Forms..::..ToolStripDropDown
Menu to add to.
colour
Type: System.Drawing..::..Color
Default colour.
colourChanged
Type: Grasshopper.Kernel..::..GH_DocumentObject..::..ColourEventHandler
Handler for Colour picker changed events.

Return Value

Menu item representing the colour picker.

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


Menu_AppendCustomItem Method

[image] [image]

Grasshopper SDK
GH_DocumentObject..::..Menu_AppendCustomItem Method
GH_DocumentObject Class See Also Send Feedback

Overload List

Name | Description
Menu_AppendCustomItem(ToolStripDropDown, Control) | Utility function for inserting exotic controls into dropdown menus.
Menu_AppendCustomItem(ToolStripDropDown, Control, KeyDownEventHandler) | Utility function for inserting exotic controls into dropdown menus.
Menu_AppendCustomItem(ToolStripDropDown, Control, KeyDownEventHandler, Boolean, Int32, Boolean) | Utility function for inserting exotic controls into dropdown menus.

See Also

GH_DocumentObject Class
GH_DocumentObject Members
Grasshopper.Kernel Namespace


Menu_AppendCustomItem Method (ToolStripDropDown, Control)

[image]

Grasshopper SDK
GH_DocumentObject..::..Menu_AppendCustomItem Method (ToolStripDropDown, Control)
GH_DocumentObject Class See Also Send Feedback
Utility function for inserting exotic controls into dropdown menus.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool Menu_AppendCustomItem(
    ToolStripDropDown menu,
    Control control
)
Visual Basic
Public Shared Function Menu_AppendCustomItem ( _
    menu As ToolStripDropDown, _
    control As Control _
) As Boolean

Parameters

menu
Type: System.Windows.Forms..::..ToolStripDropDown
Dropdown to add a control to.
control
Type: System.Windows.Forms..::..Control
Control to insert.

See Also

GH_DocumentObject Class
Menu_AppendCustomItem Overload
Grasshopper.Kernel Namespace


Menu_AppendCustomItem Method (ToolStripDropDown, Control, .)

[image]

Grasshopper SDK
GH_DocumentObject..::..Menu_AppendCustomItem Method (ToolStripDropDown, Control, ..::..)
GH_DocumentObject Class See Also Send Feedback
Utility function for inserting exotic controls into dropdown menus.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool Menu_AppendCustomItem(
    ToolStripDropDown menu,
    Control control,
    KeyDownEventHandler keydown
)
Visual Basic
Public Shared Function Menu_AppendCustomItem ( _
    menu As ToolStripDropDown, _
    control As Control, _
    keydown As KeyDownEventHandler _
) As Boolean

Parameters

menu
Type: System.Windows.Forms..::..ToolStripDropDown
Dropdown to add a control to.
control
Type: System.Windows.Forms..::..Control
Control to insert.
keydown
Type: KeyDownEventHandler
Delegate for key-presses.

See Also

GH_DocumentObject Class
Menu_AppendCustomItem Overload
Grasshopper.Kernel Namespace


Menu_AppendCustomItem Method (ToolStripDropDown, Control, ., Boolean, Int32, Boolean)

[image]

Grasshopper SDK
GH_DocumentObject..::..Menu_AppendCustomItem Method (ToolStripDropDown, Control, ..::.., Boolean, Int32, Boolean)
GH_DocumentObject Class See Also Send Feedback
Utility function for inserting exotic controls into dropdown menus.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool Menu_AppendCustomItem(
    ToolStripDropDown menu,
    Control control,
    KeyDownEventHandler keydown,
    bool enabled,
    int width,
    bool lockOnFocus
)
Visual Basic
Public Shared Function Menu_AppendCustomItem ( _
    menu As ToolStripDropDown, _
    control As Control, _
    keydown As KeyDownEventHandler, _
    enabled As Boolean, _
    width As Integer, _
    lockOnFocus As Boolean _
) As Boolean

Parameters

menu
Type: System.Windows.Forms..::..ToolStripDropDown
Dropdown to add a control to.
control
Type: System.Windows.Forms..::..Control
Control to insert.
keydown
Type: KeyDownEventHandler
Delegate for key-presses.
enabled
Type: System..::..Boolean
If true, the control will be enabled.
width
Type: System..::..Int32
Width hint for the control.
lockOnFocus
Type: System..::..Boolean
If true and the control gets focus, the rest of the menu will be locked.

See Also

GH_DocumentObject Class
Menu_AppendCustomItem Overload
Grasshopper.Kernel Namespace


Menu_AppendDigitScrollerItem Method

[image]

Grasshopper SDK
GH_DocumentObject..::..Menu_AppendDigitScrollerItem Method
GH_DocumentObject Class See Also Send Feedback
Utility function for inserting a digit scroller into menus.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_DigitScrollerBase Menu_AppendDigitScrollerItem(
    ToolStripDropDown menu,
    decimal min,
    decimal max,
    decimal value,
    int decimals
)
Visual Basic
Public Shared Function Menu_AppendDigitScrollerItem ( _
    menu As ToolStripDropDown, _
    min As Decimal, _
    max As Decimal, _
    value As Decimal, _
    decimals As Integer _
) As GH_DigitScrollerBase

Parameters

menu
Type: System.Windows.Forms..::..ToolStripDropDown
min
Type: System..::..Decimal
max
Type: System..::..Decimal
value
Type: System..::..Decimal
decimals
Type: System..::..Int32

Return Value

The digit scroller object that was inserted into the menu.

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


Menu_AppendGenericMenuItem Method

[image]

Grasshopper SDK
GH_DocumentObject..::..Menu_AppendGenericMenuItem Method
GH_DocumentObject Class See Also Send Feedback
This method is obsolete.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
[ObsoleteAttribute("This method is obsolete")]
public static ToolStripMenuItem Menu_AppendGenericMenuItem(
    ToolStrip menu,
    string text,
    EventHandler on_click,
    Image image,
    Object tag,
    bool enabled,
    bool checked
)
Visual Basic
<ObsoleteAttribute("This method is obsolete")> _
Public Shared Function Menu_AppendGenericMenuItem ( _
    menu As ToolStrip, _
    text As String, _
    on_click As EventHandler, _
    image As Image, _
    tag As Object, _
    enabled As Boolean, _
    checked As Boolean _
) As ToolStripMenuItem

Parameters

menu
Type: System.Windows.Forms..::..ToolStrip
text
Type: System..::..String
on_click
Type: System..::..EventHandler
image
Type: System.Drawing..::..Image
tag
Type: System..::..Object
enabled
Type: System..::..Boolean
checked
Type: System..::..Boolean

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


Menu_AppendItem Method

[image] [image]

Grasshopper SDK
GH_DocumentObject..::..Menu_AppendItem Method
GH_DocumentObject Class See Also Send Feedback

Overload List

Name | Description
Menu_AppendItem(ToolStrip, String) | Utility function for appending generic menu items.
Menu_AppendItem(ToolStrip, String, EventHandler) | Utility function for appending generic menu items.
Menu_AppendItem(ToolStrip, String, EventHandler, Boolean) | Utility function for appending generic menu items.
Menu_AppendItem(ToolStrip, String, EventHandler, Image) | Utility function for appending generic menu items.
Menu_AppendItem(ToolStrip, String, EventHandler, Boolean, Boolean) | Utility function for appending generic menu items.
Menu_AppendItem(ToolStrip, String, EventHandler, Image, Object) | Utility function for appending generic menu items.
Menu_AppendItem(ToolStrip, String, EventHandler, Image, Boolean, Boolean) | Utility function for appending generic menu items.

See Also

GH_DocumentObject Class
GH_DocumentObject Members
Grasshopper.Kernel Namespace


Menu_AppendItem Method (ToolStrip, String)

[image]

Grasshopper SDK
GH_DocumentObject..::..Menu_AppendItem Method (ToolStrip, String)
GH_DocumentObject Class See Also Send Feedback
Utility function for appending generic menu items.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static ToolStripMenuItem Menu_AppendItem(
    ToolStrip menu,
    string text
)
Visual Basic
Public Shared Function Menu_AppendItem ( _
    menu As ToolStrip, _
    text As String _
) As ToolStripMenuItem

Parameters

menu
Type: System.Windows.Forms..::..ToolStrip
Menu to append item to.
text
Type: System..::..String
Item text.

Return Value

The appended item

See Also

GH_DocumentObject Class
Menu_AppendItem Overload
Grasshopper.Kernel Namespace


Menu_AppendItem Method (ToolStrip, String, EventHandler)

[image]

Grasshopper SDK
GH_DocumentObject..::..Menu_AppendItem Method (ToolStrip, String, EventHandler)
GH_DocumentObject Class See Also Send Feedback
Utility function for appending generic menu items.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static ToolStripMenuItem Menu_AppendItem(
    ToolStrip menu,
    string text,
    EventHandler click
)
Visual Basic
Public Shared Function Menu_AppendItem ( _
    menu As ToolStrip, _
    text As String, _
    click As EventHandler _
) As ToolStripMenuItem

Parameters

menu
Type: System.Windows.Forms..::..ToolStrip
Menu to append item to.
text
Type: System..::..String
Item text.
click
Type: System..::..EventHandler
Delegate that handles click events. If nothing, the click event will not be handled.

Return Value

The appended item

See Also

GH_DocumentObject Class
Menu_AppendItem Overload
Grasshopper.Kernel Namespace


Menu_AppendItem Method (ToolStrip, String, EventHandler, Boolean)

[image]

Grasshopper SDK
GH_DocumentObject..::..Menu_AppendItem Method (ToolStrip, String, EventHandler, Boolean)
GH_DocumentObject Class See Also Send Feedback
Utility function for appending generic menu items.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static ToolStripMenuItem Menu_AppendItem(
    ToolStrip menu,
    string text,
    EventHandler click,
    bool enabled
)
Visual Basic
Public Shared Function Menu_AppendItem ( _
    menu As ToolStrip, _
    text As String, _
    click As EventHandler, _
    enabled As Boolean _
) As ToolStripMenuItem

Parameters

menu
Type: System.Windows.Forms..::..ToolStrip
Menu to append item to.
text
Type: System..::..String
Item text.
click
Type: System..::..EventHandler
Delegate that handles click events. If nothing, the click event will not be handled.
enabled
Type: System..::..Boolean
If true, the item will be enabled.

Return Value

The appended item

See Also

GH_DocumentObject Class
Menu_AppendItem Overload
Grasshopper.Kernel Namespace


Menu_AppendItem Method (ToolStrip, String, EventHandler, Image)

[image]

Grasshopper SDK
GH_DocumentObject..::..Menu_AppendItem Method (ToolStrip, String, EventHandler, Image)
GH_DocumentObject Class See Also Send Feedback
Utility function for appending generic menu items.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static ToolStripMenuItem Menu_AppendItem(
    ToolStrip menu,
    string text,
    EventHandler click,
    Image icon
)
Visual Basic
Public Shared Function Menu_AppendItem ( _
    menu As ToolStrip, _
    text As String, _
    click As EventHandler, _
    icon As Image _
) As ToolStripMenuItem

Parameters

menu
Type: System.Windows.Forms..::..ToolStrip
Menu to append item to.
text
Type: System..::..String
Item text.
click
Type: System..::..EventHandler
Delegate that handles click events. If nothing, the click event will not be handled.
icon
Type: System.Drawing..::..Image
Item icon, or null for no icon.

Return Value

The appended item

See Also

GH_DocumentObject Class
Menu_AppendItem Overload
Grasshopper.Kernel Namespace


Menu_AppendItem Method (ToolStrip, String, EventHandler, Boolean, Boolean)

[image]

Grasshopper SDK
GH_DocumentObject..::..Menu_AppendItem Method (ToolStrip, String, EventHandler, Boolean, Boolean)
GH_DocumentObject Class See Also Send Feedback
Utility function for appending generic menu items.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static ToolStripMenuItem Menu_AppendItem(
    ToolStrip menu,
    string text,
    EventHandler click,
    bool enabled,
    bool checked
)
Visual Basic
Public Shared Function Menu_AppendItem ( _
    menu As ToolStrip, _
    text As String, _
    click As EventHandler, _
    enabled As Boolean, _
    checked As Boolean _
) As ToolStripMenuItem

Parameters

menu
Type: System.Windows.Forms..::..ToolStrip
Menu to append item to.
text
Type: System..::..String
Item text.
click
Type: System..::..EventHandler
Delegate that handles click events. If nothing, the click event will not be handled.
enabled
Type: System..::..Boolean
If true, the item will be enabled.
checked
Type: System..::..Boolean
If true, the item will be checked.

Return Value

The appended item

See Also

GH_DocumentObject Class
Menu_AppendItem Overload
Grasshopper.Kernel Namespace


Menu_AppendItem Method (ToolStrip, String, EventHandler, Image, Object)

[image]

Grasshopper SDK
GH_DocumentObject..::..Menu_AppendItem Method (ToolStrip, String, EventHandler, Image, Object)
GH_DocumentObject Class See Also Send Feedback
Utility function for appending generic menu items.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static ToolStripMenuItem Menu_AppendItem(
    ToolStrip menu,
    string text,
    EventHandler click,
    Image icon,
    Object tag
)
Visual Basic
Public Shared Function Menu_AppendItem ( _
    menu As ToolStrip, _
    text As String, _
    click As EventHandler, _
    icon As Image, _
    tag As Object _
) As ToolStripMenuItem

Parameters

menu
Type: System.Windows.Forms..::..ToolStrip
Menu to append item to.
text
Type: System..::..String
Item text.
click
Type: System..::..EventHandler
Delegate that handles click events. If nothing, the click event will not be handled.
icon
Type: System.Drawing..::..Image
Item icon, or null for no icon.
tag
Type: System..::..Object
Tag to assign to menu item.

Return Value

The appended item

See Also

GH_DocumentObject Class
Menu_AppendItem Overload
Grasshopper.Kernel Namespace


Menu_AppendItem Method (ToolStrip, String, EventHandler, Image, Boolean, Boolean)

[image]

Grasshopper SDK
GH_DocumentObject..::..Menu_AppendItem Method (ToolStrip, String, EventHandler, Image, Boolean, Boolean)
GH_DocumentObject Class See Also Send Feedback
Utility function for appending generic menu items.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static ToolStripMenuItem Menu_AppendItem(
    ToolStrip menu,
    string text,
    EventHandler click,
    Image icon,
    bool enabled,
    bool checked
)
Visual Basic
Public Shared Function Menu_AppendItem ( _
    menu As ToolStrip, _
    text As String, _
    click As EventHandler, _
    icon As Image, _
    enabled As Boolean, _
    checked As Boolean _
) As ToolStripMenuItem

Parameters

menu
Type: System.Windows.Forms..::..ToolStrip
Menu to append item to.
text
Type: System..::..String
Item text.
click
Type: System..::..EventHandler
Delegate that handles click events.
icon
Type: System.Drawing..::..Image
Item icon.
enabled
Type: System..::..Boolean
If true, the item will be enabled.
checked
Type: System..::..Boolean
If true, the item will be checked.

Return Value

The appended item.

See Also

GH_DocumentObject Class
Menu_AppendItem Overload
Grasshopper.Kernel Namespace


Menu_AppendObjectHelp Method

[image]

Grasshopper SDK
GH_DocumentObject..::..Menu_AppendObjectHelp Method
GH_DocumentObject Class See Also Send Feedback
Appends the default object Help menu item.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected void Menu_AppendObjectHelp(
    ToolStripDropDown menu
)
Visual Basic
Protected Sub Menu_AppendObjectHelp ( _
    menu As ToolStripDropDown _
)

Parameters

menu
Type: System.Windows.Forms..::..ToolStripDropDown

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


Menu_AppendObjectName Method

[image]

Grasshopper SDK
GH_DocumentObject..::..Menu_AppendObjectName Method
GH_DocumentObject Class See Also Send Feedback
Appends the old-fashioned object name menu item. If you also want the Display mode toggle then use Menu_AppendObjectNameEx()

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected void Menu_AppendObjectName(
    ToolStripDropDown menu
)
Visual Basic
Protected Sub Menu_AppendObjectName ( _
    menu As ToolStripDropDown _
)

Parameters

menu
Type: System.Windows.Forms..::..ToolStripDropDown

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


Menu_AppendObjectNameEx Method

[image]

Grasshopper SDK
GH_DocumentObject..::..Menu_AppendObjectNameEx Method
GH_DocumentObject Class See Also Send Feedback
Appends the default object name + display mode menu item.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected void Menu_AppendObjectNameEx(
    ToolStripDropDown menu
)
Visual Basic
Protected Sub Menu_AppendObjectNameEx ( _
    menu As ToolStripDropDown _
)

Parameters

menu
Type: System.Windows.Forms..::..ToolStripDropDown

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


Menu_AppendSeparator Method

[image]

Grasshopper SDK
GH_DocumentObject..::..Menu_AppendSeparator Method
GH_DocumentObject Class See Also Send Feedback
Utility function for appending separators to a menu dropdown. If the dropdown is empty or if it already has a separator at the bottom, nothing will happen.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static ToolStripSeparator Menu_AppendSeparator(
    ToolStrip menu
)
Visual Basic
Public Shared Function Menu_AppendSeparator ( _
    menu As ToolStrip _
) As ToolStripSeparator

Parameters

menu
Type: System.Windows.Forms..::..ToolStrip
Menu to append separator to.

Return Value

The appended separator or null if no separator was appended.

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


Menu_AppendTextItem Method

[image] [image]

Grasshopper SDK
GH_DocumentObject..::..Menu_AppendTextItem Method
GH_DocumentObject Class See Also Send Feedback

Overload List

Name | Description
Menu_AppendTextItem(ToolStripDropDown, String, GH_MenuTextBox..::..KeyDownEventHandler, GH_MenuTextBox..::..TextChangedEventHandler, Boolean) | Utility function for inserting text boxes into menus.
Menu_AppendTextItem(ToolStripDropDown, String, GH_MenuTextBox..::..KeyDownEventHandler, GH_MenuTextBox..::..TextChangedEventHandler, Boolean, Int32, Boolean) | Utility function for inserting text boxes into menus.

See Also

GH_DocumentObject Class
GH_DocumentObject Members
Grasshopper.Kernel Namespace


Menu_AppendTextItem Method (ToolStripDropDown, String, GH_MenuTextBox.KeyDownEventHandler, GH_MenuTextBox.TextChangedEventHandler, Boolean)

[image]

Grasshopper SDK
GH_DocumentObject..::..Menu_AppendTextItem Method (ToolStripDropDown, String, GH_MenuTextBox..::..KeyDownEventHandler, GH_MenuTextBox..::..TextChangedEventHandler, Boolean)
GH_DocumentObject Class See Also Send Feedback
Utility function for inserting text boxes into menus.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static ToolStripTextBox Menu_AppendTextItem(
    ToolStripDropDown menu,
    string text,
    GH_MenuTextBox..::..KeyDownEventHandler keydown,
    GH_MenuTextBox..::..TextChangedEventHandler textchanged,
    bool lockOnFocus
)
Visual Basic
Public Shared Function Menu_AppendTextItem ( _
    menu As ToolStripDropDown, _
    text As String, _
    keydown As GH_MenuTextBox..::..KeyDownEventHandler, _
    textchanged As GH_MenuTextBox..::..TextChangedEventHandler, _
    lockOnFocus As Boolean _
) As ToolStripTextBox

Parameters

menu
Type: System.Windows.Forms..::..ToolStripDropDown
Menu to add a textbox to.
text
Type: System..::..String
Content of textbox.
keydown
Type: Grasshopper.GUI..::..GH_MenuTextBox..::..KeyDownEventHandler
Delegate for the KeyDown event.
textchanged
Type: Grasshopper.GUI..::..GH_MenuTextBox..::..TextChangedEventHandler
Delegate for the TextChanged event.
lockOnFocus
Type: System..::..Boolean
If true, then a GotFocus event will lock the other menu items.

Return Value

The appended text box item.

See Also

GH_DocumentObject Class
Menu_AppendTextItem Overload
Grasshopper.Kernel Namespace


Menu_AppendTextItem Method (ToolStripDropDown, String, GH_MenuTextBox.KeyDownEventHandler, GH_MenuTextBox.TextChangedEventHandler, Boolean, Int32, Boolean)

[image]

Grasshopper SDK
GH_DocumentObject..::..Menu_AppendTextItem Method (ToolStripDropDown, String, GH_MenuTextBox..::..KeyDownEventHandler, GH_MenuTextBox..::..TextChangedEventHandler, Boolean, Int32, Boolean)
GH_DocumentObject Class See Also Send Feedback
Utility function for inserting text boxes into menus.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static ToolStripTextBox Menu_AppendTextItem(
    ToolStripDropDown menu,
    string text,
    GH_MenuTextBox..::..KeyDownEventHandler keydown,
    GH_MenuTextBox..::..TextChangedEventHandler textchanged,
    bool enabled,
    int width,
    bool lockOnFocus
)
Visual Basic
Public Shared Function Menu_AppendTextItem ( _
    menu As ToolStripDropDown, _
    text As String, _
    keydown As GH_MenuTextBox..::..KeyDownEventHandler, _
    textchanged As GH_MenuTextBox..::..TextChangedEventHandler, _
    enabled As Boolean, _
    width As Integer, _
    lockOnFocus As Boolean _
) As ToolStripTextBox

Parameters

menu
Type: System.Windows.Forms..::..ToolStripDropDown
Menu to add a textbox to.
text
Type: System..::..String
Content of textbox.
keydown
Type: Grasshopper.GUI..::..GH_MenuTextBox..::..KeyDownEventHandler
Delegate for the KeyDown event.
textchanged
Type: Grasshopper.GUI..::..GH_MenuTextBox..::..TextChangedEventHandler
Delegate for the TextChanged event.
enabled
Type: System..::..Boolean
If true, the textbox will be enabled.
width
Type: System..::..Int32
If larger than zero, we'll do our very best to grow the menu to the given width. No guarantees.
lockOnFocus
Type: System..::..Boolean
If true, then a GotFocus event will lock the other menu items.

Return Value

The appended text box item.

See Also

GH_DocumentObject Class
Menu_AppendTextItem Overload
Grasshopper.Kernel Namespace


Menu_MoveItem Method

[image] [image]

Grasshopper SDK
GH_DocumentObject..::..Menu_MoveItem Method
GH_DocumentObject Class See Also Send Feedback

Overload List

Name | Description
Menu_MoveItem(ToolStripItem, array<String>[]()[][]) | Utility function for moving menu items.
Menu_MoveItem(ToolStripItem, Boolean, array<String>[]()[][]) | Utility function for moving menu items.

See Also

GH_DocumentObject Class
GH_DocumentObject Members
Grasshopper.Kernel Namespace


Menu_MoveItem Method (ToolStripItem, String[])

[image]

Grasshopper SDK
GH_DocumentObject..::..Menu_MoveItem Method (ToolStripItem, array<String>[]()[][])
GH_DocumentObject Class See Also Send Feedback
Utility function for moving menu items.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool Menu_MoveItem(
    ToolStripItem item,
    params string[] precedingItems
)
Visual Basic
Public Shared Function Menu_MoveItem ( _
    item As ToolStripItem, _
    ParamArray precedingItems As String() _
) As Boolean

Parameters

item
Type: System.Windows.Forms..::..ToolStripItem
Item to move, it must already be part of a dropdown menu.
precedingItems
Type: array< System..::..String >[]()[][]
Names of preceding items, the item will be inserted below the first name, if that fails the second, etc. etc.

Return Value

True on success, false on failure.

See Also

GH_DocumentObject Class
Menu_MoveItem Overload
Grasshopper.Kernel Namespace


Menu_MoveItem Method (ToolStripItem, Boolean, String[])

[image]

Grasshopper SDK
GH_DocumentObject..::..Menu_MoveItem Method (ToolStripItem, Boolean, array<String>[]()[][])
GH_DocumentObject Class See Also Send Feedback
Utility function for moving menu items.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool Menu_MoveItem(
    ToolStripItem item,
    bool insertBelow,
    params string[] targets
)
Visual Basic
Public Shared Function Menu_MoveItem ( _
    item As ToolStripItem, _
    insertBelow As Boolean, _
    ParamArray targets As String() _
) As Boolean

Parameters

item
Type: System.Windows.Forms..::..ToolStripItem
Item to move, it must already be part of the dropdown menu.
insertBelow
Type: System..::..Boolean
If true, the item will be inserted below the match, if false, above the match.
targets
Type: array< System..::..String >[]()[][]
Names of move to targets, the item will be inserted next to the first name, if that fails the second, etc. etc.

Return Value

True on success, false on failure.

See Also

GH_DocumentObject Class
Menu_MoveItem Overload
Grasshopper.Kernel Namespace


MovedBetweenDocuments Method

[image]

Grasshopper SDK
GH_DocumentObject..::..MovedBetweenDocuments Method
GH_DocumentObject Class See Also Send Feedback
This method will be called when an object is moved from one document to another. Override this method if you want to handle such events.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual void MovedBetweenDocuments(
    GH_Document oldDocument,
    GH_Document newDocument
)
Visual Basic
Public Overridable Sub MovedBetweenDocuments ( _
    oldDocument As GH_Document, _
    newDocument As GH_Document _
)

Parameters

oldDocument
Type: Grasshopper.Kernel..::..GH_Document
Document that used to own this object.
newDocument
Type: Grasshopper.Kernel..::..GH_Document
Document that now owns ths object.

Implements

IGH_DocumentObject..::..MovedBetweenDocuments(GH_Document, GH_Document)

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


NewInstanceGuid Method

[image] [image]

Grasshopper SDK
GH_DocumentObject..::..NewInstanceGuid Method
GH_DocumentObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NewInstanceGuid()()()() | Generate a new random instance GUID (Inherited from GH_InstanceDescription.)
Public method | NewInstanceGuid(Guid) | Set the instance ID to be a specific GUID. This is very dangerous, only use this function if you're 6"4' and your first name is David. (Inherited from GH_InstanceDescription.)

See Also

GH_DocumentObject Class
GH_DocumentObject Members
Grasshopper.Kernel Namespace


OnAttributesChanged Method

[image]

Grasshopper SDK
GH_DocumentObject..::..OnAttributesChanged Method
GH_DocumentObject Class See Also Send Feedback
Raises the AttributesChanged event on the toplevel object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void OnAttributesChanged()
Visual Basic
Public Sub OnAttributesChanged

Implements

IGH_DocumentObject..::..OnAttributesChanged()()()()

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


OnDisplayExpired Method

[image]

Grasshopper SDK
GH_DocumentObject..::..OnDisplayExpired Method
GH_DocumentObject Class See Also Send Feedback
Raises the DisplayExpired event on the toplevel object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void OnDisplayExpired(
    bool redraw
)
Visual Basic
Public Sub OnDisplayExpired ( _
    redraw As Boolean _
)

Parameters

redraw
Type: System..::..Boolean
If True, the canvas will be immediately redrawn.

Implements

IGH_DocumentObject..::..OnDisplayExpired(Boolean)

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


OnObjectChanged Method

[image] [image]

Grasshopper SDK
GH_DocumentObject..::..OnObjectChanged Method
GH_DocumentObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OnObjectChanged(String) |
Public method | OnObjectChanged(GH_ObjectChangedEventArgs) |
Public method | OnObjectChanged(GH_ObjectEventType) |
Public method | OnObjectChanged(String, Object) |
Public method | OnObjectChanged(GH_ObjectEventType, Object) |

See Also

GH_DocumentObject Class
GH_DocumentObject Members
Grasshopper.Kernel Namespace


OnObjectChanged Method (String)

[image]

Grasshopper SDK
GH_DocumentObject..::..OnObjectChanged Method (String)
GH_DocumentObject Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void OnObjectChanged(
    string customEvent
)
Visual Basic
Public Sub OnObjectChanged ( _
    customEvent As String _
)

Parameters

customEvent
Type: System..::..String

Implements

IGH_DocumentObject..::..OnObjectChanged(String)

See Also

GH_DocumentObject Class
OnObjectChanged Overload
Grasshopper.Kernel Namespace


OnObjectChanged Method (GH_ObjectChangedEventArgs)

[image]

Grasshopper SDK
GH_DocumentObject..::..OnObjectChanged Method (GH_ObjectChangedEventArgs)
GH_DocumentObject Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void OnObjectChanged(
    GH_ObjectChangedEventArgs e
)
Visual Basic
Public Sub OnObjectChanged ( _
    e As GH_ObjectChangedEventArgs _
)

Parameters

e
Type: Grasshopper.Kernel..::..GH_ObjectChangedEventArgs

Implements

IGH_DocumentObject..::..OnObjectChanged(GH_ObjectChangedEventArgs)

See Also

GH_DocumentObject Class
OnObjectChanged Overload
Grasshopper.Kernel Namespace


OnObjectChanged Method (GH_ObjectEventType)

[image]

Grasshopper SDK
GH_DocumentObject..::..OnObjectChanged Method (GH_ObjectEventType)
GH_DocumentObject Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void OnObjectChanged(
    GH_ObjectEventType eventType
)
Visual Basic
Public Sub OnObjectChanged ( _
    eventType As GH_ObjectEventType _
)

Parameters

eventType
Type: Grasshopper.Kernel..::..GH_ObjectEventType

Implements

IGH_DocumentObject..::..OnObjectChanged(GH_ObjectEventType)

See Also

GH_DocumentObject Class
OnObjectChanged Overload
Grasshopper.Kernel Namespace


OnObjectChanged Method (String, Object)

[image]

Grasshopper SDK
GH_DocumentObject..::..OnObjectChanged Method (String, Object)
GH_DocumentObject Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void OnObjectChanged(
    string customEvent,
    Object tag
)
Visual Basic
Public Sub OnObjectChanged ( _
    customEvent As String, _
    tag As Object _
)

Parameters

customEvent
Type: System..::..String
tag
Type: System..::..Object

Implements

IGH_DocumentObject..::..OnObjectChanged(String, Object)

See Also

GH_DocumentObject Class
OnObjectChanged Overload
Grasshopper.Kernel Namespace


OnObjectChanged Method (GH_ObjectEventType, Object)

[image]

Grasshopper SDK
GH_DocumentObject..::..OnObjectChanged Method (GH_ObjectEventType, Object)
GH_DocumentObject Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void OnObjectChanged(
    GH_ObjectEventType eventType,
    Object tag
)
Visual Basic
Public Sub OnObjectChanged ( _
    eventType As GH_ObjectEventType, _
    tag As Object _
)

Parameters

eventType
Type: Grasshopper.Kernel..::..GH_ObjectEventType
tag
Type: System..::..Object

Implements

IGH_DocumentObject..::..OnObjectChanged(GH_ObjectEventType, Object)

See Also

GH_DocumentObject Class
OnObjectChanged Overload
Grasshopper.Kernel Namespace


OnPingDocument Method

[image]

Grasshopper SDK
GH_DocumentObject..::..OnPingDocument Method
GH_DocumentObject Class See Also Send Feedback
Raise the PingDocument Event on the toplevel object and try to find the document which owns this object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Document OnPingDocument()
Visual Basic
Public Function OnPingDocument As GH_Document

Return Value

The document which owns this object if successful, or nothing if no document owns this object.

Implements

IGH_DocumentObject..::..OnPingDocument()()()()

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


OnPreviewExpired Method

[image]

Grasshopper SDK
GH_DocumentObject..::..OnPreviewExpired Method
GH_DocumentObject Class See Also Send Feedback
Raises the PreviewExpired event on the toplevel object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void OnPreviewExpired(
    bool redraw
)
Visual Basic
Public Sub OnPreviewExpired ( _
    redraw As Boolean _
)

Parameters

redraw
Type: System..::..Boolean
If True, the viewports will be immediately redrawn.

Implements

IGH_DocumentObject..::..OnPreviewExpired(Boolean)

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


OnSolutionExpired Method

[image]

Grasshopper SDK
GH_DocumentObject..::..OnSolutionExpired Method
GH_DocumentObject Class See Also Send Feedback
Raises the SolutionExpired event on the toplevel object. You probably want to call ExpireSolution() instead of this method directly.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void OnSolutionExpired(
    bool recompute
)
Visual Basic
Public Sub OnSolutionExpired ( _
    recompute As Boolean _
)

Parameters

recompute
Type: System..::..Boolean
If True, the solution will be immediately recalculated.

Implements

IGH_DocumentObject..::..OnSolutionExpired(Boolean)

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


Read Method

[image]

Grasshopper SDK
GH_DocumentObject..::..Read Method
GH_DocumentObject Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


RecordUndoEvent Method

[image] [image]

Grasshopper SDK
GH_DocumentObject..::..RecordUndoEvent Method
GH_DocumentObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RecordUndoEvent(String) | Record a generic object change undo event.
Public method | RecordUndoEvent(GH_UndoRecord) | Record an entire undo record.
Public method | RecordUndoEvent(String, IGH_UndoAction) | Record a specific object change undo event.

See Also

GH_DocumentObject Class
GH_DocumentObject Members
Grasshopper.Kernel Namespace


RecordUndoEvent Method (String)

[image]

Grasshopper SDK
GH_DocumentObject..::..RecordUndoEvent Method (String)
GH_DocumentObject Class See Also Send Feedback
Record a generic object change undo event.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid RecordUndoEvent(
    string name
)
Visual Basic
Public Function RecordUndoEvent ( _
    name As String _
) As Guid

Parameters

name
Type: System..::..String
Name of undo record.

Return Value

The ID of the newly added record or Guid.Empty on failure.

Implements

IGH_DocumentObject..::..RecordUndoEvent(String)

See Also

GH_DocumentObject Class
RecordUndoEvent Overload
Grasshopper.Kernel Namespace


RecordUndoEvent Method (GH_UndoRecord)

[image]

Grasshopper SDK
GH_DocumentObject..::..RecordUndoEvent Method (GH_UndoRecord)
GH_DocumentObject Class See Also Send Feedback
Record an entire undo record.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RecordUndoEvent(
    GH_UndoRecord record
)
Visual Basic
Public Sub RecordUndoEvent ( _
    record As GH_UndoRecord _
)

Parameters

record
Type: Grasshopper.Kernel.Undo..::..GH_UndoRecord
Record to push.

Implements

IGH_DocumentObject..::..RecordUndoEvent(GH_UndoRecord)

See Also

GH_DocumentObject Class
RecordUndoEvent Overload
Grasshopper.Kernel Namespace


RecordUndoEvent Method (String, IGH_UndoAction)

[image]

Grasshopper SDK
GH_DocumentObject..::..RecordUndoEvent Method (String, IGH_UndoAction)
GH_DocumentObject Class See Also Send Feedback
Record a specific object change undo event.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid RecordUndoEvent(
    string name,
    IGH_UndoAction action
)
Visual Basic
Public Function RecordUndoEvent ( _
    name As String, _
    action As IGH_UndoAction _
) As Guid

Parameters

name
Type: System..::..String
Name of undo record.
action
Type: Grasshopper.Kernel.Undo..::..IGH_UndoAction
Undo action to record.

Return Value

The ID of the newly added record or Guid.Empty on failure.

Implements

IGH_DocumentObject..::..RecordUndoEvent(String, IGH_UndoAction)

See Also

GH_DocumentObject Class
RecordUndoEvent Overload
Grasshopper.Kernel Namespace


RemovedFromDocument Method

[image]

Grasshopper SDK
GH_DocumentObject..::..RemovedFromDocument Method
GH_DocumentObject Class See Also Send Feedback
This method will be called when an object is removed from a document. Override this method if you want to handle such events.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual void RemovedFromDocument(
    GH_Document document
)
Visual Basic
Public Overridable Sub RemovedFromDocument ( _
    document As GH_Document _
)

Parameters

document
Type: Grasshopper.Kernel..::..GH_Document
Document that now no longer owns this object.

Implements

IGH_DocumentObject..::..RemovedFromDocument(GH_Document)

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


SetIconOverride Method

[image]

Grasshopper SDK
GH_DocumentObject..::..SetIconOverride Method
GH_DocumentObject Class See Also Send Feedback
Set a new custom icon override for this object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SetIconOverride(
    Bitmap custom_icon
)
Visual Basic
Public Sub SetIconOverride ( _
    custom_icon As Bitmap _
)

Parameters

custom_icon
Type: System.Drawing..::..Bitmap
Icon override. Should be a 24x24 image.

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


SetValue Method

[image] [image]

Grasshopper SDK
GH_DocumentObject..::..SetValue Method
GH_DocumentObject Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SetValue(String, Boolean) | Set a named value. This value will be serialized with the component.
Protected method | SetValue(String, Double) | Set a named value. This value will be serialized with the component.
Protected method | SetValue(String, Color) | Set a named value. This value will be serialized with the component.
Protected method | SetValue(String, Int32) | Set a named value. This value will be serialized with the component.
Protected method | SetValue(String, String) | Set a named value. This value will be serialized with the component.

See Also

GH_DocumentObject Class
GH_DocumentObject Members
Grasshopper.Kernel Namespace


SetValue Method (String, Boolean)

[image]

Grasshopper SDK
GH_DocumentObject..::..SetValue Method (String, Boolean)
GH_DocumentObject Class See Also Send Feedback
Set a named value. This value will be serialized with the component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected void SetValue(
    string name,
    bool value
)
Visual Basic
Protected Sub SetValue ( _
    name As String, _
    value As Boolean _
)

Parameters

name
Type: System..::..String
Name of value.
value
Type: System..::..Boolean
Value itself.

See Also

GH_DocumentObject Class
SetValue Overload
Grasshopper.Kernel Namespace


SetValue Method (String, Double)

[image]

Grasshopper SDK
GH_DocumentObject..::..SetValue Method (String, Double)
GH_DocumentObject Class See Also Send Feedback
Set a named value. This value will be serialized with the component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected void SetValue(
    string name,
    double value
)
Visual Basic
Protected Sub SetValue ( _
    name As String, _
    value As Double _
)

Parameters

name
Type: System..::..String
Name of value.
value
Type: System..::..Double
Value itself.

See Also

GH_DocumentObject Class
SetValue Overload
Grasshopper.Kernel Namespace


SetValue Method (String, Color)

[image]

Grasshopper SDK
GH_DocumentObject..::..SetValue Method (String, Color)
GH_DocumentObject Class See Also Send Feedback
Set a named value. This value will be serialized with the component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected void SetValue(
    string name,
    Color value
)
Visual Basic
Protected Sub SetValue ( _
    name As String, _
    value As Color _
)

Parameters

name
Type: System..::..String
Name of value.
value
Type: System.Drawing..::..Color
Value itself.

See Also

GH_DocumentObject Class
SetValue Overload
Grasshopper.Kernel Namespace


SetValue Method (String, Int32)

[image]

Grasshopper SDK
GH_DocumentObject..::..SetValue Method (String, Int32)
GH_DocumentObject Class See Also Send Feedback
Set a named value. This value will be serialized with the component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected void SetValue(
    string name,
    int value
)
Visual Basic
Protected Sub SetValue ( _
    name As String, _
    value As Integer _
)

Parameters

name
Type: System..::..String
Name of value.
value
Type: System..::..Int32
Value itself.

See Also

GH_DocumentObject Class
SetValue Overload
Grasshopper.Kernel Namespace


SetValue Method (String, String)

[image]

Grasshopper SDK
GH_DocumentObject..::..SetValue Method (String, String)
GH_DocumentObject Class See Also Send Feedback
Set a named value. This value will be serialized with the component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected void SetValue(
    string name,
    string value
)
Visual Basic
Protected Sub SetValue ( _
    name As String, _
    value As String _
)

Parameters

name
Type: System..::..String
Name of value.
value
Type: System..::..String
Value itself.

See Also

GH_DocumentObject Class
SetValue Overload
Grasshopper.Kernel Namespace


TriggerAutoSave Method

[image] [image]

Grasshopper SDK
GH_DocumentObject..::..TriggerAutoSave Method
GH_DocumentObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TriggerAutoSave()()()() | Triggers the AutoSave function on the owner document with the object_changed flag.
Public method | TriggerAutoSave(Guid) | Triggers the AutoSave function on the owner document with the object_changed flag.
Public method | TriggerAutoSave(GH_AutoSaveTrigger) | Triggers the AutoSave function on the owner document with a custom flag.
Public method | TriggerAutoSave(GH_AutoSaveTrigger, Guid) | Triggers the AutoSave function on the owner document with a custom flag.

See Also

GH_DocumentObject Class
GH_DocumentObject Members
Grasshopper.Kernel Namespace


TriggerAutoSave Method

[image]

Grasshopper SDK
GH_DocumentObject..::..TriggerAutoSave Method
GH_DocumentObject Class See Also Send Feedback
Triggers the AutoSave function on the owner document with the object_changed flag.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void TriggerAutoSave()
Visual Basic
Public Sub TriggerAutoSave

Implements

IGH_DocumentObject..::..TriggerAutoSave()()()()

See Also

GH_DocumentObject Class
TriggerAutoSave Overload
Grasshopper.Kernel Namespace


TriggerAutoSave Method (Guid)

[image]

Grasshopper SDK
GH_DocumentObject..::..TriggerAutoSave Method (Guid)
GH_DocumentObject Class See Also Send Feedback
Triggers the AutoSave function on the owner document with the object_changed flag.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void TriggerAutoSave(
    Guid id
)
Visual Basic
Public Sub TriggerAutoSave ( _
    id As Guid _
)

Parameters

id
Type: System..::..Guid
ID of autosave event. Consecutive autosave requests with the same ID will be ignored.

Implements

IGH_DocumentObject..::..TriggerAutoSave(Guid)

See Also

GH_DocumentObject Class
TriggerAutoSave Overload
Grasshopper.Kernel Namespace


TriggerAutoSave Method (GH_AutoSaveTrigger)

[image]

Grasshopper SDK
GH_DocumentObject..::..TriggerAutoSave Method (GH_AutoSaveTrigger)
GH_DocumentObject Class See Also Send Feedback
Triggers the AutoSave function on the owner document with a custom flag.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void TriggerAutoSave(
    GH_AutoSaveTrigger trigger
)
Visual Basic
Public Sub TriggerAutoSave ( _
    trigger As GH_AutoSaveTrigger _
)

Parameters

trigger
Type: Grasshopper.Kernel..::..GH_AutoSaveTrigger
Reason for the autosave operation. It is possible that a user has decided to avoid autosave events for specific types, so if you can, try and provide a correct trigger flag.

Implements

IGH_DocumentObject..::..TriggerAutoSave(GH_AutoSaveTrigger)

See Also

GH_DocumentObject Class
TriggerAutoSave Overload
Grasshopper.Kernel Namespace


TriggerAutoSave Method (GH_AutoSaveTrigger, Guid)

[image]

Grasshopper SDK
GH_DocumentObject..::..TriggerAutoSave Method (GH_AutoSaveTrigger, Guid)
GH_DocumentObject Class See Also Send Feedback
Triggers the AutoSave function on the owner document with a custom flag.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void TriggerAutoSave(
    GH_AutoSaveTrigger trigger,
    Guid id
)
Visual Basic
Public Sub TriggerAutoSave ( _
    trigger As GH_AutoSaveTrigger, _
    id As Guid _
)

Parameters

trigger
Type: Grasshopper.Kernel..::..GH_AutoSaveTrigger
Reason for the autosave operation. It is possible that a user has decided to avoid autosave events for specific types, so if you can, try and provide a correct trigger flag.
id
Type: System..::..Guid
ID of autosave event. Consecutive autosave requests with the same ID will be ignored.

Implements

IGH_DocumentObject..::..TriggerAutoSave(GH_AutoSaveTrigger, Guid)

See Also

GH_DocumentObject Class
TriggerAutoSave Overload
Grasshopper.Kernel Namespace


ValuesChanged Method

[image]

Grasshopper SDK
GH_DocumentObject..::..ValuesChanged Method
GH_DocumentObject Class See Also Send Feedback
Override this method if you want to respond to changes to the value table. The base implementation is empty, so you don't have to call it.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected virtual void ValuesChanged()
Visual Basic
Protected Overridable Sub ValuesChanged

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


Write Method

[image]

Grasshopper SDK
GH_DocumentObject..::..Write Method
GH_DocumentObject Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overrides Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


GH_DocumentObject Properties

[image] [image]

Grasshopper SDK
GH_DocumentObject Properties
GH_DocumentObject Class See Also Send Feedback

The GH_DocumentObject type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Gets or sets the attributes that are associated with this object. Only set custom attributes if you know what you are doing.
Public property | Category | Gets or sets the Category in which this object belongs. If HasCategory() returns false, this field has no meaning. (Inherited from GH_InstanceDescription.)
Public property | ComponentGuid | Returns a consistent ID for this object type. Every object must supply a unique and unchanging ID that is used to identify objects of the same type.
Public property | Description | Gets or sets the description of the object. This field typically remains fixed during the lifetime of an object. (Inherited from GH_InstanceDescription.)
Public property | Exposure | Gets the exposure of this object in the Graphical User Interface. The default is to expose everywhere.
Public property | HasCategory | Gets whether or not the Category field has been set. (Inherited from GH_InstanceDescription.)
Public property | HasSubCategory | Gets whether or not the SubCategory field has been set. (Inherited from GH_InstanceDescription.)
Protected property | Icon | Override this function to supply a custom icon (24x24 pixels). The result of this property is cached, so don't worry if icon retrieval is not very fast.
Public property | Icon_24x24 | The icon associated with this object.
Public property | Icon_24x24_Locked | The greyscale icon of this object.
Public property | IconDisplayMode | Gets the current display mode of the object.
Public property | InstanceDescription | Gets a description of the current state of the object. This field is usually the same as the Description() field, but it might be variable when overridden. (Inherited from GH_InstanceDescription.)
Public property | InstanceGuid | Gets the ID of this runtime instance. (Inherited from GH_InstanceDescription.)
Public property | Keywords | Gets a list of additional keywords that describe the object. Typically this list is empty but you can override this property to aid in object searches. (Inherited from GH_InstanceDescription.)
Public property | Name | Gets or sets the name of the object. This field typically remains fixed during the lifetime of an object. (Inherited from GH_InstanceDescription.)
Public property | NickName | Gets or sets the nickname of the object. This field can be changed by the user. (Inherited from GH_InstanceDescription.)
Public property | Obsolete | Gets whether this object is obsolete. Default implementation returns true if the class name contains the string "OBSOLETE" or if this class has been decorated with the ObsoleteAttribute. You are free to override this if you want, but I suggest adding the ObsoleteAttribute instead.
Public property | SubCategory | Gets or sets the SubCategory in which this object belongs. If HasSubCategory() returns false, this field has no meaning. (Inherited from GH_InstanceDescription.)

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


Attributes Property

[image]

Grasshopper SDK
GH_DocumentObject..::..Attributes Property
GH_DocumentObject Class See Also Send Feedback
Gets or sets the attributes that are associated with this object. Only set custom attributes if you know what you are doing.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_Attributes Attributes { get; set; }
Visual Basic
Public Property Attributes As IGH_Attributes
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DocumentObject.Attributes"]

Implements

IGH_DocumentObject..::..Attributes

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


ComponentGuid Property

[image]

Grasshopper SDK
GH_DocumentObject..::..ComponentGuid Property
GH_DocumentObject Class See Also Send Feedback
Returns a consistent ID for this object type. Every object must supply a unique and unchanging ID that is used to identify objects of the same type.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract Guid ComponentGuid { get; }
Visual Basic
Public MustOverride ReadOnly Property ComponentGuid As Guid
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DocumentObject.ComponentGuid"]

Implements

IGH_DocumentObject..::..ComponentGuid

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


Exposure Property

[image]

Grasshopper SDK
GH_DocumentObject..::..Exposure Property
GH_DocumentObject Class See Also Send Feedback
Gets the exposure of this object in the Graphical User Interface. The default is to expose everywhere.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual GH_Exposure Exposure { get; }
Visual Basic
Public Overridable ReadOnly Property Exposure As GH_Exposure
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DocumentObject.Exposure"]

Implements

IGH_DocumentObject..::..Exposure

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


Icon Property

[image]

Grasshopper SDK
GH_DocumentObject..::..Icon Property
GH_DocumentObject Class See Also Send Feedback
Override this function to supply a custom icon (24x24 pixels). The result of this property is cached, so don't worry if icon retrieval is not very fast.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected virtual Bitmap Icon { get; }
Visual Basic
Protected Overridable ReadOnly Property Icon As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DocumentObject.Icon"]

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


Icon_24x24 Property

[image]

Grasshopper SDK
GH_DocumentObject..::..Icon_24x24 Property
GH_DocumentObject Class See Also Send Feedback
The icon associated with this object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Bitmap Icon_24x24 { get; }
Visual Basic
Public ReadOnly Property Icon_24x24 As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DocumentObject.Icon_24x24"]

Implements

IGH_DocumentObject..::..Icon_24x24

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


Icon_24x24_Locked Property

[image]

Grasshopper SDK
GH_DocumentObject..::..Icon_24x24_Locked Property
GH_DocumentObject Class See Also Send Feedback
The greyscale icon of this object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Bitmap Icon_24x24_Locked { get; }
Visual Basic
Public ReadOnly Property Icon_24x24_Locked As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DocumentObject.Icon_24x24_Locked"]

Implements

IGH_DocumentObject..::..Icon_24x24_Locked

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


IconDisplayMode Property

[image]

Grasshopper SDK
GH_DocumentObject..::..IconDisplayMode Property
GH_DocumentObject Class See Also Send Feedback
Gets the current display mode of the object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_IconDisplayMode IconDisplayMode { get; set; }
Visual Basic
Public Property IconDisplayMode As GH_IconDisplayMode
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DocumentObject.IconDisplayMode"]

Implements

IGH_DocumentObject..::..IconDisplayMode

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


Obsolete Property

[image]

Grasshopper SDK
GH_DocumentObject..::..Obsolete Property
GH_DocumentObject Class See Also Send Feedback
Gets whether this object is obsolete. Default implementation returns true if the class name contains the string "OBSOLETE" or if this class has been decorated with the ObsoleteAttribute. You are free to override this if you want, but I suggest adding the ObsoleteAttribute instead.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool Obsolete { get; }
Visual Basic
Public Overridable ReadOnly Property Obsolete As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DocumentObject.Obsolete"]

Implements

IGH_DocumentObject..::..Obsolete

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


GH_DocumentObject Events

[image] [image]

Grasshopper SDK
GH_DocumentObject Events
GH_DocumentObject Class See Also Send Feedback

The GH_DocumentObject type exposes the following members.

Events

 | Name | Description
Public event | AttributesChanged | Raised whenever the number or kind of attributes changes. This event is handled by GH_Documents who subsequently wipe their attribute caches.
Public event | DisplayExpired | Raised whenever the display (on the Canvas) of a certain object becomes invalid.
Public event | ObjectChanged |
Public event | PingDocument | Raised whenever an object needs to know which GH_Document it belongs to.
Public event | PreviewExpired | Raised whenever the display (in the Rhino viewports) of a certain object becomes invalid.
Public event | SolutionExpired | Raised whenever the solution of a certain object becomes invalid.

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


AttributesChanged Event

[image]

Grasshopper SDK
GH_DocumentObject..::..AttributesChanged Event
GH_DocumentObject Class See Also Send Feedback
Raised whenever the number or kind of attributes changes. This event is handled by GH_Documents who subsequently wipe their attribute caches.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event IGH_DocumentObject..::..AttributesChangedEventHandler AttributesChanged
Visual Basic
Public Event AttributesChanged As IGH_DocumentObject..::..AttributesChangedEventHandler

Implements

IGH_DocumentObject..::..AttributesChanged

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


DisplayExpired Event

[image]

Grasshopper SDK
GH_DocumentObject..::..DisplayExpired Event
GH_DocumentObject Class See Also Send Feedback
Raised whenever the display (on the Canvas) of a certain object becomes invalid.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event IGH_DocumentObject..::..DisplayExpiredEventHandler DisplayExpired
Visual Basic
Public Event DisplayExpired As IGH_DocumentObject..::..DisplayExpiredEventHandler

Implements

IGH_DocumentObject..::..DisplayExpired

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


ObjectChanged Event

[image]

Grasshopper SDK
GH_DocumentObject..::..ObjectChanged Event
GH_DocumentObject Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event IGH_DocumentObject..::..ObjectChangedEventHandler ObjectChanged
Visual Basic
Public Event ObjectChanged As IGH_DocumentObject..::..ObjectChangedEventHandler

Implements

IGH_DocumentObject..::..ObjectChanged

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


PingDocument Event

[image]

Grasshopper SDK
GH_DocumentObject..::..PingDocument Event
GH_DocumentObject Class See Also Send Feedback
Raised whenever an object needs to know which GH_Document it belongs to.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event IGH_DocumentObject..::..PingDocumentEventHandler PingDocument
Visual Basic
Public Event PingDocument As IGH_DocumentObject..::..PingDocumentEventHandler

Implements

IGH_DocumentObject..::..PingDocument

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


PreviewExpired Event

[image]

Grasshopper SDK
GH_DocumentObject..::..PreviewExpired Event
GH_DocumentObject Class See Also Send Feedback
Raised whenever the display (in the Rhino viewports) of a certain object becomes invalid.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event IGH_DocumentObject..::..PreviewExpiredEventHandler PreviewExpired
Visual Basic
Public Event PreviewExpired As IGH_DocumentObject..::..PreviewExpiredEventHandler

Implements

IGH_DocumentObject..::..PreviewExpired

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


SolutionExpired Event

[image]

Grasshopper SDK
GH_DocumentObject..::..SolutionExpired Event
GH_DocumentObject Class See Also Send Feedback
Raised whenever the solution of a certain object becomes invalid.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event IGH_DocumentObject..::..SolutionExpiredEventHandler SolutionExpired
Visual Basic
Public Event SolutionExpired As IGH_DocumentObject..::..SolutionExpiredEventHandler

Implements

IGH_DocumentObject..::..SolutionExpired

See Also

GH_DocumentObject Class
Grasshopper.Kernel Namespace


GH_DocumentObject.ColourEventHandler Delegate

[image]

Grasshopper SDK
GH_DocumentObject..::..ColourEventHandler Delegate
GH_DocumentObject Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void ColourEventHandler(
    GH_ColourPicker sender,
    GH_ColourPickerEventArgs e
)
Visual Basic
Public Delegate Sub ColourEventHandler ( _
    sender As GH_ColourPicker, _
    e As GH_ColourPickerEventArgs _
)

Parameters

sender
Type: Grasshopper.GUI..::..GH_ColourPicker
e
Type: Grasshopper.GUI.Base..::..GH_ColourPickerEventArgs

See Also

Grasshopper.Kernel Namespace


GH_DocumentRank Enumeration

[image]

Grasshopper SDK
GH_DocumentRank Enumeration
See Also Send Feedback
Enumerates all possible document rankings.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_DocumentRank
Visual Basic
Public Enumeration GH_DocumentRank

Members

Member name | Value | Description
Unset | 0 | Indicates no rank. Documents with unset rank are invalid.
TopLevel | 1 | Top level ranking.
Subsidiary | 2 | Subsidiary ranking indicates this document is part of another document.

See Also

Grasshopper.Kernel Namespace


GH_DocumentServer Class

[image]

Grasshopper SDK
GH_DocumentServer Class
Members See Also Send Feedback
Manages and maintains a collection of GH_Documents.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class GH_DocumentServer : IEnumerable<GH_Document>
Visual Basic
Public NotInheritable Class GH_DocumentServer _
    Implements IEnumerable(Of GH_Document)

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_DocumentServer

See Also

GH_DocumentServer Members
Grasshopper.Kernel Namespace


GH_DocumentServer Members

[image] [image]

Grasshopper SDK
GH_DocumentServer Members
GH_DocumentServer Class Constructors Methods Properties Events See Also Send Feedback

The GH_DocumentServer type exposes the following members.

Constructors

 | Name | Description
Public method | GH_DocumentServer | Initializes a new instance of the GH_DocumentServer class

Methods

 | Name | Description
Public method | AddDocument(String) | Add a new document to the global list. If there already is a document with the given path, it will be made active.
Public method | AddDocument(GH_Document) | Add a new document to the global list. If the document is already registered nothing will happen.
Public method | AddNewDocument | Adds a new document to the global list. If a template file has been set, this document will be based on the template.
Public method | Contains | Gets a value indicating whether or not the given document is inside the list.
Public method | GetEnumerator |
Public method | GetEnumerator_Generic |
Public method | IndexOf(String) | Gets the index of the document that matches the filepath.
Public method | IndexOf(GH_Document) | Gets the index of the given document.
Public method | IndexOfAutoSave | Gets the document index that is associated with the specified autosave location.
Public method | NextAvailableDocument | Gets the most important, non-active document.
Public method | PromoteDocument | Push a document to the top of the list, meaning it will be first in line when a new default document needs to be selected.
Public method | RemoveAllDocuments | Remove all documents in the global list.
Public method | RemoveDocument | Removes a specific document from the global list. If the document isn't registered nothing will happen. If the document is owned by an IGH_DocumentOwner, the owner will be informed of the removal.
Public method | SafeRemoveDocument | Remove a document correctly from the server. This method shows user-interface prompts if there is unsaved data and will also save if needed.

Properties

 | Name | Description
Public property | Document | Gets the document at the given index.
Public property | DocumentCount | Gets the number of documents stored in the global list.
Public property | DocumentNames | Gets a string collection containing all the names of the documents in the global list.
Public property | ModifiedDocumentCount | Gets the total number of modified (unsaved) documents.

Events

 | Name | Description
Public event | DocumentAdded |
Public event | DocumentRemoved |

See Also

GH_DocumentServer Class
Grasshopper.Kernel Namespace


GH_DocumentServer Constructor

[image]

Grasshopper SDK
GH_DocumentServer Constructor
GH_DocumentServer Class See Also Send Feedback
Initializes a new instance of the GH_DocumentServer class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_DocumentServer()
Visual Basic
Public Sub New

See Also

GH_DocumentServer Class
Grasshopper.Kernel Namespace


GH_DocumentServer Methods

[image] [image]

Grasshopper SDK
GH_DocumentServer Methods
GH_DocumentServer Class See Also Send Feedback

The GH_DocumentServer type exposes the following members.

Methods

 | Name | Description
Public method | AddDocument(String) | Add a new document to the global list. If there already is a document with the given path, it will be made active.
Public method | AddDocument(GH_Document) | Add a new document to the global list. If the document is already registered nothing will happen.
Public method | AddNewDocument | Adds a new document to the global list. If a template file has been set, this document will be based on the template.
Public method | Contains | Gets a value indicating whether or not the given document is inside the list.
Public method | GetEnumerator |
Public method | GetEnumerator_Generic |
Public method | IndexOf(String) | Gets the index of the document that matches the filepath.
Public method | IndexOf(GH_Document) | Gets the index of the given document.
Public method | IndexOfAutoSave | Gets the document index that is associated with the specified autosave location.
Public method | NextAvailableDocument | Gets the most important, non-active document.
Public method | PromoteDocument | Push a document to the top of the list, meaning it will be first in line when a new default document needs to be selected.
Public method | RemoveAllDocuments | Remove all documents in the global list.
Public method | RemoveDocument | Removes a specific document from the global list. If the document isn't registered nothing will happen. If the document is owned by an IGH_DocumentOwner, the owner will be informed of the removal.
Public method | SafeRemoveDocument | Remove a document correctly from the server. This method shows user-interface prompts if there is unsaved data and will also save if needed.

See Also

GH_DocumentServer Class
Grasshopper.Kernel Namespace


AddDocument Method

[image] [image]

Grasshopper SDK
GH_DocumentServer..::..AddDocument Method
GH_DocumentServer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddDocument(String) | Add a new document to the global list. If there already is a document with the given path, it will be made active.
Public method | AddDocument(GH_Document) | Add a new document to the global list. If the document is already registered nothing will happen.

See Also

GH_DocumentServer Class
GH_DocumentServer Members
Grasshopper.Kernel Namespace


AddDocument Method (String)

[image]

Grasshopper SDK
GH_DocumentServer..::..AddDocument Method (String)
GH_DocumentServer Class See Also Send Feedback
Add a new document to the global list. If there already is a document with the given path, it will be made active.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Document AddDocument(
    string filepath
)
Visual Basic
Public Function AddDocument ( _
    filepath As String _
) As GH_Document

Parameters

filepath
Type: System..::..String
Filepath to document.

Return Value

The document that was added or activated, or null on failure.

See Also

GH_DocumentServer Class
AddDocument Overload
Grasshopper.Kernel Namespace


AddDocument Method (GH_Document)

[image]

Grasshopper SDK
GH_DocumentServer..::..AddDocument Method (GH_Document)
GH_DocumentServer Class See Also Send Feedback
Add a new document to the global list. If the document is already registered nothing will happen.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddDocument(
    GH_Document document
)
Visual Basic
Public Sub AddDocument ( _
    document As GH_Document _
)

Parameters

document
Type: Grasshopper.Kernel..::..GH_Document
Document to add.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown when the document is a null reference.
System..::..InvalidOperationException | Thrown when the document doesn't have top-level rank.

See Also

GH_DocumentServer Class
AddDocument Overload
Grasshopper.Kernel Namespace


AddNewDocument Method

[image]

Grasshopper SDK
GH_DocumentServer..::..AddNewDocument Method
GH_DocumentServer Class See Also Send Feedback
Adds a new document to the global list. If a template file has been set, this document will be based on the template.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Document AddNewDocument()
Visual Basic
Public Function AddNewDocument As GH_Document

Return Value

The document thaw was added.

See Also

GH_DocumentServer Class
Grasshopper.Kernel Namespace


Contains Method

[image]

Grasshopper SDK
GH_DocumentServer..::..Contains Method
GH_DocumentServer Class See Also Send Feedback
Gets a value indicating whether or not the given document is inside the list.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Contains(
    GH_Document doc
)
Visual Basic
Public Function Contains ( _
    doc As GH_Document _
) As Boolean

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document

See Also

GH_DocumentServer Class
Grasshopper.Kernel Namespace


GetEnumerator Method

[image]

Grasshopper SDK
GH_DocumentServer..::..GetEnumerator Method
GH_DocumentServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

GH_DocumentServer Class
Grasshopper.Kernel Namespace


GetEnumerator_Generic Method

[image]

Grasshopper SDK
GH_DocumentServer..::..GetEnumerator_Generic Method
GH_DocumentServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IEnumerator<GH_Document> GetEnumerator_Generic()
Visual Basic
Public Function GetEnumerator_Generic As IEnumerator(Of GH_Document)

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

GH_DocumentServer Class
Grasshopper.Kernel Namespace


IndexOf Method

[image] [image]

Grasshopper SDK
GH_DocumentServer..::..IndexOf Method
GH_DocumentServer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(String) | Gets the index of the document that matches the filepath.
Public method | IndexOf(GH_Document) | Gets the index of the given document.

See Also

GH_DocumentServer Class
GH_DocumentServer Members
Grasshopper.Kernel Namespace


IndexOf Method (String)

[image]

Grasshopper SDK
GH_DocumentServer..::..IndexOf Method (String)
GH_DocumentServer Class See Also Send Feedback
Gets the index of the document that matches the filepath.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int IndexOf(
    string filepath
)
Visual Basic
Public Function IndexOf ( _
    filepath As String _
) As Integer

Parameters

filepath
Type: System..::..String
File path URI to match.

Return Value

The index of the document that matches the given path or -1 if no document match is found.

See Also

GH_DocumentServer Class
IndexOf Overload
Grasshopper.Kernel Namespace


IndexOf Method (GH_Document)

[image]

Grasshopper SDK
GH_DocumentServer..::..IndexOf Method (GH_Document)
GH_DocumentServer Class See Also Send Feedback
Gets the index of the given document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int IndexOf(
    GH_Document doc
)
Visual Basic
Public Function IndexOf ( _
    doc As GH_Document _
) As Integer

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document
Document to search for.

Return Value

The index of the given document or -1 if the document is not in the global list.

See Also

GH_DocumentServer Class
IndexOf Overload
Grasshopper.Kernel Namespace


IndexOfAutoSave Method

[image]

Grasshopper SDK
GH_DocumentServer..::..IndexOfAutoSave Method
GH_DocumentServer Class See Also Send Feedback
Gets the document index that is associated with the specified autosave location.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int IndexOfAutoSave(
    string autoSavePath
)
Visual Basic
Public Function IndexOfAutoSave ( _
    autoSavePath As String _
) As Integer

Parameters

autoSavePath
Type: System..::..String
The full path (directory, filename and extension) of the autosave file to test against.

Return Value

The index of the document that matches the given autosave path or -1 if no document match is found.

See Also

GH_DocumentServer Class
Grasshopper.Kernel Namespace


NextAvailableDocument Method

[image]

Grasshopper SDK
GH_DocumentServer..::..NextAvailableDocument Method
GH_DocumentServer Class See Also Send Feedback
Gets the most important, non-active document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Document NextAvailableDocument()
Visual Basic
Public Function NextAvailableDocument As GH_Document

See Also

GH_DocumentServer Class
Grasshopper.Kernel Namespace


PromoteDocument Method

[image]

Grasshopper SDK
GH_DocumentServer..::..PromoteDocument Method
GH_DocumentServer Class See Also Send Feedback
Push a document to the top of the list, meaning it will be first in line when a new default document needs to be selected.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void PromoteDocument(
    GH_Document document
)
Visual Basic
Public Sub PromoteDocument ( _
    document As GH_Document _
)

Parameters

document
Type: Grasshopper.Kernel..::..GH_Document
Document to promote.

See Also

GH_DocumentServer Class
Grasshopper.Kernel Namespace


RemoveAllDocuments Method

[image]

Grasshopper SDK
GH_DocumentServer..::..RemoveAllDocuments Method
GH_DocumentServer Class See Also Send Feedback
Remove all documents in the global list.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RemoveAllDocuments()
Visual Basic
Public Sub RemoveAllDocuments

See Also

GH_DocumentServer Class
Grasshopper.Kernel Namespace


RemoveDocument Method

[image]

Grasshopper SDK
GH_DocumentServer..::..RemoveDocument Method
GH_DocumentServer Class See Also Send Feedback
Removes a specific document from the global list. If the document isn't registered nothing will happen. If the document is owned by an IGH_DocumentOwner, the owner will be informed of the removal.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RemoveDocument(
    GH_Document document
)
Visual Basic
Public Sub RemoveDocument ( _
    document As GH_Document _
)

Parameters

document
Type: Grasshopper.Kernel..::..GH_Document
Document to remove.

See Also

GH_DocumentServer Class
Grasshopper.Kernel Namespace


SafeRemoveDocument Method

[image]

Grasshopper SDK
GH_DocumentServer..::..SafeRemoveDocument Method
GH_DocumentServer Class See Also Send Feedback
Remove a document correctly from the server. This method shows user-interface prompts if there is unsaved data and will also save if needed.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool SafeRemoveDocument(
    GH_Document document
)
Visual Basic
Public Function SafeRemoveDocument ( _
    document As GH_Document _
) As Boolean

Parameters

document
Type: Grasshopper.Kernel..::..GH_Document
Document to remove.

Return Value

True if the document was removed, false if otherwise.

See Also

GH_DocumentServer Class
Grasshopper.Kernel Namespace


GH_DocumentServer Properties

[image] [image]

Grasshopper SDK
GH_DocumentServer Properties
GH_DocumentServer Class See Also Send Feedback

The GH_DocumentServer type exposes the following members.

Properties

 | Name | Description
Public property | Document | Gets the document at the given index.
Public property | DocumentCount | Gets the number of documents stored in the global list.
Public property | DocumentNames | Gets a string collection containing all the names of the documents in the global list.
Public property | ModifiedDocumentCount | Gets the total number of modified (unsaved) documents.

See Also

GH_DocumentServer Class
Grasshopper.Kernel Namespace


Document Property

[image]

Grasshopper SDK
GH_DocumentServer..::..Document Property
GH_DocumentServer Class See Also Send Feedback
Gets the document at the given index.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Document this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Document ( _
    index As Integer _
) As GH_Document
    Get

Parameters

index
Type: System..::..Int32
Index of document to retrieve.

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DocumentServer.Document(System.Int32)"]

See Also

GH_DocumentServer Class
Grasshopper.Kernel Namespace


DocumentCount Property

[image]

Grasshopper SDK
GH_DocumentServer..::..DocumentCount Property
GH_DocumentServer Class See Also Send Feedback
Gets the number of documents stored in the global list.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int DocumentCount { get; }
Visual Basic
Public ReadOnly Property DocumentCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DocumentServer.DocumentCount"]

See Also

GH_DocumentServer Class
Grasshopper.Kernel Namespace


DocumentNames Property

[image]

Grasshopper SDK
GH_DocumentServer..::..DocumentNames Property
GH_DocumentServer Class See Also Send Feedback
Gets a string collection containing all the names of the documents in the global list.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<string> DocumentNames { get; }
Visual Basic
Public ReadOnly Property DocumentNames As List(Of String)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DocumentServer.DocumentNames"]

See Also

GH_DocumentServer Class
Grasshopper.Kernel Namespace


ModifiedDocumentCount Property

[image]

Grasshopper SDK
GH_DocumentServer..::..ModifiedDocumentCount Property
GH_DocumentServer Class See Also Send Feedback
Gets the total number of modified (unsaved) documents.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int ModifiedDocumentCount { get; }
Visual Basic
Public ReadOnly Property ModifiedDocumentCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DocumentServer.ModifiedDocumentCount"]

See Also

GH_DocumentServer Class
Grasshopper.Kernel Namespace


GH_DocumentServer Events

[image] [image]

Grasshopper SDK
GH_DocumentServer Events
GH_DocumentServer Class See Also Send Feedback

The GH_DocumentServer type exposes the following members.

Events

 | Name | Description
Public event | DocumentAdded |
Public event | DocumentRemoved |

See Also

GH_DocumentServer Class
Grasshopper.Kernel Namespace


DocumentAdded Event

[image]

Grasshopper SDK
GH_DocumentServer..::..DocumentAdded Event
GH_DocumentServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_DocumentServer..::..DocumentAddedEventHandler DocumentAdded
Visual Basic
Public Event DocumentAdded As GH_DocumentServer..::..DocumentAddedEventHandler

See Also

GH_DocumentServer Class
Grasshopper.Kernel Namespace


DocumentRemoved Event

[image]

Grasshopper SDK
GH_DocumentServer..::..DocumentRemoved Event
GH_DocumentServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public event GH_DocumentServer..::..DocumentRemovedEventHandler DocumentRemoved
Visual Basic
Public Event DocumentRemoved As GH_DocumentServer..::..DocumentRemovedEventHandler

See Also

GH_DocumentServer Class
Grasshopper.Kernel Namespace


GH_DocumentServer.DocumentAddedEventHandler Delegate

[image]

Grasshopper SDK
GH_DocumentServer..::..DocumentAddedEventHandler Delegate
GH_DocumentServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void DocumentAddedEventHandler(
    GH_DocumentServer sender,
    GH_Document doc
)
Visual Basic
Public Delegate Sub DocumentAddedEventHandler ( _
    sender As GH_DocumentServer, _
    doc As GH_Document _
)

Parameters

sender
Type: Grasshopper.Kernel..::..GH_DocumentServer
doc
Type: Grasshopper.Kernel..::..GH_Document

See Also

Grasshopper.Kernel Namespace


GH_DocumentServer.DocumentRemovedEventHandler Delegate

[image]

Grasshopper SDK
GH_DocumentServer..::..DocumentRemovedEventHandler Delegate
GH_DocumentServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void DocumentRemovedEventHandler(
    GH_DocumentServer sender,
    GH_Document doc
)
Visual Basic
Public Delegate Sub DocumentRemovedEventHandler ( _
    sender As GH_DocumentServer, _
    doc As GH_Document _
)

Parameters

sender
Type: Grasshopper.Kernel..::..GH_DocumentServer
doc
Type: Grasshopper.Kernel..::..GH_Document

See Also

Grasshopper.Kernel Namespace


GH_DocumentSettings Enumeration

[image]

Grasshopper SDK
GH_DocumentSettings Enumeration
See Also Send Feedback
Enumerates all possible types of settings for a GH_Document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_DocumentSettings
Visual Basic
Public Enumeration GH_DocumentSettings

Members

Member name | Value | Description
Preview | 0 |
Properties | 1 |

See Also

Grasshopper.Kernel Namespace


GH_DocumentTree Class

[image]

Grasshopper SDK
GH_DocumentTree Class
Members See Also Send Feedback
Represents a hierarchical tree of documents that are subsidiary to one another.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_DocumentTree : IGH_DebugDescription
Visual Basic
Public Class GH_DocumentTree _
    Implements IGH_DebugDescription

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_DocumentTree

See Also

GH_DocumentTree Members
Grasshopper.Kernel Namespace


GH_DocumentTree Members

[image] [image]

Grasshopper SDK
GH_DocumentTree Members
GH_DocumentTree Class Constructors Methods Properties See Also Send Feedback

The GH_DocumentTree type exposes the following members.

Constructors

 | Name | Description
Public method | GH_DocumentTree | Create a new document tree.

Methods

 | Name | Description
Public method | AppendToDebugLog |

Properties

 | Name | Description
Public property | FlatCollection | Gets a flat collection of all documents. The most subsidiary documents are at the start of the collection.
Public property | Root | Gets the root node for this document.
Public property | RootDocument | Gets the document inside the root node of this tree.

See Also

GH_DocumentTree Class
Grasshopper.Kernel Namespace


GH_DocumentTree Constructor

[image]

Grasshopper SDK
GH_DocumentTree Constructor
GH_DocumentTree Class See Also Send Feedback
Create a new document tree.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_DocumentTree(
    GH_Document root
)
Visual Basic
Public Sub New ( _
    root As GH_Document _
)

Parameters

root
Type: Grasshopper.Kernel..::..GH_Document
Root document.

See Also

GH_DocumentTree Class
Grasshopper.Kernel Namespace


GH_DocumentTree Methods

[image] [image]

Grasshopper SDK
GH_DocumentTree Methods
GH_DocumentTree Class See Also Send Feedback

The GH_DocumentTree type exposes the following members.

Methods

 | Name | Description
Public method | AppendToDebugLog |

See Also

GH_DocumentTree Class
Grasshopper.Kernel Namespace


AppendToDebugLog Method

[image]

Grasshopper SDK
GH_DocumentTree..::..AppendToDebugLog Method
GH_DocumentTree Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AppendToDebugLog(
    GH_DebugDescriptionWriter writer
)
Visual Basic
Public Sub AppendToDebugLog ( _
    writer As GH_DebugDescriptionWriter _
)

Parameters

writer
Type: Grasshopper.Kernel..::..GH_DebugDescriptionWriter

Implements

IGH_DebugDescription..::..AppendToDebugLog(GH_DebugDescriptionWriter)

See Also

GH_DocumentTree Class
Grasshopper.Kernel Namespace


GH_DocumentTree Properties

[image] [image]

Grasshopper SDK
GH_DocumentTree Properties
GH_DocumentTree Class See Also Send Feedback

The GH_DocumentTree type exposes the following members.

Properties

 | Name | Description
Public property | FlatCollection | Gets a flat collection of all documents. The most subsidiary documents are at the start of the collection.
Public property | Root | Gets the root node for this document.
Public property | RootDocument | Gets the document inside the root node of this tree.

See Also

GH_DocumentTree Class
Grasshopper.Kernel Namespace


FlatCollection Property

[image]

Grasshopper SDK
GH_DocumentTree..::..FlatCollection Property
GH_DocumentTree Class See Also Send Feedback
Gets a flat collection of all documents. The most subsidiary documents are at the start of the collection.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IEnumerable<GH_Document> FlatCollection { get; }
Visual Basic
Public ReadOnly Property FlatCollection As IEnumerable(Of GH_Document)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DocumentTree.FlatCollection"]

See Also

GH_DocumentTree Class
Grasshopper.Kernel Namespace


Root Property

[image]

Grasshopper SDK
GH_DocumentTree..::..Root Property
GH_DocumentTree Class See Also Send Feedback
Gets the root node for this document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_DocumentTreeNode Root { get; }
Visual Basic
Public ReadOnly Property Root As GH_DocumentTreeNode
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DocumentTree.Root"]

See Also

GH_DocumentTree Class
Grasshopper.Kernel Namespace


RootDocument Property

[image]

Grasshopper SDK
GH_DocumentTree..::..RootDocument Property
GH_DocumentTree Class See Also Send Feedback
Gets the document inside the root node of this tree.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Document RootDocument { get; }
Visual Basic
Public ReadOnly Property RootDocument As GH_Document
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DocumentTree.RootDocument"]

See Also

GH_DocumentTree Class
Grasshopper.Kernel Namespace


GH_DocumentTreeNode Class

[image]

Grasshopper SDK
GH_DocumentTreeNode Class
Members See Also Send Feedback
Represents a single node in a document tree.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_DocumentTreeNode
Visual Basic
Public Class GH_DocumentTreeNode

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_DocumentTreeNode

See Also

GH_DocumentTreeNode Members
Grasshopper.Kernel Namespace


GH_DocumentTreeNode Members

[image] [image]

Grasshopper SDK
GH_DocumentTreeNode Members
GH_DocumentTreeNode Class Constructors Properties See Also Send Feedback

The GH_DocumentTreeNode type exposes the following members.

Constructors

 | Name | Description
Public method | GH_DocumentTreeNode | Create a new node instance.

Properties

 | Name | Description
Public property | Document | Gets the document at this node.
Public property | SubNodes | Gets a collection of subnodes.

See Also

GH_DocumentTreeNode Class
Grasshopper.Kernel Namespace


GH_DocumentTreeNode Constructor

[image]

Grasshopper SDK
GH_DocumentTreeNode Constructor
GH_DocumentTreeNode Class See Also Send Feedback
Create a new node instance.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_DocumentTreeNode(
    GH_Document node
)
Visual Basic
Public Sub New ( _
    node As GH_Document _
)

Parameters

node
Type: Grasshopper.Kernel..::..GH_Document
Node base document.

See Also

GH_DocumentTreeNode Class
Grasshopper.Kernel Namespace


GH_DocumentTreeNode Properties

[image] [image]

Grasshopper SDK
GH_DocumentTreeNode Properties
GH_DocumentTreeNode Class See Also Send Feedback

The GH_DocumentTreeNode type exposes the following members.

Properties

 | Name | Description
Public property | Document | Gets the document at this node.
Public property | SubNodes | Gets a collection of subnodes.

See Also

GH_DocumentTreeNode Class
Grasshopper.Kernel Namespace


Document Property

[image]

Grasshopper SDK
GH_DocumentTreeNode..::..Document Property
GH_DocumentTreeNode Class See Also Send Feedback
Gets the document at this node.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Document Document { get; }
Visual Basic
Public ReadOnly Property Document As GH_Document
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DocumentTreeNode.Document"]

See Also

GH_DocumentTreeNode Class
Grasshopper.Kernel Namespace


SubNodes Property

[image]

Grasshopper SDK
GH_DocumentTreeNode..::..SubNodes Property
GH_DocumentTreeNode Class See Also Send Feedback
Gets a collection of subnodes.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<GH_DocumentTreeNode> SubNodes { get; }
Visual Basic
Public ReadOnly Property SubNodes As List(Of GH_DocumentTreeNode)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DocumentTreeNode.SubNodes"]

See Also

GH_DocumentTreeNode Class
Grasshopper.Kernel Namespace


GH_DocUndoEventArgs Class

[image]

Grasshopper SDK
GH_DocUndoEventArgs Class
Members See Also Send Feedback
These arguments are passed along with UndoStateChanged events on GH_Document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_DocUndoEventArgs : EventArgs
Visual Basic
Public Class GH_DocUndoEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Grasshopper.Kernel..::..GH_DocUndoEventArgs

See Also

GH_DocUndoEventArgs Members
Grasshopper.Kernel Namespace


GH_DocUndoEventArgs Members

[image] [image]

Grasshopper SDK
GH_DocUndoEventArgs Members
GH_DocUndoEventArgs Class Properties See Also Send Feedback

The GH_DocUndoEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Document | Gets the document that raised the event.
Public property | Operation | Gets the type of undo operation that caused this event.
Public property | Record | Gets the UndoRecord pertaining to this event. Not every Event type has a single record associated with it so be sure to test for null.

See Also

GH_DocUndoEventArgs Class
Grasshopper.Kernel Namespace


GH_DocUndoEventArgs Properties

[image] [image]

Grasshopper SDK
GH_DocUndoEventArgs Properties
GH_DocUndoEventArgs Class See Also Send Feedback

The GH_DocUndoEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Document | Gets the document that raised the event.
Public property | Operation | Gets the type of undo operation that caused this event.
Public property | Record | Gets the UndoRecord pertaining to this event. Not every Event type has a single record associated with it so be sure to test for null.

See Also

GH_DocUndoEventArgs Class
Grasshopper.Kernel Namespace


Document Property

[image]

Grasshopper SDK
GH_DocUndoEventArgs..::..Document Property
GH_DocUndoEventArgs Class See Also Send Feedback
Gets the document that raised the event.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Document Document { get; }
Visual Basic
Public ReadOnly Property Document As GH_Document
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DocUndoEventArgs.Document"]

See Also

GH_DocUndoEventArgs Class
Grasshopper.Kernel Namespace


Operation Property

[image]

Grasshopper SDK
GH_DocUndoEventArgs..::..Operation Property
GH_DocUndoEventArgs Class See Also Send Feedback
Gets the type of undo operation that caused this event.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_UndoOperation Operation { get; }
Visual Basic
Public ReadOnly Property Operation As GH_UndoOperation
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DocUndoEventArgs.Operation"]

See Also

GH_DocUndoEventArgs Class
Grasshopper.Kernel Namespace


Record Property

[image]

Grasshopper SDK
GH_DocUndoEventArgs..::..Record Property
GH_DocUndoEventArgs Class See Also Send Feedback
Gets the UndoRecord pertaining to this event. Not every Event type has a single record associated with it so be sure to test for null.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_UndoRecord Record { get; }
Visual Basic
Public ReadOnly Property Record As GH_UndoRecord
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_DocUndoEventArgs.Record"]

See Also

GH_DocUndoEventArgs Class
Grasshopper.Kernel Namespace


GH_Exposure Enumeration

[image]

Grasshopper SDK
GH_Exposure Enumeration
See Also Send Feedback
Lists the different kinds of GUI exposure an object can have.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
[FlagsAttribute]
public enum GH_Exposure
Visual Basic
<FlagsAttribute> _
Public Enumeration GH_Exposure

Members

Member name | Value | Description
hidden | -1 | Do not expose the object anywhere. This is useful for legacy components.
primary | 2 | Expose the object in the first section on the toolbar.
secondary | 4 | Expose the object in the second section on the toolbar.
tertiary | 8 | Expose the object in the third section on the toolbar.
quarternary | 16 | Expose the object in the fourth section on the toolbar.
quinary | 32 | Expose the object in the fifth section on the toolbar.
senary | 64 | Expose the object in the sixth section on the toolbar.
septenary | 128 | Expose the object in the seventh section on the toolbar.
dropdown | 65536 | Obsolete. Only expose the object on the ribbon dropdown. Use this option for components which are unlikely to be used often. You can combine dropdown with any of the other flags (except hidden) to get both dropdown limitations and section control.
obscure | 65536 | Mark the object as obscure. Use this option for components which are unlikely to be used often. You must combine obscure with one of the other flags (except hidden). Objects which are marked as Obscure will be the first to disappear when a ribbon resizes and they will always appear at the end of a panel.

See Also

Grasshopper.Kernel Namespace


GH_ExternalFile Class

[image]

Grasshopper SDK
GH_ExternalFile Class
Members See Also Send Feedback
Represents information about external files to be loaded.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_ExternalFile
Visual Basic
Public Class GH_ExternalFile

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_ExternalFile

See Also

GH_ExternalFile Members
Grasshopper.Kernel Namespace


GH_ExternalFile Members

[image] [image]

Grasshopper SDK
GH_ExternalFile Members
GH_ExternalFile Class Constructors Methods Properties See Also Send Feedback

The GH_ExternalFile type exposes the following members.

Constructors

 | Name | Description
Public method | GH_ExternalFile | Create a new instance of the file info class

Methods

 | Name | Description
Public method | IsIdenticalTo | Compares two files for content. If the size and the hash or the other file are equal to this one, the files are considered identical.

Properties

 | Name | Description
Public property | FileHash | Gets the file hash.
Public property | FileName | Gets the file name (without the extension).
Public property | FilePath | Gets the file path.
Public property | FileSize | Gets the file size (in bytes).
Public property | FileType | Gets the file type as indicated by the extension.

See Also

GH_ExternalFile Class
Grasshopper.Kernel Namespace


GH_ExternalFile Constructor

[image]

Grasshopper SDK
GH_ExternalFile Constructor
GH_ExternalFile Class See Also Send Feedback
Create a new instance of the file info class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ExternalFile(
    string path
)
Visual Basic
Public Sub New ( _
    path As String _
)

Parameters

path
Type: System..::..String

See Also

GH_ExternalFile Class
Grasshopper.Kernel Namespace


GH_ExternalFile Methods

[image] [image]

Grasshopper SDK
GH_ExternalFile Methods
GH_ExternalFile Class See Also Send Feedback

The GH_ExternalFile type exposes the following members.

Methods

 | Name | Description
Public method | IsIdenticalTo | Compares two files for content. If the size and the hash or the other file are equal to this one, the files are considered identical.

See Also

GH_ExternalFile Class
Grasshopper.Kernel Namespace


IsIdenticalTo Method

[image]

Grasshopper SDK
GH_ExternalFile..::..IsIdenticalTo Method
GH_ExternalFile Class See Also Send Feedback
Compares two files for content. If the size and the hash or the other file are equal to this one, the files are considered identical.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsIdenticalTo(
    GH_ExternalFile other
)
Visual Basic
Public Function IsIdenticalTo ( _
    other As GH_ExternalFile _
) As Boolean

Parameters

other
Type: Grasshopper.Kernel..::..GH_ExternalFile

See Also

GH_ExternalFile Class
Grasshopper.Kernel Namespace


GH_ExternalFile Properties

[image] [image]

Grasshopper SDK
GH_ExternalFile Properties
GH_ExternalFile Class See Also Send Feedback

The GH_ExternalFile type exposes the following members.

Properties

 | Name | Description
Public property | FileHash | Gets the file hash.
Public property | FileName | Gets the file name (without the extension).
Public property | FilePath | Gets the file path.
Public property | FileSize | Gets the file size (in bytes).
Public property | FileType | Gets the file type as indicated by the extension.

See Also

GH_ExternalFile Class
Grasshopper.Kernel Namespace


FileHash Property

[image]

Grasshopper SDK
GH_ExternalFile..::..FileHash Property
GH_ExternalFile Class See Also Send Feedback
Gets the file hash.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid FileHash { get; }
Visual Basic
Public ReadOnly Property FileHash As Guid
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ExternalFile.FileHash"]

See Also

GH_ExternalFile Class
Grasshopper.Kernel Namespace


FileName Property

[image]

Grasshopper SDK
GH_ExternalFile..::..FileName Property
GH_ExternalFile Class See Also Send Feedback
Gets the file name (without the extension).

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string FileName { get; }
Visual Basic
Public ReadOnly Property FileName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ExternalFile.FileName"]

See Also

GH_ExternalFile Class
Grasshopper.Kernel Namespace


FilePath Property

[image]

Grasshopper SDK
GH_ExternalFile..::..FilePath Property
GH_ExternalFile Class See Also Send Feedback
Gets the file path.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string FilePath { get; }
Visual Basic
Public ReadOnly Property FilePath As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ExternalFile.FilePath"]

See Also

GH_ExternalFile Class
Grasshopper.Kernel Namespace


FileSize Property

[image]

Grasshopper SDK
GH_ExternalFile..::..FileSize Property
GH_ExternalFile Class See Also Send Feedback
Gets the file size (in bytes).

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public long FileSize { get; }
Visual Basic
Public ReadOnly Property FileSize As Long
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ExternalFile.FileSize"]

See Also

GH_ExternalFile Class
Grasshopper.Kernel Namespace


FileType Property

[image]

Grasshopper SDK
GH_ExternalFile..::..FileType Property
GH_ExternalFile Class See Also Send Feedback
Gets the file type as indicated by the extension.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ExternalFileType FileType { get; }
Visual Basic
Public ReadOnly Property FileType As GH_ExternalFileType
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ExternalFile.FileType"]

See Also

GH_ExternalFile Class
Grasshopper.Kernel Namespace


GH_ExternalFileType Enumeration

[image]

Grasshopper SDK
GH_ExternalFileType Enumeration
See Also Send Feedback
Enumerates the possible external files that Grasshopper is interested in.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_ExternalFileType
Visual Basic
Public Enumeration GH_ExternalFileType

Members

Member name | Value | Description
Unknown | 0 | Unknown (invalid) file type.
Assembly | 1 | File represents a GHA assembly.
UserObject | 2 | File represents a GHUSER archive.
Cluster | 3 | File represents a GHCLUSTER archive.

See Also

Grasshopper.Kernel Namespace


GH_FileSystemEventServer Class

[image]

Grasshopper SDK
GH_FileSystemEventServer Class
Members See Also Send Feedback
Provides a easy-to-use way to keep tabs on files.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class GH_FileSystemEventServer
Visual Basic
Public NotInheritable Class GH_FileSystemEventServer

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_FileSystemEventServer

See Also

GH_FileSystemEventServer Members
Grasshopper.Kernel Namespace


GH_FileSystemEventServer Members

[image] [image]

Grasshopper SDK
GH_FileSystemEventServer Members
GH_FileSystemEventServer Class Methods Properties See Also Send Feedback

The GH_FileSystemEventServer type exposes the following members.

Methods

Name | Description
AddWatcher | Add a new file watcher instance.
RemoveWatcher(Object) | Remove all watchers that are linked to a specific object.
RemoveWatcher(Object, String) | Remove all watchers that are linked to a specific object and a specific file path.

Properties

Name | Description
AllPaths | Gets a list of all the paths currently under surveillance.

See Also

GH_FileSystemEventServer Class
Grasshopper.Kernel Namespace


GH_FileSystemEventServer Methods

[image] [image]

Grasshopper SDK
GH_FileSystemEventServer Methods
GH_FileSystemEventServer Class See Also Send Feedback

The GH_FileSystemEventServer type exposes the following members.

Methods

Name | Description
AddWatcher | Add a new file watcher instance.
RemoveWatcher(Object) | Remove all watchers that are linked to a specific object.
RemoveWatcher(Object, String) | Remove all watchers that are linked to a specific object and a specific file path.

See Also

GH_FileSystemEventServer Class
Grasshopper.Kernel Namespace


AddWatcher Method

[image]

Grasshopper SDK
GH_FileSystemEventServer..::..AddWatcher Method
GH_FileSystemEventServer Class See Also Send Feedback
Add a new file watcher instance.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void AddWatcher(
    Object owner,
    string path,
    GH_FileSystemEventServer..::..FileEvent callback
)
Visual Basic
Public Shared Sub AddWatcher ( _
    owner As Object, _
    path As String, _
    callback As GH_FileSystemEventServer..::..FileEvent _
)

Parameters

owner
Type: System..::..Object
The object that owns this watcher.
path
Type: System..::..String
The path of the file to watch.
callback
Type: Grasshopper.Kernel..::..GH_FileSystemEventServer..::..FileEvent
Callback delegate used during file changes.

See Also

GH_FileSystemEventServer Class
Grasshopper.Kernel Namespace


RemoveWatcher Method

[image] [image]

Grasshopper SDK
GH_FileSystemEventServer..::..RemoveWatcher Method
GH_FileSystemEventServer Class See Also Send Feedback

Overload List

Name | Description
RemoveWatcher(Object) | Remove all watchers that are linked to a specific object.
RemoveWatcher(Object, String) | Remove all watchers that are linked to a specific object and a specific file path.

See Also

GH_FileSystemEventServer Class
GH_FileSystemEventServer Members
Grasshopper.Kernel Namespace


RemoveWatcher Method (Object)

[image]

Grasshopper SDK
GH_FileSystemEventServer..::..RemoveWatcher Method (Object)
GH_FileSystemEventServer Class See Also Send Feedback
Remove all watchers that are linked to a specific object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void RemoveWatcher(
    Object owner
)
Visual Basic
Public Shared Sub RemoveWatcher ( _
    owner As Object _
)

Parameters

owner
Type: System..::..Object

See Also

GH_FileSystemEventServer Class
RemoveWatcher Overload
Grasshopper.Kernel Namespace


RemoveWatcher Method (Object, String)

[image]

Grasshopper SDK
GH_FileSystemEventServer..::..RemoveWatcher Method (Object, String)
GH_FileSystemEventServer Class See Also Send Feedback
Remove all watchers that are linked to a specific object and a specific file path.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void RemoveWatcher(
    Object owner,
    string path
)
Visual Basic
Public Shared Sub RemoveWatcher ( _
    owner As Object, _
    path As String _
)

Parameters

owner
Type: System..::..Object
path
Type: System..::..String

See Also

GH_FileSystemEventServer Class
RemoveWatcher Overload
Grasshopper.Kernel Namespace


GH_FileSystemEventServer Properties

[image] [image]

Grasshopper SDK
GH_FileSystemEventServer Properties
GH_FileSystemEventServer Class See Also Send Feedback

The GH_FileSystemEventServer type exposes the following members.

Properties

Name | Description
AllPaths | Gets a list of all the paths currently under surveillance.

See Also

GH_FileSystemEventServer Class
Grasshopper.Kernel Namespace


AllPaths Property

[image]

Grasshopper SDK
GH_FileSystemEventServer..::..AllPaths Property
GH_FileSystemEventServer Class See Also Send Feedback
Gets a list of all the paths currently under surveillance.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static IEnumerable<string> AllPaths { get; }
Visual Basic
Public Shared ReadOnly Property AllPaths As IEnumerable(Of String)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_FileSystemEventServer.AllPaths"]

See Also

GH_FileSystemEventServer Class
Grasshopper.Kernel Namespace


GH_FileSystemEventServer.FileEvent Delegate

[image]

Grasshopper SDK
GH_FileSystemEventServer..::..FileEvent Delegate
GH_FileSystemEventServer Class See Also Send Feedback
This delegate is called when changes to a certain file occur.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void FileEvent(
    string path
)
Visual Basic
Public Delegate Sub FileEvent ( _
    path As String _
)

Parameters

path
Type: System..::..String
The path of the file involved.

See Also

Grasshopper.Kernel Namespace


GH_FileWatcher Class

[image]

Grasshopper SDK
GH_FileWatcher Class
Members See Also Send Feedback
Provides easy mechanisms to monitor changes to the local File System.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_FileWatcher : IDisposable
Visual Basic
Public Class GH_FileWatcher _
    Implements IDisposable

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_FileWatcher

See Also

GH_FileWatcher Members
Grasshopper.Kernel Namespace


GH_FileWatcher Members

[image] [image]

Grasshopper SDK
GH_FileWatcher Members
GH_FileWatcher Class Methods Properties See Also Send Feedback

The GH_FileWatcher type exposes the following members.

Methods

 | Name | Description
 | CreateDirectoryWatcher(String, String, GH_FileWatcherEvents, GH_FileWatcher..::..FileChanged) | Create a new FileSystem Watcher object aimed at a specific file.
 | CreateDirectoryWatcher(String, String, GH_FileWatcherEvents, GH_FileWatcher..::..FileChangedSimple) | Create a new FileSystem Watcher object aimed at a specific file.
 | CreateFileWatcher(String, GH_FileWatcherEvents, GH_FileWatcher..::..FileChanged) | Create a new FileSystem Watcher object aimed at a specific file.
 | CreateFileWatcher(String, GH_FileWatcherEvents, GH_FileWatcher..::..FileChangedSimple) | Create a new FileSystem Watcher object aimed at a specific file.
Public method | Dispose()()()() | Releases all resources used by the GH_FileWatcher
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the GH_FileWatcher and optionally releases the managed resources
Public method | SetCustomUIThread(Control) | If you want to override the default Invoke behaviour, you must set InvokeOnDefaultThread to False and supply either a custom Control or a Form.
Public method | SetCustomUIThread(Form) | If you want to override the default Invoke behaviour, you must set InvokeOnDefaultThread to False and supply either a custom Control or a Form.

Properties

 | Name | Description
Public property | Active | Gets or sets the active flag on this watcher.
Public property | Buffer | Gets or sets the time during which events are buffered. If multiple events for the same file occur within the buffered timespan, they will be merged into one event.
Public property | InvokeOnDefaultThread | Gets or sets invoke behaviour for events. If true, then the event delegate is called via the Grasshopper main UI thread. This is almost always what you need.
Public property | IsDisposed |
Public property | Path | Gets the file or folder path currently being watched.

See Also

GH_FileWatcher Class
Grasshopper.Kernel Namespace


GH_FileWatcher Methods

[image] [image]

Grasshopper SDK
GH_FileWatcher Methods
GH_FileWatcher Class See Also Send Feedback

Methods

 | Name | Description
 | CreateDirectoryWatcher(String, String, GH_FileWatcherEvents, GH_FileWatcher..::..FileChanged) | Create a new FileSystem Watcher object aimed at a specific file.
 | CreateDirectoryWatcher(String, String, GH_FileWatcherEvents, GH_FileWatcher..::..FileChangedSimple) | Create a new FileSystem Watcher object aimed at a specific file.
 | CreateFileWatcher(String, GH_FileWatcherEvents, GH_FileWatcher..::..FileChanged) | Create a new FileSystem Watcher object aimed at a specific file.
 | CreateFileWatcher(String, GH_FileWatcherEvents, GH_FileWatcher..::..FileChangedSimple) | Create a new FileSystem Watcher object aimed at a specific file.
Public method | Dispose()()()() |
Protected method | Dispose(Boolean) |
Public method | SetCustomUIThread(Control) | If you want to override the default Invoke behaviour, you must set InvokeOnDefaultThread to False and supply either a custom Control or a Form.
Public method | SetCustomUIThread(Form) | If you want to override the default Invoke behaviour, you must set InvokeOnDefaultThread to False and supply either a custom Control or a Form.

See Also

GH_FileWatcher Class
Grasshopper.Kernel Namespace


CreateDirectoryWatcher Method

[image] [image]

Grasshopper SDK
GH_FileWatcher..::..CreateDirectoryWatcher Method
GH_FileWatcher Class See Also Send Feedback

Overload List

Name | Description
CreateDirectoryWatcher(String, String, GH_FileWatcherEvents, GH_FileWatcher..::..FileChanged) | Create a new FileSystem Watcher object aimed at a specific file.
CreateDirectoryWatcher(String, String, GH_FileWatcherEvents, GH_FileWatcher..::..FileChangedSimple) | Create a new FileSystem Watcher object aimed at a specific file.

See Also

GH_FileWatcher Class
GH_FileWatcher Members
Grasshopper.Kernel Namespace


CreateDirectoryWatcher Method (String, String, GH_FileWatcherEvents, GH_FileWatcher.FileChanged)

[image]

Grasshopper SDK
GH_FileWatcher..::..CreateDirectoryWatcher Method (String, String, GH_FileWatcherEvents, GH_FileWatcher..::..FileChanged)
GH_FileWatcher Class See Also Send Feedback
Create a new FileSystem Watcher object aimed at a specific file.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_FileWatcher CreateDirectoryWatcher(
    string folderPath,
    string filter,
    GH_FileWatcherEvents events,
    GH_FileWatcher..::..FileChanged delegate
)
Visual Basic
Public Shared Function CreateDirectoryWatcher ( _
    folderPath As String, _
    filter As String, _
    events As GH_FileWatcherEvents, _
    delegate As GH_FileWatcher..::..FileChanged _
) As GH_FileWatcher

Parameters

folderPath
Type: System..::..String
Folder to watch.
filter
Type: System..::..String
Filter string for filenames.
events
Type: Grasshopper.Kernel..::..GH_FileWatcherEvents
Events to watch for.
delegate
Type: Grasshopper.Kernel..::..GH_FileWatcher..::..FileChanged
Callback delegate.

Return Value

A new filewatcher aimed at the specified folder.

See Also

GH_FileWatcher Class
CreateDirectoryWatcher Overload
Grasshopper.Kernel Namespace


CreateDirectoryWatcher Method (String, String, GH_FileWatcherEvents, GH_FileWatcher.FileChangedSimple)

[image]

Grasshopper SDK
GH_FileWatcher..::..CreateDirectoryWatcher Method (String, String, GH_FileWatcherEvents, GH_FileWatcher..::..FileChangedSimple)
GH_FileWatcher Class See Also Send Feedback
Create a new FileSystem Watcher object aimed at a specific file.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_FileWatcher CreateDirectoryWatcher(
    string folderPath,
    string filter,
    GH_FileWatcherEvents events,
    GH_FileWatcher..::..FileChangedSimple delegate
)
Visual Basic
Public Shared Function CreateDirectoryWatcher ( _
    folderPath As String, _
    filter As String, _
    events As GH_FileWatcherEvents, _
    delegate As GH_FileWatcher..::..FileChangedSimple _
) As GH_FileWatcher

Parameters

folderPath
Type: System..::..String
Folder to watch.
filter
Type: System..::..String
Filter string for filenames.
events
Type: Grasshopper.Kernel..::..GH_FileWatcherEvents
Events to watch for.
delegate
Type: Grasshopper.Kernel..::..GH_FileWatcher..::..FileChangedSimple
Callback delegate.

Return Value

A new filewatcher aimed at the specified folder.

See Also

GH_FileWatcher Class
CreateDirectoryWatcher Overload
Grasshopper.Kernel Namespace


CreateFileWatcher Method

[image] [image]

Grasshopper SDK
GH_FileWatcher..::..CreateFileWatcher Method
GH_FileWatcher Class See Also Send Feedback

Overload List

Name | Description
CreateFileWatcher(String, GH_FileWatcherEvents, GH_FileWatcher..::..FileChanged) | Create a new FileSystem Watcher object aimed at a specific file.
CreateFileWatcher(String, GH_FileWatcherEvents, GH_FileWatcher..::..FileChangedSimple) | Create a new FileSystem Watcher object aimed at a specific file.

See Also

GH_FileWatcher Class
GH_FileWatcher Members
Grasshopper.Kernel Namespace


CreateFileWatcher Method (String, GH_FileWatcherEvents, GH_FileWatcher.FileChanged)

[image]

Grasshopper SDK
GH_FileWatcher..::..CreateFileWatcher Method (String, GH_FileWatcherEvents, GH_FileWatcher..::..FileChanged)
GH_FileWatcher Class See Also Send Feedback
Create a new FileSystem Watcher object aimed at a specific file.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_FileWatcher CreateFileWatcher(
    string filePath,
    GH_FileWatcherEvents events,
    GH_FileWatcher..::..FileChanged delegate
)
Visual Basic
Public Shared Function CreateFileWatcher ( _
    filePath As String, _
    events As GH_FileWatcherEvents, _
    delegate As GH_FileWatcher..::..FileChanged _
) As GH_FileWatcher

Parameters

filePath
Type: System..::..String
File to watch.
events
Type: Grasshopper.Kernel..::..GH_FileWatcherEvents
Events to watch for.
delegate
Type: Grasshopper.Kernel..::..GH_FileWatcher..::..FileChanged
Callback delegate.

Return Value

A new filewatcher aimed at the specified file.

See Also

GH_FileWatcher Class
CreateFileWatcher Overload
Grasshopper.Kernel Namespace


CreateFileWatcher Method (String, GH_FileWatcherEvents, GH_FileWatcher.FileChangedSimple)

[image]

Grasshopper SDK
GH_FileWatcher..::..CreateFileWatcher Method (String, GH_FileWatcherEvents, GH_FileWatcher..::..FileChangedSimple)
GH_FileWatcher Class See Also Send Feedback
Create a new FileSystem Watcher object aimed at a specific file.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_FileWatcher CreateFileWatcher(
    string filePath,
    GH_FileWatcherEvents events,
    GH_FileWatcher..::..FileChangedSimple delegate
)
Visual Basic
Public Shared Function CreateFileWatcher ( _
    filePath As String, _
    events As GH_FileWatcherEvents, _
    delegate As GH_FileWatcher..::..FileChangedSimple _
) As GH_FileWatcher

Parameters

filePath
Type: System..::..String
File to watch.
events
Type: Grasshopper.Kernel..::..GH_FileWatcherEvents
Events to watch for.
delegate
Type: Grasshopper.Kernel..::..GH_FileWatcher..::..FileChangedSimple
Callback delegate.

Return Value

A new filewatcher aimed at the specified file.

See Also

GH_FileWatcher Class
CreateFileWatcher Overload
Grasshopper.Kernel Namespace


Dispose Method

[image] [image]

Grasshopper SDK
GH_FileWatcher..::..Dispose Method
GH_FileWatcher Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the GH_FileWatcher
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the GH_FileWatcher and optionally releases the managed resources

See Also

GH_FileWatcher Class
GH_FileWatcher Members
Grasshopper.Kernel Namespace


Dispose Method

[image]

Grasshopper SDK
GH_FileWatcher..::..Dispose Method
GH_FileWatcher Class See Also Send Feedback
Releases all resources used by the GH_FileWatcher

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose

Implements

IDisposable..::..Dispose()()()()

See Also

GH_FileWatcher Class
Dispose Overload
Grasshopper.Kernel Namespace


Dispose Method (Boolean)

[image]

Grasshopper SDK
GH_FileWatcher..::..Dispose Method (Boolean)
GH_FileWatcher Class See Also Send Feedback
Releases the unmanaged resources used by the GH_FileWatcher and optionally releases the managed resources

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected virtual void Dispose(
    bool disposing
)
Visual Basic
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

GH_FileWatcher Class
Dispose Overload
Grasshopper.Kernel Namespace


SetCustomUIThread Method

[image] [image]

Grasshopper SDK
GH_FileWatcher..::..SetCustomUIThread Method
GH_FileWatcher Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetCustomUIThread(Control) | If you want to override the default Invoke behaviour, you must set InvokeOnDefaultThread to False and supply either a custom Control or a Form.
Public method | SetCustomUIThread(Form) | If you want to override the default Invoke behaviour, you must set InvokeOnDefaultThread to False and supply either a custom Control or a Form.

See Also

GH_FileWatcher Class
GH_FileWatcher Members
Grasshopper.Kernel Namespace


SetCustomUIThread Method (Control)

[image]

Grasshopper SDK
GH_FileWatcher..::..SetCustomUIThread Method (Control)
GH_FileWatcher Class See Also Send Feedback
If you want to override the default Invoke behaviour, you must set InvokeOnDefaultThread to False and supply either a custom Control or a Form.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SetCustomUIThread(
    Control target
)
Visual Basic
Public Sub SetCustomUIThread ( _
    target As Control _
)

Parameters

target
Type: System.Windows.Forms..::..Control
GUI target object which will be used for Invoking File System Events.

See Also

GH_FileWatcher Class
SetCustomUIThread Overload
Grasshopper.Kernel Namespace


SetCustomUIThread Method (Form)

[image]

Grasshopper SDK
GH_FileWatcher..::..SetCustomUIThread Method (Form)
GH_FileWatcher Class See Also Send Feedback
If you want to override the default Invoke behaviour, you must set InvokeOnDefaultThread to False and supply either a custom Control or a Form.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SetCustomUIThread(
    Form target
)
Visual Basic
Public Sub SetCustomUIThread ( _
    target As Form _
)

Parameters

target
Type: System.Windows.Forms..::..Form
GUI target object which will be used for Invoking File System Events.

See Also

GH_FileWatcher Class
SetCustomUIThread Overload
Grasshopper.Kernel Namespace


GH_FileWatcher Properties

[image] [image]

Grasshopper SDK
GH_FileWatcher Properties
GH_FileWatcher Class See Also Send Feedback

The GH_FileWatcher type exposes the following members.

Properties

 | Name | Description
Public property | Active | Gets or sets the active flag on this watcher.
Public property | Buffer | Gets or sets the time during which events are buffered. If multiple events for the same file occur within the buffered timespan, they will be merged into one event.
Public property | InvokeOnDefaultThread | Gets or sets invoke behaviour for events. If true, then the event delegate is called via the Grasshopper main UI thread. This is almost always what you need.
Public property | IsDisposed |
Public property | Path | Gets the file or folder path currently being watched.

See Also

GH_FileWatcher Class
Grasshopper.Kernel Namespace


Active Property

[image]

Grasshopper SDK
GH_FileWatcher..::..Active Property
GH_FileWatcher Class See Also Send Feedback
Gets or sets the active flag on this watcher.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Active { get; set; }
Visual Basic
Public Property Active As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_FileWatcher.Active"]

See Also

GH_FileWatcher Class
Grasshopper.Kernel Namespace


Buffer Property

[image]

Grasshopper SDK
GH_FileWatcher..::..Buffer Property
GH_FileWatcher Class See Also Send Feedback
Gets or sets the time during which events are buffered. If multiple events for the same file occur within the buffered timespan, they will be merged into one event.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public TimeSpan Buffer { get; set; }
Visual Basic
Public Property Buffer As TimeSpan
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_FileWatcher.Buffer"]

See Also

GH_FileWatcher Class
Grasshopper.Kernel Namespace


InvokeOnDefaultThread Property

[image]

Grasshopper SDK
GH_FileWatcher..::..InvokeOnDefaultThread Property
GH_FileWatcher Class See Also Send Feedback
Gets or sets invoke behaviour for events. If true, then the event delegate is called via the Grasshopper main UI thread. This is almost always what you need.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool InvokeOnDefaultThread { get; set; }
Visual Basic
Public Property InvokeOnDefaultThread As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_FileWatcher.InvokeOnDefaultThread"]

See Also

GH_FileWatcher Class
Grasshopper.Kernel Namespace


IsDisposed Property

[image]

Grasshopper SDK
GH_FileWatcher..::..IsDisposed Property
GH_FileWatcher Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsDisposed { get; }
Visual Basic
Public ReadOnly Property IsDisposed As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_FileWatcher.IsDisposed"]

See Also

GH_FileWatcher Class
Grasshopper.Kernel Namespace


Path Property

[image]

Grasshopper SDK
GH_FileWatcher..::..Path Property
GH_FileWatcher Class See Also Send Feedback
Gets the file or folder path currently being watched.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Path { get; }
Visual Basic
Public ReadOnly Property Path As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_FileWatcher.Path"]

See Also

GH_FileWatcher Class
Grasshopper.Kernel Namespace


GH_FileWatcher.FileChanged Delegate

[image]

Grasshopper SDK
GH_FileWatcher..::..FileChanged Delegate
GH_FileWatcher Class See Also Send Feedback
Delegate method for file change callbacks.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void FileChanged(
    GH_FileWatcher sender,
    string filename,
    WatcherChangeTypes change
)
Visual Basic
Public Delegate Sub FileChanged ( _
    sender As GH_FileWatcher, _
    filename As String, _
    change As WatcherChangeTypes _
)

Parameters

sender
Type: Grasshopper.Kernel..::..GH_FileWatcher
FileWatcher that invoked the delegate.
filename
Type: System..::..String
Path to file that is being watched.
change
Type: System.IO..::..WatcherChangeTypes
The type of change that occured.

See Also

Grasshopper.Kernel Namespace


GH_FileWatcher.FileChangedSimple Delegate

[image]

Grasshopper SDK
GH_FileWatcher..::..FileChangedSimple Delegate
GH_FileWatcher Class See Also Send Feedback
Delegate method for file change callbacks.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void FileChangedSimple(
    string filename
)
Visual Basic
Public Delegate Sub FileChangedSimple ( _
    filename As String _
)

Parameters

filename
Type: System..::..String
Path to file that is being watched.

Remarks

See Also

Grasshopper.Kernel Namespace


GH_FileWatcherEvents Enumeration

[image]

Grasshopper SDK
GH_FileWatcherEvents Enumeration
See Also Send Feedback
Enumerates all possible file watcher events. These can be combined.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
[FlagsAttribute]
public enum GH_FileWatcherEvents
Visual Basic
<FlagsAttribute> _
Public Enumeration GH_FileWatcherEvents

Members

Member name | Value | Description
None | 0 | No events are specified.
Changed | 1 | The file is changed.
Renamed | 2 | The file is renamed.
Created | 4 | A file is created.
Deleted | 8 | A file is deleted.
All | 15 | Represents all possible events.

See Also

Grasshopper.Kernel Namespace


GH_Filter Enumeration

[image]

Grasshopper SDK
GH_Filter Enumeration
See Also Send Feedback
Enumerates all object Search filters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_Filter
Visual Basic
Public Enumeration GH_Filter

Members

Member name | Value | Description
DontCare | 0 | Property is ignored.
Include | 1 | Objects are requires to have this state in order to be included.
Exclude | 2 | Objects are not allowed to have this state in order to be included.

See Also

Grasshopper.Kernel Namespace


GH_FontServer Class

[image]

Grasshopper SDK
GH_FontServer Class
Members See Also Send Feedback
Maintains a collection of standard fonts and mays to measure them.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class GH_FontServer
Visual Basic
Public NotInheritable Class GH_FontServer

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_FontServer

See Also

GH_FontServer Members
Grasshopper.Kernel Namespace


GH_FontServer Members

[image] [image]

Grasshopper SDK
GH_FontServer Members
GH_FontServer Class Methods Properties Events See Also Send Feedback

The GH_FontServer type exposes the following members.

Methods

Name | Description
FontToString | Convert a font to a string.
MeasureString(String, Font) | Measure the size of a string
MeasureString(String, Font, SizeF) | Measure the size of a string
MeasureString(String, Font, Single) | Measure the size of a string
NewFont(Font, FontStyle) | Safe font constructor.
NewFont(Font, Single) | Safe font constructor.
NewFont(FontFamily, Single) | Safe font constructor.
NewFont(Font, Single, FontStyle) | Safe font constructor.
NewFont(FontFamily, Single, FontStyle) | Safe font constructor.
NewFont(String, Single, FontStyle) | High level function for Font creation. We've ran into loads of trouble in the past with missing Fonts. Never create a font directly via GDI+, always use this method.
StringToFont | Convert a font description string back into a font.
StringWidth(IEnumerable<(Of <<'(String>)>>), Font) | Measure the maximum width of a collection of strings
StringWidth(String, Font) | Measure the width of a string in pixels

Properties

Name | Description
Console | FontFamily.GenericMonospace, 10pt, regular
ConsoleSmall | FontFamily.GenericMonospace, 8pt, regular
FamilyConsole | Gets or sets the FontFamily used for monospaced fonts in Grasshopper.
FamilyScript | Gets or sets the FontFamily used for scripted fonts in Grasshopper.
FamilyStandard | Gets or sets the FontFamily used for standard fonts in Grasshopper.
Large | SystemFonts.CaptionFont, 10pt, bold
Script | FontFamily.GenericSansSerif, 10pt, italic
ScriptSmall | FontFamily.GenericSansSerif, 8pt, italic
Small | SystemFonts.CaptionFont, 6pt, regular
Standard | SystemFonts.CaptionFont, 8pt, regular
StandardBold | SystemFonts.CaptionFont, 8pt, bold
StandardItalic | SystemFonts.CaptionFont, 8pt, italic

Events

Name | Description
ConsoleFamilyChanged | Raised whenever the MonospacedFamily is changed.
ScriptFamilyChanged | Raised whenever the ScriptFamily is changed.
StandardFamilyChanged | Raised whenever the StandardFamily is changed.

See Also

GH_FontServer Class
Grasshopper.Kernel Namespace


GH_FontServer Methods

[image] [image]

Grasshopper SDK
GH_FontServer Methods
GH_FontServer Class See Also Send Feedback

The GH_FontServer type exposes the following members.

Methods

Name | Description
FontToString | Convert a font to a string.
MeasureString(String, Font) | Measure the size of a string
MeasureString(String, Font, SizeF) | Measure the size of a string
MeasureString(String, Font, Single) | Measure the size of a string
NewFont(Font, FontStyle) | Safe font constructor.
NewFont(Font, Single) | Safe font constructor.
NewFont(FontFamily, Single) | Safe font constructor.
NewFont(Font, Single, FontStyle) | Safe font constructor.
NewFont(FontFamily, Single, FontStyle) | Safe font constructor.
NewFont(String, Single, FontStyle) | High level function for Font creation. We've ran into loads of trouble in the past with missing Fonts. Never create a font directly via GDI+, always use this method.
StringToFont | Convert a font description string back into a font.
StringWidth(IEnumerable<(Of <<'(String>)>>), Font) | Measure the maximum width of a collection of strings
StringWidth(String, Font) | Measure the width of a string in pixels

See Also

GH_FontServer Class
Grasshopper.Kernel Namespace


FontToString Method

[image]

Grasshopper SDK
GH_FontServer..::..FontToString Method
GH_FontServer Class See Also Send Feedback
Convert a font to a string.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FontToString(
    Font font
)
Visual Basic
Public Shared Function FontToString ( _
    font As Font _
) As String

Parameters

font
Type: System.Drawing..::..Font
Font to convert.

Return Value

Strig representing the font family, size, bold and italic flags.

See Also

GH_FontServer Class
Grasshopper.Kernel Namespace


MeasureString Method

[image] [image]

Grasshopper SDK
GH_FontServer..::..MeasureString Method
GH_FontServer Class See Also Send Feedback

Overload List

Name | Description
MeasureString(String, Font) | Measure the size of a string
MeasureString(String, Font, SizeF) | Measure the size of a string
MeasureString(String, Font, Single) | Measure the size of a string

See Also

GH_FontServer Class
GH_FontServer Members
Grasshopper.Kernel Namespace


MeasureString Method (String, Font)

[image]

Grasshopper SDK
GH_FontServer..::..MeasureString Method (String, Font)
GH_FontServer Class See Also Send Feedback
Measure the size of a string

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Size MeasureString(
    string text,
    Font font
)
Visual Basic
Public Shared Function MeasureString ( _
    text As String, _
    font As Font _
) As Size

Parameters

text
Type: System..::..String
The string to measure
font
Type: System.Drawing..::..Font
The font to measure with

See Also

GH_FontServer Class
MeasureString Overload
Grasshopper.Kernel Namespace


MeasureString Method (String, Font, SizeF)

[image]

Grasshopper SDK
GH_FontServer..::..MeasureString Method (String, Font, SizeF)
GH_FontServer Class See Also Send Feedback
Measure the size of a string

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Size MeasureString(
    string text,
    Font font,
    SizeF iLayout
)
Visual Basic
Public Shared Function MeasureString ( _
    text As String, _
    font As Font, _
    iLayout As SizeF _
) As Size

Parameters

text
Type: System..::..String
The string to measure
font
Type: System.Drawing..::..Font
The font to measure with
iLayout
Type: System.Drawing..::..SizeF
The layout rectangle

See Also

GH_FontServer Class
MeasureString Overload
Grasshopper.Kernel Namespace


MeasureString Method (String, Font, Single)

[image]

Grasshopper SDK
GH_FontServer..::..MeasureString Method (String, Font, Single)
GH_FontServer Class See Also Send Feedback
Measure the size of a string

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Size MeasureString(
    string text,
    Font font,
    float maxwidth
)
Visual Basic
Public Shared Function MeasureString ( _
    text As String, _
    font As Font, _
    maxwidth As Single _
) As Size

Parameters

text
Type: System..::..String
The string to measure
font
Type: System.Drawing..::..Font
The font to measure with
maxwidth
Type: System..::..Single
The maximum width (in pixels) for the layout

See Also

GH_FontServer Class
MeasureString Overload
Grasshopper.Kernel Namespace


NewFont Method

[image] [image]

Grasshopper SDK
GH_FontServer..::..NewFont Method
GH_FontServer Class See Also Send Feedback

Overload List

Name | Description
NewFont(Font, FontStyle) | Safe font constructor.
NewFont(Font, Single) | Safe font constructor.
NewFont(FontFamily, Single) | Safe font constructor.
NewFont(Font, Single, FontStyle) | Safe font constructor.
NewFont(FontFamily, Single, FontStyle) | Safe font constructor.
NewFont(String, Single, FontStyle) | High level function for Font creation. We've ran into loads of trouble in the past with missing Fonts. Never create a font directly via GDI+, always use this method.

See Also

GH_FontServer Class
GH_FontServer Members
Grasshopper.Kernel Namespace


NewFont Method (Font, FontStyle)

[image]

Grasshopper SDK
GH_FontServer..::..NewFont Method (Font, FontStyle)
GH_FontServer Class See Also Send Feedback
Safe font constructor.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Font NewFont(
    Font font,
    FontStyle style
)
Visual Basic
Public Shared Function NewFont ( _
    font As Font, _
    style As FontStyle _
) As Font

Parameters

font
Type: System.Drawing..::..Font
Base font.
style
Type: System.Drawing..::..FontStyle
New style.

See Also

GH_FontServer Class
NewFont Overload
Grasshopper.Kernel Namespace


NewFont Method (Font, Single)

[image]

Grasshopper SDK
GH_FontServer..::..NewFont Method (Font, Single)
GH_FontServer Class See Also Send Feedback
Safe font constructor.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Font NewFont(
    Font font,
    float size
)
Visual Basic
Public Shared Function NewFont ( _
    font As Font, _
    size As Single _
) As Font

Parameters

font
Type: System.Drawing..::..Font
Base font.
size
Type: System..::..Single
New size (points)

See Also

GH_FontServer Class
NewFont Overload
Grasshopper.Kernel Namespace


NewFont Method (FontFamily, Single)

[image]

Grasshopper SDK
GH_FontServer..::..NewFont Method (FontFamily, Single)
GH_FontServer Class See Also Send Feedback
Safe font constructor.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Font NewFont(
    FontFamily family,
    float size
)
Visual Basic
Public Shared Function NewFont ( _
    family As FontFamily, _
    size As Single _
) As Font

Parameters

family
Type: System.Drawing..::..FontFamily
Font family.
size
Type: System..::..Single
Size (in points).

See Also

GH_FontServer Class
NewFont Overload
Grasshopper.Kernel Namespace


NewFont Method (Font, Single, FontStyle)

[image]

Grasshopper SDK
GH_FontServer..::..NewFont Method (Font, Single, FontStyle)
GH_FontServer Class See Also Send Feedback
Safe font constructor.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Font NewFont(
    Font font,
    float size,
    FontStyle style
)
Visual Basic
Public Shared Function NewFont ( _
    font As Font, _
    size As Single, _
    style As FontStyle _
) As Font

Parameters

font
Type: System.Drawing..::..Font
Base font.
size
Type: System..::..Single
New size (points)
style
Type: System.Drawing..::..FontStyle
New style.

See Also

GH_FontServer Class
NewFont Overload
Grasshopper.Kernel Namespace


NewFont Method (FontFamily, Single, FontStyle)

[image]

Grasshopper SDK
GH_FontServer..::..NewFont Method (FontFamily, Single, FontStyle)
GH_FontServer Class See Also Send Feedback
Safe font constructor.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Font NewFont(
    FontFamily family,
    float size,
    FontStyle style
)
Visual Basic
Public Shared Function NewFont ( _
    family As FontFamily, _
    size As Single, _
    style As FontStyle _
) As Font

Parameters

family
Type: System.Drawing..::..FontFamily
Font family.
size
Type: System..::..Single
Size (in points).
style
Type: System.Drawing..::..FontStyle
Style (if available).

See Also

GH_FontServer Class
NewFont Overload
Grasshopper.Kernel Namespace


NewFont Method (String, Single, FontStyle)

[image]

Grasshopper SDK
GH_FontServer..::..NewFont Method (String, Single, FontStyle)
GH_FontServer Class See Also Send Feedback
High level function for Font creation. We've ran into loads of trouble in the past with missing Fonts. Never create a font directly via GDI+, always use this method.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Font NewFont(
    string family,
    float size,
    FontStyle style
)
Visual Basic
Public Shared Function NewFont ( _
    family As String, _
    size As Single, _
    style As FontStyle _
) As Font

Parameters

family
Type: System..::..String
Font Family Name. If a font is found with the exact name, it will be loaded.
size
Type: System..::..Single
Size of font.
style
Type: System.Drawing..::..FontStyle
Font style, if the requested family does not support the requested style, the style flags will be ignored.

Return Value

A font that might or might not be what you asked for.

See Also

GH_FontServer Class
NewFont Overload
Grasshopper.Kernel Namespace


StringToFont Method

[image]

Grasshopper SDK
GH_FontServer..::..StringToFont Method
GH_FontServer Class See Also Send Feedback
Convert a font description string back into a font.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Font StringToFont(
    string text
)
Visual Basic
Public Shared Function StringToFont ( _
    text As String _
) As Font

Parameters

text
Type: System..::..String
Text to parse.

Return Value

Font represented by the text, or null if no font could be created.

See Also

GH_FontServer Class
Grasshopper.Kernel Namespace


StringWidth Method

[image] [image]

Grasshopper SDK
GH_FontServer..::..StringWidth Method
GH_FontServer Class See Also Send Feedback

Overload List

Name | Description
StringWidth(IEnumerable<(Of <<'(String>)>>), Font) | Measure the maximum width of a collection of strings
StringWidth(String, Font) | Measure the width of a string in pixels

See Also

GH_FontServer Class
GH_FontServer Members
Grasshopper.Kernel Namespace


StringWidth Method (IEnumerable(String), Font)

[image]

Grasshopper SDK
GH_FontServer..::..StringWidth Method (IEnumerable<(Of <(<'String>)>)>, Font)
GH_FontServer Class See Also Send Feedback
Measure the maximum width of a collection of strings

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static int StringWidth(
    IEnumerable<string> text,
    Font font
)
Visual Basic
Public Shared Function StringWidth ( _
    text As IEnumerable(Of String), _
    font As Font _
) As Integer

Parameters

text
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' String >)>)>
The strings to measure
font
Type: System.Drawing..::..Font
The font to measure with

See Also

GH_FontServer Class
StringWidth Overload
Grasshopper.Kernel Namespace


StringWidth Method (String, Font)

[image]

Grasshopper SDK
GH_FontServer..::..StringWidth Method (String, Font)
GH_FontServer Class See Also Send Feedback
Measure the width of a string in pixels

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static int StringWidth(
    string text,
    Font font
)
Visual Basic
Public Shared Function StringWidth ( _
    text As String, _
    font As Font _
) As Integer

Parameters

text
Type: System..::..String
The string to measure
font
Type: System.Drawing..::..Font
The font to measure with

See Also

GH_FontServer Class
StringWidth Overload
Grasshopper.Kernel Namespace


GH_FontServer Properties

[image] [image]

Grasshopper SDK
GH_FontServer Properties
GH_FontServer Class See Also Send Feedback

The GH_FontServer type exposes the following members.

Properties

Name | Description
Console | FontFamily.GenericMonospace, 10pt, regular
ConsoleSmall | FontFamily.GenericMonospace, 8pt, regular
FamilyConsole | Gets or sets the FontFamily used for monospaced fonts in Grasshopper.
FamilyScript | Gets or sets the FontFamily used for scripted fonts in Grasshopper.
FamilyStandard | Gets or sets the FontFamily used for standard fonts in Grasshopper.
Large | SystemFonts.CaptionFont, 10pt, bold
Script | FontFamily.GenericSansSerif, 10pt, italic
ScriptSmall | FontFamily.GenericSansSerif, 8pt, italic
Small | SystemFonts.CaptionFont, 6pt, regular
Standard | SystemFonts.CaptionFont, 8pt, regular
StandardBold | SystemFonts.CaptionFont, 8pt, bold
StandardItalic | SystemFonts.CaptionFont, 8pt, italic

See Also

GH_FontServer Class
Grasshopper.Kernel Namespace


Console Property

[image]

Grasshopper SDK
GH_FontServer..::..Console Property
GH_FontServer Class See Also Send Feedback
FontFamily.GenericMonospace, 10pt, regular

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Font Console { get; }
Visual Basic
Public Shared ReadOnly Property Console As Font
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_FontServer.Console"]

See Also

GH_FontServer Class
Grasshopper.Kernel Namespace


ConsoleSmall Property

[image]

Grasshopper SDK
GH_FontServer..::..ConsoleSmall Property
GH_FontServer Class See Also Send Feedback
FontFamily.GenericMonospace, 8pt, regular

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Font ConsoleSmall { get; }
Visual Basic
Public Shared ReadOnly Property ConsoleSmall As Font
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_FontServer.ConsoleSmall"]

See Also

GH_FontServer Class
Grasshopper.Kernel Namespace


FamilyConsole Property

[image]

Grasshopper SDK
GH_FontServer..::..FamilyConsole Property
GH_FontServer Class See Also Send Feedback
Gets or sets the FontFamily used for monospaced fonts in Grasshopper.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static FontFamily FamilyConsole { get; set; }
Visual Basic
Public Shared Property FamilyConsole As FontFamily
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_FontServer.FamilyConsole"]

See Also

GH_FontServer Class
Grasshopper.Kernel Namespace


FamilyScript Property

[image]

Grasshopper SDK
GH_FontServer..::..FamilyScript Property
GH_FontServer Class See Also Send Feedback
Gets or sets the FontFamily used for scripted fonts in Grasshopper.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static FontFamily FamilyScript { get; set; }
Visual Basic
Public Shared Property FamilyScript As FontFamily
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_FontServer.FamilyScript"]

See Also

GH_FontServer Class
Grasshopper.Kernel Namespace


FamilyStandard Property

[image]

Grasshopper SDK
GH_FontServer..::..FamilyStandard Property
GH_FontServer Class See Also Send Feedback
Gets or sets the FontFamily used for standard fonts in Grasshopper.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static FontFamily FamilyStandard { get; set; }
Visual Basic
Public Shared Property FamilyStandard As FontFamily
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_FontServer.FamilyStandard"]

See Also

GH_FontServer Class
Grasshopper.Kernel Namespace


Large Property

[image]

Grasshopper SDK
GH_FontServer..::..Large Property
GH_FontServer Class See Also Send Feedback
SystemFonts.CaptionFont, 10pt, bold

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Font Large { get; }
Visual Basic
Public Shared ReadOnly Property Large As Font
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_FontServer.Large"]

See Also

GH_FontServer Class
Grasshopper.Kernel Namespace


Script Property

[image]

Grasshopper SDK
GH_FontServer..::..Script Property
GH_FontServer Class See Also Send Feedback
FontFamily.GenericSansSerif, 10pt, italic

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Font Script { get; }
Visual Basic
Public Shared ReadOnly Property Script As Font
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_FontServer.Script"]

See Also

GH_FontServer Class
Grasshopper.Kernel Namespace


ScriptSmall Property

[image]

Grasshopper SDK
GH_FontServer..::..ScriptSmall Property
GH_FontServer Class See Also Send Feedback
FontFamily.GenericSansSerif, 8pt, italic

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Font ScriptSmall { get; }
Visual Basic
Public Shared ReadOnly Property ScriptSmall As Font
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_FontServer.ScriptSmall"]

See Also

GH_FontServer Class
Grasshopper.Kernel Namespace


Small Property

[image]

Grasshopper SDK
GH_FontServer..::..Small Property
GH_FontServer Class See Also Send Feedback
SystemFonts.CaptionFont, 6pt, regular

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Font Small { get; }
Visual Basic
Public Shared ReadOnly Property Small As Font
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_FontServer.Small"]

See Also

GH_FontServer Class
Grasshopper.Kernel Namespace


Standard Property

[image]

Grasshopper SDK
GH_FontServer..::..Standard Property
GH_FontServer Class See Also Send Feedback
SystemFonts.CaptionFont, 8pt, regular

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Font Standard { get; }
Visual Basic
Public Shared ReadOnly Property Standard As Font
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_FontServer.Standard"]

See Also

GH_FontServer Class
Grasshopper.Kernel Namespace


StandardBold Property

[image]

Grasshopper SDK
GH_FontServer..::..StandardBold Property
GH_FontServer Class See Also Send Feedback
SystemFonts.CaptionFont, 8pt, bold

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Font StandardBold { get; }
Visual Basic
Public Shared ReadOnly Property StandardBold As Font
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_FontServer.StandardBold"]

See Also

GH_FontServer Class
Grasshopper.Kernel Namespace


StandardItalic Property

[image]

Grasshopper SDK
GH_FontServer..::..StandardItalic Property
GH_FontServer Class See Also Send Feedback
SystemFonts.CaptionFont, 8pt, italic

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Font StandardItalic { get; }
Visual Basic
Public Shared ReadOnly Property StandardItalic As Font
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_FontServer.StandardItalic"]

See Also

GH_FontServer Class
Grasshopper.Kernel Namespace


GH_FontServer Events

[image] [image]

Grasshopper SDK
GH_FontServer Events
GH_FontServer Class See Also Send Feedback

The GH_FontServer type exposes the following members.

Events

Name | Description
ConsoleFamilyChanged | Raised whenever the MonospacedFamily is changed.
ScriptFamilyChanged | Raised whenever the ScriptFamily is changed.
StandardFamilyChanged | Raised whenever the StandardFamily is changed.

See Also

GH_FontServer Class
Grasshopper.Kernel Namespace


ConsoleFamilyChanged Event

[image]

Grasshopper SDK
GH_FontServer..::..ConsoleFamilyChanged Event
GH_FontServer Class See Also Send Feedback
Raised whenever the MonospacedFamily is changed.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event GH_FontServer..::..ConsoleFamilyChangedEventHandler ConsoleFamilyChanged
Visual Basic
Public Shared Event ConsoleFamilyChanged As GH_FontServer..::..ConsoleFamilyChangedEventHandler

See Also

GH_FontServer Class
Grasshopper.Kernel Namespace


ScriptFamilyChanged Event

[image]

Grasshopper SDK
GH_FontServer..::..ScriptFamilyChanged Event
GH_FontServer Class See Also Send Feedback
Raised whenever the ScriptFamily is changed.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event GH_FontServer..::..ScriptFamilyChangedEventHandler ScriptFamilyChanged
Visual Basic
Public Shared Event ScriptFamilyChanged As GH_FontServer..::..ScriptFamilyChangedEventHandler

See Also

GH_FontServer Class
Grasshopper.Kernel Namespace


StandardFamilyChanged Event

[image]

Grasshopper SDK
GH_FontServer..::..StandardFamilyChanged Event
GH_FontServer Class See Also Send Feedback
Raised whenever the StandardFamily is changed.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static event GH_FontServer..::..StandardFamilyChangedEventHandler StandardFamilyChanged
Visual Basic
Public Shared Event StandardFamilyChanged As GH_FontServer..::..StandardFamilyChangedEventHandler

See Also

GH_FontServer Class
Grasshopper.Kernel Namespace


GH_FontServer.ConsoleFamilyChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_FontServer..::..ConsoleFamilyChangedEventHandler Delegate
GH_FontServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void ConsoleFamilyChangedEventHandler()
Visual Basic
Public Delegate Sub ConsoleFamilyChangedEventHandler

See Also

Grasshopper.Kernel Namespace


GH_FontServer.ScriptFamilyChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_FontServer..::..ScriptFamilyChangedEventHandler Delegate
GH_FontServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void ScriptFamilyChangedEventHandler()
Visual Basic
Public Delegate Sub ScriptFamilyChangedEventHandler

See Also

Grasshopper.Kernel Namespace


GH_FontServer.StandardFamilyChangedEventHandler Delegate

[image]

Grasshopper SDK
GH_FontServer..::..StandardFamilyChangedEventHandler Delegate
GH_FontServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void StandardFamilyChangedEventHandler()
Visual Basic
Public Delegate Sub StandardFamilyChangedEventHandler

See Also

Grasshopper.Kernel Namespace


GH_Format Class

[image]

Grasshopper SDK
GH_Format Class
Members See Also Send Feedback
Provides standard Grasshopper formatting functions.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class GH_Format
Visual Basic
Public NotInheritable Class GH_Format

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_Format

See Also

GH_Format Members
Grasshopper.Kernel Namespace


GH_Format Members

[image] [image]

Grasshopper SDK
GH_Format Members
GH_Format Class Methods See Also Send Feedback

The GH_Format type exposes the following members.

Methods

Name | Description
DefaultCulture |
FormatArc(Arc) |
FormatArc(GH_Arc) |
FormatArcValidity | If the arc is invalid, return a string describing why.
FormatBoolean(Boolean) |
FormatBoolean(GH_Boolean) |
FormatBoundingBoxValidity | If the box is invalid, return a string describing why.
FormatBox(Box) |
FormatBox(GH_Box) |
FormatBoxValidity | If the box is invalid, return a string describing why.
FormatBrep(Brep) |
FormatBrep(GH_Brep) |
FormatBrepValidity | If the brep is invalid, return a string describing why.
FormatCircle(Circle) |
FormatCircle(GH_Circle) |
FormatCircleValidity | If the circle is invalid, return a string describing why.
FormatColour(Color) |
FormatColour(GH_Colour) |
FormatComplexNumber(Complex) |
FormatComplexNumber(GH_ComplexNumber) |
FormatComplexValidity | If the complex number is invalid, return a string describing why.
FormatCurve(GH_Curve) |
FormatCurve(Curve, String, String) |
FormatCurveValidity | If the curve is invalid, return a string describing why.
FormatDate(DateTime) |
FormatDate(GH_Time) |
FormatDouble(Double) |
FormatDouble(GH_Number) |
FormatDoubleValidity | If the number is invalid, return a string describing why.
FormatFilePath(String, Int32) | Format a filepath so that it doesn't exceed a string length. If the filepath filename is already longer than maxLength it will be returned intact.
FormatFilePath(String, Int32, Font) | Format a filepath so that it doesn't exceed width. If the filepath filename is already longer than maxLength it will be returned intact.
FormatGeometry |
FormatInteger(Int32) |
FormatInteger(GH_Integer) |
FormatInterval(Interval) |
FormatInterval(GH_Interval) |
FormatInterval(GH_Interval2D) |
FormatInterval(Double, Double) |
FormatIntervalValidity | If the point is invalid, return a string describing why.
FormatKeys | Format a keys enumeration as though it's a menu shortcut
FormatLine(Line) |
FormatLine(GH_Line) |
FormatLineValidity | If the line is invalid, return a string describing why.
FormatMatrix(Matrix) |
FormatMatrix(GH_Matrix) |
FormatMesh(GH_Mesh) |
FormatMesh(Mesh, String) |
FormatMeshFace |
FormatMeshFaceValidity | If the number is invalid, return a string describing why.
FormatMeshValidity | If the mesh is invalid, return a string describing why.
FormatPlane(Plane) |
FormatPlane(GH_Plane) |
FormatPlaneValidity | If the plane is invalid, return a string describing why.
FormatPoint(Point3d) |
FormatPoint(GH_Point) |
FormatPointCloud |
FormatPointValidity | If the point is invalid, return a string describing why.
FormatRectangleValidity | If the rectangle is invalid, return a string describing why.
FormatSingle |
FormatSurface(Brep) |
FormatSurface(GH_Surface) |
FormatSurfaceValidity | If the surface is invalid, return a string describing why.
FormatTransformValidity | If the transform is invalid, return a string describing why.
FormatVector(Vector3d) |
FormatVector(GH_Vector) |
FormatVectorValidity | If the point is invalid, return a string describing why.
RhinoUnitName |
RhinoUnitSymbol |
TreatAsCollection | This method is used in Scripting components to determine whether a certain class was 'intended' as a collection or as a single piece of data .

See Also

GH_Format Class
Grasshopper.Kernel Namespace


GH_Format Methods

[image] [image]

Grasshopper SDK
GH_Format Methods
GH_Format Class See Also Send Feedback

The GH_Format type exposes the following members.

Methods

Name | Description
DefaultCulture |
FormatArc(Arc) |
FormatArc(GH_Arc) |
FormatArcValidity | If the arc is invalid, return a string describing why.
FormatBoolean(Boolean) |
FormatBoolean(GH_Boolean) |
FormatBoundingBoxValidity | If the box is invalid, return a string describing why.
FormatBox(Box) |
FormatBox(GH_Box) |
FormatBoxValidity | If the box is invalid, return a string describing why.
FormatBrep(Brep) |
FormatBrep(GH_Brep) |
FormatBrepValidity | If the brep is invalid, return a string describing why.
FormatCircle(Circle) |
FormatCircle(GH_Circle) |
FormatCircleValidity | If the circle is invalid, return a string describing why.
FormatColour(Color) |
FormatColour(GH_Colour) |
FormatComplexNumber(Complex) |
FormatComplexNumber(GH_ComplexNumber) |
FormatComplexValidity | If the complex number is invalid, return a string describing why.
FormatCurve(GH_Curve) |
FormatCurve(Curve, String, String) |
FormatCurveValidity | If the curve is invalid, return a string describing why.
FormatDate(DateTime) |
FormatDate(GH_Time) |
FormatDouble(Double) |
FormatDouble(GH_Number) |
FormatDoubleValidity | If the number is invalid, return a string describing why.
FormatFilePath(String, Int32) | Format a filepath so that it doesn't exceed a string length. If the filepath filename is already longer than maxLength it will be returned intact.
FormatFilePath(String, Int32, Font) | Format a filepath so that it doesn't exceed width. If the filepath filename is already longer than maxLength it will be returned intact.
FormatGeometry |
FormatInteger(Int32) |
FormatInteger(GH_Integer) |
FormatInterval(Interval) |
FormatInterval(GH_Interval) |
FormatInterval(GH_Interval2D) |
FormatInterval(Double, Double) |
FormatIntervalValidity | If the point is invalid, return a string describing why.
FormatKeys | Format a keys enumeration as though it's a menu shortcut
FormatLine(Line) |
FormatLine(GH_Line) |
FormatLineValidity | If the line is invalid, return a string describing why.
FormatMatrix(Matrix) |
FormatMatrix(GH_Matrix) |
FormatMesh(GH_Mesh) |
FormatMesh(Mesh, String) |
FormatMeshFace |
FormatMeshFaceValidity | If the number is invalid, return a string describing why.
FormatMeshValidity | If the mesh is invalid, return a string describing why.
FormatPlane(Plane) |
FormatPlane(GH_Plane) |
FormatPlaneValidity | If the plane is invalid, return a string describing why.
FormatPoint(Point3d) |
FormatPoint(GH_Point) |
FormatPointCloud |
FormatPointValidity | If the point is invalid, return a string describing why.
FormatRectangleValidity | If the rectangle is invalid, return a string describing why.
FormatSingle |
FormatSurface(Brep) |
FormatSurface(GH_Surface) |
FormatSurfaceValidity | If the surface is invalid, return a string describing why.
FormatTransformValidity | If the transform is invalid, return a string describing why.
FormatVector(Vector3d) |
FormatVector(GH_Vector) |
FormatVectorValidity | If the point is invalid, return a string describing why.
RhinoUnitName |
RhinoUnitSymbol |
TreatAsCollection | This method is used in Scripting components to determine whether a certain class was 'intended' as a collection or as a single piece of data .

See Also

GH_Format Class
Grasshopper.Kernel Namespace


DefaultCulture Method

[image]

Grasshopper SDK
GH_Format..::..DefaultCulture Method
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static IFormatProvider DefaultCulture()
Visual Basic
Public Shared Function DefaultCulture As IFormatProvider

See Also

GH_Format Class
Grasshopper.Kernel Namespace


FormatArc Method

[image] [image]

Grasshopper SDK
GH_Format..::..FormatArc Method
GH_Format Class See Also Send Feedback

Overload List

Name | Description
FormatArc(Arc) |
FormatArc(GH_Arc) |

See Also

GH_Format Class
GH_Format Members
Grasshopper.Kernel Namespace


FormatArc Method ()

[image]

Grasshopper SDK
GH_Format..::..FormatArc Method ()
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatArc(
    Arc data
)
Visual Basic
Public Shared Function FormatArc ( _
    data As Arc _
) As String

Parameters

data
Type: Arc

See Also

GH_Format Class
FormatArc Overload
Grasshopper.Kernel Namespace


FormatArc Method (GH_Arc)

[image]

Grasshopper SDK
GH_Format..::..FormatArc Method (GH_Arc)
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatArc(
    GH_Arc data
)
Visual Basic
Public Shared Function FormatArc ( _
    data As GH_Arc _
) As String

Parameters

data
Type: Grasshopper.Kernel.Types..::..GH_Arc

See Also

GH_Format Class
FormatArc Overload
Grasshopper.Kernel Namespace


FormatArcValidity Method

[image]

Grasshopper SDK
GH_Format..::..FormatArcValidity Method
GH_Format Class See Also Send Feedback
If the arc is invalid, return a string describing why.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatArcValidity(
    Arc val,
    string identifier
)
Visual Basic
Public Shared Function FormatArcValidity ( _
    val As Arc, _
    identifier As String _
) As String

Parameters

val
Type: Arc
Value to format.
identifier
Type: System..::..String
Name used to refer to the value in the format.

Return Value

A string describing why the arc is invalid or String.Empty if the value is not invalid.

See Also

GH_Format Class
Grasshopper.Kernel Namespace


FormatBoolean Method

[image] [image]

Grasshopper SDK
GH_Format..::..FormatBoolean Method
GH_Format Class See Also Send Feedback

Overload List

Name | Description
FormatBoolean(Boolean) |
FormatBoolean(GH_Boolean) |

See Also

GH_Format Class
GH_Format Members
Grasshopper.Kernel Namespace


FormatBoolean Method (Boolean)

[image]

Grasshopper SDK
GH_Format..::..FormatBoolean Method (Boolean)
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatBoolean(
    bool data
)
Visual Basic
Public Shared Function FormatBoolean ( _
    data As Boolean _
) As String

Parameters

data
Type: System..::..Boolean

See Also

GH_Format Class
FormatBoolean Overload
Grasshopper.Kernel Namespace


FormatBoolean Method (GH_Boolean)

[image]

Grasshopper SDK
GH_Format..::..FormatBoolean Method (GH_Boolean)
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatBoolean(
    GH_Boolean data
)
Visual Basic
Public Shared Function FormatBoolean ( _
    data As GH_Boolean _
) As String

Parameters

data
Type: Grasshopper.Kernel.Types..::..GH_Boolean

See Also

GH_Format Class
FormatBoolean Overload
Grasshopper.Kernel Namespace


FormatBoundingBoxValidity Method

[image]

Grasshopper SDK
GH_Format..::..FormatBoundingBoxValidity Method
GH_Format Class See Also Send Feedback
If the box is invalid, return a string describing why.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatBoundingBoxValidity(
    BoundingBox val,
    string identifier
)
Visual Basic
Public Shared Function FormatBoundingBoxValidity ( _
    val As BoundingBox, _
    identifier As String _
) As String

Parameters

val
Type: BoundingBox
Value to format.
identifier
Type: System..::..String
Name used to refer to the value in the format.

Return Value

A string describing why the box is invalid or String.Empty if the value is not invalid.

See Also

GH_Format Class
Grasshopper.Kernel Namespace


FormatBox Method

[image] [image]

Grasshopper SDK
GH_Format..::..FormatBox Method
GH_Format Class See Also Send Feedback

Overload List

Name | Description
FormatBox(Box) |
FormatBox(GH_Box) |

See Also

GH_Format Class
GH_Format Members
Grasshopper.Kernel Namespace


FormatBox Method ()

[image]

Grasshopper SDK
GH_Format..::..FormatBox Method ()
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatBox(
    Box data
)
Visual Basic
Public Shared Function FormatBox ( _
    data As Box _
) As String

Parameters

data
Type: Box

See Also

GH_Format Class
FormatBox Overload
Grasshopper.Kernel Namespace


FormatBox Method (GH_Box)

[image]

Grasshopper SDK
GH_Format..::..FormatBox Method (GH_Box)
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatBox(
    GH_Box data
)
Visual Basic
Public Shared Function FormatBox ( _
    data As GH_Box _
) As String

Parameters

data
Type: Grasshopper.Kernel.Types..::..GH_Box

See Also

GH_Format Class
FormatBox Overload
Grasshopper.Kernel Namespace


FormatBoxValidity Method

[image]

Grasshopper SDK
GH_Format..::..FormatBoxValidity Method
GH_Format Class See Also Send Feedback
If the box is invalid, return a string describing why.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatBoxValidity(
    Box val,
    string identifier
)
Visual Basic
Public Shared Function FormatBoxValidity ( _
    val As Box, _
    identifier As String _
) As String

Parameters

val
Type: Box
Value to format.
identifier
Type: System..::..String
Name used to refer to the value in the format.

Return Value

A string describing why the box is invalid or String.Empty if the value is not invalid.

See Also

GH_Format Class
Grasshopper.Kernel Namespace


FormatBrep Method

[image] [image]

Grasshopper SDK
GH_Format..::..FormatBrep Method
GH_Format Class See Also Send Feedback

Overload List

Name | Description
FormatBrep(Brep) |
FormatBrep(GH_Brep) |

See Also

GH_Format Class
GH_Format Members
Grasshopper.Kernel Namespace


FormatBrep Method ()

[image]

Grasshopper SDK
GH_Format..::..FormatBrep Method ()
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatBrep(
    Brep data
)
Visual Basic
Public Shared Function FormatBrep ( _
    data As Brep _
) As String

Parameters

data
Type: Brep

See Also

GH_Format Class
FormatBrep Overload
Grasshopper.Kernel Namespace


FormatBrep Method (GH_Brep)

[image]

Grasshopper SDK
GH_Format..::..FormatBrep Method (GH_Brep)
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatBrep(
    GH_Brep data
)
Visual Basic
Public Shared Function FormatBrep ( _
    data As GH_Brep _
) As String

Parameters

data
Type: Grasshopper.Kernel.Types..::..GH_Brep

See Also

GH_Format Class
FormatBrep Overload
Grasshopper.Kernel Namespace


FormatBrepValidity Method

[image]

Grasshopper SDK
GH_Format..::..FormatBrepValidity Method
GH_Format Class See Also Send Feedback
If the brep is invalid, return a string describing why.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatBrepValidity(
    Brep val,
    string identifier
)
Visual Basic
Public Shared Function FormatBrepValidity ( _
    val As Brep, _
    identifier As String _
) As String

Parameters

val
Type: Brep
Value to format.
identifier
Type: System..::..String
Name used to refer to the value in the format.

Return Value

A string describing why the brep is invalid or String.Empty if the value is not invalid.

See Also

GH_Format Class
Grasshopper.Kernel Namespace


FormatCircle Method

[image] [image]

Grasshopper SDK
GH_Format..::..FormatCircle Method
GH_Format Class See Also Send Feedback

Overload List

Name | Description
FormatCircle(Circle) |
FormatCircle(GH_Circle) |

See Also

GH_Format Class
GH_Format Members
Grasshopper.Kernel Namespace


FormatCircle Method ()

[image]

Grasshopper SDK
GH_Format..::..FormatCircle Method ()
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatCircle(
    Circle data
)
Visual Basic
Public Shared Function FormatCircle ( _
    data As Circle _
) As String

Parameters

data
Type: Circle

See Also

GH_Format Class
FormatCircle Overload
Grasshopper.Kernel Namespace


FormatCircle Method (GH_Circle)

[image]

Grasshopper SDK
GH_Format..::..FormatCircle Method (GH_Circle)
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatCircle(
    GH_Circle data
)
Visual Basic
Public Shared Function FormatCircle ( _
    data As GH_Circle _
) As String

Parameters

data
Type: Grasshopper.Kernel.Types..::..GH_Circle

See Also

GH_Format Class
FormatCircle Overload
Grasshopper.Kernel Namespace


FormatCircleValidity Method

[image]

Grasshopper SDK
GH_Format..::..FormatCircleValidity Method
GH_Format Class See Also Send Feedback
If the circle is invalid, return a string describing why.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatCircleValidity(
    Circle val,
    string identifier
)
Visual Basic
Public Shared Function FormatCircleValidity ( _
    val As Circle, _
    identifier As String _
) As String

Parameters

val
Type: Circle
Value to format.
identifier
Type: System..::..String
Name used to refer to the value in the format.

Return Value

A string describing why the circle is invalid or String.Empty if the value is not invalid.

See Also

GH_Format Class
Grasshopper.Kernel Namespace


FormatColour Method

[image] [image]

Grasshopper SDK
GH_Format..::..FormatColour Method
GH_Format Class See Also Send Feedback

Overload List

Name | Description
FormatColour(Color) |
FormatColour(GH_Colour) |

See Also

GH_Format Class
GH_Format Members
Grasshopper.Kernel Namespace


FormatColour Method (Color)

[image]

Grasshopper SDK
GH_Format..::..FormatColour Method (Color)
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatColour(
    Color data
)
Visual Basic
Public Shared Function FormatColour ( _
    data As Color _
) As String

Parameters

data
Type: System.Drawing..::..Color

See Also

GH_Format Class
FormatColour Overload
Grasshopper.Kernel Namespace


FormatColour Method (GH_Colour)

[image]

Grasshopper SDK
GH_Format..::..FormatColour Method (GH_Colour)
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatColour(
    GH_Colour data
)
Visual Basic
Public Shared Function FormatColour ( _
    data As GH_Colour _
) As String

Parameters

data
Type: Grasshopper.Kernel.Types..::..GH_Colour

See Also

GH_Format Class
FormatColour Overload
Grasshopper.Kernel Namespace


FormatComplexNumber Method

[image] [image]

Grasshopper SDK
GH_Format..::..FormatComplexNumber Method
GH_Format Class See Also Send Feedback

Overload List

Name | Description
FormatComplexNumber(Complex) |
FormatComplexNumber(GH_ComplexNumber) |

See Also

GH_Format Class
GH_Format Members
Grasshopper.Kernel Namespace


FormatComplexNumber Method (Complex)

[image]

Grasshopper SDK
GH_Format..::..FormatComplexNumber Method (Complex)
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatComplexNumber(
    Complex num
)
Visual Basic
Public Shared Function FormatComplexNumber ( _
    num As Complex _
) As String

Parameters

num
Type: Grasshopper.Kernel.Types..::..Complex

See Also

GH_Format Class
FormatComplexNumber Overload
Grasshopper.Kernel Namespace


FormatComplexNumber Method (GH_ComplexNumber)

[image]

Grasshopper SDK
GH_Format..::..FormatComplexNumber Method (GH_ComplexNumber)
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatComplexNumber(
    GH_ComplexNumber data
)
Visual Basic
Public Shared Function FormatComplexNumber ( _
    data As GH_ComplexNumber _
) As String

Parameters

data
Type: Grasshopper.Kernel.Types..::..GH_ComplexNumber

See Also

GH_Format Class
FormatComplexNumber Overload
Grasshopper.Kernel Namespace


FormatComplexValidity Method

[image]

Grasshopper SDK
GH_Format..::..FormatComplexValidity Method
GH_Format Class See Also Send Feedback
If the complex number is invalid, return a string describing why.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatComplexValidity(
    Complex val,
    string identifier
)
Visual Basic
Public Shared Function FormatComplexValidity ( _
    val As Complex, _
    identifier As String _
) As String

Parameters

val
Type: Grasshopper.Kernel.Types..::..Complex
Value to format.
identifier
Type: System..::..String
Name used to refer to the value in the format.

Return Value

A string describing why the complex number is invalid or String.Empty if the value is not invalid.

See Also

GH_Format Class
Grasshopper.Kernel Namespace


FormatCurve Method

[image] [image]

Grasshopper SDK
GH_Format..::..FormatCurve Method
GH_Format Class See Also Send Feedback

Overload List

Name | Description
FormatCurve(GH_Curve) |
FormatCurve(Curve, String, String) |

See Also

GH_Format Class
GH_Format Members
Grasshopper.Kernel Namespace


FormatCurve Method (GH_Curve)

[image]

Grasshopper SDK
GH_Format..::..FormatCurve Method (GH_Curve)
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatCurve(
    GH_Curve data
)
Visual Basic
Public Shared Function FormatCurve ( _
    data As GH_Curve _
) As String

Parameters

data
Type: Grasshopper.Kernel.Types..::..GH_Curve

See Also

GH_Format Class
FormatCurve Overload
Grasshopper.Kernel Namespace


FormatCurve Method (, String, String)

[image]

Grasshopper SDK
GH_Format..::..FormatCurve Method (, String, String)
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatCurve(
    Curve data,
    string CrvPrefix,
    string CrvName
)
Visual Basic
Public Shared Function FormatCurve ( _
    data As Curve, _
    CrvPrefix As String, _
    CrvName As String _
) As String

Parameters

data
Type: Curve
CrvPrefix
Type: System..::..String
CrvName
Type: System..::..String

See Also

GH_Format Class
FormatCurve Overload
Grasshopper.Kernel Namespace


FormatCurveValidity Method

[image]

Grasshopper SDK
GH_Format..::..FormatCurveValidity Method
GH_Format Class See Also Send Feedback
If the curve is invalid, return a string describing why.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatCurveValidity(
    Curve val,
    string identifier
)
Visual Basic
Public Shared Function FormatCurveValidity ( _
    val As Curve, _
    identifier As String _
) As String

Parameters

val
Type: Curve
Value to format.
identifier
Type: System..::..String
Name used to refer to the value in the format.

Return Value

A string describing why the curve is invalid or String.Empty if the value is not invalid.

See Also

GH_Format Class
Grasshopper.Kernel Namespace


FormatDate Method

[image] [image]

Grasshopper SDK
GH_Format..::..FormatDate Method
GH_Format Class See Also Send Feedback

Overload List

Name | Description
FormatDate(DateTime) |
FormatDate(GH_Time) |

See Also

GH_Format Class
GH_Format Members
Grasshopper.Kernel Namespace


FormatDate Method (DateTime)

[image]

Grasshopper SDK
GH_Format..::..FormatDate Method (DateTime)
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatDate(
    DateTime data
)
Visual Basic
Public Shared Function FormatDate ( _
    data As DateTime _
) As String

Parameters

data
Type: System..::..DateTime

See Also

GH_Format Class
FormatDate Overload
Grasshopper.Kernel Namespace


FormatDate Method (GH_Time)

[image]

Grasshopper SDK
GH_Format..::..FormatDate Method (GH_Time)
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatDate(
    GH_Time data
)
Visual Basic
Public Shared Function FormatDate ( _
    data As GH_Time _
) As String

Parameters

data
Type: Grasshopper.Kernel.Types..::..GH_Time

See Also

GH_Format Class
FormatDate Overload
Grasshopper.Kernel Namespace


FormatDouble Method

[image] [image]

Grasshopper SDK
GH_Format..::..FormatDouble Method
GH_Format Class See Also Send Feedback

Overload List

Name | Description
FormatDouble(Double) |
FormatDouble(GH_Number) |

See Also

GH_Format Class
GH_Format Members
Grasshopper.Kernel Namespace


FormatDouble Method (Double)

[image]

Grasshopper SDK
GH_Format..::..FormatDouble Method (Double)
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatDouble(
    double data
)
Visual Basic
Public Shared Function FormatDouble ( _
    data As Double _
) As String

Parameters

data
Type: System..::..Double

See Also

GH_Format Class
FormatDouble Overload
Grasshopper.Kernel Namespace


FormatDouble Method (GH_Number)

[image]

Grasshopper SDK
GH_Format..::..FormatDouble Method (GH_Number)
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatDouble(
    GH_Number data
)
Visual Basic
Public Shared Function FormatDouble ( _
    data As GH_Number _
) As String

Parameters

data
Type: Grasshopper.Kernel.Types..::..GH_Number

See Also

GH_Format Class
FormatDouble Overload
Grasshopper.Kernel Namespace


FormatDoubleValidity Method

[image]

Grasshopper SDK
GH_Format..::..FormatDoubleValidity Method
GH_Format Class See Also Send Feedback
If the number is invalid, return a string describing why.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatDoubleValidity(
    double val,
    string identifier
)
Visual Basic
Public Shared Function FormatDoubleValidity ( _
    val As Double, _
    identifier As String _
) As String

Parameters

val
Type: System..::..Double
Value to format.
identifier
Type: System..::..String
Name used to refer to the value in the format.

Return Value

A string describing why the number is invalid or String.Empty if the value is not invalid.

See Also

GH_Format Class
Grasshopper.Kernel Namespace


FormatFilePath Method

[image] [image]

Grasshopper SDK
GH_Format..::..FormatFilePath Method
GH_Format Class See Also Send Feedback

Overload List

Name | Description
FormatFilePath(String, Int32) | Format a filepath so that it doesn't exceed a string length. If the filepath filename is already longer than maxLength it will be returned intact.
FormatFilePath(String, Int32, Font) | Format a filepath so that it doesn't exceed width. If the filepath filename is already longer than maxLength it will be returned intact.

See Also

GH_Format Class
GH_Format Members
Grasshopper.Kernel Namespace


FormatFilePath Method (String, Int32)

[image]

Grasshopper SDK
GH_Format..::..FormatFilePath Method (String, Int32)
GH_Format Class See Also Send Feedback
Format a filepath so that it doesn't exceed a string length. If the filepath filename is already longer than maxLength it will be returned intact.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatFilePath(
    string path,
    int maxLength
)
Visual Basic
Public Shared Function FormatFilePath ( _
    path As String, _
    maxLength As Integer _
) As String

Parameters

path
Type: System..::..String
Path for format.
maxLength
Type: System..::..Int32
Maximum number of characters to use.

Return Value

The formatted path.

See Also

GH_Format Class
FormatFilePath Overload
Grasshopper.Kernel Namespace


FormatFilePath Method (String, Int32, Font)

[image]

Grasshopper SDK
GH_Format..::..FormatFilePath Method (String, Int32, Font)
GH_Format Class See Also Send Feedback
Format a filepath so that it doesn't exceed width. If the filepath filename is already longer than maxLength it will be returned intact.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatFilePath(
    string path,
    int maxWidth,
    Font font
)
Visual Basic
Public Shared Function FormatFilePath ( _
    path As String, _
    maxWidth As Integer, _
    font As Font _
) As String

Parameters

path
Type: System..::..String
Path to format.
maxWidth
Type: System..::..Int32
Maximum allowed width (in pixels)
font
Type: System.Drawing..::..Font
Font to use for measuring.

Return Value

The formatted path.

See Also

GH_Format Class
FormatFilePath Overload
Grasshopper.Kernel Namespace


FormatGeometry Method

[image]

Grasshopper SDK
GH_Format..::..FormatGeometry Method
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatGeometry(
    IGH_GeometricGoo data
)
Visual Basic
Public Shared Function FormatGeometry ( _
    data As IGH_GeometricGoo _
) As String

Parameters

data
Type: Grasshopper.Kernel.Types..::..IGH_GeometricGoo

See Also

GH_Format Class
Grasshopper.Kernel Namespace


FormatInteger Method

[image] [image]

Grasshopper SDK
GH_Format..::..FormatInteger Method
GH_Format Class See Also Send Feedback

Overload List

Name | Description
FormatInteger(Int32) |
FormatInteger(GH_Integer) |

See Also

GH_Format Class
GH_Format Members
Grasshopper.Kernel Namespace


FormatInteger Method (Int32)

[image]

Grasshopper SDK
GH_Format..::..FormatInteger Method (Int32)
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatInteger(
    int data
)
Visual Basic
Public Shared Function FormatInteger ( _
    data As Integer _
) As String

Parameters

data
Type: System..::..Int32

See Also

GH_Format Class
FormatInteger Overload
Grasshopper.Kernel Namespace


FormatInteger Method (GH_Integer)

[image]

Grasshopper SDK
GH_Format..::..FormatInteger Method (GH_Integer)
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatInteger(
    GH_Integer data
)
Visual Basic
Public Shared Function FormatInteger ( _
    data As GH_Integer _
) As String

Parameters

data
Type: Grasshopper.Kernel.Types..::..GH_Integer

See Also

GH_Format Class
FormatInteger Overload
Grasshopper.Kernel Namespace


FormatInterval Method

[image] [image]

Grasshopper SDK
GH_Format..::..FormatInterval Method
GH_Format Class See Also Send Feedback

Overload List

Name | Description
FormatInterval(Interval) |
FormatInterval(GH_Interval) |
FormatInterval(GH_Interval2D) |
FormatInterval(Double, Double) |

See Also

GH_Format Class
GH_Format Members
Grasshopper.Kernel Namespace


FormatInterval Method ()

[image]

Grasshopper SDK
GH_Format..::..FormatInterval Method ()
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatInterval(
    Interval data
)
Visual Basic
Public Shared Function FormatInterval ( _
    data As Interval _
) As String

Parameters

data
Type: Interval

See Also

GH_Format Class
FormatInterval Overload
Grasshopper.Kernel Namespace


FormatInterval Method (GH_Interval)

[image]

Grasshopper SDK
GH_Format..::..FormatInterval Method (GH_Interval)
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatInterval(
    GH_Interval data
)
Visual Basic
Public Shared Function FormatInterval ( _
    data As GH_Interval _
) As String

Parameters

data
Type: Grasshopper.Kernel.Types..::..GH_Interval

See Also

GH_Format Class
FormatInterval Overload
Grasshopper.Kernel Namespace


FormatInterval Method (GH_Interval2D)

[image]

Grasshopper SDK
GH_Format..::..FormatInterval Method (GH_Interval2D)
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatInterval(
    GH_Interval2D data
)
Visual Basic
Public Shared Function FormatInterval ( _
    data As GH_Interval2D _
) As String

Parameters

data
Type: Grasshopper.Kernel.Types..::..GH_Interval2D

See Also

GH_Format Class
FormatInterval Overload
Grasshopper.Kernel Namespace


FormatInterval Method (Double, Double)

[image]

Grasshopper SDK
GH_Format..::..FormatInterval Method (Double, Double)
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatInterval(
    double t0,
    double t1
)
Visual Basic
Public Shared Function FormatInterval ( _
    t0 As Double, _
    t1 As Double _
) As String

Parameters

t0
Type: System..::..Double
t1
Type: System..::..Double

See Also

GH_Format Class
FormatInterval Overload
Grasshopper.Kernel Namespace


FormatIntervalValidity Method

[image]

Grasshopper SDK
GH_Format..::..FormatIntervalValidity Method
GH_Format Class See Also Send Feedback
If the point is invalid, return a string describing why.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatIntervalValidity(
    Interval val,
    string identifier,
    bool testSingleton,
    bool testDecreasing
)
Visual Basic
Public Shared Function FormatIntervalValidity ( _
    val As Interval, _
    identifier As String, _
    testSingleton As Boolean, _
    testDecreasing As Boolean _
) As String

Parameters

val
Type: Interval
Value to format.
identifier
Type: System..::..String
Name used to refer to the value in the format.
testSingleton
Type: System..::..Boolean
If true, Intervals that have no length are considered invalid.
testDecreasing
Type: System..::..Boolean
If true, Intervals that are decreasing are considered invalid.

Return Value

A string describing why the point is invalid or String.Empty if the value is not invalid.

See Also

GH_Format Class
Grasshopper.Kernel Namespace


FormatKeys Method

[image]

Grasshopper SDK
GH_Format..::..FormatKeys Method
GH_Format Class See Also Send Feedback
Format a keys enumeration as though it's a menu shortcut

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatKeys(
    Keys keys
)
Visual Basic
Public Shared Function FormatKeys ( _
    keys As Keys _
) As String

Parameters

keys
Type: System.Windows.Forms..::..Keys
Key data to format

See Also

GH_Format Class
Grasshopper.Kernel Namespace


FormatLine Method

[image] [image]

Grasshopper SDK
GH_Format..::..FormatLine Method
GH_Format Class See Also Send Feedback

Overload List

Name | Description
FormatLine(Line) |
FormatLine(GH_Line) |

See Also

GH_Format Class
GH_Format Members
Grasshopper.Kernel Namespace


FormatLine Method ()

[image]

Grasshopper SDK
GH_Format..::..FormatLine Method ()
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatLine(
    Line data
)
Visual Basic
Public Shared Function FormatLine ( _
    data As Line _
) As String

Parameters

data
Type: Line

See Also

GH_Format Class
FormatLine Overload
Grasshopper.Kernel Namespace


FormatLine Method (GH_Line)

[image]

Grasshopper SDK
GH_Format..::..FormatLine Method (GH_Line)
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatLine(
    GH_Line data
)
Visual Basic
Public Shared Function FormatLine ( _
    data As GH_Line _
) As String

Parameters

data
Type: Grasshopper.Kernel.Types..::..GH_Line

See Also

GH_Format Class
FormatLine Overload
Grasshopper.Kernel Namespace


FormatLineValidity Method

[image]

Grasshopper SDK
GH_Format..::..FormatLineValidity Method
GH_Format Class See Also Send Feedback
If the line is invalid, return a string describing why.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatLineValidity(
    Line val,
    string identifier
)
Visual Basic
Public Shared Function FormatLineValidity ( _
    val As Line, _
    identifier As String _
) As String

Parameters

val
Type: Line
Value to format.
identifier
Type: System..::..String
Name used to refer to the value in the format.

Return Value

A string describing why the line is invalid or String.Empty if the value is not invalid.

See Also

GH_Format Class
Grasshopper.Kernel Namespace


FormatMatrix Method

[image] [image]

Grasshopper SDK
GH_Format..::..FormatMatrix Method
GH_Format Class See Also Send Feedback

Overload List

Name | Description
FormatMatrix(Matrix) |
FormatMatrix(GH_Matrix) |

See Also

GH_Format Class
GH_Format Members
Grasshopper.Kernel Namespace


FormatMatrix Method ()

[image]

Grasshopper SDK
GH_Format..::..FormatMatrix Method ()
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatMatrix(
    Matrix data
)
Visual Basic
Public Shared Function FormatMatrix ( _
    data As Matrix _
) As String

Parameters

data
Type: Matrix

See Also

GH_Format Class
FormatMatrix Overload
Grasshopper.Kernel Namespace


FormatMatrix Method (GH_Matrix)

[image]

Grasshopper SDK
GH_Format..::..FormatMatrix Method (GH_Matrix)
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatMatrix(
    GH_Matrix data
)
Visual Basic
Public Shared Function FormatMatrix ( _
    data As GH_Matrix _
) As String

Parameters

data
Type: Grasshopper.Kernel.Types..::..GH_Matrix

See Also

GH_Format Class
FormatMatrix Overload
Grasshopper.Kernel Namespace


FormatMesh Method

[image] [image]

Grasshopper SDK
GH_Format..::..FormatMesh Method
GH_Format Class See Also Send Feedback

Overload List

Name | Description
FormatMesh(GH_Mesh) |
FormatMesh(Mesh, String) |

See Also

GH_Format Class
GH_Format Members
Grasshopper.Kernel Namespace


FormatMesh Method (GH_Mesh)

[image]

Grasshopper SDK
GH_Format..::..FormatMesh Method (GH_Mesh)
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatMesh(
    GH_Mesh data
)
Visual Basic
Public Shared Function FormatMesh ( _
    data As GH_Mesh _
) As String

Parameters

data
Type: Grasshopper.Kernel.Types..::..GH_Mesh

See Also

GH_Format Class
FormatMesh Overload
Grasshopper.Kernel Namespace


FormatMesh Method (, String)

[image]

Grasshopper SDK
GH_Format..::..FormatMesh Method (, String)
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatMesh(
    Mesh data,
    string sPrefix
)
Visual Basic
Public Shared Function FormatMesh ( _
    data As Mesh, _
    sPrefix As String _
) As String

Parameters

data
Type: Mesh
sPrefix
Type: System..::..String

See Also

GH_Format Class
FormatMesh Overload
Grasshopper.Kernel Namespace


FormatMeshFace Method

[image]

Grasshopper SDK
GH_Format..::..FormatMeshFace Method
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatMeshFace(
    GH_MeshFace data
)
Visual Basic
Public Shared Function FormatMeshFace ( _
    data As GH_MeshFace _
) As String

Parameters

data
Type: Grasshopper.Kernel.Types..::..GH_MeshFace

See Also

GH_Format Class
Grasshopper.Kernel Namespace


FormatMeshFaceValidity Method

[image]

Grasshopper SDK
GH_Format..::..FormatMeshFaceValidity Method
GH_Format Class See Also Send Feedback
If the number is invalid, return a string describing why.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatMeshFaceValidity(
    MeshFace val,
    string identifier
)
Visual Basic
Public Shared Function FormatMeshFaceValidity ( _
    val As MeshFace, _
    identifier As String _
) As String

Parameters

val
Type: MeshFace
Value to format.
identifier
Type: System..::..String
Name used to refer to the value in the format.

Return Value

A string describing why the point is invalid or String.Empty if the value is not invalid.

See Also

GH_Format Class
Grasshopper.Kernel Namespace


FormatMeshValidity Method

[image]

Grasshopper SDK
GH_Format..::..FormatMeshValidity Method
GH_Format Class See Also Send Feedback
If the mesh is invalid, return a string describing why.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatMeshValidity(
    Mesh val,
    string identifier
)
Visual Basic
Public Shared Function FormatMeshValidity ( _
    val As Mesh, _
    identifier As String _
) As String

Parameters

val
Type: Mesh
Value to format.
identifier
Type: System..::..String
Name used to refer to the value in the format.

Return Value

A string describing why the mesh is invalid or String.Empty if the value is not invalid.

See Also

GH_Format Class
Grasshopper.Kernel Namespace


FormatPlane Method

[image] [image]

Grasshopper SDK
GH_Format..::..FormatPlane Method
GH_Format Class See Also Send Feedback

Overload List

Name | Description
FormatPlane(Plane) |
FormatPlane(GH_Plane) |

See Also

GH_Format Class
GH_Format Members
Grasshopper.Kernel Namespace


FormatPlane Method ()

[image]

Grasshopper SDK
GH_Format..::..FormatPlane Method ()
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatPlane(
    Plane data
)
Visual Basic
Public Shared Function FormatPlane ( _
    data As Plane _
) As String

Parameters

data
Type: Plane

See Also

GH_Format Class
FormatPlane Overload
Grasshopper.Kernel Namespace


FormatPlane Method (GH_Plane)

[image]

Grasshopper SDK
GH_Format..::..FormatPlane Method (GH_Plane)
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatPlane(
    GH_Plane data
)
Visual Basic
Public Shared Function FormatPlane ( _
    data As GH_Plane _
) As String

Parameters

data
Type: Grasshopper.Kernel.Types..::..GH_Plane

See Also

GH_Format Class
FormatPlane Overload
Grasshopper.Kernel Namespace


FormatPlaneValidity Method

[image]

Grasshopper SDK
GH_Format..::..FormatPlaneValidity Method
GH_Format Class See Also Send Feedback
If the plane is invalid, return a string describing why.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatPlaneValidity(
    Plane val,
    string identifier,
    bool testUnitAxes
)
Visual Basic
Public Shared Function FormatPlaneValidity ( _
    val As Plane, _
    identifier As String, _
    testUnitAxes As Boolean _
) As String

Parameters

val
Type: Plane
Value to format.
identifier
Type: System..::..String
Name used to refer to the value in the format.
testUnitAxes
Type: System..::..Boolean
If True, planes with non-unit axis vectors are considered to be invalid.

Return Value

A string describing why the plane is invalid or String.Empty if the value is not invalid.

See Also

GH_Format Class
Grasshopper.Kernel Namespace


FormatPoint Method

[image] [image]

Grasshopper SDK
GH_Format..::..FormatPoint Method
GH_Format Class See Also Send Feedback

Overload List

Name | Description
FormatPoint(Point3d) |
FormatPoint(GH_Point) |

See Also

GH_Format Class
GH_Format Members
Grasshopper.Kernel Namespace


FormatPoint Method ()

[image]

Grasshopper SDK
GH_Format..::..FormatPoint Method ()
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatPoint(
    Point3d data
)
Visual Basic
Public Shared Function FormatPoint ( _
    data As Point3d _
) As String

Parameters

data
Type: Point3d

See Also

GH_Format Class
FormatPoint Overload
Grasshopper.Kernel Namespace


FormatPoint Method (GH_Point)

[image]

Grasshopper SDK
GH_Format..::..FormatPoint Method (GH_Point)
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatPoint(
    GH_Point data
)
Visual Basic
Public Shared Function FormatPoint ( _
    data As GH_Point _
) As String

Parameters

data
Type: Grasshopper.Kernel.Types..::..GH_Point

See Also

GH_Format Class
FormatPoint Overload
Grasshopper.Kernel Namespace


FormatPointCloud Method

[image]

Grasshopper SDK
GH_Format..::..FormatPointCloud Method
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatPointCloud(
    PointCloud data
)
Visual Basic
Public Shared Function FormatPointCloud ( _
    data As PointCloud _
) As String

Parameters

data
Type: PointCloud

See Also

GH_Format Class
Grasshopper.Kernel Namespace


FormatPointValidity Method

[image]

Grasshopper SDK
GH_Format..::..FormatPointValidity Method
GH_Format Class See Also Send Feedback
If the point is invalid, return a string describing why.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatPointValidity(
    Point3d val,
    string identifier
)
Visual Basic
Public Shared Function FormatPointValidity ( _
    val As Point3d, _
    identifier As String _
) As String

Parameters

val
Type: Point3d
Value to format.
identifier
Type: System..::..String
Name used to refer to the value in the format.

Return Value

A string describing why the point is invalid or String.Empty if the value is not invalid.

See Also

GH_Format Class
Grasshopper.Kernel Namespace


FormatRectangleValidity Method

[image]

Grasshopper SDK
GH_Format..::..FormatRectangleValidity Method
GH_Format Class See Also Send Feedback
If the rectangle is invalid, return a string describing why.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatRectangleValidity(
    Rectangle3d val,
    string identifier
)
Visual Basic
Public Shared Function FormatRectangleValidity ( _
    val As Rectangle3d, _
    identifier As String _
) As String

Parameters

val
Type: Rectangle3d
Value to format.
identifier
Type: System..::..String
Name used to refer to the value in the format.

Return Value

A string describing why the rectangle is invalid or String.Empty if the value is not invalid.

See Also

GH_Format Class
Grasshopper.Kernel Namespace


FormatSingle Method

[image]

Grasshopper SDK
GH_Format..::..FormatSingle Method
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatSingle(
    float data
)
Visual Basic
Public Shared Function FormatSingle ( _
    data As Single _
) As String

Parameters

data
Type: System..::..Single

See Also

GH_Format Class
Grasshopper.Kernel Namespace


FormatSurface Method

[image] [image]

Grasshopper SDK
GH_Format..::..FormatSurface Method
GH_Format Class See Also Send Feedback

Overload List

Name | Description
FormatSurface(Brep) |
FormatSurface(GH_Surface) |

See Also

GH_Format Class
GH_Format Members
Grasshopper.Kernel Namespace


FormatSurface Method ()

[image]

Grasshopper SDK
GH_Format..::..FormatSurface Method ()
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatSurface(
    Brep data
)
Visual Basic
Public Shared Function FormatSurface ( _
    data As Brep _
) As String

Parameters

data
Type: Brep

See Also

GH_Format Class
FormatSurface Overload
Grasshopper.Kernel Namespace


FormatSurface Method (GH_Surface)

[image]

Grasshopper SDK
GH_Format..::..FormatSurface Method (GH_Surface)
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatSurface(
    GH_Surface data
)
Visual Basic
Public Shared Function FormatSurface ( _
    data As GH_Surface _
) As String

Parameters

data
Type: Grasshopper.Kernel.Types..::..GH_Surface

See Also

GH_Format Class
FormatSurface Overload
Grasshopper.Kernel Namespace


FormatSurfaceValidity Method

[image]

Grasshopper SDK
GH_Format..::..FormatSurfaceValidity Method
GH_Format Class See Also Send Feedback
If the surface is invalid, return a string describing why.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatSurfaceValidity(
    Surface val,
    string identifier
)
Visual Basic
Public Shared Function FormatSurfaceValidity ( _
    val As Surface, _
    identifier As String _
) As String

Parameters

val
Type: Surface
Value to format.
identifier
Type: System..::..String
Name used to refer to the value in the format.

Return Value

A string describing why the surface is invalid or String.Empty if the value is not invalid.

See Also

GH_Format Class
Grasshopper.Kernel Namespace


FormatTransformValidity Method

[image]

Grasshopper SDK
GH_Format..::..FormatTransformValidity Method
GH_Format Class See Also Send Feedback
If the transform is invalid, return a string describing why.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatTransformValidity(
    Transform val,
    string identifier
)
Visual Basic
Public Shared Function FormatTransformValidity ( _
    val As Transform, _
    identifier As String _
) As String

Parameters

val
Type: Transform
Value to format.
identifier
Type: System..::..String
Name used to refer to the value in the format.

Return Value

A string describing why the transform is invalid or String.Empty if the value is not invalid.

See Also

GH_Format Class
Grasshopper.Kernel Namespace


FormatVector Method

[image] [image]

Grasshopper SDK
GH_Format..::..FormatVector Method
GH_Format Class See Also Send Feedback

Overload List

Name | Description
FormatVector(Vector3d) |
FormatVector(GH_Vector) |

See Also

GH_Format Class
GH_Format Members
Grasshopper.Kernel Namespace


FormatVector Method ()

[image]

Grasshopper SDK
GH_Format..::..FormatVector Method ()
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatVector(
    Vector3d data
)
Visual Basic
Public Shared Function FormatVector ( _
    data As Vector3d _
) As String

Parameters

data
Type: Vector3d

See Also

GH_Format Class
FormatVector Overload
Grasshopper.Kernel Namespace


FormatVector Method (GH_Vector)

[image]

Grasshopper SDK
GH_Format..::..FormatVector Method (GH_Vector)
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatVector(
    GH_Vector data
)
Visual Basic
Public Shared Function FormatVector ( _
    data As GH_Vector _
) As String

Parameters

data
Type: Grasshopper.Kernel.Types..::..GH_Vector

See Also

GH_Format Class
FormatVector Overload
Grasshopper.Kernel Namespace


FormatVectorValidity Method

[image]

Grasshopper SDK
GH_Format..::..FormatVectorValidity Method
GH_Format Class See Also Send Feedback
If the point is invalid, return a string describing why.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string FormatVectorValidity(
    Vector3d val,
    string identifier,
    bool testZero,
    bool testUnit
)
Visual Basic
Public Shared Function FormatVectorValidity ( _
    val As Vector3d, _
    identifier As String, _
    testZero As Boolean, _
    testUnit As Boolean _
) As String

Parameters

val
Type: Vector3d
Value to format.
identifier
Type: System..::..String
Name used to refer to the value in the format.
testZero
Type: System..::..Boolean
If True, zero-length vectors are considered to be invalid.
testUnit
Type: System..::..Boolean
If True, non-unit-length vectors are considered to be invalid.

Return Value

A string describing why the point is invalid or String.Empty if the value is not invalid.

See Also

GH_Format Class
Grasshopper.Kernel Namespace


RhinoUnitName Method

[image]

Grasshopper SDK
GH_Format..::..RhinoUnitName Method
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string RhinoUnitName()
Visual Basic
Public Shared Function RhinoUnitName As String

See Also

GH_Format Class
Grasshopper.Kernel Namespace


RhinoUnitSymbol Method

[image]

Grasshopper SDK
GH_Format..::..RhinoUnitSymbol Method
GH_Format Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string RhinoUnitSymbol()
Visual Basic
Public Shared Function RhinoUnitSymbol As String

See Also

GH_Format Class
Grasshopper.Kernel Namespace


TreatAsCollection Method

[image]

Grasshopper SDK
GH_Format..::..TreatAsCollection Method
GH_Format Class See Also Send Feedback
This method is used in Scripting components to determine whether a certain class was 'intended' as a collection or as a single piece of data .

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool TreatAsCollection(
    Object obj
)
Visual Basic
Public Shared Function TreatAsCollection ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object
Object to test.

Return Value

True if we think the object was intended as a collection.

See Also

GH_Format Class
Grasshopper.Kernel Namespace


GH_GetterResult Enumeration

[image]

Grasshopper SDK
GH_GetterResult Enumeration
See Also Send Feedback
Enumerates typical getter results.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_GetterResult
Visual Basic
Public Enumeration GH_GetterResult

Members

Member name | Value | Description
accept | 0 |
success | 1 |
cancel | 2 |

See Also

Grasshopper.Kernel Namespace


GH_GHALoadingEventArgs Class

[image]

Grasshopper SDK
GH_GHALoadingEventArgs Class
Members See Also Send Feedback
Event arguments used in the GH_GHALoaded event on GH_ComponentServer.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_GHALoadingEventArgs : EventArgs
Visual Basic
Public Class GH_GHALoadingEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Grasshopper.Kernel..::..GH_GHALoadingEventArgs

See Also

GH_GHALoadingEventArgs Members
Grasshopper.Kernel Namespace


GH_GHALoadingEventArgs Members

[image] [image]

Grasshopper SDK
GH_GHALoadingEventArgs Members
GH_GHALoadingEventArgs Class Properties See Also Send Feedback

The GH_GHALoadingEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Assembly | Gets the assembly that was loaded from the GHA file.
Public property | FileName | Gets the location of the gha file.
Public property | Icon | Gets the official icon of the GHA file.
Public property | Id | Gets the Id of the GHA file.
Public property | LoadingMechanism | Gets the mechanism that was used to load the file.
Public property | Name | Gets the official name of the GHA file.

See Also

GH_GHALoadingEventArgs Class
Grasshopper.Kernel Namespace


GH_GHALoadingEventArgs Properties

[image] [image]

Grasshopper SDK
GH_GHALoadingEventArgs Properties
GH_GHALoadingEventArgs Class See Also Send Feedback

The GH_GHALoadingEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Assembly | Gets the assembly that was loaded from the GHA file.
Public property | FileName | Gets the location of the gha file.
Public property | Icon | Gets the official icon of the GHA file.
Public property | Id | Gets the Id of the GHA file.
Public property | LoadingMechanism | Gets the mechanism that was used to load the file.
Public property | Name | Gets the official name of the GHA file.

See Also

GH_GHALoadingEventArgs Class
Grasshopper.Kernel Namespace


Assembly Property

[image]

Grasshopper SDK
GH_GHALoadingEventArgs..::..Assembly Property
GH_GHALoadingEventArgs Class See Also Send Feedback
Gets the assembly that was loaded from the GHA file.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Assembly Assembly { get; }
Visual Basic
Public ReadOnly Property Assembly As Assembly
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_GHALoadingEventArgs.Assembly"]

See Also

GH_GHALoadingEventArgs Class
Grasshopper.Kernel Namespace


FileName Property

[image]

Grasshopper SDK
GH_GHALoadingEventArgs..::..FileName Property
GH_GHALoadingEventArgs Class See Also Send Feedback
Gets the location of the gha file.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string FileName { get; }
Visual Basic
Public ReadOnly Property FileName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_GHALoadingEventArgs.FileName"]

See Also

GH_GHALoadingEventArgs Class
Grasshopper.Kernel Namespace


Icon Property

[image]

Grasshopper SDK
GH_GHALoadingEventArgs..::..Icon Property
GH_GHALoadingEventArgs Class See Also Send Feedback
Gets the official icon of the GHA file.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Bitmap Icon { get; }
Visual Basic
Public ReadOnly Property Icon As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_GHALoadingEventArgs.Icon"]

See Also

GH_GHALoadingEventArgs Class
Grasshopper.Kernel Namespace


Id Property

[image]

Grasshopper SDK
GH_GHALoadingEventArgs..::..Id Property
GH_GHALoadingEventArgs Class See Also Send Feedback
Gets the Id of the GHA file.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid Id { get; }
Visual Basic
Public ReadOnly Property Id As Guid
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_GHALoadingEventArgs.Id"]

See Also

GH_GHALoadingEventArgs Class
Grasshopper.Kernel Namespace


LoadingMechanism Property

[image]

Grasshopper SDK
GH_GHALoadingEventArgs..::..LoadingMechanism Property
GH_GHALoadingEventArgs Class See Also Send Feedback
Gets the mechanism that was used to load the file.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_LoadingMechanism LoadingMechanism { get; }
Visual Basic
Public ReadOnly Property LoadingMechanism As GH_LoadingMechanism
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_GHALoadingEventArgs.LoadingMechanism"]

See Also

GH_GHALoadingEventArgs Class
Grasshopper.Kernel Namespace


Name Property

[image]

Grasshopper SDK
GH_GHALoadingEventArgs..::..Name Property
GH_GHALoadingEventArgs Class See Also Send Feedback
Gets the official name of the GHA file.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_GHALoadingEventArgs.Name"]

See Also

GH_GHALoadingEventArgs Class
Grasshopper.Kernel Namespace


GH_GHXHarvester Class

[image]

Grasshopper SDK
GH_GHXHarvester Class
Members See Also Send Feedback
Provides static methods for harvesting data from GHX and GH files.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class GH_GHXHarvester
Visual Basic
Public NotInheritable Class GH_GHXHarvester

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_GHXHarvester

See Also

GH_GHXHarvester Members
Grasshopper.Kernel Namespace


GH_GHXHarvester Members

[image] [image]

Grasshopper SDK
GH_GHXHarvester Members
GH_GHXHarvester Class Methods See Also Send Feedback

Methods

Name | Description
HarvestBoundingBoxes(String) | Harvest all attribute bounding boxes from a GHX/GH archive.
HarvestBoundingBoxes(GH_Archive) | Harvest all attribute bounding boxes from a GHX/GH archive.
HarvestBoundingBoxes(GH_IReader) | Harvest all attribute bounding boxes from a GHX/GH node.
HarvestPivots(String) | Harvest all attribute pivots from a GHX/GH archive.
HarvestPivots(GH_Archive) | Harvest all attribute pivots from a GHX/GH archive.
HarvestPivots(GH_IReader) | Harvest all attribute pivots from a GHX/GH node.

See Also

GH_GHXHarvester Class
Grasshopper.Kernel Namespace


GH_GHXHarvester Methods

[image] [image]

Grasshopper SDK
GH_GHXHarvester Methods
GH_GHXHarvester Class See Also Send Feedback

Methods

Name | Description
HarvestBoundingBoxes(String) | Harvest all attribute bounding boxes from a GHX/GH archive.
HarvestBoundingBoxes(GH_Archive) | Harvest all attribute bounding boxes from a GHX/GH archive.
HarvestBoundingBoxes(GH_IReader) | Harvest all attribute bounding boxes from a GHX/GH node.
HarvestPivots(String) | Harvest all attribute pivots from a GHX/GH archive.
HarvestPivots(GH_Archive) | Harvest all attribute pivots from a GHX/GH archive.
HarvestPivots(GH_IReader) | Harvest all attribute pivots from a GHX/GH node.

See Also

GH_GHXHarvester Class
Grasshopper.Kernel Namespace


HarvestBoundingBoxes Method

[image] [image]

Grasshopper SDK
GH_GHXHarvester..::..HarvestBoundingBoxes Method
GH_GHXHarvester Class See Also Send Feedback

Overload List

Name | Description
HarvestBoundingBoxes(String) | Harvest all attribute bounding boxes from a GHX/GH archive.
HarvestBoundingBoxes(GH_Archive) | Harvest all attribute bounding boxes from a GHX/GH archive.
HarvestBoundingBoxes(GH_IReader) | Harvest all attribute bounding boxes from a GHX/GH node.

See Also

GH_GHXHarvester Class
GH_GHXHarvester Members
Grasshopper.Kernel Namespace


HarvestBoundingBoxes Method (String)

[image]

Grasshopper SDK
GH_GHXHarvester..::..HarvestBoundingBoxes Method (String)
GH_GHXHarvester Class See Also Send Feedback
Harvest all attribute bounding boxes from a GHX/GH archive.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static List<RectangleF> HarvestBoundingBoxes(
    string file
)
Visual Basic
Public Shared Function HarvestBoundingBoxes ( _
    file As String _
) As List(Of RectangleF)

Parameters

file
Type: System..::..String
File to parse.

Return Value

A list of all attribute bounding boxes or null on failure.

See Also

GH_GHXHarvester Class
HarvestBoundingBoxes Overload
Grasshopper.Kernel Namespace


HarvestBoundingBoxes Method (GH_Archive)

[image]

Grasshopper SDK
GH_GHXHarvester..::..HarvestBoundingBoxes Method (GH_Archive)
GH_GHXHarvester Class See Also Send Feedback
Harvest all attribute bounding boxes from a GHX/GH archive.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static List<RectangleF> HarvestBoundingBoxes(
    GH_Archive archive
)
Visual Basic
Public Shared Function HarvestBoundingBoxes ( _
    archive As GH_Archive _
) As List(Of RectangleF)

Parameters

archive
Type: GH_IO.Serialization..::..GH_Archive
Archive to parse.

Return Value

A list of all attribute bounding boxes or null on failure.

See Also

GH_GHXHarvester Class
HarvestBoundingBoxes Overload
Grasshopper.Kernel Namespace


HarvestBoundingBoxes Method (GH_IReader)

[image]

Grasshopper SDK
GH_GHXHarvester..::..HarvestBoundingBoxes Method (GH_IReader)
GH_GHXHarvester Class See Also Send Feedback
Harvest all attribute bounding boxes from a GHX/GH node.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static List<RectangleF> HarvestBoundingBoxes(
    GH_IReader node
)
Visual Basic
Public Shared Function HarvestBoundingBoxes ( _
    node As GH_IReader _
) As List(Of RectangleF)

Parameters

node
Type: GH_IO.Serialization..::..GH_IReader
Node to parse.

Return Value

A list of all attribute bounding boxes or null on failure.

See Also

GH_GHXHarvester Class
HarvestBoundingBoxes Overload
Grasshopper.Kernel Namespace


HarvestPivots Method

[image] [image]

Grasshopper SDK
GH_GHXHarvester..::..HarvestPivots Method
GH_GHXHarvester Class See Also Send Feedback

Overload List

Name | Description
HarvestPivots(String) | Harvest all attribute pivots from a GHX/GH archive.
HarvestPivots(GH_Archive) | Harvest all attribute pivots from a GHX/GH archive.
HarvestPivots(GH_IReader) | Harvest all attribute pivots from a GHX/GH node.

See Also

GH_GHXHarvester Class
GH_GHXHarvester Members
Grasshopper.Kernel Namespace


HarvestPivots Method (String)

[image]

Grasshopper SDK
GH_GHXHarvester..::..HarvestPivots Method (String)
GH_GHXHarvester Class See Also Send Feedback
Harvest all attribute pivots from a GHX/GH archive.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static List<PointF> HarvestPivots(
    string file
)
Visual Basic
Public Shared Function HarvestPivots ( _
    file As String _
) As List(Of PointF)

Parameters

file
Type: System..::..String
File to parse.

Return Value

A list of all attribute pivots or null on failure.

See Also

GH_GHXHarvester Class
HarvestPivots Overload
Grasshopper.Kernel Namespace


HarvestPivots Method (GH_Archive)

[image]

Grasshopper SDK
GH_GHXHarvester..::..HarvestPivots Method (GH_Archive)
GH_GHXHarvester Class See Also Send Feedback
Harvest all attribute pivots from a GHX/GH archive.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static List<PointF> HarvestPivots(
    GH_Archive archive
)
Visual Basic
Public Shared Function HarvestPivots ( _
    archive As GH_Archive _
) As List(Of PointF)

Parameters

archive
Type: GH_IO.Serialization..::..GH_Archive
Archive to parse.

Return Value

A list of all attribute pivots or null on failure.

See Also

GH_GHXHarvester Class
HarvestPivots Overload
Grasshopper.Kernel Namespace


HarvestPivots Method (GH_IReader)

[image]

Grasshopper SDK
GH_GHXHarvester..::..HarvestPivots Method (GH_IReader)
GH_GHXHarvester Class See Also Send Feedback
Harvest all attribute pivots from a GHX/GH node.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static List<PointF> HarvestPivots(
    GH_IReader node
)
Visual Basic
Public Shared Function HarvestPivots ( _
    node As GH_IReader _
) As List(Of PointF)

Parameters

node
Type: GH_IO.Serialization..::..GH_IReader
Node to parse.

Return Value

A list of all attribute pivots or null on failure.

See Also

GH_GHXHarvester Class
HarvestPivots Overload
Grasshopper.Kernel Namespace


GH_GuidConflictSolution Enumeration

[image]

Grasshopper SDK
GH_GuidConflictSolution Enumeration
See Also Send Feedback
Contains a list of all possible Assembly GUID conflict solutions

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_GuidConflictSolution
Visual Basic
Public Enumeration GH_GuidConflictSolution

Members

Member name | Value | Description
Unset | 0 | Indicates there is no solution picked yet
Replace | 1 | Replace the loaded proxy with the conflicting proxy
ReplaceAll | 2 | Replace all loaded proxies with all conflicting proxies in the current assembly
Skip | 3 | Skip the conflicting proxy
SkipAll | 4 | Skip all conflicting proxies in the current assembly

See Also

Grasshopper.Kernel Namespace


GH_IconDisplayMode Enumeration

[image]

Grasshopper SDK
GH_IconDisplayMode Enumeration
See Also Send Feedback
Lists all display modes that individual objects can have.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_IconDisplayMode
Visual Basic
Public Enumeration GH_IconDisplayMode

Members

Member name | Value | Description
application | 0 | Inherit the mode from the application setting. This is the default setting.
icon | 1 | Always display the icon.
name | 2 | Always display the nickname.

See Also

Grasshopper.Kernel Namespace


GH_InstanceDescription Class

[image]

Grasshopper SDK
GH_InstanceDescription Class
Members See Also Send Feedback
Base implementation of IGH_InstanceDescription. Consider deriving from this class rather than implementing IGH_InstanceDescription from scratch.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_InstanceDescription : IGH_InstanceDescription
Visual Basic
Public Class GH_InstanceDescription _
    Implements IGH_InstanceDescription

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_InstanceDescription
Grasshopper.Kernel..::..GH_DocumentObject

See Also

GH_InstanceDescription Members
Grasshopper.Kernel Namespace


GH_InstanceDescription Members

[image] [image]

Grasshopper SDK
GH_InstanceDescription Members
GH_InstanceDescription Class Methods Properties See Also Send Feedback

The GH_InstanceDescription type exposes the following members.

Methods

 | Name | Description
Public method | CopyFrom | Copy all fields (except the instance ID) from another instance description.
Public method | NewInstanceGuid()()()() | Generate a new random instance GUID
Public method | NewInstanceGuid(Guid) | Set the instance ID to be a specific GUID. This is very dangerous, only use this function if you're 6"4' and your first name is David.
Public method | Read | Default deserialization. Only retrieves Name, NickName, Description and InstanceGuid fields. If you want to retrieve additional fields use ReadFull() instead. However, ReadFull() will only work if the archive was written using WriteFull().
Public method | ReadFull | GH_InstanceDescription does not by default serialize all fields. Use this function to read all fields from the archive. This method is compatible with the default Write()/Read() operations.
Public method | Write | Default serialization. Only stores Name, NickName, Description and InstanceGuid fields. If you want to store additional fields use WriteFull() instead.
Public method | WriteFull | GH_InstanceDescription does not by default serialize all fields. Use this function to write all fields to the archive. This method is compatible with the default Write()/Read() operations.

Properties

 | Name | Description
Public property | Category | Gets or sets the Category in which this object belongs. If HasCategory() returns false, this field has no meaning.
Public property | Description | Gets or sets the description of the object. This field typically remains fixed during the lifetime of an object.
Public property | HasCategory | Gets whether or not the Category field has been set.
Public property | HasSubCategory | Gets whether or not the SubCategory field has been set.
Public property | InstanceDescription | Gets a description of the current state of the object. This field is usually the same as the Description() field, but it might be variable when overridden.
Public property | InstanceGuid | Gets the ID of this runtime instance.
Public property | Keywords | Gets a list of additional keywords that describe the object. Typically this list is empty but you can override this property to aid in object searches.
Public property | Name | Gets or sets the name of the object. This field typically remains fixed during the lifetime of an object.
Public property | NickName | Gets or sets the nickname of the object. This field can be changed by the user.
Public property | SubCategory | Gets or sets the SubCategory in which this object belongs. If HasSubCategory() returns false, this field has no meaning.

See Also

GH_InstanceDescription Class
Grasshopper.Kernel Namespace


GH_InstanceDescription Methods

[image] [image]

Grasshopper SDK
GH_InstanceDescription Methods
GH_InstanceDescription Class See Also Send Feedback

The GH_InstanceDescription type exposes the following members.

Methods

 | Name | Description
Public method | CopyFrom | Copy all fields (except the instance ID) from another instance description.
Public method | NewInstanceGuid()()()() | Generate a new random instance GUID
Public method | NewInstanceGuid(Guid) | Set the instance ID to be a specific GUID. This is very dangerous, only use this function if you're 6"4' and your first name is David.
Public method | Read | Default deserialization. Only retrieves Name, NickName, Description and InstanceGuid fields. If you want to retrieve additional fields use ReadFull() instead. However, ReadFull() will only work if the archive was written using WriteFull().
Public method | ReadFull | GH_InstanceDescription does not by default serialize all fields. Use this function to read all fields from the archive. This method is compatible with the default Write()/Read() operations.
Public method | Write | Default serialization. Only stores Name, NickName, Description and InstanceGuid fields. If you want to store additional fields use WriteFull() instead.
Public method | WriteFull | GH_InstanceDescription does not by default serialize all fields. Use this function to write all fields to the archive. This method is compatible with the default Write()/Read() operations.

See Also

GH_InstanceDescription Class
Grasshopper.Kernel Namespace


CopyFrom Method

[image]

Grasshopper SDK
GH_InstanceDescription..::..CopyFrom Method
GH_InstanceDescription Class See Also Send Feedback
Copy all fields (except the instance ID) from another instance description.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void CopyFrom(
    IGH_InstanceDescription other
)
Visual Basic
Public Sub CopyFrom ( _
    other As IGH_InstanceDescription _
)

Parameters

other
Type: Grasshopper.Kernel..::..IGH_InstanceDescription
Object to mimic.

See Also

GH_InstanceDescription Class
Grasshopper.Kernel Namespace


NewInstanceGuid Method

[image] [image]

Grasshopper SDK
GH_InstanceDescription..::..NewInstanceGuid Method
GH_InstanceDescription Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NewInstanceGuid()()()() | Generate a new random instance GUID
Public method | NewInstanceGuid(Guid) | Set the instance ID to be a specific GUID. This is very dangerous, only use this function if you're 6"4' and your first name is David.

See Also

GH_InstanceDescription Class
GH_InstanceDescription Members
Grasshopper.Kernel Namespace


NewInstanceGuid Method

[image]

Grasshopper SDK
GH_InstanceDescription..::..NewInstanceGuid Method
GH_InstanceDescription Class See Also Send Feedback
Generate a new random instance GUID

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void NewInstanceGuid()
Visual Basic
Public Sub NewInstanceGuid

Implements

IGH_InstanceDescription..::..NewInstanceGuid()()()()

See Also

GH_InstanceDescription Class
NewInstanceGuid Overload
Grasshopper.Kernel Namespace


NewInstanceGuid Method (Guid)

[image]

Grasshopper SDK
GH_InstanceDescription..::..NewInstanceGuid Method (Guid)
GH_InstanceDescription Class See Also Send Feedback
Set the instance ID to be a specific GUID. This is very dangerous, only use this function if you're 6"4' and your first name is David.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void NewInstanceGuid(
    Guid UUID
)
Visual Basic
Public Sub NewInstanceGuid ( _
    UUID As Guid _
)

Parameters

UUID
Type: System..::..Guid

Implements

IGH_InstanceDescription..::..NewInstanceGuid(Guid)

See Also

GH_InstanceDescription Class
NewInstanceGuid Overload
Grasshopper.Kernel Namespace


Read Method

[image]

Grasshopper SDK
GH_InstanceDescription..::..Read Method
GH_InstanceDescription Class See Also Send Feedback
Default deserialization. Only retrieves Name, NickName, Description and InstanceGuid fields. If you want to retrieve additional fields use ReadFull() instead. However, ReadFull() will only work if the archive was written using WriteFull().

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool Read(
    GH_IReader reader
)
Visual Basic
Public Overridable Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader
Object to deserialize with.

Return Value

Always True.

Implements

GH_ISerializable..::..Read(GH_IReader)

See Also

GH_InstanceDescription Class
Grasshopper.Kernel Namespace


ReadFull Method

[image]

Grasshopper SDK
GH_InstanceDescription..::..ReadFull Method
GH_InstanceDescription Class See Also Send Feedback
GH_InstanceDescription does not by default serialize all fields. Use this function to read all fields from the archive. This method is compatible with the default Write()/Read() operations.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool ReadFull(
    GH_IReader reader
)
Visual Basic
Public Overridable Function ReadFull ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader
Writer for deserialization.

Return Value

True on success, false on failure.

See Also

GH_InstanceDescription Class
Grasshopper.Kernel Namespace


Write Method

[image]

Grasshopper SDK
GH_InstanceDescription..::..Write Method
GH_InstanceDescription Class See Also Send Feedback
Default serialization. Only stores Name, NickName, Description and InstanceGuid fields. If you want to store additional fields use WriteFull() instead.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overridable Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter
Object to serialize with.

Return Value

Always True.

Implements

GH_ISerializable..::..Write(GH_IWriter)

See Also

GH_InstanceDescription Class
Grasshopper.Kernel Namespace


WriteFull Method

[image]

Grasshopper SDK
GH_InstanceDescription..::..WriteFull Method
GH_InstanceDescription Class See Also Send Feedback
GH_InstanceDescription does not by default serialize all fields. Use this function to write all fields to the archive. This method is compatible with the default Write()/Read() operations.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool WriteFull(
    GH_IWriter writer
)
Visual Basic
Public Overridable Function WriteFull ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter
Writer for serialization.

Return Value

True on success, false on failure.

See Also

GH_InstanceDescription Class
Grasshopper.Kernel Namespace


GH_InstanceDescription Properties

[image] [image]

Grasshopper SDK
GH_InstanceDescription Properties
GH_InstanceDescription Class See Also Send Feedback

The GH_InstanceDescription type exposes the following members.

Properties

 | Name | Description
Public property | Category | Gets or sets the Category in which this object belongs. If HasCategory() returns false, this field has no meaning.
Public property | Description | Gets or sets the description of the object. This field typically remains fixed during the lifetime of an object.
Public property | HasCategory | Gets whether or not the Category field has been set.
Public property | HasSubCategory | Gets whether or not the SubCategory field has been set.
Public property | InstanceDescription | Gets a description of the current state of the object. This field is usually the same as the Description() field, but it might be variable when overridden.
Public property | InstanceGuid | Gets the ID of this runtime instance.
Public property | Keywords | Gets a list of additional keywords that describe the object. Typically this list is empty but you can override this property to aid in object searches.
Public property | Name | Gets or sets the name of the object. This field typically remains fixed during the lifetime of an object.
Public property | NickName | Gets or sets the nickname of the object. This field can be changed by the user.
Public property | SubCategory | Gets or sets the SubCategory in which this object belongs. If HasSubCategory() returns false, this field has no meaning.

See Also

GH_InstanceDescription Class
Grasshopper.Kernel Namespace


Category Property

[image]

Grasshopper SDK
GH_InstanceDescription..::..Category Property
GH_InstanceDescription Class See Also Send Feedback
Gets or sets the Category in which this object belongs. If HasCategory() returns false, this field has no meaning.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual string Category { get; set; }
Visual Basic
Public Overridable Property Category As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_InstanceDescription.Category"]

Implements

IGH_InstanceDescription..::..Category

See Also

GH_InstanceDescription Class
Grasshopper.Kernel Namespace


Description Property

[image]

Grasshopper SDK
GH_InstanceDescription..::..Description Property
GH_InstanceDescription Class See Also Send Feedback
Gets or sets the description of the object. This field typically remains fixed during the lifetime of an object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual string Description { get; set; }
Visual Basic
Public Overridable Property Description As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_InstanceDescription.Description"]

Implements

IGH_InstanceDescription..::..Description

See Also

GH_InstanceDescription Class
Grasshopper.Kernel Namespace


HasCategory Property

[image]

Grasshopper SDK
GH_InstanceDescription..::..HasCategory Property
GH_InstanceDescription Class See Also Send Feedback
Gets whether or not the Category field has been set.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool HasCategory { get; }
Visual Basic
Public ReadOnly Property HasCategory As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_InstanceDescription.HasCategory"]

Implements

IGH_InstanceDescription..::..HasCategory

See Also

GH_InstanceDescription Class
Grasshopper.Kernel Namespace


HasSubCategory Property

[image]

Grasshopper SDK
GH_InstanceDescription..::..HasSubCategory Property
GH_InstanceDescription Class See Also Send Feedback
Gets whether or not the SubCategory field has been set.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool HasSubCategory { get; }
Visual Basic
Public ReadOnly Property HasSubCategory As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_InstanceDescription.HasSubCategory"]

Implements

IGH_InstanceDescription..::..HasSubCategory

See Also

GH_InstanceDescription Class
Grasshopper.Kernel Namespace


InstanceDescription Property

[image]

Grasshopper SDK
GH_InstanceDescription..::..InstanceDescription Property
GH_InstanceDescription Class See Also Send Feedback
Gets a description of the current state of the object. This field is usually the same as the Description() field, but it might be variable when overridden.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual string InstanceDescription { get; }
Visual Basic
Public Overridable ReadOnly Property InstanceDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_InstanceDescription.InstanceDescription"]

Implements

IGH_InstanceDescription..::..InstanceDescription

See Also

GH_InstanceDescription Class
Grasshopper.Kernel Namespace


InstanceGuid Property

[image]

Grasshopper SDK
GH_InstanceDescription..::..InstanceGuid Property
GH_InstanceDescription Class See Also Send Feedback
Gets the ID of this runtime instance.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid InstanceGuid { get; }
Visual Basic
Public ReadOnly Property InstanceGuid As Guid
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_InstanceDescription.InstanceGuid"]

Implements

IGH_InstanceDescription..::..InstanceGuid

See Also

GH_InstanceDescription Class
Grasshopper.Kernel Namespace


Keywords Property

[image]

Grasshopper SDK
GH_InstanceDescription..::..Keywords Property
GH_InstanceDescription Class See Also Send Feedback
Gets a list of additional keywords that describe the object. Typically this list is empty but you can override this property to aid in object searches.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual IEnumerable<string> Keywords { get; }
Visual Basic
Public Overridable ReadOnly Property Keywords As IEnumerable(Of String)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_InstanceDescription.Keywords"]

Implements

IGH_InstanceDescription..::..Keywords

See Also

GH_InstanceDescription Class
Grasshopper.Kernel Namespace


Name Property

[image]

Grasshopper SDK
GH_InstanceDescription..::..Name Property
GH_InstanceDescription Class See Also Send Feedback
Gets or sets the name of the object. This field typically remains fixed during the lifetime of an object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual string Name { get; set; }
Visual Basic
Public Overridable Property Name As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_InstanceDescription.Name"]

Implements

IGH_InstanceDescription..::..Name

See Also

GH_InstanceDescription Class
Grasshopper.Kernel Namespace


NickName Property

[image]

Grasshopper SDK
GH_InstanceDescription..::..NickName Property
GH_InstanceDescription Class See Also Send Feedback
Gets or sets the nickname of the object. This field can be changed by the user.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual string NickName { get; set; }
Visual Basic
Public Overridable Property NickName As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_InstanceDescription.NickName"]

Implements

IGH_InstanceDescription..::..NickName

See Also

GH_InstanceDescription Class
Grasshopper.Kernel Namespace


SubCategory Property

[image]

Grasshopper SDK
GH_InstanceDescription..::..SubCategory Property
GH_InstanceDescription Class See Also Send Feedback
Gets or sets the SubCategory in which this object belongs. If HasSubCategory() returns false, this field has no meaning.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual string SubCategory { get; set; }
Visual Basic
Public Overridable Property SubCategory As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_InstanceDescription.SubCategory"]

Implements

IGH_InstanceDescription..::..SubCategory

See Also

GH_InstanceDescription Class
Grasshopper.Kernel Namespace


GH_LibraryLicense Enumeration

[image]

Grasshopper SDK
GH_LibraryLicense Enumeration
See Also Send Feedback
Enumerates the possible library types for GHA assemblies.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_LibraryLicense
Visual Basic
Public Enumeration GH_LibraryLicense

Members

Member name | Value | Description
unset | 0 | Unset library type. You should not return this value.
expired | 1 | The license for this library has expired and it can no longer be used.
alpha | 2 | This library is an Alpha release.
beta | 3 | This library is a Beta release.
free | 4 | This library is freeware.
opensource | 5 | This library is distributed under an open source license.
trial | 6 | This library is running in Trial mode.
commercial | 7 | This library is running under a Commercial license.
educational | 8 | This library is running under an Educational license.
developer | 9 | This library is running under a Developer license.
reseller | 10 | This library is running under a Reseller license.
other | 11 | Undefined library type.

See Also

Grasshopper.Kernel Namespace


GH_LineParser Class

[image]

Grasshopper SDK
GH_LineParser Class
Members See Also Send Feedback
Provides basic functionality for the custom ReadFile component script parsing.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract class GH_LineParser
Visual Basic
Public MustInherit Class GH_LineParser

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_LineParser

See Also

GH_LineParser Members
Grasshopper.Kernel Namespace


GH_LineParser Members

[image] [image]

Grasshopper SDK
GH_LineParser Members
GH_LineParser Class Constructors Methods See Also Send Feedback

The GH_LineParser type exposes the following members.

Constructors

 | Name | Description
Protected method | GH_LineParser | Initializes a new instance of the GH_LineParser class

Methods

 | Name | Description
Public method | ParseLine | Parse a line of text and convert it to custom data.

See Also

GH_LineParser Class
Grasshopper.Kernel Namespace


GH_LineParser Constructor

[image]

Grasshopper SDK
GH_LineParser Constructor
GH_LineParser Class See Also Send Feedback
Initializes a new instance of the GH_LineParser class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_LineParser()
Visual Basic
Protected Sub New

See Also

GH_LineParser Class
Grasshopper.Kernel Namespace


GH_LineParser Methods

[image] [image]

Grasshopper SDK
GH_LineParser Methods
GH_LineParser Class See Also Send Feedback

The GH_LineParser type exposes the following members.

Methods

 | Name | Description
Public method | ParseLine | Parse a line of text and convert it to custom data.

See Also

GH_LineParser Class
Grasshopper.Kernel Namespace


ParseLine Method

[image]

Grasshopper SDK
GH_LineParser..::..ParseLine Method
GH_LineParser Class See Also Send Feedback
Parse a line of text and convert it to custom data.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract Object ParseLine(
    string line,
    ref GH_LineParserAction action
)
Visual Basic
Public MustOverride Function ParseLine ( _
    line As String, _
    ByRef action As GH_LineParserAction _
) As Object

Parameters

line
Type: System..::..String
Line to parse.
action
Type: Grasshopper.Kernel..::..GH_LineParserAction %
Set the action to take after this function returns. The default is Include.

Return Value

The data represented by the line.

See Also

GH_LineParser Class
Grasshopper.Kernel Namespace


GH_LineParserAction Enumeration

[image]

Grasshopper SDK
GH_LineParserAction Enumeration
See Also Send Feedback
Enumerates the possible actions a line parser can invoke.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_LineParserAction
Visual Basic
Public Enumeration GH_LineParserAction

Members

Member name | Value | Description
Include | 0 | Include the return code of the parser function.
Ignore | 1 | Ignore this line of text and move on to the next line.
Abort | 2 | Ignore this line of text and don't parse all subsequent lines.

See Also

Grasshopper.Kernel Namespace


GH_ListUtil Class

[image]

Grasshopper SDK
GH_ListUtil Class
Members See Also Send Feedback
Provides utilities for dealing with list of Data from input parameters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class GH_ListUtil
Visual Basic
Public NotInheritable Class GH_ListUtil

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_ListUtil

See Also

GH_ListUtil Members
Grasshopper.Kernel Namespace


GH_ListUtil Members

[image] [image]

Grasshopper SDK
GH_ListUtil Members
GH_ListUtil Class Methods See Also Send Feedback

The GH_ListUtil type exposes the following members.

Methods

Name | Description
CountNonNullRefs<(Of <<'(T>)>>) | Count all object references in L
CountNullRefs<(Of <<'(T>)>>) | Count all null references in L
EnsureNonNullCount<(Of <<'(T>)>>) | Tests a list to see if it contains sufficient non-null references.
FirstNonNullItem<(Of <<'(T>)>>) | Returns the index of the first non-null item in a list.
RemoveNullRefs<(Of <<'(T>)>>) | Remove all null references from a list of items.

See Also

GH_ListUtil Class
Grasshopper.Kernel Namespace


GH_ListUtil Methods

[image] [image]

Grasshopper SDK
GH_ListUtil Methods
GH_ListUtil Class See Also Send Feedback

The GH_ListUtil type exposes the following members.

Methods

Name | Description
CountNonNullRefs<(Of <<'(T>)>>) | Count all object references in L
CountNullRefs<(Of <<'(T>)>>) | Count all null references in L
EnsureNonNullCount<(Of <<'(T>)>>) | Tests a list to see if it contains sufficient non-null references.
FirstNonNullItem<(Of <<'(T>)>>) | Returns the index of the first non-null item in a list.
RemoveNullRefs<(Of <<'(T>)>>) | Remove all null references from a list of items.

See Also

GH_ListUtil Class
Grasshopper.Kernel Namespace


CountNonNullRefs(T) Method

[image]

Grasshopper SDK
GH_ListUtil..::..CountNonNullRefs<(Of <(<'T>)>)> Method
GH_ListUtil Class See Also Send Feedback
Count all object references in L

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static int CountNonNullRefs<T>(
    List<T> L
)
Visual Basic
Public Shared Function CountNonNullRefs(Of T) ( _
    L As List(Of T) _
) As Integer

Parameters

L
Type: System.Collections.Generic..::..List <(Of <(<'T>)>)>
List to parse

Type Parameters

T
Type of list

Return Value

Number of proper objects in L

See Also

GH_ListUtil Class
Grasshopper.Kernel Namespace


CountNullRefs(T) Method

[image]

Grasshopper SDK
GH_ListUtil..::..CountNullRefs<(Of <(<'T>)>)> Method
GH_ListUtil Class See Also Send Feedback
Count all null references in L

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static int CountNullRefs<T>(
    List<T> L
)
Visual Basic
Public Shared Function CountNullRefs(Of T) ( _
    L As List(Of T) _
) As Integer

Parameters

L
Type: System.Collections.Generic..::..List <(Of <(<'T>)>)>
List to parse

Type Parameters

T
Type of list

Return Value

Number of nulls in L

See Also

GH_ListUtil Class
Grasshopper.Kernel Namespace


EnsureNonNullCount(T) Method

[image]

Grasshopper SDK
GH_ListUtil..::..EnsureNonNullCount<(Of <(<'T>)>)> Method
GH_ListUtil Class See Also Send Feedback
Tests a list to see if it contains sufficient non-null references.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool EnsureNonNullCount<T>(
    List<T> L,
    int N
)
Visual Basic
Public Shared Function EnsureNonNullCount(Of T) ( _
    L As List(Of T), _
    N As Integer _
) As Boolean

Parameters

L
Type: System.Collections.Generic..::..List <(Of <(<'T>)>)>
List to parse
N
Type: System..::..Int32

Type Parameters

T
Type of list

Return Value

True if L contains N or more non-null references.

See Also

GH_ListUtil Class
Grasshopper.Kernel Namespace


FirstNonNullItem(T) Method

[image]

Grasshopper SDK
GH_ListUtil..::..FirstNonNullItem<(Of <(<'T>)>)> Method
GH_ListUtil Class See Also Send Feedback
Returns the index of the first non-null item in a list.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static int FirstNonNullItem<T>(
    List<T> L
)
Visual Basic
Public Shared Function FirstNonNullItem(Of T) ( _
    L As List(Of T) _
) As Integer

Parameters

L
Type: System.Collections.Generic..::..List <(Of <(<'T>)>)>
List to parse.

Type Parameters

T
Type of list

Return Value

The index of the first non-null item or -1 if no object reference could be found.

See Also

GH_ListUtil Class
Grasshopper.Kernel Namespace


RemoveNullRefs(T) Method

[image]

Grasshopper SDK
GH_ListUtil..::..RemoveNullRefs<(Of <(<'T>)>)> Method
GH_ListUtil Class See Also Send Feedback
Remove all null references from a list of items.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static List<T> RemoveNullRefs<T>(
    List<T> L
)
Visual Basic
Public Shared Function RemoveNullRefs(Of T) ( _
    L As List(Of T) _
) As List(Of T)

Parameters

L
Type: System.Collections.Generic..::..List <(Of <(<'T>)>)>
List to filter

Type Parameters

T
Type of list

Return Value

List containing only non-null items. References are shared with L

See Also

GH_ListUtil Class
Grasshopper.Kernel Namespace


GH_LoadingAttribute Class

[image]

Grasshopper SDK
GH_LoadingAttribute Class
Members See Also Send Feedback
Assembly loading behaviour attribute.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_LoadingAttribute : Attribute
Visual Basic
Public Class GH_LoadingAttribute _
    Inherits Attribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Grasshopper.Kernel..::..GH_LoadingAttribute

See Also

GH_LoadingAttribute Members
Grasshopper.Kernel Namespace


GH_LoadingAttribute Members

[image] [image]

Grasshopper SDK
GH_LoadingAttribute Members
GH_LoadingAttribute Class Constructors See Also Send Feedback

The GH_LoadingAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | GH_LoadingAttribute | Initializes a new instance of the GH_LoadingAttribute class

See Also

GH_LoadingAttribute Class
Grasshopper.Kernel Namespace


GH_LoadingAttribute Constructor

[image]

Grasshopper SDK
GH_LoadingAttribute Constructor
GH_LoadingAttribute Class See Also Send Feedback
Initializes a new instance of the GH_LoadingAttribute class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_LoadingAttribute(
    GH_LoadingDemand demand
)
Visual Basic
Public Sub New ( _
    demand As GH_LoadingDemand _
)

Parameters

demand
Type: Grasshopper.Kernel..::..GH_LoadingDemand

See Also

GH_LoadingAttribute Class
Grasshopper.Kernel Namespace


GH_LoadingDemand Enumeration

[image]

Grasshopper SDK
GH_LoadingDemand Enumeration
See Also Send Feedback
Enumerates all assembly loading behaviour demands.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_LoadingDemand
Visual Basic
Public Enumeration GH_LoadingDemand

Members

Member name | Value | Description
None | -1 | Indicates no valid loading behaviour. Do not use this value in the GH_GHALoadingAttribute constructor.
Default | 0 | Use the application settings.
ForceCOFF | 1 | Force this assembly to be loaded using COFF byte arrays.
ForceDirect | 2 | Force this assembly to be loaded directly from the disk.

See Also

Grasshopper.Kernel Namespace


GH_LoadingInstruction Enumeration

[image]

Grasshopper SDK
GH_LoadingInstruction Enumeration
See Also Send Feedback
Enumerates all external GHA loading process instructions.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_LoadingInstruction
Visual Basic
Public Enumeration GH_LoadingInstruction

Members

Member name | Value | Description
Proceed | 0 | Proceed with GHA loading.
Abort | 1 | Abort the GHA loading, all your components will be skipped.

See Also

Grasshopper.Kernel Namespace


GH_LoadingMechanism Enumeration

[image]

Grasshopper SDK
GH_LoadingMechanism Enumeration
See Also Send Feedback
Enumerates all assembly loading mechanisms.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_LoadingMechanism
Visual Basic
Public Enumeration GH_LoadingMechanism

Members

Member name | Value | Description
Unknown | -1 | Assembly was loaded with an unknown mechanism.
COFF | 1 | Assembly was loaded from a memory byte-array representation of the file.
Direct | 2 | Assembly was loaded directly from disk.

See Also

Grasshopper.Kernel Namespace


GH_MatchLevel Enumeration

[image]

Grasshopper SDK
GH_MatchLevel Enumeration
See Also Send Feedback
All possible string matching schemes.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
[FlagsAttribute]
public enum GH_MatchLevel
Visual Basic
<FlagsAttribute> _
Public Enumeration GH_MatchLevel

Members

Member name | Value | Description
None | 0 | No match is performed.
Exact | 1 | String must match the key exactly.
Start | 2 | String must start with the key.
WordExact | 4 | String must contain word that is an exact match with the key.
WordStart | 8 | String must contain a word that starts with the key.
Contains | 16 | String must contain the key.
Fuzzy | 32 | String must contain word that is somewhat similar to the key.
AllClean | 31 | Represents all match types except fuzzy matching.
All | 63 | Represents all match types.

See Also

Grasshopper.Kernel Namespace


GH_MatchWeight Enumeration

[image]

Grasshopper SDK
GH_MatchWeight Enumeration
See Also Send Feedback
Weighting factors of string matches.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_MatchWeight
Visual Basic
Public Enumeration GH_MatchWeight

Members

Member name | Value | Description
Exact | 100 |
Start | 100 |
WordExact | 100 |
WordStart | 100 |
Contains | 10 |
Fuzzy | 10 |

See Also

Grasshopper.Kernel Namespace


GH_MemoryBitmap Class

[image]

Grasshopper SDK
GH_MemoryBitmap Class
Members See Also Send Feedback
Utility class for ultra-fast bitmap sampling and filters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class GH_MemoryBitmap
Visual Basic
Public NotInheritable Class GH_MemoryBitmap

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_MemoryBitmap

See Also

GH_MemoryBitmap Members
Grasshopper.Kernel Namespace


GH_MemoryBitmap Members

[image] [image]

Grasshopper SDK
GH_MemoryBitmap Members
GH_MemoryBitmap Class Constructors Methods Properties See Also Send Feedback

The GH_MemoryBitmap type exposes the following members.

Constructors

 | Name | Description
Public method | GH_MemoryBitmap(Bitmap) | Default constructor.
Public method | GH_MemoryBitmap(Bitmap, WrapMode) | Constructor with Wrap mode override.

Methods

 | Name | Description
Public method | A | Gets the alpha channel value at the given pixel coordinates.
Public method | B | Gets the blue channel value at the given pixel coordinates.
Public method | Colour(Int32, Int32) | Gets the colour at the given pixel coordinates.
Public method | Colour(Int32, Int32, Color) | Sets the colour at the given pixel coordinates.
Public method | CopyChannel | Copy the contents of one channel into another.
Public method | Filter_AlphaEdges | Set the alpha component on all edges to a specific value.
Public method | Filter_Blur()()()() | Blur the image in both directions.
Public method | Filter_Blur(Int32) | Blur the image N times in both directions.
Public method | Filter_Blur(Int32, Int32) | Blur the image in both directions.
Public method | Filter_Blur(Int32, Int32, Int32) | Blur the image N times in both directions.
Public method | Filter_BlurAlpha | Blur the alpha channel of the image N times in both directions.
Public method | Filter_Contrast | Adjust the contrast of a specific channel.
Public method | Filter_DitherPattern | Create a checkerboard dither pattern.
Public method | Filter_DropShadow | Add a drop-shadow to the image. Image is not grown, so if you want the drop shadow to extend beyond the image boundaries, you have to add padding to the image first.
Public method | Filter_Dullify | Reduces contrast based on opacity. This filter pulls all colours towards dull grey, without wrecking drop-shadows.
Public method | Filter_Equalize | Set all the values in a specific channel to a specific value.
Public method | Filter_GreyScale()()()() | Convert the image to a greyscale shadow of its former self.
Public method | Filter_GreyScale(Double) | Convert the image to a greyscale shadow of its former self.
Public method | Filter_HueScale | Convert the image to a greyscale representation of the hues.
Public method | Filter_Invert | Invert all values in a specific channel.
Public method | Filter_LumScale | Convert the image to a greyscale representation of the luminance.
Public method | Filter_Multiply(GH_BitmapChannel, Double) | Multiply all values in a specific channel with a specific factor.
Public method | Filter_Multiply(GH_BitmapChannel, Double, Byte) | Multiply all values in a specific channel with a specific factor, using a custom scaling center anchor.
Public method | Filter_SatScale | Convert the image to a greyscale representation of the saturation.
Public method | Filter_Shift | Shift all values in a specific channel with a specific amount.
Public method | Filter_SpectrumScale | Convert the image to a spectral representation of the hues.
Public method | Filter_Tint | Colorize the image using Hue and Saturation from a base colour.
Public method | G | Gets the greeb channel value at the given pixel coordinates.
Public method | OpaqueArea | Find the opaque area of a bitmap. The opaque area is the rectangle that contains pixels with a colour that is not fully transparent.
 | PadBitmap | Add padding edges around a bitmap.
Public method | R | Gets the red channel value at the given pixel coordinates.
Public method | Release | Release the locked bits. You must call this function when you are done with this GH_MemoryBitmap instance.
Public method | Sample(Double, Double, Color%) | Top level sampling function for interpolated sampling.
Public method | Sample(Int32, Int32, Color%) | Top level sampling function.
 | ShrinkBitmap | Shrink an image by removing all outer columns and rows that contain only fully transparent pixels.

Properties

 | Name | Description
Public property | HasAlphaChannel | Gets a value indicating whether or not the local image has an alpha channel defined.
Public property | Height | Gets the height (in pixels) of the local image.
Public property | SizeOf | Gets the size (in bytes) of the local image.
Public property | Width | Gets the width (in pixels) of the local image.

See Also

GH_MemoryBitmap Class
Grasshopper.Kernel Namespace


GH_MemoryBitmap Constructor

[image] [image]

Grasshopper SDK
GH_MemoryBitmap Constructor
GH_MemoryBitmap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_MemoryBitmap(Bitmap) | Default constructor.
Public method | GH_MemoryBitmap(Bitmap, WrapMode) | Constructor with Wrap mode override.

See Also

GH_MemoryBitmap Class
GH_MemoryBitmap Members
Grasshopper.Kernel Namespace


GH_MemoryBitmap Constructor (Bitmap)

[image]

Grasshopper SDK
GH_MemoryBitmap Constructor (Bitmap)
GH_MemoryBitmap Class See Also Send Feedback
Default constructor.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_MemoryBitmap(
    Bitmap bitmap
)
Visual Basic
Public Sub New ( _
    bitmap As Bitmap _
)

Parameters

bitmap
Type: System.Drawing..::..Bitmap
Bitmap to operate on. This bitmap will be in an invalid state until the Release() function has been called.

See Also

GH_MemoryBitmap Class
GH_MemoryBitmap Overload
Grasshopper.Kernel Namespace


GH_MemoryBitmap Constructor (Bitmap, WrapMode)

[image]

Grasshopper SDK
GH_MemoryBitmap Constructor (Bitmap, WrapMode)
GH_MemoryBitmap Class See Also Send Feedback
Constructor with Wrap mode override.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_MemoryBitmap(
    Bitmap bitmap,
    WrapMode wrap
)
Visual Basic
Public Sub New ( _
    bitmap As Bitmap, _
    wrap As WrapMode _
)

Parameters

bitmap
Type: System.Drawing..::..Bitmap
Bitmap to operate on. This bitmap will be in an invalid state until the Release() function has been called.
wrap
Type: System.Drawing.Drawing2D..::..WrapMode
Wrap mode to use during sampling.

See Also

GH_MemoryBitmap Class
GH_MemoryBitmap Overload
Grasshopper.Kernel Namespace


GH_MemoryBitmap Methods

[image] [image]

Grasshopper SDK
GH_MemoryBitmap Methods
GH_MemoryBitmap Class See Also Send Feedback

The GH_MemoryBitmap type exposes the following members.

Methods

 | Name | Description
Public method | A | Gets the alpha channel value at the given pixel coordinates.
Public method | B | Gets the blue channel value at the given pixel coordinates.
Public method | Colour(Int32, Int32) | Gets the colour at the given pixel coordinates.
Public method | Colour(Int32, Int32, Color) | Sets the colour at the given pixel coordinates.
Public method | CopyChannel | Copy the contents of one channel into another.
Public method | Filter_AlphaEdges | Set the alpha component on all edges to a specific value.
Public method | Filter_Blur()()()() | Blur the image in both directions.
Public method | Filter_Blur(Int32) | Blur the image N times in both directions.
Public method | Filter_Blur(Int32, Int32) | Blur the image in both directions.
Public method | Filter_Blur(Int32, Int32, Int32) | Blur the image N times in both directions.
Public method | Filter_BlurAlpha | Blur the alpha channel of the image N times in both directions.
Public method | Filter_Contrast | Adjust the contrast of a specific channel.
Public method | Filter_DitherPattern | Create a checkerboard dither pattern.
Public method | Filter_DropShadow | Add a drop-shadow to the image. Image is not grown, so if you want the drop shadow to extend beyond the image boundaries, you have to add padding to the image first.
Public method | Filter_Dullify | Reduces contrast based on opacity. This filter pulls all colours towards dull grey, without wrecking drop-shadows.
Public method | Filter_Equalize | Set all the values in a specific channel to a specific value.
Public method | Filter_GreyScale()()()() | Convert the image to a greyscale shadow of its former self.
Public method | Filter_GreyScale(Double) | Convert the image to a greyscale shadow of its former self.
Public method | Filter_HueScale | Convert the image to a greyscale representation of the hues.
Public method | Filter_Invert | Invert all values in a specific channel.
Public method | Filter_LumScale | Convert the image to a greyscale representation of the luminance.
Public method | Filter_Multiply(GH_BitmapChannel, Double) | Multiply all values in a specific channel with a specific factor.
Public method | Filter_Multiply(GH_BitmapChannel, Double, Byte) | Multiply all values in a specific channel with a specific factor, using a custom scaling center anchor.
Public method | Filter_SatScale | Convert the image to a greyscale representation of the saturation.
Public method | Filter_Shift | Shift all values in a specific channel with a specific amount.
Public method | Filter_SpectrumScale | Convert the image to a spectral representation of the hues.
Public method | Filter_Tint | Colorize the image using Hue and Saturation from a base colour.
Public method | G | Gets the greeb channel value at the given pixel coordinates.
Public method | OpaqueArea | Find the opaque area of a bitmap. The opaque area is the rectangle that contains pixels with a colour that is not fully transparent.
 | PadBitmap | Add padding edges around a bitmap.
Public method | R | Gets the red channel value at the given pixel coordinates.
Public method | Release | Release the locked bits. You must call this function when you are done with this GH_MemoryBitmap instance.
Public method | Sample(Double, Double, Color%) | Top level sampling function for interpolated sampling.
Public method | Sample(Int32, Int32, Color%) | Top level sampling function.
 | ShrinkBitmap | Shrink an image by removing all outer columns and rows that contain only fully transparent pixels.

See Also

GH_MemoryBitmap Class
Grasshopper.Kernel Namespace


A Method

[image]

Grasshopper SDK
GH_MemoryBitmap..::..A Method
GH_MemoryBitmap Class See Also Send Feedback
Gets the alpha channel value at the given pixel coordinates.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public byte A(
    int x,
    int y
)
Visual Basic
Public Function A ( _
    x As Integer, _
    y As Integer _
) As Byte

Parameters

x
Type: System..::..Int32
X coordinate (column) of pixel. Must be on image interior.
y
Type: System..::..Int32
Y coordinate (column) of pixel. Must be on image interior.

Return Value

Value of alpha channel at given pixel or 255 if the alpha channel is not defined.

See Also

GH_MemoryBitmap Class
Grasshopper.Kernel Namespace


B Method

[image]

Grasshopper SDK
GH_MemoryBitmap..::..B Method
GH_MemoryBitmap Class See Also Send Feedback
Gets the blue channel value at the given pixel coordinates.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public byte B(
    int x,
    int y
)
Visual Basic
Public Function B ( _
    x As Integer, _
    y As Integer _
) As Byte

Parameters

x
Type: System..::..Int32
X coordinate (column) of pixel. Must be on image interior.
y
Type: System..::..Int32
Y coordinate (column) of pixel. Must be on image interior.

Return Value

Value of Blue channel at given pixel.

See Also

GH_MemoryBitmap Class
Grasshopper.Kernel Namespace


Colour Method

[image] [image]

Grasshopper SDK
GH_MemoryBitmap..::..Colour Method
GH_MemoryBitmap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Colour(Int32, Int32) | Gets the colour at the given pixel coordinates.
Public method | Colour(Int32, Int32, Color) | Sets the colour at the given pixel coordinates.

See Also

GH_MemoryBitmap Class
GH_MemoryBitmap Members
Grasshopper.Kernel Namespace


Colour Method (Int32, Int32)

[image]

Grasshopper SDK
GH_MemoryBitmap..::..Colour Method (Int32, Int32)
GH_MemoryBitmap Class See Also Send Feedback
Gets the colour at the given pixel coordinates.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color Colour(
    int x,
    int y
)
Visual Basic
Public Function Colour ( _
    x As Integer, _
    y As Integer _
) As Color

Parameters

x
Type: System..::..Int32
X coordinate (column) of pixel. Must be on image interior.
y
Type: System..::..Int32
Y coordinate (column) of pixel. Must be on image interior.

Return Value

Colour at given pixel.

See Also

GH_MemoryBitmap Class
Colour Overload
Grasshopper.Kernel Namespace


Colour Method (Int32, Int32, Color)

[image]

Grasshopper SDK
GH_MemoryBitmap..::..Colour Method (Int32, Int32, Color)
GH_MemoryBitmap Class See Also Send Feedback
Sets the colour at the given pixel coordinates.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Colour(
    int x,
    int y,
    Color col
)
Visual Basic
Public Sub Colour ( _
    x As Integer, _
    y As Integer, _
    col As Color _
)

Parameters

x
Type: System..::..Int32
X coordinate (column) of pixel. Must be on image interior.
y
Type: System..::..Int32
Y coordinate (column) of pixel. Must be on image interior.
col
Type: System.Drawing..::..Color
Color to assign.

See Also

GH_MemoryBitmap Class
Colour Overload
Grasshopper.Kernel Namespace


CopyChannel Method

[image]

Grasshopper SDK
GH_MemoryBitmap..::..CopyChannel Method
GH_MemoryBitmap Class See Also Send Feedback
Copy the contents of one channel into another.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void CopyChannel(
    GH_BitmapChannel source,
    GH_BitmapChannel target
)
Visual Basic
Public Sub CopyChannel ( _
    source As GH_BitmapChannel, _
    target As GH_BitmapChannel _
)

Parameters

source
Type: Grasshopper.Kernel..::..GH_BitmapChannel
Source channel (compound channels are not allowed).
target
Type: Grasshopper.Kernel..::..GH_BitmapChannel
Target channel (compound channels are not allowed).

See Also

GH_MemoryBitmap Class
Grasshopper.Kernel Namespace


Filter_AlphaEdges Method

[image]

Grasshopper SDK
GH_MemoryBitmap..::..Filter_AlphaEdges Method
GH_MemoryBitmap Class See Also Send Feedback
Set the alpha component on all edges to a specific value.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Filter_AlphaEdges(
    Padding padding,
    byte alpha_override
)
Visual Basic
Public Sub Filter_AlphaEdges ( _
    padding As Padding, _
    alpha_override As Byte _
)

Parameters

padding
Type: System.Windows.Forms..::..Padding
Width of alpha band along all edges. Must be a valid padding construct.
alpha_override
Type: System..::..Byte
Value of alpha to apply.

See Also

GH_MemoryBitmap Class
Grasshopper.Kernel Namespace


Filter_Blur Method

[image] [image]

Grasshopper SDK
GH_MemoryBitmap..::..Filter_Blur Method
GH_MemoryBitmap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Filter_Blur()()()() | Blur the image in both directions.
Public method | Filter_Blur(Int32) | Blur the image N times in both directions.
Public method | Filter_Blur(Int32, Int32) | Blur the image in both directions.
Public method | Filter_Blur(Int32, Int32, Int32) | Blur the image N times in both directions.

See Also

GH_MemoryBitmap Class
GH_MemoryBitmap Members
Grasshopper.Kernel Namespace


Filter_Blur Method

[image]

Grasshopper SDK
GH_MemoryBitmap..::..Filter_Blur Method
GH_MemoryBitmap Class See Also Send Feedback
Blur the image in both directions.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Filter_Blur()
Visual Basic
Public Sub Filter_Blur

See Also

GH_MemoryBitmap Class
Filter_Blur Overload
Grasshopper.Kernel Namespace


Filter_Blur Method (Int32)

[image]

Grasshopper SDK
GH_MemoryBitmap..::..Filter_Blur Method (Int32)
GH_MemoryBitmap Class See Also Send Feedback
Blur the image N times in both directions.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Filter_Blur(
    int N
)
Visual Basic
Public Sub Filter_Blur ( _
    N As Integer _
)

Parameters

N
Type: System..::..Int32
Number of times to perform the blurring operation.

See Also

GH_MemoryBitmap Class
Filter_Blur Overload
Grasshopper.Kernel Namespace


Filter_Blur Method (Int32, Int32)

[image]

Grasshopper SDK
GH_MemoryBitmap..::..Filter_Blur Method (Int32, Int32)
GH_MemoryBitmap Class See Also Send Feedback
Blur the image in both directions.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Filter_Blur(
    int interior_weight,
    int exterior_weight
)
Visual Basic
Public Sub Filter_Blur ( _
    interior_weight As Integer, _
    exterior_weight As Integer _
)

Parameters

interior_weight
Type: System..::..Int32
Weighting factor for pixels at the center of the convolution matrix.
exterior_weight
Type: System..::..Int32
Weighting factor for pixels at the edges of the convolution matrix.

See Also

GH_MemoryBitmap Class
Filter_Blur Overload
Grasshopper.Kernel Namespace


Filter_Blur Method (Int32, Int32, Int32)

[image]

Grasshopper SDK
GH_MemoryBitmap..::..Filter_Blur Method (Int32, Int32, Int32)
GH_MemoryBitmap Class See Also Send Feedback
Blur the image N times in both directions.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Filter_Blur(
    int N,
    int interior_weight,
    int exterior_weight
)
Visual Basic
Public Sub Filter_Blur ( _
    N As Integer, _
    interior_weight As Integer, _
    exterior_weight As Integer _
)

Parameters

N
Type: System..::..Int32
Number of times to perform the blurring operation.
interior_weight
Type: System..::..Int32
Weighting factor for pixels at the center of the convolution matrix.
exterior_weight
Type: System..::..Int32
Weighting factor for pixels at the edges of the convolution matrix.

See Also

GH_MemoryBitmap Class
Filter_Blur Overload
Grasshopper.Kernel Namespace


Filter_BlurAlpha Method

[image]

Grasshopper SDK
GH_MemoryBitmap..::..Filter_BlurAlpha Method
GH_MemoryBitmap Class See Also Send Feedback
Blur the alpha channel of the image N times in both directions.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Filter_BlurAlpha(
    int N,
    int interior_weight,
    int exterior_weight
)
Visual Basic
Public Sub Filter_BlurAlpha ( _
    N As Integer, _
    interior_weight As Integer, _
    exterior_weight As Integer _
)

Parameters

N
Type: System..::..Int32
Number of times to perform the blurring operation.
interior_weight
Type: System..::..Int32
Weighting factor for pixels at the center of the convolution matrix.
exterior_weight
Type: System..::..Int32
Weighting factor for pixels at the edges of the convolution matrix.

See Also

GH_MemoryBitmap Class
Grasshopper.Kernel Namespace


Filter_Contrast Method

[image]

Grasshopper SDK
GH_MemoryBitmap..::..Filter_Contrast Method
GH_MemoryBitmap Class See Also Send Feedback
Adjust the contrast of a specific channel.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Filter_Contrast(
    GH_BitmapChannel channel,
    double factor
)
Visual Basic
Public Sub Filter_Contrast ( _
    channel As GH_BitmapChannel, _
    factor As Double _
)

Parameters

channel
Type: Grasshopper.Kernel..::..GH_BitmapChannel
Channel(s) to modify.
factor
Type: System..::..Double
Contrast boost factor. A factor of 1.0 will not affect contrast. Lower values will lessen contrast and higher values will increase contrast.

See Also

GH_MemoryBitmap Class
Grasshopper.Kernel Namespace


Filter_DitherPattern Method

[image]

Grasshopper SDK
GH_MemoryBitmap..::..Filter_DitherPattern Method
GH_MemoryBitmap Class See Also Send Feedback
Create a checkerboard dither pattern.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Filter_DitherPattern(
    Color colour
)
Visual Basic
Public Sub Filter_DitherPattern ( _
    colour As Color _
)

Parameters

colour
Type: System.Drawing..::..Color
Colour value to set at dithered pixels.

See Also

GH_MemoryBitmap Class
Grasshopper.Kernel Namespace


Filter_DropShadow Method

[image]

Grasshopper SDK
GH_MemoryBitmap..::..Filter_DropShadow Method
GH_MemoryBitmap Class See Also Send Feedback
Add a drop-shadow to the image. Image is not grown, so if you want the drop shadow to extend beyond the image boundaries, you have to add padding to the image first.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Filter_DropShadow(
    Size offset,
    int blur,
    double darkness
)
Visual Basic
Public Sub Filter_DropShadow ( _
    offset As Size, _
    blur As Integer, _
    darkness As Double _
)

Parameters

offset
Type: System.Drawing..::..Size
Number of pixels (x and y) to offset the drop shadow.
blur
Type: System..::..Int32
Amount of blurring for the shadow.
darkness
Type: System..::..Double
Darkness factor for the shadow.

See Also

GH_MemoryBitmap Class
Grasshopper.Kernel Namespace


Filter_Dullify Method

[image]

Grasshopper SDK
GH_MemoryBitmap..::..Filter_Dullify Method
GH_MemoryBitmap Class See Also Send Feedback
Reduces contrast based on opacity. This filter pulls all colours towards dull grey, without wrecking drop-shadows.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Filter_Dullify()
Visual Basic
Public Sub Filter_Dullify

See Also

GH_MemoryBitmap Class
Grasshopper.Kernel Namespace


Filter_Equalize Method

[image]

Grasshopper SDK
GH_MemoryBitmap..::..Filter_Equalize Method
GH_MemoryBitmap Class See Also Send Feedback
Set all the values in a specific channel to a specific value.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Filter_Equalize(
    GH_BitmapChannel channel,
    byte value
)
Visual Basic
Public Sub Filter_Equalize ( _
    channel As GH_BitmapChannel, _
    value As Byte _
)

Parameters

channel
Type: Grasshopper.Kernel..::..GH_BitmapChannel
Channel(s) to equalize.
value
Type: System..::..Byte
Value to equalize with.

See Also

GH_MemoryBitmap Class
Grasshopper.Kernel Namespace


Filter_GreyScale Method

[image] [image]

Grasshopper SDK
GH_MemoryBitmap..::..Filter_GreyScale Method
GH_MemoryBitmap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Filter_GreyScale()()()() | Convert the image to a greyscale shadow of its former self.
Public method | Filter_GreyScale(Double) | Convert the image to a greyscale shadow of its former self.

See Also

GH_MemoryBitmap Class
GH_MemoryBitmap Members
Grasshopper.Kernel Namespace


Filter_GreyScale Method

[image]

Grasshopper SDK
GH_MemoryBitmap..::..Filter_GreyScale Method
GH_MemoryBitmap Class See Also Send Feedback
Convert the image to a greyscale shadow of its former self.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Filter_GreyScale()
Visual Basic
Public Sub Filter_GreyScale

See Also

GH_MemoryBitmap Class
Filter_GreyScale Overload
Grasshopper.Kernel Namespace


Filter_GreyScale Method (Double)

[image]

Grasshopper SDK
GH_MemoryBitmap..::..Filter_GreyScale Method (Double)
GH_MemoryBitmap Class See Also Send Feedback
Convert the image to a greyscale shadow of its former self.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Filter_GreyScale(
    double amount
)
Visual Basic
Public Sub Filter_GreyScale ( _
    amount As Double _
)

Parameters

amount
Type: System..::..Double
Greyscale factor. 1.0 equals complete greyscale, 0.0 equals no greyscale, -1.0 equals inverse greyscale

See Also

GH_MemoryBitmap Class
Filter_GreyScale Overload
Grasshopper.Kernel Namespace


Filter_HueScale Method

[image]

Grasshopper SDK
GH_MemoryBitmap..::..Filter_HueScale Method
GH_MemoryBitmap Class See Also Send Feedback
Convert the image to a greyscale representation of the hues.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Filter_HueScale()
Visual Basic
Public Sub Filter_HueScale

See Also

GH_MemoryBitmap Class
Grasshopper.Kernel Namespace


Filter_Invert Method

[image]

Grasshopper SDK
GH_MemoryBitmap..::..Filter_Invert Method
GH_MemoryBitmap Class See Also Send Feedback
Invert all values in a specific channel.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Filter_Invert(
    GH_BitmapChannel channel
)
Visual Basic
Public Sub Filter_Invert ( _
    channel As GH_BitmapChannel _
)

Parameters

channel
Type: Grasshopper.Kernel..::..GH_BitmapChannel
Channel(s) to invert.

See Also

GH_MemoryBitmap Class
Grasshopper.Kernel Namespace


Filter_LumScale Method

[image]

Grasshopper SDK
GH_MemoryBitmap..::..Filter_LumScale Method
GH_MemoryBitmap Class See Also Send Feedback
Convert the image to a greyscale representation of the luminance.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Filter_LumScale()
Visual Basic
Public Sub Filter_LumScale

See Also

GH_MemoryBitmap Class
Grasshopper.Kernel Namespace


Filter_Multiply Method

[image] [image]

Grasshopper SDK
GH_MemoryBitmap..::..Filter_Multiply Method
GH_MemoryBitmap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Filter_Multiply(GH_BitmapChannel, Double) | Multiply all values in a specific channel with a specific factor.
Public method | Filter_Multiply(GH_BitmapChannel, Double, Byte) | Multiply all values in a specific channel with a specific factor, using a custom scaling center anchor.

See Also

GH_MemoryBitmap Class
GH_MemoryBitmap Members
Grasshopper.Kernel Namespace


Filter_Multiply Method (GH_BitmapChannel, Double)

[image]

Grasshopper SDK
GH_MemoryBitmap..::..Filter_Multiply Method (GH_BitmapChannel, Double)
GH_MemoryBitmap Class See Also Send Feedback
Multiply all values in a specific channel with a specific factor.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Filter_Multiply(
    GH_BitmapChannel channel,
    double factor
)
Visual Basic
Public Sub Filter_Multiply ( _
    channel As GH_BitmapChannel, _
    factor As Double _
)

Parameters

channel
Type: Grasshopper.Kernel..::..GH_BitmapChannel
Channel(s) to multiply.
factor
Type: System..::..Double
Multiplication factor.

See Also

GH_MemoryBitmap Class
Filter_Multiply Overload
Grasshopper.Kernel Namespace


Filter_Multiply Method (GH_BitmapChannel, Double, Byte)

[image]

Grasshopper SDK
GH_MemoryBitmap..::..Filter_Multiply Method (GH_BitmapChannel, Double, Byte)
GH_MemoryBitmap Class See Also Send Feedback
Multiply all values in a specific channel with a specific factor, using a custom scaling center anchor.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Filter_Multiply(
    GH_BitmapChannel channel,
    double factor,
    byte anchor
)
Visual Basic
Public Sub Filter_Multiply ( _
    channel As GH_BitmapChannel, _
    factor As Double, _
    anchor As Byte _
)

Parameters

channel
Type: Grasshopper.Kernel..::..GH_BitmapChannel
Channel(s) to multiply.
factor
Type: System..::..Double
Multiplication factor.
anchor
Type: System..::..Byte
Byte value to scale from.

See Also

GH_MemoryBitmap Class
Filter_Multiply Overload
Grasshopper.Kernel Namespace


Filter_SatScale Method

[image]

Grasshopper SDK
GH_MemoryBitmap..::..Filter_SatScale Method
GH_MemoryBitmap Class See Also Send Feedback
Convert the image to a greyscale representation of the saturation.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Filter_SatScale()
Visual Basic
Public Sub Filter_SatScale

See Also

GH_MemoryBitmap Class
Grasshopper.Kernel Namespace


Filter_Shift Method

[image]

Grasshopper SDK
GH_MemoryBitmap..::..Filter_Shift Method
GH_MemoryBitmap Class See Also Send Feedback
Shift all values in a specific channel with a specific amount.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Filter_Shift(
    GH_BitmapChannel channel,
    byte amount
)
Visual Basic
Public Sub Filter_Shift ( _
    channel As GH_BitmapChannel, _
    amount As Byte _
)

Parameters

channel
Type: Grasshopper.Kernel..::..GH_BitmapChannel
Channel(s) to shift.
amount
Type: System..::..Byte
Shift amount.

See Also

GH_MemoryBitmap Class
Grasshopper.Kernel Namespace


Filter_SpectrumScale Method

[image]

Grasshopper SDK
GH_MemoryBitmap..::..Filter_SpectrumScale Method
GH_MemoryBitmap Class See Also Send Feedback
Convert the image to a spectral representation of the hues.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Filter_SpectrumScale()
Visual Basic
Public Sub Filter_SpectrumScale

See Also

GH_MemoryBitmap Class
Grasshopper.Kernel Namespace


Filter_Tint Method

[image]

Grasshopper SDK
GH_MemoryBitmap..::..Filter_Tint Method
GH_MemoryBitmap Class See Also Send Feedback
Colorize the image using Hue and Saturation from a base colour.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Filter_Tint(
    Color tint,
    double lum_factor,
    double sat_factor
)
Visual Basic
Public Sub Filter_Tint ( _
    tint As Color, _
    lum_factor As Double, _
    sat_factor As Double _
)

Parameters

tint
Type: System.Drawing..::..Color
Colour of colorize operation.
lum_factor
Type: System..::..Double
Luminance blend factor. 0.0 equals no luminance adjustment, 1.0 equals complete luminance adjustment.
sat_factor
Type: System..::..Double
Saturation blend factor. 0.0 equals no saturation adjustment, 1.0 equals complete saturation adjustment.

See Also

GH_MemoryBitmap Class
Grasshopper.Kernel Namespace


G Method

[image]

Grasshopper SDK
GH_MemoryBitmap..::..G Method
GH_MemoryBitmap Class See Also Send Feedback
Gets the greeb channel value at the given pixel coordinates.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public byte G(
    int x,
    int y
)
Visual Basic
Public Function G ( _
    x As Integer, _
    y As Integer _
) As Byte

Parameters

x
Type: System..::..Int32
X coordinate (column) of pixel. Must be on image interior.
y
Type: System..::..Int32
Y coordinate (column) of pixel. Must be on image interior.

Return Value

Value of Green channel at given pixel.

See Also

GH_MemoryBitmap Class
Grasshopper.Kernel Namespace


OpaqueArea Method

[image]

Grasshopper SDK
GH_MemoryBitmap..::..OpaqueArea Method
GH_MemoryBitmap Class See Also Send Feedback
Find the opaque area of a bitmap. The opaque area is the rectangle that contains pixels with a colour that is not fully transparent.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle OpaqueArea()
Visual Basic
Public Function OpaqueArea As Rectangle

Return Value

Area of bitmap containing all non-transparent pixels.

See Also

GH_MemoryBitmap Class
Grasshopper.Kernel Namespace


PadBitmap Method

[image]

Grasshopper SDK
GH_MemoryBitmap..::..PadBitmap Method
GH_MemoryBitmap Class See Also Send Feedback
Add padding edges around a bitmap.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Bitmap PadBitmap(
    Image bmp,
    Padding padding,
    Color padding_color
)
Visual Basic
Public Shared Function PadBitmap ( _
    bmp As Image, _
    padding As Padding, _
    padding_color As Color _
) As Bitmap

Parameters

bmp
Type: System.Drawing..::..Image
Source bitmap.
padding
Type: System.Windows.Forms..::..Padding
Padding to apply.
padding_color
Type: System.Drawing..::..Color
Color of padded edges.

Return Value

A new bitmap with padded edges and the same PixelFormat as the original bitmap.

See Also

GH_MemoryBitmap Class
Grasshopper.Kernel Namespace


R Method

[image]

Grasshopper SDK
GH_MemoryBitmap..::..R Method
GH_MemoryBitmap Class See Also Send Feedback
Gets the red channel value at the given pixel coordinates.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public byte R(
    int x,
    int y
)
Visual Basic
Public Function R ( _
    x As Integer, _
    y As Integer _
) As Byte

Parameters

x
Type: System..::..Int32
X coordinate (column) of pixel. Must be on image interior.
y
Type: System..::..Int32
Y coordinate (column) of pixel. Must be on image interior.

Return Value

Value of Red channel at given pixel.

See Also

GH_MemoryBitmap Class
Grasshopper.Kernel Namespace


Release Method

[image]

Grasshopper SDK
GH_MemoryBitmap..::..Release Method
GH_MemoryBitmap Class See Also Send Feedback
Release the locked bits. You must call this function when you are done with this GH_MemoryBitmap instance.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Release(
    bool includeChanges
)
Visual Basic
Public Sub Release ( _
    includeChanges As Boolean _
)

Parameters

includeChanges
Type: System..::..Boolean
If true, changes to the bitmap memory block will be written back into the bitmap.

See Also

GH_MemoryBitmap Class
Grasshopper.Kernel Namespace


Sample Method

[image] [image]

Grasshopper SDK
GH_MemoryBitmap..::..Sample Method
GH_MemoryBitmap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sample(Double, Double, Color%) | Top level sampling function for interpolated sampling.
Public method | Sample(Int32, Int32, Color%) | Top level sampling function.

See Also

GH_MemoryBitmap Class
GH_MemoryBitmap Members
Grasshopper.Kernel Namespace


Sample Method (Double, Double, Color)

[image]

Grasshopper SDK
GH_MemoryBitmap..::..Sample Method (Double, Double, Color%)
GH_MemoryBitmap Class See Also Send Feedback
Top level sampling function for interpolated sampling.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Sample(
    double x,
    double y,
    ref Color col
)
Visual Basic
Public Function Sample ( _
    x As Double, _
    y As Double, _
    ByRef col As Color _
) As Boolean

Parameters

x
Type: System..::..Double
floating point coordinate in pixel space.
y
Type: System..::..Double
floating point coordinate in pixel space.
col
Type: System.Drawing..::..Color %
Resulting colour

See Also

GH_MemoryBitmap Class
Sample Overload
Grasshopper.Kernel Namespace


Sample Method (Int32, Int32, Color)

[image]

Grasshopper SDK
GH_MemoryBitmap..::..Sample Method (Int32, Int32, Color%)
GH_MemoryBitmap Class See Also Send Feedback
Top level sampling function.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Sample(
    int x,
    int y,
    ref Color col
)
Visual Basic
Public Function Sample ( _
    x As Integer, _
    y As Integer, _
    ByRef col As Color _
) As Boolean

Parameters

x
Type: System..::..Int32
Unmapped x pixel coordinate.
y
Type: System..::..Int32
Unmapped y pixel coordinate.
col
Type: System.Drawing..::..Color %
Colour output.

Return Value

True on success, false if pixels could not be sampled.

See Also

GH_MemoryBitmap Class
Sample Overload
Grasshopper.Kernel Namespace


ShrinkBitmap Method

[image]

Grasshopper SDK
GH_MemoryBitmap..::..ShrinkBitmap Method
GH_MemoryBitmap Class See Also Send Feedback
Shrink an image by removing all outer columns and rows that contain only fully transparent pixels.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Bitmap ShrinkBitmap(
    Bitmap image
)
Visual Basic
Public Shared Function ShrinkBitmap ( _
    image As Bitmap _
) As Bitmap

Parameters

image
Type: System.Drawing..::..Bitmap
Image to shrink.

Return Value

Shrunk bitmap.

See Also

GH_MemoryBitmap Class
Grasshopper.Kernel Namespace


GH_MemoryBitmap Properties

[image] [image]

Grasshopper SDK
GH_MemoryBitmap Properties
GH_MemoryBitmap Class See Also Send Feedback

The GH_MemoryBitmap type exposes the following members.

Properties

 | Name | Description
Public property | HasAlphaChannel | Gets a value indicating whether or not the local image has an alpha channel defined.
Public property | Height | Gets the height (in pixels) of the local image.
Public property | SizeOf | Gets the size (in bytes) of the local image.
Public property | Width | Gets the width (in pixels) of the local image.

See Also

GH_MemoryBitmap Class
Grasshopper.Kernel Namespace


HasAlphaChannel Property

[image]

Grasshopper SDK
GH_MemoryBitmap..::..HasAlphaChannel Property
GH_MemoryBitmap Class See Also Send Feedback
Gets a value indicating whether or not the local image has an alpha channel defined.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool HasAlphaChannel { get; }
Visual Basic
Public ReadOnly Property HasAlphaChannel As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_MemoryBitmap.HasAlphaChannel"]

See Also

GH_MemoryBitmap Class
Grasshopper.Kernel Namespace


Height Property

[image]

Grasshopper SDK
GH_MemoryBitmap..::..Height Property
GH_MemoryBitmap Class See Also Send Feedback
Gets the height (in pixels) of the local image.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int Height { get; }
Visual Basic
Public ReadOnly Property Height As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_MemoryBitmap.Height"]

See Also

GH_MemoryBitmap Class
Grasshopper.Kernel Namespace


SizeOf Property

[image]

Grasshopper SDK
GH_MemoryBitmap..::..SizeOf Property
GH_MemoryBitmap Class See Also Send Feedback
Gets the size (in bytes) of the local image.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int SizeOf { get; }
Visual Basic
Public ReadOnly Property SizeOf As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_MemoryBitmap.SizeOf"]

See Also

GH_MemoryBitmap Class
Grasshopper.Kernel Namespace


Width Property

[image]

Grasshopper SDK
GH_MemoryBitmap..::..Width Property
GH_MemoryBitmap Class See Also Send Feedback
Gets the width (in pixels) of the local image.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int Width { get; }
Visual Basic
Public ReadOnly Property Width As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_MemoryBitmap.Width"]

See Also

GH_MemoryBitmap Class
Grasshopper.Kernel Namespace


GH_ObjectChangedEventArgs Class

[image]

Grasshopper SDK
GH_ObjectChangedEventArgs Class
Members See Also Send Feedback
Event arguments passed during ObjectChanged events.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_ObjectChangedEventArgs : EventArgs
Visual Basic
Public Class GH_ObjectChangedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Grasshopper.Kernel..::..GH_ObjectChangedEventArgs

See Also

GH_ObjectChangedEventArgs Members
Grasshopper.Kernel Namespace


GH_ObjectChangedEventArgs Members

[image] [image]

Grasshopper SDK
GH_ObjectChangedEventArgs Members
GH_ObjectChangedEventArgs Class Constructors Fields Properties See Also Send Feedback

The GH_ObjectChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GH_ObjectChangedEventArgs(IGH_DocumentObject, GH_ObjectEventType) | Initializes a new instance of the GH_ObjectChangedEventArgs class
Public method | GH_ObjectChangedEventArgs(IGH_DocumentObject, String) | Initializes a new instance of the GH_ObjectChangedEventArgs class
Public method | GH_ObjectChangedEventArgs(IGH_DocumentObject, GH_ObjectEventType, Object) | Initializes a new instance of the GH_ObjectChangedEventArgs class
Public method | GH_ObjectChangedEventArgs(IGH_DocumentObject, String, Object) | Initializes a new instance of the GH_ObjectChangedEventArgs class

Fields

 | Name | Description
Protected field | m_custom |
Protected field | m_sender |
Protected field | m_tag |
Protected field | m_type |

Properties

 | Name | Description
Public property | CustomType | Gets the customised type description of this event. This field is only set when the Type is GH_ObjectEventType.Custom.
Public property | Sender | Gets the object which raised this event.
Public property | Tag | Gets the tag for this event.
Public property | Type | Gets the type of this event.

See Also

GH_ObjectChangedEventArgs Class
Grasshopper.Kernel Namespace


GH_ObjectChangedEventArgs Constructor

[image] [image]

Grasshopper SDK
GH_ObjectChangedEventArgs Constructor
GH_ObjectChangedEventArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_ObjectChangedEventArgs(IGH_DocumentObject, GH_ObjectEventType) | Initializes a new instance of the GH_ObjectChangedEventArgs class
Public method | GH_ObjectChangedEventArgs(IGH_DocumentObject, String) | Initializes a new instance of the GH_ObjectChangedEventArgs class
Public method | GH_ObjectChangedEventArgs(IGH_DocumentObject, GH_ObjectEventType, Object) | Initializes a new instance of the GH_ObjectChangedEventArgs class
Public method | GH_ObjectChangedEventArgs(IGH_DocumentObject, String, Object) | Initializes a new instance of the GH_ObjectChangedEventArgs class

See Also

GH_ObjectChangedEventArgs Class
GH_ObjectChangedEventArgs Members
Grasshopper.Kernel Namespace


GH_ObjectChangedEventArgs Constructor (IGH_DocumentObject, GH_ObjectEventType)

[image]

Grasshopper SDK
GH_ObjectChangedEventArgs Constructor (IGH_DocumentObject, GH_ObjectEventType)
GH_ObjectChangedEventArgs Class See Also Send Feedback
Initializes a new instance of the GH_ObjectChangedEventArgs class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ObjectChangedEventArgs(
    IGH_DocumentObject eSender,
    GH_ObjectEventType eType
)
Visual Basic
Public Sub New ( _
    eSender As IGH_DocumentObject, _
    eType As GH_ObjectEventType _
)

Parameters

eSender
Type: Grasshopper.Kernel..::..IGH_DocumentObject
eType
Type: Grasshopper.Kernel..::..GH_ObjectEventType

See Also

GH_ObjectChangedEventArgs Class
GH_ObjectChangedEventArgs Overload
Grasshopper.Kernel Namespace


GH_ObjectChangedEventArgs Constructor (IGH_DocumentObject, String)

[image]

Grasshopper SDK
GH_ObjectChangedEventArgs Constructor (IGH_DocumentObject, String)
GH_ObjectChangedEventArgs Class See Also Send Feedback
Initializes a new instance of the GH_ObjectChangedEventArgs class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ObjectChangedEventArgs(
    IGH_DocumentObject eSender,
    string eCustomDescription
)
Visual Basic
Public Sub New ( _
    eSender As IGH_DocumentObject, _
    eCustomDescription As String _
)

Parameters

eSender
Type: Grasshopper.Kernel..::..IGH_DocumentObject
eCustomDescription
Type: System..::..String

See Also

GH_ObjectChangedEventArgs Class
GH_ObjectChangedEventArgs Overload
Grasshopper.Kernel Namespace


GH_ObjectChangedEventArgs Constructor (IGH_DocumentObject, GH_ObjectEventType, Object)

[image]

Grasshopper SDK
GH_ObjectChangedEventArgs Constructor (IGH_DocumentObject, GH_ObjectEventType, Object)
GH_ObjectChangedEventArgs Class See Also Send Feedback
Initializes a new instance of the GH_ObjectChangedEventArgs class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ObjectChangedEventArgs(
    IGH_DocumentObject eSender,
    GH_ObjectEventType eType,
    Object eTag
)
Visual Basic
Public Sub New ( _
    eSender As IGH_DocumentObject, _
    eType As GH_ObjectEventType, _
    eTag As Object _
)

Parameters

eSender
Type: Grasshopper.Kernel..::..IGH_DocumentObject
eType
Type: Grasshopper.Kernel..::..GH_ObjectEventType
eTag
Type: System..::..Object

See Also

GH_ObjectChangedEventArgs Class
GH_ObjectChangedEventArgs Overload
Grasshopper.Kernel Namespace


GH_ObjectChangedEventArgs Constructor (IGH_DocumentObject, String, Object)

[image]

Grasshopper SDK
GH_ObjectChangedEventArgs Constructor (IGH_DocumentObject, String, Object)
GH_ObjectChangedEventArgs Class See Also Send Feedback
Initializes a new instance of the GH_ObjectChangedEventArgs class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ObjectChangedEventArgs(
    IGH_DocumentObject eSender,
    string eCustomDescription,
    Object eTag
)
Visual Basic
Public Sub New ( _
    eSender As IGH_DocumentObject, _
    eCustomDescription As String, _
    eTag As Object _
)

Parameters

eSender
Type: Grasshopper.Kernel..::..IGH_DocumentObject
eCustomDescription
Type: System..::..String
eTag
Type: System..::..Object

See Also

GH_ObjectChangedEventArgs Class
GH_ObjectChangedEventArgs Overload
Grasshopper.Kernel Namespace


GH_ObjectChangedEventArgs Fields

[image] [image]

Grasshopper SDK
GH_ObjectChangedEventArgs Fields
GH_ObjectChangedEventArgs Class See Also Send Feedback

The GH_ObjectChangedEventArgs type exposes the following members.

Fields

 | Name | Description
Protected field | m_custom |
Protected field | m_sender |
Protected field | m_tag |
Protected field | m_type |

See Also

GH_ObjectChangedEventArgs Class
Grasshopper.Kernel Namespace


m_custom Field

[image]

Grasshopper SDK
GH_ObjectChangedEventArgs..::..m_custom Field
GH_ObjectChangedEventArgs Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected string m_custom
Visual Basic
Protected m_custom As String

See Also

GH_ObjectChangedEventArgs Class
Grasshopper.Kernel Namespace


m_sender Field

[image]

Grasshopper SDK
GH_ObjectChangedEventArgs..::..m_sender Field
GH_ObjectChangedEventArgs Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected IGH_DocumentObject m_sender
Visual Basic
Protected m_sender As IGH_DocumentObject

See Also

GH_ObjectChangedEventArgs Class
Grasshopper.Kernel Namespace


m_tag Field

[image]

Grasshopper SDK
GH_ObjectChangedEventArgs..::..m_tag Field
GH_ObjectChangedEventArgs Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected Object m_tag
Visual Basic
Protected m_tag As Object

See Also

GH_ObjectChangedEventArgs Class
Grasshopper.Kernel Namespace


m_type Field

[image]

Grasshopper SDK
GH_ObjectChangedEventArgs..::..m_type Field
GH_ObjectChangedEventArgs Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_ObjectEventType m_type
Visual Basic
Protected m_type As GH_ObjectEventType

See Also

GH_ObjectChangedEventArgs Class
Grasshopper.Kernel Namespace


GH_ObjectChangedEventArgs Properties

[image] [image]

Grasshopper SDK
GH_ObjectChangedEventArgs Properties
GH_ObjectChangedEventArgs Class See Also Send Feedback

The GH_ObjectChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | CustomType | Gets the customised type description of this event. This field is only set when the Type is GH_ObjectEventType.Custom.
Public property | Sender | Gets the object which raised this event.
Public property | Tag | Gets the tag for this event.
Public property | Type | Gets the type of this event.

See Also

GH_ObjectChangedEventArgs Class
Grasshopper.Kernel Namespace


CustomType Property

[image]

Grasshopper SDK
GH_ObjectChangedEventArgs..::..CustomType Property
GH_ObjectChangedEventArgs Class See Also Send Feedback
Gets the customised type description of this event. This field is only set when the Type is GH_ObjectEventType.Custom.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string CustomType { get; }
Visual Basic
Public ReadOnly Property CustomType As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ObjectChangedEventArgs.CustomType"]

See Also

GH_ObjectChangedEventArgs Class
Grasshopper.Kernel Namespace


Sender Property

[image]

Grasshopper SDK
GH_ObjectChangedEventArgs..::..Sender Property
GH_ObjectChangedEventArgs Class See Also Send Feedback
Gets the object which raised this event.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_DocumentObject Sender { get; }
Visual Basic
Public ReadOnly Property Sender As IGH_DocumentObject
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ObjectChangedEventArgs.Sender"]

See Also

GH_ObjectChangedEventArgs Class
Grasshopper.Kernel Namespace


Tag Property

[image]

Grasshopper SDK
GH_ObjectChangedEventArgs..::..Tag Property
GH_ObjectChangedEventArgs Class See Also Send Feedback
Gets the tag for this event.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Object Tag { get; }
Visual Basic
Public ReadOnly Property Tag As Object
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ObjectChangedEventArgs.Tag"]

See Also

GH_ObjectChangedEventArgs Class
Grasshopper.Kernel Namespace


Type Property

[image]

Grasshopper SDK
GH_ObjectChangedEventArgs..::..Type Property
GH_ObjectChangedEventArgs Class See Also Send Feedback
Gets the type of this event.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ObjectEventType Type { get; }
Visual Basic
Public ReadOnly Property Type As GH_ObjectEventType
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ObjectChangedEventArgs.Type"]

See Also

GH_ObjectChangedEventArgs Class
Grasshopper.Kernel Namespace


GH_ObjectEventType Enumeration

[image]

Grasshopper SDK
GH_ObjectEventType Enumeration
See Also Send Feedback
Represents common changes which can cause the ObjectChanged event to be raised.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_ObjectEventType
Visual Basic
Public Enumeration GH_ObjectEventType

Members

Member name | Value | Description
Unset | 0 | No type is specified.
NickName | 1 | The NickName has been changed.
NickNameAccepted | 2 | The nickname has been changed and the change was accepted. This event is only raised once per a NickName change process.
Icon | 3 | The object icon has been changed.
IconDisplayMode | 4 | The icon display mode of the object has been changed.
Layout | 5 | The layout of the attributes has changed. This usually happens when the pivot is moved, or when the object is resized, but it can also be due to a change in the object structure.
Sources | 6 | A source list of this object has been altered.
Selected | 7 | The object selected state has been toggled.
Enabled | 8 | The object enabled state has been toggled.
Preview | 9 | The preview of this object has been toggled.
PersistentData | 10 | The persistent data inside this object has been changed.
DataMatching | 11 | The Data matching settings of this object have been changed.
DataMapping | 12 | The Data mapping settings of this object have been changed.
Options | 13 | Custom options of this object have been changed.
Custom | 2147483647 | A non-standard change occured. See the Custom property on the GH_ObjectChangedEventArgs for further details.

See Also

Grasshopper.Kernel Namespace


GH_ObjectSpecies Enumeration

[image]

Grasshopper SDK
GH_ObjectSpecies Enumeration
See Also Send Feedback
Contains all object species.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
[FlagsAttribute]
public enum GH_ObjectSpecies
Visual Basic
<FlagsAttribute> _
Public Enumeration GH_ObjectSpecies

Members

Member name | Value | Description
none | 0 | Indicates no object type
doc_object | 1 | Represents any object that implements IGH_DocumentObject
parameter | 16 | Indicates classes that implement IGH_Param
component | 32 | Indicates classes that implement IGH_Component
group | 64 | Indicates classes of type GH_Group
wire | 128 | Currently this is not yet an object type.
grip_in | 256 | Represents an input grip.
grip_out | 512 | Represents an output grip.
grip | 768 | Represents an input or output grip.
balloon | 1024 | Represents an attribute balloon.
any | 4294967295 | Indicates all object types.

See Also

Grasshopper.Kernel Namespace


GH_ObjectType Enumeration

[image]

Grasshopper SDK
GH_ObjectType Enumeration
See Also Send Feedback
Enumerates all types of object that can be referenced by a GH_ObjectProxy instance.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_ObjectType
Visual Basic
Public Enumeration GH_ObjectType

Members

Member name | Value | Description
None | 0 | Object type is unset.
CompiledObject | 1 | Represents a compiled object inside a GHA assembly.
UserObject | 2 | Represents a user defined object in a remote file.

See Also

Grasshopper.Kernel Namespace


GH_Param(T) Class

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)> Class
Members See Also Send Feedback
Base implementation of IGH_Param. Derive from this class rather than implementing IGH_Param from scratch. If your parameter can store persistent data, derive from GH_PersistentParam(Of T) instead.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract class GH_Param<T> : GH_ActiveObject,
    IGH_Param, IGH_ParamWithPostProcess
where T : class, IGH_Goo
Visual Basic
Public MustInherit Class GH_Param(Of T As {Class, IGH_Goo}) _
    Inherits GH_ActiveObject _
    Implements IGH_Param, IGH_ParamWithPostProcess

Type Parameters

T
Data type for this parameter.

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_InstanceDescription
Grasshopper.Kernel..::..GH_DocumentObject
Grasshopper.Kernel..::..GH_ActiveObject
Grasshopper.Kernel..::..GH_Param<(Of <(<'T>)>)>
Grasshopper.Kernel..::..GH_PersistentParam<(Of <(<'T>)>)>

See Also

GH_Param<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


GH_Param(T) Members

[image] [image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)> Members
GH_Param<(Of <(<'T>)>)> Class Constructors Methods Fields Properties Events See Also Send Feedback

The GH_Param<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Protected method | GH_Param<(Of <(<'T>)>)>(IGH_InstanceDescription) | Initializes a new instance of the GH_Param<(Of <(<'T>)>)> class
Protected method | GH_Param<(Of <(<'T>)>)>(IGH_InstanceDescription, GH_ParamAccess) | Initializes a new instance of the GH_Param<(Of <(<'T>)>)> class
Protected method | GH_Param<(Of <(<'T>)>)>(String, String, String, String, String, GH_ParamAccess) | Initializes a new instance of the GH_Param<(Of <(<'T>)>)> class

Methods

 | Name | Description
Public method | AddedToDocument | This method will be called when an object is added to a document. Override this method if you want to handle such events. (Inherited from GH_DocumentObject.)
Public method | AddRuntimeMessage | Add a new message to this object. Valid message type flags are Warning and Error. If the Message string is empty or zero-length no message is added. (Inherited from GH_ActiveObject.)
Public method | AddSource(IGH_Param) | Append a new Source parameter to the end of the Sources list. Sources provide this parameter with data at runtime.
Public method | AddSource(IGH_Param, Int32) | Insert a new Source parameter into the Sources list. Sources provide this parameter with data at runtime.
Public method | AddVolatileData(GH_Path, Int32, Object) | Inserts an item of volatile data into the data structure.
Public method | AddVolatileData(GH_Path, Int32, T) |
Public method | AddVolatileDataList(GH_Path, List<(Of <<'(T>)>>)) |
Public method | AddVolatileDataList(GH_Path, IEnumerable) |
Public method | AddVolatileDataTree(GH_Structure<(Of <<'(T>)>>)) |
Public method | AddVolatileDataTree(IGH_Structure) |
Public method | AppendAdditionalMenuItems | Override this function if you want to add specific items to the object context menu Default items already included in the menu toolstrip are: 1. Name 2. Preview 3. Warnings 4. Errors (Overrides GH_ActiveObject..::..AppendAdditionalMenuItems(ToolStripDropDown).)
Public method | AppendMenuItems | This function is called when a context menu is about to be displayed. Override it to set custom items. GH_ActiveObject will already populate the menu with default items, if you merely wish to insert object-specific menu item, consider overriding AppendAdditionalMenuItems instead. (Inherited from GH_ActiveObject.)
Protected method | Cast_Object | Attempts to convert the Object reference into an instance of T. This method will perform a direct cast if possible or it will call Casting functions on T or Data if they exist. Data will not be duplicated unless a type conversion is required.
Public method | ClearData | (Overrides GH_ActiveObject..::..ClearData()()()().)
Public method | ClearProxySources | Remove all proxy sources without attempting to relink them.
Public method | ClearRuntimeMessages | Destroy all warning and error lists (Inherited from GH_ActiveObject.)
Public method | CollectData | (Overrides GH_ActiveObject..::..CollectData()()()().)
Protected method | CollectVolatileData_Custom | If a parameter has no sources, the CollectVolatileData_Custom() method is called. The basic implementation does nothing, but you can override this method to provide special data instantiation logic.
Protected method | CollectVolatileData_FromSources | This method collects volatile data from all the source parameters.
Public method | ComputeData | (Overrides GH_ActiveObject..::..ComputeData()()()().)
Public method | CopyFrom | Copy all fields (except the instance ID) from another instance description. (Inherited from GH_InstanceDescription.)
Public method | CreateAttributes | (Overrides GH_DocumentObject..::..CreateAttributes()()()().)
Public method | CreateProxySources | Convert all proper source parameters into proxy sources.
Public method | DependsOn | (Overrides GH_ActiveObject..::..DependsOn(IGH_ActiveObject).)
Protected method | DestroyIconCache | Call this method to erase the existing icon cache. You must call this if you want to change the display icon of an object. (Inherited from GH_DocumentObject.)
Public method | DocumentContextChanged | This method will be called when the document that owns this object moves into a different context. (Inherited from GH_DocumentObject.)
Protected method | ExpireDownStreamObjects | (Overrides GH_ActiveObject..::..ExpireDownStreamObjects()()()().)
Public method | ExpirePreview | Call this function when you suspect that the preview has expired for this object. This will cause the display cache to be eradicated. (Inherited from GH_DocumentObject.)
Public method | ExpireSolution | Informs the document that owns this object that the solution has expired. The current object will be set to BLANK as a result. This method is recursive, it will also expire any and all objects which depend on this object. If you want a less destructive expiration, consider using ClearData(). If this object is already Blank, you should consider not expiring it. (Inherited from GH_ActiveObject.)
Protected method | Format | Returns "Null" if the data is a null reference, otherwise calls ToString() on the Data instance.
Protected method | GetValue(String, Boolean) | Get a boolean value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Double) | Get a double value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Color) | Get a color value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Int32) | Get an integer value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, String) | Get a string value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | HtmlHelp_Source | Return a String which contains HTML formatted source for the help topic. If you want to pass a URL that points to a remote page, then prefix the URL with a GOTO: tag, like so: GOTO:http://www.YourWebAddressHere.com (Inherited from GH_DocumentObject.)
Protected method | InstantiateT | Attempts to instantiate a new instance of T.
Public method | IsolateObject | (Overrides GH_DocumentObject..::..IsolateObject()()()().)
Protected method | Menu_AppendBakeItem | Append the default Bake menu item. (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendDisconnectWires |
Protected method | Menu_AppendEnableItem | Append the default Enable/Disable menu item. (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendFlattenParameter |
Protected method | Menu_AppendGraftParameter |
Protected method | Menu_AppendObjectHelp | Appends the default object Help menu item. (Inherited from GH_DocumentObject.)
Protected method | Menu_AppendObjectName | Appends the old-fashioned object name menu item. If you also want the Display mode toggle then use Menu_AppendObjectNameEx() (Inherited from GH_DocumentObject.)
Protected method | Menu_AppendObjectNameEx | Appends the default object name + display mode menu item. (Inherited from GH_DocumentObject.)
Protected method | Menu_AppendPreviewItem | Append the default Show/Hide preview menu item. (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendPrincipalParameter |
Protected method | Menu_AppendReverseParameter |
Protected method | Menu_AppendRuntimeMessages | Append the default warnings and errors menu items. (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendSimplifyParameter |
Protected method | Menu_AppendWarningsAndErrors | Obsolete. This method is obsolete and has been replaced with Menu_AppendRuntimeMessages(). (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendWireDisplay |
Public method | MovedBetweenDocuments | This method will be called when an object is moved from one document to another. Override this method if you want to handle such events. (Inherited from GH_DocumentObject.)
Public method | NewInstanceGuid()()()() | Generate a new random instance GUID (Inherited from GH_InstanceDescription.)
Public method | NewInstanceGuid(Guid) | Set the instance ID to be a specific GUID. This is very dangerous, only use this function if you're 6"4' and your first name is David. (Inherited from GH_InstanceDescription.)
Public method | OnAttributesChanged | Raises the AttributesChanged event on the toplevel object. (Inherited from GH_DocumentObject.)
Public method | OnDisplayExpired | Raises the DisplayExpired event on the toplevel object. (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(String) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectChangedEventArgs) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(String, Object) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType, Object) | (Inherited from GH_DocumentObject.)
Public method | OnPingDocument | Raise the PingDocument Event on the toplevel object and try to find the document which owns this object. (Inherited from GH_DocumentObject.)
Public method | OnPreviewExpired | Raises the PreviewExpired event on the toplevel object. (Inherited from GH_DocumentObject.)
Public method | OnSolutionExpired | Raises the SolutionExpired event on the toplevel object. You probably want to call ExpireSolution() instead of this method directly. (Inherited from GH_DocumentObject.)
Protected method | OnVolatileDataCollected | Once volatile data has been collected this method will be calles. The basic implementation does nothing, but you can add code here to post-process or analyze the volatile data.
Protected method | PreferredCast | Implement this function if you're certain that you'll be confronted with very common casts. For example, GH_Point has a preferred cast from Rhino.Geometry.Point3d and GH_Number has a preferred cast from System.Double.
Protected method | Preview_ComputeClippingBox | This function can be used to iterate over all items in the Volatile data tree and collect the union clipping box of all non-null items that implement Preview.IGH_PreviewData. This function requires a lot of TypeOf and DirectCasting, so if you're worried about performance you should consider doing this yourself.
Protected method | Preview_DrawMeshes | This function can be used to iterate over all items in the Volatile data tree and call DrawViewportWires on each item that implements Preview.IGH_PreviewData. This function requires a lot of TypeOf and DirectCasting, so if you're worried about performance you should consider doing this yourself.
Protected method | Preview_DrawWires | This function can be used to iterate over all items in the Volatile data tree and call DrawViewportWires on each item that implements Preview.IGH_PreviewData. This function requires a lot of TypeOf and DirectCasting, so if you're worried about performance you should consider doing this yourself.
Public method | Read | (Overrides GH_ActiveObject..::..Read(GH_IReader).)
Public method | ReadFull | GH_InstanceDescription does not by default serialize all fields. Use this function to read all fields from the archive. This method is compatible with the default Write()/Read() operations. (Inherited from GH_InstanceDescription.)
Public method | RecordUndoEvent(String) | Record a generic object change undo event. (Inherited from GH_DocumentObject.)
Public method | RecordUndoEvent(GH_UndoRecord) | Record an entire undo record. (Inherited from GH_DocumentObject.)
Public method | RecordUndoEvent(String, IGH_UndoAction) | Record a specific object change undo event. (Inherited from GH_DocumentObject.)
Public method | RegisterRemoteIDs | Override this function if you want object changes in the Rhino document to trigger a new solution. (Inherited from GH_ActiveObject.)
Protected method | RegisterRemoteIDsUtil | Utility function which treats all data in the Volatile cache as IGH_GeometricGoo and registers all referenced objects. Call this function from within RegisterRemoteIDs() if you are absolutely sure that all the items in volatiledata implement IGH_GeometricGoo.
Public method | RelinkProxySources | Attempt to replace all proxy sources with real sources. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources.
Public method | RemoveAllSources | Remove all sources from this parameter.
Public method | RemovedFromDocument | This method will be called when an object is removed from a document. Override this method if you want to handle such events. (Inherited from GH_DocumentObject.)
Public method | RemoveEffects | Remove all post-process effects. Note to implementors, you must call the base method if you override this function.
Public method | RemoveSource(Guid) | Remove the specified source from this parameter.
Public method | RemoveSource(IGH_Param) | Remove the specified source from this parameter.
Public method | ReplaceSource(Guid, IGH_Param) | Replace an existing source with a new one. If the old_source does not exist in this parameter, nothing happens.
Public method | ReplaceSource(IGH_Param, IGH_Param) | Replace an existing source with a new one. If the old_source does not exist in this parameter, nothing happens.
Public method | RuntimeMessages | Gets the list of cached runtime messages that were recorded during solver-time processes. (Inherited from GH_ActiveObject.)
Public method | SDKCompliancy | Test whether this object is compliant with a given Rhino version. (Inherited from GH_ActiveObject.)
Public method | SetIconOverride | Set a new custom icon override for this object. (Inherited from GH_DocumentObject.)
Public method | SetPrincipal | Set the principal parameter state.
Protected method | SetValue(String, Boolean) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Double) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Color) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Int32) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, String) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave()()()() | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(Guid) | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger, Guid) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from GH_DocumentObject.)
Protected method | ValuesChanged | Override this method if you want to respond to changes to the value table. The base implementation is empty, so you don't have to call it. (Inherited from GH_DocumentObject.)
Protected method | VolatileDataDescription | This method is called to populate the Tooltip data description field.
Public method | Write | (Overrides GH_ActiveObject..::..Write(GH_IWriter).)
Public method | WriteFull | GH_InstanceDescription does not by default serialize all fields. Use this function to write all fields to the archive. This method is compatible with the default Write()/Read() operations. (Inherited from GH_InstanceDescription.)

Fields

 | Name | Description
Protected field | m_attributes | (Inherited from GH_DocumentObject.)
Protected field | m_data | Contains the runtime data for this parameter, also known as "Volatile" data.

Properties

 | Name | Description
Public property | Access | Gets or sets the Access level for this parameter.
Public property | Attributes | Gets or sets the attributes that are associated with this object. Only set custom attributes if you know what you are doing. (Inherited from GH_DocumentObject.)
Public property | Category | Gets or sets the Category in which this object belongs. If HasCategory() returns false, this field has no meaning. (Inherited from GH_InstanceDescription.)
Public property | ComponentGuid | Returns a consistent ID for this object type. Every object must supply a unique and unchanging ID that is used to identify objects of the same type. (Inherited from GH_DocumentObject.)
Public property | DataMapping | Gets or sets the data mapping of this Parameter.
Public property | DataType | Type is either Void if there are no sources or Remote. Derived classes should expand on this.
Public property | Description | Gets or sets the description of the object. This field typically remains fixed during the lifetime of an object. (Inherited from GH_InstanceDescription.)
Public property | Exposure | Gets the exposure of this object in the Graphical User Interface. The default is to expose everywhere. (Inherited from GH_DocumentObject.)
Public property | HasCategory | Gets whether or not the Category field has been set. (Inherited from GH_InstanceDescription.)
Public property | HasProxySources | Gets a value indicating whether or not this parameter maintains proxy sources. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources.
Public property | HasSubCategory | Gets whether or not the SubCategory field has been set. (Inherited from GH_InstanceDescription.)
Protected property | Icon | Override this function to supply a custom icon (24x24 pixels). The result of this property is cached, so don't worry if icon retrieval is not very fast. (Inherited from GH_DocumentObject.)
Public property | Icon_24x24 | The icon associated with this object. (Inherited from GH_DocumentObject.)
Public property | Icon_24x24_Locked | The greyscale icon of this object. (Inherited from GH_DocumentObject.)
Public property | IconCapableUI | By default the NickName menu item supports the Icon Mode override toggle. If your UI is not capable of displaying icons, then override this property and return False. (Inherited from GH_ActiveObject.)
Public property | IconDisplayMode | Gets the current display mode of the object. (Inherited from GH_DocumentObject.)
Public property | InstanceDescription | Gets the description of this instance. The default description is about the amount and source of the local values. (Overrides GH_InstanceDescription..::..InstanceDescription.)
Public property | InstanceGuid | Gets the ID of this runtime instance. (Inherited from GH_InstanceDescription.)
Public property | IsDataProvider | (Overrides GH_ActiveObject..::..IsDataProvider.)
Public property | IsPrincipal | Gets whether this parameter is a principal parameter. Principal parameters are maintained by components and are not part of the IGH_Param interface.
Public property | Keywords | Gets a list of additional keywords that describe the object. Typically this list is empty but you can override this property to aid in object searches. (Inherited from GH_InstanceDescription.)
Public property | Kind | Gets the parameter kind. The kind is evaluated lazily and cached.
Public property | Locked | Gets or sets the enabled flag of this object. Disabled objects are ignored during solutions. (Inherited from GH_ActiveObject.)
Public property | MutableNickName | Gets or sets a value that enables Nick name changes through the menu. The default is TRUE. (Inherited from GH_ActiveObject.)
Public property | Name | Gets or sets the name of the object. This field typically remains fixed during the lifetime of an object. (Inherited from GH_InstanceDescription.)
Public property | NickName | Gets or sets the nickname of the object. This field can be changed by the user. (Inherited from GH_InstanceDescription.)
Public property | Obsolete | Gets whether this object is obsolete. Default implementation returns true if the class name contains the string "OBSOLETE" or if this class has been decorated with the ObsoleteAttribute. You are free to override this if you want, but I suggest adding the ObsoleteAttribute instead. (Inherited from GH_DocumentObject.)
Public property | Optional | Gets or sets whether or not this parameter is considered optional by the owner component. Empty, non-optional parameters prevent the component from being solved.
Public property | Phase | Gets or sets the solution phase this object is currenly in. (Inherited from GH_ActiveObject.)
Public property | ProcessorTime | (Overrides GH_ActiveObject..::..ProcessorTime.)
Public property | ProxySourceCount | Gets the number of proxy sources for this parameter. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources.
Public property | Recipients | Gets a list of all the recipients of this parameter. I.e. a recipient has this parameter as one of the sources. The Recipient list is maintained by the parameter, do not modify it yourself.
Public property | Reverse | Gets or sets the data reverse modifier of this parameter.
Public property | RuntimeMessageLevel | Returns the worst case flag for the current object If the object contains at least 1 error, the result is Error. If the object contains at least 1 warning, the result is Warning. If the object contains at least 1 message, the result is Remark. If the object contains no errors, no warnings and no messages, the result is Blank. (Inherited from GH_ActiveObject.)
Public property | Simplify | Gets or sets the simplify modifier for this parameter.
Public property | SourceCount | Gets the number of sources for this parameter.
Public property | Sources | Gets a list of source parameters. Do not modify this list, if you wish to add or remove sources, use dedicated functions like AddSource() and RemoveSource() instead.
Public property | StateTags | Gets all the StateTags that are associated with this parameter. A state tag is a visual feedback icon that represents specific internal settings.
Public property | SubCategory | Gets or sets the SubCategory in which this object belongs. If HasSubCategory() returns false, this field has no meaning. (Inherited from GH_InstanceDescription.)
Public property | Type | Gets the Framework Type descriptor for the stored Data.
Public property | TypeName | Calls TypeName() on the first instance of T it can find. This is either an item in the volatile list, or a newly constructed instance.
Public property | VolatileData |
Public property | VolatileDataCount |
Public property | WireDisplay | Gets or sets the wire display style for this parameter. Wire display only affects the wires connected to the parameter input.

Events

 | Name | Description
Public event | AttributesChanged | Raised whenever the number or kind of attributes changes. This event is handled by GH_Documents who subsequently wipe their attribute caches. (Inherited from GH_DocumentObject.)
Public event | DisplayExpired | Raised whenever the display (on the Canvas) of a certain object becomes invalid. (Inherited from GH_DocumentObject.)
Public event | ObjectChanged | (Inherited from GH_DocumentObject.)
Public event | PingDocument | Raised whenever an object needs to know which GH_Document it belongs to. (Inherited from GH_DocumentObject.)
Public event | PreviewExpired | Raised whenever the display (in the Rhino viewports) of a certain object becomes invalid. (Inherited from GH_DocumentObject.)
Public event | SolutionExpired | Raised whenever the solution of a certain object becomes invalid. (Inherited from GH_DocumentObject.)

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


GH_Param(T) Constructor

[image] [image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)> Constructor
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GH_Param<(Of <(<'T>)>)>(IGH_InstanceDescription) | Initializes a new instance of the GH_Param<(Of <(<'T>)>)> class
Protected method | GH_Param<(Of <(<'T>)>)>(IGH_InstanceDescription, GH_ParamAccess) | Initializes a new instance of the GH_Param<(Of <(<'T>)>)> class
Protected method | GH_Param<(Of <(<'T>)>)>(String, String, String, String, String, GH_ParamAccess) | Initializes a new instance of the GH_Param<(Of <(<'T>)>)> class

See Also

GH_Param<(Of <(<'T>)>)> Class
GH_Param<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


GH_Param(T) Constructor (IGH_InstanceDescription)

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)> Constructor (IGH_InstanceDescription)
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Initializes a new instance of the GH_Param<(Of <(<'T>)>)> class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Param(
    IGH_InstanceDescription tag
)
Visual Basic
Protected Sub New ( _
    tag As IGH_InstanceDescription _
)

Parameters

tag
Type: Grasshopper.Kernel..::..IGH_InstanceDescription

See Also

GH_Param<(Of <(<'T>)>)> Class
GH_Param<(Of <(<'T>)>)> Overload
Grasshopper.Kernel Namespace


GH_Param(T) Constructor (IGH_InstanceDescription, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)> Constructor (IGH_InstanceDescription, GH_ParamAccess)
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Initializes a new instance of the GH_Param<(Of <(<'T>)>)> class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Param(
    IGH_InstanceDescription tag,
    GH_ParamAccess access
)
Visual Basic
Protected Sub New ( _
    tag As IGH_InstanceDescription, _
    access As GH_ParamAccess _
)

Parameters

tag
Type: Grasshopper.Kernel..::..IGH_InstanceDescription
access
Type: Grasshopper.Kernel..::..GH_ParamAccess

See Also

GH_Param<(Of <(<'T>)>)> Class
GH_Param<(Of <(<'T>)>)> Overload
Grasshopper.Kernel Namespace


GH_Param(T) Constructor (String, String, String, String, String, GH_ParamAccess)

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)> Constructor (String, String, String, String, String, GH_ParamAccess)
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Initializes a new instance of the GH_Param<(Of <(<'T>)>)> class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Param(
    string name,
    string nickname,
    string description,
    string category,
    string subcategory,
    GH_ParamAccess access
)
Visual Basic
Protected Sub New ( _
    name As String, _
    nickname As String, _
    description As String, _
    category As String, _
    subcategory As String, _
    access As GH_ParamAccess _
)

Parameters

name
Type: System..::..String
nickname
Type: System..::..String
description
Type: System..::..String
category
Type: System..::..String
subcategory
Type: System..::..String
access
Type: Grasshopper.Kernel..::..GH_ParamAccess

See Also

GH_Param<(Of <(<'T>)>)> Class
GH_Param<(Of <(<'T>)>)> Overload
Grasshopper.Kernel Namespace


GH_Param(T) Fields

[image] [image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)> Fields
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

The GH_Param<(Of <(<'T>)>)> type exposes the following members.

Fields

 | Name | Description
Protected field | m_attributes | (Inherited from GH_DocumentObject.)
Protected field | m_data | Contains the runtime data for this parameter, also known as "Volatile" data.

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


m_data Field

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..m_data Field
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Contains the runtime data for this parameter, also known as "Volatile" data.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Structure<T> m_data
Visual Basic
Protected m_data As GH_Structure(Of T)

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


GH_Param(T) Methods

[image] [image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)> Methods
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

The GH_Param<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | AddedToDocument | This method will be called when an object is added to a document. Override this method if you want to handle such events. (Inherited from GH_DocumentObject.)
Public method | AddRuntimeMessage | Add a new message to this object. Valid message type flags are Warning and Error. If the Message string is empty or zero-length no message is added. (Inherited from GH_ActiveObject.)
Public method | AddSource(IGH_Param) | Append a new Source parameter to the end of the Sources list. Sources provide this parameter with data at runtime.
Public method | AddSource(IGH_Param, Int32) | Insert a new Source parameter into the Sources list. Sources provide this parameter with data at runtime.
Public method | AddVolatileData(GH_Path, Int32, Object) | Inserts an item of volatile data into the data structure.
Public method | AddVolatileData(GH_Path, Int32, T) |
Public method | AddVolatileDataList(GH_Path, List<(Of <<'(T>)>>)) |
Public method | AddVolatileDataList(GH_Path, IEnumerable) |
Public method | AddVolatileDataTree(GH_Structure<(Of <<'(T>)>>)) |
Public method | AddVolatileDataTree(IGH_Structure) |
Public method | AppendAdditionalMenuItems | Override this function if you want to add specific items to the object context menu Default items already included in the menu toolstrip are: 1. Name 2. Preview 3. Warnings 4. Errors (Overrides GH_ActiveObject..::..AppendAdditionalMenuItems(ToolStripDropDown).)
Public method | AppendMenuItems | This function is called when a context menu is about to be displayed. Override it to set custom items. GH_ActiveObject will already populate the menu with default items, if you merely wish to insert object-specific menu item, consider overriding AppendAdditionalMenuItems instead. (Inherited from GH_ActiveObject.)
Protected method | Cast_Object | Attempts to convert the Object reference into an instance of T. This method will perform a direct cast if possible or it will call Casting functions on T or Data if they exist. Data will not be duplicated unless a type conversion is required.
Public method | ClearData | (Overrides GH_ActiveObject..::..ClearData()()()().)
Public method | ClearProxySources | Remove all proxy sources without attempting to relink them.
Public method | ClearRuntimeMessages | Destroy all warning and error lists (Inherited from GH_ActiveObject.)
Public method | CollectData | (Overrides GH_ActiveObject..::..CollectData()()()().)
Protected method | CollectVolatileData_Custom | If a parameter has no sources, the CollectVolatileData_Custom() method is called. The basic implementation does nothing, but you can override this method to provide special data instantiation logic.
Protected method | CollectVolatileData_FromSources | This method collects volatile data from all the source parameters.
Public method | ComputeData | (Overrides GH_ActiveObject..::..ComputeData()()()().)
Public method | CopyFrom | Copy all fields (except the instance ID) from another instance description. (Inherited from GH_InstanceDescription.)
Public method | CreateAttributes | (Overrides GH_DocumentObject..::..CreateAttributes()()()().)
Public method | CreateProxySources | Convert all proper source parameters into proxy sources.
Public method | DependsOn | (Overrides GH_ActiveObject..::..DependsOn(IGH_ActiveObject).)
Protected method | DestroyIconCache | Call this method to erase the existing icon cache. You must call this if you want to change the display icon of an object. (Inherited from GH_DocumentObject.)
Public method | DocumentContextChanged | This method will be called when the document that owns this object moves into a different context. (Inherited from GH_DocumentObject.)
Protected method | ExpireDownStreamObjects | (Overrides GH_ActiveObject..::..ExpireDownStreamObjects()()()().)
Public method | ExpirePreview | Call this function when you suspect that the preview has expired for this object. This will cause the display cache to be eradicated. (Inherited from GH_DocumentObject.)
Public method | ExpireSolution | Informs the document that owns this object that the solution has expired. The current object will be set to BLANK as a result. This method is recursive, it will also expire any and all objects which depend on this object. If you want a less destructive expiration, consider using ClearData(). If this object is already Blank, you should consider not expiring it. (Inherited from GH_ActiveObject.)
Protected method | Format | Returns "Null" if the data is a null reference, otherwise calls ToString() on the Data instance.
Protected method | GetValue(String, Boolean) | Get a boolean value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Double) | Get a double value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Color) | Get a color value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Int32) | Get an integer value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, String) | Get a string value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | HtmlHelp_Source | Return a String which contains HTML formatted source for the help topic. If you want to pass a URL that points to a remote page, then prefix the URL with a GOTO: tag, like so: GOTO:http://www.YourWebAddressHere.com (Inherited from GH_DocumentObject.)
Protected method | InstantiateT | Attempts to instantiate a new instance of T.
Public method | IsolateObject | (Overrides GH_DocumentObject..::..IsolateObject()()()().)
Protected method | Menu_AppendBakeItem | Append the default Bake menu item. (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendDisconnectWires |
Protected method | Menu_AppendEnableItem | Append the default Enable/Disable menu item. (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendFlattenParameter |
Protected method | Menu_AppendGraftParameter |
Protected method | Menu_AppendObjectHelp | Appends the default object Help menu item. (Inherited from GH_DocumentObject.)
Protected method | Menu_AppendObjectName | Appends the old-fashioned object name menu item. If you also want the Display mode toggle then use Menu_AppendObjectNameEx() (Inherited from GH_DocumentObject.)
Protected method | Menu_AppendObjectNameEx | Appends the default object name + display mode menu item. (Inherited from GH_DocumentObject.)
Protected method | Menu_AppendPreviewItem | Append the default Show/Hide preview menu item. (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendPrincipalParameter |
Protected method | Menu_AppendReverseParameter |
Protected method | Menu_AppendRuntimeMessages | Append the default warnings and errors menu items. (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendSimplifyParameter |
Protected method | Menu_AppendWarningsAndErrors | Obsolete. This method is obsolete and has been replaced with Menu_AppendRuntimeMessages(). (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendWireDisplay |
Public method | MovedBetweenDocuments | This method will be called when an object is moved from one document to another. Override this method if you want to handle such events. (Inherited from GH_DocumentObject.)
Public method | NewInstanceGuid()()()() | Generate a new random instance GUID (Inherited from GH_InstanceDescription.)
Public method | NewInstanceGuid(Guid) | Set the instance ID to be a specific GUID. This is very dangerous, only use this function if you're 6"4' and your first name is David. (Inherited from GH_InstanceDescription.)
Public method | OnAttributesChanged | Raises the AttributesChanged event on the toplevel object. (Inherited from GH_DocumentObject.)
Public method | OnDisplayExpired | Raises the DisplayExpired event on the toplevel object. (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(String) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectChangedEventArgs) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(String, Object) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType, Object) | (Inherited from GH_DocumentObject.)
Public method | OnPingDocument | Raise the PingDocument Event on the toplevel object and try to find the document which owns this object. (Inherited from GH_DocumentObject.)
Public method | OnPreviewExpired | Raises the PreviewExpired event on the toplevel object. (Inherited from GH_DocumentObject.)
Public method | OnSolutionExpired | Raises the SolutionExpired event on the toplevel object. You probably want to call ExpireSolution() instead of this method directly. (Inherited from GH_DocumentObject.)
Protected method | OnVolatileDataCollected | Once volatile data has been collected this method will be calles. The basic implementation does nothing, but you can add code here to post-process or analyze the volatile data.
Protected method | PreferredCast | Implement this function if you're certain that you'll be confronted with very common casts. For example, GH_Point has a preferred cast from Rhino.Geometry.Point3d and GH_Number has a preferred cast from System.Double.
Protected method | Preview_ComputeClippingBox | This function can be used to iterate over all items in the Volatile data tree and collect the union clipping box of all non-null items that implement Preview.IGH_PreviewData. This function requires a lot of TypeOf and DirectCasting, so if you're worried about performance you should consider doing this yourself.
Protected method | Preview_DrawMeshes | This function can be used to iterate over all items in the Volatile data tree and call DrawViewportWires on each item that implements Preview.IGH_PreviewData. This function requires a lot of TypeOf and DirectCasting, so if you're worried about performance you should consider doing this yourself.
Protected method | Preview_DrawWires | This function can be used to iterate over all items in the Volatile data tree and call DrawViewportWires on each item that implements Preview.IGH_PreviewData. This function requires a lot of TypeOf and DirectCasting, so if you're worried about performance you should consider doing this yourself.
Public method | Read | (Overrides GH_ActiveObject..::..Read(GH_IReader).)
Public method | ReadFull | GH_InstanceDescription does not by default serialize all fields. Use this function to read all fields from the archive. This method is compatible with the default Write()/Read() operations. (Inherited from GH_InstanceDescription.)
Public method | RecordUndoEvent(String) | Record a generic object change undo event. (Inherited from GH_DocumentObject.)
Public method | RecordUndoEvent(GH_UndoRecord) | Record an entire undo record. (Inherited from GH_DocumentObject.)
Public method | RecordUndoEvent(String, IGH_UndoAction) | Record a specific object change undo event. (Inherited from GH_DocumentObject.)
Public method | RegisterRemoteIDs | Override this function if you want object changes in the Rhino document to trigger a new solution. (Inherited from GH_ActiveObject.)
Protected method | RegisterRemoteIDsUtil | Utility function which treats all data in the Volatile cache as IGH_GeometricGoo and registers all referenced objects. Call this function from within RegisterRemoteIDs() if you are absolutely sure that all the items in volatiledata implement IGH_GeometricGoo.
Public method | RelinkProxySources | Attempt to replace all proxy sources with real sources. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources.
Public method | RemoveAllSources | Remove all sources from this parameter.
Public method | RemovedFromDocument | This method will be called when an object is removed from a document. Override this method if you want to handle such events. (Inherited from GH_DocumentObject.)
Public method | RemoveEffects | Remove all post-process effects. Note to implementors, you must call the base method if you override this function.
Public method | RemoveSource(Guid) | Remove the specified source from this parameter.
Public method | RemoveSource(IGH_Param) | Remove the specified source from this parameter.
Public method | ReplaceSource(Guid, IGH_Param) | Replace an existing source with a new one. If the old_source does not exist in this parameter, nothing happens.
Public method | ReplaceSource(IGH_Param, IGH_Param) | Replace an existing source with a new one. If the old_source does not exist in this parameter, nothing happens.
Public method | RuntimeMessages | Gets the list of cached runtime messages that were recorded during solver-time processes. (Inherited from GH_ActiveObject.)
Public method | SDKCompliancy | Test whether this object is compliant with a given Rhino version. (Inherited from GH_ActiveObject.)
Public method | SetIconOverride | Set a new custom icon override for this object. (Inherited from GH_DocumentObject.)
Public method | SetPrincipal | Set the principal parameter state.
Protected method | SetValue(String, Boolean) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Double) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Color) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Int32) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, String) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave()()()() | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(Guid) | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger, Guid) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from GH_DocumentObject.)
Protected method | ValuesChanged | Override this method if you want to respond to changes to the value table. The base implementation is empty, so you don't have to call it. (Inherited from GH_DocumentObject.)
Protected method | VolatileDataDescription | This method is called to populate the Tooltip data description field.
Public method | Write | (Overrides GH_ActiveObject..::..Write(GH_IWriter).)
Public method | WriteFull | GH_InstanceDescription does not by default serialize all fields. Use this function to write all fields to the archive. This method is compatible with the default Write()/Read() operations. (Inherited from GH_InstanceDescription.)

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


AddSource Method

[image] [image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..AddSource Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddSource(IGH_Param) | Append a new Source parameter to the end of the Sources list. Sources provide this parameter with data at runtime.
Public method | AddSource(IGH_Param, Int32) | Insert a new Source parameter into the Sources list. Sources provide this parameter with data at runtime.

See Also

GH_Param<(Of <(<'T>)>)> Class
GH_Param<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


AddSource Method (IGH_Param)

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..AddSource Method (IGH_Param)
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Append a new Source parameter to the end of the Sources list. Sources provide this parameter with data at runtime.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual void AddSource(
    IGH_Param source
)
Visual Basic
Public Overridable Sub AddSource ( _
    source As IGH_Param _
)

Parameters

source
Type: Grasshopper.Kernel..::..IGH_Param
Source to append.

Implements

IGH_Param..::..AddSource(IGH_Param)

See Also

GH_Param<(Of <(<'T>)>)> Class
AddSource Overload
Grasshopper.Kernel Namespace


AddSource Method (IGH_Param, Int32)

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..AddSource Method (IGH_Param, Int32)
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Insert a new Source parameter into the Sources list. Sources provide this parameter with data at runtime.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual void AddSource(
    IGH_Param source,
    int index
)
Visual Basic
Public Overridable Sub AddSource ( _
    source As IGH_Param, _
    index As Integer _
)

Parameters

source
Type: Grasshopper.Kernel..::..IGH_Param
Source to append.
index
Type: System..::..Int32
Insertion index of source.

Implements

IGH_Param..::..AddSource(IGH_Param, Int32)

See Also

GH_Param<(Of <(<'T>)>)> Class
AddSource Overload
Grasshopper.Kernel Namespace


AddVolatileData Method

[image] [image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..AddVolatileData Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddVolatileData(GH_Path, Int32, Object) | Inserts an item of volatile data into the data structure.
Public method | AddVolatileData(GH_Path, Int32, T) |

See Also

GH_Param<(Of <(<'T>)>)> Class
GH_Param<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


AddVolatileData Method (GH_Path, Int32, Object)

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..AddVolatileData Method (GH_Path, Int32, Object)
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Inserts an item of volatile data into the data structure.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool AddVolatileData(
    GH_Path path,
    int index,
    Object data
)
Visual Basic
Public Function AddVolatileData ( _
    path As GH_Path, _
    index As Integer, _
    data As Object _
) As Boolean

Parameters

path
Type: Grasshopper.Kernel.Data..::..GH_Path
The branch path of the data. If the path doesn't exist yet, it will be created.
index
Type: System..::..Int32
The item index of the data. If the path doesn't contain the index yet, it will be enlarged to encompass the index.
data
Type: System..::..Object
The data to store.

Return Value

True on success, False on failure. If the data cannot be converted, the topology will remain unmolested.

Implements

IGH_Param..::..AddVolatileData(GH_Path, Int32, Object)

See Also

GH_Param<(Of <(<'T>)>)> Class
AddVolatileData Overload
Grasshopper.Kernel Namespace


AddVolatileData Method (GH_Path, Int32, T)

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..AddVolatileData Method (GH_Path, Int32, T)
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool AddVolatileData(
    GH_Path path,
    int index,
    T data
)
Visual Basic
Public Function AddVolatileData ( _
    path As GH_Path, _
    index As Integer, _
    data As T _
) As Boolean

Parameters

path
Type: Grasshopper.Kernel.Data..::..GH_Path
index
Type: System..::..Int32
data
Type: T

See Also

GH_Param<(Of <(<'T>)>)> Class
AddVolatileData Overload
Grasshopper.Kernel Namespace


AddVolatileDataList Method

[image] [image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..AddVolatileDataList Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddVolatileDataList(GH_Path, List<(Of <<'(T>)>>)) |
Public method | AddVolatileDataList(GH_Path, IEnumerable) |

See Also

GH_Param<(Of <(<'T>)>)> Class
GH_Param<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


AddVolatileDataList Method (GH_Path, List(T))

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..AddVolatileDataList Method (GH_Path, List<(Of <(<'T>)>)>)
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool AddVolatileDataList(
    GH_Path path,
    List<T> list
)
Visual Basic
Public Function AddVolatileDataList ( _
    path As GH_Path, _
    list As List(Of T) _
) As Boolean

Parameters

path
Type: Grasshopper.Kernel.Data..::..GH_Path
list
Type: System.Collections.Generic..::..List <(Of <(<' T >)>)>

See Also

GH_Param<(Of <(<'T>)>)> Class
AddVolatileDataList Overload
Grasshopper.Kernel Namespace


AddVolatileDataList Method (GH_Path, IEnumerable)

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..AddVolatileDataList Method (GH_Path, IEnumerable)
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool AddVolatileDataList(
    GH_Path path,
    IEnumerable list
)
Visual Basic
Public Function AddVolatileDataList ( _
    path As GH_Path, _
    list As IEnumerable _
) As Boolean

Parameters

path
Type: Grasshopper.Kernel.Data..::..GH_Path
list
Type: System.Collections..::..IEnumerable

Implements

IGH_Param..::..AddVolatileDataList(GH_Path, IEnumerable)

See Also

GH_Param<(Of <(<'T>)>)> Class
AddVolatileDataList Overload
Grasshopper.Kernel Namespace


AddVolatileDataTree Method

[image] [image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..AddVolatileDataTree Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddVolatileDataTree(GH_Structure<(Of <<'(T>)>>)) |
Public method | AddVolatileDataTree(IGH_Structure) |

See Also

GH_Param<(Of <(<'T>)>)> Class
GH_Param<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


AddVolatileDataTree Method (GH_Structure(T))

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..AddVolatileDataTree Method (GH_Structure<(Of <(<'T>)>)>)
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool AddVolatileDataTree(
    GH_Structure<T> tree
)
Visual Basic
Public Function AddVolatileDataTree ( _
    tree As GH_Structure(Of T) _
) As Boolean

Parameters

tree
Type: Grasshopper.Kernel.Data..::..GH_Structure <(Of <(<' T >)>)>

See Also

GH_Param<(Of <(<'T>)>)> Class
AddVolatileDataTree Overload
Grasshopper.Kernel Namespace


AddVolatileDataTree Method (IGH_Structure)

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..AddVolatileDataTree Method (IGH_Structure)
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool AddVolatileDataTree(
    IGH_Structure tree
)
Visual Basic
Public Function AddVolatileDataTree ( _
    tree As IGH_Structure _
) As Boolean

Parameters

tree
Type: Grasshopper.Kernel.Data..::..IGH_Structure

Implements

IGH_Param..::..AddVolatileDataTree(IGH_Structure)

See Also

GH_Param<(Of <(<'T>)>)> Class
AddVolatileDataTree Overload
Grasshopper.Kernel Namespace


AppendAdditionalMenuItems Method

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..AppendAdditionalMenuItems Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Override this function if you want to add specific items to the object context menu Default items already included in the menu toolstrip are: 1. Name 2. Preview 3. Warnings 4. Errors

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void AppendAdditionalMenuItems(
    ToolStripDropDown menu
)
Visual Basic
Public Overrides Sub AppendAdditionalMenuItems ( _
    menu As ToolStripDropDown _
)

Parameters

menu
Type: System.Windows.Forms..::..ToolStripDropDown

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Cast_Object Method

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..Cast_Object Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Attempts to convert the Object reference into an instance of T. This method will perform a direct cast if possible or it will call Casting functions on T or Data if they exist. Data will not be duplicated unless a type conversion is required.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected T Cast_Object(
    Object data
)
Visual Basic
Protected Function Cast_Object ( _
    data As Object _
) As T

Parameters

data
Type: System..::..Object

Return Value

The cast value or Nothing on failure.

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


ClearData Method

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..ClearData Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void ClearData()
Visual Basic
Public Overrides Sub ClearData

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


ClearProxySources Method

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..ClearProxySources Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Remove all proxy sources without attempting to relink them.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual void ClearProxySources()
Visual Basic
Public Overridable Sub ClearProxySources

Implements

IGH_Param..::..ClearProxySources()()()()

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


CollectData Method

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..CollectData Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override sealed void CollectData()
Visual Basic
Public Overrides NotOverridable Sub CollectData

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


CollectVolatileData_Custom Method

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..CollectVolatileData_Custom Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
If a parameter has no sources, the CollectVolatileData_Custom() method is called. The basic implementation does nothing, but you can override this method to provide special data instantiation logic.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected virtual void CollectVolatileData_Custom()
Visual Basic
Protected Overridable Sub CollectVolatileData_Custom

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


CollectVolatileData_FromSources Method

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..CollectVolatileData_FromSources Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
This method collects volatile data from all the source parameters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected virtual void CollectVolatileData_FromSources()
Visual Basic
Protected Overridable Sub CollectVolatileData_FromSources

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


ComputeData Method

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..ComputeData Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override sealed void ComputeData()
Visual Basic
Public Overrides NotOverridable Sub ComputeData

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


CreateAttributes Method

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..CreateAttributes Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void CreateAttributes()
Visual Basic
Public Overrides Sub CreateAttributes

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


CreateProxySources Method

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..CreateProxySources Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Convert all proper source parameters into proxy sources.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual void CreateProxySources()
Visual Basic
Public Overridable Sub CreateProxySources

Implements

IGH_Param..::..CreateProxySources()()()()

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


DependsOn Method

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..DependsOn Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool DependsOn(
    IGH_ActiveObject potential_source
)
Visual Basic
Public Overrides Function DependsOn ( _
    potential_source As IGH_ActiveObject _
) As Boolean

Parameters

potential_source
Type: Grasshopper.Kernel..::..IGH_ActiveObject

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


ExpireDownStreamObjects Method

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..ExpireDownStreamObjects Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void ExpireDownStreamObjects()
Visual Basic
Protected Overrides Sub ExpireDownStreamObjects

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Format Method

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..Format Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Returns "Null" if the data is a null reference, otherwise calls ToString() on the Data instance.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected virtual string Format(
    T Data
)
Visual Basic
Protected Overridable Function Format ( _
    Data As T _
) As String

Parameters

Data
Type: T

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


GetValue Method

[image] [image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..GetValue Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetValue(String, Boolean) | Get a boolean value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Double) | Get a double value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Color) | Get a color value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Int32) | Get an integer value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, String) | Get a string value from the component value table. (Inherited from GH_DocumentObject.)

See Also

GH_Param<(Of <(<'T>)>)> Class
GH_Param<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


InstantiateT Method

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..InstantiateT Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Attempts to instantiate a new instance of T.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected virtual T InstantiateT()
Visual Basic
Protected Overridable Function InstantiateT As T

Return Value

This function should return a newly constructed instance of T.

Remarks

If T is an abstract class or if T has no default (empty) constructor, this function will ASSERT. In order to avoid a Try...Catch block performance impact, override this function and call the type constructor for T directly.

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


IsolateObject Method

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..IsolateObject Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void IsolateObject()
Visual Basic
Public Overrides Sub IsolateObject

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Menu_AppendDisconnectWires Method

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..Menu_AppendDisconnectWires Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected void Menu_AppendDisconnectWires(
    ToolStripDropDown menu
)
Visual Basic
Protected Sub Menu_AppendDisconnectWires ( _
    menu As ToolStripDropDown _
)

Parameters

menu
Type: System.Windows.Forms..::..ToolStripDropDown

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Menu_AppendFlattenParameter Method

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..Menu_AppendFlattenParameter Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected void Menu_AppendFlattenParameter(
    ToolStripDropDown menu
)
Visual Basic
Protected Sub Menu_AppendFlattenParameter ( _
    menu As ToolStripDropDown _
)

Parameters

menu
Type: System.Windows.Forms..::..ToolStripDropDown

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Menu_AppendGraftParameter Method

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..Menu_AppendGraftParameter Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected void Menu_AppendGraftParameter(
    ToolStripDropDown menu
)
Visual Basic
Protected Sub Menu_AppendGraftParameter ( _
    menu As ToolStripDropDown _
)

Parameters

menu
Type: System.Windows.Forms..::..ToolStripDropDown

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Menu_AppendPrincipalParameter Method

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..Menu_AppendPrincipalParameter Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected void Menu_AppendPrincipalParameter(
    ToolStripDropDown menu
)
Visual Basic
Protected Sub Menu_AppendPrincipalParameter ( _
    menu As ToolStripDropDown _
)

Parameters

menu
Type: System.Windows.Forms..::..ToolStripDropDown

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Menu_AppendReverseParameter Method

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..Menu_AppendReverseParameter Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected void Menu_AppendReverseParameter(
    ToolStripDropDown menu
)
Visual Basic
Protected Sub Menu_AppendReverseParameter ( _
    menu As ToolStripDropDown _
)

Parameters

menu
Type: System.Windows.Forms..::..ToolStripDropDown

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Menu_AppendSimplifyParameter Method

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..Menu_AppendSimplifyParameter Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected void Menu_AppendSimplifyParameter(
    ToolStripDropDown menu
)
Visual Basic
Protected Sub Menu_AppendSimplifyParameter ( _
    menu As ToolStripDropDown _
)

Parameters

menu
Type: System.Windows.Forms..::..ToolStripDropDown

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Menu_AppendWireDisplay Method

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..Menu_AppendWireDisplay Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected void Menu_AppendWireDisplay(
    ToolStripDropDown menu
)
Visual Basic
Protected Sub Menu_AppendWireDisplay ( _
    menu As ToolStripDropDown _
)

Parameters

menu
Type: System.Windows.Forms..::..ToolStripDropDown

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


NewInstanceGuid Method

[image] [image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..NewInstanceGuid Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NewInstanceGuid()()()() | Generate a new random instance GUID (Inherited from GH_InstanceDescription.)
Public method | NewInstanceGuid(Guid) | Set the instance ID to be a specific GUID. This is very dangerous, only use this function if you're 6"4' and your first name is David. (Inherited from GH_InstanceDescription.)

See Also

GH_Param<(Of <(<'T>)>)> Class
GH_Param<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


OnObjectChanged Method

[image] [image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..OnObjectChanged Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OnObjectChanged(String) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectChangedEventArgs) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(String, Object) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType, Object) | (Inherited from GH_DocumentObject.)

See Also

GH_Param<(Of <(<'T>)>)> Class
GH_Param<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


OnVolatileDataCollected Method

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..OnVolatileDataCollected Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Once volatile data has been collected this method will be calles. The basic implementation does nothing, but you can add code here to post-process or analyze the volatile data.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected virtual void OnVolatileDataCollected()
Visual Basic
Protected Overridable Sub OnVolatileDataCollected

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


PreferredCast Method

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..PreferredCast Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Implement this function if you're certain that you'll be confronted with very common casts. For example, GH_Point has a preferred cast from Rhino.Geometry.Point3d and GH_Number has a preferred cast from System.Double.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected virtual T PreferredCast(
    Object data
)
Visual Basic
Protected Overridable Function PreferredCast ( _
    data As Object _
) As T

Parameters

data
Type: System..::..Object
Data to convert. Data is never null.

Return Value

An instance of T or null if you did not handle the cast.

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Preview_ComputeClippingBox Method

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..Preview_ComputeClippingBox Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
This function can be used to iterate over all items in the Volatile data tree and collect the union clipping box of all non-null items that implement Preview.IGH_PreviewData. This function requires a lot of TypeOf and DirectCasting, so if you're worried about performance you should consider doing this yourself.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected BoundingBox Preview_ComputeClippingBox()
Visual Basic
Protected Function Preview_ComputeClippingBox As BoundingBox

Return Value

The clipping box for all valid items.

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Preview_DrawMeshes Method

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..Preview_DrawMeshes Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
This function can be used to iterate over all items in the Volatile data tree and call DrawViewportWires on each item that implements Preview.IGH_PreviewData. This function requires a lot of TypeOf and DirectCasting, so if you're worried about performance you should consider doing this yourself.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected void Preview_DrawMeshes(
    IGH_PreviewArgs args
)
Visual Basic
Protected Sub Preview_DrawMeshes ( _
    args As IGH_PreviewArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..IGH_PreviewArgs

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Preview_DrawWires Method

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..Preview_DrawWires Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
This function can be used to iterate over all items in the Volatile data tree and call DrawViewportWires on each item that implements Preview.IGH_PreviewData. This function requires a lot of TypeOf and DirectCasting, so if you're worried about performance you should consider doing this yourself.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected void Preview_DrawWires(
    IGH_PreviewArgs args
)
Visual Basic
Protected Sub Preview_DrawWires ( _
    args As IGH_PreviewArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..IGH_PreviewArgs

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Read Method

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..Read Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


RecordUndoEvent Method

[image] [image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..RecordUndoEvent Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RecordUndoEvent(String) | Record a generic object change undo event. (Inherited from GH_DocumentObject.)
Public method | RecordUndoEvent(GH_UndoRecord) | Record an entire undo record. (Inherited from GH_DocumentObject.)
Public method | RecordUndoEvent(String, IGH_UndoAction) | Record a specific object change undo event. (Inherited from GH_DocumentObject.)

See Also

GH_Param<(Of <(<'T>)>)> Class
GH_Param<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


RegisterRemoteIDsUtil Method

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..RegisterRemoteIDsUtil Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Utility function which treats all data in the Volatile cache as IGH_GeometricGoo and registers all referenced objects. Call this function from within RegisterRemoteIDs() if you are absolutely sure that all the items in volatiledata implement IGH_GeometricGoo.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected void RegisterRemoteIDsUtil(
    GH_GuidTable id_table
)
Visual Basic
Protected Sub RegisterRemoteIDsUtil ( _
    id_table As GH_GuidTable _
)

Parameters

id_table
Type: GH_GuidTable

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


RelinkProxySources Method

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..RelinkProxySources Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Attempt to replace all proxy sources with real sources. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool RelinkProxySources(
    GH_Document document
)
Visual Basic
Public Overridable Function RelinkProxySources ( _
    document As GH_Document _
) As Boolean

Parameters

document
Type: Grasshopper.Kernel..::..GH_Document
The document from which to harvest the real source parameters.

Return Value

True on success, false on failure.

Implements

IGH_Param..::..RelinkProxySources(GH_Document)

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


RemoveAllSources Method

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..RemoveAllSources Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Remove all sources from this parameter.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual void RemoveAllSources()
Visual Basic
Public Overridable Sub RemoveAllSources

Implements

IGH_Param..::..RemoveAllSources()()()()

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


RemoveEffects Method

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..RemoveEffects Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Remove all post-process effects. Note to implementors, you must call the base method if you override this function.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual void RemoveEffects()
Visual Basic
Public Overridable Sub RemoveEffects

Implements

IGH_Param..::..RemoveEffects()()()()

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


RemoveSource Method

[image] [image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..RemoveSource Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveSource(Guid) | Remove the specified source from this parameter.
Public method | RemoveSource(IGH_Param) | Remove the specified source from this parameter.

See Also

GH_Param<(Of <(<'T>)>)> Class
GH_Param<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


RemoveSource Method (Guid)

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..RemoveSource Method (Guid)
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Remove the specified source from this parameter.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual void RemoveSource(
    Guid source_id
)
Visual Basic
Public Overridable Sub RemoveSource ( _
    source_id As Guid _
)

Parameters

source_id
Type: System..::..Guid
InstanceID of source to remove.

Implements

IGH_Param..::..RemoveSource(Guid)

See Also

GH_Param<(Of <(<'T>)>)> Class
RemoveSource Overload
Grasshopper.Kernel Namespace


RemoveSource Method (IGH_Param)

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..RemoveSource Method (IGH_Param)
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Remove the specified source from this parameter.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual void RemoveSource(
    IGH_Param source
)
Visual Basic
Public Overridable Sub RemoveSource ( _
    source As IGH_Param _
)

Parameters

source
Type: Grasshopper.Kernel..::..IGH_Param
Source to remove.

Implements

IGH_Param..::..RemoveSource(IGH_Param)

See Also

GH_Param<(Of <(<'T>)>)> Class
RemoveSource Overload
Grasshopper.Kernel Namespace


ReplaceSource Method

[image] [image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..ReplaceSource Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReplaceSource(Guid, IGH_Param) | Replace an existing source with a new one. If the old_source does not exist in this parameter, nothing happens.
Public method | ReplaceSource(IGH_Param, IGH_Param) | Replace an existing source with a new one. If the old_source does not exist in this parameter, nothing happens.

See Also

GH_Param<(Of <(<'T>)>)> Class
GH_Param<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


ReplaceSource Method (Guid, IGH_Param)

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..ReplaceSource Method (Guid, IGH_Param)
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Replace an existing source with a new one. If the old_source does not exist in this parameter, nothing happens.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual void ReplaceSource(
    Guid old_source_id,
    IGH_Param new_source
)
Visual Basic
Public Overridable Sub ReplaceSource ( _
    old_source_id As Guid, _
    new_source As IGH_Param _
)

Parameters

old_source_id
Type: System..::..Guid
Source to replace.
new_source
Type: Grasshopper.Kernel..::..IGH_Param
Source to replace with.

Implements

IGH_Param..::..ReplaceSource(Guid, IGH_Param)

See Also

GH_Param<(Of <(<'T>)>)> Class
ReplaceSource Overload
Grasshopper.Kernel Namespace


ReplaceSource Method (IGH_Param, IGH_Param)

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..ReplaceSource Method (IGH_Param, IGH_Param)
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Replace an existing source with a new one. If the old_source does not exist in this parameter, nothing happens.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual void ReplaceSource(
    IGH_Param old_source,
    IGH_Param new_source
)
Visual Basic
Public Overridable Sub ReplaceSource ( _
    old_source As IGH_Param, _
    new_source As IGH_Param _
)

Parameters

old_source
Type: Grasshopper.Kernel..::..IGH_Param
Source to replace.
new_source
Type: Grasshopper.Kernel..::..IGH_Param
Source to replace with.

Implements

IGH_Param..::..ReplaceSource(IGH_Param, IGH_Param)

See Also

GH_Param<(Of <(<'T>)>)> Class
ReplaceSource Overload
Grasshopper.Kernel Namespace


SetPrincipal Method

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..SetPrincipal Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Set the principal parameter state.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool SetPrincipal(
    bool set,
    bool recordUndo,
    bool recompute
)
Visual Basic
Public Function SetPrincipal ( _
    set As Boolean, _
    recordUndo As Boolean, _
    recompute As Boolean _
) As Boolean

Parameters

set
Type: System..::..Boolean
recordUndo
Type: System..::..Boolean
recompute
Type: System..::..Boolean

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


SetValue Method

[image] [image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..SetValue Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SetValue(String, Boolean) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Double) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Color) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Int32) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, String) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)

See Also

GH_Param<(Of <(<'T>)>)> Class
GH_Param<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


TriggerAutoSave Method

[image] [image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..TriggerAutoSave Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TriggerAutoSave()()()() | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(Guid) | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger, Guid) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from GH_DocumentObject.)

See Also

GH_Param<(Of <(<'T>)>)> Class
GH_Param<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


VolatileDataDescription Method

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..VolatileDataDescription Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
This method is called to populate the Tooltip data description field.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected virtual string VolatileDataDescription()
Visual Basic
Protected Overridable Function VolatileDataDescription As String

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Write Method

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..Write Method
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overrides Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


GH_Param(T) Properties

[image] [image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)> Properties
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

The GH_Param<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Access | Gets or sets the Access level for this parameter.
Public property | Attributes | Gets or sets the attributes that are associated with this object. Only set custom attributes if you know what you are doing. (Inherited from GH_DocumentObject.)
Public property | Category | Gets or sets the Category in which this object belongs. If HasCategory() returns false, this field has no meaning. (Inherited from GH_InstanceDescription.)
Public property | ComponentGuid | Returns a consistent ID for this object type. Every object must supply a unique and unchanging ID that is used to identify objects of the same type. (Inherited from GH_DocumentObject.)
Public property | DataMapping | Gets or sets the data mapping of this Parameter.
Public property | DataType | Type is either Void if there are no sources or Remote. Derived classes should expand on this.
Public property | Description | Gets or sets the description of the object. This field typically remains fixed during the lifetime of an object. (Inherited from GH_InstanceDescription.)
Public property | Exposure | Gets the exposure of this object in the Graphical User Interface. The default is to expose everywhere. (Inherited from GH_DocumentObject.)
Public property | HasCategory | Gets whether or not the Category field has been set. (Inherited from GH_InstanceDescription.)
Public property | HasProxySources | Gets a value indicating whether or not this parameter maintains proxy sources. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources.
Public property | HasSubCategory | Gets whether or not the SubCategory field has been set. (Inherited from GH_InstanceDescription.)
Protected property | Icon | Override this function to supply a custom icon (24x24 pixels). The result of this property is cached, so don't worry if icon retrieval is not very fast. (Inherited from GH_DocumentObject.)
Public property | Icon_24x24 | The icon associated with this object. (Inherited from GH_DocumentObject.)
Public property | Icon_24x24_Locked | The greyscale icon of this object. (Inherited from GH_DocumentObject.)
Public property | IconCapableUI | By default the NickName menu item supports the Icon Mode override toggle. If your UI is not capable of displaying icons, then override this property and return False. (Inherited from GH_ActiveObject.)
Public property | IconDisplayMode | Gets the current display mode of the object. (Inherited from GH_DocumentObject.)
Public property | InstanceDescription | Gets the description of this instance. The default description is about the amount and source of the local values. (Overrides GH_InstanceDescription..::..InstanceDescription.)
Public property | InstanceGuid | Gets the ID of this runtime instance. (Inherited from GH_InstanceDescription.)
Public property | IsDataProvider | (Overrides GH_ActiveObject..::..IsDataProvider.)
Public property | IsPrincipal | Gets whether this parameter is a principal parameter. Principal parameters are maintained by components and are not part of the IGH_Param interface.
Public property | Keywords | Gets a list of additional keywords that describe the object. Typically this list is empty but you can override this property to aid in object searches. (Inherited from GH_InstanceDescription.)
Public property | Kind | Gets the parameter kind. The kind is evaluated lazily and cached.
Public property | Locked | Gets or sets the enabled flag of this object. Disabled objects are ignored during solutions. (Inherited from GH_ActiveObject.)
Public property | MutableNickName | Gets or sets a value that enables Nick name changes through the menu. The default is TRUE. (Inherited from GH_ActiveObject.)
Public property | Name | Gets or sets the name of the object. This field typically remains fixed during the lifetime of an object. (Inherited from GH_InstanceDescription.)
Public property | NickName | Gets or sets the nickname of the object. This field can be changed by the user. (Inherited from GH_InstanceDescription.)
Public property | Obsolete | Gets whether this object is obsolete. Default implementation returns true if the class name contains the string "OBSOLETE" or if this class has been decorated with the ObsoleteAttribute. You are free to override this if you want, but I suggest adding the ObsoleteAttribute instead. (Inherited from GH_DocumentObject.)
Public property | Optional | Gets or sets whether or not this parameter is considered optional by the owner component. Empty, non-optional parameters prevent the component from being solved.
Public property | Phase | Gets or sets the solution phase this object is currenly in. (Inherited from GH_ActiveObject.)
Public property | ProcessorTime | (Overrides GH_ActiveObject..::..ProcessorTime.)
Public property | ProxySourceCount | Gets the number of proxy sources for this parameter. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources.
Public property | Recipients | Gets a list of all the recipients of this parameter. I.e. a recipient has this parameter as one of the sources. The Recipient list is maintained by the parameter, do not modify it yourself.
Public property | Reverse | Gets or sets the data reverse modifier of this parameter.
Public property | RuntimeMessageLevel | Returns the worst case flag for the current object If the object contains at least 1 error, the result is Error. If the object contains at least 1 warning, the result is Warning. If the object contains at least 1 message, the result is Remark. If the object contains no errors, no warnings and no messages, the result is Blank. (Inherited from GH_ActiveObject.)
Public property | Simplify | Gets or sets the simplify modifier for this parameter.
Public property | SourceCount | Gets the number of sources for this parameter.
Public property | Sources | Gets a list of source parameters. Do not modify this list, if you wish to add or remove sources, use dedicated functions like AddSource() and RemoveSource() instead.
Public property | StateTags | Gets all the StateTags that are associated with this parameter. A state tag is a visual feedback icon that represents specific internal settings.
Public property | SubCategory | Gets or sets the SubCategory in which this object belongs. If HasSubCategory() returns false, this field has no meaning. (Inherited from GH_InstanceDescription.)
Public property | Type | Gets the Framework Type descriptor for the stored Data.
Public property | TypeName | Calls TypeName() on the first instance of T it can find. This is either an item in the volatile list, or a newly constructed instance.
Public property | VolatileData |
Public property | VolatileDataCount |
Public property | WireDisplay | Gets or sets the wire display style for this parameter. Wire display only affects the wires connected to the parameter input.

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Access Property

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..Access Property
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Gets or sets the Access level for this parameter.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual GH_ParamAccess Access { get; set; }
Visual Basic
Public Overridable Property Access As GH_ParamAccess
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Param`1.Access"]

Implements

IGH_Param..::..Access

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


DataMapping Property

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..DataMapping Property
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Gets or sets the data mapping of this Parameter.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_DataMapping DataMapping { get; set; }
Visual Basic
Public Property DataMapping As GH_DataMapping
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Param`1.DataMapping"]

Implements

IGH_Param..::..DataMapping

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


DataType Property

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..DataType Property
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Type is either Void if there are no sources or Remote. Derived classes should expand on this.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual GH_ParamData DataType { get; }
Visual Basic
Public Overridable ReadOnly Property DataType As GH_ParamData
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Param`1.DataType"]

Implements

IGH_Param..::..DataType

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


HasProxySources Property

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..HasProxySources Property
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Gets a value indicating whether or not this parameter maintains proxy sources. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool HasProxySources { get; }
Visual Basic
Public Overridable ReadOnly Property HasProxySources As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Param`1.HasProxySources"]

Return Value

True if the parameter has at least one proxy source, false if not.

Implements

IGH_Param..::..HasProxySources

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


InstanceDescription Property

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..InstanceDescription Property
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the description of this instance. The default description is about the amount and source of the local values.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string InstanceDescription { get; }
Visual Basic
Public Overrides ReadOnly Property InstanceDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Param`1.InstanceDescription"]

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


IsDataProvider Property

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..IsDataProvider Property
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override sealed bool IsDataProvider { get; }
Visual Basic
Public Overrides NotOverridable ReadOnly Property IsDataProvider As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Param`1.IsDataProvider"]

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


IsPrincipal Property

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..IsPrincipal Property
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Gets whether this parameter is a principal parameter. Principal parameters are maintained by components and are not part of the IGH_Param interface.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PrincipalState IsPrincipal { get; }
Visual Basic
Public ReadOnly Property IsPrincipal As GH_PrincipalState
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Param`1.IsPrincipal"]

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Kind Property

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..Kind Property
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the parameter kind. The kind is evaluated lazily and cached.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual GH_ParamKind Kind { get; }
Visual Basic
Public Overridable ReadOnly Property Kind As GH_ParamKind
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Param`1.Kind"]

Implements

IGH_Param..::..Kind

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Optional Property

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..Optional Property
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Gets or sets whether or not this parameter is considered optional by the owner component. Empty, non-optional parameters prevent the component from being solved.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Optional { get; set; }
Visual Basic
Public Property Optional As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Param`1.Optional"]

Implements

IGH_Param..::..Optional

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


ProcessorTime Property

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..ProcessorTime Property
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override TimeSpan ProcessorTime { get; }
Visual Basic
Public Overrides ReadOnly Property ProcessorTime As TimeSpan
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Param`1.ProcessorTime"]

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


ProxySourceCount Property

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..ProxySourceCount Property
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the number of proxy sources for this parameter. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual int ProxySourceCount { get; }
Visual Basic
Public Overridable ReadOnly Property ProxySourceCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Param`1.ProxySourceCount"]

Return Value

The number of proxy sources associated with this parameter.

Implements

IGH_Param..::..ProxySourceCount

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Recipients Property

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..Recipients Property
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Gets a list of all the recipients of this parameter. I.e. a recipient has this parameter as one of the sources. The Recipient list is maintained by the parameter, do not modify it yourself.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual IList<IGH_Param> Recipients { get; }
Visual Basic
Public Overridable ReadOnly Property Recipients As IList(Of IGH_Param)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Param`1.Recipients"]

Implements

IGH_Param..::..Recipients

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Reverse Property

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..Reverse Property
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Gets or sets the data reverse modifier of this parameter.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Reverse { get; set; }
Visual Basic
Public Property Reverse As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Param`1.Reverse"]

Implements

IGH_Param..::..Reverse

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Simplify Property

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..Simplify Property
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Gets or sets the simplify modifier for this parameter.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Simplify { get; set; }
Visual Basic
Public Property Simplify As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Param`1.Simplify"]

Implements

IGH_Param..::..Simplify

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


SourceCount Property

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..SourceCount Property
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the number of sources for this parameter.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual int SourceCount { get; }
Visual Basic
Public Overridable ReadOnly Property SourceCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Param`1.SourceCount"]

Implements

IGH_Param..::..SourceCount

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Sources Property

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..Sources Property
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Gets a list of source parameters. Do not modify this list, if you wish to add or remove sources, use dedicated functions like AddSource() and RemoveSource() instead.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual IList<IGH_Param> Sources { get; }
Visual Basic
Public Overridable ReadOnly Property Sources As IList(Of IGH_Param)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Param`1.Sources"]

Return Value

The sources for this parameter.

Implements

IGH_Param..::..Sources

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


StateTags Property

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..StateTags Property
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Gets all the StateTags that are associated with this parameter. A state tag is a visual feedback icon that represents specific internal settings.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual GH_StateTagList StateTags { get; }
Visual Basic
Public Overridable ReadOnly Property StateTags As GH_StateTagList
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Param`1.StateTags"]

Implements

IGH_Param..::..StateTags

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Type Property

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..Type Property
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the Framework Type descriptor for the stored Data.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual Type Type { get; }
Visual Basic
Public Overridable ReadOnly Property Type As Type
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Param`1.Type"]

Implements

IGH_Param..::..Type

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


TypeName Property

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..TypeName Property
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Calls TypeName() on the first instance of T it can find. This is either an item in the volatile list, or a newly constructed instance.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual string TypeName { get; }
Visual Basic
Public Overridable ReadOnly Property TypeName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Param`1.TypeName"]

Implements

IGH_Param..::..TypeName

Remarks

Override this for improved performance, but this function is only likely to be called from the GUI.

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


VolatileData Property

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..VolatileData Property
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_Structure VolatileData { get; }
Visual Basic
Public ReadOnly Property VolatileData As IGH_Structure
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Param`1.VolatileData"]

Implements

IGH_Param..::..VolatileData

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


VolatileDataCount Property

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..VolatileDataCount Property
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int VolatileDataCount { get; }
Visual Basic
Public ReadOnly Property VolatileDataCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Param`1.VolatileDataCount"]

Implements

IGH_Param..::..VolatileDataCount

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


WireDisplay Property

[image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)>..::..WireDisplay Property
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback
Gets or sets the wire display style for this parameter. Wire display only affects the wires connected to the parameter input.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ParamWireDisplay WireDisplay { get; set; }
Visual Basic
Public Property WireDisplay As GH_ParamWireDisplay
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_Param`1.WireDisplay"]

Implements

IGH_Param..::..WireDisplay

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


GH_Param(T) Events

[image] [image]

Grasshopper SDK
GH_Param<(Of <(<'T>)>)> Events
GH_Param<(Of <(<'T>)>)> Class See Also Send Feedback

The GH_Param<(Of <(<'T>)>)> type exposes the following members.

Events

 | Name | Description
Public event | AttributesChanged | Raised whenever the number or kind of attributes changes. This event is handled by GH_Documents who subsequently wipe their attribute caches. (Inherited from GH_DocumentObject.)
Public event | DisplayExpired | Raised whenever the display (on the Canvas) of a certain object becomes invalid. (Inherited from GH_DocumentObject.)
Public event | ObjectChanged | (Inherited from GH_DocumentObject.)
Public event | PingDocument | Raised whenever an object needs to know which GH_Document it belongs to. (Inherited from GH_DocumentObject.)
Public event | PreviewExpired | Raised whenever the display (in the Rhino viewports) of a certain object becomes invalid. (Inherited from GH_DocumentObject.)
Public event | SolutionExpired | Raised whenever the solution of a certain object becomes invalid. (Inherited from GH_DocumentObject.)

See Also

GH_Param<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


GH_ParamAccess Enumeration

[image]

Grasshopper SDK
GH_ParamAccess Enumeration
See Also Send Feedback
Enumerates the types of access that parameters support.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_ParamAccess
Visual Basic
Public Enumeration GH_ParamAccess

Members

Member name | Value | Description
item | 0 | Every data item is to be treated individually.
list | 1 | All data branches will be treated at the same time.
tree | 2 | The entire data structure will be treated at once.

See Also

Grasshopper.Kernel Namespace


GH_ParamData Enumeration

[image]

Grasshopper SDK
GH_ParamData Enumeration
See Also Send Feedback
Enumerates the possible states of being for data inside a parameter.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_ParamData
Visual Basic
Public Enumeration GH_ParamData

Members

Member name | Value | Description
unknown | 0 | Unknown, this really shouldn't happen too often.
void | 1 | Parameter contains no data.
local | 2 | Parameter contains local data.
remote | 3 | Parameter contains data that came from elsewhere.

Remarks

See Also

Grasshopper.Kernel Namespace


GH_ParameterSide Enumeration

[image]

Grasshopper SDK
GH_ParameterSide Enumeration
See Also Send Feedback
Enumerates possible sides for variable parameters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_ParameterSide
Visual Basic
Public Enumeration GH_ParameterSide

Members

Member name | Value | Description
Input | 0 | Indicates parameters along the left edge of the component.
Output | 1 | Indicates parameters along the right edge of the component.

See Also

Grasshopper.Kernel Namespace


GH_ParamHashFields Enumeration

[image]

Grasshopper SDK
GH_ParamHashFields Enumeration
See Also Send Feedback
Enumerates all accepted fields for hashing parameter data.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
[FlagsAttribute]
public enum GH_ParamHashFields
Visual Basic
<FlagsAttribute> _
Public Enumeration GH_ParamHashFields

Members

Member name | Value | Description
None | 0 | Represents a blank hash.
Input | 1 | Input parameters are taken into account.
Output | 2 | Output parameters are taken into account.
InputAndOutput | 3 | Input and output parameters are taken into account.
InstanceId | 4 | Parameter instance ID is taken into account.
NickName | 8 | Parameter nickname is taken into account.
Access | 16 | Parameter access (item, list, tree) is taken into account.
TypeId | 32 | Parameter type code is taken into account.
PersistentData | 64 | Parameter persistent data is taken into account.
Expression | 128 | Parameter Expression is taken into account.
TypeHint | 256 | Parameter typehint is taken into account.
Sources | 65536 | Parameter source IDs are taken into account.
Recipients | 131072 | Parameter recipient IDs are taken into account.
SourcesAndRecipients | 196608 | Parameter sources and recipients are taken into account.
SerialData | 16777216 | Parameter serialization byte array is taken into account.
All | 16974335 |

See Also

Grasshopper.Kernel Namespace


GH_ParamKind Enumeration

[image]

Grasshopper SDK
GH_ParamKind Enumeration
See Also Send Feedback
Enumerates the different guises of parameter

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_ParamKind
Visual Basic
Public Enumeration GH_ParamKind

Members

Member name | Value | Description
unknown | 0 | Unknown, when this happens, something went wrong. Most likely it is due to someone deriving from GH_Param and not setting the kind.
floating | 1 | Parameter is top-level.
input | 2 | Parameter is tied to an owner component as an input.
output | 3 | Parameter is tied to an owner component as an output.

See Also

Grasshopper.Kernel Namespace


GH_ParamServerEventArgs Class

[image]

Grasshopper SDK
GH_ParamServerEventArgs Class
Members See Also Send Feedback
Arguments used in events for the GH_ComponentParamServer type.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_ParamServerEventArgs : EventArgs
Visual Basic
Public Class GH_ParamServerEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Grasshopper.Kernel..::..GH_ParamServerEventArgs

See Also

GH_ParamServerEventArgs Members
Grasshopper.Kernel Namespace


GH_ParamServerEventArgs Members

[image] [image]

Grasshopper SDK
GH_ParamServerEventArgs Members
GH_ParamServerEventArgs Class Properties See Also Send Feedback

The GH_ParamServerEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | OriginalArguments | Gets access to the original parameter event arguments.
Public property | Parameter | Gets the parameter that caused the original event.
Public property | ParameterIndex | Gets the index of the parameter that caused the original event.
Public property | ParameterSide | Gets the side of the parameter that caused the original event.
Public property | Server | Gets the GH_ComponentParamServer object that raised the event.

See Also

GH_ParamServerEventArgs Class
Grasshopper.Kernel Namespace


GH_ParamServerEventArgs Properties

[image] [image]

Grasshopper SDK
GH_ParamServerEventArgs Properties
GH_ParamServerEventArgs Class See Also Send Feedback

The GH_ParamServerEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | OriginalArguments | Gets access to the original parameter event arguments.
Public property | Parameter | Gets the parameter that caused the original event.
Public property | ParameterIndex | Gets the index of the parameter that caused the original event.
Public property | ParameterSide | Gets the side of the parameter that caused the original event.
Public property | Server | Gets the GH_ComponentParamServer object that raised the event.

See Also

GH_ParamServerEventArgs Class
Grasshopper.Kernel Namespace


OriginalArguments Property

[image]

Grasshopper SDK
GH_ParamServerEventArgs..::..OriginalArguments Property
GH_ParamServerEventArgs Class See Also Send Feedback
Gets access to the original parameter event arguments.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ObjectChangedEventArgs OriginalArguments { get; }
Visual Basic
Public ReadOnly Property OriginalArguments As GH_ObjectChangedEventArgs
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ParamServerEventArgs.OriginalArguments"]

See Also

GH_ParamServerEventArgs Class
Grasshopper.Kernel Namespace


Parameter Property

[image]

Grasshopper SDK
GH_ParamServerEventArgs..::..Parameter Property
GH_ParamServerEventArgs Class See Also Send Feedback
Gets the parameter that caused the original event.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_Param Parameter { get; }
Visual Basic
Public ReadOnly Property Parameter As IGH_Param
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ParamServerEventArgs.Parameter"]

See Also

GH_ParamServerEventArgs Class
Grasshopper.Kernel Namespace


ParameterIndex Property

[image]

Grasshopper SDK
GH_ParamServerEventArgs..::..ParameterIndex Property
GH_ParamServerEventArgs Class See Also Send Feedback
Gets the index of the parameter that caused the original event.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int ParameterIndex { get; }
Visual Basic
Public ReadOnly Property ParameterIndex As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ParamServerEventArgs.ParameterIndex"]

See Also

GH_ParamServerEventArgs Class
Grasshopper.Kernel Namespace


ParameterSide Property

[image]

Grasshopper SDK
GH_ParamServerEventArgs..::..ParameterSide Property
GH_ParamServerEventArgs Class See Also Send Feedback
Gets the side of the parameter that caused the original event.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ParameterSide ParameterSide { get; }
Visual Basic
Public ReadOnly Property ParameterSide As GH_ParameterSide
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ParamServerEventArgs.ParameterSide"]

See Also

GH_ParamServerEventArgs Class
Grasshopper.Kernel Namespace


Server Property

[image]

Grasshopper SDK
GH_ParamServerEventArgs..::..Server Property
GH_ParamServerEventArgs Class See Also Send Feedback
Gets the GH_ComponentParamServer object that raised the event.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ComponentParamServer Server { get; }
Visual Basic
Public ReadOnly Property Server As GH_ComponentParamServer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ParamServerEventArgs.Server"]

See Also

GH_ParamServerEventArgs Class
Grasshopper.Kernel Namespace


GH_ParamWireDisplay Enumeration

[image]

Grasshopper SDK
GH_ParamWireDisplay Enumeration
See Also Send Feedback
Enumerates the possible wire display types for parameters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_ParamWireDisplay
Visual Basic
Public Enumeration GH_ParamWireDisplay

Members

Member name | Value | Description
default | 0 | Wire display is controlled by the application settings.
faint | 1 | Wires are displayed faintly (thin and transparent) while the parameter is not selected.
hidden | 2 | Wires are not displayed at all while the parameter is not selected.

See Also

Grasshopper.Kernel Namespace


GH_PersistentGeometryParam(T) Class

[image]

Grasshopper SDK
GH_PersistentGeometryParam<(Of <(<'T>)>)> Class
Members See Also Send Feedback
Derives from GH_PersistentParam(Of T), but adds some useful functions for dealing with geometric data types.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract class GH_PersistentGeometryParam<T> : GH_PersistentParam<T>
where T : class, IGH_GeometricGoo
Visual Basic
Public MustInherit Class GH_PersistentGeometryParam(Of T As {Class, IGH_GeometricGoo}) _
    Inherits GH_PersistentParam(Of T)

Type Parameters

T
Data type of this parameter.

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_InstanceDescription
Grasshopper.Kernel..::..GH_DocumentObject
Grasshopper.Kernel..::..GH_ActiveObject
Grasshopper.Kernel..::..GH_Param <(Of <(<'T>)>)>
Grasshopper.Kernel..::..GH_PersistentParam <(Of <(<'T>)>)>
Grasshopper.Kernel..::..GH_PersistentGeometryParam<(Of <(<'T>)>)>

See Also

GH_PersistentGeometryParam<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


GH_PersistentGeometryParam(T) Members

[image] [image]

Grasshopper SDK
GH_PersistentGeometryParam<(Of <(<'T>)>)> Members
GH_PersistentGeometryParam<(Of <(<'T>)>)> Class Constructors Methods Fields Properties Events See Also Send Feedback

The GH_PersistentGeometryParam<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Protected method | GH_PersistentGeometryParam<(Of <(<'T>)>)>(GH_InstanceDescription) | Initializes a new instance of the GH_PersistentGeometryParam<(Of <(<'T>)>)> class
Protected method | GH_PersistentGeometryParam<(Of <(<'T>)>)>(GH_InstanceDescription, Boolean) | Obsolete. Initializes a new instance of the GH_PersistentGeometryParam<(Of <(<'T>)>)> class

Methods

 | Name | Description
Public method | AddedToDocument | This method will be called when an object is added to a document. Override this method if you want to handle such events. (Inherited from GH_DocumentObject.)
Public method | AddPersistentData(Object) | Obsolete. Utility function to add a new persistent data item. If the data is null or cannot be converted into T, this method will fail. You should probably use the PersistentData property to add type-safe data if you can. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | AddRuntimeMessage | Add a new message to this object. Valid message type flags are Warning and Error. If the Message string is empty or zero-length no message is added. (Inherited from GH_ActiveObject.)
Public method | AddSource(IGH_Param) | Append a new Source parameter to the end of the Sources list. Sources provide this parameter with data at runtime. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddSource(IGH_Param, Int32) | Insert a new Source parameter into the Sources list. Sources provide this parameter with data at runtime. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddVolatileData(GH_Path, Int32, Object) | Inserts an item of volatile data into the data structure. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddVolatileDataList(GH_Path, List<(Of <<'(T>)>>)) | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddVolatileDataList(GH_Path, IEnumerable) | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddVolatileDataTree(GH_Structure<(Of <<'(T>)>>)) | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddVolatileDataTree(IGH_Structure) | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AppendAdditionalMenuItems | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | AppendMenuItems | This function is called when a context menu is about to be displayed. Override it to set custom items. GH_ActiveObject will already populate the menu with default items, if you merely wish to insert object-specific menu item, consider overriding AppendAdditionalMenuItems instead. (Inherited from GH_ActiveObject.)
Protected method | Cast_Object | Attempts to convert the Object reference into an instance of T. This method will perform a direct cast if possible or it will call Casting functions on T or Data if they exist. Data will not be duplicated unless a type conversion is required. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ClearData | (Overrides GH_Param<(Of <(<'T>)>)>..::..ClearData()()()().)
Public method | ClearProxySources | Remove all proxy sources without attempting to relink them. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ClearRuntimeMessages | Destroy all warning and error lists (Inherited from GH_ActiveObject.)
Public method | CollectData | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | CollectVolatileData_Custom | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | CollectVolatileData_FromSources | This method collects volatile data from all the source parameters. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ComputeData | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | CopyFrom | Copy all fields (except the instance ID) from another instance description. (Inherited from GH_InstanceDescription.)
Public method | CreateAttributes | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | CreateProxySources | Convert all proper source parameters into proxy sources. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | DependsOn | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | DestroyIconCache | Call this method to erase the existing icon cache. You must call this if you want to change the display icon of an object. (Inherited from GH_DocumentObject.)
Public method | DocumentContextChanged | This method will be called when the document that owns this object moves into a different context. (Inherited from GH_DocumentObject.)
Protected method | EraseGeometryCaches |
Protected method | ExpireDownStreamObjects | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ExpirePreview | Call this function when you suspect that the preview has expired for this object. This will cause the display cache to be eradicated. (Inherited from GH_DocumentObject.)
Public method | ExpireSolution | Informs the document that owns this object that the solution has expired. The current object will be set to BLANK as a result. This method is recursive, it will also expire any and all objects which depend on this object. If you want a less destructive expiration, consider using ClearData(). If this object is already Blank, you should consider not expiring it. (Inherited from GH_ActiveObject.)
Protected method | Format | Returns "Null" if the data is a null reference, otherwise calls ToString() on the Data instance. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | GetValue(String, Boolean) | Get a boolean value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Double) | Get a double value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Color) | Get a color value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Int32) | Get an integer value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, String) | Get a string value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | HtmlHelp_Source | Return a String which contains HTML formatted source for the help topic. If you want to pass a URL that points to a remote page, then prefix the URL with a GOTO: tag, like so: GOTO:http://www.YourWebAddressHere.com (Inherited from GH_DocumentObject.)
Protected method | InstantiateT | Attempts to instantiate a new instance of T. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | IsolateObject | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendBakeItem | Append the default Bake menu item. (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendDestroyPersistent | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | Menu_AppendDisconnectWires | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendEnableItem | Append the default Enable/Disable menu item. (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendExtractParameter | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | Menu_AppendFlattenParameter | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendGraftParameter | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendInternaliseData | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | Menu_AppendManageCollection | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | Menu_AppendObjectHelp | Appends the default object Help menu item. (Inherited from GH_DocumentObject.)
Protected method | Menu_AppendObjectName | Appends the old-fashioned object name menu item. If you also want the Display mode toggle then use Menu_AppendObjectNameEx() (Inherited from GH_DocumentObject.)
Protected method | Menu_AppendObjectNameEx | Appends the default object name + display mode menu item. (Inherited from GH_DocumentObject.)
Protected method | Menu_AppendPreviewItem | Append the default Show/Hide preview menu item. (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendPrincipalParameter | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendPromptMore | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | Menu_AppendPromptOne | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | Menu_AppendReverseParameter | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendRuntimeMessages | Append the default warnings and errors menu items. (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendSimplifyParameter | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendWarningsAndErrors | Obsolete. This method is obsolete and has been replaced with Menu_AppendRuntimeMessages(). (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendWireDisplay | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_CreateMultilineTextEditItem | This function returns a ToolstripMenuItem that embeds a multi-line textbox for editing persistent data. Only call this method if you know that your parameter type supports proxies. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | Menu_CustomMultiValueItem | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | Menu_CustomSingleValueItem | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | MovedBetweenDocuments | This method will be called when an object is moved from one document to another. Override this method if you want to handle such events. (Inherited from GH_DocumentObject.)
Public method | NewInstanceGuid()()()() | Generate a new random instance GUID (Inherited from GH_InstanceDescription.)
Public method | NewInstanceGuid(Guid) | Set the instance ID to be a specific GUID. This is very dangerous, only use this function if you're 6"4' and your first name is David. (Inherited from GH_InstanceDescription.)
Public method | OnAttributesChanged | Raises the AttributesChanged event on the toplevel object. (Inherited from GH_DocumentObject.)
Public method | OnDisplayExpired | Raises the DisplayExpired event on the toplevel object. (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(String) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectChangedEventArgs) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(String, Object) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType, Object) | (Inherited from GH_DocumentObject.)
Public method | OnPingDocument | Raise the PingDocument Event on the toplevel object and try to find the document which owns this object. (Inherited from GH_DocumentObject.)
Public method | OnPreviewExpired | Raises the PreviewExpired event on the toplevel object. (Inherited from GH_DocumentObject.)
Public method | OnSolutionExpired | Raises the SolutionExpired event on the toplevel object. You probably want to call ExpireSolution() instead of this method directly. (Inherited from GH_DocumentObject.)
Protected method | OnVolatileDataCollected | This override removes all instances that fail to load their geometry. (Overrides GH_Param<(Of <(<'T>)>)>..::..OnVolatileDataCollected()()()().)
Protected method | PreferredCast | Implement this function if you're certain that you'll be confronted with very common casts. For example, GH_Point has a preferred cast from Rhino.Geometry.Point3d and GH_Number has a preferred cast from System.Double. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | PrepareForPrompt | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | Preview_ComputeClippingBox | This function can be used to iterate over all items in the Volatile data tree and collect the union clipping box of all non-null items that implement Preview.IGH_PreviewData. This function requires a lot of TypeOf and DirectCasting, so if you're worried about performance you should consider doing this yourself. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Preview_DrawMeshes | This function can be used to iterate over all items in the Volatile data tree and call DrawViewportWires on each item that implements Preview.IGH_PreviewData. This function requires a lot of TypeOf and DirectCasting, so if you're worried about performance you should consider doing this yourself. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Preview_DrawWires | This function can be used to iterate over all items in the Volatile data tree and call DrawViewportWires on each item that implements Preview.IGH_PreviewData. This function requires a lot of TypeOf and DirectCasting, so if you're worried about performance you should consider doing this yourself. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Prompt_ManageCollection | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | Prompt_Plural | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | Prompt_Singular | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | Read | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | ReadFull | GH_InstanceDescription does not by default serialize all fields. Use this function to read all fields from the archive. This method is compatible with the default Write()/Read() operations. (Inherited from GH_InstanceDescription.)
Protected method | RecordPersistentDataEvent | Add an undo record that stores changes to persistent data. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | RecordUndoEvent(String) | Record a generic object change undo event. (Inherited from GH_DocumentObject.)
Public method | RecordUndoEvent(GH_UndoRecord) | Record an entire undo record. (Inherited from GH_DocumentObject.)
Public method | RecordUndoEvent(String, IGH_UndoAction) | Record a specific object change undo event. (Inherited from GH_DocumentObject.)
Protected method | RecoverFromPrompt | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | RegisterRemoteIDs | (Overrides GH_ActiveObject..::..RegisterRemoteIDs(GH_GuidTable).)
Protected method | RegisterRemoteIDsUtil | Utility function which treats all data in the Volatile cache as IGH_GeometricGoo and registers all referenced objects. Call this function from within RegisterRemoteIDs() if you are absolutely sure that all the items in volatiledata implement IGH_GeometricGoo. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | RelinkProxySources | Attempt to replace all proxy sources with real sources. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | RemoveAllSources | Remove all sources from this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | RemovedFromDocument | This method will be called when an object is removed from a document. Override this method if you want to handle such events. (Inherited from GH_DocumentObject.)
Public method | RemoveEffects | Remove all post-process effects. Note to implementors, you must call the base method if you override this function. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | RemoveSource(Guid) | Remove the specified source from this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | RemoveSource(IGH_Param) | Remove the specified source from this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ReplaceSource(Guid, IGH_Param) | Replace an existing source with a new one. If the old_source does not exist in this parameter, nothing happens. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ReplaceSource(IGH_Param, IGH_Param) | Replace an existing source with a new one. If the old_source does not exist in this parameter, nothing happens. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | RuntimeMessages | Gets the list of cached runtime messages that were recorded during solver-time processes. (Inherited from GH_ActiveObject.)
Public method | Script_AddPersistentData | Method used primarily for COM_Access code. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | Script_ClearPersistentData | Method used primarily for COM_Access code. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | SDKCompliancy | Test whether this object is compliant with a given Rhino version. (Inherited from GH_ActiveObject.)
Public method | SetIconOverride | Set a new custom icon override for this object. (Inherited from GH_DocumentObject.)
Public method | SetPersistentData(array<Object>[]()[][]) | Add a collection of values to the persistent data. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | SetPersistentData(T) | Add a single item to the persistent data. This method will record an undo event, raise the OnObjectChanged event for PersistentData flags and place a call to ExpireSolution(False). If you want to add more than one piece of data, you should use the appropriate overload for this method. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | SetPrincipal | Set the principal parameter state. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | SetValue(String, Boolean) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Double) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Color) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Int32) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, String) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave()()()() | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(Guid) | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger, Guid) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from GH_DocumentObject.)
Protected method | ValuesChanged | Override this method if you want to respond to changes to the value table. The base implementation is empty, so you don't have to call it. (Inherited from GH_DocumentObject.)
Protected method | VolatileDataDescription | This method is called to populate the Tooltip data description field. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | Write | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | WriteFull | GH_InstanceDescription does not by default serialize all fields. Use this function to write all fields to the archive. This method is compatible with the default Write()/Read() operations. (Inherited from GH_InstanceDescription.)

Fields

 | Name | Description
Protected field | m_attributes | (Inherited from GH_DocumentObject.)
Protected field | m_data | Contains the runtime data for this parameter, also known as "Volatile" data. (Inherited from GH_Param<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Access | Gets or sets the Access level for this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | Attributes | Gets or sets the attributes that are associated with this object. Only set custom attributes if you know what you are doing. (Inherited from GH_DocumentObject.)
Public property | Category | Gets or sets the Category in which this object belongs. If HasCategory() returns false, this field has no meaning. (Inherited from GH_InstanceDescription.)
Public property | ComponentGuid | Returns a consistent ID for this object type. Every object must supply a unique and unchanging ID that is used to identify objects of the same type. (Inherited from GH_DocumentObject.)
Public property | DataMapping | Gets or sets the data mapping of this Parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | DataType | Gets the type of data stored in this parameter. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public property | Description | Gets or sets the description of the object. This field typically remains fixed during the lifetime of an object. (Inherited from GH_InstanceDescription.)
Public property | Exposure | Gets the exposure of this object in the Graphical User Interface. The default is to expose everywhere. (Inherited from GH_DocumentObject.)
Public property | HasCategory | Gets whether or not the Category field has been set. (Inherited from GH_InstanceDescription.)
Public property | HasProxySources | Gets a value indicating whether or not this parameter maintains proxy sources. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | HasSubCategory | Gets whether or not the SubCategory field has been set. (Inherited from GH_InstanceDescription.)
Protected property | Icon | Override this function to supply a custom icon (24x24 pixels). The result of this property is cached, so don't worry if icon retrieval is not very fast. (Inherited from GH_DocumentObject.)
Public property | Icon_24x24 | The icon associated with this object. (Inherited from GH_DocumentObject.)
Public property | Icon_24x24_Locked | The greyscale icon of this object. (Inherited from GH_DocumentObject.)
Public property | IconCapableUI | By default the NickName menu item supports the Icon Mode override toggle. If your UI is not capable of displaying icons, then override this property and return False. (Inherited from GH_ActiveObject.)
Public property | IconDisplayMode | Gets the current display mode of the object. (Inherited from GH_DocumentObject.)
Public property | InstanceDescription | Gets the description of this instance. The default description is about the amount and source of the local values. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | InstanceGuid | Gets the ID of this runtime instance. (Inherited from GH_InstanceDescription.)
Public property | IsDataProvider | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | IsPrincipal | Gets whether this parameter is a principal parameter. Principal parameters are maintained by components and are not part of the IGH_Param interface. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | Keywords | Gets a list of additional keywords that describe the object. Typically this list is empty but you can override this property to aid in object searches. (Inherited from GH_InstanceDescription.)
Public property | Kind | Gets the parameter kind. The kind is evaluated lazily and cached. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | Locked | Gets or sets the enabled flag of this object. Disabled objects are ignored during solutions. (Inherited from GH_ActiveObject.)
Public property | MutableNickName | Gets or sets a value that enables Nick name changes through the menu. The default is TRUE. (Inherited from GH_ActiveObject.)
Public property | Name | Gets or sets the name of the object. This field typically remains fixed during the lifetime of an object. (Inherited from GH_InstanceDescription.)
Public property | NickName | Gets or sets the nickname of the object. This field can be changed by the user. (Inherited from GH_InstanceDescription.)
Public property | Obsolete | Gets whether this object is obsolete. Default implementation returns true if the class name contains the string "OBSOLETE" or if this class has been decorated with the ObsoleteAttribute. You are free to override this if you want, but I suggest adding the ObsoleteAttribute instead. (Inherited from GH_DocumentObject.)
Public property | Optional | Gets or sets whether or not this parameter is considered optional by the owner component. Empty, non-optional parameters prevent the component from being solved. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | PersistentData | Gets the persistent data stored in this parameter. If you modify the persistent data, be sure to call the: OnObjectChanged(GH_ObjectEventType.PersistentData) event. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public property | PersistentDataCount | Gets the number of persistent data items stored in this parameter. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public property | Phase | Gets or sets the solution phase this object is currenly in. (Inherited from GH_ActiveObject.)
Public property | ProcessorTime | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | ProxySourceCount | Gets the number of proxy sources for this parameter. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | Recipients | Gets a list of all the recipients of this parameter. I.e. a recipient has this parameter as one of the sources. The Recipient list is maintained by the parameter, do not modify it yourself. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | Reverse | Gets or sets the data reverse modifier of this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | RuntimeMessageLevel | Returns the worst case flag for the current object If the object contains at least 1 error, the result is Error. If the object contains at least 1 warning, the result is Warning. If the object contains at least 1 message, the result is Remark. If the object contains no errors, no warnings and no messages, the result is Blank. (Inherited from GH_ActiveObject.)
Public property | Simplify | Gets or sets the simplify modifier for this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | SourceCount | Gets the number of sources for this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | Sources | Gets a list of source parameters. Do not modify this list, if you wish to add or remove sources, use dedicated functions like AddSource() and RemoveSource() instead. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | StateTags | Gets all the StateTags that are associated with this parameter. A state tag is a visual feedback icon that represents specific internal settings. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | SubCategory | Gets or sets the SubCategory in which this object belongs. If HasSubCategory() returns false, this field has no meaning. (Inherited from GH_InstanceDescription.)
Public property | Type | Gets the Framework Type descriptor for the stored Data. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | TypeName | Calls TypeName() on the first instance of T it can find. This is either an item in the volatile list, or a newly constructed instance. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | VolatileData | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | VolatileDataCount | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | WireDisplay | Gets or sets the wire display style for this parameter. Wire display only affects the wires connected to the parameter input. (Inherited from GH_Param<(Of <(<'T>)>)>.)

Events

 | Name | Description
Public event | AttributesChanged | Raised whenever the number or kind of attributes changes. This event is handled by GH_Documents who subsequently wipe their attribute caches. (Inherited from GH_DocumentObject.)
Public event | DisplayExpired | Raised whenever the display (on the Canvas) of a certain object becomes invalid. (Inherited from GH_DocumentObject.)
Public event | ObjectChanged | (Inherited from GH_DocumentObject.)
Public event | PingDocument | Raised whenever an object needs to know which GH_Document it belongs to. (Inherited from GH_DocumentObject.)
Public event | PreviewExpired | Raised whenever the display (in the Rhino viewports) of a certain object becomes invalid. (Inherited from GH_DocumentObject.)
Public event | SolutionExpired | Raised whenever the solution of a certain object becomes invalid. (Inherited from GH_DocumentObject.)

See Also

GH_PersistentGeometryParam<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


GH_PersistentGeometryParam(T) Constructor

[image] [image]

Grasshopper SDK
GH_PersistentGeometryParam<(Of <(<'T>)>)> Constructor
GH_PersistentGeometryParam<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GH_PersistentGeometryParam<(Of <(<'T>)>)>(GH_InstanceDescription) | Initializes a new instance of the GH_PersistentGeometryParam<(Of <(<'T>)>)> class
Protected method | GH_PersistentGeometryParam<(Of <(<'T>)>)>(GH_InstanceDescription, Boolean) | Obsolete. Initializes a new instance of the GH_PersistentGeometryParam<(Of <(<'T>)>)> class

See Also

GH_PersistentGeometryParam<(Of <(<'T>)>)> Class
GH_PersistentGeometryParam<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


GH_PersistentGeometryParam(T) Constructor (GH_InstanceDescription)

[image]

Grasshopper SDK
GH_PersistentGeometryParam<(Of <(<'T>)>)> Constructor (GH_InstanceDescription)
GH_PersistentGeometryParam<(Of <(<'T>)>)> Class See Also Send Feedback
Initializes a new instance of the GH_PersistentGeometryParam<(Of <(<'T>)>)> class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_PersistentGeometryParam(
    GH_InstanceDescription nTag
)
Visual Basic
Protected Sub New ( _
    nTag As GH_InstanceDescription _
)

Parameters

nTag
Type: Grasshopper.Kernel..::..GH_InstanceDescription

See Also

GH_PersistentGeometryParam<(Of <(<'T>)>)> Class
GH_PersistentGeometryParam<(Of <(<'T>)>)> Overload
Grasshopper.Kernel Namespace


GH_PersistentGeometryParam(T) Constructor (GH_InstanceDescription, Boolean)

[image]

Grasshopper SDK
GH_PersistentGeometryParam<(Of <(<'T>)>)> Constructor (GH_InstanceDescription, Boolean)
GH_PersistentGeometryParam<(Of <(<'T>)>)> Class See Also Send Feedback
Initializes a new instance of the GH_PersistentGeometryParam<(Of <(<'T>)>)> class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
[ObsoleteAttribute("This constructor is Obsolete and will be removed in future versions of Grasshopper.")]
protected GH_PersistentGeometryParam(
    GH_InstanceDescription nTag,
    bool bIsListParam
)
Visual Basic
<ObsoleteAttribute("This constructor is Obsolete and will be removed in future versions of Grasshopper.")> _
Protected Sub New ( _
    nTag As GH_InstanceDescription, _
    bIsListParam As Boolean _
)

Parameters

nTag
Type: Grasshopper.Kernel..::..GH_InstanceDescription
bIsListParam
Type: System..::..Boolean

See Also

GH_PersistentGeometryParam<(Of <(<'T>)>)> Class
GH_PersistentGeometryParam<(Of <(<'T>)>)> Overload
Grasshopper.Kernel Namespace


GH_PersistentGeometryParam(T) Fields

[image] [image]

Grasshopper SDK
GH_PersistentGeometryParam<(Of <(<'T>)>)> Fields
GH_PersistentGeometryParam<(Of <(<'T>)>)> Class See Also Send Feedback

The GH_PersistentGeometryParam<(Of <(<'T>)>)> type exposes the following members.

Fields

 | Name | Description
Protected field | m_attributes | (Inherited from GH_DocumentObject.)
Protected field | m_data | Contains the runtime data for this parameter, also known as "Volatile" data. (Inherited from GH_Param<(Of <(<'T>)>)>.)

See Also

GH_PersistentGeometryParam<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


GH_PersistentGeometryParam(T) Methods

[image] [image]

Grasshopper SDK
GH_PersistentGeometryParam<(Of <(<'T>)>)> Methods
GH_PersistentGeometryParam<(Of <(<'T>)>)> Class See Also Send Feedback

The GH_PersistentGeometryParam<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | AddedToDocument | This method will be called when an object is added to a document. Override this method if you want to handle such events. (Inherited from GH_DocumentObject.)
Public method | AddPersistentData(Object) | Obsolete. Utility function to add a new persistent data item. If the data is null or cannot be converted into T, this method will fail. You should probably use the PersistentData property to add type-safe data if you can. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | AddRuntimeMessage | Add a new message to this object. Valid message type flags are Warning and Error. If the Message string is empty or zero-length no message is added. (Inherited from GH_ActiveObject.)
Public method | AddSource(IGH_Param) | Append a new Source parameter to the end of the Sources list. Sources provide this parameter with data at runtime. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddSource(IGH_Param, Int32) | Insert a new Source parameter into the Sources list. Sources provide this parameter with data at runtime. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddVolatileData(GH_Path, Int32, Object) | Inserts an item of volatile data into the data structure. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddVolatileDataList(GH_Path, List<(Of <<'(T>)>>)) | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddVolatileDataList(GH_Path, IEnumerable) | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddVolatileDataTree(GH_Structure<(Of <<'(T>)>>)) | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddVolatileDataTree(IGH_Structure) | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AppendAdditionalMenuItems | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | AppendMenuItems | This function is called when a context menu is about to be displayed. Override it to set custom items. GH_ActiveObject will already populate the menu with default items, if you merely wish to insert object-specific menu item, consider overriding AppendAdditionalMenuItems instead. (Inherited from GH_ActiveObject.)
Protected method | Cast_Object | Attempts to convert the Object reference into an instance of T. This method will perform a direct cast if possible or it will call Casting functions on T or Data if they exist. Data will not be duplicated unless a type conversion is required. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ClearData | (Overrides GH_Param<(Of <(<'T>)>)>..::..ClearData()()()().)
Public method | ClearProxySources | Remove all proxy sources without attempting to relink them. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ClearRuntimeMessages | Destroy all warning and error lists (Inherited from GH_ActiveObject.)
Public method | CollectData | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | CollectVolatileData_Custom | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | CollectVolatileData_FromSources | This method collects volatile data from all the source parameters. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ComputeData | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | CopyFrom | Copy all fields (except the instance ID) from another instance description. (Inherited from GH_InstanceDescription.)
Public method | CreateAttributes | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | CreateProxySources | Convert all proper source parameters into proxy sources. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | DependsOn | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | DestroyIconCache | Call this method to erase the existing icon cache. You must call this if you want to change the display icon of an object. (Inherited from GH_DocumentObject.)
Public method | DocumentContextChanged | This method will be called when the document that owns this object moves into a different context. (Inherited from GH_DocumentObject.)
Protected method | EraseGeometryCaches |
Protected method | ExpireDownStreamObjects | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ExpirePreview | Call this function when you suspect that the preview has expired for this object. This will cause the display cache to be eradicated. (Inherited from GH_DocumentObject.)
Public method | ExpireSolution | Informs the document that owns this object that the solution has expired. The current object will be set to BLANK as a result. This method is recursive, it will also expire any and all objects which depend on this object. If you want a less destructive expiration, consider using ClearData(). If this object is already Blank, you should consider not expiring it. (Inherited from GH_ActiveObject.)
Protected method | Format | Returns "Null" if the data is a null reference, otherwise calls ToString() on the Data instance. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | GetValue(String, Boolean) | Get a boolean value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Double) | Get a double value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Color) | Get a color value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Int32) | Get an integer value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, String) | Get a string value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | HtmlHelp_Source | Return a String which contains HTML formatted source for the help topic. If you want to pass a URL that points to a remote page, then prefix the URL with a GOTO: tag, like so: GOTO:http://www.YourWebAddressHere.com (Inherited from GH_DocumentObject.)
Protected method | InstantiateT | Attempts to instantiate a new instance of T. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | IsolateObject | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendBakeItem | Append the default Bake menu item. (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendDestroyPersistent | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | Menu_AppendDisconnectWires | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendEnableItem | Append the default Enable/Disable menu item. (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendExtractParameter | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | Menu_AppendFlattenParameter | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendGraftParameter | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendInternaliseData | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | Menu_AppendManageCollection | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | Menu_AppendObjectHelp | Appends the default object Help menu item. (Inherited from GH_DocumentObject.)
Protected method | Menu_AppendObjectName | Appends the old-fashioned object name menu item. If you also want the Display mode toggle then use Menu_AppendObjectNameEx() (Inherited from GH_DocumentObject.)
Protected method | Menu_AppendObjectNameEx | Appends the default object name + display mode menu item. (Inherited from GH_DocumentObject.)
Protected method | Menu_AppendPreviewItem | Append the default Show/Hide preview menu item. (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendPrincipalParameter | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendPromptMore | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | Menu_AppendPromptOne | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | Menu_AppendReverseParameter | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendRuntimeMessages | Append the default warnings and errors menu items. (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendSimplifyParameter | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendWarningsAndErrors | Obsolete. This method is obsolete and has been replaced with Menu_AppendRuntimeMessages(). (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendWireDisplay | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_CreateMultilineTextEditItem | This function returns a ToolstripMenuItem that embeds a multi-line textbox for editing persistent data. Only call this method if you know that your parameter type supports proxies. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | Menu_CustomMultiValueItem | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | Menu_CustomSingleValueItem | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | MovedBetweenDocuments | This method will be called when an object is moved from one document to another. Override this method if you want to handle such events. (Inherited from GH_DocumentObject.)
Public method | NewInstanceGuid()()()() | Generate a new random instance GUID (Inherited from GH_InstanceDescription.)
Public method | NewInstanceGuid(Guid) | Set the instance ID to be a specific GUID. This is very dangerous, only use this function if you're 6"4' and your first name is David. (Inherited from GH_InstanceDescription.)
Public method | OnAttributesChanged | Raises the AttributesChanged event on the toplevel object. (Inherited from GH_DocumentObject.)
Public method | OnDisplayExpired | Raises the DisplayExpired event on the toplevel object. (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(String) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectChangedEventArgs) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(String, Object) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType, Object) | (Inherited from GH_DocumentObject.)
Public method | OnPingDocument | Raise the PingDocument Event on the toplevel object and try to find the document which owns this object. (Inherited from GH_DocumentObject.)
Public method | OnPreviewExpired | Raises the PreviewExpired event on the toplevel object. (Inherited from GH_DocumentObject.)
Public method | OnSolutionExpired | Raises the SolutionExpired event on the toplevel object. You probably want to call ExpireSolution() instead of this method directly. (Inherited from GH_DocumentObject.)
Protected method | OnVolatileDataCollected | This override removes all instances that fail to load their geometry. (Overrides GH_Param<(Of <(<'T>)>)>..::..OnVolatileDataCollected()()()().)
Protected method | PreferredCast | Implement this function if you're certain that you'll be confronted with very common casts. For example, GH_Point has a preferred cast from Rhino.Geometry.Point3d and GH_Number has a preferred cast from System.Double. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | PrepareForPrompt | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | Preview_ComputeClippingBox | This function can be used to iterate over all items in the Volatile data tree and collect the union clipping box of all non-null items that implement Preview.IGH_PreviewData. This function requires a lot of TypeOf and DirectCasting, so if you're worried about performance you should consider doing this yourself. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Preview_DrawMeshes | This function can be used to iterate over all items in the Volatile data tree and call DrawViewportWires on each item that implements Preview.IGH_PreviewData. This function requires a lot of TypeOf and DirectCasting, so if you're worried about performance you should consider doing this yourself. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Preview_DrawWires | This function can be used to iterate over all items in the Volatile data tree and call DrawViewportWires on each item that implements Preview.IGH_PreviewData. This function requires a lot of TypeOf and DirectCasting, so if you're worried about performance you should consider doing this yourself. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Prompt_ManageCollection | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | Prompt_Plural | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | Prompt_Singular | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | Read | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | ReadFull | GH_InstanceDescription does not by default serialize all fields. Use this function to read all fields from the archive. This method is compatible with the default Write()/Read() operations. (Inherited from GH_InstanceDescription.)
Protected method | RecordPersistentDataEvent | Add an undo record that stores changes to persistent data. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | RecordUndoEvent(String) | Record a generic object change undo event. (Inherited from GH_DocumentObject.)
Public method | RecordUndoEvent(GH_UndoRecord) | Record an entire undo record. (Inherited from GH_DocumentObject.)
Public method | RecordUndoEvent(String, IGH_UndoAction) | Record a specific object change undo event. (Inherited from GH_DocumentObject.)
Protected method | RecoverFromPrompt | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | RegisterRemoteIDs | (Overrides GH_ActiveObject..::..RegisterRemoteIDs(GH_GuidTable).)
Protected method | RegisterRemoteIDsUtil | Utility function which treats all data in the Volatile cache as IGH_GeometricGoo and registers all referenced objects. Call this function from within RegisterRemoteIDs() if you are absolutely sure that all the items in volatiledata implement IGH_GeometricGoo. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | RelinkProxySources | Attempt to replace all proxy sources with real sources. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | RemoveAllSources | Remove all sources from this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | RemovedFromDocument | This method will be called when an object is removed from a document. Override this method if you want to handle such events. (Inherited from GH_DocumentObject.)
Public method | RemoveEffects | Remove all post-process effects. Note to implementors, you must call the base method if you override this function. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | RemoveSource(Guid) | Remove the specified source from this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | RemoveSource(IGH_Param) | Remove the specified source from this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ReplaceSource(Guid, IGH_Param) | Replace an existing source with a new one. If the old_source does not exist in this parameter, nothing happens. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ReplaceSource(IGH_Param, IGH_Param) | Replace an existing source with a new one. If the old_source does not exist in this parameter, nothing happens. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | RuntimeMessages | Gets the list of cached runtime messages that were recorded during solver-time processes. (Inherited from GH_ActiveObject.)
Public method | Script_AddPersistentData | Method used primarily for COM_Access code. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | Script_ClearPersistentData | Method used primarily for COM_Access code. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | SDKCompliancy | Test whether this object is compliant with a given Rhino version. (Inherited from GH_ActiveObject.)
Public method | SetIconOverride | Set a new custom icon override for this object. (Inherited from GH_DocumentObject.)
Public method | SetPersistentData(array<Object>[]()[][]) | Add a collection of values to the persistent data. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | SetPersistentData(T) | Add a single item to the persistent data. This method will record an undo event, raise the OnObjectChanged event for PersistentData flags and place a call to ExpireSolution(False). If you want to add more than one piece of data, you should use the appropriate overload for this method. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | SetPrincipal | Set the principal parameter state. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | SetValue(String, Boolean) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Double) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Color) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Int32) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, String) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave()()()() | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(Guid) | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger, Guid) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from GH_DocumentObject.)
Protected method | ValuesChanged | Override this method if you want to respond to changes to the value table. The base implementation is empty, so you don't have to call it. (Inherited from GH_DocumentObject.)
Protected method | VolatileDataDescription | This method is called to populate the Tooltip data description field. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | Write | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | WriteFull | GH_InstanceDescription does not by default serialize all fields. Use this function to write all fields to the archive. This method is compatible with the default Write()/Read() operations. (Inherited from GH_InstanceDescription.)

See Also

GH_PersistentGeometryParam<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


AddSource Method

[image] [image]

Grasshopper SDK
GH_PersistentGeometryParam<(Of <(<'T>)>)>..::..AddSource Method
GH_PersistentGeometryParam<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddSource(IGH_Param) | Append a new Source parameter to the end of the Sources list. Sources provide this parameter with data at runtime. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddSource(IGH_Param, Int32) | Insert a new Source parameter into the Sources list. Sources provide this parameter with data at runtime. (Inherited from GH_Param<(Of <(<'T>)>)>.)

See Also

GH_PersistentGeometryParam<(Of <(<'T>)>)> Class
GH_PersistentGeometryParam<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


AddVolatileDataList Method

[image] [image]

Grasshopper SDK
GH_PersistentGeometryParam<(Of <(<'T>)>)>..::..AddVolatileDataList Method
GH_PersistentGeometryParam<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddVolatileDataList(GH_Path, List<(Of <<'(T>)>>)) | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddVolatileDataList(GH_Path, IEnumerable) | (Inherited from GH_Param<(Of <(<'T>)>)>.)

See Also

GH_PersistentGeometryParam<(Of <(<'T>)>)> Class
GH_PersistentGeometryParam<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


AddVolatileDataTree Method

[image] [image]

Grasshopper SDK
GH_PersistentGeometryParam<(Of <(<'T>)>)>..::..AddVolatileDataTree Method
GH_PersistentGeometryParam<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddVolatileDataTree(GH_Structure<(Of <<'(T>)>>)) | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddVolatileDataTree(IGH_Structure) | (Inherited from GH_Param<(Of <(<'T>)>)>.)

See Also

GH_PersistentGeometryParam<(Of <(<'T>)>)> Class
GH_PersistentGeometryParam<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


ClearData Method

[image]

Grasshopper SDK
GH_PersistentGeometryParam<(Of <(<'T>)>)>..::..ClearData Method
GH_PersistentGeometryParam<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void ClearData()
Visual Basic
Public Overrides Sub ClearData

See Also

GH_PersistentGeometryParam<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


EraseGeometryCaches Method

[image]

Grasshopper SDK
GH_PersistentGeometryParam<(Of <(<'T>)>)>..::..EraseGeometryCaches Method
GH_PersistentGeometryParam<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected void EraseGeometryCaches()
Visual Basic
Protected Sub EraseGeometryCaches

See Also

GH_PersistentGeometryParam<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


GetValue Method

[image] [image]

Grasshopper SDK
GH_PersistentGeometryParam<(Of <(<'T>)>)>..::..GetValue Method
GH_PersistentGeometryParam<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetValue(String, Boolean) | Get a boolean value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Double) | Get a double value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Color) | Get a color value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Int32) | Get an integer value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, String) | Get a string value from the component value table. (Inherited from GH_DocumentObject.)

See Also

GH_PersistentGeometryParam<(Of <(<'T>)>)> Class
GH_PersistentGeometryParam<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


NewInstanceGuid Method

[image] [image]

Grasshopper SDK
GH_PersistentGeometryParam<(Of <(<'T>)>)>..::..NewInstanceGuid Method
GH_PersistentGeometryParam<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NewInstanceGuid()()()() | Generate a new random instance GUID (Inherited from GH_InstanceDescription.)
Public method | NewInstanceGuid(Guid) | Set the instance ID to be a specific GUID. This is very dangerous, only use this function if you're 6"4' and your first name is David. (Inherited from GH_InstanceDescription.)

See Also

GH_PersistentGeometryParam<(Of <(<'T>)>)> Class
GH_PersistentGeometryParam<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


OnObjectChanged Method

[image] [image]

Grasshopper SDK
GH_PersistentGeometryParam<(Of <(<'T>)>)>..::..OnObjectChanged Method
GH_PersistentGeometryParam<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OnObjectChanged(String) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectChangedEventArgs) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(String, Object) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType, Object) | (Inherited from GH_DocumentObject.)

See Also

GH_PersistentGeometryParam<(Of <(<'T>)>)> Class
GH_PersistentGeometryParam<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


OnVolatileDataCollected Method

[image]

Grasshopper SDK
GH_PersistentGeometryParam<(Of <(<'T>)>)>..::..OnVolatileDataCollected Method
GH_PersistentGeometryParam<(Of <(<'T>)>)> Class See Also Send Feedback
This override removes all instances that fail to load their geometry.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void OnVolatileDataCollected()
Visual Basic
Protected Overrides Sub OnVolatileDataCollected

See Also

GH_PersistentGeometryParam<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


RecordUndoEvent Method

[image] [image]

Grasshopper SDK
GH_PersistentGeometryParam<(Of <(<'T>)>)>..::..RecordUndoEvent Method
GH_PersistentGeometryParam<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RecordUndoEvent(String) | Record a generic object change undo event. (Inherited from GH_DocumentObject.)
Public method | RecordUndoEvent(GH_UndoRecord) | Record an entire undo record. (Inherited from GH_DocumentObject.)
Public method | RecordUndoEvent(String, IGH_UndoAction) | Record a specific object change undo event. (Inherited from GH_DocumentObject.)

See Also

GH_PersistentGeometryParam<(Of <(<'T>)>)> Class
GH_PersistentGeometryParam<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


RegisterRemoteIDs Method

[image]

Grasshopper SDK
GH_PersistentGeometryParam<(Of <(<'T>)>)>..::..RegisterRemoteIDs Method
GH_PersistentGeometryParam<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void RegisterRemoteIDs(
    GH_GuidTable table
)
Visual Basic
Public Overrides Sub RegisterRemoteIDs ( _
    table As GH_GuidTable _
)

Parameters

table
Type: GH_GuidTable

See Also

GH_PersistentGeometryParam<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


RemoveSource Method

[image] [image]

Grasshopper SDK
GH_PersistentGeometryParam<(Of <(<'T>)>)>..::..RemoveSource Method
GH_PersistentGeometryParam<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveSource(Guid) | Remove the specified source from this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | RemoveSource(IGH_Param) | Remove the specified source from this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)

See Also

GH_PersistentGeometryParam<(Of <(<'T>)>)> Class
GH_PersistentGeometryParam<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


ReplaceSource Method

[image] [image]

Grasshopper SDK
GH_PersistentGeometryParam<(Of <(<'T>)>)>..::..ReplaceSource Method
GH_PersistentGeometryParam<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReplaceSource(Guid, IGH_Param) | Replace an existing source with a new one. If the old_source does not exist in this parameter, nothing happens. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ReplaceSource(IGH_Param, IGH_Param) | Replace an existing source with a new one. If the old_source does not exist in this parameter, nothing happens. (Inherited from GH_Param<(Of <(<'T>)>)>.)

See Also

GH_PersistentGeometryParam<(Of <(<'T>)>)> Class
GH_PersistentGeometryParam<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


SetPersistentData Method

[image] [image]

Grasshopper SDK
GH_PersistentGeometryParam<(Of <(<'T>)>)>..::..SetPersistentData Method
GH_PersistentGeometryParam<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetPersistentData(array<Object>[]()[][]) | Add a collection of values to the persistent data. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
 | SetPersistentData(array<Object>[]()[][]) |
Public method | SetPersistentData(T) | Add a single item to the persistent data. This method will record an undo event, raise the OnObjectChanged event for PersistentData flags and place a call to ExpireSolution(False). If you want to add more than one piece of data, you should use the appropriate overload for this method. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
 | SetPersistentData(T) |

See Also

GH_PersistentGeometryParam<(Of <(<'T>)>)> Class
GH_PersistentGeometryParam<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


SetValue Method

[image] [image]

Grasshopper SDK
GH_PersistentGeometryParam<(Of <(<'T>)>)>..::..SetValue Method
GH_PersistentGeometryParam<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SetValue(String, Boolean) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Double) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Color) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Int32) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, String) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)

See Also

GH_PersistentGeometryParam<(Of <(<'T>)>)> Class
GH_PersistentGeometryParam<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


TriggerAutoSave Method

[image] [image]

Grasshopper SDK
GH_PersistentGeometryParam<(Of <(<'T>)>)>..::..TriggerAutoSave Method
GH_PersistentGeometryParam<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TriggerAutoSave()()()() | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(Guid) | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger, Guid) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from GH_DocumentObject.)

See Also

GH_PersistentGeometryParam<(Of <(<'T>)>)> Class
GH_PersistentGeometryParam<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


GH_PersistentGeometryParam(T) Properties

[image] [image]

Grasshopper SDK
GH_PersistentGeometryParam<(Of <(<'T>)>)> Properties
GH_PersistentGeometryParam<(Of <(<'T>)>)> Class See Also Send Feedback

The GH_PersistentGeometryParam<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Access | Gets or sets the Access level for this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | Attributes | Gets or sets the attributes that are associated with this object. Only set custom attributes if you know what you are doing. (Inherited from GH_DocumentObject.)
Public property | Category | Gets or sets the Category in which this object belongs. If HasCategory() returns false, this field has no meaning. (Inherited from GH_InstanceDescription.)
Public property | ComponentGuid | Returns a consistent ID for this object type. Every object must supply a unique and unchanging ID that is used to identify objects of the same type. (Inherited from GH_DocumentObject.)
Public property | DataMapping | Gets or sets the data mapping of this Parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | DataType | Gets the type of data stored in this parameter. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public property | Description | Gets or sets the description of the object. This field typically remains fixed during the lifetime of an object. (Inherited from GH_InstanceDescription.)
Public property | Exposure | Gets the exposure of this object in the Graphical User Interface. The default is to expose everywhere. (Inherited from GH_DocumentObject.)
Public property | HasCategory | Gets whether or not the Category field has been set. (Inherited from GH_InstanceDescription.)
Public property | HasProxySources | Gets a value indicating whether or not this parameter maintains proxy sources. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | HasSubCategory | Gets whether or not the SubCategory field has been set. (Inherited from GH_InstanceDescription.)
Protected property | Icon | Override this function to supply a custom icon (24x24 pixels). The result of this property is cached, so don't worry if icon retrieval is not very fast. (Inherited from GH_DocumentObject.)
Public property | Icon_24x24 | The icon associated with this object. (Inherited from GH_DocumentObject.)
Public property | Icon_24x24_Locked | The greyscale icon of this object. (Inherited from GH_DocumentObject.)
Public property | IconCapableUI | By default the NickName menu item supports the Icon Mode override toggle. If your UI is not capable of displaying icons, then override this property and return False. (Inherited from GH_ActiveObject.)
Public property | IconDisplayMode | Gets the current display mode of the object. (Inherited from GH_DocumentObject.)
Public property | InstanceDescription | Gets the description of this instance. The default description is about the amount and source of the local values. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | InstanceGuid | Gets the ID of this runtime instance. (Inherited from GH_InstanceDescription.)
Public property | IsDataProvider | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | IsPrincipal | Gets whether this parameter is a principal parameter. Principal parameters are maintained by components and are not part of the IGH_Param interface. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | Keywords | Gets a list of additional keywords that describe the object. Typically this list is empty but you can override this property to aid in object searches. (Inherited from GH_InstanceDescription.)
Public property | Kind | Gets the parameter kind. The kind is evaluated lazily and cached. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | Locked | Gets or sets the enabled flag of this object. Disabled objects are ignored during solutions. (Inherited from GH_ActiveObject.)
Public property | MutableNickName | Gets or sets a value that enables Nick name changes through the menu. The default is TRUE. (Inherited from GH_ActiveObject.)
Public property | Name | Gets or sets the name of the object. This field typically remains fixed during the lifetime of an object. (Inherited from GH_InstanceDescription.)
Public property | NickName | Gets or sets the nickname of the object. This field can be changed by the user. (Inherited from GH_InstanceDescription.)
Public property | Obsolete | Gets whether this object is obsolete. Default implementation returns true if the class name contains the string "OBSOLETE" or if this class has been decorated with the ObsoleteAttribute. You are free to override this if you want, but I suggest adding the ObsoleteAttribute instead. (Inherited from GH_DocumentObject.)
Public property | Optional | Gets or sets whether or not this parameter is considered optional by the owner component. Empty, non-optional parameters prevent the component from being solved. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | PersistentData | Gets the persistent data stored in this parameter. If you modify the persistent data, be sure to call the: OnObjectChanged(GH_ObjectEventType.PersistentData) event. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public property | PersistentDataCount | Gets the number of persistent data items stored in this parameter. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public property | Phase | Gets or sets the solution phase this object is currenly in. (Inherited from GH_ActiveObject.)
Public property | ProcessorTime | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | ProxySourceCount | Gets the number of proxy sources for this parameter. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | Recipients | Gets a list of all the recipients of this parameter. I.e. a recipient has this parameter as one of the sources. The Recipient list is maintained by the parameter, do not modify it yourself. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | Reverse | Gets or sets the data reverse modifier of this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | RuntimeMessageLevel | Returns the worst case flag for the current object If the object contains at least 1 error, the result is Error. If the object contains at least 1 warning, the result is Warning. If the object contains at least 1 message, the result is Remark. If the object contains no errors, no warnings and no messages, the result is Blank. (Inherited from GH_ActiveObject.)
Public property | Simplify | Gets or sets the simplify modifier for this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | SourceCount | Gets the number of sources for this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | Sources | Gets a list of source parameters. Do not modify this list, if you wish to add or remove sources, use dedicated functions like AddSource() and RemoveSource() instead. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | StateTags | Gets all the StateTags that are associated with this parameter. A state tag is a visual feedback icon that represents specific internal settings. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | SubCategory | Gets or sets the SubCategory in which this object belongs. If HasSubCategory() returns false, this field has no meaning. (Inherited from GH_InstanceDescription.)
Public property | Type | Gets the Framework Type descriptor for the stored Data. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | TypeName | Calls TypeName() on the first instance of T it can find. This is either an item in the volatile list, or a newly constructed instance. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | VolatileData | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | VolatileDataCount | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | WireDisplay | Gets or sets the wire display style for this parameter. Wire display only affects the wires connected to the parameter input. (Inherited from GH_Param<(Of <(<'T>)>)>.)

See Also

GH_PersistentGeometryParam<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


GH_PersistentGeometryParam(T) Events

[image] [image]

Grasshopper SDK
GH_PersistentGeometryParam<(Of <(<'T>)>)> Events
GH_PersistentGeometryParam<(Of <(<'T>)>)> Class See Also Send Feedback

The GH_PersistentGeometryParam<(Of <(<'T>)>)> type exposes the following members.

Events

 | Name | Description
Public event | AttributesChanged | Raised whenever the number or kind of attributes changes. This event is handled by GH_Documents who subsequently wipe their attribute caches. (Inherited from GH_DocumentObject.)
Public event | DisplayExpired | Raised whenever the display (on the Canvas) of a certain object becomes invalid. (Inherited from GH_DocumentObject.)
Public event | ObjectChanged | (Inherited from GH_DocumentObject.)
Public event | PingDocument | Raised whenever an object needs to know which GH_Document it belongs to. (Inherited from GH_DocumentObject.)
Public event | PreviewExpired | Raised whenever the display (in the Rhino viewports) of a certain object becomes invalid. (Inherited from GH_DocumentObject.)
Public event | SolutionExpired | Raised whenever the solution of a certain object becomes invalid. (Inherited from GH_DocumentObject.)

See Also

GH_PersistentGeometryParam<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


GH_PersistentParam(T) Class

[image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)> Class
Members See Also Send Feedback
Implementation of GH_Param(Of T) that supports persistent data.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract class GH_PersistentParam<T> : GH_Param<T>
where T : class, IGH_Goo
Visual Basic
Public MustInherit Class GH_PersistentParam(Of T As {Class, IGH_Goo}) _
    Inherits GH_Param(Of T)

Type Parameters

T
Data type for this parameter.

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_InstanceDescription
Grasshopper.Kernel..::..GH_DocumentObject
Grasshopper.Kernel..::..GH_ActiveObject
Grasshopper.Kernel..::..GH_Param <(Of <(<'T>)>)>
Grasshopper.Kernel..::..GH_PersistentParam<(Of <(<'T>)>)>
Grasshopper.Kernel..::..GH_PersistentGeometryParam<(Of <(<'T>)>)>
Grasshopper.Kernel.Parameters..::..Param_MeshParameters

See Also

GH_PersistentParam<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


GH_PersistentParam(T) Members

[image] [image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)> Members
GH_PersistentParam<(Of <(<'T>)>)> Class Constructors Methods Fields Properties Events See Also Send Feedback

The GH_PersistentParam<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Protected method | GH_PersistentParam<(Of <(<'T>)>)>(GH_InstanceDescription) | Initializes a new instance of the GH_PersistentParam<(Of <(<'T>)>)> class
Protected method | GH_PersistentParam<(Of <(<'T>)>)>(GH_InstanceDescription, Boolean) | Obsolete. Initializes a new instance of the GH_PersistentParam<(Of <(<'T>)>)> class
Protected method | GH_PersistentParam<(Of <(<'T>)>)>(String, String, String, String, String) | Initializes a new instance of the GH_PersistentParam<(Of <(<'T>)>)> class

Methods

 | Name | Description
Public method | AddedToDocument | This method will be called when an object is added to a document. Override this method if you want to handle such events. (Inherited from GH_DocumentObject.)
Public method | AddPersistentData(Object) | Obsolete. Utility function to add a new persistent data item. If the data is null or cannot be converted into T, this method will fail. You should probably use the PersistentData property to add type-safe data if you can.
Public method | AddPersistentData(T) | Obsolete. Utility function to add a new persistent data item. If the data is null or cannot be converted into T, this method will fail. You should probably use the PersistentData property to add type-safe data if you can.
Public method | AddRuntimeMessage | Add a new message to this object. Valid message type flags are Warning and Error. If the Message string is empty or zero-length no message is added. (Inherited from GH_ActiveObject.)
Public method | AddSource(IGH_Param) | Append a new Source parameter to the end of the Sources list. Sources provide this parameter with data at runtime. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddSource(IGH_Param, Int32) | Insert a new Source parameter into the Sources list. Sources provide this parameter with data at runtime. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddVolatileData(GH_Path, Int32, Object) | Inserts an item of volatile data into the data structure. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddVolatileDataList(GH_Path, List<(Of <<'(T>)>>)) | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddVolatileDataList(GH_Path, IEnumerable) | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddVolatileDataTree(GH_Structure<(Of <<'(T>)>>)) | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddVolatileDataTree(IGH_Structure) | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AppendAdditionalMenuItems | (Overrides GH_Param<(Of <(<'T>)>)>..::..AppendAdditionalMenuItems(ToolStripDropDown).)
Public method | AppendMenuItems | This function is called when a context menu is about to be displayed. Override it to set custom items. GH_ActiveObject will already populate the menu with default items, if you merely wish to insert object-specific menu item, consider overriding AppendAdditionalMenuItems instead. (Inherited from GH_ActiveObject.)
Protected method | Cast_Object | Attempts to convert the Object reference into an instance of T. This method will perform a direct cast if possible or it will call Casting functions on T or Data if they exist. Data will not be duplicated unless a type conversion is required. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ClearData | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ClearProxySources | Remove all proxy sources without attempting to relink them. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ClearRuntimeMessages | Destroy all warning and error lists (Inherited from GH_ActiveObject.)
Public method | CollectData | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | CollectVolatileData_Custom | (Overrides GH_Param<(Of <(<'T>)>)>..::..CollectVolatileData_Custom()()()().)
Protected method | CollectVolatileData_FromSources | This method collects volatile data from all the source parameters. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ComputeData | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | CopyFrom | Copy all fields (except the instance ID) from another instance description. (Inherited from GH_InstanceDescription.)
Public method | CreateAttributes | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | CreateProxySources | Convert all proper source parameters into proxy sources. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | DependsOn | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | DestroyIconCache | Call this method to erase the existing icon cache. You must call this if you want to change the display icon of an object. (Inherited from GH_DocumentObject.)
Public method | DocumentContextChanged | This method will be called when the document that owns this object moves into a different context. (Inherited from GH_DocumentObject.)
Protected method | ExpireDownStreamObjects | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ExpirePreview | Call this function when you suspect that the preview has expired for this object. This will cause the display cache to be eradicated. (Inherited from GH_DocumentObject.)
Public method | ExpireSolution | Informs the document that owns this object that the solution has expired. The current object will be set to BLANK as a result. This method is recursive, it will also expire any and all objects which depend on this object. If you want a less destructive expiration, consider using ClearData(). If this object is already Blank, you should consider not expiring it. (Inherited from GH_ActiveObject.)
Protected method | Format | Returns "Null" if the data is a null reference, otherwise calls ToString() on the Data instance. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | GetValue(String, Boolean) | Get a boolean value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Double) | Get a double value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Color) | Get a color value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Int32) | Get an integer value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, String) | Get a string value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | HtmlHelp_Source | Return a String which contains HTML formatted source for the help topic. If you want to pass a URL that points to a remote page, then prefix the URL with a GOTO: tag, like so: GOTO:http://www.YourWebAddressHere.com (Inherited from GH_DocumentObject.)
Protected method | InstantiateT | Attempts to instantiate a new instance of T. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | IsolateObject | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendBakeItem | Append the default Bake menu item. (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendDestroyPersistent |
Protected method | Menu_AppendDisconnectWires | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendEnableItem | Append the default Enable/Disable menu item. (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendExtractParameter |
Protected method | Menu_AppendFlattenParameter | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendGraftParameter | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendInternaliseData |
Protected method | Menu_AppendManageCollection |
Protected method | Menu_AppendObjectHelp | Appends the default object Help menu item. (Inherited from GH_DocumentObject.)
Protected method | Menu_AppendObjectName | Appends the old-fashioned object name menu item. If you also want the Display mode toggle then use Menu_AppendObjectNameEx() (Inherited from GH_DocumentObject.)
Protected method | Menu_AppendObjectNameEx | Appends the default object name + display mode menu item. (Inherited from GH_DocumentObject.)
Protected method | Menu_AppendPreviewItem | Append the default Show/Hide preview menu item. (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendPrincipalParameter | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendPromptMore |
Protected method | Menu_AppendPromptOne |
Protected method | Menu_AppendReverseParameter | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendRuntimeMessages | Append the default warnings and errors menu items. (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendSimplifyParameter | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendWarningsAndErrors | Obsolete. This method is obsolete and has been replaced with Menu_AppendRuntimeMessages(). (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendWireDisplay | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_CreateMultilineTextEditItem | This function returns a ToolstripMenuItem that embeds a multi-line textbox for editing persistent data. Only call this method if you know that your parameter type supports proxies.
Protected method | Menu_CustomMultiValueItem |
Protected method | Menu_CustomSingleValueItem |
Public method | MovedBetweenDocuments | This method will be called when an object is moved from one document to another. Override this method if you want to handle such events. (Inherited from GH_DocumentObject.)
Public method | NewInstanceGuid()()()() | Generate a new random instance GUID (Inherited from GH_InstanceDescription.)
Public method | NewInstanceGuid(Guid) | Set the instance ID to be a specific GUID. This is very dangerous, only use this function if you're 6"4' and your first name is David. (Inherited from GH_InstanceDescription.)
Public method | OnAttributesChanged | Raises the AttributesChanged event on the toplevel object. (Inherited from GH_DocumentObject.)
Public method | OnDisplayExpired | Raises the DisplayExpired event on the toplevel object. (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(String) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectChangedEventArgs) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(String, Object) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType, Object) | (Inherited from GH_DocumentObject.)
Public method | OnPingDocument | Raise the PingDocument Event on the toplevel object and try to find the document which owns this object. (Inherited from GH_DocumentObject.)
Public method | OnPreviewExpired | Raises the PreviewExpired event on the toplevel object. (Inherited from GH_DocumentObject.)
Public method | OnSolutionExpired | Raises the SolutionExpired event on the toplevel object. You probably want to call ExpireSolution() instead of this method directly. (Inherited from GH_DocumentObject.)
Protected method | OnVolatileDataCollected | Once volatile data has been collected this method will be calles. The basic implementation does nothing, but you can add code here to post-process or analyze the volatile data. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | PreferredCast | Implement this function if you're certain that you'll be confronted with very common casts. For example, GH_Point has a preferred cast from Rhino.Geometry.Point3d and GH_Number has a preferred cast from System.Double. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | PrepareForPrompt |
Protected method | Preview_ComputeClippingBox | This function can be used to iterate over all items in the Volatile data tree and collect the union clipping box of all non-null items that implement Preview.IGH_PreviewData. This function requires a lot of TypeOf and DirectCasting, so if you're worried about performance you should consider doing this yourself. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Preview_DrawMeshes | This function can be used to iterate over all items in the Volatile data tree and call DrawViewportWires on each item that implements Preview.IGH_PreviewData. This function requires a lot of TypeOf and DirectCasting, so if you're worried about performance you should consider doing this yourself. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Preview_DrawWires | This function can be used to iterate over all items in the Volatile data tree and call DrawViewportWires on each item that implements Preview.IGH_PreviewData. This function requires a lot of TypeOf and DirectCasting, so if you're worried about performance you should consider doing this yourself. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Prompt_ManageCollection |
Protected method | Prompt_Plural |
Protected method | Prompt_Singular |
Public method | Read | (Overrides GH_Param<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ReadFull | GH_InstanceDescription does not by default serialize all fields. Use this function to read all fields from the archive. This method is compatible with the default Write()/Read() operations. (Inherited from GH_InstanceDescription.)
Protected method | RecordPersistentDataEvent | Add an undo record that stores changes to persistent data.
Public method | RecordUndoEvent(String) | Record a generic object change undo event. (Inherited from GH_DocumentObject.)
Public method | RecordUndoEvent(GH_UndoRecord) | Record an entire undo record. (Inherited from GH_DocumentObject.)
Public method | RecordUndoEvent(String, IGH_UndoAction) | Record a specific object change undo event. (Inherited from GH_DocumentObject.)
Protected method | RecoverFromPrompt |
Public method | RegisterRemoteIDs | Override this function if you want object changes in the Rhino document to trigger a new solution. (Inherited from GH_ActiveObject.)
Protected method | RegisterRemoteIDsUtil | Utility function which treats all data in the Volatile cache as IGH_GeometricGoo and registers all referenced objects. Call this function from within RegisterRemoteIDs() if you are absolutely sure that all the items in volatiledata implement IGH_GeometricGoo. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | RelinkProxySources | Attempt to replace all proxy sources with real sources. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | RemoveAllSources | Remove all sources from this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | RemovedFromDocument | This method will be called when an object is removed from a document. Override this method if you want to handle such events. (Inherited from GH_DocumentObject.)
Public method | RemoveEffects | Remove all post-process effects. Note to implementors, you must call the base method if you override this function. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | RemoveSource(Guid) | Remove the specified source from this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | RemoveSource(IGH_Param) | Remove the specified source from this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ReplaceSource(Guid, IGH_Param) | Replace an existing source with a new one. If the old_source does not exist in this parameter, nothing happens. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ReplaceSource(IGH_Param, IGH_Param) | Replace an existing source with a new one. If the old_source does not exist in this parameter, nothing happens. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | RuntimeMessages | Gets the list of cached runtime messages that were recorded during solver-time processes. (Inherited from GH_ActiveObject.)
Public method | Script_AddPersistentData | Method used primarily for COM_Access code.
Public method | Script_ClearPersistentData | Method used primarily for COM_Access code.
Public method | SDKCompliancy | Test whether this object is compliant with a given Rhino version. (Inherited from GH_ActiveObject.)
Public method | SetIconOverride | Set a new custom icon override for this object. (Inherited from GH_DocumentObject.)
Public method | SetPersistentData(IEnumerable<(Of <<'(T>)>>)) | Assign a list of items to the persistent data. This method will erase any existing data, record an undo event, raise the OnObjectChanged event for PersistentData flags and place a call to ExpireSolution(False). If you want to add a tree of data, you should use the appropriate overload for this method.
Public method | SetPersistentData(array<Object>[]()[][]) | Add a collection of values to the persistent data.
Public method | SetPersistentData(T) | Add a single item to the persistent data. This method will record an undo event, raise the OnObjectChanged event for PersistentData flags and place a call to ExpireSolution(False). If you want to add more than one piece of data, you should use the appropriate overload for this method.
Public method | SetPersistentData(GH_Structure<(Of <<'(T>)>>)) | Assign a tree of items to the persistent data. This method will erase any existing data, record an undo event, raise the OnObjectChanged event for PersistentData flags and place a call to ExpireSolution(False). If you want to add a tree of data, you should use the appropriate overload for this method.
Public method | SetPrincipal | Set the principal parameter state. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | SetValue(String, Boolean) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Double) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Color) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Int32) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, String) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave()()()() | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(Guid) | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger, Guid) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from GH_DocumentObject.)
Protected method | ValuesChanged | Override this method if you want to respond to changes to the value table. The base implementation is empty, so you don't have to call it. (Inherited from GH_DocumentObject.)
Protected method | VolatileDataDescription | This method is called to populate the Tooltip data description field. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | Write | (Overrides GH_Param<(Of <(<'T>)>)>..::..Write(GH_IWriter).)
Public method | WriteFull | GH_InstanceDescription does not by default serialize all fields. Use this function to write all fields to the archive. This method is compatible with the default Write()/Read() operations. (Inherited from GH_InstanceDescription.)

Fields

 | Name | Description
Protected field | m_attributes | (Inherited from GH_DocumentObject.)
Protected field | m_data | Contains the runtime data for this parameter, also known as "Volatile" data. (Inherited from GH_Param<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Access | Gets or sets the Access level for this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | Attributes | Gets or sets the attributes that are associated with this object. Only set custom attributes if you know what you are doing. (Inherited from GH_DocumentObject.)
Public property | Category | Gets or sets the Category in which this object belongs. If HasCategory() returns false, this field has no meaning. (Inherited from GH_InstanceDescription.)
Public property | ComponentGuid | Returns a consistent ID for this object type. Every object must supply a unique and unchanging ID that is used to identify objects of the same type. (Inherited from GH_DocumentObject.)
Public property | DataMapping | Gets or sets the data mapping of this Parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | DataType | Gets the type of data stored in this parameter. (Overrides GH_Param<(Of <(<'T>)>)>..::..DataType.)
Public property | Description | Gets or sets the description of the object. This field typically remains fixed during the lifetime of an object. (Inherited from GH_InstanceDescription.)
Public property | Exposure | Gets the exposure of this object in the Graphical User Interface. The default is to expose everywhere. (Inherited from GH_DocumentObject.)
Public property | HasCategory | Gets whether or not the Category field has been set. (Inherited from GH_InstanceDescription.)
Public property | HasProxySources | Gets a value indicating whether or not this parameter maintains proxy sources. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | HasSubCategory | Gets whether or not the SubCategory field has been set. (Inherited from GH_InstanceDescription.)
Protected property | Icon | Override this function to supply a custom icon (24x24 pixels). The result of this property is cached, so don't worry if icon retrieval is not very fast. (Inherited from GH_DocumentObject.)
Public property | Icon_24x24 | The icon associated with this object. (Inherited from GH_DocumentObject.)
Public property | Icon_24x24_Locked | The greyscale icon of this object. (Inherited from GH_DocumentObject.)
Public property | IconCapableUI | By default the NickName menu item supports the Icon Mode override toggle. If your UI is not capable of displaying icons, then override this property and return False. (Inherited from GH_ActiveObject.)
Public property | IconDisplayMode | Gets the current display mode of the object. (Inherited from GH_DocumentObject.)
Public property | InstanceDescription | Gets the description of this instance. The default description is about the amount and source of the local values. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | InstanceGuid | Gets the ID of this runtime instance. (Inherited from GH_InstanceDescription.)
Public property | IsDataProvider | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | IsPrincipal | Gets whether this parameter is a principal parameter. Principal parameters are maintained by components and are not part of the IGH_Param interface. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | Keywords | Gets a list of additional keywords that describe the object. Typically this list is empty but you can override this property to aid in object searches. (Inherited from GH_InstanceDescription.)
Public property | Kind | Gets the parameter kind. The kind is evaluated lazily and cached. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | Locked | Gets or sets the enabled flag of this object. Disabled objects are ignored during solutions. (Inherited from GH_ActiveObject.)
Public property | MutableNickName | Gets or sets a value that enables Nick name changes through the menu. The default is TRUE. (Inherited from GH_ActiveObject.)
Public property | Name | Gets or sets the name of the object. This field typically remains fixed during the lifetime of an object. (Inherited from GH_InstanceDescription.)
Public property | NickName | Gets or sets the nickname of the object. This field can be changed by the user. (Inherited from GH_InstanceDescription.)
Public property | Obsolete | Gets whether this object is obsolete. Default implementation returns true if the class name contains the string "OBSOLETE" or if this class has been decorated with the ObsoleteAttribute. You are free to override this if you want, but I suggest adding the ObsoleteAttribute instead. (Inherited from GH_DocumentObject.)
Public property | Optional | Gets or sets whether or not this parameter is considered optional by the owner component. Empty, non-optional parameters prevent the component from being solved. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | PersistentData | Gets the persistent data stored in this parameter. If you modify the persistent data, be sure to call the: OnObjectChanged(GH_ObjectEventType.PersistentData) event.
Public property | PersistentDataCount | Gets the number of persistent data items stored in this parameter.
Public property | Phase | Gets or sets the solution phase this object is currenly in. (Inherited from GH_ActiveObject.)
Public property | ProcessorTime | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | ProxySourceCount | Gets the number of proxy sources for this parameter. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | Recipients | Gets a list of all the recipients of this parameter. I.e. a recipient has this parameter as one of the sources. The Recipient list is maintained by the parameter, do not modify it yourself. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | Reverse | Gets or sets the data reverse modifier of this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | RuntimeMessageLevel | Returns the worst case flag for the current object If the object contains at least 1 error, the result is Error. If the object contains at least 1 warning, the result is Warning. If the object contains at least 1 message, the result is Remark. If the object contains no errors, no warnings and no messages, the result is Blank. (Inherited from GH_ActiveObject.)
Public property | Simplify | Gets or sets the simplify modifier for this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | SourceCount | Gets the number of sources for this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | Sources | Gets a list of source parameters. Do not modify this list, if you wish to add or remove sources, use dedicated functions like AddSource() and RemoveSource() instead. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | StateTags | Gets all the StateTags that are associated with this parameter. A state tag is a visual feedback icon that represents specific internal settings. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | SubCategory | Gets or sets the SubCategory in which this object belongs. If HasSubCategory() returns false, this field has no meaning. (Inherited from GH_InstanceDescription.)
Public property | Type | Gets the Framework Type descriptor for the stored Data. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | TypeName | Calls TypeName() on the first instance of T it can find. This is either an item in the volatile list, or a newly constructed instance. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | VolatileData | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | VolatileDataCount | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | WireDisplay | Gets or sets the wire display style for this parameter. Wire display only affects the wires connected to the parameter input. (Inherited from GH_Param<(Of <(<'T>)>)>.)

Events

 | Name | Description
Public event | AttributesChanged | Raised whenever the number or kind of attributes changes. This event is handled by GH_Documents who subsequently wipe their attribute caches. (Inherited from GH_DocumentObject.)
Public event | DisplayExpired | Raised whenever the display (on the Canvas) of a certain object becomes invalid. (Inherited from GH_DocumentObject.)
Public event | ObjectChanged | (Inherited from GH_DocumentObject.)
Public event | PingDocument | Raised whenever an object needs to know which GH_Document it belongs to. (Inherited from GH_DocumentObject.)
Public event | PreviewExpired | Raised whenever the display (in the Rhino viewports) of a certain object becomes invalid. (Inherited from GH_DocumentObject.)
Public event | SolutionExpired | Raised whenever the solution of a certain object becomes invalid. (Inherited from GH_DocumentObject.)

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


GH_PersistentParam(T) Constructor

[image] [image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)> Constructor
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GH_PersistentParam<(Of <(<'T>)>)>(GH_InstanceDescription) | Initializes a new instance of the GH_PersistentParam<(Of <(<'T>)>)> class
Protected method | GH_PersistentParam<(Of <(<'T>)>)>(GH_InstanceDescription, Boolean) | Obsolete. Initializes a new instance of the GH_PersistentParam<(Of <(<'T>)>)> class
Protected method | GH_PersistentParam<(Of <(<'T>)>)>(String, String, String, String, String) | Initializes a new instance of the GH_PersistentParam<(Of <(<'T>)>)> class

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
GH_PersistentParam<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


GH_PersistentParam(T) Constructor (GH_InstanceDescription)

[image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)> Constructor (GH_InstanceDescription)
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback
Initializes a new instance of the GH_PersistentParam<(Of <(<'T>)>)> class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_PersistentParam(
    GH_InstanceDescription nTag
)
Visual Basic
Protected Sub New ( _
    nTag As GH_InstanceDescription _
)

Parameters

nTag
Type: Grasshopper.Kernel..::..GH_InstanceDescription

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
GH_PersistentParam<(Of <(<'T>)>)> Overload
Grasshopper.Kernel Namespace


GH_PersistentParam(T) Constructor (GH_InstanceDescription, Boolean)

[image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)> Constructor (GH_InstanceDescription, Boolean)
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback
Initializes a new instance of the GH_PersistentParam<(Of <(<'T>)>)> class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
[ObsoleteAttribute("This constructor is Obsolete and will be removed in future versions of Grasshopper.")]
protected GH_PersistentParam(
    GH_InstanceDescription nTag,
    bool bIsListParam
)
Visual Basic
<ObsoleteAttribute("This constructor is Obsolete and will be removed in future versions of Grasshopper.")> _
Protected Sub New ( _
    nTag As GH_InstanceDescription, _
    bIsListParam As Boolean _
)

Parameters

nTag
Type: Grasshopper.Kernel..::..GH_InstanceDescription
bIsListParam
Type: System..::..Boolean

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
GH_PersistentParam<(Of <(<'T>)>)> Overload
Grasshopper.Kernel Namespace


GH_PersistentParam(T) Constructor (String, String, String, String, String)

[image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)> Constructor (String, String, String, String, String)
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback
Initializes a new instance of the GH_PersistentParam<(Of <(<'T>)>)> class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_PersistentParam(
    string name,
    string nickname,
    string description,
    string category,
    string subcategory
)
Visual Basic
Protected Sub New ( _
    name As String, _
    nickname As String, _
    description As String, _
    category As String, _
    subcategory As String _
)

Parameters

name
Type: System..::..String
nickname
Type: System..::..String
description
Type: System..::..String
category
Type: System..::..String
subcategory
Type: System..::..String

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
GH_PersistentParam<(Of <(<'T>)>)> Overload
Grasshopper.Kernel Namespace


GH_PersistentParam(T) Fields

[image] [image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)> Fields
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback

The GH_PersistentParam<(Of <(<'T>)>)> type exposes the following members.

Fields

 | Name | Description
Protected field | m_attributes | (Inherited from GH_DocumentObject.)
Protected field | m_data | Contains the runtime data for this parameter, also known as "Volatile" data. (Inherited from GH_Param<(Of <(<'T>)>)>.)

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


GH_PersistentParam(T) Methods

[image] [image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)> Methods
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback

The GH_PersistentParam<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | AddedToDocument | This method will be called when an object is added to a document. Override this method if you want to handle such events. (Inherited from GH_DocumentObject.)
Public method | AddPersistentData(Object) | Obsolete. Utility function to add a new persistent data item. If the data is null or cannot be converted into T, this method will fail. You should probably use the PersistentData property to add type-safe data if you can.
Public method | AddPersistentData(T) | Obsolete. Utility function to add a new persistent data item. If the data is null or cannot be converted into T, this method will fail. You should probably use the PersistentData property to add type-safe data if you can.
Public method | AddRuntimeMessage | Add a new message to this object. Valid message type flags are Warning and Error. If the Message string is empty or zero-length no message is added. (Inherited from GH_ActiveObject.)
Public method | AddSource(IGH_Param) | Append a new Source parameter to the end of the Sources list. Sources provide this parameter with data at runtime. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddSource(IGH_Param, Int32) | Insert a new Source parameter into the Sources list. Sources provide this parameter with data at runtime. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddVolatileData(GH_Path, Int32, Object) | Inserts an item of volatile data into the data structure. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddVolatileDataList(GH_Path, List<(Of <<'(T>)>>)) | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddVolatileDataList(GH_Path, IEnumerable) | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddVolatileDataTree(GH_Structure<(Of <<'(T>)>>)) | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddVolatileDataTree(IGH_Structure) | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AppendAdditionalMenuItems | (Overrides GH_Param<(Of <(<'T>)>)>..::..AppendAdditionalMenuItems(ToolStripDropDown).)
Public method | AppendMenuItems | This function is called when a context menu is about to be displayed. Override it to set custom items. GH_ActiveObject will already populate the menu with default items, if you merely wish to insert object-specific menu item, consider overriding AppendAdditionalMenuItems instead. (Inherited from GH_ActiveObject.)
Protected method | Cast_Object | Attempts to convert the Object reference into an instance of T. This method will perform a direct cast if possible or it will call Casting functions on T or Data if they exist. Data will not be duplicated unless a type conversion is required. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ClearData | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ClearProxySources | Remove all proxy sources without attempting to relink them. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ClearRuntimeMessages | Destroy all warning and error lists (Inherited from GH_ActiveObject.)
Public method | CollectData | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | CollectVolatileData_Custom | (Overrides GH_Param<(Of <(<'T>)>)>..::..CollectVolatileData_Custom()()()().)
Protected method | CollectVolatileData_FromSources | This method collects volatile data from all the source parameters. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ComputeData | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | CopyFrom | Copy all fields (except the instance ID) from another instance description. (Inherited from GH_InstanceDescription.)
Public method | CreateAttributes | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | CreateProxySources | Convert all proper source parameters into proxy sources. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | DependsOn | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | DestroyIconCache | Call this method to erase the existing icon cache. You must call this if you want to change the display icon of an object. (Inherited from GH_DocumentObject.)
Public method | DocumentContextChanged | This method will be called when the document that owns this object moves into a different context. (Inherited from GH_DocumentObject.)
Protected method | ExpireDownStreamObjects | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ExpirePreview | Call this function when you suspect that the preview has expired for this object. This will cause the display cache to be eradicated. (Inherited from GH_DocumentObject.)
Public method | ExpireSolution | Informs the document that owns this object that the solution has expired. The current object will be set to BLANK as a result. This method is recursive, it will also expire any and all objects which depend on this object. If you want a less destructive expiration, consider using ClearData(). If this object is already Blank, you should consider not expiring it. (Inherited from GH_ActiveObject.)
Protected method | Format | Returns "Null" if the data is a null reference, otherwise calls ToString() on the Data instance. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | GetValue(String, Boolean) | Get a boolean value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Double) | Get a double value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Color) | Get a color value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Int32) | Get an integer value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, String) | Get a string value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | HtmlHelp_Source | Return a String which contains HTML formatted source for the help topic. If you want to pass a URL that points to a remote page, then prefix the URL with a GOTO: tag, like so: GOTO:http://www.YourWebAddressHere.com (Inherited from GH_DocumentObject.)
Protected method | InstantiateT | Attempts to instantiate a new instance of T. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | IsolateObject | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendBakeItem | Append the default Bake menu item. (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendDestroyPersistent |
Protected method | Menu_AppendDisconnectWires | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendEnableItem | Append the default Enable/Disable menu item. (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendExtractParameter |
Protected method | Menu_AppendFlattenParameter | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendGraftParameter | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendInternaliseData |
Protected method | Menu_AppendManageCollection |
Protected method | Menu_AppendObjectHelp | Appends the default object Help menu item. (Inherited from GH_DocumentObject.)
Protected method | Menu_AppendObjectName | Appends the old-fashioned object name menu item. If you also want the Display mode toggle then use Menu_AppendObjectNameEx() (Inherited from GH_DocumentObject.)
Protected method | Menu_AppendObjectNameEx | Appends the default object name + display mode menu item. (Inherited from GH_DocumentObject.)
Protected method | Menu_AppendPreviewItem | Append the default Show/Hide preview menu item. (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendPrincipalParameter | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendPromptMore |
Protected method | Menu_AppendPromptOne |
Protected method | Menu_AppendReverseParameter | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendRuntimeMessages | Append the default warnings and errors menu items. (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendSimplifyParameter | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendWarningsAndErrors | Obsolete. This method is obsolete and has been replaced with Menu_AppendRuntimeMessages(). (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendWireDisplay | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_CreateMultilineTextEditItem | This function returns a ToolstripMenuItem that embeds a multi-line textbox for editing persistent data. Only call this method if you know that your parameter type supports proxies.
Protected method | Menu_CustomMultiValueItem |
Protected method | Menu_CustomSingleValueItem |
Public method | MovedBetweenDocuments | This method will be called when an object is moved from one document to another. Override this method if you want to handle such events. (Inherited from GH_DocumentObject.)
Public method | NewInstanceGuid()()()() | Generate a new random instance GUID (Inherited from GH_InstanceDescription.)
Public method | NewInstanceGuid(Guid) | Set the instance ID to be a specific GUID. This is very dangerous, only use this function if you're 6"4' and your first name is David. (Inherited from GH_InstanceDescription.)
Public method | OnAttributesChanged | Raises the AttributesChanged event on the toplevel object. (Inherited from GH_DocumentObject.)
Public method | OnDisplayExpired | Raises the DisplayExpired event on the toplevel object. (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(String) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectChangedEventArgs) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(String, Object) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType, Object) | (Inherited from GH_DocumentObject.)
Public method | OnPingDocument | Raise the PingDocument Event on the toplevel object and try to find the document which owns this object. (Inherited from GH_DocumentObject.)
Public method | OnPreviewExpired | Raises the PreviewExpired event on the toplevel object. (Inherited from GH_DocumentObject.)
Public method | OnSolutionExpired | Raises the SolutionExpired event on the toplevel object. You probably want to call ExpireSolution() instead of this method directly. (Inherited from GH_DocumentObject.)
Protected method | OnVolatileDataCollected | Once volatile data has been collected this method will be calles. The basic implementation does nothing, but you can add code here to post-process or analyze the volatile data. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | PreferredCast | Implement this function if you're certain that you'll be confronted with very common casts. For example, GH_Point has a preferred cast from Rhino.Geometry.Point3d and GH_Number has a preferred cast from System.Double. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | PrepareForPrompt |
Protected method | Preview_ComputeClippingBox | This function can be used to iterate over all items in the Volatile data tree and collect the union clipping box of all non-null items that implement Preview.IGH_PreviewData. This function requires a lot of TypeOf and DirectCasting, so if you're worried about performance you should consider doing this yourself. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Preview_DrawMeshes | This function can be used to iterate over all items in the Volatile data tree and call DrawViewportWires on each item that implements Preview.IGH_PreviewData. This function requires a lot of TypeOf and DirectCasting, so if you're worried about performance you should consider doing this yourself. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Preview_DrawWires | This function can be used to iterate over all items in the Volatile data tree and call DrawViewportWires on each item that implements Preview.IGH_PreviewData. This function requires a lot of TypeOf and DirectCasting, so if you're worried about performance you should consider doing this yourself. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Prompt_ManageCollection |
Protected method | Prompt_Plural |
Protected method | Prompt_Singular |
Public method | Read | (Overrides GH_Param<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ReadFull | GH_InstanceDescription does not by default serialize all fields. Use this function to read all fields from the archive. This method is compatible with the default Write()/Read() operations. (Inherited from GH_InstanceDescription.)
Protected method | RecordPersistentDataEvent | Add an undo record that stores changes to persistent data.
Public method | RecordUndoEvent(String) | Record a generic object change undo event. (Inherited from GH_DocumentObject.)
Public method | RecordUndoEvent(GH_UndoRecord) | Record an entire undo record. (Inherited from GH_DocumentObject.)
Public method | RecordUndoEvent(String, IGH_UndoAction) | Record a specific object change undo event. (Inherited from GH_DocumentObject.)
Protected method | RecoverFromPrompt |
Public method | RegisterRemoteIDs | Override this function if you want object changes in the Rhino document to trigger a new solution. (Inherited from GH_ActiveObject.)
Protected method | RegisterRemoteIDsUtil | Utility function which treats all data in the Volatile cache as IGH_GeometricGoo and registers all referenced objects. Call this function from within RegisterRemoteIDs() if you are absolutely sure that all the items in volatiledata implement IGH_GeometricGoo. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | RelinkProxySources | Attempt to replace all proxy sources with real sources. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | RemoveAllSources | Remove all sources from this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | RemovedFromDocument | This method will be called when an object is removed from a document. Override this method if you want to handle such events. (Inherited from GH_DocumentObject.)
Public method | RemoveEffects | Remove all post-process effects. Note to implementors, you must call the base method if you override this function. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | RemoveSource(Guid) | Remove the specified source from this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | RemoveSource(IGH_Param) | Remove the specified source from this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ReplaceSource(Guid, IGH_Param) | Replace an existing source with a new one. If the old_source does not exist in this parameter, nothing happens. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ReplaceSource(IGH_Param, IGH_Param) | Replace an existing source with a new one. If the old_source does not exist in this parameter, nothing happens. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | RuntimeMessages | Gets the list of cached runtime messages that were recorded during solver-time processes. (Inherited from GH_ActiveObject.)
Public method | Script_AddPersistentData | Method used primarily for COM_Access code.
Public method | Script_ClearPersistentData | Method used primarily for COM_Access code.
Public method | SDKCompliancy | Test whether this object is compliant with a given Rhino version. (Inherited from GH_ActiveObject.)
Public method | SetIconOverride | Set a new custom icon override for this object. (Inherited from GH_DocumentObject.)
Public method | SetPersistentData(IEnumerable<(Of <<'(T>)>>)) | Assign a list of items to the persistent data. This method will erase any existing data, record an undo event, raise the OnObjectChanged event for PersistentData flags and place a call to ExpireSolution(False). If you want to add a tree of data, you should use the appropriate overload for this method.
Public method | SetPersistentData(array<Object>[]()[][]) | Add a collection of values to the persistent data.
Public method | SetPersistentData(T) | Add a single item to the persistent data. This method will record an undo event, raise the OnObjectChanged event for PersistentData flags and place a call to ExpireSolution(False). If you want to add more than one piece of data, you should use the appropriate overload for this method.
Public method | SetPersistentData(GH_Structure<(Of <<'(T>)>>)) | Assign a tree of items to the persistent data. This method will erase any existing data, record an undo event, raise the OnObjectChanged event for PersistentData flags and place a call to ExpireSolution(False). If you want to add a tree of data, you should use the appropriate overload for this method.
Public method | SetPrincipal | Set the principal parameter state. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | SetValue(String, Boolean) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Double) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Color) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Int32) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, String) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave()()()() | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(Guid) | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger, Guid) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from GH_DocumentObject.)
Protected method | ValuesChanged | Override this method if you want to respond to changes to the value table. The base implementation is empty, so you don't have to call it. (Inherited from GH_DocumentObject.)
Protected method | VolatileDataDescription | This method is called to populate the Tooltip data description field. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | Write | (Overrides GH_Param<(Of <(<'T>)>)>..::..Write(GH_IWriter).)
Public method | WriteFull | GH_InstanceDescription does not by default serialize all fields. Use this function to write all fields to the archive. This method is compatible with the default Write()/Read() operations. (Inherited from GH_InstanceDescription.)

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


AddPersistentData Method

[image] [image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..AddPersistentData Method
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddPersistentData(Object) | Obsolete. Utility function to add a new persistent data item. If the data is null or cannot be converted into T, this method will fail. You should probably use the PersistentData property to add type-safe data if you can.
Public method | AddPersistentData(T) | Obsolete. Utility function to add a new persistent data item. If the data is null or cannot be converted into T, this method will fail. You should probably use the PersistentData property to add type-safe data if you can.

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
GH_PersistentParam<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


AddPersistentData Method (Object)

[image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..AddPersistentData Method (Object)
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback
Utility function to add a new persistent data item. If the data is null or cannot be converted into T, this method will fail. You should probably use the PersistentData property to add type-safe data if you can.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
[ObsoleteAttribute("This method has been superceded by SetPersistenData overloads")]
public bool AddPersistentData(
    Object data
)
Visual Basic
<ObsoleteAttribute("This method has been superceded by SetPersistenData overloads")> _
Public Function AddPersistentData ( _
    data As Object _
) As Boolean

Parameters

data
Type: System..::..Object
Data to add.

Return Value

True on success, false on failure.

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
AddPersistentData Overload
Grasshopper.Kernel Namespace


AddPersistentData Method (T)

[image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..AddPersistentData Method (T)
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback
Utility function to add a new persistent data item. If the data is null or cannot be converted into T, this method will fail. You should probably use the PersistentData property to add type-safe data if you can.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
[ObsoleteAttribute("This method has been superceded by SetPersistenData overloads")]
public bool AddPersistentData(
    T data
)
Visual Basic
<ObsoleteAttribute("This method has been superceded by SetPersistenData overloads")> _
Public Function AddPersistentData ( _
    data As T _
) As Boolean

Parameters

data
Type: T
Data to add.

Return Value

True on success, false on failure.

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
AddPersistentData Overload
Grasshopper.Kernel Namespace


AddSource Method

[image] [image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..AddSource Method
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddSource(IGH_Param) | Append a new Source parameter to the end of the Sources list. Sources provide this parameter with data at runtime. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddSource(IGH_Param, Int32) | Insert a new Source parameter into the Sources list. Sources provide this parameter with data at runtime. (Inherited from GH_Param<(Of <(<'T>)>)>.)

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
GH_PersistentParam<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


AddVolatileDataList Method

[image] [image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..AddVolatileDataList Method
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddVolatileDataList(GH_Path, List<(Of <<'(T>)>>)) | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddVolatileDataList(GH_Path, IEnumerable) | (Inherited from GH_Param<(Of <(<'T>)>)>.)

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
GH_PersistentParam<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


AddVolatileDataTree Method

[image] [image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..AddVolatileDataTree Method
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddVolatileDataTree(GH_Structure<(Of <<'(T>)>>)) | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddVolatileDataTree(IGH_Structure) | (Inherited from GH_Param<(Of <(<'T>)>)>.)

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
GH_PersistentParam<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


AppendAdditionalMenuItems Method

[image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..AppendAdditionalMenuItems Method
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void AppendAdditionalMenuItems(
    ToolStripDropDown menu
)
Visual Basic
Public Overrides Sub AppendAdditionalMenuItems ( _
    menu As ToolStripDropDown _
)

Parameters

menu
Type: System.Windows.Forms..::..ToolStripDropDown

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


CollectVolatileData_Custom Method

[image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..CollectVolatileData_Custom Method
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override sealed void CollectVolatileData_Custom()
Visual Basic
Protected Overrides NotOverridable Sub CollectVolatileData_Custom

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


GetValue Method

[image] [image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..GetValue Method
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetValue(String, Boolean) | Get a boolean value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Double) | Get a double value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Color) | Get a color value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Int32) | Get an integer value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, String) | Get a string value from the component value table. (Inherited from GH_DocumentObject.)

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
GH_PersistentParam<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


Menu_AppendDestroyPersistent Method

[image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..Menu_AppendDestroyPersistent Method
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected virtual void Menu_AppendDestroyPersistent(
    ToolStripDropDown menu
)
Visual Basic
Protected Overridable Sub Menu_AppendDestroyPersistent ( _
    menu As ToolStripDropDown _
)

Parameters

menu
Type: System.Windows.Forms..::..ToolStripDropDown

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Menu_AppendExtractParameter Method

[image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..Menu_AppendExtractParameter Method
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected virtual void Menu_AppendExtractParameter(
    ToolStripDropDown menu
)
Visual Basic
Protected Overridable Sub Menu_AppendExtractParameter ( _
    menu As ToolStripDropDown _
)

Parameters

menu
Type: System.Windows.Forms..::..ToolStripDropDown

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Menu_AppendInternaliseData Method

[image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..Menu_AppendInternaliseData Method
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected virtual void Menu_AppendInternaliseData(
    ToolStripDropDown menu
)
Visual Basic
Protected Overridable Sub Menu_AppendInternaliseData ( _
    menu As ToolStripDropDown _
)

Parameters

menu
Type: System.Windows.Forms..::..ToolStripDropDown

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Menu_AppendManageCollection Method

[image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..Menu_AppendManageCollection Method
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected virtual void Menu_AppendManageCollection(
    ToolStripDropDown menu
)
Visual Basic
Protected Overridable Sub Menu_AppendManageCollection ( _
    menu As ToolStripDropDown _
)

Parameters

menu
Type: System.Windows.Forms..::..ToolStripDropDown

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Menu_AppendPromptMore Method

[image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..Menu_AppendPromptMore Method
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected virtual void Menu_AppendPromptMore(
    ToolStripDropDown menu
)
Visual Basic
Protected Overridable Sub Menu_AppendPromptMore ( _
    menu As ToolStripDropDown _
)

Parameters

menu
Type: System.Windows.Forms..::..ToolStripDropDown

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Menu_AppendPromptOne Method

[image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..Menu_AppendPromptOne Method
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected virtual void Menu_AppendPromptOne(
    ToolStripDropDown menu
)
Visual Basic
Protected Overridable Sub Menu_AppendPromptOne ( _
    menu As ToolStripDropDown _
)

Parameters

menu
Type: System.Windows.Forms..::..ToolStripDropDown

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Menu_CreateMultilineTextEditItem Method

[image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..Menu_CreateMultilineTextEditItem Method
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback
This function returns a ToolstripMenuItem that embeds a multi-line textbox for editing persistent data. Only call this method if you know that your parameter type supports proxies.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected ToolStripMenuItem Menu_CreateMultilineTextEditItem()
Visual Basic
Protected Function Menu_CreateMultilineTextEditItem As ToolStripMenuItem

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Menu_CustomMultiValueItem Method

[image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..Menu_CustomMultiValueItem Method
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected virtual ToolStripMenuItem Menu_CustomMultiValueItem()
Visual Basic
Protected Overridable Function Menu_CustomMultiValueItem As ToolStripMenuItem

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Menu_CustomSingleValueItem Method

[image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..Menu_CustomSingleValueItem Method
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected virtual ToolStripMenuItem Menu_CustomSingleValueItem()
Visual Basic
Protected Overridable Function Menu_CustomSingleValueItem As ToolStripMenuItem

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


NewInstanceGuid Method

[image] [image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..NewInstanceGuid Method
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NewInstanceGuid()()()() | Generate a new random instance GUID (Inherited from GH_InstanceDescription.)
Public method | NewInstanceGuid(Guid) | Set the instance ID to be a specific GUID. This is very dangerous, only use this function if you're 6"4' and your first name is David. (Inherited from GH_InstanceDescription.)

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
GH_PersistentParam<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


OnObjectChanged Method

[image] [image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..OnObjectChanged Method
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OnObjectChanged(String) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectChangedEventArgs) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(String, Object) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType, Object) | (Inherited from GH_DocumentObject.)

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
GH_PersistentParam<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


PrepareForPrompt Method

[image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..PrepareForPrompt Method
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected virtual void PrepareForPrompt()
Visual Basic
Protected Overridable Sub PrepareForPrompt

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Prompt_ManageCollection Method

[image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..Prompt_ManageCollection Method
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected virtual bool Prompt_ManageCollection(
    GH_Structure<T> values
)
Visual Basic
Protected Overridable Function Prompt_ManageCollection ( _
    values As GH_Structure(Of T) _
) As Boolean

Parameters

values
Type: Grasshopper.Kernel.Data..::..GH_Structure <(Of <(<' T >)>)>

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Prompt_Plural Method

[image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..Prompt_Plural Method
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected abstract GH_GetterResult Prompt_Plural(
    ref List<T> values
)
Visual Basic
Protected MustOverride Function Prompt_Plural ( _
    ByRef values As List(Of T) _
) As GH_GetterResult

Parameters

values
Type: System.Collections.Generic..::..List <(Of <(<' T >)>)>%

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Prompt_Singular Method

[image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..Prompt_Singular Method
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected abstract GH_GetterResult Prompt_Singular(
    ref T value
)
Visual Basic
Protected MustOverride Function Prompt_Singular ( _
    ByRef value As T _
) As GH_GetterResult

Parameters

value
Type: T %

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Read Method

[image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..Read Method
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


RecordPersistentDataEvent Method

[image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..RecordPersistentDataEvent Method
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback
Add an undo record that stores changes to persistent data.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected void RecordPersistentDataEvent(
    string name
)
Visual Basic
Protected Sub RecordPersistentDataEvent ( _
    name As String _
)

Parameters

name
Type: System..::..String
Name of undo record.

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


RecordUndoEvent Method

[image] [image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..RecordUndoEvent Method
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RecordUndoEvent(String) | Record a generic object change undo event. (Inherited from GH_DocumentObject.)
Public method | RecordUndoEvent(GH_UndoRecord) | Record an entire undo record. (Inherited from GH_DocumentObject.)
Public method | RecordUndoEvent(String, IGH_UndoAction) | Record a specific object change undo event. (Inherited from GH_DocumentObject.)

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
GH_PersistentParam<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


RecoverFromPrompt Method

[image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..RecoverFromPrompt Method
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected virtual void RecoverFromPrompt()
Visual Basic
Protected Overridable Sub RecoverFromPrompt

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


RemoveSource Method

[image] [image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..RemoveSource Method
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveSource(Guid) | Remove the specified source from this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | RemoveSource(IGH_Param) | Remove the specified source from this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
GH_PersistentParam<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


ReplaceSource Method

[image] [image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..ReplaceSource Method
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReplaceSource(Guid, IGH_Param) | Replace an existing source with a new one. If the old_source does not exist in this parameter, nothing happens. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ReplaceSource(IGH_Param, IGH_Param) | Replace an existing source with a new one. If the old_source does not exist in this parameter, nothing happens. (Inherited from GH_Param<(Of <(<'T>)>)>.)

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
GH_PersistentParam<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


Script_AddPersistentData Method

[image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..Script_AddPersistentData Method
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback
Method used primarily for COM_Access code.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Script_AddPersistentData(
    List<Object> data
)
Visual Basic
Public Sub Script_AddPersistentData ( _
    data As List(Of Object) _
)

Parameters

data
Type: System.Collections.Generic..::..List <(Of <(<' Object >)>)>

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Script_ClearPersistentData Method

[image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..Script_ClearPersistentData Method
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback
Method used primarily for COM_Access code.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Script_ClearPersistentData()
Visual Basic
Public Sub Script_ClearPersistentData

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


SetPersistentData Method

[image] [image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..SetPersistentData Method
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetPersistentData(IEnumerable<(Of <<'(T>)>>)) | Assign a list of items to the persistent data. This method will erase any existing data, record an undo event, raise the OnObjectChanged event for PersistentData flags and place a call to ExpireSolution(False). If you want to add a tree of data, you should use the appropriate overload for this method.
Public method | SetPersistentData(array<Object>[]()[][]) | Add a collection of values to the persistent data.
Public method | SetPersistentData(T) | Add a single item to the persistent data. This method will record an undo event, raise the OnObjectChanged event for PersistentData flags and place a call to ExpireSolution(False). If you want to add more than one piece of data, you should use the appropriate overload for this method.
Public method | SetPersistentData(GH_Structure<(Of <<'(T>)>>)) | Assign a tree of items to the persistent data. This method will erase any existing data, record an undo event, raise the OnObjectChanged event for PersistentData flags and place a call to ExpireSolution(False). If you want to add a tree of data, you should use the appropriate overload for this method.

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
GH_PersistentParam<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


SetPersistentData Method (IEnumerable(T))

[image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..SetPersistentData Method (IEnumerable<(Of <(<'T>)>)>)
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback
Assign a list of items to the persistent data. This method will erase any existing data, record an undo event, raise the OnObjectChanged event for PersistentData flags and place a call to ExpireSolution(False). If you want to add a tree of data, you should use the appropriate overload for this method.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SetPersistentData(
    IEnumerable<T> items
)
Visual Basic
Public Sub SetPersistentData ( _
    items As IEnumerable(Of T) _
)

Parameters

items
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' T >)>)>
Items to add.

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
SetPersistentData Overload
Grasshopper.Kernel Namespace


SetPersistentData Method (Object[])

[image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..SetPersistentData Method (array<Object>[]()[][])
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback
Add a collection of values to the persistent data.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SetPersistentData(
    params Object[] values
)
Visual Basic
Public Sub SetPersistentData ( _
    ParamArray values As Object() _
)

Parameters

values
Type: array< System..::..Object >[]()[][]
Values to add.

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
SetPersistentData Overload
Grasshopper.Kernel Namespace


SetPersistentData Method (T)

[image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..SetPersistentData Method (T)
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback
Add a single item to the persistent data. This method will record an undo event, raise the OnObjectChanged event for PersistentData flags and place a call to ExpireSolution(False). If you want to add more than one piece of data, you should use the appropriate overload for this method.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SetPersistentData(
    T item
)
Visual Basic
Public Sub SetPersistentData ( _
    item As T _
)

Parameters

item
Type: T
Item to add.

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
SetPersistentData Overload
Grasshopper.Kernel Namespace


SetPersistentData Method (GH_Structure(T))

[image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..SetPersistentData Method (GH_Structure<(Of <(<'T>)>)>)
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback
Assign a tree of items to the persistent data. This method will erase any existing data, record an undo event, raise the OnObjectChanged event for PersistentData flags and place a call to ExpireSolution(False). If you want to add a tree of data, you should use the appropriate overload for this method.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SetPersistentData(
    GH_Structure<T> items
)
Visual Basic
Public Sub SetPersistentData ( _
    items As GH_Structure(Of T) _
)

Parameters

items
Type: Grasshopper.Kernel.Data..::..GH_Structure <(Of <(<' T >)>)>
Items to add.

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
SetPersistentData Overload
Grasshopper.Kernel Namespace


SetValue Method

[image] [image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..SetValue Method
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SetValue(String, Boolean) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Double) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Color) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Int32) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, String) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
GH_PersistentParam<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


TriggerAutoSave Method

[image] [image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..TriggerAutoSave Method
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TriggerAutoSave()()()() | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(Guid) | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger, Guid) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from GH_DocumentObject.)

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
GH_PersistentParam<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


Write Method

[image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..Write Method
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overrides Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


GH_PersistentParam(T) Properties

[image] [image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)> Properties
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback

The GH_PersistentParam<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Access | Gets or sets the Access level for this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | Attributes | Gets or sets the attributes that are associated with this object. Only set custom attributes if you know what you are doing. (Inherited from GH_DocumentObject.)
Public property | Category | Gets or sets the Category in which this object belongs. If HasCategory() returns false, this field has no meaning. (Inherited from GH_InstanceDescription.)
Public property | ComponentGuid | Returns a consistent ID for this object type. Every object must supply a unique and unchanging ID that is used to identify objects of the same type. (Inherited from GH_DocumentObject.)
Public property | DataMapping | Gets or sets the data mapping of this Parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | DataType | Gets the type of data stored in this parameter. (Overrides GH_Param<(Of <(<'T>)>)>..::..DataType.)
Public property | Description | Gets or sets the description of the object. This field typically remains fixed during the lifetime of an object. (Inherited from GH_InstanceDescription.)
Public property | Exposure | Gets the exposure of this object in the Graphical User Interface. The default is to expose everywhere. (Inherited from GH_DocumentObject.)
Public property | HasCategory | Gets whether or not the Category field has been set. (Inherited from GH_InstanceDescription.)
Public property | HasProxySources | Gets a value indicating whether or not this parameter maintains proxy sources. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | HasSubCategory | Gets whether or not the SubCategory field has been set. (Inherited from GH_InstanceDescription.)
Protected property | Icon | Override this function to supply a custom icon (24x24 pixels). The result of this property is cached, so don't worry if icon retrieval is not very fast. (Inherited from GH_DocumentObject.)
Public property | Icon_24x24 | The icon associated with this object. (Inherited from GH_DocumentObject.)
Public property | Icon_24x24_Locked | The greyscale icon of this object. (Inherited from GH_DocumentObject.)
Public property | IconCapableUI | By default the NickName menu item supports the Icon Mode override toggle. If your UI is not capable of displaying icons, then override this property and return False. (Inherited from GH_ActiveObject.)
Public property | IconDisplayMode | Gets the current display mode of the object. (Inherited from GH_DocumentObject.)
Public property | InstanceDescription | Gets the description of this instance. The default description is about the amount and source of the local values. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | InstanceGuid | Gets the ID of this runtime instance. (Inherited from GH_InstanceDescription.)
Public property | IsDataProvider | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | IsPrincipal | Gets whether this parameter is a principal parameter. Principal parameters are maintained by components and are not part of the IGH_Param interface. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | Keywords | Gets a list of additional keywords that describe the object. Typically this list is empty but you can override this property to aid in object searches. (Inherited from GH_InstanceDescription.)
Public property | Kind | Gets the parameter kind. The kind is evaluated lazily and cached. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | Locked | Gets or sets the enabled flag of this object. Disabled objects are ignored during solutions. (Inherited from GH_ActiveObject.)
Public property | MutableNickName | Gets or sets a value that enables Nick name changes through the menu. The default is TRUE. (Inherited from GH_ActiveObject.)
Public property | Name | Gets or sets the name of the object. This field typically remains fixed during the lifetime of an object. (Inherited from GH_InstanceDescription.)
Public property | NickName | Gets or sets the nickname of the object. This field can be changed by the user. (Inherited from GH_InstanceDescription.)
Public property | Obsolete | Gets whether this object is obsolete. Default implementation returns true if the class name contains the string "OBSOLETE" or if this class has been decorated with the ObsoleteAttribute. You are free to override this if you want, but I suggest adding the ObsoleteAttribute instead. (Inherited from GH_DocumentObject.)
Public property | Optional | Gets or sets whether or not this parameter is considered optional by the owner component. Empty, non-optional parameters prevent the component from being solved. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | PersistentData | Gets the persistent data stored in this parameter. If you modify the persistent data, be sure to call the: OnObjectChanged(GH_ObjectEventType.PersistentData) event.
Public property | PersistentDataCount | Gets the number of persistent data items stored in this parameter.
Public property | Phase | Gets or sets the solution phase this object is currenly in. (Inherited from GH_ActiveObject.)
Public property | ProcessorTime | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | ProxySourceCount | Gets the number of proxy sources for this parameter. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | Recipients | Gets a list of all the recipients of this parameter. I.e. a recipient has this parameter as one of the sources. The Recipient list is maintained by the parameter, do not modify it yourself. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | Reverse | Gets or sets the data reverse modifier of this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | RuntimeMessageLevel | Returns the worst case flag for the current object If the object contains at least 1 error, the result is Error. If the object contains at least 1 warning, the result is Warning. If the object contains at least 1 message, the result is Remark. If the object contains no errors, no warnings and no messages, the result is Blank. (Inherited from GH_ActiveObject.)
Public property | Simplify | Gets or sets the simplify modifier for this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | SourceCount | Gets the number of sources for this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | Sources | Gets a list of source parameters. Do not modify this list, if you wish to add or remove sources, use dedicated functions like AddSource() and RemoveSource() instead. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | StateTags | Gets all the StateTags that are associated with this parameter. A state tag is a visual feedback icon that represents specific internal settings. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | SubCategory | Gets or sets the SubCategory in which this object belongs. If HasSubCategory() returns false, this field has no meaning. (Inherited from GH_InstanceDescription.)
Public property | Type | Gets the Framework Type descriptor for the stored Data. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | TypeName | Calls TypeName() on the first instance of T it can find. This is either an item in the volatile list, or a newly constructed instance. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | VolatileData | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | VolatileDataCount | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | WireDisplay | Gets or sets the wire display style for this parameter. Wire display only affects the wires connected to the parameter input. (Inherited from GH_Param<(Of <(<'T>)>)>.)

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


DataType Property

[image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..DataType Property
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the type of data stored in this parameter.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override sealed GH_ParamData DataType { get; }
Visual Basic
Public Overrides NotOverridable ReadOnly Property DataType As GH_ParamData
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_PersistentParam`1.DataType"]

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


PersistentData Property

[image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..PersistentData Property
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the persistent data stored in this parameter. If you modify the persistent data, be sure to call the: OnObjectChanged(GH_ObjectEventType.PersistentData) event.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Structure<T> PersistentData { get; }
Visual Basic
Public ReadOnly Property PersistentData As GH_Structure(Of T)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_PersistentParam`1.PersistentData"]

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


PersistentDataCount Property

[image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)>..::..PersistentDataCount Property
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the number of persistent data items stored in this parameter.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int PersistentDataCount { get; }
Visual Basic
Public ReadOnly Property PersistentDataCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_PersistentParam`1.PersistentDataCount"]

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


GH_PersistentParam(T) Events

[image] [image]

Grasshopper SDK
GH_PersistentParam<(Of <(<'T>)>)> Events
GH_PersistentParam<(Of <(<'T>)>)> Class See Also Send Feedback

The GH_PersistentParam<(Of <(<'T>)>)> type exposes the following members.

Events

 | Name | Description
Public event | AttributesChanged | Raised whenever the number or kind of attributes changes. This event is handled by GH_Documents who subsequently wipe their attribute caches. (Inherited from GH_DocumentObject.)
Public event | DisplayExpired | Raised whenever the display (on the Canvas) of a certain object becomes invalid. (Inherited from GH_DocumentObject.)
Public event | ObjectChanged | (Inherited from GH_DocumentObject.)
Public event | PingDocument | Raised whenever an object needs to know which GH_Document it belongs to. (Inherited from GH_DocumentObject.)
Public event | PreviewExpired | Raised whenever the display (in the Rhino viewports) of a certain object becomes invalid. (Inherited from GH_DocumentObject.)
Public event | SolutionExpired | Raised whenever the solution of a certain object becomes invalid. (Inherited from GH_DocumentObject.)

See Also

GH_PersistentParam<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


GH_PickBox Enumeration

[image]

Grasshopper SDK
GH_PickBox Enumeration
See Also Send Feedback
Represents the different ways in which picking rectangles can behave.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_PickBox
Visual Basic
Public Enumeration GH_PickBox

Members

Member name | Value | Description
Window | 0 | The picking box must completely surround the object box.
Crossing | 1 | The picking box must only partially intersect the object box.

See Also

Grasshopper.Kernel Namespace


GH_PingDocumentEventArgs Class

[image]

Grasshopper SDK
GH_PingDocumentEventArgs Class
Members See Also Send Feedback
Event arguments passed during PingDocument events.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_PingDocumentEventArgs : EventArgs
Visual Basic
Public Class GH_PingDocumentEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Grasshopper.Kernel..::..GH_PingDocumentEventArgs

See Also

GH_PingDocumentEventArgs Members
Grasshopper.Kernel Namespace


GH_PingDocumentEventArgs Members

[image] [image]

Grasshopper SDK
GH_PingDocumentEventArgs Members
GH_PingDocumentEventArgs Class Constructors Fields Properties See Also Send Feedback

The GH_PingDocumentEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GH_PingDocumentEventArgs | Initializes a new instance of the GH_PingDocumentEventArgs class

Fields

 | Name | Description
Protected field | m_document |

Properties

 | Name | Description
Public property | Document | If you're a GH_Document that owns this object, you must fill out this field. This is the only way for objects to know which document they belong to.

See Also

GH_PingDocumentEventArgs Class
Grasshopper.Kernel Namespace


GH_PingDocumentEventArgs Constructor

[image]

Grasshopper SDK
GH_PingDocumentEventArgs Constructor
GH_PingDocumentEventArgs Class See Also Send Feedback
Initializes a new instance of the GH_PingDocumentEventArgs class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PingDocumentEventArgs()
Visual Basic
Public Sub New

See Also

GH_PingDocumentEventArgs Class
Grasshopper.Kernel Namespace


GH_PingDocumentEventArgs Fields

[image] [image]

Grasshopper SDK
GH_PingDocumentEventArgs Fields
GH_PingDocumentEventArgs Class See Also Send Feedback

The GH_PingDocumentEventArgs type exposes the following members.

Fields

 | Name | Description
Protected field | m_document |

See Also

GH_PingDocumentEventArgs Class
Grasshopper.Kernel Namespace


m_document Field

[image]

Grasshopper SDK
GH_PingDocumentEventArgs..::..m_document Field
GH_PingDocumentEventArgs Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Document m_document
Visual Basic
Protected m_document As GH_Document

See Also

GH_PingDocumentEventArgs Class
Grasshopper.Kernel Namespace


GH_PingDocumentEventArgs Properties

[image] [image]

Grasshopper SDK
GH_PingDocumentEventArgs Properties
GH_PingDocumentEventArgs Class See Also Send Feedback

The GH_PingDocumentEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Document | If you're a GH_Document that owns this object, you must fill out this field. This is the only way for objects to know which document they belong to.

See Also

GH_PingDocumentEventArgs Class
Grasshopper.Kernel Namespace


Document Property

[image]

Grasshopper SDK
GH_PingDocumentEventArgs..::..Document Property
GH_PingDocumentEventArgs Class See Also Send Feedback
If you're a GH_Document that owns this object, you must fill out this field. This is the only way for objects to know which document they belong to.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Document Document { get; set; }
Visual Basic
Public Property Document As GH_Document
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_PingDocumentEventArgs.Document"]

See Also

GH_PingDocumentEventArgs Class
Grasshopper.Kernel Namespace


GH_PluginFolderType Enumeration

[image]

Grasshopper SDK
GH_PluginFolderType Enumeration
See Also Send Feedback
Enumerates the possible folder types for GH_AssemblyFolderInfo

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_PluginFolderType
Visual Basic
Public Enumeration GH_PluginFolderType

Members

Member name | Value | Description
Core | 0 | The Core folder is the one where native Grasshopper GHA files are installed.
Default | 1 | The Default folder is where Grasshopper puts 3rd party GHA files.
RhiFolder | 2 | A RhiFolder folder is created by an RHI installer package.
UserFolder | 3 | A UserFolder is created by the user via the _GrasshopperDeveloperSettings command.

See Also

Grasshopper.Kernel Namespace


GH_PreviewArgs Class

[image]

Grasshopper SDK
GH_PreviewArgs Class
Members See Also Send Feedback
This class is passed to Objects that implement IGH_PreviewObject during drawing operations.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_PreviewArgs : IGH_PreviewArgs
Visual Basic
Public Class GH_PreviewArgs _
    Implements IGH_PreviewArgs

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_PreviewArgs

See Also

GH_PreviewArgs Members
Grasshopper.Kernel Namespace


GH_PreviewArgs Members

[image] [image]

Grasshopper SDK
GH_PreviewArgs Members
GH_PreviewArgs Class Properties See Also Send Feedback

The GH_PreviewArgs type exposes the following members.

Properties

 | Name | Description
Public property | DefaultCurveThickness | Gets the curve thickness as defined by the viewport display scheme.
Public property | Display | Gets the Pipeline that is being used to draw the current preview.
Public property | Document | Gets the Grasshopper document that is currently drawing the preview.
Public property | MeshingParameters | Gets the meshing parameters to be used during meshing breps.
Public property | ShadeMaterial | Gets the document default material for unselected Faces.
Public property | ShadeMaterial_Selected | Gets the document default material for selected Faces.
Public property | Viewport | Gets the Viewport in which the current preview is drawn.
Public property | WireColour | Gets the document default colour for unselected Wires.
Public property | WireColour_Selected | Gets the document default colour for selected Wires.

See Also

GH_PreviewArgs Class
Grasshopper.Kernel Namespace


GH_PreviewArgs Properties

[image] [image]

Grasshopper SDK
GH_PreviewArgs Properties
GH_PreviewArgs Class See Also Send Feedback

The GH_PreviewArgs type exposes the following members.

Properties

 | Name | Description
Public property | DefaultCurveThickness | Gets the curve thickness as defined by the viewport display scheme.
Public property | Display | Gets the Pipeline that is being used to draw the current preview.
Public property | Document | Gets the Grasshopper document that is currently drawing the preview.
Public property | MeshingParameters | Gets the meshing parameters to be used during meshing breps.
Public property | ShadeMaterial | Gets the document default material for unselected Faces.
Public property | ShadeMaterial_Selected | Gets the document default material for selected Faces.
Public property | Viewport | Gets the Viewport in which the current preview is drawn.
Public property | WireColour | Gets the document default colour for unselected Wires.
Public property | WireColour_Selected | Gets the document default colour for selected Wires.

See Also

GH_PreviewArgs Class
Grasshopper.Kernel Namespace


DefaultCurveThickness Property

[image]

Grasshopper SDK
GH_PreviewArgs..::..DefaultCurveThickness Property
GH_PreviewArgs Class See Also Send Feedback
Gets the curve thickness as defined by the viewport display scheme.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int DefaultCurveThickness { get; }
Visual Basic
Public ReadOnly Property DefaultCurveThickness As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_PreviewArgs.DefaultCurveThickness"]

Implements

IGH_PreviewArgs..::..DefaultCurveThickness

See Also

GH_PreviewArgs Class
Grasshopper.Kernel Namespace


Display Property

[image]

Grasshopper SDK
GH_PreviewArgs..::..Display Property
GH_PreviewArgs Class See Also Send Feedback
Gets the Pipeline that is being used to draw the current preview.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public DisplayPipeline Display { get; }
Visual Basic
Public ReadOnly Property Display As DisplayPipeline
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_PreviewArgs.Display"]

Implements

IGH_PreviewArgs..::..Display

See Also

GH_PreviewArgs Class
Grasshopper.Kernel Namespace


Document Property

[image]

Grasshopper SDK
GH_PreviewArgs..::..Document Property
GH_PreviewArgs Class See Also Send Feedback
Gets the Grasshopper document that is currently drawing the preview.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Document Document { get; }
Visual Basic
Public ReadOnly Property Document As GH_Document
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_PreviewArgs.Document"]

Implements

IGH_PreviewArgs..::..Document

See Also

GH_PreviewArgs Class
Grasshopper.Kernel Namespace


MeshingParameters Property

[image]

Grasshopper SDK
GH_PreviewArgs..::..MeshingParameters Property
GH_PreviewArgs Class See Also Send Feedback
Gets the meshing parameters to be used during meshing breps.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public MeshingParameters MeshingParameters { get; }
Visual Basic
Public ReadOnly Property MeshingParameters As MeshingParameters
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_PreviewArgs.MeshingParameters"]

Implements

IGH_PreviewArgs..::..MeshingParameters

See Also

GH_PreviewArgs Class
Grasshopper.Kernel Namespace


ShadeMaterial Property

[image]

Grasshopper SDK
GH_PreviewArgs..::..ShadeMaterial Property
GH_PreviewArgs Class See Also Send Feedback
Gets the document default material for unselected Faces.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public DisplayMaterial ShadeMaterial { get; }
Visual Basic
Public ReadOnly Property ShadeMaterial As DisplayMaterial
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_PreviewArgs.ShadeMaterial"]

Implements

IGH_PreviewArgs..::..ShadeMaterial

See Also

GH_PreviewArgs Class
Grasshopper.Kernel Namespace


ShadeMaterial_Selected Property

[image]

Grasshopper SDK
GH_PreviewArgs..::..ShadeMaterial_Selected Property
GH_PreviewArgs Class See Also Send Feedback
Gets the document default material for selected Faces.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public DisplayMaterial ShadeMaterial_Selected { get; }
Visual Basic
Public ReadOnly Property ShadeMaterial_Selected As DisplayMaterial
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_PreviewArgs.ShadeMaterial_Selected"]

Implements

IGH_PreviewArgs..::..ShadeMaterial_Selected

See Also

GH_PreviewArgs Class
Grasshopper.Kernel Namespace


Viewport Property

[image]

Grasshopper SDK
GH_PreviewArgs..::..Viewport Property
GH_PreviewArgs Class See Also Send Feedback
Gets the Viewport in which the current preview is drawn.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public RhinoViewport Viewport { get; }
Visual Basic
Public ReadOnly Property Viewport As RhinoViewport
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_PreviewArgs.Viewport"]

Implements

IGH_PreviewArgs..::..Viewport

See Also

GH_PreviewArgs Class
Grasshopper.Kernel Namespace


WireColour Property

[image]

Grasshopper SDK
GH_PreviewArgs..::..WireColour Property
GH_PreviewArgs Class See Also Send Feedback
Gets the document default colour for unselected Wires.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color WireColour { get; }
Visual Basic
Public ReadOnly Property WireColour As Color
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_PreviewArgs.WireColour"]

Implements

IGH_PreviewArgs..::..WireColour

See Also

GH_PreviewArgs Class
Grasshopper.Kernel Namespace


WireColour_Selected Property

[image]

Grasshopper SDK
GH_PreviewArgs..::..WireColour_Selected Property
GH_PreviewArgs Class See Also Send Feedback
Gets the document default colour for selected Wires.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color WireColour_Selected { get; }
Visual Basic
Public ReadOnly Property WireColour_Selected As Color
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_PreviewArgs.WireColour_Selected"]

Implements

IGH_PreviewArgs..::..WireColour_Selected

See Also

GH_PreviewArgs Class
Grasshopper.Kernel Namespace


GH_PreviewExpiredEventArgs Class

[image]

Grasshopper SDK
GH_PreviewExpiredEventArgs Class
Members See Also Send Feedback
Arguments for preview events.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_PreviewExpiredEventArgs : EventArgs
Visual Basic
Public Class GH_PreviewExpiredEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Grasshopper.Kernel..::..GH_PreviewExpiredEventArgs

See Also

GH_PreviewExpiredEventArgs Members
Grasshopper.Kernel Namespace


GH_PreviewExpiredEventArgs Members

[image] [image]

Grasshopper SDK
GH_PreviewExpiredEventArgs Members
GH_PreviewExpiredEventArgs Class Constructors Fields Properties See Also Send Feedback

The GH_PreviewExpiredEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GH_PreviewExpiredEventArgs | Initializes a new instance of the GH_PreviewExpiredEventArgs class

Fields

 | Name | Description
Protected field | m_redraw |

Properties

 | Name | Description
Public property | ForceRedraw |

See Also

GH_PreviewExpiredEventArgs Class
Grasshopper.Kernel Namespace


GH_PreviewExpiredEventArgs Constructor

[image]

Grasshopper SDK
GH_PreviewExpiredEventArgs Constructor
GH_PreviewExpiredEventArgs Class See Also Send Feedback
Initializes a new instance of the GH_PreviewExpiredEventArgs class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PreviewExpiredEventArgs(
    bool eForceRedraw
)
Visual Basic
Public Sub New ( _
    eForceRedraw As Boolean _
)

Parameters

eForceRedraw
Type: System..::..Boolean

See Also

GH_PreviewExpiredEventArgs Class
Grasshopper.Kernel Namespace


GH_PreviewExpiredEventArgs Fields

[image] [image]

Grasshopper SDK
GH_PreviewExpiredEventArgs Fields
GH_PreviewExpiredEventArgs Class See Also Send Feedback

The GH_PreviewExpiredEventArgs type exposes the following members.

Fields

 | Name | Description
Protected field | m_redraw |

See Also

GH_PreviewExpiredEventArgs Class
Grasshopper.Kernel Namespace


m_redraw Field

[image]

Grasshopper SDK
GH_PreviewExpiredEventArgs..::..m_redraw Field
GH_PreviewExpiredEventArgs Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected bool m_redraw
Visual Basic
Protected m_redraw As Boolean

See Also

GH_PreviewExpiredEventArgs Class
Grasshopper.Kernel Namespace


GH_PreviewExpiredEventArgs Properties

[image] [image]

Grasshopper SDK
GH_PreviewExpiredEventArgs Properties
GH_PreviewExpiredEventArgs Class See Also Send Feedback

The GH_PreviewExpiredEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ForceRedraw |

See Also

GH_PreviewExpiredEventArgs Class
Grasshopper.Kernel Namespace


ForceRedraw Property

[image]

Grasshopper SDK
GH_PreviewExpiredEventArgs..::..ForceRedraw Property
GH_PreviewExpiredEventArgs Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool ForceRedraw { get; }
Visual Basic
Public ReadOnly Property ForceRedraw As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_PreviewExpiredEventArgs.ForceRedraw"]

See Also

GH_PreviewExpiredEventArgs Class
Grasshopper.Kernel Namespace


GH_PreviewFilter Enumeration

[image]

Grasshopper SDK
GH_PreviewFilter Enumeration
See Also Send Feedback
Lists all possible Grasshopper preview filters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_PreviewFilter
Visual Basic
Public Enumeration GH_PreviewFilter

Members

Member name | Value | Description
None | 0 | Specifies no filtering is applied to the preview, i.e. all objects are drawn.
Selected | 1 | Only selected objects are included in the preview.

See Also

Grasshopper.Kernel Namespace


GH_PreviewMesh Enumeration

[image]

Grasshopper SDK
GH_PreviewMesh Enumeration
See Also Send Feedback
Enumerates possible meshing parameters for documents.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_PreviewMesh
Visual Basic
Public Enumeration GH_PreviewMesh

Members

Member name | Value | Description
None | 0 | No preview meshes.
LowQuality | 1 | Rhino default for coarse meshes.
HighQuality | 2 | Rhino default for smooth meshes.
Document | 3 | Same meshing parameters as the current document.
Custom | 4 | Custom meshing parameters.

See Also

Grasshopper.Kernel Namespace


GH_PreviewMeshArgs Class

[image]

Grasshopper SDK
GH_PreviewMeshArgs Class
Members See Also Send Feedback
This class is passed to objects that implement IGH_PreviewData during mesh drawing operations.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_PreviewMeshArgs
Visual Basic
Public Class GH_PreviewMeshArgs

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_PreviewMeshArgs

See Also

GH_PreviewMeshArgs Members
Grasshopper.Kernel Namespace


GH_PreviewMeshArgs Members

[image] [image]

Grasshopper SDK
GH_PreviewMeshArgs Members
GH_PreviewMeshArgs Class Constructors Properties See Also Send Feedback

The GH_PreviewMeshArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GH_PreviewMeshArgs | Initializes a new instance of the GH_PreviewMeshArgs class

Properties

 | Name | Description
Public property | Material | Gets the material in which meshes ought to be drawn.
Public property | MeshingParameters | Gets the meshing parameters which ought to be used for meshing breps and surfaces. If this property returns a null reference, meshes are supposed to be omitted.
Public property | Pipeline | Gets the Display Pipeline we're currently drawing with.
Public property | Viewport | Gets the Viewport in which we're currently drawing.

See Also

GH_PreviewMeshArgs Class
Grasshopper.Kernel Namespace


GH_PreviewMeshArgs Constructor

[image]

Grasshopper SDK
GH_PreviewMeshArgs Constructor
GH_PreviewMeshArgs Class See Also Send Feedback
Initializes a new instance of the GH_PreviewMeshArgs class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PreviewMeshArgs(
    RhinoViewport vp,
    DisplayPipeline pl,
    DisplayMaterial mat,
    MeshingParameters meshParams
)
Visual Basic
Public Sub New ( _
    vp As RhinoViewport, _
    pl As DisplayPipeline, _
    mat As DisplayMaterial, _
    meshParams As MeshingParameters _
)

Parameters

vp
Type: RhinoViewport
pl
Type: DisplayPipeline
mat
Type: DisplayMaterial
meshParams
Type: MeshingParameters

See Also

GH_PreviewMeshArgs Class
Grasshopper.Kernel Namespace


GH_PreviewMeshArgs Properties

[image] [image]

Grasshopper SDK
GH_PreviewMeshArgs Properties
GH_PreviewMeshArgs Class See Also Send Feedback

The GH_PreviewMeshArgs type exposes the following members.

Properties

 | Name | Description
Public property | Material | Gets the material in which meshes ought to be drawn.
Public property | MeshingParameters | Gets the meshing parameters which ought to be used for meshing breps and surfaces. If this property returns a null reference, meshes are supposed to be omitted.
Public property | Pipeline | Gets the Display Pipeline we're currently drawing with.
Public property | Viewport | Gets the Viewport in which we're currently drawing.

See Also

GH_PreviewMeshArgs Class
Grasshopper.Kernel Namespace


Material Property

[image]

Grasshopper SDK
GH_PreviewMeshArgs..::..Material Property
GH_PreviewMeshArgs Class See Also Send Feedback
Gets the material in which meshes ought to be drawn.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public DisplayMaterial Material { get; }
Visual Basic
Public ReadOnly Property Material As DisplayMaterial
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_PreviewMeshArgs.Material"]

See Also

GH_PreviewMeshArgs Class
Grasshopper.Kernel Namespace


MeshingParameters Property

[image]

Grasshopper SDK
GH_PreviewMeshArgs..::..MeshingParameters Property
GH_PreviewMeshArgs Class See Also Send Feedback
Gets the meshing parameters which ought to be used for meshing breps and surfaces. If this property returns a null reference, meshes are supposed to be omitted.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public MeshingParameters MeshingParameters { get; }
Visual Basic
Public ReadOnly Property MeshingParameters As MeshingParameters
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_PreviewMeshArgs.MeshingParameters"]

See Also

GH_PreviewMeshArgs Class
Grasshopper.Kernel Namespace


Pipeline Property

[image]

Grasshopper SDK
GH_PreviewMeshArgs..::..Pipeline Property
GH_PreviewMeshArgs Class See Also Send Feedback
Gets the Display Pipeline we're currently drawing with.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public DisplayPipeline Pipeline { get; }
Visual Basic
Public ReadOnly Property Pipeline As DisplayPipeline
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_PreviewMeshArgs.Pipeline"]

See Also

GH_PreviewMeshArgs Class
Grasshopper.Kernel Namespace


Viewport Property

[image]

Grasshopper SDK
GH_PreviewMeshArgs..::..Viewport Property
GH_PreviewMeshArgs Class See Also Send Feedback
Gets the Viewport in which we're currently drawing.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public RhinoViewport Viewport { get; }
Visual Basic
Public ReadOnly Property Viewport As RhinoViewport
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_PreviewMeshArgs.Viewport"]

See Also

GH_PreviewMeshArgs Class
Grasshopper.Kernel Namespace


GH_PreviewMode Enumeration

[image]

Grasshopper SDK
GH_PreviewMode Enumeration
See Also Send Feedback
Lists all possible Grasshopper preview modes.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_PreviewMode
Visual Basic
Public Enumeration GH_PreviewMode

Members

Member name | Value | Description
Disabled | 0 | Preview is not drawn in the Rhino viewports.
Wireframe | 1 | Only wireframe preview is drawn in the Rhino Viewports.
Shaded | 2 | Wireframe and shaded previews are drawn in the Rhino Viewports.

See Also

Grasshopper.Kernel Namespace


GH_PreviewUtil Class

[image]

Grasshopper SDK
GH_PreviewUtil Class
Members See Also Send Feedback
This class exposes functionality that makes it easy to draw temporary geometry in Rhino viewports.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class GH_PreviewUtil : IDisposable
Visual Basic
Public NotInheritable Class GH_PreviewUtil _
    Implements IDisposable

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_PreviewUtil

See Also

GH_PreviewUtil Members
Grasshopper.Kernel Namespace


GH_PreviewUtil Members

[image] [image]

Grasshopper SDK
GH_PreviewUtil Members
GH_PreviewUtil Class Constructors Methods Properties See Also Send Feedback

The GH_PreviewUtil type exposes the following members.

Constructors

 | Name | Description
Public method | GH_PreviewUtil()()()() | Initializes a new instance of the GH_PreviewUtil class
Public method | GH_PreviewUtil(Boolean) | Initializes a new instance of the GH_PreviewUtil class

Methods

 | Name | Description
Public method | AddBox | Add a box to the temporary Preview lists.
Public method | AddBrep | Add a brep to the temporary Preview lists.
Public method | AddCurve | Add a curve to the temporary Preview lists.
Public method | AddLine | Add a line to the temporary Preview lists.
Public method | AddMesh | Add a mesh to the temporary Preview lists.
Public method | AddPlane | Add a plane to the temporary Preview lists.
Public method | AddPoint | Add a point to the temporary Preview lists.
Public method | AddVector | Add a vector to the temporary Preview lists.
Public method | Clear | Clear all temporary geometry.
Public method | Dispose | Releases all resources used by the GH_PreviewUtil
Public method | Redraw | Forces a redraw the the viewports.

Properties

 | Name | Description
Public property | Enabled | Gets or sets the enabled state of this Preview util.
Public property | WireColour | Gets or sets the colour to use for Preview geometry.

See Also

GH_PreviewUtil Class
Grasshopper.Kernel Namespace


GH_PreviewUtil Constructor

[image] [image]

Grasshopper SDK
GH_PreviewUtil Constructor
GH_PreviewUtil Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_PreviewUtil()()()() | Initializes a new instance of the GH_PreviewUtil class
Public method | GH_PreviewUtil(Boolean) | Initializes a new instance of the GH_PreviewUtil class

See Also

GH_PreviewUtil Class
GH_PreviewUtil Members
Grasshopper.Kernel Namespace


GH_PreviewUtil Constructor

[image]

Grasshopper SDK
GH_PreviewUtil Constructor
GH_PreviewUtil Class See Also Send Feedback
Initializes a new instance of the GH_PreviewUtil class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PreviewUtil()
Visual Basic
Public Sub New

See Also

GH_PreviewUtil Class
GH_PreviewUtil Overload
Grasshopper.Kernel Namespace


GH_PreviewUtil Constructor (Boolean)

[image]

Grasshopper SDK
GH_PreviewUtil Constructor (Boolean)
GH_PreviewUtil Class See Also Send Feedback
Initializes a new instance of the GH_PreviewUtil class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PreviewUtil(
    bool enable
)
Visual Basic
Public Sub New ( _
    enable As Boolean _
)

Parameters

enable
Type: System..::..Boolean

See Also

GH_PreviewUtil Class
GH_PreviewUtil Overload
Grasshopper.Kernel Namespace


GH_PreviewUtil Methods

[image] [image]

Grasshopper SDK
GH_PreviewUtil Methods
GH_PreviewUtil Class See Also Send Feedback

The GH_PreviewUtil type exposes the following members.

Methods

 | Name | Description
Public method | AddBox | Add a box to the temporary Preview lists.
Public method | AddBrep | Add a brep to the temporary Preview lists.
Public method | AddCurve | Add a curve to the temporary Preview lists.
Public method | AddLine | Add a line to the temporary Preview lists.
Public method | AddMesh | Add a mesh to the temporary Preview lists.
Public method | AddPlane | Add a plane to the temporary Preview lists.
Public method | AddPoint | Add a point to the temporary Preview lists.
Public method | AddVector | Add a vector to the temporary Preview lists.
Public method | Clear | Clear all temporary geometry.
Public method | Dispose |
Public method | Redraw | Forces a redraw the the viewports.

See Also

GH_PreviewUtil Class
Grasshopper.Kernel Namespace


AddBox Method

[image]

Grasshopper SDK
GH_PreviewUtil..::..AddBox Method
GH_PreviewUtil Class See Also Send Feedback
Add a box to the temporary Preview lists.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddBox(
    Box box
)
Visual Basic
Public Sub AddBox ( _
    box As Box _
)

Parameters

box
Type: Box
Box to add.

See Also

GH_PreviewUtil Class
Grasshopper.Kernel Namespace


AddBrep Method

[image]

Grasshopper SDK
GH_PreviewUtil..::..AddBrep Method
GH_PreviewUtil Class See Also Send Feedback
Add a brep to the temporary Preview lists.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddBrep(
    Brep brep
)
Visual Basic
Public Sub AddBrep ( _
    brep As Brep _
)

Parameters

brep
Type: Brep
Brep to add. Invalid breps will be ignored.

See Also

GH_PreviewUtil Class
Grasshopper.Kernel Namespace


AddCurve Method

[image]

Grasshopper SDK
GH_PreviewUtil..::..AddCurve Method
GH_PreviewUtil Class See Also Send Feedback
Add a curve to the temporary Preview lists.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddCurve(
    Curve curve
)
Visual Basic
Public Sub AddCurve ( _
    curve As Curve _
)

Parameters

curve
Type: Curve
Curve to add. Invalid curves will be ignored.

See Also

GH_PreviewUtil Class
Grasshopper.Kernel Namespace


AddLine Method

[image]

Grasshopper SDK
GH_PreviewUtil..::..AddLine Method
GH_PreviewUtil Class See Also Send Feedback
Add a line to the temporary Preview lists.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddLine(
    Line line
)
Visual Basic
Public Sub AddLine ( _
    line As Line _
)

Parameters

line
Type: Line
Line to add. Invalid lines will be ignored.

See Also

GH_PreviewUtil Class
Grasshopper.Kernel Namespace


AddMesh Method

[image]

Grasshopper SDK
GH_PreviewUtil..::..AddMesh Method
GH_PreviewUtil Class See Also Send Feedback
Add a mesh to the temporary Preview lists.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddMesh(
    Mesh mesh
)
Visual Basic
Public Sub AddMesh ( _
    mesh As Mesh _
)

Parameters

mesh
Type: Mesh
Mesh to add. Invalid meshes will be ignored.

See Also

GH_PreviewUtil Class
Grasshopper.Kernel Namespace


AddPlane Method

[image]

Grasshopper SDK
GH_PreviewUtil..::..AddPlane Method
GH_PreviewUtil Class See Also Send Feedback
Add a plane to the temporary Preview lists.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddPlane(
    Plane plane
)
Visual Basic
Public Sub AddPlane ( _
    plane As Plane _
)

Parameters

plane
Type: Plane
Plane to add. Invalid planes will be ignored.

See Also

GH_PreviewUtil Class
Grasshopper.Kernel Namespace


AddPoint Method

[image]

Grasshopper SDK
GH_PreviewUtil..::..AddPoint Method
GH_PreviewUtil Class See Also Send Feedback
Add a point to the temporary Preview lists.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddPoint(
    Point3d point
)
Visual Basic
Public Sub AddPoint ( _
    point As Point3d _
)

Parameters

point
Type: Point3d
Point to add. Invalid points will be ignored.

See Also

GH_PreviewUtil Class
Grasshopper.Kernel Namespace


AddVector Method

[image]

Grasshopper SDK
GH_PreviewUtil..::..AddVector Method
GH_PreviewUtil Class See Also Send Feedback
Add a vector to the temporary Preview lists.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddVector(
    Line vector
)
Visual Basic
Public Sub AddVector ( _
    vector As Line _
)

Parameters

vector
Type: Line
Vector to add. Invalid vectors will be ignored.

See Also

GH_PreviewUtil Class
Grasshopper.Kernel Namespace


Clear Method

[image]

Grasshopper SDK
GH_PreviewUtil..::..Clear Method
GH_PreviewUtil Class See Also Send Feedback
Clear all temporary geometry.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear

See Also

GH_PreviewUtil Class
Grasshopper.Kernel Namespace


Dispose Method

[image]

Grasshopper SDK
GH_PreviewUtil..::..Dispose Method
GH_PreviewUtil Class See Also Send Feedback
Releases all resources used by the GH_PreviewUtil

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose

Implements

IDisposable..::..Dispose()()()()

See Also

GH_PreviewUtil Class
Grasshopper.Kernel Namespace


Redraw Method

[image]

Grasshopper SDK
GH_PreviewUtil..::..Redraw Method
GH_PreviewUtil Class See Also Send Feedback
Forces a redraw the the viewports.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Redraw()
Visual Basic
Public Sub Redraw

See Also

GH_PreviewUtil Class
Grasshopper.Kernel Namespace


GH_PreviewUtil Properties

[image] [image]

Grasshopper SDK
GH_PreviewUtil Properties
GH_PreviewUtil Class See Also Send Feedback

The GH_PreviewUtil type exposes the following members.

Properties

 | Name | Description
Public property | Enabled | Gets or sets the enabled state of this Preview util.
Public property | WireColour | Gets or sets the colour to use for Preview geometry.

See Also

GH_PreviewUtil Class
Grasshopper.Kernel Namespace


Enabled Property

[image]

Grasshopper SDK
GH_PreviewUtil..::..Enabled Property
GH_PreviewUtil Class See Also Send Feedback
Gets or sets the enabled state of this Preview util.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Enabled { get; set; }
Visual Basic
Public Property Enabled As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_PreviewUtil.Enabled"]

See Also

GH_PreviewUtil Class
Grasshopper.Kernel Namespace


WireColour Property

[image]

Grasshopper SDK
GH_PreviewUtil..::..WireColour Property
GH_PreviewUtil Class See Also Send Feedback
Gets or sets the colour to use for Preview geometry.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color WireColour { get; set; }
Visual Basic
Public Property WireColour As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_PreviewUtil.WireColour"]

See Also

GH_PreviewUtil Class
Grasshopper.Kernel Namespace


GH_PreviewWireArgs Class

[image]

Grasshopper SDK
GH_PreviewWireArgs Class
Members See Also Send Feedback
This class is passed to objects that implement IGH_PreviewData during wire drawing operations.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_PreviewWireArgs
Visual Basic
Public Class GH_PreviewWireArgs

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_PreviewWireArgs

See Also

GH_PreviewWireArgs Members
Grasshopper.Kernel Namespace


GH_PreviewWireArgs Members

[image] [image]

Grasshopper SDK
GH_PreviewWireArgs Members
GH_PreviewWireArgs Class Constructors Properties See Also Send Feedback

The GH_PreviewWireArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GH_PreviewWireArgs | Initializes a new instance of the GH_PreviewWireArgs class

Properties

 | Name | Description
Public property | Color | Gets the color in which wires ought to be drawn.
Public property | Pipeline | Gets the Display Pipeline we're currently drawing with.
Public property | Thickness | Gets the thickness in which wires ought to be drawn.
Public property | Viewport | Gets the Viewport in which we're currently drawing.

See Also

GH_PreviewWireArgs Class
Grasshopper.Kernel Namespace


GH_PreviewWireArgs Constructor

[image]

Grasshopper SDK
GH_PreviewWireArgs Constructor
GH_PreviewWireArgs Class See Also Send Feedback
Initializes a new instance of the GH_PreviewWireArgs class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PreviewWireArgs(
    RhinoViewport vp,
    DisplayPipeline pl,
    Color col,
    int thickness
)
Visual Basic
Public Sub New ( _
    vp As RhinoViewport, _
    pl As DisplayPipeline, _
    col As Color, _
    thickness As Integer _
)

Parameters

vp
Type: RhinoViewport
pl
Type: DisplayPipeline
col
Type: System.Drawing..::..Color
thickness
Type: System..::..Int32

See Also

GH_PreviewWireArgs Class
Grasshopper.Kernel Namespace


GH_PreviewWireArgs Properties

[image] [image]

Grasshopper SDK
GH_PreviewWireArgs Properties
GH_PreviewWireArgs Class See Also Send Feedback

The GH_PreviewWireArgs type exposes the following members.

Properties

 | Name | Description
Public property | Color | Gets the color in which wires ought to be drawn.
Public property | Pipeline | Gets the Display Pipeline we're currently drawing with.
Public property | Thickness | Gets the thickness in which wires ought to be drawn.
Public property | Viewport | Gets the Viewport in which we're currently drawing.

See Also

GH_PreviewWireArgs Class
Grasshopper.Kernel Namespace


Color Property

[image]

Grasshopper SDK
GH_PreviewWireArgs..::..Color Property
GH_PreviewWireArgs Class See Also Send Feedback
Gets the color in which wires ought to be drawn.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color Color { get; }
Visual Basic
Public ReadOnly Property Color As Color
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_PreviewWireArgs.Color"]

See Also

GH_PreviewWireArgs Class
Grasshopper.Kernel Namespace


Pipeline Property

[image]

Grasshopper SDK
GH_PreviewWireArgs..::..Pipeline Property
GH_PreviewWireArgs Class See Also Send Feedback
Gets the Display Pipeline we're currently drawing with.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public DisplayPipeline Pipeline { get; }
Visual Basic
Public ReadOnly Property Pipeline As DisplayPipeline
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_PreviewWireArgs.Pipeline"]

See Also

GH_PreviewWireArgs Class
Grasshopper.Kernel Namespace


Thickness Property

[image]

Grasshopper SDK
GH_PreviewWireArgs..::..Thickness Property
GH_PreviewWireArgs Class See Also Send Feedback
Gets the thickness in which wires ought to be drawn.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int Thickness { get; }
Visual Basic
Public ReadOnly Property Thickness As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_PreviewWireArgs.Thickness"]

See Also

GH_PreviewWireArgs Class
Grasshopper.Kernel Namespace


Viewport Property

[image]

Grasshopper SDK
GH_PreviewWireArgs..::..Viewport Property
GH_PreviewWireArgs Class See Also Send Feedback
Gets the Viewport in which we're currently drawing.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public RhinoViewport Viewport { get; }
Visual Basic
Public ReadOnly Property Viewport As RhinoViewport
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_PreviewWireArgs.Viewport"]

See Also

GH_PreviewWireArgs Class
Grasshopper.Kernel Namespace


GH_PrincipalState Enumeration

[image]

Grasshopper SDK
GH_PrincipalState Enumeration
See Also Send Feedback
Enumerates the different possible states in which the masterness of a parameter can occur.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_PrincipalState
Visual Basic
Public Enumeration GH_PrincipalState

Members

Member name | Value | Description
CannotBePrincipal | 0 | This parameter cannot be a principal parameter. It is not a valid component input.
IsPrincipal | 1 | This parameter is the current principal parameter as defined by the component which owns it.
IsNotPrincipal | 2 | This parameter is not the current principal parameter, but it could be.

See Also

Grasshopper.Kernel Namespace


GH_ProcessStep Enumeration

[image]

Grasshopper SDK
GH_ProcessStep Enumeration
See Also Send Feedback
Enumerates all possible solution states in which the document can be.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_ProcessStep
Visual Basic
Public Enumeration GH_ProcessStep

Members

Member name | Value | Description
PreProcess | 0 | The document is ready for a new solution
Process | 1 | The document is currently calculating a new solution, no changes are allowed during this phase
PostProcess | 2 | The document has completed a solution, and nothing has changed since.
Aborted | 3 | The last solution has been aborted before it reached completion.

See Also

Grasshopper.Kernel Namespace


GH_ProfilerMode Enumeration

[image]

Grasshopper SDK
GH_ProfilerMode Enumeration
See Also Send Feedback
Lists all profiler modes.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_ProfilerMode
Visual Basic
Public Enumeration GH_ProfilerMode

Members

Member name | Value | Description
None | 0 | Indicates no profiling is required.
Processor | 1 | Indicates processor time is being measured.
Memory | 2 | Indicates memory footprint is being measured.

See Also

Grasshopper.Kernel Namespace


GH_RelevantObjectData Class

[image]

Grasshopper SDK
GH_RelevantObjectData Class
Members See Also Send Feedback
Contains information about relevant objects at a specific canvas location.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_RelevantObjectData
Visual Basic
Public Class GH_RelevantObjectData

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_RelevantObjectData

See Also

GH_RelevantObjectData Members
Grasshopper.Kernel Namespace


GH_RelevantObjectData Members

[image] [image]

Grasshopper SDK
GH_RelevantObjectData Members
GH_RelevantObjectData Class Constructors Methods Properties See Also Send Feedback

The GH_RelevantObjectData type exposes the following members.

Constructors

 | Name | Description
Public method | GH_RelevantObjectData | Construct a new instance.

Methods

 | Name | Description
Public method | CreateBalloonData |
Public method | CreateGripData |
Public method | CreateGroupData |
Public method | CreateObjectData |
Public method | CreateWireData |

Properties

 | Name | Description
Public property | Attributes | Gets the attributes that belong to the object.
Public property | Group | Gets the cast of the DocObject to GH_Group.
Public property | IsTopLevelObject | Gets a value indicating whether or not the Object is a top-level object.
Public property | Object | Gets the raw object cached in this data instance.
Public property | ObjectType | Gets the type of object indicated by this data.
Public property | Parameter | Gets the cast of the DocObject to IGH_Param. If the DocObject is not of type IGH_Param, the attributes of the object will be perused to find a nested IGH_Param at the point.
Public property | Point | Gets the point for which this GH_RelevantObjectData has been made.
Public property | TopLevelObject | Gets the top-level object.

See Also

GH_RelevantObjectData Class
Grasshopper.Kernel Namespace


GH_RelevantObjectData Constructor

[image]

Grasshopper SDK
GH_RelevantObjectData Constructor
GH_RelevantObjectData Class See Also Send Feedback
Construct a new instance.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_RelevantObjectData(
    PointF pt
)
Visual Basic
Public Sub New ( _
    pt As PointF _
)

Parameters

pt
Type: System.Drawing..::..PointF
Point for relevant data aquisition.

See Also

GH_RelevantObjectData Class
Grasshopper.Kernel Namespace


GH_RelevantObjectData Methods

[image] [image]

Grasshopper SDK
GH_RelevantObjectData Methods
GH_RelevantObjectData Class See Also Send Feedback

The GH_RelevantObjectData type exposes the following members.

Methods

 | Name | Description
Public method | CreateBalloonData |
Public method | CreateGripData |
Public method | CreateGroupData |
Public method | CreateObjectData |
Public method | CreateWireData |

See Also

GH_RelevantObjectData Class
Grasshopper.Kernel Namespace


CreateBalloonData Method

[image]

Grasshopper SDK
GH_RelevantObjectData..::..CreateBalloonData Method
GH_RelevantObjectData Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void CreateBalloonData(
    IGH_DocumentObject obj
)
Visual Basic
Public Sub CreateBalloonData ( _
    obj As IGH_DocumentObject _
)

Parameters

obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject

See Also

GH_RelevantObjectData Class
Grasshopper.Kernel Namespace


CreateGripData Method

[image]

Grasshopper SDK
GH_RelevantObjectData..::..CreateGripData Method
GH_RelevantObjectData Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void CreateGripData(
    IGH_DocumentObject obj,
    bool is_input
)
Visual Basic
Public Sub CreateGripData ( _
    obj As IGH_DocumentObject, _
    is_input As Boolean _
)

Parameters

obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject
is_input
Type: System..::..Boolean

See Also

GH_RelevantObjectData Class
Grasshopper.Kernel Namespace


CreateGroupData Method

[image]

Grasshopper SDK
GH_RelevantObjectData..::..CreateGroupData Method
GH_RelevantObjectData Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void CreateGroupData(
    GH_Group group
)
Visual Basic
Public Sub CreateGroupData ( _
    group As GH_Group _
)

Parameters

group
Type: GH_Group

See Also

GH_RelevantObjectData Class
Grasshopper.Kernel Namespace


CreateObjectData Method

[image]

Grasshopper SDK
GH_RelevantObjectData..::..CreateObjectData Method
GH_RelevantObjectData Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void CreateObjectData(
    IGH_DocumentObject obj
)
Visual Basic
Public Sub CreateObjectData ( _
    obj As IGH_DocumentObject _
)

Parameters

obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject

See Also

GH_RelevantObjectData Class
Grasshopper.Kernel Namespace


CreateWireData Method

[image]

Grasshopper SDK
GH_RelevantObjectData..::..CreateWireData Method
GH_RelevantObjectData Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void CreateWireData()
Visual Basic
Public Sub CreateWireData

See Also

GH_RelevantObjectData Class
Grasshopper.Kernel Namespace


GH_RelevantObjectData Properties

[image] [image]

Grasshopper SDK
GH_RelevantObjectData Properties
GH_RelevantObjectData Class See Also Send Feedback

The GH_RelevantObjectData type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Gets the attributes that belong to the object.
Public property | Group | Gets the cast of the DocObject to GH_Group.
Public property | IsTopLevelObject | Gets a value indicating whether or not the Object is a top-level object.
Public property | Object | Gets the raw object cached in this data instance.
Public property | ObjectType | Gets the type of object indicated by this data.
Public property | Parameter | Gets the cast of the DocObject to IGH_Param. If the DocObject is not of type IGH_Param, the attributes of the object will be perused to find a nested IGH_Param at the point.
Public property | Point | Gets the point for which this GH_RelevantObjectData has been made.
Public property | TopLevelObject | Gets the top-level object.

See Also

GH_RelevantObjectData Class
Grasshopper.Kernel Namespace


Attributes Property

[image]

Grasshopper SDK
GH_RelevantObjectData..::..Attributes Property
GH_RelevantObjectData Class See Also Send Feedback
Gets the attributes that belong to the object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_Attributes Attributes { get; }
Visual Basic
Public ReadOnly Property Attributes As IGH_Attributes
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_RelevantObjectData.Attributes"]

See Also

GH_RelevantObjectData Class
Grasshopper.Kernel Namespace


Group Property

[image]

Grasshopper SDK
GH_RelevantObjectData..::..Group Property
GH_RelevantObjectData Class See Also Send Feedback
Gets the cast of the DocObject to GH_Group.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Group Group { get; }
Visual Basic
Public ReadOnly Property Group As GH_Group
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_RelevantObjectData.Group"]

See Also

GH_RelevantObjectData Class
Grasshopper.Kernel Namespace


IsTopLevelObject Property

[image]

Grasshopper SDK
GH_RelevantObjectData..::..IsTopLevelObject Property
GH_RelevantObjectData Class See Also Send Feedback
Gets a value indicating whether or not the Object is a top-level object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsTopLevelObject { get; }
Visual Basic
Public ReadOnly Property IsTopLevelObject As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_RelevantObjectData.IsTopLevelObject"]

See Also

GH_RelevantObjectData Class
Grasshopper.Kernel Namespace


Object Property

[image]

Grasshopper SDK
GH_RelevantObjectData..::..Object Property
GH_RelevantObjectData Class See Also Send Feedback
Gets the raw object cached in this data instance.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_DocumentObject Object { get; }
Visual Basic
Public ReadOnly Property Object As IGH_DocumentObject
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_RelevantObjectData.Object"]

See Also

GH_RelevantObjectData Class
Grasshopper.Kernel Namespace


ObjectType Property

[image]

Grasshopper SDK
GH_RelevantObjectData..::..ObjectType Property
GH_RelevantObjectData Class See Also Send Feedback
Gets the type of object indicated by this data.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ObjectSpecies ObjectType { get; }
Visual Basic
Public ReadOnly Property ObjectType As GH_ObjectSpecies
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_RelevantObjectData.ObjectType"]

See Also

GH_RelevantObjectData Class
Grasshopper.Kernel Namespace


Parameter Property

[image]

Grasshopper SDK
GH_RelevantObjectData..::..Parameter Property
GH_RelevantObjectData Class See Also Send Feedback
Gets the cast of the DocObject to IGH_Param. If the DocObject is not of type IGH_Param, the attributes of the object will be perused to find a nested IGH_Param at the point.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_Param Parameter { get; }
Visual Basic
Public ReadOnly Property Parameter As IGH_Param
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_RelevantObjectData.Parameter"]

See Also

GH_RelevantObjectData Class
Grasshopper.Kernel Namespace


Point Property

[image]

Grasshopper SDK
GH_RelevantObjectData..::..Point Property
GH_RelevantObjectData Class See Also Send Feedback
Gets the point for which this GH_RelevantObjectData has been made.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public PointF Point { get; }
Visual Basic
Public ReadOnly Property Point As PointF
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_RelevantObjectData.Point"]

See Also

GH_RelevantObjectData Class
Grasshopper.Kernel Namespace


TopLevelObject Property

[image]

Grasshopper SDK
GH_RelevantObjectData..::..TopLevelObject Property
GH_RelevantObjectData Class See Also Send Feedback
Gets the top-level object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_DocumentObject TopLevelObject { get; }
Visual Basic
Public ReadOnly Property TopLevelObject As IGH_DocumentObject
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_RelevantObjectData.TopLevelObject"]

See Also

GH_RelevantObjectData Class
Grasshopper.Kernel Namespace


GH_RelevantObjectFilter Enumeration

[image]

Grasshopper SDK
GH_RelevantObjectFilter Enumeration
See Also Send Feedback
Enumerates the possible filters to use in relevant object searches.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
[FlagsAttribute]
public enum GH_RelevantObjectFilter
Visual Basic
<FlagsAttribute> _
Public Enumeration GH_RelevantObjectFilter

Members

Member name | Value | Description
None | 0 | Blank filter. When combined with another filter it is ignored.
Groups | 1 | Include group objects in the search.
InputGrips | 2 | Include input grips in the search.
OutputGrips | 4 | Include output grips in the search.
Grips | 6 | Include both input and outpu grips in the search.
Attributes | 8 | Include attribute bounds in the search.
Wires | 1024 | Include wires (currently not yet supported)
All | 2147483647 | Search all possible objects.

See Also

Grasshopper.Kernel Namespace


GH_RuntimeMessage Class

[image]

Grasshopper SDK
GH_RuntimeMessage Class
Members See Also Send Feedback
Contains all fields that together define a RuntimeMessage. Runtime Messages are created and recorded by document objects during Grasshopper solutions.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_RuntimeMessage
Visual Basic
Public Class GH_RuntimeMessage

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_RuntimeMessage

See Also

GH_RuntimeMessage Members
Grasshopper.Kernel Namespace


GH_RuntimeMessage Members

[image] [image]

Grasshopper SDK
GH_RuntimeMessage Members
GH_RuntimeMessage Class Constructors Properties See Also Send Feedback

The GH_RuntimeMessage type exposes the following members.

Constructors

 | Name | Description
Public method | GH_RuntimeMessage | Initializes a new instance of the GH_RuntimeMessage class

Properties

 | Name | Description
Public property | Event | Gets the time at which the message was recorded.
Public property | HasSource | Gets a value indicating whether or not this message has a source.
Public property | Message | Gets the contents of the message.
Public property | Source | Gets a string describing the source object that created the message.
Public property | Type | Gets the type qualifier of the message.

See Also

GH_RuntimeMessage Class
Grasshopper.Kernel Namespace


GH_RuntimeMessage Constructor

[image]

Grasshopper SDK
GH_RuntimeMessage Constructor
GH_RuntimeMessage Class See Also Send Feedback
Initializes a new instance of the GH_RuntimeMessage class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_RuntimeMessage(
    string nMessage,
    GH_RuntimeMessageLevel nType,
    string nSource
)
Visual Basic
Public Sub New ( _
    nMessage As String, _
    nType As GH_RuntimeMessageLevel, _
    nSource As String _
)

Parameters

nMessage
Type: System..::..String
nType
Type: Grasshopper.Kernel..::..GH_RuntimeMessageLevel
nSource
Type: System..::..String

See Also

GH_RuntimeMessage Class
Grasshopper.Kernel Namespace


GH_RuntimeMessage Properties

[image] [image]

Grasshopper SDK
GH_RuntimeMessage Properties
GH_RuntimeMessage Class See Also Send Feedback

The GH_RuntimeMessage type exposes the following members.

Properties

 | Name | Description
Public property | Event | Gets the time at which the message was recorded.
Public property | HasSource | Gets a value indicating whether or not this message has a source.
Public property | Message | Gets the contents of the message.
Public property | Source | Gets a string describing the source object that created the message.
Public property | Type | Gets the type qualifier of the message.

See Also

GH_RuntimeMessage Class
Grasshopper.Kernel Namespace


Event Property

[image]

Grasshopper SDK
GH_RuntimeMessage..::..Event Property
GH_RuntimeMessage Class See Also Send Feedback
Gets the time at which the message was recorded.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public DateTime Event { get; }
Visual Basic
Public ReadOnly Property Event As DateTime
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_RuntimeMessage.Event"]

See Also

GH_RuntimeMessage Class
Grasshopper.Kernel Namespace


HasSource Property

[image]

Grasshopper SDK
GH_RuntimeMessage..::..HasSource Property
GH_RuntimeMessage Class See Also Send Feedback
Gets a value indicating whether or not this message has a source.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool HasSource { get; }
Visual Basic
Public ReadOnly Property HasSource As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_RuntimeMessage.HasSource"]

See Also

GH_RuntimeMessage Class
Grasshopper.Kernel Namespace


Message Property

[image]

Grasshopper SDK
GH_RuntimeMessage..::..Message Property
GH_RuntimeMessage Class See Also Send Feedback
Gets the contents of the message.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Message { get; }
Visual Basic
Public ReadOnly Property Message As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_RuntimeMessage.Message"]

See Also

GH_RuntimeMessage Class
Grasshopper.Kernel Namespace


Source Property

[image]

Grasshopper SDK
GH_RuntimeMessage..::..Source Property
GH_RuntimeMessage Class See Also Send Feedback
Gets a string describing the source object that created the message.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Source { get; }
Visual Basic
Public ReadOnly Property Source As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_RuntimeMessage.Source"]

See Also

GH_RuntimeMessage Class
Grasshopper.Kernel Namespace


Type Property

[image]

Grasshopper SDK
GH_RuntimeMessage..::..Type Property
GH_RuntimeMessage Class See Also Send Feedback
Gets the type qualifier of the message.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_RuntimeMessageLevel Type { get; }
Visual Basic
Public ReadOnly Property Type As GH_RuntimeMessageLevel
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_RuntimeMessage.Type"]

See Also

GH_RuntimeMessage Class
Grasshopper.Kernel Namespace


GH_RuntimeMessageLevel Enumeration

[image]

Grasshopper SDK
GH_RuntimeMessageLevel Enumeration
See Also Send Feedback
Indicates the severity of a runtime message.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_RuntimeMessageLevel
Visual Basic
Public Enumeration GH_RuntimeMessageLevel

Members

Member name | Value | Description
Blank | 0 | No warnings or errors were recorded during solver-time processes
Remark | 255 | One of more messages (but no warnings and no errors) were recorded during solver-time processes.
Warning | 10 | One or more warnings (but no errors) were recorded during solver-time processes
Error | 20 | One or more errors (and possibly any number of warnings) were recorded during solver-time processes.

See Also

Grasshopper.Kernel Namespace


GH_SelectionState Enumeration

[image]

Grasshopper SDK
GH_SelectionState Enumeration
See Also Send Feedback
Enumerates the possible effects of a specific selection operation.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_SelectionState
Visual Basic
Public Enumeration GH_SelectionState

Members

Member name | Value | Description
Changed | 0 |
Unchanged | 1 |

See Also

Grasshopper.Kernel Namespace


GH_SelectionTopology Enumeration

[image]

Grasshopper SDK
GH_SelectionTopology Enumeration
See Also Send Feedback
Enumerates the possible selection topologies.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_SelectionTopology
Visual Basic
Public Enumeration GH_SelectionTopology

Members

Member name | Value | Description
None | 0 | No selected objects.
Convex | 1 | Selection set is convex, meaning unselected objects are not sandwiched between selected objects.
Concave | 2 | Selection set is concave, meaning unselected objects are sandwiched between selected objects.

See Also

Grasshopper.Kernel Namespace


GH_SettingsServer Class

[image]

Grasshopper SDK
GH_SettingsServer Class
Members See Also Send Feedback
A single instance of this class is maintained at module level under the accessor "Settings".

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class GH_SettingsServer : GH_ISerializable
Visual Basic
Public NotInheritable Class GH_SettingsServer _
    Implements GH_ISerializable

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_SettingsServer

See Also

GH_SettingsServer Members
Grasshopper.Kernel Namespace


GH_SettingsServer Members

[image] [image]

Grasshopper SDK
GH_SettingsServer Members
GH_SettingsServer Class Constructors Methods Properties See Also Send Feedback

The GH_SettingsServer type exposes the following members.

Constructors

 | Name | Description
Public method | GH_SettingsServer(String) | Create a new instance of the GH_SettingsServer class. The server will be associated with a settings xml file in the %ApplicationData%\Grasshopper\ directory. If a file with the same name already exists, its settings will be automatically loaded.
Public method | GH_SettingsServer(String, Boolean) | Create a new instance of the GH_SettingsServer class. The server will be associated with a settings xml file in the %ApplicationData%\Grasshopper\ directory.

Methods

 | Name | Description
Public method | Clear | Destroy all settings.
Public method | ConstainsEntry | Tests to see if a given entry is stored in this settings database.
Public method | DeleteValue |
Public method | EntryNames | Gets a list of all the entry names in this settings.
Public method | EntryType | Gets the type of a specific entry.
Public method | GetValue(String, Boolean) |
Public method | GetValue(String, Byte) |
Public method | GetValue(String, DateTime) |
Public method | GetValue(String, Double) |
Public method | GetValue(String, Color) |
Public method | GetValue(String, Point) |
Public method | GetValue(String, Rectangle) |
Public method | GetValue(String, Size) |
Public method | GetValue(String, Int32) |
Public method | GetValue(String, String) |
Public method | Read | Low-level deserializer.
Public method | SetValue(String) |
Public method | SetValue(String, Boolean) |
Public method | SetValue(String, Byte) |
Public method | SetValue(String, DateTime) |
Public method | SetValue(String, Double) |
Public method | SetValue(String, Color) |
Public method | SetValue(String, Point) |
Public method | SetValue(String, Rectangle) |
Public method | SetValue(String, Size) |
Public method | SetValue(String, Int32) |
Public method | SetValue(String, String) |
Public method | ShowSettingsBrowser |
Public method | Write | Low-level serializer.
Public method | WritePersistentSettings | Store all settings in the xml file now. You must call this function if you want the current settings to persist between sessions.

Properties

 | Name | Description
Public property | Count | Gets the total number of settings stored in this database.
Public property | DatabaseName | Gets the name of this settings database.

See Also

GH_SettingsServer Class
Grasshopper.Kernel Namespace


GH_SettingsServer Constructor

[image] [image]

Grasshopper SDK
GH_SettingsServer Constructor
GH_SettingsServer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_SettingsServer(String) | Create a new instance of the GH_SettingsServer class. The server will be associated with a settings xml file in the %ApplicationData%\Grasshopper\ directory. If a file with the same name already exists, its settings will be automatically loaded.
Public method | GH_SettingsServer(String, Boolean) | Create a new instance of the GH_SettingsServer class. The server will be associated with a settings xml file in the %ApplicationData%\Grasshopper\ directory.

See Also

GH_SettingsServer Class
GH_SettingsServer Members
Grasshopper.Kernel Namespace


GH_SettingsServer Constructor (String)

[image]

Grasshopper SDK
GH_SettingsServer Constructor (String)
GH_SettingsServer Class See Also Send Feedback
Create a new instance of the GH_SettingsServer class. The server will be associated with a settings xml file in the %ApplicationData%\Grasshopper\ directory. If a file with the same name already exists, its settings will be automatically loaded.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_SettingsServer(
    string databaseName
)
Visual Basic
Public Sub New ( _
    databaseName As String _
)

Parameters

databaseName
Type: System..::..String
The name of the settings server (equals the name of the xml file so it must adhere to FAT, FAT32 and NTFS naming conventions).

See Also

GH_SettingsServer Class
GH_SettingsServer Overload
Grasshopper.Kernel Namespace


GH_SettingsServer Constructor (String, Boolean)

[image]

Grasshopper SDK
GH_SettingsServer Constructor (String, Boolean)
GH_SettingsServer Class See Also Send Feedback
Create a new instance of the GH_SettingsServer class. The server will be associated with a settings xml file in the %ApplicationData%\Grasshopper\ directory.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_SettingsServer(
    string databaseName,
    bool loadSettings
)
Visual Basic
Public Sub New ( _
    databaseName As String, _
    loadSettings As Boolean _
)

Parameters

databaseName
Type: System..::..String
The name of the settings server (equals the name of the xml file so it must adhere to FAT, FAT32 and NTFS naming conventions).
loadSettings
Type: System..::..Boolean
When true and a file with the same name already exists, its settings will be automatically loaded.

See Also

GH_SettingsServer Class
GH_SettingsServer Overload
Grasshopper.Kernel Namespace


GH_SettingsServer Methods

[image] [image]

Grasshopper SDK
GH_SettingsServer Methods
GH_SettingsServer Class See Also Send Feedback

The GH_SettingsServer type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Destroy all settings.
Public method | ConstainsEntry | Tests to see if a given entry is stored in this settings database.
Public method | DeleteValue |
Public method | EntryNames | Gets a list of all the entry names in this settings.
Public method | EntryType | Gets the type of a specific entry.
Public method | GetValue(String, Boolean) |
Public method | GetValue(String, Byte) |
Public method | GetValue(String, DateTime) |
Public method | GetValue(String, Double) |
Public method | GetValue(String, Color) |
Public method | GetValue(String, Point) |
Public method | GetValue(String, Rectangle) |
Public method | GetValue(String, Size) |
Public method | GetValue(String, Int32) |
Public method | GetValue(String, String) |
Public method | Read | Low-level deserializer.
Public method | SetValue(String) |
Public method | SetValue(String, Boolean) |
Public method | SetValue(String, Byte) |
Public method | SetValue(String, DateTime) |
Public method | SetValue(String, Double) |
Public method | SetValue(String, Color) |
Public method | SetValue(String, Point) |
Public method | SetValue(String, Rectangle) |
Public method | SetValue(String, Size) |
Public method | SetValue(String, Int32) |
Public method | SetValue(String, String) |
Public method | ShowSettingsBrowser |
Public method | Write | Low-level serializer.
Public method | WritePersistentSettings | Store all settings in the xml file now. You must call this function if you want the current settings to persist between sessions.

See Also

GH_SettingsServer Class
Grasshopper.Kernel Namespace


Clear Method

[image]

Grasshopper SDK
GH_SettingsServer..::..Clear Method
GH_SettingsServer Class See Also Send Feedback
Destroy all settings.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear

See Also

GH_SettingsServer Class
Grasshopper.Kernel Namespace


ConstainsEntry Method

[image]

Grasshopper SDK
GH_SettingsServer..::..ConstainsEntry Method
GH_SettingsServer Class See Also Send Feedback
Tests to see if a given entry is stored in this settings database.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool ConstainsEntry(
    string name
)
Visual Basic
Public Function ConstainsEntry ( _
    name As String _
) As Boolean

Parameters

name
Type: System..::..String
Entry name to query.

Return Value

True if the entry exists, false otherwise.

See Also

GH_SettingsServer Class
Grasshopper.Kernel Namespace


DeleteValue Method

[image]

Grasshopper SDK
GH_SettingsServer..::..DeleteValue Method
GH_SettingsServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DeleteValue(
    string key
)
Visual Basic
Public Sub DeleteValue ( _
    key As String _
)

Parameters

key
Type: System..::..String

See Also

GH_SettingsServer Class
Grasshopper.Kernel Namespace


EntryNames Method

[image]

Grasshopper SDK
GH_SettingsServer..::..EntryNames Method
GH_SettingsServer Class See Also Send Feedback
Gets a list of all the entry names in this settings.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<string> EntryNames()
Visual Basic
Public Function EntryNames As List(Of String)

See Also

GH_SettingsServer Class
Grasshopper.Kernel Namespace


EntryType Method

[image]

Grasshopper SDK
GH_SettingsServer..::..EntryType Method
GH_SettingsServer Class See Also Send Feedback
Gets the type of a specific entry.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_SettingsType EntryType(
    string name
)
Visual Basic
Public Function EntryType ( _
    name As String _
) As GH_SettingsType

Parameters

name
Type: System..::..String
Name of entry.

Return Value

Type of entry. If entry doesn't exist, GH_SettingsType._unknown is returned.

See Also

GH_SettingsServer Class
Grasshopper.Kernel Namespace


GetValue Method

[image] [image]

Grasshopper SDK
GH_SettingsServer..::..GetValue Method
GH_SettingsServer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue(String, Boolean) |
Public method | GetValue(String, Byte) |
Public method | GetValue(String, DateTime) |
Public method | GetValue(String, Double) |
Public method | GetValue(String, Color) |
Public method | GetValue(String, Point) |
Public method | GetValue(String, Rectangle) |
Public method | GetValue(String, Size) |
Public method | GetValue(String, Int32) |
Public method | GetValue(String, String) |

See Also

GH_SettingsServer Class
GH_SettingsServer Members
Grasshopper.Kernel Namespace


GetValue Method (String, Boolean)

[image]

Grasshopper SDK
GH_SettingsServer..::..GetValue Method (String, Boolean)
GH_SettingsServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool GetValue(
    string key,
    bool default
)
Visual Basic
Public Function GetValue ( _
    key As String, _
    default As Boolean _
) As Boolean

Parameters

key
Type: System..::..String
default
Type: System..::..Boolean

See Also

GH_SettingsServer Class
GetValue Overload
Grasshopper.Kernel Namespace


GetValue Method (String, Byte)

[image]

Grasshopper SDK
GH_SettingsServer..::..GetValue Method (String, Byte)
GH_SettingsServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public byte GetValue(
    string key,
    byte default
)
Visual Basic
Public Function GetValue ( _
    key As String, _
    default As Byte _
) As Byte

Parameters

key
Type: System..::..String
default
Type: System..::..Byte

See Also

GH_SettingsServer Class
GetValue Overload
Grasshopper.Kernel Namespace


GetValue Method (String, DateTime)

[image]

Grasshopper SDK
GH_SettingsServer..::..GetValue Method (String, DateTime)
GH_SettingsServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public DateTime GetValue(
    string key,
    DateTime default
)
Visual Basic
Public Function GetValue ( _
    key As String, _
    default As DateTime _
) As DateTime

Parameters

key
Type: System..::..String
default
Type: System..::..DateTime

See Also

GH_SettingsServer Class
GetValue Overload
Grasshopper.Kernel Namespace


GetValue Method (String, Double)

[image]

Grasshopper SDK
GH_SettingsServer..::..GetValue Method (String, Double)
GH_SettingsServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double GetValue(
    string key,
    double default
)
Visual Basic
Public Function GetValue ( _
    key As String, _
    default As Double _
) As Double

Parameters

key
Type: System..::..String
default
Type: System..::..Double

See Also

GH_SettingsServer Class
GetValue Overload
Grasshopper.Kernel Namespace


GetValue Method (String, Color)

[image]

Grasshopper SDK
GH_SettingsServer..::..GetValue Method (String, Color)
GH_SettingsServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color GetValue(
    string key,
    Color default
)
Visual Basic
Public Function GetValue ( _
    key As String, _
    default As Color _
) As Color

Parameters

key
Type: System..::..String
default
Type: System.Drawing..::..Color

See Also

GH_SettingsServer Class
GetValue Overload
Grasshopper.Kernel Namespace


GetValue Method (String, Point)

[image]

Grasshopper SDK
GH_SettingsServer..::..GetValue Method (String, Point)
GH_SettingsServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Point GetValue(
    string key,
    Point default
)
Visual Basic
Public Function GetValue ( _
    key As String, _
    default As Point _
) As Point

Parameters

key
Type: System..::..String
default
Type: System.Drawing..::..Point

See Also

GH_SettingsServer Class
GetValue Overload
Grasshopper.Kernel Namespace


GetValue Method (String, Rectangle)

[image]

Grasshopper SDK
GH_SettingsServer..::..GetValue Method (String, Rectangle)
GH_SettingsServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle GetValue(
    string key,
    Rectangle default
)
Visual Basic
Public Function GetValue ( _
    key As String, _
    default As Rectangle _
) As Rectangle

Parameters

key
Type: System..::..String
default
Type: System.Drawing..::..Rectangle

See Also

GH_SettingsServer Class
GetValue Overload
Grasshopper.Kernel Namespace


GetValue Method (String, Size)

[image]

Grasshopper SDK
GH_SettingsServer..::..GetValue Method (String, Size)
GH_SettingsServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Size GetValue(
    string key,
    Size default
)
Visual Basic
Public Function GetValue ( _
    key As String, _
    default As Size _
) As Size

Parameters

key
Type: System..::..String
default
Type: System.Drawing..::..Size

See Also

GH_SettingsServer Class
GetValue Overload
Grasshopper.Kernel Namespace


GetValue Method (String, Int32)

[image]

Grasshopper SDK
GH_SettingsServer..::..GetValue Method (String, Int32)
GH_SettingsServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int GetValue(
    string key,
    int default
)
Visual Basic
Public Function GetValue ( _
    key As String, _
    default As Integer _
) As Integer

Parameters

key
Type: System..::..String
default
Type: System..::..Int32

See Also

GH_SettingsServer Class
GetValue Overload
Grasshopper.Kernel Namespace


GetValue Method (String, String)

[image]

Grasshopper SDK
GH_SettingsServer..::..GetValue Method (String, String)
GH_SettingsServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string GetValue(
    string key,
    string default
)
Visual Basic
Public Function GetValue ( _
    key As String, _
    default As String _
) As String

Parameters

key
Type: System..::..String
default
Type: System..::..String

See Also

GH_SettingsServer Class
GetValue Overload
Grasshopper.Kernel Namespace


Read Method

[image]

Grasshopper SDK
GH_SettingsServer..::..Read Method
GH_SettingsServer Class See Also Send Feedback
Low-level deserializer.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Read(
    GH_IReader reader
)
Visual Basic
Public Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader
Object to read from.

Return Value

True on success, false on failure.

Implements

GH_ISerializable..::..Read(GH_IReader)

See Also

GH_SettingsServer Class
Grasshopper.Kernel Namespace


SetValue Method

[image] [image]

Grasshopper SDK
GH_SettingsServer..::..SetValue Method
GH_SettingsServer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue(String) |
Public method | SetValue(String, Boolean) |
Public method | SetValue(String, Byte) |
Public method | SetValue(String, DateTime) |
Public method | SetValue(String, Double) |
Public method | SetValue(String, Color) |
Public method | SetValue(String, Point) |
Public method | SetValue(String, Rectangle) |
Public method | SetValue(String, Size) |
Public method | SetValue(String, Int32) |
Public method | SetValue(String, String) |

See Also

GH_SettingsServer Class
GH_SettingsServer Members
Grasshopper.Kernel Namespace


SetValue Method (String)

[image]

Grasshopper SDK
GH_SettingsServer..::..SetValue Method (String)
GH_SettingsServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SetValue(
    string key
)
Visual Basic
Public Sub SetValue ( _
    key As String _
)

Parameters

key
Type: System..::..String

See Also

GH_SettingsServer Class
SetValue Overload
Grasshopper.Kernel Namespace


SetValue Method (String, Boolean)

[image]

Grasshopper SDK
GH_SettingsServer..::..SetValue Method (String, Boolean)
GH_SettingsServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SetValue(
    string key,
    bool value
)
Visual Basic
Public Sub SetValue ( _
    key As String, _
    value As Boolean _
)

Parameters

key
Type: System..::..String
value
Type: System..::..Boolean

See Also

GH_SettingsServer Class
SetValue Overload
Grasshopper.Kernel Namespace


SetValue Method (String, Byte)

[image]

Grasshopper SDK
GH_SettingsServer..::..SetValue Method (String, Byte)
GH_SettingsServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SetValue(
    string key,
    byte value
)
Visual Basic
Public Sub SetValue ( _
    key As String, _
    value As Byte _
)

Parameters

key
Type: System..::..String
value
Type: System..::..Byte

See Also

GH_SettingsServer Class
SetValue Overload
Grasshopper.Kernel Namespace


SetValue Method (String, DateTime)

[image]

Grasshopper SDK
GH_SettingsServer..::..SetValue Method (String, DateTime)
GH_SettingsServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SetValue(
    string key,
    DateTime value
)
Visual Basic
Public Sub SetValue ( _
    key As String, _
    value As DateTime _
)

Parameters

key
Type: System..::..String
value
Type: System..::..DateTime

See Also

GH_SettingsServer Class
SetValue Overload
Grasshopper.Kernel Namespace


SetValue Method (String, Double)

[image]

Grasshopper SDK
GH_SettingsServer..::..SetValue Method (String, Double)
GH_SettingsServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SetValue(
    string key,
    double value
)
Visual Basic
Public Sub SetValue ( _
    key As String, _
    value As Double _
)

Parameters

key
Type: System..::..String
value
Type: System..::..Double

See Also

GH_SettingsServer Class
SetValue Overload
Grasshopper.Kernel Namespace


SetValue Method (String, Color)

[image]

Grasshopper SDK
GH_SettingsServer..::..SetValue Method (String, Color)
GH_SettingsServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SetValue(
    string key,
    Color value
)
Visual Basic
Public Sub SetValue ( _
    key As String, _
    value As Color _
)

Parameters

key
Type: System..::..String
value
Type: System.Drawing..::..Color

See Also

GH_SettingsServer Class
SetValue Overload
Grasshopper.Kernel Namespace


SetValue Method (String, Point)

[image]

Grasshopper SDK
GH_SettingsServer..::..SetValue Method (String, Point)
GH_SettingsServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SetValue(
    string key,
    Point value
)
Visual Basic
Public Sub SetValue ( _
    key As String, _
    value As Point _
)

Parameters

key
Type: System..::..String
value
Type: System.Drawing..::..Point

See Also

GH_SettingsServer Class
SetValue Overload
Grasshopper.Kernel Namespace


SetValue Method (String, Rectangle)

[image]

Grasshopper SDK
GH_SettingsServer..::..SetValue Method (String, Rectangle)
GH_SettingsServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SetValue(
    string key,
    Rectangle value
)
Visual Basic
Public Sub SetValue ( _
    key As String, _
    value As Rectangle _
)

Parameters

key
Type: System..::..String
value
Type: System.Drawing..::..Rectangle

See Also

GH_SettingsServer Class
SetValue Overload
Grasshopper.Kernel Namespace


SetValue Method (String, Size)

[image]

Grasshopper SDK
GH_SettingsServer..::..SetValue Method (String, Size)
GH_SettingsServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SetValue(
    string key,
    Size value
)
Visual Basic
Public Sub SetValue ( _
    key As String, _
    value As Size _
)

Parameters

key
Type: System..::..String
value
Type: System.Drawing..::..Size

See Also

GH_SettingsServer Class
SetValue Overload
Grasshopper.Kernel Namespace


SetValue Method (String, Int32)

[image]

Grasshopper SDK
GH_SettingsServer..::..SetValue Method (String, Int32)
GH_SettingsServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SetValue(
    string key,
    int value
)
Visual Basic
Public Sub SetValue ( _
    key As String, _
    value As Integer _
)

Parameters

key
Type: System..::..String
value
Type: System..::..Int32

See Also

GH_SettingsServer Class
SetValue Overload
Grasshopper.Kernel Namespace


SetValue Method (String, String)

[image]

Grasshopper SDK
GH_SettingsServer..::..SetValue Method (String, String)
GH_SettingsServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SetValue(
    string key,
    string value
)
Visual Basic
Public Sub SetValue ( _
    key As String, _
    value As String _
)

Parameters

key
Type: System..::..String
value
Type: System..::..String

See Also

GH_SettingsServer Class
SetValue Overload
Grasshopper.Kernel Namespace


ShowSettingsBrowser Method

[image]

Grasshopper SDK
GH_SettingsServer..::..ShowSettingsBrowser Method
GH_SettingsServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ShowSettingsBrowser(
    IWin32Window parent
)
Visual Basic
Public Sub ShowSettingsBrowser ( _
    parent As IWin32Window _
)

Parameters

parent
Type: System.Windows.Forms..::..IWin32Window

See Also

GH_SettingsServer Class
Grasshopper.Kernel Namespace


Write Method

[image]

Grasshopper SDK
GH_SettingsServer..::..Write Method
GH_SettingsServer Class See Also Send Feedback
Low-level serializer.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Write(
    GH_IWriter writer
)
Visual Basic
Public Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter
Object to write with. Writer must represent an empty archive chunk.

Return Value

True on success, false on failure.

Implements

GH_ISerializable..::..Write(GH_IWriter)

See Also

GH_SettingsServer Class
Grasshopper.Kernel Namespace


WritePersistentSettings Method

[image]

Grasshopper SDK
GH_SettingsServer..::..WritePersistentSettings Method
GH_SettingsServer Class See Also Send Feedback
Store all settings in the xml file now. You must call this function if you want the current settings to persist between sessions.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void WritePersistentSettings()
Visual Basic
Public Sub WritePersistentSettings

See Also

GH_SettingsServer Class
Grasshopper.Kernel Namespace


GH_SettingsServer Properties

[image] [image]

Grasshopper SDK
GH_SettingsServer Properties
GH_SettingsServer Class See Also Send Feedback

The GH_SettingsServer type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the total number of settings stored in this database.
Public property | DatabaseName | Gets the name of this settings database.

See Also

GH_SettingsServer Class
Grasshopper.Kernel Namespace


Count Property

[image]

Grasshopper SDK
GH_SettingsServer..::..Count Property
GH_SettingsServer Class See Also Send Feedback
Gets the total number of settings stored in this database.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_SettingsServer.Count"]

See Also

GH_SettingsServer Class
Grasshopper.Kernel Namespace


DatabaseName Property

[image]

Grasshopper SDK
GH_SettingsServer..::..DatabaseName Property
GH_SettingsServer Class See Also Send Feedback
Gets the name of this settings database.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string DatabaseName { get; }
Visual Basic
Public ReadOnly Property DatabaseName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_SettingsServer.DatabaseName"]

See Also

GH_SettingsServer Class
Grasshopper.Kernel Namespace


GH_SettingsType Enumeration

[image]

Grasshopper SDK
GH_SettingsType Enumeration
See Also Send Feedback
Lists all the data types available in the GH_SettingsServer class.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_SettingsType
Visual Basic
Public Enumeration GH_SettingsType

Members

Member name | Value | Description
_unknown | -1 |
_null | 0 |
_boolean | 1 |
_byte | 2 |
_integer | 3 |
_double | 4 |
_string | 6 |
_date | 7 |
_color | 8 |
_point | 9 |
_size | 10 |
_rectangle | 11 |

See Also

Grasshopper.Kernel Namespace


GH_SolutionEventArgs Class

[image]

Grasshopper SDK
GH_SolutionEventArgs Class
Members See Also Send Feedback
Event arguments used for Document Solution events.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_SolutionEventArgs : EventArgs
Visual Basic
Public Class GH_SolutionEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Grasshopper.Kernel..::..GH_SolutionEventArgs

See Also

GH_SolutionEventArgs Members
Grasshopper.Kernel Namespace


GH_SolutionEventArgs Members

[image] [image]

Grasshopper SDK
GH_SolutionEventArgs Members
GH_SolutionEventArgs Class Properties See Also Send Feedback

The GH_SolutionEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Document | Gets the document that raised the event, should be the same as the "sender" parameter in the event handler.
Public property | Duration | Gets the duration for this solution. The duration is a more accurate measure than EndTime-StartTime.
Public property | EndTime | Obsolete. Gets the time when the current solution completed. If the solution hasn't completed yet this field will be DateTime.MinValue.
Public property | StartTime | Gets the time when the current solution began.

See Also

GH_SolutionEventArgs Class
Grasshopper.Kernel Namespace


GH_SolutionEventArgs Properties

[image] [image]

Grasshopper SDK
GH_SolutionEventArgs Properties
GH_SolutionEventArgs Class See Also Send Feedback

The GH_SolutionEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Document | Gets the document that raised the event, should be the same as the "sender" parameter in the event handler.
Public property | Duration | Gets the duration for this solution. The duration is a more accurate measure than EndTime-StartTime.
Public property | EndTime | Obsolete. Gets the time when the current solution completed. If the solution hasn't completed yet this field will be DateTime.MinValue.
Public property | StartTime | Gets the time when the current solution began.

See Also

GH_SolutionEventArgs Class
Grasshopper.Kernel Namespace


Document Property

[image]

Grasshopper SDK
GH_SolutionEventArgs..::..Document Property
GH_SolutionEventArgs Class See Also Send Feedback
Gets the document that raised the event, should be the same as the "sender" parameter in the event handler.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Document Document { get; }
Visual Basic
Public ReadOnly Property Document As GH_Document
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_SolutionEventArgs.Document"]

See Also

GH_SolutionEventArgs Class
Grasshopper.Kernel Namespace


Duration Property

[image]

Grasshopper SDK
GH_SolutionEventArgs..::..Duration Property
GH_SolutionEventArgs Class See Also Send Feedback
Gets the duration for this solution. The duration is a more accurate measure than EndTime-StartTime.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public TimeSpan Duration { get; }
Visual Basic
Public ReadOnly Property Duration As TimeSpan
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_SolutionEventArgs.Duration"]

See Also

GH_SolutionEventArgs Class
Grasshopper.Kernel Namespace


EndTime Property

[image]

Grasshopper SDK
GH_SolutionEventArgs..::..EndTime Property
GH_SolutionEventArgs Class See Also Send Feedback
Gets the time when the current solution completed. If the solution hasn't completed yet this field will be DateTime.MinValue.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
[ObsoleteAttribute("This property is obsolete")]
public DateTime EndTime { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete")> _
Public ReadOnly Property EndTime As DateTime
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_SolutionEventArgs.EndTime"]

See Also

GH_SolutionEventArgs Class
Grasshopper.Kernel Namespace


StartTime Property

[image]

Grasshopper SDK
GH_SolutionEventArgs..::..StartTime Property
GH_SolutionEventArgs Class See Also Send Feedback
Gets the time when the current solution began.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public DateTime StartTime { get; }
Visual Basic
Public ReadOnly Property StartTime As DateTime
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_SolutionEventArgs.StartTime"]

See Also

GH_SolutionEventArgs Class
Grasshopper.Kernel Namespace


GH_SolutionExpiredEventArgs Class

[image]

Grasshopper SDK
GH_SolutionExpiredEventArgs Class
Members See Also Send Feedback
Arguments for solution events.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_SolutionExpiredEventArgs : EventArgs
Visual Basic
Public Class GH_SolutionExpiredEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Grasshopper.Kernel..::..GH_SolutionExpiredEventArgs

See Also

GH_SolutionExpiredEventArgs Members
Grasshopper.Kernel Namespace


GH_SolutionExpiredEventArgs Members

[image] [image]

Grasshopper SDK
GH_SolutionExpiredEventArgs Members
GH_SolutionExpiredEventArgs Class Constructors Properties See Also Send Feedback

The GH_SolutionExpiredEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GH_SolutionExpiredEventArgs | Initializes a new instance of the GH_SolutionExpiredEventArgs class

Properties

 | Name | Description
Public property | Recompute |

See Also

GH_SolutionExpiredEventArgs Class
Grasshopper.Kernel Namespace


GH_SolutionExpiredEventArgs Constructor

[image]

Grasshopper SDK
GH_SolutionExpiredEventArgs Constructor
GH_SolutionExpiredEventArgs Class See Also Send Feedback
Initializes a new instance of the GH_SolutionExpiredEventArgs class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_SolutionExpiredEventArgs(
    bool eRecompute
)
Visual Basic
Public Sub New ( _
    eRecompute As Boolean _
)

Parameters

eRecompute
Type: System..::..Boolean

See Also

GH_SolutionExpiredEventArgs Class
Grasshopper.Kernel Namespace


GH_SolutionExpiredEventArgs Properties

[image] [image]

Grasshopper SDK
GH_SolutionExpiredEventArgs Properties
GH_SolutionExpiredEventArgs Class See Also Send Feedback

The GH_SolutionExpiredEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Recompute |

See Also

GH_SolutionExpiredEventArgs Class
Grasshopper.Kernel Namespace


Recompute Property

[image]

Grasshopper SDK
GH_SolutionExpiredEventArgs..::..Recompute Property
GH_SolutionExpiredEventArgs Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Recompute { get; }
Visual Basic
Public ReadOnly Property Recompute As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_SolutionExpiredEventArgs.Recompute"]

See Also

GH_SolutionExpiredEventArgs Class
Grasshopper.Kernel Namespace


GH_SolutionMode Enumeration

[image]

Grasshopper SDK
GH_SolutionMode Enumeration
See Also Send Feedback
Enumerates all solution modes.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_SolutionMode
Visual Basic
Public Enumeration GH_SolutionMode

Members

Member name | Value | Description
Default | 0 | Represents the standard mode, error messages are displayed in custom forms.
CommandLine | 1 | Represents reduced feedback mode. All messages are send to the Rhino command history, which is thread safe.
Silent | 2 | Represents null feedback mode. No messages are send to any GUI.

See Also

Grasshopper.Kernel Namespace


GH_SolutionPhase Enumeration

[image]

Grasshopper SDK
GH_SolutionPhase Enumeration
See Also Send Feedback
The Phase flags are used to track object states during solutions.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_SolutionPhase
Visual Basic
Public Enumeration GH_SolutionPhase

Members

Member name | Value | Description
Blank | 0 | There is no data available in this object. This object will be solved next time a solution begins.
Collecting | 1 | This object is currently in the process of collecting data
Collected | 2 | This object has finished collecting all data and is ready for computation.
Computing | 3 | This object is currently in the process of computing new data
Computed | 4 | This object has successfully completed data computation and it will be skipped in the next solution unless it expires in the meantime. This is the final step in a successful solution cycle.
Failed | 10 | This object has failed to successfully complete the data computation stage. A new attempt at solving it will be made when the next solution starts. This is the final step in an unsuccessful solution cycle.

See Also

Grasshopper.Kernel Namespace


GH_SolutionSpan Structure

[image]

Grasshopper SDK
GH_SolutionSpan Structure
Members See Also Send Feedback
Represents the time interval for a GH_Document solution.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public struct GH_SolutionSpan
Visual Basic
Public Structure GH_SolutionSpan

See Also

GH_SolutionSpan Members
Grasshopper.Kernel Namespace


GH_SolutionSpan Members

[image] [image]

Grasshopper SDK
GH_SolutionSpan Members
GH_SolutionSpan Structure Constructors Properties See Also Send Feedback

The GH_SolutionSpan type exposes the following members.

Constructors

 | Name | Description
Public method | GH_SolutionSpan | Creates a new instance of the GH_SolutionSpan structure.

Properties

 | Name | Description
Public property | EndTime | Gets the time at which this solution was finished.
Public property | StartTime | Gets the time at which this solution was started.

See Also

GH_SolutionSpan Structure
Grasshopper.Kernel Namespace


GH_SolutionSpan Constructor

[image]

Grasshopper SDK
GH_SolutionSpan Constructor
GH_SolutionSpan Structure See Also Send Feedback
Creates a new instance of the GH_SolutionSpan structure.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_SolutionSpan(
    DateTime t0,
    DateTime t1
)
Visual Basic
Public Sub New ( _
    t0 As DateTime, _
    t1 As DateTime _
)

Parameters

t0
Type: System..::..DateTime
Time of solution start.
t1
Type: System..::..DateTime
Time of solution end.

See Also

GH_SolutionSpan Structure
Grasshopper.Kernel Namespace


GH_SolutionSpan Properties

[image] [image]

Grasshopper SDK
GH_SolutionSpan Properties
GH_SolutionSpan Structure See Also Send Feedback

The GH_SolutionSpan type exposes the following members.

Properties

 | Name | Description
Public property | EndTime | Gets the time at which this solution was finished.
Public property | StartTime | Gets the time at which this solution was started.

See Also

GH_SolutionSpan Structure
Grasshopper.Kernel Namespace


EndTime Property

[image]

Grasshopper SDK
GH_SolutionSpan..::..EndTime Property
GH_SolutionSpan Structure See Also Send Feedback
Gets the time at which this solution was finished.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public DateTime EndTime { get; }
Visual Basic
Public ReadOnly Property EndTime As DateTime
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_SolutionSpan.EndTime"]

See Also

GH_SolutionSpan Structure
Grasshopper.Kernel Namespace


StartTime Property

[image]

Grasshopper SDK
GH_SolutionSpan..::..StartTime Property
GH_SolutionSpan Structure See Also Send Feedback
Gets the time at which this solution was started.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public DateTime StartTime { get; }
Visual Basic
Public ReadOnly Property StartTime As DateTime
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_SolutionSpan.StartTime"]

See Also

GH_SolutionSpan Structure
Grasshopper.Kernel Namespace


GH_State Class

[image]

Grasshopper SDK
GH_State Class
Members See Also Send Feedback
Represents a single recorded document state. A state contains values for an arbitrary set of objects inside the document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_State : GH_ISerializable
Visual Basic
Public Class GH_State _
    Implements GH_ISerializable

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_State

See Also

GH_State Members
Grasshopper.Kernel Namespace


GH_State Members

[image] [image]

Grasshopper SDK
GH_State Members
GH_State Class Constructors Methods Properties See Also Send Feedback

The GH_State type exposes the following members.

Constructors

 | Name | Description
Public method | GH_State()()()() | Initializes a new instance of the GH_State class
Public method | GH_State(GH_State) | Initializes a new instance of the GH_State class

Methods

 | Name | Description
Public method | AddStateObject | Append a new object to the database.
Public method | ClearStates | Removes all items from the state database.
Public method | CreateStateFromDocument | Creates a state database from a document.
Public method | Read |
Public method | RemoveStateObject | Remove an object from the database.
Public method | Write |

Properties

 | Name | Description
Public property | Data[([( Guid])]) | Gets the state data stored under the specified ID
Public property | Data[([( Int32])]) | Gets the state data stored under the specified index
Public property | LastModified | Gets the date at which this state was last modified.
Public property | Name | Gets or sets the name of this state.
Public property | StateCount | Gets the number of items stored in the state database.
Public property | StateData | Gets a pointer to the internal database of states.

See Also

GH_State Class
Grasshopper.Kernel Namespace


GH_State Constructor

[image] [image]

Grasshopper SDK
GH_State Constructor
GH_State Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_State()()()() | Initializes a new instance of the GH_State class
Public method | GH_State(GH_State) | Initializes a new instance of the GH_State class

See Also

GH_State Class
GH_State Members
Grasshopper.Kernel Namespace


GH_State Constructor

[image]

Grasshopper SDK
GH_State Constructor
GH_State Class See Also Send Feedback
Initializes a new instance of the GH_State class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_State()
Visual Basic
Public Sub New

See Also

GH_State Class
GH_State Overload
Grasshopper.Kernel Namespace


GH_State Constructor (GH_State)

[image]

Grasshopper SDK
GH_State Constructor (GH_State)
GH_State Class See Also Send Feedback
Initializes a new instance of the GH_State class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_State(
    GH_State other
)
Visual Basic
Public Sub New ( _
    other As GH_State _
)

Parameters

other
Type: Grasshopper.Kernel..::..GH_State

See Also

GH_State Class
GH_State Overload
Grasshopper.Kernel Namespace


GH_State Methods

[image] [image]

Grasshopper SDK
GH_State Methods
GH_State Class See Also Send Feedback

The GH_State type exposes the following members.

Methods

 | Name | Description
Public method | AddStateObject | Append a new object to the database.
Public method | ClearStates | Removes all items from the state database.
Public method | CreateStateFromDocument | Creates a state database from a document.
Public method | Read |
Public method | RemoveStateObject | Remove an object from the database.
Public method | Write |

See Also

GH_State Class
Grasshopper.Kernel Namespace


AddStateObject Method

[image]

Grasshopper SDK
GH_State..::..AddStateObject Method
GH_State Class See Also Send Feedback
Append a new object to the database.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddStateObject(
    IGH_StateAwareObject obj,
    Guid obj_id
)
Visual Basic
Public Sub AddStateObject ( _
    obj As IGH_StateAwareObject, _
    obj_id As Guid _
)

Parameters

obj
Type: Grasshopper.Kernel..::..IGH_StateAwareObject
Object to append.
obj_id
Type: System..::..Guid
Instance GUID of object in document.

See Also

GH_State Class
Grasshopper.Kernel Namespace


ClearStates Method

[image]

Grasshopper SDK
GH_State..::..ClearStates Method
GH_State Class See Also Send Feedback
Removes all items from the state database.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ClearStates()
Visual Basic
Public Sub ClearStates

See Also

GH_State Class
Grasshopper.Kernel Namespace


CreateStateFromDocument Method

[image]

Grasshopper SDK
GH_State..::..CreateStateFromDocument Method
GH_State Class See Also Send Feedback
Creates a state database from a document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int CreateStateFromDocument(
    GH_Document doc
)
Visual Basic
Public Function CreateStateFromDocument ( _
    doc As GH_Document _
) As Integer

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document
Document to parse.

Return Value

Number of states saved or -1 if the user aborted.

See Also

GH_State Class
Grasshopper.Kernel Namespace


Read Method

[image]

Grasshopper SDK
GH_State..::..Read Method
GH_State Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Read(
    GH_IReader reader
)
Visual Basic
Public Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

Implements

GH_ISerializable..::..Read(GH_IReader)

See Also

GH_State Class
Grasshopper.Kernel Namespace


RemoveStateObject Method

[image]

Grasshopper SDK
GH_State..::..RemoveStateObject Method
GH_State Class See Also Send Feedback
Remove an object from the database.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RemoveStateObject(
    Guid obj_id
)
Visual Basic
Public Sub RemoveStateObject ( _
    obj_id As Guid _
)

Parameters

obj_id
Type: System..::..Guid

See Also

GH_State Class
Grasshopper.Kernel Namespace


Write Method

[image]

Grasshopper SDK
GH_State..::..Write Method
GH_State Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Write(
    GH_IWriter writer
)
Visual Basic
Public Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

Implements

GH_ISerializable..::..Write(GH_IWriter)

See Also

GH_State Class
Grasshopper.Kernel Namespace


GH_State Properties

[image] [image]

Grasshopper SDK
GH_State Properties
GH_State Class See Also Send Feedback

The GH_State type exposes the following members.

Properties

 | Name | Description
Public property | Data[([( Guid])]) | Gets the state data stored under the specified ID
Public property | Data[([( Int32])]) | Gets the state data stored under the specified index
Public property | LastModified | Gets the date at which this state was last modified.
Public property | Name | Gets or sets the name of this state.
Public property | StateCount | Gets the number of items stored in the state database.
Public property | StateData | Gets a pointer to the internal database of states.

See Also

GH_State Class
Grasshopper.Kernel Namespace


Data Property

[image] [image]

Grasshopper SDK
GH_State..::..Data Property
GH_State Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Data[([( Guid])]) | Gets the state data stored under the specified ID
Public property | Data[([( Int32])]) | Gets the state data stored under the specified index

See Also

GH_State Class
GH_State Members
Grasshopper.Kernel Namespace


Data Property (Guid)

[image]

Grasshopper SDK
GH_State..::..Data Property (Guid)
GH_State Class See Also Send Feedback
Gets the state data stored under the specified ID

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string this[
    Guid id
] { get; }
Visual Basic
Public ReadOnly Default Property Data ( _
    id As Guid _
) As String
    Get

Parameters

id
Type: System..::..Guid

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_State.Data(System.Guid)"]

See Also

GH_State Class
Data Overload
Grasshopper.Kernel Namespace


Data Property (Int32)

[image]

Grasshopper SDK
GH_State..::..Data Property (Int32)
GH_State Class See Also Send Feedback
Gets the state data stored under the specified index

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Data ( _
    index As Integer _
) As String
    Get

Parameters

index
Type: System..::..Int32

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_State.Data(System.Int32)"]

See Also

GH_State Class
Data Overload
Grasshopper.Kernel Namespace


LastModified Property

[image]

Grasshopper SDK
GH_State..::..LastModified Property
GH_State Class See Also Send Feedback
Gets the date at which this state was last modified.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public DateTime LastModified { get; }
Visual Basic
Public ReadOnly Property LastModified As DateTime
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_State.LastModified"]

See Also

GH_State Class
Grasshopper.Kernel Namespace


Name Property

[image]

Grasshopper SDK
GH_State..::..Name Property
GH_State Class See Also Send Feedback
Gets or sets the name of this state.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_State.Name"]

See Also

GH_State Class
Grasshopper.Kernel Namespace


StateCount Property

[image]

Grasshopper SDK
GH_State..::..StateCount Property
GH_State Class See Also Send Feedback
Gets the number of items stored in the state database.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int StateCount { get; }
Visual Basic
Public ReadOnly Property StateCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_State.StateCount"]

See Also

GH_State Class
Grasshopper.Kernel Namespace


StateData Property

[image]

Grasshopper SDK
GH_State..::..StateData Property
GH_State Class See Also Send Feedback
Gets a pointer to the internal database of states.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public SortedList<Guid, string> StateData { get; }
Visual Basic
Public ReadOnly Property StateData As SortedList(Of Guid, String)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_State.StateData"]

See Also

GH_State Class
Grasshopper.Kernel Namespace


GH_StateServer Class

[image]

Grasshopper SDK
GH_StateServer Class
Members See Also Send Feedback
Maintains all the recorded states for this document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_StateServer : List<GH_State>,
    GH_ISerializable
Visual Basic
Public Class GH_StateServer _
    Inherits List(Of GH_State) _
    Implements GH_ISerializable

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' GH_State >)>)>
Grasshopper.Kernel..::..GH_StateServer

See Also

GH_StateServer Members
Grasshopper.Kernel Namespace


GH_StateServer Members

[image] [image]

Grasshopper SDK
GH_StateServer Members
GH_StateServer Class Constructors Methods Properties See Also Send Feedback

The GH_StateServer type exposes the following members.

Constructors

 | Name | Description
Public method | GH_StateServer | Initializes a new instance of the GH_StateServer class

Methods

 | Name | Description
Public method | NewStateFromDocument | Displays UI for new state creation. If the user aborts, then null is returned. If the user successfully defines a new state, it is appended to this server.
Public method | Read |
Public method | RemoveState | Remove a certain state. This method adds an undo record to the document.
Public method | RestoreState(Int32, Int32%, Int32%) | Restore a certain state.
Public method | RestoreState(String, Int32%, Int32%) | Restore a certain state.
Public method | RestoreState(Int32, Boolean, Int32%, Int32%) | Restore a certain state.
Public method | Write |

Properties

 | Name | Description
Public property | Names | Gets a list of all the state names in this server.
Public property | Owner | Gets the document that owns this server.

See Also

GH_StateServer Class
Grasshopper.Kernel Namespace


GH_StateServer Constructor

[image]

Grasshopper SDK
GH_StateServer Constructor
GH_StateServer Class See Also Send Feedback
Initializes a new instance of the GH_StateServer class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_StateServer(
    GH_Document owner
)
Visual Basic
Public Sub New ( _
    owner As GH_Document _
)

Parameters

owner
Type: Grasshopper.Kernel..::..GH_Document

See Also

GH_StateServer Class
Grasshopper.Kernel Namespace


GH_StateServer Methods

[image] [image]

Grasshopper SDK
GH_StateServer Methods
GH_StateServer Class See Also Send Feedback

The GH_StateServer type exposes the following members.

Methods

 | Name | Description
Public method | NewStateFromDocument | Displays UI for new state creation. If the user aborts, then null is returned. If the user successfully defines a new state, it is appended to this server.
Public method | Read |
Public method | RemoveState | Remove a certain state. This method adds an undo record to the document.
Public method | RestoreState(Int32, Int32%, Int32%) | Restore a certain state.
Public method | RestoreState(String, Int32%, Int32%) | Restore a certain state.
Public method | RestoreState(Int32, Boolean, Int32%, Int32%) | Restore a certain state.
Public method | Write |

See Also

GH_StateServer Class
Grasshopper.Kernel Namespace


NewStateFromDocument Method

[image]

Grasshopper SDK
GH_StateServer..::..NewStateFromDocument Method
GH_StateServer Class See Also Send Feedback
Displays UI for new state creation. If the user aborts, then null is returned. If the user successfully defines a new state, it is appended to this server.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_State NewStateFromDocument()
Visual Basic
Public Function NewStateFromDocument As GH_State

See Also

GH_StateServer Class
Grasshopper.Kernel Namespace


Read Method

[image]

Grasshopper SDK
GH_StateServer..::..Read Method
GH_StateServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Read(
    GH_IReader reader
)
Visual Basic
Public Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

Implements

GH_ISerializable..::..Read(GH_IReader)

See Also

GH_StateServer Class
Grasshopper.Kernel Namespace


RemoveState Method

[image]

Grasshopper SDK
GH_StateServer..::..RemoveState Method
GH_StateServer Class See Also Send Feedback
Remove a certain state. This method adds an undo record to the document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool RemoveState(
    int index
)
Visual Basic
Public Function RemoveState ( _
    index As Integer _
) As Boolean

Parameters

index
Type: System..::..Int32
Index of state to remove.

Return Value

True on success, false on failure.

See Also

GH_StateServer Class
Grasshopper.Kernel Namespace


RestoreState Method

[image] [image]

Grasshopper SDK
GH_StateServer..::..RestoreState Method
GH_StateServer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RestoreState(Int32, Int32%, Int32%) | Restore a certain state.
Public method | RestoreState(String, Int32%, Int32%) | Restore a certain state.
Public method | RestoreState(Int32, Boolean, Int32%, Int32%) | Restore a certain state.

See Also

GH_StateServer Class
GH_StateServer Members
Grasshopper.Kernel Namespace


RestoreState Method (Int32, Int32, Int32)

[image]

Grasshopper SDK
GH_StateServer..::..RestoreState Method (Int32, Int32%, Int32%)
GH_StateServer Class See Also Send Feedback
Restore a certain state.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool RestoreState(
    int index,
    out int restored_objects,
    out int missing_objects
)
Visual Basic
Public Function RestoreState ( _
    index As Integer, _
    <OutAttribute> ByRef restored_objects As Integer, _
    <OutAttribute> ByRef missing_objects As Integer _
) As Boolean

Parameters

index
Type: System..::..Int32
Index of state to restore.
restored_objects
Type: System..::..Int32 %
Number of objects successfully restored.
missing_objects
Type: System..::..Int32 %
Number of objects that could not be found.

Return Value

True on success, false on failure.

See Also

GH_StateServer Class
RestoreState Overload
Grasshopper.Kernel Namespace


RestoreState Method (String, Int32, Int32)

[image]

Grasshopper SDK
GH_StateServer..::..RestoreState Method (String, Int32%, Int32%)
GH_StateServer Class See Also Send Feedback
Restore a certain state.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool RestoreState(
    string name,
    out int restored_objects,
    out int missing_objects
)
Visual Basic
Public Function RestoreState ( _
    name As String, _
    <OutAttribute> ByRef restored_objects As Integer, _
    <OutAttribute> ByRef missing_objects As Integer _
) As Boolean

Parameters

name
Type: System..::..String
Name of state to restore. Name is case-sensitive.
restored_objects
Type: System..::..Int32 %
Number of objects successfully restored.
missing_objects
Type: System..::..Int32 %
Number of objects that could not be found.

Return Value

True on success, false on failure.

See Also

GH_StateServer Class
RestoreState Overload
Grasshopper.Kernel Namespace


RestoreState Method (Int32, Boolean, Int32, Int32)

[image]

Grasshopper SDK
GH_StateServer..::..RestoreState Method (Int32, Boolean, Int32%, Int32%)
GH_StateServer Class See Also Send Feedback
Restore a certain state.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool RestoreState(
    int index,
    bool recompute,
    out int restored_objects,
    out int missing_objects
)
Visual Basic
Public Function RestoreState ( _
    index As Integer, _
    recompute As Boolean, _
    <OutAttribute> ByRef restored_objects As Integer, _
    <OutAttribute> ByRef missing_objects As Integer _
) As Boolean

Parameters

index
Type: System..::..Int32
Index of state to restore.
recompute
Type: System..::..Boolean
If True, a new solution will be started right away.
restored_objects
Type: System..::..Int32 %
Number of objects successfully restored.
missing_objects
Type: System..::..Int32 %
Number of objects that could not be found.

Return Value

True on success, false on failure.

See Also

GH_StateServer Class
RestoreState Overload
Grasshopper.Kernel Namespace


Write Method

[image]

Grasshopper SDK
GH_StateServer..::..Write Method
GH_StateServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Write(
    GH_IWriter writer
)
Visual Basic
Public Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

Implements

GH_ISerializable..::..Write(GH_IWriter)

See Also

GH_StateServer Class
Grasshopper.Kernel Namespace


GH_StateServer Properties

[image] [image]

Grasshopper SDK
GH_StateServer Properties
GH_StateServer Class See Also Send Feedback

The GH_StateServer type exposes the following members.

Properties

 | Name | Description
Public property | Names | Gets a list of all the state names in this server.
Public property | Owner | Gets the document that owns this server.

See Also

GH_StateServer Class
Grasshopper.Kernel Namespace


Names Property

[image]

Grasshopper SDK
GH_StateServer..::..Names Property
GH_StateServer Class See Also Send Feedback
Gets a list of all the state names in this server.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<string> Names { get; }
Visual Basic
Public ReadOnly Property Names As List(Of String)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_StateServer.Names"]

See Also

GH_StateServer Class
Grasshopper.Kernel Namespace


Owner Property

[image]

Grasshopper SDK
GH_StateServer..::..Owner Property
GH_StateServer Class See Also Send Feedback
Gets the document that owns this server.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Document Owner { get; }
Visual Basic
Public ReadOnly Property Owner As GH_Document
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_StateServer.Owner"]

See Also

GH_StateServer Class
Grasshopper.Kernel Namespace


GH_StateTag Class

[image]

Grasshopper SDK
GH_StateTag Class
Members See Also Send Feedback
Abstract implementation of the IGH_StateTag interface. Derive from this class rather than implementing IGH_StateTag.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract class GH_StateTag : IGH_StateTag
Visual Basic
Public MustInherit Class GH_StateTag _
    Implements IGH_StateTag

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_StateTag

See Also

GH_StateTag Members
Grasshopper.Kernel Namespace


GH_StateTag Members

[image] [image]

Grasshopper SDK
GH_StateTag Members
GH_StateTag Class Constructors Methods Properties See Also Send Feedback

The GH_StateTag type exposes the following members.

Constructors

 | Name | Description
Protected method | GH_StateTag | Initializes a new instance of the GH_StateTag class

Methods

 | Name | Description
Public method | Render |
Protected method | RenderFreeformIcon | Render a filled path with default shading.
Protected method | RenderTagBlankIcon(Graphics) | Render a blank rectangle icon.
Protected method | RenderTagBlankIcon(Graphics, GH_StateTag..::..DrawCallback) | Render a blank rectangle icon.
Protected method | RenderTagPolygonIcon | Render a filled polygon with default shading.

Properties

 | Name | Description
Public property | Description |
Public property | Icon |
Public property | Name |
Public property | Stage | Gets or sets the stage rectangle for this tag.
Public property | StateDescription | Gets or sets the state description for this tag.

See Also

GH_StateTag Class
Grasshopper.Kernel Namespace


GH_StateTag Constructor

[image]

Grasshopper SDK
GH_StateTag Constructor
GH_StateTag Class See Also Send Feedback
Initializes a new instance of the GH_StateTag class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_StateTag()
Visual Basic
Protected Sub New

See Also

GH_StateTag Class
Grasshopper.Kernel Namespace


GH_StateTag Methods

[image] [image]

Grasshopper SDK
GH_StateTag Methods
GH_StateTag Class See Also Send Feedback

The GH_StateTag type exposes the following members.

Methods

 | Name | Description
Public method | Render |
Protected method | RenderFreeformIcon | Render a filled path with default shading.
Protected method | RenderTagBlankIcon(Graphics) | Render a blank rectangle icon.
Protected method | RenderTagBlankIcon(Graphics, GH_StateTag..::..DrawCallback) | Render a blank rectangle icon.
Protected method | RenderTagPolygonIcon | Render a filled polygon with default shading.

See Also

GH_StateTag Class
Grasshopper.Kernel Namespace


Render Method

[image]

Grasshopper SDK
GH_StateTag..::..Render Method
GH_StateTag Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual void Render(
    Graphics graphics
)
Visual Basic
Public Overridable Sub Render ( _
    graphics As Graphics _
)

Parameters

graphics
Type: System.Drawing..::..Graphics

Implements

IGH_StateTag..::..Render(Graphics)

See Also

GH_StateTag Class
Grasshopper.Kernel Namespace


RenderFreeformIcon Method

[image]

Grasshopper SDK
GH_StateTag..::..RenderFreeformIcon Method
GH_StateTag Class See Also Send Feedback
Render a filled path with default shading.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected void RenderFreeformIcon(
    Graphics graphics,
    GraphicsPath path
)
Visual Basic
Protected Sub RenderFreeformIcon ( _
    graphics As Graphics, _
    path As GraphicsPath _
)

Parameters

graphics
Type: System.Drawing..::..Graphics
Graphics object to draw with.
path
Type: System.Drawing.Drawing2D..::..GraphicsPath
Path to draw.

See Also

GH_StateTag Class
Grasshopper.Kernel Namespace


RenderTagBlankIcon Method

[image] [image]

Grasshopper SDK
GH_StateTag..::..RenderTagBlankIcon Method
GH_StateTag Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RenderTagBlankIcon(Graphics) | Render a blank rectangle icon.
Protected method | RenderTagBlankIcon(Graphics, GH_StateTag..::..DrawCallback) | Render a blank rectangle icon.

See Also

GH_StateTag Class
GH_StateTag Members
Grasshopper.Kernel Namespace


RenderTagBlankIcon Method (Graphics)

[image]

Grasshopper SDK
GH_StateTag..::..RenderTagBlankIcon Method (Graphics)
GH_StateTag Class See Also Send Feedback
Render a blank rectangle icon.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected void RenderTagBlankIcon(
    Graphics graphics
)
Visual Basic
Protected Sub RenderTagBlankIcon ( _
    graphics As Graphics _
)

Parameters

graphics
Type: System.Drawing..::..Graphics
Graphics object to draw with.

See Also

GH_StateTag Class
RenderTagBlankIcon Overload
Grasshopper.Kernel Namespace


RenderTagBlankIcon Method (Graphics, GH_StateTag.DrawCallback)

[image]

Grasshopper SDK
GH_StateTag..::..RenderTagBlankIcon Method (Graphics, GH_StateTag..::..DrawCallback)
GH_StateTag Class See Also Send Feedback
Render a blank rectangle icon.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected void RenderTagBlankIcon(
    Graphics graphics,
    GH_StateTag..::..DrawCallback drawCallBack
)
Visual Basic
Protected Sub RenderTagBlankIcon ( _
    graphics As Graphics, _
    drawCallBack As GH_StateTag..::..DrawCallback _
)

Parameters

graphics
Type: System.Drawing..::..Graphics
Graphics object to draw with.
drawCallBack
Type: Grasshopper.Kernel..::..GH_StateTag..::..DrawCallback
Callback (can be null) that will be called between background and foreground shapes.

See Also

GH_StateTag Class
RenderTagBlankIcon Overload
Grasshopper.Kernel Namespace


RenderTagPolygonIcon Method

[image]

Grasshopper SDK
GH_StateTag..::..RenderTagPolygonIcon Method
GH_StateTag Class See Also Send Feedback
Render a filled polygon with default shading.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected void RenderTagPolygonIcon(
    Graphics graphics,
    PointF[] polygon
)
Visual Basic
Protected Sub RenderTagPolygonIcon ( _
    graphics As Graphics, _
    polygon As PointF() _
)

Parameters

graphics
Type: System.Drawing..::..Graphics
Graphics object to draw with.
polygon
Type: array< System.Drawing..::..PointF >[]()[][]
Polygon corners.

See Also

GH_StateTag Class
Grasshopper.Kernel Namespace


GH_StateTag Properties

[image] [image]

Grasshopper SDK
GH_StateTag Properties
GH_StateTag Class See Also Send Feedback

The GH_StateTag type exposes the following members.

Properties

 | Name | Description
Public property | Description |
Public property | Icon |
Public property | Name |
Public property | Stage | Gets or sets the stage rectangle for this tag.
Public property | StateDescription | Gets or sets the state description for this tag.

See Also

GH_StateTag Class
Grasshopper.Kernel Namespace


Description Property

[image]

Grasshopper SDK
GH_StateTag..::..Description Property
GH_StateTag Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract string Description { get; }
Visual Basic
Public MustOverride ReadOnly Property Description As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_StateTag.Description"]

Implements

IGH_StateTag..::..Description

See Also

GH_StateTag Class
Grasshopper.Kernel Namespace


Icon Property

[image]

Grasshopper SDK
GH_StateTag..::..Icon Property
GH_StateTag Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract Bitmap Icon { get; }
Visual Basic
Public MustOverride ReadOnly Property Icon As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_StateTag.Icon"]

Implements

IGH_StateTag..::..Icon

See Also

GH_StateTag Class
Grasshopper.Kernel Namespace


Name Property

[image]

Grasshopper SDK
GH_StateTag..::..Name Property
GH_StateTag Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract string Name { get; }
Visual Basic
Public MustOverride ReadOnly Property Name As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_StateTag.Name"]

Implements

IGH_StateTag..::..Name

See Also

GH_StateTag Class
Grasshopper.Kernel Namespace


Stage Property

[image]

Grasshopper SDK
GH_StateTag..::..Stage Property
GH_StateTag Class See Also Send Feedback
Gets or sets the stage rectangle for this tag.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual Rectangle Stage { get; set; }
Visual Basic
Public Overridable Property Stage As Rectangle
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_StateTag.Stage"]

Implements

IGH_StateTag..::..Stage

See Also

GH_StateTag Class
Grasshopper.Kernel Namespace


StateDescription Property

[image]

Grasshopper SDK
GH_StateTag..::..StateDescription Property
GH_StateTag Class See Also Send Feedback
Gets or sets the state description for this tag.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string StateDescription { get; set; }
Visual Basic
Public Property StateDescription As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_StateTag.StateDescription"]

Implements

IGH_StateTag..::..StateDescription

See Also

GH_StateTag Class
Grasshopper.Kernel Namespace


GH_StateTag.DrawCallback Delegate

[image]

Grasshopper SDK
GH_StateTag..::..DrawCallback Delegate
GH_StateTag Class See Also Send Feedback
Drawing delegate.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected delegate void DrawCallback(
    Graphics graphics,
    double alpha
)
Visual Basic
Protected Delegate Sub DrawCallback ( _
    graphics As Graphics, _
    alpha As Double _
)

Parameters

graphics
Type: System.Drawing..::..Graphics
Graphics object to draw with.
alpha
Type: System..::..Double
Floating point alpha blend (0~255).

See Also

Grasshopper.Kernel Namespace


GH_StateTagLayoutDirection Enumeration

[image]

Grasshopper SDK
GH_StateTagLayoutDirection Enumeration
See Also Send Feedback
Enumerates the possible layout directions for parameter state tags.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_StateTagLayoutDirection
Visual Basic
Public Enumeration GH_StateTagLayoutDirection

Members

Member name | Value | Description
Left | 0 | Floating and Input parameters should be layed out towards the left.
Right | 1 | Output parameters should be layed out towards the right.

See Also

Grasshopper.Kernel Namespace


GH_StateTagList Class

[image]

Grasshopper SDK
GH_StateTagList Class
Members See Also Send Feedback
Maintains a collection of IGH_StateTag objects.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_StateTagList : List<IGH_StateTag>,
    IGH_TooltipAwareObject
Visual Basic
Public Class GH_StateTagList _
    Inherits List(Of IGH_StateTag) _
    Implements IGH_TooltipAwareObject

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' IGH_StateTag >)>)>
Grasshopper.Kernel..::..GH_StateTagList

See Also

GH_StateTagList Members
Grasshopper.Kernel Namespace


GH_StateTagList Members

[image] [image]

Grasshopper SDK
GH_StateTagList Members
GH_StateTagList Class Constructors Methods Properties See Also Send Feedback

The GH_StateTagList type exposes the following members.

Constructors

 | Name | Description
Public method | GH_StateTagList | Initializes a new instance of the GH_StateTagList class

Methods

 | Name | Description
Public method | Layout | Layout the StateTags.
Public method | RenderStateTags | Render all StateTags in this list to the designated Graphics surface.

Properties

 | Name | Description
Public property | BoundingBox | Gets the boundingbox of all StateTags.

See Also

GH_StateTagList Class
Grasshopper.Kernel Namespace


GH_StateTagList Constructor

[image]

Grasshopper SDK
GH_StateTagList Constructor
GH_StateTagList Class See Also Send Feedback
Initializes a new instance of the GH_StateTagList class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_StateTagList()
Visual Basic
Public Sub New

See Also

GH_StateTagList Class
Grasshopper.Kernel Namespace


GH_StateTagList Methods

[image] [image]

Grasshopper SDK
GH_StateTagList Methods
GH_StateTagList Class See Also Send Feedback

The GH_StateTagList type exposes the following members.

Methods

 | Name | Description
Public method | Layout | Layout the StateTags.
Public method | RenderStateTags | Render all StateTags in this list to the designated Graphics surface.

See Also

GH_StateTagList Class
Grasshopper.Kernel Namespace


Layout Method

[image]

Grasshopper SDK
GH_StateTagList..::..Layout Method
GH_StateTagList Class See Also Send Feedback
Layout the StateTags.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Layout(
    Rectangle box,
    GH_StateTagLayoutDirection direction
)
Visual Basic
Public Sub Layout ( _
    box As Rectangle, _
    direction As GH_StateTagLayoutDirection _
)

Parameters

box
Type: System.Drawing..::..Rectangle
Content box to append to.
direction
Type: Grasshopper.Kernel..::..GH_StateTagLayoutDirection

See Also

GH_StateTagList Class
Grasshopper.Kernel Namespace


RenderStateTags Method

[image]

Grasshopper SDK
GH_StateTagList..::..RenderStateTags Method
GH_StateTagList Class See Also Send Feedback
Render all StateTags in this list to the designated Graphics surface.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RenderStateTags(
    Graphics G
)
Visual Basic
Public Sub RenderStateTags ( _
    G As Graphics _
)

Parameters

G
Type: System.Drawing..::..Graphics
Graphics object to draw with.

See Also

GH_StateTagList Class
Grasshopper.Kernel Namespace


GH_StateTagList Properties

[image] [image]

Grasshopper SDK
GH_StateTagList Properties
GH_StateTagList Class See Also Send Feedback

The GH_StateTagList type exposes the following members.

Properties

 | Name | Description
Public property | BoundingBox | Gets the boundingbox of all StateTags.

See Also

GH_StateTagList Class
Grasshopper.Kernel Namespace


BoundingBox Property

[image]

Grasshopper SDK
GH_StateTagList..::..BoundingBox Property
GH_StateTagList Class See Also Send Feedback
Gets the boundingbox of all StateTags.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rectangle BoundingBox { get; }
Visual Basic
Public ReadOnly Property BoundingBox As Rectangle
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_StateTagList.BoundingBox"]

See Also

GH_StateTagList Class
Grasshopper.Kernel Namespace


GH_TimeKind Enumeration

[image]

Grasshopper SDK
GH_TimeKind Enumeration
See Also Send Feedback
Enumerates the possible kinds that a System.DateTime value can imply.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_TimeKind
Visual Basic
Public Enumeration GH_TimeKind

Members

Member name | Value | Description
Unset | 0 | Unset kind.
Mixed | 1 | Mixed indicates there isn't a single clear answer.
PureTime | 2 | DateTime value implies a pure time (no date part).
PureDate | 3 | DateTime value implies a pute date (no time part).
DateAndTime | 4 | DateTime value implies both a date and a time component.

See Also

Grasshopper.Kernel Namespace


GH_TypeLib Class

[image]

Grasshopper SDK
GH_TypeLib Class
Members See Also Send Feedback
Utility module that caches a number of oft-used types and type-ids for quick access. Do not change any of the values in this module or you'll wreck casting and conversion logic.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class GH_TypeLib
Visual Basic
Public NotInheritable Class GH_TypeLib

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_TypeLib

See Also

GH_TypeLib Members
Grasshopper.Kernel Namespace


GH_TypeLib Members

[image] [image]

Grasshopper SDK
GH_TypeLib Members
GH_TypeLib Class Fields See Also Send Feedback

The GH_TypeLib type exposes the following members.

Fields

Name | Description
id_bool | System.Boolean
id_byte | System.Byte
id_char | System.Char
id_color | System.Drawing.Color
id_decimal | System.Decimal
id_double | System.Double
id_gh_arc | Grasshopper.Kernel.Types.GH_Arc
id_gh_bool | Grasshopper.Kernel.Types.GH_Boolean
id_gh_box | Grasshopper.Kernel.Types.GH_Box
id_gh_brep | Grasshopper.Kernel.Types.GH_Brep
id_gh_circle | Grasshopper.Kernel.Types.GH_Circle
id_gh_colour | Grasshopper.Kernel.Types.GH_Colour
id_gh_complex | Grasshopper.Kernel.Types.Complex
id_gh_complexnumber | Grasshopper.Kernel.Types.GH_ComplexNumber
id_gh_curve | Grasshopper.Kernel.Types.GH_Curve
id_gh_goo | Grasshopper.Kernel.Types.IGH_Goo
id_gh_guid | Grasshopper.Kernel.Types.GH_Guid
id_gh_int | Grasshopper.Kernel.Types.GH_Integer
id_gh_interval | Grasshopper.Kernel.Types.GH_Interval
id_gh_interval2D | Grasshopper.Kernel.Types.GH_Interval2D
id_gh_line | Grasshopper.Kernel.Types.GH_Line
id_gh_material | Grasshopper.Kernel.Types.GH_Material
id_gh_matrix | Grasshopper.Kernel.Types.GH_Matrix
id_gh_mesh | Grasshopper.Kernel.Types.GH_Mesh
id_gh_meshface | Grasshopper.Kernel.Types.GH_MeshFace
id_gh_number | Grasshopper.Kernel.Types.GH_Number
id_gh_objwrapper | Grasshopper.Kernel.Types.GH_ObjectWrapper
id_gh_path | Grasshopper.Kernel.Data.GH_Path
id_gh_plane | Grasshopper.Kernel.Types.GH_Plane
id_gh_point | Grasshopper.Kernel.Types.GH_Point
id_gh_rectangle | Grasshopper.Kernel.Types.GH_Rectangle
id_gh_string | Grasshopper.Kernel.Types.GH_String
id_gh_structpath | Grasshopper.Kernel.Types.GH_StructurePath
id_gh_surface | Grasshopper.Kernel.Types.GH_Surface
id_gh_time | Grasshopper.Kernel.Types.GH_Time
id_gh_transform | Grasshopper.Kernel.Types.GH_Transform
id_gh_uvinterval | Grasshopper.Kernel.Types.UVInterval
id_gh_vector | Grasshopper.Kernel.Types.GH_Vector
id_guid | System.Guid
id_int16 | System.Int16
id_int32 | System.Int32
id_int64 | System.Int64
id_object | System.Object
id_point | System.Drawing.Point
id_pointf | System.Drawing.PointF
id_rc_arc | Rhino.Geometry.Arc
id_rc_arccurve | Rhino.Geometry.ArcCurve
id_rc_boundingbox | Rhino.Geometry.BoundingBox
id_rc_box | Rhino.Geometry.Box
id_rc_brep | Rhino.Geometry.Brep
id_rc_brepedge | Rhino.Geometry.MeshEdge
id_rc_brepface | Rhino.Geometry.MeshFace
id_rc_circle | Rhino.Geometry.Circle
id_rc_cone | Rhino.Geometry.Cone
id_rc_curve | Rhino.Geometry.Curve
id_rc_cylinder | Rhino.Geometry.Cylinder
id_rc_ellipse | Rhino.Geometry.Circle
id_rc_extrusion | Rhino.Geometry.Extrusion
id_rc_interval | Rhino.Geometry.Interval
id_rc_line | Rhino.Geometry.Line
id_rc_linecurve | Rhino.Geometry.LineCurve
id_rc_matrix | Rhino.Geometry.Matrix
id_rc_mesh | Rhino.Geometry.Mesh
id_rc_meshface | Rhino.Geometry.MeshFace
id_rc_nurbscurve | Rhino.Geometry.NurbsCurve
id_rc_nurbssurface | Rhino.Geometry.NurbsSurface
id_rc_plane | Rhino.Geometry.Plane
id_rc_planesurface | Rhino.Geometry.PlaneSurface
id_rc_point3d | Rhino.Geometry.Point3d
id_rc_point3f | Rhino.Geometry.Point3f
id_rc_polycurve | Rhino.Geometry.PolyCurve
id_rc_polyline | Rhino.Geometry.Polyline
id_rc_polylinecurve | Rhino.Geometry.PolylineCurve
id_rc_rectangle | Rhino.Geometry.Rectangle3d
id_rc_revsurface | Rhino.Geometry.RevSurface
id_rc_sphere | Rhino.Geometry.Torus
id_rc_sumsurface | Rhino.Geometry.SumSurface
id_rc_surface | Rhino.Geometry.Surface
id_rc_torus | Rhino.Geometry.Torus
id_rc_transform | Rhino.Geometry.Transform
id_rc_vector3d | Rhino.Geometry.Vector3d
id_rc_vector3f | Rhino.Geometry.Vector3f
id_rectangle | System.Drawing.Rectangle
id_rectanglef | System.Drawing.RectangleF
id_single | System.Single
id_size | System.Drawing.Size
id_sizef | System.Drawing.SizeF
id_string | System.String
id_time | System.Date
id_uint16 | System.UInt16
id_uint32 | System.UInt32
id_uint64 | System.UInt64
t_bool | System.Boolean
t_byte | System.Byte
t_char | System.Char
t_color | System.Drawing.Color
t_decimal | System.Decimal
t_double | System.Double
t_gh_arc | Grasshopper.Kernel.Types.GH_Arc
t_gh_bool | Grasshopper.Kernel.Types.GH_Boolean
t_gh_box | Grasshopper.Kernel.Types.GH_Box
t_gh_brep | Grasshopper.Kernel.Types.GH_Brep
t_gh_circle | Grasshopper.Kernel.Types.GH_Circle
t_gh_colour | Grasshopper.Kernel.Types.GH_Colour
t_gh_complex | Grasshopper.Kernel.Types.Complex
t_gh_complexnumber | Grasshopper.Kernel.Types.GH_ComplexNumber
t_gh_curve | Grasshopper.Kernel.Types.GH_Curve
t_gh_goo | Grasshopper.Kernel.Types.IGH_Goo
t_gh_guid | Grasshopper.Kernel.Types.GH_Guid
t_gh_int | Grasshopper.Kernel.Types.GH_Integer
t_gh_interval | Grasshopper.Kernel.Types.GH_Interval
t_gh_interval2D | Grasshopper.Kernel.Types.GH_Interval2D
t_gh_line | Grasshopper.Kernel.Types.GH_Line
t_gh_material | Grasshopper.Kernel.Types.GH_Material
t_gh_matrix | Grasshopper.Kernel.Types.GH_Matrix
t_gh_mesh | Grasshopper.Kernel.Types.GH_Mesh
t_gh_meshface | Grasshopper.Kernel.Types.GH_MeshFace
t_gh_number | Grasshopper.Kernel.Types.GH_Number
t_gh_objwrapper | Grasshopper.Kernel.Types.GH_ObjectWrapper
t_gh_path | Grasshopper.Kernel.Data.GH_Path
t_gh_plane | Grasshopper.Kernel.Types.GH_Plane
t_gh_point | Grasshopper.Kernel.Types.GH_Point
t_gh_rectangle | Grasshopper.Kernel.Types.GH_Rectangle
t_gh_string | Grasshopper.Kernel.Types.GH_String
t_gh_structpath | Grasshopper.Kernel.Types.GH_StructurePath
t_gh_surface | Grasshopper.Kernel.Types.GH_Surface
t_gh_time | Grasshopper.Kernel.Types.GH_Time
t_gh_transform | Grasshopper.Kernel.Types.GH_Transform
t_gh_uvinterval | Grasshopper.Kernel.Types.UVInterval
t_gh_vector | Grasshopper.Kernel.Types.GH_Vector
t_guid | System.Guid
t_int16 | System.Int16
t_int32 | System.Int32
t_int64 | System.Int64
t_object | System.Object
t_point | System.Drawing.Point
t_pointf | System.Drawing.PointF
t_rc_arc | Rhino.Geometry.Arc
t_rc_arccurve | Rhino.Geometry.ArcCurve
t_rc_boundingbox | Rhino.Geometry.BoundingBox
t_rc_box | Rhino.Geometry.Box
t_rc_brep | Rhino.Geometry.Brep
t_rc_brepedge | Rhino.Geometry.MeshEdge
t_rc_brepface | Rhino.Geometry.MeshFace
t_rc_circle | Rhino.Geometry.Circle
t_rc_cone | Rhino.Geometry.Cone
t_rc_curve | Rhino.Geometry.Curve
t_rc_cylinder | Rhino.Geometry.Cylinder
t_rc_ellipse | Rhino.Geometry.Circle
t_rc_extrusion | Rhino.Geometry.Extrusion.
t_rc_interval | Rhino.Geometry.Interval
t_rc_line | Rhino.Geometry.Line
t_rc_linecurve | Rhino.Geometry.LineCurve
t_rc_matrix | Rhino.Geometry.Matrix
t_rc_mesh | Rhino.Geometry.Mesh
t_rc_meshface | Rhino.Geometry.MeshFace
t_rc_nurbscurve | Rhino.Geometry.NurbsCurve
t_rc_nurbssurface | Rhino.Geometry.NurbsSurface
t_rc_plane | Rhino.Geometry.Plane
t_rc_planesurface | Rhino.Geometry.PlaneSurface
t_rc_point3d | Rhino.Geometry.Point3d
t_rc_point3f | Rhino.Geometry.Point3f
t_rc_polycurve | Rhino.Geometry.PolyCurve
t_rc_polyline | Rhino.Geometry.Polyline
t_rc_polylinecurve | Rhino.Geometry.PolylineCurve
t_rc_rectangle | Rhino.Geometry.Rectangle3d
t_rc_revsurface | Rhino.Geometry.RevSurface
t_rc_sphere | Rhino.Geometry.Torus
t_rc_sumsurface | Rhino.Geometry.SumSurface
t_rc_surface | Rhino.Geometry.Surface
t_rc_torus | Rhino.Geometry.Torus
t_rc_transform | Rhino.Geometry.Transform
t_rc_vector3d | Rhino.Geometry.Vector3d
t_rc_vector3f | Rhino.Geometry.Vector3f
t_rectangle | System.Drawing.Rectangle
t_rectanglef | System.Drawing.RectangleF
t_single | System.Single
t_size | System.Drawing.Size
t_sizef | System.Drawing.SizeF
t_string | System.String
t_time | System.Date
t_uint16 | System.UInt16
t_uint32 | System.UInt32
t_uint64 | System.UInt64

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


GH_TypeLib Fields

[image] [image]

Grasshopper SDK
GH_TypeLib Fields
GH_TypeLib Class See Also Send Feedback

The GH_TypeLib type exposes the following members.

Fields

Name | Description
id_bool | System.Boolean
id_byte | System.Byte
id_char | System.Char
id_color | System.Drawing.Color
id_decimal | System.Decimal
id_double | System.Double
id_gh_arc | Grasshopper.Kernel.Types.GH_Arc
id_gh_bool | Grasshopper.Kernel.Types.GH_Boolean
id_gh_box | Grasshopper.Kernel.Types.GH_Box
id_gh_brep | Grasshopper.Kernel.Types.GH_Brep
id_gh_circle | Grasshopper.Kernel.Types.GH_Circle
id_gh_colour | Grasshopper.Kernel.Types.GH_Colour
id_gh_complex | Grasshopper.Kernel.Types.Complex
id_gh_complexnumber | Grasshopper.Kernel.Types.GH_ComplexNumber
id_gh_curve | Grasshopper.Kernel.Types.GH_Curve
id_gh_goo | Grasshopper.Kernel.Types.IGH_Goo
id_gh_guid | Grasshopper.Kernel.Types.GH_Guid
id_gh_int | Grasshopper.Kernel.Types.GH_Integer
id_gh_interval | Grasshopper.Kernel.Types.GH_Interval
id_gh_interval2D | Grasshopper.Kernel.Types.GH_Interval2D
id_gh_line | Grasshopper.Kernel.Types.GH_Line
id_gh_material | Grasshopper.Kernel.Types.GH_Material
id_gh_matrix | Grasshopper.Kernel.Types.GH_Matrix
id_gh_mesh | Grasshopper.Kernel.Types.GH_Mesh
id_gh_meshface | Grasshopper.Kernel.Types.GH_MeshFace
id_gh_number | Grasshopper.Kernel.Types.GH_Number
id_gh_objwrapper | Grasshopper.Kernel.Types.GH_ObjectWrapper
id_gh_path | Grasshopper.Kernel.Data.GH_Path
id_gh_plane | Grasshopper.Kernel.Types.GH_Plane
id_gh_point | Grasshopper.Kernel.Types.GH_Point
id_gh_rectangle | Grasshopper.Kernel.Types.GH_Rectangle
id_gh_string | Grasshopper.Kernel.Types.GH_String
id_gh_structpath | Grasshopper.Kernel.Types.GH_StructurePath
id_gh_surface | Grasshopper.Kernel.Types.GH_Surface
id_gh_time | Grasshopper.Kernel.Types.GH_Time
id_gh_transform | Grasshopper.Kernel.Types.GH_Transform
id_gh_uvinterval | Grasshopper.Kernel.Types.UVInterval
id_gh_vector | Grasshopper.Kernel.Types.GH_Vector
id_guid | System.Guid
id_int16 | System.Int16
id_int32 | System.Int32
id_int64 | System.Int64
id_object | System.Object
id_point | System.Drawing.Point
id_pointf | System.Drawing.PointF
id_rc_arc | Rhino.Geometry.Arc
id_rc_arccurve | Rhino.Geometry.ArcCurve
id_rc_boundingbox | Rhino.Geometry.BoundingBox
id_rc_box | Rhino.Geometry.Box
id_rc_brep | Rhino.Geometry.Brep
id_rc_brepedge | Rhino.Geometry.MeshEdge
id_rc_brepface | Rhino.Geometry.MeshFace
id_rc_circle | Rhino.Geometry.Circle
id_rc_cone | Rhino.Geometry.Cone
id_rc_curve | Rhino.Geometry.Curve
id_rc_cylinder | Rhino.Geometry.Cylinder
id_rc_ellipse | Rhino.Geometry.Circle
id_rc_extrusion | Rhino.Geometry.Extrusion
id_rc_interval | Rhino.Geometry.Interval
id_rc_line | Rhino.Geometry.Line
id_rc_linecurve | Rhino.Geometry.LineCurve
id_rc_matrix | Rhino.Geometry.Matrix
id_rc_mesh | Rhino.Geometry.Mesh
id_rc_meshface | Rhino.Geometry.MeshFace
id_rc_nurbscurve | Rhino.Geometry.NurbsCurve
id_rc_nurbssurface | Rhino.Geometry.NurbsSurface
id_rc_plane | Rhino.Geometry.Plane
id_rc_planesurface | Rhino.Geometry.PlaneSurface
id_rc_point3d | Rhino.Geometry.Point3d
id_rc_point3f | Rhino.Geometry.Point3f
id_rc_polycurve | Rhino.Geometry.PolyCurve
id_rc_polyline | Rhino.Geometry.Polyline
id_rc_polylinecurve | Rhino.Geometry.PolylineCurve
id_rc_rectangle | Rhino.Geometry.Rectangle3d
id_rc_revsurface | Rhino.Geometry.RevSurface
id_rc_sphere | Rhino.Geometry.Torus
id_rc_sumsurface | Rhino.Geometry.SumSurface
id_rc_surface | Rhino.Geometry.Surface
id_rc_torus | Rhino.Geometry.Torus
id_rc_transform | Rhino.Geometry.Transform
id_rc_vector3d | Rhino.Geometry.Vector3d
id_rc_vector3f | Rhino.Geometry.Vector3f
id_rectangle | System.Drawing.Rectangle
id_rectanglef | System.Drawing.RectangleF
id_single | System.Single
id_size | System.Drawing.Size
id_sizef | System.Drawing.SizeF
id_string | System.String
id_time | System.Date
id_uint16 | System.UInt16
id_uint32 | System.UInt32
id_uint64 | System.UInt64
t_bool | System.Boolean
t_byte | System.Byte
t_char | System.Char
t_color | System.Drawing.Color
t_decimal | System.Decimal
t_double | System.Double
t_gh_arc | Grasshopper.Kernel.Types.GH_Arc
t_gh_bool | Grasshopper.Kernel.Types.GH_Boolean
t_gh_box | Grasshopper.Kernel.Types.GH_Box
t_gh_brep | Grasshopper.Kernel.Types.GH_Brep
t_gh_circle | Grasshopper.Kernel.Types.GH_Circle
t_gh_colour | Grasshopper.Kernel.Types.GH_Colour
t_gh_complex | Grasshopper.Kernel.Types.Complex
t_gh_complexnumber | Grasshopper.Kernel.Types.GH_ComplexNumber
t_gh_curve | Grasshopper.Kernel.Types.GH_Curve
t_gh_goo | Grasshopper.Kernel.Types.IGH_Goo
t_gh_guid | Grasshopper.Kernel.Types.GH_Guid
t_gh_int | Grasshopper.Kernel.Types.GH_Integer
t_gh_interval | Grasshopper.Kernel.Types.GH_Interval
t_gh_interval2D | Grasshopper.Kernel.Types.GH_Interval2D
t_gh_line | Grasshopper.Kernel.Types.GH_Line
t_gh_material | Grasshopper.Kernel.Types.GH_Material
t_gh_matrix | Grasshopper.Kernel.Types.GH_Matrix
t_gh_mesh | Grasshopper.Kernel.Types.GH_Mesh
t_gh_meshface | Grasshopper.Kernel.Types.GH_MeshFace
t_gh_number | Grasshopper.Kernel.Types.GH_Number
t_gh_objwrapper | Grasshopper.Kernel.Types.GH_ObjectWrapper
t_gh_path | Grasshopper.Kernel.Data.GH_Path
t_gh_plane | Grasshopper.Kernel.Types.GH_Plane
t_gh_point | Grasshopper.Kernel.Types.GH_Point
t_gh_rectangle | Grasshopper.Kernel.Types.GH_Rectangle
t_gh_string | Grasshopper.Kernel.Types.GH_String
t_gh_structpath | Grasshopper.Kernel.Types.GH_StructurePath
t_gh_surface | Grasshopper.Kernel.Types.GH_Surface
t_gh_time | Grasshopper.Kernel.Types.GH_Time
t_gh_transform | Grasshopper.Kernel.Types.GH_Transform
t_gh_uvinterval | Grasshopper.Kernel.Types.UVInterval
t_gh_vector | Grasshopper.Kernel.Types.GH_Vector
t_guid | System.Guid
t_int16 | System.Int16
t_int32 | System.Int32
t_int64 | System.Int64
t_object | System.Object
t_point | System.Drawing.Point
t_pointf | System.Drawing.PointF
t_rc_arc | Rhino.Geometry.Arc
t_rc_arccurve | Rhino.Geometry.ArcCurve
t_rc_boundingbox | Rhino.Geometry.BoundingBox
t_rc_box | Rhino.Geometry.Box
t_rc_brep | Rhino.Geometry.Brep
t_rc_brepedge | Rhino.Geometry.MeshEdge
t_rc_brepface | Rhino.Geometry.MeshFace
t_rc_circle | Rhino.Geometry.Circle
t_rc_cone | Rhino.Geometry.Cone
t_rc_curve | Rhino.Geometry.Curve
t_rc_cylinder | Rhino.Geometry.Cylinder
t_rc_ellipse | Rhino.Geometry.Circle
t_rc_extrusion | Rhino.Geometry.Extrusion.
t_rc_interval | Rhino.Geometry.Interval
t_rc_line | Rhino.Geometry.Line
t_rc_linecurve | Rhino.Geometry.LineCurve
t_rc_matrix | Rhino.Geometry.Matrix
t_rc_mesh | Rhino.Geometry.Mesh
t_rc_meshface | Rhino.Geometry.MeshFace
t_rc_nurbscurve | Rhino.Geometry.NurbsCurve
t_rc_nurbssurface | Rhino.Geometry.NurbsSurface
t_rc_plane | Rhino.Geometry.Plane
t_rc_planesurface | Rhino.Geometry.PlaneSurface
t_rc_point3d | Rhino.Geometry.Point3d
t_rc_point3f | Rhino.Geometry.Point3f
t_rc_polycurve | Rhino.Geometry.PolyCurve
t_rc_polyline | Rhino.Geometry.Polyline
t_rc_polylinecurve | Rhino.Geometry.PolylineCurve
t_rc_rectangle | Rhino.Geometry.Rectangle3d
t_rc_revsurface | Rhino.Geometry.RevSurface
t_rc_sphere | Rhino.Geometry.Torus
t_rc_sumsurface | Rhino.Geometry.SumSurface
t_rc_surface | Rhino.Geometry.Surface
t_rc_torus | Rhino.Geometry.Torus
t_rc_transform | Rhino.Geometry.Transform
t_rc_vector3d | Rhino.Geometry.Vector3d
t_rc_vector3f | Rhino.Geometry.Vector3f
t_rectangle | System.Drawing.Rectangle
t_rectanglef | System.Drawing.RectangleF
t_single | System.Single
t_size | System.Drawing.Size
t_sizef | System.Drawing.SizeF
t_string | System.String
t_time | System.Date
t_uint16 | System.UInt16
t_uint32 | System.UInt32
t_uint64 | System.UInt64

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_bool Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_bool Field
GH_TypeLib Class See Also Send Feedback
System.Boolean

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_bool
Visual Basic
Public Shared id_bool As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_byte Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_byte Field
GH_TypeLib Class See Also Send Feedback
System.Byte

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_byte
Visual Basic
Public Shared id_byte As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_char Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_char Field
GH_TypeLib Class See Also Send Feedback
System.Char

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_char
Visual Basic
Public Shared id_char As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_color Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_color Field
GH_TypeLib Class See Also Send Feedback
System.Drawing.Color

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_color
Visual Basic
Public Shared id_color As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_decimal Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_decimal Field
GH_TypeLib Class See Also Send Feedback
System.Decimal

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_decimal
Visual Basic
Public Shared id_decimal As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_double Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_double Field
GH_TypeLib Class See Also Send Feedback
System.Double

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_double
Visual Basic
Public Shared id_double As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_gh_arc Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_gh_arc Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Arc

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_gh_arc
Visual Basic
Public Shared id_gh_arc As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_gh_bool Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_gh_bool Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Boolean

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_gh_bool
Visual Basic
Public Shared id_gh_bool As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_gh_box Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_gh_box Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Box

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_gh_box
Visual Basic
Public Shared id_gh_box As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_gh_brep Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_gh_brep Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Brep

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_gh_brep
Visual Basic
Public Shared id_gh_brep As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_gh_circle Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_gh_circle Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Circle

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_gh_circle
Visual Basic
Public Shared id_gh_circle As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_gh_colour Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_gh_colour Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Colour

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_gh_colour
Visual Basic
Public Shared id_gh_colour As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_gh_complex Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_gh_complex Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.Complex

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_gh_complex
Visual Basic
Public Shared id_gh_complex As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_gh_complexnumber Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_gh_complexnumber Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_ComplexNumber

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_gh_complexnumber
Visual Basic
Public Shared id_gh_complexnumber As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_gh_curve Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_gh_curve Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Curve

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_gh_curve
Visual Basic
Public Shared id_gh_curve As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_gh_goo Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_gh_goo Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.IGH_Goo

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_gh_goo
Visual Basic
Public Shared id_gh_goo As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_gh_guid Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_gh_guid Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Guid

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_gh_guid
Visual Basic
Public Shared id_gh_guid As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_gh_int Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_gh_int Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Integer

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_gh_int
Visual Basic
Public Shared id_gh_int As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_gh_interval Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_gh_interval Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Interval

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_gh_interval
Visual Basic
Public Shared id_gh_interval As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_gh_interval2D Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_gh_interval2D Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Interval2D

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_gh_interval2D
Visual Basic
Public Shared id_gh_interval2D As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_gh_line Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_gh_line Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Line

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_gh_line
Visual Basic
Public Shared id_gh_line As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_gh_material Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_gh_material Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Material

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_gh_material
Visual Basic
Public Shared id_gh_material As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_gh_matrix Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_gh_matrix Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Matrix

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_gh_matrix
Visual Basic
Public Shared id_gh_matrix As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_gh_mesh Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_gh_mesh Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Mesh

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_gh_mesh
Visual Basic
Public Shared id_gh_mesh As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_gh_meshface Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_gh_meshface Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_MeshFace

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_gh_meshface
Visual Basic
Public Shared id_gh_meshface As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_gh_number Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_gh_number Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Number

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_gh_number
Visual Basic
Public Shared id_gh_number As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_gh_objwrapper Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_gh_objwrapper Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_ObjectWrapper

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_gh_objwrapper
Visual Basic
Public Shared id_gh_objwrapper As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_gh_path Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_gh_path Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Data.GH_Path

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_gh_path
Visual Basic
Public Shared id_gh_path As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_gh_plane Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_gh_plane Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Plane

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_gh_plane
Visual Basic
Public Shared id_gh_plane As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_gh_point Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_gh_point Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Point

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_gh_point
Visual Basic
Public Shared id_gh_point As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_gh_rectangle Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_gh_rectangle Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Rectangle

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_gh_rectangle
Visual Basic
Public Shared id_gh_rectangle As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_gh_string Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_gh_string Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_String

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_gh_string
Visual Basic
Public Shared id_gh_string As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_gh_structpath Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_gh_structpath Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_StructurePath

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_gh_structpath
Visual Basic
Public Shared id_gh_structpath As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_gh_surface Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_gh_surface Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Surface

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_gh_surface
Visual Basic
Public Shared id_gh_surface As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_gh_time Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_gh_time Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Time

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_gh_time
Visual Basic
Public Shared id_gh_time As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_gh_transform Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_gh_transform Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Transform

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_gh_transform
Visual Basic
Public Shared id_gh_transform As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_gh_uvinterval Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_gh_uvinterval Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.UVInterval

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_gh_uvinterval
Visual Basic
Public Shared id_gh_uvinterval As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_gh_vector Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_gh_vector Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Vector

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_gh_vector
Visual Basic
Public Shared id_gh_vector As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_guid Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_guid Field
GH_TypeLib Class See Also Send Feedback
System.Guid

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_guid
Visual Basic
Public Shared id_guid As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_int16 Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_int16 Field
GH_TypeLib Class See Also Send Feedback
System.Int16

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_int16
Visual Basic
Public Shared id_int16 As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_int32 Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_int32 Field
GH_TypeLib Class See Also Send Feedback
System.Int32

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_int32
Visual Basic
Public Shared id_int32 As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_int64 Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_int64 Field
GH_TypeLib Class See Also Send Feedback
System.Int64

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_int64
Visual Basic
Public Shared id_int64 As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_object Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_object Field
GH_TypeLib Class See Also Send Feedback
System.Object

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_object
Visual Basic
Public Shared id_object As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_point Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_point Field
GH_TypeLib Class See Also Send Feedback
System.Drawing.Point

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_point
Visual Basic
Public Shared id_point As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_pointf Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_pointf Field
GH_TypeLib Class See Also Send Feedback
System.Drawing.PointF

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_pointf
Visual Basic
Public Shared id_pointf As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_rc_arc Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_rc_arc Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Arc

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_rc_arc
Visual Basic
Public Shared id_rc_arc As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_rc_arccurve Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_rc_arccurve Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.ArcCurve

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_rc_arccurve
Visual Basic
Public Shared id_rc_arccurve As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_rc_boundingbox Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_rc_boundingbox Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.BoundingBox

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_rc_boundingbox
Visual Basic
Public Shared id_rc_boundingbox As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_rc_box Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_rc_box Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Box

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_rc_box
Visual Basic
Public Shared id_rc_box As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_rc_brep Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_rc_brep Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Brep

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_rc_brep
Visual Basic
Public Shared id_rc_brep As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_rc_brepedge Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_rc_brepedge Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.MeshEdge

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_rc_brepedge
Visual Basic
Public Shared id_rc_brepedge As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_rc_brepface Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_rc_brepface Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.MeshFace

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_rc_brepface
Visual Basic
Public Shared id_rc_brepface As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_rc_circle Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_rc_circle Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Circle

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_rc_circle
Visual Basic
Public Shared id_rc_circle As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_rc_cone Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_rc_cone Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Cone

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_rc_cone
Visual Basic
Public Shared id_rc_cone As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_rc_curve Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_rc_curve Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Curve

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_rc_curve
Visual Basic
Public Shared id_rc_curve As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_rc_cylinder Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_rc_cylinder Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Cylinder

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_rc_cylinder
Visual Basic
Public Shared id_rc_cylinder As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_rc_ellipse Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_rc_ellipse Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Circle

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_rc_ellipse
Visual Basic
Public Shared id_rc_ellipse As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_rc_extrusion Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_rc_extrusion Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Extrusion

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_rc_extrusion
Visual Basic
Public Shared id_rc_extrusion As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_rc_interval Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_rc_interval Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Interval

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_rc_interval
Visual Basic
Public Shared id_rc_interval As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_rc_line Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_rc_line Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Line

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_rc_line
Visual Basic
Public Shared id_rc_line As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_rc_linecurve Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_rc_linecurve Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.LineCurve

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_rc_linecurve
Visual Basic
Public Shared id_rc_linecurve As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_rc_matrix Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_rc_matrix Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Matrix

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_rc_matrix
Visual Basic
Public Shared id_rc_matrix As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_rc_mesh Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_rc_mesh Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Mesh

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_rc_mesh
Visual Basic
Public Shared id_rc_mesh As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_rc_meshface Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_rc_meshface Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.MeshFace

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_rc_meshface
Visual Basic
Public Shared id_rc_meshface As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_rc_nurbscurve Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_rc_nurbscurve Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.NurbsCurve

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_rc_nurbscurve
Visual Basic
Public Shared id_rc_nurbscurve As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_rc_nurbssurface Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_rc_nurbssurface Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.NurbsSurface

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_rc_nurbssurface
Visual Basic
Public Shared id_rc_nurbssurface As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_rc_plane Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_rc_plane Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Plane

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_rc_plane
Visual Basic
Public Shared id_rc_plane As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_rc_planesurface Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_rc_planesurface Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.PlaneSurface

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_rc_planesurface
Visual Basic
Public Shared id_rc_planesurface As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_rc_point3d Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_rc_point3d Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Point3d

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_rc_point3d
Visual Basic
Public Shared id_rc_point3d As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_rc_point3f Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_rc_point3f Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Point3f

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_rc_point3f
Visual Basic
Public Shared id_rc_point3f As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_rc_polycurve Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_rc_polycurve Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.PolyCurve

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_rc_polycurve
Visual Basic
Public Shared id_rc_polycurve As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_rc_polyline Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_rc_polyline Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Polyline

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_rc_polyline
Visual Basic
Public Shared id_rc_polyline As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_rc_polylinecurve Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_rc_polylinecurve Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.PolylineCurve

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_rc_polylinecurve
Visual Basic
Public Shared id_rc_polylinecurve As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_rc_rectangle Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_rc_rectangle Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Rectangle3d

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_rc_rectangle
Visual Basic
Public Shared id_rc_rectangle As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_rc_revsurface Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_rc_revsurface Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.RevSurface

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_rc_revsurface
Visual Basic
Public Shared id_rc_revsurface As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_rc_sphere Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_rc_sphere Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Torus

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_rc_sphere
Visual Basic
Public Shared id_rc_sphere As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_rc_sumsurface Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_rc_sumsurface Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.SumSurface

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_rc_sumsurface
Visual Basic
Public Shared id_rc_sumsurface As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_rc_surface Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_rc_surface Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Surface

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_rc_surface
Visual Basic
Public Shared id_rc_surface As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_rc_torus Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_rc_torus Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Torus

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_rc_torus
Visual Basic
Public Shared id_rc_torus As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_rc_transform Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_rc_transform Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Transform

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_rc_transform
Visual Basic
Public Shared id_rc_transform As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_rc_vector3d Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_rc_vector3d Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Vector3d

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_rc_vector3d
Visual Basic
Public Shared id_rc_vector3d As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_rc_vector3f Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_rc_vector3f Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Vector3f

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_rc_vector3f
Visual Basic
Public Shared id_rc_vector3f As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_rectangle Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_rectangle Field
GH_TypeLib Class See Also Send Feedback
System.Drawing.Rectangle

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_rectangle
Visual Basic
Public Shared id_rectangle As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_rectanglef Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_rectanglef Field
GH_TypeLib Class See Also Send Feedback
System.Drawing.RectangleF

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_rectanglef
Visual Basic
Public Shared id_rectanglef As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_single Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_single Field
GH_TypeLib Class See Also Send Feedback
System.Single

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_single
Visual Basic
Public Shared id_single As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_size Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_size Field
GH_TypeLib Class See Also Send Feedback
System.Drawing.Size

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_size
Visual Basic
Public Shared id_size As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_sizef Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_sizef Field
GH_TypeLib Class See Also Send Feedback
System.Drawing.SizeF

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_sizef
Visual Basic
Public Shared id_sizef As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_string Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_string Field
GH_TypeLib Class See Also Send Feedback
System.String

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_string
Visual Basic
Public Shared id_string As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_time Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_time Field
GH_TypeLib Class See Also Send Feedback
System.Date

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_time
Visual Basic
Public Shared id_time As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_uint16 Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_uint16 Field
GH_TypeLib Class See Also Send Feedback
System.UInt16

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_uint16
Visual Basic
Public Shared id_uint16 As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_uint32 Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_uint32 Field
GH_TypeLib Class See Also Send Feedback
System.UInt32

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_uint32
Visual Basic
Public Shared id_uint32 As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


id_uint64 Field

[image]

Grasshopper SDK
GH_TypeLib..::..id_uint64 Field
GH_TypeLib Class See Also Send Feedback
System.UInt64

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid id_uint64
Visual Basic
Public Shared id_uint64 As Guid

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_bool Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_bool Field
GH_TypeLib Class See Also Send Feedback
System.Boolean

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_bool
Visual Basic
Public Shared t_bool As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_byte Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_byte Field
GH_TypeLib Class See Also Send Feedback
System.Byte

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_byte
Visual Basic
Public Shared t_byte As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_char Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_char Field
GH_TypeLib Class See Also Send Feedback
System.Char

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_char
Visual Basic
Public Shared t_char As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_color Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_color Field
GH_TypeLib Class See Also Send Feedback
System.Drawing.Color

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_color
Visual Basic
Public Shared t_color As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_decimal Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_decimal Field
GH_TypeLib Class See Also Send Feedback
System.Decimal

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_decimal
Visual Basic
Public Shared t_decimal As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_double Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_double Field
GH_TypeLib Class See Also Send Feedback
System.Double

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_double
Visual Basic
Public Shared t_double As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_gh_arc Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_gh_arc Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Arc

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_gh_arc
Visual Basic
Public Shared t_gh_arc As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_gh_bool Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_gh_bool Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Boolean

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_gh_bool
Visual Basic
Public Shared t_gh_bool As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_gh_box Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_gh_box Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Box

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_gh_box
Visual Basic
Public Shared t_gh_box As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_gh_brep Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_gh_brep Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Brep

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_gh_brep
Visual Basic
Public Shared t_gh_brep As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_gh_circle Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_gh_circle Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Circle

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_gh_circle
Visual Basic
Public Shared t_gh_circle As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_gh_colour Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_gh_colour Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Colour

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_gh_colour
Visual Basic
Public Shared t_gh_colour As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_gh_complex Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_gh_complex Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.Complex

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_gh_complex
Visual Basic
Public Shared t_gh_complex As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_gh_complexnumber Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_gh_complexnumber Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_ComplexNumber

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_gh_complexnumber
Visual Basic
Public Shared t_gh_complexnumber As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_gh_curve Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_gh_curve Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Curve

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_gh_curve
Visual Basic
Public Shared t_gh_curve As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_gh_goo Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_gh_goo Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.IGH_Goo

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_gh_goo
Visual Basic
Public Shared t_gh_goo As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_gh_guid Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_gh_guid Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Guid

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_gh_guid
Visual Basic
Public Shared t_gh_guid As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_gh_int Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_gh_int Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Integer

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_gh_int
Visual Basic
Public Shared t_gh_int As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_gh_interval Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_gh_interval Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Interval

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_gh_interval
Visual Basic
Public Shared t_gh_interval As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_gh_interval2D Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_gh_interval2D Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Interval2D

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_gh_interval2D
Visual Basic
Public Shared t_gh_interval2D As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_gh_line Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_gh_line Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Line

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_gh_line
Visual Basic
Public Shared t_gh_line As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_gh_material Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_gh_material Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Material

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_gh_material
Visual Basic
Public Shared t_gh_material As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_gh_matrix Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_gh_matrix Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Matrix

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_gh_matrix
Visual Basic
Public Shared t_gh_matrix As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_gh_mesh Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_gh_mesh Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Mesh

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_gh_mesh
Visual Basic
Public Shared t_gh_mesh As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_gh_meshface Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_gh_meshface Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_MeshFace

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_gh_meshface
Visual Basic
Public Shared t_gh_meshface As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_gh_number Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_gh_number Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Number

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_gh_number
Visual Basic
Public Shared t_gh_number As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_gh_objwrapper Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_gh_objwrapper Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_ObjectWrapper

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_gh_objwrapper
Visual Basic
Public Shared t_gh_objwrapper As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_gh_path Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_gh_path Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Data.GH_Path

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_gh_path
Visual Basic
Public Shared t_gh_path As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_gh_plane Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_gh_plane Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Plane

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_gh_plane
Visual Basic
Public Shared t_gh_plane As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_gh_point Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_gh_point Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Point

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_gh_point
Visual Basic
Public Shared t_gh_point As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_gh_rectangle Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_gh_rectangle Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Rectangle

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_gh_rectangle
Visual Basic
Public Shared t_gh_rectangle As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_gh_string Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_gh_string Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_String

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_gh_string
Visual Basic
Public Shared t_gh_string As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_gh_structpath Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_gh_structpath Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_StructurePath

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_gh_structpath
Visual Basic
Public Shared t_gh_structpath As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_gh_surface Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_gh_surface Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Surface

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_gh_surface
Visual Basic
Public Shared t_gh_surface As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_gh_time Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_gh_time Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Time

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_gh_time
Visual Basic
Public Shared t_gh_time As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_gh_transform Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_gh_transform Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Transform

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_gh_transform
Visual Basic
Public Shared t_gh_transform As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_gh_uvinterval Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_gh_uvinterval Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.UVInterval

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_gh_uvinterval
Visual Basic
Public Shared t_gh_uvinterval As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_gh_vector Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_gh_vector Field
GH_TypeLib Class See Also Send Feedback
Grasshopper.Kernel.Types.GH_Vector

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_gh_vector
Visual Basic
Public Shared t_gh_vector As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_guid Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_guid Field
GH_TypeLib Class See Also Send Feedback
System.Guid

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_guid
Visual Basic
Public Shared t_guid As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_int16 Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_int16 Field
GH_TypeLib Class See Also Send Feedback
System.Int16

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_int16
Visual Basic
Public Shared t_int16 As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_int32 Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_int32 Field
GH_TypeLib Class See Also Send Feedback
System.Int32

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_int32
Visual Basic
Public Shared t_int32 As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_int64 Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_int64 Field
GH_TypeLib Class See Also Send Feedback
System.Int64

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_int64
Visual Basic
Public Shared t_int64 As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_object Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_object Field
GH_TypeLib Class See Also Send Feedback
System.Object

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_object
Visual Basic
Public Shared t_object As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_point Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_point Field
GH_TypeLib Class See Also Send Feedback
System.Drawing.Point

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_point
Visual Basic
Public Shared t_point As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_pointf Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_pointf Field
GH_TypeLib Class See Also Send Feedback
System.Drawing.PointF

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_pointf
Visual Basic
Public Shared t_pointf As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_rc_arc Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_rc_arc Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Arc

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_rc_arc
Visual Basic
Public Shared t_rc_arc As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_rc_arccurve Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_rc_arccurve Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.ArcCurve

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_rc_arccurve
Visual Basic
Public Shared t_rc_arccurve As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_rc_boundingbox Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_rc_boundingbox Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.BoundingBox

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_rc_boundingbox
Visual Basic
Public Shared t_rc_boundingbox As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_rc_box Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_rc_box Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Box

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_rc_box
Visual Basic
Public Shared t_rc_box As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_rc_brep Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_rc_brep Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Brep

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_rc_brep
Visual Basic
Public Shared t_rc_brep As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_rc_brepedge Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_rc_brepedge Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.MeshEdge

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_rc_brepedge
Visual Basic
Public Shared t_rc_brepedge As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_rc_brepface Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_rc_brepface Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.MeshFace

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_rc_brepface
Visual Basic
Public Shared t_rc_brepface As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_rc_circle Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_rc_circle Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Circle

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_rc_circle
Visual Basic
Public Shared t_rc_circle As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_rc_cone Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_rc_cone Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Cone

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_rc_cone
Visual Basic
Public Shared t_rc_cone As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_rc_curve Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_rc_curve Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Curve

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_rc_curve
Visual Basic
Public Shared t_rc_curve As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_rc_cylinder Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_rc_cylinder Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Cylinder

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_rc_cylinder
Visual Basic
Public Shared t_rc_cylinder As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_rc_ellipse Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_rc_ellipse Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Circle

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_rc_ellipse
Visual Basic
Public Shared t_rc_ellipse As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_rc_extrusion Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_rc_extrusion Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Extrusion.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_rc_extrusion
Visual Basic
Public Shared t_rc_extrusion As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_rc_interval Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_rc_interval Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Interval

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_rc_interval
Visual Basic
Public Shared t_rc_interval As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_rc_line Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_rc_line Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Line

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_rc_line
Visual Basic
Public Shared t_rc_line As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_rc_linecurve Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_rc_linecurve Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.LineCurve

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_rc_linecurve
Visual Basic
Public Shared t_rc_linecurve As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_rc_matrix Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_rc_matrix Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Matrix

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_rc_matrix
Visual Basic
Public Shared t_rc_matrix As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_rc_mesh Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_rc_mesh Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Mesh

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_rc_mesh
Visual Basic
Public Shared t_rc_mesh As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_rc_meshface Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_rc_meshface Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.MeshFace

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_rc_meshface
Visual Basic
Public Shared t_rc_meshface As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_rc_nurbscurve Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_rc_nurbscurve Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.NurbsCurve

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_rc_nurbscurve
Visual Basic
Public Shared t_rc_nurbscurve As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_rc_nurbssurface Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_rc_nurbssurface Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.NurbsSurface

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_rc_nurbssurface
Visual Basic
Public Shared t_rc_nurbssurface As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_rc_plane Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_rc_plane Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Plane

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_rc_plane
Visual Basic
Public Shared t_rc_plane As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_rc_planesurface Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_rc_planesurface Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.PlaneSurface

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_rc_planesurface
Visual Basic
Public Shared t_rc_planesurface As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_rc_point3d Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_rc_point3d Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Point3d

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_rc_point3d
Visual Basic
Public Shared t_rc_point3d As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_rc_point3f Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_rc_point3f Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Point3f

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_rc_point3f
Visual Basic
Public Shared t_rc_point3f As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_rc_polycurve Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_rc_polycurve Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.PolyCurve

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_rc_polycurve
Visual Basic
Public Shared t_rc_polycurve As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_rc_polyline Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_rc_polyline Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Polyline

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_rc_polyline
Visual Basic
Public Shared t_rc_polyline As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_rc_polylinecurve Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_rc_polylinecurve Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.PolylineCurve

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_rc_polylinecurve
Visual Basic
Public Shared t_rc_polylinecurve As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_rc_rectangle Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_rc_rectangle Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Rectangle3d

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_rc_rectangle
Visual Basic
Public Shared t_rc_rectangle As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_rc_revsurface Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_rc_revsurface Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.RevSurface

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_rc_revsurface
Visual Basic
Public Shared t_rc_revsurface As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_rc_sphere Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_rc_sphere Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Torus

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_rc_sphere
Visual Basic
Public Shared t_rc_sphere As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_rc_sumsurface Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_rc_sumsurface Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.SumSurface

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_rc_sumsurface
Visual Basic
Public Shared t_rc_sumsurface As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_rc_surface Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_rc_surface Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Surface

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_rc_surface
Visual Basic
Public Shared t_rc_surface As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_rc_torus Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_rc_torus Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Torus

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_rc_torus
Visual Basic
Public Shared t_rc_torus As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_rc_transform Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_rc_transform Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Transform

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_rc_transform
Visual Basic
Public Shared t_rc_transform As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_rc_vector3d Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_rc_vector3d Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Vector3d

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_rc_vector3d
Visual Basic
Public Shared t_rc_vector3d As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_rc_vector3f Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_rc_vector3f Field
GH_TypeLib Class See Also Send Feedback
Rhino.Geometry.Vector3f

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_rc_vector3f
Visual Basic
Public Shared t_rc_vector3f As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_rectangle Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_rectangle Field
GH_TypeLib Class See Also Send Feedback
System.Drawing.Rectangle

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_rectangle
Visual Basic
Public Shared t_rectangle As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_rectanglef Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_rectanglef Field
GH_TypeLib Class See Also Send Feedback
System.Drawing.RectangleF

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_rectanglef
Visual Basic
Public Shared t_rectanglef As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_single Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_single Field
GH_TypeLib Class See Also Send Feedback
System.Single

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_single
Visual Basic
Public Shared t_single As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_size Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_size Field
GH_TypeLib Class See Also Send Feedback
System.Drawing.Size

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_size
Visual Basic
Public Shared t_size As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_sizef Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_sizef Field
GH_TypeLib Class See Also Send Feedback
System.Drawing.SizeF

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_sizef
Visual Basic
Public Shared t_sizef As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_string Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_string Field
GH_TypeLib Class See Also Send Feedback
System.String

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_string
Visual Basic
Public Shared t_string As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_time Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_time Field
GH_TypeLib Class See Also Send Feedback
System.Date

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_time
Visual Basic
Public Shared t_time As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_uint16 Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_uint16 Field
GH_TypeLib Class See Also Send Feedback
System.UInt16

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_uint16
Visual Basic
Public Shared t_uint16 As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_uint32 Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_uint32 Field
GH_TypeLib Class See Also Send Feedback
System.UInt32

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_uint32
Visual Basic
Public Shared t_uint32 As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


t_uint64 Field

[image]

Grasshopper SDK
GH_TypeLib..::..t_uint64 Field
GH_TypeLib Class See Also Send Feedback
System.UInt64

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Type t_uint64
Visual Basic
Public Shared t_uint64 As Type

See Also

GH_TypeLib Class
Grasshopper.Kernel Namespace


GH_UndoOperation Enumeration

[image]

Grasshopper SDK
GH_UndoOperation Enumeration
See Also Send Feedback
Enumerates all possible types of undo operation.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_UndoOperation
Visual Basic
Public Enumeration GH_UndoOperation

Members

Member name | Value | Description
ClearUndoStack | 0 | The stack with all undo records has been cleared.
ClearRedoStack | 1 | The stack with all redo records has been cleared. This always happens when a new undo record is added.
RecordAdded | 2 | A new undo record is added to the list. There will be a ClearRedoStack event after this one.
RecordRemoved | 3 | A specific record has been deleted. This is not a typical operation and is usually due to user intervention. Removal can occur from both the undo and the redo stack.
Undo | 4 | An undo operation was successfully completed. This means a record has been moved from the undo stack to the redo stack.
Redo | 5 | A redo operation was successfully completed. This means a record has been moved from the redo stack back onto the undo stack. This does not count as a RecordAdded operation.

See Also

Grasshopper.Kernel Namespace


GH_UpgradeUtil Class

[image]

Grasshopper SDK
GH_UpgradeUtil Class
Members See Also Send Feedback
Exposes several utility functions for migrating parameters and wires between components useful while upgrading components.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_UpgradeUtil
Visual Basic
Public Class GH_UpgradeUtil

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_UpgradeUtil

See Also

GH_UpgradeUtil Members
Grasshopper.Kernel Namespace


GH_UpgradeUtil Members

[image] [image]

Grasshopper SDK
GH_UpgradeUtil Members
GH_UpgradeUtil Class Constructors Methods See Also Send Feedback

The GH_UpgradeUtil type exposes the following members.

Constructors

 | Name | Description
Public method | GH_UpgradeUtil | Initializes a new instance of the GH_UpgradeUtil class

Methods

Name | Description
MigrateInputParameters(IGH_Component, IGH_Component) | Migrate all input parameters.
MigrateInputParameters(IGH_Component, IGH_Component, array<Int32>[]()[][], array<Int32>[]()[][]) | Migrate a bunch of input parameters.
MigrateOutputParameters(IGH_Component, IGH_Component) | Migrate all output parameters.
MigrateOutputParameters(IGH_Component, IGH_Component, array<Int32>[]()[][], array<Int32>[]()[][]) | Migrate a bunch of output parameters.
MigrateRecipients | Migrate all recipients from A to B, while maintaining order.
MigrateSources | Migrate all sources from A to B, while maintaining order.
ReplaceInputParameters | Move all input parameters from one component to another. Only use this function if the target component can handle the input layout of the source component.
ReplaceOutputParameters | Move all output parameters from one component to another. Only use this function if the target component can handle the output layout of the source component.
SwapComponents(IGH_Component, IGH_Component) | Replace an existing component with a different one. All parameters (input and output) will be migrated.
SwapComponents(IGH_Component, Guid) | Replace an existing component with a different one. All parameters (input and output) will be migrated.
SwapComponents(IGH_Component, IGH_Component, Boolean) | Replace an existing component with a different one. All parameters (input and output) will be migrated.
SwapComponents(IGH_Component, Guid, Boolean) | Replace an existing component with a different one. All parameters (input and output) will be migrated.

See Also

GH_UpgradeUtil Class
Grasshopper.Kernel Namespace


GH_UpgradeUtil Constructor

[image]

Grasshopper SDK
GH_UpgradeUtil Constructor
GH_UpgradeUtil Class See Also Send Feedback
Initializes a new instance of the GH_UpgradeUtil class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_UpgradeUtil()
Visual Basic
Public Sub New

See Also

GH_UpgradeUtil Class
Grasshopper.Kernel Namespace


GH_UpgradeUtil Methods

[image] [image]

Grasshopper SDK
GH_UpgradeUtil Methods
GH_UpgradeUtil Class See Also Send Feedback

The GH_UpgradeUtil type exposes the following members.

Methods

Name | Description
MigrateInputParameters(IGH_Component, IGH_Component) | Migrate all input parameters.
MigrateInputParameters(IGH_Component, IGH_Component, array<Int32>[]()[][], array<Int32>[]()[][]) | Migrate a bunch of input parameters.
MigrateOutputParameters(IGH_Component, IGH_Component) | Migrate all output parameters.
MigrateOutputParameters(IGH_Component, IGH_Component, array<Int32>[]()[][], array<Int32>[]()[][]) | Migrate a bunch of output parameters.
MigrateRecipients | Migrate all recipients from A to B, while maintaining order.
MigrateSources | Migrate all sources from A to B, while maintaining order.
ReplaceInputParameters | Move all input parameters from one component to another. Only use this function if the target component can handle the input layout of the source component.
ReplaceOutputParameters | Move all output parameters from one component to another. Only use this function if the target component can handle the output layout of the source component.
SwapComponents(IGH_Component, IGH_Component) | Replace an existing component with a different one. All parameters (input and output) will be migrated.
SwapComponents(IGH_Component, Guid) | Replace an existing component with a different one. All parameters (input and output) will be migrated.
SwapComponents(IGH_Component, IGH_Component, Boolean) | Replace an existing component with a different one. All parameters (input and output) will be migrated.
SwapComponents(IGH_Component, Guid, Boolean) | Replace an existing component with a different one. All parameters (input and output) will be migrated.

See Also

GH_UpgradeUtil Class
Grasshopper.Kernel Namespace


MigrateInputParameters Method

[image] [image]

Grasshopper SDK
GH_UpgradeUtil..::..MigrateInputParameters Method
GH_UpgradeUtil Class See Also Send Feedback

Overload List

Name | Description
MigrateInputParameters(IGH_Component, IGH_Component) | Migrate all input parameters.
MigrateInputParameters(IGH_Component, IGH_Component, array<Int32>[]()[][], array<Int32>[]()[][]) | Migrate a bunch of input parameters.

See Also

GH_UpgradeUtil Class
GH_UpgradeUtil Members
Grasshopper.Kernel Namespace


MigrateInputParameters Method (IGH_Component, IGH_Component)

[image]

Grasshopper SDK
GH_UpgradeUtil..::..MigrateInputParameters Method (IGH_Component, IGH_Component)
GH_UpgradeUtil Class See Also Send Feedback
Migrate all input parameters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool MigrateInputParameters(
    IGH_Component source,
    IGH_Component target
)
Visual Basic
Public Shared Function MigrateInputParameters ( _
    source As IGH_Component, _
    target As IGH_Component _
) As Boolean

Parameters

source
Type: Grasshopper.Kernel..::..IGH_Component
Source component.
target
Type: Grasshopper.Kernel..::..IGH_Component
Target component.

Return Value

True on success, false on failure.

See Also

GH_UpgradeUtil Class
MigrateInputParameters Overload
Grasshopper.Kernel Namespace


MigrateInputParameters Method (IGH_Component, IGH_Component, Int32[], Int32[])

[image]

Grasshopper SDK
GH_UpgradeUtil..::..MigrateInputParameters Method (IGH_Component, IGH_Component, array<Int32>[]()[][], array<Int32>[]()[][])
GH_UpgradeUtil Class See Also Send Feedback
Migrate a bunch of input parameters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool MigrateInputParameters(
    IGH_Component source,
    IGH_Component target,
    int[] index0,
    int[] index1
)
Visual Basic
Public Shared Function MigrateInputParameters ( _
    source As IGH_Component, _
    target As IGH_Component, _
    index0 As Integer(), _
    index1 As Integer() _
) As Boolean

Parameters

source
Type: Grasshopper.Kernel..::..IGH_Component
Source component.
target
Type: Grasshopper.Kernel..::..IGH_Component
Target component.
index0
Type: array< System..::..Int32 >[]()[][]
List of input indices to migrate.
index1
Type: array< System..::..Int32 >[]()[][]
Matching list of target indices.

Return Value

True on success, false on failure.

See Also

GH_UpgradeUtil Class
MigrateInputParameters Overload
Grasshopper.Kernel Namespace


MigrateOutputParameters Method

[image] [image]

Grasshopper SDK
GH_UpgradeUtil..::..MigrateOutputParameters Method
GH_UpgradeUtil Class See Also Send Feedback

Overload List

Name | Description
MigrateOutputParameters(IGH_Component, IGH_Component) | Migrate all output parameters.
MigrateOutputParameters(IGH_Component, IGH_Component, array<Int32>[]()[][], array<Int32>[]()[][]) | Migrate a bunch of output parameters.

See Also

GH_UpgradeUtil Class
GH_UpgradeUtil Members
Grasshopper.Kernel Namespace


MigrateOutputParameters Method (IGH_Component, IGH_Component)

[image]

Grasshopper SDK
GH_UpgradeUtil..::..MigrateOutputParameters Method (IGH_Component, IGH_Component)
GH_UpgradeUtil Class See Also Send Feedback
Migrate all output parameters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool MigrateOutputParameters(
    IGH_Component source,
    IGH_Component target
)
Visual Basic
Public Shared Function MigrateOutputParameters ( _
    source As IGH_Component, _
    target As IGH_Component _
) As Boolean

Parameters

source
Type: Grasshopper.Kernel..::..IGH_Component
Source component.
target
Type: Grasshopper.Kernel..::..IGH_Component
Target component.

Return Value

True on success, false on failure.

See Also

GH_UpgradeUtil Class
MigrateOutputParameters Overload
Grasshopper.Kernel Namespace


MigrateOutputParameters Method (IGH_Component, IGH_Component, Int32[], Int32[])

[image]

Grasshopper SDK
GH_UpgradeUtil..::..MigrateOutputParameters Method (IGH_Component, IGH_Component, array<Int32>[]()[][], array<Int32>[]()[][])
GH_UpgradeUtil Class See Also Send Feedback
Migrate a bunch of output parameters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool MigrateOutputParameters(
    IGH_Component source,
    IGH_Component target,
    int[] index0,
    int[] index1
)
Visual Basic
Public Shared Function MigrateOutputParameters ( _
    source As IGH_Component, _
    target As IGH_Component, _
    index0 As Integer(), _
    index1 As Integer() _
) As Boolean

Parameters

source
Type: Grasshopper.Kernel..::..IGH_Component
Source component.
target
Type: Grasshopper.Kernel..::..IGH_Component
Target component.
index0
Type: array< System..::..Int32 >[]()[][]
List of output indices to migrate.
index1
Type: array< System..::..Int32 >[]()[][]
Matching list of target indices.

Return Value

True on success, false on failure.

See Also

GH_UpgradeUtil Class
MigrateOutputParameters Overload
Grasshopper.Kernel Namespace


MigrateRecipients Method

[image]

Grasshopper SDK
GH_UpgradeUtil..::..MigrateRecipients Method
GH_UpgradeUtil Class See Also Send Feedback
Migrate all recipients from A to B, while maintaining order.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static int MigrateRecipients(
    IGH_Param from,
    IGH_Param to
)
Visual Basic
Public Shared Function MigrateRecipients ( _
    from As IGH_Param, _
    to As IGH_Param _
) As Integer

Parameters

from
Type: Grasshopper.Kernel..::..IGH_Param
Parameter to move recipients from.
to
Type: Grasshopper.Kernel..::..IGH_Param
Parameter to move recipients to.

Return Value

Number of recipients migrated.

See Also

GH_UpgradeUtil Class
Grasshopper.Kernel Namespace


MigrateSources Method

[image]

Grasshopper SDK
GH_UpgradeUtil..::..MigrateSources Method
GH_UpgradeUtil Class See Also Send Feedback
Migrate all sources from A to B, while maintaining order.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static int MigrateSources(
    IGH_Param from,
    IGH_Param to
)
Visual Basic
Public Shared Function MigrateSources ( _
    from As IGH_Param, _
    to As IGH_Param _
) As Integer

Parameters

from
Type: Grasshopper.Kernel..::..IGH_Param
Parameter to move sources from.
to
Type: Grasshopper.Kernel..::..IGH_Param
Parameter to move sources to.

Return Value

Number of sources migrated.

See Also

GH_UpgradeUtil Class
Grasshopper.Kernel Namespace


ReplaceInputParameters Method

[image]

Grasshopper SDK
GH_UpgradeUtil..::..ReplaceInputParameters Method
GH_UpgradeUtil Class See Also Send Feedback
Move all input parameters from one component to another. Only use this function if the target component can handle the input layout of the source component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void ReplaceInputParameters(
    IGH_Component source,
    IGH_Component target
)
Visual Basic
Public Shared Sub ReplaceInputParameters ( _
    source As IGH_Component, _
    target As IGH_Component _
)

Parameters

source
Type: Grasshopper.Kernel..::..IGH_Component
Component to move parameters from.
target
Type: Grasshopper.Kernel..::..IGH_Component
Component to move parameters to.

See Also

GH_UpgradeUtil Class
Grasshopper.Kernel Namespace


ReplaceOutputParameters Method

[image]

Grasshopper SDK
GH_UpgradeUtil..::..ReplaceOutputParameters Method
GH_UpgradeUtil Class See Also Send Feedback
Move all output parameters from one component to another. Only use this function if the target component can handle the output layout of the source component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void ReplaceOutputParameters(
    IGH_Component source,
    IGH_Component target
)
Visual Basic
Public Shared Sub ReplaceOutputParameters ( _
    source As IGH_Component, _
    target As IGH_Component _
)

Parameters

source
Type: Grasshopper.Kernel..::..IGH_Component
Component to move parameters from.
target
Type: Grasshopper.Kernel..::..IGH_Component
Component to move parameters to.

See Also

GH_UpgradeUtil Class
Grasshopper.Kernel Namespace


SwapComponents Method

[image] [image]

Grasshopper SDK
GH_UpgradeUtil..::..SwapComponents Method
GH_UpgradeUtil Class See Also Send Feedback

Overload List

Name | Description
SwapComponents(IGH_Component, IGH_Component) | Replace an existing component with a different one. All parameters (input and output) will be migrated.
SwapComponents(IGH_Component, Guid) | Replace an existing component with a different one. All parameters (input and output) will be migrated.
SwapComponents(IGH_Component, IGH_Component, Boolean) | Replace an existing component with a different one. All parameters (input and output) will be migrated.
SwapComponents(IGH_Component, Guid, Boolean) | Replace an existing component with a different one. All parameters (input and output) will be migrated.

See Also

GH_UpgradeUtil Class
GH_UpgradeUtil Members
Grasshopper.Kernel Namespace


SwapComponents Method (IGH_Component, IGH_Component)

[image]

Grasshopper SDK
GH_UpgradeUtil..::..SwapComponents Method (IGH_Component, IGH_Component)
GH_UpgradeUtil Class See Also Send Feedback
Replace an existing component with a different one. All parameters (input and output) will be migrated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool SwapComponents(
    IGH_Component oldComponent,
    IGH_Component newComponent
)
Visual Basic
Public Shared Function SwapComponents ( _
    oldComponent As IGH_Component, _
    newComponent As IGH_Component _
) As Boolean

Parameters

oldComponent
Type: Grasshopper.Kernel..::..IGH_Component
Component current in a GH_Document.
newComponent
Type: Grasshopper.Kernel..::..IGH_Component
Component to swap.

Return Value

True on success, false on failure.

See Also

GH_UpgradeUtil Class
SwapComponents Overload
Grasshopper.Kernel Namespace


SwapComponents Method (IGH_Component, Guid)

[image]

Grasshopper SDK
GH_UpgradeUtil..::..SwapComponents Method (IGH_Component, Guid)
GH_UpgradeUtil Class See Also Send Feedback
Replace an existing component with a different one. All parameters (input and output) will be migrated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static IGH_Component SwapComponents(
    IGH_Component oldComponent,
    Guid newComponentGuid
)
Visual Basic
Public Shared Function SwapComponents ( _
    oldComponent As IGH_Component, _
    newComponentGuid As Guid _
) As IGH_Component

Parameters

oldComponent
Type: Grasshopper.Kernel..::..IGH_Component
Component current in a GH_Document.
newComponentGuid
Type: System..::..Guid
ComponentGuid of the component to add.

Return Value

Component that was added.

See Also

GH_UpgradeUtil Class
SwapComponents Overload
Grasshopper.Kernel Namespace


SwapComponents Method (IGH_Component, IGH_Component, Boolean)

[image]

Grasshopper SDK
GH_UpgradeUtil..::..SwapComponents Method (IGH_Component, IGH_Component, Boolean)
GH_UpgradeUtil Class See Also Send Feedback
Replace an existing component with a different one. All parameters (input and output) will be migrated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool SwapComponents(
    IGH_Component oldComponent,
    IGH_Component newComponent,
    bool migrateParameters
)
Visual Basic
Public Shared Function SwapComponents ( _
    oldComponent As IGH_Component, _
    newComponent As IGH_Component, _
    migrateParameters As Boolean _
) As Boolean

Parameters

oldComponent
Type: Grasshopper.Kernel..::..IGH_Component
Component current in a GH_Document.
newComponent
Type: Grasshopper.Kernel..::..IGH_Component
Component to swap.
migrateParameters
Type: System..::..Boolean
If true, all parameters will be moved from old to new.

Return Value

True on success, false on failure.

See Also

GH_UpgradeUtil Class
SwapComponents Overload
Grasshopper.Kernel Namespace


SwapComponents Method (IGH_Component, Guid, Boolean)

[image]

Grasshopper SDK
GH_UpgradeUtil..::..SwapComponents Method (IGH_Component, Guid, Boolean)
GH_UpgradeUtil Class See Also Send Feedback
Replace an existing component with a different one. All parameters (input and output) will be migrated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static IGH_Component SwapComponents(
    IGH_Component oldComponent,
    Guid newComponentGuid,
    bool migrateParameters
)
Visual Basic
Public Shared Function SwapComponents ( _
    oldComponent As IGH_Component, _
    newComponentGuid As Guid, _
    migrateParameters As Boolean _
) As IGH_Component

Parameters

oldComponent
Type: Grasshopper.Kernel..::..IGH_Component
Component current in a GH_Document.
newComponentGuid
Type: System..::..Guid
ComponentGuid of the component to add.
migrateParameters
Type: System..::..Boolean
If true, all parameters will be moved from old to new.

Return Value

Component that was added.

See Also

GH_UpgradeUtil Class
SwapComponents Overload
Grasshopper.Kernel Namespace


GH_UserObject Class

[image]

Grasshopper SDK
GH_UserObject Class
Members See Also Send Feedback
Represents a custom user object. A User Object is an existing IGH_DocumentObject with overridden icon, instance description and exposure.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_UserObject
Visual Basic
Public Class GH_UserObject

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_UserObject

See Also

GH_UserObject Members
Grasshopper.Kernel Namespace


GH_UserObject Members

[image] [image]

Grasshopper SDK
GH_UserObject Members
GH_UserObject Class Constructors Methods Properties See Also Send Feedback

The GH_UserObject type exposes the following members.

Constructors

 | Name | Description
Public method | GH_UserObject()()()() | Empty constructor
Public method | GH_UserObject(String) | Create a new user object from an existing *.ghuser file.

Methods

 | Name | Description
Public method | Clear | Destroy all data except the file path and the ID.
Public method | CreateDefaultPath | Set the Path field for this user object to the default. The default file name is derived from the Description.Name field. This method also ensures the UserObject directory exists.
Public method | InstantiateObject | Instantiate a new IGH_DocumentObject from this User Object.
Public method | ReadFromFile | Force an update of the local data from the file. The Path field must be set for this to work.
Public method | SaveToFile | Save the current User Object state to a file. Any existing file will be overwritten.
Public method | SetDataFromObject | Set the Data field content of ths UserObject from a Document object instance.

Properties

 | Name | Description
Public property | BaseGuid | Gets or sets the ComponentID of the IGH_DocumentObject that functions as the base class for this User Object.
Public property | Data | Gets or sets the serialized data. This data is used to deserialize a new instance of the base class.
Public property | Description | Gets or sets the Instance Description override for this User Object.
Public property | Exposure | Gets or sets the Exposure of this User Object.
Public property | Guid | Gets or sets the Guid of this User Object. The Guid is created anew during construction and is not stored in the User Object File. You should never have to set this field.
Public property | Icon | Gets or sets the icon associated with this User Object. If the icon hasn't been overridden, then a Default icon is returned.
Public property | Path | Gets or sets the file path this User Object is loaded from or saved to.

See Also

GH_UserObject Class
Grasshopper.Kernel Namespace


GH_UserObject Constructor

[image] [image]

Grasshopper SDK
GH_UserObject Constructor
GH_UserObject Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_UserObject()()()() | Empty constructor
Public method | GH_UserObject(String) | Create a new user object from an existing *.ghuser file.

See Also

GH_UserObject Class
GH_UserObject Members
Grasshopper.Kernel Namespace


GH_UserObject Constructor

[image]

Grasshopper SDK
GH_UserObject Constructor
GH_UserObject Class See Also Send Feedback
Empty constructor

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_UserObject()
Visual Basic
Public Sub New

See Also

GH_UserObject Class
GH_UserObject Overload
Grasshopper.Kernel Namespace


GH_UserObject Constructor (String)

[image]

Grasshopper SDK
GH_UserObject Constructor (String)
GH_UserObject Class See Also Send Feedback
Create a new user object from an existing *.ghuser file.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_UserObject(
    string source_file
)
Visual Basic
Public Sub New ( _
    source_file As String _
)

Parameters

source_file
Type: System..::..String
File that contains the User Object definition.

See Also

GH_UserObject Class
GH_UserObject Overload
Grasshopper.Kernel Namespace


GH_UserObject Methods

[image] [image]

Grasshopper SDK
GH_UserObject Methods
GH_UserObject Class See Also Send Feedback

The GH_UserObject type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Destroy all data except the file path and the ID.
Public method | CreateDefaultPath | Set the Path field for this user object to the default. The default file name is derived from the Description.Name field. This method also ensures the UserObject directory exists.
Public method | InstantiateObject | Instantiate a new IGH_DocumentObject from this User Object.
Public method | ReadFromFile | Force an update of the local data from the file. The Path field must be set for this to work.
Public method | SaveToFile | Save the current User Object state to a file. Any existing file will be overwritten.
Public method | SetDataFromObject | Set the Data field content of ths UserObject from a Document object instance.

See Also

GH_UserObject Class
Grasshopper.Kernel Namespace


Clear Method

[image]

Grasshopper SDK
GH_UserObject..::..Clear Method
GH_UserObject Class See Also Send Feedback
Destroy all data except the file path and the ID.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear

See Also

GH_UserObject Class
Grasshopper.Kernel Namespace


CreateDefaultPath Method

[image]

Grasshopper SDK
GH_UserObject..::..CreateDefaultPath Method
GH_UserObject Class See Also Send Feedback
Set the Path field for this user object to the default. The default file name is derived from the Description.Name field. This method also ensures the UserObject directory exists.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void CreateDefaultPath(
    bool avoid_conflict
)
Visual Basic
Public Sub CreateDefaultPath ( _
    avoid_conflict As Boolean _
)

Parameters

avoid_conflict
Type: System..::..Boolean
If true, a unique file path is assigned.

See Also

GH_UserObject Class
Grasshopper.Kernel Namespace


InstantiateObject Method

[image]

Grasshopper SDK
GH_UserObject..::..InstantiateObject Method
GH_UserObject Class See Also Send Feedback
Instantiate a new IGH_DocumentObject from this User Object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_DocumentObject InstantiateObject()
Visual Basic
Public Function InstantiateObject As IGH_DocumentObject

Return Value

The IGH_DocumentObject instance defined inside the UserObject file or null on error.

See Also

GH_UserObject Class
Grasshopper.Kernel Namespace


ReadFromFile Method

[image]

Grasshopper SDK
GH_UserObject..::..ReadFromFile Method
GH_UserObject Class See Also Send Feedback
Force an update of the local data from the file. The Path field must be set for this to work.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ReadFromFile()
Visual Basic
Public Sub ReadFromFile

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown when the source file doesn't exist or is corrupted.

See Also

GH_UserObject Class
Grasshopper.Kernel Namespace


SaveToFile Method

[image]

Grasshopper SDK
GH_UserObject..::..SaveToFile Method
GH_UserObject Class See Also Send Feedback
Save the current User Object state to a file. Any existing file will be overwritten.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool SaveToFile()
Visual Basic
Public Function SaveToFile As Boolean

Return Value

True on success, false on failure.

See Also

GH_UserObject Class
Grasshopper.Kernel Namespace


SetDataFromObject Method

[image]

Grasshopper SDK
GH_UserObject..::..SetDataFromObject Method
GH_UserObject Class See Also Send Feedback
Set the Data field content of ths UserObject from a Document object instance.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SetDataFromObject(
    IGH_DocumentObject obj
)
Visual Basic
Public Sub SetDataFromObject ( _
    obj As IGH_DocumentObject _
)

Parameters

obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject
Object to assign

See Also

GH_UserObject Class
Grasshopper.Kernel Namespace


GH_UserObject Properties

[image] [image]

Grasshopper SDK
GH_UserObject Properties
GH_UserObject Class See Also Send Feedback

The GH_UserObject type exposes the following members.

Properties

 | Name | Description
Public property | BaseGuid | Gets or sets the ComponentID of the IGH_DocumentObject that functions as the base class for this User Object.
Public property | Data | Gets or sets the serialized data. This data is used to deserialize a new instance of the base class.
Public property | Description | Gets or sets the Instance Description override for this User Object.
Public property | Exposure | Gets or sets the Exposure of this User Object.
Public property | Guid | Gets or sets the Guid of this User Object. The Guid is created anew during construction and is not stored in the User Object File. You should never have to set this field.
Public property | Icon | Gets or sets the icon associated with this User Object. If the icon hasn't been overridden, then a Default icon is returned.
Public property | Path | Gets or sets the file path this User Object is loaded from or saved to.

See Also

GH_UserObject Class
Grasshopper.Kernel Namespace


BaseGuid Property

[image]

Grasshopper SDK
GH_UserObject..::..BaseGuid Property
GH_UserObject Class See Also Send Feedback
Gets or sets the ComponentID of the IGH_DocumentObject that functions as the base class for this User Object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid BaseGuid { get; set; }
Visual Basic
Public Property BaseGuid As Guid
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_UserObject.BaseGuid"]

See Also

GH_UserObject Class
Grasshopper.Kernel Namespace


Data Property

[image]

Grasshopper SDK
GH_UserObject..::..Data Property
GH_UserObject Class See Also Send Feedback
Gets or sets the serialized data. This data is used to deserialize a new instance of the base class.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public byte[] Data { get; set; }
Visual Basic
Public Property Data As Byte()
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_UserObject.Data"]

See Also

GH_UserObject Class
Grasshopper.Kernel Namespace


Description Property

[image]

Grasshopper SDK
GH_UserObject..::..Description Property
GH_UserObject Class See Also Send Feedback
Gets or sets the Instance Description override for this User Object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_InstanceDescription Description { get; set; }
Visual Basic
Public Property Description As GH_InstanceDescription
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_UserObject.Description"]

See Also

GH_UserObject Class
Grasshopper.Kernel Namespace


Exposure Property

[image]

Grasshopper SDK
GH_UserObject..::..Exposure Property
GH_UserObject Class See Also Send Feedback
Gets or sets the Exposure of this User Object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Exposure Exposure { get; set; }
Visual Basic
Public Property Exposure As GH_Exposure
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_UserObject.Exposure"]

See Also

GH_UserObject Class
Grasshopper.Kernel Namespace


Guid Property

[image]

Grasshopper SDK
GH_UserObject..::..Guid Property
GH_UserObject Class See Also Send Feedback
Gets or sets the Guid of this User Object. The Guid is created anew during construction and is not stored in the User Object File. You should never have to set this field.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid Guid { get; set; }
Visual Basic
Public Property Guid As Guid
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_UserObject.Guid"]

See Also

GH_UserObject Class
Grasshopper.Kernel Namespace


Icon Property

[image]

Grasshopper SDK
GH_UserObject..::..Icon Property
GH_UserObject Class See Also Send Feedback
Gets or sets the icon associated with this User Object. If the icon hasn't been overridden, then a Default icon is returned.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Bitmap Icon { get; set; }
Visual Basic
Public Property Icon As Bitmap
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_UserObject.Icon"]

See Also

GH_UserObject Class
Grasshopper.Kernel Namespace


Path Property

[image]

Grasshopper SDK
GH_UserObject..::..Path Property
GH_UserObject Class See Also Send Feedback
Gets or sets the file path this User Object is loaded from or saved to.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Path { get; set; }
Visual Basic
Public Property Path As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_UserObject.Path"]

See Also

GH_UserObject Class
Grasshopper.Kernel Namespace


GH_ValueProxy(T) Class

[image]

Grasshopper SDK
GH_ValueProxy<(Of <(<'T>)>)> Class
Members See Also Send Feedback
Represents the abstract base implementation of the IGH_ValueProxy interface.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract class GH_ValueProxy<T> : IGH_ValueProxy
Visual Basic
Public MustInherit Class GH_ValueProxy(Of T) _
    Implements IGH_ValueProxy

Type Parameters

T
The type of this implementation

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_ValueProxy<(Of <(<'T>)>)>

See Also

GH_ValueProxy<(Of <(<'T>)>)> Members
Grasshopper.Kernel Namespace


GH_ValueProxy(T) Members

[image] [image]

Grasshopper SDK
GH_ValueProxy<(Of <(<'T>)>)> Members
GH_ValueProxy<(Of <(<'T>)>)> Class Constructors Methods Fields Properties See Also Send Feedback

The GH_ValueProxy<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Protected method | GH_ValueProxy<(Of <(<'T>)>)> | Default constructor for the base class. All derived classes must call this constructor.

Methods

 | Name | Description
Public method | Duplicate |
Public method | Duplicate_T |
Public method | FromString | Performs the String->Value parsing. The default implementation always returns False.
Public method | MutateString |
Public method | ToString | Performs a default ToString operation on the local value. If the value is Nothing, an empty String is returned. (Overrides Object..::..ToString()()()().)

Fields

 | Name | Description
Protected field | m_IsStringProxy |
Protected field | m_Name |
Protected field | m_UserString |
Protected field | m_Valid |
Protected field | m_Value |

Properties

 | Name | Description
Public property | IsParsable |
Public property | IsValid |
Public property | ProxyName |
Public property | ProxyType |
Public property | ProxyValue |
Public property | UserString | Wraps the protected m_UserString field
Public property | Value |

See Also

GH_ValueProxy<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


GH_ValueProxy(T) Constructor

[image]

Grasshopper SDK
GH_ValueProxy<(Of <(<'T>)>)> Constructor
GH_ValueProxy<(Of <(<'T>)>)> Class See Also Send Feedback
Default constructor for the base class. All derived classes must call this constructor.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_ValueProxy(
    T nValue,
    string nProxyName,
    bool bIsStringProxy
)
Visual Basic
Protected Sub New ( _
    nValue As T, _
    nProxyName As String, _
    bIsStringProxy As Boolean _
)

Parameters

nValue
Type: T
The value to store in this proxy
nProxyName
Type: System..::..String
The human-friendly name of this value type
bIsStringProxy
Type: System..::..Boolean
If True, then this proxy becomes Parsable.

See Also

GH_ValueProxy<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


GH_ValueProxy(T) Fields

[image] [image]

Grasshopper SDK
GH_ValueProxy<(Of <(<'T>)>)> Fields
GH_ValueProxy<(Of <(<'T>)>)> Class See Also Send Feedback

The GH_ValueProxy<(Of <(<'T>)>)> type exposes the following members.

Fields

 | Name | Description
Protected field | m_IsStringProxy |
Protected field | m_Name |
Protected field | m_UserString |
Protected field | m_Valid |
Protected field | m_Value |

See Also

GH_ValueProxy<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


m_IsStringProxy Field

[image]

Grasshopper SDK
GH_ValueProxy<(Of <(<'T>)>)>..::..m_IsStringProxy Field
GH_ValueProxy<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected bool m_IsStringProxy
Visual Basic
Protected m_IsStringProxy As Boolean

See Also

GH_ValueProxy<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


m_Name Field

[image]

Grasshopper SDK
GH_ValueProxy<(Of <(<'T>)>)>..::..m_Name Field
GH_ValueProxy<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected string m_Name
Visual Basic
Protected m_Name As String

See Also

GH_ValueProxy<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


m_UserString Field

[image]

Grasshopper SDK
GH_ValueProxy<(Of <(<'T>)>)>..::..m_UserString Field
GH_ValueProxy<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected string m_UserString
Visual Basic
Protected m_UserString As String

See Also

GH_ValueProxy<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


m_Valid Field

[image]

Grasshopper SDK
GH_ValueProxy<(Of <(<'T>)>)>..::..m_Valid Field
GH_ValueProxy<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected bool m_Valid
Visual Basic
Protected m_Valid As Boolean

See Also

GH_ValueProxy<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


m_Value Field

[image]

Grasshopper SDK
GH_ValueProxy<(Of <(<'T>)>)>..::..m_Value Field
GH_ValueProxy<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected T m_Value
Visual Basic
Protected m_Value As T

See Also

GH_ValueProxy<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


GH_ValueProxy(T) Methods

[image] [image]

Grasshopper SDK
GH_ValueProxy<(Of <(<'T>)>)> Methods
GH_ValueProxy<(Of <(<'T>)>)> Class See Also Send Feedback

The GH_ValueProxy<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Duplicate |
Public method | Duplicate_T |
Public method | FromString | Performs the String->Value parsing. The default implementation always returns False.
Public method | MutateString |
Public method | ToString | Performs a default ToString operation on the local value. If the value is Nothing, an empty String is returned. (Overrides Object..::..ToString()()()().)

See Also

GH_ValueProxy<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_ValueProxy<(Of <(<'T>)>)>..::..Duplicate Method
GH_ValueProxy<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_ValueProxy Duplicate()
Visual Basic
Public Function Duplicate As IGH_ValueProxy

Implements

IGH_ValueProxy..::..Duplicate()()()()

See Also

GH_ValueProxy<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Duplicate_T Method

[image]

Grasshopper SDK
GH_ValueProxy<(Of <(<'T>)>)>..::..Duplicate_T Method
GH_ValueProxy<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract GH_ValueProxy<T> Duplicate_T()
Visual Basic
Public MustOverride Function Duplicate_T As GH_ValueProxy(Of T)

See Also

GH_ValueProxy<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


FromString Method

[image]

Grasshopper SDK
GH_ValueProxy<(Of <(<'T>)>)>..::..FromString Method
GH_ValueProxy<(Of <(<'T>)>)> Class See Also Send Feedback
Performs the String->Value parsing. The default implementation always returns False.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool FromString(
    string in
)
Visual Basic
Public Overridable Function FromString ( _
    in As String _
) As Boolean

Parameters

in
Type: System..::..String
The String to parse

Return Value

True in cae of success, False in case of failure.

Implements

IGH_ValueProxy..::..FromString(String)

Remarks

The result of the parse is stored in the local value pointer. If this function returns False there is no guarantee the local value is still valid.

See Also

GH_ValueProxy<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


MutateString Method

[image]

Grasshopper SDK
GH_ValueProxy<(Of <(<'T>)>)>..::..MutateString Method
GH_ValueProxy<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual string MutateString(
    string in
)
Visual Basic
Public Overridable Function MutateString ( _
    in As String _
) As String

Parameters

in
Type: System..::..String

Implements

IGH_ValueProxy..::..MutateString(String)

See Also

GH_ValueProxy<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


ToString Method

[image]

Grasshopper SDK
GH_ValueProxy<(Of <(<'T>)>)>..::..ToString Method
GH_ValueProxy<(Of <(<'T>)>)> Class See Also Send Feedback
Performs a default ToString operation on the local value. If the value is Nothing, an empty String is returned.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Implements

IGH_ValueProxy..::..ToString()()()()

Remarks

Implementors: override this function if you need custom formatting logic.

See Also

GH_ValueProxy<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


GH_ValueProxy(T) Properties

[image] [image]

Grasshopper SDK
GH_ValueProxy<(Of <(<'T>)>)> Properties
GH_ValueProxy<(Of <(<'T>)>)> Class See Also Send Feedback

The GH_ValueProxy<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | IsParsable |
Public property | IsValid |
Public property | ProxyName |
Public property | ProxyType |
Public property | ProxyValue |
Public property | UserString | Wraps the protected m_UserString field
Public property | Value |

See Also

GH_ValueProxy<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


IsParsable Property

[image]

Grasshopper SDK
GH_ValueProxy<(Of <(<'T>)>)>..::..IsParsable Property
GH_ValueProxy<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsParsable { get; }
Visual Basic
Public ReadOnly Property IsParsable As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ValueProxy`1.IsParsable"]

Implements

IGH_ValueProxy..::..IsParsable

See Also

GH_ValueProxy<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


IsValid Property

[image]

Grasshopper SDK
GH_ValueProxy<(Of <(<'T>)>)>..::..IsValid Property
GH_ValueProxy<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool IsValid { get; }
Visual Basic
Public Overridable ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ValueProxy`1.IsValid"]

Implements

IGH_ValueProxy..::..IsValid

See Also

GH_ValueProxy<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


ProxyName Property

[image]

Grasshopper SDK
GH_ValueProxy<(Of <(<'T>)>)>..::..ProxyName Property
GH_ValueProxy<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string ProxyName { get; }
Visual Basic
Public ReadOnly Property ProxyName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ValueProxy`1.ProxyName"]

Implements

IGH_ValueProxy..::..ProxyName

See Also

GH_ValueProxy<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


ProxyType Property

[image]

Grasshopper SDK
GH_ValueProxy<(Of <(<'T>)>)>..::..ProxyType Property
GH_ValueProxy<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Type ProxyType { get; }
Visual Basic
Public ReadOnly Property ProxyType As Type
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ValueProxy`1.ProxyType"]

Implements

IGH_ValueProxy..::..ProxyType

See Also

GH_ValueProxy<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


ProxyValue Property

[image]

Grasshopper SDK
GH_ValueProxy<(Of <(<'T>)>)>..::..ProxyValue Property
GH_ValueProxy<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Object ProxyValue { get; }
Visual Basic
Public ReadOnly Property ProxyValue As Object
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ValueProxy`1.ProxyValue"]

Implements

IGH_ValueProxy..::..ProxyValue

See Also

GH_ValueProxy<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


UserString Property

[image]

Grasshopper SDK
GH_ValueProxy<(Of <(<'T>)>)>..::..UserString Property
GH_ValueProxy<(Of <(<'T>)>)> Class See Also Send Feedback
Wraps the protected m_UserString field

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string UserString { get; set; }
Visual Basic
Public Property UserString As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ValueProxy`1.UserString"]

Implements

IGH_ValueProxy..::..UserString

See Also

GH_ValueProxy<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


Value Property

[image]

Grasshopper SDK
GH_ValueProxy<(Of <(<'T>)>)>..::..Value Property
GH_ValueProxy<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public T Value { get; set; }
Visual Basic
Public Property Value As T
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ValueProxy`1.Value"]

See Also

GH_ValueProxy<(Of <(<'T>)>)> Class
Grasshopper.Kernel Namespace


GH_VarParamEventArgs Class

[image]

Grasshopper SDK
GH_VarParamEventArgs Class
Members See Also Send Feedback
Arguments used in Variable Parameter events.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_VarParamEventArgs : EventArgs
Visual Basic
Public Class GH_VarParamEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Grasshopper.Kernel..::..GH_VarParamEventArgs

See Also

GH_VarParamEventArgs Members
Grasshopper.Kernel Namespace


GH_VarParamEventArgs Members

[image] [image]

Grasshopper SDK
GH_VarParamEventArgs Members
GH_VarParamEventArgs Class Constructors Properties See Also Send Feedback

The GH_VarParamEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GH_VarParamEventArgs(IGH_Param, GH_VarParamSide) | Initializes a new instance of the GH_VarParamEventArgs class
Public method | GH_VarParamEventArgs(IGH_Param, GH_VarParamSide, Int32) | Initializes a new instance of the GH_VarParamEventArgs class

Properties

 | Name | Description
Public property | Index | Gets the index of the parameter.
Public property | Param | Gets the parameter.
Public property | Side | Gets the side of the parameter.

See Also

GH_VarParamEventArgs Class
Grasshopper.Kernel Namespace


GH_VarParamEventArgs Constructor

[image] [image]

Grasshopper SDK
GH_VarParamEventArgs Constructor
GH_VarParamEventArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_VarParamEventArgs(IGH_Param, GH_VarParamSide) | Initializes a new instance of the GH_VarParamEventArgs class
Public method | GH_VarParamEventArgs(IGH_Param, GH_VarParamSide, Int32) | Initializes a new instance of the GH_VarParamEventArgs class

See Also

GH_VarParamEventArgs Class
GH_VarParamEventArgs Members
Grasshopper.Kernel Namespace


GH_VarParamEventArgs Constructor (IGH_Param, GH_VarParamSide)

[image]

Grasshopper SDK
GH_VarParamEventArgs Constructor (IGH_Param, GH_VarParamSide)
GH_VarParamEventArgs Class See Also Send Feedback
Initializes a new instance of the GH_VarParamEventArgs class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_VarParamEventArgs(
    IGH_Param n_param,
    GH_VarParamSide n_side
)
Visual Basic
Public Sub New ( _
    n_param As IGH_Param, _
    n_side As GH_VarParamSide _
)

Parameters

n_param
Type: Grasshopper.Kernel..::..IGH_Param
n_side
Type: Grasshopper.Kernel..::..GH_VarParamSide

See Also

GH_VarParamEventArgs Class
GH_VarParamEventArgs Overload
Grasshopper.Kernel Namespace


GH_VarParamEventArgs Constructor (IGH_Param, GH_VarParamSide, Int32)

[image]

Grasshopper SDK
GH_VarParamEventArgs Constructor (IGH_Param, GH_VarParamSide, Int32)
GH_VarParamEventArgs Class See Also Send Feedback
Initializes a new instance of the GH_VarParamEventArgs class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_VarParamEventArgs(
    IGH_Param n_param,
    GH_VarParamSide n_side,
    int n_index
)
Visual Basic
Public Sub New ( _
    n_param As IGH_Param, _
    n_side As GH_VarParamSide, _
    n_index As Integer _
)

Parameters

n_param
Type: Grasshopper.Kernel..::..IGH_Param
n_side
Type: Grasshopper.Kernel..::..GH_VarParamSide
n_index
Type: System..::..Int32

See Also

GH_VarParamEventArgs Class
GH_VarParamEventArgs Overload
Grasshopper.Kernel Namespace


GH_VarParamEventArgs Properties

[image] [image]

Grasshopper SDK
GH_VarParamEventArgs Properties
GH_VarParamEventArgs Class See Also Send Feedback

The GH_VarParamEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Index | Gets the index of the parameter.
Public property | Param | Gets the parameter.
Public property | Side | Gets the side of the parameter.

See Also

GH_VarParamEventArgs Class
Grasshopper.Kernel Namespace


Index Property

[image]

Grasshopper SDK
GH_VarParamEventArgs..::..Index Property
GH_VarParamEventArgs Class See Also Send Feedback
Gets the index of the parameter.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int Index { get; }
Visual Basic
Public ReadOnly Property Index As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_VarParamEventArgs.Index"]

See Also

GH_VarParamEventArgs Class
Grasshopper.Kernel Namespace


Param Property

[image]

Grasshopper SDK
GH_VarParamEventArgs..::..Param Property
GH_VarParamEventArgs Class See Also Send Feedback
Gets the parameter.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_Param Param { get; }
Visual Basic
Public ReadOnly Property Param As IGH_Param
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_VarParamEventArgs.Param"]

See Also

GH_VarParamEventArgs Class
Grasshopper.Kernel Namespace


Side Property

[image]

Grasshopper SDK
GH_VarParamEventArgs..::..Side Property
GH_VarParamEventArgs Class See Also Send Feedback
Gets the side of the parameter.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_VarParamSide Side { get; }
Visual Basic
Public ReadOnly Property Side As GH_VarParamSide
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_VarParamEventArgs.Side"]

See Also

GH_VarParamEventArgs Class
Grasshopper.Kernel Namespace


GH_VarParamSide Enumeration

[image]

Grasshopper SDK
GH_VarParamSide Enumeration
See Also Send Feedback
Enumerates possible sides for variable parameters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_VarParamSide
Visual Basic
Public Enumeration GH_VarParamSide

Members

Member name | Value | Description
Input | 0 |
Output | 1 |

See Also

Grasshopper.Kernel Namespace


GH_ZuiAction Class

[image]

Grasshopper SDK
GH_ZuiAction Class
Members See Also Send Feedback
Basic implementation of IGH_ZuiAction.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract class GH_ZuiAction : IGH_ZuiAction
Visual Basic
Public MustInherit Class GH_ZuiAction _
    Implements IGH_ZuiAction

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_ZuiAction

See Also

GH_ZuiAction Members
Grasshopper.Kernel Namespace


GH_ZuiAction Members

[image] [image]

Grasshopper SDK
GH_ZuiAction Members
GH_ZuiAction Class Constructors Methods Properties See Also Send Feedback

The GH_ZuiAction type exposes the following members.

Constructors

 | Name | Description
Protected method | GH_ZuiAction | Initializes a new instance of the GH_ZuiAction class

Methods

 | Name | Description
Public method | IsTooltipRegion |
Public method | Perform |
Public method | SetupTooltip |

Properties

 | Name | Description
Public property | Name |
Public property | TooltipEnabled |

See Also

GH_ZuiAction Class
Grasshopper.Kernel Namespace


GH_ZuiAction Constructor

[image]

Grasshopper SDK
GH_ZuiAction Constructor
GH_ZuiAction Class See Also Send Feedback
Initializes a new instance of the GH_ZuiAction class

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_ZuiAction(
    string name
)
Visual Basic
Protected Sub New ( _
    name As String _
)

Parameters

name
Type: System..::..String

See Also

GH_ZuiAction Class
Grasshopper.Kernel Namespace


GH_ZuiAction Methods

[image] [image]

Grasshopper SDK
GH_ZuiAction Methods
GH_ZuiAction Class See Also Send Feedback

The GH_ZuiAction type exposes the following members.

Methods

 | Name | Description
Public method | IsTooltipRegion |
Public method | Perform |
Public method | SetupTooltip |

See Also

GH_ZuiAction Class
Grasshopper.Kernel Namespace


IsTooltipRegion Method

[image]

Grasshopper SDK
GH_ZuiAction..::..IsTooltipRegion Method
GH_ZuiAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsTooltipRegion(
    PointF canvasPoint
)
Visual Basic
Public Function IsTooltipRegion ( _
    canvasPoint As PointF _
) As Boolean

Parameters

canvasPoint
Type: System.Drawing..::..PointF

Implements

IGH_TooltipAwareObject..::..IsTooltipRegion(PointF)

See Also

GH_ZuiAction Class
Grasshopper.Kernel Namespace


Perform Method

[image]

Grasshopper SDK
GH_ZuiAction..::..Perform Method
GH_ZuiAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract void Perform()
Visual Basic
Public MustOverride Sub Perform

Implements

IGH_ZuiAction..::..Perform()()()()

See Also

GH_ZuiAction Class
Grasshopper.Kernel Namespace


SetupTooltip Method

[image]

Grasshopper SDK
GH_ZuiAction..::..SetupTooltip Method
GH_ZuiAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract void SetupTooltip(
    PointF canvasPoint,
    GH_TooltipDisplayEventArgs e
)
Visual Basic
Public MustOverride Sub SetupTooltip ( _
    canvasPoint As PointF, _
    e As GH_TooltipDisplayEventArgs _
)

Parameters

canvasPoint
Type: System.Drawing..::..PointF
e
Type: Grasshopper.GUI..::..GH_TooltipDisplayEventArgs

Implements

IGH_TooltipAwareObject..::..SetupTooltip(PointF, GH_TooltipDisplayEventArgs)

See Also

GH_ZuiAction Class
Grasshopper.Kernel Namespace


GH_ZuiAction Properties

[image] [image]

Grasshopper SDK
GH_ZuiAction Properties
GH_ZuiAction Class See Also Send Feedback

The GH_ZuiAction type exposes the following members.

Properties

 | Name | Description
Public property | Name |
Public property | TooltipEnabled |

See Also

GH_ZuiAction Class
Grasshopper.Kernel Namespace


Name Property

[image]

Grasshopper SDK
GH_ZuiAction..::..Name Property
GH_ZuiAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ZuiAction.Name"]

Implements

IGH_ZuiAction..::..Name

See Also

GH_ZuiAction Class
Grasshopper.Kernel Namespace


TooltipEnabled Property

[image]

Grasshopper SDK
GH_ZuiAction..::..TooltipEnabled Property
GH_ZuiAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool TooltipEnabled { get; }
Visual Basic
Public ReadOnly Property TooltipEnabled As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ZuiAction.TooltipEnabled"]

Implements

IGH_TooltipAwareObject..::..TooltipEnabled

See Also

GH_ZuiAction Class
Grasshopper.Kernel Namespace


IGH_ActiveObject Interface

[image]

Grasshopper SDK
IGH_ActiveObject Interface
Members See Also Send Feedback
Base interface for all objects on the canvas that participate in solutions

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_ActiveObject : IGH_DocumentObject
Visual Basic
Public Interface IGH_ActiveObject _
    Inherits IGH_DocumentObject

See Also

IGH_ActiveObject Members
Grasshopper.Kernel Namespace


IGH_ActiveObject Members

[image] [image]

Grasshopper SDK
IGH_ActiveObject Members
IGH_ActiveObject Interface Methods Properties Events See Also Send Feedback

The IGH_ActiveObject type exposes the following members.

Methods

 | Name | Description
Public method | AddedToDocument | This method will be called when an object is added to a document. (Inherited from IGH_DocumentObject.)
Public method | AddRuntimeMessage | Add a new message to this object. Valid message type flags are Warning and Error. If the Message string is empty or zero-length no message is added.
Public method | AppendMenuItems | This function is called when a context menu is about to be displayed. Override it to set custom items. (Inherited from IGH_DocumentObject.)
Public method | ClearData | This function is called whenever the object needs to clear all solution data. This usually amounts to wiping volatile caches and messages. This function will not affect any other objects, but it will set the Phase flag to Blank
Public method | ClearRuntimeMessages | Clear all message lists.
Public method | CollectData | This function is called whenever the object is required to collect all data. Either from Persistent records, from source params or whatever. This step is only performed if the phase flag is Blank or Failed. Upon completion, the phase flag will be set to Collected
Public method | ComputeData | This function is called whenever the object is required to generate new data. This step is only performed by some objects and only when the Phase flag is Collected. Upon completion, the Phase will be Computed. If this object throws exceptions, it is the responsibility of the caller to set the Phase flag to Failed.
Public method | CreateAttributes | Create new default attributes for this object. You should only call this function when the Attributes() field is null. (Inherited from IGH_DocumentObject.)
Public method | DependsOn | Solve the inheritance relationship between this object and a potential parental object.
Public method | DocumentContextChanged | This method will be called when the document that owns this object moves into a different context. (Inherited from IGH_DocumentObject.)
Public method | ExpirePreview | Call this function when you suspect that the preview has expired for this object. This will cause the display cache to be eradicated. (Inherited from IGH_DocumentObject.)
Public method | ExpireSolution | Call this function whenever you do something which expires the current solution. This will make sure all caches are erased, all downstream objects are expired and that the event is raised. The default implementation merely places a call to OnSolutionExpired(), override this function in derived classes to make sure you clear local data caches and expire downstream objects. (Inherited from IGH_DocumentObject.)
Public method | IsolateObject | Destroy all connections to other objects. (Inherited from IGH_DocumentObject.)
Public method | MovedBetweenDocuments | This method will be called when an object is moved from one document to another. (Inherited from IGH_DocumentObject.)
Public method | OnAttributesChanged | Raises the AttributesChanged event on the toplevel object. (Inherited from IGH_DocumentObject.)
Public method | OnDisplayExpired | Raises the DisplayExpired event on the toplevel object. (Inherited from IGH_DocumentObject.)
Public method | OnObjectChanged(String) | Raises the ObjectChanged event on the current (!not the top level!) object. (Inherited from IGH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectChangedEventArgs) | Raises the ObjectChanged event on the current (!not the top level!) object. (Inherited from IGH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType) | Raises the ObjectChanged event on the current (!not the top level!) object. (Inherited from IGH_DocumentObject.)
Public method | OnObjectChanged(String, Object) | Raises the ObjectChanged event on the current (!not the top level!) object. (Inherited from IGH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType, Object) | Raises the ObjectChanged event on the current (!not the top level!) object. (Inherited from IGH_DocumentObject.)
Public method | OnPingDocument | Raise the PingDocument Event on the toplevel object and try to find the document which owns this object. (Inherited from IGH_DocumentObject.)
Public method | OnPreviewExpired | Raises the PreviewExpired event on the toplevel object. (Inherited from IGH_DocumentObject.)
Public method | OnSolutionExpired | Raises the SolutionExpired event on the toplevel object. (Inherited from IGH_DocumentObject.)
Public method | RecordUndoEvent(String) | Record a generic object change undo event. (Inherited from IGH_DocumentObject.)
Public method | RecordUndoEvent(GH_UndoRecord) | Record an entire undo record. (Inherited from IGH_DocumentObject.)
Public method | RecordUndoEvent(String, IGH_UndoAction) | Record a specific object change undo event. (Inherited from IGH_DocumentObject.)
Public method | RegisterRemoteIDs | If this object depends on Rhino Objects, you must register the UUIDs of those objects. Failure to do so will result in faulty event handling.
Public method | RemovedFromDocument | This method will be called when an object is removed from a document. (Inherited from IGH_DocumentObject.)
Public method | RuntimeMessages | Gets the list of cached runtime messages that were recorded during solver-time processes.
Public method | SDKCompliancy | Test whether this object is compliant with a given Rhino version.
Public method | TriggerAutoSave()()()() | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from IGH_DocumentObject.)
Public method | TriggerAutoSave(Guid) | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from IGH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from IGH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger, Guid) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from IGH_DocumentObject.)

Properties

 | Name | Description
Public property | Attributes | Gets or sets the attributes that are associated with this object. Only set custom attributes if you know what you are doing. (Inherited from IGH_DocumentObject.)
Public property | ComponentGuid | Returns a consistent ID for this object type. Every object must supply a unique and unchanging ID that is used to identify objects of the same type. (Inherited from IGH_DocumentObject.)
Public property | Exposure | Gets the exposure of this object in the Graphical User Interface. (Inherited from IGH_DocumentObject.)
Public property | Icon_24x24 | The icon associated with this object. (Inherited from IGH_DocumentObject.)
Public property | Icon_24x24_Locked | The greyscale icon of this object. (Inherited from IGH_DocumentObject.)
Public property | IconDisplayMode | Gets the current display mode of the object. (Inherited from IGH_DocumentObject.)
Public property | IsDataProvider | Gets whether or not this object is capable of emitting data.
Public property | Locked | Gets or sets the locked flag of this object. Locked objects are ignored during solutions.
Public property | MutableNickName | Gets or sets a value that enables Nick name changes through the menu. The default is TRUE.
Public property | Obsolete | Gets whether this object is Obsolete. (Inherited from IGH_DocumentObject.)
Public property | Phase | Gets the solution phase in which this object is currently stuck.
Public property | ProcessorTime | Gets the most recent measured processor time.
Public property | RuntimeMessageLevel | Gets the worst-case level of all messages. I.e. if only warnings have been recorded, the level will be ::warning. If even a single error exists, the level will be ::error.

Events

 | Name | Description
Public event | AttributesChanged | Raised whenever the number or kind of attributes changes. This event is handled by GH_Documents who subsequently wipe their attribute caches. (Inherited from IGH_DocumentObject.)
Public event | DisplayExpired | Raised whenever the display (on the Canvas) of a certain object becomes invalid. (Inherited from IGH_DocumentObject.)
Public event | ObjectChanged | Raised whenever some property of the object changes that would affect remote instances. (Inherited from IGH_DocumentObject.)
Public event | PingDocument | Raised whenever an object needs to know which GH_Document it belongs to. (Inherited from IGH_DocumentObject.)
Public event | PreviewExpired | Raised whenever the display (in the Rhino viewports) of a certain object becomes invalid. (Inherited from IGH_DocumentObject.)
Public event | SolutionExpired | Raised whenever the solution of a certain object becomes invalid. (Inherited from IGH_DocumentObject.)

See Also

IGH_ActiveObject Interface
Grasshopper.Kernel Namespace


IGH_ActiveObject Methods

[image] [image]

Grasshopper SDK
IGH_ActiveObject Methods
IGH_ActiveObject Interface See Also Send Feedback

The IGH_ActiveObject type exposes the following members.

Methods

 | Name | Description
Public method | AddedToDocument | This method will be called when an object is added to a document. (Inherited from IGH_DocumentObject.)
Public method | AddRuntimeMessage | Add a new message to this object. Valid message type flags are Warning and Error. If the Message string is empty or zero-length no message is added.
Public method | AppendMenuItems | This function is called when a context menu is about to be displayed. Override it to set custom items. (Inherited from IGH_DocumentObject.)
Public method | ClearData | This function is called whenever the object needs to clear all solution data. This usually amounts to wiping volatile caches and messages. This function will not affect any other objects, but it will set the Phase flag to Blank
Public method | ClearRuntimeMessages | Clear all message lists.
Public method | CollectData | This function is called whenever the object is required to collect all data. Either from Persistent records, from source params or whatever. This step is only performed if the phase flag is Blank or Failed. Upon completion, the phase flag will be set to Collected
Public method | ComputeData | This function is called whenever the object is required to generate new data. This step is only performed by some objects and only when the Phase flag is Collected. Upon completion, the Phase will be Computed. If this object throws exceptions, it is the responsibility of the caller to set the Phase flag to Failed.
Public method | CreateAttributes | Create new default attributes for this object. You should only call this function when the Attributes() field is null. (Inherited from IGH_DocumentObject.)
Public method | DependsOn | Solve the inheritance relationship between this object and a potential parental object.
Public method | DocumentContextChanged | This method will be called when the document that owns this object moves into a different context. (Inherited from IGH_DocumentObject.)
Public method | ExpirePreview | Call this function when you suspect that the preview has expired for this object. This will cause the display cache to be eradicated. (Inherited from IGH_DocumentObject.)
Public method | ExpireSolution | Call this function whenever you do something which expires the current solution. This will make sure all caches are erased, all downstream objects are expired and that the event is raised. The default implementation merely places a call to OnSolutionExpired(), override this function in derived classes to make sure you clear local data caches and expire downstream objects. (Inherited from IGH_DocumentObject.)
Public method | IsolateObject | Destroy all connections to other objects. (Inherited from IGH_DocumentObject.)
Public method | MovedBetweenDocuments | This method will be called when an object is moved from one document to another. (Inherited from IGH_DocumentObject.)
Public method | OnAttributesChanged | Raises the AttributesChanged event on the toplevel object. (Inherited from IGH_DocumentObject.)
Public method | OnDisplayExpired | Raises the DisplayExpired event on the toplevel object. (Inherited from IGH_DocumentObject.)
Public method | OnObjectChanged(String) | Raises the ObjectChanged event on the current (!not the top level!) object. (Inherited from IGH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectChangedEventArgs) | Raises the ObjectChanged event on the current (!not the top level!) object. (Inherited from IGH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType) | Raises the ObjectChanged event on the current (!not the top level!) object. (Inherited from IGH_DocumentObject.)
Public method | OnObjectChanged(String, Object) | Raises the ObjectChanged event on the current (!not the top level!) object. (Inherited from IGH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType, Object) | Raises the ObjectChanged event on the current (!not the top level!) object. (Inherited from IGH_DocumentObject.)
Public method | OnPingDocument | Raise the PingDocument Event on the toplevel object and try to find the document which owns this object. (Inherited from IGH_DocumentObject.)
Public method | OnPreviewExpired | Raises the PreviewExpired event on the toplevel object. (Inherited from IGH_DocumentObject.)
Public method | OnSolutionExpired | Raises the SolutionExpired event on the toplevel object. (Inherited from IGH_DocumentObject.)
Public method | RecordUndoEvent(String) | Record a generic object change undo event. (Inherited from IGH_DocumentObject.)
Public method | RecordUndoEvent(GH_UndoRecord) | Record an entire undo record. (Inherited from IGH_DocumentObject.)
Public method | RecordUndoEvent(String, IGH_UndoAction) | Record a specific object change undo event. (Inherited from IGH_DocumentObject.)
Public method | RegisterRemoteIDs | If this object depends on Rhino Objects, you must register the UUIDs of those objects. Failure to do so will result in faulty event handling.
Public method | RemovedFromDocument | This method will be called when an object is removed from a document. (Inherited from IGH_DocumentObject.)
Public method | RuntimeMessages | Gets the list of cached runtime messages that were recorded during solver-time processes.
Public method | SDKCompliancy | Test whether this object is compliant with a given Rhino version.
Public method | TriggerAutoSave()()()() | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from IGH_DocumentObject.)
Public method | TriggerAutoSave(Guid) | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from IGH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from IGH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger, Guid) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from IGH_DocumentObject.)

See Also

IGH_ActiveObject Interface
Grasshopper.Kernel Namespace


AddRuntimeMessage Method

[image]

Grasshopper SDK
IGH_ActiveObject..::..AddRuntimeMessage Method
IGH_ActiveObject Interface See Also Send Feedback
Add a new message to this object. Valid message type flags are Warning and Error. If the Message string is empty or zero-length no message is added.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void AddRuntimeMessage(
    GH_RuntimeMessageLevel Type,
    string Message
)
Visual Basic
Sub AddRuntimeMessage ( _
    Type As GH_RuntimeMessageLevel, _
    Message As String _
)

Parameters

Type
Type: Grasshopper.Kernel..::..GH_RuntimeMessageLevel
Type of message. Only Warnings and Errors are recorded.
Message
Type: System..::..String
Content of message.

See Also

IGH_ActiveObject Interface
Grasshopper.Kernel Namespace


ClearData Method

[image]

Grasshopper SDK
IGH_ActiveObject..::..ClearData Method
IGH_ActiveObject Interface See Also Send Feedback
This function is called whenever the object needs to clear all solution data. This usually amounts to wiping volatile caches and messages. This function will not affect any other objects, but it will set the Phase flag to Blank

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void ClearData()
Visual Basic
Sub ClearData

See Also

IGH_ActiveObject Interface
Grasshopper.Kernel Namespace


ClearRuntimeMessages Method

[image]

Grasshopper SDK
IGH_ActiveObject..::..ClearRuntimeMessages Method
IGH_ActiveObject Interface See Also Send Feedback
Clear all message lists.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void ClearRuntimeMessages()
Visual Basic
Sub ClearRuntimeMessages

See Also

IGH_ActiveObject Interface
Grasshopper.Kernel Namespace


CollectData Method

[image]

Grasshopper SDK
IGH_ActiveObject..::..CollectData Method
IGH_ActiveObject Interface See Also Send Feedback
This function is called whenever the object is required to collect all data. Either from Persistent records, from source params or whatever. This step is only performed if the phase flag is Blank or Failed. Upon completion, the phase flag will be set to Collected

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void CollectData()
Visual Basic
Sub CollectData

See Also

IGH_ActiveObject Interface
Grasshopper.Kernel Namespace


ComputeData Method

[image]

Grasshopper SDK
IGH_ActiveObject..::..ComputeData Method
IGH_ActiveObject Interface See Also Send Feedback
This function is called whenever the object is required to generate new data. This step is only performed by some objects and only when the Phase flag is Collected. Upon completion, the Phase will be Computed. If this object throws exceptions, it is the responsibility of the caller to set the Phase flag to Failed.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void ComputeData()
Visual Basic
Sub ComputeData

See Also

IGH_ActiveObject Interface
Grasshopper.Kernel Namespace


DependsOn Method

[image]

Grasshopper SDK
IGH_ActiveObject..::..DependsOn Method
IGH_ActiveObject Interface See Also Send Feedback
Solve the inheritance relationship between this object and a potential parental object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool DependsOn(
    IGH_ActiveObject PotentialSource
)
Visual Basic
Function DependsOn ( _
    PotentialSource As IGH_ActiveObject _
) As Boolean

Parameters

PotentialSource
Type: Grasshopper.Kernel..::..IGH_ActiveObject

See Also

IGH_ActiveObject Interface
Grasshopper.Kernel Namespace


OnObjectChanged Method

[image] [image]

Grasshopper SDK
IGH_ActiveObject..::..OnObjectChanged Method
IGH_ActiveObject Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | OnObjectChanged(String) | Raises the ObjectChanged event on the current (!not the top level!) object. (Inherited from IGH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectChangedEventArgs) | Raises the ObjectChanged event on the current (!not the top level!) object. (Inherited from IGH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType) | Raises the ObjectChanged event on the current (!not the top level!) object. (Inherited from IGH_DocumentObject.)
Public method | OnObjectChanged(String, Object) | Raises the ObjectChanged event on the current (!not the top level!) object. (Inherited from IGH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType, Object) | Raises the ObjectChanged event on the current (!not the top level!) object. (Inherited from IGH_DocumentObject.)

See Also

IGH_ActiveObject Interface
IGH_ActiveObject Members
Grasshopper.Kernel Namespace


RecordUndoEvent Method

[image] [image]

Grasshopper SDK
IGH_ActiveObject..::..RecordUndoEvent Method
IGH_ActiveObject Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | RecordUndoEvent(String) | Record a generic object change undo event. (Inherited from IGH_DocumentObject.)
Public method | RecordUndoEvent(GH_UndoRecord) | Record an entire undo record. (Inherited from IGH_DocumentObject.)
Public method | RecordUndoEvent(String, IGH_UndoAction) | Record a specific object change undo event. (Inherited from IGH_DocumentObject.)

See Also

IGH_ActiveObject Interface
IGH_ActiveObject Members
Grasshopper.Kernel Namespace


RegisterRemoteIDs Method

[image]

Grasshopper SDK
IGH_ActiveObject..::..RegisterRemoteIDs Method
IGH_ActiveObject Interface See Also Send Feedback
If this object depends on Rhino Objects, you must register the UUIDs of those objects. Failure to do so will result in faulty event handling.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void RegisterRemoteIDs(
    GH_GuidTable id_list
)
Visual Basic
Sub RegisterRemoteIDs ( _
    id_list As GH_GuidTable _
)

Parameters

id_list
Type: GH_GuidTable
The object ID database Grasshopper is responsive to.

See Also

IGH_ActiveObject Interface
Grasshopper.Kernel Namespace


RuntimeMessages Method

[image]

Grasshopper SDK
IGH_ActiveObject..::..RuntimeMessages Method
IGH_ActiveObject Interface See Also Send Feedback
Gets the list of cached runtime messages that were recorded during solver-time processes.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
IList<string> RuntimeMessages(
    GH_RuntimeMessageLevel level
)
Visual Basic
Function RuntimeMessages ( _
    level As GH_RuntimeMessageLevel _
) As IList(Of String)

Parameters

level
Type: Grasshopper.Kernel..::..GH_RuntimeMessageLevel
Runtime message type to retrieve.

Return Value

A list of runtime message strings.

See Also

IGH_ActiveObject Interface
Grasshopper.Kernel Namespace


SDKCompliancy Method

[image]

Grasshopper SDK
IGH_ActiveObject..::..SDKCompliancy Method
IGH_ActiveObject Interface See Also Send Feedback
Test whether this object is compliant with a given Rhino version.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool SDKCompliancy(
    int exeVersion,
    int exeServiceRelease
)
Visual Basic
Function SDKCompliancy ( _
    exeVersion As Integer, _
    exeServiceRelease As Integer _
) As Boolean

Parameters

exeVersion
Type: System..::..Int32
Rhino major release (4, 5, ...).
exeServiceRelease
Type: System..::..Int32
Rhino minor (service) release.

Return Value

True if this object is compliant with the given Rhino release.

See Also

IGH_ActiveObject Interface
Grasshopper.Kernel Namespace


TriggerAutoSave Method

[image] [image]

Grasshopper SDK
IGH_ActiveObject..::..TriggerAutoSave Method
IGH_ActiveObject Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | TriggerAutoSave()()()() | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from IGH_DocumentObject.)
Public method | TriggerAutoSave(Guid) | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from IGH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from IGH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger, Guid) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from IGH_DocumentObject.)

See Also

IGH_ActiveObject Interface
IGH_ActiveObject Members
Grasshopper.Kernel Namespace


IGH_ActiveObject Properties

[image] [image]

Grasshopper SDK
IGH_ActiveObject Properties
IGH_ActiveObject Interface See Also Send Feedback

The IGH_ActiveObject type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Gets or sets the attributes that are associated with this object. Only set custom attributes if you know what you are doing. (Inherited from IGH_DocumentObject.)
Public property | ComponentGuid | Returns a consistent ID for this object type. Every object must supply a unique and unchanging ID that is used to identify objects of the same type. (Inherited from IGH_DocumentObject.)
Public property | Exposure | Gets the exposure of this object in the Graphical User Interface. (Inherited from IGH_DocumentObject.)
Public property | Icon_24x24 | The icon associated with this object. (Inherited from IGH_DocumentObject.)
Public property | Icon_24x24_Locked | The greyscale icon of this object. (Inherited from IGH_DocumentObject.)
Public property | IconDisplayMode | Gets the current display mode of the object. (Inherited from IGH_DocumentObject.)
Public property | IsDataProvider | Gets whether or not this object is capable of emitting data.
Public property | Locked | Gets or sets the locked flag of this object. Locked objects are ignored during solutions.
Public property | MutableNickName | Gets or sets a value that enables Nick name changes through the menu. The default is TRUE.
Public property | Obsolete | Gets whether this object is Obsolete. (Inherited from IGH_DocumentObject.)
Public property | Phase | Gets the solution phase in which this object is currently stuck.
Public property | ProcessorTime | Gets the most recent measured processor time.
Public property | RuntimeMessageLevel | Gets the worst-case level of all messages. I.e. if only warnings have been recorded, the level will be ::warning. If even a single error exists, the level will be ::error.

See Also

IGH_ActiveObject Interface
Grasshopper.Kernel Namespace


IsDataProvider Property

[image]

Grasshopper SDK
IGH_ActiveObject..::..IsDataProvider Property
IGH_ActiveObject Interface See Also Send Feedback
Gets whether or not this object is capable of emitting data.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool IsDataProvider { get; }
Visual Basic
ReadOnly Property IsDataProvider As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_ActiveObject.IsDataProvider"]

See Also

IGH_ActiveObject Interface
Grasshopper.Kernel Namespace


Locked Property

[image]

Grasshopper SDK
IGH_ActiveObject..::..Locked Property
IGH_ActiveObject Interface See Also Send Feedback
Gets or sets the locked flag of this object. Locked objects are ignored during solutions.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool Locked { get; set; }
Visual Basic
Property Locked As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_ActiveObject.Locked"]

See Also

IGH_ActiveObject Interface
Grasshopper.Kernel Namespace


MutableNickName Property

[image]

Grasshopper SDK
IGH_ActiveObject..::..MutableNickName Property
IGH_ActiveObject Interface See Also Send Feedback
Gets or sets a value that enables Nick name changes through the menu. The default is TRUE.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool MutableNickName { get; set; }
Visual Basic
Property MutableNickName As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_ActiveObject.MutableNickName"]

See Also

IGH_ActiveObject Interface
Grasshopper.Kernel Namespace


Phase Property

[image]

Grasshopper SDK
IGH_ActiveObject..::..Phase Property
IGH_ActiveObject Interface See Also Send Feedback
Gets the solution phase in which this object is currently stuck.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
GH_SolutionPhase Phase { get; set; }
Visual Basic
Property Phase As GH_SolutionPhase
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_ActiveObject.Phase"]

See Also

IGH_ActiveObject Interface
Grasshopper.Kernel Namespace


ProcessorTime Property

[image]

Grasshopper SDK
IGH_ActiveObject..::..ProcessorTime Property
IGH_ActiveObject Interface See Also Send Feedback
Gets the most recent measured processor time.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
TimeSpan ProcessorTime { get; }
Visual Basic
ReadOnly Property ProcessorTime As TimeSpan
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_ActiveObject.ProcessorTime"]

See Also

IGH_ActiveObject Interface
Grasshopper.Kernel Namespace


RuntimeMessageLevel Property

[image]

Grasshopper SDK
IGH_ActiveObject..::..RuntimeMessageLevel Property
IGH_ActiveObject Interface See Also Send Feedback
Gets the worst-case level of all messages. I.e. if only warnings have been recorded, the level will be ::warning. If even a single error exists, the level will be ::error.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
GH_RuntimeMessageLevel RuntimeMessageLevel { get; }
Visual Basic
ReadOnly Property RuntimeMessageLevel As GH_RuntimeMessageLevel
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_ActiveObject.RuntimeMessageLevel"]

See Also

IGH_ActiveObject Interface
Grasshopper.Kernel Namespace


IGH_ActiveObject Events

[image] [image]

Grasshopper SDK
IGH_ActiveObject Events
IGH_ActiveObject Interface See Also Send Feedback

The IGH_ActiveObject type exposes the following members.

Events

 | Name | Description
Public event | AttributesChanged | Raised whenever the number or kind of attributes changes. This event is handled by GH_Documents who subsequently wipe their attribute caches. (Inherited from IGH_DocumentObject.)
Public event | DisplayExpired | Raised whenever the display (on the Canvas) of a certain object becomes invalid. (Inherited from IGH_DocumentObject.)
Public event | ObjectChanged | Raised whenever some property of the object changes that would affect remote instances. (Inherited from IGH_DocumentObject.)
Public event | PingDocument | Raised whenever an object needs to know which GH_Document it belongs to. (Inherited from IGH_DocumentObject.)
Public event | PreviewExpired | Raised whenever the display (in the Rhino viewports) of a certain object becomes invalid. (Inherited from IGH_DocumentObject.)
Public event | SolutionExpired | Raised whenever the solution of a certain object becomes invalid. (Inherited from IGH_DocumentObject.)

See Also

IGH_ActiveObject Interface
Grasshopper.Kernel Namespace


IGH_Attributes Interface

[image]

Grasshopper SDK
IGH_Attributes Interface
Members See Also Send Feedback
Base interface for all Attributes. Attributes are the visual portion of GH_DocumentObjects. They handle display, mouse events, layout, context menus etc. etc. You should consider inheriting from GH_Attributes or some other abstract class instead of implementing this interface from scratch.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_Attributes : GH_ISerializable,
    IGH_ResponsiveObject, IGH_TooltipAwareObject
Visual Basic
Public Interface IGH_Attributes _
    Inherits GH_ISerializable, IGH_ResponsiveObject, IGH_TooltipAwareObject

See Also

IGH_Attributes Members
Grasshopper.Kernel Namespace


IGH_Attributes Members

[image] [image]

Grasshopper SDK
IGH_Attributes Members
IGH_Attributes Interface Methods Properties See Also Send Feedback

The IGH_Attributes type exposes the following members.

Methods

 | Name | Description
Public method | AppendToAttributeTree | Recursively append these attributes and all child attributes to the attribute list.
Public method | ExpireLayout | Expires the entire layout of the attributes. When overridden, implementer must place a call to the base class ExpireLayout().
Public method | InvalidateCanvas | If the mouse location should cause a canvas invalidation then return true. You only need to override this function if you draw objects that are dependant on cursor positions outside the bounds of the attributes.
Public method | IsMenuRegion | Determines whether a point is available for context menu popups. By default, IsMenuRegion calls IsPickRegion(PointF).
Public method | IsPickRegion(PointF) | Determines whether a point is within the pickable region for this object. By default, any point inside the Bounds is treated as pickable.
Public method | IsPickRegion(RectangleF, GH_PickBox) | Determines whether a rectangle is a valid pick region for this object. By default, the picking rectangle is intersected with the Bounds rectangle.
Public method | IsTooltipRegion | Determine whether the specified pixel should result in a tooltip when the cursor hovers over it. (Inherited from IGH_TooltipAwareObject.)
Public method | NewInstanceGuid()()()() | Generate a new instance GUID for the owner object.
Public method | NewInstanceGuid(Guid) | Generate a new instance GUID for the owner object. Do not use this overload unless you're > 1.95m and called David.
Public method | PerformLayout | Recompute the layout for these attributes. This function is automatically called during Drawing operations, so you typically don't have to.
Public method | Read | This method is called whenever the instance is required to deserialize itself. (Inherited from GH_ISerializable.)
Public method | RenderToCanvas | Render these attributes into a Canvas control.
Public method | RespondToKeyDown | (Inherited from IGH_ResponsiveObject.)
Public method | RespondToKeyUp | (Inherited from IGH_ResponsiveObject.)
Public method | RespondToMouseDoubleClick | This function will be called whenever the left button is double-clicked over the canvas. If you are active, you will be the only object who gets called. (Inherited from IGH_ResponsiveObject.)
Public method | RespondToMouseDown | This function will be called whenever a mouse button is pressed over the canvas. If you are active, you will be the only object who gets called. If you are inactive, you might get called if nobody on top of you decides to become active. (Inherited from IGH_ResponsiveObject.)
Public method | RespondToMouseMove | This function will be called when the mouse moves across the canvas. If you are active, you will be the only object who gets called. If you are inactive, you might get called if nobody on top of you decides to become active. (Inherited from IGH_ResponsiveObject.)
Public method | RespondToMouseUp | This function will be called whenever a mouse button is released over the canvas. If you are active, you will be the only object who gets called. If you are inactive, you will not be called at all for MouseUp events. (Inherited from IGH_ResponsiveObject.)
Public method | SetupTooltip | This function is called when a tooltip it about to be displayed. (Inherited from IGH_TooltipAwareObject.)
Public method | Write | This method is called whenever the instance is required to serialize itself. (Inherited from GH_ISerializable.)

Properties

 | Name | Description
Public property | AllowMessageBalloon | Gets a value indicating whether these attributes allow warning and error boxes to be drawn on top of them.
Public property | Bounds | Gets the rectangle that contains the active content of the attributes. Typically the Contents determine the active area for menus, tooltips etc. Attributes are not supposed to draw objects beyond the Bounds.
Public property | DocObject | Gets the owner object of these attributes.
Public property | GetTopLevel | Gets the top level attributes of these attributes.
Public property | HasInputGrip | Gets a value indicating whether or not these attributes have an input grip.
Public property | HasOutputGrip | Gets a value indicating whether or not these attributes have an output grip.
Public property | InputGrip | Gets the input grip location for these attributes. If HasInputGrip equals False, this point is meaningless.
Public property | InstanceGuid | Gets the instance ID for these attributes.
Public property | IsTopLevel | Gets whether these attributes are top_level (i.e. no Parent attributes)
Public property | OutputGrip | Gets the output grip location for these attributes. If HasOutputGrip equals False, this point is meaningless.
Public property | Parent | Gets or sets the parent attributes. Top level attributes do not have parents.
Public property | PathName | Get a description of the location of these attributes within the local attribute tree.
Public property | Pivot | Gets the pivot for these attributes. The pivot controls the general placement of the attributes. If you want to move the attributes, change the pivot location.
Public property | Selected | Gets or sets the selected state of the top-level attributes.
Public property | TooltipEnabled | Gets the tooltip enabled value. If False, no further tooltip functions will be called. (Inherited from IGH_TooltipAwareObject.)

See Also

IGH_Attributes Interface
Grasshopper.Kernel Namespace


IGH_Attributes Methods

[image] [image]

Grasshopper SDK
IGH_Attributes Methods
IGH_Attributes Interface See Also Send Feedback

The IGH_Attributes type exposes the following members.

Methods

 | Name | Description
Public method | AppendToAttributeTree | Recursively append these attributes and all child attributes to the attribute list.
Public method | ExpireLayout | Expires the entire layout of the attributes. When overridden, implementer must place a call to the base class ExpireLayout().
Public method | InvalidateCanvas | If the mouse location should cause a canvas invalidation then return true. You only need to override this function if you draw objects that are dependant on cursor positions outside the bounds of the attributes.
Public method | IsMenuRegion | Determines whether a point is available for context menu popups. By default, IsMenuRegion calls IsPickRegion(PointF).
Public method | IsPickRegion(PointF) | Determines whether a point is within the pickable region for this object. By default, any point inside the Bounds is treated as pickable.
Public method | IsPickRegion(RectangleF, GH_PickBox) | Determines whether a rectangle is a valid pick region for this object. By default, the picking rectangle is intersected with the Bounds rectangle.
Public method | IsTooltipRegion | Determine whether the specified pixel should result in a tooltip when the cursor hovers over it. (Inherited from IGH_TooltipAwareObject.)
Public method | NewInstanceGuid()()()() | Generate a new instance GUID for the owner object.
Public method | NewInstanceGuid(Guid) | Generate a new instance GUID for the owner object. Do not use this overload unless you're > 1.95m and called David.
Public method | PerformLayout | Recompute the layout for these attributes. This function is automatically called during Drawing operations, so you typically don't have to.
Public method | Read | This method is called whenever the instance is required to deserialize itself. (Inherited from GH_ISerializable.)
Public method | RenderToCanvas | Render these attributes into a Canvas control.
Public method | RespondToKeyDown | (Inherited from IGH_ResponsiveObject.)
Public method | RespondToKeyUp | (Inherited from IGH_ResponsiveObject.)
Public method | RespondToMouseDoubleClick | This function will be called whenever the left button is double-clicked over the canvas. If you are active, you will be the only object who gets called. (Inherited from IGH_ResponsiveObject.)
Public method | RespondToMouseDown | This function will be called whenever a mouse button is pressed over the canvas. If you are active, you will be the only object who gets called. If you are inactive, you might get called if nobody on top of you decides to become active. (Inherited from IGH_ResponsiveObject.)
Public method | RespondToMouseMove | This function will be called when the mouse moves across the canvas. If you are active, you will be the only object who gets called. If you are inactive, you might get called if nobody on top of you decides to become active. (Inherited from IGH_ResponsiveObject.)
Public method | RespondToMouseUp | This function will be called whenever a mouse button is released over the canvas. If you are active, you will be the only object who gets called. If you are inactive, you will not be called at all for MouseUp events. (Inherited from IGH_ResponsiveObject.)
Public method | SetupTooltip | This function is called when a tooltip it about to be displayed. (Inherited from IGH_TooltipAwareObject.)
Public method | Write | This method is called whenever the instance is required to serialize itself. (Inherited from GH_ISerializable.)

See Also

IGH_Attributes Interface
Grasshopper.Kernel Namespace


AppendToAttributeTree Method

[image]

Grasshopper SDK
IGH_Attributes..::..AppendToAttributeTree Method
IGH_Attributes Interface See Also Send Feedback
Recursively append these attributes and all child attributes to the attribute list.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void AppendToAttributeTree(
    List<IGH_Attributes> attributes
)
Visual Basic
Sub AppendToAttributeTree ( _
    attributes As List(Of IGH_Attributes) _
)

Parameters

attributes
Type: System.Collections.Generic..::..List <(Of <(<' IGH_Attributes >)>)>
List to append to.

See Also

IGH_Attributes Interface
Grasshopper.Kernel Namespace


ExpireLayout Method

[image]

Grasshopper SDK
IGH_Attributes..::..ExpireLayout Method
IGH_Attributes Interface See Also Send Feedback
Expires the entire layout of the attributes. When overridden, implementer must place a call to the base class ExpireLayout().

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void ExpireLayout()
Visual Basic
Sub ExpireLayout

See Also

IGH_Attributes Interface
Grasshopper.Kernel Namespace


InvalidateCanvas Method

[image]

Grasshopper SDK
IGH_Attributes..::..InvalidateCanvas Method
IGH_Attributes Interface See Also Send Feedback
If the mouse location should cause a canvas invalidation then return true. You only need to override this function if you draw objects that are dependant on cursor positions outside the bounds of the attributes.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool InvalidateCanvas(
    GH_Canvas canvas,
    GH_CanvasMouseEvent e
)
Visual Basic
Function InvalidateCanvas ( _
    canvas As GH_Canvas, _
    e As GH_CanvasMouseEvent _
) As Boolean

Parameters

canvas
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
Canvas to potentially invalidate.
e
Type: Grasshopper.GUI..::..GH_CanvasMouseEvent
Event arguments for canvas mousemove.

Return Value

True if the canvas ought to be invalidated.

See Also

IGH_Attributes Interface
Grasshopper.Kernel Namespace


IsMenuRegion Method

[image]

Grasshopper SDK
IGH_Attributes..::..IsMenuRegion Method
IGH_Attributes Interface See Also Send Feedback
Determines whether a point is available for context menu popups. By default, IsMenuRegion calls IsPickRegion(PointF).

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool IsMenuRegion(
    PointF point
)
Visual Basic
Function IsMenuRegion ( _
    point As PointF _
) As Boolean

Parameters

point
Type: System.Drawing..::..PointF
Point location to test.

See Also

IGH_Attributes Interface
Grasshopper.Kernel Namespace


IsPickRegion Method

[image] [image]

Grasshopper SDK
IGH_Attributes..::..IsPickRegion Method
IGH_Attributes Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | IsPickRegion(PointF) | Determines whether a point is within the pickable region for this object. By default, any point inside the Bounds is treated as pickable.
Public method | IsPickRegion(RectangleF, GH_PickBox) | Determines whether a rectangle is a valid pick region for this object. By default, the picking rectangle is intersected with the Bounds rectangle.

See Also

IGH_Attributes Interface
IGH_Attributes Members
Grasshopper.Kernel Namespace


IsPickRegion Method (PointF)

[image]

Grasshopper SDK
IGH_Attributes..::..IsPickRegion Method (PointF)
IGH_Attributes Interface See Also Send Feedback
Determines whether a point is within the pickable region for this object. By default, any point inside the Bounds is treated as pickable.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool IsPickRegion(
    PointF point
)
Visual Basic
Function IsPickRegion ( _
    point As PointF _
) As Boolean

Parameters

point
Type: System.Drawing..::..PointF
Point location to test.

See Also

IGH_Attributes Interface
IsPickRegion Overload
Grasshopper.Kernel Namespace


IsPickRegion Method (RectangleF, GH_PickBox)

[image]

Grasshopper SDK
IGH_Attributes..::..IsPickRegion Method (RectangleF, GH_PickBox)
IGH_Attributes Interface See Also Send Feedback
Determines whether a rectangle is a valid pick region for this object. By default, the picking rectangle is intersected with the Bounds rectangle.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool IsPickRegion(
    RectangleF box,
    GH_PickBox method
)
Visual Basic
Function IsPickRegion ( _
    box As RectangleF, _
    method As GH_PickBox _
) As Boolean

Parameters

box
Type: System.Drawing..::..RectangleF
Selection box.
method
Type: Grasshopper.Kernel..::..GH_PickBox
Selection method.

See Also

IGH_Attributes Interface
IsPickRegion Overload
Grasshopper.Kernel Namespace


NewInstanceGuid Method

[image] [image]

Grasshopper SDK
IGH_Attributes..::..NewInstanceGuid Method
IGH_Attributes Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | NewInstanceGuid()()()() | Generate a new instance GUID for the owner object.
Public method | NewInstanceGuid(Guid) | Generate a new instance GUID for the owner object. Do not use this overload unless you're > 1.95m and called David.

See Also

IGH_Attributes Interface
IGH_Attributes Members
Grasshopper.Kernel Namespace


NewInstanceGuid Method

[image]

Grasshopper SDK
IGH_Attributes..::..NewInstanceGuid Method
IGH_Attributes Interface See Also Send Feedback
Generate a new instance GUID for the owner object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void NewInstanceGuid()
Visual Basic
Sub NewInstanceGuid

See Also

IGH_Attributes Interface
NewInstanceGuid Overload
Grasshopper.Kernel Namespace


NewInstanceGuid Method (Guid)

[image]

Grasshopper SDK
IGH_Attributes..::..NewInstanceGuid Method (Guid)
IGH_Attributes Interface See Also Send Feedback
Generate a new instance GUID for the owner object. Do not use this overload unless you're > 1.95m and called David.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void NewInstanceGuid(
    Guid newID
)
Visual Basic
Sub NewInstanceGuid ( _
    newID As Guid _
)

Parameters

newID
Type: System..::..Guid
New ID to assign.

See Also

IGH_Attributes Interface
NewInstanceGuid Overload
Grasshopper.Kernel Namespace


PerformLayout Method

[image]

Grasshopper SDK
IGH_Attributes..::..PerformLayout Method
IGH_Attributes Interface See Also Send Feedback
Recompute the layout for these attributes. This function is automatically called during Drawing operations, so you typically don't have to.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void PerformLayout()
Visual Basic
Sub PerformLayout

See Also

IGH_Attributes Interface
Grasshopper.Kernel Namespace


RenderToCanvas Method

[image]

Grasshopper SDK
IGH_Attributes..::..RenderToCanvas Method
IGH_Attributes Interface See Also Send Feedback
Render these attributes into a Canvas control.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void RenderToCanvas(
    GH_Canvas canvas,
    GH_CanvasChannel channel
)
Visual Basic
Sub RenderToCanvas ( _
    canvas As GH_Canvas, _
    channel As GH_CanvasChannel _
)

Parameters

canvas
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
Canvas to draw on.
channel
Type: Grasshopper.GUI.Canvas..::..GH_CanvasChannel
Current drawing channel.

See Also

IGH_Attributes Interface
Grasshopper.Kernel Namespace


IGH_Attributes Properties

[image] [image]

Grasshopper SDK
IGH_Attributes Properties
IGH_Attributes Interface See Also Send Feedback

The IGH_Attributes type exposes the following members.

Properties

 | Name | Description
Public property | AllowMessageBalloon | Gets a value indicating whether these attributes allow warning and error boxes to be drawn on top of them.
Public property | Bounds | Gets the rectangle that contains the active content of the attributes. Typically the Contents determine the active area for menus, tooltips etc. Attributes are not supposed to draw objects beyond the Bounds.
Public property | DocObject | Gets the owner object of these attributes.
Public property | GetTopLevel | Gets the top level attributes of these attributes.
Public property | HasInputGrip | Gets a value indicating whether or not these attributes have an input grip.
Public property | HasOutputGrip | Gets a value indicating whether or not these attributes have an output grip.
Public property | InputGrip | Gets the input grip location for these attributes. If HasInputGrip equals False, this point is meaningless.
Public property | InstanceGuid | Gets the instance ID for these attributes.
Public property | IsTopLevel | Gets whether these attributes are top_level (i.e. no Parent attributes)
Public property | OutputGrip | Gets the output grip location for these attributes. If HasOutputGrip equals False, this point is meaningless.
Public property | Parent | Gets or sets the parent attributes. Top level attributes do not have parents.
Public property | PathName | Get a description of the location of these attributes within the local attribute tree.
Public property | Pivot | Gets the pivot for these attributes. The pivot controls the general placement of the attributes. If you want to move the attributes, change the pivot location.
Public property | Selected | Gets or sets the selected state of the top-level attributes.
Public property | TooltipEnabled | Gets the tooltip enabled value. If False, no further tooltip functions will be called. (Inherited from IGH_TooltipAwareObject.)

See Also

IGH_Attributes Interface
Grasshopper.Kernel Namespace


AllowMessageBalloon Property

[image]

Grasshopper SDK
IGH_Attributes..::..AllowMessageBalloon Property
IGH_Attributes Interface See Also Send Feedback
Gets a value indicating whether these attributes allow warning and error boxes to be drawn on top of them.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool AllowMessageBalloon { get; }
Visual Basic
ReadOnly Property AllowMessageBalloon As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Attributes.AllowMessageBalloon"]

See Also

IGH_Attributes Interface
Grasshopper.Kernel Namespace


Bounds Property

[image]

Grasshopper SDK
IGH_Attributes..::..Bounds Property
IGH_Attributes Interface See Also Send Feedback
Gets the rectangle that contains the active content of the attributes. Typically the Contents determine the active area for menus, tooltips etc. Attributes are not supposed to draw objects beyond the Bounds.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
RectangleF Bounds { get; set; }
Visual Basic
Property Bounds As RectangleF
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Attributes.Bounds"]

See Also

IGH_Attributes Interface
Grasshopper.Kernel Namespace


DocObject Property

[image]

Grasshopper SDK
IGH_Attributes..::..DocObject Property
IGH_Attributes Interface See Also Send Feedback
Gets the owner object of these attributes.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
IGH_DocumentObject DocObject { get; }
Visual Basic
ReadOnly Property DocObject As IGH_DocumentObject
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Attributes.DocObject"]

See Also

IGH_Attributes Interface
Grasshopper.Kernel Namespace


GetTopLevel Property

[image]

Grasshopper SDK
IGH_Attributes..::..GetTopLevel Property
IGH_Attributes Interface See Also Send Feedback
Gets the top level attributes of these attributes.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
IGH_Attributes GetTopLevel { get; }
Visual Basic
ReadOnly Property GetTopLevel As IGH_Attributes
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Attributes.GetTopLevel"]

See Also

IGH_Attributes Interface
Grasshopper.Kernel Namespace


HasInputGrip Property

[image]

Grasshopper SDK
IGH_Attributes..::..HasInputGrip Property
IGH_Attributes Interface See Also Send Feedback
Gets a value indicating whether or not these attributes have an input grip.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool HasInputGrip { get; }
Visual Basic
ReadOnly Property HasInputGrip As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Attributes.HasInputGrip"]

See Also

IGH_Attributes Interface
Grasshopper.Kernel Namespace


HasOutputGrip Property

[image]

Grasshopper SDK
IGH_Attributes..::..HasOutputGrip Property
IGH_Attributes Interface See Also Send Feedback
Gets a value indicating whether or not these attributes have an output grip.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool HasOutputGrip { get; }
Visual Basic
ReadOnly Property HasOutputGrip As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Attributes.HasOutputGrip"]

See Also

IGH_Attributes Interface
Grasshopper.Kernel Namespace


InputGrip Property

[image]

Grasshopper SDK
IGH_Attributes..::..InputGrip Property
IGH_Attributes Interface See Also Send Feedback
Gets the input grip location for these attributes. If HasInputGrip equals False, this point is meaningless.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
PointF InputGrip { get; }
Visual Basic
ReadOnly Property InputGrip As PointF
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Attributes.InputGrip"]

See Also

IGH_Attributes Interface
Grasshopper.Kernel Namespace


InstanceGuid Property

[image]

Grasshopper SDK
IGH_Attributes..::..InstanceGuid Property
IGH_Attributes Interface See Also Send Feedback
Gets the instance ID for these attributes.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
Guid InstanceGuid { get; }
Visual Basic
ReadOnly Property InstanceGuid As Guid
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Attributes.InstanceGuid"]

See Also

IGH_Attributes Interface
Grasshopper.Kernel Namespace


IsTopLevel Property

[image]

Grasshopper SDK
IGH_Attributes..::..IsTopLevel Property
IGH_Attributes Interface See Also Send Feedback
Gets whether these attributes are top_level (i.e. no Parent attributes)

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool IsTopLevel { get; }
Visual Basic
ReadOnly Property IsTopLevel As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Attributes.IsTopLevel"]

See Also

IGH_Attributes Interface
Grasshopper.Kernel Namespace


OutputGrip Property

[image]

Grasshopper SDK
IGH_Attributes..::..OutputGrip Property
IGH_Attributes Interface See Also Send Feedback
Gets the output grip location for these attributes. If HasOutputGrip equals False, this point is meaningless.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
PointF OutputGrip { get; }
Visual Basic
ReadOnly Property OutputGrip As PointF
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Attributes.OutputGrip"]

See Also

IGH_Attributes Interface
Grasshopper.Kernel Namespace


Parent Property

[image]

Grasshopper SDK
IGH_Attributes..::..Parent Property
IGH_Attributes Interface See Also Send Feedback
Gets or sets the parent attributes. Top level attributes do not have parents.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
IGH_Attributes Parent { get; set; }
Visual Basic
Property Parent As IGH_Attributes
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Attributes.Parent"]

See Also

IGH_Attributes Interface
Grasshopper.Kernel Namespace


PathName Property

[image]

Grasshopper SDK
IGH_Attributes..::..PathName Property
IGH_Attributes Interface See Also Send Feedback
Get a description of the location of these attributes within the local attribute tree.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string PathName { get; }
Visual Basic
ReadOnly Property PathName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Attributes.PathName"]

See Also

IGH_Attributes Interface
Grasshopper.Kernel Namespace


Pivot Property

[image]

Grasshopper SDK
IGH_Attributes..::..Pivot Property
IGH_Attributes Interface See Also Send Feedback
Gets the pivot for these attributes. The pivot controls the general placement of the attributes. If you want to move the attributes, change the pivot location.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
PointF Pivot { get; set; }
Visual Basic
Property Pivot As PointF
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Attributes.Pivot"]

See Also

IGH_Attributes Interface
Grasshopper.Kernel Namespace


Selected Property

[image]

Grasshopper SDK
IGH_Attributes..::..Selected Property
IGH_Attributes Interface See Also Send Feedback
Gets or sets the selected state of the top-level attributes.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool Selected { get; set; }
Visual Basic
Property Selected As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Attributes.Selected"]

See Also

IGH_Attributes Interface
Grasshopper.Kernel Namespace


IGH_Author Interface

[image]

Grasshopper SDK
IGH_Author Interface
Members See Also Send Feedback
Provides of collection of basic author details.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_Author
Visual Basic
Public Interface IGH_Author

See Also

IGH_Author Members
Grasshopper.Kernel Namespace


IGH_Author Members

[image] [image]

Grasshopper SDK
IGH_Author Members
IGH_Author Interface Properties See Also Send Feedback

The IGH_Author type exposes the following members.

Properties

 | Name | Description
Public property | Address | Gets the address of the author.
Public property | Company | Gets the Company name of the author.
Public property | Copyright | Gets the copyright message for these details.
Public property | Email | Gets the email of the author.
Public property | IsEmpty | Gets whether any data has been assigned to this object.
Public property | Name | Gets the name of the author.
Public property | Phone | Gets the phone number of the author.
Public property | Website | Gets the website of the author.

See Also

IGH_Author Interface
Grasshopper.Kernel Namespace


IGH_Author Properties

[image] [image]

Grasshopper SDK
IGH_Author Properties
IGH_Author Interface See Also Send Feedback

The IGH_Author type exposes the following members.

Properties

 | Name | Description
Public property | Address | Gets the address of the author.
Public property | Company | Gets the Company name of the author.
Public property | Copyright | Gets the copyright message for these details.
Public property | Email | Gets the email of the author.
Public property | IsEmpty | Gets whether any data has been assigned to this object.
Public property | Name | Gets the name of the author.
Public property | Phone | Gets the phone number of the author.
Public property | Website | Gets the website of the author.

See Also

IGH_Author Interface
Grasshopper.Kernel Namespace


Address Property

[image]

Grasshopper SDK
IGH_Author..::..Address Property
IGH_Author Interface See Also Send Feedback
Gets the address of the author.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string Address { get; }
Visual Basic
ReadOnly Property Address As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Author.Address"]

See Also

IGH_Author Interface
Grasshopper.Kernel Namespace


Company Property

[image]

Grasshopper SDK
IGH_Author..::..Company Property
IGH_Author Interface See Also Send Feedback
Gets the Company name of the author.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string Company { get; }
Visual Basic
ReadOnly Property Company As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Author.Company"]

See Also

IGH_Author Interface
Grasshopper.Kernel Namespace


Copyright Property

[image]

Grasshopper SDK
IGH_Author..::..Copyright Property
IGH_Author Interface See Also Send Feedback
Gets the copyright message for these details.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string Copyright { get; }
Visual Basic
ReadOnly Property Copyright As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Author.Copyright"]

See Also

IGH_Author Interface
Grasshopper.Kernel Namespace


Email Property

[image]

Grasshopper SDK
IGH_Author..::..Email Property
IGH_Author Interface See Also Send Feedback
Gets the email of the author.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string Email { get; }
Visual Basic
ReadOnly Property Email As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Author.Email"]

See Also

IGH_Author Interface
Grasshopper.Kernel Namespace


IsEmpty Property

[image]

Grasshopper SDK
IGH_Author..::..IsEmpty Property
IGH_Author Interface See Also Send Feedback
Gets whether any data has been assigned to this object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool IsEmpty { get; }
Visual Basic
ReadOnly Property IsEmpty As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Author.IsEmpty"]

See Also

IGH_Author Interface
Grasshopper.Kernel Namespace


Name Property

[image]

Grasshopper SDK
IGH_Author..::..Name Property
IGH_Author Interface See Also Send Feedback
Gets the name of the author.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string Name { get; }
Visual Basic
ReadOnly Property Name As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Author.Name"]

See Also

IGH_Author Interface
Grasshopper.Kernel Namespace


Phone Property

[image]

Grasshopper SDK
IGH_Author..::..Phone Property
IGH_Author Interface See Also Send Feedback
Gets the phone number of the author.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string Phone { get; }
Visual Basic
ReadOnly Property Phone As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Author.Phone"]

See Also

IGH_Author Interface
Grasshopper.Kernel Namespace


Website Property

[image]

Grasshopper SDK
IGH_Author..::..Website Property
IGH_Author Interface See Also Send Feedback
Gets the website of the author.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string Website { get; }
Visual Basic
ReadOnly Property Website As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Author.Website"]

See Also

IGH_Author Interface
Grasshopper.Kernel Namespace


IGH_BakeAwareData Interface

[image]

Grasshopper SDK
IGH_BakeAwareData Interface
Members See Also Send Feedback
Implement this interface in your IGH_Goo data type if you want to be included in baking operations.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_BakeAwareData
Visual Basic
Public Interface IGH_BakeAwareData

See Also

IGH_BakeAwareData Members
Grasshopper.Kernel Namespace


IGH_BakeAwareData Members

[image] [image]

Grasshopper SDK
IGH_BakeAwareData Members
IGH_BakeAwareData Interface Methods See Also Send Feedback

The IGH_BakeAwareData type exposes the following members.

Methods

 | Name | Description
Public method | BakeGeometry | Bake an object in the given Rhino document.

See Also

IGH_BakeAwareData Interface
Grasshopper.Kernel Namespace


IGH_BakeAwareData Methods

[image] [image]

Grasshopper SDK
IGH_BakeAwareData Methods
IGH_BakeAwareData Interface See Also Send Feedback

The IGH_BakeAwareData type exposes the following members.

Methods

 | Name | Description
Public method | BakeGeometry | Bake an object in the given Rhino document.

See Also

IGH_BakeAwareData Interface
Grasshopper.Kernel Namespace


BakeGeometry Method

[image]

Grasshopper SDK
IGH_BakeAwareData..::..BakeGeometry Method
IGH_BakeAwareData Interface See Also Send Feedback
Bake an object in the given Rhino document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool BakeGeometry(
    RhinoDoc doc,
    ObjectAttributes att,
    out Guid obj_guid
)
Visual Basic
Function BakeGeometry ( _
    doc As RhinoDoc, _
    att As ObjectAttributes, _
    <OutAttribute> ByRef obj_guid As Guid _
) As Boolean

Parameters

doc
Type: RhinoDoc
Document to bake into.
att
Type: ObjectAttributes
Attributes to bake with (should not be null).
obj_guid
Type: System..::..Guid %
The id of the baked object.

Return Value

True on success. If False, obj_guid and obj_inst are not guaranteed to be valid pointers.

See Also

IGH_BakeAwareData Interface
Grasshopper.Kernel Namespace


IGH_BakeAwareObject Interface

[image]

Grasshopper SDK
IGH_BakeAwareObject Interface
Members See Also Send Feedback
Implement this interface on your IGH_ActiveObject if you want to participate in the Bake GUI.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_BakeAwareObject
Visual Basic
Public Interface IGH_BakeAwareObject

See Also

IGH_BakeAwareObject Members
Grasshopper.Kernel Namespace


IGH_BakeAwareObject Members

[image] [image]

Grasshopper SDK
IGH_BakeAwareObject Members
IGH_BakeAwareObject Interface Methods Properties See Also Send Feedback

The IGH_BakeAwareObject type exposes the following members.

Methods

 | Name | Description
Public method | BakeGeometry(RhinoDoc, List<(Of <<'(Guid>)>>)) | Bake all the goemetry in this object in the given Rhino document.
Public method | BakeGeometry(RhinoDoc, ObjectAttributes, List<(Of <<'(Guid>)>>)) | Bake all the goemetry in this object in the given Rhino document.

Properties

 | Name | Description
Public property | IsBakeCapable | Gets a value indicating whether or not the object can potentially Bake data in its current state.

See Also

IGH_BakeAwareObject Interface
Grasshopper.Kernel Namespace


IGH_BakeAwareObject Methods

[image] [image]

Grasshopper SDK
IGH_BakeAwareObject Methods
IGH_BakeAwareObject Interface See Also Send Feedback

Methods

 | Name | Description
Public method | BakeGeometry(RhinoDoc, List<(Of <<'(Guid>)>>)) | Bake all the goemetry in this object in the given Rhino document.
Public method | BakeGeometry(RhinoDoc, ObjectAttributes, List<(Of <<'(Guid>)>>)) | Bake all the goemetry in this object in the given Rhino document.

See Also

IGH_BakeAwareObject Interface
Grasshopper.Kernel Namespace


BakeGeometry Method

[image] [image]

Grasshopper SDK
IGH_BakeAwareObject..::..BakeGeometry Method
IGH_BakeAwareObject Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | BakeGeometry(RhinoDoc, List<(Of <<'(Guid>)>>)) | Bake all the goemetry in this object in the given Rhino document.
Public method | BakeGeometry(RhinoDoc, ObjectAttributes, List<(Of <<'(Guid>)>>)) | Bake all the goemetry in this object in the given Rhino document.

See Also

IGH_BakeAwareObject Interface
IGH_BakeAwareObject Members
Grasshopper.Kernel Namespace


BakeGeometry Method (, List(Guid))

[image]

Grasshopper SDK
IGH_BakeAwareObject..::..BakeGeometry Method (, List<(Of <(<'Guid>)>)>)
IGH_BakeAwareObject Interface See Also Send Feedback
Bake all the goemetry in this object in the given Rhino document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void BakeGeometry(
    RhinoDoc doc,
    List<Guid> obj_ids
)
Visual Basic
Sub BakeGeometry ( _
    doc As RhinoDoc, _
    obj_ids As List(Of Guid) _
)

Parameters

doc
Type: RhinoDoc
Document to bake into.
obj_ids
Type: System.Collections.Generic..::..List <(Of <(<' Guid >)>)>
All bake objects IDs will be appended to this list.

See Also

IGH_BakeAwareObject Interface
BakeGeometry Overload
Grasshopper.Kernel Namespace


BakeGeometry Method (, , List(Guid))

[image]

Grasshopper SDK
IGH_BakeAwareObject..::..BakeGeometry Method (, , List<(Of <(<'Guid>)>)>)
IGH_BakeAwareObject Interface See Also Send Feedback
Bake all the goemetry in this object in the given Rhino document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void BakeGeometry(
    RhinoDoc doc,
    ObjectAttributes att,
    List<Guid> obj_ids
)
Visual Basic
Sub BakeGeometry ( _
    doc As RhinoDoc, _
    att As ObjectAttributes, _
    obj_ids As List(Of Guid) _
)

Parameters

doc
Type: RhinoDoc
Document to bake into.
att
Type: ObjectAttributes
Attributes to use for baked geometry.
obj_ids
Type: System.Collections.Generic..::..List <(Of <(<' Guid >)>)>
All bake objects IDs will be appended to this list.

See Also

IGH_BakeAwareObject Interface
BakeGeometry Overload
Grasshopper.Kernel Namespace


IGH_BakeAwareObject Properties

[image] [image]

Grasshopper SDK
IGH_BakeAwareObject Properties
IGH_BakeAwareObject Interface See Also Send Feedback

The IGH_BakeAwareObject type exposes the following members.

Properties

 | Name | Description
Public property | IsBakeCapable | Gets a value indicating whether or not the object can potentially Bake data in its current state.

See Also

IGH_BakeAwareObject Interface
Grasshopper.Kernel Namespace


IsBakeCapable Property

[image]

Grasshopper SDK
IGH_BakeAwareObject..::..IsBakeCapable Property
IGH_BakeAwareObject Interface See Also Send Feedback
Gets a value indicating whether or not the object can potentially Bake data in its current state.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool IsBakeCapable { get; }
Visual Basic
ReadOnly Property IsBakeCapable As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_BakeAwareObject.IsBakeCapable"]

See Also

IGH_BakeAwareObject Interface
Grasshopper.Kernel Namespace


IGH_Component Interface

[image]

Grasshopper SDK
IGH_Component Interface
Members See Also Send Feedback
Base interface for all GH_Component types. Do not implement this interface from scratch, inherit from GH_Component instead.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_Component : IGH_ActiveObject,
    IGH_PreviewObject, IGH_BakeAwareObject
Visual Basic
Public Interface IGH_Component _
    Inherits IGH_ActiveObject, IGH_PreviewObject, IGH_BakeAwareObject

See Also

IGH_Component Members
Grasshopper.Kernel Namespace


IGH_Component Members

[image] [image]

Grasshopper SDK
IGH_Component Members
IGH_Component Interface Methods Properties See Also Send Feedback

The IGH_Component type exposes the following members.

Methods

 | Name | Description
Public method | AddRuntimeMessage | Add a new message to this object. Valid message type flags are Warning and Error. If the Message string is empty or zero-length no message is added. (Inherited from IGH_ActiveObject.)
Public method | BakeGeometry(RhinoDoc, List<(Of <<'(Guid>)>>)) | Bake all the goemetry in this object in the given Rhino document. (Inherited from IGH_BakeAwareObject.)
Public method | BakeGeometry(RhinoDoc, ObjectAttributes, List<(Of <<'(Guid>)>>)) | Bake all the goemetry in this object in the given Rhino document. (Inherited from IGH_BakeAwareObject.)
Public method | ClearData | This function is called whenever the object needs to clear all solution data. This usually amounts to wiping volatile caches and messages. This function will not affect any other objects, but it will set the Phase flag to Blank (Inherited from IGH_ActiveObject.)
Public method | ClearRuntimeMessages | Clear all message lists. (Inherited from IGH_ActiveObject.)
Public method | CollectData | This function is called whenever the object is required to collect all data. Either from Persistent records, from source params or whatever. This step is only performed if the phase flag is Blank or Failed. Upon completion, the phase flag will be set to Collected (Inherited from IGH_ActiveObject.)
Public method | ComputeData | This function is called whenever the object is required to generate new data. This step is only performed by some objects and only when the Phase flag is Collected. Upon completion, the Phase will be Computed. If this object throws exceptions, it is the responsibility of the caller to set the Phase flag to Failed. (Inherited from IGH_ActiveObject.)
Public method | DependsOn | Solve the inheritance relationship between this object and a potential parental object. (Inherited from IGH_ActiveObject.)
Public method | DrawViewportMeshes | Implement this function to draw all shaded meshes. If the viewport does not support shading, this function will not be called. (Inherited from IGH_PreviewObject.)
Public method | DrawViewportWires | Implement this function to draw all wire and point geometry previews. (Inherited from IGH_PreviewObject.)
Public method | RegisterRemoteIDs | If this object depends on Rhino Objects, you must register the UUIDs of those objects. Failure to do so will result in faulty event handling. (Inherited from IGH_ActiveObject.)
Public method | RuntimeMessages | Gets the list of cached runtime messages that were recorded during solver-time processes. (Inherited from IGH_ActiveObject.)
Public method | SDKCompliancy | Test whether this object is compliant with a given Rhino version. (Inherited from IGH_ActiveObject.)

Properties

 | Name | Description
Public property | ClippingBox | Gets the clipping box for this object. The clipping box is typically the union of the boundingboxes of all the geometry that is drawn by this object. (Inherited from IGH_PreviewObject.)
Public property | DataComparison | Obsolete. A data combination flag
Public property | Hidden | Gets or sets a value indicating whether or not this object is currently drawing preview flags. (Inherited from IGH_PreviewObject.)
Public property | InConstructor | Gets the constructor flag for this instance. If InConstructor = True, it means the component is still registering parameters and the layout is not yet complete.
Public property | IsBakeCapable | Gets a value indicating whether or not the object can potentially Bake data in its current state. (Inherited from IGH_BakeAwareObject.)
Public property | IsDataProvider | Gets whether or not this object is capable of emitting data. (Inherited from IGH_ActiveObject.)
Public property | IsPreviewCapable | Gets a value indicating whether or not this object (in its current state) can draw geometric previews at all. (Inherited from IGH_PreviewObject.)
Public property | IsValidMasterParameterIndex | Gets whether the MasterParameterIndex property identifies a valid parameter.
Public property | Locked | Gets or sets the locked flag of this object. Locked objects are ignored during solutions. (Inherited from IGH_ActiveObject.)
Public property | MasterParameterIndex | Gets or sets the master parameter index override. Negative indices or indices larger than or equal to the input parameter count will be ignored and regular master parameter detection will kick in.
Public property | Message | Gets or sets a custom message to be displayed underneath the component.
Public property | MutableNickName | Gets or sets a value that enables Nick name changes through the menu. The default is TRUE. (Inherited from IGH_ActiveObject.)
Public property | Params | Gets the Params object that managed input and output parameters.
Public property | Phase | Gets the solution phase in which this object is currently stuck. (Inherited from IGH_ActiveObject.)
Public property | ProcessorTime | Gets the most recent measured processor time. (Inherited from IGH_ActiveObject.)
Public property | RuntimeMessageLevel | Gets the worst-case level of all messages. I.e. if only warnings have been recorded, the level will be ::warning. If even a single error exists, the level will be ::error. (Inherited from IGH_ActiveObject.)

See Also

IGH_Component Interface
Grasshopper.Kernel Namespace


IGH_Component Methods

[image] [image]

Grasshopper SDK
IGH_Component Methods
IGH_Component Interface See Also Send Feedback

The IGH_Component type exposes the following members.

Methods

 | Name | Description
Public method | AddRuntimeMessage | Add a new message to this object. Valid message type flags are Warning and Error. If the Message string is empty or zero-length no message is added. (Inherited from IGH_ActiveObject.)
Public method | BakeGeometry(RhinoDoc, List<(Of <<'(Guid>)>>)) | Bake all the goemetry in this object in the given Rhino document. (Inherited from IGH_BakeAwareObject.)
Public method | BakeGeometry(RhinoDoc, ObjectAttributes, List<(Of <<'(Guid>)>>)) | Bake all the goemetry in this object in the given Rhino document. (Inherited from IGH_BakeAwareObject.)
Public method | ClearData | This function is called whenever the object needs to clear all solution data. This usually amounts to wiping volatile caches and messages. This function will not affect any other objects, but it will set the Phase flag to Blank (Inherited from IGH_ActiveObject.)
Public method | ClearRuntimeMessages | Clear all message lists. (Inherited from IGH_ActiveObject.)
Public method | CollectData | This function is called whenever the object is required to collect all data. Either from Persistent records, from source params or whatever. This step is only performed if the phase flag is Blank or Failed. Upon completion, the phase flag will be set to Collected (Inherited from IGH_ActiveObject.)
Public method | ComputeData | This function is called whenever the object is required to generate new data. This step is only performed by some objects and only when the Phase flag is Collected. Upon completion, the Phase will be Computed. If this object throws exceptions, it is the responsibility of the caller to set the Phase flag to Failed. (Inherited from IGH_ActiveObject.)
Public method | DependsOn | Solve the inheritance relationship between this object and a potential parental object. (Inherited from IGH_ActiveObject.)
Public method | DrawViewportMeshes | Implement this function to draw all shaded meshes. If the viewport does not support shading, this function will not be called. (Inherited from IGH_PreviewObject.)
Public method | DrawViewportWires | Implement this function to draw all wire and point geometry previews. (Inherited from IGH_PreviewObject.)
Public method | RegisterRemoteIDs | If this object depends on Rhino Objects, you must register the UUIDs of those objects. Failure to do so will result in faulty event handling. (Inherited from IGH_ActiveObject.)
Public method | RuntimeMessages | Gets the list of cached runtime messages that were recorded during solver-time processes. (Inherited from IGH_ActiveObject.)
Public method | SDKCompliancy | Test whether this object is compliant with a given Rhino version. (Inherited from IGH_ActiveObject.)

See Also

IGH_Component Interface
Grasshopper.Kernel Namespace


BakeGeometry Method

[image] [image]

Grasshopper SDK
IGH_Component..::..BakeGeometry Method
IGH_Component Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | BakeGeometry(RhinoDoc, List<(Of <<'(Guid>)>>)) | Bake all the goemetry in this object in the given Rhino document. (Inherited from IGH_BakeAwareObject.)
Public method | BakeGeometry(RhinoDoc, ObjectAttributes, List<(Of <<'(Guid>)>>)) | Bake all the goemetry in this object in the given Rhino document. (Inherited from IGH_BakeAwareObject.)

See Also

IGH_Component Interface
IGH_Component Members
Grasshopper.Kernel Namespace


IGH_Component Properties

[image] [image]

Grasshopper SDK
IGH_Component Properties
IGH_Component Interface See Also Send Feedback

The IGH_Component type exposes the following members.

Properties

 | Name | Description
Public property | ClippingBox | Gets the clipping box for this object. The clipping box is typically the union of the boundingboxes of all the geometry that is drawn by this object. (Inherited from IGH_PreviewObject.)
Public property | DataComparison | Obsolete. A data combination flag
Public property | Hidden | Gets or sets a value indicating whether or not this object is currently drawing preview flags. (Inherited from IGH_PreviewObject.)
Public property | InConstructor | Gets the constructor flag for this instance. If InConstructor = True, it means the component is still registering parameters and the layout is not yet complete.
Public property | IsBakeCapable | Gets a value indicating whether or not the object can potentially Bake data in its current state. (Inherited from IGH_BakeAwareObject.)
Public property | IsDataProvider | Gets whether or not this object is capable of emitting data. (Inherited from IGH_ActiveObject.)
Public property | IsPreviewCapable | Gets a value indicating whether or not this object (in its current state) can draw geometric previews at all. (Inherited from IGH_PreviewObject.)
Public property | IsValidMasterParameterIndex | Gets whether the MasterParameterIndex property identifies a valid parameter.
Public property | Locked | Gets or sets the locked flag of this object. Locked objects are ignored during solutions. (Inherited from IGH_ActiveObject.)
Public property | MasterParameterIndex | Gets or sets the master parameter index override. Negative indices or indices larger than or equal to the input parameter count will be ignored and regular master parameter detection will kick in.
Public property | Message | Gets or sets a custom message to be displayed underneath the component.
Public property | MutableNickName | Gets or sets a value that enables Nick name changes through the menu. The default is TRUE. (Inherited from IGH_ActiveObject.)
Public property | Params | Gets the Params object that managed input and output parameters.
Public property | Phase | Gets the solution phase in which this object is currently stuck. (Inherited from IGH_ActiveObject.)
Public property | ProcessorTime | Gets the most recent measured processor time. (Inherited from IGH_ActiveObject.)
Public property | RuntimeMessageLevel | Gets the worst-case level of all messages. I.e. if only warnings have been recorded, the level will be ::warning. If even a single error exists, the level will be ::error. (Inherited from IGH_ActiveObject.)

See Also

IGH_Component Interface
Grasshopper.Kernel Namespace


DataComparison Property

[image]

Grasshopper SDK
IGH_Component..::..DataComparison Property
IGH_Component Interface See Also Send Feedback
A data combination flag

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
[ObsoleteAttribute("This property is obsolete and will be phased out in future versions")]
GH_DataComparison DataComparison { get; set; }
Visual Basic
<ObsoleteAttribute("This property is obsolete and will be phased out in future versions")> _
Property DataComparison As GH_DataComparison
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Component.DataComparison"]

See Also

IGH_Component Interface
Grasshopper.Kernel Namespace


InConstructor Property

[image]

Grasshopper SDK
IGH_Component..::..InConstructor Property
IGH_Component Interface See Also Send Feedback
Gets the constructor flag for this instance. If InConstructor = True, it means the component is still registering parameters and the layout is not yet complete.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool InConstructor { get; }
Visual Basic
ReadOnly Property InConstructor As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Component.InConstructor"]

See Also

IGH_Component Interface
Grasshopper.Kernel Namespace


IsValidMasterParameterIndex Property

[image]

Grasshopper SDK
IGH_Component..::..IsValidMasterParameterIndex Property
IGH_Component Interface See Also Send Feedback
Gets whether the MasterParameterIndex property identifies a valid parameter.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool IsValidMasterParameterIndex { get; }
Visual Basic
ReadOnly Property IsValidMasterParameterIndex As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Component.IsValidMasterParameterIndex"]

See Also

IGH_Component Interface
Grasshopper.Kernel Namespace


MasterParameterIndex Property

[image]

Grasshopper SDK
IGH_Component..::..MasterParameterIndex Property
IGH_Component Interface See Also Send Feedback
Gets or sets the master parameter index override. Negative indices or indices larger than or equal to the input parameter count will be ignored and regular master parameter detection will kick in.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
int MasterParameterIndex { get; set; }
Visual Basic
Property MasterParameterIndex As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Component.MasterParameterIndex"]

See Also

IGH_Component Interface
Grasshopper.Kernel Namespace


Message Property

[image]

Grasshopper SDK
IGH_Component..::..Message Property
IGH_Component Interface See Also Send Feedback
Gets or sets a custom message to be displayed underneath the component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string Message { get; set; }
Visual Basic
Property Message As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Component.Message"]

See Also

IGH_Component Interface
Grasshopper.Kernel Namespace


Params Property

[image]

Grasshopper SDK
IGH_Component..::..Params Property
IGH_Component Interface See Also Send Feedback
Gets the Params object that managed input and output parameters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
GH_ComponentParamServer Params { get; }
Visual Basic
ReadOnly Property Params As GH_ComponentParamServer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Component.Params"]

See Also

IGH_Component Interface
Grasshopper.Kernel Namespace


IGH_DataAccess Interface

[image]

Grasshopper SDK
IGH_DataAccess Interface
Members See Also Send Feedback
Provides access to component parameters, in order to retrieve and assign data during solutions.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_DataAccess
Visual Basic
Public Interface IGH_DataAccess

See Also

IGH_DataAccess Members
Grasshopper.Kernel Namespace


IGH_DataAccess Members

[image] [image]

Grasshopper SDK
IGH_DataAccess Members
IGH_DataAccess Interface Methods Properties See Also Send Feedback

The IGH_DataAccess type exposes the following members.

Methods

 | Name | Description
Public method | BlitData<(Of <<'(Q>)>>) | Creates a direct copy of an existing data structure. The existing generic instance must of the exact same type as the target parameter.
Public method | DisableGapLogic()()()() | Call this function if you want to disable the gap null logic for the current iteration.
Public method | DisableGapLogic(Int32) | Call this function if you want to disable the gap null logic for a specific output parameter.
Public method | GetData<(Of <<'(T>)>>)(Int32, T%) | Retrieve data from an input parameter during GH_Component.SolveInstance().
Public method | GetData<(Of <<'(T>)>>)(String, T%) | Retrieve data from an input parameter during GH_Component.SolveInstance().
Public method | GetDataList<(Of <<'(T>)>>)(Int32, List<(Of <<'(T>)>>)) | Retrieve an entire list of data from an input parameter during GH_Component.SolveInstance().
Public method | GetDataList<(Of <<'(T>)>>)(String, List<(Of <<'(T>)>>)) | Retrieve an entire list of data from an input parameter during GH_Component.SolveInstance().
Public method | GetDataTree<(Of <<'(T>)>>)(Int32, GH_Structure<(Of <<'(T>)>>)%) | Retrieve an entire data tree from an input parameter during GH_Component.SolveInstance().
Public method | GetDataTree<(Of <<'(T>)>>)(String, GH_Structure<(Of <<'(T>)>>)%) | Retrieve an entire data tree from an input parameter during GH_Component.SolveInstance().
Public method | IncrementIteration | Increments the iteration count by 1.
Public method | ParameterTargetIndex | Get the target index for the specified output parameter.
Public method | ParameterTargetPath | Get the target path for the specified output parameter.
Public method | SetData(Int32, Object) | Stores data in an output parameter during GH_Component.SolveInstance(). Use this function only for setting individual data items. If you want to set lists of data, you *must* call SetDataList() instead.
Public method | SetData(String, Object) | Stores data in an output parameter during GH_Component.SolveInstance().
Public method | SetData(Int32, Object, Int32) | Expert user function. Stores data in an output parameter during GH_Component.SolveInstance(). Use this function only for setting individual data items. If you want to set lists of data, you *must* call SetDataList() instead.
Public method | SetDataList(Int32, IEnumerable) | Stores a list of data in an output parameter during GH_Component.SolveInstance().
Public method | SetDataList(String, IEnumerable) | Stores data in an output parameter during GH_Component.SolveInstance().
Public method | SetDataList(Int32, IEnumerable, Int32) | Expert user function. Stores a list of data in an output parameter during GH_Component.SolveInstance().
Public method | SetDataTree(Int32, IGH_DataTree) | Folds a utility tree representation into this tree.
Public method | SetDataTree(Int32, IGH_Structure) | Folds a utility tree representation into this tree.
Public method | Util_CountNonNullRefs<(Of <<'(T>)>>) | Count all object references in L
Public method | Util_CountNullRefs<(Of <<'(T>)>>) | Count all null references in L
Public method | Util_EnsureNonNullCount<(Of <<'(T>)>>) | Tests a list to see if it contains sufficient non-null references.
Public method | Util_FirstNonNullItem<(Of <<'(T>)>>) | Returns the index of the first non-null item in a list.
Public method | Util_RemoveNullRefs<(Of <<'(T>)>>) | Remove all null references from a list of items.

Properties

 | Name | Description
Public property | Iteration | Gets the current iteration count. The first time the SolveInstance() function is called on a component during a solution the Iteration counter will be zero. It will be incremented by one for every subsequent call.

See Also

IGH_DataAccess Interface
Grasshopper.Kernel Namespace


IGH_DataAccess Methods

[image] [image]

Grasshopper SDK
IGH_DataAccess Methods
IGH_DataAccess Interface See Also Send Feedback

The IGH_DataAccess type exposes the following members.

Methods

 | Name | Description
Public method | BlitData<(Of <<'(Q>)>>) | Creates a direct copy of an existing data structure. The existing generic instance must of the exact same type as the target parameter.
Public method | DisableGapLogic()()()() | Call this function if you want to disable the gap null logic for the current iteration.
Public method | DisableGapLogic(Int32) | Call this function if you want to disable the gap null logic for a specific output parameter.
Public method | GetData<(Of <<'(T>)>>)(Int32, T%) | Retrieve data from an input parameter during GH_Component.SolveInstance().
Public method | GetData<(Of <<'(T>)>>)(String, T%) | Retrieve data from an input parameter during GH_Component.SolveInstance().
Public method | GetDataList<(Of <<'(T>)>>)(Int32, List<(Of <<'(T>)>>)) | Retrieve an entire list of data from an input parameter during GH_Component.SolveInstance().
Public method | GetDataList<(Of <<'(T>)>>)(String, List<(Of <<'(T>)>>)) | Retrieve an entire list of data from an input parameter during GH_Component.SolveInstance().
Public method | GetDataTree<(Of <<'(T>)>>)(Int32, GH_Structure<(Of <<'(T>)>>)%) | Retrieve an entire data tree from an input parameter during GH_Component.SolveInstance().
Public method | GetDataTree<(Of <<'(T>)>>)(String, GH_Structure<(Of <<'(T>)>>)%) | Retrieve an entire data tree from an input parameter during GH_Component.SolveInstance().
Public method | IncrementIteration | Increments the iteration count by 1.
Public method | ParameterTargetIndex | Get the target index for the specified output parameter.
Public method | ParameterTargetPath | Get the target path for the specified output parameter.
Public method | SetData(Int32, Object) | Stores data in an output parameter during GH_Component.SolveInstance(). Use this function only for setting individual data items. If you want to set lists of data, you *must* call SetDataList() instead.
Public method | SetData(String, Object) | Stores data in an output parameter during GH_Component.SolveInstance().
Public method | SetData(Int32, Object, Int32) | Expert user function. Stores data in an output parameter during GH_Component.SolveInstance(). Use this function only for setting individual data items. If you want to set lists of data, you *must* call SetDataList() instead.
Public method | SetDataList(Int32, IEnumerable) | Stores a list of data in an output parameter during GH_Component.SolveInstance().
Public method | SetDataList(String, IEnumerable) | Stores data in an output parameter during GH_Component.SolveInstance().
Public method | SetDataList(Int32, IEnumerable, Int32) | Expert user function. Stores a list of data in an output parameter during GH_Component.SolveInstance().
Public method | SetDataTree(Int32, IGH_DataTree) | Folds a utility tree representation into this tree.
Public method | SetDataTree(Int32, IGH_Structure) | Folds a utility tree representation into this tree.
Public method | Util_CountNonNullRefs<(Of <<'(T>)>>) | Count all object references in L
Public method | Util_CountNullRefs<(Of <<'(T>)>>) | Count all null references in L
Public method | Util_EnsureNonNullCount<(Of <<'(T>)>>) | Tests a list to see if it contains sufficient non-null references.
Public method | Util_FirstNonNullItem<(Of <<'(T>)>>) | Returns the index of the first non-null item in a list.
Public method | Util_RemoveNullRefs<(Of <<'(T>)>>) | Remove all null references from a list of items.

See Also

IGH_DataAccess Interface
Grasshopper.Kernel Namespace


BlitData(Q) Method

[image]

Grasshopper SDK
IGH_DataAccess..::..BlitData<(Of <(<'Q>)>)> Method
IGH_DataAccess Interface See Also Send Feedback
Creates a direct copy of an existing data structure. The existing generic instance must of the exact same type as the target parameter.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool BlitData<Q>(
    int paramIndex,
    GH_Structure<Q> tree,
    bool overwrite
)
where Q : IGH_Goo
Visual Basic
Function BlitData(Of Q As IGH_Goo) ( _
    paramIndex As Integer, _
    tree As GH_Structure(Of Q), _
    overwrite As Boolean _
) As Boolean

Parameters

paramIndex
Type: System..::..Int32
Index of output parameter.
tree
Type: Grasshopper.Kernel.Data..::..GH_Structure <(Of <(<'Q>)>)>
Parameter whose data to blit
overwrite
Type: System..::..Boolean
If true, any existing data will be removed.

Type Parameters

Q
Type specified for GH_Structure(Of Q) comparison.

See Also

IGH_DataAccess Interface
Grasshopper.Kernel Namespace


DisableGapLogic Method

[image] [image]

Grasshopper SDK
IGH_DataAccess..::..DisableGapLogic Method
IGH_DataAccess Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | DisableGapLogic()()()() | Call this function if you want to disable the gap null logic for the current iteration.
Public method | DisableGapLogic(Int32) | Call this function if you want to disable the gap null logic for a specific output parameter.

See Also

IGH_DataAccess Interface
IGH_DataAccess Members
Grasshopper.Kernel Namespace


DisableGapLogic Method

[image]

Grasshopper SDK
IGH_DataAccess..::..DisableGapLogic Method
IGH_DataAccess Interface See Also Send Feedback
Call this function if you want to disable the gap null logic for the current iteration.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void DisableGapLogic()
Visual Basic
Sub DisableGapLogic

See Also

IGH_DataAccess Interface
DisableGapLogic Overload
Grasshopper.Kernel Namespace


DisableGapLogic Method (Int32)

[image]

Grasshopper SDK
IGH_DataAccess..::..DisableGapLogic Method (Int32)
IGH_DataAccess Interface See Also Send Feedback
Call this function if you want to disable the gap null logic for a specific output parameter.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void DisableGapLogic(
    int paramIndex
)
Visual Basic
Sub DisableGapLogic ( _
    paramIndex As Integer _
)

Parameters

paramIndex
Type: System..::..Int32
Index of output parameter to disable.

See Also

IGH_DataAccess Interface
DisableGapLogic Overload
Grasshopper.Kernel Namespace


GetData Method

[image] [image]

Grasshopper SDK
IGH_DataAccess..::..GetData Method
IGH_DataAccess Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetData<(Of <<'(T>)>>)(Int32, T%) | Retrieve data from an input parameter during GH_Component.SolveInstance().
Public method | GetData<(Of <<'(T>)>>)(String, T%) | Retrieve data from an input parameter during GH_Component.SolveInstance().

See Also

IGH_DataAccess Interface
IGH_DataAccess Members
Grasshopper.Kernel Namespace


GetData(T) Method (Int32, T)

[image]

Grasshopper SDK
IGH_DataAccess..::..GetData<(Of <(<'T>)>)> Method (Int32, T%)
IGH_DataAccess Interface See Also Send Feedback
Retrieve data from an input parameter during GH_Component.SolveInstance().

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool GetData<T>(
    int index,
    ref T destination
)
Visual Basic
Function GetData(Of T) ( _
    index As Integer, _
    ByRef destination As T _
) As Boolean

Parameters

index
Type: System..::..Int32
destination
Type: T%

Type Parameters

T
Type of the data to retrieve. If the data type does not match the parameter type, a conversion will be attempted.

Return Value

True on success, false on failure.

See Also

IGH_DataAccess Interface
GetData Overload
Grasshopper.Kernel Namespace


GetData(T) Method (String, T)

[image]

Grasshopper SDK
IGH_DataAccess..::..GetData<(Of <(<'T>)>)> Method (String, T%)
IGH_DataAccess Interface See Also Send Feedback
Retrieve data from an input parameter during GH_Component.SolveInstance().

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool GetData<T>(
    string name,
    ref T destination
)
Visual Basic
Function GetData(Of T) ( _
    name As String, _
    ByRef destination As T _
) As Boolean

Parameters

name
Type: System..::..String
destination
Type: T%

Type Parameters

T
Type of the data to retrieve. If the data type does not match the parameter type, a conversion will be attempted.

Return Value

True on success, false on failure.

Remarks

Parameter access by index is faster, consider using the other overload if possible.

See Also

IGH_DataAccess Interface
GetData Overload
Grasshopper.Kernel Namespace


GetDataList Method

[image] [image]

Grasshopper SDK
IGH_DataAccess..::..GetDataList Method
IGH_DataAccess Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDataList<(Of <<'(T>)>>)(Int32, List<(Of <<'(T>)>>)) | Retrieve an entire list of data from an input parameter during GH_Component.SolveInstance().
Public method | GetDataList<(Of <<'(T>)>>)(String, List<(Of <<'(T>)>>)) | Retrieve an entire list of data from an input parameter during GH_Component.SolveInstance().

See Also

IGH_DataAccess Interface
IGH_DataAccess Members
Grasshopper.Kernel Namespace


GetDataList(T) Method (Int32, List(T))

[image]

Grasshopper SDK
IGH_DataAccess..::..GetDataList<(Of <(<'T>)>)> Method (Int32, List<(Of <(<'T>)>)>)
IGH_DataAccess Interface See Also Send Feedback
Retrieve an entire list of data from an input parameter during GH_Component.SolveInstance().

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool GetDataList<T>(
    int index,
    List<T> list
)
Visual Basic
Function GetDataList(Of T) ( _
    index As Integer, _
    list As List(Of T) _
) As Boolean

Parameters

index
Type: System..::..Int32
list
Type: System.Collections.Generic..::..List <(Of <(<'T>)>)>

Type Parameters

T
Type of the data to retrieve. If the data type does not match the parameter type, a conversion will be attempted.

Return Value

True on success, false on failure.

See Also

IGH_DataAccess Interface
GetDataList Overload
Grasshopper.Kernel Namespace


GetDataList(T) Method (String, List(T))

[image]

Grasshopper SDK
IGH_DataAccess..::..GetDataList<(Of <(<'T>)>)> Method (String, List<(Of <(<'T>)>)>)
IGH_DataAccess Interface See Also Send Feedback
Retrieve an entire list of data from an input parameter during GH_Component.SolveInstance().

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool GetDataList<T>(
    string name,
    List<T> list
)
Visual Basic
Function GetDataList(Of T) ( _
    name As String, _
    list As List(Of T) _
) As Boolean

Parameters

name
Type: System..::..String
list
Type: System.Collections.Generic..::..List <(Of <(<'T>)>)>

Type Parameters

T
Type of the data to retrieve. If the data type does not match the parameter type, a conversion will be attempted.

Return Value

True on success, false on failure.

Remarks

Parameter access by index is faster, consider using the other overload if possible.

See Also

IGH_DataAccess Interface
GetDataList Overload
Grasshopper.Kernel Namespace


GetDataTree Method

[image] [image]

Grasshopper SDK
IGH_DataAccess..::..GetDataTree Method
IGH_DataAccess Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDataTree<(Of <<'(T>)>>)(Int32, GH_Structure<(Of <<'(T>)>>)%) | Retrieve an entire data tree from an input parameter during GH_Component.SolveInstance().
Public method | GetDataTree<(Of <<'(T>)>>)(String, GH_Structure<(Of <<'(T>)>>)%) | Retrieve an entire data tree from an input parameter during GH_Component.SolveInstance().

See Also

IGH_DataAccess Interface
IGH_DataAccess Members
Grasshopper.Kernel Namespace


GetDataTree(T) Method (Int32, GH_Structure(T))

[image]

Grasshopper SDK
IGH_DataAccess..::..GetDataTree<(Of <(<'T>)>)> Method (Int32, GH_Structure<(Of <(<'T>)>)>%)
IGH_DataAccess Interface See Also Send Feedback
Retrieve an entire data tree from an input parameter during GH_Component.SolveInstance().

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool GetDataTree<T>(
    int index,
    out GH_Structure<T> tree
)
where T : IGH_Goo
Visual Basic
Function GetDataTree(Of T As IGH_Goo) ( _
    index As Integer, _
    <OutAttribute> ByRef tree As GH_Structure(Of T) _
) As Boolean

Parameters

index
Type: System..::..Int32
tree
Type: Grasshopper.Kernel.Data..::..GH_Structure <(Of <(<'T>)>)>%

Type Parameters

T
Type of the data to retrieve. Must be identical to the type stored in the parameter.

Return Value

True on success, false on failure.

See Also

IGH_DataAccess Interface
GetDataTree Overload
Grasshopper.Kernel Namespace


GetDataTree(T) Method (String, GH_Structure(T))

[image]

Grasshopper SDK
IGH_DataAccess..::..GetDataTree<(Of <(<'T>)>)> Method (String, GH_Structure<(Of <(<'T>)>)>%)
IGH_DataAccess Interface See Also Send Feedback
Retrieve an entire data tree from an input parameter during GH_Component.SolveInstance().

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool GetDataTree<T>(
    string name,
    out GH_Structure<T> tree
)
where T : IGH_Goo
Visual Basic
Function GetDataTree(Of T As IGH_Goo) ( _
    name As String, _
    <OutAttribute> ByRef tree As GH_Structure(Of T) _
) As Boolean

Parameters

name
Type: System..::..String
tree
Type: Grasshopper.Kernel.Data..::..GH_Structure <(Of <(<'T>)>)>%

Type Parameters

T
Type of the data to retrieve. Must be identical to the type stored in the parameter.

Return Value

True on success, false on failure.

Remarks

Parameter access by index is faster, consider using the other overload if possible.

See Also

IGH_DataAccess Interface
GetDataTree Overload
Grasshopper.Kernel Namespace


IncrementIteration Method

[image]

Grasshopper SDK
IGH_DataAccess..::..IncrementIteration Method
IGH_DataAccess Interface See Also Send Feedback
Increments the iteration count by 1.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void IncrementIteration()
Visual Basic
Sub IncrementIteration

See Also

IGH_DataAccess Interface
Grasshopper.Kernel Namespace


ParameterTargetIndex Method

[image]

Grasshopper SDK
IGH_DataAccess..::..ParameterTargetIndex Method
IGH_DataAccess Interface See Also Send Feedback
Get the target index for the specified output parameter.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
int ParameterTargetIndex(
    int paramIndex
)
Visual Basic
Function ParameterTargetIndex ( _
    paramIndex As Integer _
) As Integer

Parameters

paramIndex
Type: System..::..Int32
Index of output parameter.

See Also

IGH_DataAccess Interface
Grasshopper.Kernel Namespace


ParameterTargetPath Method

[image]

Grasshopper SDK
IGH_DataAccess..::..ParameterTargetPath Method
IGH_DataAccess Interface See Also Send Feedback
Get the target path for the specified output parameter.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
GH_Path ParameterTargetPath(
    int paramIndex
)
Visual Basic
Function ParameterTargetPath ( _
    paramIndex As Integer _
) As GH_Path

Parameters

paramIndex
Type: System..::..Int32
Index of output parameter.

See Also

IGH_DataAccess Interface
Grasshopper.Kernel Namespace


SetData Method

[image] [image]

Grasshopper SDK
IGH_DataAccess..::..SetData Method
IGH_DataAccess Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SetData(Int32, Object) | Stores data in an output parameter during GH_Component.SolveInstance(). Use this function only for setting individual data items. If you want to set lists of data, you *must* call SetDataList() instead.
Public method | SetData(String, Object) | Stores data in an output parameter during GH_Component.SolveInstance().
Public method | SetData(Int32, Object, Int32) | Expert user function. Stores data in an output parameter during GH_Component.SolveInstance(). Use this function only for setting individual data items. If you want to set lists of data, you *must* call SetDataList() instead.

See Also

IGH_DataAccess Interface
IGH_DataAccess Members
Grasshopper.Kernel Namespace


SetData Method (Int32, Object)

[image]

Grasshopper SDK
IGH_DataAccess..::..SetData Method (Int32, Object)
IGH_DataAccess Interface See Also Send Feedback
Stores data in an output parameter during GH_Component.SolveInstance(). Use this function only for setting individual data items. If you want to set lists of data, you *must* call SetDataList() instead.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool SetData(
    int paramIndex,
    Object data
)
Visual Basic
Function SetData ( _
    paramIndex As Integer, _
    data As Object _
) As Boolean

Parameters

paramIndex
Type: System..::..Int32
Index of the output parameter at which to store the data.
data
Type: System..::..Object
Data to store. Data will be converted if necessary, but it will not be duplicated automatically.

See Also

IGH_DataAccess Interface
SetData Overload
Grasshopper.Kernel Namespace


SetData Method (String, Object)

[image]

Grasshopper SDK
IGH_DataAccess..::..SetData Method (String, Object)
IGH_DataAccess Interface See Also Send Feedback
Stores data in an output parameter during GH_Component.SolveInstance().

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool SetData(
    string paramName,
    Object data
)
Visual Basic
Function SetData ( _
    paramName As String, _
    data As Object _
) As Boolean

Parameters

paramName
Type: System..::..String
Name of the output parameter at which to store the data.
data
Type: System..::..Object
Data to store. Data will be converted if necessary, but it will not be duplicated automatically.

Remarks

Parameter access by index is faster, consider using the other overload if possible.

See Also

IGH_DataAccess Interface
SetData Overload
Grasshopper.Kernel Namespace


SetData Method (Int32, Object, Int32)

[image]

Grasshopper SDK
IGH_DataAccess..::..SetData Method (Int32, Object, Int32)
IGH_DataAccess Interface See Also Send Feedback
Expert user function. Stores data in an output parameter during GH_Component.SolveInstance(). Use this function only for setting individual data items. If you want to set lists of data, you *must* call SetDataList() instead.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool SetData(
    int paramIndex,
    Object data,
    int itemIndexOverride
)
Visual Basic
Function SetData ( _
    paramIndex As Integer, _
    data As Object, _
    itemIndexOverride As Integer _
) As Boolean

Parameters

paramIndex
Type: System..::..Int32
Index of the output parameter at which to store the data.
data
Type: System..::..Object
Data to store. Data will be converted if necessary, but it will not be duplicated automatically.
itemIndexOverride
Type: System..::..Int32
Typically the item index is a result of Data matching logic. If you want to override the item index, then call this function.

See Also

IGH_DataAccess Interface
SetData Overload
Grasshopper.Kernel Namespace


SetDataList Method

[image] [image]

Grasshopper SDK
IGH_DataAccess..::..SetDataList Method
IGH_DataAccess Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDataList(Int32, IEnumerable) | Stores a list of data in an output parameter during GH_Component.SolveInstance().
Public method | SetDataList(String, IEnumerable) | Stores data in an output parameter during GH_Component.SolveInstance().
Public method | SetDataList(Int32, IEnumerable, Int32) | Expert user function. Stores a list of data in an output parameter during GH_Component.SolveInstance().

See Also

IGH_DataAccess Interface
IGH_DataAccess Members
Grasshopper.Kernel Namespace


SetDataList Method (Int32, IEnumerable)

[image]

Grasshopper SDK
IGH_DataAccess..::..SetDataList Method (Int32, IEnumerable)
IGH_DataAccess Interface See Also Send Feedback
Stores a list of data in an output parameter during GH_Component.SolveInstance().

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool SetDataList(
    int paramIndex,
    IEnumerable data
)
Visual Basic
Function SetDataList ( _
    paramIndex As Integer, _
    data As IEnumerable _
) As Boolean

Parameters

paramIndex
Type: System..::..Int32
Index of the output parameter at which to store the list.
data
Type: System.Collections..::..IEnumerable
Data to store. Data will be converted if necessary, but it will not be duplicated automatically.

See Also

IGH_DataAccess Interface
SetDataList Overload
Grasshopper.Kernel Namespace


SetDataList Method (String, IEnumerable)

[image]

Grasshopper SDK
IGH_DataAccess..::..SetDataList Method (String, IEnumerable)
IGH_DataAccess Interface See Also Send Feedback
Stores data in an output parameter during GH_Component.SolveInstance().

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool SetDataList(
    string paramName,
    IEnumerable data
)
Visual Basic
Function SetDataList ( _
    paramName As String, _
    data As IEnumerable _
) As Boolean

Parameters

paramName
Type: System..::..String
Name of the parameter at which to store the data.
data
Type: System.Collections..::..IEnumerable
Data to store. Data will be converted if necessary, but it will not be duplicated automatically.

Remarks

Parameter access by index is faster, consider using the other overload if possible.

See Also

IGH_DataAccess Interface
SetDataList Overload
Grasshopper.Kernel Namespace


SetDataList Method (Int32, IEnumerable, Int32)

[image]

Grasshopper SDK
IGH_DataAccess..::..SetDataList Method (Int32, IEnumerable, Int32)
IGH_DataAccess Interface See Also Send Feedback
Expert user function. Stores a list of data in an output parameter during GH_Component.SolveInstance().

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool SetDataList(
    int paramIndex,
    IEnumerable data,
    int listIndexOverride
)
Visual Basic
Function SetDataList ( _
    paramIndex As Integer, _
    data As IEnumerable, _
    listIndexOverride As Integer _
) As Boolean

Parameters

paramIndex
Type: System..::..Int32
Index of the output parameter at which to store the list.
data
Type: System.Collections..::..IEnumerable
Data to store. Data will be converted if necessary, but it will not be duplicated automatically.
listIndexOverride
Type: System..::..Int32
Typically the branch index is a result of Data matching logic. If you want to override the branch index, then call this function.

See Also

IGH_DataAccess Interface
SetDataList Overload
Grasshopper.Kernel Namespace


SetDataTree Method

[image] [image]

Grasshopper SDK
IGH_DataAccess..::..SetDataTree Method
IGH_DataAccess Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDataTree(Int32, IGH_DataTree) | Folds a utility tree representation into this tree.
Public method | SetDataTree(Int32, IGH_Structure) | Folds a utility tree representation into this tree.

See Also

IGH_DataAccess Interface
IGH_DataAccess Members
Grasshopper.Kernel Namespace


SetDataTree Method (Int32, IGH_DataTree)

[image]

Grasshopper SDK
IGH_DataAccess..::..SetDataTree Method (Int32, IGH_DataTree)
IGH_DataAccess Interface See Also Send Feedback
Folds a utility tree representation into this tree.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool SetDataTree(
    int paramIndex,
    IGH_DataTree tree
)
Visual Basic
Function SetDataTree ( _
    paramIndex As Integer, _
    tree As IGH_DataTree _
) As Boolean

Parameters

paramIndex
Type: System..::..Int32
Index of output parameter to merge with.
tree
Type: Grasshopper.Kernel.Data..::..IGH_DataTree
Tree to merge

See Also

IGH_DataAccess Interface
SetDataTree Overload
Grasshopper.Kernel Namespace


SetDataTree Method (Int32, IGH_Structure)

[image]

Grasshopper SDK
IGH_DataAccess..::..SetDataTree Method (Int32, IGH_Structure)
IGH_DataAccess Interface See Also Send Feedback
Folds a utility tree representation into this tree.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool SetDataTree(
    int paramIndex,
    IGH_Structure tree
)
Visual Basic
Function SetDataTree ( _
    paramIndex As Integer, _
    tree As IGH_Structure _
) As Boolean

Parameters

paramIndex
Type: System..::..Int32
Index of output parameter to merge with.
tree
Type: Grasshopper.Kernel.Data..::..IGH_Structure
Tree to merge

See Also

IGH_DataAccess Interface
SetDataTree Overload
Grasshopper.Kernel Namespace


Util_CountNonNullRefs(T) Method

[image]

Grasshopper SDK
IGH_DataAccess..::..Util_CountNonNullRefs<(Of <(<'T>)>)> Method
IGH_DataAccess Interface See Also Send Feedback
Count all object references in L

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
int Util_CountNonNullRefs<T>(
    List<T> L
)
Visual Basic
Function Util_CountNonNullRefs(Of T) ( _
    L As List(Of T) _
) As Integer

Parameters

L
Type: System.Collections.Generic..::..List <(Of <(<'T>)>)>
List to parse

Type Parameters

T
Type of list

Return Value

Number of proper objects in L

See Also

IGH_DataAccess Interface
Grasshopper.Kernel Namespace


Util_CountNullRefs(T) Method

[image]

Grasshopper SDK
IGH_DataAccess..::..Util_CountNullRefs<(Of <(<'T>)>)> Method
IGH_DataAccess Interface See Also Send Feedback
Count all null references in L

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
int Util_CountNullRefs<T>(
    List<T> L
)
Visual Basic
Function Util_CountNullRefs(Of T) ( _
    L As List(Of T) _
) As Integer

Parameters

L
Type: System.Collections.Generic..::..List <(Of <(<'T>)>)>
List to parse

Type Parameters

T
Type of list

Return Value

Number of nulls in L

See Also

IGH_DataAccess Interface
Grasshopper.Kernel Namespace


Util_EnsureNonNullCount(T) Method

[image]

Grasshopper SDK
IGH_DataAccess..::..Util_EnsureNonNullCount<(Of <(<'T>)>)> Method
IGH_DataAccess Interface See Also Send Feedback
Tests a list to see if it contains sufficient non-null references.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool Util_EnsureNonNullCount<T>(
    List<T> L,
    int N
)
Visual Basic
Function Util_EnsureNonNullCount(Of T) ( _
    L As List(Of T), _
    N As Integer _
) As Boolean

Parameters

L
Type: System.Collections.Generic..::..List <(Of <(<'T>)>)>
List to parse
N
Type: System..::..Int32

Type Parameters

T
Type of list

Return Value

True if L contains N or more non-null references.

See Also

IGH_DataAccess Interface
Grasshopper.Kernel Namespace


Util_FirstNonNullItem(T) Method

[image]

Grasshopper SDK
IGH_DataAccess..::..Util_FirstNonNullItem<(Of <(<'T>)>)> Method
IGH_DataAccess Interface See Also Send Feedback
Returns the index of the first non-null item in a list.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
int Util_FirstNonNullItem<T>(
    List<T> L
)
Visual Basic
Function Util_FirstNonNullItem(Of T) ( _
    L As List(Of T) _
) As Integer

Parameters

L
Type: System.Collections.Generic..::..List <(Of <(<'T>)>)>
List to parse.

Type Parameters

T
Type of list

Return Value

The index of the first non-null item or -1 if no object reference could be found.

See Also

IGH_DataAccess Interface
Grasshopper.Kernel Namespace


Util_RemoveNullRefs(T) Method

[image]

Grasshopper SDK
IGH_DataAccess..::..Util_RemoveNullRefs<(Of <(<'T>)>)> Method
IGH_DataAccess Interface See Also Send Feedback
Remove all null references from a list of items.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
List<T> Util_RemoveNullRefs<T>(
    List<T> L
)
Visual Basic
Function Util_RemoveNullRefs(Of T) ( _
    L As List(Of T) _
) As List(Of T)

Parameters

L
Type: System.Collections.Generic..::..List <(Of <(<'T>)>)>
List to filter

Type Parameters

T
Type of list

Return Value

List containing only non-null items. References are shared with L

See Also

IGH_DataAccess Interface
Grasshopper.Kernel Namespace


IGH_DataAccess Properties

[image] [image]

Grasshopper SDK
IGH_DataAccess Properties
IGH_DataAccess Interface See Also Send Feedback

The IGH_DataAccess type exposes the following members.

Properties

 | Name | Description
Public property | Iteration | Gets the current iteration count. The first time the SolveInstance() function is called on a component during a solution the Iteration counter will be zero. It will be incremented by one for every subsequent call.

See Also

IGH_DataAccess Interface
Grasshopper.Kernel Namespace


Iteration Property

[image]

Grasshopper SDK
IGH_DataAccess..::..Iteration Property
IGH_DataAccess Interface See Also Send Feedback
Gets the current iteration count. The first time the SolveInstance() function is called on a component during a solution the Iteration counter will be zero. It will be incremented by one for every subsequent call.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
int Iteration { get; }
Visual Basic
ReadOnly Property Iteration As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_DataAccess.Iteration"]

Return Value

An integer representing the iteration count.

See Also

IGH_DataAccess Interface
Grasshopper.Kernel Namespace


IGH_DebugDescription Interface

[image]

Grasshopper SDK
IGH_DebugDescription Interface
Members See Also Send Feedback
Implement this interface to participate in Debug Logging.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_DebugDescription
Visual Basic
Public Interface IGH_DebugDescription

See Also

IGH_DebugDescription Members
Grasshopper.Kernel Namespace


IGH_DebugDescription Members

[image] [image]

Grasshopper SDK
IGH_DebugDescription Members
IGH_DebugDescription Interface Methods See Also Send Feedback

The IGH_DebugDescription type exposes the following members.

Methods

 | Name | Description
Public method | AppendToDebugLog | Write important debugging data to a debug writer object.

See Also

IGH_DebugDescription Interface
Grasshopper.Kernel Namespace


IGH_DebugDescription Methods

[image] [image]

Grasshopper SDK
IGH_DebugDescription Methods
IGH_DebugDescription Interface See Also Send Feedback

The IGH_DebugDescription type exposes the following members.

Methods

 | Name | Description
Public method | AppendToDebugLog | Write important debugging data to a debug writer object.

See Also

IGH_DebugDescription Interface
Grasshopper.Kernel Namespace


AppendToDebugLog Method

[image]

Grasshopper SDK
IGH_DebugDescription..::..AppendToDebugLog Method
IGH_DebugDescription Interface See Also Send Feedback
Write important debugging data to a debug writer object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void AppendToDebugLog(
    GH_DebugDescriptionWriter writer
)
Visual Basic
Sub AppendToDebugLog ( _
    writer As GH_DebugDescriptionWriter _
)

Parameters

writer
Type: Grasshopper.Kernel..::..GH_DebugDescriptionWriter
Object to write to.

See Also

IGH_DebugDescription Interface
Grasshopper.Kernel Namespace


IGH_DocumentObject Interface

[image]

Grasshopper SDK
IGH_DocumentObject Interface
Members See Also Send Feedback
Base interface for objects that want to play on the Canvas. Do not implement this interface from scratch. Either inherit from GH_DocumentObject or one of the other partially finished types such as GH_ActiveObject, GH_Param(Of T) or GH_Component.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_DocumentObject : IGH_InstanceDescription
Visual Basic
Public Interface IGH_DocumentObject _
    Inherits IGH_InstanceDescription

See Also

IGH_DocumentObject Members
Grasshopper.Kernel Namespace


IGH_DocumentObject Members

[image] [image]

Grasshopper SDK
IGH_DocumentObject Members
IGH_DocumentObject Interface Methods Properties Events See Also Send Feedback

The IGH_DocumentObject type exposes the following members.

Methods

 | Name | Description
Public method | AddedToDocument | This method will be called when an object is added to a document.
Public method | AppendMenuItems | This function is called when a context menu is about to be displayed. Override it to set custom items.
Public method | CreateAttributes | Create new default attributes for this object. You should only call this function when the Attributes() field is null.
Public method | DocumentContextChanged | This method will be called when the document that owns this object moves into a different context.
Public method | ExpirePreview | Call this function when you suspect that the preview has expired for this object. This will cause the display cache to be eradicated.
Public method | ExpireSolution | Call this function whenever you do something which expires the current solution. This will make sure all caches are erased, all downstream objects are expired and that the event is raised. The default implementation merely places a call to OnSolutionExpired(), override this function in derived classes to make sure you clear local data caches and expire downstream objects.
Public method | IsolateObject | Destroy all connections to other objects.
Public method | MovedBetweenDocuments | This method will be called when an object is moved from one document to another.
Public method | NewInstanceGuid()()()() | Generate a new random instance GUID (Inherited from IGH_InstanceDescription.)
Public method | NewInstanceGuid(Guid) | Set the instance ID to be a specific GUID. This is very dangerous, only use this function if you're 6"4' and called David. (Inherited from IGH_InstanceDescription.)
Public method | OnAttributesChanged | Raises the AttributesChanged event on the toplevel object.
Public method | OnDisplayExpired | Raises the DisplayExpired event on the toplevel object.
Public method | OnObjectChanged(String) | Raises the ObjectChanged event on the current (!not the top level!) object.
Public method | OnObjectChanged(GH_ObjectChangedEventArgs) | Raises the ObjectChanged event on the current (!not the top level!) object.
Public method | OnObjectChanged(GH_ObjectEventType) | Raises the ObjectChanged event on the current (!not the top level!) object.
Public method | OnObjectChanged(String, Object) | Raises the ObjectChanged event on the current (!not the top level!) object.
Public method | OnObjectChanged(GH_ObjectEventType, Object) | Raises the ObjectChanged event on the current (!not the top level!) object.
Public method | OnPingDocument | Raise the PingDocument Event on the toplevel object and try to find the document which owns this object.
Public method | OnPreviewExpired | Raises the PreviewExpired event on the toplevel object.
Public method | OnSolutionExpired | Raises the SolutionExpired event on the toplevel object.
Public method | RecordUndoEvent(String) | Record a generic object change undo event.
Public method | RecordUndoEvent(GH_UndoRecord) | Record an entire undo record.
Public method | RecordUndoEvent(String, IGH_UndoAction) | Record a specific object change undo event.
Public method | RemovedFromDocument | This method will be called when an object is removed from a document.
Public method | TriggerAutoSave()()()() | Triggers the AutoSave function on the owner document with the object_changed flag.
Public method | TriggerAutoSave(Guid) | Triggers the AutoSave function on the owner document with the object_changed flag.
Public method | TriggerAutoSave(GH_AutoSaveTrigger) | Triggers the AutoSave function on the owner document with a custom flag.
Public method | TriggerAutoSave(GH_AutoSaveTrigger, Guid) | Triggers the AutoSave function on the owner document with a custom flag.

Properties

 | Name | Description
Public property | Attributes | Gets or sets the attributes that are associated with this object. Only set custom attributes if you know what you are doing.
Public property | Category | Gets or sets the Category in which this object belongs. If HasCategory() returns false, this field has no meaning. (Inherited from IGH_InstanceDescription.)
Public property | ComponentGuid | Returns a consistent ID for this object type. Every object must supply a unique and unchanging ID that is used to identify objects of the same type.
Public property | Description | Gets or sets the description of the object. This field typically remains fixed during the lifetime of an object. (Inherited from IGH_InstanceDescription.)
Public property | Exposure | Gets the exposure of this object in the Graphical User Interface.
Public property | HasCategory | Gets whether or not the Category field has been set. (Inherited from IGH_InstanceDescription.)
Public property | HasSubCategory | Gets whether or not the SubCategory field has been set. (Inherited from IGH_InstanceDescription.)
Public property | Icon_24x24 | The icon associated with this object.
Public property | Icon_24x24_Locked | The greyscale icon of this object.
Public property | IconDisplayMode | Gets the current display mode of the object.
Public property | InstanceDescription | Gets a description of the current state of the object. This field is usually the same as the Description() field, but it might be variable when overridden. (Inherited from IGH_InstanceDescription.)
Public property | InstanceGuid | Gets the ID of this runtime instance. (Inherited from IGH_InstanceDescription.)
Public property | Keywords | Gets a list of additional keywords that describe the object. Typically this list is empty but you can override this property to aid in object searches. (Inherited from IGH_InstanceDescription.)
Public property | Name | Gets or sets the name of the object. This field typically remains fixed during the lifetime of an object. (Inherited from IGH_InstanceDescription.)
Public property | NickName | Gets or sets the nickname of the object. This field can be changed by the user. (Inherited from IGH_InstanceDescription.)
Public property | Obsolete | Gets whether this object is Obsolete.
Public property | SubCategory | Gets or sets the SubCategory in which this object belongs. If HasSubCategory() returns false, this field has no meaning. (Inherited from IGH_InstanceDescription.)

Events

 | Name | Description
Public event | AttributesChanged | Raised whenever the number or kind of attributes changes. This event is handled by GH_Documents who subsequently wipe their attribute caches.
Public event | DisplayExpired | Raised whenever the display (on the Canvas) of a certain object becomes invalid.
Public event | ObjectChanged | Raised whenever some property of the object changes that would affect remote instances.
Public event | PingDocument | Raised whenever an object needs to know which GH_Document it belongs to.
Public event | PreviewExpired | Raised whenever the display (in the Rhino viewports) of a certain object becomes invalid.
Public event | SolutionExpired | Raised whenever the solution of a certain object becomes invalid.

See Also

IGH_DocumentObject Interface
Grasshopper.Kernel Namespace


IGH_DocumentObject Methods

[image] [image]

Grasshopper SDK
IGH_DocumentObject Methods
IGH_DocumentObject Interface See Also Send Feedback

The IGH_DocumentObject type exposes the following members.

Methods

 | Name | Description
Public method | AddedToDocument | This method will be called when an object is added to a document.
Public method | AppendMenuItems | This function is called when a context menu is about to be displayed. Override it to set custom items.
Public method | CreateAttributes | Create new default attributes for this object. You should only call this function when the Attributes() field is null.
Public method | DocumentContextChanged | This method will be called when the document that owns this object moves into a different context.
Public method | ExpirePreview | Call this function when you suspect that the preview has expired for this object. This will cause the display cache to be eradicated.
Public method | ExpireSolution | Call this function whenever you do something which expires the current solution. This will make sure all caches are erased, all downstream objects are expired and that the event is raised. The default implementation merely places a call to OnSolutionExpired(), override this function in derived classes to make sure you clear local data caches and expire downstream objects.
Public method | IsolateObject | Destroy all connections to other objects.
Public method | MovedBetweenDocuments | This method will be called when an object is moved from one document to another.
Public method | NewInstanceGuid()()()() | Generate a new random instance GUID (Inherited from IGH_InstanceDescription.)
Public method | NewInstanceGuid(Guid) | Set the instance ID to be a specific GUID. This is very dangerous, only use this function if you're 6"4' and called David. (Inherited from IGH_InstanceDescription.)
Public method | OnAttributesChanged | Raises the AttributesChanged event on the toplevel object.
Public method | OnDisplayExpired | Raises the DisplayExpired event on the toplevel object.
Public method | OnObjectChanged(String) | Raises the ObjectChanged event on the current (!not the top level!) object.
Public method | OnObjectChanged(GH_ObjectChangedEventArgs) | Raises the ObjectChanged event on the current (!not the top level!) object.
Public method | OnObjectChanged(GH_ObjectEventType) | Raises the ObjectChanged event on the current (!not the top level!) object.
Public method | OnObjectChanged(String, Object) | Raises the ObjectChanged event on the current (!not the top level!) object.
Public method | OnObjectChanged(GH_ObjectEventType, Object) | Raises the ObjectChanged event on the current (!not the top level!) object.
Public method | OnPingDocument | Raise the PingDocument Event on the toplevel object and try to find the document which owns this object.
Public method | OnPreviewExpired | Raises the PreviewExpired event on the toplevel object.
Public method | OnSolutionExpired | Raises the SolutionExpired event on the toplevel object.
Public method | RecordUndoEvent(String) | Record a generic object change undo event.
Public method | RecordUndoEvent(GH_UndoRecord) | Record an entire undo record.
Public method | RecordUndoEvent(String, IGH_UndoAction) | Record a specific object change undo event.
Public method | RemovedFromDocument | This method will be called when an object is removed from a document.
Public method | TriggerAutoSave()()()() | Triggers the AutoSave function on the owner document with the object_changed flag.
Public method | TriggerAutoSave(Guid) | Triggers the AutoSave function on the owner document with the object_changed flag.
Public method | TriggerAutoSave(GH_AutoSaveTrigger) | Triggers the AutoSave function on the owner document with a custom flag.
Public method | TriggerAutoSave(GH_AutoSaveTrigger, Guid) | Triggers the AutoSave function on the owner document with a custom flag.

See Also

IGH_DocumentObject Interface
Grasshopper.Kernel Namespace


AddedToDocument Method

[image]

Grasshopper SDK
IGH_DocumentObject..::..AddedToDocument Method
IGH_DocumentObject Interface See Also Send Feedback
This method will be called when an object is added to a document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void AddedToDocument(
    GH_Document document
)
Visual Basic
Sub AddedToDocument ( _
    document As GH_Document _
)

Parameters

document
Type: Grasshopper.Kernel..::..GH_Document
Document that now owns this object.

See Also

IGH_DocumentObject Interface
Grasshopper.Kernel Namespace


AppendMenuItems Method

[image]

Grasshopper SDK
IGH_DocumentObject..::..AppendMenuItems Method
IGH_DocumentObject Interface See Also Send Feedback
This function is called when a context menu is about to be displayed. Override it to set custom items.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool AppendMenuItems(
    ToolStripDropDown menu
)
Visual Basic
Function AppendMenuItems ( _
    menu As ToolStripDropDown _
) As Boolean

Parameters

menu
Type: System.Windows.Forms..::..ToolStripDropDown
Menu object to populate.

See Also

IGH_DocumentObject Interface
Grasshopper.Kernel Namespace


CreateAttributes Method

[image]

Grasshopper SDK
IGH_DocumentObject..::..CreateAttributes Method
IGH_DocumentObject Interface See Also Send Feedback
Create new default attributes for this object. You should only call this function when the Attributes() field is null.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void CreateAttributes()
Visual Basic
Sub CreateAttributes

See Also

IGH_DocumentObject Interface
Grasshopper.Kernel Namespace


DocumentContextChanged Method

[image]

Grasshopper SDK
IGH_DocumentObject..::..DocumentContextChanged Method
IGH_DocumentObject Interface See Also Send Feedback
This method will be called when the document that owns this object moves into a different context.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void DocumentContextChanged(
    GH_Document document,
    GH_DocumentContext context
)
Visual Basic
Sub DocumentContextChanged ( _
    document As GH_Document, _
    context As GH_DocumentContext _
)

Parameters

document
Type: Grasshopper.Kernel..::..GH_Document
Document that owns this object.
context
Type: Grasshopper.Kernel..::..GH_DocumentContext
The reason for this event.

See Also

IGH_DocumentObject Interface
Grasshopper.Kernel Namespace


ExpirePreview Method

[image]

Grasshopper SDK
IGH_DocumentObject..::..ExpirePreview Method
IGH_DocumentObject Interface See Also Send Feedback
Call this function when you suspect that the preview has expired for this object. This will cause the display cache to be eradicated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void ExpirePreview(
    bool redraw
)
Visual Basic
Sub ExpirePreview ( _
    redraw As Boolean _
)

Parameters

redraw
Type: System..::..Boolean

See Also

IGH_DocumentObject Interface
Grasshopper.Kernel Namespace


ExpireSolution Method

[image]

Grasshopper SDK
IGH_DocumentObject..::..ExpireSolution Method
IGH_DocumentObject Interface See Also Send Feedback
Call this function whenever you do something which expires the current solution. This will make sure all caches are erased, all downstream objects are expired and that the event is raised. The default implementation merely places a call to OnSolutionExpired(), override this function in derived classes to make sure you clear local data caches and expire downstream objects.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void ExpireSolution(
    bool recompute
)
Visual Basic
Sub ExpireSolution ( _
    recompute As Boolean _
)

Parameters

recompute
Type: System..::..Boolean
If True, the solution will be recomputed straight away.

See Also

IGH_DocumentObject Interface
Grasshopper.Kernel Namespace


IsolateObject Method

[image]

Grasshopper SDK
IGH_DocumentObject..::..IsolateObject Method
IGH_DocumentObject Interface See Also Send Feedback
Destroy all connections to other objects.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void IsolateObject()
Visual Basic
Sub IsolateObject

See Also

IGH_DocumentObject Interface
Grasshopper.Kernel Namespace


MovedBetweenDocuments Method

[image]

Grasshopper SDK
IGH_DocumentObject..::..MovedBetweenDocuments Method
IGH_DocumentObject Interface See Also Send Feedback
This method will be called when an object is moved from one document to another.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void MovedBetweenDocuments(
    GH_Document oldDocument,
    GH_Document newDocument
)
Visual Basic
Sub MovedBetweenDocuments ( _
    oldDocument As GH_Document, _
    newDocument As GH_Document _
)

Parameters

oldDocument
Type: Grasshopper.Kernel..::..GH_Document
Document that used to own this object.
newDocument
Type: Grasshopper.Kernel..::..GH_Document
Document that now owns ths object.

See Also

IGH_DocumentObject Interface
Grasshopper.Kernel Namespace


NewInstanceGuid Method

[image] [image]

Grasshopper SDK
IGH_DocumentObject..::..NewInstanceGuid Method
IGH_DocumentObject Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | NewInstanceGuid()()()() | Generate a new random instance GUID (Inherited from IGH_InstanceDescription.)
Public method | NewInstanceGuid(Guid) | Set the instance ID to be a specific GUID. This is very dangerous, only use this function if you're 6"4' and called David. (Inherited from IGH_InstanceDescription.)

See Also

IGH_DocumentObject Interface
IGH_DocumentObject Members
Grasshopper.Kernel Namespace


OnAttributesChanged Method

[image]

Grasshopper SDK
IGH_DocumentObject..::..OnAttributesChanged Method
IGH_DocumentObject Interface See Also Send Feedback
Raises the AttributesChanged event on the toplevel object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void OnAttributesChanged()
Visual Basic
Sub OnAttributesChanged

See Also

IGH_DocumentObject Interface
Grasshopper.Kernel Namespace


OnDisplayExpired Method

[image]

Grasshopper SDK
IGH_DocumentObject..::..OnDisplayExpired Method
IGH_DocumentObject Interface See Also Send Feedback
Raises the DisplayExpired event on the toplevel object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void OnDisplayExpired(
    bool redraw
)
Visual Basic
Sub OnDisplayExpired ( _
    redraw As Boolean _
)

Parameters

redraw
Type: System..::..Boolean
If True, the canvas will be immediately redrawn.

See Also

IGH_DocumentObject Interface
Grasshopper.Kernel Namespace


OnObjectChanged Method

[image] [image]

Grasshopper SDK
IGH_DocumentObject..::..OnObjectChanged Method
IGH_DocumentObject Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | OnObjectChanged(String) | Raises the ObjectChanged event on the current (!not the top level!) object.
Public method | OnObjectChanged(GH_ObjectChangedEventArgs) | Raises the ObjectChanged event on the current (!not the top level!) object.
Public method | OnObjectChanged(GH_ObjectEventType) | Raises the ObjectChanged event on the current (!not the top level!) object.
Public method | OnObjectChanged(String, Object) | Raises the ObjectChanged event on the current (!not the top level!) object.
Public method | OnObjectChanged(GH_ObjectEventType, Object) | Raises the ObjectChanged event on the current (!not the top level!) object.

See Also

IGH_DocumentObject Interface
IGH_DocumentObject Members
Grasshopper.Kernel Namespace


OnObjectChanged Method (String)

[image]

Grasshopper SDK
IGH_DocumentObject..::..OnObjectChanged Method (String)
IGH_DocumentObject Interface See Also Send Feedback
Raises the ObjectChanged event on the current (!not the top level!) object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void OnObjectChanged(
    string customEvent
)
Visual Basic
Sub OnObjectChanged ( _
    customEvent As String _
)

Parameters

customEvent
Type: System..::..String
Custom change type name.

See Also

IGH_DocumentObject Interface
OnObjectChanged Overload
Grasshopper.Kernel Namespace


OnObjectChanged Method (GH_ObjectChangedEventArgs)

[image]

Grasshopper SDK
IGH_DocumentObject..::..OnObjectChanged Method (GH_ObjectChangedEventArgs)
IGH_DocumentObject Interface See Also Send Feedback
Raises the ObjectChanged event on the current (!not the top level!) object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void OnObjectChanged(
    GH_ObjectChangedEventArgs e
)
Visual Basic
Sub OnObjectChanged ( _
    e As GH_ObjectChangedEventArgs _
)

Parameters

e
Type: Grasshopper.Kernel..::..GH_ObjectChangedEventArgs
Fully constructed event arguments.

See Also

IGH_DocumentObject Interface
OnObjectChanged Overload
Grasshopper.Kernel Namespace


OnObjectChanged Method (GH_ObjectEventType)

[image]

Grasshopper SDK
IGH_DocumentObject..::..OnObjectChanged Method (GH_ObjectEventType)
IGH_DocumentObject Interface See Also Send Feedback
Raises the ObjectChanged event on the current (!not the top level!) object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void OnObjectChanged(
    GH_ObjectEventType eventType
)
Visual Basic
Sub OnObjectChanged ( _
    eventType As GH_ObjectEventType _
)

Parameters

eventType
Type: Grasshopper.Kernel..::..GH_ObjectEventType
Type of change.

See Also

IGH_DocumentObject Interface
OnObjectChanged Overload
Grasshopper.Kernel Namespace


OnObjectChanged Method (String, Object)

[image]

Grasshopper SDK
IGH_DocumentObject..::..OnObjectChanged Method (String, Object)
IGH_DocumentObject Interface See Also Send Feedback
Raises the ObjectChanged event on the current (!not the top level!) object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void OnObjectChanged(
    string customEvent,
    Object tag
)
Visual Basic
Sub OnObjectChanged ( _
    customEvent As String, _
    tag As Object _
)

Parameters

customEvent
Type: System..::..String
Custom change type name.
tag
Type: System..::..Object
Tag to apply to the event arguments.

See Also

IGH_DocumentObject Interface
OnObjectChanged Overload
Grasshopper.Kernel Namespace


OnObjectChanged Method (GH_ObjectEventType, Object)

[image]

Grasshopper SDK
IGH_DocumentObject..::..OnObjectChanged Method (GH_ObjectEventType, Object)
IGH_DocumentObject Interface See Also Send Feedback
Raises the ObjectChanged event on the current (!not the top level!) object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void OnObjectChanged(
    GH_ObjectEventType eventType,
    Object tag
)
Visual Basic
Sub OnObjectChanged ( _
    eventType As GH_ObjectEventType, _
    tag As Object _
)

Parameters

eventType
Type: Grasshopper.Kernel..::..GH_ObjectEventType
Type of change.
tag
Type: System..::..Object
Tag to apply to the event arguments.

See Also

IGH_DocumentObject Interface
OnObjectChanged Overload
Grasshopper.Kernel Namespace


OnPingDocument Method

[image]

Grasshopper SDK
IGH_DocumentObject..::..OnPingDocument Method
IGH_DocumentObject Interface See Also Send Feedback
Raise the PingDocument Event on the toplevel object and try to find the document which owns this object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
GH_Document OnPingDocument()
Visual Basic
Function OnPingDocument As GH_Document

Return Value

The document which owns this object if successful, or nothing if no document owns this object.

See Also

IGH_DocumentObject Interface
Grasshopper.Kernel Namespace


OnPreviewExpired Method

[image]

Grasshopper SDK
IGH_DocumentObject..::..OnPreviewExpired Method
IGH_DocumentObject Interface See Also Send Feedback
Raises the PreviewExpired event on the toplevel object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void OnPreviewExpired(
    bool redraw
)
Visual Basic
Sub OnPreviewExpired ( _
    redraw As Boolean _
)

Parameters

redraw
Type: System..::..Boolean
If True, the viewports will be immediately redrawn.

See Also

IGH_DocumentObject Interface
Grasshopper.Kernel Namespace


OnSolutionExpired Method

[image]

Grasshopper SDK
IGH_DocumentObject..::..OnSolutionExpired Method
IGH_DocumentObject Interface See Also Send Feedback
Raises the SolutionExpired event on the toplevel object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void OnSolutionExpired(
    bool recompute
)
Visual Basic
Sub OnSolutionExpired ( _
    recompute As Boolean _
)

Parameters

recompute
Type: System..::..Boolean
If True, the solution will be immediately recalculated.

See Also

IGH_DocumentObject Interface
Grasshopper.Kernel Namespace


RecordUndoEvent Method

[image] [image]

Grasshopper SDK
IGH_DocumentObject..::..RecordUndoEvent Method
IGH_DocumentObject Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | RecordUndoEvent(String) | Record a generic object change undo event.
Public method | RecordUndoEvent(GH_UndoRecord) | Record an entire undo record.
Public method | RecordUndoEvent(String, IGH_UndoAction) | Record a specific object change undo event.

See Also

IGH_DocumentObject Interface
IGH_DocumentObject Members
Grasshopper.Kernel Namespace


RecordUndoEvent Method (String)

[image]

Grasshopper SDK
IGH_DocumentObject..::..RecordUndoEvent Method (String)
IGH_DocumentObject Interface See Also Send Feedback
Record a generic object change undo event.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
Guid RecordUndoEvent(
    string name
)
Visual Basic
Function RecordUndoEvent ( _
    name As String _
) As Guid

Parameters

name
Type: System..::..String
Name of undo record.

See Also

IGH_DocumentObject Interface
RecordUndoEvent Overload
Grasshopper.Kernel Namespace


RecordUndoEvent Method (GH_UndoRecord)

[image]

Grasshopper SDK
IGH_DocumentObject..::..RecordUndoEvent Method (GH_UndoRecord)
IGH_DocumentObject Interface See Also Send Feedback
Record an entire undo record.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void RecordUndoEvent(
    GH_UndoRecord record
)
Visual Basic
Sub RecordUndoEvent ( _
    record As GH_UndoRecord _
)

Parameters

record
Type: Grasshopper.Kernel.Undo..::..GH_UndoRecord
Record to push.

See Also

IGH_DocumentObject Interface
RecordUndoEvent Overload
Grasshopper.Kernel Namespace


RecordUndoEvent Method (String, IGH_UndoAction)

[image]

Grasshopper SDK
IGH_DocumentObject..::..RecordUndoEvent Method (String, IGH_UndoAction)
IGH_DocumentObject Interface See Also Send Feedback
Record a specific object change undo event.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
Guid RecordUndoEvent(
    string name,
    IGH_UndoAction action
)
Visual Basic
Function RecordUndoEvent ( _
    name As String, _
    action As IGH_UndoAction _
) As Guid

Parameters

name
Type: System..::..String
Name of undo record.
action
Type: Grasshopper.Kernel.Undo..::..IGH_UndoAction
Undo action to record.

See Also

IGH_DocumentObject Interface
RecordUndoEvent Overload
Grasshopper.Kernel Namespace


RemovedFromDocument Method

[image]

Grasshopper SDK
IGH_DocumentObject..::..RemovedFromDocument Method
IGH_DocumentObject Interface See Also Send Feedback
This method will be called when an object is removed from a document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void RemovedFromDocument(
    GH_Document document
)
Visual Basic
Sub RemovedFromDocument ( _
    document As GH_Document _
)

Parameters

document
Type: Grasshopper.Kernel..::..GH_Document
Document that now no longer owns this object.

See Also

IGH_DocumentObject Interface
Grasshopper.Kernel Namespace


TriggerAutoSave Method

[image] [image]

Grasshopper SDK
IGH_DocumentObject..::..TriggerAutoSave Method
IGH_DocumentObject Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | TriggerAutoSave()()()() | Triggers the AutoSave function on the owner document with the object_changed flag.
Public method | TriggerAutoSave(Guid) | Triggers the AutoSave function on the owner document with the object_changed flag.
Public method | TriggerAutoSave(GH_AutoSaveTrigger) | Triggers the AutoSave function on the owner document with a custom flag.
Public method | TriggerAutoSave(GH_AutoSaveTrigger, Guid) | Triggers the AutoSave function on the owner document with a custom flag.

See Also

IGH_DocumentObject Interface
IGH_DocumentObject Members
Grasshopper.Kernel Namespace


TriggerAutoSave Method

[image]

Grasshopper SDK
IGH_DocumentObject..::..TriggerAutoSave Method
IGH_DocumentObject Interface See Also Send Feedback
Triggers the AutoSave function on the owner document with the object_changed flag.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void TriggerAutoSave()
Visual Basic
Sub TriggerAutoSave

See Also

IGH_DocumentObject Interface
TriggerAutoSave Overload
Grasshopper.Kernel Namespace


TriggerAutoSave Method (Guid)

[image]

Grasshopper SDK
IGH_DocumentObject..::..TriggerAutoSave Method (Guid)
IGH_DocumentObject Interface See Also Send Feedback
Triggers the AutoSave function on the owner document with the object_changed flag.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void TriggerAutoSave(
    Guid id
)
Visual Basic
Sub TriggerAutoSave ( _
    id As Guid _
)

Parameters

id
Type: System..::..Guid
ID of autosave event. Consecutive autosave requests with the same ID will be ignored.

See Also

IGH_DocumentObject Interface
TriggerAutoSave Overload
Grasshopper.Kernel Namespace


TriggerAutoSave Method (GH_AutoSaveTrigger)

[image]

Grasshopper SDK
IGH_DocumentObject..::..TriggerAutoSave Method (GH_AutoSaveTrigger)
IGH_DocumentObject Interface See Also Send Feedback
Triggers the AutoSave function on the owner document with a custom flag.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void TriggerAutoSave(
    GH_AutoSaveTrigger trigger
)
Visual Basic
Sub TriggerAutoSave ( _
    trigger As GH_AutoSaveTrigger _
)

Parameters

trigger
Type: Grasshopper.Kernel..::..GH_AutoSaveTrigger
Reason for the autosave operation. It is possible that a user has decided to avoid autosave events for specific types, so if you can, try and provide a correct trigger flag.

See Also

IGH_DocumentObject Interface
TriggerAutoSave Overload
Grasshopper.Kernel Namespace


TriggerAutoSave Method (GH_AutoSaveTrigger, Guid)

[image]

Grasshopper SDK
IGH_DocumentObject..::..TriggerAutoSave Method (GH_AutoSaveTrigger, Guid)
IGH_DocumentObject Interface See Also Send Feedback
Triggers the AutoSave function on the owner document with a custom flag.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void TriggerAutoSave(
    GH_AutoSaveTrigger trigger,
    Guid id
)
Visual Basic
Sub TriggerAutoSave ( _
    trigger As GH_AutoSaveTrigger, _
    id As Guid _
)

Parameters

trigger
Type: Grasshopper.Kernel..::..GH_AutoSaveTrigger
Reason for the autosave operation. It is possible that a user has decided to avoid autosave events for specific types, so if you can, try and provide a correct trigger flag.
id
Type: System..::..Guid
ID of autosave event. Consecutive autosave requests with the same ID will be ignored.

See Also

IGH_DocumentObject Interface
TriggerAutoSave Overload
Grasshopper.Kernel Namespace


IGH_DocumentObject Properties

[image] [image]

Grasshopper SDK
IGH_DocumentObject Properties
IGH_DocumentObject Interface See Also Send Feedback

The IGH_DocumentObject type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Gets or sets the attributes that are associated with this object. Only set custom attributes if you know what you are doing.
Public property | Category | Gets or sets the Category in which this object belongs. If HasCategory() returns false, this field has no meaning. (Inherited from IGH_InstanceDescription.)
Public property | ComponentGuid | Returns a consistent ID for this object type. Every object must supply a unique and unchanging ID that is used to identify objects of the same type.
Public property | Description | Gets or sets the description of the object. This field typically remains fixed during the lifetime of an object. (Inherited from IGH_InstanceDescription.)
Public property | Exposure | Gets the exposure of this object in the Graphical User Interface.
Public property | HasCategory | Gets whether or not the Category field has been set. (Inherited from IGH_InstanceDescription.)
Public property | HasSubCategory | Gets whether or not the SubCategory field has been set. (Inherited from IGH_InstanceDescription.)
Public property | Icon_24x24 | The icon associated with this object.
Public property | Icon_24x24_Locked | The greyscale icon of this object.
Public property | IconDisplayMode | Gets the current display mode of the object.
Public property | InstanceDescription | Gets a description of the current state of the object. This field is usually the same as the Description() field, but it might be variable when overridden. (Inherited from IGH_InstanceDescription.)
Public property | InstanceGuid | Gets the ID of this runtime instance. (Inherited from IGH_InstanceDescription.)
Public property | Keywords | Gets a list of additional keywords that describe the object. Typically this list is empty but you can override this property to aid in object searches. (Inherited from IGH_InstanceDescription.)
Public property | Name | Gets or sets the name of the object. This field typically remains fixed during the lifetime of an object. (Inherited from IGH_InstanceDescription.)
Public property | NickName | Gets or sets the nickname of the object. This field can be changed by the user. (Inherited from IGH_InstanceDescription.)
Public property | Obsolete | Gets whether this object is Obsolete.
Public property | SubCategory | Gets or sets the SubCategory in which this object belongs. If HasSubCategory() returns false, this field has no meaning. (Inherited from IGH_InstanceDescription.)

See Also

IGH_DocumentObject Interface
Grasshopper.Kernel Namespace


Attributes Property

[image]

Grasshopper SDK
IGH_DocumentObject..::..Attributes Property
IGH_DocumentObject Interface See Also Send Feedback
Gets or sets the attributes that are associated with this object. Only set custom attributes if you know what you are doing.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
IGH_Attributes Attributes { get; set; }
Visual Basic
Property Attributes As IGH_Attributes
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_DocumentObject.Attributes"]

See Also

IGH_DocumentObject Interface
Grasshopper.Kernel Namespace


ComponentGuid Property

[image]

Grasshopper SDK
IGH_DocumentObject..::..ComponentGuid Property
IGH_DocumentObject Interface See Also Send Feedback
Returns a consistent ID for this object type. Every object must supply a unique and unchanging ID that is used to identify objects of the same type.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
Guid ComponentGuid { get; }
Visual Basic
ReadOnly Property ComponentGuid As Guid
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_DocumentObject.ComponentGuid"]

See Also

IGH_DocumentObject Interface
Grasshopper.Kernel Namespace


Exposure Property

[image]

Grasshopper SDK
IGH_DocumentObject..::..Exposure Property
IGH_DocumentObject Interface See Also Send Feedback
Gets the exposure of this object in the Graphical User Interface.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
GH_Exposure Exposure { get; }
Visual Basic
ReadOnly Property Exposure As GH_Exposure
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_DocumentObject.Exposure"]

See Also

IGH_DocumentObject Interface
Grasshopper.Kernel Namespace


Icon_24x24 Property

[image]

Grasshopper SDK
IGH_DocumentObject..::..Icon_24x24 Property
IGH_DocumentObject Interface See Also Send Feedback
The icon associated with this object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
Bitmap Icon_24x24 { get; }
Visual Basic
ReadOnly Property Icon_24x24 As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_DocumentObject.Icon_24x24"]

See Also

IGH_DocumentObject Interface
Grasshopper.Kernel Namespace


Icon_24x24_Locked Property

[image]

Grasshopper SDK
IGH_DocumentObject..::..Icon_24x24_Locked Property
IGH_DocumentObject Interface See Also Send Feedback
The greyscale icon of this object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
Bitmap Icon_24x24_Locked { get; }
Visual Basic
ReadOnly Property Icon_24x24_Locked As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_DocumentObject.Icon_24x24_Locked"]

See Also

IGH_DocumentObject Interface
Grasshopper.Kernel Namespace


IconDisplayMode Property

[image]

Grasshopper SDK
IGH_DocumentObject..::..IconDisplayMode Property
IGH_DocumentObject Interface See Also Send Feedback
Gets the current display mode of the object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
GH_IconDisplayMode IconDisplayMode { get; set; }
Visual Basic
Property IconDisplayMode As GH_IconDisplayMode
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_DocumentObject.IconDisplayMode"]

See Also

IGH_DocumentObject Interface
Grasshopper.Kernel Namespace


Obsolete Property

[image]

Grasshopper SDK
IGH_DocumentObject..::..Obsolete Property
IGH_DocumentObject Interface See Also Send Feedback
Gets whether this object is Obsolete.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool Obsolete { get; }
Visual Basic
ReadOnly Property Obsolete As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_DocumentObject.Obsolete"]

See Also

IGH_DocumentObject Interface
Grasshopper.Kernel Namespace


IGH_DocumentObject Events

[image] [image]

Grasshopper SDK
IGH_DocumentObject Events
IGH_DocumentObject Interface See Also Send Feedback

The IGH_DocumentObject type exposes the following members.

Events

 | Name | Description
Public event | AttributesChanged | Raised whenever the number or kind of attributes changes. This event is handled by GH_Documents who subsequently wipe their attribute caches.
Public event | DisplayExpired | Raised whenever the display (on the Canvas) of a certain object becomes invalid.
Public event | ObjectChanged | Raised whenever some property of the object changes that would affect remote instances.
Public event | PingDocument | Raised whenever an object needs to know which GH_Document it belongs to.
Public event | PreviewExpired | Raised whenever the display (in the Rhino viewports) of a certain object becomes invalid.
Public event | SolutionExpired | Raised whenever the solution of a certain object becomes invalid.

See Also

IGH_DocumentObject Interface
Grasshopper.Kernel Namespace


AttributesChanged Event

[image]

Grasshopper SDK
IGH_DocumentObject..::..AttributesChanged Event
IGH_DocumentObject Interface See Also Send Feedback
Raised whenever the number or kind of attributes changes. This event is handled by GH_Documents who subsequently wipe their attribute caches.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
event IGH_DocumentObject..::..AttributesChangedEventHandler AttributesChanged
Visual Basic
Event AttributesChanged As IGH_DocumentObject..::..AttributesChangedEventHandler

See Also

IGH_DocumentObject Interface
Grasshopper.Kernel Namespace


DisplayExpired Event

[image]

Grasshopper SDK
IGH_DocumentObject..::..DisplayExpired Event
IGH_DocumentObject Interface See Also Send Feedback
Raised whenever the display (on the Canvas) of a certain object becomes invalid.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
event IGH_DocumentObject..::..DisplayExpiredEventHandler DisplayExpired
Visual Basic
Event DisplayExpired As IGH_DocumentObject..::..DisplayExpiredEventHandler

See Also

IGH_DocumentObject Interface
Grasshopper.Kernel Namespace


ObjectChanged Event

[image]

Grasshopper SDK
IGH_DocumentObject..::..ObjectChanged Event
IGH_DocumentObject Interface See Also Send Feedback
Raised whenever some property of the object changes that would affect remote instances.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
event IGH_DocumentObject..::..ObjectChangedEventHandler ObjectChanged
Visual Basic
Event ObjectChanged As IGH_DocumentObject..::..ObjectChangedEventHandler

See Also

IGH_DocumentObject Interface
Grasshopper.Kernel Namespace


PingDocument Event

[image]

Grasshopper SDK
IGH_DocumentObject..::..PingDocument Event
IGH_DocumentObject Interface See Also Send Feedback
Raised whenever an object needs to know which GH_Document it belongs to.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
event IGH_DocumentObject..::..PingDocumentEventHandler PingDocument
Visual Basic
Event PingDocument As IGH_DocumentObject..::..PingDocumentEventHandler

See Also

IGH_DocumentObject Interface
Grasshopper.Kernel Namespace


PreviewExpired Event

[image]

Grasshopper SDK
IGH_DocumentObject..::..PreviewExpired Event
IGH_DocumentObject Interface See Also Send Feedback
Raised whenever the display (in the Rhino viewports) of a certain object becomes invalid.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
event IGH_DocumentObject..::..PreviewExpiredEventHandler PreviewExpired
Visual Basic
Event PreviewExpired As IGH_DocumentObject..::..PreviewExpiredEventHandler

See Also

IGH_DocumentObject Interface
Grasshopper.Kernel Namespace


SolutionExpired Event

[image]

Grasshopper SDK
IGH_DocumentObject..::..SolutionExpired Event
IGH_DocumentObject Interface See Also Send Feedback
Raised whenever the solution of a certain object becomes invalid.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
event IGH_DocumentObject..::..SolutionExpiredEventHandler SolutionExpired
Visual Basic
Event SolutionExpired As IGH_DocumentObject..::..SolutionExpiredEventHandler

See Also

IGH_DocumentObject Interface
Grasshopper.Kernel Namespace


IGH_DocumentObject.AttributesChangedEventHandler Delegate

[image]

Grasshopper SDK
IGH_DocumentObject..::..AttributesChangedEventHandler Delegate
IGH_DocumentObject Interface See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void AttributesChangedEventHandler(
    IGH_DocumentObject sender,
    GH_AttributesChangedEventArgs e
)
Visual Basic
Public Delegate Sub AttributesChangedEventHandler ( _
    sender As IGH_DocumentObject, _
    e As GH_AttributesChangedEventArgs _
)

Parameters

sender
Type: Grasshopper.Kernel..::..IGH_DocumentObject
e
Type: Grasshopper.Kernel..::..GH_AttributesChangedEventArgs

See Also

Grasshopper.Kernel Namespace


IGH_DocumentObject.DisplayExpiredEventHandler Delegate

[image]

Grasshopper SDK
IGH_DocumentObject..::..DisplayExpiredEventHandler Delegate
IGH_DocumentObject Interface See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void DisplayExpiredEventHandler(
    IGH_DocumentObject sender,
    GH_DisplayExpiredEventArgs e
)
Visual Basic
Public Delegate Sub DisplayExpiredEventHandler ( _
    sender As IGH_DocumentObject, _
    e As GH_DisplayExpiredEventArgs _
)

Parameters

sender
Type: Grasshopper.Kernel..::..IGH_DocumentObject
e
Type: Grasshopper.Kernel..::..GH_DisplayExpiredEventArgs

See Also

Grasshopper.Kernel Namespace


IGH_DocumentObject.ObjectChangedEventHandler Delegate

[image]

Grasshopper SDK
IGH_DocumentObject..::..ObjectChangedEventHandler Delegate
IGH_DocumentObject Interface See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void ObjectChangedEventHandler(
    IGH_DocumentObject sender,
    GH_ObjectChangedEventArgs e
)
Visual Basic
Public Delegate Sub ObjectChangedEventHandler ( _
    sender As IGH_DocumentObject, _
    e As GH_ObjectChangedEventArgs _
)

Parameters

sender
Type: Grasshopper.Kernel..::..IGH_DocumentObject
e
Type: Grasshopper.Kernel..::..GH_ObjectChangedEventArgs

See Also

Grasshopper.Kernel Namespace


IGH_DocumentObject.PingDocumentEventHandler Delegate

[image]

Grasshopper SDK
IGH_DocumentObject..::..PingDocumentEventHandler Delegate
IGH_DocumentObject Interface See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void PingDocumentEventHandler(
    IGH_DocumentObject sender,
    GH_PingDocumentEventArgs e
)
Visual Basic
Public Delegate Sub PingDocumentEventHandler ( _
    sender As IGH_DocumentObject, _
    e As GH_PingDocumentEventArgs _
)

Parameters

sender
Type: Grasshopper.Kernel..::..IGH_DocumentObject
e
Type: Grasshopper.Kernel..::..GH_PingDocumentEventArgs

See Also

Grasshopper.Kernel Namespace


IGH_DocumentObject.PreviewExpiredEventHandler Delegate

[image]

Grasshopper SDK
IGH_DocumentObject..::..PreviewExpiredEventHandler Delegate
IGH_DocumentObject Interface See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void PreviewExpiredEventHandler(
    IGH_DocumentObject sender,
    GH_PreviewExpiredEventArgs e
)
Visual Basic
Public Delegate Sub PreviewExpiredEventHandler ( _
    sender As IGH_DocumentObject, _
    e As GH_PreviewExpiredEventArgs _
)

Parameters

sender
Type: Grasshopper.Kernel..::..IGH_DocumentObject
e
Type: Grasshopper.Kernel..::..GH_PreviewExpiredEventArgs

See Also

Grasshopper.Kernel Namespace


IGH_DocumentObject.SolutionExpiredEventHandler Delegate

[image]

Grasshopper SDK
IGH_DocumentObject..::..SolutionExpiredEventHandler Delegate
IGH_DocumentObject Interface See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void SolutionExpiredEventHandler(
    IGH_DocumentObject sender,
    GH_SolutionExpiredEventArgs e
)
Visual Basic
Public Delegate Sub SolutionExpiredEventHandler ( _
    sender As IGH_DocumentObject, _
    e As GH_SolutionExpiredEventArgs _
)

Parameters

sender
Type: Grasshopper.Kernel..::..IGH_DocumentObject
e
Type: Grasshopper.Kernel..::..GH_SolutionExpiredEventArgs

See Also

Grasshopper.Kernel Namespace


IGH_DocumentOwner Interface

[image]

Grasshopper SDK
IGH_DocumentOwner Interface
Members See Also Send Feedback
Implement this interface if you want to be the owner assigned to a document in the Grasshopper documentserver.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_DocumentOwner
Visual Basic
Public Interface IGH_DocumentOwner

See Also

IGH_DocumentOwner Members
Grasshopper.Kernel Namespace


IGH_DocumentOwner Members

[image] [image]

Grasshopper SDK
IGH_DocumentOwner Members
IGH_DocumentOwner Interface Methods See Also Send Feedback

The IGH_DocumentOwner type exposes the following members.

Methods

 | Name | Description
Public method | DocumentClosed | This method will be called whenever the owner document was closed.
Public method | DocumentModified | This method will be called whenever the owned document is modified.
Public method | OwnerDocument | If the IGH_DocumentOwner is part of a GH_Document of its own, this function will return that document.

See Also

IGH_DocumentOwner Interface
Grasshopper.Kernel Namespace


IGH_DocumentOwner Methods

[image] [image]

Grasshopper SDK
IGH_DocumentOwner Methods
IGH_DocumentOwner Interface See Also Send Feedback

The IGH_DocumentOwner type exposes the following members.

Methods

 | Name | Description
Public method | DocumentClosed | This method will be called whenever the owner document was closed.
Public method | DocumentModified | This method will be called whenever the owned document is modified.
Public method | OwnerDocument | If the IGH_DocumentOwner is part of a GH_Document of its own, this function will return that document.

See Also

IGH_DocumentOwner Interface
Grasshopper.Kernel Namespace


DocumentClosed Method

[image]

Grasshopper SDK
IGH_DocumentOwner..::..DocumentClosed Method
IGH_DocumentOwner Interface See Also Send Feedback
This method will be called whenever the owner document was closed.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void DocumentClosed(
    GH_Document document
)
Visual Basic
Sub DocumentClosed ( _
    document As GH_Document _
)

Parameters

document
Type: Grasshopper.Kernel..::..GH_Document
the closed docment.

See Also

IGH_DocumentOwner Interface
Grasshopper.Kernel Namespace


DocumentModified Method

[image]

Grasshopper SDK
IGH_DocumentOwner..::..DocumentModified Method
IGH_DocumentOwner Interface See Also Send Feedback
This method will be called whenever the owned document is modified.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void DocumentModified(
    GH_Document document
)
Visual Basic
Sub DocumentModified ( _
    document As GH_Document _
)

Parameters

document
Type: Grasshopper.Kernel..::..GH_Document
The modified document.

See Also

IGH_DocumentOwner Interface
Grasshopper.Kernel Namespace


OwnerDocument Method

[image]

Grasshopper SDK
IGH_DocumentOwner..::..OwnerDocument Method
IGH_DocumentOwner Interface See Also Send Feedback
If the IGH_DocumentOwner is part of a GH_Document of its own, this function will return that document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
GH_Document OwnerDocument()
Visual Basic
Function OwnerDocument As GH_Document

See Also

IGH_DocumentOwner Interface
Grasshopper.Kernel Namespace


IGH_EventConsumer Interface

[image]

Grasshopper SDK
IGH_EventConsumer Interface
Members See Also Send Feedback
Implement this interface if you want to inter-operate with a GH_EventServer.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_EventConsumer
Visual Basic
Public Interface IGH_EventConsumer

See Also

IGH_EventConsumer Members
Grasshopper.Kernel Namespace


IGH_EventConsumer Members

[image] [image]

Grasshopper SDK
IGH_EventConsumer Members
IGH_EventConsumer Interface Methods See Also Send Feedback

The IGH_EventConsumer type exposes the following members.

Methods

 | Name | Description
Public method | IsRelevantEvent | Whenever a new object event is handled, this function will be called to determine whether it will cause an update.
Public method | PartialExpiration | This method will be called by the GH_CustomEventServer to indicate one or more interesting object events can now be processed.
Public method | TotalExpiration | This method will be called by the GH_CustomEventServer to indicate all interesting object events can now be processed.

See Also

IGH_EventConsumer Interface
Grasshopper.Kernel Namespace


IGH_EventConsumer Methods

[image] [image]

Grasshopper SDK
IGH_EventConsumer Methods
IGH_EventConsumer Interface See Also Send Feedback

The IGH_EventConsumer type exposes the following members.

Methods

 | Name | Description
Public method | IsRelevantEvent | Whenever a new object event is handled, this function will be called to determine whether it will cause an update.
Public method | PartialExpiration | This method will be called by the GH_CustomEventServer to indicate one or more interesting object events can now be processed.
Public method | TotalExpiration | This method will be called by the GH_CustomEventServer to indicate all interesting object events can now be processed.

See Also

IGH_EventConsumer Interface
Grasshopper.Kernel Namespace


IsRelevantEvent Method

[image]

Grasshopper SDK
IGH_EventConsumer..::..IsRelevantEvent Method
IGH_EventConsumer Interface See Also Send Feedback
Whenever a new object event is handled, this function will be called to determine whether it will cause an update.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool IsRelevantEvent(
    RhinoObject obj
)
Visual Basic
Function IsRelevantEvent ( _
    obj As RhinoObject _
) As Boolean

Parameters

obj
Type: RhinoObject
Object that is the pivot of the event.

Return Value

True if the object should cause an update, false if not.

See Also

IGH_EventConsumer Interface
Grasshopper.Kernel Namespace


PartialExpiration Method

[image]

Grasshopper SDK
IGH_EventConsumer..::..PartialExpiration Method
IGH_EventConsumer Interface See Also Send Feedback
This method will be called by the GH_CustomEventServer to indicate one or more interesting object events can now be processed.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void PartialExpiration(
    GH_CustomEventServer server
)
Visual Basic
Sub PartialExpiration ( _
    server As GH_CustomEventServer _
)

Parameters

server
Type: Grasshopper.Kernel..::..GH_CustomEventServer
Server that called this method.

See Also

IGH_EventConsumer Interface
Grasshopper.Kernel Namespace


TotalExpiration Method

[image]

Grasshopper SDK
IGH_EventConsumer..::..TotalExpiration Method
IGH_EventConsumer Interface See Also Send Feedback
This method will be called by the GH_CustomEventServer to indicate all interesting object events can now be processed.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void TotalExpiration(
    GH_CustomEventServer server
)
Visual Basic
Sub TotalExpiration ( _
    server As GH_CustomEventServer _
)

Parameters

server
Type: Grasshopper.Kernel..::..GH_CustomEventServer
Server that called this method.

See Also

IGH_EventConsumer Interface
Grasshopper.Kernel Namespace


IGH_InitCodeAware Interface

[image]

Grasshopper SDK
IGH_InitCodeAware Interface
Members See Also Send Feedback
Implement this interface in your IGH_DocumentObject class if you want to handle initialization codes from Canvas Search boxes.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_InitCodeAware
Visual Basic
Public Interface IGH_InitCodeAware

See Also

IGH_InitCodeAware Members
Grasshopper.Kernel Namespace


IGH_InitCodeAware Members

[image] [image]

Grasshopper SDK
IGH_InitCodeAware Members
IGH_InitCodeAware Interface Methods See Also Send Feedback

The IGH_InitCodeAware type exposes the following members.

Methods

 | Name | Description
Public method | SetInitCode | This method will be called when the user inserts an object via the Canvas Search popup and supplies an "=XXXX" string init code. Do not throw exceptions in this method! Either handle the code correctly or ignore it.

See Also

IGH_InitCodeAware Interface
Grasshopper.Kernel Namespace


IGH_InitCodeAware Methods

[image] [image]

Grasshopper SDK
IGH_InitCodeAware Methods
IGH_InitCodeAware Interface See Also Send Feedback

The IGH_InitCodeAware type exposes the following members.

Methods

 | Name | Description
Public method | SetInitCode | This method will be called when the user inserts an object via the Canvas Search popup and supplies an "=XXXX" string init code. Do not throw exceptions in this method! Either handle the code correctly or ignore it.

See Also

IGH_InitCodeAware Interface
Grasshopper.Kernel Namespace


SetInitCode Method

[image]

Grasshopper SDK
IGH_InitCodeAware..::..SetInitCode Method
IGH_InitCodeAware Interface See Also Send Feedback
This method will be called when the user inserts an object via the Canvas Search popup and supplies an "=XXXX" string init code. Do not throw exceptions in this method! Either handle the code correctly or ignore it.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void SetInitCode(
    string code
)
Visual Basic
Sub SetInitCode ( _
    code As String _
)

Parameters

code
Type: System..::..String
The portion after the first "=" symbol.

See Also

IGH_InitCodeAware Interface
Grasshopper.Kernel Namespace


IGH_InstanceDescription Interface

[image]

Grasshopper SDK
IGH_InstanceDescription Interface
Members See Also Send Feedback
Base interface for all objects that participate in the Grasshopper GUI.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_InstanceDescription : GH_ISerializable
Visual Basic
Public Interface IGH_InstanceDescription _
    Inherits GH_ISerializable

Remarks

See Also

IGH_InstanceDescription Members
Grasshopper.Kernel Namespace


IGH_InstanceDescription Members

[image] [image]

Grasshopper SDK
IGH_InstanceDescription Members
IGH_InstanceDescription Interface Methods Properties See Also Send Feedback

The IGH_InstanceDescription type exposes the following members.

Methods

 | Name | Description
Public method | NewInstanceGuid()()()() | Generate a new random instance GUID
Public method | NewInstanceGuid(Guid) | Set the instance ID to be a specific GUID. This is very dangerous, only use this function if you're 6"4' and called David.
Public method | Read | This method is called whenever the instance is required to deserialize itself. (Inherited from GH_ISerializable.)
Public method | Write | This method is called whenever the instance is required to serialize itself. (Inherited from GH_ISerializable.)

Properties

 | Name | Description
Public property | Category | Gets or sets the Category in which this object belongs. If HasCategory() returns false, this field has no meaning.
Public property | Description | Gets or sets the description of the object. This field typically remains fixed during the lifetime of an object.
Public property | HasCategory | Gets whether or not the Category field has been set.
Public property | HasSubCategory | Gets whether or not the SubCategory field has been set.
Public property | InstanceDescription | Gets a description of the current state of the object. This field is usually the same as the Description() field, but it might be variable when overridden.
Public property | InstanceGuid | Gets the ID of this runtime instance.
Public property | Keywords | Gets a list of additional keywords that describe the object. Typically this list is empty but you can override this property to aid in object searches.
Public property | Name | Gets or sets the name of the object. This field typically remains fixed during the lifetime of an object.
Public property | NickName | Gets or sets the nickname of the object. This field can be changed by the user.
Public property | SubCategory | Gets or sets the SubCategory in which this object belongs. If HasSubCategory() returns false, this field has no meaning.

See Also

IGH_InstanceDescription Interface
Grasshopper.Kernel Namespace


IGH_InstanceDescription Methods

[image] [image]

Grasshopper SDK
IGH_InstanceDescription Methods
IGH_InstanceDescription Interface See Also Send Feedback

The IGH_InstanceDescription type exposes the following members.

Methods

 | Name | Description
Public method | NewInstanceGuid()()()() | Generate a new random instance GUID
Public method | NewInstanceGuid(Guid) | Set the instance ID to be a specific GUID. This is very dangerous, only use this function if you're 6"4' and called David.
Public method | Read | This method is called whenever the instance is required to deserialize itself. (Inherited from GH_ISerializable.)
Public method | Write | This method is called whenever the instance is required to serialize itself. (Inherited from GH_ISerializable.)

See Also

IGH_InstanceDescription Interface
Grasshopper.Kernel Namespace


NewInstanceGuid Method

[image] [image]

Grasshopper SDK
IGH_InstanceDescription..::..NewInstanceGuid Method
IGH_InstanceDescription Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | NewInstanceGuid()()()() | Generate a new random instance GUID
Public method | NewInstanceGuid(Guid) | Set the instance ID to be a specific GUID. This is very dangerous, only use this function if you're 6"4' and called David.

See Also

IGH_InstanceDescription Interface
IGH_InstanceDescription Members
Grasshopper.Kernel Namespace


NewInstanceGuid Method

[image]

Grasshopper SDK
IGH_InstanceDescription..::..NewInstanceGuid Method
IGH_InstanceDescription Interface See Also Send Feedback
Generate a new random instance GUID

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void NewInstanceGuid()
Visual Basic
Sub NewInstanceGuid

See Also

IGH_InstanceDescription Interface
NewInstanceGuid Overload
Grasshopper.Kernel Namespace


NewInstanceGuid Method (Guid)

[image]

Grasshopper SDK
IGH_InstanceDescription..::..NewInstanceGuid Method (Guid)
IGH_InstanceDescription Interface See Also Send Feedback
Set the instance ID to be a specific GUID. This is very dangerous, only use this function if you're 6"4' and called David.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void NewInstanceGuid(
    Guid UUID
)
Visual Basic
Sub NewInstanceGuid ( _
    UUID As Guid _
)

Parameters

UUID
Type: System..::..Guid

See Also

IGH_InstanceDescription Interface
NewInstanceGuid Overload
Grasshopper.Kernel Namespace


IGH_InstanceDescription Properties

[image] [image]

Grasshopper SDK
IGH_InstanceDescription Properties
IGH_InstanceDescription Interface See Also Send Feedback

The IGH_InstanceDescription type exposes the following members.

Properties

 | Name | Description
Public property | Category | Gets or sets the Category in which this object belongs. If HasCategory() returns false, this field has no meaning.
Public property | Description | Gets or sets the description of the object. This field typically remains fixed during the lifetime of an object.
Public property | HasCategory | Gets whether or not the Category field has been set.
Public property | HasSubCategory | Gets whether or not the SubCategory field has been set.
Public property | InstanceDescription | Gets a description of the current state of the object. This field is usually the same as the Description() field, but it might be variable when overridden.
Public property | InstanceGuid | Gets the ID of this runtime instance.
Public property | Keywords | Gets a list of additional keywords that describe the object. Typically this list is empty but you can override this property to aid in object searches.
Public property | Name | Gets or sets the name of the object. This field typically remains fixed during the lifetime of an object.
Public property | NickName | Gets or sets the nickname of the object. This field can be changed by the user.
Public property | SubCategory | Gets or sets the SubCategory in which this object belongs. If HasSubCategory() returns false, this field has no meaning.

See Also

IGH_InstanceDescription Interface
Grasshopper.Kernel Namespace


Category Property

[image]

Grasshopper SDK
IGH_InstanceDescription..::..Category Property
IGH_InstanceDescription Interface See Also Send Feedback
Gets or sets the Category in which this object belongs. If HasCategory() returns false, this field has no meaning.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string Category { get; set; }
Visual Basic
Property Category As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_InstanceDescription.Category"]

See Also

IGH_InstanceDescription Interface
Grasshopper.Kernel Namespace


Description Property

[image]

Grasshopper SDK
IGH_InstanceDescription..::..Description Property
IGH_InstanceDescription Interface See Also Send Feedback
Gets or sets the description of the object. This field typically remains fixed during the lifetime of an object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string Description { get; set; }
Visual Basic
Property Description As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_InstanceDescription.Description"]

See Also

IGH_InstanceDescription Interface
Grasshopper.Kernel Namespace


HasCategory Property

[image]

Grasshopper SDK
IGH_InstanceDescription..::..HasCategory Property
IGH_InstanceDescription Interface See Also Send Feedback
Gets whether or not the Category field has been set.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool HasCategory { get; }
Visual Basic
ReadOnly Property HasCategory As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_InstanceDescription.HasCategory"]

See Also

IGH_InstanceDescription Interface
Grasshopper.Kernel Namespace


HasSubCategory Property

[image]

Grasshopper SDK
IGH_InstanceDescription..::..HasSubCategory Property
IGH_InstanceDescription Interface See Also Send Feedback
Gets whether or not the SubCategory field has been set.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool HasSubCategory { get; }
Visual Basic
ReadOnly Property HasSubCategory As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_InstanceDescription.HasSubCategory"]

See Also

IGH_InstanceDescription Interface
Grasshopper.Kernel Namespace


InstanceDescription Property

[image]

Grasshopper SDK
IGH_InstanceDescription..::..InstanceDescription Property
IGH_InstanceDescription Interface See Also Send Feedback
Gets a description of the current state of the object. This field is usually the same as the Description() field, but it might be variable when overridden.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string InstanceDescription { get; }
Visual Basic
ReadOnly Property InstanceDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_InstanceDescription.InstanceDescription"]

See Also

IGH_InstanceDescription Interface
Grasshopper.Kernel Namespace


InstanceGuid Property

[image]

Grasshopper SDK
IGH_InstanceDescription..::..InstanceGuid Property
IGH_InstanceDescription Interface See Also Send Feedback
Gets the ID of this runtime instance.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
Guid InstanceGuid { get; }
Visual Basic
ReadOnly Property InstanceGuid As Guid
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_InstanceDescription.InstanceGuid"]

See Also

IGH_InstanceDescription Interface
Grasshopper.Kernel Namespace


Keywords Property

[image]

Grasshopper SDK
IGH_InstanceDescription..::..Keywords Property
IGH_InstanceDescription Interface See Also Send Feedback
Gets a list of additional keywords that describe the object. Typically this list is empty but you can override this property to aid in object searches.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
IEnumerable<string> Keywords { get; }
Visual Basic
ReadOnly Property Keywords As IEnumerable(Of String)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_InstanceDescription.Keywords"]

See Also

IGH_InstanceDescription Interface
Grasshopper.Kernel Namespace


Name Property

[image]

Grasshopper SDK
IGH_InstanceDescription..::..Name Property
IGH_InstanceDescription Interface See Also Send Feedback
Gets or sets the name of the object. This field typically remains fixed during the lifetime of an object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string Name { get; set; }
Visual Basic
Property Name As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_InstanceDescription.Name"]

See Also

IGH_InstanceDescription Interface
Grasshopper.Kernel Namespace


NickName Property

[image]

Grasshopper SDK
IGH_InstanceDescription..::..NickName Property
IGH_InstanceDescription Interface See Also Send Feedback
Gets or sets the nickname of the object. This field can be changed by the user.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string NickName { get; set; }
Visual Basic
Property NickName As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_InstanceDescription.NickName"]

See Also

IGH_InstanceDescription Interface
Grasshopper.Kernel Namespace


SubCategory Property

[image]

Grasshopper SDK
IGH_InstanceDescription..::..SubCategory Property
IGH_InstanceDescription Interface See Also Send Feedback
Gets or sets the SubCategory in which this object belongs. If HasSubCategory() returns false, this field has no meaning.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string SubCategory { get; set; }
Visual Basic
Property SubCategory As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_InstanceDescription.SubCategory"]

See Also

IGH_InstanceDescription Interface
Grasshopper.Kernel Namespace


IGH_InstanceGuidDependent Interface

[image]

Grasshopper SDK
IGH_InstanceGuidDependent Interface
Members See Also Send Feedback
Implement this interface in your IGH_DocumentObject class if you want to be informed when the InstanceGuids of objects in the document are mutated.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_InstanceGuidDependent
Visual Basic
Public Interface IGH_InstanceGuidDependent

See Also

IGH_InstanceGuidDependent Members
Grasshopper.Kernel Namespace


IGH_InstanceGuidDependent Members

[image] [image]

Grasshopper SDK
IGH_InstanceGuidDependent Members
IGH_InstanceGuidDependent Interface Methods See Also Send Feedback

The IGH_InstanceGuidDependent type exposes the following members.

Methods

 | Name | Description
Public method | InstanceGuidsChanged | This method will be called by the GH_Document that owns this object after it mutates some or all of it's object InstanceIds.

See Also

IGH_InstanceGuidDependent Interface
Grasshopper.Kernel Namespace


IGH_InstanceGuidDependent Methods

[image] [image]

Grasshopper SDK
IGH_InstanceGuidDependent Methods
IGH_InstanceGuidDependent Interface See Also Send Feedback

The IGH_InstanceGuidDependent type exposes the following members.

Methods

 | Name | Description
Public method | InstanceGuidsChanged | This method will be called by the GH_Document that owns this object after it mutates some or all of it's object InstanceIds.

See Also

IGH_InstanceGuidDependent Interface
Grasshopper.Kernel Namespace


InstanceGuidsChanged Method

[image]

Grasshopper SDK
IGH_InstanceGuidDependent..::..InstanceGuidsChanged Method
IGH_InstanceGuidDependent Interface See Also Send Feedback
This method will be called by the GH_Document that owns this object after it mutates some or all of it's object InstanceIds.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void InstanceGuidsChanged(
    SortedDictionary<Guid, Guid> map
)
Visual Basic
Sub InstanceGuidsChanged ( _
    map As SortedDictionary(Of Guid, Guid) _
)

Parameters

map
Type: System.Collections.Generic..::..SortedDictionary <(Of <(<' Guid, Guid >)>)>
A translation dictionary of old InstanceID keys (no longer existent) and new InstanceID values.

See Also

IGH_InstanceGuidDependent Interface
Grasshopper.Kernel Namespace


IGH_ObjectProxy Interface

[image]

Grasshopper SDK
IGH_ObjectProxy Interface
Members See Also Send Feedback
Provides proxy data for all Grasshopper components and parameters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_ObjectProxy
Visual Basic
Public Interface IGH_ObjectProxy

See Also

IGH_ObjectProxy Members
Grasshopper.Kernel Namespace


IGH_ObjectProxy Members

[image] [image]

Grasshopper SDK
IGH_ObjectProxy Members
IGH_ObjectProxy Interface Methods Properties See Also Send Feedback

The IGH_ObjectProxy type exposes the following members.

Methods

 | Name | Description
Public method | CreateInstance | Create a new instance from the target object.
Public method | DuplicateProxy | Create a duplicate of this proxy.

Properties

 | Name | Description
Public property | Desc | Gets the Instance Description associated with this proxy.
Public property | Exposure | Gets or sets the Exposure of the target object. Only set the exposure if you know what you are doing.
Public property | Guid | Gets the Guid of the target object. In the case of Compiled Objects, the Guid represents the ComponentID, in the case of User Objects, the Guid is a hash of the file path.
Public property | Icon | Gets the icon for this object.
Public property | Kind | Gets the kind of the Proxy target object.
Public property | LibraryGuid | Gets the ID of the library (GHA file) that defines this object.
Public property | Location | Gets the location of the target object. If the proxy represents a Compiled Object, the location refers to the file path of the assembly, in the case of User Objects, the location refers to the object file.
Public property | Obsolete | Gets whether this proxy represents an obsolete object.
Public property | SDKCompliant | Gets whether this object is compliant with the current Rhino version.
Public property | Type | Gets the Type for the target object. If the proxy references a User Object, the Type member will be null.

See Also

IGH_ObjectProxy Interface
Grasshopper.Kernel Namespace


IGH_ObjectProxy Methods

[image] [image]

Grasshopper SDK
IGH_ObjectProxy Methods
IGH_ObjectProxy Interface See Also Send Feedback

The IGH_ObjectProxy type exposes the following members.

Methods

 | Name | Description
Public method | CreateInstance | Create a new instance from the target object.
Public method | DuplicateProxy | Create a duplicate of this proxy.

See Also

IGH_ObjectProxy Interface
Grasshopper.Kernel Namespace


CreateInstance Method

[image]

Grasshopper SDK
IGH_ObjectProxy..::..CreateInstance Method
IGH_ObjectProxy Interface See Also Send Feedback
Create a new instance from the target object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
IGH_DocumentObject CreateInstance()
Visual Basic
Function CreateInstance As IGH_DocumentObject

Return Value

An IGH_DocumentObject instance on success or null on failure.

See Also

IGH_ObjectProxy Interface
Grasshopper.Kernel Namespace


DuplicateProxy Method

[image]

Grasshopper SDK
IGH_ObjectProxy..::..DuplicateProxy Method
IGH_ObjectProxy Interface See Also Send Feedback
Create a duplicate of this proxy.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
IGH_ObjectProxy DuplicateProxy()
Visual Basic
Function DuplicateProxy As IGH_ObjectProxy

See Also

IGH_ObjectProxy Interface
Grasshopper.Kernel Namespace


IGH_ObjectProxy Properties

[image] [image]

Grasshopper SDK
IGH_ObjectProxy Properties
IGH_ObjectProxy Interface See Also Send Feedback

The IGH_ObjectProxy type exposes the following members.

Properties

 | Name | Description
Public property | Desc | Gets the Instance Description associated with this proxy.
Public property | Exposure | Gets or sets the Exposure of the target object. Only set the exposure if you know what you are doing.
Public property | Guid | Gets the Guid of the target object. In the case of Compiled Objects, the Guid represents the ComponentID, in the case of User Objects, the Guid is a hash of the file path.
Public property | Icon | Gets the icon for this object.
Public property | Kind | Gets the kind of the Proxy target object.
Public property | LibraryGuid | Gets the ID of the library (GHA file) that defines this object.
Public property | Location | Gets the location of the target object. If the proxy represents a Compiled Object, the location refers to the file path of the assembly, in the case of User Objects, the location refers to the object file.
Public property | Obsolete | Gets whether this proxy represents an obsolete object.
Public property | SDKCompliant | Gets whether this object is compliant with the current Rhino version.
Public property | Type | Gets the Type for the target object. If the proxy references a User Object, the Type member will be null.

See Also

IGH_ObjectProxy Interface
Grasshopper.Kernel Namespace


Desc Property

[image]

Grasshopper SDK
IGH_ObjectProxy..::..Desc Property
IGH_ObjectProxy Interface See Also Send Feedback
Gets the Instance Description associated with this proxy.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
IGH_InstanceDescription Desc { get; }
Visual Basic
ReadOnly Property Desc As IGH_InstanceDescription
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_ObjectProxy.Desc"]

See Also

IGH_ObjectProxy Interface
Grasshopper.Kernel Namespace


Exposure Property

[image]

Grasshopper SDK
IGH_ObjectProxy..::..Exposure Property
IGH_ObjectProxy Interface See Also Send Feedback
Gets or sets the Exposure of the target object. Only set the exposure if you know what you are doing.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
GH_Exposure Exposure { get; set; }
Visual Basic
Property Exposure As GH_Exposure
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_ObjectProxy.Exposure"]

See Also

IGH_ObjectProxy Interface
Grasshopper.Kernel Namespace


Guid Property

[image]

Grasshopper SDK
IGH_ObjectProxy..::..Guid Property
IGH_ObjectProxy Interface See Also Send Feedback
Gets the Guid of the target object. In the case of Compiled Objects, the Guid represents the ComponentID, in the case of User Objects, the Guid is a hash of the file path.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
Guid Guid { get; }
Visual Basic
ReadOnly Property Guid As Guid
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_ObjectProxy.Guid"]

See Also

IGH_ObjectProxy Interface
Grasshopper.Kernel Namespace


Icon Property

[image]

Grasshopper SDK
IGH_ObjectProxy..::..Icon Property
IGH_ObjectProxy Interface See Also Send Feedback
Gets the icon for this object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
Bitmap Icon { get; }
Visual Basic
ReadOnly Property Icon As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_ObjectProxy.Icon"]

See Also

IGH_ObjectProxy Interface
Grasshopper.Kernel Namespace


Kind Property

[image]

Grasshopper SDK
IGH_ObjectProxy..::..Kind Property
IGH_ObjectProxy Interface See Also Send Feedback
Gets the kind of the Proxy target object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
GH_ObjectType Kind { get; }
Visual Basic
ReadOnly Property Kind As GH_ObjectType
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_ObjectProxy.Kind"]

See Also

IGH_ObjectProxy Interface
Grasshopper.Kernel Namespace


LibraryGuid Property

[image]

Grasshopper SDK
IGH_ObjectProxy..::..LibraryGuid Property
IGH_ObjectProxy Interface See Also Send Feedback
Gets the ID of the library (GHA file) that defines this object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
Guid LibraryGuid { get; }
Visual Basic
ReadOnly Property LibraryGuid As Guid
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_ObjectProxy.LibraryGuid"]

See Also

IGH_ObjectProxy Interface
Grasshopper.Kernel Namespace


Location Property

[image]

Grasshopper SDK
IGH_ObjectProxy..::..Location Property
IGH_ObjectProxy Interface See Also Send Feedback
Gets the location of the target object. If the proxy represents a Compiled Object, the location refers to the file path of the assembly, in the case of User Objects, the location refers to the object file.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string Location { get; }
Visual Basic
ReadOnly Property Location As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_ObjectProxy.Location"]

See Also

IGH_ObjectProxy Interface
Grasshopper.Kernel Namespace


Obsolete Property

[image]

Grasshopper SDK
IGH_ObjectProxy..::..Obsolete Property
IGH_ObjectProxy Interface See Also Send Feedback
Gets whether this proxy represents an obsolete object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool Obsolete { get; }
Visual Basic
ReadOnly Property Obsolete As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_ObjectProxy.Obsolete"]

See Also

IGH_ObjectProxy Interface
Grasshopper.Kernel Namespace


SDKCompliant Property

[image]

Grasshopper SDK
IGH_ObjectProxy..::..SDKCompliant Property
IGH_ObjectProxy Interface See Also Send Feedback
Gets whether this object is compliant with the current Rhino version.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool SDKCompliant { get; }
Visual Basic
ReadOnly Property SDKCompliant As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_ObjectProxy.SDKCompliant"]

See Also

IGH_ObjectProxy Interface
Grasshopper.Kernel Namespace


Type Property

[image]

Grasshopper SDK
IGH_ObjectProxy..::..Type Property
IGH_ObjectProxy Interface See Also Send Feedback
Gets the Type for the target object. If the proxy references a User Object, the Type member will be null.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
Type Type { get; }
Visual Basic
ReadOnly Property Type As Type
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_ObjectProxy.Type"]

See Also

IGH_ObjectProxy Interface
Grasshopper.Kernel Namespace


IGH_Param Interface

[image]

Grasshopper SDK
IGH_Param Interface
Members See Also Send Feedback
Base interface for all Parameter types in Grasshopper. Do not implement this interface from scratch, derive from GH_Param or GH_PersistentParam instead.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_Param : IGH_ActiveObject
Visual Basic
Public Interface IGH_Param _
    Inherits IGH_ActiveObject

See Also

IGH_Param Members
Grasshopper.Kernel Namespace


IGH_Param Members

[image] [image]

Grasshopper SDK
IGH_Param Members
IGH_Param Interface Methods Properties See Also Send Feedback

The IGH_Param type exposes the following members.

Methods

 | Name | Description
Public method | AddRuntimeMessage | Add a new message to this object. Valid message type flags are Warning and Error. If the Message string is empty or zero-length no message is added. (Inherited from IGH_ActiveObject.)
Public method | AddSource(IGH_Param) | Append a new Source parameter to the end of the Sources list. Sources provide this parameter with data at runtime.
Public method | AddSource(IGH_Param, Int32) | Insert a new Source parameter into the Sources list. Sources provide this parameter with data at runtime.
Public method | AddVolatileData | Inserts an item of volatile data into the data structure.
Public method | AddVolatileDataList | Inserts a list of items into the data structure.
Public method | AddVolatileDataTree | Insert an entire data tree into this parameter.
Public method | ClearData | This function is called whenever the object needs to clear all solution data. This usually amounts to wiping volatile caches and messages. This function will not affect any other objects, but it will set the Phase flag to Blank (Inherited from IGH_ActiveObject.)
Public method | ClearProxySources | Remove all proxy sources without attempting to relink them.
Public method | ClearRuntimeMessages | Clear all message lists. (Inherited from IGH_ActiveObject.)
Public method | CollectData | This function is called whenever the object is required to collect all data. Either from Persistent records, from source params or whatever. This step is only performed if the phase flag is Blank or Failed. Upon completion, the phase flag will be set to Collected (Inherited from IGH_ActiveObject.)
Public method | ComputeData | This function is called whenever the object is required to generate new data. This step is only performed by some objects and only when the Phase flag is Collected. Upon completion, the Phase will be Computed. If this object throws exceptions, it is the responsibility of the caller to set the Phase flag to Failed. (Inherited from IGH_ActiveObject.)
Public method | CreateProxySources | Convert all proper source parameters into proxy sources.
Public method | DependsOn | Solve the inheritance relationship between this object and a potential parental object. (Inherited from IGH_ActiveObject.)
Public method | RegisterRemoteIDs | If this object depends on Rhino Objects, you must register the UUIDs of those objects. Failure to do so will result in faulty event handling. (Inherited from IGH_ActiveObject.)
Public method | RelinkProxySources | Attempt to replace all proxy sources with real sources. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources.
Public method | RemoveAllSources | Remove all sources from this parameter.
Public method | RemoveEffects | Remove all post-process effects.
Public method | RemoveSource(Guid) | Remove the specified source from this parameter.
Public method | RemoveSource(IGH_Param) | Remove the specified source from this parameter.
Public method | ReplaceSource(Guid, IGH_Param) | Replace an existing source with a new one. If the old_source does not exist in this parameter, nothing happens.
Public method | ReplaceSource(IGH_Param, IGH_Param) | Replace an existing source with a new one. If the old_source does not exist in this parameter, nothing happens.
Public method | RuntimeMessages | Gets the list of cached runtime messages that were recorded during solver-time processes. (Inherited from IGH_ActiveObject.)
Public method | SDKCompliancy | Test whether this object is compliant with a given Rhino version. (Inherited from IGH_ActiveObject.)

Properties

 | Name | Description
Public property | Access | Gets or sets the Access level for this parameter.
Public property | DataMapping | Gets or sets the data mapping of this Parameter.
Public property | DataType | Gets the type of the current data state.
Public property | HasProxySources | Gets a value indicating whether or not this parameter maintains proxy sources. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources.
Public property | IsDataProvider | Gets whether or not this object is capable of emitting data. (Inherited from IGH_ActiveObject.)
Public property | Kind | Gets the parameter kind. The kind is evaluated lazily and cached.
Public property | Locked | Gets or sets the locked flag of this object. Locked objects are ignored during solutions. (Inherited from IGH_ActiveObject.)
Public property | MutableNickName | Gets or sets a value that enables Nick name changes through the menu. The default is TRUE. (Inherited from IGH_ActiveObject.)
Public property | Optional | Gets or sets whether or not this parameter is considered optional by the owner component. Empty, non-optional parameters prevent the component from being solved.
Public property | Phase | Gets the solution phase in which this object is currently stuck. (Inherited from IGH_ActiveObject.)
Public property | ProcessorTime | Gets the most recent measured processor time. (Inherited from IGH_ActiveObject.)
Public property | ProxySourceCount | Gets the number of proxy sources for this parameter. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources.
Public property | Recipients | Gets a list of all the recipients of this parameter. I.e. a recipient has this parameter as one of the sources. The Recipient list is maintained by the parameter, do not modify it yourself.
Public property | Reverse | Gets or sets the data reverse modifier of this parameter.
Public property | RuntimeMessageLevel | Gets the worst-case level of all messages. I.e. if only warnings have been recorded, the level will be ::warning. If even a single error exists, the level will be ::error. (Inherited from IGH_ActiveObject.)
Public property | Simplify | Gets or sets the simplify modifier for this parameter.
Public property | SourceCount | Gets the number of sources for this parameter.
Public property | Sources | Gets a list of source parameters. Do not modify this list, if you wish to add or remove sources, use dedicated functions like AddSource() and RemoveSource instead.
Public property | StateTags | Gets all the StateTags that are associated with this parameter. A state tag is a visual feedback icon that represents specific internal settings.
Public property | Type | Gets the Framework Type descriptor for the stored Data.
Public property | TypeName | Gets a human readable description of the data stored in this parameter.
Public property | VolatileData | Gets the instance of the volatile data tree stored in this parameter.
Public property | VolatileDataCount | Gets the total number of volatile data items stored in this parameter.
Public property | WireDisplay | Gets or sets the wire display style for this parameter. Wire display only affects the wires connected to the parameter input.

See Also

IGH_Param Interface
Grasshopper.Kernel Namespace


IGH_Param Methods

[image] [image]

Grasshopper SDK
IGH_Param Methods
IGH_Param Interface See Also Send Feedback

The IGH_Param type exposes the following members.

Methods

 | Name | Description
Public method | AddRuntimeMessage | Add a new message to this object. Valid message type flags are Warning and Error. If the Message string is empty or zero-length no message is added. (Inherited from IGH_ActiveObject.)
Public method | AddSource(IGH_Param) | Append a new Source parameter to the end of the Sources list. Sources provide this parameter with data at runtime.
Public method | AddSource(IGH_Param, Int32) | Insert a new Source parameter into the Sources list. Sources provide this parameter with data at runtime.
Public method | AddVolatileData | Inserts an item of volatile data into the data structure.
Public method | AddVolatileDataList | Inserts a list of items into the data structure.
Public method | AddVolatileDataTree | Insert an entire data tree into this parameter.
Public method | ClearData | This function is called whenever the object needs to clear all solution data. This usually amounts to wiping volatile caches and messages. This function will not affect any other objects, but it will set the Phase flag to Blank (Inherited from IGH_ActiveObject.)
Public method | ClearProxySources | Remove all proxy sources without attempting to relink them.
Public method | ClearRuntimeMessages | Clear all message lists. (Inherited from IGH_ActiveObject.)
Public method | CollectData | This function is called whenever the object is required to collect all data. Either from Persistent records, from source params or whatever. This step is only performed if the phase flag is Blank or Failed. Upon completion, the phase flag will be set to Collected (Inherited from IGH_ActiveObject.)
Public method | ComputeData | This function is called whenever the object is required to generate new data. This step is only performed by some objects and only when the Phase flag is Collected. Upon completion, the Phase will be Computed. If this object throws exceptions, it is the responsibility of the caller to set the Phase flag to Failed. (Inherited from IGH_ActiveObject.)
Public method | CreateProxySources | Convert all proper source parameters into proxy sources.
Public method | DependsOn | Solve the inheritance relationship between this object and a potential parental object. (Inherited from IGH_ActiveObject.)
Public method | RegisterRemoteIDs | If this object depends on Rhino Objects, you must register the UUIDs of those objects. Failure to do so will result in faulty event handling. (Inherited from IGH_ActiveObject.)
Public method | RelinkProxySources | Attempt to replace all proxy sources with real sources. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources.
Public method | RemoveAllSources | Remove all sources from this parameter.
Public method | RemoveEffects | Remove all post-process effects.
Public method | RemoveSource(Guid) | Remove the specified source from this parameter.
Public method | RemoveSource(IGH_Param) | Remove the specified source from this parameter.
Public method | ReplaceSource(Guid, IGH_Param) | Replace an existing source with a new one. If the old_source does not exist in this parameter, nothing happens.
Public method | ReplaceSource(IGH_Param, IGH_Param) | Replace an existing source with a new one. If the old_source does not exist in this parameter, nothing happens.
Public method | RuntimeMessages | Gets the list of cached runtime messages that were recorded during solver-time processes. (Inherited from IGH_ActiveObject.)
Public method | SDKCompliancy | Test whether this object is compliant with a given Rhino version. (Inherited from IGH_ActiveObject.)

See Also

IGH_Param Interface
Grasshopper.Kernel Namespace


AddSource Method

[image] [image]

Grasshopper SDK
IGH_Param..::..AddSource Method
IGH_Param Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | AddSource(IGH_Param) | Append a new Source parameter to the end of the Sources list. Sources provide this parameter with data at runtime.
Public method | AddSource(IGH_Param, Int32) | Insert a new Source parameter into the Sources list. Sources provide this parameter with data at runtime.

See Also

IGH_Param Interface
IGH_Param Members
Grasshopper.Kernel Namespace


AddSource Method (IGH_Param)

[image]

Grasshopper SDK
IGH_Param..::..AddSource Method (IGH_Param)
IGH_Param Interface See Also Send Feedback
Append a new Source parameter to the end of the Sources list. Sources provide this parameter with data at runtime.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void AddSource(
    IGH_Param source
)
Visual Basic
Sub AddSource ( _
    source As IGH_Param _
)

Parameters

source
Type: Grasshopper.Kernel..::..IGH_Param
Source to append.

See Also

IGH_Param Interface
AddSource Overload
Grasshopper.Kernel Namespace


AddSource Method (IGH_Param, Int32)

[image]

Grasshopper SDK
IGH_Param..::..AddSource Method (IGH_Param, Int32)
IGH_Param Interface See Also Send Feedback
Insert a new Source parameter into the Sources list. Sources provide this parameter with data at runtime.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void AddSource(
    IGH_Param source,
    int index
)
Visual Basic
Sub AddSource ( _
    source As IGH_Param, _
    index As Integer _
)

Parameters

source
Type: Grasshopper.Kernel..::..IGH_Param
Source to append.
index
Type: System..::..Int32
Insertion index of source.

See Also

IGH_Param Interface
AddSource Overload
Grasshopper.Kernel Namespace


AddVolatileData Method

[image]

Grasshopper SDK
IGH_Param..::..AddVolatileData Method
IGH_Param Interface See Also Send Feedback
Inserts an item of volatile data into the data structure.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool AddVolatileData(
    GH_Path path,
    int index,
    Object data
)
Visual Basic
Function AddVolatileData ( _
    path As GH_Path, _
    index As Integer, _
    data As Object _
) As Boolean

Parameters

path
Type: Grasshopper.Kernel.Data..::..GH_Path
The branch path of the data. If the path doesn't exist yet, it will be created.
index
Type: System..::..Int32
The item index of the data. If the path doesn't contain the index yet, it will be enlarged to encompass the index.
data
Type: System..::..Object
The data to store.

Return Value

True on success, False on failure. If the data cannot be converted, the topology will remain unmolested.

See Also

IGH_Param Interface
Grasshopper.Kernel Namespace


AddVolatileDataList Method

[image]

Grasshopper SDK
IGH_Param..::..AddVolatileDataList Method
IGH_Param Interface See Also Send Feedback
Inserts a list of items into the data structure.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool AddVolatileDataList(
    GH_Path path,
    IEnumerable list
)
Visual Basic
Function AddVolatileDataList ( _
    path As GH_Path, _
    list As IEnumerable _
) As Boolean

Parameters

path
Type: Grasshopper.Kernel.Data..::..GH_Path
The branch path of the data. If the path doesn't exist yet, it will be created.
list
Type: System.Collections..::..IEnumerable
The data list to store.

See Also

IGH_Param Interface
Grasshopper.Kernel Namespace


AddVolatileDataTree Method

[image]

Grasshopper SDK
IGH_Param..::..AddVolatileDataTree Method
IGH_Param Interface See Also Send Feedback
Insert an entire data tree into this parameter.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool AddVolatileDataTree(
    IGH_Structure tree
)
Visual Basic
Function AddVolatileDataTree ( _
    tree As IGH_Structure _
) As Boolean

Parameters

tree
Type: Grasshopper.Kernel.Data..::..IGH_Structure
Data tree to insert.

Return Value

True on success, false on failure.

See Also

IGH_Param Interface
Grasshopper.Kernel Namespace


ClearProxySources Method

[image]

Grasshopper SDK
IGH_Param..::..ClearProxySources Method
IGH_Param Interface See Also Send Feedback
Remove all proxy sources without attempting to relink them.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void ClearProxySources()
Visual Basic
Sub ClearProxySources

See Also

IGH_Param Interface
Grasshopper.Kernel Namespace


CreateProxySources Method

[image]

Grasshopper SDK
IGH_Param..::..CreateProxySources Method
IGH_Param Interface See Also Send Feedback
Convert all proper source parameters into proxy sources.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void CreateProxySources()
Visual Basic
Sub CreateProxySources

See Also

IGH_Param Interface
Grasshopper.Kernel Namespace


RelinkProxySources Method

[image]

Grasshopper SDK
IGH_Param..::..RelinkProxySources Method
IGH_Param Interface See Also Send Feedback
Attempt to replace all proxy sources with real sources. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool RelinkProxySources(
    GH_Document document
)
Visual Basic
Function RelinkProxySources ( _
    document As GH_Document _
) As Boolean

Parameters

document
Type: Grasshopper.Kernel..::..GH_Document

Return Value

True on success, false on failure.

See Also

IGH_Param Interface
Grasshopper.Kernel Namespace


RemoveAllSources Method

[image]

Grasshopper SDK
IGH_Param..::..RemoveAllSources Method
IGH_Param Interface See Also Send Feedback
Remove all sources from this parameter.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void RemoveAllSources()
Visual Basic
Sub RemoveAllSources

See Also

IGH_Param Interface
Grasshopper.Kernel Namespace


RemoveEffects Method

[image]

Grasshopper SDK
IGH_Param..::..RemoveEffects Method
IGH_Param Interface See Also Send Feedback
Remove all post-process effects.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void RemoveEffects()
Visual Basic
Sub RemoveEffects

See Also

IGH_Param Interface
Grasshopper.Kernel Namespace


RemoveSource Method

[image] [image]

Grasshopper SDK
IGH_Param..::..RemoveSource Method
IGH_Param Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveSource(Guid) | Remove the specified source from this parameter.
Public method | RemoveSource(IGH_Param) | Remove the specified source from this parameter.

See Also

IGH_Param Interface
IGH_Param Members
Grasshopper.Kernel Namespace


RemoveSource Method (Guid)

[image]

Grasshopper SDK
IGH_Param..::..RemoveSource Method (Guid)
IGH_Param Interface See Also Send Feedback
Remove the specified source from this parameter.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void RemoveSource(
    Guid source_id
)
Visual Basic
Sub RemoveSource ( _
    source_id As Guid _
)

Parameters

source_id
Type: System..::..Guid
InstanceID of source to remove.

See Also

IGH_Param Interface
RemoveSource Overload
Grasshopper.Kernel Namespace


RemoveSource Method (IGH_Param)

[image]

Grasshopper SDK
IGH_Param..::..RemoveSource Method (IGH_Param)
IGH_Param Interface See Also Send Feedback
Remove the specified source from this parameter.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void RemoveSource(
    IGH_Param source
)
Visual Basic
Sub RemoveSource ( _
    source As IGH_Param _
)

Parameters

source
Type: Grasshopper.Kernel..::..IGH_Param
Source to remove.

See Also

IGH_Param Interface
RemoveSource Overload
Grasshopper.Kernel Namespace


ReplaceSource Method

[image] [image]

Grasshopper SDK
IGH_Param..::..ReplaceSource Method
IGH_Param Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | ReplaceSource(Guid, IGH_Param) | Replace an existing source with a new one. If the old_source does not exist in this parameter, nothing happens.
Public method | ReplaceSource(IGH_Param, IGH_Param) | Replace an existing source with a new one. If the old_source does not exist in this parameter, nothing happens.

See Also

IGH_Param Interface
IGH_Param Members
Grasshopper.Kernel Namespace


ReplaceSource Method (Guid, IGH_Param)

[image]

Grasshopper SDK
IGH_Param..::..ReplaceSource Method (Guid, IGH_Param)
IGH_Param Interface See Also Send Feedback
Replace an existing source with a new one. If the old_source does not exist in this parameter, nothing happens.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void ReplaceSource(
    Guid old_source_id,
    IGH_Param new_source
)
Visual Basic
Sub ReplaceSource ( _
    old_source_id As Guid, _
    new_source As IGH_Param _
)

Parameters

old_source_id
Type: System..::..Guid
Source to replace.
new_source
Type: Grasshopper.Kernel..::..IGH_Param
Source to replace with.

See Also

IGH_Param Interface
ReplaceSource Overload
Grasshopper.Kernel Namespace


ReplaceSource Method (IGH_Param, IGH_Param)

[image]

Grasshopper SDK
IGH_Param..::..ReplaceSource Method (IGH_Param, IGH_Param)
IGH_Param Interface See Also Send Feedback
Replace an existing source with a new one. If the old_source does not exist in this parameter, nothing happens.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void ReplaceSource(
    IGH_Param old_source,
    IGH_Param new_source
)
Visual Basic
Sub ReplaceSource ( _
    old_source As IGH_Param, _
    new_source As IGH_Param _
)

Parameters

old_source
Type: Grasshopper.Kernel..::..IGH_Param
Source to replace.
new_source
Type: Grasshopper.Kernel..::..IGH_Param
Source to replace with.

See Also

IGH_Param Interface
ReplaceSource Overload
Grasshopper.Kernel Namespace


IGH_Param Properties

[image] [image]

Grasshopper SDK
IGH_Param Properties
IGH_Param Interface See Also Send Feedback

The IGH_Param type exposes the following members.

Properties

 | Name | Description
Public property | Access | Gets or sets the Access level for this parameter.
Public property | DataMapping | Gets or sets the data mapping of this Parameter.
Public property | DataType | Gets the type of the current data state.
Public property | HasProxySources | Gets a value indicating whether or not this parameter maintains proxy sources. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources.
Public property | IsDataProvider | Gets whether or not this object is capable of emitting data. (Inherited from IGH_ActiveObject.)
Public property | Kind | Gets the parameter kind. The kind is evaluated lazily and cached.
Public property | Locked | Gets or sets the locked flag of this object. Locked objects are ignored during solutions. (Inherited from IGH_ActiveObject.)
Public property | MutableNickName | Gets or sets a value that enables Nick name changes through the menu. The default is TRUE. (Inherited from IGH_ActiveObject.)
Public property | Optional | Gets or sets whether or not this parameter is considered optional by the owner component. Empty, non-optional parameters prevent the component from being solved.
Public property | Phase | Gets the solution phase in which this object is currently stuck. (Inherited from IGH_ActiveObject.)
Public property | ProcessorTime | Gets the most recent measured processor time. (Inherited from IGH_ActiveObject.)
Public property | ProxySourceCount | Gets the number of proxy sources for this parameter. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources.
Public property | Recipients | Gets a list of all the recipients of this parameter. I.e. a recipient has this parameter as one of the sources. The Recipient list is maintained by the parameter, do not modify it yourself.
Public property | Reverse | Gets or sets the data reverse modifier of this parameter.
Public property | RuntimeMessageLevel | Gets the worst-case level of all messages. I.e. if only warnings have been recorded, the level will be ::warning. If even a single error exists, the level will be ::error. (Inherited from IGH_ActiveObject.)
Public property | Simplify | Gets or sets the simplify modifier for this parameter.
Public property | SourceCount | Gets the number of sources for this parameter.
Public property | Sources | Gets a list of source parameters. Do not modify this list, if you wish to add or remove sources, use dedicated functions like AddSource() and RemoveSource instead.
Public property | StateTags | Gets all the StateTags that are associated with this parameter. A state tag is a visual feedback icon that represents specific internal settings.
Public property | Type | Gets the Framework Type descriptor for the stored Data.
Public property | TypeName | Gets a human readable description of the data stored in this parameter.
Public property | VolatileData | Gets the instance of the volatile data tree stored in this parameter.
Public property | VolatileDataCount | Gets the total number of volatile data items stored in this parameter.
Public property | WireDisplay | Gets or sets the wire display style for this parameter. Wire display only affects the wires connected to the parameter input.

See Also

IGH_Param Interface
Grasshopper.Kernel Namespace


Access Property

[image]

Grasshopper SDK
IGH_Param..::..Access Property
IGH_Param Interface See Also Send Feedback
Gets or sets the Access level for this parameter.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
GH_ParamAccess Access { get; set; }
Visual Basic
Property Access As GH_ParamAccess
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Param.Access"]

See Also

IGH_Param Interface
Grasshopper.Kernel Namespace


DataMapping Property

[image]

Grasshopper SDK
IGH_Param..::..DataMapping Property
IGH_Param Interface See Also Send Feedback
Gets or sets the data mapping of this Parameter.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
GH_DataMapping DataMapping { get; set; }
Visual Basic
Property DataMapping As GH_DataMapping
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Param.DataMapping"]

See Also

IGH_Param Interface
Grasshopper.Kernel Namespace


DataType Property

[image]

Grasshopper SDK
IGH_Param..::..DataType Property
IGH_Param Interface See Also Send Feedback
Gets the type of the current data state.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
GH_ParamData DataType { get; }
Visual Basic
ReadOnly Property DataType As GH_ParamData
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Param.DataType"]

See Also

IGH_Param Interface
Grasshopper.Kernel Namespace


HasProxySources Property

[image]

Grasshopper SDK
IGH_Param..::..HasProxySources Property
IGH_Param Interface See Also Send Feedback
Gets a value indicating whether or not this parameter maintains proxy sources. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool HasProxySources { get; }
Visual Basic
ReadOnly Property HasProxySources As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Param.HasProxySources"]

Return Value

True if the parameter has at least one proxy source, false if not.

See Also

IGH_Param Interface
Grasshopper.Kernel Namespace


Kind Property

[image]

Grasshopper SDK
IGH_Param..::..Kind Property
IGH_Param Interface See Also Send Feedback
Gets the parameter kind. The kind is evaluated lazily and cached.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
GH_ParamKind Kind { get; }
Visual Basic
ReadOnly Property Kind As GH_ParamKind
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Param.Kind"]

See Also

IGH_Param Interface
Grasshopper.Kernel Namespace


Optional Property

[image]

Grasshopper SDK
IGH_Param..::..Optional Property
IGH_Param Interface See Also Send Feedback
Gets or sets whether or not this parameter is considered optional by the owner component. Empty, non-optional parameters prevent the component from being solved.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool Optional { get; set; }
Visual Basic
Property Optional As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Param.Optional"]

See Also

IGH_Param Interface
Grasshopper.Kernel Namespace


ProxySourceCount Property

[image]

Grasshopper SDK
IGH_Param..::..ProxySourceCount Property
IGH_Param Interface See Also Send Feedback
Gets the number of proxy sources for this parameter. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
int ProxySourceCount { get; }
Visual Basic
ReadOnly Property ProxySourceCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Param.ProxySourceCount"]

Return Value

The number of proxy sources associated with this parameter.

See Also

IGH_Param Interface
Grasshopper.Kernel Namespace


Recipients Property

[image]

Grasshopper SDK
IGH_Param..::..Recipients Property
IGH_Param Interface See Also Send Feedback
Gets a list of all the recipients of this parameter. I.e. a recipient has this parameter as one of the sources. The Recipient list is maintained by the parameter, do not modify it yourself.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
IList<IGH_Param> Recipients { get; }
Visual Basic
ReadOnly Property Recipients As IList(Of IGH_Param)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Param.Recipients"]

See Also

IGH_Param Interface
Grasshopper.Kernel Namespace


Reverse Property

[image]

Grasshopper SDK
IGH_Param..::..Reverse Property
IGH_Param Interface See Also Send Feedback
Gets or sets the data reverse modifier of this parameter.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool Reverse { get; set; }
Visual Basic
Property Reverse As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Param.Reverse"]

See Also

IGH_Param Interface
Grasshopper.Kernel Namespace


Simplify Property

[image]

Grasshopper SDK
IGH_Param..::..Simplify Property
IGH_Param Interface See Also Send Feedback
Gets or sets the simplify modifier for this parameter.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool Simplify { get; set; }
Visual Basic
Property Simplify As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Param.Simplify"]

See Also

IGH_Param Interface
Grasshopper.Kernel Namespace


SourceCount Property

[image]

Grasshopper SDK
IGH_Param..::..SourceCount Property
IGH_Param Interface See Also Send Feedback
Gets the number of sources for this parameter.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
int SourceCount { get; }
Visual Basic
ReadOnly Property SourceCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Param.SourceCount"]

See Also

IGH_Param Interface
Grasshopper.Kernel Namespace


Sources Property

[image]

Grasshopper SDK
IGH_Param..::..Sources Property
IGH_Param Interface See Also Send Feedback
Gets a list of source parameters. Do not modify this list, if you wish to add or remove sources, use dedicated functions like AddSource() and RemoveSource instead.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
IList<IGH_Param> Sources { get; }
Visual Basic
ReadOnly Property Sources As IList(Of IGH_Param)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Param.Sources"]

Return Value

The sources for this parameter.

See Also

IGH_Param Interface
Grasshopper.Kernel Namespace


StateTags Property

[image]

Grasshopper SDK
IGH_Param..::..StateTags Property
IGH_Param Interface See Also Send Feedback
Gets all the StateTags that are associated with this parameter. A state tag is a visual feedback icon that represents specific internal settings.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
GH_StateTagList StateTags { get; }
Visual Basic
ReadOnly Property StateTags As GH_StateTagList
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Param.StateTags"]

See Also

IGH_Param Interface
Grasshopper.Kernel Namespace


Type Property

[image]

Grasshopper SDK
IGH_Param..::..Type Property
IGH_Param Interface See Also Send Feedback
Gets the Framework Type descriptor for the stored Data.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
Type Type { get; }
Visual Basic
ReadOnly Property Type As Type
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Param.Type"]

See Also

IGH_Param Interface
Grasshopper.Kernel Namespace


TypeName Property

[image]

Grasshopper SDK
IGH_Param..::..TypeName Property
IGH_Param Interface See Also Send Feedback
Gets a human readable description of the data stored in this parameter.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string TypeName { get; }
Visual Basic
ReadOnly Property TypeName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Param.TypeName"]

See Also

IGH_Param Interface
Grasshopper.Kernel Namespace


VolatileData Property

[image]

Grasshopper SDK
IGH_Param..::..VolatileData Property
IGH_Param Interface See Also Send Feedback
Gets the instance of the volatile data tree stored in this parameter.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
IGH_Structure VolatileData { get; }
Visual Basic
ReadOnly Property VolatileData As IGH_Structure
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Param.VolatileData"]

See Also

IGH_Param Interface
Grasshopper.Kernel Namespace


VolatileDataCount Property

[image]

Grasshopper SDK
IGH_Param..::..VolatileDataCount Property
IGH_Param Interface See Also Send Feedback
Gets the total number of volatile data items stored in this parameter.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
int VolatileDataCount { get; }
Visual Basic
ReadOnly Property VolatileDataCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Param.VolatileDataCount"]

See Also

IGH_Param Interface
Grasshopper.Kernel Namespace


WireDisplay Property

[image]

Grasshopper SDK
IGH_Param..::..WireDisplay Property
IGH_Param Interface See Also Send Feedback
Gets or sets the wire display style for this parameter. Wire display only affects the wires connected to the parameter input.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
GH_ParamWireDisplay WireDisplay { get; set; }
Visual Basic
Property WireDisplay As GH_ParamWireDisplay
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_Param.WireDisplay"]

See Also

IGH_Param Interface
Grasshopper.Kernel Namespace


IGH_PreviewArgs Interface

[image]

Grasshopper SDK
IGH_PreviewArgs Interface
Members See Also Send Feedback
Preview display arguments for IGH_PreviewObjects.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_PreviewArgs
Visual Basic
Public Interface IGH_PreviewArgs

See Also

IGH_PreviewArgs Members
Grasshopper.Kernel Namespace


IGH_PreviewArgs Members

[image] [image]

Grasshopper SDK
IGH_PreviewArgs Members
IGH_PreviewArgs Interface Properties See Also Send Feedback

The IGH_PreviewArgs type exposes the following members.

Properties

 | Name | Description
Public property | DefaultCurveThickness | Gets the curve thickness as defined by the viewport display scheme.
Public property | Display | Gets the Pipeline that is being used to draw the current preview.
Public property | Document | Gets the Grasshopper document that is currently drawing the preview.
Public property | MeshingParameters | Gets the meshing parameters to be used during meshing breps.
Public property | ShadeMaterial | Gets the document default material for unselected Faces.
Public property | ShadeMaterial_Selected | Gets the document default material for selected Faces.
Public property | Viewport | Gets the Viewport in which the current preview is drawn.
Public property | WireColour | Gets the document default colour for unselected Wires.
Public property | WireColour_Selected | Gets the document default colour for selected Wires.

See Also

IGH_PreviewArgs Interface
Grasshopper.Kernel Namespace


IGH_PreviewArgs Properties

[image] [image]

Grasshopper SDK
IGH_PreviewArgs Properties
IGH_PreviewArgs Interface See Also Send Feedback

The IGH_PreviewArgs type exposes the following members.

Properties

 | Name | Description
Public property | DefaultCurveThickness | Gets the curve thickness as defined by the viewport display scheme.
Public property | Display | Gets the Pipeline that is being used to draw the current preview.
Public property | Document | Gets the Grasshopper document that is currently drawing the preview.
Public property | MeshingParameters | Gets the meshing parameters to be used during meshing breps.
Public property | ShadeMaterial | Gets the document default material for unselected Faces.
Public property | ShadeMaterial_Selected | Gets the document default material for selected Faces.
Public property | Viewport | Gets the Viewport in which the current preview is drawn.
Public property | WireColour | Gets the document default colour for unselected Wires.
Public property | WireColour_Selected | Gets the document default colour for selected Wires.

See Also

IGH_PreviewArgs Interface
Grasshopper.Kernel Namespace


DefaultCurveThickness Property

[image]

Grasshopper SDK
IGH_PreviewArgs..::..DefaultCurveThickness Property
IGH_PreviewArgs Interface See Also Send Feedback
Gets the curve thickness as defined by the viewport display scheme.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
int DefaultCurveThickness { get; }
Visual Basic
ReadOnly Property DefaultCurveThickness As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_PreviewArgs.DefaultCurveThickness"]

See Also

IGH_PreviewArgs Interface
Grasshopper.Kernel Namespace


Display Property

[image]

Grasshopper SDK
IGH_PreviewArgs..::..Display Property
IGH_PreviewArgs Interface See Also Send Feedback
Gets the Pipeline that is being used to draw the current preview.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
DisplayPipeline Display { get; }
Visual Basic
ReadOnly Property Display As DisplayPipeline
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_PreviewArgs.Display"]

See Also

IGH_PreviewArgs Interface
Grasshopper.Kernel Namespace


Document Property

[image]

Grasshopper SDK
IGH_PreviewArgs..::..Document Property
IGH_PreviewArgs Interface See Also Send Feedback
Gets the Grasshopper document that is currently drawing the preview.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
GH_Document Document { get; }
Visual Basic
ReadOnly Property Document As GH_Document
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_PreviewArgs.Document"]

See Also

IGH_PreviewArgs Interface
Grasshopper.Kernel Namespace


MeshingParameters Property

[image]

Grasshopper SDK
IGH_PreviewArgs..::..MeshingParameters Property
IGH_PreviewArgs Interface See Also Send Feedback
Gets the meshing parameters to be used during meshing breps.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
MeshingParameters MeshingParameters { get; }
Visual Basic
ReadOnly Property MeshingParameters As MeshingParameters
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_PreviewArgs.MeshingParameters"]

See Also

IGH_PreviewArgs Interface
Grasshopper.Kernel Namespace


ShadeMaterial Property

[image]

Grasshopper SDK
IGH_PreviewArgs..::..ShadeMaterial Property
IGH_PreviewArgs Interface See Also Send Feedback
Gets the document default material for unselected Faces.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
DisplayMaterial ShadeMaterial { get; }
Visual Basic
ReadOnly Property ShadeMaterial As DisplayMaterial
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_PreviewArgs.ShadeMaterial"]

See Also

IGH_PreviewArgs Interface
Grasshopper.Kernel Namespace


ShadeMaterial_Selected Property

[image]

Grasshopper SDK
IGH_PreviewArgs..::..ShadeMaterial_Selected Property
IGH_PreviewArgs Interface See Also Send Feedback
Gets the document default material for selected Faces.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
DisplayMaterial ShadeMaterial_Selected { get; }
Visual Basic
ReadOnly Property ShadeMaterial_Selected As DisplayMaterial
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_PreviewArgs.ShadeMaterial_Selected"]

See Also

IGH_PreviewArgs Interface
Grasshopper.Kernel Namespace


Viewport Property

[image]

Grasshopper SDK
IGH_PreviewArgs..::..Viewport Property
IGH_PreviewArgs Interface See Also Send Feedback
Gets the Viewport in which the current preview is drawn.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
RhinoViewport Viewport { get; }
Visual Basic
ReadOnly Property Viewport As RhinoViewport
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_PreviewArgs.Viewport"]

See Also

IGH_PreviewArgs Interface
Grasshopper.Kernel Namespace


WireColour Property

[image]

Grasshopper SDK
IGH_PreviewArgs..::..WireColour Property
IGH_PreviewArgs Interface See Also Send Feedback
Gets the document default colour for unselected Wires.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
Color WireColour { get; }
Visual Basic
ReadOnly Property WireColour As Color
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_PreviewArgs.WireColour"]

See Also

IGH_PreviewArgs Interface
Grasshopper.Kernel Namespace


WireColour_Selected Property

[image]

Grasshopper SDK
IGH_PreviewArgs..::..WireColour_Selected Property
IGH_PreviewArgs Interface See Also Send Feedback
Gets the document default colour for selected Wires.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
Color WireColour_Selected { get; }
Visual Basic
ReadOnly Property WireColour_Selected As Color
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_PreviewArgs.WireColour_Selected"]

See Also

IGH_PreviewArgs Interface
Grasshopper.Kernel Namespace


IGH_PreviewData Interface

[image]

Grasshopper SDK
IGH_PreviewData Interface
Members See Also Send Feedback
All IGH_Goo types that wish to participate in Viewport redraws must implement this interface.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_PreviewData
Visual Basic
Public Interface IGH_PreviewData

See Also

IGH_PreviewData Members
Grasshopper.Kernel Namespace


IGH_PreviewData Members

[image] [image]

Grasshopper SDK
IGH_PreviewData Members
IGH_PreviewData Interface Methods Properties See Also Send Feedback

The IGH_PreviewData type exposes the following members.

Methods

 | Name | Description
Public method | DrawViewportMeshes | Implement this function to draw all shaded meshes. If the viewport does not support shading, this function will not be called.
Public method | DrawViewportWires | Implement this function to draw all wire and point previews.

Properties

 | Name | Description
Public property | ClippingBox | Gets the clipping box for this data. The clipping box is typically the same as the boundingbox.

See Also

IGH_PreviewData Interface
Grasshopper.Kernel Namespace


IGH_PreviewData Methods

[image] [image]

Grasshopper SDK
IGH_PreviewData Methods
IGH_PreviewData Interface See Also Send Feedback

The IGH_PreviewData type exposes the following members.

Methods

 | Name | Description
Public method | DrawViewportMeshes | Implement this function to draw all shaded meshes. If the viewport does not support shading, this function will not be called.
Public method | DrawViewportWires | Implement this function to draw all wire and point previews.

See Also

IGH_PreviewData Interface
Grasshopper.Kernel Namespace


DrawViewportMeshes Method

[image]

Grasshopper SDK
IGH_PreviewData..::..DrawViewportMeshes Method
IGH_PreviewData Interface See Also Send Feedback
Implement this function to draw all shaded meshes. If the viewport does not support shading, this function will not be called.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void DrawViewportMeshes(
    GH_PreviewMeshArgs args
)
Visual Basic
Sub DrawViewportMeshes ( _
    args As GH_PreviewMeshArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..GH_PreviewMeshArgs
Drawing arguments.

See Also

IGH_PreviewData Interface
Grasshopper.Kernel Namespace


DrawViewportWires Method

[image]

Grasshopper SDK
IGH_PreviewData..::..DrawViewportWires Method
IGH_PreviewData Interface See Also Send Feedback
Implement this function to draw all wire and point previews.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void DrawViewportWires(
    GH_PreviewWireArgs args
)
Visual Basic
Sub DrawViewportWires ( _
    args As GH_PreviewWireArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..GH_PreviewWireArgs
Drawing arguments.

See Also

IGH_PreviewData Interface
Grasshopper.Kernel Namespace


IGH_PreviewData Properties

[image] [image]

Grasshopper SDK
IGH_PreviewData Properties
IGH_PreviewData Interface See Also Send Feedback

The IGH_PreviewData type exposes the following members.

Properties

 | Name | Description
Public property | ClippingBox | Gets the clipping box for this data. The clipping box is typically the same as the boundingbox.

See Also

IGH_PreviewData Interface
Grasshopper.Kernel Namespace


ClippingBox Property

[image]

Grasshopper SDK
IGH_PreviewData..::..ClippingBox Property
IGH_PreviewData Interface See Also Send Feedback
Gets the clipping box for this data. The clipping box is typically the same as the boundingbox.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
BoundingBox ClippingBox { get; }
Visual Basic
ReadOnly Property ClippingBox As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_PreviewData.ClippingBox"]

Return Value

The clipping box for this object.

See Also

IGH_PreviewData Interface
Grasshopper.Kernel Namespace


IGH_PreviewMeshData Interface

[image]

Grasshopper SDK
IGH_PreviewMeshData Interface
Members See Also Send Feedback
Implement this interface if your data deals with preview meshes.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_PreviewMeshData
Visual Basic
Public Interface IGH_PreviewMeshData

See Also

IGH_PreviewMeshData Members
Grasshopper.Kernel Namespace


IGH_PreviewMeshData Members

[image] [image]

Grasshopper SDK
IGH_PreviewMeshData Members
IGH_PreviewMeshData Interface Methods See Also Send Feedback

The IGH_PreviewMeshData type exposes the following members.

Methods

 | Name | Description
Public method | DestroyPreviewMeshes | Erase all cached preview meshes.
Public method | GetPreviewMeshes | Gets all the preview meshes associated with this data.

See Also

IGH_PreviewMeshData Interface
Grasshopper.Kernel Namespace


IGH_PreviewMeshData Methods

[image] [image]

Grasshopper SDK
IGH_PreviewMeshData Methods
IGH_PreviewMeshData Interface See Also Send Feedback

The IGH_PreviewMeshData type exposes the following members.

Methods

 | Name | Description
Public method | DestroyPreviewMeshes | Erase all cached preview meshes.
Public method | GetPreviewMeshes | Gets all the preview meshes associated with this data.

See Also

IGH_PreviewMeshData Interface
Grasshopper.Kernel Namespace


DestroyPreviewMeshes Method

[image]

Grasshopper SDK
IGH_PreviewMeshData..::..DestroyPreviewMeshes Method
IGH_PreviewMeshData Interface See Also Send Feedback
Erase all cached preview meshes.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void DestroyPreviewMeshes()
Visual Basic
Sub DestroyPreviewMeshes

See Also

IGH_PreviewMeshData Interface
Grasshopper.Kernel Namespace


GetPreviewMeshes Method

[image]

Grasshopper SDK
IGH_PreviewMeshData..::..GetPreviewMeshes Method
IGH_PreviewMeshData Interface See Also Send Feedback
Gets all the preview meshes associated with this data.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
Mesh[] GetPreviewMeshes()
Visual Basic
Function GetPreviewMeshes As Mesh()

Return Value

An array of meshes that represent the preview meshes of this data.

See Also

IGH_PreviewMeshData Interface
Grasshopper.Kernel Namespace


IGH_PreviewObject Interface

[image]

Grasshopper SDK
IGH_PreviewObject Interface
Members See Also Send Feedback
All IGH_DocumentObjects that wish to participate in Viewport redraws must implement this interface.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_PreviewObject
Visual Basic
Public Interface IGH_PreviewObject

See Also

IGH_PreviewObject Members
Grasshopper.Kernel Namespace


IGH_PreviewObject Members

[image] [image]

Grasshopper SDK
IGH_PreviewObject Members
IGH_PreviewObject Interface Methods Properties See Also Send Feedback

The IGH_PreviewObject type exposes the following members.

Methods

 | Name | Description
Public method | DrawViewportMeshes | Implement this function to draw all shaded meshes. If the viewport does not support shading, this function will not be called.
Public method | DrawViewportWires | Implement this function to draw all wire and point geometry previews.

Properties

 | Name | Description
Public property | ClippingBox | Gets the clipping box for this object. The clipping box is typically the union of the boundingboxes of all the geometry that is drawn by this object.
Public property | Hidden | Gets or sets a value indicating whether or not this object is currently drawing preview flags.
Public property | IsPreviewCapable | Gets a value indicating whether or not this object (in its current state) can draw geometric previews at all.

See Also

IGH_PreviewObject Interface
Grasshopper.Kernel Namespace


IGH_PreviewObject Methods

[image] [image]

Grasshopper SDK
IGH_PreviewObject Methods
IGH_PreviewObject Interface See Also Send Feedback

The IGH_PreviewObject type exposes the following members.

Methods

 | Name | Description
Public method | DrawViewportMeshes | Implement this function to draw all shaded meshes. If the viewport does not support shading, this function will not be called.
Public method | DrawViewportWires | Implement this function to draw all wire and point geometry previews.

See Also

IGH_PreviewObject Interface
Grasshopper.Kernel Namespace


DrawViewportMeshes Method

[image]

Grasshopper SDK
IGH_PreviewObject..::..DrawViewportMeshes Method
IGH_PreviewObject Interface See Also Send Feedback
Implement this function to draw all shaded meshes. If the viewport does not support shading, this function will not be called.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void DrawViewportMeshes(
    IGH_PreviewArgs args
)
Visual Basic
Sub DrawViewportMeshes ( _
    args As IGH_PreviewArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..IGH_PreviewArgs
Draw operation arguments.

See Also

IGH_PreviewObject Interface
Grasshopper.Kernel Namespace


DrawViewportWires Method

[image]

Grasshopper SDK
IGH_PreviewObject..::..DrawViewportWires Method
IGH_PreviewObject Interface See Also Send Feedback
Implement this function to draw all wire and point geometry previews.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void DrawViewportWires(
    IGH_PreviewArgs args
)
Visual Basic
Sub DrawViewportWires ( _
    args As IGH_PreviewArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..IGH_PreviewArgs
Draw operation arguments.

See Also

IGH_PreviewObject Interface
Grasshopper.Kernel Namespace


IGH_PreviewObject Properties

[image] [image]

Grasshopper SDK
IGH_PreviewObject Properties
IGH_PreviewObject Interface See Also Send Feedback

The IGH_PreviewObject type exposes the following members.

Properties

 | Name | Description
Public property | ClippingBox | Gets the clipping box for this object. The clipping box is typically the union of the boundingboxes of all the geometry that is drawn by this object.
Public property | Hidden | Gets or sets a value indicating whether or not this object is currently drawing preview flags.
Public property | IsPreviewCapable | Gets a value indicating whether or not this object (in its current state) can draw geometric previews at all.

See Also

IGH_PreviewObject Interface
Grasshopper.Kernel Namespace


ClippingBox Property

[image]

Grasshopper SDK
IGH_PreviewObject..::..ClippingBox Property
IGH_PreviewObject Interface See Also Send Feedback
Gets the clipping box for this object. The clipping box is typically the union of the boundingboxes of all the geometry that is drawn by this object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
BoundingBox ClippingBox { get; }
Visual Basic
ReadOnly Property ClippingBox As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_PreviewObject.ClippingBox"]

Return Value

The clipping box for this object.

See Also

IGH_PreviewObject Interface
Grasshopper.Kernel Namespace


Hidden Property

[image]

Grasshopper SDK
IGH_PreviewObject..::..Hidden Property
IGH_PreviewObject Interface See Also Send Feedback
Gets or sets a value indicating whether or not this object is currently drawing preview flags.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool Hidden { get; set; }
Visual Basic
Property Hidden As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_PreviewObject.Hidden"]

See Also

IGH_PreviewObject Interface
Grasshopper.Kernel Namespace


IsPreviewCapable Property

[image]

Grasshopper SDK
IGH_PreviewObject..::..IsPreviewCapable Property
IGH_PreviewObject Interface See Also Send Feedback
Gets a value indicating whether or not this object (in its current state) can draw geometric previews at all.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool IsPreviewCapable { get; }
Visual Basic
ReadOnly Property IsPreviewCapable As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_PreviewObject.IsPreviewCapable"]

See Also

IGH_PreviewObject Interface
Grasshopper.Kernel Namespace


IGH_RCP_Aware Interface

[image]

Grasshopper SDK
IGH_RCP_Aware Interface
Members See Also Send Feedback
Implement this interface if you want to become part of the RemoteControlPanel.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_RCP_Aware
Visual Basic
Public Interface IGH_RCP_Aware

See Also

IGH_RCP_Aware Members
Grasshopper.Kernel Namespace


IGH_RCP_Aware Members

[image] [image]

Grasshopper SDK
IGH_RCP_Aware Members
IGH_RCP_Aware Interface Methods See Also Send Feedback

The IGH_RCP_Aware type exposes the following members.

Methods

 | Name | Description
Public method | Publish | Create a new proxy object which will become part of a Remote Panel.

See Also

IGH_RCP_Aware Interface
Grasshopper.Kernel Namespace


IGH_RCP_Aware Methods

[image] [image]

Grasshopper SDK
IGH_RCP_Aware Methods
IGH_RCP_Aware Interface See Also Send Feedback

The IGH_RCP_Aware type exposes the following members.

Methods

 | Name | Description
Public method | Publish | Create a new proxy object which will become part of a Remote Panel.

See Also

IGH_RCP_Aware Interface
Grasshopper.Kernel Namespace


Publish Method

[image]

Grasshopper SDK
IGH_RCP_Aware..::..Publish Method
IGH_RCP_Aware Interface See Also Send Feedback
Create a new proxy object which will become part of a Remote Panel.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
GH_Node Publish(
    IGH_ParentControl frontend
)
Visual Basic
Function Publish ( _
    frontend As IGH_ParentControl _
) As GH_Node

Parameters

frontend
Type: IGH_ParentControl

See Also

IGH_RCP_Aware Interface
Grasshopper.Kernel Namespace


IGH_StateAwareObject Interface

[image]

Grasshopper SDK
IGH_StateAwareObject Interface
Members See Also Send Feedback
Implement this interface if you want to be included in state saving/loading.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_StateAwareObject
Visual Basic
Public Interface IGH_StateAwareObject

See Also

IGH_StateAwareObject Members
Grasshopper.Kernel Namespace


IGH_StateAwareObject Members

[image] [image]

Grasshopper SDK
IGH_StateAwareObject Members
IGH_StateAwareObject Interface Methods See Also Send Feedback

The IGH_StateAwareObject type exposes the following members.

Methods

 | Name | Description
Public method | LoadState | Override this function to load your state data. DO NOT START A NEW SOLUTION. This will be handled by the state manager.
Public method | SaveState | Override this function to store your state data. You have to return a deserializable string.

See Also

IGH_StateAwareObject Interface
Grasshopper.Kernel Namespace


IGH_StateAwareObject Methods

[image] [image]

Grasshopper SDK
IGH_StateAwareObject Methods
IGH_StateAwareObject Interface See Also Send Feedback

The IGH_StateAwareObject type exposes the following members.

Methods

 | Name | Description
Public method | LoadState | Override this function to load your state data. DO NOT START A NEW SOLUTION. This will be handled by the state manager.
Public method | SaveState | Override this function to store your state data. You have to return a deserializable string.

See Also

IGH_StateAwareObject Interface
Grasshopper.Kernel Namespace


LoadState Method

[image]

Grasshopper SDK
IGH_StateAwareObject..::..LoadState Method
IGH_StateAwareObject Interface See Also Send Feedback
Override this function to load your state data. DO NOT START A NEW SOLUTION. This will be handled by the state manager.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void LoadState(
    string state
)
Visual Basic
Sub LoadState ( _
    state As String _
)

Parameters

state
Type: System..::..String

See Also

IGH_StateAwareObject Interface
Grasshopper.Kernel Namespace


SaveState Method

[image]

Grasshopper SDK
IGH_StateAwareObject..::..SaveState Method
IGH_StateAwareObject Interface See Also Send Feedback
Override this function to store your state data. You have to return a deserializable string.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string SaveState()
Visual Basic
Function SaveState As String

See Also

IGH_StateAwareObject Interface
Grasshopper.Kernel Namespace


IGH_StateTag Interface

[image]

Grasshopper SDK
IGH_StateTag Interface
Members See Also Send Feedback
A StateTag is a visual feedback mechanism that reflects a certain local setting of an Object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_StateTag
Visual Basic
Public Interface IGH_StateTag

See Also

IGH_StateTag Members
Grasshopper.Kernel Namespace


IGH_StateTag Members

[image] [image]

Grasshopper SDK
IGH_StateTag Members
IGH_StateTag Interface Methods Properties See Also Send Feedback

The IGH_StateTag type exposes the following members.

Methods

 | Name | Description
Public method | Render | Render this tag into a graphics surface.

Properties

 | Name | Description
Public property | Description | Gets the description of this state tag.
Public property | Icon | Gets the 16 by 16 pixel icon associated with this state tag.
Public property | Name | Gets the name field of this state tag.
Public property | Stage | Gets or sets the Stage rectangle for this state tag. Stages are assigned during Attribute Layout operations by owner objects.
Public property | StateDescription | Gets or sets the state description of this tag. The state description appears in the Tooltip info field.

See Also

IGH_StateTag Interface
Grasshopper.Kernel Namespace


IGH_StateTag Methods

[image] [image]

Grasshopper SDK
IGH_StateTag Methods
IGH_StateTag Interface See Also Send Feedback

The IGH_StateTag type exposes the following members.

Methods

 | Name | Description
Public method | Render | Render this tag into a graphics surface.

See Also

IGH_StateTag Interface
Grasshopper.Kernel Namespace


Render Method

[image]

Grasshopper SDK
IGH_StateTag..::..Render Method
IGH_StateTag Interface See Also Send Feedback
Render this tag into a graphics surface.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void Render(
    Graphics graphics
)
Visual Basic
Sub Render ( _
    graphics As Graphics _
)

Parameters

graphics
Type: System.Drawing..::..Graphics
Graphics object to draw to.

See Also

IGH_StateTag Interface
Grasshopper.Kernel Namespace


IGH_StateTag Properties

[image] [image]

Grasshopper SDK
IGH_StateTag Properties
IGH_StateTag Interface See Also Send Feedback

The IGH_StateTag type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets the description of this state tag.
Public property | Icon | Gets the 16 by 16 pixel icon associated with this state tag.
Public property | Name | Gets the name field of this state tag.
Public property | Stage | Gets or sets the Stage rectangle for this state tag. Stages are assigned during Attribute Layout operations by owner objects.
Public property | StateDescription | Gets or sets the state description of this tag. The state description appears in the Tooltip info field.

See Also

IGH_StateTag Interface
Grasshopper.Kernel Namespace


Description Property

[image]

Grasshopper SDK
IGH_StateTag..::..Description Property
IGH_StateTag Interface See Also Send Feedback
Gets the description of this state tag.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string Description { get; }
Visual Basic
ReadOnly Property Description As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_StateTag.Description"]

See Also

IGH_StateTag Interface
Grasshopper.Kernel Namespace


Icon Property

[image]

Grasshopper SDK
IGH_StateTag..::..Icon Property
IGH_StateTag Interface See Also Send Feedback
Gets the 16 by 16 pixel icon associated with this state tag.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
Bitmap Icon { get; }
Visual Basic
ReadOnly Property Icon As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_StateTag.Icon"]

See Also

IGH_StateTag Interface
Grasshopper.Kernel Namespace


Name Property

[image]

Grasshopper SDK
IGH_StateTag..::..Name Property
IGH_StateTag Interface See Also Send Feedback
Gets the name field of this state tag.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string Name { get; }
Visual Basic
ReadOnly Property Name As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_StateTag.Name"]

See Also

IGH_StateTag Interface
Grasshopper.Kernel Namespace


Stage Property

[image]

Grasshopper SDK
IGH_StateTag..::..Stage Property
IGH_StateTag Interface See Also Send Feedback
Gets or sets the Stage rectangle for this state tag. Stages are assigned during Attribute Layout operations by owner objects.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
Rectangle Stage { get; set; }
Visual Basic
Property Stage As Rectangle
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_StateTag.Stage"]

See Also

IGH_StateTag Interface
Grasshopper.Kernel Namespace


StateDescription Property

[image]

Grasshopper SDK
IGH_StateTag..::..StateDescription Property
IGH_StateTag Interface See Also Send Feedback
Gets or sets the state description of this tag. The state description appears in the Tooltip info field.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string StateDescription { get; set; }
Visual Basic
Property StateDescription As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_StateTag.StateDescription"]

See Also

IGH_StateTag Interface
Grasshopper.Kernel Namespace


IGH_UpgradeObject Interface

[image]

Grasshopper SDK
IGH_UpgradeObject Interface
Members See Also Send Feedback
Create a class with an empty constructor that implements this interface if you want to provide an upgrade mechanism.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_UpgradeObject
Visual Basic
Public Interface IGH_UpgradeObject

See Also

IGH_UpgradeObject Members
Grasshopper.Kernel Namespace


IGH_UpgradeObject Members

[image] [image]

Grasshopper SDK
IGH_UpgradeObject Members
IGH_UpgradeObject Interface Methods Properties See Also Send Feedback

The IGH_UpgradeObject type exposes the following members.

Methods

 | Name | Description
Public method | Upgrade | Upgrade an existing object.

Properties

 | Name | Description
Public property | UpgradeFrom | Gets the ComponentGuid of the old object (the object to be updated).
Public property | UpgradeTo | Gets the ComponentGuid of the new object (the object that will be inserted).
Public property | Version | Return a DateTime object that indicates when this upgrade mechanism was written, so that it becomes possible to distinguish competing upgrade mechanisms.

See Also

IGH_UpgradeObject Interface
Grasshopper.Kernel Namespace


IGH_UpgradeObject Methods

[image] [image]

Grasshopper SDK
IGH_UpgradeObject Methods
IGH_UpgradeObject Interface See Also Send Feedback

The IGH_UpgradeObject type exposes the following members.

Methods

 | Name | Description
Public method | Upgrade | Upgrade an existing object.

See Also

IGH_UpgradeObject Interface
Grasshopper.Kernel Namespace


Upgrade Method

[image]

Grasshopper SDK
IGH_UpgradeObject..::..Upgrade Method
IGH_UpgradeObject Interface See Also Send Feedback
Upgrade an existing object.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
IGH_DocumentObject Upgrade(
    IGH_DocumentObject target,
    GH_Document document
)
Visual Basic
Function Upgrade ( _
    target As IGH_DocumentObject, _
    document As GH_Document _
) As IGH_DocumentObject

Parameters

target
Type: Grasshopper.Kernel..::..IGH_DocumentObject
Object to upgrade.
document
Type: Grasshopper.Kernel..::..GH_Document
Document that contains the object.

Return Value

The newly created object on success, null on failure.

See Also

IGH_UpgradeObject Interface
Grasshopper.Kernel Namespace


IGH_UpgradeObject Properties

[image] [image]

Grasshopper SDK
IGH_UpgradeObject Properties
IGH_UpgradeObject Interface See Also Send Feedback

The IGH_UpgradeObject type exposes the following members.

Properties

 | Name | Description
Public property | UpgradeFrom | Gets the ComponentGuid of the old object (the object to be updated).
Public property | UpgradeTo | Gets the ComponentGuid of the new object (the object that will be inserted).
Public property | Version | Return a DateTime object that indicates when this upgrade mechanism was written, so that it becomes possible to distinguish competing upgrade mechanisms.

See Also

IGH_UpgradeObject Interface
Grasshopper.Kernel Namespace


UpgradeFrom Property

[image]

Grasshopper SDK
IGH_UpgradeObject..::..UpgradeFrom Property
IGH_UpgradeObject Interface See Also Send Feedback
Gets the ComponentGuid of the old object (the object to be updated).

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
Guid UpgradeFrom { get; }
Visual Basic
ReadOnly Property UpgradeFrom As Guid
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_UpgradeObject.UpgradeFrom"]

See Also

IGH_UpgradeObject Interface
Grasshopper.Kernel Namespace


UpgradeTo Property

[image]

Grasshopper SDK
IGH_UpgradeObject..::..UpgradeTo Property
IGH_UpgradeObject Interface See Also Send Feedback
Gets the ComponentGuid of the new object (the object that will be inserted).

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
Guid UpgradeTo { get; }
Visual Basic
ReadOnly Property UpgradeTo As Guid
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_UpgradeObject.UpgradeTo"]

See Also

IGH_UpgradeObject Interface
Grasshopper.Kernel Namespace


Version Property

[image]

Grasshopper SDK
IGH_UpgradeObject..::..Version Property
IGH_UpgradeObject Interface See Also Send Feedback
Return a DateTime object that indicates when this upgrade mechanism was written, so that it becomes possible to distinguish competing upgrade mechanisms.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
DateTime Version { get; }
Visual Basic
ReadOnly Property Version As DateTime
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_UpgradeObject.Version"]

See Also

IGH_UpgradeObject Interface
Grasshopper.Kernel Namespace


IGH_UserPromptAware Interface

[image]

Grasshopper SDK
IGH_UserPromptAware Interface
Members See Also Send Feedback
Implement this interface in your IGH_Param if you want to allow users to set data either through the menu or by double clicking.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_UserPromptAware
Visual Basic
Public Interface IGH_UserPromptAware

See Also

IGH_UserPromptAware Members
Grasshopper.Kernel Namespace


IGH_UserPromptAware Members

[image] [image]

Grasshopper SDK
IGH_UserPromptAware Members
IGH_UserPromptAware Interface Methods See Also Send Feedback

The IGH_UserPromptAware type exposes the following members.

Methods

 | Name | Description
Public method | PromptMenuMultipleItems | Create a menu item that will be inserted into the Parameter context menu for getting multiple values.
Public method | PromptMenuSingleItem | Create a menu item that will be inserted into the Parameter context menu for getting single values.
Public method | PromptMultipleItems | Get multiple items from the user.
Public method | PromptSingleItem | Get a single item from the user.

See Also

IGH_UserPromptAware Interface
Grasshopper.Kernel Namespace


IGH_UserPromptAware Methods

[image] [image]

Grasshopper SDK
IGH_UserPromptAware Methods
IGH_UserPromptAware Interface See Also Send Feedback

The IGH_UserPromptAware type exposes the following members.

Methods

 | Name | Description
Public method | PromptMenuMultipleItems | Create a menu item that will be inserted into the Parameter context menu for getting multiple values.
Public method | PromptMenuSingleItem | Create a menu item that will be inserted into the Parameter context menu for getting single values.
Public method | PromptMultipleItems | Get multiple items from the user.
Public method | PromptSingleItem | Get a single item from the user.

See Also

IGH_UserPromptAware Interface
Grasshopper.Kernel Namespace


PromptMenuMultipleItems Method

[image]

Grasshopper SDK
IGH_UserPromptAware..::..PromptMenuMultipleItems Method
IGH_UserPromptAware Interface See Also Send Feedback
Create a menu item that will be inserted into the Parameter context menu for getting multiple values.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
ToolStripMenuItem PromptMenuMultipleItems()
Visual Basic
Function PromptMenuMultipleItems As ToolStripMenuItem

See Also

IGH_UserPromptAware Interface
Grasshopper.Kernel Namespace


PromptMenuSingleItem Method

[image]

Grasshopper SDK
IGH_UserPromptAware..::..PromptMenuSingleItem Method
IGH_UserPromptAware Interface See Also Send Feedback
Create a menu item that will be inserted into the Parameter context menu for getting single values.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
ToolStripMenuItem PromptMenuSingleItem()
Visual Basic
Function PromptMenuSingleItem As ToolStripMenuItem

See Also

IGH_UserPromptAware Interface
Grasshopper.Kernel Namespace


PromptMultipleItems Method

[image]

Grasshopper SDK
IGH_UserPromptAware..::..PromptMultipleItems Method
IGH_UserPromptAware Interface See Also Send Feedback
Get multiple items from the user.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
IGH_Structure PromptMultipleItems()
Visual Basic
Function PromptMultipleItems As IGH_Structure

Return Value

A data tree of items if successful or nothing on abort/failure.

See Also

IGH_UserPromptAware Interface
Grasshopper.Kernel Namespace


PromptSingleItem Method

[image]

Grasshopper SDK
IGH_UserPromptAware..::..PromptSingleItem Method
IGH_UserPromptAware Interface See Also Send Feedback
Get a single item from the user.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
IGH_Goo PromptSingleItem()
Visual Basic
Function PromptSingleItem As IGH_Goo

Return Value

The item if successful or nothing on abort/failure.

See Also

IGH_UserPromptAware Interface
Grasshopper.Kernel Namespace


IGH_ValueProxy Interface

[image]

Grasshopper SDK
IGH_ValueProxy Interface
Members See Also Send Feedback

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_ValueProxy
Visual Basic
Public Interface IGH_ValueProxy

See Also

IGH_ValueProxy Members
Grasshopper.Kernel Namespace


IGH_ValueProxy Members

[image] [image]

Grasshopper SDK
IGH_ValueProxy Members
IGH_ValueProxy Interface Methods Properties See Also Send Feedback

The IGH_ValueProxy type exposes the following members.

Methods

 | Name | Description
Public method | Duplicate | Create an exact duplicate of the type.
Public method | FromString | If IsParsable(), then attempts to convert the string to a generic type value
Public method | MutateString | Munge a string to remove obvious errors on account of the user.
Public method | ToString | Returns a String description of the current value.

Properties

 | Name | Description
Public property | IsParsable | Gets a value indicating whether or not the type can be instantiated from a String
Public property | IsValid | Gets a value indicating whether or not the current value is valid
Public property | ProxyName | Gets a human-friendly name description of the template type
Public property | ProxyType | Gets the System.Type description of the template type
Public property | ProxyValue | Gets an instance of the local template type object
Public property | UserString | Gets or sets the user-defined string that describes this proxy This only really makes sense if the Proxy is Parsable.

See Also

IGH_ValueProxy Interface
Grasshopper.Kernel Namespace


IGH_ValueProxy Methods

[image] [image]

Grasshopper SDK
IGH_ValueProxy Methods
IGH_ValueProxy Interface See Also Send Feedback

The IGH_ValueProxy type exposes the following members.

Methods

 | Name | Description
Public method | Duplicate | Create an exact duplicate of the type.
Public method | FromString | If IsParsable(), then attempts to convert the string to a generic type value
Public method | MutateString | Munge a string to remove obvious errors on account of the user.
Public method | ToString | Returns a String description of the current value.

See Also

IGH_ValueProxy Interface
Grasshopper.Kernel Namespace


Duplicate Method

[image]

Grasshopper SDK
IGH_ValueProxy..::..Duplicate Method
IGH_ValueProxy Interface See Also Send Feedback
Create an exact duplicate of the type.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
IGH_ValueProxy Duplicate()
Visual Basic
Function Duplicate As IGH_ValueProxy

Remarks

Implementors: Do not maintain references to class instances. Copy EVERYTHING.

See Also

IGH_ValueProxy Interface
Grasshopper.Kernel Namespace


FromString Method

[image]

Grasshopper SDK
IGH_ValueProxy..::..FromString Method
IGH_ValueProxy Interface See Also Send Feedback
If IsParsable(), then attempts to convert the string to a generic type value

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool FromString(
    string in
)
Visual Basic
Function FromString ( _
    in As String _
) As Boolean

Parameters

in
Type: System..::..String
The String to parse

Return Value

True on success, false on failure. This method should not throw exceptions.

See Also

IGH_ValueProxy Interface
Grasshopper.Kernel Namespace


MutateString Method

[image]

Grasshopper SDK
IGH_ValueProxy..::..MutateString Method
IGH_ValueProxy Interface See Also Send Feedback
Munge a string to remove obvious errors on account of the user.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string MutateString(
    string in
)
Visual Basic
Function MutateString ( _
    in As String _
) As String

Parameters

in
Type: System..::..String

Return Value

See Also

IGH_ValueProxy Interface
Grasshopper.Kernel Namespace


ToString Method

[image]

Grasshopper SDK
IGH_ValueProxy..::..ToString Method
IGH_ValueProxy Interface See Also Send Feedback
Returns a String description of the current value.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string ToString()
Visual Basic
Function ToString As String

Remarks

If the implementation IsParsable(), then this representation must be in parsable format.

See Also

IGH_ValueProxy Interface
Grasshopper.Kernel Namespace


IGH_ValueProxy Properties

[image] [image]

Grasshopper SDK
IGH_ValueProxy Properties
IGH_ValueProxy Interface See Also Send Feedback

The IGH_ValueProxy type exposes the following members.

Properties

 | Name | Description
Public property | IsParsable | Gets a value indicating whether or not the type can be instantiated from a String
Public property | IsValid | Gets a value indicating whether or not the current value is valid
Public property | ProxyName | Gets a human-friendly name description of the template type
Public property | ProxyType | Gets the System.Type description of the template type
Public property | ProxyValue | Gets an instance of the local template type object
Public property | UserString | Gets or sets the user-defined string that describes this proxy This only really makes sense if the Proxy is Parsable.

See Also

IGH_ValueProxy Interface
Grasshopper.Kernel Namespace


IsParsable Property

[image]

Grasshopper SDK
IGH_ValueProxy..::..IsParsable Property
IGH_ValueProxy Interface See Also Send Feedback
Gets a value indicating whether or not the type can be instantiated from a String

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool IsParsable { get; }
Visual Basic
ReadOnly Property IsParsable As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_ValueProxy.IsParsable"]

See Also

IGH_ValueProxy Interface
Grasshopper.Kernel Namespace


IsValid Property

[image]

Grasshopper SDK
IGH_ValueProxy..::..IsValid Property
IGH_ValueProxy Interface See Also Send Feedback
Gets a value indicating whether or not the current value is valid

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool IsValid { get; }
Visual Basic
ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_ValueProxy.IsValid"]

See Also

IGH_ValueProxy Interface
Grasshopper.Kernel Namespace


ProxyName Property

[image]

Grasshopper SDK
IGH_ValueProxy..::..ProxyName Property
IGH_ValueProxy Interface See Also Send Feedback
Gets a human-friendly name description of the template type

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string ProxyName { get; }
Visual Basic
ReadOnly Property ProxyName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_ValueProxy.ProxyName"]

See Also

IGH_ValueProxy Interface
Grasshopper.Kernel Namespace


ProxyType Property

[image]

Grasshopper SDK
IGH_ValueProxy..::..ProxyType Property
IGH_ValueProxy Interface See Also Send Feedback
Gets the System.Type description of the template type

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
Type ProxyType { get; }
Visual Basic
ReadOnly Property ProxyType As Type
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_ValueProxy.ProxyType"]

See Also

IGH_ValueProxy Interface
Grasshopper.Kernel Namespace


ProxyValue Property

[image]

Grasshopper SDK
IGH_ValueProxy..::..ProxyValue Property
IGH_ValueProxy Interface See Also Send Feedback
Gets an instance of the local template type object

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
Object ProxyValue { get; }
Visual Basic
ReadOnly Property ProxyValue As Object
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_ValueProxy.ProxyValue"]

See Also

IGH_ValueProxy Interface
Grasshopper.Kernel Namespace


UserString Property

[image]

Grasshopper SDK
IGH_ValueProxy..::..UserString Property
IGH_ValueProxy Interface See Also Send Feedback
Gets or sets the user-defined string that describes this proxy This only really makes sense if the Proxy is Parsable.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string UserString { get; set; }
Visual Basic
Property UserString As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_ValueProxy.UserString"]

Return Value

If the proxy contains no user-string, the ToString result is returned instead

See Also

IGH_ValueProxy Interface
Grasshopper.Kernel Namespace


IGH_VariableParameterComponent Interface

[image]

Grasshopper SDK
IGH_VariableParameterComponent Interface
Members See Also Send Feedback
Implement this interface in your component if you want to enable variable parameter UI.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_VariableParameterComponent
Visual Basic
Public Interface IGH_VariableParameterComponent

See Also

IGH_VariableParameterComponent Members
Grasshopper.Kernel Namespace


IGH_VariableParameterComponent Members

[image] [image]

Grasshopper SDK
IGH_VariableParameterComponent Members
IGH_VariableParameterComponent Interface Methods See Also Send Feedback

The IGH_VariableParameterComponent type exposes the following members.

Methods

 | Name | Description
Public method | CanInsertParameter | This function will get called before an attempt is made to insert a parameter. Since this method is potentially called on Canvas redraws, it must be fast.
Public method | CanRemoveParameter | This function will get called before an attempt is made to remove a parameter. Since this method is potentially called on Canvas redraws, it must be fast.
Public method | CreateParameter | This function will be called when a new parameter is about to be inserted. You must provide a valid parameter or insertion will be skipped. You do not, repeat not, need to insert the parameter yourself.
Public method | DestroyParameter | This function will be called when a parameter is about to be removed. You do not need to do anything, but this would be a good time to remove any event handlers that might be attached to the parameter in question.
Public method | VariableParameterMaintenance | This method will be called when a closely related set of variable parameter operations completes. This would be a good time to ensure all Nicknames and parameter properties are correct. This method will also be called upon IO operations such as Open, Paste, Undo and Redo.

See Also

IGH_VariableParameterComponent Interface
Grasshopper.Kernel Namespace


IGH_VariableParameterComponent Methods

[image] [image]

Grasshopper SDK
IGH_VariableParameterComponent Methods
IGH_VariableParameterComponent Interface See Also Send Feedback

The IGH_VariableParameterComponent type exposes the following members.

Methods

 | Name | Description
Public method | CanInsertParameter | This function will get called before an attempt is made to insert a parameter. Since this method is potentially called on Canvas redraws, it must be fast.
Public method | CanRemoveParameter | This function will get called before an attempt is made to remove a parameter. Since this method is potentially called on Canvas redraws, it must be fast.
Public method | CreateParameter | This function will be called when a new parameter is about to be inserted. You must provide a valid parameter or insertion will be skipped. You do not, repeat not, need to insert the parameter yourself.
Public method | DestroyParameter | This function will be called when a parameter is about to be removed. You do not need to do anything, but this would be a good time to remove any event handlers that might be attached to the parameter in question.
Public method | VariableParameterMaintenance | This method will be called when a closely related set of variable parameter operations completes. This would be a good time to ensure all Nicknames and parameter properties are correct. This method will also be called upon IO operations such as Open, Paste, Undo and Redo.

See Also

IGH_VariableParameterComponent Interface
Grasshopper.Kernel Namespace


CanInsertParameter Method

[image]

Grasshopper SDK
IGH_VariableParameterComponent..::..CanInsertParameter Method
IGH_VariableParameterComponent Interface See Also Send Feedback
This function will get called before an attempt is made to insert a parameter. Since this method is potentially called on Canvas redraws, it must be fast.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool CanInsertParameter(
    GH_ParameterSide side,
    int index
)
Visual Basic
Function CanInsertParameter ( _
    side As GH_ParameterSide, _
    index As Integer _
) As Boolean

Parameters

side
Type: Grasshopper.Kernel..::..GH_ParameterSide
Parameter side.
index
Type: System..::..Int32
Insertion index of parameter. Index=0 means the parameter will be in the topmost spot.

Return Value

Return True if your component supports a variable parameter at the given location.

See Also

IGH_VariableParameterComponent Interface
Grasshopper.Kernel Namespace


CanRemoveParameter Method

[image]

Grasshopper SDK
IGH_VariableParameterComponent..::..CanRemoveParameter Method
IGH_VariableParameterComponent Interface See Also Send Feedback
This function will get called before an attempt is made to remove a parameter. Since this method is potentially called on Canvas redraws, it must be fast.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool CanRemoveParameter(
    GH_ParameterSide side,
    int index
)
Visual Basic
Function CanRemoveParameter ( _
    side As GH_ParameterSide, _
    index As Integer _
) As Boolean

Parameters

side
Type: Grasshopper.Kernel..::..GH_ParameterSide
Parameter side.
index
Type: System..::..Int32
Removal index of parameter.

Return Value

Return True if your component supports removing a parameter at the given location.

See Also

IGH_VariableParameterComponent Interface
Grasshopper.Kernel Namespace


CreateParameter Method

[image]

Grasshopper SDK
IGH_VariableParameterComponent..::..CreateParameter Method
IGH_VariableParameterComponent Interface See Also Send Feedback
This function will be called when a new parameter is about to be inserted. You must provide a valid parameter or insertion will be skipped. You do not, repeat not, need to insert the parameter yourself.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
IGH_Param CreateParameter(
    GH_ParameterSide side,
    int index
)
Visual Basic
Function CreateParameter ( _
    side As GH_ParameterSide, _
    index As Integer _
) As IGH_Param

Parameters

side
Type: Grasshopper.Kernel..::..GH_ParameterSide
Parameter side.
index
Type: System..::..Int32
Insertion index of parameter. Index=0 means the parameter will be in the topmost spot.

Return Value

A valid IGH_Param instance to be inserted.

See Also

IGH_VariableParameterComponent Interface
Grasshopper.Kernel Namespace


DestroyParameter Method

[image]

Grasshopper SDK
IGH_VariableParameterComponent..::..DestroyParameter Method
IGH_VariableParameterComponent Interface See Also Send Feedback
This function will be called when a parameter is about to be removed. You do not need to do anything, but this would be a good time to remove any event handlers that might be attached to the parameter in question.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool DestroyParameter(
    GH_ParameterSide side,
    int index
)
Visual Basic
Function DestroyParameter ( _
    side As GH_ParameterSide, _
    index As Integer _
) As Boolean

Parameters

side
Type: Grasshopper.Kernel..::..GH_ParameterSide
Parameter side.
index
Type: System..::..Int32
Removal index of parameter.

Return Value

Return True if the parameter in question can indeed be removed. Note, this is only in emergencies, typically the CanRemoveParameter function should return false if the parameter in question is not removable.

See Also

IGH_VariableParameterComponent Interface
Grasshopper.Kernel Namespace


VariableParameterMaintenance Method

[image]

Grasshopper SDK
IGH_VariableParameterComponent..::..VariableParameterMaintenance Method
IGH_VariableParameterComponent Interface See Also Send Feedback
This method will be called when a closely related set of variable parameter operations completes. This would be a good time to ensure all Nicknames and parameter properties are correct. This method will also be called upon IO operations such as Open, Paste, Undo and Redo.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void VariableParameterMaintenance()
Visual Basic
Sub VariableParameterMaintenance

See Also

IGH_VariableParameterComponent Interface
Grasshopper.Kernel Namespace


IGH_VarParamComponent Interface

[image]

Grasshopper SDK
IGH_VarParamComponent Interface
Members See Also Send Feedback
This interface is obsolete, please use the IGH_VariableParameterComponent interface instead.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_VarParamComponent
Visual Basic
Public Interface IGH_VarParamComponent

See Also

IGH_VarParamComponent Members
Grasshopper.Kernel Namespace


IGH_VarParamComponent Members

[image] [image]

Grasshopper SDK
IGH_VarParamComponent Members
IGH_VarParamComponent Interface Methods Properties See Also Send Feedback

The IGH_VarParamComponent type exposes the following members.

Methods

 | Name | Description
Public method | ConstructVariable | This function is called whenever a new parameter is required. You must provide a non-null instance for new_param, otherwise the addition will be cancelled. The Param field of the event arguments will typically be null.
Public method | IsVariableParam | Returns a value indicating whether a specific parameter is considered to be variable.
Public method | ManagerConstructed | This function is called whenever a new manager is constructed. You can override this function if you wish to modify the default behaviour of the manager.
Public method | ParametersModified | This function will be called wheneven the param collection of a component has been altered through the ParamManager. If your parameters have a peculiar naming scheme, this is the best place to assign those.

Properties

 | Name | Description
Public property | IsInputVariable | Gets a flag specifying whether or not the input can potentially contain variable parameters.
Public property | IsOutputVariable | Gets a flag specifying whether or not the output can potentially contain variable parameters.

See Also

IGH_VarParamComponent Interface
Grasshopper.Kernel Namespace


IGH_VarParamComponent Methods

[image] [image]

Grasshopper SDK
IGH_VarParamComponent Methods
IGH_VarParamComponent Interface See Also Send Feedback

The IGH_VarParamComponent type exposes the following members.

Methods

 | Name | Description
Public method | ConstructVariable | This function is called whenever a new parameter is required. You must provide a non-null instance for new_param, otherwise the addition will be cancelled. The Param field of the event arguments will typically be null.
Public method | IsVariableParam | Returns a value indicating whether a specific parameter is considered to be variable.
Public method | ManagerConstructed | This function is called whenever a new manager is constructed. You can override this function if you wish to modify the default behaviour of the manager.
Public method | ParametersModified | This function will be called wheneven the param collection of a component has been altered through the ParamManager. If your parameters have a peculiar naming scheme, this is the best place to assign those.

See Also

IGH_VarParamComponent Interface
Grasshopper.Kernel Namespace


ConstructVariable Method

[image]

Grasshopper SDK
IGH_VarParamComponent..::..ConstructVariable Method
IGH_VarParamComponent Interface See Also Send Feedback
This function is called whenever a new parameter is required. You must provide a non-null instance for new_param, otherwise the addition will be cancelled. The Param field of the event arguments will typically be null.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
IGH_Param ConstructVariable(
    GH_VarParamEventArgs e
)
Visual Basic
Function ConstructVariable ( _
    e As GH_VarParamEventArgs _
) As IGH_Param

Parameters

e
Type: Grasshopper.Kernel..::..GH_VarParamEventArgs

See Also

IGH_VarParamComponent Interface
Grasshopper.Kernel Namespace


IsVariableParam Method

[image]

Grasshopper SDK
IGH_VarParamComponent..::..IsVariableParam Method
IGH_VarParamComponent Interface See Also Send Feedback
Returns a value indicating whether a specific parameter is considered to be variable.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool IsVariableParam(
    GH_VarParamEventArgs e
)
Visual Basic
Function IsVariableParam ( _
    e As GH_VarParamEventArgs _
) As Boolean

Parameters

e
Type: Grasshopper.Kernel..::..GH_VarParamEventArgs

See Also

IGH_VarParamComponent Interface
Grasshopper.Kernel Namespace


ManagerConstructed Method

[image]

Grasshopper SDK
IGH_VarParamComponent..::..ManagerConstructed Method
IGH_VarParamComponent Interface See Also Send Feedback
This function is called whenever a new manager is constructed. You can override this function if you wish to modify the default behaviour of the manager.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void ManagerConstructed(
    GH_VarParamSide side,
    GH_VariableParameterManager manager
)
Visual Basic
Sub ManagerConstructed ( _
    side As GH_VarParamSide, _
    manager As GH_VariableParameterManager _
)

Parameters

side
Type: Grasshopper.Kernel..::..GH_VarParamSide
manager
Type: GH_VariableParameterManager

See Also

IGH_VarParamComponent Interface
Grasshopper.Kernel Namespace


ParametersModified Method

[image]

Grasshopper SDK
IGH_VarParamComponent..::..ParametersModified Method
IGH_VarParamComponent Interface See Also Send Feedback
This function will be called wheneven the param collection of a component has been altered through the ParamManager. If your parameters have a peculiar naming scheme, this is the best place to assign those.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void ParametersModified(
    GH_VarParamSide side
)
Visual Basic
Sub ParametersModified ( _
    side As GH_VarParamSide _
)

Parameters

side
Type: Grasshopper.Kernel..::..GH_VarParamSide

See Also

IGH_VarParamComponent Interface
Grasshopper.Kernel Namespace


IGH_VarParamComponent Properties

[image] [image]

Grasshopper SDK
IGH_VarParamComponent Properties
IGH_VarParamComponent Interface See Also Send Feedback

The IGH_VarParamComponent type exposes the following members.

Properties

 | Name | Description
Public property | IsInputVariable | Gets a flag specifying whether or not the input can potentially contain variable parameters.
Public property | IsOutputVariable | Gets a flag specifying whether or not the output can potentially contain variable parameters.

See Also

IGH_VarParamComponent Interface
Grasshopper.Kernel Namespace


IsInputVariable Property

[image]

Grasshopper SDK
IGH_VarParamComponent..::..IsInputVariable Property
IGH_VarParamComponent Interface See Also Send Feedback
Gets a flag specifying whether or not the input can potentially contain variable parameters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool IsInputVariable { get; }
Visual Basic
ReadOnly Property IsInputVariable As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_VarParamComponent.IsInputVariable"]

Return Value

Return TRUE to enable variable parameter UI on the input side.

See Also

IGH_VarParamComponent Interface
Grasshopper.Kernel Namespace


IsOutputVariable Property

[image]

Grasshopper SDK
IGH_VarParamComponent..::..IsOutputVariable Property
IGH_VarParamComponent Interface See Also Send Feedback
Gets a flag specifying whether or not the output can potentially contain variable parameters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool IsOutputVariable { get; }
Visual Basic
ReadOnly Property IsOutputVariable As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_VarParamComponent.IsOutputVariable"]

Return Value

Return TRUE to enable variable parameter UI on the output side.

See Also

IGH_VarParamComponent Interface
Grasshopper.Kernel Namespace


IGH_ZuiAction Interface

[image]

Grasshopper SDK
IGH_ZuiAction Interface
Members See Also Send Feedback
Represents a single action which is only visible on screen above a certain zoom level.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_ZuiAction : IGH_TooltipAwareObject
Visual Basic
Public Interface IGH_ZuiAction _
    Inherits IGH_TooltipAwareObject

See Also

IGH_ZuiAction Members
Grasshopper.Kernel Namespace


IGH_ZuiAction Members

[image] [image]

Grasshopper SDK
IGH_ZuiAction Members
IGH_ZuiAction Interface Methods Properties See Also Send Feedback

The IGH_ZuiAction type exposes the following members.

Methods

 | Name | Description
Public method | IsTooltipRegion | Determine whether the specified pixel should result in a tooltip when the cursor hovers over it. (Inherited from IGH_TooltipAwareObject.)
Public method | Perform | This method will be called when the action needs to be performed.
Public method | SetupTooltip | This function is called when a tooltip it about to be displayed. (Inherited from IGH_TooltipAwareObject.)

Properties

 | Name | Description
Public property | Name | Gets the display name for this action. Keep it short and sweet.
Public property | TooltipEnabled | Gets the tooltip enabled value. If False, no further tooltip functions will be called. (Inherited from IGH_TooltipAwareObject.)

See Also

IGH_ZuiAction Interface
Grasshopper.Kernel Namespace


IGH_ZuiAction Methods

[image] [image]

Grasshopper SDK
IGH_ZuiAction Methods
IGH_ZuiAction Interface See Also Send Feedback

The IGH_ZuiAction type exposes the following members.

Methods

 | Name | Description
Public method | IsTooltipRegion | Determine whether the specified pixel should result in a tooltip when the cursor hovers over it. (Inherited from IGH_TooltipAwareObject.)
Public method | Perform | This method will be called when the action needs to be performed.
Public method | SetupTooltip | This function is called when a tooltip it about to be displayed. (Inherited from IGH_TooltipAwareObject.)

See Also

IGH_ZuiAction Interface
Grasshopper.Kernel Namespace


Perform Method

[image]

Grasshopper SDK
IGH_ZuiAction..::..Perform Method
IGH_ZuiAction Interface See Also Send Feedback
This method will be called when the action needs to be performed.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void Perform()
Visual Basic
Sub Perform

See Also

IGH_ZuiAction Interface
Grasshopper.Kernel Namespace


IGH_ZuiAction Properties

[image] [image]

Grasshopper SDK
IGH_ZuiAction Properties
IGH_ZuiAction Interface See Also Send Feedback

The IGH_ZuiAction type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets the display name for this action. Keep it short and sweet.
Public property | TooltipEnabled | Gets the tooltip enabled value. If False, no further tooltip functions will be called. (Inherited from IGH_TooltipAwareObject.)

See Also

IGH_ZuiAction Interface
Grasshopper.Kernel Namespace


Name Property

[image]

Grasshopper SDK
IGH_ZuiAction..::..Name Property
IGH_ZuiAction Interface See Also Send Feedback
Gets the display name for this action. Keep it short and sweet.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string Name { get; }
Visual Basic
ReadOnly Property Name As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.IGH_ZuiAction.Name"]

See Also

IGH_ZuiAction Interface
Grasshopper.Kernel Namespace


Grasshopper.Kernel.Attributes Namespace

[image]

Grasshopper SDK
Grasshopper.Kernel.Attributes Namespace
Send Feedback
Contains a number of standard attribute implementations.

Classes

 | Class | Description
Public class | GH_ComponentAttributes | These Attributes are the default for GH_Components.
Public class | GH_FloatingParamAttributes | These Attributes are the default for stand-alone Parameters.
Public class | GH_LinkedParamAttributes | These Attributes are assigned to parameters that are part of a GH_Component.
Public class | GH_ResizableAttributes<(Of <(<'T>)>)> | These Attributes provide basic resizing logic.


GH_ComponentAttributes Class

[image]

Grasshopper SDK
GH_ComponentAttributes Class
Members See Also Send Feedback
These Attributes are the default for GH_Components.

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_ComponentAttributes : GH_Attributes<IGH_Component>
Visual Basic
Public Class GH_ComponentAttributes _
    Inherits GH_Attributes(Of IGH_Component)

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_Attributes <(Of <(<' IGH_Component >)>)>
Grasshopper.Kernel.Attributes..::..GH_ComponentAttributes

See Also

GH_ComponentAttributes Members
Grasshopper.Kernel.Attributes Namespace


GH_ComponentAttributes Members

[image] [image]

Grasshopper SDK
GH_ComponentAttributes Members
GH_ComponentAttributes Class Constructors Methods Fields Properties See Also Send Feedback

The GH_ComponentAttributes type exposes the following members.

Constructors

 | Name | Description
Public method | GH_ComponentAttributes | Initializes a new instance of the GH_ComponentAttributes class

Methods

 | Name | Description
Public method | AppendToAttributeTree | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..AppendToAttributeTree(List<(Of <<'(IGH_Attributes>)>>)).)
Public method | ExpireLayout | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..ExpireLayout()()()().)
Public method | InvalidateCanvas | The canvas must be invalidated when the mouse is near enough and this component has variable parameters. (Overrides GH_Attributes<(Of <(<'T>)>)>..::..InvalidateCanvas(GH_Canvas, GH_CanvasMouseEvent).)
Public method | IsMenuRegion | Determines whether a point is available for context menu popups. By default, IsMenuRegion calls IsPickRegion(PointF). (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | IsPickRegion(PointF) | Determines whether a point is within the pickable region for this object. By default, any point inside the Bounds is treated as pickable. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | IsPickRegion(RectangleF, GH_PickBox) | Determines whether a rectangle is a valid pick region for this object. By default, the picking rectangle is intersected with the Bounds rectangle. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | IsTooltipRegion | Determines whether a point is available for tooltip popups. By default, IsMenuRegion calls IsTooltipRegion(PointF). (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected method | Layout | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..Layout()()()().)
 | LayoutBounds |
 | LayoutComponentBox | Utility layout method for GH_Component style UI.
 | LayoutInputParams |
 | LayoutOutputParams |
Public method | NewInstanceGuid()()()() | Generate a new instance GUID for the owner object. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | NewInstanceGuid(Guid) | Generate a new instance GUID for the owner object. Do not use this overload unless you're > 1.95m and called David. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | PerformLayout | Recompute the layout for these attributes. This function is automatically called during Drawing operations, so you typically don't have to. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected method | PrepareForRender | This method will always be called exactly once prior to Render(). This would be a good place to make sure all the necessary GUI data is up and running. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | Read | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected method | Render | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..Render(GH_Canvas, Graphics, GH_CanvasChannel).)
Protected method | RenderComponentCapsule(GH_Canvas, Graphics) | Utility function, draws the complete component capsule including all parameter data.
Protected method | RenderComponentCapsule(GH_Canvas, Graphics, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | Utility function, draws the component capsule including all specified elements.
 | RenderComponentParameters | Utility method for rendering all component parameters.
Protected method | RenderIncomingWires(GH_Painter, IEnumerable<(Of <<'(IGH_Param>)>>), GH_ParamWireDisplay) | Utility function for derived classes. This method draws all the wires going into the left side of the attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected method | RenderIncomingWires(GH_Painter, IEnumerable<(Of <<'(IGH_Param>)>>), IEnumerable<(Of <<'(Pen>)>>)) | Utility function for derived classes. This method draws all the wires going into the left side of the attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RenderToCanvas | Render these attributes into a Canvas control. This function places calls to PrepareForRender() and Render(), you should override those. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected method | RenderVariableParameterUI |
Public method | RespondToKeyDown | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RespondToKeyUp | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RespondToMouseDoubleClick | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RespondToMouseDown | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..RespondToMouseDown(GH_Canvas, GH_CanvasMouseEvent).)
Public method | RespondToMouseMove | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RespondToMouseUp | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | SetupTooltip | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..SetupTooltip(PointF, GH_TooltipDisplayEventArgs).)
Public method | Write | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)

Fields

 | Name | Description
Protected field | m_innerBounds | Represents the Rectangle that contains the component black box.

Properties

 | Name | Description
Public property | AllowMessageBalloon | Gets a value indicating whether these attributes allow warning and error balloons to be drawn on top of them. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | Bounds | Gets the rectangle that contains the active content of the attributes. Typically the Contents determine the active area for menus, tooltips etc. Attributes are not supposed to draw objects beyond the Bounds. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | ContentBox | Gets the bounds of the component area of the attributes.
Public property | DocObject | Gets the owner object of these attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | GetTopLevel | Gets the top-level attributes of the attribute stack these attributes belong to. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | HasInputGrip | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..HasInputGrip.)
Public property | HasOutputGrip | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..HasOutputGrip.)
Public property | InputGrip | Gets the input grip location for these attributes. If HasInputGrip equals False, this point is meaningless. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | InstanceGuid | Gets the instance ID of the document object that owns these attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | IsTopLevel | Gets whether these attributes are top_level (i.e. no Parent attributes) (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | OutputGrip | Gets the output grip location for these attributes. If HasOutputGrip equals False, this point is meaningless. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | Owner | Gets the type-safe owner object of these attributes. This property is identical to the DocObject property. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | Parent | Gets or sets the parent attributes. Top level attributes do not have parents. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | PathName | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..PathName.)
Public property | Pivot | Gets or sets the pivot for these attributes. The pivot controls the general placement of the attributes. If you want to move the attributes, change the pivot location. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | Selected | Gets or sets the selected state of the top-level attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | TooltipEnabled | Gets the tooltip enabled value. If False, no further tooltip functions will be called. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)

See Also

GH_ComponentAttributes Class
Grasshopper.Kernel.Attributes Namespace


GH_ComponentAttributes Constructor

[image]

Grasshopper SDK
GH_ComponentAttributes Constructor
GH_ComponentAttributes Class See Also Send Feedback
Initializes a new instance of the GH_ComponentAttributes class

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ComponentAttributes(
    IGH_Component component
)
Visual Basic
Public Sub New ( _
    component As IGH_Component _
)

Parameters

component
Type: Grasshopper.Kernel..::..IGH_Component

See Also

GH_ComponentAttributes Class
Grasshopper.Kernel.Attributes Namespace


GH_ComponentAttributes Fields

[image] [image]

Grasshopper SDK
GH_ComponentAttributes Fields
GH_ComponentAttributes Class See Also Send Feedback

The GH_ComponentAttributes type exposes the following members.

Fields

 | Name | Description
Protected field | m_innerBounds | Represents the Rectangle that contains the component black box.

See Also

GH_ComponentAttributes Class
Grasshopper.Kernel.Attributes Namespace


m_innerBounds Field

[image]

Grasshopper SDK
GH_ComponentAttributes..::..m_innerBounds Field
GH_ComponentAttributes Class See Also Send Feedback
Represents the Rectangle that contains the component black box.

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected RectangleF m_innerBounds
Visual Basic
Protected m_innerBounds As RectangleF

See Also

GH_ComponentAttributes Class
Grasshopper.Kernel.Attributes Namespace


GH_ComponentAttributes Methods

[image] [image]

Grasshopper SDK
GH_ComponentAttributes Methods
GH_ComponentAttributes Class See Also Send Feedback

The GH_ComponentAttributes type exposes the following members.

Methods

 | Name | Description
Public method | AppendToAttributeTree | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..AppendToAttributeTree(List<(Of <<'(IGH_Attributes>)>>)).)
Public method | ExpireLayout | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..ExpireLayout()()()().)
Public method | InvalidateCanvas | The canvas must be invalidated when the mouse is near enough and this component has variable parameters. (Overrides GH_Attributes<(Of <(<'T>)>)>..::..InvalidateCanvas(GH_Canvas, GH_CanvasMouseEvent).)
Public method | IsMenuRegion | Determines whether a point is available for context menu popups. By default, IsMenuRegion calls IsPickRegion(PointF). (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | IsPickRegion(PointF) | Determines whether a point is within the pickable region for this object. By default, any point inside the Bounds is treated as pickable. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | IsPickRegion(RectangleF, GH_PickBox) | Determines whether a rectangle is a valid pick region for this object. By default, the picking rectangle is intersected with the Bounds rectangle. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | IsTooltipRegion | Determines whether a point is available for tooltip popups. By default, IsMenuRegion calls IsTooltipRegion(PointF). (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected method | Layout | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..Layout()()()().)
 | LayoutBounds |
 | LayoutComponentBox | Utility layout method for GH_Component style UI.
 | LayoutInputParams |
 | LayoutOutputParams |
Public method | NewInstanceGuid()()()() | Generate a new instance GUID for the owner object. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | NewInstanceGuid(Guid) | Generate a new instance GUID for the owner object. Do not use this overload unless you're > 1.95m and called David. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | PerformLayout | Recompute the layout for these attributes. This function is automatically called during Drawing operations, so you typically don't have to. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected method | PrepareForRender | This method will always be called exactly once prior to Render(). This would be a good place to make sure all the necessary GUI data is up and running. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | Read | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected method | Render | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..Render(GH_Canvas, Graphics, GH_CanvasChannel).)
Protected method | RenderComponentCapsule(GH_Canvas, Graphics) | Utility function, draws the complete component capsule including all parameter data.
Protected method | RenderComponentCapsule(GH_Canvas, Graphics, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | Utility function, draws the component capsule including all specified elements.
 | RenderComponentParameters | Utility method for rendering all component parameters.
Protected method | RenderIncomingWires(GH_Painter, IEnumerable<(Of <<'(IGH_Param>)>>), GH_ParamWireDisplay) | Utility function for derived classes. This method draws all the wires going into the left side of the attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected method | RenderIncomingWires(GH_Painter, IEnumerable<(Of <<'(IGH_Param>)>>), IEnumerable<(Of <<'(Pen>)>>)) | Utility function for derived classes. This method draws all the wires going into the left side of the attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RenderToCanvas | Render these attributes into a Canvas control. This function places calls to PrepareForRender() and Render(), you should override those. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected method | RenderVariableParameterUI |
Public method | RespondToKeyDown | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RespondToKeyUp | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RespondToMouseDoubleClick | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RespondToMouseDown | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..RespondToMouseDown(GH_Canvas, GH_CanvasMouseEvent).)
Public method | RespondToMouseMove | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RespondToMouseUp | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | SetupTooltip | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..SetupTooltip(PointF, GH_TooltipDisplayEventArgs).)
Public method | Write | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)

See Also

GH_ComponentAttributes Class
Grasshopper.Kernel.Attributes Namespace


AppendToAttributeTree Method

[image]

Grasshopper SDK
GH_ComponentAttributes..::..AppendToAttributeTree Method
GH_ComponentAttributes Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void AppendToAttributeTree(
    List<IGH_Attributes> attributes
)
Visual Basic
Public Overrides Sub AppendToAttributeTree ( _
    attributes As List(Of IGH_Attributes) _
)

Parameters

attributes
Type: System.Collections.Generic..::..List <(Of <(<' IGH_Attributes >)>)>

See Also

GH_ComponentAttributes Class
Grasshopper.Kernel.Attributes Namespace


ExpireLayout Method

[image]

Grasshopper SDK
GH_ComponentAttributes..::..ExpireLayout Method
GH_ComponentAttributes Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void ExpireLayout()
Visual Basic
Public Overrides Sub ExpireLayout

See Also

GH_ComponentAttributes Class
Grasshopper.Kernel.Attributes Namespace


InvalidateCanvas Method

[image]

Grasshopper SDK
GH_ComponentAttributes..::..InvalidateCanvas Method
GH_ComponentAttributes Class See Also Send Feedback
The canvas must be invalidated when the mouse is near enough and this component has variable parameters.

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool InvalidateCanvas(
    GH_Canvas canvas,
    GH_CanvasMouseEvent e
)
Visual Basic
Public Overrides Function InvalidateCanvas ( _
    canvas As GH_Canvas, _
    e As GH_CanvasMouseEvent _
) As Boolean

Parameters

canvas
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
e
Type: Grasshopper.GUI..::..GH_CanvasMouseEvent

See Also

GH_ComponentAttributes Class
Grasshopper.Kernel.Attributes Namespace


IsPickRegion Method

[image] [image]

Grasshopper SDK
GH_ComponentAttributes..::..IsPickRegion Method
GH_ComponentAttributes Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsPickRegion(PointF) | Determines whether a point is within the pickable region for this object. By default, any point inside the Bounds is treated as pickable. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | IsPickRegion(RectangleF, GH_PickBox) | Determines whether a rectangle is a valid pick region for this object. By default, the picking rectangle is intersected with the Bounds rectangle. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)

See Also

GH_ComponentAttributes Class
GH_ComponentAttributes Members
Grasshopper.Kernel.Attributes Namespace


Layout Method

[image]

Grasshopper SDK
GH_ComponentAttributes..::..Layout Method
GH_ComponentAttributes Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Layout()
Visual Basic
Protected Overrides Sub Layout

See Also

GH_ComponentAttributes Class
Grasshopper.Kernel.Attributes Namespace


LayoutBounds Method

[image]

Grasshopper SDK
GH_ComponentAttributes..::..LayoutBounds Method
GH_ComponentAttributes Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static RectangleF LayoutBounds(
    IGH_Component owner,
    RectangleF bounds
)
Visual Basic
Public Shared Function LayoutBounds ( _
    owner As IGH_Component, _
    bounds As RectangleF _
) As RectangleF

Parameters

owner
Type: Grasshopper.Kernel..::..IGH_Component
bounds
Type: System.Drawing..::..RectangleF

See Also

GH_ComponentAttributes Class
Grasshopper.Kernel.Attributes Namespace


LayoutComponentBox Method

[image]

Grasshopper SDK
GH_ComponentAttributes..::..LayoutComponentBox Method
GH_ComponentAttributes Class See Also Send Feedback
Utility layout method for GH_Component style UI.

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static RectangleF LayoutComponentBox(
    IGH_Component owner
)
Visual Basic
Public Shared Function LayoutComponentBox ( _
    owner As IGH_Component _
) As RectangleF

Parameters

owner
Type: Grasshopper.Kernel..::..IGH_Component
Component to layout.

Return Value

The rectangle describing the box of the component name/icon.

See Also

GH_ComponentAttributes Class
Grasshopper.Kernel.Attributes Namespace


LayoutInputParams Method

[image]

Grasshopper SDK
GH_ComponentAttributes..::..LayoutInputParams Method
GH_ComponentAttributes Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void LayoutInputParams(
    IGH_Component owner,
    RectangleF componentBox
)
Visual Basic
Public Shared Sub LayoutInputParams ( _
    owner As IGH_Component, _
    componentBox As RectangleF _
)

Parameters

owner
Type: Grasshopper.Kernel..::..IGH_Component
componentBox
Type: System.Drawing..::..RectangleF

See Also

GH_ComponentAttributes Class
Grasshopper.Kernel.Attributes Namespace


LayoutOutputParams Method

[image]

Grasshopper SDK
GH_ComponentAttributes..::..LayoutOutputParams Method
GH_ComponentAttributes Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void LayoutOutputParams(
    IGH_Component owner,
    RectangleF componentBox
)
Visual Basic
Public Shared Sub LayoutOutputParams ( _
    owner As IGH_Component, _
    componentBox As RectangleF _
)

Parameters

owner
Type: Grasshopper.Kernel..::..IGH_Component
componentBox
Type: System.Drawing..::..RectangleF

See Also

GH_ComponentAttributes Class
Grasshopper.Kernel.Attributes Namespace


NewInstanceGuid Method

[image] [image]

Grasshopper SDK
GH_ComponentAttributes..::..NewInstanceGuid Method
GH_ComponentAttributes Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NewInstanceGuid()()()() | Generate a new instance GUID for the owner object. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | NewInstanceGuid(Guid) | Generate a new instance GUID for the owner object. Do not use this overload unless you're > 1.95m and called David. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)

See Also

GH_ComponentAttributes Class
GH_ComponentAttributes Members
Grasshopper.Kernel.Attributes Namespace


Render Method

[image]

Grasshopper SDK
GH_ComponentAttributes..::..Render Method
GH_ComponentAttributes Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Render(
    GH_Canvas canvas,
    Graphics graphics,
    GH_CanvasChannel channel
)
Visual Basic
Protected Overrides Sub Render ( _
    canvas As GH_Canvas, _
    graphics As Graphics, _
    channel As GH_CanvasChannel _
)

Parameters

canvas
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
graphics
Type: System.Drawing..::..Graphics
channel
Type: Grasshopper.GUI.Canvas..::..GH_CanvasChannel

See Also

GH_ComponentAttributes Class
Grasshopper.Kernel.Attributes Namespace


RenderComponentCapsule Method

[image] [image]

Grasshopper SDK
GH_ComponentAttributes..::..RenderComponentCapsule Method
GH_ComponentAttributes Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RenderComponentCapsule(GH_Canvas, Graphics) | Utility function, draws the complete component capsule including all parameter data.
Protected method | RenderComponentCapsule(GH_Canvas, Graphics, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | Utility function, draws the component capsule including all specified elements.

See Also

GH_ComponentAttributes Class
GH_ComponentAttributes Members
Grasshopper.Kernel.Attributes Namespace


RenderComponentCapsule Method (GH_Canvas, Graphics)

[image]

Grasshopper SDK
GH_ComponentAttributes..::..RenderComponentCapsule Method (GH_Canvas, Graphics)
GH_ComponentAttributes Class See Also Send Feedback
Utility function, draws the complete component capsule including all parameter data.

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected void RenderComponentCapsule(
    GH_Canvas canvas,
    Graphics graphics
)
Visual Basic
Protected Sub RenderComponentCapsule ( _
    canvas As GH_Canvas, _
    graphics As Graphics _
)

Parameters

canvas
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
Canvas to draw into.
graphics
Type: System.Drawing..::..Graphics
Graphics object to draw with.

See Also

GH_ComponentAttributes Class
RenderComponentCapsule Overload
Grasshopper.Kernel.Attributes Namespace


RenderComponentCapsule Method (GH_Canvas, Graphics, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)

[image]

Grasshopper SDK
GH_ComponentAttributes..::..RenderComponentCapsule Method (GH_Canvas, Graphics, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)
GH_ComponentAttributes Class See Also Send Feedback
Utility function, draws the component capsule including all specified elements.

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected void RenderComponentCapsule(
    GH_Canvas canvas,
    Graphics graphics,
    bool drawComponentBaseBox,
    bool drawComponentNameBox,
    bool drawJaggedEdges,
    bool drawParameterGrips,
    bool drawParameterNames,
    bool drawZuiElements
)
Visual Basic
Protected Sub RenderComponentCapsule ( _
    canvas As GH_Canvas, _
    graphics As Graphics, _
    drawComponentBaseBox As Boolean, _
    drawComponentNameBox As Boolean, _
    drawJaggedEdges As Boolean, _
    drawParameterGrips As Boolean, _
    drawParameterNames As Boolean, _
    drawZuiElements As Boolean _
)

Parameters

canvas
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
Canvas to draw into.
graphics
Type: System.Drawing..::..Graphics
Graphics object to draw with.
drawComponentBaseBox
Type: System..::..Boolean
If true, will draw the component background box.
drawComponentNameBox
Type: System..::..Boolean
If true, will draw component nickname/icon element.
drawJaggedEdges
Type: System..::..Boolean
If true, parameterless sides will have jagged edges drawn on them.
drawParameterGrips
Type: System..::..Boolean
If true, will draw parameter grips.
drawParameterNames
Type: System..::..Boolean
If true, will draw parameter nicknames.
drawZuiElements
Type: System..::..Boolean
If true, will draw ZUI variable parameter interface.

See Also

GH_ComponentAttributes Class
RenderComponentCapsule Overload
Grasshopper.Kernel.Attributes Namespace


RenderComponentParameters Method

[image]

Grasshopper SDK
GH_ComponentAttributes..::..RenderComponentParameters Method
GH_ComponentAttributes Class See Also Send Feedback
Utility method for rendering all component parameters.

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void RenderComponentParameters(
    GH_Canvas canvas,
    Graphics graphics,
    IGH_Component owner,
    GH_PaletteStyle style
)
Visual Basic
Public Shared Sub RenderComponentParameters ( _
    canvas As GH_Canvas, _
    graphics As Graphics, _
    owner As IGH_Component, _
    style As GH_PaletteStyle _
)

Parameters

canvas
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
Canvas to draw to.
graphics
Type: System.Drawing..::..Graphics
Graphics to draw with.
owner
Type: Grasshopper.Kernel..::..IGH_Component
Component to draw parameters for.
style
Type: Grasshopper.GUI.Canvas..::..GH_PaletteStyle
Component capsule palette style.

See Also

GH_ComponentAttributes Class
Grasshopper.Kernel.Attributes Namespace


RenderIncomingWires Method

[image] [image]

Grasshopper SDK
GH_ComponentAttributes..::..RenderIncomingWires Method
GH_ComponentAttributes Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RenderIncomingWires(GH_Painter, IEnumerable<(Of <<'(IGH_Param>)>>), GH_ParamWireDisplay) | Utility function for derived classes. This method draws all the wires going into the left side of the attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected method | RenderIncomingWires(GH_Painter, IEnumerable<(Of <<'(IGH_Param>)>>), IEnumerable<(Of <<'(Pen>)>>)) | Utility function for derived classes. This method draws all the wires going into the left side of the attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)

See Also

GH_ComponentAttributes Class
GH_ComponentAttributes Members
Grasshopper.Kernel.Attributes Namespace


RenderVariableParameterUI Method

[image]

Grasshopper SDK
GH_ComponentAttributes..::..RenderVariableParameterUI Method
GH_ComponentAttributes Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected void RenderVariableParameterUI(
    GH_Canvas canvas,
    Graphics graphics
)
Visual Basic
Protected Sub RenderVariableParameterUI ( _
    canvas As GH_Canvas, _
    graphics As Graphics _
)

Parameters

canvas
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
graphics
Type: System.Drawing..::..Graphics

See Also

GH_ComponentAttributes Class
Grasshopper.Kernel.Attributes Namespace


RespondToMouseDown Method

[image]

Grasshopper SDK
GH_ComponentAttributes..::..RespondToMouseDown Method
GH_ComponentAttributes Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override GH_ObjectResponse RespondToMouseDown(
    GH_Canvas sender,
    GH_CanvasMouseEvent e
)
Visual Basic
Public Overrides Function RespondToMouseDown ( _
    sender As GH_Canvas, _
    e As GH_CanvasMouseEvent _
) As GH_ObjectResponse

Parameters

sender
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
e
Type: Grasshopper.GUI..::..GH_CanvasMouseEvent

See Also

GH_ComponentAttributes Class
Grasshopper.Kernel.Attributes Namespace


SetupTooltip Method

[image]

Grasshopper SDK
GH_ComponentAttributes..::..SetupTooltip Method
GH_ComponentAttributes Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void SetupTooltip(
    PointF canvasPoint,
    GH_TooltipDisplayEventArgs e
)
Visual Basic
Public Overrides Sub SetupTooltip ( _
    canvasPoint As PointF, _
    e As GH_TooltipDisplayEventArgs _
)

Parameters

canvasPoint
Type: System.Drawing..::..PointF
e
Type: Grasshopper.GUI..::..GH_TooltipDisplayEventArgs

See Also

GH_ComponentAttributes Class
Grasshopper.Kernel.Attributes Namespace


GH_ComponentAttributes Properties

[image] [image]

Grasshopper SDK
GH_ComponentAttributes Properties
GH_ComponentAttributes Class See Also Send Feedback

The GH_ComponentAttributes type exposes the following members.

Properties

 | Name | Description
Public property | AllowMessageBalloon | Gets a value indicating whether these attributes allow warning and error balloons to be drawn on top of them. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | Bounds | Gets the rectangle that contains the active content of the attributes. Typically the Contents determine the active area for menus, tooltips etc. Attributes are not supposed to draw objects beyond the Bounds. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | ContentBox | Gets the bounds of the component area of the attributes.
Public property | DocObject | Gets the owner object of these attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | GetTopLevel | Gets the top-level attributes of the attribute stack these attributes belong to. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | HasInputGrip | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..HasInputGrip.)
Public property | HasOutputGrip | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..HasOutputGrip.)
Public property | InputGrip | Gets the input grip location for these attributes. If HasInputGrip equals False, this point is meaningless. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | InstanceGuid | Gets the instance ID of the document object that owns these attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | IsTopLevel | Gets whether these attributes are top_level (i.e. no Parent attributes) (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | OutputGrip | Gets the output grip location for these attributes. If HasOutputGrip equals False, this point is meaningless. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | Owner | Gets the type-safe owner object of these attributes. This property is identical to the DocObject property. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | Parent | Gets or sets the parent attributes. Top level attributes do not have parents. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | PathName | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..PathName.)
Public property | Pivot | Gets or sets the pivot for these attributes. The pivot controls the general placement of the attributes. If you want to move the attributes, change the pivot location. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | Selected | Gets or sets the selected state of the top-level attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | TooltipEnabled | Gets the tooltip enabled value. If False, no further tooltip functions will be called. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)

See Also

GH_ComponentAttributes Class
Grasshopper.Kernel.Attributes Namespace


ContentBox Property

[image]

Grasshopper SDK
GH_ComponentAttributes..::..ContentBox Property
GH_ComponentAttributes Class See Also Send Feedback
Gets the bounds of the component area of the attributes.

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public RectangleF ContentBox { get; }
Visual Basic
Public ReadOnly Property ContentBox As RectangleF
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Attributes.GH_ComponentAttributes.ContentBox"]

See Also

GH_ComponentAttributes Class
Grasshopper.Kernel.Attributes Namespace


HasInputGrip Property

[image]

Grasshopper SDK
GH_ComponentAttributes..::..HasInputGrip Property
GH_ComponentAttributes Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool HasInputGrip { get; }
Visual Basic
Public Overrides ReadOnly Property HasInputGrip As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Attributes.GH_ComponentAttributes.HasInputGrip"]

See Also

GH_ComponentAttributes Class
Grasshopper.Kernel.Attributes Namespace


HasOutputGrip Property

[image]

Grasshopper SDK
GH_ComponentAttributes..::..HasOutputGrip Property
GH_ComponentAttributes Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool HasOutputGrip { get; }
Visual Basic
Public Overrides ReadOnly Property HasOutputGrip As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Attributes.GH_ComponentAttributes.HasOutputGrip"]

See Also

GH_ComponentAttributes Class
Grasshopper.Kernel.Attributes Namespace


PathName Property

[image]

Grasshopper SDK
GH_ComponentAttributes..::..PathName Property
GH_ComponentAttributes Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string PathName { get; }
Visual Basic
Public Overrides ReadOnly Property PathName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Attributes.GH_ComponentAttributes.PathName"]

See Also

GH_ComponentAttributes Class
Grasshopper.Kernel.Attributes Namespace


GH_FloatingParamAttributes Class

[image]

Grasshopper SDK
GH_FloatingParamAttributes Class
Members See Also Send Feedback
These Attributes are the default for stand-alone Parameters.

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_FloatingParamAttributes : GH_Attributes<IGH_Param>
Visual Basic
Public Class GH_FloatingParamAttributes _
    Inherits GH_Attributes(Of IGH_Param)

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_Attributes <(Of <(<' IGH_Param >)>)>
Grasshopper.Kernel.Attributes..::..GH_FloatingParamAttributes

See Also

GH_FloatingParamAttributes Members
Grasshopper.Kernel.Attributes Namespace


GH_FloatingParamAttributes Members

[image] [image]

Grasshopper SDK
GH_FloatingParamAttributes Members
GH_FloatingParamAttributes Class Constructors Methods Fields Properties See Also Send Feedback

The GH_FloatingParamAttributes type exposes the following members.

Constructors

 | Name | Description
Public method | GH_FloatingParamAttributes | Initializes a new instance of the GH_FloatingParamAttributes class

Methods

 | Name | Description
Public method | AppendToAttributeTree | Recursively append these attributes and all child attributes to the attribute list. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | ExpireLayout | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..ExpireLayout()()()().)
Public method | InvalidateCanvas | If the mouse location should cause a canvas invalidation then return true. You only need to override this function if you draw objects that are dependant on cursor positions outside the bounds of the attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | IsMenuRegion | Determines whether a point is available for context menu popups. By default, IsMenuRegion calls IsPickRegion(PointF). (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | IsPickRegion(PointF) | Determines whether a point is within the pickable region for this object. By default, any point inside the Bounds is treated as pickable. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | IsPickRegion(RectangleF, GH_PickBox) | Determines whether a rectangle is a valid pick region for this object. By default, the picking rectangle is intersected with the Bounds rectangle. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | IsTooltipRegion | Determines whether a point is available for tooltip popups. By default, IsMenuRegion calls IsTooltipRegion(PointF). (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected method | Layout | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..Layout()()()().)
Public method | NewInstanceGuid()()()() | Generate a new instance GUID for the owner object. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | NewInstanceGuid(Guid) | Generate a new instance GUID for the owner object. Do not use this overload unless you're > 1.95m and called David. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | PerformLayout | Recompute the layout for these attributes. This function is automatically called during Drawing operations, so you typically don't have to. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected method | PrepareForRender | This method will always be called exactly once prior to Render(). This would be a good place to make sure all the necessary GUI data is up and running. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | Read | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected method | Render | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..Render(GH_Canvas, Graphics, GH_CanvasChannel).)
Protected method | RenderIncomingWires(GH_Painter, IEnumerable<(Of <<'(IGH_Param>)>>), GH_ParamWireDisplay) | Utility function for derived classes. This method draws all the wires going into the left side of the attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected method | RenderIncomingWires(GH_Painter, IEnumerable<(Of <<'(IGH_Param>)>>), IEnumerable<(Of <<'(Pen>)>>)) | Utility function for derived classes. This method draws all the wires going into the left side of the attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RenderToCanvas | Render these attributes into a Canvas control. This function places calls to PrepareForRender() and Render(), you should override those. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RespondToKeyDown | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RespondToKeyUp | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RespondToMouseDoubleClick | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..RespondToMouseDoubleClick(GH_Canvas, GH_CanvasMouseEvent).)
Public method | RespondToMouseDown | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RespondToMouseMove | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RespondToMouseUp | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | SetupTooltip | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..SetupTooltip(PointF, GH_TooltipDisplayEventArgs).)
Public method | Write | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)

Fields

Name | Description
DefaultWidth | Defines the default (and minimum) width of a floating parameter.
IconHeight | Defines the default height of a floating parameter in Icon display mode.
TextHeight | Defines the default height of a floating parameter in Text display mode.

Properties

 | Name | Description
Public property | AllowMessageBalloon | Gets a value indicating whether these attributes allow warning and error balloons to be drawn on top of them. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | Bounds | Gets the rectangle that contains the active content of the attributes. Typically the Contents determine the active area for menus, tooltips etc. Attributes are not supposed to draw objects beyond the Bounds. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | DocObject | Gets the owner object of these attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | GetTopLevel | Gets the top-level attributes of the attribute stack these attributes belong to. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | HasInputGrip | Gets a value indicating whether or not these attributes have an input grip. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | HasOutputGrip | Gets a value indicating whether or not these attributes have an output grip. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | InputGrip | Gets the input grip location for these attributes. If HasInputGrip equals False, this point is meaningless. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | InstanceGuid | Gets the instance ID of the document object that owns these attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | IsTopLevel | Gets whether these attributes are top_level (i.e. no Parent attributes) (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | OutputGrip | Gets the output grip location for these attributes. If HasOutputGrip equals False, this point is meaningless. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | Owner | Gets the type-safe owner object of these attributes. This property is identical to the DocObject property. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | Parent | Gets or sets the parent attributes. Top level attributes do not have parents. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | PathName | Get a description of the location of these attributes within the local attribute stack. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | Pivot | Gets or sets the pivot for these attributes. The pivot controls the general placement of the attributes. If you want to move the attributes, change the pivot location. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | Selected | Gets or sets the selected state of the top-level attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | TooltipEnabled | Gets the tooltip enabled value. If False, no further tooltip functions will be called. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)

See Also

GH_FloatingParamAttributes Class
Grasshopper.Kernel.Attributes Namespace


GH_FloatingParamAttributes Constructor

[image]

Grasshopper SDK
GH_FloatingParamAttributes Constructor
GH_FloatingParamAttributes Class See Also Send Feedback
Initializes a new instance of the GH_FloatingParamAttributes class

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_FloatingParamAttributes(
    IGH_Param param
)
Visual Basic
Public Sub New ( _
    param As IGH_Param _
)

Parameters

param
Type: Grasshopper.Kernel..::..IGH_Param

See Also

GH_FloatingParamAttributes Class
Grasshopper.Kernel.Attributes Namespace


GH_FloatingParamAttributes Fields

[image] [image]

Grasshopper SDK
GH_FloatingParamAttributes Fields
GH_FloatingParamAttributes Class See Also Send Feedback

The GH_FloatingParamAttributes type exposes the following members.

Fields

Name | Description
DefaultWidth | Defines the default (and minimum) width of a floating parameter.
IconHeight | Defines the default height of a floating parameter in Icon display mode.
TextHeight | Defines the default height of a floating parameter in Text display mode.

See Also

GH_FloatingParamAttributes Class
Grasshopper.Kernel.Attributes Namespace


DefaultWidth Field

[image]

Grasshopper SDK
GH_FloatingParamAttributes..::..DefaultWidth Field
GH_FloatingParamAttributes Class See Also Send Feedback
Defines the default (and minimum) width of a floating parameter.

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const int DefaultWidth
Visual Basic
Public Const DefaultWidth As Integer

See Also

GH_FloatingParamAttributes Class
Grasshopper.Kernel.Attributes Namespace


IconHeight Field

[image]

Grasshopper SDK
GH_FloatingParamAttributes..::..IconHeight Field
GH_FloatingParamAttributes Class See Also Send Feedback
Defines the default height of a floating parameter in Icon display mode.

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const int IconHeight
Visual Basic
Public Const IconHeight As Integer

See Also

GH_FloatingParamAttributes Class
Grasshopper.Kernel.Attributes Namespace


TextHeight Field

[image]

Grasshopper SDK
GH_FloatingParamAttributes..::..TextHeight Field
GH_FloatingParamAttributes Class See Also Send Feedback
Defines the default height of a floating parameter in Text display mode.

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const int TextHeight
Visual Basic
Public Const TextHeight As Integer

See Also

GH_FloatingParamAttributes Class
Grasshopper.Kernel.Attributes Namespace


GH_FloatingParamAttributes Methods

[image] [image]

Grasshopper SDK
GH_FloatingParamAttributes Methods
GH_FloatingParamAttributes Class See Also Send Feedback

The GH_FloatingParamAttributes type exposes the following members.

Methods

 | Name | Description
Public method | AppendToAttributeTree | Recursively append these attributes and all child attributes to the attribute list. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | ExpireLayout | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..ExpireLayout()()()().)
Public method | InvalidateCanvas | If the mouse location should cause a canvas invalidation then return true. You only need to override this function if you draw objects that are dependant on cursor positions outside the bounds of the attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | IsMenuRegion | Determines whether a point is available for context menu popups. By default, IsMenuRegion calls IsPickRegion(PointF). (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | IsPickRegion(PointF) | Determines whether a point is within the pickable region for this object. By default, any point inside the Bounds is treated as pickable. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | IsPickRegion(RectangleF, GH_PickBox) | Determines whether a rectangle is a valid pick region for this object. By default, the picking rectangle is intersected with the Bounds rectangle. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | IsTooltipRegion | Determines whether a point is available for tooltip popups. By default, IsMenuRegion calls IsTooltipRegion(PointF). (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected method | Layout | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..Layout()()()().)
Public method | NewInstanceGuid()()()() | Generate a new instance GUID for the owner object. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | NewInstanceGuid(Guid) | Generate a new instance GUID for the owner object. Do not use this overload unless you're > 1.95m and called David. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | PerformLayout | Recompute the layout for these attributes. This function is automatically called during Drawing operations, so you typically don't have to. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected method | PrepareForRender | This method will always be called exactly once prior to Render(). This would be a good place to make sure all the necessary GUI data is up and running. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | Read | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected method | Render | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..Render(GH_Canvas, Graphics, GH_CanvasChannel).)
Protected method | RenderIncomingWires(GH_Painter, IEnumerable<(Of <<'(IGH_Param>)>>), GH_ParamWireDisplay) | Utility function for derived classes. This method draws all the wires going into the left side of the attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected method | RenderIncomingWires(GH_Painter, IEnumerable<(Of <<'(IGH_Param>)>>), IEnumerable<(Of <<'(Pen>)>>)) | Utility function for derived classes. This method draws all the wires going into the left side of the attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RenderToCanvas | Render these attributes into a Canvas control. This function places calls to PrepareForRender() and Render(), you should override those. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RespondToKeyDown | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RespondToKeyUp | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RespondToMouseDoubleClick | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..RespondToMouseDoubleClick(GH_Canvas, GH_CanvasMouseEvent).)
Public method | RespondToMouseDown | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RespondToMouseMove | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RespondToMouseUp | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | SetupTooltip | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..SetupTooltip(PointF, GH_TooltipDisplayEventArgs).)
Public method | Write | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)

See Also

GH_FloatingParamAttributes Class
Grasshopper.Kernel.Attributes Namespace


ExpireLayout Method

[image]

Grasshopper SDK
GH_FloatingParamAttributes..::..ExpireLayout Method
GH_FloatingParamAttributes Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void ExpireLayout()
Visual Basic
Public Overrides Sub ExpireLayout

See Also

GH_FloatingParamAttributes Class
Grasshopper.Kernel.Attributes Namespace


IsPickRegion Method

[image] [image]

Grasshopper SDK
GH_FloatingParamAttributes..::..IsPickRegion Method
GH_FloatingParamAttributes Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsPickRegion(PointF) | Determines whether a point is within the pickable region for this object. By default, any point inside the Bounds is treated as pickable. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | IsPickRegion(RectangleF, GH_PickBox) | Determines whether a rectangle is a valid pick region for this object. By default, the picking rectangle is intersected with the Bounds rectangle. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)

See Also

GH_FloatingParamAttributes Class
GH_FloatingParamAttributes Members
Grasshopper.Kernel.Attributes Namespace


Layout Method

[image]

Grasshopper SDK
GH_FloatingParamAttributes..::..Layout Method
GH_FloatingParamAttributes Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Layout()
Visual Basic
Protected Overrides Sub Layout

See Also

GH_FloatingParamAttributes Class
Grasshopper.Kernel.Attributes Namespace


NewInstanceGuid Method

[image] [image]

Grasshopper SDK
GH_FloatingParamAttributes..::..NewInstanceGuid Method
GH_FloatingParamAttributes Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NewInstanceGuid()()()() | Generate a new instance GUID for the owner object. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | NewInstanceGuid(Guid) | Generate a new instance GUID for the owner object. Do not use this overload unless you're > 1.95m and called David. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)

See Also

GH_FloatingParamAttributes Class
GH_FloatingParamAttributes Members
Grasshopper.Kernel.Attributes Namespace


Render Method

[image]

Grasshopper SDK
GH_FloatingParamAttributes..::..Render Method
GH_FloatingParamAttributes Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Render(
    GH_Canvas canvas,
    Graphics graphics,
    GH_CanvasChannel channel
)
Visual Basic
Protected Overrides Sub Render ( _
    canvas As GH_Canvas, _
    graphics As Graphics, _
    channel As GH_CanvasChannel _
)

Parameters

canvas
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
graphics
Type: System.Drawing..::..Graphics
channel
Type: Grasshopper.GUI.Canvas..::..GH_CanvasChannel

See Also

GH_FloatingParamAttributes Class
Grasshopper.Kernel.Attributes Namespace


RenderIncomingWires Method

[image] [image]

Grasshopper SDK
GH_FloatingParamAttributes..::..RenderIncomingWires Method
GH_FloatingParamAttributes Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RenderIncomingWires(GH_Painter, IEnumerable<(Of <<'(IGH_Param>)>>), GH_ParamWireDisplay) | Utility function for derived classes. This method draws all the wires going into the left side of the attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected method | RenderIncomingWires(GH_Painter, IEnumerable<(Of <<'(IGH_Param>)>>), IEnumerable<(Of <<'(Pen>)>>)) | Utility function for derived classes. This method draws all the wires going into the left side of the attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)

See Also

GH_FloatingParamAttributes Class
GH_FloatingParamAttributes Members
Grasshopper.Kernel.Attributes Namespace


RespondToMouseDoubleClick Method

[image]

Grasshopper SDK
GH_FloatingParamAttributes..::..RespondToMouseDoubleClick Method
GH_FloatingParamAttributes Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override GH_ObjectResponse RespondToMouseDoubleClick(
    GH_Canvas sender,
    GH_CanvasMouseEvent e
)
Visual Basic
Public Overrides Function RespondToMouseDoubleClick ( _
    sender As GH_Canvas, _
    e As GH_CanvasMouseEvent _
) As GH_ObjectResponse

Parameters

sender
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
e
Type: Grasshopper.GUI..::..GH_CanvasMouseEvent

See Also

GH_FloatingParamAttributes Class
Grasshopper.Kernel.Attributes Namespace


SetupTooltip Method

[image]

Grasshopper SDK
GH_FloatingParamAttributes..::..SetupTooltip Method
GH_FloatingParamAttributes Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void SetupTooltip(
    PointF point,
    GH_TooltipDisplayEventArgs e
)
Visual Basic
Public Overrides Sub SetupTooltip ( _
    point As PointF, _
    e As GH_TooltipDisplayEventArgs _
)

Parameters

point
Type: System.Drawing..::..PointF
e
Type: Grasshopper.GUI..::..GH_TooltipDisplayEventArgs

See Also

GH_FloatingParamAttributes Class
Grasshopper.Kernel.Attributes Namespace


GH_FloatingParamAttributes Properties

[image] [image]

Grasshopper SDK
GH_FloatingParamAttributes Properties
GH_FloatingParamAttributes Class See Also Send Feedback

The GH_FloatingParamAttributes type exposes the following members.

Properties

 | Name | Description
Public property | AllowMessageBalloon | Gets a value indicating whether these attributes allow warning and error balloons to be drawn on top of them. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | Bounds | Gets the rectangle that contains the active content of the attributes. Typically the Contents determine the active area for menus, tooltips etc. Attributes are not supposed to draw objects beyond the Bounds. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | DocObject | Gets the owner object of these attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | GetTopLevel | Gets the top-level attributes of the attribute stack these attributes belong to. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | HasInputGrip | Gets a value indicating whether or not these attributes have an input grip. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | HasOutputGrip | Gets a value indicating whether or not these attributes have an output grip. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | InputGrip | Gets the input grip location for these attributes. If HasInputGrip equals False, this point is meaningless. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | InstanceGuid | Gets the instance ID of the document object that owns these attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | IsTopLevel | Gets whether these attributes are top_level (i.e. no Parent attributes) (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | OutputGrip | Gets the output grip location for these attributes. If HasOutputGrip equals False, this point is meaningless. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | Owner | Gets the type-safe owner object of these attributes. This property is identical to the DocObject property. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | Parent | Gets or sets the parent attributes. Top level attributes do not have parents. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | PathName | Get a description of the location of these attributes within the local attribute stack. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | Pivot | Gets or sets the pivot for these attributes. The pivot controls the general placement of the attributes. If you want to move the attributes, change the pivot location. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | Selected | Gets or sets the selected state of the top-level attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | TooltipEnabled | Gets the tooltip enabled value. If False, no further tooltip functions will be called. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)

See Also

GH_FloatingParamAttributes Class
Grasshopper.Kernel.Attributes Namespace


GH_LinkedParamAttributes Class

[image]

Grasshopper SDK
GH_LinkedParamAttributes Class
Members See Also Send Feedback
These Attributes are assigned to parameters that are part of a GH_Component.

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_LinkedParamAttributes : GH_Attributes<IGH_Param>
Visual Basic
Public Class GH_LinkedParamAttributes _
    Inherits GH_Attributes(Of IGH_Param)

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_Attributes <(Of <(<' IGH_Param >)>)>
Grasshopper.Kernel.Attributes..::..GH_LinkedParamAttributes

See Also

GH_LinkedParamAttributes Members
Grasshopper.Kernel.Attributes Namespace


GH_LinkedParamAttributes Members

[image] [image]

Grasshopper SDK
GH_LinkedParamAttributes Members
GH_LinkedParamAttributes Class Constructors Methods Properties See Also Send Feedback

The GH_LinkedParamAttributes type exposes the following members.

Constructors

 | Name | Description
Public method | GH_LinkedParamAttributes | Initializes a new instance of the GH_LinkedParamAttributes class

Methods

 | Name | Description
Public method | AppendToAttributeTree | Recursively append these attributes and all child attributes to the attribute list. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | ExpireLayout | Expires the entire layout of the attributes. When overridden, implementer must place a call to the base class ExpireLayout(). (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | InvalidateCanvas | If the mouse location should cause a canvas invalidation then return true. You only need to override this function if you draw objects that are dependant on cursor positions outside the bounds of the attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | IsMenuRegion | Determines whether a point is available for context menu popups. By default, IsMenuRegion calls IsPickRegion(PointF). (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | IsPickRegion(PointF) | Determines whether a point is within the pickable region for this object. By default, any point inside the Bounds is treated as pickable. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | IsPickRegion(RectangleF, GH_PickBox) | Determines whether a rectangle is a valid pick region for this object. By default, the picking rectangle is intersected with the Bounds rectangle. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | IsTooltipRegion | Determines whether a point is available for tooltip popups. By default, IsMenuRegion calls IsTooltipRegion(PointF). (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected method | Layout | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..Layout()()()().)
Public method | NewInstanceGuid()()()() | Generate a new instance GUID for the owner object. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | NewInstanceGuid(Guid) | Generate a new instance GUID for the owner object. Do not use this overload unless you're > 1.95m and called David. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | PerformLayout | Recompute the layout for these attributes. This function is automatically called during Drawing operations, so you typically don't have to. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected method | PrepareForRender | This method will always be called exactly once prior to Render(). This would be a good place to make sure all the necessary GUI data is up and running. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | Read | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected method | Render | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..Render(GH_Canvas, Graphics, GH_CanvasChannel).)
Protected method | RenderIncomingWires(GH_Painter, IEnumerable<(Of <<'(IGH_Param>)>>), GH_ParamWireDisplay) | Utility function for derived classes. This method draws all the wires going into the left side of the attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected method | RenderIncomingWires(GH_Painter, IEnumerable<(Of <<'(IGH_Param>)>>), IEnumerable<(Of <<'(Pen>)>>)) | Utility function for derived classes. This method draws all the wires going into the left side of the attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RenderToCanvas | Render these attributes into a Canvas control. This function places calls to PrepareForRender() and Render(), you should override those. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RespondToKeyDown | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RespondToKeyUp | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RespondToMouseDoubleClick | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RespondToMouseDown | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RespondToMouseMove | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RespondToMouseUp | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | SetupTooltip | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..SetupTooltip(PointF, GH_TooltipDisplayEventArgs).)
Public method | Write | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | AllowMessageBalloon | Gets a value indicating whether these attributes allow warning and error balloons to be drawn on top of them. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | Bounds | Gets the rectangle that contains the active content of the attributes. Typically the Contents determine the active area for menus, tooltips etc. Attributes are not supposed to draw objects beyond the Bounds. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | DocObject | Gets the owner object of these attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | GetTopLevel | Gets the top-level attributes of the attribute stack these attributes belong to. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | HasInputGrip | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..HasInputGrip.)
Public property | HasOutputGrip | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..HasOutputGrip.)
Public property | InputGrip | Gets the input grip location for these attributes. If HasInputGrip equals False, this point is meaningless. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | InstanceGuid | Gets the instance ID of the document object that owns these attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | IsTopLevel | Gets whether these attributes are top_level (i.e. no Parent attributes) (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | OutputGrip | Gets the output grip location for these attributes. If HasOutputGrip equals False, this point is meaningless. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | Owner | Gets the type-safe owner object of these attributes. This property is identical to the DocObject property. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | Parent | Gets or sets the parent attributes. Top level attributes do not have parents. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | PathName | Get a description of the location of these attributes within the local attribute stack. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | Pivot | Gets or sets the pivot for these attributes. The pivot controls the general placement of the attributes. If you want to move the attributes, change the pivot location. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | Selected | Gets or sets the selected state of the top-level attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | TooltipEnabled | Gets the tooltip enabled value. If False, no further tooltip functions will be called. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)

See Also

GH_LinkedParamAttributes Class
Grasshopper.Kernel.Attributes Namespace


GH_LinkedParamAttributes Constructor

[image]

Grasshopper SDK
GH_LinkedParamAttributes Constructor
GH_LinkedParamAttributes Class See Also Send Feedback
Initializes a new instance of the GH_LinkedParamAttributes class

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_LinkedParamAttributes(
    IGH_Param param,
    IGH_Attributes parent
)
Visual Basic
Public Sub New ( _
    param As IGH_Param, _
    parent As IGH_Attributes _
)

Parameters

param
Type: Grasshopper.Kernel..::..IGH_Param
parent
Type: Grasshopper.Kernel..::..IGH_Attributes

See Also

GH_LinkedParamAttributes Class
Grasshopper.Kernel.Attributes Namespace


GH_LinkedParamAttributes Methods

[image] [image]

Grasshopper SDK
GH_LinkedParamAttributes Methods
GH_LinkedParamAttributes Class See Also Send Feedback

The GH_LinkedParamAttributes type exposes the following members.

Methods

 | Name | Description
Public method | AppendToAttributeTree | Recursively append these attributes and all child attributes to the attribute list. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | ExpireLayout | Expires the entire layout of the attributes. When overridden, implementer must place a call to the base class ExpireLayout(). (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | InvalidateCanvas | If the mouse location should cause a canvas invalidation then return true. You only need to override this function if you draw objects that are dependant on cursor positions outside the bounds of the attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | IsMenuRegion | Determines whether a point is available for context menu popups. By default, IsMenuRegion calls IsPickRegion(PointF). (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | IsPickRegion(PointF) | Determines whether a point is within the pickable region for this object. By default, any point inside the Bounds is treated as pickable. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | IsPickRegion(RectangleF, GH_PickBox) | Determines whether a rectangle is a valid pick region for this object. By default, the picking rectangle is intersected with the Bounds rectangle. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | IsTooltipRegion | Determines whether a point is available for tooltip popups. By default, IsMenuRegion calls IsTooltipRegion(PointF). (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected method | Layout | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..Layout()()()().)
Public method | NewInstanceGuid()()()() | Generate a new instance GUID for the owner object. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | NewInstanceGuid(Guid) | Generate a new instance GUID for the owner object. Do not use this overload unless you're > 1.95m and called David. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | PerformLayout | Recompute the layout for these attributes. This function is automatically called during Drawing operations, so you typically don't have to. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected method | PrepareForRender | This method will always be called exactly once prior to Render(). This would be a good place to make sure all the necessary GUI data is up and running. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | Read | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected method | Render | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..Render(GH_Canvas, Graphics, GH_CanvasChannel).)
Protected method | RenderIncomingWires(GH_Painter, IEnumerable<(Of <<'(IGH_Param>)>>), GH_ParamWireDisplay) | Utility function for derived classes. This method draws all the wires going into the left side of the attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected method | RenderIncomingWires(GH_Painter, IEnumerable<(Of <<'(IGH_Param>)>>), IEnumerable<(Of <<'(Pen>)>>)) | Utility function for derived classes. This method draws all the wires going into the left side of the attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RenderToCanvas | Render these attributes into a Canvas control. This function places calls to PrepareForRender() and Render(), you should override those. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RespondToKeyDown | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RespondToKeyUp | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RespondToMouseDoubleClick | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RespondToMouseDown | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RespondToMouseMove | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RespondToMouseUp | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | SetupTooltip | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..SetupTooltip(PointF, GH_TooltipDisplayEventArgs).)
Public method | Write | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)

See Also

GH_LinkedParamAttributes Class
Grasshopper.Kernel.Attributes Namespace


IsPickRegion Method

[image] [image]

Grasshopper SDK
GH_LinkedParamAttributes..::..IsPickRegion Method
GH_LinkedParamAttributes Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsPickRegion(PointF) | Determines whether a point is within the pickable region for this object. By default, any point inside the Bounds is treated as pickable. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | IsPickRegion(RectangleF, GH_PickBox) | Determines whether a rectangle is a valid pick region for this object. By default, the picking rectangle is intersected with the Bounds rectangle. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)

See Also

GH_LinkedParamAttributes Class
GH_LinkedParamAttributes Members
Grasshopper.Kernel.Attributes Namespace


Layout Method

[image]

Grasshopper SDK
GH_LinkedParamAttributes..::..Layout Method
GH_LinkedParamAttributes Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Layout()
Visual Basic
Protected Overrides Sub Layout

See Also

GH_LinkedParamAttributes Class
Grasshopper.Kernel.Attributes Namespace


NewInstanceGuid Method

[image] [image]

Grasshopper SDK
GH_LinkedParamAttributes..::..NewInstanceGuid Method
GH_LinkedParamAttributes Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NewInstanceGuid()()()() | Generate a new instance GUID for the owner object. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | NewInstanceGuid(Guid) | Generate a new instance GUID for the owner object. Do not use this overload unless you're > 1.95m and called David. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)

See Also

GH_LinkedParamAttributes Class
GH_LinkedParamAttributes Members
Grasshopper.Kernel.Attributes Namespace


Render Method

[image]

Grasshopper SDK
GH_LinkedParamAttributes..::..Render Method
GH_LinkedParamAttributes Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Render(
    GH_Canvas canvas,
    Graphics graphics,
    GH_CanvasChannel channel
)
Visual Basic
Protected Overrides Sub Render ( _
    canvas As GH_Canvas, _
    graphics As Graphics, _
    channel As GH_CanvasChannel _
)

Parameters

canvas
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
graphics
Type: System.Drawing..::..Graphics
channel
Type: Grasshopper.GUI.Canvas..::..GH_CanvasChannel

See Also

GH_LinkedParamAttributes Class
Grasshopper.Kernel.Attributes Namespace


RenderIncomingWires Method

[image] [image]

Grasshopper SDK
GH_LinkedParamAttributes..::..RenderIncomingWires Method
GH_LinkedParamAttributes Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RenderIncomingWires(GH_Painter, IEnumerable<(Of <<'(IGH_Param>)>>), GH_ParamWireDisplay) | Utility function for derived classes. This method draws all the wires going into the left side of the attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected method | RenderIncomingWires(GH_Painter, IEnumerable<(Of <<'(IGH_Param>)>>), IEnumerable<(Of <<'(Pen>)>>)) | Utility function for derived classes. This method draws all the wires going into the left side of the attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)

See Also

GH_LinkedParamAttributes Class
GH_LinkedParamAttributes Members
Grasshopper.Kernel.Attributes Namespace


SetupTooltip Method

[image]

Grasshopper SDK
GH_LinkedParamAttributes..::..SetupTooltip Method
GH_LinkedParamAttributes Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void SetupTooltip(
    PointF point,
    GH_TooltipDisplayEventArgs e
)
Visual Basic
Public Overrides Sub SetupTooltip ( _
    point As PointF, _
    e As GH_TooltipDisplayEventArgs _
)

Parameters

point
Type: System.Drawing..::..PointF
e
Type: Grasshopper.GUI..::..GH_TooltipDisplayEventArgs

See Also

GH_LinkedParamAttributes Class
Grasshopper.Kernel.Attributes Namespace


GH_LinkedParamAttributes Properties

[image] [image]

Grasshopper SDK
GH_LinkedParamAttributes Properties
GH_LinkedParamAttributes Class See Also Send Feedback

The GH_LinkedParamAttributes type exposes the following members.

Properties

 | Name | Description
Public property | AllowMessageBalloon | Gets a value indicating whether these attributes allow warning and error balloons to be drawn on top of them. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | Bounds | Gets the rectangle that contains the active content of the attributes. Typically the Contents determine the active area for menus, tooltips etc. Attributes are not supposed to draw objects beyond the Bounds. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | DocObject | Gets the owner object of these attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | GetTopLevel | Gets the top-level attributes of the attribute stack these attributes belong to. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | HasInputGrip | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..HasInputGrip.)
Public property | HasOutputGrip | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..HasOutputGrip.)
Public property | InputGrip | Gets the input grip location for these attributes. If HasInputGrip equals False, this point is meaningless. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | InstanceGuid | Gets the instance ID of the document object that owns these attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | IsTopLevel | Gets whether these attributes are top_level (i.e. no Parent attributes) (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | OutputGrip | Gets the output grip location for these attributes. If HasOutputGrip equals False, this point is meaningless. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | Owner | Gets the type-safe owner object of these attributes. This property is identical to the DocObject property. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | Parent | Gets or sets the parent attributes. Top level attributes do not have parents. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | PathName | Get a description of the location of these attributes within the local attribute stack. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | Pivot | Gets or sets the pivot for these attributes. The pivot controls the general placement of the attributes. If you want to move the attributes, change the pivot location. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | Selected | Gets or sets the selected state of the top-level attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | TooltipEnabled | Gets the tooltip enabled value. If False, no further tooltip functions will be called. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)

See Also

GH_LinkedParamAttributes Class
Grasshopper.Kernel.Attributes Namespace


HasInputGrip Property

[image]

Grasshopper SDK
GH_LinkedParamAttributes..::..HasInputGrip Property
GH_LinkedParamAttributes Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool HasInputGrip { get; }
Visual Basic
Public Overrides ReadOnly Property HasInputGrip As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Attributes.GH_LinkedParamAttributes.HasInputGrip"]

See Also

GH_LinkedParamAttributes Class
Grasshopper.Kernel.Attributes Namespace


HasOutputGrip Property

[image]

Grasshopper SDK
GH_LinkedParamAttributes..::..HasOutputGrip Property
GH_LinkedParamAttributes Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool HasOutputGrip { get; }
Visual Basic
Public Overrides ReadOnly Property HasOutputGrip As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Attributes.GH_LinkedParamAttributes.HasOutputGrip"]

See Also

GH_LinkedParamAttributes Class
Grasshopper.Kernel.Attributes Namespace


GH_ResizableAttributes(T) Class

[image]

Grasshopper SDK
GH_ResizableAttributes<(Of <(<'T>)>)> Class
Members See Also Send Feedback
These Attributes provide basic resizing logic.

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract class GH_ResizableAttributes<T> : GH_Attributes<T>
where T : IGH_DocumentObject
Visual Basic
Public MustInherit Class GH_ResizableAttributes(Of T As IGH_DocumentObject) _
    Inherits GH_Attributes(Of T)

Type Parameters

T

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_Attributes <(Of <(<'T>)>)>
Grasshopper.Kernel.Attributes..::..GH_ResizableAttributes<(Of <(<'T>)>)>

See Also

GH_ResizableAttributes<(Of <(<'T>)>)> Members
Grasshopper.Kernel.Attributes Namespace


GH_ResizableAttributes(T) Members

[image] [image]

Grasshopper SDK
GH_ResizableAttributes<(Of <(<'T>)>)> Members
GH_ResizableAttributes<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The GH_ResizableAttributes<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Protected method | GH_ResizableAttributes<(Of <(<'T>)>)> | Initializes a new instance of the GH_ResizableAttributes<(Of <(<'T>)>)> class

Methods

 | Name | Description
Public method | AppendToAttributeTree | Recursively append these attributes and all child attributes to the attribute list. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | ExpireLayout | Expires the entire layout of the attributes. When overridden, implementer must place a call to the base class ExpireLayout(). (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | InvalidateCanvas | If the mouse location should cause a canvas invalidation then return true. You only need to override this function if you draw objects that are dependant on cursor positions outside the bounds of the attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | IsMenuRegion | Determines whether a point is available for context menu popups. By default, IsMenuRegion calls IsPickRegion(PointF). (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | IsPickRegion(PointF) | Determines whether a point is within the pickable region for this object. By default, any point inside the Bounds is treated as pickable. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | IsPickRegion(RectangleF, GH_PickBox) | Determines whether a rectangle is a valid pick region for this object. By default, the picking rectangle is intersected with the Bounds rectangle. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | IsTooltipRegion | Determines whether a point is available for tooltip popups. By default, IsMenuRegion calls IsTooltipRegion(PointF). (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected method | Layout | Perform dedicated layout logic specific to this particular DocumentObject. This method is called from PerformLayout if the existing layout is stale. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | NewInstanceGuid()()()() | Generate a new instance GUID for the owner object. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | NewInstanceGuid(Guid) | Generate a new instance GUID for the owner object. Do not use this overload unless you're > 1.95m and called David. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | PerformLayout | Recompute the layout for these attributes. This function is automatically called during Drawing operations, so you typically don't have to. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected method | PrepareForRender | This method will always be called exactly once prior to Render(). This would be a good place to make sure all the necessary GUI data is up and running. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | Read | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected method | Render | Override this function to supply custom Render logic. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected method | RenderIncomingWires(GH_Painter, IEnumerable<(Of <<'(IGH_Param>)>>), GH_ParamWireDisplay) | Utility function for derived classes. This method draws all the wires going into the left side of the attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected method | RenderIncomingWires(GH_Painter, IEnumerable<(Of <<'(IGH_Param>)>>), IEnumerable<(Of <<'(Pen>)>>)) | Utility function for derived classes. This method draws all the wires going into the left side of the attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RenderToCanvas | Render these attributes into a Canvas control. This function places calls to PrepareForRender() and Render(), you should override those. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RespondToKeyDown | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RespondToKeyUp | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RespondToMouseDoubleClick | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RespondToMouseDown | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..RespondToMouseDown(GH_Canvas, GH_CanvasMouseEvent).)
Public method | RespondToMouseMove | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..RespondToMouseMove(GH_Canvas, GH_CanvasMouseEvent).)
Public method | RespondToMouseUp | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..RespondToMouseUp(GH_Canvas, GH_CanvasMouseEvent).)
Public method | SetupTooltip | Populates the Grasshopper tooltip with all relevant data. If this function returns True, it is assumed that all possible fields have been filled out and the tooltip is ready for display. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | Write | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | AllowMessageBalloon | Gets a value indicating whether these attributes allow warning and error balloons to be drawn on top of them. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | Bounds | Gets the rectangle that contains the active content of the attributes. Typically the Contents determine the active area for menus, tooltips etc. Attributes are not supposed to draw objects beyond the Bounds. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | DocObject | Gets the owner object of these attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | GetTopLevel | Gets the top-level attributes of the attribute stack these attributes belong to. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | HasInputGrip | Gets a value indicating whether or not these attributes have an input grip. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | HasOutputGrip | Gets a value indicating whether or not these attributes have an output grip. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | InputGrip | Gets the input grip location for these attributes. If HasInputGrip equals False, this point is meaningless. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | InstanceGuid | Gets the instance ID of the document object that owns these attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | IsTopLevel | Gets whether these attributes are top_level (i.e. no Parent attributes) (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected property | MaximumSize |
Protected property | MinimumSize |
Public property | OutputGrip | Gets the output grip location for these attributes. If HasOutputGrip equals False, this point is meaningless. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | Owner | Gets the type-safe owner object of these attributes. This property is identical to the DocObject property. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | Parent | Gets or sets the parent attributes. Top level attributes do not have parents. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | PathName | Get a description of the location of these attributes within the local attribute stack. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | Pivot | Gets or sets the pivot for these attributes. The pivot controls the general placement of the attributes. If you want to move the attributes, change the pivot location. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | Selected | Gets or sets the selected state of the top-level attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected property | SizingBorders |
Public property | TooltipEnabled | Gets the tooltip enabled value. If False, no further tooltip functions will be called. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)

See Also

GH_ResizableAttributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Attributes Namespace


GH_ResizableAttributes(T) Constructor

[image]

Grasshopper SDK
GH_ResizableAttributes<(Of <(<'T>)>)> Constructor
GH_ResizableAttributes<(Of <(<'T>)>)> Class See Also Send Feedback
Initializes a new instance of the GH_ResizableAttributes<(Of <(<'T>)>)> class

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_ResizableAttributes(
    T owner
)
Visual Basic
Protected Sub New ( _
    owner As T _
)

Parameters

owner
Type: T

See Also

GH_ResizableAttributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Attributes Namespace


GH_ResizableAttributes(T) Methods

[image] [image]

Grasshopper SDK
GH_ResizableAttributes<(Of <(<'T>)>)> Methods
GH_ResizableAttributes<(Of <(<'T>)>)> Class See Also Send Feedback

The GH_ResizableAttributes<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | AppendToAttributeTree | Recursively append these attributes and all child attributes to the attribute list. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | ExpireLayout | Expires the entire layout of the attributes. When overridden, implementer must place a call to the base class ExpireLayout(). (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | InvalidateCanvas | If the mouse location should cause a canvas invalidation then return true. You only need to override this function if you draw objects that are dependant on cursor positions outside the bounds of the attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | IsMenuRegion | Determines whether a point is available for context menu popups. By default, IsMenuRegion calls IsPickRegion(PointF). (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | IsPickRegion(PointF) | Determines whether a point is within the pickable region for this object. By default, any point inside the Bounds is treated as pickable. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | IsPickRegion(RectangleF, GH_PickBox) | Determines whether a rectangle is a valid pick region for this object. By default, the picking rectangle is intersected with the Bounds rectangle. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | IsTooltipRegion | Determines whether a point is available for tooltip popups. By default, IsMenuRegion calls IsTooltipRegion(PointF). (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected method | Layout | Perform dedicated layout logic specific to this particular DocumentObject. This method is called from PerformLayout if the existing layout is stale. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | NewInstanceGuid()()()() | Generate a new instance GUID for the owner object. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | NewInstanceGuid(Guid) | Generate a new instance GUID for the owner object. Do not use this overload unless you're > 1.95m and called David. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | PerformLayout | Recompute the layout for these attributes. This function is automatically called during Drawing operations, so you typically don't have to. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected method | PrepareForRender | This method will always be called exactly once prior to Render(). This would be a good place to make sure all the necessary GUI data is up and running. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | Read | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected method | Render | Override this function to supply custom Render logic. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected method | RenderIncomingWires(GH_Painter, IEnumerable<(Of <<'(IGH_Param>)>>), GH_ParamWireDisplay) | Utility function for derived classes. This method draws all the wires going into the left side of the attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected method | RenderIncomingWires(GH_Painter, IEnumerable<(Of <<'(IGH_Param>)>>), IEnumerable<(Of <<'(Pen>)>>)) | Utility function for derived classes. This method draws all the wires going into the left side of the attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RenderToCanvas | Render these attributes into a Canvas control. This function places calls to PrepareForRender() and Render(), you should override those. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RespondToKeyDown | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RespondToKeyUp | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RespondToMouseDoubleClick | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | RespondToMouseDown | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..RespondToMouseDown(GH_Canvas, GH_CanvasMouseEvent).)
Public method | RespondToMouseMove | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..RespondToMouseMove(GH_Canvas, GH_CanvasMouseEvent).)
Public method | RespondToMouseUp | (Overrides GH_Attributes<(Of <(<'T>)>)>..::..RespondToMouseUp(GH_Canvas, GH_CanvasMouseEvent).)
Public method | SetupTooltip | Populates the Grasshopper tooltip with all relevant data. If this function returns True, it is assumed that all possible fields have been filled out and the tooltip is ready for display. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | Write | (Inherited from GH_Attributes<(Of <(<'T>)>)>.)

See Also

GH_ResizableAttributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Attributes Namespace


IsPickRegion Method

[image] [image]

Grasshopper SDK
GH_ResizableAttributes<(Of <(<'T>)>)>..::..IsPickRegion Method
GH_ResizableAttributes<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsPickRegion(PointF) | Determines whether a point is within the pickable region for this object. By default, any point inside the Bounds is treated as pickable. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | IsPickRegion(RectangleF, GH_PickBox) | Determines whether a rectangle is a valid pick region for this object. By default, the picking rectangle is intersected with the Bounds rectangle. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)

See Also

GH_ResizableAttributes<(Of <(<'T>)>)> Class
GH_ResizableAttributes<(Of <(<'T>)>)> Members
Grasshopper.Kernel.Attributes Namespace


NewInstanceGuid Method

[image] [image]

Grasshopper SDK
GH_ResizableAttributes<(Of <(<'T>)>)>..::..NewInstanceGuid Method
GH_ResizableAttributes<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NewInstanceGuid()()()() | Generate a new instance GUID for the owner object. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public method | NewInstanceGuid(Guid) | Generate a new instance GUID for the owner object. Do not use this overload unless you're > 1.95m and called David. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)

See Also

GH_ResizableAttributes<(Of <(<'T>)>)> Class
GH_ResizableAttributes<(Of <(<'T>)>)> Members
Grasshopper.Kernel.Attributes Namespace


RenderIncomingWires Method

[image] [image]

Grasshopper SDK
GH_ResizableAttributes<(Of <(<'T>)>)>..::..RenderIncomingWires Method
GH_ResizableAttributes<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RenderIncomingWires(GH_Painter, IEnumerable<(Of <<'(IGH_Param>)>>), GH_ParamWireDisplay) | Utility function for derived classes. This method draws all the wires going into the left side of the attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected method | RenderIncomingWires(GH_Painter, IEnumerable<(Of <<'(IGH_Param>)>>), IEnumerable<(Of <<'(Pen>)>>)) | Utility function for derived classes. This method draws all the wires going into the left side of the attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)

See Also

GH_ResizableAttributes<(Of <(<'T>)>)> Class
GH_ResizableAttributes<(Of <(<'T>)>)> Members
Grasshopper.Kernel.Attributes Namespace


RespondToMouseDown Method

[image]

Grasshopper SDK
GH_ResizableAttributes<(Of <(<'T>)>)>..::..RespondToMouseDown Method
GH_ResizableAttributes<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override GH_ObjectResponse RespondToMouseDown(
    GH_Canvas sender,
    GH_CanvasMouseEvent e
)
Visual Basic
Public Overrides Function RespondToMouseDown ( _
    sender As GH_Canvas, _
    e As GH_CanvasMouseEvent _
) As GH_ObjectResponse

Parameters

sender
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
e
Type: Grasshopper.GUI..::..GH_CanvasMouseEvent

See Also

GH_ResizableAttributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Attributes Namespace


RespondToMouseMove Method

[image]

Grasshopper SDK
GH_ResizableAttributes<(Of <(<'T>)>)>..::..RespondToMouseMove Method
GH_ResizableAttributes<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override GH_ObjectResponse RespondToMouseMove(
    GH_Canvas sender,
    GH_CanvasMouseEvent e
)
Visual Basic
Public Overrides Function RespondToMouseMove ( _
    sender As GH_Canvas, _
    e As GH_CanvasMouseEvent _
) As GH_ObjectResponse

Parameters

sender
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
e
Type: Grasshopper.GUI..::..GH_CanvasMouseEvent

See Also

GH_ResizableAttributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Attributes Namespace


RespondToMouseUp Method

[image]

Grasshopper SDK
GH_ResizableAttributes<(Of <(<'T>)>)>..::..RespondToMouseUp Method
GH_ResizableAttributes<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override GH_ObjectResponse RespondToMouseUp(
    GH_Canvas sender,
    GH_CanvasMouseEvent e
)
Visual Basic
Public Overrides Function RespondToMouseUp ( _
    sender As GH_Canvas, _
    e As GH_CanvasMouseEvent _
) As GH_ObjectResponse

Parameters

sender
Type: Grasshopper.GUI.Canvas..::..GH_Canvas
e
Type: Grasshopper.GUI..::..GH_CanvasMouseEvent

See Also

GH_ResizableAttributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Attributes Namespace


GH_ResizableAttributes(T) Properties

[image] [image]

Grasshopper SDK
GH_ResizableAttributes<(Of <(<'T>)>)> Properties
GH_ResizableAttributes<(Of <(<'T>)>)> Class See Also Send Feedback

The GH_ResizableAttributes<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | AllowMessageBalloon | Gets a value indicating whether these attributes allow warning and error balloons to be drawn on top of them. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | Bounds | Gets the rectangle that contains the active content of the attributes. Typically the Contents determine the active area for menus, tooltips etc. Attributes are not supposed to draw objects beyond the Bounds. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | DocObject | Gets the owner object of these attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | GetTopLevel | Gets the top-level attributes of the attribute stack these attributes belong to. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | HasInputGrip | Gets a value indicating whether or not these attributes have an input grip. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | HasOutputGrip | Gets a value indicating whether or not these attributes have an output grip. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | InputGrip | Gets the input grip location for these attributes. If HasInputGrip equals False, this point is meaningless. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | InstanceGuid | Gets the instance ID of the document object that owns these attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | IsTopLevel | Gets whether these attributes are top_level (i.e. no Parent attributes) (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected property | MaximumSize |
Protected property | MinimumSize |
Public property | OutputGrip | Gets the output grip location for these attributes. If HasOutputGrip equals False, this point is meaningless. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | Owner | Gets the type-safe owner object of these attributes. This property is identical to the DocObject property. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | Parent | Gets or sets the parent attributes. Top level attributes do not have parents. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | PathName | Get a description of the location of these attributes within the local attribute stack. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | Pivot | Gets or sets the pivot for these attributes. The pivot controls the general placement of the attributes. If you want to move the attributes, change the pivot location. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Public property | Selected | Gets or sets the selected state of the top-level attributes. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)
Protected property | SizingBorders |
Public property | TooltipEnabled | Gets the tooltip enabled value. If False, no further tooltip functions will be called. (Inherited from GH_Attributes<(Of <(<'T>)>)>.)

See Also

GH_ResizableAttributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Attributes Namespace


MaximumSize Property

[image]

Grasshopper SDK
GH_ResizableAttributes<(Of <(<'T>)>)>..::..MaximumSize Property
GH_ResizableAttributes<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected virtual Size MaximumSize { get; }
Visual Basic
Protected Overridable ReadOnly Property MaximumSize As Size
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Attributes.GH_ResizableAttributes`1.MaximumSize"]

See Also

GH_ResizableAttributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Attributes Namespace


MinimumSize Property

[image]

Grasshopper SDK
GH_ResizableAttributes<(Of <(<'T>)>)>..::..MinimumSize Property
GH_ResizableAttributes<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected abstract Size MinimumSize { get; }
Visual Basic
Protected MustOverride ReadOnly Property MinimumSize As Size
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Attributes.GH_ResizableAttributes`1.MinimumSize"]

See Also

GH_ResizableAttributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Attributes Namespace


SizingBorders Property

[image]

Grasshopper SDK
GH_ResizableAttributes<(Of <(<'T>)>)>..::..SizingBorders Property
GH_ResizableAttributes<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Attributes
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected abstract Padding SizingBorders { get; }
Visual Basic
Protected MustOverride ReadOnly Property SizingBorders As Padding
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Attributes.GH_ResizableAttributes`1.SizingBorders"]

See Also

GH_ResizableAttributes<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Attributes Namespace


Grasshopper.Kernel.Data Namespace

[image]

Grasshopper SDK
Grasshopper.Kernel.Data Namespace
Send Feedback
Contains a number of classes that deal with Data Storage.

Classes

 | Class | Description
Public class | GH_BracketMismatchException | Exception used during Rule Set parsing.
Public class | GH_IndexRanges | Represents a sorted, non-colliding collection of index ranges.
Public class | GH_IndexRuleSet | A collection of index rules.
Public class | GH_Lexer | Represents a lexical mask for path operations.
Public class | GH_LexerCombo | Contains both a source and a target lexer object.
Public class | GH_Path | Describes the path in structure space of a data item or a list of items. A path consists of a series of integers, each one of which represents an index in a branch structure.
Public class | GH_Path..::..PathLengthComparer | Use this comparer to sort lists of paths using a topological approach. Shorter paths are favoured over longer paths. Equal length paths use the default comparer.
Public class | GH_PathOffset | Represents a relative offset within a data structure.
Public class | GH_Pattern | Represents an entire path match pattern.
Public class | GH_PatternElement | A single element in a string of path matching comparisons.
Public class | GH_StringMismatchException | Exception used during Rule Set parsing.
Public class | GH_Structure<(Of <(<'T>)>)> | Represents a data tree where each branch has a unique path
Public class | GH_TreeFilter | Represents a collection of rules for validating DataTree paths and indices.

Structures

 | Structure | Description
Public structure | GH_IndexRange | Represents a range of indices.
Public structure | GH_TreeIndex | Represents a single unique location in a DataTree.

Interfaces

 | Interface | Description
Public interface | IGH_DataTree | Utility interface for detection of DataTree generic instances.
Public interface | IGH_IndexRule | Interface for index rules. An index rule is a way to determine whether a specific integer is considered valid, invalid or neutral. Index rules are used for selecting elements in DataTrees.
Public interface | IGH_Structure | Base interface for all GH_Structure types.
Public interface | IGH_StructureEnumerator | Defines a minimum interface for iterating over all data in an IGH_Structure.

Delegates

 | Delegate | Description
Public delegate | GH_Structure<(Of <(<'T>)>)>..::..ConversionDelegate<(Of <(<'Tfrom, Tto>)>)> | Represents a conversion between two types of IGH_Goo.

Enumerations

 | Enumeration | Description
Public enumeration | GH_ExpandMode | Enumerates the possible expansion modes for structure paths.
Public enumeration | GH_GraftMode | Enumerates all predefined grafting modes.
Public enumeration | GH_PatternType | Represents all possible element types in a Path Pattern.
Public enumeration | GH_RuleResult | Enumerates the possible opinions a rule can have.
Public enumeration | GH_SimplificationMode | Enumerates the possible data structure simplification modes.


GH_BracketMismatchException Class

[image]

Grasshopper SDK
GH_BracketMismatchException Class
Members See Also Send Feedback
Exception used during Rule Set parsing.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_BracketMismatchException : Exception
Visual Basic
Public Class GH_BracketMismatchException _
    Inherits Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
Grasshopper.Kernel.Data..::..GH_BracketMismatchException

See Also

GH_BracketMismatchException Members
Grasshopper.Kernel.Data Namespace


GH_BracketMismatchException Members

[image] [image]

Grasshopper SDK
GH_BracketMismatchException Members
GH_BracketMismatchException Class Constructors Properties See Also Send Feedback

The GH_BracketMismatchException type exposes the following members.

Constructors

 | Name | Description
Public method | GH_BracketMismatchException()()()() | Initializes a new instance of the GH_BracketMismatchException class
Public method | GH_BracketMismatchException(String) | Initializes a new instance of the GH_BracketMismatchException class
Public method | GH_BracketMismatchException(String, Int32) | Initializes a new instance of the GH_BracketMismatchException class

Properties

 | Name | Description
Public property | Index |

See Also

GH_BracketMismatchException Class
Grasshopper.Kernel.Data Namespace


GH_BracketMismatchException Constructor

[image] [image]

Grasshopper SDK
GH_BracketMismatchException Constructor
GH_BracketMismatchException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_BracketMismatchException()()()() | Initializes a new instance of the GH_BracketMismatchException class
Public method | GH_BracketMismatchException(String) | Initializes a new instance of the GH_BracketMismatchException class
Public method | GH_BracketMismatchException(String, Int32) | Initializes a new instance of the GH_BracketMismatchException class

See Also

GH_BracketMismatchException Class
GH_BracketMismatchException Members
Grasshopper.Kernel.Data Namespace


GH_BracketMismatchException Constructor

[image]

Grasshopper SDK
GH_BracketMismatchException Constructor
GH_BracketMismatchException Class See Also Send Feedback
Initializes a new instance of the GH_BracketMismatchException class

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_BracketMismatchException()
Visual Basic
Public Sub New

See Also

GH_BracketMismatchException Class
GH_BracketMismatchException Overload
Grasshopper.Kernel.Data Namespace


GH_BracketMismatchException Constructor (String)

[image]

Grasshopper SDK
GH_BracketMismatchException Constructor (String)
GH_BracketMismatchException Class See Also Send Feedback
Initializes a new instance of the GH_BracketMismatchException class

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_BracketMismatchException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)

Parameters

message
Type: System..::..String

See Also

GH_BracketMismatchException Class
GH_BracketMismatchException Overload
Grasshopper.Kernel.Data Namespace


GH_BracketMismatchException Constructor (String, Int32)

[image]

Grasshopper SDK
GH_BracketMismatchException Constructor (String, Int32)
GH_BracketMismatchException Class See Also Send Feedback
Initializes a new instance of the GH_BracketMismatchException class

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_BracketMismatchException(
    string message,
    int location
)
Visual Basic
Public Sub New ( _
    message As String, _
    location As Integer _
)

Parameters

message
Type: System..::..String
location
Type: System..::..Int32

See Also

GH_BracketMismatchException Class
GH_BracketMismatchException Overload
Grasshopper.Kernel.Data Namespace


GH_BracketMismatchException Properties

[image] [image]

Grasshopper SDK
GH_BracketMismatchException Properties
GH_BracketMismatchException Class See Also Send Feedback

The GH_BracketMismatchException type exposes the following members.

Properties

 | Name | Description
Public property | Index |

See Also

GH_BracketMismatchException Class
Grasshopper.Kernel.Data Namespace


Index Property

[image]

Grasshopper SDK
GH_BracketMismatchException..::..Index Property
GH_BracketMismatchException Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int Index { get; }
Visual Basic
Public ReadOnly Property Index As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_BracketMismatchException.Index"]

See Also

GH_BracketMismatchException Class
Grasshopper.Kernel.Data Namespace


GH_ExpandMode Enumeration

[image]

Grasshopper SDK
GH_ExpandMode Enumeration
See Also Send Feedback
Enumerates the possible expansion modes for structure paths.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_ExpandMode
Visual Basic
Public Enumeration GH_ExpandMode

Members

Member name | Value | Description
None | 0 | Indicates no expansion should take place.
SimpleReplace | 1 | Paths are expanded and collisions are erased.
SimpleAppend | 2 | Paths are expanded and merged with colliding paths.
Recursive | 3 | Before a path is expanded, any collision is expanded first.

See Also

Grasshopper.Kernel.Data Namespace


GH_GraftMode Enumeration

[image]

Grasshopper SDK
GH_GraftMode Enumeration
See Also Send Feedback
Enumerates all predefined grafting modes.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
[FlagsAttribute]
public enum GH_GraftMode
Visual Basic
<FlagsAttribute> _
Public Enumeration GH_GraftMode

Members

Member name | Value | Description
None | 0 | Don't include null items or empty lists.
GraftNullItems | 1 | Null items are included in the grafted tree.
GraftEmptyLists | 2 | Empty lists are included in the grafted tree.
GraftAll | 3 | Null items and empty lists are both included in the grafted tree.

See Also

Grasshopper.Kernel.Data Namespace


GH_IndexRange Structure

[image]

Grasshopper SDK
GH_IndexRange Structure
Members See Also Send Feedback
Represents a range of indices.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public struct GH_IndexRange : GH_ISerializable
Visual Basic
Public Structure GH_IndexRange _
    Implements GH_ISerializable

See Also

GH_IndexRange Members
Grasshopper.Kernel.Data Namespace


GH_IndexRange Members

[image] [image]

Grasshopper SDK
GH_IndexRange Members
GH_IndexRange Structure Constructors Methods Properties See Also Send Feedback

The GH_IndexRange type exposes the following members.

Constructors

 | Name | Description
Public method | GH_IndexRange(Int32) | Create a new singular range.
Public method | GH_IndexRange(Int32, Int32) | Create a new range.

Methods

 | Name | Description
Public method | AdjacentTo | Tests whether this range is adjacent to another.
Public method | Contains(Int32) | Tests whether a specified index is defined by this range.
Public method | Contains(GH_IndexRange) | Tests whether a specified range is entirely contained within this range.
 | Intersection | Create the intersection between two ranges.
Public method | IntersectsWith | Tests whether certain indices are described by both this and another range.
Public method | Read |
 | Split | Split a range into two using an integer index.
Public method | ToString | (Overrides ValueType..::..ToString()()()().)
 | Union | Create a range which contains both input ranges.
Public method | Write |

Properties

 | Name | Description
Public property | Index0 | Gets the first index in the range.
Public property | Index1 | Gets the last index in the range.
 | InvalidRange | Gets the predefined invalid range.
Public property | IsSingular | Gets whether the range has zero length.
Public property | IsValid | Gets whether this range is valid.
Public property | Length | Gets the length of the range.
 | MaxValue |

See Also

GH_IndexRange Structure
Grasshopper.Kernel.Data Namespace


GH_IndexRange Constructor

[image] [image]

Grasshopper SDK
GH_IndexRange Constructor
GH_IndexRange Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_IndexRange(Int32) | Create a new singular range.
Public method | GH_IndexRange(Int32, Int32) | Create a new range.

See Also

GH_IndexRange Structure
GH_IndexRange Members
Grasshopper.Kernel.Data Namespace


GH_IndexRange Constructor (Int32)

[image]

Grasshopper SDK
GH_IndexRange Constructor (Int32)
GH_IndexRange Structure See Also Send Feedback
Create a new singular range.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_IndexRange(
    int index
)
Visual Basic
Public Sub New ( _
    index As Integer _
)

Parameters

index
Type: System..::..Int32
Index of range start and end.

See Also

GH_IndexRange Structure
GH_IndexRange Overload
Grasshopper.Kernel.Data Namespace


GH_IndexRange Constructor (Int32, Int32)

[image]

Grasshopper SDK
GH_IndexRange Constructor (Int32, Int32)
GH_IndexRange Structure See Also Send Feedback
Create a new range.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_IndexRange(
    int index0,
    int index1
)
Visual Basic
Public Sub New ( _
    index0 As Integer, _
    index1 As Integer _
)

Parameters

index0
Type: System..::..Int32
First index in range.
index1
Type: System..::..Int32
Last index in range.

See Also

GH_IndexRange Structure
GH_IndexRange Overload
Grasshopper.Kernel.Data Namespace


GH_IndexRange Methods

[image] [image]

Grasshopper SDK
GH_IndexRange Methods
GH_IndexRange Structure See Also Send Feedback

The GH_IndexRange type exposes the following members.

Methods

 | Name | Description
Public method | AdjacentTo | Tests whether this range is adjacent to another.
Public method | Contains(Int32) | Tests whether a specified index is defined by this range.
Public method | Contains(GH_IndexRange) | Tests whether a specified range is entirely contained within this range.
 | Intersection | Create the intersection between two ranges.
Public method | IntersectsWith | Tests whether certain indices are described by both this and another range.
Public method | Read |
 | Split | Split a range into two using an integer index.
Public method | ToString | (Overrides ValueType..::..ToString()()()().)
 | Union | Create a range which contains both input ranges.
Public method | Write |

See Also

GH_IndexRange Structure
Grasshopper.Kernel.Data Namespace


AdjacentTo Method

[image]

Grasshopper SDK
GH_IndexRange..::..AdjacentTo Method
GH_IndexRange Structure See Also Send Feedback
Tests whether this range is adjacent to another.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool AdjacentTo(
    GH_IndexRange range
)
Visual Basic
Public Function AdjacentTo ( _
    range As GH_IndexRange _
) As Boolean

Parameters

range
Type: Grasshopper.Kernel.Data..::..GH_IndexRange
Range to test.

Return Value

True if the ranges are adjacent and not intersecting.

See Also

GH_IndexRange Structure
Grasshopper.Kernel.Data Namespace


Contains Method

[image] [image]

Grasshopper SDK
GH_IndexRange..::..Contains Method
GH_IndexRange Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | Contains(Int32) | Tests whether a specified index is defined by this range.
Public method | Contains(GH_IndexRange) | Tests whether a specified range is entirely contained within this range.

See Also

GH_IndexRange Structure
GH_IndexRange Members
Grasshopper.Kernel.Data Namespace


Contains Method (Int32)

[image]

Grasshopper SDK
GH_IndexRange..::..Contains Method (Int32)
GH_IndexRange Structure See Also Send Feedback
Tests whether a specified index is defined by this range.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Contains(
    int index
)
Visual Basic
Public Function Contains ( _
    index As Integer _
) As Boolean

Parameters

index
Type: System..::..Int32
Index to test.

Return Value

True if the index is inside this range.

See Also

GH_IndexRange Structure
Contains Overload
Grasshopper.Kernel.Data Namespace


Contains Method (GH_IndexRange)

[image]

Grasshopper SDK
GH_IndexRange..::..Contains Method (GH_IndexRange)
GH_IndexRange Structure See Also Send Feedback
Tests whether a specified range is entirely contained within this range.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Contains(
    GH_IndexRange range
)
Visual Basic
Public Function Contains ( _
    range As GH_IndexRange _
) As Boolean

Parameters

range
Type: Grasshopper.Kernel.Data..::..GH_IndexRange
Range to test.

Return Value

True if the range is inside this one.

See Also

GH_IndexRange Structure
Contains Overload
Grasshopper.Kernel.Data Namespace


Intersection Method

[image]

Grasshopper SDK
GH_IndexRange..::..Intersection Method
GH_IndexRange Structure See Also Send Feedback
Create the intersection between two ranges.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_IndexRange Intersection(
    GH_IndexRange range0,
    GH_IndexRange range1
)
Visual Basic
Public Shared Function Intersection ( _
    range0 As GH_IndexRange, _
    range1 As GH_IndexRange _
) As GH_IndexRange

Parameters

range0
Type: Grasshopper.Kernel.Data..::..GH_IndexRange
First range to intersect.
range1
Type: Grasshopper.Kernel.Data..::..GH_IndexRange
Second range to intersect.

Return Value

The intersection or an invalid range if the input doesn't intersect.

See Also

GH_IndexRange Structure
Grasshopper.Kernel.Data Namespace


IntersectsWith Method

[image]

Grasshopper SDK
GH_IndexRange..::..IntersectsWith Method
GH_IndexRange Structure See Also Send Feedback
Tests whether certain indices are described by both this and another range.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IntersectsWith(
    GH_IndexRange range
)
Visual Basic
Public Function IntersectsWith ( _
    range As GH_IndexRange _
) As Boolean

Parameters

range
Type: Grasshopper.Kernel.Data..::..GH_IndexRange
Range to intersect with.

Return Value

True if the ranges intersect.

See Also

GH_IndexRange Structure
Grasshopper.Kernel.Data Namespace


Read Method

[image]

Grasshopper SDK
GH_IndexRange..::..Read Method
GH_IndexRange Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Read(
    GH_IReader reader
)
Visual Basic
Public Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

Implements

GH_ISerializable..::..Read(GH_IReader)

See Also

GH_IndexRange Structure
Grasshopper.Kernel.Data Namespace


Split Method

[image]

Grasshopper SDK
GH_IndexRange..::..Split Method
GH_IndexRange Structure See Also Send Feedback
Split a range into two using an integer index.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static int Split(
    GH_IndexRange range,
    GH_IndexRange splitter,
    out GH_IndexRange result0,
    out GH_IndexRange result1
)
Visual Basic
Public Shared Function Split ( _
    range As GH_IndexRange, _
    splitter As GH_IndexRange, _
    <OutAttribute> ByRef result0 As GH_IndexRange, _
    <OutAttribute> ByRef result1 As GH_IndexRange _
) As Integer

Parameters

range
Type: Grasshopper.Kernel.Data..::..GH_IndexRange
Range to split.
splitter
Type: Grasshopper.Kernel.Data..::..GH_IndexRange
Range to split with.
result0
Type: Grasshopper.Kernel.Data..::..GH_IndexRange %
First split result if successful, or an invalid range if not.
result1
Type: Grasshopper.Kernel.Data..::..GH_IndexRange %
Second split result if successful, or an invalid range if not.

Return Value

The number of valid split results.

See Also

GH_IndexRange Structure
Grasshopper.Kernel.Data Namespace


ToString Method

[image]

Grasshopper SDK
GH_IndexRange..::..ToString Method
GH_IndexRange Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_IndexRange Structure
Grasshopper.Kernel.Data Namespace


Union Method

[image]

Grasshopper SDK
GH_IndexRange..::..Union Method
GH_IndexRange Structure See Also Send Feedback
Create a range which contains both input ranges.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_IndexRange Union(
    GH_IndexRange range0,
    GH_IndexRange range1
)
Visual Basic
Public Shared Function Union ( _
    range0 As GH_IndexRange, _
    range1 As GH_IndexRange _
) As GH_IndexRange

Parameters

range0
Type: Grasshopper.Kernel.Data..::..GH_IndexRange
range1
Type: Grasshopper.Kernel.Data..::..GH_IndexRange

Return Value

Smallest range big enough to contain both range0 and range1.

See Also

GH_IndexRange Structure
Grasshopper.Kernel.Data Namespace


Write Method

[image]

Grasshopper SDK
GH_IndexRange..::..Write Method
GH_IndexRange Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Write(
    GH_IWriter writer
)
Visual Basic
Public Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

Implements

GH_ISerializable..::..Write(GH_IWriter)

See Also

GH_IndexRange Structure
Grasshopper.Kernel.Data Namespace


GH_IndexRange Properties

[image] [image]

Grasshopper SDK
GH_IndexRange Properties
GH_IndexRange Structure See Also Send Feedback

The GH_IndexRange type exposes the following members.

Properties

 | Name | Description
Public property | Index0 | Gets the first index in the range.
Public property | Index1 | Gets the last index in the range.
 | InvalidRange | Gets the predefined invalid range.
Public property | IsSingular | Gets whether the range has zero length.
Public property | IsValid | Gets whether this range is valid.
Public property | Length | Gets the length of the range.
 | MaxValue |

See Also

GH_IndexRange Structure
Grasshopper.Kernel.Data Namespace


Index0 Property

[image]

Grasshopper SDK
GH_IndexRange..::..Index0 Property
GH_IndexRange Structure See Also Send Feedback
Gets the first index in the range.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int Index0 { get; }
Visual Basic
Public ReadOnly Property Index0 As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_IndexRange.Index0"]

See Also

GH_IndexRange Structure
Grasshopper.Kernel.Data Namespace


Index1 Property

[image]

Grasshopper SDK
GH_IndexRange..::..Index1 Property
GH_IndexRange Structure See Also Send Feedback
Gets the last index in the range.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int Index1 { get; }
Visual Basic
Public ReadOnly Property Index1 As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_IndexRange.Index1"]

See Also

GH_IndexRange Structure
Grasshopper.Kernel.Data Namespace


InvalidRange Property

[image]

Grasshopper SDK
GH_IndexRange..::..InvalidRange Property
GH_IndexRange Structure See Also Send Feedback
Gets the predefined invalid range.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_IndexRange InvalidRange { get; }
Visual Basic
Public Shared ReadOnly Property InvalidRange As GH_IndexRange
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_IndexRange.InvalidRange"]

See Also

GH_IndexRange Structure
Grasshopper.Kernel.Data Namespace


IsSingular Property

[image]

Grasshopper SDK
GH_IndexRange..::..IsSingular Property
GH_IndexRange Structure See Also Send Feedback
Gets whether the range has zero length.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsSingular { get; }
Visual Basic
Public ReadOnly Property IsSingular As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_IndexRange.IsSingular"]

See Also

GH_IndexRange Structure
Grasshopper.Kernel.Data Namespace


IsValid Property

[image]

Grasshopper SDK
GH_IndexRange..::..IsValid Property
GH_IndexRange Structure See Also Send Feedback
Gets whether this range is valid.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsValid { get; }
Visual Basic
Public ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_IndexRange.IsValid"]

See Also

GH_IndexRange Structure
Grasshopper.Kernel.Data Namespace


Length Property

[image]

Grasshopper SDK
GH_IndexRange..::..Length Property
GH_IndexRange Structure See Also Send Feedback
Gets the length of the range.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int Length { get; }
Visual Basic
Public ReadOnly Property Length As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_IndexRange.Length"]

See Also

GH_IndexRange Structure
Grasshopper.Kernel.Data Namespace


MaxValue Property

[image]

Grasshopper SDK
GH_IndexRange..::..MaxValue Property
GH_IndexRange Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_IndexRange MaxValue { get; }
Visual Basic
Public Shared ReadOnly Property MaxValue As GH_IndexRange
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_IndexRange.MaxValue"]

See Also

GH_IndexRange Structure
Grasshopper.Kernel.Data Namespace


GH_IndexRanges Class

[image]

Grasshopper SDK
GH_IndexRanges Class
Members See Also Send Feedback
Represents a sorted, non-colliding collection of index ranges.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_IndexRanges : GH_ISerializable
Visual Basic
Public Class GH_IndexRanges _
    Implements GH_ISerializable

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Data..::..GH_IndexRanges

See Also

GH_IndexRanges Members
Grasshopper.Kernel.Data Namespace


GH_IndexRanges Members

[image] [image]

Grasshopper SDK
GH_IndexRanges Members
GH_IndexRanges Class Constructors Methods Properties See Also Send Feedback

The GH_IndexRanges type exposes the following members.

Constructors

 | Name | Description
Public method | GH_IndexRanges | Initializes a new instance of the GH_IndexRanges class

Methods

 | Name | Description
Public method | InsertRange | Insert an index range into the collection.
Public method | Read |
Public method | RemoveRange | Remove an index range from the collection.
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | Write |

Properties

 | Name | Description
Public property | Count | Gets the number of ranges stored in this collection.
Public property | Range | Gets the range at the given index.

See Also

GH_IndexRanges Class
Grasshopper.Kernel.Data Namespace


GH_IndexRanges Constructor

[image]

Grasshopper SDK
GH_IndexRanges Constructor
GH_IndexRanges Class See Also Send Feedback
Initializes a new instance of the GH_IndexRanges class

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_IndexRanges()
Visual Basic
Public Sub New

See Also

GH_IndexRanges Class
Grasshopper.Kernel.Data Namespace


GH_IndexRanges Methods

[image] [image]

Grasshopper SDK
GH_IndexRanges Methods
GH_IndexRanges Class See Also Send Feedback

The GH_IndexRanges type exposes the following members.

Methods

 | Name | Description
Public method | InsertRange | Insert an index range into the collection.
Public method | Read |
Public method | RemoveRange | Remove an index range from the collection.
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | Write |

See Also

GH_IndexRanges Class
Grasshopper.Kernel.Data Namespace


InsertRange Method

[image]

Grasshopper SDK
GH_IndexRanges..::..InsertRange Method
GH_IndexRanges Class See Also Send Feedback
Insert an index range into the collection.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool InsertRange(
    GH_IndexRange range
)
Visual Basic
Public Function InsertRange ( _
    range As GH_IndexRange _
) As Boolean

Parameters

range
Type: Grasshopper.Kernel.Data..::..GH_IndexRange
Range to insert.

Return Value

True if the collection was meaningfully modified.

See Also

GH_IndexRanges Class
Grasshopper.Kernel.Data Namespace


Read Method

[image]

Grasshopper SDK
GH_IndexRanges..::..Read Method
GH_IndexRanges Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Read(
    GH_IReader reader
)
Visual Basic
Public Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

Implements

GH_ISerializable..::..Read(GH_IReader)

See Also

GH_IndexRanges Class
Grasshopper.Kernel.Data Namespace


RemoveRange Method

[image]

Grasshopper SDK
GH_IndexRanges..::..RemoveRange Method
GH_IndexRanges Class See Also Send Feedback
Remove an index range from the collection.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool RemoveRange(
    GH_IndexRange range
)
Visual Basic
Public Function RemoveRange ( _
    range As GH_IndexRange _
) As Boolean

Parameters

range
Type: Grasshopper.Kernel.Data..::..GH_IndexRange
Range to remove.

Return Value

True if the collection was meaningfully modified.

See Also

GH_IndexRanges Class
Grasshopper.Kernel.Data Namespace


ToString Method

[image]

Grasshopper SDK
GH_IndexRanges..::..ToString Method
GH_IndexRanges Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_IndexRanges Class
Grasshopper.Kernel.Data Namespace


Write Method

[image]

Grasshopper SDK
GH_IndexRanges..::..Write Method
GH_IndexRanges Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Write(
    GH_IWriter writer
)
Visual Basic
Public Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

Implements

GH_ISerializable..::..Write(GH_IWriter)

See Also

GH_IndexRanges Class
Grasshopper.Kernel.Data Namespace


GH_IndexRanges Properties

[image] [image]

Grasshopper SDK
GH_IndexRanges Properties
GH_IndexRanges Class See Also Send Feedback

The GH_IndexRanges type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of ranges stored in this collection.
Public property | Range | Gets the range at the given index.

See Also

GH_IndexRanges Class
Grasshopper.Kernel.Data Namespace


Count Property

[image]

Grasshopper SDK
GH_IndexRanges..::..Count Property
GH_IndexRanges Class See Also Send Feedback
Gets the number of ranges stored in this collection.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_IndexRanges.Count"]

See Also

GH_IndexRanges Class
Grasshopper.Kernel.Data Namespace


Range Property

[image]

Grasshopper SDK
GH_IndexRanges..::..Range Property
GH_IndexRanges Class See Also Send Feedback
Gets the range at the given index.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_IndexRange this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Range ( _
    index As Integer _
) As GH_IndexRange
    Get

Parameters

index
Type: System..::..Int32
Index of range to retrieve.

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_IndexRanges.Range(System.Int32)"]

See Also

GH_IndexRanges Class
Grasshopper.Kernel.Data Namespace


GH_IndexRuleSet Class

[image]

Grasshopper SDK
GH_IndexRuleSet Class
Members See Also Send Feedback
A collection of index rules.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_IndexRuleSet
Visual Basic
Public Class GH_IndexRuleSet

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Data..::..GH_IndexRuleSet

See Also

GH_IndexRuleSet Members
Grasshopper.Kernel.Data Namespace


GH_IndexRuleSet Members

[image] [image]

Grasshopper SDK
GH_IndexRuleSet Members
GH_IndexRuleSet Class Constructors Methods Properties See Also Send Feedback

The GH_IndexRuleSet type exposes the following members.

Constructors

 | Name | Description
Public method | GH_IndexRuleSet | Blank constructor. Creates an empty collection of rules.

Methods

 | Name | Description
Public method | AddAnyDigitRule | Append a rule for any single digit.
Public method | AddAnyDigitsRule | Append a rule for any amount of digits.
Public method | AddDigitPatternRule(array<Int32>[]()[][]) | Append a rule for filtering digit patterns.
Public method | AddDigitPatternRule(Int32, Int32) | Append a rule for filtering digit patterns. This pattern does not have an upper bound.
Public method | AddDigitPatternRule(Int32, Int32, Int32) | Append a rule for filtering digit patterns.
Public method | AddDigitRule | Append a single digit rule.
Public method | AddRangePatternRule | Append a rule for filtering range patterns.
Public method | AddRangeRule | Append a single range rule.
Public method | Evaluate | Evaluate the index given the local rules.

Properties

 | Name | Description
Public property | Count | Gets the number of rules defined in this collection.
Public property | Rule | Gets the rule at the specified index.

See Also

GH_IndexRuleSet Class
Grasshopper.Kernel.Data Namespace


GH_IndexRuleSet Constructor

[image]

Grasshopper SDK
GH_IndexRuleSet Constructor
GH_IndexRuleSet Class See Also Send Feedback
Blank constructor. Creates an empty collection of rules.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_IndexRuleSet()
Visual Basic
Public Sub New

See Also

GH_IndexRuleSet Class
Grasshopper.Kernel.Data Namespace


GH_IndexRuleSet Methods

[image] [image]

Grasshopper SDK
GH_IndexRuleSet Methods
GH_IndexRuleSet Class See Also Send Feedback

The GH_IndexRuleSet type exposes the following members.

Methods

 | Name | Description
Public method | AddAnyDigitRule | Append a rule for any single digit.
Public method | AddAnyDigitsRule | Append a rule for any amount of digits.
Public method | AddDigitPatternRule(array<Int32>[]()[][]) | Append a rule for filtering digit patterns.
Public method | AddDigitPatternRule(Int32, Int32) | Append a rule for filtering digit patterns. This pattern does not have an upper bound.
Public method | AddDigitPatternRule(Int32, Int32, Int32) | Append a rule for filtering digit patterns.
Public method | AddDigitRule | Append a single digit rule.
Public method | AddRangePatternRule | Append a rule for filtering range patterns.
Public method | AddRangeRule | Append a single range rule.
Public method | Evaluate | Evaluate the index given the local rules.

See Also

GH_IndexRuleSet Class
Grasshopper.Kernel.Data Namespace


AddAnyDigitRule Method

[image]

Grasshopper SDK
GH_IndexRuleSet..::..AddAnyDigitRule Method
GH_IndexRuleSet Class See Also Send Feedback
Append a rule for any single digit.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddAnyDigitRule()
Visual Basic
Public Sub AddAnyDigitRule

See Also

GH_IndexRuleSet Class
Grasshopper.Kernel.Data Namespace


AddAnyDigitsRule Method

[image]

Grasshopper SDK
GH_IndexRuleSet..::..AddAnyDigitsRule Method
GH_IndexRuleSet Class See Also Send Feedback
Append a rule for any amount of digits.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddAnyDigitsRule()
Visual Basic
Public Sub AddAnyDigitsRule

See Also

GH_IndexRuleSet Class
Grasshopper.Kernel.Data Namespace


AddDigitPatternRule Method

[image] [image]

Grasshopper SDK
GH_IndexRuleSet..::..AddDigitPatternRule Method
GH_IndexRuleSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddDigitPatternRule(array<Int32>[]()[][]) | Append a rule for filtering digit patterns.
Public method | AddDigitPatternRule(Int32, Int32) | Append a rule for filtering digit patterns. This pattern does not have an upper bound.
Public method | AddDigitPatternRule(Int32, Int32, Int32) | Append a rule for filtering digit patterns.

See Also

GH_IndexRuleSet Class
GH_IndexRuleSet Members
Grasshopper.Kernel.Data Namespace


AddDigitPatternRule Method (Int32[])

[image]

Grasshopper SDK
GH_IndexRuleSet..::..AddDigitPatternRule Method (array<Int32>[]()[][])
GH_IndexRuleSet Class See Also Send Feedback
Append a rule for filtering digit patterns.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddDigitPatternRule(
    int[] pattern
)
Visual Basic
Public Sub AddDigitPatternRule ( _
    pattern As Integer() _
)

Parameters

pattern
Type: array< System..::..Int32 >[]()[][]
Complete pattern. A complete pattern consists of at least three integers, the first one signifying the pattern lower bound, the last one signifying the patters upper bound (use Int32.MaxValue is you do not want to enforce an upper bound), and at least one integer in between defining the pattern growth.

See Also

GH_IndexRuleSet Class
AddDigitPatternRule Overload
Grasshopper.Kernel.Data Namespace


AddDigitPatternRule Method (Int32, Int32)

[image]

Grasshopper SDK
GH_IndexRuleSet..::..AddDigitPatternRule Method (Int32, Int32)
GH_IndexRuleSet Class See Also Send Feedback
Append a rule for filtering digit patterns. This pattern does not have an upper bound.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddDigitPatternRule(
    int firstDigit,
    int nextDigit
)
Visual Basic
Public Sub AddDigitPatternRule ( _
    firstDigit As Integer, _
    nextDigit As Integer _
)

Parameters

firstDigit
Type: System..::..Int32
First digit in pattern.
nextDigit
Type: System..::..Int32
Next digit in pattern.

See Also

GH_IndexRuleSet Class
AddDigitPatternRule Overload
Grasshopper.Kernel.Data Namespace


AddDigitPatternRule Method (Int32, Int32, Int32)

[image]

Grasshopper SDK
GH_IndexRuleSet..::..AddDigitPatternRule Method (Int32, Int32, Int32)
GH_IndexRuleSet Class See Also Send Feedback
Append a rule for filtering digit patterns.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddDigitPatternRule(
    int firstDigit,
    int nextDigit,
    int lastDigit
)
Visual Basic
Public Sub AddDigitPatternRule ( _
    firstDigit As Integer, _
    nextDigit As Integer, _
    lastDigit As Integer _
)

Parameters

firstDigit
Type: System..::..Int32
First digit in pattern.
nextDigit
Type: System..::..Int32
Next digit in pattern.
lastDigit
Type: System..::..Int32
Last digit in pattern.

See Also

GH_IndexRuleSet Class
AddDigitPatternRule Overload
Grasshopper.Kernel.Data Namespace


AddDigitRule Method

[image]

Grasshopper SDK
GH_IndexRuleSet..::..AddDigitRule Method
GH_IndexRuleSet Class See Also Send Feedback
Append a single digit rule.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddDigitRule(
    int digit,
    bool invert
)
Visual Basic
Public Sub AddDigitRule ( _
    digit As Integer, _
    invert As Boolean _
)

Parameters

digit
Type: System..::..Int32
Digit to filter.
invert
Type: System..::..Boolean
If true, the digit will be filtered against rather than for.

See Also

GH_IndexRuleSet Class
Grasshopper.Kernel.Data Namespace


AddRangePatternRule Method

[image]

Grasshopper SDK
GH_IndexRuleSet..::..AddRangePatternRule Method
GH_IndexRuleSet Class See Also Send Feedback
Append a rule for filtering range patterns.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddRangePatternRule(
    GH_IndexRange[] pattern
)
Visual Basic
Public Sub AddRangePatternRule ( _
    pattern As GH_IndexRange() _
)

Parameters

pattern
Type: array< Grasshopper.Kernel.Data..::..GH_IndexRange >[]()[][]
Complete pattern. A complete pattern consists of at least three ranges, the first one signifying the pattern lower bound, the last one signifying the patters upper bound (use GH_IndexRange.MaxValue is you do not want to enforce an upper bound), and at least one range in between defining the pattern growth.

See Also

GH_IndexRuleSet Class
Grasshopper.Kernel.Data Namespace


AddRangeRule Method

[image]

Grasshopper SDK
GH_IndexRuleSet..::..AddRangeRule Method
GH_IndexRuleSet Class See Also Send Feedback
Append a single range rule.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddRangeRule(
    GH_IndexRange range,
    bool invert
)
Visual Basic
Public Sub AddRangeRule ( _
    range As GH_IndexRange, _
    invert As Boolean _
)

Parameters

range
Type: Grasshopper.Kernel.Data..::..GH_IndexRange
Range to filter.
invert
Type: System..::..Boolean
If true, the range will be filtered against rather than for.

See Also

GH_IndexRuleSet Class
Grasshopper.Kernel.Data Namespace


Evaluate Method

[image]

Grasshopper SDK
GH_IndexRuleSet..::..Evaluate Method
GH_IndexRuleSet Class See Also Send Feedback
Evaluate the index given the local rules.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_RuleResult Evaluate(
    int index
)
Visual Basic
Public Function Evaluate ( _
    index As Integer _
) As GH_RuleResult

Parameters

index
Type: System..::..Int32
Index to evaluate.

Return Value

The result of the evaluation.

See Also

GH_IndexRuleSet Class
Grasshopper.Kernel.Data Namespace


GH_IndexRuleSet Properties

[image] [image]

Grasshopper SDK
GH_IndexRuleSet Properties
GH_IndexRuleSet Class See Also Send Feedback

The GH_IndexRuleSet type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of rules defined in this collection.
Public property | Rule | Gets the rule at the specified index.

See Also

GH_IndexRuleSet Class
Grasshopper.Kernel.Data Namespace


Count Property

[image]

Grasshopper SDK
GH_IndexRuleSet..::..Count Property
GH_IndexRuleSet Class See Also Send Feedback
Gets the number of rules defined in this collection.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_IndexRuleSet.Count"]

See Also

GH_IndexRuleSet Class
Grasshopper.Kernel.Data Namespace


Rule Property

[image]

Grasshopper SDK
GH_IndexRuleSet..::..Rule Property
GH_IndexRuleSet Class See Also Send Feedback
Gets the rule at the specified index.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_IndexRule this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Rule ( _
    index As Integer _
) As IGH_IndexRule
    Get

Parameters

index
Type: System..::..Int32

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_IndexRuleSet.Rule(System.Int32)"]

See Also

GH_IndexRuleSet Class
Grasshopper.Kernel.Data Namespace


GH_Lexer Class

[image]

Grasshopper SDK
GH_Lexer Class
Members See Also Send Feedback
Represents a lexical mask for path operations.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Lexer
Visual Basic
Public Class GH_Lexer

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Data..::..GH_Lexer

See Also

GH_Lexer Members
Grasshopper.Kernel.Data Namespace


GH_Lexer Members

[image] [image]

Grasshopper SDK
GH_Lexer Members
GH_Lexer Class Constructors Methods Properties See Also Send Feedback

The GH_Lexer type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Lexer()()()() | Blank constructor.
Public method | GH_Lexer(String) | Create a new mask from a textual string.

Methods

 | Name | Description
Public method | EvaluatePath | Evaluate the variables in this mask with the provided expression solver.
 | PerformLexicalReplace<(Of <<'(T>)>>)(GH_Lexer, GH_Lexer, DataTree<(Of <<'(T>)>>), DataTree<(Of <<'(T>)>>)) | Lexical Find..Replace operations.
 | PerformLexicalReplace<(Of <<'(T>)>>)(GH_Lexer, GH_Lexer, IGH_Structure, GH_Structure<(Of <<'(T>)>>)) | Lexical Find..Replace operations.

Properties

 | Name | Description
Public property | IsItem | Gets a value indicating whether or not the item portion of the lexer has been set.
Public property | IsPath | Gets a value indicating whether or not the path portion of the lexer has been set.
Public property | Item | Gets the item string that was extracted from the mask. The default is "append"
Public property | Mask | Gets the original string that represents the user input for this lexer.
Public property | Path | Gets the list of path strings that was extracted from the mask. If the mask hasn't been parsed yet, it will be parsed now. If the returned list is still nothing, parsing failed.

See Also

GH_Lexer Class
Grasshopper.Kernel.Data Namespace


GH_Lexer Constructor

[image] [image]

Grasshopper SDK
GH_Lexer Constructor
GH_Lexer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Lexer()()()() | Blank constructor.
Public method | GH_Lexer(String) | Create a new mask from a textual string.

See Also

GH_Lexer Class
GH_Lexer Members
Grasshopper.Kernel.Data Namespace


GH_Lexer Constructor

[image]

Grasshopper SDK
GH_Lexer Constructor
GH_Lexer Class See Also Send Feedback
Blank constructor.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Lexer()
Visual Basic
Public Sub New

See Also

GH_Lexer Class
GH_Lexer Overload
Grasshopper.Kernel.Data Namespace


GH_Lexer Constructor (String)

[image]

Grasshopper SDK
GH_Lexer Constructor (String)
GH_Lexer Class See Also Send Feedback
Create a new mask from a textual string.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Lexer(
    string M
)
Visual Basic
Public Sub New ( _
    M As String _
)

Parameters

M
Type: System..::..String
Mask string.

See Also

GH_Lexer Class
GH_Lexer Overload
Grasshopper.Kernel.Data Namespace


GH_Lexer Methods

[image] [image]

Grasshopper SDK
GH_Lexer Methods
GH_Lexer Class See Also Send Feedback

The GH_Lexer type exposes the following members.

Methods

 | Name | Description
Public method | EvaluatePath | Evaluate the variables in this mask with the provided expression solver.
 | PerformLexicalReplace<(Of <<'(T>)>>)(GH_Lexer, GH_Lexer, DataTree<(Of <<'(T>)>>), DataTree<(Of <<'(T>)>>)) | Lexical Find..Replace operations.
 | PerformLexicalReplace<(Of <<'(T>)>>)(GH_Lexer, GH_Lexer, IGH_Structure, GH_Structure<(Of <<'(T>)>>)) | Lexical Find..Replace operations.

See Also

GH_Lexer Class
Grasshopper.Kernel.Data Namespace


EvaluatePath Method

[image]

Grasshopper SDK
GH_Lexer..::..EvaluatePath Method
GH_Lexer Class See Also Send Feedback
Evaluate the variables in this mask with the provided expression solver.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool EvaluatePath(
    GH_ExpressionParser evaluator,
    ref GH_Path path,
    ref int index
)
Visual Basic
Public Function EvaluatePath ( _
    evaluator As GH_ExpressionParser, _
    ByRef path As GH_Path, _
    ByRef index As Integer _
) As Boolean

Parameters

evaluator
Type: Grasshopper.Kernel.Expressions..::..GH_ExpressionParser
Evaluator to use. Must have all variables properly set up.
path
Type: Grasshopper.Kernel.Data..::..GH_Path %
Path result.
index
Type: System..::..Int32 %
Index result. If the lexer contains no item representation then the index remains unmolested.

Return Value

True on success, false on failure.

See Also

GH_Lexer Class
Grasshopper.Kernel.Data Namespace


PerformLexicalReplace Method

[image] [image]

Grasshopper SDK
GH_Lexer..::..PerformLexicalReplace Method
GH_Lexer Class See Also Send Feedback

Overload List

Name | Description
PerformLexicalReplace<(Of <<'(T>)>>)(GH_Lexer, GH_Lexer, DataTree<(Of <<'(T>)>>), DataTree<(Of <<'(T>)>>)) | Lexical Find..Replace operations.
PerformLexicalReplace<(Of <<'(T>)>>)(GH_Lexer, GH_Lexer, IGH_Structure, GH_Structure<(Of <<'(T>)>>)) | Lexical Find..Replace operations.

See Also

GH_Lexer Class
GH_Lexer Members
Grasshopper.Kernel.Data Namespace


PerformLexicalReplace(T) Method (GH_Lexer, GH_Lexer, DataTree(T), DataTree(T))

[image]

Grasshopper SDK
GH_Lexer..::..PerformLexicalReplace<(Of <(<'T>)>)> Method (GH_Lexer, GH_Lexer, DataTree<(Of <(<'T>)>)>, DataTree<(Of <(<'T>)>)>)
GH_Lexer Class See Also Send Feedback
Lexical Find..Replace operations.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void PerformLexicalReplace<T>(
    GH_Lexer source,
    GH_Lexer target,
    DataTree<T> tree_in,
    DataTree<T> tree_out
)
Visual Basic
Public Shared Sub PerformLexicalReplace(Of T) ( _
    source As GH_Lexer, _
    target As GH_Lexer, _
    tree_in As DataTree(Of T), _
    tree_out As DataTree(Of T) _
)

Parameters

source
Type: Grasshopper.Kernel.Data..::..GH_Lexer
Search mask.
target
Type: Grasshopper.Kernel.Data..::..GH_Lexer
Replace pattern.
tree_in
Type: Grasshopper..::..DataTree <(Of <(<'T>)>)>
Source data tree.
tree_out
Type: Grasshopper..::..DataTree <(Of <(<'T>)>)>
Target data tree.

Type Parameters

T
Type of data in target tree.

See Also

GH_Lexer Class
PerformLexicalReplace Overload
Grasshopper.Kernel.Data Namespace


PerformLexicalReplace(T) Method (GH_Lexer, GH_Lexer, IGH_Structure, GH_Structure(T))

[image]

Grasshopper SDK
GH_Lexer..::..PerformLexicalReplace<(Of <(<'T>)>)> Method (GH_Lexer, GH_Lexer, IGH_Structure, GH_Structure<(Of <(<'T>)>)>)
GH_Lexer Class See Also Send Feedback
Lexical Find..Replace operations.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void PerformLexicalReplace<T>(
    GH_Lexer source,
    GH_Lexer target,
    IGH_Structure structure_in,
    GH_Structure<T> structure_out
)
where T : IGH_Goo
Visual Basic
Public Shared Sub PerformLexicalReplace(Of T As IGH_Goo) ( _
    source As GH_Lexer, _
    target As GH_Lexer, _
    structure_in As IGH_Structure, _
    structure_out As GH_Structure(Of T) _
)

Parameters

source
Type: Grasshopper.Kernel.Data..::..GH_Lexer
Search mask.
target
Type: Grasshopper.Kernel.Data..::..GH_Lexer
Replace pattern.
structure_in
Type: Grasshopper.Kernel.Data..::..IGH_Structure
Source data tree.
structure_out
Type: Grasshopper.Kernel.Data..::..GH_Structure <(Of <(<'T>)>)>
Target data tree.

Type Parameters

T
Type of data in target tree.

See Also

GH_Lexer Class
PerformLexicalReplace Overload
Grasshopper.Kernel.Data Namespace


GH_Lexer Properties

[image] [image]

Grasshopper SDK
GH_Lexer Properties
GH_Lexer Class See Also Send Feedback

The GH_Lexer type exposes the following members.

Properties

 | Name | Description
Public property | IsItem | Gets a value indicating whether or not the item portion of the lexer has been set.
Public property | IsPath | Gets a value indicating whether or not the path portion of the lexer has been set.
Public property | Item | Gets the item string that was extracted from the mask. The default is "append"
Public property | Mask | Gets the original string that represents the user input for this lexer.
Public property | Path | Gets the list of path strings that was extracted from the mask. If the mask hasn't been parsed yet, it will be parsed now. If the returned list is still nothing, parsing failed.

See Also

GH_Lexer Class
Grasshopper.Kernel.Data Namespace


IsItem Property

[image]

Grasshopper SDK
GH_Lexer..::..IsItem Property
GH_Lexer Class See Also Send Feedback
Gets a value indicating whether or not the item portion of the lexer has been set.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsItem { get; }
Visual Basic
Public ReadOnly Property IsItem As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_Lexer.IsItem"]

See Also

GH_Lexer Class
Grasshopper.Kernel.Data Namespace


IsPath Property

[image]

Grasshopper SDK
GH_Lexer..::..IsPath Property
GH_Lexer Class See Also Send Feedback
Gets a value indicating whether or not the path portion of the lexer has been set.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsPath { get; }
Visual Basic
Public ReadOnly Property IsPath As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_Lexer.IsPath"]

See Also

GH_Lexer Class
Grasshopper.Kernel.Data Namespace


Item Property

[image]

Grasshopper SDK
GH_Lexer..::..Item Property
GH_Lexer Class See Also Send Feedback
Gets the item string that was extracted from the mask. The default is "append"

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Item { get; }
Visual Basic
Public ReadOnly Property Item As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_Lexer.Item"]

See Also

GH_Lexer Class
Grasshopper.Kernel.Data Namespace


Mask Property

[image]

Grasshopper SDK
GH_Lexer..::..Mask Property
GH_Lexer Class See Also Send Feedback
Gets the original string that represents the user input for this lexer.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Mask { get; }
Visual Basic
Public ReadOnly Property Mask As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_Lexer.Mask"]

See Also

GH_Lexer Class
Grasshopper.Kernel.Data Namespace


Path Property

[image]

Grasshopper SDK
GH_Lexer..::..Path Property
GH_Lexer Class See Also Send Feedback
Gets the list of path strings that was extracted from the mask. If the mask hasn't been parsed yet, it will be parsed now. If the returned list is still nothing, parsing failed.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<string> Path { get; }
Visual Basic
Public ReadOnly Property Path As List(Of String)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_Lexer.Path"]

See Also

GH_Lexer Class
Grasshopper.Kernel.Data Namespace


GH_LexerCombo Class

[image]

Grasshopper SDK
GH_LexerCombo Class
Members See Also Send Feedback
Contains both a source and a target lexer object.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_LexerCombo
Visual Basic
Public Class GH_LexerCombo

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Data..::..GH_LexerCombo

See Also

GH_LexerCombo Members
Grasshopper.Kernel.Data Namespace


GH_LexerCombo Members

[image] [image]

Grasshopper SDK
GH_LexerCombo Members
GH_LexerCombo Class Constructors Properties See Also Send Feedback

The GH_LexerCombo type exposes the following members.

Constructors

 | Name | Description
Public method | GH_LexerCombo()()()() | Initializes a new instance of the GH_LexerCombo class
Public method | GH_LexerCombo(String, String) | Initializes a new instance of the GH_LexerCombo class
Public method | GH_LexerCombo(GH_Lexer, GH_Lexer) | Initializes a new instance of the GH_LexerCombo class

Properties

 | Name | Description
Public property | Source | Gets or sets the lexer object that represents the source of a lexical operation.
Public property | Target | Gets or sets the lexer object that represents the target of a lexical operation.

See Also

GH_LexerCombo Class
Grasshopper.Kernel.Data Namespace


GH_LexerCombo Constructor

[image] [image]

Grasshopper SDK
GH_LexerCombo Constructor
GH_LexerCombo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_LexerCombo()()()() | Initializes a new instance of the GH_LexerCombo class
Public method | GH_LexerCombo(String, String) | Initializes a new instance of the GH_LexerCombo class
Public method | GH_LexerCombo(GH_Lexer, GH_Lexer) | Initializes a new instance of the GH_LexerCombo class

See Also

GH_LexerCombo Class
GH_LexerCombo Members
Grasshopper.Kernel.Data Namespace


GH_LexerCombo Constructor

[image]

Grasshopper SDK
GH_LexerCombo Constructor
GH_LexerCombo Class See Also Send Feedback
Initializes a new instance of the GH_LexerCombo class

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_LexerCombo()
Visual Basic
Public Sub New

See Also

GH_LexerCombo Class
GH_LexerCombo Overload
Grasshopper.Kernel.Data Namespace


GH_LexerCombo Constructor (String, String)

[image]

Grasshopper SDK
GH_LexerCombo Constructor (String, String)
GH_LexerCombo Class See Also Send Feedback
Initializes a new instance of the GH_LexerCombo class

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_LexerCombo(
    string n_source,
    string n_target
)
Visual Basic
Public Sub New ( _
    n_source As String, _
    n_target As String _
)

Parameters

n_source
Type: System..::..String
n_target
Type: System..::..String

See Also

GH_LexerCombo Class
GH_LexerCombo Overload
Grasshopper.Kernel.Data Namespace


GH_LexerCombo Constructor (GH_Lexer, GH_Lexer)

[image]

Grasshopper SDK
GH_LexerCombo Constructor (GH_Lexer, GH_Lexer)
GH_LexerCombo Class See Also Send Feedback
Initializes a new instance of the GH_LexerCombo class

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_LexerCombo(
    GH_Lexer n_source,
    GH_Lexer n_target
)
Visual Basic
Public Sub New ( _
    n_source As GH_Lexer, _
    n_target As GH_Lexer _
)

Parameters

n_source
Type: Grasshopper.Kernel.Data..::..GH_Lexer
n_target
Type: Grasshopper.Kernel.Data..::..GH_Lexer

See Also

GH_LexerCombo Class
GH_LexerCombo Overload
Grasshopper.Kernel.Data Namespace


GH_LexerCombo Properties

[image] [image]

Grasshopper SDK
GH_LexerCombo Properties
GH_LexerCombo Class See Also Send Feedback

The GH_LexerCombo type exposes the following members.

Properties

 | Name | Description
Public property | Source | Gets or sets the lexer object that represents the source of a lexical operation.
Public property | Target | Gets or sets the lexer object that represents the target of a lexical operation.

See Also

GH_LexerCombo Class
Grasshopper.Kernel.Data Namespace


Source Property

[image]

Grasshopper SDK
GH_LexerCombo..::..Source Property
GH_LexerCombo Class See Also Send Feedback
Gets or sets the lexer object that represents the source of a lexical operation.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Lexer Source { get; set; }
Visual Basic
Public Property Source As GH_Lexer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_LexerCombo.Source"]

See Also

GH_LexerCombo Class
Grasshopper.Kernel.Data Namespace


Target Property

[image]

Grasshopper SDK
GH_LexerCombo..::..Target Property
GH_LexerCombo Class See Also Send Feedback
Gets or sets the lexer object that represents the target of a lexical operation.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Lexer Target { get; set; }
Visual Basic
Public Property Target As GH_Lexer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_LexerCombo.Target"]

See Also

GH_LexerCombo Class
Grasshopper.Kernel.Data Namespace


GH_Path Class

[image]

Grasshopper SDK
GH_Path Class
Members See Also Send Feedback
Describes the path in structure space of a data item or a list of items. A path consists of a series of integers, each one of which represents an index in a branch structure.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Path : IComparable<GH_Path>,
    IComparer<GH_Path>, GH_ISerializable
Visual Basic
Public Class GH_Path _
    Implements IComparable(Of GH_Path), IComparer(Of GH_Path),  _
    GH_ISerializable

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Data..::..GH_Path

See Also

GH_Path Members
Grasshopper.Kernel.Data Namespace


GH_Path Members

[image] [image]

Grasshopper SDK
GH_Path Members
GH_Path Class Constructors Methods Operators Properties See Also Send Feedback

The GH_Path type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Path()()()() | Default constructor, creates a path with zero elements.
Public method | GH_Path(Int32) | Creates a new path with a single element.
Public method | GH_Path(array<Int32>[]()[][]) | Creates a new path from a series of elements.
Public method | GH_Path(GH_Path) | Creates an exact copy of another path.

Methods

 | Name | Description
Public method | AppendElement | Create a new path by appending a new index value to this path.
Public method | Compare | Compare two paths. This function determines the Sorting behaviour of paths.
Public method | CompareTo | Compare this path to another path. This function determines the Sorting behaviour of paths.
Public method | CullElement | Removes the last index value from the path. If the path is already empty, nothing will happen.
Public method | CullFirstElement | Removes the first index value from the path. If the path is already empty, nothing will happen.
Public method | Format | Format a path.
Public method | FromString | Try to deserialize a GH_Path from a String.
Public method | GetHashCode | Specialized Hash code pattern. (Overrides Object..::..GetHashCode()()()().)
Public method | Increment(Int32) | Increment a specific index in this path by one.
Public method | Increment(Int32, Int32) | Increment a specific index in this path by one.
Public method | IsAncestor | Test another path to see if it is an ancestor of this path. For a path to be considered an ancestor, it must share the initial dimensions.
Public method | IsCoincident(array<Int32>[]()[][]) | Test to see if this path is coincident with set of integers.
Public method | IsCoincident(GH_Path) | Test to see if this path is coincident with another path.
Public method | PrependElement | Create a new path by prepending a new index value to this path.
Public method | Read | Read this path from an archive.
 | SplitPathLikeString | Try to split up a path-like formatted string "{A;B;C}(i)" into component parts.
Public method | ToString()()()() | Concatenates the indices in the path. (Overrides Object..::..ToString()()()().)
Public method | ToString(Boolean) | Concatenates the indices in the path.
Public method | Write | Write this path to an archive.

Operators

Name | Description
Equality |
GreaterThan |
Inequality |
LessThan |

Properties

 | Name | Description
Public property | Dimension | Gets or sets the value of the path at the given dimension index.
Public property | Indices | Gets or sets the entire index space; the path that identifies an element in structure space. You should not change the index space when the path is used inside a structure since it will invalidate the sort order. If you don't know what you're doing, for Pete's sake don't touch this.
Public property | InternalPath | Obsolete. Gets or sets the entire index space; the path that identifies an element in structure space. You should not change the index space when the path is used inside a structure since it will invalidate the sort order. If you don't know what you're doing, for Pete's sake don't touch this.
Public property | Length | Returns the number of dimensions in the path.
Public property | Valid | Gets whether this path is valid. Invalid paths either have no elements or negative elements.

See Also

GH_Path Class
Grasshopper.Kernel.Data Namespace


GH_Path Constructor

[image] [image]

Grasshopper SDK
GH_Path Constructor
GH_Path Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Path()()()() | Default constructor, creates a path with zero elements.
Public method | GH_Path(Int32) | Creates a new path with a single element.
Public method | GH_Path(array<Int32>[]()[][]) | Creates a new path from a series of elements.
Public method | GH_Path(GH_Path) | Creates an exact copy of another path.

See Also

GH_Path Class
GH_Path Members
Grasshopper.Kernel.Data Namespace


GH_Path Constructor

[image]

Grasshopper SDK
GH_Path Constructor
GH_Path Class See Also Send Feedback
Default constructor, creates a path with zero elements.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Path()
Visual Basic
Public Sub New

See Also

GH_Path Class
GH_Path Overload
Grasshopper.Kernel.Data Namespace


GH_Path Constructor (Int32)

[image]

Grasshopper SDK
GH_Path Constructor (Int32)
GH_Path Class See Also Send Feedback
Creates a new path with a single element.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Path(
    int index
)
Visual Basic
Public Sub New ( _
    index As Integer _
)

Parameters

index
Type: System..::..Int32
The index of the first element.

See Also

GH_Path Class
GH_Path Overload
Grasshopper.Kernel.Data Namespace


GH_Path Constructor (Int32[])

[image]

Grasshopper SDK
GH_Path Constructor (array<Int32>[]()[][])
GH_Path Class See Also Send Feedback
Creates a new path from a series of elements.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Path(
    params int[] args
)
Visual Basic
Public Sub New ( _
    ParamArray args As Integer() _
)

Parameters

args
Type: array< System..::..Int32 >[]()[][]
The index values of this path, if null, an empty path is created.

See Also

GH_Path Class
GH_Path Overload
Grasshopper.Kernel.Data Namespace


GH_Path Constructor (GH_Path)

[image]

Grasshopper SDK
GH_Path Constructor (GH_Path)
GH_Path Class See Also Send Feedback
Creates an exact copy of another path.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Path(
    GH_Path Other
)
Visual Basic
Public Sub New ( _
    Other As GH_Path _
)

Parameters

Other
Type: Grasshopper.Kernel.Data..::..GH_Path
Path to copy, cannot be null.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown if Other is a null reference

See Also

GH_Path Class
GH_Path Overload
Grasshopper.Kernel.Data Namespace


GH_Path Methods

[image] [image]

Grasshopper SDK
GH_Path Methods
GH_Path Class See Also Send Feedback

The GH_Path type exposes the following members.

Methods

 | Name | Description
Public method | AppendElement | Create a new path by appending a new index value to this path.
Public method | Compare | Compare two paths. This function determines the Sorting behaviour of paths.
Public method | CompareTo | Compare this path to another path. This function determines the Sorting behaviour of paths.
Public method | CullElement | Removes the last index value from the path. If the path is already empty, nothing will happen.
Public method | CullFirstElement | Removes the first index value from the path. If the path is already empty, nothing will happen.
Public method | Format | Format a path.
Public method | FromString | Try to deserialize a GH_Path from a String.
Public method | GetHashCode | Specialized Hash code pattern. (Overrides Object..::..GetHashCode()()()().)
Public method | Increment(Int32) | Increment a specific index in this path by one.
Public method | Increment(Int32, Int32) | Increment a specific index in this path by one.
Public method | IsAncestor | Test another path to see if it is an ancestor of this path. For a path to be considered an ancestor, it must share the initial dimensions.
Public method | IsCoincident(array<Int32>[]()[][]) | Test to see if this path is coincident with set of integers.
Public method | IsCoincident(GH_Path) | Test to see if this path is coincident with another path.
Public method | PrependElement | Create a new path by prepending a new index value to this path.
Public method | Read | Read this path from an archive.
 | SplitPathLikeString | Try to split up a path-like formatted string "{A;B;C}(i)" into component parts.
Public method | ToString()()()() | Concatenates the indices in the path. (Overrides Object..::..ToString()()()().)
Public method | ToString(Boolean) | Concatenates the indices in the path.
Public method | Write | Write this path to an archive.

See Also

GH_Path Class
Grasshopper.Kernel.Data Namespace


AppendElement Method

[image]

Grasshopper SDK
GH_Path..::..AppendElement Method
GH_Path Class See Also Send Feedback
Create a new path by appending a new index value to this path.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Path AppendElement(
    int index
)
Visual Basic
Public Function AppendElement ( _
    index As Integer _
) As GH_Path

Parameters

index
Type: System..::..Int32
Index value to append.

See Also

GH_Path Class
Grasshopper.Kernel.Data Namespace


Compare Method

[image]

Grasshopper SDK
GH_Path..::..Compare Method
GH_Path Class See Also Send Feedback
Compare two paths. This function determines the Sorting behaviour of paths.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int Compare(
    GH_Path x,
    GH_Path y
)
Visual Basic
Public Function Compare ( _
    x As GH_Path, _
    y As GH_Path _
) As Integer

Parameters

x
Type: Grasshopper.Kernel.Data..::..GH_Path
y
Type: Grasshopper.Kernel.Data..::..GH_Path

Implements

IComparer<(Of <(<'T>)>)>..::..Compare(T, T)

See Also

GH_Path Class
Grasshopper.Kernel.Data Namespace


CompareTo Method

[image]

Grasshopper SDK
GH_Path..::..CompareTo Method
GH_Path Class See Also Send Feedback
Compare this path to another path. This function determines the Sorting behaviour of paths.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int CompareTo(
    GH_Path other
)
Visual Basic
Public Function CompareTo ( _
    other As GH_Path _
) As Integer

Parameters

other
Type: Grasshopper.Kernel.Data..::..GH_Path

Implements

IComparable<(Of <(<'T>)>)>..::..CompareTo(T)

See Also

GH_Path Class
Grasshopper.Kernel.Data Namespace


CullElement Method

[image]

Grasshopper SDK
GH_Path..::..CullElement Method
GH_Path Class See Also Send Feedback
Removes the last index value from the path. If the path is already empty, nothing will happen.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Path CullElement()
Visual Basic
Public Function CullElement As GH_Path

See Also

GH_Path Class
Grasshopper.Kernel.Data Namespace


CullFirstElement Method

[image]

Grasshopper SDK
GH_Path..::..CullFirstElement Method
GH_Path Class See Also Send Feedback
Removes the first index value from the path. If the path is already empty, nothing will happen.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Path CullFirstElement()
Visual Basic
Public Function CullFirstElement As GH_Path

See Also

GH_Path Class
Grasshopper.Kernel.Data Namespace


Format Method

[image]

Grasshopper SDK
GH_Path..::..Format Method
GH_Path Class See Also Send Feedback
Format a path.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Format(
    string format_provider,
    string separator
)
Visual Basic
Public Function Format ( _
    format_provider As String, _
    separator As String _
) As String

Parameters

format_provider
Type: System..::..String
The string describing the format. You are allowed to use {0} as a format placeholder. The placeholder will be filled up with a semi-colon separated list: 0;0;2;4
separator
Type: System..::..String
Character to use for element separators. The default separator is a semi-colon.

Return Value

Formatted string.

See Also

GH_Path Class
Grasshopper.Kernel.Data Namespace


FromString Method

[image]

Grasshopper SDK
GH_Path..::..FromString Method
GH_Path Class See Also Send Feedback
Try to deserialize a GH_Path from a String.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool FromString(
    string s
)
Visual Basic
Public Function FromString ( _
    s As String _
) As Boolean

Parameters

s
Type: System..::..String

See Also

GH_Path Class
Grasshopper.Kernel.Data Namespace


GetHashCode Method

[image]

Grasshopper SDK
GH_Path..::..GetHashCode Method
GH_Path Class See Also Send Feedback
Specialized Hash code pattern.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

See Also

GH_Path Class
Grasshopper.Kernel.Data Namespace


Increment Method

[image] [image]

Grasshopper SDK
GH_Path..::..Increment Method
GH_Path Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Increment(Int32) | Increment a specific index in this path by one.
Public method | Increment(Int32, Int32) | Increment a specific index in this path by one.

See Also

GH_Path Class
GH_Path Members
Grasshopper.Kernel.Data Namespace


Increment Method (Int32)

[image]

Grasshopper SDK
GH_Path..::..Increment Method (Int32)
GH_Path Class See Also Send Feedback
Increment a specific index in this path by one.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Path Increment(
    int index
)
Visual Basic
Public Function Increment ( _
    index As Integer _
) As GH_Path

Parameters

index
Type: System..::..Int32
Index to increment. Valid indices are (-Length+1) to (Length-1).

Return Value

A new path with incremented index.

See Also

GH_Path Class
Increment Overload
Grasshopper.Kernel.Data Namespace


Increment Method (Int32, Int32)

[image]

Grasshopper SDK
GH_Path..::..Increment Method (Int32, Int32)
GH_Path Class See Also Send Feedback
Increment a specific index in this path by one.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Path Increment(
    int index,
    int offset
)
Visual Basic
Public Function Increment ( _
    index As Integer, _
    offset As Integer _
) As GH_Path

Parameters

index
Type: System..::..Int32
Index to increment. Valis indices are (-Length+1) to (Length-1).
offset
Type: System..::..Int32
Amount to increment.

Return Value

A new path with incremented index.

See Also

GH_Path Class
Increment Overload
Grasshopper.Kernel.Data Namespace


IsAncestor Method

[image]

Grasshopper SDK
GH_Path..::..IsAncestor Method
GH_Path Class See Also Send Feedback
Test another path to see if it is an ancestor of this path. For a path to be considered an ancestor, it must share the initial dimensions.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsAncestor(
    GH_Path potential_ancestor,
    ref int additional_generations
)
Visual Basic
Public Function IsAncestor ( _
    potential_ancestor As GH_Path, _
    ByRef additional_generations As Integer _
) As Boolean

Parameters

potential_ancestor
Type: Grasshopper.Kernel.Data..::..GH_Path
Parental path to test.
additional_generations
Type: System..::..Int32 %
This value will hold the number of generations between parent and child path.

Return Value

True if other overlaps completely with this path while being at least one element shorter.

See Also

GH_Path Class
Grasshopper.Kernel.Data Namespace


IsCoincident Method

[image] [image]

Grasshopper SDK
GH_Path..::..IsCoincident Method
GH_Path Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsCoincident(array<Int32>[]()[][]) | Test to see if this path is coincident with set of integers.
Public method | IsCoincident(GH_Path) | Test to see if this path is coincident with another path.

See Also

GH_Path Class
GH_Path Members
Grasshopper.Kernel.Data Namespace


IsCoincident Method (Int32[])

[image]

Grasshopper SDK
GH_Path..::..IsCoincident Method (array<Int32>[]()[][])
GH_Path Class See Also Send Feedback
Test to see if this path is coincident with set of integers.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsCoincident(
    params int[] index_list
)
Visual Basic
Public Function IsCoincident ( _
    ParamArray index_list As Integer() _
) As Boolean

Parameters

index_list
Type: array< System..::..Int32 >[]()[][]
Integers to compare to.

Return Value

True if both paths are coincident (identical), false if not.

See Also

GH_Path Class
IsCoincident Overload
Grasshopper.Kernel.Data Namespace


IsCoincident Method (GH_Path)

[image]

Grasshopper SDK
GH_Path..::..IsCoincident Method (GH_Path)
GH_Path Class See Also Send Feedback
Test to see if this path is coincident with another path.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsCoincident(
    GH_Path other
)
Visual Basic
Public Function IsCoincident ( _
    other As GH_Path _
) As Boolean

Parameters

other
Type: Grasshopper.Kernel.Data..::..GH_Path
Path to compare to.

Return Value

True if both paths are coincident (identical), false if not.

See Also

GH_Path Class
IsCoincident Overload
Grasshopper.Kernel.Data Namespace


PrependElement Method

[image]

Grasshopper SDK
GH_Path..::..PrependElement Method
GH_Path Class See Also Send Feedback
Create a new path by prepending a new index value to this path.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Path PrependElement(
    int index
)
Visual Basic
Public Function PrependElement ( _
    index As Integer _
) As GH_Path

Parameters

index
Type: System..::..Int32
Index value to prepend.

See Also

GH_Path Class
Grasshopper.Kernel.Data Namespace


Read Method

[image]

Grasshopper SDK
GH_Path..::..Read Method
GH_Path Class See Also Send Feedback
Read this path from an archive.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Read(
    GH_IReader reader
)
Visual Basic
Public Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader
Object to read with.

Return Value

True on success, false on failure.

Implements

GH_ISerializable..::..Read(GH_IReader)

See Also

GH_Path Class
Grasshopper.Kernel.Data Namespace


SplitPathLikeString Method

[image]

Grasshopper SDK
GH_Path..::..SplitPathLikeString Method
GH_Path Class See Also Send Feedback
Try to split up a path-like formatted string "{A;B;C}(i)" into component parts.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool SplitPathLikeString(
    string s,
    out string[] path_segments,
    out string index_segment
)
Visual Basic
Public Shared Function SplitPathLikeString ( _
    s As String, _
    <OutAttribute> ByRef path_segments As String(), _
    <OutAttribute> ByRef index_segment As String _
) As Boolean

Parameters

s
Type: System..::..String
String to parse.
path_segments
Type: array< System..::..String >[]()[][]%
Output - Strings inside the path portion of s.
index_segment
Type: System..::..String %
Output - String inside the index portion of s.

Return Value

True on success, false on failure.

See Also

GH_Path Class
Grasshopper.Kernel.Data Namespace


ToString Method

[image] [image]

Grasshopper SDK
GH_Path..::..ToString Method
GH_Path Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Concatenates the indices in the path. (Overrides Object..::..ToString()()()().)
Public method | ToString(Boolean) | Concatenates the indices in the path.

See Also

GH_Path Class
GH_Path Members
Grasshopper.Kernel.Data Namespace


ToString Method

[image]

Grasshopper SDK
GH_Path..::..ToString Method
GH_Path Class See Also Send Feedback
Concatenates the indices in the path.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_Path Class
ToString Overload
Grasshopper.Kernel.Data Namespace


ToString Method (Boolean)

[image]

Grasshopper SDK
GH_Path..::..ToString Method (Boolean)
GH_Path Class See Also Send Feedback
Concatenates the indices in the path.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string ToString(
    bool includeBrackets
)
Visual Basic
Public Function ToString ( _
    includeBrackets As Boolean _
) As String

Parameters

includeBrackets
Type: System..::..Boolean
If True, brackets will be prepended and appended to the path string.

See Also

GH_Path Class
ToString Overload
Grasshopper.Kernel.Data Namespace


Write Method

[image]

Grasshopper SDK
GH_Path..::..Write Method
GH_Path Class See Also Send Feedback
Write this path to an archive.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Write(
    GH_IWriter writer
)
Visual Basic
Public Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter
Object to write with.

Return Value

True on success, false on failure.

Implements

GH_ISerializable..::..Write(GH_IWriter)

See Also

GH_Path Class
Grasshopper.Kernel.Data Namespace


GH_Path Operators

[image] [image]

Grasshopper SDK
GH_Path Operators
GH_Path Class See Also Send Feedback

The GH_Path type exposes the following members.

Operators

Name | Description
Equality |
GreaterThan |
Inequality |
LessThan |

See Also

GH_Path Class
Grasshopper.Kernel.Data Namespace


Equality Operator

[image]

Grasshopper SDK
GH_Path..::..Equality Operator
GH_Path Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool operator ==(
    GH_Path A,
    GH_Path B
)
Visual Basic
Public Shared Operator = ( _
    A As GH_Path, _
    B As GH_Path _
) As Boolean

Parameters

A
Type: Grasshopper.Kernel.Data..::..GH_Path
B
Type: Grasshopper.Kernel.Data..::..GH_Path

See Also

GH_Path Class
Grasshopper.Kernel.Data Namespace


GreaterThan Operator

[image]

Grasshopper SDK
GH_Path..::..GreaterThan Operator
GH_Path Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool operator >(
    GH_Path A,
    GH_Path B
)
Visual Basic
Public Shared Operator > ( _
    A As GH_Path, _
    B As GH_Path _
) As Boolean

Parameters

A
Type: Grasshopper.Kernel.Data..::..GH_Path
B
Type: Grasshopper.Kernel.Data..::..GH_Path

See Also

GH_Path Class
Grasshopper.Kernel.Data Namespace


Inequality Operator

[image]

Grasshopper SDK
GH_Path..::..Inequality Operator
GH_Path Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool operator !=(
    GH_Path A,
    GH_Path B
)
Visual Basic
Public Shared Operator <> ( _
    A As GH_Path, _
    B As GH_Path _
) As Boolean

Parameters

A
Type: Grasshopper.Kernel.Data..::..GH_Path
B
Type: Grasshopper.Kernel.Data..::..GH_Path

See Also

GH_Path Class
Grasshopper.Kernel.Data Namespace


LessThan Operator

[image]

Grasshopper SDK
GH_Path..::..LessThan Operator
GH_Path Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool operator <(
    GH_Path A,
    GH_Path B
)
Visual Basic
Public Shared Operator < ( _
    A As GH_Path, _
    B As GH_Path _
) As Boolean

Parameters

A
Type: Grasshopper.Kernel.Data..::..GH_Path
B
Type: Grasshopper.Kernel.Data..::..GH_Path

See Also

GH_Path Class
Grasshopper.Kernel.Data Namespace


GH_Path Properties

[image] [image]

Grasshopper SDK
GH_Path Properties
GH_Path Class See Also Send Feedback

The GH_Path type exposes the following members.

Properties

 | Name | Description
Public property | Dimension | Gets or sets the value of the path at the given dimension index.
Public property | Indices | Gets or sets the entire index space; the path that identifies an element in structure space. You should not change the index space when the path is used inside a structure since it will invalidate the sort order. If you don't know what you're doing, for Pete's sake don't touch this.
Public property | InternalPath | Obsolete. Gets or sets the entire index space; the path that identifies an element in structure space. You should not change the index space when the path is used inside a structure since it will invalidate the sort order. If you don't know what you're doing, for Pete's sake don't touch this.
Public property | Length | Returns the number of dimensions in the path.
Public property | Valid | Gets whether this path is valid. Invalid paths either have no elements or negative elements.

See Also

GH_Path Class
Grasshopper.Kernel.Data Namespace


Dimension Property

[image]

Grasshopper SDK
GH_Path..::..Dimension Property
GH_Path Class See Also Send Feedback
Gets or sets the value of the path at the given dimension index.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int this[
    int index
] { get; set; }
Visual Basic
Public Default Property Dimension ( _
    index As Integer _
) As Integer
    Get
    Set

Parameters

index
Type: System..::..Int32
Index of dimension.

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_Path.Dimension(System.Int32)"]

See Also

GH_Path Class
Grasshopper.Kernel.Data Namespace


Indices Property

[image]

Grasshopper SDK
GH_Path..::..Indices Property
GH_Path Class See Also Send Feedback
Gets or sets the entire index space; the path that identifies an element in structure space. You should not change the index space when the path is used inside a structure since it will invalidate the sort order. If you don't know what you're doing, for Pete's sake don't touch this.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int[] Indices { get; set; }
Visual Basic
Public Property Indices As Integer()
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_Path.Indices"]

See Also

GH_Path Class
Grasshopper.Kernel.Data Namespace


InternalPath Property

[image]

Grasshopper SDK
GH_Path..::..InternalPath Property
GH_Path Class See Also Send Feedback
Gets or sets the entire index space; the path that identifies an element in structure space. You should not change the index space when the path is used inside a structure since it will invalidate the sort order. If you don't know what you're doing, for Pete's sake don't touch this.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
[ObsoleteAttribute("This property has been replaced by the Indices property")]
public int[] InternalPath { get; set; }
Visual Basic
<ObsoleteAttribute("This property has been replaced by the Indices property")> _
Public Property InternalPath As Integer()
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_Path.InternalPath"]

See Also

GH_Path Class
Grasshopper.Kernel.Data Namespace


Length Property

[image]

Grasshopper SDK
GH_Path..::..Length Property
GH_Path Class See Also Send Feedback
Returns the number of dimensions in the path.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int Length { get; }
Visual Basic
Public ReadOnly Property Length As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_Path.Length"]

See Also

GH_Path Class
Grasshopper.Kernel.Data Namespace


Valid Property

[image]

Grasshopper SDK
GH_Path..::..Valid Property
GH_Path Class See Also Send Feedback
Gets whether this path is valid. Invalid paths either have no elements or negative elements.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Valid { get; }
Visual Basic
Public ReadOnly Property Valid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_Path.Valid"]

See Also

GH_Path Class
Grasshopper.Kernel.Data Namespace


GH_Path.PathLengthComparer Class

[image]

Grasshopper SDK
GH_Path..::..PathLengthComparer Class
GH_Path Class Members See Also Send Feedback
Use this comparer to sort lists of paths using a topological approach. Shorter paths are favoured over longer paths. Equal length paths use the default comparer.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class PathLengthComparer : IComparer<GH_Path>
Visual Basic
Public Class PathLengthComparer _
    Implements IComparer(Of GH_Path)

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Data..::..GH_Path..::..PathLengthComparer

See Also

GH_Path..::..PathLengthComparer Members
Grasshopper.Kernel.Data Namespace


GH_Path.PathLengthComparer Members

[image] [image]

Grasshopper SDK
GH_Path..::..PathLengthComparer Members
GH_Path..::..PathLengthComparer Class Constructors Methods See Also Send Feedback

Describes the path in structure space of a data item or a list of items. A path consists of a series of integers, each one of which represents an index in a branch structure.

The GH_Path..::..PathLengthComparer type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Path..::..PathLengthComparer | Initializes a new instance of the GH_Path..::..PathLengthComparer class

Methods

 | Name | Description
Public method | Compare |

See Also

GH_Path..::..PathLengthComparer Class
Grasshopper.Kernel.Data Namespace


GH_Path.PathLengthComparer Constructor

[image]

Grasshopper SDK
GH_Path..::..PathLengthComparer Constructor
GH_Path..::..PathLengthComparer Class See Also Send Feedback
Initializes a new instance of the GH_Path..::..PathLengthComparer class

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public PathLengthComparer()
Visual Basic
Public Sub New

See Also

GH_Path..::..PathLengthComparer Class
Grasshopper.Kernel.Data Namespace


GH_Path.PathLengthComparer Methods

[image] [image]

Grasshopper SDK
GH_Path..::..PathLengthComparer Methods
GH_Path..::..PathLengthComparer Class See Also Send Feedback

The GH_Path..::..PathLengthComparer type exposes the following members.

Methods

 | Name | Description
Public method | Compare |

See Also

GH_Path..::..PathLengthComparer Class
Grasshopper.Kernel.Data Namespace


Compare Method

[image]

Grasshopper SDK
GH_Path..::..PathLengthComparer..::..Compare Method
GH_Path..::..PathLengthComparer Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int Compare(
    GH_Path x,
    GH_Path y
)
Visual Basic
Public Function Compare ( _
    x As GH_Path, _
    y As GH_Path _
) As Integer

Parameters

x
Type: Grasshopper.Kernel.Data..::..GH_Path
y
Type: Grasshopper.Kernel.Data..::..GH_Path

Implements

IComparer<(Of <(<'T>)>)>..::..Compare(T, T)

See Also

GH_Path..::..PathLengthComparer Class
Grasshopper.Kernel.Data Namespace


GH_PathOffset Class

[image]

Grasshopper SDK
GH_PathOffset Class
Members See Also Send Feedback
Represents a relative offset within a data structure.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_PathOffset
Visual Basic
Public Class GH_PathOffset

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Data..::..GH_PathOffset

See Also

GH_PathOffset Members
Grasshopper.Kernel.Data Namespace


GH_PathOffset Members

[image] [image]

Grasshopper SDK
GH_PathOffset Members
GH_PathOffset Class Constructors Methods Properties See Also Send Feedback

The GH_PathOffset type exposes the following members.

Constructors

 | Name | Description
Public method | GH_PathOffset()()()() | Initializes a new instance of the GH_PathOffset class
Public method | GH_PathOffset(IEnumerable<(Of <<'(Int32>)>>)) | Initializes a new instance of the GH_PathOffset class
Public method | GH_PathOffset(IEnumerable<(Of <<'(Int32>)>>), Int32) | Initializes a new instance of the GH_PathOffset class
Public method | GH_PathOffset(IEnumerable<(Of <<'(Int32>)>>), Int32, Boolean, Boolean) | Initializes a new instance of the GH_PathOffset class

Methods

 | Name | Description
Public method | OffsetPath(GH_Path, Int32, GH_Path%, Int32%) | Offset a path + index value without wrapping.
Public method | OffsetPath(GH_Path, Int32, IGH_Structure, GH_Path%, Int32%) | Offset a path + index value with wrapping and bounds checking.
 | ParseString |
Public method | ToString | Format the Path Offset. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | ItemOffset | Gets or sets the relative offset for branch items.
Public property | ItemWrap | Gets or sets the ItemWrap flag.
Public property | PathOffset | Gets access to the relative offsets for path indices.
Public property | PathWrap | Gets or sets the PathWrap flag.

See Also

GH_PathOffset Class
Grasshopper.Kernel.Data Namespace


GH_PathOffset Constructor

[image] [image]

Grasshopper SDK
GH_PathOffset Constructor
GH_PathOffset Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_PathOffset()()()() | Initializes a new instance of the GH_PathOffset class
Public method | GH_PathOffset(IEnumerable<(Of <<'(Int32>)>>)) | Initializes a new instance of the GH_PathOffset class
Public method | GH_PathOffset(IEnumerable<(Of <<'(Int32>)>>), Int32) | Initializes a new instance of the GH_PathOffset class
Public method | GH_PathOffset(IEnumerable<(Of <<'(Int32>)>>), Int32, Boolean, Boolean) | Initializes a new instance of the GH_PathOffset class

See Also

GH_PathOffset Class
GH_PathOffset Members
Grasshopper.Kernel.Data Namespace


GH_PathOffset Constructor

[image]

Grasshopper SDK
GH_PathOffset Constructor
GH_PathOffset Class See Also Send Feedback
Initializes a new instance of the GH_PathOffset class

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PathOffset()
Visual Basic
Public Sub New

See Also

GH_PathOffset Class
GH_PathOffset Overload
Grasshopper.Kernel.Data Namespace


GH_PathOffset Constructor (IEnumerable(Int32))

[image]

Grasshopper SDK
GH_PathOffset Constructor (IEnumerable<(Of <(<'Int32>)>)>)
GH_PathOffset Class See Also Send Feedback
Initializes a new instance of the GH_PathOffset class

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PathOffset(
    IEnumerable<int> pathShift
)
Visual Basic
Public Sub New ( _
    pathShift As IEnumerable(Of Integer) _
)

Parameters

pathShift
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Int32 >)>)>

See Also

GH_PathOffset Class
GH_PathOffset Overload
Grasshopper.Kernel.Data Namespace


GH_PathOffset Constructor (IEnumerable(Int32), Int32)

[image]

Grasshopper SDK
GH_PathOffset Constructor (IEnumerable<(Of <(<'Int32>)>)>, Int32)
GH_PathOffset Class See Also Send Feedback
Initializes a new instance of the GH_PathOffset class

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PathOffset(
    IEnumerable<int> pathShift,
    int itemShift
)
Visual Basic
Public Sub New ( _
    pathShift As IEnumerable(Of Integer), _
    itemShift As Integer _
)

Parameters

pathShift
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Int32 >)>)>
itemShift
Type: System..::..Int32

See Also

GH_PathOffset Class
GH_PathOffset Overload
Grasshopper.Kernel.Data Namespace


GH_PathOffset Constructor (IEnumerable(Int32), Int32, Boolean, Boolean)

[image]

Grasshopper SDK
GH_PathOffset Constructor (IEnumerable<(Of <(<'Int32>)>)>, Int32, Boolean, Boolean)
GH_PathOffset Class See Also Send Feedback
Initializes a new instance of the GH_PathOffset class

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PathOffset(
    IEnumerable<int> pathShift,
    int itemShift,
    bool pathWrap,
    bool itemWrap
)
Visual Basic
Public Sub New ( _
    pathShift As IEnumerable(Of Integer), _
    itemShift As Integer, _
    pathWrap As Boolean, _
    itemWrap As Boolean _
)

Parameters

pathShift
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Int32 >)>)>
itemShift
Type: System..::..Int32
pathWrap
Type: System..::..Boolean
itemWrap
Type: System..::..Boolean

See Also

GH_PathOffset Class
GH_PathOffset Overload
Grasshopper.Kernel.Data Namespace


GH_PathOffset Methods

[image] [image]

Grasshopper SDK
GH_PathOffset Methods
GH_PathOffset Class See Also Send Feedback

The GH_PathOffset type exposes the following members.

Methods

 | Name | Description
Public method | OffsetPath(GH_Path, Int32, GH_Path%, Int32%) | Offset a path + index value without wrapping.
Public method | OffsetPath(GH_Path, Int32, IGH_Structure, GH_Path%, Int32%) | Offset a path + index value with wrapping and bounds checking.
 | ParseString |
Public method | ToString | Format the Path Offset. (Overrides Object..::..ToString()()()().)

See Also

GH_PathOffset Class
Grasshopper.Kernel.Data Namespace


OffsetPath Method

[image] [image]

Grasshopper SDK
GH_PathOffset..::..OffsetPath Method
GH_PathOffset Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OffsetPath(GH_Path, Int32, GH_Path%, Int32%) | Offset a path + index value without wrapping.
Public method | OffsetPath(GH_Path, Int32, IGH_Structure, GH_Path%, Int32%) | Offset a path + index value with wrapping and bounds checking.

See Also

GH_PathOffset Class
GH_PathOffset Members
Grasshopper.Kernel.Data Namespace


OffsetPath Method (GH_Path, Int32, GH_Path, Int32)

[image]

Grasshopper SDK
GH_PathOffset..::..OffsetPath Method (GH_Path, Int32, GH_Path%, Int32%)
GH_PathOffset Class See Also Send Feedback
Offset a path + index value without wrapping.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool OffsetPath(
    GH_Path path,
    int index,
    ref GH_Path rel_path,
    ref int rel_index
)
Visual Basic
Public Function OffsetPath ( _
    path As GH_Path, _
    index As Integer, _
    ByRef rel_path As GH_Path, _
    ByRef rel_index As Integer _
) As Boolean

Parameters

path
Type: Grasshopper.Kernel.Data..::..GH_Path
Path to offset.
index
Type: System..::..Int32
Item to offset.
rel_path
Type: Grasshopper.Kernel.Data..::..GH_Path %
Offsetted path.
rel_index
Type: System..::..Int32 %
Offsetted index.

Return Value

True on success, false on failure.

See Also

GH_PathOffset Class
OffsetPath Overload
Grasshopper.Kernel.Data Namespace


OffsetPath Method (GH_Path, Int32, IGH_Structure, GH_Path, Int32)

[image]

Grasshopper SDK
GH_PathOffset..::..OffsetPath Method (GH_Path, Int32, IGH_Structure, GH_Path%, Int32%)
GH_PathOffset Class See Also Send Feedback
Offset a path + index value with wrapping and bounds checking.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool OffsetPath(
    GH_Path path,
    int index,
    IGH_Structure tree,
    out GH_Path relativePath,
    out int relativeIndex
)
Visual Basic
Public Function OffsetPath ( _
    path As GH_Path, _
    index As Integer, _
    tree As IGH_Structure, _
    <OutAttribute> ByRef relativePath As GH_Path, _
    <OutAttribute> ByRef relativeIndex As Integer _
) As Boolean

Parameters

path
Type: Grasshopper.Kernel.Data..::..GH_Path
Path to offset.
index
Type: System..::..Int32
Item to offset.
tree
Type: Grasshopper.Kernel.Data..::..IGH_Structure
Structure context for offset.
relativePath
Type: Grasshopper.Kernel.Data..::..GH_Path %
Offsetted path.
relativeIndex
Type: System..::..Int32 %
Offsetted index.

Return Value

True on success, false on failure.

See Also

GH_PathOffset Class
OffsetPath Overload
Grasshopper.Kernel.Data Namespace


ParseString Method

[image]

Grasshopper SDK
GH_PathOffset..::..ParseString Method
GH_PathOffset Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_PathOffset ParseString(
    string mask
)
Visual Basic
Public Shared Function ParseString ( _
    mask As String _
) As GH_PathOffset

Parameters

mask
Type: System..::..String

See Also

GH_PathOffset Class
Grasshopper.Kernel.Data Namespace


ToString Method

[image]

Grasshopper SDK
GH_PathOffset..::..ToString Method
GH_PathOffset Class See Also Send Feedback
Format the Path Offset.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_PathOffset Class
Grasshopper.Kernel.Data Namespace


GH_PathOffset Properties

[image] [image]

Grasshopper SDK
GH_PathOffset Properties
GH_PathOffset Class See Also Send Feedback

The GH_PathOffset type exposes the following members.

Properties

 | Name | Description
Public property | ItemOffset | Gets or sets the relative offset for branch items.
Public property | ItemWrap | Gets or sets the ItemWrap flag.
Public property | PathOffset | Gets access to the relative offsets for path indices.
Public property | PathWrap | Gets or sets the PathWrap flag.

See Also

GH_PathOffset Class
Grasshopper.Kernel.Data Namespace


ItemOffset Property

[image]

Grasshopper SDK
GH_PathOffset..::..ItemOffset Property
GH_PathOffset Class See Also Send Feedback
Gets or sets the relative offset for branch items.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int ItemOffset { get; set; }
Visual Basic
Public Property ItemOffset As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_PathOffset.ItemOffset"]

See Also

GH_PathOffset Class
Grasshopper.Kernel.Data Namespace


ItemWrap Property

[image]

Grasshopper SDK
GH_PathOffset..::..ItemWrap Property
GH_PathOffset Class See Also Send Feedback
Gets or sets the ItemWrap flag.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool ItemWrap { get; set; }
Visual Basic
Public Property ItemWrap As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_PathOffset.ItemWrap"]

See Also

GH_PathOffset Class
Grasshopper.Kernel.Data Namespace


PathOffset Property

[image]

Grasshopper SDK
GH_PathOffset..::..PathOffset Property
GH_PathOffset Class See Also Send Feedback
Gets access to the relative offsets for path indices.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<int> PathOffset { get; }
Visual Basic
Public ReadOnly Property PathOffset As List(Of Integer)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_PathOffset.PathOffset"]

See Also

GH_PathOffset Class
Grasshopper.Kernel.Data Namespace


PathWrap Property

[image]

Grasshopper SDK
GH_PathOffset..::..PathWrap Property
GH_PathOffset Class See Also Send Feedback
Gets or sets the PathWrap flag.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool PathWrap { get; set; }
Visual Basic
Public Property PathWrap As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_PathOffset.PathWrap"]

See Also

GH_PathOffset Class
Grasshopper.Kernel.Data Namespace


GH_Pattern Class

[image]

Grasshopper SDK
GH_Pattern Class
Members See Also Send Feedback
Represents an entire path match pattern.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class GH_Pattern
Visual Basic
Public NotInheritable Class GH_Pattern

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Data..::..GH_Pattern

See Also

GH_Pattern Members
Grasshopper.Kernel.Data Namespace


GH_Pattern Members

[image] [image]

Grasshopper SDK
GH_Pattern Members
GH_Pattern Class Constructors Methods Operators See Also Send Feedback

The GH_Pattern type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Pattern | Initializes a new instance of the GH_Pattern class

Methods

 | Name | Description
Public method | AppendElement | Append a new pattern element to the pattern. Depending on the new element type and the existing pattern, the element will either be merged with the final segment or a new segment will be created.
Public method | AppendElements | Append each element in a list to this pattern. Element addition logic is applied to each individual item in the list.
Public method | FromString | Attempt to parse a Pattern string.
Public method | Match | Match this pattern against a path.
Public method | ToString | (Overrides Object..::..ToString()()()().)

Operators

Name | Description
Equality(GH_Path, GH_Pattern) |
Equality(GH_Pattern, GH_Path) |
Inequality(GH_Path, GH_Pattern) |
Inequality(GH_Pattern, GH_Path) |

See Also

GH_Pattern Class
Grasshopper.Kernel.Data Namespace


GH_Pattern Constructor

[image]

Grasshopper SDK
GH_Pattern Constructor
GH_Pattern Class See Also Send Feedback
Initializes a new instance of the GH_Pattern class

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Pattern()
Visual Basic
Public Sub New

See Also

GH_Pattern Class
Grasshopper.Kernel.Data Namespace


GH_Pattern Methods

[image] [image]

Grasshopper SDK
GH_Pattern Methods
GH_Pattern Class See Also Send Feedback

The GH_Pattern type exposes the following members.

Methods

 | Name | Description
Public method | AppendElement | Append a new pattern element to the pattern. Depending on the new element type and the existing pattern, the element will either be merged with the final segment or a new segment will be created.
Public method | AppendElements | Append each element in a list to this pattern. Element addition logic is applied to each individual item in the list.
Public method | FromString | Attempt to parse a Pattern string.
Public method | Match | Match this pattern against a path.
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

GH_Pattern Class
Grasshopper.Kernel.Data Namespace


AppendElement Method

[image]

Grasshopper SDK
GH_Pattern..::..AppendElement Method
GH_Pattern Class See Also Send Feedback
Append a new pattern element to the pattern. Depending on the new element type and the existing pattern, the element will either be merged with the final segment or a new segment will be created.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AppendElement(
    GH_PatternElement e
)
Visual Basic
Public Sub AppendElement ( _
    e As GH_PatternElement _
)

Parameters

e
Type: Grasshopper.Kernel.Data..::..GH_PatternElement

See Also

GH_Pattern Class
Grasshopper.Kernel.Data Namespace


AppendElements Method

[image]

Grasshopper SDK
GH_Pattern..::..AppendElements Method
GH_Pattern Class See Also Send Feedback
Append each element in a list to this pattern. Element addition logic is applied to each individual item in the list.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AppendElements(
    IEnumerable<GH_PatternElement> element_list
)
Visual Basic
Public Sub AppendElements ( _
    element_list As IEnumerable(Of GH_PatternElement) _
)

Parameters

element_list
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' GH_PatternElement >)>)>

See Also

GH_Pattern Class
Grasshopper.Kernel.Data Namespace


FromString Method

[image]

Grasshopper SDK
GH_Pattern..::..FromString Method
GH_Pattern Class See Also Send Feedback
Attempt to parse a Pattern string.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool FromString(
    string s_pat,
    ref string msg
)
Visual Basic
Public Function FromString ( _
    s_pat As String, _
    ByRef msg As String _
) As Boolean

Parameters

s_pat
Type: System..::..String
String to parse.
msg
Type: System..::..String %
If this function fails, msg will contain a message describing the error.

Return Value

True on success, false on failure.

See Also

GH_Pattern Class
Grasshopper.Kernel.Data Namespace


Match Method

[image]

Grasshopper SDK
GH_Pattern..::..Match Method
GH_Pattern Class See Also Send Feedback
Match this pattern against a path.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Match(
    GH_Path path
)
Visual Basic
Public Function Match ( _
    path As GH_Path _
) As Boolean

Parameters

path
Type: Grasshopper.Kernel.Data..::..GH_Path
Path to match against.

Return Value

True if the pattern matches the path.

See Also

GH_Pattern Class
Grasshopper.Kernel.Data Namespace


ToString Method

[image]

Grasshopper SDK
GH_Pattern..::..ToString Method
GH_Pattern Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_Pattern Class
Grasshopper.Kernel.Data Namespace


GH_Pattern Operators

[image] [image]

Grasshopper SDK
GH_Pattern Operators
GH_Pattern Class See Also Send Feedback

Operators

Name | Description
Equality(GH_Path, GH_Pattern) |
Equality(GH_Pattern, GH_Path) |
Inequality(GH_Path, GH_Pattern) |
Inequality(GH_Pattern, GH_Path) |

See Also

GH_Pattern Class
Grasshopper.Kernel.Data Namespace


Equality Operator

[image] [image]

Grasshopper SDK
GH_Pattern..::..Equality Operator
GH_Pattern Class See Also Send Feedback

Overload List

Name | Description
Equality(GH_Path, GH_Pattern) |
Equality(GH_Pattern, GH_Path) |

See Also

GH_Pattern Class
GH_Pattern Members
Grasshopper.Kernel.Data Namespace


Equality Operator (GH_Path, GH_Pattern)

[image]

Grasshopper SDK
GH_Pattern..::..Equality Operator (GH_Path, GH_Pattern)
GH_Pattern Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool operator ==(
    GH_Path path,
    GH_Pattern pattern
)
Visual Basic
Public Shared Operator = ( _
    path As GH_Path, _
    pattern As GH_Pattern _
) As Boolean

Parameters

path
Type: Grasshopper.Kernel.Data..::..GH_Path
pattern
Type: Grasshopper.Kernel.Data..::..GH_Pattern

See Also

GH_Pattern Class
Equality Overload
Grasshopper.Kernel.Data Namespace


Equality Operator (GH_Pattern, GH_Path)

[image]

Grasshopper SDK
GH_Pattern..::..Equality Operator (GH_Pattern, GH_Path)
GH_Pattern Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool operator ==(
    GH_Pattern pattern,
    GH_Path path
)
Visual Basic
Public Shared Operator = ( _
    pattern As GH_Pattern, _
    path As GH_Path _
) As Boolean

Parameters

pattern
Type: Grasshopper.Kernel.Data..::..GH_Pattern
path
Type: Grasshopper.Kernel.Data..::..GH_Path

See Also

GH_Pattern Class
Equality Overload
Grasshopper.Kernel.Data Namespace


Inequality Operator

[image] [image]

Grasshopper SDK
GH_Pattern..::..Inequality Operator
GH_Pattern Class See Also Send Feedback

Overload List

Name | Description
Inequality(GH_Path, GH_Pattern) |
Inequality(GH_Pattern, GH_Path) |

See Also

GH_Pattern Class
GH_Pattern Members
Grasshopper.Kernel.Data Namespace


Inequality Operator (GH_Path, GH_Pattern)

[image]

Grasshopper SDK
GH_Pattern..::..Inequality Operator (GH_Path, GH_Pattern)
GH_Pattern Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool operator !=(
    GH_Path path,
    GH_Pattern pattern
)
Visual Basic
Public Shared Operator <> ( _
    path As GH_Path, _
    pattern As GH_Pattern _
) As Boolean

Parameters

path
Type: Grasshopper.Kernel.Data..::..GH_Path
pattern
Type: Grasshopper.Kernel.Data..::..GH_Pattern

See Also

GH_Pattern Class
Inequality Overload
Grasshopper.Kernel.Data Namespace


Inequality Operator (GH_Pattern, GH_Path)

[image]

Grasshopper SDK
GH_Pattern..::..Inequality Operator (GH_Pattern, GH_Path)
GH_Pattern Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool operator !=(
    GH_Pattern pattern,
    GH_Path path
)
Visual Basic
Public Shared Operator <> ( _
    pattern As GH_Pattern, _
    path As GH_Path _
) As Boolean

Parameters

pattern
Type: Grasshopper.Kernel.Data..::..GH_Pattern
path
Type: Grasshopper.Kernel.Data..::..GH_Path

See Also

GH_Pattern Class
Inequality Overload
Grasshopper.Kernel.Data Namespace


GH_PatternElement Class

[image]

Grasshopper SDK
GH_PatternElement Class
Members See Also Send Feedback
A single element in a string of path matching comparisons.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class GH_PatternElement
Visual Basic
Public NotInheritable Class GH_PatternElement

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Data..::..GH_PatternElement

See Also

GH_PatternElement Members
Grasshopper.Kernel.Data Namespace


GH_PatternElement Members

[image] [image]

Grasshopper SDK
GH_PatternElement Members
GH_PatternElement Class Methods Properties See Also Send Feedback

The GH_PatternElement type exposes the following members.

Methods

 | Name | Description
 | AnyDigitElement | Creates a new instance of GH_PatternElement with the AnyDigit flag.
 | GroupElement | Creates a new instance of GH_PatternElement with the Number flag.
Public method | Match | Compare a single integer for matching validity.
 | NumberElement | Creates a new instance of GH_PatternElement with the Number flag.
 | RangeElement | Creates a new instance of GH_PatternElement with the Number flag.
Public method | ToString | (Overrides Object..::..ToString()()()().)
 | WildCardElement | Creates a new instance of GH_PatternElement with the WildCard flag.

Properties

 | Name | Description
Public property | Invert |
Public property | Tags | Gets the tags stored in this element. The tag layout depends on the Type of this element: None = no tags; Wildcards = no tags; Digit = a single tag; Range = two tags; Group = any number of tags
Public property | Type |

See Also

GH_PatternElement Class
Grasshopper.Kernel.Data Namespace


GH_PatternElement Methods

[image] [image]

Grasshopper SDK
GH_PatternElement Methods
GH_PatternElement Class See Also Send Feedback

The GH_PatternElement type exposes the following members.

Methods

 | Name | Description
 | AnyDigitElement | Creates a new instance of GH_PatternElement with the AnyDigit flag.
 | GroupElement | Creates a new instance of GH_PatternElement with the Number flag.
Public method | Match | Compare a single integer for matching validity.
 | NumberElement | Creates a new instance of GH_PatternElement with the Number flag.
 | RangeElement | Creates a new instance of GH_PatternElement with the Number flag.
Public method | ToString | (Overrides Object..::..ToString()()()().)
 | WildCardElement | Creates a new instance of GH_PatternElement with the WildCard flag.

See Also

GH_PatternElement Class
Grasshopper.Kernel.Data Namespace


AnyDigitElement Method

[image]

Grasshopper SDK
GH_PatternElement..::..AnyDigitElement Method
GH_PatternElement Class See Also Send Feedback
Creates a new instance of GH_PatternElement with the AnyDigit flag.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_PatternElement AnyDigitElement()
Visual Basic
Public Shared Function AnyDigitElement As GH_PatternElement

See Also

GH_PatternElement Class
Grasshopper.Kernel.Data Namespace


GroupElement Method

[image]

Grasshopper SDK
GH_PatternElement..::..GroupElement Method
GH_PatternElement Class See Also Send Feedback
Creates a new instance of GH_PatternElement with the Number flag.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_PatternElement GroupElement(
    IEnumerable<int> numbers,
    bool invert
)
Visual Basic
Public Shared Function GroupElement ( _
    numbers As IEnumerable(Of Integer), _
    invert As Boolean _
) As GH_PatternElement

Parameters

numbers
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Int32 >)>)>
Numbers to include in the match.
invert
Type: System..::..Boolean
If True, the match will be negative.

See Also

GH_PatternElement Class
Grasshopper.Kernel.Data Namespace


Match Method

[image]

Grasshopper SDK
GH_PatternElement..::..Match Method
GH_PatternElement Class See Also Send Feedback
Compare a single integer for matching validity.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Match(
    int index
)
Visual Basic
Public Function Match ( _
    index As Integer _
) As Boolean

Parameters

index
Type: System..::..Int32
Number to match against this pattern element.

See Also

GH_PatternElement Class
Grasshopper.Kernel.Data Namespace


NumberElement Method

[image]

Grasshopper SDK
GH_PatternElement..::..NumberElement Method
GH_PatternElement Class See Also Send Feedback
Creates a new instance of GH_PatternElement with the Number flag.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_PatternElement NumberElement(
    int number,
    bool invert
)
Visual Basic
Public Shared Function NumberElement ( _
    number As Integer, _
    invert As Boolean _
) As GH_PatternElement

Parameters

number
Type: System..::..Int32
Number to match.
invert
Type: System..::..Boolean
If True, the match will be negative.

See Also

GH_PatternElement Class
Grasshopper.Kernel.Data Namespace


RangeElement Method

[image]

Grasshopper SDK
GH_PatternElement..::..RangeElement Method
GH_PatternElement Class See Also Send Feedback
Creates a new instance of GH_PatternElement with the Number flag.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_PatternElement RangeElement(
    int lower,
    int upper,
    bool invert
)
Visual Basic
Public Shared Function RangeElement ( _
    lower As Integer, _
    upper As Integer, _
    invert As Boolean _
) As GH_PatternElement

Parameters

lower
Type: System..::..Int32
Inclusive Lower limit of index range.
upper
Type: System..::..Int32
Inclusive Upper limit of index range.
invert
Type: System..::..Boolean
If True, the match will be negative.

See Also

GH_PatternElement Class
Grasshopper.Kernel.Data Namespace


ToString Method

[image]

Grasshopper SDK
GH_PatternElement..::..ToString Method
GH_PatternElement Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_PatternElement Class
Grasshopper.Kernel.Data Namespace


WildCardElement Method

[image]

Grasshopper SDK
GH_PatternElement..::..WildCardElement Method
GH_PatternElement Class See Also Send Feedback
Creates a new instance of GH_PatternElement with the WildCard flag.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_PatternElement WildCardElement()
Visual Basic
Public Shared Function WildCardElement As GH_PatternElement

See Also

GH_PatternElement Class
Grasshopper.Kernel.Data Namespace


GH_PatternElement Properties

[image] [image]

Grasshopper SDK
GH_PatternElement Properties
GH_PatternElement Class See Also Send Feedback

The GH_PatternElement type exposes the following members.

Properties

 | Name | Description
Public property | Invert |
Public property | Tags | Gets the tags stored in this element. The tag layout depends on the Type of this element: None = no tags; Wildcards = no tags; Digit = a single tag; Range = two tags; Group = any number of tags
Public property | Type |

See Also

GH_PatternElement Class
Grasshopper.Kernel.Data Namespace


Invert Property

[image]

Grasshopper SDK
GH_PatternElement..::..Invert Property
GH_PatternElement Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Invert { get; set; }
Visual Basic
Public Property Invert As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_PatternElement.Invert"]

See Also

GH_PatternElement Class
Grasshopper.Kernel.Data Namespace


Tags Property

[image]

Grasshopper SDK
GH_PatternElement..::..Tags Property
GH_PatternElement Class See Also Send Feedback
Gets the tags stored in this element. The tag layout depends on the Type of this element:
None = no tags;
Wildcards = no tags;
Digit = a single tag;
Range = two tags;
Group = any number of tags

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<int> Tags { get; }
Visual Basic
Public ReadOnly Property Tags As List(Of Integer)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_PatternElement.Tags"]

See Also

GH_PatternElement Class
Grasshopper.Kernel.Data Namespace


Type Property

[image]

Grasshopper SDK
GH_PatternElement..::..Type Property
GH_PatternElement Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PatternType Type { get; }
Visual Basic
Public ReadOnly Property Type As GH_PatternType
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_PatternElement.Type"]

See Also

GH_PatternElement Class
Grasshopper.Kernel.Data Namespace


GH_PatternType Enumeration

[image]

Grasshopper SDK
GH_PatternType Enumeration
See Also Send Feedback
Represents all possible element types in a Path Pattern.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_PatternType
Visual Basic
Public Enumeration GH_PatternType

Members

Member name | Value | Description
None | -1 | Represents an invalid, default value.
Number | 0 | Single number
Range | 1 | A range of digits delimited by two extremes.
Group | 2 | A collection of non-related Integers
AnyDigit | 10 | Any single digit
WildCard | 11 | Any (or no) collection of digits

See Also

Grasshopper.Kernel.Data Namespace


GH_RuleResult Enumeration

[image]

Grasshopper SDK
GH_RuleResult Enumeration
See Also Send Feedback
Enumerates the possible opinions a rule can have.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_RuleResult
Visual Basic
Public Enumeration GH_RuleResult

Members

Member name | Value | Description
NoOpinion | 0 | The rule does not prohibit or enforce any behaviour.
Include | 1 | The rule claims a certain index ought to be included.
Exclude | -1 | The rule claims a certain index ought to be exluded.

See Also

Grasshopper.Kernel.Data Namespace


GH_SimplificationMode Enumeration

[image]

Grasshopper SDK
GH_SimplificationMode Enumeration
See Also Send Feedback
Enumerates the possible data structure simplification modes.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_SimplificationMode
Visual Basic
Public Enumeration GH_SimplificationMode

Members

Member name | Value | Description
None | 0 | Specifies no simplification is to take place.
CollapseLeadingOverlaps | 1 | Only overlaps at the leading portion of paths will be simplified.
CollapseAllOverlaps | 2 | Overlaps along the entire span of the paths will be simplified.

See Also

Grasshopper.Kernel.Data Namespace


GH_StringMismatchException Class

[image]

Grasshopper SDK
GH_StringMismatchException Class
Members See Also Send Feedback
Exception used during Rule Set parsing.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_StringMismatchException : Exception
Visual Basic
Public Class GH_StringMismatchException _
    Inherits Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
Grasshopper.Kernel.Data..::..GH_StringMismatchException

See Also

GH_StringMismatchException Members
Grasshopper.Kernel.Data Namespace


GH_StringMismatchException Members

[image] [image]

Grasshopper SDK
GH_StringMismatchException Members
GH_StringMismatchException Class Constructors See Also Send Feedback

Constructors

 | Name | Description
Public method | GH_StringMismatchException()()()() | Initializes a new instance of the GH_StringMismatchException class
Public method | GH_StringMismatchException(String) | Initializes a new instance of the GH_StringMismatchException class

See Also

GH_StringMismatchException Class
Grasshopper.Kernel.Data Namespace


GH_StringMismatchException Constructor

[image] [image]

Grasshopper SDK
GH_StringMismatchException Constructor
GH_StringMismatchException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_StringMismatchException()()()() | Initializes a new instance of the GH_StringMismatchException class
Public method | GH_StringMismatchException(String) | Initializes a new instance of the GH_StringMismatchException class

See Also

GH_StringMismatchException Class
GH_StringMismatchException Members
Grasshopper.Kernel.Data Namespace


GH_StringMismatchException Constructor

[image]

Grasshopper SDK
GH_StringMismatchException Constructor
GH_StringMismatchException Class See Also Send Feedback
Initializes a new instance of the GH_StringMismatchException class

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_StringMismatchException()
Visual Basic
Public Sub New

See Also

GH_StringMismatchException Class
GH_StringMismatchException Overload
Grasshopper.Kernel.Data Namespace


GH_StringMismatchException Constructor (String)

[image]

Grasshopper SDK
GH_StringMismatchException Constructor (String)
GH_StringMismatchException Class See Also Send Feedback
Initializes a new instance of the GH_StringMismatchException class

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_StringMismatchException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)

Parameters

message
Type: System..::..String

See Also

GH_StringMismatchException Class
GH_StringMismatchException Overload
Grasshopper.Kernel.Data Namespace


GH_Structure(T) Class

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)> Class
Members See Also Send Feedback
Represents a data tree where each branch has a unique path

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Structure<T> : IGH_Structure,
    IEnumerable<T>, GH_ISerializable
where T : IGH_Goo
Visual Basic
Public Class GH_Structure(Of T As IGH_Goo) _
    Implements IGH_Structure, IEnumerable(Of T), GH_ISerializable

Type Parameters

T
The data type that this structure maintains. Must implement IGH_Goo or derive from a class that implements IGH_Goo.

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Data..::..GH_Structure<(Of <(<'T>)>)>

See Also

GH_Structure<(Of <(<'T>)>)> Members
Grasshopper.Kernel.Data Namespace


GH_Structure(T) Members

[image] [image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)> Members
GH_Structure<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The GH_Structure<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Structure<(Of <(<'T>)>)>()()()() | Default constructor, create a blank data structure.
Public method | GH_Structure<(Of <(<'T>)>)>(GH_Structure<(Of <<'(T>)>>), Boolean) | Copy constructor, duplicate another data structure.

Methods

 | Name | Description
Public method | AllData | Gets an enumerator for all the data items in this structure.
Public method | Append(T) | Append a data item to the last branch in the structure. If no branch exist yet, a new one will be created with [path = {0}]
Public method | Append(T, GH_Path) | Append a data item to the specified branch in the structure. If the branch doesn't exist yet, it will be created.
Public method | AppendRange(IEnumerable<(Of <<'(T>)>>)) | Append a list of data items to the last branch in the structure
Public method | AppendRange(IEnumerable<(Of <<'(T>)>>), GH_Path) | Append a list of data items to the specified branch in the structure. If the branch doesn't exist yet, it will be created.
Public method | Clear | Clears the entire structure.
Public method | ClearData | Removes all data from all paths without affecting the structure topology.
Public method | DataDescription | Gets a description of the data contained in this structure.
Public method | Duplicate | Create an exact duplicate of this structure. All data items are copied as well.
Public method | DuplicateCast<(Of <<'(Q>)>>) | Create a duplicate of this structure in a different type.
Public method | EnsureCapacity | Ensures that all current branches have a certain capacity.
Public method | EnsurePath(array<Int32>[]()[][]) | Create a new branch with the specified path if it doesn't already exists.
Public method | EnsurePath(GH_Path) | Create a new branch with the specified path if it doesn't already exists.
Public method | ExpandPath | Expand a path in this structure by appending an element.
Public method | Flatten | Flattens the entire structure into a single path.
Public method | FlattenData | Collects all data in the structure under a single list. Does not alter the state of this structure.
Public method | GetEnumerator |
Public method | GetEnumerator_Generic |
Public method | Graft(Boolean) | Obsolete. Grafts all paths by reallocating all data into child paths.
Public method | Graft(GH_GraftMode) | Grafts all paths by reallocating all data into child paths.
Public method | Graft(GH_GraftMode, GH_Path) | Grafts a specific path by reallocating all data into child paths. If a grafted path coincides with an existing path, the data item in question will be appended to the existing path.
Public method | Graft(GH_Path, Boolean) | Obsolete. Grafts a specific path by reallocating all data into child paths. If a grafted path coincides with an existing path, the data item in question will be appended to the existing path.
Public method | Insert | Insert a data item into the specified branch in the structure. If the branch doesn't exist yet, it will be created.
Public method | LongestPathIndex | Finds the path in this structure with the most dimensions. In case of multiple equally long longest paths, the last one will be returned.
Public method | MergeStructure | Merges two structures together. Data inside similar paths will be merged into single lists and unique paths will be appended. The other structure will not be altered, so beware that data is now shared among both structures.
Public method | PathExists | Returns True if the specified path is already defined inside the structure.
Public method | PathIndex | Find the indices that surround the given path domain. Indices may be out of bounds.
Public method | Read | Read the entire GH_Structure from an archive. This method relies on the the serialization of the IGH_Goo items it contains. Also, the IGH_Goo T generic must have a public constructor that takes no arguments.
Public method | RemoveData | Removes the first occurence of a data instance in the tree.
Public method | RemovePath | Removes a path and all associated data from the structure. If the path doesn't exist, nothing will happen.
Public method | ReplacePath | Replace an existing path with a different one. If the operation is successfull, then the 'find' path will be deleted. If the 'replace' path is already defined, the items in 'find' will be appended to the existing path.
Public method | Reverse | Reverse the order of items in all branches.
Public method | ShallowDuplicate | Create a structure with a similar topology to this one with pointers to the same data items.
Public method | ShortestPathIndex | Finds the path in this structure with the least dimensions. In case of multiple equally long longest paths, the first one will be returned.
Public method | Simplify | Simplify the data structure by collapsing path indices shared by all branches.
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | TrimExcess | Trims the excess allocated memory in all branches.
Public method | Write | Write the entire GH_Structure to an archive. This method relies on the the serialization of the IGH_Goo items it contains.

Properties

 | Name | Description
Public property | Branch[([( Int32])]) | Gets a limited access pointer to the data list at the specified index
Public property | Branch[([( GH_Path])]) | Gets a limited access pointer to the data list associated with a certain path.
Public property | Branches | Gets a list of all the data-arrays in this structure
Public property | DataCount | Gets the total number of data items stored in all paths.
Public property | DataItem[([( Int32])]) | Gets the item at a given offset. The structure is treated as a linear list in this case. If index is out of range, null is returned. For repeated indexed retrieval, consider using a For Each loop since the enumerator is more efficient.
Public property | DataItem[([( GH_Path, Int32])]) | Gets a direct pointer to a data item under a specific path and index.
Public property | DataList[([( Int32])]) | Gets a direct pointer to the list of data under the specified index.
Public property | DataList[([( GH_Path])]) | Gets a direct pointer to the list of data under a specific path.
Public property | FirstItem | Gets the first item in the structure. If no such item exists, null is returned.
Public property | IsEmpty | Gets the Empty state of the structure. If the structure is Empty it contains no paths and no branches.
Public property | LastItem | Gets the last item in the structure. If no such item exists, null is returned.
Public property | NonNulls | Get an enumerator for this structure that allow linear iteration over the data hierarchy while skipping all Null entries. This Enumerator has been optimized, do not cache instances of it.
Public property | Path | Gets the data path at the specified index.
Public property | PathCount | Gets the number of paths defined in this structure.
Public property | Paths | Gets a list of all the paths in this structure.
Public property | StructureProxy | Gets a proxy list of all the data-arrays in this structure.
Public property | TopologyDescription | Gets a description of the topology of the structure. Useful for debugging purposes.

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


GH_Structure(T) Constructor

[image] [image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)> Constructor
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Structure<(Of <(<'T>)>)>()()()() | Default constructor, create a blank data structure.
Public method | GH_Structure<(Of <(<'T>)>)>(GH_Structure<(Of <<'(T>)>>), Boolean) | Copy constructor, duplicate another data structure.

See Also

GH_Structure<(Of <(<'T>)>)> Class
GH_Structure<(Of <(<'T>)>)> Members
Grasshopper.Kernel.Data Namespace


GH_Structure(T) Constructor

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)> Constructor
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Default constructor, create a blank data structure.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Structure()
Visual Basic
Public Sub New

See Also

GH_Structure<(Of <(<'T>)>)> Class
GH_Structure<(Of <(<'T>)>)> Overload
Grasshopper.Kernel.Data Namespace


GH_Structure(T) Constructor (GH_Structure(T), Boolean)

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)> Constructor (GH_Structure<(Of <(<'T>)>)>, Boolean)
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Copy constructor, duplicate another data structure.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Structure(
    GH_Structure<T> other,
    bool shallowCopy
)
Visual Basic
Public Sub New ( _
    other As GH_Structure(Of T), _
    shallowCopy As Boolean _
)

Parameters

other
Type: Grasshopper.Kernel.Data..::..GH_Structure <(Of <(<' T >)>)>
Structure to copy, if null, this structure will be empty.
shallowCopy
Type: System..::..Boolean
If True, data item pointers are shared among this and the [other] structure.

See Also

GH_Structure<(Of <(<'T>)>)> Class
GH_Structure<(Of <(<'T>)>)> Overload
Grasshopper.Kernel.Data Namespace


GH_Structure(T) Methods

[image] [image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)> Methods
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback

The GH_Structure<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | AllData | Gets an enumerator for all the data items in this structure.
Public method | Append(T) | Append a data item to the last branch in the structure. If no branch exist yet, a new one will be created with [path = {0}]
Public method | Append(T, GH_Path) | Append a data item to the specified branch in the structure. If the branch doesn't exist yet, it will be created.
Public method | AppendRange(IEnumerable<(Of <<'(T>)>>)) | Append a list of data items to the last branch in the structure
Public method | AppendRange(IEnumerable<(Of <<'(T>)>>), GH_Path) | Append a list of data items to the specified branch in the structure. If the branch doesn't exist yet, it will be created.
Public method | Clear | Clears the entire structure.
Public method | ClearData | Removes all data from all paths without affecting the structure topology.
Public method | DataDescription | Gets a description of the data contained in this structure.
Public method | Duplicate | Create an exact duplicate of this structure. All data items are copied as well.
Public method | DuplicateCast<(Of <<'(Q>)>>) | Create a duplicate of this structure in a different type.
Public method | EnsureCapacity | Ensures that all current branches have a certain capacity.
Public method | EnsurePath(array<Int32>[]()[][]) | Create a new branch with the specified path if it doesn't already exists.
Public method | EnsurePath(GH_Path) | Create a new branch with the specified path if it doesn't already exists.
Public method | ExpandPath | Expand a path in this structure by appending an element.
Public method | Flatten | Flattens the entire structure into a single path.
Public method | FlattenData | Collects all data in the structure under a single list. Does not alter the state of this structure.
Public method | GetEnumerator |
Public method | GetEnumerator_Generic |
Public method | Graft(Boolean) | Obsolete. Grafts all paths by reallocating all data into child paths.
Public method | Graft(GH_GraftMode) | Grafts all paths by reallocating all data into child paths.
Public method | Graft(GH_GraftMode, GH_Path) | Grafts a specific path by reallocating all data into child paths. If a grafted path coincides with an existing path, the data item in question will be appended to the existing path.
Public method | Graft(GH_Path, Boolean) | Obsolete. Grafts a specific path by reallocating all data into child paths. If a grafted path coincides with an existing path, the data item in question will be appended to the existing path.
Public method | Insert | Insert a data item into the specified branch in the structure. If the branch doesn't exist yet, it will be created.
Public method | LongestPathIndex | Finds the path in this structure with the most dimensions. In case of multiple equally long longest paths, the last one will be returned.
Public method | MergeStructure | Merges two structures together. Data inside similar paths will be merged into single lists and unique paths will be appended. The other structure will not be altered, so beware that data is now shared among both structures.
Public method | PathExists | Returns True if the specified path is already defined inside the structure.
Public method | PathIndex | Find the indices that surround the given path domain. Indices may be out of bounds.
Public method | Read | Read the entire GH_Structure from an archive. This method relies on the the serialization of the IGH_Goo items it contains. Also, the IGH_Goo T generic must have a public constructor that takes no arguments.
Public method | RemoveData | Removes the first occurence of a data instance in the tree.
Public method | RemovePath | Removes a path and all associated data from the structure. If the path doesn't exist, nothing will happen.
Public method | ReplacePath | Replace an existing path with a different one. If the operation is successfull, then the 'find' path will be deleted. If the 'replace' path is already defined, the items in 'find' will be appended to the existing path.
Public method | Reverse | Reverse the order of items in all branches.
Public method | ShallowDuplicate | Create a structure with a similar topology to this one with pointers to the same data items.
Public method | ShortestPathIndex | Finds the path in this structure with the least dimensions. In case of multiple equally long longest paths, the first one will be returned.
Public method | Simplify | Simplify the data structure by collapsing path indices shared by all branches.
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | TrimExcess | Trims the excess allocated memory in all branches.
Public method | Write | Write the entire GH_Structure to an archive. This method relies on the the serialization of the IGH_Goo items it contains.

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


AllData Method

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..AllData Method
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Gets an enumerator for all the data items in this structure.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_StructureEnumerator AllData(
    bool skipNulls
)
Visual Basic
Public Function AllData ( _
    skipNulls As Boolean _
) As IGH_StructureEnumerator

Parameters

skipNulls
Type: System..::..Boolean
If True, null items will be skipped.

Implements

IGH_Structure..::..AllData(Boolean)

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


Append Method

[image] [image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..Append Method
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Append(T) | Append a data item to the last branch in the structure. If no branch exist yet, a new one will be created with [path = {0}]
Public method | Append(T, GH_Path) | Append a data item to the specified branch in the structure. If the branch doesn't exist yet, it will be created.

See Also

GH_Structure<(Of <(<'T>)>)> Class
GH_Structure<(Of <(<'T>)>)> Members
Grasshopper.Kernel.Data Namespace


Append Method (T)

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..Append Method (T)
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Append a data item to the last branch in the structure. If no branch exist yet, a new one will be created with [path = {0}]

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Append(
    T data
)
Visual Basic
Public Sub Append ( _
    data As T _
)

Parameters

data
Type: T
Data to append.

See Also

GH_Structure<(Of <(<'T>)>)> Class
Append Overload
Grasshopper.Kernel.Data Namespace


Append Method (T, GH_Path)

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..Append Method (T, GH_Path)
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Append a data item to the specified branch in the structure. If the branch doesn't exist yet, it will be created.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Append(
    T data,
    GH_Path path
)
Visual Basic
Public Sub Append ( _
    data As T, _
    path As GH_Path _
)

Parameters

data
Type: T
Data to append
path
Type: Grasshopper.Kernel.Data..::..GH_Path
Data path

See Also

GH_Structure<(Of <(<'T>)>)> Class
Append Overload
Grasshopper.Kernel.Data Namespace


AppendRange Method

[image] [image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..AppendRange Method
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AppendRange(IEnumerable<(Of <<'(T>)>>)) | Append a list of data items to the last branch in the structure
Public method | AppendRange(IEnumerable<(Of <<'(T>)>>), GH_Path) | Append a list of data items to the specified branch in the structure. If the branch doesn't exist yet, it will be created.

See Also

GH_Structure<(Of <(<'T>)>)> Class
GH_Structure<(Of <(<'T>)>)> Members
Grasshopper.Kernel.Data Namespace


AppendRange Method (IEnumerable(T))

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..AppendRange Method (IEnumerable<(Of <(<'T>)>)>)
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Append a list of data items to the last branch in the structure

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AppendRange(
    IEnumerable<T> data
)
Visual Basic
Public Sub AppendRange ( _
    data As IEnumerable(Of T) _
)

Parameters

data
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' T >)>)>
Data to append

See Also

GH_Structure<(Of <(<'T>)>)> Class
AppendRange Overload
Grasshopper.Kernel.Data Namespace


AppendRange Method (IEnumerable(T), GH_Path)

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..AppendRange Method (IEnumerable<(Of <(<'T>)>)>, GH_Path)
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Append a list of data items to the specified branch in the structure. If the branch doesn't exist yet, it will be created.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AppendRange(
    IEnumerable<T> data,
    GH_Path path
)
Visual Basic
Public Sub AppendRange ( _
    data As IEnumerable(Of T), _
    path As GH_Path _
)

Parameters

data
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' T >)>)>
Data to append
path
Type: Grasshopper.Kernel.Data..::..GH_Path
Data path

See Also

GH_Structure<(Of <(<'T>)>)> Class
AppendRange Overload
Grasshopper.Kernel.Data Namespace


Clear Method

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..Clear Method
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Clears the entire structure.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear

Implements

IGH_Structure..::..Clear()()()()

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


ClearData Method

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..ClearData Method
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Removes all data from all paths without affecting the structure topology.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ClearData()
Visual Basic
Public Sub ClearData

Implements

IGH_Structure..::..ClearData()()()()

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


DataDescription Method

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..DataDescription Method
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Gets a description of the data contained in this structure.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string DataDescription(
    bool includeIndices,
    bool includePaths
)
Visual Basic
Public Function DataDescription ( _
    includeIndices As Boolean, _
    includePaths As Boolean _
) As String

Parameters

includeIndices
Type: System..::..Boolean
If true, every data item will be prefixed by its index.
includePaths
Type: System..::..Boolean
If true, every branch of data will be preceded by the path.

Return Value

A string describing the data.

Implements

IGH_Structure..::..DataDescription(Boolean, Boolean)

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..Duplicate Method
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Create an exact duplicate of this structure. All data items are copied as well.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Structure<T> Duplicate()
Visual Basic
Public Function Duplicate As GH_Structure(Of T)

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


DuplicateCast(Q) Method

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..DuplicateCast<(Of <(<'Q>)>)> Method
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Create a duplicate of this structure in a different type.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Structure<Q> DuplicateCast<Q>(
    GH_Structure<(Of <(<'T>)>)>..::..ConversionDelegate<T, Q> conversion
)
where Q : IGH_Goo
Visual Basic
Public Function DuplicateCast(Of Q As IGH_Goo) ( _
    conversion As GH_Structure<(Of <(<'T>)>)>..::..ConversionDelegate(Of T, Q) _
) As GH_Structure(Of Q)

Parameters

conversion
Type: Grasshopper.Kernel.Data..::..GH_Structure<(Of <(<'T>)>)>..::..ConversionDelegate <(Of <(<' T, Q>)>)>
Conversion delegate.

Type Parameters

Q
Type of conversion.

Return Value

A duplicate of this structure with all valid casts.

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


EnsureCapacity Method

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..EnsureCapacity Method
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Ensures that all current branches have a certain capacity.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void EnsureCapacity(
    int capacity
)
Visual Basic
Public Sub EnsureCapacity ( _
    capacity As Integer _
)

Parameters

capacity
Type: System..::..Int32
Capacity per branch.

Implements

IGH_Structure..::..EnsureCapacity(Int32)

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


EnsurePath Method

[image] [image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..EnsurePath Method
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EnsurePath(array<Int32>[]()[][]) | Create a new branch with the specified path if it doesn't already exists.
Public method | EnsurePath(GH_Path) | Create a new branch with the specified path if it doesn't already exists.

See Also

GH_Structure<(Of <(<'T>)>)> Class
GH_Structure<(Of <(<'T>)>)> Members
Grasshopper.Kernel.Data Namespace


EnsurePath Method (Int32[])

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..EnsurePath Method (array<Int32>[]()[][])
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Create a new branch with the specified path if it doesn't already exists.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<T> EnsurePath(
    params int[] path
)
Visual Basic
Public Function EnsurePath ( _
    ParamArray path As Integer() _
) As List(Of T)

Parameters

path
Type: array< System..::..Int32 >[]()[][]
Path of the branch to ensure.

Return Value

The list that belongs to the specified path.

See Also

GH_Structure<(Of <(<'T>)>)> Class
EnsurePath Overload
Grasshopper.Kernel.Data Namespace


EnsurePath Method (GH_Path)

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..EnsurePath Method (GH_Path)
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Create a new branch with the specified path if it doesn't already exists.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<T> EnsurePath(
    GH_Path path
)
Visual Basic
Public Function EnsurePath ( _
    path As GH_Path _
) As List(Of T)

Parameters

path
Type: Grasshopper.Kernel.Data..::..GH_Path
Path of the branch to ensure.

Return Value

The list that belongs to the specified path.

See Also

GH_Structure<(Of <(<'T>)>)> Class
EnsurePath Overload
Grasshopper.Kernel.Data Namespace


ExpandPath Method

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..ExpandPath Method
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Expand a path in this structure by appending an element.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ExpandPath(
    GH_Path path,
    int element,
    GH_ExpandMode mode
)
Visual Basic
Public Sub ExpandPath ( _
    path As GH_Path, _
    element As Integer, _
    mode As GH_ExpandMode _
)

Parameters

path
Type: Grasshopper.Kernel.Data..::..GH_Path
Path to expand, if the path doesn't exist, nothing will happen.
element
Type: System..::..Int32
Element to append to the path.
mode
Type: Grasshopper.Kernel.Data..::..GH_ExpandMode
Expansion mode.

Implements

IGH_Structure..::..ExpandPath(GH_Path, Int32, GH_ExpandMode)

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


Flatten Method

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..Flatten Method
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Flattens the entire structure into a single path.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Flatten(
    GH_Path flat_path
)
Visual Basic
Public Sub Flatten ( _
    flat_path As GH_Path _
)

Parameters

flat_path
Type: Grasshopper.Kernel.Data..::..GH_Path
The path of the flattened data. If null, the path will be {0}

Implements

IGH_Structure..::..Flatten(GH_Path)

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


FlattenData Method

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..FlattenData Method
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Collects all data in the structure under a single list. Does not alter the state of this structure.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<T> FlattenData()
Visual Basic
Public Function FlattenData As List(Of T)

Return Value

A linear list containing all data items in all branches.

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


GetEnumerator Method

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..GetEnumerator Method
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


GetEnumerator_Generic Method

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..GetEnumerator_Generic Method
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IEnumerator<T> GetEnumerator_Generic()
Visual Basic
Public Function GetEnumerator_Generic As IEnumerator(Of T)

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


Graft Method

[image] [image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..Graft Method
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Graft(Boolean) | Obsolete. Grafts all paths by reallocating all data into child paths.
Public method | Graft(GH_GraftMode) | Grafts all paths by reallocating all data into child paths.
Public method | Graft(GH_GraftMode, GH_Path) | Grafts a specific path by reallocating all data into child paths. If a grafted path coincides with an existing path, the data item in question will be appended to the existing path.
Public method | Graft(GH_Path, Boolean) | Obsolete. Grafts a specific path by reallocating all data into child paths. If a grafted path coincides with an existing path, the data item in question will be appended to the existing path.

See Also

GH_Structure<(Of <(<'T>)>)> Class
GH_Structure<(Of <(<'T>)>)> Members
Grasshopper.Kernel.Data Namespace


Graft Method (Boolean)

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..Graft Method (Boolean)
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Grafts all paths by reallocating all data into child paths.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
[ObsoleteAttribute("this method has been replaced by Graft(GH_GraftMode)")]
public void Graft(
    bool clearSingleNulls
)
Visual Basic
<ObsoleteAttribute("this method has been replaced by Graft(GH_GraftMode)")> _
Public Sub Graft ( _
    clearSingleNulls As Boolean _
)

Parameters

clearSingleNulls
Type: System..::..Boolean
If True, nulls will not be grafted.

Implements

IGH_Structure..::..Graft(Boolean)

See Also

GH_Structure<(Of <(<'T>)>)> Class
Graft Overload
Grasshopper.Kernel.Data Namespace


Graft Method (GH_GraftMode)

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..Graft Method (GH_GraftMode)
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Grafts all paths by reallocating all data into child paths.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Graft(
    GH_GraftMode mode
)
Visual Basic
Public Sub Graft ( _
    mode As GH_GraftMode _
)

Parameters

mode
Type: Grasshopper.Kernel.Data..::..GH_GraftMode
Graft mode.

Implements

IGH_Structure..::..Graft(GH_GraftMode)

See Also

GH_Structure<(Of <(<'T>)>)> Class
Graft Overload
Grasshopper.Kernel.Data Namespace


Graft Method (GH_GraftMode, GH_Path)

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..Graft Method (GH_GraftMode, GH_Path)
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Grafts a specific path by reallocating all data into child paths. If a grafted path coincides with an existing path, the data item in question will be appended to the existing path.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Graft(
    GH_GraftMode mode,
    GH_Path path
)
Visual Basic
Public Sub Graft ( _
    mode As GH_GraftMode, _
    path As GH_Path _
)

Parameters

mode
Type: Grasshopper.Kernel.Data..::..GH_GraftMode
Graft mode.
path
Type: Grasshopper.Kernel.Data..::..GH_Path
Path to graft

Implements

IGH_Structure..::..Graft(GH_GraftMode, GH_Path)

See Also

GH_Structure<(Of <(<'T>)>)> Class
Graft Overload
Grasshopper.Kernel.Data Namespace


Graft Method (GH_Path, Boolean)

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..Graft Method (GH_Path, Boolean)
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Grafts a specific path by reallocating all data into child paths. If a grafted path coincides with an existing path, the data item in question will be appended to the existing path.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
[ObsoleteAttribute("this method has been replaced by Graft(GH_GraftMode, GH_Path)")]
public void Graft(
    GH_Path path,
    bool clearSingleNulls
)
Visual Basic
<ObsoleteAttribute("this method has been replaced by Graft(GH_GraftMode, GH_Path)")> _
Public Sub Graft ( _
    path As GH_Path, _
    clearSingleNulls As Boolean _
)

Parameters

path
Type: Grasshopper.Kernel.Data..::..GH_Path
Path of data to graft.
clearSingleNulls
Type: System..::..Boolean
If true, nulls will not be grafted.

Implements

IGH_Structure..::..Graft(GH_Path, Boolean)

See Also

GH_Structure<(Of <(<'T>)>)> Class
Graft Overload
Grasshopper.Kernel.Data Namespace


Insert Method

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..Insert Method
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Insert a data item into the specified branch in the structure. If the branch doesn't exist yet, it will be created.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Insert(
    T data,
    GH_Path path,
    int index
)
Visual Basic
Public Sub Insert ( _
    data As T, _
    path As GH_Path, _
    index As Integer _
)

Parameters

data
Type: T
Data to insert.
path
Type: Grasshopper.Kernel.Data..::..GH_Path
Path of branch to insert into.
index
Type: System..::..Int32
Insertion index.

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


LongestPathIndex Method

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..LongestPathIndex Method
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Finds the path in this structure with the most dimensions. In case of multiple equally long longest paths, the last one will be returned.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int LongestPathIndex()
Visual Basic
Public Function LongestPathIndex As Integer

Return Value

The index of the longest path or -1 if there are no paths.

Implements

IGH_Structure..::..LongestPathIndex()()()()

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


MergeStructure Method

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..MergeStructure Method
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Merges two structures together. Data inside similar paths will be merged into single lists and unique paths will be appended. The other structure will not be altered, so beware that data is now shared among both structures.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void MergeStructure(
    GH_Structure<T> other
)
Visual Basic
Public Sub MergeStructure ( _
    other As GH_Structure(Of T) _
)

Parameters

other
Type: Grasshopper.Kernel.Data..::..GH_Structure <(Of <(<' T >)>)>
Structure to merge

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


PathExists Method

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..PathExists Method
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Returns True if the specified path is already defined inside the structure.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool PathExists(
    GH_Path path
)
Visual Basic
Public Function PathExists ( _
    path As GH_Path _
) As Boolean

Parameters

path
Type: Grasshopper.Kernel.Data..::..GH_Path
The data path to search for

Implements

IGH_Structure..::..PathExists(GH_Path)

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


PathIndex Method

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..PathIndex Method
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Find the indices that surround the given path domain. Indices may be out of bounds.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void PathIndex(
    GH_Path path,
    ref int idx0,
    ref int idx1
)
Visual Basic
Public Sub PathIndex ( _
    path As GH_Path, _
    ByRef idx0 As Integer, _
    ByRef idx1 As Integer _
)

Parameters

path
Type: Grasshopper.Kernel.Data..::..GH_Path
Path to search for (it need not exist in the structure).
idx0
Type: System..::..Int32 %
The index of the path itself or the first smaller path if the path is not defined.
idx1
Type: System..::..Int32 %
The index of th path itself of the first larger path if the path is not defined.

Implements

IGH_Structure..::..PathIndex(GH_Path, Int32%, Int32%)

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


Read Method

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..Read Method
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Read the entire GH_Structure from an archive. This method relies on the the serialization of the IGH_Goo items it contains. Also, the IGH_Goo T generic must have a public constructor that takes no arguments.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Read(
    GH_IReader reader
)
Visual Basic
Public Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader
Archive to read from.

Return Value

True on success, false on failure.

Implements

GH_ISerializable..::..Read(GH_IReader)

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


RemoveData Method

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..RemoveData Method
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Removes the first occurence of a data instance in the tree.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RemoveData(
    T data
)
Visual Basic
Public Sub RemoveData ( _
    data As T _
)

Parameters

data
Type: T
Data to remove.

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


RemovePath Method

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..RemovePath Method
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Removes a path and all associated data from the structure. If the path doesn't exist, nothing will happen.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RemovePath(
    GH_Path path
)
Visual Basic
Public Sub RemovePath ( _
    path As GH_Path _
)

Parameters

path
Type: Grasshopper.Kernel.Data..::..GH_Path
Path to remove.

Implements

IGH_Structure..::..RemovePath(GH_Path)

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


ReplacePath Method

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..ReplacePath Method
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Replace an existing path with a different one. If the operation is successfull, then the 'find' path will be deleted. If the 'replace' path is already defined, the items in 'find' will be appended to the existing path.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ReplacePath(
    GH_Path find,
    GH_Path replace
)
Visual Basic
Public Sub ReplacePath ( _
    find As GH_Path, _
    replace As GH_Path _
)

Parameters

find
Type: Grasshopper.Kernel.Data..::..GH_Path
The path to search for.
replace
Type: Grasshopper.Kernel.Data..::..GH_Path
The new path.

Implements

IGH_Structure..::..ReplacePath(GH_Path, GH_Path)

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


Reverse Method

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..Reverse Method
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Reverse the order of items in all branches.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Reverse()
Visual Basic
Public Sub Reverse

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


ShallowDuplicate Method

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..ShallowDuplicate Method
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Create a structure with a similar topology to this one with pointers to the same data items.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Structure<T> ShallowDuplicate()
Visual Basic
Public Function ShallowDuplicate As GH_Structure(Of T)

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


ShortestPathIndex Method

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..ShortestPathIndex Method
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Finds the path in this structure with the least dimensions. In case of multiple equally long longest paths, the first one will be returned.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int ShortestPathIndex()
Visual Basic
Public Function ShortestPathIndex As Integer

Return Value

The index of the shortest path or -1 if there are no paths.

Implements

IGH_Structure..::..ShortestPathIndex()()()()

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


Simplify Method

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..Simplify Method
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Simplify the data structure by collapsing path indices shared by all branches.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Simplify(
    GH_SimplificationMode mode
)
Visual Basic
Public Sub Simplify ( _
    mode As GH_SimplificationMode _
)

Parameters

mode
Type: Grasshopper.Kernel.Data..::..GH_SimplificationMode
Simplification algorithm to use.

Implements

IGH_Structure..::..Simplify(GH_SimplificationMode)

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


ToString Method

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..ToString Method
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


TrimExcess Method

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..TrimExcess Method
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Trims the excess allocated memory in all branches.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void TrimExcess()
Visual Basic
Public Sub TrimExcess

Implements

IGH_Structure..::..TrimExcess()()()()

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


Write Method

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..Write Method
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Write the entire GH_Structure to an archive. This method relies on the the serialization of the IGH_Goo items it contains.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Write(
    GH_IWriter writer
)
Visual Basic
Public Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter
Archive to write to.

Return Value

True on success, false on failure.

Implements

GH_ISerializable..::..Write(GH_IWriter)

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


GH_Structure(T) Properties

[image] [image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)> Properties
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback

The GH_Structure<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Branch[([( Int32])]) | Gets a limited access pointer to the data list at the specified index
Public property | Branch[([( GH_Path])]) | Gets a limited access pointer to the data list associated with a certain path.
Public property | Branches | Gets a list of all the data-arrays in this structure
Public property | DataCount | Gets the total number of data items stored in all paths.
Public property | DataItem[([( Int32])]) | Gets the item at a given offset. The structure is treated as a linear list in this case. If index is out of range, null is returned. For repeated indexed retrieval, consider using a For Each loop since the enumerator is more efficient.
Public property | DataItem[([( GH_Path, Int32])]) | Gets a direct pointer to a data item under a specific path and index.
Public property | DataList[([( Int32])]) | Gets a direct pointer to the list of data under the specified index.
Public property | DataList[([( GH_Path])]) | Gets a direct pointer to the list of data under a specific path.
Public property | FirstItem | Gets the first item in the structure. If no such item exists, null is returned.
Public property | IsEmpty | Gets the Empty state of the structure. If the structure is Empty it contains no paths and no branches.
Public property | LastItem | Gets the last item in the structure. If no such item exists, null is returned.
Public property | NonNulls | Get an enumerator for this structure that allow linear iteration over the data hierarchy while skipping all Null entries. This Enumerator has been optimized, do not cache instances of it.
Public property | Path | Gets the data path at the specified index.
Public property | PathCount | Gets the number of paths defined in this structure.
Public property | Paths | Gets a list of all the paths in this structure.
Public property | StructureProxy | Gets a proxy list of all the data-arrays in this structure.
Public property | TopologyDescription | Gets a description of the topology of the structure. Useful for debugging purposes.

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


Branch Property

[image] [image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..Branch Property
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Branch[([( Int32])]) | Gets a limited access pointer to the data list at the specified index
Public property | Branch[([( GH_Path])]) | Gets a limited access pointer to the data list associated with a certain path.

See Also

GH_Structure<(Of <(<'T>)>)> Class
GH_Structure<(Of <(<'T>)>)> Members
Grasshopper.Kernel.Data Namespace


Branch Property (Int32)

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..Branch Property (Int32)
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Gets a limited access pointer to the data list at the specified index

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IList this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property Branch ( _
    index As Integer _
) As IList
    Get

Parameters

index
Type: System..::..Int32
Index of data to retrieve.

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_Structure`1.Branch(System.Int32)"]

Implements

IGH_Structure..::..Branch[([( Int32])])

See Also

GH_Structure<(Of <(<'T>)>)> Class
Branch Overload
Grasshopper.Kernel.Data Namespace


Branch Property (GH_Path)

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..Branch Property (GH_Path)
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Gets a limited access pointer to the data list associated with a certain path.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IList this[
    GH_Path path
] { get; }
Visual Basic
Public ReadOnly Property Branch ( _
    path As GH_Path _
) As IList
    Get

Parameters

path
Type: Grasshopper.Kernel.Data..::..GH_Path
Data path to retrieve.

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_Structure`1.Branch(Grasshopper.Kernel.Data.GH_Path)"]

Implements

IGH_Structure..::..Branch[([( GH_Path])])

See Also

GH_Structure<(Of <(<'T>)>)> Class
Branch Overload
Grasshopper.Kernel.Data Namespace


Branches Property

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..Branches Property
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Gets a list of all the data-arrays in this structure

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IList<List<T>> Branches { get; }
Visual Basic
Public ReadOnly Property Branches As IList(Of List(Of T))
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_Structure`1.Branches"]

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


DataCount Property

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..DataCount Property
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the total number of data items stored in all paths.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int DataCount { get; }
Visual Basic
Public ReadOnly Property DataCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_Structure`1.DataCount"]

Implements

IGH_Structure..::..DataCount

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


DataItem Property

[image] [image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..DataItem Property
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public property | DataItem[([( Int32])]) | Gets the item at a given offset. The structure is treated as a linear list in this case. If index is out of range, null is returned. For repeated indexed retrieval, consider using a For Each loop since the enumerator is more efficient.
Public property | DataItem[([( GH_Path, Int32])]) | Gets a direct pointer to a data item under a specific path and index.

See Also

GH_Structure<(Of <(<'T>)>)> Class
GH_Structure<(Of <(<'T>)>)> Members
Grasshopper.Kernel.Data Namespace


DataItem Property (Int32)

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..DataItem Property (Int32)
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the item at a given offset. The structure is treated as a linear list in this case. If index is out of range, null is returned. For repeated indexed retrieval, consider using a For Each loop since the enumerator is more efficient.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public T this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property DataItem ( _
    index As Integer _
) As T
    Get

Parameters

index
Type: System..::..Int32
Offset of item to retrieve

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_Structure`1.DataItem(System.Int32)"]

Exceptions

Exception | Condition
System..::..IndexOutOfRangeException | Thrown if index is smaller than zero or larger than the size of the collection

See Also

GH_Structure<(Of <(<'T>)>)> Class
DataItem Overload
Grasshopper.Kernel.Data Namespace


DataItem Property (GH_Path, Int32)

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..DataItem Property (GH_Path, Int32)
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Gets a direct pointer to a data item under a specific path and index.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public T this[
    GH_Path path,
    int index
] { get; }
Visual Basic
Public ReadOnly Property DataItem ( _
    path As GH_Path, _
    index As Integer _
) As T
    Get

Parameters

path
Type: Grasshopper.Kernel.Data..::..GH_Path
Path of the data branch to retrieve.
index
Type: System..::..Int32
Index of item to retrieve.

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_Structure`1.DataItem(Grasshopper.Kernel.Data.GH_Path,System.Int32)"]

Exceptions

Exception | Condition
System..::..NullReferenceException | Thrown if the path doesn't exist.
System..::..IndexOutOfRangeException | Thrown if the index does not exist within the path list.

See Also

GH_Structure<(Of <(<'T>)>)> Class
DataItem Overload
Grasshopper.Kernel.Data Namespace


DataList Property

[image] [image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..DataList Property
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public property | DataList[([( Int32])]) | Gets a direct pointer to the list of data under the specified index.
Public property | DataList[([( GH_Path])]) | Gets a direct pointer to the list of data under a specific path.

See Also

GH_Structure<(Of <(<'T>)>)> Class
GH_Structure<(Of <(<'T>)>)> Members
Grasshopper.Kernel.Data Namespace


DataList Property (Int32)

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..DataList Property (Int32)
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Gets a direct pointer to the list of data under the specified index.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<T> this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property DataList ( _
    index As Integer _
) As List(Of T)
    Get

Parameters

index
Type: System..::..Int32
Index of the data branch to retrieve.

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_Structure`1.DataList(System.Int32)"]

Exceptions

Exception | Condition
System..::..IndexOutOfRangeException | Thrown if the index does not represent a valid branch.

See Also

GH_Structure<(Of <(<'T>)>)> Class
DataList Overload
Grasshopper.Kernel.Data Namespace


DataList Property (GH_Path)

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..DataList Property (GH_Path)
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Gets a direct pointer to the list of data under a specific path.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<T> this[
    GH_Path path
] { get; }
Visual Basic
Public ReadOnly Default Property DataList ( _
    path As GH_Path _
) As List(Of T)
    Get

Parameters

path
Type: Grasshopper.Kernel.Data..::..GH_Path
Path of the data branch to retrieve. If the path doesn't exist, null is returned.

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_Structure`1.DataList(Grasshopper.Kernel.Data.GH_Path)"]

See Also

GH_Structure<(Of <(<'T>)>)> Class
DataList Overload
Grasshopper.Kernel.Data Namespace


FirstItem Property

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..FirstItem Property
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the first item in the structure. If no such item exists, null is returned.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public T this[
    bool filter_nulls
] { get; }
Visual Basic
Public ReadOnly Property FirstItem ( _
    filter_nulls As Boolean _
) As T
    Get

Parameters

filter_nulls
Type: System..::..Boolean
If True, nulls will be skipped.

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_Structure`1.FirstItem(System.Boolean)"]

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


IsEmpty Property

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..IsEmpty Property
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the Empty state of the structure. If the structure is Empty it contains no paths and no branches.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_Structure`1.IsEmpty"]

Implements

IGH_Structure..::..IsEmpty

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


LastItem Property

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..LastItem Property
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the last item in the structure. If no such item exists, null is returned.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public T this[
    bool filter_nulls
] { get; }
Visual Basic
Public ReadOnly Property LastItem ( _
    filter_nulls As Boolean _
) As T
    Get

Parameters

filter_nulls
Type: System..::..Boolean
If True, nulls will be skipped.

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_Structure`1.LastItem(System.Boolean)"]

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


NonNulls Property

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..NonNulls Property
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Get an enumerator for this structure that allow linear iteration over the data hierarchy while skipping all Null entries. This Enumerator has been optimized, do not cache instances of it.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IEnumerable<T> NonNulls { get; }
Visual Basic
Public ReadOnly Property NonNulls As IEnumerable(Of T)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_Structure`1.NonNulls"]

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


Path Property

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..Path Property
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the data path at the specified index.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Path this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property Path ( _
    index As Integer _
) As GH_Path
    Get

Parameters

index
Type: System..::..Int32
Index of path to retrieve.

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_Structure`1.Path(System.Int32)"]

Implements

IGH_Structure..::..Path[([( Int32])])

Exceptions

Exception | Condition
System..::..IndexOutOfRangeException | Thrown if the index does not represent a valid path.

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


PathCount Property

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..PathCount Property
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the number of paths defined in this structure.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int PathCount { get; }
Visual Basic
Public ReadOnly Property PathCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_Structure`1.PathCount"]

Implements

IGH_Structure..::..PathCount

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


Paths Property

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..Paths Property
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Gets a list of all the paths in this structure.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IList<GH_Path> Paths { get; }
Visual Basic
Public ReadOnly Property Paths As IList(Of GH_Path)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_Structure`1.Paths"]

Implements

IGH_Structure..::..Paths

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


StructureProxy Property

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..StructureProxy Property
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Gets a proxy list of all the data-arrays in this structure.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IList<IList> StructureProxy { get; }
Visual Basic
Public ReadOnly Property StructureProxy As IList(Of IList)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_Structure`1.StructureProxy"]

Implements

IGH_Structure..::..StructureProxy

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


TopologyDescription Property

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..TopologyDescription Property
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Gets a description of the topology of the structure. Useful for debugging purposes.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string TopologyDescription { get; }
Visual Basic
Public ReadOnly Property TopologyDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_Structure`1.TopologyDescription"]

Implements

IGH_Structure..::..TopologyDescription

See Also

GH_Structure<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Data Namespace


GH_Structure(T).ConversionDelegate(Tfrom, Tto) Delegate

[image]

Grasshopper SDK
GH_Structure<(Of <(<'T>)>)>..::..ConversionDelegate<(Of <(<'Tfrom, Tto>)>)> Delegate
GH_Structure<(Of <(<'T>)>)> Class See Also Send Feedback
Represents a conversion between two types of IGH_Goo.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate Tto ConversionDelegate<Tfrom, Tto>(
    Tfrom data
)
where Tfrom : IGH_Goo
where Tto : IGH_Goo
Visual Basic
Public Delegate Function ConversionDelegate(Of Tfrom As IGH_Goo, Tto As IGH_Goo) ( _
    data As Tfrom _
) As Tto

Parameters

data
Type: Tfrom
Data to convert.

Type Parameters

Tfrom
Type to convert from.
Tto
Type to convert to.

Return Value

Convered data.

See Also

Grasshopper.Kernel.Data Namespace


GH_TreeFilter Class

[image]

Grasshopper SDK
GH_TreeFilter Class
Members See Also Send Feedback
Represents a collection of rules for validating DataTree paths and indices.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_TreeFilter
Visual Basic
Public Class GH_TreeFilter

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Data..::..GH_TreeFilter

See Also

GH_TreeFilter Members
Grasshopper.Kernel.Data Namespace


GH_TreeFilter Members

[image] [image]

Grasshopper SDK
GH_TreeFilter Members
GH_TreeFilter Class Constructors Methods Fields See Also Send Feedback

The GH_TreeFilter type exposes the following members.

Constructors

 | Name | Description
Public method | GH_TreeFilter | Initializes a new instance of the GH_TreeFilter class

Methods

Name | Description
FindItemBrackets | Locate the two parenthesis that delineate the index segment of an Index Rule set.
FindNextLevelChar | Find the next occurance of a char in a string that is level with the search start index.
FindPathBrackets | Locate the two curly brackets that delineate the path segment of an Index Rule set.
FindPrevLevelChar | Find the previous occurance of a char in a string that is level with the search start index.
ParsePattern | Parses a textual filter and returns an instance of the GH_TreeFilter. If the filter cannot be parsed an exception will be thrown.
SplitStringWithExpressions | Split a string into segments using level-aware split. This method throws exceptions if the input string is not correctly formatted.

Fields

Name | Description
ItemClose |
ItemOpen |
PathClose |
PathOpen |
PathSeparator |
SegmentSeparator |
StringDelimeter |

See Also

GH_TreeFilter Class
Grasshopper.Kernel.Data Namespace


GH_TreeFilter Constructor

[image]

Grasshopper SDK
GH_TreeFilter Constructor
GH_TreeFilter Class See Also Send Feedback
Initializes a new instance of the GH_TreeFilter class

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_TreeFilter()
Visual Basic
Public Sub New

See Also

GH_TreeFilter Class
Grasshopper.Kernel.Data Namespace


GH_TreeFilter Fields

[image] [image]

Grasshopper SDK
GH_TreeFilter Fields
GH_TreeFilter Class See Also Send Feedback

The GH_TreeFilter type exposes the following members.

Fields

Name | Description
ItemClose |
ItemOpen |
PathClose |
PathOpen |
PathSeparator |
SegmentSeparator |
StringDelimeter |

See Also

GH_TreeFilter Class
Grasshopper.Kernel.Data Namespace


ItemClose Field

[image]

Grasshopper SDK
GH_TreeFilter..::..ItemClose Field
GH_TreeFilter Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const char ItemClose
Visual Basic
Public Const ItemClose As Char

See Also

GH_TreeFilter Class
Grasshopper.Kernel.Data Namespace


ItemOpen Field

[image]

Grasshopper SDK
GH_TreeFilter..::..ItemOpen Field
GH_TreeFilter Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const char ItemOpen
Visual Basic
Public Const ItemOpen As Char

See Also

GH_TreeFilter Class
Grasshopper.Kernel.Data Namespace


PathClose Field

[image]

Grasshopper SDK
GH_TreeFilter..::..PathClose Field
GH_TreeFilter Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const char PathClose
Visual Basic
Public Const PathClose As Char

See Also

GH_TreeFilter Class
Grasshopper.Kernel.Data Namespace


PathOpen Field

[image]

Grasshopper SDK
GH_TreeFilter..::..PathOpen Field
GH_TreeFilter Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const char PathOpen
Visual Basic
Public Const PathOpen As Char

See Also

GH_TreeFilter Class
Grasshopper.Kernel.Data Namespace


PathSeparator Field

[image]

Grasshopper SDK
GH_TreeFilter..::..PathSeparator Field
GH_TreeFilter Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const char PathSeparator
Visual Basic
Public Const PathSeparator As Char

See Also

GH_TreeFilter Class
Grasshopper.Kernel.Data Namespace


SegmentSeparator Field

[image]

Grasshopper SDK
GH_TreeFilter..::..SegmentSeparator Field
GH_TreeFilter Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const char SegmentSeparator
Visual Basic
Public Const SegmentSeparator As Char

See Also

GH_TreeFilter Class
Grasshopper.Kernel.Data Namespace


StringDelimeter Field

[image]

Grasshopper SDK
GH_TreeFilter..::..StringDelimeter Field
GH_TreeFilter Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public const char StringDelimeter
Visual Basic
Public Const StringDelimeter As Char

See Also

GH_TreeFilter Class
Grasshopper.Kernel.Data Namespace


GH_TreeFilter Methods

[image] [image]

Grasshopper SDK
GH_TreeFilter Methods
GH_TreeFilter Class See Also Send Feedback

The GH_TreeFilter type exposes the following members.

Methods

Name | Description
FindItemBrackets | Locate the two parenthesis that delineate the index segment of an Index Rule set.
FindNextLevelChar | Find the next occurance of a char in a string that is level with the search start index.
FindPathBrackets | Locate the two curly brackets that delineate the path segment of an Index Rule set.
FindPrevLevelChar | Find the previous occurance of a char in a string that is level with the search start index.
ParsePattern | Parses a textual filter and returns an instance of the GH_TreeFilter. If the filter cannot be parsed an exception will be thrown.
SplitStringWithExpressions | Split a string into segments using level-aware split. This method throws exceptions if the input string is not correctly formatted.

See Also

GH_TreeFilter Class
Grasshopper.Kernel.Data Namespace


FindItemBrackets Method

[image]

Grasshopper SDK
GH_TreeFilter..::..FindItemBrackets Method
GH_TreeFilter Class See Also Send Feedback
Locate the two parenthesis that delineate the index segment of an Index Rule set.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool FindItemBrackets(
    string text,
    out int index0,
    out int index1
)
Visual Basic
Public Shared Function FindItemBrackets ( _
    text As String, _
    <OutAttribute> ByRef index0 As Integer, _
    <OutAttribute> ByRef index1 As Integer _
) As Boolean

Parameters

text
Type: System..::..String
String to search.
index0
Type: System..::..Int32 %
Index of opening parenthesis.
index1
Type: System..::..Int32 %
Index of closing parenthesis.

Return Value

True if valid parenthesis were found, false if not.

See Also

GH_TreeFilter Class
Grasshopper.Kernel.Data Namespace


FindNextLevelChar Method

[image]

Grasshopper SDK
GH_TreeFilter..::..FindNextLevelChar Method
GH_TreeFilter Class See Also Send Feedback
Find the next occurance of a char in a string that is level with the search start index.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static int FindNextLevelChar(
    string text,
    int index,
    char char
)
Visual Basic
Public Shared Function FindNextLevelChar ( _
    text As String, _
    index As Integer, _
    char As Char _
) As Integer

Parameters

text
Type: System..::..String
String to search.
index
Type: System..::..Int32
Index to search from.
char
Type: System..::..Char
Char to match.

Return Value

The index of the first level character match or -1 if no such character could be found.

See Also

GH_TreeFilter Class
Grasshopper.Kernel.Data Namespace


FindPathBrackets Method

[image]

Grasshopper SDK
GH_TreeFilter..::..FindPathBrackets Method
GH_TreeFilter Class See Also Send Feedback
Locate the two curly brackets that delineate the path segment of an Index Rule set.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool FindPathBrackets(
    string text,
    out int index0,
    out int index1
)
Visual Basic
Public Shared Function FindPathBrackets ( _
    text As String, _
    <OutAttribute> ByRef index0 As Integer, _
    <OutAttribute> ByRef index1 As Integer _
) As Boolean

Parameters

text
Type: System..::..String
String to search.
index0
Type: System..::..Int32 %
Index of opening curly bracket.
index1
Type: System..::..Int32 %
Index of closing curly bracket.

Return Value

True if valid brackets were found, false if not.

See Also

GH_TreeFilter Class
Grasshopper.Kernel.Data Namespace


FindPrevLevelChar Method

[image]

Grasshopper SDK
GH_TreeFilter..::..FindPrevLevelChar Method
GH_TreeFilter Class See Also Send Feedback
Find the previous occurance of a char in a string that is level with the search start index.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static int FindPrevLevelChar(
    string text,
    int index,
    char char
)
Visual Basic
Public Shared Function FindPrevLevelChar ( _
    text As String, _
    index As Integer, _
    char As Char _
) As Integer

Parameters

text
Type: System..::..String
String to search.
index
Type: System..::..Int32
Index to search from.
char
Type: System..::..Char
Char to match.

Return Value

The index of the first level character match or -1 if no such character could be found.

See Also

GH_TreeFilter Class
Grasshopper.Kernel.Data Namespace


ParsePattern Method

[image]

Grasshopper SDK
GH_TreeFilter..::..ParsePattern Method
GH_TreeFilter Class See Also Send Feedback
Parses a textual filter and returns an instance of the GH_TreeFilter. If the filter cannot be parsed an exception will be thrown.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_TreeFilter ParsePattern(
    string filter
)
Visual Basic
Public Shared Function ParsePattern ( _
    filter As String _
) As GH_TreeFilter

Parameters

filter
Type: System..::..String
Filter to parse.

Return Value

An instance of GH_TreeFilter describing the textual filter.

See Also

GH_TreeFilter Class
Grasshopper.Kernel.Data Namespace


SplitStringWithExpressions Method

[image]

Grasshopper SDK
GH_TreeFilter..::..SplitStringWithExpressions Method
GH_TreeFilter Class See Also Send Feedback
Split a string into segments using level-aware split. This method throws exceptions if the input string is not correctly formatted.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static List<string> SplitStringWithExpressions(
    string text,
    char separator
)
Visual Basic
Public Shared Function SplitStringWithExpressions ( _
    text As String, _
    separator As Char _
) As List(Of String)

Parameters

text
Type: System..::..String
String to split.
separator
Type: System..::..Char
Splitting character.

Return Value

A list of string segments.

Exceptions

Exception | Condition
Grasshopper.Kernel.Data..::..GH_BracketMismatchException | Thrown when the opening and closing brackets don't add up.
Grasshopper.Kernel.Data..::..GH_StringMismatchException | Thrown when the string delimeter symbols don't add up.

See Also

GH_TreeFilter Class
Grasshopper.Kernel.Data Namespace


GH_TreeIndex Structure

[image]

Grasshopper SDK
GH_TreeIndex Structure
Members See Also Send Feedback
Represents a single unique location in a DataTree.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public struct GH_TreeIndex
Visual Basic
Public Structure GH_TreeIndex

See Also

GH_TreeIndex Members
Grasshopper.Kernel.Data Namespace


GH_TreeIndex Members

[image] [image]

Grasshopper SDK
GH_TreeIndex Members
GH_TreeIndex Structure Constructors Properties See Also Send Feedback

The GH_TreeIndex type exposes the following members.

Constructors

 | Name | Description
Public method | GH_TreeIndex | Create a new instance of the GH_TreeIndex structure with preset path and item index.

Properties

 | Name | Description
Public property | Item | Gets or sets the item index.
Public property | Path | Gets or sets the Path identifier.

See Also

GH_TreeIndex Structure
Grasshopper.Kernel.Data Namespace


GH_TreeIndex Constructor

[image]

Grasshopper SDK
GH_TreeIndex Constructor
GH_TreeIndex Structure See Also Send Feedback
Create a new instance of the GH_TreeIndex structure with preset path and item index.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_TreeIndex(
    GH_Path path,
    int item
)
Visual Basic
Public Sub New ( _
    path As GH_Path, _
    item As Integer _
)

Parameters

path
Type: Grasshopper.Kernel.Data..::..GH_Path
item
Type: System..::..Int32

See Also

GH_TreeIndex Structure
Grasshopper.Kernel.Data Namespace


GH_TreeIndex Properties

[image] [image]

Grasshopper SDK
GH_TreeIndex Properties
GH_TreeIndex Structure See Also Send Feedback

The GH_TreeIndex type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gets or sets the item index.
Public property | Path | Gets or sets the Path identifier.

See Also

GH_TreeIndex Structure
Grasshopper.Kernel.Data Namespace


Item Property

[image]

Grasshopper SDK
GH_TreeIndex..::..Item Property
GH_TreeIndex Structure See Also Send Feedback
Gets or sets the item index.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int Item { get; set; }
Visual Basic
Public Property Item As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_TreeIndex.Item"]

See Also

GH_TreeIndex Structure
Grasshopper.Kernel.Data Namespace


Path Property

[image]

Grasshopper SDK
GH_TreeIndex..::..Path Property
GH_TreeIndex Structure See Also Send Feedback
Gets or sets the Path identifier.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Path Path { get; set; }
Visual Basic
Public Property Path As GH_Path
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_TreeIndex.Path"]

See Also

GH_TreeIndex Structure
Grasshopper.Kernel.Data Namespace


IGH_DataTree Interface

[image]

Grasshopper SDK
IGH_DataTree Interface
Members See Also Send Feedback
Utility interface for detection of DataTree generic instances.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_DataTree
Visual Basic
Public Interface IGH_DataTree

See Also

IGH_DataTree Members
Grasshopper.Kernel.Data Namespace


IGH_DataTree Members

[image] [image]

Grasshopper SDK
IGH_DataTree Members
IGH_DataTree Interface Methods See Also Send Feedback

The IGH_DataTree type exposes the following members.

Methods

 | Name | Description
Public method | MergeWithParameter | Utility function for assigning Script Data Trees to parameters.

See Also

IGH_DataTree Interface
Grasshopper.Kernel.Data Namespace


IGH_DataTree Methods

[image] [image]

Grasshopper SDK
IGH_DataTree Methods
IGH_DataTree Interface See Also Send Feedback

The IGH_DataTree type exposes the following members.

Methods

 | Name | Description
Public method | MergeWithParameter | Utility function for assigning Script Data Trees to parameters.

See Also

IGH_DataTree Interface
Grasshopper.Kernel.Data Namespace


MergeWithParameter Method

[image]

Grasshopper SDK
IGH_DataTree..::..MergeWithParameter Method
IGH_DataTree Interface See Also Send Feedback
Utility function for assigning Script Data Trees to parameters.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool MergeWithParameter(
    IGH_Param param
)
Visual Basic
Function MergeWithParameter ( _
    param As IGH_Param _
) As Boolean

Parameters

param
Type: Grasshopper.Kernel..::..IGH_Param
Parameter to merge with.

See Also

IGH_DataTree Interface
Grasshopper.Kernel.Data Namespace


IGH_IndexRule Interface

[image]

Grasshopper SDK
IGH_IndexRule Interface
Members See Also Send Feedback
Interface for index rules. An index rule is a way to determine whether a specific integer is considered valid, invalid or neutral. Index rules are used for selecting elements in DataTrees.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_IndexRule
Visual Basic
Public Interface IGH_IndexRule

See Also

IGH_IndexRule Members
Grasshopper.Kernel.Data Namespace


IGH_IndexRule Members

[image] [image]

Grasshopper SDK
IGH_IndexRule Members
IGH_IndexRule Interface Methods See Also Send Feedback

The IGH_IndexRule type exposes the following members.

Methods

 | Name | Description
Public method | Evaluate |

See Also

IGH_IndexRule Interface
Grasshopper.Kernel.Data Namespace


IGH_IndexRule Methods

[image] [image]

Grasshopper SDK
IGH_IndexRule Methods
IGH_IndexRule Interface See Also Send Feedback

The IGH_IndexRule type exposes the following members.

Methods

 | Name | Description
Public method | Evaluate |

See Also

IGH_IndexRule Interface
Grasshopper.Kernel.Data Namespace


Evaluate Method

[image]

Grasshopper SDK
IGH_IndexRule..::..Evaluate Method
IGH_IndexRule Interface See Also Send Feedback

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
GH_RuleResult Evaluate(
    int index
)
Visual Basic
Function Evaluate ( _
    index As Integer _
) As GH_RuleResult

Parameters

index
Type: System..::..Int32

See Also

IGH_IndexRule Interface
Grasshopper.Kernel.Data Namespace


IGH_Structure Interface

[image]

Grasshopper SDK
IGH_Structure Interface
Members See Also Send Feedback
Base interface for all GH_Structure types.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_Structure
Visual Basic
Public Interface IGH_Structure

See Also

IGH_Structure Members
Grasshopper.Kernel.Data Namespace


IGH_Structure Members

[image] [image]

Grasshopper SDK
IGH_Structure Members
IGH_Structure Interface Methods Properties See Also Send Feedback

The IGH_Structure type exposes the following members.

Methods

 | Name | Description
Public method | AllData | Gets an enumerator for all the data items in this structure.
Public method | Clear | Clears the entire structure.
Public method | ClearData | Removes all data from all paths without affecting the structure topology.
Public method | DataDescription | Gets a description of the data contained in this structure.
Public method | EnsureCapacity | Ensures that all branches have a certain capacity
Public method | ExpandPath | Expand a path in this structure by appending an element.
Public method | Flatten | Flattens the entire structure into a single path.
Public method | Graft(Boolean) | Obsolete. Grafts all paths by reallocating all data into child paths.
Public method | Graft(GH_GraftMode) | Grafts all paths by reallocating all data into child paths.
Public method | Graft(GH_GraftMode, GH_Path) | Grafts a specific path by reallocating all data into child paths. If a grafted path coincides with an existing path, the data item in question will be appended to the existing path.
Public method | Graft(GH_Path, Boolean) | Obsolete. Grafts a specific path by reallocating all data into child paths. If a grafted path coincides with an existing path, the data item in question will be appended to the existing path.
Public method | LongestPathIndex | Finds the path in this structure with the most dimensions. In case of multiple equally long longest paths, the last one will be returned.
Public method | PathExists | Returns True if the specified path is already defined inside the structure.
Public method | PathIndex | Find the indices that delineate the given path domain.
Public method | RemovePath | Removes a path and all associated data from the structure. If the path doesn't exist, nothing will happen.
Public method | ReplacePath | Replace an existing path with a different one. If the operation is successfull, then the 'find' path will be deleted. If the 'replace' path is already defined, the items in 'find' will be appended to the existing path.
Public method | ShortestPathIndex | Finds the path in this structure with the least dimensions. In case of multiple equally long longest paths, the first one will be returned.
Public method | Simplify | Simplify the data structure by removing path indices shared by all branches.
Public method | TrimExcess | Trims the excess allocated memory in all branches

Properties

 | Name | Description
Public property | Branch[([( Int32])]) | Gets a limited access pointer to the data list at the specified index.
Public property | Branch[([( GH_Path])]) | Gets a limited access pointer to the data list associated with a certain path.
Public property | DataCount | Gets the total number of data items stored in all paths.
Public property | IsEmpty | Gets the Empty state of the structure. If the structure is Empty when it contains no paths and no branches.
Public property | Path | Gets the data path at the specified index.
Public property | PathCount | Gets the number of paths defined in this structure.
Public property | Paths | Gets a list of all the paths in this structure.
Public property | StructureProxy | Gets a proxy list of all the data-arrays in this structure
Public property | TopologyDescription | Gets a description of the topology of the structure. Useful for debugging purposes.

See Also

IGH_Structure Interface
Grasshopper.Kernel.Data Namespace


IGH_Structure Methods

[image] [image]

Grasshopper SDK
IGH_Structure Methods
IGH_Structure Interface See Also Send Feedback

The IGH_Structure type exposes the following members.

Methods

 | Name | Description
Public method | AllData | Gets an enumerator for all the data items in this structure.
Public method | Clear | Clears the entire structure.
Public method | ClearData | Removes all data from all paths without affecting the structure topology.
Public method | DataDescription | Gets a description of the data contained in this structure.
Public method | EnsureCapacity | Ensures that all branches have a certain capacity
Public method | ExpandPath | Expand a path in this structure by appending an element.
Public method | Flatten | Flattens the entire structure into a single path.
Public method | Graft(Boolean) | Obsolete. Grafts all paths by reallocating all data into child paths.
Public method | Graft(GH_GraftMode) | Grafts all paths by reallocating all data into child paths.
Public method | Graft(GH_GraftMode, GH_Path) | Grafts a specific path by reallocating all data into child paths. If a grafted path coincides with an existing path, the data item in question will be appended to the existing path.
Public method | Graft(GH_Path, Boolean) | Obsolete. Grafts a specific path by reallocating all data into child paths. If a grafted path coincides with an existing path, the data item in question will be appended to the existing path.
Public method | LongestPathIndex | Finds the path in this structure with the most dimensions. In case of multiple equally long longest paths, the last one will be returned.
Public method | PathExists | Returns True if the specified path is already defined inside the structure.
Public method | PathIndex | Find the indices that delineate the given path domain.
Public method | RemovePath | Removes a path and all associated data from the structure. If the path doesn't exist, nothing will happen.
Public method | ReplacePath | Replace an existing path with a different one. If the operation is successfull, then the 'find' path will be deleted. If the 'replace' path is already defined, the items in 'find' will be appended to the existing path.
Public method | ShortestPathIndex | Finds the path in this structure with the least dimensions. In case of multiple equally long longest paths, the first one will be returned.
Public method | Simplify | Simplify the data structure by removing path indices shared by all branches.
Public method | TrimExcess | Trims the excess allocated memory in all branches

See Also

IGH_Structure Interface
Grasshopper.Kernel.Data Namespace


AllData Method

[image]

Grasshopper SDK
IGH_Structure..::..AllData Method
IGH_Structure Interface See Also Send Feedback
Gets an enumerator for all the data items in this structure.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
IGH_StructureEnumerator AllData(
    bool skipNulls
)
Visual Basic
Function AllData ( _
    skipNulls As Boolean _
) As IGH_StructureEnumerator

Parameters

skipNulls
Type: System..::..Boolean
If True, null items will be skipped.

See Also

IGH_Structure Interface
Grasshopper.Kernel.Data Namespace


Clear Method

[image]

Grasshopper SDK
IGH_Structure..::..Clear Method
IGH_Structure Interface See Also Send Feedback
Clears the entire structure.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void Clear()
Visual Basic
Sub Clear

See Also

IGH_Structure Interface
Grasshopper.Kernel.Data Namespace


ClearData Method

[image]

Grasshopper SDK
IGH_Structure..::..ClearData Method
IGH_Structure Interface See Also Send Feedback
Removes all data from all paths without affecting the structure topology.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void ClearData()
Visual Basic
Sub ClearData

See Also

IGH_Structure Interface
Grasshopper.Kernel.Data Namespace


DataDescription Method

[image]

Grasshopper SDK
IGH_Structure..::..DataDescription Method
IGH_Structure Interface See Also Send Feedback
Gets a description of the data contained in this structure.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string DataDescription(
    bool includeIndices,
    bool includePaths
)
Visual Basic
Function DataDescription ( _
    includeIndices As Boolean, _
    includePaths As Boolean _
) As String

Parameters

includeIndices
Type: System..::..Boolean
If true, every data item will be prefixed by its index.
includePaths
Type: System..::..Boolean
If true, every branch of data will be preceded by the path.

Return Value

A string describing the data.

See Also

IGH_Structure Interface
Grasshopper.Kernel.Data Namespace


EnsureCapacity Method

[image]

Grasshopper SDK
IGH_Structure..::..EnsureCapacity Method
IGH_Structure Interface See Also Send Feedback
Ensures that all branches have a certain capacity

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void EnsureCapacity(
    int capacity
)
Visual Basic
Sub EnsureCapacity ( _
    capacity As Integer _
)

Parameters

capacity
Type: System..::..Int32
Capacity per branch.

See Also

IGH_Structure Interface
Grasshopper.Kernel.Data Namespace


ExpandPath Method

[image]

Grasshopper SDK
IGH_Structure..::..ExpandPath Method
IGH_Structure Interface See Also Send Feedback
Expand a path in this structure by appending an element.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void ExpandPath(
    GH_Path path,
    int element,
    GH_ExpandMode mode
)
Visual Basic
Sub ExpandPath ( _
    path As GH_Path, _
    element As Integer, _
    mode As GH_ExpandMode _
)

Parameters

path
Type: Grasshopper.Kernel.Data..::..GH_Path
Path to expand, if the path doesn't exist, nothing will happen.
element
Type: System..::..Int32
Element to append to the path.
mode
Type: Grasshopper.Kernel.Data..::..GH_ExpandMode
Expansion mode.

See Also

IGH_Structure Interface
Grasshopper.Kernel.Data Namespace


Flatten Method

[image]

Grasshopper SDK
IGH_Structure..::..Flatten Method
IGH_Structure Interface See Also Send Feedback
Flattens the entire structure into a single path.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void Flatten(
    GH_Path path
)
Visual Basic
Sub Flatten ( _
    path As GH_Path _
)

Parameters

path
Type: Grasshopper.Kernel.Data..::..GH_Path
The path of the flattened data. If null, the path will be {0}

See Also

IGH_Structure Interface
Grasshopper.Kernel.Data Namespace


Graft Method

[image] [image]

Grasshopper SDK
IGH_Structure..::..Graft Method
IGH_Structure Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | Graft(Boolean) | Obsolete. Grafts all paths by reallocating all data into child paths.
Public method | Graft(GH_GraftMode) | Grafts all paths by reallocating all data into child paths.
Public method | Graft(GH_GraftMode, GH_Path) | Grafts a specific path by reallocating all data into child paths. If a grafted path coincides with an existing path, the data item in question will be appended to the existing path.
Public method | Graft(GH_Path, Boolean) | Obsolete. Grafts a specific path by reallocating all data into child paths. If a grafted path coincides with an existing path, the data item in question will be appended to the existing path.

See Also

IGH_Structure Interface
IGH_Structure Members
Grasshopper.Kernel.Data Namespace


Graft Method (Boolean)

[image]

Grasshopper SDK
IGH_Structure..::..Graft Method (Boolean)
IGH_Structure Interface See Also Send Feedback
Grafts all paths by reallocating all data into child paths.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
[ObsoleteAttribute("this method has been replaced by Graft(GH_GraftMode)")]
void Graft(
    bool clearSingleNulls
)
Visual Basic
<ObsoleteAttribute("this method has been replaced by Graft(GH_GraftMode)")> _
Sub Graft ( _
    clearSingleNulls As Boolean _
)

Parameters

clearSingleNulls
Type: System..::..Boolean
If true, nulls will not be grafted.

See Also

IGH_Structure Interface
Graft Overload
Grasshopper.Kernel.Data Namespace


Graft Method (GH_GraftMode)

[image]

Grasshopper SDK
IGH_Structure..::..Graft Method (GH_GraftMode)
IGH_Structure Interface See Also Send Feedback
Grafts all paths by reallocating all data into child paths.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void Graft(
    GH_GraftMode mode
)
Visual Basic
Sub Graft ( _
    mode As GH_GraftMode _
)

Parameters

mode
Type: Grasshopper.Kernel.Data..::..GH_GraftMode
Graft mode.

See Also

IGH_Structure Interface
Graft Overload
Grasshopper.Kernel.Data Namespace


Graft Method (GH_GraftMode, GH_Path)

[image]

Grasshopper SDK
IGH_Structure..::..Graft Method (GH_GraftMode, GH_Path)
IGH_Structure Interface See Also Send Feedback
Grafts a specific path by reallocating all data into child paths. If a grafted path coincides with an existing path, the data item in question will be appended to the existing path.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void Graft(
    GH_GraftMode mode,
    GH_Path path
)
Visual Basic
Sub Graft ( _
    mode As GH_GraftMode, _
    path As GH_Path _
)

Parameters

mode
Type: Grasshopper.Kernel.Data..::..GH_GraftMode
Graft mode.
path
Type: Grasshopper.Kernel.Data..::..GH_Path
Path to graft

See Also

IGH_Structure Interface
Graft Overload
Grasshopper.Kernel.Data Namespace


Graft Method (GH_Path, Boolean)

[image]

Grasshopper SDK
IGH_Structure..::..Graft Method (GH_Path, Boolean)
IGH_Structure Interface See Also Send Feedback
Grafts a specific path by reallocating all data into child paths. If a grafted path coincides with an existing path, the data item in question will be appended to the existing path.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
[ObsoleteAttribute("this method has been replaced by Graft(GH_GraftMode, GH_Path)")]
void Graft(
    GH_Path path,
    bool clearSingleNulls
)
Visual Basic
<ObsoleteAttribute("this method has been replaced by Graft(GH_GraftMode, GH_Path)")> _
Sub Graft ( _
    path As GH_Path, _
    clearSingleNulls As Boolean _
)

Parameters

path
Type: Grasshopper.Kernel.Data..::..GH_Path
Path of data to graft.
clearSingleNulls
Type: System..::..Boolean
If true, nulls will not be grafted.

See Also

IGH_Structure Interface
Graft Overload
Grasshopper.Kernel.Data Namespace


LongestPathIndex Method

[image]

Grasshopper SDK
IGH_Structure..::..LongestPathIndex Method
IGH_Structure Interface See Also Send Feedback
Finds the path in this structure with the most dimensions. In case of multiple equally long longest paths, the last one will be returned.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
int LongestPathIndex()
Visual Basic
Function LongestPathIndex As Integer

Return Value

The index of the longest path or -1 if there are no paths.

See Also

IGH_Structure Interface
Grasshopper.Kernel.Data Namespace


PathExists Method

[image]

Grasshopper SDK
IGH_Structure..::..PathExists Method
IGH_Structure Interface See Also Send Feedback
Returns True if the specified path is already defined inside the structure.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool PathExists(
    GH_Path path
)
Visual Basic
Function PathExists ( _
    path As GH_Path _
) As Boolean

Parameters

path
Type: Grasshopper.Kernel.Data..::..GH_Path
The data path to search for

See Also

IGH_Structure Interface
Grasshopper.Kernel.Data Namespace


PathIndex Method

[image]

Grasshopper SDK
IGH_Structure..::..PathIndex Method
IGH_Structure Interface See Also Send Feedback
Find the indices that delineate the given path domain.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void PathIndex(
    GH_Path path,
    ref int idx0,
    ref int idx1
)
Visual Basic
Sub PathIndex ( _
    path As GH_Path, _
    ByRef idx0 As Integer, _
    ByRef idx1 As Integer _
)

Parameters

path
Type: Grasshopper.Kernel.Data..::..GH_Path
Path to search for (it need not exist in the structure).
idx0
Type: System..::..Int32 %
The index of the path itself or the first smaller path if the path is not defined.
idx1
Type: System..::..Int32 %
The index of the path itself of the first larger path if the path is not defined.

See Also

IGH_Structure Interface
Grasshopper.Kernel.Data Namespace


RemovePath Method

[image]

Grasshopper SDK
IGH_Structure..::..RemovePath Method
IGH_Structure Interface See Also Send Feedback
Removes a path and all associated data from the structure. If the path doesn't exist, nothing will happen.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void RemovePath(
    GH_Path path
)
Visual Basic
Sub RemovePath ( _
    path As GH_Path _
)

Parameters

path
Type: Grasshopper.Kernel.Data..::..GH_Path
Path the remove.

See Also

IGH_Structure Interface
Grasshopper.Kernel.Data Namespace


ReplacePath Method

[image]

Grasshopper SDK
IGH_Structure..::..ReplacePath Method
IGH_Structure Interface See Also Send Feedback
Replace an existing path with a different one. If the operation is successfull, then the 'find' path will be deleted. If the 'replace' path is already defined, the items in 'find' will be appended to the existing path.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void ReplacePath(
    GH_Path find,
    GH_Path replace
)
Visual Basic
Sub ReplacePath ( _
    find As GH_Path, _
    replace As GH_Path _
)

Parameters

find
Type: Grasshopper.Kernel.Data..::..GH_Path
The path to search for.
replace
Type: Grasshopper.Kernel.Data..::..GH_Path
The new path.

See Also

IGH_Structure Interface
Grasshopper.Kernel.Data Namespace


ShortestPathIndex Method

[image]

Grasshopper SDK
IGH_Structure..::..ShortestPathIndex Method
IGH_Structure Interface See Also Send Feedback
Finds the path in this structure with the least dimensions. In case of multiple equally long longest paths, the first one will be returned.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
int ShortestPathIndex()
Visual Basic
Function ShortestPathIndex As Integer

Return Value

The index of the shortest path or -1 if there are no paths.

See Also

IGH_Structure Interface
Grasshopper.Kernel.Data Namespace


Simplify Method

[image]

Grasshopper SDK
IGH_Structure..::..Simplify Method
IGH_Structure Interface See Also Send Feedback
Simplify the data structure by removing path indices shared by all branches.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void Simplify(
    GH_SimplificationMode mode
)
Visual Basic
Sub Simplify ( _
    mode As GH_SimplificationMode _
)

Parameters

mode
Type: Grasshopper.Kernel.Data..::..GH_SimplificationMode
Simplification algorithm to use.

See Also

IGH_Structure Interface
Grasshopper.Kernel.Data Namespace


TrimExcess Method

[image]

Grasshopper SDK
IGH_Structure..::..TrimExcess Method
IGH_Structure Interface See Also Send Feedback
Trims the excess allocated memory in all branches

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void TrimExcess()
Visual Basic
Sub TrimExcess

See Also

IGH_Structure Interface
Grasshopper.Kernel.Data Namespace


IGH_Structure Properties

[image] [image]

Grasshopper SDK
IGH_Structure Properties
IGH_Structure Interface See Also Send Feedback

The IGH_Structure type exposes the following members.

Properties

 | Name | Description
Public property | Branch[([( Int32])]) | Gets a limited access pointer to the data list at the specified index.
Public property | Branch[([( GH_Path])]) | Gets a limited access pointer to the data list associated with a certain path.
Public property | DataCount | Gets the total number of data items stored in all paths.
Public property | IsEmpty | Gets the Empty state of the structure. If the structure is Empty when it contains no paths and no branches.
Public property | Path | Gets the data path at the specified index.
Public property | PathCount | Gets the number of paths defined in this structure.
Public property | Paths | Gets a list of all the paths in this structure.
Public property | StructureProxy | Gets a proxy list of all the data-arrays in this structure
Public property | TopologyDescription | Gets a description of the topology of the structure. Useful for debugging purposes.

See Also

IGH_Structure Interface
Grasshopper.Kernel.Data Namespace


Branch Property

[image] [image]

Grasshopper SDK
IGH_Structure..::..Branch Property
IGH_Structure Interface See Also Send Feedback

Overload List

 | Name | Description
Public property | Branch[([( Int32])]) | Gets a limited access pointer to the data list at the specified index.
Public property | Branch[([( GH_Path])]) | Gets a limited access pointer to the data list associated with a certain path.

See Also

IGH_Structure Interface
IGH_Structure Members
Grasshopper.Kernel.Data Namespace


Branch Property (Int32)

[image]

Grasshopper SDK
IGH_Structure..::..Branch Property (Int32)
IGH_Structure Interface See Also Send Feedback
Gets a limited access pointer to the data list at the specified index.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
IList this[
    int index
] { get; }
Visual Basic
ReadOnly Property Branch ( _
    index As Integer _
) As IList
    Get

Parameters

index
Type: System..::..Int32
Index of data to retrieve.

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.IGH_Structure.Branch(System.Int32)"]

See Also

IGH_Structure Interface
Branch Overload
Grasshopper.Kernel.Data Namespace


Branch Property (GH_Path)

[image]

Grasshopper SDK
IGH_Structure..::..Branch Property (GH_Path)
IGH_Structure Interface See Also Send Feedback
Gets a limited access pointer to the data list associated with a certain path.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
IList this[
    GH_Path path
] { get; }
Visual Basic
ReadOnly Property Branch ( _
    path As GH_Path _
) As IList
    Get

Parameters

path
Type: Grasshopper.Kernel.Data..::..GH_Path
Path of data to retrieve.

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.IGH_Structure.Branch(Grasshopper.Kernel.Data.GH_Path)"]

See Also

IGH_Structure Interface
Branch Overload
Grasshopper.Kernel.Data Namespace


DataCount Property

[image]

Grasshopper SDK
IGH_Structure..::..DataCount Property
IGH_Structure Interface See Also Send Feedback
Gets the total number of data items stored in all paths.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
int DataCount { get; }
Visual Basic
ReadOnly Property DataCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.IGH_Structure.DataCount"]

See Also

IGH_Structure Interface
Grasshopper.Kernel.Data Namespace


IsEmpty Property

[image]

Grasshopper SDK
IGH_Structure..::..IsEmpty Property
IGH_Structure Interface See Also Send Feedback
Gets the Empty state of the structure. If the structure is Empty when it contains no paths and no branches.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool IsEmpty { get; }
Visual Basic
ReadOnly Property IsEmpty As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.IGH_Structure.IsEmpty"]

See Also

IGH_Structure Interface
Grasshopper.Kernel.Data Namespace


Path Property

[image]

Grasshopper SDK
IGH_Structure..::..Path Property
IGH_Structure Interface See Also Send Feedback
Gets the data path at the specified index.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
GH_Path this[
    int index
] { get; }
Visual Basic
ReadOnly Property Path ( _
    index As Integer _
) As GH_Path
    Get

Parameters

index
Type: System..::..Int32
Index of path to retrieve.

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.IGH_Structure.Path(System.Int32)"]

Exceptions

Exception | Condition
System..::..IndexOutOfRangeException | Thrown if the index does not represent a valid path.

See Also

IGH_Structure Interface
Grasshopper.Kernel.Data Namespace


PathCount Property

[image]

Grasshopper SDK
IGH_Structure..::..PathCount Property
IGH_Structure Interface See Also Send Feedback
Gets the number of paths defined in this structure.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
int PathCount { get; }
Visual Basic
ReadOnly Property PathCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.IGH_Structure.PathCount"]

See Also

IGH_Structure Interface
Grasshopper.Kernel.Data Namespace


Paths Property

[image]

Grasshopper SDK
IGH_Structure..::..Paths Property
IGH_Structure Interface See Also Send Feedback
Gets a list of all the paths in this structure.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
IList<GH_Path> Paths { get; }
Visual Basic
ReadOnly Property Paths As IList(Of GH_Path)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.IGH_Structure.Paths"]

See Also

IGH_Structure Interface
Grasshopper.Kernel.Data Namespace


StructureProxy Property

[image]

Grasshopper SDK
IGH_Structure..::..StructureProxy Property
IGH_Structure Interface See Also Send Feedback
Gets a proxy list of all the data-arrays in this structure

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
IList<IList> StructureProxy { get; }
Visual Basic
ReadOnly Property StructureProxy As IList(Of IList)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.IGH_Structure.StructureProxy"]

See Also

IGH_Structure Interface
Grasshopper.Kernel.Data Namespace


TopologyDescription Property

[image]

Grasshopper SDK
IGH_Structure..::..TopologyDescription Property
IGH_Structure Interface See Also Send Feedback
Gets a description of the topology of the structure. Useful for debugging purposes.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string TopologyDescription { get; }
Visual Basic
ReadOnly Property TopologyDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.IGH_Structure.TopologyDescription"]

See Also

IGH_Structure Interface
Grasshopper.Kernel.Data Namespace


IGH_StructureEnumerator Interface

[image]

Grasshopper SDK
IGH_StructureEnumerator Interface
See Also Send Feedback
Defines a minimum interface for iterating over all data in an IGH_Structure.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_StructureEnumerator : IEnumerable<IGH_Goo>
Visual Basic
Public Interface IGH_StructureEnumerator _
    Inherits IEnumerable(Of IGH_Goo)

See Also

Grasshopper.Kernel.Data Namespace


Grasshopper.Kernel.Expressions Namespace

[image]

Grasshopper SDK
Grasshopper.Kernel.Expressions Namespace
Send Feedback
Namespace which contains all classes needed to evaluate Grasshopper expressions.

Classes

 | Class | Description
Public class | GH_CodeString |
Public class | GH_CodeStringSegment |
Public class | GH_ExpressionParser | Provides a run-time evaluator for Grasshopper expressions.
Public class | GH_ExpressionString |
Public class | GH_ExpressionSyntaxWriter |
Public class | GH_ParserOperator |
Public class | GH_ParserSymbol |
Public class | GH_ScriptVariant |
Public class | GH_SignatureException |
Public class | GH_SolverException |
Public class | GH_SyntaxException |
Public class | GH_Variant | Variant data used in Grasshopper Expressions.

Enumerations

 | Enumeration | Description
Public enumeration | GH_CharType |
Public enumeration | GH_OperatorType |
Public enumeration | GH_ParserPrecedence |
Public enumeration | GH_ParserTokenClass |
Public enumeration | GH_ScriptVariantType |
Public enumeration | GH_VariantType | Lists all possible variable types supported in the Grasshopper Expression Parser.


GH_CharType Enumeration

[image]

Grasshopper SDK
GH_CharType Enumeration
See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_CharType
Visual Basic
Public Enumeration GH_CharType

Members

Member name | Value | Description
undefined | 0 |
whitespace | 1 |
dot | 2 |
comma | 3 |
colon | 4 |
semicolon | 5 |
continuation | 6 |
newline | 7 |
operator | 20 |
parenthesis_open | 21 |
parenthesis_close | 22 |
bracket_open | 23 |
bracket_close | 24 |
stringstart | 50 |
stringend | 51 |
stringbody | 52 |
commentstart | 60 |
commentend | 61 |
commentbody | 62 |

See Also

Grasshopper.Kernel.Expressions Namespace


GH_CodeString Class

[image]

Grasshopper SDK
GH_CodeString Class
Members See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_CodeString
Visual Basic
Public Class GH_CodeString

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Expressions..::..GH_CodeString

See Also

GH_CodeString Members
Grasshopper.Kernel.Expressions Namespace


GH_CodeString Members

[image] [image]

Grasshopper SDK
GH_CodeString Members
GH_CodeString Class Constructors Methods Fields Properties See Also Send Feedback

The GH_CodeString type exposes the following members.

Constructors

 | Name | Description
Public method | GH_CodeString | Initializes a new instance of the GH_CodeString class

Methods

 | Name | Description
Public method | Flatten |
Public method | ParseNewString |
Public method | Replace |
Public method | ReplaceToken |

Fields

 | Name | Description
 | DoubleQuote |
Protected field | m_Segments |

Properties

 | Name | Description
Public property | Segments |

See Also

GH_CodeString Class
Grasshopper.Kernel.Expressions Namespace


GH_CodeString Constructor

[image]

Grasshopper SDK
GH_CodeString Constructor
GH_CodeString Class See Also Send Feedback
Initializes a new instance of the GH_CodeString class

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_CodeString(
    string input
)
Visual Basic
Public Sub New ( _
    input As String _
)

Parameters

input
Type: System..::..String

See Also

GH_CodeString Class
Grasshopper.Kernel.Expressions Namespace


GH_CodeString Fields

[image] [image]

Grasshopper SDK
GH_CodeString Fields
GH_CodeString Class See Also Send Feedback

The GH_CodeString type exposes the following members.

Fields

 | Name | Description
 | DoubleQuote |
Protected field | m_Segments |

See Also

GH_CodeString Class
Grasshopper.Kernel.Expressions Namespace


DoubleQuote Field

[image]

Grasshopper SDK
GH_CodeString..::..DoubleQuote Field
GH_CodeString Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected const char DoubleQuote
Visual Basic
Protected Const DoubleQuote As Char

See Also

GH_CodeString Class
Grasshopper.Kernel.Expressions Namespace


m_Segments Field

[image]

Grasshopper SDK
GH_CodeString..::..m_Segments Field
GH_CodeString Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected List<GH_CodeStringSegment> m_Segments
Visual Basic
Protected m_Segments As List(Of GH_CodeStringSegment)

See Also

GH_CodeString Class
Grasshopper.Kernel.Expressions Namespace


GH_CodeString Methods

[image] [image]

Grasshopper SDK
GH_CodeString Methods
GH_CodeString Class See Also Send Feedback

The GH_CodeString type exposes the following members.

Methods

 | Name | Description
Public method | Flatten |
Public method | ParseNewString |
Public method | Replace |
Public method | ReplaceToken |

See Also

GH_CodeString Class
Grasshopper.Kernel.Expressions Namespace


Flatten Method

[image]

Grasshopper SDK
GH_CodeString..::..Flatten Method
GH_CodeString Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Flatten()
Visual Basic
Public Function Flatten As String

See Also

GH_CodeString Class
Grasshopper.Kernel.Expressions Namespace


ParseNewString Method

[image]

Grasshopper SDK
GH_CodeString..::..ParseNewString Method
GH_CodeString Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ParseNewString(
    string input
)
Visual Basic
Public Sub ParseNewString ( _
    input As String _
)

Parameters

input
Type: System..::..String

See Also

GH_CodeString Class
Grasshopper.Kernel.Expressions Namespace


Replace Method

[image]

Grasshopper SDK
GH_CodeString..::..Replace Method
GH_CodeString Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Replace(
    string search,
    string replace,
    bool bIgnoreCase,
    bool bOmitNonCode
)
Visual Basic
Public Sub Replace ( _
    search As String, _
    replace As String, _
    bIgnoreCase As Boolean, _
    bOmitNonCode As Boolean _
)

Parameters

search
Type: System..::..String
replace
Type: System..::..String
bIgnoreCase
Type: System..::..Boolean
bOmitNonCode
Type: System..::..Boolean

See Also

GH_CodeString Class
Grasshopper.Kernel.Expressions Namespace


ReplaceToken Method

[image]

Grasshopper SDK
GH_CodeString..::..ReplaceToken Method
GH_CodeString Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ReplaceToken(
    string search,
    string replace,
    bool bIgnoreCase,
    bool bOmitNonCode
)
Visual Basic
Public Sub ReplaceToken ( _
    search As String, _
    replace As String, _
    bIgnoreCase As Boolean, _
    bOmitNonCode As Boolean _
)

Parameters

search
Type: System..::..String
replace
Type: System..::..String
bIgnoreCase
Type: System..::..Boolean
bOmitNonCode
Type: System..::..Boolean

See Also

GH_CodeString Class
Grasshopper.Kernel.Expressions Namespace


GH_CodeString Properties

[image] [image]

Grasshopper SDK
GH_CodeString Properties
GH_CodeString Class See Also Send Feedback

The GH_CodeString type exposes the following members.

Properties

 | Name | Description
Public property | Segments |

See Also

GH_CodeString Class
Grasshopper.Kernel.Expressions Namespace


Segments Property

[image]

Grasshopper SDK
GH_CodeString..::..Segments Property
GH_CodeString Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<GH_CodeStringSegment> Segments { get; }
Visual Basic
Public ReadOnly Property Segments As List(Of GH_CodeStringSegment)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Expressions.GH_CodeString.Segments"]

See Also

GH_CodeString Class
Grasshopper.Kernel.Expressions Namespace


GH_CodeStringSegment Class

[image]

Grasshopper SDK
GH_CodeStringSegment Class
Members See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_CodeStringSegment
Visual Basic
Public Class GH_CodeStringSegment

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Expressions..::..GH_CodeStringSegment

See Also

GH_CodeStringSegment Members
Grasshopper.Kernel.Expressions Namespace


GH_CodeStringSegment Members

[image] [image]

Grasshopper SDK
GH_CodeStringSegment Members
GH_CodeStringSegment Class Constructors Methods Fields Properties See Also Send Feedback

The GH_CodeStringSegment type exposes the following members.

Constructors

 | Name | Description
Public method | GH_CodeStringSegment | Initializes a new instance of the GH_CodeStringSegment class

Methods

 | Name | Description
Protected method | IsAlpha |
Public method | Replace |
Public method | ReplaceToken |
Public method | ToString | (Overrides Object..::..ToString()()()().)

Fields

 | Name | Description
Protected field | m_IsCode |
Protected field | m_String |

Properties

 | Name | Description
Public property | IsCode |
Public property | String |
Public property | StringValue |

See Also

GH_CodeStringSegment Class
Grasshopper.Kernel.Expressions Namespace


GH_CodeStringSegment Constructor

[image]

Grasshopper SDK
GH_CodeStringSegment Constructor
GH_CodeStringSegment Class See Also Send Feedback
Initializes a new instance of the GH_CodeStringSegment class

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_CodeStringSegment(
    string nString,
    bool bIsCode
)
Visual Basic
Public Sub New ( _
    nString As String, _
    bIsCode As Boolean _
)

Parameters

nString
Type: System..::..String
bIsCode
Type: System..::..Boolean

See Also

GH_CodeStringSegment Class
Grasshopper.Kernel.Expressions Namespace


GH_CodeStringSegment Fields

[image] [image]

Grasshopper SDK
GH_CodeStringSegment Fields
GH_CodeStringSegment Class See Also Send Feedback

The GH_CodeStringSegment type exposes the following members.

Fields

 | Name | Description
Protected field | m_IsCode |
Protected field | m_String |

See Also

GH_CodeStringSegment Class
Grasshopper.Kernel.Expressions Namespace


m_IsCode Field

[image]

Grasshopper SDK
GH_CodeStringSegment..::..m_IsCode Field
GH_CodeStringSegment Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected bool m_IsCode
Visual Basic
Protected m_IsCode As Boolean

See Also

GH_CodeStringSegment Class
Grasshopper.Kernel.Expressions Namespace


m_String Field

[image]

Grasshopper SDK
GH_CodeStringSegment..::..m_String Field
GH_CodeStringSegment Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected string m_String
Visual Basic
Protected m_String As String

See Also

GH_CodeStringSegment Class
Grasshopper.Kernel.Expressions Namespace


GH_CodeStringSegment Methods

[image] [image]

Grasshopper SDK
GH_CodeStringSegment Methods
GH_CodeStringSegment Class See Also Send Feedback

The GH_CodeStringSegment type exposes the following members.

Methods

 | Name | Description
Protected method | IsAlpha |
Public method | Replace |
Public method | ReplaceToken |
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

GH_CodeStringSegment Class
Grasshopper.Kernel.Expressions Namespace


IsAlpha Method

[image]

Grasshopper SDK
GH_CodeStringSegment..::..IsAlpha Method
GH_CodeStringSegment Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected bool IsAlpha(
    char C
)
Visual Basic
Protected Function IsAlpha ( _
    C As Char _
) As Boolean

Parameters

C
Type: System..::..Char

See Also

GH_CodeStringSegment Class
Grasshopper.Kernel.Expressions Namespace


Replace Method

[image]

Grasshopper SDK
GH_CodeStringSegment..::..Replace Method
GH_CodeStringSegment Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Replace(
    string search,
    string replace,
    bool bIgnoreCase
)
Visual Basic
Public Sub Replace ( _
    search As String, _
    replace As String, _
    bIgnoreCase As Boolean _
)

Parameters

search
Type: System..::..String
replace
Type: System..::..String
bIgnoreCase
Type: System..::..Boolean

See Also

GH_CodeStringSegment Class
Grasshopper.Kernel.Expressions Namespace


ReplaceToken Method

[image]

Grasshopper SDK
GH_CodeStringSegment..::..ReplaceToken Method
GH_CodeStringSegment Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ReplaceToken(
    string token,
    string replace,
    bool bIgnoreCase
)
Visual Basic
Public Sub ReplaceToken ( _
    token As String, _
    replace As String, _
    bIgnoreCase As Boolean _
)

Parameters

token
Type: System..::..String
replace
Type: System..::..String
bIgnoreCase
Type: System..::..Boolean

See Also

GH_CodeStringSegment Class
Grasshopper.Kernel.Expressions Namespace


ToString Method

[image]

Grasshopper SDK
GH_CodeStringSegment..::..ToString Method
GH_CodeStringSegment Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_CodeStringSegment Class
Grasshopper.Kernel.Expressions Namespace


GH_CodeStringSegment Properties

[image] [image]

Grasshopper SDK
GH_CodeStringSegment Properties
GH_CodeStringSegment Class See Also Send Feedback

The GH_CodeStringSegment type exposes the following members.

Properties

 | Name | Description
Public property | IsCode |
Public property | String |
Public property | StringValue |

See Also

GH_CodeStringSegment Class
Grasshopper.Kernel.Expressions Namespace


IsCode Property

[image]

Grasshopper SDK
GH_CodeStringSegment..::..IsCode Property
GH_CodeStringSegment Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsCode { get; set; }
Visual Basic
Public Property IsCode As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Expressions.GH_CodeStringSegment.IsCode"]

See Also

GH_CodeStringSegment Class
Grasshopper.Kernel.Expressions Namespace


String Property

[image]

Grasshopper SDK
GH_CodeStringSegment..::..String Property
GH_CodeStringSegment Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string String { get; set; }
Visual Basic
Public Property String As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Expressions.GH_CodeStringSegment.String"]

See Also

GH_CodeStringSegment Class
Grasshopper.Kernel.Expressions Namespace


StringValue Property

[image]

Grasshopper SDK
GH_CodeStringSegment..::..StringValue Property
GH_CodeStringSegment Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string StringValue { get; }
Visual Basic
Public ReadOnly Property StringValue As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Expressions.GH_CodeStringSegment.StringValue"]

See Also

GH_CodeStringSegment Class
Grasshopper.Kernel.Expressions Namespace


GH_ExpressionParser Class

[image]

Grasshopper SDK
GH_ExpressionParser Class
Members See Also Send Feedback
Provides a run-time evaluator for Grasshopper expressions.

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_ExpressionParser
Visual Basic
Public Class GH_ExpressionParser

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Expressions..::..GH_ExpressionParser

See Also

GH_ExpressionParser Members
Grasshopper.Kernel.Expressions Namespace


GH_ExpressionParser Members

[image] [image]

Grasshopper SDK
GH_ExpressionParser Members
GH_ExpressionParser Class Constructors Methods Properties See Also Send Feedback

The GH_ExpressionParser type exposes the following members.

Constructors

 | Name | Description
Public method | GH_ExpressionParser()()()() | Initializes a new instance of the GH_ExpressionParser class
Public method | GH_ExpressionParser(Boolean) | Initializes a new instance of the GH_ExpressionParser class

Methods

 | Name | Description
Public method | AddVariable(String, Complex) |
Public method | AddVariable(String, Plane) |
Public method | AddVariable(String, Point3d) |
Public method | AddVariable(String, Vector3d) |
Public method | AddVariable(String, Boolean) |
Public method | AddVariable(String, Double) |
Public method | AddVariable(String, Int32) |
Public method | AddVariable(String, String) |
Public method | AddVariableEx(String, GH_Variant) |
Public method | AddVariableEx(String, IGH_Goo) |
 | BalancedCharTest | Test a string for balanced open and close chars. You can use this function to see if brackets or parenthesis have been properly used.
Public method | CachedSymbols | Retrieve a copy of the Queue of cached symbols. You can use the cached symbols as an uber-optimization to speed up successive calls to Evaluate() with an identical expression string
Public method | CacheSymbols | Create a Symbols array from the expression. Use this method if you intend to evaluate the same expression multiple times. At this point, the expression has to be in correct syntax format. Use the GH_ExpressionSyntaxWriter.RewriteAll() method to make sure.
Public method | ClearSymbols | Destroy the Symbols cache.
Public method | ClearVariables | Destroy the variable cache.
Public method | DisplayFunctionList |
Public method | Evaluate()()()() | Evaluate the expression currently loaded in the Symbols cache using the currently loaded variables.
Public method | Evaluate(String) | Store a new expression in the Symbols cache and evaluate it using the current variables
Public method | Evaluate(Queue<(Of <<'(GH_ParserSymbol>)>>)) | Evaluate the expression queue without overriding any local caches. You can obtain an expression queue by calling CachedSymbols()
 | IsValidVariableName | Tests whether a string is a valid variable name for expressions. Valid names must contain at least one character, must start with an alphabetic character, and only contain alphanumeric chars and underscores.
Protected method | Op_BinaryAddition |
Protected method | Op_BinaryAmpersand |
Protected method | Op_BinaryAND |
Protected method | Op_BinaryAngle |
Protected method | Op_BinaryCircumflex |
Protected method | Op_BinaryCrossProduct |
Protected method | Op_BinaryDistance |
Protected method | Op_BinaryDivision |
Protected method | Op_BinaryEquality |
Protected method | Op_BinaryIntegerDivision |
Protected method | Op_BinaryLargerThan |
Protected method | Op_BinaryLargerThanOrEqual |
Protected method | Op_BinaryModulus |
Protected method | Op_BinaryMultiplication |
Protected method | Op_BinaryNearEquality |
Protected method | Op_BinaryOR |
Protected method | Op_BinaryPull |
Protected method | Op_BinaryPush |
Protected method | Op_BinarySmallerThan |
Protected method | Op_BinarySmallerThanOrEqual |
Protected method | Op_BinarySubtraction |
Protected method | Op_BinaryXOR |
Protected method | Op_UnaryBang |
Protected method | Op_UnaryCube |
Protected method | Op_UnaryDeg2Rad |
Protected method | Op_UnaryImaginary |
Protected method | Op_UnaryMinus |
Protected method | Op_UnaryNOT |
Protected method | Op_UnaryOComponent |
Protected method | Op_UnaryPlus |
Protected method | Op_UnarySquare |
Protected method | Op_UnaryXComponent |
Protected method | Op_UnaryYComponent |
Protected method | Op_UnaryZComponent |

Properties

 | Name | Description
Public property | ThrowExceptions |
Public property | Variables |

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


GH_ExpressionParser Constructor

[image] [image]

Grasshopper SDK
GH_ExpressionParser Constructor
GH_ExpressionParser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_ExpressionParser()()()() | Initializes a new instance of the GH_ExpressionParser class
Public method | GH_ExpressionParser(Boolean) | Initializes a new instance of the GH_ExpressionParser class

See Also

GH_ExpressionParser Class
GH_ExpressionParser Members
Grasshopper.Kernel.Expressions Namespace


GH_ExpressionParser Constructor

[image]

Grasshopper SDK
GH_ExpressionParser Constructor
GH_ExpressionParser Class See Also Send Feedback
Initializes a new instance of the GH_ExpressionParser class

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ExpressionParser()
Visual Basic
Public Sub New

See Also

GH_ExpressionParser Class
GH_ExpressionParser Overload
Grasshopper.Kernel.Expressions Namespace


GH_ExpressionParser Constructor (Boolean)

[image]

Grasshopper SDK
GH_ExpressionParser Constructor (Boolean)
GH_ExpressionParser Class See Also Send Feedback
Initializes a new instance of the GH_ExpressionParser class

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ExpressionParser(
    bool bThrowExceptions
)
Visual Basic
Public Sub New ( _
    bThrowExceptions As Boolean _
)

Parameters

bThrowExceptions
Type: System..::..Boolean

See Also

GH_ExpressionParser Class
GH_ExpressionParser Overload
Grasshopper.Kernel.Expressions Namespace


GH_ExpressionParser Methods

[image] [image]

Grasshopper SDK
GH_ExpressionParser Methods
GH_ExpressionParser Class See Also Send Feedback

The GH_ExpressionParser type exposes the following members.

Methods

 | Name | Description
Public method | AddVariable(String, Complex) |
Public method | AddVariable(String, Plane) |
Public method | AddVariable(String, Point3d) |
Public method | AddVariable(String, Vector3d) |
Public method | AddVariable(String, Boolean) |
Public method | AddVariable(String, Double) |
Public method | AddVariable(String, Int32) |
Public method | AddVariable(String, String) |
Public method | AddVariableEx(String, GH_Variant) |
Public method | AddVariableEx(String, IGH_Goo) |
 | BalancedCharTest | Test a string for balanced open and close chars. You can use this function to see if brackets or parenthesis have been properly used.
Public method | CachedSymbols | Retrieve a copy of the Queue of cached symbols. You can use the cached symbols as an uber-optimization to speed up successive calls to Evaluate() with an identical expression string
Public method | CacheSymbols | Create a Symbols array from the expression. Use this method if you intend to evaluate the same expression multiple times. At this point, the expression has to be in correct syntax format. Use the GH_ExpressionSyntaxWriter.RewriteAll() method to make sure.
Public method | ClearSymbols | Destroy the Symbols cache.
Public method | ClearVariables | Destroy the variable cache.
Public method | DisplayFunctionList |
Public method | Evaluate()()()() | Evaluate the expression currently loaded in the Symbols cache using the currently loaded variables.
Public method | Evaluate(String) | Store a new expression in the Symbols cache and evaluate it using the current variables
Public method | Evaluate(Queue<(Of <<'(GH_ParserSymbol>)>>)) | Evaluate the expression queue without overriding any local caches. You can obtain an expression queue by calling CachedSymbols()
 | IsValidVariableName | Tests whether a string is a valid variable name for expressions. Valid names must contain at least one character, must start with an alphabetic character, and only contain alphanumeric chars and underscores.
Protected method | Op_BinaryAddition |
Protected method | Op_BinaryAmpersand |
Protected method | Op_BinaryAND |
Protected method | Op_BinaryAngle |
Protected method | Op_BinaryCircumflex |
Protected method | Op_BinaryCrossProduct |
Protected method | Op_BinaryDistance |
Protected method | Op_BinaryDivision |
Protected method | Op_BinaryEquality |
Protected method | Op_BinaryIntegerDivision |
Protected method | Op_BinaryLargerThan |
Protected method | Op_BinaryLargerThanOrEqual |
Protected method | Op_BinaryModulus |
Protected method | Op_BinaryMultiplication |
Protected method | Op_BinaryNearEquality |
Protected method | Op_BinaryOR |
Protected method | Op_BinaryPull |
Protected method | Op_BinaryPush |
Protected method | Op_BinarySmallerThan |
Protected method | Op_BinarySmallerThanOrEqual |
Protected method | Op_BinarySubtraction |
Protected method | Op_BinaryXOR |
Protected method | Op_UnaryBang |
Protected method | Op_UnaryCube |
Protected method | Op_UnaryDeg2Rad |
Protected method | Op_UnaryImaginary |
Protected method | Op_UnaryMinus |
Protected method | Op_UnaryNOT |
Protected method | Op_UnaryOComponent |
Protected method | Op_UnaryPlus |
Protected method | Op_UnarySquare |
Protected method | Op_UnaryXComponent |
Protected method | Op_UnaryYComponent |
Protected method | Op_UnaryZComponent |

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


AddVariable Method

[image] [image]

Grasshopper SDK
GH_ExpressionParser..::..AddVariable Method
GH_ExpressionParser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddVariable(String, Complex) |
Public method | AddVariable(String, Plane) |
Public method | AddVariable(String, Point3d) |
Public method | AddVariable(String, Vector3d) |
Public method | AddVariable(String, Boolean) |
Public method | AddVariable(String, Double) |
Public method | AddVariable(String, Int32) |
Public method | AddVariable(String, String) |

See Also

GH_ExpressionParser Class
GH_ExpressionParser Members
Grasshopper.Kernel.Expressions Namespace


AddVariable Method (String, Complex)

[image]

Grasshopper SDK
GH_ExpressionParser..::..AddVariable Method (String, Complex)
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddVariable(
    string name,
    Complex val
)
Visual Basic
Public Sub AddVariable ( _
    name As String, _
    val As Complex _
)

Parameters

name
Type: System..::..String
val
Type: Grasshopper.Kernel.Types..::..Complex

See Also

GH_ExpressionParser Class
AddVariable Overload
Grasshopper.Kernel.Expressions Namespace


AddVariable Method (String, )

[image]

Grasshopper SDK
GH_ExpressionParser..::..AddVariable Method (String, )
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddVariable(
    string name,
    Plane val
)
Visual Basic
Public Sub AddVariable ( _
    name As String, _
    val As Plane _
)

Parameters

name
Type: System..::..String
val
Type: Plane

See Also

GH_ExpressionParser Class
AddVariable Overload
Grasshopper.Kernel.Expressions Namespace


AddVariable Method (String, )

[image]

Grasshopper SDK
GH_ExpressionParser..::..AddVariable Method (String, )
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddVariable(
    string name,
    Point3d val
)
Visual Basic
Public Sub AddVariable ( _
    name As String, _
    val As Point3d _
)

Parameters

name
Type: System..::..String
val
Type: Point3d

See Also

GH_ExpressionParser Class
AddVariable Overload
Grasshopper.Kernel.Expressions Namespace


AddVariable Method (String, )

[image]

Grasshopper SDK
GH_ExpressionParser..::..AddVariable Method (String, )
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddVariable(
    string name,
    Vector3d val
)
Visual Basic
Public Sub AddVariable ( _
    name As String, _
    val As Vector3d _
)

Parameters

name
Type: System..::..String
val
Type: Vector3d

See Also

GH_ExpressionParser Class
AddVariable Overload
Grasshopper.Kernel.Expressions Namespace


AddVariable Method (String, Boolean)

[image]

Grasshopper SDK
GH_ExpressionParser..::..AddVariable Method (String, Boolean)
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddVariable(
    string name,
    bool val
)
Visual Basic
Public Sub AddVariable ( _
    name As String, _
    val As Boolean _
)

Parameters

name
Type: System..::..String
val
Type: System..::..Boolean

See Also

GH_ExpressionParser Class
AddVariable Overload
Grasshopper.Kernel.Expressions Namespace


AddVariable Method (String, Double)

[image]

Grasshopper SDK
GH_ExpressionParser..::..AddVariable Method (String, Double)
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddVariable(
    string name,
    double val
)
Visual Basic
Public Sub AddVariable ( _
    name As String, _
    val As Double _
)

Parameters

name
Type: System..::..String
val
Type: System..::..Double

See Also

GH_ExpressionParser Class
AddVariable Overload
Grasshopper.Kernel.Expressions Namespace


AddVariable Method (String, Int32)

[image]

Grasshopper SDK
GH_ExpressionParser..::..AddVariable Method (String, Int32)
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddVariable(
    string name,
    int val
)
Visual Basic
Public Sub AddVariable ( _
    name As String, _
    val As Integer _
)

Parameters

name
Type: System..::..String
val
Type: System..::..Int32

See Also

GH_ExpressionParser Class
AddVariable Overload
Grasshopper.Kernel.Expressions Namespace


AddVariable Method (String, String)

[image]

Grasshopper SDK
GH_ExpressionParser..::..AddVariable Method (String, String)
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddVariable(
    string name,
    string val
)
Visual Basic
Public Sub AddVariable ( _
    name As String, _
    val As String _
)

Parameters

name
Type: System..::..String
val
Type: System..::..String

See Also

GH_ExpressionParser Class
AddVariable Overload
Grasshopper.Kernel.Expressions Namespace


AddVariableEx Method

[image] [image]

Grasshopper SDK
GH_ExpressionParser..::..AddVariableEx Method
GH_ExpressionParser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddVariableEx(String, GH_Variant) |
Public method | AddVariableEx(String, IGH_Goo) |

See Also

GH_ExpressionParser Class
GH_ExpressionParser Members
Grasshopper.Kernel.Expressions Namespace


AddVariableEx Method (String, GH_Variant)

[image]

Grasshopper SDK
GH_ExpressionParser..::..AddVariableEx Method (String, GH_Variant)
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddVariableEx(
    string name,
    GH_Variant val
)
Visual Basic
Public Sub AddVariableEx ( _
    name As String, _
    val As GH_Variant _
)

Parameters

name
Type: System..::..String
val
Type: Grasshopper.Kernel.Expressions..::..GH_Variant

See Also

GH_ExpressionParser Class
AddVariableEx Overload
Grasshopper.Kernel.Expressions Namespace


AddVariableEx Method (String, IGH_Goo)

[image]

Grasshopper SDK
GH_ExpressionParser..::..AddVariableEx Method (String, IGH_Goo)
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddVariableEx(
    string name,
    IGH_Goo val
)
Visual Basic
Public Sub AddVariableEx ( _
    name As String, _
    val As IGH_Goo _
)

Parameters

name
Type: System..::..String
val
Type: Grasshopper.Kernel.Types..::..IGH_Goo

See Also

GH_ExpressionParser Class
AddVariableEx Overload
Grasshopper.Kernel.Expressions Namespace


BalancedCharTest Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..BalancedCharTest Method
GH_ExpressionParser Class See Also Send Feedback
Test a string for balanced open and close chars. You can use this function to see if brackets or parenthesis have been properly used.

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool BalancedCharTest(
    string str,
    char char_open,
    char char_close,
    out int error_at
)
Visual Basic
Public Shared Function BalancedCharTest ( _
    str As String, _
    char_open As Char, _
    char_close As Char, _
    <OutAttribute> ByRef error_at As Integer _
) As Boolean

Parameters

str
Type: System..::..String
String to parse.
char_open
Type: System..::..Char
Char that indicates an opening statement.
char_close
Type: System..::..Char
Char that indicates a closing statement.
error_at
Type: System..::..Int32 %
The index at which the first error appears or -1 if no error was found.

Return Value

True if the chars are balanced, false if they are not.

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


CachedSymbols Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..CachedSymbols Method
GH_ExpressionParser Class See Also Send Feedback
Retrieve a copy of the Queue of cached symbols. You can use the cached symbols as an uber-optimization to speed up successive calls to Evaluate() with an identical expression string

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Queue<GH_ParserSymbol> CachedSymbols()
Visual Basic
Public Function CachedSymbols As Queue(Of GH_ParserSymbol)

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


CacheSymbols Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..CacheSymbols Method
GH_ExpressionParser Class See Also Send Feedback
Create a Symbols array from the expression. Use this method if you intend to evaluate the same expression multiple times. At this point, the expression has to be in correct syntax format. Use the GH_ExpressionSyntaxWriter.RewriteAll() method to make sure.

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool CacheSymbols(
    string Expression
)
Visual Basic
Public Function CacheSymbols ( _
    Expression As String _
) As Boolean

Parameters

Expression
Type: System..::..String

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


ClearSymbols Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..ClearSymbols Method
GH_ExpressionParser Class See Also Send Feedback
Destroy the Symbols cache.

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ClearSymbols()
Visual Basic
Public Sub ClearSymbols

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


ClearVariables Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..ClearVariables Method
GH_ExpressionParser Class See Also Send Feedback
Destroy the variable cache.

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ClearVariables()
Visual Basic
Public Sub ClearVariables

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


DisplayFunctionList Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..DisplayFunctionList Method
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DisplayFunctionList(
    IWin32Window wnd
)
Visual Basic
Public Sub DisplayFunctionList ( _
    wnd As IWin32Window _
)

Parameters

wnd
Type: System.Windows.Forms..::..IWin32Window

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


Evaluate Method

[image] [image]

Grasshopper SDK
GH_ExpressionParser..::..Evaluate Method
GH_ExpressionParser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Evaluate()()()() | Evaluate the expression currently loaded in the Symbols cache using the currently loaded variables.
Public method | Evaluate(String) | Store a new expression in the Symbols cache and evaluate it using the current variables
Public method | Evaluate(Queue<(Of <<'(GH_ParserSymbol>)>>)) | Evaluate the expression queue without overriding any local caches. You can obtain an expression queue by calling CachedSymbols()

See Also

GH_ExpressionParser Class
GH_ExpressionParser Members
Grasshopper.Kernel.Expressions Namespace


Evaluate Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..Evaluate Method
GH_ExpressionParser Class See Also Send Feedback
Evaluate the expression currently loaded in the Symbols cache using the currently loaded variables.

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Variant Evaluate()
Visual Basic
Public Function Evaluate As GH_Variant

See Also

GH_ExpressionParser Class
Evaluate Overload
Grasshopper.Kernel.Expressions Namespace


Evaluate Method (String)

[image]

Grasshopper SDK
GH_ExpressionParser..::..Evaluate Method (String)
GH_ExpressionParser Class See Also Send Feedback
Store a new expression in the Symbols cache and evaluate it using the current variables

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Variant Evaluate(
    string Expression
)
Visual Basic
Public Function Evaluate ( _
    Expression As String _
) As GH_Variant

Parameters

Expression
Type: System..::..String

See Also

GH_ExpressionParser Class
Evaluate Overload
Grasshopper.Kernel.Expressions Namespace


Evaluate Method (Queue(GH_ParserSymbol))

[image]

Grasshopper SDK
GH_ExpressionParser..::..Evaluate Method (Queue<(Of <(<'GH_ParserSymbol>)>)>)
GH_ExpressionParser Class See Also Send Feedback
Evaluate the expression queue without overriding any local caches. You can obtain an expression queue by calling CachedSymbols()

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Variant Evaluate(
    Queue<GH_ParserSymbol> qHint
)
Visual Basic
Public Function Evaluate ( _
    qHint As Queue(Of GH_ParserSymbol) _
) As GH_Variant

Parameters

qHint
Type: System.Collections.Generic..::..Queue <(Of <(<' GH_ParserSymbol >)>)>

See Also

GH_ExpressionParser Class
Evaluate Overload
Grasshopper.Kernel.Expressions Namespace


IsValidVariableName Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..IsValidVariableName Method
GH_ExpressionParser Class See Also Send Feedback
Tests whether a string is a valid variable name for expressions. Valid names must contain at least one character, must start with an alphabetic character, and only contain alphanumeric chars and underscores.

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool IsValidVariableName(
    string name
)
Visual Basic
Public Shared Function IsValidVariableName ( _
    name As String _
) As Boolean

Parameters

name
Type: System..::..String
Name to test.

Return Value

True if the name is valid (might still conflict with a function name though), false if not.

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


Op_BinaryAddition Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..Op_BinaryAddition Method
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Variant Op_BinaryAddition(
    GH_Variant A,
    GH_Variant B
)
Visual Basic
Protected Function Op_BinaryAddition ( _
    A As GH_Variant, _
    B As GH_Variant _
) As GH_Variant

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_Variant
B
Type: Grasshopper.Kernel.Expressions..::..GH_Variant

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


Op_BinaryAmpersand Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..Op_BinaryAmpersand Method
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Variant Op_BinaryAmpersand(
    GH_Variant A,
    GH_Variant B
)
Visual Basic
Protected Function Op_BinaryAmpersand ( _
    A As GH_Variant, _
    B As GH_Variant _
) As GH_Variant

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_Variant
B
Type: Grasshopper.Kernel.Expressions..::..GH_Variant

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


Op_BinaryAND Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..Op_BinaryAND Method
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Variant Op_BinaryAND(
    GH_Variant A,
    GH_Variant B
)
Visual Basic
Protected Function Op_BinaryAND ( _
    A As GH_Variant, _
    B As GH_Variant _
) As GH_Variant

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_Variant
B
Type: Grasshopper.Kernel.Expressions..::..GH_Variant

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


Op_BinaryAngle Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..Op_BinaryAngle Method
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Variant Op_BinaryAngle(
    GH_Variant A,
    GH_Variant B
)
Visual Basic
Protected Function Op_BinaryAngle ( _
    A As GH_Variant, _
    B As GH_Variant _
) As GH_Variant

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_Variant
B
Type: Grasshopper.Kernel.Expressions..::..GH_Variant

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


Op_BinaryCircumflex Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..Op_BinaryCircumflex Method
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Variant Op_BinaryCircumflex(
    GH_Variant A,
    GH_Variant B
)
Visual Basic
Protected Function Op_BinaryCircumflex ( _
    A As GH_Variant, _
    B As GH_Variant _
) As GH_Variant

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_Variant
B
Type: Grasshopper.Kernel.Expressions..::..GH_Variant

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


Op_BinaryCrossProduct Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..Op_BinaryCrossProduct Method
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Variant Op_BinaryCrossProduct(
    GH_Variant A,
    GH_Variant B
)
Visual Basic
Protected Function Op_BinaryCrossProduct ( _
    A As GH_Variant, _
    B As GH_Variant _
) As GH_Variant

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_Variant
B
Type: Grasshopper.Kernel.Expressions..::..GH_Variant

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


Op_BinaryDistance Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..Op_BinaryDistance Method
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Variant Op_BinaryDistance(
    GH_Variant A,
    GH_Variant B
)
Visual Basic
Protected Function Op_BinaryDistance ( _
    A As GH_Variant, _
    B As GH_Variant _
) As GH_Variant

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_Variant
B
Type: Grasshopper.Kernel.Expressions..::..GH_Variant

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


Op_BinaryDivision Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..Op_BinaryDivision Method
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Variant Op_BinaryDivision(
    GH_Variant A,
    GH_Variant B
)
Visual Basic
Protected Function Op_BinaryDivision ( _
    A As GH_Variant, _
    B As GH_Variant _
) As GH_Variant

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_Variant
B
Type: Grasshopper.Kernel.Expressions..::..GH_Variant

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


Op_BinaryEquality Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..Op_BinaryEquality Method
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Variant Op_BinaryEquality(
    GH_Variant A,
    GH_Variant B
)
Visual Basic
Protected Function Op_BinaryEquality ( _
    A As GH_Variant, _
    B As GH_Variant _
) As GH_Variant

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_Variant
B
Type: Grasshopper.Kernel.Expressions..::..GH_Variant

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


Op_BinaryIntegerDivision Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..Op_BinaryIntegerDivision Method
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Variant Op_BinaryIntegerDivision(
    GH_Variant A,
    GH_Variant B
)
Visual Basic
Protected Function Op_BinaryIntegerDivision ( _
    A As GH_Variant, _
    B As GH_Variant _
) As GH_Variant

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_Variant
B
Type: Grasshopper.Kernel.Expressions..::..GH_Variant

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


Op_BinaryLargerThan Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..Op_BinaryLargerThan Method
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Variant Op_BinaryLargerThan(
    GH_Variant A,
    GH_Variant B
)
Visual Basic
Protected Function Op_BinaryLargerThan ( _
    A As GH_Variant, _
    B As GH_Variant _
) As GH_Variant

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_Variant
B
Type: Grasshopper.Kernel.Expressions..::..GH_Variant

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


Op_BinaryLargerThanOrEqual Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..Op_BinaryLargerThanOrEqual Method
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Variant Op_BinaryLargerThanOrEqual(
    GH_Variant A,
    GH_Variant B
)
Visual Basic
Protected Function Op_BinaryLargerThanOrEqual ( _
    A As GH_Variant, _
    B As GH_Variant _
) As GH_Variant

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_Variant
B
Type: Grasshopper.Kernel.Expressions..::..GH_Variant

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


Op_BinaryModulus Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..Op_BinaryModulus Method
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Variant Op_BinaryModulus(
    GH_Variant A,
    GH_Variant B
)
Visual Basic
Protected Function Op_BinaryModulus ( _
    A As GH_Variant, _
    B As GH_Variant _
) As GH_Variant

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_Variant
B
Type: Grasshopper.Kernel.Expressions..::..GH_Variant

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


Op_BinaryMultiplication Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..Op_BinaryMultiplication Method
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Variant Op_BinaryMultiplication(
    GH_Variant A,
    GH_Variant B
)
Visual Basic
Protected Function Op_BinaryMultiplication ( _
    A As GH_Variant, _
    B As GH_Variant _
) As GH_Variant

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_Variant
B
Type: Grasshopper.Kernel.Expressions..::..GH_Variant

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


Op_BinaryNearEquality Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..Op_BinaryNearEquality Method
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Variant Op_BinaryNearEquality(
    GH_Variant A,
    GH_Variant B
)
Visual Basic
Protected Function Op_BinaryNearEquality ( _
    A As GH_Variant, _
    B As GH_Variant _
) As GH_Variant

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_Variant
B
Type: Grasshopper.Kernel.Expressions..::..GH_Variant

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


Op_BinaryOR Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..Op_BinaryOR Method
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Variant Op_BinaryOR(
    GH_Variant A,
    GH_Variant B
)
Visual Basic
Protected Function Op_BinaryOR ( _
    A As GH_Variant, _
    B As GH_Variant _
) As GH_Variant

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_Variant
B
Type: Grasshopper.Kernel.Expressions..::..GH_Variant

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


Op_BinaryPull Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..Op_BinaryPull Method
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Variant Op_BinaryPull(
    GH_Variant A,
    GH_Variant B
)
Visual Basic
Protected Function Op_BinaryPull ( _
    A As GH_Variant, _
    B As GH_Variant _
) As GH_Variant

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_Variant
B
Type: Grasshopper.Kernel.Expressions..::..GH_Variant

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


Op_BinaryPush Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..Op_BinaryPush Method
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Variant Op_BinaryPush(
    GH_Variant A,
    GH_Variant B
)
Visual Basic
Protected Function Op_BinaryPush ( _
    A As GH_Variant, _
    B As GH_Variant _
) As GH_Variant

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_Variant
B
Type: Grasshopper.Kernel.Expressions..::..GH_Variant

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


Op_BinarySmallerThan Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..Op_BinarySmallerThan Method
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Variant Op_BinarySmallerThan(
    GH_Variant A,
    GH_Variant B
)
Visual Basic
Protected Function Op_BinarySmallerThan ( _
    A As GH_Variant, _
    B As GH_Variant _
) As GH_Variant

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_Variant
B
Type: Grasshopper.Kernel.Expressions..::..GH_Variant

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


Op_BinarySmallerThanOrEqual Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..Op_BinarySmallerThanOrEqual Method
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Variant Op_BinarySmallerThanOrEqual(
    GH_Variant A,
    GH_Variant B
)
Visual Basic
Protected Function Op_BinarySmallerThanOrEqual ( _
    A As GH_Variant, _
    B As GH_Variant _
) As GH_Variant

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_Variant
B
Type: Grasshopper.Kernel.Expressions..::..GH_Variant

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


Op_BinarySubtraction Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..Op_BinarySubtraction Method
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Variant Op_BinarySubtraction(
    GH_Variant A,
    GH_Variant B
)
Visual Basic
Protected Function Op_BinarySubtraction ( _
    A As GH_Variant, _
    B As GH_Variant _
) As GH_Variant

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_Variant
B
Type: Grasshopper.Kernel.Expressions..::..GH_Variant

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


Op_BinaryXOR Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..Op_BinaryXOR Method
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Variant Op_BinaryXOR(
    GH_Variant A,
    GH_Variant B
)
Visual Basic
Protected Function Op_BinaryXOR ( _
    A As GH_Variant, _
    B As GH_Variant _
) As GH_Variant

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_Variant
B
Type: Grasshopper.Kernel.Expressions..::..GH_Variant

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


Op_UnaryBang Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..Op_UnaryBang Method
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Variant Op_UnaryBang(
    GH_Variant V
)
Visual Basic
Protected Function Op_UnaryBang ( _
    V As GH_Variant _
) As GH_Variant

Parameters

V
Type: Grasshopper.Kernel.Expressions..::..GH_Variant

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


Op_UnaryCube Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..Op_UnaryCube Method
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Variant Op_UnaryCube(
    GH_Variant V
)
Visual Basic
Protected Function Op_UnaryCube ( _
    V As GH_Variant _
) As GH_Variant

Parameters

V
Type: Grasshopper.Kernel.Expressions..::..GH_Variant

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


Op_UnaryDeg2Rad Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..Op_UnaryDeg2Rad Method
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Variant Op_UnaryDeg2Rad(
    GH_Variant V
)
Visual Basic
Protected Function Op_UnaryDeg2Rad ( _
    V As GH_Variant _
) As GH_Variant

Parameters

V
Type: Grasshopper.Kernel.Expressions..::..GH_Variant

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


Op_UnaryImaginary Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..Op_UnaryImaginary Method
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Variant Op_UnaryImaginary(
    GH_Variant V
)
Visual Basic
Protected Function Op_UnaryImaginary ( _
    V As GH_Variant _
) As GH_Variant

Parameters

V
Type: Grasshopper.Kernel.Expressions..::..GH_Variant

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


Op_UnaryMinus Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..Op_UnaryMinus Method
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Variant Op_UnaryMinus(
    GH_Variant V
)
Visual Basic
Protected Function Op_UnaryMinus ( _
    V As GH_Variant _
) As GH_Variant

Parameters

V
Type: Grasshopper.Kernel.Expressions..::..GH_Variant

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


Op_UnaryNOT Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..Op_UnaryNOT Method
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Variant Op_UnaryNOT(
    GH_Variant V
)
Visual Basic
Protected Function Op_UnaryNOT ( _
    V As GH_Variant _
) As GH_Variant

Parameters

V
Type: Grasshopper.Kernel.Expressions..::..GH_Variant

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


Op_UnaryOComponent Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..Op_UnaryOComponent Method
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Variant Op_UnaryOComponent(
    GH_Variant V
)
Visual Basic
Protected Function Op_UnaryOComponent ( _
    V As GH_Variant _
) As GH_Variant

Parameters

V
Type: Grasshopper.Kernel.Expressions..::..GH_Variant

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


Op_UnaryPlus Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..Op_UnaryPlus Method
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Variant Op_UnaryPlus(
    GH_Variant V
)
Visual Basic
Protected Function Op_UnaryPlus ( _
    V As GH_Variant _
) As GH_Variant

Parameters

V
Type: Grasshopper.Kernel.Expressions..::..GH_Variant

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


Op_UnarySquare Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..Op_UnarySquare Method
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Variant Op_UnarySquare(
    GH_Variant V
)
Visual Basic
Protected Function Op_UnarySquare ( _
    V As GH_Variant _
) As GH_Variant

Parameters

V
Type: Grasshopper.Kernel.Expressions..::..GH_Variant

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


Op_UnaryXComponent Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..Op_UnaryXComponent Method
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Variant Op_UnaryXComponent(
    GH_Variant V
)
Visual Basic
Protected Function Op_UnaryXComponent ( _
    V As GH_Variant _
) As GH_Variant

Parameters

V
Type: Grasshopper.Kernel.Expressions..::..GH_Variant

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


Op_UnaryYComponent Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..Op_UnaryYComponent Method
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Variant Op_UnaryYComponent(
    GH_Variant V
)
Visual Basic
Protected Function Op_UnaryYComponent ( _
    V As GH_Variant _
) As GH_Variant

Parameters

V
Type: Grasshopper.Kernel.Expressions..::..GH_Variant

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


Op_UnaryZComponent Method

[image]

Grasshopper SDK
GH_ExpressionParser..::..Op_UnaryZComponent Method
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Variant Op_UnaryZComponent(
    GH_Variant V
)
Visual Basic
Protected Function Op_UnaryZComponent ( _
    V As GH_Variant _
) As GH_Variant

Parameters

V
Type: Grasshopper.Kernel.Expressions..::..GH_Variant

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


GH_ExpressionParser Properties

[image] [image]

Grasshopper SDK
GH_ExpressionParser Properties
GH_ExpressionParser Class See Also Send Feedback

The GH_ExpressionParser type exposes the following members.

Properties

 | Name | Description
Public property | ThrowExceptions |
Public property | Variables |

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


ThrowExceptions Property

[image]

Grasshopper SDK
GH_ExpressionParser..::..ThrowExceptions Property
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool ThrowExceptions { get; set; }
Visual Basic
Public Property ThrowExceptions As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Expressions.GH_ExpressionParser.ThrowExceptions"]

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


Variables Property

[image]

Grasshopper SDK
GH_ExpressionParser..::..Variables Property
GH_ExpressionParser Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public SortedDictionary<string, GH_Variant> Variables { get; }
Visual Basic
Public ReadOnly Property Variables As SortedDictionary(Of String, GH_Variant)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Expressions.GH_ExpressionParser.Variables"]

See Also

GH_ExpressionParser Class
Grasshopper.Kernel.Expressions Namespace


GH_ExpressionString Class

[image]

Grasshopper SDK
GH_ExpressionString Class
Members See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_ExpressionString : List<char>
Visual Basic
Public Class GH_ExpressionString _
    Inherits List(Of Char)

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' Char >)>)>
Grasshopper.Kernel.Expressions..::..GH_ExpressionString

See Also

GH_ExpressionString Members
Grasshopper.Kernel.Expressions Namespace


GH_ExpressionString Members

[image] [image]

Grasshopper SDK
GH_ExpressionString Members
GH_ExpressionString Class Constructors Methods Fields Properties See Also Send Feedback

The GH_ExpressionString type exposes the following members.

Constructors

 | Name | Description
Public method | GH_ExpressionString | Initializes a new instance of the GH_ExpressionString class

Methods

 | Name | Description
Public method | BuildLUT |
Public method | IsWhiteSpace |
Public method | ToString | (Overrides Object..::..ToString()()()().)

Fields

 | Name | Description
 | bracket_closed |
 | bracket_open |
 | colon |
 | comma |
 | dot |
 | dquote |
 | invalid |
 | linefeed |
Protected field | m_t |
 | paren_close |
 | paren_open |
 | quote |
 | return |
 | scolon |
 | space |
 | tab |
 | underbar |

Properties

 | Name | Description
Public property | Char |
Public property | Next |
Public property | Prev |

See Also

GH_ExpressionString Class
Grasshopper.Kernel.Expressions Namespace


GH_ExpressionString Constructor

[image]

Grasshopper SDK
GH_ExpressionString Constructor
GH_ExpressionString Class See Also Send Feedback
Initializes a new instance of the GH_ExpressionString class

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ExpressionString(
    string in
)
Visual Basic
Public Sub New ( _
    in As String _
)

Parameters

in
Type: System..::..String

See Also

GH_ExpressionString Class
Grasshopper.Kernel.Expressions Namespace


GH_ExpressionString Fields

[image] [image]

Grasshopper SDK
GH_ExpressionString Fields
GH_ExpressionString Class See Also Send Feedback

The GH_ExpressionString type exposes the following members.

Fields

 | Name | Description
 | bracket_closed |
 | bracket_open |
 | colon |
 | comma |
 | dot |
 | dquote |
 | invalid |
 | linefeed |
Protected field | m_t |
 | paren_close |
 | paren_open |
 | quote |
 | return |
 | scolon |
 | space |
 | tab |
 | underbar |

See Also

GH_ExpressionString Class
Grasshopper.Kernel.Expressions Namespace


bracket_closed Field

[image]

Grasshopper SDK
GH_ExpressionString..::..bracket_closed Field
GH_ExpressionString Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected static char bracket_closed
Visual Basic
Protected Shared bracket_closed As Char

See Also

GH_ExpressionString Class
Grasshopper.Kernel.Expressions Namespace


bracket_open Field

[image]

Grasshopper SDK
GH_ExpressionString..::..bracket_open Field
GH_ExpressionString Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected static char bracket_open
Visual Basic
Protected Shared bracket_open As Char

See Also

GH_ExpressionString Class
Grasshopper.Kernel.Expressions Namespace


colon Field

[image]

Grasshopper SDK
GH_ExpressionString..::..colon Field
GH_ExpressionString Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected static char colon
Visual Basic
Protected Shared colon As Char

See Also

GH_ExpressionString Class
Grasshopper.Kernel.Expressions Namespace


comma Field

[image]

Grasshopper SDK
GH_ExpressionString..::..comma Field
GH_ExpressionString Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected static char comma
Visual Basic
Protected Shared comma As Char

See Also

GH_ExpressionString Class
Grasshopper.Kernel.Expressions Namespace


dot Field

[image]

Grasshopper SDK
GH_ExpressionString..::..dot Field
GH_ExpressionString Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected static char dot
Visual Basic
Protected Shared dot As Char

See Also

GH_ExpressionString Class
Grasshopper.Kernel.Expressions Namespace


dquote Field

[image]

Grasshopper SDK
GH_ExpressionString..::..dquote Field
GH_ExpressionString Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected static char dquote
Visual Basic
Protected Shared dquote As Char

See Also

GH_ExpressionString Class
Grasshopper.Kernel.Expressions Namespace


invalid Field

[image]

Grasshopper SDK
GH_ExpressionString..::..invalid Field
GH_ExpressionString Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected static char invalid
Visual Basic
Protected Shared invalid As Char

See Also

GH_ExpressionString Class
Grasshopper.Kernel.Expressions Namespace


linefeed Field

[image]

Grasshopper SDK
GH_ExpressionString..::..linefeed Field
GH_ExpressionString Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected static char linefeed
Visual Basic
Protected Shared linefeed As Char

See Also

GH_ExpressionString Class
Grasshopper.Kernel.Expressions Namespace


m_t Field

[image]

Grasshopper SDK
GH_ExpressionString..::..m_t Field
GH_ExpressionString Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected List<GH_CharType> m_t
Visual Basic
Protected m_t As List(Of GH_CharType)

See Also

GH_ExpressionString Class
Grasshopper.Kernel.Expressions Namespace


paren_close Field

[image]

Grasshopper SDK
GH_ExpressionString..::..paren_close Field
GH_ExpressionString Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected static char paren_close
Visual Basic
Protected Shared paren_close As Char

See Also

GH_ExpressionString Class
Grasshopper.Kernel.Expressions Namespace


paren_open Field

[image]

Grasshopper SDK
GH_ExpressionString..::..paren_open Field
GH_ExpressionString Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected static char paren_open
Visual Basic
Protected Shared paren_open As Char

See Also

GH_ExpressionString Class
Grasshopper.Kernel.Expressions Namespace


quote Field

[image]

Grasshopper SDK
GH_ExpressionString..::..quote Field
GH_ExpressionString Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected static char quote
Visual Basic
Protected Shared quote As Char

See Also

GH_ExpressionString Class
Grasshopper.Kernel.Expressions Namespace


return Field

[image]

Grasshopper SDK
GH_ExpressionString..::..return Field
GH_ExpressionString Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected static char return
Visual Basic
Protected Shared return As Char

See Also

GH_ExpressionString Class
Grasshopper.Kernel.Expressions Namespace


scolon Field

[image]

Grasshopper SDK
GH_ExpressionString..::..scolon Field
GH_ExpressionString Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected static char scolon
Visual Basic
Protected Shared scolon As Char

See Also

GH_ExpressionString Class
Grasshopper.Kernel.Expressions Namespace


space Field

[image]

Grasshopper SDK
GH_ExpressionString..::..space Field
GH_ExpressionString Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected static char space
Visual Basic
Protected Shared space As Char

See Also

GH_ExpressionString Class
Grasshopper.Kernel.Expressions Namespace


tab Field

[image]

Grasshopper SDK
GH_ExpressionString..::..tab Field
GH_ExpressionString Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected static char tab
Visual Basic
Protected Shared tab As Char

See Also

GH_ExpressionString Class
Grasshopper.Kernel.Expressions Namespace


underbar Field

[image]

Grasshopper SDK
GH_ExpressionString..::..underbar Field
GH_ExpressionString Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected static char underbar
Visual Basic
Protected Shared underbar As Char

See Also

GH_ExpressionString Class
Grasshopper.Kernel.Expressions Namespace


GH_ExpressionString Methods

[image] [image]

Grasshopper SDK
GH_ExpressionString Methods
GH_ExpressionString Class See Also Send Feedback

The GH_ExpressionString type exposes the following members.

Methods

 | Name | Description
Public method | BuildLUT |
Public method | IsWhiteSpace |
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

GH_ExpressionString Class
Grasshopper.Kernel.Expressions Namespace


BuildLUT Method

[image]

Grasshopper SDK
GH_ExpressionString..::..BuildLUT Method
GH_ExpressionString Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void BuildLUT()
Visual Basic
Public Sub BuildLUT

See Also

GH_ExpressionString Class
Grasshopper.Kernel.Expressions Namespace


IsWhiteSpace Method

[image]

Grasshopper SDK
GH_ExpressionString..::..IsWhiteSpace Method
GH_ExpressionString Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsWhiteSpace(
    int index
)
Visual Basic
Public Function IsWhiteSpace ( _
    index As Integer _
) As Boolean

Parameters

index
Type: System..::..Int32

See Also

GH_ExpressionString Class
Grasshopper.Kernel.Expressions Namespace


ToString Method

[image]

Grasshopper SDK
GH_ExpressionString..::..ToString Method
GH_ExpressionString Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_ExpressionString Class
Grasshopper.Kernel.Expressions Namespace


GH_ExpressionString Properties

[image] [image]

Grasshopper SDK
GH_ExpressionString Properties
GH_ExpressionString Class See Also Send Feedback

The GH_ExpressionString type exposes the following members.

Properties

 | Name | Description
Public property | Char |
Public property | Next |
Public property | Prev |

See Also

GH_ExpressionString Class
Grasshopper.Kernel.Expressions Namespace


Char Property

[image]

Grasshopper SDK
GH_ExpressionString..::..Char Property
GH_ExpressionString Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public char this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property Char ( _
    index As Integer _
) As Char
    Get

Parameters

index
Type: System..::..Int32

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Expressions.GH_ExpressionString.Char(System.Int32)"]

See Also

GH_ExpressionString Class
Grasshopper.Kernel.Expressions Namespace


Next Property

[image]

Grasshopper SDK
GH_ExpressionString..::..Next Property
GH_ExpressionString Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public char this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property Next ( _
    index As Integer _
) As Char
    Get

Parameters

index
Type: System..::..Int32

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Expressions.GH_ExpressionString.Next(System.Int32)"]

See Also

GH_ExpressionString Class
Grasshopper.Kernel.Expressions Namespace


Prev Property

[image]

Grasshopper SDK
GH_ExpressionString..::..Prev Property
GH_ExpressionString Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public char this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property Prev ( _
    index As Integer _
) As Char
    Get

Parameters

index
Type: System..::..Int32

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Expressions.GH_ExpressionString.Prev(System.Int32)"]

See Also

GH_ExpressionString Class
Grasshopper.Kernel.Expressions Namespace


GH_ExpressionSyntaxWriter Class

[image]

Grasshopper SDK
GH_ExpressionSyntaxWriter Class
Members See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class GH_ExpressionSyntaxWriter
Visual Basic
Public NotInheritable Class GH_ExpressionSyntaxWriter

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Expressions..::..GH_ExpressionSyntaxWriter

See Also

GH_ExpressionSyntaxWriter Members
Grasshopper.Kernel.Expressions Namespace


GH_ExpressionSyntaxWriter Members

[image] [image]

Grasshopper SDK
GH_ExpressionSyntaxWriter Members
GH_ExpressionSyntaxWriter Class Methods See Also Send Feedback

The GH_ExpressionSyntaxWriter type exposes the following members.

Methods

Name | Description
RewriteAll | Apply all syntax rulesets to the expression.
RewriteForEvaluator(String) | Rewrite the expression so that all temporary keywords and symbols are replaced by evaluator-specific chars. The expression will become less readable, do not let the user see the result of this function. You need to rewrite the expression with this function if you intend to feed it into the Evaluator.
RewriteForEvaluator(GH_CodeString) | Rewrite the expression so that all temporary keywords and symbols are replaced by evaluator-specific chars. The expression will become less readable, do not let the user see the result of this function. You need to rewrite the expression with this function if you intend to feed it into the Evaluator.
RewriteForGraphicInterface(String) | Rewrite the expression so that tags are replaced by the complex characters that make up the esoteric operators, functions and constants. The expression should become more readable
RewriteForGraphicInterface(GH_CodeString) | Rewrite the expression so that tags are replaced by the complex characters that make up the esoteric operators, functions and constants. The expression should become more readable for humans.

See Also

GH_ExpressionSyntaxWriter Class
Grasshopper.Kernel.Expressions Namespace


GH_ExpressionSyntaxWriter Methods

[image] [image]

Grasshopper SDK
GH_ExpressionSyntaxWriter Methods
GH_ExpressionSyntaxWriter Class See Also Send Feedback

The GH_ExpressionSyntaxWriter type exposes the following members.

Methods

Name | Description
RewriteAll | Apply all syntax rulesets to the expression.
RewriteForEvaluator(String) | Rewrite the expression so that all temporary keywords and symbols are replaced by evaluator-specific chars. The expression will become less readable, do not let the user see the result of this function. You need to rewrite the expression with this function if you intend to feed it into the Evaluator.
RewriteForEvaluator(GH_CodeString) | Rewrite the expression so that all temporary keywords and symbols are replaced by evaluator-specific chars. The expression will become less readable, do not let the user see the result of this function. You need to rewrite the expression with this function if you intend to feed it into the Evaluator.
RewriteForGraphicInterface(String) | Rewrite the expression so that tags are replaced by the complex characters that make up the esoteric operators, functions and constants. The expression should become more readable
RewriteForGraphicInterface(GH_CodeString) | Rewrite the expression so that tags are replaced by the complex characters that make up the esoteric operators, functions and constants. The expression should become more readable for humans.

See Also

GH_ExpressionSyntaxWriter Class
Grasshopper.Kernel.Expressions Namespace


RewriteAll Method

[image]

Grasshopper SDK
GH_ExpressionSyntaxWriter..::..RewriteAll Method
GH_ExpressionSyntaxWriter Class See Also Send Feedback
Apply all syntax rulesets to the expression.

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string RewriteAll(
    string Expression
)
Visual Basic
Public Shared Function RewriteAll ( _
    Expression As String _
) As String

Parameters

Expression
Type: System..::..String

See Also

GH_ExpressionSyntaxWriter Class
Grasshopper.Kernel.Expressions Namespace


RewriteForEvaluator Method

[image] [image]

Grasshopper SDK
GH_ExpressionSyntaxWriter..::..RewriteForEvaluator Method
GH_ExpressionSyntaxWriter Class See Also Send Feedback

Overload List

Name | Description
RewriteForEvaluator(String) | Rewrite the expression so that all temporary keywords and symbols are replaced by evaluator-specific chars. The expression will become less readable, do not let the user see the result of this function. You need to rewrite the expression with this function if you intend to feed it into the Evaluator.
RewriteForEvaluator(GH_CodeString) | Rewrite the expression so that all temporary keywords and symbols are replaced by evaluator-specific chars. The expression will become less readable, do not let the user see the result of this function. You need to rewrite the expression with this function if you intend to feed it into the Evaluator.

See Also

GH_ExpressionSyntaxWriter Class
GH_ExpressionSyntaxWriter Members
Grasshopper.Kernel.Expressions Namespace


RewriteForEvaluator Method (String)

[image]

Grasshopper SDK
GH_ExpressionSyntaxWriter..::..RewriteForEvaluator Method (String)
GH_ExpressionSyntaxWriter Class See Also Send Feedback
Rewrite the expression so that all temporary keywords and symbols are replaced by evaluator-specific chars. The expression will become less readable, do not let the user see the result of this function. You need to rewrite the expression with this function if you intend to feed it into the Evaluator.

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string RewriteForEvaluator(
    string Expression
)
Visual Basic
Public Shared Function RewriteForEvaluator ( _
    Expression As String _
) As String

Parameters

Expression
Type: System..::..String

See Also

GH_ExpressionSyntaxWriter Class
RewriteForEvaluator Overload
Grasshopper.Kernel.Expressions Namespace


RewriteForEvaluator Method (GH_CodeString)

[image]

Grasshopper SDK
GH_ExpressionSyntaxWriter..::..RewriteForEvaluator Method (GH_CodeString)
GH_ExpressionSyntaxWriter Class See Also Send Feedback
Rewrite the expression so that all temporary keywords and symbols are replaced by evaluator-specific chars. The expression will become less readable, do not let the user see the result of this function. You need to rewrite the expression with this function if you intend to feed it into the Evaluator.

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void RewriteForEvaluator(
    GH_CodeString sCode
)
Visual Basic
Public Shared Sub RewriteForEvaluator ( _
    sCode As GH_CodeString _
)

Parameters

sCode
Type: Grasshopper.Kernel.Expressions..::..GH_CodeString

See Also

GH_ExpressionSyntaxWriter Class
RewriteForEvaluator Overload
Grasshopper.Kernel.Expressions Namespace


RewriteForGraphicInterface Method

[image] [image]

Grasshopper SDK
GH_ExpressionSyntaxWriter..::..RewriteForGraphicInterface Method
GH_ExpressionSyntaxWriter Class See Also Send Feedback

Overload List

Name | Description
RewriteForGraphicInterface(String) | Rewrite the expression so that tags are replaced by the complex characters that make up the esoteric operators, functions and constants. The expression should become more readable
RewriteForGraphicInterface(GH_CodeString) | Rewrite the expression so that tags are replaced by the complex characters that make up the esoteric operators, functions and constants. The expression should become more readable for humans.

See Also

GH_ExpressionSyntaxWriter Class
GH_ExpressionSyntaxWriter Members
Grasshopper.Kernel.Expressions Namespace


RewriteForGraphicInterface Method (String)

[image]

Grasshopper SDK
GH_ExpressionSyntaxWriter..::..RewriteForGraphicInterface Method (String)
GH_ExpressionSyntaxWriter Class See Also Send Feedback
Rewrite the expression so that tags are replaced by the complex characters that make up the esoteric operators, functions and constants. The expression should become more readable

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static string RewriteForGraphicInterface(
    string expression
)
Visual Basic
Public Shared Function RewriteForGraphicInterface ( _
    expression As String _
) As String

Parameters

expression
Type: System..::..String

See Also

GH_ExpressionSyntaxWriter Class
RewriteForGraphicInterface Overload
Grasshopper.Kernel.Expressions Namespace


RewriteForGraphicInterface Method (GH_CodeString)

[image]

Grasshopper SDK
GH_ExpressionSyntaxWriter..::..RewriteForGraphicInterface Method (GH_CodeString)
GH_ExpressionSyntaxWriter Class See Also Send Feedback
Rewrite the expression so that tags are replaced by the complex characters that make up the esoteric operators, functions and constants. The expression should become more readable for humans.

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void RewriteForGraphicInterface(
    GH_CodeString code
)
Visual Basic
Public Shared Sub RewriteForGraphicInterface ( _
    code As GH_CodeString _
)

Parameters

code
Type: Grasshopper.Kernel.Expressions..::..GH_CodeString

See Also

GH_ExpressionSyntaxWriter Class
RewriteForGraphicInterface Overload
Grasshopper.Kernel.Expressions Namespace


GH_OperatorType Enumeration

[image]

Grasshopper SDK
GH_OperatorType Enumeration
See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_OperatorType
Visual Basic
Public Enumeration GH_OperatorType

Members

Member name | Value | Description
UnaryOnLeft | 0 |
UnaryOnRight | 1 |
Binary | 2 |

See Also

Grasshopper.Kernel.Expressions Namespace


GH_ParserOperator Class

[image]

Grasshopper SDK
GH_ParserOperator Class
Members See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_ParserOperator : IComparable<GH_ParserOperator>
Visual Basic
Public Class GH_ParserOperator _
    Implements IComparable(Of GH_ParserOperator)

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Expressions..::..GH_ParserOperator

See Also

GH_ParserOperator Members
Grasshopper.Kernel.Expressions Namespace


GH_ParserOperator Members

[image] [image]

Grasshopper SDK
GH_ParserOperator Members
GH_ParserOperator Class Constructors Methods Fields See Also Send Feedback

The GH_ParserOperator type exposes the following members.

Constructors

 | Name | Description
Public method | GH_ParserOperator | Initializes a new instance of the GH_ParserOperator class

Methods

 | Name | Description
Public method | CompareTo |
Public method | Equals | (Overrides Object..::..Equals(Object).)

Fields

 | Name | Description
Public field | m_description |
Public field | m_name |
Public field | m_precedence |
Public field | m_symbol |
Public field | m_type |

See Also

GH_ParserOperator Class
Grasshopper.Kernel.Expressions Namespace


GH_ParserOperator Constructor

[image]

Grasshopper SDK
GH_ParserOperator Constructor
GH_ParserOperator Class See Also Send Feedback
Initializes a new instance of the GH_ParserOperator class

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ParserOperator(
    string name,
    char symbol,
    GH_ParserPrecedence precedence,
    GH_OperatorType type,
    string description
)
Visual Basic
Public Sub New ( _
    name As String, _
    symbol As Char, _
    precedence As GH_ParserPrecedence, _
    type As GH_OperatorType, _
    description As String _
)

Parameters

name
Type: System..::..String
symbol
Type: System..::..Char
precedence
Type: Grasshopper.Kernel.Expressions..::..GH_ParserPrecedence
type
Type: Grasshopper.Kernel.Expressions..::..GH_OperatorType
description
Type: System..::..String

See Also

GH_ParserOperator Class
Grasshopper.Kernel.Expressions Namespace


GH_ParserOperator Fields

[image] [image]

Grasshopper SDK
GH_ParserOperator Fields
GH_ParserOperator Class See Also Send Feedback

The GH_ParserOperator type exposes the following members.

Fields

 | Name | Description
Public field | m_description |
Public field | m_name |
Public field | m_precedence |
Public field | m_symbol |
Public field | m_type |

See Also

GH_ParserOperator Class
Grasshopper.Kernel.Expressions Namespace


m_description Field

[image]

Grasshopper SDK
GH_ParserOperator..::..m_description Field
GH_ParserOperator Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string m_description
Visual Basic
Public m_description As String

See Also

GH_ParserOperator Class
Grasshopper.Kernel.Expressions Namespace


m_name Field

[image]

Grasshopper SDK
GH_ParserOperator..::..m_name Field
GH_ParserOperator Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string m_name
Visual Basic
Public m_name As String

See Also

GH_ParserOperator Class
Grasshopper.Kernel.Expressions Namespace


m_precedence Field

[image]

Grasshopper SDK
GH_ParserOperator..::..m_precedence Field
GH_ParserOperator Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ParserPrecedence m_precedence
Visual Basic
Public m_precedence As GH_ParserPrecedence

See Also

GH_ParserOperator Class
Grasshopper.Kernel.Expressions Namespace


m_symbol Field

[image]

Grasshopper SDK
GH_ParserOperator..::..m_symbol Field
GH_ParserOperator Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public char m_symbol
Visual Basic
Public m_symbol As Char

See Also

GH_ParserOperator Class
Grasshopper.Kernel.Expressions Namespace


m_type Field

[image]

Grasshopper SDK
GH_ParserOperator..::..m_type Field
GH_ParserOperator Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_OperatorType m_type
Visual Basic
Public m_type As GH_OperatorType

See Also

GH_ParserOperator Class
Grasshopper.Kernel.Expressions Namespace


GH_ParserOperator Methods

[image] [image]

Grasshopper SDK
GH_ParserOperator Methods
GH_ParserOperator Class See Also Send Feedback

The GH_ParserOperator type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo |
Public method | Equals | (Overrides Object..::..Equals(Object).)

See Also

GH_ParserOperator Class
Grasshopper.Kernel.Expressions Namespace


CompareTo Method

[image]

Grasshopper SDK
GH_ParserOperator..::..CompareTo Method
GH_ParserOperator Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int CompareTo(
    GH_ParserOperator other
)
Visual Basic
Public Function CompareTo ( _
    other As GH_ParserOperator _
) As Integer

Parameters

other
Type: Grasshopper.Kernel.Expressions..::..GH_ParserOperator

Implements

IComparable<(Of <(<'T>)>)>..::..CompareTo(T)

See Also

GH_ParserOperator Class
Grasshopper.Kernel.Expressions Namespace


Equals Method

[image]

Grasshopper SDK
GH_ParserOperator..::..Equals Method
GH_ParserOperator Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object

See Also

GH_ParserOperator Class
Grasshopper.Kernel.Expressions Namespace


GH_ParserPrecedence Enumeration

[image]

Grasshopper SDK
GH_ParserPrecedence Enumeration
See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_ParserPrecedence
Visual Basic
Public Enumeration GH_ParserPrecedence

Members

Member name | Value | Description
Invalid | -1 |
None | 0 |
Level0 | 1 |
Level1 | 2 |
Level2 | 3 |
Level3 | 4 |
Level4 | 5 |
Level5 | 6 |

See Also

Grasshopper.Kernel.Expressions Namespace


GH_ParserSymbol Class

[image]

Grasshopper SDK
GH_ParserSymbol Class
Members See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_ParserSymbol : IComparable<GH_ParserSymbol>
Visual Basic
Public Class GH_ParserSymbol _
    Implements IComparable(Of GH_ParserSymbol)

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Expressions..::..GH_ParserSymbol

See Also

GH_ParserSymbol Members
Grasshopper.Kernel.Expressions Namespace


GH_ParserSymbol Members

[image] [image]

Grasshopper SDK
GH_ParserSymbol Members
GH_ParserSymbol Class Constructors Methods Fields See Also Send Feedback

The GH_ParserSymbol type exposes the following members.

Constructors

 | Name | Description
Public method | GH_ParserSymbol()()()() | Initializes a new instance of the GH_ParserSymbol class
Public method | GH_ParserSymbol(String, GH_ParserTokenClass, GH_ParserPrecedence) | Initializes a new instance of the GH_ParserSymbol class

Methods

 | Name | Description
Public method | CompareTo |
Public method | Equals | (Overrides Object..::..Equals(Object).)
Public method | ToString | (Overrides Object..::..ToString()()()().)

Fields

 | Name | Description
Public field | m_class |
Public field | m_level |
Public field | m_token |

See Also

GH_ParserSymbol Class
Grasshopper.Kernel.Expressions Namespace


GH_ParserSymbol Constructor

[image] [image]

Grasshopper SDK
GH_ParserSymbol Constructor
GH_ParserSymbol Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_ParserSymbol()()()() | Initializes a new instance of the GH_ParserSymbol class
Public method | GH_ParserSymbol(String, GH_ParserTokenClass, GH_ParserPrecedence) | Initializes a new instance of the GH_ParserSymbol class

See Also

GH_ParserSymbol Class
GH_ParserSymbol Members
Grasshopper.Kernel.Expressions Namespace


GH_ParserSymbol Constructor

[image]

Grasshopper SDK
GH_ParserSymbol Constructor
GH_ParserSymbol Class See Also Send Feedback
Initializes a new instance of the GH_ParserSymbol class

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ParserSymbol()
Visual Basic
Public Sub New

See Also

GH_ParserSymbol Class
GH_ParserSymbol Overload
Grasshopper.Kernel.Expressions Namespace


GH_ParserSymbol Constructor (String, GH_ParserTokenClass, GH_ParserPrecedence)

[image]

Grasshopper SDK
GH_ParserSymbol Constructor (String, GH_ParserTokenClass, GH_ParserPrecedence)
GH_ParserSymbol Class See Also Send Feedback
Initializes a new instance of the GH_ParserSymbol class

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ParserSymbol(
    string token,
    GH_ParserTokenClass class,
    GH_ParserPrecedence level
)
Visual Basic
Public Sub New ( _
    token As String, _
    class As GH_ParserTokenClass, _
    level As GH_ParserPrecedence _
)

Parameters

token
Type: System..::..String
class
Type: Grasshopper.Kernel.Expressions..::..GH_ParserTokenClass
level
Type: Grasshopper.Kernel.Expressions..::..GH_ParserPrecedence

See Also

GH_ParserSymbol Class
GH_ParserSymbol Overload
Grasshopper.Kernel.Expressions Namespace


GH_ParserSymbol Fields

[image] [image]

Grasshopper SDK
GH_ParserSymbol Fields
GH_ParserSymbol Class See Also Send Feedback

The GH_ParserSymbol type exposes the following members.

Fields

 | Name | Description
Public field | m_class |
Public field | m_level |
Public field | m_token |

See Also

GH_ParserSymbol Class
Grasshopper.Kernel.Expressions Namespace


m_class Field

[image]

Grasshopper SDK
GH_ParserSymbol..::..m_class Field
GH_ParserSymbol Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ParserTokenClass m_class
Visual Basic
Public m_class As GH_ParserTokenClass

See Also

GH_ParserSymbol Class
Grasshopper.Kernel.Expressions Namespace


m_level Field

[image]

Grasshopper SDK
GH_ParserSymbol..::..m_level Field
GH_ParserSymbol Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ParserPrecedence m_level
Visual Basic
Public m_level As GH_ParserPrecedence

See Also

GH_ParserSymbol Class
Grasshopper.Kernel.Expressions Namespace


m_token Field

[image]

Grasshopper SDK
GH_ParserSymbol..::..m_token Field
GH_ParserSymbol Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string m_token
Visual Basic
Public m_token As String

See Also

GH_ParserSymbol Class
Grasshopper.Kernel.Expressions Namespace


GH_ParserSymbol Methods

[image] [image]

Grasshopper SDK
GH_ParserSymbol Methods
GH_ParserSymbol Class See Also Send Feedback

The GH_ParserSymbol type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo |
Public method | Equals | (Overrides Object..::..Equals(Object).)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

GH_ParserSymbol Class
Grasshopper.Kernel.Expressions Namespace


CompareTo Method

[image]

Grasshopper SDK
GH_ParserSymbol..::..CompareTo Method
GH_ParserSymbol Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int CompareTo(
    GH_ParserSymbol other
)
Visual Basic
Public Function CompareTo ( _
    other As GH_ParserSymbol _
) As Integer

Parameters

other
Type: Grasshopper.Kernel.Expressions..::..GH_ParserSymbol

Implements

IComparable<(Of <(<'T>)>)>..::..CompareTo(T)

See Also

GH_ParserSymbol Class
Grasshopper.Kernel.Expressions Namespace


Equals Method

[image]

Grasshopper SDK
GH_ParserSymbol..::..Equals Method
GH_ParserSymbol Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object

See Also

GH_ParserSymbol Class
Grasshopper.Kernel.Expressions Namespace


ToString Method

[image]

Grasshopper SDK
GH_ParserSymbol..::..ToString Method
GH_ParserSymbol Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_ParserSymbol Class
Grasshopper.Kernel.Expressions Namespace


GH_ParserTokenClass Enumeration

[image]

Grasshopper SDK
GH_ParserTokenClass Enumeration
See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_ParserTokenClass
Visual Basic
Public Enumeration GH_ParserTokenClass

Members

Member name | Value | Description
Keyword | 1 |
Identifier | 2 |
Numeric | 3 |
Literal | 4 |
Operator | 5 |
Punctuation | 6 |

See Also

Grasshopper.Kernel.Expressions Namespace


GH_ScriptVariant Class

[image]

Grasshopper SDK
GH_ScriptVariant Class
Members See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_ScriptVariant
Visual Basic
Public Class GH_ScriptVariant

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Expressions..::..GH_ScriptVariant

See Also

GH_ScriptVariant Members
Grasshopper.Kernel.Expressions Namespace


GH_ScriptVariant Members

[image] [image]

Grasshopper SDK
GH_ScriptVariant Members
GH_ScriptVariant Class Constructors Methods Operators Fields Properties See Also Send Feedback

The GH_ScriptVariant type exposes the following members.

Constructors

 | Name | Description
Public method | GH_ScriptVariant()()()() | Initializes a new instance of the GH_ScriptVariant class
Public method | GH_ScriptVariant(Plane) | Initializes a new instance of the GH_ScriptVariant class
Public method | GH_ScriptVariant(Point3d) | Initializes a new instance of the GH_ScriptVariant class
Public method | GH_ScriptVariant(Vector3d) | Initializes a new instance of the GH_ScriptVariant class
Public method | GH_ScriptVariant(Boolean) | Initializes a new instance of the GH_ScriptVariant class
Public method | GH_ScriptVariant(Byte) | Initializes a new instance of the GH_ScriptVariant class
Public method | GH_ScriptVariant(DateTime) | Initializes a new instance of the GH_ScriptVariant class
Public method | GH_ScriptVariant(Double) | Initializes a new instance of the GH_ScriptVariant class
Public method | GH_ScriptVariant(Int32) | Initializes a new instance of the GH_ScriptVariant class
Public method | GH_ScriptVariant(String) | Initializes a new instance of the GH_ScriptVariant class

Methods

 | Name | Description
 | ThrowNullOperatorException |
 | ThrowOperatorException(String, GH_ScriptVariantType) |
 | ThrowOperatorException(String, String) |
 | ThrowOperatorException(String, GH_ScriptVariantType, GH_ScriptVariantType) |
 | ThrowOperatorException(String, String, String) |
Public method | ToString | (Overrides Object..::..ToString()()()().)

Operators

Name | Description
Addition |
BitwiseAnd |
BitwiseOr |
Concatenate |
Division |
Equality |
ExclusiveOr |
ExplicitNarrowingExplicitExplicitExplicit(GH_ScriptVariant to Vector3d) |
ExplicitNarrowingExplicitExplicitExplicit(GH_ScriptVariant to Int32) |
ExplicitNarrowingExplicitExplicitExplicit(GH_ScriptVariant to Boolean) |
ExplicitNarrowingExplicitExplicitExplicit(GH_ScriptVariant to Plane) |
ExplicitNarrowingExplicitExplicitExplicit(GH_ScriptVariant to Point3d) |
ExplicitNarrowingExplicitExplicitExplicit(GH_ScriptVariant to DateTime) |
ExplicitNarrowingExplicitExplicitExplicit(GH_ScriptVariant to Double) |
ExplicitNarrowingExplicitExplicitExplicit(GH_ScriptVariant to String) |
Exponent |
False |
GreaterThan |
GreaterThanOrEqual |
ImplicitWideningImplicitImplicitImplicit(Plane to GH_ScriptVariant) |
ImplicitWideningImplicitImplicitImplicit(Point3d to GH_ScriptVariant) |
ImplicitWideningImplicitImplicitImplicit(Vector3d to GH_ScriptVariant) |
ImplicitWideningImplicitImplicitImplicit(Boolean to GH_ScriptVariant) |
ImplicitWideningImplicitImplicitImplicit(DateTime to GH_ScriptVariant) |
ImplicitWideningImplicitImplicitImplicit(Double to GH_ScriptVariant) |
ImplicitWideningImplicitImplicitImplicit(Int32 to GH_ScriptVariant) |
ImplicitWideningImplicitImplicitImplicit(String to GH_ScriptVariant) |
Inequality |
IntegerDivision |
LeftShift |
LessThan |
LessThanOrEqual |
Modulus |
Multiply |
OnesComplement |
RightShift |
Subtraction |
True |
UnaryNegation |
UnaryPlus |

Fields

 | Name | Description
Protected field | m_type |
Protected field | m_value |

Properties

 | Name | Description
Public property | Boolean |
Public property | DateTime |
Public property | Double |
Public property | Integer |
Public property | Object |
Public property | Plane |
Public property | Point |
Public property | String |
Public property | Type |
Public property | Vector |

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


GH_ScriptVariant Constructor

[image] [image]

Grasshopper SDK
GH_ScriptVariant Constructor
GH_ScriptVariant Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_ScriptVariant()()()() | Initializes a new instance of the GH_ScriptVariant class
Public method | GH_ScriptVariant(Plane) | Initializes a new instance of the GH_ScriptVariant class
Public method | GH_ScriptVariant(Point3d) | Initializes a new instance of the GH_ScriptVariant class
Public method | GH_ScriptVariant(Vector3d) | Initializes a new instance of the GH_ScriptVariant class
Public method | GH_ScriptVariant(Boolean) | Initializes a new instance of the GH_ScriptVariant class
Public method | GH_ScriptVariant(Byte) | Initializes a new instance of the GH_ScriptVariant class
Public method | GH_ScriptVariant(DateTime) | Initializes a new instance of the GH_ScriptVariant class
Public method | GH_ScriptVariant(Double) | Initializes a new instance of the GH_ScriptVariant class
Public method | GH_ScriptVariant(Int32) | Initializes a new instance of the GH_ScriptVariant class
Public method | GH_ScriptVariant(String) | Initializes a new instance of the GH_ScriptVariant class

See Also

GH_ScriptVariant Class
GH_ScriptVariant Members
Grasshopper.Kernel.Expressions Namespace


GH_ScriptVariant Constructor

[image]

Grasshopper SDK
GH_ScriptVariant Constructor
GH_ScriptVariant Class See Also Send Feedback
Initializes a new instance of the GH_ScriptVariant class

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ScriptVariant()
Visual Basic
Public Sub New

See Also

GH_ScriptVariant Class
GH_ScriptVariant Overload
Grasshopper.Kernel.Expressions Namespace


GH_ScriptVariant Constructor ()

[image]

Grasshopper SDK
GH_ScriptVariant Constructor ()
GH_ScriptVariant Class See Also Send Feedback
Initializes a new instance of the GH_ScriptVariant class

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ScriptVariant(
    Plane val
)
Visual Basic
Public Sub New ( _
    val As Plane _
)

Parameters

val
Type: Plane

See Also

GH_ScriptVariant Class
GH_ScriptVariant Overload
Grasshopper.Kernel.Expressions Namespace


GH_ScriptVariant Constructor ()

[image]

Grasshopper SDK
GH_ScriptVariant Constructor ()
GH_ScriptVariant Class See Also Send Feedback
Initializes a new instance of the GH_ScriptVariant class

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ScriptVariant(
    Point3d val
)
Visual Basic
Public Sub New ( _
    val As Point3d _
)

Parameters

val
Type: Point3d

See Also

GH_ScriptVariant Class
GH_ScriptVariant Overload
Grasshopper.Kernel.Expressions Namespace


GH_ScriptVariant Constructor ()

[image]

Grasshopper SDK
GH_ScriptVariant Constructor ()
GH_ScriptVariant Class See Also Send Feedback
Initializes a new instance of the GH_ScriptVariant class

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ScriptVariant(
    Vector3d val
)
Visual Basic
Public Sub New ( _
    val As Vector3d _
)

Parameters

val
Type: Vector3d

See Also

GH_ScriptVariant Class
GH_ScriptVariant Overload
Grasshopper.Kernel.Expressions Namespace


GH_ScriptVariant Constructor (Boolean)

[image]

Grasshopper SDK
GH_ScriptVariant Constructor (Boolean)
GH_ScriptVariant Class See Also Send Feedback
Initializes a new instance of the GH_ScriptVariant class

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ScriptVariant(
    bool val
)
Visual Basic
Public Sub New ( _
    val As Boolean _
)

Parameters

val
Type: System..::..Boolean

See Also

GH_ScriptVariant Class
GH_ScriptVariant Overload
Grasshopper.Kernel.Expressions Namespace


GH_ScriptVariant Constructor (Byte)

[image]

Grasshopper SDK
GH_ScriptVariant Constructor (Byte)
GH_ScriptVariant Class See Also Send Feedback
Initializes a new instance of the GH_ScriptVariant class

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ScriptVariant(
    byte val
)
Visual Basic
Public Sub New ( _
    val As Byte _
)

Parameters

val
Type: System..::..Byte

See Also

GH_ScriptVariant Class
GH_ScriptVariant Overload
Grasshopper.Kernel.Expressions Namespace


GH_ScriptVariant Constructor (DateTime)

[image]

Grasshopper SDK
GH_ScriptVariant Constructor (DateTime)
GH_ScriptVariant Class See Also Send Feedback
Initializes a new instance of the GH_ScriptVariant class

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ScriptVariant(
    DateTime val
)
Visual Basic
Public Sub New ( _
    val As DateTime _
)

Parameters

val
Type: System..::..DateTime

See Also

GH_ScriptVariant Class
GH_ScriptVariant Overload
Grasshopper.Kernel.Expressions Namespace


GH_ScriptVariant Constructor (Double)

[image]

Grasshopper SDK
GH_ScriptVariant Constructor (Double)
GH_ScriptVariant Class See Also Send Feedback
Initializes a new instance of the GH_ScriptVariant class

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ScriptVariant(
    double val
)
Visual Basic
Public Sub New ( _
    val As Double _
)

Parameters

val
Type: System..::..Double

See Also

GH_ScriptVariant Class
GH_ScriptVariant Overload
Grasshopper.Kernel.Expressions Namespace


GH_ScriptVariant Constructor (Int32)

[image]

Grasshopper SDK
GH_ScriptVariant Constructor (Int32)
GH_ScriptVariant Class See Also Send Feedback
Initializes a new instance of the GH_ScriptVariant class

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ScriptVariant(
    int val
)
Visual Basic
Public Sub New ( _
    val As Integer _
)

Parameters

val
Type: System..::..Int32

See Also

GH_ScriptVariant Class
GH_ScriptVariant Overload
Grasshopper.Kernel.Expressions Namespace


GH_ScriptVariant Constructor (String)

[image]

Grasshopper SDK
GH_ScriptVariant Constructor (String)
GH_ScriptVariant Class See Also Send Feedback
Initializes a new instance of the GH_ScriptVariant class

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ScriptVariant(
    string val
)
Visual Basic
Public Sub New ( _
    val As String _
)

Parameters

val
Type: System..::..String

See Also

GH_ScriptVariant Class
GH_ScriptVariant Overload
Grasshopper.Kernel.Expressions Namespace


GH_ScriptVariant Fields

[image] [image]

Grasshopper SDK
GH_ScriptVariant Fields
GH_ScriptVariant Class See Also Send Feedback

The GH_ScriptVariant type exposes the following members.

Fields

 | Name | Description
Protected field | m_type |
Protected field | m_value |

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


m_type Field

[image]

Grasshopper SDK
GH_ScriptVariant..::..m_type Field
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_ScriptVariantType m_type
Visual Basic
Protected m_type As GH_ScriptVariantType

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


m_value Field

[image]

Grasshopper SDK
GH_ScriptVariant..::..m_value Field
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected Object m_value
Visual Basic
Protected m_value As Object

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


GH_ScriptVariant Methods

[image] [image]

Grasshopper SDK
GH_ScriptVariant Methods
GH_ScriptVariant Class See Also Send Feedback

The GH_ScriptVariant type exposes the following members.

Methods

 | Name | Description
 | ThrowNullOperatorException |
 | ThrowOperatorException(String, GH_ScriptVariantType) |
 | ThrowOperatorException(String, String) |
 | ThrowOperatorException(String, GH_ScriptVariantType, GH_ScriptVariantType) |
 | ThrowOperatorException(String, String, String) |
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


ThrowNullOperatorException Method

[image]

Grasshopper SDK
GH_ScriptVariant..::..ThrowNullOperatorException Method
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected static void ThrowNullOperatorException(
    string sName
)
Visual Basic
Protected Shared Sub ThrowNullOperatorException ( _
    sName As String _
)

Parameters

sName
Type: System..::..String

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


ThrowOperatorException Method

[image] [image]

Grasshopper SDK
GH_ScriptVariant..::..ThrowOperatorException Method
GH_ScriptVariant Class See Also Send Feedback

Overload List

Name | Description
ThrowOperatorException(String, GH_ScriptVariantType) |
ThrowOperatorException(String, String) |
ThrowOperatorException(String, GH_ScriptVariantType, GH_ScriptVariantType) |
ThrowOperatorException(String, String, String) |

See Also

GH_ScriptVariant Class
GH_ScriptVariant Members
Grasshopper.Kernel.Expressions Namespace


ThrowOperatorException Method (String, GH_ScriptVariantType)

[image]

Grasshopper SDK
GH_ScriptVariant..::..ThrowOperatorException Method (String, GH_ScriptVariantType)
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected static void ThrowOperatorException(
    string op_name,
    GH_ScriptVariantType A
)
Visual Basic
Protected Shared Sub ThrowOperatorException ( _
    op_name As String, _
    A As GH_ScriptVariantType _
)

Parameters

op_name
Type: System..::..String
A
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariantType

See Also

GH_ScriptVariant Class
ThrowOperatorException Overload
Grasshopper.Kernel.Expressions Namespace


ThrowOperatorException Method (String, String)

[image]

Grasshopper SDK
GH_ScriptVariant..::..ThrowOperatorException Method (String, String)
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected static void ThrowOperatorException(
    string op_name,
    string A
)
Visual Basic
Protected Shared Sub ThrowOperatorException ( _
    op_name As String, _
    A As String _
)

Parameters

op_name
Type: System..::..String
A
Type: System..::..String

See Also

GH_ScriptVariant Class
ThrowOperatorException Overload
Grasshopper.Kernel.Expressions Namespace


ThrowOperatorException Method (String, GH_ScriptVariantType, GH_ScriptVariantType)

[image]

Grasshopper SDK
GH_ScriptVariant..::..ThrowOperatorException Method (String, GH_ScriptVariantType, GH_ScriptVariantType)
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected static void ThrowOperatorException(
    string op_name,
    GH_ScriptVariantType A,
    GH_ScriptVariantType B
)
Visual Basic
Protected Shared Sub ThrowOperatorException ( _
    op_name As String, _
    A As GH_ScriptVariantType, _
    B As GH_ScriptVariantType _
)

Parameters

op_name
Type: System..::..String
A
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariantType
B
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariantType

See Also

GH_ScriptVariant Class
ThrowOperatorException Overload
Grasshopper.Kernel.Expressions Namespace


ThrowOperatorException Method (String, String, String)

[image]

Grasshopper SDK
GH_ScriptVariant..::..ThrowOperatorException Method (String, String, String)
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected static void ThrowOperatorException(
    string op_name,
    string A,
    string B
)
Visual Basic
Protected Shared Sub ThrowOperatorException ( _
    op_name As String, _
    A As String, _
    B As String _
)

Parameters

op_name
Type: System..::..String
A
Type: System..::..String
B
Type: System..::..String

See Also

GH_ScriptVariant Class
ThrowOperatorException Overload
Grasshopper.Kernel.Expressions Namespace


ToString Method

[image]

Grasshopper SDK
GH_ScriptVariant..::..ToString Method
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


GH_ScriptVariant Operators and Type Conversions

[image] [image]

Grasshopper SDK
GH_ScriptVariant Operators and Type Conversions
GH_ScriptVariant Class See Also Send Feedback

The GH_ScriptVariant type exposes the following members.

Operators

Name | Description
Addition |
BitwiseAnd |
BitwiseOr |
Concatenate |
Division |
Equality |
ExclusiveOr |
ExplicitNarrowingExplicitExplicitExplicit(GH_ScriptVariant to Vector3d) |
ExplicitNarrowingExplicitExplicitExplicit(GH_ScriptVariant to Int32) |
ExplicitNarrowingExplicitExplicitExplicit(GH_ScriptVariant to Boolean) |
ExplicitNarrowingExplicitExplicitExplicit(GH_ScriptVariant to Plane) |
ExplicitNarrowingExplicitExplicitExplicit(GH_ScriptVariant to Point3d) |
ExplicitNarrowingExplicitExplicitExplicit(GH_ScriptVariant to DateTime) |
ExplicitNarrowingExplicitExplicitExplicit(GH_ScriptVariant to Double) |
ExplicitNarrowingExplicitExplicitExplicit(GH_ScriptVariant to String) |
Exponent |
False |
GreaterThan |
GreaterThanOrEqual |
ImplicitWideningImplicitImplicitImplicit(Plane to GH_ScriptVariant) |
ImplicitWideningImplicitImplicitImplicit(Point3d to GH_ScriptVariant) |
ImplicitWideningImplicitImplicitImplicit(Vector3d to GH_ScriptVariant) |
ImplicitWideningImplicitImplicitImplicit(Boolean to GH_ScriptVariant) |
ImplicitWideningImplicitImplicitImplicit(DateTime to GH_ScriptVariant) |
ImplicitWideningImplicitImplicitImplicit(Double to GH_ScriptVariant) |
ImplicitWideningImplicitImplicitImplicit(Int32 to GH_ScriptVariant) |
ImplicitWideningImplicitImplicitImplicit(String to GH_ScriptVariant) |
Inequality |
IntegerDivision |
LeftShift |
LessThan |
LessThanOrEqual |
Modulus |
Multiply |
OnesComplement |
RightShift |
Subtraction |
True |
UnaryNegation |
UnaryPlus |

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


Addition Operator

[image]

Grasshopper SDK
GH_ScriptVariant..::..Addition Operator
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_ScriptVariant operator +(
    GH_ScriptVariant A,
    GH_ScriptVariant B
)
Visual Basic
Public Shared Operator + ( _
    A As GH_ScriptVariant, _
    B As GH_ScriptVariant _
) As GH_ScriptVariant

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant
B
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


BitwiseAnd Operator

[image]

Grasshopper SDK
GH_ScriptVariant..::..BitwiseAnd Operator
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool operator &(
    GH_ScriptVariant A,
    GH_ScriptVariant B
)
Visual Basic
Public Shared Operator And ( _
    A As GH_ScriptVariant, _
    B As GH_ScriptVariant _
) As Boolean

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant
B
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


BitwiseOr Operator

[image]

Grasshopper SDK
GH_ScriptVariant..::..BitwiseOr Operator
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool operator |(
    GH_ScriptVariant A,
    GH_ScriptVariant B
)
Visual Basic
Public Shared Operator Or ( _
    A As GH_ScriptVariant, _
    B As GH_ScriptVariant _
) As Boolean

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant
B
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


Concatenate Operator

[image]

Grasshopper SDK
GH_ScriptVariant..::..Concatenate Operator
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
C# does not support this operator.
Visual Basic
Public Shared Operator & ( _
    A As GH_ScriptVariant, _
    B As GH_ScriptVariant _
) As GH_ScriptVariant

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant
B
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


Division Operator

[image]

Grasshopper SDK
GH_ScriptVariant..::..Division Operator
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_ScriptVariant operator /(
    GH_ScriptVariant A,
    GH_ScriptVariant B
)
Visual Basic
Public Shared Operator / ( _
    A As GH_ScriptVariant, _
    B As GH_ScriptVariant _
) As GH_ScriptVariant

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant
B
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


Equality Operator

[image]

Grasshopper SDK
GH_ScriptVariant..::..Equality Operator
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool operator ==(
    GH_ScriptVariant A,
    GH_ScriptVariant B
)
Visual Basic
Public Shared Operator = ( _
    A As GH_ScriptVariant, _
    B As GH_ScriptVariant _
) As Boolean

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant
B
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


ExclusiveOr Operator

[image]

Grasshopper SDK
GH_ScriptVariant..::..ExclusiveOr Operator
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool operator ^(
    GH_ScriptVariant A,
    GH_ScriptVariant B
)
Visual Basic
Public Shared Operator Xor ( _
    A As GH_ScriptVariant, _
    B As GH_ScriptVariant _
) As Boolean

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant
B
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


Explicit Conversion Operators

[image] [image]

Grasshopper SDK
GH_ScriptVariant ExplicitNarrowingExplicitExplicitExplicit Conversion Operators
GH_ScriptVariant Class See Also Send Feedback

Overload List

Name | Description
ExplicitNarrowingExplicitExplicitExplicit(GH_ScriptVariant to Vector3d) |
ExplicitNarrowingExplicitExplicitExplicit(GH_ScriptVariant to Int32) |
ExplicitNarrowingExplicitExplicitExplicit(GH_ScriptVariant to Boolean) |
ExplicitNarrowingExplicitExplicitExplicit(GH_ScriptVariant to Plane) |
ExplicitNarrowingExplicitExplicitExplicit(GH_ScriptVariant to Point3d) |
ExplicitNarrowingExplicitExplicitExplicit(GH_ScriptVariant to DateTime) |
ExplicitNarrowingExplicitExplicitExplicit(GH_ScriptVariant to Double) |
ExplicitNarrowingExplicitExplicitExplicit(GH_ScriptVariant to String) |

See Also

GH_ScriptVariant Class
GH_ScriptVariant Members
Grasshopper.Kernel.Expressions Namespace


Explicit Conversion (GH_ScriptVariant to )

[image]

Grasshopper SDK
GH_ScriptVariant ExplicitNarrowingExplicitExplicitExplicit Conversion (GH_ScriptVariant to )
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static explicit operator Vector3d (
    GH_ScriptVariant in
)
Visual Basic
Public Shared Narrowing Operator CType ( _
    in As GH_ScriptVariant _
) As Vector3d

Parameters

in
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant

See Also

GH_ScriptVariant Class
ExplicitNarrowingExplicitExplicitExplicit Overload
Grasshopper.Kernel.Expressions Namespace


Explicit Conversion (GH_ScriptVariant to Int32)

[image]

Grasshopper SDK
GH_ScriptVariant ExplicitNarrowingExplicitExplicitExplicit Conversion (GH_ScriptVariant to Int32)
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static explicit operator int (
    GH_ScriptVariant in
)
Visual Basic
Public Shared Narrowing Operator CType ( _
    in As GH_ScriptVariant _
) As Integer

Parameters

in
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant

See Also

GH_ScriptVariant Class
ExplicitNarrowingExplicitExplicitExplicit Overload
Grasshopper.Kernel.Expressions Namespace


Explicit Conversion (GH_ScriptVariant to Boolean)

[image]

Grasshopper SDK
GH_ScriptVariant ExplicitNarrowingExplicitExplicitExplicit Conversion (GH_ScriptVariant to Boolean)
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static explicit operator bool (
    GH_ScriptVariant in
)
Visual Basic
Public Shared Narrowing Operator CType ( _
    in As GH_ScriptVariant _
) As Boolean

Parameters

in
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant

See Also

GH_ScriptVariant Class
ExplicitNarrowingExplicitExplicitExplicit Overload
Grasshopper.Kernel.Expressions Namespace


Explicit Conversion (GH_ScriptVariant to )

[image]

Grasshopper SDK
GH_ScriptVariant ExplicitNarrowingExplicitExplicitExplicit Conversion (GH_ScriptVariant to )
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static explicit operator Plane (
    GH_ScriptVariant in
)
Visual Basic
Public Shared Narrowing Operator CType ( _
    in As GH_ScriptVariant _
) As Plane

Parameters

in
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant

See Also

GH_ScriptVariant Class
ExplicitNarrowingExplicitExplicitExplicit Overload
Grasshopper.Kernel.Expressions Namespace


Explicit Conversion (GH_ScriptVariant to )

[image]

Grasshopper SDK
GH_ScriptVariant ExplicitNarrowingExplicitExplicitExplicit Conversion (GH_ScriptVariant to )
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static explicit operator Point3d (
    GH_ScriptVariant in
)
Visual Basic
Public Shared Narrowing Operator CType ( _
    in As GH_ScriptVariant _
) As Point3d

Parameters

in
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant

See Also

GH_ScriptVariant Class
ExplicitNarrowingExplicitExplicitExplicit Overload
Grasshopper.Kernel.Expressions Namespace


Explicit Conversion (GH_ScriptVariant to DateTime)

[image]

Grasshopper SDK
GH_ScriptVariant ExplicitNarrowingExplicitExplicitExplicit Conversion (GH_ScriptVariant to DateTime)
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static explicit operator DateTime (
    GH_ScriptVariant in
)
Visual Basic
Public Shared Narrowing Operator CType ( _
    in As GH_ScriptVariant _
) As DateTime

Parameters

in
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant

See Also

GH_ScriptVariant Class
ExplicitNarrowingExplicitExplicitExplicit Overload
Grasshopper.Kernel.Expressions Namespace


Explicit Conversion (GH_ScriptVariant to Double)

[image]

Grasshopper SDK
GH_ScriptVariant ExplicitNarrowingExplicitExplicitExplicit Conversion (GH_ScriptVariant to Double)
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static explicit operator double (
    GH_ScriptVariant in
)
Visual Basic
Public Shared Narrowing Operator CType ( _
    in As GH_ScriptVariant _
) As Double

Parameters

in
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant

See Also

GH_ScriptVariant Class
ExplicitNarrowingExplicitExplicitExplicit Overload
Grasshopper.Kernel.Expressions Namespace


Explicit Conversion (GH_ScriptVariant to String)

[image]

Grasshopper SDK
GH_ScriptVariant ExplicitNarrowingExplicitExplicitExplicit Conversion (GH_ScriptVariant to String)
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static explicit operator string (
    GH_ScriptVariant in
)
Visual Basic
Public Shared Narrowing Operator CType ( _
    in As GH_ScriptVariant _
) As String

Parameters

in
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant

See Also

GH_ScriptVariant Class
ExplicitNarrowingExplicitExplicitExplicit Overload
Grasshopper.Kernel.Expressions Namespace


Exponent Operator

[image]

Grasshopper SDK
GH_ScriptVariant..::..Exponent Operator
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
C# does not support this operator.
Visual Basic
Public Shared Operator ^ ( _
    A As GH_ScriptVariant, _
    B As GH_ScriptVariant _
) As GH_ScriptVariant

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant
B
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


False Operator

[image]

Grasshopper SDK
GH_ScriptVariant..::..False Operator
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool operator false(
    GH_ScriptVariant A
)
Visual Basic
Public Shared Operator IsFalse ( _
    A As GH_ScriptVariant _
) As Boolean

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


GreaterThan Operator

[image]

Grasshopper SDK
GH_ScriptVariant..::..GreaterThan Operator
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool operator >(
    GH_ScriptVariant A,
    GH_ScriptVariant B
)
Visual Basic
Public Shared Operator > ( _
    A As GH_ScriptVariant, _
    B As GH_ScriptVariant _
) As Boolean

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant
B
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


GreaterThanOrEqual Operator

[image]

Grasshopper SDK
GH_ScriptVariant..::..GreaterThanOrEqual Operator
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool operator >=(
    GH_ScriptVariant A,
    GH_ScriptVariant B
)
Visual Basic
Public Shared Operator >= ( _
    A As GH_ScriptVariant, _
    B As GH_ScriptVariant _
) As Boolean

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant
B
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


Implicit Conversion Operators

[image] [image]

Grasshopper SDK
GH_ScriptVariant ImplicitWideningImplicitImplicitImplicit Conversion Operators
GH_ScriptVariant Class See Also Send Feedback

Overload List

Name | Description
ImplicitWideningImplicitImplicitImplicit(Plane to GH_ScriptVariant) |
ImplicitWideningImplicitImplicitImplicit(Point3d to GH_ScriptVariant) |
ImplicitWideningImplicitImplicitImplicit(Vector3d to GH_ScriptVariant) |
ImplicitWideningImplicitImplicitImplicit(Boolean to GH_ScriptVariant) |
ImplicitWideningImplicitImplicitImplicit(DateTime to GH_ScriptVariant) |
ImplicitWideningImplicitImplicitImplicit(Double to GH_ScriptVariant) |
ImplicitWideningImplicitImplicitImplicit(Int32 to GH_ScriptVariant) |
ImplicitWideningImplicitImplicitImplicit(String to GH_ScriptVariant) |

See Also

GH_ScriptVariant Class
GH_ScriptVariant Members
Grasshopper.Kernel.Expressions Namespace


Implicit Conversion ( to GH_ScriptVariant)

[image]

Grasshopper SDK
GH_ScriptVariant ImplicitWideningImplicitImplicitImplicit Conversion ( to GH_ScriptVariant)
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static implicit operator GH_ScriptVariant (
    Plane in
)
Visual Basic
Public Shared Widening Operator CType ( _
    in As Plane _
) As GH_ScriptVariant

Parameters

in
Type: Plane

See Also

GH_ScriptVariant Class
ImplicitWideningImplicitImplicitImplicit Overload
Grasshopper.Kernel.Expressions Namespace


Implicit Conversion ( to GH_ScriptVariant)

[image]

Grasshopper SDK
GH_ScriptVariant ImplicitWideningImplicitImplicitImplicit Conversion ( to GH_ScriptVariant)
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static implicit operator GH_ScriptVariant (
    Point3d in
)
Visual Basic
Public Shared Widening Operator CType ( _
    in As Point3d _
) As GH_ScriptVariant

Parameters

in
Type: Point3d

See Also

GH_ScriptVariant Class
ImplicitWideningImplicitImplicitImplicit Overload
Grasshopper.Kernel.Expressions Namespace


Implicit Conversion ( to GH_ScriptVariant)

[image]

Grasshopper SDK
GH_ScriptVariant ImplicitWideningImplicitImplicitImplicit Conversion ( to GH_ScriptVariant)
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static implicit operator GH_ScriptVariant (
    Vector3d in
)
Visual Basic
Public Shared Widening Operator CType ( _
    in As Vector3d _
) As GH_ScriptVariant

Parameters

in
Type: Vector3d

See Also

GH_ScriptVariant Class
ImplicitWideningImplicitImplicitImplicit Overload
Grasshopper.Kernel.Expressions Namespace


Implicit Conversion (Boolean to GH_ScriptVariant)

[image]

Grasshopper SDK
GH_ScriptVariant ImplicitWideningImplicitImplicitImplicit Conversion (Boolean to GH_ScriptVariant)
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static implicit operator GH_ScriptVariant (
    bool in
)
Visual Basic
Public Shared Widening Operator CType ( _
    in As Boolean _
) As GH_ScriptVariant

Parameters

in
Type: System..::..Boolean

See Also

GH_ScriptVariant Class
ImplicitWideningImplicitImplicitImplicit Overload
Grasshopper.Kernel.Expressions Namespace


Implicit Conversion (DateTime to GH_ScriptVariant)

[image]

Grasshopper SDK
GH_ScriptVariant ImplicitWideningImplicitImplicitImplicit Conversion (DateTime to GH_ScriptVariant)
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static implicit operator GH_ScriptVariant (
    DateTime in
)
Visual Basic
Public Shared Widening Operator CType ( _
    in As DateTime _
) As GH_ScriptVariant

Parameters

in
Type: System..::..DateTime

See Also

GH_ScriptVariant Class
ImplicitWideningImplicitImplicitImplicit Overload
Grasshopper.Kernel.Expressions Namespace


Implicit Conversion (Double to GH_ScriptVariant)

[image]

Grasshopper SDK
GH_ScriptVariant ImplicitWideningImplicitImplicitImplicit Conversion (Double to GH_ScriptVariant)
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static implicit operator GH_ScriptVariant (
    double in
)
Visual Basic
Public Shared Widening Operator CType ( _
    in As Double _
) As GH_ScriptVariant

Parameters

in
Type: System..::..Double

See Also

GH_ScriptVariant Class
ImplicitWideningImplicitImplicitImplicit Overload
Grasshopper.Kernel.Expressions Namespace


Implicit Conversion (Int32 to GH_ScriptVariant)

[image]

Grasshopper SDK
GH_ScriptVariant ImplicitWideningImplicitImplicitImplicit Conversion (Int32 to GH_ScriptVariant)
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static implicit operator GH_ScriptVariant (
    int in
)
Visual Basic
Public Shared Widening Operator CType ( _
    in As Integer _
) As GH_ScriptVariant

Parameters

in
Type: System..::..Int32

See Also

GH_ScriptVariant Class
ImplicitWideningImplicitImplicitImplicit Overload
Grasshopper.Kernel.Expressions Namespace


Implicit Conversion (String to GH_ScriptVariant)

[image]

Grasshopper SDK
GH_ScriptVariant ImplicitWideningImplicitImplicitImplicit Conversion (String to GH_ScriptVariant)
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static implicit operator GH_ScriptVariant (
    string in
)
Visual Basic
Public Shared Widening Operator CType ( _
    in As String _
) As GH_ScriptVariant

Parameters

in
Type: System..::..String

See Also

GH_ScriptVariant Class
ImplicitWideningImplicitImplicitImplicit Overload
Grasshopper.Kernel.Expressions Namespace


Inequality Operator

[image]

Grasshopper SDK
GH_ScriptVariant..::..Inequality Operator
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool operator !=(
    GH_ScriptVariant A,
    GH_ScriptVariant B
)
Visual Basic
Public Shared Operator <> ( _
    A As GH_ScriptVariant, _
    B As GH_ScriptVariant _
) As Boolean

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant
B
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


IntegerDivision Operator

[image]

Grasshopper SDK
GH_ScriptVariant..::..IntegerDivision Operator
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
C# does not support this operator.
Visual Basic
Public Shared Operator \ ( _
    A As GH_ScriptVariant, _
    B As GH_ScriptVariant _
) As GH_ScriptVariant

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant
B
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


LeftShift Operator

[image]

Grasshopper SDK
GH_ScriptVariant..::..LeftShift Operator
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_ScriptVariant operator <<(
    GH_ScriptVariant A,
    int B
)
Visual Basic
Public Shared Operator << ( _
    A As GH_ScriptVariant, _
    B As Integer _
) As GH_ScriptVariant

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant
B
Type: System..::..Int32

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


LessThan Operator

[image]

Grasshopper SDK
GH_ScriptVariant..::..LessThan Operator
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool operator <(
    GH_ScriptVariant A,
    GH_ScriptVariant B
)
Visual Basic
Public Shared Operator < ( _
    A As GH_ScriptVariant, _
    B As GH_ScriptVariant _
) As Boolean

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant
B
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


LessThanOrEqual Operator

[image]

Grasshopper SDK
GH_ScriptVariant..::..LessThanOrEqual Operator
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool operator <=(
    GH_ScriptVariant A,
    GH_ScriptVariant B
)
Visual Basic
Public Shared Operator <= ( _
    A As GH_ScriptVariant, _
    B As GH_ScriptVariant _
) As Boolean

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant
B
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


Modulus Operator

[image]

Grasshopper SDK
GH_ScriptVariant..::..Modulus Operator
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_ScriptVariant operator %(
    GH_ScriptVariant A,
    GH_ScriptVariant B
)
Visual Basic
Public Shared Operator Mod ( _
    A As GH_ScriptVariant, _
    B As GH_ScriptVariant _
) As GH_ScriptVariant

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant
B
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


Multiply Operator

[image]

Grasshopper SDK
GH_ScriptVariant..::..Multiply Operator
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_ScriptVariant operator *(
    GH_ScriptVariant A,
    GH_ScriptVariant B
)
Visual Basic
Public Shared Operator * ( _
    A As GH_ScriptVariant, _
    B As GH_ScriptVariant _
) As GH_ScriptVariant

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant
B
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


OnesComplement Operator

[image]

Grasshopper SDK
GH_ScriptVariant..::..OnesComplement Operator
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_ScriptVariant operator ~(
    GH_ScriptVariant A
)
Visual Basic
Public Shared Operator ~ ( _
    A As GH_ScriptVariant _
) As GH_ScriptVariant

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


RightShift Operator

[image]

Grasshopper SDK
GH_ScriptVariant..::..RightShift Operator
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_ScriptVariant operator >>(
    GH_ScriptVariant A,
    int B
)
Visual Basic
Public Shared Operator >> ( _
    A As GH_ScriptVariant, _
    B As Integer _
) As GH_ScriptVariant

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant
B
Type: System..::..Int32

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


Subtraction Operator

[image]

Grasshopper SDK
GH_ScriptVariant..::..Subtraction Operator
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_ScriptVariant operator -(
    GH_ScriptVariant A,
    GH_ScriptVariant B
)
Visual Basic
Public Shared Operator - ( _
    A As GH_ScriptVariant, _
    B As GH_ScriptVariant _
) As GH_ScriptVariant

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant
B
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


True Operator

[image]

Grasshopper SDK
GH_ScriptVariant..::..True Operator
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool operator true(
    GH_ScriptVariant A
)
Visual Basic
Public Shared Operator IsTrue ( _
    A As GH_ScriptVariant _
) As Boolean

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


UnaryNegation Operator

[image]

Grasshopper SDK
GH_ScriptVariant..::..UnaryNegation Operator
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_ScriptVariant operator -(
    GH_ScriptVariant A
)
Visual Basic
Public Shared Operator - ( _
    A As GH_ScriptVariant _
) As GH_ScriptVariant

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


UnaryPlus Operator

[image]

Grasshopper SDK
GH_ScriptVariant..::..UnaryPlus Operator
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static GH_ScriptVariant operator +(
    GH_ScriptVariant A
)
Visual Basic
Public Shared Operator + ( _
    A As GH_ScriptVariant _
) As GH_ScriptVariant

Parameters

A
Type: Grasshopper.Kernel.Expressions..::..GH_ScriptVariant

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


GH_ScriptVariant Properties

[image] [image]

Grasshopper SDK
GH_ScriptVariant Properties
GH_ScriptVariant Class See Also Send Feedback

The GH_ScriptVariant type exposes the following members.

Properties

 | Name | Description
Public property | Boolean |
Public property | DateTime |
Public property | Double |
Public property | Integer |
Public property | Object |
Public property | Plane |
Public property | Point |
Public property | String |
Public property | Type |
Public property | Vector |

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


Boolean Property

[image]

Grasshopper SDK
GH_ScriptVariant..::..Boolean Property
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Boolean { get; }
Visual Basic
Public ReadOnly Property Boolean As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Expressions.GH_ScriptVariant.Boolean"]

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


DateTime Property

[image]

Grasshopper SDK
GH_ScriptVariant..::..DateTime Property
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public DateTime DateTime { get; }
Visual Basic
Public ReadOnly Property DateTime As DateTime
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Expressions.GH_ScriptVariant.DateTime"]

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


Double Property

[image]

Grasshopper SDK
GH_ScriptVariant..::..Double Property
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double Double { get; }
Visual Basic
Public ReadOnly Property Double As Double
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Expressions.GH_ScriptVariant.Double"]

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


Integer Property

[image]

Grasshopper SDK
GH_ScriptVariant..::..Integer Property
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int Integer { get; }
Visual Basic
Public ReadOnly Property Integer As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Expressions.GH_ScriptVariant.Integer"]

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


Object Property

[image]

Grasshopper SDK
GH_ScriptVariant..::..Object Property
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Object Object { get; }
Visual Basic
Public ReadOnly Property Object As Object
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Expressions.GH_ScriptVariant.Object"]

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


Plane Property

[image]

Grasshopper SDK
GH_ScriptVariant..::..Plane Property
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Plane Plane { get; }
Visual Basic
Public ReadOnly Property Plane As Plane
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Expressions.GH_ScriptVariant.Plane"]

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


Point Property

[image]

Grasshopper SDK
GH_ScriptVariant..::..Point Property
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Point3d Point { get; }
Visual Basic
Public ReadOnly Property Point As Point3d
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Expressions.GH_ScriptVariant.Point"]

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


String Property

[image]

Grasshopper SDK
GH_ScriptVariant..::..String Property
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string String { get; }
Visual Basic
Public ReadOnly Property String As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Expressions.GH_ScriptVariant.String"]

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


Type Property

[image]

Grasshopper SDK
GH_ScriptVariant..::..Type Property
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ScriptVariantType Type { get; }
Visual Basic
Public ReadOnly Property Type As GH_ScriptVariantType
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Expressions.GH_ScriptVariant.Type"]

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


Vector Property

[image]

Grasshopper SDK
GH_ScriptVariant..::..Vector Property
GH_ScriptVariant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Vector3d Vector { get; }
Visual Basic
Public ReadOnly Property Vector As Vector3d
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Expressions.GH_ScriptVariant.Vector"]

See Also

GH_ScriptVariant Class
Grasshopper.Kernel.Expressions Namespace


GH_ScriptVariantType Enumeration

[image]

Grasshopper SDK
GH_ScriptVariantType Enumeration
See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_ScriptVariantType
Visual Basic
Public Enumeration GH_ScriptVariantType

Members

Member name | Value | Description
nothing | 0 |
boolean | 1 |
integer | 2 |
double | 3 |
string | 5 |
datetime | 6 |
point | 10 |
vector | 11 |
plane | 12 |
object | 20 |

See Also

Grasshopper.Kernel.Expressions Namespace


GH_SignatureException Class

[image]

Grasshopper SDK
GH_SignatureException Class
Members See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_SignatureException : Exception
Visual Basic
Public Class GH_SignatureException _
    Inherits Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
Grasshopper.Kernel.Expressions..::..GH_SignatureException

See Also

GH_SignatureException Members
Grasshopper.Kernel.Expressions Namespace


GH_SignatureException Members

[image] [image]

Grasshopper SDK
GH_SignatureException Members
GH_SignatureException Class Constructors Properties See Also Send Feedback

The GH_SignatureException type exposes the following members.

Constructors

 | Name | Description
Public method | GH_SignatureException | Initializes a new instance of the GH_SignatureException class

Properties

 | Name | Description
Public property | Message | (Overrides Exception..::..Message.)

See Also

GH_SignatureException Class
Grasshopper.Kernel.Expressions Namespace


GH_SignatureException Constructor

[image]

Grasshopper SDK
GH_SignatureException Constructor
GH_SignatureException Class See Also Send Feedback
Initializes a new instance of the GH_SignatureException class

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_SignatureException(
    List<GH_Variant> args,
    string name
)
Visual Basic
Public Sub New ( _
    args As List(Of GH_Variant), _
    name As String _
)

Parameters

args
Type: System.Collections.Generic..::..List <(Of <(<' GH_Variant >)>)>
name
Type: System..::..String

See Also

GH_SignatureException Class
Grasshopper.Kernel.Expressions Namespace


GH_SignatureException Properties

[image] [image]

Grasshopper SDK
GH_SignatureException Properties
GH_SignatureException Class See Also Send Feedback

The GH_SignatureException type exposes the following members.

Properties

 | Name | Description
Public property | Message | (Overrides Exception..::..Message.)

See Also

GH_SignatureException Class
Grasshopper.Kernel.Expressions Namespace


Message Property

[image]

Grasshopper SDK
GH_SignatureException..::..Message Property
GH_SignatureException Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string Message { get; }
Visual Basic
Public Overrides ReadOnly Property Message As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Expressions.GH_SignatureException.Message"]

Implements

_Exception..::..Message

See Also

GH_SignatureException Class
Grasshopper.Kernel.Expressions Namespace


GH_SolverException Class

[image]

Grasshopper SDK
GH_SolverException Class
Members See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_SolverException : Exception
Visual Basic
Public Class GH_SolverException _
    Inherits Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
Grasshopper.Kernel.Expressions..::..GH_SolverException

See Also

GH_SolverException Members
Grasshopper.Kernel.Expressions Namespace


GH_SolverException Members

[image] [image]

Grasshopper SDK
GH_SolverException Members
GH_SolverException Class Constructors See Also Send Feedback

The GH_SolverException type exposes the following members.

Constructors

 | Name | Description
Public method | GH_SolverException | Initializes a new instance of the GH_SolverException class

See Also

GH_SolverException Class
Grasshopper.Kernel.Expressions Namespace


GH_SolverException Constructor

[image]

Grasshopper SDK
GH_SolverException Constructor
GH_SolverException Class See Also Send Feedback
Initializes a new instance of the GH_SolverException class

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_SolverException(
    string nMessage
)
Visual Basic
Public Sub New ( _
    nMessage As String _
)

Parameters

nMessage
Type: System..::..String

See Also

GH_SolverException Class
Grasshopper.Kernel.Expressions Namespace


GH_SyntaxException Class

[image]

Grasshopper SDK
GH_SyntaxException Class
Members See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_SyntaxException : Exception
Visual Basic
Public Class GH_SyntaxException _
    Inherits Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
Grasshopper.Kernel.Expressions..::..GH_SyntaxException

See Also

GH_SyntaxException Members
Grasshopper.Kernel.Expressions Namespace


GH_SyntaxException Members

[image] [image]

Grasshopper SDK
GH_SyntaxException Members
GH_SyntaxException Class Constructors See Also Send Feedback

The GH_SyntaxException type exposes the following members.

Constructors

 | Name | Description
Public method | GH_SyntaxException | Initializes a new instance of the GH_SyntaxException class

See Also

GH_SyntaxException Class
Grasshopper.Kernel.Expressions Namespace


GH_SyntaxException Constructor

[image]

Grasshopper SDK
GH_SyntaxException Constructor
GH_SyntaxException Class See Also Send Feedback
Initializes a new instance of the GH_SyntaxException class

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_SyntaxException(
    string nMessage
)
Visual Basic
Public Sub New ( _
    nMessage As String _
)

Parameters

nMessage
Type: System..::..String

See Also

GH_SyntaxException Class
Grasshopper.Kernel.Expressions Namespace


GH_Variant Class

[image]

Grasshopper SDK
GH_Variant Class
Members See Also Send Feedback
Variant data used in Grasshopper Expressions.

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Variant
Visual Basic
Public Class GH_Variant

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Expressions..::..GH_Variant

See Also

GH_Variant Members
Grasshopper.Kernel.Expressions Namespace


GH_Variant Members

[image] [image]

Grasshopper SDK
GH_Variant Members
GH_Variant Class Constructors Methods Properties See Also Send Feedback

The GH_Variant type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Variant()()()() | Create a new Null variant.
Public method | GH_Variant(Plane) | Create a new Plane variant.
Public method | GH_Variant(Point3d) | Create a new Point variant.
Public method | GH_Variant(Vector3d) | Create a new Point variant.
Public method | GH_Variant(Boolean) | Create a new Bool variant.
Public method | GH_Variant(Double) | Create a new Double variant.
Public method | GH_Variant(Int32) | Create a new Integer variant.
Public method | GH_Variant(String) | Create a new String variant.
Public method | GH_Variant(Complex) | Create a new Complex variant.
Public method | GH_Variant(GH_Variant) | Duplicate a Variant.

Methods

 | Name | Description
Public method | Data<(Of <<'(T>)>>) | Perform a straight cast of the data inside this Variant.
Public method | Duplicate | Duplicate this Variant. If the type of this Variant is [unknown] the contents are not guaranteed to be duplicated.
Public method | Evaluate | If this variant represents a string, this function will attempt to evaluate that string and replace the data inside this variant.
Public method | ToGoo | Attempt to convert a Variant to a Grasshopper IGH_Goo type.
Public method | ToString | (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | _Bool | Gets the contents of this Variant as a bool.
Public property | _Complex | Gets the contents of this Variant as a complex number.
Public property | _Double | Gets the contents of this Variant as a double. If the Variant is of type Integer this cast will also work.
Public property | _Int | Gets the contents of this Variant as an integer.
Public property | _Plane | Gets the contents of this Variant as a Plane.
Public property | _Point | Gets the contents of this Variant as a Point.
Public property | _String | Gets the contents of this Variant as a String. This function will work for all Variant types.
Public property | _Vector | Gets the contents of this Variant as a Vector.
Public property | IsNumeric | Gets a value indicating whether or not the Variant is a numeric type. Only Doubles and Integers are considered to be Numeric.
Public property | Type | Gets the Type of this Variant.

See Also

GH_Variant Class
Grasshopper.Kernel.Expressions Namespace


GH_Variant Constructor

[image] [image]

Grasshopper SDK
GH_Variant Constructor
GH_Variant Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Variant()()()() | Create a new Null variant.
Public method | GH_Variant(Plane) | Create a new Plane variant.
Public method | GH_Variant(Point3d) | Create a new Point variant.
Public method | GH_Variant(Vector3d) | Create a new Point variant.
Public method | GH_Variant(Boolean) | Create a new Bool variant.
Public method | GH_Variant(Double) | Create a new Double variant.
Public method | GH_Variant(Int32) | Create a new Integer variant.
Public method | GH_Variant(String) | Create a new String variant.
Public method | GH_Variant(Complex) | Create a new Complex variant.
Public method | GH_Variant(GH_Variant) | Duplicate a Variant.

See Also

GH_Variant Class
GH_Variant Members
Grasshopper.Kernel.Expressions Namespace


GH_Variant Constructor

[image]

Grasshopper SDK
GH_Variant Constructor
GH_Variant Class See Also Send Feedback
Create a new Null variant.

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Variant()
Visual Basic
Public Sub New

See Also

GH_Variant Class
GH_Variant Overload
Grasshopper.Kernel.Expressions Namespace


GH_Variant Constructor ()

[image]

Grasshopper SDK
GH_Variant Constructor ()
GH_Variant Class See Also Send Feedback
Create a new Plane variant.

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Variant(
    Plane value
)
Visual Basic
Public Sub New ( _
    value As Plane _
)

Parameters

value
Type: Plane
Value of Variant.

See Also

GH_Variant Class
GH_Variant Overload
Grasshopper.Kernel.Expressions Namespace


GH_Variant Constructor ()

[image]

Grasshopper SDK
GH_Variant Constructor ()
GH_Variant Class See Also Send Feedback
Create a new Point variant.

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Variant(
    Point3d value
)
Visual Basic
Public Sub New ( _
    value As Point3d _
)

Parameters

value
Type: Point3d
Value of Variant.

See Also

GH_Variant Class
GH_Variant Overload
Grasshopper.Kernel.Expressions Namespace


GH_Variant Constructor ()

[image]

Grasshopper SDK
GH_Variant Constructor ()
GH_Variant Class See Also Send Feedback
Create a new Point variant.

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Variant(
    Vector3d value
)
Visual Basic
Public Sub New ( _
    value As Vector3d _
)

Parameters

value
Type: Vector3d
Value of Variant.

See Also

GH_Variant Class
GH_Variant Overload
Grasshopper.Kernel.Expressions Namespace


GH_Variant Constructor (Boolean)

[image]

Grasshopper SDK
GH_Variant Constructor (Boolean)
GH_Variant Class See Also Send Feedback
Create a new Bool variant.

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Variant(
    bool value
)
Visual Basic
Public Sub New ( _
    value As Boolean _
)

Parameters

value
Type: System..::..Boolean
Value of Variant.

See Also

GH_Variant Class
GH_Variant Overload
Grasshopper.Kernel.Expressions Namespace


GH_Variant Constructor (Double)

[image]

Grasshopper SDK
GH_Variant Constructor (Double)
GH_Variant Class See Also Send Feedback
Create a new Double variant.

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Variant(
    double value
)
Visual Basic
Public Sub New ( _
    value As Double _
)

Parameters

value
Type: System..::..Double
Value of Variant.

See Also

GH_Variant Class
GH_Variant Overload
Grasshopper.Kernel.Expressions Namespace


GH_Variant Constructor (Int32)

[image]

Grasshopper SDK
GH_Variant Constructor (Int32)
GH_Variant Class See Also Send Feedback
Create a new Integer variant.

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Variant(
    int value
)
Visual Basic
Public Sub New ( _
    value As Integer _
)

Parameters

value
Type: System..::..Int32
Value of Variant.

See Also

GH_Variant Class
GH_Variant Overload
Grasshopper.Kernel.Expressions Namespace


GH_Variant Constructor (String)

[image]

Grasshopper SDK
GH_Variant Constructor (String)
GH_Variant Class See Also Send Feedback
Create a new String variant.

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Variant(
    string value
)
Visual Basic
Public Sub New ( _
    value As String _
)

Parameters

value
Type: System..::..String
Value of Variant.

See Also

GH_Variant Class
GH_Variant Overload
Grasshopper.Kernel.Expressions Namespace


GH_Variant Constructor (Complex)

[image]

Grasshopper SDK
GH_Variant Constructor (Complex)
GH_Variant Class See Also Send Feedback
Create a new Complex variant.

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Variant(
    Complex value
)
Visual Basic
Public Sub New ( _
    value As Complex _
)

Parameters

value
Type: Grasshopper.Kernel.Types..::..Complex
Value of Variant.

See Also

GH_Variant Class
GH_Variant Overload
Grasshopper.Kernel.Expressions Namespace


GH_Variant Constructor (GH_Variant)

[image]

Grasshopper SDK
GH_Variant Constructor (GH_Variant)
GH_Variant Class See Also Send Feedback
Duplicate a Variant.

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Variant(
    GH_Variant other
)
Visual Basic
Public Sub New ( _
    other As GH_Variant _
)

Parameters

other
Type: Grasshopper.Kernel.Expressions..::..GH_Variant
Variant to duplicate

See Also

GH_Variant Class
GH_Variant Overload
Grasshopper.Kernel.Expressions Namespace


GH_Variant Methods

[image] [image]

Grasshopper SDK
GH_Variant Methods
GH_Variant Class See Also Send Feedback

The GH_Variant type exposes the following members.

Methods

 | Name | Description
Public method | Data<(Of <<'(T>)>>) | Perform a straight cast of the data inside this Variant.
Public method | Duplicate | Duplicate this Variant. If the type of this Variant is [unknown] the contents are not guaranteed to be duplicated.
Public method | Evaluate | If this variant represents a string, this function will attempt to evaluate that string and replace the data inside this variant.
Public method | ToGoo | Attempt to convert a Variant to a Grasshopper IGH_Goo type.
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

GH_Variant Class
Grasshopper.Kernel.Expressions Namespace


Data(T) Method

[image]

Grasshopper SDK
GH_Variant..::..Data<(Of <(<'T>)>)> Method
GH_Variant Class See Also Send Feedback
Perform a straight cast of the data inside this Variant.

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public T Data<T>()
Visual Basic
Public Function Data(Of T) As T

Type Parameters

T

Return Value

The value inside this Variant cast to T.

See Also

GH_Variant Class
Grasshopper.Kernel.Expressions Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_Variant..::..Duplicate Method
GH_Variant Class See Also Send Feedback
Duplicate this Variant. If the type of this Variant is [unknown] the contents are not guaranteed to be duplicated.

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Variant Duplicate()
Visual Basic
Public Function Duplicate As GH_Variant

See Also

GH_Variant Class
Grasshopper.Kernel.Expressions Namespace


Evaluate Method

[image]

Grasshopper SDK
GH_Variant..::..Evaluate Method
GH_Variant Class See Also Send Feedback
If this variant represents a string, this function will attempt to evaluate that string and replace the data inside this variant.

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Evaluate()
Visual Basic
Public Function Evaluate As Boolean

Return Value

True if the string was evaluated, false if otherwise.

See Also

GH_Variant Class
Grasshopper.Kernel.Expressions Namespace


ToGoo Method

[image]

Grasshopper SDK
GH_Variant..::..ToGoo Method
GH_Variant Class See Also Send Feedback
Attempt to convert a Variant to a Grasshopper IGH_Goo type.

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_Goo ToGoo()
Visual Basic
Public Function ToGoo As IGH_Goo

Return Value

An instance of a class implementing IGH_Goo or null.

See Also

GH_Variant Class
Grasshopper.Kernel.Expressions Namespace


ToString Method

[image]

Grasshopper SDK
GH_Variant..::..ToString Method
GH_Variant Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_Variant Class
Grasshopper.Kernel.Expressions Namespace


GH_Variant Properties

[image] [image]

Grasshopper SDK
GH_Variant Properties
GH_Variant Class See Also Send Feedback

The GH_Variant type exposes the following members.

Properties

 | Name | Description
Public property | _Bool | Gets the contents of this Variant as a bool.
Public property | _Complex | Gets the contents of this Variant as a complex number.
Public property | _Double | Gets the contents of this Variant as a double. If the Variant is of type Integer this cast will also work.
Public property | _Int | Gets the contents of this Variant as an integer.
Public property | _Plane | Gets the contents of this Variant as a Plane.
Public property | _Point | Gets the contents of this Variant as a Point.
Public property | _String | Gets the contents of this Variant as a String. This function will work for all Variant types.
Public property | _Vector | Gets the contents of this Variant as a Vector.
Public property | IsNumeric | Gets a value indicating whether or not the Variant is a numeric type. Only Doubles and Integers are considered to be Numeric.
Public property | Type | Gets the Type of this Variant.

See Also

GH_Variant Class
Grasshopper.Kernel.Expressions Namespace


_Bool Property

[image]

Grasshopper SDK
GH_Variant..::.._Bool Property
GH_Variant Class See Also Send Feedback
Gets the contents of this Variant as a bool.

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool _Bool { get; }
Visual Basic
Public ReadOnly Property _Bool As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Expressions.GH_Variant._Bool"]

See Also

GH_Variant Class
Grasshopper.Kernel.Expressions Namespace


_Complex Property

[image]

Grasshopper SDK
GH_Variant..::.._Complex Property
GH_Variant Class See Also Send Feedback
Gets the contents of this Variant as a complex number.

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Complex _Complex { get; }
Visual Basic
Public ReadOnly Property _Complex As Complex
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Expressions.GH_Variant._Complex"]

See Also

GH_Variant Class
Grasshopper.Kernel.Expressions Namespace


_Double Property

[image]

Grasshopper SDK
GH_Variant..::.._Double Property
GH_Variant Class See Also Send Feedback
Gets the contents of this Variant as a double. If the Variant is of type Integer this cast will also work.

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double _Double { get; }
Visual Basic
Public ReadOnly Property _Double As Double
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Expressions.GH_Variant._Double"]

See Also

GH_Variant Class
Grasshopper.Kernel.Expressions Namespace


_Int Property

[image]

Grasshopper SDK
GH_Variant..::.._Int Property
GH_Variant Class See Also Send Feedback
Gets the contents of this Variant as an integer.

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int _Int { get; }
Visual Basic
Public ReadOnly Property _Int As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Expressions.GH_Variant._Int"]

See Also

GH_Variant Class
Grasshopper.Kernel.Expressions Namespace


_Plane Property

[image]

Grasshopper SDK
GH_Variant..::.._Plane Property
GH_Variant Class See Also Send Feedback
Gets the contents of this Variant as a Plane.

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Plane _Plane { get; }
Visual Basic
Public ReadOnly Property _Plane As Plane
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Expressions.GH_Variant._Plane"]

See Also

GH_Variant Class
Grasshopper.Kernel.Expressions Namespace


_Point Property

[image]

Grasshopper SDK
GH_Variant..::.._Point Property
GH_Variant Class See Also Send Feedback
Gets the contents of this Variant as a Point.

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Point3d _Point { get; }
Visual Basic
Public ReadOnly Property _Point As Point3d
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Expressions.GH_Variant._Point"]

See Also

GH_Variant Class
Grasshopper.Kernel.Expressions Namespace


_String Property

[image]

Grasshopper SDK
GH_Variant..::.._String Property
GH_Variant Class See Also Send Feedback
Gets the contents of this Variant as a String. This function will work for all Variant types.

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string _String { get; }
Visual Basic
Public ReadOnly Property _String As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Expressions.GH_Variant._String"]

See Also

GH_Variant Class
Grasshopper.Kernel.Expressions Namespace


_Vector Property

[image]

Grasshopper SDK
GH_Variant..::.._Vector Property
GH_Variant Class See Also Send Feedback
Gets the contents of this Variant as a Vector.

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Vector3d _Vector { get; }
Visual Basic
Public ReadOnly Property _Vector As Vector3d
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Expressions.GH_Variant._Vector"]

See Also

GH_Variant Class
Grasshopper.Kernel.Expressions Namespace


IsNumeric Property

[image]

Grasshopper SDK
GH_Variant..::..IsNumeric Property
GH_Variant Class See Also Send Feedback
Gets a value indicating whether or not the Variant is a numeric type. Only Doubles and Integers are considered to be Numeric.

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsNumeric { get; }
Visual Basic
Public ReadOnly Property IsNumeric As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Expressions.GH_Variant.IsNumeric"]

See Also

GH_Variant Class
Grasshopper.Kernel.Expressions Namespace


Type Property

[image]

Grasshopper SDK
GH_Variant..::..Type Property
GH_Variant Class See Also Send Feedback
Gets the Type of this Variant.

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_VariantType Type { get; }
Visual Basic
Public ReadOnly Property Type As GH_VariantType
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Expressions.GH_Variant.Type"]

See Also

GH_Variant Class
Grasshopper.Kernel.Expressions Namespace


GH_VariantType Enumeration

[image]

Grasshopper SDK
GH_VariantType Enumeration
See Also Send Feedback
Lists all possible variable types supported in the Grasshopper Expression Parser.

Namespace: Grasshopper.Kernel.Expressions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_VariantType
Visual Basic
Public Enumeration GH_VariantType

Members

Member name | Value | Description
unknown | -1 | Unknown type.
null | 0 | Variant is a null reference.
bool | 1 | Variant is of type System.Boolean
int | 2 | Variant is of type System.Int32
double | 4 | Variant is of type System.Double
string | 8 | Variant is of type System.String
point | 16 | Variant is of type Rhino.Geometry.Point3d
plane | 32 | Variant is of type Rhino.Geometry.Plane
complex | 64 | Variant is of type Grasshopper.Types.GH_Complex

See Also

Grasshopper.Kernel.Expressions Namespace


Grasshopper.Kernel.Geometry.SpatialTrees Namespace

[image]

Grasshopper SDK
Grasshopper.Kernel.Geometry.SpatialTrees Namespace
Send Feedback

Classes

 | Class | Description
Public class | Index3d<(Of <(<'T>)>)> | Represents an element index within a Tree3d instance.
Public class | Node3d<(Of <(<'T>)>)> | Basic node in a Tree3d structure. Nodes in tree structures maintain a local region and either a list of content indices or a list of up to 8 child nodes.
Public class | TreeDelegates | Provides a bunch of standard coordinate extractor methods.

Delegates

 | Delegate | Description
Public delegate | Coordinates3d<(Of <(<'T>)>)> | Delegate for coordinate retrieval.
Public delegate | Validation3d<(Of <(<'T>)>)> | Delegate to be used during advanced customized searches.


Coordinates3d(T) Delegate

[image]

Grasshopper SDK
Coordinates3d<(Of <(<'T>)>)> Delegate
See Also Send Feedback
Delegate for coordinate retrieval.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate void Coordinates3d<T>(
    T element,
    out double x,
    out double y,
    out double z
)
Visual Basic
Public Delegate Sub Coordinates3d(Of T) ( _
    element As T, _
    <OutAttribute> ByRef x As Double, _
    <OutAttribute> ByRef y As Double, _
    <OutAttribute> ByRef z As Double _
)

Parameters

element
Type: T
Element to retrieve coordinates from.
x
Type: System..::..Double %
X coordinate of element.
y
Type: System..::..Double %
Y coordinate of element.
z
Type: System..::..Double %
Z coordinate of element.

Type Parameters

T
Element type.

See Also

Grasshopper.Kernel.Geometry.SpatialTrees Namespace


Index3d(T) Class

[image]

Grasshopper SDK
Index3d<(Of <(<'T>)>)> Class
Members See Also Send Feedback
Represents an element index within a Tree3d instance.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class Index3d<T> : IComparable<Index3d<T>>
Visual Basic
Public Class Index3d(Of T) _
    Implements IComparable(Of Index3d(Of T))

Type Parameters

T

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Geometry.SpatialTrees..::..Index3d<(Of <(<'T>)>)>

See Also

Index3d<(Of <(<'T>)>)> Members
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


Index3d(T) Members

[image] [image]

Grasshopper SDK
Index3d<(Of <(<'T>)>)> Members
Index3d<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The Index3d<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | Index3d<(Of <(<'T>)>)> | Initializes a new instance of the Index3d<(Of <(<'T>)>)> class

Methods

 | Name | Description
Public method | CompareTo |

Properties

 | Name | Description
Public property | GlobalIndex | Gets the item index within the tree global list.
Public property | Item | Gets the actual item.
Public property | LocalIndex | Gets the index within the node index list.
Public property | Node | Gets the node of the tree in which this element is stored.

See Also

Index3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


Index3d(T) Constructor

[image]

Grasshopper SDK
Index3d<(Of <(<'T>)>)> Constructor
Index3d<(Of <(<'T>)>)> Class See Also Send Feedback
Initializes a new instance of the Index3d<(Of <(<'T>)>)> class

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Index3d(
    Node3d<T> node,
    int nodeIndex
)
Visual Basic
Public Sub New ( _
    node As Node3d(Of T), _
    nodeIndex As Integer _
)

Parameters

node
Type: Grasshopper.Kernel.Geometry.SpatialTrees..::..Node3d <(Of <(<' T >)>)>
nodeIndex
Type: System..::..Int32

See Also

Index3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


Index3d(T) Methods

[image] [image]

Grasshopper SDK
Index3d<(Of <(<'T>)>)> Methods
Index3d<(Of <(<'T>)>)> Class See Also Send Feedback

The Index3d<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo |

See Also

Index3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


CompareTo Method

[image]

Grasshopper SDK
Index3d<(Of <(<'T>)>)>..::..CompareTo Method
Index3d<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int CompareTo(
    Index3d<T> other
)
Visual Basic
Public Function CompareTo ( _
    other As Index3d(Of T) _
) As Integer

Parameters

other
Type: Grasshopper.Kernel.Geometry.SpatialTrees..::..Index3d <(Of <(<' T >)>)>

Implements

IComparable<(Of <(<'T>)>)>..::..CompareTo(T)

See Also

Index3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


Index3d(T) Properties

[image] [image]

Grasshopper SDK
Index3d<(Of <(<'T>)>)> Properties
Index3d<(Of <(<'T>)>)> Class See Also Send Feedback

The Index3d<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | GlobalIndex | Gets the item index within the tree global list.
Public property | Item | Gets the actual item.
Public property | LocalIndex | Gets the index within the node index list.
Public property | Node | Gets the node of the tree in which this element is stored.

See Also

Index3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


GlobalIndex Property

[image]

Grasshopper SDK
Index3d<(Of <(<'T>)>)>..::..GlobalIndex Property
Index3d<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the item index within the tree global list.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int GlobalIndex { get; }
Visual Basic
Public ReadOnly Property GlobalIndex As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Geometry.SpatialTrees.Index3d`1.GlobalIndex"]

See Also

Index3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


Item Property

[image]

Grasshopper SDK
Index3d<(Of <(<'T>)>)>..::..Item Property
Index3d<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the actual item.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public T Item { get; }
Visual Basic
Public ReadOnly Property Item As T
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Geometry.SpatialTrees.Index3d`1.Item"]

See Also

Index3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


LocalIndex Property

[image]

Grasshopper SDK
Index3d<(Of <(<'T>)>)>..::..LocalIndex Property
Index3d<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the index within the node index list.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int LocalIndex { get; }
Visual Basic
Public ReadOnly Property LocalIndex As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Geometry.SpatialTrees.Index3d`1.LocalIndex"]

See Also

Index3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


Node Property

[image]

Grasshopper SDK
Index3d<(Of <(<'T>)>)>..::..Node Property
Index3d<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the node of the tree in which this element is stored.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Node3d<T> Node { get; }
Visual Basic
Public ReadOnly Property Node As Node3d(Of T)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Geometry.SpatialTrees.Index3d`1.Node"]

See Also

Index3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


Node3d(T) Class

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)> Class
Members See Also Send Feedback
Basic node in a Tree3d structure. Nodes in tree structures maintain a local region and either a list of content indices or a list of up to 8 child nodes.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class Node3d<T>
Visual Basic
Public NotInheritable Class Node3d(Of T)

Type Parameters

T

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Geometry.SpatialTrees..::..Node3d<(Of <(<'T>)>)>

See Also

Node3d<(Of <(<'T>)>)> Members
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


Node3d(T) Members

[image] [image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)> Members
Node3d<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The Node3d<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | Node3d<(Of <(<'T>)>)>(Coordinates3d<(Of <<'(T>)>>), BoundingBox) | Create a new spatial tree root.
Public method | Node3d<(Of <(<'T>)>)>(Coordinates3d<(Of <<'(T>)>>), BoundingBox, Int32) | Create a new spatial tree root.

Methods

 | Name | Description
Public method | Add | Insert another item into the tree. The item should be within the region of this node.
Public method | AddRange | Insert a collection of items into the tree. The items should all be within the region of this node.
Public method | AddToRhinoDocument |
Public method | CollapseNodes | Collapse the (sub)tree rooted at this node. Collapsing happens when a node only has a single child, in which case the child usurps the position previously held by the parent. Do not collapse a (sub)tree if you still plan to add items later.
Public method | FurthestItem(Point3d) | Find the furtest item.
Public method | FurthestItem(T) | Find the furtest item.
Public method | FurthestItem(Point3d, Double, Double) | Find the furtest item.
Public method | FurthestItem(Double, Double, Double) | Find the furtest item.
Public method | FurthestItem(T, Double, Double) | Find the furtest item.
Public method | FurthestItem(Double, Double, Double, Double, Double) | Find the furtest item.
Public method | NearestItem(Point3d) | Find the nearest item.
Public method | NearestItem(T) | Find the nearest item.
Public method | NearestItem(Point3d, Double, Double) | Find the nearest item.
Public method | NearestItem(Double, Double, Double) | Find the nearest item.
Public method | NearestItem(T, Double, Double) | Find the nearest item.
Public method | NearestItem(Double, Double, Double, Validation3d<(Of <<'(T>)>>)) | Find the nearest item using custom validation criteria.
Public method | NearestItem(Double, Double, Double, Double, Double) | Find the nearest item.
Public method | NearestItems(T, Int32) | Find the N nearest items.
Public method | NearestItems(Double, Double, Double, Int32) | Find the N nearest items.
Public method | NearestItems(T, Int32, Double, Double) | Find the N nearest items.
Public method | NearestItems(Double, Double, Double, Int32, Double, Double) | Find the N nearest items.
Public method | OptimizeTree | Optimize this tree for fast searches. Do not call this method if you still plan to add items in the future. You can no longer modify this tree once it has been optimized.
Public method | Remove(Int32) | Remove the item with the given index from the entire tree. It doesn't matter on which node you call this function, it is a tree-wide operation.
Public method | Remove(Index3d<(Of <<'(T>)>>)) | Remove the item with the given index from the entire tree. It doesn't matter on which node you call this function, it is a tree-wide operation.
Public method | ShrinkRegions | Shrink the region for this node and all child nodes. Do not use this method if you intend to add more items later as it creates spatial gaps in the tree structure. You can shrink nodes if you're done adding items and want to start searching the tree.
Public method | SubTree | Gets an iterator for all nodes in this (sub)tree.
Public method | TrimExcess | Trim the excess space on all index lists. You can call this method to reduce memory usage. It will not modify the tree in any functional way.

Properties

 | Name | Description
Public property | Center | Gets the center of the spatial region of this node. If the node contains no children the center is always in the middle of the Region. If the node does contain child-nodes, the center may be anywhere within the region.
Public property | ChildCount | Gets the number of defined child nodes. Leaf nodes have no children. Root and twig nodes can have anywhere between 1 and 8 children.
Public property | ChildNode | Gets the child node at the given index.
Public property | ContentAverage | Returns the average coordinate of all items in this node. If this node does not contain any items, Point3d.Unset is returned.
Public property | ContentBoundingBox | Returns the boundingbox of all items in this node. If this node does not contain any items, BoundingBox.Empty is returned.
Public property | IndicesLocal | Gets the list of item indices that are contained within this node.
Public property | IndicesRecursive | Gets the list of item indices that are contained within this node and any child nodes.
Public property | IsLeaf | Gets whether this node is a leaf node. Leaf nodes have no child nodes.
Public property | IsMutable | Gets whether this tree is mutable. You can only add items to mutable trees. We don't recommend removing items from unmutable trees, though that shouldn't necessarily lead to problems. Trees become unmutable after a call to ShrinkRegions(), CollapseNodes() or OptimizeTree().
Public property | IsRoot | Gets whether this node is a root node. Root nodes have no parent node and depth zero.
Public property | IsTwig | Gets whether this node is a twig node. Twig nodes have both parents and at least one child.
Public property | ItemCount | Gets the total number of items stored directly in this node.
Public property | ItemsGlobal | Gets the list of all items stored inside this entire tree. Do not modify this collection unless you know what you are doing.
Public property | ItemsLocal | Gets a list of all the items stored directly in this node. This list is constructed every time you access this property, so keep it down to a minimum.
Public property | Limit | Gets the subdivision limit for this tree. This limit can only be set once when you create a new tree. It is fixed forever after.
Public property | MemoryConsumption | Gets the estimated memory consumption of the (sub)tree structure. Items inside the global list are not included in this estimate.
Public property | NextNode | Gets the logical neighbour to the right of this node. There is no spatial relationships between logical neighbours, this is purely an iteration aid.
Public property | NodeDepth | Gets the recursive depth of this node. The tree root is at depth zero. The first subdivision is at depth one, and so on and so forth.
Public property | ParentNode | Gets the immediate parent of this node. Root nodes have no parent.
Public property | Region | Gets the spatial region of this node.
Public property | RootNode | Gets the ultimate root node for this tree.
Public property | WeightedSubdivision | Gets or sets whether subdivision is weighted based on content averages. Setting this value will only affect future subdivisions, not existing ones.

See Also

Node3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


Node3d(T) Constructor

[image] [image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)> Constructor
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Node3d<(Of <(<'T>)>)>(Coordinates3d<(Of <<'(T>)>>), BoundingBox) | Create a new spatial tree root.
Public method | Node3d<(Of <(<'T>)>)>(Coordinates3d<(Of <<'(T>)>>), BoundingBox, Int32) | Create a new spatial tree root.

See Also

Node3d<(Of <(<'T>)>)> Class
Node3d<(Of <(<'T>)>)> Members
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


Node3d(T) Constructor (Coordinates3d(T), )

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)> Constructor (Coordinates3d<(Of <(<'T>)>)>, )
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Create a new spatial tree root.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Node3d(
    Coordinates3d<T> converter,
    BoundingBox region
)
Visual Basic
Public Sub New ( _
    converter As Coordinates3d(Of T), _
    region As BoundingBox _
)

Parameters

converter
Type: Grasshopper.Kernel.Geometry.SpatialTrees..::..Coordinates3d <(Of <(<' T >)>)>
Converter delegate.
region
Type: BoundingBox
Bounding box for this node. The region should be big enough to contain all items you're going to insert.

See Also

Node3d<(Of <(<'T>)>)> Class
Node3d<(Of <(<'T>)>)> Overload
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


Node3d(T) Constructor (Coordinates3d(T), , Int32)

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)> Constructor (Coordinates3d<(Of <(<'T>)>)>, , Int32)
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Create a new spatial tree root.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Node3d(
    Coordinates3d<T> converter,
    BoundingBox region,
    int limit
)
Visual Basic
Public Sub New ( _
    converter As Coordinates3d(Of T), _
    region As BoundingBox, _
    limit As Integer _
)

Parameters

converter
Type: Grasshopper.Kernel.Geometry.SpatialTrees..::..Coordinates3d <(Of <(<' T >)>)>
Converter delegate.
region
Type: BoundingBox
Bounding box for this node. The region should be big enough to contain all items you're going to insert.
limit
Type: System..::..Int32
Node subdivision limit.

See Also

Node3d<(Of <(<'T>)>)> Class
Node3d<(Of <(<'T>)>)> Overload
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


Node3d(T) Methods

[image] [image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)> Methods
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback

The Node3d<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Add | Insert another item into the tree. The item should be within the region of this node.
Public method | AddRange | Insert a collection of items into the tree. The items should all be within the region of this node.
Public method | AddToRhinoDocument |
Public method | CollapseNodes | Collapse the (sub)tree rooted at this node. Collapsing happens when a node only has a single child, in which case the child usurps the position previously held by the parent. Do not collapse a (sub)tree if you still plan to add items later.
Public method | FurthestItem(Point3d) | Find the furtest item.
Public method | FurthestItem(T) | Find the furtest item.
Public method | FurthestItem(Point3d, Double, Double) | Find the furtest item.
Public method | FurthestItem(Double, Double, Double) | Find the furtest item.
Public method | FurthestItem(T, Double, Double) | Find the furtest item.
Public method | FurthestItem(Double, Double, Double, Double, Double) | Find the furtest item.
Public method | NearestItem(Point3d) | Find the nearest item.
Public method | NearestItem(T) | Find the nearest item.
Public method | NearestItem(Point3d, Double, Double) | Find the nearest item.
Public method | NearestItem(Double, Double, Double) | Find the nearest item.
Public method | NearestItem(T, Double, Double) | Find the nearest item.
Public method | NearestItem(Double, Double, Double, Validation3d<(Of <<'(T>)>>)) | Find the nearest item using custom validation criteria.
Public method | NearestItem(Double, Double, Double, Double, Double) | Find the nearest item.
Public method | NearestItems(T, Int32) | Find the N nearest items.
Public method | NearestItems(Double, Double, Double, Int32) | Find the N nearest items.
Public method | NearestItems(T, Int32, Double, Double) | Find the N nearest items.
Public method | NearestItems(Double, Double, Double, Int32, Double, Double) | Find the N nearest items.
Public method | OptimizeTree | Optimize this tree for fast searches. Do not call this method if you still plan to add items in the future. You can no longer modify this tree once it has been optimized.
Public method | Remove(Int32) | Remove the item with the given index from the entire tree. It doesn't matter on which node you call this function, it is a tree-wide operation.
Public method | Remove(Index3d<(Of <<'(T>)>>)) | Remove the item with the given index from the entire tree. It doesn't matter on which node you call this function, it is a tree-wide operation.
Public method | ShrinkRegions | Shrink the region for this node and all child nodes. Do not use this method if you intend to add more items later as it creates spatial gaps in the tree structure. You can shrink nodes if you're done adding items and want to start searching the tree.
Public method | SubTree | Gets an iterator for all nodes in this (sub)tree.
Public method | TrimExcess | Trim the excess space on all index lists. You can call this method to reduce memory usage. It will not modify the tree in any functional way.

See Also

Node3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


Add Method

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..Add Method
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Insert another item into the tree. The item should be within the region of this node.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Add(
    T item
)
Visual Basic
Public Sub Add ( _
    item As T _
)

Parameters

item
Type: T
Item to insert.

See Also

Node3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


AddRange Method

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..AddRange Method
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Insert a collection of items into the tree. The items should all be within the region of this node.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddRange(
    IEnumerable<T> items
)
Visual Basic
Public Sub AddRange ( _
    items As IEnumerable(Of T) _
)

Parameters

items
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' T >)>)>
Items to add.

See Also

Node3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


AddToRhinoDocument Method

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..AddToRhinoDocument Method
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddToRhinoDocument(
    RhinoDoc doc
)
Visual Basic
Public Sub AddToRhinoDocument ( _
    doc As RhinoDoc _
)

Parameters

doc
Type: RhinoDoc

See Also

Node3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


CollapseNodes Method

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..CollapseNodes Method
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Collapse the (sub)tree rooted at this node. Collapsing happens when a node only has a single child, in which case the child usurps the position previously held by the parent. Do not collapse a (sub)tree if you still plan to add items later.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Node3d<T> CollapseNodes()
Visual Basic
Public Function CollapseNodes As Node3d(Of T)

Return Value

The new root for this (sub)tree. May well be an instance of this node if it cannot be collapsed.

See Also

Node3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


FurthestItem Method

[image] [image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..FurthestItem Method
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FurthestItem(Point3d) | Find the furtest item.
Public method | FurthestItem(T) | Find the furtest item.
Public method | FurthestItem(Point3d, Double, Double) | Find the furtest item.
Public method | FurthestItem(Double, Double, Double) | Find the furtest item.
Public method | FurthestItem(T, Double, Double) | Find the furtest item.
Public method | FurthestItem(Double, Double, Double, Double, Double) | Find the furtest item.

See Also

Node3d<(Of <(<'T>)>)> Class
Node3d<(Of <(<'T>)>)> Members
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


FurthestItem Method ()

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..FurthestItem Method ()
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Find the furtest item.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Index3d<T> FurthestItem(
    Point3d locus
)
Visual Basic
Public Function FurthestItem ( _
    locus As Point3d _
) As Index3d(Of T)

Parameters

locus
Type: Point3d
Location to search from.

Return Value

The index of the furtest item or null if no furtest item could be found.

See Also

Node3d<(Of <(<'T>)>)> Class
FurthestItem Overload
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


FurthestItem Method (T)

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..FurthestItem Method (T)
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Find the furtest item.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Index3d<T> FurthestItem(
    T locus
)
Visual Basic
Public Function FurthestItem ( _
    locus As T _
) As Index3d(Of T)

Parameters

locus
Type: T
Location to search from.

Return Value

The index of the furtest item or null if no furtest item could be found.

See Also

Node3d<(Of <(<'T>)>)> Class
FurthestItem Overload
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


FurthestItem Method (, Double, Double)

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..FurthestItem Method (, Double, Double)
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Find the furtest item.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Index3d<T> FurthestItem(
    Point3d locus,
    double minimumDistance,
    double maximumDistance
)
Visual Basic
Public Function FurthestItem ( _
    locus As Point3d, _
    minimumDistance As Double, _
    maximumDistance As Double _
) As Index3d(Of T)

Parameters

locus
Type: Point3d
Location to search from.
minimumDistance
Type: System..::..Double
Minimum distance for furtest item. Items closer than minimumDistance will be ignored.
maximumDistance
Type: System..::..Double
Maximum distance for furtest item. Items further than maximumDistance will be ignored.

Return Value

The index of the furtest item or null if no furtest item could be found.

See Also

Node3d<(Of <(<'T>)>)> Class
FurthestItem Overload
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


FurthestItem Method (Double, Double, Double)

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..FurthestItem Method (Double, Double, Double)
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Find the furtest item.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Index3d<T> FurthestItem(
    double x,
    double y,
    double z
)
Visual Basic
Public Function FurthestItem ( _
    x As Double, _
    y As Double, _
    z As Double _
) As Index3d(Of T)

Parameters

x
Type: System..::..Double
x coordinate to search from.
y
Type: System..::..Double
y coordinate to search from.
z
Type: System..::..Double
z coordinate to search from.

Return Value

The index of the furtest item or null if no furtest item could be found.

See Also

Node3d<(Of <(<'T>)>)> Class
FurthestItem Overload
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


FurthestItem Method (T, Double, Double)

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..FurthestItem Method (T, Double, Double)
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Find the furtest item.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Index3d<T> FurthestItem(
    T locus,
    double minimumDistance,
    double maximumDistance
)
Visual Basic
Public Function FurthestItem ( _
    locus As T, _
    minimumDistance As Double, _
    maximumDistance As Double _
) As Index3d(Of T)

Parameters

locus
Type: T
Location to search from.
minimumDistance
Type: System..::..Double
Minimum distance for furtest item. Items closer than minimumDistance will be ignored.
maximumDistance
Type: System..::..Double
Maximum distance for furtest item. Items further than maximumDistance will be ignored.

Return Value

The index of the furtest item or null if no furtest item could be found.

See Also

Node3d<(Of <(<'T>)>)> Class
FurthestItem Overload
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


FurthestItem Method (Double, Double, Double, Double, Double)

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..FurthestItem Method (Double, Double, Double, Double, Double)
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Find the furtest item.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Index3d<T> FurthestItem(
    double x,
    double y,
    double z,
    double minimumDistance,
    double maximumDistance
)
Visual Basic
Public Function FurthestItem ( _
    x As Double, _
    y As Double, _
    z As Double, _
    minimumDistance As Double, _
    maximumDistance As Double _
) As Index3d(Of T)

Parameters

x
Type: System..::..Double
x coordinate to search from.
y
Type: System..::..Double
y coordinate to search from.
z
Type: System..::..Double
z coordinate to search from.
minimumDistance
Type: System..::..Double
Minimum distance for furtest item. Items closer than minimumDistance will be ignored.
maximumDistance
Type: System..::..Double
Maximum distance for furtest item. Items further than maximumDistance will be ignored.

Return Value

The index of the furtest item or null if no furtest item could be found.

See Also

Node3d<(Of <(<'T>)>)> Class
FurthestItem Overload
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


NearestItem Method

[image] [image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..NearestItem Method
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NearestItem(Point3d) | Find the nearest item.
Public method | NearestItem(T) | Find the nearest item.
Public method | NearestItem(Point3d, Double, Double) | Find the nearest item.
Public method | NearestItem(Double, Double, Double) | Find the nearest item.
Public method | NearestItem(T, Double, Double) | Find the nearest item.
Public method | NearestItem(Double, Double, Double, Validation3d<(Of <<'(T>)>>)) | Find the nearest item using custom validation criteria.
Public method | NearestItem(Double, Double, Double, Double, Double) | Find the nearest item.

See Also

Node3d<(Of <(<'T>)>)> Class
Node3d<(Of <(<'T>)>)> Members
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


NearestItem Method ()

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..NearestItem Method ()
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Find the nearest item.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Index3d<T> NearestItem(
    Point3d locus
)
Visual Basic
Public Function NearestItem ( _
    locus As Point3d _
) As Index3d(Of T)

Parameters

locus
Type: Point3d
Location to search from.

Return Value

The index of the nearest item or null if no nearest item could be found.

See Also

Node3d<(Of <(<'T>)>)> Class
NearestItem Overload
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


NearestItem Method (T)

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..NearestItem Method (T)
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Find the nearest item.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Index3d<T> NearestItem(
    T locus
)
Visual Basic
Public Function NearestItem ( _
    locus As T _
) As Index3d(Of T)

Parameters

locus
Type: T
Location to search from.

Return Value

The index of the nearest item or null if no nearest item could be found.

See Also

Node3d<(Of <(<'T>)>)> Class
NearestItem Overload
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


NearestItem Method (, Double, Double)

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..NearestItem Method (, Double, Double)
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Find the nearest item.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Index3d<T> NearestItem(
    Point3d locus,
    double minimumDistance,
    double maximumDistance
)
Visual Basic
Public Function NearestItem ( _
    locus As Point3d, _
    minimumDistance As Double, _
    maximumDistance As Double _
) As Index3d(Of T)

Parameters

locus
Type: Point3d
Location to search from.
minimumDistance
Type: System..::..Double
Minimum distance for nearest item. Items closer than minimumDistance will be ignored.
maximumDistance
Type: System..::..Double
Maximum distance for nearest item. Items further than maximumDistance will be ignored.

Return Value

The index of the nearest item or null if no nearest item could be found.

See Also

Node3d<(Of <(<'T>)>)> Class
NearestItem Overload
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


NearestItem Method (Double, Double, Double)

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..NearestItem Method (Double, Double, Double)
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Find the nearest item.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Index3d<T> NearestItem(
    double x,
    double y,
    double z
)
Visual Basic
Public Function NearestItem ( _
    x As Double, _
    y As Double, _
    z As Double _
) As Index3d(Of T)

Parameters

x
Type: System..::..Double
x coordinate to search from.
y
Type: System..::..Double
y coordinate to search from.
z
Type: System..::..Double
z coordinate to search from.

Return Value

The index of the nearest item or null if no nearest item could be found.

See Also

Node3d<(Of <(<'T>)>)> Class
NearestItem Overload
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


NearestItem Method (T, Double, Double)

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..NearestItem Method (T, Double, Double)
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Find the nearest item.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Index3d<T> NearestItem(
    T locus,
    double minimumDistance,
    double maximumDistance
)
Visual Basic
Public Function NearestItem ( _
    locus As T, _
    minimumDistance As Double, _
    maximumDistance As Double _
) As Index3d(Of T)

Parameters

locus
Type: T
Location to search from.
minimumDistance
Type: System..::..Double
Minimum distance for nearest item. Items closer than minimumDistance will be ignored.
maximumDistance
Type: System..::..Double
Maximum distance for nearest item. Items further than maximumDistance will be ignored.

Return Value

The index of the nearest item or null if no nearest item could be found.

See Also

Node3d<(Of <(<'T>)>)> Class
NearestItem Overload
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


NearestItem Method (Double, Double, Double, Validation3d(T))

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..NearestItem Method (Double, Double, Double, Validation3d<(Of <(<'T>)>)>)
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Find the nearest item using custom validation criteria.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Index3d<T> NearestItem(
    double x,
    double y,
    double z,
    Validation3d<T> validationDelegate
)
Visual Basic
Public Function NearestItem ( _
    x As Double, _
    y As Double, _
    z As Double, _
    validationDelegate As Validation3d(Of T) _
) As Index3d(Of T)

Parameters

x
Type: System..::..Double
x coordinate to search from.
y
Type: System..::..Double
y coordinate to search from.
z
Type: System..::..Double
z coordinate to search from.
validationDelegate
Type: Grasshopper.Kernel.Geometry.SpatialTrees..::..Validation3d <(Of <(<' T >)>)>
Item validation delegate.

Return Value

The index of the nearest item or null if no nearest item could be found.

See Also

Node3d<(Of <(<'T>)>)> Class
NearestItem Overload
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


NearestItem Method (Double, Double, Double, Double, Double)

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..NearestItem Method (Double, Double, Double, Double, Double)
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Find the nearest item.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Index3d<T> NearestItem(
    double x,
    double y,
    double z,
    double minimumDistance,
    double maximumDistance
)
Visual Basic
Public Function NearestItem ( _
    x As Double, _
    y As Double, _
    z As Double, _
    minimumDistance As Double, _
    maximumDistance As Double _
) As Index3d(Of T)

Parameters

x
Type: System..::..Double
x coordinate to search from.
y
Type: System..::..Double
y coordinate to search from.
z
Type: System..::..Double
z coordinate to search from.
minimumDistance
Type: System..::..Double
Minimum distance for nearest item. Items closer than minimumDistance will be ignored.
maximumDistance
Type: System..::..Double
Maximum distance for nearest item. Items further than maximumDistance will be ignored.

Return Value

The index of the nearest item or null if no nearest item could be found.

See Also

Node3d<(Of <(<'T>)>)> Class
NearestItem Overload
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


NearestItems Method

[image] [image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..NearestItems Method
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NearestItems(T, Int32) | Find the N nearest items.
Public method | NearestItems(Double, Double, Double, Int32) | Find the N nearest items.
Public method | NearestItems(T, Int32, Double, Double) | Find the N nearest items.
Public method | NearestItems(Double, Double, Double, Int32, Double, Double) | Find the N nearest items.

See Also

Node3d<(Of <(<'T>)>)> Class
Node3d<(Of <(<'T>)>)> Members
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


NearestItems Method (T, Int32)

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..NearestItems Method (T, Int32)
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Find the N nearest items.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<Index3d<T>> NearestItems(
    T locus,
    int groupSize
)
Visual Basic
Public Function NearestItems ( _
    locus As T, _
    groupSize As Integer _
) As List(Of Index3d(Of T))

Parameters

locus
Type: T
Search locus.
groupSize
Type: System..::..Int32
Number of nearest items to return.

Return Value

A list of nearest items, sorted from nearest to furthest.

See Also

Node3d<(Of <(<'T>)>)> Class
NearestItems Overload
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


NearestItems Method (Double, Double, Double, Int32)

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..NearestItems Method (Double, Double, Double, Int32)
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Find the N nearest items.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<Index3d<T>> NearestItems(
    double x,
    double y,
    double z,
    int groupSize
)
Visual Basic
Public Function NearestItems ( _
    x As Double, _
    y As Double, _
    z As Double, _
    groupSize As Integer _
) As List(Of Index3d(Of T))

Parameters

x
Type: System..::..Double
x coordinate to search from.
y
Type: System..::..Double
y coordinate to search from.
z
Type: System..::..Double
z coordinate to search from.
groupSize
Type: System..::..Int32
Number of nearest items to return.

Return Value

A list of nearest items, sorted from nearest to furthest.

See Also

Node3d<(Of <(<'T>)>)> Class
NearestItems Overload
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


NearestItems Method (T, Int32, Double, Double)

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..NearestItems Method (T, Int32, Double, Double)
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Find the N nearest items.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<Index3d<T>> NearestItems(
    T locus,
    int groupSize,
    double minimumDistance,
    double maximumDistance
)
Visual Basic
Public Function NearestItems ( _
    locus As T, _
    groupSize As Integer, _
    minimumDistance As Double, _
    maximumDistance As Double _
) As List(Of Index3d(Of T))

Parameters

locus
Type: T
Search locus.
groupSize
Type: System..::..Int32
Number of nearest items to return.
minimumDistance
Type: System..::..Double
Minimum distance for nearest items. Items closer than minimumDistance will be ignored.
maximumDistance
Type: System..::..Double
Maximum distance for nearest items. Items further than maximumDistance will be ignored.

Return Value

A list of nearest items, sorted from nearest to furthest.

See Also

Node3d<(Of <(<'T>)>)> Class
NearestItems Overload
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


NearestItems Method (Double, Double, Double, Int32, Double, Double)

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..NearestItems Method (Double, Double, Double, Int32, Double, Double)
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Find the N nearest items.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<Index3d<T>> NearestItems(
    double x,
    double y,
    double z,
    int groupSize,
    double minimumDistance,
    double maximumDistance
)
Visual Basic
Public Function NearestItems ( _
    x As Double, _
    y As Double, _
    z As Double, _
    groupSize As Integer, _
    minimumDistance As Double, _
    maximumDistance As Double _
) As List(Of Index3d(Of T))

Parameters

x
Type: System..::..Double
x coordinate to search from.
y
Type: System..::..Double
y coordinate to search from.
z
Type: System..::..Double
z coordinate to search from.
groupSize
Type: System..::..Int32
Number of nearest items to return.
minimumDistance
Type: System..::..Double
Minimum distance for nearest items. Items closer than minimumDistance will be ignored.
maximumDistance
Type: System..::..Double
Maximum distance for nearest items. Items further than maximumDistance will be ignored.

Return Value

A list of nearest items, sorted from nearest to furthest.

See Also

Node3d<(Of <(<'T>)>)> Class
NearestItems Overload
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


OptimizeTree Method

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..OptimizeTree Method
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Optimize this tree for fast searches. Do not call this method if you still plan to add items in the future. You can no longer modify this tree once it has been optimized.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Node3d<T> OptimizeTree()
Visual Basic
Public Function OptimizeTree As Node3d(Of T)

Return Value

The new root of the optimized tree. If the root could not be optimized an instance of this node will be returned.

See Also

Node3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


Remove Method

[image] [image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..Remove Method
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Remove(Int32) | Remove the item with the given index from the entire tree. It doesn't matter on which node you call this function, it is a tree-wide operation.
Public method | Remove(Index3d<(Of <<'(T>)>>)) | Remove the item with the given index from the entire tree. It doesn't matter on which node you call this function, it is a tree-wide operation.

See Also

Node3d<(Of <(<'T>)>)> Class
Node3d<(Of <(<'T>)>)> Members
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


Remove Method (Int32)

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..Remove Method (Int32)
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Remove the item with the given index from the entire tree. It doesn't matter on which node you call this function, it is a tree-wide operation.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Remove(
    int index
)
Visual Basic
Public Sub Remove ( _
    index As Integer _
)

Parameters

index
Type: System..::..Int32
Index of item to remove.

See Also

Node3d<(Of <(<'T>)>)> Class
Remove Overload
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


Remove Method (Index3d(T))

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..Remove Method (Index3d<(Of <(<'T>)>)>)
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Remove the item with the given index from the entire tree. It doesn't matter on which node you call this function, it is a tree-wide operation.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Remove(
    Index3d<T> index
)
Visual Basic
Public Sub Remove ( _
    index As Index3d(Of T) _
)

Parameters

index
Type: Grasshopper.Kernel.Geometry.SpatialTrees..::..Index3d <(Of <(<' T >)>)>
Index of item to remove.

See Also

Node3d<(Of <(<'T>)>)> Class
Remove Overload
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


ShrinkRegions Method

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..ShrinkRegions Method
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Shrink the region for this node and all child nodes. Do not use this method if you intend to add more items later as it creates spatial gaps in the tree structure. You can shrink nodes if you're done adding items and want to start searching the tree.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ShrinkRegions()
Visual Basic
Public Sub ShrinkRegions

See Also

Node3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


SubTree Method

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..SubTree Method
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Gets an iterator for all nodes in this (sub)tree.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IEnumerator<Node3d<T>> SubTree(
    bool omitStructuralNodes
)
Visual Basic
Public Function SubTree ( _
    omitStructuralNodes As Boolean _
) As IEnumerator(Of Node3d(Of T))

Parameters

omitStructuralNodes
Type: System..::..Boolean
If true, nodes that contain other nodes will be skipped. Only nodes containing items will be included.

See Also

Node3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


TrimExcess Method

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..TrimExcess Method
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Trim the excess space on all index lists. You can call this method to reduce memory usage. It will not modify the tree in any functional way.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void TrimExcess()
Visual Basic
Public Sub TrimExcess

See Also

Node3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


Node3d(T) Properties

[image] [image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)> Properties
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback

The Node3d<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Center | Gets the center of the spatial region of this node. If the node contains no children the center is always in the middle of the Region. If the node does contain child-nodes, the center may be anywhere within the region.
Public property | ChildCount | Gets the number of defined child nodes. Leaf nodes have no children. Root and twig nodes can have anywhere between 1 and 8 children.
Public property | ChildNode | Gets the child node at the given index.
Public property | ContentAverage | Returns the average coordinate of all items in this node. If this node does not contain any items, Point3d.Unset is returned.
Public property | ContentBoundingBox | Returns the boundingbox of all items in this node. If this node does not contain any items, BoundingBox.Empty is returned.
Public property | IndicesLocal | Gets the list of item indices that are contained within this node.
Public property | IndicesRecursive | Gets the list of item indices that are contained within this node and any child nodes.
Public property | IsLeaf | Gets whether this node is a leaf node. Leaf nodes have no child nodes.
Public property | IsMutable | Gets whether this tree is mutable. You can only add items to mutable trees. We don't recommend removing items from unmutable trees, though that shouldn't necessarily lead to problems. Trees become unmutable after a call to ShrinkRegions(), CollapseNodes() or OptimizeTree().
Public property | IsRoot | Gets whether this node is a root node. Root nodes have no parent node and depth zero.
Public property | IsTwig | Gets whether this node is a twig node. Twig nodes have both parents and at least one child.
Public property | ItemCount | Gets the total number of items stored directly in this node.
Public property | ItemsGlobal | Gets the list of all items stored inside this entire tree. Do not modify this collection unless you know what you are doing.
Public property | ItemsLocal | Gets a list of all the items stored directly in this node. This list is constructed every time you access this property, so keep it down to a minimum.
Public property | Limit | Gets the subdivision limit for this tree. This limit can only be set once when you create a new tree. It is fixed forever after.
Public property | MemoryConsumption | Gets the estimated memory consumption of the (sub)tree structure. Items inside the global list are not included in this estimate.
Public property | NextNode | Gets the logical neighbour to the right of this node. There is no spatial relationships between logical neighbours, this is purely an iteration aid.
Public property | NodeDepth | Gets the recursive depth of this node. The tree root is at depth zero. The first subdivision is at depth one, and so on and so forth.
Public property | ParentNode | Gets the immediate parent of this node. Root nodes have no parent.
Public property | Region | Gets the spatial region of this node.
Public property | RootNode | Gets the ultimate root node for this tree.
Public property | WeightedSubdivision | Gets or sets whether subdivision is weighted based on content averages. Setting this value will only affect future subdivisions, not existing ones.

See Also

Node3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


Center Property

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..Center Property
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the center of the spatial region of this node. If the node contains no children the center is always in the middle of the Region. If the node does contain child-nodes, the center may be anywhere within the region.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Point3d Center { get; }
Visual Basic
Public ReadOnly Property Center As Point3d
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Geometry.SpatialTrees.Node3d`1.Center"]

See Also

Node3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


ChildCount Property

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..ChildCount Property
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the number of defined child nodes. Leaf nodes have no children. Root and twig nodes can have anywhere between 1 and 8 children.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int ChildCount { get; }
Visual Basic
Public ReadOnly Property ChildCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Geometry.SpatialTrees.Node3d`1.ChildCount"]

See Also

Node3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


ChildNode Property

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..ChildNode Property
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the child node at the given index.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Node3d<T> this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property ChildNode ( _
    index As Integer _
) As Node3d(Of T)
    Get

Parameters

index
Type: System..::..Int32
Index of child node to retrieve. Valid indices are from 0 to 7 inclusive.

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Geometry.SpatialTrees.Node3d`1.ChildNode(System.Int32)"]

See Also

Node3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


ContentAverage Property

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..ContentAverage Property
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Returns the average coordinate of all items in this node. If this node does not contain any items, Point3d.Unset is returned.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Point3d ContentAverage { get; }
Visual Basic
Public ReadOnly Property ContentAverage As Point3d
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Geometry.SpatialTrees.Node3d`1.ContentAverage"]

See Also

Node3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


ContentBoundingBox Property

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..ContentBoundingBox Property
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Returns the boundingbox of all items in this node. If this node does not contain any items, BoundingBox.Empty is returned.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public BoundingBox ContentBoundingBox { get; }
Visual Basic
Public ReadOnly Property ContentBoundingBox As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Geometry.SpatialTrees.Node3d`1.ContentBoundingBox"]

See Also

Node3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


IndicesLocal Property

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..IndicesLocal Property
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the list of item indices that are contained within this node.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<int> IndicesLocal { get; }
Visual Basic
Public ReadOnly Property IndicesLocal As List(Of Integer)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Geometry.SpatialTrees.Node3d`1.IndicesLocal"]

See Also

Node3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


IndicesRecursive Property

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..IndicesRecursive Property
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the list of item indices that are contained within this node and any child nodes.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<int> IndicesRecursive { get; }
Visual Basic
Public ReadOnly Property IndicesRecursive As List(Of Integer)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Geometry.SpatialTrees.Node3d`1.IndicesRecursive"]

See Also

Node3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


IsLeaf Property

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..IsLeaf Property
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Gets whether this node is a leaf node. Leaf nodes have no child nodes.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsLeaf { get; }
Visual Basic
Public ReadOnly Property IsLeaf As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Geometry.SpatialTrees.Node3d`1.IsLeaf"]

See Also

Node3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


IsMutable Property

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..IsMutable Property
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Gets whether this tree is mutable. You can only add items to mutable trees. We don't recommend removing items from unmutable trees, though that shouldn't necessarily lead to problems. Trees become unmutable after a call to ShrinkRegions(), CollapseNodes() or OptimizeTree().

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsMutable { get; }
Visual Basic
Public ReadOnly Property IsMutable As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Geometry.SpatialTrees.Node3d`1.IsMutable"]

See Also

Node3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


IsRoot Property

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..IsRoot Property
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Gets whether this node is a root node. Root nodes have no parent node and depth zero.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsRoot { get; }
Visual Basic
Public ReadOnly Property IsRoot As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Geometry.SpatialTrees.Node3d`1.IsRoot"]

See Also

Node3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


IsTwig Property

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..IsTwig Property
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Gets whether this node is a twig node. Twig nodes have both parents and at least one child.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsTwig { get; }
Visual Basic
Public ReadOnly Property IsTwig As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Geometry.SpatialTrees.Node3d`1.IsTwig"]

See Also

Node3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


ItemCount Property

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..ItemCount Property
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the total number of items stored directly in this node.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int ItemCount { get; }
Visual Basic
Public ReadOnly Property ItemCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Geometry.SpatialTrees.Node3d`1.ItemCount"]

See Also

Node3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


ItemsGlobal Property

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..ItemsGlobal Property
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the list of all items stored inside this entire tree. Do not modify this collection unless you know what you are doing.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<T> ItemsGlobal { get; }
Visual Basic
Public ReadOnly Property ItemsGlobal As List(Of T)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Geometry.SpatialTrees.Node3d`1.ItemsGlobal"]

See Also

Node3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


ItemsLocal Property

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..ItemsLocal Property
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Gets a list of all the items stored directly in this node. This list is constructed every time you access this property, so keep it down to a minimum.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<T> ItemsLocal { get; }
Visual Basic
Public ReadOnly Property ItemsLocal As List(Of T)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Geometry.SpatialTrees.Node3d`1.ItemsLocal"]

See Also

Node3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


Limit Property

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..Limit Property
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the subdivision limit for this tree. This limit can only be set once when you create a new tree. It is fixed forever after.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int Limit { get; }
Visual Basic
Public ReadOnly Property Limit As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Geometry.SpatialTrees.Node3d`1.Limit"]

See Also

Node3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


MemoryConsumption Property

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..MemoryConsumption Property
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the estimated memory consumption of the (sub)tree structure. Items inside the global list are not included in this estimate.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public long MemoryConsumption { get; }
Visual Basic
Public ReadOnly Property MemoryConsumption As Long
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Geometry.SpatialTrees.Node3d`1.MemoryConsumption"]

See Also

Node3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


NextNode Property

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..NextNode Property
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the logical neighbour to the right of this node. There is no spatial relationships between logical neighbours, this is purely an iteration aid.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Node3d<T> NextNode { get; }
Visual Basic
Public ReadOnly Property NextNode As Node3d(Of T)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Geometry.SpatialTrees.Node3d`1.NextNode"]

See Also

Node3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


NodeDepth Property

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..NodeDepth Property
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the recursive depth of this node. The tree root is at depth zero. The first subdivision is at depth one, and so on and so forth.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int NodeDepth { get; }
Visual Basic
Public ReadOnly Property NodeDepth As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Geometry.SpatialTrees.Node3d`1.NodeDepth"]

See Also

Node3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


ParentNode Property

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..ParentNode Property
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the immediate parent of this node. Root nodes have no parent.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Node3d<T> ParentNode { get; }
Visual Basic
Public ReadOnly Property ParentNode As Node3d(Of T)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Geometry.SpatialTrees.Node3d`1.ParentNode"]

See Also

Node3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


Region Property

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..Region Property
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the spatial region of this node.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public BoundingBox Region { get; }
Visual Basic
Public ReadOnly Property Region As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Geometry.SpatialTrees.Node3d`1.Region"]

See Also

Node3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


RootNode Property

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..RootNode Property
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the ultimate root node for this tree.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Node3d<T> RootNode { get; }
Visual Basic
Public ReadOnly Property RootNode As Node3d(Of T)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Geometry.SpatialTrees.Node3d`1.RootNode"]

See Also

Node3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


WeightedSubdivision Property

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..WeightedSubdivision Property
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Gets or sets whether subdivision is weighted based on content averages. Setting this value will only affect future subdivisions, not existing ones.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool WeightedSubdivision { get; set; }
Visual Basic
Public Property WeightedSubdivision As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Geometry.SpatialTrees.Node3d`1.WeightedSubdivision"]

See Also

Node3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


TreeDelegates Class

[image]

Grasshopper SDK
TreeDelegates Class
Members See Also Send Feedback
Provides a bunch of standard coordinate extractor methods.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class TreeDelegates
Visual Basic
Public NotInheritable Class TreeDelegates

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Geometry.SpatialTrees..::..TreeDelegates

See Also

TreeDelegates Members
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


TreeDelegates Members

[image] [image]

Grasshopper SDK
TreeDelegates Members
TreeDelegates Class Methods See Also Send Feedback

The TreeDelegates type exposes the following members.

Methods

Name | Description
Node2Coordinates |
Node3Coordinates |
Point2dCoordinates |
Point2fCoordinates |
Point3dCoordinates |
Point3fCoordinates |
PointCoordinates |

See Also

TreeDelegates Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


TreeDelegates Methods

[image] [image]

Grasshopper SDK
TreeDelegates Methods
TreeDelegates Class See Also Send Feedback

The TreeDelegates type exposes the following members.

Methods

Name | Description
Node2Coordinates |
Node3Coordinates |
Point2dCoordinates |
Point2fCoordinates |
Point3dCoordinates |
Point3fCoordinates |
PointCoordinates |

See Also

TreeDelegates Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


Node2Coordinates Method

[image]

Grasshopper SDK
TreeDelegates..::..Node2Coordinates Method
TreeDelegates Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void Node2Coordinates(
    Node2 pt,
    ref double x,
    ref double y,
    ref double z
)
Visual Basic
Public Shared Sub Node2Coordinates ( _
    pt As Node2, _
    ByRef x As Double, _
    ByRef y As Double, _
    ByRef z As Double _
)

Parameters

pt
Type: Node2
x
Type: System..::..Double %
y
Type: System..::..Double %
z
Type: System..::..Double %

See Also

TreeDelegates Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


Node3Coordinates Method

[image]

Grasshopper SDK
TreeDelegates..::..Node3Coordinates Method
TreeDelegates Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void Node3Coordinates(
    Node3 pt,
    ref double x,
    ref double y,
    ref double z
)
Visual Basic
Public Shared Sub Node3Coordinates ( _
    pt As Node3, _
    ByRef x As Double, _
    ByRef y As Double, _
    ByRef z As Double _
)

Parameters

pt
Type: Node3
x
Type: System..::..Double %
y
Type: System..::..Double %
z
Type: System..::..Double %

See Also

TreeDelegates Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


Point2dCoordinates Method

[image]

Grasshopper SDK
TreeDelegates..::..Point2dCoordinates Method
TreeDelegates Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void Point2dCoordinates(
    Point2d pt,
    ref double x,
    ref double y,
    ref double z
)
Visual Basic
Public Shared Sub Point2dCoordinates ( _
    pt As Point2d, _
    ByRef x As Double, _
    ByRef y As Double, _
    ByRef z As Double _
)

Parameters

pt
Type: Point2d
x
Type: System..::..Double %
y
Type: System..::..Double %
z
Type: System..::..Double %

See Also

TreeDelegates Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


Point2fCoordinates Method

[image]

Grasshopper SDK
TreeDelegates..::..Point2fCoordinates Method
TreeDelegates Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void Point2fCoordinates(
    Point2d pt,
    ref double x,
    ref double y,
    ref double z
)
Visual Basic
Public Shared Sub Point2fCoordinates ( _
    pt As Point2d, _
    ByRef x As Double, _
    ByRef y As Double, _
    ByRef z As Double _
)

Parameters

pt
Type: Point2d
x
Type: System..::..Double %
y
Type: System..::..Double %
z
Type: System..::..Double %

See Also

TreeDelegates Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


Point3dCoordinates Method

[image]

Grasshopper SDK
TreeDelegates..::..Point3dCoordinates Method
TreeDelegates Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void Point3dCoordinates(
    Point3d pt,
    ref double x,
    ref double y,
    ref double z
)
Visual Basic
Public Shared Sub Point3dCoordinates ( _
    pt As Point3d, _
    ByRef x As Double, _
    ByRef y As Double, _
    ByRef z As Double _
)

Parameters

pt
Type: Point3d
x
Type: System..::..Double %
y
Type: System..::..Double %
z
Type: System..::..Double %

See Also

TreeDelegates Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


Point3fCoordinates Method

[image]

Grasshopper SDK
TreeDelegates..::..Point3fCoordinates Method
TreeDelegates Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void Point3fCoordinates(
    Point3d pt,
    ref double x,
    ref double y,
    ref double z
)
Visual Basic
Public Shared Sub Point3fCoordinates ( _
    pt As Point3d, _
    ByRef x As Double, _
    ByRef y As Double, _
    ByRef z As Double _
)

Parameters

pt
Type: Point3d
x
Type: System..::..Double %
y
Type: System..::..Double %
z
Type: System..::..Double %

See Also

TreeDelegates Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


PointCoordinates Method

[image]

Grasshopper SDK
TreeDelegates..::..PointCoordinates Method
TreeDelegates Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void PointCoordinates(
    Point pt,
    ref double x,
    ref double y,
    ref double z
)
Visual Basic
Public Shared Sub PointCoordinates ( _
    pt As Point, _
    ByRef x As Double, _
    ByRef y As Double, _
    ByRef z As Double _
)

Parameters

pt
Type: Point
x
Type: System..::..Double %
y
Type: System..::..Double %
z
Type: System..::..Double %

See Also

TreeDelegates Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


Validation3d(T) Delegate

[image]

Grasshopper SDK
Validation3d<(Of <(<'T>)>)> Delegate
See Also Send Feedback
Delegate to be used during advanced customized searches.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public delegate bool Validation3d<T>(
    T element,
    int globalIndex,
    Node3d<T> node
)
Visual Basic
Public Delegate Function Validation3d(Of T) ( _
    element As T, _
    globalIndex As Integer, _
    node As Node3d(Of T) _
) As Boolean

Parameters

element
Type: T
Potential hit.
globalIndex
Type: System..::..Int32
Index of item in global list.
node
Type: Grasshopper.Kernel.Geometry.SpatialTrees..::..Node3d <(Of <(<'T>)>)>
Node containing the element.

Type Parameters

T
Element type.

Return Value

True if item can be included in the search, false if not.

See Also

Grasshopper.Kernel.Geometry.SpatialTrees Namespace


Grasshopper.Kernel.Parameters Namespace

[image]

Grasshopper SDK
Grasshopper.Kernel.Parameters Namespace
Send Feedback
This namespace contains all the default Parameter objects which ship with Grasshopper.

Classes

 | Class | Description
Public class | Param_MeshParameters |

Interfaces

 | Interface | Description
Public interface | IGH_TypeHint | Represents conversion logic for a certain data type.


IGH_TypeHint Interface

[image]

Grasshopper SDK
IGH_TypeHint Interface
Members See Also Send Feedback
Represents conversion logic for a certain data type.

Namespace: Grasshopper.Kernel.Parameters
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_TypeHint
Visual Basic
Public Interface IGH_TypeHint

See Also

IGH_TypeHint Members
Grasshopper.Kernel.Parameters Namespace


IGH_TypeHint Members

[image] [image]

Grasshopper SDK
IGH_TypeHint Members
IGH_TypeHint Interface Methods Properties See Also Send Feedback

The IGH_TypeHint type exposes the following members.

Methods

 | Name | Description
Public method | Cast | Apply conversion logic to a specific object. This function should not throw exceptions.

Properties

 | Name | Description
Public property | HintID | Unique ID for every type of Hint.
Public property | TypeName | Name of target Type

See Also

IGH_TypeHint Interface
Grasshopper.Kernel.Parameters Namespace


IGH_TypeHint Methods

[image] [image]

Grasshopper SDK
IGH_TypeHint Methods
IGH_TypeHint Interface See Also Send Feedback

The IGH_TypeHint type exposes the following members.

Methods

 | Name | Description
Public method | Cast | Apply conversion logic to a specific object. This function should not throw exceptions.

See Also

IGH_TypeHint Interface
Grasshopper.Kernel.Parameters Namespace


Cast Method

[image]

Grasshopper SDK
IGH_TypeHint..::..Cast Method
IGH_TypeHint Interface See Also Send Feedback
Apply conversion logic to a specific object. This function should not throw exceptions.

Namespace: Grasshopper.Kernel.Parameters
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool Cast(
    Object data,
    out Object target
)
Visual Basic
Function Cast ( _
    data As Object, _
    <OutAttribute> ByRef target As Object _
) As Boolean

Parameters

data
Type: System..::..Object
Data to convert.
target
Type: System..::..Object %
Output instance.

Return Value

True on success, false on failure. If False is returned, target may be null.

See Also

IGH_TypeHint Interface
Grasshopper.Kernel.Parameters Namespace


IGH_TypeHint Properties

[image] [image]

Grasshopper SDK
IGH_TypeHint Properties
IGH_TypeHint Interface See Also Send Feedback

The IGH_TypeHint type exposes the following members.

Properties

 | Name | Description
Public property | HintID | Unique ID for every type of Hint.
Public property | TypeName | Name of target Type

See Also

IGH_TypeHint Interface
Grasshopper.Kernel.Parameters Namespace


HintID Property

[image]

Grasshopper SDK
IGH_TypeHint..::..HintID Property
IGH_TypeHint Interface See Also Send Feedback
Unique ID for every type of Hint.

Namespace: Grasshopper.Kernel.Parameters
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
Guid HintID { get; }
Visual Basic
ReadOnly Property HintID As Guid
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Parameters.IGH_TypeHint.HintID"]

See Also

IGH_TypeHint Interface
Grasshopper.Kernel.Parameters Namespace


TypeName Property

[image]

Grasshopper SDK
IGH_TypeHint..::..TypeName Property
IGH_TypeHint Interface See Also Send Feedback
Name of target Type

Namespace: Grasshopper.Kernel.Parameters
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string TypeName { get; }
Visual Basic
ReadOnly Property TypeName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Parameters.IGH_TypeHint.TypeName"]

See Also

IGH_TypeHint Interface
Grasshopper.Kernel.Parameters Namespace


Param_MeshParameters Class

[image]

Grasshopper SDK
Param_MeshParameters Class
Members See Also Send Feedback

Namespace: Grasshopper.Kernel.Parameters
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class Param_MeshParameters : GH_PersistentParam<GH_MeshingParameters>
Visual Basic
Public Class Param_MeshParameters _
    Inherits GH_PersistentParam(Of GH_MeshingParameters)

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel..::..GH_InstanceDescription
Grasshopper.Kernel..::..GH_DocumentObject
Grasshopper.Kernel..::..GH_ActiveObject
Grasshopper.Kernel..::..GH_Param <(Of <(<' GH_MeshingParameters >)>)>
Grasshopper.Kernel..::..GH_PersistentParam <(Of <(<' GH_MeshingParameters >)>)>
Grasshopper.Kernel.Parameters..::..Param_MeshParameters

See Also

Param_MeshParameters Members
Grasshopper.Kernel.Parameters Namespace


Param_MeshParameters Members

[image] [image]

Grasshopper SDK
Param_MeshParameters Members
Param_MeshParameters Class Constructors Methods Fields Properties Events See Also Send Feedback

The Param_MeshParameters type exposes the following members.

Constructors

 | Name | Description
Public method | Param_MeshParameters | Initializes a new instance of the Param_MeshParameters class

Methods

 | Name | Description
Public method | AddedToDocument | This method will be called when an object is added to a document. Override this method if you want to handle such events. (Inherited from GH_DocumentObject.)
Public method | AddPersistentData(Object) | Obsolete. Utility function to add a new persistent data item. If the data is null or cannot be converted into T, this method will fail. You should probably use the PersistentData property to add type-safe data if you can. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | AddPersistentData(T) | Obsolete. Utility function to add a new persistent data item. If the data is null or cannot be converted into T, this method will fail. You should probably use the PersistentData property to add type-safe data if you can. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | AddRuntimeMessage | Add a new message to this object. Valid message type flags are Warning and Error. If the Message string is empty or zero-length no message is added. (Inherited from GH_ActiveObject.)
Public method | AddSource(IGH_Param) | Append a new Source parameter to the end of the Sources list. Sources provide this parameter with data at runtime. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddSource(IGH_Param, Int32) | Insert a new Source parameter into the Sources list. Sources provide this parameter with data at runtime. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddVolatileData(GH_Path, Int32, Object) | Inserts an item of volatile data into the data structure. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddVolatileData(GH_Path, Int32, T) | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddVolatileDataList(GH_Path, List<(Of <<'(T>)>>)) | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddVolatileDataList(GH_Path, IEnumerable) | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddVolatileDataTree(GH_Structure<(Of <<'(T>)>>)) | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddVolatileDataTree(IGH_Structure) | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AppendAdditionalMenuItems | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | AppendMenuItems | This function is called when a context menu is about to be displayed. Override it to set custom items. GH_ActiveObject will already populate the menu with default items, if you merely wish to insert object-specific menu item, consider overriding AppendAdditionalMenuItems instead. (Inherited from GH_ActiveObject.)
Protected method | Cast_Object | Attempts to convert the Object reference into an instance of T. This method will perform a direct cast if possible or it will call Casting functions on T or Data if they exist. Data will not be duplicated unless a type conversion is required. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ClearData | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ClearProxySources | Remove all proxy sources without attempting to relink them. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ClearRuntimeMessages | Destroy all warning and error lists (Inherited from GH_ActiveObject.)
Public method | CollectData | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | CollectVolatileData_Custom | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | CollectVolatileData_FromSources | This method collects volatile data from all the source parameters. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ComputeData | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | CopyFrom | Copy all fields (except the instance ID) from another instance description. (Inherited from GH_InstanceDescription.)
Public method | CreateAttributes | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | CreateProxySources | Convert all proper source parameters into proxy sources. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | DependsOn | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | DestroyIconCache | Call this method to erase the existing icon cache. You must call this if you want to change the display icon of an object. (Inherited from GH_DocumentObject.)
Public method | DocumentContextChanged | This method will be called when the document that owns this object moves into a different context. (Inherited from GH_DocumentObject.)
Protected method | ExpireDownStreamObjects | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ExpirePreview | Call this function when you suspect that the preview has expired for this object. This will cause the display cache to be eradicated. (Inherited from GH_DocumentObject.)
Public method | ExpireSolution | Informs the document that owns this object that the solution has expired. The current object will be set to BLANK as a result. This method is recursive, it will also expire any and all objects which depend on this object. If you want a less destructive expiration, consider using ClearData(). If this object is already Blank, you should consider not expiring it. (Inherited from GH_ActiveObject.)
Protected method | Format | Returns "Null" if the data is a null reference, otherwise calls ToString() on the Data instance. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | GetValue(String, Boolean) | Get a boolean value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Double) | Get a double value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Color) | Get a color value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Int32) | Get an integer value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, String) | Get a string value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | HtmlHelp_Source | Return a String which contains HTML formatted source for the help topic. If you want to pass a URL that points to a remote page, then prefix the URL with a GOTO: tag, like so: GOTO:http://www.YourWebAddressHere.com (Inherited from GH_DocumentObject.)
Protected method | InstantiateT | Attempts to instantiate a new instance of T. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | IsolateObject | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendBakeItem | Append the default Bake menu item. (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendDestroyPersistent | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | Menu_AppendDisconnectWires | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendEnableItem | Append the default Enable/Disable menu item. (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendExtractParameter | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | Menu_AppendFlattenParameter | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendGraftParameter | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendInternaliseData | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | Menu_AppendManageCollection | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | Menu_AppendObjectHelp | Appends the default object Help menu item. (Inherited from GH_DocumentObject.)
Protected method | Menu_AppendObjectName | Appends the old-fashioned object name menu item. If you also want the Display mode toggle then use Menu_AppendObjectNameEx() (Inherited from GH_DocumentObject.)
Protected method | Menu_AppendObjectNameEx | Appends the default object name + display mode menu item. (Inherited from GH_DocumentObject.)
Protected method | Menu_AppendPreviewItem | Append the default Show/Hide preview menu item. (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendPrincipalParameter | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendPromptMore | (Overrides GH_PersistentParam<(Of <(<'T>)>)>..::..Menu_AppendPromptMore(ToolStripDropDown).)
Protected method | Menu_AppendPromptOne | (Overrides GH_PersistentParam<(Of <(<'T>)>)>..::..Menu_AppendPromptOne(ToolStripDropDown).)
Protected method | Menu_AppendReverseParameter | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendRuntimeMessages | Append the default warnings and errors menu items. (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendSimplifyParameter | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendWarningsAndErrors | Obsolete. This method is obsolete and has been replaced with Menu_AppendRuntimeMessages(). (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendWireDisplay | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_CreateMultilineTextEditItem | This function returns a ToolstripMenuItem that embeds a multi-line textbox for editing persistent data. Only call this method if you know that your parameter type supports proxies. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | Menu_CustomMultiValueItem | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | Menu_CustomSingleValueItem | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | MovedBetweenDocuments | This method will be called when an object is moved from one document to another. Override this method if you want to handle such events. (Inherited from GH_DocumentObject.)
Public method | NewInstanceGuid()()()() | Generate a new random instance GUID (Inherited from GH_InstanceDescription.)
Public method | NewInstanceGuid(Guid) | Set the instance ID to be a specific GUID. This is very dangerous, only use this function if you're 6"4' and your first name is David. (Inherited from GH_InstanceDescription.)
Public method | OnAttributesChanged | Raises the AttributesChanged event on the toplevel object. (Inherited from GH_DocumentObject.)
Public method | OnDisplayExpired | Raises the DisplayExpired event on the toplevel object. (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(String) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectChangedEventArgs) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(String, Object) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType, Object) | (Inherited from GH_DocumentObject.)
Public method | OnPingDocument | Raise the PingDocument Event on the toplevel object and try to find the document which owns this object. (Inherited from GH_DocumentObject.)
Public method | OnPreviewExpired | Raises the PreviewExpired event on the toplevel object. (Inherited from GH_DocumentObject.)
Public method | OnSolutionExpired | Raises the SolutionExpired event on the toplevel object. You probably want to call ExpireSolution() instead of this method directly. (Inherited from GH_DocumentObject.)
Protected method | OnVolatileDataCollected | Once volatile data has been collected this method will be calles. The basic implementation does nothing, but you can add code here to post-process or analyze the volatile data. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | PreferredCast | Implement this function if you're certain that you'll be confronted with very common casts. For example, GH_Point has a preferred cast from Rhino.Geometry.Point3d and GH_Number has a preferred cast from System.Double. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | PrepareForPrompt | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | Preview_ComputeClippingBox | This function can be used to iterate over all items in the Volatile data tree and collect the union clipping box of all non-null items that implement Preview.IGH_PreviewData. This function requires a lot of TypeOf and DirectCasting, so if you're worried about performance you should consider doing this yourself. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Preview_DrawMeshes | This function can be used to iterate over all items in the Volatile data tree and call DrawViewportWires on each item that implements Preview.IGH_PreviewData. This function requires a lot of TypeOf and DirectCasting, so if you're worried about performance you should consider doing this yourself. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Preview_DrawWires | This function can be used to iterate over all items in the Volatile data tree and call DrawViewportWires on each item that implements Preview.IGH_PreviewData. This function requires a lot of TypeOf and DirectCasting, so if you're worried about performance you should consider doing this yourself. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Prompt_ManageCollection | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | Prompt_Plural | (Overrides GH_PersistentParam<(Of <(<'T>)>)>..::..Prompt_Plural(List<(Of <<'(T>)>>)%).)
Protected method | Prompt_Singular | (Overrides GH_PersistentParam<(Of <(<'T>)>)>..::..Prompt_Singular(T%).)
Public method | Read | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | ReadFull | GH_InstanceDescription does not by default serialize all fields. Use this function to read all fields from the archive. This method is compatible with the default Write()/Read() operations. (Inherited from GH_InstanceDescription.)
Protected method | RecordPersistentDataEvent | Add an undo record that stores changes to persistent data. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | RecordUndoEvent(String) | Record a generic object change undo event. (Inherited from GH_DocumentObject.)
Public method | RecordUndoEvent(GH_UndoRecord) | Record an entire undo record. (Inherited from GH_DocumentObject.)
Public method | RecordUndoEvent(String, IGH_UndoAction) | Record a specific object change undo event. (Inherited from GH_DocumentObject.)
Protected method | RecoverFromPrompt | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | RegisterRemoteIDs | Override this function if you want object changes in the Rhino document to trigger a new solution. (Inherited from GH_ActiveObject.)
Protected method | RegisterRemoteIDsUtil | Utility function which treats all data in the Volatile cache as IGH_GeometricGoo and registers all referenced objects. Call this function from within RegisterRemoteIDs() if you are absolutely sure that all the items in volatiledata implement IGH_GeometricGoo. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | RelinkProxySources | Attempt to replace all proxy sources with real sources. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | RemoveAllSources | Remove all sources from this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | RemovedFromDocument | This method will be called when an object is removed from a document. Override this method if you want to handle such events. (Inherited from GH_DocumentObject.)
Public method | RemoveEffects | Remove all post-process effects. Note to implementors, you must call the base method if you override this function. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | RemoveSource(Guid) | Remove the specified source from this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | RemoveSource(IGH_Param) | Remove the specified source from this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ReplaceSource(Guid, IGH_Param) | Replace an existing source with a new one. If the old_source does not exist in this parameter, nothing happens. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ReplaceSource(IGH_Param, IGH_Param) | Replace an existing source with a new one. If the old_source does not exist in this parameter, nothing happens. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | RuntimeMessages | Gets the list of cached runtime messages that were recorded during solver-time processes. (Inherited from GH_ActiveObject.)
Public method | Script_AddPersistentData | Method used primarily for COM_Access code. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | Script_ClearPersistentData | Method used primarily for COM_Access code. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | SDKCompliancy | Test whether this object is compliant with a given Rhino version. (Inherited from GH_ActiveObject.)
Public method | SetIconOverride | Set a new custom icon override for this object. (Inherited from GH_DocumentObject.)
Public method | SetPersistentData(array<Object>[]()[][]) | Add a collection of values to the persistent data. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | SetPersistentData(T) | Add a single item to the persistent data. This method will record an undo event, raise the OnObjectChanged event for PersistentData flags and place a call to ExpireSolution(False). If you want to add more than one piece of data, you should use the appropriate overload for this method. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | SetPrincipal | Set the principal parameter state. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | SetValue(String, Boolean) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Double) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Color) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Int32) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, String) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave()()()() | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(Guid) | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger, Guid) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from GH_DocumentObject.)
Protected method | ValuesChanged | Override this method if you want to respond to changes to the value table. The base implementation is empty, so you don't have to call it. (Inherited from GH_DocumentObject.)
Protected method | VolatileDataDescription | This method is called to populate the Tooltip data description field. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | Write | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | WriteFull | GH_InstanceDescription does not by default serialize all fields. Use this function to write all fields to the archive. This method is compatible with the default Write()/Read() operations. (Inherited from GH_InstanceDescription.)

Fields

 | Name | Description
Protected field | m_attributes | (Inherited from GH_DocumentObject.)
Protected field | m_data | Contains the runtime data for this parameter, also known as "Volatile" data. (Inherited from GH_Param<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Access | Gets or sets the Access level for this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | Attributes | Gets or sets the attributes that are associated with this object. Only set custom attributes if you know what you are doing. (Inherited from GH_DocumentObject.)
Public property | Category | Gets or sets the Category in which this object belongs. If HasCategory() returns false, this field has no meaning. (Inherited from GH_InstanceDescription.)
Public property | ComponentGuid | (Overrides GH_DocumentObject..::..ComponentGuid.)
Public property | DataMapping | Gets or sets the data mapping of this Parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | DataType | Gets the type of data stored in this parameter. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public property | Description | Gets or sets the description of the object. This field typically remains fixed during the lifetime of an object. (Inherited from GH_InstanceDescription.)
Public property | Exposure | (Overrides GH_DocumentObject..::..Exposure.)
Public property | HasCategory | Gets whether or not the Category field has been set. (Inherited from GH_InstanceDescription.)
Public property | HasProxySources | Gets a value indicating whether or not this parameter maintains proxy sources. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | HasSubCategory | Gets whether or not the SubCategory field has been set. (Inherited from GH_InstanceDescription.)
Protected property | Icon | (Overrides GH_DocumentObject..::..Icon.)
Public property | Icon_24x24 | The icon associated with this object. (Inherited from GH_DocumentObject.)
Public property | Icon_24x24_Locked | The greyscale icon of this object. (Inherited from GH_DocumentObject.)
Public property | IconCapableUI | By default the NickName menu item supports the Icon Mode override toggle. If your UI is not capable of displaying icons, then override this property and return False. (Inherited from GH_ActiveObject.)
Public property | IconDisplayMode | Gets the current display mode of the object. (Inherited from GH_DocumentObject.)
Public property | InstanceDescription | Gets the description of this instance. The default description is about the amount and source of the local values. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | InstanceGuid | Gets the ID of this runtime instance. (Inherited from GH_InstanceDescription.)
Public property | IsDataProvider | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | IsPrincipal | Gets whether this parameter is a principal parameter. Principal parameters are maintained by components and are not part of the IGH_Param interface. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | Keywords | Gets a list of additional keywords that describe the object. Typically this list is empty but you can override this property to aid in object searches. (Inherited from GH_InstanceDescription.)
Public property | Kind | Gets the parameter kind. The kind is evaluated lazily and cached. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | Locked | Gets or sets the enabled flag of this object. Disabled objects are ignored during solutions. (Inherited from GH_ActiveObject.)
Public property | MutableNickName | Gets or sets a value that enables Nick name changes through the menu. The default is TRUE. (Inherited from GH_ActiveObject.)
Public property | Name | Gets or sets the name of the object. This field typically remains fixed during the lifetime of an object. (Inherited from GH_InstanceDescription.)
Public property | NickName | Gets or sets the nickname of the object. This field can be changed by the user. (Inherited from GH_InstanceDescription.)
Public property | Obsolete | Gets whether this object is obsolete. Default implementation returns true if the class name contains the string "OBSOLETE" or if this class has been decorated with the ObsoleteAttribute. You are free to override this if you want, but I suggest adding the ObsoleteAttribute instead. (Inherited from GH_DocumentObject.)
Public property | Optional | Gets or sets whether or not this parameter is considered optional by the owner component. Empty, non-optional parameters prevent the component from being solved. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | PersistentData | Gets the persistent data stored in this parameter. If you modify the persistent data, be sure to call the: OnObjectChanged(GH_ObjectEventType.PersistentData) event. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public property | PersistentDataCount | Gets the number of persistent data items stored in this parameter. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public property | Phase | Gets or sets the solution phase this object is currenly in. (Inherited from GH_ActiveObject.)
Public property | ProcessorTime | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | ProxySourceCount | Gets the number of proxy sources for this parameter. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | Recipients | Gets a list of all the recipients of this parameter. I.e. a recipient has this parameter as one of the sources. The Recipient list is maintained by the parameter, do not modify it yourself. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | Reverse | Gets or sets the data reverse modifier of this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | RuntimeMessageLevel | Returns the worst case flag for the current object If the object contains at least 1 error, the result is Error. If the object contains at least 1 warning, the result is Warning. If the object contains at least 1 message, the result is Remark. If the object contains no errors, no warnings and no messages, the result is Blank. (Inherited from GH_ActiveObject.)
Public property | Simplify | Gets or sets the simplify modifier for this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | SourceCount | Gets the number of sources for this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | Sources | Gets a list of source parameters. Do not modify this list, if you wish to add or remove sources, use dedicated functions like AddSource() and RemoveSource() instead. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | StateTags | Gets all the StateTags that are associated with this parameter. A state tag is a visual feedback icon that represents specific internal settings. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | SubCategory | Gets or sets the SubCategory in which this object belongs. If HasSubCategory() returns false, this field has no meaning. (Inherited from GH_InstanceDescription.)
Public property | Type | Gets the Framework Type descriptor for the stored Data. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | TypeName | Calls TypeName() on the first instance of T it can find. This is either an item in the volatile list, or a newly constructed instance. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | VolatileData | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | VolatileDataCount | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | WireDisplay | Gets or sets the wire display style for this parameter. Wire display only affects the wires connected to the parameter input. (Inherited from GH_Param<(Of <(<'T>)>)>.)

Events

 | Name | Description
Public event | AttributesChanged | Raised whenever the number or kind of attributes changes. This event is handled by GH_Documents who subsequently wipe their attribute caches. (Inherited from GH_DocumentObject.)
Public event | DisplayExpired | Raised whenever the display (on the Canvas) of a certain object becomes invalid. (Inherited from GH_DocumentObject.)
Public event | ObjectChanged | (Inherited from GH_DocumentObject.)
Public event | PingDocument | Raised whenever an object needs to know which GH_Document it belongs to. (Inherited from GH_DocumentObject.)
Public event | PreviewExpired | Raised whenever the display (in the Rhino viewports) of a certain object becomes invalid. (Inherited from GH_DocumentObject.)
Public event | SolutionExpired | Raised whenever the solution of a certain object becomes invalid. (Inherited from GH_DocumentObject.)

See Also

Param_MeshParameters Class
Grasshopper.Kernel.Parameters Namespace


Param_MeshParameters Constructor

[image]

Grasshopper SDK
Param_MeshParameters Constructor
Param_MeshParameters Class See Also Send Feedback
Initializes a new instance of the Param_MeshParameters class

Namespace: Grasshopper.Kernel.Parameters
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Param_MeshParameters()
Visual Basic
Public Sub New

See Also

Param_MeshParameters Class
Grasshopper.Kernel.Parameters Namespace


Param_MeshParameters Fields

[image] [image]

Grasshopper SDK
Param_MeshParameters Fields
Param_MeshParameters Class See Also Send Feedback

The Param_MeshParameters type exposes the following members.

Fields

 | Name | Description
Protected field | m_attributes | (Inherited from GH_DocumentObject.)
Protected field | m_data | Contains the runtime data for this parameter, also known as "Volatile" data. (Inherited from GH_Param<(Of <(<'T>)>)>.)

See Also

Param_MeshParameters Class
Grasshopper.Kernel.Parameters Namespace


Param_MeshParameters Methods

[image] [image]

Grasshopper SDK
Param_MeshParameters Methods
Param_MeshParameters Class See Also Send Feedback

The Param_MeshParameters type exposes the following members.

Methods

 | Name | Description
Public method | AddedToDocument | This method will be called when an object is added to a document. Override this method if you want to handle such events. (Inherited from GH_DocumentObject.)
Public method | AddPersistentData(Object) | Obsolete. Utility function to add a new persistent data item. If the data is null or cannot be converted into T, this method will fail. You should probably use the PersistentData property to add type-safe data if you can. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | AddPersistentData(T) | Obsolete. Utility function to add a new persistent data item. If the data is null or cannot be converted into T, this method will fail. You should probably use the PersistentData property to add type-safe data if you can. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | AddRuntimeMessage | Add a new message to this object. Valid message type flags are Warning and Error. If the Message string is empty or zero-length no message is added. (Inherited from GH_ActiveObject.)
Public method | AddSource(IGH_Param) | Append a new Source parameter to the end of the Sources list. Sources provide this parameter with data at runtime. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddSource(IGH_Param, Int32) | Insert a new Source parameter into the Sources list. Sources provide this parameter with data at runtime. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddVolatileData(GH_Path, Int32, Object) | Inserts an item of volatile data into the data structure. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddVolatileData(GH_Path, Int32, T) | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddVolatileDataList(GH_Path, List<(Of <<'(T>)>>)) | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddVolatileDataList(GH_Path, IEnumerable) | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddVolatileDataTree(GH_Structure<(Of <<'(T>)>>)) | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddVolatileDataTree(IGH_Structure) | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AppendAdditionalMenuItems | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | AppendMenuItems | This function is called when a context menu is about to be displayed. Override it to set custom items. GH_ActiveObject will already populate the menu with default items, if you merely wish to insert object-specific menu item, consider overriding AppendAdditionalMenuItems instead. (Inherited from GH_ActiveObject.)
Protected method | Cast_Object | Attempts to convert the Object reference into an instance of T. This method will perform a direct cast if possible or it will call Casting functions on T or Data if they exist. Data will not be duplicated unless a type conversion is required. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ClearData | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ClearProxySources | Remove all proxy sources without attempting to relink them. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ClearRuntimeMessages | Destroy all warning and error lists (Inherited from GH_ActiveObject.)
Public method | CollectData | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | CollectVolatileData_Custom | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | CollectVolatileData_FromSources | This method collects volatile data from all the source parameters. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ComputeData | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | CopyFrom | Copy all fields (except the instance ID) from another instance description. (Inherited from GH_InstanceDescription.)
Public method | CreateAttributes | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | CreateProxySources | Convert all proper source parameters into proxy sources. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | DependsOn | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | DestroyIconCache | Call this method to erase the existing icon cache. You must call this if you want to change the display icon of an object. (Inherited from GH_DocumentObject.)
Public method | DocumentContextChanged | This method will be called when the document that owns this object moves into a different context. (Inherited from GH_DocumentObject.)
Protected method | ExpireDownStreamObjects | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ExpirePreview | Call this function when you suspect that the preview has expired for this object. This will cause the display cache to be eradicated. (Inherited from GH_DocumentObject.)
Public method | ExpireSolution | Informs the document that owns this object that the solution has expired. The current object will be set to BLANK as a result. This method is recursive, it will also expire any and all objects which depend on this object. If you want a less destructive expiration, consider using ClearData(). If this object is already Blank, you should consider not expiring it. (Inherited from GH_ActiveObject.)
Protected method | Format | Returns "Null" if the data is a null reference, otherwise calls ToString() on the Data instance. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | GetValue(String, Boolean) | Get a boolean value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Double) | Get a double value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Color) | Get a color value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Int32) | Get an integer value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, String) | Get a string value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | HtmlHelp_Source | Return a String which contains HTML formatted source for the help topic. If you want to pass a URL that points to a remote page, then prefix the URL with a GOTO: tag, like so: GOTO:http://www.YourWebAddressHere.com (Inherited from GH_DocumentObject.)
Protected method | InstantiateT | Attempts to instantiate a new instance of T. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | IsolateObject | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendBakeItem | Append the default Bake menu item. (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendDestroyPersistent | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | Menu_AppendDisconnectWires | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendEnableItem | Append the default Enable/Disable menu item. (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendExtractParameter | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | Menu_AppendFlattenParameter | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendGraftParameter | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendInternaliseData | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | Menu_AppendManageCollection | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | Menu_AppendObjectHelp | Appends the default object Help menu item. (Inherited from GH_DocumentObject.)
Protected method | Menu_AppendObjectName | Appends the old-fashioned object name menu item. If you also want the Display mode toggle then use Menu_AppendObjectNameEx() (Inherited from GH_DocumentObject.)
Protected method | Menu_AppendObjectNameEx | Appends the default object name + display mode menu item. (Inherited from GH_DocumentObject.)
Protected method | Menu_AppendPreviewItem | Append the default Show/Hide preview menu item. (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendPrincipalParameter | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendPromptMore | (Overrides GH_PersistentParam<(Of <(<'T>)>)>..::..Menu_AppendPromptMore(ToolStripDropDown).)
Protected method | Menu_AppendPromptOne | (Overrides GH_PersistentParam<(Of <(<'T>)>)>..::..Menu_AppendPromptOne(ToolStripDropDown).)
Protected method | Menu_AppendReverseParameter | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendRuntimeMessages | Append the default warnings and errors menu items. (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendSimplifyParameter | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_AppendWarningsAndErrors | Obsolete. This method is obsolete and has been replaced with Menu_AppendRuntimeMessages(). (Inherited from GH_ActiveObject.)
Protected method | Menu_AppendWireDisplay | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Menu_CreateMultilineTextEditItem | This function returns a ToolstripMenuItem that embeds a multi-line textbox for editing persistent data. Only call this method if you know that your parameter type supports proxies. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | Menu_CustomMultiValueItem | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | Menu_CustomSingleValueItem | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | MovedBetweenDocuments | This method will be called when an object is moved from one document to another. Override this method if you want to handle such events. (Inherited from GH_DocumentObject.)
Public method | NewInstanceGuid()()()() | Generate a new random instance GUID (Inherited from GH_InstanceDescription.)
Public method | NewInstanceGuid(Guid) | Set the instance ID to be a specific GUID. This is very dangerous, only use this function if you're 6"4' and your first name is David. (Inherited from GH_InstanceDescription.)
Public method | OnAttributesChanged | Raises the AttributesChanged event on the toplevel object. (Inherited from GH_DocumentObject.)
Public method | OnDisplayExpired | Raises the DisplayExpired event on the toplevel object. (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(String) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectChangedEventArgs) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(String, Object) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType, Object) | (Inherited from GH_DocumentObject.)
Public method | OnPingDocument | Raise the PingDocument Event on the toplevel object and try to find the document which owns this object. (Inherited from GH_DocumentObject.)
Public method | OnPreviewExpired | Raises the PreviewExpired event on the toplevel object. (Inherited from GH_DocumentObject.)
Public method | OnSolutionExpired | Raises the SolutionExpired event on the toplevel object. You probably want to call ExpireSolution() instead of this method directly. (Inherited from GH_DocumentObject.)
Protected method | OnVolatileDataCollected | Once volatile data has been collected this method will be calles. The basic implementation does nothing, but you can add code here to post-process or analyze the volatile data. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | PreferredCast | Implement this function if you're certain that you'll be confronted with very common casts. For example, GH_Point has a preferred cast from Rhino.Geometry.Point3d and GH_Number has a preferred cast from System.Double. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | PrepareForPrompt | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | Preview_ComputeClippingBox | This function can be used to iterate over all items in the Volatile data tree and collect the union clipping box of all non-null items that implement Preview.IGH_PreviewData. This function requires a lot of TypeOf and DirectCasting, so if you're worried about performance you should consider doing this yourself. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Preview_DrawMeshes | This function can be used to iterate over all items in the Volatile data tree and call DrawViewportWires on each item that implements Preview.IGH_PreviewData. This function requires a lot of TypeOf and DirectCasting, so if you're worried about performance you should consider doing this yourself. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Preview_DrawWires | This function can be used to iterate over all items in the Volatile data tree and call DrawViewportWires on each item that implements Preview.IGH_PreviewData. This function requires a lot of TypeOf and DirectCasting, so if you're worried about performance you should consider doing this yourself. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | Prompt_ManageCollection | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Protected method | Prompt_Plural | (Overrides GH_PersistentParam<(Of <(<'T>)>)>..::..Prompt_Plural(List<(Of <<'(T>)>>)%).)
Protected method | Prompt_Singular | (Overrides GH_PersistentParam<(Of <(<'T>)>)>..::..Prompt_Singular(T%).)
Public method | Read | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | ReadFull | GH_InstanceDescription does not by default serialize all fields. Use this function to read all fields from the archive. This method is compatible with the default Write()/Read() operations. (Inherited from GH_InstanceDescription.)
Protected method | RecordPersistentDataEvent | Add an undo record that stores changes to persistent data. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | RecordUndoEvent(String) | Record a generic object change undo event. (Inherited from GH_DocumentObject.)
Public method | RecordUndoEvent(GH_UndoRecord) | Record an entire undo record. (Inherited from GH_DocumentObject.)
Public method | RecordUndoEvent(String, IGH_UndoAction) | Record a specific object change undo event. (Inherited from GH_DocumentObject.)
Protected method | RecoverFromPrompt | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | RegisterRemoteIDs | Override this function if you want object changes in the Rhino document to trigger a new solution. (Inherited from GH_ActiveObject.)
Protected method | RegisterRemoteIDsUtil | Utility function which treats all data in the Volatile cache as IGH_GeometricGoo and registers all referenced objects. Call this function from within RegisterRemoteIDs() if you are absolutely sure that all the items in volatiledata implement IGH_GeometricGoo. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | RelinkProxySources | Attempt to replace all proxy sources with real sources. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | RemoveAllSources | Remove all sources from this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | RemovedFromDocument | This method will be called when an object is removed from a document. Override this method if you want to handle such events. (Inherited from GH_DocumentObject.)
Public method | RemoveEffects | Remove all post-process effects. Note to implementors, you must call the base method if you override this function. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | RemoveSource(Guid) | Remove the specified source from this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | RemoveSource(IGH_Param) | Remove the specified source from this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ReplaceSource(Guid, IGH_Param) | Replace an existing source with a new one. If the old_source does not exist in this parameter, nothing happens. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ReplaceSource(IGH_Param, IGH_Param) | Replace an existing source with a new one. If the old_source does not exist in this parameter, nothing happens. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | RuntimeMessages | Gets the list of cached runtime messages that were recorded during solver-time processes. (Inherited from GH_ActiveObject.)
Public method | Script_AddPersistentData | Method used primarily for COM_Access code. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | Script_ClearPersistentData | Method used primarily for COM_Access code. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | SDKCompliancy | Test whether this object is compliant with a given Rhino version. (Inherited from GH_ActiveObject.)
Public method | SetIconOverride | Set a new custom icon override for this object. (Inherited from GH_DocumentObject.)
Public method | SetPersistentData(array<Object>[]()[][]) | Add a collection of values to the persistent data. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | SetPersistentData(T) | Add a single item to the persistent data. This method will record an undo event, raise the OnObjectChanged event for PersistentData flags and place a call to ExpireSolution(False). If you want to add more than one piece of data, you should use the appropriate overload for this method. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | SetPrincipal | Set the principal parameter state. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Protected method | SetValue(String, Boolean) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Double) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Color) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Int32) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, String) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave()()()() | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(Guid) | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger, Guid) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from GH_DocumentObject.)
Protected method | ValuesChanged | Override this method if you want to respond to changes to the value table. The base implementation is empty, so you don't have to call it. (Inherited from GH_DocumentObject.)
Protected method | VolatileDataDescription | This method is called to populate the Tooltip data description field. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | Write | (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | WriteFull | GH_InstanceDescription does not by default serialize all fields. Use this function to write all fields to the archive. This method is compatible with the default Write()/Read() operations. (Inherited from GH_InstanceDescription.)

See Also

Param_MeshParameters Class
Grasshopper.Kernel.Parameters Namespace


AddPersistentData Method

[image] [image]

Grasshopper SDK
Param_MeshParameters..::..AddPersistentData Method
Param_MeshParameters Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddPersistentData(Object) | Obsolete. Utility function to add a new persistent data item. If the data is null or cannot be converted into T, this method will fail. You should probably use the PersistentData property to add type-safe data if you can. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | AddPersistentData(T) | Obsolete. Utility function to add a new persistent data item. If the data is null or cannot be converted into T, this method will fail. You should probably use the PersistentData property to add type-safe data if you can. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)

See Also

Param_MeshParameters Class
Param_MeshParameters Members
Grasshopper.Kernel.Parameters Namespace


AddSource Method

[image] [image]

Grasshopper SDK
Param_MeshParameters..::..AddSource Method
Param_MeshParameters Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddSource(IGH_Param) | Append a new Source parameter to the end of the Sources list. Sources provide this parameter with data at runtime. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddSource(IGH_Param, Int32) | Insert a new Source parameter into the Sources list. Sources provide this parameter with data at runtime. (Inherited from GH_Param<(Of <(<'T>)>)>.)

See Also

Param_MeshParameters Class
Param_MeshParameters Members
Grasshopper.Kernel.Parameters Namespace


AddVolatileData Method

[image] [image]

Grasshopper SDK
Param_MeshParameters..::..AddVolatileData Method
Param_MeshParameters Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddVolatileData(GH_Path, Int32, Object) | Inserts an item of volatile data into the data structure. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddVolatileData(GH_Path, Int32, T) | (Inherited from GH_Param<(Of <(<'T>)>)>.)

See Also

Param_MeshParameters Class
Param_MeshParameters Members
Grasshopper.Kernel.Parameters Namespace


AddVolatileDataList Method

[image] [image]

Grasshopper SDK
Param_MeshParameters..::..AddVolatileDataList Method
Param_MeshParameters Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddVolatileDataList(GH_Path, List<(Of <<'(T>)>>)) | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddVolatileDataList(GH_Path, IEnumerable) | (Inherited from GH_Param<(Of <(<'T>)>)>.)

See Also

Param_MeshParameters Class
Param_MeshParameters Members
Grasshopper.Kernel.Parameters Namespace


AddVolatileDataTree Method

[image] [image]

Grasshopper SDK
Param_MeshParameters..::..AddVolatileDataTree Method
Param_MeshParameters Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddVolatileDataTree(GH_Structure<(Of <<'(T>)>>)) | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | AddVolatileDataTree(IGH_Structure) | (Inherited from GH_Param<(Of <(<'T>)>)>.)

See Also

Param_MeshParameters Class
Param_MeshParameters Members
Grasshopper.Kernel.Parameters Namespace


GetValue Method

[image] [image]

Grasshopper SDK
Param_MeshParameters..::..GetValue Method
Param_MeshParameters Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetValue(String, Boolean) | Get a boolean value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Double) | Get a double value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Color) | Get a color value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, Int32) | Get an integer value from the component value table. (Inherited from GH_DocumentObject.)
Protected method | GetValue(String, String) | Get a string value from the component value table. (Inherited from GH_DocumentObject.)

See Also

Param_MeshParameters Class
Param_MeshParameters Members
Grasshopper.Kernel.Parameters Namespace


Menu_AppendPromptMore Method

[image]

Grasshopper SDK
Param_MeshParameters..::..Menu_AppendPromptMore Method
Param_MeshParameters Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Parameters
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Menu_AppendPromptMore(
    ToolStripDropDown menu
)
Visual Basic
Protected Overrides Sub Menu_AppendPromptMore ( _
    menu As ToolStripDropDown _
)

Parameters

menu
Type: System.Windows.Forms..::..ToolStripDropDown

See Also

Param_MeshParameters Class
Grasshopper.Kernel.Parameters Namespace


Menu_AppendPromptOne Method

[image]

Grasshopper SDK
Param_MeshParameters..::..Menu_AppendPromptOne Method
Param_MeshParameters Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Parameters
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Menu_AppendPromptOne(
    ToolStripDropDown menu
)
Visual Basic
Protected Overrides Sub Menu_AppendPromptOne ( _
    menu As ToolStripDropDown _
)

Parameters

menu
Type: System.Windows.Forms..::..ToolStripDropDown

See Also

Param_MeshParameters Class
Grasshopper.Kernel.Parameters Namespace


NewInstanceGuid Method

[image] [image]

Grasshopper SDK
Param_MeshParameters..::..NewInstanceGuid Method
Param_MeshParameters Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NewInstanceGuid()()()() | Generate a new random instance GUID (Inherited from GH_InstanceDescription.)
Public method | NewInstanceGuid(Guid) | Set the instance ID to be a specific GUID. This is very dangerous, only use this function if you're 6"4' and your first name is David. (Inherited from GH_InstanceDescription.)

See Also

Param_MeshParameters Class
Param_MeshParameters Members
Grasshopper.Kernel.Parameters Namespace


OnObjectChanged Method

[image] [image]

Grasshopper SDK
Param_MeshParameters..::..OnObjectChanged Method
Param_MeshParameters Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OnObjectChanged(String) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectChangedEventArgs) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(String, Object) | (Inherited from GH_DocumentObject.)
Public method | OnObjectChanged(GH_ObjectEventType, Object) | (Inherited from GH_DocumentObject.)

See Also

Param_MeshParameters Class
Param_MeshParameters Members
Grasshopper.Kernel.Parameters Namespace


Prompt_Plural Method

[image]

Grasshopper SDK
Param_MeshParameters..::..Prompt_Plural Method
Param_MeshParameters Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Parameters
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override GH_GetterResult Prompt_Plural(
    ref List<GH_MeshingParameters> values
)
Visual Basic
Protected Overrides Function Prompt_Plural ( _
    ByRef values As List(Of GH_MeshingParameters) _
) As GH_GetterResult

Parameters

values
Type: System.Collections.Generic..::..List <(Of <(<' GH_MeshingParameters >)>)>%

See Also

Param_MeshParameters Class
Grasshopper.Kernel.Parameters Namespace


Prompt_Singular Method

[image]

Grasshopper SDK
Param_MeshParameters..::..Prompt_Singular Method
Param_MeshParameters Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Parameters
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override GH_GetterResult Prompt_Singular(
    ref GH_MeshingParameters value
)
Visual Basic
Protected Overrides Function Prompt_Singular ( _
    ByRef value As GH_MeshingParameters _
) As GH_GetterResult

Parameters

value
Type: Grasshopper.Kernel.Types..::..GH_MeshingParameters %

See Also

Param_MeshParameters Class
Grasshopper.Kernel.Parameters Namespace


RecordUndoEvent Method

[image] [image]

Grasshopper SDK
Param_MeshParameters..::..RecordUndoEvent Method
Param_MeshParameters Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RecordUndoEvent(String) | Record a generic object change undo event. (Inherited from GH_DocumentObject.)
Public method | RecordUndoEvent(GH_UndoRecord) | Record an entire undo record. (Inherited from GH_DocumentObject.)
Public method | RecordUndoEvent(String, IGH_UndoAction) | Record a specific object change undo event. (Inherited from GH_DocumentObject.)

See Also

Param_MeshParameters Class
Param_MeshParameters Members
Grasshopper.Kernel.Parameters Namespace


RemoveSource Method

[image] [image]

Grasshopper SDK
Param_MeshParameters..::..RemoveSource Method
Param_MeshParameters Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveSource(Guid) | Remove the specified source from this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | RemoveSource(IGH_Param) | Remove the specified source from this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)

See Also

Param_MeshParameters Class
Param_MeshParameters Members
Grasshopper.Kernel.Parameters Namespace


ReplaceSource Method

[image] [image]

Grasshopper SDK
Param_MeshParameters..::..ReplaceSource Method
Param_MeshParameters Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReplaceSource(Guid, IGH_Param) | Replace an existing source with a new one. If the old_source does not exist in this parameter, nothing happens. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public method | ReplaceSource(IGH_Param, IGH_Param) | Replace an existing source with a new one. If the old_source does not exist in this parameter, nothing happens. (Inherited from GH_Param<(Of <(<'T>)>)>.)

See Also

Param_MeshParameters Class
Param_MeshParameters Members
Grasshopper.Kernel.Parameters Namespace


SetPersistentData Method

[image] [image]

Grasshopper SDK
Param_MeshParameters..::..SetPersistentData Method
Param_MeshParameters Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetPersistentData(array<Object>[]()[][]) | Add a collection of values to the persistent data. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public method | SetPersistentData(T) | Add a single item to the persistent data. This method will record an undo event, raise the OnObjectChanged event for PersistentData flags and place a call to ExpireSolution(False). If you want to add more than one piece of data, you should use the appropriate overload for this method. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
 | SetPersistentData(T) |
 | SetPersistentData(T) |

See Also

Param_MeshParameters Class
Param_MeshParameters Members
Grasshopper.Kernel.Parameters Namespace


SetValue Method

[image] [image]

Grasshopper SDK
Param_MeshParameters..::..SetValue Method
Param_MeshParameters Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SetValue(String, Boolean) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Double) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Color) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, Int32) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)
Protected method | SetValue(String, String) | Set a named value. This value will be serialized with the component. (Inherited from GH_DocumentObject.)

See Also

Param_MeshParameters Class
Param_MeshParameters Members
Grasshopper.Kernel.Parameters Namespace


TriggerAutoSave Method

[image] [image]

Grasshopper SDK
Param_MeshParameters..::..TriggerAutoSave Method
Param_MeshParameters Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TriggerAutoSave()()()() | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(Guid) | Triggers the AutoSave function on the owner document with the object_changed flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from GH_DocumentObject.)
Public method | TriggerAutoSave(GH_AutoSaveTrigger, Guid) | Triggers the AutoSave function on the owner document with a custom flag. (Inherited from GH_DocumentObject.)

See Also

Param_MeshParameters Class
Param_MeshParameters Members
Grasshopper.Kernel.Parameters Namespace


Param_MeshParameters Properties

[image] [image]

Grasshopper SDK
Param_MeshParameters Properties
Param_MeshParameters Class See Also Send Feedback

The Param_MeshParameters type exposes the following members.

Properties

 | Name | Description
Public property | Access | Gets or sets the Access level for this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | Attributes | Gets or sets the attributes that are associated with this object. Only set custom attributes if you know what you are doing. (Inherited from GH_DocumentObject.)
Public property | Category | Gets or sets the Category in which this object belongs. If HasCategory() returns false, this field has no meaning. (Inherited from GH_InstanceDescription.)
Public property | ComponentGuid | (Overrides GH_DocumentObject..::..ComponentGuid.)
Public property | DataMapping | Gets or sets the data mapping of this Parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | DataType | Gets the type of data stored in this parameter. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public property | Description | Gets or sets the description of the object. This field typically remains fixed during the lifetime of an object. (Inherited from GH_InstanceDescription.)
Public property | Exposure | (Overrides GH_DocumentObject..::..Exposure.)
Public property | HasCategory | Gets whether or not the Category field has been set. (Inherited from GH_InstanceDescription.)
Public property | HasProxySources | Gets a value indicating whether or not this parameter maintains proxy sources. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | HasSubCategory | Gets whether or not the SubCategory field has been set. (Inherited from GH_InstanceDescription.)
Protected property | Icon | (Overrides GH_DocumentObject..::..Icon.)
Public property | Icon_24x24 | The icon associated with this object. (Inherited from GH_DocumentObject.)
Public property | Icon_24x24_Locked | The greyscale icon of this object. (Inherited from GH_DocumentObject.)
Public property | IconCapableUI | By default the NickName menu item supports the Icon Mode override toggle. If your UI is not capable of displaying icons, then override this property and return False. (Inherited from GH_ActiveObject.)
Public property | IconDisplayMode | Gets the current display mode of the object. (Inherited from GH_DocumentObject.)
Public property | InstanceDescription | Gets the description of this instance. The default description is about the amount and source of the local values. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | InstanceGuid | Gets the ID of this runtime instance. (Inherited from GH_InstanceDescription.)
Public property | IsDataProvider | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | IsPrincipal | Gets whether this parameter is a principal parameter. Principal parameters are maintained by components and are not part of the IGH_Param interface. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | Keywords | Gets a list of additional keywords that describe the object. Typically this list is empty but you can override this property to aid in object searches. (Inherited from GH_InstanceDescription.)
Public property | Kind | Gets the parameter kind. The kind is evaluated lazily and cached. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | Locked | Gets or sets the enabled flag of this object. Disabled objects are ignored during solutions. (Inherited from GH_ActiveObject.)
Public property | MutableNickName | Gets or sets a value that enables Nick name changes through the menu. The default is TRUE. (Inherited from GH_ActiveObject.)
Public property | Name | Gets or sets the name of the object. This field typically remains fixed during the lifetime of an object. (Inherited from GH_InstanceDescription.)
Public property | NickName | Gets or sets the nickname of the object. This field can be changed by the user. (Inherited from GH_InstanceDescription.)
Public property | Obsolete | Gets whether this object is obsolete. Default implementation returns true if the class name contains the string "OBSOLETE" or if this class has been decorated with the ObsoleteAttribute. You are free to override this if you want, but I suggest adding the ObsoleteAttribute instead. (Inherited from GH_DocumentObject.)
Public property | Optional | Gets or sets whether or not this parameter is considered optional by the owner component. Empty, non-optional parameters prevent the component from being solved. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | PersistentData | Gets the persistent data stored in this parameter. If you modify the persistent data, be sure to call the: OnObjectChanged(GH_ObjectEventType.PersistentData) event. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public property | PersistentDataCount | Gets the number of persistent data items stored in this parameter. (Inherited from GH_PersistentParam<(Of <(<'T>)>)>.)
Public property | Phase | Gets or sets the solution phase this object is currenly in. (Inherited from GH_ActiveObject.)
Public property | ProcessorTime | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | ProxySourceCount | Gets the number of proxy sources for this parameter. Proxy sources are used during file IO, when actual sources might not be available yet. Once an IO operation has been completed there should be no more proxy sources. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | Recipients | Gets a list of all the recipients of this parameter. I.e. a recipient has this parameter as one of the sources. The Recipient list is maintained by the parameter, do not modify it yourself. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | Reverse | Gets or sets the data reverse modifier of this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | RuntimeMessageLevel | Returns the worst case flag for the current object If the object contains at least 1 error, the result is Error. If the object contains at least 1 warning, the result is Warning. If the object contains at least 1 message, the result is Remark. If the object contains no errors, no warnings and no messages, the result is Blank. (Inherited from GH_ActiveObject.)
Public property | Simplify | Gets or sets the simplify modifier for this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | SourceCount | Gets the number of sources for this parameter. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | Sources | Gets a list of source parameters. Do not modify this list, if you wish to add or remove sources, use dedicated functions like AddSource() and RemoveSource() instead. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | StateTags | Gets all the StateTags that are associated with this parameter. A state tag is a visual feedback icon that represents specific internal settings. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | SubCategory | Gets or sets the SubCategory in which this object belongs. If HasSubCategory() returns false, this field has no meaning. (Inherited from GH_InstanceDescription.)
Public property | Type | Gets the Framework Type descriptor for the stored Data. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | TypeName | Calls TypeName() on the first instance of T it can find. This is either an item in the volatile list, or a newly constructed instance. (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | VolatileData | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | VolatileDataCount | (Inherited from GH_Param<(Of <(<'T>)>)>.)
Public property | WireDisplay | Gets or sets the wire display style for this parameter. Wire display only affects the wires connected to the parameter input. (Inherited from GH_Param<(Of <(<'T>)>)>.)

See Also

Param_MeshParameters Class
Grasshopper.Kernel.Parameters Namespace


ComponentGuid Property

[image]

Grasshopper SDK
Param_MeshParameters..::..ComponentGuid Property
Param_MeshParameters Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Parameters
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override Guid ComponentGuid { get; }
Visual Basic
Public Overrides ReadOnly Property ComponentGuid As Guid
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Parameters.Param_MeshParameters.ComponentGuid"]

See Also

Param_MeshParameters Class
Grasshopper.Kernel.Parameters Namespace


Exposure Property

[image]

Grasshopper SDK
Param_MeshParameters..::..Exposure Property
Param_MeshParameters Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Parameters
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override GH_Exposure Exposure { get; }
Visual Basic
Public Overrides ReadOnly Property Exposure As GH_Exposure
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Parameters.Param_MeshParameters.Exposure"]

See Also

Param_MeshParameters Class
Grasshopper.Kernel.Parameters Namespace


Icon Property

[image]

Grasshopper SDK
Param_MeshParameters..::..Icon Property
Param_MeshParameters Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Parameters
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override Bitmap Icon { get; }
Visual Basic
Protected Overrides ReadOnly Property Icon As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Parameters.Param_MeshParameters.Icon"]

See Also

Param_MeshParameters Class
Grasshopper.Kernel.Parameters Namespace


Param_MeshParameters Events

[image] [image]

Grasshopper SDK
Param_MeshParameters Events
Param_MeshParameters Class See Also Send Feedback

The Param_MeshParameters type exposes the following members.

Events

 | Name | Description
Public event | AttributesChanged | Raised whenever the number or kind of attributes changes. This event is handled by GH_Documents who subsequently wipe their attribute caches. (Inherited from GH_DocumentObject.)
Public event | DisplayExpired | Raised whenever the display (on the Canvas) of a certain object becomes invalid. (Inherited from GH_DocumentObject.)
Public event | ObjectChanged | (Inherited from GH_DocumentObject.)
Public event | PingDocument | Raised whenever an object needs to know which GH_Document it belongs to. (Inherited from GH_DocumentObject.)
Public event | PreviewExpired | Raised whenever the display (in the Rhino viewports) of a certain object becomes invalid. (Inherited from GH_DocumentObject.)
Public event | SolutionExpired | Raised whenever the solution of a certain object becomes invalid. (Inherited from GH_DocumentObject.)

See Also

Param_MeshParameters Class
Grasshopper.Kernel.Parameters Namespace


Grasshopper.Kernel.Types Namespace

[image]

Grasshopper SDK
Grasshopper.Kernel.Types Namespace
Send Feedback
Contains all default data types that ship with Grasshopper.

Classes

 | Class | Description
Public class | GH_Arc | Represents a 3D circular arc. GH_Arc re-implements the OpenNURBS OnArc class.
Public class | GH_Boolean | Represents a boolean value. GH_Boolean re-implements the framework System.Boolean type.
Public class | GH_Box | Represents a 3D oriented Box volume.
Public class | GH_Box..::..GH_BoxProxy |
Public class | GH_Brep | Represents a 3D polysurface. GH_Brep wraps the functionality of the OpenNURBS OnBrep class.
Public class | GH_Brep..::..GH_BrepProxy |
Public class | GH_Circle | Represents a 3D circle. GH_Circle re-implements the OpenNURBS OnCircle class.
Public class | GH_Circle..::..GH_CircleProxy | Proxy description of GH_Circle class. This class is used by the Generic Multivalue interfaces.
Public class | GH_Colour | Represents an ARGB colour. GH_Colour re-implements the framework System.Drawing.Color type.
Public class | GH_ComplexNumber | Wraps up the Complex data type for IGH_Goo adherence.
Public class | GH_Culture | Represents a globally unique identifier. GH_Guid re-implements the framework System.Guid type.
Public class | GH_Curve | Represents a 3D spline curve.
Public class | GH_Curve..::..GH_CurveProxy | Proxy description of GH_Curve class. This class is used by the Generic Multivalue interfaces.
Public class | GH_Field | Represents a field of forces.
Public class | GH_FieldElement | Abstract implementation of IGH_FieldElement, derive from this class rather than implementing IGH_FieldElement to save yourself time and effort.
Public class | GH_GeometricGoo<(Of <(<'T>)>)> | Abstract base implementation of IGH_GeometricGoo. If you implement IGH_GeometricGoo, use this for a booster.
Public class | GH_GeometricGooWrapper | Utility class for maintaining all kinds of IGH_GeometricGoo types.
Public class | GH_GeometryGroup |
Public class | GH_GeometryGroup..::..GH_GeometryGroupProxy |
Public class | GH_Goo<(Of <(<'T>)>)> | Base class for IGH_Goo implementation. Takes care of some default behaviour.
Public class | GH_GooProxy<(Of <(<'T>)>)> | Abstract base implementation of IGH_GooProxy
Public class | GH_Guid | Represents a globally unique identifier. GH_Guid re-implements the framework System.Guid type.
Public class | GH_Integer | Represents a 32-bit signed integer. GH_Integer re-implements the framework System.Int32 type.
Public class | GH_Interval | Represents a one-dimensional numeric domain.
Public class | GH_Interval2D | Represents a two-dimensional numeric domain.
Public class | GH_Interval2D..::..GH_Interval2DProxy | Proxy description of GH_Interval class. This class is used by the Generic Multivalue interfaces.
Public class | GH_Line | Represents a 3D line segment. GH_Line re-implements the OpenNURBS OnLine class.
Public class | GH_Line..::..GH_LineProxy | Proxy description of GH_Line class. This class is used by the Generic Multivalue interfaces.
Public class | GH_LineCharge | Line charge implementation for IGH_Fields.
Public class | GH_LonLatCoordinate |
Public class | GH_Material | Represents a implementation of the Rhino material
Public class | GH_Material..::..GH_Material_Proxy |
Public class | GH_Matrix | Represents a 32-bit signed integer. GH_Integer re-implements the framework System.Int32 type.
Public class | GH_Mesh | Represents a 3D polygonal mesh composed of quads and tris. GH_MEsh wraps the functionality of the OpenNURBS OnMesh class.
Public class | GH_Mesh..::..GH_MeshProxy |
Public class | GH_MeshFace | Represents a tri or quad mesh face. GH_MeshFace works similar to the OpenNURBS OnMeshFace class.
Public class | GH_MeshFace..::..GH_MeshFaceProxy | Proxy description of GH_MeshFace class. This class is used by the Generic Multivalue interfaces.
Public class | GH_MeshingParameters |
Public class | GH_MeshingParameters..::..RhMesherSettings_Proxy |
Public class | GH_Number | Represents a double-precision floating point number. GH_Number re-implements the framework System.Double type.
Public class | GH_ObjectWrapper |
Public class | GH_Plane | Represents a 3D plane. GH_Plane re-implements the OpenNURBS OnPlane class.
Public class | GH_Plane..::..GH_PlaneProxy | Proxy description of GH_Plane class. This class is used by the Generic Multivalue interfaces.
Public class | GH_Point |
Public class | GH_Point..::..GH_PointProxy |
Public class | GH_PointCharge | Point charge implementation for IGH_Fields.
Public class | GH_PointRefData |
Public class | GH_PointUtil |
Public class | GH_Rectangle | Represents a 3D rectangle. GH_Rectangle re-implements the RhinoCommon Rectangle3d.
Public class | GH_Rectangle..::..GH_RectangleProxy | Proxy description of GH_Rectangle class. This class is used by the Generic Multivalue interfaces.
Public class | GH_SpinForce | Rotational spin force for IGH_Fields.
Public class | GH_String | Represents a literal string. GH_String re-implements the framework System.String type.
Public class | GH_StructurePath |
Public class | GH_Surface | Represents a 3D (trimmed) surface. GH_Surface wraps the functionality of the OpenNURBS OnBrepFace class.
Public class | GH_Surface..::..GH_SurfaceProxy |
Public class | GH_Time | Represents a date and time. GH_Time re-implements the framework System.DateTime type.
Public class | GH_Transform | Represents a collection of transformations.
Public class | GH_Vector | Represents a 3D vector. GH_Vector re-implements the OpenNURBS On3dVector class.
Public class | GH_Vector..::..GH_VectorProxy | Proxy description of GH_Vector class. This class is used by the Generic Multivalue interfaces.
Public class | GH_VectorForce | Linear vector force implementation for IGH_Fields.

Structures

 | Structure | Description
Public structure | Complex | Complex number type in Grasshopper. Do not confuse with GH_Complex which is the IGH_Goo implementation of ComplexNumber.
Public structure | UVInterval | UVInterval data type. Do not confuse this with GH_Interval2D.

Interfaces

 | Interface | Description
Public interface | IGH_FieldElement | Represents the basic interface for field elements.
Public interface | IGH_GeometricGoo | Base interface for all Data inside Grasshoper that could pass for Geometry
Public interface | IGH_Goo | Base interface for all Data inside Grasshopper. Every parameter must implement a type of Goo.
Public interface | IGH_GooProxy | Base interface for all type proxies.

Enumerations

 | Enumeration | Description
Public enumeration | GH_DifferentialSolver | Enumerates all implemented differential samplers.
Public enumeration | GH_Material..::..RDK_GL_Result |
Public enumeration | GH_PointRefType |


Complex Structure

[image]

Grasshopper SDK
Complex Structure
Members See Also Send Feedback
Complex number type in Grasshopper. Do not confuse with GH_Complex which is the IGH_Goo implementation of ComplexNumber.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public struct Complex
Visual Basic
Public Structure Complex

See Also

Complex Members
Grasshopper.Kernel.Types Namespace


Complex Members

[image] [image]

Grasshopper SDK
Complex Members
Complex Structure Constructors Methods Operators Properties See Also Send Feedback

The Complex type exposes the following members.

Constructors

 | Name | Description
Public method | Complex(Double) | Initializes a new instance of the Complex class
Public method | Complex(Double, Double) | Initializes a new instance of the Complex class

Methods

 | Name | Description
Public method | ACos |
Public method | ASin |
Public method | ATan |
Public method | Cos |
Public method | Cosecant |
Public method | CoTan |
Public method | Exponential |
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)
Public method | Log |
Public method | Log10 |
Public method | Modulus |
Public method | ModulusSquared |
Public method | Power |
Public method | Root |
Public method | Secant |
Public method | Sin |
Public method | Square |
Public method | SquareRoot |
Public method | Tan |

Operators

Name | Description
Addition(Double, Complex) |
Addition(Complex, Complex) |
Addition(Complex, Double) |
Division(Double, Complex) |
Division(Complex, Complex) |
Division(Complex, Double) |
Multiply(Double, Complex) |
Multiply(Complex, Complex) |
Multiply(Complex, Double) |
Subtraction(Double, Complex) |
Subtraction(Complex, Complex) |
Subtraction(Complex, Double) |
UnaryNegation |
UnaryPlus |

Properties

 | Name | Description
Public property | Argument | Gets or sets the complex argument.
 | ComplexUnit |
Public property | Imaginary | Gets or sets the imaginary component of the Complex number.
 | Infinity |
Public property | IsReal | Gets whether this complex number only has a real component.
Public property | IsRealNonNegative | Gets whether this complex number only has a positive real component.
Public property | IsValid | Gets the validity of this number.
Public property | IsZero | Gets whether or not this complex number equals {0.0; 0.0}
 | NaN |
 | NegativeInfinity |
Public property | Real | Gets or sets the real component of the Complex number.
 | Zero |

See Also

Complex Structure
Grasshopper.Kernel.Types Namespace


Complex Constructor

[image] [image]

Grasshopper SDK
Complex Constructor
Complex Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | Complex(Double) | Initializes a new instance of the Complex class
Public method | Complex(Double, Double) | Initializes a new instance of the Complex class

See Also

Complex Structure
Complex Members
Grasshopper.Kernel.Types Namespace


Complex Constructor (Double)

[image]

Grasshopper SDK
Complex Constructor (Double)
Complex Structure See Also Send Feedback
Initializes a new instance of the Complex class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Complex(
    double real_component
)
Visual Basic
Public Sub New ( _
    real_component As Double _
)

Parameters

real_component
Type: System..::..Double

See Also

Complex Structure
Complex Overload
Grasshopper.Kernel.Types Namespace


Complex Constructor (Double, Double)

[image]

Grasshopper SDK
Complex Constructor (Double, Double)
Complex Structure See Also Send Feedback
Initializes a new instance of the Complex class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Complex(
    double real_component,
    double imaginary_component
)
Visual Basic
Public Sub New ( _
    real_component As Double, _
    imaginary_component As Double _
)

Parameters

real_component
Type: System..::..Double
imaginary_component
Type: System..::..Double

See Also

Complex Structure
Complex Overload
Grasshopper.Kernel.Types Namespace


Complex Methods

[image] [image]

Grasshopper SDK
Complex Methods
Complex Structure See Also Send Feedback

The Complex type exposes the following members.

Methods

 | Name | Description
Public method | ACos |
Public method | ASin |
Public method | ATan |
Public method | Cos |
Public method | Cosecant |
Public method | CoTan |
Public method | Exponential |
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)
Public method | Log |
Public method | Log10 |
Public method | Modulus |
Public method | ModulusSquared |
Public method | Power |
Public method | Root |
Public method | Secant |
Public method | Sin |
Public method | Square |
Public method | SquareRoot |
Public method | Tan |

See Also

Complex Structure
Grasshopper.Kernel.Types Namespace


ACos Method

[image]

Grasshopper SDK
Complex..::..ACos Method
Complex Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Complex ACos()
Visual Basic
Public Function ACos As Complex

See Also

Complex Structure
Grasshopper.Kernel.Types Namespace


ASin Method

[image]

Grasshopper SDK
Complex..::..ASin Method
Complex Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Complex ASin()
Visual Basic
Public Function ASin As Complex

See Also

Complex Structure
Grasshopper.Kernel.Types Namespace


ATan Method

[image]

Grasshopper SDK
Complex..::..ATan Method
Complex Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Complex ATan()
Visual Basic
Public Function ATan As Complex

See Also

Complex Structure
Grasshopper.Kernel.Types Namespace


Cos Method

[image]

Grasshopper SDK
Complex..::..Cos Method
Complex Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Complex Cos()
Visual Basic
Public Function Cos As Complex

See Also

Complex Structure
Grasshopper.Kernel.Types Namespace


Cosecant Method

[image]

Grasshopper SDK
Complex..::..Cosecant Method
Complex Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Complex Cosecant()
Visual Basic
Public Function Cosecant As Complex

See Also

Complex Structure
Grasshopper.Kernel.Types Namespace


CoTan Method

[image]

Grasshopper SDK
Complex..::..CoTan Method
Complex Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Complex CoTan()
Visual Basic
Public Function CoTan As Complex

See Also

Complex Structure
Grasshopper.Kernel.Types Namespace


Exponential Method

[image]

Grasshopper SDK
Complex..::..Exponential Method
Complex Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Complex Exponential()
Visual Basic
Public Function Exponential As Complex

See Also

Complex Structure
Grasshopper.Kernel.Types Namespace


GetHashCode Method

[image]

Grasshopper SDK
Complex..::..GetHashCode Method
Complex Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

See Also

Complex Structure
Grasshopper.Kernel.Types Namespace


Log Method

[image]

Grasshopper SDK
Complex..::..Log Method
Complex Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Complex Log()
Visual Basic
Public Function Log As Complex

See Also

Complex Structure
Grasshopper.Kernel.Types Namespace


Log10 Method

[image]

Grasshopper SDK
Complex..::..Log10 Method
Complex Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Complex Log10()
Visual Basic
Public Function Log10 As Complex

See Also

Complex Structure
Grasshopper.Kernel.Types Namespace


Modulus Method

[image]

Grasshopper SDK
Complex..::..Modulus Method
Complex Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double Modulus()
Visual Basic
Public Function Modulus As Double

See Also

Complex Structure
Grasshopper.Kernel.Types Namespace


ModulusSquared Method

[image]

Grasshopper SDK
Complex..::..ModulusSquared Method
Complex Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double ModulusSquared()
Visual Basic
Public Function ModulusSquared As Double

See Also

Complex Structure
Grasshopper.Kernel.Types Namespace


Power Method

[image]

Grasshopper SDK
Complex..::..Power Method
Complex Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Complex Power(
    Complex exponent
)
Visual Basic
Public Function Power ( _
    exponent As Complex _
) As Complex

Parameters

exponent
Type: Grasshopper.Kernel.Types..::..Complex

See Also

Complex Structure
Grasshopper.Kernel.Types Namespace


Root Method

[image]

Grasshopper SDK
Complex..::..Root Method
Complex Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Complex Root(
    Complex rootexponent
)
Visual Basic
Public Function Root ( _
    rootexponent As Complex _
) As Complex

Parameters

rootexponent
Type: Grasshopper.Kernel.Types..::..Complex

See Also

Complex Structure
Grasshopper.Kernel.Types Namespace


Secant Method

[image]

Grasshopper SDK
Complex..::..Secant Method
Complex Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Complex Secant()
Visual Basic
Public Function Secant As Complex

See Also

Complex Structure
Grasshopper.Kernel.Types Namespace


Sin Method

[image]

Grasshopper SDK
Complex..::..Sin Method
Complex Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Complex Sin()
Visual Basic
Public Function Sin As Complex

See Also

Complex Structure
Grasshopper.Kernel.Types Namespace


Square Method

[image]

Grasshopper SDK
Complex..::..Square Method
Complex Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Complex Square()
Visual Basic
Public Function Square As Complex

See Also

Complex Structure
Grasshopper.Kernel.Types Namespace


SquareRoot Method

[image]

Grasshopper SDK
Complex..::..SquareRoot Method
Complex Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Complex SquareRoot()
Visual Basic
Public Function SquareRoot As Complex

See Also

Complex Structure
Grasshopper.Kernel.Types Namespace


Tan Method

[image]

Grasshopper SDK
Complex..::..Tan Method
Complex Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Complex Tan()
Visual Basic
Public Function Tan As Complex

See Also

Complex Structure
Grasshopper.Kernel.Types Namespace


Complex Operators

[image] [image]

Grasshopper SDK
Complex Operators
Complex Structure See Also Send Feedback

The Complex type exposes the following members.

Operators

Name | Description
Addition(Double, Complex) |
Addition(Complex, Complex) |
Addition(Complex, Double) |
Division(Double, Complex) |
Division(Complex, Complex) |
Division(Complex, Double) |
Multiply(Double, Complex) |
Multiply(Complex, Complex) |
Multiply(Complex, Double) |
Subtraction(Double, Complex) |
Subtraction(Complex, Complex) |
Subtraction(Complex, Double) |
UnaryNegation |
UnaryPlus |

See Also

Complex Structure
Grasshopper.Kernel.Types Namespace


Addition Operator

[image] [image]

Grasshopper SDK
Complex..::..Addition Operator
Complex Structure See Also Send Feedback

Overload List

Name | Description
Addition(Double, Complex) |
Addition(Complex, Complex) |
Addition(Complex, Double) |

See Also

Complex Structure
Complex Members
Grasshopper.Kernel.Types Namespace


Addition Operator (Double, Complex)

[image]

Grasshopper SDK
Complex..::..Addition Operator (Double, Complex)
Complex Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Complex operator +(
    double A,
    Complex B
)
Visual Basic
Public Shared Operator + ( _
    A As Double, _
    B As Complex _
) As Complex

Parameters

A
Type: System..::..Double
B
Type: Grasshopper.Kernel.Types..::..Complex

See Also

Complex Structure
Addition Overload
Grasshopper.Kernel.Types Namespace


Addition Operator (Complex, Complex)

[image]

Grasshopper SDK
Complex..::..Addition Operator (Complex, Complex)
Complex Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Complex operator +(
    Complex A,
    Complex B
)
Visual Basic
Public Shared Operator + ( _
    A As Complex, _
    B As Complex _
) As Complex

Parameters

A
Type: Grasshopper.Kernel.Types..::..Complex
B
Type: Grasshopper.Kernel.Types..::..Complex

See Also

Complex Structure
Addition Overload
Grasshopper.Kernel.Types Namespace


Addition Operator (Complex, Double)

[image]

Grasshopper SDK
Complex..::..Addition Operator (Complex, Double)
Complex Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Complex operator +(
    Complex A,
    double B
)
Visual Basic
Public Shared Operator + ( _
    A As Complex, _
    B As Double _
) As Complex

Parameters

A
Type: Grasshopper.Kernel.Types..::..Complex
B
Type: System..::..Double

See Also

Complex Structure
Addition Overload
Grasshopper.Kernel.Types Namespace


Division Operator

[image] [image]

Grasshopper SDK
Complex..::..Division Operator
Complex Structure See Also Send Feedback

Overload List

Name | Description
Division(Double, Complex) |
Division(Complex, Complex) |
Division(Complex, Double) |

See Also

Complex Structure
Complex Members
Grasshopper.Kernel.Types Namespace


Division Operator (Double, Complex)

[image]

Grasshopper SDK
Complex..::..Division Operator (Double, Complex)
Complex Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Complex operator /(
    double dividend,
    Complex divisor
)
Visual Basic
Public Shared Operator / ( _
    dividend As Double, _
    divisor As Complex _
) As Complex

Parameters

dividend
Type: System..::..Double
divisor
Type: Grasshopper.Kernel.Types..::..Complex

See Also

Complex Structure
Division Overload
Grasshopper.Kernel.Types Namespace


Division Operator (Complex, Complex)

[image]

Grasshopper SDK
Complex..::..Division Operator (Complex, Complex)
Complex Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Complex operator /(
    Complex dividend,
    Complex divisor
)
Visual Basic
Public Shared Operator / ( _
    dividend As Complex, _
    divisor As Complex _
) As Complex

Parameters

dividend
Type: Grasshopper.Kernel.Types..::..Complex
divisor
Type: Grasshopper.Kernel.Types..::..Complex

See Also

Complex Structure
Division Overload
Grasshopper.Kernel.Types Namespace


Division Operator (Complex, Double)

[image]

Grasshopper SDK
Complex..::..Division Operator (Complex, Double)
Complex Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Complex operator /(
    Complex dividend,
    double divisor
)
Visual Basic
Public Shared Operator / ( _
    dividend As Complex, _
    divisor As Double _
) As Complex

Parameters

dividend
Type: Grasshopper.Kernel.Types..::..Complex
divisor
Type: System..::..Double

See Also

Complex Structure
Division Overload
Grasshopper.Kernel.Types Namespace


Multiply Operator

[image] [image]

Grasshopper SDK
Complex..::..Multiply Operator
Complex Structure See Also Send Feedback

Overload List

Name | Description
Multiply(Double, Complex) |
Multiply(Complex, Complex) |
Multiply(Complex, Double) |

See Also

Complex Structure
Complex Members
Grasshopper.Kernel.Types Namespace


Multiply Operator (Double, Complex)

[image]

Grasshopper SDK
Complex..::..Multiply Operator (Double, Complex)
Complex Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Complex operator *(
    double A,
    Complex B
)
Visual Basic
Public Shared Operator * ( _
    A As Double, _
    B As Complex _
) As Complex

Parameters

A
Type: System..::..Double
B
Type: Grasshopper.Kernel.Types..::..Complex

See Also

Complex Structure
Multiply Overload
Grasshopper.Kernel.Types Namespace


Multiply Operator (Complex, Complex)

[image]

Grasshopper SDK
Complex..::..Multiply Operator (Complex, Complex)
Complex Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Complex operator *(
    Complex A,
    Complex B
)
Visual Basic
Public Shared Operator * ( _
    A As Complex, _
    B As Complex _
) As Complex

Parameters

A
Type: Grasshopper.Kernel.Types..::..Complex
B
Type: Grasshopper.Kernel.Types..::..Complex

See Also

Complex Structure
Multiply Overload
Grasshopper.Kernel.Types Namespace


Multiply Operator (Complex, Double)

[image]

Grasshopper SDK
Complex..::..Multiply Operator (Complex, Double)
Complex Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Complex operator *(
    Complex A,
    double B
)
Visual Basic
Public Shared Operator * ( _
    A As Complex, _
    B As Double _
) As Complex

Parameters

A
Type: Grasshopper.Kernel.Types..::..Complex
B
Type: System..::..Double

See Also

Complex Structure
Multiply Overload
Grasshopper.Kernel.Types Namespace


Subtraction Operator

[image] [image]

Grasshopper SDK
Complex..::..Subtraction Operator
Complex Structure See Also Send Feedback

Overload List

Name | Description
Subtraction(Double, Complex) |
Subtraction(Complex, Complex) |
Subtraction(Complex, Double) |

See Also

Complex Structure
Complex Members
Grasshopper.Kernel.Types Namespace


Subtraction Operator (Double, Complex)

[image]

Grasshopper SDK
Complex..::..Subtraction Operator (Double, Complex)
Complex Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Complex operator -(
    double A,
    Complex B
)
Visual Basic
Public Shared Operator - ( _
    A As Double, _
    B As Complex _
) As Complex

Parameters

A
Type: System..::..Double
B
Type: Grasshopper.Kernel.Types..::..Complex

See Also

Complex Structure
Subtraction Overload
Grasshopper.Kernel.Types Namespace


Subtraction Operator (Complex, Complex)

[image]

Grasshopper SDK
Complex..::..Subtraction Operator (Complex, Complex)
Complex Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Complex operator -(
    Complex A,
    Complex B
)
Visual Basic
Public Shared Operator - ( _
    A As Complex, _
    B As Complex _
) As Complex

Parameters

A
Type: Grasshopper.Kernel.Types..::..Complex
B
Type: Grasshopper.Kernel.Types..::..Complex

See Also

Complex Structure
Subtraction Overload
Grasshopper.Kernel.Types Namespace


Subtraction Operator (Complex, Double)

[image]

Grasshopper SDK
Complex..::..Subtraction Operator (Complex, Double)
Complex Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Complex operator -(
    Complex A,
    double B
)
Visual Basic
Public Shared Operator - ( _
    A As Complex, _
    B As Double _
) As Complex

Parameters

A
Type: Grasshopper.Kernel.Types..::..Complex
B
Type: System..::..Double

See Also

Complex Structure
Subtraction Overload
Grasshopper.Kernel.Types Namespace


UnaryNegation Operator

[image]

Grasshopper SDK
Complex..::..UnaryNegation Operator
Complex Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Complex operator -(
    Complex subtrahend
)
Visual Basic
Public Shared Operator - ( _
    subtrahend As Complex _
) As Complex

Parameters

subtrahend
Type: Grasshopper.Kernel.Types..::..Complex

See Also

Complex Structure
Grasshopper.Kernel.Types Namespace


UnaryPlus Operator

[image]

Grasshopper SDK
Complex..::..UnaryPlus Operator
Complex Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Complex operator +(
    Complex summand
)
Visual Basic
Public Shared Operator + ( _
    summand As Complex _
) As Complex

Parameters

summand
Type: Grasshopper.Kernel.Types..::..Complex

See Also

Complex Structure
Grasshopper.Kernel.Types Namespace


Complex Properties

[image] [image]

Grasshopper SDK
Complex Properties
Complex Structure See Also Send Feedback

The Complex type exposes the following members.

Properties

 | Name | Description
Public property | Argument | Gets or sets the complex argument.
 | ComplexUnit |
Public property | Imaginary | Gets or sets the imaginary component of the Complex number.
 | Infinity |
Public property | IsReal | Gets whether this complex number only has a real component.
Public property | IsRealNonNegative | Gets whether this complex number only has a positive real component.
Public property | IsValid | Gets the validity of this number.
Public property | IsZero | Gets whether or not this complex number equals {0.0; 0.0}
 | NaN |
 | NegativeInfinity |
Public property | Real | Gets or sets the real component of the Complex number.
 | Zero |

See Also

Complex Structure
Grasshopper.Kernel.Types Namespace


Argument Property

[image]

Grasshopper SDK
Complex..::..Argument Property
Complex Structure See Also Send Feedback
Gets or sets the complex argument.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double Argument { get; set; }
Visual Basic
Public Property Argument As Double
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.Complex.Argument"]

See Also

Complex Structure
Grasshopper.Kernel.Types Namespace


ComplexUnit Property

[image]

Grasshopper SDK
Complex..::..ComplexUnit Property
Complex Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Complex ComplexUnit { get; }
Visual Basic
Public Shared ReadOnly Property ComplexUnit As Complex
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.Complex.ComplexUnit"]

See Also

Complex Structure
Grasshopper.Kernel.Types Namespace


Imaginary Property

[image]

Grasshopper SDK
Complex..::..Imaginary Property
Complex Structure See Also Send Feedback
Gets or sets the imaginary component of the Complex number.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double Imaginary { get; set; }
Visual Basic
Public Property Imaginary As Double
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.Complex.Imaginary"]

See Also

Complex Structure
Grasshopper.Kernel.Types Namespace


Infinity Property

[image]

Grasshopper SDK
Complex..::..Infinity Property
Complex Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Complex Infinity { get; }
Visual Basic
Public Shared ReadOnly Property Infinity As Complex
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.Complex.Infinity"]

See Also

Complex Structure
Grasshopper.Kernel.Types Namespace


IsReal Property

[image]

Grasshopper SDK
Complex..::..IsReal Property
Complex Structure See Also Send Feedback
Gets whether this complex number only has a real component.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsReal { get; }
Visual Basic
Public ReadOnly Property IsReal As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.Complex.IsReal"]

See Also

Complex Structure
Grasshopper.Kernel.Types Namespace


IsRealNonNegative Property

[image]

Grasshopper SDK
Complex..::..IsRealNonNegative Property
Complex Structure See Also Send Feedback
Gets whether this complex number only has a positive real component.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsRealNonNegative { get; }
Visual Basic
Public ReadOnly Property IsRealNonNegative As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.Complex.IsRealNonNegative"]

See Also

Complex Structure
Grasshopper.Kernel.Types Namespace


IsValid Property

[image]

Grasshopper SDK
Complex..::..IsValid Property
Complex Structure See Also Send Feedback
Gets the validity of this number.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsValid { get; }
Visual Basic
Public ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.Complex.IsValid"]

See Also

Complex Structure
Grasshopper.Kernel.Types Namespace


IsZero Property

[image]

Grasshopper SDK
Complex..::..IsZero Property
Complex Structure See Also Send Feedback
Gets whether or not this complex number equals {0.0; 0.0}

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsZero { get; }
Visual Basic
Public ReadOnly Property IsZero As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.Complex.IsZero"]

See Also

Complex Structure
Grasshopper.Kernel.Types Namespace


NaN Property

[image]

Grasshopper SDK
Complex..::..NaN Property
Complex Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Complex NaN { get; }
Visual Basic
Public Shared ReadOnly Property NaN As Complex
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.Complex.NaN"]

See Also

Complex Structure
Grasshopper.Kernel.Types Namespace


NegativeInfinity Property

[image]

Grasshopper SDK
Complex..::..NegativeInfinity Property
Complex Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Complex NegativeInfinity { get; }
Visual Basic
Public Shared ReadOnly Property NegativeInfinity As Complex
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.Complex.NegativeInfinity"]

See Also

Complex Structure
Grasshopper.Kernel.Types Namespace


Real Property

[image]

Grasshopper SDK
Complex..::..Real Property
Complex Structure See Also Send Feedback
Gets or sets the real component of the Complex number.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double Real { get; set; }
Visual Basic
Public Property Real As Double
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.Complex.Real"]

See Also

Complex Structure
Grasshopper.Kernel.Types Namespace


Zero Property

[image]

Grasshopper SDK
Complex..::..Zero Property
Complex Structure See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Complex Zero { get; }
Visual Basic
Public Shared ReadOnly Property Zero As Complex
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.Complex.Zero"]

See Also

Complex Structure
Grasshopper.Kernel.Types Namespace


GH_Arc Class

[image]

Grasshopper SDK
GH_Arc Class
Members See Also Send Feedback
Represents a 3D circular arc. GH_Arc re-implements the OpenNURBS OnArc class.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Arc : GH_GeometricGoo<Arc>,
    IGH_BakeAwareData, IGH_PreviewData
Visual Basic
Public Class GH_Arc _
    Inherits GH_GeometricGoo(Of Arc) _
    Implements IGH_BakeAwareData, IGH_PreviewData

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_Goo <(Of <(<'Arc>)>)>
Grasshopper.Kernel.Types..::..GH_GeometricGoo <(Of <(<'Arc>)>)>
Grasshopper.Kernel.Types..::..GH_Arc

See Also

GH_Arc Members
Grasshopper.Kernel.Types Namespace


GH_Arc Members

[image] [image]

Grasshopper SDK
GH_Arc Members
GH_Arc Class Constructors Methods Fields Properties See Also Send Feedback

The GH_Arc type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Arc()()()() | Default constructor
Public method | GH_Arc(Arc) | Create a duplicate of another arc
Public method | GH_Arc(GH_Arc) | Create a duplicate of another arc

Methods

 | Name | Description
Public method | BakeGeometry |
Public method | CastFrom | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type T. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ClearCaches | Clears all caches. Typically if the geometry is referenced, this will erase the local copy. If your T is a value-type, you must override this function and specifically unset the local value. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | DrawViewportMeshes |
Public method | DrawViewportWires |
Public method | Duplicate | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateArc | Create a duplicate of this arc.
Public method | DuplicateGeometry | Create a duplicate of this arc. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..DuplicateGeometry()()()().)
Public method | EmitProxy | Returns a proxy that represents this arc. Do not call this function unless you're (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | GetBoundingBox | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..GetBoundingBox(Transform).)
Public method | LoadGeometry()()()() | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | LoadGeometry(RhinoDoc) | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. The default is to always return True. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | Morph | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Morph(SpaceMorph).)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ToString | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Transform | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Transform(Transform).)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Boundingbox | Gets the boundingbox for this geometry. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Boundingbox.)
Public property | ClippingBox |
Public property | IsGeometryLoaded | Gets a value indicating whether or not this geometry is currently loaded (assuming it is referenced). Not all IGH_GeometricGoo implementations support referenced geometry. The default is to always return True. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public property | IsReferencedGeometry | Gets a value indicating whether or not this geometry is referenced. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public property | IsValid | Gets the validity of this instance.
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot.)
Public property | ReferenceID | Gets or sets the Guid of the object that is referenced. Not all IGH_GeometricGoo implementations support referenced geometry. The default implementation is to always return Guid.Empty. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the value of this type. Note that if the type has a ReferenceID this value might get destroyed in the future. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)

See Also

GH_Arc Class
Grasshopper.Kernel.Types Namespace


GH_Arc Constructor

[image] [image]

Grasshopper SDK
GH_Arc Constructor
GH_Arc Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Arc()()()() | Default constructor
Public method | GH_Arc(Arc) | Create a duplicate of another arc
Public method | GH_Arc(GH_Arc) | Create a duplicate of another arc

See Also

GH_Arc Class
GH_Arc Members
Grasshopper.Kernel.Types Namespace


GH_Arc Constructor

[image]

Grasshopper SDK
GH_Arc Constructor
GH_Arc Class See Also Send Feedback
Default constructor

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Arc()
Visual Basic
Public Sub New

See Also

GH_Arc Class
GH_Arc Overload
Grasshopper.Kernel.Types Namespace


GH_Arc Constructor ()

[image]

Grasshopper SDK
GH_Arc Constructor ()
GH_Arc Class See Also Send Feedback
Create a duplicate of another arc

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Arc(
    Arc arc
)
Visual Basic
Public Sub New ( _
    arc As Arc _
)

Parameters

arc
Type: Arc
Arc to copy. If null, a default arc will be created.

See Also

GH_Arc Class
GH_Arc Overload
Grasshopper.Kernel.Types Namespace


GH_Arc Constructor (GH_Arc)

[image]

Grasshopper SDK
GH_Arc Constructor (GH_Arc)
GH_Arc Class See Also Send Feedback
Create a duplicate of another arc

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Arc(
    GH_Arc other
)
Visual Basic
Public Sub New ( _
    other As GH_Arc _
)

Parameters

other
Type: Grasshopper.Kernel.Types..::..GH_Arc
Arc to copy. If null, a default arc will be created.

See Also

GH_Arc Class
GH_Arc Overload
Grasshopper.Kernel.Types Namespace


GH_Arc Fields

[image] [image]

Grasshopper SDK
GH_Arc Fields
GH_Arc Class See Also Send Feedback

The GH_Arc type exposes the following members.

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Arc Class
Grasshopper.Kernel.Types Namespace


GH_Arc Methods

[image] [image]

Grasshopper SDK
GH_Arc Methods
GH_Arc Class See Also Send Feedback

The GH_Arc type exposes the following members.

Methods

 | Name | Description
Public method | BakeGeometry |
Public method | CastFrom | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type T. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ClearCaches | Clears all caches. Typically if the geometry is referenced, this will erase the local copy. If your T is a value-type, you must override this function and specifically unset the local value. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | DrawViewportMeshes |
Public method | DrawViewportWires |
Public method | Duplicate | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateArc | Create a duplicate of this arc.
Public method | DuplicateGeometry | Create a duplicate of this arc. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..DuplicateGeometry()()()().)
Public method | EmitProxy | Returns a proxy that represents this arc. Do not call this function unless you're (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | GetBoundingBox | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..GetBoundingBox(Transform).)
Public method | LoadGeometry()()()() | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | LoadGeometry(RhinoDoc) | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. The default is to always return True. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | Morph | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Morph(SpaceMorph).)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ToString | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Transform | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Transform(Transform).)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

See Also

GH_Arc Class
Grasshopper.Kernel.Types Namespace


BakeGeometry Method

[image]

Grasshopper SDK
GH_Arc..::..BakeGeometry Method
GH_Arc Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool BakeGeometry(
    RhinoDoc doc,
    ObjectAttributes att,
    ref Guid obj_guid
)
Visual Basic
Public Function BakeGeometry ( _
    doc As RhinoDoc, _
    att As ObjectAttributes, _
    ByRef obj_guid As Guid _
) As Boolean

Parameters

doc
Type: RhinoDoc
att
Type: ObjectAttributes
obj_guid
Type: System..::..Guid %

Implements

IGH_BakeAwareData..::..BakeGeometry(RhinoDoc, ObjectAttributes, Guid%)

See Also

GH_Arc Class
Grasshopper.Kernel.Types Namespace


CastFrom Method

[image]

Grasshopper SDK
GH_Arc..::..CastFrom Method
GH_Arc Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastFrom(
    Object source
)
Visual Basic
Public Overrides Function CastFrom ( _
    source As Object _
) As Boolean

Parameters

source
Type: System..::..Object

See Also

GH_Arc Class
Grasshopper.Kernel.Types Namespace


CastTo Method

[image] [image]

Grasshopper SDK
GH_Arc..::..CastTo Method
GH_Arc Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type T. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Arc Class
GH_Arc Members
Grasshopper.Kernel.Types Namespace


CastTo(T) Method (T)

[image]

Grasshopper SDK
GH_Arc..::..CastTo<(Of <(<'T>)>)> Method (T%)
GH_Arc Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastTo<T>(
    out T target
)
Visual Basic
Public Overrides Function CastTo(Of T) ( _
    <OutAttribute> ByRef target As T _
) As Boolean

Parameters

target
Type: T%

Type Parameters

T

See Also

GH_Arc Class
CastTo Overload
Grasshopper.Kernel.Types Namespace


DrawViewportMeshes Method

[image]

Grasshopper SDK
GH_Arc..::..DrawViewportMeshes Method
GH_Arc Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DrawViewportMeshes(
    GH_PreviewMeshArgs args
)
Visual Basic
Public Sub DrawViewportMeshes ( _
    args As GH_PreviewMeshArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..GH_PreviewMeshArgs

Implements

IGH_PreviewData..::..DrawViewportMeshes(GH_PreviewMeshArgs)

See Also

GH_Arc Class
Grasshopper.Kernel.Types Namespace


DrawViewportWires Method

[image]

Grasshopper SDK
GH_Arc..::..DrawViewportWires Method
GH_Arc Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DrawViewportWires(
    GH_PreviewWireArgs args
)
Visual Basic
Public Sub DrawViewportWires ( _
    args As GH_PreviewWireArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..GH_PreviewWireArgs

Implements

IGH_PreviewData..::..DrawViewportWires(GH_PreviewWireArgs)

See Also

GH_Arc Class
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_Arc..::..Duplicate Method
GH_Arc Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_Goo Duplicate()
Visual Basic
Public Overrides Function Duplicate As IGH_Goo

See Also

GH_Arc Class
Grasshopper.Kernel.Types Namespace


DuplicateArc Method

[image]

Grasshopper SDK
GH_Arc..::..DuplicateArc Method
GH_Arc Class See Also Send Feedback
Create a duplicate of this arc.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Arc DuplicateArc()
Visual Basic
Public Function DuplicateArc As GH_Arc

See Also

GH_Arc Class
Grasshopper.Kernel.Types Namespace


DuplicateGeometry Method

[image]

Grasshopper SDK
GH_Arc..::..DuplicateGeometry Method
GH_Arc Class See Also Send Feedback
Create a duplicate of this arc.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GeometricGoo DuplicateGeometry()
Visual Basic
Public Overrides Function DuplicateGeometry As IGH_GeometricGoo

See Also

GH_Arc Class
Grasshopper.Kernel.Types Namespace


EmitProxy Method

[image]

Grasshopper SDK
GH_Arc..::..EmitProxy Method
GH_Arc Class See Also Send Feedback
Returns a proxy that represents this arc. Do not call this function unless you're

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GooProxy EmitProxy()
Visual Basic
Public Overrides Function EmitProxy As IGH_GooProxy

See Also

GH_Arc Class
Grasshopper.Kernel.Types Namespace


GetBoundingBox Method

[image]

Grasshopper SDK
GH_Arc..::..GetBoundingBox Method
GH_Arc Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override BoundingBox GetBoundingBox(
    Transform xform
)
Visual Basic
Public Overrides Function GetBoundingBox ( _
    xform As Transform _
) As BoundingBox

Parameters

xform
Type: Transform

See Also

GH_Arc Class
Grasshopper.Kernel.Types Namespace


LoadGeometry Method

[image] [image]

Grasshopper SDK
GH_Arc..::..LoadGeometry Method
GH_Arc Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LoadGeometry()()()() | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | LoadGeometry(RhinoDoc) | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. The default is to always return True. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)

See Also

GH_Arc Class
GH_Arc Members
Grasshopper.Kernel.Types Namespace


Morph Method

[image]

Grasshopper SDK
GH_Arc..::..Morph Method
GH_Arc Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GeometricGoo Morph(
    SpaceMorph xmorph
)
Visual Basic
Public Overrides Function Morph ( _
    xmorph As SpaceMorph _
) As IGH_GeometricGoo

Parameters

xmorph
Type: SpaceMorph

See Also

GH_Arc Class
Grasshopper.Kernel.Types Namespace


Read Method

[image]

Grasshopper SDK
GH_Arc..::..Read Method
GH_Arc Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

See Also

GH_Arc Class
Grasshopper.Kernel.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_Arc..::..ToString Method
GH_Arc Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_Arc Class
Grasshopper.Kernel.Types Namespace


Transform Method

[image]

Grasshopper SDK
GH_Arc..::..Transform Method
GH_Arc Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GeometricGoo Transform(
    Transform xform
)
Visual Basic
Public Overrides Function Transform ( _
    xform As Transform _
) As IGH_GeometricGoo

Parameters

xform
Type: Transform

See Also

GH_Arc Class
Grasshopper.Kernel.Types Namespace


Write Method

[image]

Grasshopper SDK
GH_Arc..::..Write Method
GH_Arc Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overrides Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

See Also

GH_Arc Class
Grasshopper.Kernel.Types Namespace


GH_Arc Properties

[image] [image]

Grasshopper SDK
GH_Arc Properties
GH_Arc Class See Also Send Feedback

The GH_Arc type exposes the following members.

Properties

 | Name | Description
Public property | Boundingbox | Gets the boundingbox for this geometry. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Boundingbox.)
Public property | ClippingBox |
Public property | IsGeometryLoaded | Gets a value indicating whether or not this geometry is currently loaded (assuming it is referenced). Not all IGH_GeometricGoo implementations support referenced geometry. The default is to always return True. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public property | IsReferencedGeometry | Gets a value indicating whether or not this geometry is referenced. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public property | IsValid | Gets the validity of this instance.
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot.)
Public property | ReferenceID | Gets or sets the Guid of the object that is referenced. Not all IGH_GeometricGoo implementations support referenced geometry. The default implementation is to always return Guid.Empty. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the value of this type. Note that if the type has a ReferenceID this value might get destroyed in the future. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)

See Also

GH_Arc Class
Grasshopper.Kernel.Types Namespace


Boundingbox Property

[image]

Grasshopper SDK
GH_Arc..::..Boundingbox Property
GH_Arc Class See Also Send Feedback
Gets the boundingbox for this geometry.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override BoundingBox Boundingbox { get; }
Visual Basic
Public Overrides ReadOnly Property Boundingbox As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Arc.Boundingbox"]

Return Value

The boundingbox for this piece of geometry or Boundingbox.Empty if the geometry is null or invalid.

See Also

GH_Arc Class
Grasshopper.Kernel.Types Namespace


ClippingBox Property

[image]

Grasshopper SDK
GH_Arc..::..ClippingBox Property
GH_Arc Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public BoundingBox ClippingBox { get; }
Visual Basic
Public ReadOnly Property ClippingBox As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Arc.ClippingBox"]

Implements

IGH_PreviewData..::..ClippingBox

See Also

GH_Arc Class
Grasshopper.Kernel.Types Namespace


IsValid Property

[image]

Grasshopper SDK
GH_Arc..::..IsValid Property
GH_Arc Class See Also Send Feedback
Gets the validity of this instance.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsValid { get; }
Visual Basic
Public ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Arc.IsValid"]

See Also

GH_Arc Class
Grasshopper.Kernel.Types Namespace


IsValidWhyNot Property

[image]

Grasshopper SDK
GH_Arc..::..IsValidWhyNot Property
GH_Arc Class See Also Send Feedback
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string IsValidWhyNot { get; }
Visual Basic
Public Overrides ReadOnly Property IsValidWhyNot As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Arc.IsValidWhyNot"]

See Also

GH_Arc Class
Grasshopper.Kernel.Types Namespace


TypeDescription Property

[image]

Grasshopper SDK
GH_Arc..::..TypeDescription Property
GH_Arc Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeDescription { get; }
Visual Basic
Public Overrides ReadOnly Property TypeDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Arc.TypeDescription"]

See Also

GH_Arc Class
Grasshopper.Kernel.Types Namespace


TypeName Property

[image]

Grasshopper SDK
GH_Arc..::..TypeName Property
GH_Arc Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeName { get; }
Visual Basic
Public Overrides ReadOnly Property TypeName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Arc.TypeName"]

See Also

GH_Arc Class
Grasshopper.Kernel.Types Namespace


GH_Boolean Class

[image]

Grasshopper SDK
GH_Boolean Class
Members See Also Send Feedback
Represents a boolean value. GH_Boolean re-implements the framework System.Boolean type.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Boolean : GH_Goo<bool>,
    IGH_QuickCast
Visual Basic
Public Class GH_Boolean _
    Inherits GH_Goo(Of Boolean) _
    Implements IGH_QuickCast

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_Goo <(Of <(<' Boolean >)>)>
Grasshopper.Kernel.Types..::..GH_Boolean

See Also

GH_Boolean Members
Grasshopper.Kernel.Types Namespace


GH_Boolean Members

[image] [image]

Grasshopper SDK
GH_Boolean Members
GH_Boolean Class Constructors Methods Fields Properties See Also Send Feedback

The GH_Boolean type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Boolean()()()() | Blank constructor
Public method | GH_Boolean(Boolean) | Initializes a new instance of the GH_Boolean class
Public method | GH_Boolean(GH_Boolean) | Initializes a new instance of the GH_Boolean class

Methods

 | Name | Description
Public method | CastFrom | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | Duplicate | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateBoolean |
Public method | EmitProxy | (Overrides GH_Goo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ToString | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | IsValid | Gets the validity of this instance. Booleans are always valid. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the internal data. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Boolean Class
Grasshopper.Kernel.Types Namespace


GH_Boolean Constructor

[image] [image]

Grasshopper SDK
GH_Boolean Constructor
GH_Boolean Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Boolean()()()() | Blank constructor
Public method | GH_Boolean(Boolean) | Initializes a new instance of the GH_Boolean class
Public method | GH_Boolean(GH_Boolean) | Initializes a new instance of the GH_Boolean class

See Also

GH_Boolean Class
GH_Boolean Members
Grasshopper.Kernel.Types Namespace


GH_Boolean Constructor

[image]

Grasshopper SDK
GH_Boolean Constructor
GH_Boolean Class See Also Send Feedback
Blank constructor

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Boolean()
Visual Basic
Public Sub New

See Also

GH_Boolean Class
GH_Boolean Overload
Grasshopper.Kernel.Types Namespace


GH_Boolean Constructor (Boolean)

[image]

Grasshopper SDK
GH_Boolean Constructor (Boolean)
GH_Boolean Class See Also Send Feedback
Initializes a new instance of the GH_Boolean class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Boolean(
    bool bool
)
Visual Basic
Public Sub New ( _
    bool As Boolean _
)

Parameters

bool
Type: System..::..Boolean

See Also

GH_Boolean Class
GH_Boolean Overload
Grasshopper.Kernel.Types Namespace


GH_Boolean Constructor (GH_Boolean)

[image]

Grasshopper SDK
GH_Boolean Constructor (GH_Boolean)
GH_Boolean Class See Also Send Feedback
Initializes a new instance of the GH_Boolean class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Boolean(
    GH_Boolean other
)
Visual Basic
Public Sub New ( _
    other As GH_Boolean _
)

Parameters

other
Type: Grasshopper.Kernel.Types..::..GH_Boolean

See Also

GH_Boolean Class
GH_Boolean Overload
Grasshopper.Kernel.Types Namespace


GH_Boolean Fields

[image] [image]

Grasshopper SDK
GH_Boolean Fields
GH_Boolean Class See Also Send Feedback

The GH_Boolean type exposes the following members.

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Boolean Class
Grasshopper.Kernel.Types Namespace


GH_Boolean Methods

[image] [image]

Grasshopper SDK
GH_Boolean Methods
GH_Boolean Class See Also Send Feedback

The GH_Boolean type exposes the following members.

Methods

 | Name | Description
Public method | CastFrom | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | Duplicate | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateBoolean |
Public method | EmitProxy | (Overrides GH_Goo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ToString | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

See Also

GH_Boolean Class
Grasshopper.Kernel.Types Namespace


CastFrom Method

[image]

Grasshopper SDK
GH_Boolean..::..CastFrom Method
GH_Boolean Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastFrom(
    Object source
)
Visual Basic
Public Overrides Function CastFrom ( _
    source As Object _
) As Boolean

Parameters

source
Type: System..::..Object

See Also

GH_Boolean Class
Grasshopper.Kernel.Types Namespace


CastTo Method

[image] [image]

Grasshopper SDK
GH_Boolean..::..CastTo Method
GH_Boolean Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Boolean Class
GH_Boolean Members
Grasshopper.Kernel.Types Namespace


CastTo(T) Method (T)

[image]

Grasshopper SDK
GH_Boolean..::..CastTo<(Of <(<'T>)>)> Method (T%)
GH_Boolean Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastTo<T>(
    out T target
)
Visual Basic
Public Overrides Function CastTo(Of T) ( _
    <OutAttribute> ByRef target As T _
) As Boolean

Parameters

target
Type: T%

Type Parameters

T

See Also

GH_Boolean Class
CastTo Overload
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_Boolean..::..Duplicate Method
GH_Boolean Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_Goo Duplicate()
Visual Basic
Public Overrides Function Duplicate As IGH_Goo

See Also

GH_Boolean Class
Grasshopper.Kernel.Types Namespace


DuplicateBoolean Method

[image]

Grasshopper SDK
GH_Boolean..::..DuplicateBoolean Method
GH_Boolean Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Boolean DuplicateBoolean()
Visual Basic
Public Function DuplicateBoolean As GH_Boolean

See Also

GH_Boolean Class
Grasshopper.Kernel.Types Namespace


EmitProxy Method

[image]

Grasshopper SDK
GH_Boolean..::..EmitProxy Method
GH_Boolean Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GooProxy EmitProxy()
Visual Basic
Public Overrides Function EmitProxy As IGH_GooProxy

See Also

GH_Boolean Class
Grasshopper.Kernel.Types Namespace


Read Method

[image]

Grasshopper SDK
GH_Boolean..::..Read Method
GH_Boolean Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

See Also

GH_Boolean Class
Grasshopper.Kernel.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_Boolean..::..ToString Method
GH_Boolean Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_Boolean Class
Grasshopper.Kernel.Types Namespace


Write Method

[image]

Grasshopper SDK
GH_Boolean..::..Write Method
GH_Boolean Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overrides Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

See Also

GH_Boolean Class
Grasshopper.Kernel.Types Namespace


GH_Boolean Properties

[image] [image]

Grasshopper SDK
GH_Boolean Properties
GH_Boolean Class See Also Send Feedback

The GH_Boolean type exposes the following members.

Properties

 | Name | Description
Public property | IsValid | Gets the validity of this instance. Booleans are always valid. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the internal data. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Boolean Class
Grasshopper.Kernel.Types Namespace


IsValid Property

[image]

Grasshopper SDK
GH_Boolean..::..IsValid Property
GH_Boolean Class See Also Send Feedback
Gets the validity of this instance. Booleans are always valid.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool IsValid { get; }
Visual Basic
Public Overrides ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Boolean.IsValid"]

See Also

GH_Boolean Class
Grasshopper.Kernel.Types Namespace


TypeDescription Property

[image]

Grasshopper SDK
GH_Boolean..::..TypeDescription Property
GH_Boolean Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeDescription { get; }
Visual Basic
Public Overrides ReadOnly Property TypeDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Boolean.TypeDescription"]

See Also

GH_Boolean Class
Grasshopper.Kernel.Types Namespace


TypeName Property

[image]

Grasshopper SDK
GH_Boolean..::..TypeName Property
GH_Boolean Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeName { get; }
Visual Basic
Public Overrides ReadOnly Property TypeName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Boolean.TypeName"]

See Also

GH_Boolean Class
Grasshopper.Kernel.Types Namespace


GH_Box Class

[image]

Grasshopper SDK
GH_Box Class
Members See Also Send Feedback
Represents a 3D oriented Box volume.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Box : GH_GeometricGoo<Box>,
    IGH_BakeAwareData, IGH_PreviewData
Visual Basic
Public Class GH_Box _
    Inherits GH_GeometricGoo(Of Box) _
    Implements IGH_BakeAwareData, IGH_PreviewData

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_Goo <(Of <(<'Box>)>)>
Grasshopper.Kernel.Types..::..GH_GeometricGoo <(Of <(<'Box>)>)>
Grasshopper.Kernel.Types..::..GH_Box

See Also

GH_Box Members
Grasshopper.Kernel.Types Namespace


GH_Box Members

[image] [image]

Grasshopper SDK
GH_Box Members
GH_Box Class Constructors Methods Fields Properties See Also Send Feedback

The GH_Box type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Box()()()() | Initializes a new instance of the GH_Box class
Public method | GH_Box(BoundingBox) | Initializes a new instance of the GH_Box class
Public method | GH_Box(Box) | Initializes a new instance of the GH_Box class
Public method | GH_Box(Guid) | Initializes a new instance of the GH_Box class
Public method | GH_Box(GH_Box) | Initializes a new instance of the GH_Box class

Methods

 | Name | Description
Public method | BakeGeometry |
Public method | Brep | Differs from Rhino.Geometry.Brep.FromBox() because it Handles degenerate cases.
Public method | CastFrom | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type T. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ClearCaches | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..ClearCaches()()()().)
Public method | DrawViewportMeshes |
Public method | DrawViewportWires |
Public method | Duplicate | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateBox |
Public method | DuplicateGeometry | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..DuplicateGeometry()()()().)
Public method | EmitProxy | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | Geometry | Convert the box to a GeometryBase instance.
Public method | GetBoundingBox | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..GetBoundingBox(Transform).)
Public method | LoadGeometry()()()() | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | LoadGeometry(RhinoDoc) | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..LoadGeometry(RhinoDoc).)
Public method | Mesh |
Public method | Morph | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Morph(SpaceMorph).)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ToString | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Transform | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Transform(Transform).)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Boundingbox | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Boundingbox.)
Public property | ClippingBox |
Public property | IsGeometryLoaded | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..IsGeometryLoaded.)
Public property | IsReferencedGeometry | Gets a value indicating whether or not this geometry is referenced. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public property | IsValid | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot.)
Public property | ReferenceID | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..ReferenceID.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Value.)

See Also

GH_Box Class
Grasshopper.Kernel.Types Namespace


GH_Box Constructor

[image] [image]

Grasshopper SDK
GH_Box Constructor
GH_Box Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Box()()()() | Initializes a new instance of the GH_Box class
Public method | GH_Box(BoundingBox) | Initializes a new instance of the GH_Box class
Public method | GH_Box(Box) | Initializes a new instance of the GH_Box class
Public method | GH_Box(Guid) | Initializes a new instance of the GH_Box class
Public method | GH_Box(GH_Box) | Initializes a new instance of the GH_Box class

See Also

GH_Box Class
GH_Box Members
Grasshopper.Kernel.Types Namespace


GH_Box Constructor

[image]

Grasshopper SDK
GH_Box Constructor
GH_Box Class See Also Send Feedback
Initializes a new instance of the GH_Box class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Box()
Visual Basic
Public Sub New

See Also

GH_Box Class
GH_Box Overload
Grasshopper.Kernel.Types Namespace


GH_Box Constructor ()

[image]

Grasshopper SDK
GH_Box Constructor ()
GH_Box Class See Also Send Feedback
Initializes a new instance of the GH_Box class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Box(
    BoundingBox box
)
Visual Basic
Public Sub New ( _
    box As BoundingBox _
)

Parameters

box
Type: BoundingBox

See Also

GH_Box Class
GH_Box Overload
Grasshopper.Kernel.Types Namespace


GH_Box Constructor ()

[image]

Grasshopper SDK
GH_Box Constructor ()
GH_Box Class See Also Send Feedback
Initializes a new instance of the GH_Box class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Box(
    Box box
)
Visual Basic
Public Sub New ( _
    box As Box _
)

Parameters

box
Type: Box

See Also

GH_Box Class
GH_Box Overload
Grasshopper.Kernel.Types Namespace


GH_Box Constructor (Guid)

[image]

Grasshopper SDK
GH_Box Constructor (Guid)
GH_Box Class See Also Send Feedback
Initializes a new instance of the GH_Box class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Box(
    Guid id
)
Visual Basic
Public Sub New ( _
    id As Guid _
)

Parameters

id
Type: System..::..Guid

See Also

GH_Box Class
GH_Box Overload
Grasshopper.Kernel.Types Namespace


GH_Box Constructor (GH_Box)

[image]

Grasshopper SDK
GH_Box Constructor (GH_Box)
GH_Box Class See Also Send Feedback
Initializes a new instance of the GH_Box class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Box(
    GH_Box other
)
Visual Basic
Public Sub New ( _
    other As GH_Box _
)

Parameters

other
Type: Grasshopper.Kernel.Types..::..GH_Box

See Also

GH_Box Class
GH_Box Overload
Grasshopper.Kernel.Types Namespace


GH_Box Fields

[image] [image]

Grasshopper SDK
GH_Box Fields
GH_Box Class See Also Send Feedback

The GH_Box type exposes the following members.

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Box Class
Grasshopper.Kernel.Types Namespace


GH_Box Methods

[image] [image]

Grasshopper SDK
GH_Box Methods
GH_Box Class See Also Send Feedback

The GH_Box type exposes the following members.

Methods

 | Name | Description
Public method | BakeGeometry |
Public method | Brep | Differs from Rhino.Geometry.Brep.FromBox() because it Handles degenerate cases.
Public method | CastFrom | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type T. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ClearCaches | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..ClearCaches()()()().)
Public method | DrawViewportMeshes |
Public method | DrawViewportWires |
Public method | Duplicate | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateBox |
Public method | DuplicateGeometry | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..DuplicateGeometry()()()().)
Public method | EmitProxy | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | Geometry | Convert the box to a GeometryBase instance.
Public method | GetBoundingBox | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..GetBoundingBox(Transform).)
Public method | LoadGeometry()()()() | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | LoadGeometry(RhinoDoc) | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..LoadGeometry(RhinoDoc).)
Public method | Mesh |
Public method | Morph | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Morph(SpaceMorph).)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ToString | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Transform | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Transform(Transform).)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

See Also

GH_Box Class
Grasshopper.Kernel.Types Namespace


BakeGeometry Method

[image]

Grasshopper SDK
GH_Box..::..BakeGeometry Method
GH_Box Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool BakeGeometry(
    RhinoDoc doc,
    ObjectAttributes att,
    ref Guid obj_guid
)
Visual Basic
Public Function BakeGeometry ( _
    doc As RhinoDoc, _
    att As ObjectAttributes, _
    ByRef obj_guid As Guid _
) As Boolean

Parameters

doc
Type: RhinoDoc
att
Type: ObjectAttributes
obj_guid
Type: System..::..Guid %

Implements

IGH_BakeAwareData..::..BakeGeometry(RhinoDoc, ObjectAttributes, Guid%)

See Also

GH_Box Class
Grasshopper.Kernel.Types Namespace


Brep Method

[image]

Grasshopper SDK
GH_Box..::..Brep Method
GH_Box Class See Also Send Feedback
Differs from Rhino.Geometry.Brep.FromBox() because it Handles degenerate cases.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Brep Brep()
Visual Basic
Public Function Brep As Brep

See Also

GH_Box Class
Grasshopper.Kernel.Types Namespace


CastFrom Method

[image]

Grasshopper SDK
GH_Box..::..CastFrom Method
GH_Box Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastFrom(
    Object source
)
Visual Basic
Public Overrides Function CastFrom ( _
    source As Object _
) As Boolean

Parameters

source
Type: System..::..Object

See Also

GH_Box Class
Grasshopper.Kernel.Types Namespace


CastTo Method

[image] [image]

Grasshopper SDK
GH_Box..::..CastTo Method
GH_Box Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type T. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Box Class
GH_Box Members
Grasshopper.Kernel.Types Namespace


CastTo(T) Method (T)

[image]

Grasshopper SDK
GH_Box..::..CastTo<(Of <(<'T>)>)> Method (T%)
GH_Box Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastTo<T>(
    out T target
)
Visual Basic
Public Overrides Function CastTo(Of T) ( _
    <OutAttribute> ByRef target As T _
) As Boolean

Parameters

target
Type: T%

Type Parameters

T

See Also

GH_Box Class
CastTo Overload
Grasshopper.Kernel.Types Namespace


ClearCaches Method

[image]

Grasshopper SDK
GH_Box..::..ClearCaches Method
GH_Box Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void ClearCaches()
Visual Basic
Public Overrides Sub ClearCaches

See Also

GH_Box Class
Grasshopper.Kernel.Types Namespace


DrawViewportMeshes Method

[image]

Grasshopper SDK
GH_Box..::..DrawViewportMeshes Method
GH_Box Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DrawViewportMeshes(
    GH_PreviewMeshArgs args
)
Visual Basic
Public Sub DrawViewportMeshes ( _
    args As GH_PreviewMeshArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..GH_PreviewMeshArgs

Implements

IGH_PreviewData..::..DrawViewportMeshes(GH_PreviewMeshArgs)

See Also

GH_Box Class
Grasshopper.Kernel.Types Namespace


DrawViewportWires Method

[image]

Grasshopper SDK
GH_Box..::..DrawViewportWires Method
GH_Box Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DrawViewportWires(
    GH_PreviewWireArgs args
)
Visual Basic
Public Sub DrawViewportWires ( _
    args As GH_PreviewWireArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..GH_PreviewWireArgs

Implements

IGH_PreviewData..::..DrawViewportWires(GH_PreviewWireArgs)

See Also

GH_Box Class
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_Box..::..Duplicate Method
GH_Box Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_Goo Duplicate()
Visual Basic
Public Overrides Function Duplicate As IGH_Goo

See Also

GH_Box Class
Grasshopper.Kernel.Types Namespace


DuplicateBox Method

[image]

Grasshopper SDK
GH_Box..::..DuplicateBox Method
GH_Box Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Box DuplicateBox()
Visual Basic
Public Function DuplicateBox As GH_Box

See Also

GH_Box Class
Grasshopper.Kernel.Types Namespace


DuplicateGeometry Method

[image]

Grasshopper SDK
GH_Box..::..DuplicateGeometry Method
GH_Box Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GeometricGoo DuplicateGeometry()
Visual Basic
Public Overrides Function DuplicateGeometry As IGH_GeometricGoo

See Also

GH_Box Class
Grasshopper.Kernel.Types Namespace


EmitProxy Method

[image]

Grasshopper SDK
GH_Box..::..EmitProxy Method
GH_Box Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GooProxy EmitProxy()
Visual Basic
Public Overrides Function EmitProxy As IGH_GooProxy

See Also

GH_Box Class
Grasshopper.Kernel.Types Namespace


Geometry Method

[image]

Grasshopper SDK
GH_Box..::..Geometry Method
GH_Box Class See Also Send Feedback
Convert the box to a GeometryBase instance.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Geometry(
    ref Brep brp,
    ref Curve crv,
    ref Point pt
)
Visual Basic
Public Function Geometry ( _
    ByRef brp As Brep, _
    ByRef crv As Curve, _
    ByRef pt As Point _
) As Boolean

Parameters

brp
Type: Brep%
If the box is at most degenerate in one direction, the brp parameter will be filled out.
crv
Type: Curve%
If the box is degenerate in exactly two directions, the crv parameter will be filled out.
pt
Type: Point%
If the box is degenerate in all three directions, the pt parameter will be filled out.

Return Value

True on success, false on failure.

See Also

GH_Box Class
Grasshopper.Kernel.Types Namespace


GetBoundingBox Method

[image]

Grasshopper SDK
GH_Box..::..GetBoundingBox Method
GH_Box Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override BoundingBox GetBoundingBox(
    Transform xform
)
Visual Basic
Public Overrides Function GetBoundingBox ( _
    xform As Transform _
) As BoundingBox

Parameters

xform
Type: Transform

See Also

GH_Box Class
Grasshopper.Kernel.Types Namespace


LoadGeometry Method

[image] [image]

Grasshopper SDK
GH_Box..::..LoadGeometry Method
GH_Box Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LoadGeometry()()()() | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | LoadGeometry(RhinoDoc) | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..LoadGeometry(RhinoDoc).)

See Also

GH_Box Class
GH_Box Members
Grasshopper.Kernel.Types Namespace


LoadGeometry Method ()

[image]

Grasshopper SDK
GH_Box..::..LoadGeometry Method ()
GH_Box Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool LoadGeometry(
    RhinoDoc doc
)
Visual Basic
Public Overrides Function LoadGeometry ( _
    doc As RhinoDoc _
) As Boolean

Parameters

doc
Type: RhinoDoc

See Also

GH_Box Class
LoadGeometry Overload
Grasshopper.Kernel.Types Namespace


Mesh Method

[image]

Grasshopper SDK
GH_Box..::..Mesh Method
GH_Box Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Mesh Mesh()
Visual Basic
Public Function Mesh As Mesh

See Also

GH_Box Class
Grasshopper.Kernel.Types Namespace


Morph Method

[image]

Grasshopper SDK
GH_Box..::..Morph Method
GH_Box Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GeometricGoo Morph(
    SpaceMorph xmorph
)
Visual Basic
Public Overrides Function Morph ( _
    xmorph As SpaceMorph _
) As IGH_GeometricGoo

Parameters

xmorph
Type: SpaceMorph

See Also

GH_Box Class
Grasshopper.Kernel.Types Namespace


Read Method

[image]

Grasshopper SDK
GH_Box..::..Read Method
GH_Box Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

See Also

GH_Box Class
Grasshopper.Kernel.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_Box..::..ToString Method
GH_Box Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_Box Class
Grasshopper.Kernel.Types Namespace


Transform Method

[image]

Grasshopper SDK
GH_Box..::..Transform Method
GH_Box Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GeometricGoo Transform(
    Transform xform
)
Visual Basic
Public Overrides Function Transform ( _
    xform As Transform _
) As IGH_GeometricGoo

Parameters

xform
Type: Transform

See Also

GH_Box Class
Grasshopper.Kernel.Types Namespace


Write Method

[image]

Grasshopper SDK
GH_Box..::..Write Method
GH_Box Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overrides Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

See Also

GH_Box Class
Grasshopper.Kernel.Types Namespace


GH_Box Properties

[image] [image]

Grasshopper SDK
GH_Box Properties
GH_Box Class See Also Send Feedback

The GH_Box type exposes the following members.

Properties

 | Name | Description
Public property | Boundingbox | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Boundingbox.)
Public property | ClippingBox |
Public property | IsGeometryLoaded | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..IsGeometryLoaded.)
Public property | IsReferencedGeometry | Gets a value indicating whether or not this geometry is referenced. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public property | IsValid | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot.)
Public property | ReferenceID | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..ReferenceID.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Value.)

See Also

GH_Box Class
Grasshopper.Kernel.Types Namespace


Boundingbox Property

[image]

Grasshopper SDK
GH_Box..::..Boundingbox Property
GH_Box Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override BoundingBox Boundingbox { get; }
Visual Basic
Public Overrides ReadOnly Property Boundingbox As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Box.Boundingbox"]

See Also

GH_Box Class
Grasshopper.Kernel.Types Namespace


ClippingBox Property

[image]

Grasshopper SDK
GH_Box..::..ClippingBox Property
GH_Box Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public BoundingBox ClippingBox { get; }
Visual Basic
Public ReadOnly Property ClippingBox As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Box.ClippingBox"]

Implements

IGH_PreviewData..::..ClippingBox

See Also

GH_Box Class
Grasshopper.Kernel.Types Namespace


IsGeometryLoaded Property

[image]

Grasshopper SDK
GH_Box..::..IsGeometryLoaded Property
GH_Box Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool IsGeometryLoaded { get; }
Visual Basic
Public Overrides ReadOnly Property IsGeometryLoaded As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Box.IsGeometryLoaded"]

See Also

GH_Box Class
Grasshopper.Kernel.Types Namespace


IsValid Property

[image]

Grasshopper SDK
GH_Box..::..IsValid Property
GH_Box Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool IsValid { get; }
Visual Basic
Public Overrides ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Box.IsValid"]

See Also

GH_Box Class
Grasshopper.Kernel.Types Namespace


IsValidWhyNot Property

[image]

Grasshopper SDK
GH_Box..::..IsValidWhyNot Property
GH_Box Class See Also Send Feedback
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string IsValidWhyNot { get; }
Visual Basic
Public Overrides ReadOnly Property IsValidWhyNot As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Box.IsValidWhyNot"]

See Also

GH_Box Class
Grasshopper.Kernel.Types Namespace


ReferenceID Property

[image]

Grasshopper SDK
GH_Box..::..ReferenceID Property
GH_Box Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override Guid ReferenceID { get; set; }
Visual Basic
Public Overrides Property ReferenceID As Guid
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Box.ReferenceID"]

See Also

GH_Box Class
Grasshopper.Kernel.Types Namespace


TypeDescription Property

[image]

Grasshopper SDK
GH_Box..::..TypeDescription Property
GH_Box Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeDescription { get; }
Visual Basic
Public Overrides ReadOnly Property TypeDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Box.TypeDescription"]

See Also

GH_Box Class
Grasshopper.Kernel.Types Namespace


TypeName Property

[image]

Grasshopper SDK
GH_Box..::..TypeName Property
GH_Box Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeName { get; }
Visual Basic
Public Overrides ReadOnly Property TypeName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Box.TypeName"]

See Also

GH_Box Class
Grasshopper.Kernel.Types Namespace


Value Property

[image]

Grasshopper SDK
GH_Box..::..Value Property
GH_Box Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override Box Value { get; set; }
Visual Basic
Public Overrides Property Value As Box
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Box.Value"]

See Also

GH_Box Class
Grasshopper.Kernel.Types Namespace


GH_Box.GH_BoxProxy Class

[image]

Grasshopper SDK
GH_Box..::..GH_BoxProxy Class
GH_Box Class Members See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_BoxProxy : GH_GooProxy<GH_Box>
Visual Basic
Public Class GH_BoxProxy _
    Inherits GH_GooProxy(Of GH_Box)

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_GooProxy <(Of <(<' GH_Box >)>)>
Grasshopper.Kernel.Types..::..GH_Box..::..GH_BoxProxy

See Also

GH_Box..::..GH_BoxProxy Members
Grasshopper.Kernel.Types Namespace


GH_Box.GH_BoxProxy Members

[image] [image]

Grasshopper SDK
GH_Box..::..GH_BoxProxy Members
GH_Box..::..GH_BoxProxy Class Constructors Methods Properties See Also Send Feedback

Represents a 3D oriented Box volume.

The GH_Box..::..GH_BoxProxy type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Box..::..GH_BoxProxy | Initializes a new instance of the GH_Box..::..GH_BoxProxy class

Methods

 | Name | Description
Public method | Construct | (Overrides GH_GooProxy<(Of <(<'T>)>)>..::..Construct()()()().)
Public method | FormatInstance | Returns a String description of the current value. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FromString | If IsParsable(), then attempts to convert the string to a generic type value (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | MutateString | Munge a string to remove obvious errors on account of the user. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | NumberToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | StringToNumber | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | ToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Area |
Public property | IsParsable | Gets a value indicating whether or not the type can be instantiated from a String. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | ObjectID |
Public property | Origin |
Protected property | Owner | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | ProxyOwner | Gets the piece of Grasshopper data that spawned this proxy. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeName | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | UserString | Gets or sets the user-defined string that describes this proxy. This only really makes sense if the Proxy is Parsable. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Valid | Gets a value indicating whether this proxy represents valid data. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Volume |
Public property | XAxis |
Public property | XSize |
Public property | YAxis |
Public property | YSize |
Public property | ZAxis |
Public property | ZSize |

See Also

GH_Box..::..GH_BoxProxy Class
Grasshopper.Kernel.Types Namespace


GH_Box.GH_BoxProxy Constructor

[image]

Grasshopper SDK
GH_Box..::..GH_BoxProxy Constructor
GH_Box..::..GH_BoxProxy Class See Also Send Feedback
Initializes a new instance of the GH_Box..::..GH_BoxProxy class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_BoxProxy(
    GH_Box Value
)
Visual Basic
Public Sub New ( _
    Value As GH_Box _
)

Parameters

Value
Type: Grasshopper.Kernel.Types..::..GH_Box

See Also

GH_Box..::..GH_BoxProxy Class
Grasshopper.Kernel.Types Namespace


GH_Box.GH_BoxProxy Methods

[image] [image]

Grasshopper SDK
GH_Box..::..GH_BoxProxy Methods
GH_Box..::..GH_BoxProxy Class See Also Send Feedback

The GH_Box..::..GH_BoxProxy type exposes the following members.

Methods

 | Name | Description
Public method | Construct | (Overrides GH_GooProxy<(Of <(<'T>)>)>..::..Construct()()()().)
Public method | FormatInstance | Returns a String description of the current value. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FromString | If IsParsable(), then attempts to convert the string to a generic type value (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | MutateString | Munge a string to remove obvious errors on account of the user. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | NumberToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | StringToNumber | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | ToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

See Also

GH_Box..::..GH_BoxProxy Class
Grasshopper.Kernel.Types Namespace


Construct Method

[image]

Grasshopper SDK
GH_Box..::..GH_BoxProxy..::..Construct Method
GH_Box..::..GH_BoxProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void Construct()
Visual Basic
Public Overrides Sub Construct

See Also

GH_Box..::..GH_BoxProxy Class
Grasshopper.Kernel.Types Namespace


GH_Box.GH_BoxProxy Properties

[image] [image]

Grasshopper SDK
GH_Box..::..GH_BoxProxy Properties
GH_Box..::..GH_BoxProxy Class See Also Send Feedback

The GH_Box..::..GH_BoxProxy type exposes the following members.

Properties

 | Name | Description
Public property | Area |
Public property | IsParsable | Gets a value indicating whether or not the type can be instantiated from a String. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | ObjectID |
Public property | Origin |
Protected property | Owner | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | ProxyOwner | Gets the piece of Grasshopper data that spawned this proxy. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeName | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | UserString | Gets or sets the user-defined string that describes this proxy. This only really makes sense if the Proxy is Parsable. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Valid | Gets a value indicating whether this proxy represents valid data. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Volume |
Public property | XAxis |
Public property | XSize |
Public property | YAxis |
Public property | YSize |
Public property | ZAxis |
Public property | ZSize |

See Also

GH_Box..::..GH_BoxProxy Class
Grasshopper.Kernel.Types Namespace


Area Property

[image]

Grasshopper SDK
GH_Box..::..GH_BoxProxy..::..Area Property
GH_Box..::..GH_BoxProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Area { get; }
Visual Basic
Public ReadOnly Property Area As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Box.GH_BoxProxy.Area"]

See Also

GH_Box..::..GH_BoxProxy Class
Grasshopper.Kernel.Types Namespace


ObjectID Property

[image]

Grasshopper SDK
GH_Box..::..GH_BoxProxy..::..ObjectID Property
GH_Box..::..GH_BoxProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string ObjectID { get; set; }
Visual Basic
Public Property ObjectID As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Box.GH_BoxProxy.ObjectID"]

See Also

GH_Box..::..GH_BoxProxy Class
Grasshopper.Kernel.Types Namespace


Origin Property

[image]

Grasshopper SDK
GH_Box..::..GH_BoxProxy..::..Origin Property
GH_Box..::..GH_BoxProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Point3d_Wrapper Origin { get; }
Visual Basic
Public ReadOnly Property Origin As GH_Point3d_Wrapper
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Box.GH_BoxProxy.Origin"]

See Also

GH_Box..::..GH_BoxProxy Class
Grasshopper.Kernel.Types Namespace


Volume Property

[image]

Grasshopper SDK
GH_Box..::..GH_BoxProxy..::..Volume Property
GH_Box..::..GH_BoxProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Volume { get; }
Visual Basic
Public ReadOnly Property Volume As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Box.GH_BoxProxy.Volume"]

See Also

GH_Box..::..GH_BoxProxy Class
Grasshopper.Kernel.Types Namespace


XAxis Property

[image]

Grasshopper SDK
GH_Box..::..GH_BoxProxy..::..XAxis Property
GH_Box..::..GH_BoxProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Vector3d_Wrapper XAxis { get; }
Visual Basic
Public ReadOnly Property XAxis As GH_Vector3d_Wrapper
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Box.GH_BoxProxy.XAxis"]

See Also

GH_Box..::..GH_BoxProxy Class
Grasshopper.Kernel.Types Namespace


XSize Property

[image]

Grasshopper SDK
GH_Box..::..GH_BoxProxy..::..XSize Property
GH_Box..::..GH_BoxProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Interval_Wrapper XSize { get; }
Visual Basic
Public ReadOnly Property XSize As GH_Interval_Wrapper
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Box.GH_BoxProxy.XSize"]

See Also

GH_Box..::..GH_BoxProxy Class
Grasshopper.Kernel.Types Namespace


YAxis Property

[image]

Grasshopper SDK
GH_Box..::..GH_BoxProxy..::..YAxis Property
GH_Box..::..GH_BoxProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Vector3d_Wrapper YAxis { get; }
Visual Basic
Public ReadOnly Property YAxis As GH_Vector3d_Wrapper
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Box.GH_BoxProxy.YAxis"]

See Also

GH_Box..::..GH_BoxProxy Class
Grasshopper.Kernel.Types Namespace


YSize Property

[image]

Grasshopper SDK
GH_Box..::..GH_BoxProxy..::..YSize Property
GH_Box..::..GH_BoxProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Interval_Wrapper YSize { get; }
Visual Basic
Public ReadOnly Property YSize As GH_Interval_Wrapper
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Box.GH_BoxProxy.YSize"]

See Also

GH_Box..::..GH_BoxProxy Class
Grasshopper.Kernel.Types Namespace


ZAxis Property

[image]

Grasshopper SDK
GH_Box..::..GH_BoxProxy..::..ZAxis Property
GH_Box..::..GH_BoxProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Vector3d_Wrapper ZAxis { get; }
Visual Basic
Public ReadOnly Property ZAxis As GH_Vector3d_Wrapper
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Box.GH_BoxProxy.ZAxis"]

See Also

GH_Box..::..GH_BoxProxy Class
Grasshopper.Kernel.Types Namespace


ZSize Property

[image]

Grasshopper SDK
GH_Box..::..GH_BoxProxy..::..ZSize Property
GH_Box..::..GH_BoxProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Interval_Wrapper ZSize { get; }
Visual Basic
Public ReadOnly Property ZSize As GH_Interval_Wrapper
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Box.GH_BoxProxy.ZSize"]

See Also

GH_Box..::..GH_BoxProxy Class
Grasshopper.Kernel.Types Namespace


GH_Brep Class

[image]

Grasshopper SDK
GH_Brep Class
Members See Also Send Feedback
Represents a 3D polysurface. GH_Brep wraps the functionality of the OpenNURBS OnBrep class.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Brep : GH_GeometricGoo<Brep>,
    IGH_BakeAwareData, IGH_PreviewData, IGH_PreviewMeshData
Visual Basic
Public Class GH_Brep _
    Inherits GH_GeometricGoo(Of Brep) _
    Implements IGH_BakeAwareData, IGH_PreviewData, IGH_PreviewMeshData

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_Goo <(Of <(<'Brep>)>)>
Grasshopper.Kernel.Types..::..GH_GeometricGoo <(Of <(<'Brep>)>)>
Grasshopper.Kernel.Types..::..GH_Brep

See Also

GH_Brep Members
Grasshopper.Kernel.Types Namespace


GH_Brep Members

[image] [image]

Grasshopper SDK
GH_Brep Members
GH_Brep Class Constructors Methods Fields Properties See Also Send Feedback

The GH_Brep type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Brep()()()() | Initializes a new instance of the GH_Brep class
Public method | GH_Brep(Brep) | Initializes a new instance of the GH_Brep class
Public method | GH_Brep(Guid) | Initializes a new instance of the GH_Brep class
Public method | GH_Brep(GH_Brep) | Initializes a new instance of the GH_Brep class

Methods

 | Name | Description
Public method | BakeGeometry |
 | BrepTightBoundingBox | Compute the boundingbox of a Brep object without meshing.
Public method | CastFrom | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type T. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ClearCaches | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..ClearCaches()()()().)
Public method | DestroyPreviewMeshes |
Public method | DrawViewportMeshes |
Public method | DrawViewportWires |
Public method | Duplicate | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateBrep |
Public method | DuplicateGeometry | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..DuplicateGeometry()()()().)
Public method | EmitProxy | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | GetBoundingBox | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..GetBoundingBox(Transform).)
Public method | GetPreviewMeshes |
Public method | LoadGeometry()()()() | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | LoadGeometry(RhinoDoc) | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..LoadGeometry(RhinoDoc).)
Public method | Morph | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Morph(SpaceMorph).)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ScriptVariable()()()().)
Public method | ToString | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Transform | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Transform(Transform).)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Boundingbox | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Boundingbox.)
Public property | ClippingBox |
Public property | IsGeometryLoaded | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..IsGeometryLoaded.)
Public property | IsReferencedGeometry | Gets a value indicating whether or not this geometry is referenced. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public property | IsValid | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot.)
Public property | ReferenceID | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..ReferenceID.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Value.)

See Also

GH_Brep Class
Grasshopper.Kernel.Types Namespace


GH_Brep Constructor

[image] [image]

Grasshopper SDK
GH_Brep Constructor
GH_Brep Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Brep()()()() | Initializes a new instance of the GH_Brep class
Public method | GH_Brep(Brep) | Initializes a new instance of the GH_Brep class
Public method | GH_Brep(Guid) | Initializes a new instance of the GH_Brep class
Public method | GH_Brep(GH_Brep) | Initializes a new instance of the GH_Brep class

See Also

GH_Brep Class
GH_Brep Members
Grasshopper.Kernel.Types Namespace


GH_Brep Constructor

[image]

Grasshopper SDK
GH_Brep Constructor
GH_Brep Class See Also Send Feedback
Initializes a new instance of the GH_Brep class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Brep()
Visual Basic
Public Sub New

See Also

GH_Brep Class
GH_Brep Overload
Grasshopper.Kernel.Types Namespace


GH_Brep Constructor ()

[image]

Grasshopper SDK
GH_Brep Constructor ()
GH_Brep Class See Also Send Feedback
Initializes a new instance of the GH_Brep class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Brep(
    Brep brep
)
Visual Basic
Public Sub New ( _
    brep As Brep _
)

Parameters

brep
Type: Brep

See Also

GH_Brep Class
GH_Brep Overload
Grasshopper.Kernel.Types Namespace


GH_Brep Constructor (Guid)

[image]

Grasshopper SDK
GH_Brep Constructor (Guid)
GH_Brep Class See Also Send Feedback
Initializes a new instance of the GH_Brep class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Brep(
    Guid id
)
Visual Basic
Public Sub New ( _
    id As Guid _
)

Parameters

id
Type: System..::..Guid

See Also

GH_Brep Class
GH_Brep Overload
Grasshopper.Kernel.Types Namespace


GH_Brep Constructor (GH_Brep)

[image]

Grasshopper SDK
GH_Brep Constructor (GH_Brep)
GH_Brep Class See Also Send Feedback
Initializes a new instance of the GH_Brep class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Brep(
    GH_Brep other
)
Visual Basic
Public Sub New ( _
    other As GH_Brep _
)

Parameters

other
Type: Grasshopper.Kernel.Types..::..GH_Brep

See Also

GH_Brep Class
GH_Brep Overload
Grasshopper.Kernel.Types Namespace


GH_Brep Fields

[image] [image]

Grasshopper SDK
GH_Brep Fields
GH_Brep Class See Also Send Feedback

The GH_Brep type exposes the following members.

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Brep Class
Grasshopper.Kernel.Types Namespace


GH_Brep Methods

[image] [image]

Grasshopper SDK
GH_Brep Methods
GH_Brep Class See Also Send Feedback

The GH_Brep type exposes the following members.

Methods

 | Name | Description
Public method | BakeGeometry |
 | BrepTightBoundingBox | Compute the boundingbox of a Brep object without meshing.
Public method | CastFrom | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type T. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ClearCaches | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..ClearCaches()()()().)
Public method | DestroyPreviewMeshes |
Public method | DrawViewportMeshes |
Public method | DrawViewportWires |
Public method | Duplicate | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateBrep |
Public method | DuplicateGeometry | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..DuplicateGeometry()()()().)
Public method | EmitProxy | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | GetBoundingBox | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..GetBoundingBox(Transform).)
Public method | GetPreviewMeshes |
Public method | LoadGeometry()()()() | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | LoadGeometry(RhinoDoc) | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..LoadGeometry(RhinoDoc).)
Public method | Morph | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Morph(SpaceMorph).)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ScriptVariable()()()().)
Public method | ToString | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Transform | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Transform(Transform).)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

See Also

GH_Brep Class
Grasshopper.Kernel.Types Namespace


BakeGeometry Method

[image]

Grasshopper SDK
GH_Brep..::..BakeGeometry Method
GH_Brep Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool BakeGeometry(
    RhinoDoc doc,
    ObjectAttributes att,
    ref Guid obj_guid
)
Visual Basic
Public Function BakeGeometry ( _
    doc As RhinoDoc, _
    att As ObjectAttributes, _
    ByRef obj_guid As Guid _
) As Boolean

Parameters

doc
Type: RhinoDoc
att
Type: ObjectAttributes
obj_guid
Type: System..::..Guid %

Implements

IGH_BakeAwareData..::..BakeGeometry(RhinoDoc, ObjectAttributes, Guid%)

See Also

GH_Brep Class
Grasshopper.Kernel.Types Namespace


BrepTightBoundingBox Method

[image]

Grasshopper SDK
GH_Brep..::..BrepTightBoundingBox Method
GH_Brep Class See Also Send Feedback
Compute the boundingbox of a Brep object without meshing.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static BoundingBox BrepTightBoundingBox(
    Brep in
)
Visual Basic
Public Shared Function BrepTightBoundingBox ( _
    in As Brep _
) As BoundingBox

Parameters

in
Type: Brep
Brep to measure.

Return Value

The world aligned boundingbox of the object.

See Also

GH_Brep Class
Grasshopper.Kernel.Types Namespace


CastFrom Method

[image]

Grasshopper SDK
GH_Brep..::..CastFrom Method
GH_Brep Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastFrom(
    Object source
)
Visual Basic
Public Overrides Function CastFrom ( _
    source As Object _
) As Boolean

Parameters

source
Type: System..::..Object

See Also

GH_Brep Class
Grasshopper.Kernel.Types Namespace


CastTo Method

[image] [image]

Grasshopper SDK
GH_Brep..::..CastTo Method
GH_Brep Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type T. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Brep Class
GH_Brep Members
Grasshopper.Kernel.Types Namespace


CastTo(T) Method (T)

[image]

Grasshopper SDK
GH_Brep..::..CastTo<(Of <(<'T>)>)> Method (T%)
GH_Brep Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastTo<T>(
    out T target
)
Visual Basic
Public Overrides Function CastTo(Of T) ( _
    <OutAttribute> ByRef target As T _
) As Boolean

Parameters

target
Type: T%

Type Parameters

T

See Also

GH_Brep Class
CastTo Overload
Grasshopper.Kernel.Types Namespace


ClearCaches Method

[image]

Grasshopper SDK
GH_Brep..::..ClearCaches Method
GH_Brep Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void ClearCaches()
Visual Basic
Public Overrides Sub ClearCaches

See Also

GH_Brep Class
Grasshopper.Kernel.Types Namespace


DestroyPreviewMeshes Method

[image]

Grasshopper SDK
GH_Brep..::..DestroyPreviewMeshes Method
GH_Brep Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DestroyPreviewMeshes()
Visual Basic
Public Sub DestroyPreviewMeshes

Implements

IGH_PreviewMeshData..::..DestroyPreviewMeshes()()()()

See Also

GH_Brep Class
Grasshopper.Kernel.Types Namespace


DrawViewportMeshes Method

[image]

Grasshopper SDK
GH_Brep..::..DrawViewportMeshes Method
GH_Brep Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DrawViewportMeshes(
    GH_PreviewMeshArgs args
)
Visual Basic
Public Sub DrawViewportMeshes ( _
    args As GH_PreviewMeshArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..GH_PreviewMeshArgs

Implements

IGH_PreviewData..::..DrawViewportMeshes(GH_PreviewMeshArgs)

See Also

GH_Brep Class
Grasshopper.Kernel.Types Namespace


DrawViewportWires Method

[image]

Grasshopper SDK
GH_Brep..::..DrawViewportWires Method
GH_Brep Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DrawViewportWires(
    GH_PreviewWireArgs args
)
Visual Basic
Public Sub DrawViewportWires ( _
    args As GH_PreviewWireArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..GH_PreviewWireArgs

Implements

IGH_PreviewData..::..DrawViewportWires(GH_PreviewWireArgs)

See Also

GH_Brep Class
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_Brep..::..Duplicate Method
GH_Brep Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_Goo Duplicate()
Visual Basic
Public Overrides Function Duplicate As IGH_Goo

See Also

GH_Brep Class
Grasshopper.Kernel.Types Namespace


DuplicateBrep Method

[image]

Grasshopper SDK
GH_Brep..::..DuplicateBrep Method
GH_Brep Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Brep DuplicateBrep()
Visual Basic
Public Function DuplicateBrep As GH_Brep

See Also

GH_Brep Class
Grasshopper.Kernel.Types Namespace


DuplicateGeometry Method

[image]

Grasshopper SDK
GH_Brep..::..DuplicateGeometry Method
GH_Brep Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GeometricGoo DuplicateGeometry()
Visual Basic
Public Overrides Function DuplicateGeometry As IGH_GeometricGoo

See Also

GH_Brep Class
Grasshopper.Kernel.Types Namespace


EmitProxy Method

[image]

Grasshopper SDK
GH_Brep..::..EmitProxy Method
GH_Brep Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GooProxy EmitProxy()
Visual Basic
Public Overrides Function EmitProxy As IGH_GooProxy

See Also

GH_Brep Class
Grasshopper.Kernel.Types Namespace


GetBoundingBox Method

[image]

Grasshopper SDK
GH_Brep..::..GetBoundingBox Method
GH_Brep Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override BoundingBox GetBoundingBox(
    Transform xform
)
Visual Basic
Public Overrides Function GetBoundingBox ( _
    xform As Transform _
) As BoundingBox

Parameters

xform
Type: Transform

See Also

GH_Brep Class
Grasshopper.Kernel.Types Namespace


GetPreviewMeshes Method

[image]

Grasshopper SDK
GH_Brep..::..GetPreviewMeshes Method
GH_Brep Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Mesh[] GetPreviewMeshes()
Visual Basic
Public Function GetPreviewMeshes As Mesh()

Implements

IGH_PreviewMeshData..::..GetPreviewMeshes()()()()

See Also

GH_Brep Class
Grasshopper.Kernel.Types Namespace


LoadGeometry Method

[image] [image]

Grasshopper SDK
GH_Brep..::..LoadGeometry Method
GH_Brep Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LoadGeometry()()()() | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | LoadGeometry(RhinoDoc) | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..LoadGeometry(RhinoDoc).)

See Also

GH_Brep Class
GH_Brep Members
Grasshopper.Kernel.Types Namespace


LoadGeometry Method ()

[image]

Grasshopper SDK
GH_Brep..::..LoadGeometry Method ()
GH_Brep Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool LoadGeometry(
    RhinoDoc doc
)
Visual Basic
Public Overrides Function LoadGeometry ( _
    doc As RhinoDoc _
) As Boolean

Parameters

doc
Type: RhinoDoc

See Also

GH_Brep Class
LoadGeometry Overload
Grasshopper.Kernel.Types Namespace


Morph Method

[image]

Grasshopper SDK
GH_Brep..::..Morph Method
GH_Brep Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GeometricGoo Morph(
    SpaceMorph xmorph
)
Visual Basic
Public Overrides Function Morph ( _
    xmorph As SpaceMorph _
) As IGH_GeometricGoo

Parameters

xmorph
Type: SpaceMorph

See Also

GH_Brep Class
Grasshopper.Kernel.Types Namespace


Read Method

[image]

Grasshopper SDK
GH_Brep..::..Read Method
GH_Brep Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

See Also

GH_Brep Class
Grasshopper.Kernel.Types Namespace


ScriptVariable Method

[image]

Grasshopper SDK
GH_Brep..::..ScriptVariable Method
GH_Brep Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override Object ScriptVariable()
Visual Basic
Public Overrides Function ScriptVariable As Object

See Also

GH_Brep Class
Grasshopper.Kernel.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_Brep..::..ToString Method
GH_Brep Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_Brep Class
Grasshopper.Kernel.Types Namespace


Transform Method

[image]

Grasshopper SDK
GH_Brep..::..Transform Method
GH_Brep Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GeometricGoo Transform(
    Transform xform
)
Visual Basic
Public Overrides Function Transform ( _
    xform As Transform _
) As IGH_GeometricGoo

Parameters

xform
Type: Transform

See Also

GH_Brep Class
Grasshopper.Kernel.Types Namespace


Write Method

[image]

Grasshopper SDK
GH_Brep..::..Write Method
GH_Brep Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overrides Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

See Also

GH_Brep Class
Grasshopper.Kernel.Types Namespace


GH_Brep Properties

[image] [image]

Grasshopper SDK
GH_Brep Properties
GH_Brep Class See Also Send Feedback

The GH_Brep type exposes the following members.

Properties

 | Name | Description
Public property | Boundingbox | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Boundingbox.)
Public property | ClippingBox |
Public property | IsGeometryLoaded | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..IsGeometryLoaded.)
Public property | IsReferencedGeometry | Gets a value indicating whether or not this geometry is referenced. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public property | IsValid | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot.)
Public property | ReferenceID | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..ReferenceID.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Value.)

See Also

GH_Brep Class
Grasshopper.Kernel.Types Namespace


Boundingbox Property

[image]

Grasshopper SDK
GH_Brep..::..Boundingbox Property
GH_Brep Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override BoundingBox Boundingbox { get; }
Visual Basic
Public Overrides ReadOnly Property Boundingbox As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Brep.Boundingbox"]

See Also

GH_Brep Class
Grasshopper.Kernel.Types Namespace


ClippingBox Property

[image]

Grasshopper SDK
GH_Brep..::..ClippingBox Property
GH_Brep Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public BoundingBox ClippingBox { get; }
Visual Basic
Public ReadOnly Property ClippingBox As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Brep.ClippingBox"]

Implements

IGH_PreviewData..::..ClippingBox

See Also

GH_Brep Class
Grasshopper.Kernel.Types Namespace


IsGeometryLoaded Property

[image]

Grasshopper SDK
GH_Brep..::..IsGeometryLoaded Property
GH_Brep Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool IsGeometryLoaded { get; }
Visual Basic
Public Overrides ReadOnly Property IsGeometryLoaded As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Brep.IsGeometryLoaded"]

See Also

GH_Brep Class
Grasshopper.Kernel.Types Namespace


IsValid Property

[image]

Grasshopper SDK
GH_Brep..::..IsValid Property
GH_Brep Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool IsValid { get; }
Visual Basic
Public Overrides ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Brep.IsValid"]

See Also

GH_Brep Class
Grasshopper.Kernel.Types Namespace


IsValidWhyNot Property

[image]

Grasshopper SDK
GH_Brep..::..IsValidWhyNot Property
GH_Brep Class See Also Send Feedback
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string IsValidWhyNot { get; }
Visual Basic
Public Overrides ReadOnly Property IsValidWhyNot As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Brep.IsValidWhyNot"]

See Also

GH_Brep Class
Grasshopper.Kernel.Types Namespace


ReferenceID Property

[image]

Grasshopper SDK
GH_Brep..::..ReferenceID Property
GH_Brep Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override Guid ReferenceID { get; set; }
Visual Basic
Public Overrides Property ReferenceID As Guid
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Brep.ReferenceID"]

See Also

GH_Brep Class
Grasshopper.Kernel.Types Namespace


TypeDescription Property

[image]

Grasshopper SDK
GH_Brep..::..TypeDescription Property
GH_Brep Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeDescription { get; }
Visual Basic
Public Overrides ReadOnly Property TypeDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Brep.TypeDescription"]

See Also

GH_Brep Class
Grasshopper.Kernel.Types Namespace


TypeName Property

[image]

Grasshopper SDK
GH_Brep..::..TypeName Property
GH_Brep Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeName { get; }
Visual Basic
Public Overrides ReadOnly Property TypeName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Brep.TypeName"]

See Also

GH_Brep Class
Grasshopper.Kernel.Types Namespace


Value Property

[image]

Grasshopper SDK
GH_Brep..::..Value Property
GH_Brep Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override Brep Value { get; set; }
Visual Basic
Public Overrides Property Value As Brep
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Brep.Value"]

See Also

GH_Brep Class
Grasshopper.Kernel.Types Namespace


GH_Brep.GH_BrepProxy Class

[image]

Grasshopper SDK
GH_Brep..::..GH_BrepProxy Class
GH_Brep Class Members See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_BrepProxy : GH_GooProxy<GH_Brep>
Visual Basic
Public Class GH_BrepProxy _
    Inherits GH_GooProxy(Of GH_Brep)

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_GooProxy <(Of <(<' GH_Brep >)>)>
Grasshopper.Kernel.Types..::..GH_Brep..::..GH_BrepProxy

See Also

GH_Brep..::..GH_BrepProxy Members
Grasshopper.Kernel.Types Namespace


GH_Brep.GH_BrepProxy Members

[image] [image]

Grasshopper SDK
GH_Brep..::..GH_BrepProxy Members
GH_Brep..::..GH_BrepProxy Class Constructors Methods Properties See Also Send Feedback

Represents a 3D polysurface. GH_Brep wraps the functionality of the OpenNURBS OnBrep class.

The GH_Brep..::..GH_BrepProxy type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Brep..::..GH_BrepProxy | Initializes a new instance of the GH_Brep..::..GH_BrepProxy class

Methods

 | Name | Description
Public method | Construct | (Overrides GH_GooProxy<(Of <(<'T>)>)>..::..Construct()()()().)
Public method | FormatInstance | Returns a String description of the current value. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FromString | (Overrides GH_GooProxy<(Of <(<'T>)>)>..::..FromString(String).)
Public method | MutateString | Munge a string to remove obvious errors on account of the user. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | NumberToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | StringToNumber | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | ToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Area |
Public property | EdgeCount |
Public property | FaceCount |
Public property | IsParsable | Gets a value indicating whether or not the type can be instantiated from a String. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | LoopCount |
Public property | Manifold |
Public property | ObjectID |
Protected property | Owner | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | ProxyOwner | Gets the piece of Grasshopper data that spawned this proxy. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Solid |
Public property | TypeDescription | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeName | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | UserString | Gets or sets the user-defined string that describes this proxy. This only really makes sense if the Proxy is Parsable. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Valid | Gets a value indicating whether this proxy represents valid data. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | VertexCount |
Public property | Volume |

See Also

GH_Brep..::..GH_BrepProxy Class
Grasshopper.Kernel.Types Namespace


GH_Brep.GH_BrepProxy Constructor

[image]

Grasshopper SDK
GH_Brep..::..GH_BrepProxy Constructor
GH_Brep..::..GH_BrepProxy Class See Also Send Feedback
Initializes a new instance of the GH_Brep..::..GH_BrepProxy class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_BrepProxy(
    GH_Brep Value
)
Visual Basic
Public Sub New ( _
    Value As GH_Brep _
)

Parameters

Value
Type: Grasshopper.Kernel.Types..::..GH_Brep

See Also

GH_Brep..::..GH_BrepProxy Class
Grasshopper.Kernel.Types Namespace


GH_Brep.GH_BrepProxy Methods

[image] [image]

Grasshopper SDK
GH_Brep..::..GH_BrepProxy Methods
GH_Brep..::..GH_BrepProxy Class See Also Send Feedback

The GH_Brep..::..GH_BrepProxy type exposes the following members.

Methods

 | Name | Description
Public method | Construct | (Overrides GH_GooProxy<(Of <(<'T>)>)>..::..Construct()()()().)
Public method | FormatInstance | Returns a String description of the current value. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FromString | (Overrides GH_GooProxy<(Of <(<'T>)>)>..::..FromString(String).)
Public method | MutateString | Munge a string to remove obvious errors on account of the user. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | NumberToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | StringToNumber | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | ToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

See Also

GH_Brep..::..GH_BrepProxy Class
Grasshopper.Kernel.Types Namespace


Construct Method

[image]

Grasshopper SDK
GH_Brep..::..GH_BrepProxy..::..Construct Method
GH_Brep..::..GH_BrepProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void Construct()
Visual Basic
Public Overrides Sub Construct

See Also

GH_Brep..::..GH_BrepProxy Class
Grasshopper.Kernel.Types Namespace


FromString Method

[image]

Grasshopper SDK
GH_Brep..::..GH_BrepProxy..::..FromString Method
GH_Brep..::..GH_BrepProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool FromString(
    string in
)
Visual Basic
Public Overrides Function FromString ( _
    in As String _
) As Boolean

Parameters

in
Type: System..::..String

See Also

GH_Brep..::..GH_BrepProxy Class
Grasshopper.Kernel.Types Namespace


GH_Brep.GH_BrepProxy Properties

[image] [image]

Grasshopper SDK
GH_Brep..::..GH_BrepProxy Properties
GH_Brep..::..GH_BrepProxy Class See Also Send Feedback

The GH_Brep..::..GH_BrepProxy type exposes the following members.

Properties

 | Name | Description
Public property | Area |
Public property | EdgeCount |
Public property | FaceCount |
Public property | IsParsable | Gets a value indicating whether or not the type can be instantiated from a String. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | LoopCount |
Public property | Manifold |
Public property | ObjectID |
Protected property | Owner | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | ProxyOwner | Gets the piece of Grasshopper data that spawned this proxy. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Solid |
Public property | TypeDescription | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeName | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | UserString | Gets or sets the user-defined string that describes this proxy. This only really makes sense if the Proxy is Parsable. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Valid | Gets a value indicating whether this proxy represents valid data. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | VertexCount |
Public property | Volume |

See Also

GH_Brep..::..GH_BrepProxy Class
Grasshopper.Kernel.Types Namespace


Area Property

[image]

Grasshopper SDK
GH_Brep..::..GH_BrepProxy..::..Area Property
GH_Brep..::..GH_BrepProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Area { get; }
Visual Basic
Public ReadOnly Property Area As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Brep.GH_BrepProxy.Area"]

See Also

GH_Brep..::..GH_BrepProxy Class
Grasshopper.Kernel.Types Namespace


EdgeCount Property

[image]

Grasshopper SDK
GH_Brep..::..GH_BrepProxy..::..EdgeCount Property
GH_Brep..::..GH_BrepProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int EdgeCount { get; }
Visual Basic
Public ReadOnly Property EdgeCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Brep.GH_BrepProxy.EdgeCount"]

See Also

GH_Brep..::..GH_BrepProxy Class
Grasshopper.Kernel.Types Namespace


FaceCount Property

[image]

Grasshopper SDK
GH_Brep..::..GH_BrepProxy..::..FaceCount Property
GH_Brep..::..GH_BrepProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int FaceCount { get; }
Visual Basic
Public ReadOnly Property FaceCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Brep.GH_BrepProxy.FaceCount"]

See Also

GH_Brep..::..GH_BrepProxy Class
Grasshopper.Kernel.Types Namespace


LoopCount Property

[image]

Grasshopper SDK
GH_Brep..::..GH_BrepProxy..::..LoopCount Property
GH_Brep..::..GH_BrepProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int LoopCount { get; }
Visual Basic
Public ReadOnly Property LoopCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Brep.GH_BrepProxy.LoopCount"]

See Also

GH_Brep..::..GH_BrepProxy Class
Grasshopper.Kernel.Types Namespace


Manifold Property

[image]

Grasshopper SDK
GH_Brep..::..GH_BrepProxy..::..Manifold Property
GH_Brep..::..GH_BrepProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Manifold { get; }
Visual Basic
Public ReadOnly Property Manifold As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Brep.GH_BrepProxy.Manifold"]

See Also

GH_Brep..::..GH_BrepProxy Class
Grasshopper.Kernel.Types Namespace


ObjectID Property

[image]

Grasshopper SDK
GH_Brep..::..GH_BrepProxy..::..ObjectID Property
GH_Brep..::..GH_BrepProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string ObjectID { get; set; }
Visual Basic
Public Property ObjectID As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Brep.GH_BrepProxy.ObjectID"]

See Also

GH_Brep..::..GH_BrepProxy Class
Grasshopper.Kernel.Types Namespace


Solid Property

[image]

Grasshopper SDK
GH_Brep..::..GH_BrepProxy..::..Solid Property
GH_Brep..::..GH_BrepProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Solid { get; }
Visual Basic
Public ReadOnly Property Solid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Brep.GH_BrepProxy.Solid"]

See Also

GH_Brep..::..GH_BrepProxy Class
Grasshopper.Kernel.Types Namespace


VertexCount Property

[image]

Grasshopper SDK
GH_Brep..::..GH_BrepProxy..::..VertexCount Property
GH_Brep..::..GH_BrepProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int VertexCount { get; }
Visual Basic
Public ReadOnly Property VertexCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Brep.GH_BrepProxy.VertexCount"]

See Also

GH_Brep..::..GH_BrepProxy Class
Grasshopper.Kernel.Types Namespace


Volume Property

[image]

Grasshopper SDK
GH_Brep..::..GH_BrepProxy..::..Volume Property
GH_Brep..::..GH_BrepProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Volume { get; }
Visual Basic
Public ReadOnly Property Volume As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Brep.GH_BrepProxy.Volume"]

See Also

GH_Brep..::..GH_BrepProxy Class
Grasshopper.Kernel.Types Namespace


GH_Circle Class

[image]

Grasshopper SDK
GH_Circle Class
Members See Also Send Feedback
Represents a 3D circle. GH_Circle re-implements the OpenNURBS OnCircle class.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Circle : GH_GeometricGoo<Circle>,
    IGH_BakeAwareData, IGH_PreviewData
Visual Basic
Public Class GH_Circle _
    Inherits GH_GeometricGoo(Of Circle) _
    Implements IGH_BakeAwareData, IGH_PreviewData

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_Goo <(Of <(<'Circle>)>)>
Grasshopper.Kernel.Types..::..GH_GeometricGoo <(Of <(<'Circle>)>)>
Grasshopper.Kernel.Types..::..GH_Circle

See Also

GH_Circle Members
Grasshopper.Kernel.Types Namespace


GH_Circle Members

[image] [image]

Grasshopper SDK
GH_Circle Members
GH_Circle Class Constructors Methods Fields Properties See Also Send Feedback

The GH_Circle type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Circle()()()() | Default constructor
Public method | GH_Circle(Circle) | Create a duplicate of another circle
Public method | GH_Circle(GH_Circle) | Create a duplicate of another circle.

Methods

 | Name | Description
Public method | BakeGeometry |
Public method | CastFrom | Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(T>)>>)(T%) | Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type T. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ClearCaches | Clears all caches. Typically if the geometry is referenced, this will erase the local copy. If your T is a value-type, you must override this function and specifically unset the local value. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | DrawViewportMeshes |
Public method | DrawViewportWires |
Public method | Duplicate | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateCircle | Create a duplicate of this circle.
Public method | DuplicateGeometry | Create a duplicate of this circle. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..DuplicateGeometry()()()().)
Public method | EmitProxy | Returns a proxy that represents this circle. Do not call this function unless you're (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | GetBoundingBox | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..GetBoundingBox(Transform).)
Public method | LoadGeometry()()()() | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | LoadGeometry(RhinoDoc) | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. The default is to always return True. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | Morph | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Morph(SpaceMorph).)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ToString | Format the circle using default grasshopper formatting logic. (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Transform | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Transform(Transform).)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Boundingbox | Gets the boundingbox for this geometry. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Boundingbox.)
Public property | ClippingBox |
Public property | IsGeometryLoaded | Gets a value indicating whether or not this geometry is currently loaded (assuming it is referenced). Not all IGH_GeometricGoo implementations support referenced geometry. The default is to always return True. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public property | IsReferencedGeometry | Gets a value indicating whether or not this geometry is referenced. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public property | IsValid | Gets the validity of this instance. Circles are valid when their base planes are valid and when the radius is larger than zero. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot.)
Public property | ReferenceID | Gets or sets the Guid of the object that is referenced. Not all IGH_GeometricGoo implementations support referenced geometry. The default implementation is to always return Guid.Empty. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the value of this type. Note that if the type has a ReferenceID this value might get destroyed in the future. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)

See Also

GH_Circle Class
Grasshopper.Kernel.Types Namespace


GH_Circle Constructor

[image] [image]

Grasshopper SDK
GH_Circle Constructor
GH_Circle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Circle()()()() | Default constructor
Public method | GH_Circle(Circle) | Create a duplicate of another circle
Public method | GH_Circle(GH_Circle) | Create a duplicate of another circle.

See Also

GH_Circle Class
GH_Circle Members
Grasshopper.Kernel.Types Namespace


GH_Circle Constructor

[image]

Grasshopper SDK
GH_Circle Constructor
GH_Circle Class See Also Send Feedback
Default constructor

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Circle()
Visual Basic
Public Sub New

See Also

GH_Circle Class
GH_Circle Overload
Grasshopper.Kernel.Types Namespace


GH_Circle Constructor ()

[image]

Grasshopper SDK
GH_Circle Constructor ()
GH_Circle Class See Also Send Feedback
Create a duplicate of another circle

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Circle(
    Circle circle
)
Visual Basic
Public Sub New ( _
    circle As Circle _
)

Parameters

circle
Type: Circle
Circle to copy. If null, a default circle will be created.

See Also

GH_Circle Class
GH_Circle Overload
Grasshopper.Kernel.Types Namespace


GH_Circle Constructor (GH_Circle)

[image]

Grasshopper SDK
GH_Circle Constructor (GH_Circle)
GH_Circle Class See Also Send Feedback
Create a duplicate of another circle.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Circle(
    GH_Circle other
)
Visual Basic
Public Sub New ( _
    other As GH_Circle _
)

Parameters

other
Type: Grasshopper.Kernel.Types..::..GH_Circle
Circle to mimic.

See Also

GH_Circle Class
GH_Circle Overload
Grasshopper.Kernel.Types Namespace


GH_Circle Fields

[image] [image]

Grasshopper SDK
GH_Circle Fields
GH_Circle Class See Also Send Feedback

The GH_Circle type exposes the following members.

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Circle Class
Grasshopper.Kernel.Types Namespace


GH_Circle Methods

[image] [image]

Grasshopper SDK
GH_Circle Methods
GH_Circle Class See Also Send Feedback

The GH_Circle type exposes the following members.

Methods

 | Name | Description
Public method | BakeGeometry |
Public method | CastFrom | Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(T>)>>)(T%) | Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type T. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ClearCaches | Clears all caches. Typically if the geometry is referenced, this will erase the local copy. If your T is a value-type, you must override this function and specifically unset the local value. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | DrawViewportMeshes |
Public method | DrawViewportWires |
Public method | Duplicate | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateCircle | Create a duplicate of this circle.
Public method | DuplicateGeometry | Create a duplicate of this circle. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..DuplicateGeometry()()()().)
Public method | EmitProxy | Returns a proxy that represents this circle. Do not call this function unless you're (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | GetBoundingBox | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..GetBoundingBox(Transform).)
Public method | LoadGeometry()()()() | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | LoadGeometry(RhinoDoc) | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. The default is to always return True. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | Morph | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Morph(SpaceMorph).)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ToString | Format the circle using default grasshopper formatting logic. (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Transform | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Transform(Transform).)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

See Also

GH_Circle Class
Grasshopper.Kernel.Types Namespace


BakeGeometry Method

[image]

Grasshopper SDK
GH_Circle..::..BakeGeometry Method
GH_Circle Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool BakeGeometry(
    RhinoDoc doc,
    ObjectAttributes att,
    ref Guid obj_guid
)
Visual Basic
Public Function BakeGeometry ( _
    doc As RhinoDoc, _
    att As ObjectAttributes, _
    ByRef obj_guid As Guid _
) As Boolean

Parameters

doc
Type: RhinoDoc
att
Type: ObjectAttributes
obj_guid
Type: System..::..Guid %

Implements

IGH_BakeAwareData..::..BakeGeometry(RhinoDoc, ObjectAttributes, Guid%)

See Also

GH_Circle Class
Grasshopper.Kernel.Types Namespace


CastFrom Method

[image]

Grasshopper SDK
GH_Circle..::..CastFrom Method
GH_Circle Class See Also Send Feedback
Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastFrom(
    Object source
)
Visual Basic
Public Overrides Function CastFrom ( _
    source As Object _
) As Boolean

Parameters

source
Type: System..::..Object

See Also

GH_Circle Class
Grasshopper.Kernel.Types Namespace


CastTo Method

[image] [image]

Grasshopper SDK
GH_Circle..::..CastTo Method
GH_Circle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CastTo<(Of <<'(T>)>>)(T%) | Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type T. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Circle Class
GH_Circle Members
Grasshopper.Kernel.Types Namespace


CastTo(T) Method (T)

[image]

Grasshopper SDK
GH_Circle..::..CastTo<(Of <(<'T>)>)> Method (T%)
GH_Circle Class See Also Send Feedback
Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastTo<T>(
    out T target
)
Visual Basic
Public Overrides Function CastTo(Of T) ( _
    <OutAttribute> ByRef target As T _
) As Boolean

Parameters

target
Type: T%

Type Parameters

T

See Also

GH_Circle Class
CastTo Overload
Grasshopper.Kernel.Types Namespace


DrawViewportMeshes Method

[image]

Grasshopper SDK
GH_Circle..::..DrawViewportMeshes Method
GH_Circle Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DrawViewportMeshes(
    GH_PreviewMeshArgs args
)
Visual Basic
Public Sub DrawViewportMeshes ( _
    args As GH_PreviewMeshArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..GH_PreviewMeshArgs

Implements

IGH_PreviewData..::..DrawViewportMeshes(GH_PreviewMeshArgs)

See Also

GH_Circle Class
Grasshopper.Kernel.Types Namespace


DrawViewportWires Method

[image]

Grasshopper SDK
GH_Circle..::..DrawViewportWires Method
GH_Circle Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DrawViewportWires(
    GH_PreviewWireArgs args
)
Visual Basic
Public Sub DrawViewportWires ( _
    args As GH_PreviewWireArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..GH_PreviewWireArgs

Implements

IGH_PreviewData..::..DrawViewportWires(GH_PreviewWireArgs)

See Also

GH_Circle Class
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_Circle..::..Duplicate Method
GH_Circle Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_Goo Duplicate()
Visual Basic
Public Overrides Function Duplicate As IGH_Goo

See Also

GH_Circle Class
Grasshopper.Kernel.Types Namespace


DuplicateCircle Method

[image]

Grasshopper SDK
GH_Circle..::..DuplicateCircle Method
GH_Circle Class See Also Send Feedback
Create a duplicate of this circle.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Circle DuplicateCircle()
Visual Basic
Public Function DuplicateCircle As GH_Circle

See Also

GH_Circle Class
Grasshopper.Kernel.Types Namespace


DuplicateGeometry Method

[image]

Grasshopper SDK
GH_Circle..::..DuplicateGeometry Method
GH_Circle Class See Also Send Feedback
Create a duplicate of this circle.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GeometricGoo DuplicateGeometry()
Visual Basic
Public Overrides Function DuplicateGeometry As IGH_GeometricGoo

See Also

GH_Circle Class
Grasshopper.Kernel.Types Namespace


EmitProxy Method

[image]

Grasshopper SDK
GH_Circle..::..EmitProxy Method
GH_Circle Class See Also Send Feedback
Returns a proxy that represents this circle. Do not call this function unless you're

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GooProxy EmitProxy()
Visual Basic
Public Overrides Function EmitProxy As IGH_GooProxy

See Also

GH_Circle Class
Grasshopper.Kernel.Types Namespace


GetBoundingBox Method

[image]

Grasshopper SDK
GH_Circle..::..GetBoundingBox Method
GH_Circle Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override BoundingBox GetBoundingBox(
    Transform xform
)
Visual Basic
Public Overrides Function GetBoundingBox ( _
    xform As Transform _
) As BoundingBox

Parameters

xform
Type: Transform

See Also

GH_Circle Class
Grasshopper.Kernel.Types Namespace


LoadGeometry Method

[image] [image]

Grasshopper SDK
GH_Circle..::..LoadGeometry Method
GH_Circle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LoadGeometry()()()() | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | LoadGeometry(RhinoDoc) | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. The default is to always return True. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)

See Also

GH_Circle Class
GH_Circle Members
Grasshopper.Kernel.Types Namespace


Morph Method

[image]

Grasshopper SDK
GH_Circle..::..Morph Method
GH_Circle Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GeometricGoo Morph(
    SpaceMorph xmorph
)
Visual Basic
Public Overrides Function Morph ( _
    xmorph As SpaceMorph _
) As IGH_GeometricGoo

Parameters

xmorph
Type: SpaceMorph

See Also

GH_Circle Class
Grasshopper.Kernel.Types Namespace


Read Method

[image]

Grasshopper SDK
GH_Circle..::..Read Method
GH_Circle Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

See Also

GH_Circle Class
Grasshopper.Kernel.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_Circle..::..ToString Method
GH_Circle Class See Also Send Feedback
Format the circle using default grasshopper formatting logic.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_Circle Class
Grasshopper.Kernel.Types Namespace


Transform Method

[image]

Grasshopper SDK
GH_Circle..::..Transform Method
GH_Circle Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GeometricGoo Transform(
    Transform xform
)
Visual Basic
Public Overrides Function Transform ( _
    xform As Transform _
) As IGH_GeometricGoo

Parameters

xform
Type: Transform

See Also

GH_Circle Class
Grasshopper.Kernel.Types Namespace


Write Method

[image]

Grasshopper SDK
GH_Circle..::..Write Method
GH_Circle Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overrides Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

See Also

GH_Circle Class
Grasshopper.Kernel.Types Namespace


GH_Circle Properties

[image] [image]

Grasshopper SDK
GH_Circle Properties
GH_Circle Class See Also Send Feedback

The GH_Circle type exposes the following members.

Properties

 | Name | Description
Public property | Boundingbox | Gets the boundingbox for this geometry. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Boundingbox.)
Public property | ClippingBox |
Public property | IsGeometryLoaded | Gets a value indicating whether or not this geometry is currently loaded (assuming it is referenced). Not all IGH_GeometricGoo implementations support referenced geometry. The default is to always return True. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public property | IsReferencedGeometry | Gets a value indicating whether or not this geometry is referenced. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public property | IsValid | Gets the validity of this instance. Circles are valid when their base planes are valid and when the radius is larger than zero. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot.)
Public property | ReferenceID | Gets or sets the Guid of the object that is referenced. Not all IGH_GeometricGoo implementations support referenced geometry. The default implementation is to always return Guid.Empty. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the value of this type. Note that if the type has a ReferenceID this value might get destroyed in the future. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)

See Also

GH_Circle Class
Grasshopper.Kernel.Types Namespace


Boundingbox Property

[image]

Grasshopper SDK
GH_Circle..::..Boundingbox Property
GH_Circle Class See Also Send Feedback
Gets the boundingbox for this geometry.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override BoundingBox Boundingbox { get; }
Visual Basic
Public Overrides ReadOnly Property Boundingbox As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Circle.Boundingbox"]

Return Value

The boundingbox for this piece of geometry or Boundingbox.Empty if the geometry is null or invalid.

See Also

GH_Circle Class
Grasshopper.Kernel.Types Namespace


ClippingBox Property

[image]

Grasshopper SDK
GH_Circle..::..ClippingBox Property
GH_Circle Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public BoundingBox ClippingBox { get; }
Visual Basic
Public ReadOnly Property ClippingBox As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Circle.ClippingBox"]

Implements

IGH_PreviewData..::..ClippingBox

See Also

GH_Circle Class
Grasshopper.Kernel.Types Namespace


IsValid Property

[image]

Grasshopper SDK
GH_Circle..::..IsValid Property
GH_Circle Class See Also Send Feedback
Gets the validity of this instance. Circles are valid when their base planes are valid and when the radius is larger than zero.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool IsValid { get; }
Visual Basic
Public Overrides ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Circle.IsValid"]

See Also

GH_Circle Class
Grasshopper.Kernel.Types Namespace


IsValidWhyNot Property

[image]

Grasshopper SDK
GH_Circle..::..IsValidWhyNot Property
GH_Circle Class See Also Send Feedback
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string IsValidWhyNot { get; }
Visual Basic
Public Overrides ReadOnly Property IsValidWhyNot As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Circle.IsValidWhyNot"]

See Also

GH_Circle Class
Grasshopper.Kernel.Types Namespace


TypeDescription Property

[image]

Grasshopper SDK
GH_Circle..::..TypeDescription Property
GH_Circle Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeDescription { get; }
Visual Basic
Public Overrides ReadOnly Property TypeDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Circle.TypeDescription"]

See Also

GH_Circle Class
Grasshopper.Kernel.Types Namespace


TypeName Property

[image]

Grasshopper SDK
GH_Circle..::..TypeName Property
GH_Circle Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeName { get; }
Visual Basic
Public Overrides ReadOnly Property TypeName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Circle.TypeName"]

See Also

GH_Circle Class
Grasshopper.Kernel.Types Namespace


GH_Circle.GH_CircleProxy Class

[image]

Grasshopper SDK
GH_Circle..::..GH_CircleProxy Class
GH_Circle Class Members See Also Send Feedback
Proxy description of GH_Circle class. This class is used by the Generic Multivalue interfaces.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_CircleProxy : GH_GooProxy<GH_Circle>
Visual Basic
Public Class GH_CircleProxy _
    Inherits GH_GooProxy(Of GH_Circle)

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_GooProxy <(Of <(<' GH_Circle >)>)>
Grasshopper.Kernel.Types..::..GH_Circle..::..GH_CircleProxy

See Also

GH_Circle..::..GH_CircleProxy Members
Grasshopper.Kernel.Types Namespace


GH_Circle.GH_CircleProxy Members

[image] [image]

Grasshopper SDK
GH_Circle..::..GH_CircleProxy Members
GH_Circle..::..GH_CircleProxy Class Constructors Methods Properties See Also Send Feedback

Represents a 3D circle. GH_Circle re-implements the OpenNURBS OnCircle class.

The GH_Circle..::..GH_CircleProxy type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Circle..::..GH_CircleProxy | Initializes a new instance of the GH_Circle..::..GH_CircleProxy class

Methods

 | Name | Description
Public method | Construct | (Overrides GH_GooProxy<(Of <(<'T>)>)>..::..Construct()()()().)
Public method | FormatInstance | Returns a String description of the current value. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FromString | If IsParsable(), then attempts to convert the string to a generic type value (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | MutateString | Munge a string to remove obvious errors on account of the user. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | NumberToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | StringToNumber | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | ToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Area |
Public property | Center |
Public property | Circumference |
Public property | IsParsable | Gets a value indicating whether or not the type can be instantiated from a String. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Normal |
Protected property | Owner | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | ProxyOwner | Gets the piece of Grasshopper data that spawned this proxy. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Radius |
Public property | TypeDescription | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeName | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | UserString | Gets or sets the user-defined string that describes this proxy. This only really makes sense if the Proxy is Parsable. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Valid | Gets a value indicating whether this proxy represents valid data. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

See Also

GH_Circle..::..GH_CircleProxy Class
Grasshopper.Kernel.Types Namespace


GH_Circle.GH_CircleProxy Constructor

[image]

Grasshopper SDK
GH_Circle..::..GH_CircleProxy Constructor
GH_Circle..::..GH_CircleProxy Class See Also Send Feedback
Initializes a new instance of the GH_Circle..::..GH_CircleProxy class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_CircleProxy(
    GH_Circle nOwner
)
Visual Basic
Public Sub New ( _
    nOwner As GH_Circle _
)

Parameters

nOwner
Type: Grasshopper.Kernel.Types..::..GH_Circle

See Also

GH_Circle..::..GH_CircleProxy Class
Grasshopper.Kernel.Types Namespace


GH_Circle.GH_CircleProxy Methods

[image] [image]

Grasshopper SDK
GH_Circle..::..GH_CircleProxy Methods
GH_Circle..::..GH_CircleProxy Class See Also Send Feedback

The GH_Circle..::..GH_CircleProxy type exposes the following members.

Methods

 | Name | Description
Public method | Construct | (Overrides GH_GooProxy<(Of <(<'T>)>)>..::..Construct()()()().)
Public method | FormatInstance | Returns a String description of the current value. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FromString | If IsParsable(), then attempts to convert the string to a generic type value (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | MutateString | Munge a string to remove obvious errors on account of the user. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | NumberToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | StringToNumber | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | ToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

See Also

GH_Circle..::..GH_CircleProxy Class
Grasshopper.Kernel.Types Namespace


Construct Method

[image]

Grasshopper SDK
GH_Circle..::..GH_CircleProxy..::..Construct Method
GH_Circle..::..GH_CircleProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void Construct()
Visual Basic
Public Overrides Sub Construct

See Also

GH_Circle..::..GH_CircleProxy Class
Grasshopper.Kernel.Types Namespace


GH_Circle.GH_CircleProxy Properties

[image] [image]

Grasshopper SDK
GH_Circle..::..GH_CircleProxy Properties
GH_Circle..::..GH_CircleProxy Class See Also Send Feedback

The GH_Circle..::..GH_CircleProxy type exposes the following members.

Properties

 | Name | Description
Public property | Area |
Public property | Center |
Public property | Circumference |
Public property | IsParsable | Gets a value indicating whether or not the type can be instantiated from a String. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Normal |
Protected property | Owner | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | ProxyOwner | Gets the piece of Grasshopper data that spawned this proxy. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Radius |
Public property | TypeDescription | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeName | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | UserString | Gets or sets the user-defined string that describes this proxy. This only really makes sense if the Proxy is Parsable. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Valid | Gets a value indicating whether this proxy represents valid data. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

See Also

GH_Circle..::..GH_CircleProxy Class
Grasshopper.Kernel.Types Namespace


Area Property

[image]

Grasshopper SDK
GH_Circle..::..GH_CircleProxy..::..Area Property
GH_Circle..::..GH_CircleProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Area { get; set; }
Visual Basic
Public Property Area As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Circle.GH_CircleProxy.Area"]

See Also

GH_Circle..::..GH_CircleProxy Class
Grasshopper.Kernel.Types Namespace


Center Property

[image]

Grasshopper SDK
GH_Circle..::..GH_CircleProxy..::..Center Property
GH_Circle..::..GH_CircleProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Point3d_Wrapper Center { get; }
Visual Basic
Public ReadOnly Property Center As GH_Point3d_Wrapper
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Circle.GH_CircleProxy.Center"]

See Also

GH_Circle..::..GH_CircleProxy Class
Grasshopper.Kernel.Types Namespace


Circumference Property

[image]

Grasshopper SDK
GH_Circle..::..GH_CircleProxy..::..Circumference Property
GH_Circle..::..GH_CircleProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Circumference { get; set; }
Visual Basic
Public Property Circumference As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Circle.GH_CircleProxy.Circumference"]

See Also

GH_Circle..::..GH_CircleProxy Class
Grasshopper.Kernel.Types Namespace


Normal Property

[image]

Grasshopper SDK
GH_Circle..::..GH_CircleProxy..::..Normal Property
GH_Circle..::..GH_CircleProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Vector3d_Wrapper Normal { get; }
Visual Basic
Public ReadOnly Property Normal As GH_Vector3d_Wrapper
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Circle.GH_CircleProxy.Normal"]

See Also

GH_Circle..::..GH_CircleProxy Class
Grasshopper.Kernel.Types Namespace


Radius Property

[image]

Grasshopper SDK
GH_Circle..::..GH_CircleProxy..::..Radius Property
GH_Circle..::..GH_CircleProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Radius { get; set; }
Visual Basic
Public Property Radius As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Circle.GH_CircleProxy.Radius"]

See Also

GH_Circle..::..GH_CircleProxy Class
Grasshopper.Kernel.Types Namespace


GH_Colour Class

[image]

Grasshopper SDK
GH_Colour Class
Members See Also Send Feedback
Represents an ARGB colour. GH_Colour re-implements the framework System.Drawing.Color type.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Colour : GH_Goo<Color>,
    IGH_QuickCast
Visual Basic
Public Class GH_Colour _
    Inherits GH_Goo(Of Color) _
    Implements IGH_QuickCast

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_Goo <(Of <(<' Color >)>)>
Grasshopper.Kernel.Types..::..GH_Colour

See Also

GH_Colour Members
Grasshopper.Kernel.Types Namespace


GH_Colour Members

[image] [image]

Grasshopper SDK
GH_Colour Members
GH_Colour Class Constructors Methods Fields Properties See Also Send Feedback

The GH_Colour type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Colour()()()() | Blank constructor
Public method | GH_Colour(Color) | Initializes a new instance of the GH_Colour class
Public method | GH_Colour(GH_Colour) | Initializes a new instance of the GH_Colour class

Methods

 | Name | Description
Public method | CastFrom | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | Duplicate | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateColour |
Public method | EmitProxy | (Overrides GH_Goo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ToString | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | IsValid | Gets the validity of this instance. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the internal data. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Colour Class
Grasshopper.Kernel.Types Namespace


GH_Colour Constructor

[image] [image]

Grasshopper SDK
GH_Colour Constructor
GH_Colour Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Colour()()()() | Blank constructor
Public method | GH_Colour(Color) | Initializes a new instance of the GH_Colour class
Public method | GH_Colour(GH_Colour) | Initializes a new instance of the GH_Colour class

See Also

GH_Colour Class
GH_Colour Members
Grasshopper.Kernel.Types Namespace


GH_Colour Constructor

[image]

Grasshopper SDK
GH_Colour Constructor
GH_Colour Class See Also Send Feedback
Blank constructor

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Colour()
Visual Basic
Public Sub New

See Also

GH_Colour Class
GH_Colour Overload
Grasshopper.Kernel.Types Namespace


GH_Colour Constructor (Color)

[image]

Grasshopper SDK
GH_Colour Constructor (Color)
GH_Colour Class See Also Send Feedback
Initializes a new instance of the GH_Colour class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Colour(
    Color colour
)
Visual Basic
Public Sub New ( _
    colour As Color _
)

Parameters

colour
Type: System.Drawing..::..Color

See Also

GH_Colour Class
GH_Colour Overload
Grasshopper.Kernel.Types Namespace


GH_Colour Constructor (GH_Colour)

[image]

Grasshopper SDK
GH_Colour Constructor (GH_Colour)
GH_Colour Class See Also Send Feedback
Initializes a new instance of the GH_Colour class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Colour(
    GH_Colour other
)
Visual Basic
Public Sub New ( _
    other As GH_Colour _
)

Parameters

other
Type: Grasshopper.Kernel.Types..::..GH_Colour

See Also

GH_Colour Class
GH_Colour Overload
Grasshopper.Kernel.Types Namespace


GH_Colour Fields

[image] [image]

Grasshopper SDK
GH_Colour Fields
GH_Colour Class See Also Send Feedback

The GH_Colour type exposes the following members.

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Colour Class
Grasshopper.Kernel.Types Namespace


GH_Colour Methods

[image] [image]

Grasshopper SDK
GH_Colour Methods
GH_Colour Class See Also Send Feedback

The GH_Colour type exposes the following members.

Methods

 | Name | Description
Public method | CastFrom | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | Duplicate | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateColour |
Public method | EmitProxy | (Overrides GH_Goo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ToString | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

See Also

GH_Colour Class
Grasshopper.Kernel.Types Namespace


CastFrom Method

[image]

Grasshopper SDK
GH_Colour..::..CastFrom Method
GH_Colour Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastFrom(
    Object source
)
Visual Basic
Public Overrides Function CastFrom ( _
    source As Object _
) As Boolean

Parameters

source
Type: System..::..Object

See Also

GH_Colour Class
Grasshopper.Kernel.Types Namespace


CastTo Method

[image] [image]

Grasshopper SDK
GH_Colour..::..CastTo Method
GH_Colour Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Colour Class
GH_Colour Members
Grasshopper.Kernel.Types Namespace


CastTo(T) Method (T)

[image]

Grasshopper SDK
GH_Colour..::..CastTo<(Of <(<'T>)>)> Method (T%)
GH_Colour Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastTo<T>(
    out T target
)
Visual Basic
Public Overrides Function CastTo(Of T) ( _
    <OutAttribute> ByRef target As T _
) As Boolean

Parameters

target
Type: T%

Type Parameters

T

See Also

GH_Colour Class
CastTo Overload
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_Colour..::..Duplicate Method
GH_Colour Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_Goo Duplicate()
Visual Basic
Public Overrides Function Duplicate As IGH_Goo

See Also

GH_Colour Class
Grasshopper.Kernel.Types Namespace


DuplicateColour Method

[image]

Grasshopper SDK
GH_Colour..::..DuplicateColour Method
GH_Colour Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Colour DuplicateColour()
Visual Basic
Public Function DuplicateColour As GH_Colour

See Also

GH_Colour Class
Grasshopper.Kernel.Types Namespace


EmitProxy Method

[image]

Grasshopper SDK
GH_Colour..::..EmitProxy Method
GH_Colour Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GooProxy EmitProxy()
Visual Basic
Public Overrides Function EmitProxy As IGH_GooProxy

See Also

GH_Colour Class
Grasshopper.Kernel.Types Namespace


Read Method

[image]

Grasshopper SDK
GH_Colour..::..Read Method
GH_Colour Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

See Also

GH_Colour Class
Grasshopper.Kernel.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_Colour..::..ToString Method
GH_Colour Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_Colour Class
Grasshopper.Kernel.Types Namespace


Write Method

[image]

Grasshopper SDK
GH_Colour..::..Write Method
GH_Colour Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overrides Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

See Also

GH_Colour Class
Grasshopper.Kernel.Types Namespace


GH_Colour Properties

[image] [image]

Grasshopper SDK
GH_Colour Properties
GH_Colour Class See Also Send Feedback

The GH_Colour type exposes the following members.

Properties

 | Name | Description
Public property | IsValid | Gets the validity of this instance. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the internal data. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Colour Class
Grasshopper.Kernel.Types Namespace


IsValid Property

[image]

Grasshopper SDK
GH_Colour..::..IsValid Property
GH_Colour Class See Also Send Feedback
Gets the validity of this instance.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool IsValid { get; }
Visual Basic
Public Overrides ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Colour.IsValid"]

See Also

GH_Colour Class
Grasshopper.Kernel.Types Namespace


IsValidWhyNot Property

[image]

Grasshopper SDK
GH_Colour..::..IsValidWhyNot Property
GH_Colour Class See Also Send Feedback
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string IsValidWhyNot { get; }
Visual Basic
Public Overrides ReadOnly Property IsValidWhyNot As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Colour.IsValidWhyNot"]

See Also

GH_Colour Class
Grasshopper.Kernel.Types Namespace


TypeDescription Property

[image]

Grasshopper SDK
GH_Colour..::..TypeDescription Property
GH_Colour Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeDescription { get; }
Visual Basic
Public Overrides ReadOnly Property TypeDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Colour.TypeDescription"]

See Also

GH_Colour Class
Grasshopper.Kernel.Types Namespace


TypeName Property

[image]

Grasshopper SDK
GH_Colour..::..TypeName Property
GH_Colour Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeName { get; }
Visual Basic
Public Overrides ReadOnly Property TypeName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Colour.TypeName"]

See Also

GH_Colour Class
Grasshopper.Kernel.Types Namespace


GH_ComplexNumber Class

[image]

Grasshopper SDK
GH_ComplexNumber Class
Members See Also Send Feedback
Wraps up the Complex data type for IGH_Goo adherence.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_ComplexNumber : GH_Goo<Complex>,
    IGH_QuickCast
Visual Basic
Public Class GH_ComplexNumber _
    Inherits GH_Goo(Of Complex) _
    Implements IGH_QuickCast

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_Goo <(Of <(<' Complex >)>)>
Grasshopper.Kernel.Types..::..GH_ComplexNumber

See Also

GH_ComplexNumber Members
Grasshopper.Kernel.Types Namespace


GH_ComplexNumber Members

[image] [image]

Grasshopper SDK
GH_ComplexNumber Members
GH_ComplexNumber Class Constructors Methods Fields Properties See Also Send Feedback

The GH_ComplexNumber type exposes the following members.

Constructors

 | Name | Description
Public method | GH_ComplexNumber()()()() | Blank constructor
Public method | GH_ComplexNumber(Complex) | Initializes a new instance of the GH_ComplexNumber class
Public method | GH_ComplexNumber(GH_ComplexNumber) | Initializes a new instance of the GH_ComplexNumber class

Methods

 | Name | Description
Public method | CastFrom | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | Duplicate | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateComplex |
Public method | EmitProxy | (Overrides GH_Goo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ToString | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | IsValid | Gets the validity of this instance. If either the real or the imaginary component are NaN, then it is considered invalid (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the internal data. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_ComplexNumber Class
Grasshopper.Kernel.Types Namespace


GH_ComplexNumber Constructor

[image] [image]

Grasshopper SDK
GH_ComplexNumber Constructor
GH_ComplexNumber Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_ComplexNumber()()()() | Blank constructor
Public method | GH_ComplexNumber(Complex) | Initializes a new instance of the GH_ComplexNumber class
Public method | GH_ComplexNumber(GH_ComplexNumber) | Initializes a new instance of the GH_ComplexNumber class

See Also

GH_ComplexNumber Class
GH_ComplexNumber Members
Grasshopper.Kernel.Types Namespace


GH_ComplexNumber Constructor

[image]

Grasshopper SDK
GH_ComplexNumber Constructor
GH_ComplexNumber Class See Also Send Feedback
Blank constructor

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ComplexNumber()
Visual Basic
Public Sub New

See Also

GH_ComplexNumber Class
GH_ComplexNumber Overload
Grasshopper.Kernel.Types Namespace


GH_ComplexNumber Constructor (Complex)

[image]

Grasshopper SDK
GH_ComplexNumber Constructor (Complex)
GH_ComplexNumber Class See Also Send Feedback
Initializes a new instance of the GH_ComplexNumber class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ComplexNumber(
    Complex number
)
Visual Basic
Public Sub New ( _
    number As Complex _
)

Parameters

number
Type: Grasshopper.Kernel.Types..::..Complex

See Also

GH_ComplexNumber Class
GH_ComplexNumber Overload
Grasshopper.Kernel.Types Namespace


GH_ComplexNumber Constructor (GH_ComplexNumber)

[image]

Grasshopper SDK
GH_ComplexNumber Constructor (GH_ComplexNumber)
GH_ComplexNumber Class See Also Send Feedback
Initializes a new instance of the GH_ComplexNumber class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ComplexNumber(
    GH_ComplexNumber other
)
Visual Basic
Public Sub New ( _
    other As GH_ComplexNumber _
)

Parameters

other
Type: Grasshopper.Kernel.Types..::..GH_ComplexNumber

See Also

GH_ComplexNumber Class
GH_ComplexNumber Overload
Grasshopper.Kernel.Types Namespace


GH_ComplexNumber Fields

[image] [image]

Grasshopper SDK
GH_ComplexNumber Fields
GH_ComplexNumber Class See Also Send Feedback

The GH_ComplexNumber type exposes the following members.

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_ComplexNumber Class
Grasshopper.Kernel.Types Namespace


GH_ComplexNumber Methods

[image] [image]

Grasshopper SDK
GH_ComplexNumber Methods
GH_ComplexNumber Class See Also Send Feedback

The GH_ComplexNumber type exposes the following members.

Methods

 | Name | Description
Public method | CastFrom | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | Duplicate | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateComplex |
Public method | EmitProxy | (Overrides GH_Goo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ToString | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

See Also

GH_ComplexNumber Class
Grasshopper.Kernel.Types Namespace


CastFrom Method

[image]

Grasshopper SDK
GH_ComplexNumber..::..CastFrom Method
GH_ComplexNumber Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastFrom(
    Object source
)
Visual Basic
Public Overrides Function CastFrom ( _
    source As Object _
) As Boolean

Parameters

source
Type: System..::..Object

See Also

GH_ComplexNumber Class
Grasshopper.Kernel.Types Namespace


CastTo Method

[image] [image]

Grasshopper SDK
GH_ComplexNumber..::..CastTo Method
GH_ComplexNumber Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_ComplexNumber Class
GH_ComplexNumber Members
Grasshopper.Kernel.Types Namespace


CastTo(T) Method (T)

[image]

Grasshopper SDK
GH_ComplexNumber..::..CastTo<(Of <(<'T>)>)> Method (T%)
GH_ComplexNumber Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastTo<T>(
    out T target
)
Visual Basic
Public Overrides Function CastTo(Of T) ( _
    <OutAttribute> ByRef target As T _
) As Boolean

Parameters

target
Type: T%

Type Parameters

T

See Also

GH_ComplexNumber Class
CastTo Overload
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_ComplexNumber..::..Duplicate Method
GH_ComplexNumber Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_Goo Duplicate()
Visual Basic
Public Overrides Function Duplicate As IGH_Goo

See Also

GH_ComplexNumber Class
Grasshopper.Kernel.Types Namespace


DuplicateComplex Method

[image]

Grasshopper SDK
GH_ComplexNumber..::..DuplicateComplex Method
GH_ComplexNumber Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ComplexNumber DuplicateComplex()
Visual Basic
Public Function DuplicateComplex As GH_ComplexNumber

See Also

GH_ComplexNumber Class
Grasshopper.Kernel.Types Namespace


EmitProxy Method

[image]

Grasshopper SDK
GH_ComplexNumber..::..EmitProxy Method
GH_ComplexNumber Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GooProxy EmitProxy()
Visual Basic
Public Overrides Function EmitProxy As IGH_GooProxy

See Also

GH_ComplexNumber Class
Grasshopper.Kernel.Types Namespace


Read Method

[image]

Grasshopper SDK
GH_ComplexNumber..::..Read Method
GH_ComplexNumber Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

See Also

GH_ComplexNumber Class
Grasshopper.Kernel.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_ComplexNumber..::..ToString Method
GH_ComplexNumber Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_ComplexNumber Class
Grasshopper.Kernel.Types Namespace


Write Method

[image]

Grasshopper SDK
GH_ComplexNumber..::..Write Method
GH_ComplexNumber Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overrides Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

See Also

GH_ComplexNumber Class
Grasshopper.Kernel.Types Namespace


GH_ComplexNumber Properties

[image] [image]

Grasshopper SDK
GH_ComplexNumber Properties
GH_ComplexNumber Class See Also Send Feedback

The GH_ComplexNumber type exposes the following members.

Properties

 | Name | Description
Public property | IsValid | Gets the validity of this instance. If either the real or the imaginary component are NaN, then it is considered invalid (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the internal data. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_ComplexNumber Class
Grasshopper.Kernel.Types Namespace


IsValid Property

[image]

Grasshopper SDK
GH_ComplexNumber..::..IsValid Property
GH_ComplexNumber Class See Also Send Feedback
Gets the validity of this instance. If either the real or the imaginary component are NaN, then it is considered invalid

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool IsValid { get; }
Visual Basic
Public Overrides ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_ComplexNumber.IsValid"]

See Also

GH_ComplexNumber Class
Grasshopper.Kernel.Types Namespace


IsValidWhyNot Property

[image]

Grasshopper SDK
GH_ComplexNumber..::..IsValidWhyNot Property
GH_ComplexNumber Class See Also Send Feedback
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string IsValidWhyNot { get; }
Visual Basic
Public Overrides ReadOnly Property IsValidWhyNot As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_ComplexNumber.IsValidWhyNot"]

See Also

GH_ComplexNumber Class
Grasshopper.Kernel.Types Namespace


TypeDescription Property

[image]

Grasshopper SDK
GH_ComplexNumber..::..TypeDescription Property
GH_ComplexNumber Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeDescription { get; }
Visual Basic
Public Overrides ReadOnly Property TypeDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_ComplexNumber.TypeDescription"]

See Also

GH_ComplexNumber Class
Grasshopper.Kernel.Types Namespace


TypeName Property

[image]

Grasshopper SDK
GH_ComplexNumber..::..TypeName Property
GH_ComplexNumber Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeName { get; }
Visual Basic
Public Overrides ReadOnly Property TypeName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_ComplexNumber.TypeName"]

See Also

GH_ComplexNumber Class
Grasshopper.Kernel.Types Namespace


GH_Culture Class

[image]

Grasshopper SDK
GH_Culture Class
Members See Also Send Feedback
Represents a globally unique identifier. GH_Guid re-implements the framework System.Guid type.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Culture : GH_Goo<CultureInfo>
Visual Basic
Public Class GH_Culture _
    Inherits GH_Goo(Of CultureInfo)

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_Goo <(Of <(<' CultureInfo >)>)>
Grasshopper.Kernel.Types..::..GH_Culture

See Also

GH_Culture Members
Grasshopper.Kernel.Types Namespace


GH_Culture Members

[image] [image]

Grasshopper SDK
GH_Culture Members
GH_Culture Class Constructors Methods Fields Properties See Also Send Feedback

The GH_Culture type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Culture()()()() | Blank constructor
Public method | GH_Culture(CultureInfo) | Initializes a new instance of the GH_Culture class
Public method | GH_Culture(GH_Culture) | Initializes a new instance of the GH_Culture class

Methods

 | Name | Description
Public method | CastFrom | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | Duplicate | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateCulture |
Public method | EmitProxy | (Overrides GH_Goo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ScriptVariable()()()().)
Public method | ToString | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | IsValid | Gets the validity of this instance. Guids are always valid. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the internal data. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Culture Class
Grasshopper.Kernel.Types Namespace


GH_Culture Constructor

[image] [image]

Grasshopper SDK
GH_Culture Constructor
GH_Culture Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Culture()()()() | Blank constructor
Public method | GH_Culture(CultureInfo) | Initializes a new instance of the GH_Culture class
Public method | GH_Culture(GH_Culture) | Initializes a new instance of the GH_Culture class

See Also

GH_Culture Class
GH_Culture Members
Grasshopper.Kernel.Types Namespace


GH_Culture Constructor

[image]

Grasshopper SDK
GH_Culture Constructor
GH_Culture Class See Also Send Feedback
Blank constructor

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Culture()
Visual Basic
Public Sub New

See Also

GH_Culture Class
GH_Culture Overload
Grasshopper.Kernel.Types Namespace


GH_Culture Constructor (CultureInfo)

[image]

Grasshopper SDK
GH_Culture Constructor (CultureInfo)
GH_Culture Class See Also Send Feedback
Initializes a new instance of the GH_Culture class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Culture(
    CultureInfo culture
)
Visual Basic
Public Sub New ( _
    culture As CultureInfo _
)

Parameters

culture
Type: System.Globalization..::..CultureInfo

See Also

GH_Culture Class
GH_Culture Overload
Grasshopper.Kernel.Types Namespace


GH_Culture Constructor (GH_Culture)

[image]

Grasshopper SDK
GH_Culture Constructor (GH_Culture)
GH_Culture Class See Also Send Feedback
Initializes a new instance of the GH_Culture class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Culture(
    GH_Culture other
)
Visual Basic
Public Sub New ( _
    other As GH_Culture _
)

Parameters

other
Type: Grasshopper.Kernel.Types..::..GH_Culture

See Also

GH_Culture Class
GH_Culture Overload
Grasshopper.Kernel.Types Namespace


GH_Culture Fields

[image] [image]

Grasshopper SDK
GH_Culture Fields
GH_Culture Class See Also Send Feedback

The GH_Culture type exposes the following members.

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Culture Class
Grasshopper.Kernel.Types Namespace


GH_Culture Methods

[image] [image]

Grasshopper SDK
GH_Culture Methods
GH_Culture Class See Also Send Feedback

The GH_Culture type exposes the following members.

Methods

 | Name | Description
Public method | CastFrom | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | Duplicate | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateCulture |
Public method | EmitProxy | (Overrides GH_Goo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ScriptVariable()()()().)
Public method | ToString | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

See Also

GH_Culture Class
Grasshopper.Kernel.Types Namespace


CastFrom Method

[image]

Grasshopper SDK
GH_Culture..::..CastFrom Method
GH_Culture Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastFrom(
    Object source
)
Visual Basic
Public Overrides Function CastFrom ( _
    source As Object _
) As Boolean

Parameters

source
Type: System..::..Object

See Also

GH_Culture Class
Grasshopper.Kernel.Types Namespace


CastTo Method

[image] [image]

Grasshopper SDK
GH_Culture..::..CastTo Method
GH_Culture Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Culture Class
GH_Culture Members
Grasshopper.Kernel.Types Namespace


CastTo(T) Method (T)

[image]

Grasshopper SDK
GH_Culture..::..CastTo<(Of <(<'T>)>)> Method (T%)
GH_Culture Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastTo<T>(
    out T target
)
Visual Basic
Public Overrides Function CastTo(Of T) ( _
    <OutAttribute> ByRef target As T _
) As Boolean

Parameters

target
Type: T%

Type Parameters

T

See Also

GH_Culture Class
CastTo Overload
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_Culture..::..Duplicate Method
GH_Culture Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_Goo Duplicate()
Visual Basic
Public Overrides Function Duplicate As IGH_Goo

See Also

GH_Culture Class
Grasshopper.Kernel.Types Namespace


DuplicateCulture Method

[image]

Grasshopper SDK
GH_Culture..::..DuplicateCulture Method
GH_Culture Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Culture DuplicateCulture()
Visual Basic
Public Function DuplicateCulture As GH_Culture

See Also

GH_Culture Class
Grasshopper.Kernel.Types Namespace


EmitProxy Method

[image]

Grasshopper SDK
GH_Culture..::..EmitProxy Method
GH_Culture Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GooProxy EmitProxy()
Visual Basic
Public Overrides Function EmitProxy As IGH_GooProxy

See Also

GH_Culture Class
Grasshopper.Kernel.Types Namespace


Read Method

[image]

Grasshopper SDK
GH_Culture..::..Read Method
GH_Culture Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

See Also

GH_Culture Class
Grasshopper.Kernel.Types Namespace


ScriptVariable Method

[image]

Grasshopper SDK
GH_Culture..::..ScriptVariable Method
GH_Culture Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override Object ScriptVariable()
Visual Basic
Public Overrides Function ScriptVariable As Object

See Also

GH_Culture Class
Grasshopper.Kernel.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_Culture..::..ToString Method
GH_Culture Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_Culture Class
Grasshopper.Kernel.Types Namespace


Write Method

[image]

Grasshopper SDK
GH_Culture..::..Write Method
GH_Culture Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overrides Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

See Also

GH_Culture Class
Grasshopper.Kernel.Types Namespace


GH_Culture Properties

[image] [image]

Grasshopper SDK
GH_Culture Properties
GH_Culture Class See Also Send Feedback

The GH_Culture type exposes the following members.

Properties

 | Name | Description
Public property | IsValid | Gets the validity of this instance. Guids are always valid. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the internal data. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Culture Class
Grasshopper.Kernel.Types Namespace


IsValid Property

[image]

Grasshopper SDK
GH_Culture..::..IsValid Property
GH_Culture Class See Also Send Feedback
Gets the validity of this instance. Guids are always valid.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool IsValid { get; }
Visual Basic
Public Overrides ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Culture.IsValid"]

See Also

GH_Culture Class
Grasshopper.Kernel.Types Namespace


TypeDescription Property

[image]

Grasshopper SDK
GH_Culture..::..TypeDescription Property
GH_Culture Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeDescription { get; }
Visual Basic
Public Overrides ReadOnly Property TypeDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Culture.TypeDescription"]

See Also

GH_Culture Class
Grasshopper.Kernel.Types Namespace


TypeName Property

[image]

Grasshopper SDK
GH_Culture..::..TypeName Property
GH_Culture Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeName { get; }
Visual Basic
Public Overrides ReadOnly Property TypeName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Culture.TypeName"]

See Also

GH_Culture Class
Grasshopper.Kernel.Types Namespace


GH_Curve Class

[image]

Grasshopper SDK
GH_Curve Class
Members See Also Send Feedback
Represents a 3D spline curve.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Curve : GH_GeometricGoo<Curve>,
    IGH_BakeAwareData, IGH_PreviewData
Visual Basic
Public Class GH_Curve _
    Inherits GH_GeometricGoo(Of Curve) _
    Implements IGH_BakeAwareData, IGH_PreviewData

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_Goo <(Of <(<'Curve>)>)>
Grasshopper.Kernel.Types..::..GH_GeometricGoo <(Of <(<'Curve>)>)>
Grasshopper.Kernel.Types..::..GH_Curve

See Also

GH_Curve Members
Grasshopper.Kernel.Types Namespace


GH_Curve Members

[image] [image]

Grasshopper SDK
GH_Curve Members
GH_Curve Class Constructors Methods Fields Properties See Also Send Feedback

The GH_Curve type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Curve()()()() | Default constructor, creates an invalid curve.
Public method | GH_Curve(Curve) | Create a duplicate of an existing curve.
Public method | GH_Curve(Guid) | Create a new referenced curve that references a Rhino curve object with the specified ID.
Public method | GH_Curve(GH_Curve) | Create a duplicate of another GH_Curve. This constructor also copies reference data.
Public method | GH_Curve(Guid, Int32) | Create a new references edge curve that references an edge index in a Rhino Brep object.

Methods

 | Name | Description
Public method | BakeGeometry |
Public method | CastFrom | Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(T>)>>)(T%) | Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type T. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ClearCaches | Clears all volatile caches for this instance. The boundingbox is cleared, and if the curve is referenced, the local instance of the curve is erased. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..ClearCaches()()()().)
Public method | DrawViewportMeshes |
Public method | DrawViewportWires |
Public method | Duplicate | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateCurve | Create a duplicate of this curve.
Public method | DuplicateGeometry | Create a duplicate of this curve. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..DuplicateGeometry()()()().)
Public method | EmitProxy | Returns a proxy that represents this curve. Do not call this function unless you're (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | GetBoundingBox | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..GetBoundingBox(Transform).)
Public method | LoadGeometry()()()() | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | LoadGeometry(RhinoDoc) | If the curve is referenced and not yet loaded, attempts to load the curve. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..LoadGeometry(RhinoDoc).)
Public method | MakeDeformable | Converts the local geometry into deformable nurbs curve geometry. This method will not destroy Reference data.
Public method | Morph | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Morph(SpaceMorph).)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ScriptVariable()()()().)
Public method | ToString | Format the curve using default grasshopper formatting logic. (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Transform | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Transform(Transform).)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Boundingbox | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Boundingbox.)
Public property | ClippingBox |
Public property | IsGeometryLoaded | Gets the load state of this curve object. The curve is considered to be loaded when the local OnCurve instance is not null. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..IsGeometryLoaded.)
Public property | IsReferencedGeometry | Gets a value indicating whether or not this geometry is referenced. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public property | IsValid | Gets the validity of this curve. If the curve is referenced but cannot be loaded, the curve is not valid. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot.)
Public property | ReferenceEdge | Gets or sets the edge index for a referenced curve. If the index >= 0 then an edge reference is implied.
Public property | ReferenceID | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..ReferenceID.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Value.)

See Also

GH_Curve Class
Grasshopper.Kernel.Types Namespace


GH_Curve Constructor

[image] [image]

Grasshopper SDK
GH_Curve Constructor
GH_Curve Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Curve()()()() | Default constructor, creates an invalid curve.
Public method | GH_Curve(Curve) | Create a duplicate of an existing curve.
Public method | GH_Curve(Guid) | Create a new referenced curve that references a Rhino curve object with the specified ID.
Public method | GH_Curve(GH_Curve) | Create a duplicate of another GH_Curve. This constructor also copies reference data.
Public method | GH_Curve(Guid, Int32) | Create a new references edge curve that references an edge index in a Rhino Brep object.

See Also

GH_Curve Class
GH_Curve Members
Grasshopper.Kernel.Types Namespace


GH_Curve Constructor

[image]

Grasshopper SDK
GH_Curve Constructor
GH_Curve Class See Also Send Feedback
Default constructor, creates an invalid curve.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Curve()
Visual Basic
Public Sub New

See Also

GH_Curve Class
GH_Curve Overload
Grasshopper.Kernel.Types Namespace


GH_Curve Constructor ()

[image]

Grasshopper SDK
GH_Curve Constructor ()
GH_Curve Class See Also Send Feedback
Create a duplicate of an existing curve.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Curve(
    Curve curve
)
Visual Basic
Public Sub New ( _
    curve As Curve _
)

Parameters

curve
Type: Curve
Curve to duplicate

See Also

GH_Curve Class
GH_Curve Overload
Grasshopper.Kernel.Types Namespace


GH_Curve Constructor (Guid)

[image]

Grasshopper SDK
GH_Curve Constructor (Guid)
GH_Curve Class See Also Send Feedback
Create a new referenced curve that references a Rhino curve object with the specified ID.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Curve(
    Guid ref_guid
)
Visual Basic
Public Sub New ( _
    ref_guid As Guid _
)

Parameters

ref_guid
Type: System..::..Guid
ID of curve object to reference.

See Also

GH_Curve Class
GH_Curve Overload
Grasshopper.Kernel.Types Namespace


GH_Curve Constructor (GH_Curve)

[image]

Grasshopper SDK
GH_Curve Constructor (GH_Curve)
GH_Curve Class See Also Send Feedback
Create a duplicate of another GH_Curve. This constructor also copies reference data.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Curve(
    GH_Curve other
)
Visual Basic
Public Sub New ( _
    other As GH_Curve _
)

Parameters

other
Type: Grasshopper.Kernel.Types..::..GH_Curve
Curve to duplicate

See Also

GH_Curve Class
GH_Curve Overload
Grasshopper.Kernel.Types Namespace


GH_Curve Constructor (Guid, Int32)

[image]

Grasshopper SDK
GH_Curve Constructor (Guid, Int32)
GH_Curve Class See Also Send Feedback
Create a new references edge curve that references an edge index in a Rhino Brep object.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Curve(
    Guid ref_guid,
    int ref_edge
)
Visual Basic
Public Sub New ( _
    ref_guid As Guid, _
    ref_edge As Integer _
)

Parameters

ref_guid
Type: System..::..Guid
ID of Brep to reference.
ref_edge
Type: System..::..Int32
Edge index of Brep to reference.

See Also

GH_Curve Class
GH_Curve Overload
Grasshopper.Kernel.Types Namespace


GH_Curve Fields

[image] [image]

Grasshopper SDK
GH_Curve Fields
GH_Curve Class See Also Send Feedback

The GH_Curve type exposes the following members.

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Curve Class
Grasshopper.Kernel.Types Namespace


GH_Curve Methods

[image] [image]

Grasshopper SDK
GH_Curve Methods
GH_Curve Class See Also Send Feedback

The GH_Curve type exposes the following members.

Methods

 | Name | Description
Public method | BakeGeometry |
Public method | CastFrom | Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(T>)>>)(T%) | Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type T. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ClearCaches | Clears all volatile caches for this instance. The boundingbox is cleared, and if the curve is referenced, the local instance of the curve is erased. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..ClearCaches()()()().)
Public method | DrawViewportMeshes |
Public method | DrawViewportWires |
Public method | Duplicate | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateCurve | Create a duplicate of this curve.
Public method | DuplicateGeometry | Create a duplicate of this curve. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..DuplicateGeometry()()()().)
Public method | EmitProxy | Returns a proxy that represents this curve. Do not call this function unless you're (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | GetBoundingBox | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..GetBoundingBox(Transform).)
Public method | LoadGeometry()()()() | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | LoadGeometry(RhinoDoc) | If the curve is referenced and not yet loaded, attempts to load the curve. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..LoadGeometry(RhinoDoc).)
Public method | MakeDeformable | Converts the local geometry into deformable nurbs curve geometry. This method will not destroy Reference data.
Public method | Morph | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Morph(SpaceMorph).)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ScriptVariable()()()().)
Public method | ToString | Format the curve using default grasshopper formatting logic. (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Transform | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Transform(Transform).)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

See Also

GH_Curve Class
Grasshopper.Kernel.Types Namespace


BakeGeometry Method

[image]

Grasshopper SDK
GH_Curve..::..BakeGeometry Method
GH_Curve Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool BakeGeometry(
    RhinoDoc doc,
    ObjectAttributes att,
    ref Guid obj_guid
)
Visual Basic
Public Function BakeGeometry ( _
    doc As RhinoDoc, _
    att As ObjectAttributes, _
    ByRef obj_guid As Guid _
) As Boolean

Parameters

doc
Type: RhinoDoc
att
Type: ObjectAttributes
obj_guid
Type: System..::..Guid %

Implements

IGH_BakeAwareData..::..BakeGeometry(RhinoDoc, ObjectAttributes, Guid%)

See Also

GH_Curve Class
Grasshopper.Kernel.Types Namespace


CastFrom Method

[image]

Grasshopper SDK
GH_Curve..::..CastFrom Method
GH_Curve Class See Also Send Feedback
Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastFrom(
    Object source
)
Visual Basic
Public Overrides Function CastFrom ( _
    source As Object _
) As Boolean

Parameters

source
Type: System..::..Object

See Also

GH_Curve Class
Grasshopper.Kernel.Types Namespace


CastTo Method

[image] [image]

Grasshopper SDK
GH_Curve..::..CastTo Method
GH_Curve Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CastTo<(Of <<'(T>)>>)(T%) | Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type T. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Curve Class
GH_Curve Members
Grasshopper.Kernel.Types Namespace


CastTo(T) Method (T)

[image]

Grasshopper SDK
GH_Curve..::..CastTo<(Of <(<'T>)>)> Method (T%)
GH_Curve Class See Also Send Feedback
Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastTo<T>(
    out T target
)
Visual Basic
Public Overrides Function CastTo(Of T) ( _
    <OutAttribute> ByRef target As T _
) As Boolean

Parameters

target
Type: T%

Type Parameters

T

See Also

GH_Curve Class
CastTo Overload
Grasshopper.Kernel.Types Namespace


ClearCaches Method

[image]

Grasshopper SDK
GH_Curve..::..ClearCaches Method
GH_Curve Class See Also Send Feedback
Clears all volatile caches for this instance. The boundingbox is cleared, and if the curve is referenced, the local instance of the curve is erased.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void ClearCaches()
Visual Basic
Public Overrides Sub ClearCaches

See Also

GH_Curve Class
Grasshopper.Kernel.Types Namespace


DrawViewportMeshes Method

[image]

Grasshopper SDK
GH_Curve..::..DrawViewportMeshes Method
GH_Curve Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DrawViewportMeshes(
    GH_PreviewMeshArgs args
)
Visual Basic
Public Sub DrawViewportMeshes ( _
    args As GH_PreviewMeshArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..GH_PreviewMeshArgs

Implements

IGH_PreviewData..::..DrawViewportMeshes(GH_PreviewMeshArgs)

See Also

GH_Curve Class
Grasshopper.Kernel.Types Namespace


DrawViewportWires Method

[image]

Grasshopper SDK
GH_Curve..::..DrawViewportWires Method
GH_Curve Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DrawViewportWires(
    GH_PreviewWireArgs args
)
Visual Basic
Public Sub DrawViewportWires ( _
    args As GH_PreviewWireArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..GH_PreviewWireArgs

Implements

IGH_PreviewData..::..DrawViewportWires(GH_PreviewWireArgs)

See Also

GH_Curve Class
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_Curve..::..Duplicate Method
GH_Curve Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_Goo Duplicate()
Visual Basic
Public Overrides Function Duplicate As IGH_Goo

See Also

GH_Curve Class
Grasshopper.Kernel.Types Namespace


DuplicateCurve Method

[image]

Grasshopper SDK
GH_Curve..::..DuplicateCurve Method
GH_Curve Class See Also Send Feedback
Create a duplicate of this curve.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Curve DuplicateCurve()
Visual Basic
Public Function DuplicateCurve As GH_Curve

See Also

GH_Curve Class
Grasshopper.Kernel.Types Namespace


DuplicateGeometry Method

[image]

Grasshopper SDK
GH_Curve..::..DuplicateGeometry Method
GH_Curve Class See Also Send Feedback
Create a duplicate of this curve.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GeometricGoo DuplicateGeometry()
Visual Basic
Public Overrides Function DuplicateGeometry As IGH_GeometricGoo

See Also

GH_Curve Class
Grasshopper.Kernel.Types Namespace


EmitProxy Method

[image]

Grasshopper SDK
GH_Curve..::..EmitProxy Method
GH_Curve Class See Also Send Feedback
Returns a proxy that represents this curve. Do not call this function unless you're

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GooProxy EmitProxy()
Visual Basic
Public Overrides Function EmitProxy As IGH_GooProxy

See Also

GH_Curve Class
Grasshopper.Kernel.Types Namespace


GetBoundingBox Method

[image]

Grasshopper SDK
GH_Curve..::..GetBoundingBox Method
GH_Curve Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override BoundingBox GetBoundingBox(
    Transform xform
)
Visual Basic
Public Overrides Function GetBoundingBox ( _
    xform As Transform _
) As BoundingBox

Parameters

xform
Type: Transform

See Also

GH_Curve Class
Grasshopper.Kernel.Types Namespace


LoadGeometry Method

[image] [image]

Grasshopper SDK
GH_Curve..::..LoadGeometry Method
GH_Curve Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LoadGeometry()()()() | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | LoadGeometry(RhinoDoc) | If the curve is referenced and not yet loaded, attempts to load the curve. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..LoadGeometry(RhinoDoc).)

See Also

GH_Curve Class
GH_Curve Members
Grasshopper.Kernel.Types Namespace


LoadGeometry Method ()

[image]

Grasshopper SDK
GH_Curve..::..LoadGeometry Method ()
GH_Curve Class See Also Send Feedback
If the curve is referenced and not yet loaded, attempts to load the curve.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool LoadGeometry(
    RhinoDoc doc
)
Visual Basic
Public Overrides Function LoadGeometry ( _
    doc As RhinoDoc _
) As Boolean

Parameters

doc
Type: RhinoDoc

Return Value

True if the curve is loaded (or if it was already loaded), False on failure.

See Also

GH_Curve Class
LoadGeometry Overload
Grasshopper.Kernel.Types Namespace


MakeDeformable Method

[image]

Grasshopper SDK
GH_Curve..::..MakeDeformable Method
GH_Curve Class See Also Send Feedback
Converts the local geometry into deformable nurbs curve geometry. This method will not destroy Reference data.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool MakeDeformable()
Visual Basic
Public Function MakeDeformable As Boolean

See Also

GH_Curve Class
Grasshopper.Kernel.Types Namespace


Morph Method

[image]

Grasshopper SDK
GH_Curve..::..Morph Method
GH_Curve Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GeometricGoo Morph(
    SpaceMorph xmorph
)
Visual Basic
Public Overrides Function Morph ( _
    xmorph As SpaceMorph _
) As IGH_GeometricGoo

Parameters

xmorph
Type: SpaceMorph

See Also

GH_Curve Class
Grasshopper.Kernel.Types Namespace


Read Method

[image]

Grasshopper SDK
GH_Curve..::..Read Method
GH_Curve Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

See Also

GH_Curve Class
Grasshopper.Kernel.Types Namespace


ScriptVariable Method

[image]

Grasshopper SDK
GH_Curve..::..ScriptVariable Method
GH_Curve Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override Object ScriptVariable()
Visual Basic
Public Overrides Function ScriptVariable As Object

See Also

GH_Curve Class
Grasshopper.Kernel.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_Curve..::..ToString Method
GH_Curve Class See Also Send Feedback
Format the curve using default grasshopper formatting logic.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_Curve Class
Grasshopper.Kernel.Types Namespace


Transform Method

[image]

Grasshopper SDK
GH_Curve..::..Transform Method
GH_Curve Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GeometricGoo Transform(
    Transform xform
)
Visual Basic
Public Overrides Function Transform ( _
    xform As Transform _
) As IGH_GeometricGoo

Parameters

xform
Type: Transform

See Also

GH_Curve Class
Grasshopper.Kernel.Types Namespace


Write Method

[image]

Grasshopper SDK
GH_Curve..::..Write Method
GH_Curve Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overrides Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

See Also

GH_Curve Class
Grasshopper.Kernel.Types Namespace


GH_Curve Properties

[image] [image]

Grasshopper SDK
GH_Curve Properties
GH_Curve Class See Also Send Feedback

The GH_Curve type exposes the following members.

Properties

 | Name | Description
Public property | Boundingbox | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Boundingbox.)
Public property | ClippingBox |
Public property | IsGeometryLoaded | Gets the load state of this curve object. The curve is considered to be loaded when the local OnCurve instance is not null. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..IsGeometryLoaded.)
Public property | IsReferencedGeometry | Gets a value indicating whether or not this geometry is referenced. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public property | IsValid | Gets the validity of this curve. If the curve is referenced but cannot be loaded, the curve is not valid. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot.)
Public property | ReferenceEdge | Gets or sets the edge index for a referenced curve. If the index >= 0 then an edge reference is implied.
Public property | ReferenceID | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..ReferenceID.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Value.)

See Also

GH_Curve Class
Grasshopper.Kernel.Types Namespace


Boundingbox Property

[image]

Grasshopper SDK
GH_Curve..::..Boundingbox Property
GH_Curve Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override BoundingBox Boundingbox { get; }
Visual Basic
Public Overrides ReadOnly Property Boundingbox As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Curve.Boundingbox"]

See Also

GH_Curve Class
Grasshopper.Kernel.Types Namespace


ClippingBox Property

[image]

Grasshopper SDK
GH_Curve..::..ClippingBox Property
GH_Curve Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public BoundingBox ClippingBox { get; }
Visual Basic
Public ReadOnly Property ClippingBox As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Curve.ClippingBox"]

Implements

IGH_PreviewData..::..ClippingBox

See Also

GH_Curve Class
Grasshopper.Kernel.Types Namespace


IsGeometryLoaded Property

[image]

Grasshopper SDK
GH_Curve..::..IsGeometryLoaded Property
GH_Curve Class See Also Send Feedback
Gets the load state of this curve object. The curve is considered to be loaded when the local OnCurve instance is not null.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool IsGeometryLoaded { get; }
Visual Basic
Public Overrides ReadOnly Property IsGeometryLoaded As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Curve.IsGeometryLoaded"]

See Also

GH_Curve Class
Grasshopper.Kernel.Types Namespace


IsValid Property

[image]

Grasshopper SDK
GH_Curve..::..IsValid Property
GH_Curve Class See Also Send Feedback
Gets the validity of this curve. If the curve is referenced but cannot be loaded, the curve is not valid.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool IsValid { get; }
Visual Basic
Public Overrides ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Curve.IsValid"]

See Also

GH_Curve Class
Grasshopper.Kernel.Types Namespace


IsValidWhyNot Property

[image]

Grasshopper SDK
GH_Curve..::..IsValidWhyNot Property
GH_Curve Class See Also Send Feedback
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string IsValidWhyNot { get; }
Visual Basic
Public Overrides ReadOnly Property IsValidWhyNot As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Curve.IsValidWhyNot"]

See Also

GH_Curve Class
Grasshopper.Kernel.Types Namespace


ReferenceEdge Property

[image]

Grasshopper SDK
GH_Curve..::..ReferenceEdge Property
GH_Curve Class See Also Send Feedback
Gets or sets the edge index for a referenced curve. If the index >= 0 then an edge reference is implied.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int ReferenceEdge { get; set; }
Visual Basic
Public Property ReferenceEdge As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Curve.ReferenceEdge"]

Remarks

If an edge reference is implied, then the ReferenceID must point to a RhinoBrepObject.

See Also

GH_Curve Class
Grasshopper.Kernel.Types Namespace


ReferenceID Property

[image]

Grasshopper SDK
GH_Curve..::..ReferenceID Property
GH_Curve Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override Guid ReferenceID { get; set; }
Visual Basic
Public Overrides Property ReferenceID As Guid
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Curve.ReferenceID"]

See Also

GH_Curve Class
Grasshopper.Kernel.Types Namespace


TypeDescription Property

[image]

Grasshopper SDK
GH_Curve..::..TypeDescription Property
GH_Curve Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeDescription { get; }
Visual Basic
Public Overrides ReadOnly Property TypeDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Curve.TypeDescription"]

See Also

GH_Curve Class
Grasshopper.Kernel.Types Namespace


TypeName Property

[image]

Grasshopper SDK
GH_Curve..::..TypeName Property
GH_Curve Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeName { get; }
Visual Basic
Public Overrides ReadOnly Property TypeName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Curve.TypeName"]

See Also

GH_Curve Class
Grasshopper.Kernel.Types Namespace


Value Property

[image]

Grasshopper SDK
GH_Curve..::..Value Property
GH_Curve Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override Curve Value { get; set; }
Visual Basic
Public Overrides Property Value As Curve
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Curve.Value"]

See Also

GH_Curve Class
Grasshopper.Kernel.Types Namespace


GH_Curve.GH_CurveProxy Class

[image]

Grasshopper SDK
GH_Curve..::..GH_CurveProxy Class
GH_Curve Class Members See Also Send Feedback
Proxy description of GH_Curve class. This class is used by the Generic Multivalue interfaces.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_CurveProxy : GH_GooProxy<GH_Curve>
Visual Basic
Public Class GH_CurveProxy _
    Inherits GH_GooProxy(Of GH_Curve)

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_GooProxy <(Of <(<' GH_Curve >)>)>
Grasshopper.Kernel.Types..::..GH_Curve..::..GH_CurveProxy

See Also

GH_Curve..::..GH_CurveProxy Members
Grasshopper.Kernel.Types Namespace


GH_Curve.GH_CurveProxy Members

[image] [image]

Grasshopper SDK
GH_Curve..::..GH_CurveProxy Members
GH_Curve..::..GH_CurveProxy Class Constructors Methods Properties See Also Send Feedback

Represents a 3D spline curve.

The GH_Curve..::..GH_CurveProxy type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Curve..::..GH_CurveProxy | Initializes a new instance of the GH_Curve..::..GH_CurveProxy class

Methods

 | Name | Description
Public method | Construct | (Overrides GH_GooProxy<(Of <(<'T>)>)>..::..Construct()()()().)
Public method | FormatInstance | Returns a String description of the current value. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FromString | (Overrides GH_GooProxy<(Of <(<'T>)>)>..::..FromString(String).)
Public method | MutateString | Munge a string to remove obvious errors on account of the user. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | NumberToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | StringToNumber | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | ToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Closed |
Public property | Deformable |
Public property | Domain |
Public property | IsParsable | Gets a value indicating whether or not the type can be instantiated from a String. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Length |
Public property | Linear |
Public property | ObjectID |
Protected property | Owner | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Periodic |
Public property | Planar |
Public property | ProxyOwner | Gets the piece of Grasshopper data that spawned this proxy. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Type |
Public property | TypeDescription | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeName | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | UserString | Gets or sets the user-defined string that describes this proxy. This only really makes sense if the Proxy is Parsable. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Valid | Gets a value indicating whether this proxy represents valid data. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

See Also

GH_Curve..::..GH_CurveProxy Class
Grasshopper.Kernel.Types Namespace


GH_Curve.GH_CurveProxy Constructor

[image]

Grasshopper SDK
GH_Curve..::..GH_CurveProxy Constructor
GH_Curve..::..GH_CurveProxy Class See Also Send Feedback
Initializes a new instance of the GH_Curve..::..GH_CurveProxy class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_CurveProxy(
    GH_Curve owner
)
Visual Basic
Public Sub New ( _
    owner As GH_Curve _
)

Parameters

owner
Type: Grasshopper.Kernel.Types..::..GH_Curve

See Also

GH_Curve..::..GH_CurveProxy Class
Grasshopper.Kernel.Types Namespace


GH_Curve.GH_CurveProxy Methods

[image] [image]

Grasshopper SDK
GH_Curve..::..GH_CurveProxy Methods
GH_Curve..::..GH_CurveProxy Class See Also Send Feedback

The GH_Curve..::..GH_CurveProxy type exposes the following members.

Methods

 | Name | Description
Public method | Construct | (Overrides GH_GooProxy<(Of <(<'T>)>)>..::..Construct()()()().)
Public method | FormatInstance | Returns a String description of the current value. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FromString | (Overrides GH_GooProxy<(Of <(<'T>)>)>..::..FromString(String).)
Public method | MutateString | Munge a string to remove obvious errors on account of the user. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | NumberToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | StringToNumber | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | ToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

See Also

GH_Curve..::..GH_CurveProxy Class
Grasshopper.Kernel.Types Namespace


Construct Method

[image]

Grasshopper SDK
GH_Curve..::..GH_CurveProxy..::..Construct Method
GH_Curve..::..GH_CurveProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void Construct()
Visual Basic
Public Overrides Sub Construct

See Also

GH_Curve..::..GH_CurveProxy Class
Grasshopper.Kernel.Types Namespace


FromString Method

[image]

Grasshopper SDK
GH_Curve..::..GH_CurveProxy..::..FromString Method
GH_Curve..::..GH_CurveProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool FromString(
    string in
)
Visual Basic
Public Overrides Function FromString ( _
    in As String _
) As Boolean

Parameters

in
Type: System..::..String

See Also

GH_Curve..::..GH_CurveProxy Class
Grasshopper.Kernel.Types Namespace


GH_Curve.GH_CurveProxy Properties

[image] [image]

Grasshopper SDK
GH_Curve..::..GH_CurveProxy Properties
GH_Curve..::..GH_CurveProxy Class See Also Send Feedback

The GH_Curve..::..GH_CurveProxy type exposes the following members.

Properties

 | Name | Description
Public property | Closed |
Public property | Deformable |
Public property | Domain |
Public property | IsParsable | Gets a value indicating whether or not the type can be instantiated from a String. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Length |
Public property | Linear |
Public property | ObjectID |
Protected property | Owner | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Periodic |
Public property | Planar |
Public property | ProxyOwner | Gets the piece of Grasshopper data that spawned this proxy. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Type |
Public property | TypeDescription | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeName | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | UserString | Gets or sets the user-defined string that describes this proxy. This only really makes sense if the Proxy is Parsable. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Valid | Gets a value indicating whether this proxy represents valid data. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

See Also

GH_Curve..::..GH_CurveProxy Class
Grasshopper.Kernel.Types Namespace


Closed Property

[image]

Grasshopper SDK
GH_Curve..::..GH_CurveProxy..::..Closed Property
GH_Curve..::..GH_CurveProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Closed { get; }
Visual Basic
Public ReadOnly Property Closed As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Curve.GH_CurveProxy.Closed"]

See Also

GH_Curve..::..GH_CurveProxy Class
Grasshopper.Kernel.Types Namespace


Deformable Property

[image]

Grasshopper SDK
GH_Curve..::..GH_CurveProxy..::..Deformable Property
GH_Curve..::..GH_CurveProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Deformable { get; }
Visual Basic
Public ReadOnly Property Deformable As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Curve.GH_CurveProxy.Deformable"]

See Also

GH_Curve..::..GH_CurveProxy Class
Grasshopper.Kernel.Types Namespace


Domain Property

[image]

Grasshopper SDK
GH_Curve..::..GH_CurveProxy..::..Domain Property
GH_Curve..::..GH_CurveProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Domain { get; }
Visual Basic
Public ReadOnly Property Domain As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Curve.GH_CurveProxy.Domain"]

See Also

GH_Curve..::..GH_CurveProxy Class
Grasshopper.Kernel.Types Namespace


Length Property

[image]

Grasshopper SDK
GH_Curve..::..GH_CurveProxy..::..Length Property
GH_Curve..::..GH_CurveProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Length { get; }
Visual Basic
Public ReadOnly Property Length As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Curve.GH_CurveProxy.Length"]

See Also

GH_Curve..::..GH_CurveProxy Class
Grasshopper.Kernel.Types Namespace


Linear Property

[image]

Grasshopper SDK
GH_Curve..::..GH_CurveProxy..::..Linear Property
GH_Curve..::..GH_CurveProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Linear { get; }
Visual Basic
Public ReadOnly Property Linear As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Curve.GH_CurveProxy.Linear"]

See Also

GH_Curve..::..GH_CurveProxy Class
Grasshopper.Kernel.Types Namespace


ObjectID Property

[image]

Grasshopper SDK
GH_Curve..::..GH_CurveProxy..::..ObjectID Property
GH_Curve..::..GH_CurveProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string ObjectID { get; set; }
Visual Basic
Public Property ObjectID As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Curve.GH_CurveProxy.ObjectID"]

See Also

GH_Curve..::..GH_CurveProxy Class
Grasshopper.Kernel.Types Namespace


Periodic Property

[image]

Grasshopper SDK
GH_Curve..::..GH_CurveProxy..::..Periodic Property
GH_Curve..::..GH_CurveProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Periodic { get; }
Visual Basic
Public ReadOnly Property Periodic As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Curve.GH_CurveProxy.Periodic"]

See Also

GH_Curve..::..GH_CurveProxy Class
Grasshopper.Kernel.Types Namespace


Planar Property

[image]

Grasshopper SDK
GH_Curve..::..GH_CurveProxy..::..Planar Property
GH_Curve..::..GH_CurveProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Planar { get; }
Visual Basic
Public ReadOnly Property Planar As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Curve.GH_CurveProxy.Planar"]

See Also

GH_Curve..::..GH_CurveProxy Class
Grasshopper.Kernel.Types Namespace


Type Property

[image]

Grasshopper SDK
GH_Curve..::..GH_CurveProxy..::..Type Property
GH_Curve..::..GH_CurveProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Type { get; }
Visual Basic
Public ReadOnly Property Type As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Curve.GH_CurveProxy.Type"]

See Also

GH_Curve..::..GH_CurveProxy Class
Grasshopper.Kernel.Types Namespace


GH_DifferentialSolver Enumeration

[image]

Grasshopper SDK
GH_DifferentialSolver Enumeration
See Also Send Feedback
Enumerates all implemented differential samplers.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_DifferentialSolver
Visual Basic
Public Enumeration GH_DifferentialSolver

Members

Member name | Value | Description
None | 0 | Unset solver, always returns a zero-length tensor.
Euler | 1 | Euler differential solver.
RungeKutta2 | 2 | Runge-Kutta second order solver.
RungeKutta3 | 3 | Runge-Kutta third order solver.
RungeKutta4 | 4 | Runge-Kutta fourth order solver.

See Also

Grasshopper.Kernel.Types Namespace


GH_Field Class

[image]

Grasshopper SDK
GH_Field Class
Members See Also Send Feedback
Represents a field of forces.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Field : IGH_Goo, IGH_PreviewData
Visual Basic
Public Class GH_Field _
    Implements IGH_Goo, IGH_PreviewData

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_Field

See Also

GH_Field Members
Grasshopper.Kernel.Types Namespace


GH_Field Members

[image] [image]

Grasshopper SDK
GH_Field Members
GH_Field Class Constructors Methods Properties See Also Send Feedback

The GH_Field type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Field()()()() | Blank constructor.
Public method | GH_Field(GH_Field) | Copy constructor.

Methods

 | Name | Description
Public method | CastFrom |
Public method | CastTo<(Of <<'(T>)>>) |
Public method | CurvatureAt |
Public method | DrawViewportMeshes |
Public method | DrawViewportWires |
Public method | Duplicate |
Public method | EmitProxy |
Public method | Read |
Public method | ScriptVariable |
Public method | SolveStep | Move a point through the field.
Public method | SolveSteps | Move a point through a succession of steps.
Public method | TensorAt | Compute the field tensor at the given location as contributed by all the field elements.
Public method | ToString |
Public method | Write |

Properties

 | Name | Description
Public property | ClippingBox |
Public property | Elements | Gets the list of elements of this field.
Public property | IsValid |
Public property | IsValidWhyNot |
Public property | TypeDescription |
Public property | TypeName |

See Also

GH_Field Class
Grasshopper.Kernel.Types Namespace


GH_Field Constructor

[image] [image]

Grasshopper SDK
GH_Field Constructor
GH_Field Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Field()()()() | Blank constructor.
Public method | GH_Field(GH_Field) | Copy constructor.

See Also

GH_Field Class
GH_Field Members
Grasshopper.Kernel.Types Namespace


GH_Field Constructor

[image]

Grasshopper SDK
GH_Field Constructor
GH_Field Class See Also Send Feedback
Blank constructor.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Field()
Visual Basic
Public Sub New

See Also

GH_Field Class
GH_Field Overload
Grasshopper.Kernel.Types Namespace


GH_Field Constructor (GH_Field)

[image]

Grasshopper SDK
GH_Field Constructor (GH_Field)
GH_Field Class See Also Send Feedback
Copy constructor.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Field(
    GH_Field other
)
Visual Basic
Public Sub New ( _
    other As GH_Field _
)

Parameters

other
Type: Grasshopper.Kernel.Types..::..GH_Field
Field to duplicate.

See Also

GH_Field Class
GH_Field Overload
Grasshopper.Kernel.Types Namespace


GH_Field Methods

[image] [image]

Grasshopper SDK
GH_Field Methods
GH_Field Class See Also Send Feedback

The GH_Field type exposes the following members.

Methods

 | Name | Description
Public method | CastFrom |
Public method | CastTo<(Of <<'(T>)>>) |
Public method | CurvatureAt |
Public method | DrawViewportMeshes |
Public method | DrawViewportWires |
Public method | Duplicate |
Public method | EmitProxy |
Public method | Read |
Public method | ScriptVariable |
Public method | SolveStep | Move a point through the field.
Public method | SolveSteps | Move a point through a succession of steps.
Public method | TensorAt | Compute the field tensor at the given location as contributed by all the field elements.
Public method | ToString |
Public method | Write |

See Also

GH_Field Class
Grasshopper.Kernel.Types Namespace


CastFrom Method

[image]

Grasshopper SDK
GH_Field..::..CastFrom Method
GH_Field Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool CastFrom(
    Object source
)
Visual Basic
Public Function CastFrom ( _
    source As Object _
) As Boolean

Parameters

source
Type: System..::..Object

Implements

IGH_Goo..::..CastFrom(Object)

See Also

GH_Field Class
Grasshopper.Kernel.Types Namespace


CastTo(T) Method

[image]

Grasshopper SDK
GH_Field..::..CastTo<(Of <(<'T>)>)> Method
GH_Field Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool CastTo<T>(
    ref T target
)
Visual Basic
Public Function CastTo(Of T) ( _
    ByRef target As T _
) As Boolean

Parameters

target
Type: T%

Type Parameters

T

Implements

IGH_Goo..::..CastTo<(Of <<'(T>)>>)(T%)

See Also

GH_Field Class
Grasshopper.Kernel.Types Namespace


CurvatureAt Method

[image]

Grasshopper SDK
GH_Field..::..CurvatureAt Method
GH_Field Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double CurvatureAt(
    Point3d location
)
Visual Basic
Public Function CurvatureAt ( _
    location As Point3d _
) As Double

Parameters

location
Type: Point3d

See Also

GH_Field Class
Grasshopper.Kernel.Types Namespace


DrawViewportMeshes Method

[image]

Grasshopper SDK
GH_Field..::..DrawViewportMeshes Method
GH_Field Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DrawViewportMeshes(
    GH_PreviewMeshArgs args
)
Visual Basic
Public Sub DrawViewportMeshes ( _
    args As GH_PreviewMeshArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..GH_PreviewMeshArgs

Implements

IGH_PreviewData..::..DrawViewportMeshes(GH_PreviewMeshArgs)

See Also

GH_Field Class
Grasshopper.Kernel.Types Namespace


DrawViewportWires Method

[image]

Grasshopper SDK
GH_Field..::..DrawViewportWires Method
GH_Field Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DrawViewportWires(
    GH_PreviewWireArgs args
)
Visual Basic
Public Sub DrawViewportWires ( _
    args As GH_PreviewWireArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..GH_PreviewWireArgs

Implements

IGH_PreviewData..::..DrawViewportWires(GH_PreviewWireArgs)

See Also

GH_Field Class
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_Field..::..Duplicate Method
GH_Field Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_Goo Duplicate()
Visual Basic
Public Function Duplicate As IGH_Goo

Implements

IGH_Goo..::..Duplicate()()()()

See Also

GH_Field Class
Grasshopper.Kernel.Types Namespace


EmitProxy Method

[image]

Grasshopper SDK
GH_Field..::..EmitProxy Method
GH_Field Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_GooProxy EmitProxy()
Visual Basic
Public Function EmitProxy As IGH_GooProxy

Implements

IGH_Goo..::..EmitProxy()()()()

See Also

GH_Field Class
Grasshopper.Kernel.Types Namespace


Read Method

[image]

Grasshopper SDK
GH_Field..::..Read Method
GH_Field Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Read(
    GH_IReader reader
)
Visual Basic
Public Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

Implements

GH_ISerializable..::..Read(GH_IReader)

See Also

GH_Field Class
Grasshopper.Kernel.Types Namespace


ScriptVariable Method

[image]

Grasshopper SDK
GH_Field..::..ScriptVariable Method
GH_Field Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Object ScriptVariable()
Visual Basic
Public Function ScriptVariable As Object

Implements

IGH_Goo..::..ScriptVariable()()()()

See Also

GH_Field Class
Grasshopper.Kernel.Types Namespace


SolveStep Method

[image]

Grasshopper SDK
GH_Field..::..SolveStep Method
GH_Field Class See Also Send Feedback
Move a point through the field.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Vector3d SolveStep(
    Point3d location,
    double factor,
    GH_DifferentialSolver method
)
Visual Basic
Public Function SolveStep ( _
    location As Point3d, _
    factor As Double, _
    method As GH_DifferentialSolver _
) As Vector3d

Parameters

location
Type: Point3d
Point to move from.
factor
Type: System..::..Double
Multiplication factor to apply to sampling. A low factor results in more accurate sampling, but smaller steps.
method
Type: Grasshopper.Kernel.Types..::..GH_DifferentialSolver
Estimator to use.

Return Value

New point location.

See Also

GH_Field Class
Grasshopper.Kernel.Types Namespace


SolveSteps Method

[image]

Grasshopper SDK
GH_Field..::..SolveSteps Method
GH_Field Class See Also Send Feedback
Move a point through a succession of steps.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Point3dList SolveSteps(
    Point3d location,
    double accuracy,
    int count,
    GH_DifferentialSolver method
)
Visual Basic
Public Function SolveSteps ( _
    location As Point3d, _
    accuracy As Double, _
    count As Integer, _
    method As GH_DifferentialSolver _
) As Point3dList

Parameters

location
Type: Point3d
Point to move.
accuracy
Type: System..::..Double
Rough accuracy.
count
Type: System..::..Int32
Number of samples to take.
method
Type: Grasshopper.Kernel.Types..::..GH_DifferentialSolver
Estimator to use.

Return Value

A track (including the original location) of all the samples.

See Also

GH_Field Class
Grasshopper.Kernel.Types Namespace


TensorAt Method

[image]

Grasshopper SDK
GH_Field..::..TensorAt Method
GH_Field Class See Also Send Feedback
Compute the field tensor at the given location as contributed by all the field elements.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Vector3d TensorAt(
    Point3d location
)
Visual Basic
Public Function TensorAt ( _
    location As Point3d _
) As Vector3d

Parameters

location
Type: Point3d
Location to sample field at.

Return Value

The strength and direction of the field at the given location.

See Also

GH_Field Class
Grasshopper.Kernel.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_Field..::..ToString Method
GH_Field Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string ToString()
Visual Basic
Public Function ToString As String

Implements

IGH_Goo..::..ToString()()()()

See Also

GH_Field Class
Grasshopper.Kernel.Types Namespace


Write Method

[image]

Grasshopper SDK
GH_Field..::..Write Method
GH_Field Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Write(
    GH_IWriter writer
)
Visual Basic
Public Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

Implements

GH_ISerializable..::..Write(GH_IWriter)

See Also

GH_Field Class
Grasshopper.Kernel.Types Namespace


GH_Field Properties

[image] [image]

Grasshopper SDK
GH_Field Properties
GH_Field Class See Also Send Feedback

The GH_Field type exposes the following members.

Properties

 | Name | Description
Public property | ClippingBox |
Public property | Elements | Gets the list of elements of this field.
Public property | IsValid |
Public property | IsValidWhyNot |
Public property | TypeDescription |
Public property | TypeName |

See Also

GH_Field Class
Grasshopper.Kernel.Types Namespace


ClippingBox Property

[image]

Grasshopper SDK
GH_Field..::..ClippingBox Property
GH_Field Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public BoundingBox ClippingBox { get; }
Visual Basic
Public ReadOnly Property ClippingBox As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Field.ClippingBox"]

Implements

IGH_PreviewData..::..ClippingBox

See Also

GH_Field Class
Grasshopper.Kernel.Types Namespace


Elements Property

[image]

Grasshopper SDK
GH_Field..::..Elements Property
GH_Field Class See Also Send Feedback
Gets the list of elements of this field.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<IGH_FieldElement> Elements { get; }
Visual Basic
Public ReadOnly Property Elements As List(Of IGH_FieldElement)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Field.Elements"]

See Also

GH_Field Class
Grasshopper.Kernel.Types Namespace


IsValid Property

[image]

Grasshopper SDK
GH_Field..::..IsValid Property
GH_Field Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsValid { get; }
Visual Basic
Public ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Field.IsValid"]

Implements

IGH_Goo..::..IsValid

See Also

GH_Field Class
Grasshopper.Kernel.Types Namespace


IsValidWhyNot Property

[image]

Grasshopper SDK
GH_Field..::..IsValidWhyNot Property
GH_Field Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string IsValidWhyNot { get; }
Visual Basic
Public ReadOnly Property IsValidWhyNot As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Field.IsValidWhyNot"]

Implements

IGH_Goo..::..IsValidWhyNot

See Also

GH_Field Class
Grasshopper.Kernel.Types Namespace


TypeDescription Property

[image]

Grasshopper SDK
GH_Field..::..TypeDescription Property
GH_Field Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string TypeDescription { get; }
Visual Basic
Public ReadOnly Property TypeDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Field.TypeDescription"]

Implements

IGH_Goo..::..TypeDescription

See Also

GH_Field Class
Grasshopper.Kernel.Types Namespace


TypeName Property

[image]

Grasshopper SDK
GH_Field..::..TypeName Property
GH_Field Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string TypeName { get; }
Visual Basic
Public ReadOnly Property TypeName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Field.TypeName"]

Implements

IGH_Goo..::..TypeName

See Also

GH_Field Class
Grasshopper.Kernel.Types Namespace


GH_FieldElement Class

[image]

Grasshopper SDK
GH_FieldElement Class
Members See Also Send Feedback
Abstract implementation of IGH_FieldElement, derive from this class rather than implementing IGH_FieldElement to save yourself time and effort.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract class GH_FieldElement : IGH_FieldElement
Visual Basic
Public MustInherit Class GH_FieldElement _
    Implements IGH_FieldElement

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_FieldElement
Grasshopper.Kernel.Types..::..GH_LineCharge
Grasshopper.Kernel.Types..::..GH_PointCharge
Grasshopper.Kernel.Types..::..GH_SpinForce
Grasshopper.Kernel.Types..::..GH_VectorForce

See Also

GH_FieldElement Members
Grasshopper.Kernel.Types Namespace


GH_FieldElement Members

[image] [image]

Grasshopper SDK
GH_FieldElement Members
GH_FieldElement Class Constructors Methods Properties See Also Send Feedback

The GH_FieldElement type exposes the following members.

Constructors

 | Name | Description
Protected method | GH_FieldElement | Initializes a new instance of the GH_FieldElement class

Methods

 | Name | Description
Public method | DrawViewportMeshes |
Public method | DrawViewportWires |
Public method | Duplicate |
Public method | Force |
Public method | IsCoincident |
Public method | Read |
Public method | Write |

Properties

 | Name | Description
Public property | BoundingBox |
Public property | ClippingBox |
Public property | ElementGuid |
Public property | IsLimited |
Public property | Limits |

See Also

GH_FieldElement Class
Grasshopper.Kernel.Types Namespace


GH_FieldElement Constructor

[image]

Grasshopper SDK
GH_FieldElement Constructor
GH_FieldElement Class See Also Send Feedback
Initializes a new instance of the GH_FieldElement class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_FieldElement()
Visual Basic
Protected Sub New

See Also

GH_FieldElement Class
Grasshopper.Kernel.Types Namespace


GH_FieldElement Methods

[image] [image]

Grasshopper SDK
GH_FieldElement Methods
GH_FieldElement Class See Also Send Feedback

The GH_FieldElement type exposes the following members.

Methods

 | Name | Description
Public method | DrawViewportMeshes |
Public method | DrawViewportWires |
Public method | Duplicate |
Public method | Force |
Public method | IsCoincident |
Public method | Read |
Public method | Write |

See Also

GH_FieldElement Class
Grasshopper.Kernel.Types Namespace


DrawViewportMeshes Method

[image]

Grasshopper SDK
GH_FieldElement..::..DrawViewportMeshes Method
GH_FieldElement Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual void DrawViewportMeshes(
    GH_PreviewMeshArgs args
)
Visual Basic
Public Overridable Sub DrawViewportMeshes ( _
    args As GH_PreviewMeshArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..GH_PreviewMeshArgs

Implements

IGH_PreviewData..::..DrawViewportMeshes(GH_PreviewMeshArgs)

See Also

GH_FieldElement Class
Grasshopper.Kernel.Types Namespace


DrawViewportWires Method

[image]

Grasshopper SDK
GH_FieldElement..::..DrawViewportWires Method
GH_FieldElement Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual void DrawViewportWires(
    GH_PreviewWireArgs args
)
Visual Basic
Public Overridable Sub DrawViewportWires ( _
    args As GH_PreviewWireArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..GH_PreviewWireArgs

Implements

IGH_PreviewData..::..DrawViewportWires(GH_PreviewWireArgs)

See Also

GH_FieldElement Class
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_FieldElement..::..Duplicate Method
GH_FieldElement Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract IGH_FieldElement Duplicate()
Visual Basic
Public MustOverride Function Duplicate As IGH_FieldElement

Implements

IGH_FieldElement..::..Duplicate()()()()

See Also

GH_FieldElement Class
Grasshopper.Kernel.Types Namespace


Force Method

[image]

Grasshopper SDK
GH_FieldElement..::..Force Method
GH_FieldElement Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract Vector3d Force(
    Point3d location
)
Visual Basic
Public MustOverride Function Force ( _
    location As Point3d _
) As Vector3d

Parameters

location
Type: Point3d

Implements

IGH_FieldElement..::..Force(Point3d)

See Also

GH_FieldElement Class
Grasshopper.Kernel.Types Namespace


IsCoincident Method

[image]

Grasshopper SDK
GH_FieldElement..::..IsCoincident Method
GH_FieldElement Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool IsCoincident(
    Point3d point,
    double tolerance
)
Visual Basic
Public Overridable Function IsCoincident ( _
    point As Point3d, _
    tolerance As Double _
) As Boolean

Parameters

point
Type: Point3d
tolerance
Type: System..::..Double

Implements

IGH_FieldElement..::..IsCoincident(Point3d, Double)

See Also

GH_FieldElement Class
Grasshopper.Kernel.Types Namespace


Read Method

[image]

Grasshopper SDK
GH_FieldElement..::..Read Method
GH_FieldElement Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool Read(
    GH_IReader reader
)
Visual Basic
Public Overridable Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

Implements

GH_ISerializable..::..Read(GH_IReader)

See Also

GH_FieldElement Class
Grasshopper.Kernel.Types Namespace


Write Method

[image]

Grasshopper SDK
GH_FieldElement..::..Write Method
GH_FieldElement Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overridable Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

Implements

GH_ISerializable..::..Write(GH_IWriter)

See Also

GH_FieldElement Class
Grasshopper.Kernel.Types Namespace


GH_FieldElement Properties

[image] [image]

Grasshopper SDK
GH_FieldElement Properties
GH_FieldElement Class See Also Send Feedback

The GH_FieldElement type exposes the following members.

Properties

 | Name | Description
Public property | BoundingBox |
Public property | ClippingBox |
Public property | ElementGuid |
Public property | IsLimited |
Public property | Limits |

See Also

GH_FieldElement Class
Grasshopper.Kernel.Types Namespace


BoundingBox Property

[image]

Grasshopper SDK
GH_FieldElement..::..BoundingBox Property
GH_FieldElement Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract BoundingBox BoundingBox { get; }
Visual Basic
Public MustOverride ReadOnly Property BoundingBox As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_FieldElement.BoundingBox"]

Implements

IGH_FieldElement..::..BoundingBox

See Also

GH_FieldElement Class
Grasshopper.Kernel.Types Namespace


ClippingBox Property

[image]

Grasshopper SDK
GH_FieldElement..::..ClippingBox Property
GH_FieldElement Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual BoundingBox ClippingBox { get; }
Visual Basic
Public Overridable ReadOnly Property ClippingBox As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_FieldElement.ClippingBox"]

Implements

IGH_PreviewData..::..ClippingBox

See Also

GH_FieldElement Class
Grasshopper.Kernel.Types Namespace


ElementGuid Property

[image]

Grasshopper SDK
GH_FieldElement..::..ElementGuid Property
GH_FieldElement Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract Guid ElementGuid { get; }
Visual Basic
Public MustOverride ReadOnly Property ElementGuid As Guid
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_FieldElement.ElementGuid"]

Implements

IGH_FieldElement..::..ElementGuid

See Also

GH_FieldElement Class
Grasshopper.Kernel.Types Namespace


IsLimited Property

[image]

Grasshopper SDK
GH_FieldElement..::..IsLimited Property
GH_FieldElement Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsLimited { get; set; }
Visual Basic
Public Property IsLimited As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_FieldElement.IsLimited"]

Implements

IGH_FieldElement..::..IsLimited

See Also

GH_FieldElement Class
Grasshopper.Kernel.Types Namespace


Limits Property

[image]

Grasshopper SDK
GH_FieldElement..::..Limits Property
GH_FieldElement Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Box Limits { get; set; }
Visual Basic
Public Property Limits As Box
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_FieldElement.Limits"]

Implements

IGH_FieldElement..::..Limits

See Also

GH_FieldElement Class
Grasshopper.Kernel.Types Namespace


GH_GeometricGoo(T) Class

[image]

Grasshopper SDK
GH_GeometricGoo<(Of <(<'T>)>)> Class
Members See Also Send Feedback
Abstract base implementation of IGH_GeometricGoo. If you implement IGH_GeometricGoo, use this for a booster.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract class GH_GeometricGoo<T> : GH_Goo<T>,
    IGH_GeometricGoo
Visual Basic
Public MustInherit Class GH_GeometricGoo(Of T) _
    Inherits GH_Goo(Of T) _
    Implements IGH_GeometricGoo

Type Parameters

T

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_Goo <(Of <(<'T>)>)>
Grasshopper.Kernel.Types..::..GH_GeometricGoo<(Of <(<'T>)>)>
Grasshopper.Kernel.Types..::..GH_Arc
Grasshopper.Kernel.Types..::..GH_Box
Grasshopper.Kernel.Types..::..GH_Brep
Grasshopper.Kernel.Types..::..GH_Circle
Grasshopper.Kernel.Types..::..GH_Curve
Grasshopper.Kernel.Types..::..GH_Line
Grasshopper.Kernel.Types..::..GH_Mesh
Grasshopper.Kernel.Types..::..GH_Plane
Grasshopper.Kernel.Types..::..GH_Rectangle
Grasshopper.Kernel.Types..::..GH_Surface

See Also

GH_GeometricGoo<(Of <(<'T>)>)> Members
Grasshopper.Kernel.Types Namespace


GH_GeometricGoo(T) Members

[image] [image]

Grasshopper SDK
GH_GeometricGoo<(Of <(<'T>)>)> Members
GH_GeometricGoo<(Of <(<'T>)>)> Class Constructors Methods Fields Properties See Also Send Feedback

The GH_GeometricGoo<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Protected method | GH_GeometricGoo<(Of <(<'T>)>)>()()()() | Blank constructor, m_value will be set to default (null for reference types, zeroes for value types)
Protected method | GH_GeometricGoo<(Of <(<'T>)>)>(T) | Data constructor, m_value will be set to internal_data.

Methods

 | Name | Description
Public method | CastFrom | Attempt a cast from generic object. (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type T. (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ClearCaches | Clears all caches. Typically if the geometry is referenced, this will erase the local copy. If your T is a value-type, you must override this function and specifically unset the local value.
Public method | Duplicate | Make a complete duplicate of this instance. No shallow copies. (Overrides GH_Goo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateGeometry | Make a complete duplicate of this geometry. No shallow copies.
Public method | EmitProxy | Create a new proxy for this instance. Return Null if this class does not support proxies. (Overrides GH_Goo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | GetBoundingBox | Compute an aligned boundingbox.
Public method | LoadGeometry()()()() | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry.
Public method | LoadGeometry(RhinoDoc) | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. The default is to always return True.
Public method | Morph | Morph the object or a deformable representation of the object.
Public method | Read | Default behaviour is to return True. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ToString | Creates a string description of the current instance value. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | Transform | Transforms the object or a deformable representation of the object.
Public method | Write | Default behaviour is to return True. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Boundingbox | Gets the boundingbox for this geometry.
Public property | IsGeometryLoaded | Gets a value indicating whether or not this geometry is currently loaded (assuming it is referenced). Not all IGH_GeometricGoo implementations support referenced geometry. The default is to always return True.
Public property | IsReferencedGeometry | Gets a value indicating whether or not this geometry is referenced. Not all IGH_GeometricGoo implementations support referenced geometry.
Public property | IsValid | Gets a value indicating whether or not the current value is valid. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public property | ReferenceID | Gets or sets the Guid of the object that is referenced. Not all IGH_GeometricGoo implementations support referenced geometry. The default implementation is to always return Guid.Empty.
Public property | TypeDescription | Gets a description of the type of the implementation. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public property | TypeName | Gets the name of the type of the implementation. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public property | Value | Gets or sets the value of this type. Note that if the type has a ReferenceID this value might get destroyed in the future. (Overrides GH_Goo<(Of <(<'T>)>)>..::..Value.)

See Also

GH_GeometricGoo<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


GH_GeometricGoo(T) Constructor

[image] [image]

Grasshopper SDK
GH_GeometricGoo<(Of <(<'T>)>)> Constructor
GH_GeometricGoo<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GH_GeometricGoo<(Of <(<'T>)>)>()()()() | Blank constructor, m_value will be set to default (null for reference types, zeroes for value types)
Protected method | GH_GeometricGoo<(Of <(<'T>)>)>(T) | Data constructor, m_value will be set to internal_data.

See Also

GH_GeometricGoo<(Of <(<'T>)>)> Class
GH_GeometricGoo<(Of <(<'T>)>)> Members
Grasshopper.Kernel.Types Namespace


GH_GeometricGoo(T) Constructor

[image]

Grasshopper SDK
GH_GeometricGoo<(Of <(<'T>)>)> Constructor
GH_GeometricGoo<(Of <(<'T>)>)> Class See Also Send Feedback
Blank constructor, m_value will be set to default (null for reference types, zeroes for value types)

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_GeometricGoo()
Visual Basic
Protected Sub New

See Also

GH_GeometricGoo<(Of <(<'T>)>)> Class
GH_GeometricGoo<(Of <(<'T>)>)> Overload
Grasshopper.Kernel.Types Namespace


GH_GeometricGoo(T) Constructor (T)

[image]

Grasshopper SDK
GH_GeometricGoo<(Of <(<'T>)>)> Constructor (T)
GH_GeometricGoo<(Of <(<'T>)>)> Class See Also Send Feedback
Data constructor, m_value will be set to internal_data.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_GeometricGoo(
    T internal_data
)
Visual Basic
Protected Sub New ( _
    internal_data As T _
)

Parameters

internal_data
Type: T
Value to store inside this Goo instance.

See Also

GH_GeometricGoo<(Of <(<'T>)>)> Class
GH_GeometricGoo<(Of <(<'T>)>)> Overload
Grasshopper.Kernel.Types Namespace


GH_GeometricGoo(T) Fields

[image] [image]

Grasshopper SDK
GH_GeometricGoo<(Of <(<'T>)>)> Fields
GH_GeometricGoo<(Of <(<'T>)>)> Class See Also Send Feedback

The GH_GeometricGoo<(Of <(<'T>)>)> type exposes the following members.

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_GeometricGoo<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


GH_GeometricGoo(T) Methods

[image] [image]

Grasshopper SDK
GH_GeometricGoo<(Of <(<'T>)>)> Methods
GH_GeometricGoo<(Of <(<'T>)>)> Class See Also Send Feedback

The GH_GeometricGoo<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | CastFrom | Attempt a cast from generic object. (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type T. (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ClearCaches | Clears all caches. Typically if the geometry is referenced, this will erase the local copy. If your T is a value-type, you must override this function and specifically unset the local value.
Public method | Duplicate | Make a complete duplicate of this instance. No shallow copies. (Overrides GH_Goo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateGeometry | Make a complete duplicate of this geometry. No shallow copies.
Public method | EmitProxy | Create a new proxy for this instance. Return Null if this class does not support proxies. (Overrides GH_Goo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | GetBoundingBox | Compute an aligned boundingbox.
Public method | LoadGeometry()()()() | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry.
Public method | LoadGeometry(RhinoDoc) | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. The default is to always return True.
Public method | Morph | Morph the object or a deformable representation of the object.
Public method | Read | Default behaviour is to return True. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ToString | Creates a string description of the current instance value. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | Transform | Transforms the object or a deformable representation of the object.
Public method | Write | Default behaviour is to return True. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_GeometricGoo<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


CastFrom Method

[image]

Grasshopper SDK
GH_GeometricGoo<(Of <(<'T>)>)>..::..CastFrom Method
GH_GeometricGoo<(Of <(<'T>)>)> Class See Also Send Feedback
Attempt a cast from generic object.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastFrom(
    Object source
)
Visual Basic
Public Overrides Function CastFrom ( _
    source As Object _
) As Boolean

Parameters

source
Type: System..::..Object
Reference to source of cast.

Return Value

True on success, false on failure.

Remarks

If False, the contents of this instance are not to be trusted.

See Also

GH_GeometricGoo<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


CastTo Method

[image] [image]

Grasshopper SDK
GH_GeometricGoo<(Of <(<'T>)>)>..::..CastTo Method
GH_GeometricGoo<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type T. (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_GeometricGoo<(Of <(<'T>)>)> Class
GH_GeometricGoo<(Of <(<'T>)>)> Members
Grasshopper.Kernel.Types Namespace


CastTo(Q) Method (Q)

[image]

Grasshopper SDK
GH_GeometricGoo<(Of <(<'T>)>)>..::..CastTo<(Of <(<'Q>)>)> Method (Q%)
GH_GeometricGoo<(Of <(<'T>)>)> Class See Also Send Feedback
Attempt a cast to type T.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastTo<Q>(
    out Q target
)
Visual Basic
Public Overrides Function CastTo(Of Q) ( _
    <OutAttribute> ByRef target As Q _
) As Boolean

Parameters

target
Type: Q%
Pointer to target of cast.

Type Parameters

Q
Type to cast to

Return Value

True on success, false on failure.

Remarks

If false, the target instance contents are not guaranteed to be valid.

See Also

GH_GeometricGoo<(Of <(<'T>)>)> Class
CastTo Overload
Grasshopper.Kernel.Types Namespace


ClearCaches Method

[image]

Grasshopper SDK
GH_GeometricGoo<(Of <(<'T>)>)>..::..ClearCaches Method
GH_GeometricGoo<(Of <(<'T>)>)> Class See Also Send Feedback
Clears all caches. Typically if the geometry is referenced, this will erase the local copy. If your T is a value-type, you must override this function and specifically unset the local value.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual void ClearCaches()
Visual Basic
Public Overridable Sub ClearCaches

Implements

IGH_GeometricGoo..::..ClearCaches()()()()

See Also

GH_GeometricGoo<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_GeometricGoo<(Of <(<'T>)>)>..::..Duplicate Method
GH_GeometricGoo<(Of <(<'T>)>)> Class See Also Send Feedback
Make a complete duplicate of this instance. No shallow copies.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_Goo Duplicate()
Visual Basic
Public Overrides Function Duplicate As IGH_Goo

Remarks

Classes which implement this interface should also provide type specific Duplicate methods

See Also

GH_GeometricGoo<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


DuplicateGeometry Method

[image]

Grasshopper SDK
GH_GeometricGoo<(Of <(<'T>)>)>..::..DuplicateGeometry Method
GH_GeometricGoo<(Of <(<'T>)>)> Class See Also Send Feedback
Make a complete duplicate of this geometry. No shallow copies.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract IGH_GeometricGoo DuplicateGeometry()
Visual Basic
Public MustOverride Function DuplicateGeometry As IGH_GeometricGoo

Implements

IGH_GeometricGoo..::..DuplicateGeometry()()()()

Remarks

Each class that implements this interface should also provide a type specific duplication method

See Also

GH_GeometricGoo<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


EmitProxy Method

[image]

Grasshopper SDK
GH_GeometricGoo<(Of <(<'T>)>)>..::..EmitProxy Method
GH_GeometricGoo<(Of <(<'T>)>)> Class See Also Send Feedback
Create a new proxy for this instance. Return Null if this class does not support proxies.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GooProxy EmitProxy()
Visual Basic
Public Overrides Function EmitProxy As IGH_GooProxy

See Also

GH_GeometricGoo<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


GetBoundingBox Method

[image]

Grasshopper SDK
GH_GeometricGoo<(Of <(<'T>)>)>..::..GetBoundingBox Method
GH_GeometricGoo<(Of <(<'T>)>)> Class See Also Send Feedback
Compute an aligned boundingbox.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract BoundingBox GetBoundingBox(
    Transform xform
)
Visual Basic
Public MustOverride Function GetBoundingBox ( _
    xform As Transform _
) As BoundingBox

Parameters

xform
Type: Transform
Transformation to apply to geometry for BoundingBox computation.

Return Value

The world aligned boundingbox of the transformed geometry.

Implements

IGH_GeometricGoo..::..GetBoundingBox(Transform)

See Also

GH_GeometricGoo<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


LoadGeometry Method

[image] [image]

Grasshopper SDK
GH_GeometricGoo<(Of <(<'T>)>)>..::..LoadGeometry Method
GH_GeometricGoo<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LoadGeometry()()()() | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry.
Public method | LoadGeometry(RhinoDoc) | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. The default is to always return True.

See Also

GH_GeometricGoo<(Of <(<'T>)>)> Class
GH_GeometricGoo<(Of <(<'T>)>)> Members
Grasshopper.Kernel.Types Namespace


LoadGeometry Method

[image]

Grasshopper SDK
GH_GeometricGoo<(Of <(<'T>)>)>..::..LoadGeometry Method
GH_GeometricGoo<(Of <(<'T>)>)> Class See Also Send Feedback
If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool LoadGeometry()
Visual Basic
Public Overridable Function LoadGeometry As Boolean

Implements

IGH_GeometricGoo..::..LoadGeometry()()()()

See Also

GH_GeometricGoo<(Of <(<'T>)>)> Class
LoadGeometry Overload
Grasshopper.Kernel.Types Namespace


LoadGeometry Method ()

[image]

Grasshopper SDK
GH_GeometricGoo<(Of <(<'T>)>)>..::..LoadGeometry Method ()
GH_GeometricGoo<(Of <(<'T>)>)> Class See Also Send Feedback
If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. The default is to always return True.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool LoadGeometry(
    RhinoDoc doc
)
Visual Basic
Public Overridable Function LoadGeometry ( _
    doc As RhinoDoc _
) As Boolean

Parameters

doc
Type: RhinoDoc
Document to use for loading.

Implements

IGH_GeometricGoo..::..LoadGeometry(RhinoDoc)

See Also

GH_GeometricGoo<(Of <(<'T>)>)> Class
LoadGeometry Overload
Grasshopper.Kernel.Types Namespace


Morph Method

[image]

Grasshopper SDK
GH_GeometricGoo<(Of <(<'T>)>)>..::..Morph Method
GH_GeometricGoo<(Of <(<'T>)>)> Class See Also Send Feedback
Morph the object or a deformable representation of the object.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract IGH_GeometricGoo Morph(
    SpaceMorph xmorph
)
Visual Basic
Public MustOverride Function Morph ( _
    xmorph As SpaceMorph _
) As IGH_GeometricGoo

Parameters

xmorph
Type: SpaceMorph
Spatial deform.

Return Value

Deformed geometry. If the local geometry can be deformed accurately, then the returned instance equals this instance. Not all geometry types can be accurately deformed though, if this is the case, this function will return an instance of another IGH_GeometricGoo derived type which can be deformed.

Implements

IGH_GeometricGoo..::..Morph(SpaceMorph)

See Also

GH_GeometricGoo<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


Transform Method

[image]

Grasshopper SDK
GH_GeometricGoo<(Of <(<'T>)>)>..::..Transform Method
GH_GeometricGoo<(Of <(<'T>)>)> Class See Also Send Feedback
Transforms the object or a deformable representation of the object.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract IGH_GeometricGoo Transform(
    Transform xform
)
Visual Basic
Public MustOverride Function Transform ( _
    xform As Transform _
) As IGH_GeometricGoo

Parameters

xform
Type: Transform
Transformation matrix.

Return Value

Transformed geometry. If the local geometry can be transformed accurately, then the returned instance equals this instance. Not all geometry types can be accurately transformed under all circumstances though, if this is the case, this function will return an instance of another IGH_GeometricGoo derived type which can be transformed.

Implements

IGH_GeometricGoo..::..Transform(Transform)

See Also

GH_GeometricGoo<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


GH_GeometricGoo(T) Properties

[image] [image]

Grasshopper SDK
GH_GeometricGoo<(Of <(<'T>)>)> Properties
GH_GeometricGoo<(Of <(<'T>)>)> Class See Also Send Feedback

The GH_GeometricGoo<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Boundingbox | Gets the boundingbox for this geometry.
Public property | IsGeometryLoaded | Gets a value indicating whether or not this geometry is currently loaded (assuming it is referenced). Not all IGH_GeometricGoo implementations support referenced geometry. The default is to always return True.
Public property | IsReferencedGeometry | Gets a value indicating whether or not this geometry is referenced. Not all IGH_GeometricGoo implementations support referenced geometry.
Public property | IsValid | Gets a value indicating whether or not the current value is valid. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public property | ReferenceID | Gets or sets the Guid of the object that is referenced. Not all IGH_GeometricGoo implementations support referenced geometry. The default implementation is to always return Guid.Empty.
Public property | TypeDescription | Gets a description of the type of the implementation. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public property | TypeName | Gets the name of the type of the implementation. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public property | Value | Gets or sets the value of this type. Note that if the type has a ReferenceID this value might get destroyed in the future. (Overrides GH_Goo<(Of <(<'T>)>)>..::..Value.)

See Also

GH_GeometricGoo<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


Boundingbox Property

[image]

Grasshopper SDK
GH_GeometricGoo<(Of <(<'T>)>)>..::..Boundingbox Property
GH_GeometricGoo<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the boundingbox for this geometry.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract BoundingBox Boundingbox { get; }
Visual Basic
Public MustOverride ReadOnly Property Boundingbox As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_GeometricGoo`1.Boundingbox"]

Return Value

The boundingbox for this piece of geometry or Boundingbox.Empty if the geometry is null or invalid.

Implements

IGH_GeometricGoo..::..Boundingbox

See Also

GH_GeometricGoo<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


IsGeometryLoaded Property

[image]

Grasshopper SDK
GH_GeometricGoo<(Of <(<'T>)>)>..::..IsGeometryLoaded Property
GH_GeometricGoo<(Of <(<'T>)>)> Class See Also Send Feedback
Gets a value indicating whether or not this geometry is currently loaded (assuming it is referenced). Not all IGH_GeometricGoo implementations support referenced geometry. The default is to always return True.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool IsGeometryLoaded { get; }
Visual Basic
Public Overridable ReadOnly Property IsGeometryLoaded As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_GeometricGoo`1.IsGeometryLoaded"]

Implements

IGH_GeometricGoo..::..IsGeometryLoaded

See Also

GH_GeometricGoo<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


IsReferencedGeometry Property

[image]

Grasshopper SDK
GH_GeometricGoo<(Of <(<'T>)>)>..::..IsReferencedGeometry Property
GH_GeometricGoo<(Of <(<'T>)>)> Class See Also Send Feedback
Gets a value indicating whether or not this geometry is referenced. Not all IGH_GeometricGoo implementations support referenced geometry.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool IsReferencedGeometry { get; }
Visual Basic
Public Overridable ReadOnly Property IsReferencedGeometry As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_GeometricGoo`1.IsReferencedGeometry"]

Implements

IGH_GeometricGoo..::..IsReferencedGeometry

See Also

GH_GeometricGoo<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


IsValid Property

[image]

Grasshopper SDK
GH_GeometricGoo<(Of <(<'T>)>)>..::..IsValid Property
GH_GeometricGoo<(Of <(<'T>)>)> Class See Also Send Feedback
Gets a value indicating whether or not the current value is valid.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool IsValid { get; }
Visual Basic
Public Overrides ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_GeometricGoo`1.IsValid"]

See Also

GH_GeometricGoo<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


ReferenceID Property

[image]

Grasshopper SDK
GH_GeometricGoo<(Of <(<'T>)>)>..::..ReferenceID Property
GH_GeometricGoo<(Of <(<'T>)>)> Class See Also Send Feedback
Gets or sets the Guid of the object that is referenced. Not all IGH_GeometricGoo implementations support referenced geometry. The default implementation is to always return Guid.Empty.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual Guid ReferenceID { get; set; }
Visual Basic
Public Overridable Property ReferenceID As Guid
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_GeometricGoo`1.ReferenceID"]

Implements

IGH_GeometricGoo..::..ReferenceID

See Also

GH_GeometricGoo<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


Value Property

[image]

Grasshopper SDK
GH_GeometricGoo<(Of <(<'T>)>)>..::..Value Property
GH_GeometricGoo<(Of <(<'T>)>)> Class See Also Send Feedback
Gets or sets the value of this type. Note that if the type has a ReferenceID this value might get destroyed in the future.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override T Value { get; set; }
Visual Basic
Public Overrides Property Value As T
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_GeometricGoo`1.Value"]

See Also

GH_GeometricGoo<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


GH_GeometricGooWrapper Class

[image]

Grasshopper SDK
GH_GeometricGooWrapper Class
Members See Also Send Feedback
Utility class for maintaining all kinds of IGH_GeometricGoo types.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class GH_GeometricGooWrapper : IGH_GeometricGoo
Visual Basic
Public NotInheritable Class GH_GeometricGooWrapper _
    Implements IGH_GeometricGoo

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_GeometricGooWrapper

See Also

GH_GeometricGooWrapper Members
Grasshopper.Kernel.Types Namespace


GH_GeometricGooWrapper Members

[image] [image]

Grasshopper SDK
GH_GeometricGooWrapper Members
GH_GeometricGooWrapper Class Constructors Methods Properties See Also Send Feedback

The GH_GeometricGooWrapper type exposes the following members.

Constructors

 | Name | Description
Public method | GH_GeometricGooWrapper()()()() | Initializes a new instance of the GH_GeometricGooWrapper class
Public method | GH_GeometricGooWrapper(IGH_GeometricGoo) | Initializes a new instance of the GH_GeometricGooWrapper class

Methods

 | Name | Description
Public method | CastFrom |
Public method | CastTo<(Of <<'(T>)>>) |
Public method | ClearCaches |
Public method | Duplicate |
Public method | DuplicateGeometry |
Public method | EmitProxy |
Public method | GetBoundingBox |
Public method | LoadGeometry()()()() |
Public method | LoadGeometry(RhinoDoc) |
Public method | Morph |
Public method | Read |
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disapears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type.
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | Transform |
Public method | Write |

Properties

 | Name | Description
Public property | Boundingbox |
Public property | InternalGoo |
Public property | IsGeometryLoaded |
Public property | IsReferencedGeometry |
Public property | IsValid |
Public property | IsValidWhyNot |
Public property | ReferenceID |
Public property | TypeDescription |
Public property | TypeName |

See Also

GH_GeometricGooWrapper Class
Grasshopper.Kernel.Types Namespace


GH_GeometricGooWrapper Constructor

[image] [image]

Grasshopper SDK
GH_GeometricGooWrapper Constructor
GH_GeometricGooWrapper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_GeometricGooWrapper()()()() | Initializes a new instance of the GH_GeometricGooWrapper class
Public method | GH_GeometricGooWrapper(IGH_GeometricGoo) | Initializes a new instance of the GH_GeometricGooWrapper class

See Also

GH_GeometricGooWrapper Class
GH_GeometricGooWrapper Members
Grasshopper.Kernel.Types Namespace


GH_GeometricGooWrapper Constructor

[image]

Grasshopper SDK
GH_GeometricGooWrapper Constructor
GH_GeometricGooWrapper Class See Also Send Feedback
Initializes a new instance of the GH_GeometricGooWrapper class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_GeometricGooWrapper()
Visual Basic
Public Sub New

See Also

GH_GeometricGooWrapper Class
GH_GeometricGooWrapper Overload
Grasshopper.Kernel.Types Namespace


GH_GeometricGooWrapper Constructor (IGH_GeometricGoo)

[image]

Grasshopper SDK
GH_GeometricGooWrapper Constructor (IGH_GeometricGoo)
GH_GeometricGooWrapper Class See Also Send Feedback
Initializes a new instance of the GH_GeometricGooWrapper class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_GeometricGooWrapper(
    IGH_GeometricGoo goo
)
Visual Basic
Public Sub New ( _
    goo As IGH_GeometricGoo _
)

Parameters

goo
Type: Grasshopper.Kernel.Types..::..IGH_GeometricGoo

See Also

GH_GeometricGooWrapper Class
GH_GeometricGooWrapper Overload
Grasshopper.Kernel.Types Namespace


GH_GeometricGooWrapper Methods

[image] [image]

Grasshopper SDK
GH_GeometricGooWrapper Methods
GH_GeometricGooWrapper Class See Also Send Feedback

The GH_GeometricGooWrapper type exposes the following members.

Methods

 | Name | Description
Public method | CastFrom |
Public method | CastTo<(Of <<'(T>)>>) |
Public method | ClearCaches |
Public method | Duplicate |
Public method | DuplicateGeometry |
Public method | EmitProxy |
Public method | GetBoundingBox |
Public method | LoadGeometry()()()() |
Public method | LoadGeometry(RhinoDoc) |
Public method | Morph |
Public method | Read |
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disapears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type.
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | Transform |
Public method | Write |

See Also

GH_GeometricGooWrapper Class
Grasshopper.Kernel.Types Namespace


CastFrom Method

[image]

Grasshopper SDK
GH_GeometricGooWrapper..::..CastFrom Method
GH_GeometricGooWrapper Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool CastFrom(
    Object source
)
Visual Basic
Public Function CastFrom ( _
    source As Object _
) As Boolean

Parameters

source
Type: System..::..Object

Implements

IGH_Goo..::..CastFrom(Object)

See Also

GH_GeometricGooWrapper Class
Grasshopper.Kernel.Types Namespace


CastTo(T) Method

[image]

Grasshopper SDK
GH_GeometricGooWrapper..::..CastTo<(Of <(<'T>)>)> Method
GH_GeometricGooWrapper Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool CastTo<T>(
    ref T target
)
Visual Basic
Public Function CastTo(Of T) ( _
    ByRef target As T _
) As Boolean

Parameters

target
Type: T%

Type Parameters

T

Implements

IGH_Goo..::..CastTo<(Of <<'(T>)>>)(T%)

See Also

GH_GeometricGooWrapper Class
Grasshopper.Kernel.Types Namespace


ClearCaches Method

[image]

Grasshopper SDK
GH_GeometricGooWrapper..::..ClearCaches Method
GH_GeometricGooWrapper Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ClearCaches()
Visual Basic
Public Sub ClearCaches

Implements

IGH_GeometricGoo..::..ClearCaches()()()()

See Also

GH_GeometricGooWrapper Class
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_GeometricGooWrapper..::..Duplicate Method
GH_GeometricGooWrapper Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_Goo Duplicate()
Visual Basic
Public Function Duplicate As IGH_Goo

Implements

IGH_Goo..::..Duplicate()()()()

See Also

GH_GeometricGooWrapper Class
Grasshopper.Kernel.Types Namespace


DuplicateGeometry Method

[image]

Grasshopper SDK
GH_GeometricGooWrapper..::..DuplicateGeometry Method
GH_GeometricGooWrapper Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_GeometricGoo DuplicateGeometry()
Visual Basic
Public Function DuplicateGeometry As IGH_GeometricGoo

Implements

IGH_GeometricGoo..::..DuplicateGeometry()()()()

See Also

GH_GeometricGooWrapper Class
Grasshopper.Kernel.Types Namespace


EmitProxy Method

[image]

Grasshopper SDK
GH_GeometricGooWrapper..::..EmitProxy Method
GH_GeometricGooWrapper Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_GooProxy EmitProxy()
Visual Basic
Public Function EmitProxy As IGH_GooProxy

Implements

IGH_Goo..::..EmitProxy()()()()

See Also

GH_GeometricGooWrapper Class
Grasshopper.Kernel.Types Namespace


GetBoundingBox Method

[image]

Grasshopper SDK
GH_GeometricGooWrapper..::..GetBoundingBox Method
GH_GeometricGooWrapper Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public BoundingBox GetBoundingBox(
    Transform xform
)
Visual Basic
Public Function GetBoundingBox ( _
    xform As Transform _
) As BoundingBox

Parameters

xform
Type: Transform

Implements

IGH_GeometricGoo..::..GetBoundingBox(Transform)

See Also

GH_GeometricGooWrapper Class
Grasshopper.Kernel.Types Namespace


LoadGeometry Method

[image] [image]

Grasshopper SDK
GH_GeometricGooWrapper..::..LoadGeometry Method
GH_GeometricGooWrapper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LoadGeometry()()()() |
Public method | LoadGeometry(RhinoDoc) |

See Also

GH_GeometricGooWrapper Class
GH_GeometricGooWrapper Members
Grasshopper.Kernel.Types Namespace


LoadGeometry Method

[image]

Grasshopper SDK
GH_GeometricGooWrapper..::..LoadGeometry Method
GH_GeometricGooWrapper Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool LoadGeometry()
Visual Basic
Public Function LoadGeometry As Boolean

Implements

IGH_GeometricGoo..::..LoadGeometry()()()()

See Also

GH_GeometricGooWrapper Class
LoadGeometry Overload
Grasshopper.Kernel.Types Namespace


LoadGeometry Method ()

[image]

Grasshopper SDK
GH_GeometricGooWrapper..::..LoadGeometry Method ()
GH_GeometricGooWrapper Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool LoadGeometry(
    RhinoDoc doc
)
Visual Basic
Public Function LoadGeometry ( _
    doc As RhinoDoc _
) As Boolean

Parameters

doc
Type: RhinoDoc

Implements

IGH_GeometricGoo..::..LoadGeometry(RhinoDoc)

See Also

GH_GeometricGooWrapper Class
LoadGeometry Overload
Grasshopper.Kernel.Types Namespace


Morph Method

[image]

Grasshopper SDK
GH_GeometricGooWrapper..::..Morph Method
GH_GeometricGooWrapper Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_GeometricGoo Morph(
    SpaceMorph xmorph
)
Visual Basic
Public Function Morph ( _
    xmorph As SpaceMorph _
) As IGH_GeometricGoo

Parameters

xmorph
Type: SpaceMorph

Implements

IGH_GeometricGoo..::..Morph(SpaceMorph)

See Also

GH_GeometricGooWrapper Class
Grasshopper.Kernel.Types Namespace


Read Method

[image]

Grasshopper SDK
GH_GeometricGooWrapper..::..Read Method
GH_GeometricGooWrapper Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Read(
    GH_IReader reader
)
Visual Basic
Public Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

Implements

GH_ISerializable..::..Read(GH_IReader)

See Also

GH_GeometricGooWrapper Class
Grasshopper.Kernel.Types Namespace


ScriptVariable Method

[image]

Grasshopper SDK
GH_GeometricGooWrapper..::..ScriptVariable Method
GH_GeometricGooWrapper Class See Also Send Feedback
This function will be called when the local IGH_Goo instance disapears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Object ScriptVariable()
Visual Basic
Public Function ScriptVariable As Object

Return Value

The object that represents this IGH_Goo instance in a script.

Implements

IGH_Goo..::..ScriptVariable()()()()

See Also

GH_GeometricGooWrapper Class
Grasshopper.Kernel.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_GeometricGooWrapper..::..ToString Method
GH_GeometricGooWrapper Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Implements

IGH_Goo..::..ToString()()()()

See Also

GH_GeometricGooWrapper Class
Grasshopper.Kernel.Types Namespace


Transform Method

[image]

Grasshopper SDK
GH_GeometricGooWrapper..::..Transform Method
GH_GeometricGooWrapper Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_GeometricGoo Transform(
    Transform xform
)
Visual Basic
Public Function Transform ( _
    xform As Transform _
) As IGH_GeometricGoo

Parameters

xform
Type: Transform

Implements

IGH_GeometricGoo..::..Transform(Transform)

See Also

GH_GeometricGooWrapper Class
Grasshopper.Kernel.Types Namespace


Write Method

[image]

Grasshopper SDK
GH_GeometricGooWrapper..::..Write Method
GH_GeometricGooWrapper Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Write(
    GH_IWriter writer
)
Visual Basic
Public Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

Implements

GH_ISerializable..::..Write(GH_IWriter)

See Also

GH_GeometricGooWrapper Class
Grasshopper.Kernel.Types Namespace


GH_GeometricGooWrapper Properties

[image] [image]

Grasshopper SDK
GH_GeometricGooWrapper Properties
GH_GeometricGooWrapper Class See Also Send Feedback

The GH_GeometricGooWrapper type exposes the following members.

Properties

 | Name | Description
Public property | Boundingbox |
Public property | InternalGoo |
Public property | IsGeometryLoaded |
Public property | IsReferencedGeometry |
Public property | IsValid |
Public property | IsValidWhyNot |
Public property | ReferenceID |
Public property | TypeDescription |
Public property | TypeName |

See Also

GH_GeometricGooWrapper Class
Grasshopper.Kernel.Types Namespace


Boundingbox Property

[image]

Grasshopper SDK
GH_GeometricGooWrapper..::..Boundingbox Property
GH_GeometricGooWrapper Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public BoundingBox Boundingbox { get; }
Visual Basic
Public ReadOnly Property Boundingbox As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_GeometricGooWrapper.Boundingbox"]

Implements

IGH_GeometricGoo..::..Boundingbox

See Also

GH_GeometricGooWrapper Class
Grasshopper.Kernel.Types Namespace


InternalGoo Property

[image]

Grasshopper SDK
GH_GeometricGooWrapper..::..InternalGoo Property
GH_GeometricGooWrapper Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_GeometricGoo InternalGoo { get; }
Visual Basic
Public ReadOnly Property InternalGoo As IGH_GeometricGoo
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_GeometricGooWrapper.InternalGoo"]

See Also

GH_GeometricGooWrapper Class
Grasshopper.Kernel.Types Namespace


IsGeometryLoaded Property

[image]

Grasshopper SDK
GH_GeometricGooWrapper..::..IsGeometryLoaded Property
GH_GeometricGooWrapper Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsGeometryLoaded { get; }
Visual Basic
Public ReadOnly Property IsGeometryLoaded As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_GeometricGooWrapper.IsGeometryLoaded"]

Implements

IGH_GeometricGoo..::..IsGeometryLoaded

See Also

GH_GeometricGooWrapper Class
Grasshopper.Kernel.Types Namespace


IsReferencedGeometry Property

[image]

Grasshopper SDK
GH_GeometricGooWrapper..::..IsReferencedGeometry Property
GH_GeometricGooWrapper Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsReferencedGeometry { get; }
Visual Basic
Public ReadOnly Property IsReferencedGeometry As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_GeometricGooWrapper.IsReferencedGeometry"]

Implements

IGH_GeometricGoo..::..IsReferencedGeometry

See Also

GH_GeometricGooWrapper Class
Grasshopper.Kernel.Types Namespace


IsValid Property

[image]

Grasshopper SDK
GH_GeometricGooWrapper..::..IsValid Property
GH_GeometricGooWrapper Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsValid { get; }
Visual Basic
Public ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_GeometricGooWrapper.IsValid"]

Implements

IGH_Goo..::..IsValid

See Also

GH_GeometricGooWrapper Class
Grasshopper.Kernel.Types Namespace


IsValidWhyNot Property

[image]

Grasshopper SDK
GH_GeometricGooWrapper..::..IsValidWhyNot Property
GH_GeometricGooWrapper Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string IsValidWhyNot { get; }
Visual Basic
Public ReadOnly Property IsValidWhyNot As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_GeometricGooWrapper.IsValidWhyNot"]

Implements

IGH_Goo..::..IsValidWhyNot

See Also

GH_GeometricGooWrapper Class
Grasshopper.Kernel.Types Namespace


ReferenceID Property

[image]

Grasshopper SDK
GH_GeometricGooWrapper..::..ReferenceID Property
GH_GeometricGooWrapper Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid ReferenceID { get; set; }
Visual Basic
Public Property ReferenceID As Guid
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_GeometricGooWrapper.ReferenceID"]

Implements

IGH_GeometricGoo..::..ReferenceID

See Also

GH_GeometricGooWrapper Class
Grasshopper.Kernel.Types Namespace


TypeDescription Property

[image]

Grasshopper SDK
GH_GeometricGooWrapper..::..TypeDescription Property
GH_GeometricGooWrapper Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string TypeDescription { get; }
Visual Basic
Public ReadOnly Property TypeDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_GeometricGooWrapper.TypeDescription"]

Implements

IGH_Goo..::..TypeDescription

See Also

GH_GeometricGooWrapper Class
Grasshopper.Kernel.Types Namespace


TypeName Property

[image]

Grasshopper SDK
GH_GeometricGooWrapper..::..TypeName Property
GH_GeometricGooWrapper Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string TypeName { get; }
Visual Basic
Public ReadOnly Property TypeName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_GeometricGooWrapper.TypeName"]

Implements

IGH_Goo..::..TypeName

See Also

GH_GeometricGooWrapper Class
Grasshopper.Kernel.Types Namespace


GH_GeometryGroup Class

[image]

Grasshopper SDK
GH_GeometryGroup Class
Members See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_GeometryGroup : IGH_GeometricGoo,
    IGH_BakeAwareData, IGH_PreviewData
Visual Basic
Public Class GH_GeometryGroup _
    Implements IGH_GeometricGoo, IGH_BakeAwareData, IGH_PreviewData

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_GeometryGroup

See Also

GH_GeometryGroup Members
Grasshopper.Kernel.Types Namespace


GH_GeometryGroup Members

[image] [image]

Grasshopper SDK
GH_GeometryGroup Members
GH_GeometryGroup Class Constructors Methods Properties See Also Send Feedback

The GH_GeometryGroup type exposes the following members.

Constructors

 | Name | Description
Public method | GH_GeometryGroup | Initializes a new instance of the GH_GeometryGroup class

Methods

 | Name | Description
Public method | BakeGeometry |
Public method | CastFrom |
Public method | CastTo<(Of <<'(T>)>>) |
Public method | ClearCaches |
Public method | DrawViewportMeshes |
Public method | DrawViewportWires |
Public method | Duplicate |
Public method | DuplicateGeometry |
Public method | EmitProxy |
Public method | GetBoundingBox |
Public method | LoadGeometry()()()() |
Public method | LoadGeometry(RhinoDoc) |
Public method | Morph |
Public method | Read |
Public method | ScriptVariable |
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | Transform |
Public method | Write |

Properties

 | Name | Description
Public property | Boundingbox |
Public property | ClippingBox |
Public property | IsGeometryLoaded |
Public property | IsReferencedGeometry |
Public property | IsValid |
Public property | IsValidWhyNot |
Public property | Objects |
Public property | ReferenceID |
Public property | TypeDescription |
Public property | TypeName |

See Also

GH_GeometryGroup Class
Grasshopper.Kernel.Types Namespace


GH_GeometryGroup Constructor

[image]

Grasshopper SDK
GH_GeometryGroup Constructor
GH_GeometryGroup Class See Also Send Feedback
Initializes a new instance of the GH_GeometryGroup class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_GeometryGroup()
Visual Basic
Public Sub New

See Also

GH_GeometryGroup Class
Grasshopper.Kernel.Types Namespace


GH_GeometryGroup Methods

[image] [image]

Grasshopper SDK
GH_GeometryGroup Methods
GH_GeometryGroup Class See Also Send Feedback

The GH_GeometryGroup type exposes the following members.

Methods

 | Name | Description
Public method | BakeGeometry |
Public method | CastFrom |
Public method | CastTo<(Of <<'(T>)>>) |
Public method | ClearCaches |
Public method | DrawViewportMeshes |
Public method | DrawViewportWires |
Public method | Duplicate |
Public method | DuplicateGeometry |
Public method | EmitProxy |
Public method | GetBoundingBox |
Public method | LoadGeometry()()()() |
Public method | LoadGeometry(RhinoDoc) |
Public method | Morph |
Public method | Read |
Public method | ScriptVariable |
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | Transform |
Public method | Write |

See Also

GH_GeometryGroup Class
Grasshopper.Kernel.Types Namespace


BakeGeometry Method

[image]

Grasshopper SDK
GH_GeometryGroup..::..BakeGeometry Method
GH_GeometryGroup Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool BakeGeometry(
    RhinoDoc doc,
    ObjectAttributes att,
    ref Guid obj_guid
)
Visual Basic
Public Function BakeGeometry ( _
    doc As RhinoDoc, _
    att As ObjectAttributes, _
    ByRef obj_guid As Guid _
) As Boolean

Parameters

doc
Type: RhinoDoc
att
Type: ObjectAttributes
obj_guid
Type: System..::..Guid %

Implements

IGH_BakeAwareData..::..BakeGeometry(RhinoDoc, ObjectAttributes, Guid%)

See Also

GH_GeometryGroup Class
Grasshopper.Kernel.Types Namespace


CastFrom Method

[image]

Grasshopper SDK
GH_GeometryGroup..::..CastFrom Method
GH_GeometryGroup Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool CastFrom(
    Object source
)
Visual Basic
Public Function CastFrom ( _
    source As Object _
) As Boolean

Parameters

source
Type: System..::..Object

Implements

IGH_Goo..::..CastFrom(Object)

See Also

GH_GeometryGroup Class
Grasshopper.Kernel.Types Namespace


CastTo(T) Method

[image]

Grasshopper SDK
GH_GeometryGroup..::..CastTo<(Of <(<'T>)>)> Method
GH_GeometryGroup Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool CastTo<T>(
    ref T target
)
Visual Basic
Public Function CastTo(Of T) ( _
    ByRef target As T _
) As Boolean

Parameters

target
Type: T%

Type Parameters

T

Implements

IGH_Goo..::..CastTo<(Of <<'(T>)>>)(T%)

See Also

GH_GeometryGroup Class
Grasshopper.Kernel.Types Namespace


ClearCaches Method

[image]

Grasshopper SDK
GH_GeometryGroup..::..ClearCaches Method
GH_GeometryGroup Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ClearCaches()
Visual Basic
Public Sub ClearCaches

Implements

IGH_GeometricGoo..::..ClearCaches()()()()

See Also

GH_GeometryGroup Class
Grasshopper.Kernel.Types Namespace


DrawViewportMeshes Method

[image]

Grasshopper SDK
GH_GeometryGroup..::..DrawViewportMeshes Method
GH_GeometryGroup Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DrawViewportMeshes(
    GH_PreviewMeshArgs args
)
Visual Basic
Public Sub DrawViewportMeshes ( _
    args As GH_PreviewMeshArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..GH_PreviewMeshArgs

Implements

IGH_PreviewData..::..DrawViewportMeshes(GH_PreviewMeshArgs)

See Also

GH_GeometryGroup Class
Grasshopper.Kernel.Types Namespace


DrawViewportWires Method

[image]

Grasshopper SDK
GH_GeometryGroup..::..DrawViewportWires Method
GH_GeometryGroup Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DrawViewportWires(
    GH_PreviewWireArgs args
)
Visual Basic
Public Sub DrawViewportWires ( _
    args As GH_PreviewWireArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..GH_PreviewWireArgs

Implements

IGH_PreviewData..::..DrawViewportWires(GH_PreviewWireArgs)

See Also

GH_GeometryGroup Class
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_GeometryGroup..::..Duplicate Method
GH_GeometryGroup Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_Goo Duplicate()
Visual Basic
Public Function Duplicate As IGH_Goo

Implements

IGH_Goo..::..Duplicate()()()()

See Also

GH_GeometryGroup Class
Grasshopper.Kernel.Types Namespace


DuplicateGeometry Method

[image]

Grasshopper SDK
GH_GeometryGroup..::..DuplicateGeometry Method
GH_GeometryGroup Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_GeometricGoo DuplicateGeometry()
Visual Basic
Public Function DuplicateGeometry As IGH_GeometricGoo

Implements

IGH_GeometricGoo..::..DuplicateGeometry()()()()

See Also

GH_GeometryGroup Class
Grasshopper.Kernel.Types Namespace


EmitProxy Method

[image]

Grasshopper SDK
GH_GeometryGroup..::..EmitProxy Method
GH_GeometryGroup Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_GooProxy EmitProxy()
Visual Basic
Public Function EmitProxy As IGH_GooProxy

Implements

IGH_Goo..::..EmitProxy()()()()

See Also

GH_GeometryGroup Class
Grasshopper.Kernel.Types Namespace


GetBoundingBox Method

[image]

Grasshopper SDK
GH_GeometryGroup..::..GetBoundingBox Method
GH_GeometryGroup Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public BoundingBox GetBoundingBox(
    Transform xform
)
Visual Basic
Public Function GetBoundingBox ( _
    xform As Transform _
) As BoundingBox

Parameters

xform
Type: Transform

Implements

IGH_GeometricGoo..::..GetBoundingBox(Transform)

See Also

GH_GeometryGroup Class
Grasshopper.Kernel.Types Namespace


LoadGeometry Method

[image] [image]

Grasshopper SDK
GH_GeometryGroup..::..LoadGeometry Method
GH_GeometryGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LoadGeometry()()()() |
Public method | LoadGeometry(RhinoDoc) |

See Also

GH_GeometryGroup Class
GH_GeometryGroup Members
Grasshopper.Kernel.Types Namespace


LoadGeometry Method

[image]

Grasshopper SDK
GH_GeometryGroup..::..LoadGeometry Method
GH_GeometryGroup Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool LoadGeometry()
Visual Basic
Public Function LoadGeometry As Boolean

Implements

IGH_GeometricGoo..::..LoadGeometry()()()()

See Also

GH_GeometryGroup Class
LoadGeometry Overload
Grasshopper.Kernel.Types Namespace


LoadGeometry Method ()

[image]

Grasshopper SDK
GH_GeometryGroup..::..LoadGeometry Method ()
GH_GeometryGroup Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool LoadGeometry(
    RhinoDoc doc
)
Visual Basic
Public Function LoadGeometry ( _
    doc As RhinoDoc _
) As Boolean

Parameters

doc
Type: RhinoDoc

Implements

IGH_GeometricGoo..::..LoadGeometry(RhinoDoc)

See Also

GH_GeometryGroup Class
LoadGeometry Overload
Grasshopper.Kernel.Types Namespace


Morph Method

[image]

Grasshopper SDK
GH_GeometryGroup..::..Morph Method
GH_GeometryGroup Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_GeometricGoo Morph(
    SpaceMorph xmorph
)
Visual Basic
Public Function Morph ( _
    xmorph As SpaceMorph _
) As IGH_GeometricGoo

Parameters

xmorph
Type: SpaceMorph

Implements

IGH_GeometricGoo..::..Morph(SpaceMorph)

See Also

GH_GeometryGroup Class
Grasshopper.Kernel.Types Namespace


Read Method

[image]

Grasshopper SDK
GH_GeometryGroup..::..Read Method
GH_GeometryGroup Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Read(
    GH_IReader reader
)
Visual Basic
Public Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

Implements

GH_ISerializable..::..Read(GH_IReader)

See Also

GH_GeometryGroup Class
Grasshopper.Kernel.Types Namespace


ScriptVariable Method

[image]

Grasshopper SDK
GH_GeometryGroup..::..ScriptVariable Method
GH_GeometryGroup Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Object ScriptVariable()
Visual Basic
Public Function ScriptVariable As Object

Implements

IGH_Goo..::..ScriptVariable()()()()

See Also

GH_GeometryGroup Class
Grasshopper.Kernel.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_GeometryGroup..::..ToString Method
GH_GeometryGroup Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Implements

IGH_Goo..::..ToString()()()()

See Also

GH_GeometryGroup Class
Grasshopper.Kernel.Types Namespace


Transform Method

[image]

Grasshopper SDK
GH_GeometryGroup..::..Transform Method
GH_GeometryGroup Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_GeometricGoo Transform(
    Transform xform
)
Visual Basic
Public Function Transform ( _
    xform As Transform _
) As IGH_GeometricGoo

Parameters

xform
Type: Transform

Implements

IGH_GeometricGoo..::..Transform(Transform)

See Also

GH_GeometryGroup Class
Grasshopper.Kernel.Types Namespace


Write Method

[image]

Grasshopper SDK
GH_GeometryGroup..::..Write Method
GH_GeometryGroup Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Write(
    GH_IWriter writer
)
Visual Basic
Public Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

Implements

GH_ISerializable..::..Write(GH_IWriter)

See Also

GH_GeometryGroup Class
Grasshopper.Kernel.Types Namespace


GH_GeometryGroup Properties

[image] [image]

Grasshopper SDK
GH_GeometryGroup Properties
GH_GeometryGroup Class See Also Send Feedback

The GH_GeometryGroup type exposes the following members.

Properties

 | Name | Description
Public property | Boundingbox |
Public property | ClippingBox |
Public property | IsGeometryLoaded |
Public property | IsReferencedGeometry |
Public property | IsValid |
Public property | IsValidWhyNot |
Public property | Objects |
Public property | ReferenceID |
Public property | TypeDescription |
Public property | TypeName |

See Also

GH_GeometryGroup Class
Grasshopper.Kernel.Types Namespace


Boundingbox Property

[image]

Grasshopper SDK
GH_GeometryGroup..::..Boundingbox Property
GH_GeometryGroup Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public BoundingBox Boundingbox { get; }
Visual Basic
Public ReadOnly Property Boundingbox As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_GeometryGroup.Boundingbox"]

Implements

IGH_GeometricGoo..::..Boundingbox

See Also

GH_GeometryGroup Class
Grasshopper.Kernel.Types Namespace


ClippingBox Property

[image]

Grasshopper SDK
GH_GeometryGroup..::..ClippingBox Property
GH_GeometryGroup Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public BoundingBox ClippingBox { get; }
Visual Basic
Public ReadOnly Property ClippingBox As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_GeometryGroup.ClippingBox"]

Implements

IGH_PreviewData..::..ClippingBox

See Also

GH_GeometryGroup Class
Grasshopper.Kernel.Types Namespace


IsGeometryLoaded Property

[image]

Grasshopper SDK
GH_GeometryGroup..::..IsGeometryLoaded Property
GH_GeometryGroup Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsGeometryLoaded { get; }
Visual Basic
Public ReadOnly Property IsGeometryLoaded As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_GeometryGroup.IsGeometryLoaded"]

Implements

IGH_GeometricGoo..::..IsGeometryLoaded

See Also

GH_GeometryGroup Class
Grasshopper.Kernel.Types Namespace


IsReferencedGeometry Property

[image]

Grasshopper SDK
GH_GeometryGroup..::..IsReferencedGeometry Property
GH_GeometryGroup Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsReferencedGeometry { get; }
Visual Basic
Public ReadOnly Property IsReferencedGeometry As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_GeometryGroup.IsReferencedGeometry"]

Implements

IGH_GeometricGoo..::..IsReferencedGeometry

See Also

GH_GeometryGroup Class
Grasshopper.Kernel.Types Namespace


IsValid Property

[image]

Grasshopper SDK
GH_GeometryGroup..::..IsValid Property
GH_GeometryGroup Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsValid { get; }
Visual Basic
Public ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_GeometryGroup.IsValid"]

Implements

IGH_Goo..::..IsValid

See Also

GH_GeometryGroup Class
Grasshopper.Kernel.Types Namespace


IsValidWhyNot Property

[image]

Grasshopper SDK
GH_GeometryGroup..::..IsValidWhyNot Property
GH_GeometryGroup Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string IsValidWhyNot { get; }
Visual Basic
Public ReadOnly Property IsValidWhyNot As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_GeometryGroup.IsValidWhyNot"]

Implements

IGH_Goo..::..IsValidWhyNot

See Also

GH_GeometryGroup Class
Grasshopper.Kernel.Types Namespace


Objects Property

[image]

Grasshopper SDK
GH_GeometryGroup..::..Objects Property
GH_GeometryGroup Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<IGH_GeometricGoo> Objects { get; }
Visual Basic
Public ReadOnly Property Objects As List(Of IGH_GeometricGoo)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_GeometryGroup.Objects"]

See Also

GH_GeometryGroup Class
Grasshopper.Kernel.Types Namespace


ReferenceID Property

[image]

Grasshopper SDK
GH_GeometryGroup..::..ReferenceID Property
GH_GeometryGroup Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid ReferenceID { get; set; }
Visual Basic
Public Property ReferenceID As Guid
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_GeometryGroup.ReferenceID"]

Implements

IGH_GeometricGoo..::..ReferenceID

See Also

GH_GeometryGroup Class
Grasshopper.Kernel.Types Namespace


TypeDescription Property

[image]

Grasshopper SDK
GH_GeometryGroup..::..TypeDescription Property
GH_GeometryGroup Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string TypeDescription { get; }
Visual Basic
Public ReadOnly Property TypeDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_GeometryGroup.TypeDescription"]

Implements

IGH_Goo..::..TypeDescription

See Also

GH_GeometryGroup Class
Grasshopper.Kernel.Types Namespace


TypeName Property

[image]

Grasshopper SDK
GH_GeometryGroup..::..TypeName Property
GH_GeometryGroup Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string TypeName { get; }
Visual Basic
Public ReadOnly Property TypeName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_GeometryGroup.TypeName"]

Implements

IGH_Goo..::..TypeName

See Also

GH_GeometryGroup Class
Grasshopper.Kernel.Types Namespace


GH_GeometryGroup.GH_GeometryGroupProxy Class

[image]

Grasshopper SDK
GH_GeometryGroup..::..GH_GeometryGroupProxy Class
GH_GeometryGroup Class Members See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_GeometryGroupProxy : GH_GooProxy<GH_GeometryGroup>
Visual Basic
Public Class GH_GeometryGroupProxy _
    Inherits GH_GooProxy(Of GH_GeometryGroup)

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_GooProxy <(Of <(<' GH_GeometryGroup >)>)>
Grasshopper.Kernel.Types..::..GH_GeometryGroup..::..GH_GeometryGroupProxy

See Also

GH_GeometryGroup..::..GH_GeometryGroupProxy Members
Grasshopper.Kernel.Types Namespace


GH_GeometryGroup.GH_GeometryGroupProxy Members

[image] [image]

Grasshopper SDK
GH_GeometryGroup..::..GH_GeometryGroupProxy Members
GH_GeometryGroup..::..GH_GeometryGroupProxy Class Constructors Methods Properties See Also Send Feedback

The GH_GeometryGroup..::..GH_GeometryGroupProxy type exposes the following members.

Constructors

 | Name | Description
Public method | GH_GeometryGroup..::..GH_GeometryGroupProxy | Initializes a new instance of the GH_GeometryGroup..::..GH_GeometryGroupProxy class

Methods

 | Name | Description
Public method | Construct | Override this method to supply a custom UI during proxy construction. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FormatInstance | Returns a String description of the current value. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FromString | If IsParsable(), then attempts to convert the string to a generic type value (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | MutateString | Munge a string to remove obvious errors on account of the user. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | NumberToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | StringToNumber | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | ToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | IsParsable | Gets a value indicating whether or not the type can be instantiated from a String. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected property | Owner | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | ProxyOwner | Gets the piece of Grasshopper data that spawned this proxy. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeName | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | UserString | Gets or sets the user-defined string that describes this proxy. This only really makes sense if the Proxy is Parsable. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Valid | Gets a value indicating whether this proxy represents valid data. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

See Also

GH_GeometryGroup..::..GH_GeometryGroupProxy Class
Grasshopper.Kernel.Types Namespace


GH_GeometryGroup.GH_GeometryGroupProxy Constructor

[image]

Grasshopper SDK
GH_GeometryGroup..::..GH_GeometryGroupProxy Constructor
GH_GeometryGroup..::..GH_GeometryGroupProxy Class See Also Send Feedback
Initializes a new instance of the GH_GeometryGroup..::..GH_GeometryGroupProxy class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_GeometryGroupProxy(
    GH_GeometryGroup owner
)
Visual Basic
Public Sub New ( _
    owner As GH_GeometryGroup _
)

Parameters

owner
Type: Grasshopper.Kernel.Types..::..GH_GeometryGroup

See Also

GH_GeometryGroup..::..GH_GeometryGroupProxy Class
Grasshopper.Kernel.Types Namespace


GH_GeometryGroup.GH_GeometryGroupProxy Methods

[image] [image]

Grasshopper SDK
GH_GeometryGroup..::..GH_GeometryGroupProxy Methods
GH_GeometryGroup..::..GH_GeometryGroupProxy Class See Also Send Feedback

The GH_GeometryGroup..::..GH_GeometryGroupProxy type exposes the following members.

Methods

 | Name | Description
Public method | Construct | Override this method to supply a custom UI during proxy construction. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FormatInstance | Returns a String description of the current value. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FromString | If IsParsable(), then attempts to convert the string to a generic type value (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | MutateString | Munge a string to remove obvious errors on account of the user. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | NumberToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | StringToNumber | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | ToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

See Also

GH_GeometryGroup..::..GH_GeometryGroupProxy Class
Grasshopper.Kernel.Types Namespace


GH_GeometryGroup.GH_GeometryGroupProxy Properties

[image] [image]

Grasshopper SDK
GH_GeometryGroup..::..GH_GeometryGroupProxy Properties
GH_GeometryGroup..::..GH_GeometryGroupProxy Class See Also Send Feedback

The GH_GeometryGroup..::..GH_GeometryGroupProxy type exposes the following members.

Properties

 | Name | Description
Public property | IsParsable | Gets a value indicating whether or not the type can be instantiated from a String. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected property | Owner | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | ProxyOwner | Gets the piece of Grasshopper data that spawned this proxy. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeName | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | UserString | Gets or sets the user-defined string that describes this proxy. This only really makes sense if the Proxy is Parsable. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Valid | Gets a value indicating whether this proxy represents valid data. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

See Also

GH_GeometryGroup..::..GH_GeometryGroupProxy Class
Grasshopper.Kernel.Types Namespace


GH_Goo(T) Class

[image]

Grasshopper SDK
GH_Goo<(Of <(<'T>)>)> Class
Members See Also Send Feedback
Base class for IGH_Goo implementation. Takes care of some default behaviour.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract class GH_Goo<T> : IGH_Goo
Visual Basic
Public MustInherit Class GH_Goo(Of T) _
    Implements IGH_Goo

Type Parameters

T

Remarks

Feel free to implement IGH_Goo directly though.

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_Goo<(Of <(<'T>)>)>
Grasshopper.Kernel.Types..::..GH_Boolean
Grasshopper.Kernel.Types..::..GH_Colour
Grasshopper.Kernel.Types..::..GH_ComplexNumber
Grasshopper.Kernel.Types..::..GH_Culture
Grasshopper.Kernel.Types..::..GH_GeometricGoo<(Of <(<'T>)>)>
Grasshopper.Kernel.Types..::..GH_Guid
Grasshopper.Kernel.Types..::..GH_Integer
Grasshopper.Kernel.Types..::..GH_Interval
Grasshopper.Kernel.Types..::..GH_Interval2D
Grasshopper.Kernel.Types..::..GH_Material
Grasshopper.Kernel.Types..::..GH_Matrix
Grasshopper.Kernel.Types..::..GH_MeshFace
Grasshopper.Kernel.Types..::..GH_MeshingParameters
Grasshopper.Kernel.Types..::..GH_Number
Grasshopper.Kernel.Types..::..GH_ObjectWrapper
Grasshopper.Kernel.Types..::..GH_String
Grasshopper.Kernel.Types..::..GH_StructurePath
Grasshopper.Kernel.Types..::..GH_Time
Grasshopper.Kernel.Types..::..GH_Transform
Grasshopper.Kernel.Types..::..GH_Vector

See Also

GH_Goo<(Of <(<'T>)>)> Members
Grasshopper.Kernel.Types Namespace


GH_Goo(T) Members

[image] [image]

Grasshopper SDK
GH_Goo<(Of <(<'T>)>)> Members
GH_Goo<(Of <(<'T>)>)> Class Constructors Methods Fields Properties See Also Send Feedback

The GH_Goo<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Protected method | GH_Goo<(Of <(<'T>)>)>()()()() | Blank constructor, m_value will be set to default (null for reference types, zeroes for value types)
Protected method | GH_Goo<(Of <(<'T>)>)>(T) | Data constructor, m_value will be set to internal_data.
Protected method | GH_Goo<(Of <(<'T>)>)>(GH_Goo<(Of <<'(T>)>>)) | Copy constructor, copies the data from another GH_Goo(Of T) instance. Reference types will not be duplicated.

Methods

 | Name | Description
Public method | CastFrom | Attempt a cast from generic data.
Public method | CastTo<(Of <<'(Q>)>>) | Attempt a cast to type Q.
Public method | Duplicate | Make a complete duplicate of this instance. No shallow copies.
Public method | EmitProxy | Create a new proxy for this instance. Return Null if this class does not support proxies.
Public method | Read | Default behaviour is to return True.
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type.
Public method | ToString | Creates a string description of the current instance value. (Overrides Object..::..ToString()()()().)
Public method | Write | Default behaviour is to return True.

Fields

 | Name | Description
Protected field | m_value |

Properties

 | Name | Description
Public property | IsValid | Gets a value indicating whether or not the current value is valid.
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.
Public property | TypeDescription | Gets a description of the type of the implementation.
Public property | TypeName | Gets the name of the type of the implementation.
Public property | Value | Gets or sets the internal data.

See Also

GH_Goo<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


GH_Goo(T) Constructor

[image] [image]

Grasshopper SDK
GH_Goo<(Of <(<'T>)>)> Constructor
GH_Goo<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GH_Goo<(Of <(<'T>)>)>()()()() | Blank constructor, m_value will be set to default (null for reference types, zeroes for value types)
Protected method | GH_Goo<(Of <(<'T>)>)>(T) | Data constructor, m_value will be set to internal_data.
Protected method | GH_Goo<(Of <(<'T>)>)>(GH_Goo<(Of <<'(T>)>>)) | Copy constructor, copies the data from another GH_Goo(Of T) instance. Reference types will not be duplicated.

See Also

GH_Goo<(Of <(<'T>)>)> Class
GH_Goo<(Of <(<'T>)>)> Members
Grasshopper.Kernel.Types Namespace


GH_Goo(T) Constructor

[image]

Grasshopper SDK
GH_Goo<(Of <(<'T>)>)> Constructor
GH_Goo<(Of <(<'T>)>)> Class See Also Send Feedback
Blank constructor, m_value will be set to default (null for reference types, zeroes for value types)

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Goo()
Visual Basic
Protected Sub New

See Also

GH_Goo<(Of <(<'T>)>)> Class
GH_Goo<(Of <(<'T>)>)> Overload
Grasshopper.Kernel.Types Namespace


GH_Goo(T) Constructor (T)

[image]

Grasshopper SDK
GH_Goo<(Of <(<'T>)>)> Constructor (T)
GH_Goo<(Of <(<'T>)>)> Class See Also Send Feedback
Data constructor, m_value will be set to internal_data.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Goo(
    T internal_data
)
Visual Basic
Protected Sub New ( _
    internal_data As T _
)

Parameters

internal_data
Type: T
Value to store inside this Goo instance.

See Also

GH_Goo<(Of <(<'T>)>)> Class
GH_Goo<(Of <(<'T>)>)> Overload
Grasshopper.Kernel.Types Namespace


GH_Goo(T) Constructor (GH_Goo(T))

[image]

Grasshopper SDK
GH_Goo<(Of <(<'T>)>)> Constructor (GH_Goo<(Of <(<'T>)>)>)
GH_Goo<(Of <(<'T>)>)> Class See Also Send Feedback
Copy constructor, copies the data from another GH_Goo(Of T) instance. Reference types will not be duplicated.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_Goo(
    GH_Goo<T> other
)
Visual Basic
Protected Sub New ( _
    other As GH_Goo(Of T) _
)

Parameters

other
Type: Grasshopper.Kernel.Types..::..GH_Goo <(Of <(<' T >)>)>
Goo instance to copy.

See Also

GH_Goo<(Of <(<'T>)>)> Class
GH_Goo<(Of <(<'T>)>)> Overload
Grasshopper.Kernel.Types Namespace


GH_Goo(T) Fields

[image] [image]

Grasshopper SDK
GH_Goo<(Of <(<'T>)>)> Fields
GH_Goo<(Of <(<'T>)>)> Class See Also Send Feedback

The GH_Goo<(Of <(<'T>)>)> type exposes the following members.

Fields

 | Name | Description
Protected field | m_value |

See Also

GH_Goo<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


m_value Field

[image]

Grasshopper SDK
GH_Goo<(Of <(<'T>)>)>..::..m_value Field
GH_Goo<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected T m_value
Visual Basic
Protected m_value As T

See Also

GH_Goo<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


GH_Goo(T) Methods

[image] [image]

Grasshopper SDK
GH_Goo<(Of <(<'T>)>)> Methods
GH_Goo<(Of <(<'T>)>)> Class See Also Send Feedback

The GH_Goo<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | CastFrom | Attempt a cast from generic data.
Public method | CastTo<(Of <<'(Q>)>>) | Attempt a cast to type Q.
Public method | Duplicate | Make a complete duplicate of this instance. No shallow copies.
Public method | EmitProxy | Create a new proxy for this instance. Return Null if this class does not support proxies.
Public method | Read | Default behaviour is to return True.
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type.
Public method | ToString | Creates a string description of the current instance value. (Overrides Object..::..ToString()()()().)
Public method | Write | Default behaviour is to return True.

See Also

GH_Goo<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


CastFrom Method

[image]

Grasshopper SDK
GH_Goo<(Of <(<'T>)>)>..::..CastFrom Method
GH_Goo<(Of <(<'T>)>)> Class See Also Send Feedback
Attempt a cast from generic data.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool CastFrom(
    Object source
)
Visual Basic
Public Overridable Function CastFrom ( _
    source As Object _
) As Boolean

Parameters

source
Type: System..::..Object
Reference to data that should be cast.

Return Value

True on success, false on failure.

Implements

IGH_Goo..::..CastFrom(Object)

Remarks

If False, the contents of this instance are not to be trusted.

See Also

GH_Goo<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


CastTo(Q) Method

[image]

Grasshopper SDK
GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <(<'Q>)>)> Method
GH_Goo<(Of <(<'T>)>)> Class See Also Send Feedback
Attempt a cast to type Q.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool CastTo<Q>(
    ref Q target
)
Visual Basic
Public Overridable Function CastTo(Of Q) ( _
    ByRef target As Q _
) As Boolean

Parameters

target
Type: Q%
Pointer to target of cast.

Type Parameters

Q
Type to cast to.

Return Value

True on success, false on failure.

Implements

IGH_Goo..::..CastTo<(Of <<'(T>)>>)(T%)

Remarks

If false, the target instance contents are not guaranteed to be valid.

See Also

GH_Goo<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_Goo<(Of <(<'T>)>)>..::..Duplicate Method
GH_Goo<(Of <(<'T>)>)> Class See Also Send Feedback
Make a complete duplicate of this instance. No shallow copies.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract IGH_Goo Duplicate()
Visual Basic
Public MustOverride Function Duplicate As IGH_Goo

Implements

IGH_Goo..::..Duplicate()()()()

Remarks

Classes which implement this interface should also provide type specific Duplicate methods

See Also

GH_Goo<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


EmitProxy Method

[image]

Grasshopper SDK
GH_Goo<(Of <(<'T>)>)>..::..EmitProxy Method
GH_Goo<(Of <(<'T>)>)> Class See Also Send Feedback
Create a new proxy for this instance. Return Null if this class does not support proxies.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual IGH_GooProxy EmitProxy()
Visual Basic
Public Overridable Function EmitProxy As IGH_GooProxy

Implements

IGH_Goo..::..EmitProxy()()()()

See Also

GH_Goo<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


Read Method

[image]

Grasshopper SDK
GH_Goo<(Of <(<'T>)>)>..::..Read Method
GH_Goo<(Of <(<'T>)>)> Class See Also Send Feedback
Default behaviour is to return True.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool Read(
    GH_IReader reader
)
Visual Basic
Public Overridable Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

Implements

GH_ISerializable..::..Read(GH_IReader)

See Also

GH_Goo<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


ScriptVariable Method

[image]

Grasshopper SDK
GH_Goo<(Of <(<'T>)>)>..::..ScriptVariable Method
GH_Goo<(Of <(<'T>)>)> Class See Also Send Feedback
This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual Object ScriptVariable()
Visual Basic
Public Overridable Function ScriptVariable As Object

Return Value

The default implementation of this function returns the Value instance.

Implements

IGH_Goo..::..ScriptVariable()()()()

See Also

GH_Goo<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_Goo<(Of <(<'T>)>)>..::..ToString Method
GH_Goo<(Of <(<'T>)>)> Class See Also Send Feedback
Creates a string description of the current instance value.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract string ToString()
Visual Basic
Public MustOverride Function ToString As String

Implements

IGH_Goo..::..ToString()()()()

See Also

GH_Goo<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


Write Method

[image]

Grasshopper SDK
GH_Goo<(Of <(<'T>)>)>..::..Write Method
GH_Goo<(Of <(<'T>)>)> Class See Also Send Feedback
Default behaviour is to return True.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overridable Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

Implements

GH_ISerializable..::..Write(GH_IWriter)

See Also

GH_Goo<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


GH_Goo(T) Properties

[image] [image]

Grasshopper SDK
GH_Goo<(Of <(<'T>)>)> Properties
GH_Goo<(Of <(<'T>)>)> Class See Also Send Feedback

The GH_Goo<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | IsValid | Gets a value indicating whether or not the current value is valid.
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.
Public property | TypeDescription | Gets a description of the type of the implementation.
Public property | TypeName | Gets the name of the type of the implementation.
Public property | Value | Gets or sets the internal data.

See Also

GH_Goo<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


IsValid Property

[image]

Grasshopper SDK
GH_Goo<(Of <(<'T>)>)>..::..IsValid Property
GH_Goo<(Of <(<'T>)>)> Class See Also Send Feedback
Gets a value indicating whether or not the current value is valid.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract bool IsValid { get; }
Visual Basic
Public MustOverride ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Goo`1.IsValid"]

Implements

IGH_Goo..::..IsValid

See Also

GH_Goo<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


IsValidWhyNot Property

[image]

Grasshopper SDK
GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot Property
GH_Goo<(Of <(<'T>)>)> Class See Also Send Feedback
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual string IsValidWhyNot { get; }
Visual Basic
Public Overridable ReadOnly Property IsValidWhyNot As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Goo`1.IsValidWhyNot"]

Implements

IGH_Goo..::..IsValidWhyNot

See Also

GH_Goo<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


TypeDescription Property

[image]

Grasshopper SDK
GH_Goo<(Of <(<'T>)>)>..::..TypeDescription Property
GH_Goo<(Of <(<'T>)>)> Class See Also Send Feedback
Gets a description of the type of the implementation.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract string TypeDescription { get; }
Visual Basic
Public MustOverride ReadOnly Property TypeDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Goo`1.TypeDescription"]

Implements

IGH_Goo..::..TypeDescription

See Also

GH_Goo<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


TypeName Property

[image]

Grasshopper SDK
GH_Goo<(Of <(<'T>)>)>..::..TypeName Property
GH_Goo<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the name of the type of the implementation.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract string TypeName { get; }
Visual Basic
Public MustOverride ReadOnly Property TypeName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Goo`1.TypeName"]

Implements

IGH_Goo..::..TypeName

See Also

GH_Goo<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


Value Property

[image]

Grasshopper SDK
GH_Goo<(Of <(<'T>)>)>..::..Value Property
GH_Goo<(Of <(<'T>)>)> Class See Also Send Feedback
Gets or sets the internal data.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual T Value { get; set; }
Visual Basic
Public Overridable Property Value As T
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Goo`1.Value"]

See Also

GH_Goo<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


GH_GooProxy(T) Class

[image]

Grasshopper SDK
GH_GooProxy<(Of <(<'T>)>)> Class
Members See Also Send Feedback
Abstract base implementation of IGH_GooProxy

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract class GH_GooProxy<T> : IGH_GooProxy
where T : IGH_Goo
Visual Basic
Public MustInherit Class GH_GooProxy(Of T As IGH_Goo) _
    Implements IGH_GooProxy

Type Parameters

T

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_GooProxy<(Of <(<'T>)>)>
Grasshopper.Kernel.Types..::..GH_Box..::..GH_BoxProxy
Grasshopper.Kernel.Types..::..GH_Brep..::..GH_BrepProxy
Grasshopper.Kernel.Types..::..GH_Circle..::..GH_CircleProxy
Grasshopper.Kernel.Types..::..GH_Curve..::..GH_CurveProxy
Grasshopper.Kernel.Types..::..GH_GeometryGroup..::..GH_GeometryGroupProxy
Grasshopper.Kernel.Types..::..GH_Interval2D..::..GH_Interval2DProxy
Grasshopper.Kernel.Types..::..GH_Line..::..GH_LineProxy
Grasshopper.Kernel.Types..::..GH_Material..::..GH_Material_Proxy
Grasshopper.Kernel.Types..::..GH_Mesh..::..GH_MeshProxy
Grasshopper.Kernel.Types..::..GH_MeshFace..::..GH_MeshFaceProxy
Grasshopper.Kernel.Types..::..GH_MeshingParameters..::..RhMesherSettings_Proxy
Grasshopper.Kernel.Types..::..GH_Plane..::..GH_PlaneProxy
Grasshopper.Kernel.Types..::..GH_Point..::..GH_PointProxy
Grasshopper.Kernel.Types..::..GH_Rectangle..::..GH_RectangleProxy
Grasshopper.Kernel.Types..::..GH_Surface..::..GH_SurfaceProxy
Grasshopper.Kernel.Types..::..GH_Vector..::..GH_VectorProxy

See Also

GH_GooProxy<(Of <(<'T>)>)> Members
Grasshopper.Kernel.Types Namespace


GH_GooProxy(T) Members

[image] [image]

Grasshopper SDK
GH_GooProxy<(Of <(<'T>)>)> Members
GH_GooProxy<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The GH_GooProxy<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Protected method | GH_GooProxy<(Of <(<'T>)>)> | Initializes a new instance of the GH_GooProxy<(Of <(<'T>)>)> class

Methods

 | Name | Description
Public method | Construct | Override this method to supply a custom UI during proxy construction.
Public method | FormatInstance | Returns a String description of the current value.
Public method | FromString | If IsParsable(), then attempts to convert the string to a generic type value
Public method | MutateString | Munge a string to remove obvious errors on account of the user.
Protected method | NumberToString |
Protected method | StringToNumber |
Public method | ToString | (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | IsParsable | Gets a value indicating whether or not the type can be instantiated from a String.
Protected property | Owner |
Public property | ProxyOwner | Gets the piece of Grasshopper data that spawned this proxy.
Public property | TypeDescription |
Public property | TypeName |
Public property | UserString | Gets or sets the user-defined string that describes this proxy. This only really makes sense if the Proxy is Parsable.
Public property | Valid | Gets a value indicating whether this proxy represents valid data.

See Also

GH_GooProxy<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


GH_GooProxy(T) Constructor

[image]

Grasshopper SDK
GH_GooProxy<(Of <(<'T>)>)> Constructor
GH_GooProxy<(Of <(<'T>)>)> Class See Also Send Feedback
Initializes a new instance of the GH_GooProxy<(Of <(<'T>)>)> class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_GooProxy(
    T owner
)
Visual Basic
Protected Sub New ( _
    owner As T _
)

Parameters

owner
Type: T

See Also

GH_GooProxy<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


GH_GooProxy(T) Methods

[image] [image]

Grasshopper SDK
GH_GooProxy<(Of <(<'T>)>)> Methods
GH_GooProxy<(Of <(<'T>)>)> Class See Also Send Feedback

The GH_GooProxy<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Construct | Override this method to supply a custom UI during proxy construction.
Public method | FormatInstance | Returns a String description of the current value.
Public method | FromString | If IsParsable(), then attempts to convert the string to a generic type value
Public method | MutateString | Munge a string to remove obvious errors on account of the user.
Protected method | NumberToString |
Protected method | StringToNumber |
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

GH_GooProxy<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


Construct Method

[image]

Grasshopper SDK
GH_GooProxy<(Of <(<'T>)>)>..::..Construct Method
GH_GooProxy<(Of <(<'T>)>)> Class See Also Send Feedback
Override this method to supply a custom UI during proxy construction.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual void Construct()
Visual Basic
Public Overridable Sub Construct

Implements

IGH_GooProxy..::..Construct()()()()

See Also

GH_GooProxy<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


FormatInstance Method

[image]

Grasshopper SDK
GH_GooProxy<(Of <(<'T>)>)>..::..FormatInstance Method
GH_GooProxy<(Of <(<'T>)>)> Class See Also Send Feedback
Returns a String description of the current value.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual string FormatInstance()
Visual Basic
Public Overridable Function FormatInstance As String

Implements

IGH_GooProxy..::..FormatInstance()()()()

Remarks

If the implementation IsParsable(), then this representation must be in parsable format.

See Also

GH_GooProxy<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


FromString Method

[image]

Grasshopper SDK
GH_GooProxy<(Of <(<'T>)>)>..::..FromString Method
GH_GooProxy<(Of <(<'T>)>)> Class See Also Send Feedback
If IsParsable(), then attempts to convert the string to a generic type value

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool FromString(
    string in
)
Visual Basic
Public Overridable Function FromString ( _
    in As String _
) As Boolean

Parameters

in
Type: System..::..String
The String to parse.

Return Value

True on success, false on failure. This method should not throw exceptions.

Implements

IGH_GooProxy..::..FromString(String)

See Also

GH_GooProxy<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


MutateString Method

[image]

Grasshopper SDK
GH_GooProxy<(Of <(<'T>)>)>..::..MutateString Method
GH_GooProxy<(Of <(<'T>)>)> Class See Also Send Feedback
Munge a string to remove obvious errors on account of the user.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual string MutateString(
    string in
)
Visual Basic
Public Overridable Function MutateString ( _
    in As String _
) As String

Parameters

in
Type: System..::..String

Implements

IGH_GooProxy..::..MutateString(String)

See Also

GH_GooProxy<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


NumberToString Method

[image]

Grasshopper SDK
GH_GooProxy<(Of <(<'T>)>)>..::..NumberToString Method
GH_GooProxy<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected string NumberToString(
    double number
)
Visual Basic
Protected Function NumberToString ( _
    number As Double _
) As String

Parameters

number
Type: System..::..Double

See Also

GH_GooProxy<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


StringToNumber Method

[image]

Grasshopper SDK
GH_GooProxy<(Of <(<'T>)>)>..::..StringToNumber Method
GH_GooProxy<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected double StringToNumber(
    string text
)
Visual Basic
Protected Function StringToNumber ( _
    text As String _
) As Double

Parameters

text
Type: System..::..String

See Also

GH_GooProxy<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_GooProxy<(Of <(<'T>)>)>..::..ToString Method
GH_GooProxy<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_GooProxy<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


GH_GooProxy(T) Properties

[image] [image]

Grasshopper SDK
GH_GooProxy<(Of <(<'T>)>)> Properties
GH_GooProxy<(Of <(<'T>)>)> Class See Also Send Feedback

The GH_GooProxy<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | IsParsable | Gets a value indicating whether or not the type can be instantiated from a String.
Protected property | Owner |
Public property | ProxyOwner | Gets the piece of Grasshopper data that spawned this proxy.
Public property | TypeDescription |
Public property | TypeName |
Public property | UserString | Gets or sets the user-defined string that describes this proxy. This only really makes sense if the Proxy is Parsable.
Public property | Valid | Gets a value indicating whether this proxy represents valid data.

See Also

GH_GooProxy<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


IsParsable Property

[image]

Grasshopper SDK
GH_GooProxy<(Of <(<'T>)>)>..::..IsParsable Property
GH_GooProxy<(Of <(<'T>)>)> Class See Also Send Feedback
Gets a value indicating whether or not the type can be instantiated from a String.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool IsParsable { get; }
Visual Basic
Public Overridable ReadOnly Property IsParsable As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_GooProxy`1.IsParsable"]

Implements

IGH_GooProxy..::..IsParsable

See Also

GH_GooProxy<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


Owner Property

[image]

Grasshopper SDK
GH_GooProxy<(Of <(<'T>)>)>..::..Owner Property
GH_GooProxy<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected T Owner { get; }
Visual Basic
Protected ReadOnly Property Owner As T
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_GooProxy`1.Owner"]

See Also

GH_GooProxy<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


ProxyOwner Property

[image]

Grasshopper SDK
GH_GooProxy<(Of <(<'T>)>)>..::..ProxyOwner Property
GH_GooProxy<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the piece of Grasshopper data that spawned this proxy.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_Goo ProxyOwner { get; }
Visual Basic
Public ReadOnly Property ProxyOwner As IGH_Goo
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_GooProxy`1.ProxyOwner"]

Implements

IGH_GooProxy..::..ProxyOwner

See Also

GH_GooProxy<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


TypeDescription Property

[image]

Grasshopper SDK
GH_GooProxy<(Of <(<'T>)>)>..::..TypeDescription Property
GH_GooProxy<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string TypeDescription { get; }
Visual Basic
Public ReadOnly Property TypeDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_GooProxy`1.TypeDescription"]

See Also

GH_GooProxy<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


TypeName Property

[image]

Grasshopper SDK
GH_GooProxy<(Of <(<'T>)>)>..::..TypeName Property
GH_GooProxy<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string TypeName { get; }
Visual Basic
Public ReadOnly Property TypeName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_GooProxy`1.TypeName"]

See Also

GH_GooProxy<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


UserString Property

[image]

Grasshopper SDK
GH_GooProxy<(Of <(<'T>)>)>..::..UserString Property
GH_GooProxy<(Of <(<'T>)>)> Class See Also Send Feedback
Gets or sets the user-defined string that describes this proxy. This only really makes sense if the Proxy is Parsable.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string UserString { get; set; }
Visual Basic
Public Property UserString As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_GooProxy`1.UserString"]

Return Value

The UserString value or the value of FormatInstance() if UserString has not been assigned.

Implements

IGH_GooProxy..::..UserString

See Also

GH_GooProxy<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


Valid Property

[image]

Grasshopper SDK
GH_GooProxy<(Of <(<'T>)>)>..::..Valid Property
GH_GooProxy<(Of <(<'T>)>)> Class See Also Send Feedback
Gets a value indicating whether this proxy represents valid data.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool Valid { get; }
Visual Basic
Public Overridable ReadOnly Property Valid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_GooProxy`1.Valid"]

Implements

IGH_GooProxy..::..Valid

See Also

GH_GooProxy<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Types Namespace


GH_Guid Class

[image]

Grasshopper SDK
GH_Guid Class
Members See Also Send Feedback
Represents a globally unique identifier. GH_Guid re-implements the framework System.Guid type.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Guid : GH_Goo<Guid>
Visual Basic
Public Class GH_Guid _
    Inherits GH_Goo(Of Guid)

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_Goo <(Of <(<' Guid >)>)>
Grasshopper.Kernel.Types..::..GH_Guid

See Also

GH_Guid Members
Grasshopper.Kernel.Types Namespace


GH_Guid Members

[image] [image]

Grasshopper SDK
GH_Guid Members
GH_Guid Class Constructors Methods Fields Properties See Also Send Feedback

The GH_Guid type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Guid()()()() | Blank constructor
Public method | GH_Guid(Guid) | Initializes a new instance of the GH_Guid class
Public method | GH_Guid(GH_Guid) | Initializes a new instance of the GH_Guid class

Methods

 | Name | Description
Public method | CastFrom | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | Duplicate | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateGuid |
Public method | EmitProxy | (Overrides GH_Goo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ToString | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | IsValid | Gets the validity of this instance. Guids are always valid. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the internal data. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Guid Class
Grasshopper.Kernel.Types Namespace


GH_Guid Constructor

[image] [image]

Grasshopper SDK
GH_Guid Constructor
GH_Guid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Guid()()()() | Blank constructor
Public method | GH_Guid(Guid) | Initializes a new instance of the GH_Guid class
Public method | GH_Guid(GH_Guid) | Initializes a new instance of the GH_Guid class

See Also

GH_Guid Class
GH_Guid Members
Grasshopper.Kernel.Types Namespace


GH_Guid Constructor

[image]

Grasshopper SDK
GH_Guid Constructor
GH_Guid Class See Also Send Feedback
Blank constructor

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Guid()
Visual Basic
Public Sub New

See Also

GH_Guid Class
GH_Guid Overload
Grasshopper.Kernel.Types Namespace


GH_Guid Constructor (Guid)

[image]

Grasshopper SDK
GH_Guid Constructor (Guid)
GH_Guid Class See Also Send Feedback
Initializes a new instance of the GH_Guid class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Guid(
    Guid id
)
Visual Basic
Public Sub New ( _
    id As Guid _
)

Parameters

id
Type: System..::..Guid

See Also

GH_Guid Class
GH_Guid Overload
Grasshopper.Kernel.Types Namespace


GH_Guid Constructor (GH_Guid)

[image]

Grasshopper SDK
GH_Guid Constructor (GH_Guid)
GH_Guid Class See Also Send Feedback
Initializes a new instance of the GH_Guid class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Guid(
    GH_Guid other
)
Visual Basic
Public Sub New ( _
    other As GH_Guid _
)

Parameters

other
Type: Grasshopper.Kernel.Types..::..GH_Guid

See Also

GH_Guid Class
GH_Guid Overload
Grasshopper.Kernel.Types Namespace


GH_Guid Fields

[image] [image]

Grasshopper SDK
GH_Guid Fields
GH_Guid Class See Also Send Feedback

The GH_Guid type exposes the following members.

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Guid Class
Grasshopper.Kernel.Types Namespace


GH_Guid Methods

[image] [image]

Grasshopper SDK
GH_Guid Methods
GH_Guid Class See Also Send Feedback

The GH_Guid type exposes the following members.

Methods

 | Name | Description
Public method | CastFrom | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | Duplicate | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateGuid |
Public method | EmitProxy | (Overrides GH_Goo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ToString | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

See Also

GH_Guid Class
Grasshopper.Kernel.Types Namespace


CastFrom Method

[image]

Grasshopper SDK
GH_Guid..::..CastFrom Method
GH_Guid Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastFrom(
    Object source
)
Visual Basic
Public Overrides Function CastFrom ( _
    source As Object _
) As Boolean

Parameters

source
Type: System..::..Object

See Also

GH_Guid Class
Grasshopper.Kernel.Types Namespace


CastTo Method

[image] [image]

Grasshopper SDK
GH_Guid..::..CastTo Method
GH_Guid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)

See Also

GH_Guid Class
GH_Guid Members
Grasshopper.Kernel.Types Namespace


CastTo(T) Method (T)

[image]

Grasshopper SDK
GH_Guid..::..CastTo<(Of <(<'T>)>)> Method (T%)
GH_Guid Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastTo<T>(
    out T target
)
Visual Basic
Public Overrides Function CastTo(Of T) ( _
    <OutAttribute> ByRef target As T _
) As Boolean

Parameters

target
Type: T%

Type Parameters

T

See Also

GH_Guid Class
CastTo Overload
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_Guid..::..Duplicate Method
GH_Guid Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_Goo Duplicate()
Visual Basic
Public Overrides Function Duplicate As IGH_Goo

See Also

GH_Guid Class
Grasshopper.Kernel.Types Namespace


DuplicateGuid Method

[image]

Grasshopper SDK
GH_Guid..::..DuplicateGuid Method
GH_Guid Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Guid DuplicateGuid()
Visual Basic
Public Function DuplicateGuid As GH_Guid

See Also

GH_Guid Class
Grasshopper.Kernel.Types Namespace


EmitProxy Method

[image]

Grasshopper SDK
GH_Guid..::..EmitProxy Method
GH_Guid Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GooProxy EmitProxy()
Visual Basic
Public Overrides Function EmitProxy As IGH_GooProxy

See Also

GH_Guid Class
Grasshopper.Kernel.Types Namespace


Read Method

[image]

Grasshopper SDK
GH_Guid..::..Read Method
GH_Guid Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

See Also

GH_Guid Class
Grasshopper.Kernel.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_Guid..::..ToString Method
GH_Guid Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_Guid Class
Grasshopper.Kernel.Types Namespace


Write Method

[image]

Grasshopper SDK
GH_Guid..::..Write Method
GH_Guid Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overrides Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

See Also

GH_Guid Class
Grasshopper.Kernel.Types Namespace


GH_Guid Properties

[image] [image]

Grasshopper SDK
GH_Guid Properties
GH_Guid Class See Also Send Feedback

The GH_Guid type exposes the following members.

Properties

 | Name | Description
Public property | IsValid | Gets the validity of this instance. Guids are always valid. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the internal data. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Guid Class
Grasshopper.Kernel.Types Namespace


IsValid Property

[image]

Grasshopper SDK
GH_Guid..::..IsValid Property
GH_Guid Class See Also Send Feedback
Gets the validity of this instance. Guids are always valid.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool IsValid { get; }
Visual Basic
Public Overrides ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Guid.IsValid"]

See Also

GH_Guid Class
Grasshopper.Kernel.Types Namespace


TypeDescription Property

[image]

Grasshopper SDK
GH_Guid..::..TypeDescription Property
GH_Guid Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeDescription { get; }
Visual Basic
Public Overrides ReadOnly Property TypeDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Guid.TypeDescription"]

See Also

GH_Guid Class
Grasshopper.Kernel.Types Namespace


TypeName Property

[image]

Grasshopper SDK
GH_Guid..::..TypeName Property
GH_Guid Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeName { get; }
Visual Basic
Public Overrides ReadOnly Property TypeName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Guid.TypeName"]

See Also

GH_Guid Class
Grasshopper.Kernel.Types Namespace


GH_Integer Class

[image]

Grasshopper SDK
GH_Integer Class
Members See Also Send Feedback
Represents a 32-bit signed integer. GH_Integer re-implements the framework System.Int32 type.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Integer : GH_Goo<int>,
    IGH_QuickCast
Visual Basic
Public Class GH_Integer _
    Inherits GH_Goo(Of Integer) _
    Implements IGH_QuickCast

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_Goo <(Of <(<' Int32 >)>)>
Grasshopper.Kernel.Types..::..GH_Integer

See Also

GH_Integer Members
Grasshopper.Kernel.Types Namespace


GH_Integer Members

[image] [image]

Grasshopper SDK
GH_Integer Members
GH_Integer Class Constructors Methods Fields Properties See Also Send Feedback

The GH_Integer type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Integer()()()() | Blank constructor
Public method | GH_Integer(Int32) | Initializes a new instance of the GH_Integer class
Public method | GH_Integer(GH_Integer) | Initializes a new instance of the GH_Integer class

Methods

 | Name | Description
Public method | CastFrom | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | Duplicate | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateInteger |
Public method | EmitProxy | (Overrides GH_Goo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ToString | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | IsValid | Gets the validity of this instance. Integers are always valid. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the internal data. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Integer Class
Grasshopper.Kernel.Types Namespace


GH_Integer Constructor

[image] [image]

Grasshopper SDK
GH_Integer Constructor
GH_Integer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Integer()()()() | Blank constructor
Public method | GH_Integer(Int32) | Initializes a new instance of the GH_Integer class
Public method | GH_Integer(GH_Integer) | Initializes a new instance of the GH_Integer class

See Also

GH_Integer Class
GH_Integer Members
Grasshopper.Kernel.Types Namespace


GH_Integer Constructor

[image]

Grasshopper SDK
GH_Integer Constructor
GH_Integer Class See Also Send Feedback
Blank constructor

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Integer()
Visual Basic
Public Sub New

See Also

GH_Integer Class
GH_Integer Overload
Grasshopper.Kernel.Types Namespace


GH_Integer Constructor (Int32)

[image]

Grasshopper SDK
GH_Integer Constructor (Int32)
GH_Integer Class See Also Send Feedback
Initializes a new instance of the GH_Integer class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Integer(
    int number
)
Visual Basic
Public Sub New ( _
    number As Integer _
)

Parameters

number
Type: System..::..Int32

See Also

GH_Integer Class
GH_Integer Overload
Grasshopper.Kernel.Types Namespace


GH_Integer Constructor (GH_Integer)

[image]

Grasshopper SDK
GH_Integer Constructor (GH_Integer)
GH_Integer Class See Also Send Feedback
Initializes a new instance of the GH_Integer class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Integer(
    GH_Integer other
)
Visual Basic
Public Sub New ( _
    other As GH_Integer _
)

Parameters

other
Type: Grasshopper.Kernel.Types..::..GH_Integer

See Also

GH_Integer Class
GH_Integer Overload
Grasshopper.Kernel.Types Namespace


GH_Integer Fields

[image] [image]

Grasshopper SDK
GH_Integer Fields
GH_Integer Class See Also Send Feedback

The GH_Integer type exposes the following members.

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Integer Class
Grasshopper.Kernel.Types Namespace


GH_Integer Methods

[image] [image]

Grasshopper SDK
GH_Integer Methods
GH_Integer Class See Also Send Feedback

The GH_Integer type exposes the following members.

Methods

 | Name | Description
Public method | CastFrom | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | Duplicate | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateInteger |
Public method | EmitProxy | (Overrides GH_Goo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ToString | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

See Also

GH_Integer Class
Grasshopper.Kernel.Types Namespace


CastFrom Method

[image]

Grasshopper SDK
GH_Integer..::..CastFrom Method
GH_Integer Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastFrom(
    Object source
)
Visual Basic
Public Overrides Function CastFrom ( _
    source As Object _
) As Boolean

Parameters

source
Type: System..::..Object

See Also

GH_Integer Class
Grasshopper.Kernel.Types Namespace


CastTo Method

[image] [image]

Grasshopper SDK
GH_Integer..::..CastTo Method
GH_Integer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)

See Also

GH_Integer Class
GH_Integer Members
Grasshopper.Kernel.Types Namespace


CastTo(T) Method (T)

[image]

Grasshopper SDK
GH_Integer..::..CastTo<(Of <(<'T>)>)> Method (T%)
GH_Integer Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastTo<T>(
    out T target
)
Visual Basic
Public Overrides Function CastTo(Of T) ( _
    <OutAttribute> ByRef target As T _
) As Boolean

Parameters

target
Type: T%

Type Parameters

T

See Also

GH_Integer Class
CastTo Overload
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_Integer..::..Duplicate Method
GH_Integer Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_Goo Duplicate()
Visual Basic
Public Overrides Function Duplicate As IGH_Goo

See Also

GH_Integer Class
Grasshopper.Kernel.Types Namespace


DuplicateInteger Method

[image]

Grasshopper SDK
GH_Integer..::..DuplicateInteger Method
GH_Integer Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Integer DuplicateInteger()
Visual Basic
Public Function DuplicateInteger As GH_Integer

See Also

GH_Integer Class
Grasshopper.Kernel.Types Namespace


EmitProxy Method

[image]

Grasshopper SDK
GH_Integer..::..EmitProxy Method
GH_Integer Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GooProxy EmitProxy()
Visual Basic
Public Overrides Function EmitProxy As IGH_GooProxy

See Also

GH_Integer Class
Grasshopper.Kernel.Types Namespace


Read Method

[image]

Grasshopper SDK
GH_Integer..::..Read Method
GH_Integer Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

See Also

GH_Integer Class
Grasshopper.Kernel.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_Integer..::..ToString Method
GH_Integer Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_Integer Class
Grasshopper.Kernel.Types Namespace


Write Method

[image]

Grasshopper SDK
GH_Integer..::..Write Method
GH_Integer Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overrides Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

See Also

GH_Integer Class
Grasshopper.Kernel.Types Namespace


GH_Integer Properties

[image] [image]

Grasshopper SDK
GH_Integer Properties
GH_Integer Class See Also Send Feedback

The GH_Integer type exposes the following members.

Properties

 | Name | Description
Public property | IsValid | Gets the validity of this instance. Integers are always valid. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the internal data. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Integer Class
Grasshopper.Kernel.Types Namespace


IsValid Property

[image]

Grasshopper SDK
GH_Integer..::..IsValid Property
GH_Integer Class See Also Send Feedback
Gets the validity of this instance. Integers are always valid.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool IsValid { get; }
Visual Basic
Public Overrides ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Integer.IsValid"]

See Also

GH_Integer Class
Grasshopper.Kernel.Types Namespace


TypeDescription Property

[image]

Grasshopper SDK
GH_Integer..::..TypeDescription Property
GH_Integer Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeDescription { get; }
Visual Basic
Public Overrides ReadOnly Property TypeDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Integer.TypeDescription"]

See Also

GH_Integer Class
Grasshopper.Kernel.Types Namespace


TypeName Property

[image]

Grasshopper SDK
GH_Integer..::..TypeName Property
GH_Integer Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeName { get; }
Visual Basic
Public Overrides ReadOnly Property TypeName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Integer.TypeName"]

See Also

GH_Integer Class
Grasshopper.Kernel.Types Namespace


GH_Interval Class

[image]

Grasshopper SDK
GH_Interval Class
Members See Also Send Feedback
Represents a one-dimensional numeric domain.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Interval : GH_Goo<Interval>,
    IGH_QuickCast
Visual Basic
Public Class GH_Interval _
    Inherits GH_Goo(Of Interval) _
    Implements IGH_QuickCast

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_Goo <(Of <(<'Interval>)>)>
Grasshopper.Kernel.Types..::..GH_Interval

See Also

GH_Interval Members
Grasshopper.Kernel.Types Namespace


GH_Interval Members

[image] [image]

Grasshopper SDK
GH_Interval Members
GH_Interval Class Constructors Methods Fields Properties See Also Send Feedback

The GH_Interval type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Interval()()()() | Default constructor
Public method | GH_Interval(Interval) | Create a duplicate of another interval
Public method | GH_Interval(GH_Interval) | Create a duplicate from another interval.

Methods

 | Name | Description
Public method | CastFrom | Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic. (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | Local to Remote caster function. this stuff is complex, don't concern yourself with casting logic. (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | Duplicate | Create a duplicate of this interval. (Overrides GH_Goo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateInterval | Create a duplicate of this interval.
Public method | EmitProxy | Returns a proxy that represents this interval. Do not call this function unless you're (Overrides GH_Goo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ToString | Format the interval using default grasshopper formatting logic. (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | IsValid | Gets the validity of this instance. Intervals are invalid if either of the extremes is a #NaN. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the internal data. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Interval Class
Grasshopper.Kernel.Types Namespace


GH_Interval Constructor

[image] [image]

Grasshopper SDK
GH_Interval Constructor
GH_Interval Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Interval()()()() | Default constructor
Public method | GH_Interval(Interval) | Create a duplicate of another interval
Public method | GH_Interval(GH_Interval) | Create a duplicate from another interval.

See Also

GH_Interval Class
GH_Interval Members
Grasshopper.Kernel.Types Namespace


GH_Interval Constructor

[image]

Grasshopper SDK
GH_Interval Constructor
GH_Interval Class See Also Send Feedback
Default constructor

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Interval()
Visual Basic
Public Sub New

See Also

GH_Interval Class
GH_Interval Overload
Grasshopper.Kernel.Types Namespace


GH_Interval Constructor ()

[image]

Grasshopper SDK
GH_Interval Constructor ()
GH_Interval Class See Also Send Feedback
Create a duplicate of another interval

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Interval(
    Interval interval
)
Visual Basic
Public Sub New ( _
    interval As Interval _
)

Parameters

interval
Type: Interval
Interval to copy. If null, a default interval will be created.

See Also

GH_Interval Class
GH_Interval Overload
Grasshopper.Kernel.Types Namespace


GH_Interval Constructor (GH_Interval)

[image]

Grasshopper SDK
GH_Interval Constructor (GH_Interval)
GH_Interval Class See Also Send Feedback
Create a duplicate from another interval.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Interval(
    GH_Interval other
)
Visual Basic
Public Sub New ( _
    other As GH_Interval _
)

Parameters

other
Type: Grasshopper.Kernel.Types..::..GH_Interval
Interval start

See Also

GH_Interval Class
GH_Interval Overload
Grasshopper.Kernel.Types Namespace


GH_Interval Fields

[image] [image]

Grasshopper SDK
GH_Interval Fields
GH_Interval Class See Also Send Feedback

The GH_Interval type exposes the following members.

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Interval Class
Grasshopper.Kernel.Types Namespace


GH_Interval Methods

[image] [image]

Grasshopper SDK
GH_Interval Methods
GH_Interval Class See Also Send Feedback

The GH_Interval type exposes the following members.

Methods

 | Name | Description
Public method | CastFrom | Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic. (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | Local to Remote caster function. this stuff is complex, don't concern yourself with casting logic. (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | Duplicate | Create a duplicate of this interval. (Overrides GH_Goo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateInterval | Create a duplicate of this interval.
Public method | EmitProxy | Returns a proxy that represents this interval. Do not call this function unless you're (Overrides GH_Goo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ToString | Format the interval using default grasshopper formatting logic. (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

See Also

GH_Interval Class
Grasshopper.Kernel.Types Namespace


CastFrom Method

[image]

Grasshopper SDK
GH_Interval..::..CastFrom Method
GH_Interval Class See Also Send Feedback
Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastFrom(
    Object source
)
Visual Basic
Public Overrides Function CastFrom ( _
    source As Object _
) As Boolean

Parameters

source
Type: System..::..Object

See Also

GH_Interval Class
Grasshopper.Kernel.Types Namespace


CastTo Method

[image] [image]

Grasshopper SDK
GH_Interval..::..CastTo Method
GH_Interval Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | Local to Remote caster function. this stuff is complex, don't concern yourself with casting logic. (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)

See Also

GH_Interval Class
GH_Interval Members
Grasshopper.Kernel.Types Namespace


CastTo(T) Method (T)

[image]

Grasshopper SDK
GH_Interval..::..CastTo<(Of <(<'T>)>)> Method (T%)
GH_Interval Class See Also Send Feedback
Local to Remote caster function. this stuff is complex, don't concern yourself with casting logic.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastTo<T>(
    out T target
)
Visual Basic
Public Overrides Function CastTo(Of T) ( _
    <OutAttribute> ByRef target As T _
) As Boolean

Parameters

target
Type: T%

Type Parameters

T

See Also

GH_Interval Class
CastTo Overload
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_Interval..::..Duplicate Method
GH_Interval Class See Also Send Feedback
Create a duplicate of this interval.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_Goo Duplicate()
Visual Basic
Public Overrides Function Duplicate As IGH_Goo

See Also

GH_Interval Class
Grasshopper.Kernel.Types Namespace


DuplicateInterval Method

[image]

Grasshopper SDK
GH_Interval..::..DuplicateInterval Method
GH_Interval Class See Also Send Feedback
Create a duplicate of this interval.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Interval DuplicateInterval()
Visual Basic
Public Function DuplicateInterval As GH_Interval

See Also

GH_Interval Class
Grasshopper.Kernel.Types Namespace


EmitProxy Method

[image]

Grasshopper SDK
GH_Interval..::..EmitProxy Method
GH_Interval Class See Also Send Feedback
Returns a proxy that represents this interval. Do not call this function unless you're

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GooProxy EmitProxy()
Visual Basic
Public Overrides Function EmitProxy As IGH_GooProxy

See Also

GH_Interval Class
Grasshopper.Kernel.Types Namespace


Read Method

[image]

Grasshopper SDK
GH_Interval..::..Read Method
GH_Interval Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

See Also

GH_Interval Class
Grasshopper.Kernel.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_Interval..::..ToString Method
GH_Interval Class See Also Send Feedback
Format the interval using default grasshopper formatting logic.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_Interval Class
Grasshopper.Kernel.Types Namespace


Write Method

[image]

Grasshopper SDK
GH_Interval..::..Write Method
GH_Interval Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overrides Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

See Also

GH_Interval Class
Grasshopper.Kernel.Types Namespace


GH_Interval Properties

[image] [image]

Grasshopper SDK
GH_Interval Properties
GH_Interval Class See Also Send Feedback

The GH_Interval type exposes the following members.

Properties

 | Name | Description
Public property | IsValid | Gets the validity of this instance. Intervals are invalid if either of the extremes is a #NaN. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the internal data. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Interval Class
Grasshopper.Kernel.Types Namespace


IsValid Property

[image]

Grasshopper SDK
GH_Interval..::..IsValid Property
GH_Interval Class See Also Send Feedback
Gets the validity of this instance. Intervals are invalid if either of the extremes is a #NaN.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool IsValid { get; }
Visual Basic
Public Overrides ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Interval.IsValid"]

See Also

GH_Interval Class
Grasshopper.Kernel.Types Namespace


IsValidWhyNot Property

[image]

Grasshopper SDK
GH_Interval..::..IsValidWhyNot Property
GH_Interval Class See Also Send Feedback
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string IsValidWhyNot { get; }
Visual Basic
Public Overrides ReadOnly Property IsValidWhyNot As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Interval.IsValidWhyNot"]

See Also

GH_Interval Class
Grasshopper.Kernel.Types Namespace


TypeDescription Property

[image]

Grasshopper SDK
GH_Interval..::..TypeDescription Property
GH_Interval Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeDescription { get; }
Visual Basic
Public Overrides ReadOnly Property TypeDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Interval.TypeDescription"]

See Also

GH_Interval Class
Grasshopper.Kernel.Types Namespace


TypeName Property

[image]

Grasshopper SDK
GH_Interval..::..TypeName Property
GH_Interval Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeName { get; }
Visual Basic
Public Overrides ReadOnly Property TypeName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Interval.TypeName"]

See Also

GH_Interval Class
Grasshopper.Kernel.Types Namespace


GH_Interval2D Class

[image]

Grasshopper SDK
GH_Interval2D Class
Members See Also Send Feedback
Represents a two-dimensional numeric domain.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Interval2D : GH_Goo<UVInterval>
Visual Basic
Public Class GH_Interval2D _
    Inherits GH_Goo(Of UVInterval)

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_Goo <(Of <(<' UVInterval >)>)>
Grasshopper.Kernel.Types..::..GH_Interval2D

See Also

GH_Interval2D Members
Grasshopper.Kernel.Types Namespace


GH_Interval2D Members

[image] [image]

Grasshopper SDK
GH_Interval2D Members
GH_Interval2D Class Constructors Methods Fields Properties See Also Send Feedback

The GH_Interval2D type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Interval2D()()()() | Default constructor. Creates two empty intervals.
Public method | GH_Interval2D(GH_Interval2D) | Create a duplicate of another two-dimensional interval
Public method | GH_Interval2D(UVInterval) | Duplicates a one-dimensional interval in both directions.

Methods

 | Name | Description
Public method | CastFrom | Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic. (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | Local to Remote caster function. this stuff is complex, don't concern yourself with casting logic. (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | Duplicate | Create a duplicate of this interval. (Overrides GH_Goo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateInterval | Create a duplicate of this interval.
Public method | EmitProxy | Returns a proxy that represents this interval. Do not call this function unless you're (Overrides GH_Goo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ToString | Format the interval using default grasshopper formatting logic. (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | IsValid | Gets the validity of this instance. Valid intervals contain no #NaN extremes (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the internal data. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Interval2D Class
Grasshopper.Kernel.Types Namespace


GH_Interval2D Constructor

[image] [image]

Grasshopper SDK
GH_Interval2D Constructor
GH_Interval2D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Interval2D()()()() | Default constructor. Creates two empty intervals.
Public method | GH_Interval2D(GH_Interval2D) | Create a duplicate of another two-dimensional interval
Public method | GH_Interval2D(UVInterval) | Duplicates a one-dimensional interval in both directions.

See Also

GH_Interval2D Class
GH_Interval2D Members
Grasshopper.Kernel.Types Namespace


GH_Interval2D Constructor

[image]

Grasshopper SDK
GH_Interval2D Constructor
GH_Interval2D Class See Also Send Feedback
Default constructor. Creates two empty intervals.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Interval2D()
Visual Basic
Public Sub New

See Also

GH_Interval2D Class
GH_Interval2D Overload
Grasshopper.Kernel.Types Namespace


GH_Interval2D Constructor (GH_Interval2D)

[image]

Grasshopper SDK
GH_Interval2D Constructor (GH_Interval2D)
GH_Interval2D Class See Also Send Feedback
Create a duplicate of another two-dimensional interval

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Interval2D(
    GH_Interval2D other
)
Visual Basic
Public Sub New ( _
    other As GH_Interval2D _
)

Parameters

other
Type: Grasshopper.Kernel.Types..::..GH_Interval2D
Interval to copy. If null, a default interval will be created.

See Also

GH_Interval2D Class
GH_Interval2D Overload
Grasshopper.Kernel.Types Namespace


GH_Interval2D Constructor (UVInterval)

[image]

Grasshopper SDK
GH_Interval2D Constructor (UVInterval)
GH_Interval2D Class See Also Send Feedback
Duplicates a one-dimensional interval in both directions.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Interval2D(
    UVInterval uv
)
Visual Basic
Public Sub New ( _
    uv As UVInterval _
)

Parameters

uv
Type: Grasshopper.Kernel.Types..::..UVInterval
UVInterval value.

See Also

GH_Interval2D Class
GH_Interval2D Overload
Grasshopper.Kernel.Types Namespace


GH_Interval2D Fields

[image] [image]

Grasshopper SDK
GH_Interval2D Fields
GH_Interval2D Class See Also Send Feedback

The GH_Interval2D type exposes the following members.

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Interval2D Class
Grasshopper.Kernel.Types Namespace


GH_Interval2D Methods

[image] [image]

Grasshopper SDK
GH_Interval2D Methods
GH_Interval2D Class See Also Send Feedback

The GH_Interval2D type exposes the following members.

Methods

 | Name | Description
Public method | CastFrom | Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic. (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | Local to Remote caster function. this stuff is complex, don't concern yourself with casting logic. (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | Duplicate | Create a duplicate of this interval. (Overrides GH_Goo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateInterval | Create a duplicate of this interval.
Public method | EmitProxy | Returns a proxy that represents this interval. Do not call this function unless you're (Overrides GH_Goo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ToString | Format the interval using default grasshopper formatting logic. (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

See Also

GH_Interval2D Class
Grasshopper.Kernel.Types Namespace


CastFrom Method

[image]

Grasshopper SDK
GH_Interval2D..::..CastFrom Method
GH_Interval2D Class See Also Send Feedback
Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastFrom(
    Object source
)
Visual Basic
Public Overrides Function CastFrom ( _
    source As Object _
) As Boolean

Parameters

source
Type: System..::..Object

See Also

GH_Interval2D Class
Grasshopper.Kernel.Types Namespace


CastTo Method

[image] [image]

Grasshopper SDK
GH_Interval2D..::..CastTo Method
GH_Interval2D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | Local to Remote caster function. this stuff is complex, don't concern yourself with casting logic. (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)

See Also

GH_Interval2D Class
GH_Interval2D Members
Grasshopper.Kernel.Types Namespace


CastTo(T) Method (T)

[image]

Grasshopper SDK
GH_Interval2D..::..CastTo<(Of <(<'T>)>)> Method (T%)
GH_Interval2D Class See Also Send Feedback
Local to Remote caster function. this stuff is complex, don't concern yourself with casting logic.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastTo<T>(
    ref T target
)
Visual Basic
Public Overrides Function CastTo(Of T) ( _
    ByRef target As T _
) As Boolean

Parameters

target
Type: T%

Type Parameters

T

See Also

GH_Interval2D Class
CastTo Overload
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_Interval2D..::..Duplicate Method
GH_Interval2D Class See Also Send Feedback
Create a duplicate of this interval.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_Goo Duplicate()
Visual Basic
Public Overrides Function Duplicate As IGH_Goo

See Also

GH_Interval2D Class
Grasshopper.Kernel.Types Namespace


DuplicateInterval Method

[image]

Grasshopper SDK
GH_Interval2D..::..DuplicateInterval Method
GH_Interval2D Class See Also Send Feedback
Create a duplicate of this interval.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Interval2D DuplicateInterval()
Visual Basic
Public Function DuplicateInterval As GH_Interval2D

See Also

GH_Interval2D Class
Grasshopper.Kernel.Types Namespace


EmitProxy Method

[image]

Grasshopper SDK
GH_Interval2D..::..EmitProxy Method
GH_Interval2D Class See Also Send Feedback
Returns a proxy that represents this interval. Do not call this function unless you're

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GooProxy EmitProxy()
Visual Basic
Public Overrides Function EmitProxy As IGH_GooProxy

See Also

GH_Interval2D Class
Grasshopper.Kernel.Types Namespace


Read Method

[image]

Grasshopper SDK
GH_Interval2D..::..Read Method
GH_Interval2D Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

See Also

GH_Interval2D Class
Grasshopper.Kernel.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_Interval2D..::..ToString Method
GH_Interval2D Class See Also Send Feedback
Format the interval using default grasshopper formatting logic.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_Interval2D Class
Grasshopper.Kernel.Types Namespace


Write Method

[image]

Grasshopper SDK
GH_Interval2D..::..Write Method
GH_Interval2D Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overrides Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

See Also

GH_Interval2D Class
Grasshopper.Kernel.Types Namespace


GH_Interval2D Properties

[image] [image]

Grasshopper SDK
GH_Interval2D Properties
GH_Interval2D Class See Also Send Feedback

The GH_Interval2D type exposes the following members.

Properties

 | Name | Description
Public property | IsValid | Gets the validity of this instance. Valid intervals contain no #NaN extremes (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the internal data. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Interval2D Class
Grasshopper.Kernel.Types Namespace


IsValid Property

[image]

Grasshopper SDK
GH_Interval2D..::..IsValid Property
GH_Interval2D Class See Also Send Feedback
Gets the validity of this instance. Valid intervals contain no #NaN extremes

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool IsValid { get; }
Visual Basic
Public Overrides ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Interval2D.IsValid"]

See Also

GH_Interval2D Class
Grasshopper.Kernel.Types Namespace


IsValidWhyNot Property

[image]

Grasshopper SDK
GH_Interval2D..::..IsValidWhyNot Property
GH_Interval2D Class See Also Send Feedback
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string IsValidWhyNot { get; }
Visual Basic
Public Overrides ReadOnly Property IsValidWhyNot As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Interval2D.IsValidWhyNot"]

See Also

GH_Interval2D Class
Grasshopper.Kernel.Types Namespace


TypeDescription Property

[image]

Grasshopper SDK
GH_Interval2D..::..TypeDescription Property
GH_Interval2D Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeDescription { get; }
Visual Basic
Public Overrides ReadOnly Property TypeDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Interval2D.TypeDescription"]

See Also

GH_Interval2D Class
Grasshopper.Kernel.Types Namespace


TypeName Property

[image]

Grasshopper SDK
GH_Interval2D..::..TypeName Property
GH_Interval2D Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeName { get; }
Visual Basic
Public Overrides ReadOnly Property TypeName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Interval2D.TypeName"]

See Also

GH_Interval2D Class
Grasshopper.Kernel.Types Namespace


GH_Interval2D.GH_Interval2DProxy Class

[image]

Grasshopper SDK
GH_Interval2D..::..GH_Interval2DProxy Class
GH_Interval2D Class Members See Also Send Feedback
Proxy description of GH_Interval class. This class is used by the Generic Multivalue interfaces.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Interval2DProxy : GH_GooProxy<GH_Interval2D>
Visual Basic
Public Class GH_Interval2DProxy _
    Inherits GH_GooProxy(Of GH_Interval2D)

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_GooProxy <(Of <(<' GH_Interval2D >)>)>
Grasshopper.Kernel.Types..::..GH_Interval2D..::..GH_Interval2DProxy

See Also

GH_Interval2D..::..GH_Interval2DProxy Members
Grasshopper.Kernel.Types Namespace


GH_Interval2D.GH_Interval2DProxy Members

[image] [image]

Grasshopper SDK
GH_Interval2D..::..GH_Interval2DProxy Members
GH_Interval2D..::..GH_Interval2DProxy Class Constructors Methods Properties See Also Send Feedback

Represents a two-dimensional numeric domain.

The GH_Interval2D..::..GH_Interval2DProxy type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Interval2D..::..GH_Interval2DProxy | Initializes a new instance of the GH_Interval2D..::..GH_Interval2DProxy class

Methods

 | Name | Description
Public method | Construct | Override this method to supply a custom UI during proxy construction. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FormatInstance | Returns a String description of the current value. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FromString | If IsParsable(), then attempts to convert the string to a generic type value (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | MutateString | Munge a string to remove obvious errors on account of the user. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | NumberToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | StringToNumber | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | ToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Area |
Public property | IsParsable | Gets a value indicating whether or not the type can be instantiated from a String. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected property | Owner | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | ProxyOwner | Gets the piece of Grasshopper data that spawned this proxy. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeName | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | U0 |
Public property | U1 |
Public property | UIsIncreasing |
Public property | UIsNormalized |
Public property | ULength |
Public property | UMiddle |
Public property | UserString | Gets or sets the user-defined string that describes this proxy. This only really makes sense if the Proxy is Parsable. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | V0 |
Public property | V1 |
Public property | Valid | Gets a value indicating whether this proxy represents valid data. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | VIsIncreasing |
Public property | VIsNormalized |
Public property | VLength |
Public property | VMiddle |

See Also

GH_Interval2D..::..GH_Interval2DProxy Class
Grasshopper.Kernel.Types Namespace


GH_Interval2D.GH_Interval2DProxy Constructor

[image]

Grasshopper SDK
GH_Interval2D..::..GH_Interval2DProxy Constructor
GH_Interval2D..::..GH_Interval2DProxy Class See Also Send Feedback
Initializes a new instance of the GH_Interval2D..::..GH_Interval2DProxy class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Interval2DProxy(
    GH_Interval2D nValue
)
Visual Basic
Public Sub New ( _
    nValue As GH_Interval2D _
)

Parameters

nValue
Type: Grasshopper.Kernel.Types..::..GH_Interval2D

See Also

GH_Interval2D..::..GH_Interval2DProxy Class
Grasshopper.Kernel.Types Namespace


GH_Interval2D.GH_Interval2DProxy Methods

[image] [image]

Grasshopper SDK
GH_Interval2D..::..GH_Interval2DProxy Methods
GH_Interval2D..::..GH_Interval2DProxy Class See Also Send Feedback

The GH_Interval2D..::..GH_Interval2DProxy type exposes the following members.

Methods

 | Name | Description
Public method | Construct | Override this method to supply a custom UI during proxy construction. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FormatInstance | Returns a String description of the current value. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FromString | If IsParsable(), then attempts to convert the string to a generic type value (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | MutateString | Munge a string to remove obvious errors on account of the user. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | NumberToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | StringToNumber | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | ToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

See Also

GH_Interval2D..::..GH_Interval2DProxy Class
Grasshopper.Kernel.Types Namespace


GH_Interval2D.GH_Interval2DProxy Properties

[image] [image]

Grasshopper SDK
GH_Interval2D..::..GH_Interval2DProxy Properties
GH_Interval2D..::..GH_Interval2DProxy Class See Also Send Feedback

The GH_Interval2D..::..GH_Interval2DProxy type exposes the following members.

Properties

 | Name | Description
Public property | Area |
Public property | IsParsable | Gets a value indicating whether or not the type can be instantiated from a String. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected property | Owner | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | ProxyOwner | Gets the piece of Grasshopper data that spawned this proxy. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeName | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | U0 |
Public property | U1 |
Public property | UIsIncreasing |
Public property | UIsNormalized |
Public property | ULength |
Public property | UMiddle |
Public property | UserString | Gets or sets the user-defined string that describes this proxy. This only really makes sense if the Proxy is Parsable. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | V0 |
Public property | V1 |
Public property | Valid | Gets a value indicating whether this proxy represents valid data. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | VIsIncreasing |
Public property | VIsNormalized |
Public property | VLength |
Public property | VMiddle |

See Also

GH_Interval2D..::..GH_Interval2DProxy Class
Grasshopper.Kernel.Types Namespace


Area Property

[image]

Grasshopper SDK
GH_Interval2D..::..GH_Interval2DProxy..::..Area Property
GH_Interval2D..::..GH_Interval2DProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double Area { get; }
Visual Basic
Public ReadOnly Property Area As Double
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Interval2D.GH_Interval2DProxy.Area"]

See Also

GH_Interval2D..::..GH_Interval2DProxy Class
Grasshopper.Kernel.Types Namespace


U0 Property

[image]

Grasshopper SDK
GH_Interval2D..::..GH_Interval2DProxy..::..U0 Property
GH_Interval2D..::..GH_Interval2DProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double U0 { get; set; }
Visual Basic
Public Property U0 As Double
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Interval2D.GH_Interval2DProxy.U0"]

See Also

GH_Interval2D..::..GH_Interval2DProxy Class
Grasshopper.Kernel.Types Namespace


U1 Property

[image]

Grasshopper SDK
GH_Interval2D..::..GH_Interval2DProxy..::..U1 Property
GH_Interval2D..::..GH_Interval2DProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double U1 { get; set; }
Visual Basic
Public Property U1 As Double
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Interval2D.GH_Interval2DProxy.U1"]

See Also

GH_Interval2D..::..GH_Interval2DProxy Class
Grasshopper.Kernel.Types Namespace


UIsIncreasing Property

[image]

Grasshopper SDK
GH_Interval2D..::..GH_Interval2DProxy..::..UIsIncreasing Property
GH_Interval2D..::..GH_Interval2DProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool UIsIncreasing { get; set; }
Visual Basic
Public Property UIsIncreasing As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Interval2D.GH_Interval2DProxy.UIsIncreasing"]

See Also

GH_Interval2D..::..GH_Interval2DProxy Class
Grasshopper.Kernel.Types Namespace


UIsNormalized Property

[image]

Grasshopper SDK
GH_Interval2D..::..GH_Interval2DProxy..::..UIsNormalized Property
GH_Interval2D..::..GH_Interval2DProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool UIsNormalized { get; set; }
Visual Basic
Public Property UIsNormalized As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Interval2D.GH_Interval2DProxy.UIsNormalized"]

See Also

GH_Interval2D..::..GH_Interval2DProxy Class
Grasshopper.Kernel.Types Namespace


ULength Property

[image]

Grasshopper SDK
GH_Interval2D..::..GH_Interval2DProxy..::..ULength Property
GH_Interval2D..::..GH_Interval2DProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double ULength { get; }
Visual Basic
Public ReadOnly Property ULength As Double
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Interval2D.GH_Interval2DProxy.ULength"]

See Also

GH_Interval2D..::..GH_Interval2DProxy Class
Grasshopper.Kernel.Types Namespace


UMiddle Property

[image]

Grasshopper SDK
GH_Interval2D..::..GH_Interval2DProxy..::..UMiddle Property
GH_Interval2D..::..GH_Interval2DProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double UMiddle { get; }
Visual Basic
Public ReadOnly Property UMiddle As Double
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Interval2D.GH_Interval2DProxy.UMiddle"]

See Also

GH_Interval2D..::..GH_Interval2DProxy Class
Grasshopper.Kernel.Types Namespace


V0 Property

[image]

Grasshopper SDK
GH_Interval2D..::..GH_Interval2DProxy..::..V0 Property
GH_Interval2D..::..GH_Interval2DProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double V0 { get; set; }
Visual Basic
Public Property V0 As Double
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Interval2D.GH_Interval2DProxy.V0"]

See Also

GH_Interval2D..::..GH_Interval2DProxy Class
Grasshopper.Kernel.Types Namespace


V1 Property

[image]

Grasshopper SDK
GH_Interval2D..::..GH_Interval2DProxy..::..V1 Property
GH_Interval2D..::..GH_Interval2DProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double V1 { get; set; }
Visual Basic
Public Property V1 As Double
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Interval2D.GH_Interval2DProxy.V1"]

See Also

GH_Interval2D..::..GH_Interval2DProxy Class
Grasshopper.Kernel.Types Namespace


VIsIncreasing Property

[image]

Grasshopper SDK
GH_Interval2D..::..GH_Interval2DProxy..::..VIsIncreasing Property
GH_Interval2D..::..GH_Interval2DProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool VIsIncreasing { get; set; }
Visual Basic
Public Property VIsIncreasing As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Interval2D.GH_Interval2DProxy.VIsIncreasing"]

See Also

GH_Interval2D..::..GH_Interval2DProxy Class
Grasshopper.Kernel.Types Namespace


VIsNormalized Property

[image]

Grasshopper SDK
GH_Interval2D..::..GH_Interval2DProxy..::..VIsNormalized Property
GH_Interval2D..::..GH_Interval2DProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool VIsNormalized { get; set; }
Visual Basic
Public Property VIsNormalized As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Interval2D.GH_Interval2DProxy.VIsNormalized"]

See Also

GH_Interval2D..::..GH_Interval2DProxy Class
Grasshopper.Kernel.Types Namespace


VLength Property

[image]

Grasshopper SDK
GH_Interval2D..::..GH_Interval2DProxy..::..VLength Property
GH_Interval2D..::..GH_Interval2DProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double VLength { get; }
Visual Basic
Public ReadOnly Property VLength As Double
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Interval2D.GH_Interval2DProxy.VLength"]

See Also

GH_Interval2D..::..GH_Interval2DProxy Class
Grasshopper.Kernel.Types Namespace


VMiddle Property

[image]

Grasshopper SDK
GH_Interval2D..::..GH_Interval2DProxy..::..VMiddle Property
GH_Interval2D..::..GH_Interval2DProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double VMiddle { get; }
Visual Basic
Public ReadOnly Property VMiddle As Double
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Interval2D.GH_Interval2DProxy.VMiddle"]

See Also

GH_Interval2D..::..GH_Interval2DProxy Class
Grasshopper.Kernel.Types Namespace


GH_Line Class

[image]

Grasshopper SDK
GH_Line Class
Members See Also Send Feedback
Represents a 3D line segment. GH_Line re-implements the OpenNURBS OnLine class.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Line : GH_GeometricGoo<Line>,
    IGH_BakeAwareData, IGH_PreviewData
Visual Basic
Public Class GH_Line _
    Inherits GH_GeometricGoo(Of Line) _
    Implements IGH_BakeAwareData, IGH_PreviewData

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_Goo <(Of <(<'Line>)>)>
Grasshopper.Kernel.Types..::..GH_GeometricGoo <(Of <(<'Line>)>)>
Grasshopper.Kernel.Types..::..GH_Line

See Also

GH_Line Members
Grasshopper.Kernel.Types Namespace


GH_Line Members

[image] [image]

Grasshopper SDK
GH_Line Members
GH_Line Class Constructors Methods Fields Properties See Also Send Feedback

The GH_Line type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Line()()()() | Default constructor
Public method | GH_Line(Line) | Create a duplicate of another line.
Public method | GH_Line(GH_Line) | Create a duplicate of another line.

Methods

 | Name | Description
Public method | BakeGeometry |
Public method | CastFrom | Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type T. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | ClearCaches | Clears all caches. Typically if the geometry is referenced, this will erase the local copy. If your T is a value-type, you must override this function and specifically unset the local value. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | DrawViewportMeshes |
Public method | DrawViewportWires |
Public method | Duplicate | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateGeometry | Create a duplicate of this line. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..DuplicateGeometry()()()().)
Public method | DuplicateLine | Create a duplicate of this line.
Public method | EmitProxy | Returns a proxy that represents this line. Do not call this function unless you're (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | GetBoundingBox | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..GetBoundingBox(Transform).)
Public method | LoadGeometry()()()() | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | LoadGeometry(RhinoDoc) | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. The default is to always return True. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | Morph | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Morph(SpaceMorph).)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ToString | Format the line using default grasshopper formatting logic. (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Transform | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Transform(Transform).)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Boundingbox | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Boundingbox.)
Public property | ClippingBox |
Public property | IsGeometryLoaded | Gets a value indicating whether or not this geometry is currently loaded (assuming it is referenced). Not all IGH_GeometricGoo implementations support referenced geometry. The default is to always return True. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public property | IsReferencedGeometry | Gets a value indicating whether or not this geometry is referenced. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public property | IsValid | Gets the validity of this instance. Lines with zero length are not considered to be valid. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot.)
Public property | ReferenceID | Gets or sets the Guid of the object that is referenced. Not all IGH_GeometricGoo implementations support referenced geometry. The default implementation is to always return Guid.Empty. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the value of this type. Note that if the type has a ReferenceID this value might get destroyed in the future. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)

See Also

GH_Line Class
Grasshopper.Kernel.Types Namespace


GH_Line Constructor

[image] [image]

Grasshopper SDK
GH_Line Constructor
GH_Line Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Line()()()() | Default constructor
Public method | GH_Line(Line) | Create a duplicate of another line.
Public method | GH_Line(GH_Line) | Create a duplicate of another line.

See Also

GH_Line Class
GH_Line Members
Grasshopper.Kernel.Types Namespace


GH_Line Constructor

[image]

Grasshopper SDK
GH_Line Constructor
GH_Line Class See Also Send Feedback
Default constructor

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Line()
Visual Basic
Public Sub New

See Also

GH_Line Class
GH_Line Overload
Grasshopper.Kernel.Types Namespace


GH_Line Constructor ()

[image]

Grasshopper SDK
GH_Line Constructor ()
GH_Line Class See Also Send Feedback
Create a duplicate of another line.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Line(
    Line line
)
Visual Basic
Public Sub New ( _
    line As Line _
)

Parameters

line
Type: Line
Line to copy. If null, a default line will be created.

See Also

GH_Line Class
GH_Line Overload
Grasshopper.Kernel.Types Namespace


GH_Line Constructor (GH_Line)

[image]

Grasshopper SDK
GH_Line Constructor (GH_Line)
GH_Line Class See Also Send Feedback
Create a duplicate of another line.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Line(
    GH_Line other
)
Visual Basic
Public Sub New ( _
    other As GH_Line _
)

Parameters

other
Type: Grasshopper.Kernel.Types..::..GH_Line
Line to copy. If null, a default line will be created.

See Also

GH_Line Class
GH_Line Overload
Grasshopper.Kernel.Types Namespace


GH_Line Fields

[image] [image]

Grasshopper SDK
GH_Line Fields
GH_Line Class See Also Send Feedback

The GH_Line type exposes the following members.

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Line Class
Grasshopper.Kernel.Types Namespace


GH_Line Methods

[image] [image]

Grasshopper SDK
GH_Line Methods
GH_Line Class See Also Send Feedback

The GH_Line type exposes the following members.

Methods

 | Name | Description
Public method | BakeGeometry |
Public method | CastFrom | Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type T. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | ClearCaches | Clears all caches. Typically if the geometry is referenced, this will erase the local copy. If your T is a value-type, you must override this function and specifically unset the local value. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | DrawViewportMeshes |
Public method | DrawViewportWires |
Public method | Duplicate | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateGeometry | Create a duplicate of this line. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..DuplicateGeometry()()()().)
Public method | DuplicateLine | Create a duplicate of this line.
Public method | EmitProxy | Returns a proxy that represents this line. Do not call this function unless you're (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | GetBoundingBox | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..GetBoundingBox(Transform).)
Public method | LoadGeometry()()()() | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | LoadGeometry(RhinoDoc) | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. The default is to always return True. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | Morph | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Morph(SpaceMorph).)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ToString | Format the line using default grasshopper formatting logic. (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Transform | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Transform(Transform).)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

See Also

GH_Line Class
Grasshopper.Kernel.Types Namespace


BakeGeometry Method

[image]

Grasshopper SDK
GH_Line..::..BakeGeometry Method
GH_Line Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool BakeGeometry(
    RhinoDoc doc,
    ObjectAttributes att,
    ref Guid obj_guid
)
Visual Basic
Public Function BakeGeometry ( _
    doc As RhinoDoc, _
    att As ObjectAttributes, _
    ByRef obj_guid As Guid _
) As Boolean

Parameters

doc
Type: RhinoDoc
att
Type: ObjectAttributes
obj_guid
Type: System..::..Guid %

Implements

IGH_BakeAwareData..::..BakeGeometry(RhinoDoc, ObjectAttributes, Guid%)

See Also

GH_Line Class
Grasshopper.Kernel.Types Namespace


CastFrom Method

[image]

Grasshopper SDK
GH_Line..::..CastFrom Method
GH_Line Class See Also Send Feedback
Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastFrom(
    Object source
)
Visual Basic
Public Overrides Function CastFrom ( _
    source As Object _
) As Boolean

Parameters

source
Type: System..::..Object

See Also

GH_Line Class
Grasshopper.Kernel.Types Namespace


CastTo Method

[image] [image]

Grasshopper SDK
GH_Line..::..CastTo Method
GH_Line Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type T. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)

See Also

GH_Line Class
GH_Line Members
Grasshopper.Kernel.Types Namespace


CastTo(T) Method (T)

[image]

Grasshopper SDK
GH_Line..::..CastTo<(Of <(<'T>)>)> Method (T%)
GH_Line Class See Also Send Feedback
Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastTo<T>(
    out T target
)
Visual Basic
Public Overrides Function CastTo(Of T) ( _
    <OutAttribute> ByRef target As T _
) As Boolean

Parameters

target
Type: T%

Type Parameters

T

See Also

GH_Line Class
CastTo Overload
Grasshopper.Kernel.Types Namespace


DrawViewportMeshes Method

[image]

Grasshopper SDK
GH_Line..::..DrawViewportMeshes Method
GH_Line Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DrawViewportMeshes(
    GH_PreviewMeshArgs args
)
Visual Basic
Public Sub DrawViewportMeshes ( _
    args As GH_PreviewMeshArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..GH_PreviewMeshArgs

Implements

IGH_PreviewData..::..DrawViewportMeshes(GH_PreviewMeshArgs)

See Also

GH_Line Class
Grasshopper.Kernel.Types Namespace


DrawViewportWires Method

[image]

Grasshopper SDK
GH_Line..::..DrawViewportWires Method
GH_Line Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DrawViewportWires(
    GH_PreviewWireArgs args
)
Visual Basic
Public Sub DrawViewportWires ( _
    args As GH_PreviewWireArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..GH_PreviewWireArgs

Implements

IGH_PreviewData..::..DrawViewportWires(GH_PreviewWireArgs)

See Also

GH_Line Class
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_Line..::..Duplicate Method
GH_Line Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_Goo Duplicate()
Visual Basic
Public Overrides Function Duplicate As IGH_Goo

See Also

GH_Line Class
Grasshopper.Kernel.Types Namespace


DuplicateGeometry Method

[image]

Grasshopper SDK
GH_Line..::..DuplicateGeometry Method
GH_Line Class See Also Send Feedback
Create a duplicate of this line.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GeometricGoo DuplicateGeometry()
Visual Basic
Public Overrides Function DuplicateGeometry As IGH_GeometricGoo

See Also

GH_Line Class
Grasshopper.Kernel.Types Namespace


DuplicateLine Method

[image]

Grasshopper SDK
GH_Line..::..DuplicateLine Method
GH_Line Class See Also Send Feedback
Create a duplicate of this line.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Line DuplicateLine()
Visual Basic
Public Function DuplicateLine As GH_Line

See Also

GH_Line Class
Grasshopper.Kernel.Types Namespace


EmitProxy Method

[image]

Grasshopper SDK
GH_Line..::..EmitProxy Method
GH_Line Class See Also Send Feedback
Returns a proxy that represents this line. Do not call this function unless you're

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GooProxy EmitProxy()
Visual Basic
Public Overrides Function EmitProxy As IGH_GooProxy

See Also

GH_Line Class
Grasshopper.Kernel.Types Namespace


GetBoundingBox Method

[image]

Grasshopper SDK
GH_Line..::..GetBoundingBox Method
GH_Line Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override BoundingBox GetBoundingBox(
    Transform xform
)
Visual Basic
Public Overrides Function GetBoundingBox ( _
    xform As Transform _
) As BoundingBox

Parameters

xform
Type: Transform

See Also

GH_Line Class
Grasshopper.Kernel.Types Namespace


LoadGeometry Method

[image] [image]

Grasshopper SDK
GH_Line..::..LoadGeometry Method
GH_Line Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LoadGeometry()()()() | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | LoadGeometry(RhinoDoc) | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. The default is to always return True. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)

See Also

GH_Line Class
GH_Line Members
Grasshopper.Kernel.Types Namespace


Morph Method

[image]

Grasshopper SDK
GH_Line..::..Morph Method
GH_Line Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GeometricGoo Morph(
    SpaceMorph xmorph
)
Visual Basic
Public Overrides Function Morph ( _
    xmorph As SpaceMorph _
) As IGH_GeometricGoo

Parameters

xmorph
Type: SpaceMorph

See Also

GH_Line Class
Grasshopper.Kernel.Types Namespace


Read Method

[image]

Grasshopper SDK
GH_Line..::..Read Method
GH_Line Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

See Also

GH_Line Class
Grasshopper.Kernel.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_Line..::..ToString Method
GH_Line Class See Also Send Feedback
Format the line using default grasshopper formatting logic.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_Line Class
Grasshopper.Kernel.Types Namespace


Transform Method

[image]

Grasshopper SDK
GH_Line..::..Transform Method
GH_Line Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GeometricGoo Transform(
    Transform xform
)
Visual Basic
Public Overrides Function Transform ( _
    xform As Transform _
) As IGH_GeometricGoo

Parameters

xform
Type: Transform

See Also

GH_Line Class
Grasshopper.Kernel.Types Namespace


Write Method

[image]

Grasshopper SDK
GH_Line..::..Write Method
GH_Line Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overrides Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

See Also

GH_Line Class
Grasshopper.Kernel.Types Namespace


GH_Line Properties

[image] [image]

Grasshopper SDK
GH_Line Properties
GH_Line Class See Also Send Feedback

The GH_Line type exposes the following members.

Properties

 | Name | Description
Public property | Boundingbox | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Boundingbox.)
Public property | ClippingBox |
Public property | IsGeometryLoaded | Gets a value indicating whether or not this geometry is currently loaded (assuming it is referenced). Not all IGH_GeometricGoo implementations support referenced geometry. The default is to always return True. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public property | IsReferencedGeometry | Gets a value indicating whether or not this geometry is referenced. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public property | IsValid | Gets the validity of this instance. Lines with zero length are not considered to be valid. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot.)
Public property | ReferenceID | Gets or sets the Guid of the object that is referenced. Not all IGH_GeometricGoo implementations support referenced geometry. The default implementation is to always return Guid.Empty. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the value of this type. Note that if the type has a ReferenceID this value might get destroyed in the future. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)

See Also

GH_Line Class
Grasshopper.Kernel.Types Namespace


Boundingbox Property

[image]

Grasshopper SDK
GH_Line..::..Boundingbox Property
GH_Line Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override BoundingBox Boundingbox { get; }
Visual Basic
Public Overrides ReadOnly Property Boundingbox As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Line.Boundingbox"]

See Also

GH_Line Class
Grasshopper.Kernel.Types Namespace


ClippingBox Property

[image]

Grasshopper SDK
GH_Line..::..ClippingBox Property
GH_Line Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public BoundingBox ClippingBox { get; }
Visual Basic
Public ReadOnly Property ClippingBox As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Line.ClippingBox"]

Implements

IGH_PreviewData..::..ClippingBox

See Also

GH_Line Class
Grasshopper.Kernel.Types Namespace


IsValid Property

[image]

Grasshopper SDK
GH_Line..::..IsValid Property
GH_Line Class See Also Send Feedback
Gets the validity of this instance. Lines with zero length are not considered to be valid.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool IsValid { get; }
Visual Basic
Public Overrides ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Line.IsValid"]

See Also

GH_Line Class
Grasshopper.Kernel.Types Namespace


IsValidWhyNot Property

[image]

Grasshopper SDK
GH_Line..::..IsValidWhyNot Property
GH_Line Class See Also Send Feedback
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string IsValidWhyNot { get; }
Visual Basic
Public Overrides ReadOnly Property IsValidWhyNot As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Line.IsValidWhyNot"]

See Also

GH_Line Class
Grasshopper.Kernel.Types Namespace


TypeDescription Property

[image]

Grasshopper SDK
GH_Line..::..TypeDescription Property
GH_Line Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeDescription { get; }
Visual Basic
Public Overrides ReadOnly Property TypeDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Line.TypeDescription"]

See Also

GH_Line Class
Grasshopper.Kernel.Types Namespace


TypeName Property

[image]

Grasshopper SDK
GH_Line..::..TypeName Property
GH_Line Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeName { get; }
Visual Basic
Public Overrides ReadOnly Property TypeName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Line.TypeName"]

See Also

GH_Line Class
Grasshopper.Kernel.Types Namespace


GH_Line.GH_LineProxy Class

[image]

Grasshopper SDK
GH_Line..::..GH_LineProxy Class
GH_Line Class Members See Also Send Feedback
Proxy description of GH_Line class. This class is used by the Generic Multivalue interfaces.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_LineProxy : GH_GooProxy<GH_Line>
Visual Basic
Public Class GH_LineProxy _
    Inherits GH_GooProxy(Of GH_Line)

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_GooProxy <(Of <(<' GH_Line >)>)>
Grasshopper.Kernel.Types..::..GH_Line..::..GH_LineProxy

See Also

GH_Line..::..GH_LineProxy Members
Grasshopper.Kernel.Types Namespace


GH_Line.GH_LineProxy Members

[image] [image]

Grasshopper SDK
GH_Line..::..GH_LineProxy Members
GH_Line..::..GH_LineProxy Class Constructors Methods Properties See Also Send Feedback

Represents a 3D line segment. GH_Line re-implements the OpenNURBS OnLine class.

The GH_Line..::..GH_LineProxy type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Line..::..GH_LineProxy | Initializes a new instance of the GH_Line..::..GH_LineProxy class

Methods

 | Name | Description
Public method | Construct | (Overrides GH_GooProxy<(Of <(<'T>)>)>..::..Construct()()()().)
Public method | FormatInstance | Returns a String description of the current value. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FromString | If IsParsable(), then attempts to convert the string to a generic type value (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | MutateString | Munge a string to remove obvious errors on account of the user. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | NumberToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | StringToNumber | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | ToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Ax |
Public property | Ay |
Public property | Az |
Public property | Bx |
Public property | By |
Public property | Bz |
Public property | IsParsable | Gets a value indicating whether or not the type can be instantiated from a String. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Length |
Protected property | Owner | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | ProxyOwner | Gets the piece of Grasshopper data that spawned this proxy. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeName | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | UserString | Gets or sets the user-defined string that describes this proxy. This only really makes sense if the Proxy is Parsable. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Valid | Gets a value indicating whether this proxy represents valid data. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

See Also

GH_Line..::..GH_LineProxy Class
Grasshopper.Kernel.Types Namespace


GH_Line.GH_LineProxy Constructor

[image]

Grasshopper SDK
GH_Line..::..GH_LineProxy Constructor
GH_Line..::..GH_LineProxy Class See Also Send Feedback
Initializes a new instance of the GH_Line..::..GH_LineProxy class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_LineProxy(
    GH_Line nOwner
)
Visual Basic
Public Sub New ( _
    nOwner As GH_Line _
)

Parameters

nOwner
Type: Grasshopper.Kernel.Types..::..GH_Line

See Also

GH_Line..::..GH_LineProxy Class
Grasshopper.Kernel.Types Namespace


GH_Line.GH_LineProxy Methods

[image] [image]

Grasshopper SDK
GH_Line..::..GH_LineProxy Methods
GH_Line..::..GH_LineProxy Class See Also Send Feedback

The GH_Line..::..GH_LineProxy type exposes the following members.

Methods

 | Name | Description
Public method | Construct | (Overrides GH_GooProxy<(Of <(<'T>)>)>..::..Construct()()()().)
Public method | FormatInstance | Returns a String description of the current value. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FromString | If IsParsable(), then attempts to convert the string to a generic type value (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | MutateString | Munge a string to remove obvious errors on account of the user. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | NumberToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | StringToNumber | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | ToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

See Also

GH_Line..::..GH_LineProxy Class
Grasshopper.Kernel.Types Namespace


Construct Method

[image]

Grasshopper SDK
GH_Line..::..GH_LineProxy..::..Construct Method
GH_Line..::..GH_LineProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void Construct()
Visual Basic
Public Overrides Sub Construct

See Also

GH_Line..::..GH_LineProxy Class
Grasshopper.Kernel.Types Namespace


GH_Line.GH_LineProxy Properties

[image] [image]

Grasshopper SDK
GH_Line..::..GH_LineProxy Properties
GH_Line..::..GH_LineProxy Class See Also Send Feedback

The GH_Line..::..GH_LineProxy type exposes the following members.

Properties

 | Name | Description
Public property | Ax |
Public property | Ay |
Public property | Az |
Public property | Bx |
Public property | By |
Public property | Bz |
Public property | IsParsable | Gets a value indicating whether or not the type can be instantiated from a String. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Length |
Protected property | Owner | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | ProxyOwner | Gets the piece of Grasshopper data that spawned this proxy. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeName | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | UserString | Gets or sets the user-defined string that describes this proxy. This only really makes sense if the Proxy is Parsable. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Valid | Gets a value indicating whether this proxy represents valid data. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

See Also

GH_Line..::..GH_LineProxy Class
Grasshopper.Kernel.Types Namespace


Ax Property

[image]

Grasshopper SDK
GH_Line..::..GH_LineProxy..::..Ax Property
GH_Line..::..GH_LineProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Ax { get; set; }
Visual Basic
Public Property Ax As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Line.GH_LineProxy.Ax"]

See Also

GH_Line..::..GH_LineProxy Class
Grasshopper.Kernel.Types Namespace


Ay Property

[image]

Grasshopper SDK
GH_Line..::..GH_LineProxy..::..Ay Property
GH_Line..::..GH_LineProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Ay { get; set; }
Visual Basic
Public Property Ay As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Line.GH_LineProxy.Ay"]

See Also

GH_Line..::..GH_LineProxy Class
Grasshopper.Kernel.Types Namespace


Az Property

[image]

Grasshopper SDK
GH_Line..::..GH_LineProxy..::..Az Property
GH_Line..::..GH_LineProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Az { get; set; }
Visual Basic
Public Property Az As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Line.GH_LineProxy.Az"]

See Also

GH_Line..::..GH_LineProxy Class
Grasshopper.Kernel.Types Namespace


Bx Property

[image]

Grasshopper SDK
GH_Line..::..GH_LineProxy..::..Bx Property
GH_Line..::..GH_LineProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Bx { get; set; }
Visual Basic
Public Property Bx As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Line.GH_LineProxy.Bx"]

See Also

GH_Line..::..GH_LineProxy Class
Grasshopper.Kernel.Types Namespace


By Property

[image]

Grasshopper SDK
GH_Line..::..GH_LineProxy..::..By Property
GH_Line..::..GH_LineProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string By { get; set; }
Visual Basic
Public Property By As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Line.GH_LineProxy.By"]

See Also

GH_Line..::..GH_LineProxy Class
Grasshopper.Kernel.Types Namespace


Bz Property

[image]

Grasshopper SDK
GH_Line..::..GH_LineProxy..::..Bz Property
GH_Line..::..GH_LineProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Bz { get; set; }
Visual Basic
Public Property Bz As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Line.GH_LineProxy.Bz"]

See Also

GH_Line..::..GH_LineProxy Class
Grasshopper.Kernel.Types Namespace


Length Property

[image]

Grasshopper SDK
GH_Line..::..GH_LineProxy..::..Length Property
GH_Line..::..GH_LineProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Length { get; set; }
Visual Basic
Public Property Length As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Line.GH_LineProxy.Length"]

See Also

GH_Line..::..GH_LineProxy Class
Grasshopper.Kernel.Types Namespace


GH_LineCharge Class

[image]

Grasshopper SDK
GH_LineCharge Class
Members See Also Send Feedback
Line charge implementation for IGH_Fields.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_LineCharge : GH_FieldElement
Visual Basic
Public Class GH_LineCharge _
    Inherits GH_FieldElement

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_FieldElement
Grasshopper.Kernel.Types..::..GH_LineCharge

See Also

GH_LineCharge Members
Grasshopper.Kernel.Types Namespace


GH_LineCharge Members

[image] [image]

Grasshopper SDK
GH_LineCharge Members
GH_LineCharge Class Constructors Methods Properties See Also Send Feedback

The GH_LineCharge type exposes the following members.

Constructors

 | Name | Description
Public method | GH_LineCharge | Initializes a new instance of the GH_LineCharge class

Methods

 | Name | Description
Public method | DrawViewportMeshes | (Inherited from GH_FieldElement.)
Public method | DrawViewportWires | (Overrides GH_FieldElement..::..DrawViewportWires(GH_PreviewWireArgs).)
Public method | Duplicate | (Overrides GH_FieldElement..::..Duplicate()()()().)
Public method | Force | (Overrides GH_FieldElement..::..Force(Point3d).)
Public method | IsCoincident | (Overrides GH_FieldElement..::..IsCoincident(Point3d, Double).)
Public method | Read | (Overrides GH_FieldElement..::..Read(GH_IReader).)
Public method | Write | (Overrides GH_FieldElement..::..Write(GH_IWriter).)

Properties

 | Name | Description
Public property | BoundingBox | (Overrides GH_FieldElement..::..BoundingBox.)
Public property | Charge |
Public property | ClippingBox | (Inherited from GH_FieldElement.)
Public property | ElementGuid | (Overrides GH_FieldElement..::..ElementGuid.)
Public property | IsLimited | (Inherited from GH_FieldElement.)
Public property | Limits | (Inherited from GH_FieldElement.)
Public property | Segment |

See Also

GH_LineCharge Class
Grasshopper.Kernel.Types Namespace


GH_LineCharge Constructor

[image]

Grasshopper SDK
GH_LineCharge Constructor
GH_LineCharge Class See Also Send Feedback
Initializes a new instance of the GH_LineCharge class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_LineCharge()
Visual Basic
Public Sub New

See Also

GH_LineCharge Class
Grasshopper.Kernel.Types Namespace


GH_LineCharge Methods

[image] [image]

Grasshopper SDK
GH_LineCharge Methods
GH_LineCharge Class See Also Send Feedback

The GH_LineCharge type exposes the following members.

Methods

 | Name | Description
Public method | DrawViewportMeshes | (Inherited from GH_FieldElement.)
Public method | DrawViewportWires | (Overrides GH_FieldElement..::..DrawViewportWires(GH_PreviewWireArgs).)
Public method | Duplicate | (Overrides GH_FieldElement..::..Duplicate()()()().)
Public method | Force | (Overrides GH_FieldElement..::..Force(Point3d).)
Public method | IsCoincident | (Overrides GH_FieldElement..::..IsCoincident(Point3d, Double).)
Public method | Read | (Overrides GH_FieldElement..::..Read(GH_IReader).)
Public method | Write | (Overrides GH_FieldElement..::..Write(GH_IWriter).)

See Also

GH_LineCharge Class
Grasshopper.Kernel.Types Namespace


DrawViewportWires Method

[image]

Grasshopper SDK
GH_LineCharge..::..DrawViewportWires Method
GH_LineCharge Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void DrawViewportWires(
    GH_PreviewWireArgs args
)
Visual Basic
Public Overrides Sub DrawViewportWires ( _
    args As GH_PreviewWireArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..GH_PreviewWireArgs

See Also

GH_LineCharge Class
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_LineCharge..::..Duplicate Method
GH_LineCharge Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_FieldElement Duplicate()
Visual Basic
Public Overrides Function Duplicate As IGH_FieldElement

See Also

GH_LineCharge Class
Grasshopper.Kernel.Types Namespace


Force Method

[image]

Grasshopper SDK
GH_LineCharge..::..Force Method
GH_LineCharge Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override Vector3d Force(
    Point3d location
)
Visual Basic
Public Overrides Function Force ( _
    location As Point3d _
) As Vector3d

Parameters

location
Type: Point3d

See Also

GH_LineCharge Class
Grasshopper.Kernel.Types Namespace


IsCoincident Method

[image]

Grasshopper SDK
GH_LineCharge..::..IsCoincident Method
GH_LineCharge Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool IsCoincident(
    Point3d point,
    double tolerance
)
Visual Basic
Public Overrides Function IsCoincident ( _
    point As Point3d, _
    tolerance As Double _
) As Boolean

Parameters

point
Type: Point3d
tolerance
Type: System..::..Double

See Also

GH_LineCharge Class
Grasshopper.Kernel.Types Namespace


Read Method

[image]

Grasshopper SDK
GH_LineCharge..::..Read Method
GH_LineCharge Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

See Also

GH_LineCharge Class
Grasshopper.Kernel.Types Namespace


Write Method

[image]

Grasshopper SDK
GH_LineCharge..::..Write Method
GH_LineCharge Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overrides Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

See Also

GH_LineCharge Class
Grasshopper.Kernel.Types Namespace


GH_LineCharge Properties

[image] [image]

Grasshopper SDK
GH_LineCharge Properties
GH_LineCharge Class See Also Send Feedback

The GH_LineCharge type exposes the following members.

Properties

 | Name | Description
Public property | BoundingBox | (Overrides GH_FieldElement..::..BoundingBox.)
Public property | Charge |
Public property | ClippingBox | (Inherited from GH_FieldElement.)
Public property | ElementGuid | (Overrides GH_FieldElement..::..ElementGuid.)
Public property | IsLimited | (Inherited from GH_FieldElement.)
Public property | Limits | (Inherited from GH_FieldElement.)
Public property | Segment |

See Also

GH_LineCharge Class
Grasshopper.Kernel.Types Namespace


BoundingBox Property

[image]

Grasshopper SDK
GH_LineCharge..::..BoundingBox Property
GH_LineCharge Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override BoundingBox BoundingBox { get; }
Visual Basic
Public Overrides ReadOnly Property BoundingBox As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_LineCharge.BoundingBox"]

See Also

GH_LineCharge Class
Grasshopper.Kernel.Types Namespace


Charge Property

[image]

Grasshopper SDK
GH_LineCharge..::..Charge Property
GH_LineCharge Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double Charge { get; set; }
Visual Basic
Public Property Charge As Double
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_LineCharge.Charge"]

See Also

GH_LineCharge Class
Grasshopper.Kernel.Types Namespace


ElementGuid Property

[image]

Grasshopper SDK
GH_LineCharge..::..ElementGuid Property
GH_LineCharge Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override Guid ElementGuid { get; }
Visual Basic
Public Overrides ReadOnly Property ElementGuid As Guid
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_LineCharge.ElementGuid"]

See Also

GH_LineCharge Class
Grasshopper.Kernel.Types Namespace


Segment Property

[image]

Grasshopper SDK
GH_LineCharge..::..Segment Property
GH_LineCharge Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Line Segment { get; set; }
Visual Basic
Public Property Segment As Line
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_LineCharge.Segment"]

See Also

GH_LineCharge Class
Grasshopper.Kernel.Types Namespace


GH_LonLatCoordinate Class

[image]

Grasshopper SDK
GH_LonLatCoordinate Class
Members See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_LonLatCoordinate : IGH_Goo
Visual Basic
Public Class GH_LonLatCoordinate _
    Implements IGH_Goo

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_LonLatCoordinate

See Also

GH_LonLatCoordinate Members
Grasshopper.Kernel.Types Namespace


GH_LonLatCoordinate Members

[image] [image]

Grasshopper SDK
GH_LonLatCoordinate Members
GH_LonLatCoordinate Class Constructors Methods Properties See Also Send Feedback

The GH_LonLatCoordinate type exposes the following members.

Constructors

 | Name | Description
Public method | GH_LonLatCoordinate()()()() | Initializes a new instance of the GH_LonLatCoordinate class
Public method | GH_LonLatCoordinate(Double, Double) | Initializes a new instance of the GH_LonLatCoordinate class

Methods

 | Name | Description
Public method | CastFrom |
Public method | CastTo<(Of <<'(T>)>>) |
Public method | Duplicate |
Public method | EmitProxy |
Public method | Read |
Public method | ScriptVariable |
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | Write |

Properties

 | Name | Description
Public property | IsValid |
Public property | IsValidWhyNot |
Public property | Latitude | Gets or sets the longitude (in degrees) of the location.
Public property | Longitude | Gets or sets the longitude (in degrees) of the location.
Public property | SphereUParameter | Gets the spherical U parameter.
Public property | SphereVParameter | Gets the spherical V parameter.
Public property | TypeDescription |
Public property | TypeName |

See Also

GH_LonLatCoordinate Class
Grasshopper.Kernel.Types Namespace


GH_LonLatCoordinate Constructor

[image] [image]

Grasshopper SDK
GH_LonLatCoordinate Constructor
GH_LonLatCoordinate Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_LonLatCoordinate()()()() | Initializes a new instance of the GH_LonLatCoordinate class
Public method | GH_LonLatCoordinate(Double, Double) | Initializes a new instance of the GH_LonLatCoordinate class

See Also

GH_LonLatCoordinate Class
GH_LonLatCoordinate Members
Grasshopper.Kernel.Types Namespace


GH_LonLatCoordinate Constructor

[image]

Grasshopper SDK
GH_LonLatCoordinate Constructor
GH_LonLatCoordinate Class See Also Send Feedback
Initializes a new instance of the GH_LonLatCoordinate class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_LonLatCoordinate()
Visual Basic
Public Sub New

See Also

GH_LonLatCoordinate Class
GH_LonLatCoordinate Overload
Grasshopper.Kernel.Types Namespace


GH_LonLatCoordinate Constructor (Double, Double)

[image]

Grasshopper SDK
GH_LonLatCoordinate Constructor (Double, Double)
GH_LonLatCoordinate Class See Also Send Feedback
Initializes a new instance of the GH_LonLatCoordinate class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_LonLatCoordinate(
    double longitude,
    double latitude
)
Visual Basic
Public Sub New ( _
    longitude As Double, _
    latitude As Double _
)

Parameters

longitude
Type: System..::..Double
latitude
Type: System..::..Double

See Also

GH_LonLatCoordinate Class
GH_LonLatCoordinate Overload
Grasshopper.Kernel.Types Namespace


GH_LonLatCoordinate Methods

[image] [image]

Grasshopper SDK
GH_LonLatCoordinate Methods
GH_LonLatCoordinate Class See Also Send Feedback

The GH_LonLatCoordinate type exposes the following members.

Methods

 | Name | Description
Public method | CastFrom |
Public method | CastTo<(Of <<'(T>)>>) |
Public method | Duplicate |
Public method | EmitProxy |
Public method | Read |
Public method | ScriptVariable |
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | Write |

See Also

GH_LonLatCoordinate Class
Grasshopper.Kernel.Types Namespace


CastFrom Method

[image]

Grasshopper SDK
GH_LonLatCoordinate..::..CastFrom Method
GH_LonLatCoordinate Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool CastFrom(
    Object source
)
Visual Basic
Public Function CastFrom ( _
    source As Object _
) As Boolean

Parameters

source
Type: System..::..Object

Implements

IGH_Goo..::..CastFrom(Object)

See Also

GH_LonLatCoordinate Class
Grasshopper.Kernel.Types Namespace


CastTo(T) Method

[image]

Grasshopper SDK
GH_LonLatCoordinate..::..CastTo<(Of <(<'T>)>)> Method
GH_LonLatCoordinate Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool CastTo<T>(
    ref T target
)
Visual Basic
Public Function CastTo(Of T) ( _
    ByRef target As T _
) As Boolean

Parameters

target
Type: T%

Type Parameters

T

Implements

IGH_Goo..::..CastTo<(Of <<'(T>)>>)(T%)

See Also

GH_LonLatCoordinate Class
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_LonLatCoordinate..::..Duplicate Method
GH_LonLatCoordinate Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_Goo Duplicate()
Visual Basic
Public Function Duplicate As IGH_Goo

Implements

IGH_Goo..::..Duplicate()()()()

See Also

GH_LonLatCoordinate Class
Grasshopper.Kernel.Types Namespace


EmitProxy Method

[image]

Grasshopper SDK
GH_LonLatCoordinate..::..EmitProxy Method
GH_LonLatCoordinate Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_GooProxy EmitProxy()
Visual Basic
Public Function EmitProxy As IGH_GooProxy

Implements

IGH_Goo..::..EmitProxy()()()()

See Also

GH_LonLatCoordinate Class
Grasshopper.Kernel.Types Namespace


Read Method

[image]

Grasshopper SDK
GH_LonLatCoordinate..::..Read Method
GH_LonLatCoordinate Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Read(
    GH_IReader reader
)
Visual Basic
Public Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

Implements

GH_ISerializable..::..Read(GH_IReader)

See Also

GH_LonLatCoordinate Class
Grasshopper.Kernel.Types Namespace


ScriptVariable Method

[image]

Grasshopper SDK
GH_LonLatCoordinate..::..ScriptVariable Method
GH_LonLatCoordinate Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Object ScriptVariable()
Visual Basic
Public Function ScriptVariable As Object

Implements

IGH_Goo..::..ScriptVariable()()()()

See Also

GH_LonLatCoordinate Class
Grasshopper.Kernel.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_LonLatCoordinate..::..ToString Method
GH_LonLatCoordinate Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Implements

IGH_Goo..::..ToString()()()()

See Also

GH_LonLatCoordinate Class
Grasshopper.Kernel.Types Namespace


Write Method

[image]

Grasshopper SDK
GH_LonLatCoordinate..::..Write Method
GH_LonLatCoordinate Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Write(
    GH_IWriter writer
)
Visual Basic
Public Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

Implements

GH_ISerializable..::..Write(GH_IWriter)

See Also

GH_LonLatCoordinate Class
Grasshopper.Kernel.Types Namespace


GH_LonLatCoordinate Properties

[image] [image]

Grasshopper SDK
GH_LonLatCoordinate Properties
GH_LonLatCoordinate Class See Also Send Feedback

The GH_LonLatCoordinate type exposes the following members.

Properties

 | Name | Description
Public property | IsValid |
Public property | IsValidWhyNot |
Public property | Latitude | Gets or sets the longitude (in degrees) of the location.
Public property | Longitude | Gets or sets the longitude (in degrees) of the location.
Public property | SphereUParameter | Gets the spherical U parameter.
Public property | SphereVParameter | Gets the spherical V parameter.
Public property | TypeDescription |
Public property | TypeName |

See Also

GH_LonLatCoordinate Class
Grasshopper.Kernel.Types Namespace


IsValid Property

[image]

Grasshopper SDK
GH_LonLatCoordinate..::..IsValid Property
GH_LonLatCoordinate Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsValid { get; }
Visual Basic
Public ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_LonLatCoordinate.IsValid"]

Implements

IGH_Goo..::..IsValid

See Also

GH_LonLatCoordinate Class
Grasshopper.Kernel.Types Namespace


IsValidWhyNot Property

[image]

Grasshopper SDK
GH_LonLatCoordinate..::..IsValidWhyNot Property
GH_LonLatCoordinate Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string IsValidWhyNot { get; }
Visual Basic
Public ReadOnly Property IsValidWhyNot As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_LonLatCoordinate.IsValidWhyNot"]

Implements

IGH_Goo..::..IsValidWhyNot

See Also

GH_LonLatCoordinate Class
Grasshopper.Kernel.Types Namespace


Latitude Property

[image]

Grasshopper SDK
GH_LonLatCoordinate..::..Latitude Property
GH_LonLatCoordinate Class See Also Send Feedback
Gets or sets the longitude (in degrees) of the location.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double Latitude { get; set; }
Visual Basic
Public Property Latitude As Double
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_LonLatCoordinate.Latitude"]

See Also

GH_LonLatCoordinate Class
Grasshopper.Kernel.Types Namespace


Longitude Property

[image]

Grasshopper SDK
GH_LonLatCoordinate..::..Longitude Property
GH_LonLatCoordinate Class See Also Send Feedback
Gets or sets the longitude (in degrees) of the location.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double Longitude { get; set; }
Visual Basic
Public Property Longitude As Double
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_LonLatCoordinate.Longitude"]

See Also

GH_LonLatCoordinate Class
Grasshopper.Kernel.Types Namespace


SphereUParameter Property

[image]

Grasshopper SDK
GH_LonLatCoordinate..::..SphereUParameter Property
GH_LonLatCoordinate Class See Also Send Feedback
Gets the spherical U parameter.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double SphereUParameter { get; }
Visual Basic
Public ReadOnly Property SphereUParameter As Double
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_LonLatCoordinate.SphereUParameter"]

See Also

GH_LonLatCoordinate Class
Grasshopper.Kernel.Types Namespace


SphereVParameter Property

[image]

Grasshopper SDK
GH_LonLatCoordinate..::..SphereVParameter Property
GH_LonLatCoordinate Class See Also Send Feedback
Gets the spherical V parameter.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double SphereVParameter { get; }
Visual Basic
Public ReadOnly Property SphereVParameter As Double
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_LonLatCoordinate.SphereVParameter"]

See Also

GH_LonLatCoordinate Class
Grasshopper.Kernel.Types Namespace


TypeDescription Property

[image]

Grasshopper SDK
GH_LonLatCoordinate..::..TypeDescription Property
GH_LonLatCoordinate Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string TypeDescription { get; }
Visual Basic
Public ReadOnly Property TypeDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_LonLatCoordinate.TypeDescription"]

Implements

IGH_Goo..::..TypeDescription

See Also

GH_LonLatCoordinate Class
Grasshopper.Kernel.Types Namespace


TypeName Property

[image]

Grasshopper SDK
GH_LonLatCoordinate..::..TypeName Property
GH_LonLatCoordinate Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string TypeName { get; }
Visual Basic
Public ReadOnly Property TypeName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_LonLatCoordinate.TypeName"]

Implements

IGH_Goo..::..TypeName

See Also

GH_LonLatCoordinate Class
Grasshopper.Kernel.Types Namespace


GH_Material Class

[image]

Grasshopper SDK
GH_Material Class
Members See Also Send Feedback
Represents a implementation of the Rhino material

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Material : GH_Goo<DisplayMaterial>
Visual Basic
Public Class GH_Material _
    Inherits GH_Goo(Of DisplayMaterial)

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_Goo <(Of <(<'DisplayMaterial>)>)>
Grasshopper.Kernel.Types..::..GH_Material

See Also

GH_Material Members
Grasshopper.Kernel.Types Namespace


GH_Material Members

[image] [image]

Grasshopper SDK
GH_Material Members
GH_Material Class Constructors Methods Fields Properties See Also Send Feedback

The GH_Material type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Material()()()() | Initializes a new instance of the GH_Material class
Public method | GH_Material(DisplayMaterial) | Create a new Material.
Public method | GH_Material(Color) | Create a new material based on a colour. The colour is used to control Diffuse, Emission and Transparency. Ambient, Specular and Shine are always default.
Public method | GH_Material(Guid) | Create a new Material from an RDK shader ID.
Public method | GH_Material(GH_Material) | Copy another GH_Material instance.

Methods

 | Name | Description
Public method | CastFrom | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
 | CreateStandardMaterial | Creates a standard Grasshopper material from a colour.
Public method | Duplicate | Duplicate this material. (Overrides GH_Goo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateMaterial | Duplicate this material.
Public method | EmitProxy | (Overrides GH_Goo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
 | GetModuleHandle |
 | RDK_GetMaterial |
 | RDK_GetMaterialSimulation |
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | RefreshReferenceData | If the material is a referenced material, this function will update the local values to match the reference.
Public method | ScriptVariable | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ScriptVariable()()()().)
Public method | ToString | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

Fields

 | Name | Description
Protected field | m_rdk_id |
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | IsReferencedShader |
Public property | IsValid | (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot.)
Public property | RDK_ID |
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the internal data. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Material Class
Grasshopper.Kernel.Types Namespace


GH_Material Constructor

[image] [image]

Grasshopper SDK
GH_Material Constructor
GH_Material Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Material()()()() | Initializes a new instance of the GH_Material class
Public method | GH_Material(DisplayMaterial) | Create a new Material.
Public method | GH_Material(Color) | Create a new material based on a colour. The colour is used to control Diffuse, Emission and Transparency. Ambient, Specular and Shine are always default.
Public method | GH_Material(Guid) | Create a new Material from an RDK shader ID.
Public method | GH_Material(GH_Material) | Copy another GH_Material instance.

See Also

GH_Material Class
GH_Material Members
Grasshopper.Kernel.Types Namespace


GH_Material Constructor

[image]

Grasshopper SDK
GH_Material Constructor
GH_Material Class See Also Send Feedback
Initializes a new instance of the GH_Material class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Material()
Visual Basic
Public Sub New

See Also

GH_Material Class
GH_Material Overload
Grasshopper.Kernel.Types Namespace


GH_Material Constructor ()

[image]

Grasshopper SDK
GH_Material Constructor ()
GH_Material Class See Also Send Feedback
Create a new Material.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Material(
    DisplayMaterial other
)
Visual Basic
Public Sub New ( _
    other As DisplayMaterial _
)

Parameters

other
Type: DisplayMaterial
Material to use (an internal copy will be made).

See Also

GH_Material Class
GH_Material Overload
Grasshopper.Kernel.Types Namespace


GH_Material Constructor (Color)

[image]

Grasshopper SDK
GH_Material Constructor (Color)
GH_Material Class See Also Send Feedback
Create a new material based on a colour. The colour is used to control Diffuse, Emission and Transparency. Ambient, Specular and Shine are always default.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Material(
    Color diffuse
)
Visual Basic
Public Sub New ( _
    diffuse As Color _
)

Parameters

diffuse
Type: System.Drawing..::..Color
The diffuse colour of the material.

See Also

GH_Material Class
GH_Material Overload
Grasshopper.Kernel.Types Namespace


GH_Material Constructor (Guid)

[image]

Grasshopper SDK
GH_Material Constructor (Guid)
GH_Material Class See Also Send Feedback
Create a new Material from an RDK shader ID.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Material(
    Guid rdk_id
)
Visual Basic
Public Sub New ( _
    rdk_id As Guid _
)

Parameters

rdk_id
Type: System..::..Guid
ID of RDK Shader.

See Also

GH_Material Class
GH_Material Overload
Grasshopper.Kernel.Types Namespace


GH_Material Constructor (GH_Material)

[image]

Grasshopper SDK
GH_Material Constructor (GH_Material)
GH_Material Class See Also Send Feedback
Copy another GH_Material instance.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Material(
    GH_Material other
)
Visual Basic
Public Sub New ( _
    other As GH_Material _
)

Parameters

other
Type: Grasshopper.Kernel.Types..::..GH_Material
Material to mimic.

See Also

GH_Material Class
GH_Material Overload
Grasshopper.Kernel.Types Namespace


GH_Material Fields

[image] [image]

Grasshopper SDK
GH_Material Fields
GH_Material Class See Also Send Feedback

The GH_Material type exposes the following members.

Fields

 | Name | Description
Protected field | m_rdk_id |
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Material Class
Grasshopper.Kernel.Types Namespace


m_rdk_id Field

[image]

Grasshopper SDK
GH_Material..::..m_rdk_id Field
GH_Material Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected Guid m_rdk_id
Visual Basic
Protected m_rdk_id As Guid

See Also

GH_Material Class
Grasshopper.Kernel.Types Namespace


GH_Material Methods

[image] [image]

Grasshopper SDK
GH_Material Methods
GH_Material Class See Also Send Feedback

The GH_Material type exposes the following members.

Methods

 | Name | Description
Public method | CastFrom | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
 | CreateStandardMaterial | Creates a standard Grasshopper material from a colour.
Public method | Duplicate | Duplicate this material. (Overrides GH_Goo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateMaterial | Duplicate this material.
Public method | EmitProxy | (Overrides GH_Goo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
 | GetModuleHandle |
 | RDK_GetMaterial |
 | RDK_GetMaterialSimulation |
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | RefreshReferenceData | If the material is a referenced material, this function will update the local values to match the reference.
Public method | ScriptVariable | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ScriptVariable()()()().)
Public method | ToString | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

See Also

GH_Material Class
Grasshopper.Kernel.Types Namespace


CastFrom Method

[image]

Grasshopper SDK
GH_Material..::..CastFrom Method
GH_Material Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastFrom(
    Object source
)
Visual Basic
Public Overrides Function CastFrom ( _
    source As Object _
) As Boolean

Parameters

source
Type: System..::..Object

See Also

GH_Material Class
Grasshopper.Kernel.Types Namespace


CastTo Method

[image] [image]

Grasshopper SDK
GH_Material..::..CastTo Method
GH_Material Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)

See Also

GH_Material Class
GH_Material Members
Grasshopper.Kernel.Types Namespace


CastTo(T) Method (T)

[image]

Grasshopper SDK
GH_Material..::..CastTo<(Of <(<'T>)>)> Method (T%)
GH_Material Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastTo<T>(
    ref T target
)
Visual Basic
Public Overrides Function CastTo(Of T) ( _
    ByRef target As T _
) As Boolean

Parameters

target
Type: T%

Type Parameters

T

See Also

GH_Material Class
CastTo Overload
Grasshopper.Kernel.Types Namespace


CreateStandardMaterial Method

[image]

Grasshopper SDK
GH_Material..::..CreateStandardMaterial Method
GH_Material Class See Also Send Feedback
Creates a standard Grasshopper material from a colour.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static DisplayMaterial CreateStandardMaterial(
    Color colour
)
Visual Basic
Public Shared Function CreateStandardMaterial ( _
    colour As Color _
) As DisplayMaterial

Parameters

colour
Type: System.Drawing..::..Color
Base colour for material.

See Also

GH_Material Class
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_Material..::..Duplicate Method
GH_Material Class See Also Send Feedback
Duplicate this material.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_Goo Duplicate()
Visual Basic
Public Overrides Function Duplicate As IGH_Goo

Return Value

An exact duplicate of this material.

See Also

GH_Material Class
Grasshopper.Kernel.Types Namespace


DuplicateMaterial Method

[image]

Grasshopper SDK
GH_Material..::..DuplicateMaterial Method
GH_Material Class See Also Send Feedback
Duplicate this material.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Material DuplicateMaterial()
Visual Basic
Public Function DuplicateMaterial As GH_Material

Return Value

An exact duplicate of this material.

See Also

GH_Material Class
Grasshopper.Kernel.Types Namespace


EmitProxy Method

[image]

Grasshopper SDK
GH_Material..::..EmitProxy Method
GH_Material Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GooProxy EmitProxy()
Visual Basic
Public Overrides Function EmitProxy As IGH_GooProxy

See Also

GH_Material Class
Grasshopper.Kernel.Types Namespace


GetModuleHandle Method

[image]

Grasshopper SDK
GH_Material..::..GetModuleHandle Method
GH_Material Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static IntPtr GetModuleHandle(
    ref string lpModuleName
)
Visual Basic
Public Shared Function GetModuleHandle ( _
    ByRef lpModuleName As String _
) As IntPtr

Parameters

lpModuleName
Type: System..::..String %

See Also

GH_Material Class
Grasshopper.Kernel.Types Namespace


RDK_GetMaterial Method

[image]

Grasshopper SDK
GH_Material..::..RDK_GetMaterial Method
GH_Material Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Guid RDK_GetMaterial()
Visual Basic
Public Shared Function RDK_GetMaterial As Guid

See Also

GH_Material Class
Grasshopper.Kernel.Types Namespace


RDK_GetMaterialSimulation Method

[image]

Grasshopper SDK
GH_Material..::..RDK_GetMaterialSimulation Method
GH_Material Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool RDK_GetMaterialSimulation(
    Guid id,
    IntPtr on_material_ptr
)
Visual Basic
Public Shared Function RDK_GetMaterialSimulation ( _
    id As Guid, _
    on_material_ptr As IntPtr _
) As Boolean

Parameters

id
Type: System..::..Guid
on_material_ptr
Type: System..::..IntPtr

See Also

GH_Material Class
Grasshopper.Kernel.Types Namespace


Read Method

[image]

Grasshopper SDK
GH_Material..::..Read Method
GH_Material Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

See Also

GH_Material Class
Grasshopper.Kernel.Types Namespace


RefreshReferenceData Method

[image]

Grasshopper SDK
GH_Material..::..RefreshReferenceData Method
GH_Material Class See Also Send Feedback
If the material is a referenced material, this function will update the local values to match the reference.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Material..::..RDK_GL_Result RefreshReferenceData()
Visual Basic
Public Function RefreshReferenceData As GH_Material..::..RDK_GL_Result

See Also

GH_Material Class
Grasshopper.Kernel.Types Namespace


ScriptVariable Method

[image]

Grasshopper SDK
GH_Material..::..ScriptVariable Method
GH_Material Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override Object ScriptVariable()
Visual Basic
Public Overrides Function ScriptVariable As Object

See Also

GH_Material Class
Grasshopper.Kernel.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_Material..::..ToString Method
GH_Material Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_Material Class
Grasshopper.Kernel.Types Namespace


Write Method

[image]

Grasshopper SDK
GH_Material..::..Write Method
GH_Material Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overrides Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

See Also

GH_Material Class
Grasshopper.Kernel.Types Namespace


GH_Material Properties

[image] [image]

Grasshopper SDK
GH_Material Properties
GH_Material Class See Also Send Feedback

The GH_Material type exposes the following members.

Properties

 | Name | Description
Public property | IsReferencedShader |
Public property | IsValid | (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot.)
Public property | RDK_ID |
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the internal data. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Material Class
Grasshopper.Kernel.Types Namespace


IsReferencedShader Property

[image]

Grasshopper SDK
GH_Material..::..IsReferencedShader Property
GH_Material Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsReferencedShader { get; }
Visual Basic
Public ReadOnly Property IsReferencedShader As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Material.IsReferencedShader"]

See Also

GH_Material Class
Grasshopper.Kernel.Types Namespace


IsValid Property

[image]

Grasshopper SDK
GH_Material..::..IsValid Property
GH_Material Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool IsValid { get; }
Visual Basic
Public Overrides ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Material.IsValid"]

See Also

GH_Material Class
Grasshopper.Kernel.Types Namespace


IsValidWhyNot Property

[image]

Grasshopper SDK
GH_Material..::..IsValidWhyNot Property
GH_Material Class See Also Send Feedback
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string IsValidWhyNot { get; }
Visual Basic
Public Overrides ReadOnly Property IsValidWhyNot As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Material.IsValidWhyNot"]

See Also

GH_Material Class
Grasshopper.Kernel.Types Namespace


RDK_ID Property

[image]

Grasshopper SDK
GH_Material..::..RDK_ID Property
GH_Material Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid RDK_ID { get; set; }
Visual Basic
Public Property RDK_ID As Guid
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Material.RDK_ID"]

See Also

GH_Material Class
Grasshopper.Kernel.Types Namespace


TypeDescription Property

[image]

Grasshopper SDK
GH_Material..::..TypeDescription Property
GH_Material Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeDescription { get; }
Visual Basic
Public Overrides ReadOnly Property TypeDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Material.TypeDescription"]

See Also

GH_Material Class
Grasshopper.Kernel.Types Namespace


TypeName Property

[image]

Grasshopper SDK
GH_Material..::..TypeName Property
GH_Material Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeName { get; }
Visual Basic
Public Overrides ReadOnly Property TypeName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Material.TypeName"]

See Also

GH_Material Class
Grasshopper.Kernel.Types Namespace


GH_Material.GH_Material_Proxy Class

[image]

Grasshopper SDK
GH_Material..::..GH_Material_Proxy Class
GH_Material Class Members See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Material_Proxy : GH_GooProxy<GH_Material>
Visual Basic
Public Class GH_Material_Proxy _
    Inherits GH_GooProxy(Of GH_Material)

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_GooProxy <(Of <(<' GH_Material >)>)>
Grasshopper.Kernel.Types..::..GH_Material..::..GH_Material_Proxy

See Also

GH_Material..::..GH_Material_Proxy Members
Grasshopper.Kernel.Types Namespace


GH_Material.GH_Material_Proxy Members

[image] [image]

Grasshopper SDK
GH_Material..::..GH_Material_Proxy Members
GH_Material..::..GH_Material_Proxy Class Constructors Methods Properties See Also Send Feedback

Represents a implementation of the Rhino material

The GH_Material..::..GH_Material_Proxy type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Material..::..GH_Material_Proxy | Initializes a new instance of the GH_Material..::..GH_Material_Proxy class

Methods

 | Name | Description
Public method | Construct | Override this method to supply a custom UI during proxy construction. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FormatInstance | Returns a String description of the current value. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FromString | If IsParsable(), then attempts to convert the string to a generic type value (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | MutateString | Munge a string to remove obvious errors on account of the user. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | NumberToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | StringToNumber | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | ToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Ambient |
Public property | Diffuse |
Public property | Emission |
Public property | IsParsable | Gets a value indicating whether or not the type can be instantiated from a String. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | IsRDKMaterial |
Protected property | Owner | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | ProxyOwner | Gets the piece of Grasshopper data that spawned this proxy. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Shine |
Public property | Specular |
Public property | Transparency |
Public property | TypeDescription | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeName | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | UserString | Gets or sets the user-defined string that describes this proxy. This only really makes sense if the Proxy is Parsable. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Valid | Gets a value indicating whether this proxy represents valid data. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

See Also

GH_Material..::..GH_Material_Proxy Class
Grasshopper.Kernel.Types Namespace


GH_Material.GH_Material_Proxy Constructor

[image]

Grasshopper SDK
GH_Material..::..GH_Material_Proxy Constructor
GH_Material..::..GH_Material_Proxy Class See Also Send Feedback
Initializes a new instance of the GH_Material..::..GH_Material_Proxy class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Material_Proxy(
    GH_Material nValue
)
Visual Basic
Public Sub New ( _
    nValue As GH_Material _
)

Parameters

nValue
Type: Grasshopper.Kernel.Types..::..GH_Material

See Also

GH_Material..::..GH_Material_Proxy Class
Grasshopper.Kernel.Types Namespace


GH_Material.GH_Material_Proxy Methods

[image] [image]

Grasshopper SDK
GH_Material..::..GH_Material_Proxy Methods
GH_Material..::..GH_Material_Proxy Class See Also Send Feedback

The GH_Material..::..GH_Material_Proxy type exposes the following members.

Methods

 | Name | Description
Public method | Construct | Override this method to supply a custom UI during proxy construction. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FormatInstance | Returns a String description of the current value. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FromString | If IsParsable(), then attempts to convert the string to a generic type value (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | MutateString | Munge a string to remove obvious errors on account of the user. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | NumberToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | StringToNumber | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | ToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

See Also

GH_Material..::..GH_Material_Proxy Class
Grasshopper.Kernel.Types Namespace


GH_Material.GH_Material_Proxy Properties

[image] [image]

Grasshopper SDK
GH_Material..::..GH_Material_Proxy Properties
GH_Material..::..GH_Material_Proxy Class See Also Send Feedback

The GH_Material..::..GH_Material_Proxy type exposes the following members.

Properties

 | Name | Description
Public property | Ambient |
Public property | Diffuse |
Public property | Emission |
Public property | IsParsable | Gets a value indicating whether or not the type can be instantiated from a String. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | IsRDKMaterial |
Protected property | Owner | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | ProxyOwner | Gets the piece of Grasshopper data that spawned this proxy. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Shine |
Public property | Specular |
Public property | Transparency |
Public property | TypeDescription | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeName | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | UserString | Gets or sets the user-defined string that describes this proxy. This only really makes sense if the Proxy is Parsable. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Valid | Gets a value indicating whether this proxy represents valid data. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

See Also

GH_Material..::..GH_Material_Proxy Class
Grasshopper.Kernel.Types Namespace


Ambient Property

[image]

Grasshopper SDK
GH_Material..::..GH_Material_Proxy..::..Ambient Property
GH_Material..::..GH_Material_Proxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color Ambient { get; set; }
Visual Basic
Public Property Ambient As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Material.GH_Material_Proxy.Ambient"]

See Also

GH_Material..::..GH_Material_Proxy Class
Grasshopper.Kernel.Types Namespace


Diffuse Property

[image]

Grasshopper SDK
GH_Material..::..GH_Material_Proxy..::..Diffuse Property
GH_Material..::..GH_Material_Proxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color Diffuse { get; set; }
Visual Basic
Public Property Diffuse As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Material.GH_Material_Proxy.Diffuse"]

See Also

GH_Material..::..GH_Material_Proxy Class
Grasshopper.Kernel.Types Namespace


Emission Property

[image]

Grasshopper SDK
GH_Material..::..GH_Material_Proxy..::..Emission Property
GH_Material..::..GH_Material_Proxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color Emission { get; set; }
Visual Basic
Public Property Emission As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Material.GH_Material_Proxy.Emission"]

See Also

GH_Material..::..GH_Material_Proxy Class
Grasshopper.Kernel.Types Namespace


IsRDKMaterial Property

[image]

Grasshopper SDK
GH_Material..::..GH_Material_Proxy..::..IsRDKMaterial Property
GH_Material..::..GH_Material_Proxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsRDKMaterial { get; }
Visual Basic
Public ReadOnly Property IsRDKMaterial As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Material.GH_Material_Proxy.IsRDKMaterial"]

See Also

GH_Material..::..GH_Material_Proxy Class
Grasshopper.Kernel.Types Namespace


Shine Property

[image]

Grasshopper SDK
GH_Material..::..GH_Material_Proxy..::..Shine Property
GH_Material..::..GH_Material_Proxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double Shine { get; set; }
Visual Basic
Public Property Shine As Double
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Material.GH_Material_Proxy.Shine"]

See Also

GH_Material..::..GH_Material_Proxy Class
Grasshopper.Kernel.Types Namespace


Specular Property

[image]

Grasshopper SDK
GH_Material..::..GH_Material_Proxy..::..Specular Property
GH_Material..::..GH_Material_Proxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Color Specular { get; set; }
Visual Basic
Public Property Specular As Color
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Material.GH_Material_Proxy.Specular"]

See Also

GH_Material..::..GH_Material_Proxy Class
Grasshopper.Kernel.Types Namespace


Transparency Property

[image]

Grasshopper SDK
GH_Material..::..GH_Material_Proxy..::..Transparency Property
GH_Material..::..GH_Material_Proxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double Transparency { get; set; }
Visual Basic
Public Property Transparency As Double
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Material.GH_Material_Proxy.Transparency"]

See Also

GH_Material..::..GH_Material_Proxy Class
Grasshopper.Kernel.Types Namespace


GH_Material.RDK_GL_Result Enumeration

[image]

Grasshopper SDK
GH_Material..::..RDK_GL_Result Enumeration
GH_Material Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum RDK_GL_Result
Visual Basic
Public Enumeration RDK_GL_Result

Members

Member name | Value | Description
none | 0 |
success | 1 |
ID_not_found | 10 |
RDK_not_found | 11 |

See Also

Grasshopper.Kernel.Types Namespace


GH_Matrix Class

[image]

Grasshopper SDK
GH_Matrix Class
Members See Also Send Feedback
Represents a 32-bit signed integer. GH_Integer re-implements the framework System.Int32 type.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Matrix : GH_Goo<Matrix>,
    IGH_QuickCast
Visual Basic
Public Class GH_Matrix _
    Inherits GH_Goo(Of Matrix) _
    Implements IGH_QuickCast

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_Goo <(Of <(<'Matrix>)>)>
Grasshopper.Kernel.Types..::..GH_Matrix

See Also

GH_Matrix Members
Grasshopper.Kernel.Types Namespace


GH_Matrix Members

[image] [image]

Grasshopper SDK
GH_Matrix Members
GH_Matrix Class Constructors Methods Fields Properties See Also Send Feedback

The GH_Matrix type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Matrix()()()() | Blank constructor
Public method | GH_Matrix(Matrix) | Initializes a new instance of the GH_Matrix class
Public method | GH_Matrix(GH_Matrix) | Initializes a new instance of the GH_Matrix class

Methods

 | Name | Description
Public method | CastFrom | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
 | CloneMatrix | Duplicates a Matrix.
Public method | Duplicate | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateMatrix |
Public method | EmitProxy | Create a new proxy for this instance. Return Null if this class does not support proxies. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ScriptVariable()()()().)
Public method | ToString | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | IsValid | Gets the validity of this instance. Integers are always valid. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the internal data. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Matrix Class
Grasshopper.Kernel.Types Namespace


GH_Matrix Constructor

[image] [image]

Grasshopper SDK
GH_Matrix Constructor
GH_Matrix Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Matrix()()()() | Blank constructor
Public method | GH_Matrix(Matrix) | Initializes a new instance of the GH_Matrix class
Public method | GH_Matrix(GH_Matrix) | Initializes a new instance of the GH_Matrix class

See Also

GH_Matrix Class
GH_Matrix Members
Grasshopper.Kernel.Types Namespace


GH_Matrix Constructor

[image]

Grasshopper SDK
GH_Matrix Constructor
GH_Matrix Class See Also Send Feedback
Blank constructor

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Matrix()
Visual Basic
Public Sub New

See Also

GH_Matrix Class
GH_Matrix Overload
Grasshopper.Kernel.Types Namespace


GH_Matrix Constructor ()

[image]

Grasshopper SDK
GH_Matrix Constructor ()
GH_Matrix Class See Also Send Feedback
Initializes a new instance of the GH_Matrix class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Matrix(
    Matrix matrix
)
Visual Basic
Public Sub New ( _
    matrix As Matrix _
)

Parameters

matrix
Type: Matrix

See Also

GH_Matrix Class
GH_Matrix Overload
Grasshopper.Kernel.Types Namespace


GH_Matrix Constructor (GH_Matrix)

[image]

Grasshopper SDK
GH_Matrix Constructor (GH_Matrix)
GH_Matrix Class See Also Send Feedback
Initializes a new instance of the GH_Matrix class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Matrix(
    GH_Matrix other
)
Visual Basic
Public Sub New ( _
    other As GH_Matrix _
)

Parameters

other
Type: Grasshopper.Kernel.Types..::..GH_Matrix

See Also

GH_Matrix Class
GH_Matrix Overload
Grasshopper.Kernel.Types Namespace


GH_Matrix Fields

[image] [image]

Grasshopper SDK
GH_Matrix Fields
GH_Matrix Class See Also Send Feedback

The GH_Matrix type exposes the following members.

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Matrix Class
Grasshopper.Kernel.Types Namespace


GH_Matrix Methods

[image] [image]

Grasshopper SDK
GH_Matrix Methods
GH_Matrix Class See Also Send Feedback

The GH_Matrix type exposes the following members.

Methods

 | Name | Description
Public method | CastFrom | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
 | CloneMatrix | Duplicates a Matrix.
Public method | Duplicate | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateMatrix |
Public method | EmitProxy | Create a new proxy for this instance. Return Null if this class does not support proxies. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ScriptVariable()()()().)
Public method | ToString | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

See Also

GH_Matrix Class
Grasshopper.Kernel.Types Namespace


CastFrom Method

[image]

Grasshopper SDK
GH_Matrix..::..CastFrom Method
GH_Matrix Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastFrom(
    Object source
)
Visual Basic
Public Overrides Function CastFrom ( _
    source As Object _
) As Boolean

Parameters

source
Type: System..::..Object

See Also

GH_Matrix Class
Grasshopper.Kernel.Types Namespace


CastTo Method

[image] [image]

Grasshopper SDK
GH_Matrix..::..CastTo Method
GH_Matrix Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)

See Also

GH_Matrix Class
GH_Matrix Members
Grasshopper.Kernel.Types Namespace


CastTo(T) Method (T)

[image]

Grasshopper SDK
GH_Matrix..::..CastTo<(Of <(<'T>)>)> Method (T%)
GH_Matrix Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastTo<T>(
    out T target
)
Visual Basic
Public Overrides Function CastTo(Of T) ( _
    <OutAttribute> ByRef target As T _
) As Boolean

Parameters

target
Type: T%

Type Parameters

T

See Also

GH_Matrix Class
CastTo Overload
Grasshopper.Kernel.Types Namespace


CloneMatrix Method

[image]

Grasshopper SDK
GH_Matrix..::..CloneMatrix Method
GH_Matrix Class See Also Send Feedback
Duplicates a Matrix.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Matrix CloneMatrix(
    Matrix matrix
)
Visual Basic
Public Shared Function CloneMatrix ( _
    matrix As Matrix _
) As Matrix

Parameters

matrix
Type: Matrix

See Also

GH_Matrix Class
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_Matrix..::..Duplicate Method
GH_Matrix Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_Goo Duplicate()
Visual Basic
Public Overrides Function Duplicate As IGH_Goo

See Also

GH_Matrix Class
Grasshopper.Kernel.Types Namespace


DuplicateMatrix Method

[image]

Grasshopper SDK
GH_Matrix..::..DuplicateMatrix Method
GH_Matrix Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Matrix DuplicateMatrix()
Visual Basic
Public Function DuplicateMatrix As GH_Matrix

See Also

GH_Matrix Class
Grasshopper.Kernel.Types Namespace


Read Method

[image]

Grasshopper SDK
GH_Matrix..::..Read Method
GH_Matrix Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

See Also

GH_Matrix Class
Grasshopper.Kernel.Types Namespace


ScriptVariable Method

[image]

Grasshopper SDK
GH_Matrix..::..ScriptVariable Method
GH_Matrix Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override Object ScriptVariable()
Visual Basic
Public Overrides Function ScriptVariable As Object

See Also

GH_Matrix Class
Grasshopper.Kernel.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_Matrix..::..ToString Method
GH_Matrix Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_Matrix Class
Grasshopper.Kernel.Types Namespace


Write Method

[image]

Grasshopper SDK
GH_Matrix..::..Write Method
GH_Matrix Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overrides Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

See Also

GH_Matrix Class
Grasshopper.Kernel.Types Namespace


GH_Matrix Properties

[image] [image]

Grasshopper SDK
GH_Matrix Properties
GH_Matrix Class See Also Send Feedback

The GH_Matrix type exposes the following members.

Properties

 | Name | Description
Public property | IsValid | Gets the validity of this instance. Integers are always valid. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the internal data. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Matrix Class
Grasshopper.Kernel.Types Namespace


IsValid Property

[image]

Grasshopper SDK
GH_Matrix..::..IsValid Property
GH_Matrix Class See Also Send Feedback
Gets the validity of this instance. Integers are always valid.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool IsValid { get; }
Visual Basic
Public Overrides ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Matrix.IsValid"]

See Also

GH_Matrix Class
Grasshopper.Kernel.Types Namespace


TypeDescription Property

[image]

Grasshopper SDK
GH_Matrix..::..TypeDescription Property
GH_Matrix Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeDescription { get; }
Visual Basic
Public Overrides ReadOnly Property TypeDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Matrix.TypeDescription"]

See Also

GH_Matrix Class
Grasshopper.Kernel.Types Namespace


TypeName Property

[image]

Grasshopper SDK
GH_Matrix..::..TypeName Property
GH_Matrix Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeName { get; }
Visual Basic
Public Overrides ReadOnly Property TypeName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Matrix.TypeName"]

See Also

GH_Matrix Class
Grasshopper.Kernel.Types Namespace


GH_Mesh Class

[image]

Grasshopper SDK
GH_Mesh Class
Members See Also Send Feedback
Represents a 3D polygonal mesh composed of quads and tris. GH_MEsh wraps the functionality of the OpenNURBS OnMesh class.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Mesh : GH_GeometricGoo<Mesh>,
    IGH_BakeAwareData, IGH_PreviewData
Visual Basic
Public Class GH_Mesh _
    Inherits GH_GeometricGoo(Of Mesh) _
    Implements IGH_BakeAwareData, IGH_PreviewData

Remarks

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_Goo <(Of <(<'Mesh>)>)>
Grasshopper.Kernel.Types..::..GH_GeometricGoo <(Of <(<'Mesh>)>)>
Grasshopper.Kernel.Types..::..GH_Mesh

See Also

GH_Mesh Members
Grasshopper.Kernel.Types Namespace


GH_Mesh Members

[image] [image]

Grasshopper SDK
GH_Mesh Members
GH_Mesh Class Constructors Methods Fields Properties See Also Send Feedback

The GH_Mesh type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Mesh()()()() | Initializes a new instance of the GH_Mesh class
Public method | GH_Mesh(Mesh) | Initializes a new instance of the GH_Mesh class
Public method | GH_Mesh(Guid) | Initializes a new instance of the GH_Mesh class
Public method | GH_Mesh(GH_Mesh) | Initializes a new instance of the GH_Mesh class

Methods

 | Name | Description
Public method | BakeGeometry |
Public method | CastFrom | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type T. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | ClearCaches | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..ClearCaches()()()().)
Public method | DrawViewportMeshes |
Public method | DrawViewportWires |
Public method | Duplicate | Make a complete duplicate of this instance. No shallow copies. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | DuplicateGeometry | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..DuplicateGeometry()()()().)
Public method | DuplicateMesh |
Public method | EmitProxy | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | GetBoundingBox | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..GetBoundingBox(Transform).)
Public method | LoadGeometry()()()() | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | LoadGeometry(RhinoDoc) | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..LoadGeometry(RhinoDoc).)
Public method | Morph | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Morph(SpaceMorph).)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ScriptVariable()()()().)
Public method | ToString | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Transform | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Transform(Transform).)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Boundingbox | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Boundingbox.)
Public property | ClippingBox |
Public property | IsGeometryLoaded | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..IsGeometryLoaded.)
Public property | IsReferencedGeometry | Gets a value indicating whether or not this geometry is referenced. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public property | IsValid | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot.)
Public property | ReferenceID | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..ReferenceID.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the value of this type. Note that if the type has a ReferenceID this value might get destroyed in the future. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)

See Also

GH_Mesh Class
Grasshopper.Kernel.Types Namespace


GH_Mesh Constructor

[image] [image]

Grasshopper SDK
GH_Mesh Constructor
GH_Mesh Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Mesh()()()() | Initializes a new instance of the GH_Mesh class
Public method | GH_Mesh(Mesh) | Initializes a new instance of the GH_Mesh class
Public method | GH_Mesh(Guid) | Initializes a new instance of the GH_Mesh class
Public method | GH_Mesh(GH_Mesh) | Initializes a new instance of the GH_Mesh class

See Also

GH_Mesh Class
GH_Mesh Members
Grasshopper.Kernel.Types Namespace


GH_Mesh Constructor

[image]

Grasshopper SDK
GH_Mesh Constructor
GH_Mesh Class See Also Send Feedback
Initializes a new instance of the GH_Mesh class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Mesh()
Visual Basic
Public Sub New

See Also

GH_Mesh Class
GH_Mesh Overload
Grasshopper.Kernel.Types Namespace


GH_Mesh Constructor ()

[image]

Grasshopper SDK
GH_Mesh Constructor ()
GH_Mesh Class See Also Send Feedback
Initializes a new instance of the GH_Mesh class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Mesh(
    Mesh mesh
)
Visual Basic
Public Sub New ( _
    mesh As Mesh _
)

Parameters

mesh
Type: Mesh

See Also

GH_Mesh Class
GH_Mesh Overload
Grasshopper.Kernel.Types Namespace


GH_Mesh Constructor (Guid)

[image]

Grasshopper SDK
GH_Mesh Constructor (Guid)
GH_Mesh Class See Also Send Feedback
Initializes a new instance of the GH_Mesh class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Mesh(
    Guid id
)
Visual Basic
Public Sub New ( _
    id As Guid _
)

Parameters

id
Type: System..::..Guid

See Also

GH_Mesh Class
GH_Mesh Overload
Grasshopper.Kernel.Types Namespace


GH_Mesh Constructor (GH_Mesh)

[image]

Grasshopper SDK
GH_Mesh Constructor (GH_Mesh)
GH_Mesh Class See Also Send Feedback
Initializes a new instance of the GH_Mesh class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Mesh(
    GH_Mesh other
)
Visual Basic
Public Sub New ( _
    other As GH_Mesh _
)

Parameters

other
Type: Grasshopper.Kernel.Types..::..GH_Mesh

See Also

GH_Mesh Class
GH_Mesh Overload
Grasshopper.Kernel.Types Namespace


GH_Mesh Fields

[image] [image]

Grasshopper SDK
GH_Mesh Fields
GH_Mesh Class See Also Send Feedback

The GH_Mesh type exposes the following members.

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Mesh Class
Grasshopper.Kernel.Types Namespace


GH_Mesh Methods

[image] [image]

Grasshopper SDK
GH_Mesh Methods
GH_Mesh Class See Also Send Feedback

The GH_Mesh type exposes the following members.

Methods

 | Name | Description
Public method | BakeGeometry |
Public method | CastFrom | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type T. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | ClearCaches | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..ClearCaches()()()().)
Public method | DrawViewportMeshes |
Public method | DrawViewportWires |
Public method | Duplicate | Make a complete duplicate of this instance. No shallow copies. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | DuplicateGeometry | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..DuplicateGeometry()()()().)
Public method | DuplicateMesh |
Public method | EmitProxy | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | GetBoundingBox | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..GetBoundingBox(Transform).)
Public method | LoadGeometry()()()() | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | LoadGeometry(RhinoDoc) | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..LoadGeometry(RhinoDoc).)
Public method | Morph | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Morph(SpaceMorph).)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ScriptVariable()()()().)
Public method | ToString | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Transform | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Transform(Transform).)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

See Also

GH_Mesh Class
Grasshopper.Kernel.Types Namespace


BakeGeometry Method

[image]

Grasshopper SDK
GH_Mesh..::..BakeGeometry Method
GH_Mesh Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool BakeGeometry(
    RhinoDoc doc,
    ObjectAttributes att,
    ref Guid obj_guid
)
Visual Basic
Public Function BakeGeometry ( _
    doc As RhinoDoc, _
    att As ObjectAttributes, _
    ByRef obj_guid As Guid _
) As Boolean

Parameters

doc
Type: RhinoDoc
att
Type: ObjectAttributes
obj_guid
Type: System..::..Guid %

Implements

IGH_BakeAwareData..::..BakeGeometry(RhinoDoc, ObjectAttributes, Guid%)

See Also

GH_Mesh Class
Grasshopper.Kernel.Types Namespace


CastFrom Method

[image]

Grasshopper SDK
GH_Mesh..::..CastFrom Method
GH_Mesh Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastFrom(
    Object source
)
Visual Basic
Public Overrides Function CastFrom ( _
    source As Object _
) As Boolean

Parameters

source
Type: System..::..Object

See Also

GH_Mesh Class
Grasshopper.Kernel.Types Namespace


CastTo Method

[image] [image]

Grasshopper SDK
GH_Mesh..::..CastTo Method
GH_Mesh Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type T. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)

See Also

GH_Mesh Class
GH_Mesh Members
Grasshopper.Kernel.Types Namespace


CastTo(T) Method (T)

[image]

Grasshopper SDK
GH_Mesh..::..CastTo<(Of <(<'T>)>)> Method (T%)
GH_Mesh Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastTo<T>(
    out T target
)
Visual Basic
Public Overrides Function CastTo(Of T) ( _
    <OutAttribute> ByRef target As T _
) As Boolean

Parameters

target
Type: T%

Type Parameters

T

See Also

GH_Mesh Class
CastTo Overload
Grasshopper.Kernel.Types Namespace


ClearCaches Method

[image]

Grasshopper SDK
GH_Mesh..::..ClearCaches Method
GH_Mesh Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void ClearCaches()
Visual Basic
Public Overrides Sub ClearCaches

See Also

GH_Mesh Class
Grasshopper.Kernel.Types Namespace


DrawViewportMeshes Method

[image]

Grasshopper SDK
GH_Mesh..::..DrawViewportMeshes Method
GH_Mesh Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DrawViewportMeshes(
    GH_PreviewMeshArgs args
)
Visual Basic
Public Sub DrawViewportMeshes ( _
    args As GH_PreviewMeshArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..GH_PreviewMeshArgs

Implements

IGH_PreviewData..::..DrawViewportMeshes(GH_PreviewMeshArgs)

See Also

GH_Mesh Class
Grasshopper.Kernel.Types Namespace


DrawViewportWires Method

[image]

Grasshopper SDK
GH_Mesh..::..DrawViewportWires Method
GH_Mesh Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DrawViewportWires(
    GH_PreviewWireArgs args
)
Visual Basic
Public Sub DrawViewportWires ( _
    args As GH_PreviewWireArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..GH_PreviewWireArgs

Implements

IGH_PreviewData..::..DrawViewportWires(GH_PreviewWireArgs)

See Also

GH_Mesh Class
Grasshopper.Kernel.Types Namespace


DuplicateGeometry Method

[image]

Grasshopper SDK
GH_Mesh..::..DuplicateGeometry Method
GH_Mesh Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GeometricGoo DuplicateGeometry()
Visual Basic
Public Overrides Function DuplicateGeometry As IGH_GeometricGoo

See Also

GH_Mesh Class
Grasshopper.Kernel.Types Namespace


DuplicateMesh Method

[image]

Grasshopper SDK
GH_Mesh..::..DuplicateMesh Method
GH_Mesh Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Mesh DuplicateMesh()
Visual Basic
Public Function DuplicateMesh As GH_Mesh

See Also

GH_Mesh Class
Grasshopper.Kernel.Types Namespace


EmitProxy Method

[image]

Grasshopper SDK
GH_Mesh..::..EmitProxy Method
GH_Mesh Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GooProxy EmitProxy()
Visual Basic
Public Overrides Function EmitProxy As IGH_GooProxy

See Also

GH_Mesh Class
Grasshopper.Kernel.Types Namespace


GetBoundingBox Method

[image]

Grasshopper SDK
GH_Mesh..::..GetBoundingBox Method
GH_Mesh Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override BoundingBox GetBoundingBox(
    Transform xform
)
Visual Basic
Public Overrides Function GetBoundingBox ( _
    xform As Transform _
) As BoundingBox

Parameters

xform
Type: Transform

See Also

GH_Mesh Class
Grasshopper.Kernel.Types Namespace


LoadGeometry Method

[image] [image]

Grasshopper SDK
GH_Mesh..::..LoadGeometry Method
GH_Mesh Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LoadGeometry()()()() | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | LoadGeometry(RhinoDoc) | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..LoadGeometry(RhinoDoc).)

See Also

GH_Mesh Class
GH_Mesh Members
Grasshopper.Kernel.Types Namespace


LoadGeometry Method ()

[image]

Grasshopper SDK
GH_Mesh..::..LoadGeometry Method ()
GH_Mesh Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool LoadGeometry(
    RhinoDoc doc
)
Visual Basic
Public Overrides Function LoadGeometry ( _
    doc As RhinoDoc _
) As Boolean

Parameters

doc
Type: RhinoDoc

See Also

GH_Mesh Class
LoadGeometry Overload
Grasshopper.Kernel.Types Namespace


Morph Method

[image]

Grasshopper SDK
GH_Mesh..::..Morph Method
GH_Mesh Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GeometricGoo Morph(
    SpaceMorph xmorph
)
Visual Basic
Public Overrides Function Morph ( _
    xmorph As SpaceMorph _
) As IGH_GeometricGoo

Parameters

xmorph
Type: SpaceMorph

See Also

GH_Mesh Class
Grasshopper.Kernel.Types Namespace


Read Method

[image]

Grasshopper SDK
GH_Mesh..::..Read Method
GH_Mesh Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

See Also

GH_Mesh Class
Grasshopper.Kernel.Types Namespace


ScriptVariable Method

[image]

Grasshopper SDK
GH_Mesh..::..ScriptVariable Method
GH_Mesh Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override Object ScriptVariable()
Visual Basic
Public Overrides Function ScriptVariable As Object

See Also

GH_Mesh Class
Grasshopper.Kernel.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_Mesh..::..ToString Method
GH_Mesh Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_Mesh Class
Grasshopper.Kernel.Types Namespace


Transform Method

[image]

Grasshopper SDK
GH_Mesh..::..Transform Method
GH_Mesh Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GeometricGoo Transform(
    Transform xform
)
Visual Basic
Public Overrides Function Transform ( _
    xform As Transform _
) As IGH_GeometricGoo

Parameters

xform
Type: Transform

See Also

GH_Mesh Class
Grasshopper.Kernel.Types Namespace


Write Method

[image]

Grasshopper SDK
GH_Mesh..::..Write Method
GH_Mesh Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overrides Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

See Also

GH_Mesh Class
Grasshopper.Kernel.Types Namespace


GH_Mesh Properties

[image] [image]

Grasshopper SDK
GH_Mesh Properties
GH_Mesh Class See Also Send Feedback

The GH_Mesh type exposes the following members.

Properties

 | Name | Description
Public property | Boundingbox | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Boundingbox.)
Public property | ClippingBox |
Public property | IsGeometryLoaded | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..IsGeometryLoaded.)
Public property | IsReferencedGeometry | Gets a value indicating whether or not this geometry is referenced. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public property | IsValid | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot.)
Public property | ReferenceID | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..ReferenceID.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the value of this type. Note that if the type has a ReferenceID this value might get destroyed in the future. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)

See Also

GH_Mesh Class
Grasshopper.Kernel.Types Namespace


Boundingbox Property

[image]

Grasshopper SDK
GH_Mesh..::..Boundingbox Property
GH_Mesh Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override BoundingBox Boundingbox { get; }
Visual Basic
Public Overrides ReadOnly Property Boundingbox As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Mesh.Boundingbox"]

See Also

GH_Mesh Class
Grasshopper.Kernel.Types Namespace


ClippingBox Property

[image]

Grasshopper SDK
GH_Mesh..::..ClippingBox Property
GH_Mesh Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public BoundingBox ClippingBox { get; }
Visual Basic
Public ReadOnly Property ClippingBox As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Mesh.ClippingBox"]

Implements

IGH_PreviewData..::..ClippingBox

See Also

GH_Mesh Class
Grasshopper.Kernel.Types Namespace


IsGeometryLoaded Property

[image]

Grasshopper SDK
GH_Mesh..::..IsGeometryLoaded Property
GH_Mesh Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool IsGeometryLoaded { get; }
Visual Basic
Public Overrides ReadOnly Property IsGeometryLoaded As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Mesh.IsGeometryLoaded"]

See Also

GH_Mesh Class
Grasshopper.Kernel.Types Namespace


IsValid Property

[image]

Grasshopper SDK
GH_Mesh..::..IsValid Property
GH_Mesh Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool IsValid { get; }
Visual Basic
Public Overrides ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Mesh.IsValid"]

See Also

GH_Mesh Class
Grasshopper.Kernel.Types Namespace


IsValidWhyNot Property

[image]

Grasshopper SDK
GH_Mesh..::..IsValidWhyNot Property
GH_Mesh Class See Also Send Feedback
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string IsValidWhyNot { get; }
Visual Basic
Public Overrides ReadOnly Property IsValidWhyNot As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Mesh.IsValidWhyNot"]

See Also

GH_Mesh Class
Grasshopper.Kernel.Types Namespace


ReferenceID Property

[image]

Grasshopper SDK
GH_Mesh..::..ReferenceID Property
GH_Mesh Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override Guid ReferenceID { get; set; }
Visual Basic
Public Overrides Property ReferenceID As Guid
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Mesh.ReferenceID"]

See Also

GH_Mesh Class
Grasshopper.Kernel.Types Namespace


TypeDescription Property

[image]

Grasshopper SDK
GH_Mesh..::..TypeDescription Property
GH_Mesh Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeDescription { get; }
Visual Basic
Public Overrides ReadOnly Property TypeDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Mesh.TypeDescription"]

See Also

GH_Mesh Class
Grasshopper.Kernel.Types Namespace


TypeName Property

[image]

Grasshopper SDK
GH_Mesh..::..TypeName Property
GH_Mesh Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeName { get; }
Visual Basic
Public Overrides ReadOnly Property TypeName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Mesh.TypeName"]

See Also

GH_Mesh Class
Grasshopper.Kernel.Types Namespace


GH_Mesh.GH_MeshProxy Class

[image]

Grasshopper SDK
GH_Mesh..::..GH_MeshProxy Class
GH_Mesh Class Members See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_MeshProxy : GH_GooProxy<GH_Mesh>
Visual Basic
Public Class GH_MeshProxy _
    Inherits GH_GooProxy(Of GH_Mesh)

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_GooProxy <(Of <(<' GH_Mesh >)>)>
Grasshopper.Kernel.Types..::..GH_Mesh..::..GH_MeshProxy

See Also

GH_Mesh..::..GH_MeshProxy Members
Grasshopper.Kernel.Types Namespace


GH_Mesh.GH_MeshProxy Members

[image] [image]

Grasshopper SDK
GH_Mesh..::..GH_MeshProxy Members
GH_Mesh..::..GH_MeshProxy Class Constructors Methods Properties See Also Send Feedback

Represents a 3D polygonal mesh composed of quads and tris. GH_MEsh wraps the functionality of the OpenNURBS OnMesh class.

The GH_Mesh..::..GH_MeshProxy type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Mesh..::..GH_MeshProxy | Initializes a new instance of the GH_Mesh..::..GH_MeshProxy class

Methods

 | Name | Description
Public method | Construct | (Overrides GH_GooProxy<(Of <(<'T>)>)>..::..Construct()()()().)
Public method | FormatInstance | Returns a String description of the current value. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FromString | If IsParsable(), then attempts to convert the string to a generic type value (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | MutateString | Munge a string to remove obvious errors on account of the user. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | NumberToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | StringToNumber | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | ToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Area |
Public property | EdgeCount |
Public property | FaceCount |
Public property | IsParsable | Gets a value indicating whether or not the type can be instantiated from a String. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Manifold |
Public property | ObjectID |
Protected property | Owner | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | ProxyOwner | Gets the piece of Grasshopper data that spawned this proxy. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Solid |
Public property | TypeDescription | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeName | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | UserString | Gets or sets the user-defined string that describes this proxy. This only really makes sense if the Proxy is Parsable. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Valid | Gets a value indicating whether this proxy represents valid data. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | VertexCount |
Public property | Volume |

See Also

GH_Mesh..::..GH_MeshProxy Class
Grasshopper.Kernel.Types Namespace


GH_Mesh.GH_MeshProxy Constructor

[image]

Grasshopper SDK
GH_Mesh..::..GH_MeshProxy Constructor
GH_Mesh..::..GH_MeshProxy Class See Also Send Feedback
Initializes a new instance of the GH_Mesh..::..GH_MeshProxy class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_MeshProxy(
    GH_Mesh Value
)
Visual Basic
Public Sub New ( _
    Value As GH_Mesh _
)

Parameters

Value
Type: Grasshopper.Kernel.Types..::..GH_Mesh

See Also

GH_Mesh..::..GH_MeshProxy Class
Grasshopper.Kernel.Types Namespace


GH_Mesh.GH_MeshProxy Methods

[image] [image]

Grasshopper SDK
GH_Mesh..::..GH_MeshProxy Methods
GH_Mesh..::..GH_MeshProxy Class See Also Send Feedback

The GH_Mesh..::..GH_MeshProxy type exposes the following members.

Methods

 | Name | Description
Public method | Construct | (Overrides GH_GooProxy<(Of <(<'T>)>)>..::..Construct()()()().)
Public method | FormatInstance | Returns a String description of the current value. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FromString | If IsParsable(), then attempts to convert the string to a generic type value (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | MutateString | Munge a string to remove obvious errors on account of the user. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | NumberToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | StringToNumber | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | ToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

See Also

GH_Mesh..::..GH_MeshProxy Class
Grasshopper.Kernel.Types Namespace


Construct Method

[image]

Grasshopper SDK
GH_Mesh..::..GH_MeshProxy..::..Construct Method
GH_Mesh..::..GH_MeshProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void Construct()
Visual Basic
Public Overrides Sub Construct

See Also

GH_Mesh..::..GH_MeshProxy Class
Grasshopper.Kernel.Types Namespace


GH_Mesh.GH_MeshProxy Properties

[image] [image]

Grasshopper SDK
GH_Mesh..::..GH_MeshProxy Properties
GH_Mesh..::..GH_MeshProxy Class See Also Send Feedback

The GH_Mesh..::..GH_MeshProxy type exposes the following members.

Properties

 | Name | Description
Public property | Area |
Public property | EdgeCount |
Public property | FaceCount |
Public property | IsParsable | Gets a value indicating whether or not the type can be instantiated from a String. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Manifold |
Public property | ObjectID |
Protected property | Owner | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | ProxyOwner | Gets the piece of Grasshopper data that spawned this proxy. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Solid |
Public property | TypeDescription | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeName | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | UserString | Gets or sets the user-defined string that describes this proxy. This only really makes sense if the Proxy is Parsable. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Valid | Gets a value indicating whether this proxy represents valid data. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | VertexCount |
Public property | Volume |

See Also

GH_Mesh..::..GH_MeshProxy Class
Grasshopper.Kernel.Types Namespace


Area Property

[image]

Grasshopper SDK
GH_Mesh..::..GH_MeshProxy..::..Area Property
GH_Mesh..::..GH_MeshProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Area { get; }
Visual Basic
Public ReadOnly Property Area As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Mesh.GH_MeshProxy.Area"]

See Also

GH_Mesh..::..GH_MeshProxy Class
Grasshopper.Kernel.Types Namespace


EdgeCount Property

[image]

Grasshopper SDK
GH_Mesh..::..GH_MeshProxy..::..EdgeCount Property
GH_Mesh..::..GH_MeshProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int EdgeCount { get; }
Visual Basic
Public ReadOnly Property EdgeCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Mesh.GH_MeshProxy.EdgeCount"]

See Also

GH_Mesh..::..GH_MeshProxy Class
Grasshopper.Kernel.Types Namespace


FaceCount Property

[image]

Grasshopper SDK
GH_Mesh..::..GH_MeshProxy..::..FaceCount Property
GH_Mesh..::..GH_MeshProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int FaceCount { get; }
Visual Basic
Public ReadOnly Property FaceCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Mesh.GH_MeshProxy.FaceCount"]

See Also

GH_Mesh..::..GH_MeshProxy Class
Grasshopper.Kernel.Types Namespace


Manifold Property

[image]

Grasshopper SDK
GH_Mesh..::..GH_MeshProxy..::..Manifold Property
GH_Mesh..::..GH_MeshProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Manifold { get; }
Visual Basic
Public ReadOnly Property Manifold As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Mesh.GH_MeshProxy.Manifold"]

See Also

GH_Mesh..::..GH_MeshProxy Class
Grasshopper.Kernel.Types Namespace


ObjectID Property

[image]

Grasshopper SDK
GH_Mesh..::..GH_MeshProxy..::..ObjectID Property
GH_Mesh..::..GH_MeshProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string ObjectID { get; set; }
Visual Basic
Public Property ObjectID As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Mesh.GH_MeshProxy.ObjectID"]

See Also

GH_Mesh..::..GH_MeshProxy Class
Grasshopper.Kernel.Types Namespace


Solid Property

[image]

Grasshopper SDK
GH_Mesh..::..GH_MeshProxy..::..Solid Property
GH_Mesh..::..GH_MeshProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Solid { get; }
Visual Basic
Public ReadOnly Property Solid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Mesh.GH_MeshProxy.Solid"]

See Also

GH_Mesh..::..GH_MeshProxy Class
Grasshopper.Kernel.Types Namespace


VertexCount Property

[image]

Grasshopper SDK
GH_Mesh..::..GH_MeshProxy..::..VertexCount Property
GH_Mesh..::..GH_MeshProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int VertexCount { get; }
Visual Basic
Public ReadOnly Property VertexCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Mesh.GH_MeshProxy.VertexCount"]

See Also

GH_Mesh..::..GH_MeshProxy Class
Grasshopper.Kernel.Types Namespace


Volume Property

[image]

Grasshopper SDK
GH_Mesh..::..GH_MeshProxy..::..Volume Property
GH_Mesh..::..GH_MeshProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Volume { get; }
Visual Basic
Public ReadOnly Property Volume As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Mesh.GH_MeshProxy.Volume"]

See Also

GH_Mesh..::..GH_MeshProxy Class
Grasshopper.Kernel.Types Namespace


GH_MeshFace Class

[image]

Grasshopper SDK
GH_MeshFace Class
Members See Also Send Feedback
Represents a tri or quad mesh face. GH_MeshFace works similar to the OpenNURBS OnMeshFace class.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_MeshFace : GH_Goo<MeshFace>
Visual Basic
Public Class GH_MeshFace _
    Inherits GH_Goo(Of MeshFace)

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_Goo <(Of <(<'MeshFace>)>)>
Grasshopper.Kernel.Types..::..GH_MeshFace

See Also

GH_MeshFace Members
Grasshopper.Kernel.Types Namespace


GH_MeshFace Members

[image] [image]

Grasshopper SDK
GH_MeshFace Members
GH_MeshFace Class Constructors Methods Fields Properties See Also Send Feedback

The GH_MeshFace type exposes the following members.

Constructors

 | Name | Description
Public method | GH_MeshFace()()()() | Default constructor. Sets all corners to 0.
Public method | GH_MeshFace(MeshFace) | Create a duplicate of another mesh face.
Public method | GH_MeshFace(GH_MeshFace) | Create a duplicate of another mesh face
Public method | GH_MeshFace(Int32, Int32, Int32) | Create a triangular mesh face from 3 corners indices.
Public method | GH_MeshFace(Int32, Int32, Int32, Int32) | Create a quadrangular mesh face from 4 corners indices.

Methods

 | Name | Description
Public method | CastFrom | Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic. (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic. (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | Duplicate | Create a duplicate of this Mesh face. (Overrides GH_Goo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateMeshFace | Create a duplicate of this Mesh face.
Public method | EmitProxy | Returns a proxy that represents this mesh face. Do not call this function unless you're (Overrides GH_Goo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ToString | Format the mesh face using default grasshopper formatting logic. (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | IsValid | Test for validity. No negative indices are allowed and only C and D are allowed to be identical. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the internal data. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_MeshFace Class
Grasshopper.Kernel.Types Namespace


GH_MeshFace Constructor

[image] [image]

Grasshopper SDK
GH_MeshFace Constructor
GH_MeshFace Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_MeshFace()()()() | Default constructor. Sets all corners to 0.
Public method | GH_MeshFace(MeshFace) | Create a duplicate of another mesh face.
Public method | GH_MeshFace(GH_MeshFace) | Create a duplicate of another mesh face
Public method | GH_MeshFace(Int32, Int32, Int32) | Create a triangular mesh face from 3 corners indices.
Public method | GH_MeshFace(Int32, Int32, Int32, Int32) | Create a quadrangular mesh face from 4 corners indices.

See Also

GH_MeshFace Class
GH_MeshFace Members
Grasshopper.Kernel.Types Namespace


GH_MeshFace Constructor

[image]

Grasshopper SDK
GH_MeshFace Constructor
GH_MeshFace Class See Also Send Feedback
Default constructor. Sets all corners to 0.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_MeshFace()
Visual Basic
Public Sub New

See Also

GH_MeshFace Class
GH_MeshFace Overload
Grasshopper.Kernel.Types Namespace


GH_MeshFace Constructor ()

[image]

Grasshopper SDK
GH_MeshFace Constructor ()
GH_MeshFace Class See Also Send Feedback
Create a duplicate of another mesh face.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_MeshFace(
    MeshFace other
)
Visual Basic
Public Sub New ( _
    other As MeshFace _
)

Parameters

other
Type: MeshFace
Mesh face to duplicate.

See Also

GH_MeshFace Class
GH_MeshFace Overload
Grasshopper.Kernel.Types Namespace


GH_MeshFace Constructor (GH_MeshFace)

[image]

Grasshopper SDK
GH_MeshFace Constructor (GH_MeshFace)
GH_MeshFace Class See Also Send Feedback
Create a duplicate of another mesh face

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_MeshFace(
    GH_MeshFace other
)
Visual Basic
Public Sub New ( _
    other As GH_MeshFace _
)

Parameters

other
Type: Grasshopper.Kernel.Types..::..GH_MeshFace
Mesh face to duplicate

See Also

GH_MeshFace Class
GH_MeshFace Overload
Grasshopper.Kernel.Types Namespace


GH_MeshFace Constructor (Int32, Int32, Int32)

[image]

Grasshopper SDK
GH_MeshFace Constructor (Int32, Int32, Int32)
GH_MeshFace Class See Also Send Feedback
Create a triangular mesh face from 3 corners indices.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_MeshFace(
    int nA,
    int nB,
    int nC
)
Visual Basic
Public Sub New ( _
    nA As Integer, _
    nB As Integer, _
    nC As Integer _
)

Parameters

nA
Type: System..::..Int32
First corner index
nB
Type: System..::..Int32
Second corner index
nC
Type: System..::..Int32
Third corner index

See Also

GH_MeshFace Class
GH_MeshFace Overload
Grasshopper.Kernel.Types Namespace


GH_MeshFace Constructor (Int32, Int32, Int32, Int32)

[image]

Grasshopper SDK
GH_MeshFace Constructor (Int32, Int32, Int32, Int32)
GH_MeshFace Class See Also Send Feedback
Create a quadrangular mesh face from 4 corners indices.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_MeshFace(
    int nA,
    int nB,
    int nC,
    int nD
)
Visual Basic
Public Sub New ( _
    nA As Integer, _
    nB As Integer, _
    nC As Integer, _
    nD As Integer _
)

Parameters

nA
Type: System..::..Int32
First corner index
nB
Type: System..::..Int32
Second corner index
nC
Type: System..::..Int32
Third corner index
nD
Type: System..::..Int32
Fourth corner index

See Also

GH_MeshFace Class
GH_MeshFace Overload
Grasshopper.Kernel.Types Namespace


GH_MeshFace Fields

[image] [image]

Grasshopper SDK
GH_MeshFace Fields
GH_MeshFace Class See Also Send Feedback

The GH_MeshFace type exposes the following members.

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_MeshFace Class
Grasshopper.Kernel.Types Namespace


GH_MeshFace Methods

[image] [image]

Grasshopper SDK
GH_MeshFace Methods
GH_MeshFace Class See Also Send Feedback

The GH_MeshFace type exposes the following members.

Methods

 | Name | Description
Public method | CastFrom | Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic. (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic. (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | Duplicate | Create a duplicate of this Mesh face. (Overrides GH_Goo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateMeshFace | Create a duplicate of this Mesh face.
Public method | EmitProxy | Returns a proxy that represents this mesh face. Do not call this function unless you're (Overrides GH_Goo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ToString | Format the mesh face using default grasshopper formatting logic. (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

See Also

GH_MeshFace Class
Grasshopper.Kernel.Types Namespace


CastFrom Method

[image]

Grasshopper SDK
GH_MeshFace..::..CastFrom Method
GH_MeshFace Class See Also Send Feedback
Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastFrom(
    Object source
)
Visual Basic
Public Overrides Function CastFrom ( _
    source As Object _
) As Boolean

Parameters

source
Type: System..::..Object

See Also

GH_MeshFace Class
Grasshopper.Kernel.Types Namespace


CastTo Method

[image] [image]

Grasshopper SDK
GH_MeshFace..::..CastTo Method
GH_MeshFace Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic. (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)

See Also

GH_MeshFace Class
GH_MeshFace Members
Grasshopper.Kernel.Types Namespace


CastTo(T) Method (T)

[image]

Grasshopper SDK
GH_MeshFace..::..CastTo<(Of <(<'T>)>)> Method (T%)
GH_MeshFace Class See Also Send Feedback
Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastTo<T>(
    ref T target
)
Visual Basic
Public Overrides Function CastTo(Of T) ( _
    ByRef target As T _
) As Boolean

Parameters

target
Type: T%

Type Parameters

T

See Also

GH_MeshFace Class
CastTo Overload
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_MeshFace..::..Duplicate Method
GH_MeshFace Class See Also Send Feedback
Create a duplicate of this Mesh face.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_Goo Duplicate()
Visual Basic
Public Overrides Function Duplicate As IGH_Goo

See Also

GH_MeshFace Class
Grasshopper.Kernel.Types Namespace


DuplicateMeshFace Method

[image]

Grasshopper SDK
GH_MeshFace..::..DuplicateMeshFace Method
GH_MeshFace Class See Also Send Feedback
Create a duplicate of this Mesh face.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_MeshFace DuplicateMeshFace()
Visual Basic
Public Function DuplicateMeshFace As GH_MeshFace

See Also

GH_MeshFace Class
Grasshopper.Kernel.Types Namespace


EmitProxy Method

[image]

Grasshopper SDK
GH_MeshFace..::..EmitProxy Method
GH_MeshFace Class See Also Send Feedback
Returns a proxy that represents this mesh face. Do not call this function unless you're

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GooProxy EmitProxy()
Visual Basic
Public Overrides Function EmitProxy As IGH_GooProxy

See Also

GH_MeshFace Class
Grasshopper.Kernel.Types Namespace


Read Method

[image]

Grasshopper SDK
GH_MeshFace..::..Read Method
GH_MeshFace Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

See Also

GH_MeshFace Class
Grasshopper.Kernel.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_MeshFace..::..ToString Method
GH_MeshFace Class See Also Send Feedback
Format the mesh face using default grasshopper formatting logic.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_MeshFace Class
Grasshopper.Kernel.Types Namespace


Write Method

[image]

Grasshopper SDK
GH_MeshFace..::..Write Method
GH_MeshFace Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overrides Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

See Also

GH_MeshFace Class
Grasshopper.Kernel.Types Namespace


GH_MeshFace Properties

[image] [image]

Grasshopper SDK
GH_MeshFace Properties
GH_MeshFace Class See Also Send Feedback

The GH_MeshFace type exposes the following members.

Properties

 | Name | Description
Public property | IsValid | Test for validity. No negative indices are allowed and only C and D are allowed to be identical. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the internal data. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_MeshFace Class
Grasshopper.Kernel.Types Namespace


IsValid Property

[image]

Grasshopper SDK
GH_MeshFace..::..IsValid Property
GH_MeshFace Class See Also Send Feedback
Test for validity. No negative indices are allowed and only C and D are allowed to be identical.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool IsValid { get; }
Visual Basic
Public Overrides ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_MeshFace.IsValid"]

See Also

GH_MeshFace Class
Grasshopper.Kernel.Types Namespace


IsValidWhyNot Property

[image]

Grasshopper SDK
GH_MeshFace..::..IsValidWhyNot Property
GH_MeshFace Class See Also Send Feedback
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string IsValidWhyNot { get; }
Visual Basic
Public Overrides ReadOnly Property IsValidWhyNot As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_MeshFace.IsValidWhyNot"]

See Also

GH_MeshFace Class
Grasshopper.Kernel.Types Namespace


TypeDescription Property

[image]

Grasshopper SDK
GH_MeshFace..::..TypeDescription Property
GH_MeshFace Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeDescription { get; }
Visual Basic
Public Overrides ReadOnly Property TypeDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_MeshFace.TypeDescription"]

See Also

GH_MeshFace Class
Grasshopper.Kernel.Types Namespace


TypeName Property

[image]

Grasshopper SDK
GH_MeshFace..::..TypeName Property
GH_MeshFace Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeName { get; }
Visual Basic
Public Overrides ReadOnly Property TypeName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_MeshFace.TypeName"]

See Also

GH_MeshFace Class
Grasshopper.Kernel.Types Namespace


GH_MeshFace.GH_MeshFaceProxy Class

[image]

Grasshopper SDK
GH_MeshFace..::..GH_MeshFaceProxy Class
GH_MeshFace Class Members See Also Send Feedback
Proxy description of GH_MeshFace class. This class is used by the Generic Multivalue interfaces.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_MeshFaceProxy : GH_GooProxy<GH_MeshFace>
Visual Basic
Public Class GH_MeshFaceProxy _
    Inherits GH_GooProxy(Of GH_MeshFace)

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_GooProxy <(Of <(<' GH_MeshFace >)>)>
Grasshopper.Kernel.Types..::..GH_MeshFace..::..GH_MeshFaceProxy

See Also

GH_MeshFace..::..GH_MeshFaceProxy Members
Grasshopper.Kernel.Types Namespace


GH_MeshFace.GH_MeshFaceProxy Members

[image] [image]

Grasshopper SDK
GH_MeshFace..::..GH_MeshFaceProxy Members
GH_MeshFace..::..GH_MeshFaceProxy Class Constructors Methods Properties See Also Send Feedback

Represents a tri or quad mesh face. GH_MeshFace works similar to the OpenNURBS OnMeshFace class.

The GH_MeshFace..::..GH_MeshFaceProxy type exposes the following members.

Constructors

 | Name | Description
Public method | GH_MeshFace..::..GH_MeshFaceProxy | Initializes a new instance of the GH_MeshFace..::..GH_MeshFaceProxy class

Methods

 | Name | Description
Public method | Construct | Override this method to supply a custom UI during proxy construction. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FormatInstance | Returns a String description of the current value. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FromString | If IsParsable(), then attempts to convert the string to a generic type value (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | MutateString | Munge a string to remove obvious errors on account of the user. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | NumberToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | StringToNumber | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | ToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | A |
Public property | B |
Public property | C |
Public property | D |
Public property | IsParsable | Gets a value indicating whether or not the type can be instantiated from a String. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Kind |
Protected property | Owner | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | ProxyOwner | Gets the piece of Grasshopper data that spawned this proxy. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeName | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | UserString | Gets or sets the user-defined string that describes this proxy. This only really makes sense if the Proxy is Parsable. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Valid | Gets a value indicating whether this proxy represents valid data. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

See Also

GH_MeshFace..::..GH_MeshFaceProxy Class
Grasshopper.Kernel.Types Namespace


GH_MeshFace.GH_MeshFaceProxy Constructor

[image]

Grasshopper SDK
GH_MeshFace..::..GH_MeshFaceProxy Constructor
GH_MeshFace..::..GH_MeshFaceProxy Class See Also Send Feedback
Initializes a new instance of the GH_MeshFace..::..GH_MeshFaceProxy class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_MeshFaceProxy(
    GH_MeshFace nValue
)
Visual Basic
Public Sub New ( _
    nValue As GH_MeshFace _
)

Parameters

nValue
Type: Grasshopper.Kernel.Types..::..GH_MeshFace

See Also

GH_MeshFace..::..GH_MeshFaceProxy Class
Grasshopper.Kernel.Types Namespace


GH_MeshFace.GH_MeshFaceProxy Methods

[image] [image]

Grasshopper SDK
GH_MeshFace..::..GH_MeshFaceProxy Methods
GH_MeshFace..::..GH_MeshFaceProxy Class See Also Send Feedback

The GH_MeshFace..::..GH_MeshFaceProxy type exposes the following members.

Methods

 | Name | Description
Public method | Construct | Override this method to supply a custom UI during proxy construction. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FormatInstance | Returns a String description of the current value. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FromString | If IsParsable(), then attempts to convert the string to a generic type value (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | MutateString | Munge a string to remove obvious errors on account of the user. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | NumberToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | StringToNumber | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | ToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

See Also

GH_MeshFace..::..GH_MeshFaceProxy Class
Grasshopper.Kernel.Types Namespace


GH_MeshFace.GH_MeshFaceProxy Properties

[image] [image]

Grasshopper SDK
GH_MeshFace..::..GH_MeshFaceProxy Properties
GH_MeshFace..::..GH_MeshFaceProxy Class See Also Send Feedback

The GH_MeshFace..::..GH_MeshFaceProxy type exposes the following members.

Properties

 | Name | Description
Public property | A |
Public property | B |
Public property | C |
Public property | D |
Public property | IsParsable | Gets a value indicating whether or not the type can be instantiated from a String. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Kind |
Protected property | Owner | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | ProxyOwner | Gets the piece of Grasshopper data that spawned this proxy. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeName | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | UserString | Gets or sets the user-defined string that describes this proxy. This only really makes sense if the Proxy is Parsable. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Valid | Gets a value indicating whether this proxy represents valid data. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

See Also

GH_MeshFace..::..GH_MeshFaceProxy Class
Grasshopper.Kernel.Types Namespace


A Property

[image]

Grasshopper SDK
GH_MeshFace..::..GH_MeshFaceProxy..::..A Property
GH_MeshFace..::..GH_MeshFaceProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int A { get; set; }
Visual Basic
Public Property A As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_MeshFace.GH_MeshFaceProxy.A"]

See Also

GH_MeshFace..::..GH_MeshFaceProxy Class
Grasshopper.Kernel.Types Namespace


B Property

[image]

Grasshopper SDK
GH_MeshFace..::..GH_MeshFaceProxy..::..B Property
GH_MeshFace..::..GH_MeshFaceProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int B { get; set; }
Visual Basic
Public Property B As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_MeshFace.GH_MeshFaceProxy.B"]

See Also

GH_MeshFace..::..GH_MeshFaceProxy Class
Grasshopper.Kernel.Types Namespace


C Property

[image]

Grasshopper SDK
GH_MeshFace..::..GH_MeshFaceProxy..::..C Property
GH_MeshFace..::..GH_MeshFaceProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int C { get; set; }
Visual Basic
Public Property C As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_MeshFace.GH_MeshFaceProxy.C"]

See Also

GH_MeshFace..::..GH_MeshFaceProxy Class
Grasshopper.Kernel.Types Namespace


D Property

[image]

Grasshopper SDK
GH_MeshFace..::..GH_MeshFaceProxy..::..D Property
GH_MeshFace..::..GH_MeshFaceProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int D { get; set; }
Visual Basic
Public Property D As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_MeshFace.GH_MeshFaceProxy.D"]

See Also

GH_MeshFace..::..GH_MeshFaceProxy Class
Grasshopper.Kernel.Types Namespace


Kind Property

[image]

Grasshopper SDK
GH_MeshFace..::..GH_MeshFaceProxy..::..Kind Property
GH_MeshFace..::..GH_MeshFaceProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Kind { get; }
Visual Basic
Public ReadOnly Property Kind As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_MeshFace.GH_MeshFaceProxy.Kind"]

See Also

GH_MeshFace..::..GH_MeshFaceProxy Class
Grasshopper.Kernel.Types Namespace


GH_MeshingParameters Class

[image]

Grasshopper SDK
GH_MeshingParameters Class
Members See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_MeshingParameters : GH_Goo<MeshingParameters>
Visual Basic
Public Class GH_MeshingParameters _
    Inherits GH_Goo(Of MeshingParameters)

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_Goo <(Of <(<'MeshingParameters>)>)>
Grasshopper.Kernel.Types..::..GH_MeshingParameters

See Also

GH_MeshingParameters Members
Grasshopper.Kernel.Types Namespace


GH_MeshingParameters Members

[image] [image]

Grasshopper SDK
GH_MeshingParameters Members
GH_MeshingParameters Class Constructors Methods Fields Properties See Also Send Feedback

The GH_MeshingParameters type exposes the following members.

Constructors

 | Name | Description
Public method | GH_MeshingParameters()()()() | Initializes a new instance of the GH_MeshingParameters class
Public method | GH_MeshingParameters(MeshingParameters) | Initializes a new instance of the GH_MeshingParameters class

Methods

 | Name | Description
Public method | CastFrom | Attempt a cast from generic data. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(Q>)>>) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | Duplicate | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateMesherSettings |
Public method | EmitProxy | (Overrides GH_Goo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ToString | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | IsValid | (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the internal data. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_MeshingParameters Class
Grasshopper.Kernel.Types Namespace


GH_MeshingParameters Constructor

[image] [image]

Grasshopper SDK
GH_MeshingParameters Constructor
GH_MeshingParameters Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_MeshingParameters()()()() | Initializes a new instance of the GH_MeshingParameters class
Public method | GH_MeshingParameters(MeshingParameters) | Initializes a new instance of the GH_MeshingParameters class

See Also

GH_MeshingParameters Class
GH_MeshingParameters Members
Grasshopper.Kernel.Types Namespace


GH_MeshingParameters Constructor

[image]

Grasshopper SDK
GH_MeshingParameters Constructor
GH_MeshingParameters Class See Also Send Feedback
Initializes a new instance of the GH_MeshingParameters class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_MeshingParameters()
Visual Basic
Public Sub New

See Also

GH_MeshingParameters Class
GH_MeshingParameters Overload
Grasshopper.Kernel.Types Namespace


GH_MeshingParameters Constructor ()

[image]

Grasshopper SDK
GH_MeshingParameters Constructor ()
GH_MeshingParameters Class See Also Send Feedback
Initializes a new instance of the GH_MeshingParameters class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_MeshingParameters(
    MeshingParameters other
)
Visual Basic
Public Sub New ( _
    other As MeshingParameters _
)

Parameters

other
Type: MeshingParameters

See Also

GH_MeshingParameters Class
GH_MeshingParameters Overload
Grasshopper.Kernel.Types Namespace


GH_MeshingParameters Fields

[image] [image]

Grasshopper SDK
GH_MeshingParameters Fields
GH_MeshingParameters Class See Also Send Feedback

The GH_MeshingParameters type exposes the following members.

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_MeshingParameters Class
Grasshopper.Kernel.Types Namespace


GH_MeshingParameters Methods

[image] [image]

Grasshopper SDK
GH_MeshingParameters Methods
GH_MeshingParameters Class See Also Send Feedback

The GH_MeshingParameters type exposes the following members.

Methods

 | Name | Description
Public method | CastFrom | Attempt a cast from generic data. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(Q>)>>) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | Duplicate | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateMesherSettings |
Public method | EmitProxy | (Overrides GH_Goo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ToString | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

See Also

GH_MeshingParameters Class
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_MeshingParameters..::..Duplicate Method
GH_MeshingParameters Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_Goo Duplicate()
Visual Basic
Public Overrides Function Duplicate As IGH_Goo

See Also

GH_MeshingParameters Class
Grasshopper.Kernel.Types Namespace


DuplicateMesherSettings Method

[image]

Grasshopper SDK
GH_MeshingParameters..::..DuplicateMesherSettings Method
GH_MeshingParameters Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_MeshingParameters DuplicateMesherSettings()
Visual Basic
Public Function DuplicateMesherSettings As GH_MeshingParameters

See Also

GH_MeshingParameters Class
Grasshopper.Kernel.Types Namespace


EmitProxy Method

[image]

Grasshopper SDK
GH_MeshingParameters..::..EmitProxy Method
GH_MeshingParameters Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GooProxy EmitProxy()
Visual Basic
Public Overrides Function EmitProxy As IGH_GooProxy

See Also

GH_MeshingParameters Class
Grasshopper.Kernel.Types Namespace


Read Method

[image]

Grasshopper SDK
GH_MeshingParameters..::..Read Method
GH_MeshingParameters Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

See Also

GH_MeshingParameters Class
Grasshopper.Kernel.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_MeshingParameters..::..ToString Method
GH_MeshingParameters Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_MeshingParameters Class
Grasshopper.Kernel.Types Namespace


Write Method

[image]

Grasshopper SDK
GH_MeshingParameters..::..Write Method
GH_MeshingParameters Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overrides Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

See Also

GH_MeshingParameters Class
Grasshopper.Kernel.Types Namespace


GH_MeshingParameters Properties

[image] [image]

Grasshopper SDK
GH_MeshingParameters Properties
GH_MeshingParameters Class See Also Send Feedback

The GH_MeshingParameters type exposes the following members.

Properties

 | Name | Description
Public property | IsValid | (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the internal data. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_MeshingParameters Class
Grasshopper.Kernel.Types Namespace


IsValid Property

[image]

Grasshopper SDK
GH_MeshingParameters..::..IsValid Property
GH_MeshingParameters Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool IsValid { get; }
Visual Basic
Public Overrides ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_MeshingParameters.IsValid"]

See Also

GH_MeshingParameters Class
Grasshopper.Kernel.Types Namespace


TypeDescription Property

[image]

Grasshopper SDK
GH_MeshingParameters..::..TypeDescription Property
GH_MeshingParameters Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeDescription { get; }
Visual Basic
Public Overrides ReadOnly Property TypeDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_MeshingParameters.TypeDescription"]

See Also

GH_MeshingParameters Class
Grasshopper.Kernel.Types Namespace


TypeName Property

[image]

Grasshopper SDK
GH_MeshingParameters..::..TypeName Property
GH_MeshingParameters Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeName { get; }
Visual Basic
Public Overrides ReadOnly Property TypeName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_MeshingParameters.TypeName"]

See Also

GH_MeshingParameters Class
Grasshopper.Kernel.Types Namespace


GH_MeshingParameters.RhMesherSettings_Proxy Class

[image]

Grasshopper SDK
GH_MeshingParameters..::..RhMesherSettings_Proxy Class
GH_MeshingParameters Class Members See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class RhMesherSettings_Proxy : GH_GooProxy<GH_MeshingParameters>
Visual Basic
Public Class RhMesherSettings_Proxy _
    Inherits GH_GooProxy(Of GH_MeshingParameters)

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_GooProxy <(Of <(<' GH_MeshingParameters >)>)>
Grasshopper.Kernel.Types..::..GH_MeshingParameters..::..RhMesherSettings_Proxy

See Also

GH_MeshingParameters..::..RhMesherSettings_Proxy Members
Grasshopper.Kernel.Types Namespace


GH_MeshingParameters.RhMesherSettings_Proxy Members

[image] [image]

Grasshopper SDK
GH_MeshingParameters..::..RhMesherSettings_Proxy Members
GH_MeshingParameters..::..RhMesherSettings_Proxy Class Constructors Methods Properties See Also Send Feedback

The GH_MeshingParameters..::..RhMesherSettings_Proxy type exposes the following members.

Constructors

 | Name | Description
Public method | GH_MeshingParameters..::..RhMesherSettings_Proxy | Initializes a new instance of the GH_MeshingParameters..::..RhMesherSettings_Proxy class

Methods

 | Name | Description
Public method | Construct | Override this method to supply a custom UI during proxy construction. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FormatInstance | Returns a String description of the current value. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FromString | If IsParsable(), then attempts to convert the string to a generic type value (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | MutateString | Munge a string to remove obvious errors on account of the user. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | NumberToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | StringToNumber | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | ToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | AngleTolerance |
Public property | AspectRatio |
Public property | GridMaxCount |
Public property | GridMinCount |
Public property | IsParsable | (Overrides GH_GooProxy<(Of <(<'T>)>)>..::..IsParsable.)
Public property | JaggedSeams |
Public property | MaxEdgeLength |
Public property | MinEdgeLength |
Protected property | Owner | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | ProxyOwner | Gets the piece of Grasshopper data that spawned this proxy. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Refine |
Public property | SimplePlanes |
Public property | Tolerance |
Public property | TypeDescription | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeName | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | UserString | Gets or sets the user-defined string that describes this proxy. This only really makes sense if the Proxy is Parsable. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Valid | Gets a value indicating whether this proxy represents valid data. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

See Also

GH_MeshingParameters..::..RhMesherSettings_Proxy Class
Grasshopper.Kernel.Types Namespace


GH_MeshingParameters.RhMesherSettings_Proxy Constructor

[image]

Grasshopper SDK
GH_MeshingParameters..::..RhMesherSettings_Proxy Constructor
GH_MeshingParameters..::..RhMesherSettings_Proxy Class See Also Send Feedback
Initializes a new instance of the GH_MeshingParameters..::..RhMesherSettings_Proxy class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public RhMesherSettings_Proxy(
    GH_MeshingParameters owner
)
Visual Basic
Public Sub New ( _
    owner As GH_MeshingParameters _
)

Parameters

owner
Type: Grasshopper.Kernel.Types..::..GH_MeshingParameters

See Also

GH_MeshingParameters..::..RhMesherSettings_Proxy Class
Grasshopper.Kernel.Types Namespace


GH_MeshingParameters.RhMesherSettings_Proxy Methods

[image] [image]

Grasshopper SDK
GH_MeshingParameters..::..RhMesherSettings_Proxy Methods
GH_MeshingParameters..::..RhMesherSettings_Proxy Class See Also Send Feedback

The GH_MeshingParameters..::..RhMesherSettings_Proxy type exposes the following members.

Methods

 | Name | Description
Public method | Construct | Override this method to supply a custom UI during proxy construction. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FormatInstance | Returns a String description of the current value. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FromString | If IsParsable(), then attempts to convert the string to a generic type value (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | MutateString | Munge a string to remove obvious errors on account of the user. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | NumberToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | StringToNumber | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | ToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

See Also

GH_MeshingParameters..::..RhMesherSettings_Proxy Class
Grasshopper.Kernel.Types Namespace


GH_MeshingParameters.RhMesherSettings_Proxy Properties

[image] [image]

Grasshopper SDK
GH_MeshingParameters..::..RhMesherSettings_Proxy Properties
GH_MeshingParameters..::..RhMesherSettings_Proxy Class See Also Send Feedback

The GH_MeshingParameters..::..RhMesherSettings_Proxy type exposes the following members.

Properties

 | Name | Description
Public property | AngleTolerance |
Public property | AspectRatio |
Public property | GridMaxCount |
Public property | GridMinCount |
Public property | IsParsable | (Overrides GH_GooProxy<(Of <(<'T>)>)>..::..IsParsable.)
Public property | JaggedSeams |
Public property | MaxEdgeLength |
Public property | MinEdgeLength |
Protected property | Owner | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | ProxyOwner | Gets the piece of Grasshopper data that spawned this proxy. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Refine |
Public property | SimplePlanes |
Public property | Tolerance |
Public property | TypeDescription | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeName | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | UserString | Gets or sets the user-defined string that describes this proxy. This only really makes sense if the Proxy is Parsable. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Valid | Gets a value indicating whether this proxy represents valid data. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

See Also

GH_MeshingParameters..::..RhMesherSettings_Proxy Class
Grasshopper.Kernel.Types Namespace


AngleTolerance Property

[image]

Grasshopper SDK
GH_MeshingParameters..::..RhMesherSettings_Proxy..::..AngleTolerance Property
GH_MeshingParameters..::..RhMesherSettings_Proxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double AngleTolerance { get; set; }
Visual Basic
Public Property AngleTolerance As Double
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_MeshingParameters.RhMesherSettings_Proxy.AngleTolerance"]

See Also

GH_MeshingParameters..::..RhMesherSettings_Proxy Class
Grasshopper.Kernel.Types Namespace


AspectRatio Property

[image]

Grasshopper SDK
GH_MeshingParameters..::..RhMesherSettings_Proxy..::..AspectRatio Property
GH_MeshingParameters..::..RhMesherSettings_Proxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double AspectRatio { get; set; }
Visual Basic
Public Property AspectRatio As Double
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_MeshingParameters.RhMesherSettings_Proxy.AspectRatio"]

See Also

GH_MeshingParameters..::..RhMesherSettings_Proxy Class
Grasshopper.Kernel.Types Namespace


GridMaxCount Property

[image]

Grasshopper SDK
GH_MeshingParameters..::..RhMesherSettings_Proxy..::..GridMaxCount Property
GH_MeshingParameters..::..RhMesherSettings_Proxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int GridMaxCount { get; set; }
Visual Basic
Public Property GridMaxCount As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_MeshingParameters.RhMesherSettings_Proxy.GridMaxCount"]

See Also

GH_MeshingParameters..::..RhMesherSettings_Proxy Class
Grasshopper.Kernel.Types Namespace


GridMinCount Property

[image]

Grasshopper SDK
GH_MeshingParameters..::..RhMesherSettings_Proxy..::..GridMinCount Property
GH_MeshingParameters..::..RhMesherSettings_Proxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int GridMinCount { get; set; }
Visual Basic
Public Property GridMinCount As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_MeshingParameters.RhMesherSettings_Proxy.GridMinCount"]

See Also

GH_MeshingParameters..::..RhMesherSettings_Proxy Class
Grasshopper.Kernel.Types Namespace


IsParsable Property

[image]

Grasshopper SDK
GH_MeshingParameters..::..RhMesherSettings_Proxy..::..IsParsable Property
GH_MeshingParameters..::..RhMesherSettings_Proxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool IsParsable { get; }
Visual Basic
Public Overrides ReadOnly Property IsParsable As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_MeshingParameters.RhMesherSettings_Proxy.IsParsable"]

See Also

GH_MeshingParameters..::..RhMesherSettings_Proxy Class
Grasshopper.Kernel.Types Namespace


JaggedSeams Property

[image]

Grasshopper SDK
GH_MeshingParameters..::..RhMesherSettings_Proxy..::..JaggedSeams Property
GH_MeshingParameters..::..RhMesherSettings_Proxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool JaggedSeams { get; set; }
Visual Basic
Public Property JaggedSeams As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_MeshingParameters.RhMesherSettings_Proxy.JaggedSeams"]

See Also

GH_MeshingParameters..::..RhMesherSettings_Proxy Class
Grasshopper.Kernel.Types Namespace


MaxEdgeLength Property

[image]

Grasshopper SDK
GH_MeshingParameters..::..RhMesherSettings_Proxy..::..MaxEdgeLength Property
GH_MeshingParameters..::..RhMesherSettings_Proxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double MaxEdgeLength { get; set; }
Visual Basic
Public Property MaxEdgeLength As Double
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_MeshingParameters.RhMesherSettings_Proxy.MaxEdgeLength"]

See Also

GH_MeshingParameters..::..RhMesherSettings_Proxy Class
Grasshopper.Kernel.Types Namespace


MinEdgeLength Property

[image]

Grasshopper SDK
GH_MeshingParameters..::..RhMesherSettings_Proxy..::..MinEdgeLength Property
GH_MeshingParameters..::..RhMesherSettings_Proxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double MinEdgeLength { get; set; }
Visual Basic
Public Property MinEdgeLength As Double
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_MeshingParameters.RhMesherSettings_Proxy.MinEdgeLength"]

See Also

GH_MeshingParameters..::..RhMesherSettings_Proxy Class
Grasshopper.Kernel.Types Namespace


Refine Property

[image]

Grasshopper SDK
GH_MeshingParameters..::..RhMesherSettings_Proxy..::..Refine Property
GH_MeshingParameters..::..RhMesherSettings_Proxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Refine { get; set; }
Visual Basic
Public Property Refine As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_MeshingParameters.RhMesherSettings_Proxy.Refine"]

See Also

GH_MeshingParameters..::..RhMesherSettings_Proxy Class
Grasshopper.Kernel.Types Namespace


SimplePlanes Property

[image]

Grasshopper SDK
GH_MeshingParameters..::..RhMesherSettings_Proxy..::..SimplePlanes Property
GH_MeshingParameters..::..RhMesherSettings_Proxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool SimplePlanes { get; set; }
Visual Basic
Public Property SimplePlanes As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_MeshingParameters.RhMesherSettings_Proxy.SimplePlanes"]

See Also

GH_MeshingParameters..::..RhMesherSettings_Proxy Class
Grasshopper.Kernel.Types Namespace


Tolerance Property

[image]

Grasshopper SDK
GH_MeshingParameters..::..RhMesherSettings_Proxy..::..Tolerance Property
GH_MeshingParameters..::..RhMesherSettings_Proxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double Tolerance { get; set; }
Visual Basic
Public Property Tolerance As Double
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_MeshingParameters.RhMesherSettings_Proxy.Tolerance"]

See Also

GH_MeshingParameters..::..RhMesherSettings_Proxy Class
Grasshopper.Kernel.Types Namespace


GH_Number Class

[image]

Grasshopper SDK
GH_Number Class
Members See Also Send Feedback
Represents a double-precision floating point number. GH_Number re-implements the framework System.Double type.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Number : GH_Goo<double>,
    IGH_QuickCast
Visual Basic
Public Class GH_Number _
    Inherits GH_Goo(Of Double) _
    Implements IGH_QuickCast

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_Goo <(Of <(<' Double >)>)>
Grasshopper.Kernel.Types..::..GH_Number

See Also

GH_Number Members
Grasshopper.Kernel.Types Namespace


GH_Number Members

[image] [image]

Grasshopper SDK
GH_Number Members
GH_Number Class Constructors Methods Fields Properties See Also Send Feedback

The GH_Number type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Number()()()() | Blank constructor
Public method | GH_Number(Double) | Initializes a new instance of the GH_Number class
Public method | GH_Number(GH_Number) | Initializes a new instance of the GH_Number class

Methods

 | Name | Description
Public method | CastFrom | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | Duplicate | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateNumber |
Public method | EmitProxy | (Overrides GH_Goo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ToString | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | IsValid | Gets the validity of this instance. If the number is NaN, then it is considered invalid (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the internal data. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Number Class
Grasshopper.Kernel.Types Namespace


GH_Number Constructor

[image] [image]

Grasshopper SDK
GH_Number Constructor
GH_Number Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Number()()()() | Blank constructor
Public method | GH_Number(Double) | Initializes a new instance of the GH_Number class
Public method | GH_Number(GH_Number) | Initializes a new instance of the GH_Number class

See Also

GH_Number Class
GH_Number Members
Grasshopper.Kernel.Types Namespace


GH_Number Constructor

[image]

Grasshopper SDK
GH_Number Constructor
GH_Number Class See Also Send Feedback
Blank constructor

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Number()
Visual Basic
Public Sub New

See Also

GH_Number Class
GH_Number Overload
Grasshopper.Kernel.Types Namespace


GH_Number Constructor (Double)

[image]

Grasshopper SDK
GH_Number Constructor (Double)
GH_Number Class See Also Send Feedback
Initializes a new instance of the GH_Number class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Number(
    double number
)
Visual Basic
Public Sub New ( _
    number As Double _
)

Parameters

number
Type: System..::..Double

See Also

GH_Number Class
GH_Number Overload
Grasshopper.Kernel.Types Namespace


GH_Number Constructor (GH_Number)

[image]

Grasshopper SDK
GH_Number Constructor (GH_Number)
GH_Number Class See Also Send Feedback
Initializes a new instance of the GH_Number class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Number(
    GH_Number other
)
Visual Basic
Public Sub New ( _
    other As GH_Number _
)

Parameters

other
Type: Grasshopper.Kernel.Types..::..GH_Number

See Also

GH_Number Class
GH_Number Overload
Grasshopper.Kernel.Types Namespace


GH_Number Fields

[image] [image]

Grasshopper SDK
GH_Number Fields
GH_Number Class See Also Send Feedback

The GH_Number type exposes the following members.

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Number Class
Grasshopper.Kernel.Types Namespace


GH_Number Methods

[image] [image]

Grasshopper SDK
GH_Number Methods
GH_Number Class See Also Send Feedback

The GH_Number type exposes the following members.

Methods

 | Name | Description
Public method | CastFrom | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | Duplicate | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateNumber |
Public method | EmitProxy | (Overrides GH_Goo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ToString | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

See Also

GH_Number Class
Grasshopper.Kernel.Types Namespace


CastFrom Method

[image]

Grasshopper SDK
GH_Number..::..CastFrom Method
GH_Number Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastFrom(
    Object source
)
Visual Basic
Public Overrides Function CastFrom ( _
    source As Object _
) As Boolean

Parameters

source
Type: System..::..Object

See Also

GH_Number Class
Grasshopper.Kernel.Types Namespace


CastTo Method

[image] [image]

Grasshopper SDK
GH_Number..::..CastTo Method
GH_Number Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)

See Also

GH_Number Class
GH_Number Members
Grasshopper.Kernel.Types Namespace


CastTo(T) Method (T)

[image]

Grasshopper SDK
GH_Number..::..CastTo<(Of <(<'T>)>)> Method (T%)
GH_Number Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastTo<T>(
    out T target
)
Visual Basic
Public Overrides Function CastTo(Of T) ( _
    <OutAttribute> ByRef target As T _
) As Boolean

Parameters

target
Type: T%

Type Parameters

T

See Also

GH_Number Class
CastTo Overload
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_Number..::..Duplicate Method
GH_Number Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_Goo Duplicate()
Visual Basic
Public Overrides Function Duplicate As IGH_Goo

See Also

GH_Number Class
Grasshopper.Kernel.Types Namespace


DuplicateNumber Method

[image]

Grasshopper SDK
GH_Number..::..DuplicateNumber Method
GH_Number Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Number DuplicateNumber()
Visual Basic
Public Function DuplicateNumber As GH_Number

See Also

GH_Number Class
Grasshopper.Kernel.Types Namespace


EmitProxy Method

[image]

Grasshopper SDK
GH_Number..::..EmitProxy Method
GH_Number Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GooProxy EmitProxy()
Visual Basic
Public Overrides Function EmitProxy As IGH_GooProxy

See Also

GH_Number Class
Grasshopper.Kernel.Types Namespace


Read Method

[image]

Grasshopper SDK
GH_Number..::..Read Method
GH_Number Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

See Also

GH_Number Class
Grasshopper.Kernel.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_Number..::..ToString Method
GH_Number Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_Number Class
Grasshopper.Kernel.Types Namespace


Write Method

[image]

Grasshopper SDK
GH_Number..::..Write Method
GH_Number Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overrides Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

See Also

GH_Number Class
Grasshopper.Kernel.Types Namespace


GH_Number Properties

[image] [image]

Grasshopper SDK
GH_Number Properties
GH_Number Class See Also Send Feedback

The GH_Number type exposes the following members.

Properties

 | Name | Description
Public property | IsValid | Gets the validity of this instance. If the number is NaN, then it is considered invalid (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the internal data. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Number Class
Grasshopper.Kernel.Types Namespace


IsValid Property

[image]

Grasshopper SDK
GH_Number..::..IsValid Property
GH_Number Class See Also Send Feedback
Gets the validity of this instance. If the number is NaN, then it is considered invalid

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool IsValid { get; }
Visual Basic
Public Overrides ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Number.IsValid"]

See Also

GH_Number Class
Grasshopper.Kernel.Types Namespace


IsValidWhyNot Property

[image]

Grasshopper SDK
GH_Number..::..IsValidWhyNot Property
GH_Number Class See Also Send Feedback
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string IsValidWhyNot { get; }
Visual Basic
Public Overrides ReadOnly Property IsValidWhyNot As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Number.IsValidWhyNot"]

See Also

GH_Number Class
Grasshopper.Kernel.Types Namespace


TypeDescription Property

[image]

Grasshopper SDK
GH_Number..::..TypeDescription Property
GH_Number Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeDescription { get; }
Visual Basic
Public Overrides ReadOnly Property TypeDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Number.TypeDescription"]

See Also

GH_Number Class
Grasshopper.Kernel.Types Namespace


TypeName Property

[image]

Grasshopper SDK
GH_Number..::..TypeName Property
GH_Number Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeName { get; }
Visual Basic
Public Overrides ReadOnly Property TypeName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Number.TypeName"]

See Also

GH_Number Class
Grasshopper.Kernel.Types Namespace


GH_ObjectWrapper Class

[image]

Grasshopper SDK
GH_ObjectWrapper Class
Members See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_ObjectWrapper : GH_Goo<Object>,
    IGH_BakeAwareData, IGH_PreviewData
Visual Basic
Public Class GH_ObjectWrapper _
    Inherits GH_Goo(Of Object) _
    Implements IGH_BakeAwareData, IGH_PreviewData

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_Goo <(Of <(<' Object >)>)>
Grasshopper.Kernel.Types..::..GH_ObjectWrapper

See Also

GH_ObjectWrapper Members
Grasshopper.Kernel.Types Namespace


GH_ObjectWrapper Members

[image] [image]

Grasshopper SDK
GH_ObjectWrapper Members
GH_ObjectWrapper Class Constructors Methods Fields Properties See Also Send Feedback

The GH_ObjectWrapper type exposes the following members.

Constructors

 | Name | Description
Public method | GH_ObjectWrapper()()()() | Initializes a new instance of the GH_ObjectWrapper class
Public method | GH_ObjectWrapper(Object) | Initializes a new instance of the GH_ObjectWrapper class

Methods

 | Name | Description
Public method | BakeGeometry |
Public method | CastFrom | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | DrawViewportMeshes |
Public method | DrawViewportWires |
Public method | Duplicate | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateObject |
Public method | EmitProxy | (Overrides GH_Goo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ScriptVariable()()()().)
Public method | ToString | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Write | Default behaviour is to return True. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | ClippingBox |
Public property | IsValid | (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the internal data. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_ObjectWrapper Class
Grasshopper.Kernel.Types Namespace


GH_ObjectWrapper Constructor

[image] [image]

Grasshopper SDK
GH_ObjectWrapper Constructor
GH_ObjectWrapper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_ObjectWrapper()()()() | Initializes a new instance of the GH_ObjectWrapper class
Public method | GH_ObjectWrapper(Object) | Initializes a new instance of the GH_ObjectWrapper class

See Also

GH_ObjectWrapper Class
GH_ObjectWrapper Members
Grasshopper.Kernel.Types Namespace


GH_ObjectWrapper Constructor

[image]

Grasshopper SDK
GH_ObjectWrapper Constructor
GH_ObjectWrapper Class See Also Send Feedback
Initializes a new instance of the GH_ObjectWrapper class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ObjectWrapper()
Visual Basic
Public Sub New

See Also

GH_ObjectWrapper Class
GH_ObjectWrapper Overload
Grasshopper.Kernel.Types Namespace


GH_ObjectWrapper Constructor (Object)

[image]

Grasshopper SDK
GH_ObjectWrapper Constructor (Object)
GH_ObjectWrapper Class See Also Send Feedback
Initializes a new instance of the GH_ObjectWrapper class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ObjectWrapper(
    Object obj
)
Visual Basic
Public Sub New ( _
    obj As Object _
)

Parameters

obj
Type: System..::..Object

See Also

GH_ObjectWrapper Class
GH_ObjectWrapper Overload
Grasshopper.Kernel.Types Namespace


GH_ObjectWrapper Fields

[image] [image]

Grasshopper SDK
GH_ObjectWrapper Fields
GH_ObjectWrapper Class See Also Send Feedback

The GH_ObjectWrapper type exposes the following members.

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_ObjectWrapper Class
Grasshopper.Kernel.Types Namespace


GH_ObjectWrapper Methods

[image] [image]

Grasshopper SDK
GH_ObjectWrapper Methods
GH_ObjectWrapper Class See Also Send Feedback

The GH_ObjectWrapper type exposes the following members.

Methods

 | Name | Description
Public method | BakeGeometry |
Public method | CastFrom | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | DrawViewportMeshes |
Public method | DrawViewportWires |
Public method | Duplicate | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateObject |
Public method | EmitProxy | (Overrides GH_Goo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ScriptVariable()()()().)
Public method | ToString | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Write | Default behaviour is to return True. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_ObjectWrapper Class
Grasshopper.Kernel.Types Namespace


BakeGeometry Method

[image]

Grasshopper SDK
GH_ObjectWrapper..::..BakeGeometry Method
GH_ObjectWrapper Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool BakeGeometry(
    RhinoDoc doc,
    ObjectAttributes att,
    ref Guid obj_guid
)
Visual Basic
Public Function BakeGeometry ( _
    doc As RhinoDoc, _
    att As ObjectAttributes, _
    ByRef obj_guid As Guid _
) As Boolean

Parameters

doc
Type: RhinoDoc
att
Type: ObjectAttributes
obj_guid
Type: System..::..Guid %

Implements

IGH_BakeAwareData..::..BakeGeometry(RhinoDoc, ObjectAttributes, Guid%)

See Also

GH_ObjectWrapper Class
Grasshopper.Kernel.Types Namespace


CastFrom Method

[image]

Grasshopper SDK
GH_ObjectWrapper..::..CastFrom Method
GH_ObjectWrapper Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastFrom(
    Object source
)
Visual Basic
Public Overrides Function CastFrom ( _
    source As Object _
) As Boolean

Parameters

source
Type: System..::..Object

See Also

GH_ObjectWrapper Class
Grasshopper.Kernel.Types Namespace


CastTo Method

[image] [image]

Grasshopper SDK
GH_ObjectWrapper..::..CastTo Method
GH_ObjectWrapper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)

See Also

GH_ObjectWrapper Class
GH_ObjectWrapper Members
Grasshopper.Kernel.Types Namespace


CastTo(T) Method (T)

[image]

Grasshopper SDK
GH_ObjectWrapper..::..CastTo<(Of <(<'T>)>)> Method (T%)
GH_ObjectWrapper Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastTo<T>(
    out T target
)
Visual Basic
Public Overrides Function CastTo(Of T) ( _
    <OutAttribute> ByRef target As T _
) As Boolean

Parameters

target
Type: T%

Type Parameters

T

See Also

GH_ObjectWrapper Class
CastTo Overload
Grasshopper.Kernel.Types Namespace


DrawViewportMeshes Method

[image]

Grasshopper SDK
GH_ObjectWrapper..::..DrawViewportMeshes Method
GH_ObjectWrapper Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DrawViewportMeshes(
    GH_PreviewMeshArgs args
)
Visual Basic
Public Sub DrawViewportMeshes ( _
    args As GH_PreviewMeshArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..GH_PreviewMeshArgs

Implements

IGH_PreviewData..::..DrawViewportMeshes(GH_PreviewMeshArgs)

See Also

GH_ObjectWrapper Class
Grasshopper.Kernel.Types Namespace


DrawViewportWires Method

[image]

Grasshopper SDK
GH_ObjectWrapper..::..DrawViewportWires Method
GH_ObjectWrapper Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DrawViewportWires(
    GH_PreviewWireArgs args
)
Visual Basic
Public Sub DrawViewportWires ( _
    args As GH_PreviewWireArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..GH_PreviewWireArgs

Implements

IGH_PreviewData..::..DrawViewportWires(GH_PreviewWireArgs)

See Also

GH_ObjectWrapper Class
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_ObjectWrapper..::..Duplicate Method
GH_ObjectWrapper Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_Goo Duplicate()
Visual Basic
Public Overrides Function Duplicate As IGH_Goo

See Also

GH_ObjectWrapper Class
Grasshopper.Kernel.Types Namespace


DuplicateObject Method

[image]

Grasshopper SDK
GH_ObjectWrapper..::..DuplicateObject Method
GH_ObjectWrapper Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_ObjectWrapper DuplicateObject()
Visual Basic
Public Function DuplicateObject As GH_ObjectWrapper

See Also

GH_ObjectWrapper Class
Grasshopper.Kernel.Types Namespace


EmitProxy Method

[image]

Grasshopper SDK
GH_ObjectWrapper..::..EmitProxy Method
GH_ObjectWrapper Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GooProxy EmitProxy()
Visual Basic
Public Overrides Function EmitProxy As IGH_GooProxy

See Also

GH_ObjectWrapper Class
Grasshopper.Kernel.Types Namespace


Read Method

[image]

Grasshopper SDK
GH_ObjectWrapper..::..Read Method
GH_ObjectWrapper Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

See Also

GH_ObjectWrapper Class
Grasshopper.Kernel.Types Namespace


ScriptVariable Method

[image]

Grasshopper SDK
GH_ObjectWrapper..::..ScriptVariable Method
GH_ObjectWrapper Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override Object ScriptVariable()
Visual Basic
Public Overrides Function ScriptVariable As Object

See Also

GH_ObjectWrapper Class
Grasshopper.Kernel.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_ObjectWrapper..::..ToString Method
GH_ObjectWrapper Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_ObjectWrapper Class
Grasshopper.Kernel.Types Namespace


GH_ObjectWrapper Properties

[image] [image]

Grasshopper SDK
GH_ObjectWrapper Properties
GH_ObjectWrapper Class See Also Send Feedback

The GH_ObjectWrapper type exposes the following members.

Properties

 | Name | Description
Public property | ClippingBox |
Public property | IsValid | (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the internal data. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_ObjectWrapper Class
Grasshopper.Kernel.Types Namespace


ClippingBox Property

[image]

Grasshopper SDK
GH_ObjectWrapper..::..ClippingBox Property
GH_ObjectWrapper Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public BoundingBox ClippingBox { get; }
Visual Basic
Public ReadOnly Property ClippingBox As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_ObjectWrapper.ClippingBox"]

Implements

IGH_PreviewData..::..ClippingBox

See Also

GH_ObjectWrapper Class
Grasshopper.Kernel.Types Namespace


IsValid Property

[image]

Grasshopper SDK
GH_ObjectWrapper..::..IsValid Property
GH_ObjectWrapper Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool IsValid { get; }
Visual Basic
Public Overrides ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_ObjectWrapper.IsValid"]

See Also

GH_ObjectWrapper Class
Grasshopper.Kernel.Types Namespace


TypeDescription Property

[image]

Grasshopper SDK
GH_ObjectWrapper..::..TypeDescription Property
GH_ObjectWrapper Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeDescription { get; }
Visual Basic
Public Overrides ReadOnly Property TypeDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_ObjectWrapper.TypeDescription"]

See Also

GH_ObjectWrapper Class
Grasshopper.Kernel.Types Namespace


TypeName Property

[image]

Grasshopper SDK
GH_ObjectWrapper..::..TypeName Property
GH_ObjectWrapper Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeName { get; }
Visual Basic
Public Overrides ReadOnly Property TypeName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_ObjectWrapper.TypeName"]

See Also

GH_ObjectWrapper Class
Grasshopper.Kernel.Types Namespace


GH_Plane Class

[image]

Grasshopper SDK
GH_Plane Class
Members See Also Send Feedback
Represents a 3D plane. GH_Plane re-implements the OpenNURBS OnPlane class.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Plane : GH_GeometricGoo<Plane>,
    IGH_BakeAwareData, IGH_PreviewData
Visual Basic
Public Class GH_Plane _
    Inherits GH_GeometricGoo(Of Plane) _
    Implements IGH_BakeAwareData, IGH_PreviewData

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_Goo <(Of <(<'Plane>)>)>
Grasshopper.Kernel.Types..::..GH_GeometricGoo <(Of <(<'Plane>)>)>
Grasshopper.Kernel.Types..::..GH_Plane

See Also

GH_Plane Members
Grasshopper.Kernel.Types Namespace


GH_Plane Members

[image] [image]

Grasshopper SDK
GH_Plane Members
GH_Plane Class Constructors Methods Fields Properties See Also Send Feedback

The GH_Plane type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Plane()()()() | Default constructor. Creates a world XY plane.
Public method | GH_Plane(Plane) | Create a duplicate of another plane.
Public method | GH_Plane(GH_Plane) | Create a duplicate of another plane.

Methods

 | Name | Description
Public method | BakeGeometry |
Public method | CastFrom | Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type T. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | ClearCaches | Clears all caches. Typically if the geometry is referenced, this will erase the local copy. If your T is a value-type, you must override this function and specifically unset the local value. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
 | DrawPlane(DisplayPipeline, Plane) | Draw a plane with default colours and default size.
 | DrawPlane(DisplayPipeline, Plane, Double, Int32) |
 | DrawPlane(DisplayPipeline, Plane, Double, Int32, Color, Color, Color) |
 | DrawPlane(DisplayPipeline, Plane, Double, Int32, Color, Color, Color, Color) |
 | DrawPlaneIcon |
Public method | DrawViewportMeshes |
Public method | DrawViewportWires |
Public method | Duplicate | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateGeometry | Create a duplicate of this plane. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..DuplicateGeometry()()()().)
Public method | DuplicatePlane | Create a duplicate of this plane.
Public method | EmitProxy | Returns a proxy that represents this plane. Do not call this function unless you're (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | GetBoundingBox | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..GetBoundingBox(Transform).)
Public method | LoadGeometry()()()() | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | LoadGeometry(RhinoDoc) | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. The default is to always return True. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | Morph | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Morph(SpaceMorph).)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ToString | Format the plane using default grasshopper formatting logic. (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Transform | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Transform(Transform).)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Boundingbox | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Boundingbox.)
Public property | ClippingBox |
Public property | IsGeometryLoaded | Gets a value indicating whether or not this geometry is currently loaded (assuming it is referenced). Not all IGH_GeometricGoo implementations support referenced geometry. The default is to always return True. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public property | IsReferencedGeometry | Gets a value indicating whether or not this geometry is referenced. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public property | IsValid | Gets the validity of the plane. If the plane is invalid, attempts are made to fix the data. If the plane remains invalid, False is returned. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot.)
Public property | ReferenceID | Gets or sets the Guid of the object that is referenced. Not all IGH_GeometricGoo implementations support referenced geometry. The default implementation is to always return Guid.Empty. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the value of this type. Note that if the type has a ReferenceID this value might get destroyed in the future. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)

See Also

GH_Plane Class
Grasshopper.Kernel.Types Namespace


GH_Plane Constructor

[image] [image]

Grasshopper SDK
GH_Plane Constructor
GH_Plane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Plane()()()() | Default constructor. Creates a world XY plane.
Public method | GH_Plane(Plane) | Create a duplicate of another plane.
Public method | GH_Plane(GH_Plane) | Create a duplicate of another plane.

See Also

GH_Plane Class
GH_Plane Members
Grasshopper.Kernel.Types Namespace


GH_Plane Constructor

[image]

Grasshopper SDK
GH_Plane Constructor
GH_Plane Class See Also Send Feedback
Default constructor. Creates a world XY plane.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Plane()
Visual Basic
Public Sub New

See Also

GH_Plane Class
GH_Plane Overload
Grasshopper.Kernel.Types Namespace


GH_Plane Constructor ()

[image]

Grasshopper SDK
GH_Plane Constructor ()
GH_Plane Class See Also Send Feedback
Create a duplicate of another plane.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Plane(
    Plane plane
)
Visual Basic
Public Sub New ( _
    plane As Plane _
)

Parameters

plane
Type: Plane
Plane to set.

See Also

GH_Plane Class
GH_Plane Overload
Grasshopper.Kernel.Types Namespace


GH_Plane Constructor (GH_Plane)

[image]

Grasshopper SDK
GH_Plane Constructor (GH_Plane)
GH_Plane Class See Also Send Feedback
Create a duplicate of another plane.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Plane(
    GH_Plane other
)
Visual Basic
Public Sub New ( _
    other As GH_Plane _
)

Parameters

other
Type: Grasshopper.Kernel.Types..::..GH_Plane
Plane to copy. If null, a default plane will be created.

See Also

GH_Plane Class
GH_Plane Overload
Grasshopper.Kernel.Types Namespace


GH_Plane Fields

[image] [image]

Grasshopper SDK
GH_Plane Fields
GH_Plane Class See Also Send Feedback

The GH_Plane type exposes the following members.

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Plane Class
Grasshopper.Kernel.Types Namespace


GH_Plane Methods

[image] [image]

Grasshopper SDK
GH_Plane Methods
GH_Plane Class See Also Send Feedback

The GH_Plane type exposes the following members.

Methods

 | Name | Description
Public method | BakeGeometry |
Public method | CastFrom | Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type T. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | ClearCaches | Clears all caches. Typically if the geometry is referenced, this will erase the local copy. If your T is a value-type, you must override this function and specifically unset the local value. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
 | DrawPlane(DisplayPipeline, Plane) | Draw a plane with default colours and default size.
 | DrawPlane(DisplayPipeline, Plane, Double, Int32) |
 | DrawPlane(DisplayPipeline, Plane, Double, Int32, Color, Color, Color) |
 | DrawPlane(DisplayPipeline, Plane, Double, Int32, Color, Color, Color, Color) |
 | DrawPlaneIcon |
Public method | DrawViewportMeshes |
Public method | DrawViewportWires |
Public method | Duplicate | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateGeometry | Create a duplicate of this plane. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..DuplicateGeometry()()()().)
Public method | DuplicatePlane | Create a duplicate of this plane.
Public method | EmitProxy | Returns a proxy that represents this plane. Do not call this function unless you're (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | GetBoundingBox | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..GetBoundingBox(Transform).)
Public method | LoadGeometry()()()() | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | LoadGeometry(RhinoDoc) | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. The default is to always return True. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | Morph | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Morph(SpaceMorph).)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ToString | Format the plane using default grasshopper formatting logic. (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Transform | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Transform(Transform).)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

See Also

GH_Plane Class
Grasshopper.Kernel.Types Namespace


BakeGeometry Method

[image]

Grasshopper SDK
GH_Plane..::..BakeGeometry Method
GH_Plane Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool BakeGeometry(
    RhinoDoc doc,
    ObjectAttributes att,
    ref Guid obj_guid
)
Visual Basic
Public Function BakeGeometry ( _
    doc As RhinoDoc, _
    att As ObjectAttributes, _
    ByRef obj_guid As Guid _
) As Boolean

Parameters

doc
Type: RhinoDoc
att
Type: ObjectAttributes
obj_guid
Type: System..::..Guid %

Implements

IGH_BakeAwareData..::..BakeGeometry(RhinoDoc, ObjectAttributes, Guid%)

See Also

GH_Plane Class
Grasshopper.Kernel.Types Namespace


CastFrom Method

[image]

Grasshopper SDK
GH_Plane..::..CastFrom Method
GH_Plane Class See Also Send Feedback
Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastFrom(
    Object source
)
Visual Basic
Public Overrides Function CastFrom ( _
    source As Object _
) As Boolean

Parameters

source
Type: System..::..Object

See Also

GH_Plane Class
Grasshopper.Kernel.Types Namespace


CastTo Method

[image] [image]

Grasshopper SDK
GH_Plane..::..CastTo Method
GH_Plane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type T. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)

See Also

GH_Plane Class
GH_Plane Members
Grasshopper.Kernel.Types Namespace


CastTo(T) Method (T)

[image]

Grasshopper SDK
GH_Plane..::..CastTo<(Of <(<'T>)>)> Method (T%)
GH_Plane Class See Also Send Feedback
Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastTo<T>(
    out T target
)
Visual Basic
Public Overrides Function CastTo(Of T) ( _
    <OutAttribute> ByRef target As T _
) As Boolean

Parameters

target
Type: T%

Type Parameters

T

See Also

GH_Plane Class
CastTo Overload
Grasshopper.Kernel.Types Namespace


DrawPlane Method

[image] [image]

Grasshopper SDK
GH_Plane..::..DrawPlane Method
GH_Plane Class See Also Send Feedback

Overload List

Name | Description
DrawPlane(DisplayPipeline, Plane) | Draw a plane with default colours and default size.
DrawPlane(DisplayPipeline, Plane, Double, Int32) |
DrawPlane(DisplayPipeline, Plane, Double, Int32, Color, Color, Color) |
DrawPlane(DisplayPipeline, Plane, Double, Int32, Color, Color, Color, Color) |

See Also

GH_Plane Class
GH_Plane Members
Grasshopper.Kernel.Types Namespace


DrawPlane Method (, )

[image]

Grasshopper SDK
GH_Plane..::..DrawPlane Method (, )
GH_Plane Class See Also Send Feedback
Draw a plane with default colours and default size.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void DrawPlane(
    DisplayPipeline display,
    Plane plane
)
Visual Basic
Public Shared Sub DrawPlane ( _
    display As DisplayPipeline, _
    plane As Plane _
)

Parameters

display
Type: DisplayPipeline
plane
Type: Plane

See Also

GH_Plane Class
DrawPlane Overload
Grasshopper.Kernel.Types Namespace


DrawPlane Method (, , Double, Int32)

[image]

Grasshopper SDK
GH_Plane..::..DrawPlane Method (, , Double, Int32)
GH_Plane Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void DrawPlane(
    DisplayPipeline display,
    Plane plane,
    double size,
    int frequency
)
Visual Basic
Public Shared Sub DrawPlane ( _
    display As DisplayPipeline, _
    plane As Plane, _
    size As Double, _
    frequency As Integer _
)

Parameters

display
Type: DisplayPipeline
plane
Type: Plane
size
Type: System..::..Double
frequency
Type: System..::..Int32

See Also

GH_Plane Class
DrawPlane Overload
Grasshopper.Kernel.Types Namespace


DrawPlane Method (, , Double, Int32, Color, Color, Color)

[image]

Grasshopper SDK
GH_Plane..::..DrawPlane Method (, , Double, Int32, Color, Color, Color)
GH_Plane Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void DrawPlane(
    DisplayPipeline display,
    Plane plane,
    double size,
    int frequency,
    Color grid_color,
    Color x_color,
    Color y_color
)
Visual Basic
Public Shared Sub DrawPlane ( _
    display As DisplayPipeline, _
    plane As Plane, _
    size As Double, _
    frequency As Integer, _
    grid_color As Color, _
    x_color As Color, _
    y_color As Color _
)

Parameters

display
Type: DisplayPipeline
plane
Type: Plane
size
Type: System..::..Double
frequency
Type: System..::..Int32
grid_color
Type: System.Drawing..::..Color
x_color
Type: System.Drawing..::..Color
y_color
Type: System.Drawing..::..Color

See Also

GH_Plane Class
DrawPlane Overload
Grasshopper.Kernel.Types Namespace


DrawPlane Method (, , Double, Int32, Color, Color, Color, Color)

[image]

Grasshopper SDK
GH_Plane..::..DrawPlane Method (, , Double, Int32, Color, Color, Color, Color)
GH_Plane Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void DrawPlane(
    DisplayPipeline display,
    Plane plane,
    double size,
    int frequency,
    Color grid_color,
    Color x_color,
    Color y_color,
    Color back_color
)
Visual Basic
Public Shared Sub DrawPlane ( _
    display As DisplayPipeline, _
    plane As Plane, _
    size As Double, _
    frequency As Integer, _
    grid_color As Color, _
    x_color As Color, _
    y_color As Color, _
    back_color As Color _
)

Parameters

display
Type: DisplayPipeline
plane
Type: Plane
size
Type: System..::..Double
frequency
Type: System..::..Int32
grid_color
Type: System.Drawing..::..Color
x_color
Type: System.Drawing..::..Color
y_color
Type: System.Drawing..::..Color
back_color
Type: System.Drawing..::..Color

See Also

GH_Plane Class
DrawPlane Overload
Grasshopper.Kernel.Types Namespace


DrawPlaneIcon Method

[image]

Grasshopper SDK
GH_Plane..::..DrawPlaneIcon Method
GH_Plane Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void DrawPlaneIcon(
    DisplayPipeline display,
    Plane plane,
    double size,
    Color edgeColour,
    Color fillColour
)
Visual Basic
Public Shared Sub DrawPlaneIcon ( _
    display As DisplayPipeline, _
    plane As Plane, _
    size As Double, _
    edgeColour As Color, _
    fillColour As Color _
)

Parameters

display
Type: DisplayPipeline
plane
Type: Plane
size
Type: System..::..Double
edgeColour
Type: System.Drawing..::..Color
fillColour
Type: System.Drawing..::..Color

See Also

GH_Plane Class
Grasshopper.Kernel.Types Namespace


DrawViewportMeshes Method

[image]

Grasshopper SDK
GH_Plane..::..DrawViewportMeshes Method
GH_Plane Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DrawViewportMeshes(
    GH_PreviewMeshArgs args
)
Visual Basic
Public Sub DrawViewportMeshes ( _
    args As GH_PreviewMeshArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..GH_PreviewMeshArgs

Implements

IGH_PreviewData..::..DrawViewportMeshes(GH_PreviewMeshArgs)

See Also

GH_Plane Class
Grasshopper.Kernel.Types Namespace


DrawViewportWires Method

[image]

Grasshopper SDK
GH_Plane..::..DrawViewportWires Method
GH_Plane Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DrawViewportWires(
    GH_PreviewWireArgs args
)
Visual Basic
Public Sub DrawViewportWires ( _
    args As GH_PreviewWireArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..GH_PreviewWireArgs

Implements

IGH_PreviewData..::..DrawViewportWires(GH_PreviewWireArgs)

See Also

GH_Plane Class
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_Plane..::..Duplicate Method
GH_Plane Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_Goo Duplicate()
Visual Basic
Public Overrides Function Duplicate As IGH_Goo

See Also

GH_Plane Class
Grasshopper.Kernel.Types Namespace


DuplicateGeometry Method

[image]

Grasshopper SDK
GH_Plane..::..DuplicateGeometry Method
GH_Plane Class See Also Send Feedback
Create a duplicate of this plane.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GeometricGoo DuplicateGeometry()
Visual Basic
Public Overrides Function DuplicateGeometry As IGH_GeometricGoo

See Also

GH_Plane Class
Grasshopper.Kernel.Types Namespace


DuplicatePlane Method

[image]

Grasshopper SDK
GH_Plane..::..DuplicatePlane Method
GH_Plane Class See Also Send Feedback
Create a duplicate of this plane.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Plane DuplicatePlane()
Visual Basic
Public Function DuplicatePlane As GH_Plane

See Also

GH_Plane Class
Grasshopper.Kernel.Types Namespace


EmitProxy Method

[image]

Grasshopper SDK
GH_Plane..::..EmitProxy Method
GH_Plane Class See Also Send Feedback
Returns a proxy that represents this plane. Do not call this function unless you're

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GooProxy EmitProxy()
Visual Basic
Public Overrides Function EmitProxy As IGH_GooProxy

See Also

GH_Plane Class
Grasshopper.Kernel.Types Namespace


GetBoundingBox Method

[image]

Grasshopper SDK
GH_Plane..::..GetBoundingBox Method
GH_Plane Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override BoundingBox GetBoundingBox(
    Transform xform
)
Visual Basic
Public Overrides Function GetBoundingBox ( _
    xform As Transform _
) As BoundingBox

Parameters

xform
Type: Transform

See Also

GH_Plane Class
Grasshopper.Kernel.Types Namespace


LoadGeometry Method

[image] [image]

Grasshopper SDK
GH_Plane..::..LoadGeometry Method
GH_Plane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LoadGeometry()()()() | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | LoadGeometry(RhinoDoc) | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. The default is to always return True. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)

See Also

GH_Plane Class
GH_Plane Members
Grasshopper.Kernel.Types Namespace


Morph Method

[image]

Grasshopper SDK
GH_Plane..::..Morph Method
GH_Plane Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GeometricGoo Morph(
    SpaceMorph xmorph
)
Visual Basic
Public Overrides Function Morph ( _
    xmorph As SpaceMorph _
) As IGH_GeometricGoo

Parameters

xmorph
Type: SpaceMorph

See Also

GH_Plane Class
Grasshopper.Kernel.Types Namespace


Read Method

[image]

Grasshopper SDK
GH_Plane..::..Read Method
GH_Plane Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

See Also

GH_Plane Class
Grasshopper.Kernel.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_Plane..::..ToString Method
GH_Plane Class See Also Send Feedback
Format the plane using default grasshopper formatting logic.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_Plane Class
Grasshopper.Kernel.Types Namespace


Transform Method

[image]

Grasshopper SDK
GH_Plane..::..Transform Method
GH_Plane Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GeometricGoo Transform(
    Transform xform
)
Visual Basic
Public Overrides Function Transform ( _
    xform As Transform _
) As IGH_GeometricGoo

Parameters

xform
Type: Transform

See Also

GH_Plane Class
Grasshopper.Kernel.Types Namespace


Write Method

[image]

Grasshopper SDK
GH_Plane..::..Write Method
GH_Plane Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overrides Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

See Also

GH_Plane Class
Grasshopper.Kernel.Types Namespace


GH_Plane Properties

[image] [image]

Grasshopper SDK
GH_Plane Properties
GH_Plane Class See Also Send Feedback

The GH_Plane type exposes the following members.

Properties

 | Name | Description
Public property | Boundingbox | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Boundingbox.)
Public property | ClippingBox |
Public property | IsGeometryLoaded | Gets a value indicating whether or not this geometry is currently loaded (assuming it is referenced). Not all IGH_GeometricGoo implementations support referenced geometry. The default is to always return True. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public property | IsReferencedGeometry | Gets a value indicating whether or not this geometry is referenced. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public property | IsValid | Gets the validity of the plane. If the plane is invalid, attempts are made to fix the data. If the plane remains invalid, False is returned. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot.)
Public property | ReferenceID | Gets or sets the Guid of the object that is referenced. Not all IGH_GeometricGoo implementations support referenced geometry. The default implementation is to always return Guid.Empty. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the value of this type. Note that if the type has a ReferenceID this value might get destroyed in the future. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)

See Also

GH_Plane Class
Grasshopper.Kernel.Types Namespace


Boundingbox Property

[image]

Grasshopper SDK
GH_Plane..::..Boundingbox Property
GH_Plane Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override BoundingBox Boundingbox { get; }
Visual Basic
Public Overrides ReadOnly Property Boundingbox As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Plane.Boundingbox"]

See Also

GH_Plane Class
Grasshopper.Kernel.Types Namespace


ClippingBox Property

[image]

Grasshopper SDK
GH_Plane..::..ClippingBox Property
GH_Plane Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public BoundingBox ClippingBox { get; }
Visual Basic
Public ReadOnly Property ClippingBox As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Plane.ClippingBox"]

Implements

IGH_PreviewData..::..ClippingBox

See Also

GH_Plane Class
Grasshopper.Kernel.Types Namespace


IsValid Property

[image]

Grasshopper SDK
GH_Plane..::..IsValid Property
GH_Plane Class See Also Send Feedback
Gets the validity of the plane. If the plane is invalid, attempts are made to fix the data. If the plane remains invalid, False is returned.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool IsValid { get; }
Visual Basic
Public Overrides ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Plane.IsValid"]

See Also

GH_Plane Class
Grasshopper.Kernel.Types Namespace


IsValidWhyNot Property

[image]

Grasshopper SDK
GH_Plane..::..IsValidWhyNot Property
GH_Plane Class See Also Send Feedback
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string IsValidWhyNot { get; }
Visual Basic
Public Overrides ReadOnly Property IsValidWhyNot As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Plane.IsValidWhyNot"]

See Also

GH_Plane Class
Grasshopper.Kernel.Types Namespace


TypeDescription Property

[image]

Grasshopper SDK
GH_Plane..::..TypeDescription Property
GH_Plane Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeDescription { get; }
Visual Basic
Public Overrides ReadOnly Property TypeDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Plane.TypeDescription"]

See Also

GH_Plane Class
Grasshopper.Kernel.Types Namespace


TypeName Property

[image]

Grasshopper SDK
GH_Plane..::..TypeName Property
GH_Plane Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeName { get; }
Visual Basic
Public Overrides ReadOnly Property TypeName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Plane.TypeName"]

See Also

GH_Plane Class
Grasshopper.Kernel.Types Namespace


GH_Plane.GH_PlaneProxy Class

[image]

Grasshopper SDK
GH_Plane..::..GH_PlaneProxy Class
GH_Plane Class Members See Also Send Feedback
Proxy description of GH_Plane class. This class is used by the Generic Multivalue interfaces.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_PlaneProxy : GH_GooProxy<GH_Plane>
Visual Basic
Public Class GH_PlaneProxy _
    Inherits GH_GooProxy(Of GH_Plane)

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_GooProxy <(Of <(<' GH_Plane >)>)>
Grasshopper.Kernel.Types..::..GH_Plane..::..GH_PlaneProxy

See Also

GH_Plane..::..GH_PlaneProxy Members
Grasshopper.Kernel.Types Namespace


GH_Plane.GH_PlaneProxy Members

[image] [image]

Grasshopper SDK
GH_Plane..::..GH_PlaneProxy Members
GH_Plane..::..GH_PlaneProxy Class Constructors Methods Properties See Also Send Feedback

Represents a 3D plane. GH_Plane re-implements the OpenNURBS OnPlane class.

The GH_Plane..::..GH_PlaneProxy type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Plane..::..GH_PlaneProxy | Initializes a new instance of the GH_Plane..::..GH_PlaneProxy class

Methods

 | Name | Description
Public method | Construct | (Overrides GH_GooProxy<(Of <(<'T>)>)>..::..Construct()()()().)
Public method | FormatInstance | Returns a String description of the current value. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FromString | If IsParsable(), then attempts to convert the string to a generic type value (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | MutateString | Munge a string to remove obvious errors on account of the user. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | NumberToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | StringToNumber | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | ToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | IsParsable | Gets a value indicating whether or not the type can be instantiated from a String. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Origin |
Protected property | Owner | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | ProxyOwner | Gets the piece of Grasshopper data that spawned this proxy. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeName | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | UserString | Gets or sets the user-defined string that describes this proxy. This only really makes sense if the Proxy is Parsable. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Valid | Gets a value indicating whether this proxy represents valid data. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | XAxis |
Public property | YAxis |
Public property | ZAxis |

See Also

GH_Plane..::..GH_PlaneProxy Class
Grasshopper.Kernel.Types Namespace


GH_Plane.GH_PlaneProxy Constructor

[image]

Grasshopper SDK
GH_Plane..::..GH_PlaneProxy Constructor
GH_Plane..::..GH_PlaneProxy Class See Also Send Feedback
Initializes a new instance of the GH_Plane..::..GH_PlaneProxy class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PlaneProxy(
    GH_Plane nOwner
)
Visual Basic
Public Sub New ( _
    nOwner As GH_Plane _
)

Parameters

nOwner
Type: Grasshopper.Kernel.Types..::..GH_Plane

See Also

GH_Plane..::..GH_PlaneProxy Class
Grasshopper.Kernel.Types Namespace


GH_Plane.GH_PlaneProxy Methods

[image] [image]

Grasshopper SDK
GH_Plane..::..GH_PlaneProxy Methods
GH_Plane..::..GH_PlaneProxy Class See Also Send Feedback

The GH_Plane..::..GH_PlaneProxy type exposes the following members.

Methods

 | Name | Description
Public method | Construct | (Overrides GH_GooProxy<(Of <(<'T>)>)>..::..Construct()()()().)
Public method | FormatInstance | Returns a String description of the current value. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FromString | If IsParsable(), then attempts to convert the string to a generic type value (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | MutateString | Munge a string to remove obvious errors on account of the user. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | NumberToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | StringToNumber | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | ToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

See Also

GH_Plane..::..GH_PlaneProxy Class
Grasshopper.Kernel.Types Namespace


Construct Method

[image]

Grasshopper SDK
GH_Plane..::..GH_PlaneProxy..::..Construct Method
GH_Plane..::..GH_PlaneProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void Construct()
Visual Basic
Public Overrides Sub Construct

See Also

GH_Plane..::..GH_PlaneProxy Class
Grasshopper.Kernel.Types Namespace


GH_Plane.GH_PlaneProxy Properties

[image] [image]

Grasshopper SDK
GH_Plane..::..GH_PlaneProxy Properties
GH_Plane..::..GH_PlaneProxy Class See Also Send Feedback

The GH_Plane..::..GH_PlaneProxy type exposes the following members.

Properties

 | Name | Description
Public property | IsParsable | Gets a value indicating whether or not the type can be instantiated from a String. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Origin |
Protected property | Owner | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | ProxyOwner | Gets the piece of Grasshopper data that spawned this proxy. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeName | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | UserString | Gets or sets the user-defined string that describes this proxy. This only really makes sense if the Proxy is Parsable. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Valid | Gets a value indicating whether this proxy represents valid data. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | XAxis |
Public property | YAxis |
Public property | ZAxis |

See Also

GH_Plane..::..GH_PlaneProxy Class
Grasshopper.Kernel.Types Namespace


Origin Property

[image]

Grasshopper SDK
GH_Plane..::..GH_PlaneProxy..::..Origin Property
GH_Plane..::..GH_PlaneProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Point3d_Wrapper Origin { get; }
Visual Basic
Public ReadOnly Property Origin As GH_Point3d_Wrapper
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Plane.GH_PlaneProxy.Origin"]

See Also

GH_Plane..::..GH_PlaneProxy Class
Grasshopper.Kernel.Types Namespace


XAxis Property

[image]

Grasshopper SDK
GH_Plane..::..GH_PlaneProxy..::..XAxis Property
GH_Plane..::..GH_PlaneProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Vector3d_Wrapper XAxis { get; }
Visual Basic
Public ReadOnly Property XAxis As GH_Vector3d_Wrapper
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Plane.GH_PlaneProxy.XAxis"]

See Also

GH_Plane..::..GH_PlaneProxy Class
Grasshopper.Kernel.Types Namespace


YAxis Property

[image]

Grasshopper SDK
GH_Plane..::..GH_PlaneProxy..::..YAxis Property
GH_Plane..::..GH_PlaneProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Vector3d_Wrapper YAxis { get; }
Visual Basic
Public ReadOnly Property YAxis As GH_Vector3d_Wrapper
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Plane.GH_PlaneProxy.YAxis"]

See Also

GH_Plane..::..GH_PlaneProxy Class
Grasshopper.Kernel.Types Namespace


ZAxis Property

[image]

Grasshopper SDK
GH_Plane..::..GH_PlaneProxy..::..ZAxis Property
GH_Plane..::..GH_PlaneProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Vector3d_Wrapper ZAxis { get; }
Visual Basic
Public ReadOnly Property ZAxis As GH_Vector3d_Wrapper
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Plane.GH_PlaneProxy.ZAxis"]

See Also

GH_Plane..::..GH_PlaneProxy Class
Grasshopper.Kernel.Types Namespace


GH_Point Class

[image]

Grasshopper SDK
GH_Point Class
Members See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Point : IGH_GeometricGoo, IGH_BakeAwareData,
    IGH_PreviewData, IGH_QuickCast
Visual Basic
Public Class GH_Point _
    Implements IGH_GeometricGoo, IGH_BakeAwareData, IGH_PreviewData, IGH_QuickCast

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_Point

See Also

GH_Point Members
Grasshopper.Kernel.Types Namespace


GH_Point Members

[image] [image]

Grasshopper SDK
GH_Point Members
GH_Point Class Constructors Methods Properties See Also Send Feedback

The GH_Point type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Point()()()() | Initializes a new instance of the GH_Point class
Public method | GH_Point(Point3d) | Initializes a new instance of the GH_Point class
Public method | GH_Point(Guid) | Initializes a new instance of the GH_Point class
Public method | GH_Point(GH_Point) | Initializes a new instance of the GH_Point class

Methods

 | Name | Description
Public method | BakeGeometry |
Public method | CastFrom |
Public method | CastTo<(Of <<'(T>)>>) |
Public method | ClearCaches |
Public method | CreateFromCoordinate | Create a new point geometry instance based on a fixed coordinate
Public method | CreateFromCurveDistance | Create new point geometry instance based on a curve distance parameter
Public method | CreateFromCurveRatio | Create new point geometry instance based on a curve parameter ratio
Public method | CreateFromEdgeDistance | Create new point geometry instance based on a curve distance parameter
Public method | CreateFromEdgeRatio | Create new point geometry instance based on an edge parameter ratio
Public method | CreateFromPointObject | Create a new point geometry instance based on point object ID
Public method | CreateFromSurfaceParam | Create new point geometry instance based on a curve distance parameter
Public method | DrawViewportMeshes |
Public method | DrawViewportWires |
Public method | Duplicate |
Public method | DuplicateGeometry |
Public method | DuplicatePoint |
Public method | EmitProxy |
Public method | EnsureReferenceData | Creates new Reference data if it doesn't already exists
Public method | GetBoundingBox |
Public method | LoadGeometry()()()() |
Public method | LoadGeometry(RhinoDoc) |
Public method | Morph |
Public method | Read |
Public method | ReferenceCurve()()()() |
Public method | ReferenceCurve(RhinoObject) |
Public method | ReferenceIndex()()()() | Retrieve the index of the point reference data.
Public method | ReferenceIndex(Int32) | Sets the index of the point reference data.
Public method | ReferenceParam(Int32) | Retrieve the indexed param of the point reference data.
Public method | ReferenceParam(Int32, Double) | Sets the index of the point reference data.
Public method | ReferencesCurve | Returns true if this point is based on a curve reference
Public method | ReferencesEdge | Returns True if this point is based on an edge reference
Public method | ReferenceSurface |
Public method | ReferenceType()()()() | Retrieve the reference type of this point object.
Public method | ReferenceType(GH_PointRefType) | Sets the type of the point reference data.
Public method | ScriptVariable |
Public method | SetReferenceParams | Sets both param values of the point reference
Public method | ShowReferenceDialog()()()() |
Public method | ShowReferenceDialog(IWin32Window) |
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | Transform |
Public method | Write |

Properties

 | Name | Description
Public property | Boundingbox |
Public property | ClippingBox |
Public property | IsGeometryLoaded |
Public property | IsReferencedGeometry |
Public property | IsValid |
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.
Public property | ReferenceData | Gets or sets the reference data of this point geometry.
Public property | ReferenceID |
Public property | TypeDescription |
Public property | TypeName |
Public property | Value |

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


GH_Point Constructor

[image] [image]

Grasshopper SDK
GH_Point Constructor
GH_Point Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Point()()()() | Initializes a new instance of the GH_Point class
Public method | GH_Point(Point3d) | Initializes a new instance of the GH_Point class
Public method | GH_Point(Guid) | Initializes a new instance of the GH_Point class
Public method | GH_Point(GH_Point) | Initializes a new instance of the GH_Point class

See Also

GH_Point Class
GH_Point Members
Grasshopper.Kernel.Types Namespace


GH_Point Constructor

[image]

Grasshopper SDK
GH_Point Constructor
GH_Point Class See Also Send Feedback
Initializes a new instance of the GH_Point class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Point()
Visual Basic
Public Sub New

See Also

GH_Point Class
GH_Point Overload
Grasshopper.Kernel.Types Namespace


GH_Point Constructor ()

[image]

Grasshopper SDK
GH_Point Constructor ()
GH_Point Class See Also Send Feedback
Initializes a new instance of the GH_Point class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Point(
    Point3d pt
)
Visual Basic
Public Sub New ( _
    pt As Point3d _
)

Parameters

pt
Type: Point3d

See Also

GH_Point Class
GH_Point Overload
Grasshopper.Kernel.Types Namespace


GH_Point Constructor (Guid)

[image]

Grasshopper SDK
GH_Point Constructor (Guid)
GH_Point Class See Also Send Feedback
Initializes a new instance of the GH_Point class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Point(
    Guid rh_obj_id
)
Visual Basic
Public Sub New ( _
    rh_obj_id As Guid _
)

Parameters

rh_obj_id
Type: System..::..Guid

See Also

GH_Point Class
GH_Point Overload
Grasshopper.Kernel.Types Namespace


GH_Point Constructor (GH_Point)

[image]

Grasshopper SDK
GH_Point Constructor (GH_Point)
GH_Point Class See Also Send Feedback
Initializes a new instance of the GH_Point class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Point(
    GH_Point iOther
)
Visual Basic
Public Sub New ( _
    iOther As GH_Point _
)

Parameters

iOther
Type: Grasshopper.Kernel.Types..::..GH_Point

See Also

GH_Point Class
GH_Point Overload
Grasshopper.Kernel.Types Namespace


GH_Point Methods

[image] [image]

Grasshopper SDK
GH_Point Methods
GH_Point Class See Also Send Feedback

The GH_Point type exposes the following members.

Methods

 | Name | Description
Public method | BakeGeometry |
Public method | CastFrom |
Public method | CastTo<(Of <<'(T>)>>) |
Public method | ClearCaches |
Public method | CreateFromCoordinate | Create a new point geometry instance based on a fixed coordinate
Public method | CreateFromCurveDistance | Create new point geometry instance based on a curve distance parameter
Public method | CreateFromCurveRatio | Create new point geometry instance based on a curve parameter ratio
Public method | CreateFromEdgeDistance | Create new point geometry instance based on a curve distance parameter
Public method | CreateFromEdgeRatio | Create new point geometry instance based on an edge parameter ratio
Public method | CreateFromPointObject | Create a new point geometry instance based on point object ID
Public method | CreateFromSurfaceParam | Create new point geometry instance based on a curve distance parameter
Public method | DrawViewportMeshes |
Public method | DrawViewportWires |
Public method | Duplicate |
Public method | DuplicateGeometry |
Public method | DuplicatePoint |
Public method | EmitProxy |
Public method | EnsureReferenceData | Creates new Reference data if it doesn't already exists
Public method | GetBoundingBox |
Public method | LoadGeometry()()()() |
Public method | LoadGeometry(RhinoDoc) |
Public method | Morph |
Public method | Read |
Public method | ReferenceCurve()()()() |
Public method | ReferenceCurve(RhinoObject) |
Public method | ReferenceIndex()()()() | Retrieve the index of the point reference data.
Public method | ReferenceIndex(Int32) | Sets the index of the point reference data.
Public method | ReferenceParam(Int32) | Retrieve the indexed param of the point reference data.
Public method | ReferenceParam(Int32, Double) | Sets the index of the point reference data.
Public method | ReferencesCurve | Returns true if this point is based on a curve reference
Public method | ReferencesEdge | Returns True if this point is based on an edge reference
Public method | ReferenceSurface |
Public method | ReferenceType()()()() | Retrieve the reference type of this point object.
Public method | ReferenceType(GH_PointRefType) | Sets the type of the point reference data.
Public method | ScriptVariable |
Public method | SetReferenceParams | Sets both param values of the point reference
Public method | ShowReferenceDialog()()()() |
Public method | ShowReferenceDialog(IWin32Window) |
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | Transform |
Public method | Write |

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


BakeGeometry Method

[image]

Grasshopper SDK
GH_Point..::..BakeGeometry Method
GH_Point Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool BakeGeometry(
    RhinoDoc doc,
    ObjectAttributes att,
    ref Guid obj_guid
)
Visual Basic
Public Function BakeGeometry ( _
    doc As RhinoDoc, _
    att As ObjectAttributes, _
    ByRef obj_guid As Guid _
) As Boolean

Parameters

doc
Type: RhinoDoc
att
Type: ObjectAttributes
obj_guid
Type: System..::..Guid %

Implements

IGH_BakeAwareData..::..BakeGeometry(RhinoDoc, ObjectAttributes, Guid%)

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


CastFrom Method

[image]

Grasshopper SDK
GH_Point..::..CastFrom Method
GH_Point Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool CastFrom(
    Object source
)
Visual Basic
Public Function CastFrom ( _
    source As Object _
) As Boolean

Parameters

source
Type: System..::..Object

Implements

IGH_Goo..::..CastFrom(Object)

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


CastTo(T) Method

[image]

Grasshopper SDK
GH_Point..::..CastTo<(Of <(<'T>)>)> Method
GH_Point Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool CastTo<T>(
    out T target
)
Visual Basic
Public Function CastTo(Of T) ( _
    <OutAttribute> ByRef target As T _
) As Boolean

Parameters

target
Type: T%

Type Parameters

T

Implements

IGH_Goo..::..CastTo<(Of <<'(T>)>>)(T%)

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


ClearCaches Method

[image]

Grasshopper SDK
GH_Point..::..ClearCaches Method
GH_Point Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ClearCaches()
Visual Basic
Public Sub ClearCaches

Implements

IGH_GeometricGoo..::..ClearCaches()()()()

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


CreateFromCoordinate Method

[image]

Grasshopper SDK
GH_Point..::..CreateFromCoordinate Method
GH_Point Class See Also Send Feedback
Create a new point geometry instance based on a fixed coordinate

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void CreateFromCoordinate(
    Point3d pt
)
Visual Basic
Public Sub CreateFromCoordinate ( _
    pt As Point3d _
)

Parameters

pt
Type: Point3d
The coordinate for the point

Remarks

This 'constructor' merely sets fields, it doesn't load the geometry and it doesn't perform validity checking.

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


CreateFromCurveDistance Method

[image]

Grasshopper SDK
GH_Point..::..CreateFromCurveDistance Method
GH_Point Class See Also Send Feedback
Create new point geometry instance based on a curve distance parameter

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void CreateFromCurveDistance(
    Guid crv_id,
    Curve crv,
    double t,
    bool bFromStart
)
Visual Basic
Public Sub CreateFromCurveDistance ( _
    crv_id As Guid, _
    crv As Curve, _
    t As Double, _
    bFromStart As Boolean _
)

Parameters

crv_id
Type: System..::..Guid
ID of the curve this object references
crv
Type: Curve
The curve to act on
t
Type: System..::..Double
Parameter on the curve that controls the distance measurement
bFromStart
Type: System..::..Boolean
True if the distance is to be measured from the start of the curve

Remarks

This 'constructor' merely sets fields, it doesn't load the geometry and it doesn't perform validity checking.

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


CreateFromCurveRatio Method

[image]

Grasshopper SDK
GH_Point..::..CreateFromCurveRatio Method
GH_Point Class See Also Send Feedback
Create new point geometry instance based on a curve parameter ratio

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void CreateFromCurveRatio(
    Guid crv_id,
    Curve crv,
    double t
)
Visual Basic
Public Sub CreateFromCurveRatio ( _
    crv_id As Guid, _
    crv As Curve, _
    t As Double _
)

Parameters

crv_id
Type: System..::..Guid
ID of the curve this object references
crv
Type: Curve
t
Type: System..::..Double
Parameter on curve in domain space

Remarks

This 'constructor' merely sets fields, it doesn't load the geometry and it doesn't perform validity checking.

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


CreateFromEdgeDistance Method

[image]

Grasshopper SDK
GH_Point..::..CreateFromEdgeDistance Method
GH_Point Class See Also Send Feedback
Create new point geometry instance based on a curve distance parameter

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void CreateFromEdgeDistance(
    Guid brp_id,
    Curve edge,
    int e_index,
    double t,
    bool bFromStart
)
Visual Basic
Public Sub CreateFromEdgeDistance ( _
    brp_id As Guid, _
    edge As Curve, _
    e_index As Integer, _
    t As Double, _
    bFromStart As Boolean _
)

Parameters

brp_id
Type: System..::..Guid
ID of the curve this object references
edge
Type: Curve
The edge curve
e_index
Type: System..::..Int32
Index of edge to reference
t
Type: System..::..Double
Parameter along the curve in curve domain space
bFromStart
Type: System..::..Boolean
True if the distance is to be measured from the start of the curve

Remarks

This 'constructor' merely sets fields, it doesn't load the geometry and it doesn't perform validity checking.

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


CreateFromEdgeRatio Method

[image]

Grasshopper SDK
GH_Point..::..CreateFromEdgeRatio Method
GH_Point Class See Also Send Feedback
Create new point geometry instance based on an edge parameter ratio

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void CreateFromEdgeRatio(
    Guid brp_id,
    Curve edge,
    int e_index,
    double t
)
Visual Basic
Public Sub CreateFromEdgeRatio ( _
    brp_id As Guid, _
    edge As Curve, _
    e_index As Integer, _
    t As Double _
)

Parameters

brp_id
Type: System..::..Guid
ID of the brep this object references
edge
Type: Curve
The edge curve
e_index
Type: System..::..Int32
Index of edge to reference
t
Type: System..::..Double
Parameter on edge in edge domain space

Remarks

This 'constructor' merely sets fields, it doesn't load the geometry and it doesn't perform validity checking.

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


CreateFromPointObject Method

[image]

Grasshopper SDK
GH_Point..::..CreateFromPointObject Method
GH_Point Class See Also Send Feedback
Create a new point geometry instance based on point object ID

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void CreateFromPointObject(
    Guid id
)
Visual Basic
Public Sub CreateFromPointObject ( _
    id As Guid _
)

Parameters

id
Type: System..::..Guid
The identifier of the point object

Remarks

This 'constructor' merely sets fields, it doesn't load the geometry and it doesn't perform validity checking.

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


CreateFromSurfaceParam Method

[image]

Grasshopper SDK
GH_Point..::..CreateFromSurfaceParam Method
GH_Point Class See Also Send Feedback
Create new point geometry instance based on a curve distance parameter

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void CreateFromSurfaceParam(
    Guid brp_id,
    int f_index,
    Surface srf,
    double u,
    double v
)
Visual Basic
Public Sub CreateFromSurfaceParam ( _
    brp_id As Guid, _
    f_index As Integer, _
    srf As Surface, _
    u As Double, _
    v As Double _
)

Parameters

brp_id
Type: System..::..Guid
ID of the curve this object references
f_index
Type: System..::..Int32
Index of edge to reference
srf
Type: Surface
Surface to work on
u
Type: System..::..Double
Parameter in surface U direction
v
Type: System..::..Double
Parameter in surface V direction

Remarks

This 'constructor' merely sets fields, it doesn't load the geometry and it doesn't perform validity checking.

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


DrawViewportMeshes Method

[image]

Grasshopper SDK
GH_Point..::..DrawViewportMeshes Method
GH_Point Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DrawViewportMeshes(
    GH_PreviewMeshArgs args
)
Visual Basic
Public Sub DrawViewportMeshes ( _
    args As GH_PreviewMeshArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..GH_PreviewMeshArgs

Implements

IGH_PreviewData..::..DrawViewportMeshes(GH_PreviewMeshArgs)

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


DrawViewportWires Method

[image]

Grasshopper SDK
GH_Point..::..DrawViewportWires Method
GH_Point Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DrawViewportWires(
    GH_PreviewWireArgs args
)
Visual Basic
Public Sub DrawViewportWires ( _
    args As GH_PreviewWireArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..GH_PreviewWireArgs

Implements

IGH_PreviewData..::..DrawViewportWires(GH_PreviewWireArgs)

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_Point..::..Duplicate Method
GH_Point Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_Goo Duplicate()
Visual Basic
Public Function Duplicate As IGH_Goo

Implements

IGH_Goo..::..Duplicate()()()()

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


DuplicateGeometry Method

[image]

Grasshopper SDK
GH_Point..::..DuplicateGeometry Method
GH_Point Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_GeometricGoo DuplicateGeometry()
Visual Basic
Public Function DuplicateGeometry As IGH_GeometricGoo

Implements

IGH_GeometricGoo..::..DuplicateGeometry()()()()

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


DuplicatePoint Method

[image]

Grasshopper SDK
GH_Point..::..DuplicatePoint Method
GH_Point Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Point DuplicatePoint()
Visual Basic
Public Function DuplicatePoint As GH_Point

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


EmitProxy Method

[image]

Grasshopper SDK
GH_Point..::..EmitProxy Method
GH_Point Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_GooProxy EmitProxy()
Visual Basic
Public Function EmitProxy As IGH_GooProxy

Implements

IGH_Goo..::..EmitProxy()()()()

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


EnsureReferenceData Method

[image]

Grasshopper SDK
GH_Point..::..EnsureReferenceData Method
GH_Point Class See Also Send Feedback
Creates new Reference data if it doesn't already exists

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void EnsureReferenceData()
Visual Basic
Public Sub EnsureReferenceData

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


GetBoundingBox Method

[image]

Grasshopper SDK
GH_Point..::..GetBoundingBox Method
GH_Point Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public BoundingBox GetBoundingBox(
    Transform xform
)
Visual Basic
Public Function GetBoundingBox ( _
    xform As Transform _
) As BoundingBox

Parameters

xform
Type: Transform

Implements

IGH_GeometricGoo..::..GetBoundingBox(Transform)

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


LoadGeometry Method

[image] [image]

Grasshopper SDK
GH_Point..::..LoadGeometry Method
GH_Point Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LoadGeometry()()()() |
Public method | LoadGeometry(RhinoDoc) |

See Also

GH_Point Class
GH_Point Members
Grasshopper.Kernel.Types Namespace


LoadGeometry Method

[image]

Grasshopper SDK
GH_Point..::..LoadGeometry Method
GH_Point Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool LoadGeometry()
Visual Basic
Public Function LoadGeometry As Boolean

Implements

IGH_GeometricGoo..::..LoadGeometry()()()()

See Also

GH_Point Class
LoadGeometry Overload
Grasshopper.Kernel.Types Namespace


LoadGeometry Method ()

[image]

Grasshopper SDK
GH_Point..::..LoadGeometry Method ()
GH_Point Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool LoadGeometry(
    RhinoDoc doc
)
Visual Basic
Public Function LoadGeometry ( _
    doc As RhinoDoc _
) As Boolean

Parameters

doc
Type: RhinoDoc

Implements

IGH_GeometricGoo..::..LoadGeometry(RhinoDoc)

See Also

GH_Point Class
LoadGeometry Overload
Grasshopper.Kernel.Types Namespace


Morph Method

[image]

Grasshopper SDK
GH_Point..::..Morph Method
GH_Point Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_GeometricGoo Morph(
    SpaceMorph xmorph
)
Visual Basic
Public Function Morph ( _
    xmorph As SpaceMorph _
) As IGH_GeometricGoo

Parameters

xmorph
Type: SpaceMorph

Implements

IGH_GeometricGoo..::..Morph(SpaceMorph)

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


Read Method

[image]

Grasshopper SDK
GH_Point..::..Read Method
GH_Point Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Read(
    GH_IReader reader
)
Visual Basic
Public Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

Implements

GH_ISerializable..::..Read(GH_IReader)

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


ReferenceCurve Method

[image] [image]

Grasshopper SDK
GH_Point..::..ReferenceCurve Method
GH_Point Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReferenceCurve()()()() |
Public method | ReferenceCurve(RhinoObject) |

See Also

GH_Point Class
GH_Point Members
Grasshopper.Kernel.Types Namespace


ReferenceCurve Method

[image]

Grasshopper SDK
GH_Point..::..ReferenceCurve Method
GH_Point Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Curve ReferenceCurve()
Visual Basic
Public Function ReferenceCurve As Curve

See Also

GH_Point Class
ReferenceCurve Overload
Grasshopper.Kernel.Types Namespace


ReferenceCurve Method ()

[image]

Grasshopper SDK
GH_Point..::..ReferenceCurve Method ()
GH_Point Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Curve ReferenceCurve(
    RhinoObject ref
)
Visual Basic
Public Function ReferenceCurve ( _
    ref As RhinoObject _
) As Curve

Parameters

ref
Type: RhinoObject

See Also

GH_Point Class
ReferenceCurve Overload
Grasshopper.Kernel.Types Namespace


ReferenceIndex Method

[image] [image]

Grasshopper SDK
GH_Point..::..ReferenceIndex Method
GH_Point Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReferenceIndex()()()() | Retrieve the index of the point reference data.
Public method | ReferenceIndex(Int32) | Sets the index of the point reference data.

See Also

GH_Point Class
GH_Point Members
Grasshopper.Kernel.Types Namespace


ReferenceIndex Method

[image]

Grasshopper SDK
GH_Point..::..ReferenceIndex Method
GH_Point Class See Also Send Feedback
Retrieve the index of the point reference data.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int ReferenceIndex()
Visual Basic
Public Function ReferenceIndex As Integer

Return Value

The index of the reference data. This index describes the sub-object of the reference.

Remarks

If there exists no reference data, -1 is returned.

See Also

GH_Point Class
ReferenceIndex Overload
Grasshopper.Kernel.Types Namespace


ReferenceIndex Method (Int32)

[image]

Grasshopper SDK
GH_Point..::..ReferenceIndex Method (Int32)
GH_Point Class See Also Send Feedback
Sets the index of the point reference data.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ReferenceIndex(
    int new_index
)
Visual Basic
Public Sub ReferenceIndex ( _
    new_index As Integer _
)

Parameters

new_index
Type: System..::..Int32
The index to set. This index describes the sub-object of the reference.

Remarks

If there is no reference data, this function will create a new instance.

See Also

GH_Point Class
ReferenceIndex Overload
Grasshopper.Kernel.Types Namespace


ReferenceParam Method

[image] [image]

Grasshopper SDK
GH_Point..::..ReferenceParam Method
GH_Point Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReferenceParam(Int32) | Retrieve the indexed param of the point reference data.
Public method | ReferenceParam(Int32, Double) | Sets the index of the point reference data.

See Also

GH_Point Class
GH_Point Members
Grasshopper.Kernel.Types Namespace


ReferenceParam Method (Int32)

[image]

Grasshopper SDK
GH_Point..::..ReferenceParam Method (Int32)
GH_Point Class See Also Send Feedback
Retrieve the indexed param of the point reference data.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double ReferenceParam(
    int index
)
Visual Basic
Public Function ReferenceParam ( _
    index As Integer _
) As Double

Parameters

index
Type: System..::..Int32
Index of parameter. Only 0 and 1 are valid values.

Return Value

The indexed param of the reference data.

Remarks

If there exists no reference data, NaN is returned.

See Also

GH_Point Class
ReferenceParam Overload
Grasshopper.Kernel.Types Namespace


ReferenceParam Method (Int32, Double)

[image]

Grasshopper SDK
GH_Point..::..ReferenceParam Method (Int32, Double)
GH_Point Class See Also Send Feedback
Sets the index of the point reference data.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ReferenceParam(
    int index,
    double new_param
)
Visual Basic
Public Sub ReferenceParam ( _
    index As Integer, _
    new_param As Double _
)

Parameters

index
Type: System..::..Int32
The index of the parameter. Only 0 and 1 are valid values.
new_param
Type: System..::..Double
The new value of the parameter

Remarks

If there is no reference data, this function will create a new instance.

See Also

GH_Point Class
ReferenceParam Overload
Grasshopper.Kernel.Types Namespace


ReferencesCurve Method

[image]

Grasshopper SDK
GH_Point..::..ReferencesCurve Method
GH_Point Class See Also Send Feedback
Returns true if this point is based on a curve reference

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool ReferencesCurve()
Visual Basic
Public Function ReferencesCurve As Boolean

Return Value

Remarks

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


ReferencesEdge Method

[image]

Grasshopper SDK
GH_Point..::..ReferencesEdge Method
GH_Point Class See Also Send Feedback
Returns True if this point is based on an edge reference

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool ReferencesEdge()
Visual Basic
Public Function ReferencesEdge As Boolean

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


ReferenceSurface Method

[image]

Grasshopper SDK
GH_Point..::..ReferenceSurface Method
GH_Point Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public BrepFace ReferenceSurface()
Visual Basic
Public Function ReferenceSurface As BrepFace

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


ReferenceType Method

[image] [image]

Grasshopper SDK
GH_Point..::..ReferenceType Method
GH_Point Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReferenceType()()()() | Retrieve the reference type of this point object.
Public method | ReferenceType(GH_PointRefType) | Sets the type of the point reference data.

See Also

GH_Point Class
GH_Point Members
Grasshopper.Kernel.Types Namespace


ReferenceType Method

[image]

Grasshopper SDK
GH_Point..::..ReferenceType Method
GH_Point Class See Also Send Feedback
Retrieve the reference type of this point object.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PointRefType ReferenceType()
Visual Basic
Public Function ReferenceType As GH_PointRefType

Return Value

The reference type as specified by the Reference Data. If there is no reference data, either Unset or Coordinate is returned depending on whether m_Point is a null reference.

See Also

GH_Point Class
ReferenceType Overload
Grasshopper.Kernel.Types Namespace


ReferenceType Method (GH_PointRefType)

[image]

Grasshopper SDK
GH_Point..::..ReferenceType Method (GH_PointRefType)
GH_Point Class See Also Send Feedback
Sets the type of the point reference data.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ReferenceType(
    GH_PointRefType new_type
)
Visual Basic
Public Sub ReferenceType ( _
    new_type As GH_PointRefType _
)

Parameters

new_type
Type: Grasshopper.Kernel.Types..::..GH_PointRefType
The new type, if type = Coordinate or Unset, then the Reference data will be erased.

Remarks

If there is no reference data, this function will create a new instance.

See Also

GH_Point Class
ReferenceType Overload
Grasshopper.Kernel.Types Namespace


ScriptVariable Method

[image]

Grasshopper SDK
GH_Point..::..ScriptVariable Method
GH_Point Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Object ScriptVariable()
Visual Basic
Public Function ScriptVariable As Object

Implements

IGH_Goo..::..ScriptVariable()()()()

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


SetReferenceParams Method

[image]

Grasshopper SDK
GH_Point..::..SetReferenceParams Method
GH_Point Class See Also Send Feedback
Sets both param values of the point reference

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void SetReferenceParams(
    double u,
    double v
)
Visual Basic
Public Sub SetReferenceParams ( _
    u As Double, _
    v As Double _
)

Parameters

u
Type: System..::..Double
The new u parameter
v
Type: System..::..Double
The new v parameter

Remarks

If there is no reference data, this function will create a new instance.

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


ShowReferenceDialog Method

[image] [image]

Grasshopper SDK
GH_Point..::..ShowReferenceDialog Method
GH_Point Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ShowReferenceDialog()()()() |
Public method | ShowReferenceDialog(IWin32Window) |

See Also

GH_Point Class
GH_Point Members
Grasshopper.Kernel.Types Namespace


ShowReferenceDialog Method

[image]

Grasshopper SDK
GH_Point..::..ShowReferenceDialog Method
GH_Point Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public DialogResult ShowReferenceDialog()
Visual Basic
Public Function ShowReferenceDialog As DialogResult

See Also

GH_Point Class
ShowReferenceDialog Overload
Grasshopper.Kernel.Types Namespace


ShowReferenceDialog Method (IWin32Window)

[image]

Grasshopper SDK
GH_Point..::..ShowReferenceDialog Method (IWin32Window)
GH_Point Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public DialogResult ShowReferenceDialog(
    IWin32Window owner
)
Visual Basic
Public Function ShowReferenceDialog ( _
    owner As IWin32Window _
) As DialogResult

Parameters

owner
Type: System.Windows.Forms..::..IWin32Window

See Also

GH_Point Class
ShowReferenceDialog Overload
Grasshopper.Kernel.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_Point..::..ToString Method
GH_Point Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Implements

IGH_Goo..::..ToString()()()()

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


Transform Method

[image]

Grasshopper SDK
GH_Point..::..Transform Method
GH_Point Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IGH_GeometricGoo Transform(
    Transform xform
)
Visual Basic
Public Function Transform ( _
    xform As Transform _
) As IGH_GeometricGoo

Parameters

xform
Type: Transform

Implements

IGH_GeometricGoo..::..Transform(Transform)

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


Write Method

[image]

Grasshopper SDK
GH_Point..::..Write Method
GH_Point Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Write(
    GH_IWriter writer
)
Visual Basic
Public Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

Implements

GH_ISerializable..::..Write(GH_IWriter)

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


GH_Point Properties

[image] [image]

Grasshopper SDK
GH_Point Properties
GH_Point Class See Also Send Feedback

The GH_Point type exposes the following members.

Properties

 | Name | Description
Public property | Boundingbox |
Public property | ClippingBox |
Public property | IsGeometryLoaded |
Public property | IsReferencedGeometry |
Public property | IsValid |
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.
Public property | ReferenceData | Gets or sets the reference data of this point geometry.
Public property | ReferenceID |
Public property | TypeDescription |
Public property | TypeName |
Public property | Value |

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


Boundingbox Property

[image]

Grasshopper SDK
GH_Point..::..Boundingbox Property
GH_Point Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public BoundingBox Boundingbox { get; }
Visual Basic
Public ReadOnly Property Boundingbox As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Point.Boundingbox"]

Implements

IGH_GeometricGoo..::..Boundingbox

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


ClippingBox Property

[image]

Grasshopper SDK
GH_Point..::..ClippingBox Property
GH_Point Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public BoundingBox ClippingBox { get; }
Visual Basic
Public ReadOnly Property ClippingBox As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Point.ClippingBox"]

Implements

IGH_PreviewData..::..ClippingBox

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


IsGeometryLoaded Property

[image]

Grasshopper SDK
GH_Point..::..IsGeometryLoaded Property
GH_Point Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsGeometryLoaded { get; }
Visual Basic
Public ReadOnly Property IsGeometryLoaded As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Point.IsGeometryLoaded"]

Implements

IGH_GeometricGoo..::..IsGeometryLoaded

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


IsReferencedGeometry Property

[image]

Grasshopper SDK
GH_Point..::..IsReferencedGeometry Property
GH_Point Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsReferencedGeometry { get; }
Visual Basic
Public ReadOnly Property IsReferencedGeometry As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Point.IsReferencedGeometry"]

Implements

IGH_GeometricGoo..::..IsReferencedGeometry

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


IsValid Property

[image]

Grasshopper SDK
GH_Point..::..IsValid Property
GH_Point Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsValid { get; }
Visual Basic
Public ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Point.IsValid"]

Implements

IGH_Goo..::..IsValid

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


IsValidWhyNot Property

[image]

Grasshopper SDK
GH_Point..::..IsValidWhyNot Property
GH_Point Class See Also Send Feedback
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string IsValidWhyNot { get; }
Visual Basic
Public ReadOnly Property IsValidWhyNot As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Point.IsValidWhyNot"]

Implements

IGH_Goo..::..IsValidWhyNot

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


ReferenceData Property

[image]

Grasshopper SDK
GH_Point..::..ReferenceData Property
GH_Point Class See Also Send Feedback
Gets or sets the reference data of this point geometry.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PointRefData ReferenceData { get; set; }
Visual Basic
Public Property ReferenceData As GH_PointRefData
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Point.ReferenceData"]

Remarks

Reference data can be Null

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


ReferenceID Property

[image]

Grasshopper SDK
GH_Point..::..ReferenceID Property
GH_Point Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid ReferenceID { get; set; }
Visual Basic
Public Property ReferenceID As Guid
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Point.ReferenceID"]

Implements

IGH_GeometricGoo..::..ReferenceID

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


TypeDescription Property

[image]

Grasshopper SDK
GH_Point..::..TypeDescription Property
GH_Point Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string TypeDescription { get; }
Visual Basic
Public ReadOnly Property TypeDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Point.TypeDescription"]

Implements

IGH_Goo..::..TypeDescription

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


TypeName Property

[image]

Grasshopper SDK
GH_Point..::..TypeName Property
GH_Point Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string TypeName { get; }
Visual Basic
Public ReadOnly Property TypeName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Point.TypeName"]

Implements

IGH_Goo..::..TypeName

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


Value Property

[image]

Grasshopper SDK
GH_Point..::..Value Property
GH_Point Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Point3d Value { get; set; }
Visual Basic
Public Property Value As Point3d
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Point.Value"]

See Also

GH_Point Class
Grasshopper.Kernel.Types Namespace


GH_Point.GH_PointProxy Class

[image]

Grasshopper SDK
GH_Point..::..GH_PointProxy Class
GH_Point Class Members See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_PointProxy : GH_GooProxy<GH_Point>
Visual Basic
Public Class GH_PointProxy _
    Inherits GH_GooProxy(Of GH_Point)

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_GooProxy <(Of <(<' GH_Point >)>)>
Grasshopper.Kernel.Types..::..GH_Point..::..GH_PointProxy

See Also

GH_Point..::..GH_PointProxy Members
Grasshopper.Kernel.Types Namespace


GH_Point.GH_PointProxy Members

[image] [image]

Grasshopper SDK
GH_Point..::..GH_PointProxy Members
GH_Point..::..GH_PointProxy Class Constructors Methods Properties See Also Send Feedback

The GH_Point..::..GH_PointProxy type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Point..::..GH_PointProxy | Initializes a new instance of the GH_Point..::..GH_PointProxy class

Methods

 | Name | Description
Public method | Construct | (Overrides GH_GooProxy<(Of <(<'T>)>)>..::..Construct()()()().)
Public method | FormatInstance | Returns a String description of the current value. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FromString | If IsParsable(), then attempts to convert the string to a generic type value (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | MutateString | Munge a string to remove obvious errors on account of the user. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | NumberToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | SrfRefChanged |
Protected method | StringToNumber | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | ToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Distance |
Public property | IsParsable | Gets a value indicating whether or not the type can be instantiated from a String. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected property | Owner | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | ProxyOwner | Gets the piece of Grasshopper data that spawned this proxy. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Referenced |
Public property | ReferenceID |
Public property | ReferenceType |
Public property | TParameterRatio |
Public property | TypeDescription | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeName | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | UserString | Gets or sets the user-defined string that describes this proxy. This only really makes sense if the Proxy is Parsable. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | UVParameterRatio |
Public property | Valid | Gets a value indicating whether this proxy represents valid data. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | X |
Public property | Y |
Public property | Z |

See Also

GH_Point..::..GH_PointProxy Class
Grasshopper.Kernel.Types Namespace


GH_Point.GH_PointProxy Constructor

[image]

Grasshopper SDK
GH_Point..::..GH_PointProxy Constructor
GH_Point..::..GH_PointProxy Class See Also Send Feedback
Initializes a new instance of the GH_Point..::..GH_PointProxy class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PointProxy(
    GH_Point Value
)
Visual Basic
Public Sub New ( _
    Value As GH_Point _
)

Parameters

Value
Type: Grasshopper.Kernel.Types..::..GH_Point

See Also

GH_Point..::..GH_PointProxy Class
Grasshopper.Kernel.Types Namespace


GH_Point.GH_PointProxy Methods

[image] [image]

Grasshopper SDK
GH_Point..::..GH_PointProxy Methods
GH_Point..::..GH_PointProxy Class See Also Send Feedback

The GH_Point..::..GH_PointProxy type exposes the following members.

Methods

 | Name | Description
Public method | Construct | (Overrides GH_GooProxy<(Of <(<'T>)>)>..::..Construct()()()().)
Public method | FormatInstance | Returns a String description of the current value. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FromString | If IsParsable(), then attempts to convert the string to a generic type value (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | MutateString | Munge a string to remove obvious errors on account of the user. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | NumberToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | SrfRefChanged |
Protected method | StringToNumber | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | ToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

See Also

GH_Point..::..GH_PointProxy Class
Grasshopper.Kernel.Types Namespace


Construct Method

[image]

Grasshopper SDK
GH_Point..::..GH_PointProxy..::..Construct Method
GH_Point..::..GH_PointProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void Construct()
Visual Basic
Public Overrides Sub Construct

See Also

GH_Point..::..GH_PointProxy Class
Grasshopper.Kernel.Types Namespace


SrfRefChanged Method

[image]

Grasshopper SDK
GH_Point..::..GH_PointProxy..::..SrfRefChanged Method
GH_Point..::..GH_PointProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected void SrfRefChanged(
    GH_PointRefUV_Wrapper sender,
    GH_PointRefData ref
)
Visual Basic
Protected Sub SrfRefChanged ( _
    sender As GH_PointRefUV_Wrapper, _
    ref As GH_PointRefData _
)

Parameters

sender
Type: GH_PointRefUV_Wrapper
ref
Type: Grasshopper.Kernel.Types..::..GH_PointRefData

See Also

GH_Point..::..GH_PointProxy Class
Grasshopper.Kernel.Types Namespace


GH_Point.GH_PointProxy Properties

[image] [image]

Grasshopper SDK
GH_Point..::..GH_PointProxy Properties
GH_Point..::..GH_PointProxy Class See Also Send Feedback

The GH_Point..::..GH_PointProxy type exposes the following members.

Properties

 | Name | Description
Public property | Distance |
Public property | IsParsable | Gets a value indicating whether or not the type can be instantiated from a String. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected property | Owner | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | ProxyOwner | Gets the piece of Grasshopper data that spawned this proxy. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Referenced |
Public property | ReferenceID |
Public property | ReferenceType |
Public property | TParameterRatio |
Public property | TypeDescription | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeName | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | UserString | Gets or sets the user-defined string that describes this proxy. This only really makes sense if the Proxy is Parsable. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | UVParameterRatio |
Public property | Valid | Gets a value indicating whether this proxy represents valid data. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | X |
Public property | Y |
Public property | Z |

See Also

GH_Point..::..GH_PointProxy Class
Grasshopper.Kernel.Types Namespace


Distance Property

[image]

Grasshopper SDK
GH_Point..::..GH_PointProxy..::..Distance Property
GH_Point..::..GH_PointProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Distance { get; set; }
Visual Basic
Public Property Distance As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Point.GH_PointProxy.Distance"]

See Also

GH_Point..::..GH_PointProxy Class
Grasshopper.Kernel.Types Namespace


Referenced Property

[image]

Grasshopper SDK
GH_Point..::..GH_PointProxy..::..Referenced Property
GH_Point..::..GH_PointProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Referenced { get; }
Visual Basic
Public ReadOnly Property Referenced As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Point.GH_PointProxy.Referenced"]

See Also

GH_Point..::..GH_PointProxy Class
Grasshopper.Kernel.Types Namespace


ReferenceID Property

[image]

Grasshopper SDK
GH_Point..::..GH_PointProxy..::..ReferenceID Property
GH_Point..::..GH_PointProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string ReferenceID { get; }
Visual Basic
Public ReadOnly Property ReferenceID As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Point.GH_PointProxy.ReferenceID"]

See Also

GH_Point..::..GH_PointProxy Class
Grasshopper.Kernel.Types Namespace


ReferenceType Property

[image]

Grasshopper SDK
GH_Point..::..GH_PointProxy..::..ReferenceType Property
GH_Point..::..GH_PointProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string ReferenceType { get; }
Visual Basic
Public ReadOnly Property ReferenceType As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Point.GH_PointProxy.ReferenceType"]

See Also

GH_Point..::..GH_PointProxy Class
Grasshopper.Kernel.Types Namespace


TParameterRatio Property

[image]

Grasshopper SDK
GH_Point..::..GH_PointProxy..::..TParameterRatio Property
GH_Point..::..GH_PointProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string TParameterRatio { get; set; }
Visual Basic
Public Property TParameterRatio As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Point.GH_PointProxy.TParameterRatio"]

See Also

GH_Point..::..GH_PointProxy Class
Grasshopper.Kernel.Types Namespace


UVParameterRatio Property

[image]

Grasshopper SDK
GH_Point..::..GH_PointProxy..::..UVParameterRatio Property
GH_Point..::..GH_PointProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PointRefUV_Wrapper UVParameterRatio { get; }
Visual Basic
Public ReadOnly Property UVParameterRatio As GH_PointRefUV_Wrapper
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Point.GH_PointProxy.UVParameterRatio"]

See Also

GH_Point..::..GH_PointProxy Class
Grasshopper.Kernel.Types Namespace


X Property

[image]

Grasshopper SDK
GH_Point..::..GH_PointProxy..::..X Property
GH_Point..::..GH_PointProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string X { get; set; }
Visual Basic
Public Property X As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Point.GH_PointProxy.X"]

See Also

GH_Point..::..GH_PointProxy Class
Grasshopper.Kernel.Types Namespace


Y Property

[image]

Grasshopper SDK
GH_Point..::..GH_PointProxy..::..Y Property
GH_Point..::..GH_PointProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Y { get; set; }
Visual Basic
Public Property Y As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Point.GH_PointProxy.Y"]

See Also

GH_Point..::..GH_PointProxy Class
Grasshopper.Kernel.Types Namespace


Z Property

[image]

Grasshopper SDK
GH_Point..::..GH_PointProxy..::..Z Property
GH_Point..::..GH_PointProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Z { get; set; }
Visual Basic
Public Property Z As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Point.GH_PointProxy.Z"]

See Also

GH_Point..::..GH_PointProxy Class
Grasshopper.Kernel.Types Namespace


GH_PointCharge Class

[image]

Grasshopper SDK
GH_PointCharge Class
Members See Also Send Feedback
Point charge implementation for IGH_Fields.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_PointCharge : GH_FieldElement
Visual Basic
Public Class GH_PointCharge _
    Inherits GH_FieldElement

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_FieldElement
Grasshopper.Kernel.Types..::..GH_PointCharge

See Also

GH_PointCharge Members
Grasshopper.Kernel.Types Namespace


GH_PointCharge Members

[image] [image]

Grasshopper SDK
GH_PointCharge Members
GH_PointCharge Class Constructors Methods Properties See Also Send Feedback

The GH_PointCharge type exposes the following members.

Constructors

 | Name | Description
Public method | GH_PointCharge | Initializes a new instance of the GH_PointCharge class

Methods

 | Name | Description
Public method | DrawViewportMeshes | (Inherited from GH_FieldElement.)
Public method | DrawViewportWires | (Overrides GH_FieldElement..::..DrawViewportWires(GH_PreviewWireArgs).)
Public method | Duplicate | (Overrides GH_FieldElement..::..Duplicate()()()().)
Public method | Force | (Overrides GH_FieldElement..::..Force(Point3d).)
Public method | IsCoincident | (Overrides GH_FieldElement..::..IsCoincident(Point3d, Double).)
Public method | Read | (Overrides GH_FieldElement..::..Read(GH_IReader).)
Public method | Write | (Overrides GH_FieldElement..::..Write(GH_IWriter).)

Properties

 | Name | Description
Public property | BoundingBox | (Overrides GH_FieldElement..::..BoundingBox.)
Public property | Charge |
Public property | ClippingBox | (Inherited from GH_FieldElement.)
Public property | Decay |
Public property | ElementGuid | (Overrides GH_FieldElement..::..ElementGuid.)
Public property | IsLimited | (Inherited from GH_FieldElement.)
Public property | Limits | (Inherited from GH_FieldElement.)
Public property | Location |

See Also

GH_PointCharge Class
Grasshopper.Kernel.Types Namespace


GH_PointCharge Constructor

[image]

Grasshopper SDK
GH_PointCharge Constructor
GH_PointCharge Class See Also Send Feedback
Initializes a new instance of the GH_PointCharge class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PointCharge()
Visual Basic
Public Sub New

See Also

GH_PointCharge Class
Grasshopper.Kernel.Types Namespace


GH_PointCharge Methods

[image] [image]

Grasshopper SDK
GH_PointCharge Methods
GH_PointCharge Class See Also Send Feedback

The GH_PointCharge type exposes the following members.

Methods

 | Name | Description
Public method | DrawViewportMeshes | (Inherited from GH_FieldElement.)
Public method | DrawViewportWires | (Overrides GH_FieldElement..::..DrawViewportWires(GH_PreviewWireArgs).)
Public method | Duplicate | (Overrides GH_FieldElement..::..Duplicate()()()().)
Public method | Force | (Overrides GH_FieldElement..::..Force(Point3d).)
Public method | IsCoincident | (Overrides GH_FieldElement..::..IsCoincident(Point3d, Double).)
Public method | Read | (Overrides GH_FieldElement..::..Read(GH_IReader).)
Public method | Write | (Overrides GH_FieldElement..::..Write(GH_IWriter).)

See Also

GH_PointCharge Class
Grasshopper.Kernel.Types Namespace


DrawViewportWires Method

[image]

Grasshopper SDK
GH_PointCharge..::..DrawViewportWires Method
GH_PointCharge Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void DrawViewportWires(
    GH_PreviewWireArgs args
)
Visual Basic
Public Overrides Sub DrawViewportWires ( _
    args As GH_PreviewWireArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..GH_PreviewWireArgs

See Also

GH_PointCharge Class
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_PointCharge..::..Duplicate Method
GH_PointCharge Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_FieldElement Duplicate()
Visual Basic
Public Overrides Function Duplicate As IGH_FieldElement

See Also

GH_PointCharge Class
Grasshopper.Kernel.Types Namespace


Force Method

[image]

Grasshopper SDK
GH_PointCharge..::..Force Method
GH_PointCharge Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override Vector3d Force(
    Point3d location
)
Visual Basic
Public Overrides Function Force ( _
    location As Point3d _
) As Vector3d

Parameters

location
Type: Point3d

See Also

GH_PointCharge Class
Grasshopper.Kernel.Types Namespace


IsCoincident Method

[image]

Grasshopper SDK
GH_PointCharge..::..IsCoincident Method
GH_PointCharge Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool IsCoincident(
    Point3d point,
    double tolerance
)
Visual Basic
Public Overrides Function IsCoincident ( _
    point As Point3d, _
    tolerance As Double _
) As Boolean

Parameters

point
Type: Point3d
tolerance
Type: System..::..Double

See Also

GH_PointCharge Class
Grasshopper.Kernel.Types Namespace


Read Method

[image]

Grasshopper SDK
GH_PointCharge..::..Read Method
GH_PointCharge Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

See Also

GH_PointCharge Class
Grasshopper.Kernel.Types Namespace


Write Method

[image]

Grasshopper SDK
GH_PointCharge..::..Write Method
GH_PointCharge Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overrides Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

See Also

GH_PointCharge Class
Grasshopper.Kernel.Types Namespace


GH_PointCharge Properties

[image] [image]

Grasshopper SDK
GH_PointCharge Properties
GH_PointCharge Class See Also Send Feedback

The GH_PointCharge type exposes the following members.

Properties

 | Name | Description
Public property | BoundingBox | (Overrides GH_FieldElement..::..BoundingBox.)
Public property | Charge |
Public property | ClippingBox | (Inherited from GH_FieldElement.)
Public property | Decay |
Public property | ElementGuid | (Overrides GH_FieldElement..::..ElementGuid.)
Public property | IsLimited | (Inherited from GH_FieldElement.)
Public property | Limits | (Inherited from GH_FieldElement.)
Public property | Location |

See Also

GH_PointCharge Class
Grasshopper.Kernel.Types Namespace


BoundingBox Property

[image]

Grasshopper SDK
GH_PointCharge..::..BoundingBox Property
GH_PointCharge Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override BoundingBox BoundingBox { get; }
Visual Basic
Public Overrides ReadOnly Property BoundingBox As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_PointCharge.BoundingBox"]

See Also

GH_PointCharge Class
Grasshopper.Kernel.Types Namespace


Charge Property

[image]

Grasshopper SDK
GH_PointCharge..::..Charge Property
GH_PointCharge Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double Charge { get; set; }
Visual Basic
Public Property Charge As Double
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_PointCharge.Charge"]

See Also

GH_PointCharge Class
Grasshopper.Kernel.Types Namespace


Decay Property

[image]

Grasshopper SDK
GH_PointCharge..::..Decay Property
GH_PointCharge Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double Decay { get; set; }
Visual Basic
Public Property Decay As Double
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_PointCharge.Decay"]

See Also

GH_PointCharge Class
Grasshopper.Kernel.Types Namespace


ElementGuid Property

[image]

Grasshopper SDK
GH_PointCharge..::..ElementGuid Property
GH_PointCharge Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override Guid ElementGuid { get; }
Visual Basic
Public Overrides ReadOnly Property ElementGuid As Guid
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_PointCharge.ElementGuid"]

See Also

GH_PointCharge Class
Grasshopper.Kernel.Types Namespace


Location Property

[image]

Grasshopper SDK
GH_PointCharge..::..Location Property
GH_PointCharge Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Point3d Location { get; set; }
Visual Basic
Public Property Location As Point3d
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_PointCharge.Location"]

See Also

GH_PointCharge Class
Grasshopper.Kernel.Types Namespace


GH_PointRefData Class

[image]

Grasshopper SDK
GH_PointRefData Class
Members See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_PointRefData
Visual Basic
Public Class GH_PointRefData

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_PointRefData

See Also

GH_PointRefData Members
Grasshopper.Kernel.Types Namespace


GH_PointRefData Members

[image] [image]

Grasshopper SDK
GH_PointRefData Members
GH_PointRefData Class Constructors Methods Fields See Also Send Feedback

The GH_PointRefData type exposes the following members.

Constructors

 | Name | Description
Public method | GH_PointRefData()()()() | Initializes a new instance of the GH_PointRefData class
Public method | GH_PointRefData(GH_PointRefData) | Initializes a new instance of the GH_PointRefData class

Methods

 | Name | Description
Public method | EvCurve | Evaluate this reference structure when applied to a curve
Public method | EvCurveParam | Evaluate this reference structure when applied to a curve
Public method | EvSurface | Evaluate this reference structure when applied to the surface
Protected method | SetCurveDistFromEndParam |
Protected method | SetCurveDistFromStartParam |
Public method | SetCurveParam | Set the curve reference parameter based on the value of m_RefType and the curve parameter
Protected method | SetCurveRatioParam |
Public method | SetSurfaceParam | Set the surface reference parameters

Fields

 | Name | Description
Public field | m_RefID |
Public field | m_RefIndex |
Public field | m_RefParam |
Public field | m_RefType |

See Also

GH_PointRefData Class
Grasshopper.Kernel.Types Namespace


GH_PointRefData Constructor

[image] [image]

Grasshopper SDK
GH_PointRefData Constructor
GH_PointRefData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_PointRefData()()()() | Initializes a new instance of the GH_PointRefData class
Public method | GH_PointRefData(GH_PointRefData) | Initializes a new instance of the GH_PointRefData class

See Also

GH_PointRefData Class
GH_PointRefData Members
Grasshopper.Kernel.Types Namespace


GH_PointRefData Constructor

[image]

Grasshopper SDK
GH_PointRefData Constructor
GH_PointRefData Class See Also Send Feedback
Initializes a new instance of the GH_PointRefData class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PointRefData()
Visual Basic
Public Sub New

See Also

GH_PointRefData Class
GH_PointRefData Overload
Grasshopper.Kernel.Types Namespace


GH_PointRefData Constructor (GH_PointRefData)

[image]

Grasshopper SDK
GH_PointRefData Constructor (GH_PointRefData)
GH_PointRefData Class See Also Send Feedback
Initializes a new instance of the GH_PointRefData class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PointRefData(
    GH_PointRefData iOther
)
Visual Basic
Public Sub New ( _
    iOther As GH_PointRefData _
)

Parameters

iOther
Type: Grasshopper.Kernel.Types..::..GH_PointRefData

See Also

GH_PointRefData Class
GH_PointRefData Overload
Grasshopper.Kernel.Types Namespace


GH_PointRefData Fields

[image] [image]

Grasshopper SDK
GH_PointRefData Fields
GH_PointRefData Class See Also Send Feedback

The GH_PointRefData type exposes the following members.

Fields

 | Name | Description
Public field | m_RefID |
Public field | m_RefIndex |
Public field | m_RefParam |
Public field | m_RefType |

See Also

GH_PointRefData Class
Grasshopper.Kernel.Types Namespace


m_RefID Field

[image]

Grasshopper SDK
GH_PointRefData..::..m_RefID Field
GH_PointRefData Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid m_RefID
Visual Basic
Public m_RefID As Guid

See Also

GH_PointRefData Class
Grasshopper.Kernel.Types Namespace


m_RefIndex Field

[image]

Grasshopper SDK
GH_PointRefData..::..m_RefIndex Field
GH_PointRefData Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int m_RefIndex
Visual Basic
Public m_RefIndex As Integer

See Also

GH_PointRefData Class
Grasshopper.Kernel.Types Namespace


m_RefParam Field

[image]

Grasshopper SDK
GH_PointRefData..::..m_RefParam Field
GH_PointRefData Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double[] m_RefParam
Visual Basic
Public m_RefParam As Double()

See Also

GH_PointRefData Class
Grasshopper.Kernel.Types Namespace


m_RefType Field

[image]

Grasshopper SDK
GH_PointRefData..::..m_RefType Field
GH_PointRefData Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PointRefType m_RefType
Visual Basic
Public m_RefType As GH_PointRefType

See Also

GH_PointRefData Class
Grasshopper.Kernel.Types Namespace


GH_PointRefData Methods

[image] [image]

Grasshopper SDK
GH_PointRefData Methods
GH_PointRefData Class See Also Send Feedback

The GH_PointRefData type exposes the following members.

Methods

 | Name | Description
Public method | EvCurve | Evaluate this reference structure when applied to a curve
Public method | EvCurveParam | Evaluate this reference structure when applied to a curve
Public method | EvSurface | Evaluate this reference structure when applied to the surface
Protected method | SetCurveDistFromEndParam |
Protected method | SetCurveDistFromStartParam |
Public method | SetCurveParam | Set the curve reference parameter based on the value of m_RefType and the curve parameter
Protected method | SetCurveRatioParam |
Public method | SetSurfaceParam | Set the surface reference parameters

See Also

GH_PointRefData Class
Grasshopper.Kernel.Types Namespace


EvCurve Method

[image]

Grasshopper SDK
GH_PointRefData..::..EvCurve Method
GH_PointRefData Class See Also Send Feedback
Evaluate this reference structure when applied to a curve

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Point3d EvCurve(
    Curve c
)
Visual Basic
Public Function EvCurve ( _
    c As Curve _
) As Point3d

Parameters

c
Type: Curve
The curve to act on

Return Value

The point on the curve if successful, or Nothing

Remarks

Evaluation depends on the value of m_RefType

See Also

GH_PointRefData Class
Grasshopper.Kernel.Types Namespace


EvCurveParam Method

[image]

Grasshopper SDK
GH_PointRefData..::..EvCurveParam Method
GH_PointRefData Class See Also Send Feedback
Evaluate this reference structure when applied to a curve

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double EvCurveParam(
    Curve c
)
Visual Basic
Public Function EvCurveParam ( _
    c As Curve _
) As Double

Parameters

c
Type: Curve
The curve to act on

Return Value

The parameter on the curve that corresponds to this reference, or NaN

Remarks

Evaluation depends on the value of m_RefType

See Also

GH_PointRefData Class
Grasshopper.Kernel.Types Namespace


EvSurface Method

[image]

Grasshopper SDK
GH_PointRefData..::..EvSurface Method
GH_PointRefData Class See Also Send Feedback
Evaluate this reference structure when applied to the surface

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Point3d EvSurface(
    Surface s
)
Visual Basic
Public Function EvSurface ( _
    s As Surface _
) As Point3d

Parameters

s
Type: Surface
The surface to act on.

Return Value

A point if successful, or Nothing

Remarks

Surface is evaluated at normalized {uv} parameters

See Also

GH_PointRefData Class
Grasshopper.Kernel.Types Namespace


SetCurveDistFromEndParam Method

[image]

Grasshopper SDK
GH_PointRefData..::..SetCurveDistFromEndParam Method
GH_PointRefData Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected bool SetCurveDistFromEndParam(
    Curve c,
    double t
)
Visual Basic
Protected Function SetCurveDistFromEndParam ( _
    c As Curve, _
    t As Double _
) As Boolean

Parameters

c
Type: Curve
t
Type: System..::..Double

See Also

GH_PointRefData Class
Grasshopper.Kernel.Types Namespace


SetCurveDistFromStartParam Method

[image]

Grasshopper SDK
GH_PointRefData..::..SetCurveDistFromStartParam Method
GH_PointRefData Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected bool SetCurveDistFromStartParam(
    Curve c,
    double t
)
Visual Basic
Protected Function SetCurveDistFromStartParam ( _
    c As Curve, _
    t As Double _
) As Boolean

Parameters

c
Type: Curve
t
Type: System..::..Double

See Also

GH_PointRefData Class
Grasshopper.Kernel.Types Namespace


SetCurveParam Method

[image]

Grasshopper SDK
GH_PointRefData..::..SetCurveParam Method
GH_PointRefData Class See Also Send Feedback
Set the curve reference parameter based on the value of m_RefType and the curve parameter

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool SetCurveParam(
    Curve c,
    double t
)
Visual Basic
Public Function SetCurveParam ( _
    c As Curve, _
    t As Double _
) As Boolean

Parameters

c
Type: Curve
The curve to act on
t
Type: System..::..Double
The parameter on the curve domain which is to be translated

Return Value

True on success

See Also

GH_PointRefData Class
Grasshopper.Kernel.Types Namespace


SetCurveRatioParam Method

[image]

Grasshopper SDK
GH_PointRefData..::..SetCurveRatioParam Method
GH_PointRefData Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected bool SetCurveRatioParam(
    Curve c,
    double t
)
Visual Basic
Protected Function SetCurveRatioParam ( _
    c As Curve, _
    t As Double _
) As Boolean

Parameters

c
Type: Curve
t
Type: System..::..Double

See Also

GH_PointRefData Class
Grasshopper.Kernel.Types Namespace


SetSurfaceParam Method

[image]

Grasshopper SDK
GH_PointRefData..::..SetSurfaceParam Method
GH_PointRefData Class See Also Send Feedback
Set the surface reference parameters

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool SetSurfaceParam(
    Surface srf,
    double u,
    double v
)
Visual Basic
Public Function SetSurfaceParam ( _
    srf As Surface, _
    u As Double, _
    v As Double _
) As Boolean

Parameters

srf
Type: Surface
The surface to act on
u
Type: System..::..Double
The parameter on the surface u domain
v
Type: System..::..Double
The parameter on the surface v domain

Return Value

True on success

See Also

GH_PointRefData Class
Grasshopper.Kernel.Types Namespace


GH_PointRefType Enumeration

[image]

Grasshopper SDK
GH_PointRefType Enumeration
See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_PointRefType
Visual Basic
Public Enumeration GH_PointRefType

Members

Member name | Value | Description
coordinate | 1 |
point_object | 2 |
curve_ratio | 10 |
curve_dist_start | 11 |
curve_dist_end | 12 |
srf_param | 20 |

See Also

Grasshopper.Kernel.Types Namespace


GH_PointUtil Class

[image]

Grasshopper SDK
GH_PointUtil Class
Members See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class GH_PointUtil
Visual Basic
Public NotInheritable Class GH_PointUtil

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_PointUtil

See Also

GH_PointUtil Members
Grasshopper.Kernel.Types Namespace


GH_PointUtil Members

[image] [image]

Grasshopper SDK
GH_PointUtil Members
GH_PointUtil Class Methods See Also Send Feedback

The GH_PointUtil type exposes the following members.

Methods

Name | Description
FitPlaneThroughPoints | Fit a least-squares plane through a collection of points.
ProjectPointsToPlane | Project a list of points onto the plane. The result will be points in plane-uv coordinates.
PullPointsToPlane | Pull a list of points onto the plane. The result will be points in 3D world coordinates which are coincident with the given plane.
RemapPointsToPlane | Remap a list of points onto the plane. This operation equals a ChangeBasisXForm for each point.

See Also

GH_PointUtil Class
Grasshopper.Kernel.Types Namespace


GH_PointUtil Methods

[image] [image]

Grasshopper SDK
GH_PointUtil Methods
GH_PointUtil Class See Also Send Feedback

The GH_PointUtil type exposes the following members.

Methods

Name | Description
FitPlaneThroughPoints | Fit a least-squares plane through a collection of points.
ProjectPointsToPlane | Project a list of points onto the plane. The result will be points in plane-uv coordinates.
PullPointsToPlane | Pull a list of points onto the plane. The result will be points in 3D world coordinates which are coincident with the given plane.
RemapPointsToPlane | Remap a list of points onto the plane. This operation equals a ChangeBasisXForm for each point.

See Also

GH_PointUtil Class
Grasshopper.Kernel.Types Namespace


FitPlaneThroughPoints Method

[image]

Grasshopper SDK
GH_PointUtil..::..FitPlaneThroughPoints Method
GH_PointUtil Class See Also Send Feedback
Fit a least-squares plane through a collection of points.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Plane FitPlaneThroughPoints(
    IEnumerable<GH_Point> pts
)
Visual Basic
Public Shared Function FitPlaneThroughPoints ( _
    pts As IEnumerable(Of GH_Point) _
) As Plane

Parameters

pts
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' GH_Point >)>)>
Points to fit, may contain nulls.

Return Value

Best fit plane or null if insufficient points were supplied.

See Also

GH_PointUtil Class
Grasshopper.Kernel.Types Namespace


ProjectPointsToPlane Method

[image]

Grasshopper SDK
GH_PointUtil..::..ProjectPointsToPlane Method
GH_PointUtil Class See Also Send Feedback
Project a list of points onto the plane. The result will be points in plane-uv coordinates.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static List<GH_Point> ProjectPointsToPlane(
    IEnumerable<GH_Point> pts,
    Plane plane,
    bool include_nulls
)
Visual Basic
Public Shared Function ProjectPointsToPlane ( _
    pts As IEnumerable(Of GH_Point), _
    plane As Plane, _
    include_nulls As Boolean _
) As List(Of GH_Point)

Parameters

pts
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' GH_Point >)>)>
Points to project.
plane
Type: Plane
Plane to project onto.
include_nulls
Type: System..::..Boolean
If True, nulls in the pts list are maintained.

See Also

GH_PointUtil Class
Grasshopper.Kernel.Types Namespace


PullPointsToPlane Method

[image]

Grasshopper SDK
GH_PointUtil..::..PullPointsToPlane Method
GH_PointUtil Class See Also Send Feedback
Pull a list of points onto the plane. The result will be points in 3D world coordinates which are coincident with the given plane.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static List<GH_Point> PullPointsToPlane(
    IEnumerable<GH_Point> pts,
    Plane plane,
    bool include_nulls
)
Visual Basic
Public Shared Function PullPointsToPlane ( _
    pts As IEnumerable(Of GH_Point), _
    plane As Plane, _
    include_nulls As Boolean _
) As List(Of GH_Point)

Parameters

pts
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' GH_Point >)>)>
Points to pull.
plane
Type: Plane
Plane to pull onto.
include_nulls
Type: System..::..Boolean
If True, nulls in the pts list are maintained.

See Also

GH_PointUtil Class
Grasshopper.Kernel.Types Namespace


RemapPointsToPlane Method

[image]

Grasshopper SDK
GH_PointUtil..::..RemapPointsToPlane Method
GH_PointUtil Class See Also Send Feedback
Remap a list of points onto the plane. This operation equals a ChangeBasisXForm for each point.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static List<GH_Point> RemapPointsToPlane(
    IEnumerable<GH_Point> pts,
    Plane plane,
    bool include_nulls
)
Visual Basic
Public Shared Function RemapPointsToPlane ( _
    pts As IEnumerable(Of GH_Point), _
    plane As Plane, _
    include_nulls As Boolean _
) As List(Of GH_Point)

Parameters

pts
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' GH_Point >)>)>
Points to remap.
plane
Type: Plane
Plane to remap with.
include_nulls
Type: System..::..Boolean
If True, nulls in the pts list are maintained.

See Also

GH_PointUtil Class
Grasshopper.Kernel.Types Namespace


GH_Rectangle Class

[image]

Grasshopper SDK
GH_Rectangle Class
Members See Also Send Feedback
Represents a 3D rectangle. GH_Rectangle re-implements the RhinoCommon Rectangle3d.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Rectangle : GH_GeometricGoo<Rectangle3d>,
    IGH_BakeAwareData, IGH_PreviewData
Visual Basic
Public Class GH_Rectangle _
    Inherits GH_GeometricGoo(Of Rectangle3d) _
    Implements IGH_BakeAwareData, IGH_PreviewData

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_Goo <(Of <(<'Rectangle3d>)>)>
Grasshopper.Kernel.Types..::..GH_GeometricGoo <(Of <(<'Rectangle3d>)>)>
Grasshopper.Kernel.Types..::..GH_Rectangle

See Also

GH_Rectangle Members
Grasshopper.Kernel.Types Namespace


GH_Rectangle Members

[image] [image]

Grasshopper SDK
GH_Rectangle Members
GH_Rectangle Class Constructors Methods Fields Properties See Also Send Feedback

The GH_Rectangle type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Rectangle()()()() | Default constructor
Public method | GH_Rectangle(Rectangle3d) | Create a duplicate of another rectangle.
Public method | GH_Rectangle(GH_Rectangle) | Create a duplicate of another circle.

Methods

 | Name | Description
Public method | BakeGeometry |
Public method | CastFrom | Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type T. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | ClearCaches | Clears all caches. Typically if the geometry is referenced, this will erase the local copy. If your T is a value-type, you must override this function and specifically unset the local value. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | DrawViewportMeshes |
Public method | DrawViewportWires |
Public method | Duplicate | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateGeometry | Create a duplicate of this rectangle. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..DuplicateGeometry()()()().)
Public method | DuplicateRectangle | Create a duplicate of this rectangle.
Public method | EmitProxy | Returns a proxy that represents this rectangle. Do not call this function unless you're (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | GetBoundingBox | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..GetBoundingBox(Transform).)
Public method | LoadGeometry()()()() | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | LoadGeometry(RhinoDoc) | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. The default is to always return True. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | Morph | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Morph(SpaceMorph).)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ToString | Format the circle using default grasshopper formatting logic. (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Transform | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Transform(Transform).)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Boundingbox | Gets the boundingbox for this geometry. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Boundingbox.)
Public property | ClippingBox |
Public property | IsGeometryLoaded | Gets a value indicating whether or not this geometry is currently loaded (assuming it is referenced). Not all IGH_GeometricGoo implementations support referenced geometry. The default is to always return True. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public property | IsReferencedGeometry | Gets a value indicating whether or not this geometry is referenced. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public property | IsValid | Gets the validity of this instance. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot.)
Public property | ReferenceID | Gets or sets the Guid of the object that is referenced. Not all IGH_GeometricGoo implementations support referenced geometry. The default implementation is to always return Guid.Empty. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the value of this type. Note that if the type has a ReferenceID this value might get destroyed in the future. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)

See Also

GH_Rectangle Class
Grasshopper.Kernel.Types Namespace


GH_Rectangle Constructor

[image] [image]

Grasshopper SDK
GH_Rectangle Constructor
GH_Rectangle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Rectangle()()()() | Default constructor
Public method | GH_Rectangle(Rectangle3d) | Create a duplicate of another rectangle.
Public method | GH_Rectangle(GH_Rectangle) | Create a duplicate of another circle.

See Also

GH_Rectangle Class
GH_Rectangle Members
Grasshopper.Kernel.Types Namespace


GH_Rectangle Constructor

[image]

Grasshopper SDK
GH_Rectangle Constructor
GH_Rectangle Class See Also Send Feedback
Default constructor

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Rectangle()
Visual Basic
Public Sub New

See Also

GH_Rectangle Class
GH_Rectangle Overload
Grasshopper.Kernel.Types Namespace


GH_Rectangle Constructor ()

[image]

Grasshopper SDK
GH_Rectangle Constructor ()
GH_Rectangle Class See Also Send Feedback
Create a duplicate of another rectangle.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Rectangle(
    Rectangle3d rec
)
Visual Basic
Public Sub New ( _
    rec As Rectangle3d _
)

Parameters

rec
Type: Rectangle3d
Rectangle to copy. If null, a default rectangle will be created.

See Also

GH_Rectangle Class
GH_Rectangle Overload
Grasshopper.Kernel.Types Namespace


GH_Rectangle Constructor (GH_Rectangle)

[image]

Grasshopper SDK
GH_Rectangle Constructor (GH_Rectangle)
GH_Rectangle Class See Also Send Feedback
Create a duplicate of another circle.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Rectangle(
    GH_Rectangle other
)
Visual Basic
Public Sub New ( _
    other As GH_Rectangle _
)

Parameters

other
Type: Grasshopper.Kernel.Types..::..GH_Rectangle
Circle to mimic.

See Also

GH_Rectangle Class
GH_Rectangle Overload
Grasshopper.Kernel.Types Namespace


GH_Rectangle Fields

[image] [image]

Grasshopper SDK
GH_Rectangle Fields
GH_Rectangle Class See Also Send Feedback

The GH_Rectangle type exposes the following members.

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Rectangle Class
Grasshopper.Kernel.Types Namespace


GH_Rectangle Methods

[image] [image]

Grasshopper SDK
GH_Rectangle Methods
GH_Rectangle Class See Also Send Feedback

The GH_Rectangle type exposes the following members.

Methods

 | Name | Description
Public method | BakeGeometry |
Public method | CastFrom | Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type T. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | ClearCaches | Clears all caches. Typically if the geometry is referenced, this will erase the local copy. If your T is a value-type, you must override this function and specifically unset the local value. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | DrawViewportMeshes |
Public method | DrawViewportWires |
Public method | Duplicate | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateGeometry | Create a duplicate of this rectangle. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..DuplicateGeometry()()()().)
Public method | DuplicateRectangle | Create a duplicate of this rectangle.
Public method | EmitProxy | Returns a proxy that represents this rectangle. Do not call this function unless you're (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | GetBoundingBox | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..GetBoundingBox(Transform).)
Public method | LoadGeometry()()()() | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | LoadGeometry(RhinoDoc) | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. The default is to always return True. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | Morph | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Morph(SpaceMorph).)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ToString | Format the circle using default grasshopper formatting logic. (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Transform | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Transform(Transform).)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

See Also

GH_Rectangle Class
Grasshopper.Kernel.Types Namespace


BakeGeometry Method

[image]

Grasshopper SDK
GH_Rectangle..::..BakeGeometry Method
GH_Rectangle Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool BakeGeometry(
    RhinoDoc doc,
    ObjectAttributes att,
    ref Guid obj_guid
)
Visual Basic
Public Function BakeGeometry ( _
    doc As RhinoDoc, _
    att As ObjectAttributes, _
    ByRef obj_guid As Guid _
) As Boolean

Parameters

doc
Type: RhinoDoc
att
Type: ObjectAttributes
obj_guid
Type: System..::..Guid %

Implements

IGH_BakeAwareData..::..BakeGeometry(RhinoDoc, ObjectAttributes, Guid%)

See Also

GH_Rectangle Class
Grasshopper.Kernel.Types Namespace


CastFrom Method

[image]

Grasshopper SDK
GH_Rectangle..::..CastFrom Method
GH_Rectangle Class See Also Send Feedback
Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastFrom(
    Object source
)
Visual Basic
Public Overrides Function CastFrom ( _
    source As Object _
) As Boolean

Parameters

source
Type: System..::..Object

See Also

GH_Rectangle Class
Grasshopper.Kernel.Types Namespace


CastTo Method

[image] [image]

Grasshopper SDK
GH_Rectangle..::..CastTo Method
GH_Rectangle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type T. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)

See Also

GH_Rectangle Class
GH_Rectangle Members
Grasshopper.Kernel.Types Namespace


CastTo(T) Method (T)

[image]

Grasshopper SDK
GH_Rectangle..::..CastTo<(Of <(<'T>)>)> Method (T%)
GH_Rectangle Class See Also Send Feedback
Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastTo<T>(
    out T target
)
Visual Basic
Public Overrides Function CastTo(Of T) ( _
    <OutAttribute> ByRef target As T _
) As Boolean

Parameters

target
Type: T%

Type Parameters

T

See Also

GH_Rectangle Class
CastTo Overload
Grasshopper.Kernel.Types Namespace


DrawViewportMeshes Method

[image]

Grasshopper SDK
GH_Rectangle..::..DrawViewportMeshes Method
GH_Rectangle Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DrawViewportMeshes(
    GH_PreviewMeshArgs args
)
Visual Basic
Public Sub DrawViewportMeshes ( _
    args As GH_PreviewMeshArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..GH_PreviewMeshArgs

Implements

IGH_PreviewData..::..DrawViewportMeshes(GH_PreviewMeshArgs)

See Also

GH_Rectangle Class
Grasshopper.Kernel.Types Namespace


DrawViewportWires Method

[image]

Grasshopper SDK
GH_Rectangle..::..DrawViewportWires Method
GH_Rectangle Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DrawViewportWires(
    GH_PreviewWireArgs args
)
Visual Basic
Public Sub DrawViewportWires ( _
    args As GH_PreviewWireArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..GH_PreviewWireArgs

Implements

IGH_PreviewData..::..DrawViewportWires(GH_PreviewWireArgs)

See Also

GH_Rectangle Class
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_Rectangle..::..Duplicate Method
GH_Rectangle Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_Goo Duplicate()
Visual Basic
Public Overrides Function Duplicate As IGH_Goo

See Also

GH_Rectangle Class
Grasshopper.Kernel.Types Namespace


DuplicateGeometry Method

[image]

Grasshopper SDK
GH_Rectangle..::..DuplicateGeometry Method
GH_Rectangle Class See Also Send Feedback
Create a duplicate of this rectangle.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GeometricGoo DuplicateGeometry()
Visual Basic
Public Overrides Function DuplicateGeometry As IGH_GeometricGoo

See Also

GH_Rectangle Class
Grasshopper.Kernel.Types Namespace


DuplicateRectangle Method

[image]

Grasshopper SDK
GH_Rectangle..::..DuplicateRectangle Method
GH_Rectangle Class See Also Send Feedback
Create a duplicate of this rectangle.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Rectangle DuplicateRectangle()
Visual Basic
Public Function DuplicateRectangle As GH_Rectangle

See Also

GH_Rectangle Class
Grasshopper.Kernel.Types Namespace


EmitProxy Method

[image]

Grasshopper SDK
GH_Rectangle..::..EmitProxy Method
GH_Rectangle Class See Also Send Feedback
Returns a proxy that represents this rectangle. Do not call this function unless you're

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GooProxy EmitProxy()
Visual Basic
Public Overrides Function EmitProxy As IGH_GooProxy

See Also

GH_Rectangle Class
Grasshopper.Kernel.Types Namespace


GetBoundingBox Method

[image]

Grasshopper SDK
GH_Rectangle..::..GetBoundingBox Method
GH_Rectangle Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override BoundingBox GetBoundingBox(
    Transform xform
)
Visual Basic
Public Overrides Function GetBoundingBox ( _
    xform As Transform _
) As BoundingBox

Parameters

xform
Type: Transform

See Also

GH_Rectangle Class
Grasshopper.Kernel.Types Namespace


LoadGeometry Method

[image] [image]

Grasshopper SDK
GH_Rectangle..::..LoadGeometry Method
GH_Rectangle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LoadGeometry()()()() | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | LoadGeometry(RhinoDoc) | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. The default is to always return True. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)

See Also

GH_Rectangle Class
GH_Rectangle Members
Grasshopper.Kernel.Types Namespace


Morph Method

[image]

Grasshopper SDK
GH_Rectangle..::..Morph Method
GH_Rectangle Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GeometricGoo Morph(
    SpaceMorph xmorph
)
Visual Basic
Public Overrides Function Morph ( _
    xmorph As SpaceMorph _
) As IGH_GeometricGoo

Parameters

xmorph
Type: SpaceMorph

See Also

GH_Rectangle Class
Grasshopper.Kernel.Types Namespace


Read Method

[image]

Grasshopper SDK
GH_Rectangle..::..Read Method
GH_Rectangle Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

See Also

GH_Rectangle Class
Grasshopper.Kernel.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_Rectangle..::..ToString Method
GH_Rectangle Class See Also Send Feedback
Format the circle using default grasshopper formatting logic.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_Rectangle Class
Grasshopper.Kernel.Types Namespace


Transform Method

[image]

Grasshopper SDK
GH_Rectangle..::..Transform Method
GH_Rectangle Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GeometricGoo Transform(
    Transform xform
)
Visual Basic
Public Overrides Function Transform ( _
    xform As Transform _
) As IGH_GeometricGoo

Parameters

xform
Type: Transform

See Also

GH_Rectangle Class
Grasshopper.Kernel.Types Namespace


Write Method

[image]

Grasshopper SDK
GH_Rectangle..::..Write Method
GH_Rectangle Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overrides Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

See Also

GH_Rectangle Class
Grasshopper.Kernel.Types Namespace


GH_Rectangle Properties

[image] [image]

Grasshopper SDK
GH_Rectangle Properties
GH_Rectangle Class See Also Send Feedback

The GH_Rectangle type exposes the following members.

Properties

 | Name | Description
Public property | Boundingbox | Gets the boundingbox for this geometry. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Boundingbox.)
Public property | ClippingBox |
Public property | IsGeometryLoaded | Gets a value indicating whether or not this geometry is currently loaded (assuming it is referenced). Not all IGH_GeometricGoo implementations support referenced geometry. The default is to always return True. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public property | IsReferencedGeometry | Gets a value indicating whether or not this geometry is referenced. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public property | IsValid | Gets the validity of this instance. (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot.)
Public property | ReferenceID | Gets or sets the Guid of the object that is referenced. Not all IGH_GeometricGoo implementations support referenced geometry. The default implementation is to always return Guid.Empty. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the value of this type. Note that if the type has a ReferenceID this value might get destroyed in the future. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)

See Also

GH_Rectangle Class
Grasshopper.Kernel.Types Namespace


Boundingbox Property

[image]

Grasshopper SDK
GH_Rectangle..::..Boundingbox Property
GH_Rectangle Class See Also Send Feedback
Gets the boundingbox for this geometry.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override BoundingBox Boundingbox { get; }
Visual Basic
Public Overrides ReadOnly Property Boundingbox As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Rectangle.Boundingbox"]

Return Value

The boundingbox for this piece of geometry or Boundingbox.Empty if the geometry is null or invalid.

See Also

GH_Rectangle Class
Grasshopper.Kernel.Types Namespace


ClippingBox Property

[image]

Grasshopper SDK
GH_Rectangle..::..ClippingBox Property
GH_Rectangle Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public BoundingBox ClippingBox { get; }
Visual Basic
Public ReadOnly Property ClippingBox As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Rectangle.ClippingBox"]

Implements

IGH_PreviewData..::..ClippingBox

See Also

GH_Rectangle Class
Grasshopper.Kernel.Types Namespace


IsValid Property

[image]

Grasshopper SDK
GH_Rectangle..::..IsValid Property
GH_Rectangle Class See Also Send Feedback
Gets the validity of this instance.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool IsValid { get; }
Visual Basic
Public Overrides ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Rectangle.IsValid"]

See Also

GH_Rectangle Class
Grasshopper.Kernel.Types Namespace


IsValidWhyNot Property

[image]

Grasshopper SDK
GH_Rectangle..::..IsValidWhyNot Property
GH_Rectangle Class See Also Send Feedback
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string IsValidWhyNot { get; }
Visual Basic
Public Overrides ReadOnly Property IsValidWhyNot As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Rectangle.IsValidWhyNot"]

See Also

GH_Rectangle Class
Grasshopper.Kernel.Types Namespace


TypeDescription Property

[image]

Grasshopper SDK
GH_Rectangle..::..TypeDescription Property
GH_Rectangle Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeDescription { get; }
Visual Basic
Public Overrides ReadOnly Property TypeDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Rectangle.TypeDescription"]

See Also

GH_Rectangle Class
Grasshopper.Kernel.Types Namespace


TypeName Property

[image]

Grasshopper SDK
GH_Rectangle..::..TypeName Property
GH_Rectangle Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeName { get; }
Visual Basic
Public Overrides ReadOnly Property TypeName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Rectangle.TypeName"]

See Also

GH_Rectangle Class
Grasshopper.Kernel.Types Namespace


GH_Rectangle.GH_RectangleProxy Class

[image]

Grasshopper SDK
GH_Rectangle..::..GH_RectangleProxy Class
GH_Rectangle Class Members See Also Send Feedback
Proxy description of GH_Rectangle class. This class is used by the Generic Multivalue interfaces.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_RectangleProxy : GH_GooProxy<GH_Rectangle>
Visual Basic
Public Class GH_RectangleProxy _
    Inherits GH_GooProxy(Of GH_Rectangle)

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_GooProxy <(Of <(<' GH_Rectangle >)>)>
Grasshopper.Kernel.Types..::..GH_Rectangle..::..GH_RectangleProxy

See Also

GH_Rectangle..::..GH_RectangleProxy Members
Grasshopper.Kernel.Types Namespace


GH_Rectangle.GH_RectangleProxy Members

[image] [image]

Grasshopper SDK
GH_Rectangle..::..GH_RectangleProxy Members
GH_Rectangle..::..GH_RectangleProxy Class Constructors Methods Properties See Also Send Feedback

Represents a 3D rectangle. GH_Rectangle re-implements the RhinoCommon Rectangle3d.

The GH_Rectangle..::..GH_RectangleProxy type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Rectangle..::..GH_RectangleProxy | Initializes a new instance of the GH_Rectangle..::..GH_RectangleProxy class

Methods

 | Name | Description
Public method | Construct | (Overrides GH_GooProxy<(Of <(<'T>)>)>..::..Construct()()()().)
Public method | FormatInstance | Returns a String description of the current value. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FromString | If IsParsable(), then attempts to convert the string to a generic type value (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | MutateString | Munge a string to remove obvious errors on account of the user. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | NumberToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | StringToNumber | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | ToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Area |
Public property | Circumference |
Public property | Height |
Public property | IsParsable | Gets a value indicating whether or not the type can be instantiated from a String. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Origin |
Protected property | Owner | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | ProxyOwner | Gets the piece of Grasshopper data that spawned this proxy. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeName | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | UserString | Gets or sets the user-defined string that describes this proxy. This only really makes sense if the Proxy is Parsable. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Valid | Gets a value indicating whether this proxy represents valid data. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Width |
Public property | XAxis |
Public property | YAxis |
Public property | ZAxis |

See Also

GH_Rectangle..::..GH_RectangleProxy Class
Grasshopper.Kernel.Types Namespace


GH_Rectangle.GH_RectangleProxy Constructor

[image]

Grasshopper SDK
GH_Rectangle..::..GH_RectangleProxy Constructor
GH_Rectangle..::..GH_RectangleProxy Class See Also Send Feedback
Initializes a new instance of the GH_Rectangle..::..GH_RectangleProxy class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_RectangleProxy(
    GH_Rectangle nOwner
)
Visual Basic
Public Sub New ( _
    nOwner As GH_Rectangle _
)

Parameters

nOwner
Type: Grasshopper.Kernel.Types..::..GH_Rectangle

See Also

GH_Rectangle..::..GH_RectangleProxy Class
Grasshopper.Kernel.Types Namespace


GH_Rectangle.GH_RectangleProxy Methods

[image] [image]

Grasshopper SDK
GH_Rectangle..::..GH_RectangleProxy Methods
GH_Rectangle..::..GH_RectangleProxy Class See Also Send Feedback

The GH_Rectangle..::..GH_RectangleProxy type exposes the following members.

Methods

 | Name | Description
Public method | Construct | (Overrides GH_GooProxy<(Of <(<'T>)>)>..::..Construct()()()().)
Public method | FormatInstance | Returns a String description of the current value. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FromString | If IsParsable(), then attempts to convert the string to a generic type value (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | MutateString | Munge a string to remove obvious errors on account of the user. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | NumberToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | StringToNumber | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | ToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

See Also

GH_Rectangle..::..GH_RectangleProxy Class
Grasshopper.Kernel.Types Namespace


Construct Method

[image]

Grasshopper SDK
GH_Rectangle..::..GH_RectangleProxy..::..Construct Method
GH_Rectangle..::..GH_RectangleProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void Construct()
Visual Basic
Public Overrides Sub Construct

See Also

GH_Rectangle..::..GH_RectangleProxy Class
Grasshopper.Kernel.Types Namespace


GH_Rectangle.GH_RectangleProxy Properties

[image] [image]

Grasshopper SDK
GH_Rectangle..::..GH_RectangleProxy Properties
GH_Rectangle..::..GH_RectangleProxy Class See Also Send Feedback

The GH_Rectangle..::..GH_RectangleProxy type exposes the following members.

Properties

 | Name | Description
Public property | Area |
Public property | Circumference |
Public property | Height |
Public property | IsParsable | Gets a value indicating whether or not the type can be instantiated from a String. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Origin |
Protected property | Owner | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | ProxyOwner | Gets the piece of Grasshopper data that spawned this proxy. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeName | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | UserString | Gets or sets the user-defined string that describes this proxy. This only really makes sense if the Proxy is Parsable. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Valid | Gets a value indicating whether this proxy represents valid data. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Width |
Public property | XAxis |
Public property | YAxis |
Public property | ZAxis |

See Also

GH_Rectangle..::..GH_RectangleProxy Class
Grasshopper.Kernel.Types Namespace


Area Property

[image]

Grasshopper SDK
GH_Rectangle..::..GH_RectangleProxy..::..Area Property
GH_Rectangle..::..GH_RectangleProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Area { get; }
Visual Basic
Public ReadOnly Property Area As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Rectangle.GH_RectangleProxy.Area"]

See Also

GH_Rectangle..::..GH_RectangleProxy Class
Grasshopper.Kernel.Types Namespace


Circumference Property

[image]

Grasshopper SDK
GH_Rectangle..::..GH_RectangleProxy..::..Circumference Property
GH_Rectangle..::..GH_RectangleProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Circumference { get; }
Visual Basic
Public ReadOnly Property Circumference As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Rectangle.GH_RectangleProxy.Circumference"]

See Also

GH_Rectangle..::..GH_RectangleProxy Class
Grasshopper.Kernel.Types Namespace


Height Property

[image]

Grasshopper SDK
GH_Rectangle..::..GH_RectangleProxy..::..Height Property
GH_Rectangle..::..GH_RectangleProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Interval_Wrapper Height { get; }
Visual Basic
Public ReadOnly Property Height As GH_Interval_Wrapper
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Rectangle.GH_RectangleProxy.Height"]

See Also

GH_Rectangle..::..GH_RectangleProxy Class
Grasshopper.Kernel.Types Namespace


Origin Property

[image]

Grasshopper SDK
GH_Rectangle..::..GH_RectangleProxy..::..Origin Property
GH_Rectangle..::..GH_RectangleProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Point3d_Wrapper Origin { get; }
Visual Basic
Public ReadOnly Property Origin As GH_Point3d_Wrapper
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Rectangle.GH_RectangleProxy.Origin"]

See Also

GH_Rectangle..::..GH_RectangleProxy Class
Grasshopper.Kernel.Types Namespace


Width Property

[image]

Grasshopper SDK
GH_Rectangle..::..GH_RectangleProxy..::..Width Property
GH_Rectangle..::..GH_RectangleProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Interval_Wrapper Width { get; }
Visual Basic
Public ReadOnly Property Width As GH_Interval_Wrapper
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Rectangle.GH_RectangleProxy.Width"]

See Also

GH_Rectangle..::..GH_RectangleProxy Class
Grasshopper.Kernel.Types Namespace


XAxis Property

[image]

Grasshopper SDK
GH_Rectangle..::..GH_RectangleProxy..::..XAxis Property
GH_Rectangle..::..GH_RectangleProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Vector3d_Wrapper XAxis { get; }
Visual Basic
Public ReadOnly Property XAxis As GH_Vector3d_Wrapper
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Rectangle.GH_RectangleProxy.XAxis"]

See Also

GH_Rectangle..::..GH_RectangleProxy Class
Grasshopper.Kernel.Types Namespace


YAxis Property

[image]

Grasshopper SDK
GH_Rectangle..::..GH_RectangleProxy..::..YAxis Property
GH_Rectangle..::..GH_RectangleProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Vector3d_Wrapper YAxis { get; }
Visual Basic
Public ReadOnly Property YAxis As GH_Vector3d_Wrapper
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Rectangle.GH_RectangleProxy.YAxis"]

See Also

GH_Rectangle..::..GH_RectangleProxy Class
Grasshopper.Kernel.Types Namespace


ZAxis Property

[image]

Grasshopper SDK
GH_Rectangle..::..GH_RectangleProxy..::..ZAxis Property
GH_Rectangle..::..GH_RectangleProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Vector3d_Wrapper ZAxis { get; }
Visual Basic
Public ReadOnly Property ZAxis As GH_Vector3d_Wrapper
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Rectangle.GH_RectangleProxy.ZAxis"]

See Also

GH_Rectangle..::..GH_RectangleProxy Class
Grasshopper.Kernel.Types Namespace


GH_SpinForce Class

[image]

Grasshopper SDK
GH_SpinForce Class
Members See Also Send Feedback
Rotational spin force for IGH_Fields.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_SpinForce : GH_FieldElement
Visual Basic
Public Class GH_SpinForce _
    Inherits GH_FieldElement

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_FieldElement
Grasshopper.Kernel.Types..::..GH_SpinForce

See Also

GH_SpinForce Members
Grasshopper.Kernel.Types Namespace


GH_SpinForce Members

[image] [image]

Grasshopper SDK
GH_SpinForce Members
GH_SpinForce Class Constructors Methods Properties See Also Send Feedback

The GH_SpinForce type exposes the following members.

Constructors

 | Name | Description
Public method | GH_SpinForce | Initializes a new instance of the GH_SpinForce class

Methods

 | Name | Description
Public method | DrawViewportMeshes | (Inherited from GH_FieldElement.)
Public method | DrawViewportWires | (Overrides GH_FieldElement..::..DrawViewportWires(GH_PreviewWireArgs).)
Public method | Duplicate | (Overrides GH_FieldElement..::..Duplicate()()()().)
Public method | Force | (Overrides GH_FieldElement..::..Force(Point3d).)
Public method | IsCoincident | (Inherited from GH_FieldElement.)
Public method | Read | (Overrides GH_FieldElement..::..Read(GH_IReader).)
Public method | Write | (Overrides GH_FieldElement..::..Write(GH_IWriter).)

Properties

 | Name | Description
Public property | BoundingBox | (Overrides GH_FieldElement..::..BoundingBox.)
Public property | ClippingBox | (Inherited from GH_FieldElement.)
Public property | Decay |
Public property | ElementGuid | (Overrides GH_FieldElement..::..ElementGuid.)
Public property | IsLimited | (Inherited from GH_FieldElement.)
Public property | Limits | (Inherited from GH_FieldElement.)
Public property | Plane |
Public property | Radius |
Public property | Strength |

See Also

GH_SpinForce Class
Grasshopper.Kernel.Types Namespace


GH_SpinForce Constructor

[image]

Grasshopper SDK
GH_SpinForce Constructor
GH_SpinForce Class See Also Send Feedback
Initializes a new instance of the GH_SpinForce class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_SpinForce()
Visual Basic
Public Sub New

See Also

GH_SpinForce Class
Grasshopper.Kernel.Types Namespace


GH_SpinForce Methods

[image] [image]

Grasshopper SDK
GH_SpinForce Methods
GH_SpinForce Class See Also Send Feedback

The GH_SpinForce type exposes the following members.

Methods

 | Name | Description
Public method | DrawViewportMeshes | (Inherited from GH_FieldElement.)
Public method | DrawViewportWires | (Overrides GH_FieldElement..::..DrawViewportWires(GH_PreviewWireArgs).)
Public method | Duplicate | (Overrides GH_FieldElement..::..Duplicate()()()().)
Public method | Force | (Overrides GH_FieldElement..::..Force(Point3d).)
Public method | IsCoincident | (Inherited from GH_FieldElement.)
Public method | Read | (Overrides GH_FieldElement..::..Read(GH_IReader).)
Public method | Write | (Overrides GH_FieldElement..::..Write(GH_IWriter).)

See Also

GH_SpinForce Class
Grasshopper.Kernel.Types Namespace


DrawViewportWires Method

[image]

Grasshopper SDK
GH_SpinForce..::..DrawViewportWires Method
GH_SpinForce Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void DrawViewportWires(
    GH_PreviewWireArgs args
)
Visual Basic
Public Overrides Sub DrawViewportWires ( _
    args As GH_PreviewWireArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..GH_PreviewWireArgs

See Also

GH_SpinForce Class
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_SpinForce..::..Duplicate Method
GH_SpinForce Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_FieldElement Duplicate()
Visual Basic
Public Overrides Function Duplicate As IGH_FieldElement

See Also

GH_SpinForce Class
Grasshopper.Kernel.Types Namespace


Force Method

[image]

Grasshopper SDK
GH_SpinForce..::..Force Method
GH_SpinForce Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override Vector3d Force(
    Point3d location
)
Visual Basic
Public Overrides Function Force ( _
    location As Point3d _
) As Vector3d

Parameters

location
Type: Point3d

See Also

GH_SpinForce Class
Grasshopper.Kernel.Types Namespace


Read Method

[image]

Grasshopper SDK
GH_SpinForce..::..Read Method
GH_SpinForce Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

See Also

GH_SpinForce Class
Grasshopper.Kernel.Types Namespace


Write Method

[image]

Grasshopper SDK
GH_SpinForce..::..Write Method
GH_SpinForce Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overrides Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

See Also

GH_SpinForce Class
Grasshopper.Kernel.Types Namespace


GH_SpinForce Properties

[image] [image]

Grasshopper SDK
GH_SpinForce Properties
GH_SpinForce Class See Also Send Feedback

The GH_SpinForce type exposes the following members.

Properties

 | Name | Description
Public property | BoundingBox | (Overrides GH_FieldElement..::..BoundingBox.)
Public property | ClippingBox | (Inherited from GH_FieldElement.)
Public property | Decay |
Public property | ElementGuid | (Overrides GH_FieldElement..::..ElementGuid.)
Public property | IsLimited | (Inherited from GH_FieldElement.)
Public property | Limits | (Inherited from GH_FieldElement.)
Public property | Plane |
Public property | Radius |
Public property | Strength |

See Also

GH_SpinForce Class
Grasshopper.Kernel.Types Namespace


BoundingBox Property

[image]

Grasshopper SDK
GH_SpinForce..::..BoundingBox Property
GH_SpinForce Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override BoundingBox BoundingBox { get; }
Visual Basic
Public Overrides ReadOnly Property BoundingBox As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_SpinForce.BoundingBox"]

See Also

GH_SpinForce Class
Grasshopper.Kernel.Types Namespace


Decay Property

[image]

Grasshopper SDK
GH_SpinForce..::..Decay Property
GH_SpinForce Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double Decay { get; set; }
Visual Basic
Public Property Decay As Double
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_SpinForce.Decay"]

See Also

GH_SpinForce Class
Grasshopper.Kernel.Types Namespace


ElementGuid Property

[image]

Grasshopper SDK
GH_SpinForce..::..ElementGuid Property
GH_SpinForce Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override Guid ElementGuid { get; }
Visual Basic
Public Overrides ReadOnly Property ElementGuid As Guid
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_SpinForce.ElementGuid"]

See Also

GH_SpinForce Class
Grasshopper.Kernel.Types Namespace


Plane Property

[image]

Grasshopper SDK
GH_SpinForce..::..Plane Property
GH_SpinForce Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Plane Plane { get; set; }
Visual Basic
Public Property Plane As Plane
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_SpinForce.Plane"]

See Also

GH_SpinForce Class
Grasshopper.Kernel.Types Namespace


Radius Property

[image]

Grasshopper SDK
GH_SpinForce..::..Radius Property
GH_SpinForce Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double Radius { get; set; }
Visual Basic
Public Property Radius As Double
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_SpinForce.Radius"]

See Also

GH_SpinForce Class
Grasshopper.Kernel.Types Namespace


Strength Property

[image]

Grasshopper SDK
GH_SpinForce..::..Strength Property
GH_SpinForce Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double Strength { get; set; }
Visual Basic
Public Property Strength As Double
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_SpinForce.Strength"]

See Also

GH_SpinForce Class
Grasshopper.Kernel.Types Namespace


GH_String Class

[image]

Grasshopper SDK
GH_String Class
Members See Also Send Feedback
Represents a literal string. GH_String re-implements the framework System.String type.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_String : GH_Goo<string>,
    IGH_QuickCast
Visual Basic
Public Class GH_String _
    Inherits GH_Goo(Of String) _
    Implements IGH_QuickCast

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_Goo <(Of <(<' String >)>)>
Grasshopper.Kernel.Types..::..GH_String

See Also

GH_String Members
Grasshopper.Kernel.Types Namespace


GH_String Members

[image] [image]

Grasshopper SDK
GH_String Members
GH_String Class Constructors Methods Fields Properties See Also Send Feedback

The GH_String type exposes the following members.

Constructors

 | Name | Description
Public method | GH_String()()()() | Blank constructor
Public method | GH_String(String) | Initializes a new instance of the GH_String class
Public method | GH_String(GH_String) | Initializes a new instance of the GH_String class

Methods

 | Name | Description
Public method | CastFrom | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | Duplicate | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateString |
Public method | EmitProxy | (Overrides GH_Goo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ToString | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | IsValid | Gets the validity of this instance. String are valid if they are not null. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the internal data. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_String Class
Grasshopper.Kernel.Types Namespace


GH_String Constructor

[image] [image]

Grasshopper SDK
GH_String Constructor
GH_String Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_String()()()() | Blank constructor
Public method | GH_String(String) | Initializes a new instance of the GH_String class
Public method | GH_String(GH_String) | Initializes a new instance of the GH_String class

See Also

GH_String Class
GH_String Members
Grasshopper.Kernel.Types Namespace


GH_String Constructor

[image]

Grasshopper SDK
GH_String Constructor
GH_String Class See Also Send Feedback
Blank constructor

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_String()
Visual Basic
Public Sub New

See Also

GH_String Class
GH_String Overload
Grasshopper.Kernel.Types Namespace


GH_String Constructor (String)

[image]

Grasshopper SDK
GH_String Constructor (String)
GH_String Class See Also Send Feedback
Initializes a new instance of the GH_String class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_String(
    string str
)
Visual Basic
Public Sub New ( _
    str As String _
)

Parameters

str
Type: System..::..String

See Also

GH_String Class
GH_String Overload
Grasshopper.Kernel.Types Namespace


GH_String Constructor (GH_String)

[image]

Grasshopper SDK
GH_String Constructor (GH_String)
GH_String Class See Also Send Feedback
Initializes a new instance of the GH_String class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_String(
    GH_String other
)
Visual Basic
Public Sub New ( _
    other As GH_String _
)

Parameters

other
Type: Grasshopper.Kernel.Types..::..GH_String

See Also

GH_String Class
GH_String Overload
Grasshopper.Kernel.Types Namespace


GH_String Fields

[image] [image]

Grasshopper SDK
GH_String Fields
GH_String Class See Also Send Feedback

The GH_String type exposes the following members.

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_String Class
Grasshopper.Kernel.Types Namespace


GH_String Methods

[image] [image]

Grasshopper SDK
GH_String Methods
GH_String Class See Also Send Feedback

The GH_String type exposes the following members.

Methods

 | Name | Description
Public method | CastFrom | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | Duplicate | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateString |
Public method | EmitProxy | (Overrides GH_Goo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ToString | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

See Also

GH_String Class
Grasshopper.Kernel.Types Namespace


CastFrom Method

[image]

Grasshopper SDK
GH_String..::..CastFrom Method
GH_String Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastFrom(
    Object source
)
Visual Basic
Public Overrides Function CastFrom ( _
    source As Object _
) As Boolean

Parameters

source
Type: System..::..Object

See Also

GH_String Class
Grasshopper.Kernel.Types Namespace


CastTo Method

[image] [image]

Grasshopper SDK
GH_String..::..CastTo Method
GH_String Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)

See Also

GH_String Class
GH_String Members
Grasshopper.Kernel.Types Namespace


CastTo(T) Method (T)

[image]

Grasshopper SDK
GH_String..::..CastTo<(Of <(<'T>)>)> Method (T%)
GH_String Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastTo<T>(
    out T target
)
Visual Basic
Public Overrides Function CastTo(Of T) ( _
    <OutAttribute> ByRef target As T _
) As Boolean

Parameters

target
Type: T%

Type Parameters

T

See Also

GH_String Class
CastTo Overload
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_String..::..Duplicate Method
GH_String Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_Goo Duplicate()
Visual Basic
Public Overrides Function Duplicate As IGH_Goo

See Also

GH_String Class
Grasshopper.Kernel.Types Namespace


DuplicateString Method

[image]

Grasshopper SDK
GH_String..::..DuplicateString Method
GH_String Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_String DuplicateString()
Visual Basic
Public Function DuplicateString As GH_String

See Also

GH_String Class
Grasshopper.Kernel.Types Namespace


EmitProxy Method

[image]

Grasshopper SDK
GH_String..::..EmitProxy Method
GH_String Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GooProxy EmitProxy()
Visual Basic
Public Overrides Function EmitProxy As IGH_GooProxy

See Also

GH_String Class
Grasshopper.Kernel.Types Namespace


Read Method

[image]

Grasshopper SDK
GH_String..::..Read Method
GH_String Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

See Also

GH_String Class
Grasshopper.Kernel.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_String..::..ToString Method
GH_String Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_String Class
Grasshopper.Kernel.Types Namespace


Write Method

[image]

Grasshopper SDK
GH_String..::..Write Method
GH_String Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overrides Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

See Also

GH_String Class
Grasshopper.Kernel.Types Namespace


GH_String Properties

[image] [image]

Grasshopper SDK
GH_String Properties
GH_String Class See Also Send Feedback

The GH_String type exposes the following members.

Properties

 | Name | Description
Public property | IsValid | Gets the validity of this instance. String are valid if they are not null. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the internal data. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_String Class
Grasshopper.Kernel.Types Namespace


IsValid Property

[image]

Grasshopper SDK
GH_String..::..IsValid Property
GH_String Class See Also Send Feedback
Gets the validity of this instance. String are valid if they are not null.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool IsValid { get; }
Visual Basic
Public Overrides ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_String.IsValid"]

See Also

GH_String Class
Grasshopper.Kernel.Types Namespace


IsValidWhyNot Property

[image]

Grasshopper SDK
GH_String..::..IsValidWhyNot Property
GH_String Class See Also Send Feedback
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string IsValidWhyNot { get; }
Visual Basic
Public Overrides ReadOnly Property IsValidWhyNot As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_String.IsValidWhyNot"]

See Also

GH_String Class
Grasshopper.Kernel.Types Namespace


TypeDescription Property

[image]

Grasshopper SDK
GH_String..::..TypeDescription Property
GH_String Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeDescription { get; }
Visual Basic
Public Overrides ReadOnly Property TypeDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_String.TypeDescription"]

See Also

GH_String Class
Grasshopper.Kernel.Types Namespace


TypeName Property

[image]

Grasshopper SDK
GH_String..::..TypeName Property
GH_String Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeName { get; }
Visual Basic
Public Overrides ReadOnly Property TypeName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_String.TypeName"]

See Also

GH_String Class
Grasshopper.Kernel.Types Namespace


GH_StructurePath Class

[image]

Grasshopper SDK
GH_StructurePath Class
Members See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_StructurePath : GH_Goo<GH_Path>
Visual Basic
Public Class GH_StructurePath _
    Inherits GH_Goo(Of GH_Path)

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_Goo <(Of <(<' GH_Path >)>)>
Grasshopper.Kernel.Types..::..GH_StructurePath

See Also

GH_StructurePath Members
Grasshopper.Kernel.Types Namespace


GH_StructurePath Members

[image] [image]

Grasshopper SDK
GH_StructurePath Members
GH_StructurePath Class Constructors Methods Fields Properties See Also Send Feedback

The GH_StructurePath type exposes the following members.

Constructors

 | Name | Description
Public method | GH_StructurePath()()()() | Blank constructor
Public method | GH_StructurePath(GH_Path) | Initializes a new instance of the GH_StructurePath class
Public method | GH_StructurePath(GH_StructurePath) | Initializes a new instance of the GH_StructurePath class

Methods

 | Name | Description
Public method | CastFrom | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | Duplicate | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicatePath |
Public method | EmitProxy | (Overrides GH_Goo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ScriptVariable()()()().)
Public method | ToString | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | IsValid | Gets the validity of this instance. Integers are always valid (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Value.)

See Also

GH_StructurePath Class
Grasshopper.Kernel.Types Namespace


GH_StructurePath Constructor

[image] [image]

Grasshopper SDK
GH_StructurePath Constructor
GH_StructurePath Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_StructurePath()()()() | Blank constructor
Public method | GH_StructurePath(GH_Path) | Initializes a new instance of the GH_StructurePath class
Public method | GH_StructurePath(GH_StructurePath) | Initializes a new instance of the GH_StructurePath class

See Also

GH_StructurePath Class
GH_StructurePath Members
Grasshopper.Kernel.Types Namespace


GH_StructurePath Constructor

[image]

Grasshopper SDK
GH_StructurePath Constructor
GH_StructurePath Class See Also Send Feedback
Blank constructor

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_StructurePath()
Visual Basic
Public Sub New

See Also

GH_StructurePath Class
GH_StructurePath Overload
Grasshopper.Kernel.Types Namespace


GH_StructurePath Constructor (GH_Path)

[image]

Grasshopper SDK
GH_StructurePath Constructor (GH_Path)
GH_StructurePath Class See Also Send Feedback
Initializes a new instance of the GH_StructurePath class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_StructurePath(
    GH_Path path
)
Visual Basic
Public Sub New ( _
    path As GH_Path _
)

Parameters

path
Type: Grasshopper.Kernel.Data..::..GH_Path

See Also

GH_StructurePath Class
GH_StructurePath Overload
Grasshopper.Kernel.Types Namespace


GH_StructurePath Constructor (GH_StructurePath)

[image]

Grasshopper SDK
GH_StructurePath Constructor (GH_StructurePath)
GH_StructurePath Class See Also Send Feedback
Initializes a new instance of the GH_StructurePath class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_StructurePath(
    GH_StructurePath other
)
Visual Basic
Public Sub New ( _
    other As GH_StructurePath _
)

Parameters

other
Type: Grasshopper.Kernel.Types..::..GH_StructurePath

See Also

GH_StructurePath Class
GH_StructurePath Overload
Grasshopper.Kernel.Types Namespace


GH_StructurePath Fields

[image] [image]

Grasshopper SDK
GH_StructurePath Fields
GH_StructurePath Class See Also Send Feedback

The GH_StructurePath type exposes the following members.

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_StructurePath Class
Grasshopper.Kernel.Types Namespace


GH_StructurePath Methods

[image] [image]

Grasshopper SDK
GH_StructurePath Methods
GH_StructurePath Class See Also Send Feedback

The GH_StructurePath type exposes the following members.

Methods

 | Name | Description
Public method | CastFrom | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | Duplicate | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicatePath |
Public method | EmitProxy | (Overrides GH_Goo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ScriptVariable()()()().)
Public method | ToString | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

See Also

GH_StructurePath Class
Grasshopper.Kernel.Types Namespace


CastFrom Method

[image]

Grasshopper SDK
GH_StructurePath..::..CastFrom Method
GH_StructurePath Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastFrom(
    Object source
)
Visual Basic
Public Overrides Function CastFrom ( _
    source As Object _
) As Boolean

Parameters

source
Type: System..::..Object

See Also

GH_StructurePath Class
Grasshopper.Kernel.Types Namespace


CastTo Method

[image] [image]

Grasshopper SDK
GH_StructurePath..::..CastTo Method
GH_StructurePath Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)

See Also

GH_StructurePath Class
GH_StructurePath Members
Grasshopper.Kernel.Types Namespace


CastTo(T) Method (T)

[image]

Grasshopper SDK
GH_StructurePath..::..CastTo<(Of <(<'T>)>)> Method (T%)
GH_StructurePath Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastTo<T>(
    out T target
)
Visual Basic
Public Overrides Function CastTo(Of T) ( _
    <OutAttribute> ByRef target As T _
) As Boolean

Parameters

target
Type: T%

Type Parameters

T

See Also

GH_StructurePath Class
CastTo Overload
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_StructurePath..::..Duplicate Method
GH_StructurePath Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_Goo Duplicate()
Visual Basic
Public Overrides Function Duplicate As IGH_Goo

See Also

GH_StructurePath Class
Grasshopper.Kernel.Types Namespace


DuplicatePath Method

[image]

Grasshopper SDK
GH_StructurePath..::..DuplicatePath Method
GH_StructurePath Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_StructurePath DuplicatePath()
Visual Basic
Public Function DuplicatePath As GH_StructurePath

See Also

GH_StructurePath Class
Grasshopper.Kernel.Types Namespace


EmitProxy Method

[image]

Grasshopper SDK
GH_StructurePath..::..EmitProxy Method
GH_StructurePath Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GooProxy EmitProxy()
Visual Basic
Public Overrides Function EmitProxy As IGH_GooProxy

See Also

GH_StructurePath Class
Grasshopper.Kernel.Types Namespace


Read Method

[image]

Grasshopper SDK
GH_StructurePath..::..Read Method
GH_StructurePath Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

See Also

GH_StructurePath Class
Grasshopper.Kernel.Types Namespace


ScriptVariable Method

[image]

Grasshopper SDK
GH_StructurePath..::..ScriptVariable Method
GH_StructurePath Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override Object ScriptVariable()
Visual Basic
Public Overrides Function ScriptVariable As Object

See Also

GH_StructurePath Class
Grasshopper.Kernel.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_StructurePath..::..ToString Method
GH_StructurePath Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_StructurePath Class
Grasshopper.Kernel.Types Namespace


Write Method

[image]

Grasshopper SDK
GH_StructurePath..::..Write Method
GH_StructurePath Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overrides Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

See Also

GH_StructurePath Class
Grasshopper.Kernel.Types Namespace


GH_StructurePath Properties

[image] [image]

Grasshopper SDK
GH_StructurePath Properties
GH_StructurePath Class See Also Send Feedback

The GH_StructurePath type exposes the following members.

Properties

 | Name | Description
Public property | IsValid | Gets the validity of this instance. Integers are always valid (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Value.)

See Also

GH_StructurePath Class
Grasshopper.Kernel.Types Namespace


IsValid Property

[image]

Grasshopper SDK
GH_StructurePath..::..IsValid Property
GH_StructurePath Class See Also Send Feedback
Gets the validity of this instance. Integers are always valid

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool IsValid { get; }
Visual Basic
Public Overrides ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_StructurePath.IsValid"]

See Also

GH_StructurePath Class
Grasshopper.Kernel.Types Namespace


TypeDescription Property

[image]

Grasshopper SDK
GH_StructurePath..::..TypeDescription Property
GH_StructurePath Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeDescription { get; }
Visual Basic
Public Overrides ReadOnly Property TypeDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_StructurePath.TypeDescription"]

See Also

GH_StructurePath Class
Grasshopper.Kernel.Types Namespace


TypeName Property

[image]

Grasshopper SDK
GH_StructurePath..::..TypeName Property
GH_StructurePath Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeName { get; }
Visual Basic
Public Overrides ReadOnly Property TypeName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_StructurePath.TypeName"]

See Also

GH_StructurePath Class
Grasshopper.Kernel.Types Namespace


Value Property

[image]

Grasshopper SDK
GH_StructurePath..::..Value Property
GH_StructurePath Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override GH_Path Value { get; set; }
Visual Basic
Public Overrides Property Value As GH_Path
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_StructurePath.Value"]

See Also

GH_StructurePath Class
Grasshopper.Kernel.Types Namespace


GH_Surface Class

[image]

Grasshopper SDK
GH_Surface Class
Members See Also Send Feedback
Represents a 3D (trimmed) surface. GH_Surface wraps the functionality of the OpenNURBS OnBrepFace class.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Surface : GH_GeometricGoo<Brep>,
    IGH_BakeAwareData, IGH_PreviewData, IGH_PreviewMeshData
Visual Basic
Public Class GH_Surface _
    Inherits GH_GeometricGoo(Of Brep) _
    Implements IGH_BakeAwareData, IGH_PreviewData, IGH_PreviewMeshData

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_Goo <(Of <(<'Brep>)>)>
Grasshopper.Kernel.Types..::..GH_GeometricGoo <(Of <(<'Brep>)>)>
Grasshopper.Kernel.Types..::..GH_Surface

See Also

GH_Surface Members
Grasshopper.Kernel.Types Namespace


GH_Surface Members

[image] [image]

Grasshopper SDK
GH_Surface Members
GH_Surface Class Constructors Methods Fields Properties See Also Send Feedback

The GH_Surface type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Surface()()()() | Initializes a new instance of the GH_Surface class
Public method | GH_Surface(Brep) | Initializes a new instance of the GH_Surface class
Public method | GH_Surface(Surface) | Initializes a new instance of the GH_Surface class
Public method | GH_Surface(Guid) | Initializes a new instance of the GH_Surface class
Public method | GH_Surface(GH_Surface) | Initializes a new instance of the GH_Surface class

Methods

 | Name | Description
Public method | BakeGeometry |
Public method | CastFrom | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type T. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | ClearCaches | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..ClearCaches()()()().)
Public method | DestroyPreviewMeshes |
Public method | DrawViewportMeshes |
Public method | DrawViewportWires |
Public method | Duplicate | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateGeometry | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..DuplicateGeometry()()()().)
Public method | DuplicateSurface |
Public method | EmitProxy | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | GetBoundingBox | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..GetBoundingBox(Transform).)
Public method | GetPreviewMeshes |
Public method | IsPointOnDomain |
Public method | IsPointOnFace |
Public method | LoadGeometry()()()() | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | LoadGeometry(RhinoDoc) | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..LoadGeometry(RhinoDoc).)
Public method | Morph | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Morph(SpaceMorph).)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ScriptVariable()()()().)
Public method | ToString | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Transform | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Transform(Transform).)
Public method | Untrim |
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Boundingbox | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Boundingbox.)
Public property | ClippingBox |
Public property | Face |
Public property | IsGeometryLoaded | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..IsGeometryLoaded.)
Public property | IsReferencedGeometry | Gets a value indicating whether or not this geometry is referenced. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public property | IsValid | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot.)
Public property | ReferenceID | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..ReferenceID.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Value.)

See Also

GH_Surface Class
Grasshopper.Kernel.Types Namespace


GH_Surface Constructor

[image] [image]

Grasshopper SDK
GH_Surface Constructor
GH_Surface Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Surface()()()() | Initializes a new instance of the GH_Surface class
Public method | GH_Surface(Brep) | Initializes a new instance of the GH_Surface class
Public method | GH_Surface(Surface) | Initializes a new instance of the GH_Surface class
Public method | GH_Surface(Guid) | Initializes a new instance of the GH_Surface class
Public method | GH_Surface(GH_Surface) | Initializes a new instance of the GH_Surface class

See Also

GH_Surface Class
GH_Surface Members
Grasshopper.Kernel.Types Namespace


GH_Surface Constructor

[image]

Grasshopper SDK
GH_Surface Constructor
GH_Surface Class See Also Send Feedback
Initializes a new instance of the GH_Surface class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Surface()
Visual Basic
Public Sub New

See Also

GH_Surface Class
GH_Surface Overload
Grasshopper.Kernel.Types Namespace


GH_Surface Constructor ()

[image]

Grasshopper SDK
GH_Surface Constructor ()
GH_Surface Class See Also Send Feedback
Initializes a new instance of the GH_Surface class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Surface(
    Brep brep
)
Visual Basic
Public Sub New ( _
    brep As Brep _
)

Parameters

brep
Type: Brep

See Also

GH_Surface Class
GH_Surface Overload
Grasshopper.Kernel.Types Namespace


GH_Surface Constructor ()

[image]

Grasshopper SDK
GH_Surface Constructor ()
GH_Surface Class See Also Send Feedback
Initializes a new instance of the GH_Surface class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Surface(
    Surface srf
)
Visual Basic
Public Sub New ( _
    srf As Surface _
)

Parameters

srf
Type: Surface

See Also

GH_Surface Class
GH_Surface Overload
Grasshopper.Kernel.Types Namespace


GH_Surface Constructor (Guid)

[image]

Grasshopper SDK
GH_Surface Constructor (Guid)
GH_Surface Class See Also Send Feedback
Initializes a new instance of the GH_Surface class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Surface(
    Guid id
)
Visual Basic
Public Sub New ( _
    id As Guid _
)

Parameters

id
Type: System..::..Guid

See Also

GH_Surface Class
GH_Surface Overload
Grasshopper.Kernel.Types Namespace


GH_Surface Constructor (GH_Surface)

[image]

Grasshopper SDK
GH_Surface Constructor (GH_Surface)
GH_Surface Class See Also Send Feedback
Initializes a new instance of the GH_Surface class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Surface(
    GH_Surface other
)
Visual Basic
Public Sub New ( _
    other As GH_Surface _
)

Parameters

other
Type: Grasshopper.Kernel.Types..::..GH_Surface

See Also

GH_Surface Class
GH_Surface Overload
Grasshopper.Kernel.Types Namespace


GH_Surface Fields

[image] [image]

Grasshopper SDK
GH_Surface Fields
GH_Surface Class See Also Send Feedback

The GH_Surface type exposes the following members.

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Surface Class
Grasshopper.Kernel.Types Namespace


GH_Surface Methods

[image] [image]

Grasshopper SDK
GH_Surface Methods
GH_Surface Class See Also Send Feedback

The GH_Surface type exposes the following members.

Methods

 | Name | Description
Public method | BakeGeometry |
Public method | CastFrom | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type T. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | ClearCaches | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..ClearCaches()()()().)
Public method | DestroyPreviewMeshes |
Public method | DrawViewportMeshes |
Public method | DrawViewportWires |
Public method | Duplicate | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateGeometry | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..DuplicateGeometry()()()().)
Public method | DuplicateSurface |
Public method | EmitProxy | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | GetBoundingBox | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..GetBoundingBox(Transform).)
Public method | GetPreviewMeshes |
Public method | IsPointOnDomain |
Public method | IsPointOnFace |
Public method | LoadGeometry()()()() | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | LoadGeometry(RhinoDoc) | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..LoadGeometry(RhinoDoc).)
Public method | Morph | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Morph(SpaceMorph).)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ScriptVariable()()()().)
Public method | ToString | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Transform | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Transform(Transform).)
Public method | Untrim |
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

See Also

GH_Surface Class
Grasshopper.Kernel.Types Namespace


BakeGeometry Method

[image]

Grasshopper SDK
GH_Surface..::..BakeGeometry Method
GH_Surface Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool BakeGeometry(
    RhinoDoc doc,
    ObjectAttributes att,
    ref Guid obj_guid
)
Visual Basic
Public Function BakeGeometry ( _
    doc As RhinoDoc, _
    att As ObjectAttributes, _
    ByRef obj_guid As Guid _
) As Boolean

Parameters

doc
Type: RhinoDoc
att
Type: ObjectAttributes
obj_guid
Type: System..::..Guid %

Implements

IGH_BakeAwareData..::..BakeGeometry(RhinoDoc, ObjectAttributes, Guid%)

See Also

GH_Surface Class
Grasshopper.Kernel.Types Namespace


CastFrom Method

[image]

Grasshopper SDK
GH_Surface..::..CastFrom Method
GH_Surface Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastFrom(
    Object source
)
Visual Basic
Public Overrides Function CastFrom ( _
    source As Object _
) As Boolean

Parameters

source
Type: System..::..Object

See Also

GH_Surface Class
Grasshopper.Kernel.Types Namespace


CastTo Method

[image] [image]

Grasshopper SDK
GH_Surface..::..CastTo Method
GH_Surface Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type T. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)

See Also

GH_Surface Class
GH_Surface Members
Grasshopper.Kernel.Types Namespace


CastTo(T) Method (T)

[image]

Grasshopper SDK
GH_Surface..::..CastTo<(Of <(<'T>)>)> Method (T%)
GH_Surface Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastTo<T>(
    out T target
)
Visual Basic
Public Overrides Function CastTo(Of T) ( _
    <OutAttribute> ByRef target As T _
) As Boolean

Parameters

target
Type: T%

Type Parameters

T

See Also

GH_Surface Class
CastTo Overload
Grasshopper.Kernel.Types Namespace


ClearCaches Method

[image]

Grasshopper SDK
GH_Surface..::..ClearCaches Method
GH_Surface Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void ClearCaches()
Visual Basic
Public Overrides Sub ClearCaches

See Also

GH_Surface Class
Grasshopper.Kernel.Types Namespace


DestroyPreviewMeshes Method

[image]

Grasshopper SDK
GH_Surface..::..DestroyPreviewMeshes Method
GH_Surface Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DestroyPreviewMeshes()
Visual Basic
Public Sub DestroyPreviewMeshes

Implements

IGH_PreviewMeshData..::..DestroyPreviewMeshes()()()()

See Also

GH_Surface Class
Grasshopper.Kernel.Types Namespace


DrawViewportMeshes Method

[image]

Grasshopper SDK
GH_Surface..::..DrawViewportMeshes Method
GH_Surface Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DrawViewportMeshes(
    GH_PreviewMeshArgs args
)
Visual Basic
Public Sub DrawViewportMeshes ( _
    args As GH_PreviewMeshArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..GH_PreviewMeshArgs

Implements

IGH_PreviewData..::..DrawViewportMeshes(GH_PreviewMeshArgs)

See Also

GH_Surface Class
Grasshopper.Kernel.Types Namespace


DrawViewportWires Method

[image]

Grasshopper SDK
GH_Surface..::..DrawViewportWires Method
GH_Surface Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DrawViewportWires(
    GH_PreviewWireArgs args
)
Visual Basic
Public Sub DrawViewportWires ( _
    args As GH_PreviewWireArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..GH_PreviewWireArgs

Implements

IGH_PreviewData..::..DrawViewportWires(GH_PreviewWireArgs)

See Also

GH_Surface Class
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_Surface..::..Duplicate Method
GH_Surface Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_Goo Duplicate()
Visual Basic
Public Overrides Function Duplicate As IGH_Goo

See Also

GH_Surface Class
Grasshopper.Kernel.Types Namespace


DuplicateGeometry Method

[image]

Grasshopper SDK
GH_Surface..::..DuplicateGeometry Method
GH_Surface Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GeometricGoo DuplicateGeometry()
Visual Basic
Public Overrides Function DuplicateGeometry As IGH_GeometricGoo

See Also

GH_Surface Class
Grasshopper.Kernel.Types Namespace


DuplicateSurface Method

[image]

Grasshopper SDK
GH_Surface..::..DuplicateSurface Method
GH_Surface Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Surface DuplicateSurface()
Visual Basic
Public Function DuplicateSurface As GH_Surface

See Also

GH_Surface Class
Grasshopper.Kernel.Types Namespace


EmitProxy Method

[image]

Grasshopper SDK
GH_Surface..::..EmitProxy Method
GH_Surface Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GooProxy EmitProxy()
Visual Basic
Public Overrides Function EmitProxy As IGH_GooProxy

See Also

GH_Surface Class
Grasshopper.Kernel.Types Namespace


GetBoundingBox Method

[image]

Grasshopper SDK
GH_Surface..::..GetBoundingBox Method
GH_Surface Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override BoundingBox GetBoundingBox(
    Transform xform
)
Visual Basic
Public Overrides Function GetBoundingBox ( _
    xform As Transform _
) As BoundingBox

Parameters

xform
Type: Transform

See Also

GH_Surface Class
Grasshopper.Kernel.Types Namespace


GetPreviewMeshes Method

[image]

Grasshopper SDK
GH_Surface..::..GetPreviewMeshes Method
GH_Surface Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Mesh[] GetPreviewMeshes()
Visual Basic
Public Function GetPreviewMeshes As Mesh()

Implements

IGH_PreviewMeshData..::..GetPreviewMeshes()()()()

See Also

GH_Surface Class
Grasshopper.Kernel.Types Namespace


IsPointOnDomain Method

[image]

Grasshopper SDK
GH_Surface..::..IsPointOnDomain Method
GH_Surface Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsPointOnDomain(
    double u,
    double v
)
Visual Basic
Public Function IsPointOnDomain ( _
    u As Double, _
    v As Double _
) As Boolean

Parameters

u
Type: System..::..Double
v
Type: System..::..Double

See Also

GH_Surface Class
Grasshopper.Kernel.Types Namespace


IsPointOnFace Method

[image]

Grasshopper SDK
GH_Surface..::..IsPointOnFace Method
GH_Surface Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsPointOnFace(
    double u,
    double v
)
Visual Basic
Public Function IsPointOnFace ( _
    u As Double, _
    v As Double _
) As Boolean

Parameters

u
Type: System..::..Double
v
Type: System..::..Double

See Also

GH_Surface Class
Grasshopper.Kernel.Types Namespace


LoadGeometry Method

[image] [image]

Grasshopper SDK
GH_Surface..::..LoadGeometry Method
GH_Surface Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LoadGeometry()()()() | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public method | LoadGeometry(RhinoDoc) | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..LoadGeometry(RhinoDoc).)

See Also

GH_Surface Class
GH_Surface Members
Grasshopper.Kernel.Types Namespace


LoadGeometry Method ()

[image]

Grasshopper SDK
GH_Surface..::..LoadGeometry Method ()
GH_Surface Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool LoadGeometry(
    RhinoDoc doc
)
Visual Basic
Public Overrides Function LoadGeometry ( _
    doc As RhinoDoc _
) As Boolean

Parameters

doc
Type: RhinoDoc

See Also

GH_Surface Class
LoadGeometry Overload
Grasshopper.Kernel.Types Namespace


Morph Method

[image]

Grasshopper SDK
GH_Surface..::..Morph Method
GH_Surface Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GeometricGoo Morph(
    SpaceMorph xmorph
)
Visual Basic
Public Overrides Function Morph ( _
    xmorph As SpaceMorph _
) As IGH_GeometricGoo

Parameters

xmorph
Type: SpaceMorph

See Also

GH_Surface Class
Grasshopper.Kernel.Types Namespace


Read Method

[image]

Grasshopper SDK
GH_Surface..::..Read Method
GH_Surface Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

See Also

GH_Surface Class
Grasshopper.Kernel.Types Namespace


ScriptVariable Method

[image]

Grasshopper SDK
GH_Surface..::..ScriptVariable Method
GH_Surface Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override Object ScriptVariable()
Visual Basic
Public Overrides Function ScriptVariable As Object

See Also

GH_Surface Class
Grasshopper.Kernel.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_Surface..::..ToString Method
GH_Surface Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_Surface Class
Grasshopper.Kernel.Types Namespace


Transform Method

[image]

Grasshopper SDK
GH_Surface..::..Transform Method
GH_Surface Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GeometricGoo Transform(
    Transform xform
)
Visual Basic
Public Overrides Function Transform ( _
    xform As Transform _
) As IGH_GeometricGoo

Parameters

xform
Type: Transform

See Also

GH_Surface Class
Grasshopper.Kernel.Types Namespace


Untrim Method

[image]

Grasshopper SDK
GH_Surface..::..Untrim Method
GH_Surface Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Untrim()
Visual Basic
Public Function Untrim As Boolean

See Also

GH_Surface Class
Grasshopper.Kernel.Types Namespace


Write Method

[image]

Grasshopper SDK
GH_Surface..::..Write Method
GH_Surface Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overrides Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

See Also

GH_Surface Class
Grasshopper.Kernel.Types Namespace


GH_Surface Properties

[image] [image]

Grasshopper SDK
GH_Surface Properties
GH_Surface Class See Also Send Feedback

The GH_Surface type exposes the following members.

Properties

 | Name | Description
Public property | Boundingbox | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Boundingbox.)
Public property | ClippingBox |
Public property | Face |
Public property | IsGeometryLoaded | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..IsGeometryLoaded.)
Public property | IsReferencedGeometry | Gets a value indicating whether or not this geometry is referenced. Not all IGH_GeometricGoo implementations support referenced geometry. (Inherited from GH_GeometricGoo<(Of <(<'T>)>)>.)
Public property | IsValid | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot.)
Public property | ReferenceID | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..ReferenceID.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | (Overrides GH_GeometricGoo<(Of <(<'T>)>)>..::..Value.)

See Also

GH_Surface Class
Grasshopper.Kernel.Types Namespace


Boundingbox Property

[image]

Grasshopper SDK
GH_Surface..::..Boundingbox Property
GH_Surface Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override BoundingBox Boundingbox { get; }
Visual Basic
Public Overrides ReadOnly Property Boundingbox As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Surface.Boundingbox"]

See Also

GH_Surface Class
Grasshopper.Kernel.Types Namespace


ClippingBox Property

[image]

Grasshopper SDK
GH_Surface..::..ClippingBox Property
GH_Surface Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public BoundingBox ClippingBox { get; }
Visual Basic
Public ReadOnly Property ClippingBox As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Surface.ClippingBox"]

Implements

IGH_PreviewData..::..ClippingBox

See Also

GH_Surface Class
Grasshopper.Kernel.Types Namespace


Face Property

[image]

Grasshopper SDK
GH_Surface..::..Face Property
GH_Surface Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public BrepFace Face { get; }
Visual Basic
Public ReadOnly Property Face As BrepFace
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Surface.Face"]

See Also

GH_Surface Class
Grasshopper.Kernel.Types Namespace


IsGeometryLoaded Property

[image]

Grasshopper SDK
GH_Surface..::..IsGeometryLoaded Property
GH_Surface Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool IsGeometryLoaded { get; }
Visual Basic
Public Overrides ReadOnly Property IsGeometryLoaded As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Surface.IsGeometryLoaded"]

See Also

GH_Surface Class
Grasshopper.Kernel.Types Namespace


IsValid Property

[image]

Grasshopper SDK
GH_Surface..::..IsValid Property
GH_Surface Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool IsValid { get; }
Visual Basic
Public Overrides ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Surface.IsValid"]

See Also

GH_Surface Class
Grasshopper.Kernel.Types Namespace


IsValidWhyNot Property

[image]

Grasshopper SDK
GH_Surface..::..IsValidWhyNot Property
GH_Surface Class See Also Send Feedback
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string IsValidWhyNot { get; }
Visual Basic
Public Overrides ReadOnly Property IsValidWhyNot As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Surface.IsValidWhyNot"]

See Also

GH_Surface Class
Grasshopper.Kernel.Types Namespace


ReferenceID Property

[image]

Grasshopper SDK
GH_Surface..::..ReferenceID Property
GH_Surface Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override Guid ReferenceID { get; set; }
Visual Basic
Public Overrides Property ReferenceID As Guid
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Surface.ReferenceID"]

See Also

GH_Surface Class
Grasshopper.Kernel.Types Namespace


TypeDescription Property

[image]

Grasshopper SDK
GH_Surface..::..TypeDescription Property
GH_Surface Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeDescription { get; }
Visual Basic
Public Overrides ReadOnly Property TypeDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Surface.TypeDescription"]

See Also

GH_Surface Class
Grasshopper.Kernel.Types Namespace


TypeName Property

[image]

Grasshopper SDK
GH_Surface..::..TypeName Property
GH_Surface Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeName { get; }
Visual Basic
Public Overrides ReadOnly Property TypeName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Surface.TypeName"]

See Also

GH_Surface Class
Grasshopper.Kernel.Types Namespace


Value Property

[image]

Grasshopper SDK
GH_Surface..::..Value Property
GH_Surface Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override Brep Value { get; set; }
Visual Basic
Public Overrides Property Value As Brep
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Surface.Value"]

See Also

GH_Surface Class
Grasshopper.Kernel.Types Namespace


GH_Surface.GH_SurfaceProxy Class

[image]

Grasshopper SDK
GH_Surface..::..GH_SurfaceProxy Class
GH_Surface Class Members See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_SurfaceProxy : GH_GooProxy<GH_Surface>
Visual Basic
Public Class GH_SurfaceProxy _
    Inherits GH_GooProxy(Of GH_Surface)

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_GooProxy <(Of <(<' GH_Surface >)>)>
Grasshopper.Kernel.Types..::..GH_Surface..::..GH_SurfaceProxy

See Also

GH_Surface..::..GH_SurfaceProxy Members
Grasshopper.Kernel.Types Namespace


GH_Surface.GH_SurfaceProxy Members

[image] [image]

Grasshopper SDK
GH_Surface..::..GH_SurfaceProxy Members
GH_Surface..::..GH_SurfaceProxy Class Constructors Methods Properties See Also Send Feedback

Represents a 3D (trimmed) surface. GH_Surface wraps the functionality of the OpenNURBS OnBrepFace class.

The GH_Surface..::..GH_SurfaceProxy type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Surface..::..GH_SurfaceProxy | Initializes a new instance of the GH_Surface..::..GH_SurfaceProxy class

Methods

 | Name | Description
Public method | Construct | (Overrides GH_GooProxy<(Of <(<'T>)>)>..::..Construct()()()().)
Public method | FormatInstance | Returns a String description of the current value. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FromString | (Overrides GH_GooProxy<(Of <(<'T>)>)>..::..FromString(String).)
Public method | MutateString | Munge a string to remove obvious errors on account of the user. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | NumberToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | StringToNumber | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | ToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Area |
Public property | Closed |
Public property | Deformable |
Public property | EdgeCount |
Public property | IsParsable | Gets a value indicating whether or not the type can be instantiated from a String. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | LoopCount |
Public property | ObjectID |
Protected property | Owner | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Periodic |
Public property | Planar |
Public property | ProxyOwner | Gets the piece of Grasshopper data that spawned this proxy. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Singular |
Public property | Solid |
Public property | Trimmed |
Public property | TypeDescription | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeName | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | UserString | Gets or sets the user-defined string that describes this proxy. This only really makes sense if the Proxy is Parsable. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Valid | Gets a value indicating whether this proxy represents valid data. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | VertexCount |
Public property | Volume |

See Also

GH_Surface..::..GH_SurfaceProxy Class
Grasshopper.Kernel.Types Namespace


GH_Surface.GH_SurfaceProxy Constructor

[image]

Grasshopper SDK
GH_Surface..::..GH_SurfaceProxy Constructor
GH_Surface..::..GH_SurfaceProxy Class See Also Send Feedback
Initializes a new instance of the GH_Surface..::..GH_SurfaceProxy class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_SurfaceProxy(
    GH_Surface Value
)
Visual Basic
Public Sub New ( _
    Value As GH_Surface _
)

Parameters

Value
Type: Grasshopper.Kernel.Types..::..GH_Surface

See Also

GH_Surface..::..GH_SurfaceProxy Class
Grasshopper.Kernel.Types Namespace


GH_Surface.GH_SurfaceProxy Methods

[image] [image]

Grasshopper SDK
GH_Surface..::..GH_SurfaceProxy Methods
GH_Surface..::..GH_SurfaceProxy Class See Also Send Feedback

The GH_Surface..::..GH_SurfaceProxy type exposes the following members.

Methods

 | Name | Description
Public method | Construct | (Overrides GH_GooProxy<(Of <(<'T>)>)>..::..Construct()()()().)
Public method | FormatInstance | Returns a String description of the current value. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FromString | (Overrides GH_GooProxy<(Of <(<'T>)>)>..::..FromString(String).)
Public method | MutateString | Munge a string to remove obvious errors on account of the user. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | NumberToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | StringToNumber | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | ToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)

See Also

GH_Surface..::..GH_SurfaceProxy Class
Grasshopper.Kernel.Types Namespace


Construct Method

[image]

Grasshopper SDK
GH_Surface..::..GH_SurfaceProxy..::..Construct Method
GH_Surface..::..GH_SurfaceProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void Construct()
Visual Basic
Public Overrides Sub Construct

See Also

GH_Surface..::..GH_SurfaceProxy Class
Grasshopper.Kernel.Types Namespace


FromString Method

[image]

Grasshopper SDK
GH_Surface..::..GH_SurfaceProxy..::..FromString Method
GH_Surface..::..GH_SurfaceProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool FromString(
    string in
)
Visual Basic
Public Overrides Function FromString ( _
    in As String _
) As Boolean

Parameters

in
Type: System..::..String

See Also

GH_Surface..::..GH_SurfaceProxy Class
Grasshopper.Kernel.Types Namespace


GH_Surface.GH_SurfaceProxy Properties

[image] [image]

Grasshopper SDK
GH_Surface..::..GH_SurfaceProxy Properties
GH_Surface..::..GH_SurfaceProxy Class See Also Send Feedback

The GH_Surface..::..GH_SurfaceProxy type exposes the following members.

Properties

 | Name | Description
Public property | Area |
Public property | Closed |
Public property | Deformable |
Public property | EdgeCount |
Public property | IsParsable | Gets a value indicating whether or not the type can be instantiated from a String. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | LoopCount |
Public property | ObjectID |
Protected property | Owner | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Periodic |
Public property | Planar |
Public property | ProxyOwner | Gets the piece of Grasshopper data that spawned this proxy. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Singular |
Public property | Solid |
Public property | Trimmed |
Public property | TypeDescription | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeName | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | UserString | Gets or sets the user-defined string that describes this proxy. This only really makes sense if the Proxy is Parsable. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Valid | Gets a value indicating whether this proxy represents valid data. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | VertexCount |
Public property | Volume |

See Also

GH_Surface..::..GH_SurfaceProxy Class
Grasshopper.Kernel.Types Namespace


Area Property

[image]

Grasshopper SDK
GH_Surface..::..GH_SurfaceProxy..::..Area Property
GH_Surface..::..GH_SurfaceProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Area { get; }
Visual Basic
Public ReadOnly Property Area As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Surface.GH_SurfaceProxy.Area"]

See Also

GH_Surface..::..GH_SurfaceProxy Class
Grasshopper.Kernel.Types Namespace


Closed Property

[image]

Grasshopper SDK
GH_Surface..::..GH_SurfaceProxy..::..Closed Property
GH_Surface..::..GH_SurfaceProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Closed { get; }
Visual Basic
Public ReadOnly Property Closed As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Surface.GH_SurfaceProxy.Closed"]

See Also

GH_Surface..::..GH_SurfaceProxy Class
Grasshopper.Kernel.Types Namespace


Deformable Property

[image]

Grasshopper SDK
GH_Surface..::..GH_SurfaceProxy..::..Deformable Property
GH_Surface..::..GH_SurfaceProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Deformable { get; }
Visual Basic
Public ReadOnly Property Deformable As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Surface.GH_SurfaceProxy.Deformable"]

See Also

GH_Surface..::..GH_SurfaceProxy Class
Grasshopper.Kernel.Types Namespace


EdgeCount Property

[image]

Grasshopper SDK
GH_Surface..::..GH_SurfaceProxy..::..EdgeCount Property
GH_Surface..::..GH_SurfaceProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int EdgeCount { get; }
Visual Basic
Public ReadOnly Property EdgeCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Surface.GH_SurfaceProxy.EdgeCount"]

See Also

GH_Surface..::..GH_SurfaceProxy Class
Grasshopper.Kernel.Types Namespace


LoopCount Property

[image]

Grasshopper SDK
GH_Surface..::..GH_SurfaceProxy..::..LoopCount Property
GH_Surface..::..GH_SurfaceProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int LoopCount { get; }
Visual Basic
Public ReadOnly Property LoopCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Surface.GH_SurfaceProxy.LoopCount"]

See Also

GH_Surface..::..GH_SurfaceProxy Class
Grasshopper.Kernel.Types Namespace


ObjectID Property

[image]

Grasshopper SDK
GH_Surface..::..GH_SurfaceProxy..::..ObjectID Property
GH_Surface..::..GH_SurfaceProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string ObjectID { get; set; }
Visual Basic
Public Property ObjectID As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Surface.GH_SurfaceProxy.ObjectID"]

See Also

GH_Surface..::..GH_SurfaceProxy Class
Grasshopper.Kernel.Types Namespace


Periodic Property

[image]

Grasshopper SDK
GH_Surface..::..GH_SurfaceProxy..::..Periodic Property
GH_Surface..::..GH_SurfaceProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Periodic { get; }
Visual Basic
Public ReadOnly Property Periodic As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Surface.GH_SurfaceProxy.Periodic"]

See Also

GH_Surface..::..GH_SurfaceProxy Class
Grasshopper.Kernel.Types Namespace


Planar Property

[image]

Grasshopper SDK
GH_Surface..::..GH_SurfaceProxy..::..Planar Property
GH_Surface..::..GH_SurfaceProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Planar { get; }
Visual Basic
Public ReadOnly Property Planar As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Surface.GH_SurfaceProxy.Planar"]

See Also

GH_Surface..::..GH_SurfaceProxy Class
Grasshopper.Kernel.Types Namespace


Singular Property

[image]

Grasshopper SDK
GH_Surface..::..GH_SurfaceProxy..::..Singular Property
GH_Surface..::..GH_SurfaceProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Singular { get; }
Visual Basic
Public ReadOnly Property Singular As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Surface.GH_SurfaceProxy.Singular"]

See Also

GH_Surface..::..GH_SurfaceProxy Class
Grasshopper.Kernel.Types Namespace


Solid Property

[image]

Grasshopper SDK
GH_Surface..::..GH_SurfaceProxy..::..Solid Property
GH_Surface..::..GH_SurfaceProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Solid { get; }
Visual Basic
Public ReadOnly Property Solid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Surface.GH_SurfaceProxy.Solid"]

See Also

GH_Surface..::..GH_SurfaceProxy Class
Grasshopper.Kernel.Types Namespace


Trimmed Property

[image]

Grasshopper SDK
GH_Surface..::..GH_SurfaceProxy..::..Trimmed Property
GH_Surface..::..GH_SurfaceProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Trimmed { get; }
Visual Basic
Public ReadOnly Property Trimmed As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Surface.GH_SurfaceProxy.Trimmed"]

See Also

GH_Surface..::..GH_SurfaceProxy Class
Grasshopper.Kernel.Types Namespace


VertexCount Property

[image]

Grasshopper SDK
GH_Surface..::..GH_SurfaceProxy..::..VertexCount Property
GH_Surface..::..GH_SurfaceProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int VertexCount { get; }
Visual Basic
Public ReadOnly Property VertexCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Surface.GH_SurfaceProxy.VertexCount"]

See Also

GH_Surface..::..GH_SurfaceProxy Class
Grasshopper.Kernel.Types Namespace


Volume Property

[image]

Grasshopper SDK
GH_Surface..::..GH_SurfaceProxy..::..Volume Property
GH_Surface..::..GH_SurfaceProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Volume { get; }
Visual Basic
Public ReadOnly Property Volume As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Surface.GH_SurfaceProxy.Volume"]

See Also

GH_Surface..::..GH_SurfaceProxy Class
Grasshopper.Kernel.Types Namespace


GH_Time Class

[image]

Grasshopper SDK
GH_Time Class
Members See Also Send Feedback
Represents a date and time. GH_Time re-implements the framework System.DateTime type.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Time : GH_Goo<DateTime>
Visual Basic
Public Class GH_Time _
    Inherits GH_Goo(Of DateTime)

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_Goo <(Of <(<' DateTime >)>)>
Grasshopper.Kernel.Types..::..GH_Time

See Also

GH_Time Members
Grasshopper.Kernel.Types Namespace


GH_Time Members

[image] [image]

Grasshopper SDK
GH_Time Members
GH_Time Class Constructors Methods Fields Properties See Also Send Feedback

The GH_Time type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Time()()()() | Blank constructor
Public method | GH_Time(DateTime) | Initializes a new instance of the GH_Time class
Public method | GH_Time(GH_Time) | Initializes a new instance of the GH_Time class

Methods

 | Name | Description
Public method | CastFrom | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | Duplicate | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateDateTime |
Public method | EmitProxy | (Overrides GH_Goo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ToString | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | IsValid | Gets the validity of this instance. Datetime is valid if it's not equal to DateTime.MaxValue (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the internal data. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Time Class
Grasshopper.Kernel.Types Namespace


GH_Time Constructor

[image] [image]

Grasshopper SDK
GH_Time Constructor
GH_Time Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Time()()()() | Blank constructor
Public method | GH_Time(DateTime) | Initializes a new instance of the GH_Time class
Public method | GH_Time(GH_Time) | Initializes a new instance of the GH_Time class

See Also

GH_Time Class
GH_Time Members
Grasshopper.Kernel.Types Namespace


GH_Time Constructor

[image]

Grasshopper SDK
GH_Time Constructor
GH_Time Class See Also Send Feedback
Blank constructor

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Time()
Visual Basic
Public Sub New

See Also

GH_Time Class
GH_Time Overload
Grasshopper.Kernel.Types Namespace


GH_Time Constructor (DateTime)

[image]

Grasshopper SDK
GH_Time Constructor (DateTime)
GH_Time Class See Also Send Feedback
Initializes a new instance of the GH_Time class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Time(
    DateTime time
)
Visual Basic
Public Sub New ( _
    time As DateTime _
)

Parameters

time
Type: System..::..DateTime

See Also

GH_Time Class
GH_Time Overload
Grasshopper.Kernel.Types Namespace


GH_Time Constructor (GH_Time)

[image]

Grasshopper SDK
GH_Time Constructor (GH_Time)
GH_Time Class See Also Send Feedback
Initializes a new instance of the GH_Time class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Time(
    GH_Time other
)
Visual Basic
Public Sub New ( _
    other As GH_Time _
)

Parameters

other
Type: Grasshopper.Kernel.Types..::..GH_Time

See Also

GH_Time Class
GH_Time Overload
Grasshopper.Kernel.Types Namespace


GH_Time Fields

[image] [image]

Grasshopper SDK
GH_Time Fields
GH_Time Class See Also Send Feedback

The GH_Time type exposes the following members.

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Time Class
Grasshopper.Kernel.Types Namespace


GH_Time Methods

[image] [image]

Grasshopper SDK
GH_Time Methods
GH_Time Class See Also Send Feedback

The GH_Time type exposes the following members.

Methods

 | Name | Description
Public method | CastFrom | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | Duplicate | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateDateTime |
Public method | EmitProxy | (Overrides GH_Goo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ToString | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

See Also

GH_Time Class
Grasshopper.Kernel.Types Namespace


CastFrom Method

[image]

Grasshopper SDK
GH_Time..::..CastFrom Method
GH_Time Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastFrom(
    Object source
)
Visual Basic
Public Overrides Function CastFrom ( _
    source As Object _
) As Boolean

Parameters

source
Type: System..::..Object

See Also

GH_Time Class
Grasshopper.Kernel.Types Namespace


CastTo Method

[image] [image]

Grasshopper SDK
GH_Time..::..CastTo Method
GH_Time Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)

See Also

GH_Time Class
GH_Time Members
Grasshopper.Kernel.Types Namespace


CastTo(T) Method (T)

[image]

Grasshopper SDK
GH_Time..::..CastTo<(Of <(<'T>)>)> Method (T%)
GH_Time Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastTo<T>(
    out T target
)
Visual Basic
Public Overrides Function CastTo(Of T) ( _
    <OutAttribute> ByRef target As T _
) As Boolean

Parameters

target
Type: T%

Type Parameters

T

See Also

GH_Time Class
CastTo Overload
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_Time..::..Duplicate Method
GH_Time Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_Goo Duplicate()
Visual Basic
Public Overrides Function Duplicate As IGH_Goo

See Also

GH_Time Class
Grasshopper.Kernel.Types Namespace


DuplicateDateTime Method

[image]

Grasshopper SDK
GH_Time..::..DuplicateDateTime Method
GH_Time Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Time DuplicateDateTime()
Visual Basic
Public Function DuplicateDateTime As GH_Time

See Also

GH_Time Class
Grasshopper.Kernel.Types Namespace


EmitProxy Method

[image]

Grasshopper SDK
GH_Time..::..EmitProxy Method
GH_Time Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GooProxy EmitProxy()
Visual Basic
Public Overrides Function EmitProxy As IGH_GooProxy

See Also

GH_Time Class
Grasshopper.Kernel.Types Namespace


Read Method

[image]

Grasshopper SDK
GH_Time..::..Read Method
GH_Time Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

See Also

GH_Time Class
Grasshopper.Kernel.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_Time..::..ToString Method
GH_Time Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_Time Class
Grasshopper.Kernel.Types Namespace


Write Method

[image]

Grasshopper SDK
GH_Time..::..Write Method
GH_Time Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overrides Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

See Also

GH_Time Class
Grasshopper.Kernel.Types Namespace


GH_Time Properties

[image] [image]

Grasshopper SDK
GH_Time Properties
GH_Time Class See Also Send Feedback

The GH_Time type exposes the following members.

Properties

 | Name | Description
Public property | IsValid | Gets the validity of this instance. Datetime is valid if it's not equal to DateTime.MaxValue (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the internal data. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Time Class
Grasshopper.Kernel.Types Namespace


IsValid Property

[image]

Grasshopper SDK
GH_Time..::..IsValid Property
GH_Time Class See Also Send Feedback
Gets the validity of this instance. Datetime is valid if it's not equal to DateTime.MaxValue

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool IsValid { get; }
Visual Basic
Public Overrides ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Time.IsValid"]

See Also

GH_Time Class
Grasshopper.Kernel.Types Namespace


IsValidWhyNot Property

[image]

Grasshopper SDK
GH_Time..::..IsValidWhyNot Property
GH_Time Class See Also Send Feedback
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string IsValidWhyNot { get; }
Visual Basic
Public Overrides ReadOnly Property IsValidWhyNot As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Time.IsValidWhyNot"]

See Also

GH_Time Class
Grasshopper.Kernel.Types Namespace


TypeDescription Property

[image]

Grasshopper SDK
GH_Time..::..TypeDescription Property
GH_Time Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeDescription { get; }
Visual Basic
Public Overrides ReadOnly Property TypeDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Time.TypeDescription"]

See Also

GH_Time Class
Grasshopper.Kernel.Types Namespace


TypeName Property

[image]

Grasshopper SDK
GH_Time..::..TypeName Property
GH_Time Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeName { get; }
Visual Basic
Public Overrides ReadOnly Property TypeName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Time.TypeName"]

See Also

GH_Time Class
Grasshopper.Kernel.Types Namespace


GH_Transform Class

[image]

Grasshopper SDK
GH_Transform Class
Members See Also Send Feedback
Represents a collection of transformations.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Transform : GH_Goo<Transform>
Visual Basic
Public Class GH_Transform _
    Inherits GH_Goo(Of Transform)

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_Goo <(Of <(<'Transform>)>)>
Grasshopper.Kernel.Types..::..GH_Transform

See Also

GH_Transform Members
Grasshopper.Kernel.Types Namespace


GH_Transform Members

[image] [image]

Grasshopper SDK
GH_Transform Members
GH_Transform Class Constructors Methods Fields Properties See Also Send Feedback

The GH_Transform type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Transform()()()() | Initializes a new instance of the GH_Transform class
Public method | GH_Transform(Transform) | Initializes a new instance of the GH_Transform class
Public method | GH_Transform(GH_Transform) | Initializes a new instance of the GH_Transform class
Public method | GH_Transform(ITransform) | Initializes a new instance of the GH_Transform class

Methods

 | Name | Description
Public method | CastFrom | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | ClearCaches | Erase the compound transformation caches.
Public method | Duplicate | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | EmitProxy | Returns a proxy that represents this transform. Do not call this function unless you're (Overrides GH_Goo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | GetInverse |
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ScriptVariable()()()().)
Public method | ToString | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | CompoundTransforms | Gets the internal set of transforms. If you modify the compound transformations, you must call ClearCaches().
Public property | IsValid | (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Value.)

See Also

GH_Transform Class
Grasshopper.Kernel.Types Namespace


GH_Transform Constructor

[image] [image]

Grasshopper SDK
GH_Transform Constructor
GH_Transform Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Transform()()()() | Initializes a new instance of the GH_Transform class
Public method | GH_Transform(Transform) | Initializes a new instance of the GH_Transform class
Public method | GH_Transform(GH_Transform) | Initializes a new instance of the GH_Transform class
Public method | GH_Transform(ITransform) | Initializes a new instance of the GH_Transform class

See Also

GH_Transform Class
GH_Transform Members
Grasshopper.Kernel.Types Namespace


GH_Transform Constructor

[image]

Grasshopper SDK
GH_Transform Constructor
GH_Transform Class See Also Send Feedback
Initializes a new instance of the GH_Transform class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Transform()
Visual Basic
Public Sub New

See Also

GH_Transform Class
GH_Transform Overload
Grasshopper.Kernel.Types Namespace


GH_Transform Constructor ()

[image]

Grasshopper SDK
GH_Transform Constructor ()
GH_Transform Class See Also Send Feedback
Initializes a new instance of the GH_Transform class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Transform(
    Transform transform
)
Visual Basic
Public Sub New ( _
    transform As Transform _
)

Parameters

transform
Type: Transform

See Also

GH_Transform Class
GH_Transform Overload
Grasshopper.Kernel.Types Namespace


GH_Transform Constructor (GH_Transform)

[image]

Grasshopper SDK
GH_Transform Constructor (GH_Transform)
GH_Transform Class See Also Send Feedback
Initializes a new instance of the GH_Transform class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Transform(
    GH_Transform other
)
Visual Basic
Public Sub New ( _
    other As GH_Transform _
)

Parameters

other
Type: Grasshopper.Kernel.Types..::..GH_Transform

See Also

GH_Transform Class
GH_Transform Overload
Grasshopper.Kernel.Types Namespace


GH_Transform Constructor (ITransform)

[image]

Grasshopper SDK
GH_Transform Constructor (ITransform)
GH_Transform Class See Also Send Feedback
Initializes a new instance of the GH_Transform class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Transform(
    ITransform transform
)
Visual Basic
Public Sub New ( _
    transform As ITransform _
)

Parameters

transform
Type: Grasshopper.Kernel.Types.Transforms..::..ITransform

See Also

GH_Transform Class
GH_Transform Overload
Grasshopper.Kernel.Types Namespace


GH_Transform Fields

[image] [image]

Grasshopper SDK
GH_Transform Fields
GH_Transform Class See Also Send Feedback

The GH_Transform type exposes the following members.

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Transform Class
Grasshopper.Kernel.Types Namespace


GH_Transform Methods

[image] [image]

Grasshopper SDK
GH_Transform Methods
GH_Transform Class See Also Send Feedback

The GH_Transform type exposes the following members.

Methods

 | Name | Description
Public method | CastFrom | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | ClearCaches | Erase the compound transformation caches.
Public method | Duplicate | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | EmitProxy | Returns a proxy that represents this transform. Do not call this function unless you're (Overrides GH_Goo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | GetInverse |
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ScriptVariable()()()().)
Public method | ToString | (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

See Also

GH_Transform Class
Grasshopper.Kernel.Types Namespace


CastFrom Method

[image]

Grasshopper SDK
GH_Transform..::..CastFrom Method
GH_Transform Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastFrom(
    Object source
)
Visual Basic
Public Overrides Function CastFrom ( _
    source As Object _
) As Boolean

Parameters

source
Type: System..::..Object

See Also

GH_Transform Class
Grasshopper.Kernel.Types Namespace


CastTo Method

[image] [image]

Grasshopper SDK
GH_Transform..::..CastTo Method
GH_Transform Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)

See Also

GH_Transform Class
GH_Transform Members
Grasshopper.Kernel.Types Namespace


CastTo(Q) Method (Q)

[image]

Grasshopper SDK
GH_Transform..::..CastTo<(Of <(<'Q>)>)> Method (Q%)
GH_Transform Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastTo<Q>(
    ref Q target
)
Visual Basic
Public Overrides Function CastTo(Of Q) ( _
    ByRef target As Q _
) As Boolean

Parameters

target
Type: Q%

Type Parameters

Q

See Also

GH_Transform Class
CastTo Overload
Grasshopper.Kernel.Types Namespace


ClearCaches Method

[image]

Grasshopper SDK
GH_Transform..::..ClearCaches Method
GH_Transform Class See Also Send Feedback
Erase the compound transformation caches.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ClearCaches()
Visual Basic
Public Sub ClearCaches

See Also

GH_Transform Class
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_Transform..::..Duplicate Method
GH_Transform Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_Goo Duplicate()
Visual Basic
Public Overrides Function Duplicate As IGH_Goo

See Also

GH_Transform Class
Grasshopper.Kernel.Types Namespace


EmitProxy Method

[image]

Grasshopper SDK
GH_Transform..::..EmitProxy Method
GH_Transform Class See Also Send Feedback
Returns a proxy that represents this transform. Do not call this function unless you're

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GooProxy EmitProxy()
Visual Basic
Public Overrides Function EmitProxy As IGH_GooProxy

See Also

GH_Transform Class
Grasshopper.Kernel.Types Namespace


GetInverse Method

[image]

Grasshopper SDK
GH_Transform..::..GetInverse Method
GH_Transform Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Transform GetInverse()
Visual Basic
Public Function GetInverse As GH_Transform

See Also

GH_Transform Class
Grasshopper.Kernel.Types Namespace


Read Method

[image]

Grasshopper SDK
GH_Transform..::..Read Method
GH_Transform Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

See Also

GH_Transform Class
Grasshopper.Kernel.Types Namespace


ScriptVariable Method

[image]

Grasshopper SDK
GH_Transform..::..ScriptVariable Method
GH_Transform Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override Object ScriptVariable()
Visual Basic
Public Overrides Function ScriptVariable As Object

See Also

GH_Transform Class
Grasshopper.Kernel.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_Transform..::..ToString Method
GH_Transform Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_Transform Class
Grasshopper.Kernel.Types Namespace


Write Method

[image]

Grasshopper SDK
GH_Transform..::..Write Method
GH_Transform Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overrides Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

See Also

GH_Transform Class
Grasshopper.Kernel.Types Namespace


GH_Transform Properties

[image] [image]

Grasshopper SDK
GH_Transform Properties
GH_Transform Class See Also Send Feedback

The GH_Transform type exposes the following members.

Properties

 | Name | Description
Public property | CompoundTransforms | Gets the internal set of transforms. If you modify the compound transformations, you must call ClearCaches().
Public property | IsValid | (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValidWhyNot.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Value.)

See Also

GH_Transform Class
Grasshopper.Kernel.Types Namespace


CompoundTransforms Property

[image]

Grasshopper SDK
GH_Transform..::..CompoundTransforms Property
GH_Transform Class See Also Send Feedback
Gets the internal set of transforms. If you modify the compound transformations, you must call ClearCaches().

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<ITransform> CompoundTransforms { get; }
Visual Basic
Public ReadOnly Property CompoundTransforms As List(Of ITransform)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Transform.CompoundTransforms"]

See Also

GH_Transform Class
Grasshopper.Kernel.Types Namespace


IsValid Property

[image]

Grasshopper SDK
GH_Transform..::..IsValid Property
GH_Transform Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool IsValid { get; }
Visual Basic
Public Overrides ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Transform.IsValid"]

See Also

GH_Transform Class
Grasshopper.Kernel.Types Namespace


IsValidWhyNot Property

[image]

Grasshopper SDK
GH_Transform..::..IsValidWhyNot Property
GH_Transform Class See Also Send Feedback
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string IsValidWhyNot { get; }
Visual Basic
Public Overrides ReadOnly Property IsValidWhyNot As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Transform.IsValidWhyNot"]

See Also

GH_Transform Class
Grasshopper.Kernel.Types Namespace


TypeDescription Property

[image]

Grasshopper SDK
GH_Transform..::..TypeDescription Property
GH_Transform Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeDescription { get; }
Visual Basic
Public Overrides ReadOnly Property TypeDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Transform.TypeDescription"]

See Also

GH_Transform Class
Grasshopper.Kernel.Types Namespace


TypeName Property

[image]

Grasshopper SDK
GH_Transform..::..TypeName Property
GH_Transform Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeName { get; }
Visual Basic
Public Overrides ReadOnly Property TypeName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Transform.TypeName"]

See Also

GH_Transform Class
Grasshopper.Kernel.Types Namespace


Value Property

[image]

Grasshopper SDK
GH_Transform..::..Value Property
GH_Transform Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override Transform Value { get; set; }
Visual Basic
Public Overrides Property Value As Transform
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Transform.Value"]

See Also

GH_Transform Class
Grasshopper.Kernel.Types Namespace


GH_Vector Class

[image]

Grasshopper SDK
GH_Vector Class
Members See Also Send Feedback
Represents a 3D vector. GH_Vector re-implements the OpenNURBS On3dVector class.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_Vector : GH_Goo<Vector3d>,
    IGH_QuickCast
Visual Basic
Public Class GH_Vector _
    Inherits GH_Goo(Of Vector3d) _
    Implements IGH_QuickCast

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_Goo <(Of <(<'Vector3d>)>)>
Grasshopper.Kernel.Types..::..GH_Vector

See Also

GH_Vector Members
Grasshopper.Kernel.Types Namespace


GH_Vector Members

[image] [image]

Grasshopper SDK
GH_Vector Members
GH_Vector Class Constructors Methods Fields Properties See Also Send Feedback

The GH_Vector type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Vector()()()() | Default constructor. Creates a zero-length vector.
Public method | GH_Vector(Vector3d) | Create a vector from x, y and z components.
Public method | GH_Vector(GH_Vector) | Create a duplicate of another vector

Methods

 | Name | Description
Public method | CastFrom | Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic. (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic. (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | Duplicate | Create a duplicate of this vector. (Overrides GH_Goo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateVector | Create a duplicate of this vector.
Public method | EmitProxy | Returns a proxy that represents this vector. Do not call this function unless you're (Overrides GH_Goo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ToString | Format the vector using default grasshopper formatting logic. (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | IsValid | (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the internal data. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Vector Class
Grasshopper.Kernel.Types Namespace


GH_Vector Constructor

[image] [image]

Grasshopper SDK
GH_Vector Constructor
GH_Vector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_Vector()()()() | Default constructor. Creates a zero-length vector.
Public method | GH_Vector(Vector3d) | Create a vector from x, y and z components.
Public method | GH_Vector(GH_Vector) | Create a duplicate of another vector

See Also

GH_Vector Class
GH_Vector Members
Grasshopper.Kernel.Types Namespace


GH_Vector Constructor

[image]

Grasshopper SDK
GH_Vector Constructor
GH_Vector Class See Also Send Feedback
Default constructor. Creates a zero-length vector.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Vector()
Visual Basic
Public Sub New

See Also

GH_Vector Class
GH_Vector Overload
Grasshopper.Kernel.Types Namespace


GH_Vector Constructor ()

[image]

Grasshopper SDK
GH_Vector Constructor ()
GH_Vector Class See Also Send Feedback
Create a vector from x, y and z components.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Vector(
    Vector3d vector
)
Visual Basic
Public Sub New ( _
    vector As Vector3d _
)

Parameters

vector
Type: Vector3d
Vector to wrap.

See Also

GH_Vector Class
GH_Vector Overload
Grasshopper.Kernel.Types Namespace


GH_Vector Constructor (GH_Vector)

[image]

Grasshopper SDK
GH_Vector Constructor (GH_Vector)
GH_Vector Class See Also Send Feedback
Create a duplicate of another vector

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Vector(
    GH_Vector other
)
Visual Basic
Public Sub New ( _
    other As GH_Vector _
)

Parameters

other
Type: Grasshopper.Kernel.Types..::..GH_Vector
Vector to copy. If null, a default vector will be created.

See Also

GH_Vector Class
GH_Vector Overload
Grasshopper.Kernel.Types Namespace


GH_Vector Fields

[image] [image]

Grasshopper SDK
GH_Vector Fields
GH_Vector Class See Also Send Feedback

The GH_Vector type exposes the following members.

Fields

 | Name | Description
Protected field | m_value | (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Vector Class
Grasshopper.Kernel.Types Namespace


GH_Vector Methods

[image] [image]

Grasshopper SDK
GH_Vector Methods
GH_Vector Class See Also Send Feedback

The GH_Vector type exposes the following members.

Methods

 | Name | Description
Public method | CastFrom | Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic. (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastFrom(Object).)
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic. (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)
Public method | Duplicate | Create a duplicate of this vector. (Overrides GH_Goo<(Of <(<'T>)>)>..::..Duplicate()()()().)
Public method | DuplicateVector | Create a duplicate of this vector.
Public method | EmitProxy | Returns a proxy that represents this vector. Do not call this function unless you're (Overrides GH_Goo<(Of <(<'T>)>)>..::..EmitProxy()()()().)
Public method | Read | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Read(GH_IReader).)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | ToString | Format the vector using default grasshopper formatting logic. (Overrides GH_Goo<(Of <(<'T>)>)>..::..ToString()()()().)
Public method | Write | (Overrides GH_Goo<(Of <(<'T>)>)>..::..Write(GH_IWriter).)

See Also

GH_Vector Class
Grasshopper.Kernel.Types Namespace


CastFrom Method

[image]

Grasshopper SDK
GH_Vector..::..CastFrom Method
GH_Vector Class See Also Send Feedback
Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastFrom(
    Object source
)
Visual Basic
Public Overrides Function CastFrom ( _
    source As Object _
) As Boolean

Parameters

source
Type: System..::..Object

See Also

GH_Vector Class
Grasshopper.Kernel.Types Namespace


CastTo Method

[image] [image]

Grasshopper SDK
GH_Vector..::..CastTo Method
GH_Vector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CastTo<(Of <<'(Q>)>>)(Q%) | Attempt a cast to type Q. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public method | CastTo<(Of <<'(T>)>>)(T%) | Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic. (Overrides GH_Goo<(Of <(<'T>)>)>..::..CastTo<(Of <<'(Q>)>>)(Q%).)

See Also

GH_Vector Class
GH_Vector Members
Grasshopper.Kernel.Types Namespace


CastTo(T) Method (T)

[image]

Grasshopper SDK
GH_Vector..::..CastTo<(Of <(<'T>)>)> Method (T%)
GH_Vector Class See Also Send Feedback
Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool CastTo<T>(
    out T target
)
Visual Basic
Public Overrides Function CastTo(Of T) ( _
    <OutAttribute> ByRef target As T _
) As Boolean

Parameters

target
Type: T%

Type Parameters

T

See Also

GH_Vector Class
CastTo Overload
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_Vector..::..Duplicate Method
GH_Vector Class See Also Send Feedback
Create a duplicate of this vector.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_Goo Duplicate()
Visual Basic
Public Overrides Function Duplicate As IGH_Goo

See Also

GH_Vector Class
Grasshopper.Kernel.Types Namespace


DuplicateVector Method

[image]

Grasshopper SDK
GH_Vector..::..DuplicateVector Method
GH_Vector Class See Also Send Feedback
Create a duplicate of this vector.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_Vector DuplicateVector()
Visual Basic
Public Function DuplicateVector As GH_Vector

See Also

GH_Vector Class
Grasshopper.Kernel.Types Namespace


EmitProxy Method

[image]

Grasshopper SDK
GH_Vector..::..EmitProxy Method
GH_Vector Class See Also Send Feedback
Returns a proxy that represents this vector. Do not call this function unless you're

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_GooProxy EmitProxy()
Visual Basic
Public Overrides Function EmitProxy As IGH_GooProxy

See Also

GH_Vector Class
Grasshopper.Kernel.Types Namespace


Read Method

[image]

Grasshopper SDK
GH_Vector..::..Read Method
GH_Vector Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

See Also

GH_Vector Class
Grasshopper.Kernel.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_Vector..::..ToString Method
GH_Vector Class See Also Send Feedback
Format the vector using default grasshopper formatting logic.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_Vector Class
Grasshopper.Kernel.Types Namespace


Write Method

[image]

Grasshopper SDK
GH_Vector..::..Write Method
GH_Vector Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overrides Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

See Also

GH_Vector Class
Grasshopper.Kernel.Types Namespace


GH_Vector Properties

[image] [image]

Grasshopper SDK
GH_Vector Properties
GH_Vector Class See Also Send Feedback

The GH_Vector type exposes the following members.

Properties

 | Name | Description
Public property | IsValid | (Overrides GH_Goo<(Of <(<'T>)>)>..::..IsValid.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Inherited from GH_Goo<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeDescription.)
Public property | TypeName | (Overrides GH_Goo<(Of <(<'T>)>)>..::..TypeName.)
Public property | Value | Gets or sets the internal data. (Inherited from GH_Goo<(Of <(<'T>)>)>.)

See Also

GH_Vector Class
Grasshopper.Kernel.Types Namespace


IsValid Property

[image]

Grasshopper SDK
GH_Vector..::..IsValid Property
GH_Vector Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool IsValid { get; }
Visual Basic
Public Overrides ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Vector.IsValid"]

See Also

GH_Vector Class
Grasshopper.Kernel.Types Namespace


TypeDescription Property

[image]

Grasshopper SDK
GH_Vector..::..TypeDescription Property
GH_Vector Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeDescription { get; }
Visual Basic
Public Overrides ReadOnly Property TypeDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Vector.TypeDescription"]

See Also

GH_Vector Class
Grasshopper.Kernel.Types Namespace


TypeName Property

[image]

Grasshopper SDK
GH_Vector..::..TypeName Property
GH_Vector Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string TypeName { get; }
Visual Basic
Public Overrides ReadOnly Property TypeName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Vector.TypeName"]

See Also

GH_Vector Class
Grasshopper.Kernel.Types Namespace


GH_Vector.GH_VectorProxy Class

[image]

Grasshopper SDK
GH_Vector..::..GH_VectorProxy Class
GH_Vector Class Members See Also Send Feedback
Proxy description of GH_Vector class. This class is used by the Generic Multivalue interfaces.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_VectorProxy : GH_GooProxy<GH_Vector>
Visual Basic
Public Class GH_VectorProxy _
    Inherits GH_GooProxy(Of GH_Vector)

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_GooProxy <(Of <(<' GH_Vector >)>)>
Grasshopper.Kernel.Types..::..GH_Vector..::..GH_VectorProxy

See Also

GH_Vector..::..GH_VectorProxy Members
Grasshopper.Kernel.Types Namespace


GH_Vector.GH_VectorProxy Members

[image] [image]

Grasshopper SDK
GH_Vector..::..GH_VectorProxy Members
GH_Vector..::..GH_VectorProxy Class Constructors Methods Properties See Also Send Feedback

Represents a 3D vector. GH_Vector re-implements the OpenNURBS On3dVector class.

The GH_Vector..::..GH_VectorProxy type exposes the following members.

Constructors

 | Name | Description
Public method | GH_Vector..::..GH_VectorProxy | Initializes a new instance of the GH_Vector..::..GH_VectorProxy class

Methods

 | Name | Description
Public method | Construct | (Overrides GH_GooProxy<(Of <(<'T>)>)>..::..Construct()()()().)
Public method | FormatInstance | Returns a String description of the current value. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FromString | (Overrides GH_GooProxy<(Of <(<'T>)>)>..::..FromString(String).)
Public method | MutateString | Munge a string to remove obvious errors on account of the user. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | NumberToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | StringToNumber | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | ToString | (Overrides GH_GooProxy<(Of <(<'T>)>)>..::..ToString()()()().)

Properties

 | Name | Description
Public property | IsParsable | (Overrides GH_GooProxy<(Of <(<'T>)>)>..::..IsParsable.)
Public property | Length |
Protected property | Owner | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | ProxyOwner | Gets the piece of Grasshopper data that spawned this proxy. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeName | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | UserString | Gets or sets the user-defined string that describes this proxy. This only really makes sense if the Proxy is Parsable. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Valid | Gets a value indicating whether this proxy represents valid data. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | X |
Public property | Y |
Public property | Z |

See Also

GH_Vector..::..GH_VectorProxy Class
Grasshopper.Kernel.Types Namespace


GH_Vector.GH_VectorProxy Constructor

[image]

Grasshopper SDK
GH_Vector..::..GH_VectorProxy Constructor
GH_Vector..::..GH_VectorProxy Class See Also Send Feedback
Initializes a new instance of the GH_Vector..::..GH_VectorProxy class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_VectorProxy(
    GH_Vector nOwner
)
Visual Basic
Public Sub New ( _
    nOwner As GH_Vector _
)

Parameters

nOwner
Type: Grasshopper.Kernel.Types..::..GH_Vector

See Also

GH_Vector..::..GH_VectorProxy Class
Grasshopper.Kernel.Types Namespace


GH_Vector.GH_VectorProxy Methods

[image] [image]

Grasshopper SDK
GH_Vector..::..GH_VectorProxy Methods
GH_Vector..::..GH_VectorProxy Class See Also Send Feedback

The GH_Vector..::..GH_VectorProxy type exposes the following members.

Methods

 | Name | Description
Public method | Construct | (Overrides GH_GooProxy<(Of <(<'T>)>)>..::..Construct()()()().)
Public method | FormatInstance | Returns a String description of the current value. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | FromString | (Overrides GH_GooProxy<(Of <(<'T>)>)>..::..FromString(String).)
Public method | MutateString | Munge a string to remove obvious errors on account of the user. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | NumberToString | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Protected method | StringToNumber | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public method | ToString | (Overrides GH_GooProxy<(Of <(<'T>)>)>..::..ToString()()()().)

See Also

GH_Vector..::..GH_VectorProxy Class
Grasshopper.Kernel.Types Namespace


Construct Method

[image]

Grasshopper SDK
GH_Vector..::..GH_VectorProxy..::..Construct Method
GH_Vector..::..GH_VectorProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void Construct()
Visual Basic
Public Overrides Sub Construct

See Also

GH_Vector..::..GH_VectorProxy Class
Grasshopper.Kernel.Types Namespace


FromString Method

[image]

Grasshopper SDK
GH_Vector..::..GH_VectorProxy..::..FromString Method
GH_Vector..::..GH_VectorProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool FromString(
    string in
)
Visual Basic
Public Overrides Function FromString ( _
    in As String _
) As Boolean

Parameters

in
Type: System..::..String

See Also

GH_Vector..::..GH_VectorProxy Class
Grasshopper.Kernel.Types Namespace


ToString Method

[image]

Grasshopper SDK
GH_Vector..::..GH_VectorProxy..::..ToString Method
GH_Vector..::..GH_VectorProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

GH_Vector..::..GH_VectorProxy Class
Grasshopper.Kernel.Types Namespace


GH_Vector.GH_VectorProxy Properties

[image] [image]

Grasshopper SDK
GH_Vector..::..GH_VectorProxy Properties
GH_Vector..::..GH_VectorProxy Class See Also Send Feedback

The GH_Vector..::..GH_VectorProxy type exposes the following members.

Properties

 | Name | Description
Public property | IsParsable | (Overrides GH_GooProxy<(Of <(<'T>)>)>..::..IsParsable.)
Public property | Length |
Protected property | Owner | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | ProxyOwner | Gets the piece of Grasshopper data that spawned this proxy. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeDescription | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | TypeName | (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | UserString | Gets or sets the user-defined string that describes this proxy. This only really makes sense if the Proxy is Parsable. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | Valid | Gets a value indicating whether this proxy represents valid data. (Inherited from GH_GooProxy<(Of <(<'T>)>)>.)
Public property | X |
Public property | Y |
Public property | Z |

See Also

GH_Vector..::..GH_VectorProxy Class
Grasshopper.Kernel.Types Namespace


IsParsable Property

[image]

Grasshopper SDK
GH_Vector..::..GH_VectorProxy..::..IsParsable Property
GH_Vector..::..GH_VectorProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool IsParsable { get; }
Visual Basic
Public Overrides ReadOnly Property IsParsable As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Vector.GH_VectorProxy.IsParsable"]

See Also

GH_Vector..::..GH_VectorProxy Class
Grasshopper.Kernel.Types Namespace


Length Property

[image]

Grasshopper SDK
GH_Vector..::..GH_VectorProxy..::..Length Property
GH_Vector..::..GH_VectorProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Length { get; set; }
Visual Basic
Public Property Length As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Vector.GH_VectorProxy.Length"]

See Also

GH_Vector..::..GH_VectorProxy Class
Grasshopper.Kernel.Types Namespace


X Property

[image]

Grasshopper SDK
GH_Vector..::..GH_VectorProxy..::..X Property
GH_Vector..::..GH_VectorProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string X { get; set; }
Visual Basic
Public Property X As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Vector.GH_VectorProxy.X"]

See Also

GH_Vector..::..GH_VectorProxy Class
Grasshopper.Kernel.Types Namespace


Y Property

[image]

Grasshopper SDK
GH_Vector..::..GH_VectorProxy..::..Y Property
GH_Vector..::..GH_VectorProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Y { get; set; }
Visual Basic
Public Property Y As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Vector.GH_VectorProxy.Y"]

See Also

GH_Vector..::..GH_VectorProxy Class
Grasshopper.Kernel.Types Namespace


Z Property

[image]

Grasshopper SDK
GH_Vector..::..GH_VectorProxy..::..Z Property
GH_Vector..::..GH_VectorProxy Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Z { get; set; }
Visual Basic
Public Property Z As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_Vector.GH_VectorProxy.Z"]

See Also

GH_Vector..::..GH_VectorProxy Class
Grasshopper.Kernel.Types Namespace


GH_VectorForce Class

[image]

Grasshopper SDK
GH_VectorForce Class
Members See Also Send Feedback
Linear vector force implementation for IGH_Fields.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_VectorForce : GH_FieldElement
Visual Basic
Public Class GH_VectorForce _
    Inherits GH_FieldElement

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types..::..GH_FieldElement
Grasshopper.Kernel.Types..::..GH_VectorForce

See Also

GH_VectorForce Members
Grasshopper.Kernel.Types Namespace


GH_VectorForce Members

[image] [image]

Grasshopper SDK
GH_VectorForce Members
GH_VectorForce Class Constructors Methods Properties See Also Send Feedback

The GH_VectorForce type exposes the following members.

Constructors

 | Name | Description
Public method | GH_VectorForce | Initializes a new instance of the GH_VectorForce class

Methods

 | Name | Description
Public method | DrawViewportMeshes | (Inherited from GH_FieldElement.)
Public method | DrawViewportWires | (Overrides GH_FieldElement..::..DrawViewportWires(GH_PreviewWireArgs).)
Public method | Duplicate | (Overrides GH_FieldElement..::..Duplicate()()()().)
Public method | Force | (Overrides GH_FieldElement..::..Force(Point3d).)
Public method | IsCoincident | (Inherited from GH_FieldElement.)
Public method | Read | (Overrides GH_FieldElement..::..Read(GH_IReader).)
Public method | Write | (Overrides GH_FieldElement..::..Write(GH_IWriter).)

Properties

 | Name | Description
Public property | BoundingBox | (Overrides GH_FieldElement..::..BoundingBox.)
Public property | Chord |
Public property | ClippingBox | (Inherited from GH_FieldElement.)
Public property | ElementGuid | (Overrides GH_FieldElement..::..ElementGuid.)
Public property | IsLimited | (Inherited from GH_FieldElement.)
Public property | Limits | (Inherited from GH_FieldElement.)

See Also

GH_VectorForce Class
Grasshopper.Kernel.Types Namespace


GH_VectorForce Constructor

[image]

Grasshopper SDK
GH_VectorForce Constructor
GH_VectorForce Class See Also Send Feedback
Initializes a new instance of the GH_VectorForce class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_VectorForce()
Visual Basic
Public Sub New

See Also

GH_VectorForce Class
Grasshopper.Kernel.Types Namespace


GH_VectorForce Methods

[image] [image]

Grasshopper SDK
GH_VectorForce Methods
GH_VectorForce Class See Also Send Feedback

The GH_VectorForce type exposes the following members.

Methods

 | Name | Description
Public method | DrawViewportMeshes | (Inherited from GH_FieldElement.)
Public method | DrawViewportWires | (Overrides GH_FieldElement..::..DrawViewportWires(GH_PreviewWireArgs).)
Public method | Duplicate | (Overrides GH_FieldElement..::..Duplicate()()()().)
Public method | Force | (Overrides GH_FieldElement..::..Force(Point3d).)
Public method | IsCoincident | (Inherited from GH_FieldElement.)
Public method | Read | (Overrides GH_FieldElement..::..Read(GH_IReader).)
Public method | Write | (Overrides GH_FieldElement..::..Write(GH_IWriter).)

See Also

GH_VectorForce Class
Grasshopper.Kernel.Types Namespace


DrawViewportWires Method

[image]

Grasshopper SDK
GH_VectorForce..::..DrawViewportWires Method
GH_VectorForce Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override void DrawViewportWires(
    GH_PreviewWireArgs args
)
Visual Basic
Public Overrides Sub DrawViewportWires ( _
    args As GH_PreviewWireArgs _
)

Parameters

args
Type: Grasshopper.Kernel..::..GH_PreviewWireArgs

See Also

GH_VectorForce Class
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
GH_VectorForce..::..Duplicate Method
GH_VectorForce Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override IGH_FieldElement Duplicate()
Visual Basic
Public Overrides Function Duplicate As IGH_FieldElement

See Also

GH_VectorForce Class
Grasshopper.Kernel.Types Namespace


Force Method

[image]

Grasshopper SDK
GH_VectorForce..::..Force Method
GH_VectorForce Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override Vector3d Force(
    Point3d location
)
Visual Basic
Public Overrides Function Force ( _
    location As Point3d _
) As Vector3d

Parameters

location
Type: Point3d

See Also

GH_VectorForce Class
Grasshopper.Kernel.Types Namespace


Read Method

[image]

Grasshopper SDK
GH_VectorForce..::..Read Method
GH_VectorForce Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

See Also

GH_VectorForce Class
Grasshopper.Kernel.Types Namespace


Write Method

[image]

Grasshopper SDK
GH_VectorForce..::..Write Method
GH_VectorForce Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overrides Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

See Also

GH_VectorForce Class
Grasshopper.Kernel.Types Namespace


GH_VectorForce Properties

[image] [image]

Grasshopper SDK
GH_VectorForce Properties
GH_VectorForce Class See Also Send Feedback

The GH_VectorForce type exposes the following members.

Properties

 | Name | Description
Public property | BoundingBox | (Overrides GH_FieldElement..::..BoundingBox.)
Public property | Chord |
Public property | ClippingBox | (Inherited from GH_FieldElement.)
Public property | ElementGuid | (Overrides GH_FieldElement..::..ElementGuid.)
Public property | IsLimited | (Inherited from GH_FieldElement.)
Public property | Limits | (Inherited from GH_FieldElement.)

See Also

GH_VectorForce Class
Grasshopper.Kernel.Types Namespace


BoundingBox Property

[image]

Grasshopper SDK
GH_VectorForce..::..BoundingBox Property
GH_VectorForce Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override BoundingBox BoundingBox { get; }
Visual Basic
Public Overrides ReadOnly Property BoundingBox As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_VectorForce.BoundingBox"]

See Also

GH_VectorForce Class
Grasshopper.Kernel.Types Namespace


Chord Property

[image]

Grasshopper SDK
GH_VectorForce..::..Chord Property
GH_VectorForce Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Line Chord { get; set; }
Visual Basic
Public Property Chord As Line
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_VectorForce.Chord"]

See Also

GH_VectorForce Class
Grasshopper.Kernel.Types Namespace


ElementGuid Property

[image]

Grasshopper SDK
GH_VectorForce..::..ElementGuid Property
GH_VectorForce Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override Guid ElementGuid { get; }
Visual Basic
Public Overrides ReadOnly Property ElementGuid As Guid
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.GH_VectorForce.ElementGuid"]

See Also

GH_VectorForce Class
Grasshopper.Kernel.Types Namespace


IGH_FieldElement Interface

[image]

Grasshopper SDK
IGH_FieldElement Interface
Members See Also Send Feedback
Represents the basic interface for field elements.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_FieldElement : GH_ISerializable,
    IGH_PreviewData
Visual Basic
Public Interface IGH_FieldElement _
    Inherits GH_ISerializable, IGH_PreviewData

See Also

IGH_FieldElement Members
Grasshopper.Kernel.Types Namespace


IGH_FieldElement Members

[image] [image]

Grasshopper SDK
IGH_FieldElement Members
IGH_FieldElement Interface Methods Properties See Also Send Feedback

The IGH_FieldElement type exposes the following members.

Methods

 | Name | Description
Public method | DrawViewportMeshes | Implement this function to draw all shaded meshes. If the viewport does not support shading, this function will not be called. (Inherited from IGH_PreviewData.)
Public method | DrawViewportWires | Implement this function to draw all wire and point previews. (Inherited from IGH_PreviewData.)
Public method | Duplicate | Create an exact copy of this element.
Public method | Force | Compute the force at a given location.
Public method | IsCoincident | Computes whether the point can be considered coincident with the element.
Public method | Read | This method is called whenever the instance is required to deserialize itself. (Inherited from GH_ISerializable.)
Public method | Write | This method is called whenever the instance is required to serialize itself. (Inherited from GH_ISerializable.)

Properties

 | Name | Description
Public property | BoundingBox | Gets the visual boundingbox of all the geometry used to represent this element in 3D.
Public property | ClippingBox | Gets the clipping box for this data. The clipping box is typically the same as the boundingbox. (Inherited from IGH_PreviewData.)
Public property | ElementGuid | Gets the element Guid for this element.
Public property | IsLimited | Gets or sets whether this element affects a limited region.
Public property | Limits | Gets or sets the limits of this region. Unless IsLimited equals true, the Limits property is ignored.

See Also

IGH_FieldElement Interface
Grasshopper.Kernel.Types Namespace


IGH_FieldElement Methods

[image] [image]

Grasshopper SDK
IGH_FieldElement Methods
IGH_FieldElement Interface See Also Send Feedback

The IGH_FieldElement type exposes the following members.

Methods

 | Name | Description
Public method | DrawViewportMeshes | Implement this function to draw all shaded meshes. If the viewport does not support shading, this function will not be called. (Inherited from IGH_PreviewData.)
Public method | DrawViewportWires | Implement this function to draw all wire and point previews. (Inherited from IGH_PreviewData.)
Public method | Duplicate | Create an exact copy of this element.
Public method | Force | Compute the force at a given location.
Public method | IsCoincident | Computes whether the point can be considered coincident with the element.
Public method | Read | This method is called whenever the instance is required to deserialize itself. (Inherited from GH_ISerializable.)
Public method | Write | This method is called whenever the instance is required to serialize itself. (Inherited from GH_ISerializable.)

See Also

IGH_FieldElement Interface
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
IGH_FieldElement..::..Duplicate Method
IGH_FieldElement Interface See Also Send Feedback
Create an exact copy of this element.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
IGH_FieldElement Duplicate()
Visual Basic
Function Duplicate As IGH_FieldElement

See Also

IGH_FieldElement Interface
Grasshopper.Kernel.Types Namespace


Force Method

[image]

Grasshopper SDK
IGH_FieldElement..::..Force Method
IGH_FieldElement Interface See Also Send Feedback
Compute the force at a given location.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
Vector3d Force(
    Point3d location
)
Visual Basic
Function Force ( _
    location As Point3d _
) As Vector3d

Parameters

location
Type: Point3d

See Also

IGH_FieldElement Interface
Grasshopper.Kernel.Types Namespace


IsCoincident Method

[image]

Grasshopper SDK
IGH_FieldElement..::..IsCoincident Method
IGH_FieldElement Interface See Also Send Feedback
Computes whether the point can be considered coincident with the element.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool IsCoincident(
    Point3d point,
    double tolerance
)
Visual Basic
Function IsCoincident ( _
    point As Point3d, _
    tolerance As Double _
) As Boolean

Parameters

point
Type: Point3d
Point to test.
tolerance
Type: System..::..Double
Tolerance to use.

Return Value

True if the point is coincident within tolerance.

See Also

IGH_FieldElement Interface
Grasshopper.Kernel.Types Namespace


IGH_FieldElement Properties

[image] [image]

Grasshopper SDK
IGH_FieldElement Properties
IGH_FieldElement Interface See Also Send Feedback

The IGH_FieldElement type exposes the following members.

Properties

 | Name | Description
Public property | BoundingBox | Gets the visual boundingbox of all the geometry used to represent this element in 3D.
Public property | ClippingBox | Gets the clipping box for this data. The clipping box is typically the same as the boundingbox. (Inherited from IGH_PreviewData.)
Public property | ElementGuid | Gets the element Guid for this element.
Public property | IsLimited | Gets or sets whether this element affects a limited region.
Public property | Limits | Gets or sets the limits of this region. Unless IsLimited equals true, the Limits property is ignored.

See Also

IGH_FieldElement Interface
Grasshopper.Kernel.Types Namespace


BoundingBox Property

[image]

Grasshopper SDK
IGH_FieldElement..::..BoundingBox Property
IGH_FieldElement Interface See Also Send Feedback
Gets the visual boundingbox of all the geometry used to represent this element in 3D.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
BoundingBox BoundingBox { get; }
Visual Basic
ReadOnly Property BoundingBox As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.IGH_FieldElement.BoundingBox"]

See Also

IGH_FieldElement Interface
Grasshopper.Kernel.Types Namespace


ElementGuid Property

[image]

Grasshopper SDK
IGH_FieldElement..::..ElementGuid Property
IGH_FieldElement Interface See Also Send Feedback
Gets the element Guid for this element.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
Guid ElementGuid { get; }
Visual Basic
ReadOnly Property ElementGuid As Guid
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.IGH_FieldElement.ElementGuid"]

See Also

IGH_FieldElement Interface
Grasshopper.Kernel.Types Namespace


IsLimited Property

[image]

Grasshopper SDK
IGH_FieldElement..::..IsLimited Property
IGH_FieldElement Interface See Also Send Feedback
Gets or sets whether this element affects a limited region.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool IsLimited { get; set; }
Visual Basic
Property IsLimited As Boolean
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.IGH_FieldElement.IsLimited"]

See Also

IGH_FieldElement Interface
Grasshopper.Kernel.Types Namespace


Limits Property

[image]

Grasshopper SDK
IGH_FieldElement..::..Limits Property
IGH_FieldElement Interface See Also Send Feedback
Gets or sets the limits of this region. Unless IsLimited equals true, the Limits property is ignored.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
Box Limits { get; set; }
Visual Basic
Property Limits As Box
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.IGH_FieldElement.Limits"]

See Also

IGH_FieldElement Interface
Grasshopper.Kernel.Types Namespace


IGH_GeometricGoo Interface

[image]

Grasshopper SDK
IGH_GeometricGoo Interface
Members See Also Send Feedback
Base interface for all Data inside Grasshoper that could pass for Geometry

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_GeometricGoo : IGH_Goo
Visual Basic
Public Interface IGH_GeometricGoo _
    Inherits IGH_Goo

See Also

IGH_GeometricGoo Members
Grasshopper.Kernel.Types Namespace


IGH_GeometricGoo Members

[image] [image]

Grasshopper SDK
IGH_GeometricGoo Members
IGH_GeometricGoo Interface Methods Properties See Also Send Feedback

The IGH_GeometricGoo type exposes the following members.

Methods

 | Name | Description
Public method | CastFrom | Attempt a cast from generic object (Inherited from IGH_Goo.)
Public method | CastTo<(Of <<'(T>)>>) | Attempt a cast to type T (Inherited from IGH_Goo.)
Public method | ClearCaches | Clears all caches. Typically if the geometry is referenced, this will erase the local copy.
Public method | Duplicate | Make a complete duplicate of this instance. No shallow copies. (Inherited from IGH_Goo.)
Public method | DuplicateGeometry | Make a complete duplicate of this geometry. No shallow copies.
Public method | EmitProxy | Create a new proxy for this instance. Return Null if this class does not support proxies. (Inherited from IGH_Goo.)
Public method | GetBoundingBox | Compute an aligned boundingbox.
Public method | LoadGeometry()()()() | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry.
Public method | LoadGeometry(RhinoDoc) | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry.
Public method | Morph | Morph the object or a deformable representation of the object.
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disapears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from IGH_Goo.)
Public method | ToString | Creates a string description of the current instance value (Inherited from IGH_Goo.)
Public method | Transform | Transforms the object or a deformable representation of the object.

Properties

 | Name | Description
Public property | Boundingbox | Gets the (cached) boundingbox for this geometry. Not all geometry types cache boundingbox results.
Public property | IsGeometryLoaded | Gets a value indicating whether or not this geometry is currently loaded (assuming it is referenced). Not all IGH_GeometricGoo implementations support referenced geometry.
Public property | IsReferencedGeometry | Gets a value indicating whether or not this geometry is referenced. Not all IGH_GeometricGoo implementations support referenced geometry.
Public property | IsValid | Gets a value indicating whether or not the current value is valid. (Inherited from IGH_Goo.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Inherited from IGH_Goo.)
Public property | ReferenceID | Gets or sets the Guid of the object that is referenced. Not all IGH_GeometricGoo implementations support referenced geometry.
Public property | TypeDescription | Gets a description of the type of the implementation. (Inherited from IGH_Goo.)
Public property | TypeName | Gets the name of the type of the implementation. (Inherited from IGH_Goo.)

See Also

IGH_GeometricGoo Interface
Grasshopper.Kernel.Types Namespace


IGH_GeometricGoo Methods

[image] [image]

Grasshopper SDK
IGH_GeometricGoo Methods
IGH_GeometricGoo Interface See Also Send Feedback

The IGH_GeometricGoo type exposes the following members.

Methods

 | Name | Description
Public method | CastFrom | Attempt a cast from generic object (Inherited from IGH_Goo.)
Public method | CastTo<(Of <<'(T>)>>) | Attempt a cast to type T (Inherited from IGH_Goo.)
Public method | ClearCaches | Clears all caches. Typically if the geometry is referenced, this will erase the local copy.
Public method | Duplicate | Make a complete duplicate of this instance. No shallow copies. (Inherited from IGH_Goo.)
Public method | DuplicateGeometry | Make a complete duplicate of this geometry. No shallow copies.
Public method | EmitProxy | Create a new proxy for this instance. Return Null if this class does not support proxies. (Inherited from IGH_Goo.)
Public method | GetBoundingBox | Compute an aligned boundingbox.
Public method | LoadGeometry()()()() | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry.
Public method | LoadGeometry(RhinoDoc) | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry.
Public method | Morph | Morph the object or a deformable representation of the object.
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disapears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type. (Inherited from IGH_Goo.)
Public method | ToString | Creates a string description of the current instance value (Inherited from IGH_Goo.)
Public method | Transform | Transforms the object or a deformable representation of the object.

See Also

IGH_GeometricGoo Interface
Grasshopper.Kernel.Types Namespace


ClearCaches Method

[image]

Grasshopper SDK
IGH_GeometricGoo..::..ClearCaches Method
IGH_GeometricGoo Interface See Also Send Feedback
Clears all caches. Typically if the geometry is referenced, this will erase the local copy.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void ClearCaches()
Visual Basic
Sub ClearCaches

See Also

IGH_GeometricGoo Interface
Grasshopper.Kernel.Types Namespace


DuplicateGeometry Method

[image]

Grasshopper SDK
IGH_GeometricGoo..::..DuplicateGeometry Method
IGH_GeometricGoo Interface See Also Send Feedback
Make a complete duplicate of this geometry. No shallow copies.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
IGH_GeometricGoo DuplicateGeometry()
Visual Basic
Function DuplicateGeometry As IGH_GeometricGoo

Remarks

Each class that implements this interface should also provide a type specific duplication method

See Also

IGH_GeometricGoo Interface
Grasshopper.Kernel.Types Namespace


GetBoundingBox Method

[image]

Grasshopper SDK
IGH_GeometricGoo..::..GetBoundingBox Method
IGH_GeometricGoo Interface See Also Send Feedback
Compute an aligned boundingbox.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
BoundingBox GetBoundingBox(
    Transform xform
)
Visual Basic
Function GetBoundingBox ( _
    xform As Transform _
) As BoundingBox

Parameters

xform
Type: Transform
Transformation to apply to geometry for BoundingBox computation.

Return Value

The world aligned boundingbox of the transformed geometry.

See Also

IGH_GeometricGoo Interface
Grasshopper.Kernel.Types Namespace


LoadGeometry Method

[image] [image]

Grasshopper SDK
IGH_GeometricGoo..::..LoadGeometry Method
IGH_GeometricGoo Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | LoadGeometry()()()() | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry.
Public method | LoadGeometry(RhinoDoc) | If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry.

See Also

IGH_GeometricGoo Interface
IGH_GeometricGoo Members
Grasshopper.Kernel.Types Namespace


LoadGeometry Method

[image]

Grasshopper SDK
IGH_GeometricGoo..::..LoadGeometry Method
IGH_GeometricGoo Interface See Also Send Feedback
If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool LoadGeometry()
Visual Basic
Function LoadGeometry As Boolean

See Also

IGH_GeometricGoo Interface
LoadGeometry Overload
Grasshopper.Kernel.Types Namespace


LoadGeometry Method ()

[image]

Grasshopper SDK
IGH_GeometricGoo..::..LoadGeometry Method ()
IGH_GeometricGoo Interface See Also Send Feedback
If the geometry is referenced and currently unloaded, forces loading of the geometry. Not all IGH_GeometricGoo implementations support referenced geometry.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool LoadGeometry(
    RhinoDoc doc
)
Visual Basic
Function LoadGeometry ( _
    doc As RhinoDoc _
) As Boolean

Parameters

doc
Type: RhinoDoc
Document to use for loading.

See Also

IGH_GeometricGoo Interface
LoadGeometry Overload
Grasshopper.Kernel.Types Namespace


Morph Method

[image]

Grasshopper SDK
IGH_GeometricGoo..::..Morph Method
IGH_GeometricGoo Interface See Also Send Feedback
Morph the object or a deformable representation of the object.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
IGH_GeometricGoo Morph(
    SpaceMorph xmorph
)
Visual Basic
Function Morph ( _
    xmorph As SpaceMorph _
) As IGH_GeometricGoo

Parameters

xmorph
Type: SpaceMorph
Spatial deform.

Return Value

Deformed geometry. If the local geometry can be deformed accurately, then the returned instance equals this instance. Not all geometry types can be accurately deformed though, if this is the case, this function will return an instance of another IGH_GeometricGoo derived type which can be deformed.

See Also

IGH_GeometricGoo Interface
Grasshopper.Kernel.Types Namespace


Transform Method

[image]

Grasshopper SDK
IGH_GeometricGoo..::..Transform Method
IGH_GeometricGoo Interface See Also Send Feedback
Transforms the object or a deformable representation of the object.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
IGH_GeometricGoo Transform(
    Transform xform
)
Visual Basic
Function Transform ( _
    xform As Transform _
) As IGH_GeometricGoo

Parameters

xform
Type: Transform
Transformation matrix.

Return Value

Transformed geometry. If the local geometry can be transformed accurately, then the returned instance equals this instance. Not all geometry types can be accurately transformed under all circumstances though, if this is the case, this function will return an instance of another IGH_GeometricGoo derived type which can be transformed.

See Also

IGH_GeometricGoo Interface
Grasshopper.Kernel.Types Namespace


IGH_GeometricGoo Properties

[image] [image]

Grasshopper SDK
IGH_GeometricGoo Properties
IGH_GeometricGoo Interface See Also Send Feedback

The IGH_GeometricGoo type exposes the following members.

Properties

 | Name | Description
Public property | Boundingbox | Gets the (cached) boundingbox for this geometry. Not all geometry types cache boundingbox results.
Public property | IsGeometryLoaded | Gets a value indicating whether or not this geometry is currently loaded (assuming it is referenced). Not all IGH_GeometricGoo implementations support referenced geometry.
Public property | IsReferencedGeometry | Gets a value indicating whether or not this geometry is referenced. Not all IGH_GeometricGoo implementations support referenced geometry.
Public property | IsValid | Gets a value indicating whether or not the current value is valid. (Inherited from IGH_Goo.)
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty. (Inherited from IGH_Goo.)
Public property | ReferenceID | Gets or sets the Guid of the object that is referenced. Not all IGH_GeometricGoo implementations support referenced geometry.
Public property | TypeDescription | Gets a description of the type of the implementation. (Inherited from IGH_Goo.)
Public property | TypeName | Gets the name of the type of the implementation. (Inherited from IGH_Goo.)

See Also

IGH_GeometricGoo Interface
Grasshopper.Kernel.Types Namespace


Boundingbox Property

[image]

Grasshopper SDK
IGH_GeometricGoo..::..Boundingbox Property
IGH_GeometricGoo Interface See Also Send Feedback
Gets the (cached) boundingbox for this geometry. Not all geometry types cache boundingbox results.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
BoundingBox Boundingbox { get; }
Visual Basic
ReadOnly Property Boundingbox As BoundingBox
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.IGH_GeometricGoo.Boundingbox"]

Return Value

The boundingbox for this piece of geometry or Boundingbox.Empty if the geometry is null or invalid.

See Also

IGH_GeometricGoo Interface
Grasshopper.Kernel.Types Namespace


IsGeometryLoaded Property

[image]

Grasshopper SDK
IGH_GeometricGoo..::..IsGeometryLoaded Property
IGH_GeometricGoo Interface See Also Send Feedback
Gets a value indicating whether or not this geometry is currently loaded (assuming it is referenced). Not all IGH_GeometricGoo implementations support referenced geometry.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool IsGeometryLoaded { get; }
Visual Basic
ReadOnly Property IsGeometryLoaded As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.IGH_GeometricGoo.IsGeometryLoaded"]

See Also

IGH_GeometricGoo Interface
Grasshopper.Kernel.Types Namespace


IsReferencedGeometry Property

[image]

Grasshopper SDK
IGH_GeometricGoo..::..IsReferencedGeometry Property
IGH_GeometricGoo Interface See Also Send Feedback
Gets a value indicating whether or not this geometry is referenced. Not all IGH_GeometricGoo implementations support referenced geometry.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool IsReferencedGeometry { get; }
Visual Basic
ReadOnly Property IsReferencedGeometry As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.IGH_GeometricGoo.IsReferencedGeometry"]

See Also

IGH_GeometricGoo Interface
Grasshopper.Kernel.Types Namespace


ReferenceID Property

[image]

Grasshopper SDK
IGH_GeometricGoo..::..ReferenceID Property
IGH_GeometricGoo Interface See Also Send Feedback
Gets or sets the Guid of the object that is referenced. Not all IGH_GeometricGoo implementations support referenced geometry.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
Guid ReferenceID { get; set; }
Visual Basic
Property ReferenceID As Guid
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.IGH_GeometricGoo.ReferenceID"]

See Also

IGH_GeometricGoo Interface
Grasshopper.Kernel.Types Namespace


IGH_Goo Interface

[image]

Grasshopper SDK
IGH_Goo Interface
Members See Also Send Feedback
Base interface for all Data inside Grasshopper. Every parameter must implement a type of Goo.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_Goo : GH_ISerializable
Visual Basic
Public Interface IGH_Goo _
    Inherits GH_ISerializable

See Also

IGH_Goo Members
Grasshopper.Kernel.Types Namespace


IGH_Goo Members

[image] [image]

Grasshopper SDK
IGH_Goo Members
IGH_Goo Interface Methods Properties See Also Send Feedback

The IGH_Goo type exposes the following members.

Methods

 | Name | Description
Public method | CastFrom | Attempt a cast from generic object
Public method | CastTo<(Of <<'(T>)>>) | Attempt a cast to type T
Public method | Duplicate | Make a complete duplicate of this instance. No shallow copies.
Public method | EmitProxy | Create a new proxy for this instance. Return Null if this class does not support proxies.
Public method | Read | This method is called whenever the instance is required to deserialize itself. (Inherited from GH_ISerializable.)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disapears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type.
Public method | ToString | Creates a string description of the current instance value
Public method | Write | This method is called whenever the instance is required to serialize itself. (Inherited from GH_ISerializable.)

Properties

 | Name | Description
Public property | IsValid | Gets a value indicating whether or not the current value is valid.
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.
Public property | TypeDescription | Gets a description of the type of the implementation.
Public property | TypeName | Gets the name of the type of the implementation.

See Also

IGH_Goo Interface
Grasshopper.Kernel.Types Namespace


IGH_Goo Methods

[image] [image]

Grasshopper SDK
IGH_Goo Methods
IGH_Goo Interface See Also Send Feedback

The IGH_Goo type exposes the following members.

Methods

 | Name | Description
Public method | CastFrom | Attempt a cast from generic object
Public method | CastTo<(Of <<'(T>)>>) | Attempt a cast to type T
Public method | Duplicate | Make a complete duplicate of this instance. No shallow copies.
Public method | EmitProxy | Create a new proxy for this instance. Return Null if this class does not support proxies.
Public method | Read | This method is called whenever the instance is required to deserialize itself. (Inherited from GH_ISerializable.)
Public method | ScriptVariable | This function will be called when the local IGH_Goo instance disapears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type.
Public method | ToString | Creates a string description of the current instance value
Public method | Write | This method is called whenever the instance is required to serialize itself. (Inherited from GH_ISerializable.)

See Also

IGH_Goo Interface
Grasshopper.Kernel.Types Namespace


CastFrom Method

[image]

Grasshopper SDK
IGH_Goo..::..CastFrom Method
IGH_Goo Interface See Also Send Feedback
Attempt a cast from generic object

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool CastFrom(
    Object source
)
Visual Basic
Function CastFrom ( _
    source As Object _
) As Boolean

Parameters

source
Type: System..::..Object
Reference to source of cast.

Return Value

True on success, false on failure.

Remarks

If False, the contents of this instance are not to be trusted.

See Also

IGH_Goo Interface
Grasshopper.Kernel.Types Namespace


CastTo(T) Method

[image]

Grasshopper SDK
IGH_Goo..::..CastTo<(Of <(<'T>)>)> Method
IGH_Goo Interface See Also Send Feedback
Attempt a cast to type T

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool CastTo<T>(
    out T target
)
Visual Basic
Function CastTo(Of T) ( _
    <OutAttribute> ByRef target As T _
) As Boolean

Parameters

target
Type: T%
Pointer to target of cast.

Type Parameters

T
Type to cast to

Return Value

True on success, false on failure.

Remarks

If false, the target instance contents are not guaranteed to be valid.

See Also

IGH_Goo Interface
Grasshopper.Kernel.Types Namespace


Duplicate Method

[image]

Grasshopper SDK
IGH_Goo..::..Duplicate Method
IGH_Goo Interface See Also Send Feedback
Make a complete duplicate of this instance. No shallow copies.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
IGH_Goo Duplicate()
Visual Basic
Function Duplicate As IGH_Goo

Remarks

Classes which implement this interface should also provide type specific Duplicate methods

See Also

IGH_Goo Interface
Grasshopper.Kernel.Types Namespace


EmitProxy Method

[image]

Grasshopper SDK
IGH_Goo..::..EmitProxy Method
IGH_Goo Interface See Also Send Feedback
Create a new proxy for this instance. Return Null if this class does not support proxies.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
IGH_GooProxy EmitProxy()
Visual Basic
Function EmitProxy As IGH_GooProxy

See Also

IGH_Goo Interface
Grasshopper.Kernel.Types Namespace


ScriptVariable Method

[image]

Grasshopper SDK
IGH_Goo..::..ScriptVariable Method
IGH_Goo Interface See Also Send Feedback
This function will be called when the local IGH_Goo instance disapears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
Object ScriptVariable()
Visual Basic
Function ScriptVariable As Object

Return Value

The object that represents this IGH_Goo instance in a script.

See Also

IGH_Goo Interface
Grasshopper.Kernel.Types Namespace


ToString Method

[image]

Grasshopper SDK
IGH_Goo..::..ToString Method
IGH_Goo Interface See Also Send Feedback
Creates a string description of the current instance value

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string ToString()
Visual Basic
Function ToString As String

See Also

IGH_Goo Interface
Grasshopper.Kernel.Types Namespace


IGH_Goo Properties

[image] [image]

Grasshopper SDK
IGH_Goo Properties
IGH_Goo Interface See Also Send Feedback

The IGH_Goo type exposes the following members.

Properties

 | Name | Description
Public property | IsValid | Gets a value indicating whether or not the current value is valid.
Public property | IsValidWhyNot | Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.
Public property | TypeDescription | Gets a description of the type of the implementation.
Public property | TypeName | Gets the name of the type of the implementation.

See Also

IGH_Goo Interface
Grasshopper.Kernel.Types Namespace


IsValid Property

[image]

Grasshopper SDK
IGH_Goo..::..IsValid Property
IGH_Goo Interface See Also Send Feedback
Gets a value indicating whether or not the current value is valid.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool IsValid { get; }
Visual Basic
ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.IGH_Goo.IsValid"]

See Also

IGH_Goo Interface
Grasshopper.Kernel.Types Namespace


IsValidWhyNot Property

[image]

Grasshopper SDK
IGH_Goo..::..IsValidWhyNot Property
IGH_Goo Interface See Also Send Feedback
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string IsValidWhyNot { get; }
Visual Basic
ReadOnly Property IsValidWhyNot As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.IGH_Goo.IsValidWhyNot"]

See Also

IGH_Goo Interface
Grasshopper.Kernel.Types Namespace


TypeDescription Property

[image]

Grasshopper SDK
IGH_Goo..::..TypeDescription Property
IGH_Goo Interface See Also Send Feedback
Gets a description of the type of the implementation.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string TypeDescription { get; }
Visual Basic
ReadOnly Property TypeDescription As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.IGH_Goo.TypeDescription"]

See Also

IGH_Goo Interface
Grasshopper.Kernel.Types Namespace


TypeName Property

[image]

Grasshopper SDK
IGH_Goo..::..TypeName Property
IGH_Goo Interface See Also Send Feedback
Gets the name of the type of the implementation.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string TypeName { get; }
Visual Basic
ReadOnly Property TypeName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.IGH_Goo.TypeName"]

See Also

IGH_Goo Interface
Grasshopper.Kernel.Types Namespace


IGH_GooProxy Interface

[image]

Grasshopper SDK
IGH_GooProxy Interface
Members See Also Send Feedback
Base interface for all type proxies.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_GooProxy
Visual Basic
Public Interface IGH_GooProxy

See Also

IGH_GooProxy Members
Grasshopper.Kernel.Types Namespace


IGH_GooProxy Members

[image] [image]

Grasshopper SDK
IGH_GooProxy Members
IGH_GooProxy Interface Methods Properties See Also Send Feedback

The IGH_GooProxy type exposes the following members.

Methods

 | Name | Description
Public method | Construct | This method will be called when a new instance of this type is constructed. It allows implementers to supply a customized UI to be shown during construction. This method should never throw exceptions.
Public method | FormatInstance | Returns a String description of the current value.
Public method | FromString | If IsParsable(), then attempts to convert the string to a generic type value
Public method | MutateString | Munge a string to remove obvious errors on account of the user.

Properties

 | Name | Description
Public property | IsParsable | Gets a value indicating whether or not the type can be instantiated from a String.
Public property | ProxyOwner | Gets the piece of Grasshopper data that spawned this proxy.
Public property | UserString | Gets or sets the user-defined string that describes this proxy. This only really makes sense if the Proxy is Parsable.
Public property | Valid | Gets a value indicating whether this proxy represents valid data.

See Also

IGH_GooProxy Interface
Grasshopper.Kernel.Types Namespace


IGH_GooProxy Methods

[image] [image]

Grasshopper SDK
IGH_GooProxy Methods
IGH_GooProxy Interface See Also Send Feedback

The IGH_GooProxy type exposes the following members.

Methods

 | Name | Description
Public method | Construct | This method will be called when a new instance of this type is constructed. It allows implementers to supply a customized UI to be shown during construction. This method should never throw exceptions.
Public method | FormatInstance | Returns a String description of the current value.
Public method | FromString | If IsParsable(), then attempts to convert the string to a generic type value
Public method | MutateString | Munge a string to remove obvious errors on account of the user.

See Also

IGH_GooProxy Interface
Grasshopper.Kernel.Types Namespace


Construct Method

[image]

Grasshopper SDK
IGH_GooProxy..::..Construct Method
IGH_GooProxy Interface See Also Send Feedback
This method will be called when a new instance of this type is constructed. It allows implementers to supply a customized UI to be shown during construction. This method should never throw exceptions.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void Construct()
Visual Basic
Sub Construct

See Also

IGH_GooProxy Interface
Grasshopper.Kernel.Types Namespace


FormatInstance Method

[image]

Grasshopper SDK
IGH_GooProxy..::..FormatInstance Method
IGH_GooProxy Interface See Also Send Feedback
Returns a String description of the current value.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string FormatInstance()
Visual Basic
Function FormatInstance As String

Remarks

If the implementation IsParsable(), then this representation will be in parsable format.

See Also

IGH_GooProxy Interface
Grasshopper.Kernel.Types Namespace


FromString Method

[image]

Grasshopper SDK
IGH_GooProxy..::..FromString Method
IGH_GooProxy Interface See Also Send Feedback
If IsParsable(), then attempts to convert the string to a generic type value

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool FromString(
    string in
)
Visual Basic
Function FromString ( _
    in As String _
) As Boolean

Parameters

in
Type: System..::..String
The String to parse.

Return Value

True on success, false on failure. This method should not throw exceptions.

See Also

IGH_GooProxy Interface
Grasshopper.Kernel.Types Namespace


MutateString Method

[image]

Grasshopper SDK
IGH_GooProxy..::..MutateString Method
IGH_GooProxy Interface See Also Send Feedback
Munge a string to remove obvious errors on account of the user.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string MutateString(
    string in
)
Visual Basic
Function MutateString ( _
    in As String _
) As String

Parameters

in
Type: System..::..String

See Also

IGH_GooProxy Interface
Grasshopper.Kernel.Types Namespace


IGH_GooProxy Properties

[image] [image]

Grasshopper SDK
IGH_GooProxy Properties
IGH_GooProxy Interface See Also Send Feedback

The IGH_GooProxy type exposes the following members.

Properties

 | Name | Description
Public property | IsParsable | Gets a value indicating whether or not the type can be instantiated from a String.
Public property | ProxyOwner | Gets the piece of Grasshopper data that spawned this proxy.
Public property | UserString | Gets or sets the user-defined string that describes this proxy. This only really makes sense if the Proxy is Parsable.
Public property | Valid | Gets a value indicating whether this proxy represents valid data.

See Also

IGH_GooProxy Interface
Grasshopper.Kernel.Types Namespace


IsParsable Property

[image]

Grasshopper SDK
IGH_GooProxy..::..IsParsable Property
IGH_GooProxy Interface See Also Send Feedback
Gets a value indicating whether or not the type can be instantiated from a String.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool IsParsable { get; }
Visual Basic
ReadOnly Property IsParsable As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.IGH_GooProxy.IsParsable"]

See Also

IGH_GooProxy Interface
Grasshopper.Kernel.Types Namespace


ProxyOwner Property

[image]

Grasshopper SDK
IGH_GooProxy..::..ProxyOwner Property
IGH_GooProxy Interface See Also Send Feedback
Gets the piece of Grasshopper data that spawned this proxy.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
IGH_Goo ProxyOwner { get; }
Visual Basic
ReadOnly Property ProxyOwner As IGH_Goo
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.IGH_GooProxy.ProxyOwner"]

See Also

IGH_GooProxy Interface
Grasshopper.Kernel.Types Namespace


UserString Property

[image]

Grasshopper SDK
IGH_GooProxy..::..UserString Property
IGH_GooProxy Interface See Also Send Feedback
Gets or sets the user-defined string that describes this proxy. This only really makes sense if the Proxy is Parsable.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string UserString { get; set; }
Visual Basic
Property UserString As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.IGH_GooProxy.UserString"]

Return Value

The UserString value or the value of FormatInstance() if UserString has not been assigned.

See Also

IGH_GooProxy Interface
Grasshopper.Kernel.Types Namespace


Valid Property

[image]

Grasshopper SDK
IGH_GooProxy..::..Valid Property
IGH_GooProxy Interface See Also Send Feedback
Gets a value indicating whether this proxy represents valid data.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool Valid { get; }
Visual Basic
ReadOnly Property Valid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.IGH_GooProxy.Valid"]

See Also

IGH_GooProxy Interface
Grasshopper.Kernel.Types Namespace


UVInterval Structure

[image]

Grasshopper SDK
UVInterval Structure
Members See Also Send Feedback
UVInterval data type. Do not confuse this with GH_Interval2D.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public struct UVInterval
Visual Basic
Public Structure UVInterval

See Also

UVInterval Members
Grasshopper.Kernel.Types Namespace


UVInterval Members

[image] [image]

Grasshopper SDK
UVInterval Members
UVInterval Structure Constructors Properties See Also Send Feedback

The UVInterval type exposes the following members.

Constructors

 | Name | Description
Public method | UVInterval | Initializes a new instance of the UVInterval class

Properties

 | Name | Description
Public property | IsValid | Gets a value indicating whether or not this UVInterval is valid.
Public property | U | Gets or sets the U interval.
Public property | U0 | Gets or sets the T0 value of the U domain.
Public property | U1 | Gets or sets the T1 value of the U domain.
Public property | V | Gets or sets the V interval.
Public property | V0 | Gets or sets the T0 value of the V domain.
Public property | V1 | Gets or sets the T1 value of the V domain.

See Also

UVInterval Structure
Grasshopper.Kernel.Types Namespace


UVInterval Constructor

[image]

Grasshopper SDK
UVInterval Constructor
UVInterval Structure See Also Send Feedback
Initializes a new instance of the UVInterval class

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public UVInterval(
    Interval newU,
    Interval newV
)
Visual Basic
Public Sub New ( _
    newU As Interval, _
    newV As Interval _
)

Parameters

newU
Type: Interval
newV
Type: Interval

See Also

UVInterval Structure
Grasshopper.Kernel.Types Namespace


UVInterval Properties

[image] [image]

Grasshopper SDK
UVInterval Properties
UVInterval Structure See Also Send Feedback

The UVInterval type exposes the following members.

Properties

 | Name | Description
Public property | IsValid | Gets a value indicating whether or not this UVInterval is valid.
Public property | U | Gets or sets the U interval.
Public property | U0 | Gets or sets the T0 value of the U domain.
Public property | U1 | Gets or sets the T1 value of the U domain.
Public property | V | Gets or sets the V interval.
Public property | V0 | Gets or sets the T0 value of the V domain.
Public property | V1 | Gets or sets the T1 value of the V domain.

See Also

UVInterval Structure
Grasshopper.Kernel.Types Namespace


IsValid Property

[image]

Grasshopper SDK
UVInterval..::..IsValid Property
UVInterval Structure See Also Send Feedback
Gets a value indicating whether or not this UVInterval is valid.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsValid { get; }
Visual Basic
Public ReadOnly Property IsValid As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.UVInterval.IsValid"]

See Also

UVInterval Structure
Grasshopper.Kernel.Types Namespace


U Property

[image]

Grasshopper SDK
UVInterval..::..U Property
UVInterval Structure See Also Send Feedback
Gets or sets the U interval.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Interval U { get; set; }
Visual Basic
Public Property U As Interval
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.UVInterval.U"]

See Also

UVInterval Structure
Grasshopper.Kernel.Types Namespace


U0 Property

[image]

Grasshopper SDK
UVInterval..::..U0 Property
UVInterval Structure See Also Send Feedback
Gets or sets the T0 value of the U domain.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double U0 { get; set; }
Visual Basic
Public Property U0 As Double
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.UVInterval.U0"]

See Also

UVInterval Structure
Grasshopper.Kernel.Types Namespace


U1 Property

[image]

Grasshopper SDK
UVInterval..::..U1 Property
UVInterval Structure See Also Send Feedback
Gets or sets the T1 value of the U domain.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double U1 { get; set; }
Visual Basic
Public Property U1 As Double
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.UVInterval.U1"]

See Also

UVInterval Structure
Grasshopper.Kernel.Types Namespace


V Property

[image]

Grasshopper SDK
UVInterval..::..V Property
UVInterval Structure See Also Send Feedback
Gets or sets the V interval.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Interval V { get; set; }
Visual Basic
Public Property V As Interval
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.UVInterval.V"]

See Also

UVInterval Structure
Grasshopper.Kernel.Types Namespace


V0 Property

[image]

Grasshopper SDK
UVInterval..::..V0 Property
UVInterval Structure See Also Send Feedback
Gets or sets the T0 value of the V domain.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double V0 { get; set; }
Visual Basic
Public Property V0 As Double
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.UVInterval.V0"]

See Also

UVInterval Structure
Grasshopper.Kernel.Types Namespace


V1 Property

[image]

Grasshopper SDK
UVInterval..::..V1 Property
UVInterval Structure See Also Send Feedback
Gets or sets the T1 value of the V domain.

Namespace: Grasshopper.Kernel.Types
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double V1 { get; set; }
Visual Basic
Public Property V1 As Double
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.UVInterval.V1"]

See Also

UVInterval Structure
Grasshopper.Kernel.Types Namespace


Grasshopper.Kernel.Types.Transforms Namespace

[image]

Grasshopper SDK
Grasshopper.Kernel.Types.Transforms Namespace
Send Feedback

Classes

 | Class | Description
Public class | Generic | Implements a generic matrix transformation.
Public class | Identity | Implements a null-transform.
Public class | Orientation | Implements an orientation (ChangeBasis) transformation.
Public class | Projection | Implements a projection transformation.
Public class | Rotation | Implements a rotation transformation.
Public class | Scale | Implements a scaling transformation.
Public class | Translation | Implements a translation (Move) transformation.

Interfaces

 | Interface | Description
Public interface | ITransform | Basic interface for a single Grasshopper transformation.


Generic Class

[image]

Grasshopper SDK
Generic Class
Members See Also Send Feedback
Implements a generic matrix transformation.

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class Generic : ITransform
Visual Basic
Public Class Generic _
    Implements ITransform

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types.Transforms..::..Generic

See Also

Generic Members
Grasshopper.Kernel.Types.Transforms Namespace


Generic Members

[image] [image]

Grasshopper SDK
Generic Members
Generic Class Constructors Methods Properties See Also Send Feedback

The Generic type exposes the following members.

Constructors

 | Name | Description
Public method | Generic()()()() | Initializes a new instance of the Generic class
Public method | Generic(Transform) | Initializes a new instance of the Generic class

Methods

 | Name | Description
Public method | Duplicate |
Public method | Read |
Public method | Reverse |
Public method | ToMatrix |
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | Write |

Properties

 | Name | Description
Public property | Name |
Public property | Transform |

See Also

Generic Class
Grasshopper.Kernel.Types.Transforms Namespace


Generic Constructor

[image] [image]

Grasshopper SDK
Generic Constructor
Generic Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Generic()()()() | Initializes a new instance of the Generic class
Public method | Generic(Transform) | Initializes a new instance of the Generic class

See Also

Generic Class
Generic Members
Grasshopper.Kernel.Types.Transforms Namespace


Generic Constructor

[image]

Grasshopper SDK
Generic Constructor
Generic Class See Also Send Feedback
Initializes a new instance of the Generic class

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Generic()
Visual Basic
Public Sub New

See Also

Generic Class
Generic Overload
Grasshopper.Kernel.Types.Transforms Namespace


Generic Constructor ()

[image]

Grasshopper SDK
Generic Constructor ()
Generic Class See Also Send Feedback
Initializes a new instance of the Generic class

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Generic(
    Transform transform
)
Visual Basic
Public Sub New ( _
    transform As Transform _
)

Parameters

transform
Type: Transform

See Also

Generic Class
Generic Overload
Grasshopper.Kernel.Types.Transforms Namespace


Generic Methods

[image] [image]

Grasshopper SDK
Generic Methods
Generic Class See Also Send Feedback

The Generic type exposes the following members.

Methods

 | Name | Description
Public method | Duplicate |
Public method | Read |
Public method | Reverse |
Public method | ToMatrix |
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | Write |

See Also

Generic Class
Grasshopper.Kernel.Types.Transforms Namespace


Duplicate Method

[image]

Grasshopper SDK
Generic..::..Duplicate Method
Generic Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public ITransform Duplicate()
Visual Basic
Public Function Duplicate As ITransform

Implements

ITransform..::..Duplicate()()()()

See Also

Generic Class
Grasshopper.Kernel.Types.Transforms Namespace


Read Method

[image]

Grasshopper SDK
Generic..::..Read Method
Generic Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Read(
    GH_IReader reader
)
Visual Basic
Public Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

Implements

GH_ISerializable..::..Read(GH_IReader)

See Also

Generic Class
Grasshopper.Kernel.Types.Transforms Namespace


Reverse Method

[image]

Grasshopper SDK
Generic..::..Reverse Method
Generic Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public ITransform Reverse()
Visual Basic
Public Function Reverse As ITransform

Implements

ITransform..::..Reverse()()()()

See Also

Generic Class
Grasshopper.Kernel.Types.Transforms Namespace


ToMatrix Method

[image]

Grasshopper SDK
Generic..::..ToMatrix Method
Generic Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Transform ToMatrix()
Visual Basic
Public Function ToMatrix As Transform

Implements

ITransform..::..ToMatrix()()()()

See Also

Generic Class
Grasshopper.Kernel.Types.Transforms Namespace


ToString Method

[image]

Grasshopper SDK
Generic..::..ToString Method
Generic Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Implements

ITransform..::..ToString()()()()

See Also

Generic Class
Grasshopper.Kernel.Types.Transforms Namespace


Write Method

[image]

Grasshopper SDK
Generic..::..Write Method
Generic Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Write(
    GH_IWriter writer
)
Visual Basic
Public Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

Implements

GH_ISerializable..::..Write(GH_IWriter)

See Also

Generic Class
Grasshopper.Kernel.Types.Transforms Namespace


Generic Properties

[image] [image]

Grasshopper SDK
Generic Properties
Generic Class See Also Send Feedback

The Generic type exposes the following members.

Properties

 | Name | Description
Public property | Name |
Public property | Transform |

See Also

Generic Class
Grasshopper.Kernel.Types.Transforms Namespace


Name Property

[image]

Grasshopper SDK
Generic..::..Name Property
Generic Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.Transforms.Generic.Name"]

Implements

ITransform..::..Name

See Also

Generic Class
Grasshopper.Kernel.Types.Transforms Namespace


Transform Property

[image]

Grasshopper SDK
Generic..::..Transform Property
Generic Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Transform Transform { get; set; }
Visual Basic
Public Property Transform As Transform
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.Transforms.Generic.Transform"]

See Also

Generic Class
Grasshopper.Kernel.Types.Transforms Namespace


Identity Class

[image]

Grasshopper SDK
Identity Class
Members See Also Send Feedback
Implements a null-transform.

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class Identity : ITransform
Visual Basic
Public Class Identity _
    Implements ITransform

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types.Transforms..::..Identity

See Also

Identity Members
Grasshopper.Kernel.Types.Transforms Namespace


Identity Members

[image] [image]

Grasshopper SDK
Identity Members
Identity Class Constructors Methods Properties See Also Send Feedback

The Identity type exposes the following members.

Constructors

 | Name | Description
Public method | Identity | Initializes a new instance of the Identity class

Methods

 | Name | Description
Public method | Duplicate |
Public method | Read |
Public method | Reverse |
Public method | ToMatrix |
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | Write |

Properties

 | Name | Description
Public property | Name |

See Also

Identity Class
Grasshopper.Kernel.Types.Transforms Namespace


Identity Constructor

[image]

Grasshopper SDK
Identity Constructor
Identity Class See Also Send Feedback
Initializes a new instance of the Identity class

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Identity()
Visual Basic
Public Sub New

See Also

Identity Class
Grasshopper.Kernel.Types.Transforms Namespace


Identity Methods

[image] [image]

Grasshopper SDK
Identity Methods
Identity Class See Also Send Feedback

The Identity type exposes the following members.

Methods

 | Name | Description
Public method | Duplicate |
Public method | Read |
Public method | Reverse |
Public method | ToMatrix |
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | Write |

See Also

Identity Class
Grasshopper.Kernel.Types.Transforms Namespace


Duplicate Method

[image]

Grasshopper SDK
Identity..::..Duplicate Method
Identity Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public ITransform Duplicate()
Visual Basic
Public Function Duplicate As ITransform

Implements

ITransform..::..Duplicate()()()()

See Also

Identity Class
Grasshopper.Kernel.Types.Transforms Namespace


Read Method

[image]

Grasshopper SDK
Identity..::..Read Method
Identity Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Read(
    GH_IReader reader
)
Visual Basic
Public Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

Implements

GH_ISerializable..::..Read(GH_IReader)

See Also

Identity Class
Grasshopper.Kernel.Types.Transforms Namespace


Reverse Method

[image]

Grasshopper SDK
Identity..::..Reverse Method
Identity Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public ITransform Reverse()
Visual Basic
Public Function Reverse As ITransform

Implements

ITransform..::..Reverse()()()()

See Also

Identity Class
Grasshopper.Kernel.Types.Transforms Namespace


ToMatrix Method

[image]

Grasshopper SDK
Identity..::..ToMatrix Method
Identity Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Transform ToMatrix()
Visual Basic
Public Function ToMatrix As Transform

Implements

ITransform..::..ToMatrix()()()()

See Also

Identity Class
Grasshopper.Kernel.Types.Transforms Namespace


ToString Method

[image]

Grasshopper SDK
Identity..::..ToString Method
Identity Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Implements

ITransform..::..ToString()()()()

See Also

Identity Class
Grasshopper.Kernel.Types.Transforms Namespace


Write Method

[image]

Grasshopper SDK
Identity..::..Write Method
Identity Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Write(
    GH_IWriter writer
)
Visual Basic
Public Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

Implements

GH_ISerializable..::..Write(GH_IWriter)

See Also

Identity Class
Grasshopper.Kernel.Types.Transforms Namespace


Identity Properties

[image] [image]

Grasshopper SDK
Identity Properties
Identity Class See Also Send Feedback

The Identity type exposes the following members.

Properties

 | Name | Description
Public property | Name |

See Also

Identity Class
Grasshopper.Kernel.Types.Transforms Namespace


Name Property

[image]

Grasshopper SDK
Identity..::..Name Property
Identity Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.Transforms.Identity.Name"]

Implements

ITransform..::..Name

See Also

Identity Class
Grasshopper.Kernel.Types.Transforms Namespace


ITransform Interface

[image]

Grasshopper SDK
ITransform Interface
Members See Also Send Feedback
Basic interface for a single Grasshopper transformation.

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface ITransform : GH_ISerializable
Visual Basic
Public Interface ITransform _
    Inherits GH_ISerializable

See Also

ITransform Members
Grasshopper.Kernel.Types.Transforms Namespace


ITransform Members

[image] [image]

Grasshopper SDK
ITransform Members
ITransform Interface Methods Properties See Also Send Feedback

The ITransform type exposes the following members.

Methods

 | Name | Description
Public method | Duplicate |
Public method | Read | This method is called whenever the instance is required to deserialize itself. (Inherited from GH_ISerializable.)
Public method | Reverse |
Public method | ToMatrix |
Public method | ToString |
Public method | Write | This method is called whenever the instance is required to serialize itself. (Inherited from GH_ISerializable.)

Properties

 | Name | Description
Public property | Name |

See Also

ITransform Interface
Grasshopper.Kernel.Types.Transforms Namespace


ITransform Methods

[image] [image]

Grasshopper SDK
ITransform Methods
ITransform Interface See Also Send Feedback

The ITransform type exposes the following members.

Methods

 | Name | Description
Public method | Duplicate |
Public method | Read | This method is called whenever the instance is required to deserialize itself. (Inherited from GH_ISerializable.)
Public method | Reverse |
Public method | ToMatrix |
Public method | ToString |
Public method | Write | This method is called whenever the instance is required to serialize itself. (Inherited from GH_ISerializable.)

See Also

ITransform Interface
Grasshopper.Kernel.Types.Transforms Namespace


Duplicate Method

[image]

Grasshopper SDK
ITransform..::..Duplicate Method
ITransform Interface See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
ITransform Duplicate()
Visual Basic
Function Duplicate As ITransform

See Also

ITransform Interface
Grasshopper.Kernel.Types.Transforms Namespace


Reverse Method

[image]

Grasshopper SDK
ITransform..::..Reverse Method
ITransform Interface See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
ITransform Reverse()
Visual Basic
Function Reverse As ITransform

See Also

ITransform Interface
Grasshopper.Kernel.Types.Transforms Namespace


ToMatrix Method

[image]

Grasshopper SDK
ITransform..::..ToMatrix Method
ITransform Interface See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
Transform ToMatrix()
Visual Basic
Function ToMatrix As Transform

See Also

ITransform Interface
Grasshopper.Kernel.Types.Transforms Namespace


ToString Method

[image]

Grasshopper SDK
ITransform..::..ToString Method
ITransform Interface See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string ToString()
Visual Basic
Function ToString As String

See Also

ITransform Interface
Grasshopper.Kernel.Types.Transforms Namespace


ITransform Properties

[image] [image]

Grasshopper SDK
ITransform Properties
ITransform Interface See Also Send Feedback

The ITransform type exposes the following members.

Properties

 | Name | Description
Public property | Name |

See Also

ITransform Interface
Grasshopper.Kernel.Types.Transforms Namespace


Name Property

[image]

Grasshopper SDK
ITransform..::..Name Property
ITransform Interface See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
string Name { get; }
Visual Basic
ReadOnly Property Name As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.Transforms.ITransform.Name"]

See Also

ITransform Interface
Grasshopper.Kernel.Types.Transforms Namespace


Orientation Class

[image]

Grasshopper SDK
Orientation Class
Members See Also Send Feedback
Implements an orientation (ChangeBasis) transformation.

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class Orientation : ITransform
Visual Basic
Public Class Orientation _
    Implements ITransform

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types.Transforms..::..Orientation

See Also

Orientation Members
Grasshopper.Kernel.Types.Transforms Namespace


Orientation Members

[image] [image]

Grasshopper SDK
Orientation Members
Orientation Class Constructors Methods Properties See Also Send Feedback

The Orientation type exposes the following members.

Constructors

 | Name | Description
Public method | Orientation()()()() | Initializes a new instance of the Orientation class
Public method | Orientation(Plane, Plane) | Initializes a new instance of the Orientation class

Methods

 | Name | Description
Public method | Duplicate |
Public method | Read |
Public method | Reverse |
Public method | ToMatrix |
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | Write |

Properties

 | Name | Description
Public property | Name |
Public property | SourceFrame |
Public property | TargetFrame |

See Also

Orientation Class
Grasshopper.Kernel.Types.Transforms Namespace


Orientation Constructor

[image] [image]

Grasshopper SDK
Orientation Constructor
Orientation Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Orientation()()()() | Initializes a new instance of the Orientation class
Public method | Orientation(Plane, Plane) | Initializes a new instance of the Orientation class

See Also

Orientation Class
Orientation Members
Grasshopper.Kernel.Types.Transforms Namespace


Orientation Constructor

[image]

Grasshopper SDK
Orientation Constructor
Orientation Class See Also Send Feedback
Initializes a new instance of the Orientation class

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Orientation()
Visual Basic
Public Sub New

See Also

Orientation Class
Orientation Overload
Grasshopper.Kernel.Types.Transforms Namespace


Orientation Constructor (, )

[image]

Grasshopper SDK
Orientation Constructor (, )
Orientation Class See Also Send Feedback
Initializes a new instance of the Orientation class

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Orientation(
    Plane source,
    Plane target
)
Visual Basic
Public Sub New ( _
    source As Plane, _
    target As Plane _
)

Parameters

source
Type: Plane
target
Type: Plane

See Also

Orientation Class
Orientation Overload
Grasshopper.Kernel.Types.Transforms Namespace


Orientation Methods

[image] [image]

Grasshopper SDK
Orientation Methods
Orientation Class See Also Send Feedback

The Orientation type exposes the following members.

Methods

 | Name | Description
Public method | Duplicate |
Public method | Read |
Public method | Reverse |
Public method | ToMatrix |
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | Write |

See Also

Orientation Class
Grasshopper.Kernel.Types.Transforms Namespace


Duplicate Method

[image]

Grasshopper SDK
Orientation..::..Duplicate Method
Orientation Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public ITransform Duplicate()
Visual Basic
Public Function Duplicate As ITransform

Implements

ITransform..::..Duplicate()()()()

See Also

Orientation Class
Grasshopper.Kernel.Types.Transforms Namespace


Read Method

[image]

Grasshopper SDK
Orientation..::..Read Method
Orientation Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Read(
    GH_IReader reader
)
Visual Basic
Public Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

Implements

GH_ISerializable..::..Read(GH_IReader)

See Also

Orientation Class
Grasshopper.Kernel.Types.Transforms Namespace


Reverse Method

[image]

Grasshopper SDK
Orientation..::..Reverse Method
Orientation Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public ITransform Reverse()
Visual Basic
Public Function Reverse As ITransform

Implements

ITransform..::..Reverse()()()()

See Also

Orientation Class
Grasshopper.Kernel.Types.Transforms Namespace


ToMatrix Method

[image]

Grasshopper SDK
Orientation..::..ToMatrix Method
Orientation Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Transform ToMatrix()
Visual Basic
Public Function ToMatrix As Transform

Implements

ITransform..::..ToMatrix()()()()

See Also

Orientation Class
Grasshopper.Kernel.Types.Transforms Namespace


ToString Method

[image]

Grasshopper SDK
Orientation..::..ToString Method
Orientation Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Implements

ITransform..::..ToString()()()()

See Also

Orientation Class
Grasshopper.Kernel.Types.Transforms Namespace


Write Method

[image]

Grasshopper SDK
Orientation..::..Write Method
Orientation Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Write(
    GH_IWriter writer
)
Visual Basic
Public Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

Implements

GH_ISerializable..::..Write(GH_IWriter)

See Also

Orientation Class
Grasshopper.Kernel.Types.Transforms Namespace


Orientation Properties

[image] [image]

Grasshopper SDK
Orientation Properties
Orientation Class See Also Send Feedback

The Orientation type exposes the following members.

Properties

 | Name | Description
Public property | Name |
Public property | SourceFrame |
Public property | TargetFrame |

See Also

Orientation Class
Grasshopper.Kernel.Types.Transforms Namespace


Name Property

[image]

Grasshopper SDK
Orientation..::..Name Property
Orientation Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.Transforms.Orientation.Name"]

Implements

ITransform..::..Name

See Also

Orientation Class
Grasshopper.Kernel.Types.Transforms Namespace


SourceFrame Property

[image]

Grasshopper SDK
Orientation..::..SourceFrame Property
Orientation Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Plane SourceFrame { get; set; }
Visual Basic
Public Property SourceFrame As Plane
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.Transforms.Orientation.SourceFrame"]

See Also

Orientation Class
Grasshopper.Kernel.Types.Transforms Namespace


TargetFrame Property

[image]

Grasshopper SDK
Orientation..::..TargetFrame Property
Orientation Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Plane TargetFrame { get; set; }
Visual Basic
Public Property TargetFrame As Plane
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.Transforms.Orientation.TargetFrame"]

See Also

Orientation Class
Grasshopper.Kernel.Types.Transforms Namespace


Projection Class

[image]

Grasshopper SDK
Projection Class
Members See Also Send Feedback
Implements a projection transformation.

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class Projection : ITransform
Visual Basic
Public Class Projection _
    Implements ITransform

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types.Transforms..::..Projection

See Also

Projection Members
Grasshopper.Kernel.Types.Transforms Namespace


Projection Members

[image] [image]

Grasshopper SDK
Projection Members
Projection Class Constructors Methods Properties See Also Send Feedback

The Projection type exposes the following members.

Constructors

 | Name | Description
Public method | Projection()()()() | Initializes a new instance of the Projection class
Public method | Projection(Plane) | Initializes a new instance of the Projection class

Methods

 | Name | Description
Public method | Duplicate |
Public method | Read |
Public method | Reverse |
Public method | ToMatrix |
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | Write |

Properties

 | Name | Description
Public property | Name |
Public property | ProjectionPlane |

See Also

Projection Class
Grasshopper.Kernel.Types.Transforms Namespace


Projection Constructor

[image] [image]

Grasshopper SDK
Projection Constructor
Projection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Projection()()()() | Initializes a new instance of the Projection class
Public method | Projection(Plane) | Initializes a new instance of the Projection class

See Also

Projection Class
Projection Members
Grasshopper.Kernel.Types.Transforms Namespace


Projection Constructor

[image]

Grasshopper SDK
Projection Constructor
Projection Class See Also Send Feedback
Initializes a new instance of the Projection class

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Projection()
Visual Basic
Public Sub New

See Also

Projection Class
Projection Overload
Grasshopper.Kernel.Types.Transforms Namespace


Projection Constructor ()

[image]

Grasshopper SDK
Projection Constructor ()
Projection Class See Also Send Feedback
Initializes a new instance of the Projection class

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Projection(
    Plane plane
)
Visual Basic
Public Sub New ( _
    plane As Plane _
)

Parameters

plane
Type: Plane

See Also

Projection Class
Projection Overload
Grasshopper.Kernel.Types.Transforms Namespace


Projection Methods

[image] [image]

Grasshopper SDK
Projection Methods
Projection Class See Also Send Feedback

The Projection type exposes the following members.

Methods

 | Name | Description
Public method | Duplicate |
Public method | Read |
Public method | Reverse |
Public method | ToMatrix |
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | Write |

See Also

Projection Class
Grasshopper.Kernel.Types.Transforms Namespace


Duplicate Method

[image]

Grasshopper SDK
Projection..::..Duplicate Method
Projection Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public ITransform Duplicate()
Visual Basic
Public Function Duplicate As ITransform

Implements

ITransform..::..Duplicate()()()()

See Also

Projection Class
Grasshopper.Kernel.Types.Transforms Namespace


Read Method

[image]

Grasshopper SDK
Projection..::..Read Method
Projection Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Read(
    GH_IReader reader
)
Visual Basic
Public Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

Implements

GH_ISerializable..::..Read(GH_IReader)

See Also

Projection Class
Grasshopper.Kernel.Types.Transforms Namespace


Reverse Method

[image]

Grasshopper SDK
Projection..::..Reverse Method
Projection Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public ITransform Reverse()
Visual Basic
Public Function Reverse As ITransform

Implements

ITransform..::..Reverse()()()()

See Also

Projection Class
Grasshopper.Kernel.Types.Transforms Namespace


ToMatrix Method

[image]

Grasshopper SDK
Projection..::..ToMatrix Method
Projection Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Transform ToMatrix()
Visual Basic
Public Function ToMatrix As Transform

Implements

ITransform..::..ToMatrix()()()()

See Also

Projection Class
Grasshopper.Kernel.Types.Transforms Namespace


ToString Method

[image]

Grasshopper SDK
Projection..::..ToString Method
Projection Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Implements

ITransform..::..ToString()()()()

See Also

Projection Class
Grasshopper.Kernel.Types.Transforms Namespace


Write Method

[image]

Grasshopper SDK
Projection..::..Write Method
Projection Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Write(
    GH_IWriter writer
)
Visual Basic
Public Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

Implements

GH_ISerializable..::..Write(GH_IWriter)

See Also

Projection Class
Grasshopper.Kernel.Types.Transforms Namespace


Projection Properties

[image] [image]

Grasshopper SDK
Projection Properties
Projection Class See Also Send Feedback

The Projection type exposes the following members.

Properties

 | Name | Description
Public property | Name |
Public property | ProjectionPlane |

See Also

Projection Class
Grasshopper.Kernel.Types.Transforms Namespace


Name Property

[image]

Grasshopper SDK
Projection..::..Name Property
Projection Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.Transforms.Projection.Name"]

Implements

ITransform..::..Name

See Also

Projection Class
Grasshopper.Kernel.Types.Transforms Namespace


ProjectionPlane Property

[image]

Grasshopper SDK
Projection..::..ProjectionPlane Property
Projection Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Plane ProjectionPlane { get; set; }
Visual Basic
Public Property ProjectionPlane As Plane
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.Transforms.Projection.ProjectionPlane"]

See Also

Projection Class
Grasshopper.Kernel.Types.Transforms Namespace


Rotation Class

[image]

Grasshopper SDK
Rotation Class
Members See Also Send Feedback
Implements a rotation transformation.

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class Rotation : ITransform
Visual Basic
Public Class Rotation _
    Implements ITransform

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types.Transforms..::..Rotation

See Also

Rotation Members
Grasshopper.Kernel.Types.Transforms Namespace


Rotation Members

[image] [image]

Grasshopper SDK
Rotation Members
Rotation Class Constructors Methods Properties See Also Send Feedback

The Rotation type exposes the following members.

Constructors

 | Name | Description
Public method | Rotation()()()() | Initializes a new instance of the Rotation class
Public method | Rotation(Point3d, Vector3d, Vector3d) | Initializes a new instance of the Rotation class
Public method | Rotation(Point3d, Vector3d, Double) | Initializes a new instance of the Rotation class

Methods

 | Name | Description
Public method | Duplicate |
Public method | Read |
Public method | Reverse |
Public method | ToMatrix |
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | Write |

Properties

 | Name | Description
Public property | Name |
Public property | RotationAngle |
Public property | RotationAxis |
Public property | RotationCenter |

See Also

Rotation Class
Grasshopper.Kernel.Types.Transforms Namespace


Rotation Constructor

[image] [image]

Grasshopper SDK
Rotation Constructor
Rotation Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Rotation()()()() | Initializes a new instance of the Rotation class
Public method | Rotation(Point3d, Vector3d, Vector3d) | Initializes a new instance of the Rotation class
Public method | Rotation(Point3d, Vector3d, Double) | Initializes a new instance of the Rotation class

See Also

Rotation Class
Rotation Members
Grasshopper.Kernel.Types.Transforms Namespace


Rotation Constructor

[image]

Grasshopper SDK
Rotation Constructor
Rotation Class See Also Send Feedback
Initializes a new instance of the Rotation class

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rotation()
Visual Basic
Public Sub New

See Also

Rotation Class
Rotation Overload
Grasshopper.Kernel.Types.Transforms Namespace


Rotation Constructor (, , )

[image]

Grasshopper SDK
Rotation Constructor (, , )
Rotation Class See Also Send Feedback
Initializes a new instance of the Rotation class

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rotation(
    Point3d center,
    Vector3d dir0,
    Vector3d dir1
)
Visual Basic
Public Sub New ( _
    center As Point3d, _
    dir0 As Vector3d, _
    dir1 As Vector3d _
)

Parameters

center
Type: Point3d
dir0
Type: Vector3d
dir1
Type: Vector3d

See Also

Rotation Class
Rotation Overload
Grasshopper.Kernel.Types.Transforms Namespace


Rotation Constructor (, , Double)

[image]

Grasshopper SDK
Rotation Constructor (, , Double)
Rotation Class See Also Send Feedback
Initializes a new instance of the Rotation class

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Rotation(
    Point3d center,
    Vector3d axis,
    double angle
)
Visual Basic
Public Sub New ( _
    center As Point3d, _
    axis As Vector3d, _
    angle As Double _
)

Parameters

center
Type: Point3d
axis
Type: Vector3d
angle
Type: System..::..Double

See Also

Rotation Class
Rotation Overload
Grasshopper.Kernel.Types.Transforms Namespace


Rotation Methods

[image] [image]

Grasshopper SDK
Rotation Methods
Rotation Class See Also Send Feedback

The Rotation type exposes the following members.

Methods

 | Name | Description
Public method | Duplicate |
Public method | Read |
Public method | Reverse |
Public method | ToMatrix |
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | Write |

See Also

Rotation Class
Grasshopper.Kernel.Types.Transforms Namespace


Duplicate Method

[image]

Grasshopper SDK
Rotation..::..Duplicate Method
Rotation Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public ITransform Duplicate()
Visual Basic
Public Function Duplicate As ITransform

Implements

ITransform..::..Duplicate()()()()

See Also

Rotation Class
Grasshopper.Kernel.Types.Transforms Namespace


Read Method

[image]

Grasshopper SDK
Rotation..::..Read Method
Rotation Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Read(
    GH_IReader reader
)
Visual Basic
Public Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

Implements

GH_ISerializable..::..Read(GH_IReader)

See Also

Rotation Class
Grasshopper.Kernel.Types.Transforms Namespace


Reverse Method

[image]

Grasshopper SDK
Rotation..::..Reverse Method
Rotation Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public ITransform Reverse()
Visual Basic
Public Function Reverse As ITransform

Implements

ITransform..::..Reverse()()()()

See Also

Rotation Class
Grasshopper.Kernel.Types.Transforms Namespace


ToMatrix Method

[image]

Grasshopper SDK
Rotation..::..ToMatrix Method
Rotation Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Transform ToMatrix()
Visual Basic
Public Function ToMatrix As Transform

Implements

ITransform..::..ToMatrix()()()()

See Also

Rotation Class
Grasshopper.Kernel.Types.Transforms Namespace


ToString Method

[image]

Grasshopper SDK
Rotation..::..ToString Method
Rotation Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Implements

ITransform..::..ToString()()()()

See Also

Rotation Class
Grasshopper.Kernel.Types.Transforms Namespace


Write Method

[image]

Grasshopper SDK
Rotation..::..Write Method
Rotation Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Write(
    GH_IWriter writer
)
Visual Basic
Public Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

Implements

GH_ISerializable..::..Write(GH_IWriter)

See Also

Rotation Class
Grasshopper.Kernel.Types.Transforms Namespace


Rotation Properties

[image] [image]

Grasshopper SDK
Rotation Properties
Rotation Class See Also Send Feedback

The Rotation type exposes the following members.

Properties

 | Name | Description
Public property | Name |
Public property | RotationAngle |
Public property | RotationAxis |
Public property | RotationCenter |

See Also

Rotation Class
Grasshopper.Kernel.Types.Transforms Namespace


Name Property

[image]

Grasshopper SDK
Rotation..::..Name Property
Rotation Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.Transforms.Rotation.Name"]

Implements

ITransform..::..Name

See Also

Rotation Class
Grasshopper.Kernel.Types.Transforms Namespace


RotationAngle Property

[image]

Grasshopper SDK
Rotation..::..RotationAngle Property
Rotation Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double RotationAngle { get; set; }
Visual Basic
Public Property RotationAngle As Double
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.Transforms.Rotation.RotationAngle"]

See Also

Rotation Class
Grasshopper.Kernel.Types.Transforms Namespace


RotationAxis Property

[image]

Grasshopper SDK
Rotation..::..RotationAxis Property
Rotation Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Vector3d RotationAxis { get; set; }
Visual Basic
Public Property RotationAxis As Vector3d
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.Transforms.Rotation.RotationAxis"]

See Also

Rotation Class
Grasshopper.Kernel.Types.Transforms Namespace


RotationCenter Property

[image]

Grasshopper SDK
Rotation..::..RotationCenter Property
Rotation Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Point3d RotationCenter { get; set; }
Visual Basic
Public Property RotationCenter As Point3d
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.Transforms.Rotation.RotationCenter"]

See Also

Rotation Class
Grasshopper.Kernel.Types.Transforms Namespace


Scale Class

[image]

Grasshopper SDK
Scale Class
Members See Also Send Feedback
Implements a scaling transformation.

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class Scale : ITransform
Visual Basic
Public Class Scale _
    Implements ITransform

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types.Transforms..::..Scale

See Also

Scale Members
Grasshopper.Kernel.Types.Transforms Namespace


Scale Members

[image] [image]

Grasshopper SDK
Scale Members
Scale Class Constructors Methods Properties See Also Send Feedback

The Scale type exposes the following members.

Constructors

 | Name | Description
Public method | Scale()()()() | Initializes a new instance of the Scale class
Public method | Scale(Plane, Double) | Initializes a new instance of the Scale class
Public method | Scale(Point3d, Double) | Initializes a new instance of the Scale class
Public method | Scale(Plane, Double, Double, Double) | Initializes a new instance of the Scale class

Methods

 | Name | Description
Public method | Duplicate |
Public method | Read |
Public method | Reverse |
Public method | ToMatrix |
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | Write |

Properties

 | Name | Description
Public property | Name |
Public property | ScaleXFactor |
Public property | ScaleYFactor |
Public property | ScaleZFactor |
Public property | ScalingFrame |

See Also

Scale Class
Grasshopper.Kernel.Types.Transforms Namespace


Scale Constructor

[image] [image]

Grasshopper SDK
Scale Constructor
Scale Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale()()()() | Initializes a new instance of the Scale class
Public method | Scale(Plane, Double) | Initializes a new instance of the Scale class
Public method | Scale(Point3d, Double) | Initializes a new instance of the Scale class
Public method | Scale(Plane, Double, Double, Double) | Initializes a new instance of the Scale class

See Also

Scale Class
Scale Members
Grasshopper.Kernel.Types.Transforms Namespace


Scale Constructor

[image]

Grasshopper SDK
Scale Constructor
Scale Class See Also Send Feedback
Initializes a new instance of the Scale class

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Scale()
Visual Basic
Public Sub New

See Also

Scale Class
Scale Overload
Grasshopper.Kernel.Types.Transforms Namespace


Scale Constructor (, Double)

[image]

Grasshopper SDK
Scale Constructor (, Double)
Scale Class See Also Send Feedback
Initializes a new instance of the Scale class

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Scale(
    Plane frame,
    double scale
)
Visual Basic
Public Sub New ( _
    frame As Plane, _
    scale As Double _
)

Parameters

frame
Type: Plane
scale
Type: System..::..Double

See Also

Scale Class
Scale Overload
Grasshopper.Kernel.Types.Transforms Namespace


Scale Constructor (, Double)

[image]

Grasshopper SDK
Scale Constructor (, Double)
Scale Class See Also Send Feedback
Initializes a new instance of the Scale class

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Scale(
    Point3d point,
    double scale
)
Visual Basic
Public Sub New ( _
    point As Point3d, _
    scale As Double _
)

Parameters

point
Type: Point3d
scale
Type: System..::..Double

See Also

Scale Class
Scale Overload
Grasshopper.Kernel.Types.Transforms Namespace


Scale Constructor (, Double, Double, Double)

[image]

Grasshopper SDK
Scale Constructor (, Double, Double, Double)
Scale Class See Also Send Feedback
Initializes a new instance of the Scale class

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Scale(
    Plane frame,
    double xscale,
    double yscale,
    double zscale
)
Visual Basic
Public Sub New ( _
    frame As Plane, _
    xscale As Double, _
    yscale As Double, _
    zscale As Double _
)

Parameters

frame
Type: Plane
xscale
Type: System..::..Double
yscale
Type: System..::..Double
zscale
Type: System..::..Double

See Also

Scale Class
Scale Overload
Grasshopper.Kernel.Types.Transforms Namespace


Scale Methods

[image] [image]

Grasshopper SDK
Scale Methods
Scale Class See Also Send Feedback

The Scale type exposes the following members.

Methods

 | Name | Description
Public method | Duplicate |
Public method | Read |
Public method | Reverse |
Public method | ToMatrix |
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | Write |

See Also

Scale Class
Grasshopper.Kernel.Types.Transforms Namespace


Duplicate Method

[image]

Grasshopper SDK
Scale..::..Duplicate Method
Scale Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public ITransform Duplicate()
Visual Basic
Public Function Duplicate As ITransform

Implements

ITransform..::..Duplicate()()()()

See Also

Scale Class
Grasshopper.Kernel.Types.Transforms Namespace


Read Method

[image]

Grasshopper SDK
Scale..::..Read Method
Scale Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Read(
    GH_IReader reader
)
Visual Basic
Public Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

Implements

GH_ISerializable..::..Read(GH_IReader)

See Also

Scale Class
Grasshopper.Kernel.Types.Transforms Namespace


Reverse Method

[image]

Grasshopper SDK
Scale..::..Reverse Method
Scale Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public ITransform Reverse()
Visual Basic
Public Function Reverse As ITransform

Implements

ITransform..::..Reverse()()()()

See Also

Scale Class
Grasshopper.Kernel.Types.Transforms Namespace


ToMatrix Method

[image]

Grasshopper SDK
Scale..::..ToMatrix Method
Scale Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Transform ToMatrix()
Visual Basic
Public Function ToMatrix As Transform

Implements

ITransform..::..ToMatrix()()()()

See Also

Scale Class
Grasshopper.Kernel.Types.Transforms Namespace


ToString Method

[image]

Grasshopper SDK
Scale..::..ToString Method
Scale Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Implements

ITransform..::..ToString()()()()

See Also

Scale Class
Grasshopper.Kernel.Types.Transforms Namespace


Write Method

[image]

Grasshopper SDK
Scale..::..Write Method
Scale Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Write(
    GH_IWriter writer
)
Visual Basic
Public Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

Implements

GH_ISerializable..::..Write(GH_IWriter)

See Also

Scale Class
Grasshopper.Kernel.Types.Transforms Namespace


Scale Properties

[image] [image]

Grasshopper SDK
Scale Properties
Scale Class See Also Send Feedback

The Scale type exposes the following members.

Properties

 | Name | Description
Public property | Name |
Public property | ScaleXFactor |
Public property | ScaleYFactor |
Public property | ScaleZFactor |
Public property | ScalingFrame |

See Also

Scale Class
Grasshopper.Kernel.Types.Transforms Namespace


Name Property

[image]

Grasshopper SDK
Scale..::..Name Property
Scale Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.Transforms.Scale.Name"]

Implements

ITransform..::..Name

See Also

Scale Class
Grasshopper.Kernel.Types.Transforms Namespace


ScaleXFactor Property

[image]

Grasshopper SDK
Scale..::..ScaleXFactor Property
Scale Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double ScaleXFactor { get; set; }
Visual Basic
Public Property ScaleXFactor As Double
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.Transforms.Scale.ScaleXFactor"]

See Also

Scale Class
Grasshopper.Kernel.Types.Transforms Namespace


ScaleYFactor Property

[image]

Grasshopper SDK
Scale..::..ScaleYFactor Property
Scale Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double ScaleYFactor { get; set; }
Visual Basic
Public Property ScaleYFactor As Double
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.Transforms.Scale.ScaleYFactor"]

See Also

Scale Class
Grasshopper.Kernel.Types.Transforms Namespace


ScaleZFactor Property

[image]

Grasshopper SDK
Scale..::..ScaleZFactor Property
Scale Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public double ScaleZFactor { get; set; }
Visual Basic
Public Property ScaleZFactor As Double
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.Transforms.Scale.ScaleZFactor"]

See Also

Scale Class
Grasshopper.Kernel.Types.Transforms Namespace


ScalingFrame Property

[image]

Grasshopper SDK
Scale..::..ScalingFrame Property
Scale Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Plane ScalingFrame { get; set; }
Visual Basic
Public Property ScalingFrame As Plane
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.Transforms.Scale.ScalingFrame"]

See Also

Scale Class
Grasshopper.Kernel.Types.Transforms Namespace


Translation Class

[image]

Grasshopper SDK
Translation Class
Members See Also Send Feedback
Implements a translation (Move) transformation.

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class Translation : ITransform
Visual Basic
Public Class Translation _
    Implements ITransform

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Types.Transforms..::..Translation

See Also

Translation Members
Grasshopper.Kernel.Types.Transforms Namespace


Translation Members

[image] [image]

Grasshopper SDK
Translation Members
Translation Class Constructors Methods Properties See Also Send Feedback

The Translation type exposes the following members.

Constructors

 | Name | Description
Public method | Translation()()()() | Initializes a new instance of the Translation class
Public method | Translation(Vector3d) | Initializes a new instance of the Translation class

Methods

 | Name | Description
Public method | Duplicate |
Public method | Read |
Public method | Reverse |
Public method | ToMatrix |
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | Write |

Properties

 | Name | Description
Public property | Name |
Public property | TranslationVector |

See Also

Translation Class
Grasshopper.Kernel.Types.Transforms Namespace


Translation Constructor

[image] [image]

Grasshopper SDK
Translation Constructor
Translation Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Translation()()()() | Initializes a new instance of the Translation class
Public method | Translation(Vector3d) | Initializes a new instance of the Translation class

See Also

Translation Class
Translation Members
Grasshopper.Kernel.Types.Transforms Namespace


Translation Constructor

[image]

Grasshopper SDK
Translation Constructor
Translation Class See Also Send Feedback
Initializes a new instance of the Translation class

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Translation()
Visual Basic
Public Sub New

See Also

Translation Class
Translation Overload
Grasshopper.Kernel.Types.Transforms Namespace


Translation Constructor ()

[image]

Grasshopper SDK
Translation Constructor ()
Translation Class See Also Send Feedback
Initializes a new instance of the Translation class

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Translation(
    Vector3d translation
)
Visual Basic
Public Sub New ( _
    translation As Vector3d _
)

Parameters

translation
Type: Vector3d

See Also

Translation Class
Translation Overload
Grasshopper.Kernel.Types.Transforms Namespace


Translation Methods

[image] [image]

Grasshopper SDK
Translation Methods
Translation Class See Also Send Feedback

The Translation type exposes the following members.

Methods

 | Name | Description
Public method | Duplicate |
Public method | Read |
Public method | Reverse |
Public method | ToMatrix |
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | Write |

See Also

Translation Class
Grasshopper.Kernel.Types.Transforms Namespace


Duplicate Method

[image]

Grasshopper SDK
Translation..::..Duplicate Method
Translation Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public ITransform Duplicate()
Visual Basic
Public Function Duplicate As ITransform

Implements

ITransform..::..Duplicate()()()()

See Also

Translation Class
Grasshopper.Kernel.Types.Transforms Namespace


Read Method

[image]

Grasshopper SDK
Translation..::..Read Method
Translation Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Read(
    GH_IReader reader
)
Visual Basic
Public Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

Implements

GH_ISerializable..::..Read(GH_IReader)

See Also

Translation Class
Grasshopper.Kernel.Types.Transforms Namespace


Reverse Method

[image]

Grasshopper SDK
Translation..::..Reverse Method
Translation Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public ITransform Reverse()
Visual Basic
Public Function Reverse As ITransform

Implements

ITransform..::..Reverse()()()()

See Also

Translation Class
Grasshopper.Kernel.Types.Transforms Namespace


ToMatrix Method

[image]

Grasshopper SDK
Translation..::..ToMatrix Method
Translation Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Transform ToMatrix()
Visual Basic
Public Function ToMatrix As Transform

Implements

ITransform..::..ToMatrix()()()()

See Also

Translation Class
Grasshopper.Kernel.Types.Transforms Namespace


ToString Method

[image]

Grasshopper SDK
Translation..::..ToString Method
Translation Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Implements

ITransform..::..ToString()()()()

See Also

Translation Class
Grasshopper.Kernel.Types.Transforms Namespace


Write Method

[image]

Grasshopper SDK
Translation..::..Write Method
Translation Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool Write(
    GH_IWriter writer
)
Visual Basic
Public Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

Implements

GH_ISerializable..::..Write(GH_IWriter)

See Also

Translation Class
Grasshopper.Kernel.Types.Transforms Namespace


Translation Properties

[image] [image]

Grasshopper SDK
Translation Properties
Translation Class See Also Send Feedback

The Translation type exposes the following members.

Properties

 | Name | Description
Public property | Name |
Public property | TranslationVector |

See Also

Translation Class
Grasshopper.Kernel.Types.Transforms Namespace


Name Property

[image]

Grasshopper SDK
Translation..::..Name Property
Translation Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.Transforms.Translation.Name"]

Implements

ITransform..::..Name

See Also

Translation Class
Grasshopper.Kernel.Types.Transforms Namespace


TranslationVector Property

[image]

Grasshopper SDK
Translation..::..TranslationVector Property
Translation Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Types.Transforms
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Vector3d TranslationVector { get; set; }
Visual Basic
Public Property TranslationVector As Vector3d
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Types.Transforms.Translation.TranslationVector"]

See Also

Translation Class
Grasshopper.Kernel.Types.Transforms Namespace


Grasshopper.Kernel.Undo Namespace

[image]

Grasshopper SDK
Grasshopper.Kernel.Undo Namespace
Send Feedback
Namespace that contains all the types and methods to do with the recording and re-instating GHX undo/redo data.

Classes

 | Class | Description
Public class | GH_ArchivedUndoAction | Base class implementation for undo actions that require (de)serialization of data.
Public class | GH_ObjectUndoAction | Utility base class for undo actions that operate on a single IGH_DocumentObject.
Public class | GH_UndoAction | Base class implementation for undo actions.
Public class | GH_UndoException | Exception associated with undo events
Public class | GH_UndoRecord | Represents a single undo/redo record. A single record may contain any number of undo actions.
Public class | GH_UndoServer | Provides access to a documents undo data.

Interfaces

 | Interface | Description
Public interface | IGH_UndoAction | Base interface for all undo/redo actions

Enumerations

 | Enumeration | Description
Public enumeration | GH_UndoState | State enumeration for undo records.


GH_ArchivedUndoAction Class

[image]

Grasshopper SDK
GH_ArchivedUndoAction Class
Members See Also Send Feedback
Base class implementation for undo actions that require (de)serialization of data.

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract class GH_ArchivedUndoAction : GH_UndoAction
Visual Basic
Public MustInherit Class GH_ArchivedUndoAction _
    Inherits GH_UndoAction

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Undo..::..GH_UndoAction
Grasshopper.Kernel.Undo..::..GH_ArchivedUndoAction
Grasshopper.Kernel.Undo.Actions..::..GH_AddStateAction
Grasshopper.Kernel.Undo.Actions..::..GH_GenericObjectAction
Grasshopper.Kernel.Undo.Actions..::..GH_RemoveObjectAction
Grasshopper.Kernel.Undo.Actions..::..GH_RemoveStateAction

See Also

GH_ArchivedUndoAction Members
Grasshopper.Kernel.Undo Namespace


GH_ArchivedUndoAction Members

[image] [image]

Grasshopper SDK
GH_ArchivedUndoAction Members
GH_ArchivedUndoAction Class Constructors Methods Fields Properties See Also Send Feedback

The GH_ArchivedUndoAction type exposes the following members.

Constructors

 | Name | Description
Protected method | GH_ArchivedUndoAction | Initializes a new instance of the GH_ArchivedUndoAction class

Methods

 | Name | Description
Protected method | Deserialize | Deserializes the obj from the local archive.
Protected method | Internal_Redo | (Inherited from GH_UndoAction.)
Protected method | Internal_Undo | (Inherited from GH_UndoAction.)
Public method | Read | (Overrides GH_UndoAction..::..Read(GH_IReader).)
Public method | Redo | (Inherited from GH_UndoAction.)
Protected method | Serialize | Serializes the obj into the local archive.
Protected method | SerializeToByteArray | Serializes the obj into the local archive.
Public method | Undo | (Inherited from GH_UndoAction.)
Public method | Write | (Overrides GH_UndoAction..::..Write(GH_IWriter).)

Fields

 | Name | Description
Protected field | m_data | Internal data storage for serialized archives.

Properties

 | Name | Description
Public property | ExpiresDisplay | Override this property if you want the Rhino viewport display to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | ExpiresSolution | Override this property if you want the Grasshopper solution to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | State | (Inherited from GH_UndoAction.)

See Also

GH_ArchivedUndoAction Class
Grasshopper.Kernel.Undo Namespace


GH_ArchivedUndoAction Constructor

[image]

Grasshopper SDK
GH_ArchivedUndoAction Constructor
GH_ArchivedUndoAction Class See Also Send Feedback
Initializes a new instance of the GH_ArchivedUndoAction class

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_ArchivedUndoAction()
Visual Basic
Protected Sub New

See Also

GH_ArchivedUndoAction Class
Grasshopper.Kernel.Undo Namespace


GH_ArchivedUndoAction Fields

[image] [image]

Grasshopper SDK
GH_ArchivedUndoAction Fields
GH_ArchivedUndoAction Class See Also Send Feedback

The GH_ArchivedUndoAction type exposes the following members.

Fields

 | Name | Description
Protected field | m_data | Internal data storage for serialized archives.

See Also

GH_ArchivedUndoAction Class
Grasshopper.Kernel.Undo Namespace


m_data Field

[image]

Grasshopper SDK
GH_ArchivedUndoAction..::..m_data Field
GH_ArchivedUndoAction Class See Also Send Feedback
Internal data storage for serialized archives.

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected byte[] m_data
Visual Basic
Protected m_data As Byte()

See Also

GH_ArchivedUndoAction Class
Grasshopper.Kernel.Undo Namespace


GH_ArchivedUndoAction Methods

[image] [image]

Grasshopper SDK
GH_ArchivedUndoAction Methods
GH_ArchivedUndoAction Class See Also Send Feedback

The GH_ArchivedUndoAction type exposes the following members.

Methods

 | Name | Description
Protected method | Deserialize | Deserializes the obj from the local archive.
Protected method | Internal_Redo | (Inherited from GH_UndoAction.)
Protected method | Internal_Undo | (Inherited from GH_UndoAction.)
Public method | Read | (Overrides GH_UndoAction..::..Read(GH_IReader).)
Public method | Redo | (Inherited from GH_UndoAction.)
Protected method | Serialize | Serializes the obj into the local archive.
Protected method | SerializeToByteArray | Serializes the obj into the local archive.
Public method | Undo | (Inherited from GH_UndoAction.)
Public method | Write | (Overrides GH_UndoAction..::..Write(GH_IWriter).)

See Also

GH_ArchivedUndoAction Class
Grasshopper.Kernel.Undo Namespace


Deserialize Method

[image]

Grasshopper SDK
GH_ArchivedUndoAction..::..Deserialize Method
GH_ArchivedUndoAction Class See Also Send Feedback
Deserializes the obj from the local archive.

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected void Deserialize(
    GH_ISerializable obj
)
Visual Basic
Protected Sub Deserialize ( _
    obj As GH_ISerializable _
)

Parameters

obj
Type: GH_IO..::..GH_ISerializable

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown when obj is a null reference.
System..::..NullReferenceException | Thrown when the internal archive data is null.
System.IO..::..IOException | Thrown when the deserialization fails.

See Also

GH_ArchivedUndoAction Class
Grasshopper.Kernel.Undo Namespace


Read Method

[image]

Grasshopper SDK
GH_ArchivedUndoAction..::..Read Method
GH_ArchivedUndoAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

See Also

GH_ArchivedUndoAction Class
Grasshopper.Kernel.Undo Namespace


Serialize Method

[image]

Grasshopper SDK
GH_ArchivedUndoAction..::..Serialize Method
GH_ArchivedUndoAction Class See Also Send Feedback
Serializes the obj into the local archive.

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected void Serialize(
    GH_ISerializable obj
)
Visual Basic
Protected Sub Serialize ( _
    obj As GH_ISerializable _
)

Parameters

obj
Type: GH_IO..::..GH_ISerializable
Object to serialize

See Also

GH_ArchivedUndoAction Class
Grasshopper.Kernel.Undo Namespace


SerializeToByteArray Method

[image]

Grasshopper SDK
GH_ArchivedUndoAction..::..SerializeToByteArray Method
GH_ArchivedUndoAction Class See Also Send Feedback
Serializes the obj into the local archive.

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected byte[] SerializeToByteArray(
    GH_ISerializable obj
)
Visual Basic
Protected Function SerializeToByteArray ( _
    obj As GH_ISerializable _
) As Byte()

Parameters

obj
Type: GH_IO..::..GH_ISerializable
Object to serialize

See Also

GH_ArchivedUndoAction Class
Grasshopper.Kernel.Undo Namespace


Write Method

[image]

Grasshopper SDK
GH_ArchivedUndoAction..::..Write Method
GH_ArchivedUndoAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overrides Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

See Also

GH_ArchivedUndoAction Class
Grasshopper.Kernel.Undo Namespace


GH_ArchivedUndoAction Properties

[image] [image]

Grasshopper SDK
GH_ArchivedUndoAction Properties
GH_ArchivedUndoAction Class See Also Send Feedback

The GH_ArchivedUndoAction type exposes the following members.

Properties

 | Name | Description
Public property | ExpiresDisplay | Override this property if you want the Rhino viewport display to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | ExpiresSolution | Override this property if you want the Grasshopper solution to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | State | (Inherited from GH_UndoAction.)

See Also

GH_ArchivedUndoAction Class
Grasshopper.Kernel.Undo Namespace


GH_ObjectUndoAction Class

[image]

Grasshopper SDK
GH_ObjectUndoAction Class
Members See Also Send Feedback
Utility base class for undo actions that operate on a single IGH_DocumentObject.

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract class GH_ObjectUndoAction : GH_UndoAction
Visual Basic
Public MustInherit Class GH_ObjectUndoAction _
    Inherits GH_UndoAction

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Undo..::..GH_UndoAction
Grasshopper.Kernel.Undo..::..GH_ObjectUndoAction
Grasshopper.Kernel.Undo.Actions..::..GH_DataMatchingAction
Grasshopper.Kernel.Undo.Actions..::..GH_DataModificationAction
Grasshopper.Kernel.Undo.Actions..::..GH_HiddenAction
Grasshopper.Kernel.Undo.Actions..::..GH_IconDisplayAction
Grasshopper.Kernel.Undo.Actions..::..GH_IconOverrideAction
Grasshopper.Kernel.Undo.Actions..::..GH_LayoutAction
Grasshopper.Kernel.Undo.Actions..::..GH_LockedAction
Grasshopper.Kernel.Undo.Actions..::..GH_NickNameAction
Grasshopper.Kernel.Undo.Actions..::..GH_PersistentDataAction<(Of <(<'T>)>)>
Grasshopper.Kernel.Undo.Actions..::..GH_PivotAction
Grasshopper.Kernel.Undo.Actions..::..GH_WireDisplayAction

See Also

GH_ObjectUndoAction Members
Grasshopper.Kernel.Undo Namespace


GH_ObjectUndoAction Members

[image] [image]

Grasshopper SDK
GH_ObjectUndoAction Members
GH_ObjectUndoAction Class Constructors Methods Properties See Also Send Feedback

The GH_ObjectUndoAction type exposes the following members.

Constructors

 | Name | Description
Protected method | GH_ObjectUndoAction | Initializes a new instance of the GH_ObjectUndoAction class

Methods

 | Name | Description
Protected method | Internal_Redo | (Overrides GH_UndoAction..::..Internal_Redo(GH_Document).)
Protected method | Internal_Undo | (Overrides GH_UndoAction..::..Internal_Undo(GH_Document).)
Protected method | Object_Redo |
Protected method | Object_Undo |
Public method | Read | (Inherited from GH_UndoAction.)
Public method | Redo | (Inherited from GH_UndoAction.)
Public method | Undo | (Inherited from GH_UndoAction.)
Public method | Write | (Inherited from GH_UndoAction.)

Properties

 | Name | Description
Public property | ExpiresDisplay | Override this property if you want the Rhino viewport display to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | ExpiresSolution | Override this property if you want the Grasshopper solution to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | State | (Inherited from GH_UndoAction.)

See Also

GH_ObjectUndoAction Class
Grasshopper.Kernel.Undo Namespace


GH_ObjectUndoAction Constructor

[image]

Grasshopper SDK
GH_ObjectUndoAction Constructor
GH_ObjectUndoAction Class See Also Send Feedback
Initializes a new instance of the GH_ObjectUndoAction class

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_ObjectUndoAction(
    Guid object_id
)
Visual Basic
Protected Sub New ( _
    object_id As Guid _
)

Parameters

object_id
Type: System..::..Guid

See Also

GH_ObjectUndoAction Class
Grasshopper.Kernel.Undo Namespace


GH_ObjectUndoAction Methods

[image] [image]

Grasshopper SDK
GH_ObjectUndoAction Methods
GH_ObjectUndoAction Class See Also Send Feedback

The GH_ObjectUndoAction type exposes the following members.

Methods

 | Name | Description
Protected method | Internal_Redo | (Overrides GH_UndoAction..::..Internal_Redo(GH_Document).)
Protected method | Internal_Undo | (Overrides GH_UndoAction..::..Internal_Undo(GH_Document).)
Protected method | Object_Redo |
Protected method | Object_Undo |
Public method | Read | (Inherited from GH_UndoAction.)
Public method | Redo | (Inherited from GH_UndoAction.)
Public method | Undo | (Inherited from GH_UndoAction.)
Public method | Write | (Inherited from GH_UndoAction.)

See Also

GH_ObjectUndoAction Class
Grasshopper.Kernel.Undo Namespace


Internal_Redo Method

[image]

Grasshopper SDK
GH_ObjectUndoAction..::..Internal_Redo Method
GH_ObjectUndoAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Internal_Redo(
    GH_Document doc
)
Visual Basic
Protected Overrides Sub Internal_Redo ( _
    doc As GH_Document _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document

See Also

GH_ObjectUndoAction Class
Grasshopper.Kernel.Undo Namespace


Internal_Undo Method

[image]

Grasshopper SDK
GH_ObjectUndoAction..::..Internal_Undo Method
GH_ObjectUndoAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Internal_Undo(
    GH_Document doc
)
Visual Basic
Protected Overrides Sub Internal_Undo ( _
    doc As GH_Document _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document

See Also

GH_ObjectUndoAction Class
Grasshopper.Kernel.Undo Namespace


Object_Redo Method

[image]

Grasshopper SDK
GH_ObjectUndoAction..::..Object_Redo Method
GH_ObjectUndoAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected abstract void Object_Redo(
    GH_Document doc,
    IGH_DocumentObject obj
)
Visual Basic
Protected MustOverride Sub Object_Redo ( _
    doc As GH_Document, _
    obj As IGH_DocumentObject _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document
obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject

See Also

GH_ObjectUndoAction Class
Grasshopper.Kernel.Undo Namespace


Object_Undo Method

[image]

Grasshopper SDK
GH_ObjectUndoAction..::..Object_Undo Method
GH_ObjectUndoAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected abstract void Object_Undo(
    GH_Document doc,
    IGH_DocumentObject obj
)
Visual Basic
Protected MustOverride Sub Object_Undo ( _
    doc As GH_Document, _
    obj As IGH_DocumentObject _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document
obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject

See Also

GH_ObjectUndoAction Class
Grasshopper.Kernel.Undo Namespace


GH_ObjectUndoAction Properties

[image] [image]

Grasshopper SDK
GH_ObjectUndoAction Properties
GH_ObjectUndoAction Class See Also Send Feedback

The GH_ObjectUndoAction type exposes the following members.

Properties

 | Name | Description
Public property | ExpiresDisplay | Override this property if you want the Rhino viewport display to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | ExpiresSolution | Override this property if you want the Grasshopper solution to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | State | (Inherited from GH_UndoAction.)

See Also

GH_ObjectUndoAction Class
Grasshopper.Kernel.Undo Namespace


GH_UndoAction Class

[image]

Grasshopper SDK
GH_UndoAction Class
Members See Also Send Feedback
Base class implementation for undo actions.

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public abstract class GH_UndoAction : IGH_UndoAction
Visual Basic
Public MustInherit Class GH_UndoAction _
    Implements IGH_UndoAction

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Undo..::..GH_UndoAction
Grasshopper.Kernel.Undo.Actions..::..GH_AddObjectAction
Grasshopper.Kernel.Undo.Actions..::..GH_WireAction
Grasshopper.Kernel.Undo..::..GH_ArchivedUndoAction
Grasshopper.Kernel.Undo..::..GH_ObjectUndoAction

See Also

GH_UndoAction Members
Grasshopper.Kernel.Undo Namespace


GH_UndoAction Members

[image] [image]

Grasshopper SDK
GH_UndoAction Members
GH_UndoAction Class Constructors Methods Properties See Also Send Feedback

The GH_UndoAction type exposes the following members.

Constructors

 | Name | Description
Protected method | GH_UndoAction | Initializes a new instance of the GH_UndoAction class

Methods

 | Name | Description
Protected method | Internal_Redo |
Protected method | Internal_Undo |
Public method | Read |
Public method | Redo |
Public method | Undo |
Public method | Write |

Properties

 | Name | Description
Public property | ExpiresDisplay | Override this property if you want the Rhino viewport display to refresh upon undo completion.
Public property | ExpiresSolution | Override this property if you want the Grasshopper solution to refresh upon undo completion.
Public property | State |

See Also

GH_UndoAction Class
Grasshopper.Kernel.Undo Namespace


GH_UndoAction Constructor

[image]

Grasshopper SDK
GH_UndoAction Constructor
GH_UndoAction Class See Also Send Feedback
Initializes a new instance of the GH_UndoAction class

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected GH_UndoAction()
Visual Basic
Protected Sub New

See Also

GH_UndoAction Class
Grasshopper.Kernel.Undo Namespace


GH_UndoAction Methods

[image] [image]

Grasshopper SDK
GH_UndoAction Methods
GH_UndoAction Class See Also Send Feedback

The GH_UndoAction type exposes the following members.

Methods

 | Name | Description
Protected method | Internal_Redo |
Protected method | Internal_Undo |
Public method | Read |
Public method | Redo |
Public method | Undo |
Public method | Write |

See Also

GH_UndoAction Class
Grasshopper.Kernel.Undo Namespace


Internal_Redo Method

[image]

Grasshopper SDK
GH_UndoAction..::..Internal_Redo Method
GH_UndoAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected abstract void Internal_Redo(
    GH_Document doc
)
Visual Basic
Protected MustOverride Sub Internal_Redo ( _
    doc As GH_Document _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document

See Also

GH_UndoAction Class
Grasshopper.Kernel.Undo Namespace


Internal_Undo Method

[image]

Grasshopper SDK
GH_UndoAction..::..Internal_Undo Method
GH_UndoAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected abstract void Internal_Undo(
    GH_Document doc
)
Visual Basic
Protected MustOverride Sub Internal_Undo ( _
    doc As GH_Document _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document

See Also

GH_UndoAction Class
Grasshopper.Kernel.Undo Namespace


Read Method

[image]

Grasshopper SDK
GH_UndoAction..::..Read Method
GH_UndoAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool Read(
    GH_IReader reader
)
Visual Basic
Public Overridable Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

Implements

GH_ISerializable..::..Read(GH_IReader)

See Also

GH_UndoAction Class
Grasshopper.Kernel.Undo Namespace


Redo Method

[image]

Grasshopper SDK
GH_UndoAction..::..Redo Method
GH_UndoAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Redo(
    GH_Document doc
)
Visual Basic
Public Sub Redo ( _
    doc As GH_Document _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document

Implements

IGH_UndoAction..::..Redo(GH_Document)

See Also

GH_UndoAction Class
Grasshopper.Kernel.Undo Namespace


Undo Method

[image]

Grasshopper SDK
GH_UndoAction..::..Undo Method
GH_UndoAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Undo(
    GH_Document doc
)
Visual Basic
Public Sub Undo ( _
    doc As GH_Document _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document

Implements

IGH_UndoAction..::..Undo(GH_Document)

See Also

GH_UndoAction Class
Grasshopper.Kernel.Undo Namespace


Write Method

[image]

Grasshopper SDK
GH_UndoAction..::..Write Method
GH_UndoAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overridable Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

Implements

GH_ISerializable..::..Write(GH_IWriter)

See Also

GH_UndoAction Class
Grasshopper.Kernel.Undo Namespace


GH_UndoAction Properties

[image] [image]

Grasshopper SDK
GH_UndoAction Properties
GH_UndoAction Class See Also Send Feedback

The GH_UndoAction type exposes the following members.

Properties

 | Name | Description
Public property | ExpiresDisplay | Override this property if you want the Rhino viewport display to refresh upon undo completion.
Public property | ExpiresSolution | Override this property if you want the Grasshopper solution to refresh upon undo completion.
Public property | State |

See Also

GH_UndoAction Class
Grasshopper.Kernel.Undo Namespace


ExpiresDisplay Property

[image]

Grasshopper SDK
GH_UndoAction..::..ExpiresDisplay Property
GH_UndoAction Class See Also Send Feedback
Override this property if you want the Rhino viewport display to refresh upon undo completion.

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool ExpiresDisplay { get; }
Visual Basic
Public Overridable ReadOnly Property ExpiresDisplay As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Undo.GH_UndoAction.ExpiresDisplay"]

Implements

IGH_UndoAction..::..ExpiresDisplay

See Also

GH_UndoAction Class
Grasshopper.Kernel.Undo Namespace


ExpiresSolution Property

[image]

Grasshopper SDK
GH_UndoAction..::..ExpiresSolution Property
GH_UndoAction Class See Also Send Feedback
Override this property if you want the Grasshopper solution to refresh upon undo completion.

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public virtual bool ExpiresSolution { get; }
Visual Basic
Public Overridable ReadOnly Property ExpiresSolution As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Undo.GH_UndoAction.ExpiresSolution"]

Implements

IGH_UndoAction..::..ExpiresSolution

See Also

GH_UndoAction Class
Grasshopper.Kernel.Undo Namespace


State Property

[image]

Grasshopper SDK
GH_UndoAction..::..State Property
GH_UndoAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_UndoState State { get; }
Visual Basic
Public ReadOnly Property State As GH_UndoState
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Undo.GH_UndoAction.State"]

Implements

IGH_UndoAction..::..State

See Also

GH_UndoAction Class
Grasshopper.Kernel.Undo Namespace


GH_UndoException Class

[image]

Grasshopper SDK
GH_UndoException Class
Members See Also Send Feedback
Exception associated with undo events

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_UndoException : Exception
Visual Basic
Public Class GH_UndoException _
    Inherits Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
Grasshopper.Kernel.Undo..::..GH_UndoException

See Also

GH_UndoException Members
Grasshopper.Kernel.Undo Namespace


GH_UndoException Members

[image] [image]

Grasshopper SDK
GH_UndoException Members
GH_UndoException Class Constructors See Also Send Feedback

Constructors

 | Name | Description
Public method | GH_UndoException(String) | Initializes a new instance of the GH_UndoException class
Public method | GH_UndoException(String, array<Object>[]()[][]) | Initializes a new instance of the GH_UndoException class

See Also

GH_UndoException Class
Grasshopper.Kernel.Undo Namespace


GH_UndoException Constructor

[image] [image]

Grasshopper SDK
GH_UndoException Constructor
GH_UndoException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_UndoException(String) | Initializes a new instance of the GH_UndoException class
Public method | GH_UndoException(String, array<Object>[]()[][]) | Initializes a new instance of the GH_UndoException class

See Also

GH_UndoException Class
GH_UndoException Members
Grasshopper.Kernel.Undo Namespace


GH_UndoException Constructor (String)

[image]

Grasshopper SDK
GH_UndoException Constructor (String)
GH_UndoException Class See Also Send Feedback
Initializes a new instance of the GH_UndoException class

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_UndoException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)

Parameters

message
Type: System..::..String

See Also

GH_UndoException Class
GH_UndoException Overload
Grasshopper.Kernel.Undo Namespace


GH_UndoException Constructor (String, Object[])

[image]

Grasshopper SDK
GH_UndoException Constructor (String, array<Object>[]()[][])
GH_UndoException Class See Also Send Feedback
Initializes a new instance of the GH_UndoException class

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_UndoException(
    string message,
    params Object[] args
)
Visual Basic
Public Sub New ( _
    message As String, _
    ParamArray args As Object() _
)

Parameters

message
Type: System..::..String
args
Type: array< System..::..Object >[]()[][]

See Also

GH_UndoException Class
GH_UndoException Overload
Grasshopper.Kernel.Undo Namespace


GH_UndoRecord Class

[image]

Grasshopper SDK
GH_UndoRecord Class
Members See Also Send Feedback
Represents a single undo/redo record. A single record may contain any number of undo actions.

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_UndoRecord
Visual Basic
Public Class GH_UndoRecord

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Undo..::..GH_UndoRecord

See Also

GH_UndoRecord Members
Grasshopper.Kernel.Undo Namespace


GH_UndoRecord Members

[image] [image]

Grasshopper SDK
GH_UndoRecord Members
GH_UndoRecord Class Constructors Methods Properties See Also Send Feedback

The GH_UndoRecord type exposes the following members.

Constructors

 | Name | Description
Public method | GH_UndoRecord()()()() | Initializes a new instance of the GH_UndoRecord class
Public method | GH_UndoRecord(String) | Initializes a new instance of the GH_UndoRecord class
Public method | GH_UndoRecord(String, IGH_UndoAction) | Initializes a new instance of the GH_UndoRecord class
Public method | GH_UndoRecord(String, array<IGH_UndoAction>[]()[][]) | Initializes a new instance of the GH_UndoRecord class
Public method | GH_UndoRecord(String, IEnumerable<(Of <<'(IGH_UndoAction>)>>)) | Initializes a new instance of the GH_UndoRecord class

Methods

 | Name | Description
Public method | AddAction | Append an undo action to this record. You should only do this prior to calling undo for the first time.
Public method | Redo |
Public method | Undo |

Properties

 | Name | Description
Public property | ActionCount | Gets the number of actions stored in this record.
Public property | Actions | Gets or sets the actions inside this record.
Public property | ExpiresDisplay | Gets the display expiration flag for this event. If True, the Rhino viewports will be redrawn once the entire undo record has been completed. If ExpiresSolution is set to true, ExpriresDisplay is implied.
Public property | ExpiresSolution | Gets the solution expiration flag for this event. If True, the solution needs to be recalculated once the entire undo record has been completed.
Public property | Guid | Gets the ID of this undo item. Every undo record has a unique ID.
Public property | Name | Gets or sets the name of the undo record (as displayed in the menu)
Public property | State | Gets the undo state of this record. The state dictates which action are legal.
Public property | Time | Gets the time at which this record was created.

See Also

GH_UndoRecord Class
Grasshopper.Kernel.Undo Namespace


GH_UndoRecord Constructor

[image] [image]

Grasshopper SDK
GH_UndoRecord Constructor
GH_UndoRecord Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GH_UndoRecord()()()() | Initializes a new instance of the GH_UndoRecord class
Public method | GH_UndoRecord(String) | Initializes a new instance of the GH_UndoRecord class
Public method | GH_UndoRecord(String, IGH_UndoAction) | Initializes a new instance of the GH_UndoRecord class
Public method | GH_UndoRecord(String, array<IGH_UndoAction>[]()[][]) | Initializes a new instance of the GH_UndoRecord class
Public method | GH_UndoRecord(String, IEnumerable<(Of <<'(IGH_UndoAction>)>>)) | Initializes a new instance of the GH_UndoRecord class

See Also

GH_UndoRecord Class
GH_UndoRecord Members
Grasshopper.Kernel.Undo Namespace


GH_UndoRecord Constructor

[image]

Grasshopper SDK
GH_UndoRecord Constructor
GH_UndoRecord Class See Also Send Feedback
Initializes a new instance of the GH_UndoRecord class

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_UndoRecord()
Visual Basic
Public Sub New

See Also

GH_UndoRecord Class
GH_UndoRecord Overload
Grasshopper.Kernel.Undo Namespace


GH_UndoRecord Constructor (String)

[image]

Grasshopper SDK
GH_UndoRecord Constructor (String)
GH_UndoRecord Class See Also Send Feedback
Initializes a new instance of the GH_UndoRecord class

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_UndoRecord(
    string name
)
Visual Basic
Public Sub New ( _
    name As String _
)

Parameters

name
Type: System..::..String

See Also

GH_UndoRecord Class
GH_UndoRecord Overload
Grasshopper.Kernel.Undo Namespace


GH_UndoRecord Constructor (String, IGH_UndoAction)

[image]

Grasshopper SDK
GH_UndoRecord Constructor (String, IGH_UndoAction)
GH_UndoRecord Class See Also Send Feedback
Initializes a new instance of the GH_UndoRecord class

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_UndoRecord(
    string name,
    IGH_UndoAction action
)
Visual Basic
Public Sub New ( _
    name As String, _
    action As IGH_UndoAction _
)

Parameters

name
Type: System..::..String
action
Type: Grasshopper.Kernel.Undo..::..IGH_UndoAction

See Also

GH_UndoRecord Class
GH_UndoRecord Overload
Grasshopper.Kernel.Undo Namespace


GH_UndoRecord Constructor (String, IGH_UndoAction[])

[image]

Grasshopper SDK
GH_UndoRecord Constructor (String, array<IGH_UndoAction>[]()[][])
GH_UndoRecord Class See Also Send Feedback
Initializes a new instance of the GH_UndoRecord class

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_UndoRecord(
    string name,
    params IGH_UndoAction[] actions
)
Visual Basic
Public Sub New ( _
    name As String, _
    ParamArray actions As IGH_UndoAction() _
)

Parameters

name
Type: System..::..String
actions
Type: array< Grasshopper.Kernel.Undo..::..IGH_UndoAction >[]()[][]

See Also

GH_UndoRecord Class
GH_UndoRecord Overload
Grasshopper.Kernel.Undo Namespace


GH_UndoRecord Constructor (String, IEnumerable(IGH_UndoAction))

[image]

Grasshopper SDK
GH_UndoRecord Constructor (String, IEnumerable<(Of <(<'IGH_UndoAction>)>)>)
GH_UndoRecord Class See Also Send Feedback
Initializes a new instance of the GH_UndoRecord class

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_UndoRecord(
    string name,
    IEnumerable<IGH_UndoAction> actions
)
Visual Basic
Public Sub New ( _
    name As String, _
    actions As IEnumerable(Of IGH_UndoAction) _
)

Parameters

name
Type: System..::..String
actions
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' IGH_UndoAction >)>)>

See Also

GH_UndoRecord Class
GH_UndoRecord Overload
Grasshopper.Kernel.Undo Namespace


GH_UndoRecord Methods

[image] [image]

Grasshopper SDK
GH_UndoRecord Methods
GH_UndoRecord Class See Also Send Feedback

The GH_UndoRecord type exposes the following members.

Methods

 | Name | Description
Public method | AddAction | Append an undo action to this record. You should only do this prior to calling undo for the first time.
Public method | Redo |
Public method | Undo |

See Also

GH_UndoRecord Class
Grasshopper.Kernel.Undo Namespace


AddAction Method

[image]

Grasshopper SDK
GH_UndoRecord..::..AddAction Method
GH_UndoRecord Class See Also Send Feedback
Append an undo action to this record. You should only do this prior to calling undo for the first time.

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AddAction(
    IGH_UndoAction action
)
Visual Basic
Public Sub AddAction ( _
    action As IGH_UndoAction _
)

Parameters

action
Type: Grasshopper.Kernel.Undo..::..IGH_UndoAction
Action to append.

See Also

GH_UndoRecord Class
Grasshopper.Kernel.Undo Namespace


Redo Method

[image]

Grasshopper SDK
GH_UndoRecord..::..Redo Method
GH_UndoRecord Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Redo(
    GH_Document doc
)
Visual Basic
Public Sub Redo ( _
    doc As GH_Document _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document

See Also

GH_UndoRecord Class
Grasshopper.Kernel.Undo Namespace


Undo Method

[image]

Grasshopper SDK
GH_UndoRecord..::..Undo Method
GH_UndoRecord Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Undo(
    GH_Document doc
)
Visual Basic
Public Sub Undo ( _
    doc As GH_Document _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document

See Also

GH_UndoRecord Class
Grasshopper.Kernel.Undo Namespace


GH_UndoRecord Properties

[image] [image]

Grasshopper SDK
GH_UndoRecord Properties
GH_UndoRecord Class See Also Send Feedback

The GH_UndoRecord type exposes the following members.

Properties

 | Name | Description
Public property | ActionCount | Gets the number of actions stored in this record.
Public property | Actions | Gets or sets the actions inside this record.
Public property | ExpiresDisplay | Gets the display expiration flag for this event. If True, the Rhino viewports will be redrawn once the entire undo record has been completed. If ExpiresSolution is set to true, ExpriresDisplay is implied.
Public property | ExpiresSolution | Gets the solution expiration flag for this event. If True, the solution needs to be recalculated once the entire undo record has been completed.
Public property | Guid | Gets the ID of this undo item. Every undo record has a unique ID.
Public property | Name | Gets or sets the name of the undo record (as displayed in the menu)
Public property | State | Gets the undo state of this record. The state dictates which action are legal.
Public property | Time | Gets the time at which this record was created.

See Also

GH_UndoRecord Class
Grasshopper.Kernel.Undo Namespace


ActionCount Property

[image]

Grasshopper SDK
GH_UndoRecord..::..ActionCount Property
GH_UndoRecord Class See Also Send Feedback
Gets the number of actions stored in this record.

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int ActionCount { get; }
Visual Basic
Public ReadOnly Property ActionCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Undo.GH_UndoRecord.ActionCount"]

See Also

GH_UndoRecord Class
Grasshopper.Kernel.Undo Namespace


Actions Property

[image]

Grasshopper SDK
GH_UndoRecord..::..Actions Property
GH_UndoRecord Class See Also Send Feedback
Gets or sets the actions inside this record.

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public IList<IGH_UndoAction> Actions { get; }
Visual Basic
Public ReadOnly Property Actions As IList(Of IGH_UndoAction)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Undo.GH_UndoRecord.Actions"]

See Also

GH_UndoRecord Class
Grasshopper.Kernel.Undo Namespace


ExpiresDisplay Property

[image]

Grasshopper SDK
GH_UndoRecord..::..ExpiresDisplay Property
GH_UndoRecord Class See Also Send Feedback
Gets the display expiration flag for this event. If True, the Rhino viewports will be redrawn once the entire undo record has been completed. If ExpiresSolution is set to true, ExpriresDisplay is implied.

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool ExpiresDisplay { get; }
Visual Basic
Public ReadOnly Property ExpiresDisplay As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Undo.GH_UndoRecord.ExpiresDisplay"]

See Also

GH_UndoRecord Class
Grasshopper.Kernel.Undo Namespace


ExpiresSolution Property

[image]

Grasshopper SDK
GH_UndoRecord..::..ExpiresSolution Property
GH_UndoRecord Class See Also Send Feedback
Gets the solution expiration flag for this event. If True, the solution needs to be recalculated once the entire undo record has been completed.

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool ExpiresSolution { get; }
Visual Basic
Public ReadOnly Property ExpiresSolution As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Undo.GH_UndoRecord.ExpiresSolution"]

See Also

GH_UndoRecord Class
Grasshopper.Kernel.Undo Namespace


Guid Property

[image]

Grasshopper SDK
GH_UndoRecord..::..Guid Property
GH_UndoRecord Class See Also Send Feedback
Gets the ID of this undo item. Every undo record has a unique ID.

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid Guid { get; }
Visual Basic
Public ReadOnly Property Guid As Guid
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Undo.GH_UndoRecord.Guid"]

See Also

GH_UndoRecord Class
Grasshopper.Kernel.Undo Namespace


Name Property

[image]

Grasshopper SDK
GH_UndoRecord..::..Name Property
GH_UndoRecord Class See Also Send Feedback
Gets or sets the name of the undo record (as displayed in the menu)

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Undo.GH_UndoRecord.Name"]

See Also

GH_UndoRecord Class
Grasshopper.Kernel.Undo Namespace


State Property

[image]

Grasshopper SDK
GH_UndoRecord..::..State Property
GH_UndoRecord Class See Also Send Feedback
Gets the undo state of this record. The state dictates which action are legal.

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_UndoState State { get; }
Visual Basic
Public ReadOnly Property State As GH_UndoState
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Undo.GH_UndoRecord.State"]

See Also

GH_UndoRecord Class
Grasshopper.Kernel.Undo Namespace


Time Property

[image]

Grasshopper SDK
GH_UndoRecord..::..Time Property
GH_UndoRecord Class See Also Send Feedback
Gets the time at which this record was created.

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public DateTime Time { get; }
Visual Basic
Public ReadOnly Property Time As DateTime
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Undo.GH_UndoRecord.Time"]

See Also

GH_UndoRecord Class
Grasshopper.Kernel.Undo Namespace


GH_UndoServer Class

[image]

Grasshopper SDK
GH_UndoServer Class
Members See Also Send Feedback
Provides access to a documents undo data.

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_UndoServer : IGH_DebugDescription
Visual Basic
Public Class GH_UndoServer _
    Implements IGH_DebugDescription

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Undo..::..GH_UndoServer

See Also

GH_UndoServer Members
Grasshopper.Kernel.Undo Namespace


GH_UndoServer Members

[image] [image]

Grasshopper SDK
GH_UndoServer Members
GH_UndoServer Class Constructors Methods Properties See Also Send Feedback

The GH_UndoServer type exposes the following members.

Constructors

 | Name | Description
Public method | GH_UndoServer | Initializes a new instance of the GH_UndoServer class

Methods

 | Name | Description
Public method | AppendToDebugLog |
Public method | Clear | Clear both undo and redo lists.
Public method | ClearRedo | Clear the undo list.
Public method | ClearUndo | Clear the redo list.
Public method | PerformRedo | Performs a single Redo step if possible and migrates the record onto the undo stack. This function may throw all kinds of exceptions, if you're calling it from a UI thread, use a Try..Catch block to prevent crashes.
Public method | PerformUndo | Performs a single Undo step when possible and migrates the record onto the redo stack. This function may throw all kinds of exceptions, if you're calling it from a UI thread, use a Try..Catch block to prevent crashes.
Public method | PushUndoRecord(GH_UndoRecord) | Add a new undo record to the undo stack, this function clears the Redo stack.
Public method | PushUndoRecord(String, GH_UndoAction) | Add a new undo record to the undo stack, this function clears the Redo stack.
Public method | RemoveRecord | Remove the record with the specified ID from the undo or redo stack.

Properties

 | Name | Description
Public property | FirstRedoName | Gets the name of the last item in the redo stack (the first item to be redone).
Public property | FirstUndoName | Gets the name of the last item in the undo stack (the first item to be undone).
Public property | MaxRecords | Gets or sets the maximum number of undo records that can be stored.
Public property | RedoCount | Number of redo records currently in the stack.
Public property | RedoGuids | Gets a sorted list of all the redo Guids in this server.
Public property | RedoNames | Gets a sorted list of all the redo Guids in this server.
Public property | UndoCount | Number of undo records currently in the stack.
Public property | UndoGuids | Gets a sorted list of all the undo Guids in this server.
Public property | UndoNames | Gets a sorted list of all the undo Guids in this server.

See Also

GH_UndoServer Class
Grasshopper.Kernel.Undo Namespace


GH_UndoServer Constructor

[image]

Grasshopper SDK
GH_UndoServer Constructor
GH_UndoServer Class See Also Send Feedback
Initializes a new instance of the GH_UndoServer class

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_UndoServer(
    GH_Document nOwner
)
Visual Basic
Public Sub New ( _
    nOwner As GH_Document _
)

Parameters

nOwner
Type: Grasshopper.Kernel..::..GH_Document

See Also

GH_UndoServer Class
Grasshopper.Kernel.Undo Namespace


GH_UndoServer Methods

[image] [image]

Grasshopper SDK
GH_UndoServer Methods
GH_UndoServer Class See Also Send Feedback

The GH_UndoServer type exposes the following members.

Methods

 | Name | Description
Public method | AppendToDebugLog |
Public method | Clear | Clear both undo and redo lists.
Public method | ClearRedo | Clear the undo list.
Public method | ClearUndo | Clear the redo list.
Public method | PerformRedo | Performs a single Redo step if possible and migrates the record onto the undo stack. This function may throw all kinds of exceptions, if you're calling it from a UI thread, use a Try..Catch block to prevent crashes.
Public method | PerformUndo | Performs a single Undo step when possible and migrates the record onto the redo stack. This function may throw all kinds of exceptions, if you're calling it from a UI thread, use a Try..Catch block to prevent crashes.
Public method | PushUndoRecord(GH_UndoRecord) | Add a new undo record to the undo stack, this function clears the Redo stack.
Public method | PushUndoRecord(String, GH_UndoAction) | Add a new undo record to the undo stack, this function clears the Redo stack.
Public method | RemoveRecord | Remove the record with the specified ID from the undo or redo stack.

See Also

GH_UndoServer Class
Grasshopper.Kernel.Undo Namespace


AppendToDebugLog Method

[image]

Grasshopper SDK
GH_UndoServer..::..AppendToDebugLog Method
GH_UndoServer Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void AppendToDebugLog(
    GH_DebugDescriptionWriter writer
)
Visual Basic
Public Sub AppendToDebugLog ( _
    writer As GH_DebugDescriptionWriter _
)

Parameters

writer
Type: Grasshopper.Kernel..::..GH_DebugDescriptionWriter

Implements

IGH_DebugDescription..::..AppendToDebugLog(GH_DebugDescriptionWriter)

See Also

GH_UndoServer Class
Grasshopper.Kernel.Undo Namespace


Clear Method

[image]

Grasshopper SDK
GH_UndoServer..::..Clear Method
GH_UndoServer Class See Also Send Feedback
Clear both undo and redo lists.

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear

See Also

GH_UndoServer Class
Grasshopper.Kernel.Undo Namespace


ClearRedo Method

[image]

Grasshopper SDK
GH_UndoServer..::..ClearRedo Method
GH_UndoServer Class See Also Send Feedback
Clear the undo list.

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ClearRedo()
Visual Basic
Public Sub ClearRedo

See Also

GH_UndoServer Class
Grasshopper.Kernel.Undo Namespace


ClearUndo Method

[image]

Grasshopper SDK
GH_UndoServer..::..ClearUndo Method
GH_UndoServer Class See Also Send Feedback
Clear the redo list.

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ClearUndo()
Visual Basic
Public Sub ClearUndo

Remarks

See Also

GH_UndoServer Class
Grasshopper.Kernel.Undo Namespace


PerformRedo Method

[image]

Grasshopper SDK
GH_UndoServer..::..PerformRedo Method
GH_UndoServer Class See Also Send Feedback
Performs a single Redo step if possible and migrates the record onto the undo stack. This function may throw all kinds of exceptions, if you're calling it from a UI thread, use a Try..Catch block to prevent crashes.

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void PerformRedo()
Visual Basic
Public Sub PerformRedo

See Also

GH_UndoServer Class
Grasshopper.Kernel.Undo Namespace


PerformUndo Method

[image]

Grasshopper SDK
GH_UndoServer..::..PerformUndo Method
GH_UndoServer Class See Also Send Feedback
Performs a single Undo step when possible and migrates the record onto the redo stack. This function may throw all kinds of exceptions, if you're calling it from a UI thread, use a Try..Catch block to prevent crashes.

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void PerformUndo()
Visual Basic
Public Sub PerformUndo

See Also

GH_UndoServer Class
Grasshopper.Kernel.Undo Namespace


PushUndoRecord Method

[image] [image]

Grasshopper SDK
GH_UndoServer..::..PushUndoRecord Method
GH_UndoServer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PushUndoRecord(GH_UndoRecord) | Add a new undo record to the undo stack, this function clears the Redo stack.
Public method | PushUndoRecord(String, GH_UndoAction) | Add a new undo record to the undo stack, this function clears the Redo stack.

See Also

GH_UndoServer Class
GH_UndoServer Members
Grasshopper.Kernel.Undo Namespace


PushUndoRecord Method (GH_UndoRecord)

[image]

Grasshopper SDK
GH_UndoServer..::..PushUndoRecord Method (GH_UndoRecord)
GH_UndoServer Class See Also Send Feedback
Add a new undo record to the undo stack, this function clears the Redo stack.

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void PushUndoRecord(
    GH_UndoRecord record
)
Visual Basic
Public Sub PushUndoRecord ( _
    record As GH_UndoRecord _
)

Parameters

record
Type: Grasshopper.Kernel.Undo..::..GH_UndoRecord
Record to add.

See Also

GH_UndoServer Class
PushUndoRecord Overload
Grasshopper.Kernel.Undo Namespace


PushUndoRecord Method (String, GH_UndoAction)

[image]

Grasshopper SDK
GH_UndoServer..::..PushUndoRecord Method (String, GH_UndoAction)
GH_UndoServer Class See Also Send Feedback
Add a new undo record to the undo stack, this function clears the Redo stack.

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Guid PushUndoRecord(
    string name,
    GH_UndoAction action
)
Visual Basic
Public Function PushUndoRecord ( _
    name As String, _
    action As GH_UndoAction _
) As Guid

Parameters

name
Type: System..::..String
Name of undo record.
action
Type: Grasshopper.Kernel.Undo..::..GH_UndoAction
Undo action.

Return Value

The ID of the newly created undo record.

See Also

GH_UndoServer Class
PushUndoRecord Overload
Grasshopper.Kernel.Undo Namespace


RemoveRecord Method

[image]

Grasshopper SDK
GH_UndoServer..::..RemoveRecord Method
GH_UndoServer Class See Also Send Feedback
Remove the record with the specified ID from the undo or redo stack.

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool RemoveRecord(
    Guid id
)
Visual Basic
Public Function RemoveRecord ( _
    id As Guid _
) As Boolean

Parameters

id
Type: System..::..Guid
ID of record to remove.

Return Value

True on success, false on failure.

See Also

GH_UndoServer Class
Grasshopper.Kernel.Undo Namespace


GH_UndoServer Properties

[image] [image]

Grasshopper SDK
GH_UndoServer Properties
GH_UndoServer Class See Also Send Feedback

The GH_UndoServer type exposes the following members.

Properties

 | Name | Description
Public property | FirstRedoName | Gets the name of the last item in the redo stack (the first item to be redone).
Public property | FirstUndoName | Gets the name of the last item in the undo stack (the first item to be undone).
Public property | MaxRecords | Gets or sets the maximum number of undo records that can be stored.
Public property | RedoCount | Number of redo records currently in the stack.
Public property | RedoGuids | Gets a sorted list of all the redo Guids in this server.
Public property | RedoNames | Gets a sorted list of all the redo Guids in this server.
Public property | UndoCount | Number of undo records currently in the stack.
Public property | UndoGuids | Gets a sorted list of all the undo Guids in this server.
Public property | UndoNames | Gets a sorted list of all the undo Guids in this server.

See Also

GH_UndoServer Class
Grasshopper.Kernel.Undo Namespace


FirstRedoName Property

[image]

Grasshopper SDK
GH_UndoServer..::..FirstRedoName Property
GH_UndoServer Class See Also Send Feedback
Gets the name of the last item in the redo stack (the first item to be redone).

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string FirstRedoName { get; }
Visual Basic
Public ReadOnly Property FirstRedoName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Undo.GH_UndoServer.FirstRedoName"]

See Also

GH_UndoServer Class
Grasshopper.Kernel.Undo Namespace


FirstUndoName Property

[image]

Grasshopper SDK
GH_UndoServer..::..FirstUndoName Property
GH_UndoServer Class See Also Send Feedback
Gets the name of the last item in the undo stack (the first item to be undone).

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public string FirstUndoName { get; }
Visual Basic
Public ReadOnly Property FirstUndoName As String
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Undo.GH_UndoServer.FirstUndoName"]

See Also

GH_UndoServer Class
Grasshopper.Kernel.Undo Namespace


MaxRecords Property

[image]

Grasshopper SDK
GH_UndoServer..::..MaxRecords Property
GH_UndoServer Class See Also Send Feedback
Gets or sets the maximum number of undo records that can be stored.

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int MaxRecords { get; set; }
Visual Basic
Public Property MaxRecords As Integer
    Get
    Set

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Undo.GH_UndoServer.MaxRecords"]

Remarks

The number of redo records is logically limited to the same number. THIS SETTING IS CURRENTLY IGNORED

See Also

GH_UndoServer Class
Grasshopper.Kernel.Undo Namespace


RedoCount Property

[image]

Grasshopper SDK
GH_UndoServer..::..RedoCount Property
GH_UndoServer Class See Also Send Feedback
Number of redo records currently in the stack.

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int RedoCount { get; }
Visual Basic
Public ReadOnly Property RedoCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Undo.GH_UndoServer.RedoCount"]

See Also

GH_UndoServer Class
Grasshopper.Kernel.Undo Namespace


RedoGuids Property

[image]

Grasshopper SDK
GH_UndoServer..::..RedoGuids Property
GH_UndoServer Class See Also Send Feedback
Gets a sorted list of all the redo Guids in this server.

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<Guid> RedoGuids { get; }
Visual Basic
Public ReadOnly Property RedoGuids As List(Of Guid)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Undo.GH_UndoServer.RedoGuids"]

See Also

GH_UndoServer Class
Grasshopper.Kernel.Undo Namespace


RedoNames Property

[image]

Grasshopper SDK
GH_UndoServer..::..RedoNames Property
GH_UndoServer Class See Also Send Feedback
Gets a sorted list of all the redo Guids in this server.

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<string> RedoNames { get; }
Visual Basic
Public ReadOnly Property RedoNames As List(Of String)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Undo.GH_UndoServer.RedoNames"]

See Also

GH_UndoServer Class
Grasshopper.Kernel.Undo Namespace


UndoCount Property

[image]

Grasshopper SDK
GH_UndoServer..::..UndoCount Property
GH_UndoServer Class See Also Send Feedback
Number of undo records currently in the stack.

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public int UndoCount { get; }
Visual Basic
Public ReadOnly Property UndoCount As Integer
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Undo.GH_UndoServer.UndoCount"]

See Also

GH_UndoServer Class
Grasshopper.Kernel.Undo Namespace


UndoGuids Property

[image]

Grasshopper SDK
GH_UndoServer..::..UndoGuids Property
GH_UndoServer Class See Also Send Feedback
Gets a sorted list of all the undo Guids in this server.

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<Guid> UndoGuids { get; }
Visual Basic
Public ReadOnly Property UndoGuids As List(Of Guid)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Undo.GH_UndoServer.UndoGuids"]

See Also

GH_UndoServer Class
Grasshopper.Kernel.Undo Namespace


UndoNames Property

[image]

Grasshopper SDK
GH_UndoServer..::..UndoNames Property
GH_UndoServer Class See Also Send Feedback
Gets a sorted list of all the undo Guids in this server.

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public List<string> UndoNames { get; }
Visual Basic
Public ReadOnly Property UndoNames As List(Of String)
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Undo.GH_UndoServer.UndoNames"]

See Also

GH_UndoServer Class
Grasshopper.Kernel.Undo Namespace


GH_UndoState Enumeration

[image]

Grasshopper SDK
GH_UndoState Enumeration
See Also Send Feedback
State enumeration for undo records.

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public enum GH_UndoState
Visual Basic
Public Enumeration GH_UndoState

Members

Member name | Value | Description
undo | 0 | Record can be undone.
redo | 1 | Record can be redone

See Also

Grasshopper.Kernel.Undo Namespace


IGH_UndoAction Interface

[image]

Grasshopper SDK
IGH_UndoAction Interface
Members See Also Send Feedback
Base interface for all undo/redo actions

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public interface IGH_UndoAction : GH_ISerializable
Visual Basic
Public Interface IGH_UndoAction _
    Inherits GH_ISerializable

See Also

IGH_UndoAction Members
Grasshopper.Kernel.Undo Namespace


IGH_UndoAction Members

[image] [image]

Grasshopper SDK
IGH_UndoAction Members
IGH_UndoAction Interface Methods Properties See Also Send Feedback

The IGH_UndoAction type exposes the following members.

Methods

 | Name | Description
Public method | Read | This method is called whenever the instance is required to deserialize itself. (Inherited from GH_ISerializable.)
Public method | Redo | Redo the action stored in this record.
Public method | Undo | Undo the action stored in this record.
Public method | Write | This method is called whenever the instance is required to serialize itself. (Inherited from GH_ISerializable.)

Properties

 | Name | Description
Public property | ExpiresDisplay | Gets the display expiration flag for this event. If True, the Rhino viewports will be redrawn once the entire undo record has been completed. If ExpiresSolution is set to true, ExpriresDisplay is implied.
Public property | ExpiresSolution | Gets the solution expiration flag for this event. If True, the solution needs to be recalculated once the entire undo record has been completed.
Public property | State | Gets the current state of the undo action.

See Also

IGH_UndoAction Interface
Grasshopper.Kernel.Undo Namespace


IGH_UndoAction Methods

[image] [image]

Grasshopper SDK
IGH_UndoAction Methods
IGH_UndoAction Interface See Also Send Feedback

The IGH_UndoAction type exposes the following members.

Methods

 | Name | Description
Public method | Read | This method is called whenever the instance is required to deserialize itself. (Inherited from GH_ISerializable.)
Public method | Redo | Redo the action stored in this record.
Public method | Undo | Undo the action stored in this record.
Public method | Write | This method is called whenever the instance is required to serialize itself. (Inherited from GH_ISerializable.)

See Also

IGH_UndoAction Interface
Grasshopper.Kernel.Undo Namespace


Redo Method

[image]

Grasshopper SDK
IGH_UndoAction..::..Redo Method
IGH_UndoAction Interface See Also Send Feedback
Redo the action stored in this record.

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void Redo(
    GH_Document doc
)
Visual Basic
Sub Redo ( _
    doc As GH_Document _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document
The target document.

Exceptions

Exception | Condition
Grasshopper.Kernel.Undo..::..GH_UndoException | Thrown when the State flag conflicts with a redo action.

See Also

IGH_UndoAction Interface
Grasshopper.Kernel.Undo Namespace


Undo Method

[image]

Grasshopper SDK
IGH_UndoAction..::..Undo Method
IGH_UndoAction Interface See Also Send Feedback
Undo the action stored in this record.

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
void Undo(
    GH_Document doc
)
Visual Basic
Sub Undo ( _
    doc As GH_Document _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document
The target document.

Exceptions

Exception | Condition
Grasshopper.Kernel.Undo..::..GH_UndoException | Thrown when the State flag conflicts with an undo action.

See Also

IGH_UndoAction Interface
Grasshopper.Kernel.Undo Namespace


IGH_UndoAction Properties

[image] [image]

Grasshopper SDK
IGH_UndoAction Properties
IGH_UndoAction Interface See Also Send Feedback

The IGH_UndoAction type exposes the following members.

Properties

 | Name | Description
Public property | ExpiresDisplay | Gets the display expiration flag for this event. If True, the Rhino viewports will be redrawn once the entire undo record has been completed. If ExpiresSolution is set to true, ExpriresDisplay is implied.
Public property | ExpiresSolution | Gets the solution expiration flag for this event. If True, the solution needs to be recalculated once the entire undo record has been completed.
Public property | State | Gets the current state of the undo action.

See Also

IGH_UndoAction Interface
Grasshopper.Kernel.Undo Namespace


ExpiresDisplay Property

[image]

Grasshopper SDK
IGH_UndoAction..::..ExpiresDisplay Property
IGH_UndoAction Interface See Also Send Feedback
Gets the display expiration flag for this event. If True, the Rhino viewports will be redrawn once the entire undo record has been completed. If ExpiresSolution is set to true, ExpriresDisplay is implied.

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool ExpiresDisplay { get; }
Visual Basic
ReadOnly Property ExpiresDisplay As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Undo.IGH_UndoAction.ExpiresDisplay"]

See Also

IGH_UndoAction Interface
Grasshopper.Kernel.Undo Namespace


ExpiresSolution Property

[image]

Grasshopper SDK
IGH_UndoAction..::..ExpiresSolution Property
IGH_UndoAction Interface See Also Send Feedback
Gets the solution expiration flag for this event. If True, the solution needs to be recalculated once the entire undo record has been completed.

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
bool ExpiresSolution { get; }
Visual Basic
ReadOnly Property ExpiresSolution As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Undo.IGH_UndoAction.ExpiresSolution"]

See Also

IGH_UndoAction Interface
Grasshopper.Kernel.Undo Namespace


State Property

[image]

Grasshopper SDK
IGH_UndoAction..::..State Property
IGH_UndoAction Interface See Also Send Feedback
Gets the current state of the undo action.

Namespace: Grasshopper.Kernel.Undo
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
GH_UndoState State { get; }
Visual Basic
ReadOnly Property State As GH_UndoState
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Undo.IGH_UndoAction.State"]

See Also

IGH_UndoAction Interface
Grasshopper.Kernel.Undo Namespace


Grasshopper.Kernel.Undo.Actions Namespace

[image]

Grasshopper SDK
Grasshopper.Kernel.Undo.Actions Namespace
Send Feedback
Contains a set of predefined undo/redo actions to make certain undo records simpler.

Classes

 | Class | Description
Public class | GH_AddObjectAction | Records a single object addition.
Public class | GH_AddStateAction | Record the addition of a single solution state to a document.
Public class | GH_DataMatchingAction | Records a single Component DataComparison event.
Public class | GH_DataModificationAction | Records a single Parameter DataModification event.
Public class | GH_GenericObjectAction | Records a single object change. Object changes are undone/redone by (de)serializing the objects. Object changes also keep track of all wires feeding into and coming out of the object.
Public class | GH_HiddenAction | Records a single object Preview event.
Public class | GH_IconDisplayAction | Records a single icon display mode event.
Public class | GH_IconOverrideAction | Records a single icon override event.
Public class | GH_LayoutAction | Records a single object layout event. Useful for tracking object resizes.
Public class | GH_LockedAction | Records a single object Enabled event.
Public class | GH_NickNameAction | Records a single object NickName and IconDisplayMode event.
Public class | GH_PersistentDataAction<(Of <(<'T>)>)> | Records the changes in the persistent data of a parameter.
Public class | GH_PivotAction | Records a single object pivot event. Useful for tracking object movement.
Public class | GH_RemoveObjectAction | Records a single object removal.
Public class | GH_RemoveStateAction | Record the removal of a single solution state from a document.
Public class | GH_WireAction | Records any change to the input wires of a given parameter.
Public class | GH_WireDisplayAction | Records a single wire display mode event.


GH_AddObjectAction Class

[image]

Grasshopper SDK
GH_AddObjectAction Class
Members See Also Send Feedback
Records a single object addition.

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_AddObjectAction : GH_UndoAction
Visual Basic
Public Class GH_AddObjectAction _
    Inherits GH_UndoAction

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Undo..::..GH_UndoAction
Grasshopper.Kernel.Undo.Actions..::..GH_AddObjectAction

See Also

GH_AddObjectAction Members
Grasshopper.Kernel.Undo.Actions Namespace


GH_AddObjectAction Members

[image] [image]

Grasshopper SDK
GH_AddObjectAction Members
GH_AddObjectAction Class Constructors Methods Properties See Also Send Feedback

The GH_AddObjectAction type exposes the following members.

Constructors

 | Name | Description
Public method | GH_AddObjectAction | Initializes a new instance of the GH_AddObjectAction class

Methods

 | Name | Description
Protected method | Internal_Redo | (Overrides GH_UndoAction..::..Internal_Redo(GH_Document).)
Protected method | Internal_Undo | (Overrides GH_UndoAction..::..Internal_Undo(GH_Document).)
Public method | Read | (Inherited from GH_UndoAction.)
Public method | Redo | (Inherited from GH_UndoAction.)
Public method | Undo | (Inherited from GH_UndoAction.)
Public method | Write | (Inherited from GH_UndoAction.)

Properties

 | Name | Description
Public property | ExpiresDisplay | Override this property if you want the Rhino viewport display to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | ExpiresSolution | (Overrides GH_UndoAction..::..ExpiresSolution.)
Public property | State | (Inherited from GH_UndoAction.)

See Also

GH_AddObjectAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_AddObjectAction Constructor

[image]

Grasshopper SDK
GH_AddObjectAction Constructor
GH_AddObjectAction Class See Also Send Feedback
Initializes a new instance of the GH_AddObjectAction class

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_AddObjectAction(
    IGH_DocumentObject obj
)
Visual Basic
Public Sub New ( _
    obj As IGH_DocumentObject _
)

Parameters

obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject

See Also

GH_AddObjectAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_AddObjectAction Methods

[image] [image]

Grasshopper SDK
GH_AddObjectAction Methods
GH_AddObjectAction Class See Also Send Feedback

The GH_AddObjectAction type exposes the following members.

Methods

 | Name | Description
Protected method | Internal_Redo | (Overrides GH_UndoAction..::..Internal_Redo(GH_Document).)
Protected method | Internal_Undo | (Overrides GH_UndoAction..::..Internal_Undo(GH_Document).)
Public method | Read | (Inherited from GH_UndoAction.)
Public method | Redo | (Inherited from GH_UndoAction.)
Public method | Undo | (Inherited from GH_UndoAction.)
Public method | Write | (Inherited from GH_UndoAction.)

See Also

GH_AddObjectAction Class
Grasshopper.Kernel.Undo.Actions Namespace


Internal_Redo Method

[image]

Grasshopper SDK
GH_AddObjectAction..::..Internal_Redo Method
GH_AddObjectAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Internal_Redo(
    GH_Document doc
)
Visual Basic
Protected Overrides Sub Internal_Redo ( _
    doc As GH_Document _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document

See Also

GH_AddObjectAction Class
Grasshopper.Kernel.Undo.Actions Namespace


Internal_Undo Method

[image]

Grasshopper SDK
GH_AddObjectAction..::..Internal_Undo Method
GH_AddObjectAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Internal_Undo(
    GH_Document doc
)
Visual Basic
Protected Overrides Sub Internal_Undo ( _
    doc As GH_Document _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document

See Also

GH_AddObjectAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_AddObjectAction Properties

[image] [image]

Grasshopper SDK
GH_AddObjectAction Properties
GH_AddObjectAction Class See Also Send Feedback

The GH_AddObjectAction type exposes the following members.

Properties

 | Name | Description
Public property | ExpiresDisplay | Override this property if you want the Rhino viewport display to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | ExpiresSolution | (Overrides GH_UndoAction..::..ExpiresSolution.)
Public property | State | (Inherited from GH_UndoAction.)

See Also

GH_AddObjectAction Class
Grasshopper.Kernel.Undo.Actions Namespace


ExpiresSolution Property

[image]

Grasshopper SDK
GH_AddObjectAction..::..ExpiresSolution Property
GH_AddObjectAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool ExpiresSolution { get; }
Visual Basic
Public Overrides ReadOnly Property ExpiresSolution As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Undo.Actions.GH_AddObjectAction.ExpiresSolution"]

See Also

GH_AddObjectAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_AddStateAction Class

[image]

Grasshopper SDK
GH_AddStateAction Class
Members See Also Send Feedback
Record the addition of a single solution state to a document.

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_AddStateAction : GH_ArchivedUndoAction
Visual Basic
Public Class GH_AddStateAction _
    Inherits GH_ArchivedUndoAction

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Undo..::..GH_UndoAction
Grasshopper.Kernel.Undo..::..GH_ArchivedUndoAction
Grasshopper.Kernel.Undo.Actions..::..GH_AddStateAction

See Also

GH_AddStateAction Members
Grasshopper.Kernel.Undo.Actions Namespace


GH_AddStateAction Members

[image] [image]

Grasshopper SDK
GH_AddStateAction Members
GH_AddStateAction Class Constructors Methods Fields Properties See Also Send Feedback

The GH_AddStateAction type exposes the following members.

Constructors

 | Name | Description
Public method | GH_AddStateAction | Initializes a new instance of the GH_AddStateAction class

Methods

 | Name | Description
Protected method | Deserialize | Deserializes the obj from the local archive. (Inherited from GH_ArchivedUndoAction.)
Protected method | Internal_Redo | (Overrides GH_UndoAction..::..Internal_Redo(GH_Document).)
Protected method | Internal_Undo | (Overrides GH_UndoAction..::..Internal_Undo(GH_Document).)
Public method | Read | (Overrides GH_ArchivedUndoAction..::..Read(GH_IReader).)
Public method | Redo | (Inherited from GH_UndoAction.)
Protected method | Serialize | Serializes the obj into the local archive. (Inherited from GH_ArchivedUndoAction.)
Protected method | SerializeToByteArray | Serializes the obj into the local archive. (Inherited from GH_ArchivedUndoAction.)
Public method | Undo | (Inherited from GH_UndoAction.)
Public method | Write | (Overrides GH_ArchivedUndoAction..::..Write(GH_IWriter).)

Fields

 | Name | Description
Protected field | m_data | Internal data storage for serialized archives. (Inherited from GH_ArchivedUndoAction.)

Properties

 | Name | Description
Public property | ExpiresDisplay | Override this property if you want the Rhino viewport display to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | ExpiresSolution | Override this property if you want the Grasshopper solution to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | State | (Inherited from GH_UndoAction.)

See Also

GH_AddStateAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_AddStateAction Constructor

[image]

Grasshopper SDK
GH_AddStateAction Constructor
GH_AddStateAction Class See Also Send Feedback
Initializes a new instance of the GH_AddStateAction class

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_AddStateAction(
    int index,
    GH_State state
)
Visual Basic
Public Sub New ( _
    index As Integer, _
    state As GH_State _
)

Parameters

index
Type: System..::..Int32
state
Type: Grasshopper.Kernel..::..GH_State

See Also

GH_AddStateAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_AddStateAction Fields

[image] [image]

Grasshopper SDK
GH_AddStateAction Fields
GH_AddStateAction Class See Also Send Feedback

The GH_AddStateAction type exposes the following members.

Fields

 | Name | Description
Protected field | m_data | Internal data storage for serialized archives. (Inherited from GH_ArchivedUndoAction.)

See Also

GH_AddStateAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_AddStateAction Methods

[image] [image]

Grasshopper SDK
GH_AddStateAction Methods
GH_AddStateAction Class See Also Send Feedback

The GH_AddStateAction type exposes the following members.

Methods

 | Name | Description
Protected method | Deserialize | Deserializes the obj from the local archive. (Inherited from GH_ArchivedUndoAction.)
Protected method | Internal_Redo | (Overrides GH_UndoAction..::..Internal_Redo(GH_Document).)
Protected method | Internal_Undo | (Overrides GH_UndoAction..::..Internal_Undo(GH_Document).)
Public method | Read | (Overrides GH_ArchivedUndoAction..::..Read(GH_IReader).)
Public method | Redo | (Inherited from GH_UndoAction.)
Protected method | Serialize | Serializes the obj into the local archive. (Inherited from GH_ArchivedUndoAction.)
Protected method | SerializeToByteArray | Serializes the obj into the local archive. (Inherited from GH_ArchivedUndoAction.)
Public method | Undo | (Inherited from GH_UndoAction.)
Public method | Write | (Overrides GH_ArchivedUndoAction..::..Write(GH_IWriter).)

See Also

GH_AddStateAction Class
Grasshopper.Kernel.Undo.Actions Namespace


Internal_Redo Method

[image]

Grasshopper SDK
GH_AddStateAction..::..Internal_Redo Method
GH_AddStateAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Internal_Redo(
    GH_Document doc
)
Visual Basic
Protected Overrides Sub Internal_Redo ( _
    doc As GH_Document _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document

See Also

GH_AddStateAction Class
Grasshopper.Kernel.Undo.Actions Namespace


Internal_Undo Method

[image]

Grasshopper SDK
GH_AddStateAction..::..Internal_Undo Method
GH_AddStateAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Internal_Undo(
    GH_Document doc
)
Visual Basic
Protected Overrides Sub Internal_Undo ( _
    doc As GH_Document _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document

See Also

GH_AddStateAction Class
Grasshopper.Kernel.Undo.Actions Namespace


Read Method

[image]

Grasshopper SDK
GH_AddStateAction..::..Read Method
GH_AddStateAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

See Also

GH_AddStateAction Class
Grasshopper.Kernel.Undo.Actions Namespace


Write Method

[image]

Grasshopper SDK
GH_AddStateAction..::..Write Method
GH_AddStateAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overrides Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

See Also

GH_AddStateAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_AddStateAction Properties

[image] [image]

Grasshopper SDK
GH_AddStateAction Properties
GH_AddStateAction Class See Also Send Feedback

The GH_AddStateAction type exposes the following members.

Properties

 | Name | Description
Public property | ExpiresDisplay | Override this property if you want the Rhino viewport display to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | ExpiresSolution | Override this property if you want the Grasshopper solution to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | State | (Inherited from GH_UndoAction.)

See Also

GH_AddStateAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_DataMatchingAction Class

[image]

Grasshopper SDK
GH_DataMatchingAction Class
Members See Also Send Feedback
Records a single Component DataComparison event.

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_DataMatchingAction : GH_ObjectUndoAction
Visual Basic
Public Class GH_DataMatchingAction _
    Inherits GH_ObjectUndoAction

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Undo..::..GH_UndoAction
Grasshopper.Kernel.Undo..::..GH_ObjectUndoAction
Grasshopper.Kernel.Undo.Actions..::..GH_DataMatchingAction

See Also

GH_DataMatchingAction Members
Grasshopper.Kernel.Undo.Actions Namespace


GH_DataMatchingAction Members

[image] [image]

Grasshopper SDK
GH_DataMatchingAction Members
GH_DataMatchingAction Class Constructors Methods Properties See Also Send Feedback

The GH_DataMatchingAction type exposes the following members.

Constructors

 | Name | Description
Public method | GH_DataMatchingAction | Initializes a new instance of the GH_DataMatchingAction class

Methods

 | Name | Description
Protected method | Internal_Redo | (Inherited from GH_ObjectUndoAction.)
Protected method | Internal_Undo | (Inherited from GH_ObjectUndoAction.)
Protected method | Object_Redo | (Overrides GH_ObjectUndoAction..::..Object_Redo(GH_Document, IGH_DocumentObject).)
Protected method | Object_Undo | (Overrides GH_ObjectUndoAction..::..Object_Undo(GH_Document, IGH_DocumentObject).)
Public method | Read | (Inherited from GH_UndoAction.)
Public method | Redo | (Inherited from GH_UndoAction.)
Public method | Undo | (Inherited from GH_UndoAction.)
Public method | Write | (Inherited from GH_UndoAction.)

Properties

 | Name | Description
Public property | ExpiresDisplay | Override this property if you want the Rhino viewport display to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | ExpiresSolution | (Overrides GH_UndoAction..::..ExpiresSolution.)
Public property | State | (Inherited from GH_UndoAction.)

See Also

GH_DataMatchingAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_DataMatchingAction Constructor

[image]

Grasshopper SDK
GH_DataMatchingAction Constructor
GH_DataMatchingAction Class See Also Send Feedback
Initializes a new instance of the GH_DataMatchingAction class

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_DataMatchingAction(
    IGH_Component obj
)
Visual Basic
Public Sub New ( _
    obj As IGH_Component _
)

Parameters

obj
Type: Grasshopper.Kernel..::..IGH_Component

See Also

GH_DataMatchingAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_DataMatchingAction Methods

[image] [image]

Grasshopper SDK
GH_DataMatchingAction Methods
GH_DataMatchingAction Class See Also Send Feedback

The GH_DataMatchingAction type exposes the following members.

Methods

 | Name | Description
Protected method | Internal_Redo | (Inherited from GH_ObjectUndoAction.)
Protected method | Internal_Undo | (Inherited from GH_ObjectUndoAction.)
Protected method | Object_Redo | (Overrides GH_ObjectUndoAction..::..Object_Redo(GH_Document, IGH_DocumentObject).)
Protected method | Object_Undo | (Overrides GH_ObjectUndoAction..::..Object_Undo(GH_Document, IGH_DocumentObject).)
Public method | Read | (Inherited from GH_UndoAction.)
Public method | Redo | (Inherited from GH_UndoAction.)
Public method | Undo | (Inherited from GH_UndoAction.)
Public method | Write | (Inherited from GH_UndoAction.)

See Also

GH_DataMatchingAction Class
Grasshopper.Kernel.Undo.Actions Namespace


Object_Redo Method

[image]

Grasshopper SDK
GH_DataMatchingAction..::..Object_Redo Method
GH_DataMatchingAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Object_Redo(
    GH_Document doc,
    IGH_DocumentObject obj
)
Visual Basic
Protected Overrides Sub Object_Redo ( _
    doc As GH_Document, _
    obj As IGH_DocumentObject _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document
obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject

See Also

GH_DataMatchingAction Class
Grasshopper.Kernel.Undo.Actions Namespace


Object_Undo Method

[image]

Grasshopper SDK
GH_DataMatchingAction..::..Object_Undo Method
GH_DataMatchingAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Object_Undo(
    GH_Document doc,
    IGH_DocumentObject obj
)
Visual Basic
Protected Overrides Sub Object_Undo ( _
    doc As GH_Document, _
    obj As IGH_DocumentObject _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document
obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject

See Also

GH_DataMatchingAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_DataMatchingAction Properties

[image] [image]

Grasshopper SDK
GH_DataMatchingAction Properties
GH_DataMatchingAction Class See Also Send Feedback

The GH_DataMatchingAction type exposes the following members.

Properties

 | Name | Description
Public property | ExpiresDisplay | Override this property if you want the Rhino viewport display to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | ExpiresSolution | (Overrides GH_UndoAction..::..ExpiresSolution.)
Public property | State | (Inherited from GH_UndoAction.)

See Also

GH_DataMatchingAction Class
Grasshopper.Kernel.Undo.Actions Namespace


ExpiresSolution Property

[image]

Grasshopper SDK
GH_DataMatchingAction..::..ExpiresSolution Property
GH_DataMatchingAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool ExpiresSolution { get; }
Visual Basic
Public Overrides ReadOnly Property ExpiresSolution As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Undo.Actions.GH_DataMatchingAction.ExpiresSolution"]

See Also

GH_DataMatchingAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_DataModificationAction Class

[image]

Grasshopper SDK
GH_DataModificationAction Class
Members See Also Send Feedback
Records a single Parameter DataModification event.

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_DataModificationAction : GH_ObjectUndoAction
Visual Basic
Public Class GH_DataModificationAction _
    Inherits GH_ObjectUndoAction

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Undo..::..GH_UndoAction
Grasshopper.Kernel.Undo..::..GH_ObjectUndoAction
Grasshopper.Kernel.Undo.Actions..::..GH_DataModificationAction

See Also

GH_DataModificationAction Members
Grasshopper.Kernel.Undo.Actions Namespace


GH_DataModificationAction Members

[image] [image]

Grasshopper SDK
GH_DataModificationAction Members
GH_DataModificationAction Class Constructors Methods Properties See Also Send Feedback

The GH_DataModificationAction type exposes the following members.

Constructors

 | Name | Description
Public method | GH_DataModificationAction | Initializes a new instance of the GH_DataModificationAction class

Methods

 | Name | Description
Protected method | Internal_Redo | (Inherited from GH_ObjectUndoAction.)
Protected method | Internal_Undo | (Inherited from GH_ObjectUndoAction.)
Protected method | Object_Redo | (Overrides GH_ObjectUndoAction..::..Object_Redo(GH_Document, IGH_DocumentObject).)
Protected method | Object_Undo | (Overrides GH_ObjectUndoAction..::..Object_Undo(GH_Document, IGH_DocumentObject).)
Public method | Read | (Inherited from GH_UndoAction.)
Public method | Redo | (Inherited from GH_UndoAction.)
Public method | Undo | (Inherited from GH_UndoAction.)
Public method | Write | (Inherited from GH_UndoAction.)

Properties

 | Name | Description
Public property | ExpiresDisplay | Override this property if you want the Rhino viewport display to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | ExpiresSolution | (Overrides GH_UndoAction..::..ExpiresSolution.)
Public property | State | (Inherited from GH_UndoAction.)

See Also

GH_DataModificationAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_DataModificationAction Constructor

[image]

Grasshopper SDK
GH_DataModificationAction Constructor
GH_DataModificationAction Class See Also Send Feedback
Initializes a new instance of the GH_DataModificationAction class

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_DataModificationAction(
    IGH_Param obj
)
Visual Basic
Public Sub New ( _
    obj As IGH_Param _
)

Parameters

obj
Type: Grasshopper.Kernel..::..IGH_Param

See Also

GH_DataModificationAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_DataModificationAction Methods

[image] [image]

Grasshopper SDK
GH_DataModificationAction Methods
GH_DataModificationAction Class See Also Send Feedback

The GH_DataModificationAction type exposes the following members.

Methods

 | Name | Description
Protected method | Internal_Redo | (Inherited from GH_ObjectUndoAction.)
Protected method | Internal_Undo | (Inherited from GH_ObjectUndoAction.)
Protected method | Object_Redo | (Overrides GH_ObjectUndoAction..::..Object_Redo(GH_Document, IGH_DocumentObject).)
Protected method | Object_Undo | (Overrides GH_ObjectUndoAction..::..Object_Undo(GH_Document, IGH_DocumentObject).)
Public method | Read | (Inherited from GH_UndoAction.)
Public method | Redo | (Inherited from GH_UndoAction.)
Public method | Undo | (Inherited from GH_UndoAction.)
Public method | Write | (Inherited from GH_UndoAction.)

See Also

GH_DataModificationAction Class
Grasshopper.Kernel.Undo.Actions Namespace


Object_Redo Method

[image]

Grasshopper SDK
GH_DataModificationAction..::..Object_Redo Method
GH_DataModificationAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Object_Redo(
    GH_Document doc,
    IGH_DocumentObject obj
)
Visual Basic
Protected Overrides Sub Object_Redo ( _
    doc As GH_Document, _
    obj As IGH_DocumentObject _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document
obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject

See Also

GH_DataModificationAction Class
Grasshopper.Kernel.Undo.Actions Namespace


Object_Undo Method

[image]

Grasshopper SDK
GH_DataModificationAction..::..Object_Undo Method
GH_DataModificationAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Object_Undo(
    GH_Document doc,
    IGH_DocumentObject obj
)
Visual Basic
Protected Overrides Sub Object_Undo ( _
    doc As GH_Document, _
    obj As IGH_DocumentObject _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document
obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject

See Also

GH_DataModificationAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_DataModificationAction Properties

[image] [image]

Grasshopper SDK
GH_DataModificationAction Properties
GH_DataModificationAction Class See Also Send Feedback

The GH_DataModificationAction type exposes the following members.

Properties

 | Name | Description
Public property | ExpiresDisplay | Override this property if you want the Rhino viewport display to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | ExpiresSolution | (Overrides GH_UndoAction..::..ExpiresSolution.)
Public property | State | (Inherited from GH_UndoAction.)

See Also

GH_DataModificationAction Class
Grasshopper.Kernel.Undo.Actions Namespace


ExpiresSolution Property

[image]

Grasshopper SDK
GH_DataModificationAction..::..ExpiresSolution Property
GH_DataModificationAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool ExpiresSolution { get; }
Visual Basic
Public Overrides ReadOnly Property ExpiresSolution As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Undo.Actions.GH_DataModificationAction.ExpiresSolution"]

See Also

GH_DataModificationAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_GenericObjectAction Class

[image]

Grasshopper SDK
GH_GenericObjectAction Class
Members See Also Send Feedback
Records a single object change. Object changes are undone/redone by (de)serializing the objects. Object changes also keep track of all wires feeding into and coming out of the object.

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_GenericObjectAction : GH_ArchivedUndoAction
Visual Basic
Public Class GH_GenericObjectAction _
    Inherits GH_ArchivedUndoAction

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Undo..::..GH_UndoAction
Grasshopper.Kernel.Undo..::..GH_ArchivedUndoAction
Grasshopper.Kernel.Undo.Actions..::..GH_GenericObjectAction

See Also

GH_GenericObjectAction Members
Grasshopper.Kernel.Undo.Actions Namespace


GH_GenericObjectAction Members

[image] [image]

Grasshopper SDK
GH_GenericObjectAction Members
GH_GenericObjectAction Class Constructors Methods Fields Properties See Also Send Feedback

The GH_GenericObjectAction type exposes the following members.

Constructors

 | Name | Description
Public method | GH_GenericObjectAction | Initializes a new instance of the GH_GenericObjectAction class

Methods

 | Name | Description
Protected method | Deserialize | Deserializes the obj from the local archive. (Inherited from GH_ArchivedUndoAction.)
Protected method | Internal_Redo | (Overrides GH_UndoAction..::..Internal_Redo(GH_Document).)
Protected method | Internal_Undo | (Overrides GH_UndoAction..::..Internal_Undo(GH_Document).)
Public method | Read | (Inherited from GH_ArchivedUndoAction.)
Public method | Redo | (Inherited from GH_UndoAction.)
Protected method | Serialize | Serializes the obj into the local archive. (Inherited from GH_ArchivedUndoAction.)
Protected method | SerializeToByteArray | Serializes the obj into the local archive. (Inherited from GH_ArchivedUndoAction.)
Public method | Undo | (Inherited from GH_UndoAction.)
Public method | Write | (Inherited from GH_ArchivedUndoAction.)

Fields

 | Name | Description
Protected field | m_data | Internal data storage for serialized archives. (Inherited from GH_ArchivedUndoAction.)

Properties

 | Name | Description
Public property | ExpiresDisplay | Override this property if you want the Rhino viewport display to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | ExpiresSolution | (Overrides GH_UndoAction..::..ExpiresSolution.)
Public property | State | (Inherited from GH_UndoAction.)

See Also

GH_GenericObjectAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_GenericObjectAction Constructor

[image]

Grasshopper SDK
GH_GenericObjectAction Constructor
GH_GenericObjectAction Class See Also Send Feedback
Initializes a new instance of the GH_GenericObjectAction class

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_GenericObjectAction(
    IGH_DocumentObject obj
)
Visual Basic
Public Sub New ( _
    obj As IGH_DocumentObject _
)

Parameters

obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject

See Also

GH_GenericObjectAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_GenericObjectAction Fields

[image] [image]

Grasshopper SDK
GH_GenericObjectAction Fields
GH_GenericObjectAction Class See Also Send Feedback

The GH_GenericObjectAction type exposes the following members.

Fields

 | Name | Description
Protected field | m_data | Internal data storage for serialized archives. (Inherited from GH_ArchivedUndoAction.)

See Also

GH_GenericObjectAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_GenericObjectAction Methods

[image] [image]

Grasshopper SDK
GH_GenericObjectAction Methods
GH_GenericObjectAction Class See Also Send Feedback

The GH_GenericObjectAction type exposes the following members.

Methods

 | Name | Description
Protected method | Deserialize | Deserializes the obj from the local archive. (Inherited from GH_ArchivedUndoAction.)
Protected method | Internal_Redo | (Overrides GH_UndoAction..::..Internal_Redo(GH_Document).)
Protected method | Internal_Undo | (Overrides GH_UndoAction..::..Internal_Undo(GH_Document).)
Public method | Read | (Inherited from GH_ArchivedUndoAction.)
Public method | Redo | (Inherited from GH_UndoAction.)
Protected method | Serialize | Serializes the obj into the local archive. (Inherited from GH_ArchivedUndoAction.)
Protected method | SerializeToByteArray | Serializes the obj into the local archive. (Inherited from GH_ArchivedUndoAction.)
Public method | Undo | (Inherited from GH_UndoAction.)
Public method | Write | (Inherited from GH_ArchivedUndoAction.)

See Also

GH_GenericObjectAction Class
Grasshopper.Kernel.Undo.Actions Namespace


Internal_Redo Method

[image]

Grasshopper SDK
GH_GenericObjectAction..::..Internal_Redo Method
GH_GenericObjectAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Internal_Redo(
    GH_Document doc
)
Visual Basic
Protected Overrides Sub Internal_Redo ( _
    doc As GH_Document _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document

See Also

GH_GenericObjectAction Class
Grasshopper.Kernel.Undo.Actions Namespace


Internal_Undo Method

[image]

Grasshopper SDK
GH_GenericObjectAction..::..Internal_Undo Method
GH_GenericObjectAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Internal_Undo(
    GH_Document doc
)
Visual Basic
Protected Overrides Sub Internal_Undo ( _
    doc As GH_Document _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document

See Also

GH_GenericObjectAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_GenericObjectAction Properties

[image] [image]

Grasshopper SDK
GH_GenericObjectAction Properties
GH_GenericObjectAction Class See Also Send Feedback

The GH_GenericObjectAction type exposes the following members.

Properties

 | Name | Description
Public property | ExpiresDisplay | Override this property if you want the Rhino viewport display to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | ExpiresSolution | (Overrides GH_UndoAction..::..ExpiresSolution.)
Public property | State | (Inherited from GH_UndoAction.)

See Also

GH_GenericObjectAction Class
Grasshopper.Kernel.Undo.Actions Namespace


ExpiresSolution Property

[image]

Grasshopper SDK
GH_GenericObjectAction..::..ExpiresSolution Property
GH_GenericObjectAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool ExpiresSolution { get; }
Visual Basic
Public Overrides ReadOnly Property ExpiresSolution As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Undo.Actions.GH_GenericObjectAction.ExpiresSolution"]

See Also

GH_GenericObjectAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_HiddenAction Class

[image]

Grasshopper SDK
GH_HiddenAction Class
Members See Also Send Feedback
Records a single object Preview event.

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_HiddenAction : GH_ObjectUndoAction
Visual Basic
Public Class GH_HiddenAction _
    Inherits GH_ObjectUndoAction

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Undo..::..GH_UndoAction
Grasshopper.Kernel.Undo..::..GH_ObjectUndoAction
Grasshopper.Kernel.Undo.Actions..::..GH_HiddenAction

See Also

GH_HiddenAction Members
Grasshopper.Kernel.Undo.Actions Namespace


GH_HiddenAction Members

[image] [image]

Grasshopper SDK
GH_HiddenAction Members
GH_HiddenAction Class Constructors Methods Properties See Also Send Feedback

The GH_HiddenAction type exposes the following members.

Constructors

 | Name | Description
Public method | GH_HiddenAction | Initializes a new instance of the GH_HiddenAction class

Methods

 | Name | Description
Protected method | Internal_Redo | (Inherited from GH_ObjectUndoAction.)
Protected method | Internal_Undo | (Inherited from GH_ObjectUndoAction.)
Protected method | Object_Redo | (Overrides GH_ObjectUndoAction..::..Object_Redo(GH_Document, IGH_DocumentObject).)
Protected method | Object_Undo | (Overrides GH_ObjectUndoAction..::..Object_Undo(GH_Document, IGH_DocumentObject).)
Public method | Read | (Inherited from GH_UndoAction.)
Public method | Redo | (Inherited from GH_UndoAction.)
Public method | Undo | (Inherited from GH_UndoAction.)
Public method | Write | (Inherited from GH_UndoAction.)

Properties

 | Name | Description
Public property | ExpiresDisplay | (Overrides GH_UndoAction..::..ExpiresDisplay.)
Public property | ExpiresSolution | Override this property if you want the Grasshopper solution to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | State | (Inherited from GH_UndoAction.)

See Also

GH_HiddenAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_HiddenAction Constructor

[image]

Grasshopper SDK
GH_HiddenAction Constructor
GH_HiddenAction Class See Also Send Feedback
Initializes a new instance of the GH_HiddenAction class

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_HiddenAction(
    IGH_ActiveObject obj
)
Visual Basic
Public Sub New ( _
    obj As IGH_ActiveObject _
)

Parameters

obj
Type: Grasshopper.Kernel..::..IGH_ActiveObject

See Also

GH_HiddenAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_HiddenAction Methods

[image] [image]

Grasshopper SDK
GH_HiddenAction Methods
GH_HiddenAction Class See Also Send Feedback

The GH_HiddenAction type exposes the following members.

Methods

 | Name | Description
Protected method | Internal_Redo | (Inherited from GH_ObjectUndoAction.)
Protected method | Internal_Undo | (Inherited from GH_ObjectUndoAction.)
Protected method | Object_Redo | (Overrides GH_ObjectUndoAction..::..Object_Redo(GH_Document, IGH_DocumentObject).)
Protected method | Object_Undo | (Overrides GH_ObjectUndoAction..::..Object_Undo(GH_Document, IGH_DocumentObject).)
Public method | Read | (Inherited from GH_UndoAction.)
Public method | Redo | (Inherited from GH_UndoAction.)
Public method | Undo | (Inherited from GH_UndoAction.)
Public method | Write | (Inherited from GH_UndoAction.)

See Also

GH_HiddenAction Class
Grasshopper.Kernel.Undo.Actions Namespace


Object_Redo Method

[image]

Grasshopper SDK
GH_HiddenAction..::..Object_Redo Method
GH_HiddenAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Object_Redo(
    GH_Document doc,
    IGH_DocumentObject obj
)
Visual Basic
Protected Overrides Sub Object_Redo ( _
    doc As GH_Document, _
    obj As IGH_DocumentObject _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document
obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject

See Also

GH_HiddenAction Class
Grasshopper.Kernel.Undo.Actions Namespace


Object_Undo Method

[image]

Grasshopper SDK
GH_HiddenAction..::..Object_Undo Method
GH_HiddenAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Object_Undo(
    GH_Document doc,
    IGH_DocumentObject obj
)
Visual Basic
Protected Overrides Sub Object_Undo ( _
    doc As GH_Document, _
    obj As IGH_DocumentObject _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document
obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject

See Also

GH_HiddenAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_HiddenAction Properties

[image] [image]

Grasshopper SDK
GH_HiddenAction Properties
GH_HiddenAction Class See Also Send Feedback

The GH_HiddenAction type exposes the following members.

Properties

 | Name | Description
Public property | ExpiresDisplay | (Overrides GH_UndoAction..::..ExpiresDisplay.)
Public property | ExpiresSolution | Override this property if you want the Grasshopper solution to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | State | (Inherited from GH_UndoAction.)

See Also

GH_HiddenAction Class
Grasshopper.Kernel.Undo.Actions Namespace


ExpiresDisplay Property

[image]

Grasshopper SDK
GH_HiddenAction..::..ExpiresDisplay Property
GH_HiddenAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool ExpiresDisplay { get; }
Visual Basic
Public Overrides ReadOnly Property ExpiresDisplay As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Undo.Actions.GH_HiddenAction.ExpiresDisplay"]

See Also

GH_HiddenAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_IconDisplayAction Class

[image]

Grasshopper SDK
GH_IconDisplayAction Class
Members See Also Send Feedback
Records a single icon display mode event.

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_IconDisplayAction : GH_ObjectUndoAction
Visual Basic
Public Class GH_IconDisplayAction _
    Inherits GH_ObjectUndoAction

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Undo..::..GH_UndoAction
Grasshopper.Kernel.Undo..::..GH_ObjectUndoAction
Grasshopper.Kernel.Undo.Actions..::..GH_IconDisplayAction

See Also

GH_IconDisplayAction Members
Grasshopper.Kernel.Undo.Actions Namespace


GH_IconDisplayAction Members

[image] [image]

Grasshopper SDK
GH_IconDisplayAction Members
GH_IconDisplayAction Class Constructors Methods Properties See Also Send Feedback

The GH_IconDisplayAction type exposes the following members.

Constructors

 | Name | Description
Public method | GH_IconDisplayAction | Initializes a new instance of the GH_IconDisplayAction class

Methods

 | Name | Description
Protected method | Internal_Redo | (Inherited from GH_ObjectUndoAction.)
Protected method | Internal_Undo | (Inherited from GH_ObjectUndoAction.)
Protected method | Object_Redo | (Overrides GH_ObjectUndoAction..::..Object_Redo(GH_Document, IGH_DocumentObject).)
Protected method | Object_Undo | (Overrides GH_ObjectUndoAction..::..Object_Undo(GH_Document, IGH_DocumentObject).)
Public method | Read | (Inherited from GH_UndoAction.)
Public method | Redo | (Inherited from GH_UndoAction.)
Public method | Undo | (Inherited from GH_UndoAction.)
Public method | Write | (Inherited from GH_UndoAction.)

Properties

 | Name | Description
Public property | ExpiresDisplay | Override this property if you want the Rhino viewport display to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | ExpiresSolution | Override this property if you want the Grasshopper solution to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | State | (Inherited from GH_UndoAction.)

See Also

GH_IconDisplayAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_IconDisplayAction Constructor

[image]

Grasshopper SDK
GH_IconDisplayAction Constructor
GH_IconDisplayAction Class See Also Send Feedback
Initializes a new instance of the GH_IconDisplayAction class

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_IconDisplayAction(
    IGH_DocumentObject obj
)
Visual Basic
Public Sub New ( _
    obj As IGH_DocumentObject _
)

Parameters

obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject

See Also

GH_IconDisplayAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_IconDisplayAction Methods

[image] [image]

Grasshopper SDK
GH_IconDisplayAction Methods
GH_IconDisplayAction Class See Also Send Feedback

The GH_IconDisplayAction type exposes the following members.

Methods

 | Name | Description
Protected method | Internal_Redo | (Inherited from GH_ObjectUndoAction.)
Protected method | Internal_Undo | (Inherited from GH_ObjectUndoAction.)
Protected method | Object_Redo | (Overrides GH_ObjectUndoAction..::..Object_Redo(GH_Document, IGH_DocumentObject).)
Protected method | Object_Undo | (Overrides GH_ObjectUndoAction..::..Object_Undo(GH_Document, IGH_DocumentObject).)
Public method | Read | (Inherited from GH_UndoAction.)
Public method | Redo | (Inherited from GH_UndoAction.)
Public method | Undo | (Inherited from GH_UndoAction.)
Public method | Write | (Inherited from GH_UndoAction.)

See Also

GH_IconDisplayAction Class
Grasshopper.Kernel.Undo.Actions Namespace


Object_Redo Method

[image]

Grasshopper SDK
GH_IconDisplayAction..::..Object_Redo Method
GH_IconDisplayAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Object_Redo(
    GH_Document doc,
    IGH_DocumentObject obj
)
Visual Basic
Protected Overrides Sub Object_Redo ( _
    doc As GH_Document, _
    obj As IGH_DocumentObject _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document
obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject

See Also

GH_IconDisplayAction Class
Grasshopper.Kernel.Undo.Actions Namespace


Object_Undo Method

[image]

Grasshopper SDK
GH_IconDisplayAction..::..Object_Undo Method
GH_IconDisplayAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Object_Undo(
    GH_Document doc,
    IGH_DocumentObject obj
)
Visual Basic
Protected Overrides Sub Object_Undo ( _
    doc As GH_Document, _
    obj As IGH_DocumentObject _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document
obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject

See Also

GH_IconDisplayAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_IconDisplayAction Properties

[image] [image]

Grasshopper SDK
GH_IconDisplayAction Properties
GH_IconDisplayAction Class See Also Send Feedback

The GH_IconDisplayAction type exposes the following members.

Properties

 | Name | Description
Public property | ExpiresDisplay | Override this property if you want the Rhino viewport display to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | ExpiresSolution | Override this property if you want the Grasshopper solution to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | State | (Inherited from GH_UndoAction.)

See Also

GH_IconDisplayAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_IconOverrideAction Class

[image]

Grasshopper SDK
GH_IconOverrideAction Class
Members See Also Send Feedback
Records a single icon override event.

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_IconOverrideAction : GH_ObjectUndoAction
Visual Basic
Public Class GH_IconOverrideAction _
    Inherits GH_ObjectUndoAction

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Undo..::..GH_UndoAction
Grasshopper.Kernel.Undo..::..GH_ObjectUndoAction
Grasshopper.Kernel.Undo.Actions..::..GH_IconOverrideAction

See Also

GH_IconOverrideAction Members
Grasshopper.Kernel.Undo.Actions Namespace


GH_IconOverrideAction Members

[image] [image]

Grasshopper SDK
GH_IconOverrideAction Members
GH_IconOverrideAction Class Constructors Methods Properties See Also Send Feedback

The GH_IconOverrideAction type exposes the following members.

Constructors

 | Name | Description
Public method | GH_IconOverrideAction | Initializes a new instance of the GH_IconOverrideAction class

Methods

 | Name | Description
Protected method | Internal_Redo | (Inherited from GH_ObjectUndoAction.)
Protected method | Internal_Undo | (Inherited from GH_ObjectUndoAction.)
Protected method | Object_Redo | (Overrides GH_ObjectUndoAction..::..Object_Redo(GH_Document, IGH_DocumentObject).)
Protected method | Object_Undo | (Overrides GH_ObjectUndoAction..::..Object_Undo(GH_Document, IGH_DocumentObject).)
Public method | Read | (Inherited from GH_UndoAction.)
Public method | Redo | (Inherited from GH_UndoAction.)
Public method | Undo | (Inherited from GH_UndoAction.)
Public method | Write | (Inherited from GH_UndoAction.)

Properties

 | Name | Description
Public property | ExpiresDisplay | Override this property if you want the Rhino viewport display to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | ExpiresSolution | Override this property if you want the Grasshopper solution to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | State | (Inherited from GH_UndoAction.)

See Also

GH_IconOverrideAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_IconOverrideAction Constructor

[image]

Grasshopper SDK
GH_IconOverrideAction Constructor
GH_IconOverrideAction Class See Also Send Feedback
Initializes a new instance of the GH_IconOverrideAction class

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_IconOverrideAction(
    IGH_DocumentObject obj
)
Visual Basic
Public Sub New ( _
    obj As IGH_DocumentObject _
)

Parameters

obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject

See Also

GH_IconOverrideAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_IconOverrideAction Methods

[image] [image]

Grasshopper SDK
GH_IconOverrideAction Methods
GH_IconOverrideAction Class See Also Send Feedback

The GH_IconOverrideAction type exposes the following members.

Methods

 | Name | Description
Protected method | Internal_Redo | (Inherited from GH_ObjectUndoAction.)
Protected method | Internal_Undo | (Inherited from GH_ObjectUndoAction.)
Protected method | Object_Redo | (Overrides GH_ObjectUndoAction..::..Object_Redo(GH_Document, IGH_DocumentObject).)
Protected method | Object_Undo | (Overrides GH_ObjectUndoAction..::..Object_Undo(GH_Document, IGH_DocumentObject).)
Public method | Read | (Inherited from GH_UndoAction.)
Public method | Redo | (Inherited from GH_UndoAction.)
Public method | Undo | (Inherited from GH_UndoAction.)
Public method | Write | (Inherited from GH_UndoAction.)

See Also

GH_IconOverrideAction Class
Grasshopper.Kernel.Undo.Actions Namespace


Object_Redo Method

[image]

Grasshopper SDK
GH_IconOverrideAction..::..Object_Redo Method
GH_IconOverrideAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Object_Redo(
    GH_Document doc,
    IGH_DocumentObject obj
)
Visual Basic
Protected Overrides Sub Object_Redo ( _
    doc As GH_Document, _
    obj As IGH_DocumentObject _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document
obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject

See Also

GH_IconOverrideAction Class
Grasshopper.Kernel.Undo.Actions Namespace


Object_Undo Method

[image]

Grasshopper SDK
GH_IconOverrideAction..::..Object_Undo Method
GH_IconOverrideAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Object_Undo(
    GH_Document doc,
    IGH_DocumentObject obj
)
Visual Basic
Protected Overrides Sub Object_Undo ( _
    doc As GH_Document, _
    obj As IGH_DocumentObject _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document
obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject

See Also

GH_IconOverrideAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_IconOverrideAction Properties

[image] [image]

Grasshopper SDK
GH_IconOverrideAction Properties
GH_IconOverrideAction Class See Also Send Feedback

The GH_IconOverrideAction type exposes the following members.

Properties

 | Name | Description
Public property | ExpiresDisplay | Override this property if you want the Rhino viewport display to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | ExpiresSolution | Override this property if you want the Grasshopper solution to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | State | (Inherited from GH_UndoAction.)

See Also

GH_IconOverrideAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_LayoutAction Class

[image]

Grasshopper SDK
GH_LayoutAction Class
Members See Also Send Feedback
Records a single object layout event. Useful for tracking object resizes.

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_LayoutAction : GH_ObjectUndoAction
Visual Basic
Public Class GH_LayoutAction _
    Inherits GH_ObjectUndoAction

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Undo..::..GH_UndoAction
Grasshopper.Kernel.Undo..::..GH_ObjectUndoAction
Grasshopper.Kernel.Undo.Actions..::..GH_LayoutAction

See Also

GH_LayoutAction Members
Grasshopper.Kernel.Undo.Actions Namespace


GH_LayoutAction Members

[image] [image]

Grasshopper SDK
GH_LayoutAction Members
GH_LayoutAction Class Constructors Methods Properties See Also Send Feedback

The GH_LayoutAction type exposes the following members.

Constructors

 | Name | Description
Public method | GH_LayoutAction | Initializes a new instance of the GH_LayoutAction class

Methods

 | Name | Description
Protected method | Internal_Redo | (Inherited from GH_ObjectUndoAction.)
Protected method | Internal_Undo | (Inherited from GH_ObjectUndoAction.)
Protected method | Object_Redo | (Overrides GH_ObjectUndoAction..::..Object_Redo(GH_Document, IGH_DocumentObject).)
Protected method | Object_Undo | (Overrides GH_ObjectUndoAction..::..Object_Undo(GH_Document, IGH_DocumentObject).)
Public method | Read | (Inherited from GH_UndoAction.)
Public method | Redo | (Inherited from GH_UndoAction.)
Public method | Undo | (Inherited from GH_UndoAction.)
Public method | Write | (Inherited from GH_UndoAction.)

Properties

 | Name | Description
Public property | ExpiresDisplay | Override this property if you want the Rhino viewport display to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | ExpiresSolution | Override this property if you want the Grasshopper solution to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | State | (Inherited from GH_UndoAction.)

See Also

GH_LayoutAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_LayoutAction Constructor

[image]

Grasshopper SDK
GH_LayoutAction Constructor
GH_LayoutAction Class See Also Send Feedback
Initializes a new instance of the GH_LayoutAction class

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_LayoutAction(
    IGH_DocumentObject obj
)
Visual Basic
Public Sub New ( _
    obj As IGH_DocumentObject _
)

Parameters

obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject

See Also

GH_LayoutAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_LayoutAction Methods

[image] [image]

Grasshopper SDK
GH_LayoutAction Methods
GH_LayoutAction Class See Also Send Feedback

The GH_LayoutAction type exposes the following members.

Methods

 | Name | Description
Protected method | Internal_Redo | (Inherited from GH_ObjectUndoAction.)
Protected method | Internal_Undo | (Inherited from GH_ObjectUndoAction.)
Protected method | Object_Redo | (Overrides GH_ObjectUndoAction..::..Object_Redo(GH_Document, IGH_DocumentObject).)
Protected method | Object_Undo | (Overrides GH_ObjectUndoAction..::..Object_Undo(GH_Document, IGH_DocumentObject).)
Public method | Read | (Inherited from GH_UndoAction.)
Public method | Redo | (Inherited from GH_UndoAction.)
Public method | Undo | (Inherited from GH_UndoAction.)
Public method | Write | (Inherited from GH_UndoAction.)

See Also

GH_LayoutAction Class
Grasshopper.Kernel.Undo.Actions Namespace


Object_Redo Method

[image]

Grasshopper SDK
GH_LayoutAction..::..Object_Redo Method
GH_LayoutAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Object_Redo(
    GH_Document doc,
    IGH_DocumentObject obj
)
Visual Basic
Protected Overrides Sub Object_Redo ( _
    doc As GH_Document, _
    obj As IGH_DocumentObject _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document
obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject

See Also

GH_LayoutAction Class
Grasshopper.Kernel.Undo.Actions Namespace


Object_Undo Method

[image]

Grasshopper SDK
GH_LayoutAction..::..Object_Undo Method
GH_LayoutAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Object_Undo(
    GH_Document doc,
    IGH_DocumentObject obj
)
Visual Basic
Protected Overrides Sub Object_Undo ( _
    doc As GH_Document, _
    obj As IGH_DocumentObject _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document
obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject

See Also

GH_LayoutAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_LayoutAction Properties

[image] [image]

Grasshopper SDK
GH_LayoutAction Properties
GH_LayoutAction Class See Also Send Feedback

The GH_LayoutAction type exposes the following members.

Properties

 | Name | Description
Public property | ExpiresDisplay | Override this property if you want the Rhino viewport display to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | ExpiresSolution | Override this property if you want the Grasshopper solution to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | State | (Inherited from GH_UndoAction.)

See Also

GH_LayoutAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_LockedAction Class

[image]

Grasshopper SDK
GH_LockedAction Class
Members See Also Send Feedback
Records a single object Enabled event.

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_LockedAction : GH_ObjectUndoAction
Visual Basic
Public Class GH_LockedAction _
    Inherits GH_ObjectUndoAction

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Undo..::..GH_UndoAction
Grasshopper.Kernel.Undo..::..GH_ObjectUndoAction
Grasshopper.Kernel.Undo.Actions..::..GH_LockedAction

See Also

GH_LockedAction Members
Grasshopper.Kernel.Undo.Actions Namespace


GH_LockedAction Members

[image] [image]

Grasshopper SDK
GH_LockedAction Members
GH_LockedAction Class Constructors Methods Properties See Also Send Feedback

The GH_LockedAction type exposes the following members.

Constructors

 | Name | Description
Public method | GH_LockedAction | Initializes a new instance of the GH_LockedAction class

Methods

 | Name | Description
Protected method | Internal_Redo | (Inherited from GH_ObjectUndoAction.)
Protected method | Internal_Undo | (Inherited from GH_ObjectUndoAction.)
Protected method | Object_Redo | (Overrides GH_ObjectUndoAction..::..Object_Redo(GH_Document, IGH_DocumentObject).)
Protected method | Object_Undo | (Overrides GH_ObjectUndoAction..::..Object_Undo(GH_Document, IGH_DocumentObject).)
Public method | Read | (Inherited from GH_UndoAction.)
Public method | Redo | (Inherited from GH_UndoAction.)
Public method | Undo | (Inherited from GH_UndoAction.)
Public method | Write | (Inherited from GH_UndoAction.)

Properties

 | Name | Description
Public property | ExpiresDisplay | Override this property if you want the Rhino viewport display to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | ExpiresSolution | (Overrides GH_UndoAction..::..ExpiresSolution.)
Public property | State | (Inherited from GH_UndoAction.)

See Also

GH_LockedAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_LockedAction Constructor

[image]

Grasshopper SDK
GH_LockedAction Constructor
GH_LockedAction Class See Also Send Feedback
Initializes a new instance of the GH_LockedAction class

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_LockedAction(
    IGH_ActiveObject obj
)
Visual Basic
Public Sub New ( _
    obj As IGH_ActiveObject _
)

Parameters

obj
Type: Grasshopper.Kernel..::..IGH_ActiveObject

See Also

GH_LockedAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_LockedAction Methods

[image] [image]

Grasshopper SDK
GH_LockedAction Methods
GH_LockedAction Class See Also Send Feedback

The GH_LockedAction type exposes the following members.

Methods

 | Name | Description
Protected method | Internal_Redo | (Inherited from GH_ObjectUndoAction.)
Protected method | Internal_Undo | (Inherited from GH_ObjectUndoAction.)
Protected method | Object_Redo | (Overrides GH_ObjectUndoAction..::..Object_Redo(GH_Document, IGH_DocumentObject).)
Protected method | Object_Undo | (Overrides GH_ObjectUndoAction..::..Object_Undo(GH_Document, IGH_DocumentObject).)
Public method | Read | (Inherited from GH_UndoAction.)
Public method | Redo | (Inherited from GH_UndoAction.)
Public method | Undo | (Inherited from GH_UndoAction.)
Public method | Write | (Inherited from GH_UndoAction.)

See Also

GH_LockedAction Class
Grasshopper.Kernel.Undo.Actions Namespace


Object_Redo Method

[image]

Grasshopper SDK
GH_LockedAction..::..Object_Redo Method
GH_LockedAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Object_Redo(
    GH_Document doc,
    IGH_DocumentObject obj
)
Visual Basic
Protected Overrides Sub Object_Redo ( _
    doc As GH_Document, _
    obj As IGH_DocumentObject _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document
obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject

See Also

GH_LockedAction Class
Grasshopper.Kernel.Undo.Actions Namespace


Object_Undo Method

[image]

Grasshopper SDK
GH_LockedAction..::..Object_Undo Method
GH_LockedAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Object_Undo(
    GH_Document doc,
    IGH_DocumentObject obj
)
Visual Basic
Protected Overrides Sub Object_Undo ( _
    doc As GH_Document, _
    obj As IGH_DocumentObject _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document
obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject

See Also

GH_LockedAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_LockedAction Properties

[image] [image]

Grasshopper SDK
GH_LockedAction Properties
GH_LockedAction Class See Also Send Feedback

The GH_LockedAction type exposes the following members.

Properties

 | Name | Description
Public property | ExpiresDisplay | Override this property if you want the Rhino viewport display to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | ExpiresSolution | (Overrides GH_UndoAction..::..ExpiresSolution.)
Public property | State | (Inherited from GH_UndoAction.)

See Also

GH_LockedAction Class
Grasshopper.Kernel.Undo.Actions Namespace


ExpiresSolution Property

[image]

Grasshopper SDK
GH_LockedAction..::..ExpiresSolution Property
GH_LockedAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool ExpiresSolution { get; }
Visual Basic
Public Overrides ReadOnly Property ExpiresSolution As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Undo.Actions.GH_LockedAction.ExpiresSolution"]

See Also

GH_LockedAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_NickNameAction Class

[image]

Grasshopper SDK
GH_NickNameAction Class
Members See Also Send Feedback
Records a single object NickName and IconDisplayMode event.

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_NickNameAction : GH_ObjectUndoAction
Visual Basic
Public Class GH_NickNameAction _
    Inherits GH_ObjectUndoAction

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Undo..::..GH_UndoAction
Grasshopper.Kernel.Undo..::..GH_ObjectUndoAction
Grasshopper.Kernel.Undo.Actions..::..GH_NickNameAction

See Also

GH_NickNameAction Members
Grasshopper.Kernel.Undo.Actions Namespace


GH_NickNameAction Members

[image] [image]

Grasshopper SDK
GH_NickNameAction Members
GH_NickNameAction Class Constructors Methods Properties See Also Send Feedback

The GH_NickNameAction type exposes the following members.

Constructors

 | Name | Description
Public method | GH_NickNameAction | Initializes a new instance of the GH_NickNameAction class

Methods

 | Name | Description
Protected method | Internal_Redo | (Inherited from GH_ObjectUndoAction.)
Protected method | Internal_Undo | (Inherited from GH_ObjectUndoAction.)
Protected method | Object_Redo | (Overrides GH_ObjectUndoAction..::..Object_Redo(GH_Document, IGH_DocumentObject).)
Protected method | Object_Undo | (Overrides GH_ObjectUndoAction..::..Object_Undo(GH_Document, IGH_DocumentObject).)
Public method | Read | (Inherited from GH_UndoAction.)
Public method | Redo | (Inherited from GH_UndoAction.)
Public method | Undo | (Inherited from GH_UndoAction.)
Public method | Write | (Inherited from GH_UndoAction.)

Properties

 | Name | Description
Public property | ExpiresDisplay | Override this property if you want the Rhino viewport display to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | ExpiresSolution | Override this property if you want the Grasshopper solution to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | State | (Inherited from GH_UndoAction.)

See Also

GH_NickNameAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_NickNameAction Constructor

[image]

Grasshopper SDK
GH_NickNameAction Constructor
GH_NickNameAction Class See Also Send Feedback
Initializes a new instance of the GH_NickNameAction class

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_NickNameAction(
    IGH_DocumentObject obj
)
Visual Basic
Public Sub New ( _
    obj As IGH_DocumentObject _
)

Parameters

obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject

See Also

GH_NickNameAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_NickNameAction Methods

[image] [image]

Grasshopper SDK
GH_NickNameAction Methods
GH_NickNameAction Class See Also Send Feedback

The GH_NickNameAction type exposes the following members.

Methods

 | Name | Description
Protected method | Internal_Redo | (Inherited from GH_ObjectUndoAction.)
Protected method | Internal_Undo | (Inherited from GH_ObjectUndoAction.)
Protected method | Object_Redo | (Overrides GH_ObjectUndoAction..::..Object_Redo(GH_Document, IGH_DocumentObject).)
Protected method | Object_Undo | (Overrides GH_ObjectUndoAction..::..Object_Undo(GH_Document, IGH_DocumentObject).)
Public method | Read | (Inherited from GH_UndoAction.)
Public method | Redo | (Inherited from GH_UndoAction.)
Public method | Undo | (Inherited from GH_UndoAction.)
Public method | Write | (Inherited from GH_UndoAction.)

See Also

GH_NickNameAction Class
Grasshopper.Kernel.Undo.Actions Namespace


Object_Redo Method

[image]

Grasshopper SDK
GH_NickNameAction..::..Object_Redo Method
GH_NickNameAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Object_Redo(
    GH_Document doc,
    IGH_DocumentObject obj
)
Visual Basic
Protected Overrides Sub Object_Redo ( _
    doc As GH_Document, _
    obj As IGH_DocumentObject _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document
obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject

See Also

GH_NickNameAction Class
Grasshopper.Kernel.Undo.Actions Namespace


Object_Undo Method

[image]

Grasshopper SDK
GH_NickNameAction..::..Object_Undo Method
GH_NickNameAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Object_Undo(
    GH_Document doc,
    IGH_DocumentObject obj
)
Visual Basic
Protected Overrides Sub Object_Undo ( _
    doc As GH_Document, _
    obj As IGH_DocumentObject _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document
obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject

See Also

GH_NickNameAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_NickNameAction Properties

[image] [image]

Grasshopper SDK
GH_NickNameAction Properties
GH_NickNameAction Class See Also Send Feedback

The GH_NickNameAction type exposes the following members.

Properties

 | Name | Description
Public property | ExpiresDisplay | Override this property if you want the Rhino viewport display to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | ExpiresSolution | Override this property if you want the Grasshopper solution to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | State | (Inherited from GH_UndoAction.)

See Also

GH_NickNameAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_PersistentDataAction(T) Class

[image]

Grasshopper SDK
GH_PersistentDataAction<(Of <(<'T>)>)> Class
Members See Also Send Feedback
Records the changes in the persistent data of a parameter.

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_PersistentDataAction<T> : GH_ObjectUndoAction
where T : class, IGH_Goo
Visual Basic
Public Class GH_PersistentDataAction(Of T As {Class, IGH_Goo}) _
    Inherits GH_ObjectUndoAction

Type Parameters

T

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Undo..::..GH_UndoAction
Grasshopper.Kernel.Undo..::..GH_ObjectUndoAction
Grasshopper.Kernel.Undo.Actions..::..GH_PersistentDataAction<(Of <(<'T>)>)>

See Also

GH_PersistentDataAction<(Of <(<'T>)>)> Members
Grasshopper.Kernel.Undo.Actions Namespace


GH_PersistentDataAction(T) Members

[image] [image]

Grasshopper SDK
GH_PersistentDataAction<(Of <(<'T>)>)> Members
GH_PersistentDataAction<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The GH_PersistentDataAction<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | GH_PersistentDataAction<(Of <(<'T>)>)> | Initializes a new instance of the GH_PersistentDataAction<(Of <(<'T>)>)> class

Methods

 | Name | Description
Protected method | Internal_Redo | (Inherited from GH_ObjectUndoAction.)
Protected method | Internal_Undo | (Inherited from GH_ObjectUndoAction.)
Protected method | Object_Redo | (Overrides GH_ObjectUndoAction..::..Object_Redo(GH_Document, IGH_DocumentObject).)
Protected method | Object_Undo | (Overrides GH_ObjectUndoAction..::..Object_Undo(GH_Document, IGH_DocumentObject).)
Public method | Read | (Inherited from GH_UndoAction.)
Public method | Redo | (Inherited from GH_UndoAction.)
Public method | Undo | (Inherited from GH_UndoAction.)
Public method | Write | (Inherited from GH_UndoAction.)

Properties

 | Name | Description
Public property | ExpiresDisplay | Override this property if you want the Rhino viewport display to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | ExpiresSolution | (Overrides GH_UndoAction..::..ExpiresSolution.)
Public property | State | (Inherited from GH_UndoAction.)

See Also

GH_PersistentDataAction<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_PersistentDataAction(T) Constructor

[image]

Grasshopper SDK
GH_PersistentDataAction<(Of <(<'T>)>)> Constructor
GH_PersistentDataAction<(Of <(<'T>)>)> Class See Also Send Feedback
Initializes a new instance of the GH_PersistentDataAction<(Of <(<'T>)>)> class

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PersistentDataAction(
    GH_PersistentParam<T> obj
)
Visual Basic
Public Sub New ( _
    obj As GH_PersistentParam(Of T) _
)

Parameters

obj
Type: Grasshopper.Kernel..::..GH_PersistentParam <(Of <(<' T >)>)>

See Also

GH_PersistentDataAction<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_PersistentDataAction(T) Methods

[image] [image]

Grasshopper SDK
GH_PersistentDataAction<(Of <(<'T>)>)> Methods
GH_PersistentDataAction<(Of <(<'T>)>)> Class See Also Send Feedback

The GH_PersistentDataAction<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Protected method | Internal_Redo | (Inherited from GH_ObjectUndoAction.)
Protected method | Internal_Undo | (Inherited from GH_ObjectUndoAction.)
Protected method | Object_Redo | (Overrides GH_ObjectUndoAction..::..Object_Redo(GH_Document, IGH_DocumentObject).)
Protected method | Object_Undo | (Overrides GH_ObjectUndoAction..::..Object_Undo(GH_Document, IGH_DocumentObject).)
Public method | Read | (Inherited from GH_UndoAction.)
Public method | Redo | (Inherited from GH_UndoAction.)
Public method | Undo | (Inherited from GH_UndoAction.)
Public method | Write | (Inherited from GH_UndoAction.)

See Also

GH_PersistentDataAction<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Undo.Actions Namespace


Object_Redo Method

[image]

Grasshopper SDK
GH_PersistentDataAction<(Of <(<'T>)>)>..::..Object_Redo Method
GH_PersistentDataAction<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Object_Redo(
    GH_Document doc,
    IGH_DocumentObject obj
)
Visual Basic
Protected Overrides Sub Object_Redo ( _
    doc As GH_Document, _
    obj As IGH_DocumentObject _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document
obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject

See Also

GH_PersistentDataAction<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Undo.Actions Namespace


Object_Undo Method

[image]

Grasshopper SDK
GH_PersistentDataAction<(Of <(<'T>)>)>..::..Object_Undo Method
GH_PersistentDataAction<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Object_Undo(
    GH_Document doc,
    IGH_DocumentObject obj
)
Visual Basic
Protected Overrides Sub Object_Undo ( _
    doc As GH_Document, _
    obj As IGH_DocumentObject _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document
obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject

See Also

GH_PersistentDataAction<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_PersistentDataAction(T) Properties

[image] [image]

Grasshopper SDK
GH_PersistentDataAction<(Of <(<'T>)>)> Properties
GH_PersistentDataAction<(Of <(<'T>)>)> Class See Also Send Feedback

The GH_PersistentDataAction<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | ExpiresDisplay | Override this property if you want the Rhino viewport display to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | ExpiresSolution | (Overrides GH_UndoAction..::..ExpiresSolution.)
Public property | State | (Inherited from GH_UndoAction.)

See Also

GH_PersistentDataAction<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Undo.Actions Namespace


ExpiresSolution Property

[image]

Grasshopper SDK
GH_PersistentDataAction<(Of <(<'T>)>)>..::..ExpiresSolution Property
GH_PersistentDataAction<(Of <(<'T>)>)> Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool ExpiresSolution { get; }
Visual Basic
Public Overrides ReadOnly Property ExpiresSolution As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Undo.Actions.GH_PersistentDataAction`1.ExpiresSolution"]

See Also

GH_PersistentDataAction<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_PivotAction Class

[image]

Grasshopper SDK
GH_PivotAction Class
Members See Also Send Feedback
Records a single object pivot event. Useful for tracking object movement.

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_PivotAction : GH_ObjectUndoAction
Visual Basic
Public Class GH_PivotAction _
    Inherits GH_ObjectUndoAction

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Undo..::..GH_UndoAction
Grasshopper.Kernel.Undo..::..GH_ObjectUndoAction
Grasshopper.Kernel.Undo.Actions..::..GH_PivotAction

See Also

GH_PivotAction Members
Grasshopper.Kernel.Undo.Actions Namespace


GH_PivotAction Members

[image] [image]

Grasshopper SDK
GH_PivotAction Members
GH_PivotAction Class Constructors Methods Properties See Also Send Feedback

The GH_PivotAction type exposes the following members.

Constructors

 | Name | Description
Public method | GH_PivotAction | Initializes a new instance of the GH_PivotAction class

Methods

 | Name | Description
Protected method | Internal_Redo | (Inherited from GH_ObjectUndoAction.)
Protected method | Internal_Undo | (Inherited from GH_ObjectUndoAction.)
Protected method | Object_Redo | (Overrides GH_ObjectUndoAction..::..Object_Redo(GH_Document, IGH_DocumentObject).)
Protected method | Object_Undo | (Overrides GH_ObjectUndoAction..::..Object_Undo(GH_Document, IGH_DocumentObject).)
Public method | Read | (Inherited from GH_UndoAction.)
Public method | Redo | (Inherited from GH_UndoAction.)
Public method | Undo | (Inherited from GH_UndoAction.)
Public method | Write | (Inherited from GH_UndoAction.)

Properties

 | Name | Description
Public property | ExpiresDisplay | Override this property if you want the Rhino viewport display to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | ExpiresSolution | Override this property if you want the Grasshopper solution to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | State | (Inherited from GH_UndoAction.)

See Also

GH_PivotAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_PivotAction Constructor

[image]

Grasshopper SDK
GH_PivotAction Constructor
GH_PivotAction Class See Also Send Feedback
Initializes a new instance of the GH_PivotAction class

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_PivotAction(
    IGH_DocumentObject obj
)
Visual Basic
Public Sub New ( _
    obj As IGH_DocumentObject _
)

Parameters

obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject

See Also

GH_PivotAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_PivotAction Methods

[image] [image]

Grasshopper SDK
GH_PivotAction Methods
GH_PivotAction Class See Also Send Feedback

The GH_PivotAction type exposes the following members.

Methods

 | Name | Description
Protected method | Internal_Redo | (Inherited from GH_ObjectUndoAction.)
Protected method | Internal_Undo | (Inherited from GH_ObjectUndoAction.)
Protected method | Object_Redo | (Overrides GH_ObjectUndoAction..::..Object_Redo(GH_Document, IGH_DocumentObject).)
Protected method | Object_Undo | (Overrides GH_ObjectUndoAction..::..Object_Undo(GH_Document, IGH_DocumentObject).)
Public method | Read | (Inherited from GH_UndoAction.)
Public method | Redo | (Inherited from GH_UndoAction.)
Public method | Undo | (Inherited from GH_UndoAction.)
Public method | Write | (Inherited from GH_UndoAction.)

See Also

GH_PivotAction Class
Grasshopper.Kernel.Undo.Actions Namespace


Object_Redo Method

[image]

Grasshopper SDK
GH_PivotAction..::..Object_Redo Method
GH_PivotAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Object_Redo(
    GH_Document doc,
    IGH_DocumentObject obj
)
Visual Basic
Protected Overrides Sub Object_Redo ( _
    doc As GH_Document, _
    obj As IGH_DocumentObject _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document
obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject

See Also

GH_PivotAction Class
Grasshopper.Kernel.Undo.Actions Namespace


Object_Undo Method

[image]

Grasshopper SDK
GH_PivotAction..::..Object_Undo Method
GH_PivotAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Object_Undo(
    GH_Document doc,
    IGH_DocumentObject obj
)
Visual Basic
Protected Overrides Sub Object_Undo ( _
    doc As GH_Document, _
    obj As IGH_DocumentObject _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document
obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject

See Also

GH_PivotAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_PivotAction Properties

[image] [image]

Grasshopper SDK
GH_PivotAction Properties
GH_PivotAction Class See Also Send Feedback

The GH_PivotAction type exposes the following members.

Properties

 | Name | Description
Public property | ExpiresDisplay | Override this property if you want the Rhino viewport display to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | ExpiresSolution | Override this property if you want the Grasshopper solution to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | State | (Inherited from GH_UndoAction.)

See Also

GH_PivotAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_RemoveObjectAction Class

[image]

Grasshopper SDK
GH_RemoveObjectAction Class
Members See Also Send Feedback
Records a single object removal.

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_RemoveObjectAction : GH_ArchivedUndoAction
Visual Basic
Public Class GH_RemoveObjectAction _
    Inherits GH_ArchivedUndoAction

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Undo..::..GH_UndoAction
Grasshopper.Kernel.Undo..::..GH_ArchivedUndoAction
Grasshopper.Kernel.Undo.Actions..::..GH_RemoveObjectAction

See Also

GH_RemoveObjectAction Members
Grasshopper.Kernel.Undo.Actions Namespace


GH_RemoveObjectAction Members

[image] [image]

Grasshopper SDK
GH_RemoveObjectAction Members
GH_RemoveObjectAction Class Constructors Methods Fields Properties See Also Send Feedback

The GH_RemoveObjectAction type exposes the following members.

Constructors

 | Name | Description
Public method | GH_RemoveObjectAction | Initializes a new instance of the GH_RemoveObjectAction class

Methods

 | Name | Description
Protected method | Deserialize | Deserializes the obj from the local archive. (Inherited from GH_ArchivedUndoAction.)
Protected method | Internal_Redo | (Overrides GH_UndoAction..::..Internal_Redo(GH_Document).)
Protected method | Internal_Undo | (Overrides GH_UndoAction..::..Internal_Undo(GH_Document).)
Public method | Read | (Inherited from GH_ArchivedUndoAction.)
Public method | Redo | (Inherited from GH_UndoAction.)
Protected method | Serialize | Serializes the obj into the local archive. (Inherited from GH_ArchivedUndoAction.)
Protected method | SerializeToByteArray | Serializes the obj into the local archive. (Inherited from GH_ArchivedUndoAction.)
Public method | Undo | (Inherited from GH_UndoAction.)
Public method | Write | (Inherited from GH_ArchivedUndoAction.)

Fields

 | Name | Description
Protected field | m_data | Internal data storage for serialized archives. (Inherited from GH_ArchivedUndoAction.)

Properties

 | Name | Description
Public property | ExpiresDisplay | Override this property if you want the Rhino viewport display to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | ExpiresSolution | (Overrides GH_UndoAction..::..ExpiresSolution.)
Public property | State | (Inherited from GH_UndoAction.)

See Also

GH_RemoveObjectAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_RemoveObjectAction Constructor

[image]

Grasshopper SDK
GH_RemoveObjectAction Constructor
GH_RemoveObjectAction Class See Also Send Feedback
Initializes a new instance of the GH_RemoveObjectAction class

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_RemoveObjectAction(
    IGH_DocumentObject obj
)
Visual Basic
Public Sub New ( _
    obj As IGH_DocumentObject _
)

Parameters

obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject

See Also

GH_RemoveObjectAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_RemoveObjectAction Fields

[image] [image]

Grasshopper SDK
GH_RemoveObjectAction Fields
GH_RemoveObjectAction Class See Also Send Feedback

The GH_RemoveObjectAction type exposes the following members.

Fields

 | Name | Description
Protected field | m_data | Internal data storage for serialized archives. (Inherited from GH_ArchivedUndoAction.)

See Also

GH_RemoveObjectAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_RemoveObjectAction Methods

[image] [image]

Grasshopper SDK
GH_RemoveObjectAction Methods
GH_RemoveObjectAction Class See Also Send Feedback

The GH_RemoveObjectAction type exposes the following members.

Methods

 | Name | Description
Protected method | Deserialize | Deserializes the obj from the local archive. (Inherited from GH_ArchivedUndoAction.)
Protected method | Internal_Redo | (Overrides GH_UndoAction..::..Internal_Redo(GH_Document).)
Protected method | Internal_Undo | (Overrides GH_UndoAction..::..Internal_Undo(GH_Document).)
Public method | Read | (Inherited from GH_ArchivedUndoAction.)
Public method | Redo | (Inherited from GH_UndoAction.)
Protected method | Serialize | Serializes the obj into the local archive. (Inherited from GH_ArchivedUndoAction.)
Protected method | SerializeToByteArray | Serializes the obj into the local archive. (Inherited from GH_ArchivedUndoAction.)
Public method | Undo | (Inherited from GH_UndoAction.)
Public method | Write | (Inherited from GH_ArchivedUndoAction.)

See Also

GH_RemoveObjectAction Class
Grasshopper.Kernel.Undo.Actions Namespace


Internal_Redo Method

[image]

Grasshopper SDK
GH_RemoveObjectAction..::..Internal_Redo Method
GH_RemoveObjectAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Internal_Redo(
    GH_Document doc
)
Visual Basic
Protected Overrides Sub Internal_Redo ( _
    doc As GH_Document _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document

See Also

GH_RemoveObjectAction Class
Grasshopper.Kernel.Undo.Actions Namespace


Internal_Undo Method

[image]

Grasshopper SDK
GH_RemoveObjectAction..::..Internal_Undo Method
GH_RemoveObjectAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Internal_Undo(
    GH_Document doc
)
Visual Basic
Protected Overrides Sub Internal_Undo ( _
    doc As GH_Document _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document

See Also

GH_RemoveObjectAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_RemoveObjectAction Properties

[image] [image]

Grasshopper SDK
GH_RemoveObjectAction Properties
GH_RemoveObjectAction Class See Also Send Feedback

The GH_RemoveObjectAction type exposes the following members.

Properties

 | Name | Description
Public property | ExpiresDisplay | Override this property if you want the Rhino viewport display to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | ExpiresSolution | (Overrides GH_UndoAction..::..ExpiresSolution.)
Public property | State | (Inherited from GH_UndoAction.)

See Also

GH_RemoveObjectAction Class
Grasshopper.Kernel.Undo.Actions Namespace


ExpiresSolution Property

[image]

Grasshopper SDK
GH_RemoveObjectAction..::..ExpiresSolution Property
GH_RemoveObjectAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool ExpiresSolution { get; }
Visual Basic
Public Overrides ReadOnly Property ExpiresSolution As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Undo.Actions.GH_RemoveObjectAction.ExpiresSolution"]

See Also

GH_RemoveObjectAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_RemoveStateAction Class

[image]

Grasshopper SDK
GH_RemoveStateAction Class
Members See Also Send Feedback
Record the removal of a single solution state from a document.

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_RemoveStateAction : GH_ArchivedUndoAction
Visual Basic
Public Class GH_RemoveStateAction _
    Inherits GH_ArchivedUndoAction

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Undo..::..GH_UndoAction
Grasshopper.Kernel.Undo..::..GH_ArchivedUndoAction
Grasshopper.Kernel.Undo.Actions..::..GH_RemoveStateAction

See Also

GH_RemoveStateAction Members
Grasshopper.Kernel.Undo.Actions Namespace


GH_RemoveStateAction Members

[image] [image]

Grasshopper SDK
GH_RemoveStateAction Members
GH_RemoveStateAction Class Constructors Methods Fields Properties See Also Send Feedback

The GH_RemoveStateAction type exposes the following members.

Constructors

 | Name | Description
Public method | GH_RemoveStateAction | Initializes a new instance of the GH_RemoveStateAction class

Methods

 | Name | Description
Protected method | Deserialize | Deserializes the obj from the local archive. (Inherited from GH_ArchivedUndoAction.)
Protected method | Internal_Redo | (Overrides GH_UndoAction..::..Internal_Redo(GH_Document).)
Protected method | Internal_Undo | (Overrides GH_UndoAction..::..Internal_Undo(GH_Document).)
Public method | Read | (Overrides GH_ArchivedUndoAction..::..Read(GH_IReader).)
Public method | Redo | (Inherited from GH_UndoAction.)
Protected method | Serialize | Serializes the obj into the local archive. (Inherited from GH_ArchivedUndoAction.)
Protected method | SerializeToByteArray | Serializes the obj into the local archive. (Inherited from GH_ArchivedUndoAction.)
Public method | Undo | (Inherited from GH_UndoAction.)
Public method | Write | (Overrides GH_ArchivedUndoAction..::..Write(GH_IWriter).)

Fields

 | Name | Description
Protected field | m_data | Internal data storage for serialized archives. (Inherited from GH_ArchivedUndoAction.)

Properties

 | Name | Description
Public property | ExpiresDisplay | Override this property if you want the Rhino viewport display to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | ExpiresSolution | Override this property if you want the Grasshopper solution to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | State | (Inherited from GH_UndoAction.)

See Also

GH_RemoveStateAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_RemoveStateAction Constructor

[image]

Grasshopper SDK
GH_RemoveStateAction Constructor
GH_RemoveStateAction Class See Also Send Feedback
Initializes a new instance of the GH_RemoveStateAction class

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_RemoveStateAction(
    int index,
    GH_State state
)
Visual Basic
Public Sub New ( _
    index As Integer, _
    state As GH_State _
)

Parameters

index
Type: System..::..Int32
state
Type: Grasshopper.Kernel..::..GH_State

See Also

GH_RemoveStateAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_RemoveStateAction Fields

[image] [image]

Grasshopper SDK
GH_RemoveStateAction Fields
GH_RemoveStateAction Class See Also Send Feedback

The GH_RemoveStateAction type exposes the following members.

Fields

 | Name | Description
Protected field | m_data | Internal data storage for serialized archives. (Inherited from GH_ArchivedUndoAction.)

See Also

GH_RemoveStateAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_RemoveStateAction Methods

[image] [image]

Grasshopper SDK
GH_RemoveStateAction Methods
GH_RemoveStateAction Class See Also Send Feedback

The GH_RemoveStateAction type exposes the following members.

Methods

 | Name | Description
Protected method | Deserialize | Deserializes the obj from the local archive. (Inherited from GH_ArchivedUndoAction.)
Protected method | Internal_Redo | (Overrides GH_UndoAction..::..Internal_Redo(GH_Document).)
Protected method | Internal_Undo | (Overrides GH_UndoAction..::..Internal_Undo(GH_Document).)
Public method | Read | (Overrides GH_ArchivedUndoAction..::..Read(GH_IReader).)
Public method | Redo | (Inherited from GH_UndoAction.)
Protected method | Serialize | Serializes the obj into the local archive. (Inherited from GH_ArchivedUndoAction.)
Protected method | SerializeToByteArray | Serializes the obj into the local archive. (Inherited from GH_ArchivedUndoAction.)
Public method | Undo | (Inherited from GH_UndoAction.)
Public method | Write | (Overrides GH_ArchivedUndoAction..::..Write(GH_IWriter).)

See Also

GH_RemoveStateAction Class
Grasshopper.Kernel.Undo.Actions Namespace


Internal_Redo Method

[image]

Grasshopper SDK
GH_RemoveStateAction..::..Internal_Redo Method
GH_RemoveStateAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Internal_Redo(
    GH_Document doc
)
Visual Basic
Protected Overrides Sub Internal_Redo ( _
    doc As GH_Document _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document

See Also

GH_RemoveStateAction Class
Grasshopper.Kernel.Undo.Actions Namespace


Internal_Undo Method

[image]

Grasshopper SDK
GH_RemoveStateAction..::..Internal_Undo Method
GH_RemoveStateAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Internal_Undo(
    GH_Document doc
)
Visual Basic
Protected Overrides Sub Internal_Undo ( _
    doc As GH_Document _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document

See Also

GH_RemoveStateAction Class
Grasshopper.Kernel.Undo.Actions Namespace


Read Method

[image]

Grasshopper SDK
GH_RemoveStateAction..::..Read Method
GH_RemoveStateAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Read(
    GH_IReader reader
)
Visual Basic
Public Overrides Function Read ( _
    reader As GH_IReader _
) As Boolean

Parameters

reader
Type: GH_IO.Serialization..::..GH_IReader

See Also

GH_RemoveStateAction Class
Grasshopper.Kernel.Undo.Actions Namespace


Write Method

[image]

Grasshopper SDK
GH_RemoveStateAction..::..Write Method
GH_RemoveStateAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool Write(
    GH_IWriter writer
)
Visual Basic
Public Overrides Function Write ( _
    writer As GH_IWriter _
) As Boolean

Parameters

writer
Type: GH_IO.Serialization..::..GH_IWriter

See Also

GH_RemoveStateAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_RemoveStateAction Properties

[image] [image]

Grasshopper SDK
GH_RemoveStateAction Properties
GH_RemoveStateAction Class See Also Send Feedback

The GH_RemoveStateAction type exposes the following members.

Properties

 | Name | Description
Public property | ExpiresDisplay | Override this property if you want the Rhino viewport display to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | ExpiresSolution | Override this property if you want the Grasshopper solution to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | State | (Inherited from GH_UndoAction.)

See Also

GH_RemoveStateAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_WireAction Class

[image]

Grasshopper SDK
GH_WireAction Class
Members See Also Send Feedback
Records any change to the input wires of a given parameter.

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_WireAction : GH_UndoAction
Visual Basic
Public Class GH_WireAction _
    Inherits GH_UndoAction

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Undo..::..GH_UndoAction
Grasshopper.Kernel.Undo.Actions..::..GH_WireAction

See Also

GH_WireAction Members
Grasshopper.Kernel.Undo.Actions Namespace


GH_WireAction Members

[image] [image]

Grasshopper SDK
GH_WireAction Members
GH_WireAction Class Constructors Methods Properties See Also Send Feedback

The GH_WireAction type exposes the following members.

Constructors

 | Name | Description
Public method | GH_WireAction | Initializes a new instance of the GH_WireAction class

Methods

 | Name | Description
Protected method | Internal_Redo | (Overrides GH_UndoAction..::..Internal_Redo(GH_Document).)
Protected method | Internal_Undo | (Overrides GH_UndoAction..::..Internal_Undo(GH_Document).)
Public method | Read | (Inherited from GH_UndoAction.)
Public method | Redo | (Inherited from GH_UndoAction.)
Public method | Undo | (Inherited from GH_UndoAction.)
Public method | Write | (Inherited from GH_UndoAction.)

Properties

 | Name | Description
Public property | ExpiresDisplay | Override this property if you want the Rhino viewport display to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | ExpiresSolution | (Overrides GH_UndoAction..::..ExpiresSolution.)
Public property | State | (Inherited from GH_UndoAction.)

See Also

GH_WireAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_WireAction Constructor

[image]

Grasshopper SDK
GH_WireAction Constructor
GH_WireAction Class See Also Send Feedback
Initializes a new instance of the GH_WireAction class

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_WireAction(
    IGH_Param param
)
Visual Basic
Public Sub New ( _
    param As IGH_Param _
)

Parameters

param
Type: Grasshopper.Kernel..::..IGH_Param

See Also

GH_WireAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_WireAction Methods

[image] [image]

Grasshopper SDK
GH_WireAction Methods
GH_WireAction Class See Also Send Feedback

The GH_WireAction type exposes the following members.

Methods

 | Name | Description
Protected method | Internal_Redo | (Overrides GH_UndoAction..::..Internal_Redo(GH_Document).)
Protected method | Internal_Undo | (Overrides GH_UndoAction..::..Internal_Undo(GH_Document).)
Public method | Read | (Inherited from GH_UndoAction.)
Public method | Redo | (Inherited from GH_UndoAction.)
Public method | Undo | (Inherited from GH_UndoAction.)
Public method | Write | (Inherited from GH_UndoAction.)

See Also

GH_WireAction Class
Grasshopper.Kernel.Undo.Actions Namespace


Internal_Redo Method

[image]

Grasshopper SDK
GH_WireAction..::..Internal_Redo Method
GH_WireAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Internal_Redo(
    GH_Document doc
)
Visual Basic
Protected Overrides Sub Internal_Redo ( _
    doc As GH_Document _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document

See Also

GH_WireAction Class
Grasshopper.Kernel.Undo.Actions Namespace


Internal_Undo Method

[image]

Grasshopper SDK
GH_WireAction..::..Internal_Undo Method
GH_WireAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Internal_Undo(
    GH_Document doc
)
Visual Basic
Protected Overrides Sub Internal_Undo ( _
    doc As GH_Document _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document

See Also

GH_WireAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_WireAction Properties

[image] [image]

Grasshopper SDK
GH_WireAction Properties
GH_WireAction Class See Also Send Feedback

The GH_WireAction type exposes the following members.

Properties

 | Name | Description
Public property | ExpiresDisplay | Override this property if you want the Rhino viewport display to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | ExpiresSolution | (Overrides GH_UndoAction..::..ExpiresSolution.)
Public property | State | (Inherited from GH_UndoAction.)

See Also

GH_WireAction Class
Grasshopper.Kernel.Undo.Actions Namespace


ExpiresSolution Property

[image]

Grasshopper SDK
GH_WireAction..::..ExpiresSolution Property
GH_WireAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public override bool ExpiresSolution { get; }
Visual Basic
Public Overrides ReadOnly Property ExpiresSolution As Boolean
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Kernel.Undo.Actions.GH_WireAction.ExpiresSolution"]

See Also

GH_WireAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_WireDisplayAction Class

[image]

Grasshopper SDK
GH_WireDisplayAction Class
Members See Also Send Feedback
Records a single wire display mode event.

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_WireDisplayAction : GH_ObjectUndoAction
Visual Basic
Public Class GH_WireDisplayAction _
    Inherits GH_ObjectUndoAction

Inheritance Hierarchy

System..::..Object
Grasshopper.Kernel.Undo..::..GH_UndoAction
Grasshopper.Kernel.Undo..::..GH_ObjectUndoAction
Grasshopper.Kernel.Undo.Actions..::..GH_WireDisplayAction

See Also

GH_WireDisplayAction Members
Grasshopper.Kernel.Undo.Actions Namespace


GH_WireDisplayAction Members

[image] [image]

Grasshopper SDK
GH_WireDisplayAction Members
GH_WireDisplayAction Class Constructors Methods Properties See Also Send Feedback

The GH_WireDisplayAction type exposes the following members.

Constructors

 | Name | Description
Public method | GH_WireDisplayAction | Initializes a new instance of the GH_WireDisplayAction class

Methods

 | Name | Description
Protected method | Internal_Redo | (Inherited from GH_ObjectUndoAction.)
Protected method | Internal_Undo | (Inherited from GH_ObjectUndoAction.)
Protected method | Object_Redo | (Overrides GH_ObjectUndoAction..::..Object_Redo(GH_Document, IGH_DocumentObject).)
Protected method | Object_Undo | (Overrides GH_ObjectUndoAction..::..Object_Undo(GH_Document, IGH_DocumentObject).)
Public method | Read | (Inherited from GH_UndoAction.)
Public method | Redo | (Inherited from GH_UndoAction.)
Public method | Undo | (Inherited from GH_UndoAction.)
Public method | Write | (Inherited from GH_UndoAction.)

Properties

 | Name | Description
Public property | ExpiresDisplay | Override this property if you want the Rhino viewport display to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | ExpiresSolution | Override this property if you want the Grasshopper solution to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | State | (Inherited from GH_UndoAction.)

See Also

GH_WireDisplayAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_WireDisplayAction Constructor

[image]

Grasshopper SDK
GH_WireDisplayAction Constructor
GH_WireDisplayAction Class See Also Send Feedback
Initializes a new instance of the GH_WireDisplayAction class

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_WireDisplayAction(
    IGH_Param obj
)
Visual Basic
Public Sub New ( _
    obj As IGH_Param _
)

Parameters

obj
Type: Grasshopper.Kernel..::..IGH_Param

See Also

GH_WireDisplayAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_WireDisplayAction Methods

[image] [image]

Grasshopper SDK
GH_WireDisplayAction Methods
GH_WireDisplayAction Class See Also Send Feedback

The GH_WireDisplayAction type exposes the following members.

Methods

 | Name | Description
Protected method | Internal_Redo | (Inherited from GH_ObjectUndoAction.)
Protected method | Internal_Undo | (Inherited from GH_ObjectUndoAction.)
Protected method | Object_Redo | (Overrides GH_ObjectUndoAction..::..Object_Redo(GH_Document, IGH_DocumentObject).)
Protected method | Object_Undo | (Overrides GH_ObjectUndoAction..::..Object_Undo(GH_Document, IGH_DocumentObject).)
Public method | Read | (Inherited from GH_UndoAction.)
Public method | Redo | (Inherited from GH_UndoAction.)
Public method | Undo | (Inherited from GH_UndoAction.)
Public method | Write | (Inherited from GH_UndoAction.)

See Also

GH_WireDisplayAction Class
Grasshopper.Kernel.Undo.Actions Namespace


Object_Redo Method

[image]

Grasshopper SDK
GH_WireDisplayAction..::..Object_Redo Method
GH_WireDisplayAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Object_Redo(
    GH_Document doc,
    IGH_DocumentObject obj
)
Visual Basic
Protected Overrides Sub Object_Redo ( _
    doc As GH_Document, _
    obj As IGH_DocumentObject _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document
obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject

See Also

GH_WireDisplayAction Class
Grasshopper.Kernel.Undo.Actions Namespace


Object_Undo Method

[image]

Grasshopper SDK
GH_WireDisplayAction..::..Object_Undo Method
GH_WireDisplayAction Class See Also Send Feedback

Namespace: Grasshopper.Kernel.Undo.Actions
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Object_Undo(
    GH_Document doc,
    IGH_DocumentObject obj
)
Visual Basic
Protected Overrides Sub Object_Undo ( _
    doc As GH_Document, _
    obj As IGH_DocumentObject _
)

Parameters

doc
Type: Grasshopper.Kernel..::..GH_Document
obj
Type: Grasshopper.Kernel..::..IGH_DocumentObject

See Also

GH_WireDisplayAction Class
Grasshopper.Kernel.Undo.Actions Namespace


GH_WireDisplayAction Properties

[image] [image]

Grasshopper SDK
GH_WireDisplayAction Properties
GH_WireDisplayAction Class See Also Send Feedback

The GH_WireDisplayAction type exposes the following members.

Properties

 | Name | Description
Public property | ExpiresDisplay | Override this property if you want the Rhino viewport display to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | ExpiresSolution | Override this property if you want the Grasshopper solution to refresh upon undo completion. (Inherited from GH_UndoAction.)
Public property | State | (Inherited from GH_UndoAction.)

See Also

GH_WireDisplayAction Class
Grasshopper.Kernel.Undo.Actions Namespace


Grasshopper.Plugin Namespace

[image]

Grasshopper SDK
Grasshopper.Plugin Namespace
Send Feedback
This namespace contains all the classes that participate in the Rhino Plugin dance. You are unlikely to need any of this.

Classes

 | Class | Description
Public class | GH_PluginUtil | Grasshopper plugin utility class. This class exports some static (Shared in VB) methods to do with plugin loading and unloading.
Public class | GH_ResourceGate | This class provides access to specific resources of the Grasshopper assembly.
Public class | GH_RhinoScriptInterface | Plugin Interface object that is exposed via the RhinoScript layer.


GH_PluginUtil Class

[image]

Grasshopper SDK
GH_PluginUtil Class
Members See Also Send Feedback
Grasshopper plugin utility class. This class exports some static (Shared in VB) methods to do with plugin loading and unloading.

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class GH_PluginUtil
Visual Basic
Public NotInheritable Class GH_PluginUtil

Inheritance Hierarchy

System..::..Object
Grasshopper.Plugin..::..GH_PluginUtil

See Also

GH_PluginUtil Members
Grasshopper.Plugin Namespace


GH_PluginUtil Members

[image] [image]

Grasshopper SDK
GH_PluginUtil Members
GH_PluginUtil Class Methods See Also Send Feedback

The GH_PluginUtil type exposes the following members.

Methods

Name | Description
BringRhinoToTop | Bring the Rhino window to the top of the stack.
BringWindowToTop |
FocusOnRhino | Set the focus to the Rhino command line.
SendKeyCodeToRhino(Char) | Send a key-code to the Rhino command line.
SendKeyCodeToRhino(Int32) | Send a key-code to the Rhino command line.
SendKeyCodeToRhino(String) | Send a string of characters to the Rhino command line.
SendMessage |
SetFocus |

See Also

GH_PluginUtil Class
Grasshopper.Plugin Namespace


GH_PluginUtil Methods

[image] [image]

Grasshopper SDK
GH_PluginUtil Methods
GH_PluginUtil Class See Also Send Feedback

The GH_PluginUtil type exposes the following members.

Methods

Name | Description
BringRhinoToTop | Bring the Rhino window to the top of the stack.
BringWindowToTop |
FocusOnRhino | Set the focus to the Rhino command line.
SendKeyCodeToRhino(Char) | Send a key-code to the Rhino command line.
SendKeyCodeToRhino(Int32) | Send a key-code to the Rhino command line.
SendKeyCodeToRhino(String) | Send a string of characters to the Rhino command line.
SendMessage |
SetFocus |

See Also

GH_PluginUtil Class
Grasshopper.Plugin Namespace


BringRhinoToTop Method

[image]

Grasshopper SDK
GH_PluginUtil..::..BringRhinoToTop Method
GH_PluginUtil Class See Also Send Feedback
Bring the Rhino window to the top of the stack.

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void BringRhinoToTop()
Visual Basic
Public Shared Sub BringRhinoToTop

See Also

GH_PluginUtil Class
Grasshopper.Plugin Namespace


BringWindowToTop Method

[image]

Grasshopper SDK
GH_PluginUtil..::..BringWindowToTop Method
GH_PluginUtil Class See Also Send Feedback

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static bool BringWindowToTop(
    IntPtr hWnd
)
Visual Basic
Public Shared Function BringWindowToTop ( _
    hWnd As IntPtr _
) As Boolean

Parameters

hWnd
Type: System..::..IntPtr

See Also

GH_PluginUtil Class
Grasshopper.Plugin Namespace


FocusOnRhino Method

[image]

Grasshopper SDK
GH_PluginUtil..::..FocusOnRhino Method
GH_PluginUtil Class See Also Send Feedback
Set the focus to the Rhino command line.

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void FocusOnRhino()
Visual Basic
Public Shared Sub FocusOnRhino

See Also

GH_PluginUtil Class
Grasshopper.Plugin Namespace


SendKeyCodeToRhino Method

[image] [image]

Grasshopper SDK
GH_PluginUtil..::..SendKeyCodeToRhino Method
GH_PluginUtil Class See Also Send Feedback

Overload List

Name | Description
SendKeyCodeToRhino(Char) | Send a key-code to the Rhino command line.
SendKeyCodeToRhino(Int32) | Send a key-code to the Rhino command line.
SendKeyCodeToRhino(String) | Send a string of characters to the Rhino command line.

See Also

GH_PluginUtil Class
GH_PluginUtil Members
Grasshopper.Plugin Namespace


SendKeyCodeToRhino Method (Char)

[image]

Grasshopper SDK
GH_PluginUtil..::..SendKeyCodeToRhino Method (Char)
GH_PluginUtil Class See Also Send Feedback
Send a key-code to the Rhino command line.

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void SendKeyCodeToRhino(
    char key
)
Visual Basic
Public Shared Sub SendKeyCodeToRhino ( _
    key As Char _
)

Parameters

key
Type: System..::..Char
Key char.

See Also

GH_PluginUtil Class
SendKeyCodeToRhino Overload
Grasshopper.Plugin Namespace


SendKeyCodeToRhino Method (Int32)

[image]

Grasshopper SDK
GH_PluginUtil..::..SendKeyCodeToRhino Method (Int32)
GH_PluginUtil Class See Also Send Feedback
Send a key-code to the Rhino command line.

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void SendKeyCodeToRhino(
    int key
)
Visual Basic
Public Shared Sub SendKeyCodeToRhino ( _
    key As Integer _
)

Parameters

key
Type: System..::..Int32
Key code.

See Also

GH_PluginUtil Class
SendKeyCodeToRhino Overload
Grasshopper.Plugin Namespace


SendKeyCodeToRhino Method (String)

[image]

Grasshopper SDK
GH_PluginUtil..::..SendKeyCodeToRhino Method (String)
GH_PluginUtil Class See Also Send Feedback
Send a string of characters to the Rhino command line.

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void SendKeyCodeToRhino(
    string key
)
Visual Basic
Public Shared Sub SendKeyCodeToRhino ( _
    key As String _
)

Parameters

key
Type: System..::..String
String

See Also

GH_PluginUtil Class
SendKeyCodeToRhino Overload
Grasshopper.Plugin Namespace


SendMessage Method

[image]

Grasshopper SDK
GH_PluginUtil..::..SendMessage Method
GH_PluginUtil Class See Also Send Feedback

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static IntPtr SendMessage(
    IntPtr hWnd,
    int msg,
    int wParam,
    IntPtr lParam
)
Visual Basic
Public Shared Function SendMessage ( _
    hWnd As IntPtr, _
    msg As Integer, _
    wParam As Integer, _
    lParam As IntPtr _
) As IntPtr

Parameters

hWnd
Type: System..::..IntPtr
msg
Type: System..::..Int32
wParam
Type: System..::..Int32
lParam
Type: System..::..IntPtr

See Also

GH_PluginUtil Class
Grasshopper.Plugin Namespace


SetFocus Method

[image]

Grasshopper SDK
GH_PluginUtil..::..SetFocus Method
GH_PluginUtil Class See Also Send Feedback

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static void SetFocus(
    IntPtr hWnd
)
Visual Basic
Public Shared Sub SetFocus ( _
    hWnd As IntPtr _
)

Parameters

hWnd
Type: System..::..IntPtr

See Also

GH_PluginUtil Class
Grasshopper.Plugin Namespace


GH_ResourceGate Class

[image]

Grasshopper SDK
GH_ResourceGate Class
Members See Also Send Feedback
This class provides access to specific resources of the Grasshopper assembly.

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public sealed class GH_ResourceGate
Visual Basic
Public NotInheritable Class GH_ResourceGate

Inheritance Hierarchy

System..::..Object
Grasshopper.Plugin..::..GH_ResourceGate

See Also

GH_ResourceGate Members
Grasshopper.Plugin Namespace


GH_ResourceGate Members

[image] [image]

Grasshopper SDK
GH_ResourceGate Members
GH_ResourceGate Class Properties See Also Send Feedback

The GH_ResourceGate type exposes the following members.

Properties

Name | Description
BlackIcon | Returns a 24x24 hexagonal black icon.
Error_12x12 | Returns a 12x12 round red icon
Error_16x16 | Returns a 16x16 round red icon
Error_24x24 | Returns a 24x24 round red icon
Error_40x40 | Returns a 40x40 round red icon
Info_12x12 | Returns a 12x12 round blue icon
Info_16x16 | Returns a 16x16 round blue icon
Info_24x24 | Returns a 24x24 round blue icon
Info_40x40 | Returns a 40x40 round blue icon
OK_12x12 | Returns a 12x12 round green icon
OK_16x16 | Returns a 16x16 round green icon
OK_24x24 | Returns a 24x24 round green icon
OK_40x40 | Returns a 40x40 round green icon
Warning_12x12 | Returns a 12x12 round yellow icon
Warning_16x16 | Returns a 16x16 round yellow icon
Warning_24x24 | Returns a 24x24 round yellow icon
Warning_40x40 | Returns a 40x40 round yellow icon
WhiteIcon | Returns a 24x24 square white icon.

See Also

GH_ResourceGate Class
Grasshopper.Plugin Namespace


GH_ResourceGate Properties

[image] [image]

Grasshopper SDK
GH_ResourceGate Properties
GH_ResourceGate Class See Also Send Feedback

The GH_ResourceGate type exposes the following members.

Properties

Name | Description
BlackIcon | Returns a 24x24 hexagonal black icon.
Error_12x12 | Returns a 12x12 round red icon
Error_16x16 | Returns a 16x16 round red icon
Error_24x24 | Returns a 24x24 round red icon
Error_40x40 | Returns a 40x40 round red icon
Info_12x12 | Returns a 12x12 round blue icon
Info_16x16 | Returns a 16x16 round blue icon
Info_24x24 | Returns a 24x24 round blue icon
Info_40x40 | Returns a 40x40 round blue icon
OK_12x12 | Returns a 12x12 round green icon
OK_16x16 | Returns a 16x16 round green icon
OK_24x24 | Returns a 24x24 round green icon
OK_40x40 | Returns a 40x40 round green icon
Warning_12x12 | Returns a 12x12 round yellow icon
Warning_16x16 | Returns a 16x16 round yellow icon
Warning_24x24 | Returns a 24x24 round yellow icon
Warning_40x40 | Returns a 40x40 round yellow icon
WhiteIcon | Returns a 24x24 square white icon.

See Also

GH_ResourceGate Class
Grasshopper.Plugin Namespace


BlackIcon Property

[image]

Grasshopper SDK
GH_ResourceGate..::..BlackIcon Property
GH_ResourceGate Class See Also Send Feedback
Returns a 24x24 hexagonal black icon.

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Bitmap BlackIcon { get; }
Visual Basic
Public Shared ReadOnly Property BlackIcon As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Plugin.GH_ResourceGate.BlackIcon"]

See Also

GH_ResourceGate Class
Grasshopper.Plugin Namespace


Error_12x12 Property

[image]

Grasshopper SDK
GH_ResourceGate..::..Error_12x12 Property
GH_ResourceGate Class See Also Send Feedback
Returns a 12x12 round red icon

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Bitmap Error_12x12 { get; }
Visual Basic
Public Shared ReadOnly Property Error_12x12 As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Plugin.GH_ResourceGate.Error_12x12"]

See Also

GH_ResourceGate Class
Grasshopper.Plugin Namespace


Error_16x16 Property

[image]

Grasshopper SDK
GH_ResourceGate..::..Error_16x16 Property
GH_ResourceGate Class See Also Send Feedback
Returns a 16x16 round red icon

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Bitmap Error_16x16 { get; }
Visual Basic
Public Shared ReadOnly Property Error_16x16 As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Plugin.GH_ResourceGate.Error_16x16"]

See Also

GH_ResourceGate Class
Grasshopper.Plugin Namespace


Error_24x24 Property

[image]

Grasshopper SDK
GH_ResourceGate..::..Error_24x24 Property
GH_ResourceGate Class See Also Send Feedback
Returns a 24x24 round red icon

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Bitmap Error_24x24 { get; }
Visual Basic
Public Shared ReadOnly Property Error_24x24 As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Plugin.GH_ResourceGate.Error_24x24"]

See Also

GH_ResourceGate Class
Grasshopper.Plugin Namespace


Error_40x40 Property

[image]

Grasshopper SDK
GH_ResourceGate..::..Error_40x40 Property
GH_ResourceGate Class See Also Send Feedback
Returns a 40x40 round red icon

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Bitmap Error_40x40 { get; }
Visual Basic
Public Shared ReadOnly Property Error_40x40 As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Plugin.GH_ResourceGate.Error_40x40"]

See Also

GH_ResourceGate Class
Grasshopper.Plugin Namespace


Info_12x12 Property

[image]

Grasshopper SDK
GH_ResourceGate..::..Info_12x12 Property
GH_ResourceGate Class See Also Send Feedback
Returns a 12x12 round blue icon

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Bitmap Info_12x12 { get; }
Visual Basic
Public Shared ReadOnly Property Info_12x12 As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Plugin.GH_ResourceGate.Info_12x12"]

See Also

GH_ResourceGate Class
Grasshopper.Plugin Namespace


Info_16x16 Property

[image]

Grasshopper SDK
GH_ResourceGate..::..Info_16x16 Property
GH_ResourceGate Class See Also Send Feedback
Returns a 16x16 round blue icon

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Bitmap Info_16x16 { get; }
Visual Basic
Public Shared ReadOnly Property Info_16x16 As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Plugin.GH_ResourceGate.Info_16x16"]

See Also

GH_ResourceGate Class
Grasshopper.Plugin Namespace


Info_24x24 Property

[image]

Grasshopper SDK
GH_ResourceGate..::..Info_24x24 Property
GH_ResourceGate Class See Also Send Feedback
Returns a 24x24 round blue icon

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Bitmap Info_24x24 { get; }
Visual Basic
Public Shared ReadOnly Property Info_24x24 As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Plugin.GH_ResourceGate.Info_24x24"]

See Also

GH_ResourceGate Class
Grasshopper.Plugin Namespace


Info_40x40 Property

[image]

Grasshopper SDK
GH_ResourceGate..::..Info_40x40 Property
GH_ResourceGate Class See Also Send Feedback
Returns a 40x40 round blue icon

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Bitmap Info_40x40 { get; }
Visual Basic
Public Shared ReadOnly Property Info_40x40 As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Plugin.GH_ResourceGate.Info_40x40"]

See Also

GH_ResourceGate Class
Grasshopper.Plugin Namespace


OK_12x12 Property

[image]

Grasshopper SDK
GH_ResourceGate..::..OK_12x12 Property
GH_ResourceGate Class See Also Send Feedback
Returns a 12x12 round green icon

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Bitmap OK_12x12 { get; }
Visual Basic
Public Shared ReadOnly Property OK_12x12 As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Plugin.GH_ResourceGate.OK_12x12"]

See Also

GH_ResourceGate Class
Grasshopper.Plugin Namespace


OK_16x16 Property

[image]

Grasshopper SDK
GH_ResourceGate..::..OK_16x16 Property
GH_ResourceGate Class See Also Send Feedback
Returns a 16x16 round green icon

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Bitmap OK_16x16 { get; }
Visual Basic
Public Shared ReadOnly Property OK_16x16 As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Plugin.GH_ResourceGate.OK_16x16"]

See Also

GH_ResourceGate Class
Grasshopper.Plugin Namespace


OK_24x24 Property

[image]

Grasshopper SDK
GH_ResourceGate..::..OK_24x24 Property
GH_ResourceGate Class See Also Send Feedback
Returns a 24x24 round green icon

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Bitmap OK_24x24 { get; }
Visual Basic
Public Shared ReadOnly Property OK_24x24 As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Plugin.GH_ResourceGate.OK_24x24"]

See Also

GH_ResourceGate Class
Grasshopper.Plugin Namespace


OK_40x40 Property

[image]

Grasshopper SDK
GH_ResourceGate..::..OK_40x40 Property
GH_ResourceGate Class See Also Send Feedback
Returns a 40x40 round green icon

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Bitmap OK_40x40 { get; }
Visual Basic
Public Shared ReadOnly Property OK_40x40 As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Plugin.GH_ResourceGate.OK_40x40"]

See Also

GH_ResourceGate Class
Grasshopper.Plugin Namespace


Warning_12x12 Property

[image]

Grasshopper SDK
GH_ResourceGate..::..Warning_12x12 Property
GH_ResourceGate Class See Also Send Feedback
Returns a 12x12 round yellow icon

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Bitmap Warning_12x12 { get; }
Visual Basic
Public Shared ReadOnly Property Warning_12x12 As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Plugin.GH_ResourceGate.Warning_12x12"]

See Also

GH_ResourceGate Class
Grasshopper.Plugin Namespace


Warning_16x16 Property

[image]

Grasshopper SDK
GH_ResourceGate..::..Warning_16x16 Property
GH_ResourceGate Class See Also Send Feedback
Returns a 16x16 round yellow icon

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Bitmap Warning_16x16 { get; }
Visual Basic
Public Shared ReadOnly Property Warning_16x16 As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Plugin.GH_ResourceGate.Warning_16x16"]

See Also

GH_ResourceGate Class
Grasshopper.Plugin Namespace


Warning_24x24 Property

[image]

Grasshopper SDK
GH_ResourceGate..::..Warning_24x24 Property
GH_ResourceGate Class See Also Send Feedback
Returns a 24x24 round yellow icon

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Bitmap Warning_24x24 { get; }
Visual Basic
Public Shared ReadOnly Property Warning_24x24 As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Plugin.GH_ResourceGate.Warning_24x24"]

See Also

GH_ResourceGate Class
Grasshopper.Plugin Namespace


Warning_40x40 Property

[image]

Grasshopper SDK
GH_ResourceGate..::..Warning_40x40 Property
GH_ResourceGate Class See Also Send Feedback
Returns a 40x40 round yellow icon

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Bitmap Warning_40x40 { get; }
Visual Basic
Public Shared ReadOnly Property Warning_40x40 As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Plugin.GH_ResourceGate.Warning_40x40"]

See Also

GH_ResourceGate Class
Grasshopper.Plugin Namespace


WhiteIcon Property

[image]

Grasshopper SDK
GH_ResourceGate..::..WhiteIcon Property
GH_ResourceGate Class See Also Send Feedback
Returns a 24x24 square white icon.

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public static Bitmap WhiteIcon { get; }
Visual Basic
Public Shared ReadOnly Property WhiteIcon As Bitmap
    Get

Field Value

[Missing <value> documentation for "P:Grasshopper.Plugin.GH_ResourceGate.WhiteIcon"]

See Also

GH_ResourceGate Class
Grasshopper.Plugin Namespace


GH_RhinoScriptInterface Class

[image]

Grasshopper SDK
GH_RhinoScriptInterface Class
Members See Also Send Feedback
Plugin Interface object that is exposed via the RhinoScript layer.

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public class GH_RhinoScriptInterface
Visual Basic
Public Class GH_RhinoScriptInterface

Inheritance Hierarchy

System..::..Object
Grasshopper.Plugin..::..GH_RhinoScriptInterface

See Also

GH_RhinoScriptInterface Members
Grasshopper.Plugin Namespace


GH_RhinoScriptInterface Members

[image] [image]

Grasshopper SDK
GH_RhinoScriptInterface Members
GH_RhinoScriptInterface Class Constructors Methods See Also Send Feedback

The GH_RhinoScriptInterface type exposes the following members.

Constructors

 | Name | Description
Public method | GH_RhinoScriptInterface | Initializes a new instance of the GH_RhinoScriptInterface class

Methods

 | Name | Description
Public method | AssignDataToParameter | Find a parameter and assign some persistent data.
Public method | BakeDataInObject | Find an object and bake all geometry inside of it.
Public method | CloseAllDocuments | Close all Grasshopper documents.
Public method | CloseDocument | Close the currently active Grasshopper document. If there is not active document, nothing will happen.
Public method | DisableBanner | Disables the display of the Grasshopper banner during Component loading. The banner is typically only shown once during a Grasshopper session, namely when the Editor is first loaded.
Public method | DisableSolver | Disables the Grasshopper Solver. If the Solver is disabled, expired components and parameter will not be recomputed, though any existing solution will remain intact.
Public method | EnableBanner | Enables the display of the Grasshopper banner during Component loading. The banner is typically only shown once during a Grasshopper session, namely when the Editor is first loaded.
Public method | EnableSolver | Enables the Grasshopper Solver. If the Solver is enabled, expired components and parameter will be recomputed.
Public method | HideEditor | Hide the main Grasshopper Editor. If the editor hasn't been loaded or if the Editor is already hidden, nothing will happen.
Public method | IsEditorLoaded | Returns the loaded state of the Grasshopper Main window.
Public method | IsEditorVisible | Returns the visible state of the Grasshopper Main window.
Public method | IsSolverEnabled | Returns the state of the Grasshopper Solver.
Public method | LoadEditor | Load the main Grasshopper Editor. If the editor has already been loaded nothing will happen.
Public method | OpenDocument | Open a Grasshopper document. The editor will be loaded if necessary, but it will not be automatically shown.
Public method | RunSolver | Runs the solver once, even if the global solver lock is on.
Public method | SaveDocument | Save the currently active Grasshopper document. If the active document has never been saved, a Save... dialog will be shown. If there is no active document, nothing will happen.
Public method | SaveDocumentAs | Save the currently active Grasshopper document in a specific location. If there is no active document, nothing will happen.
Public method | ShowEditor | Show the main Grasshopper Editor. The editor will be loaded first if needed. If the Editor is already on screen, nothing will happen.

See Also

GH_RhinoScriptInterface Class
Grasshopper.Plugin Namespace


GH_RhinoScriptInterface Constructor

[image]

Grasshopper SDK
GH_RhinoScriptInterface Constructor
GH_RhinoScriptInterface Class See Also Send Feedback
Initializes a new instance of the GH_RhinoScriptInterface class

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public GH_RhinoScriptInterface()
Visual Basic
Public Sub New

See Also

GH_RhinoScriptInterface Class
Grasshopper.Plugin Namespace


GH_RhinoScriptInterface Methods

[image] [image]

Grasshopper SDK
GH_RhinoScriptInterface Methods
GH_RhinoScriptInterface Class See Also Send Feedback

The GH_RhinoScriptInterface type exposes the following members.

Methods

 | Name | Description
Public method | AssignDataToParameter | Find a parameter and assign some persistent data.
Public method | BakeDataInObject | Find an object and bake all geometry inside of it.
Public method | CloseAllDocuments | Close all Grasshopper documents.
Public method | CloseDocument | Close the currently active Grasshopper document. If there is not active document, nothing will happen.
Public method | DisableBanner | Disables the display of the Grasshopper banner during Component loading. The banner is typically only shown once during a Grasshopper session, namely when the Editor is first loaded.
Public method | DisableSolver | Disables the Grasshopper Solver. If the Solver is disabled, expired components and parameter will not be recomputed, though any existing solution will remain intact.
Public method | EnableBanner | Enables the display of the Grasshopper banner during Component loading. The banner is typically only shown once during a Grasshopper session, namely when the Editor is first loaded.
Public method | EnableSolver | Enables the Grasshopper Solver. If the Solver is enabled, expired components and parameter will be recomputed.
Public method | HideEditor | Hide the main Grasshopper Editor. If the editor hasn't been loaded or if the Editor is already hidden, nothing will happen.
Public method | IsEditorLoaded | Returns the loaded state of the Grasshopper Main window.
Public method | IsEditorVisible | Returns the visible state of the Grasshopper Main window.
Public method | IsSolverEnabled | Returns the state of the Grasshopper Solver.
Public method | LoadEditor | Load the main Grasshopper Editor. If the editor has already been loaded nothing will happen.
Public method | OpenDocument | Open a Grasshopper document. The editor will be loaded if necessary, but it will not be automatically shown.
Public method | RunSolver | Runs the solver once, even if the global solver lock is on.
Public method | SaveDocument | Save the currently active Grasshopper document. If the active document has never been saved, a Save... dialog will be shown. If there is no active document, nothing will happen.
Public method | SaveDocumentAs | Save the currently active Grasshopper document in a specific location. If there is no active document, nothing will happen.
Public method | ShowEditor | Show the main Grasshopper Editor. The editor will be loaded first if needed. If the Editor is already on screen, nothing will happen.

See Also

GH_RhinoScriptInterface Class
Grasshopper.Plugin Namespace


AssignDataToParameter Method

[image]

Grasshopper SDK
GH_RhinoScriptInterface..::..AssignDataToParameter Method
GH_RhinoScriptInterface Class See Also Send Feedback
Find a parameter and assign some persistent data.

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool AssignDataToParameter(
    string parameterID,
    Object data
)
Visual Basic
Public Function AssignDataToParameter ( _
    parameterID As String, _
    data As Object _
) As Boolean

Parameters

parameterID
Type: System..::..String
Instance ID of parameter or parameter name.
data
Type: System..::..Object
Data to assign.

Return Value

True on success, false on failure.

See Also

GH_RhinoScriptInterface Class
Grasshopper.Plugin Namespace


BakeDataInObject Method

[image]

Grasshopper SDK
GH_RhinoScriptInterface..::..BakeDataInObject Method
GH_RhinoScriptInterface Class See Also Send Feedback
Find an object and bake all geometry inside of it.

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public Object BakeDataInObject(
    string objectID
)
Visual Basic
Public Function BakeDataInObject ( _
    objectID As String _
) As Object

Parameters

objectID
Type: System..::..String
Object InstanceID or name.

Return Value

An array of Rhino object IDs, or null on failure.

See Also

GH_RhinoScriptInterface Class
Grasshopper.Plugin Namespace


CloseAllDocuments Method

[image]

Grasshopper SDK
GH_RhinoScriptInterface..::..CloseAllDocuments Method
GH_RhinoScriptInterface Class Example See Also Send Feedback
Close all Grasshopper documents.

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool CloseAllDocuments()
Visual Basic
Public Function CloseAllDocuments As Boolean

Return Value

True on success, false on failure.

Examples

CopyVBScript
Call GrasshopperExampleScript()
Sub GrasshopperExampleScript()
  Dim GH
  Set GH = Rhino.GetPlugInObject("Grasshopper")
  Call GH.CloseAllDocuments()
  Set GH = Nothing
End Sub

See Also

GH_RhinoScriptInterface Class
Grasshopper.Plugin Namespace


CloseDocument Method

[image]

Grasshopper SDK
GH_RhinoScriptInterface..::..CloseDocument Method
GH_RhinoScriptInterface Class Example See Also Send Feedback
Close the currently active Grasshopper document. If there is not active document, nothing will happen.

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool CloseDocument()
Visual Basic
Public Function CloseDocument As Boolean

Return Value

True on success, false on failure.

Examples

CopyVBScript
Call GrasshopperExampleScript()
Sub GrasshopperExampleScript()
  Dim GH
  Set GH = Rhino.GetPlugInObject("Grasshopper")
  Call GH.CloseDocument()
  Set GH = Nothing
End Sub

See Also

GH_RhinoScriptInterface Class
Grasshopper.Plugin Namespace


DisableBanner Method

[image]

Grasshopper SDK
GH_RhinoScriptInterface..::..DisableBanner Method
GH_RhinoScriptInterface Class Example See Also Send Feedback
Disables the display of the Grasshopper banner during Component loading. The banner is typically only shown once during a Grasshopper session, namely when the Editor is first loaded.

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DisableBanner()
Visual Basic
Public Sub DisableBanner

Examples

CopyVBScript
Call GrasshopperExampleScript()
Sub GrasshopperExampleScript()
  Dim GH
  Set GH = Rhino.GetPlugInObject("Grasshopper")
  Call GH.DisableBanner()
  Call GH.ShowEditor()
  Set GH = Nothing
End Sub

See Also

GH_RhinoScriptInterface Class
Grasshopper.Plugin Namespace


DisableSolver Method

[image]

Grasshopper SDK
GH_RhinoScriptInterface..::..DisableSolver Method
GH_RhinoScriptInterface Class Example See Also Send Feedback
Disables the Grasshopper Solver. If the Solver is disabled, expired components and parameter will not be recomputed, though any existing solution will remain intact.

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void DisableSolver()
Visual Basic
Public Sub DisableSolver

Examples

CopyVBScript
Call GrasshopperExampleScript()
Sub GrasshopperExampleScript()
  Dim GH
  Set GH = Rhino.GetPlugInObject("Grasshopper")
  Call GH.DisableSolver()
  Set GH = Nothing
End Sub

See Also

GH_RhinoScriptInterface Class
Grasshopper.Plugin Namespace


EnableBanner Method

[image]

Grasshopper SDK
GH_RhinoScriptInterface..::..EnableBanner Method
GH_RhinoScriptInterface Class Example See Also Send Feedback
Enables the display of the Grasshopper banner during Component loading. The banner is typically only shown once during a Grasshopper session, namely when the Editor is first loaded.

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void EnableBanner()
Visual Basic
Public Sub EnableBanner

Examples

CopyVBScript
Call GrasshopperExampleScript()
Sub GrasshopperExampleScript()
  Dim GH
  Set GH = Rhino.GetPlugInObject("Grasshopper")
  Call GH.EnableBanner()
  Call GH.ShowEditor()
  Set GH = Nothing
End Sub

See Also

GH_RhinoScriptInterface Class
Grasshopper.Plugin Namespace


EnableSolver Method

[image]

Grasshopper SDK
GH_RhinoScriptInterface..::..EnableSolver Method
GH_RhinoScriptInterface Class Example See Also Send Feedback
Enables the Grasshopper Solver. If the Solver is enabled, expired components and parameter will be recomputed.

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void EnableSolver()
Visual Basic
Public Sub EnableSolver

Examples

CopyVBScript
Call GrasshopperExampleScript()
Sub GrasshopperExampleScript()
  Dim GH
  Set GH = Rhino.GetPlugInObject("Grasshopper")
  Call GH.EnableSolver()
  Set GH = Nothing
End Sub

See Also

GH_RhinoScriptInterface Class
Grasshopper.Plugin Namespace


HideEditor Method

[image]

Grasshopper SDK
GH_RhinoScriptInterface..::..HideEditor Method
GH_RhinoScriptInterface Class Example See Also Send Feedback
Hide the main Grasshopper Editor. If the editor hasn't been loaded or if the Editor is already hidden, nothing will happen.

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void HideEditor()
Visual Basic
Public Sub HideEditor

Examples

CopyVBScript
Call GrasshopperExampleScript()
Sub GrasshopperExampleScript()
  Dim GH
  Set GH = Rhino.GetPlugInObject("Grasshopper")
  Call GH.HideEditor()
  Set GH = Nothing
End Sub

See Also

GH_RhinoScriptInterface Class
Grasshopper.Plugin Namespace


IsEditorLoaded Method

[image]

Grasshopper SDK
GH_RhinoScriptInterface..::..IsEditorLoaded Method
GH_RhinoScriptInterface Class Example See Also Send Feedback
Returns the loaded state of the Grasshopper Main window.

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsEditorLoaded()
Visual Basic
Public Function IsEditorLoaded As Boolean

Return Value

True if the Main Grasshopper Window has been loaded.

Examples

CopyVBScript
Call GrasshopperExampleScript()
Sub GrasshopperExampleScript()
  Dim GH
  Set GH = Rhino.GetPlugInObject("Grasshopper")
  Call Rhino.Print("Grasshopper Editor Loaded: " & GH.IsEditorLoaded())
  Set GH = Nothing
End Sub

See Also

GH_RhinoScriptInterface Class
Grasshopper.Plugin Namespace


IsEditorVisible Method

[image]

Grasshopper SDK
GH_RhinoScriptInterface..::..IsEditorVisible Method
GH_RhinoScriptInterface Class Example See Also Send Feedback
Returns the visible state of the Grasshopper Main window.

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsEditorVisible()
Visual Basic
Public Function IsEditorVisible As Boolean

Return Value

True if the Main Grasshopper Window has been loaded and is visible.

Examples

CopyVBScript
Call GrasshopperExampleScript()
Sub GrasshopperExampleScript()
  Dim GH
  Set GH = Rhino.GetPlugInObject("Grasshopper")
  Call Rhino.Print("Grasshopper Editor Visible: " & GH.IsEditorVisible())
  Set GH = Nothing
End Sub

See Also

GH_RhinoScriptInterface Class
Grasshopper.Plugin Namespace


IsSolverEnabled Method

[image]

Grasshopper SDK
GH_RhinoScriptInterface..::..IsSolverEnabled Method
GH_RhinoScriptInterface Class Example See Also Send Feedback
Returns the state of the Grasshopper Solver.

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool IsSolverEnabled()
Visual Basic
Public Function IsSolverEnabled As Boolean

Return Value

True if the Grasshopper Solver is enabled.

Examples

CopyVBScript
Call GrasshopperExampleScript()
Sub GrasshopperExampleScript()
  Dim GH
  Set GH = Rhino.GetPlugInObject("Grasshopper")
  Call Rhino.Print("Grasshopper Solver Enabled: " & GH.IsSolverEnabled())
  Set GH = Nothing
End Sub

See Also

GH_RhinoScriptInterface Class
Grasshopper.Plugin Namespace


LoadEditor Method

[image]

Grasshopper SDK
GH_RhinoScriptInterface..::..LoadEditor Method
GH_RhinoScriptInterface Class Example See Also Send Feedback
Load the main Grasshopper Editor. If the editor has already been loaded nothing will happen.

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void LoadEditor()
Visual Basic
Public Sub LoadEditor

Examples

CopyVBScript
Call GrasshopperExampleScript()
Sub GrasshopperExampleScript()
  Dim GH
  Set GH = Rhino.GetPlugInObject("Grasshopper")
  Call GH.LoadEditor()
  Set GH = Nothing
End Sub

See Also

GH_RhinoScriptInterface Class
Grasshopper.Plugin Namespace


OpenDocument Method

[image]

Grasshopper SDK
GH_RhinoScriptInterface..::..OpenDocument Method
GH_RhinoScriptInterface Class Example See Also Send Feedback
Open a Grasshopper document. The editor will be loaded if necessary, but it will not be automatically shown.

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool OpenDocument(
    string filename
)
Visual Basic
Public Function OpenDocument ( _
    filename As String _
) As Boolean

Parameters

filename
Type: System..::..String
Path of file to open (must be a *.gh or *.ghx extension).

Return Value

True on success, false on failure.

Examples

CopyVBScript
Call GrasshopperExampleScript()
Sub GrasshopperExampleScript()
  Dim GH
  Set GH = Rhino.GetPlugInObject("Grasshopper")
  Call GH.OpenDocument("C:\ExampleFile.ghx")
  Set GH = Nothing
End Sub

See Also

GH_RhinoScriptInterface Class
Grasshopper.Plugin Namespace


RunSolver Method

[image]

Grasshopper SDK
GH_RhinoScriptInterface..::..RunSolver Method
GH_RhinoScriptInterface Class See Also Send Feedback
Runs the solver once, even if the global solver lock is on.

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void RunSolver(
    bool expireAllObjects
)
Visual Basic
Public Sub RunSolver ( _
    expireAllObjects As Boolean _
)

Parameters

expireAllObjects
Type: System..::..Boolean
If true, will expire all objects in the current document.

See Also

GH_RhinoScriptInterface Class
Grasshopper.Plugin Namespace


SaveDocument Method

[image]

Grasshopper SDK
GH_RhinoScriptInterface..::..SaveDocument Method
GH_RhinoScriptInterface Class Example See Also Send Feedback
Save the currently active Grasshopper document. If the active document has never been saved, a Save... dialog will be shown. If there is no active document, nothing will happen.

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool SaveDocument()
Visual Basic
Public Function SaveDocument As Boolean

Return Value

True on success, false on failure.

Examples

CopyVBScript
Call GrasshopperExampleScript()
Sub GrasshopperExampleScript()
  Dim GH
  Set GH = Rhino.GetPlugInObject("Grasshopper")
  Call GH.SaveDocument()
  Set GH = Nothing
End Sub

See Also

GH_RhinoScriptInterface Class
Grasshopper.Plugin Namespace


SaveDocumentAs Method

[image]

Grasshopper SDK
GH_RhinoScriptInterface..::..SaveDocumentAs Method
GH_RhinoScriptInterface Class Example See Also Send Feedback
Save the currently active Grasshopper document in a specific location. If there is no active document, nothing will happen.

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public bool SaveDocumentAs(
    string filename
)
Visual Basic
Public Function SaveDocumentAs ( _
    filename As String _
) As Boolean

Parameters

filename
Type: System..::..String
Path of file to save to (must be a *.gh or *ghx extension).

Return Value

True on success, false on failure.

Examples

CopyVBScript
Call GrasshopperExampleScript()
Sub GrasshopperExampleScript()
  Dim GH
  Set GH = Rhino.GetPlugInObject("Grasshopper")
  Call GH.SaveDocumentAs("C:\GrasshopperBackup\[" & Hour(Now()) & "][" & Minute(Now()) & "][" & Second(Now()) & "].ghx")
  Set GH = Nothing
End Sub

See Also

GH_RhinoScriptInterface Class
Grasshopper.Plugin Namespace


ShowEditor Method

[image]

Grasshopper SDK
GH_RhinoScriptInterface..::..ShowEditor Method
GH_RhinoScriptInterface Class Example See Also Send Feedback
Show the main Grasshopper Editor. The editor will be loaded first if needed. If the Editor is already on screen, nothing will happen.

Namespace: Grasshopper.Plugin
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
public void ShowEditor()
Visual Basic
Public Sub ShowEditor

Examples

CopyVBScript
Call GrasshopperExampleScript()
Sub GrasshopperExampleScript()
  Dim GH
  Set GH = Rhino.GetPlugInObject("Grasshopper")
  Call GH.ShowEditor()
  Set GH = Nothing
End Sub

See Also

GH_RhinoScriptInterface Class
Grasshopper.Plugin Namespace


ChildIndex Method

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..ChildIndex Method
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Find the child index that is associated with a given coordinate.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected int ChildIndex(
    double x,
    double y,
    double z
)
Visual Basic
Protected Function ChildIndex ( _
    x As Double, _
    y As Double, _
    z As Double _
) As Integer

Parameters

x
Type: System..::..Double
y
Type: System..::..Double
z
Type: System..::..Double

Return Value

Index of twig that would contain the point.

See Also

Node3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


RemoveIndexRecursive Method

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..RemoveIndexRecursive Method
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Adjust this node and all child nodes to cater for the removal of a single index. If a node contains the specified index, that item will be removed entirely.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected void RemoveIndexRecursive(
    int index
)
Visual Basic
Protected Sub RemoveIndexRecursive ( _
    index As Integer _
)

Parameters

index
Type: System..::..Int32
Index to remove.

See Also

Node3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


ChildRegion Method

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..ChildRegion Method
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Compute the region of a specific child node.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected BoundingBox ChildRegion(
    int index
)
Visual Basic
Protected Function ChildRegion ( _
    index As Integer _
) As BoundingBox

Parameters

index
Type: System..::..Int32
Index of twig to compute.

See Also

Node3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


InsertIndexRecursive Method

[image]

Grasshopper SDK
Node3d<(Of <(<'T>)>)>..::..InsertIndexRecursive Method
Node3d<(Of <(<'T>)>)> Class See Also Send Feedback
Adust this node and all child nodes for the insertion of a single index.

Namespace: Grasshopper.Kernel.Geometry.SpatialTrees
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected void InsertIndexRecursive(
    int index
)
Visual Basic
Protected Sub InsertIndexRecursive ( _
    index As Integer _
)

Parameters

index
Type: System..::..Int32
Index to insert.

See Also

Node3d<(Of <(<'T>)>)> Class
Grasshopper.Kernel.Geometry.SpatialTrees Namespace


Dispose Method

[image]

Grasshopper SDK
GH_TooltipComponent..::..Dispose Method
GH_TooltipComponent Class See Also Send Feedback
Releases the unmanaged resources used by the GH_TooltipComponent and optionally releases the managed resources

Namespace: Grasshopper.GUI
Assembly: Grasshopper (in Grasshopper.dll) Version: 1.0.0.20 (0.9.52.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

GH_TooltipComponent Class
Grasshopper.GUI Namespace